Getting started

SQL Comparison SDK: SQL Data Compare API 11

Getting started with the SQL Data Compare API

The SQL Comparison SDK provides an Application Program Interface you can use to automate SQL Data Compare. Online help and sample projects are provided to help you to use the API.

You can use the SQL Data Compare API to deploy multiple databases, or upgrade your customers' databases without manual intervention.

You can use the API if you are familiar with programming in C#, Visual Basic .NET, or any other .NET language. The engines are implemented as .NET assemblies. You can reference them from Visual Studio or the development environment of your choice.

If you'd like to access the tools without programming in .NET and you have purchased a Pro version of SQL Data Compare, you can use the command line interface.

For more information, visit www.red-gate.com, send us an e-mail at info@red-gate.com, or visit the Red Gate Software Support Forum.

Licensing the SQL Data Compare API

To use the SQL Data Compare API, you must have a SQL Comparison SDK license. If you don't have a license, you will be able to use the SDK for 14 days, but you won't be able to redistribute your applications.

The assemblies

To automate SQL Data Compare, you use the following .NET assemblies:

  • RedGate.Shared.Utils and RedGate.Shared.SQL

    These assemblies contain routines used by SQL Data Compare. It provides functions to access and execute batches of SQL statements and other helper functions.

  • RedGate.SQLCompare.Engine

    This is the engine behind SQL Compare. For the SQL Data Compare API, it is used to retrieve the database schema.

  • RedGate.SQLDataCompare.Engine

    This is the engine behind SQL Data Compare. It provides classes used for comparing and deploying the data in SQL Server databases.

  • RedGate.SQLCompare.BackupReader

    This is the engine behind SQL Compare when comparing against backups. For the SQL Data Compare API, it's used to retrieve the database schema of a database backup (SQL Server native or SQL Backup v3 or later).

Referencing the assemblies

You can access the SQL Compare and SQL Data Compare engines from C#, Visual Basic .NET, or any other .NET language. The easiest way to do this is from within the Visual Studio .NET environment. Add references in your project to RedGate.SQL.Shared.dll, RedGate.Shared.ComparisonInterfaces.dll, RedGate.SQLCompare.Engine.dll, and RedGate.SQLDataCompare.Engine.dll.

Using the API

For details of how you use the API to automate the comparison and deployment of data, see Comparing and deploying data using the API. For a detailed example, see Worked example.

Sample API projects

The SQL Data Compare API provides a number of sample API projects in C# and Visual Basic .NET. To download the sample API projects, click here.

The samples demonstrate how to:

  • deploy databases
  • receive feedback events
  • print data differences to the console
  • use a customized comparison key
  • use a WHERE clause to filter the data
  • compare BLOBs
  • load and save projects
  • compare to a backup file

See also

Distributing your applications | Frequently asked questions for the SQL Data Compare API


API Reference

SQL Comparison SDK: SQL Compare 11

Introduction to the API Reference

The SQL Data Compare API comprises the following assemblies:

  • RedGate.Shared.Utils is a library used by SQL Data Compare.
  • RedGate.SQLCompare.Engine is used by the SQL Data Compare API to retrieve the database schema.
  • RedGate.SQLDataCompare.Engine is used to automate the comparison and deployment of data.
  • RedGate.SQLCompare.BackupReader is used by the SQL Data Compare API to retrieve the database schema of a database backup (SQL Server native or SQL Backup v3 or later).
  • RedGate.SQLCompare.Engine.UIProject is used by the SQL Data Compare API to load and save SQL Data Compare Projects

This Reference provides details of the classes, enumerations, interfaces, and delegates provided by these assemblies.


RedGate.BackupReader Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.BackupReader Namespace

Classes

Class | Description
BackupCommand | Represents an SQL statement that is executed while connected to a data source, and is implemented by .NET Framework data providers that access relational databases.
BackupConnection | An implementation of IDbConnection for reading data from MS SQL Server backup files
BackupDataReader | An implementation of IDataReader for reading data from MS SQL Server backup files
BackupReaderCommandBase | Base class for BackupReader commands
BackupReaderException | An exception thrown from within the BackupReader
BackupSet | A representation of a single backup set - i.e. the result of a "BACKUP DATABASE..." statement. There may be many backup sets in one physical file, or many physical files required for one backup set (if the backup is RAIDed). BackupSet objects are serializable to allow persistence in saved projects, and do not contain references to the physical files they were originally derived from. It is the responsibility of the user to ensure that the required physical files are specified when attempting to use a BackupSet.
CollationHelper | A helper class for collation related tasks
LiveCommand | Represents an SQL statement that is executed while connected to a data source, and is implemented by .NET Framework data providers that access relational databases.
LiveConnection | An implementation of IBackupConnection for treating a live DB as a page reader
SqlVariant | A representation of the SQL_VARIANT data type.

Structures

Structure | Description
TableName | Representation of a schema-qualified table name, used when populating additional system tables.
© 2008-2014 Red Gate Software Ltd. All rights reserved.


BackupCommand Class

[image]

SQL Data Compare API 12.0.40
BackupCommand Class
Members See Also

Represents an SQL statement that is executed while connected to a data source, and is implemented by .NET Framework data providers that access relational databases.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class BackupCommand _
    Inherits BackupReaderCommandBase
C#
public sealed class BackupCommand : BackupReaderCommandBase
Visual C++
public ref class BackupCommand sealed : public BackupReaderCommandBase

Inheritance Hierarchy

Object
RedGate.BackupReader..::.BackupReaderCommandBase
RedGate.BackupReader..::.BackupCommand

See Also

BackupCommand Members
RedGate.BackupReader Namespace


BackupCommand Members

[image] [image]

SQL Data Compare API 12.0.40
BackupCommand Members
BackupCommand Class Methods Fields Properties Explicit Interface Implementations See Also

The BackupCommand type exposes the following members.

Methods

Name | Description
Cancel | Not yet implemented (Inherited from BackupReaderCommandBase.)
CreateParameter | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)
Dispose | Frees up resources associated with this object (Inherited from BackupReaderCommandBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteNonQuery | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)
ExecuteReader | Overloaded.
ExecuteScalar | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Prepare | Intentional No-op (Inherited from BackupReaderCommandBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_AllowNoIndex | (Inherited from BackupReaderCommandBase.)

Properties

Name | Description
CommandText | Gets or sets the text command to run against the data source. (Inherited from BackupReaderCommandBase.)
CommandTimeout | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)
CommandType | Indicates or specifies how the System.Data.IDbCommand.CommandText property is interpreted. In this implementation, only CommandType.Text is supported. (Inherited from BackupReaderCommandBase.)
Connection | Gets or sets the System.Data.IDbConnection used by this instance of the System.Data.IDbCommand. (Inherited from BackupReaderCommandBase.)
Parameters | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)
Transaction | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)
UpdatedRowSource | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)

Explicit Interface Implementations

Name | Description
IDbCommandConnection | (Inherited from BackupReaderCommandBase.)
IDbCommandExecuteReader | (Inherited from BackupReaderCommandBase.)

See Also

BackupCommand Class
RedGate.BackupReader Namespace


BackupConnection Class

[image]

SQL Data Compare API 12.0.40
BackupConnection Class
Members See Also

An implementation of IDbConnection for reading data from MS SQL Server backup files

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class BackupConnection _
    Implements IBackupConnection, IDbConnection, IDisposable, ICancellable,  _
    ICloneable
C#
public sealed class BackupConnection : IBackupConnection,
    IDbConnection, IDisposable, ICancellable, ICloneable
Visual C++
public ref class BackupConnection sealed : IBackupConnection,
    IDbConnection, IDisposable, ICancellable, ICloneable

Inheritance Hierarchy

Object
RedGate.BackupReader..::.BackupConnection

See Also

BackupConnection Members
RedGate.BackupReader Namespace


BackupConnection Members

[image] [image]

SQL Data Compare API 12.0.40
BackupConnection Members
BackupConnection Class Constructors Methods Properties Explicit Interface Implementations See Also

The BackupConnection type exposes the following members.

Constructors

Name | Description
BackupConnection | Overloaded.

Methods

Name | Description
BeginTransaction | Overloaded.
CancelOperation | Cancels the operation.
ChangeDatabase | Not implemented in this implementation
Clone |
Close | Closes the BackupConnection. If executed while Open() is still executing, the Open() operation should be cancelled as soon as possible.
CreateCommand | Creates a BackupCommand object for executing against the main data source
CreateSysTableCommand | Creates a command on to the queryable system table store
Dispose | Not implemented yet
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBackupSets | Gets a list of all the backup sets available in the files specified by the ConnectionString. If the ConnectionString is not valid, or has not been set, an InvalidOperationException is thrown. This call may be quite expensive, especially if the files are SQB, since all the extents need to be mapped.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsPasswordRequired | Returns whether a password is required for any of the files specified in the connection string, less any passwords that have already been specified on the connection string. That is, if the connection string specifies files f1.sqb and f2.sqb, with passwords p1 and p2, this method will return true until p1 and p2 are both set. However, if an additional file f3.sqb is also specified, with no password, this will return false if p1 and p2 are already specified.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Open | Opens the BackupConnection to the source specified in the ConnectionString. Expensive.
OpenForMetaInformation | Opens the BackupConnection to access database information from the source specified in the ConnectionString. Cheap but not suitable to retrieve actual data / structure from the database - only meta information.
PopulateAdditionalSystemTables | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UseBackupSet | Sets the backup set to be used by this connection. Must be one of the values returned from GetBackupSets(). This call may be quite expensive, especially if the files are SQB, since all the extents need to be mapped.

Properties

Name | Description
BackupTemporaryDirectory | Get the temporary backup data store directory or null if it doesn't exist
CompatibilityVersion | Returns the major version number for the current session's compatibility version
ConnectionString | AttachFilename="C:\File1";AttachFilename="C:\File2" AttachFilename=C:\File1;AttachFilename=C:\File2 AttachFilename=c:\blah\backup.sqb (SQL Backup)
ConnectionTimeout | Not implemented in this implementation
CurrentBackupSet | Returns the current active backup set
Database | Not implemented in this implementation
DatabaseGuid | Gets the Database GUID (Family GUID) for decryption in SQL Server 2K
SQLServerInternalVersionNumber | Returns the internal SQL Server version number
State | Open or Closed
Status | An event handler for providing progress feedback.
Version | Returns the major version number for the current session's server version

Explicit Interface Implementations

Name | Description
IDbConnectionCreateCommand |

See Also

BackupConnection Class
RedGate.BackupReader Namespace


BackupConnection Constructor

[image] [image]

SQL Data Compare API 12.0.40
BackupConnection Constructor
BackupConnection Class See Also

Overload List

Name | Description
BackupConnection()()() | Creates a new BackupConnection object
BackupConnection(Assembly) | Creates a new BackupConnection object

See Also

BackupConnection Class
BackupConnection Members
RedGate.BackupReader Namespace


BackupConnection Constructor

[image]

SQL Data Compare API 12.0.40
BackupConnection Constructor
BackupConnection Class See Also

Creates a new BackupConnection object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BackupConnection()
Visual C++
public:
BackupConnection()

See Also

BackupConnection Class
BackupConnection Overload
RedGate.BackupReader Namespace


BackupConnection Constructor ()

[image]

SQL Data Compare API 12.0.40
BackupConnection Constructor ()
BackupConnection Class See Also

Creates a new BackupConnection object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    asm As Assembly _
)
C#
public BackupConnection(
    Assembly asm
)
Visual C++
public:
BackupConnection(
    Assembly^ asm
)

Parameters

asm
Type: Assembly

See Also

BackupConnection Class
BackupConnection Overload
RedGate.BackupReader Namespace


BackupConnection Methods

[image] [image]

SQL Data Compare API 12.0.40
BackupConnection Methods
BackupConnection Class See Also

The BackupConnection type exposes the following methods.

Methods

Name | Description
BeginTransaction | Overloaded.
CancelOperation | Cancels the operation.
ChangeDatabase | Not implemented in this implementation
Clone |
Close | Closes the BackupConnection. If executed while Open() is still executing, the Open() operation should be cancelled as soon as possible.
CreateCommand | Creates a BackupCommand object for executing against the main data source
CreateSysTableCommand | Creates a command on to the queryable system table store
Dispose | Not implemented yet
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBackupSets | Gets a list of all the backup sets available in the files specified by the ConnectionString. If the ConnectionString is not valid, or has not been set, an InvalidOperationException is thrown. This call may be quite expensive, especially if the files are SQB, since all the extents need to be mapped.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsPasswordRequired | Returns whether a password is required for any of the files specified in the connection string, less any passwords that have already been specified on the connection string. That is, if the connection string specifies files f1.sqb and f2.sqb, with passwords p1 and p2, this method will return true until p1 and p2 are both set. However, if an additional file f3.sqb is also specified, with no password, this will return false if p1 and p2 are already specified.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Open | Opens the BackupConnection to the source specified in the ConnectionString. Expensive.
OpenForMetaInformation | Opens the BackupConnection to access database information from the source specified in the ConnectionString. Cheap but not suitable to retrieve actual data / structure from the database - only meta information.
PopulateAdditionalSystemTables | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UseBackupSet | Sets the backup set to be used by this connection. Must be one of the values returned from GetBackupSets(). This call may be quite expensive, especially if the files are SQB, since all the extents need to be mapped.

Explicit Interface Implementations

Name | Description
IDbConnectionCreateCommand |

See Also

BackupConnection Class
RedGate.BackupReader Namespace


BeginTransaction Method

[image] [image]

SQL Data Compare API 12.0.40
BackupConnection..::.BeginTransaction Method
BackupConnection Class See Also

Overload List

Name | Description
BeginTransaction()()() | Not implemented in this implementation
BeginTransaction(IsolationLevel) | Not implemented in this implementation

See Also

BackupConnection Class
BackupConnection Members
RedGate.BackupReader Namespace


BeginTransaction Method

[image]

SQL Data Compare API 12.0.40
BackupConnection..::.BeginTransaction Method
BackupConnection Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function BeginTransaction As IDbTransaction
C#
public IDbTransaction BeginTransaction()
Visual C++
public:
virtual IDbTransaction^ BeginTransaction() sealed

Return Value

Implements

IDbConnectionBeginTransaction()()()

See Also

BackupConnection Class
BeginTransaction Overload
RedGate.BackupReader Namespace


BeginTransaction Method ()

[image]

SQL Data Compare API 12.0.40
BackupConnection..::.BeginTransaction Method ()
BackupConnection Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function BeginTransaction ( _
    il As IsolationLevel _
) As IDbTransaction
C#
public IDbTransaction BeginTransaction(
    IsolationLevel il
)
Visual C++
public:
virtual IDbTransaction^ BeginTransaction(
    IsolationLevel il
) sealed

Parameters

il
Type: IsolationLevel

Return Value

Implements

IDbConnectionBeginTransaction(IsolationLevel)

See Also

BackupConnection Class
BeginTransaction Overload
RedGate.BackupReader Namespace


CancelOperation Method

[image]

SQL Data Compare API 12.0.40
BackupConnection..::.CancelOperation Method
BackupConnection Class See Also

Cancels the operation.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelOperation
C#
public void CancelOperation()
Visual C++
public:
virtual void CancelOperation() sealed

Implements

ICancellable..::.CancelOperation()()()

See Also

BackupConnection Class
RedGate.BackupReader Namespace


ChangeDatabase Method

[image]

SQL Data Compare API 12.0.40
BackupConnection..::.ChangeDatabase Method
BackupConnection Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub ChangeDatabase ( _
    databaseName As String _
)
C#
public void ChangeDatabase(
    string databaseName
)
Visual C++
public:
virtual void ChangeDatabase(
    String^ databaseName
) sealed

Parameters

databaseName
Type: String

Return Value

Implements

IDbConnectionChangeDatabase(String)

See Also

BackupConnection Class
RedGate.BackupReader Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
BackupConnection..::.Clone Method
BackupConnection Class See Also

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone As Object
C#
public Object Clone()
Visual C++
public:
virtual Object^ Clone() sealed

Implements

ICloneableClone()()()

See Also

BackupConnection Class
RedGate.BackupReader Namespace


Close Method

[image]

SQL Data Compare API 12.0.40
BackupConnection..::.Close Method
BackupConnection Class See Also

Closes the BackupConnection. If executed while Open() is still executing, the Open() operation should be cancelled as soon as possible.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub Close
C#
public void Close()
Visual C++
public:
virtual void Close() sealed

Implements

IDbConnectionClose()()()

See Also

BackupConnection Class
RedGate.BackupReader Namespace


CreateCommand Method

[image]

SQL Data Compare API 12.0.40
BackupConnection..::.CreateCommand Method
BackupConnection Class See Also

Creates a BackupCommand object for executing against the main data source

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateCommand As BackupCommand
C#
public BackupCommand CreateCommand()
Visual C++
public:
BackupCommand^ CreateCommand()

Return Value

See Also

BackupConnection Class
RedGate.BackupReader Namespace


. Method

[image]

SQL Data Compare API 12.0.40
BackupConnection..::...::. Method
BackupConnection Class See Also

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Private Function CreateCommand As IDbCommand
    Implements IDbConnection.CreateCommand
C#
IDbCommand IDbConnection.CreateCommand()
Visual C++
private:
virtual IDbCommand^ CreateCommand() sealed = IDbConnection::CreateCommand

Implements

IDbConnectionCreateCommand()()()

See Also

BackupConnection Class
RedGate.BackupReader Namespace


CreateSysTableCommand Method

[image]

SQL Data Compare API 12.0.40
BackupConnection..::.CreateSysTableCommand Method
BackupConnection Class See Also

Creates a command on to the queryable system table store

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSysTableCommand As IDbCommand
C#
public IDbCommand CreateSysTableCommand()
Visual C++
public:
virtual IDbCommand^ CreateSysTableCommand() sealed

Return Value

An instance of IDbCommand connected to the system table store

Implements

IBackupConnection..::.CreateSysTableCommand()()()

See Also

BackupConnection Class
RedGate.BackupReader Namespace


Dispose Method

[image]

SQL Data Compare API 12.0.40
BackupConnection..::.Dispose Method
BackupConnection Class See Also

Not implemented yet

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose
C#
public void Dispose()
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposableDispose()()()

See Also

BackupConnection Class
RedGate.BackupReader Namespace


GetBackupSets Method

[image]

SQL Data Compare API 12.0.40
BackupConnection..::.GetBackupSets Method
BackupConnection Class See Also

Gets a list of all the backup sets available in the files specified by the ConnectionString. If the ConnectionString is not valid, or has not been set, an InvalidOperationException is thrown. This call may be quite expensive, especially if the files are SQB, since all the extents need to be mapped.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetBackupSets As IList(Of IBackupSet)
C#
public IList<IBackupSet> GetBackupSets()
Visual C++
public:
virtual IList<IBackupSet^>^ GetBackupSets() sealed

Return Value

Implements

IBackupConnection..::.GetBackupSets()()()

See Also

BackupConnection Class
RedGate.BackupReader Namespace


IsPasswordRequired Method

[image]

SQL Data Compare API 12.0.40
BackupConnection..::.IsPasswordRequired Method
BackupConnection Class See Also

Returns whether a password is required for any of the files specified in the connection string, less any passwords that have already been specified on the connection string. That is, if the connection string specifies files f1.sqb and f2.sqb, with passwords p1 and p2, this method will return true until p1 and p2 are both set. However, if an additional file f3.sqb is also specified, with no password, this will return false if p1 and p2 are already specified.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function IsPasswordRequired As Boolean
C#
public bool IsPasswordRequired()
Visual C++
public:
virtual bool IsPasswordRequired() sealed

Return Value

True if further passwords are required, false otherwise

Implements

IBackupConnection..::.IsPasswordRequired()()()

See Also

BackupConnection Class
RedGate.BackupReader Namespace


Open Method

[image]

SQL Data Compare API 12.0.40
BackupConnection..::.Open Method
BackupConnection Class See Also

Opens the BackupConnection to the source specified in the ConnectionString. Expensive.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub Open
C#
public void Open()
Visual C++
public:
virtual void Open() sealed

Implements

IDbConnectionOpen()()()

See Also

BackupConnection Class
RedGate.BackupReader Namespace


OpenForMetaInformation Method

[image]

SQL Data Compare API 12.0.40
BackupConnection..::.OpenForMetaInformation Method
BackupConnection Class See Also

Opens the BackupConnection to access database information from the source specified in the ConnectionString. Cheap but not suitable to retrieve actual data / structure from the database - only meta information.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub OpenForMetaInformation
C#
public void OpenForMetaInformation()
Visual C++
public:
virtual void OpenForMetaInformation() sealed

Implements

IBackupConnection..::.OpenForMetaInformation()()()

See Also

BackupConnection Class
RedGate.BackupReader Namespace


PopulateAdditionalSystemTables Method

[image] [image]

SQL Data Compare API 12.0.40
BackupConnection..::.PopulateAdditionalSystemTables Method
BackupConnection Class See Also

Overload List

Name | Description
PopulateAdditionalSystemTables(array<ITableName>[]()[]) | Populates one or more system tables in addition to those already populated during the call to Open(). The BackupConnection must be in the Open state before calling this method. Progress may be given by setting the Status event handler in a similar way to the Open call. Progress will range from 0% to 100% over the course of all the tables to be populated.
PopulateAdditionalSystemTables(List<(Of <(ITableName>)>)) | Populates one or more system tables in addition to those already populated during the call to Open(). The BackupConnection must be in the Open state before calling this method. Progress may be given by setting the Status event handler in a similar way to the Open call. Progress will range from 0% to 100% over the course of all the tables to be populated.

See Also

BackupConnection Class
BackupConnection Members
RedGate.BackupReader Namespace


PopulateAdditionalSystemTables Method ([])

[image]

SQL Data Compare API 12.0.40
BackupConnection..::.PopulateAdditionalSystemTables Method (array<>[]()[])
BackupConnection Class See Also

Populates one or more system tables in addition to those already populated during the call to Open(). The BackupConnection must be in the Open state before calling this method. Progress may be given by setting the Status event handler in a similar way to the Open call. Progress will range from 0% to 100% over the course of all the tables to be populated.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub PopulateAdditionalSystemTables ( _
    ParamArray tables As ITableName() _
)
C#
public void PopulateAdditionalSystemTables(
    params ITableName[] tables
)
Visual C++
public:
virtual void PopulateAdditionalSystemTables(
    ... array<ITableName^>^ tables
) sealed

Parameters

tables
Type: array<ITableName>[]()[]
The schema-qualified name(s) of the tables to populate

Implements

IBackupConnection..::.PopulateAdditionalSystemTables(array<ITableName>[]()[])

Exceptions

Exception | Condition
ArgumentException | Throws ArgumentException if a specified table has already been populated.

See Also

BackupConnection Class
PopulateAdditionalSystemTables Overload
RedGate.BackupReader Namespace


PopulateAdditionalSystemTables Method (())

[image]

SQL Data Compare API 12.0.40
BackupConnection..::.PopulateAdditionalSystemTables Method (<(Of <(>)>))
BackupConnection Class See Also

Populates one or more system tables in addition to those already populated during the call to Open(). The BackupConnection must be in the Open state before calling this method. Progress may be given by setting the Status event handler in a similar way to the Open call. Progress will range from 0% to 100% over the course of all the tables to be populated.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub PopulateAdditionalSystemTables ( _
    tables As List(Of ITableName) _
)
C#
public void PopulateAdditionalSystemTables(
    List<ITableName> tables
)
Visual C++
public:
virtual void PopulateAdditionalSystemTables(
    List<ITableName^>^ tables
) sealed

Parameters

tables
Type: List<(Of <(ITableName>)>)
A list of the schema-qualified names of the tables to populate

Implements

IBackupConnection..::.PopulateAdditionalSystemTables(List<(Of <(ITableName>)>))

Exceptions

Exception | Condition
ArgumentException | Throws ArgumentException if a specified table has already been populated.

See Also

BackupConnection Class
PopulateAdditionalSystemTables Overload
RedGate.BackupReader Namespace


UseBackupSet Method

[image]

SQL Data Compare API 12.0.40
BackupConnection..::.UseBackupSet Method
BackupConnection Class See Also

Sets the backup set to be used by this connection. Must be one of the values returned from GetBackupSets(). This call may be quite expensive, especially if the files are SQB, since all the extents need to be mapped.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub UseBackupSet ( _
    ibackupSet As IBackupSet _
)
C#
public void UseBackupSet(
    IBackupSet ibackupSet
)
Visual C++
public:
virtual void UseBackupSet(
    IBackupSet^ ibackupSet
) sealed

Parameters

ibackupSet
Type: RedGate.Shared.SQL.BackupReaderInterfaces..::.IBackupSet
The backup set to use for this connection

Implements

IBackupConnection..::.UseBackupSet(IBackupSet)

See Also

BackupConnection Class
RedGate.BackupReader Namespace


BackupConnection Properties

[image] [image]

SQL Data Compare API 12.0.40
BackupConnection Properties
BackupConnection Class See Also

The BackupConnection type exposes the following properties.

Properties

Name | Description
BackupTemporaryDirectory | Get the temporary backup data store directory or null if it doesn't exist
CompatibilityVersion | Returns the major version number for the current session's compatibility version
ConnectionString | AttachFilename="C:\File1";AttachFilename="C:\File2" AttachFilename=C:\File1;AttachFilename=C:\File2 AttachFilename=c:\blah\backup.sqb (SQL Backup)
ConnectionTimeout | Not implemented in this implementation
CurrentBackupSet | Returns the current active backup set
Database | Not implemented in this implementation
DatabaseGuid | Gets the Database GUID (Family GUID) for decryption in SQL Server 2K
SQLServerInternalVersionNumber | Returns the internal SQL Server version number
State | Open or Closed
Status | An event handler for providing progress feedback.
Version | Returns the major version number for the current session's server version

See Also

BackupConnection Class
RedGate.BackupReader Namespace


BackupTemporaryDirectory Property

[image]

SQL Data Compare API 12.0.40
BackupConnection..::.BackupTemporaryDirectory Property
BackupConnection Class See Also

Get the temporary backup data store directory or null if it doesn't exist

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BackupTemporaryDirectory As String
C#
public string BackupTemporaryDirectory { get; }
Visual C++
public:
virtual property String^ BackupTemporaryDirectory {
    String^ get () sealed;
}

Implements

IBackupConnection..::.BackupTemporaryDirectory

See Also

BackupConnection Class
RedGate.BackupReader Namespace


CompatibilityVersion Property

[image]

SQL Data Compare API 12.0.40
BackupConnection..::.CompatibilityVersion Property
BackupConnection Class See Also

Returns the major version number for the current session's compatibility version

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CompatibilityVersion As Integer
C#
public int CompatibilityVersion { get; }
Visual C++
public:
virtual property int CompatibilityVersion {
    int get () sealed;
}

Implements

IBackupConnection..::.CompatibilityVersion

See Also

BackupConnection Class
RedGate.BackupReader Namespace


ConnectionString Property

[image]

SQL Data Compare API 12.0.40
BackupConnection..::.ConnectionString Property
BackupConnection Class See Also

AttachFilename="C:\File1";AttachFilename="C:\File2"
AttachFilename=C:\File1;AttachFilename=C:\File2
AttachFilename=c:\blah\backup.sqb (SQL Backup)

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Property ConnectionString As String
C#
public string ConnectionString { get; set; }
Visual C++
public:
virtual property String^ ConnectionString {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IDbConnectionConnectionString()()()

See Also

BackupConnection Class
RedGate.BackupReader Namespace


ConnectionTimeout Property

[image]

SQL Data Compare API 12.0.40
BackupConnection..::.ConnectionTimeout Property
BackupConnection Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConnectionTimeout As Integer
C#
public int ConnectionTimeout { get; }
Visual C++
public:
virtual property int ConnectionTimeout {
    int get () sealed;
}

Return Value

Implements

IDbConnectionConnectionTimeout()()()

See Also

BackupConnection Class
RedGate.BackupReader Namespace


CurrentBackupSet Property

[image]

SQL Data Compare API 12.0.40
BackupConnection..::.CurrentBackupSet Property
BackupConnection Class See Also

Returns the current active backup set

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentBackupSet As IBackupSet
C#
public IBackupSet CurrentBackupSet { get; }
Visual C++
public:
virtual property IBackupSet^ CurrentBackupSet {
    IBackupSet^ get () sealed;
}

Return Value

The active BackupSet

Implements

IBackupConnection..::.CurrentBackupSet

See Also

BackupConnection Class
RedGate.BackupReader Namespace


Database Property

[image]

SQL Data Compare API 12.0.40
BackupConnection..::.Database Property
BackupConnection Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Database As String
C#
public string Database { get; }
Visual C++
public:
virtual property String^ Database {
    String^ get () sealed;
}

Return Value

Implements

IDbConnectionDatabase()()()

See Also

BackupConnection Class
RedGate.BackupReader Namespace


DatabaseGuid Property

[image]

SQL Data Compare API 12.0.40
BackupConnection..::.DatabaseGuid Property
BackupConnection Class See Also

Gets the Database GUID (Family GUID) for decryption in SQL Server 2K

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DatabaseGuid As Guid
C#
public Guid DatabaseGuid { get; }
Visual C++
public:
virtual property Guid DatabaseGuid {
    Guid get () sealed;
}

Implements

IBackupConnection..::.DatabaseGuid

See Also

BackupConnection Class
RedGate.BackupReader Namespace


SQLServerInternalVersionNumber Property

[image]

SQL Data Compare API 12.0.40
BackupConnection..::.SQLServerInternalVersionNumber Property
BackupConnection Class See Also

Returns the internal SQL Server version number

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SQLServerInternalVersionNumber As Integer
C#
public int SQLServerInternalVersionNumber { get; }
Visual C++
public:
virtual property int SQLServerInternalVersionNumber {
    int get () sealed;
}

Implements

IBackupConnection..::.SQLServerInternalVersionNumber

See Also

BackupConnection Class
RedGate.BackupReader Namespace


State Property

[image]

SQL Data Compare API 12.0.40
BackupConnection..::.State Property
BackupConnection Class See Also

Open or Closed

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property State As ConnectionState
C#
public ConnectionState State { get; }
Visual C++
public:
virtual property ConnectionState State {
    ConnectionState get () sealed;
}

Implements

IDbConnectionState()()()

See Also

BackupConnection Class
RedGate.BackupReader Namespace


Status Property

[image]

SQL Data Compare API 12.0.40
BackupConnection..::.Status Property
BackupConnection Class See Also

An event handler for providing progress feedback.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

See Also

BackupConnection Class
RedGate.BackupReader Namespace


Version Property

[image]

SQL Data Compare API 12.0.40
BackupConnection..::.Version Property
BackupConnection Class See Also

Returns the major version number for the current session's server version

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As Integer
C#
public int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () sealed;
}

Implements

IBackupConnection..::.Version

See Also

BackupConnection Class
RedGate.BackupReader Namespace


BackupDataReader Class

[image]

SQL Data Compare API 12.0.40
BackupDataReader Class
Members See Also

An implementation of IDataReader for reading data from MS SQL Server backup files

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
<StrongNameIdentityPermissionAttribute(SecurityAction.LinkDemand, PublicKey := "0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")> _
Public NotInheritable Class BackupDataReader _
    Implements IDataReader, IDisposable, IDataRecord
C#
[StrongNameIdentityPermissionAttribute(SecurityAction.LinkDemand, PublicKey = "0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")]
public sealed class BackupDataReader : IDataReader,
    IDisposable, IDataRecord
Visual C++
[StrongNameIdentityPermissionAttribute(SecurityAction::LinkDemand, PublicKey = L"0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")]
public ref class BackupDataReader sealed : IDataReader,
    IDisposable, IDataRecord

Inheritance Hierarchy

Object
RedGate.BackupReader..::.BackupDataReader

See Also

BackupDataReader Members
RedGate.BackupReader Namespace


BackupDataReader Members

[image] [image]

SQL Data Compare API 12.0.40
BackupDataReader Members
BackupDataReader Class Methods Properties See Also

The BackupDataReader type exposes the following members.

Methods

Name | Description
Close | Closes the BackupReader 0bject.
CollationNameFromId | Get the string version of the collation
Dispose | Frees any resources associated with this object
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBoolean | Gets the boolean value of the specified field
GetByte | Gets the 8-bit unsigned integer value of the specified column
GetBytes | Reads a stream of bytes from the specified column offset into the buffer as an array, starting at the given buffer offset. If the target buffer is null, then the number of bytes available in the field is returned.
GetChar | Gets the character value of the specified column.
GetChars | Reads a stream of characters from the specified column offset into the buffer as an array, starting at the given buffer offset.
GetData | Not implemented
GetDataStream | Gets a stream for the field specified. The stream is not necessarily seekable, but does allow memory-efficient access to large BLOBs, as fragments are only read in as required.
GetDataTypeName | Gets the data type information for the specified field.
GetDateTime | Gets the date and time data value of the specified field.
GetDecimal | Gets the fixed-position numeric value of the specified field.
GetDouble | Gets the double-precision floating point number of the specified field.
GetFieldType | Gets the System.Type information corresponding to the type of System.Object that would be returned from System.Data.IDataRecord.GetValue(System.Int32).
GetFloat | Gets the single-precision floating point number of the specified field.
GetGuid | Returns the GUID value of the specified field.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetInt16 | Gets the 16-bit signed integer value of the specified field.
GetInt32 | Gets the 32-bit signed integer value of the specified field.
GetInt64 | Gets the 64-bit signed integer value of the specified field.
GetName | Gets the name for the field to find.
GetOrdinal | Return the index of the named field.
GetSchemaTable | Not implemented
GetSqlBinary | Returns a SqlBinary corresponding to the contents of the specified field
GetSqlBoolean | Gets the SqlBoolean value of the specified field
GetSqlByte | Gets the 8-bit unsigned integer value of the specified column
GetSqlBytes | Returns an array of bytes corresponding to the contents of the specified field
GetSqlChars | Gets a SqlChars object representing the string value of the column
GetSqlDate | Gets a string representation of the Sql Server 2008 SqlDate object
GetSqlDateTime | Gets the date and time data value of the specified field.
GetSqlDateTime2 | Gets a string representation of the Sql Server 2008 SqlDateTime2 object
GetSqlDateTimeOffset | Gets a string representation of the Sql Server 2008 SqlDateTimeOffset object
GetSqlDecimal | Gets the fixed-position numeric value of the specified field.
GetSqlDouble | Gets the double-precision floating point number of the specified field.
GetSqlGuid | Returns the GUID value of the specified field.
GetSqlInt16 | Gets the 16-bit signed integer value of the specified field.
GetSqlInt32 | Gets the 32-bit signed integer value of the specified field.
GetSqlInt64 | Gets the 64-bit signed integer value of the specified field.
GetSqlMoney | Gets the SqlMoney value of the specified field
GetSqlSingle | Gets the single-precision floating point number of the specified field.
GetSqlString | Gets the string value of the specified field. This also works for XML fields (SQL 2005), where the original XML string is returned.
GetSqlTime | Gets a string representation of the Sql Server 2008 SqlTime object
GetSqlVariant | Gets the SqlVariant value of the specified field
GetSqlXml | Gets the XML value of the specified field. Note: MSXML doesn't preserve newlines correctly - the original XML uses LF as newline, but the result of SqlXml.Value uses CRLF instead. This causes SQL Data Compare to consider them different, and hence this method should not be used where this is important.
GetString | Gets the string value of the specified field.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Return the value of the specified field.
GetValues | Gets all the attribute fields in the collection for the current record.
IsDBNull | Return whether the specified field is set to null.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextResult | Not implemented
Read | Advances the BackupReader to the next record.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Depth | Gets a value indicating the depth of nesting for the current row.
FieldCount | Gets the number of fields in each row
IsClosed | Gets a value indicating whether the data reader is closed.
Item | Overloaded.
RecordsAffected | Not implemented

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


BackupDataReader Methods

[image] [image]

SQL Data Compare API 12.0.40
BackupDataReader Methods
BackupDataReader Class See Also

The BackupDataReader type exposes the following methods.

Methods

Name | Description
Close | Closes the BackupReader 0bject.
CollationNameFromId | Get the string version of the collation
Dispose | Frees any resources associated with this object
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBoolean | Gets the boolean value of the specified field
GetByte | Gets the 8-bit unsigned integer value of the specified column
GetBytes | Reads a stream of bytes from the specified column offset into the buffer as an array, starting at the given buffer offset. If the target buffer is null, then the number of bytes available in the field is returned.
GetChar | Gets the character value of the specified column.
GetChars | Reads a stream of characters from the specified column offset into the buffer as an array, starting at the given buffer offset.
GetData | Not implemented
GetDataStream | Gets a stream for the field specified. The stream is not necessarily seekable, but does allow memory-efficient access to large BLOBs, as fragments are only read in as required.
GetDataTypeName | Gets the data type information for the specified field.
GetDateTime | Gets the date and time data value of the specified field.
GetDecimal | Gets the fixed-position numeric value of the specified field.
GetDouble | Gets the double-precision floating point number of the specified field.
GetFieldType | Gets the System.Type information corresponding to the type of System.Object that would be returned from System.Data.IDataRecord.GetValue(System.Int32).
GetFloat | Gets the single-precision floating point number of the specified field.
GetGuid | Returns the GUID value of the specified field.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetInt16 | Gets the 16-bit signed integer value of the specified field.
GetInt32 | Gets the 32-bit signed integer value of the specified field.
GetInt64 | Gets the 64-bit signed integer value of the specified field.
GetName | Gets the name for the field to find.
GetOrdinal | Return the index of the named field.
GetSchemaTable | Not implemented
GetSqlBinary | Returns a SqlBinary corresponding to the contents of the specified field
GetSqlBoolean | Gets the SqlBoolean value of the specified field
GetSqlByte | Gets the 8-bit unsigned integer value of the specified column
GetSqlBytes | Returns an array of bytes corresponding to the contents of the specified field
GetSqlChars | Gets a SqlChars object representing the string value of the column
GetSqlDate | Gets a string representation of the Sql Server 2008 SqlDate object
GetSqlDateTime | Gets the date and time data value of the specified field.
GetSqlDateTime2 | Gets a string representation of the Sql Server 2008 SqlDateTime2 object
GetSqlDateTimeOffset | Gets a string representation of the Sql Server 2008 SqlDateTimeOffset object
GetSqlDecimal | Gets the fixed-position numeric value of the specified field.
GetSqlDouble | Gets the double-precision floating point number of the specified field.
GetSqlGuid | Returns the GUID value of the specified field.
GetSqlInt16 | Gets the 16-bit signed integer value of the specified field.
GetSqlInt32 | Gets the 32-bit signed integer value of the specified field.
GetSqlInt64 | Gets the 64-bit signed integer value of the specified field.
GetSqlMoney | Gets the SqlMoney value of the specified field
GetSqlSingle | Gets the single-precision floating point number of the specified field.
GetSqlString | Gets the string value of the specified field. This also works for XML fields (SQL 2005), where the original XML string is returned.
GetSqlTime | Gets a string representation of the Sql Server 2008 SqlTime object
GetSqlVariant | Gets the SqlVariant value of the specified field
GetSqlXml | Gets the XML value of the specified field. Note: MSXML doesn't preserve newlines correctly - the original XML uses LF as newline, but the result of SqlXml.Value uses CRLF instead. This causes SQL Data Compare to consider them different, and hence this method should not be used where this is important.
GetString | Gets the string value of the specified field.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Return the value of the specified field.
GetValues | Gets all the attribute fields in the collection for the current record.
IsDBNull | Return whether the specified field is set to null.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextResult | Not implemented
Read | Advances the BackupReader to the next record.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


Close Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.Close Method
BackupDataReader Class See Also

Closes the BackupReader 0bject.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub Close
C#
public void Close()
Visual C++
public:
virtual void Close() sealed

Implements

IDataReaderClose()()()

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


CollationNameFromId Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.CollationNameFromId Method
BackupDataReader Class See Also

Get the string version of the collation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function CollationNameFromId ( _
    id As Integer _
) As String
C#
public string CollationNameFromId(
    int id
)
Visual C++
public:
virtual String^ CollationNameFromId(
    int id
) sealed

Parameters

id
Type: Int32
collation id

Return Value

collation

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


Dispose Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.Dispose Method
BackupDataReader Class See Also

Frees any resources associated with this object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose
C#
public void Dispose()
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposableDispose()()()

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetBoolean Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetBoolean Method
BackupDataReader Class See Also

Gets the boolean value of the specified field

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetBoolean ( _
    i As Integer _
) As Boolean
C#
public bool GetBoolean(
    int i
)
Visual C++
public:
virtual bool GetBoolean(
    int i
) sealed

Parameters

i
Type: Int32
The zero-based column ordinal

Return Value

The value of the column

Implements

IDataRecordGetBoolean(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetByte Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetByte Method
BackupDataReader Class See Also

Gets the 8-bit unsigned integer value of the specified column

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetByte ( _
    i As Integer _
) As Byte
C#
public byte GetByte(
    int i
)
Visual C++
public:
virtual unsigned char GetByte(
    int i
) sealed

Parameters

i
Type: Int32
The zero-based column ordinal

Return Value

The 8-bit unsigned integer value of the specified column

Implements

IDataRecordGetByte(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetBytes Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetBytes Method
BackupDataReader Class See Also

Reads a stream of bytes from the specified column offset into the buffer as an array, starting at the given buffer offset. If the target buffer is null, then the number of bytes available in the field is returned.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetBytes ( _
    i As Integer, _
    fieldOffset As Long, _
    buffer As Byte(), _
    bufferoffset As Integer, _
    length As Integer _
) As Long
C#
public long GetBytes(
    int i,
    long fieldOffset,
    byte[] buffer,
    int bufferoffset,
    int length
)
Visual C++
public:
virtual long long GetBytes(
    int i,
    long long fieldOffset,
    array<unsigned char>^ buffer,
    int bufferoffset,
    int length
) sealed

Parameters

i
Type: Int32
The zero-based column ordinal.
fieldOffset
Type: Int64
The index within the field from which to start the read operation.
buffer
Type: array<Byte>[]()[]
The buffer into which to read the stream of bytes.
bufferoffset
Type: Int32
The index for buffer to start the read operation.
length
Type: Int32
The number of bytes to read.

Return Value

The actual number of bytes read.

Implements

IDataRecordGetBytes(Int32, Int64, array<Byte>[]()[], Int32, Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetChar Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetChar Method
BackupDataReader Class See Also

Gets the character value of the specified column.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetChar ( _
    i As Integer _
) As Char
C#
public char GetChar(
    int i
)
Visual C++
public:
virtual wchar_t GetChar(
    int i
) sealed

Parameters

i
Type: Int32
The zero-based column ordinal.

Return Value

The character value of the specified column.

Implements

IDataRecordGetChar(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetChars Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetChars Method
BackupDataReader Class See Also

Reads a stream of characters from the specified column offset into the buffer as an array, starting at the given buffer offset.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetChars ( _
    i As Integer, _
    fieldOffset As Long, _
    buffer As Char(), _
    bufferoffset As Integer, _
    length As Integer _
) As Long
C#
public long GetChars(
    int i,
    long fieldOffset,
    char[] buffer,
    int bufferoffset,
    int length
)
Visual C++
public:
virtual long long GetChars(
    int i,
    long long fieldOffset,
    array<wchar_t>^ buffer,
    int bufferoffset,
    int length
) sealed

Parameters

i
Type: Int32
The zero-based column ordinal.
fieldOffset
Type: Int64
The index within the row from which to start the read operation.
buffer
Type: array<Char>[]()[]
The buffer into which to read the stream of bytes.
bufferoffset
Type: Int32
The index for buffer to start the read operation.
length
Type: Int32
The number of bytes to read.

Return Value

The actual number of characters read.

Implements

IDataRecordGetChars(Int32, Int64, array<Char>[]()[], Int32, Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetData Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetData Method
BackupDataReader Class See Also

Not implemented

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetData ( _
    i As Integer _
) As IDataReader
C#
public IDataReader GetData(
    int i
)
Visual C++
public:
virtual IDataReader^ GetData(
    int i
) sealed

Parameters

i
Type: Int32

Return Value

Implements

IDataRecordGetData(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetDataStream Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetDataStream Method
BackupDataReader Class See Also

Gets a stream for the field specified. The stream is not necessarily seekable, but does allow memory-efficient access to large BLOBs, as fragments are only read in as required.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDataStream ( _
    i As Integer _
) As Stream
C#
public Stream GetDataStream(
    int i
)
Visual C++
public:
virtual Stream^ GetDataStream(
    int i
) sealed

Parameters

i
Type: Int32
Zero-based index of the field

Return Value

A Stream corresponding to the raw data of the field requested, or null.

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetDataTypeName Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetDataTypeName Method
BackupDataReader Class See Also

Gets the data type information for the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDataTypeName ( _
    i As Integer _
) As String
C#
public string GetDataTypeName(
    int i
)
Visual C++
public:
virtual String^ GetDataTypeName(
    int i
) sealed

Parameters

i
Type: Int32
The index of the field to find.

Return Value

The data type information for the specified field.

Implements

IDataRecordGetDataTypeName(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetDateTime Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetDateTime Method
BackupDataReader Class See Also

Gets the date and time data value of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDateTime ( _
    i As Integer _
) As DateTime
C#
public DateTime GetDateTime(
    int i
)
Visual C++
public:
virtual DateTime GetDateTime(
    int i
) sealed

Parameters

i
Type: Int32
The index of the field to find.

Return Value

The date and time data value of the spcified field.

Implements

IDataRecordGetDateTime(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetDecimal Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetDecimal Method
BackupDataReader Class See Also

Gets the fixed-position numeric value of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDecimal ( _
    i As Integer _
) As Decimal
C#
public decimal GetDecimal(
    int i
)
Visual C++
public:
virtual Decimal GetDecimal(
    int i
) sealed

Parameters

i
Type: Int32
The index of the field to find.

Return Value

The fixed-position numeric value of the specified field.

Implements

IDataRecordGetDecimal(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetDouble Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetDouble Method
BackupDataReader Class See Also

Gets the double-precision floating point number of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDouble ( _
    i As Integer _
) As Double
C#
public double GetDouble(
    int i
)
Visual C++
public:
virtual double GetDouble(
    int i
) sealed

Parameters

i
Type: Int32
The index of the field to find.

Return Value

The double-precision floating point number of the specified field.

Implements

IDataRecordGetDouble(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetFieldType Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetFieldType Method
BackupDataReader Class See Also

Gets the System.Type information corresponding to the type of System.Object that would be returned from System.Data.IDataRecord.GetValue(System.Int32).

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetFieldType ( _
    i As Integer _
) As Type
C#
public Type GetFieldType(
    int i
)
Visual C++
public:
virtual Type^ GetFieldType(
    int i
) sealed

Parameters

i
Type: Int32
The index of the field to find.

Return Value

The System.Type information corresponding to the type of System.Object that would be returned from System.Data.IDataRecord.GetValue(System.Int32).

Implements

IDataRecordGetFieldType(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetFloat Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetFloat Method
BackupDataReader Class See Also

Gets the single-precision floating point number of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetFloat ( _
    i As Integer _
) As Single
C#
public float GetFloat(
    int i
)
Visual C++
public:
virtual float GetFloat(
    int i
) sealed

Parameters

i
Type: Int32
The index of the field to find.

Return Value

The single-precision floating point number of the specified field.

Implements

IDataRecordGetFloat(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetGuid Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetGuid Method
BackupDataReader Class See Also

Returns the GUID value of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetGuid ( _
    i As Integer _
) As Guid
C#
public Guid GetGuid(
    int i
)
Visual C++
public:
virtual Guid GetGuid(
    int i
) sealed

Parameters

i
Type: Int32
The index of the field to find.

Return Value

The GUID value of the specified field.

Implements

IDataRecordGetGuid(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetInt16 Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetInt16 Method
BackupDataReader Class See Also

Gets the 16-bit signed integer value of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetInt16 ( _
    i As Integer _
) As Short
C#
public short GetInt16(
    int i
)
Visual C++
public:
virtual short GetInt16(
    int i
) sealed

Parameters

i
Type: Int32
The index of the field to find.

Return Value

The 16-bit signed integer value of the specified field.

Implements

IDataRecordGetInt16(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetInt32 Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetInt32 Method
BackupDataReader Class See Also

Gets the 32-bit signed integer value of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetInt32 ( _
    i As Integer _
) As Integer
C#
public int GetInt32(
    int i
)
Visual C++
public:
virtual int GetInt32(
    int i
) sealed

Parameters

i
Type: Int32
The index of the field to find.

Return Value

The 32-bit signed integer value of the specified field.

Implements

IDataRecordGetInt32(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetInt64 Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetInt64 Method
BackupDataReader Class See Also

Gets the 64-bit signed integer value of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetInt64 ( _
    i As Integer _
) As Long
C#
public long GetInt64(
    int i
)
Visual C++
public:
virtual long long GetInt64(
    int i
) sealed

Parameters

i
Type: Int32
The index of the field to find.

Return Value

The 64-bit signed integer value of the specified field.

Implements

IDataRecordGetInt64(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetName Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetName Method
BackupDataReader Class See Also

Gets the name for the field to find.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetName ( _
    i As Integer _
) As String
C#
public string GetName(
    int i
)
Visual C++
public:
virtual String^ GetName(
    int i
) sealed

Parameters

i
Type: Int32
The index of the field to find.

Return Value

The name of the field or the empty string (""), if there is no value to return.

Implements

IDataRecordGetName(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetOrdinal Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetOrdinal Method
BackupDataReader Class See Also

Return the index of the named field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetOrdinal ( _
    name As String _
) As Integer
C#
public int GetOrdinal(
    string name
)
Visual C++
public:
virtual int GetOrdinal(
    String^ name
) sealed

Parameters

name
Type: String
The name of the field to find.

Return Value

The index of the named field.

Implements

IDataRecordGetOrdinal(String)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSchemaTable Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetSchemaTable Method
BackupDataReader Class See Also

Not implemented

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSchemaTable As DataTable
C#
public DataTable GetSchemaTable()
Visual C++
public:
virtual DataTable^ GetSchemaTable() sealed

Return Value

Implements

IDataReaderGetSchemaTable()()()

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlBinary Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetSqlBinary Method
BackupDataReader Class See Also

Returns a SqlBinary corresponding to the contents of the specified field

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlBinary ( _
    i As Integer _
) As SqlBinary
C#
public SqlBinary GetSqlBinary(
    int i
)
Visual C++
public:
virtual SqlBinary GetSqlBinary(
    int i
) sealed

Parameters

i
Type: Int32
The zero-based column ordinal

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlBoolean Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetSqlBoolean Method
BackupDataReader Class See Also

Gets the SqlBoolean value of the specified field

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlBoolean ( _
    i As Integer _
) As SqlBoolean
C#
public SqlBoolean GetSqlBoolean(
    int i
)
Visual C++
public:
virtual SqlBoolean GetSqlBoolean(
    int i
) sealed

Parameters

i
Type: Int32
The zero-based column ordinal

Return Value

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlByte Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetSqlByte Method
BackupDataReader Class See Also

Gets the 8-bit unsigned integer value of the specified column

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlByte ( _
    i As Integer _
) As SqlByte
C#
public SqlByte GetSqlByte(
    int i
)
Visual C++
public:
virtual SqlByte GetSqlByte(
    int i
) sealed

Parameters

i
Type: Int32
The zero-based column ordinal

Return Value

The 8-bit unsigned integer value of the specified column

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlBytes Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetSqlBytes Method
BackupDataReader Class See Also

Returns an array of bytes corresponding to the contents of the specified field

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlBytes ( _
    i As Integer _
) As SqlBytes
C#
public SqlBytes GetSqlBytes(
    int i
)
Visual C++
public:
virtual SqlBytes^ GetSqlBytes(
    int i
) sealed

Parameters

i
Type: Int32
The zero-based column ordinal

Return Value

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlChars Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetSqlChars Method
BackupDataReader Class See Also

Gets a SqlChars object representing the string value of the column

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlChars ( _
    i As Integer _
) As SqlChars
C#
public SqlChars GetSqlChars(
    int i
)
Visual C++
public:
virtual SqlChars^ GetSqlChars(
    int i
) sealed

Parameters

i
Type: Int32
Zero-based column ordinal

Return Value

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlDate Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetSqlDate Method
BackupDataReader Class See Also

Gets a string representation of the Sql Server 2008 SqlDate object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlDate ( _
    i As Integer _
) As String
C#
public string GetSqlDate(
    int i
)
Visual C++
public:
virtual String^ GetSqlDate(
    int i
) sealed

Parameters

i
Type: Int32
Zero-based index of the field

Return Value

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlDateTime Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetSqlDateTime Method
BackupDataReader Class See Also

Gets the date and time data value of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlDateTime ( _
    i As Integer _
) As SqlDateTime
C#
public SqlDateTime GetSqlDateTime(
    int i
)
Visual C++
public:
virtual SqlDateTime GetSqlDateTime(
    int i
) sealed

Parameters

i
Type: Int32
The index of the field to find.

Return Value

The date and time data value of the spcified field.

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlDateTime2 Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetSqlDateTime2 Method
BackupDataReader Class See Also

Gets a string representation of the Sql Server 2008 SqlDateTime2 object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlDateTime2 ( _
    i As Integer _
) As String
C#
public string GetSqlDateTime2(
    int i
)
Visual C++
public:
virtual String^ GetSqlDateTime2(
    int i
) sealed

Parameters

i
Type: Int32
Zero-based index of the field

Return Value

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlDateTimeOffset Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetSqlDateTimeOffset Method
BackupDataReader Class See Also

Gets a string representation of the Sql Server 2008 SqlDateTimeOffset object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlDateTimeOffset ( _
    i As Integer _
) As String
C#
public string GetSqlDateTimeOffset(
    int i
)
Visual C++
public:
virtual String^ GetSqlDateTimeOffset(
    int i
) sealed

Parameters

i
Type: Int32
Zero-based index of the field

Return Value

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlDecimal Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetSqlDecimal Method
BackupDataReader Class See Also

Gets the fixed-position numeric value of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlDecimal ( _
    i As Integer _
) As SqlDecimal
C#
public SqlDecimal GetSqlDecimal(
    int i
)
Visual C++
public:
virtual SqlDecimal GetSqlDecimal(
    int i
) sealed

Parameters

i
Type: Int32
The index of the field to find.

Return Value

The fixed-position numeric value of the specified field.

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlDouble Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetSqlDouble Method
BackupDataReader Class See Also

Gets the double-precision floating point number of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlDouble ( _
    i As Integer _
) As SqlDouble
C#
public SqlDouble GetSqlDouble(
    int i
)
Visual C++
public:
virtual SqlDouble GetSqlDouble(
    int i
) sealed

Parameters

i
Type: Int32
The index of the field to find.

Return Value

The double-precision floating point number of the specified field.

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlGuid Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetSqlGuid Method
BackupDataReader Class See Also

Returns the GUID value of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlGuid ( _
    i As Integer _
) As SqlGuid
C#
public SqlGuid GetSqlGuid(
    int i
)
Visual C++
public:
virtual SqlGuid GetSqlGuid(
    int i
) sealed

Parameters

i
Type: Int32
The index of the field to find.

Return Value

The GUID value of the specified field.

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlInt16 Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetSqlInt16 Method
BackupDataReader Class See Also

Gets the 16-bit signed integer value of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlInt16 ( _
    i As Integer _
) As SqlInt16
C#
public SqlInt16 GetSqlInt16(
    int i
)
Visual C++
public:
virtual SqlInt16 GetSqlInt16(
    int i
) sealed

Parameters

i
Type: Int32
The index of the field to find.

Return Value

The 16-bit signed integer value of the specified field.

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlInt32 Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetSqlInt32 Method
BackupDataReader Class See Also

Gets the 32-bit signed integer value of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlInt32 ( _
    i As Integer _
) As SqlInt32
C#
public SqlInt32 GetSqlInt32(
    int i
)
Visual C++
public:
virtual SqlInt32 GetSqlInt32(
    int i
) sealed

Parameters

i
Type: Int32
The index of the field to find.

Return Value

The 32-bit signed integer value of the specified field.

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlInt64 Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetSqlInt64 Method
BackupDataReader Class See Also

Gets the 64-bit signed integer value of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlInt64 ( _
    i As Integer _
) As SqlInt64
C#
public SqlInt64 GetSqlInt64(
    int i
)
Visual C++
public:
virtual SqlInt64 GetSqlInt64(
    int i
) sealed

Parameters

i
Type: Int32
The index of the field to find.

Return Value

The 64-bit signed integer value of the specified field.

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlMoney Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetSqlMoney Method
BackupDataReader Class See Also

Gets the SqlMoney value of the specified field

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlMoney ( _
    i As Integer _
) As SqlMoney
C#
public SqlMoney GetSqlMoney(
    int i
)
Visual C++
public:
virtual SqlMoney GetSqlMoney(
    int i
) sealed

Parameters

i
Type: Int32
The zero-based index of the field to get

Return Value

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlSingle Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetSqlSingle Method
BackupDataReader Class See Also

Gets the single-precision floating point number of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlSingle ( _
    i As Integer _
) As SqlSingle
C#
public SqlSingle GetSqlSingle(
    int i
)
Visual C++
public:
virtual SqlSingle GetSqlSingle(
    int i
) sealed

Parameters

i
Type: Int32
The index of the field to find.

Return Value

The single-precision floating point number of the specified field.

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlString Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetSqlString Method
BackupDataReader Class See Also

Gets the string value of the specified field. This also works for XML fields (SQL 2005), where the original XML string is returned.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlString ( _
    i As Integer _
) As SqlString
C#
public SqlString GetSqlString(
    int i
)
Visual C++
public:
virtual SqlString GetSqlString(
    int i
) sealed

Parameters

i
Type: Int32
The index of the field to find.

Return Value

The string value of the specified field.

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlTime Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetSqlTime Method
BackupDataReader Class See Also

Gets a string representation of the Sql Server 2008 SqlTime object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlTime ( _
    i As Integer _
) As String
C#
public string GetSqlTime(
    int i
)
Visual C++
public:
virtual String^ GetSqlTime(
    int i
) sealed

Parameters

i
Type: Int32
Zero-based index of the field

Return Value

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlVariant Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetSqlVariant Method
BackupDataReader Class See Also

Gets the SqlVariant value of the specified field

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlVariant ( _
    i As Integer _
) As ISqlVariant
C#
public ISqlVariant GetSqlVariant(
    int i
)
Visual C++
public:
virtual ISqlVariant^ GetSqlVariant(
    int i
) sealed

Parameters

i
Type: Int32
Zero-based index of the field

Return Value

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlXml Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetSqlXml Method
BackupDataReader Class See Also

Gets the XML value of the specified field. Note: MSXML doesn't preserve newlines correctly - the original XML uses LF as newline, but the result of SqlXml.Value uses CRLF instead. This causes SQL Data Compare to consider them different, and hence this method should not be used where this is important.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlXml ( _
    i As Integer _
) As SqlXml
C#
public SqlXml GetSqlXml(
    int i
)
Visual C++
public:
virtual SqlXml^ GetSqlXml(
    int i
) sealed

Parameters

i
Type: Int32
Zero-based index of the field

Return Value

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetString Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetString Method
BackupDataReader Class See Also

Gets the string value of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetString ( _
    i As Integer _
) As String
C#
public string GetString(
    int i
)
Visual C++
public:
virtual String^ GetString(
    int i
) sealed

Parameters

i
Type: Int32
The index of the field to find.

Return Value

The string value of the specified field.

Implements

IDataRecordGetString(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetValue Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetValue Method
BackupDataReader Class See Also

Return the value of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValue ( _
    i As Integer _
) As Object
C#
public Object GetValue(
    int i
)
Visual C++
public:
virtual Object^ GetValue(
    int i
) sealed

Parameters

i
Type: Int32
The index of the field to find.

Return Value

The System.Object which will contain the field value upon return.

Implements

IDataRecordGetValue(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetValues Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.GetValues Method
BackupDataReader Class See Also

Gets all the attribute fields in the collection for the current record.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValues ( _
    values As Object() _
) As Integer
C#
public int GetValues(
    Object[] values
)
Visual C++
public:
virtual int GetValues(
    array<Object^>^ values
) sealed

Parameters

values
Type: array<Object>[]()[]
An array of System.Object to copy the attribute fields into.

Return Value

The number of instances of System.Object in the array.

Implements

IDataRecordGetValues(array<Object>[]()[])

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


IsDBNull Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.IsDBNull Method
BackupDataReader Class See Also

Return whether the specified field is set to null.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function IsDBNull ( _
    i As Integer _
) As Boolean
C#
public bool IsDBNull(
    int i
)
Visual C++
public:
virtual bool IsDBNull(
    int i
) sealed

Parameters

i
Type: Int32
The index of the field to find.

Return Value

true if the specified field is set to null. Otherwise, false.

Implements

IDataRecordIsDBNull(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


NextResult Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.NextResult Method
BackupDataReader Class See Also

Not implemented

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function NextResult As Boolean
C#
public bool NextResult()
Visual C++
public:
virtual bool NextResult() sealed

Return Value

Implements

IDataReaderNextResult()()()

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


Read Method

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.Read Method
BackupDataReader Class See Also

Advances the BackupReader to the next record.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function Read As Boolean
C#
public bool Read()
Visual C++
public:
virtual bool Read() sealed

Return Value

true if there are more rows; otherwise, false.

Implements

IDataReaderRead()()()

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


BackupDataReader Properties

[image] [image]

SQL Data Compare API 12.0.40
BackupDataReader Properties
BackupDataReader Class See Also

The BackupDataReader type exposes the following properties.

Properties

Name | Description
Depth | Gets a value indicating the depth of nesting for the current row.
FieldCount | Gets the number of fields in each row
IsClosed | Gets a value indicating whether the data reader is closed.
Item | Overloaded.
RecordsAffected | Not implemented

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


Depth Property

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.Depth Property
BackupDataReader Class See Also

Gets a value indicating the depth of nesting for the current row.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Depth As Integer
C#
public int Depth { get; }
Visual C++
public:
virtual property int Depth {
    int get () sealed;
}

Implements

IDataReaderDepth()()()

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


FieldCount Property

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.FieldCount Property
BackupDataReader Class See Also

Gets the number of fields in each row

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FieldCount As Integer
C#
public int FieldCount { get; }
Visual C++
public:
virtual property int FieldCount {
    int get () sealed;
}

Implements

IDataRecordFieldCount()()()

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


IsClosed Property

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.IsClosed Property
BackupDataReader Class See Also

Gets a value indicating whether the data reader is closed.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsClosed As Boolean
C#
public bool IsClosed { get; }
Visual C++
public:
virtual property bool IsClosed {
    bool get () sealed;
}

Implements

IDataReaderIsClosed()()()

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
BackupDataReader..::.Item Property
BackupDataReader Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Gets the column located at the specified index.
Item[([(String])]) | Gets the column with the specified name.

See Also

BackupDataReader Class
BackupDataReader Members
RedGate.BackupReader Namespace


Item Property ()

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.Item Property ()
BackupDataReader Class See Also

Gets the column located at the specified index.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    i As Integer _
) As Object
C#
public Object this[
    int i
] { get; }
Visual C++
public:
virtual property Object^ default[int i] {
    Object^ get (int i) sealed;
}

Parameters

i
Type: Int32
The index of the column to get.

Return Value

The column located at the specified index as an System.Object.

Implements

IDataRecordItem(Int32)

See Also

BackupDataReader Class
Item Overload
RedGate.BackupReader Namespace


Item Property ()

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.Item Property ()
BackupDataReader Class See Also

Gets the column with the specified name.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As Object
C#
public Object this[
    string name
] { get; }
Visual C++
public:
virtual property Object^ default[String^ name] {
    Object^ get (String^ name) sealed;
}

Parameters

name
Type: String
The name of the column to find.

Return Value

The column with the specified name as an System.Object.

Implements

IDataRecordItem(String)

See Also

BackupDataReader Class
Item Overload
RedGate.BackupReader Namespace


RecordsAffected Property

[image]

SQL Data Compare API 12.0.40
BackupDataReader..::.RecordsAffected Property
BackupDataReader Class See Also

Not implemented

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RecordsAffected As Integer
C#
public int RecordsAffected { get; }
Visual C++
public:
virtual property int RecordsAffected {
    int get () sealed;
}

Implements

IDataReaderRecordsAffected()()()

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


BackupReaderCommandBase Class

[image]

SQL Data Compare API 12.0.40
BackupReaderCommandBase Class
Members See Also

Base class for BackupReader commands

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class BackupReaderCommandBase _
    Implements IDbCommand, IDisposable
C#
public abstract class BackupReaderCommandBase : IDbCommand,
    IDisposable
Visual C++
public ref class BackupReaderCommandBase abstract : IDbCommand,
    IDisposable

Inheritance Hierarchy

Object
RedGate.BackupReader..::.BackupReaderCommandBase
RedGate.BackupReader..::.BackupCommand
RedGate.BackupReader..::.LiveCommand

See Also

BackupReaderCommandBase Members
RedGate.BackupReader Namespace


BackupReaderCommandBase Members

[image] [image]

SQL Data Compare API 12.0.40
BackupReaderCommandBase Members
BackupReaderCommandBase Class Constructors Methods Fields Properties Explicit Interface Implementations See Also

The BackupReaderCommandBase type exposes the following members.

Constructors

Name | Description
BackupReaderCommandBase |

Methods

Name | Description
Cancel | Not yet implemented
CreateParameter | Not implemented in this implementation
Dispose | Frees up resources associated with this object
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteNonQuery | Not implemented in this implementation
ExecuteReader | Overloaded.
ExecuteScalar | Not implemented in this implementation
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Prepare | Intentional No-op
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_AllowNoIndex |

Properties

Name | Description
CommandText | Gets or sets the text command to run against the data source.
CommandTimeout | Not implemented in this implementation
CommandType | Indicates or specifies how the System.Data.IDbCommand.CommandText property is interpreted. In this implementation, only CommandType.Text is supported.
Connection | Gets or sets the System.Data.IDbConnection used by this instance of the System.Data.IDbCommand.
Parameters | Not implemented in this implementation
Transaction | Not implemented in this implementation
UpdatedRowSource | Not implemented in this implementation

Explicit Interface Implementations

Name | Description
IDbCommandConnection |
IDbCommandExecuteReader |

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


BackupReaderCommandBase Constructor

[image]

SQL Data Compare API 12.0.40
BackupReaderCommandBase Constructor
BackupReaderCommandBase Class See Also

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    allowNoIndex As Boolean _
)
C#
protected BackupReaderCommandBase(
    bool allowNoIndex
)
Visual C++
protected:
BackupReaderCommandBase(
    bool allowNoIndex
)

Parameters

allowNoIndex
Type: Boolean

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


BackupReaderCommandBase Fields

[image] [image]

SQL Data Compare API 12.0.40
BackupReaderCommandBase Fields
BackupReaderCommandBase Class See Also

The BackupReaderCommandBase type exposes the following fields.

Fields

Name | Description
m_AllowNoIndex |

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


m_AllowNoIndex Field

[image]

SQL Data Compare API 12.0.40
BackupReaderCommandBase..::.m_AllowNoIndex Field
BackupReaderCommandBase Class See Also

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Protected m_AllowNoIndex As Boolean
C#
protected bool m_AllowNoIndex
Visual C++
protected:
bool m_AllowNoIndex

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


BackupReaderCommandBase Methods

[image] [image]

SQL Data Compare API 12.0.40
BackupReaderCommandBase Methods
BackupReaderCommandBase Class See Also

The BackupReaderCommandBase type exposes the following methods.

Methods

Name | Description
Cancel | Not yet implemented
CreateParameter | Not implemented in this implementation
Dispose | Frees up resources associated with this object
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteNonQuery | Not implemented in this implementation
ExecuteReader | Overloaded.
ExecuteScalar | Not implemented in this implementation
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Prepare | Intentional No-op
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IDbCommandExecuteReader |

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


Cancel Method

[image]

SQL Data Compare API 12.0.40
BackupReaderCommandBase..::.Cancel Method
BackupReaderCommandBase Class See Also

Not yet implemented

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub Cancel
C#
public void Cancel()
Visual C++
public:
virtual void Cancel() sealed

Implements

IDbCommandCancel()()()

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


CreateParameter Method

[image]

SQL Data Compare API 12.0.40
BackupReaderCommandBase..::.CreateParameter Method
BackupReaderCommandBase Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateParameter As IDbDataParameter
C#
public IDbDataParameter CreateParameter()
Visual C++
public:
virtual IDbDataParameter^ CreateParameter() sealed

Return Value

Implements

IDbCommandCreateParameter()()()

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


Dispose Method

[image]

SQL Data Compare API 12.0.40
BackupReaderCommandBase..::.Dispose Method
BackupReaderCommandBase Class See Also

Frees up resources associated with this object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose
C#
public void Dispose()
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposableDispose()()()

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


ExecuteNonQuery Method

[image]

SQL Data Compare API 12.0.40
BackupReaderCommandBase..::.ExecuteNonQuery Method
BackupReaderCommandBase Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function ExecuteNonQuery As Integer
C#
public int ExecuteNonQuery()
Visual C++
public:
virtual int ExecuteNonQuery() sealed

Return Value

Implements

IDbCommandExecuteNonQuery()()()

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


ExecuteReader Method

[image] [image]

SQL Data Compare API 12.0.40
BackupReaderCommandBase..::.ExecuteReader Method
BackupReaderCommandBase Class See Also

Overload List

Name | Description
ExecuteReader()()() |
ExecuteReader(CommandBehavior) | Not implemented in this implementation

See Also

BackupReaderCommandBase Class
BackupReaderCommandBase Members
RedGate.BackupReader Namespace


ExecuteReader Method

[image]

SQL Data Compare API 12.0.40
BackupReaderCommandBase..::.ExecuteReader Method
BackupReaderCommandBase Class See Also

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function ExecuteReader As BackupDataReader
C#
public BackupDataReader ExecuteReader()
Visual C++
public:
BackupDataReader^ ExecuteReader()

See Also

BackupReaderCommandBase Class
ExecuteReader Overload
RedGate.BackupReader Namespace


ExecuteReader Method ()

[image]

SQL Data Compare API 12.0.40
BackupReaderCommandBase..::.ExecuteReader Method ()
BackupReaderCommandBase Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function ExecuteReader ( _
    behavior As CommandBehavior _
) As IDataReader
C#
public IDataReader ExecuteReader(
    CommandBehavior behavior
)
Visual C++
public:
virtual IDataReader^ ExecuteReader(
    CommandBehavior behavior
) sealed

Parameters

behavior
Type: CommandBehavior

Return Value

Implements

IDbCommandExecuteReader(CommandBehavior)

See Also

BackupReaderCommandBase Class
ExecuteReader Overload
RedGate.BackupReader Namespace


. Method

[image]

SQL Data Compare API 12.0.40
BackupReaderCommandBase..::...::. Method
BackupReaderCommandBase Class See Also

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Private Function ExecuteReader As IDataReader
    Implements IDbCommand.ExecuteReader
C#
IDataReader IDbCommand.ExecuteReader()
Visual C++
private:
virtual IDataReader^ ExecuteReader() sealed = IDbCommand::ExecuteReader

Implements

IDbCommandExecuteReader()()()

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


ExecuteScalar Method

[image]

SQL Data Compare API 12.0.40
BackupReaderCommandBase..::.ExecuteScalar Method
BackupReaderCommandBase Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function ExecuteScalar As Object
C#
public Object ExecuteScalar()
Visual C++
public:
virtual Object^ ExecuteScalar() sealed

Return Value

Implements

IDbCommandExecuteScalar()()()

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


Prepare Method

[image]

SQL Data Compare API 12.0.40
BackupReaderCommandBase..::.Prepare Method
BackupReaderCommandBase Class See Also

Intentional No-op

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub Prepare
C#
public void Prepare()
Visual C++
public:
virtual void Prepare() sealed

Implements

IDbCommandPrepare()()()

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


BackupReaderCommandBase Properties

[image] [image]

SQL Data Compare API 12.0.40
BackupReaderCommandBase Properties
BackupReaderCommandBase Class See Also

The BackupReaderCommandBase type exposes the following properties.

Properties

Name | Description
CommandText | Gets or sets the text command to run against the data source.
CommandTimeout | Not implemented in this implementation
CommandType | Indicates or specifies how the System.Data.IDbCommand.CommandText property is interpreted. In this implementation, only CommandType.Text is supported.
Connection | Gets or sets the System.Data.IDbConnection used by this instance of the System.Data.IDbCommand.
Parameters | Not implemented in this implementation
Transaction | Not implemented in this implementation
UpdatedRowSource | Not implemented in this implementation

Explicit Interface Implementations

Name | Description
IDbCommandConnection |

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


CommandText Property

[image]

SQL Data Compare API 12.0.40
BackupReaderCommandBase..::.CommandText Property
BackupReaderCommandBase Class See Also

Gets or sets the text command to run against the data source.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Property CommandText As String
C#
public string CommandText { get; set; }
Visual C++
public:
virtual property String^ CommandText {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IDbCommandCommandText()()()

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


CommandTimeout Property

[image]

SQL Data Compare API 12.0.40
BackupReaderCommandBase..::.CommandTimeout Property
BackupReaderCommandBase Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Property CommandTimeout As Integer
C#
public int CommandTimeout { get; set; }
Visual C++
public:
virtual property int CommandTimeout {
    int get () sealed;
    void set (int value) sealed;
}

Return Value

Implements

IDbCommandCommandTimeout()()()

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


CommandType Property

[image]

SQL Data Compare API 12.0.40
BackupReaderCommandBase..::.CommandType Property
BackupReaderCommandBase Class See Also

Indicates or specifies how the System.Data.IDbCommand.CommandText property is interpreted. In this implementation, only CommandType.Text is supported.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Property CommandType As CommandType
C#
public CommandType CommandType { get; set; }
Visual C++
public:
virtual property CommandType CommandType {
    CommandType get () sealed;
    void set (CommandType value) sealed;
}

Implements

IDbCommandCommandType()()()

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


Connection Property

[image]

SQL Data Compare API 12.0.40
BackupReaderCommandBase..::.Connection Property
BackupReaderCommandBase Class See Also

Gets or sets the System.Data.IDbConnection used by this instance of the System.Data.IDbCommand.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Property Connection As IDbConnection
C#
public IDbConnection Connection { get; set; }
Visual C++
public:
property IDbConnection^ Connection {
    IDbConnection^ get ();
    void set (IDbConnection^ value);
}

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


. Property

[image]

SQL Data Compare API 12.0.40
BackupReaderCommandBase..::...::. Property
BackupReaderCommandBase Class See Also

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Private Property Connection As IDbConnection
    Implements IDbCommand.Connection
C#
IDbConnection IDbCommand.Connection { get; set; }
Visual C++
private:
virtual property IDbConnection^ Connection {
    IDbConnection^ get () sealed = IDbCommand::Connection::get;
    void set (IDbConnection^ value) sealed = IDbCommand::Connection::set;
}

Implements

IDbCommandConnection()()()

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


Parameters Property

[image]

SQL Data Compare API 12.0.40
BackupReaderCommandBase..::.Parameters Property
BackupReaderCommandBase Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As IDataParameterCollection
C#
public IDataParameterCollection Parameters { get; }
Visual C++
public:
virtual property IDataParameterCollection^ Parameters {
    IDataParameterCollection^ get () sealed;
}

Return Value

Implements

IDbCommandParameters()()()

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


Transaction Property

[image]

SQL Data Compare API 12.0.40
BackupReaderCommandBase..::.Transaction Property
BackupReaderCommandBase Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Property Transaction As IDbTransaction
C#
public IDbTransaction Transaction { get; set; }
Visual C++
public:
virtual property IDbTransaction^ Transaction {
    IDbTransaction^ get () sealed;
    void set (IDbTransaction^ value) sealed;
}

Return Value

Implements

IDbCommandTransaction()()()

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


UpdatedRowSource Property

[image]

SQL Data Compare API 12.0.40
BackupReaderCommandBase..::.UpdatedRowSource Property
BackupReaderCommandBase Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Property UpdatedRowSource As UpdateRowSource
C#
public UpdateRowSource UpdatedRowSource { get; set; }
Visual C++
public:
virtual property UpdateRowSource UpdatedRowSource {
    UpdateRowSource get () sealed;
    void set (UpdateRowSource value) sealed;
}

Return Value

Implements

IDbCommandUpdatedRowSource()()()

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


BackupReaderException Class

[image]

SQL Data Compare API 12.0.40
BackupReaderException Class
Members See Also

An exception thrown from within the BackupReader

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Class BackupReaderException _
    Inherits Exception
C#
public class BackupReaderException : Exception
Visual C++
public ref class BackupReaderException : public Exception

Inheritance Hierarchy

Object
Exception
RedGate.BackupReader..::.BackupReaderException

See Also

BackupReaderException Members
RedGate.BackupReader Namespace


BackupReaderException Members

[image] [image]

SQL Data Compare API 12.0.40
BackupReaderException Members
BackupReaderException Class Methods Properties See Also

The BackupReaderException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BackupReaderException Class
RedGate.BackupReader Namespace


BackupSet Class

[image]

SQL Data Compare API 12.0.40
BackupSet Class
Members See Also

A representation of a single backup set - i.e. the result of a "BACKUP DATABASE..." statement. There may be many backup sets in one physical file, or many physical files required for one backup set (if the backup is RAIDed). BackupSet objects are serializable to allow persistence in saved projects, and do not contain references to the physical files they were originally derived from. It is the responsibility of the user to ensure that the required physical files are specified when attempting to use a BackupSet.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
<StrongNameIdentityPermissionAttribute(SecurityAction.LinkDemand, PublicKey := "0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")> _
Public NotInheritable Class BackupSet _
    Implements IBackupSet, ICloneable, IComparable(Of BackupSet)
C#
[StrongNameIdentityPermissionAttribute(SecurityAction.LinkDemand, PublicKey = "0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")]
public sealed class BackupSet : IBackupSet,
    ICloneable, IComparable<BackupSet>
Visual C++
[StrongNameIdentityPermissionAttribute(SecurityAction::LinkDemand, PublicKey = L"0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")]
public ref class BackupSet sealed : IBackupSet,
    ICloneable, IComparable<BackupSet^>

Inheritance Hierarchy

Object
RedGate.BackupReader..::.BackupSet

See Also

BackupSet Members
RedGate.BackupReader Namespace


BackupSet Members

[image] [image]

SQL Data Compare API 12.0.40
BackupSet Members
BackupSet Class Constructors Methods Properties See Also

The BackupSet type exposes the following members.

Constructors

Name | Description
BackupSet | A parameterless constructor needed for IRedGateSerializable.

Methods

Name | Description
Clone |
CompareTo | Compares the current object with another BackupSet object
Deserialize | This method deserializes the object from the current serialization
Equals | Returns whether this BackupSet is equal to the object specified (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets a hash code representing this object (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serialize up you data. (Nb the version number has already been added in)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BackupType | The type of backup
CanHandle | Gets whether SQL Backup Reader is able to handle this BackupSet. This should be used by the user interface to determine whether the user is allowed to select this backup set.
CheckpointLsn | Log sequence number of most recent checkpoint of this backup
DatabaseName | The original database name
Encrypted | Returns whether the BackupSet is encrypted or not.
EndDate | The date and time the backup completed
FirstLsn | First log sequence number of this backup
FullBackupLsn | Log sequence number of the full backup associated with this backup
IsIncomplete | Returns whether the BackupSet is incomplete or not.
LastLsn | Last log sequence number of this backup
Name | The name of the backupset, if one is set.
ServerName | The server from which the database was backed up
Size | Size (in bytes) of this backup
StartDate | The date and time the backup began
Version | This is the current latest version of your serialized data.

See Also

BackupSet Class
RedGate.BackupReader Namespace


BackupSet Constructor

[image]

SQL Data Compare API 12.0.40
BackupSet Constructor
BackupSet Class See Also

A parameterless constructor needed for IRedGateSerializable.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BackupSet()
Visual C++
public:
BackupSet()

See Also

BackupSet Class
RedGate.BackupReader Namespace


BackupSet Methods

[image] [image]

SQL Data Compare API 12.0.40
BackupSet Methods
BackupSet Class See Also

The BackupSet type exposes the following methods.

Methods

Name | Description
Clone |
CompareTo | Compares the current object with another BackupSet object
Deserialize | This method deserializes the object from the current serialization
Equals | Returns whether this BackupSet is equal to the object specified (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets a hash code representing this object (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serialize up you data. (Nb the version number has already been added in)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BackupSet Class
RedGate.BackupReader Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
BackupSet..::.Clone Method
BackupSet Class See Also

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone As Object
C#
public Object Clone()
Visual C++
public:
virtual Object^ Clone() sealed

Implements

ICloneableClone()()()

See Also

BackupSet Class
RedGate.BackupReader Namespace


CompareTo Method

[image]

SQL Data Compare API 12.0.40
BackupSet..::.CompareTo Method
BackupSet Class See Also

Compares the current object with another BackupSet object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareTo ( _
    other As BackupSet _
) As Integer
C#
public int CompareTo(
    BackupSet other
)
Visual C++
public:
virtual int CompareTo(
    BackupSet^ other
) sealed

Parameters

other
Type: RedGate.BackupReader..::.BackupSet
A BackupSet to compare with this object.

Return Value

A 32-bit signed integer that indicates the relative order of the objects being compared. The return value has the following meanings: Value Meaning Less than zero This object is less than the other parameter.Zero This object is equal to other. Greater than zero This object is greater than other.

Implements

IComparableCompareTo(UTP)

See Also

BackupSet Class
RedGate.BackupReader Namespace


Deserialize Method

[image]

SQL Data Compare API 12.0.40
BackupSet..::.Deserialize Method
BackupSet Class See Also

This method deserializes the object from the current serialization

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function Deserialize ( _
    versionId As Integer, _
    formatter As ISerializeFormatter _
) As Boolean
C#
public bool Deserialize(
    int versionId,
    ISerializeFormatter formatter
)
Visual C++
public:
virtual bool Deserialize(
    int versionId,
    ISerializeFormatter^ formatter
) sealed

Parameters

versionId
Type: Int32
The version of the serialized data
formatter
Type: ISerializeFormatter

Return Value

See Also

BackupSet Class
RedGate.BackupReader Namespace


Equals Method

[image]

SQL Data Compare API 12.0.40
BackupSet..::.Equals Method
BackupSet Class See Also

Returns whether this BackupSet is equal to the object specified

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object

Return Value

See Also

BackupSet Class
RedGate.BackupReader Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
BackupSet..::.GetHashCode Method
BackupSet Class See Also

Gets a hash code representing this object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

Return Value

See Also

BackupSet Class
RedGate.BackupReader Namespace


Serialize Method

[image]

SQL Data Compare API 12.0.40
BackupSet..::.Serialize Method
BackupSet Class See Also

Serialize up you data. (Nb the version number has already been added in)

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub Serialize ( _
    formatter As ISerializeFormatter _
)
C#
public void Serialize(
    ISerializeFormatter formatter
)
Visual C++
public:
virtual void Serialize(
    ISerializeFormatter^ formatter
) sealed

Parameters

formatter
Type: ISerializeFormatter

See Also

BackupSet Class
RedGate.BackupReader Namespace


BackupSet Properties

[image] [image]

SQL Data Compare API 12.0.40
BackupSet Properties
BackupSet Class See Also

The BackupSet type exposes the following properties.

Properties

Name | Description
BackupType | The type of backup
CanHandle | Gets whether SQL Backup Reader is able to handle this BackupSet. This should be used by the user interface to determine whether the user is allowed to select this backup set.
CheckpointLsn | Log sequence number of most recent checkpoint of this backup
DatabaseName | The original database name
Encrypted | Returns whether the BackupSet is encrypted or not.
EndDate | The date and time the backup completed
FirstLsn | First log sequence number of this backup
FullBackupLsn | Log sequence number of the full backup associated with this backup
IsIncomplete | Returns whether the BackupSet is incomplete or not.
LastLsn | Last log sequence number of this backup
Name | The name of the backupset, if one is set.
ServerName | The server from which the database was backed up
Size | Size (in bytes) of this backup
StartDate | The date and time the backup began
Version | This is the current latest version of your serialized data.

See Also

BackupSet Class
RedGate.BackupReader Namespace


BackupType Property

[image]

SQL Data Compare API 12.0.40
BackupSet..::.BackupType Property
BackupSet Class See Also

The type of backup

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BackupType As BackupType
C#
public BackupType BackupType { get; }
Visual C++
public:
virtual property BackupType BackupType {
    BackupType get () sealed;
}

Implements

IBackupSet..::.BackupType

See Also

BackupSet Class
RedGate.BackupReader Namespace


CanHandle Property

[image]

SQL Data Compare API 12.0.40
BackupSet..::.CanHandle Property
BackupSet Class See Also

Gets whether SQL Backup Reader is able to handle this BackupSet. This should be used by the user interface to determine whether the user is allowed to select this backup set.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanHandle As Boolean
C#
public bool CanHandle { get; }
Visual C++
public:
virtual property bool CanHandle {
    bool get () sealed;
}

Implements

IBackupSet..::.CanHandle

See Also

BackupSet Class
RedGate.BackupReader Namespace


CheckpointLsn Property

[image]

SQL Data Compare API 12.0.40
BackupSet..::.CheckpointLsn Property
BackupSet Class See Also

Log sequence number of most recent checkpoint of this backup

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CheckpointLsn As String
C#
public string CheckpointLsn { get; }
Visual C++
public:
property String^ CheckpointLsn {
    String^ get ();
}

See Also

BackupSet Class
RedGate.BackupReader Namespace


DatabaseName Property

[image]

SQL Data Compare API 12.0.40
BackupSet..::.DatabaseName Property
BackupSet Class See Also

The original database name

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DatabaseName As String
C#
public string DatabaseName { get; }
Visual C++
public:
virtual property String^ DatabaseName {
    String^ get () sealed;
}

Implements

IBackupSet..::.DatabaseName

See Also

BackupSet Class
RedGate.BackupReader Namespace


Encrypted Property

[image]

SQL Data Compare API 12.0.40
BackupSet..::.Encrypted Property
BackupSet Class See Also

Returns whether the BackupSet is encrypted or not.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Property Encrypted As Boolean
C#
public bool Encrypted { get; set; }
Visual C++
public:
virtual property bool Encrypted {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IBackupSet..::.Encrypted

See Also

BackupSet Class
RedGate.BackupReader Namespace


EndDate Property

[image]

SQL Data Compare API 12.0.40
BackupSet..::.EndDate Property
BackupSet Class See Also

The date and time the backup completed

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EndDate As DateTime
C#
public DateTime EndDate { get; }
Visual C++
public:
virtual property DateTime EndDate {
    DateTime get () sealed;
}

Implements

IBackupSet..::.EndDate

See Also

BackupSet Class
RedGate.BackupReader Namespace


FirstLsn Property

[image]

SQL Data Compare API 12.0.40
BackupSet..::.FirstLsn Property
BackupSet Class See Also

First log sequence number of this backup

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FirstLsn As String
C#
public string FirstLsn { get; }
Visual C++
public:
virtual property String^ FirstLsn {
    String^ get () sealed;
}

Implements

IBackupSet..::.FirstLsn

See Also

BackupSet Class
RedGate.BackupReader Namespace


FullBackupLsn Property

[image]

SQL Data Compare API 12.0.40
BackupSet..::.FullBackupLsn Property
BackupSet Class See Also

Log sequence number of the full backup associated with this backup

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullBackupLsn As String
C#
public string FullBackupLsn { get; }
Visual C++
public:
property String^ FullBackupLsn {
    String^ get ();
}

See Also

BackupSet Class
RedGate.BackupReader Namespace


IsIncomplete Property

[image]

SQL Data Compare API 12.0.40
BackupSet..::.IsIncomplete Property
BackupSet Class See Also

Returns whether the BackupSet is incomplete or not.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Property IsIncomplete As Boolean
C#
public bool IsIncomplete { get; set; }
Visual C++
public:
virtual property bool IsIncomplete {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IBackupSet..::.IsIncomplete

See Also

BackupSet Class
RedGate.BackupReader Namespace


LastLsn Property

[image]

SQL Data Compare API 12.0.40
BackupSet..::.LastLsn Property
BackupSet Class See Also

Last log sequence number of this backup

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LastLsn As String
C#
public string LastLsn { get; }
Visual C++
public:
virtual property String^ LastLsn {
    String^ get () sealed;
}

Implements

IBackupSet..::.LastLsn

See Also

BackupSet Class
RedGate.BackupReader Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
BackupSet..::.Name Property
BackupSet Class See Also

The name of the backupset, if one is set.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
}

Implements

IBackupSet..::.Name

See Also

BackupSet Class
RedGate.BackupReader Namespace


ServerName Property

[image]

SQL Data Compare API 12.0.40
BackupSet..::.ServerName Property
BackupSet Class See Also

The server from which the database was backed up

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ServerName As String
C#
public string ServerName { get; }
Visual C++
public:
virtual property String^ ServerName {
    String^ get () sealed;
}

Implements

IBackupSet..::.ServerName

See Also

BackupSet Class
RedGate.BackupReader Namespace


Size Property

[image]

SQL Data Compare API 12.0.40
BackupSet..::.Size Property
BackupSet Class See Also

Size (in bytes) of this backup

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size As ULong
C#
public ulong Size { get; }
Visual C++
public:
virtual property unsigned long long Size {
    unsigned long long get () sealed;
}

Implements

IBackupSet..::.Size

See Also

BackupSet Class
RedGate.BackupReader Namespace


StartDate Property

[image]

SQL Data Compare API 12.0.40
BackupSet..::.StartDate Property
BackupSet Class See Also

The date and time the backup began

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StartDate As DateTime
C#
public DateTime StartDate { get; }
Visual C++
public:
virtual property DateTime StartDate {
    DateTime get () sealed;
}

Implements

IBackupSet..::.StartDate

See Also

BackupSet Class
RedGate.BackupReader Namespace


Version Property

[image]

SQL Data Compare API 12.0.40
BackupSet..::.Version Property
BackupSet Class See Also

This is the current latest version of your serialized data.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As Integer
C#
public int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () sealed;
}

See Also

BackupSet Class
RedGate.BackupReader Namespace


CollationHelper Class

[image]

SQL Data Compare API 12.0.40
CollationHelper Class
Members See Also

A helper class for collation related tasks

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
<StrongNameIdentityPermissionAttribute(SecurityAction.LinkDemand, PublicKey := "0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")> _
Public NotInheritable Class CollationHelper
C#
[StrongNameIdentityPermissionAttribute(SecurityAction.LinkDemand, PublicKey = "0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")]
public static class CollationHelper
Visual C++
[StrongNameIdentityPermissionAttribute(SecurityAction::LinkDemand, PublicKey = L"0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")]
public ref class CollationHelper abstract sealed

Inheritance Hierarchy

Object
RedGate.BackupReader..::.CollationHelper

See Also

CollationHelper Members
RedGate.BackupReader Namespace


CollationHelper Members

[image] [image]

SQL Data Compare API 12.0.40
CollationHelper Members
CollationHelper Class Methods See Also

The CollationHelper type exposes the following members.

Methods

Name | Description
CodePageFromCollationID | Retrieves the codepage associated with a collation ID from the collation's ID.
CollationNameFromId | Retrieves the string collation name (such as SQL_EBCDIC297_CP1_CS_AS) given the SQL Server Collation ID number. Throws an ArgumentException if the collation name cannot be found.

See Also

CollationHelper Class
RedGate.BackupReader Namespace


CollationHelper Methods

[image] [image]

SQL Data Compare API 12.0.40
CollationHelper Methods
CollationHelper Class See Also

The CollationHelper type exposes the following methods.

Methods

Name | Description
CodePageFromCollationID | Retrieves the codepage associated with a collation ID from the collation's ID.
CollationNameFromId | Retrieves the string collation name (such as SQL_EBCDIC297_CP1_CS_AS) given the SQL Server Collation ID number. Throws an ArgumentException if the collation name cannot be found.

See Also

CollationHelper Class
RedGate.BackupReader Namespace


CodePageFromCollationID Method

[image]

SQL Data Compare API 12.0.40
CollationHelper..::.CodePageFromCollationID Method
CollationHelper Class See Also

Retrieves the codepage associated with a collation ID from the collation's ID.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CodePageFromCollationID ( _
    id As Integer _
) As Integer
C#
public static int CodePageFromCollationID(
    int id
)
Visual C++
public:
static int CodePageFromCollationID(
    int id
)

Parameters

id
Type: Int32
ID of the collation

Return Value

ID of the codepage

See Also

CollationHelper Class
RedGate.BackupReader Namespace


CollationNameFromId Method

[image]

SQL Data Compare API 12.0.40
CollationHelper..::.CollationNameFromId Method
CollationHelper Class See Also

Retrieves the string collation name (such as SQL_EBCDIC297_CP1_CS_AS) given the SQL Server Collation ID number. Throws an ArgumentException if the collation name cannot be found.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CollationNameFromId ( _
    id As Integer _
) As String
C#
public static string CollationNameFromId(
    int id
)
Visual C++
public:
static String^ CollationNameFromId(
    int id
)

Parameters

id
Type: Int32
Collation ID

Return Value

Collation name

Exceptions

Exception | Condition
ArgumentException | if the collation ID isn't known

See Also

CollationHelper Class
RedGate.BackupReader Namespace


LiveCommand Class

[image]

SQL Data Compare API 12.0.40
LiveCommand Class
Members See Also

Represents an SQL statement that is executed while connected to a data source, and is implemented by .NET Framework data providers that access relational databases.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LiveCommand _
    Inherits BackupReaderCommandBase
C#
public sealed class LiveCommand : BackupReaderCommandBase
Visual C++
public ref class LiveCommand sealed : public BackupReaderCommandBase

Inheritance Hierarchy

Object
RedGate.BackupReader..::.BackupReaderCommandBase
RedGate.BackupReader..::.LiveCommand

See Also

LiveCommand Members
RedGate.BackupReader Namespace


LiveCommand Members

[image] [image]

SQL Data Compare API 12.0.40
LiveCommand Members
LiveCommand Class Methods Fields Properties Explicit Interface Implementations See Also

The LiveCommand type exposes the following members.

Methods

Name | Description
Cancel | Not yet implemented (Inherited from BackupReaderCommandBase.)
CreateParameter | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)
Dispose | Frees up resources associated with this object (Inherited from BackupReaderCommandBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteNonQuery | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)
ExecuteReader | Overloaded.
ExecuteScalar | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Prepare | Intentional No-op (Inherited from BackupReaderCommandBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_AllowNoIndex | (Inherited from BackupReaderCommandBase.)

Properties

Name | Description
CommandText | Gets or sets the text command to run against the data source. (Inherited from BackupReaderCommandBase.)
CommandTimeout | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)
CommandType | Indicates or specifies how the System.Data.IDbCommand.CommandText property is interpreted. In this implementation, only CommandType.Text is supported. (Inherited from BackupReaderCommandBase.)
Connection | Gets or sets the System.Data.IDbConnection used by this instance of the System.Data.IDbCommand. (Inherited from BackupReaderCommandBase.)
Parameters | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)
Transaction | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)
UpdatedRowSource | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)

Explicit Interface Implementations

Name | Description
IDbCommandConnection | (Inherited from BackupReaderCommandBase.)
IDbCommandExecuteReader | (Inherited from BackupReaderCommandBase.)

See Also

LiveCommand Class
RedGate.BackupReader Namespace


LiveConnection Class

[image]

SQL Data Compare API 12.0.40
LiveConnection Class
Members See Also

An implementation of IBackupConnection for treating a live DB as a page reader

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LiveConnection _
    Implements IBackupConnection, IDbConnection, IDisposable, ICancellable
C#
public sealed class LiveConnection : IBackupConnection,
    IDbConnection, IDisposable, ICancellable
Visual C++
public ref class LiveConnection sealed : IBackupConnection,
    IDbConnection, IDisposable, ICancellable

Inheritance Hierarchy

Object
RedGate.BackupReader..::.LiveConnection

See Also

LiveConnection Members
RedGate.BackupReader Namespace


LiveConnection Members

[image] [image]

SQL Data Compare API 12.0.40
LiveConnection Members
LiveConnection Class Constructors Methods Properties Explicit Interface Implementations See Also

The LiveConnection type exposes the following members.

Constructors

Name | Description
LiveConnection | Overloaded.

Methods

Name | Description
BeginTransaction | Overloaded.
CancelOperation | Cancels the operation.
ChangeDatabase | Not implemented in this implementation
Close | Closes the LiveConnection.
CreateCommand | Creates a command object for executing against the main data source
CreateSysTableCommand | Creates a command on to the queryable system table store
Dispose | Not implemented yet
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBackupSets | Not valid for this object
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsPasswordRequired | Always returns false since the LiveConnection doesn't handle the underlying connection object
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Open | Opens the LiveConnection to the source specified in the ConnectionString. Expensive.
OpenForMetaInformation | Opens the LiveConnection to access database information from the source specified in the ConnectionString. Cheap but not suitable to retrieve actual data / structure from the database - only meta information.
PopulateAdditionalSystemTables | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UseBackupSet | Not valid for this object

Properties

Name | Description
BackupTemporaryDirectory | Get the temporary backup data store directory or null if it doesn't exist
CompatibilityVersion | Not implemented
ConnectionString | Gets the string used to open a database.
ConnectionTimeout | Not implemented in this implementation
CurrentBackupSet | Not valid for this object
Database | Not implemented in this implementation
DatabaseGuid | Not implemented
SQLServerInternalVersionNumber | Not valid for this object
State | Open or Closed
Status | An event handler for providing progress feedback.
Version | Returns 7, 8, 9 - SQL7, SQL2000, SQL2005

Explicit Interface Implementations

Name | Description
IDbConnectionCreateCommand |

See Also

LiveConnection Class
RedGate.BackupReader Namespace


LiveConnection Constructor

[image] [image]

SQL Data Compare API 12.0.40
LiveConnection Constructor
LiveConnection Class See Also

Overload List

Name | Description
LiveConnection(SqlConnection, SQLVersion) | Creates a new LiveConnection object
LiveConnection(SqlConnection, SQLVersion, Boolean) | Creates a new LiveConnection object
LiveConnection(Assembly, SqlConnection, SQLVersion, Boolean) | Creates a new LiveConnection object

See Also

LiveConnection Class
LiveConnection Members
RedGate.BackupReader Namespace


LiveConnection Constructor (, )

[image]

SQL Data Compare API 12.0.40
LiveConnection Constructor (, )
LiveConnection Class See Also

Creates a new LiveConnection object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    conn As SqlConnection, _
    version As SQLVersion _
)
C#
public LiveConnection(
    SqlConnection conn,
    SQLVersion version
)
Visual C++
public:
LiveConnection(
    SqlConnection^ conn,
    SQLVersion version
)

Parameters

conn
Type: SqlConnection
version
Type: SQLVersion

See Also

LiveConnection Class
LiveConnection Overload
RedGate.BackupReader Namespace


LiveConnection Constructor (, , )

[image]

SQL Data Compare API 12.0.40
LiveConnection Constructor (, , )
LiveConnection Class See Also

Creates a new LiveConnection object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    conn As SqlConnection, _
    version As SQLVersion, _
    createNewConnection As Boolean _
)
C#
public LiveConnection(
    SqlConnection conn,
    SQLVersion version,
    bool createNewConnection
)
Visual C++
public:
LiveConnection(
    SqlConnection^ conn,
    SQLVersion version,
    bool createNewConnection
)

Parameters

conn
Type: SqlConnection
version
Type: SQLVersion
createNewConnection
Type: Boolean

See Also

LiveConnection Class
LiveConnection Overload
RedGate.BackupReader Namespace


LiveConnection Constructor (, , , )

[image]

SQL Data Compare API 12.0.40
LiveConnection Constructor (, , , )
LiveConnection Class See Also

Creates a new LiveConnection object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    asm As Assembly, _
    conn As SqlConnection, _
    version As SQLVersion, _
    createNewConnection As Boolean _
)
C#
public LiveConnection(
    Assembly asm,
    SqlConnection conn,
    SQLVersion version,
    bool createNewConnection
)
Visual C++
public:
LiveConnection(
    Assembly^ asm,
    SqlConnection^ conn,
    SQLVersion version,
    bool createNewConnection
)

Parameters

asm
Type: Assembly
conn
Type: SqlConnection
version
Type: SQLVersion
createNewConnection
Type: Boolean

See Also

LiveConnection Class
LiveConnection Overload
RedGate.BackupReader Namespace


LiveConnection Methods

[image] [image]

SQL Data Compare API 12.0.40
LiveConnection Methods
LiveConnection Class See Also

The LiveConnection type exposes the following methods.

Methods

Name | Description
BeginTransaction | Overloaded.
CancelOperation | Cancels the operation.
ChangeDatabase | Not implemented in this implementation
Close | Closes the LiveConnection.
CreateCommand | Creates a command object for executing against the main data source
CreateSysTableCommand | Creates a command on to the queryable system table store
Dispose | Not implemented yet
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBackupSets | Not valid for this object
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsPasswordRequired | Always returns false since the LiveConnection doesn't handle the underlying connection object
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Open | Opens the LiveConnection to the source specified in the ConnectionString. Expensive.
OpenForMetaInformation | Opens the LiveConnection to access database information from the source specified in the ConnectionString. Cheap but not suitable to retrieve actual data / structure from the database - only meta information.
PopulateAdditionalSystemTables | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UseBackupSet | Not valid for this object

Explicit Interface Implementations

Name | Description
IDbConnectionCreateCommand |

See Also

LiveConnection Class
RedGate.BackupReader Namespace


BeginTransaction Method

[image] [image]

SQL Data Compare API 12.0.40
LiveConnection..::.BeginTransaction Method
LiveConnection Class See Also

Overload List

Name | Description
BeginTransaction()()() | Not implemented in this implementation
BeginTransaction(IsolationLevel) | Not implemented in this implementation

See Also

LiveConnection Class
LiveConnection Members
RedGate.BackupReader Namespace


BeginTransaction Method

[image]

SQL Data Compare API 12.0.40
LiveConnection..::.BeginTransaction Method
LiveConnection Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function BeginTransaction As IDbTransaction
C#
public IDbTransaction BeginTransaction()
Visual C++
public:
virtual IDbTransaction^ BeginTransaction() sealed

Return Value

Implements

IDbConnectionBeginTransaction()()()

See Also

LiveConnection Class
BeginTransaction Overload
RedGate.BackupReader Namespace


BeginTransaction Method ()

[image]

SQL Data Compare API 12.0.40
LiveConnection..::.BeginTransaction Method ()
LiveConnection Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function BeginTransaction ( _
    il As IsolationLevel _
) As IDbTransaction
C#
public IDbTransaction BeginTransaction(
    IsolationLevel il
)
Visual C++
public:
virtual IDbTransaction^ BeginTransaction(
    IsolationLevel il
) sealed

Parameters

il
Type: IsolationLevel

Return Value

Implements

IDbConnectionBeginTransaction(IsolationLevel)

See Also

LiveConnection Class
BeginTransaction Overload
RedGate.BackupReader Namespace


CancelOperation Method

[image]

SQL Data Compare API 12.0.40
LiveConnection..::.CancelOperation Method
LiveConnection Class See Also

Cancels the operation.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelOperation
C#
public void CancelOperation()
Visual C++
public:
virtual void CancelOperation() sealed

Implements

ICancellable..::.CancelOperation()()()

See Also

LiveConnection Class
RedGate.BackupReader Namespace


ChangeDatabase Method

[image]

SQL Data Compare API 12.0.40
LiveConnection..::.ChangeDatabase Method
LiveConnection Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub ChangeDatabase ( _
    databaseName As String _
)
C#
public void ChangeDatabase(
    string databaseName
)
Visual C++
public:
virtual void ChangeDatabase(
    String^ databaseName
) sealed

Parameters

databaseName
Type: String

Return Value

Implements

IDbConnectionChangeDatabase(String)

See Also

LiveConnection Class
RedGate.BackupReader Namespace


Close Method

[image]

SQL Data Compare API 12.0.40
LiveConnection..::.Close Method
LiveConnection Class See Also

Closes the LiveConnection.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub Close
C#
public void Close()
Visual C++
public:
virtual void Close() sealed

Implements

IDbConnectionClose()()()

See Also

LiveConnection Class
RedGate.BackupReader Namespace


CreateCommand Method

[image]

SQL Data Compare API 12.0.40
LiveConnection..::.CreateCommand Method
LiveConnection Class See Also

Creates a command object for executing against the main data source

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateCommand As IDbCommand
C#
public IDbCommand CreateCommand()
Visual C++
public:
IDbCommand^ CreateCommand()

Return Value

See Also

LiveConnection Class
RedGate.BackupReader Namespace


. Method

[image]

SQL Data Compare API 12.0.40
LiveConnection..::...::. Method
LiveConnection Class See Also

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Private Function CreateCommand As IDbCommand
    Implements IDbConnection.CreateCommand
C#
IDbCommand IDbConnection.CreateCommand()
Visual C++
private:
virtual IDbCommand^ CreateCommand() sealed = IDbConnection::CreateCommand

Implements

IDbConnectionCreateCommand()()()

See Also

LiveConnection Class
RedGate.BackupReader Namespace


CreateSysTableCommand Method

[image]

SQL Data Compare API 12.0.40
LiveConnection..::.CreateSysTableCommand Method
LiveConnection Class See Also

Creates a command on to the queryable system table store

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSysTableCommand As IDbCommand
C#
public IDbCommand CreateSysTableCommand()
Visual C++
public:
virtual IDbCommand^ CreateSysTableCommand() sealed

Return Value

An instance of IDbCommand connected to the system table store

Implements

IBackupConnection..::.CreateSysTableCommand()()()

See Also

LiveConnection Class
RedGate.BackupReader Namespace


Dispose Method

[image]

SQL Data Compare API 12.0.40
LiveConnection..::.Dispose Method
LiveConnection Class See Also

Not implemented yet

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose
C#
public void Dispose()
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposableDispose()()()

See Also

LiveConnection Class
RedGate.BackupReader Namespace


GetBackupSets Method

[image]

SQL Data Compare API 12.0.40
LiveConnection..::.GetBackupSets Method
LiveConnection Class See Also

Not valid for this object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetBackupSets As IList(Of IBackupSet)
C#
public IList<IBackupSet> GetBackupSets()
Visual C++
public:
virtual IList<IBackupSet^>^ GetBackupSets() sealed

Return Value

Implements

IBackupConnection..::.GetBackupSets()()()

See Also

LiveConnection Class
RedGate.BackupReader Namespace


IsPasswordRequired Method

[image]

SQL Data Compare API 12.0.40
LiveConnection..::.IsPasswordRequired Method
LiveConnection Class See Also

Always returns false since the LiveConnection doesn't handle the underlying connection object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function IsPasswordRequired As Boolean
C#
public bool IsPasswordRequired()
Visual C++
public:
virtual bool IsPasswordRequired() sealed

Return Value

Implements

IBackupConnection..::.IsPasswordRequired()()()

See Also

LiveConnection Class
RedGate.BackupReader Namespace


Open Method

[image]

SQL Data Compare API 12.0.40
LiveConnection..::.Open Method
LiveConnection Class See Also

Opens the LiveConnection to the source specified in the ConnectionString. Expensive.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub Open
C#
public void Open()
Visual C++
public:
virtual void Open() sealed

Implements

IDbConnectionOpen()()()

See Also

LiveConnection Class
RedGate.BackupReader Namespace


OpenForMetaInformation Method

[image]

SQL Data Compare API 12.0.40
LiveConnection..::.OpenForMetaInformation Method
LiveConnection Class See Also

Opens the LiveConnection to access database information from the source specified in the ConnectionString. Cheap but not suitable to retrieve actual data / structure from the database - only meta information.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub OpenForMetaInformation
C#
public void OpenForMetaInformation()
Visual C++
public:
virtual void OpenForMetaInformation() sealed

Implements

IBackupConnection..::.OpenForMetaInformation()()()

See Also

LiveConnection Class
RedGate.BackupReader Namespace


PopulateAdditionalSystemTables Method

[image] [image]

SQL Data Compare API 12.0.40
LiveConnection..::.PopulateAdditionalSystemTables Method
LiveConnection Class See Also

Overload List

Name | Description
PopulateAdditionalSystemTables(array<ITableName>[]()[]) | Populates one or more system tables in addition to those already populated The LiveConnection must be in the Open state before calling this method. Progress may be given by setting the Status event handler in a similar way to the Open call. Progress will range from 0% to 100% over the course of all the tables to be populated.
PopulateAdditionalSystemTables(List<(Of <(ITableName>)>)) | Populates one or more system tables in addition to those already populated The LiveConnection must be in the Open state before calling this method. Progress may be given by setting the Status event handler in a similar way to the Open call. Progress will range from 0% to 100% over the course of all the tables to be populated.

See Also

LiveConnection Class
LiveConnection Members
RedGate.BackupReader Namespace


PopulateAdditionalSystemTables Method ([])

[image]

SQL Data Compare API 12.0.40
LiveConnection..::.PopulateAdditionalSystemTables Method (array<>[]()[])
LiveConnection Class See Also

Populates one or more system tables in addition to those already populated The LiveConnection must be in the Open state before calling this method. Progress may be given by setting the Status event handler in a similar way to the Open call. Progress will range from 0% to 100% over the course of all the tables to be populated.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub PopulateAdditionalSystemTables ( _
    ParamArray tables As ITableName() _
)
C#
public void PopulateAdditionalSystemTables(
    params ITableName[] tables
)
Visual C++
public:
virtual void PopulateAdditionalSystemTables(
    ... array<ITableName^>^ tables
) sealed

Parameters

tables
Type: array<ITableName>[]()[]
The schema-qualified name(s) of the tables to populate

Implements

IBackupConnection..::.PopulateAdditionalSystemTables(array<ITableName>[]()[])

Exceptions

Exception | Condition
ArgumentException | Throws ArgumentException if a specified table has already been populated.

See Also

LiveConnection Class
PopulateAdditionalSystemTables Overload
RedGate.BackupReader Namespace


PopulateAdditionalSystemTables Method (())

[image]

SQL Data Compare API 12.0.40
LiveConnection..::.PopulateAdditionalSystemTables Method (<(Of <(>)>))
LiveConnection Class See Also

Populates one or more system tables in addition to those already populated The LiveConnection must be in the Open state before calling this method. Progress may be given by setting the Status event handler in a similar way to the Open call. Progress will range from 0% to 100% over the course of all the tables to be populated.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub PopulateAdditionalSystemTables ( _
    tables As List(Of ITableName) _
)
C#
public void PopulateAdditionalSystemTables(
    List<ITableName> tables
)
Visual C++
public:
virtual void PopulateAdditionalSystemTables(
    List<ITableName^>^ tables
) sealed

Parameters

tables
Type: List<(Of <(ITableName>)>)
A list of the schema-qualified names of the tables to populate

Implements

IBackupConnection..::.PopulateAdditionalSystemTables(List<(Of <(ITableName>)>))

Exceptions

Exception | Condition
ArgumentException | Throws ArgumentException if a specified table has already been populated.

See Also

LiveConnection Class
PopulateAdditionalSystemTables Overload
RedGate.BackupReader Namespace


UseBackupSet Method

[image]

SQL Data Compare API 12.0.40
LiveConnection..::.UseBackupSet Method
LiveConnection Class See Also

Not valid for this object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub UseBackupSet ( _
    ibackupSet As IBackupSet _
)
C#
public void UseBackupSet(
    IBackupSet ibackupSet
)
Visual C++
public:
virtual void UseBackupSet(
    IBackupSet^ ibackupSet
) sealed

Parameters

ibackupSet
Type: RedGate.Shared.SQL.BackupReaderInterfaces..::.IBackupSet

Return Value

Implements

IBackupConnection..::.UseBackupSet(IBackupSet)

See Also

LiveConnection Class
RedGate.BackupReader Namespace


LiveConnection Properties

[image] [image]

SQL Data Compare API 12.0.40
LiveConnection Properties
LiveConnection Class See Also

The LiveConnection type exposes the following properties.

Properties

Name | Description
BackupTemporaryDirectory | Get the temporary backup data store directory or null if it doesn't exist
CompatibilityVersion | Not implemented
ConnectionString | Gets the string used to open a database.
ConnectionTimeout | Not implemented in this implementation
CurrentBackupSet | Not valid for this object
Database | Not implemented in this implementation
DatabaseGuid | Not implemented
SQLServerInternalVersionNumber | Not valid for this object
State | Open or Closed
Status | An event handler for providing progress feedback.
Version | Returns 7, 8, 9 - SQL7, SQL2000, SQL2005

See Also

LiveConnection Class
RedGate.BackupReader Namespace


BackupTemporaryDirectory Property

[image]

SQL Data Compare API 12.0.40
LiveConnection..::.BackupTemporaryDirectory Property
LiveConnection Class See Also

Get the temporary backup data store directory or null if it doesn't exist

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BackupTemporaryDirectory As String
C#
public string BackupTemporaryDirectory { get; }
Visual C++
public:
virtual property String^ BackupTemporaryDirectory {
    String^ get () sealed;
}

Implements

IBackupConnection..::.BackupTemporaryDirectory

See Also

LiveConnection Class
RedGate.BackupReader Namespace


CompatibilityVersion Property

[image]

SQL Data Compare API 12.0.40
LiveConnection..::.CompatibilityVersion Property
LiveConnection Class See Also

Not implemented

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CompatibilityVersion As Integer
C#
public int CompatibilityVersion { get; }
Visual C++
public:
virtual property int CompatibilityVersion {
    int get () sealed;
}

Implements

IBackupConnection..::.CompatibilityVersion

See Also

LiveConnection Class
RedGate.BackupReader Namespace


ConnectionString Property

[image]

SQL Data Compare API 12.0.40
LiveConnection..::.ConnectionString Property
LiveConnection Class See Also

Gets the string used to open a database.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Property ConnectionString As String
C#
public string ConnectionString { get; set; }
Visual C++
public:
virtual property String^ ConnectionString {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Return Value

A string containing connection settings.

Implements

IDbConnectionConnectionString()()()

See Also

LiveConnection Class
RedGate.BackupReader Namespace


ConnectionTimeout Property

[image]

SQL Data Compare API 12.0.40
LiveConnection..::.ConnectionTimeout Property
LiveConnection Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConnectionTimeout As Integer
C#
public int ConnectionTimeout { get; }
Visual C++
public:
virtual property int ConnectionTimeout {
    int get () sealed;
}

Return Value

Implements

IDbConnectionConnectionTimeout()()()

See Also

LiveConnection Class
RedGate.BackupReader Namespace


CurrentBackupSet Property

[image]

SQL Data Compare API 12.0.40
LiveConnection..::.CurrentBackupSet Property
LiveConnection Class See Also

Not valid for this object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentBackupSet As IBackupSet
C#
public IBackupSet CurrentBackupSet { get; }
Visual C++
public:
virtual property IBackupSet^ CurrentBackupSet {
    IBackupSet^ get () sealed;
}

Return Value

Implements

IBackupConnection..::.CurrentBackupSet

See Also

LiveConnection Class
RedGate.BackupReader Namespace


Database Property

[image]

SQL Data Compare API 12.0.40
LiveConnection..::.Database Property
LiveConnection Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Database As String
C#
public string Database { get; }
Visual C++
public:
virtual property String^ Database {
    String^ get () sealed;
}

Return Value

Implements

IDbConnectionDatabase()()()

See Also

LiveConnection Class
RedGate.BackupReader Namespace


DatabaseGuid Property

[image]

SQL Data Compare API 12.0.40
LiveConnection..::.DatabaseGuid Property
LiveConnection Class See Also

Not implemented

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DatabaseGuid As Guid
C#
public Guid DatabaseGuid { get; }
Visual C++
public:
virtual property Guid DatabaseGuid {
    Guid get () sealed;
}

Implements

IBackupConnection..::.DatabaseGuid

See Also

LiveConnection Class
RedGate.BackupReader Namespace


SQLServerInternalVersionNumber Property

[image]

SQL Data Compare API 12.0.40
LiveConnection..::.SQLServerInternalVersionNumber Property
LiveConnection Class See Also

Not valid for this object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SQLServerInternalVersionNumber As Integer
C#
public int SQLServerInternalVersionNumber { get; }
Visual C++
public:
virtual property int SQLServerInternalVersionNumber {
    int get () sealed;
}

Return Value

Implements

IBackupConnection..::.SQLServerInternalVersionNumber

See Also

LiveConnection Class
RedGate.BackupReader Namespace


State Property

[image]

SQL Data Compare API 12.0.40
LiveConnection..::.State Property
LiveConnection Class See Also

Open or Closed

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property State As ConnectionState
C#
public ConnectionState State { get; }
Visual C++
public:
virtual property ConnectionState State {
    ConnectionState get () sealed;
}

Implements

IDbConnectionState()()()

See Also

LiveConnection Class
RedGate.BackupReader Namespace


Status Property

[image]

SQL Data Compare API 12.0.40
LiveConnection..::.Status Property
LiveConnection Class See Also

An event handler for providing progress feedback.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

See Also

LiveConnection Class
RedGate.BackupReader Namespace


Version Property

[image]

SQL Data Compare API 12.0.40
LiveConnection..::.Version Property
LiveConnection Class See Also

Returns 7, 8, 9 - SQL7, SQL2000, SQL2005

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As Integer
C#
public int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () sealed;
}

Implements

IBackupConnection..::.Version

See Also

LiveConnection Class
RedGate.BackupReader Namespace


SqlVariant Class

[image]

SQL Data Compare API 12.0.40
SqlVariant Class
Members See Also

A representation of the SQL_VARIANT data type.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
<StrongNameIdentityPermissionAttribute(SecurityAction.LinkDemand, PublicKey := "0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")> _
Public NotInheritable Class SqlVariant
C#
[StrongNameIdentityPermissionAttribute(SecurityAction.LinkDemand, PublicKey = "0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")]
public sealed class SqlVariant
Visual C++
[StrongNameIdentityPermissionAttribute(SecurityAction::LinkDemand, PublicKey = L"0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")]
public ref class SqlVariant sealed

Inheritance Hierarchy

Object
RedGate.BackupReader..::.SqlVariant

See Also

SqlVariant Members
RedGate.BackupReader Namespace


SqlVariant Members

[image] [image]

SQL Data Compare API 12.0.40
SqlVariant Members
SqlVariant Class Methods Properties See Also

The SqlVariant type exposes the following members.

Methods

Name | Description
Equals | SqlVariant equals The object to compare with (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BaseType | Gets the SQL base type associated with this instance
BaseTypeName | Gets the SQL name associated with this instance
CollationID | Collation ID for string types
Data | The buffer of actual data
MaxLength | Maximum permissible length for string and binary types
Object | Gets the object contained within this SqlVariant object
Precision | Precision value for numeric / decimal types
Scale | Scale value for numeric / decimal types
Version | Version number - always 1 currently

See Also

SqlVariant Class
RedGate.BackupReader Namespace


SqlVariant Methods

[image] [image]

SQL Data Compare API 12.0.40
SqlVariant Methods
SqlVariant Class See Also

The SqlVariant type exposes the following methods.

Methods

Name | Description
Equals | SqlVariant equals The object to compare with (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlVariant Class
RedGate.BackupReader Namespace


Equals Method

[image]

SQL Data Compare API 12.0.40
SqlVariant..::.Equals Method
SqlVariant Class See Also

SqlVariant equals The object to compare with

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object

See Also

SqlVariant Class
RedGate.BackupReader Namespace


SqlVariant Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlVariant Properties
SqlVariant Class See Also

The SqlVariant type exposes the following properties.

Properties

Name | Description
BaseType | Gets the SQL base type associated with this instance
BaseTypeName | Gets the SQL name associated with this instance
CollationID | Collation ID for string types
Data | The buffer of actual data
MaxLength | Maximum permissible length for string and binary types
Object | Gets the object contained within this SqlVariant object
Precision | Precision value for numeric / decimal types
Scale | Scale value for numeric / decimal types
Version | Version number - always 1 currently

See Also

SqlVariant Class
RedGate.BackupReader Namespace


BaseType Property

[image]

SQL Data Compare API 12.0.40
SqlVariant..::.BaseType Property
SqlVariant Class See Also

Gets the SQL base type associated with this instance

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BaseType As BackupSqlType
C#
public BackupSqlType BaseType { get; }
Visual C++
public:
virtual property BackupSqlType BaseType {
    BackupSqlType get () sealed;
}

See Also

SqlVariant Class
RedGate.BackupReader Namespace


BaseTypeName Property

[image]

SQL Data Compare API 12.0.40
SqlVariant..::.BaseTypeName Property
SqlVariant Class See Also

Gets the SQL name associated with this instance

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BaseTypeName As String
C#
public string BaseTypeName { get; }
Visual C++
public:
virtual property String^ BaseTypeName {
    String^ get () sealed;
}

See Also

SqlVariant Class
RedGate.BackupReader Namespace


CollationID Property

[image]

SQL Data Compare API 12.0.40
SqlVariant..::.CollationID Property
SqlVariant Class See Also

Collation ID for string types

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CollationID As Long
C#
public long CollationID { get; }
Visual C++
public:
virtual property long long CollationID {
    long long get () sealed;
}

See Also

SqlVariant Class
RedGate.BackupReader Namespace


Data Property

[image]

SQL Data Compare API 12.0.40
SqlVariant..::.Data Property
SqlVariant Class See Also

The buffer of actual data

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Data As Byte()
C#
public byte[] Data { get; }
Visual C++
public:
virtual property array<unsigned char>^ Data {
    array<unsigned char>^ get () sealed;
}

See Also

SqlVariant Class
RedGate.BackupReader Namespace


MaxLength Property

[image]

SQL Data Compare API 12.0.40
SqlVariant..::.MaxLength Property
SqlVariant Class See Also

Maximum permissible length for string and binary types

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MaxLength As Integer
C#
public int MaxLength { get; }
Visual C++
public:
virtual property int MaxLength {
    int get () sealed;
}

See Also

SqlVariant Class
RedGate.BackupReader Namespace


Object Property

[image]

SQL Data Compare API 12.0.40
SqlVariant..::.Object Property
SqlVariant Class See Also

Gets the object contained within this SqlVariant object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Object As Object
C#
public Object Object { get; }
Visual C++
public:
virtual property Object^ Object {
    Object^ get () sealed;
}

See Also

SqlVariant Class
RedGate.BackupReader Namespace


Precision Property

[image]

SQL Data Compare API 12.0.40
SqlVariant..::.Precision Property
SqlVariant Class See Also

Precision value for numeric / decimal types

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Precision As Byte
C#
public byte Precision { get; }
Visual C++
public:
virtual property unsigned char Precision {
    unsigned char get () sealed;
}

See Also

SqlVariant Class
RedGate.BackupReader Namespace


Scale Property

[image]

SQL Data Compare API 12.0.40
SqlVariant..::.Scale Property
SqlVariant Class See Also

Scale value for numeric / decimal types

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Scale As Byte
C#
public byte Scale { get; }
Visual C++
public:
virtual property unsigned char Scale {
    unsigned char get () sealed;
}

See Also

SqlVariant Class
RedGate.BackupReader Namespace


Version Property

[image]

SQL Data Compare API 12.0.40
SqlVariant..::.Version Property
SqlVariant Class See Also

Version number - always 1 currently

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As Integer
C#
public int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () sealed;
}

See Also

SqlVariant Class
RedGate.BackupReader Namespace


TableName Structure

[image]

SQL Data Compare API 12.0.40
TableName Structure
Members See Also

Representation of a schema-qualified table name, used when populating additional system tables.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Structure TableName
C#
public struct TableName
Visual C++
public value class TableName

See Also

TableName Members
RedGate.BackupReader Namespace


TableName Members

[image] [image]

SQL Data Compare API 12.0.40
TableName Members
TableName Structure Constructors Methods Properties See Also

The TableName type exposes the following members.

Constructors

Name | Description
TableName | Constructs a new TableName structure using the supplied parameters

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
Name | Unqualified object name, e.g. sysobjects
Schema | Schema or owner, e.g. dbo

See Also

TableName Structure
RedGate.BackupReader Namespace


TableName Constructor

[image]

SQL Data Compare API 12.0.40
TableName Constructor
TableName Structure See Also

Constructs a new TableName structure using the supplied parameters

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    schema As String, _
    name As String _
)
C#
public TableName(
    string schema,
    string name
)
Visual C++
public:
TableName(
    String^ schema,
    String^ name
)

Parameters

schema
Type: String
Schema or owner
name
Type: String
Unqualified object name

See Also

TableName Structure
RedGate.BackupReader Namespace


TableName Properties

[image] [image]

SQL Data Compare API 12.0.40
TableName Properties
TableName Structure See Also

The TableName type exposes the following properties.

Properties

Name | Description
Name | Unqualified object name, e.g. sysobjects
Schema | Schema or owner, e.g. dbo

See Also

TableName Structure
RedGate.BackupReader Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
TableName..::.Name Property
TableName Structure See Also

Unqualified object name, e.g. sysobjects

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
}

See Also

TableName Structure
RedGate.BackupReader Namespace


Schema Property

[image]

SQL Data Compare API 12.0.40
TableName..::.Schema Property
TableName Structure See Also

Schema or owner, e.g. dbo

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Schema As String
C#
public string Schema { get; }
Visual C++
public:
virtual property String^ Schema {
    String^ get () sealed;
}

See Also

TableName Structure
RedGate.BackupReader Namespace


RedGate.Shared.SQL Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.Shared.SQL Namespace

Classes

Class | Description
DataSource | Represents a database data source.
DBConnectionInformation | Contains all the information needed to connect to a SQL Server database.
SqlConnectionProperties |
SqlExceptionUtils |

Interfaces

Interface | Description
IDataSource | Represents a database data source.

Enumerations

Enumeration | Description
ObjectType |
SqlVersion |


DataSource Class

[image]

SQL Data Compare API 12.0.40
DataSource Class
Members See Also

Represents a database data source.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public MustInherit Class DataSource _
    Implements IDataSource, ICloneable
C#
[SerializableAttribute]
public abstract class DataSource : IDataSource,
    ICloneable
Visual C++
[SerializableAttribute]
public ref class DataSource abstract : IDataSource,
    ICloneable

Inheritance Hierarchy

Object
RedGate.Shared.SQL..::.DataSource
RedGate.SQLCompare.Engine..::.LiveDatabaseSource
RedGate.SQLCompare.Engine..::.SnapshotSource
RedGate.SQLCompare.Engine..::.SourceControlDataSource
RedGate.SQLCompare.Engine.ReadFromFolder..::.FolderDataSource
RedGate.SQLCompare.Engine.ReadFromBackup..::.BackupDatabaseSource
RedGate.SQLCompare.Engine.Model..::.EmptyDatabaseSource

See Also

DataSource Members
RedGate.Shared.SQL Namespace


DataSource Members

[image] [image]

SQL Data Compare API 12.0.40
DataSource Members
DataSource Class Constructors Methods Properties Explicit Interface Implementations See Also

The DataSource type exposes the following members.

Constructors

Name | Description
DataSource |

Methods

Name | Description
Clone | Creates a clone of the current DataSource.
Deserialize | This method deserializes the object using the specified ISerializeFormatter.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes this object using the specified ISerializeFormatter.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DatabaseName | Gets or sets the name of the database.
IsValid |
IsWriteable | Returns true if this DataSource can be written to.
ServerName | Gets or sets the name of the SQL Server.
Version | Gets the accepted object version number for this object.

Explicit Interface Implementations

Name | Description
ICloneableClone |

See Also

DataSource Class
RedGate.Shared.SQL Namespace


DataSource Constructor

[image]

SQL Data Compare API 12.0.40
DataSource Constructor
DataSource Class See Also

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected DataSource()
Visual C++
protected:
DataSource()

See Also

DataSource Class
RedGate.Shared.SQL Namespace


DataSource Methods

[image] [image]

SQL Data Compare API 12.0.40
DataSource Methods
DataSource Class See Also

The DataSource type exposes the following methods.

Methods

Name | Description
Clone | Creates a clone of the current DataSource.
Deserialize | This method deserializes the object using the specified ISerializeFormatter.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes this object using the specified ISerializeFormatter.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICloneableClone |

See Also

DataSource Class
RedGate.Shared.SQL Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
DataSource..::.Clone Method
DataSource Class See Also

Creates a clone of the current DataSource.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function Clone As IDataSource
C#
public abstract IDataSource Clone()
Visual C++
public:
virtual IDataSource^ Clone() abstract

Implements

IDataSource..::.Clone()()()

See Also

DataSource Class
RedGate.Shared.SQL Namespace


. Method

[image]

SQL Data Compare API 12.0.40
DataSource..::...::. Method
DataSource Class See Also

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Private Function Clone As Object Implements ICloneable.Clone
C#
Object ICloneable.Clone()
Visual C++
private:
virtual Object^ Clone() sealed = ICloneable::Clone

Implements

ICloneableClone()()()

See Also

DataSource Class
RedGate.Shared.SQL Namespace


Deserialize Method

[image]

SQL Data Compare API 12.0.40
DataSource..::.Deserialize Method
DataSource Class See Also

This method deserializes the object using the specified ISerializeFormatter.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function Deserialize ( _
    versionId As Integer, _
    formatter As ISerializeFormatter _
) As Boolean
C#
public abstract bool Deserialize(
    int versionId,
    ISerializeFormatter formatter
)
Visual C++
public:
virtual bool Deserialize(
    int versionId,
    ISerializeFormatter^ formatter
) abstract

Parameters

versionId
Type: Int32
The version of the serialized data.
formatter
Type: ISerializeFormatter
The serialization formatter to use.

Return Value

True if deserialized successfully, false if deserialization fails or versionId is not recognised.

See Also

DataSource Class
RedGate.Shared.SQL Namespace


Serialize Method

[image]

SQL Data Compare API 12.0.40
DataSource..::.Serialize Method
DataSource Class See Also

Serializes this object using the specified ISerializeFormatter.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Serialize ( _
    formatter As ISerializeFormatter _
)
C#
public abstract void Serialize(
    ISerializeFormatter formatter
)
Visual C++
public:
virtual void Serialize(
    ISerializeFormatter^ formatter
) abstract

Parameters

formatter
Type: ISerializeFormatter
The serialization formatter to use.

See Also

DataSource Class
RedGate.Shared.SQL Namespace


DataSource Properties

[image] [image]

SQL Data Compare API 12.0.40
DataSource Properties
DataSource Class See Also

The DataSource type exposes the following properties.

Properties

Name | Description
DatabaseName | Gets or sets the name of the database.
IsValid |
IsWriteable | Returns true if this DataSource can be written to.
ServerName | Gets or sets the name of the SQL Server.
Version | Gets the accepted object version number for this object.

See Also

DataSource Class
RedGate.Shared.SQL Namespace


DatabaseName Property

[image]

SQL Data Compare API 12.0.40
DataSource..::.DatabaseName Property
DataSource Class See Also

Gets or sets the name of the database.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Property DatabaseName As String
C#
public abstract string DatabaseName { get; set; }
Visual C++
public:
virtual property String^ DatabaseName {
    String^ get () abstract;
    void set (String^ value) abstract;
}

Implements

IDataSource..::.DatabaseName

See Also

DataSource Class
RedGate.Shared.SQL Namespace


IsValid Property

[image]

SQL Data Compare API 12.0.40
DataSource..::.IsValid Property
DataSource Class See Also

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property IsValid As Boolean
C#
public abstract bool IsValid { get; }
Visual C++
public:
virtual property bool IsValid {
    bool get () abstract;
}

Implements

IDataSource..::.IsValid

See Also

DataSource Class
RedGate.Shared.SQL Namespace


IsWriteable Property

[image]

SQL Data Compare API 12.0.40
DataSource..::.IsWriteable Property
DataSource Class See Also

Returns true if this DataSource can be written to.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property IsWriteable As Boolean
C#
public abstract bool IsWriteable { get; }
Visual C++
public:
virtual property bool IsWriteable {
    bool get () abstract;
}

Implements

IDataSource..::.IsWriteable

See Also

DataSource Class
RedGate.Shared.SQL Namespace


ServerName Property

[image]

SQL Data Compare API 12.0.40
DataSource..::.ServerName Property
DataSource Class See Also

Gets or sets the name of the SQL Server.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Property ServerName As String
C#
public abstract string ServerName { get; set; }
Visual C++
public:
virtual property String^ ServerName {
    String^ get () abstract;
    void set (String^ value) abstract;
}

Implements

IDataSource..::.ServerName

See Also

DataSource Class
RedGate.Shared.SQL Namespace


Version Property

[image]

SQL Data Compare API 12.0.40
DataSource..::.Version Property
DataSource Class See Also

Gets the accepted object version number for this object.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Version As Integer
C#
public abstract int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () abstract;
}

See Also

DataSource Class
RedGate.Shared.SQL Namespace


DBConnectionInformation Class

[image]

SQL Data Compare API 12.0.40
DBConnectionInformation Class
Members See Also

Contains all the information needed to connect to a SQL Server database.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class DBConnectionInformation
C#
[SerializableAttribute]
public sealed class DBConnectionInformation
Visual C++
[SerializableAttribute]
public ref class DBConnectionInformation sealed

Inheritance Hierarchy

Object
RedGate.Shared.SQL..::.DBConnectionInformation

See Also

DBConnectionInformation Members
RedGate.Shared.SQL Namespace


DBConnectionInformation Members

[image] [image]

SQL Data Compare API 12.0.40
DBConnectionInformation Members
DBConnectionInformation Class Constructors Methods Properties See Also

The DBConnectionInformation type exposes the following members.

Constructors

Name | Description
DBConnectionInformation | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DatabaseName | The database to connect to.
IntegratedSecurity | If true, integrated authentication will be used. If false, SQL Server authentication will be used.
Password | The password to use if using SQL Server authentication.
ServerName | The server to connect to.
UserName | The user to connect as if using SQL Server authentication.

See Also

DBConnectionInformation Class
RedGate.Shared.SQL Namespace


DBConnectionInformation Constructor

[image] [image]

SQL Data Compare API 12.0.40
DBConnectionInformation Constructor
DBConnectionInformation Class See Also

Overload List

Name | Description
DBConnectionInformation(String, String) | Constructs a new DBConnectionInformation object using integrated authentication (also known as Windows authentication).
DBConnectionInformation(String, String, String, String) | Constructs a new DBConnectionInformation object using SQL Server authentication.

See Also

DBConnectionInformation Class
DBConnectionInformation Members
RedGate.Shared.SQL Namespace


DBConnectionInformation Constructor (, )

[image]

SQL Data Compare API 12.0.40
DBConnectionInformation Constructor (, )
DBConnectionInformation Class See Also

Constructs a new DBConnectionInformation object using integrated authentication (also known as Windows authentication).

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    serverName As String, _
    databaseName As String _
)
C#
public DBConnectionInformation(
    string serverName,
    string databaseName
)
Visual C++
public:
DBConnectionInformation(
    String^ serverName,
    String^ databaseName
)

Parameters

serverName
Type: String
The server to connect to.
databaseName
Type: String
The database to connect to.

See Also

DBConnectionInformation Class
DBConnectionInformation Overload
RedGate.Shared.SQL Namespace


DBConnectionInformation Constructor (, , , )

[image]

SQL Data Compare API 12.0.40
DBConnectionInformation Constructor (, , , )
DBConnectionInformation Class See Also

Constructs a new DBConnectionInformation object using SQL Server authentication.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    serverName As String, _
    databaseName As String, _
    userName As String, _
    password As String _
)
C#
public DBConnectionInformation(
    string serverName,
    string databaseName,
    string userName,
    string password
)
Visual C++
public:
DBConnectionInformation(
    String^ serverName,
    String^ databaseName,
    String^ userName,
    String^ password
)

Parameters

serverName
Type: String
The server to connect to.
databaseName
Type: String
The database to connect to.
userName
Type: String
The user to connect as.
password
Type: String
The password to use.

See Also

DBConnectionInformation Class
DBConnectionInformation Overload
RedGate.Shared.SQL Namespace


DBConnectionInformation Properties

[image] [image]

SQL Data Compare API 12.0.40
DBConnectionInformation Properties
DBConnectionInformation Class See Also

The DBConnectionInformation type exposes the following properties.

Properties

Name | Description
DatabaseName | The database to connect to.
IntegratedSecurity | If true, integrated authentication will be used. If false, SQL Server authentication will be used.
Password | The password to use if using SQL Server authentication.
ServerName | The server to connect to.
UserName | The user to connect as if using SQL Server authentication.

See Also

DBConnectionInformation Class
RedGate.Shared.SQL Namespace


DatabaseName Property

[image]

SQL Data Compare API 12.0.40
DBConnectionInformation..::.DatabaseName Property
DBConnectionInformation Class See Also

The database to connect to.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DatabaseName As String
C#
public string DatabaseName { get; }
Visual C++
public:
property String^ DatabaseName {
    String^ get ();
}

See Also

DBConnectionInformation Class
RedGate.Shared.SQL Namespace


IntegratedSecurity Property

[image]

SQL Data Compare API 12.0.40
DBConnectionInformation..::.IntegratedSecurity Property
DBConnectionInformation Class See Also

If true, integrated authentication will be used. If false, SQL Server authentication will be used.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IntegratedSecurity As Boolean
C#
public bool IntegratedSecurity { get; }
Visual C++
public:
property bool IntegratedSecurity {
    bool get ();
}

See Also

DBConnectionInformation Class
RedGate.Shared.SQL Namespace


Password Property

[image]

SQL Data Compare API 12.0.40
DBConnectionInformation..::.Password Property
DBConnectionInformation Class See Also

The password to use if using SQL Server authentication.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Password As String
C#
public string Password { get; }
Visual C++
public:
property String^ Password {
    String^ get ();
}

See Also

DBConnectionInformation Class
RedGate.Shared.SQL Namespace


ServerName Property

[image]

SQL Data Compare API 12.0.40
DBConnectionInformation..::.ServerName Property
DBConnectionInformation Class See Also

The server to connect to.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ServerName As String
C#
public string ServerName { get; }
Visual C++
public:
property String^ ServerName {
    String^ get ();
}

See Also

DBConnectionInformation Class
RedGate.Shared.SQL Namespace


UserName Property

[image]

SQL Data Compare API 12.0.40
DBConnectionInformation..::.UserName Property
DBConnectionInformation Class See Also

The user to connect as if using SQL Server authentication.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UserName As String
C#
public string UserName { get; }
Visual C++
public:
property String^ UserName {
    String^ get ();
}

See Also

DBConnectionInformation Class
RedGate.Shared.SQL Namespace


IDataSource Interface

[image]

SQL Data Compare API 12.0.40
IDataSource Interface
Members See Also

Represents a database data source.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDataSource
C#
public interface IDataSource
Visual C++
public interface class IDataSource

See Also

IDataSource Members
RedGate.Shared.SQL Namespace


IDataSource Members

[image] [image]

SQL Data Compare API 12.0.40
IDataSource Members
IDataSource Interface Methods Properties See Also

The IDataSource type exposes the following members.

Methods

Name | Description
Clone | Creates a clone of this IDataSource.

Properties

Name | Description
DatabaseName | Gets or sets the data source database name.
IsValid |
IsWriteable | Gets a value indicating if this data source can be written to.
ServerName | Gets or sets the data source server name.

See Also

IDataSource Interface
RedGate.Shared.SQL Namespace


IDataSource Methods

[image] [image]

SQL Data Compare API 12.0.40
IDataSource Methods
IDataSource Interface See Also

The IDataSource type exposes the following methods.

Methods

Name | Description
Clone | Creates a clone of this IDataSource.

See Also

IDataSource Interface
RedGate.Shared.SQL Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
IDataSource..::.Clone Method
IDataSource Interface See Also

Creates a clone of this IDataSource.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Function Clone As IDataSource
C#
IDataSource Clone()
Visual C++
IDataSource^ Clone()

Return Value

A clone of this IDataSource.

See Also

IDataSource Interface
RedGate.Shared.SQL Namespace


IDataSource Properties

[image] [image]

SQL Data Compare API 12.0.40
IDataSource Properties
IDataSource Interface See Also

The IDataSource type exposes the following properties.

Properties

Name | Description
DatabaseName | Gets or sets the data source database name.
IsValid |
IsWriteable | Gets a value indicating if this data source can be written to.
ServerName | Gets or sets the data source server name.

See Also

IDataSource Interface
RedGate.Shared.SQL Namespace


DatabaseName Property

[image]

SQL Data Compare API 12.0.40
IDataSource..::.DatabaseName Property
IDataSource Interface See Also

Gets or sets the data source database name.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Property DatabaseName As String
C#
string DatabaseName { get; set; }
Visual C++
property String^ DatabaseName {
    String^ get ();
    void set (String^ value);
}

See Also

IDataSource Interface
RedGate.Shared.SQL Namespace


IsValid Property

[image]

SQL Data Compare API 12.0.40
IDataSource..::.IsValid Property
IDataSource Interface See Also

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsValid As Boolean
C#
bool IsValid { get; }
Visual C++
property bool IsValid {
    bool get ();
}

See Also

IDataSource Interface
RedGate.Shared.SQL Namespace


IsWriteable Property

[image]

SQL Data Compare API 12.0.40
IDataSource..::.IsWriteable Property
IDataSource Interface See Also

Gets a value indicating if this data source can be written to.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsWriteable As Boolean
C#
bool IsWriteable { get; }
Visual C++
property bool IsWriteable {
    bool get ();
}

See Also

IDataSource Interface
RedGate.Shared.SQL Namespace


ServerName Property

[image]

SQL Data Compare API 12.0.40
IDataSource..::.ServerName Property
IDataSource Interface See Also

Gets or sets the data source server name.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Property ServerName As String
C#
string ServerName { get; set; }
Visual C++
property String^ ServerName {
    String^ get ();
    void set (String^ value);
}

See Also

IDataSource Interface
RedGate.Shared.SQL Namespace


ObjectType Enumeration

[image]

SQL Data Compare API 12.0.40
ObjectType Enumeration
See Also

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration ObjectType
C#
public enum ObjectType
Visual C++
public enum class ObjectType

Members

Member name | Description
Assembly |
AsymmetricKey |
Certificate |
Contract |
DdlTrigger |
Default |
EventNotification |
ExtendedProperty |
FullTextCatalog |
FullTextStoplist |
Function_Aggregate |
Function_UserDefinedFunction_Table |
Function_UserDefinedFunction_Scalar |
MessageType |
PartitionFunction |
PartitionScheme |
Queue |
Role_ApplicationRole |
Role_Role |
Route |
Rule |
Schema |
SearchPropertyList |
SecurityPolicy |
Sequence |
Service |
ServiceBinding |
StoredProcedure |
SymmetricKey |
Synonym |
Table |
User |
UserDefinedType_UserDefinedDataType |
UserDefinedType_UserDefinedTableType |
UserDefinedType_UserDefinedType |
View |
XmlSchemaCollection |
Constraint |
TableKey |
DmlTrigger |

See Also

RedGate.Shared.SQL Namespace


SqlConnectionProperties Class

[image]

SQL Data Compare API 12.0.40
SqlConnectionProperties Class
Members See Also

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class SqlConnectionProperties
C#
[SerializableAttribute]
public class SqlConnectionProperties
Visual C++
[SerializableAttribute]
public ref class SqlConnectionProperties

Inheritance Hierarchy

Object
RedGate.Shared.SQL..::.SqlConnectionProperties
RedGate.SQLCompare.Engine..::.ConnectionProperties

See Also

SqlConnectionProperties Members
RedGate.Shared.SQL Namespace


SqlConnectionProperties Members

[image] [image]

SQL Data Compare API 12.0.40
SqlConnectionProperties Members
SqlConnectionProperties Class Constructors Methods Fields Properties See Also

The SqlConnectionProperties type exposes the following members.

Constructors

Name | Description
SqlConnectionProperties | Overloaded.

Methods

Name | Description
BuildConnectionString |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromSqlConnectionProperties |
FromSqlConnectionStringBuilder |
GetCachedConnectionString |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToDBConnectionInformation | Returns a DBConnectionInformation object representing the current connection properties.
ToString | (Overrides Object..::.ToString()()().)

Fields

Name | Description
m_ConnectionString |
m_DatabaseName |
m_IntegratedSecurity |
m_ServerName |
m_UserName |

Properties

Name | Description
ConnectionString |
DatabaseName | The name of the database to connect to.
EncryptedPassword |
IntegratedSecurity | True to use integrated authentication, false for SQL Server authentication.
Password | The password to use when connecting to the SQL Server.
ServerName | The name of the SQL Server to connect to.
UserName | The user name to use when connecting to the SQL Server.

See Also

SqlConnectionProperties Class
RedGate.Shared.SQL Namespace


SqlConnectionProperties Constructor

[image] [image]

SQL Data Compare API 12.0.40
SqlConnectionProperties Constructor
SqlConnectionProperties Class See Also

Overload List

Name | Description
SqlConnectionProperties()()() | Constructor for the ConnectionProperties class.
SqlConnectionProperties(String, String) | Constructor for integrated security.
SqlConnectionProperties(String, String, String, String) | Constructor for SQL security.

See Also

SqlConnectionProperties Class
SqlConnectionProperties Members
RedGate.Shared.SQL Namespace


SqlConnectionProperties Constructor

[image]

SQL Data Compare API 12.0.40
SqlConnectionProperties Constructor
SqlConnectionProperties Class See Also

Constructor for the ConnectionProperties class.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlConnectionProperties()
Visual C++
public:
SqlConnectionProperties()

See Also

SqlConnectionProperties Class
SqlConnectionProperties Overload
RedGate.Shared.SQL Namespace


SqlConnectionProperties Constructor (, )

[image]

SQL Data Compare API 12.0.40
SqlConnectionProperties Constructor (, )
SqlConnectionProperties Class See Also

Constructor for integrated security.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    serverName As String, _
    databaseName As String _
)
C#
public SqlConnectionProperties(
    string serverName,
    string databaseName
)
Visual C++
public:
SqlConnectionProperties(
    String^ serverName,
    String^ databaseName
)

Parameters

serverName
Type: String
The SQL Server name.
databaseName
Type: String
The database name.

See Also

SqlConnectionProperties Class
SqlConnectionProperties Overload
RedGate.Shared.SQL Namespace


SqlConnectionProperties Constructor (, , , )

[image]

SQL Data Compare API 12.0.40
SqlConnectionProperties Constructor (, , , )
SqlConnectionProperties Class See Also

Constructor for SQL security.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    serverName As String, _
    databaseName As String, _
    userName As String, _
    password As String _
)
C#
public SqlConnectionProperties(
    string serverName,
    string databaseName,
    string userName,
    string password
)
Visual C++
public:
SqlConnectionProperties(
    String^ serverName,
    String^ databaseName,
    String^ userName,
    String^ password
)

Parameters

serverName
Type: String
The SQL Server name.
databaseName
Type: String
The database name.
userName
Type: String
The user name to use to connect to the SQL Server.
password
Type: String
The password to use to connect to the SQL Server.

See Also

SqlConnectionProperties Class
SqlConnectionProperties Overload
RedGate.Shared.SQL Namespace


SqlConnectionProperties Fields

[image] [image]

SQL Data Compare API 12.0.40
SqlConnectionProperties Fields
SqlConnectionProperties Class See Also

The SqlConnectionProperties type exposes the following fields.

Fields

Name | Description
m_ConnectionString |
m_DatabaseName |
m_IntegratedSecurity |
m_ServerName |
m_UserName |

See Also

SqlConnectionProperties Class
RedGate.Shared.SQL Namespace


m_ConnectionString Field

[image]

SQL Data Compare API 12.0.40
SqlConnectionProperties..::.m_ConnectionString Field
SqlConnectionProperties Class See Also

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Protected m_ConnectionString As String
C#
protected string m_ConnectionString
Visual C++
protected:
String^ m_ConnectionString

See Also

SqlConnectionProperties Class
RedGate.Shared.SQL Namespace


m_DatabaseName Field

[image]

SQL Data Compare API 12.0.40
SqlConnectionProperties..::.m_DatabaseName Field
SqlConnectionProperties Class See Also

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Protected m_DatabaseName As String
C#
protected string m_DatabaseName
Visual C++
protected:
String^ m_DatabaseName

See Also

SqlConnectionProperties Class
RedGate.Shared.SQL Namespace


m_IntegratedSecurity Field

[image]

SQL Data Compare API 12.0.40
SqlConnectionProperties..::.m_IntegratedSecurity Field
SqlConnectionProperties Class See Also

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Protected m_IntegratedSecurity As Boolean
C#
protected bool m_IntegratedSecurity
Visual C++
protected:
bool m_IntegratedSecurity

See Also

SqlConnectionProperties Class
RedGate.Shared.SQL Namespace


m_ServerName Field

[image]

SQL Data Compare API 12.0.40
SqlConnectionProperties..::.m_ServerName Field
SqlConnectionProperties Class See Also

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Protected m_ServerName As String
C#
protected string m_ServerName
Visual C++
protected:
String^ m_ServerName

See Also

SqlConnectionProperties Class
RedGate.Shared.SQL Namespace


m_UserName Field

[image]

SQL Data Compare API 12.0.40
SqlConnectionProperties..::.m_UserName Field
SqlConnectionProperties Class See Also

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Protected m_UserName As String
C#
protected string m_UserName
Visual C++
protected:
String^ m_UserName

See Also

SqlConnectionProperties Class
RedGate.Shared.SQL Namespace


SqlConnectionProperties Methods

[image] [image]

SQL Data Compare API 12.0.40
SqlConnectionProperties Methods
SqlConnectionProperties Class See Also

The SqlConnectionProperties type exposes the following methods.

Methods

Name | Description
BuildConnectionString |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromSqlConnectionProperties |
FromSqlConnectionStringBuilder |
GetCachedConnectionString |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToDBConnectionInformation | Returns a DBConnectionInformation object representing the current connection properties.
ToString | (Overrides Object..::.ToString()()().)

See Also

SqlConnectionProperties Class
RedGate.Shared.SQL Namespace


BuildConnectionString Method

[image]

SQL Data Compare API 12.0.40
SqlConnectionProperties..::.BuildConnectionString Method
SqlConnectionProperties Class See Also

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Protected Function BuildConnectionString As String
C#
protected string BuildConnectionString()
Visual C++
protected:
String^ BuildConnectionString()

See Also

SqlConnectionProperties Class
RedGate.Shared.SQL Namespace


FromSqlConnectionProperties Method

[image]

SQL Data Compare API 12.0.40
SqlConnectionProperties..::.FromSqlConnectionProperties Method
SqlConnectionProperties Class See Also

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FromSqlConnectionProperties ( _
    properties As SqlConnectionProperties _
) As SqlConnectionProperties
C#
public static SqlConnectionProperties FromSqlConnectionProperties(
    SqlConnectionProperties properties
)
Visual C++
public:
static SqlConnectionProperties^ FromSqlConnectionProperties(
    SqlConnectionProperties^ properties
)

Parameters

properties
Type: RedGate.Shared.SQL..::.SqlConnectionProperties

See Also

SqlConnectionProperties Class
RedGate.Shared.SQL Namespace


FromSqlConnectionStringBuilder Method

[image]

SQL Data Compare API 12.0.40
SqlConnectionProperties..::.FromSqlConnectionStringBuilder Method
SqlConnectionProperties Class See Also

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FromSqlConnectionStringBuilder ( _
    connectionStringBuilder As SqlConnectionStringBuilder _
) As SqlConnectionProperties
C#
public static SqlConnectionProperties FromSqlConnectionStringBuilder(
    SqlConnectionStringBuilder connectionStringBuilder
)
Visual C++
public:
static SqlConnectionProperties^ FromSqlConnectionStringBuilder(
    SqlConnectionStringBuilder^ connectionStringBuilder
)

Parameters

connectionStringBuilder
Type: SqlConnectionStringBuilder

See Also

SqlConnectionProperties Class
RedGate.Shared.SQL Namespace


GetCachedConnectionString Method

[image]

SQL Data Compare API 12.0.40
SqlConnectionProperties..::.GetCachedConnectionString Method
SqlConnectionProperties Class See Also

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetCachedConnectionString As String
C#
protected string GetCachedConnectionString()
Visual C++
protected:
String^ GetCachedConnectionString()

See Also

SqlConnectionProperties Class
RedGate.Shared.SQL Namespace


ToDBConnectionInformation Method

[image]

SQL Data Compare API 12.0.40
SqlConnectionProperties..::.ToDBConnectionInformation Method
SqlConnectionProperties Class See Also

Returns a DBConnectionInformation object representing the current connection properties.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Function ToDBConnectionInformation As DBConnectionInformation
C#
public DBConnectionInformation ToDBConnectionInformation()
Visual C++
public:
DBConnectionInformation^ ToDBConnectionInformation()

Return Value

A DBConnectionInformation object with the same connection information as this object.

Remarks

This can be passed to [!:BlockExecutor.ExecuteBlock(ExecutionBlock,DBConnectionInformation)] to use these connection properties to run a synchronization script on the database represented by the current ConnectionProperties object.

See Also

SqlConnectionProperties Class
RedGate.Shared.SQL Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
SqlConnectionProperties..::.ToString Method
SqlConnectionProperties Class See Also

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

See Also

SqlConnectionProperties Class
RedGate.Shared.SQL Namespace


SqlConnectionProperties Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlConnectionProperties Properties
SqlConnectionProperties Class See Also

The SqlConnectionProperties type exposes the following properties.

Properties

Name | Description
ConnectionString |
DatabaseName | The name of the database to connect to.
EncryptedPassword |
IntegratedSecurity | True to use integrated authentication, false for SQL Server authentication.
Password | The password to use when connecting to the SQL Server.
ServerName | The name of the SQL Server to connect to.
UserName | The user name to use when connecting to the SQL Server.

See Also

SqlConnectionProperties Class
RedGate.Shared.SQL Namespace


ConnectionString Property

[image]

SQL Data Compare API 12.0.40
SqlConnectionProperties..::.ConnectionString Property
SqlConnectionProperties Class See Also

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConnectionString As String
C#
public string ConnectionString { get; }
Visual C++
public:
property String^ ConnectionString {
    String^ get ();
}

See Also

SqlConnectionProperties Class
RedGate.Shared.SQL Namespace


DatabaseName Property

[image]

SQL Data Compare API 12.0.40
SqlConnectionProperties..::.DatabaseName Property
SqlConnectionProperties Class See Also

The name of the database to connect to.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property DatabaseName As String
C#
public string DatabaseName { get; set; }
Visual C++
public:
property String^ DatabaseName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlConnectionProperties Class
RedGate.Shared.SQL Namespace


EncryptedPassword Property

[image]

SQL Data Compare API 12.0.40
SqlConnectionProperties..::.EncryptedPassword Property
SqlConnectionProperties Class See Also

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Protected Property EncryptedPassword As Byte()
C#
protected byte[] EncryptedPassword { get; set; }
Visual C++
protected:
property array<unsigned char>^ EncryptedPassword {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

SqlConnectionProperties Class
RedGate.Shared.SQL Namespace


IntegratedSecurity Property

[image]

SQL Data Compare API 12.0.40
SqlConnectionProperties..::.IntegratedSecurity Property
SqlConnectionProperties Class See Also

True to use integrated authentication, false for SQL Server authentication.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property IntegratedSecurity As Boolean
C#
public bool IntegratedSecurity { get; set; }
Visual C++
public:
property bool IntegratedSecurity {
    bool get ();
    void set (bool value);
}

See Also

SqlConnectionProperties Class
RedGate.Shared.SQL Namespace


Password Property

[image]

SQL Data Compare API 12.0.40
SqlConnectionProperties..::.Password Property
SqlConnectionProperties Class See Also

The password to use when connecting to the SQL Server.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password { get; set; }
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

SqlConnectionProperties Class
RedGate.Shared.SQL Namespace


ServerName Property

[image]

SQL Data Compare API 12.0.40
SqlConnectionProperties..::.ServerName Property
SqlConnectionProperties Class See Also

The name of the SQL Server to connect to.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property ServerName As String
C#
public string ServerName { get; set; }
Visual C++
public:
property String^ ServerName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlConnectionProperties Class
RedGate.Shared.SQL Namespace


UserName Property

[image]

SQL Data Compare API 12.0.40
SqlConnectionProperties..::.UserName Property
SqlConnectionProperties Class See Also

The user name to use when connecting to the SQL Server.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property UserName As String
C#
public string UserName { get; set; }
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlConnectionProperties Class
RedGate.Shared.SQL Namespace


SqlExceptionUtils Class

[image]

SQL Data Compare API 12.0.40
SqlExceptionUtils Class
Members See Also

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SqlExceptionUtils
C#
public static class SqlExceptionUtils
Visual C++
public ref class SqlExceptionUtils abstract sealed

Inheritance Hierarchy

Object
RedGate.Shared.SQL..::.SqlExceptionUtils

See Also

SqlExceptionUtils Members
RedGate.Shared.SQL Namespace


SqlExceptionUtils Members

[image] [image]

SQL Data Compare API 12.0.40
SqlExceptionUtils Members
SqlExceptionUtils Class Methods See Also

The SqlExceptionUtils type exposes the following members.

Methods

Name | Description
IsFailureConnectingToDatabase |

See Also

SqlExceptionUtils Class
RedGate.Shared.SQL Namespace


SqlExceptionUtils Methods

[image] [image]

SQL Data Compare API 12.0.40
SqlExceptionUtils Methods
SqlExceptionUtils Class See Also

The SqlExceptionUtils type exposes the following methods.

Methods

Name | Description
IsFailureConnectingToDatabase |

See Also

SqlExceptionUtils Class
RedGate.Shared.SQL Namespace


IsFailureConnectingToDatabase Method

[image]

SQL Data Compare API 12.0.40
SqlExceptionUtils..::.IsFailureConnectingToDatabase Method
SqlExceptionUtils Class See Also

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsFailureConnectingToDatabase ( _
    sqlException As SqlException _
) As Boolean
C#
public static bool IsFailureConnectingToDatabase(
    SqlException sqlException
)
Visual C++
public:
static bool IsFailureConnectingToDatabase(
    SqlException^ sqlException
)

Parameters

sqlException
Type: SqlException

Remarks

There are possibly a few obscure cases that we don't handle properly, see: (1) ^/CurrentProjects/SharedDbaTools/Trunk/RedGate.DbaTools.Sql/Server/SqlErrorNumber.cs and (2) ^/CurrentProjects/SQLResponse/Trunk/Source/Common/Utilities/Sql/SqlMessageId.cs

See Also

SqlExceptionUtils Class
RedGate.Shared.SQL Namespace


SqlVersion Enumeration

[image]

SQL Data Compare API 12.0.40
SqlVersion Enumeration
See Also

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration SqlVersion
C#
public enum SqlVersion
Visual C++
public enum class SqlVersion

Members

Member name | Description
Unknown |
Sql7 |
Sql2000 |
Sql2005 |
Katmai |
Sql2012 |
Sql2014 |
Sql2016 |

See Also

RedGate.Shared.SQL Namespace


RedGate.Shared.SQL.BackupReaderInterfaces Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.Shared.SQL.BackupReaderInterfaces Namespace

Interfaces

Interface | Description
IBackupConnection | A base interface for Backup Connections
IBackupSet | A base interface for a BackupSet

Enumerations

Enumeration | Description
BackupType | The backup type - full, differential etc.


BackupType Enumeration

[image]

SQL Data Compare API 12.0.40
BackupType Enumeration
See Also

The backup type - full, differential etc.

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration BackupType
C#
public enum BackupType
Visual C++
public enum class BackupType

Members

Member name | Description
Other | Unknown or other type
Full | Full backup
Differential | Differential backup
Log | Transaction log backup
Partial | Partial backup
FileGroup | File / filegroup backup

See Also

RedGate.Shared.SQL.BackupReaderInterfaces Namespace


IBackupConnection Interface

[image]

SQL Data Compare API 12.0.40
IBackupConnection Interface
Members See Also

A base interface for Backup Connections

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Interface IBackupConnection _
    Implements IDbConnection, IDisposable, ICancellable
C#
public interface IBackupConnection : IDbConnection,
    IDisposable, ICancellable
Visual C++
public interface class IBackupConnection : IDbConnection,
    IDisposable, ICancellable

See Also

IBackupConnection Members
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


IBackupConnection Members

[image] [image]

SQL Data Compare API 12.0.40
IBackupConnection Members
IBackupConnection Interface Methods Properties See Also

The IBackupConnection type exposes the following members.

Methods

Name | Description
BeginTransaction | Overloaded.
CancelOperation | Cancels the current running operation. This will throw an instance of OperationCancelledException at the currently executing location on the executing thread (Inherited from ICancellable.)
ChangeDatabase | Changes the current database for an open Connection object. (Inherited from IDbConnection.)
Close | Closes the connection to the database. (Inherited from IDbConnection.)
CreateCommand | Creates and returns a Command object associated with the connection. (Inherited from IDbConnection.)
CreateSysTableCommand | Generate a command to run against the Backup Reader's system table store.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
GetBackupSets | Get the list of BackupSets linked to the connection.
IsPasswordRequired | Whether a password is required
Open | Opens a database connection with the settings specified by the ConnectionString property of the provider-specific Connection object. (Inherited from IDbConnection.)
OpenForMetaInformation | A quick open that just populates the meta information
PopulateAdditionalSystemTables | Overloaded.
UseBackupSet | Select the BackupSet to use in the connection.

Properties

Name | Description
BackupTemporaryDirectory | All Backup Temp files will be placed in this directory - due to handle persistance in the UI the UI can delete this directory on shutdown to eliminate all Backup Files
CompatibilityVersion | Compatibility version number
ConnectionString | Gets or sets the string used to open a database. (Inherited from IDbConnection.)
ConnectionTimeout | Gets the time to wait while trying to establish a connection before terminating the attempt and generating an error. (Inherited from IDbConnection.)
CurrentBackupSet | The current backup set being used.
Database | Gets the name of the current database or the database to be used after a connection is opened. (Inherited from IDbConnection.)
DatabaseGuid | Database GUID (syscomments for SS2000 requires this)
SQLServerInternalVersionNumber | SQL Server implementation dependent version number
State | Gets the current state of the connection. (Inherited from IDbConnection.)
Status | Gets and sets a delegate that can be used to notify of message or percentage changes (Inherited from ICancellable.)
Version | The external version number (e.g. 10 for SS2008)

See Also

IBackupConnection Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


IBackupConnection Methods

[image] [image]

SQL Data Compare API 12.0.40
IBackupConnection Methods
IBackupConnection Interface See Also

The IBackupConnection type exposes the following methods.

Methods

Name | Description
BeginTransaction | Overloaded.
CancelOperation | Cancels the current running operation. This will throw an instance of OperationCancelledException at the currently executing location on the executing thread (Inherited from ICancellable.)
ChangeDatabase | Changes the current database for an open Connection object. (Inherited from IDbConnection.)
Close | Closes the connection to the database. (Inherited from IDbConnection.)
CreateCommand | Creates and returns a Command object associated with the connection. (Inherited from IDbConnection.)
CreateSysTableCommand | Generate a command to run against the Backup Reader's system table store.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
GetBackupSets | Get the list of BackupSets linked to the connection.
IsPasswordRequired | Whether a password is required
Open | Opens a database connection with the settings specified by the ConnectionString property of the provider-specific Connection object. (Inherited from IDbConnection.)
OpenForMetaInformation | A quick open that just populates the meta information
PopulateAdditionalSystemTables | Overloaded.
UseBackupSet | Select the BackupSet to use in the connection.

See Also

IBackupConnection Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


BeginTransaction Method

[image] [image]

SQL Data Compare API 12.0.40
IBackupConnection..::.BeginTransaction Method
IBackupConnection Interface See Also

Overload List

Name | Description
BeginTransaction()()() | Begins a database transaction. (Inherited from IDbConnection.)
BeginTransaction(IsolationLevel) | Begins a database transaction with the specified IsolationLevel value. (Inherited from IDbConnection.)

See Also

IBackupConnection Interface
IBackupConnection Members
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


CreateSysTableCommand Method

[image]

SQL Data Compare API 12.0.40
IBackupConnection..::.CreateSysTableCommand Method
IBackupConnection Interface See Also

Generate a command to run against the Backup Reader's system table store.

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Function CreateSysTableCommand As IDbCommand
C#
IDbCommand CreateSysTableCommand()
Visual C++
IDbCommand^ CreateSysTableCommand()

Return Value

The IDbCommand for execution against the system table store

See Also

IBackupConnection Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


GetBackupSets Method

[image]

SQL Data Compare API 12.0.40
IBackupConnection..::.GetBackupSets Method
IBackupConnection Interface See Also

Get the list of BackupSets linked to the connection.

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Function GetBackupSets As IList(Of IBackupSet)
C#
IList<IBackupSet> GetBackupSets()
Visual C++
IList<IBackupSet^>^ GetBackupSets()

Return Value

List of BackupSets

See Also

IBackupConnection Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


IsPasswordRequired Method

[image]

SQL Data Compare API 12.0.40
IBackupConnection..::.IsPasswordRequired Method
IBackupConnection Interface See Also

Whether a password is required

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Function IsPasswordRequired As Boolean
C#
bool IsPasswordRequired()
Visual C++
bool IsPasswordRequired()

Return Value

True if required, false otherwise

See Also

IBackupConnection Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


OpenForMetaInformation Method

[image]

SQL Data Compare API 12.0.40
IBackupConnection..::.OpenForMetaInformation Method
IBackupConnection Interface See Also

A quick open that just populates the meta information

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Sub OpenForMetaInformation
C#
void OpenForMetaInformation()
Visual C++
void OpenForMetaInformation()

See Also

IBackupConnection Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


PopulateAdditionalSystemTables Method

[image] [image]

SQL Data Compare API 12.0.40
IBackupConnection..::.PopulateAdditionalSystemTables Method
IBackupConnection Interface See Also

Overload List

Name | Description
PopulateAdditionalSystemTables(array<ITableName>[]()[]) | Populate System Tables not populated by the BackupConnection by default
PopulateAdditionalSystemTables(List<(Of <(ITableName>)>)) | Populate System Tables not populated by the BackupConnection by default

See Also

IBackupConnection Interface
IBackupConnection Members
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


PopulateAdditionalSystemTables Method ([])

[image]

SQL Data Compare API 12.0.40
IBackupConnection..::.PopulateAdditionalSystemTables Method (array<>[]()[])
IBackupConnection Interface See Also

Populate System Tables not populated by the BackupConnection by default

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Sub PopulateAdditionalSystemTables ( _
    ParamArray tables As ITableName() _
)
C#
void PopulateAdditionalSystemTables(
    params ITableName[] tables
)
Visual C++
void PopulateAdditionalSystemTables(
    ... array<ITableName^>^ tables
)

Parameters

tables
Type: array<ITableName>[]()[]
List of extra tables to populate

See Also

IBackupConnection Interface
PopulateAdditionalSystemTables Overload
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


PopulateAdditionalSystemTables Method (())

[image]

SQL Data Compare API 12.0.40
IBackupConnection..::.PopulateAdditionalSystemTables Method (<(Of <(>)>))
IBackupConnection Interface See Also

Populate System Tables not populated by the BackupConnection by default

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Sub PopulateAdditionalSystemTables ( _
    tables As List(Of ITableName) _
)
C#
void PopulateAdditionalSystemTables(
    List<ITableName> tables
)
Visual C++
void PopulateAdditionalSystemTables(
    List<ITableName^>^ tables
)

Parameters

tables
Type: List<(Of <(ITableName>)>)
List of extra tables to populate

See Also

IBackupConnection Interface
PopulateAdditionalSystemTables Overload
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


UseBackupSet Method

[image]

SQL Data Compare API 12.0.40
IBackupConnection..::.UseBackupSet Method
IBackupConnection Interface See Also

Select the BackupSet to use in the connection.

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Sub UseBackupSet ( _
    backupSet As IBackupSet _
)
C#
void UseBackupSet(
    IBackupSet backupSet
)
Visual C++
void UseBackupSet(
    IBackupSet^ backupSet
)

Parameters

backupSet
Type: RedGate.Shared.SQL.BackupReaderInterfaces..::.IBackupSet
The BackupSet to use

See Also

IBackupConnection Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


IBackupConnection Properties

[image] [image]

SQL Data Compare API 12.0.40
IBackupConnection Properties
IBackupConnection Interface See Also

The IBackupConnection type exposes the following properties.

Properties

Name | Description
BackupTemporaryDirectory | All Backup Temp files will be placed in this directory - due to handle persistance in the UI the UI can delete this directory on shutdown to eliminate all Backup Files
CompatibilityVersion | Compatibility version number
ConnectionString | Gets or sets the string used to open a database. (Inherited from IDbConnection.)
ConnectionTimeout | Gets the time to wait while trying to establish a connection before terminating the attempt and generating an error. (Inherited from IDbConnection.)
CurrentBackupSet | The current backup set being used.
Database | Gets the name of the current database or the database to be used after a connection is opened. (Inherited from IDbConnection.)
DatabaseGuid | Database GUID (syscomments for SS2000 requires this)
SQLServerInternalVersionNumber | SQL Server implementation dependent version number
State | Gets the current state of the connection. (Inherited from IDbConnection.)
Status | Gets and sets a delegate that can be used to notify of message or percentage changes (Inherited from ICancellable.)
Version | The external version number (e.g. 10 for SS2008)

See Also

IBackupConnection Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


BackupTemporaryDirectory Property

[image]

SQL Data Compare API 12.0.40
IBackupConnection..::.BackupTemporaryDirectory Property
IBackupConnection Interface See Also

All Backup Temp files will be placed in this directory - due to handle persistance in the UI the UI can delete this directory on shutdown to eliminate all Backup Files

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property BackupTemporaryDirectory As String
C#
string BackupTemporaryDirectory { get; }
Visual C++
property String^ BackupTemporaryDirectory {
    String^ get ();
}

See Also

IBackupConnection Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


CompatibilityVersion Property

[image]

SQL Data Compare API 12.0.40
IBackupConnection..::.CompatibilityVersion Property
IBackupConnection Interface See Also

Compatibility version number

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CompatibilityVersion As Integer
C#
int CompatibilityVersion { get; }
Visual C++
property int CompatibilityVersion {
    int get ();
}

See Also

IBackupConnection Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


CurrentBackupSet Property

[image]

SQL Data Compare API 12.0.40
IBackupConnection..::.CurrentBackupSet Property
IBackupConnection Interface See Also

The current backup set being used.

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CurrentBackupSet As IBackupSet
C#
IBackupSet CurrentBackupSet { get; }
Visual C++
property IBackupSet^ CurrentBackupSet {
    IBackupSet^ get ();
}

See Also

IBackupConnection Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


DatabaseGuid Property

[image]

SQL Data Compare API 12.0.40
IBackupConnection..::.DatabaseGuid Property
IBackupConnection Interface See Also

Database GUID (syscomments for SS2000 requires this)

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DatabaseGuid As Guid
C#
Guid DatabaseGuid { get; }
Visual C++
property Guid DatabaseGuid {
    Guid get ();
}

See Also

IBackupConnection Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


SQLServerInternalVersionNumber Property

[image]

SQL Data Compare API 12.0.40
IBackupConnection..::.SQLServerInternalVersionNumber Property
IBackupConnection Interface See Also

SQL Server implementation dependent version number

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SQLServerInternalVersionNumber As Integer
C#
int SQLServerInternalVersionNumber { get; }
Visual C++
property int SQLServerInternalVersionNumber {
    int get ();
}

See Also

IBackupConnection Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


Version Property

[image]

SQL Data Compare API 12.0.40
IBackupConnection..::.Version Property
IBackupConnection Interface See Also

The external version number (e.g. 10 for SS2008)

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Version As Integer
C#
int Version { get; }
Visual C++
property int Version {
    int get ();
}

See Also

IBackupConnection Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


IBackupSet Interface

[image]

SQL Data Compare API 12.0.40
IBackupSet Interface
Members See Also

A base interface for a BackupSet

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Interface IBackupSet
C#
public interface IBackupSet
Visual C++
public interface class IBackupSet

See Also

IBackupSet Members
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


IBackupSet Members

[image] [image]

SQL Data Compare API 12.0.40
IBackupSet Members
IBackupSet Interface Properties See Also

The IBackupSet type exposes the following members.

Properties

Name | Description
BackupType | The type of backup
CanHandle | Gets whether SQL Backup Reader is able to handle this BackupSet. This should be used by the user interface to determine whether the user is allowed to select this backup set.
DatabaseName | The Database Name that the backup was made on
Encrypted | Whether the Backup is Encrypted
EndDate | When the backup was finished
FirstLsn | First LogSequenceNumber in the Backup
IsIncomplete | Gets whether the backup set is a complete backup set or not. An incomplete backupset containing multiple files one or more of which is missing
LastLsn | Last LogSequenceNumber in the Backup
Name | The Name of the BackupSet
ServerName | The Server Name that the backup was made on
Size | Size (in bytes) of this backup
StartDate | When the backup was started

See Also

IBackupSet Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


IBackupSet Properties

[image] [image]

SQL Data Compare API 12.0.40
IBackupSet Properties
IBackupSet Interface See Also

The IBackupSet type exposes the following properties.

Properties

Name | Description
BackupType | The type of backup
CanHandle | Gets whether SQL Backup Reader is able to handle this BackupSet. This should be used by the user interface to determine whether the user is allowed to select this backup set.
DatabaseName | The Database Name that the backup was made on
Encrypted | Whether the Backup is Encrypted
EndDate | When the backup was finished
FirstLsn | First LogSequenceNumber in the Backup
IsIncomplete | Gets whether the backup set is a complete backup set or not. An incomplete backupset containing multiple files one or more of which is missing
LastLsn | Last LogSequenceNumber in the Backup
Name | The Name of the BackupSet
ServerName | The Server Name that the backup was made on
Size | Size (in bytes) of this backup
StartDate | When the backup was started

See Also

IBackupSet Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


BackupType Property

[image]

SQL Data Compare API 12.0.40
IBackupSet..::.BackupType Property
IBackupSet Interface See Also

The type of backup

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property BackupType As BackupType
C#
BackupType BackupType { get; }
Visual C++
property BackupType BackupType {
    BackupType get ();
}

See Also

IBackupSet Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


CanHandle Property

[image]

SQL Data Compare API 12.0.40
IBackupSet..::.CanHandle Property
IBackupSet Interface See Also

Gets whether SQL Backup Reader is able to handle this BackupSet. This should be used by the user interface to determine whether the user is allowed to select this backup set.

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CanHandle As Boolean
C#
bool CanHandle { get; }
Visual C++
property bool CanHandle {
    bool get ();
}

See Also

IBackupSet Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


DatabaseName Property

[image]

SQL Data Compare API 12.0.40
IBackupSet..::.DatabaseName Property
IBackupSet Interface See Also

The Database Name that the backup was made on

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DatabaseName As String
C#
string DatabaseName { get; }
Visual C++
property String^ DatabaseName {
    String^ get ();
}

See Also

IBackupSet Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


Encrypted Property

[image]

SQL Data Compare API 12.0.40
IBackupSet..::.Encrypted Property
IBackupSet Interface See Also

Whether the Backup is Encrypted

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Encrypted As Boolean
C#
bool Encrypted { get; }
Visual C++
property bool Encrypted {
    bool get ();
}

See Also

IBackupSet Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


EndDate Property

[image]

SQL Data Compare API 12.0.40
IBackupSet..::.EndDate Property
IBackupSet Interface See Also

When the backup was finished

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property EndDate As DateTime
C#
DateTime EndDate { get; }
Visual C++
property DateTime EndDate {
    DateTime get ();
}

See Also

IBackupSet Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


FirstLsn Property

[image]

SQL Data Compare API 12.0.40
IBackupSet..::.FirstLsn Property
IBackupSet Interface See Also

First LogSequenceNumber in the Backup

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property FirstLsn As String
C#
string FirstLsn { get; }
Visual C++
property String^ FirstLsn {
    String^ get ();
}

See Also

IBackupSet Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


IsIncomplete Property

[image]

SQL Data Compare API 12.0.40
IBackupSet..::.IsIncomplete Property
IBackupSet Interface See Also

Gets whether the backup set is a complete backup set or not. An incomplete backupset containing multiple files one or more of which is missing

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsIncomplete As Boolean
C#
bool IsIncomplete { get; }
Visual C++
property bool IsIncomplete {
    bool get ();
}

See Also

IBackupSet Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


LastLsn Property

[image]

SQL Data Compare API 12.0.40
IBackupSet..::.LastLsn Property
IBackupSet Interface See Also

Last LogSequenceNumber in the Backup

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property LastLsn As String
C#
string LastLsn { get; }
Visual C++
property String^ LastLsn {
    String^ get ();
}

See Also

IBackupSet Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
IBackupSet..::.Name Property
IBackupSet Interface See Also

The Name of the BackupSet

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name { get; }
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IBackupSet Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


ServerName Property

[image]

SQL Data Compare API 12.0.40
IBackupSet..::.ServerName Property
IBackupSet Interface See Also

The Server Name that the backup was made on

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ServerName As String
C#
string ServerName { get; }
Visual C++
property String^ ServerName {
    String^ get ();
}

See Also

IBackupSet Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


Size Property

[image]

SQL Data Compare API 12.0.40
IBackupSet..::.Size Property
IBackupSet Interface See Also

Size (in bytes) of this backup

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Size As ULong
C#
ulong Size { get; }
Visual C++
property unsigned long long Size {
    unsigned long long get ();
}

See Also

IBackupSet Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


StartDate Property

[image]

SQL Data Compare API 12.0.40
IBackupSet..::.StartDate Property
IBackupSet Interface See Also

When the backup was started

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property StartDate As DateTime
C#
DateTime StartDate { get; }
Visual C++
property DateTime StartDate {
    DateTime get ();
}

See Also

IBackupSet Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


RedGate.Shared.SQL.ExecutionBlock Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.Shared.SQL.ExecutionBlock Namespace

Classes

Class | Description
Batch | A class representing a batch of SQL statements.
BlockExecutor | Runs the SQL code in an ExecutionBlock on the SQL Server. This action can be cancelled.
BlockLoader | Loads execution blocks from script files on disk.
BlockSaver | Saves BlockExecutors using ICancellable. This class writes the contents of an Execution block to disk. The caller can specify the file name and the type of encoding.
ExecutionBlock | A series of SQL batches to be executed.
ExecutionBlockExtensions |
ExecutionBlockPrinter | Class that provides a method for printing an ExecutionBlock onto standard output.
SkipRetryCancelEventArgs | Event arguments for when an execution block fails to execute
TooManyFailedAttemptsException |

Interfaces

Interface | Description
IExecutionBlock | Allows reading an execution block. RedGate.Shared.SQL.ExecutionBlock..::.BlockSaver and RedGate.Shared.SQL.ExecutionBlock..::.BlockExecutor.

Delegates

Delegate | Description
SkipRetryCancelEventHandler | Method that determines the behaviour of the BlockExecutor when an execute block fails

Enumerations

Enumeration | Description
SkipRetryCancelResult | Enumeration that specifies the behaviour when an execution block fails to execute


Batch Class

[image]

SQL Data Compare API 12.0.40
Batch Class
Members See Also

A class representing a batch of SQL statements.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Class Batch
C#
public class Batch
Visual C++
public ref class Batch

Remarks

A batch is a set of SQL statements that can be executed on a SQL Server. The batch can contain more than one SQL statement, but this is not usually the case. A batch can contain more than one line (for example, the SQL to create a stored procedure might contain 100 lines).

Inheritance Hierarchy

Object
RedGate.Shared.SQL.ExecutionBlock..::.Batch

See Also

Batch Members
RedGate.Shared.SQL.ExecutionBlock Namespace


Batch Members

[image] [image]

SQL Data Compare API 12.0.40
Batch Members
Batch Class Methods Properties See Also

The Batch type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CancelAllRepeating | Removes all currently set Repeating properties if set to true.
Contents | The contents of the batch.
ExtraCRLF | True if an extra CRLF has been appended to the batch.
Marker | True if this batch is a separator (for example, a GO statement).
Repeating | True if the contents of the batch must be executed every time a command is executed.

See Also

Batch Class
RedGate.Shared.SQL.ExecutionBlock Namespace


Batch Properties

[image] [image]

SQL Data Compare API 12.0.40
Batch Properties
Batch Class See Also

The Batch type exposes the following properties.

Properties

Name | Description
CancelAllRepeating | Removes all currently set Repeating properties if set to true.
Contents | The contents of the batch.
ExtraCRLF | True if an extra CRLF has been appended to the batch.
Marker | True if this batch is a separator (for example, a GO statement).
Repeating | True if the contents of the batch must be executed every time a command is executed.

See Also

Batch Class
RedGate.Shared.SQL.ExecutionBlock Namespace


CancelAllRepeating Property

[image]

SQL Data Compare API 12.0.40
Batch..::.CancelAllRepeating Property
Batch Class See Also

Removes all currently set Repeating properties if set to true.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property CancelAllRepeating As Boolean
C#
public bool CancelAllRepeating { get; internal set; }
Visual C++
public:
property bool CancelAllRepeating {
    bool get ();
    void set (bool value);
}

See Also

Batch Class
RedGate.Shared.SQL.ExecutionBlock Namespace


Contents Property

[image]

SQL Data Compare API 12.0.40
Batch..::.Contents Property
Batch Class See Also

The contents of the batch.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property Contents As String
C#
public string Contents { get; internal set; }
Visual C++
public:
property String^ Contents {
    String^ get ();
    void set (String^ value);
}

See Also

Batch Class
RedGate.Shared.SQL.ExecutionBlock Namespace


ExtraCRLF Property

[image]

SQL Data Compare API 12.0.40
Batch..::.ExtraCRLF Property
Batch Class See Also

True if an extra CRLF has been appended to the batch.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExtraCRLF As Boolean
C#
public bool ExtraCRLF { get; }
Visual C++
public:
property bool ExtraCRLF {
    bool get ();
}

Remarks

Sometimes the definitions of stored procedures, views, and so on, do not end in a CRLF. If executed in SQL Query Analyzer, an extra CRLF will be appended. If this flag is set, the extra CRLF will be stripped when the script is run using [!:BlockExecutor.ExecuteBlock(ExecutionBlock,string,string,bool,string,string)].

See Also

Batch Class
RedGate.Shared.SQL.ExecutionBlock Namespace


Marker Property

[image]

SQL Data Compare API 12.0.40
Batch..::.Marker Property
Batch Class See Also

True if this batch is a separator (for example, a GO statement).

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property Marker As Boolean
C#
public bool Marker { get; internal set; }
Visual C++
public:
property bool Marker {
    bool get ();
    void set (bool value);
}

See Also

Batch Class
RedGate.Shared.SQL.ExecutionBlock Namespace


Repeating Property

[image]

SQL Data Compare API 12.0.40
Batch..::.Repeating Property
Batch Class See Also

True if the contents of the batch must be executed every time a command is executed.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property Repeating As Boolean
C#
public bool Repeating { get; internal set; }
Visual C++
public:
property bool Repeating {
    bool get ();
    void set (bool value);
}

Remarks

This is set to true if a variable declaration is made, because the variable must be declared at the beginning of every statement that is executed.

See Also

Batch Class
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockExecutor Class

[image]

SQL Data Compare API 12.0.40
BlockExecutor Class
Members See Also

Runs the SQL code in an ExecutionBlock on the SQL Server. This action can be cancelled.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Class BlockExecutor _
    Implements ICancellable
C#
public class BlockExecutor : ICancellable
Visual C++
public ref class BlockExecutor : ICancellable

Remarks

Use of this requires the exclude of the System.Data.Common and System.Data.SqlClient namespaces from capture if using Smart Assembly

Inheritance Hierarchy

Object
RedGate.Shared.SQL.ExecutionBlock..::.BlockExecutor

See Also

BlockExecutor Members
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockExecutor Members

[image] [image]

SQL Data Compare API 12.0.40
BlockExecutor Members
BlockExecutor Class Constructors Methods Properties See Also

The BlockExecutor type exposes the following members.

Constructors

Name | Description
BlockExecutor |

Methods

Name | Description
CancelOperation | Cancels the current operation.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteBlock | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLast500Errors | Returns the last 500 errors from the [!:ExecuteBlock(ExecutionBlock,string,string,bool,string,string)] method.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnIgnoreRetryCancel | Queries if the execution should continue in the event of a failure
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
LastCommandText | The last SQL command to be executed from the [!:ExecuteBlock(ExecutionBlock, string, string, bool, string, string)] method.
SkipRetryCancel | The event handler for status events.
Status | The event handler for status events.

See Also

BlockExecutor Class
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockExecutor Constructor

[image]

SQL Data Compare API 12.0.40
BlockExecutor Constructor
BlockExecutor Class See Also

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BlockExecutor()
Visual C++
public:
BlockExecutor()

See Also

BlockExecutor Class
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockExecutor Methods

[image] [image]

SQL Data Compare API 12.0.40
BlockExecutor Methods
BlockExecutor Class See Also

The BlockExecutor type exposes the following methods.

Methods

Name | Description
CancelOperation | Cancels the current operation.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteBlock | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLast500Errors | Returns the last 500 errors from the [!:ExecuteBlock(ExecutionBlock,string,string,bool,string,string)] method.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnIgnoreRetryCancel | Queries if the execution should continue in the event of a failure
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BlockExecutor Class
RedGate.Shared.SQL.ExecutionBlock Namespace


CancelOperation Method

[image]

SQL Data Compare API 12.0.40
BlockExecutor..::.CancelOperation Method
BlockExecutor Class See Also

Cancels the current operation.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelOperation
C#
public void CancelOperation()
Visual C++
public:
virtual void CancelOperation() sealed

Implements

ICancellable..::.CancelOperation()()()

See Also

BlockExecutor Class
RedGate.Shared.SQL.ExecutionBlock Namespace


ExecuteBlock Method

[image] [image]

SQL Data Compare API 12.0.40
BlockExecutor..::.ExecuteBlock Method
BlockExecutor Class See Also

Overload List

Name | Description
ExecuteBlock(IExecutionBlock, DBConnectionInformation) | Runs a block of SQL code contained in an ExecutionBlock.
ExecuteBlock(IExecutionBlock, IDbConnection) |
ExecuteBlock(IExecutionBlock, String, String) | Runs a block of SQL code contained in an ExecutionBlock using integrated security.
ExecuteBlock(IExecutionBlock, String, String, Boolean, String, String) | Runs a block of SQL code contained in an ExecutionBlock.

See Also

BlockExecutor Class
BlockExecutor Members
RedGate.Shared.SQL.ExecutionBlock Namespace


ExecuteBlock Method (IExecutionBlock, DBConnectionInformation)

[image]

SQL Data Compare API 12.0.40
BlockExecutor..::.ExecuteBlock Method (IExecutionBlock, DBConnectionInformation)
BlockExecutor Class See Also

Runs a block of SQL code contained in an ExecutionBlock.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub ExecuteBlock ( _
    block As IExecutionBlock, _
    connection As DBConnectionInformation _
)
C#
public void ExecuteBlock(
    IExecutionBlock block,
    DBConnectionInformation connection
)
Visual C++
public:
void ExecuteBlock(
    IExecutionBlock^ block,
    DBConnectionInformation^ connection
)

Parameters

block
Type: RedGate.Shared.SQL.ExecutionBlock..::.IExecutionBlock
The block of SQL code to run.
connection
Type: RedGate.Shared.SQL..::.DBConnectionInformation
The connection information to use.

Remarks

Feedback is provided via the Status event handler.

See GetMigrationSQL()()() and BuildFromDifferences()()() for code samples.

See Also

BlockExecutor Class
ExecuteBlock Overload
RedGate.Shared.SQL.ExecutionBlock Namespace


ExecuteBlock Method (IExecutionBlock, )

[image]

SQL Data Compare API 12.0.40
BlockExecutor..::.ExecuteBlock Method (IExecutionBlock, )
BlockExecutor Class See Also

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub ExecuteBlock ( _
    block As IExecutionBlock, _
    connection As IDbConnection _
)
C#
public void ExecuteBlock(
    IExecutionBlock block,
    IDbConnection connection
)
Visual C++
public:
void ExecuteBlock(
    IExecutionBlock^ block,
    IDbConnection^ connection
)

Parameters

block
Type: RedGate.Shared.SQL.ExecutionBlock..::.IExecutionBlock
connection
Type: IDbConnection

See Also

BlockExecutor Class
ExecuteBlock Overload
RedGate.Shared.SQL.ExecutionBlock Namespace


ExecuteBlock Method (IExecutionBlock, , )

[image]

SQL Data Compare API 12.0.40
BlockExecutor..::.ExecuteBlock Method (IExecutionBlock, , )
BlockExecutor Class See Also

Runs a block of SQL code contained in an ExecutionBlock using integrated security.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub ExecuteBlock ( _
    block As IExecutionBlock, _
    server As String, _
    database As String _
)
C#
public void ExecuteBlock(
    IExecutionBlock block,
    string server,
    string database
)
Visual C++
public:
void ExecuteBlock(
    IExecutionBlock^ block,
    String^ server,
    String^ database
)

Parameters

block
Type: RedGate.Shared.SQL.ExecutionBlock..::.IExecutionBlock
The block of SQL code to run.
server
Type: String
The SQL Server on which to run the code.
database
Type: String
The database on which to run the code.

Remarks

Feedback is provided via the Status event handler. See [!:ExecuteBlock(ExecutionBlock, string, string, bool, string, string)] for more details.

See Also

BlockExecutor Class
ExecuteBlock Overload
RedGate.Shared.SQL.ExecutionBlock Namespace


ExecuteBlock Method (IExecutionBlock, , , , , )

[image]

SQL Data Compare API 12.0.40
BlockExecutor..::.ExecuteBlock Method (IExecutionBlock, , , , , )
BlockExecutor Class See Also

Runs a block of SQL code contained in an ExecutionBlock.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub ExecuteBlock ( _
    block As IExecutionBlock, _
    server As String, _
    database As String, _
    integratedSecurity As Boolean, _
    userName As String, _
    password As String _
)
C#
public void ExecuteBlock(
    IExecutionBlock block,
    string server,
    string database,
    bool integratedSecurity,
    string userName,
    string password
)
Visual C++
public:
void ExecuteBlock(
    IExecutionBlock^ block,
    String^ server,
    String^ database,
    bool integratedSecurity,
    String^ userName,
    String^ password
)

Parameters

block
Type: RedGate.Shared.SQL.ExecutionBlock..::.IExecutionBlock
The block of SQL code to run.
server
Type: String
The SQL Server on which to run the code.
database
Type: String
The database on which to run the code.
integratedSecurity
Type: Boolean
True to use integrated security.
userName
Type: String
The user name to use to connect to the SQL Server.
password
Type: String
The password to use to connect to the SQL Server.

Remarks

Feedback is provided via the Status event handler.

See GetMigrationSQL()()() and BuildFromDifferences()()() for code samples.

See Also

BlockExecutor Class
ExecuteBlock Overload
RedGate.Shared.SQL.ExecutionBlock Namespace


GetLast500Errors Method

[image]

SQL Data Compare API 12.0.40
BlockExecutor..::.GetLast500Errors Method
BlockExecutor Class See Also

Returns the last 500 errors from the [!:ExecuteBlock(ExecutionBlock,string,string,bool,string,string)] method.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLast500Errors As SqlError()
C#
public SqlError[] GetLast500Errors()
Visual C++
public:
array<SqlError^>^ GetLast500Errors()

Return Value

An array containing the last 500 errors.

See Also

BlockExecutor Class
RedGate.Shared.SQL.ExecutionBlock Namespace


OnIgnoreRetryCancel Method

[image]

SQL Data Compare API 12.0.40
BlockExecutor..::.OnIgnoreRetryCancel Method
BlockExecutor Class See Also

Queries if the execution should continue in the event of a failure

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Protected Function OnIgnoreRetryCancel ( _
    e As SkipRetryCancelEventArgs _
) As SkipRetryCancelResult
C#
protected SkipRetryCancelResult OnIgnoreRetryCancel(
    SkipRetryCancelEventArgs e
)
Visual C++
protected:
SkipRetryCancelResult OnIgnoreRetryCancel(
    SkipRetryCancelEventArgs^ e
)

Parameters

e
Type: RedGate.Shared.SQL.ExecutionBlock..::.SkipRetryCancelEventArgs
The args which contain the last block to have failed

Return Value

The result defaults to Cancel if no IgnoreRetryCancelHandler has been given

See Also

BlockExecutor Class
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockExecutor Properties

[image] [image]

SQL Data Compare API 12.0.40
BlockExecutor Properties
BlockExecutor Class See Also

The BlockExecutor type exposes the following properties.

Properties

Name | Description
LastCommandText | The last SQL command to be executed from the [!:ExecuteBlock(ExecutionBlock, string, string, bool, string, string)] method.
SkipRetryCancel | The event handler for status events.
Status | The event handler for status events.

See Also

BlockExecutor Class
RedGate.Shared.SQL.ExecutionBlock Namespace


LastCommandText Property

[image]

SQL Data Compare API 12.0.40
BlockExecutor..::.LastCommandText Property
BlockExecutor Class See Also

The last SQL command to be executed from the [!:ExecuteBlock(ExecutionBlock, string, string, bool, string, string)] method.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LastCommandText As String
C#
public string LastCommandText { get; }
Visual C++
public:
property String^ LastCommandText {
    String^ get ();
}

See Also

BlockExecutor Class
RedGate.Shared.SQL.ExecutionBlock Namespace


SkipRetryCancel Property

[image]

SQL Data Compare API 12.0.40
BlockExecutor..::.SkipRetryCancel Property
BlockExecutor Class See Also

The event handler for status events.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property SkipRetryCancel As SkipRetryCancelEventHandler
C#
public SkipRetryCancelEventHandler SkipRetryCancel { get; set; }
Visual C++
public:
property SkipRetryCancelEventHandler^ SkipRetryCancel {
    SkipRetryCancelEventHandler^ get ();
    void set (SkipRetryCancelEventHandler^ value);
}

See Also

BlockExecutor Class
RedGate.Shared.SQL.ExecutionBlock Namespace


Status Property

[image]

SQL Data Compare API 12.0.40
BlockExecutor..::.Status Property
BlockExecutor Class See Also

The event handler for status events.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

See Also

BlockExecutor Class
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockLoader Class

[image]

SQL Data Compare API 12.0.40
BlockLoader Class
Members See Also

Loads execution blocks from script files on disk.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Class BlockLoader _
    Implements ICancellable
C#
public class BlockLoader : ICancellable
Visual C++
public ref class BlockLoader : ICancellable

Inheritance Hierarchy

Object
RedGate.Shared.SQL.ExecutionBlock..::.BlockLoader

See Also

BlockLoader Members
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockLoader Members

[image] [image]

SQL Data Compare API 12.0.40
BlockLoader Members
BlockLoader Class Constructors Methods Properties See Also

The BlockLoader type exposes the following members.

Constructors

Name | Description
BlockLoader | Creates a block loader.

Methods

Name | Description
CancelOperation | Cancels the load operation.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Load | Perform the load. Returns the execution block.
LoadFromString | Loads an execution block from the specified script. Returns the execution block.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Path | The path of the script file to load.
Status | The StatusEventHandler used to update progress information.

See Also

BlockLoader Class
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockLoader Constructor

[image]

SQL Data Compare API 12.0.40
BlockLoader Constructor
BlockLoader Class See Also

Creates a block loader.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    path As String _
)
C#
public BlockLoader(
    string path
)
Visual C++
public:
BlockLoader(
    String^ path
)

Parameters

path
Type: String
The path of the script file to load.

See Also

BlockLoader Class
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockLoader Methods

[image] [image]

SQL Data Compare API 12.0.40
BlockLoader Methods
BlockLoader Class See Also

The BlockLoader type exposes the following methods.

Methods

Name | Description
CancelOperation | Cancels the load operation.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Load | Perform the load. Returns the execution block.
LoadFromString | Loads an execution block from the specified script. Returns the execution block.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BlockLoader Class
RedGate.Shared.SQL.ExecutionBlock Namespace


CancelOperation Method

[image]

SQL Data Compare API 12.0.40
BlockLoader..::.CancelOperation Method
BlockLoader Class See Also

Cancels the load operation.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelOperation
C#
public void CancelOperation()
Visual C++
public:
virtual void CancelOperation() sealed

Implements

ICancellable..::.CancelOperation()()()

See Also

BlockLoader Class
RedGate.Shared.SQL.ExecutionBlock Namespace


Load Method

[image]

SQL Data Compare API 12.0.40
BlockLoader..::.Load Method
BlockLoader Class See Also

Perform the load. Returns the execution block.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Function Load As IExecutionBlock
C#
public IExecutionBlock Load()
Visual C++
public:
IExecutionBlock^ Load()

See Also

BlockLoader Class
RedGate.Shared.SQL.ExecutionBlock Namespace


LoadFromString Method

[image]

SQL Data Compare API 12.0.40
BlockLoader..::.LoadFromString Method
BlockLoader Class See Also

Loads an execution block from the specified script. Returns the execution block.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function LoadFromString ( _
    script As String _
) As IExecutionBlock
C#
public static IExecutionBlock LoadFromString(
    string script
)
Visual C++
public:
static IExecutionBlock^ LoadFromString(
    String^ script
)

Parameters

script
Type: String
The script to load - may contain multiple batches.

See Also

BlockLoader Class
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockLoader Properties

[image] [image]

SQL Data Compare API 12.0.40
BlockLoader Properties
BlockLoader Class See Also

The BlockLoader type exposes the following properties.

Properties

Name | Description
Path | The path of the script file to load.
Status | The StatusEventHandler used to update progress information.

See Also

BlockLoader Class
RedGate.Shared.SQL.ExecutionBlock Namespace


Path Property

[image]

SQL Data Compare API 12.0.40
BlockLoader..::.Path Property
BlockLoader Class See Also

The path of the script file to load.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Path As String
C#
public string Path { get; }
Visual C++
public:
property String^ Path {
    String^ get ();
}

See Also

BlockLoader Class
RedGate.Shared.SQL.ExecutionBlock Namespace


Status Property

[image]

SQL Data Compare API 12.0.40
BlockLoader..::.Status Property
BlockLoader Class See Also

The StatusEventHandler used to update progress information.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

See Also

BlockLoader Class
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockSaver Class

[image]

SQL Data Compare API 12.0.40
BlockSaver Class
Members See Also

Saves BlockExecutors using ICancellable. This class writes the contents of an Execution block to disk. The caller can specify the file name and the type of encoding.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Class BlockSaver _
    Implements ICancellable
C#
public class BlockSaver : ICancellable
Visual C++
public ref class BlockSaver : ICancellable

Inheritance Hierarchy

Object
RedGate.Shared.SQL.ExecutionBlock..::.BlockSaver

See Also

BlockSaver Members
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockSaver Members

[image] [image]

SQL Data Compare API 12.0.40
BlockSaver Members
BlockSaver Class Constructors Methods Properties See Also

The BlockSaver type exposes the following members.

Constructors

Name | Description
BlockSaver | Overloaded.

Methods

Name | Description
CancelOperation | Cancels the operation (used by ICancellable).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SaveToFile | Saves a copy of the ExecutionBlock to a text file with the given encoding. If the file exists, it will be overwritten. This function is not thread safe.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AppendToFile | Whether the block is appended to the exisitng file (if it exists) or whether a new file is always written.
EncodingType | Sets the EncodingType. You should call this only once.
ExecutionBlock | Sets the ExecutionBlock. You should call this only once.
FileName | Sets the FileName. You should call this only once.
Status | Cancellable Status Handler (used by ICancellable).

See Also

BlockSaver Class
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockSaver Constructor

[image] [image]

SQL Data Compare API 12.0.40
BlockSaver Constructor
BlockSaver Class See Also

Overload List

Name | Description
BlockSaver()()() | Default constructor. You must set the FileName, EncodingType, and ExecutionBlock before the BlockSaver can be run.
BlockSaver(String, EncodingType, IExecutionBlock) | Constructs a BlockSaver with all the parameters specified.
BlockSaver(String, EncodingType, IExecutionBlock, Boolean) | Constructs a BlockSaver with all the parameters specified.
BlockSaver(String, Encoding, IExecutionBlock, Boolean) | Constructs a BlockSaver with all the parameters specified.

See Also

BlockSaver Class
BlockSaver Members
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockSaver Constructor

[image]

SQL Data Compare API 12.0.40
BlockSaver Constructor
BlockSaver Class See Also

Default constructor. You must set the FileName, EncodingType, and ExecutionBlock before the BlockSaver can be run.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BlockSaver()
Visual C++
public:
BlockSaver()

See Also

BlockSaver Class
BlockSaver Overload
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockSaver Constructor (, , IExecutionBlock)

[image]

SQL Data Compare API 12.0.40
BlockSaver Constructor (, , IExecutionBlock)
BlockSaver Class See Also

Constructs a BlockSaver with all the parameters specified.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fileName As String, _
    encoding As EncodingType, _
    block As IExecutionBlock _
)
C#
public BlockSaver(
    string fileName,
    EncodingType encoding,
    IExecutionBlock block
)
Visual C++
public:
BlockSaver(
    String^ fileName,
    EncodingType encoding,
    IExecutionBlock^ block
)

Parameters

fileName
Type: String
The file name to use.
encoding
Type: EncodingType
The type of encoding to use.
block
Type: RedGate.Shared.SQL.ExecutionBlock..::.IExecutionBlock
The block of SQL code to use.

See Also

BlockSaver Class
BlockSaver Overload
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockSaver Constructor (, , IExecutionBlock, )

[image]

SQL Data Compare API 12.0.40
BlockSaver Constructor (, , IExecutionBlock, )
BlockSaver Class See Also

Constructs a BlockSaver with all the parameters specified.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fileName As String, _
    encoding As EncodingType, _
    block As IExecutionBlock, _
    appendToFile As Boolean _
)
C#
public BlockSaver(
    string fileName,
    EncodingType encoding,
    IExecutionBlock block,
    bool appendToFile
)
Visual C++
public:
BlockSaver(
    String^ fileName,
    EncodingType encoding,
    IExecutionBlock^ block,
    bool appendToFile
)

Parameters

fileName
Type: String
The file name to use.
encoding
Type: EncodingType
The type of encoding to use.
block
Type: RedGate.Shared.SQL.ExecutionBlock..::.IExecutionBlock
The block of SQL code to use.
appendToFile
Type: Boolean
Whether the append the block to the file (if it exists) or whether to create a new file (and overwrite existing file)

See Also

BlockSaver Class
BlockSaver Overload
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockSaver Constructor (, , IExecutionBlock, )

[image]

SQL Data Compare API 12.0.40
BlockSaver Constructor (, , IExecutionBlock, )
BlockSaver Class See Also

Constructs a BlockSaver with all the parameters specified.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fileName As String, _
    encoding As Encoding, _
    block As IExecutionBlock, _
    appendToFile As Boolean _
)
C#
public BlockSaver(
    string fileName,
    Encoding encoding,
    IExecutionBlock block,
    bool appendToFile
)
Visual C++
public:
BlockSaver(
    String^ fileName,
    Encoding^ encoding,
    IExecutionBlock^ block,
    bool appendToFile
)

Parameters

fileName
Type: String
The file name to use.
encoding
Type: Encoding
The Encoding object to be used
block
Type: RedGate.Shared.SQL.ExecutionBlock..::.IExecutionBlock
The block of SQL code to use.
appendToFile
Type: Boolean
Whether the append the block to the file (if it exists) or whether to create a new file (and overwrite existing file)

See Also

BlockSaver Class
BlockSaver Overload
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockSaver Methods

[image] [image]

SQL Data Compare API 12.0.40
BlockSaver Methods
BlockSaver Class See Also

The BlockSaver type exposes the following methods.

Methods

Name | Description
CancelOperation | Cancels the operation (used by ICancellable).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SaveToFile | Saves a copy of the ExecutionBlock to a text file with the given encoding. If the file exists, it will be overwritten. This function is not thread safe.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BlockSaver Class
RedGate.Shared.SQL.ExecutionBlock Namespace


CancelOperation Method

[image]

SQL Data Compare API 12.0.40
BlockSaver..::.CancelOperation Method
BlockSaver Class See Also

Cancels the operation (used by ICancellable).

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelOperation
C#
public void CancelOperation()
Visual C++
public:
virtual void CancelOperation() sealed

Implements

ICancellable..::.CancelOperation()()()

See Also

BlockSaver Class
RedGate.Shared.SQL.ExecutionBlock Namespace


SaveToFile Method

[image]

SQL Data Compare API 12.0.40
BlockSaver..::.SaveToFile Method
BlockSaver Class See Also

Saves a copy of the ExecutionBlock to a text file with the given encoding. If the file exists, it will be overwritten. This function is not thread safe.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveToFile
C#
public void SaveToFile()
Visual C++
public:
void SaveToFile()

Exceptions

Exception | Condition
RedGate.Shared.Utils..::.OperationCancelledException | The operation was cancelled.
ArgumentException | FileName has not been set.
IOException | An I/O error occured.
DirectoryNotFoundException | The directory location specified by FileName is invalid.

See Also

BlockSaver Class
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockSaver Properties

[image] [image]

SQL Data Compare API 12.0.40
BlockSaver Properties
BlockSaver Class See Also

The BlockSaver type exposes the following properties.

Properties

Name | Description
AppendToFile | Whether the block is appended to the exisitng file (if it exists) or whether a new file is always written.
EncodingType | Sets the EncodingType. You should call this only once.
ExecutionBlock | Sets the ExecutionBlock. You should call this only once.
FileName | Sets the FileName. You should call this only once.
Status | Cancellable Status Handler (used by ICancellable).

See Also

BlockSaver Class
RedGate.Shared.SQL.ExecutionBlock Namespace


AppendToFile Property

[image]

SQL Data Compare API 12.0.40
BlockSaver..::.AppendToFile Property
BlockSaver Class See Also

Whether the block is appended to the exisitng file (if it exists) or whether a new file is always written.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property AppendToFile As Boolean
C#
public bool AppendToFile { get; set; }
Visual C++
public:
property bool AppendToFile {
    bool get ();
    void set (bool value);
}

See Also

BlockSaver Class
RedGate.Shared.SQL.ExecutionBlock Namespace


EncodingType Property

[image]

SQL Data Compare API 12.0.40
BlockSaver..::.EncodingType Property
BlockSaver Class See Also

Sets the EncodingType. You should call this only once.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property EncodingType As EncodingType
C#
public EncodingType EncodingType { get; set; }
Visual C++
public:
property EncodingType EncodingType {
    EncodingType get ();
    void set (EncodingType value);
}

Exceptions

Exception | Condition
ArgumentException | If set, and EncodingType has already been set, or get, and EncodingType has not been set.

See Also

BlockSaver Class
RedGate.Shared.SQL.ExecutionBlock Namespace


ExecutionBlock Property

[image]

SQL Data Compare API 12.0.40
BlockSaver..::.ExecutionBlock Property
BlockSaver Class See Also

Sets the ExecutionBlock. You should call this only once.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecutionBlock As IExecutionBlock
C#
public IExecutionBlock ExecutionBlock { get; set; }
Visual C++
public:
property IExecutionBlock^ ExecutionBlock {
    IExecutionBlock^ get ();
    void set (IExecutionBlock^ value);
}

Exceptions

Exception | Condition
ArgumentException | If set, and ExecutionBlock has already been set, or get, and ExecutionBlock has not been set.

See Also

BlockSaver Class
RedGate.Shared.SQL.ExecutionBlock Namespace


FileName Property

[image]

SQL Data Compare API 12.0.40
BlockSaver..::.FileName Property
BlockSaver Class See Also

Sets the FileName. You should call this only once.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property FileName As String
C#
public string FileName { get; set; }
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
ArgumentException | If set, and FileName has already been set, or get, and FileName has not been set.

See Also

BlockSaver Class
RedGate.Shared.SQL.ExecutionBlock Namespace


Status Property

[image]

SQL Data Compare API 12.0.40
BlockSaver..::.Status Property
BlockSaver Class See Also

Cancellable Status Handler (used by ICancellable).

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

See Also

BlockSaver Class
RedGate.Shared.SQL.ExecutionBlock Namespace


ExecutionBlock Class

[image]

SQL Data Compare API 12.0.40
ExecutionBlock Class
Members See Also

A series of SQL batches to be executed.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Class ExecutionBlock _
    Inherits DisposableBase _
    Implements IExecutionBlock, IDisposable, IEnumerable(Of Batch),  _
    IEnumerable
C#
public class ExecutionBlock : DisposableBase, IExecutionBlock,
    IDisposable, IEnumerable<Batch>, IEnumerable
Visual C++
public ref class ExecutionBlock : public DisposableBase,
    IExecutionBlock, IDisposable, IEnumerable<Batch^>, IEnumerable

Remarks

An ExecutionBlock contains a series of SQL batches that can be executed against a SQL database. It is essentially a wrapper over a text file with extra information about batch markers (GO statements) and statements that need to be repeated before a batch is run (such as variable declarations).

An ExecutionBlock contains Line objects which in turn contain GetStream()()() objects.

The underlying stream can be accessed from M

ExecutionBlock objects are created by [!:RedGate.SQLDataCompare.Engine.SqlProvider.GetMigrationSQL]. There should be no need to create an ExecutionBlock manually.

It is essential to call the Dispose(Boolean) method of ExecutionBlock objects to ensure temporary files are deleted.

Inheritance Hierarchy

Object
RedGate.Shared.Utils..::.DisposableBase
RedGate.Shared.SQL.ExecutionBlock..::.ExecutionBlock

See Also

ExecutionBlock Members
RedGate.Shared.SQL.ExecutionBlock Namespace


ExecutionBlock Members

[image] [image]

SQL Data Compare API 12.0.40
ExecutionBlock Members
ExecutionBlock Class Methods Properties Explicit Interface Implementations See Also

The ExecutionBlock type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLine | Gets a line of SQL.
GetStream | Returns a stream to the underlying SQL text file.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SaveToFile | Obsolete. Saves a copy of the ExecutionBlock to a text file with the given encoding.
StopWriting | Indicates that writing has finished.
ToString | Obsolete. Please rewrite your code to use GetString(). (Overrides Object..::.ToString()()().)

Properties

Name | Description
BatchCount | Obsolete. The number of batches.
ByteCount | Gets the underlying bytes position
CharCount | The number of characters in the ExecutionBlock
Encoding | The encoding the execution block was written in
IsDisposed | Returns a value indicating if this instance has been disposed. (Inherited from DisposableBase.)
LineCount | The number of lines.
MaxLineLength | The maximum length of a line.
Name | Gets or sets the name of the block

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator |

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


ExecutionBlock Methods

[image] [image]

SQL Data Compare API 12.0.40
ExecutionBlock Methods
ExecutionBlock Class See Also

The ExecutionBlock type exposes the following methods.

Methods

Name | Description
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLine | Gets a line of SQL.
GetStream | Returns a stream to the underlying SQL text file.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SaveToFile | Obsolete. Saves a copy of the ExecutionBlock to a text file with the given encoding.
StopWriting | Indicates that writing has finished.
ToString | Obsolete. Please rewrite your code to use GetString(). (Overrides Object..::.ToString()()().)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator |

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


Dispose Method

[image] [image]

SQL Data Compare API 12.0.40
ExecutionBlock..::.Dispose Method
ExecutionBlock Class See Also

Overload List

Name | Description
Dispose()()() | (Inherited from DisposableBase.)
Dispose(Boolean) | (Overrides DisposableBase ..::. Dispose(Boolean).)

See Also

ExecutionBlock Class
ExecutionBlock Members
RedGate.Shared.SQL.ExecutionBlock Namespace


Dispose Method ()

[image]

SQL Data Compare API 12.0.40
ExecutionBlock..::.Dispose Method ()
ExecutionBlock Class See Also

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
C#
protected override void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: Boolean

See Also

ExecutionBlock Class
Dispose Overload
RedGate.Shared.SQL.ExecutionBlock Namespace


GetEnumerator Method

[image]

SQL Data Compare API 12.0.40
ExecutionBlock..::.GetEnumerator Method
ExecutionBlock Class See Also

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of Batch)
C#
public IEnumerator<Batch> GetEnumerator()
Visual C++
public:
virtual IEnumerator<Batch^>^ GetEnumerator() sealed

Implements

IEnumerableGetEnumerator()()()

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


. Method

[image]

SQL Data Compare API 12.0.40
ExecutionBlock..::...::. Method
ExecutionBlock Class See Also

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
C#
IEnumerator IEnumerable.GetEnumerator()
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerableGetEnumerator()()()

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


GetLine Method

[image]

SQL Data Compare API 12.0.40
ExecutionBlock..::.GetLine Method
ExecutionBlock Class See Also

Gets a line of SQL.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLine ( _
    index As Long _
) As Line
C#
public Line GetLine(
    long index
)
Visual C++
public:
Line^ GetLine(
    long long index
)

Parameters

index
Type: Int64
The index of the line to get.

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


GetStream Method

[image]

SQL Data Compare API 12.0.40
ExecutionBlock..::.GetStream Method
ExecutionBlock Class See Also

Returns a stream to the underlying SQL text file.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Function GetStream As Stream
C#
public Stream GetStream()
Visual C++
public:
virtual Stream^ GetStream() sealed

Implements

IExecutionBlock..::.GetStream()()()

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


SaveToFile Method

[image]

SQL Data Compare API 12.0.40
ExecutionBlock..::.SaveToFile Method
ExecutionBlock Class See Also

Saves a copy of the ExecutionBlock to a text file with the given encoding.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Please use BlockSaver instead", False)> _
Public Sub SaveToFile ( _
    filePath As String, _
    encoding As EncodingType _
)
C#
[ObsoleteAttribute("Please use BlockSaver instead", false)]
public void SaveToFile(
    string filePath,
    EncodingType encoding
)
Visual C++
[ObsoleteAttribute(L"Please use BlockSaver instead", false)]
public:
void SaveToFile(
    String^ filePath,
    EncodingType encoding
)

Parameters

filePath
Type: String
encoding
Type: EncodingType

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


StopWriting Method

[image]

SQL Data Compare API 12.0.40
ExecutionBlock..::.StopWriting Method
ExecutionBlock Class See Also

Indicates that writing has finished.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub StopWriting
C#
public void StopWriting()
Visual C++
public:
void StopWriting()

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
ExecutionBlock..::.ToString Method
ExecutionBlock Class See Also

Please rewrite your code to use GetString().

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("This is obsolete! Please rewrite your code to use GetString().",  _
    True)> _
Public Overrides Function ToString As String
C#
[ObsoleteAttribute("This is obsolete! Please rewrite your code to use GetString().",
    true)]
public override string ToString()
Visual C++
[ObsoleteAttribute(L"This is obsolete! Please rewrite your code to use GetString().",
    true)]
public:
virtual String^ ToString() override

Remarks

This should remain "obsolete" indefinitely to guide API usage. The implementation should be whatever's most useful to see in the debugger.

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


ExecutionBlock Properties

[image] [image]

SQL Data Compare API 12.0.40
ExecutionBlock Properties
ExecutionBlock Class See Also

The ExecutionBlock type exposes the following properties.

Properties

Name | Description
BatchCount | Obsolete. The number of batches.
ByteCount | Gets the underlying bytes position
CharCount | The number of characters in the ExecutionBlock
Encoding | The encoding the execution block was written in
IsDisposed | Returns a value indicating if this instance has been disposed. (Inherited from DisposableBase.)
LineCount | The number of lines.
MaxLineLength | The maximum length of a line.
Name | Gets or sets the name of the block

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


BatchCount Property

[image]

SQL Data Compare API 12.0.40
ExecutionBlock..::.BatchCount Property
ExecutionBlock Class See Also

The number of batches.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("This is IEnumerable, use Count() instead. Don't worry about the long/int issue since if there are over 2 billion batches we'll have already run out of memory.",  _
    False)> _
Public ReadOnly Property BatchCount As Integer
C#
[ObsoleteAttribute("This is IEnumerable, use Count() instead. Don't worry about the long/int issue since if there are over 2 billion batches we'll have already run out of memory.",
    false)]
public int BatchCount { get; }
Visual C++
[ObsoleteAttribute(L"This is IEnumerable, use Count() instead. Don't worry about the long/int issue since if there are over 2 billion batches we'll have already run out of memory.",
    false)]
public:
virtual property int BatchCount {
    int get () sealed;
}

Implements

IExecutionBlock..::.BatchCount

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


ByteCount Property

[image]

SQL Data Compare API 12.0.40
ExecutionBlock..::.ByteCount Property
ExecutionBlock Class See Also

Gets the underlying bytes position

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ByteCount As Long
C#
public long ByteCount { get; }
Visual C++
public:
property long long ByteCount {
    long long get ();
}

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


CharCount Property

[image]

SQL Data Compare API 12.0.40
ExecutionBlock..::.CharCount Property
ExecutionBlock Class See Also

The number of characters in the ExecutionBlock

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CharCount As Long
C#
public long CharCount { get; }
Visual C++
public:
property long long CharCount {
    long long get ();
}

Remarks

Note that this is not always the same as the number of bytes because of Unicode issues

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


Encoding Property

[image]

SQL Data Compare API 12.0.40
ExecutionBlock..::.Encoding Property
ExecutionBlock Class See Also

The encoding the execution block was written in

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Encoding As Encoding
C#
public Encoding Encoding { get; }
Visual C++
public:
virtual property Encoding^ Encoding {
    Encoding^ get () sealed;
}

Implements

IExecutionBlock..::.Encoding

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


LineCount Property

[image]

SQL Data Compare API 12.0.40
ExecutionBlock..::.LineCount Property
ExecutionBlock Class See Also

The number of lines.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LineCount As Long
C#
public long LineCount { get; }
Visual C++
public:
property long long LineCount {
    long long get ();
}

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


MaxLineLength Property

[image]

SQL Data Compare API 12.0.40
ExecutionBlock..::.MaxLineLength Property
ExecutionBlock Class See Also

The maximum length of a line.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MaxLineLength As Integer
C#
public int MaxLineLength { get; }
Visual C++
public:
property int MaxLineLength {
    int get ();
}

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
ExecutionBlock..::.Name Property
ExecutionBlock Class See Also

Gets or sets the name of the block

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


ExecutionBlockExtensions Class

[image]

SQL Data Compare API 12.0.40
ExecutionBlockExtensions Class
Members See Also

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ExecutionBlockExtensions
C#
public static class ExecutionBlockExtensions
Visual C++
public ref class ExecutionBlockExtensions abstract sealed

Inheritance Hierarchy

Object
RedGate.Shared.SQL.ExecutionBlock..::.ExecutionBlockExtensions

See Also

ExecutionBlockExtensions Members
RedGate.Shared.SQL.ExecutionBlock Namespace


ExecutionBlockExtensions Members

[image] [image]

SQL Data Compare API 12.0.40
ExecutionBlockExtensions Members
ExecutionBlockExtensions Class Methods See Also

The ExecutionBlockExtensions type exposes the following members.

Methods

Name | Description
Count | Saves the (theoretical) rubbish performance of seeking through the stream to count for ExecutionBlock
ElementAt | Marks the block as finished writing and efficiently (for ExecutionBlock) retrieves the Batch at index
GetBatch | Obsolete. Marks the block as finished writing and efficiently retrieves the Batch at index
GetFileStream | Obsolete. Returns a stream to the underlying SQL text file and marks the block as finished writing.
GetString | Returns the contents of the ExecutionBlock. Do not call before the execution block has finished being written - behaviour is undefined and may change in future!

See Also

ExecutionBlockExtensions Class
RedGate.Shared.SQL.ExecutionBlock Namespace


ExecutionBlockExtensions Methods

[image] [image]

SQL Data Compare API 12.0.40
ExecutionBlockExtensions Methods
ExecutionBlockExtensions Class See Also

The ExecutionBlockExtensions type exposes the following methods.

Methods

Name | Description
Count | Saves the (theoretical) rubbish performance of seeking through the stream to count for ExecutionBlock
ElementAt | Marks the block as finished writing and efficiently (for ExecutionBlock) retrieves the Batch at index
GetBatch | Obsolete. Marks the block as finished writing and efficiently retrieves the Batch at index
GetFileStream | Obsolete. Returns a stream to the underlying SQL text file and marks the block as finished writing.
GetString | Returns the contents of the ExecutionBlock. Do not call before the execution block has finished being written - behaviour is undefined and may change in future!

See Also

ExecutionBlockExtensions Class
RedGate.Shared.SQL.ExecutionBlock Namespace


Count Method

[image]

SQL Data Compare API 12.0.40
ExecutionBlockExtensions..::.Count Method
ExecutionBlockExtensions Class See Also

Saves the (theoretical) rubbish performance of seeking through the stream to count for ExecutionBlock

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Count ( _
    enumerableExecutionBlock As IEnumerable(Of Batch) _
) As Integer
C#
public static int Count(
    IEnumerable<Batch> enumerableExecutionBlock
)
Visual C++
public:
static int Count(
    IEnumerable<Batch^>^ enumerableExecutionBlock
)

Parameters

enumerableExecutionBlock
Type: IEnumerable<(Of <( Batch >)>)

See Also

ExecutionBlockExtensions Class
RedGate.Shared.SQL.ExecutionBlock Namespace


ElementAt Method

[image]

SQL Data Compare API 12.0.40
ExecutionBlockExtensions..::.ElementAt Method
ExecutionBlockExtensions Class See Also

Marks the block as finished writing and efficiently (for ExecutionBlock) retrieves the Batch at index

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ElementAt ( _
    executionBlock As IEnumerable(Of Batch), _
    index As Integer _
) As Batch
C#
public static Batch ElementAt(
    IEnumerable<Batch> executionBlock,
    int index
)
Visual C++
public:
static Batch^ ElementAt(
    IEnumerable<Batch^>^ executionBlock,
    int index
)

Parameters

executionBlock
Type: IEnumerable<(Of <( Batch >)>)
index
Type: Int32

Remarks

In theory, more efficient than ElementAt which would iterate over each previous position.

Exceptions

Exception | Condition
ArgumentOutOfRangeException | The index is not valid

See Also

ExecutionBlockExtensions Class
RedGate.Shared.SQL.ExecutionBlock Namespace


GetBatch Method

[image]

SQL Data Compare API 12.0.40
ExecutionBlockExtensions..::.GetBatch Method
ExecutionBlockExtensions Class See Also

Marks the block as finished writing and efficiently retrieves the Batch at index

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Please call ElementAt instead. Don't worry about the long/int issue since if there are over 2 billion batches we'll have already run out of memory.",  _
    False)> _
Public Shared Function GetBatch ( _
    executionBlock As IExecutionBlock, _
    index As Long _
) As Batch
C#
[ObsoleteAttribute("Please call ElementAt instead. Don't worry about the long/int issue since if there are over 2 billion batches we'll have already run out of memory.",
    false)]
public static Batch GetBatch(
    IExecutionBlock executionBlock,
    long index
)
Visual C++
[ObsoleteAttribute(L"Please call ElementAt instead. Don't worry about the long/int issue since if there are over 2 billion batches we'll have already run out of memory.",
    false)]
public:
static Batch^ GetBatch(
    IExecutionBlock^ executionBlock,
    long long index
)

Parameters

executionBlock
Type: RedGate.Shared.SQL.ExecutionBlock..::.IExecutionBlock
index
Type: Int64

Exceptions

Exception | Condition
ArgumentOutOfRangeException | The index is not valid

See Also

ExecutionBlockExtensions Class
RedGate.Shared.SQL.ExecutionBlock Namespace


GetFileStream Method

[image]

SQL Data Compare API 12.0.40
ExecutionBlockExtensions..::.GetFileStream Method
ExecutionBlockExtensions Class See Also

Returns a stream to the underlying SQL text file and marks the block as finished writing.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Please call GetStream() instead - we don't guarantee a file-backed stream",  _
    False)> _
Public Shared Function GetFileStream ( _
    executionBlock As IExecutionBlock _
) As Stream
C#
[ObsoleteAttribute("Please call GetStream() instead - we don't guarantee a file-backed stream",
    false)]
public static Stream GetFileStream(
    IExecutionBlock executionBlock
)
Visual C++
[ObsoleteAttribute(L"Please call GetStream() instead - we don't guarantee a file-backed stream",
    false)]
public:
static Stream^ GetFileStream(
    IExecutionBlock^ executionBlock
)

Parameters

executionBlock
Type: RedGate.Shared.SQL.ExecutionBlock..::.IExecutionBlock

See Also

ExecutionBlockExtensions Class
RedGate.Shared.SQL.ExecutionBlock Namespace


GetString Method

[image]

SQL Data Compare API 12.0.40
ExecutionBlockExtensions..::.GetString Method
ExecutionBlockExtensions Class See Also

Returns the contents of the ExecutionBlock. Do not call before the execution block has finished being written - behaviour is undefined and may change in future!

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetString ( _
    executionBlock As IExecutionBlock _
) As String
C#
public static string GetString(
    IExecutionBlock executionBlock
)
Visual C++
public:
static String^ GetString(
    IExecutionBlock^ executionBlock
)

Parameters

executionBlock
Type: RedGate.Shared.SQL.ExecutionBlock..::.IExecutionBlock

Remarks

If the ExecutionBlock contains a lot of SQL code, this method can cause virtual memory problems; you are recommended to use GetStream()()() instead.

See Also

ExecutionBlockExtensions Class
RedGate.Shared.SQL.ExecutionBlock Namespace


ExecutionBlockPrinter Class

[image]

SQL Data Compare API 12.0.40
ExecutionBlockPrinter Class
Members See Also

Class that provides a method for printing an ExecutionBlock onto standard output.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
<StrongNameIdentityPermissionAttribute(SecurityAction.LinkDemand, PublicKey := "0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")> _
Public NotInheritable Class ExecutionBlockPrinter
C#
[StrongNameIdentityPermissionAttribute(SecurityAction.LinkDemand, PublicKey = "0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")]
public static class ExecutionBlockPrinter
Visual C++
[StrongNameIdentityPermissionAttribute(SecurityAction::LinkDemand, PublicKey = L"0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")]
public ref class ExecutionBlockPrinter abstract sealed

Inheritance Hierarchy

Object
RedGate.Shared.SQL.ExecutionBlock..::.ExecutionBlockPrinter

See Also

ExecutionBlockPrinter Members
RedGate.Shared.SQL.ExecutionBlock Namespace


ExecutionBlockPrinter Members

[image] [image]

SQL Data Compare API 12.0.40
ExecutionBlockPrinter Members
ExecutionBlockPrinter Class Methods See Also

Methods

Name | Description
PrintExecutionBlock | Overloaded.

See Also

ExecutionBlockPrinter Class
RedGate.Shared.SQL.ExecutionBlock Namespace


ExecutionBlockPrinter Methods

[image] [image]

SQL Data Compare API 12.0.40
ExecutionBlockPrinter Methods
ExecutionBlockPrinter Class See Also

Methods

Name | Description
PrintExecutionBlock | Overloaded.

See Also

ExecutionBlockPrinter Class
RedGate.Shared.SQL.ExecutionBlock Namespace


PrintExecutionBlock Method

[image] [image]

SQL Data Compare API 12.0.40
ExecutionBlockPrinter..::.PrintExecutionBlock Method
ExecutionBlockPrinter Class See Also

Overload List

Name | Description
PrintExecutionBlock(IExecutionBlock) | Prints the SQL script wrapped by the supplied ExecutionBlock to standard output.
PrintExecutionBlock(IExecutionBlock, String, Boolean) | Obsolete. Prints the SQL script wrapped by the supplied execution block to the specified file. If the supplied filename is null the method returns without taking any action. If the value of filename is set to 'stdout' the script will be written to standard output.

See Also

ExecutionBlockPrinter Class
ExecutionBlockPrinter Members
RedGate.Shared.SQL.ExecutionBlock Namespace


PrintExecutionBlock Method (IExecutionBlock)

[image]

SQL Data Compare API 12.0.40
ExecutionBlockPrinter..::.PrintExecutionBlock Method (IExecutionBlock)
ExecutionBlockPrinter Class See Also

Prints the SQL script wrapped by the supplied ExecutionBlock to standard output.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub PrintExecutionBlock ( _
    block As IExecutionBlock _
)
C#
public static void PrintExecutionBlock(
    IExecutionBlock block
)
Visual C++
public:
static void PrintExecutionBlock(
    IExecutionBlock^ block
)

Parameters

block
Type: RedGate.Shared.SQL.ExecutionBlock..::.IExecutionBlock
The ExecutionBlock to write onto standard output.

See Also

ExecutionBlockPrinter Class
PrintExecutionBlock Overload
RedGate.Shared.SQL.ExecutionBlock Namespace


PrintExecutionBlock Method (IExecutionBlock, , )

[image]

SQL Data Compare API 12.0.40
ExecutionBlockPrinter..::.PrintExecutionBlock Method (IExecutionBlock, , )
ExecutionBlockPrinter Class See Also

Prints the SQL script wrapped by the supplied execution block to the specified file. If the supplied filename is null the method returns without taking any action. If the value of filename is set to 'stdout' the script will be written to standard output.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Please use BlockSaver if writing to a file, or PrintExecutionBlock(ExecutionBlock) if writing to stdout")> _
Public Shared Sub PrintExecutionBlock ( _
    block As IExecutionBlock, _
    filename As String, _
    force As Boolean _
)
C#
[ObsoleteAttribute("Please use BlockSaver if writing to a file, or PrintExecutionBlock(ExecutionBlock) if writing to stdout")]
public static void PrintExecutionBlock(
    IExecutionBlock block,
    string filename,
    bool force
)
Visual C++
[ObsoleteAttribute(L"Please use BlockSaver if writing to a file, or PrintExecutionBlock(ExecutionBlock) if writing to stdout")]
public:
static void PrintExecutionBlock(
    IExecutionBlock^ block,
    String^ filename,
    bool force
)

Parameters

block
Type: RedGate.Shared.SQL.ExecutionBlock..::.IExecutionBlock
execution block.
filename
Type: String
filename to which SQL script should be written.
force
Type: Boolean
true to force writing of script even if specified file exists, if set to false an IOException will be thrown if the specified output file already exists.

Exceptions

Exception | Condition
IOException | if an error occurs writing to the file.

See Also

ExecutionBlockPrinter Class
PrintExecutionBlock Overload
RedGate.Shared.SQL.ExecutionBlock Namespace


IExecutionBlock Interface

[image]

SQL Data Compare API 12.0.40
IExecutionBlock Interface
Members See Also

Allows reading an execution block. RedGate.Shared.SQL.ExecutionBlock..::.BlockSaver and RedGate.Shared.SQL.ExecutionBlock..::.BlockExecutor.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Interface IExecutionBlock _
    Implements IDisposable, IEnumerable(Of Batch),  _
    IEnumerable
C#
public interface IExecutionBlock : IDisposable,
    IEnumerable<Batch>, IEnumerable
Visual C++
public interface class IExecutionBlock : IDisposable,
    IEnumerable<Batch^>, IEnumerable

Remarks

Also prevents consumers needing a direct reference to Shared.Utils, which they would otherwise need to since since ExecutionBlock references DisposableBase

See Also

IExecutionBlock Members
RedGate.Shared.SQL.ExecutionBlock Namespace
RedGate.Shared.SQL.ExecutionBlock..::.BlockSaver
RedGate.Shared.SQL.ExecutionBlock..::.BlockExecutor


IExecutionBlock Members

[image] [image]

SQL Data Compare API 12.0.40
IExecutionBlock Members
IExecutionBlock Interface Methods Properties See Also

The IExecutionBlock type exposes the following members.

Methods

Name | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
GetEnumerator | Overloaded.
GetStream | Returns a stream to the underlying SQL text file and marks the block as finished writing.

Properties

Name | Description
BatchCount | Obsolete.
Encoding | The encoding the execution block was written in

See Also

IExecutionBlock Interface
RedGate.Shared.SQL.ExecutionBlock Namespace


IExecutionBlock Methods

[image] [image]

SQL Data Compare API 12.0.40
IExecutionBlock Methods
IExecutionBlock Interface See Also

The IExecutionBlock type exposes the following methods.

Methods

Name | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
GetEnumerator | Overloaded.
GetStream | Returns a stream to the underlying SQL text file and marks the block as finished writing.

See Also

IExecutionBlock Interface
RedGate.Shared.SQL.ExecutionBlock Namespace


GetEnumerator Method

[image] [image]

SQL Data Compare API 12.0.40
IExecutionBlock..::.GetEnumerator Method
IExecutionBlock Interface See Also

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( Batch >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IExecutionBlock Interface
IExecutionBlock Members
RedGate.Shared.SQL.ExecutionBlock Namespace


GetStream Method

[image]

SQL Data Compare API 12.0.40
IExecutionBlock..::.GetStream Method
IExecutionBlock Interface See Also

Returns a stream to the underlying SQL text file and marks the block as finished writing.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Function GetStream As Stream
C#
Stream GetStream()
Visual C++
Stream^ GetStream()

See Also

IExecutionBlock Interface
RedGate.Shared.SQL.ExecutionBlock Namespace


IExecutionBlock Properties

[image] [image]

SQL Data Compare API 12.0.40
IExecutionBlock Properties
IExecutionBlock Interface See Also

The IExecutionBlock type exposes the following properties.

Properties

Name | Description
BatchCount | Obsolete.
Encoding | The encoding the execution block was written in

See Also

IExecutionBlock Interface
RedGate.Shared.SQL.ExecutionBlock Namespace


BatchCount Property

[image]

SQL Data Compare API 12.0.40
IExecutionBlock..::.BatchCount Property
IExecutionBlock Interface See Also

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("This is IEnumerable, use Count() instead. Don't worry about the long/int issue since if there are over 2 billion batches we'll have already run out of memory.",  _
    False)> _
ReadOnly Property BatchCount As Integer
C#
[ObsoleteAttribute("This is IEnumerable, use Count() instead. Don't worry about the long/int issue since if there are over 2 billion batches we'll have already run out of memory.",
    false)]
int BatchCount { get; }
Visual C++
[ObsoleteAttribute(L"This is IEnumerable, use Count() instead. Don't worry about the long/int issue since if there are over 2 billion batches we'll have already run out of memory.",
    false)]
property int BatchCount {
    int get ();
}

See Also

IExecutionBlock Interface
RedGate.Shared.SQL.ExecutionBlock Namespace


Encoding Property

[image]

SQL Data Compare API 12.0.40
IExecutionBlock..::.Encoding Property
IExecutionBlock Interface See Also

The encoding the execution block was written in

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Encoding As Encoding
C#
Encoding Encoding { get; }
Visual C++
property Encoding^ Encoding {
    Encoding^ get ();
}

See Also

IExecutionBlock Interface
RedGate.Shared.SQL.ExecutionBlock Namespace


SkipRetryCancelEventArgs Class

[image]

SQL Data Compare API 12.0.40
SkipRetryCancelEventArgs Class
Members See Also

Event arguments for when an execution block fails to execute

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Class SkipRetryCancelEventArgs _
    Inherits EventArgs
C#
public class SkipRetryCancelEventArgs : EventArgs
Visual C++
public ref class SkipRetryCancelEventArgs : public EventArgs

Inheritance Hierarchy

Object
EventArgs
RedGate.Shared.SQL.ExecutionBlock..::.SkipRetryCancelEventArgs

See Also

SkipRetryCancelEventArgs Members
RedGate.Shared.SQL.ExecutionBlock Namespace


SkipRetryCancelEventArgs Members

[image] [image]

SQL Data Compare API 12.0.40
SkipRetryCancelEventArgs Members
SkipRetryCancelEventArgs Class Constructors Methods Properties See Also

The SkipRetryCancelEventArgs type exposes the following members.

Constructors

Name | Description
SkipRetryCancelEventArgs | Initializes a new instance of the SkipRetryCancelEventArgs class with the specified exception and last command to have executed.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
InnerException | The exception that caused all this.
LastCommandText | The last command that is currently executing operation.

See Also

SkipRetryCancelEventArgs Class
RedGate.Shared.SQL.ExecutionBlock Namespace


SkipRetryCancelEventArgs Constructor

[image]

SQL Data Compare API 12.0.40
SkipRetryCancelEventArgs Constructor
SkipRetryCancelEventArgs Class See Also

Initializes a new instance of the SkipRetryCancelEventArgs class with the specified exception and last command to have executed.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    innerException As Exception, _
    lastCommandText As String _
)
C#
public SkipRetryCancelEventArgs(
    Exception innerException,
    string lastCommandText
)
Visual C++
public:
SkipRetryCancelEventArgs(
    Exception^ innerException,
    String^ lastCommandText
)

Parameters

innerException
Type: Exception
The exception that caused all this.
lastCommandText
Type: String
The last command that is currently executing operation.

See Also

SkipRetryCancelEventArgs Class
RedGate.Shared.SQL.ExecutionBlock Namespace


SkipRetryCancelEventArgs Properties

[image] [image]

SQL Data Compare API 12.0.40
SkipRetryCancelEventArgs Properties
SkipRetryCancelEventArgs Class See Also

The SkipRetryCancelEventArgs type exposes the following properties.

Properties

Name | Description
InnerException | The exception that caused all this.
LastCommandText | The last command that is currently executing operation.

See Also

SkipRetryCancelEventArgs Class
RedGate.Shared.SQL.ExecutionBlock Namespace


InnerException Property

[image]

SQL Data Compare API 12.0.40
SkipRetryCancelEventArgs..::.InnerException Property
SkipRetryCancelEventArgs Class See Also

The exception that caused all this.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException { get; }
Visual C++
public:
property Exception^ InnerException {
    Exception^ get ();
}

Remarks

This can be null.

See Also

SkipRetryCancelEventArgs Class
RedGate.Shared.SQL.ExecutionBlock Namespace


LastCommandText Property

[image]

SQL Data Compare API 12.0.40
SkipRetryCancelEventArgs..::.LastCommandText Property
SkipRetryCancelEventArgs Class See Also

The last command that is currently executing operation.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LastCommandText As String
C#
public string LastCommandText { get; }
Visual C++
public:
property String^ LastCommandText {
    String^ get ();
}

Remarks

This should always contain the sql of the last batch of blocks that was attempted to be executed.

See Also

SkipRetryCancelEventArgs Class
RedGate.Shared.SQL.ExecutionBlock Namespace


SkipRetryCancelEventHandler Delegate

[image]

SQL Data Compare API 12.0.40
SkipRetryCancelEventHandler Delegate
See Also

Method that determines the behaviour of the BlockExecutor when an execute block fails

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Function SkipRetryCancelEventHandler ( _
    sender As Object, _
    e As SkipRetryCancelEventArgs _
) As SkipRetryCancelResult
C#
public delegate SkipRetryCancelResult SkipRetryCancelEventHandler(
    Object sender,
    SkipRetryCancelEventArgs e
)
Visual C++
public delegate SkipRetryCancelResult SkipRetryCancelEventHandler(
    Object^ sender,
    SkipRetryCancelEventArgs^ e
)

Parameters

sender
Type: Object
e
Type: RedGate.Shared.SQL.ExecutionBlock..::.SkipRetryCancelEventArgs

See Also

RedGate.Shared.SQL.ExecutionBlock Namespace


SkipRetryCancelResult Enumeration

[image]

SQL Data Compare API 12.0.40
SkipRetryCancelResult Enumeration
See Also

Enumeration that specifies the behaviour when an execution block fails to execute

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration SkipRetryCancelResult
C#
public enum SkipRetryCancelResult
Visual C++
public enum class SkipRetryCancelResult

Members

Member name | Description
Skip | Skips the current batch that caused the error and carries on
Retry | Attempts to run the block as-is again
Cancel | Fails the execution block (the default behaviour)

See Also

RedGate.Shared.SQL.ExecutionBlock Namespace


TooManyFailedAttemptsException Class

[image]

SQL Data Compare API 12.0.40
TooManyFailedAttemptsException Class
Members See Also

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Class TooManyFailedAttemptsException _
    Inherits Exception
C#
public class TooManyFailedAttemptsException : Exception
Visual C++
public ref class TooManyFailedAttemptsException : public Exception

Inheritance Hierarchy

Object
Exception
RedGate.Shared.SQL.ExecutionBlock..::.TooManyFailedAttemptsException

See Also

TooManyFailedAttemptsException Members
RedGate.Shared.SQL.ExecutionBlock Namespace


TooManyFailedAttemptsException Members

[image] [image]

SQL Data Compare API 12.0.40
TooManyFailedAttemptsException Members
TooManyFailedAttemptsException Class Constructors Methods Properties See Also

The TooManyFailedAttemptsException type exposes the following members.

Constructors

Name | Description
TooManyFailedAttemptsException |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

TooManyFailedAttemptsException Class
RedGate.Shared.SQL.ExecutionBlock Namespace


TooManyFailedAttemptsException Constructor

[image]

SQL Data Compare API 12.0.40
TooManyFailedAttemptsException Constructor
TooManyFailedAttemptsException Class See Also

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    attempts As Integer _
)
C#
public TooManyFailedAttemptsException(
    int attempts
)
Visual C++
public:
TooManyFailedAttemptsException(
    int attempts
)

Parameters

attempts
Type: Int32

See Also

TooManyFailedAttemptsException Class
RedGate.Shared.SQL.ExecutionBlock Namespace


RedGate.Shared.Utils Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.Shared.Utils Namespace

Classes

Class | Description
DisposableBase | Helper class that implements the recommended IDisposable design pattern.
OperationCancelledException | This exception is thrown when the operation is cancelled by the CancelOperation()()() method. This is becoming obsolete in favour of OperationCanceledException. You should never throw this exception, and always catch both types of exception if any.
StatusEventArgs | Represents arguments to the StatusEventHandler event.

Interfaces

Interface | Description
ICancellable | An interface for objects with operations that can be cancelled.

Delegates

Delegate | Description
StatusEventHandler | Represents a method that can receive status events.


DisposableBase Class

[image]

SQL Data Compare API 12.0.40
DisposableBase Class
Members See Also

Helper class that implements the recommended IDisposable design pattern.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public MustInherit Class DisposableBase _
    Implements IDisposable
C#
[SerializableAttribute]
public abstract class DisposableBase : IDisposable
Visual C++
[SerializableAttribute]
public ref class DisposableBase abstract : IDisposable

Inheritance Hierarchy

Object
RedGate.Shared.Utils..::.DisposableBase
RedGate.Shared.SQL.ExecutionBlock..::.ExecutionBlock
RedGate.SQLCompare.Engine..::.SerializableBlobStore
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.FileBasedProject
RedGate.SQLCompare.Engine.ApiHelpers..::.StagedDeploymentSqlGenerator
RedGate.SQLDataCompare.Engine..::.Blob
RedGate.SQLDataCompare.Engine..::.ComparisonSession
RedGate.SQLDataCompare.Engine.ResultsStore..::.Reader
RedGate.SQLDataCompare.Engine.ResultsStore..::.Store

See Also

DisposableBase Members
RedGate.Shared.Utils Namespace


DisposableBase Members

[image] [image]

SQL Data Compare API 12.0.40
DisposableBase Members
DisposableBase Class Methods Properties See Also

The DisposableBase type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDisposed | Returns a value indicating if this instance has been disposed.

See Also

DisposableBase Class
RedGate.Shared.Utils Namespace


DisposableBase Methods

[image] [image]

SQL Data Compare API 12.0.40
DisposableBase Methods
DisposableBase Class See Also

The DisposableBase type exposes the following methods.

Methods

Name | Description
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DisposableBase Class
RedGate.Shared.Utils Namespace


Dispose Method

[image] [image]

SQL Data Compare API 12.0.40
DisposableBase..::.Dispose Method
DisposableBase Class See Also

Overload List

Name | Description
Dispose()()() |
Dispose(Boolean) | Method called when disposing or finalizing.

See Also

DisposableBase Class
DisposableBase Members
RedGate.Shared.Utils Namespace


Dispose Method

[image]

SQL Data Compare API 12.0.40
DisposableBase..::.Dispose Method
DisposableBase Class See Also

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose
C#
public void Dispose()
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposableDispose()()()

See Also

DisposableBase Class
Dispose Overload
RedGate.Shared.Utils Namespace


Dispose Method ()

[image]

SQL Data Compare API 12.0.40
DisposableBase..::.Dispose Method ()
DisposableBase Class See Also

Method called when disposing or finalizing.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
C#
protected virtual void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: Boolean
If true, this was called by the Dispose()()() method, and so managed and unmanaged resources should be cleaned up. If false, this was called by the finalizer, so only unmanaged resources should be cleaned up.

Remarks

As a guide, all methods of a class inheriting IDisposable should check if it is disposed when every non-private method is called using the provided method CheckDisposed()()().

See Also

DisposableBase Class
Dispose Overload
RedGate.Shared.Utils Namespace


Finalize Method

[image]

SQL Data Compare API 12.0.40
DisposableBase..::.Finalize Method
DisposableBase Class See Also

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Finalize
C#
protected override void Finalize()
Visual C++
protected:
virtual void Finalize() override

See Also

DisposableBase Class
RedGate.Shared.Utils Namespace


DisposableBase Properties

[image] [image]

SQL Data Compare API 12.0.40
DisposableBase Properties
DisposableBase Class See Also

The DisposableBase type exposes the following properties.

Properties

Name | Description
IsDisposed | Returns a value indicating if this instance has been disposed.

See Also

DisposableBase Class
RedGate.Shared.Utils Namespace


IsDisposed Property

[image]

SQL Data Compare API 12.0.40
DisposableBase..::.IsDisposed Property
DisposableBase Class See Also

Returns a value indicating if this instance has been disposed.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsDisposed As Boolean
C#
public bool IsDisposed { get; }
Visual C++
public:
virtual property bool IsDisposed {
    bool get () sealed;
}

See Also

DisposableBase Class
RedGate.Shared.Utils Namespace


ICancellable Interface

[image]

SQL Data Compare API 12.0.40
ICancellable Interface
Members See Also

An interface for objects with operations that can be cancelled.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Interface ICancellable
C#
public interface ICancellable
Visual C++
public interface class ICancellable

Remarks

SQL Compare and SQL Data Compare have operations which can take a long time and may need to be cancelled. Examples include executing SQL scripts, registering databases in SQL Compare and generating SQL Data Compare scripts.

If a long-running operation is cancelled then an OperationCancelledException is thrown

See RedGate.SQLDataCompare.Engine.ComparisonSession for a code sample.

See Also

ICancellable Members
RedGate.Shared.Utils Namespace


ICancellable Members

[image] [image]

SQL Data Compare API 12.0.40
ICancellable Members
ICancellable Interface Methods Properties See Also

The ICancellable type exposes the following members.

Methods

Name | Description
CancelOperation | Cancels the current running operation. This will throw an instance of OperationCancelledException at the currently executing location on the executing thread

Properties

Name | Description
Status | Gets and sets a delegate that can be used to notify of message or percentage changes

See Also

ICancellable Interface
RedGate.Shared.Utils Namespace


ICancellable Methods

[image] [image]

SQL Data Compare API 12.0.40
ICancellable Methods
ICancellable Interface See Also

The ICancellable type exposes the following methods.

Methods

Name | Description
CancelOperation | Cancels the current running operation. This will throw an instance of OperationCancelledException at the currently executing location on the executing thread

See Also

ICancellable Interface
RedGate.Shared.Utils Namespace


CancelOperation Method

[image]

SQL Data Compare API 12.0.40
ICancellable..::.CancelOperation Method
ICancellable Interface See Also

Cancels the current running operation. This will throw an instance of OperationCancelledException at the currently executing location on the executing thread

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Sub CancelOperation
C#
void CancelOperation()
Visual C++
void CancelOperation()

See Also

ICancellable Interface
RedGate.Shared.Utils Namespace


ICancellable Properties

[image] [image]

SQL Data Compare API 12.0.40
ICancellable Properties
ICancellable Interface See Also

The ICancellable type exposes the following properties.

Properties

Name | Description
Status | Gets and sets a delegate that can be used to notify of message or percentage changes

See Also

ICancellable Interface
RedGate.Shared.Utils Namespace


Status Property

[image]

SQL Data Compare API 12.0.40
ICancellable..::.Status Property
ICancellable Interface See Also

Gets and sets a delegate that can be used to notify of message or percentage changes

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Property Status As StatusEventHandler
C#
StatusEventHandler Status { get; set; }
Visual C++
property StatusEventHandler^ Status {
    StatusEventHandler^ get ();
    void set (StatusEventHandler^ value);
}

See Also

ICancellable Interface
RedGate.Shared.Utils Namespace


OperationCancelledException Class

[image]

SQL Data Compare API 12.0.40
OperationCancelledException Class
Members See Also

This exception is thrown when the operation is cancelled by the CancelOperation()()() method. This is becoming obsolete in favour of OperationCanceledException. You should never throw this exception, and always catch both types of exception if any.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class OperationCancelledException _
    Inherits Exception
C#
[SerializableAttribute]
public class OperationCancelledException : Exception
Visual C++
[SerializableAttribute]
public ref class OperationCancelledException : public Exception

Inheritance Hierarchy

Object
Exception
RedGate.Shared.Utils..::.OperationCancelledException

See Also

OperationCancelledException Members
RedGate.Shared.Utils Namespace


OperationCancelledException Members

[image] [image]

SQL Data Compare API 12.0.40
OperationCancelledException Members
OperationCancelledException Class Constructors Methods Properties See Also

The OperationCancelledException type exposes the following members.

Constructors

Name | Description
OperationCancelledException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

OperationCancelledException Class
RedGate.Shared.Utils Namespace


OperationCancelledException Constructor

[image] [image]

SQL Data Compare API 12.0.40
OperationCancelledException Constructor
OperationCancelledException Class See Also

Overload List

Name | Description
OperationCancelledException()()() | Initializes a new instance of the OperationCancelledException class.
OperationCancelledException(String) | Initializes a new instance of the OperationCancelledException class with a specified error message.
OperationCancelledException(SerializationInfo, StreamingContext) | Initializes a new instance of the OperationCancelledException class with serialized data.
OperationCancelledException(String, Exception) | Initializes a new instance of the OperationCancelledException class with a specified error message and a reference to the inner exception that is the cause of this exception.

See Also

OperationCancelledException Class
OperationCancelledException Members
RedGate.Shared.Utils Namespace


OperationCancelledException Constructor

[image]

SQL Data Compare API 12.0.40
OperationCancelledException Constructor
OperationCancelledException Class See Also

Initializes a new instance of the OperationCancelledException class.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public OperationCancelledException()
Visual C++
public:
OperationCancelledException()

See Also

OperationCancelledException Class
OperationCancelledException Overload
RedGate.Shared.Utils Namespace


OperationCancelledException Constructor ()

[image]

SQL Data Compare API 12.0.40
OperationCancelledException Constructor ()
OperationCancelledException Class See Also

Initializes a new instance of the OperationCancelledException class with a specified error message.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public OperationCancelledException(
    string message
)
Visual C++
public:
OperationCancelledException(
    String^ message
)

Parameters

message
Type: String
A message that describes the error.

See Also

OperationCancelledException Class
OperationCancelledException Overload
RedGate.Shared.Utils Namespace


OperationCancelledException Constructor (, )

[image]

SQL Data Compare API 12.0.40
OperationCancelledException Constructor (, )
OperationCancelledException Class See Also

Initializes a new instance of the OperationCancelledException class with serialized data.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected OperationCancelledException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
OperationCancelledException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: SerializationInfo
The object that holds the serialized object data.
context
Type: StreamingContext
The contextual information about the source or destination.

See Also

OperationCancelledException Class
OperationCancelledException Overload
RedGate.Shared.Utils Namespace


OperationCancelledException Constructor (, )

[image]

SQL Data Compare API 12.0.40
OperationCancelledException Constructor (, )
OperationCancelledException Class See Also

Initializes a new instance of the OperationCancelledException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
C#
public OperationCancelledException(
    string message,
    Exception innerException
)
Visual C++
public:
OperationCancelledException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: String
The error message that explains the reason for the exception.
innerException
Type: Exception
The exception that is the cause of the current exception.

See Also

OperationCancelledException Class
OperationCancelledException Overload
RedGate.Shared.Utils Namespace


StatusEventArgs Class

[image]

SQL Data Compare API 12.0.40
StatusEventArgs Class
Members See Also

Represents arguments to the StatusEventHandler event.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Class StatusEventArgs _
    Inherits EventArgs
C#
public class StatusEventArgs : EventArgs
Visual C++
public ref class StatusEventArgs : public EventArgs

Inheritance Hierarchy

Object
EventArgs
RedGate.Shared.Utils..::.StatusEventArgs

See Also

StatusEventArgs Members
RedGate.Shared.Utils Namespace


StatusEventArgs Members

[image] [image]

SQL Data Compare API 12.0.40
StatusEventArgs Members
StatusEventArgs Class Constructors Methods Properties See Also

The StatusEventArgs type exposes the following members.

Constructors

Name | Description
StatusEventArgs | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Message | The status message.
Percentage | The percentage complete.

See Also

StatusEventArgs Class
RedGate.Shared.Utils Namespace


StatusEventArgs Constructor

[image] [image]

SQL Data Compare API 12.0.40
StatusEventArgs Constructor
StatusEventArgs Class See Also

Overload List

Name | Description
StatusEventArgs(Int32) | Initializes a new instance of the StatusEventArgs class with the specified completion percentage.
StatusEventArgs(String) | Initializes a new instance of the StatusEventArgs class with the specified message.
StatusEventArgs(String, Int32) | Initializes a new instance of the StatusEventArgs class with the specified message and completion percentage.

See Also

StatusEventArgs Class
StatusEventArgs Members
RedGate.Shared.Utils Namespace


StatusEventArgs Constructor ()

[image]

SQL Data Compare API 12.0.40
StatusEventArgs Constructor ()
StatusEventArgs Class See Also

Initializes a new instance of the StatusEventArgs class with the specified completion percentage.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    percentage As Integer _
)
C#
public StatusEventArgs(
    int percentage
)
Visual C++
public:
StatusEventArgs(
    int percentage
)

Parameters

percentage
Type: Int32
The percentage complete of the currently executing operation.

See Also

StatusEventArgs Class
StatusEventArgs Overload
RedGate.Shared.Utils Namespace


StatusEventArgs Constructor ()

[image]

SQL Data Compare API 12.0.40
StatusEventArgs Constructor ()
StatusEventArgs Class See Also

Initializes a new instance of the StatusEventArgs class with the specified message.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public StatusEventArgs(
    string message
)
Visual C++
public:
StatusEventArgs(
    String^ message
)

Parameters

message
Type: String
The status message.

See Also

StatusEventArgs Class
StatusEventArgs Overload
RedGate.Shared.Utils Namespace


StatusEventArgs Constructor (, )

[image]

SQL Data Compare API 12.0.40
StatusEventArgs Constructor (, )
StatusEventArgs Class See Also

Initializes a new instance of the StatusEventArgs class with the specified message and completion percentage.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    percentage As Integer _
)
C#
public StatusEventArgs(
    string message,
    int percentage
)
Visual C++
public:
StatusEventArgs(
    String^ message,
    int percentage
)

Parameters

message
Type: String
The status message.
percentage
Type: Int32
The percentage complete of the currently executing operation.

See Also

StatusEventArgs Class
StatusEventArgs Overload
RedGate.Shared.Utils Namespace


StatusEventArgs Properties

[image] [image]

SQL Data Compare API 12.0.40
StatusEventArgs Properties
StatusEventArgs Class See Also

The StatusEventArgs type exposes the following properties.

Properties

Name | Description
Message | The status message.
Percentage | The percentage complete.

See Also

StatusEventArgs Class
RedGate.Shared.Utils Namespace


Message Property

[image]

SQL Data Compare API 12.0.40
StatusEventArgs..::.Message Property
StatusEventArgs Class See Also

The status message.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Message As String
C#
public string Message { get; }
Visual C++
public:
property String^ Message {
    String^ get ();
}

Remarks

This can be null.

See Also

StatusEventArgs Class
RedGate.Shared.Utils Namespace


Percentage Property

[image]

SQL Data Compare API 12.0.40
StatusEventArgs..::.Percentage Property
StatusEventArgs Class See Also

The percentage complete.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Percentage As Integer
C#
public int Percentage { get; }
Visual C++
public:
property int Percentage {
    int get ();
}

Remarks

This is -1 if there is no percentage complete information.

See Also

StatusEventArgs Class
RedGate.Shared.Utils Namespace


StatusEventHandler Delegate

[image]

SQL Data Compare API 12.0.40
StatusEventHandler Delegate
See Also

Represents a method that can receive status events.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub StatusEventHandler ( _
    sender As Object, _
    e As StatusEventArgs _
)
C#
public delegate void StatusEventHandler(
    Object sender,
    StatusEventArgs e
)
Visual C++
public delegate void StatusEventHandler(
    Object^ sender,
    StatusEventArgs^ e
)

Parameters

sender
Type: Object
The source of the event.
e
Type: RedGate.Shared.Utils..::.StatusEventArgs
A StatusEventArgs object that contains the event data.

See Also

RedGate.Shared.Utils Namespace


RedGate.Shared.Utils.Collections Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.Shared.Utils.Collections Namespace

Classes

Class | Description
DictionaryBasedSet<(Of <(T>)>) | Class containing all the ICollection implementations for a dictionary-backed Set, that simply pass the relevant methods calls to the private backing dictionary.
EnumerableBase<(Of <(T>)>) | An enumerable that adds various other useful methods for object membership.
InnerList<(Of <(T>)>) | A collection wrapping a List object.
Set<(Of <(T>)>) | A collection representing an unordered set of unique values.


DictionaryBasedSet(T) Generic Class

[image]

SQL Data Compare API 12.0.40
DictionaryBasedSet<(Of <(T>)>) Generic Class
Members See Also

Class containing all the ICollection implementations for a dictionary-backed Set, that simply pass the relevant methods calls to the private backing dictionary.

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public MustInherit Class DictionaryBasedSet(Of T) _
    Inherits EnumerableBase(Of T) _
    Implements ICollection(Of T), IEnumerable(Of T),  _
    ICollection, IEnumerable
C#
[SerializableAttribute]
public abstract class DictionaryBasedSet<T> : EnumerableBase<T>, ICollection<T>,
    IEnumerable<T>, ICollection, IEnumerable
Visual C++
[SerializableAttribute]
generic<typename T>
public ref class DictionaryBasedSet abstract : public EnumerableBase<T>,
    ICollection<T>, IEnumerable<T>, ICollection, IEnumerable

Type Parameters

T
The type to store in the set.

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <(T>)>)
RedGate.Shared.Utils.Collections..::.DictionaryBasedSet<(Of <(T>)>)
RedGate.Shared.Utils.Collections..::.Set<(Of <(T>)>)

See Also

DictionaryBasedSet<(Of <(T>)>) Members
RedGate.Shared.Utils.Collections Namespace


DictionaryBasedSet(T) Members

[image] [image]

SQL Data Compare API 12.0.40
DictionaryBasedSet<(Of <(T>)>) Members
DictionaryBasedSet<(Of <(T>)>) Class Methods Properties Explicit Interface Implementations See Also

The DictionaryBasedSet<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Add |
AddIfNotExists | Adds item to the DictionaryBasedSet<(Of <(T>)>) if it does not already exist.
AddRange |
AddRangeIfNotExists | Adds items to the DictionaryBasedSet<(Of <(T>)>) only if none of the items are already in the set.
Clear |
Contains |
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo |
Difference |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Overrides EnumerableBase <(Of <( T >)>)..::. GetEnumerator()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersection |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
Union |

Properties

Name | Description
Count |
IsReadOnly |

Explicit Interface Implementations

Name | Description
ICollectionCopyTo |
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)
ICollectionIsSynchronized |
ICollectionSyncRoot |

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


DictionaryBasedSet(T) Methods

[image] [image]

SQL Data Compare API 12.0.40
DictionaryBasedSet<(Of <(T>)>) Methods
DictionaryBasedSet<(Of <(T>)>) Class See Also

The DictionaryBasedSet<(Of <(T>)>) type exposes the following methods.

Methods

Name | Description
Add |
AddIfNotExists | Adds item to the DictionaryBasedSet<(Of <(T>)>) if it does not already exist.
AddRange |
AddRangeIfNotExists | Adds items to the DictionaryBasedSet<(Of <(T>)>) only if none of the items are already in the set.
Clear |
Contains |
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo |
Difference |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Overrides EnumerableBase <(Of <( T >)>)..::. GetEnumerator()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersection |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
Union |

Explicit Interface Implementations

Name | Description
ICollectionCopyTo |
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


Add Method

[image]

SQL Data Compare API 12.0.40
DictionaryBasedSet<(Of <(T>)>)..::.Add Method
DictionaryBasedSet<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add ( _
    item As T _
)
C#
public void Add(
    T item
)
Visual C++
public:
virtual void Add(
    T item
) sealed

Parameters

item
Type: T

Implements

ICollectionAdd(UTP)

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


AddIfNotExists Method

[image]

SQL Data Compare API 12.0.40
DictionaryBasedSet<(Of <(T>)>)..::.AddIfNotExists Method
DictionaryBasedSet<(Of <(T>)>) Class See Also

Adds item to the DictionaryBasedSet<(Of <(T>)>) if it does not already exist.

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Function AddIfNotExists ( _
    item As T _
) As Boolean
C#
public bool AddIfNotExists(
    T item
)
Visual C++
public:
bool AddIfNotExists(
    T item
)

Parameters

item
Type: T
The item to add to the DictionaryBasedSet<(Of <(T>)>).

Return Value

True if the item was successfully added, false if it is in the set already.

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


AddRange Method

[image]

SQL Data Compare API 12.0.40
DictionaryBasedSet<(Of <(T>)>)..::.AddRange Method
DictionaryBasedSet<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddRange ( _
    items As IEnumerable(Of T) _
)
C#
public void AddRange(
    IEnumerable<T> items
)
Visual C++
public:
void AddRange(
    IEnumerable<T>^ items
)

Parameters

items
Type: IEnumerable<(Of <( T >)>)

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


AddRangeIfNotExists Method

[image]

SQL Data Compare API 12.0.40
DictionaryBasedSet<(Of <(T>)>)..::.AddRangeIfNotExists Method
DictionaryBasedSet<(Of <(T>)>) Class See Also

Adds items to the DictionaryBasedSet<(Of <(T>)>) only if none of the items are already in the set.

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Function AddRangeIfNotExists ( _
    items As IEnumerable(Of T) _
) As Boolean
C#
public bool AddRangeIfNotExists(
    IEnumerable<T> items
)
Visual C++
public:
bool AddRangeIfNotExists(
    IEnumerable<T>^ items
)

Parameters

items
Type: IEnumerable<(Of <( T >)>)

Return Value

True if none of the items were already in the set, so the items were added.

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


Clear Method

[image]

SQL Data Compare API 12.0.40
DictionaryBasedSet<(Of <(T>)>)..::.Clear Method
DictionaryBasedSet<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear
C#
public void Clear()
Visual C++
public:
virtual void Clear() sealed

Implements

ICollectionClear()()()

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


Contains Method

[image]

SQL Data Compare API 12.0.40
DictionaryBasedSet<(Of <(T>)>)..::.Contains Method
DictionaryBasedSet<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains ( _
    item As T _
) As Boolean
C#
public bool Contains(
    T item
)
Visual C++
public:
virtual bool Contains(
    T item
) sealed

Parameters

item
Type: T

Implements

ICollectionContains(UTP)

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


CopyTo Method

[image]

SQL Data Compare API 12.0.40
DictionaryBasedSet<(Of <(T>)>)..::.CopyTo Method
DictionaryBasedSet<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As T(), _
    startIndex As Integer _
)
C#
public void CopyTo(
    T[] array,
    int startIndex
)
Visual C++
public:
virtual void CopyTo(
    array<T>^ array,
    int startIndex
) sealed

Parameters

array
Type: array< T >[]()[]
startIndex
Type: Int32

Implements

ICollectionCopyTo(array<UTP>[]()[], Int32)

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


. Method

[image]

SQL Data Compare API 12.0.40
DictionaryBasedSet<(Of <(T>)>)..::...::. Method
DictionaryBasedSet<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Private Sub CopyTo ( _
    array As Array, _
    index As Integer _
) Implements ICollection.CopyTo
C#
void ICollection.CopyTo(
    Array array,
    int index
)
Visual C++
private:
virtual void CopyTo(
    Array^ array,
    int index
) sealed = ICollection::CopyTo

Parameters

array
Type: Array
index
Type: Int32

Implements

ICollectionCopyTo(Array, Int32)

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


Difference Method

[image]

SQL Data Compare API 12.0.40
DictionaryBasedSet<(Of <(T>)>)..::.Difference Method
DictionaryBasedSet<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Difference ( _
    other As ISet(Of T) _
) As IEnumerable(Of T)
C#
public virtual IEnumerable<T> Difference(
    ISet<T> other
)
Visual C++
public:
virtual IEnumerable<T>^ Difference(
    ISet<T>^ other
)

Parameters

other
Type: ISet<(Of <( T >)>)

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


GetEnumerator Method

[image]

SQL Data Compare API 12.0.40
DictionaryBasedSet<(Of <(T>)>)..::.GetEnumerator Method
DictionaryBasedSet<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetEnumerator As IEnumerator(Of T)
C#
public override sealed IEnumerator<T> GetEnumerator()
Visual C++
public:
virtual IEnumerator<T>^ GetEnumerator() override sealed

Implements

IEnumerableGetEnumerator()()()

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


Intersection Method

[image]

SQL Data Compare API 12.0.40
DictionaryBasedSet<(Of <(T>)>)..::.Intersection Method
DictionaryBasedSet<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Intersection ( _
    other As ISet(Of T) _
) As IEnumerable(Of T)
C#
public virtual IEnumerable<T> Intersection(
    ISet<T> other
)
Visual C++
public:
virtual IEnumerable<T>^ Intersection(
    ISet<T>^ other
)

Parameters

other
Type: ISet<(Of <( T >)>)

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


Remove Method

[image]

SQL Data Compare API 12.0.40
DictionaryBasedSet<(Of <(T>)>)..::.Remove Method
DictionaryBasedSet<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Function Remove ( _
    item As T _
) As Boolean
C#
public bool Remove(
    T item
)
Visual C++
public:
virtual bool Remove(
    T item
) sealed

Parameters

item
Type: T

Implements

ICollectionRemove(UTP)

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


Union Method

[image]

SQL Data Compare API 12.0.40
DictionaryBasedSet<(Of <(T>)>)..::.Union Method
DictionaryBasedSet<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Union ( _
    other As ISet(Of T) _
) As IEnumerable(Of T)
C#
public virtual IEnumerable<T> Union(
    ISet<T> other
)
Visual C++
public:
virtual IEnumerable<T>^ Union(
    ISet<T>^ other
)

Parameters

other
Type: ISet<(Of <( T >)>)

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


DictionaryBasedSet(T) Properties

[image] [image]

SQL Data Compare API 12.0.40
DictionaryBasedSet<(Of <(T>)>) Properties
DictionaryBasedSet<(Of <(T>)>) Class See Also

The DictionaryBasedSet<(Of <(T>)>) type exposes the following properties.

Properties

Name | Description
Count |
IsReadOnly |

Explicit Interface Implementations

Name | Description
ICollectionIsSynchronized |
ICollectionSyncRoot |

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


Count Property

[image]

SQL Data Compare API 12.0.40
DictionaryBasedSet<(Of <(T>)>)..::.Count Property
DictionaryBasedSet<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count { get; }
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollectionCount()()()
ICollectionCount()()()

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


IsReadOnly Property

[image]

SQL Data Compare API 12.0.40
DictionaryBasedSet<(Of <(T>)>)..::.IsReadOnly Property
DictionaryBasedSet<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
C#
public bool IsReadOnly { get; }
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Implements

ICollectionIsReadOnly()()()

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


. Property

[image]

SQL Data Compare API 12.0.40
DictionaryBasedSet<(Of <(T>)>)..::...::. Property
DictionaryBasedSet<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Private ReadOnly Property IsSynchronized As Boolean
    Implements ICollection.IsSynchronized
C#
bool ICollection.IsSynchronized { get; }
Visual C++
private:
virtual property bool IsSynchronized {
    bool get () sealed = ICollection::IsSynchronized::get;
}

Implements

ICollectionIsSynchronized()()()

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


. Property

[image]

SQL Data Compare API 12.0.40
DictionaryBasedSet<(Of <(T>)>)..::...::. Property
DictionaryBasedSet<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Private ReadOnly Property SyncRoot As Object
    Implements ICollection.SyncRoot
C#
Object ICollection.SyncRoot { get; }
Visual C++
private:
virtual property Object^ SyncRoot {
    Object^ get () sealed = ICollection::SyncRoot::get;
}

Implements

ICollectionSyncRoot()()()

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


EnumerableBase(T) Generic Class

[image]

SQL Data Compare API 12.0.40
EnumerableBase<(Of <(T>)>) Generic Class
Members See Also

An enumerable that adds various other useful methods for object membership.

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public MustInherit Class EnumerableBase(Of T) _
    Implements IEnumerable(Of T), IEnumerable
C#
[SerializableAttribute]
public abstract class EnumerableBase<T> : IEnumerable<T>,
    IEnumerable
Visual C++
[SerializableAttribute]
generic<typename T>
public ref class EnumerableBase abstract : IEnumerable<T>,
    IEnumerable

Type Parameters

T
The type of object returned from the enumerable.

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Collections..::.EnumerableBase<(Of <(T>)>)
RedGate.Shared.Utils.Collections..::.InnerList<(Of <(T>)>)
RedGate.Shared.Utils.Collections..::.DictionaryBasedSet<(Of <(T>)>)

See Also

EnumerableBase<(Of <(T>)>) Members
RedGate.Shared.Utils.Collections Namespace


EnumerableBase(T) Members

[image] [image]

SQL Data Compare API 12.0.40
EnumerableBase<(Of <(T>)>) Members
EnumerableBase<(Of <(T>)>) Class Methods Explicit Interface Implementations See Also

The EnumerableBase<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate.
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate.
FindFirst | Returns the first object in this IEnumerable that satisfies predicate.
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable.

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator |

See Also

EnumerableBase<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


EnumerableBase(T) Methods

[image] [image]

SQL Data Compare API 12.0.40
EnumerableBase<(Of <(T>)>) Methods
EnumerableBase<(Of <(T>)>) Class See Also

The EnumerableBase<(Of <(T>)>) type exposes the following methods.

Methods

Name | Description
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate.
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate.
FindFirst | Returns the first object in this IEnumerable that satisfies predicate.
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable.

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator |

See Also

EnumerableBase<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


ConvertAll(TOutput) Generic Method

[image]

SQL Data Compare API 12.0.40
EnumerableBase<(Of <(T>)>)..::.ConvertAll<(Of <(TOutput>)>) Generic Method
EnumerableBase<(Of <(T>)>) Class See Also

Returns an IEnumerable with the result of running converter on each element of this IEnumerable.

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ConvertAll(Of TOutput) ( _
    converter As Converter(Of T, TOutput) _
) As IEnumerable(Of TOutput)
C#
public virtual IEnumerable<TOutput> ConvertAll<TOutput>(
    Converter<T, TOutput> converter
)
Visual C++
public:
generic<typename TOutput>
virtual IEnumerable<TOutput>^ ConvertAll(
    Converter<T, TOutput>^ converter
)

Parameters

converter
Type: Converter<(Of <( T, TOutput>)>)
A Converter

Type Parameters

TOutput
The output type.

Return Value

An IEnumerable of the result of running converter on each element of this IEnumerable

See Also

EnumerableBase<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


Exists Method

[image]

SQL Data Compare API 12.0.40
EnumerableBase<(Of <(T>)>)..::.Exists Method
EnumerableBase<(Of <(T>)>) Class See Also

Determines if there is an element in this IEnumerable that satisfies predicate.

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Exists ( _
    predicate As Predicate(Of T) _
) As Boolean
C#
public virtual bool Exists(
    Predicate<T> predicate
)
Visual C++
public:
virtual bool Exists(
    Predicate<T>^ predicate
)

Parameters

predicate
Type: Predicate<(Of <( T >)>)
The predicate.

Return Value

True if there is an element in this IEnumerable for which [!:predicate] is true.

See Also

EnumerableBase<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


ExistsCount Method

[image]

SQL Data Compare API 12.0.40
EnumerableBase<(Of <(T>)>)..::.ExistsCount Method
EnumerableBase<(Of <(T>)>) Class See Also

Determines the number of elements in this IEnumerable that satisfy predicate.

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ExistsCount ( _
    predicate As Predicate(Of T) _
) As Integer
C#
public virtual int ExistsCount(
    Predicate<T> predicate
)
Visual C++
public:
virtual int ExistsCount(
    Predicate<T>^ predicate
)

Parameters

predicate
Type: Predicate<(Of <( T >)>)
The predicate.

Return Value

The number of elements in this IEnumerable for which predicate returns true.

See Also

EnumerableBase<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


FindAll Method

[image]

SQL Data Compare API 12.0.40
EnumerableBase<(Of <(T>)>)..::.FindAll Method
EnumerableBase<(Of <(T>)>) Class See Also

Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate.

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function FindAll ( _
    predicate As Predicate(Of T) _
) As IEnumerable(Of T)
C#
public virtual IEnumerable<T> FindAll(
    Predicate<T> predicate
)
Visual C++
public:
virtual IEnumerable<T>^ FindAll(
    Predicate<T>^ predicate
)

Parameters

predicate
Type: Predicate<(Of <( T >)>)
The predicate.

Return Value

An IEnumerable of all the objects returned by this IEnumerable that satisfy predicate.

See Also

EnumerableBase<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


FindFirst Method

[image]

SQL Data Compare API 12.0.40
EnumerableBase<(Of <(T>)>)..::.FindFirst Method
EnumerableBase<(Of <(T>)>) Class See Also

Returns the first object in this IEnumerable that satisfies predicate.

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function FindFirst ( _
    predicate As Predicate(Of T) _
) As T
C#
public virtual T FindFirst(
    Predicate<T> predicate
)
Visual C++
public:
virtual T FindFirst(
    Predicate<T>^ predicate
)

Parameters

predicate
Type: Predicate<(Of <( T >)>)
The predicate.

Return Value

The first object that satisfies predicate.

See Also

EnumerableBase<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


GetEnumerator Method

[image]

SQL Data Compare API 12.0.40
EnumerableBase<(Of <(T>)>)..::.GetEnumerator Method
EnumerableBase<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetEnumerator As IEnumerator(Of T)
C#
public abstract IEnumerator<T> GetEnumerator()
Visual C++
public:
virtual IEnumerator<T>^ GetEnumerator() abstract

Implements

IEnumerableGetEnumerator()()()

See Also

EnumerableBase<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


. Method

[image]

SQL Data Compare API 12.0.40
EnumerableBase<(Of <(T>)>)..::...::. Method
EnumerableBase<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
C#
IEnumerator IEnumerable.GetEnumerator()
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerableGetEnumerator()()()

See Also

EnumerableBase<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


TrueForAll Method

[image]

SQL Data Compare API 12.0.40
EnumerableBase<(Of <(T>)>)..::.TrueForAll Method
EnumerableBase<(Of <(T>)>) Class See Also

Determines if predicate is true for all objects returned by this IEnumerable.

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function TrueForAll ( _
    predicate As Predicate(Of T) _
) As Boolean
C#
public virtual bool TrueForAll(
    Predicate<T> predicate
)
Visual C++
public:
virtual bool TrueForAll(
    Predicate<T>^ predicate
)

Parameters

predicate
Type: Predicate<(Of <( T >)>)
The predicate.

Return Value

True if predicate is true for every object returned by this IEnumerable.

See Also

EnumerableBase<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


InnerList(T) Generic Class

[image]

SQL Data Compare API 12.0.40
InnerList<(Of <(T>)>) Generic Class
Members See Also

A collection wrapping a List object.

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public MustInherit Class InnerList(Of T) _
    Inherits EnumerableBase(Of T) _
    Implements IList(Of T), ICollection(Of T),  _
    IEnumerable(Of T), IEnumerable
C#
[SerializableAttribute]
public abstract class InnerList<T> : EnumerableBase<T>, IList<T>,
    ICollection<T>, IEnumerable<T>, IEnumerable
Visual C++
[SerializableAttribute]
generic<typename T>
public ref class InnerList abstract : public EnumerableBase<T>,
    IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable

Type Parameters

T
The type stored in the list.

Remarks

This class is intended to simplify programming wrapper collections around lists; all the methods are virtual so can be overridden as required for the particular collection.

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( T >)>)
RedGate.Shared.Utils.Collections..::.InnerList<(Of <(T>)>)
RedGate.SQLCompare.Engine..::.ClrFiles
RedGate.SQLCompare.Engine..::.FileGroups
RedGate.SQLCompare.Engine..::.FlatFieldList
RedGate.SQLCompare.Engine..::.Mappings<(Of <(TMapping, TMap, TContext>)>)
RedGate.SQLCompare.Engine..::.Messages
RedGate.SQLCompare.Engine..::.Permissions
RedGate.SQLCompare.Engine..::.PermissionsCollection
RedGate.SQLCompare.Engine..::.Regions
RedGate.SQLDataCompare.Engine..::.FieldPairs
RedGate.SQLDataCompare.Engine..::.TableDifferences
RedGate.SQLDataCompare.Engine.ResultsStore..::.ColumnSorts

See Also

InnerList<(Of <(T>)>) Members
RedGate.Shared.Utils.Collections Namespace


InnerList(T) Members

[image] [image]

SQL Data Compare API 12.0.40
InnerList<(Of <(T>)>) Members
InnerList<(Of <(T>)>) Class Methods Properties Explicit Interface Implementations See Also

The InnerList<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Contains |
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Overrides EnumerableBase <(Of <( T >)>)..::. GetEnumerator()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Properties

Name | Description
Count |
Item |

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

InnerList<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


InnerList(T) Methods

[image] [image]

SQL Data Compare API 12.0.40
InnerList<(Of <(T>)>) Methods
InnerList<(Of <(T>)>) Class See Also

The InnerList<(Of <(T>)>) type exposes the following methods.

Methods

Name | Description
Contains |
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Overrides EnumerableBase <(Of <( T >)>)..::. GetEnumerator()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

InnerList<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


Contains Method

[image]

SQL Data Compare API 12.0.40
InnerList<(Of <(T>)>)..::.Contains Method
InnerList<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As T _
) As Boolean
C#
public virtual bool Contains(
    T item
)
Visual C++
public:
virtual bool Contains(
    T item
)

Parameters

item
Type: T

Implements

ICollectionContains(UTP)

See Also

InnerList<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


CopyTo Method

[image]

SQL Data Compare API 12.0.40
InnerList<(Of <(T>)>)..::.CopyTo Method
InnerList<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub CopyTo ( _
    array As T(), _
    index As Integer _
)
C#
public virtual void CopyTo(
    T[] array,
    int index
)
Visual C++
public:
virtual void CopyTo(
    array<T>^ array,
    int index
)

Parameters

array
Type: array< T >[]()[]
index
Type: Int32

Implements

ICollectionCopyTo(array<UTP>[]()[], Int32)

See Also

InnerList<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


GetEnumerator Method

[image]

SQL Data Compare API 12.0.40
InnerList<(Of <(T>)>)..::.GetEnumerator Method
InnerList<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetEnumerator As IEnumerator(Of T)
C#
public override IEnumerator<T> GetEnumerator()
Visual C++
public:
virtual IEnumerator<T>^ GetEnumerator() override

Implements

IEnumerableGetEnumerator()()()

See Also

InnerList<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


IndexOf Method

[image]

SQL Data Compare API 12.0.40
InnerList<(Of <(T>)>)..::.IndexOf Method
InnerList<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function IndexOf ( _
    item As T _
) As Integer
C#
public virtual int IndexOf(
    T item
)
Visual C++
public:
virtual int IndexOf(
    T item
)

Parameters

item
Type: T

Implements

IListIndexOf(UTP)

See Also

InnerList<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


InnerList(T) Properties

[image] [image]

SQL Data Compare API 12.0.40
InnerList<(Of <(T>)>) Properties
InnerList<(Of <(T>)>) Class See Also

The InnerList<(Of <(T>)>) type exposes the following properties.

Properties

Name | Description
Count |
Item |

See Also

InnerList<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


Count Property

[image]

SQL Data Compare API 12.0.40
InnerList<(Of <(T>)>)..::.Count Property
InnerList<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Count As Integer
C#
public virtual int Count { get; }
Visual C++
public:
virtual property int Count {
    int get ();
}

Implements

ICollectionCount()()()

See Also

InnerList<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


Item Property

[image]

SQL Data Compare API 12.0.40
InnerList<(Of <(T>)>)..::.Item Property
InnerList<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Default Property Item ( _
    index As Integer _
) As T
C#
public virtual T this[
    int index
] { get; set; }
Visual C++
public:
virtual property T default[int index] {
    T get (int index);
    void set (int index, T value);
}

Parameters

index
Type: Int32

Implements

IListItem(Int32)

See Also

InnerList<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


Set(T) Generic Class

[image]

SQL Data Compare API 12.0.40
Set<(Of <(T>)>) Generic Class
Members See Also

A collection representing an unordered set of unique values.

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class Set(Of T) _
    Inherits DictionaryBasedSet(Of T)
C#
[SerializableAttribute]
public class Set<T> : DictionaryBasedSet<T>
Visual C++
[SerializableAttribute]
generic<typename T>
public ref class Set : public DictionaryBasedSet<T>

Type Parameters

T
The type to store in this set.

Remarks

Please note that behaviour of the set operations is undefined between two Sets that use different IEqualityComparers.

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <(T>)>)
RedGate.Shared.Utils.Collections..::.DictionaryBasedSet <(Of <(T>)>)
RedGate.Shared.Utils.Collections..::.Set<(Of <(T>)>)
RedGate.SQLCompare.Engine.Filter..::.FilterConditionCollection<(Of <(T>)>)

See Also

Set<(Of <(T>)>) Members
RedGate.Shared.Utils.Collections Namespace


Set(T) Members

[image] [image]

SQL Data Compare API 12.0.40
Set<(Of <(T>)>) Members
Set<(Of <(T>)>) Class Constructors Methods Properties Explicit Interface Implementations See Also

The Set<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
Set<(Of <(T>)>) | Overloaded.

Methods

Name | Description
Add | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
AddIfNotExists | Adds item to the DictionaryBasedSet<(Of <(T>)>) if it does not already exist. (Inherited from DictionaryBasedSet<(Of <(T>)>).)
AddRange | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
AddRangeIfNotExists | Adds items to the DictionaryBasedSet<(Of <(T>)>) only if none of the items are already in the set. (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Clear | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Contains | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Difference | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersection | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
IsDisjointWith |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
Union | (Inherited from DictionaryBasedSet<(Of <(T>)>).)

Properties

Name | Description
Count | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
IsReadOnly | (Inherited from DictionaryBasedSet<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
ICollectionCopyTo | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)
ICollectionIsSynchronized | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
ICollectionSyncRoot | (Inherited from DictionaryBasedSet<(Of <(T>)>).)

See Also

Set<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


Set(T) Constructor

[image] [image]

SQL Data Compare API 12.0.40
Set<(Of <(T>)>) Constructor
Set<(Of <(T>)>) Class See Also

Overload List

Name | Description
Set<(Of <(T>)>)()()() | Initialises a new instance of the Set<(Of <(T>)>) class with the default equality comparer and default capacity.
Set<(Of <(T>)>)(IEnumerable<(Of <(T>)>)) | Initialises a new instance of the Set<(Of <(T>)>) class with the contents copied from the specified IEnumerable, using the default equality comparer.
Set<(Of <(T>)>)(IEqualityComparer<(Of <(T>)>)) | Initialises a new instance of the Set<(Of <(T>)>) class with the default capacity and the specified IEqualityComparer.
Set<(Of <(T>)>)(Int32) | Initialises a new instance of the Set<(Of <(T>)>) class with the specified initial capacity and default equality comparer.
Set<(Of <(T>)>)(IEnumerable<(Of <(T>)>), IEqualityComparer<(Of <(T>)>)) | Initialises a new instance of the Set<(Of <(T>)>) class with the contents copied from the specified IEnumerable, using the specified IEqualityComparer.
Set<(Of <(T>)>)(Int32, IEqualityComparer<(Of <(T>)>)) | Initialises a new instance of the Set<(Of <(T>)>) class with the specified capacity and IEqualityComparer.

See Also

Set<(Of <(T>)>) Class
Set<(Of <(T>)>) Members
RedGate.Shared.Utils.Collections Namespace


Set(T) Constructor

[image]

SQL Data Compare API 12.0.40
Set<(Of <(T>)>) Constructor
Set<(Of <(T>)>) Class See Also

Initialises a new instance of the Set<(Of <(T>)>) class with the default equality comparer and default capacity.

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Set()
Visual C++
public:
Set()

See Also

Set<(Of <(T>)>) Class
Set<(Of <(T>)>) Overload
RedGate.Shared.Utils.Collections Namespace


Set(T) Constructor ((T))

[image]

SQL Data Compare API 12.0.40
Set<(Of <(T>)>) Constructor (<(Of <(T>)>))
Set<(Of <(T>)>) Class See Also

Initialises a new instance of the Set<(Of <(T>)>) class with the contents copied from the specified IEnumerable, using the default equality comparer.

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    src As IEnumerable(Of T) _
)
C#
public Set(
    IEnumerable<T> src
)
Visual C++
public:
Set(
    IEnumerable<T>^ src
)

Parameters

src
Type: IEnumerable<(Of <( T >)>)
The items to add to the Set.

See Also

Set<(Of <(T>)>) Class
Set<(Of <(T>)>) Overload
RedGate.Shared.Utils.Collections Namespace


Set(T) Constructor ((T))

[image]

SQL Data Compare API 12.0.40
Set<(Of <(T>)>) Constructor (<(Of <(T>)>))
Set<(Of <(T>)>) Class See Also

Initialises a new instance of the Set<(Of <(T>)>) class with the default capacity and the specified IEqualityComparer.

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    comparer As IEqualityComparer(Of T) _
)
C#
public Set(
    IEqualityComparer<T> comparer
)
Visual C++
public:
Set(
    IEqualityComparer<T>^ comparer
)

Parameters

comparer
Type: IEqualityComparer<(Of <( T >)>)
The equality comparer to use.

See Also

Set<(Of <(T>)>) Class
Set<(Of <(T>)>) Overload
RedGate.Shared.Utils.Collections Namespace


Set(T) Constructor ()

[image]

SQL Data Compare API 12.0.40
Set<(Of <(T>)>) Constructor ()
Set<(Of <(T>)>) Class See Also

Initialises a new instance of the Set<(Of <(T>)>) class with the specified initial capacity and default equality comparer.

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    capacity As Integer _
)
C#
public Set(
    int capacity
)
Visual C++
public:
Set(
    int capacity
)

Parameters

capacity
Type: Int32
The initial capacity.

See Also

Set<(Of <(T>)>) Class
Set<(Of <(T>)>) Overload
RedGate.Shared.Utils.Collections Namespace


Set(T) Constructor ((T), (T))

[image]

SQL Data Compare API 12.0.40
Set<(Of <(T>)>) Constructor (<(Of <(T>)>), <(Of <(T>)>))
Set<(Of <(T>)>) Class See Also

Initialises a new instance of the Set<(Of <(T>)>) class with the contents copied from the specified IEnumerable, using the specified IEqualityComparer.

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    src As IEnumerable(Of T), _
    comparer As IEqualityComparer(Of T) _
)
C#
public Set(
    IEnumerable<T> src,
    IEqualityComparer<T> comparer
)
Visual C++
public:
Set(
    IEnumerable<T>^ src,
    IEqualityComparer<T>^ comparer
)

Parameters

src
Type: IEnumerable<(Of <( T >)>)
The items to add to the Set.
comparer
Type: IEqualityComparer<(Of <( T >)>)
The equality comparer to use.

See Also

Set<(Of <(T>)>) Class
Set<(Of <(T>)>) Overload
RedGate.Shared.Utils.Collections Namespace


Set(T) Constructor (, (T))

[image]

SQL Data Compare API 12.0.40
Set<(Of <(T>)>) Constructor (, <(Of <(T>)>))
Set<(Of <(T>)>) Class See Also

Initialises a new instance of the Set<(Of <(T>)>) class with the specified capacity and IEqualityComparer.

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    capacity As Integer, _
    comparer As IEqualityComparer(Of T) _
)
C#
public Set(
    int capacity,
    IEqualityComparer<T> comparer
)
Visual C++
public:
Set(
    int capacity,
    IEqualityComparer<T>^ comparer
)

Parameters

capacity
Type: Int32
The initial capacity.
comparer
Type: IEqualityComparer<(Of <( T >)>)
The equality comparer to use.

See Also

Set<(Of <(T>)>) Class
Set<(Of <(T>)>) Overload
RedGate.Shared.Utils.Collections Namespace


Set(T) Methods

[image] [image]

SQL Data Compare API 12.0.40
Set<(Of <(T>)>) Methods
Set<(Of <(T>)>) Class See Also

The Set<(Of <(T>)>) type exposes the following methods.

Methods

Name | Description
Add | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
AddIfNotExists | Adds item to the DictionaryBasedSet<(Of <(T>)>) if it does not already exist. (Inherited from DictionaryBasedSet<(Of <(T>)>).)
AddRange | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
AddRangeIfNotExists | Adds items to the DictionaryBasedSet<(Of <(T>)>) only if none of the items are already in the set. (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Clear | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Contains | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Difference | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersection | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
IsDisjointWith |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
Union | (Inherited from DictionaryBasedSet<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
ICollectionCopyTo | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Set<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


IsDisjointWith Method

[image]

SQL Data Compare API 12.0.40
Set<(Of <(T>)>)..::.IsDisjointWith Method
Set<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Function IsDisjointWith ( _
    b As Set(Of T) _
) As Boolean
C#
public bool IsDisjointWith(
    Set<T> b
)
Visual C++
public:
bool IsDisjointWith(
    Set<T>^ b
)

Parameters

b
Type: RedGate.Shared.Utils.Collections..::.Set <(Of <( T >)>)

See Also

Set<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


RedGate.Shared.Utils.Collections.Extensions Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.Shared.Utils.Collections.Extensions Namespace

Classes

Class | Description
EnumerableExtensions |


EnumerableExtensions Class

[image]

SQL Data Compare API 12.0.40
EnumerableExtensions Class
Members See Also

Namespace: RedGate.Shared.Utils.Collections.Extensions
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class EnumerableExtensions
C#
public static class EnumerableExtensions
Visual C++
public ref class EnumerableExtensions abstract sealed

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Collections.Extensions..::.EnumerableExtensions

See Also

EnumerableExtensions Members
RedGate.Shared.Utils.Collections.Extensions Namespace


EnumerableExtensions Members

[image] [image]

SQL Data Compare API 12.0.40
EnumerableExtensions Members
EnumerableExtensions Class Methods See Also

The EnumerableExtensions type exposes the following members.

Methods

Name | Description
ConcatSingle<(Of <(T>)>) |
ForEach<(Of <(T>)>) |
GetRangeUsingIndexes<(Of <(T>)>) |
Join<(Of <(T>)>) | Joins an enumerable into a single string, separated by separator, and optionally prefixed/suffixed with start/end respectively.
Maximum<(Of <(T>)>) |

See Also

EnumerableExtensions Class
RedGate.Shared.Utils.Collections.Extensions Namespace


EnumerableExtensions Methods

[image] [image]

SQL Data Compare API 12.0.40
EnumerableExtensions Methods
EnumerableExtensions Class See Also

The EnumerableExtensions type exposes the following methods.

Methods

Name | Description
ConcatSingle<(Of <(T>)>) |
ForEach<(Of <(T>)>) |
GetRangeUsingIndexes<(Of <(T>)>) |
Join<(Of <(T>)>) | Joins an enumerable into a single string, separated by separator, and optionally prefixed/suffixed with start/end respectively.
Maximum<(Of <(T>)>) |

See Also

EnumerableExtensions Class
RedGate.Shared.Utils.Collections.Extensions Namespace


ConcatSingle(T) Generic Method

[image]

SQL Data Compare API 12.0.40
EnumerableExtensions..::.ConcatSingle<(Of <(T>)>) Generic Method
EnumerableExtensions Class See Also

Namespace: RedGate.Shared.Utils.Collections.Extensions
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ConcatSingle(Of T) ( _
    enumerable As IEnumerable(Of T), _
    singleItem As T _
) As IEnumerable(Of T)
C#
public static IEnumerable<T> ConcatSingle<T>(
    IEnumerable<T> enumerable,
    T singleItem
)
Visual C++
public:
generic<typename T>
static IEnumerable<T>^ ConcatSingle(
    IEnumerable<T>^ enumerable,
    T singleItem
)

Parameters

enumerable
Type: IEnumerable<(Of <(T>)>)
singleItem
Type: T

Type Parameters

T

See Also

EnumerableExtensions Class
RedGate.Shared.Utils.Collections.Extensions Namespace


ForEach(T) Generic Method

[image]

SQL Data Compare API 12.0.40
EnumerableExtensions..::.ForEach<(Of <(T>)>) Generic Method
EnumerableExtensions Class See Also

Namespace: RedGate.Shared.Utils.Collections.Extensions
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ForEach(Of T) ( _
    collection As IEnumerable(Of T), _
    action As Action(Of T) _
)
C#
public static void ForEach<T>(
    IEnumerable<T> collection,
    Action<T> action
)
Visual C++
public:
generic<typename T>
static void ForEach(
    IEnumerable<T>^ collection,
    Action<T>^ action
)

Parameters

collection
Type: IEnumerable<(Of <(T>)>)
action
Type: Action<(Of <(T>)>)

Type Parameters

T

See Also

EnumerableExtensions Class
RedGate.Shared.Utils.Collections.Extensions Namespace


GetRangeUsingIndexes(T) Generic Method

[image]

SQL Data Compare API 12.0.40
EnumerableExtensions..::.GetRangeUsingIndexes<(Of <(T>)>) Generic Method
EnumerableExtensions Class See Also

Namespace: RedGate.Shared.Utils.Collections.Extensions
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeUsingIndexes(Of T) ( _
    enumerable As IEnumerable(Of T), _
    startIndex As Integer, _
    endIndex As Integer _
) As List(Of T)
C#
public static List<T> GetRangeUsingIndexes<T>(
    IEnumerable<T> enumerable,
    int startIndex,
    int endIndex
)
Visual C++
public:
generic<typename T>
static List<T>^ GetRangeUsingIndexes(
    IEnumerable<T>^ enumerable,
    int startIndex,
    int endIndex
)

Parameters

enumerable
Type: IEnumerable<(Of <(T>)>)
startIndex
Type: Int32
endIndex
Type: Int32

Type Parameters

T

See Also

EnumerableExtensions Class
RedGate.Shared.Utils.Collections.Extensions Namespace


Join(T) Generic Method

[image]

SQL Data Compare API 12.0.40
EnumerableExtensions..::.Join<(Of <(T>)>) Generic Method
EnumerableExtensions Class Example See Also

Joins an enumerable into a single string, separated by separator, and optionally prefixed/suffixed with start/end respectively.

Namespace: RedGate.Shared.Utils.Collections.Extensions
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Join(Of T) ( _
    enumerable As IEnumerable(Of T), _
    separator As String, _
    start As String, _
    end As String _
) As String
C#
public static string Join<T>(
    IEnumerable<T> enumerable,
    string separator,
    string start,
    string end
)
Visual C++
public:
generic<typename T>
static String^ Join(
    IEnumerable<T>^ enumerable,
    String^ separator,
    String^ start,
    String^ end
)

Parameters

enumerable
Type: IEnumerable<(Of <(T>)>)
separator
Type: String
start
Type: String
end
Type: String

Type Parameters

T

Examples

Copy Code
            var x = new[] {"First", "Second"};
            x.Join(",", "[", "]");

returns "[First,Second]"

See Also

EnumerableExtensions Class
RedGate.Shared.Utils.Collections.Extensions Namespace


Maximum(T) Generic Method

[image]

SQL Data Compare API 12.0.40
EnumerableExtensions..::.Maximum<(Of <(T>)>) Generic Method
EnumerableExtensions Class See Also

Namespace: RedGate.Shared.Utils.Collections.Extensions
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Maximum(Of T) ( _
    collection As IEnumerable(Of T), _
    comparison As Comparison(Of T) _
) As T
C#
public static T Maximum<T>(
    IEnumerable<T> collection,
    Comparison<T> comparison
)
Visual C++
public:
generic<typename T>
static T Maximum(
    IEnumerable<T>^ collection,
    Comparison<T>^ comparison
)

Parameters

collection
Type: IEnumerable<(Of <(T>)>)
comparison
Type: Comparison<(Of <(T>)>)

Type Parameters

T

See Also

EnumerableExtensions Class
RedGate.Shared.Utils.Collections.Extensions Namespace


RedGate.Shared.Utils.CommandLine.Automation Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.Shared.Utils.CommandLine.Automation Namespace

Classes

Class | Description
Output |
Runner |


Output Class

[image]

SQL Data Compare API 12.0.40
Output Class
Members See Also

Namespace: RedGate.Shared.Utils.CommandLine.Automation
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Class Output
C#
public class Output
Visual C++
public ref class Output

Inheritance Hierarchy

Object
RedGate.Shared.Utils.CommandLine.Automation..::.Output

See Also

Output Members
RedGate.Shared.Utils.CommandLine.Automation Namespace


Output Members

[image] [image]

SQL Data Compare API 12.0.40
Output Members
Output Class Constructors Methods Properties See Also

The Output type exposes the following members.

Constructors

Name | Description
Output |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Error |
ExitCode |
StdOutput |

See Also

Output Class
RedGate.Shared.Utils.CommandLine.Automation Namespace


Output Constructor

[image]

SQL Data Compare API 12.0.40
Output Constructor
Output Class See Also

Namespace: RedGate.Shared.Utils.CommandLine.Automation
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    exitCode As Integer, _
    standardOutput As String, _
    standardError As String _
)
C#
public Output(
    int exitCode,
    string standardOutput,
    string standardError
)
Visual C++
public:
Output(
    int exitCode,
    String^ standardOutput,
    String^ standardError
)

Parameters

exitCode
Type: Int32
standardOutput
Type: String
standardError
Type: String

See Also

Output Class
RedGate.Shared.Utils.CommandLine.Automation Namespace


Output Properties

[image] [image]

SQL Data Compare API 12.0.40
Output Properties
Output Class See Also

The Output type exposes the following properties.

Properties

Name | Description
Error |
ExitCode |
StdOutput |

See Also

Output Class
RedGate.Shared.Utils.CommandLine.Automation Namespace


Error Property

[image]

SQL Data Compare API 12.0.40
Output..::.Error Property
Output Class See Also

Namespace: RedGate.Shared.Utils.CommandLine.Automation
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As String
C#
public string Error { get; }
Visual C++
public:
property String^ Error {
    String^ get ();
}

See Also

Output Class
RedGate.Shared.Utils.CommandLine.Automation Namespace


ExitCode Property

[image]

SQL Data Compare API 12.0.40
Output..::.ExitCode Property
Output Class See Also

Namespace: RedGate.Shared.Utils.CommandLine.Automation
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExitCode As Integer
C#
public int ExitCode { get; }
Visual C++
public:
property int ExitCode {
    int get ();
}

See Also

Output Class
RedGate.Shared.Utils.CommandLine.Automation Namespace


StdOutput Property

[image]

SQL Data Compare API 12.0.40
Output..::.StdOutput Property
Output Class See Also

Namespace: RedGate.Shared.Utils.CommandLine.Automation
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StdOutput As String
C#
public string StdOutput { get; }
Visual C++
public:
property String^ StdOutput {
    String^ get ();
}

See Also

Output Class
RedGate.Shared.Utils.CommandLine.Automation Namespace


Runner Class

[image]

SQL Data Compare API 12.0.40
Runner Class
Members See Also

Namespace: RedGate.Shared.Utils.CommandLine.Automation
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Class Runner
C#
public class Runner
Visual C++
public ref class Runner

Inheritance Hierarchy

Object
RedGate.Shared.Utils.CommandLine.Automation..::.Runner

See Also

Runner Members
RedGate.Shared.Utils.CommandLine.Automation Namespace


Runner Members

[image] [image]

SQL Data Compare API 12.0.40
Runner Members
Runner Class Constructors Methods Properties See Also

The Runner type exposes the following members.

Constructors

Name | Description
Runner |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Run |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Command |
WorkingDirectory |

See Also

Runner Class
RedGate.Shared.Utils.CommandLine.Automation Namespace


Runner Constructor

[image]

SQL Data Compare API 12.0.40
Runner Constructor
Runner Class See Also

Namespace: RedGate.Shared.Utils.CommandLine.Automation
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    commandPath As String _
)
C#
public Runner(
    string commandPath
)
Visual C++
public:
Runner(
    String^ commandPath
)

Parameters

commandPath
Type: String

See Also

Runner Class
RedGate.Shared.Utils.CommandLine.Automation Namespace


Runner Methods

[image] [image]

SQL Data Compare API 12.0.40
Runner Methods
Runner Class See Also

The Runner type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Run |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Runner Class
RedGate.Shared.Utils.CommandLine.Automation Namespace


Run Method

[image]

SQL Data Compare API 12.0.40
Runner..::.Run Method
Runner Class See Also

Namespace: RedGate.Shared.Utils.CommandLine.Automation
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Function Run ( _
    arguments As String, _
    timeout_msecs As Integer _
) As Output
C#
public Output Run(
    string arguments,
    int timeout_msecs
)
Visual C++
public:
Output^ Run(
    String^ arguments,
    int timeout_msecs
)

Parameters

arguments
Type: String
timeout_msecs
Type: Int32

See Also

Runner Class
RedGate.Shared.Utils.CommandLine.Automation Namespace


Runner Properties

[image] [image]

SQL Data Compare API 12.0.40
Runner Properties
Runner Class See Also

The Runner type exposes the following properties.

Properties

Name | Description
Command |
WorkingDirectory |

See Also

Runner Class
RedGate.Shared.Utils.CommandLine.Automation Namespace


Command Property

[image]

SQL Data Compare API 12.0.40
Runner..::.Command Property
Runner Class See Also

Namespace: RedGate.Shared.Utils.CommandLine.Automation
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Command As String
C#
public string Command { get; }
Visual C++
public:
property String^ Command {
    String^ get ();
}

See Also

Runner Class
RedGate.Shared.Utils.CommandLine.Automation Namespace


WorkingDirectory Property

[image]

SQL Data Compare API 12.0.40
Runner..::.WorkingDirectory Property
Runner Class See Also

Namespace: RedGate.Shared.Utils.CommandLine.Automation
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Property WorkingDirectory As String
C#
public string WorkingDirectory { get; set; }
Visual C++
public:
property String^ WorkingDirectory {
    String^ get ();
    void set (String^ value);
}

See Also

Runner Class
RedGate.Shared.Utils.CommandLine.Automation Namespace


RedGate.Shared.Utils.IO.FileSystem Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.Shared.Utils.IO.FileSystem Namespace

Classes

Class | Description
DirectoryInfoWrapper |
FileInfoWrapper |
FileSystem |
FileUtils |
NullFileWrapper |

Interfaces

Interface | Description
IDirectoryInfoWrapper |
IFileInfoWrapper |
IFileSystem |
IFileSystemInfoWrapper |


DirectoryInfoWrapper Class

[image]

SQL Data Compare API 12.0.40
DirectoryInfoWrapper Class
Members See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Class DirectoryInfoWrapper _
    Implements IDirectoryInfoWrapper, IFileSystemInfoWrapper
C#
public class DirectoryInfoWrapper : IDirectoryInfoWrapper,
    IFileSystemInfoWrapper
Visual C++
public ref class DirectoryInfoWrapper : IDirectoryInfoWrapper,
    IFileSystemInfoWrapper

Inheritance Hierarchy

Object
RedGate.Shared.Utils.IO.FileSystem..::.DirectoryInfoWrapper

See Also

DirectoryInfoWrapper Members
RedGate.Shared.Utils.IO.FileSystem Namespace


DirectoryInfoWrapper Members

[image] [image]

SQL Data Compare API 12.0.40
DirectoryInfoWrapper Members
DirectoryInfoWrapper Class Constructors Methods Properties See Also

The DirectoryInfoWrapper type exposes the following members.

Constructors

Name | Description
DirectoryInfoWrapper | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDirectories |
GetFiles |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Attributes |
Exists |
FullName |

See Also

DirectoryInfoWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


DirectoryInfoWrapper Constructor

[image] [image]

SQL Data Compare API 12.0.40
DirectoryInfoWrapper Constructor
DirectoryInfoWrapper Class See Also

Overload List

Name | Description
DirectoryInfoWrapper(DirectoryInfo) |
DirectoryInfoWrapper(String) |

See Also

DirectoryInfoWrapper Class
DirectoryInfoWrapper Members
RedGate.Shared.Utils.IO.FileSystem Namespace


DirectoryInfoWrapper Constructor ()

[image]

SQL Data Compare API 12.0.40
DirectoryInfoWrapper Constructor ()
DirectoryInfoWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    directoryInfo As DirectoryInfo _
)
C#
public DirectoryInfoWrapper(
    DirectoryInfo directoryInfo
)
Visual C++
public:
DirectoryInfoWrapper(
    DirectoryInfo^ directoryInfo
)

Parameters

directoryInfo
Type: DirectoryInfo

See Also

DirectoryInfoWrapper Class
DirectoryInfoWrapper Overload
RedGate.Shared.Utils.IO.FileSystem Namespace


DirectoryInfoWrapper Constructor ()

[image]

SQL Data Compare API 12.0.40
DirectoryInfoWrapper Constructor ()
DirectoryInfoWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    path As String _
)
C#
public DirectoryInfoWrapper(
    string path
)
Visual C++
public:
DirectoryInfoWrapper(
    String^ path
)

Parameters

path
Type: String

See Also

DirectoryInfoWrapper Class
DirectoryInfoWrapper Overload
RedGate.Shared.Utils.IO.FileSystem Namespace


DirectoryInfoWrapper Methods

[image] [image]

SQL Data Compare API 12.0.40
DirectoryInfoWrapper Methods
DirectoryInfoWrapper Class See Also

The DirectoryInfoWrapper type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDirectories |
GetFiles |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DirectoryInfoWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


GetDirectories Method

[image]

SQL Data Compare API 12.0.40
DirectoryInfoWrapper..::.GetDirectories Method
DirectoryInfoWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDirectories ( _
    searchPattern As String, _
    searchOption As SearchOption _
) As IEnumerable(Of IDirectoryInfoWrapper)
C#
public IEnumerable<IDirectoryInfoWrapper> GetDirectories(
    string searchPattern,
    SearchOption searchOption
)
Visual C++
public:
virtual IEnumerable<IDirectoryInfoWrapper^>^ GetDirectories(
    String^ searchPattern,
    SearchOption searchOption
) sealed

Parameters

searchPattern
Type: String
searchOption
Type: SearchOption

Implements

IDirectoryInfoWrapper..::.GetDirectories(String, SearchOption)

See Also

DirectoryInfoWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


GetFiles Method

[image]

SQL Data Compare API 12.0.40
DirectoryInfoWrapper..::.GetFiles Method
DirectoryInfoWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Function GetFiles ( _
    searchPattern As String, _
    searchOption As SearchOption _
) As IEnumerable(Of IFileInfoWrapper)
C#
public IEnumerable<IFileInfoWrapper> GetFiles(
    string searchPattern,
    SearchOption searchOption
)
Visual C++
public:
virtual IEnumerable<IFileInfoWrapper^>^ GetFiles(
    String^ searchPattern,
    SearchOption searchOption
) sealed

Parameters

searchPattern
Type: String
searchOption
Type: SearchOption

Implements

IDirectoryInfoWrapper..::.GetFiles(String, SearchOption)

See Also

DirectoryInfoWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


DirectoryInfoWrapper Properties

[image] [image]

SQL Data Compare API 12.0.40
DirectoryInfoWrapper Properties
DirectoryInfoWrapper Class See Also

The DirectoryInfoWrapper type exposes the following properties.

Properties

Name | Description
Attributes |
Exists |
FullName |

See Also

DirectoryInfoWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


Attributes Property

[image]

SQL Data Compare API 12.0.40
DirectoryInfoWrapper..::.Attributes Property
DirectoryInfoWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Property Attributes As FileAttributes
C#
public FileAttributes Attributes { get; set; }
Visual C++
public:
virtual property FileAttributes Attributes {
    FileAttributes get () sealed;
    void set (FileAttributes value) sealed;
}

Implements

IDirectoryInfoWrapper..::.Attributes

See Also

DirectoryInfoWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


Exists Property

[image]

SQL Data Compare API 12.0.40
DirectoryInfoWrapper..::.Exists Property
DirectoryInfoWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exists As Boolean
C#
public bool Exists { get; }
Visual C++
public:
virtual property bool Exists {
    bool get () sealed;
}

Implements

IFileSystemInfoWrapper..::.Exists

See Also

DirectoryInfoWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


FullName Property

[image]

SQL Data Compare API 12.0.40
DirectoryInfoWrapper..::.FullName Property
DirectoryInfoWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullName As String
C#
public string FullName { get; }
Visual C++
public:
virtual property String^ FullName {
    String^ get () sealed;
}

Implements

IFileSystemInfoWrapper..::.FullName

See Also

DirectoryInfoWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


FileInfoWrapper Class

[image]

SQL Data Compare API 12.0.40
FileInfoWrapper Class
Members See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Class FileInfoWrapper _
    Implements IFileInfoWrapper, IFileSystemInfoWrapper
C#
public class FileInfoWrapper : IFileInfoWrapper,
    IFileSystemInfoWrapper
Visual C++
public ref class FileInfoWrapper : IFileInfoWrapper,
    IFileSystemInfoWrapper

Inheritance Hierarchy

Object
RedGate.Shared.Utils.IO.FileSystem..::.FileInfoWrapper

See Also

FileInfoWrapper Members
RedGate.Shared.Utils.IO.FileSystem Namespace


FileInfoWrapper Members

[image] [image]

SQL Data Compare API 12.0.40
FileInfoWrapper Members
FileInfoWrapper Class Constructors Methods Properties See Also

The FileInfoWrapper type exposes the following members.

Constructors

Name | Description
FileInfoWrapper | Overloaded.

Methods

Name | Description
CopyTo |
Delete |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MarkReadWrite |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CreationTime |
DirectoryName |
Exists |
FileExtensionWithDot |
FilenameWithoutExtension |
FullName |
Parent |

See Also

FileInfoWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


FileInfoWrapper Constructor

[image] [image]

SQL Data Compare API 12.0.40
FileInfoWrapper Constructor
FileInfoWrapper Class See Also

Overload List

Name | Description
FileInfoWrapper(FileInfo) |
FileInfoWrapper(String) |

See Also

FileInfoWrapper Class
FileInfoWrapper Members
RedGate.Shared.Utils.IO.FileSystem Namespace


FileInfoWrapper Constructor ()

[image]

SQL Data Compare API 12.0.40
FileInfoWrapper Constructor ()
FileInfoWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fileInfo As FileInfo _
)
C#
public FileInfoWrapper(
    FileInfo fileInfo
)
Visual C++
public:
FileInfoWrapper(
    FileInfo^ fileInfo
)

Parameters

fileInfo
Type: FileInfo

See Also

FileInfoWrapper Class
FileInfoWrapper Overload
RedGate.Shared.Utils.IO.FileSystem Namespace


FileInfoWrapper Constructor ()

[image]

SQL Data Compare API 12.0.40
FileInfoWrapper Constructor ()
FileInfoWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    absolutePath As String _
)
C#
public FileInfoWrapper(
    string absolutePath
)
Visual C++
public:
FileInfoWrapper(
    String^ absolutePath
)

Parameters

absolutePath
Type: String

See Also

FileInfoWrapper Class
FileInfoWrapper Overload
RedGate.Shared.Utils.IO.FileSystem Namespace


FileInfoWrapper Methods

[image] [image]

SQL Data Compare API 12.0.40
FileInfoWrapper Methods
FileInfoWrapper Class See Also

The FileInfoWrapper type exposes the following methods.

Methods

Name | Description
CopyTo |
Delete |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MarkReadWrite |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileInfoWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


CopyTo Method

[image]

SQL Data Compare API 12.0.40
FileInfoWrapper..::.CopyTo Method
FileInfoWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyTo ( _
    dest As IFileInfoWrapper _
)
C#
public void CopyTo(
    IFileInfoWrapper dest
)
Visual C++
public:
virtual void CopyTo(
    IFileInfoWrapper^ dest
) sealed

Parameters

dest
Type: RedGate.Shared.Utils.IO.FileSystem..::.IFileInfoWrapper

Implements

IFileInfoWrapper..::.CopyTo(IFileInfoWrapper)

See Also

FileInfoWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


Delete Method

[image]

SQL Data Compare API 12.0.40
FileInfoWrapper..::.Delete Method
FileInfoWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub Delete
C#
public void Delete()
Visual C++
public:
virtual void Delete() sealed

Implements

IFileInfoWrapper..::.Delete()()()

See Also

FileInfoWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


MarkReadWrite Method

[image]

SQL Data Compare API 12.0.40
FileInfoWrapper..::.MarkReadWrite Method
FileInfoWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub MarkReadWrite
C#
public void MarkReadWrite()
Visual C++
public:
virtual void MarkReadWrite() sealed

Implements

IFileInfoWrapper..::.MarkReadWrite()()()

See Also

FileInfoWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


FileInfoWrapper Properties

[image] [image]

SQL Data Compare API 12.0.40
FileInfoWrapper Properties
FileInfoWrapper Class See Also

The FileInfoWrapper type exposes the following properties.

Properties

Name | Description
CreationTime |
DirectoryName |
Exists |
FileExtensionWithDot |
FilenameWithoutExtension |
FullName |
Parent |

See Also

FileInfoWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


CreationTime Property

[image]

SQL Data Compare API 12.0.40
FileInfoWrapper..::.CreationTime Property
FileInfoWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CreationTime As DateTime
C#
public DateTime CreationTime { get; }
Visual C++
public:
virtual property DateTime CreationTime {
    DateTime get () sealed;
}

Implements

IFileInfoWrapper..::.CreationTime

See Also

FileInfoWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


DirectoryName Property

[image]

SQL Data Compare API 12.0.40
FileInfoWrapper..::.DirectoryName Property
FileInfoWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DirectoryName As String
C#
public string DirectoryName { get; }
Visual C++
public:
virtual property String^ DirectoryName {
    String^ get () sealed;
}

Implements

IFileInfoWrapper..::.DirectoryName

See Also

FileInfoWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


Exists Property

[image]

SQL Data Compare API 12.0.40
FileInfoWrapper..::.Exists Property
FileInfoWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exists As Boolean
C#
public bool Exists { get; }
Visual C++
public:
virtual property bool Exists {
    bool get () sealed;
}

Implements

IFileSystemInfoWrapper..::.Exists

See Also

FileInfoWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


FileExtensionWithDot Property

[image]

SQL Data Compare API 12.0.40
FileInfoWrapper..::.FileExtensionWithDot Property
FileInfoWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FileExtensionWithDot As String
C#
public string FileExtensionWithDot { get; }
Visual C++
public:
virtual property String^ FileExtensionWithDot {
    String^ get () sealed;
}

Implements

IFileInfoWrapper..::.FileExtensionWithDot

See Also

FileInfoWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


FilenameWithoutExtension Property

[image]

SQL Data Compare API 12.0.40
FileInfoWrapper..::.FilenameWithoutExtension Property
FileInfoWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FilenameWithoutExtension As String
C#
public string FilenameWithoutExtension { get; }
Visual C++
public:
virtual property String^ FilenameWithoutExtension {
    String^ get () sealed;
}

Implements

IFileInfoWrapper..::.FilenameWithoutExtension

See Also

FileInfoWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


FullName Property

[image]

SQL Data Compare API 12.0.40
FileInfoWrapper..::.FullName Property
FileInfoWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullName As String
C#
public string FullName { get; }
Visual C++
public:
virtual property String^ FullName {
    String^ get () sealed;
}

Implements

IFileSystemInfoWrapper..::.FullName

See Also

FileInfoWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


Parent Property

[image]

SQL Data Compare API 12.0.40
FileInfoWrapper..::.Parent Property
FileInfoWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As DirectoryInfo
C#
public DirectoryInfo Parent { get; }
Visual C++
public:
virtual property DirectoryInfo^ Parent {
    DirectoryInfo^ get () sealed;
}

Implements

IFileInfoWrapper..::.Parent

See Also

FileInfoWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


FileSystem Class

[image]

SQL Data Compare API 12.0.40
FileSystem Class
Members See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Class FileSystem _
    Implements IFileSystem
C#
public class FileSystem : IFileSystem
Visual C++
public ref class FileSystem : IFileSystem

Inheritance Hierarchy

Object
RedGate.Shared.Utils.IO.FileSystem..::.FileSystem

See Also

FileSystem Members
RedGate.Shared.Utils.IO.FileSystem Namespace


FileSystem Members

[image] [image]

SQL Data Compare API 12.0.40
FileSystem Members
FileSystem Class Constructors Methods See Also

The FileSystem type exposes the following members.

Constructors

Name | Description
FileSystem |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetInfoForAbsolutePath |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileSystem Class
RedGate.Shared.Utils.IO.FileSystem Namespace


FileSystem Constructor

[image]

SQL Data Compare API 12.0.40
FileSystem Constructor
FileSystem Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FileSystem()
Visual C++
public:
FileSystem()

See Also

FileSystem Class
RedGate.Shared.Utils.IO.FileSystem Namespace


FileSystem Methods

[image] [image]

SQL Data Compare API 12.0.40
FileSystem Methods
FileSystem Class See Also

The FileSystem type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetInfoForAbsolutePath |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileSystem Class
RedGate.Shared.Utils.IO.FileSystem Namespace


GetInfoForAbsolutePath Method

[image]

SQL Data Compare API 12.0.40
FileSystem..::.GetInfoForAbsolutePath Method
FileSystem Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Function GetInfoForAbsolutePath ( _
    path As String _
) As IFileInfoWrapper
C#
public IFileInfoWrapper GetInfoForAbsolutePath(
    string path
)
Visual C++
public:
virtual IFileInfoWrapper^ GetInfoForAbsolutePath(
    String^ path
) sealed

Parameters

path
Type: String

Implements

IFileSystem..::.GetInfoForAbsolutePath(String)

See Also

FileSystem Class
RedGate.Shared.Utils.IO.FileSystem Namespace


FileUtils Class

[image]

SQL Data Compare API 12.0.40
FileUtils Class
Members See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FileUtils
C#
public static class FileUtils
Visual C++
public ref class FileUtils abstract sealed

Inheritance Hierarchy

Object
RedGate.Shared.Utils.IO.FileSystem..::.FileUtils

See Also

FileUtils Members
RedGate.Shared.Utils.IO.FileSystem Namespace


FileUtils Members

[image] [image]

SQL Data Compare API 12.0.40
FileUtils Members
FileUtils Class Methods See Also

The FileUtils type exposes the following members.

Methods

Name | Description
Delete | Deletes a path, whether it's a directory or a file Optionally ignores the case where the file already doesn't exist on disk
DeleteDirectory | Recursively deletes a directory even if it's marked as readonly
ForAllFilesAndDirectories | Runs the actions for all files and directories under directoryInfoWrapper (including directoryInfoWrapper itself) in a post order traversal
GetInvalidCharacters |
IsDirectoryEmpty |
IsWindowsReservedName |
TryDeleteDirectory |

See Also

FileUtils Class
RedGate.Shared.Utils.IO.FileSystem Namespace


FileUtils Methods

[image] [image]

SQL Data Compare API 12.0.40
FileUtils Methods
FileUtils Class See Also

The FileUtils type exposes the following methods.

Methods

Name | Description
Delete | Deletes a path, whether it's a directory or a file Optionally ignores the case where the file already doesn't exist on disk
DeleteDirectory | Recursively deletes a directory even if it's marked as readonly
ForAllFilesAndDirectories | Runs the actions for all files and directories under directoryInfoWrapper (including directoryInfoWrapper itself) in a post order traversal
GetInvalidCharacters |
IsDirectoryEmpty |
IsWindowsReservedName |
TryDeleteDirectory |

See Also

FileUtils Class
RedGate.Shared.Utils.IO.FileSystem Namespace


Delete Method

[image]

SQL Data Compare API 12.0.40
FileUtils..::.Delete Method
FileUtils Class See Also

Deletes a path, whether it's a directory or a file Optionally ignores the case where the file already doesn't exist on disk

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Delete ( _
    path As String _
)
C#
public static void Delete(
    string path
)
Visual C++
public:
static void Delete(
    String^ path
)

Parameters

path
Type: String

See Also

FileUtils Class
RedGate.Shared.Utils.IO.FileSystem Namespace


DeleteDirectory Method

[image]

SQL Data Compare API 12.0.40
FileUtils..::.DeleteDirectory Method
FileUtils Class See Also

Recursively deletes a directory even if it's marked as readonly

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub DeleteDirectory ( _
    path As String _
)
C#
public static void DeleteDirectory(
    string path
)
Visual C++
public:
static void DeleteDirectory(
    String^ path
)

Parameters

path
Type: String

See Also

FileUtils Class
RedGate.Shared.Utils.IO.FileSystem Namespace


ForAllFilesAndDirectories Method

[image]

SQL Data Compare API 12.0.40
FileUtils..::.ForAllFilesAndDirectories Method
FileUtils Class See Also

Runs the actions for all files and directories under directoryInfoWrapper (including directoryInfoWrapper itself) in a post order traversal

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ForAllFilesAndDirectories ( _
    directoryInfoWrapper As IDirectoryInfoWrapper, _
    actionForFiles As Action(Of IFileInfoWrapper), _
    actionForDirectories As Action(Of IDirectoryInfoWrapper) _
)
C#
public static void ForAllFilesAndDirectories(
    IDirectoryInfoWrapper directoryInfoWrapper,
    Action<IFileInfoWrapper> actionForFiles,
    Action<IDirectoryInfoWrapper> actionForDirectories
)
Visual C++
public:
static void ForAllFilesAndDirectories(
    IDirectoryInfoWrapper^ directoryInfoWrapper,
    Action<IFileInfoWrapper^>^ actionForFiles,
    Action<IDirectoryInfoWrapper^>^ actionForDirectories
)

Parameters

directoryInfoWrapper
Type: RedGate.Shared.Utils.IO.FileSystem..::.IDirectoryInfoWrapper
actionForFiles
Type: Action<(Of <( IFileInfoWrapper >)>)
actionForDirectories
Type: Action<(Of <( IDirectoryInfoWrapper >)>)

See Also

FileUtils Class
RedGate.Shared.Utils.IO.FileSystem Namespace


GetInvalidCharacters Method

[image]

SQL Data Compare API 12.0.40
FileUtils..::.GetInvalidCharacters Method
FileUtils Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetInvalidCharacters ( _
    path As String _
) As List(Of Char)
C#
public static List<char> GetInvalidCharacters(
    string path
)
Visual C++
public:
static List<wchar_t>^ GetInvalidCharacters(
    String^ path
)

Parameters

path
Type: String

See Also

FileUtils Class
RedGate.Shared.Utils.IO.FileSystem Namespace


IsDirectoryEmpty Method

[image]

SQL Data Compare API 12.0.40
FileUtils..::.IsDirectoryEmpty Method
FileUtils Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsDirectoryEmpty ( _
    path As String _
) As Boolean
C#
public static bool IsDirectoryEmpty(
    string path
)
Visual C++
public:
static bool IsDirectoryEmpty(
    String^ path
)

Parameters

path
Type: String

See Also

FileUtils Class
RedGate.Shared.Utils.IO.FileSystem Namespace


IsWindowsReservedName Method

[image]

SQL Data Compare API 12.0.40
FileUtils..::.IsWindowsReservedName Method
FileUtils Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsWindowsReservedName ( _
    name As String _
) As Boolean
C#
public static bool IsWindowsReservedName(
    string name
)
Visual C++
public:
static bool IsWindowsReservedName(
    String^ name
)

Parameters

name
Type: String

See Also

FileUtils Class
RedGate.Shared.Utils.IO.FileSystem Namespace


TryDeleteDirectory Method

[image]

SQL Data Compare API 12.0.40
FileUtils..::.TryDeleteDirectory Method
FileUtils Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function TryDeleteDirectory ( _
    path As String _
) As Boolean
C#
public static bool TryDeleteDirectory(
    string path
)
Visual C++
public:
static bool TryDeleteDirectory(
    String^ path
)

Parameters

path
Type: String

See Also

FileUtils Class
RedGate.Shared.Utils.IO.FileSystem Namespace


IDirectoryInfoWrapper Interface

[image]

SQL Data Compare API 12.0.40
IDirectoryInfoWrapper Interface
Members See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDirectoryInfoWrapper _
    Implements IFileSystemInfoWrapper
C#
public interface IDirectoryInfoWrapper : IFileSystemInfoWrapper
Visual C++
public interface class IDirectoryInfoWrapper : IFileSystemInfoWrapper

See Also

IDirectoryInfoWrapper Members
RedGate.Shared.Utils.IO.FileSystem Namespace


IDirectoryInfoWrapper Members

[image] [image]

SQL Data Compare API 12.0.40
IDirectoryInfoWrapper Members
IDirectoryInfoWrapper Interface Methods Properties See Also

The IDirectoryInfoWrapper type exposes the following members.

Methods

Name | Description
GetDirectories |
GetFiles |

Properties

Name | Description
Attributes |
Exists | (Inherited from IFileSystemInfoWrapper.)
FullName | (Inherited from IFileSystemInfoWrapper.)

See Also

IDirectoryInfoWrapper Interface
RedGate.Shared.Utils.IO.FileSystem Namespace


IDirectoryInfoWrapper Methods

[image] [image]

SQL Data Compare API 12.0.40
IDirectoryInfoWrapper Methods
IDirectoryInfoWrapper Interface See Also

The IDirectoryInfoWrapper type exposes the following methods.

Methods

Name | Description
GetDirectories |
GetFiles |

See Also

IDirectoryInfoWrapper Interface
RedGate.Shared.Utils.IO.FileSystem Namespace


GetDirectories Method

[image]

SQL Data Compare API 12.0.40
IDirectoryInfoWrapper..::.GetDirectories Method
IDirectoryInfoWrapper Interface See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Function GetDirectories ( _
    searchPattern As String, _
    searchOption As SearchOption _
) As IEnumerable(Of IDirectoryInfoWrapper)
C#
IEnumerable<IDirectoryInfoWrapper> GetDirectories(
    string searchPattern,
    SearchOption searchOption
)
Visual C++
IEnumerable<IDirectoryInfoWrapper^>^ GetDirectories(
    String^ searchPattern,
    SearchOption searchOption
)

Parameters

searchPattern
Type: String
searchOption
Type: SearchOption

See Also

IDirectoryInfoWrapper Interface
RedGate.Shared.Utils.IO.FileSystem Namespace


GetFiles Method

[image]

SQL Data Compare API 12.0.40
IDirectoryInfoWrapper..::.GetFiles Method
IDirectoryInfoWrapper Interface See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Function GetFiles ( _
    searchPattern As String, _
    searchOption As SearchOption _
) As IEnumerable(Of IFileInfoWrapper)
C#
IEnumerable<IFileInfoWrapper> GetFiles(
    string searchPattern,
    SearchOption searchOption
)
Visual C++
IEnumerable<IFileInfoWrapper^>^ GetFiles(
    String^ searchPattern,
    SearchOption searchOption
)

Parameters

searchPattern
Type: String
searchOption
Type: SearchOption

See Also

IDirectoryInfoWrapper Interface
RedGate.Shared.Utils.IO.FileSystem Namespace


IDirectoryInfoWrapper Properties

[image] [image]

SQL Data Compare API 12.0.40
IDirectoryInfoWrapper Properties
IDirectoryInfoWrapper Interface See Also

The IDirectoryInfoWrapper type exposes the following properties.

Properties

Name | Description
Attributes |
Exists | (Inherited from IFileSystemInfoWrapper.)
FullName | (Inherited from IFileSystemInfoWrapper.)

See Also

IDirectoryInfoWrapper Interface
RedGate.Shared.Utils.IO.FileSystem Namespace


Attributes Property

[image]

SQL Data Compare API 12.0.40
IDirectoryInfoWrapper..::.Attributes Property
IDirectoryInfoWrapper Interface See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Property Attributes As FileAttributes
C#
FileAttributes Attributes { get; set; }
Visual C++
property FileAttributes Attributes {
    FileAttributes get ();
    void set (FileAttributes value);
}

See Also

IDirectoryInfoWrapper Interface
RedGate.Shared.Utils.IO.FileSystem Namespace


IFileInfoWrapper Interface

[image]

SQL Data Compare API 12.0.40
IFileInfoWrapper Interface
Members See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Interface IFileInfoWrapper _
    Implements IFileSystemInfoWrapper
C#
public interface IFileInfoWrapper : IFileSystemInfoWrapper
Visual C++
public interface class IFileInfoWrapper : IFileSystemInfoWrapper

See Also

IFileInfoWrapper Members
RedGate.Shared.Utils.IO.FileSystem Namespace


IFileInfoWrapper Members

[image] [image]

SQL Data Compare API 12.0.40
IFileInfoWrapper Members
IFileInfoWrapper Interface Methods Properties See Also

The IFileInfoWrapper type exposes the following members.

Methods

Name | Description
CopyTo |
Delete |
MarkReadWrite |

Properties

Name | Description
CreationTime |
DirectoryName |
Exists | (Inherited from IFileSystemInfoWrapper.)
FileExtensionWithDot |
FilenameWithoutExtension |
FullName | (Inherited from IFileSystemInfoWrapper.)
Parent |

See Also

IFileInfoWrapper Interface
RedGate.Shared.Utils.IO.FileSystem Namespace


IFileInfoWrapper Methods

[image] [image]

SQL Data Compare API 12.0.40
IFileInfoWrapper Methods
IFileInfoWrapper Interface See Also

The IFileInfoWrapper type exposes the following methods.

Methods

Name | Description
CopyTo |
Delete |
MarkReadWrite |

See Also

IFileInfoWrapper Interface
RedGate.Shared.Utils.IO.FileSystem Namespace


CopyTo Method

[image]

SQL Data Compare API 12.0.40
IFileInfoWrapper..::.CopyTo Method
IFileInfoWrapper Interface See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Sub CopyTo ( _
    dest As IFileInfoWrapper _
)
C#
void CopyTo(
    IFileInfoWrapper dest
)
Visual C++
void CopyTo(
    IFileInfoWrapper^ dest
)

Parameters

dest
Type: RedGate.Shared.Utils.IO.FileSystem..::.IFileInfoWrapper

See Also

IFileInfoWrapper Interface
RedGate.Shared.Utils.IO.FileSystem Namespace


Delete Method

[image]

SQL Data Compare API 12.0.40
IFileInfoWrapper..::.Delete Method
IFileInfoWrapper Interface See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Sub Delete
C#
void Delete()
Visual C++
void Delete()

See Also

IFileInfoWrapper Interface
RedGate.Shared.Utils.IO.FileSystem Namespace


MarkReadWrite Method

[image]

SQL Data Compare API 12.0.40
IFileInfoWrapper..::.MarkReadWrite Method
IFileInfoWrapper Interface See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Sub MarkReadWrite
C#
void MarkReadWrite()
Visual C++
void MarkReadWrite()

See Also

IFileInfoWrapper Interface
RedGate.Shared.Utils.IO.FileSystem Namespace


IFileInfoWrapper Properties

[image] [image]

SQL Data Compare API 12.0.40
IFileInfoWrapper Properties
IFileInfoWrapper Interface See Also

The IFileInfoWrapper type exposes the following properties.

Properties

Name | Description
CreationTime |
DirectoryName |
Exists | (Inherited from IFileSystemInfoWrapper.)
FileExtensionWithDot |
FilenameWithoutExtension |
FullName | (Inherited from IFileSystemInfoWrapper.)
Parent |

See Also

IFileInfoWrapper Interface
RedGate.Shared.Utils.IO.FileSystem Namespace


CreationTime Property

[image]

SQL Data Compare API 12.0.40
IFileInfoWrapper..::.CreationTime Property
IFileInfoWrapper Interface See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CreationTime As DateTime
C#
DateTime CreationTime { get; }
Visual C++
property DateTime CreationTime {
    DateTime get ();
}

See Also

IFileInfoWrapper Interface
RedGate.Shared.Utils.IO.FileSystem Namespace


DirectoryName Property

[image]

SQL Data Compare API 12.0.40
IFileInfoWrapper..::.DirectoryName Property
IFileInfoWrapper Interface See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DirectoryName As String
C#
string DirectoryName { get; }
Visual C++
property String^ DirectoryName {
    String^ get ();
}

See Also

IFileInfoWrapper Interface
RedGate.Shared.Utils.IO.FileSystem Namespace


FileExtensionWithDot Property

[image]

SQL Data Compare API 12.0.40
IFileInfoWrapper..::.FileExtensionWithDot Property
IFileInfoWrapper Interface See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property FileExtensionWithDot As String
C#
string FileExtensionWithDot { get; }
Visual C++
property String^ FileExtensionWithDot {
    String^ get ();
}

See Also

IFileInfoWrapper Interface
RedGate.Shared.Utils.IO.FileSystem Namespace


FilenameWithoutExtension Property

[image]

SQL Data Compare API 12.0.40
IFileInfoWrapper..::.FilenameWithoutExtension Property
IFileInfoWrapper Interface See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property FilenameWithoutExtension As String
C#
string FilenameWithoutExtension { get; }
Visual C++
property String^ FilenameWithoutExtension {
    String^ get ();
}

See Also

IFileInfoWrapper Interface
RedGate.Shared.Utils.IO.FileSystem Namespace


Parent Property

[image]

SQL Data Compare API 12.0.40
IFileInfoWrapper..::.Parent Property
IFileInfoWrapper Interface See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Parent As DirectoryInfo
C#
DirectoryInfo Parent { get; }
Visual C++
property DirectoryInfo^ Parent {
    DirectoryInfo^ get ();
}

See Also

IFileInfoWrapper Interface
RedGate.Shared.Utils.IO.FileSystem Namespace


IFileSystem Interface

[image]

SQL Data Compare API 12.0.40
IFileSystem Interface
Members See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Interface IFileSystem
C#
public interface IFileSystem
Visual C++
public interface class IFileSystem

See Also

IFileSystem Members
RedGate.Shared.Utils.IO.FileSystem Namespace


IFileSystem Members

[image] [image]

SQL Data Compare API 12.0.40
IFileSystem Members
IFileSystem Interface Methods See Also

The IFileSystem type exposes the following members.

Methods

Name | Description
GetInfoForAbsolutePath |

See Also

IFileSystem Interface
RedGate.Shared.Utils.IO.FileSystem Namespace


IFileSystem Methods

[image] [image]

SQL Data Compare API 12.0.40
IFileSystem Methods
IFileSystem Interface See Also

The IFileSystem type exposes the following methods.

Methods

Name | Description
GetInfoForAbsolutePath |

See Also

IFileSystem Interface
RedGate.Shared.Utils.IO.FileSystem Namespace


GetInfoForAbsolutePath Method

[image]

SQL Data Compare API 12.0.40
IFileSystem..::.GetInfoForAbsolutePath Method
IFileSystem Interface See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Function GetInfoForAbsolutePath ( _
    path As String _
) As IFileInfoWrapper
C#
IFileInfoWrapper GetInfoForAbsolutePath(
    string path
)
Visual C++
IFileInfoWrapper^ GetInfoForAbsolutePath(
    String^ path
)

Parameters

path
Type: String

See Also

IFileSystem Interface
RedGate.Shared.Utils.IO.FileSystem Namespace


IFileSystemInfoWrapper Interface

[image]

SQL Data Compare API 12.0.40
IFileSystemInfoWrapper Interface
Members See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Interface IFileSystemInfoWrapper
C#
public interface IFileSystemInfoWrapper
Visual C++
public interface class IFileSystemInfoWrapper

See Also

IFileSystemInfoWrapper Members
RedGate.Shared.Utils.IO.FileSystem Namespace


IFileSystemInfoWrapper Members

[image] [image]

SQL Data Compare API 12.0.40
IFileSystemInfoWrapper Members
IFileSystemInfoWrapper Interface Properties See Also

The IFileSystemInfoWrapper type exposes the following members.

Properties

Name | Description
Exists |
FullName |

See Also

IFileSystemInfoWrapper Interface
RedGate.Shared.Utils.IO.FileSystem Namespace


IFileSystemInfoWrapper Properties

[image] [image]

SQL Data Compare API 12.0.40
IFileSystemInfoWrapper Properties
IFileSystemInfoWrapper Interface See Also

The IFileSystemInfoWrapper type exposes the following properties.

Properties

Name | Description
Exists |
FullName |

See Also

IFileSystemInfoWrapper Interface
RedGate.Shared.Utils.IO.FileSystem Namespace


Exists Property

[image]

SQL Data Compare API 12.0.40
IFileSystemInfoWrapper..::.Exists Property
IFileSystemInfoWrapper Interface See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Exists As Boolean
C#
bool Exists { get; }
Visual C++
property bool Exists {
    bool get ();
}

See Also

IFileSystemInfoWrapper Interface
RedGate.Shared.Utils.IO.FileSystem Namespace


FullName Property

[image]

SQL Data Compare API 12.0.40
IFileSystemInfoWrapper..::.FullName Property
IFileSystemInfoWrapper Interface See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property FullName As String
C#
string FullName { get; }
Visual C++
property String^ FullName {
    String^ get ();
}

See Also

IFileSystemInfoWrapper Interface
RedGate.Shared.Utils.IO.FileSystem Namespace


NullFileWrapper Class

[image]

SQL Data Compare API 12.0.40
NullFileWrapper Class
Members See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Class NullFileWrapper _
    Implements IFileInfoWrapper, IFileSystemInfoWrapper
C#
public class NullFileWrapper : IFileInfoWrapper,
    IFileSystemInfoWrapper
Visual C++
public ref class NullFileWrapper : IFileInfoWrapper,
    IFileSystemInfoWrapper

Inheritance Hierarchy

Object
RedGate.Shared.Utils.IO.FileSystem..::.NullFileWrapper

See Also

NullFileWrapper Members
RedGate.Shared.Utils.IO.FileSystem Namespace


NullFileWrapper Members

[image] [image]

SQL Data Compare API 12.0.40
NullFileWrapper Members
NullFileWrapper Class Constructors Methods Properties See Also

The NullFileWrapper type exposes the following members.

Constructors

Name | Description
NullFileWrapper |

Methods

Name | Description
CopyTo |
Delete |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MarkReadWrite |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CreationTime |
DirectoryName |
Exists |
FileExtensionWithDot |
FilenameWithoutExtension |
FullName |
Parent |

See Also

NullFileWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


NullFileWrapper Constructor

[image]

SQL Data Compare API 12.0.40
NullFileWrapper Constructor
NullFileWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public NullFileWrapper()
Visual C++
public:
NullFileWrapper()

See Also

NullFileWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


NullFileWrapper Methods

[image] [image]

SQL Data Compare API 12.0.40
NullFileWrapper Methods
NullFileWrapper Class See Also

The NullFileWrapper type exposes the following methods.

Methods

Name | Description
CopyTo |
Delete |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MarkReadWrite |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NullFileWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


CopyTo Method

[image]

SQL Data Compare API 12.0.40
NullFileWrapper..::.CopyTo Method
NullFileWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyTo ( _
    dest As IFileInfoWrapper _
)
C#
public void CopyTo(
    IFileInfoWrapper dest
)
Visual C++
public:
virtual void CopyTo(
    IFileInfoWrapper^ dest
) sealed

Parameters

dest
Type: RedGate.Shared.Utils.IO.FileSystem..::.IFileInfoWrapper

Implements

IFileInfoWrapper..::.CopyTo(IFileInfoWrapper)

See Also

NullFileWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


Delete Method

[image]

SQL Data Compare API 12.0.40
NullFileWrapper..::.Delete Method
NullFileWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub Delete
C#
public void Delete()
Visual C++
public:
virtual void Delete() sealed

Implements

IFileInfoWrapper..::.Delete()()()

See Also

NullFileWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


MarkReadWrite Method

[image]

SQL Data Compare API 12.0.40
NullFileWrapper..::.MarkReadWrite Method
NullFileWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub MarkReadWrite
C#
public void MarkReadWrite()
Visual C++
public:
virtual void MarkReadWrite() sealed

Implements

IFileInfoWrapper..::.MarkReadWrite()()()

See Also

NullFileWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


NullFileWrapper Properties

[image] [image]

SQL Data Compare API 12.0.40
NullFileWrapper Properties
NullFileWrapper Class See Also

The NullFileWrapper type exposes the following properties.

Properties

Name | Description
CreationTime |
DirectoryName |
Exists |
FileExtensionWithDot |
FilenameWithoutExtension |
FullName |
Parent |

See Also

NullFileWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


CreationTime Property

[image]

SQL Data Compare API 12.0.40
NullFileWrapper..::.CreationTime Property
NullFileWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CreationTime As DateTime
C#
public DateTime CreationTime { get; }
Visual C++
public:
virtual property DateTime CreationTime {
    DateTime get () sealed;
}

Implements

IFileInfoWrapper..::.CreationTime

See Also

NullFileWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


DirectoryName Property

[image]

SQL Data Compare API 12.0.40
NullFileWrapper..::.DirectoryName Property
NullFileWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DirectoryName As String
C#
public string DirectoryName { get; }
Visual C++
public:
virtual property String^ DirectoryName {
    String^ get () sealed;
}

Implements

IFileInfoWrapper..::.DirectoryName

See Also

NullFileWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


Exists Property

[image]

SQL Data Compare API 12.0.40
NullFileWrapper..::.Exists Property
NullFileWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exists As Boolean
C#
public bool Exists { get; }
Visual C++
public:
virtual property bool Exists {
    bool get () sealed;
}

Implements

IFileSystemInfoWrapper..::.Exists

See Also

NullFileWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


FileExtensionWithDot Property

[image]

SQL Data Compare API 12.0.40
NullFileWrapper..::.FileExtensionWithDot Property
NullFileWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FileExtensionWithDot As String
C#
public string FileExtensionWithDot { get; }
Visual C++
public:
virtual property String^ FileExtensionWithDot {
    String^ get () sealed;
}

Implements

IFileInfoWrapper..::.FileExtensionWithDot

See Also

NullFileWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


FilenameWithoutExtension Property

[image]

SQL Data Compare API 12.0.40
NullFileWrapper..::.FilenameWithoutExtension Property
NullFileWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FilenameWithoutExtension As String
C#
public string FilenameWithoutExtension { get; }
Visual C++
public:
virtual property String^ FilenameWithoutExtension {
    String^ get () sealed;
}

Implements

IFileInfoWrapper..::.FilenameWithoutExtension

See Also

NullFileWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


FullName Property

[image]

SQL Data Compare API 12.0.40
NullFileWrapper..::.FullName Property
NullFileWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullName As String
C#
public string FullName { get; }
Visual C++
public:
virtual property String^ FullName {
    String^ get () sealed;
}

Implements

IFileSystemInfoWrapper..::.FullName

See Also

NullFileWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


Parent Property

[image]

SQL Data Compare API 12.0.40
NullFileWrapper..::.Parent Property
NullFileWrapper Class See Also

Namespace: RedGate.Shared.Utils.IO.FileSystem
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As DirectoryInfo
C#
public DirectoryInfo Parent { get; }
Visual C++
public:
virtual property DirectoryInfo^ Parent {
    DirectoryInfo^ get () sealed;
}

Implements

IFileInfoWrapper..::.Parent

See Also

NullFileWrapper Class
RedGate.Shared.Utils.IO.FileSystem Namespace


RedGate.Shared.Utils.IO.Serialization Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.Shared.Utils.IO.Serialization Namespace

Classes

Class | Description
SerializationException | Base exception for Serialization errors.
SerializationInvalidFileException | Serialization error caused by an incorrectly formatted file.
SerializationInvalidFileTypeException | Serialization error caused by an unexpected type name in the file.
SerializationInvalidTypeException | Serialization error caused by a type name not being recognised by the deserializer.
SerializationInvalidVersionException | Serialization error caused by attempting to deserialize a file for which the serialization version is different to the specified object version.
SerializationNotSupportedException | Serialization error caused by a class not implementing the IRedGateSerializable interface.
SerializationParameterConversionException | Serialization error caused by an error raised when converting a parameter. This could be because the serialized file has been edited manually.
SerializationParameterEmptyException | Serialization error caused by an empty parameter.
SerializationParameterMissingException | Serialization error caused by a missing parameter.


SerializationException Class

[image]

SQL Data Compare API 12.0.40
SerializationException Class
Members See Also

Base exception for Serialization errors.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class SerializationException _
    Inherits Exception
C#
[SerializableAttribute]
public class SerializationException : Exception
Visual C++
[SerializableAttribute]
public ref class SerializationException : public Exception

Inheritance Hierarchy

Object
Exception
RedGate.Shared.Utils.IO.Serialization..::.SerializationException
RedGate.Shared.Utils.IO.Serialization..::.SerializationInvalidFileException
RedGate.Shared.Utils.IO.Serialization..::.SerializationParameterConversionException
RedGate.Shared.Utils.IO.Serialization..::.SerializationNotSupportedException
RedGate.Shared.Utils.IO.Serialization..::.SerializationInvalidTypeException
RedGate.Shared.Utils.IO.Serialization..::.SerializationInvalidVersionException
RedGate.Shared.Utils.IO.Serialization..::.SerializationParameterMissingException
RedGate.Shared.Utils.IO.Serialization..::.SerializationParameterEmptyException

See Also

SerializationException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationException Members

[image] [image]

SQL Data Compare API 12.0.40
SerializationException Members
SerializationException Class Constructors Methods Properties See Also

The SerializationException type exposes the following members.

Constructors

Name | Description
SerializationException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SerializationException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationException Constructor

[image] [image]

SQL Data Compare API 12.0.40
SerializationException Constructor
SerializationException Class See Also

Overload List

Name | Description
SerializationException()()() | Initializes a new instance of the SerializationException class.
SerializationException(String) | Initializes a new instance of the SerializationException class with a specified error message.
SerializationException(SerializationInfo, StreamingContext) | Initializes a new instance of the SerializationException class with serialized data.
SerializationException(String, Exception) | Initializes a new instance of the SerializationException class with a specified error message and a reference to the inner exception that is the cause of this exception.

See Also

SerializationException Class
SerializationException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationException Constructor

[image]

SQL Data Compare API 12.0.40
SerializationException Constructor
SerializationException Class See Also

Initializes a new instance of the SerializationException class.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SerializationException()
Visual C++
public:
SerializationException()

See Also

SerializationException Class
SerializationException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationException Constructor ()

[image]

SQL Data Compare API 12.0.40
SerializationException Constructor ()
SerializationException Class See Also

Initializes a new instance of the SerializationException class with a specified error message.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public SerializationException(
    string message
)
Visual C++
public:
SerializationException(
    String^ message
)

Parameters

message
Type: String
A message that describes the error.

See Also

SerializationException Class
SerializationException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationException Constructor (, )

[image]

SQL Data Compare API 12.0.40
SerializationException Constructor (, )
SerializationException Class See Also

Initializes a new instance of the SerializationException class with serialized data.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected SerializationException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
SerializationException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: SerializationInfo
The object that holds the serialized object data.
context
Type: StreamingContext
The contextual information about the source or destination.

See Also

SerializationException Class
SerializationException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationException Constructor (, )

[image]

SQL Data Compare API 12.0.40
SerializationException Constructor (, )
SerializationException Class See Also

Initializes a new instance of the SerializationException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
C#
public SerializationException(
    string message,
    Exception innerException
)
Visual C++
public:
SerializationException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: String
The error message that explains the reason for the exception.
innerException
Type: Exception
The exception that is the cause of the current exception.

See Also

SerializationException Class
SerializationException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidFileException Class

[image]

SQL Data Compare API 12.0.40
SerializationInvalidFileException Class
Members See Also

Serialization error caused by an incorrectly formatted file.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class SerializationInvalidFileException _
    Inherits SerializationException
C#
[SerializableAttribute]
public class SerializationInvalidFileException : SerializationException
Visual C++
[SerializableAttribute]
public ref class SerializationInvalidFileException : public SerializationException

Inheritance Hierarchy

Object
Exception
RedGate.Shared.Utils.IO.Serialization..::.SerializationException
RedGate.Shared.Utils.IO.Serialization..::.SerializationInvalidFileException
RedGate.Shared.Utils.IO.Serialization..::.SerializationInvalidFileTypeException

See Also

SerializationInvalidFileException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidFileException Members

[image] [image]

SQL Data Compare API 12.0.40
SerializationInvalidFileException Members
SerializationInvalidFileException Class Constructors Methods Properties See Also

The SerializationInvalidFileException type exposes the following members.

Constructors

Name | Description
SerializationInvalidFileException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
FileName | Gets the name of the file that is incorrectly formatted.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SerializationInvalidFileException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidFileException Constructor

[image] [image]

SQL Data Compare API 12.0.40
SerializationInvalidFileException Constructor
SerializationInvalidFileException Class See Also

Overload List

Name | Description
SerializationInvalidFileException(String) | Initializes a new instance of the SerializationInvalidFileException class.
SerializationInvalidFileException(SerializationInfo, StreamingContext) | Initializes a new instance of the SerializationInvalidFileException class with serialized data.
SerializationInvalidFileException(String, String) | Initializes a new instance of the SerializationInvalidFileException class with a specified error message.
SerializationInvalidFileException(String, String, Exception) | Initializes a new instance of the SerializationInvalidFileException class with a specified error message and a reference to the inner exception that is the cause of this exception.

See Also

SerializationInvalidFileException Class
SerializationInvalidFileException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidFileException Constructor ()

[image]

SQL Data Compare API 12.0.40
SerializationInvalidFileException Constructor ()
SerializationInvalidFileException Class See Also

Initializes a new instance of the SerializationInvalidFileException class.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fileName As String _
)
C#
public SerializationInvalidFileException(
    string fileName
)
Visual C++
public:
SerializationInvalidFileException(
    String^ fileName
)

Parameters

fileName
Type: String
The name of the file that caused the exception.

See Also

SerializationInvalidFileException Class
SerializationInvalidFileException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidFileException Constructor (, )

[image]

SQL Data Compare API 12.0.40
SerializationInvalidFileException Constructor (, )
SerializationInvalidFileException Class See Also

Initializes a new instance of the SerializationInvalidFileException class with serialized data.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected SerializationInvalidFileException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
SerializationInvalidFileException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: SerializationInfo
The object that holds the serialized object data.
context
Type: StreamingContext
The contextual information about the source or destination.

See Also

SerializationInvalidFileException Class
SerializationInvalidFileException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidFileException Constructor (, )

[image]

SQL Data Compare API 12.0.40
SerializationInvalidFileException Constructor (, )
SerializationInvalidFileException Class See Also

Initializes a new instance of the SerializationInvalidFileException class with a specified error message.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    fileName As String _
)
C#
public SerializationInvalidFileException(
    string message,
    string fileName
)
Visual C++
public:
SerializationInvalidFileException(
    String^ message,
    String^ fileName
)

Parameters

message
Type: String
The error message that explains the reason for the exception.
fileName
Type: String
The name of the file that caused the exception.

See Also

SerializationInvalidFileException Class
SerializationInvalidFileException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidFileException Constructor (, , )

[image]

SQL Data Compare API 12.0.40
SerializationInvalidFileException Constructor (, , )
SerializationInvalidFileException Class See Also

Initializes a new instance of the SerializationInvalidFileException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    fileName As String, _
    innerException As Exception _
)
C#
public SerializationInvalidFileException(
    string message,
    string fileName,
    Exception innerException
)
Visual C++
public:
SerializationInvalidFileException(
    String^ message,
    String^ fileName,
    Exception^ innerException
)

Parameters

message
Type: String
The error message that explains the reason for the exception.
fileName
Type: String
The name of the file that caused the exception.
innerException
Type: Exception
The exception that is the cause of the current exception.

See Also

SerializationInvalidFileException Class
SerializationInvalidFileException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidFileException Properties

[image] [image]

SQL Data Compare API 12.0.40
SerializationInvalidFileException Properties
SerializationInvalidFileException Class See Also

The SerializationInvalidFileException type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
FileName | Gets the name of the file that is incorrectly formatted.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SerializationInvalidFileException Class
RedGate.Shared.Utils.IO.Serialization Namespace


FileName Property

[image]

SQL Data Compare API 12.0.40
SerializationInvalidFileException..::.FileName Property
SerializationInvalidFileException Class See Also

Gets the name of the file that is incorrectly formatted.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Property FileName As String
C#
public string FileName { get; private set; }
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

See Also

SerializationInvalidFileException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidFileTypeException Class

[image]

SQL Data Compare API 12.0.40
SerializationInvalidFileTypeException Class
Members See Also

Serialization error caused by an unexpected type name in the file.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class SerializationInvalidFileTypeException _
    Inherits SerializationInvalidFileException
C#
[SerializableAttribute]
public class SerializationInvalidFileTypeException : SerializationInvalidFileException
Visual C++
[SerializableAttribute]
public ref class SerializationInvalidFileTypeException : public SerializationInvalidFileException

Inheritance Hierarchy

Object
Exception
RedGate.Shared.Utils.IO.Serialization..::.SerializationException
RedGate.Shared.Utils.IO.Serialization..::.SerializationInvalidFileException
RedGate.Shared.Utils.IO.Serialization..::.SerializationInvalidFileTypeException

See Also

SerializationInvalidFileTypeException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidFileTypeException Members

[image] [image]

SQL Data Compare API 12.0.40
SerializationInvalidFileTypeException Members
SerializationInvalidFileTypeException Class Constructors Methods Properties See Also

The SerializationInvalidFileTypeException type exposes the following members.

Constructors

Name | Description
SerializationInvalidFileTypeException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
FileName | Gets the name of the file that is incorrectly formatted. (Inherited from SerializationInvalidFileException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
TypeName | Gets the type name that caused the exception.

See Also

SerializationInvalidFileTypeException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidFileTypeException Constructor

[image] [image]

SQL Data Compare API 12.0.40
SerializationInvalidFileTypeException Constructor
SerializationInvalidFileTypeException Class See Also

Overload List

Name | Description
SerializationInvalidFileTypeException(SerializationInfo, StreamingContext) | Initializes a new instance of the SerializationInvalidFileTypeException class with serialized data.
SerializationInvalidFileTypeException(String, String) | Initializes a new instance of the SerializationInvalidFileTypeException class.
SerializationInvalidFileTypeException(String, String, String) | Initializes a new instance of the SerializationInvalidFileTypeException class with a specified error message.

See Also

SerializationInvalidFileTypeException Class
SerializationInvalidFileTypeException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidFileTypeException Constructor (, )

[image]

SQL Data Compare API 12.0.40
SerializationInvalidFileTypeException Constructor (, )
SerializationInvalidFileTypeException Class See Also

Initializes a new instance of the SerializationInvalidFileTypeException class with serialized data.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected SerializationInvalidFileTypeException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
SerializationInvalidFileTypeException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: SerializationInfo
The object that holds the serialized object data.
context
Type: StreamingContext
The contextual information about the source or destination.

See Also

SerializationInvalidFileTypeException Class
SerializationInvalidFileTypeException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidFileTypeException Constructor (, )

[image]

SQL Data Compare API 12.0.40
SerializationInvalidFileTypeException Constructor (, )
SerializationInvalidFileTypeException Class See Also

Initializes a new instance of the SerializationInvalidFileTypeException class.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fileName As String, _
    typeName As String _
)
C#
public SerializationInvalidFileTypeException(
    string fileName,
    string typeName
)
Visual C++
public:
SerializationInvalidFileTypeException(
    String^ fileName,
    String^ typeName
)

Parameters

fileName
Type: String
The name of the file that caused the exception.
typeName
Type: String
The type name that caused the exception.

See Also

SerializationInvalidFileTypeException Class
SerializationInvalidFileTypeException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidFileTypeException Constructor (, , )

[image]

SQL Data Compare API 12.0.40
SerializationInvalidFileTypeException Constructor (, , )
SerializationInvalidFileTypeException Class See Also

Initializes a new instance of the SerializationInvalidFileTypeException class with a specified error message.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    fileName As String, _
    typeName As String _
)
C#
public SerializationInvalidFileTypeException(
    string message,
    string fileName,
    string typeName
)
Visual C++
public:
SerializationInvalidFileTypeException(
    String^ message,
    String^ fileName,
    String^ typeName
)

Parameters

message
Type: String
The error message that explains the reason for the exception.
fileName
Type: String
The name of the file that caused the exception.
typeName
Type: String
The type name that caused the exception.

See Also

SerializationInvalidFileTypeException Class
SerializationInvalidFileTypeException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidFileTypeException Properties

[image] [image]

SQL Data Compare API 12.0.40
SerializationInvalidFileTypeException Properties
SerializationInvalidFileTypeException Class See Also

The SerializationInvalidFileTypeException type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
FileName | Gets the name of the file that is incorrectly formatted. (Inherited from SerializationInvalidFileException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
TypeName | Gets the type name that caused the exception.

See Also

SerializationInvalidFileTypeException Class
RedGate.Shared.Utils.IO.Serialization Namespace


TypeName Property

[image]

SQL Data Compare API 12.0.40
SerializationInvalidFileTypeException..::.TypeName Property
SerializationInvalidFileTypeException Class See Also

Gets the type name that caused the exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeName As String
C#
public string TypeName { get; private set; }
Visual C++
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}

See Also

SerializationInvalidFileTypeException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidTypeException Class

[image]

SQL Data Compare API 12.0.40
SerializationInvalidTypeException Class
Members See Also

Serialization error caused by a type name not being recognised by the deserializer.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class SerializationInvalidTypeException _
    Inherits SerializationException
C#
[SerializableAttribute]
public class SerializationInvalidTypeException : SerializationException
Visual C++
[SerializableAttribute]
public ref class SerializationInvalidTypeException : public SerializationException

Inheritance Hierarchy

Object
Exception
RedGate.Shared.Utils.IO.Serialization..::.SerializationException
RedGate.Shared.Utils.IO.Serialization..::.SerializationInvalidTypeException

See Also

SerializationInvalidTypeException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidTypeException Members

[image] [image]

SQL Data Compare API 12.0.40
SerializationInvalidTypeException Members
SerializationInvalidTypeException Class Constructors Methods Properties See Also

The SerializationInvalidTypeException type exposes the following members.

Constructors

Name | Description
SerializationInvalidTypeException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Parameter | Gets the name of the parameter that caused the exception.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
TypeName | Gets the type name that caused the exception.

See Also

SerializationInvalidTypeException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidTypeException Constructor

[image] [image]

SQL Data Compare API 12.0.40
SerializationInvalidTypeException Constructor
SerializationInvalidTypeException Class See Also

Overload List

Name | Description
SerializationInvalidTypeException(SerializationInfo, StreamingContext) | Initializes a new instance of the SerializationInvalidTypeException class with serialized data.
SerializationInvalidTypeException(String, String) | Initializes a new instance of the SerializationInvalidTypeException.
SerializationInvalidTypeException(String, String, String) | Initializes a new instance of the SerializationInvalidTypeException with the specified error message.

See Also

SerializationInvalidTypeException Class
SerializationInvalidTypeException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidTypeException Constructor (, )

[image]

SQL Data Compare API 12.0.40
SerializationInvalidTypeException Constructor (, )
SerializationInvalidTypeException Class See Also

Initializes a new instance of the SerializationInvalidTypeException class with serialized data.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected SerializationInvalidTypeException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
SerializationInvalidTypeException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: SerializationInfo
The object that holds the serialized object data.
context
Type: StreamingContext
The contextual information about the source or destination.

See Also

SerializationInvalidTypeException Class
SerializationInvalidTypeException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidTypeException Constructor (, )

[image]

SQL Data Compare API 12.0.40
SerializationInvalidTypeException Constructor (, )
SerializationInvalidTypeException Class See Also

Initializes a new instance of the SerializationInvalidTypeException.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    paramName As String, _
    typeName As String _
)
C#
public SerializationInvalidTypeException(
    string paramName,
    string typeName
)
Visual C++
public:
SerializationInvalidTypeException(
    String^ paramName,
    String^ typeName
)

Parameters

paramName
Type: String
The name of the parameter that caused the exception.
typeName
Type: String
The type name that caused the exception.

See Also

SerializationInvalidTypeException Class
SerializationInvalidTypeException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidTypeException Constructor (, , )

[image]

SQL Data Compare API 12.0.40
SerializationInvalidTypeException Constructor (, , )
SerializationInvalidTypeException Class See Also

Initializes a new instance of the SerializationInvalidTypeException with the specified error message.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    paramName As String, _
    typeName As String _
)
C#
public SerializationInvalidTypeException(
    string message,
    string paramName,
    string typeName
)
Visual C++
public:
SerializationInvalidTypeException(
    String^ message,
    String^ paramName,
    String^ typeName
)

Parameters

message
Type: String
The error message that explains the reason for the exception.
paramName
Type: String
The name of the parameter that caused the exception.
typeName
Type: String
The type name that caused the exception.

See Also

SerializationInvalidTypeException Class
SerializationInvalidTypeException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidTypeException Properties

[image] [image]

SQL Data Compare API 12.0.40
SerializationInvalidTypeException Properties
SerializationInvalidTypeException Class See Also

The SerializationInvalidTypeException type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Parameter | Gets the name of the parameter that caused the exception.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
TypeName | Gets the type name that caused the exception.

See Also

SerializationInvalidTypeException Class
RedGate.Shared.Utils.IO.Serialization Namespace


Parameter Property

[image]

SQL Data Compare API 12.0.40
SerializationInvalidTypeException..::.Parameter Property
SerializationInvalidTypeException Class See Also

Gets the name of the parameter that caused the exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Property Parameter As String
C#
public string Parameter { get; private set; }
Visual C++
public:
property String^ Parameter {
    String^ get ();
    void set (String^ value);
}

See Also

SerializationInvalidTypeException Class
RedGate.Shared.Utils.IO.Serialization Namespace


TypeName Property

[image]

SQL Data Compare API 12.0.40
SerializationInvalidTypeException..::.TypeName Property
SerializationInvalidTypeException Class See Also

Gets the type name that caused the exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeName As String
C#
public string TypeName { get; private set; }
Visual C++
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}

See Also

SerializationInvalidTypeException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidVersionException Class

[image]

SQL Data Compare API 12.0.40
SerializationInvalidVersionException Class
Members See Also

Serialization error caused by attempting to deserialize a file for which the serialization version is different to the specified object version.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class SerializationInvalidVersionException _
    Inherits SerializationException
C#
[SerializableAttribute]
public class SerializationInvalidVersionException : SerializationException
Visual C++
[SerializableAttribute]
public ref class SerializationInvalidVersionException : public SerializationException

Inheritance Hierarchy

Object
Exception
RedGate.Shared.Utils.IO.Serialization..::.SerializationException
RedGate.Shared.Utils.IO.Serialization..::.SerializationInvalidVersionException

See Also

SerializationInvalidVersionException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidVersionException Members

[image] [image]

SQL Data Compare API 12.0.40
SerializationInvalidVersionException Members
SerializationInvalidVersionException Class Constructors Methods Properties See Also

The SerializationInvalidVersionException type exposes the following members.

Constructors

Name | Description
SerializationInvalidVersionException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Parameter | Gets the name of the parameter that caused the exception.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
TypeName | Gets the type name that caused the exception.
Version | Gets the version that caused the exception.

See Also

SerializationInvalidVersionException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidVersionException Constructor

[image] [image]

SQL Data Compare API 12.0.40
SerializationInvalidVersionException Constructor
SerializationInvalidVersionException Class See Also

Overload List

Name | Description
SerializationInvalidVersionException(SerializationInfo, StreamingContext) | Initializes a new instance of the SerializationInvalidVersionException class with serialized data.
SerializationInvalidVersionException(String, String, String) | Initializes a new instance of the SerializationInvalidVersionException class.
SerializationInvalidVersionException(String, String, String, String) | Initializes a new instance of the SerializationInvalidVersionException class with a specified error message.
SerializationInvalidVersionException(String, String, String, String, Exception) | Initializes a new instance of the SerializationInvalidVersionException class with a specified error message and a reference to the inner exception that is the cause of this exception.

See Also

SerializationInvalidVersionException Class
SerializationInvalidVersionException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidVersionException Constructor (, )

[image]

SQL Data Compare API 12.0.40
SerializationInvalidVersionException Constructor (, )
SerializationInvalidVersionException Class See Also

Initializes a new instance of the SerializationInvalidVersionException class with serialized data.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected SerializationInvalidVersionException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
SerializationInvalidVersionException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: SerializationInfo
The object that holds the serialized object data.
context
Type: StreamingContext
The contextual information about the source or destination.

See Also

SerializationInvalidVersionException Class
SerializationInvalidVersionException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidVersionException Constructor (, , )

[image]

SQL Data Compare API 12.0.40
SerializationInvalidVersionException Constructor (, , )
SerializationInvalidVersionException Class See Also

Initializes a new instance of the SerializationInvalidVersionException class.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    paramName As String, _
    typeName As String, _
    version As String _
)
C#
public SerializationInvalidVersionException(
    string paramName,
    string typeName,
    string version
)
Visual C++
public:
SerializationInvalidVersionException(
    String^ paramName,
    String^ typeName,
    String^ version
)

Parameters

paramName
Type: String
The name of the parameter that caused the exception.
typeName
Type: String
The type name that caused the exception.
version
Type: String
The version that caused the exception.

See Also

SerializationInvalidVersionException Class
SerializationInvalidVersionException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidVersionException Constructor (, , , )

[image]

SQL Data Compare API 12.0.40
SerializationInvalidVersionException Constructor (, , , )
SerializationInvalidVersionException Class See Also

Initializes a new instance of the SerializationInvalidVersionException class with a specified error message.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    paramName As String, _
    typeName As String, _
    version As String _
)
C#
public SerializationInvalidVersionException(
    string message,
    string paramName,
    string typeName,
    string version
)
Visual C++
public:
SerializationInvalidVersionException(
    String^ message,
    String^ paramName,
    String^ typeName,
    String^ version
)

Parameters

message
Type: String
The error message that explains the reason for the exception.
paramName
Type: String
The name of the parameter that caused the exception.
typeName
Type: String
The type name that caused the exception.
version
Type: String
The version that caused the exception.

See Also

SerializationInvalidVersionException Class
SerializationInvalidVersionException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidVersionException Constructor (, , , , )

[image]

SQL Data Compare API 12.0.40
SerializationInvalidVersionException Constructor (, , , , )
SerializationInvalidVersionException Class See Also

Initializes a new instance of the SerializationInvalidVersionException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    paramName As String, _
    typeName As String, _
    version As String, _
    innerException As Exception _
)
C#
public SerializationInvalidVersionException(
    string message,
    string paramName,
    string typeName,
    string version,
    Exception innerException
)
Visual C++
public:
SerializationInvalidVersionException(
    String^ message,
    String^ paramName,
    String^ typeName,
    String^ version,
    Exception^ innerException
)

Parameters

message
Type: String
The error message that explains the reason for the exception.
paramName
Type: String
The name of the parameter that caused the exception.
typeName
Type: String
The type name that caused the exception.
version
Type: String
The version that caused the exception.
innerException
Type: Exception
The exception that is the cause of the current exception.

See Also

SerializationInvalidVersionException Class
SerializationInvalidVersionException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidVersionException Properties

[image] [image]

SQL Data Compare API 12.0.40
SerializationInvalidVersionException Properties
SerializationInvalidVersionException Class See Also

The SerializationInvalidVersionException type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Parameter | Gets the name of the parameter that caused the exception.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
TypeName | Gets the type name that caused the exception.
Version | Gets the version that caused the exception.

See Also

SerializationInvalidVersionException Class
RedGate.Shared.Utils.IO.Serialization Namespace


Parameter Property

[image]

SQL Data Compare API 12.0.40
SerializationInvalidVersionException..::.Parameter Property
SerializationInvalidVersionException Class See Also

Gets the name of the parameter that caused the exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Property Parameter As String
C#
public string Parameter { get; private set; }
Visual C++
public:
property String^ Parameter {
    String^ get ();
    void set (String^ value);
}

See Also

SerializationInvalidVersionException Class
RedGate.Shared.Utils.IO.Serialization Namespace


TypeName Property

[image]

SQL Data Compare API 12.0.40
SerializationInvalidVersionException..::.TypeName Property
SerializationInvalidVersionException Class See Also

Gets the type name that caused the exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeName As String
C#
public string TypeName { get; private set; }
Visual C++
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}

See Also

SerializationInvalidVersionException Class
RedGate.Shared.Utils.IO.Serialization Namespace


Version Property

[image]

SQL Data Compare API 12.0.40
SerializationInvalidVersionException..::.Version Property
SerializationInvalidVersionException Class See Also

Gets the version that caused the exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Property Version As String
C#
public string Version { get; private set; }
Visual C++
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}

See Also

SerializationInvalidVersionException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationNotSupportedException Class

[image]

SQL Data Compare API 12.0.40
SerializationNotSupportedException Class
Members See Also

Serialization error caused by a class not implementing the IRedGateSerializable interface.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class SerializationNotSupportedException _
    Inherits SerializationException
C#
[SerializableAttribute]
public class SerializationNotSupportedException : SerializationException
Visual C++
[SerializableAttribute]
public ref class SerializationNotSupportedException : public SerializationException

Inheritance Hierarchy

Object
Exception
RedGate.Shared.Utils.IO.Serialization..::.SerializationException
RedGate.Shared.Utils.IO.Serialization..::.SerializationNotSupportedException

See Also

SerializationNotSupportedException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationNotSupportedException Members

[image] [image]

SQL Data Compare API 12.0.40
SerializationNotSupportedException Members
SerializationNotSupportedException Class Constructors Methods Properties See Also

The SerializationNotSupportedException type exposes the following members.

Constructors

Name | Description
SerializationNotSupportedException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Parameter | Gets the name of the parameter that caused the exception.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
TypeName | Gets the type name that caused the exception.

See Also

SerializationNotSupportedException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationNotSupportedException Constructor

[image] [image]

SQL Data Compare API 12.0.40
SerializationNotSupportedException Constructor
SerializationNotSupportedException Class See Also

Overload List

Name | Description
SerializationNotSupportedException(SerializationInfo, StreamingContext) | Initializes a new instance of the SerializationNotSupportedException class with serialized data.
SerializationNotSupportedException(String, String) | Initializes a new instance of the SerializationNotSupportedException.
SerializationNotSupportedException(String, String, String) | Initializes a new instance of the SerializationNotSupportedException with a specified error message.

See Also

SerializationNotSupportedException Class
SerializationNotSupportedException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationNotSupportedException Constructor (, )

[image]

SQL Data Compare API 12.0.40
SerializationNotSupportedException Constructor (, )
SerializationNotSupportedException Class See Also

Initializes a new instance of the SerializationNotSupportedException class with serialized data.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected SerializationNotSupportedException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
SerializationNotSupportedException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: SerializationInfo
The object that holds the serialized object data.
context
Type: StreamingContext
The contextual information about the source or destination.

See Also

SerializationNotSupportedException Class
SerializationNotSupportedException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationNotSupportedException Constructor (, )

[image]

SQL Data Compare API 12.0.40
SerializationNotSupportedException Constructor (, )
SerializationNotSupportedException Class See Also

Initializes a new instance of the SerializationNotSupportedException.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    paramName As String, _
    typeName As String _
)
C#
public SerializationNotSupportedException(
    string paramName,
    string typeName
)
Visual C++
public:
SerializationNotSupportedException(
    String^ paramName,
    String^ typeName
)

Parameters

paramName
Type: String
The name of the parameter that caused the exception.
typeName
Type: String
The type name that caused the exception.

See Also

SerializationNotSupportedException Class
SerializationNotSupportedException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationNotSupportedException Constructor (, , )

[image]

SQL Data Compare API 12.0.40
SerializationNotSupportedException Constructor (, , )
SerializationNotSupportedException Class See Also

Initializes a new instance of the SerializationNotSupportedException with a specified error message.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    paramName As String, _
    typeName As String _
)
C#
public SerializationNotSupportedException(
    string message,
    string paramName,
    string typeName
)
Visual C++
public:
SerializationNotSupportedException(
    String^ message,
    String^ paramName,
    String^ typeName
)

Parameters

message
Type: String
The error message that explains the reason for the exception.
paramName
Type: String
The name of the parameter that caused the exception.
typeName
Type: String
The type name that caused the exception.

See Also

SerializationNotSupportedException Class
SerializationNotSupportedException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationNotSupportedException Properties

[image] [image]

SQL Data Compare API 12.0.40
SerializationNotSupportedException Properties
SerializationNotSupportedException Class See Also

The SerializationNotSupportedException type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Parameter | Gets the name of the parameter that caused the exception.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
TypeName | Gets the type name that caused the exception.

See Also

SerializationNotSupportedException Class
RedGate.Shared.Utils.IO.Serialization Namespace


Parameter Property

[image]

SQL Data Compare API 12.0.40
SerializationNotSupportedException..::.Parameter Property
SerializationNotSupportedException Class See Also

Gets the name of the parameter that caused the exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Property Parameter As String
C#
public string Parameter { get; private set; }
Visual C++
public:
property String^ Parameter {
    String^ get ();
    void set (String^ value);
}

See Also

SerializationNotSupportedException Class
RedGate.Shared.Utils.IO.Serialization Namespace


TypeName Property

[image]

SQL Data Compare API 12.0.40
SerializationNotSupportedException..::.TypeName Property
SerializationNotSupportedException Class See Also

Gets the type name that caused the exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeName As String
C#
public string TypeName { get; private set; }
Visual C++
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}

See Also

SerializationNotSupportedException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterConversionException Class

[image]

SQL Data Compare API 12.0.40
SerializationParameterConversionException Class
Members See Also

Serialization error caused by an error raised when converting a parameter. This could be because the serialized file has been edited manually.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class SerializationParameterConversionException _
    Inherits SerializationException
C#
[SerializableAttribute]
public class SerializationParameterConversionException : SerializationException
Visual C++
[SerializableAttribute]
public ref class SerializationParameterConversionException : public SerializationException

Inheritance Hierarchy

Object
Exception
RedGate.Shared.Utils.IO.Serialization..::.SerializationException
RedGate.Shared.Utils.IO.Serialization..::.SerializationParameterConversionException

See Also

SerializationParameterConversionException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterConversionException Members

[image] [image]

SQL Data Compare API 12.0.40
SerializationParameterConversionException Members
SerializationParameterConversionException Class Constructors Methods Properties See Also

The SerializationParameterConversionException type exposes the following members.

Constructors

Name | Description
SerializationParameterConversionException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
FileName | Gets the name of the file that caused the exception.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Parameter | Gets the name of the parameter that caused the exception.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SerializationParameterConversionException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterConversionException Constructor

[image] [image]

SQL Data Compare API 12.0.40
SerializationParameterConversionException Constructor
SerializationParameterConversionException Class See Also

Overload List

Name | Description
SerializationParameterConversionException(SerializationInfo, StreamingContext) | Initializes a new instance of the SerializationParameterConversionException class with serialized data.
SerializationParameterConversionException(String, String) | Initializes a new instance of the SerializationParameterConversionException class.
SerializationParameterConversionException(String, String, String) | Initializes a new instance of the SerializationParameterConversionException class with a specified error message.
SerializationParameterConversionException(String, String, String, Exception) | Initializes a new instance of the SerializationParameterConversionException class with a specified error message and a reference to the inner exception that is the cause of this exception.

See Also

SerializationParameterConversionException Class
SerializationParameterConversionException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterConversionException Constructor (, )

[image]

SQL Data Compare API 12.0.40
SerializationParameterConversionException Constructor (, )
SerializationParameterConversionException Class See Also

Initializes a new instance of the SerializationParameterConversionException class with serialized data.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected SerializationParameterConversionException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
SerializationParameterConversionException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: SerializationInfo
The object that holds the serialized object data.
context
Type: StreamingContext
The contextual information about the source or destination.

See Also

SerializationParameterConversionException Class
SerializationParameterConversionException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterConversionException Constructor (, )

[image]

SQL Data Compare API 12.0.40
SerializationParameterConversionException Constructor (, )
SerializationParameterConversionException Class See Also

Initializes a new instance of the SerializationParameterConversionException class.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    paramName As String, _
    fileName As String _
)
C#
public SerializationParameterConversionException(
    string paramName,
    string fileName
)
Visual C++
public:
SerializationParameterConversionException(
    String^ paramName,
    String^ fileName
)

Parameters

paramName
Type: String
The name of the parameter that caused the exception.
fileName
Type: String
The name of the file that caused the exception.

See Also

SerializationParameterConversionException Class
SerializationParameterConversionException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterConversionException Constructor (, , )

[image]

SQL Data Compare API 12.0.40
SerializationParameterConversionException Constructor (, , )
SerializationParameterConversionException Class See Also

Initializes a new instance of the SerializationParameterConversionException class with a specified error message.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    paramName As String, _
    fileName As String _
)
C#
public SerializationParameterConversionException(
    string message,
    string paramName,
    string fileName
)
Visual C++
public:
SerializationParameterConversionException(
    String^ message,
    String^ paramName,
    String^ fileName
)

Parameters

message
Type: String
The error message that explains the reason for the exception.
paramName
Type: String
The name of the parameter that caused the exception.
fileName
Type: String
The name of the file that caused the exception.

See Also

SerializationParameterConversionException Class
SerializationParameterConversionException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterConversionException Constructor (, , , )

[image]

SQL Data Compare API 12.0.40
SerializationParameterConversionException Constructor (, , , )
SerializationParameterConversionException Class See Also

Initializes a new instance of the SerializationParameterConversionException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    paramName As String, _
    fileName As String, _
    innerException As Exception _
)
C#
public SerializationParameterConversionException(
    string message,
    string paramName,
    string fileName,
    Exception innerException
)
Visual C++
public:
SerializationParameterConversionException(
    String^ message,
    String^ paramName,
    String^ fileName,
    Exception^ innerException
)

Parameters

message
Type: String
The error message that explains the reason for the exception.
paramName
Type: String
The name of the parameter that caused the exception.
fileName
Type: String
The name of the file that caused the exception.
innerException
Type: Exception
The exception that is the cause of the current exception.

See Also

SerializationParameterConversionException Class
SerializationParameterConversionException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterConversionException Properties

[image] [image]

SQL Data Compare API 12.0.40
SerializationParameterConversionException Properties
SerializationParameterConversionException Class See Also

The SerializationParameterConversionException type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
FileName | Gets the name of the file that caused the exception.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Parameter | Gets the name of the parameter that caused the exception.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SerializationParameterConversionException Class
RedGate.Shared.Utils.IO.Serialization Namespace


FileName Property

[image]

SQL Data Compare API 12.0.40
SerializationParameterConversionException..::.FileName Property
SerializationParameterConversionException Class See Also

Gets the name of the file that caused the exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Property FileName As String
C#
public string FileName { get; private set; }
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

See Also

SerializationParameterConversionException Class
RedGate.Shared.Utils.IO.Serialization Namespace


Parameter Property

[image]

SQL Data Compare API 12.0.40
SerializationParameterConversionException..::.Parameter Property
SerializationParameterConversionException Class See Also

Gets the name of the parameter that caused the exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Property Parameter As String
C#
public string Parameter { get; private set; }
Visual C++
public:
property String^ Parameter {
    String^ get ();
    void set (String^ value);
}

See Also

SerializationParameterConversionException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterEmptyException Class

[image]

SQL Data Compare API 12.0.40
SerializationParameterEmptyException Class
Members See Also

Serialization error caused by an empty parameter.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class SerializationParameterEmptyException _
    Inherits SerializationException
C#
[SerializableAttribute]
public class SerializationParameterEmptyException : SerializationException
Visual C++
[SerializableAttribute]
public ref class SerializationParameterEmptyException : public SerializationException

Inheritance Hierarchy

Object
Exception
RedGate.Shared.Utils.IO.Serialization..::.SerializationException
RedGate.Shared.Utils.IO.Serialization..::.SerializationParameterEmptyException

See Also

SerializationParameterEmptyException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterEmptyException Members

[image] [image]

SQL Data Compare API 12.0.40
SerializationParameterEmptyException Members
SerializationParameterEmptyException Class Constructors Methods Properties See Also

The SerializationParameterEmptyException type exposes the following members.

Constructors

Name | Description
SerializationParameterEmptyException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
FileName | Gets the name of the file that caused the exception.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Parameter | Gets the name of the parameter that caused the exception.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SerializationParameterEmptyException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterEmptyException Constructor

[image] [image]

SQL Data Compare API 12.0.40
SerializationParameterEmptyException Constructor
SerializationParameterEmptyException Class See Also

Overload List

Name | Description
SerializationParameterEmptyException(SerializationInfo, StreamingContext) | Initializes a new instance of the SerializationParameterEmptyException class with serialized data.
SerializationParameterEmptyException(String, String) | Initializes a new instance of the SerializationParameterEmptyException class.
SerializationParameterEmptyException(String, String, String) | Initializes a new instance of the SerializationParameterEmptyException class with a specified error message.

See Also

SerializationParameterEmptyException Class
SerializationParameterEmptyException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterEmptyException Constructor (, )

[image]

SQL Data Compare API 12.0.40
SerializationParameterEmptyException Constructor (, )
SerializationParameterEmptyException Class See Also

Initializes a new instance of the SerializationParameterEmptyException class with serialized data.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected SerializationParameterEmptyException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
SerializationParameterEmptyException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: SerializationInfo
The object that holds the serialized object data.
context
Type: StreamingContext
The contextual information about the source or destination.

See Also

SerializationParameterEmptyException Class
SerializationParameterEmptyException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterEmptyException Constructor (, )

[image]

SQL Data Compare API 12.0.40
SerializationParameterEmptyException Constructor (, )
SerializationParameterEmptyException Class See Also

Initializes a new instance of the SerializationParameterEmptyException class.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fileName As String, _
    parameter As String _
)
C#
public SerializationParameterEmptyException(
    string fileName,
    string parameter
)
Visual C++
public:
SerializationParameterEmptyException(
    String^ fileName,
    String^ parameter
)

Parameters

fileName
Type: String
The name of the file that caused the exception.
parameter
Type: String
The name of the parameter that caused the exception.

See Also

SerializationParameterEmptyException Class
SerializationParameterEmptyException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterEmptyException Constructor (, , )

[image]

SQL Data Compare API 12.0.40
SerializationParameterEmptyException Constructor (, , )
SerializationParameterEmptyException Class See Also

Initializes a new instance of the SerializationParameterEmptyException class with a specified error message.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    fileName As String, _
    parameter As String _
)
C#
public SerializationParameterEmptyException(
    string message,
    string fileName,
    string parameter
)
Visual C++
public:
SerializationParameterEmptyException(
    String^ message,
    String^ fileName,
    String^ parameter
)

Parameters

message
Type: String
The error message that explains the reason for the exception.
fileName
Type: String
The name of the file that caused the exception.
parameter
Type: String
The name of the parameter that caused the exception.

See Also

SerializationParameterEmptyException Class
SerializationParameterEmptyException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterEmptyException Properties

[image] [image]

SQL Data Compare API 12.0.40
SerializationParameterEmptyException Properties
SerializationParameterEmptyException Class See Also

The SerializationParameterEmptyException type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
FileName | Gets the name of the file that caused the exception.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Parameter | Gets the name of the parameter that caused the exception.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SerializationParameterEmptyException Class
RedGate.Shared.Utils.IO.Serialization Namespace


FileName Property

[image]

SQL Data Compare API 12.0.40
SerializationParameterEmptyException..::.FileName Property
SerializationParameterEmptyException Class See Also

Gets the name of the file that caused the exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Property FileName As String
C#
public string FileName { get; private set; }
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

See Also

SerializationParameterEmptyException Class
RedGate.Shared.Utils.IO.Serialization Namespace


Parameter Property

[image]

SQL Data Compare API 12.0.40
SerializationParameterEmptyException..::.Parameter Property
SerializationParameterEmptyException Class See Also

Gets the name of the parameter that caused the exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Property Parameter As String
C#
public string Parameter { get; private set; }
Visual C++
public:
property String^ Parameter {
    String^ get ();
    void set (String^ value);
}

See Also

SerializationParameterEmptyException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterMissingException Class

[image]

SQL Data Compare API 12.0.40
SerializationParameterMissingException Class
Members See Also

Serialization error caused by a missing parameter.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class SerializationParameterMissingException _
    Inherits SerializationException
C#
[SerializableAttribute]
public class SerializationParameterMissingException : SerializationException
Visual C++
[SerializableAttribute]
public ref class SerializationParameterMissingException : public SerializationException

Inheritance Hierarchy

Object
Exception
RedGate.Shared.Utils.IO.Serialization..::.SerializationException
RedGate.Shared.Utils.IO.Serialization..::.SerializationParameterMissingException

See Also

SerializationParameterMissingException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterMissingException Members

[image] [image]

SQL Data Compare API 12.0.40
SerializationParameterMissingException Members
SerializationParameterMissingException Class Constructors Methods Properties See Also

The SerializationParameterMissingException type exposes the following members.

Constructors

Name | Description
SerializationParameterMissingException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
FileName | Gets the name of the file that caused the exception.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Parameter | Gets the name of the parameter that caused the exception.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SerializationParameterMissingException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterMissingException Constructor

[image] [image]

SQL Data Compare API 12.0.40
SerializationParameterMissingException Constructor
SerializationParameterMissingException Class See Also

Overload List

Name | Description
SerializationParameterMissingException(SerializationInfo, StreamingContext) | Initializes a new instance of the SerializationParameterConversionException class with serialized data.
SerializationParameterMissingException(String, String) | Initializes a new instance of the SerializationParameterMissingException class.
SerializationParameterMissingException(String, String, String) | Initializes a new instance of the SerializationParameterMissingException class with a specified error message.

See Also

SerializationParameterMissingException Class
SerializationParameterMissingException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterMissingException Constructor (, )

[image]

SQL Data Compare API 12.0.40
SerializationParameterMissingException Constructor (, )
SerializationParameterMissingException Class See Also

Initializes a new instance of the SerializationParameterConversionException class with serialized data.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected SerializationParameterMissingException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
SerializationParameterMissingException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: SerializationInfo
The object that holds the serialized object data.
context
Type: StreamingContext
The contextual information about the source or destination.

See Also

SerializationParameterMissingException Class
SerializationParameterMissingException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterMissingException Constructor (, )

[image]

SQL Data Compare API 12.0.40
SerializationParameterMissingException Constructor (, )
SerializationParameterMissingException Class See Also

Initializes a new instance of the SerializationParameterMissingException class.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fileName As String, _
    parameter As String _
)
C#
public SerializationParameterMissingException(
    string fileName,
    string parameter
)
Visual C++
public:
SerializationParameterMissingException(
    String^ fileName,
    String^ parameter
)

Parameters

fileName
Type: String
The name of the file that caused the exception.
parameter
Type: String
The name of the parameter that caused the exception.

See Also

SerializationParameterMissingException Class
SerializationParameterMissingException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterMissingException Constructor (, , )

[image]

SQL Data Compare API 12.0.40
SerializationParameterMissingException Constructor (, , )
SerializationParameterMissingException Class See Also

Initializes a new instance of the SerializationParameterMissingException class with a specified error message.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    fileName As String, _
    parameter As String _
)
C#
public SerializationParameterMissingException(
    string message,
    string fileName,
    string parameter
)
Visual C++
public:
SerializationParameterMissingException(
    String^ message,
    String^ fileName,
    String^ parameter
)

Parameters

message
Type: String
The error message that explains the reason for the exception.
fileName
Type: String
The name of the file that caused the exception.
parameter
Type: String
The name of the parameter that caused the exception.

See Also

SerializationParameterMissingException Class
SerializationParameterMissingException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterMissingException Properties

[image] [image]

SQL Data Compare API 12.0.40
SerializationParameterMissingException Properties
SerializationParameterMissingException Class See Also

The SerializationParameterMissingException type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
FileName | Gets the name of the file that caused the exception.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Parameter | Gets the name of the parameter that caused the exception.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SerializationParameterMissingException Class
RedGate.Shared.Utils.IO.Serialization Namespace


FileName Property

[image]

SQL Data Compare API 12.0.40
SerializationParameterMissingException..::.FileName Property
SerializationParameterMissingException Class See Also

Gets the name of the file that caused the exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Property FileName As String
C#
public string FileName { get; private set; }
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

See Also

SerializationParameterMissingException Class
RedGate.Shared.Utils.IO.Serialization Namespace


Parameter Property

[image]

SQL Data Compare API 12.0.40
SerializationParameterMissingException..::.Parameter Property
SerializationParameterMissingException Class See Also

Gets the name of the parameter that caused the exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Property Parameter As String
C#
public string Parameter { get; private set; }
Visual C++
public:
property String^ Parameter {
    String^ get ();
    void set (String^ value);
}

See Also

SerializationParameterMissingException Class
RedGate.Shared.Utils.IO.Serialization Namespace


RedGate.Shared.Utils.Reflection Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.Shared.Utils.Reflection Namespace

Classes

Class | Description
ReflectionUtils |


ReflectionUtils Class

[image]

SQL Data Compare API 12.0.40
ReflectionUtils Class
Members See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReflectionUtils
C#
public static class ReflectionUtils
Visual C++
public ref class ReflectionUtils abstract sealed

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Reflection..::.ReflectionUtils

See Also

ReflectionUtils Members
RedGate.Shared.Utils.Reflection Namespace


ReflectionUtils Members

[image] [image]

SQL Data Compare API 12.0.40
ReflectionUtils Members
ReflectionUtils Class Methods See Also

The ReflectionUtils type exposes the following members.

Methods

Name | Description
AllEnumValues<(Of <(T>)>) |
CallMethod | Overloaded.
CallStaticMethod | Overloaded.
ConvertPublicKeyTokenToString |
Create | Overloaded.
GetAttribute<(Of <(T>)>) |
GetExecutingAssemblyDirectory |
GetFieldValue<(Of <(TInstance, TValue>)>) |
GetPropertyValue<(Of <(TInstance, TValue>)>) |
GetStaticFieldValue<(Of <(TValue>)>) |
GetStaticPropertyValue<(Of <(TValue>)>) |
GetType |
HasProperty<(Of <(TInstace>)>) |
ListenFirstForEvent<(Of <(TInstance>)>) |
ListenFirstForEventIfNotCurrentlySubscribed<(Of <(TInstance>)>) |
SetFieldValue<(Of <(TInstance, TValue>)>) |
SetPropertyValue<(Of <(TInstance, TValue>)>) |
TryGetAttribute<(Of <(T>)>) |
TryGetPropertyValue<(Of <(TInstance, TValue>)>) |
TryLoadFromIfExists |
UpdateFieldValue<(Of <(TInstance, TValue>)>) |

See Also

ReflectionUtils Class
RedGate.Shared.Utils.Reflection Namespace


ReflectionUtils Methods

[image] [image]

SQL Data Compare API 12.0.40
ReflectionUtils Methods
ReflectionUtils Class See Also

The ReflectionUtils type exposes the following methods.

Methods

Name | Description
AllEnumValues<(Of <(T>)>) |
CallMethod | Overloaded.
CallStaticMethod | Overloaded.
ConvertPublicKeyTokenToString |
Create | Overloaded.
GetAttribute<(Of <(T>)>) |
GetExecutingAssemblyDirectory |
GetFieldValue<(Of <(TInstance, TValue>)>) |
GetPropertyValue<(Of <(TInstance, TValue>)>) |
GetStaticFieldValue<(Of <(TValue>)>) |
GetStaticPropertyValue<(Of <(TValue>)>) |
GetType |
HasProperty<(Of <(TInstace>)>) |
ListenFirstForEvent<(Of <(TInstance>)>) |
ListenFirstForEventIfNotCurrentlySubscribed<(Of <(TInstance>)>) |
SetFieldValue<(Of <(TInstance, TValue>)>) |
SetPropertyValue<(Of <(TInstance, TValue>)>) |
TryGetAttribute<(Of <(T>)>) |
TryGetPropertyValue<(Of <(TInstance, TValue>)>) |
TryLoadFromIfExists |
UpdateFieldValue<(Of <(TInstance, TValue>)>) |

See Also

ReflectionUtils Class
RedGate.Shared.Utils.Reflection Namespace


AllEnumValues(T) Generic Method

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.AllEnumValues<(Of <(T>)>) Generic Method
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function AllEnumValues(Of T) As T()
C#
public static T[] AllEnumValues<T>()
Visual C++
public:
generic<typename T>
static array<T>^ AllEnumValues()

Type Parameters

T

See Also

ReflectionUtils Class
RedGate.Shared.Utils.Reflection Namespace


CallMethod Method

[image] [image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.CallMethod Method
ReflectionUtils Class See Also

Overload List

Name | Description
CallMethod<(Of <(TInstance>)>)(TInstance, String) |
CallMethod<(Of <(TInstance, TResult>)>)(TInstance, String) |
CallMethod<(Of <(TInstance, TArg>)>)(TInstance, String, TArg) |
CallMethod<(Of <(TInstance, TArg, TResult>)>)(TInstance, String, TArg) |
CallMethod<(Of <(TInstance, TResult>)>)(TInstance, String, array<Type>[]()[], array<Object>[]()[]) |
CallMethod<(Of <(TInstance, TArg1, TArg2, TArg3>)>)(TInstance, String, TArg1, TArg2, TArg3) |

See Also

ReflectionUtils Class
ReflectionUtils Members
RedGate.Shared.Utils.Reflection Namespace


CallMethod(TInstance) Generic Method (TInstance, )

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.CallMethod<(Of <(TInstance>)>) Generic Method (TInstance, )
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub CallMethod(Of TInstance) ( _
    instance As TInstance, _
    method As String _
)
C#
public static void CallMethod<TInstance>(
    TInstance instance,
    string method
)
Visual C++
public:
generic<typename TInstance>
static void CallMethod(
    TInstance instance,
    String^ method
)

Parameters

instance
Type: TInstance
method
Type: String

Type Parameters

TInstance

See Also

ReflectionUtils Class
CallMethod Overload
RedGate.Shared.Utils.Reflection Namespace


CallMethod(TInstance, TResult) Generic Method (TInstance, )

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.CallMethod<(Of <(TInstance, TResult>)>) Generic Method (TInstance, )
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CallMethod(Of TInstance, TResult) ( _
    instance As TInstance, _
    method As String _
) As TResult
C#
public static TResult CallMethod<TInstance, TResult>(
    TInstance instance,
    string method
)
Visual C++
public:
generic<typename TInstance, typename TResult>
static TResult CallMethod(
    TInstance instance,
    String^ method
)

Parameters

instance
Type: TInstance
method
Type: String

Type Parameters

TInstance
TResult

See Also

ReflectionUtils Class
CallMethod Overload
RedGate.Shared.Utils.Reflection Namespace


CallMethod(TInstance, TArg) Generic Method (TInstance, , TArg)

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.CallMethod<(Of <(TInstance, TArg>)>) Generic Method (TInstance, , TArg)
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub CallMethod(Of TInstance, TArg) ( _
    instance As TInstance, _
    method As String, _
    arg As TArg _
)
C#
public static void CallMethod<TInstance, TArg>(
    TInstance instance,
    string method,
    TArg arg
)
Visual C++
public:
generic<typename TInstance, typename TArg>
static void CallMethod(
    TInstance instance,
    String^ method,
    TArg arg
)

Parameters

instance
Type: TInstance
method
Type: String
arg
Type: TArg

Type Parameters

TInstance
TArg

See Also

ReflectionUtils Class
CallMethod Overload
RedGate.Shared.Utils.Reflection Namespace


CallMethod(TInstance, TArg, TResult) Generic Method (TInstance, , TArg)

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.CallMethod<(Of <(TInstance, TArg, TResult>)>) Generic Method (TInstance, , TArg)
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CallMethod(Of TInstance, TArg, TResult) ( _
    instance As TInstance, _
    method As String, _
    arg As TArg _
) As TResult
C#
public static TResult CallMethod<TInstance, TArg, TResult>(
    TInstance instance,
    string method,
    TArg arg
)
Visual C++
public:
generic<typename TInstance, typename TArg, typename TResult>
static TResult CallMethod(
    TInstance instance,
    String^ method,
    TArg arg
)

Parameters

instance
Type: TInstance
method
Type: String
arg
Type: TArg

Type Parameters

TInstance
TArg
TResult

See Also

ReflectionUtils Class
CallMethod Overload
RedGate.Shared.Utils.Reflection Namespace


CallMethod(TInstance, TResult) Generic Method (TInstance, , [], [])

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.CallMethod<(Of <(TInstance, TResult>)>) Generic Method (TInstance, , array<>[]()[], array<>[]()[])
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CallMethod(Of TInstance, TResult) ( _
    instance As TInstance, _
    method As String, _
    argTypes As Type(), _
    args As Object() _
) As TResult
C#
public static TResult CallMethod<TInstance, TResult>(
    TInstance instance,
    string method,
    Type[] argTypes,
    Object[] args
)
Visual C++
public:
generic<typename TInstance, typename TResult>
static TResult CallMethod(
    TInstance instance,
    String^ method,
    array<Type^>^ argTypes,
    array<Object^>^ args
)

Parameters

instance
Type: TInstance
method
Type: String
argTypes
Type: array<Type>[]()[]
args
Type: array<Object>[]()[]

Type Parameters

TInstance
TResult

See Also

ReflectionUtils Class
CallMethod Overload
RedGate.Shared.Utils.Reflection Namespace


CallMethod(TInstance, TArg1, TArg2, TArg3) Generic Method (TInstance, , TArg1, TArg2, TArg3)

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.CallMethod<(Of <(TInstance, TArg1, TArg2, TArg3>)>) Generic Method (TInstance, , TArg1, TArg2, TArg3)
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub CallMethod(Of TInstance, TArg1, TArg2, TArg3) ( _
    instance As TInstance, _
    method As String, _
    arg1 As TArg1, _
    arg2 As TArg2, _
    arg3 As TArg3 _
)
C#
public static void CallMethod<TInstance, TArg1, TArg2, TArg3>(
    TInstance instance,
    string method,
    TArg1 arg1,
    TArg2 arg2,
    TArg3 arg3
)
Visual C++
public:
generic<typename TInstance, typename TArg1, typename TArg2, typename TArg3>
static void CallMethod(
    TInstance instance,
    String^ method,
    TArg1 arg1,
    TArg2 arg2,
    TArg3 arg3
)

Parameters

instance
Type: TInstance
method
Type: String
arg1
Type: TArg1
arg2
Type: TArg2
arg3
Type: TArg3

Type Parameters

TInstance
TArg1
TArg2
TArg3

See Also

ReflectionUtils Class
CallMethod Overload
RedGate.Shared.Utils.Reflection Namespace


CallStaticMethod Method

[image] [image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.CallStaticMethod Method
ReflectionUtils Class See Also

Overload List

Name | Description
CallStaticMethod<(Of <(TResult>)>)(Type, String) |
CallStaticMethod<(Of <(TArg, TResult>)>)(Type, String, TArg) |

See Also

ReflectionUtils Class
ReflectionUtils Members
RedGate.Shared.Utils.Reflection Namespace


CallStaticMethod(TResult) Generic Method (, )

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.CallStaticMethod<(Of <(TResult>)>) Generic Method (, )
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CallStaticMethod(Of TResult) ( _
    type As Type, _
    method As String _
) As TResult
C#
public static TResult CallStaticMethod<TResult>(
    Type type,
    string method
)
Visual C++
public:
generic<typename TResult>
static TResult CallStaticMethod(
    Type^ type,
    String^ method
)

Parameters

type
Type: Type
method
Type: String

Type Parameters

TResult

See Also

ReflectionUtils Class
CallStaticMethod Overload
RedGate.Shared.Utils.Reflection Namespace


CallStaticMethod(TArg, TResult) Generic Method (, , TArg)

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.CallStaticMethod<(Of <(TArg, TResult>)>) Generic Method (, , TArg)
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CallStaticMethod(Of TArg, TResult) ( _
    type As Type, _
    method As String, _
    arg As TArg _
) As TResult
C#
public static TResult CallStaticMethod<TArg, TResult>(
    Type type,
    string method,
    TArg arg
)
Visual C++
public:
generic<typename TArg, typename TResult>
static TResult CallStaticMethod(
    Type^ type,
    String^ method,
    TArg arg
)

Parameters

type
Type: Type
method
Type: String
arg
Type: TArg

Type Parameters

TArg
TResult

See Also

ReflectionUtils Class
CallStaticMethod Overload
RedGate.Shared.Utils.Reflection Namespace


ConvertPublicKeyTokenToString Method

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.ConvertPublicKeyTokenToString Method
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ConvertPublicKeyTokenToString ( _
    publicKeyToken As Byte() _
) As String
C#
public static string ConvertPublicKeyTokenToString(
    byte[] publicKeyToken
)
Visual C++
public:
static String^ ConvertPublicKeyTokenToString(
    array<unsigned char>^ publicKeyToken
)

Parameters

publicKeyToken
Type: array<Byte>[]()[]

See Also

ReflectionUtils Class
RedGate.Shared.Utils.Reflection Namespace


Create Method

[image] [image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.Create Method
ReflectionUtils Class See Also

Overload List

Name | Description
Create<(Of <(TInstance>)>)(Type) |
Create<(Of <(TArg, TInstance>)>)(Type, TArg) |
Create(Type, array<Object>[]()[], array<Type>[]()[]) |
Create(Type, Type, Object) |
Create<(Of <(TArg1, TArg2, TInstance>)>)(Type, TArg1, TArg2) |

See Also

ReflectionUtils Class
ReflectionUtils Members
RedGate.Shared.Utils.Reflection Namespace


Create(TInstance) Generic Method ()

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.Create<(Of <(TInstance>)>) Generic Method ()
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Create(Of TInstance) ( _
    type As Type _
) As TInstance
C#
public static TInstance Create<TInstance>(
    Type type
)
Visual C++
public:
generic<typename TInstance>
static TInstance Create(
    Type^ type
)

Parameters

type
Type: Type

Type Parameters

TInstance

See Also

ReflectionUtils Class
Create Overload
RedGate.Shared.Utils.Reflection Namespace


Create(TArg, TInstance) Generic Method (, TArg)

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.Create<(Of <(TArg, TInstance>)>) Generic Method (, TArg)
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Create(Of TArg, TInstance) ( _
    type As Type, _
    arg As TArg _
) As TInstance
C#
public static TInstance Create<TArg, TInstance>(
    Type type,
    TArg arg
)
Visual C++
public:
generic<typename TArg, typename TInstance>
static TInstance Create(
    Type^ type,
    TArg arg
)

Parameters

type
Type: Type
arg
Type: TArg

Type Parameters

TArg
TInstance

See Also

ReflectionUtils Class
Create Overload
RedGate.Shared.Utils.Reflection Namespace


Create Method (, [], [])

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.Create Method (, array<>[]()[], array<>[]()[])
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Create ( _
    type As Type, _
    args As Object(), _
    argTypes As Type() _
) As Object
C#
public static Object Create(
    Type type,
    Object[] args,
    Type[] argTypes
)
Visual C++
public:
static Object^ Create(
    Type^ type,
    array<Object^>^ args,
    array<Type^>^ argTypes
)

Parameters

type
Type: Type
args
Type: array<Object>[]()[]
argTypes
Type: array<Type>[]()[]

See Also

ReflectionUtils Class
Create Overload
RedGate.Shared.Utils.Reflection Namespace


Create Method (, , )

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.Create Method (, , )
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Create ( _
    type As Type, _
    argType As Type, _
    arg As Object _
) As Object
C#
public static Object Create(
    Type type,
    Type argType,
    Object arg
)
Visual C++
public:
static Object^ Create(
    Type^ type,
    Type^ argType,
    Object^ arg
)

Parameters

type
Type: Type
argType
Type: Type
arg
Type: Object

See Also

ReflectionUtils Class
Create Overload
RedGate.Shared.Utils.Reflection Namespace


Create(TArg1, TArg2, TInstance) Generic Method (, TArg1, TArg2)

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.Create<(Of <(TArg1, TArg2, TInstance>)>) Generic Method (, TArg1, TArg2)
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Create(Of TArg1, TArg2, TInstance) ( _
    type As Type, _
    arg1 As TArg1, _
    arg2 As TArg2 _
) As TInstance
C#
public static TInstance Create<TArg1, TArg2, TInstance>(
    Type type,
    TArg1 arg1,
    TArg2 arg2
)
Visual C++
public:
generic<typename TArg1, typename TArg2, typename TInstance>
static TInstance Create(
    Type^ type,
    TArg1 arg1,
    TArg2 arg2
)

Parameters

type
Type: Type
arg1
Type: TArg1
arg2
Type: TArg2

Type Parameters

TArg1
TArg2
TInstance

See Also

ReflectionUtils Class
Create Overload
RedGate.Shared.Utils.Reflection Namespace


GetAttribute(T) Generic Method

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.GetAttribute<(Of <(T>)>) Generic Method
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetAttribute(Of T) As T
C#
public static T GetAttribute<T>()
Visual C++
public:
generic<typename T>
static T GetAttribute()

Type Parameters

T

See Also

ReflectionUtils Class
RedGate.Shared.Utils.Reflection Namespace


GetExecutingAssemblyDirectory Method

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.GetExecutingAssemblyDirectory Method
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetExecutingAssemblyDirectory As String
C#
public static string GetExecutingAssemblyDirectory()
Visual C++
public:
static String^ GetExecutingAssemblyDirectory()

See Also

ReflectionUtils Class
RedGate.Shared.Utils.Reflection Namespace


GetFieldValue(TInstance, TValue) Generic Method

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.GetFieldValue<(Of <(TInstance, TValue>)>) Generic Method
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFieldValue(Of TInstance, TValue) ( _
    instance As TInstance, _
    field As String _
) As TValue
C#
public static TValue GetFieldValue<TInstance, TValue>(
    TInstance instance,
    string field
)
Visual C++
public:
generic<typename TInstance, typename TValue>
static TValue GetFieldValue(
    TInstance instance,
    String^ field
)

Parameters

instance
Type: TInstance
field
Type: String

Type Parameters

TInstance
TValue

See Also

ReflectionUtils Class
RedGate.Shared.Utils.Reflection Namespace


GetPropertyValue(TInstance, TValue) Generic Method

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.GetPropertyValue<(Of <(TInstance, TValue>)>) Generic Method
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetPropertyValue(Of TInstance, TValue) ( _
    instance As TInstance, _
    property As String _
) As TValue
C#
public static TValue GetPropertyValue<TInstance, TValue>(
    TInstance instance,
    string property
)
Visual C++
public:
generic<typename TInstance, typename TValue>
static TValue GetPropertyValue(
    TInstance instance,
    String^ property
)

Parameters

instance
Type: TInstance
property
Type: String

Type Parameters

TInstance
TValue

See Also

ReflectionUtils Class
RedGate.Shared.Utils.Reflection Namespace


GetStaticFieldValue(TValue) Generic Method

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.GetStaticFieldValue<(Of <(TValue>)>) Generic Method
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetStaticFieldValue(Of TValue) ( _
    type As Type, _
    field As String _
) As TValue
C#
public static TValue GetStaticFieldValue<TValue>(
    Type type,
    string field
)
Visual C++
public:
generic<typename TValue>
static TValue GetStaticFieldValue(
    Type^ type,
    String^ field
)

Parameters

type
Type: Type
field
Type: String

Type Parameters

TValue

See Also

ReflectionUtils Class
RedGate.Shared.Utils.Reflection Namespace


GetStaticPropertyValue(TValue) Generic Method

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.GetStaticPropertyValue<(Of <(TValue>)>) Generic Method
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetStaticPropertyValue(Of TValue) ( _
    type As Type, _
    property As String _
) As TValue
C#
public static TValue GetStaticPropertyValue<TValue>(
    Type type,
    string property
)
Visual C++
public:
generic<typename TValue>
static TValue GetStaticPropertyValue(
    Type^ type,
    String^ property
)

Parameters

type
Type: Type
property
Type: String

Type Parameters

TValue

See Also

ReflectionUtils Class
RedGate.Shared.Utils.Reflection Namespace


GetType Method

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.GetType Method
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetType ( _
    assemblyName As String, _
    typeName As String _
) As Type
C#
public static Type GetType(
    string assemblyName,
    string typeName
)
Visual C++
public:
static Type^ GetType(
    String^ assemblyName,
    String^ typeName
)

Parameters

assemblyName
Type: String
NOTE: If this doesn't specify a version then any of the assemblies in the app domain may be used
typeName
Type: String

See Also

ReflectionUtils Class
RedGate.Shared.Utils.Reflection Namespace


HasProperty(TInstace) Generic Method

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.HasProperty<(Of <(TInstace>)>) Generic Method
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function HasProperty(Of TInstace) ( _
    property As String _
) As Boolean
C#
public static bool HasProperty<TInstace>(
    string property
)
Visual C++
public:
generic<typename TInstace>
static bool HasProperty(
    String^ property
)

Parameters

property
Type: String

Type Parameters

TInstace

See Also

ReflectionUtils Class
RedGate.Shared.Utils.Reflection Namespace


ListenFirstForEvent(TInstance) Generic Method

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.ListenFirstForEvent<(Of <(TInstance>)>) Generic Method
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ListenFirstForEvent(Of TInstance) ( _
    instance As TInstance, _
    backingField As String, _
    value As Delegate _
)
C#
public static void ListenFirstForEvent<TInstance>(
    TInstance instance,
    string backingField,
    Delegate value
)
Visual C++
public:
generic<typename TInstance>
static void ListenFirstForEvent(
    TInstance instance,
    String^ backingField,
    Delegate^ value
)

Parameters

instance
Type: TInstance
backingField
Type: String
value
Type: Delegate

Type Parameters

TInstance

See Also

ReflectionUtils Class
RedGate.Shared.Utils.Reflection Namespace


ListenFirstForEventIfNotCurrentlySubscribed(TInstance) Generic Method

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.ListenFirstForEventIfNotCurrentlySubscribed<(Of <(TInstance>)>) Generic Method
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ListenFirstForEventIfNotCurrentlySubscribed(Of TInstance) ( _
    instance As TInstance, _
    backingField As String, _
    value As Delegate _
) As Boolean
C#
public static bool ListenFirstForEventIfNotCurrentlySubscribed<TInstance>(
    TInstance instance,
    string backingField,
    Delegate value
)
Visual C++
public:
generic<typename TInstance>
static bool ListenFirstForEventIfNotCurrentlySubscribed(
    TInstance instance,
    String^ backingField,
    Delegate^ value
)

Parameters

instance
Type: TInstance
backingField
Type: String
value
Type: Delegate

Type Parameters

TInstance

See Also

ReflectionUtils Class
RedGate.Shared.Utils.Reflection Namespace


SetFieldValue(TInstance, TValue) Generic Method

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.SetFieldValue<(Of <(TInstance, TValue>)>) Generic Method
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub SetFieldValue(Of TInstance, TValue) ( _
    instance As TInstance, _
    field As String, _
    newValue As TValue _
)
C#
public static void SetFieldValue<TInstance, TValue>(
    TInstance instance,
    string field,
    TValue newValue
)
Visual C++
public:
generic<typename TInstance, typename TValue>
static void SetFieldValue(
    TInstance instance,
    String^ field,
    TValue newValue
)

Parameters

instance
Type: TInstance
field
Type: String
newValue
Type: TValue

Type Parameters

TInstance
TValue

See Also

ReflectionUtils Class
RedGate.Shared.Utils.Reflection Namespace


SetPropertyValue(TInstance, TValue) Generic Method

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.SetPropertyValue<(Of <(TInstance, TValue>)>) Generic Method
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub SetPropertyValue(Of TInstance, TValue) ( _
    instance As TInstance, _
    property As String, _
    newValue As TValue _
)
C#
public static void SetPropertyValue<TInstance, TValue>(
    TInstance instance,
    string property,
    TValue newValue
)
Visual C++
public:
generic<typename TInstance, typename TValue>
static void SetPropertyValue(
    TInstance instance,
    String^ property,
    TValue newValue
)

Parameters

instance
Type: TInstance
property
Type: String
newValue
Type: TValue

Type Parameters

TInstance
TValue

See Also

ReflectionUtils Class
RedGate.Shared.Utils.Reflection Namespace


TryGetAttribute(T) Generic Method

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.TryGetAttribute<(Of <(T>)>) Generic Method
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function TryGetAttribute(Of T As Attribute) ( _
    type As Type, _
    <OutAttribute> ByRef attribute As T _
) As Boolean
C#
public static bool TryGetAttribute<T>(
    Type type,
    out T attribute
) where T : Attribute
Visual C++
public:
generic<typename T>
where T : Attribute
static bool TryGetAttribute(
    Type^ type,
    [OutAttribute] T% attribute
)

Parameters

type
Type: Type
attribute
Type: T%

Type Parameters

T

See Also

ReflectionUtils Class
RedGate.Shared.Utils.Reflection Namespace


TryGetPropertyValue(TInstance, TValue) Generic Method

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.TryGetPropertyValue<(Of <(TInstance, TValue>)>) Generic Method
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function TryGetPropertyValue(Of TInstance, TValue) ( _
    instance As TInstance, _
    property As String, _
    <OutAttribute> ByRef value As TValue _
) As Boolean
C#
public static bool TryGetPropertyValue<TInstance, TValue>(
    TInstance instance,
    string property,
    out TValue value
)
Visual C++
public:
generic<typename TInstance, typename TValue>
static bool TryGetPropertyValue(
    TInstance instance,
    String^ property,
    [OutAttribute] TValue% value
)

Parameters

instance
Type: TInstance
property
Type: String
value
Type: TValue%

Type Parameters

TInstance
TValue

See Also

ReflectionUtils Class
RedGate.Shared.Utils.Reflection Namespace


TryLoadFromIfExists Method

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.TryLoadFromIfExists Method
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function TryLoadFromIfExists ( _
    dir As String, _
    requestedAssemblyName As AssemblyName, _
    <OutAttribute> ByRef assembly As Assembly _
) As Boolean
C#
public static bool TryLoadFromIfExists(
    string dir,
    AssemblyName requestedAssemblyName,
    out Assembly assembly
)
Visual C++
public:
static bool TryLoadFromIfExists(
    String^ dir,
    AssemblyName^ requestedAssemblyName,
    [OutAttribute] Assembly^% assembly
)

Parameters

dir
Type: String
requestedAssemblyName
Type: AssemblyName
assembly
Type: Assembly%

See Also

ReflectionUtils Class
RedGate.Shared.Utils.Reflection Namespace


UpdateFieldValue(TInstance, TValue) Generic Method

[image]

SQL Data Compare API 12.0.40
ReflectionUtils..::.UpdateFieldValue<(Of <(TInstance, TValue>)>) Generic Method
ReflectionUtils Class See Also

Namespace: RedGate.Shared.Utils.Reflection
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub UpdateFieldValue(Of TInstance, TValue) ( _
    instance As TInstance, _
    field As String, _
    updater As Func(Of TValue, TValue) _
)
C#
public static void UpdateFieldValue<TInstance, TValue>(
    TInstance instance,
    string field,
    Func<TValue, TValue> updater
)
Visual C++
public:
generic<typename TInstance, typename TValue>
static void UpdateFieldValue(
    TInstance instance,
    String^ field,
    Func<TValue, TValue>^ updater
)

Parameters

instance
Type: TInstance
field
Type: String
updater
Type: Func<(Of <(TValue, TValue>)>)

Type Parameters

TInstance
TValue

See Also

ReflectionUtils Class
RedGate.Shared.Utils.Reflection Namespace


RedGate.Shared.Utils.Sys Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.Shared.Utils.Sys Namespace

Classes

Class | Description
Time |


Time Class

[image]

SQL Data Compare API 12.0.40
Time Class
Members See Also

Namespace: RedGate.Shared.Utils.Sys
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Time
C#
public static class Time
Visual C++
public ref class Time abstract sealed

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Sys..::.Time

See Also

Time Members
RedGate.Shared.Utils.Sys Namespace


Time Members

[image] [image]

SQL Data Compare API 12.0.40
Time Members
Time Class Methods See Also

The Time type exposes the following members.

Methods

Name | Description
SinceLastShutdown |

See Also

Time Class
RedGate.Shared.Utils.Sys Namespace


Time Methods

[image] [image]

SQL Data Compare API 12.0.40
Time Methods
Time Class See Also

The Time type exposes the following methods.

Methods

Name | Description
SinceLastShutdown |

See Also

Time Class
RedGate.Shared.Utils.Sys Namespace


SinceLastShutdown Method

[image]

SQL Data Compare API 12.0.40
Time..::.SinceLastShutdown Method
Time Class See Also

Namespace: RedGate.Shared.Utils.Sys
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SinceLastShutdown As TimeSpan
C#
public static TimeSpan SinceLastShutdown()
Visual C++
public:
static TimeSpan SinceLastShutdown()

See Also

Time Class
RedGate.Shared.Utils.Sys Namespace


RedGate.SQLCompare.Engine Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine Namespace

Classes

Class | Description
AggregateExceptionExtensions |
AlterAuthorizationChangesCalculator |
AsymmetricKey | An asymmetric key.
AsymmetricKeys | A collection of asymmetric keys.
AsymmetricKeysChanges |
BackupOptions |
Canceler |
Certificate | A certificate.
Certificates | A collection of certificates.
CertificatesChanges |
ChangeTrackingsChanges |
CheckConstraint | A check constraint.
CheckConstraintChangesCalculator |
CheckConstraints | A collection of check constraints.
CheckConstraintsChanges |
ClrAssemblies | A collection of Common Language Runtime (CLR) assemblies.
ClrAssembliesChanges |
ClrAssembly | A Common Language Runtime (CLR) assembly.
CLRDowngradeWarningsCalculator |
ClrFile | A Common Language Runtime (CLR) file.
ClrFiles | A collection of CLR files.
ConnectionProperties | Serializable connection properties used to connect to a SQL Server database.
Contract | A contract.
Contracts | A collection of contracts.
ContractsChanges |
CycleDetectedException |
Database | This is a (vaguely temporary) class used to reduce the number of new items added to Database's interface. Use one of the interfaces this class implements where possible, since those will behave consistenly between the two classes.
DatabaseCreation | Methods for creating a live database with specific files and filegroups
DatabaseCreationInfo |
DatabaseExtensions |
DatabaseFile |
DatabaseLevelPermission | A database-level permission.
DatabaseLevelPermissions | A collection of database-level permissions.
DatabaseObjectCollection<(Of <(T>)>) | A collection of database objects that doesn't know how to serialize itself to a SQL Compare snapshot. Compare with RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection<(Of <(T>)>)
DatabaseObjectExistsException | Exception thrown when a matching IDatabaseObject already exists in a collection. It is a DuplicateObjectNameException that stores which IDatabaseObject was found to already exist.
DatabaseObjectWithAuthorization | A database object that can have its owner altered using ALTER AUTHORIZATION.
DatabaseObjectWithAuthorizationAndExtendedProperties |
DataCompareIndexDeploymentSql |
DataCompareUserActions |
DataRecordExtensions |
DatatypeMigrationWarningsCalculator |
DdlTrigger | A DDL trigger.
DdlTriggers | A collection of DDL triggers.
DdlTriggersChanges |
Default | A database default.
Defaults | A collection of defaults.
DefaultsChanges | TODO: I'm not sure if this grouping is sensible; currently it's just everything needed by DefaultChangesCalculator Need to do a proper investigation on what CompareEngine thinks the difference between defaults and DRI defaults is
DependenciesBuilder | The core object dependencies within a database.
DependenciesCollector |
DependenciesHelper |
DependenciesResultCalculator | Various methods for calculating dependencies between different objects. It appears that these results are never used internally; instead they are intended for CompareUI/SOC/etc to look at
DeploymentResult |
Difference | A difference between two database objects.
Differences | A collection of difference objects representing the differences between two databases.
DmlTriggersChanges |
DmvModelFactory |
DRIDefaultsChanges | TODO: I'm not sure if this grouping is sensible. Currently it's defaults-related things that isn't in DefaultsChanges
DuplicateObjectNameException | Exception thrown when the engine finds that an object definition already exists for a given name and it is not expected to. In many cases this is caused by case-sensitivity problems, so this exception has specific support for flagging that error case (IsCaseInsensitiveCollision). This class also provides static ThrowIf... methods to perform the normal collision checks used by the engine, detect case-insensitivity problems, and throw the correct DuplicateObjectNameException when collisions occur.
EngineDataCompareOptions | Class containing the three options enumerations for the three stages in data comparison.
EqualityDifference |
EqualityDifference..::.Context |
EqualityDifferenceFactory |
EventNotification | An event notification.
EventNotifications | A collection of event notifications.
EventNotificationsChanges |
EventTypes | A collection of EventTypes.
ExtendedProperties | The extended properties associated with a database object.
ExtendedPropertiesChanges |
ExtendedProperty | An extended property.
ExtendedPropertyValue |
Field | A SQL Server field.
FieldBinding |
FieldBindings |
FieldMappingBestMatchMessage | A message.
Fields | A collection of fields.
FileGroups | A collection of filegroups.
FileTable | Filetables are a new feature in 2012 that provide a filestream view of a folder/file hierarchy.
FlatFieldList |
ForeignKey | A foreign key.
ForeignKeyChangesCalculator |
ForeignKeys | A collection of foreign keys.
ForeignKeysChanges |
FullTextCatalog | A full text catalog.
FullTextCatalogs | A collection of full text catalogs.
FulltextChanges | TODO: is there a sensible subdivision of this class? Alternatively, we might want to put fulltext changes queues alongside their normal versions (eg fulltext views/tables to drop goes alongside views (or tables?) and fulltext columns to drop goes alongside fields to drop
FullTextChangesCalculator |
FullTextStoplist | A full text stoplist.
FullTextStoplistChangesCalculator |
FullTextStoplists | A collection of full text stoplists.
FullTextStopwords | A collection of stopwords associated with a full text stoplist.
Function | A user-defined function.
Functions | A collection of functions.
FunctionsChanges |
IDatabaseObjectExtensionMethods |
Index | An index.
Indexes | A collection of indexes.
IndexesChangeCalculator |
IndexesChanges |
IndexFields |
IndexWarningsCalculator |
InMemoryDependencyMemoizer |
KeyedCollection<(Of <(T>)>) | A collection that can store items by key as well as by list index.
LazyWithOverride<(Of <(T>)>) |
LiveDatabaseSource | A standard SQL Server database.
LockEscalationTypeExtensions |
Mapping<(Of <(T>)>) | Abstract class used to contain a mapping between two database objects.
MappingContext |
MappingException | Exception thrown when an error is encountered whilst mapping.
Mappings<(Of <(TMapping, TMap, TContext>)>) | Abstract class for creating a set of mappings from a list of database objects.
Members | A collection of role members. These can be users or roles.
Message | A message.
MessageBase |
Messages | A collection of messages.
MessageType | A message type.
MessageTypes | A collection of message types.
MessageTypesChanges |
MessageUsage | A message usage.
MessageUsages | A collection of message usages.
MigScriptPlugMessageDecorator |
NewDataTypesFormatting |
ObjectCollections |
ObjectNotInDatabaseException | An exception that is used when a database object that is not in the database is requested.
ObjectNotInDifferences | Exception that is used when a database object that is not in the differences collection is requested.
ObjectTypeHelper | Various useful methods for ObjectType
OptionDescriptionAttribute | Options used in comparison and synchronization.
OptionDescriptionDCAttribute | Options used when comparing and synchronizing databases.
OptionsExtensions |
Parameter | A SQL Server parameter.
Parameters | A collection of parameters.
PartitionFunction | A partition function.
PartitionFunctions | A collection of partition functions.
PartitionFunctionsChanges |
PartitionScheme | A partition scheme.
PartitionSchemes | A collection of partition schemes.
PartitionSchemesChanges |
Permission | A permission.
Permissions | A collection of permissions.
PermissionsChanges |
PermissionsCollection |
PlannedChangesExtensions |
ProgressTracker |
Project | A SQL Compare project.
ProjectBackupOptions |
Queue | A queue.
Queues | A collection of queues.
QueuesChanges |
ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) |
Region | A region of text.
Regions | A collection of regions.
RelationalIndex | A relational index.
Role | A role.
Roles | A collection of roles.
RolesChanges |
Route | A route.
Routes | A collection of routes.
RoutesChanges |
Rule | A rule.
Rules | A collection of rules.
RulesChanges |
SC_DeploymentOptions |
Schema | A schema.
SchemaBinding |
SchemaBindings |
SchemaBindingsToUnbindCalculator |
SchemaObject | A schema object.
SchemaObjectAuthorizationsChanges |
SchemaObjectWithAuthorization | Represents a schema object that can also have an ALTER AUTHORIZATION applied to it to change the user as well (so it can have both user & schema).
Schemas | A collection of schemas.
SchemasChanges |
ScriptableDatabaseObject | Represents a scriptable database object. Also has default implementations of some of the IDatabaseObject methods & properties
ScriptGenerationResult |
ScriptRegistrationInformation | Holds the information needed in order to perform a registration of a scripts folder.
ScriptSource | Information about the source of a database object. This information includes details of the creation script file, as well as the starting and ending character position for the creation statement.
SearchProperty |
SearchPropertyList | A list of search properties we can attach to a fulltext index which lets the index search those properties on a document as well as the document text
SearchPropertyLists |
SearchPropertyListsChanges |
SelectedSyncObjects..::.ComparableByteArray |
SelectedSyncObjects..::.HitValue |
Sequence |
Sequences |
SequencesChanges |
SerializableBlobStore |
SerializableCollection<(Of <(T>)>) | A collection that can be serialized to disk.
SerializableCollectionString |
SerializableDatabaseObjectCollection<(Of <(T>)>) | A collection of database objects that can be serialized to disk.
Service | A service.
ServiceBinding | A service binding.
ServiceBindings | A collection of service bindings.
ServiceBindingsChanges |
Services | A collection of services.
ServicesChanges |
SnapshotSource | A SQL Server database encapsulated within a snapshot.
SourceControlDataSource | A link to a SQL Source Control database
SourceControlInfo |
SpatialIndex |
SqlCompareArgumentException | This exception is used as the general exception for SQL Compare.
SqlCompareException | This exception is used as the general exception for SQL Compare.
SqlCompareFieldMapping | Contains a mapping from a field in one table to a field in another table.
SqlCompareFieldMappings | Holds mappings for fields in a table or view.
SqlCompareOwnerMapping | Obsolete. Contains a mapping between the schema or owners in the different databases.
SqlCompareOwnerMappings | Holds mappings for the schema or owners between the two databases. Uses the database objects to create the mappings for the views and the tables from the two databases.
SqlCompareTableMapping | Contains a mapping from a view or table to another view or table. Also contains information on the criteria used for matching the two tables, which can be based on an index or an arbitrary set of mapped fields.
SqlCompareTableMappingExtensions |
SqlCompareTableMappings |
SqlExceptionWithSql | Wrap a SqlException with the sql that failed
SqlGenerationQueueBuilder | Calculates the database object changes required based on the selected Differences
SqlGenerationQueues |
SqlGenerationResult |
SqlScriptAdjuster |
SqlSetOptions | SQL set options.
Statistics | This implements ISystemNameable indirectly, but only in 2000 is it even possibly system nameable
StoplistsChanges |
StoredProcedure | A stored procedure.
StoredProcedures | A collection of stored procedures.
StoredProceduresChanges |
SymmetricKey | A symmetric key.
SymmetricKeys | A collection of symmetric keys.
SymmetricKeysChanges |
Synonym | A synonym.
Synonyms | A collection of synonyms.
SynonymsChanges |
Table | A table.
TableChange |
TableChangeTrackingChangesCalculator |
TableFields | A collection of Fields belonging to several different tables
Tables | A collection of tables.
TablesChanges |
Trigger | A trigger.
TriggerChangesCalculator |
Triggers | A collection of triggers.
TypeRebuilderCollector |
TypesChanges |
UDTBinding |
UDTBindings |
UnsupportedDataWarehouseException | Exception for when trying to register an Azure Data Warehouse (and possibly PDW) database
UnsupportedSqlServerVersionException | Exception for when trying to register a database for a SQL Server version that is too old (currently 2000 and earlier)
User | A user.
UserActionUtilities | Various utilities for use with user actions
UserDefinedType | A user-defined type.
UserDefinedTypes | A collection of user-defined types.
Users | A collection of users.
UsersChanges |
Utils | A class providing utility functions.
Utils..::.ResultWithDuration<(Of <(T>)>) | Helper class for returning both the result of an operation and the time the operation took
View | A view.
Views | A collection of views.
ViewsAndTables | A collection of Views and Tables.
ViewsChanges |
ViewTableFulltextChangesCalculator |
ViewTableSuperClass | A view or table superclass.
WarningURLs | A strongly-typed resource class, for looking up localized strings, etc.
Work | Used to calculate the work to be done to synchronize databases.
WorkFields |
XmlSchemaCollection | An XML schema collection.
XmlSchemaCollections | A collection of XML schema collections.
XmlSchemaCollectionsChanges |

Structures

Structure | Description
ColumnPairReference | A reference to a column pair
ColumnReference | A reference to a column
KeyReference | A reference to a Key
Options | Options used when comparing and synchronizing databases.
SelectTableEvent | Struct representing a user action
TablePairReference | A reference to a table pair
UserActionWarning | Contains details of a user action that has failed due to schema changes since the project was created.
WhereClauseReference | A reference to a where clause

Interfaces

Interface | Description
IBinaryObject |
ICancellationStatus |
ICanExistenceCheck |
ICompareDifference |
IDatabase | A SQL Server database object model. The object model may represent a scripts folder, snapshot, or a live database.
IDatabaseObject | An interface implemented by database objects.
IDifferences |
IDmvModel |
IDmvModelFactory |
IEncryptedTextObject | A text object that can be encrypted and have other options applied to the textual definition.
IEncryptedTextReader |
IExecuteAs | Used by database objects that can be executed as a specific user. This is used only for SQL Server 2005 and 2008.
IField |
IHasAuthorization | Marks objects that have an owner instead of a schema. Note that some objects can have both an owner and a schema; in this instance, SchemaObjectWithAuthorization is used instead.
IHasPermissions | The database object may have permissions associated with it.
IIsSystemObject | Indicates that an object instance is a system object when implemented by a class.
IMemoizeDependencies |
IMetadata | An interface for storing arbitrary extra data on an object
INonReadOnlyCollection |
IOwner | An interface representing an object that can 'own' other objects.
IPatchUpAfterDeserialization |
IReadOnlyKeyedDatabaseObjectCollectionWrapper |
IResultSet |
ISessionSetObject |
IShouldWriteStorageSettings |
ISometimesInlinable |
ITextObject | A database object that has its definition stored in the database as text.
IVersionedDatabase |
IWork |
IWorkStage |

Delegates

Delegate | Description
PrepareStringDelegate<(Of <(TMap, TContext>)>) | Creates the name used for comparing two objects when creating mappings.

Enumerations

Enumeration | Description
AsymmetricKey..::.AsymmetricKeyEncryptionAlgorithm | The asymmetric key encryption algorithm.
AsymmetricKey..::.AsymmetricKeyKeyEncryption | How the private key of the asymmetric key is encrypted.
BackupProvider |
Certificate..::.CertificateKeyEncryption | How the private key of the certificate is encrypted.
ComparisonOptions | Options used when comparing databases.
DatabaseFile..::.FileTypeOption |
DatabaseLevelPermissionAction | The database-level permission.
DatabaseSource |
DataCompareGroupingStyle | An enumeration of the possible grouping styles supported by the main grid.
DataCompression | Compression used for a table or index record. This has been introduced in SQL Server 2008.
DBPopulationOptions | Options used when populating databases.
DurabilityTypes |
EventType | The type of event.
ExecuteAs | The EXECUTE AS clause used to create the object.
FullTextChangeTracking | The type of change tracking applied to the full text index on a view or table.
FullTextStoplistType | The stoplist used by the full text index on a view or table.
FunctionType | The type of function.
GridDensity | The grid density for the levels of the spatial index.
LockEscalationType | See MSDN docs on the LOCK_ESCALATION keyword: http://technet.microsoft.com/en-us/library/ms184286(v=sql.105).aspx Gotchas:- Text used to generate SQL The actual values are also the values stored by SQL Server
MappingOptions | Options used when generating the mapping between two databases.
MessageTypeValidation | The validation type for a message type.
Option | This enum is used to store the names of options and assign each of them a unique value
PermissionLevel | The action that a permission allows.
PermissionSet | The code access permissions for CLR assemblies.
PermissionStatementType | The type of permission.
Project..::.ProjectChangesEffect |
Project..::.UberProjectDeserializationMode |
ReferentialAction | Referential actions for foreign keys.
RemoteDataArchiveState | The Stretch Database state of a table
SecurableType | The class on which the permission exists.
SelectTableEventAction | An enum stating which action the user made
SessionSettings | Settings for comparing objects.
SpatialIndexInformation..::.GridDensities | Obsolete. The grid densities of spatial indexes
SpatialIndexInformation..::.SpatialIndexTypes | Obsolete. The type of the spatial index. In SQL Server 2008 this can be either geometry or geography.
SpatialIndexInformation..::.TesselationSchemes | Obsolete. Used to specify the tesselation scheme for the spatial index.
SpatialIndexType | The type of the spatial index. In SQL Server 2008 this can be either geometry or geography.
SqbEncryptionLevel | SQB encryption level enumeration
SqlBackupLicenseType |
SqlCompareFieldMappingStatus | The result of the SqlCompareFieldMapping.
SqlCompareTableMappingStatus | The result of the mapping.
SqlOptions | Options used when synchronizing databases.
SqlSetOption |
SqlType | A SQL Server data type.
SymmetricKey..::.SymmetricKeyEncryptionAlgorithm | The symmetric key encryption algorithm.
SynchronizationDirection | The direction of migration for synchronization.
Synonym..::.ReferenceLocation |
Table..::.TableChangeTracking | Table change tracking option set. This has been introduced in SQL Server 2008.
TesselationScheme | The tesselation scheme for the spatial index.
TypeOfBackup |
UserType | The type of user.


AggregateExceptionExtensions Class

[image]

SQL Data Compare API 12.0.40
AggregateExceptionExtensions Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AggregateExceptionExtensions
C#
public static class AggregateExceptionExtensions
Visual C++
public ref class AggregateExceptionExtensions abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.AggregateExceptionExtensions

See Also

AggregateExceptionExtensions Members
RedGate.SQLCompare.Engine Namespace


AggregateExceptionExtensions Members

[image] [image]

SQL Data Compare API 12.0.40
AggregateExceptionExtensions Members
AggregateExceptionExtensions Class Methods See Also

The AggregateExceptionExtensions type exposes the following members.

Methods

Name | Description
GetSingleImportantException |

See Also

AggregateExceptionExtensions Class
RedGate.SQLCompare.Engine Namespace


AggregateExceptionExtensions Methods

[image] [image]

SQL Data Compare API 12.0.40
AggregateExceptionExtensions Methods
AggregateExceptionExtensions Class See Also

The AggregateExceptionExtensions type exposes the following methods.

Methods

Name | Description
GetSingleImportantException |

See Also

AggregateExceptionExtensions Class
RedGate.SQLCompare.Engine Namespace


GetSingleImportantException Method

[image]

SQL Data Compare API 12.0.40
AggregateExceptionExtensions..::.GetSingleImportantException Method
AggregateExceptionExtensions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSingleImportantException ( _
    aggregateException As AggregateException _
) As Exception
C#
public static Exception GetSingleImportantException(
    AggregateException aggregateException
)
Visual C++
public:
static Exception^ GetSingleImportantException(
    AggregateException^ aggregateException
)

Parameters

aggregateException
Type: AggregateException

See Also

AggregateExceptionExtensions Class
RedGate.SQLCompare.Engine Namespace


AlterAuthorizationChangesCalculator Class

[image]

SQL Data Compare API 12.0.40
AlterAuthorizationChangesCalculator Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class AlterAuthorizationChangesCalculator
C#
public class AlterAuthorizationChangesCalculator
Visual C++
public ref class AlterAuthorizationChangesCalculator

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.AlterAuthorizationChangesCalculator

See Also

AlterAuthorizationChangesCalculator Members
RedGate.SQLCompare.Engine Namespace


AlterAuthorizationChangesCalculator Members

[image] [image]

SQL Data Compare API 12.0.40
AlterAuthorizationChangesCalculator Members
AlterAuthorizationChangesCalculator Class Constructors Methods See Also

The AlterAuthorizationChangesCalculator type exposes the following members.

Constructors

Name | Description
AlterAuthorizationChangesCalculator |

Methods

Name | Description
CompareAlterAuthorization |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AlterAuthorizationChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


AlterAuthorizationChangesCalculator Constructor

[image]

SQL Data Compare API 12.0.40
AlterAuthorizationChangesCalculator Constructor
AlterAuthorizationChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    schemaObjectAuthorizationsChanges As SchemaObjectAuthorizationsChanges _
)
C#
public AlterAuthorizationChangesCalculator(
    SchemaObjectAuthorizationsChanges schemaObjectAuthorizationsChanges
)
Visual C++
public:
AlterAuthorizationChangesCalculator(
    SchemaObjectAuthorizationsChanges^ schemaObjectAuthorizationsChanges
)

Parameters

schemaObjectAuthorizationsChanges
Type: RedGate.SQLCompare.Engine..::.SchemaObjectAuthorizationsChanges

See Also

AlterAuthorizationChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


AlterAuthorizationChangesCalculator Methods

[image] [image]

SQL Data Compare API 12.0.40
AlterAuthorizationChangesCalculator Methods
AlterAuthorizationChangesCalculator Class See Also

The AlterAuthorizationChangesCalculator type exposes the following methods.

Methods

Name | Description
CompareAlterAuthorization |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AlterAuthorizationChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


CompareAlterAuthorization Method

[image]

SQL Data Compare API 12.0.40
AlterAuthorizationChangesCalculator..::.CompareAlterAuthorization Method
AlterAuthorizationChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CompareAlterAuthorization ( _
    obj As SchemaObjectWithAuthorization, _
    targetObj As SchemaObjectWithAuthorization, _
    options As Options _
)
C#
public void CompareAlterAuthorization(
    SchemaObjectWithAuthorization obj,
    SchemaObjectWithAuthorization targetObj,
    Options options
)
Visual C++
public:
void CompareAlterAuthorization(
    SchemaObjectWithAuthorization^ obj,
    SchemaObjectWithAuthorization^ targetObj,
    Options options
)

Parameters

obj
Type: RedGate.SQLCompare.Engine..::.SchemaObjectWithAuthorization
targetObj
Type: RedGate.SQLCompare.Engine..::.SchemaObjectWithAuthorization
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

AlterAuthorizationChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


AsymmetricKey Class

[image]

SQL Data Compare API 12.0.40
AsymmetricKey Class
Members See Also

An asymmetric key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AsymmetricKey _
    Inherits DatabaseObjectWithAuthorization _
    Implements IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck,  _
    IPatchUpAfterDeserialization, ISqlComparable
C#
public sealed class AsymmetricKey : DatabaseObjectWithAuthorization, IHasPermissions,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, IPatchUpAfterDeserialization, ISqlComparable
Visual C++
public ref class AsymmetricKey sealed : public DatabaseObjectWithAuthorization,
    IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck, IPatchUpAfterDeserialization,
    ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.AsymmetricKey

See Also

AsymmetricKey Members
RedGate.SQLCompare.Engine Namespace


AsymmetricKey Members

[image] [image]

SQL Data Compare API 12.0.40
AsymmetricKey Members
AsymmetricKey Class Methods Fields Properties Explicit Interface Implementations See Also

The AsymmetricKey type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AlterAuthorizationClassType | (Overrides DatabaseObjectWithAuthorization ..::. AlterAuthorizationClassType.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
KeyAlgorithm | The key algorithm.
KeyLength | The length of the asymmetric key.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.AsymmetricKey (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions |
PrivateKeyEncryption | The encryption type of the asymmetric key's private key.
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)
ThumbPrint | The thumb print for the asymmetric key.

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

AsymmetricKey Class
RedGate.SQLCompare.Engine Namespace


AsymmetricKey Methods

[image] [image]

SQL Data Compare API 12.0.40
AsymmetricKey Methods
AsymmetricKey Class See Also

The AsymmetricKey type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

AsymmetricKey Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
AsymmetricKey..::.ISqlComparable..::.CompareWith Method
AsymmetricKey Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    target As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable target,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ target,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

target
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

AsymmetricKey Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
AsymmetricKey..::.Equals Method
AsymmetricKey Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the asymmetric key with a specified asymmetric key. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

AsymmetricKey Class
AsymmetricKey Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
AsymmetricKey..::.Equals Method (IDatabaseObject, Options)
AsymmetricKey Class See Also

Compares the asymmetric key with a specified asymmetric key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The asymmetric key to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the asymmetric keys are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

AsymmetricKey Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
AsymmetricKey..::.PatchUpAfterDeserialization Method
AsymmetricKey Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

AsymmetricKey Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
AsymmetricKey..::.ScriptObject Method
AsymmetricKey Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options, for example quoted identifier on or off.
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

AsymmetricKey Class
RedGate.SQLCompare.Engine Namespace


AsymmetricKey Properties

[image] [image]

SQL Data Compare API 12.0.40
AsymmetricKey Properties
AsymmetricKey Class See Also

The AsymmetricKey type exposes the following properties.

Properties

Name | Description
AlterAuthorizationClassType | (Overrides DatabaseObjectWithAuthorization ..::. AlterAuthorizationClassType.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
KeyAlgorithm | The key algorithm.
KeyLength | The length of the asymmetric key.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.AsymmetricKey (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions |
PrivateKeyEncryption | The encryption type of the asymmetric key's private key.
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)
ThumbPrint | The thumb print for the asymmetric key.

See Also

AsymmetricKey Class
RedGate.SQLCompare.Engine Namespace


AlterAuthorizationClassType Property

[image]

SQL Data Compare API 12.0.40
AsymmetricKey..::.AlterAuthorizationClassType Property
AsymmetricKey Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property AlterAuthorizationClassType As String
C#
public override string AlterAuthorizationClassType { get; }
Visual C++
public:
virtual property String^ AlterAuthorizationClassType {
    String^ get () override;
}

Implements

IHasAuthorization..::.AlterAuthorizationClassType

See Also

AsymmetricKey Class
RedGate.SQLCompare.Engine Namespace


KeyAlgorithm Property

[image]

SQL Data Compare API 12.0.40
AsymmetricKey..::.KeyAlgorithm Property
AsymmetricKey Class See Also

The key algorithm.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property KeyAlgorithm As AsymmetricKey..::.AsymmetricKeyEncryptionAlgorithm
C#
public AsymmetricKey..::.AsymmetricKeyEncryptionAlgorithm KeyAlgorithm { get; internal set; }
Visual C++
public:
property AsymmetricKey..::.AsymmetricKeyEncryptionAlgorithm KeyAlgorithm {
    AsymmetricKey..::.AsymmetricKeyEncryptionAlgorithm get ();
    void set (AsymmetricKey..::.AsymmetricKeyEncryptionAlgorithm value);
}

See Also

AsymmetricKey Class
RedGate.SQLCompare.Engine Namespace


KeyLength Property

[image]

SQL Data Compare API 12.0.40
AsymmetricKey..::.KeyLength Property
AsymmetricKey Class See Also

The length of the asymmetric key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property KeyLength As Integer
C#
public int KeyLength { get; internal set; }
Visual C++
public:
property int KeyLength {
    int get ();
    void set (int value);
}

See Also

AsymmetricKey Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
AsymmetricKey..::.ObjectType Property
AsymmetricKey Class See Also

Returns ObjectType.AsymmetricKey

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()
ITSqlObjectObjectType()()()

See Also

AsymmetricKey Class
RedGate.SQLCompare.Engine Namespace


Permissions Property

[image]

SQL Data Compare API 12.0.40
AsymmetricKey..::.Permissions Property
AsymmetricKey Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Permissions As Permissions
C#
public Permissions Permissions { get; private set; }
Visual C++
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
    void set (Permissions^ value) sealed;
}

Implements

IHasPermissions..::.Permissions

See Also

AsymmetricKey Class
RedGate.SQLCompare.Engine Namespace


PrivateKeyEncryption Property

[image]

SQL Data Compare API 12.0.40
AsymmetricKey..::.PrivateKeyEncryption Property
AsymmetricKey Class See Also

The encryption type of the asymmetric key's private key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PrivateKeyEncryption As AsymmetricKey..::.AsymmetricKeyKeyEncryption
C#
public AsymmetricKey..::.AsymmetricKeyKeyEncryption PrivateKeyEncryption { get; internal set; }
Visual C++
public:
property AsymmetricKey..::.AsymmetricKeyKeyEncryption PrivateKeyEncryption {
    AsymmetricKey..::.AsymmetricKeyKeyEncryption get ();
    void set (AsymmetricKey..::.AsymmetricKeyKeyEncryption value);
}

See Also

AsymmetricKey Class
RedGate.SQLCompare.Engine Namespace


ThumbPrint Property

[image]

SQL Data Compare API 12.0.40
AsymmetricKey..::.ThumbPrint Property
AsymmetricKey Class See Also

The thumb print for the asymmetric key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ThumbPrint As Byte()
C#
public byte[] ThumbPrint { get; internal set; }
Visual C++
public:
property array<unsigned char>^ ThumbPrint {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

AsymmetricKey Class
RedGate.SQLCompare.Engine Namespace


AsymmetricKey.AsymmetricKeyEncryptionAlgorithm Enumeration

[image]

SQL Data Compare API 12.0.40
AsymmetricKey..::.AsymmetricKeyEncryptionAlgorithm Enumeration
AsymmetricKey Class See Also

The asymmetric key encryption algorithm.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration AsymmetricKeyEncryptionAlgorithm
C#
public enum AsymmetricKeyEncryptionAlgorithm
Visual C++
public enum class AsymmetricKeyEncryptionAlgorithm

Members

Member name | Description
RSA512 | 1R = RSA 512
RSA1024 | 2R = RSA 1024
RSA2048 | 3R = RSA 2048
Unknown | Unknown = probably NA / hardware crypto device - fix for SC-8138

See Also

RedGate.SQLCompare.Engine Namespace


AsymmetricKey.AsymmetricKeyKeyEncryption Enumeration

[image]

SQL Data Compare API 12.0.40
AsymmetricKey..::.AsymmetricKeyKeyEncryption Enumeration
AsymmetricKey Class See Also

How the private key of the asymmetric key is encrypted.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration AsymmetricKeyKeyEncryption
C#
public enum AsymmetricKeyKeyEncryption
Visual C++
public enum class AsymmetricKeyKeyEncryption

Members

Member name | Description
NotAvailable | NA = There is no private key for the asymmetric key.
MasterKey | MK = Private key is encrypted by the master key.
PrivateKey | PW = Private key is encrypted by a user-defined password.
ServiceKey | SK = Private key is encrypted by the service master key.
Unknown | Unknown = Private key is encrypted by something else, probably a hardware crypto device.

See Also

RedGate.SQLCompare.Engine Namespace


AsymmetricKeys Class

[image]

SQL Data Compare API 12.0.40
AsymmetricKeys Class
Members See Also

A collection of asymmetric keys.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AsymmetricKeys _
    Inherits SerializableDatabaseObjectCollection(Of AsymmetricKey) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class AsymmetricKeys : SerializableDatabaseObjectCollection<AsymmetricKey>, IPatchUpAfterDeserialization
Visual C++
public ref class AsymmetricKeys sealed : public SerializableDatabaseObjectCollection<AsymmetricKey^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( AsymmetricKey >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( AsymmetricKey >)>)
RedGate.SQLCompare.Engine..::.AsymmetricKeys

See Also

AsymmetricKeys Members
RedGate.SQLCompare.Engine Namespace


AsymmetricKeys Members

[image] [image]

SQL Data Compare API 12.0.40
AsymmetricKeys Members
AsymmetricKeys Class Methods Fields Properties Explicit Interface Implementations See Also

The AsymmetricKeys type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

AsymmetricKeys Class
RedGate.SQLCompare.Engine Namespace


AsymmetricKeys Methods

[image] [image]

SQL Data Compare API 12.0.40
AsymmetricKeys Methods
AsymmetricKeys Class See Also

The AsymmetricKeys type exposes the following methods.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

AsymmetricKeys Class
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
AsymmetricKeys..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
AsymmetricKeys Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

AsymmetricKeys Class
RedGate.SQLCompare.Engine Namespace


AsymmetricKeysChanges Class

[image]

SQL Data Compare API 12.0.40
AsymmetricKeysChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AsymmetricKeysChanges
C#
public sealed class AsymmetricKeysChanges
Visual C++
public ref class AsymmetricKeysChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.AsymmetricKeysChanges

See Also

AsymmetricKeysChanges Members
RedGate.SQLCompare.Engine Namespace


AsymmetricKeysChanges Members

[image] [image]

SQL Data Compare API 12.0.40
AsymmetricKeysChanges Members
AsymmetricKeysChanges Class Constructors Methods Properties See Also

The AsymmetricKeysChanges type exposes the following members.

Constructors

Name | Description
AsymmetricKeysChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AsymmetricKeysToAlter |
AsymmetricKeysToCreate |
AsymmetricKeysToDrop |
AsymmKeyTargets |

See Also

AsymmetricKeysChanges Class
RedGate.SQLCompare.Engine Namespace


AsymmetricKeysChanges Constructor

[image]

SQL Data Compare API 12.0.40
AsymmetricKeysChanges Constructor
AsymmetricKeysChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public AsymmetricKeysChanges(
    bool caseSensitive
)
Visual C++
public:
AsymmetricKeysChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

AsymmetricKeysChanges Class
RedGate.SQLCompare.Engine Namespace


AsymmetricKeysChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
AsymmetricKeysChanges Properties
AsymmetricKeysChanges Class See Also

The AsymmetricKeysChanges type exposes the following properties.

Properties

Name | Description
AsymmetricKeysToAlter |
AsymmetricKeysToCreate |
AsymmetricKeysToDrop |
AsymmKeyTargets |

See Also

AsymmetricKeysChanges Class
RedGate.SQLCompare.Engine Namespace


AsymmetricKeysToAlter Property

[image]

SQL Data Compare API 12.0.40
AsymmetricKeysChanges..::.AsymmetricKeysToAlter Property
AsymmetricKeysChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AsymmetricKeysToAlter As AsymmetricKeys
C#
public AsymmetricKeys AsymmetricKeysToAlter { get; private set; }
Visual C++
public:
property AsymmetricKeys^ AsymmetricKeysToAlter {
    AsymmetricKeys^ get ();
    void set (AsymmetricKeys^ value);
}

See Also

AsymmetricKeysChanges Class
RedGate.SQLCompare.Engine Namespace


AsymmetricKeysToCreate Property

[image]

SQL Data Compare API 12.0.40
AsymmetricKeysChanges..::.AsymmetricKeysToCreate Property
AsymmetricKeysChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AsymmetricKeysToCreate As AsymmetricKeys
C#
public AsymmetricKeys AsymmetricKeysToCreate { get; private set; }
Visual C++
public:
property AsymmetricKeys^ AsymmetricKeysToCreate {
    AsymmetricKeys^ get ();
    void set (AsymmetricKeys^ value);
}

See Also

AsymmetricKeysChanges Class
RedGate.SQLCompare.Engine Namespace


AsymmetricKeysToDrop Property

[image]

SQL Data Compare API 12.0.40
AsymmetricKeysChanges..::.AsymmetricKeysToDrop Property
AsymmetricKeysChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AsymmetricKeysToDrop As AsymmetricKeys
C#
public AsymmetricKeys AsymmetricKeysToDrop { get; private set; }
Visual C++
public:
property AsymmetricKeys^ AsymmetricKeysToDrop {
    AsymmetricKeys^ get ();
    void set (AsymmetricKeys^ value);
}

See Also

AsymmetricKeysChanges Class
RedGate.SQLCompare.Engine Namespace


AsymmKeyTargets Property

[image]

SQL Data Compare API 12.0.40
AsymmetricKeysChanges..::.AsymmKeyTargets Property
AsymmetricKeysChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AsymmKeyTargets As Dictionary(Of AsymmetricKey, AsymmetricKey)
C#
public Dictionary<AsymmetricKey, AsymmetricKey> AsymmKeyTargets { get; private set; }
Visual C++
public:
property Dictionary<AsymmetricKey^, AsymmetricKey^>^ AsymmKeyTargets {
    Dictionary<AsymmetricKey^, AsymmetricKey^>^ get ();
    void set (Dictionary<AsymmetricKey^, AsymmetricKey^>^ value);
}

See Also

AsymmetricKeysChanges Class
RedGate.SQLCompare.Engine Namespace


BackupOptions Class

[image]

SQL Data Compare API 12.0.40
BackupOptions Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class BackupOptions
C#
public sealed class BackupOptions
Visual C++
public ref class BackupOptions sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.BackupOptions

See Also

BackupOptions Members
RedGate.SQLCompare.Engine Namespace


BackupOptions Members

[image] [image]

SQL Data Compare API 12.0.40
BackupOptions Members
BackupOptions Class Constructors Methods Properties See Also

The BackupOptions type exposes the following members.

Constructors

Name | Description
BackupOptions |

Methods

Name | Description
Clone |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetDefaultOptions |
ToString | (Overrides Object..::.ToString()()().)
UpdateFromDataSource |

Properties

Name | Description
BackupEnabled |
CachedDefaultNativeFolder | The default location for Native backups
CachedDefaultSqbFolder | The default location for SQB backups
CachedSqbLicenseType | Gets the type of the SQL Backup license on the target server
CachedSqbVersion | Gets the installed version of SQL Backup on the target server. Returns zero if SQL Backup isn't installed.
CompressionLevel |
DatabaseName |
EncryptionLevel |
Filename |
Folder |
NameFileAutomatically |
OverwriteIfExists |
Password |
ProviderOfBackup |
ThreadCount |
TypeOfBackup |

See Also

BackupOptions Class
RedGate.SQLCompare.Engine Namespace


BackupOptions Constructor

[image]

SQL Data Compare API 12.0.40
BackupOptions Constructor
BackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BackupOptions()
Visual C++
public:
BackupOptions()

See Also

BackupOptions Class
RedGate.SQLCompare.Engine Namespace


BackupOptions Methods

[image] [image]

SQL Data Compare API 12.0.40
BackupOptions Methods
BackupOptions Class See Also

The BackupOptions type exposes the following methods.

Methods

Name | Description
Clone |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetDefaultOptions |
ToString | (Overrides Object..::.ToString()()().)
UpdateFromDataSource |

See Also

BackupOptions Class
RedGate.SQLCompare.Engine Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
BackupOptions..::.Clone Method
BackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone As BackupOptions
C#
public BackupOptions Clone()
Visual C++
public:
BackupOptions^ Clone()

See Also

BackupOptions Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
BackupOptions..::.Equals Method
BackupOptions Class See Also

Overload List

Name | Description
Equals(Object) | (Overrides Object..::.Equals(Object).)
Equals(BackupOptions) |

See Also

BackupOptions Class
BackupOptions Members
RedGate.SQLCompare.Engine Namespace


Equals Method ()

[image]

SQL Data Compare API 12.0.40
BackupOptions..::.Equals Method ()
BackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object

See Also

BackupOptions Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


Equals Method (BackupOptions)

[image]

SQL Data Compare API 12.0.40
BackupOptions..::.Equals Method (BackupOptions)
BackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    other As BackupOptions _
) As Boolean
C#
public bool Equals(
    BackupOptions other
)
Visual C++
public:
bool Equals(
    BackupOptions^ other
)

Parameters

other
Type: RedGate.SQLCompare.Engine..::.BackupOptions

See Also

BackupOptions Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
BackupOptions..::.GetHashCode Method
BackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

See Also

BackupOptions Class
RedGate.SQLCompare.Engine Namespace


SetDefaultOptions Method

[image]

SQL Data Compare API 12.0.40
BackupOptions..::.SetDefaultOptions Method
BackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetDefaultOptions
C#
public void SetDefaultOptions()
Visual C++
public:
void SetDefaultOptions()

See Also

BackupOptions Class
RedGate.SQLCompare.Engine Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
BackupOptions..::.ToString Method
BackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

See Also

BackupOptions Class
RedGate.SQLCompare.Engine Namespace


UpdateFromDataSource Method

[image]

SQL Data Compare API 12.0.40
BackupOptions..::.UpdateFromDataSource Method
BackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub UpdateFromDataSource ( _
    factory As IServerFactory, _
    dataSource As IDataSource _
)
C#
public void UpdateFromDataSource(
    IServerFactory factory,
    IDataSource dataSource
)
Visual C++
public:
void UpdateFromDataSource(
    IServerFactory^ factory,
    IDataSource^ dataSource
)

Parameters

factory
Type: RedGate.SQLCompare.Engine.Deployment..::.IServerFactory
dataSource
Type: RedGate.Shared.SQL..::.IDataSource

See Also

BackupOptions Class
RedGate.SQLCompare.Engine Namespace


BackupOptions Properties

[image] [image]

SQL Data Compare API 12.0.40
BackupOptions Properties
BackupOptions Class See Also

The BackupOptions type exposes the following properties.

Properties

Name | Description
BackupEnabled |
CachedDefaultNativeFolder | The default location for Native backups
CachedDefaultSqbFolder | The default location for SQB backups
CachedSqbLicenseType | Gets the type of the SQL Backup license on the target server
CachedSqbVersion | Gets the installed version of SQL Backup on the target server. Returns zero if SQL Backup isn't installed.
CompressionLevel |
DatabaseName |
EncryptionLevel |
Filename |
Folder |
NameFileAutomatically |
OverwriteIfExists |
Password |
ProviderOfBackup |
ThreadCount |
TypeOfBackup |

See Also

BackupOptions Class
RedGate.SQLCompare.Engine Namespace


BackupEnabled Property

[image]

SQL Data Compare API 12.0.40
BackupOptions..::.BackupEnabled Property
BackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BackupEnabled As Boolean
C#
public bool BackupEnabled { get; set; }
Visual C++
public:
property bool BackupEnabled {
    bool get ();
    void set (bool value);
}

See Also

BackupOptions Class
RedGate.SQLCompare.Engine Namespace


CachedDefaultNativeFolder Property

[image]

SQL Data Compare API 12.0.40
BackupOptions..::.CachedDefaultNativeFolder Property
BackupOptions Class See Also

The default location for Native backups

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CachedDefaultNativeFolder As String
C#
public string CachedDefaultNativeFolder { get; set; }
Visual C++
public:
property String^ CachedDefaultNativeFolder {
    String^ get ();
    void set (String^ value);
}

See Also

BackupOptions Class
RedGate.SQLCompare.Engine Namespace


CachedDefaultSqbFolder Property

[image]

SQL Data Compare API 12.0.40
BackupOptions..::.CachedDefaultSqbFolder Property
BackupOptions Class See Also

The default location for SQB backups

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CachedDefaultSqbFolder As String
C#
public string CachedDefaultSqbFolder { get; set; }
Visual C++
public:
property String^ CachedDefaultSqbFolder {
    String^ get ();
    void set (String^ value);
}

See Also

BackupOptions Class
RedGate.SQLCompare.Engine Namespace


CachedSqbLicenseType Property

[image]

SQL Data Compare API 12.0.40
BackupOptions..::.CachedSqbLicenseType Property
BackupOptions Class See Also

Gets the type of the SQL Backup license on the target server

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CachedSqbLicenseType As SqlBackupLicenseType
C#
public SqlBackupLicenseType CachedSqbLicenseType { get; set; }
Visual C++
public:
property SqlBackupLicenseType CachedSqbLicenseType {
    SqlBackupLicenseType get ();
    void set (SqlBackupLicenseType value);
}

See Also

BackupOptions Class
RedGate.SQLCompare.Engine Namespace


CachedSqbVersion Property

[image]

SQL Data Compare API 12.0.40
BackupOptions..::.CachedSqbVersion Property
BackupOptions Class See Also

Gets the installed version of SQL Backup on the target server. Returns zero if SQL Backup isn't installed.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CachedSqbVersion As Integer
C#
public int CachedSqbVersion { get; set; }
Visual C++
public:
property int CachedSqbVersion {
    int get ();
    void set (int value);
}

See Also

BackupOptions Class
RedGate.SQLCompare.Engine Namespace


CompressionLevel Property

[image]

SQL Data Compare API 12.0.40
BackupOptions..::.CompressionLevel Property
BackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CompressionLevel As Integer
C#
public int CompressionLevel { get; set; }
Visual C++
public:
property int CompressionLevel {
    int get ();
    void set (int value);
}

See Also

BackupOptions Class
RedGate.SQLCompare.Engine Namespace


DatabaseName Property

[image]

SQL Data Compare API 12.0.40
BackupOptions..::.DatabaseName Property
BackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DatabaseName As String
C#
public string DatabaseName { get; set; }
Visual C++
public:
property String^ DatabaseName {
    String^ get ();
    void set (String^ value);
}

See Also

BackupOptions Class
RedGate.SQLCompare.Engine Namespace


EncryptionLevel Property

[image]

SQL Data Compare API 12.0.40
BackupOptions..::.EncryptionLevel Property
BackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property EncryptionLevel As SqbEncryptionLevel
C#
public SqbEncryptionLevel EncryptionLevel { get; set; }
Visual C++
public:
property SqbEncryptionLevel EncryptionLevel {
    SqbEncryptionLevel get ();
    void set (SqbEncryptionLevel value);
}

See Also

BackupOptions Class
RedGate.SQLCompare.Engine Namespace


Filename Property

[image]

SQL Data Compare API 12.0.40
BackupOptions..::.Filename Property
BackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Filename As String
C#
public string Filename { get; set; }
Visual C++
public:
property String^ Filename {
    String^ get ();
    void set (String^ value);
}

See Also

BackupOptions Class
RedGate.SQLCompare.Engine Namespace


Folder Property

[image]

SQL Data Compare API 12.0.40
BackupOptions..::.Folder Property
BackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Folder As String
C#
public string Folder { get; set; }
Visual C++
public:
property String^ Folder {
    String^ get ();
    void set (String^ value);
}

See Also

BackupOptions Class
RedGate.SQLCompare.Engine Namespace


NameFileAutomatically Property

[image]

SQL Data Compare API 12.0.40
BackupOptions..::.NameFileAutomatically Property
BackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NameFileAutomatically As Boolean
C#
public bool NameFileAutomatically { get; set; }
Visual C++
public:
property bool NameFileAutomatically {
    bool get ();
    void set (bool value);
}

See Also

BackupOptions Class
RedGate.SQLCompare.Engine Namespace


OverwriteIfExists Property

[image]

SQL Data Compare API 12.0.40
BackupOptions..::.OverwriteIfExists Property
BackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property OverwriteIfExists As Boolean
C#
public bool OverwriteIfExists { get; set; }
Visual C++
public:
property bool OverwriteIfExists {
    bool get ();
    void set (bool value);
}

See Also

BackupOptions Class
RedGate.SQLCompare.Engine Namespace


Password Property

[image]

SQL Data Compare API 12.0.40
BackupOptions..::.Password Property
BackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password { get; set; }
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

BackupOptions Class
RedGate.SQLCompare.Engine Namespace


ProviderOfBackup Property

[image]

SQL Data Compare API 12.0.40
BackupOptions..::.ProviderOfBackup Property
BackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ProviderOfBackup As BackupProvider
C#
public BackupProvider ProviderOfBackup { get; set; }
Visual C++
public:
property BackupProvider ProviderOfBackup {
    BackupProvider get ();
    void set (BackupProvider value);
}

See Also

BackupOptions Class
RedGate.SQLCompare.Engine Namespace


ThreadCount Property

[image]

SQL Data Compare API 12.0.40
BackupOptions..::.ThreadCount Property
BackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ThreadCount As Integer
C#
public int ThreadCount { get; set; }
Visual C++
public:
property int ThreadCount {
    int get ();
    void set (int value);
}

See Also

BackupOptions Class
RedGate.SQLCompare.Engine Namespace


TypeOfBackup Property

[image]

SQL Data Compare API 12.0.40
BackupOptions..::.TypeOfBackup Property
BackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeOfBackup As TypeOfBackup
C#
public TypeOfBackup TypeOfBackup { get; set; }
Visual C++
public:
property TypeOfBackup TypeOfBackup {
    TypeOfBackup get ();
    void set (TypeOfBackup value);
}

See Also

BackupOptions Class
RedGate.SQLCompare.Engine Namespace


BackupProvider Enumeration

[image]

SQL Data Compare API 12.0.40
BackupProvider Enumeration
See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration BackupProvider
C#
public enum BackupProvider
Visual C++
public enum class BackupProvider

Members

Member name | Description
Native |
SQB |

See Also

RedGate.SQLCompare.Engine Namespace


Canceler Class

[image]

SQL Data Compare API 12.0.40
Canceler Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class Canceler
C#
public class Canceler
Visual C++
public ref class Canceler

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.Canceler

See Also

Canceler Members
RedGate.SQLCompare.Engine Namespace


Canceler Members

[image] [image]

SQL Data Compare API 12.0.40
Canceler Members
Canceler Class Constructors Methods Properties See Also

The Canceler type exposes the following members.

Constructors

Name | Description
Canceler |

Methods

Name | Description
Cancel |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ThrowIfCancelled |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsCanceled |

See Also

Canceler Class
RedGate.SQLCompare.Engine Namespace


Canceler Constructor

[image]

SQL Data Compare API 12.0.40
Canceler Constructor
Canceler Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Canceler()
Visual C++
public:
Canceler()

See Also

Canceler Class
RedGate.SQLCompare.Engine Namespace


Canceler Methods

[image] [image]

SQL Data Compare API 12.0.40
Canceler Methods
Canceler Class See Also

The Canceler type exposes the following methods.

Methods

Name | Description
Cancel |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ThrowIfCancelled |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Canceler Class
RedGate.SQLCompare.Engine Namespace


Cancel Method

[image]

SQL Data Compare API 12.0.40
Canceler..::.Cancel Method
Canceler Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Cancel
C#
public void Cancel()
Visual C++
public:
void Cancel()

See Also

Canceler Class
RedGate.SQLCompare.Engine Namespace


ThrowIfCancelled Method

[image]

SQL Data Compare API 12.0.40
Canceler..::.ThrowIfCancelled Method
Canceler Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub ThrowIfCancelled
C#
public void ThrowIfCancelled()
Visual C++
public:
void ThrowIfCancelled()

See Also

Canceler Class
RedGate.SQLCompare.Engine Namespace


Canceler Properties

[image] [image]

SQL Data Compare API 12.0.40
Canceler Properties
Canceler Class See Also

The Canceler type exposes the following properties.

Properties

Name | Description
IsCanceled |

See Also

Canceler Class
RedGate.SQLCompare.Engine Namespace


IsCanceled Property

[image]

SQL Data Compare API 12.0.40
Canceler..::.IsCanceled Property
Canceler Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsCanceled As Boolean
C#
public bool IsCanceled { get; set; }
Visual C++
public:
property bool IsCanceled {
    bool get ();
    void set (bool value);
}

See Also

Canceler Class
RedGate.SQLCompare.Engine Namespace


Certificate Class

[image]

SQL Data Compare API 12.0.40
Certificate Class
Members See Also

A certificate.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Certificate _
    Inherits DatabaseObjectWithAuthorization _
    Implements IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck,  _
    IPatchUpAfterDeserialization, ISqlComparable
C#
public sealed class Certificate : DatabaseObjectWithAuthorization, IHasPermissions,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, IPatchUpAfterDeserialization, ISqlComparable
Visual C++
public ref class Certificate sealed : public DatabaseObjectWithAuthorization,
    IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck, IPatchUpAfterDeserialization,
    ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.Certificate

See Also

Certificate Members
RedGate.SQLCompare.Engine Namespace


Certificate Members

[image] [image]

SQL Data Compare API 12.0.40
Certificate Members
Certificate Class Methods Fields Properties Explicit Interface Implementations See Also

The Certificate type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
ActiveForDialog | True if the certificate is available to the initiator of a Service Broker dialog conversation.
AlterAuthorizationClassType | (Overrides DatabaseObjectWithAuthorization ..::. AlterAuthorizationClassType.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExpiryDate | The expiry date of the certificate.
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
IssuerName | The name of the certificate's issuer.
KeyEncryptionType | The certificate's private key encryption type.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Certificate (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions |
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)
SerialNumber | The certificate's serial number.
StartDate | The start date of the certificate.
Subject | The certificate's subject.
ThumbPrint | The thumb print for this certificate.

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

Certificate Class
RedGate.SQLCompare.Engine Namespace


Certificate Methods

[image] [image]

SQL Data Compare API 12.0.40
Certificate Methods
Certificate Class See Also

The Certificate type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

Certificate Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
Certificate..::.ISqlComparable..::.CompareWith Method
Certificate Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    target As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable target,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ target,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

target
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

Certificate Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
Certificate..::.Equals Method
Certificate Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the certificate with a specified certificate. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

Certificate Class
Certificate Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
Certificate..::.Equals Method (IDatabaseObject, Options)
Certificate Class See Also

Compares the certificate with a specified certificate.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The certificate to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the certificates are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

Certificate Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
Certificate..::.PatchUpAfterDeserialization Method
Certificate Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

Certificate Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
Certificate..::.ScriptObject Method
Certificate Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

Certificate Class
RedGate.SQLCompare.Engine Namespace


Certificate Properties

[image] [image]

SQL Data Compare API 12.0.40
Certificate Properties
Certificate Class See Also

The Certificate type exposes the following properties.

Properties

Name | Description
ActiveForDialog | True if the certificate is available to the initiator of a Service Broker dialog conversation.
AlterAuthorizationClassType | (Overrides DatabaseObjectWithAuthorization ..::. AlterAuthorizationClassType.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExpiryDate | The expiry date of the certificate.
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
IssuerName | The name of the certificate's issuer.
KeyEncryptionType | The certificate's private key encryption type.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Certificate (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions |
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)
SerialNumber | The certificate's serial number.
StartDate | The start date of the certificate.
Subject | The certificate's subject.
ThumbPrint | The thumb print for this certificate.

See Also

Certificate Class
RedGate.SQLCompare.Engine Namespace


ActiveForDialog Property

[image]

SQL Data Compare API 12.0.40
Certificate..::.ActiveForDialog Property
Certificate Class See Also

True if the certificate is available to the initiator of a Service Broker dialog conversation.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ActiveForDialog As Boolean
C#
public bool ActiveForDialog { get; internal set; }
Visual C++
public:
property bool ActiveForDialog {
    bool get ();
    void set (bool value);
}

See Also

Certificate Class
RedGate.SQLCompare.Engine Namespace


AlterAuthorizationClassType Property

[image]

SQL Data Compare API 12.0.40
Certificate..::.AlterAuthorizationClassType Property
Certificate Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property AlterAuthorizationClassType As String
C#
public override string AlterAuthorizationClassType { get; }
Visual C++
public:
virtual property String^ AlterAuthorizationClassType {
    String^ get () override;
}

Implements

IHasAuthorization..::.AlterAuthorizationClassType

See Also

Certificate Class
RedGate.SQLCompare.Engine Namespace


ExpiryDate Property

[image]

SQL Data Compare API 12.0.40
Certificate..::.ExpiryDate Property
Certificate Class See Also

The expiry date of the certificate.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExpiryDate As DateTime
C#
public DateTime ExpiryDate { get; internal set; }
Visual C++
public:
property DateTime ExpiryDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

Certificate Class
RedGate.SQLCompare.Engine Namespace


IssuerName Property

[image]

SQL Data Compare API 12.0.40
Certificate..::.IssuerName Property
Certificate Class See Also

The name of the certificate's issuer.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IssuerName As String
C#
public string IssuerName { get; internal set; }
Visual C++
public:
property String^ IssuerName {
    String^ get ();
    void set (String^ value);
}

See Also

Certificate Class
RedGate.SQLCompare.Engine Namespace


KeyEncryptionType Property

[image]

SQL Data Compare API 12.0.40
Certificate..::.KeyEncryptionType Property
Certificate Class See Also

The certificate's private key encryption type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property KeyEncryptionType As Certificate..::.CertificateKeyEncryption
C#
public Certificate..::.CertificateKeyEncryption KeyEncryptionType { get; internal set; }
Visual C++
public:
property Certificate..::.CertificateKeyEncryption KeyEncryptionType {
    Certificate..::.CertificateKeyEncryption get ();
    void set (Certificate..::.CertificateKeyEncryption value);
}

See Also

Certificate Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
Certificate..::.ObjectType Property
Certificate Class See Also

Returns ObjectType.Certificate

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()
ITSqlObjectObjectType()()()

See Also

Certificate Class
RedGate.SQLCompare.Engine Namespace


Permissions Property

[image]

SQL Data Compare API 12.0.40
Certificate..::.Permissions Property
Certificate Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Permissions As Permissions
C#
public Permissions Permissions { get; private set; }
Visual C++
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
    void set (Permissions^ value) sealed;
}

Implements

IHasPermissions..::.Permissions

See Also

Certificate Class
RedGate.SQLCompare.Engine Namespace


SerialNumber Property

[image]

SQL Data Compare API 12.0.40
Certificate..::.SerialNumber Property
Certificate Class See Also

The certificate's serial number.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SerialNumber As String
C#
public string SerialNumber { get; internal set; }
Visual C++
public:
property String^ SerialNumber {
    String^ get ();
    void set (String^ value);
}

See Also

Certificate Class
RedGate.SQLCompare.Engine Namespace


StartDate Property

[image]

SQL Data Compare API 12.0.40
Certificate..::.StartDate Property
Certificate Class See Also

The start date of the certificate.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property StartDate As DateTime
C#
public DateTime StartDate { get; internal set; }
Visual C++
public:
property DateTime StartDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

Certificate Class
RedGate.SQLCompare.Engine Namespace


Subject Property

[image]

SQL Data Compare API 12.0.40
Certificate..::.Subject Property
Certificate Class See Also

The certificate's subject.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Subject As String
C#
public string Subject { get; internal set; }
Visual C++
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}

See Also

Certificate Class
RedGate.SQLCompare.Engine Namespace


ThumbPrint Property

[image]

SQL Data Compare API 12.0.40
Certificate..::.ThumbPrint Property
Certificate Class See Also

The thumb print for this certificate.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ThumbPrint As Byte()
C#
public byte[] ThumbPrint { get; internal set; }
Visual C++
public:
property array<unsigned char>^ ThumbPrint {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

Certificate Class
RedGate.SQLCompare.Engine Namespace


Certificate.CertificateKeyEncryption Enumeration

[image]

SQL Data Compare API 12.0.40
Certificate..::.CertificateKeyEncryption Enumeration
Certificate Class See Also

How the private key of the certificate is encrypted.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration CertificateKeyEncryption
C#
public enum CertificateKeyEncryption
Visual C++
public enum class CertificateKeyEncryption

Members

Member name | Description
NotAvailable | NA = There is no private key for the certificate.
MasterKey | MK = Private key is encrypted by the master key.
PrivateKey | PW = Private key is encrypted by a user-defined password.
ServiceKey | SK = Private key is encrypted by the service master key.

See Also

RedGate.SQLCompare.Engine Namespace


Certificates Class

[image]

SQL Data Compare API 12.0.40
Certificates Class
Members See Also

A collection of certificates.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Certificates _
    Inherits SerializableDatabaseObjectCollection(Of Certificate) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class Certificates : SerializableDatabaseObjectCollection<Certificate>, IPatchUpAfterDeserialization
Visual C++
public ref class Certificates sealed : public SerializableDatabaseObjectCollection<Certificate^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Certificate >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( Certificate >)>)
RedGate.SQLCompare.Engine..::.Certificates

See Also

Certificates Members
RedGate.SQLCompare.Engine Namespace


Certificates Members

[image] [image]

SQL Data Compare API 12.0.40
Certificates Members
Certificates Class Methods Fields Properties Explicit Interface Implementations See Also

The Certificates type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

Certificates Class
RedGate.SQLCompare.Engine Namespace


Certificates Methods

[image] [image]

SQL Data Compare API 12.0.40
Certificates Methods
Certificates Class See Also

The Certificates type exposes the following methods.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

Certificates Class
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
Certificates..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
Certificates Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

Certificates Class
RedGate.SQLCompare.Engine Namespace


CertificatesChanges Class

[image]

SQL Data Compare API 12.0.40
CertificatesChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CertificatesChanges
C#
public sealed class CertificatesChanges
Visual C++
public ref class CertificatesChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.CertificatesChanges

See Also

CertificatesChanges Members
RedGate.SQLCompare.Engine Namespace


CertificatesChanges Members

[image] [image]

SQL Data Compare API 12.0.40
CertificatesChanges Members
CertificatesChanges Class Constructors Methods Properties See Also

The CertificatesChanges type exposes the following members.

Constructors

Name | Description
CertificatesChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CertificatesToAlter |
CertificatesToCreate |
CertificatesToDrop |
CertificateTargets |

See Also

CertificatesChanges Class
RedGate.SQLCompare.Engine Namespace


CertificatesChanges Constructor

[image]

SQL Data Compare API 12.0.40
CertificatesChanges Constructor
CertificatesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public CertificatesChanges(
    bool caseSensitive
)
Visual C++
public:
CertificatesChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

CertificatesChanges Class
RedGate.SQLCompare.Engine Namespace


CertificatesChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
CertificatesChanges Properties
CertificatesChanges Class See Also

The CertificatesChanges type exposes the following properties.

Properties

Name | Description
CertificatesToAlter |
CertificatesToCreate |
CertificatesToDrop |
CertificateTargets |

See Also

CertificatesChanges Class
RedGate.SQLCompare.Engine Namespace


CertificatesToAlter Property

[image]

SQL Data Compare API 12.0.40
CertificatesChanges..::.CertificatesToAlter Property
CertificatesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CertificatesToAlter As Certificates
C#
public Certificates CertificatesToAlter { get; private set; }
Visual C++
public:
property Certificates^ CertificatesToAlter {
    Certificates^ get ();
    void set (Certificates^ value);
}

See Also

CertificatesChanges Class
RedGate.SQLCompare.Engine Namespace


CertificatesToCreate Property

[image]

SQL Data Compare API 12.0.40
CertificatesChanges..::.CertificatesToCreate Property
CertificatesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CertificatesToCreate As Certificates
C#
public Certificates CertificatesToCreate { get; private set; }
Visual C++
public:
property Certificates^ CertificatesToCreate {
    Certificates^ get ();
    void set (Certificates^ value);
}

See Also

CertificatesChanges Class
RedGate.SQLCompare.Engine Namespace


CertificatesToDrop Property

[image]

SQL Data Compare API 12.0.40
CertificatesChanges..::.CertificatesToDrop Property
CertificatesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CertificatesToDrop As Certificates
C#
public Certificates CertificatesToDrop { get; private set; }
Visual C++
public:
property Certificates^ CertificatesToDrop {
    Certificates^ get ();
    void set (Certificates^ value);
}

See Also

CertificatesChanges Class
RedGate.SQLCompare.Engine Namespace


CertificateTargets Property

[image]

SQL Data Compare API 12.0.40
CertificatesChanges..::.CertificateTargets Property
CertificatesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CertificateTargets As Dictionary(Of Certificate, Certificate)
C#
public Dictionary<Certificate, Certificate> CertificateTargets { get; private set; }
Visual C++
public:
property Dictionary<Certificate^, Certificate^>^ CertificateTargets {
    Dictionary<Certificate^, Certificate^>^ get ();
    void set (Dictionary<Certificate^, Certificate^>^ value);
}

See Also

CertificatesChanges Class
RedGate.SQLCompare.Engine Namespace


ChangeTrackingsChanges Class

[image]

SQL Data Compare API 12.0.40
ChangeTrackingsChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ChangeTrackingsChanges
C#
public sealed class ChangeTrackingsChanges
Visual C++
public ref class ChangeTrackingsChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ChangeTrackingsChanges

See Also

ChangeTrackingsChanges Members
RedGate.SQLCompare.Engine Namespace


ChangeTrackingsChanges Members

[image] [image]

SQL Data Compare API 12.0.40
ChangeTrackingsChanges Members
ChangeTrackingsChanges Class Constructors Methods Properties See Also

The ChangeTrackingsChanges type exposes the following members.

Constructors

Name | Description
ChangeTrackingsChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ChangeTrackingToAlter |
ChangeTrackingToDisable |

See Also

ChangeTrackingsChanges Class
RedGate.SQLCompare.Engine Namespace


ChangeTrackingsChanges Constructor

[image]

SQL Data Compare API 12.0.40
ChangeTrackingsChanges Constructor
ChangeTrackingsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChangeTrackingsChanges()
Visual C++
public:
ChangeTrackingsChanges()

See Also

ChangeTrackingsChanges Class
RedGate.SQLCompare.Engine Namespace


ChangeTrackingsChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
ChangeTrackingsChanges Properties
ChangeTrackingsChanges Class See Also

The ChangeTrackingsChanges type exposes the following properties.

Properties

Name | Description
ChangeTrackingToAlter |
ChangeTrackingToDisable |

See Also

ChangeTrackingsChanges Class
RedGate.SQLCompare.Engine Namespace


ChangeTrackingToAlter Property

[image]

SQL Data Compare API 12.0.40
ChangeTrackingsChanges..::.ChangeTrackingToAlter Property
ChangeTrackingsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ChangeTrackingToAlter As Set(Of Table)
C#
public Set<Table> ChangeTrackingToAlter { get; private set; }
Visual C++
public:
property Set<Table^>^ ChangeTrackingToAlter {
    Set<Table^>^ get ();
    void set (Set<Table^>^ value);
}

See Also

ChangeTrackingsChanges Class
RedGate.SQLCompare.Engine Namespace


ChangeTrackingToDisable Property

[image]

SQL Data Compare API 12.0.40
ChangeTrackingsChanges..::.ChangeTrackingToDisable Property
ChangeTrackingsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ChangeTrackingToDisable As Set(Of Table)
C#
public Set<Table> ChangeTrackingToDisable { get; private set; }
Visual C++
public:
property Set<Table^>^ ChangeTrackingToDisable {
    Set<Table^>^ get ();
    void set (Set<Table^>^ value);
}

See Also

ChangeTrackingsChanges Class
RedGate.SQLCompare.Engine Namespace


CheckConstraint Class

[image]

SQL Data Compare API 12.0.40
CheckConstraint Class
Members See Also

A check constraint.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CheckConstraint _
    Implements IDatabaseObject, ITSqlObject, ICanExistenceCheck, IHasScriptSource,  _
    ISqlComparable
C#
public sealed class CheckConstraint : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck, IHasScriptSource, ISqlComparable
Visual C++
public ref class CheckConstraint sealed : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck, IHasScriptSource, ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.CheckConstraint

See Also

CheckConstraint Members
RedGate.SQLCompare.Engine Namespace


CheckConstraint Members

[image] [image]

SQL Data Compare API 12.0.40
CheckConstraint Members
CheckConstraint Class Methods Properties Explicit Interface Implementations See Also

The CheckConstraint type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Database | The database to which the object belongs.
Disabled | True if the check constraint is disabled.
Fields | The fields in the check constraint.
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! This is not escaped.
Name | The constraint name. DANGER WILL ROBINSON!! This is not escaped. Do you mean CheckConstraint..::.QualifiedName?
NoCheck | True if the constraint is marked as WITH NOCHECK (that is, it is not trusted).
NotForReplication | True if the check constraint is marked not for replication.
ObjectType | Returns ObjectType.CheckConstraint.
Owner | The owner or schema of the parent table.
QualifiedName | The qualified name of the object. Do you mean CheckConstraint..::.Name?
ScriptSource | The location of the creation script for this object if the database source is set to scripts folder.
ScriptSourceNocheck | The location of any ALTER TABLE ... NOCHECK CONSTRAINT commands on the constraint.
SysobjectID | The sysobject identier of the object.
SystemNamed |
Text | The constraint text.

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

CheckConstraint Class
RedGate.SQLCompare.Engine Namespace


CheckConstraint Methods

[image] [image]

SQL Data Compare API 12.0.40
CheckConstraint Methods
CheckConstraint Class See Also

The CheckConstraint type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

CheckConstraint Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
CheckConstraint..::.ISqlComparable..::.CompareWith Method
CheckConstraint Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    obj As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable obj,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ obj,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

obj
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

CheckConstraint Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
CheckConstraint..::.Equals Method
CheckConstraint Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the check constraint with a specified check constraint.

See Also

CheckConstraint Class
CheckConstraint Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
CheckConstraint..::.Equals Method (IDatabaseObject, Options)
CheckConstraint Class See Also

Compares the check constraint with a specified check constraint.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    obj As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public bool Equals(
    IDatabaseObject obj,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ obj,
    Options options
) sealed

Parameters

obj
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The constraint to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

Compares the table with a specified table.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

CheckConstraint Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


CheckConstraint Properties

[image] [image]

SQL Data Compare API 12.0.40
CheckConstraint Properties
CheckConstraint Class See Also

The CheckConstraint type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs.
Disabled | True if the check constraint is disabled.
Fields | The fields in the check constraint.
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! This is not escaped.
Name | The constraint name. DANGER WILL ROBINSON!! This is not escaped. Do you mean CheckConstraint..::.QualifiedName?
NoCheck | True if the constraint is marked as WITH NOCHECK (that is, it is not trusted).
NotForReplication | True if the check constraint is marked not for replication.
ObjectType | Returns ObjectType.CheckConstraint.
Owner | The owner or schema of the parent table.
QualifiedName | The qualified name of the object. Do you mean CheckConstraint..::.Name?
ScriptSource | The location of the creation script for this object if the database source is set to scripts folder.
ScriptSourceNocheck | The location of any ALTER TABLE ... NOCHECK CONSTRAINT commands on the constraint.
SysobjectID | The sysobject identier of the object.
SystemNamed |
Text | The constraint text.

See Also

CheckConstraint Class
RedGate.SQLCompare.Engine Namespace


Database Property

[image]

SQL Data Compare API 12.0.40
CheckConstraint..::.Database Property
CheckConstraint Class See Also

The database to which the object belongs.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Database As Database
C#
public Database Database { get; }
Visual C++
public:
virtual property Database^ Database {
    Database^ get () sealed;
}

Implements

IDatabaseObject..::.Database

See Also

CheckConstraint Class
RedGate.SQLCompare.Engine Namespace


Disabled Property

[image]

SQL Data Compare API 12.0.40
CheckConstraint..::.Disabled Property
CheckConstraint Class See Also

True if the check constraint is disabled.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Disabled As Boolean
C#
public bool Disabled { get; internal set; }
Visual C++
public:
property bool Disabled {
    bool get ();
    void set (bool value);
}

See Also

CheckConstraint Class
RedGate.SQLCompare.Engine Namespace


Fields Property

[image]

SQL Data Compare API 12.0.40
CheckConstraint..::.Fields Property
CheckConstraint Class See Also

The fields in the check constraint.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Fields As Fields
C#
public Fields Fields { get; private set; }
Visual C++
public:
property Fields^ Fields {
    Fields^ get ();
    void set (Fields^ value);
}

Remarks

If it's a table level constraint then the list will have length 0, and if it's a column level constraint then the list will have length 1

See Also

CheckConstraint Class
RedGate.SQLCompare.Engine Namespace


FullyQualifiedName Property

[image]

SQL Data Compare API 12.0.40
CheckConstraint..::.FullyQualifiedName Property
CheckConstraint Class See Also

The fully-qualified name of the object. DANGER WILL ROBINSON!! This is not escaped.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullyQualifiedName As String
C#
public string FullyQualifiedName { get; }
Visual C++
public:
virtual property String^ FullyQualifiedName {
    String^ get () sealed;
}

Implements

ITSqlObjectFullyQualifiedName()()()

See Also

CheckConstraint Class
RedGate.SQLCompare.Engine Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
CheckConstraint..::.Name Property
CheckConstraint Class See Also

The constraint name. DANGER WILL ROBINSON!! This is not escaped. Do you mean CheckConstraint..::.QualifiedName?

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; internal set; }
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ITSqlObjectName()()()

See Also

CheckConstraint Class
RedGate.SQLCompare.Engine Namespace
CheckConstraint..::.QualifiedName


NoCheck Property

[image]

SQL Data Compare API 12.0.40
CheckConstraint..::.NoCheck Property
CheckConstraint Class See Also

True if the constraint is marked as WITH NOCHECK (that is, it is not trusted).

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NoCheck As Boolean
C#
public bool NoCheck { get; internal set; }
Visual C++
public:
property bool NoCheck {
    bool get ();
    void set (bool value);
}

See Also

CheckConstraint Class
RedGate.SQLCompare.Engine Namespace


NotForReplication Property

[image]

SQL Data Compare API 12.0.40
CheckConstraint..::.NotForReplication Property
CheckConstraint Class See Also

True if the check constraint is marked not for replication.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NotForReplication As Boolean
C#
public bool NotForReplication { get; internal set; }
Visual C++
public:
property bool NotForReplication {
    bool get ();
    void set (bool value);
}

See Also

CheckConstraint Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
CheckConstraint..::.ObjectType Property
CheckConstraint Class See Also

Returns ObjectType.CheckConstraint.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ObjectType As ObjectType
C#
public ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () sealed;
}

Implements

ITSqlObjectObjectType()()()

See Also

CheckConstraint Class
RedGate.SQLCompare.Engine Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
CheckConstraint..::.Owner Property
CheckConstraint Class See Also

The owner or schema of the parent table.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Owner As String
C#
public string Owner { get; }
Visual C++
public:
virtual property String^ Owner {
    String^ get () sealed;
}

Implements

ITSqlObjectOwner()()()

See Also

CheckConstraint Class
RedGate.SQLCompare.Engine Namespace


QualifiedName Property

[image]

SQL Data Compare API 12.0.40
CheckConstraint..::.QualifiedName Property
CheckConstraint Class See Also

The qualified name of the object. Do you mean CheckConstraint..::.Name?

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property QualifiedName As String
C#
public string QualifiedName { get; }
Visual C++
public:
virtual property String^ QualifiedName {
    String^ get () sealed;
}

Implements

ITSqlObjectQualifiedName()()()

See Also

CheckConstraint Class
RedGate.SQLCompare.Engine Namespace
CheckConstraint..::.Name


ScriptSource Property

[image]

SQL Data Compare API 12.0.40
CheckConstraint..::.ScriptSource Property
CheckConstraint Class See Also

The location of the creation script for this object if the database source is set to scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSource As ScriptSource
C#
public ScriptSource ScriptSource { get; internal set; }
Visual C++
public:
virtual property ScriptSource^ ScriptSource {
    ScriptSource^ get () sealed;
    void set (ScriptSource^ value) sealed;
}

Implements

IHasScriptSource..::.ScriptSource

See Also

CheckConstraint Class
RedGate.SQLCompare.Engine Namespace


ScriptSourceNocheck Property

[image]

SQL Data Compare API 12.0.40
CheckConstraint..::.ScriptSourceNocheck Property
CheckConstraint Class See Also

The location of any ALTER TABLE ... NOCHECK CONSTRAINT commands on the constraint.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSourceNocheck As ScriptSource
C#
public ScriptSource ScriptSourceNocheck { get; internal set; }
Visual C++
public:
property ScriptSource^ ScriptSourceNocheck {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

CheckConstraint Class
RedGate.SQLCompare.Engine Namespace


SysobjectID Property

[image]

SQL Data Compare API 12.0.40
CheckConstraint..::.SysobjectID Property
CheckConstraint Class See Also

The sysobject identier of the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SysobjectID As Integer
C#
public int SysobjectID { get; set; }
Visual C++
public:
virtual property int SysobjectID {
    int get () sealed;
    void set (int value) sealed;
}

See Also

CheckConstraint Class
RedGate.SQLCompare.Engine Namespace


SystemNamed Property

[image]

SQL Data Compare API 12.0.40
CheckConstraint..::.SystemNamed Property
CheckConstraint Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SystemNamed As Boolean
C#
public bool SystemNamed { get; set; }
Visual C++
public:
virtual property bool SystemNamed {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

CheckConstraint Class
RedGate.SQLCompare.Engine Namespace


Text Property

[image]

SQL Data Compare API 12.0.40
CheckConstraint..::.Text Property
CheckConstraint Class See Also

The constraint text.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text { get; internal set; }
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

CheckConstraint Class
RedGate.SQLCompare.Engine Namespace


CheckConstraintChangesCalculator Class

[image]

SQL Data Compare API 12.0.40
CheckConstraintChangesCalculator Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class CheckConstraintChangesCalculator
C#
public class CheckConstraintChangesCalculator
Visual C++
public ref class CheckConstraintChangesCalculator

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.CheckConstraintChangesCalculator

See Also

CheckConstraintChangesCalculator Members
RedGate.SQLCompare.Engine Namespace


CheckConstraintChangesCalculator Members

[image] [image]

SQL Data Compare API 12.0.40
CheckConstraintChangesCalculator Members
CheckConstraintChangesCalculator Class Constructors Methods See Also

The CheckConstraintChangesCalculator type exposes the following members.

Constructors

Name | Description
CheckConstraintChangesCalculator |

Methods

Name | Description
AddAll |
CalculateWorkTableCheckConstraints |
CreateCheckConstraintForField |
DropAll |
DropAndRecreateTableConstraints |
DropCheckConstraintIfReferencingDroppedColumn |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckConstraintChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


CheckConstraintChangesCalculator Constructor

[image]

SQL Data Compare API 12.0.40
CheckConstraintChangesCalculator Constructor
CheckConstraintChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    checkConstraintsChanges As CheckConstraintsChanges _
)
C#
public CheckConstraintChangesCalculator(
    CheckConstraintsChanges checkConstraintsChanges
)
Visual C++
public:
CheckConstraintChangesCalculator(
    CheckConstraintsChanges^ checkConstraintsChanges
)

Parameters

checkConstraintsChanges
Type: RedGate.SQLCompare.Engine..::.CheckConstraintsChanges

See Also

CheckConstraintChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


CheckConstraintChangesCalculator Methods

[image] [image]

SQL Data Compare API 12.0.40
CheckConstraintChangesCalculator Methods
CheckConstraintChangesCalculator Class See Also

The CheckConstraintChangesCalculator type exposes the following methods.

Methods

Name | Description
AddAll |
CalculateWorkTableCheckConstraints |
CreateCheckConstraintForField |
DropAll |
DropAndRecreateTableConstraints |
DropCheckConstraintIfReferencingDroppedColumn |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckConstraintChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


AddAll Method

[image]

SQL Data Compare API 12.0.40
CheckConstraintChangesCalculator..::.AddAll Method
CheckConstraintChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddAll ( _
    checkConstraints As CheckConstraints _
)
C#
public void AddAll(
    CheckConstraints checkConstraints
)
Visual C++
public:
void AddAll(
    CheckConstraints^ checkConstraints
)

Parameters

checkConstraints
Type: RedGate.SQLCompare.Engine..::.CheckConstraints

See Also

CheckConstraintChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


CalculateWorkTableCheckConstraints Method

[image]

SQL Data Compare API 12.0.40
CheckConstraintChangesCalculator..::.CalculateWorkTableCheckConstraints Method
CheckConstraintChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculateWorkTableCheckConstraints ( _
    sourceCheckConstraints As CheckConstraints, _
    targetTable As Table, _
    targetDatabaseSource As DatabaseSource, _
    options As Options, _
    needToForceTableBodyAlter As Boolean _
)
C#
public void CalculateWorkTableCheckConstraints(
    CheckConstraints sourceCheckConstraints,
    Table targetTable,
    DatabaseSource targetDatabaseSource,
    Options options,
    bool needToForceTableBodyAlter
)
Visual C++
public:
void CalculateWorkTableCheckConstraints(
    CheckConstraints^ sourceCheckConstraints,
    Table^ targetTable,
    DatabaseSource targetDatabaseSource,
    Options options,
    bool needToForceTableBodyAlter
)

Parameters

sourceCheckConstraints
Type: RedGate.SQLCompare.Engine..::.CheckConstraints
targetTable
Type: RedGate.SQLCompare.Engine..::.Table
targetDatabaseSource
Type: RedGate.SQLCompare.Engine..::.DatabaseSource
options
Type: RedGate.SQLCompare.Engine..::.Options
needToForceTableBodyAlter
Type: Boolean

See Also

CheckConstraintChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


CreateCheckConstraintForField Method

[image]

SQL Data Compare API 12.0.40
CheckConstraintChangesCalculator..::.CreateCheckConstraintForField Method
CheckConstraintChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateCheckConstraintForField ( _
    constraints As CheckConstraints, _
    field As IField _
)
C#
public void CreateCheckConstraintForField(
    CheckConstraints constraints,
    IField field
)
Visual C++
public:
void CreateCheckConstraintForField(
    CheckConstraints^ constraints,
    IField^ field
)

Parameters

constraints
Type: RedGate.SQLCompare.Engine..::.CheckConstraints
field
Type: RedGate.SQLCompare.Engine..::.IField

See Also

CheckConstraintChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


DropAll Method

[image]

SQL Data Compare API 12.0.40
CheckConstraintChangesCalculator..::.DropAll Method
CheckConstraintChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub DropAll ( _
    checkConstraints As CheckConstraints _
)
C#
public void DropAll(
    CheckConstraints checkConstraints
)
Visual C++
public:
void DropAll(
    CheckConstraints^ checkConstraints
)

Parameters

checkConstraints
Type: RedGate.SQLCompare.Engine..::.CheckConstraints

See Also

CheckConstraintChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


DropAndRecreateTableConstraints Method

[image]

SQL Data Compare API 12.0.40
CheckConstraintChangesCalculator..::.DropAndRecreateTableConstraints Method
CheckConstraintChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub DropAndRecreateTableConstraints ( _
    sourceCheckConstraints As CheckConstraints, _
    targetCheckConstraints As CheckConstraints, _
    fieldsToAdd As Fields, _
    fieldsToDrop As Fields, _
    fieldsToModify As Fields, _
    fullRebuild As Boolean _
)
C#
public void DropAndRecreateTableConstraints(
    CheckConstraints sourceCheckConstraints,
    CheckConstraints targetCheckConstraints,
    Fields fieldsToAdd,
    Fields fieldsToDrop,
    Fields fieldsToModify,
    bool fullRebuild
)
Visual C++
public:
void DropAndRecreateTableConstraints(
    CheckConstraints^ sourceCheckConstraints,
    CheckConstraints^ targetCheckConstraints,
    Fields^ fieldsToAdd,
    Fields^ fieldsToDrop,
    Fields^ fieldsToModify,
    bool fullRebuild
)

Parameters

sourceCheckConstraints
Type: RedGate.SQLCompare.Engine..::.CheckConstraints
targetCheckConstraints
Type: RedGate.SQLCompare.Engine..::.CheckConstraints
fieldsToAdd
Type: RedGate.SQLCompare.Engine..::.Fields
fieldsToDrop
Type: RedGate.SQLCompare.Engine..::.Fields
fieldsToModify
Type: RedGate.SQLCompare.Engine..::.Fields
fullRebuild
Type: Boolean

See Also

CheckConstraintChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


DropCheckConstraintIfReferencingDroppedColumn Method

[image]

SQL Data Compare API 12.0.40
CheckConstraintChangesCalculator..::.DropCheckConstraintIfReferencingDroppedColumn Method
CheckConstraintChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub DropCheckConstraintIfReferencingDroppedColumn ( _
    constraints As CheckConstraints, _
    field As IField _
)
C#
public void DropCheckConstraintIfReferencingDroppedColumn(
    CheckConstraints constraints,
    IField field
)
Visual C++
public:
void DropCheckConstraintIfReferencingDroppedColumn(
    CheckConstraints^ constraints,
    IField^ field
)

Parameters

constraints
Type: RedGate.SQLCompare.Engine..::.CheckConstraints
field
Type: RedGate.SQLCompare.Engine..::.IField

See Also

CheckConstraintChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


CheckConstraints Class

[image]

SQL Data Compare API 12.0.40
CheckConstraints Class
Members See Also

A collection of check constraints.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CheckConstraints _
    Inherits SerializableDatabaseObjectCollection(Of CheckConstraint)
C#
public sealed class CheckConstraints : SerializableDatabaseObjectCollection<CheckConstraint>
Visual C++
public ref class CheckConstraints sealed : public SerializableDatabaseObjectCollection<CheckConstraint^>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( CheckConstraint >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( CheckConstraint >)>)
RedGate.SQLCompare.Engine..::.CheckConstraints

See Also

CheckConstraints Members
RedGate.SQLCompare.Engine Namespace


CheckConstraints Members

[image] [image]

SQL Data Compare API 12.0.40
CheckConstraints Members
CheckConstraints Class Methods Fields Properties Explicit Interface Implementations See Also

The CheckConstraints type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

CheckConstraints Class
RedGate.SQLCompare.Engine Namespace


CheckConstraints Methods

[image] [image]

SQL Data Compare API 12.0.40
CheckConstraints Methods
CheckConstraints Class See Also

The CheckConstraints type exposes the following methods.

Methods

Name | Description
Add | Overloaded.
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

CheckConstraints Class
RedGate.SQLCompare.Engine Namespace


Add Method

[image] [image]

SQL Data Compare API 12.0.40
CheckConstraints..::.Add Method
CheckConstraints Class See Also

Overload List

Name | Description
Add(T) | (Inherited from KeyedCollection<(Of <(T>)>).)
Add(CheckConstraint) | (Overrides SerializableDatabaseObjectCollection <(Of <( CheckConstraint >)>)..::. Add(T).)

See Also

CheckConstraints Class
CheckConstraints Members
RedGate.SQLCompare.Engine Namespace


Add Method (CheckConstraint)

[image]

SQL Data Compare API 12.0.40
CheckConstraints..::.Add Method (CheckConstraint)
CheckConstraints Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Add ( _
    value As CheckConstraint _
)
C#
public override void Add(
    CheckConstraint value
)
Visual C++
public:
virtual void Add(
    CheckConstraint^ value
) override

Parameters

value
Type: RedGate.SQLCompare.Engine..::.CheckConstraint

See Also

CheckConstraints Class
Add Overload
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
CheckConstraints..::.PatchUpAfterDeserialization Method
CheckConstraints Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    table As Table _
)
C#
public void PatchUpAfterDeserialization(
    Table table
)
Visual C++
public:
void PatchUpAfterDeserialization(
    Table^ table
)

Parameters

table
Type: RedGate.SQLCompare.Engine..::.Table

See Also

CheckConstraints Class
RedGate.SQLCompare.Engine Namespace


CheckConstraints Properties

[image] [image]

SQL Data Compare API 12.0.40
CheckConstraints Properties
CheckConstraints Class See Also

The CheckConstraints type exposes the following properties.

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

See Also

CheckConstraints Class
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
CheckConstraints..::.Item Property
CheckConstraints Class See Also

Overload List

Name | Description
Item[([(String])]) | Returns a check constraint given a name. (Overrides KeyedCollection <(Of <( T >)>)..::. Item[([(String])]).)
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
Item[([(Table, String])]) | Returns a check constraint given a table and a name.

See Also

CheckConstraints Class
CheckConstraints Members
RedGate.SQLCompare.Engine Namespace


Item Property ()

[image]

SQL Data Compare API 12.0.40
CheckConstraints..::.Item Property ()
CheckConstraints Class See Also

Returns a check constraint given a name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Default Property Item ( _
    name As String _
) As CheckConstraint
C#
public override CheckConstraint this[
    string name
] { get; }
Visual C++
public:
virtual property CheckConstraint^ default[String^ name] {
    CheckConstraint^ get (String^ name) override;
}

Parameters

name
Type: String
The string-based index of the element to get or set.

Implements

IKeyedCollectionItem(String)

See Also

CheckConstraints Class
Item Overload
RedGate.SQLCompare.Engine Namespace


Item Property (Table, )

[image]

SQL Data Compare API 12.0.40
CheckConstraints..::.Item Property (Table, )
CheckConstraints Class See Also

Returns a check constraint given a table and a name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    table As Table, _
    name As String _
) As CheckConstraint
C#
public CheckConstraint this[
    Table table,
    string name
] { get; }
Visual C++
public:
property CheckConstraint^ default[Table^ table, String^ name] {
    CheckConstraint^ get (Table^ table, String^ name);
}

Parameters

table
Type: RedGate.SQLCompare.Engine..::.Table
The table component of the string-based index of the element to get or set.
name
Type: String
The name component of the string-based index of the element to get or set.

See Also

CheckConstraints Class
Item Overload
RedGate.SQLCompare.Engine Namespace


CheckConstraintsChanges Class

[image]

SQL Data Compare API 12.0.40
CheckConstraintsChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CheckConstraintsChanges
C#
public sealed class CheckConstraintsChanges
Visual C++
public ref class CheckConstraintsChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.CheckConstraintsChanges

See Also

CheckConstraintsChanges Members
RedGate.SQLCompare.Engine Namespace


CheckConstraintsChanges Members

[image] [image]

SQL Data Compare API 12.0.40
CheckConstraintsChanges Members
CheckConstraintsChanges Class Constructors Methods Properties See Also

The CheckConstraintsChanges type exposes the following members.

Constructors

Name | Description
CheckConstraintsChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CheckConstraintsToCreate |
CheckConstraintsToDrop |

See Also

CheckConstraintsChanges Class
RedGate.SQLCompare.Engine Namespace


CheckConstraintsChanges Constructor

[image]

SQL Data Compare API 12.0.40
CheckConstraintsChanges Constructor
CheckConstraintsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public CheckConstraintsChanges(
    bool caseSensitive
)
Visual C++
public:
CheckConstraintsChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

CheckConstraintsChanges Class
RedGate.SQLCompare.Engine Namespace


CheckConstraintsChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
CheckConstraintsChanges Properties
CheckConstraintsChanges Class See Also

The CheckConstraintsChanges type exposes the following properties.

Properties

Name | Description
CheckConstraintsToCreate |
CheckConstraintsToDrop |

See Also

CheckConstraintsChanges Class
RedGate.SQLCompare.Engine Namespace


CheckConstraintsToCreate Property

[image]

SQL Data Compare API 12.0.40
CheckConstraintsChanges..::.CheckConstraintsToCreate Property
CheckConstraintsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CheckConstraintsToCreate As CheckConstraints
C#
public CheckConstraints CheckConstraintsToCreate { get; private set; }
Visual C++
public:
property CheckConstraints^ CheckConstraintsToCreate {
    CheckConstraints^ get ();
    void set (CheckConstraints^ value);
}

See Also

CheckConstraintsChanges Class
RedGate.SQLCompare.Engine Namespace


CheckConstraintsToDrop Property

[image]

SQL Data Compare API 12.0.40
CheckConstraintsChanges..::.CheckConstraintsToDrop Property
CheckConstraintsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CheckConstraintsToDrop As CheckConstraints
C#
public CheckConstraints CheckConstraintsToDrop { get; private set; }
Visual C++
public:
property CheckConstraints^ CheckConstraintsToDrop {
    CheckConstraints^ get ();
    void set (CheckConstraints^ value);
}

See Also

CheckConstraintsChanges Class
RedGate.SQLCompare.Engine Namespace


ClrAssemblies Class

[image]

SQL Data Compare API 12.0.40
ClrAssemblies Class
Members See Also

A collection of Common Language Runtime (CLR) assemblies.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ClrAssemblies _
    Inherits SerializableDatabaseObjectCollection(Of ClrAssembly) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class ClrAssemblies : SerializableDatabaseObjectCollection<ClrAssembly>, IPatchUpAfterDeserialization
Visual C++
public ref class ClrAssemblies sealed : public SerializableDatabaseObjectCollection<ClrAssembly^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( ClrAssembly >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( ClrAssembly >)>)
RedGate.SQLCompare.Engine..::.ClrAssemblies

See Also

ClrAssemblies Members
RedGate.SQLCompare.Engine Namespace


ClrAssemblies Members

[image] [image]

SQL Data Compare API 12.0.40
ClrAssemblies Members
ClrAssemblies Class Methods Fields Properties Explicit Interface Implementations See Also

The ClrAssemblies type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

ClrAssemblies Class
RedGate.SQLCompare.Engine Namespace


ClrAssemblies Methods

[image] [image]

SQL Data Compare API 12.0.40
ClrAssemblies Methods
ClrAssemblies Class See Also

The ClrAssemblies type exposes the following methods.

Methods

Name | Description
Add | Overloaded.
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

ClrAssemblies Class
RedGate.SQLCompare.Engine Namespace


Add Method

[image] [image]

SQL Data Compare API 12.0.40
ClrAssemblies..::.Add Method
ClrAssemblies Class See Also

Overload List

Name | Description
Add(T) | (Inherited from KeyedCollection<(Of <(T>)>).)
Add(ClrAssembly) | (Overrides SerializableDatabaseObjectCollection <(Of <( ClrAssembly >)>)..::. Add(T).)

See Also

ClrAssemblies Class
ClrAssemblies Members
RedGate.SQLCompare.Engine Namespace


Add Method (ClrAssembly)

[image]

SQL Data Compare API 12.0.40
ClrAssemblies..::.Add Method (ClrAssembly)
ClrAssemblies Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Add ( _
    value As ClrAssembly _
)
C#
public override void Add(
    ClrAssembly value
)
Visual C++
public:
virtual void Add(
    ClrAssembly^ value
) override

Parameters

value
Type: RedGate.SQLCompare.Engine..::.ClrAssembly

See Also

ClrAssemblies Class
Add Overload
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
ClrAssemblies..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
ClrAssemblies Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

ClrAssemblies Class
RedGate.SQLCompare.Engine Namespace


ClrAssemblies Properties

[image] [image]

SQL Data Compare API 12.0.40
ClrAssemblies Properties
ClrAssemblies Class See Also

The ClrAssemblies type exposes the following properties.

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

See Also

ClrAssemblies Class
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
ClrAssemblies..::.Item Property
ClrAssemblies Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns a CLR assembly given its identifier. (Overrides KeyedCollection <(Of <( T >)>)..::. Item[([(Int32])]).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

ClrAssemblies Class
ClrAssemblies Members
RedGate.SQLCompare.Engine Namespace


Item Property ()

[image]

SQL Data Compare API 12.0.40
ClrAssemblies..::.Item Property ()
ClrAssemblies Class See Also

Returns a CLR assembly given its identifier.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Default Property Item ( _
    index As Integer _
) As ClrAssembly
C#
public override ClrAssembly this[
    int index
] { get; }
Visual C++
public:
virtual property ClrAssembly^ default[int index] {
    ClrAssembly^ get (int index) override;
}

Parameters

index
Type: Int32
The system id of the assmebly.

Implements

IKeyedCollectionItem(Int32)

See Also

ClrAssemblies Class
Item Overload
RedGate.SQLCompare.Engine Namespace


ClrAssembliesChanges Class

[image]

SQL Data Compare API 12.0.40
ClrAssembliesChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ClrAssembliesChanges
C#
public sealed class ClrAssembliesChanges
Visual C++
public ref class ClrAssembliesChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ClrAssembliesChanges

See Also

ClrAssembliesChanges Members
RedGate.SQLCompare.Engine Namespace


ClrAssembliesChanges Members

[image] [image]

SQL Data Compare API 12.0.40
ClrAssembliesChanges Members
ClrAssembliesChanges Class Constructors Methods Properties See Also

The ClrAssembliesChanges type exposes the following members.

Constructors

Name | Description
ClrAssembliesChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AssemblyTargets |
ClrAssembliesToAlter |
ClrAssembliesToCreate |
ClrAssembliesToDrop |

See Also

ClrAssembliesChanges Class
RedGate.SQLCompare.Engine Namespace


ClrAssembliesChanges Constructor

[image]

SQL Data Compare API 12.0.40
ClrAssembliesChanges Constructor
ClrAssembliesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public ClrAssembliesChanges(
    bool caseSensitive
)
Visual C++
public:
ClrAssembliesChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

ClrAssembliesChanges Class
RedGate.SQLCompare.Engine Namespace


ClrAssembliesChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
ClrAssembliesChanges Properties
ClrAssembliesChanges Class See Also

The ClrAssembliesChanges type exposes the following properties.

Properties

Name | Description
AssemblyTargets |
ClrAssembliesToAlter |
ClrAssembliesToCreate |
ClrAssembliesToDrop |

See Also

ClrAssembliesChanges Class
RedGate.SQLCompare.Engine Namespace


AssemblyTargets Property

[image]

SQL Data Compare API 12.0.40
ClrAssembliesChanges..::.AssemblyTargets Property
ClrAssembliesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyTargets As Dictionary(Of ClrAssembly, ClrAssembly)
C#
public Dictionary<ClrAssembly, ClrAssembly> AssemblyTargets { get; private set; }
Visual C++
public:
property Dictionary<ClrAssembly^, ClrAssembly^>^ AssemblyTargets {
    Dictionary<ClrAssembly^, ClrAssembly^>^ get ();
    void set (Dictionary<ClrAssembly^, ClrAssembly^>^ value);
}

See Also

ClrAssembliesChanges Class
RedGate.SQLCompare.Engine Namespace


ClrAssembliesToAlter Property

[image]

SQL Data Compare API 12.0.40
ClrAssembliesChanges..::.ClrAssembliesToAlter Property
ClrAssembliesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ClrAssembliesToAlter As ClrAssemblies
C#
public ClrAssemblies ClrAssembliesToAlter { get; private set; }
Visual C++
public:
property ClrAssemblies^ ClrAssembliesToAlter {
    ClrAssemblies^ get ();
    void set (ClrAssemblies^ value);
}

See Also

ClrAssembliesChanges Class
RedGate.SQLCompare.Engine Namespace


ClrAssembliesToCreate Property

[image]

SQL Data Compare API 12.0.40
ClrAssembliesChanges..::.ClrAssembliesToCreate Property
ClrAssembliesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ClrAssembliesToCreate As ClrAssemblies
C#
public ClrAssemblies ClrAssembliesToCreate { get; private set; }
Visual C++
public:
property ClrAssemblies^ ClrAssembliesToCreate {
    ClrAssemblies^ get ();
    void set (ClrAssemblies^ value);
}

See Also

ClrAssembliesChanges Class
RedGate.SQLCompare.Engine Namespace


ClrAssembliesToDrop Property

[image]

SQL Data Compare API 12.0.40
ClrAssembliesChanges..::.ClrAssembliesToDrop Property
ClrAssembliesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ClrAssembliesToDrop As ClrAssemblies
C#
public ClrAssemblies ClrAssembliesToDrop { get; private set; }
Visual C++
public:
property ClrAssemblies^ ClrAssembliesToDrop {
    ClrAssemblies^ get ();
    void set (ClrAssemblies^ value);
}

See Also

ClrAssembliesChanges Class
RedGate.SQLCompare.Engine Namespace


ClrAssembly Class

[image]

SQL Data Compare API 12.0.40
ClrAssembly Class
Members See Also

A Common Language Runtime (CLR) assembly.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ClrAssembly _
    Inherits DatabaseObjectWithAuthorizationAndExtendedProperties _
    Implements IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck,  _
    IBinaryObject, IAssemblyMetadata, IPatchUpAfterDeserialization, ISqlComparable
C#
public sealed class ClrAssembly : DatabaseObjectWithAuthorizationAndExtendedProperties, IHasPermissions,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, IBinaryObject, IAssemblyMetadata,
    IPatchUpAfterDeserialization, ISqlComparable
Visual C++
public ref class ClrAssembly sealed : public DatabaseObjectWithAuthorizationAndExtendedProperties,
    IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck, IBinaryObject,
    IAssemblyMetadata, IPatchUpAfterDeserialization, ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorizationAndExtendedProperties
RedGate.SQLCompare.Engine..::.ClrAssembly

See Also

ClrAssembly Members
RedGate.SQLCompare.Engine Namespace


ClrAssembly Members

[image] [image]

SQL Data Compare API 12.0.40
ClrAssembly Members
ClrAssembly Class Methods Fields Properties Explicit Interface Implementations See Also

The ClrAssembly type exposes the following members.

Methods

Name | Description
CompareWith |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFileExtension |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryGetMetadata |
TryScriptObjectAsBinary |
WriteDllsToDirectory |

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AlterAuthorizationClassType | (Overrides DatabaseObjectWithAuthorization ..::. AlterAuthorizationClassType.)
CLRName | The CLR name of the assembly.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
Files | The files that belong to the assembly.
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
ID | The sysobject identifier for the CLR assembly.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Assembly (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
PermissionSet | The code access permission for the CLR assembly.
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)
ScriptSourceVisibility | The script source for any ALTER ASSEMBLY statements attached to this assembly other than adding files
Visibility | Indicates whether the assembly's visibility is set to on or off.

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

ClrAssembly Class
RedGate.SQLCompare.Engine Namespace


ClrAssembly Methods

[image] [image]

SQL Data Compare API 12.0.40
ClrAssembly Methods
ClrAssembly Class See Also

The ClrAssembly type exposes the following methods.

Methods

Name | Description
CompareWith |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFileExtension |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryGetMetadata |
TryScriptObjectAsBinary |
WriteDllsToDirectory |

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

ClrAssembly Class
RedGate.SQLCompare.Engine Namespace


CompareWith Method

[image]

SQL Data Compare API 12.0.40
ClrAssembly..::.CompareWith Method
ClrAssembly Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareWith ( _
    target As ClrAssembly, _
    options As Options _
) As IEnumerable(Of EqualityDifference)
C#
public IEnumerable<EqualityDifference> CompareWith(
    ClrAssembly target,
    Options options
)
Visual C++
public:
IEnumerable<EqualityDifference^>^ CompareWith(
    ClrAssembly^ target,
    Options options
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.ClrAssembly
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

ClrAssembly Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
ClrAssembly..::.ISqlComparable..::.CompareWith Method
ClrAssembly Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    other As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable other,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ other,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

other
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

ClrAssembly Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
ClrAssembly..::.Equals Method
ClrAssembly Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the assembly with a specified assembly. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

ClrAssembly Class
ClrAssembly Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
ClrAssembly..::.Equals Method (IDatabaseObject, Options)
ClrAssembly Class See Also

Compares the assembly with a specified assembly.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The assembly to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the assemblies are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

ClrAssembly Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


GetFileExtension Method

[image]

SQL Data Compare API 12.0.40
ClrAssembly..::.GetFileExtension Method
ClrAssembly Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFileExtension ( _
    isMainFile As Boolean, _
    options As Options _
) As String
C#
public static string GetFileExtension(
    bool isMainFile,
    Options options
)
Visual C++
public:
static String^ GetFileExtension(
    bool isMainFile,
    Options options
)

Parameters

isMainFile
Type: Boolean
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

ClrAssembly Class
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
ClrAssembly..::.PatchUpAfterDeserialization Method
ClrAssembly Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

ClrAssembly Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
ClrAssembly..::.ScriptObject Method
ClrAssembly Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options, e.g. quoted identifier on or off.
options
Type: RedGate.SQLCompare.Engine..::.Options
Options that may influence the scripting.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

ClrAssembly Class
RedGate.SQLCompare.Engine Namespace


TryGetMetadata Method

[image]

SQL Data Compare API 12.0.40
ClrAssembly..::.TryGetMetadata Method
ClrAssembly Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function TryGetMetadata ( _
    <OutAttribute> ByRef metadata As IAssemblyMetadata _
) As Boolean
C#
public bool TryGetMetadata(
    out IAssemblyMetadata metadata
)
Visual C++
public:
virtual bool TryGetMetadata(
    [OutAttribute] IAssemblyMetadata^% metadata
) sealed

Parameters

metadata
Type: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.IAssemblyMetadata %

Implements

IBinaryObject..::.TryGetMetadata(IAssemblyMetadata%)

See Also

ClrAssembly Class
RedGate.SQLCompare.Engine Namespace


TryScriptObjectAsBinary Method

[image]

SQL Data Compare API 12.0.40
ClrAssembly..::.TryScriptObjectAsBinary Method
ClrAssembly Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function TryScriptObjectAsBinary ( _
    file As FileInfo, _
    options As Options _
) As Boolean
C#
public bool TryScriptObjectAsBinary(
    FileInfo file,
    Options options
)
Visual C++
public:
virtual bool TryScriptObjectAsBinary(
    FileInfo^ file,
    Options options
) sealed

Parameters

file
Type: FileInfo
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

IBinaryObject..::.TryScriptObjectAsBinary(FileInfo, Options)

See Also

ClrAssembly Class
RedGate.SQLCompare.Engine Namespace


WriteDllsToDirectory Method

[image]

SQL Data Compare API 12.0.40
ClrAssembly..::.WriteDllsToDirectory Method
ClrAssembly Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteDllsToDirectory ( _
    dirInfo As DirectoryInfo _
)
C#
public void WriteDllsToDirectory(
    DirectoryInfo dirInfo
)
Visual C++
public:
void WriteDllsToDirectory(
    DirectoryInfo^ dirInfo
)

Parameters

dirInfo
Type: DirectoryInfo

See Also

ClrAssembly Class
RedGate.SQLCompare.Engine Namespace


ClrAssembly Properties

[image] [image]

SQL Data Compare API 12.0.40
ClrAssembly Properties
ClrAssembly Class See Also

The ClrAssembly type exposes the following properties.

Properties

Name | Description
AlterAuthorizationClassType | (Overrides DatabaseObjectWithAuthorization ..::. AlterAuthorizationClassType.)
CLRName | The CLR name of the assembly.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
Files | The files that belong to the assembly.
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
ID | The sysobject identifier for the CLR assembly.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Assembly (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
PermissionSet | The code access permission for the CLR assembly.
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)
ScriptSourceVisibility | The script source for any ALTER ASSEMBLY statements attached to this assembly other than adding files
Visibility | Indicates whether the assembly's visibility is set to on or off.

See Also

ClrAssembly Class
RedGate.SQLCompare.Engine Namespace


AlterAuthorizationClassType Property

[image]

SQL Data Compare API 12.0.40
ClrAssembly..::.AlterAuthorizationClassType Property
ClrAssembly Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property AlterAuthorizationClassType As String
C#
public override string AlterAuthorizationClassType { get; }
Visual C++
public:
virtual property String^ AlterAuthorizationClassType {
    String^ get () override;
}

Implements

IHasAuthorization..::.AlterAuthorizationClassType

See Also

ClrAssembly Class
RedGate.SQLCompare.Engine Namespace


CLRName Property

[image]

SQL Data Compare API 12.0.40
ClrAssembly..::.CLRName Property
ClrAssembly Class See Also

The CLR name of the assembly.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CLRName As String
C#
public string CLRName { get; internal set; }
Visual C++
public:
virtual property String^ CLRName {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IAssemblyMetadata..::.CLRName

See Also

ClrAssembly Class
RedGate.SQLCompare.Engine Namespace


Files Property

[image]

SQL Data Compare API 12.0.40
ClrAssembly..::.Files Property
ClrAssembly Class See Also

The files that belong to the assembly.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Files As ClrFiles
C#
public ClrFiles Files { get; }
Visual C++
public:
property ClrFiles^ Files {
    ClrFiles^ get ();
}

See Also

ClrAssembly Class
RedGate.SQLCompare.Engine Namespace


ID Property

[image]

SQL Data Compare API 12.0.40
ClrAssembly..::.ID Property
ClrAssembly Class See Also

The sysobject identifier for the CLR assembly.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ID As Integer
C#
public int ID { get; internal set; }
Visual C++
public:
property int ID {
    int get ();
    void set (int value);
}

See Also

ClrAssembly Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
ClrAssembly..::.ObjectType Property
ClrAssembly Class See Also

Returns ObjectType.Assembly

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()
ITSqlObjectObjectType()()()

See Also

ClrAssembly Class
RedGate.SQLCompare.Engine Namespace


PermissionSet Property

[image]

SQL Data Compare API 12.0.40
ClrAssembly..::.PermissionSet Property
ClrAssembly Class See Also

The code access permission for the CLR assembly.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PermissionSet As PermissionSet
C#
public PermissionSet PermissionSet { get; internal set; }
Visual C++
public:
virtual property PermissionSet PermissionSet {
    PermissionSet get () sealed;
    void set (PermissionSet value) sealed;
}

Implements

IAssemblyMetadata..::.PermissionSet

See Also

ClrAssembly Class
RedGate.SQLCompare.Engine Namespace


ScriptSourceVisibility Property

[image]

SQL Data Compare API 12.0.40
ClrAssembly..::.ScriptSourceVisibility Property
ClrAssembly Class See Also

The script source for any ALTER ASSEMBLY statements attached to this assembly other than adding files

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSourceVisibility As ScriptSource
C#
public ScriptSource ScriptSourceVisibility { get; internal set; }
Visual C++
public:
property ScriptSource^ ScriptSourceVisibility {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

ClrAssembly Class
RedGate.SQLCompare.Engine Namespace


Visibility Property

[image]

SQL Data Compare API 12.0.40
ClrAssembly..::.Visibility Property
ClrAssembly Class See Also

Indicates whether the assembly's visibility is set to on or off.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Visibility As Boolean
C#
public bool Visibility { get; internal set; }
Visual C++
public:
property bool Visibility {
    bool get ();
    void set (bool value);
}

See Also

ClrAssembly Class
RedGate.SQLCompare.Engine Namespace


CLRDowngradeWarningsCalculator Class

[image]

SQL Data Compare API 12.0.40
CLRDowngradeWarningsCalculator Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class CLRDowngradeWarningsCalculator
C#
public class CLRDowngradeWarningsCalculator
Visual C++
public ref class CLRDowngradeWarningsCalculator

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.CLRDowngradeWarningsCalculator

See Also

CLRDowngradeWarningsCalculator Members
RedGate.SQLCompare.Engine Namespace


CLRDowngradeWarningsCalculator Members

[image] [image]

SQL Data Compare API 12.0.40
CLRDowngradeWarningsCalculator Members
CLRDowngradeWarningsCalculator Class Constructors Methods See Also

The CLRDowngradeWarningsCalculator type exposes the following members.

Constructors

Name | Description
CLRDowngradeWarningsCalculator |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryWarnAboutCLRTrigger |
TryWarnAboutCLRUDT |

See Also

CLRDowngradeWarningsCalculator Class
RedGate.SQLCompare.Engine Namespace


CLRDowngradeWarningsCalculator Constructor

[image]

SQL Data Compare API 12.0.40
CLRDowngradeWarningsCalculator Constructor
CLRDowngradeWarningsCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    warnings As Messages _
)
C#
public CLRDowngradeWarningsCalculator(
    Messages warnings
)
Visual C++
public:
CLRDowngradeWarningsCalculator(
    Messages^ warnings
)

Parameters

warnings
Type: RedGate.SQLCompare.Engine..::.Messages

See Also

CLRDowngradeWarningsCalculator Class
RedGate.SQLCompare.Engine Namespace


CLRDowngradeWarningsCalculator Methods

[image] [image]

SQL Data Compare API 12.0.40
CLRDowngradeWarningsCalculator Methods
CLRDowngradeWarningsCalculator Class See Also

The CLRDowngradeWarningsCalculator type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryWarnAboutCLRTrigger |
TryWarnAboutCLRUDT |

See Also

CLRDowngradeWarningsCalculator Class
RedGate.SQLCompare.Engine Namespace


TryWarnAboutCLRTrigger Method

[image]

SQL Data Compare API 12.0.40
CLRDowngradeWarningsCalculator..::.TryWarnAboutCLRTrigger Method
CLRDowngradeWarningsCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function TryWarnAboutCLRTrigger ( _
    trigger As Trigger, _
    owner As IDatabaseObject, _
    targetDatabase As IDatabase, _
    options As Options _
) As Boolean
C#
public bool TryWarnAboutCLRTrigger(
    Trigger trigger,
    IDatabaseObject owner,
    IDatabase targetDatabase,
    Options options
)
Visual C++
public:
bool TryWarnAboutCLRTrigger(
    Trigger^ trigger,
    IDatabaseObject^ owner,
    IDatabase^ targetDatabase,
    Options options
)

Parameters

trigger
Type: RedGate.SQLCompare.Engine..::.Trigger
owner
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
targetDatabase
Type: RedGate.SQLCompare.Engine..::.IDatabase
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

CLRDowngradeWarningsCalculator Class
RedGate.SQLCompare.Engine Namespace


TryWarnAboutCLRUDT Method

[image]

SQL Data Compare API 12.0.40
CLRDowngradeWarningsCalculator..::.TryWarnAboutCLRUDT Method
CLRDowngradeWarningsCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function TryWarnAboutCLRUDT ( _
    type As UserDefinedType, _
    targetDatabase As IDatabase _
) As Boolean
C#
public bool TryWarnAboutCLRUDT(
    UserDefinedType type,
    IDatabase targetDatabase
)
Visual C++
public:
bool TryWarnAboutCLRUDT(
    UserDefinedType^ type,
    IDatabase^ targetDatabase
)

Parameters

type
Type: RedGate.SQLCompare.Engine..::.UserDefinedType
targetDatabase
Type: RedGate.SQLCompare.Engine..::.IDatabase

See Also

CLRDowngradeWarningsCalculator Class
RedGate.SQLCompare.Engine Namespace


ClrFile Class

[image]

SQL Data Compare API 12.0.40
ClrFile Class
Members See Also

A Common Language Runtime (CLR) file.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ClrFile _
    Inherits ScriptableDatabaseObject _
    Implements IBinaryObject, IDatabaseObject, ITSqlObject, ICanExistenceCheck,  _
    IPatchUpAfterDeserialization, ISqlComparable
C#
public sealed class ClrFile : ScriptableDatabaseObject, IBinaryObject,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, IPatchUpAfterDeserialization, ISqlComparable
Visual C++
public ref class ClrFile sealed : public ScriptableDatabaseObject,
    IBinaryObject, IDatabaseObject, ITSqlObject, ICanExistenceCheck, IPatchUpAfterDeserialization,
    ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.ClrFile

See Also

ClrFile Members
RedGate.SQLCompare.Engine Namespace


ClrFile Members

[image] [image]

SQL Data Compare API 12.0.40
ClrFile Members
ClrFile Class Methods Fields Properties Explicit Interface Implementations See Also

The ClrFile type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryGetMetadata |
TryScriptObjectAsBinary |

Operators

Name | Description
Equality |
Inequality |

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
Contents | The raw data of the CLR assembly file.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
Name | The name of the CLR file. (Overrides ScriptableDatabaseObject ..::. Name.)
ObjectType | (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

ClrFile Class
RedGate.SQLCompare.Engine Namespace


ClrFile Methods

[image] [image]

SQL Data Compare API 12.0.40
ClrFile Methods
ClrFile Class See Also

The ClrFile type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryGetMetadata |
TryScriptObjectAsBinary |

Operators

Name | Description
Equality |
Inequality |

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

ClrFile Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
ClrFile..::.ISqlComparable..::.CompareWith Method
ClrFile Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    obj As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable obj,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ obj,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

obj
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

ClrFile Class
RedGate.SQLCompare.Engine Namespace


Equality Operator

[image]

SQL Data Compare API 12.0.40
ClrFile..::.Equality Operator
ClrFile Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator = ( _
    left As ClrFile, _
    right As ClrFile _
) As Boolean
C#
public static bool operator ==(
    ClrFile left,
    ClrFile right
)
Visual C++
public:
static bool operator ==(
    ClrFile^ left,
    ClrFile^ right
)

Parameters

left
Type: RedGate.SQLCompare.Engine..::.ClrFile
right
Type: RedGate.SQLCompare.Engine..::.ClrFile

See Also

ClrFile Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
ClrFile..::.Equals Method
ClrFile Class See Also

Overload List

Name | Description
Equals(Object) | (Overrides Object..::.Equals(Object).)
Equals(IDatabaseObject, Options) | (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

ClrFile Class
ClrFile Members
RedGate.SQLCompare.Engine Namespace


Equals Method ()

[image]

SQL Data Compare API 12.0.40
ClrFile..::.Equals Method ()
ClrFile Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object

See Also

ClrFile Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
ClrFile..::.Equals Method (IDatabaseObject, Options)
ClrFile Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) override

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

ClrFile Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
ClrFile..::.GetHashCode Method
ClrFile Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

See Also

ClrFile Class
RedGate.SQLCompare.Engine Namespace


Inequality Operator

[image]

SQL Data Compare API 12.0.40
ClrFile..::.Inequality Operator
ClrFile Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <> ( _
    left As ClrFile, _
    right As ClrFile _
) As Boolean
C#
public static bool operator !=(
    ClrFile left,
    ClrFile right
)
Visual C++
public:
static bool operator !=(
    ClrFile^ left,
    ClrFile^ right
)

Parameters

left
Type: RedGate.SQLCompare.Engine..::.ClrFile
right
Type: RedGate.SQLCompare.Engine..::.ClrFile

See Also

ClrFile Class
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
ClrFile..::.PatchUpAfterDeserialization Method
ClrFile Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

ClrFile Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
ClrFile..::.ScriptObject Method
ClrFile Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
options
Type: RedGate.SQLCompare.Engine..::.Options
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

See Also

ClrFile Class
RedGate.SQLCompare.Engine Namespace


TryGetMetadata Method

[image]

SQL Data Compare API 12.0.40
ClrFile..::.TryGetMetadata Method
ClrFile Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function TryGetMetadata ( _
    <OutAttribute> ByRef metadata As IAssemblyMetadata _
) As Boolean
C#
public bool TryGetMetadata(
    out IAssemblyMetadata metadata
)
Visual C++
public:
virtual bool TryGetMetadata(
    [OutAttribute] IAssemblyMetadata^% metadata
) sealed

Parameters

metadata
Type: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.IAssemblyMetadata %

Implements

IBinaryObject..::.TryGetMetadata(IAssemblyMetadata%)

See Also

ClrFile Class
RedGate.SQLCompare.Engine Namespace


TryScriptObjectAsBinary Method

[image]

SQL Data Compare API 12.0.40
ClrFile..::.TryScriptObjectAsBinary Method
ClrFile Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function TryScriptObjectAsBinary ( _
    file As FileInfo, _
    options As Options _
) As Boolean
C#
public bool TryScriptObjectAsBinary(
    FileInfo file,
    Options options
)
Visual C++
public:
virtual bool TryScriptObjectAsBinary(
    FileInfo^ file,
    Options options
) sealed

Parameters

file
Type: FileInfo
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

IBinaryObject..::.TryScriptObjectAsBinary(FileInfo, Options)

See Also

ClrFile Class
RedGate.SQLCompare.Engine Namespace


ClrFile Properties

[image] [image]

SQL Data Compare API 12.0.40
ClrFile Properties
ClrFile Class See Also

The ClrFile type exposes the following properties.

Properties

Name | Description
Contents | The raw data of the CLR assembly file.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
Name | The name of the CLR file. (Overrides ScriptableDatabaseObject ..::. Name.)
ObjectType | (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)

See Also

ClrFile Class
RedGate.SQLCompare.Engine Namespace


Contents Property

[image]

SQL Data Compare API 12.0.40
ClrFile..::.Contents Property
ClrFile Class See Also

The raw data of the CLR assembly file.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Contents As Byte()
C#
public byte[] Contents { get; }
Visual C++
public:
property array<unsigned char>^ Contents {
    array<unsigned char>^ get ();
}

See Also

ClrFile Class
RedGate.SQLCompare.Engine Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
ClrFile..::.Name Property
ClrFile Class See Also

The name of the CLR file.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property Name As String
C#
public override string Name { get; internal set; }
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}

Implements

ITSqlObjectName()()()
ITSqlObjectName()()()

See Also

ClrFile Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
ClrFile..::.ObjectType Property
ClrFile Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()
ITSqlObjectObjectType()()()

See Also

ClrFile Class
RedGate.SQLCompare.Engine Namespace


ClrFiles Class

[image]

SQL Data Compare API 12.0.40
ClrFiles Class
Members See Also

A collection of CLR files.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ClrFiles _
    Inherits InnerList(Of ClrFile) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class ClrFiles : InnerList<ClrFile>, IPatchUpAfterDeserialization
Visual C++
public ref class ClrFiles sealed : public InnerList<ClrFile^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( T >)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( ClrFile >)>)
RedGate.SQLCompare.Engine..::.ClrFiles

See Also

ClrFiles Members
RedGate.SQLCompare.Engine Namespace


ClrFiles Members

[image] [image]

SQL Data Compare API 12.0.40
ClrFiles Members
ClrFiles Class Methods Properties Explicit Interface Implementations See Also

The ClrFiles type exposes the following members.

Methods

Name | Description
Contains | (Inherited from InnerList<(Of <(T>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | (Inherited from InnerList<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

ClrFiles Class
RedGate.SQLCompare.Engine Namespace


ClrFiles Methods

[image] [image]

SQL Data Compare API 12.0.40
ClrFiles Methods
ClrFiles Class See Also

The ClrFiles type exposes the following methods.

Methods

Name | Description
Contains | (Inherited from InnerList<(Of <(T>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

ClrFiles Class
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
ClrFiles..::.PatchUpAfterDeserialization Method
ClrFiles Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

ClrFiles Class
RedGate.SQLCompare.Engine Namespace


ColumnPairReference Structure

[image]

SQL Data Compare API 12.0.40
ColumnPairReference Structure
Members See Also

A reference to a column pair

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Structure ColumnPairReference
C#
public struct ColumnPairReference
Visual C++
public value class ColumnPairReference

See Also

ColumnPairReference Members
RedGate.SQLCompare.Engine Namespace


ColumnPairReference Members

[image] [image]

SQL Data Compare API 12.0.40
ColumnPairReference Members
ColumnPairReference Structure Constructors Methods Fields See Also

The ColumnPairReference type exposes the following members.

Constructors

Name | Description
ColumnPairReference | Creates a new reference to two columns

Methods

Name | Description
Equals | (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

Name | Description
Col1 | A column reference to the first column
Col2 | A column reference to the second column

See Also

ColumnPairReference Structure
RedGate.SQLCompare.Engine Namespace


ColumnPairReference Constructor

[image]

SQL Data Compare API 12.0.40
ColumnPairReference Constructor
ColumnPairReference Structure See Also

Creates a new reference to two columns

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    one As ColumnReference, _
    two As ColumnReference _
)
C#
public ColumnPairReference(
    ColumnReference one,
    ColumnReference two
)
Visual C++
public:
ColumnPairReference(
    ColumnReference one,
    ColumnReference two
)

Parameters

one
Type: RedGate.SQLCompare.Engine..::.ColumnReference
A reference to the first column
two
Type: RedGate.SQLCompare.Engine..::.ColumnReference
A reference to the second column

See Also

ColumnPairReference Structure
RedGate.SQLCompare.Engine Namespace


ColumnPairReference Fields

[image] [image]

SQL Data Compare API 12.0.40
ColumnPairReference Fields
ColumnPairReference Structure See Also

The ColumnPairReference type exposes the following fields.

Fields

Name | Description
Col1 | A column reference to the first column
Col2 | A column reference to the second column

See Also

ColumnPairReference Structure
RedGate.SQLCompare.Engine Namespace


Col1 Field

[image]

SQL Data Compare API 12.0.40
ColumnPairReference..::.Col1 Field
ColumnPairReference Structure See Also

A column reference to the first column

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Col1 As ColumnReference
C#
public ColumnReference Col1
Visual C++
public:
ColumnReference Col1

See Also

ColumnPairReference Structure
RedGate.SQLCompare.Engine Namespace


Col2 Field

[image]

SQL Data Compare API 12.0.40
ColumnPairReference..::.Col2 Field
ColumnPairReference Structure See Also

A column reference to the second column

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Col2 As ColumnReference
C#
public ColumnReference Col2
Visual C++
public:
ColumnReference Col2

See Also

ColumnPairReference Structure
RedGate.SQLCompare.Engine Namespace


ColumnPairReference Methods

[image] [image]

SQL Data Compare API 12.0.40
ColumnPairReference Methods
ColumnPairReference Structure See Also

The ColumnPairReference type exposes the following methods.

Methods

Name | Description
Equals | (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

ColumnPairReference Structure
RedGate.SQLCompare.Engine Namespace


Equals Method

[image]

SQL Data Compare API 12.0.40
ColumnPairReference..::.Equals Method
ColumnPairReference Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object

See Also

ColumnPairReference Structure
RedGate.SQLCompare.Engine Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
ColumnPairReference..::.GetHashCode Method
ColumnPairReference Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

See Also

ColumnPairReference Structure
RedGate.SQLCompare.Engine Namespace


ColumnReference Structure

[image]

SQL Data Compare API 12.0.40
ColumnReference Structure
Members See Also

A reference to a column

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Structure ColumnReference
C#
public struct ColumnReference
Visual C++
public value class ColumnReference

See Also

ColumnReference Members
RedGate.SQLCompare.Engine Namespace


ColumnReference Members

[image] [image]

SQL Data Compare API 12.0.40
ColumnReference Members
ColumnReference Structure Constructors Methods Fields See Also

The ColumnReference type exposes the following members.

Constructors

Name | Description
ColumnReference | Creates a new column reference

Methods

Name | Description
Equals | (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

Name | Description
ColumnName | The columns name
TableName | The tables name

See Also

ColumnReference Structure
RedGate.SQLCompare.Engine Namespace


ColumnReference Constructor

[image]

SQL Data Compare API 12.0.40
ColumnReference Constructor
ColumnReference Structure See Also

Creates a new column reference

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    tm As Mapping(Of ViewTableSuperClass), _
    fm As Mapping(Of IField) _
)
C#
public ColumnReference(
    Mapping<ViewTableSuperClass> tm,
    Mapping<IField> fm
)
Visual C++
public:
ColumnReference(
    Mapping<ViewTableSuperClass^>^ tm,
    Mapping<IField^>^ fm
)

Parameters

tm
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( ViewTableSuperClass >)>)
The table mapping of the table to reference
fm
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( IField >)>)
The field mapping of the field to reference

See Also

ColumnReference Structure
RedGate.SQLCompare.Engine Namespace


ColumnReference Fields

[image] [image]

SQL Data Compare API 12.0.40
ColumnReference Fields
ColumnReference Structure See Also

The ColumnReference type exposes the following fields.

Fields

Name | Description
ColumnName | The columns name
TableName | The tables name

See Also

ColumnReference Structure
RedGate.SQLCompare.Engine Namespace


ColumnName Field

[image]

SQL Data Compare API 12.0.40
ColumnReference..::.ColumnName Field
ColumnReference Structure See Also

The columns name

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public ColumnName As String
C#
public string ColumnName
Visual C++
public:
String^ ColumnName

See Also

ColumnReference Structure
RedGate.SQLCompare.Engine Namespace


TableName Field

[image]

SQL Data Compare API 12.0.40
ColumnReference..::.TableName Field
ColumnReference Structure See Also

The tables name

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public TableName As String
C#
public string TableName
Visual C++
public:
String^ TableName

See Also

ColumnReference Structure
RedGate.SQLCompare.Engine Namespace


ColumnReference Methods

[image] [image]

SQL Data Compare API 12.0.40
ColumnReference Methods
ColumnReference Structure See Also

The ColumnReference type exposes the following methods.

Methods

Name | Description
Equals | (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

ColumnReference Structure
RedGate.SQLCompare.Engine Namespace


Equals Method

[image]

SQL Data Compare API 12.0.40
ColumnReference..::.Equals Method
ColumnReference Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object

See Also

ColumnReference Structure
RedGate.SQLCompare.Engine Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
ColumnReference..::.GetHashCode Method
ColumnReference Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

See Also

ColumnReference Structure
RedGate.SQLCompare.Engine Namespace


ComparisonOptions Enumeration

[image]

SQL Data Compare API 12.0.40
ComparisonOptions Enumeration
See Also

Options used when comparing databases.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration ComparisonOptions
C#
[FlagsAttribute]
public enum ComparisonOptions
Visual C++
[FlagsAttribute]
public enum class ComparisonOptions

Members

Member name | Description
Default | None.
None | None.
TrimTrailingSpaces | If two columns of data differ only by the number of spaces at the end of the string, SQL Data Compare considers the data to be identical. The trailing spaces are not included in the synchronization script. This option does not apply to CLR or variant columns.
ForceBinaryCollation | For all string data types, forces binary collation irrespective of column collation, resulting in a case-sensitive comparison. When this option is selected and the comparison key is a string, this may result in slower performance because the indexes are not used.
UseChecksumComparison | When you are comparing tables or views with a large volume of data that changes infrequently, if you set this option, a checksum is used to compare the data. If the checksums differ, the data is compared; if the checksums are the same, the data is not compared. On SQL Server 2000 the connected user must be a member of the db_owner role or the system administrator role. This option applies only to SQL Server 2000 or later.
CompressTemporaryFiles | Compresses the temporary files that SQL Data Compare generates while performing the comparison. This reduces the possibility of running out of temporary disk space when comparing very large databases. When you select this option, you will not be able to sort the results of the comparison.
TreatEmptyStringAsNull | Treat an empty string and null as equal for varchar, nvarchar
UseFullPrecisionForComparison |

See Also

RedGate.SQLCompare.Engine Namespace


ConnectionProperties Class

[image]

SQL Data Compare API 12.0.40
ConnectionProperties Class
Members See Also

Serializable connection properties used to connect to a SQL Server database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ConnectionProperties _
    Inherits SqlConnectionProperties _
    Implements ISerializable
C#
[SerializableAttribute]
public class ConnectionProperties : SqlConnectionProperties, ISerializable
Visual C++
[SerializableAttribute]
public ref class ConnectionProperties : public SqlConnectionProperties,
    ISerializable

Inheritance Hierarchy

Object
RedGate.Shared.SQL..::.SqlConnectionProperties
RedGate.SQLCompare.Engine..::.ConnectionProperties

See Also

ConnectionProperties Members
RedGate.SQLCompare.Engine Namespace


ConnectionProperties Members

[image] [image]

SQL Data Compare API 12.0.40
ConnectionProperties Members
ConnectionProperties Class Constructors Methods Fields Properties See Also

The ConnectionProperties type exposes the following members.

Constructors

Name | Description
ConnectionProperties | Overloaded.

Methods

Name | Description
BuildConnectionString | (Inherited from SqlConnectionProperties.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
ForBackup |
FromSqlConnectionProperties |
FromSqlConnectionStringBuilder |
GetCachedConnectionString | (Inherited from SqlConnectionProperties.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | Used in serialization.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToDBConnectionInformation | Returns a DBConnectionInformation object representing the current connection properties. (Inherited from SqlConnectionProperties.)
ToString | (Inherited from SqlConnectionProperties.)

Fields

Name | Description
m_ConnectionString | (Inherited from SqlConnectionProperties.)
m_DatabaseName | (Inherited from SqlConnectionProperties.)
m_IntegratedSecurity | (Inherited from SqlConnectionProperties.)
m_ServerName | (Inherited from SqlConnectionProperties.)
m_UserName | (Inherited from SqlConnectionProperties.)

Properties

Name | Description
ConnectionString | (Inherited from SqlConnectionProperties.)
DatabaseName | The name of the database to connect to. (Inherited from SqlConnectionProperties.)
EncryptedPassword | (Inherited from SqlConnectionProperties.)
IntegratedSecurity | True to use integrated authentication, false for SQL Server authentication. (Inherited from SqlConnectionProperties.)
Password | The password to use when connecting to the SQL Server. (Inherited from SqlConnectionProperties.)
ServerName | The name of the SQL Server to connect to. (Inherited from SqlConnectionProperties.)
UserName | The user name to use when connecting to the SQL Server. (Inherited from SqlConnectionProperties.)

See Also

ConnectionProperties Class
RedGate.SQLCompare.Engine Namespace


ConnectionProperties Constructor

[image] [image]

SQL Data Compare API 12.0.40
ConnectionProperties Constructor
ConnectionProperties Class See Also

Overload List

Name | Description
ConnectionProperties()()() | Constructor for the ConnectionProperties class.
ConnectionProperties(String, String) | Constructor for integrated security.
ConnectionProperties(String, String, String, String) | Constructor for SQL security.

See Also

ConnectionProperties Class
ConnectionProperties Members
RedGate.SQLCompare.Engine Namespace


ConnectionProperties Constructor

[image]

SQL Data Compare API 12.0.40
ConnectionProperties Constructor
ConnectionProperties Class See Also

Constructor for the ConnectionProperties class.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ConnectionProperties()
Visual C++
public:
ConnectionProperties()

See Also

ConnectionProperties Class
ConnectionProperties Overload
RedGate.SQLCompare.Engine Namespace


ConnectionProperties Constructor (, )

[image]

SQL Data Compare API 12.0.40
ConnectionProperties Constructor (, )
ConnectionProperties Class See Also

Constructor for integrated security.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    serverName As String, _
    databaseName As String _
)
C#
public ConnectionProperties(
    string serverName,
    string databaseName
)
Visual C++
public:
ConnectionProperties(
    String^ serverName,
    String^ databaseName
)

Parameters

serverName
Type: String
The SQL Server name.
databaseName
Type: String
The database name.

See Also

ConnectionProperties Class
ConnectionProperties Overload
RedGate.SQLCompare.Engine Namespace


ConnectionProperties Constructor (, , , )

[image]

SQL Data Compare API 12.0.40
ConnectionProperties Constructor (, , , )
ConnectionProperties Class See Also

Constructor for SQL security.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    serverName As String, _
    databaseName As String, _
    userName As String, _
    password As String _
)
C#
public ConnectionProperties(
    string serverName,
    string databaseName,
    string userName,
    string password
)
Visual C++
public:
ConnectionProperties(
    String^ serverName,
    String^ databaseName,
    String^ userName,
    String^ password
)

Parameters

serverName
Type: String
The SQL Server name.
databaseName
Type: String
The database name.
userName
Type: String
The user name to use to connect to the SQL Server.
password
Type: String
The password to use to connect to the SQL Server.

See Also

ConnectionProperties Class
ConnectionProperties Overload
RedGate.SQLCompare.Engine Namespace


ConnectionProperties Methods

[image] [image]

SQL Data Compare API 12.0.40
ConnectionProperties Methods
ConnectionProperties Class See Also

The ConnectionProperties type exposes the following methods.

Methods

Name | Description
BuildConnectionString | (Inherited from SqlConnectionProperties.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
ForBackup |
FromSqlConnectionProperties |
FromSqlConnectionStringBuilder |
GetCachedConnectionString | (Inherited from SqlConnectionProperties.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | Used in serialization.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToDBConnectionInformation | Returns a DBConnectionInformation object representing the current connection properties. (Inherited from SqlConnectionProperties.)
ToString | (Inherited from SqlConnectionProperties.)

See Also

ConnectionProperties Class
RedGate.SQLCompare.Engine Namespace


ForBackup Method

[image]

SQL Data Compare API 12.0.40
ConnectionProperties..::.ForBackup Method
ConnectionProperties Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ForBackup ( _
    filePaths As ICollection(Of String), _
    passwords As ICollection(Of String), _
    backupSet As IBackupSet, _
    ignoreWrongPasswords As Boolean _
) As ConnectionProperties
C#
public static ConnectionProperties ForBackup(
    ICollection<string> filePaths,
    ICollection<string> passwords,
    IBackupSet backupSet,
    bool ignoreWrongPasswords
)
Visual C++
public:
static ConnectionProperties^ ForBackup(
    ICollection<String^>^ filePaths,
    ICollection<String^>^ passwords,
    IBackupSet^ backupSet,
    bool ignoreWrongPasswords
)

Parameters

filePaths
Type: ICollection<(Of <(String>)>)
passwords
Type: ICollection<(Of <(String>)>)
backupSet
Type: RedGate.Shared.SQL.BackupReaderInterfaces..::.IBackupSet
ignoreWrongPasswords
Type: Boolean

See Also

ConnectionProperties Class
RedGate.SQLCompare.Engine Namespace


FromSqlConnectionProperties Method

[image]

SQL Data Compare API 12.0.40
ConnectionProperties..::.FromSqlConnectionProperties Method
ConnectionProperties Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FromSqlConnectionProperties ( _
    properties As SqlConnectionProperties _
) As ConnectionProperties
C#
public static ConnectionProperties FromSqlConnectionProperties(
    SqlConnectionProperties properties
)
Visual C++
public:
static ConnectionProperties^ FromSqlConnectionProperties(
    SqlConnectionProperties^ properties
)

Parameters

properties
Type: RedGate.Shared.SQL..::.SqlConnectionProperties

See Also

ConnectionProperties Class
RedGate.SQLCompare.Engine Namespace


FromSqlConnectionStringBuilder Method

[image]

SQL Data Compare API 12.0.40
ConnectionProperties..::.FromSqlConnectionStringBuilder Method
ConnectionProperties Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FromSqlConnectionStringBuilder ( _
    connectionStringBuilder As SqlConnectionStringBuilder _
) As ConnectionProperties
C#
public static ConnectionProperties FromSqlConnectionStringBuilder(
    SqlConnectionStringBuilder connectionStringBuilder
)
Visual C++
public:
static ConnectionProperties^ FromSqlConnectionStringBuilder(
    SqlConnectionStringBuilder^ connectionStringBuilder
)

Parameters

connectionStringBuilder
Type: SqlConnectionStringBuilder

See Also

ConnectionProperties Class
RedGate.SQLCompare.Engine Namespace


GetObjectData Method

[image]

SQL Data Compare API 12.0.40
ConnectionProperties..::.GetObjectData Method
ConnectionProperties Class See Also

Used in serialization.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: SerializationInfo
The object that holds the serialized object data.
context
Type: StreamingContext
The contextual information about the source or destination.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)

See Also

ConnectionProperties Class
RedGate.SQLCompare.Engine Namespace


Contract Class

[image]

SQL Data Compare API 12.0.40
Contract Class
Members See Also

A contract.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Contract _
    Inherits DatabaseObjectWithAuthorizationAndExtendedProperties _
    Implements IIsSystemObject, IDatabaseObject, ITSqlObject, ICanExistenceCheck,  _
    IHasPermissions, IPatchUpAfterDeserialization, ISqlComparable
C#
public sealed class Contract : DatabaseObjectWithAuthorizationAndExtendedProperties, IIsSystemObject,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, IHasPermissions, IPatchUpAfterDeserialization,
    ISqlComparable
Visual C++
public ref class Contract sealed : public DatabaseObjectWithAuthorizationAndExtendedProperties,
    IIsSystemObject, IDatabaseObject, ITSqlObject, ICanExistenceCheck, IHasPermissions,
    IPatchUpAfterDeserialization, ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorizationAndExtendedProperties
RedGate.SQLCompare.Engine..::.Contract

See Also

Contract Members
RedGate.SQLCompare.Engine Namespace


Contract Members

[image] [image]

SQL Data Compare API 12.0.40
Contract Members
Contract Class Methods Fields Properties Explicit Interface Implementations See Also

The Contract type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AlterAuthorizationClassType | (Overrides DatabaseObjectWithAuthorization ..::. AlterAuthorizationClassType.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
IsSystemObject | Indicates whether the object is a system object.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Assembly (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)
Services | The services that depend on the contract.
Usages | The message types used by the contract.

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

Contract Class
RedGate.SQLCompare.Engine Namespace


Contract Methods

[image] [image]

SQL Data Compare API 12.0.40
Contract Methods
Contract Class See Also

The Contract type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

Contract Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
Contract..::.ISqlComparable..::.CompareWith Method
Contract Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    obj As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable obj,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ obj,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

obj
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

Contract Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
Contract..::.Equals Method
Contract Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the contract with a specified contract. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

Contract Class
Contract Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
Contract..::.Equals Method (IDatabaseObject, Options)
Contract Class See Also

Compares the contract with a specified contract.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The contract to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the contracts are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

Contract Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
Contract..::.PatchUpAfterDeserialization Method
Contract Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

Contract Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
Contract..::.ScriptObject Method
Contract Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

Contract Class
RedGate.SQLCompare.Engine Namespace


Contract Properties

[image] [image]

SQL Data Compare API 12.0.40
Contract Properties
Contract Class See Also

The Contract type exposes the following properties.

Properties

Name | Description
AlterAuthorizationClassType | (Overrides DatabaseObjectWithAuthorization ..::. AlterAuthorizationClassType.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
IsSystemObject | Indicates whether the object is a system object.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Assembly (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)
Services | The services that depend on the contract.
Usages | The message types used by the contract.

See Also

Contract Class
RedGate.SQLCompare.Engine Namespace


AlterAuthorizationClassType Property

[image]

SQL Data Compare API 12.0.40
Contract..::.AlterAuthorizationClassType Property
Contract Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property AlterAuthorizationClassType As String
C#
public override string AlterAuthorizationClassType { get; }
Visual C++
public:
virtual property String^ AlterAuthorizationClassType {
    String^ get () override;
}

Implements

IHasAuthorization..::.AlterAuthorizationClassType

See Also

Contract Class
RedGate.SQLCompare.Engine Namespace


IsSystemObject Property

[image]

SQL Data Compare API 12.0.40
Contract..::.IsSystemObject Property
Contract Class See Also

Indicates whether the object is a system object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSystemObject As Boolean
C#
public bool IsSystemObject { get; private set; }
Visual C++
public:
virtual property bool IsSystemObject {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IIsSystemObject..::.IsSystemObject

See Also

Contract Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
Contract..::.ObjectType Property
Contract Class See Also

Returns ObjectType.Assembly

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()
ITSqlObjectObjectType()()()

See Also

Contract Class
RedGate.SQLCompare.Engine Namespace


Services Property

[image]

SQL Data Compare API 12.0.40
Contract..::.Services Property
Contract Class See Also

The services that depend on the contract.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Services As Services
C#
public Services Services { get; }
Visual C++
public:
property Services^ Services {
    Services^ get ();
}

See Also

Contract Class
RedGate.SQLCompare.Engine Namespace


Usages Property

[image]

SQL Data Compare API 12.0.40
Contract..::.Usages Property
Contract Class See Also

The message types used by the contract.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Usages As MessageUsages
C#
public MessageUsages Usages { get; }
Visual C++
public:
property MessageUsages^ Usages {
    MessageUsages^ get ();
}

See Also

Contract Class
RedGate.SQLCompare.Engine Namespace


Contracts Class

[image]

SQL Data Compare API 12.0.40
Contracts Class
Members See Also

A collection of contracts.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Contracts _
    Inherits SerializableDatabaseObjectCollection(Of Contract) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class Contracts : SerializableDatabaseObjectCollection<Contract>, IPatchUpAfterDeserialization
Visual C++
public ref class Contracts sealed : public SerializableDatabaseObjectCollection<Contract^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Contract >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( Contract >)>)
RedGate.SQLCompare.Engine..::.Contracts

See Also

Contracts Members
RedGate.SQLCompare.Engine Namespace


Contracts Members

[image] [image]

SQL Data Compare API 12.0.40
Contracts Members
Contracts Class Methods Fields Properties Explicit Interface Implementations See Also

The Contracts type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

Contracts Class
RedGate.SQLCompare.Engine Namespace


Contracts Methods

[image] [image]

SQL Data Compare API 12.0.40
Contracts Methods
Contracts Class See Also

The Contracts type exposes the following methods.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

Contracts Class
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
Contracts..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
Contracts Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

Contracts Class
RedGate.SQLCompare.Engine Namespace


ContractsChanges Class

[image]

SQL Data Compare API 12.0.40
ContractsChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ContractsChanges
C#
public sealed class ContractsChanges
Visual C++
public ref class ContractsChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ContractsChanges

See Also

ContractsChanges Members
RedGate.SQLCompare.Engine Namespace


ContractsChanges Members

[image] [image]

SQL Data Compare API 12.0.40
ContractsChanges Members
ContractsChanges Class Constructors Methods Properties See Also

The ContractsChanges type exposes the following members.

Constructors

Name | Description
ContractsChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ContractsToAlter |
ContractsToCreate |
ContractsToDrop |
ContractTargets |

See Also

ContractsChanges Class
RedGate.SQLCompare.Engine Namespace


ContractsChanges Constructor

[image]

SQL Data Compare API 12.0.40
ContractsChanges Constructor
ContractsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public ContractsChanges(
    bool caseSensitive
)
Visual C++
public:
ContractsChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

ContractsChanges Class
RedGate.SQLCompare.Engine Namespace


ContractsChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
ContractsChanges Properties
ContractsChanges Class See Also

The ContractsChanges type exposes the following properties.

Properties

Name | Description
ContractsToAlter |
ContractsToCreate |
ContractsToDrop |
ContractTargets |

See Also

ContractsChanges Class
RedGate.SQLCompare.Engine Namespace


ContractsToAlter Property

[image]

SQL Data Compare API 12.0.40
ContractsChanges..::.ContractsToAlter Property
ContractsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ContractsToAlter As Contracts
C#
public Contracts ContractsToAlter { get; private set; }
Visual C++
public:
property Contracts^ ContractsToAlter {
    Contracts^ get ();
    void set (Contracts^ value);
}

See Also

ContractsChanges Class
RedGate.SQLCompare.Engine Namespace


ContractsToCreate Property

[image]

SQL Data Compare API 12.0.40
ContractsChanges..::.ContractsToCreate Property
ContractsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ContractsToCreate As Contracts
C#
public Contracts ContractsToCreate { get; private set; }
Visual C++
public:
property Contracts^ ContractsToCreate {
    Contracts^ get ();
    void set (Contracts^ value);
}

See Also

ContractsChanges Class
RedGate.SQLCompare.Engine Namespace


ContractsToDrop Property

[image]

SQL Data Compare API 12.0.40
ContractsChanges..::.ContractsToDrop Property
ContractsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ContractsToDrop As Contracts
C#
public Contracts ContractsToDrop { get; private set; }
Visual C++
public:
property Contracts^ ContractsToDrop {
    Contracts^ get ();
    void set (Contracts^ value);
}

See Also

ContractsChanges Class
RedGate.SQLCompare.Engine Namespace


ContractTargets Property

[image]

SQL Data Compare API 12.0.40
ContractsChanges..::.ContractTargets Property
ContractsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ContractTargets As Dictionary(Of Contract, Contract)
C#
public Dictionary<Contract, Contract> ContractTargets { get; private set; }
Visual C++
public:
property Dictionary<Contract^, Contract^>^ ContractTargets {
    Dictionary<Contract^, Contract^>^ get ();
    void set (Dictionary<Contract^, Contract^>^ value);
}

See Also

ContractsChanges Class
RedGate.SQLCompare.Engine Namespace


CycleDetectedException Class

[image]

SQL Data Compare API 12.0.40
CycleDetectedException Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class CycleDetectedException _
    Inherits Exception
C#
public class CycleDetectedException : Exception
Visual C++
public ref class CycleDetectedException : public Exception

Inheritance Hierarchy

Object
Exception
RedGate.SQLCompare.Engine..::.CycleDetectedException

See Also

CycleDetectedException Members
RedGate.SQLCompare.Engine Namespace


CycleDetectedException Members

[image] [image]

SQL Data Compare API 12.0.40
CycleDetectedException Members
CycleDetectedException Class Constructors Methods Properties See Also

The CycleDetectedException type exposes the following members.

Constructors

Name | Description
CycleDetectedException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CycleDetectedException Class
RedGate.SQLCompare.Engine Namespace


CycleDetectedException Constructor

[image] [image]

SQL Data Compare API 12.0.40
CycleDetectedException Constructor
CycleDetectedException Class See Also

Overload List

Name | Description
CycleDetectedException()()() |
CycleDetectedException(IEnumerable<(Of <(Object>)>)) |
CycleDetectedException(SerializationInfo, StreamingContext) |

See Also

CycleDetectedException Class
CycleDetectedException Members
RedGate.SQLCompare.Engine Namespace


CycleDetectedException Constructor

[image]

SQL Data Compare API 12.0.40
CycleDetectedException Constructor
CycleDetectedException Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CycleDetectedException()
Visual C++
public:
CycleDetectedException()

See Also

CycleDetectedException Class
CycleDetectedException Overload
RedGate.SQLCompare.Engine Namespace


CycleDetectedException Constructor (())

[image]

SQL Data Compare API 12.0.40
CycleDetectedException Constructor (<(Of <(>)>))
CycleDetectedException Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    sortRequired As IEnumerable(Of Object) _
)
C#
public CycleDetectedException(
    IEnumerable<Object> sortRequired
)
Visual C++
public:
CycleDetectedException(
    IEnumerable<Object^>^ sortRequired
)

Parameters

sortRequired
Type: IEnumerable<(Of <(Object>)>)

See Also

CycleDetectedException Class
CycleDetectedException Overload
RedGate.SQLCompare.Engine Namespace


CycleDetectedException Constructor (, )

[image]

SQL Data Compare API 12.0.40
CycleDetectedException Constructor (, )
CycleDetectedException Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
public CycleDetectedException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
public:
CycleDetectedException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: SerializationInfo
context
Type: StreamingContext

See Also

CycleDetectedException Class
CycleDetectedException Overload
RedGate.SQLCompare.Engine Namespace


Database Class

[image]

SQL Data Compare API 12.0.40
Database Class
Members See Also

This is a (vaguely temporary) class used to reduce the number of new items added to Database's interface. Use one of the interfaces this class implements where possible, since those will behave consistenly between the two classes.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class Database _
    Inherits ObjectCollections _
    Implements IDatabase, ICancellable, ICloneable, IVersionedDatabase,  _
    ICancellationStatus, IDatabaseObjects, IDisposable, IComparableDatabase
C#
public class Database : ObjectCollections, IDatabase,
    ICancellable, ICloneable, IVersionedDatabase, ICancellationStatus, IDatabaseObjects,
    IDisposable, IComparableDatabase
Visual C++
public ref class Database : public ObjectCollections,
    IDatabase, ICancellable, ICloneable, IVersionedDatabase, ICancellationStatus,
    IDatabaseObjects, IDisposable, IComparableDatabase

Remarks

See IDatabase documentation for usage

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ObjectCollections
RedGate.SQLCompare.Engine..::.Database
RedGate.SQLCompare.Engine.ReadFromBackup..::.BackupSetDatabase

See Also

Database Members
RedGate.SQLCompare.Engine Namespace


Database Members

[image] [image]

SQL Data Compare API 12.0.40
Database Members
Database Class Constructors Methods Fields Properties Explicit Interface Implementations See Also

The Database type exposes the following members.

Constructors

Name | Description
Database |

Methods

Name | Description
CompareWith | Overloaded.
CreateEmptyTarget | For internal use only
Dispose | Disposes of the object. (Overrides ObjectCollections ..::. Dispose()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllObjects | (Inherited from ObjectCollections.)
GetDatabaseObject | Overloaded.
GetDatabaseObjects<(Of <(T>)>) | (Inherited from ObjectCollections.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectCollectionByType | Returns a readonly collection of database objects, of the specified type. (Inherited from ObjectCollections.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LoadFromDisk | Loads the Database from disk.
LoadFromStream | Loads the Database from a stream. This is an alternative to the LoadFromDisk method.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PopulateFromMetadataFiles |
Register | Overloaded.
RegisterForDataCompare | Overloaded.
RegisterForDataCompareInner |
RetrieveCaseInformationFromLiveDatabase | This static method returns true if the Database in question is using a case sensitive collation.
SaveToDisk | Saves the Database to disk.
SaveToFolder | Overloaded.
SaveToStream | Writes the Database snapshot to the specified stream. This is an alternative to the SaveToDisk method
SetSqlServerVersionInfo | Sets the SqlVersion of the database and updates the associated list of supported features taking into account whether the server version or compatibility level should be used for the feature list.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_Assemblies | (Inherited from ObjectCollections.)
m_AssemblyDependencies | (Inherited from ObjectCollections.)
m_AssemblyDependenciesBuilder | (Inherited from ObjectCollections.)
m_AsymmetricKeys | (Inherited from ObjectCollections.)
m_Certificates | (Inherited from ObjectCollections.)
m_Contracts | (Inherited from ObjectCollections.)
m_DBFactory |
m_DdlTriggers | (Inherited from ObjectCollections.)
m_Defaults | (Inherited from ObjectCollections.)
m_Dependencies | (Inherited from ObjectCollections.)
m_DependenciesBuilder | (Inherited from ObjectCollections.)
m_EventNotifications | (Inherited from ObjectCollections.)
m_ExtendedProperties | (Inherited from ObjectCollections.)
m_ForeignKeys | (Inherited from ObjectCollections.)
m_FullTextCatalogs | (Inherited from ObjectCollections.)
m_FullTextStoplists | (Inherited from ObjectCollections.)
m_Functions | (Inherited from ObjectCollections.)
m_License | (Inherited from ObjectCollections.)
m_MessageTypes | (Inherited from ObjectCollections.)
m_PartitionFunctions | (Inherited from ObjectCollections.)
m_PartitionSchemes | (Inherited from ObjectCollections.)
m_Queues | (Inherited from ObjectCollections.)
m_Roles | (Inherited from ObjectCollections.)
m_Routes | (Inherited from ObjectCollections.)
m_Rules | (Inherited from ObjectCollections.)
m_Schemas | (Inherited from ObjectCollections.)
m_SearchPropertyLists | (Inherited from ObjectCollections.)
m_SecondaryDatabases | (Inherited from ObjectCollections.)
m_SecurityPolicies | (Inherited from ObjectCollections.)
m_Sequences | (Inherited from ObjectCollections.)
m_ServiceBindings | (Inherited from ObjectCollections.)
m_Services | (Inherited from ObjectCollections.)
m_StoredProcedures | (Inherited from ObjectCollections.)
m_SymmetricKeys | (Inherited from ObjectCollections.)
m_Synonyms | (Inherited from ObjectCollections.)
m_Tables | (Inherited from ObjectCollections.)
m_Triggers | (Inherited from ObjectCollections.)
m_UserDefinedTypes | (Inherited from ObjectCollections.)
m_Users | (Inherited from ObjectCollections.)
m_Views | (Inherited from ObjectCollections.)
m_XmlSchemaCollections | (Inherited from ObjectCollections.)

Properties

Name | Description
Assemblies | The CLR assemblies in the database. Note that CLR assemblies were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
AsymmetricKeys | The asymmetric keys in the database. Note that asymmetric keys were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
AvailableObjectCollectionTypes |
Cancel | Indicates whether the Database registration has been canceled.
CaseSensitive | Indicates whether the Database has been set up as case sensitive.
Certificates | The certificates in the database. Note that certificates were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
ClrAssemblyDependenciesBuilder | The dependencies of the CLR assemblies in the database.
Collation | The collation of the database.
ConnectionProperties | The connection properties for the database.
Contracts | The contracts in the database. Note that contracts were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
DatabaseSource |
DbInfo | Script File Information *INTERNAL USE ONLY*
DdlTriggers | The DDL triggers in the database. (Inherited from ObjectCollections.)
Defaults | The defaults in the database. (Inherited from ObjectCollections.)
DependenciesBuilder | The dependencies in the database.
EventNotifications | The database-level event notifications in the database. Note that event notifications were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
ExtendedProperties | Database-level extended properties. (Inherited from ObjectCollections.)
FullTextCatalogs | The full-text catalogs in the database. (Inherited from ObjectCollections.)
FullTextEnabled | True if the Database has full text enabled.
FullTextStoplists | The full-text stoplists in the database. (Inherited from ObjectCollections.)
Functions | The user-defined functions in the database. (Inherited from ObjectCollections.)
IsAzure | Is this database an Azure database?
m_AssemblyData | (Inherited from ObjectCollections.)
m_Comments | (Inherited from ObjectCollections.)
m_XMLSchemaData | (Inherited from ObjectCollections.)
MajorVersion | The major version of the SQL Server for the database. This reflects the compatibility mode of the database.
MessageTypes | The message types in the database. Note that message types were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
ParserMessages | A list of parser messages generated during population from a script folder. This will be null if the Database source is not a set of scripts.
PartitionFunctions | The partition functions in the database. Note that partition functions were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
PartitionSchemes | The partition schemes in the database. Note that partitions schemes were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
Queues | The queues in the database. Note that queues were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
RemoteDataArchiveEnabled | True if the database has REMOTE_DATA_ARCHIVE (aka 'Stretch Database') enabled.
Roles | The roles in the database. (Inherited from ObjectCollections.)
Routes | The routes in the database. Note that routes were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
Rules | The rules in the database. (Inherited from ObjectCollections.)
Schemas | The schemas in the database. Note that schemas were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
ScriptFolder |
SearchPropertyLists | (Inherited from ObjectCollections.)
SecurityPolicies | The security policies in the database. (Inherited from ObjectCollections.)
Sequences | The sequence objects in the database. Note that these were introduced in SQL Server 2012 (Inherited from ObjectCollections.)
ServerMajorVersion | The major server version of the SQL Server for the database. This may be different from the MajorVersion property if the Database is running in a compatibility mode.
ServiceBindings | The service bindings in the database. Note that service bindings were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
Services | The services in the database. Note that services were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
SOCCompareLocationProvider |
SourceControlInfo |
SqlServerVersionInfo | Information about the version of SQL Server this database exists on, including version number, compatibility level, internal version and whether or not it's an Azure database.
Status | Used to provide status events.
StoredProcedures | The stored procedures in the database. (Inherited from ObjectCollections.)
SupportedFeatures |
SymmetricKeys | The symmetric keys in the database. Note that symmetric keys were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
Synonyms | The synonyms in the database. Note that synonyms were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
Tables | The tables in the database. (Inherited from ObjectCollections.)
TotalObjectCount | (Inherited from ObjectCollections.)
UnmodfiedTotalObjectCount |
UserDefinedTypes | The user-defined types in the database. (Inherited from ObjectCollections.)
Users | The users in the database. (Inherited from ObjectCollections.)
Views | The views in the database. (Inherited from ObjectCollections.)
XmlSchemaCollections | The XML schema collections in the database. Note that XML schema collections were introduced in SQL Server 2005. (Inherited from ObjectCollections.)

Explicit Interface Implementations

Name | Description
ICloneableClone |
IDatabase..::.GetObjectCollectionByType |

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


Database Constructor

[image]

SQL Data Compare API 12.0.40
Database Constructor
Database Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Database()
Visual C++
public:
Database()

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


Database Fields

[image] [image]

SQL Data Compare API 12.0.40
Database Fields
Database Class See Also

The Database type exposes the following fields.

Fields

Name | Description
m_Assemblies | (Inherited from ObjectCollections.)
m_AssemblyDependencies | (Inherited from ObjectCollections.)
m_AssemblyDependenciesBuilder | (Inherited from ObjectCollections.)
m_AsymmetricKeys | (Inherited from ObjectCollections.)
m_Certificates | (Inherited from ObjectCollections.)
m_Contracts | (Inherited from ObjectCollections.)
m_DBFactory |
m_DdlTriggers | (Inherited from ObjectCollections.)
m_Defaults | (Inherited from ObjectCollections.)
m_Dependencies | (Inherited from ObjectCollections.)
m_DependenciesBuilder | (Inherited from ObjectCollections.)
m_EventNotifications | (Inherited from ObjectCollections.)
m_ExtendedProperties | (Inherited from ObjectCollections.)
m_ForeignKeys | (Inherited from ObjectCollections.)
m_FullTextCatalogs | (Inherited from ObjectCollections.)
m_FullTextStoplists | (Inherited from ObjectCollections.)
m_Functions | (Inherited from ObjectCollections.)
m_License | (Inherited from ObjectCollections.)
m_MessageTypes | (Inherited from ObjectCollections.)
m_PartitionFunctions | (Inherited from ObjectCollections.)
m_PartitionSchemes | (Inherited from ObjectCollections.)
m_Queues | (Inherited from ObjectCollections.)
m_Roles | (Inherited from ObjectCollections.)
m_Routes | (Inherited from ObjectCollections.)
m_Rules | (Inherited from ObjectCollections.)
m_Schemas | (Inherited from ObjectCollections.)
m_SearchPropertyLists | (Inherited from ObjectCollections.)
m_SecondaryDatabases | (Inherited from ObjectCollections.)
m_SecurityPolicies | (Inherited from ObjectCollections.)
m_Sequences | (Inherited from ObjectCollections.)
m_ServiceBindings | (Inherited from ObjectCollections.)
m_Services | (Inherited from ObjectCollections.)
m_StoredProcedures | (Inherited from ObjectCollections.)
m_SymmetricKeys | (Inherited from ObjectCollections.)
m_Synonyms | (Inherited from ObjectCollections.)
m_Tables | (Inherited from ObjectCollections.)
m_Triggers | (Inherited from ObjectCollections.)
m_UserDefinedTypes | (Inherited from ObjectCollections.)
m_Users | (Inherited from ObjectCollections.)
m_Views | (Inherited from ObjectCollections.)
m_XmlSchemaCollections | (Inherited from ObjectCollections.)

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


m_DBFactory Field

[image]

SQL Data Compare API 12.0.40
Database..::.m_DBFactory Field
Database Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_DBFactory As IDatabaseFactory
C#
protected IDatabaseFactory m_DBFactory
Visual C++
protected:
IDatabaseFactory^ m_DBFactory

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


Database Methods

[image] [image]

SQL Data Compare API 12.0.40
Database Methods
Database Class See Also

The Database type exposes the following methods.

Methods

Name | Description
CompareWith | Overloaded.
CreateEmptyTarget | For internal use only
Dispose | Disposes of the object. (Overrides ObjectCollections ..::. Dispose()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllObjects | (Inherited from ObjectCollections.)
GetDatabaseObject | Overloaded.
GetDatabaseObjects<(Of <(T>)>) | (Inherited from ObjectCollections.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectCollectionByType | Returns a readonly collection of database objects, of the specified type. (Inherited from ObjectCollections.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LoadFromDisk | Loads the Database from disk.
LoadFromStream | Loads the Database from a stream. This is an alternative to the LoadFromDisk method.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PopulateFromMetadataFiles |
Register | Overloaded.
RegisterForDataCompare | Overloaded.
RegisterForDataCompareInner |
RetrieveCaseInformationFromLiveDatabase | This static method returns true if the Database in question is using a case sensitive collation.
SaveToDisk | Saves the Database to disk.
SaveToFolder | Overloaded.
SaveToStream | Writes the Database snapshot to the specified stream. This is an alternative to the SaveToDisk method
SetSqlServerVersionInfo | Sets the SqlVersion of the database and updates the associated list of supported features taking into account whether the server version or compatibility level should be used for the feature list.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICloneableClone |
IDatabase..::.GetObjectCollectionByType |

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


. Method

[image]

SQL Data Compare API 12.0.40
Database..::...::. Method
Database Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function Clone As Object Implements ICloneable.Clone
C#
Object ICloneable.Clone()
Visual C++
private:
virtual Object^ Clone() sealed = ICloneable::Clone

Implements

ICloneableClone()()()

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


CompareWith Method

[image] [image]

SQL Data Compare API 12.0.40
Database..::.CompareWith Method
Database Class See Also

Overload List

Name | Description
CompareWith(Database, Options) | Compares the Database with another database.
CompareWith(Database, Options, SqlCompareOwnerMappings) | Compares the Database with another database.
CompareWith(Database, Options, SqlCompareOwnerMappings, SqlCompareTableMappings) | Compares the Database with another database.

See Also

Database Class
Database Members
RedGate.SQLCompare.Engine Namespace


CompareWith Method (Database, Options)

[image]

SQL Data Compare API 12.0.40
Database..::.CompareWith Method (Database, Options)
Database Class Example See Also

Compares the Database with another database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareWith ( _
    targetDatabase As Database, _
    options As Options _
) As Differences
C#
public Differences CompareWith(
    Database targetDatabase,
    Options options
)
Visual C++
public:
virtual Differences^ CompareWith(
    Database^ targetDatabase,
    Options options
) sealed

Parameters

targetDatabase
Type: RedGate.SQLCompare.Engine..::.Database
The Database to compare with.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

A Differences collection containing the differences between the two databases.

Implements

IDatabase..::.CompareWith(Database, Options)

Remarks

When two databases have been compared they can be synchronized using the Work class. Note that all objects that differ are selected for synchronization by default.

Progress feedback is provided via the Status event.

Examples

This example shows how you compare two databases and print out a summary of the differences.
C# Copy Code
             Database db1=new Database();
             Database db2=new Database();

             db1.Register(new ConnectionProperties(".", "WidgetStaging"), Options.Default);
             db2.Register(new ConnectionProperties(".", "WidgetProduction"), Options.Default);

             Differences differences=db1.CompareWith(db2, Options.Default);

             foreach (Difference difference in differences)
             {
                 Console.WriteLine("{0} {1} {2}", difference.Type.ToString(), difference.DatabaseObjectType.ToString(), difference.Name);
             }

             //dispose of the objects
             db1.Dispose();
             db2.Dispose();
Visual Basic Copy Code
             Dim db1 As New Database()
             Dim db2 As New Database()

             db1.Register(New ConnectionProperties(".", "WidgetStaging"), Options.Default)
             db2.Register(New ConnectionProperties(".", "WidgetProduction"), Options.Default)

             Dim differences As Differences = db1.CompareWith(db2, Options.Default)

             Dim difference As Difference

             For Each difference In differences
                 Console.WriteLine("{0} {1} {2}", difference.Type.ToString(), difference.DatabaseObjectType.ToString(), difference.Name)
             Next

             'dispose of the objects
             db1.Dispose()
             db2.Dispose()

See Also

Database Class
CompareWith Overload
RedGate.SQLCompare.Engine Namespace


CompareWith Method (Database, Options, SqlCompareOwnerMappings)

[image]

SQL Data Compare API 12.0.40
Database..::.CompareWith Method (Database, Options, SqlCompareOwnerMappings)
Database Class See Also

Compares the Database with another database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareWith ( _
    targetDatabase As Database, _
    options As Options, _
    ownerMappings As SqlCompareOwnerMappings _
) As Differences
C#
public Differences CompareWith(
    Database targetDatabase,
    Options options,
    SqlCompareOwnerMappings ownerMappings
)
Visual C++
public:
virtual Differences^ CompareWith(
    Database^ targetDatabase,
    Options options,
    SqlCompareOwnerMappings^ ownerMappings
) sealed

Parameters

targetDatabase
Type: RedGate.SQLCompare.Engine..::.Database
The Database to compare with.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.
ownerMappings
Type: RedGate.SQLCompare.Engine..::.SqlCompareOwnerMappings
Owner mappings.

Return Value

A Differences collection containing the differences between the two databases.

Implements

IDatabase..::.CompareWith(Database, Options, SqlCompareOwnerMappings)

Remarks

When two databases have been compared they can be synchronized using the Work class. Note that all objects that differ are selected for synchronization by default.

Progress feedback is provided via the Status event.

See Also

Database Class
CompareWith Overload
RedGate.SQLCompare.Engine Namespace


CompareWith Method (Database, Options, SqlCompareOwnerMappings, SqlCompareTableMappings)

[image]

SQL Data Compare API 12.0.40
Database..::.CompareWith Method (Database, Options, SqlCompareOwnerMappings, SqlCompareTableMappings)
Database Class See Also

Compares the Database with another database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareWith ( _
    targetDatabase As Database, _
    options As Options, _
    ownerMappings As SqlCompareOwnerMappings, _
    tableMappings As SqlCompareTableMappings _
) As Differences
C#
public Differences CompareWith(
    Database targetDatabase,
    Options options,
    SqlCompareOwnerMappings ownerMappings,
    SqlCompareTableMappings tableMappings
)
Visual C++
public:
virtual Differences^ CompareWith(
    Database^ targetDatabase,
    Options options,
    SqlCompareOwnerMappings^ ownerMappings,
    SqlCompareTableMappings^ tableMappings
) sealed

Parameters

targetDatabase
Type: RedGate.SQLCompare.Engine..::.Database
The Database to compare with.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.
ownerMappings
Type: RedGate.SQLCompare.Engine..::.SqlCompareOwnerMappings
Owner mappings.
tableMappings
Type: RedGate.SQLCompare.Engine..::.SqlCompareTableMappings
Table mappings.

Return Value

A Differences collection containing the differences between the two databases.

Implements

IDatabase..::.CompareWith(Database, Options, SqlCompareOwnerMappings, SqlCompareTableMappings)

Remarks

When two databases have been compared they can be synchronized using the Work class. Note that all objects that differ are selected for synchronization by default.

Progress feedback is provided via the Status event.

See Also

Database Class
CompareWith Overload
RedGate.SQLCompare.Engine Namespace


CreateEmptyTarget Method

[image]

SQL Data Compare API 12.0.40
Database..::.CreateEmptyTarget Method
Database Class See Also

For internal use only

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateEmptyTarget ( _
    caseSensitive As Boolean _
) As Database
C#
public Database CreateEmptyTarget(
    bool caseSensitive
)
Visual C++
public:
virtual Database^ CreateEmptyTarget(
    bool caseSensitive
) sealed

Parameters

caseSensitive
Type: Boolean

Return Value

Implements

IDatabase..::.CreateEmptyTarget(Boolean)

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


Dispose Method

[image]

SQL Data Compare API 12.0.40
Database..::.Dispose Method
Database Class See Also

Disposes of the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Dispose
C#
public override void Dispose()
Visual C++
public:
virtual void Dispose() override

Implements

IDisposableDispose()()()
IDisposableDispose()()()

Remarks

It is important to dispose of the object to delete any temporary files it uses.

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


GetDatabaseObject Method

[image] [image]

SQL Data Compare API 12.0.40
Database..::.GetDatabaseObject Method
Database Class See Also

Overload List

Name | Description
GetDatabaseObject(String) | Get database object by two-part name (Inherited from ObjectCollections.)
GetDatabaseObject(String, ObjectType) | (Inherited from ObjectCollections.)

See Also

Database Class
Database Members
RedGate.SQLCompare.Engine Namespace


IDatabase.GetObjectCollectionByType Method

[image]

SQL Data Compare API 12.0.40
Database..::.IDatabase..::.GetObjectCollectionByType Method
Database Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function GetObjectCollectionByType ( _
    type As ObjectType _
) As ICollection(Of IDatabaseObject) Implements IDatabase.GetObjectCollectionByType
C#
ICollection<IDatabaseObject> IDatabase.GetObjectCollectionByType(
    ObjectType type
)
Visual C++
private:
virtual ICollection<IDatabaseObject^>^ GetObjectCollectionByType(
    ObjectType type
) sealed = IDatabase::GetObjectCollectionByType

Parameters

type
Type: ObjectType

Implements

IDatabase..::.GetObjectCollectionByType(ObjectType)

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


LoadFromDisk Method

[image]

SQL Data Compare API 12.0.40
Database..::.LoadFromDisk Method
Database Class Example See Also

Loads the Database from disk.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub LoadFromDisk ( _
    fileName As String, _
    caseSensitiveComparison As Boolean, _
    options As Nullable(Of Options) _
)
C#
public void LoadFromDisk(
    string fileName,
    bool caseSensitiveComparison,
    Nullable<Options> options
)
Visual C++
public:
virtual void LoadFromDisk(
    String^ fileName,
    bool caseSensitiveComparison,
    Nullable<Options> options
) sealed

Parameters

fileName
Type: String
The name of the Database snapshot file to load.
caseSensitiveComparison
Type: Boolean
Whether the comparison is case sensitive (from the project options). This is checked against the case sensitivity of the snapshot to ensure that they match.
options
Type: Nullable<(Of <( Options >)>)

Implements

IDatabase..::.LoadFromDisk(String, Boolean, Nullable<(Of <(Options>)>))

Remarks

Progress events are fired via the Status event.

Examples

See SaveToDisk(String) for a code sample.

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


LoadFromStream Method

[image]

SQL Data Compare API 12.0.40
Database..::.LoadFromStream Method
Database Class See Also

Loads the Database from a stream. This is an alternative to the LoadFromDisk method.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub LoadFromStream ( _
    f As Stream, _
    caseSensitiveComparison As Boolean, _
    options As Nullable(Of Options) _
)
C#
public void LoadFromStream(
    Stream f,
    bool caseSensitiveComparison,
    Nullable<Options> options
)
Visual C++
public:
virtual void LoadFromStream(
    Stream^ f,
    bool caseSensitiveComparison,
    Nullable<Options> options
) sealed

Parameters

f
Type: Stream
The open stream from which to read the database.
caseSensitiveComparison
Type: Boolean
Whether the comparison is case sensitive (from the project options). This is checked against the case sensitivity of the snapshot to ensure that they match.
options
Type: Nullable<(Of <( Options >)>)

Implements

IDatabase..::.LoadFromStream(Stream, Boolean, Nullable<(Of <(Options>)>))

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


PopulateFromMetadataFiles Method

[image]

SQL Data Compare API 12.0.40
Database..::.PopulateFromMetadataFiles Method
Database Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PopulateFromMetadataFiles ( _
    scriptFolderPath As DirectoryInfo _
)
C#
public void PopulateFromMetadataFiles(
    DirectoryInfo scriptFolderPath
)
Visual C++
public:
void PopulateFromMetadataFiles(
    DirectoryInfo^ scriptFolderPath
)

Parameters

scriptFolderPath
Type: DirectoryInfo

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


Register Method

[image] [image]

SQL Data Compare API 12.0.40
Database..::.Register Method
Database Class See Also

Overload List

Name | Description
Register(String, ScriptDatabaseInformation, Options) | Registers the Database from creation scripts that are stored in the folder specified by the path parameter.
Register(ConnectionProperties, Options, IDmvModelFactory) | Registers a database.
Register(String, ScriptDatabaseInformation, Options, IEnumerable<(Of <(String>)>)) | Registers the Database from creation scripts that are stored in the folder specified by the path parameter.
Register(String, ScriptDatabaseInformation, Options, IEnumerable<(Of <(String>)>), IReadFromFolderCache, IDatabaseFromFolderPopulator) |

See Also

Database Class
Database Members
RedGate.SQLCompare.Engine Namespace


Register Method (, ScriptDatabaseInformation, Options)

[image]

SQL Data Compare API 12.0.40
Database..::.Register Method (, ScriptDatabaseInformation, Options)
Database Class See Also

Registers the Database from creation scripts that are stored in the folder specified by the path parameter.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Register ( _
    path As String, _
    dbinfo As ScriptDatabaseInformation, _
    options As Options _
)
C#
public void Register(
    string path,
    ScriptDatabaseInformation dbinfo,
    Options options
)
Visual C++
public:
virtual void Register(
    String^ path,
    ScriptDatabaseInformation^ dbinfo,
    Options options
) sealed

Parameters

path
Type: String
The path to the folder that contains the creations scripts.
dbinfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
This is an optional parameter. If the specified folder contains the SQL Compare generated xml file with the necessary Database information, it does not need to be specified. However, if the folder does not contain this information, or this information needs to be overriden, then this parameter must be set.
options
Type: RedGate.SQLCompare.Engine..::.Options
Options.

Implements

IDatabase..::.Register(String, ScriptDatabaseInformation, Options)

See Also

Database Class
Register Overload
RedGate.SQLCompare.Engine Namespace


Register Method (ConnectionProperties, Options, IDmvModelFactory)

[image]

SQL Data Compare API 12.0.40
Database..::.Register Method (ConnectionProperties, Options, IDmvModelFactory)
Database Class Example See Also

Registers a database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Register ( _
    connectionProperties As ConnectionProperties, _
    options As Options, _
    factory As IDmvModelFactory _
)
C#
public void Register(
    ConnectionProperties connectionProperties,
    Options options,
    IDmvModelFactory factory
)
Visual C++
public:
virtual void Register(
    ConnectionProperties^ connectionProperties,
    Options options,
    IDmvModelFactory^ factory
) sealed

Parameters

connectionProperties
Type: RedGate.SQLCompare.Engine..::.ConnectionProperties
The connection properties associated with the database.
options
Type: RedGate.SQLCompare.Engine..::.Options
Options.
factory
Type: RedGate.SQLCompare.Engine..::.IDmvModelFactory

Implements

IDatabase..::.Register(ConnectionProperties, Options, IDmvModelFactory)

Remarks

Connects to a Database and retrieves all schema information. The Database object can then be saved to disk or used in a comparison. Progress feedback is provided via the Status event.

Examples

This example shows how you register a Database from a live server, with feedback.
C# Copy Code
             using System;
             using RedGate.Shared.Utils;
             using RedGate.SQLCompare.Engine;

             namespace ConsoleApplication2
             {
                 public class Class1
                 {

                     public static void Main()
                     {
                         Class1 c1=new Class1();
                         c.Run();
                     }

                     private void StatusCallback(object sender, StatusEventArgs e)
                     {
                         //fired by the SqlProvider to indicate events

                         if (e.Message!=null)
                         {
                             Console.WriteLine(e.Message);
                         }

                         if (e.Percentage!=-1)
                         {
                             Console.WriteLine("{0}%", e.Percentage);
                         }

                     }

                     private void Run()
                     {
                         Database db=new Database();
                         db.Status+=new StatusEventHandler(StatusCallback);
                         db.Register(new ConnectionProperties(".", "WidgetStaging"),Options.Default);
                         db.Dispose();
                     }
                 }
             }
Visual Basic Copy Code
             Option Explicit On

             Imports RedGate.Shared.Utils
             Imports RedGate.SQLCompare.Engine

             Module Module3

                 Sub Main()

                     Dim c As Class1 = New Class1()

                     c.Run()
                     Console.WriteLine("Press [Enter]")
                     Console.ReadLine()

                 End Sub

                 Public Class Class1

                     Sub StatusCallback(ByVal sender As Object, ByVal e As StatusEventArgs)

                         If Not (e.Message Is Nothing) Then
                             Console.WriteLine(e.Message)
                         End If

                         If e.Percentage <> -1 Then
                             Console.WriteLine("{0}%", e.Percentage)
                         End If

                     End Sub

                     Sub Run()

                         Dim db As New Database()
                         db.Status = New StatusEventHandler(AddressOf Me.StatusCallback)
                         db.Register(New ConnectionProperties(".", "WidgetStaging"), Options.Default)
                         db.Dispose()
                     End Sub

                 End Class
             End Module

See Also

Database Class
Register Overload
RedGate.SQLCompare.Engine Namespace


Register Method (, ScriptDatabaseInformation, Options, ())

[image]

SQL Data Compare API 12.0.40
Database..::.Register Method (, ScriptDatabaseInformation, Options, <(Of <(>)>))
Database Class See Also

Registers the Database from creation scripts that are stored in the folder specified by the path parameter.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Register ( _
    path As String, _
    dbinfo As ScriptDatabaseInformation, _
    options As Options, _
    filesToUse As IEnumerable(Of String) _
)
C#
public void Register(
    string path,
    ScriptDatabaseInformation dbinfo,
    Options options,
    IEnumerable<string> filesToUse
)
Visual C++
public:
virtual void Register(
    String^ path,
    ScriptDatabaseInformation^ dbinfo,
    Options options,
    IEnumerable<String^>^ filesToUse
) sealed

Parameters

path
Type: String
The path to the folder that contains the creations scripts.
dbinfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
This is an optional parameter. If the specified folder contains the SQL Compare generated xml file with the necessary Database information, it does not need to be specified. However, if the folder does not contain this information, or this information needs to be overriden, then this parameter must be set.
options
Type: RedGate.SQLCompare.Engine..::.Options
Options.
filesToUse
Type: IEnumerable<(Of <(String>)>)
A list of files to use for the register if this is set to null then any .sql file found under the path and it's subfolders will be used

Implements

IDatabase..::.Register(String, ScriptDatabaseInformation, Options, IEnumerable<(Of <(String>)>))

See Also

Database Class
Register Overload
RedGate.SQLCompare.Engine Namespace


Register Method (, ScriptDatabaseInformation, Options, (), IReadFromFolderCache, IDatabaseFromFolderPopulator)

[image]

SQL Data Compare API 12.0.40
Database..::.Register Method (, ScriptDatabaseInformation, Options, <(Of <(>)>), IReadFromFolderCache, IDatabaseFromFolderPopulator)
Database Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Register ( _
    path As String, _
    dbinfo As ScriptDatabaseInformation, _
    options As Options, _
    filesToUse As IEnumerable(Of String), _
    cache As IReadFromFolderCache, _
    databasePopulator As IDatabaseFromFolderPopulator _
) As CacheResult
C#
public CacheResult Register(
    string path,
    ScriptDatabaseInformation dbinfo,
    Options options,
    IEnumerable<string> filesToUse,
    IReadFromFolderCache cache,
    IDatabaseFromFolderPopulator databasePopulator
)
Visual C++
public:
virtual CacheResult^ Register(
    String^ path,
    ScriptDatabaseInformation^ dbinfo,
    Options options,
    IEnumerable<String^>^ filesToUse,
    IReadFromFolderCache^ cache,
    IDatabaseFromFolderPopulator^ databasePopulator
) sealed

Parameters

path
Type: String
dbinfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
options
Type: RedGate.SQLCompare.Engine..::.Options
filesToUse
Type: IEnumerable<(Of <(String>)>)
cache
Type: RedGate.SQLCompare.Engine.ReadFromFolder.Cache..::.IReadFromFolderCache
databasePopulator
Type: RedGate.SQLCompare.Engine.Model.DatabaseObjects.DatabaseFromFolderPopulator..::.IDatabaseFromFolderPopulator

Implements

IDatabase..::.Register(String, ScriptDatabaseInformation, Options, IEnumerable<(Of <(String>)>), IReadFromFolderCache, IDatabaseFromFolderPopulator)

Exceptions

Exception | Condition
ArgumentNullException |
RedGate.SQLCompare.Engine..::.SqlCompareException |

See Also

Database Class
Register Overload
RedGate.SQLCompare.Engine Namespace


RegisterForDataCompare Method

[image] [image]

SQL Data Compare API 12.0.40
Database..::.RegisterForDataCompare Method
Database Class See Also

Overload List

Name | Description
RegisterForDataCompare(ConnectionProperties) | Registers a Database for SQL Data Compare.
RegisterForDataCompare(ConnectionProperties, Options) | Registers a Database for SQL Data Compare.
RegisterForDataCompare(String, ScriptDatabaseInformation, Options) |

See Also

Database Class
Database Members
RedGate.SQLCompare.Engine Namespace


RegisterForDataCompare Method (ConnectionProperties)

[image]

SQL Data Compare API 12.0.40
Database..::.RegisterForDataCompare Method (ConnectionProperties)
Database Class See Also

Registers a Database for SQL Data Compare.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub RegisterForDataCompare ( _
    connectionProperties As ConnectionProperties _
)
C#
public void RegisterForDataCompare(
    ConnectionProperties connectionProperties
)
Visual C++
public:
virtual void RegisterForDataCompare(
    ConnectionProperties^ connectionProperties
) sealed

Parameters

connectionProperties
Type: RedGate.SQLCompare.Engine..::.ConnectionProperties
The connection properties to use for the Database connection.

Implements

IDatabase..::.RegisterForDataCompare(ConnectionProperties)

See Also

Database Class
RegisterForDataCompare Overload
RedGate.SQLCompare.Engine Namespace


RegisterForDataCompare Method (ConnectionProperties, Options)

[image]

SQL Data Compare API 12.0.40
Database..::.RegisterForDataCompare Method (ConnectionProperties, Options)
Database Class See Also

Registers a Database for SQL Data Compare.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub RegisterForDataCompare ( _
    connectionProperties As ConnectionProperties, _
    options As Options _
)
C#
public void RegisterForDataCompare(
    ConnectionProperties connectionProperties,
    Options options
)
Visual C++
public:
virtual void RegisterForDataCompare(
    ConnectionProperties^ connectionProperties,
    Options options
) sealed

Parameters

connectionProperties
Type: RedGate.SQLCompare.Engine..::.ConnectionProperties
The connection properties to use for the Database connection.
options
Type: RedGate.SQLCompare.Engine..::.Options
Options.

Implements

IDatabase..::.RegisterForDataCompare(ConnectionProperties, Options)

See Also

Database Class
RegisterForDataCompare Overload
RedGate.SQLCompare.Engine Namespace


RegisterForDataCompare Method (, ScriptDatabaseInformation, Options)

[image]

SQL Data Compare API 12.0.40
Database..::.RegisterForDataCompare Method (, ScriptDatabaseInformation, Options)
Database Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub RegisterForDataCompare ( _
    path As String, _
    dbinfo As ScriptDatabaseInformation, _
    options As Options _
)
C#
public void RegisterForDataCompare(
    string path,
    ScriptDatabaseInformation dbinfo,
    Options options
)
Visual C++
public:
virtual void RegisterForDataCompare(
    String^ path,
    ScriptDatabaseInformation^ dbinfo,
    Options options
) sealed

Parameters

path
Type: String
dbinfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

IDatabase..::.RegisterForDataCompare(String, ScriptDatabaseInformation, Options)

See Also

Database Class
RegisterForDataCompare Overload
RedGate.SQLCompare.Engine Namespace


RegisterForDataCompareInner Method

[image]

SQL Data Compare API 12.0.40
Database..::.RegisterForDataCompareInner Method
Database Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RegisterForDataCompareInner ( _
    dbFactory As IDatabaseFactory _
)
C#
protected virtual void RegisterForDataCompareInner(
    IDatabaseFactory dbFactory
)
Visual C++
protected:
virtual void RegisterForDataCompareInner(
    IDatabaseFactory^ dbFactory
)

Parameters

dbFactory
Type: RedGate.SQLCompare.Engine.Registration.ModelFactory..::.IDatabaseFactory

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


RetrieveCaseInformationFromLiveDatabase Method

[image]

SQL Data Compare API 12.0.40
Database..::.RetrieveCaseInformationFromLiveDatabase Method
Database Class See Also

This static method returns true if the Database in question is using a case sensitive collation.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function RetrieveCaseInformationFromLiveDatabase ( _
    connection As SqlConnection _
) As Boolean
C#
public static bool RetrieveCaseInformationFromLiveDatabase(
    SqlConnection connection
)
Visual C++
public:
static bool RetrieveCaseInformationFromLiveDatabase(
    SqlConnection^ connection
)

Parameters

connection
Type: SqlConnection
A connection to the Database to be checked. If the connection that is provided is closed, it will be opened again, then closed.

Return Value

True if the Database collation is case sensitive.

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


SaveToDisk Method

[image]

SQL Data Compare API 12.0.40
Database..::.SaveToDisk Method
Database Class Example See Also

Saves the Database to disk.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveToDisk ( _
    fileName As String _
)
C#
public void SaveToDisk(
    string fileName
)
Visual C++
public:
virtual void SaveToDisk(
    String^ fileName
) sealed

Parameters

fileName
Type: String
The name of the snapshot file to be created.

Implements

IDatabase..::.SaveToDisk(String)

Examples

The example shows how you save and load a snapshot.
C# Copy Code
             //register a Database using integrated security
             Database db1=new Database();
             db.Register(new ConnectionProperties(".", "WidgetStaging"), Options.Default);

             //save the Database to disk
             db.SaveToDisk(@"c:\WidgetStaging.snp");

             Database db2=new Database();
             db2.LoadFromDisk(@"c:\WidgetStaging.snp");

             //dispose of the objects
             db.Dispose();
             db2.Dispose();
Visual Basic Copy Code
             'register a Database using integrated security
             Dim db1 As New Database()
             db.Register(New ConnectionProperties(".", "WidgetStaging"), Options.Default)

             'save the Database to disk
             db.SaveToDisk("c:\WidgetStaging.snp")

             Dim db2 As New Database()
             db2.LoadFromDisk("c:\WidgetStaging.snp")

             'dispose of the objects
             db.Dispose()
             db2.Dispose()

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


SaveToFolder Method

[image] [image]

SQL Data Compare API 12.0.40
Database..::.SaveToFolder Method
Database Class See Also

Overload List

Name | Description
SaveToFolder(String) | Obsolete. Saves the Database as a set of creation scripts to the specified folder.
SaveToFolder(String, ScriptDatabaseInformation) | Saves the Database as a set of creation scripts to the specified folder.
SaveToFolder(String, Options, ScriptDatabaseInformation, IFileNameGenerator) | Saves the Database as a set of creation scripts to the specified folder.

See Also

Database Class
Database Members
RedGate.SQLCompare.Engine Namespace


SaveToFolder Method ()

[image]

SQL Data Compare API 12.0.40
Database..::.SaveToFolder Method ()
Database Class See Also

Saves the Database as a set of creation scripts to the specified folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Please use the SaveToFolder(string folderName, ScriptDatabaseInformation dbInfo) method!",  _
    True)> _
Public Sub SaveToFolder ( _
    folderName As String _
)
C#
[ObsoleteAttribute("Please use the SaveToFolder(string folderName, ScriptDatabaseInformation dbInfo) method!",
    true)]
public void SaveToFolder(
    string folderName
)
Visual C++
[ObsoleteAttribute(L"Please use the SaveToFolder(string folderName, ScriptDatabaseInformation dbInfo) method!",
    true)]
public:
virtual void SaveToFolder(
    String^ folderName
) sealed

Parameters

folderName
Type: String

Implements

IDatabase..::.SaveToFolder(String)

See Also

Database Class
SaveToFolder Overload
RedGate.SQLCompare.Engine Namespace


SaveToFolder Method (, ScriptDatabaseInformation)

[image]

SQL Data Compare API 12.0.40
Database..::.SaveToFolder Method (, ScriptDatabaseInformation)
Database Class See Also

Saves the Database as a set of creation scripts to the specified folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveToFolder ( _
    folderName As String, _
    dbInfo As ScriptDatabaseInformation _
)
C#
public void SaveToFolder(
    string folderName,
    ScriptDatabaseInformation dbInfo
)
Visual C++
public:
virtual void SaveToFolder(
    String^ folderName,
    ScriptDatabaseInformation^ dbInfo
) sealed

Parameters

folderName
Type: String
dbInfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
Options to control how the script files are written to the folder - will be changed by the call

Implements

IDatabase..::.SaveToFolder(String, ScriptDatabaseInformation)

See Also

Database Class
SaveToFolder Overload
RedGate.SQLCompare.Engine Namespace


SaveToFolder Method (, Options, ScriptDatabaseInformation, IFileNameGenerator)

[image]

SQL Data Compare API 12.0.40
Database..::.SaveToFolder Method (, Options, ScriptDatabaseInformation, IFileNameGenerator)
Database Class See Also

Saves the Database as a set of creation scripts to the specified folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveToFolder ( _
    folderName As String, _
    options As Options, _
    readOnlyDbInfo As ScriptDatabaseInformation, _
    generator As IFileNameGenerator _
)
C#
public void SaveToFolder(
    string folderName,
    Options options,
    ScriptDatabaseInformation readOnlyDbInfo,
    IFileNameGenerator generator
)
Visual C++
public:
virtual void SaveToFolder(
    String^ folderName,
    Options options,
    ScriptDatabaseInformation^ readOnlyDbInfo,
    IFileNameGenerator^ generator
) sealed

Parameters

folderName
Type: String
options
Type: RedGate.SQLCompare.Engine..::.Options
Options to control how the Database objects are scripted out
readOnlyDbInfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
Options to control how the script files are written to the folder - will be changed by the call
generator
Type: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser..::.IFileNameGenerator
Generator will be autodetected if none is specified.

Implements

IDatabase..::.SaveToFolder(String, Options, ScriptDatabaseInformation, IFileNameGenerator)

See Also

Database Class
SaveToFolder Overload
RedGate.SQLCompare.Engine Namespace


SaveToStream Method

[image]

SQL Data Compare API 12.0.40
Database..::.SaveToStream Method
Database Class See Also

Writes the Database snapshot to the specified stream. This is an alternative to the SaveToDisk method

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveToStream ( _
    stream As Stream _
)
C#
public void SaveToStream(
    Stream stream
)
Visual C++
public:
virtual void SaveToStream(
    Stream^ stream
) sealed

Parameters

stream
Type: Stream
The stream to write to.

Implements

IDatabase..::.SaveToStream(Stream)

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


SetSqlServerVersionInfo Method

[image]

SQL Data Compare API 12.0.40
Database..::.SetSqlServerVersionInfo Method
Database Class See Also

Sets the SqlVersion of the database and updates the associated list of supported features taking into account whether the server version or compatibility level should be used for the feature list.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetSqlServerVersionInfo ( _
    versionInfo As SqlVersion, _
    useCompatibilityLevel As Boolean _
)
C#
public void SetSqlServerVersionInfo(
    SqlVersion versionInfo,
    bool useCompatibilityLevel
)
Visual C++
public:
void SetSqlServerVersionInfo(
    SqlVersion^ versionInfo,
    bool useCompatibilityLevel
)

Parameters

versionInfo
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.SqlVersion
useCompatibilityLevel
Type: Boolean

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


Database Properties

[image] [image]

SQL Data Compare API 12.0.40
Database Properties
Database Class See Also

The Database type exposes the following properties.

Properties

Name | Description
Assemblies | The CLR assemblies in the database. Note that CLR assemblies were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
AsymmetricKeys | The asymmetric keys in the database. Note that asymmetric keys were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
AvailableObjectCollectionTypes |
Cancel | Indicates whether the Database registration has been canceled.
CaseSensitive | Indicates whether the Database has been set up as case sensitive.
Certificates | The certificates in the database. Note that certificates were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
ClrAssemblyDependenciesBuilder | The dependencies of the CLR assemblies in the database.
Collation | The collation of the database.
ConnectionProperties | The connection properties for the database.
Contracts | The contracts in the database. Note that contracts were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
DatabaseSource |
DbInfo | Script File Information *INTERNAL USE ONLY*
DdlTriggers | The DDL triggers in the database. (Inherited from ObjectCollections.)
Defaults | The defaults in the database. (Inherited from ObjectCollections.)
DependenciesBuilder | The dependencies in the database.
EventNotifications | The database-level event notifications in the database. Note that event notifications were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
ExtendedProperties | Database-level extended properties. (Inherited from ObjectCollections.)
FullTextCatalogs | The full-text catalogs in the database. (Inherited from ObjectCollections.)
FullTextEnabled | True if the Database has full text enabled.
FullTextStoplists | The full-text stoplists in the database. (Inherited from ObjectCollections.)
Functions | The user-defined functions in the database. (Inherited from ObjectCollections.)
IsAzure | Is this database an Azure database?
m_AssemblyData | (Inherited from ObjectCollections.)
m_Comments | (Inherited from ObjectCollections.)
m_XMLSchemaData | (Inherited from ObjectCollections.)
MajorVersion | The major version of the SQL Server for the database. This reflects the compatibility mode of the database.
MessageTypes | The message types in the database. Note that message types were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
ParserMessages | A list of parser messages generated during population from a script folder. This will be null if the Database source is not a set of scripts.
PartitionFunctions | The partition functions in the database. Note that partition functions were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
PartitionSchemes | The partition schemes in the database. Note that partitions schemes were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
Queues | The queues in the database. Note that queues were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
RemoteDataArchiveEnabled | True if the database has REMOTE_DATA_ARCHIVE (aka 'Stretch Database') enabled.
Roles | The roles in the database. (Inherited from ObjectCollections.)
Routes | The routes in the database. Note that routes were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
Rules | The rules in the database. (Inherited from ObjectCollections.)
Schemas | The schemas in the database. Note that schemas were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
ScriptFolder |
SearchPropertyLists | (Inherited from ObjectCollections.)
SecurityPolicies | The security policies in the database. (Inherited from ObjectCollections.)
Sequences | The sequence objects in the database. Note that these were introduced in SQL Server 2012 (Inherited from ObjectCollections.)
ServerMajorVersion | The major server version of the SQL Server for the database. This may be different from the MajorVersion property if the Database is running in a compatibility mode.
ServiceBindings | The service bindings in the database. Note that service bindings were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
Services | The services in the database. Note that services were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
SOCCompareLocationProvider |
SourceControlInfo |
SqlServerVersionInfo | Information about the version of SQL Server this database exists on, including version number, compatibility level, internal version and whether or not it's an Azure database.
Status | Used to provide status events.
StoredProcedures | The stored procedures in the database. (Inherited from ObjectCollections.)
SupportedFeatures |
SymmetricKeys | The symmetric keys in the database. Note that symmetric keys were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
Synonyms | The synonyms in the database. Note that synonyms were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
Tables | The tables in the database. (Inherited from ObjectCollections.)
TotalObjectCount | (Inherited from ObjectCollections.)
UnmodfiedTotalObjectCount |
UserDefinedTypes | The user-defined types in the database. (Inherited from ObjectCollections.)
Users | The users in the database. (Inherited from ObjectCollections.)
Views | The views in the database. (Inherited from ObjectCollections.)
XmlSchemaCollections | The XML schema collections in the database. Note that XML schema collections were introduced in SQL Server 2005. (Inherited from ObjectCollections.)

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


AvailableObjectCollectionTypes Property

[image]

SQL Data Compare API 12.0.40
Database..::.AvailableObjectCollectionTypes Property
Database Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property AvailableObjectCollectionTypes As IEnumerable(Of ObjectType)
C#
public static IEnumerable<ObjectType> AvailableObjectCollectionTypes { get; }
Visual C++
public:
static property IEnumerable<ObjectType>^ AvailableObjectCollectionTypes {
    IEnumerable<ObjectType>^ get ();
}

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


Cancel Property

[image]

SQL Data Compare API 12.0.40
Database..::.Cancel Property
Database Class See Also

Indicates whether the Database registration has been canceled.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
C#
public bool Cancel { get; set; }
Visual C++
public:
virtual property bool Cancel {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

ICancellationStatus..::.Cancel

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


CaseSensitive Property

[image]

SQL Data Compare API 12.0.40
Database..::.CaseSensitive Property
Database Class See Also

Indicates whether the Database has been set up as case sensitive.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CaseSensitive As Boolean
C#
public bool CaseSensitive { get; internal set; }
Visual C++
public:
virtual property bool CaseSensitive {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IDatabase..::.CaseSensitive

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


ClrAssemblyDependenciesBuilder Property

[image]

SQL Data Compare API 12.0.40
Database..::.ClrAssemblyDependenciesBuilder Property
Database Class See Also

The dependencies of the CLR assemblies in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClrAssemblyDependenciesBuilder As DependenciesBuilder
C#
public DependenciesBuilder ClrAssemblyDependenciesBuilder { get; }
Visual C++
public:
virtual property DependenciesBuilder^ ClrAssemblyDependenciesBuilder {
    DependenciesBuilder^ get () sealed;
}

Implements

IDatabase..::.ClrAssemblyDependenciesBuilder

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


Collation Property

[image]

SQL Data Compare API 12.0.40
Database..::.Collation Property
Database Class See Also

The collation of the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Collation As String
C#
public string Collation { get; internal set; }
Visual C++
public:
virtual property String^ Collation {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IDatabase..::.Collation

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


ConnectionProperties Property

[image]

SQL Data Compare API 12.0.40
Database..::.ConnectionProperties Property
Database Class See Also

The connection properties for the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ConnectionProperties As ConnectionProperties
C#
public ConnectionProperties ConnectionProperties { get; set; }
Visual C++
public:
virtual property ConnectionProperties^ ConnectionProperties {
    ConnectionProperties^ get () sealed;
    void set (ConnectionProperties^ value) sealed;
}

Implements

IDatabase..::.ConnectionProperties

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


DatabaseSource Property

[image]

SQL Data Compare API 12.0.40
Database..::.DatabaseSource Property
Database Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DatabaseSource As DatabaseSource
C#
public DatabaseSource DatabaseSource { get; set; }
Visual C++
public:
virtual property DatabaseSource DatabaseSource {
    DatabaseSource get () sealed;
    void set (DatabaseSource value) sealed;
}

Implements

IDatabase..::.DatabaseSource

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


DbInfo Property

[image]

SQL Data Compare API 12.0.40
Database..::.DbInfo Property
Database Class See Also

Script File Information *INTERNAL USE ONLY*

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DbInfo As ScriptDatabaseInformation
C#
public ScriptDatabaseInformation DbInfo { get; set; }
Visual C++
public:
virtual property ScriptDatabaseInformation^ DbInfo {
    ScriptDatabaseInformation^ get () sealed;
    void set (ScriptDatabaseInformation^ value) sealed;
}

Implements

IDatabase..::.DbInfo

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


DependenciesBuilder Property

[image]

SQL Data Compare API 12.0.40
Database..::.DependenciesBuilder Property
Database Class See Also

The dependencies in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DependenciesBuilder As DependenciesBuilder
C#
public DependenciesBuilder DependenciesBuilder { get; }
Visual C++
public:
virtual property DependenciesBuilder^ DependenciesBuilder {
    DependenciesBuilder^ get () sealed;
}

Implements

IDatabase..::.DependenciesBuilder

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


FullTextEnabled Property

[image]

SQL Data Compare API 12.0.40
Database..::.FullTextEnabled Property
Database Class See Also

True if the Database has full text enabled.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextEnabled As Boolean
C#
public bool FullTextEnabled { get; internal set; }
Visual C++
public:
virtual property bool FullTextEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IDatabase..::.FullTextEnabled

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


IsAzure Property

[image]

SQL Data Compare API 12.0.40
Database..::.IsAzure Property
Database Class See Also

Is this database an Azure database?

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsAzure As Boolean
C#
public bool IsAzure { get; }
Visual C++
public:
virtual property bool IsAzure {
    bool get () sealed;
}

Implements

IDatabase..::.IsAzure

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


MajorVersion Property

[image]

SQL Data Compare API 12.0.40
Database..::.MajorVersion Property
Database Class See Also

The major version of the SQL Server for the database. This reflects the compatibility mode of the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MajorVersion As SQLVersion
C#
public SQLVersion MajorVersion { get; }
Visual C++
public:
virtual property SQLVersion MajorVersion {
    SQLVersion get () sealed;
}

Implements

IVersionedDatabase..::.MajorVersion

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


ParserMessages Property

[image]

SQL Data Compare API 12.0.40
Database..::.ParserMessages Property
Database Class See Also

A list of parser messages generated during population from a script folder. This will be null if the Database source is not a set of scripts.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ParserMessages As ReadOnlyListWrapper(Of ParserMessage)
C#
public ReadOnlyListWrapper<ParserMessage> ParserMessages { get; internal set; }
Visual C++
public:
virtual property ReadOnlyListWrapper<ParserMessage^>^ ParserMessages {
    ReadOnlyListWrapper<ParserMessage^>^ get () sealed;
    void set (ReadOnlyListWrapper<ParserMessage^>^ value) sealed;
}

Implements

IDatabase..::.ParserMessages

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


RemoteDataArchiveEnabled Property

[image]

SQL Data Compare API 12.0.40
Database..::.RemoteDataArchiveEnabled Property
Database Class See Also

True if the database has REMOTE_DATA_ARCHIVE (aka 'Stretch Database') enabled.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RemoteDataArchiveEnabled As Boolean
C#
public bool RemoteDataArchiveEnabled { get; internal set; }
Visual C++
public:
property bool RemoteDataArchiveEnabled {
    bool get ();
    void set (bool value);
}

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


ScriptFolder Property

[image]

SQL Data Compare API 12.0.40
Database..::.ScriptFolder Property
Database Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptFolder As String
C#
public string ScriptFolder { get; set; }
Visual C++
public:
virtual property String^ ScriptFolder {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IDatabase..::.ScriptFolder

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


ServerMajorVersion Property

[image]

SQL Data Compare API 12.0.40
Database..::.ServerMajorVersion Property
Database Class See Also

The major server version of the SQL Server for the database. This may be different from the MajorVersion property if the Database is running in a compatibility mode.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ServerMajorVersion As SQLVersion
C#
public SQLVersion ServerMajorVersion { get; }
Visual C++
public:
virtual property SQLVersion ServerMajorVersion {
    SQLVersion get () sealed;
}

Implements

IVersionedDatabase..::.ServerMajorVersion

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


SOCCompareLocationProvider Property

[image]

SQL Data Compare API 12.0.40
Database..::.SOCCompareLocationProvider Property
Database Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SOCCompareLocationProvider As ISOCCompareLocationProvider
C#
public ISOCCompareLocationProvider SOCCompareLocationProvider { get; set; }
Visual C++
public:
virtual property ISOCCompareLocationProvider^ SOCCompareLocationProvider {
    ISOCCompareLocationProvider^ get () sealed;
    void set (ISOCCompareLocationProvider^ value) sealed;
}

Implements

IDatabase..::.SOCCompareLocationProvider

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


SourceControlInfo Property

[image]

SQL Data Compare API 12.0.40
Database..::.SourceControlInfo Property
Database Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SourceControlInfo As SourceControlInfo
C#
public SourceControlInfo SourceControlInfo { get; set; }
Visual C++
public:
virtual property SourceControlInfo^ SourceControlInfo {
    SourceControlInfo^ get () sealed;
    void set (SourceControlInfo^ value) sealed;
}

Implements

IDatabase..::.SourceControlInfo

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


SqlServerVersionInfo Property

[image]

SQL Data Compare API 12.0.40
Database..::.SqlServerVersionInfo Property
Database Class See Also

Information about the version of SQL Server this database exists on, including version number, compatibility level, internal version and whether or not it's an Azure database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SqlServerVersionInfo As SqlVersion
C#
public SqlVersion SqlServerVersionInfo { get; }
Visual C++
public:
virtual property SqlVersion^ SqlServerVersionInfo {
    SqlVersion^ get () sealed;
}

Implements

IVersionedDatabase..::.SqlServerVersionInfo

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


Status Property

[image]

SQL Data Compare API 12.0.40
Database..::.Status Property
Database Class See Also

Used to provide status events.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


SupportedFeatures Property

[image]

SQL Data Compare API 12.0.40
Database..::.SupportedFeatures Property
Database Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SupportedFeatures As IFeatureChecker
C#
public IFeatureChecker SupportedFeatures { get; internal set; }
Visual C++
public:
virtual property IFeatureChecker^ SupportedFeatures {
    IFeatureChecker^ get () sealed;
    void set (IFeatureChecker^ value) sealed;
}

Implements

IVersionedDatabase..::.SupportedFeatures

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


UnmodfiedTotalObjectCount Property

[image]

SQL Data Compare API 12.0.40
Database..::.UnmodfiedTotalObjectCount Property
Database Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property UnmodfiedTotalObjectCount As Integer
C#
public static int UnmodfiedTotalObjectCount { get; }
Visual C++
public:
static property int UnmodfiedTotalObjectCount {
    int get ();
}

See Also

Database Class
RedGate.SQLCompare.Engine Namespace


DatabaseCreation Class

[image]

SQL Data Compare API 12.0.40
DatabaseCreation Class
Members See Also

Methods for creating a live database with specific files and filegroups

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DatabaseCreation
C#
public static class DatabaseCreation
Visual C++
public ref class DatabaseCreation abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.DatabaseCreation

See Also

DatabaseCreation Members
RedGate.SQLCompare.Engine Namespace


DatabaseCreation Members

[image] [image]

SQL Data Compare API 12.0.40
DatabaseCreation Members
DatabaseCreation Class Methods See Also

The DatabaseCreation type exposes the following members.

Methods

Name | Description
CalculateDatabaseCreationInformation |
CreateDatabase | Overloaded.

See Also

DatabaseCreation Class
RedGate.SQLCompare.Engine Namespace


DatabaseCreation Methods

[image] [image]

SQL Data Compare API 12.0.40
DatabaseCreation Methods
DatabaseCreation Class See Also

The DatabaseCreation type exposes the following methods.

Methods

Name | Description
CalculateDatabaseCreationInformation |
CreateDatabase | Overloaded.

See Also

DatabaseCreation Class
RedGate.SQLCompare.Engine Namespace


CalculateDatabaseCreationInformation Method

[image]

SQL Data Compare API 12.0.40
DatabaseCreation..::.CalculateDatabaseCreationInformation Method
DatabaseCreation Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub CalculateDatabaseCreationInformation ( _
    targetDataSource As ConnectionProperties, _
    sourceDataSource As ConnectionProperties, _
    <OutAttribute> ByRef defaultDbName As String, _
    <OutAttribute> ByRef defaultCollation As String, _
    <OutAttribute> ByRef defaultDbFiles As List(Of DatabaseFile), _
    <OutAttribute> ByRef defaultDataPath As String, _
    <OutAttribute> ByRef defaultLogPath As String _
)
C#
public static void CalculateDatabaseCreationInformation(
    ConnectionProperties targetDataSource,
    ConnectionProperties sourceDataSource,
    out string defaultDbName,
    out string defaultCollation,
    out List<DatabaseFile> defaultDbFiles,
    out string defaultDataPath,
    out string defaultLogPath
)
Visual C++
public:
static void CalculateDatabaseCreationInformation(
    ConnectionProperties^ targetDataSource,
    ConnectionProperties^ sourceDataSource,
    [OutAttribute] String^% defaultDbName,
    [OutAttribute] String^% defaultCollation,
    [OutAttribute] List<DatabaseFile^>^% defaultDbFiles,
    [OutAttribute] String^% defaultDataPath,
    [OutAttribute] String^% defaultLogPath
)

Parameters

targetDataSource
Type: RedGate.SQLCompare.Engine..::.ConnectionProperties
sourceDataSource
Type: RedGate.SQLCompare.Engine..::.ConnectionProperties
defaultDbName
Type: String%
defaultCollation
Type: String%
defaultDbFiles
Type: List<(Of <( DatabaseFile >)>)%
defaultDataPath
Type: String%
defaultLogPath
Type: String%

See Also

DatabaseCreation Class
RedGate.SQLCompare.Engine Namespace


CreateDatabase Method

[image] [image]

SQL Data Compare API 12.0.40
DatabaseCreation..::.CreateDatabase Method
DatabaseCreation Class See Also

Overload List

Name | Description
CreateDatabase(DbConnection, DatabaseCreationInfo) | Run sql against connection to create the database specified by databaseCreationInfo
CreateDatabase(DbConnection, DatabaseCreationInfo, CancellationToken) | Run sql against connection to create the database specified by databaseCreationInfo. Use cancel to cancel the creation if necessary

See Also

DatabaseCreation Class
DatabaseCreation Members
RedGate.SQLCompare.Engine Namespace


CreateDatabase Method (, DatabaseCreationInfo)

[image]

SQL Data Compare API 12.0.40
DatabaseCreation..::.CreateDatabase Method (, DatabaseCreationInfo)
DatabaseCreation Class See Also

Run sql against connection to create the database specified by databaseCreationInfo

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub CreateDatabase ( _
    connection As DbConnection, _
    databaseCreationInfo As DatabaseCreationInfo _
)
C#
public static void CreateDatabase(
    DbConnection connection,
    DatabaseCreationInfo databaseCreationInfo
)
Visual C++
public:
static void CreateDatabase(
    DbConnection^ connection,
    DatabaseCreationInfo^ databaseCreationInfo
)

Parameters

connection
Type: DbConnection
databaseCreationInfo
Type: RedGate.SQLCompare.Engine..::.DatabaseCreationInfo

See Also

DatabaseCreation Class
CreateDatabase Overload
RedGate.SQLCompare.Engine Namespace


CreateDatabase Method (, DatabaseCreationInfo, )

[image]

SQL Data Compare API 12.0.40
DatabaseCreation..::.CreateDatabase Method (, DatabaseCreationInfo, )
DatabaseCreation Class See Also

Run sql against connection to create the database specified by databaseCreationInfo. Use cancel to cancel the creation if necessary

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub CreateDatabase ( _
    connection As DbConnection, _
    databaseCreationInfo As DatabaseCreationInfo, _
    cancel As CancellationToken _
)
C#
public static void CreateDatabase(
    DbConnection connection,
    DatabaseCreationInfo databaseCreationInfo,
    CancellationToken cancel
)
Visual C++
public:
static void CreateDatabase(
    DbConnection^ connection,
    DatabaseCreationInfo^ databaseCreationInfo,
    CancellationToken cancel
)

Parameters

connection
Type: DbConnection
databaseCreationInfo
Type: RedGate.SQLCompare.Engine..::.DatabaseCreationInfo
cancel
Type: CancellationToken

See Also

DatabaseCreation Class
CreateDatabase Overload
RedGate.SQLCompare.Engine Namespace


DatabaseCreationInfo Class

[image]

SQL Data Compare API 12.0.40
DatabaseCreationInfo Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class DatabaseCreationInfo
C#
public class DatabaseCreationInfo
Visual C++
public ref class DatabaseCreationInfo

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.DatabaseCreationInfo

See Also

DatabaseCreationInfo Members
RedGate.SQLCompare.Engine Namespace


DatabaseCreationInfo Members

[image] [image]

SQL Data Compare API 12.0.40
DatabaseCreationInfo Members
DatabaseCreationInfo Class Constructors Methods Properties See Also

The DatabaseCreationInfo type exposes the following members.

Constructors

Name | Description
DatabaseCreationInfo |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Collation |
DatabaseFiles |
Name |

See Also

DatabaseCreationInfo Class
RedGate.SQLCompare.Engine Namespace


DatabaseCreationInfo Constructor

[image]

SQL Data Compare API 12.0.40
DatabaseCreationInfo Constructor
DatabaseCreationInfo Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DatabaseCreationInfo()
Visual C++
public:
DatabaseCreationInfo()

See Also

DatabaseCreationInfo Class
RedGate.SQLCompare.Engine Namespace


DatabaseCreationInfo Properties

[image] [image]

SQL Data Compare API 12.0.40
DatabaseCreationInfo Properties
DatabaseCreationInfo Class See Also

The DatabaseCreationInfo type exposes the following properties.

Properties

Name | Description
Collation |
DatabaseFiles |
Name |

See Also

DatabaseCreationInfo Class
RedGate.SQLCompare.Engine Namespace


Collation Property

[image]

SQL Data Compare API 12.0.40
DatabaseCreationInfo..::.Collation Property
DatabaseCreationInfo Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Collation As String
C#
public string Collation { get; set; }
Visual C++
public:
property String^ Collation {
    String^ get ();
    void set (String^ value);
}

See Also

DatabaseCreationInfo Class
RedGate.SQLCompare.Engine Namespace


DatabaseFiles Property

[image]

SQL Data Compare API 12.0.40
DatabaseCreationInfo..::.DatabaseFiles Property
DatabaseCreationInfo Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DatabaseFiles As List(Of DatabaseFile)
C#
public List<DatabaseFile> DatabaseFiles { get; set; }
Visual C++
public:
property List<DatabaseFile^>^ DatabaseFiles {
    List<DatabaseFile^>^ get ();
    void set (List<DatabaseFile^>^ value);
}

See Also

DatabaseCreationInfo Class
RedGate.SQLCompare.Engine Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
DatabaseCreationInfo..::.Name Property
DatabaseCreationInfo Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

DatabaseCreationInfo Class
RedGate.SQLCompare.Engine Namespace


DatabaseExtensions Class

[image]

SQL Data Compare API 12.0.40
DatabaseExtensions Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DatabaseExtensions
C#
public static class DatabaseExtensions
Visual C++
public ref class DatabaseExtensions abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.DatabaseExtensions

See Also

DatabaseExtensions Members
RedGate.SQLCompare.Engine Namespace


DatabaseExtensions Members

[image] [image]

SQL Data Compare API 12.0.40
DatabaseExtensions Members
DatabaseExtensions Class Methods See Also

The DatabaseExtensions type exposes the following members.

Methods

Name | Description
GetSupportedFeatures |

See Also

DatabaseExtensions Class
RedGate.SQLCompare.Engine Namespace


DatabaseExtensions Methods

[image] [image]

SQL Data Compare API 12.0.40
DatabaseExtensions Methods
DatabaseExtensions Class See Also

The DatabaseExtensions type exposes the following methods.

Methods

Name | Description
GetSupportedFeatures |

See Also

DatabaseExtensions Class
RedGate.SQLCompare.Engine Namespace


GetSupportedFeatures Method

[image]

SQL Data Compare API 12.0.40
DatabaseExtensions..::.GetSupportedFeatures Method
DatabaseExtensions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSupportedFeatures ( _
    database As IVersionedDatabase _
) As IFeatureChecker
C#
public static IFeatureChecker GetSupportedFeatures(
    IVersionedDatabase database
)
Visual C++
public:
static IFeatureChecker^ GetSupportedFeatures(
    IVersionedDatabase^ database
)

Parameters

database
Type: RedGate.SQLCompare.Engine..::.IVersionedDatabase

See Also

DatabaseExtensions Class
RedGate.SQLCompare.Engine Namespace


DatabaseFile Class

[image]

SQL Data Compare API 12.0.40
DatabaseFile Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class DatabaseFile
C#
public class DatabaseFile
Visual C++
public ref class DatabaseFile

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.DatabaseFile

See Also

DatabaseFile Members
RedGate.SQLCompare.Engine Namespace


DatabaseFile Members

[image] [image]

SQL Data Compare API 12.0.40
DatabaseFile Members
DatabaseFile Class Constructors Methods Properties See Also

The DatabaseFile type exposes the following members.

Constructors

Name | Description
DatabaseFile |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FileGroup |
FileName |
FileType |
LogicalName |
Path |

See Also

DatabaseFile Class
RedGate.SQLCompare.Engine Namespace


DatabaseFile Constructor

[image]

SQL Data Compare API 12.0.40
DatabaseFile Constructor
DatabaseFile Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DatabaseFile()
Visual C++
public:
DatabaseFile()

See Also

DatabaseFile Class
RedGate.SQLCompare.Engine Namespace


DatabaseFile Properties

[image] [image]

SQL Data Compare API 12.0.40
DatabaseFile Properties
DatabaseFile Class See Also

The DatabaseFile type exposes the following properties.

Properties

Name | Description
FileGroup |
FileName |
FileType |
LogicalName |
Path |

See Also

DatabaseFile Class
RedGate.SQLCompare.Engine Namespace


FileGroup Property

[image]

SQL Data Compare API 12.0.40
DatabaseFile..::.FileGroup Property
DatabaseFile Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FileGroup As String
C#
public string FileGroup { get; set; }
Visual C++
public:
property String^ FileGroup {
    String^ get ();
    void set (String^ value);
}

See Also

DatabaseFile Class
RedGate.SQLCompare.Engine Namespace


FileName Property

[image]

SQL Data Compare API 12.0.40
DatabaseFile..::.FileName Property
DatabaseFile Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FileName As String
C#
public string FileName { get; set; }
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

See Also

DatabaseFile Class
RedGate.SQLCompare.Engine Namespace


FileType Property

[image]

SQL Data Compare API 12.0.40
DatabaseFile..::.FileType Property
DatabaseFile Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FileType As DatabaseFile..::.FileTypeOption
C#
public DatabaseFile..::.FileTypeOption FileType { get; set; }
Visual C++
public:
property DatabaseFile..::.FileTypeOption FileType {
    DatabaseFile..::.FileTypeOption get ();
    void set (DatabaseFile..::.FileTypeOption value);
}

See Also

DatabaseFile Class
RedGate.SQLCompare.Engine Namespace


LogicalName Property

[image]

SQL Data Compare API 12.0.40
DatabaseFile..::.LogicalName Property
DatabaseFile Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LogicalName As String
C#
public string LogicalName { get; set; }
Visual C++
public:
property String^ LogicalName {
    String^ get ();
    void set (String^ value);
}

See Also

DatabaseFile Class
RedGate.SQLCompare.Engine Namespace


Path Property

[image]

SQL Data Compare API 12.0.40
DatabaseFile..::.Path Property
DatabaseFile Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Path As String
C#
public string Path { get; set; }
Visual C++
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

See Also

DatabaseFile Class
RedGate.SQLCompare.Engine Namespace


DatabaseFile.FileTypeOption Enumeration

[image]

SQL Data Compare API 12.0.40
DatabaseFile..::.FileTypeOption Enumeration
DatabaseFile Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration FileTypeOption
C#
public enum FileTypeOption
Visual C++
public enum class FileTypeOption

Members

Member name | Description
Rows |
Log |
Filestream |

See Also

RedGate.SQLCompare.Engine Namespace


DatabaseLevelPermission Class

[image]

SQL Data Compare API 12.0.40
DatabaseLevelPermission Class
Members See Also

A database-level permission.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DatabaseLevelPermission
C#
public sealed class DatabaseLevelPermission
Visual C++
public ref class DatabaseLevelPermission sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.DatabaseLevelPermission

See Also

DatabaseLevelPermission Members
RedGate.SQLCompare.Engine Namespace


DatabaseLevelPermission Members

[image] [image]

SQL Data Compare API 12.0.40
DatabaseLevelPermission Members
DatabaseLevelPermission Class Methods Properties See Also

The DatabaseLevelPermission type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetPermissionActionName | Returns the SQL text name for a database-level permission.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Action | The action to which the permission applies.
Type | The type of permission.
UserName | The user or role to which the permission applies.

See Also

DatabaseLevelPermission Class
RedGate.SQLCompare.Engine Namespace


DatabaseLevelPermission Methods

[image] [image]

SQL Data Compare API 12.0.40
DatabaseLevelPermission Methods
DatabaseLevelPermission Class See Also

The DatabaseLevelPermission type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetPermissionActionName | Returns the SQL text name for a database-level permission.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseLevelPermission Class
RedGate.SQLCompare.Engine Namespace


GetPermissionActionName Method

[image]

SQL Data Compare API 12.0.40
DatabaseLevelPermission..::.GetPermissionActionName Method
DatabaseLevelPermission Class See Also

Returns the SQL text name for a database-level permission.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetPermissionActionName ( _
    pa As DatabaseLevelPermissionAction _
) As String
C#
public static string GetPermissionActionName(
    DatabaseLevelPermissionAction pa
)
Visual C++
public:
static String^ GetPermissionActionName(
    DatabaseLevelPermissionAction pa
)

Parameters

pa
Type: RedGate.SQLCompare.Engine..::.DatabaseLevelPermissionAction
The permission action for which the SQL name is requested.

Return Value

The SQL text name for a database-level permission.

See Also

DatabaseLevelPermission Class
RedGate.SQLCompare.Engine Namespace


DatabaseLevelPermission Properties

[image] [image]

SQL Data Compare API 12.0.40
DatabaseLevelPermission Properties
DatabaseLevelPermission Class See Also

The DatabaseLevelPermission type exposes the following properties.

Properties

Name | Description
Action | The action to which the permission applies.
Type | The type of permission.
UserName | The user or role to which the permission applies.

See Also

DatabaseLevelPermission Class
RedGate.SQLCompare.Engine Namespace


Action Property

[image]

SQL Data Compare API 12.0.40
DatabaseLevelPermission..::.Action Property
DatabaseLevelPermission Class See Also

The action to which the permission applies.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Action As DatabaseLevelPermissionAction
C#
public DatabaseLevelPermissionAction Action { get; }
Visual C++
public:
property DatabaseLevelPermissionAction Action {
    DatabaseLevelPermissionAction get ();
}

See Also

DatabaseLevelPermission Class
RedGate.SQLCompare.Engine Namespace


Type Property

[image]

SQL Data Compare API 12.0.40
DatabaseLevelPermission..::.Type Property
DatabaseLevelPermission Class See Also

The type of permission.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As PermissionStatementType
C#
public PermissionStatementType Type { get; }
Visual C++
public:
property PermissionStatementType Type {
    PermissionStatementType get ();
}

See Also

DatabaseLevelPermission Class
RedGate.SQLCompare.Engine Namespace


UserName Property

[image]

SQL Data Compare API 12.0.40
DatabaseLevelPermission..::.UserName Property
DatabaseLevelPermission Class See Also

The user or role to which the permission applies.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UserName As String
C#
public string UserName { get; }
Visual C++
public:
property String^ UserName {
    String^ get ();
}

See Also

DatabaseLevelPermission Class
RedGate.SQLCompare.Engine Namespace


DatabaseLevelPermissionAction Enumeration

[image]

SQL Data Compare API 12.0.40
DatabaseLevelPermissionAction Enumeration
See Also

The database-level permission.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration DatabaseLevelPermissionAction
C#
public enum DatabaseLevelPermissionAction
Visual C++
public enum class DatabaseLevelPermissionAction

Members

Member name | Description
None | None, this is for internal use only.
Alter | Alter (AL )
AlterAnyAsymmetricKey | Alter Any Asymmetric Key (ALAK)
AlterAnyApplicationRole | Alter Any Application Role (ALAR)
AlterAnyAssembly | Alter Any Assembly (ALAS)
AlterAnyCertificate | Alter Any Certificate (ALCF)
AlterAnyDataspace | Alter Any Data Space (ALDS)
AlterAnyDatabaseEventNotification | Alter Any Database Event Notification (ALED)
AlterAnyFulltextCatalog | Alter Any Full Text Catalog (ALFT)
AlterAnyMessageType | Alter Any Message Type (ALMT)
AlterAnyRole | Alter Any Role (ALRL)
AlterAnyRoute | Alter Any Route (ALRT)
AlterAnyRemoteServiceBinding | Alter Any Remote Service Binding (ALSB)
AlterAnyContract | Alter Any Contract (ALSC)
AlterAnySymmetricKey | Alter Any Symmetric Key (ALSK)
AlterAnySchema | Alter Any Schema (ALSM)
AlterAnyService | Alter Any Service (ALSV)
AlterAnyDatabaseDdlTrigger | Alter Any Database DDL Trigger (ALTG)
AlterAnyUser | Alter Any User (ALUS)
Authenticate | Authenticate (AUTH)
BackupDatabase | Back Up Database (BADB)
BackupLog | Back Up Log (BALO)
Control | Control (CL )
Connect | Connect (CO )
ConnectReplication | Connect Replication (CORP)
Checkpoint | Checkpoint (CP )
CreateAggregate | Create Aggregate (CRAG)
CreateAsymmetricKey | Create Asymmetric Key (CRAK)
CreateAssembly | Create Assembly (CRAS)
CreateCertificate | Create Certificate (CRCF)
CreateDatabase | Create Database (CRDB)
CreateDefault | Create Default (CRDF)
CreateDatabaseDdlEventNotification | Create Database DDL Event Notification (CRED)
CreateFunction | Create Function (CRFN)
CreateFulltextCatalog | Create Full Text Catalog (CRFT)
CreateMessageType | Create Message Type (CRMT)
CreateProcedure | Create Procedure (CRPR)
CreateQueue | Create Queue (CRQU)
CreateRole | Create Role (CRRL)
CreateRoute | Create Route (CRRT)
CreateRule | Create Rule (CRRU)
CreateRemoteServiceBinding | Create Remote Service Binding (CRSB)
CreateContract | Create Contract (CRSC)
CreateSymmetricKey | Create Symmetric Key (CRSK)
CreateSchema | Create Schema (CRSM)
CreateSynonym | Create Synonym (CRSN)
CreateService | Create Service (CRSV)
CreateTable | Create Table (CRTB)
CreateType | Create Type (CRTY)
CreateView | Create View (CRVW)
CreateXmlSchemaCollection | Create XML Schema Collection (CRXS)
Delete | Delete (DL)
Execute | Execute (EX)
Impersonate | Impersonate (IM)
Insert | Insert (IN )
Receive | Receive (RC)
References | References (RF)
Select | Select (SL)
Send | Send (SN)
Showplan | Showplan (SPLN)
SubscribeQueryNotifications | Subscribe Query Notifications (SUQN)
TakeOwnership | Take Ownership (TO )
Update | Update (UP)
ViewDefinition | View Definition (VW)
ViewDatabaseState | View Database State (VWDS)
AlterAnyDatabaseAudit | Alter Any Database Audit (ALDA)
AlterAnyMask | Alter Any Mask (AAMK)
Unmask | Unmask (UMSK)
ViewAnyColumnEncryptionKeyDefinition | VWCK
ViewAnyColumnMasterKeyDefinition | VWCM

See Also

RedGate.SQLCompare.Engine Namespace


DatabaseLevelPermissions Class

[image]

SQL Data Compare API 12.0.40
DatabaseLevelPermissions Class
Members See Also

A collection of database-level permissions.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DatabaseLevelPermissions
C#
public sealed class DatabaseLevelPermissions
Visual C++
public ref class DatabaseLevelPermissions sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.DatabaseLevelPermissions

See Also

DatabaseLevelPermissions Members
RedGate.SQLCompare.Engine Namespace


DatabaseLevelPermissions Members

[image] [image]

SQL Data Compare API 12.0.40
DatabaseLevelPermissions Members
DatabaseLevelPermissions Class Methods Properties See Also

The DatabaseLevelPermissions type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Item | The permission type for a specific permission action.

See Also

DatabaseLevelPermissions Class
RedGate.SQLCompare.Engine Namespace


DatabaseLevelPermissions Methods

[image] [image]

SQL Data Compare API 12.0.40
DatabaseLevelPermissions Methods
DatabaseLevelPermissions Class See Also

The DatabaseLevelPermissions type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseLevelPermissions Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
DatabaseLevelPermissions..::.Equals Method
DatabaseLevelPermissions Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(DatabaseLevelPermissions, Options) | Compares the database-level permission with a specified database-level permission.

See Also

DatabaseLevelPermissions Class
DatabaseLevelPermissions Members
RedGate.SQLCompare.Engine Namespace


Equals Method (DatabaseLevelPermissions, Options)

[image]

SQL Data Compare API 12.0.40
DatabaseLevelPermissions..::.Equals Method (DatabaseLevelPermissions, Options)
DatabaseLevelPermissions Class See Also

Compares the database-level permission with a specified database-level permission.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    targetPermissions As DatabaseLevelPermissions, _
    options As Options _
) As Boolean
C#
public bool Equals(
    DatabaseLevelPermissions targetPermissions,
    Options options
)
Visual C++
public:
bool Equals(
    DatabaseLevelPermissions^ targetPermissions,
    Options options
)

Parameters

targetPermissions
Type: RedGate.SQLCompare.Engine..::.DatabaseLevelPermissions
The database-level permissions to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the database-level permisssions are identical; otherwise, false.

See Also

DatabaseLevelPermissions Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


DatabaseLevelPermissions Properties

[image] [image]

SQL Data Compare API 12.0.40
DatabaseLevelPermissions Properties
DatabaseLevelPermissions Class See Also

The DatabaseLevelPermissions type exposes the following properties.

Properties

Name | Description
Item | The permission type for a specific permission action.

See Also

DatabaseLevelPermissions Class
RedGate.SQLCompare.Engine Namespace


Item Property

[image]

SQL Data Compare API 12.0.40
DatabaseLevelPermissions..::.Item Property
DatabaseLevelPermissions Class See Also

The permission type for a specific permission action.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item ( _
    permission As DatabaseLevelPermissionAction _
) As PermissionStatementType
C#
public PermissionStatementType this[
    DatabaseLevelPermissionAction permission
] { get; set; }
Visual C++
public:
property PermissionStatementType default[DatabaseLevelPermissionAction permission] {
    PermissionStatementType get (DatabaseLevelPermissionAction permission);
    void set (DatabaseLevelPermissionAction permission, PermissionStatementType value);
}

Parameters

permission
Type: RedGate.SQLCompare.Engine..::.DatabaseLevelPermissionAction
The permission type.

See Also

DatabaseLevelPermissions Class
RedGate.SQLCompare.Engine Namespace


DatabaseObjectCollection(T) Generic Class

[image]

SQL Data Compare API 12.0.40
DatabaseObjectCollection<(Of <(T>)>) Generic Class
Members See Also

A collection of database objects that doesn't know how to serialize itself to a SQL Compare snapshot. Compare with RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection<(Of <(T>)>)

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class DatabaseObjectCollection(Of T As IDatabaseObject) _
    Inherits KeyedCollection(Of T) _
    Implements IDatabaseObjects(Of T), IKeyedCollection(Of T),  _
    IEnumerable(Of T), IEnumerable, INonReadOnlyCollection
C#
public class DatabaseObjectCollection<T> : KeyedCollection<T>, IDatabaseObjects<T>,
    IKeyedCollection<T>, IEnumerable<T>, IEnumerable, INonReadOnlyCollection where T : IDatabaseObject
Visual C++
generic<typename T>
where T : IDatabaseObject
public ref class DatabaseObjectCollection : public KeyedCollection<T>,
    IDatabaseObjects<T>, IKeyedCollection<T>, IEnumerable<T>, IEnumerable, INonReadOnlyCollection

Type Parameters

T

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <(T>)>)
RedGate.SQLCompare.Engine..::.DatabaseObjectCollection<(Of <(T>)>)
RedGate.SQLCompare.Engine..::.Fields
RedGate.SQLCompare.Engine..::.Tables

See Also

DatabaseObjectCollection<(Of <(T>)>) Members
RedGate.SQLCompare.Engine Namespace
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection<(Of <(T>)>)


DatabaseObjectCollection(T) Members

[image] [image]

SQL Data Compare API 12.0.40
DatabaseObjectCollection<(Of <(T>)>) Members
DatabaseObjectCollection<(Of <(T>)>) Class Methods Fields Properties Explicit Interface Implementations See Also

The DatabaseObjectCollection<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Add | (Overrides KeyedCollection <(Of <( T >)>)..::. Add(T).)
AsReadOnly |
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Overrides KeyedCollection <(Of <( T >)>)..::.GetKey(UTP).)
GetObjectNameForException | Get a nicely-formatted object name to display to the user if the Add(T) method throws an argument exception
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

DatabaseObjectCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


DatabaseObjectCollection(T) Methods

[image] [image]

SQL Data Compare API 12.0.40
DatabaseObjectCollection<(Of <(T>)>) Methods
DatabaseObjectCollection<(Of <(T>)>) Class See Also

The DatabaseObjectCollection<(Of <(T>)>) type exposes the following methods.

Methods

Name | Description
Add | (Overrides KeyedCollection <(Of <( T >)>)..::. Add(T).)
AsReadOnly |
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Overrides KeyedCollection <(Of <( T >)>)..::.GetKey(UTP).)
GetObjectNameForException | Get a nicely-formatted object name to display to the user if the Add(T) method throws an argument exception
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

DatabaseObjectCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


Add Method

[image]

SQL Data Compare API 12.0.40
DatabaseObjectCollection<(Of <(T>)>)..::.Add Method
DatabaseObjectCollection<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Add ( _
    value As T _
)
C#
public override void Add(
    T value
)
Visual C++
public:
virtual void Add(
    T value
) override

Parameters

value
Type: T

Implements

IKeyedCollectionAdd(UTP)

See Also

DatabaseObjectCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


AsReadOnly Method

[image]

SQL Data Compare API 12.0.40
DatabaseObjectCollection<(Of <(T>)>)..::.AsReadOnly Method
DatabaseObjectCollection<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function AsReadOnly As IReadOnlyKeyedDatabaseObjectCollectionWrapper
C#
public IReadOnlyKeyedDatabaseObjectCollectionWrapper AsReadOnly()
Visual C++
public:
virtual IReadOnlyKeyedDatabaseObjectCollectionWrapper^ AsReadOnly() sealed

Implements

INonReadOnlyCollection..::.AsReadOnly()()()

See Also

DatabaseObjectCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


GetKey Method

[image]

SQL Data Compare API 12.0.40
DatabaseObjectCollection<(Of <(T>)>)..::.GetKey Method
DatabaseObjectCollection<(Of <(T>)>) Class See Also

For internal use.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Friend Overrides Function GetKey ( _
    value As T _
) As String
C#
protected internal override string GetKey(
    T value
)
Visual C++
protected public:
virtual String^ GetKey(
    T value
) override

Parameters

value
Type: T
For internal use

Return Value

For internal use

See Also

DatabaseObjectCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


GetObjectNameForException Method

[image]

SQL Data Compare API 12.0.40
DatabaseObjectCollection<(Of <(T>)>)..::.GetObjectNameForException Method
DatabaseObjectCollection<(Of <(T>)>) Class See Also

Get a nicely-formatted object name to display to the user if the Add(T) method throws an argument exception

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetObjectNameForException ( _
    value As T _
) As String
C#
protected virtual string GetObjectNameForException(
    T value
)
Visual C++
protected:
virtual String^ GetObjectNameForException(
    T value
)

Parameters

value
Type: T

See Also

DatabaseObjectCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


DatabaseObjectCollection(T) Properties

[image] [image]

SQL Data Compare API 12.0.40
DatabaseObjectCollection<(Of <(T>)>) Properties
DatabaseObjectCollection<(Of <(T>)>) Class See Also

The DatabaseObjectCollection<(Of <(T>)>) type exposes the following properties.

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

See Also

DatabaseObjectCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
DatabaseObjectCollection<(Of <(T>)>)..::.Item Property
DatabaseObjectCollection<(Of <(T>)>) Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name.

See Also

DatabaseObjectCollection<(Of <(T>)>) Class
DatabaseObjectCollection<(Of <(T>)>) Members
RedGate.SQLCompare.Engine Namespace


Item Property (, )

[image]

SQL Data Compare API 12.0.40
DatabaseObjectCollection<(Of <(T>)>)..::.Item Property (, )
DatabaseObjectCollection<(Of <(T>)>) Class See Also

Returns a database object given its owner and name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Default Property Item ( _
    owner As String, _
    name As String _
) As T
C#
public virtual T this[
    string owner,
    string name
] { get; }
Visual C++
public:
virtual property T default[String^ owner, String^ name] {
    T get (String^ owner, String^ name);
}

Parameters

owner
Type: String
The owner component of the string-based index of the element to get or set.
name
Type: String
The name component of the string-based index of the element to get or set.

See Also

DatabaseObjectCollection<(Of <(T>)>) Class
Item Overload
RedGate.SQLCompare.Engine Namespace


DatabaseObjectExistsException Class

[image]

SQL Data Compare API 12.0.40
DatabaseObjectExistsException Class
Members See Also

Exception thrown when a matching IDatabaseObject already exists in a collection. It is a DuplicateObjectNameException that stores which IDatabaseObject was found to already exist.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class DatabaseObjectExistsException _
    Inherits DuplicateObjectNameException
C#
public class DatabaseObjectExistsException : DuplicateObjectNameException
Visual C++
public ref class DatabaseObjectExistsException : public DuplicateObjectNameException

Inheritance Hierarchy

Object
Exception
RedGate.SQLCompare.Engine..::.SqlCompareException
RedGate.SQLCompare.Engine..::.DuplicateObjectNameException
RedGate.SQLCompare.Engine..::.DatabaseObjectExistsException

See Also

DatabaseObjectExistsException Members
RedGate.SQLCompare.Engine Namespace


DatabaseObjectExistsException Members

[image] [image]

SQL Data Compare API 12.0.40
DatabaseObjectExistsException Members
DatabaseObjectExistsException Class Constructors Methods Properties See Also

The DatabaseObjectExistsException type exposes the following members.

Constructors

Name | Description
DatabaseObjectExistsException | The serialization constructor. Note - the Object property is not preserved across serialization boundaries because IDatabaseObject implementations might not be SerializableAttribute.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | Sets the SerializationInfo object with the custom properties on this exception. (Inherited from DuplicateObjectNameException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
IsCaseInsensitiveCollision | Whether the duplicate was with a name that differed only by case. (Inherited from DuplicateObjectNameException.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Object | The IDatabaseObject that was found to have a matching object already defined.
ObjectName | The name of the object that already existed (Inherited from DuplicateObjectNameException.)
ObjectType | The type of object involved in the collision (a human-readable string used in the exception message) (Inherited from DuplicateObjectNameException.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DatabaseObjectExistsException Class
RedGate.SQLCompare.Engine Namespace


DatabaseObjectExistsException Constructor

[image]

SQL Data Compare API 12.0.40
DatabaseObjectExistsException Constructor
DatabaseObjectExistsException Class See Also

The serialization constructor. Note - the Object property is not preserved across serialization boundaries because IDatabaseObject implementations might not be SerializableAttribute.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected DatabaseObjectExistsException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
DatabaseObjectExistsException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: SerializationInfo
context
Type: StreamingContext

See Also

DatabaseObjectExistsException Class
RedGate.SQLCompare.Engine Namespace


DatabaseObjectExistsException Properties

[image] [image]

SQL Data Compare API 12.0.40
DatabaseObjectExistsException Properties
DatabaseObjectExistsException Class See Also

The DatabaseObjectExistsException type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
IsCaseInsensitiveCollision | Whether the duplicate was with a name that differed only by case. (Inherited from DuplicateObjectNameException.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Object | The IDatabaseObject that was found to have a matching object already defined.
ObjectName | The name of the object that already existed (Inherited from DuplicateObjectNameException.)
ObjectType | The type of object involved in the collision (a human-readable string used in the exception message) (Inherited from DuplicateObjectNameException.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DatabaseObjectExistsException Class
RedGate.SQLCompare.Engine Namespace


Object Property

[image]

SQL Data Compare API 12.0.40
DatabaseObjectExistsException..::.Object Property
DatabaseObjectExistsException Class See Also

The IDatabaseObject that was found to have a matching object already defined.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Object As IDatabaseObject
C#
public IDatabaseObject Object { get; }
Visual C++
public:
property IDatabaseObject^ Object {
    IDatabaseObject^ get ();
}

See Also

DatabaseObjectExistsException Class
RedGate.SQLCompare.Engine Namespace


DatabaseObjectWithAuthorization Class

[image]

SQL Data Compare API 12.0.40
DatabaseObjectWithAuthorization Class
Members See Also

A database object that can have its owner altered using ALTER AUTHORIZATION.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class DatabaseObjectWithAuthorization _
    Inherits ScriptableDatabaseObject _
    Implements IHasAuthorization, IDatabaseObject, ITSqlObject, ICanExistenceCheck
C#
public abstract class DatabaseObjectWithAuthorization : ScriptableDatabaseObject, IHasAuthorization,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck
Visual C++
public ref class DatabaseObjectWithAuthorization abstract : public ScriptableDatabaseObject,
    IHasAuthorization, IDatabaseObject, ITSqlObject, ICanExistenceCheck

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorizationAndExtendedProperties
RedGate.SQLCompare.Engine..::.SearchPropertyList
RedGate.SQLCompare.Engine..::.AsymmetricKey
RedGate.SQLCompare.Engine..::.Certificate
RedGate.SQLCompare.Engine..::.FullTextStoplist
RedGate.SQLCompare.Engine..::.FullTextCatalog
RedGate.SQLCompare.Engine..::.SymmetricKey

See Also

DatabaseObjectWithAuthorization Members
RedGate.SQLCompare.Engine Namespace


DatabaseObjectWithAuthorization Members

[image] [image]

SQL Data Compare API 12.0.40
DatabaseObjectWithAuthorization Members
DatabaseObjectWithAuthorization Class Methods Fields Properties See Also

The DatabaseObjectWithAuthorization type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Inherited from ScriptableDatabaseObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AlterAuthorizationClassType |
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | The type of the object. (Inherited from ScriptableDatabaseObject.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement.
ScriptSources | (Inherited from ScriptableDatabaseObject.)

See Also

DatabaseObjectWithAuthorization Class
RedGate.SQLCompare.Engine Namespace


DatabaseObjectWithAuthorization Properties

[image] [image]

SQL Data Compare API 12.0.40
DatabaseObjectWithAuthorization Properties
DatabaseObjectWithAuthorization Class See Also

The DatabaseObjectWithAuthorization type exposes the following properties.

Properties

Name | Description
AlterAuthorizationClassType |
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | The type of the object. (Inherited from ScriptableDatabaseObject.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement.
ScriptSources | (Inherited from ScriptableDatabaseObject.)

See Also

DatabaseObjectWithAuthorization Class
RedGate.SQLCompare.Engine Namespace


AlterAuthorizationClassType Property

[image]

SQL Data Compare API 12.0.40
DatabaseObjectWithAuthorization..::.AlterAuthorizationClassType Property
DatabaseObjectWithAuthorization Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property AlterAuthorizationClassType As String
C#
public abstract string AlterAuthorizationClassType { get; }
Visual C++
public:
virtual property String^ AlterAuthorizationClassType {
    String^ get () abstract;
}

Implements

IHasAuthorization..::.AlterAuthorizationClassType

See Also

DatabaseObjectWithAuthorization Class
RedGate.SQLCompare.Engine Namespace


ScriptSourceAuthorization Property

[image]

SQL Data Compare API 12.0.40
DatabaseObjectWithAuthorization..::.ScriptSourceAuthorization Property
DatabaseObjectWithAuthorization Class See Also

The script source for any ALTER AUTHORIZATION statement.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSourceAuthorization As ScriptSource
C#
public ScriptSource ScriptSourceAuthorization { get; internal set; }
Visual C++
public:
property ScriptSource^ ScriptSourceAuthorization {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

DatabaseObjectWithAuthorization Class
RedGate.SQLCompare.Engine Namespace


DatabaseObjectWithAuthorizationAndExtendedProperties Class

[image]

SQL Data Compare API 12.0.40
DatabaseObjectWithAuthorizationAndExtendedProperties Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class DatabaseObjectWithAuthorizationAndExtendedProperties _
    Inherits DatabaseObjectWithAuthorization
C#
public abstract class DatabaseObjectWithAuthorizationAndExtendedProperties : DatabaseObjectWithAuthorization
Visual C++
public ref class DatabaseObjectWithAuthorizationAndExtendedProperties abstract : public DatabaseObjectWithAuthorization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorizationAndExtendedProperties
RedGate.SQLCompare.Engine..::.ClrAssembly
RedGate.SQLCompare.Engine..::.Contract
RedGate.SQLCompare.Engine..::.MessageType
RedGate.SQLCompare.Engine..::.Role
RedGate.SQLCompare.Engine..::.Route
RedGate.SQLCompare.Engine..::.Schema
RedGate.SQLCompare.Engine..::.Service
RedGate.SQLCompare.Engine..::.ServiceBinding

See Also

DatabaseObjectWithAuthorizationAndExtendedProperties Members
RedGate.SQLCompare.Engine Namespace


DatabaseObjectWithAuthorizationAndExtendedProperties Members

[image] [image]

SQL Data Compare API 12.0.40
DatabaseObjectWithAuthorizationAndExtendedProperties Members
DatabaseObjectWithAuthorizationAndExtendedProperties Class Constructors Methods Fields Properties See Also

The DatabaseObjectWithAuthorizationAndExtendedProperties type exposes the following members.

Constructors

Name | Description
DatabaseObjectWithAuthorizationAndExtendedProperties |

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Inherited from ScriptableDatabaseObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AlterAuthorizationClassType | (Inherited from DatabaseObjectWithAuthorization.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties |
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | The type of the object. (Inherited from ScriptableDatabaseObject.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions |
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)

See Also

DatabaseObjectWithAuthorizationAndExtendedProperties Class
RedGate.SQLCompare.Engine Namespace


DatabaseObjectWithAuthorizationAndExtendedProperties Constructor

[image]

SQL Data Compare API 12.0.40
DatabaseObjectWithAuthorizationAndExtendedProperties Constructor
DatabaseObjectWithAuthorizationAndExtendedProperties Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected DatabaseObjectWithAuthorizationAndExtendedProperties()
Visual C++
protected:
DatabaseObjectWithAuthorizationAndExtendedProperties()

See Also

DatabaseObjectWithAuthorizationAndExtendedProperties Class
RedGate.SQLCompare.Engine Namespace


DatabaseObjectWithAuthorizationAndExtendedProperties Properties

[image] [image]

SQL Data Compare API 12.0.40
DatabaseObjectWithAuthorizationAndExtendedProperties Properties
DatabaseObjectWithAuthorizationAndExtendedProperties Class See Also

The DatabaseObjectWithAuthorizationAndExtendedProperties type exposes the following properties.

Properties

Name | Description
AlterAuthorizationClassType | (Inherited from DatabaseObjectWithAuthorization.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties |
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | The type of the object. (Inherited from ScriptableDatabaseObject.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions |
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)

See Also

DatabaseObjectWithAuthorizationAndExtendedProperties Class
RedGate.SQLCompare.Engine Namespace


ExtendedProperties Property

[image]

SQL Data Compare API 12.0.40
DatabaseObjectWithAuthorizationAndExtendedProperties..::.ExtendedProperties Property
DatabaseObjectWithAuthorizationAndExtendedProperties Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedProperties As ExtendedProperties
C#
public ExtendedProperties ExtendedProperties { get; protected set; }
Visual C++
public:
property ExtendedProperties^ ExtendedProperties {
    ExtendedProperties^ get ();
    void set (ExtendedProperties^ value);
}

See Also

DatabaseObjectWithAuthorizationAndExtendedProperties Class
RedGate.SQLCompare.Engine Namespace


Permissions Property

[image]

SQL Data Compare API 12.0.40
DatabaseObjectWithAuthorizationAndExtendedProperties..::.Permissions Property
DatabaseObjectWithAuthorizationAndExtendedProperties Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Permissions As Permissions
C#
public Permissions Permissions { get; protected set; }
Visual C++
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
    void set (Permissions^ value) sealed;
}

See Also

DatabaseObjectWithAuthorizationAndExtendedProperties Class
RedGate.SQLCompare.Engine Namespace


DatabaseSource Enumeration

[image]

SQL Data Compare API 12.0.40
DatabaseSource Enumeration
See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration DatabaseSource
C#
public enum DatabaseSource
Visual C++
public enum class DatabaseSource

Members

Member name | Description
Unknown |
LiveDatabase |
Snapshot |
ScriptFolder |
Backup |

See Also

RedGate.SQLCompare.Engine Namespace


DataCompareGroupingStyle Enumeration

[image]

SQL Data Compare API 12.0.40
DataCompareGroupingStyle Enumeration
See Also

An enumeration of the possible grouping styles supported by the main grid.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration DataCompareGroupingStyle
C#
public enum DataCompareGroupingStyle
Visual C++
public enum class DataCompareGroupingStyle

Members

Member name | Description
Comparison | Indicates that the results should be grouped by the result of the comparison (this is the default style)
Flat | Indicates that the results should not be grouped at all

See Also

RedGate.SQLCompare.Engine Namespace


DataCompareIndexDeploymentSql Class

[image]

SQL Data Compare API 12.0.40
DataCompareIndexDeploymentSql Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class DataCompareIndexDeploymentSql
C#
public class DataCompareIndexDeploymentSql
Visual C++
public ref class DataCompareIndexDeploymentSql

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.DataCompareIndexDeploymentSql

See Also

DataCompareIndexDeploymentSql Members
RedGate.SQLCompare.Engine Namespace


DataCompareIndexDeploymentSql Members

[image] [image]

SQL Data Compare API 12.0.40
DataCompareIndexDeploymentSql Members
DataCompareIndexDeploymentSql Class Constructors Methods See Also

The DataCompareIndexDeploymentSql type exposes the following members.

Constructors

Name | Description
DataCompareIndexDeploymentSql |

Methods

Name | Description
AlterIndexRebuild |
AlterTableAddIndex |
AlterTableDisableTrigger |
AlterTableDropConstraint | Overloaded.
AlterTableEnableTrigger |
AlterTableNocheckConstraint | Generate SQL to disable a constraint
CreateIndex |
DropIndex |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RestoreConstraintEnabledness | Generate SQL to re-enable a constraint
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataCompareIndexDeploymentSql Class
RedGate.SQLCompare.Engine Namespace


DataCompareIndexDeploymentSql Constructor

[image]

SQL Data Compare API 12.0.40
DataCompareIndexDeploymentSql Constructor
DataCompareIndexDeploymentSql Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    options As Options, _
    targetSQLVersion As SQLVersion _
)
C#
public DataCompareIndexDeploymentSql(
    Options options,
    SQLVersion targetSQLVersion
)
Visual C++
public:
DataCompareIndexDeploymentSql(
    Options options,
    SQLVersion targetSQLVersion
)

Parameters

options
Type: RedGate.SQLCompare.Engine..::.Options
targetSQLVersion
Type: SQLVersion

See Also

DataCompareIndexDeploymentSql Class
RedGate.SQLCompare.Engine Namespace


DataCompareIndexDeploymentSql Methods

[image] [image]

SQL Data Compare API 12.0.40
DataCompareIndexDeploymentSql Methods
DataCompareIndexDeploymentSql Class See Also

The DataCompareIndexDeploymentSql type exposes the following methods.

Methods

Name | Description
AlterIndexRebuild |
AlterTableAddIndex |
AlterTableDisableTrigger |
AlterTableDropConstraint | Overloaded.
AlterTableEnableTrigger |
AlterTableNocheckConstraint | Generate SQL to disable a constraint
CreateIndex |
DropIndex |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RestoreConstraintEnabledness | Generate SQL to re-enable a constraint
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataCompareIndexDeploymentSql Class
RedGate.SQLCompare.Engine Namespace


AlterIndexRebuild Method

[image]

SQL Data Compare API 12.0.40
DataCompareIndexDeploymentSql..::.AlterIndexRebuild Method
DataCompareIndexDeploymentSql Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function AlterIndexRebuild ( _
    columnStoreindex As RelationalIndex, _
    target As ViewTableSuperClass _
) As String
C#
public string AlterIndexRebuild(
    RelationalIndex columnStoreindex,
    ViewTableSuperClass target
)
Visual C++
public:
String^ AlterIndexRebuild(
    RelationalIndex^ columnStoreindex,
    ViewTableSuperClass^ target
)

Parameters

columnStoreindex
Type: RedGate.SQLCompare.Engine..::.RelationalIndex
target
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass

See Also

DataCompareIndexDeploymentSql Class
RedGate.SQLCompare.Engine Namespace


AlterTableAddIndex Method

[image]

SQL Data Compare API 12.0.40
DataCompareIndexDeploymentSql..::.AlterTableAddIndex Method
DataCompareIndexDeploymentSql Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function AlterTableAddIndex ( _
    target As ViewTableSuperClass, _
    relIndex As RelationalIndex _
) As String
C#
public string AlterTableAddIndex(
    ViewTableSuperClass target,
    RelationalIndex relIndex
)
Visual C++
public:
String^ AlterTableAddIndex(
    ViewTableSuperClass^ target,
    RelationalIndex^ relIndex
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
relIndex
Type: RedGate.SQLCompare.Engine..::.RelationalIndex

See Also

DataCompareIndexDeploymentSql Class
RedGate.SQLCompare.Engine Namespace


AlterTableDisableTrigger Method

[image]

SQL Data Compare API 12.0.40
DataCompareIndexDeploymentSql..::.AlterTableDisableTrigger Method
DataCompareIndexDeploymentSql Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function AlterTableDisableTrigger ( _
    target As ViewTableSuperClass, _
    trigger As Trigger _
) As String
C#
public string AlterTableDisableTrigger(
    ViewTableSuperClass target,
    Trigger trigger
)
Visual C++
public:
String^ AlterTableDisableTrigger(
    ViewTableSuperClass^ target,
    Trigger^ trigger
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
trigger
Type: RedGate.SQLCompare.Engine..::.Trigger

See Also

DataCompareIndexDeploymentSql Class
RedGate.SQLCompare.Engine Namespace


AlterTableDropConstraint Method

[image] [image]

SQL Data Compare API 12.0.40
DataCompareIndexDeploymentSql..::.AlterTableDropConstraint Method
DataCompareIndexDeploymentSql Class See Also

Overload List

Name | Description
AlterTableDropConstraint(ViewTableSuperClass, ForeignKey) |
AlterTableDropConstraint(ViewTableSuperClass, Index) |

See Also

DataCompareIndexDeploymentSql Class
DataCompareIndexDeploymentSql Members
RedGate.SQLCompare.Engine Namespace


AlterTableDropConstraint Method (ViewTableSuperClass, ForeignKey)

[image]

SQL Data Compare API 12.0.40
DataCompareIndexDeploymentSql..::.AlterTableDropConstraint Method (ViewTableSuperClass, ForeignKey)
DataCompareIndexDeploymentSql Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function AlterTableDropConstraint ( _
    target As ViewTableSuperClass, _
    fk As ForeignKey _
) As String
C#
public string AlterTableDropConstraint(
    ViewTableSuperClass target,
    ForeignKey fk
)
Visual C++
public:
String^ AlterTableDropConstraint(
    ViewTableSuperClass^ target,
    ForeignKey^ fk
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
fk
Type: RedGate.SQLCompare.Engine..::.ForeignKey

See Also

DataCompareIndexDeploymentSql Class
AlterTableDropConstraint Overload
RedGate.SQLCompare.Engine Namespace


AlterTableDropConstraint Method (ViewTableSuperClass, Index)

[image]

SQL Data Compare API 12.0.40
DataCompareIndexDeploymentSql..::.AlterTableDropConstraint Method (ViewTableSuperClass, Index)
DataCompareIndexDeploymentSql Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function AlterTableDropConstraint ( _
    target As ViewTableSuperClass, _
    index As Index _
) As String
C#
public string AlterTableDropConstraint(
    ViewTableSuperClass target,
    Index index
)
Visual C++
public:
String^ AlterTableDropConstraint(
    ViewTableSuperClass^ target,
    Index^ index
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
index
Type: RedGate.SQLCompare.Engine..::.Index

See Also

DataCompareIndexDeploymentSql Class
AlterTableDropConstraint Overload
RedGate.SQLCompare.Engine Namespace


AlterTableEnableTrigger Method

[image]

SQL Data Compare API 12.0.40
DataCompareIndexDeploymentSql..::.AlterTableEnableTrigger Method
DataCompareIndexDeploymentSql Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function AlterTableEnableTrigger ( _
    target As ViewTableSuperClass, _
    trigger As Trigger _
) As String
C#
public string AlterTableEnableTrigger(
    ViewTableSuperClass target,
    Trigger trigger
)
Visual C++
public:
String^ AlterTableEnableTrigger(
    ViewTableSuperClass^ target,
    Trigger^ trigger
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
trigger
Type: RedGate.SQLCompare.Engine..::.Trigger

See Also

DataCompareIndexDeploymentSql Class
RedGate.SQLCompare.Engine Namespace


AlterTableNocheckConstraint Method

[image]

SQL Data Compare API 12.0.40
DataCompareIndexDeploymentSql..::.AlterTableNocheckConstraint Method
DataCompareIndexDeploymentSql Class See Also

Generate SQL to disable a constraint

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function AlterTableNocheckConstraint ( _
    target As ViewTableSuperClass, _
    fk As ForeignKey _
) As String
C#
public string AlterTableNocheckConstraint(
    ViewTableSuperClass target,
    ForeignKey fk
)
Visual C++
public:
String^ AlterTableNocheckConstraint(
    ViewTableSuperClass^ target,
    ForeignKey^ fk
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
fk
Type: RedGate.SQLCompare.Engine..::.ForeignKey

See Also

DataCompareIndexDeploymentSql Class
RedGate.SQLCompare.Engine Namespace


CreateIndex Method

[image]

SQL Data Compare API 12.0.40
DataCompareIndexDeploymentSql..::.CreateIndex Method
DataCompareIndexDeploymentSql Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateIndex ( _
    index As Index, _
    target As ViewTableSuperClass _
) As String
C#
public string CreateIndex(
    Index index,
    ViewTableSuperClass target
)
Visual C++
public:
String^ CreateIndex(
    Index^ index,
    ViewTableSuperClass^ target
)

Parameters

index
Type: RedGate.SQLCompare.Engine..::.Index
target
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass

See Also

DataCompareIndexDeploymentSql Class
RedGate.SQLCompare.Engine Namespace


DropIndex Method

[image]

SQL Data Compare API 12.0.40
DataCompareIndexDeploymentSql..::.DropIndex Method
DataCompareIndexDeploymentSql Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function DropIndex ( _
    target As ViewTableSuperClass, _
    index As Index _
) As String
C#
public string DropIndex(
    ViewTableSuperClass target,
    Index index
)
Visual C++
public:
String^ DropIndex(
    ViewTableSuperClass^ target,
    Index^ index
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
index
Type: RedGate.SQLCompare.Engine..::.Index

See Also

DataCompareIndexDeploymentSql Class
RedGate.SQLCompare.Engine Namespace


RestoreConstraintEnabledness Method

[image]

SQL Data Compare API 12.0.40
DataCompareIndexDeploymentSql..::.RestoreConstraintEnabledness Method
DataCompareIndexDeploymentSql Class See Also

Generate SQL to re-enable a constraint

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function RestoreConstraintEnabledness ( _
    target As ViewTableSuperClass, _
    key As ForeignKey, _
    skipIntegrityChecks As Boolean _
) As String
C#
public string RestoreConstraintEnabledness(
    ViewTableSuperClass target,
    ForeignKey key,
    bool skipIntegrityChecks
)
Visual C++
public:
String^ RestoreConstraintEnabledness(
    ViewTableSuperClass^ target,
    ForeignKey^ key,
    bool skipIntegrityChecks
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
key
Type: RedGate.SQLCompare.Engine..::.ForeignKey
skipIntegrityChecks
Type: Boolean

See Also

DataCompareIndexDeploymentSql Class
RedGate.SQLCompare.Engine Namespace


DataCompareUserActions Class

[image]

SQL Data Compare API 12.0.40
DataCompareUserActions Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataCompareUserActions
C#
public static class DataCompareUserActions
Visual C++
public ref class DataCompareUserActions abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.DataCompareUserActions

See Also

DataCompareUserActions Members
RedGate.SQLCompare.Engine Namespace


DataCompareUserActions Members

[image] [image]

SQL Data Compare API 12.0.40
DataCompareUserActions Members
DataCompareUserActions Class Methods See Also

The DataCompareUserActions type exposes the following members.

Methods

Name | Description
AddAction | Used to add a user action. This will only add actions that are necessary removing all duplicates or unnecessary actions ( for example a deselect table followed by a select table ). This is needed as I now report on failed user actions in the UI and I only want to keep what's sensible.

See Also

DataCompareUserActions Class
RedGate.SQLCompare.Engine Namespace


DataCompareUserActions Methods

[image] [image]

SQL Data Compare API 12.0.40
DataCompareUserActions Methods
DataCompareUserActions Class See Also

The DataCompareUserActions type exposes the following methods.

Methods

Name | Description
AddAction | Used to add a user action. This will only add actions that are necessary removing all duplicates or unnecessary actions ( for example a deselect table followed by a select table ). This is needed as I now report on failed user actions in the UI and I only want to keep what's sensible.

See Also

DataCompareUserActions Class
RedGate.SQLCompare.Engine Namespace


AddAction Method

[image]

SQL Data Compare API 12.0.40
DataCompareUserActions..::.AddAction Method
DataCompareUserActions Class See Also

Used to add a user action. This will only add actions that are necessary removing all duplicates or unnecessary actions ( for example a deselect table followed by a select table ). This is needed as I now report on failed user actions in the UI and I only want to keep what's sensible.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function AddAction ( _
    existing As IList(Of SelectTableEvent), _
    options As EngineDataCompareOptions, _
    ste As SelectTableEvent _
) As Boolean
C#
public static bool AddAction(
    IList<SelectTableEvent> existing,
    EngineDataCompareOptions options,
    SelectTableEvent ste
)
Visual C++
public:
static bool AddAction(
    IList<SelectTableEvent>^ existing,
    EngineDataCompareOptions^ options,
    SelectTableEvent ste
)

Parameters

existing
Type: IList<(Of <( SelectTableEvent >)>)
options
Type: RedGate.SQLCompare.Engine..::.EngineDataCompareOptions
ste
Type: RedGate.SQLCompare.Engine..::.SelectTableEvent

See Also

DataCompareUserActions Class
RedGate.SQLCompare.Engine Namespace


DataCompression Enumeration

[image]

SQL Data Compare API 12.0.40
DataCompression Enumeration
See Also

Compression used for a table or index record. This has been introduced in SQL Server 2008.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration DataCompression
C#
public enum DataCompression
Visual C++
public enum class DataCompression

Members

Member name | Description
None |
Row |
Page |
Columnstore |
ColumnstoreArchive |

See Also

RedGate.SQLCompare.Engine Namespace


DataRecordExtensions Class

[image]

SQL Data Compare API 12.0.40
DataRecordExtensions Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataRecordExtensions
C#
public static class DataRecordExtensions
Visual C++
public ref class DataRecordExtensions abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.DataRecordExtensions

See Also

DataRecordExtensions Members
RedGate.SQLCompare.Engine Namespace


DataRecordExtensions Members

[image] [image]

SQL Data Compare API 12.0.40
DataRecordExtensions Members
DataRecordExtensions Class Methods See Also

The DataRecordExtensions type exposes the following members.

Methods

Name | Description
HasColumn |

See Also

DataRecordExtensions Class
RedGate.SQLCompare.Engine Namespace


DataRecordExtensions Methods

[image] [image]

SQL Data Compare API 12.0.40
DataRecordExtensions Methods
DataRecordExtensions Class See Also

The DataRecordExtensions type exposes the following methods.

Methods

Name | Description
HasColumn |

See Also

DataRecordExtensions Class
RedGate.SQLCompare.Engine Namespace


HasColumn Method

[image]

SQL Data Compare API 12.0.40
DataRecordExtensions..::.HasColumn Method
DataRecordExtensions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function HasColumn ( _
    dr As IDataRecord, _
    columnName As String _
) As Boolean
C#
public static bool HasColumn(
    IDataRecord dr,
    string columnName
)
Visual C++
public:
static bool HasColumn(
    IDataRecord^ dr,
    String^ columnName
)

Parameters

dr
Type: IDataRecord
columnName
Type: String

See Also

DataRecordExtensions Class
RedGate.SQLCompare.Engine Namespace


DatatypeMigrationWarningsCalculator Class

[image]

SQL Data Compare API 12.0.40
DatatypeMigrationWarningsCalculator Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class DatatypeMigrationWarningsCalculator
C#
public class DatatypeMigrationWarningsCalculator
Visual C++
public ref class DatatypeMigrationWarningsCalculator

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.DatatypeMigrationWarningsCalculator

See Also

DatatypeMigrationWarningsCalculator Members
RedGate.SQLCompare.Engine Namespace


DatatypeMigrationWarningsCalculator Members

[image] [image]

SQL Data Compare API 12.0.40
DatatypeMigrationWarningsCalculator Members
DatatypeMigrationWarningsCalculator Class Constructors Methods See Also

The DatatypeMigrationWarningsCalculator type exposes the following members.

Constructors

Name | Description
DatatypeMigrationWarningsCalculator |

Methods

Name | Description
CalculateWorkCheckDatatypeMigration | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatatypeMigrationWarningsCalculator Class
RedGate.SQLCompare.Engine Namespace


DatatypeMigrationWarningsCalculator Constructor

[image]

SQL Data Compare API 12.0.40
DatatypeMigrationWarningsCalculator Constructor
DatatypeMigrationWarningsCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    warnings As Messages _
)
C#
public DatatypeMigrationWarningsCalculator(
    Messages warnings
)
Visual C++
public:
DatatypeMigrationWarningsCalculator(
    Messages^ warnings
)

Parameters

warnings
Type: RedGate.SQLCompare.Engine..::.Messages

See Also

DatatypeMigrationWarningsCalculator Class
RedGate.SQLCompare.Engine Namespace


DatatypeMigrationWarningsCalculator Methods

[image] [image]

SQL Data Compare API 12.0.40
DatatypeMigrationWarningsCalculator Methods
DatatypeMigrationWarningsCalculator Class See Also

The DatatypeMigrationWarningsCalculator type exposes the following methods.

Methods

Name | Description
CalculateWorkCheckDatatypeMigration | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatatypeMigrationWarningsCalculator Class
RedGate.SQLCompare.Engine Namespace


CalculateWorkCheckDatatypeMigration Method

[image] [image]

SQL Data Compare API 12.0.40
DatatypeMigrationWarningsCalculator..::.CalculateWorkCheckDatatypeMigration Method
DatatypeMigrationWarningsCalculator Class See Also

Overload List

Name | Description
CalculateWorkCheckDatatypeMigration(IDatabaseObject, SqlType, Int32, IFeatureChecker) |
CalculateWorkCheckDatatypeMigration(IDatabaseObject, String, SqlType, Int32, IFeatureChecker) |

See Also

DatatypeMigrationWarningsCalculator Class
DatatypeMigrationWarningsCalculator Members
RedGate.SQLCompare.Engine Namespace


CalculateWorkCheckDatatypeMigration Method (IDatabaseObject, SqlType, , IFeatureChecker)

[image]

SQL Data Compare API 12.0.40
DatatypeMigrationWarningsCalculator..::.CalculateWorkCheckDatatypeMigration Method (IDatabaseObject, SqlType, , IFeatureChecker)
DatatypeMigrationWarningsCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculateWorkCheckDatatypeMigration ( _
    obj As IDatabaseObject, _
    type As SqlType, _
    length As Integer, _
    targetFeatures As IFeatureChecker _
)
C#
public void CalculateWorkCheckDatatypeMigration(
    IDatabaseObject obj,
    SqlType type,
    int length,
    IFeatureChecker targetFeatures
)
Visual C++
public:
void CalculateWorkCheckDatatypeMigration(
    IDatabaseObject^ obj,
    SqlType type,
    int length,
    IFeatureChecker^ targetFeatures
)

Parameters

obj
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
type
Type: RedGate.SQLCompare.Engine..::.SqlType
length
Type: Int32
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

See Also

DatatypeMigrationWarningsCalculator Class
CalculateWorkCheckDatatypeMigration Overload
RedGate.SQLCompare.Engine Namespace


CalculateWorkCheckDatatypeMigration Method (IDatabaseObject, , SqlType, , IFeatureChecker)

[image]

SQL Data Compare API 12.0.40
DatatypeMigrationWarningsCalculator..::.CalculateWorkCheckDatatypeMigration Method (IDatabaseObject, , SqlType, , IFeatureChecker)
DatatypeMigrationWarningsCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculateWorkCheckDatatypeMigration ( _
    obj As IDatabaseObject, _
    objectName As String, _
    type As SqlType, _
    length As Integer, _
    targetFeatures As IFeatureChecker _
)
C#
public void CalculateWorkCheckDatatypeMigration(
    IDatabaseObject obj,
    string objectName,
    SqlType type,
    int length,
    IFeatureChecker targetFeatures
)
Visual C++
public:
void CalculateWorkCheckDatatypeMigration(
    IDatabaseObject^ obj,
    String^ objectName,
    SqlType type,
    int length,
    IFeatureChecker^ targetFeatures
)

Parameters

obj
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
objectName
Type: String
type
Type: RedGate.SQLCompare.Engine..::.SqlType
length
Type: Int32
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

See Also

DatatypeMigrationWarningsCalculator Class
CalculateWorkCheckDatatypeMigration Overload
RedGate.SQLCompare.Engine Namespace


DBPopulationOptions Enumeration

[image]

SQL Data Compare API 12.0.40
DBPopulationOptions Enumeration
See Also

Options used when populating databases.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration DBPopulationOptions
C#
[FlagsAttribute]
public enum DBPopulationOptions
Visual C++
[FlagsAttribute]
public enum class DBPopulationOptions

Members

Member name | Description
Defaults |
ForDataCompare |
ExcludeAssemlyFiles |
DatabaseCaseSensitivity |
DatabaseCollation |
IncludeViewColumnDetails |
ExcludeObjectDependencies |
DecryptPost2kEncryptedObjects |
ExcludeMemoryOptimizedTables |

See Also

RedGate.SQLCompare.Engine Namespace


DdlTrigger Class

[image]

SQL Data Compare API 12.0.40
DdlTrigger Class
Members See Also

A DDL trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DdlTrigger _
    Inherits ScriptableDatabaseObject _
    Implements IDatabaseObject, ITSqlObject, ICanExistenceCheck, IExecuteAs,  _
    IEncryptedTextObject, ITextObject, ISessionSetObject, IPatchUpAfterDeserialization, ISqlComparable
C#
public sealed class DdlTrigger : ScriptableDatabaseObject, IDatabaseObject,
    ITSqlObject, ICanExistenceCheck, IExecuteAs, IEncryptedTextObject, ITextObject,
    ISessionSetObject, IPatchUpAfterDeserialization, ISqlComparable
Visual C++
public ref class DdlTrigger sealed : public ScriptableDatabaseObject,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, IExecuteAs, IEncryptedTextObject,
    ITextObject, ISessionSetObject, IPatchUpAfterDeserialization, ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DdlTrigger

See Also

DdlTrigger Members
RedGate.SQLCompare.Engine Namespace


DdlTrigger Members

[image] [image]

SQL Data Compare API 12.0.40
DdlTrigger Members
DdlTrigger Class Methods Fields Properties Explicit Interface Implementations See Also

The DdlTrigger type exposes the following members.

Methods

Name | Description
CompareWith |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSql |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
SetSessionOptions |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
After | True if the trigger is an after trigger.
AnsiNullsOn | True if the trigger was created with ansi nulls on.
Assembly | The CLR assembly for the DDL trigger, for a CLR DDL trigger.
AssemblyClass | The CLR assembly class name for the DDL trigger, for a CLR DDL trigger.
AssemblyMethod | The CLR assembly method name for the DDL trigger, for a CLR trigger.
CLRObject | True if the DDL trigger is a Common Language Runtime (CLR) DDL trigger.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
EnableDisableStatementSource |
Encrypted | True if the DDL trigger definition is encrypted.
EventTypes | The event types for the DDL trigger.
ExecuteAs | The user whose security context is to be used for the execution of the DDL trigger. This is a SQL Server 2005 feature.
ExecuteAsType | The EXECUTE AS clause used for the object.
ExtendedProperties | The extended properties defined for the DDL trigger.
FullyQualifiedName | The fully-qualified name of the DDL trigger. DANGER WILL ROBINSON!! This is not escaped. (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
InsteadOf | True if the trigger is an instead of trigger.
IsDisabled | True if the trigger is disabled.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.DdlTrigger (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
QuotedIdentifierOn | True if the trigger was created with quoted identifiers on.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)
Text | The text of the DDL trigger, if it is not a CLR DDL trigger.

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |
IEncryptedTextObject..::.TextID |

See Also

DdlTrigger Class
RedGate.SQLCompare.Engine Namespace


DdlTrigger Methods

[image] [image]

SQL Data Compare API 12.0.40
DdlTrigger Methods
DdlTrigger Class See Also

The DdlTrigger type exposes the following methods.

Methods

Name | Description
CompareWith |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSql |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
SetSessionOptions |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

DdlTrigger Class
RedGate.SQLCompare.Engine Namespace


CompareWith Method

[image]

SQL Data Compare API 12.0.40
DdlTrigger..::.CompareWith Method
DdlTrigger Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareWith ( _
    target As DdlTrigger, _
    options As Options _
) As IEnumerable(Of EqualityDifference)
C#
public IEnumerable<EqualityDifference> CompareWith(
    DdlTrigger target,
    Options options
)
Visual C++
public:
IEnumerable<EqualityDifference^>^ CompareWith(
    DdlTrigger^ target,
    Options options
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.DdlTrigger
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

DdlTrigger Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
DdlTrigger..::.ISqlComparable..::.CompareWith Method
DdlTrigger Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    obj As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable obj,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ obj,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

obj
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

DdlTrigger Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
DdlTrigger..::.Equals Method
DdlTrigger Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(DdlTrigger, Options) | Compares the DDL trigger with the specified DDL trigger.
Equals(IDatabaseObject, Options) | Compares the DDL trigger with a specified DDL trigger. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

DdlTrigger Class
DdlTrigger Members
RedGate.SQLCompare.Engine Namespace


Equals Method (DdlTrigger, Options)

[image]

SQL Data Compare API 12.0.40
DdlTrigger..::.Equals Method (DdlTrigger, Options)
DdlTrigger Class See Also

Compares the DDL trigger with the specified DDL trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    target As DdlTrigger, _
    options As Options _
) As Boolean
C#
public bool Equals(
    DdlTrigger target,
    Options options
)
Visual C++
public:
bool Equals(
    DdlTrigger^ target,
    Options options
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.DdlTrigger
The DDL trigger to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the DDL triggers are identical; otherwise false.

See Also

DdlTrigger Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
DdlTrigger..::.Equals Method (IDatabaseObject, Options)
DdlTrigger Class See Also

Compares the DDL trigger with a specified DDL trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    value As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject value,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ value,
    Options options
) override

Parameters

value
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The DDL trigger to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the DDL triggers are identical; otherwise false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

DdlTrigger Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


GetSql Method

[image]

SQL Data Compare API 12.0.40
DdlTrigger..::.GetSql Method
DdlTrigger Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSql ( _
    options As Options, _
    targetIsEncrypted As Boolean, _
    useAlter As Boolean, _
    targetFeatures As IFeatureChecker _
) As String
C#
public string GetSql(
    Options options,
    bool targetIsEncrypted,
    bool useAlter,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual String^ GetSql(
    Options options,
    bool targetIsEncrypted,
    bool useAlter,
    IFeatureChecker^ targetFeatures
) sealed

Parameters

options
Type: RedGate.SQLCompare.Engine..::.Options
targetIsEncrypted
Type: Boolean
useAlter
Type: Boolean
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Implements

IEncryptedTextObject..::.GetSql(Options, Boolean, Boolean, IFeatureChecker)

See Also

DdlTrigger Class
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
DdlTrigger..::.PatchUpAfterDeserialization Method
DdlTrigger Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

DdlTrigger Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
DdlTrigger..::.ScriptObject Method
DdlTrigger Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifiers on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

DdlTrigger Class
RedGate.SQLCompare.Engine Namespace


SetSessionOptions Method

[image]

SQL Data Compare API 12.0.40
DdlTrigger..::.SetSessionOptions Method
DdlTrigger Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetSessionOptions ( _
    ansiNulls As Boolean, _
    quotedIdentifier As Boolean _
)
C#
public void SetSessionOptions(
    bool ansiNulls,
    bool quotedIdentifier
)
Visual C++
public:
virtual void SetSessionOptions(
    bool ansiNulls,
    bool quotedIdentifier
) sealed

Parameters

ansiNulls
Type: Boolean
quotedIdentifier
Type: Boolean

Implements

ISessionSetObject..::.SetSessionOptions(Boolean, Boolean)

See Also

DdlTrigger Class
RedGate.SQLCompare.Engine Namespace


DdlTrigger Properties

[image] [image]

SQL Data Compare API 12.0.40
DdlTrigger Properties
DdlTrigger Class See Also

The DdlTrigger type exposes the following properties.

Properties

Name | Description
After | True if the trigger is an after trigger.
AnsiNullsOn | True if the trigger was created with ansi nulls on.
Assembly | The CLR assembly for the DDL trigger, for a CLR DDL trigger.
AssemblyClass | The CLR assembly class name for the DDL trigger, for a CLR DDL trigger.
AssemblyMethod | The CLR assembly method name for the DDL trigger, for a CLR trigger.
CLRObject | True if the DDL trigger is a Common Language Runtime (CLR) DDL trigger.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
EnableDisableStatementSource |
Encrypted | True if the DDL trigger definition is encrypted.
EventTypes | The event types for the DDL trigger.
ExecuteAs | The user whose security context is to be used for the execution of the DDL trigger. This is a SQL Server 2005 feature.
ExecuteAsType | The EXECUTE AS clause used for the object.
ExtendedProperties | The extended properties defined for the DDL trigger.
FullyQualifiedName | The fully-qualified name of the DDL trigger. DANGER WILL ROBINSON!! This is not escaped. (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
InsteadOf | True if the trigger is an instead of trigger.
IsDisabled | True if the trigger is disabled.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.DdlTrigger (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
QuotedIdentifierOn | True if the trigger was created with quoted identifiers on.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)
Text | The text of the DDL trigger, if it is not a CLR DDL trigger.

Explicit Interface Implementations

Name | Description
IEncryptedTextObject..::.TextID |

See Also

DdlTrigger Class
RedGate.SQLCompare.Engine Namespace


After Property

[image]

SQL Data Compare API 12.0.40
DdlTrigger..::.After Property
DdlTrigger Class See Also

True if the trigger is an after trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property After As Boolean
C#
public bool After { get; }
Visual C++
public:
property bool After {
    bool get ();
}

See Also

DdlTrigger Class
RedGate.SQLCompare.Engine Namespace


AnsiNullsOn Property

[image]

SQL Data Compare API 12.0.40
DdlTrigger..::.AnsiNullsOn Property
DdlTrigger Class See Also

True if the trigger was created with ansi nulls on.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AnsiNullsOn As Boolean
C#
public bool AnsiNullsOn { get; internal set; }
Visual C++
public:
virtual property bool AnsiNullsOn {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

ISessionSetObject..::.AnsiNullsOn

See Also

DdlTrigger Class
RedGate.SQLCompare.Engine Namespace


Assembly Property

[image]

SQL Data Compare API 12.0.40
DdlTrigger..::.Assembly Property
DdlTrigger Class See Also

The CLR assembly for the DDL trigger, for a CLR DDL trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Assembly As ClrAssembly
C#
public ClrAssembly Assembly { get; internal set; }
Visual C++
public:
virtual property ClrAssembly^ Assembly {
    ClrAssembly^ get () sealed;
    void set (ClrAssembly^ value) sealed;
}

See Also

DdlTrigger Class
RedGate.SQLCompare.Engine Namespace


AssemblyClass Property

[image]

SQL Data Compare API 12.0.40
DdlTrigger..::.AssemblyClass Property
DdlTrigger Class See Also

The CLR assembly class name for the DDL trigger, for a CLR DDL trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyClass As String
C#
public string AssemblyClass { get; internal set; }
Visual C++
public:
property String^ AssemblyClass {
    String^ get ();
    void set (String^ value);
}

See Also

DdlTrigger Class
RedGate.SQLCompare.Engine Namespace


AssemblyMethod Property

[image]

SQL Data Compare API 12.0.40
DdlTrigger..::.AssemblyMethod Property
DdlTrigger Class See Also

The CLR assembly method name for the DDL trigger, for a CLR trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyMethod As String
C#
public string AssemblyMethod { get; internal set; }
Visual C++
public:
property String^ AssemblyMethod {
    String^ get ();
    void set (String^ value);
}

See Also

DdlTrigger Class
RedGate.SQLCompare.Engine Namespace


CLRObject Property

[image]

SQL Data Compare API 12.0.40
DdlTrigger..::.CLRObject Property
DdlTrigger Class See Also

True if the DDL trigger is a Common Language Runtime (CLR) DDL trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CLRObject As Boolean
C#
public bool CLRObject { get; internal set; }
Visual C++
public:
virtual property bool CLRObject {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

DdlTrigger Class
RedGate.SQLCompare.Engine Namespace


EnableDisableStatementSource Property

[image]

SQL Data Compare API 12.0.40
DdlTrigger..::.EnableDisableStatementSource Property
DdlTrigger Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property EnableDisableStatementSource As ScriptSource
C#
public ScriptSource EnableDisableStatementSource { get; set; }
Visual C++
public:
property ScriptSource^ EnableDisableStatementSource {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

DdlTrigger Class
RedGate.SQLCompare.Engine Namespace


Encrypted Property

[image]

SQL Data Compare API 12.0.40
DdlTrigger..::.Encrypted Property
DdlTrigger Class See Also

True if the DDL trigger definition is encrypted.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Encrypted As Boolean
C#
public bool Encrypted { get; internal set; }
Visual C++
public:
virtual property bool Encrypted {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IEncryptedTextObject..::.Encrypted

Remarks

The contents of the trigger cannot be decrypted.

See Also

DdlTrigger Class
RedGate.SQLCompare.Engine Namespace


EventTypes Property

[image]

SQL Data Compare API 12.0.40
DdlTrigger..::.EventTypes Property
DdlTrigger Class See Also

The event types for the DDL trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EventTypes As EventTypes
C#
public EventTypes EventTypes { get; }
Visual C++
public:
property EventTypes^ EventTypes {
    EventTypes^ get ();
}

See Also

DdlTrigger Class
RedGate.SQLCompare.Engine Namespace


ExecuteAs Property

[image]

SQL Data Compare API 12.0.40
DdlTrigger..::.ExecuteAs Property
DdlTrigger Class See Also

The user whose security context is to be used for the execution of the DDL trigger. This is a SQL Server 2005 feature.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecuteAs As User
C#
public User ExecuteAs { get; internal set; }
Visual C++
public:
virtual property User^ ExecuteAs {
    User^ get () sealed;
    void set (User^ value) sealed;
}

Implements

IExecuteAs..::.ExecuteAs

See Also

DdlTrigger Class
RedGate.SQLCompare.Engine Namespace


ExecuteAsType Property

[image]

SQL Data Compare API 12.0.40
DdlTrigger..::.ExecuteAsType Property
DdlTrigger Class See Also

The EXECUTE AS clause used for the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecuteAsType As ExecuteAs
C#
public ExecuteAs ExecuteAsType { get; internal set; }
Visual C++
public:
virtual property ExecuteAs ExecuteAsType {
    ExecuteAs get () sealed;
    void set (ExecuteAs value) sealed;
}

Implements

IExecuteAs..::.ExecuteAsType

See Also

DdlTrigger Class
RedGate.SQLCompare.Engine Namespace


ExtendedProperties Property

[image]

SQL Data Compare API 12.0.40
DdlTrigger..::.ExtendedProperties Property
DdlTrigger Class See Also

The extended properties defined for the DDL trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedProperties
C#
public ExtendedProperties ExtendedProperties { get; }
Visual C++
public:
property ExtendedProperties^ ExtendedProperties {
    ExtendedProperties^ get ();
}

See Also

DdlTrigger Class
RedGate.SQLCompare.Engine Namespace


FullyQualifiedName Property

[image]

SQL Data Compare API 12.0.40
DdlTrigger..::.FullyQualifiedName Property
DdlTrigger Class See Also

The fully-qualified name of the DDL trigger. DANGER WILL ROBINSON!! This is not escaped.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FullyQualifiedName As String
C#
public override string FullyQualifiedName { get; }
Visual C++
public:
virtual property String^ FullyQualifiedName {
    String^ get () override;
}

Implements

ITSqlObjectFullyQualifiedName()()()
ITSqlObjectFullyQualifiedName()()()

See Also

DdlTrigger Class
RedGate.SQLCompare.Engine Namespace


InsteadOf Property

[image]

SQL Data Compare API 12.0.40
DdlTrigger..::.InsteadOf Property
DdlTrigger Class See Also

True if the trigger is an instead of trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property InsteadOf As Boolean
C#
public bool InsteadOf { get; internal set; }
Visual C++
public:
property bool InsteadOf {
    bool get ();
    void set (bool value);
}

See Also

DdlTrigger Class
RedGate.SQLCompare.Engine Namespace


IsDisabled Property

[image]

SQL Data Compare API 12.0.40
DdlTrigger..::.IsDisabled Property
DdlTrigger Class See Also

True if the trigger is disabled.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsDisabled As Boolean
C#
public bool IsDisabled { get; internal set; }
Visual C++
public:
property bool IsDisabled {
    bool get ();
    void set (bool value);
}

See Also

DdlTrigger Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
DdlTrigger..::.ObjectType Property
DdlTrigger Class See Also

Returns ObjectType.DdlTrigger

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()
ITSqlObjectObjectType()()()

See Also

DdlTrigger Class
RedGate.SQLCompare.Engine Namespace


QuotedIdentifierOn Property

[image]

SQL Data Compare API 12.0.40
DdlTrigger..::.QuotedIdentifierOn Property
DdlTrigger Class See Also

True if the trigger was created with quoted identifiers on.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property QuotedIdentifierOn As Boolean
C#
public bool QuotedIdentifierOn { get; internal set; }
Visual C++
public:
virtual property bool QuotedIdentifierOn {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

ISessionSetObject..::.QuotedIdentifierOn

See Also

DdlTrigger Class
RedGate.SQLCompare.Engine Namespace


Text Property

[image]

SQL Data Compare API 12.0.40
DdlTrigger..::.Text Property
DdlTrigger Class See Also

The text of the DDL trigger, if it is not a CLR DDL trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
C#
public string Text { get; }
Visual C++
public:
virtual property String^ Text {
    String^ get () sealed;
}

Implements

ITextObject..::.Text

See Also

DdlTrigger Class
RedGate.SQLCompare.Engine Namespace


IEncryptedTextObject.TextID Property

[image]

SQL Data Compare API 12.0.40
DdlTrigger..::.IEncryptedTextObject..::.TextID Property
DdlTrigger Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private ReadOnly Property TextID As Integer
    Implements IEncryptedTextObject.TextID
C#
int IEncryptedTextObject.TextID { get; }
Visual C++
private:
virtual property int TextID {
    int get () sealed = IEncryptedTextObject::TextID::get;
}

Implements

IEncryptedTextObject..::.TextID

See Also

DdlTrigger Class
RedGate.SQLCompare.Engine Namespace


DdlTriggers Class

[image]

SQL Data Compare API 12.0.40
DdlTriggers Class
Members See Also

A collection of DDL triggers.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DdlTriggers _
    Inherits SerializableDatabaseObjectCollection(Of DdlTrigger) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class DdlTriggers : SerializableDatabaseObjectCollection<DdlTrigger>, IPatchUpAfterDeserialization
Visual C++
public ref class DdlTriggers sealed : public SerializableDatabaseObjectCollection<DdlTrigger^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( DdlTrigger >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( DdlTrigger >)>)
RedGate.SQLCompare.Engine..::.DdlTriggers

See Also

DdlTriggers Members
RedGate.SQLCompare.Engine Namespace


DdlTriggers Members

[image] [image]

SQL Data Compare API 12.0.40
DdlTriggers Members
DdlTriggers Class Methods Fields Properties Explicit Interface Implementations See Also

The DdlTriggers type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

DdlTriggers Class
RedGate.SQLCompare.Engine Namespace


DdlTriggers Methods

[image] [image]

SQL Data Compare API 12.0.40
DdlTriggers Methods
DdlTriggers Class See Also

The DdlTriggers type exposes the following methods.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

DdlTriggers Class
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
DdlTriggers..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
DdlTriggers Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

DdlTriggers Class
RedGate.SQLCompare.Engine Namespace


DdlTriggersChanges Class

[image]

SQL Data Compare API 12.0.40
DdlTriggersChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DdlTriggersChanges
C#
public sealed class DdlTriggersChanges
Visual C++
public ref class DdlTriggersChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.DdlTriggersChanges

See Also

DdlTriggersChanges Members
RedGate.SQLCompare.Engine Namespace


DdlTriggersChanges Members

[image] [image]

SQL Data Compare API 12.0.40
DdlTriggersChanges Members
DdlTriggersChanges Class Constructors Methods Properties See Also

The DdlTriggersChanges type exposes the following members.

Constructors

Name | Description
DdlTriggersChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DdlTriggersToAlter |
DdlTriggersToCreate |
DdlTriggersToDrop |
DdlTriggerTargets |

See Also

DdlTriggersChanges Class
RedGate.SQLCompare.Engine Namespace


DdlTriggersChanges Constructor

[image]

SQL Data Compare API 12.0.40
DdlTriggersChanges Constructor
DdlTriggersChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public DdlTriggersChanges(
    bool caseSensitive
)
Visual C++
public:
DdlTriggersChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

DdlTriggersChanges Class
RedGate.SQLCompare.Engine Namespace


DdlTriggersChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
DdlTriggersChanges Properties
DdlTriggersChanges Class See Also

The DdlTriggersChanges type exposes the following properties.

Properties

Name | Description
DdlTriggersToAlter |
DdlTriggersToCreate |
DdlTriggersToDrop |
DdlTriggerTargets |

See Also

DdlTriggersChanges Class
RedGate.SQLCompare.Engine Namespace


DdlTriggersToAlter Property

[image]

SQL Data Compare API 12.0.40
DdlTriggersChanges..::.DdlTriggersToAlter Property
DdlTriggersChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DdlTriggersToAlter As DdlTriggers
C#
public DdlTriggers DdlTriggersToAlter { get; private set; }
Visual C++
public:
property DdlTriggers^ DdlTriggersToAlter {
    DdlTriggers^ get ();
    void set (DdlTriggers^ value);
}

See Also

DdlTriggersChanges Class
RedGate.SQLCompare.Engine Namespace


DdlTriggersToCreate Property

[image]

SQL Data Compare API 12.0.40
DdlTriggersChanges..::.DdlTriggersToCreate Property
DdlTriggersChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DdlTriggersToCreate As DdlTriggers
C#
public DdlTriggers DdlTriggersToCreate { get; private set; }
Visual C++
public:
property DdlTriggers^ DdlTriggersToCreate {
    DdlTriggers^ get ();
    void set (DdlTriggers^ value);
}

See Also

DdlTriggersChanges Class
RedGate.SQLCompare.Engine Namespace


DdlTriggersToDrop Property

[image]

SQL Data Compare API 12.0.40
DdlTriggersChanges..::.DdlTriggersToDrop Property
DdlTriggersChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DdlTriggersToDrop As DdlTriggers
C#
public DdlTriggers DdlTriggersToDrop { get; private set; }
Visual C++
public:
property DdlTriggers^ DdlTriggersToDrop {
    DdlTriggers^ get ();
    void set (DdlTriggers^ value);
}

See Also

DdlTriggersChanges Class
RedGate.SQLCompare.Engine Namespace


DdlTriggerTargets Property

[image]

SQL Data Compare API 12.0.40
DdlTriggersChanges..::.DdlTriggerTargets Property
DdlTriggersChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DdlTriggerTargets As Dictionary(Of DdlTrigger, DdlTrigger)
C#
public Dictionary<DdlTrigger, DdlTrigger> DdlTriggerTargets { get; private set; }
Visual C++
public:
property Dictionary<DdlTrigger^, DdlTrigger^>^ DdlTriggerTargets {
    Dictionary<DdlTrigger^, DdlTrigger^>^ get ();
    void set (Dictionary<DdlTrigger^, DdlTrigger^>^ value);
}

See Also

DdlTriggersChanges Class
RedGate.SQLCompare.Engine Namespace


Default Class

[image]

SQL Data Compare API 12.0.40
Default Class
Members See Also

A database default.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Default _
    Inherits SchemaObject _
    Implements IDatabaseObject, ITSqlObject, ICanExistenceCheck, ITextObject,  _
    IPatchUpAfterDeserialization, ISqlComparable
C#
public sealed class Default : SchemaObject, IDatabaseObject,
    ITSqlObject, ICanExistenceCheck, ITextObject, IPatchUpAfterDeserialization, ISqlComparable
Visual C++
public ref class Default sealed : public SchemaObject,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, ITextObject, IPatchUpAfterDeserialization,
    ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.Default

See Also

Default Members
RedGate.SQLCompare.Engine Namespace


Default Members

[image] [image]

SQL Data Compare API 12.0.40
Default Members
Default Class Methods Fields Properties Explicit Interface Implementations See Also

The Default type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Default (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSources | (Inherited from SchemaObject.)
Text | The text of the default.

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

Default Class
RedGate.SQLCompare.Engine Namespace


Default Methods

[image] [image]

SQL Data Compare API 12.0.40
Default Methods
Default Class See Also

The Default type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

Default Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
Default..::.ISqlComparable..::.CompareWith Method
Default Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    obj As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable obj,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ obj,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

obj
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

Default Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
Default..::.Equals Method
Default Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the default with a specified default. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

Default Class
Default Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
Default..::.Equals Method (IDatabaseObject, Options)
Default Class See Also

Compares the default with a specified default.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) override

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The object to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the defaults are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

Default Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
Default..::.PatchUpAfterDeserialization Method
Default Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

Default Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
Default..::.ScriptObject Method
Default Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

Default Class
RedGate.SQLCompare.Engine Namespace


Default Properties

[image] [image]

SQL Data Compare API 12.0.40
Default Properties
Default Class See Also

The Default type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Default (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSources | (Inherited from SchemaObject.)
Text | The text of the default.

See Also

Default Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
Default..::.ObjectType Property
Default Class See Also

Returns ObjectType.Default

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()
ITSqlObjectObjectType()()()

See Also

Default Class
RedGate.SQLCompare.Engine Namespace


Text Property

[image]

SQL Data Compare API 12.0.40
Default..::.Text Property
Default Class See Also

The text of the default.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text { get; internal set; }
Visual C++
public:
virtual property String^ Text {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ITextObject..::.Text

See Also

Default Class
RedGate.SQLCompare.Engine Namespace


Defaults Class

[image]

SQL Data Compare API 12.0.40
Defaults Class
Members See Also

A collection of defaults.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Defaults _
    Inherits SerializableDatabaseObjectCollection(Of Default) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class Defaults : SerializableDatabaseObjectCollection<Default>, IPatchUpAfterDeserialization
Visual C++
public ref class Defaults sealed : public SerializableDatabaseObjectCollection<Default^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Default >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( Default >)>)
RedGate.SQLCompare.Engine..::.Defaults

See Also

Defaults Members
RedGate.SQLCompare.Engine Namespace


Defaults Members

[image] [image]

SQL Data Compare API 12.0.40
Defaults Members
Defaults Class Methods Fields Properties Explicit Interface Implementations See Also

The Defaults type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

Defaults Class
RedGate.SQLCompare.Engine Namespace


Defaults Methods

[image] [image]

SQL Data Compare API 12.0.40
Defaults Methods
Defaults Class See Also

The Defaults type exposes the following methods.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

Defaults Class
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
Defaults..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
Defaults Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

Defaults Class
RedGate.SQLCompare.Engine Namespace


DefaultsChanges Class

[image]

SQL Data Compare API 12.0.40
DefaultsChanges Class
Members See Also

TODO: I'm not sure if this grouping is sensible; currently it's just everything needed by DefaultChangesCalculator Need to do a proper investigation on what CompareEngine thinks the difference between defaults and DRI defaults is

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DefaultsChanges
C#
public sealed class DefaultsChanges
Visual C++
public ref class DefaultsChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.DefaultsChanges

See Also

DefaultsChanges Members
RedGate.SQLCompare.Engine Namespace


DefaultsChanges Members

[image] [image]

SQL Data Compare API 12.0.40
DefaultsChanges Members
DefaultsChanges Class Constructors Methods Properties See Also

The DefaultsChanges type exposes the following members.

Constructors

Name | Description
DefaultsChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DefaultsToCreate |
DefaultsToDrop |
FieldDefaultsToBind |
FieldDefaultsToUnbind |
UDTDefaultsToBind |
UDTDefaultsToUnbind |

See Also

DefaultsChanges Class
RedGate.SQLCompare.Engine Namespace


DefaultsChanges Constructor

[image]

SQL Data Compare API 12.0.40
DefaultsChanges Constructor
DefaultsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public DefaultsChanges(
    bool caseSensitive
)
Visual C++
public:
DefaultsChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

DefaultsChanges Class
RedGate.SQLCompare.Engine Namespace


DefaultsChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
DefaultsChanges Properties
DefaultsChanges Class See Also

The DefaultsChanges type exposes the following properties.

Properties

Name | Description
DefaultsToCreate |
DefaultsToDrop |
FieldDefaultsToBind |
FieldDefaultsToUnbind |
UDTDefaultsToBind |
UDTDefaultsToUnbind |

See Also

DefaultsChanges Class
RedGate.SQLCompare.Engine Namespace


DefaultsToCreate Property

[image]

SQL Data Compare API 12.0.40
DefaultsChanges..::.DefaultsToCreate Property
DefaultsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultsToCreate As Defaults
C#
public Defaults DefaultsToCreate { get; private set; }
Visual C++
public:
property Defaults^ DefaultsToCreate {
    Defaults^ get ();
    void set (Defaults^ value);
}

See Also

DefaultsChanges Class
RedGate.SQLCompare.Engine Namespace


DefaultsToDrop Property

[image]

SQL Data Compare API 12.0.40
DefaultsChanges..::.DefaultsToDrop Property
DefaultsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultsToDrop As Defaults
C#
public Defaults DefaultsToDrop { get; private set; }
Visual C++
public:
property Defaults^ DefaultsToDrop {
    Defaults^ get ();
    void set (Defaults^ value);
}

See Also

DefaultsChanges Class
RedGate.SQLCompare.Engine Namespace


FieldDefaultsToBind Property

[image]

SQL Data Compare API 12.0.40
DefaultsChanges..::.FieldDefaultsToBind Property
DefaultsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FieldDefaultsToBind As FieldBindings
C#
public FieldBindings FieldDefaultsToBind { get; private set; }
Visual C++
public:
property FieldBindings^ FieldDefaultsToBind {
    FieldBindings^ get ();
    void set (FieldBindings^ value);
}

See Also

DefaultsChanges Class
RedGate.SQLCompare.Engine Namespace


FieldDefaultsToUnbind Property

[image]

SQL Data Compare API 12.0.40
DefaultsChanges..::.FieldDefaultsToUnbind Property
DefaultsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FieldDefaultsToUnbind As FieldBindings
C#
public FieldBindings FieldDefaultsToUnbind { get; private set; }
Visual C++
public:
property FieldBindings^ FieldDefaultsToUnbind {
    FieldBindings^ get ();
    void set (FieldBindings^ value);
}

See Also

DefaultsChanges Class
RedGate.SQLCompare.Engine Namespace


UDTDefaultsToBind Property

[image]

SQL Data Compare API 12.0.40
DefaultsChanges..::.UDTDefaultsToBind Property
DefaultsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UDTDefaultsToBind As UDTBindings
C#
public UDTBindings UDTDefaultsToBind { get; private set; }
Visual C++
public:
property UDTBindings^ UDTDefaultsToBind {
    UDTBindings^ get ();
    void set (UDTBindings^ value);
}

See Also

DefaultsChanges Class
RedGate.SQLCompare.Engine Namespace


UDTDefaultsToUnbind Property

[image]

SQL Data Compare API 12.0.40
DefaultsChanges..::.UDTDefaultsToUnbind Property
DefaultsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UDTDefaultsToUnbind As UDTBindings
C#
public UDTBindings UDTDefaultsToUnbind { get; private set; }
Visual C++
public:
property UDTBindings^ UDTDefaultsToUnbind {
    UDTBindings^ get ();
    void set (UDTBindings^ value);
}

See Also

DefaultsChanges Class
RedGate.SQLCompare.Engine Namespace


DependenciesBuilder Class

[image]

SQL Data Compare API 12.0.40
DependenciesBuilder Class
Members See Also

The core object dependencies within a database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DependenciesBuilder _
    Implements IEnumerable(Of KeyValuePair(Of Integer, Integer)),  _
    IEnumerable
C#
public sealed class DependenciesBuilder : IEnumerable<KeyValuePair<int, int>>,
    IEnumerable
Visual C++
public ref class DependenciesBuilder sealed : IEnumerable<KeyValuePair<int, int>>,
    IEnumerable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.DependenciesBuilder

See Also

DependenciesBuilder Members
RedGate.SQLCompare.Engine Namespace


DependenciesBuilder Members

[image] [image]

SQL Data Compare API 12.0.40
DependenciesBuilder Members
DependenciesBuilder Class Methods Explicit Interface Implementations See Also

The DependenciesBuilder type exposes the following members.

Methods

Name | Description
AddDependency | For internal use only.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | For internal use only.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator |

See Also

DependenciesBuilder Class
RedGate.SQLCompare.Engine Namespace


DependenciesBuilder Methods

[image] [image]

SQL Data Compare API 12.0.40
DependenciesBuilder Methods
DependenciesBuilder Class See Also

The DependenciesBuilder type exposes the following methods.

Methods

Name | Description
AddDependency | For internal use only.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | For internal use only.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator |

See Also

DependenciesBuilder Class
RedGate.SQLCompare.Engine Namespace


AddDependency Method

[image]

SQL Data Compare API 12.0.40
DependenciesBuilder..::.AddDependency Method
DependenciesBuilder Class See Also

For internal use only.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddDependency ( _
    id As Integer, _
    dependencyID As Integer, _
    strong As Boolean _
)
C#
public void AddDependency(
    int id,
    int dependencyID,
    bool strong
)
Visual C++
public:
void AddDependency(
    int id,
    int dependencyID,
    bool strong
)

Parameters

id
Type: Int32
dependencyID
Type: Int32
strong
Type: Boolean

See Also

DependenciesBuilder Class
RedGate.SQLCompare.Engine Namespace


GetEnumerator Method

[image]

SQL Data Compare API 12.0.40
DependenciesBuilder..::.GetEnumerator Method
DependenciesBuilder Class See Also

For internal use only.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of Integer, Integer))
C#
public IEnumerator<KeyValuePair<int, int>> GetEnumerator()
Visual C++
public:
virtual IEnumerator<KeyValuePair<int, int>>^ GetEnumerator() sealed

Return Value

A KeyValuePair of id and dependency id

Implements

IEnumerableGetEnumerator()()()

See Also

DependenciesBuilder Class
RedGate.SQLCompare.Engine Namespace


. Method

[image]

SQL Data Compare API 12.0.40
DependenciesBuilder..::...::. Method
DependenciesBuilder Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
C#
IEnumerator IEnumerable.GetEnumerator()
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerableGetEnumerator()()()

See Also

DependenciesBuilder Class
RedGate.SQLCompare.Engine Namespace


DependenciesCollector Class

[image]

SQL Data Compare API 12.0.40
DependenciesCollector Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class DependenciesCollector
C#
public class DependenciesCollector
Visual C++
public ref class DependenciesCollector

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.DependenciesCollector

See Also

DependenciesCollector Members
RedGate.SQLCompare.Engine Namespace


DependenciesCollector Members

[image] [image]

SQL Data Compare API 12.0.40
DependenciesCollector Members
DependenciesCollector Class Constructors Methods See Also

The DependenciesCollector type exposes the following members.

Constructors

Name | Description
DependenciesCollector |

Methods

Name | Description
AddDependency | Overloaded.
AddStrongDependency |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetReverseDependencies |
GetReverseDependentObjects |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DependenciesCollector Class
RedGate.SQLCompare.Engine Namespace


DependenciesCollector Constructor

[image]

SQL Data Compare API 12.0.40
DependenciesCollector Constructor
DependenciesCollector Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    dependencies As IDictionary(Of Difference, Set(Of Difference)) _
)
C#
public DependenciesCollector(
    IDictionary<Difference, Set<Difference>> dependencies
)
Visual C++
public:
DependenciesCollector(
    IDictionary<Difference^, Set<Difference^>^>^ dependencies
)

Parameters

dependencies
Type: IDictionary<(Of <( Difference, Set <(Of <( Difference >)>)>)>)

See Also

DependenciesCollector Class
RedGate.SQLCompare.Engine Namespace


DependenciesCollector Methods

[image] [image]

SQL Data Compare API 12.0.40
DependenciesCollector Methods
DependenciesCollector Class See Also

The DependenciesCollector type exposes the following methods.

Methods

Name | Description
AddDependency | Overloaded.
AddStrongDependency |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetReverseDependencies |
GetReverseDependentObjects |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DependenciesCollector Class
RedGate.SQLCompare.Engine Namespace


AddDependency Method

[image] [image]

SQL Data Compare API 12.0.40
DependenciesCollector..::.AddDependency Method
DependenciesCollector Class See Also

Overload List

Name | Description
AddDependency(Difference, IEnumerable<(Of <(Difference>)>)) |
AddDependency(Difference, Difference, Boolean) | Adds dependencies to the dependency collection. If setDependency is true it sets the dependecy difference (B where A depends on B) to be selected as a dependency.
AddDependency<(Of <(T>)>)(IDictionary<(Of <(T, Set<(Of <(Difference>)>)>)>), T, Difference) | Add the specified dependency to the dependencies collection for later processing.

See Also

DependenciesCollector Class
DependenciesCollector Members
RedGate.SQLCompare.Engine Namespace


AddDependency Method (Difference, (Difference))

[image]

SQL Data Compare API 12.0.40
DependenciesCollector..::.AddDependency Method (Difference, <(Of <(Difference>)>))
DependenciesCollector Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddDependency ( _
    dependency As Difference, _
    dependedOnBy As IEnumerable(Of Difference) _
)
C#
public void AddDependency(
    Difference dependency,
    IEnumerable<Difference> dependedOnBy
)
Visual C++
public:
void AddDependency(
    Difference^ dependency,
    IEnumerable<Difference^>^ dependedOnBy
)

Parameters

dependency
Type: RedGate.SQLCompare.Engine..::.Difference
dependedOnBy
Type: IEnumerable<(Of <( Difference >)>)

See Also

DependenciesCollector Class
AddDependency Overload
RedGate.SQLCompare.Engine Namespace


AddDependency Method (Difference, Difference, )

[image]

SQL Data Compare API 12.0.40
DependenciesCollector..::.AddDependency Method (Difference, Difference, )
DependenciesCollector Class See Also

Adds dependencies to the dependency collection. If setDependency is true it sets the dependecy difference (B where A depends on B) to be selected as a dependency.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddDependency ( _
    dependency As Difference, _
    dependedOnBy As Difference, _
    setDependency As Boolean _
)
C#
public void AddDependency(
    Difference dependency,
    Difference dependedOnBy,
    bool setDependency
)
Visual C++
public:
void AddDependency(
    Difference^ dependency,
    Difference^ dependedOnBy,
    bool setDependency
)

Parameters

dependency
Type: RedGate.SQLCompare.Engine..::.Difference
dependedOnBy
Type: RedGate.SQLCompare.Engine..::.Difference
setDependency
Type: Boolean

See Also

DependenciesCollector Class
AddDependency Overload
RedGate.SQLCompare.Engine Namespace


AddDependency(T) Generic Method ((T, Set(Difference)), T, Difference)

[image]

SQL Data Compare API 12.0.40
DependenciesCollector..::.AddDependency<(Of <(T>)>) Generic Method (<(Of <(T, Set<(Of <(Difference>)>)>)>), T, Difference)
DependenciesCollector Class See Also

Add the specified dependency to the dependencies collection for later processing.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AddDependency(Of T) ( _
    dependencies As IDictionary(Of T, Set(Of Difference)), _
    dependencyName As T, _
    dependedOnBy As Difference _
)
C#
public static void AddDependency<T>(
    IDictionary<T, Set<Difference>> dependencies,
    T dependencyName,
    Difference dependedOnBy
)
Visual C++
public:
generic<typename T>
static void AddDependency(
    IDictionary<T, Set<Difference^>^>^ dependencies,
    T dependencyName,
    Difference^ dependedOnBy
)

Parameters

dependencies
Type: IDictionary<(Of <(T, Set <(Of <( Difference >)>)>)>)
dependencyName
Type: T
dependedOnBy
Type: RedGate.SQLCompare.Engine..::.Difference

Type Parameters

T

See Also

DependenciesCollector Class
AddDependency Overload
RedGate.SQLCompare.Engine Namespace


AddStrongDependency Method

[image]

SQL Data Compare API 12.0.40
DependenciesCollector..::.AddStrongDependency Method
DependenciesCollector Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddStrongDependency ( _
    dependency As Difference, _
    dependedOnBy As Difference, _
    setDependency As Boolean _
)
C#
public void AddStrongDependency(
    Difference dependency,
    Difference dependedOnBy,
    bool setDependency
)
Visual C++
public:
void AddStrongDependency(
    Difference^ dependency,
    Difference^ dependedOnBy,
    bool setDependency
)

Parameters

dependency
Type: RedGate.SQLCompare.Engine..::.Difference
dependedOnBy
Type: RedGate.SQLCompare.Engine..::.Difference
setDependency
Type: Boolean

See Also

DependenciesCollector Class
RedGate.SQLCompare.Engine Namespace


GetReverseDependencies Method

[image]

SQL Data Compare API 12.0.40
DependenciesCollector..::.GetReverseDependencies Method
DependenciesCollector Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetReverseDependencies As ICollection(Of Difference)
C#
public ICollection<Difference> GetReverseDependencies()
Visual C++
public:
ICollection<Difference^>^ GetReverseDependencies()

See Also

DependenciesCollector Class
RedGate.SQLCompare.Engine Namespace


GetReverseDependentObjects Method

[image]

SQL Data Compare API 12.0.40
DependenciesCollector..::.GetReverseDependentObjects Method
DependenciesCollector Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetReverseDependentObjects ( _
    difference As Difference _
) As ICollection(Of Difference)
C#
public ICollection<Difference> GetReverseDependentObjects(
    Difference difference
)
Visual C++
public:
ICollection<Difference^>^ GetReverseDependentObjects(
    Difference^ difference
)

Parameters

difference
Type: RedGate.SQLCompare.Engine..::.Difference

See Also

DependenciesCollector Class
RedGate.SQLCompare.Engine Namespace


DependenciesHelper Class

[image]

SQL Data Compare API 12.0.40
DependenciesHelper Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DependenciesHelper
C#
public static class DependenciesHelper
Visual C++
public ref class DependenciesHelper abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.DependenciesHelper

See Also

DependenciesHelper Members
RedGate.SQLCompare.Engine Namespace


DependenciesHelper Members

[image] [image]

SQL Data Compare API 12.0.40
DependenciesHelper Members
DependenciesHelper Class Methods See Also

The DependenciesHelper type exposes the following members.

Methods

Name | Description
ClearMemoizedValues |
GetDependencies | Gets the dependencies of a particular string of SQL code. Internal use only.
SetMemoization |

See Also

DependenciesHelper Class
RedGate.SQLCompare.Engine Namespace


DependenciesHelper Methods

[image] [image]

SQL Data Compare API 12.0.40
DependenciesHelper Methods
DependenciesHelper Class See Also

The DependenciesHelper type exposes the following methods.

Methods

Name | Description
ClearMemoizedValues |
GetDependencies | Gets the dependencies of a particular string of SQL code. Internal use only.
SetMemoization |

See Also

DependenciesHelper Class
RedGate.SQLCompare.Engine Namespace


ClearMemoizedValues Method

[image]

SQL Data Compare API 12.0.40
DependenciesHelper..::.ClearMemoizedValues Method
DependenciesHelper Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ClearMemoizedValues
C#
public static void ClearMemoizedValues()
Visual C++
public:
static void ClearMemoizedValues()

See Also

DependenciesHelper Class
RedGate.SQLCompare.Engine Namespace


GetDependencies Method

[image]

SQL Data Compare API 12.0.40
DependenciesHelper..::.GetDependencies Method
DependenciesHelper Class See Also

Gets the dependencies of a particular string of SQL code. Internal use only.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDependencies ( _
    sql As String, _
    quotedIdentifiers As Boolean, _
    throwExceptions As Boolean _
) As Stack(Of String())
C#
public static Stack<string[]> GetDependencies(
    string sql,
    bool quotedIdentifiers,
    bool throwExceptions
)
Visual C++
public:
static Stack<array<String^>^>^ GetDependencies(
    String^ sql,
    bool quotedIdentifiers,
    bool throwExceptions
)

Parameters

sql
Type: String
quotedIdentifiers
Type: Boolean
throwExceptions
Type: Boolean

See Also

DependenciesHelper Class
RedGate.SQLCompare.Engine Namespace


SetMemoization Method

[image]

SQL Data Compare API 12.0.40
DependenciesHelper..::.SetMemoization Method
DependenciesHelper Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub SetMemoization ( _
    enabled As Boolean _
)
C#
public static void SetMemoization(
    bool enabled
)
Visual C++
public:
static void SetMemoization(
    bool enabled
)

Parameters

enabled
Type: Boolean

See Also

DependenciesHelper Class
RedGate.SQLCompare.Engine Namespace


DependenciesResultCalculator Class

[image]

SQL Data Compare API 12.0.40
DependenciesResultCalculator Class
Members See Also

Various methods for calculating dependencies between different objects. It appears that these results are never used internally; instead they are intended for CompareUI/SOC/etc to look at

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class DependenciesResultCalculator
C#
public class DependenciesResultCalculator
Visual C++
public ref class DependenciesResultCalculator

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.DependenciesResultCalculator

See Also

DependenciesResultCalculator Members
RedGate.SQLCompare.Engine Namespace


DependenciesResultCalculator Members

[image] [image]

SQL Data Compare API 12.0.40
DependenciesResultCalculator Members
DependenciesResultCalculator Class Constructors Methods See Also

The DependenciesResultCalculator type exposes the following members.

Constructors

Name | Description
DependenciesResultCalculator |

Methods

Name | Description
CalculateWorkSetDependencyForContracts | Make sure that all message types are marked as dependents for contracts! Note, that this must be called after the contracts are selected for dependencies!
CalculateWorkSetDependencyForDBSysObjects | Sets the dependency for objects whose dependency is stored in the main dependency matrix. These are mainly objects that are sysobjects identifyables.
CalculateWorkSetDependencyForEventNotifications | Make sure that the relevant service and queue are marked as dependents for event notifications. Note, that this must be called after event notifications are selected for dependencies!
CalculateWorkSetDependencyForMessageTypes | Make sure that all xml schemacollections are marked as dependents for message types! Note, that this must be called after the message types are selected for dependencies!
CalculateWorkSetDependencyForPartitionFunctions | Make sure that all tables are marked as dependents for partition functions (through the schemes)! This must be run after all the partition functions are selected as dependencies.
CalculateWorkSetDependencyForPartitionSchemes | Make sure that all Partition Functions are marked as dependents for partition schemes, and then all partition schemes are marked as dependents for partitions
CalculateWorkSetDependencyForQueues | Make sure that all stored procedures are marked as dependents for queues! Note, that this must be called after queues are selected for dependencies! :(
CalculateWorkSetDependencyForServices | Make sure that all contracts and queues are marked as dependents for services! Note, that this must be called after services are selected for dependencies!
CalculateWorkSetDependencyForToAssemblies | Make sure that all assemblies are marked as dependents for CLR UDTs, storedProcedures, ....! Note, that this must be called after UDTs are selected for dependencies!
CalculateWorkSetDependencyForUDTs | Make sure that all user defined types of assemblies that are selected as dependencies are also selected as dependencies.
CalculateWorkSetDependencyForUsers | Sets user dependencies. This should be at the end, after other dependencies have been selected.
CalculateWorkSetDependencyToUDTs | Make sure that tables are marked as depending on CLR UDTs
CalculateWorkSetTypeDependencyForTablesAndFunctions | Make sure that all the user defined types that tables, functions, sprocs reference are included. This must be done after functions and tables are selected as dependencies.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DependenciesResultCalculator Class
RedGate.SQLCompare.Engine Namespace


DependenciesResultCalculator Constructor

[image]

SQL Data Compare API 12.0.40
DependenciesResultCalculator Constructor
DependenciesResultCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    dependenciesCollector As DependenciesCollector _
)
C#
public DependenciesResultCalculator(
    DependenciesCollector dependenciesCollector
)
Visual C++
public:
DependenciesResultCalculator(
    DependenciesCollector^ dependenciesCollector
)

Parameters

dependenciesCollector
Type: RedGate.SQLCompare.Engine..::.DependenciesCollector

See Also

DependenciesResultCalculator Class
RedGate.SQLCompare.Engine Namespace


DependenciesResultCalculator Methods

[image] [image]

SQL Data Compare API 12.0.40
DependenciesResultCalculator Methods
DependenciesResultCalculator Class See Also

The DependenciesResultCalculator type exposes the following methods.

Methods

Name | Description
CalculateWorkSetDependencyForContracts | Make sure that all message types are marked as dependents for contracts! Note, that this must be called after the contracts are selected for dependencies!
CalculateWorkSetDependencyForDBSysObjects | Sets the dependency for objects whose dependency is stored in the main dependency matrix. These are mainly objects that are sysobjects identifyables.
CalculateWorkSetDependencyForEventNotifications | Make sure that the relevant service and queue are marked as dependents for event notifications. Note, that this must be called after event notifications are selected for dependencies!
CalculateWorkSetDependencyForMessageTypes | Make sure that all xml schemacollections are marked as dependents for message types! Note, that this must be called after the message types are selected for dependencies!
CalculateWorkSetDependencyForPartitionFunctions | Make sure that all tables are marked as dependents for partition functions (through the schemes)! This must be run after all the partition functions are selected as dependencies.
CalculateWorkSetDependencyForPartitionSchemes | Make sure that all Partition Functions are marked as dependents for partition schemes, and then all partition schemes are marked as dependents for partitions
CalculateWorkSetDependencyForQueues | Make sure that all stored procedures are marked as dependents for queues! Note, that this must be called after queues are selected for dependencies! :(
CalculateWorkSetDependencyForServices | Make sure that all contracts and queues are marked as dependents for services! Note, that this must be called after services are selected for dependencies!
CalculateWorkSetDependencyForToAssemblies | Make sure that all assemblies are marked as dependents for CLR UDTs, storedProcedures, ....! Note, that this must be called after UDTs are selected for dependencies!
CalculateWorkSetDependencyForUDTs | Make sure that all user defined types of assemblies that are selected as dependencies are also selected as dependencies.
CalculateWorkSetDependencyForUsers | Sets user dependencies. This should be at the end, after other dependencies have been selected.
CalculateWorkSetDependencyToUDTs | Make sure that tables are marked as depending on CLR UDTs
CalculateWorkSetTypeDependencyForTablesAndFunctions | Make sure that all the user defined types that tables, functions, sprocs reference are included. This must be done after functions and tables are selected as dependencies.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DependenciesResultCalculator Class
RedGate.SQLCompare.Engine Namespace


CalculateWorkSetDependencyForContracts Method

[image]

SQL Data Compare API 12.0.40
DependenciesResultCalculator..::.CalculateWorkSetDependencyForContracts Method
DependenciesResultCalculator Class See Also

Make sure that all message types are marked as dependents for contracts! Note, that this must be called after the contracts are selected for dependencies!

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculateWorkSetDependencyForContracts ( _
    differences As Differences _
)
C#
public void CalculateWorkSetDependencyForContracts(
    Differences differences
)
Visual C++
public:
void CalculateWorkSetDependencyForContracts(
    Differences^ differences
)

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences

See Also

DependenciesResultCalculator Class
RedGate.SQLCompare.Engine Namespace


CalculateWorkSetDependencyForDBSysObjects Method

[image]

SQL Data Compare API 12.0.40
DependenciesResultCalculator..::.CalculateWorkSetDependencyForDBSysObjects Method
DependenciesResultCalculator Class See Also

Sets the dependency for objects whose dependency is stored in the main dependency matrix. These are mainly objects that are sysobjects identifyables.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculateWorkSetDependencyForDBSysObjects ( _
    differences As Differences, _
    options As Options _
)
C#
public void CalculateWorkSetDependencyForDBSysObjects(
    Differences differences,
    Options options
)
Visual C++
public:
void CalculateWorkSetDependencyForDBSysObjects(
    Differences^ differences,
    Options options
)

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

DependenciesResultCalculator Class
RedGate.SQLCompare.Engine Namespace


CalculateWorkSetDependencyForEventNotifications Method

[image]

SQL Data Compare API 12.0.40
DependenciesResultCalculator..::.CalculateWorkSetDependencyForEventNotifications Method
DependenciesResultCalculator Class See Also

Make sure that the relevant service and queue are marked as dependents for event notifications. Note, that this must be called after event notifications are selected for dependencies!

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculateWorkSetDependencyForEventNotifications ( _
    differences As Differences _
)
C#
public void CalculateWorkSetDependencyForEventNotifications(
    Differences differences
)
Visual C++
public:
void CalculateWorkSetDependencyForEventNotifications(
    Differences^ differences
)

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences

See Also

DependenciesResultCalculator Class
RedGate.SQLCompare.Engine Namespace


CalculateWorkSetDependencyForMessageTypes Method

[image]

SQL Data Compare API 12.0.40
DependenciesResultCalculator..::.CalculateWorkSetDependencyForMessageTypes Method
DependenciesResultCalculator Class See Also

Make sure that all xml schemacollections are marked as dependents for message types! Note, that this must be called after the message types are selected for dependencies!

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculateWorkSetDependencyForMessageTypes ( _
    differences As Differences _
)
C#
public void CalculateWorkSetDependencyForMessageTypes(
    Differences differences
)
Visual C++
public:
void CalculateWorkSetDependencyForMessageTypes(
    Differences^ differences
)

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences

See Also

DependenciesResultCalculator Class
RedGate.SQLCompare.Engine Namespace


CalculateWorkSetDependencyForPartitionFunctions Method

[image]

SQL Data Compare API 12.0.40
DependenciesResultCalculator..::.CalculateWorkSetDependencyForPartitionFunctions Method
DependenciesResultCalculator Class See Also

Make sure that all tables are marked as dependents for partition functions (through the schemes)! This must be run after all the partition functions are selected as dependencies.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculateWorkSetDependencyForPartitionFunctions ( _
    differences As Differences, _
    runOnTwo As Boolean _
)
C#
public void CalculateWorkSetDependencyForPartitionFunctions(
    Differences differences,
    bool runOnTwo
)
Visual C++
public:
void CalculateWorkSetDependencyForPartitionFunctions(
    Differences^ differences,
    bool runOnTwo
)

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
runOnTwo
Type: Boolean

See Also

DependenciesResultCalculator Class
RedGate.SQLCompare.Engine Namespace


CalculateWorkSetDependencyForPartitionSchemes Method

[image]

SQL Data Compare API 12.0.40
DependenciesResultCalculator..::.CalculateWorkSetDependencyForPartitionSchemes Method
DependenciesResultCalculator Class See Also

Make sure that all Partition Functions are marked as dependents for partition schemes, and then all partition schemes are marked as dependents for partitions

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculateWorkSetDependencyForPartitionSchemes ( _
    differences As Differences _
)
C#
public void CalculateWorkSetDependencyForPartitionSchemes(
    Differences differences
)
Visual C++
public:
void CalculateWorkSetDependencyForPartitionSchemes(
    Differences^ differences
)

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences

Remarks

This depends on the ordering of differences in that tables/views come before partition functions (which come before partition schemes and should know what schemes depend on them) so that all the dependencies can be set in one pass

See Also

DependenciesResultCalculator Class
RedGate.SQLCompare.Engine Namespace


CalculateWorkSetDependencyForQueues Method

[image]

SQL Data Compare API 12.0.40
DependenciesResultCalculator..::.CalculateWorkSetDependencyForQueues Method
DependenciesResultCalculator Class See Also

Make sure that all stored procedures are marked as dependents for queues! Note, that this must be called after queues are selected for dependencies! :(

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculateWorkSetDependencyForQueues ( _
    differences As Differences _
)
C#
public void CalculateWorkSetDependencyForQueues(
    Differences differences
)
Visual C++
public:
void CalculateWorkSetDependencyForQueues(
    Differences^ differences
)

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences

See Also

DependenciesResultCalculator Class
RedGate.SQLCompare.Engine Namespace


CalculateWorkSetDependencyForServices Method

[image]

SQL Data Compare API 12.0.40
DependenciesResultCalculator..::.CalculateWorkSetDependencyForServices Method
DependenciesResultCalculator Class See Also

Make sure that all contracts and queues are marked as dependents for services! Note, that this must be called after services are selected for dependencies!

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculateWorkSetDependencyForServices ( _
    differences As Differences _
)
C#
public void CalculateWorkSetDependencyForServices(
    Differences differences
)
Visual C++
public:
void CalculateWorkSetDependencyForServices(
    Differences^ differences
)

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences

See Also

DependenciesResultCalculator Class
RedGate.SQLCompare.Engine Namespace


CalculateWorkSetDependencyForToAssemblies Method

[image]

SQL Data Compare API 12.0.40
DependenciesResultCalculator..::.CalculateWorkSetDependencyForToAssemblies Method
DependenciesResultCalculator Class See Also

Make sure that all assemblies are marked as dependents for CLR UDTs, storedProcedures, ....! Note, that this must be called after UDTs are selected for dependencies!

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CalculateWorkSetDependencyForToAssemblies ( _
    differences As Differences, _
    runOnTwo As Boolean, _
    doTriggers As Boolean _
) As Boolean
C#
public bool CalculateWorkSetDependencyForToAssemblies(
    Differences differences,
    bool runOnTwo,
    bool doTriggers
)
Visual C++
public:
bool CalculateWorkSetDependencyForToAssemblies(
    Differences^ differences,
    bool runOnTwo,
    bool doTriggers
)

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
runOnTwo
Type: Boolean
doTriggers
Type: Boolean

Return Value

True, if an assembly has been added as a new dependency.

See Also

DependenciesResultCalculator Class
RedGate.SQLCompare.Engine Namespace


CalculateWorkSetDependencyForUDTs Method

[image]

SQL Data Compare API 12.0.40
DependenciesResultCalculator..::.CalculateWorkSetDependencyForUDTs Method
DependenciesResultCalculator Class See Also

Make sure that all user defined types of assemblies that are selected as dependencies are also selected as dependencies.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculateWorkSetDependencyForUDTs ( _
    differences As Differences, _
    runOnTwo As Boolean, _
    options As Options _
)
C#
public void CalculateWorkSetDependencyForUDTs(
    Differences differences,
    bool runOnTwo,
    Options options
)
Visual C++
public:
void CalculateWorkSetDependencyForUDTs(
    Differences^ differences,
    bool runOnTwo,
    Options options
)

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
runOnTwo
Type: Boolean
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

DependenciesResultCalculator Class
RedGate.SQLCompare.Engine Namespace


CalculateWorkSetDependencyForUsers Method

[image]

SQL Data Compare API 12.0.40
DependenciesResultCalculator..::.CalculateWorkSetDependencyForUsers Method
DependenciesResultCalculator Class See Also

Sets user dependencies. This should be at the end, after other dependencies have been selected.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculateWorkSetDependencyForUsers ( _
    differences As Differences, _
    options As Options, _
    runOnTwo As Boolean, _
    sourceDatabase As Database, _
    targetDatabase As Database, _
    sqlGenerationQueueBuilder As SqlGenerationQueueBuilder _
)
C#
public void CalculateWorkSetDependencyForUsers(
    Differences differences,
    Options options,
    bool runOnTwo,
    Database sourceDatabase,
    Database targetDatabase,
    SqlGenerationQueueBuilder sqlGenerationQueueBuilder
)
Visual C++
public:
void CalculateWorkSetDependencyForUsers(
    Differences^ differences,
    Options options,
    bool runOnTwo,
    Database^ sourceDatabase,
    Database^ targetDatabase,
    SqlGenerationQueueBuilder^ sqlGenerationQueueBuilder
)

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
options
Type: RedGate.SQLCompare.Engine..::.Options
runOnTwo
Type: Boolean
sourceDatabase
Type: RedGate.SQLCompare.Engine..::.Database
targetDatabase
Type: RedGate.SQLCompare.Engine..::.Database
sqlGenerationQueueBuilder
Type: RedGate.SQLCompare.Engine..::.SqlGenerationQueueBuilder

See Also

DependenciesResultCalculator Class
RedGate.SQLCompare.Engine Namespace


CalculateWorkSetDependencyToUDTs Method

[image]

SQL Data Compare API 12.0.40
DependenciesResultCalculator..::.CalculateWorkSetDependencyToUDTs Method
DependenciesResultCalculator Class See Also

Make sure that tables are marked as depending on CLR UDTs

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculateWorkSetDependencyToUDTs ( _
    differences As Differences, _
    runOnTwo As Boolean _
)
C#
public void CalculateWorkSetDependencyToUDTs(
    Differences differences,
    bool runOnTwo
)
Visual C++
public:
void CalculateWorkSetDependencyToUDTs(
    Differences^ differences,
    bool runOnTwo
)

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
runOnTwo
Type: Boolean

See Also

DependenciesResultCalculator Class
RedGate.SQLCompare.Engine Namespace


CalculateWorkSetTypeDependencyForTablesAndFunctions Method

[image]

SQL Data Compare API 12.0.40
DependenciesResultCalculator..::.CalculateWorkSetTypeDependencyForTablesAndFunctions Method
DependenciesResultCalculator Class See Also

Make sure that all the user defined types that tables, functions, sprocs reference are included. This must be done after functions and tables are selected as dependencies.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CalculateWorkSetTypeDependencyForTablesAndFunctions ( _
    differences As Differences, _
    runOnTwo As Boolean _
) As Boolean
C#
public bool CalculateWorkSetTypeDependencyForTablesAndFunctions(
    Differences differences,
    bool runOnTwo
)
Visual C++
public:
bool CalculateWorkSetTypeDependencyForTablesAndFunctions(
    Differences^ differences,
    bool runOnTwo
)

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
runOnTwo
Type: Boolean

See Also

DependenciesResultCalculator Class
RedGate.SQLCompare.Engine Namespace


DeploymentResult Class

[image]

SQL Data Compare API 12.0.40
DeploymentResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class DeploymentResult
C#
public class DeploymentResult
Visual C++
public ref class DeploymentResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.DeploymentResult
RedGate.SQLCompare.Engine..::.ScriptGenerationResult
RedGate.SQLCompare.Engine..::.SqlGenerationResult

See Also

DeploymentResult Members
RedGate.SQLCompare.Engine Namespace


DeploymentResult Members

[image] [image]

SQL Data Compare API 12.0.40
DeploymentResult Members
DeploymentResult Class Methods Properties See Also

The DeploymentResult type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Messages |
Warnings |

See Also

DeploymentResult Class
RedGate.SQLCompare.Engine Namespace


DeploymentResult Properties

[image] [image]

SQL Data Compare API 12.0.40
DeploymentResult Properties
DeploymentResult Class See Also

The DeploymentResult type exposes the following properties.

Properties

Name | Description
Messages |
Warnings |

See Also

DeploymentResult Class
RedGate.SQLCompare.Engine Namespace


Messages Property

[image]

SQL Data Compare API 12.0.40
DeploymentResult..::.Messages Property
DeploymentResult Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Messages As IEnumerable(Of IDeploymentMessage)
C#
public IEnumerable<IDeploymentMessage> Messages { get; }
Visual C++
public:
virtual property IEnumerable<IDeploymentMessage^>^ Messages {
    IEnumerable<IDeploymentMessage^>^ get () sealed;
}

See Also

DeploymentResult Class
RedGate.SQLCompare.Engine Namespace


Warnings Property

[image]

SQL Data Compare API 12.0.40
DeploymentResult..::.Warnings Property
DeploymentResult Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Warnings As IEnumerable(Of IDeploymentMessage)
C#
public IEnumerable<IDeploymentMessage> Warnings { get; }
Visual C++
public:
virtual property IEnumerable<IDeploymentMessage^>^ Warnings {
    IEnumerable<IDeploymentMessage^>^ get () sealed;
}

See Also

DeploymentResult Class
RedGate.SQLCompare.Engine Namespace


Difference Class

[image]

SQL Data Compare API 12.0.40
Difference Class
Members See Also

A difference between two database objects.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Difference _
    Implements ICompareDifference, IDatabaseObjectDifference(Of IDatabaseObject),  _
    IDifference, IComparable(Of Difference)
C#
public sealed class Difference : ICompareDifference,
    IDatabaseObjectDifference<IDatabaseObject>, IDifference, IComparable<Difference>
Visual C++
public ref class Difference sealed : ICompareDifference,
    IDatabaseObjectDifference<IDatabaseObject^>, IDifference, IComparable<Difference^>

Remarks

See CompareWith(Database, Options) and Work for more information.

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.Difference

See Also

Difference Members
RedGate.SQLCompare.Engine Namespace


Difference Members

[image] [image]

SQL Data Compare API 12.0.40
Difference Members
Difference Class Methods Properties See Also

The Difference type exposes the following members.

Methods

Name | Description
CompareTo | Compares the current object with another object of the same type.
Equals | Equality check. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Hashcode for the difference. (Overrides Object..::.GetHashCode()()().)
GetOriginalDifference |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DatabaseObjectType | The type of database object the difference represents.
Name | The name of the database object.
ObjectIn1 | The object in the first database.
ObjectIn2 | The object in the second database.
Renamed | Indicates whether the object was renamed as part of a rename refactoring.
Selected | True if the difference is selected.
Type | The type of difference.

See Also

Difference Class
RedGate.SQLCompare.Engine Namespace


Difference Methods

[image] [image]

SQL Data Compare API 12.0.40
Difference Methods
Difference Class See Also

The Difference type exposes the following methods.

Methods

Name | Description
CompareTo | Compares the current object with another object of the same type.
Equals | Equality check. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Hashcode for the difference. (Overrides Object..::.GetHashCode()()().)
GetOriginalDifference |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Difference Class
RedGate.SQLCompare.Engine Namespace


CompareTo Method

[image]

SQL Data Compare API 12.0.40
Difference..::.CompareTo Method
Difference Class See Also

Compares the current object with another object of the same type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareTo ( _
    other As Difference _
) As Integer
C#
public int CompareTo(
    Difference other
)
Visual C++
public:
virtual int CompareTo(
    Difference^ other
) sealed

Parameters

other
Type: RedGate.SQLCompare.Engine..::.Difference
An object to compare with this object.

Return Value

A 32-bit signed integer that indicates the relative order of the objects being compared. The return value has the following meanings: Value Meaning Less than zero This object is less than the other parameter.Zero This object is equal to other. Greater than zero This object is greater than other.

Implements

IComparableCompareTo(UTP)

See Also

Difference Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image]

SQL Data Compare API 12.0.40
Difference..::.Equals Method
Difference Class See Also

Equality check.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object
Difference instance to compare against.

Return Value

True if the two Difference instances are equal.

Implements

IDifferenceEquals(Object)

See Also

Difference Class
RedGate.SQLCompare.Engine Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
Difference..::.GetHashCode Method
Difference Class See Also

Hashcode for the difference.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

Return Value

Hashcode for the difference.

Implements

IDifferenceGetHashCode()()()

See Also

Difference Class
RedGate.SQLCompare.Engine Namespace


GetOriginalDifference Method

[image]

SQL Data Compare API 12.0.40
Difference..::.GetOriginalDifference Method
Difference Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetOriginalDifference ( _
    d As Difference _
) As Difference
C#
public static Difference GetOriginalDifference(
    Difference d
)
Visual C++
public:
static Difference^ GetOriginalDifference(
    Difference^ d
)

Parameters

d
Type: RedGate.SQLCompare.Engine..::.Difference

See Also

Difference Class
RedGate.SQLCompare.Engine Namespace


Difference Properties

[image] [image]

SQL Data Compare API 12.0.40
Difference Properties
Difference Class See Also

The Difference type exposes the following properties.

Properties

Name | Description
DatabaseObjectType | The type of database object the difference represents.
Name | The name of the database object.
ObjectIn1 | The object in the first database.
ObjectIn2 | The object in the second database.
Renamed | Indicates whether the object was renamed as part of a rename refactoring.
Selected | True if the difference is selected.
Type | The type of difference.

See Also

Difference Class
RedGate.SQLCompare.Engine Namespace


DatabaseObjectType Property

[image]

SQL Data Compare API 12.0.40
Difference..::.DatabaseObjectType Property
Difference Class See Also

The type of database object the difference represents.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DatabaseObjectType As ObjectType
C#
public ObjectType DatabaseObjectType { get; internal set; }
Visual C++
public:
virtual property ObjectType DatabaseObjectType {
    ObjectType get () sealed;
    void set (ObjectType value) sealed;
}

Implements

IDifferenceDatabaseObjectType()()()

See Also

Difference Class
RedGate.SQLCompare.Engine Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
Difference..::.Name Property
Difference Class See Also

The name of the database object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; internal set; }
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IDifferenceName()()()

See Also

Difference Class
RedGate.SQLCompare.Engine Namespace


ObjectIn1 Property

[image]

SQL Data Compare API 12.0.40
Difference..::.ObjectIn1 Property
Difference Class See Also

The object in the first database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectIn1 As IDatabaseObject
C#
public IDatabaseObject ObjectIn1 { get; internal set; }
Visual C++
public:
virtual property IDatabaseObject^ ObjectIn1 {
    IDatabaseObject^ get () sealed;
    void set (IDatabaseObject^ value) sealed;
}

Implements

IDatabaseObjectDifferenceObjectIn1()()()

See Also

Difference Class
RedGate.SQLCompare.Engine Namespace


ObjectIn2 Property

[image]

SQL Data Compare API 12.0.40
Difference..::.ObjectIn2 Property
Difference Class See Also

The object in the second database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectIn2 As IDatabaseObject
C#
public IDatabaseObject ObjectIn2 { get; internal set; }
Visual C++
public:
virtual property IDatabaseObject^ ObjectIn2 {
    IDatabaseObject^ get () sealed;
    void set (IDatabaseObject^ value) sealed;
}

Implements

IDatabaseObjectDifferenceObjectIn2()()()

See Also

Difference Class
RedGate.SQLCompare.Engine Namespace


Renamed Property

[image]

SQL Data Compare API 12.0.40
Difference..::.Renamed Property
Difference Class See Also

Indicates whether the object was renamed as part of a rename refactoring.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Renamed As Boolean
C#
public bool Renamed { get; set; }
Visual C++
public:
virtual property bool Renamed {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IDifferenceRenamed()()()

See Also

Difference Class
RedGate.SQLCompare.Engine Namespace


Selected Property

[image]

SQL Data Compare API 12.0.40
Difference..::.Selected Property
Difference Class See Also

True if the difference is selected.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Selected As Boolean
C#
public bool Selected { get; set; }
Visual C++
public:
virtual property bool Selected {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IDifferenceSelected()()()

Remarks

Set to true to include the difference in a migration script.

See Also

Difference Class
RedGate.SQLCompare.Engine Namespace


Type Property

[image]

SQL Data Compare API 12.0.40
Difference..::.Type Property
Difference Class See Also

The type of difference.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As DifferenceType
C#
public DifferenceType Type { get; internal set; }
Visual C++
public:
virtual property DifferenceType Type {
    DifferenceType get () sealed;
    void set (DifferenceType value) sealed;
}

Implements

IDifferenceType()()()

See Also

Difference Class
RedGate.SQLCompare.Engine Namespace


Differences Class

[image]

SQL Data Compare API 12.0.40
Differences Class
Members See Also

A collection of difference objects representing the differences between two databases.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Differences _
    Implements IEnumerable(Of Difference), IEnumerable
C#
public sealed class Differences : IEnumerable<Difference>,
    IEnumerable
Visual C++
public ref class Differences sealed : IEnumerable<Difference^>,
    IEnumerable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.Differences

See Also

Differences Members
RedGate.SQLCompare.Engine Namespace


Differences Members

[image] [image]

SQL Data Compare API 12.0.40
Differences Members
Differences Class Methods Properties Explicit Interface Implementations See Also

The Differences type exposes the following members.

Methods

Name | Description
Add | Adds an item to the Differences collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AreAllEqual |
Database1 | The first database to be compared.
Database2 | The second database to be compared.

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator |

See Also

Differences Class
RedGate.SQLCompare.Engine Namespace


Differences Methods

[image] [image]

SQL Data Compare API 12.0.40
Differences Methods
Differences Class See Also

The Differences type exposes the following methods.

Methods

Name | Description
Add | Adds an item to the Differences collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator |

See Also

Differences Class
RedGate.SQLCompare.Engine Namespace


Add Method

[image]

SQL Data Compare API 12.0.40
Differences..::.Add Method
Differences Class See Also

Adds an item to the Differences collection.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add ( _
    value As Difference _
)
C#
public void Add(
    Difference value
)
Visual C++
public:
void Add(
    Difference^ value
)

Parameters

value
Type: RedGate.SQLCompare.Engine..::.Difference
The object to add.

See Also

Differences Class
RedGate.SQLCompare.Engine Namespace


GetEnumerator Method

[image]

SQL Data Compare API 12.0.40
Differences..::.GetEnumerator Method
Differences Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of Difference)
C#
public IEnumerator<Difference> GetEnumerator()
Visual C++
public:
virtual IEnumerator<Difference^>^ GetEnumerator() sealed

Implements

IEnumerableGetEnumerator()()()

See Also

Differences Class
RedGate.SQLCompare.Engine Namespace


. Method

[image]

SQL Data Compare API 12.0.40
Differences..::...::. Method
Differences Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
C#
IEnumerator IEnumerable.GetEnumerator()
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerableGetEnumerator()()()

See Also

Differences Class
RedGate.SQLCompare.Engine Namespace


Remove Method

[image]

SQL Data Compare API 12.0.40
Differences..::.Remove Method
Differences Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Remove ( _
    difference As Difference _
)
C#
public void Remove(
    Difference difference
)
Visual C++
public:
void Remove(
    Difference^ difference
)

Parameters

difference
Type: RedGate.SQLCompare.Engine..::.Difference

See Also

Differences Class
RedGate.SQLCompare.Engine Namespace


Differences Properties

[image] [image]

SQL Data Compare API 12.0.40
Differences Properties
Differences Class See Also

The Differences type exposes the following properties.

Properties

Name | Description
AreAllEqual |
Database1 | The first database to be compared.
Database2 | The second database to be compared.

See Also

Differences Class
RedGate.SQLCompare.Engine Namespace


AreAllEqual Property

[image]

SQL Data Compare API 12.0.40
Differences..::.AreAllEqual Property
Differences Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AreAllEqual As Boolean
C#
public bool AreAllEqual { get; }
Visual C++
public:
property bool AreAllEqual {
    bool get ();
}

See Also

Differences Class
RedGate.SQLCompare.Engine Namespace


Database1 Property

[image]

SQL Data Compare API 12.0.40
Differences..::.Database1 Property
Differences Class See Also

The first database to be compared.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Database1 As Database
C#
public Database Database1 { get; internal set; }
Visual C++
public:
property Database^ Database1 {
    Database^ get ();
    void set (Database^ value);
}

See Also

Differences Class
RedGate.SQLCompare.Engine Namespace


Database2 Property

[image]

SQL Data Compare API 12.0.40
Differences..::.Database2 Property
Differences Class See Also

The second database to be compared.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Database2 As Database
C#
public Database Database2 { get; internal set; }
Visual C++
public:
property Database^ Database2 {
    Database^ get ();
    void set (Database^ value);
}

See Also

Differences Class
RedGate.SQLCompare.Engine Namespace


DmlTriggersChanges Class

[image]

SQL Data Compare API 12.0.40
DmlTriggersChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DmlTriggersChanges
C#
public sealed class DmlTriggersChanges
Visual C++
public ref class DmlTriggersChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.DmlTriggersChanges

See Also

DmlTriggersChanges Members
RedGate.SQLCompare.Engine Namespace


DmlTriggersChanges Members

[image] [image]

SQL Data Compare API 12.0.40
DmlTriggersChanges Members
DmlTriggersChanges Class Constructors Methods Properties See Also

The DmlTriggersChanges type exposes the following members.

Constructors

Name | Description
DmlTriggersChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
TriggerOrderDifferenceOnly |
TriggersToAlter |
TriggersToCreate |
TriggersToDrop |
TriggerTargets |

See Also

DmlTriggersChanges Class
RedGate.SQLCompare.Engine Namespace


DmlTriggersChanges Constructor

[image]

SQL Data Compare API 12.0.40
DmlTriggersChanges Constructor
DmlTriggersChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public DmlTriggersChanges(
    bool caseSensitive
)
Visual C++
public:
DmlTriggersChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

DmlTriggersChanges Class
RedGate.SQLCompare.Engine Namespace


DmlTriggersChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
DmlTriggersChanges Properties
DmlTriggersChanges Class See Also

The DmlTriggersChanges type exposes the following properties.

Properties

Name | Description
TriggerOrderDifferenceOnly |
TriggersToAlter |
TriggersToCreate |
TriggersToDrop |
TriggerTargets |

See Also

DmlTriggersChanges Class
RedGate.SQLCompare.Engine Namespace


TriggerOrderDifferenceOnly Property

[image]

SQL Data Compare API 12.0.40
DmlTriggersChanges..::.TriggerOrderDifferenceOnly Property
DmlTriggersChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TriggerOrderDifferenceOnly As Set(Of Trigger)
C#
public Set<Trigger> TriggerOrderDifferenceOnly { get; private set; }
Visual C++
public:
property Set<Trigger^>^ TriggerOrderDifferenceOnly {
    Set<Trigger^>^ get ();
    void set (Set<Trigger^>^ value);
}

See Also

DmlTriggersChanges Class
RedGate.SQLCompare.Engine Namespace


TriggersToAlter Property

[image]

SQL Data Compare API 12.0.40
DmlTriggersChanges..::.TriggersToAlter Property
DmlTriggersChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TriggersToAlter As Triggers
C#
public Triggers TriggersToAlter { get; private set; }
Visual C++
public:
property Triggers^ TriggersToAlter {
    Triggers^ get ();
    void set (Triggers^ value);
}

See Also

DmlTriggersChanges Class
RedGate.SQLCompare.Engine Namespace


TriggersToCreate Property

[image]

SQL Data Compare API 12.0.40
DmlTriggersChanges..::.TriggersToCreate Property
DmlTriggersChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TriggersToCreate As Triggers
C#
public Triggers TriggersToCreate { get; private set; }
Visual C++
public:
property Triggers^ TriggersToCreate {
    Triggers^ get ();
    void set (Triggers^ value);
}

See Also

DmlTriggersChanges Class
RedGate.SQLCompare.Engine Namespace


TriggersToDrop Property

[image]

SQL Data Compare API 12.0.40
DmlTriggersChanges..::.TriggersToDrop Property
DmlTriggersChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TriggersToDrop As Triggers
C#
public Triggers TriggersToDrop { get; private set; }
Visual C++
public:
property Triggers^ TriggersToDrop {
    Triggers^ get ();
    void set (Triggers^ value);
}

See Also

DmlTriggersChanges Class
RedGate.SQLCompare.Engine Namespace


TriggerTargets Property

[image]

SQL Data Compare API 12.0.40
DmlTriggersChanges..::.TriggerTargets Property
DmlTriggersChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TriggerTargets As Dictionary(Of Trigger, Trigger)
C#
public Dictionary<Trigger, Trigger> TriggerTargets { get; private set; }
Visual C++
public:
property Dictionary<Trigger^, Trigger^>^ TriggerTargets {
    Dictionary<Trigger^, Trigger^>^ get ();
    void set (Dictionary<Trigger^, Trigger^>^ value);
}

See Also

DmlTriggersChanges Class
RedGate.SQLCompare.Engine Namespace


DmvModelFactory Class

[image]

SQL Data Compare API 12.0.40
DmvModelFactory Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class DmvModelFactory _
    Implements IDmvModelFactory
C#
public class DmvModelFactory : IDmvModelFactory
Visual C++
public ref class DmvModelFactory : IDmvModelFactory

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.DmvModelFactory

See Also

DmvModelFactory Members
RedGate.SQLCompare.Engine Namespace


DmvModelFactory Members

[image] [image]

SQL Data Compare API 12.0.40
DmvModelFactory Members
DmvModelFactory Class Constructors Methods See Also

The DmvModelFactory type exposes the following members.

Constructors

Name | Description
DmvModelFactory |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromConnectionProperties |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DmvModelFactory Class
RedGate.SQLCompare.Engine Namespace


DmvModelFactory Constructor

[image]

SQL Data Compare API 12.0.40
DmvModelFactory Constructor
DmvModelFactory Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DmvModelFactory()
Visual C++
public:
DmvModelFactory()

See Also

DmvModelFactory Class
RedGate.SQLCompare.Engine Namespace


DmvModelFactory Methods

[image] [image]

SQL Data Compare API 12.0.40
DmvModelFactory Methods
DmvModelFactory Class See Also

The DmvModelFactory type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromConnectionProperties |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DmvModelFactory Class
RedGate.SQLCompare.Engine Namespace


FromConnectionProperties Method

[image]

SQL Data Compare API 12.0.40
DmvModelFactory..::.FromConnectionProperties Method
DmvModelFactory Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function FromConnectionProperties ( _
    connProp As ConnectionProperties, _
    options As Options, _
    cancellationStatus As ICancellationStatus, _
    temporaryFileManager As ITemporaryFileManager _
) As IDmvModel
C#
public virtual IDmvModel FromConnectionProperties(
    ConnectionProperties connProp,
    Options options,
    ICancellationStatus cancellationStatus,
    ITemporaryFileManager temporaryFileManager
)
Visual C++
public:
virtual IDmvModel^ FromConnectionProperties(
    ConnectionProperties^ connProp,
    Options options,
    ICancellationStatus^ cancellationStatus,
    ITemporaryFileManager^ temporaryFileManager
)

Parameters

connProp
Type: RedGate.SQLCompare.Engine..::.ConnectionProperties
options
Type: RedGate.SQLCompare.Engine..::.Options
cancellationStatus
Type: RedGate.SQLCompare.Engine..::.ICancellationStatus
temporaryFileManager
Type: ITemporaryFileManager

Implements

IDmvModelFactory..::.FromConnectionProperties(ConnectionProperties, Options, ICancellationStatus, ITemporaryFileManager)

See Also

DmvModelFactory Class
RedGate.SQLCompare.Engine Namespace


DRIDefaultsChanges Class

[image]

SQL Data Compare API 12.0.40
DRIDefaultsChanges Class
Members See Also

TODO: I'm not sure if this grouping is sensible. Currently it's defaults-related things that isn't in DefaultsChanges

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DRIDefaultsChanges
C#
public sealed class DRIDefaultsChanges
Visual C++
public ref class DRIDefaultsChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.DRIDefaultsChanges

See Also

DRIDefaultsChanges Members
RedGate.SQLCompare.Engine Namespace


DRIDefaultsChanges Members

[image] [image]

SQL Data Compare API 12.0.40
DRIDefaultsChanges Members
DRIDefaultsChanges Class Constructors Methods Properties See Also

The DRIDefaultsChanges type exposes the following members.

Constructors

Name | Description
DRIDefaultsChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DRIDefaultsToCreate |
DRIDefaultsToDrop |

See Also

DRIDefaultsChanges Class
RedGate.SQLCompare.Engine Namespace


DRIDefaultsChanges Constructor

[image]

SQL Data Compare API 12.0.40
DRIDefaultsChanges Constructor
DRIDefaultsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public DRIDefaultsChanges(
    bool caseSensitive
)
Visual C++
public:
DRIDefaultsChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

DRIDefaultsChanges Class
RedGate.SQLCompare.Engine Namespace


DRIDefaultsChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
DRIDefaultsChanges Properties
DRIDefaultsChanges Class See Also

The DRIDefaultsChanges type exposes the following properties.

Properties

Name | Description
DRIDefaultsToCreate |
DRIDefaultsToDrop |

See Also

DRIDefaultsChanges Class
RedGate.SQLCompare.Engine Namespace


DRIDefaultsToCreate Property

[image]

SQL Data Compare API 12.0.40
DRIDefaultsChanges..::.DRIDefaultsToCreate Property
DRIDefaultsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DRIDefaultsToCreate As FieldBindings
C#
public FieldBindings DRIDefaultsToCreate { get; private set; }
Visual C++
public:
property FieldBindings^ DRIDefaultsToCreate {
    FieldBindings^ get ();
    void set (FieldBindings^ value);
}

See Also

DRIDefaultsChanges Class
RedGate.SQLCompare.Engine Namespace


DRIDefaultsToDrop Property

[image]

SQL Data Compare API 12.0.40
DRIDefaultsChanges..::.DRIDefaultsToDrop Property
DRIDefaultsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DRIDefaultsToDrop As FieldBindings
C#
public FieldBindings DRIDefaultsToDrop { get; private set; }
Visual C++
public:
property FieldBindings^ DRIDefaultsToDrop {
    FieldBindings^ get ();
    void set (FieldBindings^ value);
}

See Also

DRIDefaultsChanges Class
RedGate.SQLCompare.Engine Namespace


DuplicateObjectNameException Class

[image]

SQL Data Compare API 12.0.40
DuplicateObjectNameException Class
Members See Also

Exception thrown when the engine finds that an object definition already exists for a given name and it is not expected to. In many cases this is caused by case-sensitivity problems, so this exception has specific support for flagging that error case (IsCaseInsensitiveCollision).

This class also provides static ThrowIf... methods to perform the normal collision checks used by the engine, detect case-insensitivity problems, and throw the correct DuplicateObjectNameException when collisions occur.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class DuplicateObjectNameException _
    Inherits SqlCompareException
C#
[SerializableAttribute]
public class DuplicateObjectNameException : SqlCompareException
Visual C++
[SerializableAttribute]
public ref class DuplicateObjectNameException : public SqlCompareException

Inheritance Hierarchy

Object
Exception
RedGate.SQLCompare.Engine..::.SqlCompareException
RedGate.SQLCompare.Engine..::.DuplicateObjectNameException
RedGate.SQLCompare.Engine..::.DatabaseObjectExistsException

See Also

DuplicateObjectNameException Members
RedGate.SQLCompare.Engine Namespace


DuplicateObjectNameException Members

[image] [image]

SQL Data Compare API 12.0.40
DuplicateObjectNameException Members
DuplicateObjectNameException Class Constructors Methods Properties See Also

The DuplicateObjectNameException type exposes the following members.

Constructors

Name | Description
DuplicateObjectNameException | Overloaded.

Methods

Name | Description
DetectCaseInsensitiveCollision<(Of <(T>)>) | Helper method to search through a dictionary for a matching key and detect whether the key only matches because the dictionary's comparison is case-insensitive. This should only be called when a matching key has already been detected in the dictionary and an exception is going to be thrown, because it's slower than just using ContainsKey to detect the collision.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | Sets the SerializationInfo object with the custom properties on this exception. (Overrides Exception..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ThrowIfCaseInsensitiveClash | Checks that matchedname is the same as the name of obj in a case-sensitive way. If it isn't, it throws DuplicateObjectNameException with an appropriate error message.
ThrowIfDuplicateName | Overloaded.
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
IsCaseInsensitiveCollision | Whether the duplicate was with a name that differed only by case.
Message | Gets a message that describes the current exception. (Inherited from Exception.)
ObjectName | The name of the object that already existed
ObjectType | The type of object involved in the collision (a human-readable string used in the exception message)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DuplicateObjectNameException Class
RedGate.SQLCompare.Engine Namespace


DuplicateObjectNameException Constructor

[image] [image]

SQL Data Compare API 12.0.40
DuplicateObjectNameException Constructor
DuplicateObjectNameException Class See Also

Overload List

Name | Description
DuplicateObjectNameException()()() | Constructs a DuplicateObjectNameException with no extra information.
DuplicateObjectNameException(SerializationInfo, StreamingContext) | Constructs a DuplicateObjectNameException during serialization.
DuplicateObjectNameException(String, Exception) | Constructs a DuplicateObjectNameException exception. This is only provided because it's required/expected for all exceptions - it doesn't populate the more specific properties of this exception. You should use DuplicateObjectNameException(String, Boolean, String, Exception) if you really need an inner exception.
DuplicateObjectNameException(String, Boolean, String) | Constructs a DuplicateObjectNameException with a default message based on the object properties provided.
DuplicateObjectNameException(String, Boolean, String, Exception) | Constructs a DuplicateObjectNameException witha default message and an inner exception
DuplicateObjectNameException(String, Boolean, String, String) | Constructs a DuplicateObjectNameException with a specific message. In almost all cases you should use one of the other constructors that provides the default message, rather than this one.

See Also

DuplicateObjectNameException Class
DuplicateObjectNameException Members
RedGate.SQLCompare.Engine Namespace


DuplicateObjectNameException Constructor

[image]

SQL Data Compare API 12.0.40
DuplicateObjectNameException Constructor
DuplicateObjectNameException Class See Also

Constructs a DuplicateObjectNameException with no extra information.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DuplicateObjectNameException()
Visual C++
public:
DuplicateObjectNameException()

See Also

DuplicateObjectNameException Class
DuplicateObjectNameException Overload
RedGate.SQLCompare.Engine Namespace


DuplicateObjectNameException Constructor (, )

[image]

SQL Data Compare API 12.0.40
DuplicateObjectNameException Constructor (, )
DuplicateObjectNameException Class See Also

Constructs a DuplicateObjectNameException during serialization.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected DuplicateObjectNameException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
DuplicateObjectNameException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: SerializationInfo
The SerializationInfo property bag
context
Type: StreamingContext
The serialization context

See Also

DuplicateObjectNameException Class
DuplicateObjectNameException Overload
RedGate.SQLCompare.Engine Namespace


DuplicateObjectNameException Constructor (, )

[image]

SQL Data Compare API 12.0.40
DuplicateObjectNameException Constructor (, )
DuplicateObjectNameException Class See Also

Constructs a DuplicateObjectNameException exception. This is only provided because it's required/expected for all exceptions - it doesn't populate the more specific properties of this exception. You should use DuplicateObjectNameException(String, Boolean, String, Exception) if you really need an inner exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
C#
public DuplicateObjectNameException(
    string message,
    Exception inner
)
Visual C++
public:
DuplicateObjectNameException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: String
The message for the exception.
inner
Type: Exception
The inner exception.

See Also

DuplicateObjectNameException Class
DuplicateObjectNameException Overload
RedGate.SQLCompare.Engine Namespace


DuplicateObjectNameException Constructor (, , )

[image]

SQL Data Compare API 12.0.40
DuplicateObjectNameException Constructor (, , )
DuplicateObjectNameException Class See Also

Constructs a DuplicateObjectNameException with a default message based on the object properties provided.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    objectName As String, _
    isCaseInsensitiveCollision As Boolean, _
    objectType As String _
)
C#
public DuplicateObjectNameException(
    string objectName,
    bool isCaseInsensitiveCollision,
    string objectType
)
Visual C++
public:
DuplicateObjectNameException(
    String^ objectName,
    bool isCaseInsensitiveCollision,
    String^ objectType
)

Parameters

objectName
Type: String
The object name that was duplicated
isCaseInsensitiveCollision
Type: Boolean
Did the duplication occur because a case-insensitive match existed
objectType
Type: String
The (human-readable) type of object that had a duplicate name

See Also

DuplicateObjectNameException Class
DuplicateObjectNameException Overload
RedGate.SQLCompare.Engine Namespace


DuplicateObjectNameException Constructor (, , , )

[image]

SQL Data Compare API 12.0.40
DuplicateObjectNameException Constructor (, , , )
DuplicateObjectNameException Class See Also

Constructs a DuplicateObjectNameException witha default message and an inner exception

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    objectName As String, _
    isCaseInsensitiveCollision As Boolean, _
    objectType As String, _
    inner As Exception _
)
C#
public DuplicateObjectNameException(
    string objectName,
    bool isCaseInsensitiveCollision,
    string objectType,
    Exception inner
)
Visual C++
public:
DuplicateObjectNameException(
    String^ objectName,
    bool isCaseInsensitiveCollision,
    String^ objectType,
    Exception^ inner
)

Parameters

objectName
Type: String
The object name that was duplicated
isCaseInsensitiveCollision
Type: Boolean
Did the duplication occur because a case-insensitive match existed
objectType
Type: String
The (human-readable) type of object that had a duplicate name
inner
Type: Exception
The exception that triggered this DuplicateObjectNameException

See Also

DuplicateObjectNameException Class
DuplicateObjectNameException Overload
RedGate.SQLCompare.Engine Namespace


DuplicateObjectNameException Constructor (, , , )

[image]

SQL Data Compare API 12.0.40
DuplicateObjectNameException Constructor (, , , )
DuplicateObjectNameException Class See Also

Constructs a DuplicateObjectNameException with a specific message. In almost all cases you should use one of the other constructors that provides the default message, rather than this one.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    objectName As String, _
    isCaseInsensitiveCollision As Boolean, _
    objectType As String, _
    message As String _
)
C#
public DuplicateObjectNameException(
    string objectName,
    bool isCaseInsensitiveCollision,
    string objectType,
    string message
)
Visual C++
public:
DuplicateObjectNameException(
    String^ objectName,
    bool isCaseInsensitiveCollision,
    String^ objectType,
    String^ message
)

Parameters

objectName
Type: String
The object name that was duplicated
isCaseInsensitiveCollision
Type: Boolean
Did the duplication occur because a case-insensitive match existed
objectType
Type: String
The (human-readable) type of object that had a duplicate name
message
Type: String
The exception message to display

See Also

DuplicateObjectNameException Class
DuplicateObjectNameException Overload
RedGate.SQLCompare.Engine Namespace


DuplicateObjectNameException Methods

[image] [image]

SQL Data Compare API 12.0.40
DuplicateObjectNameException Methods
DuplicateObjectNameException Class See Also

The DuplicateObjectNameException type exposes the following methods.

Methods

Name | Description
DetectCaseInsensitiveCollision<(Of <(T>)>) | Helper method to search through a dictionary for a matching key and detect whether the key only matches because the dictionary's comparison is case-insensitive. This should only be called when a matching key has already been detected in the dictionary and an exception is going to be thrown, because it's slower than just using ContainsKey to detect the collision.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | Sets the SerializationInfo object with the custom properties on this exception. (Overrides Exception..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ThrowIfCaseInsensitiveClash | Checks that matchedname is the same as the name of obj in a case-sensitive way. If it isn't, it throws DuplicateObjectNameException with an appropriate error message.
ThrowIfDuplicateName | Overloaded.
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DuplicateObjectNameException Class
RedGate.SQLCompare.Engine Namespace


DetectCaseInsensitiveCollision(T) Generic Method

[image]

SQL Data Compare API 12.0.40
DuplicateObjectNameException..::.DetectCaseInsensitiveCollision<(Of <(T>)>) Generic Method
DuplicateObjectNameException Class See Also

Helper method to search through a dictionary for a matching key and detect whether the key only matches because the dictionary's comparison is case-insensitive. This should only be called when a matching key has already been detected in the dictionary and an exception is going to be thrown, because it's slower than just using ContainsKey to detect the collision.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function DetectCaseInsensitiveCollision(Of T) ( _
    key As String, _
    existingObjects As Dictionary(Of String, T) _
) As Boolean
C#
protected static bool DetectCaseInsensitiveCollision<T>(
    string key,
    Dictionary<string, T> existingObjects
)
Visual C++
protected:
generic<typename T>
static bool DetectCaseInsensitiveCollision(
    String^ key,
    Dictionary<String^, T>^ existingObjects
)

Parameters

key
Type: String
The key that has already been matched by existingObjects default comparer
existingObjects
Type: Dictionary<(Of <(String, T>)>)

Type Parameters

T
The value type of existingObjects

Return Value

true if the existing key that matches key in existingObjects differs in case.

See Also

DuplicateObjectNameException Class
RedGate.SQLCompare.Engine Namespace


GetObjectData Method

[image]

SQL Data Compare API 12.0.40
DuplicateObjectNameException..::.GetObjectData Method
DuplicateObjectNameException Class See Also

Sets the SerializationInfo object with the custom properties on this exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: SerializationInfo
The object that holds the serialized object data.
context
Type: StreamingContext
The contextual information about the source or destination.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)

See Also

DuplicateObjectNameException Class
RedGate.SQLCompare.Engine Namespace


ThrowIfCaseInsensitiveClash Method

[image]

SQL Data Compare API 12.0.40
DuplicateObjectNameException..::.ThrowIfCaseInsensitiveClash Method
DuplicateObjectNameException Class See Also

Checks that matchedname is the same as the name of obj in a case-sensitive way. If it isn't, it throws DuplicateObjectNameException with an appropriate error message.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ThrowIfCaseInsensitiveClash ( _
    obj As IDatabaseObject, _
    matchedname As String _
)
C#
public static void ThrowIfCaseInsensitiveClash(
    IDatabaseObject obj,
    string matchedname
)
Visual C++
public:
static void ThrowIfCaseInsensitiveClash(
    IDatabaseObject^ obj,
    String^ matchedname
)

Parameters

obj
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The object found to match matchedname.
matchedname
Type: String
The object name that was searched for.

See Also

DuplicateObjectNameException Class
RedGate.SQLCompare.Engine Namespace


ThrowIfDuplicateName Method

[image] [image]

SQL Data Compare API 12.0.40
DuplicateObjectNameException..::.ThrowIfDuplicateName Method
DuplicateObjectNameException Class See Also

Overload List

Name | Description
ThrowIfDuplicateName<(Of <(T>)>)(String, Dictionary<(Of <(String, T>)>), ObjectType, String) | If key already exists in existingObjects (based on that dictionary's default Comparer), this will throw a DuplicateObjectNameException. This method will detect case-insensitive collision scenarios (where the existing object key differs from key only by case) and set the appropriate flag in the exception.
ThrowIfDuplicateName<(Of <(T>)>)(String, Dictionary<(Of <(String, T>)>), String, String) | If key already exists in existingObjects (based on that dictionary's default Comparer), this will throw a DuplicateObjectNameException. This method will detect case-insensitive collision scenarios (where the existing object key differs from key only by case) and set the appropriate flag in the exception.

See Also

DuplicateObjectNameException Class
DuplicateObjectNameException Members
RedGate.SQLCompare.Engine Namespace


ThrowIfDuplicateName(T) Generic Method (, (, T), , )

[image]

SQL Data Compare API 12.0.40
DuplicateObjectNameException..::.ThrowIfDuplicateName<(Of <(T>)>) Generic Method (, <(Of <(, T>)>), , )
DuplicateObjectNameException Class See Also

If key already exists in existingObjects (based on that dictionary's default Comparer), this will throw a DuplicateObjectNameException. This method will detect case-insensitive collision scenarios (where the existing object key differs from key only by case) and set the appropriate flag in the exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ThrowIfDuplicateName(Of T) ( _
    key As String, _
    existingObjects As Dictionary(Of String, T), _
    objectType As ObjectType, _
    objectNameForMessage As String _
)
C#
public static void ThrowIfDuplicateName<T>(
    string key,
    Dictionary<string, T> existingObjects,
    ObjectType objectType,
    string objectNameForMessage
)
Visual C++
public:
generic<typename T>
static void ThrowIfDuplicateName(
    String^ key,
    Dictionary<String^, T>^ existingObjects,
    ObjectType objectType,
    String^ objectNameForMessage
)

Parameters

key
Type: String
The key we're going to add to existingObjects
existingObjects
Type: Dictionary<(Of <(String, T>)>)
The dictionary of existing key/object pairs
objectType
Type: ObjectType
The ObjectType of the object being added
objectNameForMessage
Type: String
The string to use for the object's name in the exception message, if it's different to the key. If null (the default value), then key will be used.

Type Parameters

T
the value type of existingObjects

See Also

DuplicateObjectNameException Class
ThrowIfDuplicateName Overload
RedGate.SQLCompare.Engine Namespace


ThrowIfDuplicateName(T) Generic Method (, (, T), , )

[image]

SQL Data Compare API 12.0.40
DuplicateObjectNameException..::.ThrowIfDuplicateName<(Of <(T>)>) Generic Method (, <(Of <(, T>)>), , )
DuplicateObjectNameException Class See Also

If key already exists in existingObjects (based on that dictionary's default Comparer), this will throw a DuplicateObjectNameException. This method will detect case-insensitive collision scenarios (where the existing object key differs from key only by case) and set the appropriate flag in the exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ThrowIfDuplicateName(Of T) ( _
    key As String, _
    existingObjects As Dictionary(Of String, T), _
    objectType As String, _
    objectNameForMessage As String _
)
C#
public static void ThrowIfDuplicateName<T>(
    string key,
    Dictionary<string, T> existingObjects,
    string objectType,
    string objectNameForMessage
)
Visual C++
public:
generic<typename T>
static void ThrowIfDuplicateName(
    String^ key,
    Dictionary<String^, T>^ existingObjects,
    String^ objectType,
    String^ objectNameForMessage
)

Parameters

key
Type: String
The key we're going to add to existingObjects
existingObjects
Type: Dictionary<(Of <(String, T>)>)
The dictionary of existing key/object pairs
objectType
Type: String
The human-readable type name of the object being added
objectNameForMessage
Type: String
The string to use for the object's name in the exception message, if it's different to the key. If null (the default value), then key will be used.

Type Parameters

T
the value type of existingObjects

See Also

DuplicateObjectNameException Class
ThrowIfDuplicateName Overload
RedGate.SQLCompare.Engine Namespace


DuplicateObjectNameException Properties

[image] [image]

SQL Data Compare API 12.0.40
DuplicateObjectNameException Properties
DuplicateObjectNameException Class See Also

The DuplicateObjectNameException type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
IsCaseInsensitiveCollision | Whether the duplicate was with a name that differed only by case.
Message | Gets a message that describes the current exception. (Inherited from Exception.)
ObjectName | The name of the object that already existed
ObjectType | The type of object involved in the collision (a human-readable string used in the exception message)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DuplicateObjectNameException Class
RedGate.SQLCompare.Engine Namespace


IsCaseInsensitiveCollision Property

[image]

SQL Data Compare API 12.0.40
DuplicateObjectNameException..::.IsCaseInsensitiveCollision Property
DuplicateObjectNameException Class See Also

Whether the duplicate was with a name that differed only by case.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsCaseInsensitiveCollision As Boolean
C#
public bool IsCaseInsensitiveCollision { get; }
Visual C++
public:
property bool IsCaseInsensitiveCollision {
    bool get ();
}

See Also

DuplicateObjectNameException Class
RedGate.SQLCompare.Engine Namespace


ObjectName Property

[image]

SQL Data Compare API 12.0.40
DuplicateObjectNameException..::.ObjectName Property
DuplicateObjectNameException Class See Also

The name of the object that already existed

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ObjectName As String
C#
public string ObjectName { get; }
Visual C++
public:
property String^ ObjectName {
    String^ get ();
}

See Also

DuplicateObjectNameException Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
DuplicateObjectNameException..::.ObjectType Property
DuplicateObjectNameException Class See Also

The type of object involved in the collision (a human-readable string used in the exception message)

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ObjectType As String
C#
public string ObjectType { get; }
Visual C++
public:
property String^ ObjectType {
    String^ get ();
}

See Also

DuplicateObjectNameException Class
RedGate.SQLCompare.Engine Namespace


DurabilityTypes Enumeration

[image]

SQL Data Compare API 12.0.40
DurabilityTypes Enumeration
See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration DurabilityTypes
C#
public enum DurabilityTypes
Visual C++
public enum class DurabilityTypes

Members

Member name | Description
SchemaAndData |
SchemaOnly |

See Also

RedGate.SQLCompare.Engine Namespace


EngineDataCompareOptions Class

[image]

SQL Data Compare API 12.0.40
EngineDataCompareOptions Class
Members See Also

Class containing the three options enumerations for the three stages in data comparison.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class EngineDataCompareOptions _
    Implements ISerializable, ICloneable
C#
[SerializableAttribute]
public sealed class EngineDataCompareOptions : ISerializable,
    ICloneable
Visual C++
[SerializableAttribute]
public ref class EngineDataCompareOptions sealed : ISerializable,
    ICloneable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.EngineDataCompareOptions

See Also

EngineDataCompareOptions Members
RedGate.SQLCompare.Engine Namespace


EngineDataCompareOptions Members

[image] [image]

SQL Data Compare API 12.0.40
EngineDataCompareOptions Members
EngineDataCompareOptions Class Constructors Methods Fields Properties Explicit Interface Implementations See Also

The EngineDataCompareOptions type exposes the following members.

Constructors

Name | Description
EngineDataCompareOptions | Overloaded.

Methods

Name | Description
Clone |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAvailableComparisonOptions | Returns a list of available options for comparing databases.
GetAvailableMappingOptions | Returns a list of available options for mapping databases.
GetAvailableSqlOptions | Returns a list of available options for generating the synchronization SQL script.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | Gets serialization information with all of the data needed to recreate an instance of the EngineDataCompareOptions class.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsOptionSet |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ProductInfoDefaultValue | The current version of the SQL Data Compare Engine, to be inserted in the comment header of a deployment script

Properties

Name | Description
ComparisonOptions | Options that must be set before the databases are compared.
MappingOptions | Options that must be set before the databases are mapped.
ProductInfo |
SqlOptions | Options that must be set before the SQL script is generated.

Explicit Interface Implementations

Name | Description
ICloneableClone | Creates a shallow copy of the options.

See Also

EngineDataCompareOptions Class
RedGate.SQLCompare.Engine Namespace


EngineDataCompareOptions Constructor

[image] [image]

SQL Data Compare API 12.0.40
EngineDataCompareOptions Constructor
EngineDataCompareOptions Class See Also

Overload List

Name | Description
EngineDataCompareOptions()()() | Creates an options class and sets all of the options enumerations to default.
EngineDataCompareOptions(MappingOptions, ComparisonOptions, SqlOptions, String) | Creates an options class and sets all of the options enumerations to the parameters of the constructor.

See Also

EngineDataCompareOptions Class
EngineDataCompareOptions Members
RedGate.SQLCompare.Engine Namespace


EngineDataCompareOptions Constructor

[image]

SQL Data Compare API 12.0.40
EngineDataCompareOptions Constructor
EngineDataCompareOptions Class See Also

Creates an options class and sets all of the options enumerations to default.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public EngineDataCompareOptions()
Visual C++
public:
EngineDataCompareOptions()

See Also

EngineDataCompareOptions Class
EngineDataCompareOptions Overload
RedGate.SQLCompare.Engine Namespace


EngineDataCompareOptions Constructor (MappingOptions, ComparisonOptions, SqlOptions, )

[image]

SQL Data Compare API 12.0.40
EngineDataCompareOptions Constructor (MappingOptions, ComparisonOptions, SqlOptions, )
EngineDataCompareOptions Class See Also

Creates an options class and sets all of the options enumerations to the parameters of the constructor.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    mappingOptions As MappingOptions, _
    comparisonOptions As ComparisonOptions, _
    sqlOptions As SqlOptions, _
    productInfo As String _
)
C#
public EngineDataCompareOptions(
    MappingOptions mappingOptions,
    ComparisonOptions comparisonOptions,
    SqlOptions sqlOptions,
    string productInfo
)
Visual C++
public:
EngineDataCompareOptions(
    MappingOptions mappingOptions,
    ComparisonOptions comparisonOptions,
    SqlOptions sqlOptions,
    String^ productInfo
)

Parameters

mappingOptions
Type: RedGate.SQLCompare.Engine..::.MappingOptions
Options to use when mapping the databases.
comparisonOptions
Type: RedGate.SQLCompare.Engine..::.ComparisonOptions
Options to use when comparing the databases.
sqlOptions
Type: RedGate.SQLCompare.Engine..::.SqlOptions
Options to use when generating the synchronization SQL script.
productInfo
Type: String
A string describing the product such as "SQL Data Compare version 1.2.3"

See Also

EngineDataCompareOptions Class
EngineDataCompareOptions Overload
RedGate.SQLCompare.Engine Namespace


EngineDataCompareOptions Fields

[image] [image]

SQL Data Compare API 12.0.40
EngineDataCompareOptions Fields
EngineDataCompareOptions Class See Also

The EngineDataCompareOptions type exposes the following fields.

Fields

Name | Description
ProductInfoDefaultValue | The current version of the SQL Data Compare Engine, to be inserted in the comment header of a deployment script

See Also

EngineDataCompareOptions Class
RedGate.SQLCompare.Engine Namespace


ProductInfoDefaultValue Field

[image]

SQL Data Compare API 12.0.40
EngineDataCompareOptions..::.ProductInfoDefaultValue Field
EngineDataCompareOptions Class See Also

The current version of the SQL Data Compare Engine, to be inserted in the comment header of a deployment script

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ProductInfoDefaultValue As String
C#
public static readonly string ProductInfoDefaultValue
Visual C++
public:
static initonly String^ ProductInfoDefaultValue

See Also

EngineDataCompareOptions Class
RedGate.SQLCompare.Engine Namespace


EngineDataCompareOptions Methods

[image] [image]

SQL Data Compare API 12.0.40
EngineDataCompareOptions Methods
EngineDataCompareOptions Class See Also

The EngineDataCompareOptions type exposes the following methods.

Methods

Name | Description
Clone |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAvailableComparisonOptions | Returns a list of available options for comparing databases.
GetAvailableMappingOptions | Returns a list of available options for mapping databases.
GetAvailableSqlOptions | Returns a list of available options for generating the synchronization SQL script.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | Gets serialization information with all of the data needed to recreate an instance of the EngineDataCompareOptions class.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsOptionSet |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICloneableClone | Creates a shallow copy of the options.

See Also

EngineDataCompareOptions Class
RedGate.SQLCompare.Engine Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
EngineDataCompareOptions..::.Clone Method
EngineDataCompareOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone As EngineDataCompareOptions
C#
public EngineDataCompareOptions Clone()
Visual C++
public:
EngineDataCompareOptions^ Clone()

See Also

EngineDataCompareOptions Class
RedGate.SQLCompare.Engine Namespace


. Method

[image]

SQL Data Compare API 12.0.40
EngineDataCompareOptions..::...::. Method
EngineDataCompareOptions Class See Also

Creates a shallow copy of the options.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Private Function Clone As Object Implements ICloneable.Clone
C#
Object ICloneable.Clone()
Visual C++
private:
virtual Object^ Clone() sealed = ICloneable::Clone

Return Value

A shallow copy of the options.

Implements

ICloneableClone()()()

See Also

EngineDataCompareOptions Class
RedGate.SQLCompare.Engine Namespace


GetAvailableComparisonOptions Method

[image]

SQL Data Compare API 12.0.40
EngineDataCompareOptions..::.GetAvailableComparisonOptions Method
EngineDataCompareOptions Class See Also

Returns a list of available options for comparing databases.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetAvailableComparisonOptions As ComparisonOptions()
C#
public static ComparisonOptions[] GetAvailableComparisonOptions()
Visual C++
public:
static array<ComparisonOptions>^ GetAvailableComparisonOptions()

Return Value

A list of options.

See Also

EngineDataCompareOptions Class
RedGate.SQLCompare.Engine Namespace


GetAvailableMappingOptions Method

[image]

SQL Data Compare API 12.0.40
EngineDataCompareOptions..::.GetAvailableMappingOptions Method
EngineDataCompareOptions Class See Also

Returns a list of available options for mapping databases.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetAvailableMappingOptions As MappingOptions()
C#
public static MappingOptions[] GetAvailableMappingOptions()
Visual C++
public:
static array<MappingOptions>^ GetAvailableMappingOptions()

Return Value

A list of options.

See Also

EngineDataCompareOptions Class
RedGate.SQLCompare.Engine Namespace


GetAvailableSqlOptions Method

[image]

SQL Data Compare API 12.0.40
EngineDataCompareOptions..::.GetAvailableSqlOptions Method
EngineDataCompareOptions Class See Also

Returns a list of available options for generating the synchronization SQL script.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetAvailableSqlOptions As SqlOptions()
C#
public static SqlOptions[] GetAvailableSqlOptions()
Visual C++
public:
static array<SqlOptions>^ GetAvailableSqlOptions()

Return Value

A list of options.

See Also

EngineDataCompareOptions Class
RedGate.SQLCompare.Engine Namespace


GetObjectData Method

[image]

SQL Data Compare API 12.0.40
EngineDataCompareOptions..::.GetObjectData Method
EngineDataCompareOptions Class See Also

Gets serialization information with all of the data needed to recreate an instance of the EngineDataCompareOptions class.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: SerializationInfo
The object to be populated with serialization information.
context
Type: StreamingContext
The destination context of the serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)

See Also

EngineDataCompareOptions Class
RedGate.SQLCompare.Engine Namespace


IsOptionSet Method

[image]

SQL Data Compare API 12.0.40
EngineDataCompareOptions..::.IsOptionSet Method
EngineDataCompareOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Function IsOptionSet ( _
    option As ComparisonOptions _
) As Boolean
C#
public bool IsOptionSet(
    ComparisonOptions option
)
Visual C++
public:
bool IsOptionSet(
    ComparisonOptions option
)

Parameters

option
Type: RedGate.SQLCompare.Engine..::.ComparisonOptions
A single value from ComparisonOptions enum.

Return Value

See Also

EngineDataCompareOptions Class
RedGate.SQLCompare.Engine Namespace


EngineDataCompareOptions Properties

[image] [image]

SQL Data Compare API 12.0.40
EngineDataCompareOptions Properties
EngineDataCompareOptions Class See Also

The EngineDataCompareOptions type exposes the following properties.

Properties

Name | Description
ComparisonOptions | Options that must be set before the databases are compared.
MappingOptions | Options that must be set before the databases are mapped.
ProductInfo |
SqlOptions | Options that must be set before the SQL script is generated.

See Also

EngineDataCompareOptions Class
RedGate.SQLCompare.Engine Namespace


ComparisonOptions Property

[image]

SQL Data Compare API 12.0.40
EngineDataCompareOptions..::.ComparisonOptions Property
EngineDataCompareOptions Class See Also

Options that must be set before the databases are compared.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property ComparisonOptions As ComparisonOptions
C#
public ComparisonOptions ComparisonOptions { get; set; }
Visual C++
public:
property ComparisonOptions ComparisonOptions {
    ComparisonOptions get ();
    void set (ComparisonOptions value);
}

See Also

EngineDataCompareOptions Class
RedGate.SQLCompare.Engine Namespace


MappingOptions Property

[image]

SQL Data Compare API 12.0.40
EngineDataCompareOptions..::.MappingOptions Property
EngineDataCompareOptions Class See Also

Options that must be set before the databases are mapped.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property MappingOptions As MappingOptions
C#
public MappingOptions MappingOptions { get; set; }
Visual C++
public:
property MappingOptions MappingOptions {
    MappingOptions get ();
    void set (MappingOptions value);
}

See Also

EngineDataCompareOptions Class
RedGate.SQLCompare.Engine Namespace


ProductInfo Property

[image]

SQL Data Compare API 12.0.40
EngineDataCompareOptions..::.ProductInfo Property
EngineDataCompareOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property ProductInfo As String
C#
public string ProductInfo { get; set; }
Visual C++
public:
property String^ ProductInfo {
    String^ get ();
    void set (String^ value);
}

See Also

EngineDataCompareOptions Class
RedGate.SQLCompare.Engine Namespace


SqlOptions Property

[image]

SQL Data Compare API 12.0.40
EngineDataCompareOptions..::.SqlOptions Property
EngineDataCompareOptions Class See Also

Options that must be set before the SQL script is generated.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property SqlOptions As SqlOptions
C#
public SqlOptions SqlOptions { get; set; }
Visual C++
public:
property SqlOptions SqlOptions {
    SqlOptions get ();
    void set (SqlOptions value);
}

See Also

EngineDataCompareOptions Class
RedGate.SQLCompare.Engine Namespace


EqualityDifference Class

[image]

SQL Data Compare API 12.0.40
EqualityDifference Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class EqualityDifference _
    Implements IEquatable(Of EqualityDifference)
C#
public class EqualityDifference : IEquatable<EqualityDifference>
Visual C++
public ref class EqualityDifference : IEquatable<EqualityDifference^>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.EqualityDifference

See Also

EqualityDifference Members
RedGate.SQLCompare.Engine Namespace


EqualityDifference Members

[image] [image]

SQL Data Compare API 12.0.40
EqualityDifference Members
EqualityDifference Class Constructors Methods Properties See Also

The EqualityDifference type exposes the following members.

Constructors

Name | Description
EqualityDifference |

Methods

Name | Description
AddContext |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDifferenceAsTree | Get a nicely-formatted description for differences
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OutputDifferenceAsTree | Print a nicely-formatted description of differences to output
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
Name |
SourceValue |
TargetValue |

See Also

EqualityDifference Class
RedGate.SQLCompare.Engine Namespace


EqualityDifference Constructor

[image]

SQL Data Compare API 12.0.40
EqualityDifference Constructor
EqualityDifference Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    value1 As Object, _
    value2 As Object _
)
C#
public EqualityDifference(
    string name,
    Object value1,
    Object value2
)
Visual C++
public:
EqualityDifference(
    String^ name,
    Object^ value1,
    Object^ value2
)

Parameters

name
Type: String
value1
Type: Object
value2
Type: Object

See Also

EqualityDifference Class
RedGate.SQLCompare.Engine Namespace


EqualityDifference Methods

[image] [image]

SQL Data Compare API 12.0.40
EqualityDifference Methods
EqualityDifference Class See Also

The EqualityDifference type exposes the following methods.

Methods

Name | Description
AddContext |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDifferenceAsTree | Get a nicely-formatted description for differences
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OutputDifferenceAsTree | Print a nicely-formatted description of differences to output
ToString | (Overrides Object..::.ToString()()().)

See Also

EqualityDifference Class
RedGate.SQLCompare.Engine Namespace


AddContext Method

[image]

SQL Data Compare API 12.0.40
EqualityDifference..::.AddContext Method
EqualityDifference Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function AddContext ( _
    name As String, _
    value As String _
) As EqualityDifference
C#
public EqualityDifference AddContext(
    string name,
    string value
)
Visual C++
public:
EqualityDifference^ AddContext(
    String^ name,
    String^ value
)

Parameters

name
Type: String
value
Type: String

See Also

EqualityDifference Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
EqualityDifference..::.Equals Method
EqualityDifference Class See Also

Overload List

Name | Description
Equals(Object) | (Overrides Object..::.Equals(Object).)
Equals(EqualityDifference) |

See Also

EqualityDifference Class
EqualityDifference Members
RedGate.SQLCompare.Engine Namespace


Equals Method ()

[image]

SQL Data Compare API 12.0.40
EqualityDifference..::.Equals Method ()
EqualityDifference Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object

See Also

EqualityDifference Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


Equals Method (EqualityDifference)

[image]

SQL Data Compare API 12.0.40
EqualityDifference..::.Equals Method (EqualityDifference)
EqualityDifference Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    other As EqualityDifference _
) As Boolean
C#
public bool Equals(
    EqualityDifference other
)
Visual C++
public:
virtual bool Equals(
    EqualityDifference^ other
) sealed

Parameters

other
Type: RedGate.SQLCompare.Engine..::.EqualityDifference

Implements

IEquatableEquals(UTP)

See Also

EqualityDifference Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


GetDifferenceAsTree Method

[image]

SQL Data Compare API 12.0.40
EqualityDifference..::.GetDifferenceAsTree Method
EqualityDifference Class See Also

Get a nicely-formatted description for differences

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDifferenceAsTree ( _
    differences As IEnumerable(Of EqualityDifference) _
) As String
C#
public static string GetDifferenceAsTree(
    IEnumerable<EqualityDifference> differences
)
Visual C++
public:
static String^ GetDifferenceAsTree(
    IEnumerable<EqualityDifference^>^ differences
)

Parameters

differences
Type: IEnumerable<(Of <( EqualityDifference >)>)

See Also

EqualityDifference Class
RedGate.SQLCompare.Engine Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
EqualityDifference..::.GetHashCode Method
EqualityDifference Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

See Also

EqualityDifference Class
RedGate.SQLCompare.Engine Namespace


OutputDifferenceAsTree Method

[image]

SQL Data Compare API 12.0.40
EqualityDifference..::.OutputDifferenceAsTree Method
EqualityDifference Class See Also

Print a nicely-formatted description of differences to output

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub OutputDifferenceAsTree ( _
    output As TextWriter, _
    differences As IEnumerable(Of EqualityDifference) _
)
C#
public static void OutputDifferenceAsTree(
    TextWriter output,
    IEnumerable<EqualityDifference> differences
)
Visual C++
public:
static void OutputDifferenceAsTree(
    TextWriter^ output,
    IEnumerable<EqualityDifference^>^ differences
)

Parameters

output
Type: TextWriter
differences
Type: IEnumerable<(Of <( EqualityDifference >)>)

See Also

EqualityDifference Class
RedGate.SQLCompare.Engine Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
EqualityDifference..::.ToString Method
EqualityDifference Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

See Also

EqualityDifference Class
RedGate.SQLCompare.Engine Namespace


EqualityDifference Properties

[image] [image]

SQL Data Compare API 12.0.40
EqualityDifference Properties
EqualityDifference Class See Also

The EqualityDifference type exposes the following properties.

Properties

Name | Description
Name |
SourceValue |
TargetValue |

See Also

EqualityDifference Class
RedGate.SQLCompare.Engine Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
EqualityDifference..::.Name Property
EqualityDifference Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; private set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

EqualityDifference Class
RedGate.SQLCompare.Engine Namespace


SourceValue Property

[image]

SQL Data Compare API 12.0.40
EqualityDifference..::.SourceValue Property
EqualityDifference Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SourceValue As Object
C#
public Object SourceValue { get; private set; }
Visual C++
public:
property Object^ SourceValue {
    Object^ get ();
    void set (Object^ value);
}

See Also

EqualityDifference Class
RedGate.SQLCompare.Engine Namespace


TargetValue Property

[image]

SQL Data Compare API 12.0.40
EqualityDifference..::.TargetValue Property
EqualityDifference Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TargetValue As Object
C#
public Object TargetValue { get; private set; }
Visual C++
public:
property Object^ TargetValue {
    Object^ get ();
    void set (Object^ value);
}

See Also

EqualityDifference Class
RedGate.SQLCompare.Engine Namespace


EqualityDifference.Context Class

[image]

SQL Data Compare API 12.0.40
EqualityDifference..::.Context Class
EqualityDifference Class Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class Context
C#
public class Context
Visual C++
public ref class Context

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.EqualityDifference..::.Context

See Also

EqualityDifference..::.Context Members
RedGate.SQLCompare.Engine Namespace


EqualityDifference.Context Members

[image] [image]

SQL Data Compare API 12.0.40
EqualityDifference..::.Context Members
EqualityDifference..::.Context Class Constructors Methods Properties See Also

The EqualityDifference..::.Context type exposes the following members.

Constructors

Name | Description
EqualityDifference..::.Context |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Name |
Value |

See Also

EqualityDifference..::.Context Class
RedGate.SQLCompare.Engine Namespace


EqualityDifference.Context Constructor

[image]

SQL Data Compare API 12.0.40
EqualityDifference..::.Context Constructor
EqualityDifference..::.Context Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Context()
Visual C++
public:
Context()

See Also

EqualityDifference..::.Context Class
RedGate.SQLCompare.Engine Namespace


EqualityDifference.Context Properties

[image] [image]

SQL Data Compare API 12.0.40
EqualityDifference..::.Context Properties
EqualityDifference..::.Context Class See Also

The EqualityDifference..::.Context type exposes the following properties.

Properties

Name | Description
Name |
Value |

See Also

EqualityDifference..::.Context Class
RedGate.SQLCompare.Engine Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
EqualityDifference..::.Context..::.Name Property
EqualityDifference..::.Context Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

EqualityDifference..::.Context Class
RedGate.SQLCompare.Engine Namespace


Value Property

[image]

SQL Data Compare API 12.0.40
EqualityDifference..::.Context..::.Value Property
EqualityDifference..::.Context Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As String
C#
public string Value { get; set; }
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

EqualityDifference..::.Context Class
RedGate.SQLCompare.Engine Namespace


EqualityDifferenceFactory Class

[image]

SQL Data Compare API 12.0.40
EqualityDifferenceFactory Class
See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class EqualityDifferenceFactory
C#
public static class EqualityDifferenceFactory
Visual C++
public ref class EqualityDifferenceFactory abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.EqualityDifferenceFactory

See Also

RedGate.SQLCompare.Engine Namespace


EventNotification Class

[image]

SQL Data Compare API 12.0.40
EventNotification Class
Members See Also

An event notification.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class EventNotification _
    Inherits ScriptableDatabaseObject _
    Implements IPatchUpAfterDeserialization, ISqlComparable
C#
public sealed class EventNotification : ScriptableDatabaseObject, IPatchUpAfterDeserialization,
    ISqlComparable
Visual C++
public ref class EventNotification sealed : public ScriptableDatabaseObject,
    IPatchUpAfterDeserialization, ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.EventNotification

See Also

EventNotification Members
RedGate.SQLCompare.Engine Namespace


EventNotification Members

[image] [image]

SQL Data Compare API 12.0.40
EventNotification Members
EventNotification Class Methods Fields Properties Explicit Interface Implementations See Also

The EventNotification type exposes the following members.

Methods

Name | Description
CompareWith | Compares this object with another and gives a list of differences
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
BrokerInstance | The broker instance.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
EventTypes | The event types.
ExtendedProperties | The extended properties defined for the event notification.
FanIn | True if the event notification has the fan in option enabled.
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Assembly (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)
ServiceName | The name of the service.

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

EventNotification Class
RedGate.SQLCompare.Engine Namespace


EventNotification Methods

[image] [image]

SQL Data Compare API 12.0.40
EventNotification Methods
EventNotification Class See Also

The EventNotification type exposes the following methods.

Methods

Name | Description
CompareWith | Compares this object with another and gives a list of differences
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

EventNotification Class
RedGate.SQLCompare.Engine Namespace


CompareWith Method

[image]

SQL Data Compare API 12.0.40
EventNotification..::.CompareWith Method
EventNotification Class See Also

Compares this object with another and gives a list of differences

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareWith ( _
    target As EventNotification, _
    options As Options _
) As IEnumerable(Of EqualityDifference)
C#
public IEnumerable<EqualityDifference> CompareWith(
    EventNotification target,
    Options options
)
Visual C++
public:
IEnumerable<EqualityDifference^>^ CompareWith(
    EventNotification^ target,
    Options options
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.EventNotification
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

EventNotification Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
EventNotification..::.ISqlComparable..::.CompareWith Method
EventNotification Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    obj As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable obj,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ obj,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

obj
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

EventNotification Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
EventNotification..::.Equals Method
EventNotification Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the event notification with a specified event notification. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

EventNotification Class
EventNotification Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
EventNotification..::.Equals Method (IDatabaseObject, Options)
EventNotification Class See Also

Compares the event notification with a specified event notification.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The event notification to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the event notifications are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

EventNotification Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
EventNotification..::.PatchUpAfterDeserialization Method
EventNotification Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

EventNotification Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
EventNotification..::.ScriptObject Method
EventNotification Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

EventNotification Class
RedGate.SQLCompare.Engine Namespace


EventNotification Properties

[image] [image]

SQL Data Compare API 12.0.40
EventNotification Properties
EventNotification Class See Also

The EventNotification type exposes the following properties.

Properties

Name | Description
BrokerInstance | The broker instance.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
EventTypes | The event types.
ExtendedProperties | The extended properties defined for the event notification.
FanIn | True if the event notification has the fan in option enabled.
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Assembly (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)
ServiceName | The name of the service.

See Also

EventNotification Class
RedGate.SQLCompare.Engine Namespace


BrokerInstance Property

[image]

SQL Data Compare API 12.0.40
EventNotification..::.BrokerInstance Property
EventNotification Class See Also

The broker instance.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BrokerInstance As String
C#
public string BrokerInstance { get; internal set; }
Visual C++
public:
property String^ BrokerInstance {
    String^ get ();
    void set (String^ value);
}

See Also

EventNotification Class
RedGate.SQLCompare.Engine Namespace


EventTypes Property

[image]

SQL Data Compare API 12.0.40
EventNotification..::.EventTypes Property
EventNotification Class See Also

The event types.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EventTypes As EventTypes
C#
public EventTypes EventTypes { get; }
Visual C++
public:
property EventTypes^ EventTypes {
    EventTypes^ get ();
}

See Also

EventNotification Class
RedGate.SQLCompare.Engine Namespace


ExtendedProperties Property

[image]

SQL Data Compare API 12.0.40
EventNotification..::.ExtendedProperties Property
EventNotification Class See Also

The extended properties defined for the event notification.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedProperties
C#
public ExtendedProperties ExtendedProperties { get; }
Visual C++
public:
property ExtendedProperties^ ExtendedProperties {
    ExtendedProperties^ get ();
}

See Also

EventNotification Class
RedGate.SQLCompare.Engine Namespace


FanIn Property

[image]

SQL Data Compare API 12.0.40
EventNotification..::.FanIn Property
EventNotification Class See Also

True if the event notification has the fan in option enabled.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FanIn As Boolean
C#
public bool FanIn { get; internal set; }
Visual C++
public:
property bool FanIn {
    bool get ();
    void set (bool value);
}

See Also

EventNotification Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
EventNotification..::.ObjectType Property
EventNotification Class See Also

Returns ObjectType.Assembly

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()

See Also

EventNotification Class
RedGate.SQLCompare.Engine Namespace


ServiceName Property

[image]

SQL Data Compare API 12.0.40
EventNotification..::.ServiceName Property
EventNotification Class See Also

The name of the service.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ServiceName As String
C#
public string ServiceName { get; internal set; }
Visual C++
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}

See Also

EventNotification Class
RedGate.SQLCompare.Engine Namespace


EventNotifications Class

[image]

SQL Data Compare API 12.0.40
EventNotifications Class
Members See Also

A collection of event notifications.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class EventNotifications _
    Inherits SerializableDatabaseObjectCollection(Of EventNotification) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class EventNotifications : SerializableDatabaseObjectCollection<EventNotification>, IPatchUpAfterDeserialization
Visual C++
public ref class EventNotifications sealed : public SerializableDatabaseObjectCollection<EventNotification^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( EventNotification >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( EventNotification >)>)
RedGate.SQLCompare.Engine..::.EventNotifications

See Also

EventNotifications Members
RedGate.SQLCompare.Engine Namespace


EventNotifications Members

[image] [image]

SQL Data Compare API 12.0.40
EventNotifications Members
EventNotifications Class Methods Fields Properties Explicit Interface Implementations See Also

The EventNotifications type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

EventNotifications Class
RedGate.SQLCompare.Engine Namespace


EventNotifications Methods

[image] [image]

SQL Data Compare API 12.0.40
EventNotifications Methods
EventNotifications Class See Also

The EventNotifications type exposes the following methods.

Methods

Name | Description
Add | Overloaded.
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

EventNotifications Class
RedGate.SQLCompare.Engine Namespace


Add Method

[image] [image]

SQL Data Compare API 12.0.40
EventNotifications..::.Add Method
EventNotifications Class See Also

Overload List

Name | Description
Add(T) | (Inherited from KeyedCollection<(Of <(T>)>).)
Add(EventNotification) | (Overrides SerializableDatabaseObjectCollection <(Of <( EventNotification >)>)..::. Add(T).)

See Also

EventNotifications Class
EventNotifications Members
RedGate.SQLCompare.Engine Namespace


Add Method (EventNotification)

[image]

SQL Data Compare API 12.0.40
EventNotifications..::.Add Method (EventNotification)
EventNotifications Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Add ( _
    value As EventNotification _
)
C#
public override void Add(
    EventNotification value
)
Visual C++
public:
virtual void Add(
    EventNotification^ value
) override

Parameters

value
Type: RedGate.SQLCompare.Engine..::.EventNotification

See Also

EventNotifications Class
Add Overload
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
EventNotifications..::.Equals Method
EventNotifications Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(EventNotifications, Options) | Compares the event notification collection with a specified event notification collection.

See Also

EventNotifications Class
EventNotifications Members
RedGate.SQLCompare.Engine Namespace


Equals Method (EventNotifications, Options)

[image]

SQL Data Compare API 12.0.40
EventNotifications..::.Equals Method (EventNotifications, Options)
EventNotifications Class See Also

Compares the event notification collection with a specified event notification collection.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    target As EventNotifications, _
    options As Options _
) As Boolean
C#
public bool Equals(
    EventNotifications target,
    Options options
)
Visual C++
public:
bool Equals(
    EventNotifications^ target,
    Options options
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.EventNotifications
The object to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the event notification collections are identical; otherwise, false.

See Also

EventNotifications Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
EventNotifications..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
EventNotifications Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

EventNotifications Class
RedGate.SQLCompare.Engine Namespace


EventNotificationsChanges Class

[image]

SQL Data Compare API 12.0.40
EventNotificationsChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class EventNotificationsChanges
C#
public sealed class EventNotificationsChanges
Visual C++
public ref class EventNotificationsChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.EventNotificationsChanges

See Also

EventNotificationsChanges Members
RedGate.SQLCompare.Engine Namespace


EventNotificationsChanges Members

[image] [image]

SQL Data Compare API 12.0.40
EventNotificationsChanges Members
EventNotificationsChanges Class Constructors Methods Properties See Also

The EventNotificationsChanges type exposes the following members.

Constructors

Name | Description
EventNotificationsChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
EventNotificationsToCreate |
EventNotificationsToDrop |

See Also

EventNotificationsChanges Class
RedGate.SQLCompare.Engine Namespace


EventNotificationsChanges Constructor

[image]

SQL Data Compare API 12.0.40
EventNotificationsChanges Constructor
EventNotificationsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public EventNotificationsChanges(
    bool caseSensitive
)
Visual C++
public:
EventNotificationsChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

EventNotificationsChanges Class
RedGate.SQLCompare.Engine Namespace


EventNotificationsChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
EventNotificationsChanges Properties
EventNotificationsChanges Class See Also

The EventNotificationsChanges type exposes the following properties.

Properties

Name | Description
EventNotificationsToCreate |
EventNotificationsToDrop |

See Also

EventNotificationsChanges Class
RedGate.SQLCompare.Engine Namespace


EventNotificationsToCreate Property

[image]

SQL Data Compare API 12.0.40
EventNotificationsChanges..::.EventNotificationsToCreate Property
EventNotificationsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property EventNotificationsToCreate As EventNotifications
C#
public EventNotifications EventNotificationsToCreate { get; private set; }
Visual C++
public:
property EventNotifications^ EventNotificationsToCreate {
    EventNotifications^ get ();
    void set (EventNotifications^ value);
}

See Also

EventNotificationsChanges Class
RedGate.SQLCompare.Engine Namespace


EventNotificationsToDrop Property

[image]

SQL Data Compare API 12.0.40
EventNotificationsChanges..::.EventNotificationsToDrop Property
EventNotificationsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property EventNotificationsToDrop As EventNotifications
C#
public EventNotifications EventNotificationsToDrop { get; private set; }
Visual C++
public:
property EventNotifications^ EventNotificationsToDrop {
    EventNotifications^ get ();
    void set (EventNotifications^ value);
}

See Also

EventNotificationsChanges Class
RedGate.SQLCompare.Engine Namespace


EventType Enumeration

[image]

SQL Data Compare API 12.0.40
EventType Enumeration
See Also

The type of event.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration EventType
C#
public enum EventType
Visual C++
public enum class EventType

Members

Member name | Description
Unknown | Unknown
Insert | INSERT
Update | UPDATE
Delete | DELETE
CreateTable | CREATE_TABLE
AlterTable | ALTER_TABLE
DropTable | DROP_TABLE
CreateIndex | CREATE_INDEX
AlterIndex | ALTER_INDEX
DropIndex | DROP_INDEX
CreateStatistics | CREATE_STATISTICS
UpdateStatistics | UPDATE_STATISTICS
DropStatistics | DROP_STATISTICS
CreateSynonym | CREATE_SYNONYM
DropSynonym | DROP_SYNONYM
CreateView | CREATE_VIEW
AlterView | ALTER_VIEW
DropView | DROP_VIEW
CreateProcedure | CREATE_PROCEDURE
AlterProcedure | ALTER_PROCEDURE
DropProcedure | DROP_PROCEDURE
CreateFunction | CREATE_FUNCTION
AlterFunction | ALTER_FUNCTION
DropFunction | DROP_FUNCTION
CreateTrigger | CREATE_TRIGGER
AlterTrigger | ALTER_TRIGGER
DropTrigger | DROP_TRIGGER
CreateEventNotification | CREATE_EVENT_NOTIFICATION
DropEventNotification | DROP_EVENT_NOTIFICATION
CreateType | CREATE_TYPE
DropType | DROP_TYPE
CreateAssembly | CREATE_ASSEMBLY
AlterAssembly | ALTER_ASSEMBLY
DropAssembly | DROP_ASSEMBLY
CreateUser | CREATE_USER
AlterUser | ALTER_USER
DropUser | DROP_USER
CreateRole | CREATE_ROLE
AlterRole | ALTER_ROLE
DropRole | DROP_ROLE
CreateApplicationRole | CREATE_APPLICATION_ROLE
AlterApplicationRole | ALTER_APPLICATION_ROLE
DropApplicationRole | DROP_APPLICATION_ROLE
CreateSchema | CREATE_SCHEMA
AlterSchema | ALTER_SCHEMA
DropSchema | DROP_SCHEMA
CreateLogin | CREATE_LOGIN
AlterLogin | ALTER_LOGIN
DropLogin | DROP_LOGIN
CreateMessageType | CREATE_MESSAGE_TYPE
AlterMessageType | ALTER_MESSAGE_TYPE
DropMessageType | DROP_MESSAGE_TYPE
CreateContract | CREATE_CONTRACT
DropContract | DROP_CONTRACT
CreateQueue | CREATE_QUEUE
AlterQueue | ALTER_QUEUE
DropQueue | DROP_QUEUE
BrokerQueueDisabled | BROKER_QUEUE_DISABLED
CreateService | CREATE_SERVICE
AlterService | ALTER_SERVICE
DropService | DROP_SERVICE
CreateRoute | CREATE_ROUTE
AlterRoute | ALTER_ROUTE
DropRoute | DROP_ROUTE
GrantServer | GRANT_SERVER
DenyServer | DENY_SERVER
RevokeServer | REVOKE_SERVER
GrantDatabase | GRANT_DATABASE
DenyDatabase | DENY_DATABASE
RevokeDatabase | REVOKE_DATABASE
QueueActivation | QUEUE_ACTIVATION
CreateRemoteServiceBinding | CREATE_REMOTE_SERVICE_BINDING
AlterRemoteServiceBinding | ALTER_REMOTE_SERVICE_BINDING
DropRemoteServiceBinding | DROP_REMOTE_SERVICE_BINDING
CreateXmlSchemaCollection | CREATE_XML_SCHEMA_COLLECTION
AlterXmlSchemaCollection | ALTER_XML_SCHEMA_COLLECTION
DropXmlSchemaCollection | DROP_XML_SCHEMA_COLLECTION
CreateEndpoint | CREATE_ENDPOINT
AlterEndpoint | ALTER_ENDPOINT
DropEndpoint | DROP_ENDPOINT
CreatePartitionFunction | CREATE_PARTITION_FUNCTION
AlterPartitionFunction | ALTER_PARTITION_FUNCTION
DropPartitionFunction | DROP_PARTITION_FUNCTION
CreatePartitionScheme | CREATE_PARTITION_SCHEME
AlterPartitionScheme | ALTER_PARTITION_SCHEME
DropPartitionScheme | DROP_PARTITION_SCHEME
CreateCertificate | CREATE_CERTIFICATE
AlterCertificate | ALTER_CERTIFICATE
DropCertificate | DROP_CERTIFICATE
CreateDatabase | CREATE_DATABASE
AlterDatabase | ALTER_DATABASE
DropDatabase | DROP_DATABASE
AlterAuthorizationServer | ALTER_AUTHORIZATION_SERVER
AlterAuthorizationDatabase | ALTER_AUTHORIZATION_DATABASE
CreateXmlIndex | CREATE_XML_INDEX
AddRoleMember | ADD_ROLE_MEMBER
DropRoleMember | DROP_ROLE_MEMBER
AddServerRoleMember | ADD_SERVER_ROLE_MEMBER
DropServerRoleMember | DROP_SERVER_ROLE_MEMBER
AlterExtendedProperty | ALTER_EXTENDED_PROPERTY
AlterFulltextCatalog | ALTER_FULLTEXT_CATALOG
AlterFulltextIndex | ALTER_FULLTEXT_INDEX
AlterInstance | ALTER_INSTANCE
AlterMessage | ALTER_MESSAGE
AlterPlanGuide | ALTER_PLAN_GUIDE
AlterRemoteServer | ALTER_REMOTE_SERVER
BindDefault | BIND_DEFAULT
BindRule | BIND_RULE
CreateDefault | CREATE_DEFAULT
CreateExtendedProcedure | CREATE_EXTENDED_PROCEDURE
CreateExtendedProperty | CREATE_EXTENDED_PROPERTY
CreateFulltextCatalog | CREATE_FULLTEXT_CATALOG
CreateFulltextIndex | CREATE_FULLTEXT_INDEX
CreateLinkedServer | CREATE_LINKED_SERVER
CreateLinkedServerLogin | CREATE_LINKED_SERVER_LOGIN
CreateMessage | CREATE_MESSAGE
CreatePlanGuide | CREATE_PLAN_GUIDE
CreateRule | CREATE_RULE
CreateRemoteServer | CREATE_REMOTE_SERVER
DropDefault | DROP_DEFAULT
DropExtendedProcedure | DROP_EXTENDED_PROCEDURE
DropExtendedProperty | DROP_EXTENDED_PROPERTY
DropFulltextCatalog | DROP_FULLTEXT_CATALOG
DropFulltextIndex | DROP_FULLTEXT_INDEX
DropLinkedServerLogin | DROP_LINKED_SERVER_LOGIN
DropMessage | DROP_MESSAGE
DropPlanGuide | DROP_PLAN_GUIDE
DropRule | DROP_RULE
DropRemoteServer | DROP_REMOTE_SERVER
Rename | RENAME
UnbindDefault | UNBIND_DEFAULT
UnbindRule | UNBIND_RULE
CreateSymmetricKey | CREATE_SYMMETRIC_KEY
AlterSymmetricKey | ALTER_SYMMETRIC_KEY
DropSymmetricKey | DROP_SYMMETRIC_KEY
CreateAsymmetricKey | CREATE_ASYMMETRIC_KEY
AlterAsymmetricKey | ALTER_ASYMMETRIC_KEY
DropAsymmetricKey | DROP_ASYMMETRIC_KEY
AlterServiceMasterKey | ALTER_SERVICE_MASTER_KEY
CreateMasterKey | CREATE_MASTER_KEY
AlterMasterKey | ALTER_MASTER_KEY
DropMasterKey | DROP_MASTER_KEY
AddSignatureSchemaObject | ADD_SIGNATURE_SCHEMA_OBJECT
DropSignatureSchemaObject | DROP_SIGNATURE_SCHEMA_OBJECT
AddSignature | ADD_SIGNATURE
DropSignature | DROP_SIGNATURE
CreateCredential | CREATE_CREDENTIAL
AlterCredential | ALTER_CREDENTIAL
DropCredential | DROP_CREDENTIAL
DropLinkedServer | DROP_LINKED_SERVER
AlterLinkedServer | ALTER_LINKED_SERVER
CreateEventSession | CREATE_EVENT_SESSION
AlterEventSession | ALTER_EVENT_SESSION
DropEventSession | DROP_EVENT_SESSION
CreateResourcePool | CREATE_RESOURCE_POOL
AlterResourcePool | ALTER_RESOURCE_POOL
DropResourcePool | DROP_RESOURCE_POOL
CreateWorkloadGroup | CREATE_WORKLOAD_GROUP
AlterWorkloadGroup | ALTER_WORKLOAD_GROUP
DropWorkloadGroup | DROP_WORKLOAD_GROUP
AlterResourceGovernorConfig | ALTER_RESOURCE_GOVERNOR_CONFIG
CreateSpatialIndex | CREATE_SPATIAL_INDEX
CreateCryptographicProvider | CREATE_CRYPTOGRAPHIC_PROVIDER
AlterCryptographicProvider | ALTER_CRYPTOGRAPHIC_PROVIDER
DropCryptographicProvider | DROP_CRYPTOGRAPHIC_PROVIDER
CreateDatabaseEncryptionKey | CREATE_DATABASE_ENCRYPTION_KEY
AlterDatabaseEncryptionKey | ALTER_DATABASE_ENCRYPTION_KEY
DropDatabaseEncryptionKey | DROP_DATABASE_ENCRYPTION_KEY
CreateBrokerPriority | CREATE_BROKER_PRIORITY
AlterBrokerPriority | ALTER_BROKER_PRIORITY
DropBrokerPriority | DROP_BROKER_PRIORITY
CreateServerAudit | CREATE_SERVER_AUDIT
AlterServerAudit | ALTER_SERVER_AUDIT
DropServerAudit | DROP_SERVER_AUDIT
CreateServerAuditSpecification | CREATE_SERVER_AUDIT_SPECIFICATION
AlterServerAuditSpecification | ALTER_SERVER_AUDIT_SPECIFICATION
DropServerAuditSpecification | DROP_SERVER_AUDIT_SPECIFICATION
CreateDatabaseAuditSpecification | CREATE_DATABASE_AUDIT_SPECIFICATION
AlterDatabaseAuditSpecification | ALTER_DATABASE_AUDIT_SPECIFICATION
DropDatabaseAuditSpecification | DROP_DATABASE_AUDIT_SPECIFICATION
CreateFulltextStoplist | CREATE_FULLTEXT_STOPLIST
AlterFulltextStoplist | ALTER_FULLTEXT_STOPLIST
DropFulltextStoplist | DROP_FULLTEXT_STOPLIST
AlterServerConfiguration | ALTER_SERVER_CONFIGURATION
CreateSearchPropertyList | CREATE_SEARCH_PROPERTY_LIST
AlterSearchPropertyList | ALTER_SEARCH_PROPERTY_LIST
DropSearchPropertyList | DROP_SEARCH_PROPERTY_LIST
CreateServerRole | CREATE_SERVER_ROLE
AlterServerRole | ALTER_SERVER_ROLE
DropServerRole | DROP_SERVER_ROLE
CreateSequence | CREATE_SEQUENCE
AlterSequence | ALTER_SEQUENCE
DropSequence | DROP_SEQUENCE
CreateAvailabilityGroup | CREATE_AVAILABILITY_GROUP
AlterAvailabilityGroup | ALTER_AVAILABILITY_GROUP
DropAvailabilityGroup | DROP_AVAILABILITY_GROUP
CreateAudit | CREATE_AUDIT
DropAudit | DROP_AUDIT
AlterAudit | ALTER_AUDIT
CreateSecurityPolicy | CREATE_SECURITY_POLICY
AlterSecurityPolicy | ALTER_SECURITY_POLICY
DropSecurityPolicy | DROP_SECURITY_POLICY
CreateColumnMasterKey | CREATE_COLUMN_MASTER_KEY
DropColumnMasterKey | DROP_COLUMN_MASTER_KEY
CreateColumnEncryptionKey | CREATE_COLUMN_ENCRYPTION_KEY
AlterColumnEncryptionKey | ALTER_COLUMN_ENCRYPTION_KEY
DropColumnEncryptionKey | DROP_COLUMN_ENCRYPTION_KEY
AlterDatabaseScopedConfiguration | ALTER_DATABASE_SCOPED_CONFIGURATION
CreateExternalResourcePool | CREATE_EXTERNAL_RESOURCE_POOL
AlterExternalResourcePool | ALTER_EXTERNAL_RESOURCE_POOL
DropExternalResourcePool | DROP_EXTERNAL_RESOURCE_POOL
CreateExternalLibrary | CREATE_EXTERNAL_LIBRARY
AlterExternalLibrary | ALTER_EXTERNAL_LIBRARY
DropExternalLibrary | DROP_EXTERNAL_LIBRARY
AuditLogin | AUDIT_LOGIN
AuditLogout | AUDIT_LOGOUT
AuditLoginFailed | AUDIT_LOGIN_FAILED
Eventlog | EVENTLOG
Errorlog | ERRORLOG
LockDeadlock | LOCK_DEADLOCK
Exception | EXCEPTION
SpCachemiss | SP_CACHEMISS
SpCacheinsert | SP_CACHEINSERT
SpCacheremove | SP_CACHEREMOVE
SpRecompile | SP_RECOMPILE
ObjectCreated | OBJECT_CREATED
ObjectDeleted | OBJECT_DELETED
HashWarning | HASH_WARNING
LockDeadlockChain | LOCK_DEADLOCK_CHAIN
LockEscalation | LOCK_ESCALATION
OledbErrors | OLEDB_ERRORS
ExecutionWarnings | EXECUTION_WARNINGS
SortWarnings | SORT_WARNINGS
MissingColumnStatistics | MISSING_COLUMN_STATISTICS
MissingJoinPredicate | MISSING_JOIN_PREDICATE
ServerMemoryChange | SERVER_MEMORY_CHANGE
Userconfigurable0 | USERCONFIGURABLE_0
Userconfigurable1 | USERCONFIGURABLE_1
Userconfigurable2 | USERCONFIGURABLE_2
Userconfigurable3 | USERCONFIGURABLE_3
Userconfigurable4 | USERCONFIGURABLE_4
Userconfigurable5 | USERCONFIGURABLE_5
Userconfigurable6 | USERCONFIGURABLE_6
Userconfigurable7 | USERCONFIGURABLE_7
Userconfigurable8 | USERCONFIGURABLE_8
Userconfigurable9 | USERCONFIGURABLE_9
DataFileAutoGrow | DATA_FILE_AUTO_GROW
LogFileAutoGrow | LOG_FILE_AUTO_GROW
DataFileAutoShrink | DATA_FILE_AUTO_SHRINK
LogFileAutoShrink | LOG_FILE_AUTO_SHRINK
AuditDatabaseScopeGdrEvent | AUDIT_DATABASE_SCOPE_GDR_EVENT
AuditSchemaObjectGdrEvent | AUDIT_SCHEMA_OBJECT_GDR_EVENT
AuditAddloginEvent | AUDIT_ADDLOGIN_EVENT
AuditLoginGdrEvent | AUDIT_LOGIN_GDR_EVENT
AuditLoginChangePropertyEvent | AUDIT_LOGIN_CHANGE_PROPERTY_EVENT
AuditLoginChangePasswordEvent | AUDIT_LOGIN_CHANGE_PASSWORD_EVENT
AuditAddLoginToServerRoleEvent | AUDIT_ADD_LOGIN_TO_SERVER_ROLE_EVENT
AuditAddDbUserEvent | AUDIT_ADD_DB_USER_EVENT
AuditAddMemberToDbRoleEvent | AUDIT_ADD_MEMBER_TO_DB_ROLE_EVENT
AuditAddRoleEvent | AUDIT_ADD_ROLE_EVENT
AuditAppRoleChangePasswordEvent | AUDIT_APP_ROLE_CHANGE_PASSWORD_EVENT
AuditSchemaObjectAccessEvent | AUDIT_SCHEMA_OBJECT_ACCESS_EVENT
AuditBackupRestoreEvent | AUDIT_BACKUP_RESTORE_EVENT
AuditDbccEvent | AUDIT_DBCC_EVENT
AuditChangeAuditEvent | AUDIT_CHANGE_AUDIT_EVENT
OledbCallEvent | OLEDB_CALL_EVENT
OledbQueryinterfaceEvent | OLEDB_QUERYINTERFACE_EVENT
OledbDatareadEvent | OLEDB_DATAREAD_EVENT
ShowplanXml | SHOWPLAN_XML
DeprecationAnnouncement | DEPRECATION_ANNOUNCEMENT
DeprecationFinalSupport | DEPRECATION_FINAL_SUPPORT
ExchangeSpillEvent | EXCHANGE_SPILL_EVENT
AuditDatabaseManagementEvent | AUDIT_DATABASE_MANAGEMENT_EVENT
AuditDatabaseObjectManagementEvent | AUDIT_DATABASE_OBJECT_MANAGEMENT_EVENT
AuditDatabasePrincipalManagementEvent | AUDIT_DATABASE_PRINCIPAL_MANAGEMENT_EVENT
AuditSchemaObjectManagementEvent | AUDIT_SCHEMA_OBJECT_MANAGEMENT_EVENT
AuditServerPrincipalImpersonationEvent | AUDIT_SERVER_PRINCIPAL_IMPERSONATION_EVENT
AuditDatabasePrincipalImpersonationEvent | AUDIT_DATABASE_PRINCIPAL_IMPERSONATION_EVENT
AuditServerObjectTakeOwnershipEvent | AUDIT_SERVER_OBJECT_TAKE_OWNERSHIP_EVENT
AuditDatabaseObjectTakeOwnershipEvent | AUDIT_DATABASE_OBJECT_TAKE_OWNERSHIP_EVENT
BlockedProcessReport | BLOCKED_PROCESS_REPORT
ShowplanXmlStatisticsProfile | SHOWPLAN_XML_STATISTICS_PROFILE
DeadlockGraph | DEADLOCK_GRAPH
TraceFileClose | TRACE_FILE_CLOSE
AuditChangeDatabaseOwner | AUDIT_CHANGE_DATABASE_OWNER
AuditSchemaObjectTakeOwnershipEvent | AUDIT_SCHEMA_OBJECT_TAKE_OWNERSHIP_EVENT
FtCrawlStarted | FT_CRAWL_STARTED
FtCrawlStopped | FT_CRAWL_STOPPED
FtCrawlAborted | FT_CRAWL_ABORTED
UserErrorMessage | USER_ERROR_MESSAGE
ObjectAltered | OBJECT_ALTERED
SqlStmtrecompile | SQL_STMTRECOMPILE
DatabaseMirroringStateChange | DATABASE_MIRRORING_STATE_CHANGE
ShowplanXmlForQueryCompile | SHOWPLAN_XML_FOR_QUERY_COMPILE
ShowplanAllForQueryCompile | SHOWPLAN_ALL_FOR_QUERY_COMPILE
AuditServerScopeGdrEvent | AUDIT_SERVER_SCOPE_GDR_EVENT
AuditServerObjectGdrEvent | AUDIT_SERVER_OBJECT_GDR_EVENT
AuditDatabaseObjectGdrEvent | AUDIT_DATABASE_OBJECT_GDR_EVENT
AuditServerOperationEvent | AUDIT_SERVER_OPERATION_EVENT
AuditServerAlterTraceEvent | AUDIT_SERVER_ALTER_TRACE_EVENT
AuditServerObjectManagementEvent | AUDIT_SERVER_OBJECT_MANAGEMENT_EVENT
AuditServerPrincipalManagementEvent | AUDIT_SERVER_PRINCIPAL_MANAGEMENT_EVENT
AuditDatabaseOperationEvent | AUDIT_DATABASE_OPERATION_EVENT
AuditDatabaseObjectAccessEvent | AUDIT_DATABASE_OBJECT_ACCESS_EVENT
OledbProviderInformation | OLEDB_PROVIDER_INFORMATION
MountTape | MOUNT_TAPE
AssemblyLoad | ASSEMBLY_LOAD
XqueryStaticType | XQUERY_STATIC_TYPE
QnSubscription | QN__SUBSCRIPTION
QnParameterTable | QN__PARAMETER_TABLE
QnTemplate | QN__TEMPLATE
QnDynamics | QN__DYNAMICS
BitmapWarning | BITMAP_WARNING
DatabaseSuspectDataPage | DATABASE_SUSPECT_DATA_PAGE
CpuThresholdExceeded | CPU_THRESHOLD_EXCEEDED
AuditFulltext | AUDIT_FULLTEXT
DdlEvents | DDL_EVENTS
DdlServerLevelEvents | DDL_SERVER_LEVEL_EVENTS
DdlEndpointEvents | DDL_ENDPOINT_EVENTS
DdlDatabaseEvents | DDL_DATABASE_EVENTS
DdlServerSecurityEvents | DDL_SERVER_SECURITY_EVENTS
DdlLoginEvents | DDL_LOGIN_EVENTS
DdlGdrServerEvents | DDL_GDR_SERVER_EVENTS
DdlAuthorizationServerEvents | DDL_AUTHORIZATION_SERVER_EVENTS
DdlCredentialEvents | DDL_CREDENTIAL_EVENTS
DdlServiceMasterKeyEvents | DDL_SERVICE_MASTER_KEY_EVENTS
DdlExtendedProcedureEvents | DDL_EXTENDED_PROCEDURE_EVENTS
DdlLinkedServerEvents | DDL_LINKED_SERVER_EVENTS
DdlLinkedServerLoginEvents | DDL_LINKED_SERVER_LOGIN_EVENTS
DdlMessageEvents | DDL_MESSAGE_EVENTS
DdlRemoteServerEvents | DDL_REMOTE_SERVER_EVENTS
DdlDatabaseLevelEvents | DDL_DATABASE_LEVEL_EVENTS
DdlTableViewEvents | DDL_TABLE_VIEW_EVENTS
DdlTableEvents | DDL_TABLE_EVENTS
DdlViewEvents | DDL_VIEW_EVENTS
DdlIndexEvents | DDL_INDEX_EVENTS
DdlStatisticsEvents | DDL_STATISTICS_EVENTS
DdlSynonymEvents | DDL_SYNONYM_EVENTS
DdlFunctionEvents | DDL_FUNCTION_EVENTS
DdlProcedureEvents | DDL_PROCEDURE_EVENTS
DdlTriggerEvents | DDL_TRIGGER_EVENTS
DdlEventNotificationEvents | DDL_EVENT_NOTIFICATION_EVENTS
DdlAssemblyEvents | DDL_ASSEMBLY_EVENTS
DdlTypeEvents | DDL_TYPE_EVENTS
DdlDatabaseSecurityEvents | DDL_DATABASE_SECURITY_EVENTS
DdlCertificateEvents | DDL_CERTIFICATE_EVENTS
DdlUserEvents | DDL_USER_EVENTS
DdlRoleEvents | DDL_ROLE_EVENTS
DdlApplicationRoleEvents | DDL_APPLICATION_ROLE_EVENTS
DdlSchemaEvents | DDL_SCHEMA_EVENTS
DdlGdrDatabaseEvents | DDL_GDR_DATABASE_EVENTS
DdlAuthorizationDatabaseEvents | DDL_AUTHORIZATION_DATABASE_EVENTS
DdlSymmetricKeyEvents | DDL_SYMMETRIC_KEY_EVENTS
DdlAsymmetricKeyEvents | DDL_ASYMMETRIC_KEY_EVENTS
DdlCryptoSignatureEvents | DDL_CRYPTO_SIGNATURE_EVENTS
DdlMasterKeyEvents | DDL_MASTER_KEY_EVENTS
DdlSsbEvents | DDL_SSB_EVENTS
DdlMessageTypeEvents | DDL_MESSAGE_TYPE_EVENTS
DdlContractEvents | DDL_CONTRACT_EVENTS
DdlQueueEvents | DDL_QUEUE_EVENTS
DdlServiceEvents | DDL_SERVICE_EVENTS
DdlRouteEvents | DDL_ROUTE_EVENTS
DdlRemoteServiceBindingEvents | DDL_REMOTE_SERVICE_BINDING_EVENTS
DdlXmlSchemaCollectionEvents | DDL_XML_SCHEMA_COLLECTION_EVENTS
DdlPartitionEvents | DDL_PARTITION_EVENTS
DdlPartitionFunctionEvents | DDL_PARTITION_FUNCTION_EVENTS
DdlPartitionSchemeEvents | DDL_PARTITION_SCHEME_EVENTS
DdlDefaultEvents | DDL_DEFAULT_EVENTS
DdlExtendedPropertyEvents | DDL_EXTENDED_PROPERTY_EVENTS
DdlFulltextCatalogEvents | DDL_FULLTEXT_CATALOG_EVENTS
DdlPlanGuideEvents | DDL_PLAN_GUIDE_EVENTS
DdlRuleEvents | DDL_RULE_EVENTS
DdlEventSessionEvents | DDL_EVENT_SESSION_EVENTS
DdlResourceGovernorEvents | DDL_RESOURCE_GOVERNOR_EVENTS
DdlResourcePool | DDL_RESOURCE_POOL
DdlWorkloadGroup | DDL_WORKLOAD_GROUP
DdlCryptographicProviderEvents | DDL_CRYPTOGRAPHIC_PROVIDER_EVENTS
DdlDatabaseEncryptionKeyEvents | DDL_DATABASE_ENCRYPTION_KEY_EVENTS
DdlBrokerPriorityEvents | DDL_BROKER_PRIORITY_EVENTS
DdlServerAuditEvents | DDL_SERVER_AUDIT_EVENTS
DdlServerAuditSpecificationEvents | DDL_SERVER_AUDIT_SPECIFICATION_EVENTS
DdlDatabaseAuditSpecificationEvents | DDL_DATABASE_AUDIT_SPECIFICATION_EVENTS
DdlFulltextStoplistEvents | DDL_FULLTEXT_STOPLIST_EVENTS
DdlSearchPropertyListEvents | DDL_SEARCH_PROPERTY_LIST_EVENTS
DdlSequenceEvents | DDL_SEQUENCE_EVENTS
DdlAvailabilityGroupEvents | DDL_AVAILABILITY_GROUP_EVENTS
DdlDatabaseAuditEvents | DDL_DATABASE_AUDIT_EVENTS
DdlSecurityPolicyEvents | DDL_SECURITY_POLICY_EVENTS
DdlColumnMasterKeyEvents | DDL_COLUMN_MASTER_KEY_EVENTS
DdlColumnEncryptionKeyEvents | DDL_COLUMN_ENCRYPTION_KEY_EVENTS
DdlExternalResourcePoolEvents | DDL_EXTERNAL_RESOURCE_POOL_EVENTS
DdlLibraryEvents | DDL_LIBRARY_EVENTS
TrcAllEvents | TRC_ALL_EVENTS
TrcDatabase | TRC_DATABASE
TrcErrorsAndWarnings | TRC_ERRORS_AND_WARNINGS
TrcLocks | TRC_LOCKS
TrcObjects | TRC_OBJECTS
TrcPerformance | TRC_PERFORMANCE
TrcSecurityAudit | TRC_SECURITY_AUDIT
TrcServer | TRC_SERVER
TrcStoredProcedures | TRC_STORED_PROCEDURES
TrcTsql | TRC_TSQL
TrcUserConfigurable | TRC_USER_CONFIGURABLE
TrcOledb | TRC_OLEDB
TrcFullText | TRC_FULL_TEXT
TrcDeprecation | TRC_DEPRECATION
TrcClr | TRC_CLR
TrcQueryNotifications | TRC_QUERY_NOTIFICATIONS

See Also

RedGate.SQLCompare.Engine Namespace


EventTypes Class

[image]

SQL Data Compare API 12.0.40
EventTypes Class
Members See Also

A collection of EventTypes.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class EventTypes _
    Inherits SerializableCollection(Of EventType)
C#
public sealed class EventTypes : SerializableCollection<EventType>
Visual C++
public ref class EventTypes sealed : public SerializableCollection<EventType>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( EventType >)>)
RedGate.SQLCompare.Engine..::.EventTypes

See Also

EventTypes Members
RedGate.SQLCompare.Engine Namespace


EventTypes Members

[image] [image]

SQL Data Compare API 12.0.40
EventTypes Members
EventTypes Class Methods Fields Properties Explicit Interface Implementations See Also

The EventTypes type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

EventTypes Class
RedGate.SQLCompare.Engine Namespace


ExecuteAs Enumeration

[image]

SQL Data Compare API 12.0.40
ExecuteAs Enumeration
See Also

The EXECUTE AS clause used to create the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration ExecuteAs
C#
public enum ExecuteAs
Visual C++
public enum class ExecuteAs

Members

Member name | Description
Caller | The object is set to EXECUTE AS CALLER.
Owner | The object is set to EXECUTE AS OWNER.
Dbo | The object is set to EXECUTE AS 'dbo'.
Guest | The object is set to EXECUTE AS 'guest'.
User | The object is set to EXECUTE AS a specified user.

See Also

RedGate.SQLCompare.Engine Namespace


ExtendedProperties Class

[image]

SQL Data Compare API 12.0.40
ExtendedProperties Class
Members See Also

The extended properties associated with a database object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ExtendedProperties _
    Inherits SerializableDatabaseObjectCollection(Of ExtendedProperty) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class ExtendedProperties : SerializableDatabaseObjectCollection<ExtendedProperty>, IPatchUpAfterDeserialization
Visual C++
public ref class ExtendedProperties sealed : public SerializableDatabaseObjectCollection<ExtendedProperty^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( ExtendedProperty >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( ExtendedProperty >)>)
RedGate.SQLCompare.Engine..::.ExtendedProperties

See Also

ExtendedProperties Members
RedGate.SQLCompare.Engine Namespace


ExtendedProperties Members

[image] [image]

SQL Data Compare API 12.0.40
ExtendedProperties Members
ExtendedProperties Class Methods Fields Properties Explicit Interface Implementations See Also

The ExtendedProperties type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

ExtendedProperties Class
RedGate.SQLCompare.Engine Namespace


ExtendedProperties Methods

[image] [image]

SQL Data Compare API 12.0.40
ExtendedProperties Methods
ExtendedProperties Class See Also

The ExtendedProperties type exposes the following methods.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

ExtendedProperties Class
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
ExtendedProperties..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
ExtendedProperties Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

ExtendedProperties Class
RedGate.SQLCompare.Engine Namespace


ExtendedProperties Properties

[image] [image]

SQL Data Compare API 12.0.40
ExtendedProperties Properties
ExtendedProperties Class See Also

The ExtendedProperties type exposes the following properties.

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

See Also

ExtendedProperties Class
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
ExtendedProperties..::.Item Property
ExtendedProperties Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(ExtendedProperty])]) | Returns an extended property.
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
Item[([(String, String, String, String, String, String, String])]) | Returns an extended property given information about its types and names.

See Also

ExtendedProperties Class
ExtendedProperties Members
RedGate.SQLCompare.Engine Namespace


Item Property (ExtendedProperty)

[image]

SQL Data Compare API 12.0.40
ExtendedProperties..::.Item Property (ExtendedProperty)
ExtendedProperties Class See Also

Returns an extended property.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    value As ExtendedProperty _
) As ExtendedProperty
C#
public ExtendedProperty this[
    ExtendedProperty value
] { get; }
Visual C++
public:
property ExtendedProperty^ default[ExtendedProperty^ value] {
    ExtendedProperty^ get (ExtendedProperty^ value);
}

Parameters

value
Type: RedGate.SQLCompare.Engine..::.ExtendedProperty
The value of the extended property to get.

See Also

ExtendedProperties Class
Item Overload
RedGate.SQLCompare.Engine Namespace


Item Property (, , , , , , )

[image]

SQL Data Compare API 12.0.40
ExtendedProperties..::.Item Property (, , , , , , )
ExtendedProperties Class See Also

Returns an extended property given information about its types and names.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    level0Type As String, _
    level0Name As String, _
    level1Type As String, _
    level1Name As String, _
    level2Type As String, _
    level2Name As String, _
    name As String _
) As ExtendedProperty
C#
public ExtendedProperty this[
    string level0Type,
    string level0Name,
    string level1Type,
    string level1Name,
    string level2Type,
    string level2Name,
    string name
] { get; }
Visual C++
public:
property ExtendedProperty^ default[String^ level0Type, String^ level0Name, String^ level1Type, String^ level1Name, String^ level2Type, String^ level2Name, String^ name] {
    ExtendedProperty^ get (String^ level0Type, String^ level0Name, String^ level1Type, String^ level1Name, String^ level2Type, String^ level2Name, String^ name);
}

Parameters

level0Type
Type: String
The type of the level0 object for which the extended property is specified.
level0Name
Type: String
The name of the level0 object for which the extended property is specified.
level1Type
Type: String
The type of the level1 object for which the extended property is specified.
level1Name
Type: String
The name of the level1 object for which the extended property is specified.
level2Type
Type: String
The type of the level2 object for which the extended property is specified.
level2Name
Type: String
The name of the level2 object for which the extended property is specified.
name
Type: String
The name of the extended property.

See Also

ExtendedProperties Class
Item Overload
RedGate.SQLCompare.Engine Namespace


ExtendedPropertiesChanges Class

[image]

SQL Data Compare API 12.0.40
ExtendedPropertiesChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ExtendedPropertiesChanges
C#
public sealed class ExtendedPropertiesChanges
Visual C++
public ref class ExtendedPropertiesChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ExtendedPropertiesChanges

See Also

ExtendedPropertiesChanges Members
RedGate.SQLCompare.Engine Namespace


ExtendedPropertiesChanges Members

[image] [image]

SQL Data Compare API 12.0.40
ExtendedPropertiesChanges Members
ExtendedPropertiesChanges Class Constructors Methods Properties See Also

The ExtendedPropertiesChanges type exposes the following members.

Constructors

Name | Description
ExtendedPropertiesChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ExtPropTargets |
PropertiesToAlter |
PropertiesToCreate |
PropertiesToDrop |

See Also

ExtendedPropertiesChanges Class
RedGate.SQLCompare.Engine Namespace


ExtendedPropertiesChanges Constructor

[image]

SQL Data Compare API 12.0.40
ExtendedPropertiesChanges Constructor
ExtendedPropertiesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public ExtendedPropertiesChanges(
    bool caseSensitive
)
Visual C++
public:
ExtendedPropertiesChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

ExtendedPropertiesChanges Class
RedGate.SQLCompare.Engine Namespace


ExtendedPropertiesChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
ExtendedPropertiesChanges Properties
ExtendedPropertiesChanges Class See Also

The ExtendedPropertiesChanges type exposes the following properties.

Properties

Name | Description
ExtPropTargets |
PropertiesToAlter |
PropertiesToCreate |
PropertiesToDrop |

See Also

ExtendedPropertiesChanges Class
RedGate.SQLCompare.Engine Namespace


ExtPropTargets Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertiesChanges..::.ExtPropTargets Property
ExtendedPropertiesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtPropTargets As Dictionary(Of ExtendedProperty, Pair(Of ExtendedProperty, ScriptableDatabaseObject))
C#
public Dictionary<ExtendedProperty, Pair<ExtendedProperty, ScriptableDatabaseObject>> ExtPropTargets { get; private set; }
Visual C++
public:
property Dictionary<ExtendedProperty^, Pair<ExtendedProperty^, ScriptableDatabaseObject^>>^ ExtPropTargets {
    Dictionary<ExtendedProperty^, Pair<ExtendedProperty^, ScriptableDatabaseObject^>>^ get ();
    void set (Dictionary<ExtendedProperty^, Pair<ExtendedProperty^, ScriptableDatabaseObject^>>^ value);
}

See Also

ExtendedPropertiesChanges Class
RedGate.SQLCompare.Engine Namespace


PropertiesToAlter Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertiesChanges..::.PropertiesToAlter Property
ExtendedPropertiesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PropertiesToAlter As ExtendedProperties
C#
public ExtendedProperties PropertiesToAlter { get; private set; }
Visual C++
public:
property ExtendedProperties^ PropertiesToAlter {
    ExtendedProperties^ get ();
    void set (ExtendedProperties^ value);
}

See Also

ExtendedPropertiesChanges Class
RedGate.SQLCompare.Engine Namespace


PropertiesToCreate Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertiesChanges..::.PropertiesToCreate Property
ExtendedPropertiesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PropertiesToCreate As ExtendedProperties
C#
public ExtendedProperties PropertiesToCreate { get; private set; }
Visual C++
public:
property ExtendedProperties^ PropertiesToCreate {
    ExtendedProperties^ get ();
    void set (ExtendedProperties^ value);
}

See Also

ExtendedPropertiesChanges Class
RedGate.SQLCompare.Engine Namespace


PropertiesToDrop Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertiesChanges..::.PropertiesToDrop Property
ExtendedPropertiesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PropertiesToDrop As ExtendedProperties
C#
public ExtendedProperties PropertiesToDrop { get; private set; }
Visual C++
public:
property ExtendedProperties^ PropertiesToDrop {
    ExtendedProperties^ get ();
    void set (ExtendedProperties^ value);
}

See Also

ExtendedPropertiesChanges Class
RedGate.SQLCompare.Engine Namespace


ExtendedProperty Class

[image]

SQL Data Compare API 12.0.40
ExtendedProperty Class
Members See Also

An extended property.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ExtendedProperty _
    Inherits ScriptableDatabaseObject _
    Implements IPatchUpAfterDeserialization, ISqlComparable
C#
public sealed class ExtendedProperty : ScriptableDatabaseObject, IPatchUpAfterDeserialization,
    ISqlComparable
Visual C++
public ref class ExtendedProperty sealed : public ScriptableDatabaseObject,
    IPatchUpAfterDeserialization, ISqlComparable

Remarks

See sp_addextendedproperty in SQL Server Books Online for more information.

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.ExtendedProperty

See Also

ExtendedProperty Members
RedGate.SQLCompare.Engine Namespace


ExtendedProperty Members

[image] [image]

SQL Data Compare API 12.0.40
ExtendedProperty Members
ExtendedProperty Class Methods Fields Properties Explicit Interface Implementations See Also

The ExtendedProperty type exposes the following members.

Methods

Name | Description
CompareWith |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | A string representation of the extended property. (Overrides Object..::.ToString()()().)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
FullyQualifiedName | (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
Level0Name | The Level0 name of the extended property.
Level0Type | The Level0 type of the extended property.
Level1Name | The Level1 name of the extended property.
Level1Type | The Level1 type of the extended property.
Level2Name | The Level2 name of the extended property.
Level2Type | The Level2 type of the extended property.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | (Overrides ScriptableDatabaseObject ..::. Owner.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)
Value |
VariableAssignScriptSource |
VariableDeclareScriptSource | The script sources for the variable assigned to this extended property

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

ExtendedProperty Class
RedGate.SQLCompare.Engine Namespace


ExtendedProperty Methods

[image] [image]

SQL Data Compare API 12.0.40
ExtendedProperty Methods
ExtendedProperty Class See Also

The ExtendedProperty type exposes the following methods.

Methods

Name | Description
CompareWith |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | A string representation of the extended property. (Overrides Object..::.ToString()()().)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

ExtendedProperty Class
RedGate.SQLCompare.Engine Namespace


CompareWith Method

[image]

SQL Data Compare API 12.0.40
ExtendedProperty..::.CompareWith Method
ExtendedProperty Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareWith ( _
    target As ExtendedProperty, _
    options As Options _
) As IEnumerable(Of EqualityDifference)
C#
public IEnumerable<EqualityDifference> CompareWith(
    ExtendedProperty target,
    Options options
)
Visual C++
public:
IEnumerable<EqualityDifference^>^ CompareWith(
    ExtendedProperty^ target,
    Options options
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.ExtendedProperty
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

ExtendedProperty Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
ExtendedProperty..::.ISqlComparable..::.CompareWith Method
ExtendedProperty Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    obj As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable obj,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ obj,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

obj
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

ExtendedProperty Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
ExtendedProperty..::.Equals Method
ExtendedProperty Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

ExtendedProperty Class
ExtendedProperty Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
ExtendedProperty..::.Equals Method (IDatabaseObject, Options)
ExtendedProperty Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) override

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

ExtendedProperty Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
ExtendedProperty..::.PatchUpAfterDeserialization Method
ExtendedProperty Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

ExtendedProperty Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
ExtendedProperty..::.ScriptObject Method
ExtendedProperty Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
options
Type: RedGate.SQLCompare.Engine..::.Options
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

See Also

ExtendedProperty Class
RedGate.SQLCompare.Engine Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
ExtendedProperty..::.ToString Method
ExtendedProperty Class See Also

A string representation of the extended property.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

Return Value

A string.

See Also

ExtendedProperty Class
RedGate.SQLCompare.Engine Namespace


ExtendedProperty Properties

[image] [image]

SQL Data Compare API 12.0.40
ExtendedProperty Properties
ExtendedProperty Class See Also

The ExtendedProperty type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
FullyQualifiedName | (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
Level0Name | The Level0 name of the extended property.
Level0Type | The Level0 type of the extended property.
Level1Name | The Level1 name of the extended property.
Level1Type | The Level1 type of the extended property.
Level2Name | The Level2 name of the extended property.
Level2Type | The Level2 type of the extended property.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | (Overrides ScriptableDatabaseObject ..::. Owner.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)
Value |
VariableAssignScriptSource |
VariableDeclareScriptSource | The script sources for the variable assigned to this extended property

See Also

ExtendedProperty Class
RedGate.SQLCompare.Engine Namespace


FullyQualifiedName Property

[image]

SQL Data Compare API 12.0.40
ExtendedProperty..::.FullyQualifiedName Property
ExtendedProperty Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FullyQualifiedName As String
C#
public override string FullyQualifiedName { get; }
Visual C++
public:
virtual property String^ FullyQualifiedName {
    String^ get () override;
}

Implements

ITSqlObjectFullyQualifiedName()()()

See Also

ExtendedProperty Class
RedGate.SQLCompare.Engine Namespace


Level0Name Property

[image]

SQL Data Compare API 12.0.40
ExtendedProperty..::.Level0Name Property
ExtendedProperty Class See Also

The Level0 name of the extended property.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Level0Name As String
C#
public string Level0Name { get; internal set; }
Visual C++
public:
property String^ Level0Name {
    String^ get ();
    void set (String^ value);
}

Remarks

See SQL Server Books Online for more information.

See Also

ExtendedProperty Class
RedGate.SQLCompare.Engine Namespace


Level0Type Property

[image]

SQL Data Compare API 12.0.40
ExtendedProperty..::.Level0Type Property
ExtendedProperty Class See Also

The Level0 type of the extended property.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Level0Type As String
C#
public string Level0Type { get; internal set; }
Visual C++
public:
property String^ Level0Type {
    String^ get ();
    void set (String^ value);
}

Remarks

See SQL Server Books Online for more information.

See Also

ExtendedProperty Class
RedGate.SQLCompare.Engine Namespace


Level1Name Property

[image]

SQL Data Compare API 12.0.40
ExtendedProperty..::.Level1Name Property
ExtendedProperty Class See Also

The Level1 name of the extended property.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Level1Name As String
C#
public string Level1Name { get; internal set; }
Visual C++
public:
property String^ Level1Name {
    String^ get ();
    void set (String^ value);
}

Remarks

See SQL Server Books Online for more information.

See Also

ExtendedProperty Class
RedGate.SQLCompare.Engine Namespace


Level1Type Property

[image]

SQL Data Compare API 12.0.40
ExtendedProperty..::.Level1Type Property
ExtendedProperty Class See Also

The Level1 type of the extended property.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Level1Type As String
C#
public string Level1Type { get; internal set; }
Visual C++
public:
property String^ Level1Type {
    String^ get ();
    void set (String^ value);
}

Remarks

See SQL Server Books Online for more information.

See Also

ExtendedProperty Class
RedGate.SQLCompare.Engine Namespace


Level2Name Property

[image]

SQL Data Compare API 12.0.40
ExtendedProperty..::.Level2Name Property
ExtendedProperty Class See Also

The Level2 name of the extended property.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Level2Name As String
C#
public string Level2Name { get; internal set; }
Visual C++
public:
property String^ Level2Name {
    String^ get ();
    void set (String^ value);
}

Remarks

See SQL Server Books Online for more information.

See Also

ExtendedProperty Class
RedGate.SQLCompare.Engine Namespace


Level2Type Property

[image]

SQL Data Compare API 12.0.40
ExtendedProperty..::.Level2Type Property
ExtendedProperty Class See Also

The Level2 type of the extended property.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Level2Type As String
C#
public string Level2Type { get; internal set; }
Visual C++
public:
property String^ Level2Type {
    String^ get ();
    void set (String^ value);
}

Remarks

See SQL Server Books Online for more information.

See Also

ExtendedProperty Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
ExtendedProperty..::.ObjectType Property
ExtendedProperty Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()

See Also

ExtendedProperty Class
RedGate.SQLCompare.Engine Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
ExtendedProperty..::.Owner Property
ExtendedProperty Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property Owner As String
C#
public override string Owner { get; internal set; }
Visual C++
public:
virtual property String^ Owner {
    String^ get () override;
    void set (String^ value) override;
}

Implements

ITSqlObjectOwner()()()

See Also

ExtendedProperty Class
RedGate.SQLCompare.Engine Namespace


Value Property

[image]

SQL Data Compare API 12.0.40
ExtendedProperty..::.Value Property
ExtendedProperty Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As ExtendedPropertyValue
C#
public ExtendedPropertyValue Value { get; }
Visual C++
public:
property ExtendedPropertyValue^ Value {
    ExtendedPropertyValue^ get ();
}

See Also

ExtendedProperty Class
RedGate.SQLCompare.Engine Namespace


VariableAssignScriptSource Property

[image]

SQL Data Compare API 12.0.40
ExtendedProperty..::.VariableAssignScriptSource Property
ExtendedProperty Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property VariableAssignScriptSource As ScriptSource
C#
public ScriptSource VariableAssignScriptSource { get; set; }
Visual C++
public:
property ScriptSource^ VariableAssignScriptSource {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

ExtendedProperty Class
RedGate.SQLCompare.Engine Namespace


VariableDeclareScriptSource Property

[image]

SQL Data Compare API 12.0.40
ExtendedProperty..::.VariableDeclareScriptSource Property
ExtendedProperty Class See Also

The script sources for the variable assigned to this extended property

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property VariableDeclareScriptSource As ScriptSource
C#
public ScriptSource VariableDeclareScriptSource { get; set; }
Visual C++
public:
property ScriptSource^ VariableDeclareScriptSource {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

ExtendedProperty Class
RedGate.SQLCompare.Engine Namespace


ExtendedPropertyValue Class

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyValue Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ExtendedPropertyValue
C#
public sealed class ExtendedPropertyValue
Visual C++
public ref class ExtendedPropertyValue sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ExtendedPropertyValue

See Also

ExtendedPropertyValue Members
RedGate.SQLCompare.Engine Namespace


ExtendedPropertyValue Members

[image] [image]

SQL Data Compare API 12.0.40
ExtendedPropertyValue Members
ExtendedPropertyValue Class Constructors Methods Properties See Also

The ExtendedPropertyValue type exposes the following members.

Constructors

Name | Description
ExtendedPropertyValue | Overloaded.

Methods

Name | Description
CompareWith |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSQLTypeString |
GetSQLValue |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize |
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
DefinedSize |
Precision |
Scale |
SqlType |
TypeName |

See Also

ExtendedPropertyValue Class
RedGate.SQLCompare.Engine Namespace


ExtendedPropertyValue Constructor

[image] [image]

SQL Data Compare API 12.0.40
ExtendedPropertyValue Constructor
ExtendedPropertyValue Class See Also

Overload List

Name | Description
ExtendedPropertyValue(NullableBinaryReader, Single) |
ExtendedPropertyValue(Object, Int32, Int32, Int32, String, SqlType) |

See Also

ExtendedPropertyValue Class
ExtendedPropertyValue Members
RedGate.SQLCompare.Engine Namespace


ExtendedPropertyValue Constructor (, )

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyValue Constructor (, )
ExtendedPropertyValue Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    reader As NullableBinaryReader, _
    version As Single _
)
C#
public ExtendedPropertyValue(
    NullableBinaryReader reader,
    float version
)
Visual C++
public:
ExtendedPropertyValue(
    NullableBinaryReader^ reader,
    float version
)

Parameters

reader
Type: NullableBinaryReader
version
Type: Single

See Also

ExtendedPropertyValue Class
ExtendedPropertyValue Overload
RedGate.SQLCompare.Engine Namespace


ExtendedPropertyValue Constructor (, , , , , SqlType)

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyValue Constructor (, , , , , SqlType)
ExtendedPropertyValue Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    value As Object, _
    scale As Integer, _
    precision As Integer, _
    definedSize As Integer, _
    typeName As String, _
    type As SqlType _
)
C#
public ExtendedPropertyValue(
    Object value,
    int scale,
    int precision,
    int definedSize,
    string typeName,
    SqlType type
)
Visual C++
public:
ExtendedPropertyValue(
    Object^ value,
    int scale,
    int precision,
    int definedSize,
    String^ typeName,
    SqlType type
)

Parameters

value
Type: Object
scale
Type: Int32
precision
Type: Int32
definedSize
Type: Int32
typeName
Type: String
type
Type: RedGate.SQLCompare.Engine..::.SqlType

See Also

ExtendedPropertyValue Class
ExtendedPropertyValue Overload
RedGate.SQLCompare.Engine Namespace


ExtendedPropertyValue Methods

[image] [image]

SQL Data Compare API 12.0.40
ExtendedPropertyValue Methods
ExtendedPropertyValue Class See Also

The ExtendedPropertyValue type exposes the following methods.

Methods

Name | Description
CompareWith |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSQLTypeString |
GetSQLValue |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize |
ToString | (Overrides Object..::.ToString()()().)

See Also

ExtendedPropertyValue Class
RedGate.SQLCompare.Engine Namespace


CompareWith Method

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyValue..::.CompareWith Method
ExtendedPropertyValue Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CompareWith ( _
    o1 As ExtendedPropertyValue, _
    o2 As ExtendedPropertyValue, _
    options As Options _
) As IEnumerable(Of EqualityDifference)
C#
public static IEnumerable<EqualityDifference> CompareWith(
    ExtendedPropertyValue o1,
    ExtendedPropertyValue o2,
    Options options
)
Visual C++
public:
static IEnumerable<EqualityDifference^>^ CompareWith(
    ExtendedPropertyValue^ o1,
    ExtendedPropertyValue^ o2,
    Options options
)

Parameters

o1
Type: RedGate.SQLCompare.Engine..::.ExtendedPropertyValue
o2
Type: RedGate.SQLCompare.Engine..::.ExtendedPropertyValue
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

ExtendedPropertyValue Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
ExtendedPropertyValue..::.Equals Method
ExtendedPropertyValue Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(ExtendedPropertyValue, ExtendedPropertyValue, Options) |

See Also

ExtendedPropertyValue Class
ExtendedPropertyValue Members
RedGate.SQLCompare.Engine Namespace


Equals Method (ExtendedPropertyValue, ExtendedPropertyValue, Options)

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyValue..::.Equals Method (ExtendedPropertyValue, ExtendedPropertyValue, Options)
ExtendedPropertyValue Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Equals ( _
    o1 As ExtendedPropertyValue, _
    o2 As ExtendedPropertyValue, _
    options As Options _
) As Boolean
C#
public static bool Equals(
    ExtendedPropertyValue o1,
    ExtendedPropertyValue o2,
    Options options
)
Visual C++
public:
static bool Equals(
    ExtendedPropertyValue^ o1,
    ExtendedPropertyValue^ o2,
    Options options
)

Parameters

o1
Type: RedGate.SQLCompare.Engine..::.ExtendedPropertyValue
o2
Type: RedGate.SQLCompare.Engine..::.ExtendedPropertyValue
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

ExtendedPropertyValue Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


GetSQLTypeString Method

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyValue..::.GetSQLTypeString Method
ExtendedPropertyValue Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSQLTypeString As String
C#
public string GetSQLTypeString()
Visual C++
public:
String^ GetSQLTypeString()

See Also

ExtendedPropertyValue Class
RedGate.SQLCompare.Engine Namespace


GetSQLValue Method

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyValue..::.GetSQLValue Method
ExtendedPropertyValue Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSQLValue As String
C#
public string GetSQLValue()
Visual C++
public:
String^ GetSQLValue()

See Also

ExtendedPropertyValue Class
RedGate.SQLCompare.Engine Namespace


Serialize Method

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyValue..::.Serialize Method
ExtendedPropertyValue Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Serialize ( _
    writer As NullableBinaryWriter _
)
C#
public void Serialize(
    NullableBinaryWriter writer
)
Visual C++
public:
void Serialize(
    NullableBinaryWriter^ writer
)

Parameters

writer
Type: NullableBinaryWriter

See Also

ExtendedPropertyValue Class
RedGate.SQLCompare.Engine Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyValue..::.ToString Method
ExtendedPropertyValue Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

See Also

ExtendedPropertyValue Class
RedGate.SQLCompare.Engine Namespace


ExtendedPropertyValue Properties

[image] [image]

SQL Data Compare API 12.0.40
ExtendedPropertyValue Properties
ExtendedPropertyValue Class See Also

The ExtendedPropertyValue type exposes the following properties.

Properties

Name | Description
DefinedSize |
Precision |
Scale |
SqlType |
TypeName |

See Also

ExtendedPropertyValue Class
RedGate.SQLCompare.Engine Namespace


DefinedSize Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyValue..::.DefinedSize Property
ExtendedPropertyValue Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DefinedSize As Integer
C#
public int DefinedSize { get; }
Visual C++
public:
property int DefinedSize {
    int get ();
}

See Also

ExtendedPropertyValue Class
RedGate.SQLCompare.Engine Namespace


Precision Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyValue..::.Precision Property
ExtendedPropertyValue Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Precision As Integer
C#
public int Precision { get; }
Visual C++
public:
property int Precision {
    int get ();
}

See Also

ExtendedPropertyValue Class
RedGate.SQLCompare.Engine Namespace


Scale Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyValue..::.Scale Property
ExtendedPropertyValue Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Scale As Integer
C#
public int Scale { get; }
Visual C++
public:
property int Scale {
    int get ();
}

See Also

ExtendedPropertyValue Class
RedGate.SQLCompare.Engine Namespace


SqlType Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyValue..::.SqlType Property
ExtendedPropertyValue Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SqlType As SqlType
C#
public SqlType SqlType { get; }
Visual C++
public:
property SqlType SqlType {
    SqlType get ();
}

See Also

ExtendedPropertyValue Class
RedGate.SQLCompare.Engine Namespace


TypeName Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyValue..::.TypeName Property
ExtendedPropertyValue Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TypeName As String
C#
public string TypeName { get; }
Visual C++
public:
property String^ TypeName {
    String^ get ();
}

See Also

ExtendedPropertyValue Class
RedGate.SQLCompare.Engine Namespace


Field Class

[image]

SQL Data Compare API 12.0.40
Field Class
Members See Also

A SQL Server field.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Field _
    Implements IField, IDatabaseObject, ITSqlObject, ICanExistenceCheck,  _
    ISqlComparable
C#
public sealed class Field : IField,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, ISqlComparable
Visual C++
public ref class Field sealed : IField,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.Field

See Also

Field Members
RedGate.SQLCompare.Engine Namespace


Field Members

[image] [image]

SQL Data Compare API 12.0.40
Field Members
Field Class Constructors Methods Properties Explicit Interface Implementations See Also

The Field type exposes the following members.

Constructors

Name | Description
Field |

Methods

Name | Description
Clone |
CompareWith | Compares the field with a specified field.
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDataTypeSql |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSQL |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowNulls | True if the field can contain NULL values.
Collation | The collation order of character fields.
ColumnSet | True if this field is a column set.
Computed | True if the field is computed.
ComputedText | The computed text of the field.
DataMaskingFunction | The function used to mask the data.
Default | The default that is bound to the field.
DefaultText | The text of the field's default value.
DefinedSize | The length of the field.
DependentFields | Dependent fields for computed columns.
DRIDefault | The Declarative Referential Integrity (DRI) default.
DRIDefaultID |
DRIDefaultIsSystemNamed |
Filestream | Specifies if this is a filestream column.
FullTextLanguage | The language of any full-text index to which the field belongs.
FullTextTypeColumn | The column that holds document type information. This is a SQL Server 2005 feature.
FullyQualifiedTypeName | The name of the fully-qualified field type. For SQL Server 2005, this property contains the schema name.
Function |
Identity | True if the field is an identity field.
IdentityIncrement | The identity increment.
IdentitySeed | The identity seed.
IsFullTextFromInlineCreate | True if this fulltext field was set from an inline CREATE FULLTEXT INDEX statement
IsIncludedInFullTextIndex | True if the field is contained in a full-text index.
Name | The name of the field. DANGER WILL ROBINSON!! This is not escaped. Do you mean Field..::.QualifiedName?
NotForReplication | True if the field is marked as not for replication.
NullabilityExplicitlySet |
ObjectType | Returns ObjectType.Field
Ordinal |
Owner | The owner of the field. This is undefined.
Persisted | The column is in a calculated column that is persisted.
Precision | The precision of a decimal or numeric data type.
QualifiedName | The qualified name of the object. Do you mean Field..::.Name?
RowGUIDCol | True if the field is a ROWGUIDCOL.
Rule | The rule bound to the field.
Scale | The scale of the field.
ScriptSourceForDefault | The location of the creation script for the default binding of this field if the database source is set to scripts folder.
ScriptSourceForFullTextColumn | The location of the creation script for the fulltext column information for this field if the database source is set to scripts folder.
ScriptSourceForRule | The location of the creation script for the rule binding of this field if the database source is set to scripts folder.
Sparse | Whether this column is a sparse column
SqlType | The field type.
Table |
TableOrView |
TypeName | The name of the field type.
TypeSchemaName | The name of the schema for the field's data type.
View |
XmlDocument | The referenced XML document.
XmlSchemaCollection | The referenced XML schema collection.

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |
IDatabaseObject..::.Equals |

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


Field Constructor

[image]

SQL Data Compare API 12.0.40
Field Constructor
Field Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Field()
Visual C++
public:
Field()

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


Field Methods

[image] [image]

SQL Data Compare API 12.0.40
Field Methods
Field Class See Also

The Field type exposes the following methods.

Methods

Name | Description
Clone |
CompareWith | Compares the field with a specified field.
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDataTypeSql |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSQL |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |
IDatabaseObject..::.Equals |

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
Field..::.Clone Method
Field Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone As Field
C#
public Field Clone()
Visual C++
public:
virtual Field^ Clone() sealed

Implements

IField..::.Clone()()()

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


CompareWith Method

[image]

SQL Data Compare API 12.0.40
Field..::.CompareWith Method
Field Class See Also

Compares the field with a specified field.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareWith ( _
    targetField As IField, _
    options As Options, _
    ignoreDriDefault As Boolean _
) As IEnumerable(Of EqualityDifference)
C#
public IEnumerable<EqualityDifference> CompareWith(
    IField targetField,
    Options options,
    bool ignoreDriDefault
)
Visual C++
public:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    IField^ targetField,
    Options options,
    bool ignoreDriDefault
) sealed

Parameters

targetField
Type: RedGate.SQLCompare.Engine..::.IField
The field to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.
ignoreDriDefault
Type: Boolean
Whether to ignore default constraints for the field

Return Value

True if the fields are identical; otherwise, false.

Implements

IField..::.CompareWith(IField, Options, Boolean)

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
Field..::.ISqlComparable..::.CompareWith Method
Field Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    obj As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable obj,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ obj,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

obj
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
Field..::.Equals Method
Field Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IField, Options, Boolean) |

See Also

Field Class
Field Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IField, Options, )

[image]

SQL Data Compare API 12.0.40
Field..::.Equals Method (IField, Options, )
Field Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    targetField As IField, _
    options As Options, _
    ignoreDriDefault As Boolean _
) As Boolean
C#
public bool Equals(
    IField targetField,
    Options options,
    bool ignoreDriDefault
)
Visual C++
public:
virtual bool Equals(
    IField^ targetField,
    Options options,
    bool ignoreDriDefault
) sealed

Parameters

targetField
Type: RedGate.SQLCompare.Engine..::.IField
options
Type: RedGate.SQLCompare.Engine..::.Options
ignoreDriDefault
Type: Boolean

Implements

IField..::.Equals(IField, Options, Boolean)

See Also

Field Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


IDatabaseObject.Equals Method

[image]

SQL Data Compare API 12.0.40
Field..::.IDatabaseObject..::.Equals Method
Field Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean Implements IDatabaseObject.Equals
C#
bool IDatabaseObject.Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
private:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) sealed = IDatabaseObject::Equals

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


GetDataTypeSql Method

[image]

SQL Data Compare API 12.0.40
Field..::.GetDataTypeSql Method
Field Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDataTypeSql ( _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As String
C#
public string GetDataTypeSql(
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual String^ GetDataTypeSql(
    Options options,
    IFeatureChecker^ targetFeatures
) sealed

Parameters

options
Type: RedGate.SQLCompare.Engine..::.Options
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Implements

IField..::.GetDataTypeSql(Options, IFeatureChecker)

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


GetSQL Method

[image]

SQL Data Compare API 12.0.40
Field..::.GetSQL Method
Field Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSQL ( _
    options As Options, _
    includeFullDefinition As Boolean, _
    targetFeatures As IFeatureChecker, _
    targetAllowsNulls As Nullable(Of Boolean) _
) As String
C#
public string GetSQL(
    Options options,
    bool includeFullDefinition,
    IFeatureChecker targetFeatures,
    Nullable<bool> targetAllowsNulls
)
Visual C++
public:
virtual String^ GetSQL(
    Options options,
    bool includeFullDefinition,
    IFeatureChecker^ targetFeatures,
    Nullable<bool> targetAllowsNulls
) sealed

Parameters

options
Type: RedGate.SQLCompare.Engine..::.Options
includeFullDefinition
Type: Boolean
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker
targetAllowsNulls
Type: Nullable<(Of <(Boolean>)>)

Implements

IField..::.GetSQL(Options, Boolean, IFeatureChecker, Nullable<(Of <(Boolean>)>))

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


Field Properties

[image] [image]

SQL Data Compare API 12.0.40
Field Properties
Field Class See Also

The Field type exposes the following properties.

Properties

Name | Description
AllowNulls | True if the field can contain NULL values.
Collation | The collation order of character fields.
ColumnSet | True if this field is a column set.
Computed | True if the field is computed.
ComputedText | The computed text of the field.
DataMaskingFunction | The function used to mask the data.
Default | The default that is bound to the field.
DefaultText | The text of the field's default value.
DefinedSize | The length of the field.
DependentFields | Dependent fields for computed columns.
DRIDefault | The Declarative Referential Integrity (DRI) default.
DRIDefaultID |
DRIDefaultIsSystemNamed |
Filestream | Specifies if this is a filestream column.
FullTextLanguage | The language of any full-text index to which the field belongs.
FullTextTypeColumn | The column that holds document type information. This is a SQL Server 2005 feature.
FullyQualifiedTypeName | The name of the fully-qualified field type. For SQL Server 2005, this property contains the schema name.
Function |
Identity | True if the field is an identity field.
IdentityIncrement | The identity increment.
IdentitySeed | The identity seed.
IsFullTextFromInlineCreate | True if this fulltext field was set from an inline CREATE FULLTEXT INDEX statement
IsIncludedInFullTextIndex | True if the field is contained in a full-text index.
Name | The name of the field. DANGER WILL ROBINSON!! This is not escaped. Do you mean Field..::.QualifiedName?
NotForReplication | True if the field is marked as not for replication.
NullabilityExplicitlySet |
ObjectType | Returns ObjectType.Field
Ordinal |
Owner | The owner of the field. This is undefined.
Persisted | The column is in a calculated column that is persisted.
Precision | The precision of a decimal or numeric data type.
QualifiedName | The qualified name of the object. Do you mean Field..::.Name?
RowGUIDCol | True if the field is a ROWGUIDCOL.
Rule | The rule bound to the field.
Scale | The scale of the field.
ScriptSourceForDefault | The location of the creation script for the default binding of this field if the database source is set to scripts folder.
ScriptSourceForFullTextColumn | The location of the creation script for the fulltext column information for this field if the database source is set to scripts folder.
ScriptSourceForRule | The location of the creation script for the rule binding of this field if the database source is set to scripts folder.
Sparse | Whether this column is a sparse column
SqlType | The field type.
Table |
TableOrView |
TypeName | The name of the field type.
TypeSchemaName | The name of the schema for the field's data type.
View |
XmlDocument | The referenced XML document.
XmlSchemaCollection | The referenced XML schema collection.

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


AllowNulls Property

[image]

SQL Data Compare API 12.0.40
Field..::.AllowNulls Property
Field Class See Also

True if the field can contain NULL values.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowNulls As Boolean
C#
public bool AllowNulls { get; set; }
Visual C++
public:
virtual property bool AllowNulls {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IField..::.AllowNulls

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


Collation Property

[image]

SQL Data Compare API 12.0.40
Field..::.Collation Property
Field Class See Also

The collation order of character fields.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Collation As String
C#
public string Collation { get; set; }
Visual C++
public:
virtual property String^ Collation {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IField..::.Collation

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


ColumnSet Property

[image]

SQL Data Compare API 12.0.40
Field..::.ColumnSet Property
Field Class See Also

True if this field is a column set.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ColumnSet As Boolean
C#
public bool ColumnSet { get; set; }
Visual C++
public:
virtual property bool ColumnSet {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IField..::.ColumnSet

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


Computed Property

[image]

SQL Data Compare API 12.0.40
Field..::.Computed Property
Field Class See Also

True if the field is computed.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Computed As Boolean
C#
public bool Computed { get; set; }
Visual C++
public:
virtual property bool Computed {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IField..::.Computed

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


ComputedText Property

[image]

SQL Data Compare API 12.0.40
Field..::.ComputedText Property
Field Class See Also

The computed text of the field.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ComputedText As String
C#
public string ComputedText { get; set; }
Visual C++
public:
virtual property String^ ComputedText {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IField..::.ComputedText

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


DataMaskingFunction Property

[image]

SQL Data Compare API 12.0.40
Field..::.DataMaskingFunction Property
Field Class See Also

The function used to mask the data.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DataMaskingFunction As String
C#
public string DataMaskingFunction { get; set; }
Visual C++
public:
virtual property String^ DataMaskingFunction {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IField..::.DataMaskingFunction

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


Default Property

[image]

SQL Data Compare API 12.0.40
Field..::.Default Property
Field Class See Also

The default that is bound to the field.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Default As Default
C#
public Default Default { get; set; }
Visual C++
public:
virtual property Default^ Default {
    Default^ get () sealed;
    void set (Default^ value) sealed;
}

Implements

IField..::.Default

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


DefaultText Property

[image]

SQL Data Compare API 12.0.40
Field..::.DefaultText Property
Field Class See Also

The text of the field's default value.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultText As String
C#
public string DefaultText { get; set; }
Visual C++
public:
virtual property String^ DefaultText {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IField..::.DefaultText

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


DefinedSize Property

[image]

SQL Data Compare API 12.0.40
Field..::.DefinedSize Property
Field Class See Also

The length of the field.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefinedSize As Integer
C#
public int DefinedSize { get; set; }
Visual C++
public:
virtual property int DefinedSize {
    int get () sealed;
    void set (int value) sealed;
}

Implements

IField..::.DefinedSize

Remarks

Valid only for character and binary data.

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


DependentFields Property

[image]

SQL Data Compare API 12.0.40
Field..::.DependentFields Property
Field Class See Also

Dependent fields for computed columns.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DependentFields As String()
C#
public string[] DependentFields { get; set; }
Visual C++
public:
virtual property array<String^>^ DependentFields {
    array<String^>^ get () sealed;
    void set (array<String^>^ value) sealed;
}

Implements

IField..::.DependentFields

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


DRIDefault Property

[image]

SQL Data Compare API 12.0.40
Field..::.DRIDefault Property
Field Class See Also

The Declarative Referential Integrity (DRI) default.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DRIDefault As String
C#
public string DRIDefault { get; set; }
Visual C++
public:
virtual property String^ DRIDefault {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IField..::.DRIDefault

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


DRIDefaultID Property

[image]

SQL Data Compare API 12.0.40
Field..::.DRIDefaultID Property
Field Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DRIDefaultID As Integer
C#
public int DRIDefaultID { get; set; }
Visual C++
public:
virtual property int DRIDefaultID {
    int get () sealed;
    void set (int value) sealed;
}

Implements

IField..::.DRIDefaultID

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


DRIDefaultIsSystemNamed Property

[image]

SQL Data Compare API 12.0.40
Field..::.DRIDefaultIsSystemNamed Property
Field Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DRIDefaultIsSystemNamed As Boolean
C#
public bool DRIDefaultIsSystemNamed { get; set; }
Visual C++
public:
virtual property bool DRIDefaultIsSystemNamed {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IField..::.DRIDefaultIsSystemNamed

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


Filestream Property

[image]

SQL Data Compare API 12.0.40
Field..::.Filestream Property
Field Class See Also

Specifies if this is a filestream column.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Filestream As Boolean
C#
public bool Filestream { get; set; }
Visual C++
public:
virtual property bool Filestream {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IField..::.Filestream

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


FullTextLanguage Property

[image]

SQL Data Compare API 12.0.40
Field..::.FullTextLanguage Property
Field Class See Also

The language of any full-text index to which the field belongs.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextLanguage As Integer
C#
public int FullTextLanguage { get; set; }
Visual C++
public:
virtual property int FullTextLanguage {
    int get () sealed;
    void set (int value) sealed;
}

Implements

IField..::.FullTextLanguage

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


FullTextTypeColumn Property

[image]

SQL Data Compare API 12.0.40
Field..::.FullTextTypeColumn Property
Field Class See Also

The column that holds document type information. This is a SQL Server 2005 feature.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextTypeColumn As String
C#
public string FullTextTypeColumn { get; set; }
Visual C++
public:
virtual property String^ FullTextTypeColumn {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IField..::.FullTextTypeColumn

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


FullyQualifiedTypeName Property

[image]

SQL Data Compare API 12.0.40
Field..::.FullyQualifiedTypeName Property
Field Class See Also

The name of the fully-qualified field type. For SQL Server 2005, this property contains the schema name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullyQualifiedTypeName As String
C#
public string FullyQualifiedTypeName { get; }
Visual C++
public:
virtual property String^ FullyQualifiedTypeName {
    String^ get () sealed;
}

Implements

IField..::.FullyQualifiedTypeName

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


Function Property

[image]

SQL Data Compare API 12.0.40
Field..::.Function Property
Field Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Function As Function
C#
public Function Function { get; set; }
Visual C++
public:
virtual property Function^ Function {
    Function^ get () sealed;
    void set (Function^ value) sealed;
}

Implements

IField..::.Function

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


Identity Property

[image]

SQL Data Compare API 12.0.40
Field..::.Identity Property
Field Class See Also

True if the field is an identity field.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Identity As Boolean
C#
public bool Identity { get; set; }
Visual C++
public:
virtual property bool Identity {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IField..::.Identity

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


IdentityIncrement Property

[image]

SQL Data Compare API 12.0.40
Field..::.IdentityIncrement Property
Field Class See Also

The identity increment.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IdentityIncrement As Long
C#
public long IdentityIncrement { get; internal set; }
Visual C++
public:
virtual property long long IdentityIncrement {
    long long get () sealed;
    void set (long long value) sealed;
}

Implements

IField..::.IdentityIncrement

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


IdentitySeed Property

[image]

SQL Data Compare API 12.0.40
Field..::.IdentitySeed Property
Field Class See Also

The identity seed.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IdentitySeed As SqlDecimal
C#
public SqlDecimal IdentitySeed { get; internal set; }
Visual C++
public:
virtual property SqlDecimal IdentitySeed {
    SqlDecimal get () sealed;
    void set (SqlDecimal value) sealed;
}

Implements

IField..::.IdentitySeed

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


IsFullTextFromInlineCreate Property

[image]

SQL Data Compare API 12.0.40
Field..::.IsFullTextFromInlineCreate Property
Field Class See Also

True if this fulltext field was set from an inline CREATE FULLTEXT INDEX statement

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsFullTextFromInlineCreate As Boolean
C#
public bool IsFullTextFromInlineCreate { get; set; }
Visual C++
public:
virtual property bool IsFullTextFromInlineCreate {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IField..::.IsFullTextFromInlineCreate

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


IsIncludedInFullTextIndex Property

[image]

SQL Data Compare API 12.0.40
Field..::.IsIncludedInFullTextIndex Property
Field Class See Also

True if the field is contained in a full-text index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsIncludedInFullTextIndex As Boolean
C#
public bool IsIncludedInFullTextIndex { get; set; }
Visual C++
public:
virtual property bool IsIncludedInFullTextIndex {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IField..::.IsIncludedInFullTextIndex

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
Field..::.Name Property
Field Class See Also

The name of the field. DANGER WILL ROBINSON!! This is not escaped. Do you mean Field..::.QualifiedName?

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IField..::.Name
ITSqlObjectName()()()

See Also

Field Class
RedGate.SQLCompare.Engine Namespace
Field..::.QualifiedName


NotForReplication Property

[image]

SQL Data Compare API 12.0.40
Field..::.NotForReplication Property
Field Class See Also

True if the field is marked as not for replication.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NotForReplication As Boolean
C#
public bool NotForReplication { get; set; }
Visual C++
public:
virtual property bool NotForReplication {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IField..::.NotForReplication

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


NullabilityExplicitlySet Property

[image]

SQL Data Compare API 12.0.40
Field..::.NullabilityExplicitlySet Property
Field Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NullabilityExplicitlySet As Boolean
C#
public bool NullabilityExplicitlySet { get; set; }
Visual C++
public:
virtual property bool NullabilityExplicitlySet {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IField..::.NullabilityExplicitlySet

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
Field..::.ObjectType Property
Field Class See Also

Returns ObjectType.Field

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ObjectType As ObjectType
C#
public ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () sealed;
}

Implements

ITSqlObjectObjectType()()()

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


Ordinal Property

[image]

SQL Data Compare API 12.0.40
Field..::.Ordinal Property
Field Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Ordinal As Integer
C#
public int Ordinal { get; set; }
Visual C++
public:
virtual property int Ordinal {
    int get () sealed;
    void set (int value) sealed;
}

Implements

IField..::.Ordinal

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
Field..::.Owner Property
Field Class See Also

The owner of the field. This is undefined.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Owner As String
C#
public string Owner { get; }
Visual C++
public:
virtual property String^ Owner {
    String^ get () sealed;
}

Implements

ITSqlObjectOwner()()()

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


Persisted Property

[image]

SQL Data Compare API 12.0.40
Field..::.Persisted Property
Field Class See Also

The column is in a calculated column that is persisted.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Persisted As Boolean
C#
public bool Persisted { get; set; }
Visual C++
public:
virtual property bool Persisted {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IField..::.Persisted

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


Precision Property

[image]

SQL Data Compare API 12.0.40
Field..::.Precision Property
Field Class See Also

The precision of a decimal or numeric data type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Precision As Integer
C#
public int Precision { get; internal set; }
Visual C++
public:
virtual property int Precision {
    int get () sealed;
    void set (int value) sealed;
}

Implements

IField..::.Precision

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


QualifiedName Property

[image]

SQL Data Compare API 12.0.40
Field..::.QualifiedName Property
Field Class See Also

The qualified name of the object. Do you mean Field..::.Name?

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property QualifiedName As String
C#
public string QualifiedName { get; }
Visual C++
public:
virtual property String^ QualifiedName {
    String^ get () sealed;
}

Implements

ITSqlObjectQualifiedName()()()

See Also

Field Class
RedGate.SQLCompare.Engine Namespace
Field..::.Name


RowGUIDCol Property

[image]

SQL Data Compare API 12.0.40
Field..::.RowGUIDCol Property
Field Class See Also

True if the field is a ROWGUIDCOL.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RowGUIDCol As Boolean
C#
public bool RowGUIDCol { get; set; }
Visual C++
public:
virtual property bool RowGUIDCol {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IField..::.RowGUIDCol

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


Rule Property

[image]

SQL Data Compare API 12.0.40
Field..::.Rule Property
Field Class See Also

The rule bound to the field.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Rule As Rule
C#
public Rule Rule { get; set; }
Visual C++
public:
virtual property Rule^ Rule {
    Rule^ get () sealed;
    void set (Rule^ value) sealed;
}

Implements

IField..::.Rule

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


Scale Property

[image]

SQL Data Compare API 12.0.40
Field..::.Scale Property
Field Class See Also

The scale of the field.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Scale As Integer
C#
public int Scale { get; internal set; }
Visual C++
public:
virtual property int Scale {
    int get () sealed;
    void set (int value) sealed;
}

Implements

IField..::.Scale

Remarks

Valid for numeric and decimal data types.

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


ScriptSourceForDefault Property

[image]

SQL Data Compare API 12.0.40
Field..::.ScriptSourceForDefault Property
Field Class See Also

The location of the creation script for the default binding of this field if the database source is set to scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSourceForDefault As ScriptSource
C#
public ScriptSource ScriptSourceForDefault { get; set; }
Visual C++
public:
virtual property ScriptSource^ ScriptSourceForDefault {
    ScriptSource^ get () sealed;
    void set (ScriptSource^ value) sealed;
}

Implements

IField..::.ScriptSourceForDefault

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


ScriptSourceForFullTextColumn Property

[image]

SQL Data Compare API 12.0.40
Field..::.ScriptSourceForFullTextColumn Property
Field Class See Also

The location of the creation script for the fulltext column information for this field if the database source is set to scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSourceForFullTextColumn As ScriptSource
C#
public ScriptSource ScriptSourceForFullTextColumn { get; set; }
Visual C++
public:
virtual property ScriptSource^ ScriptSourceForFullTextColumn {
    ScriptSource^ get () sealed;
    void set (ScriptSource^ value) sealed;
}

Implements

IField..::.ScriptSourceForFullTextColumn

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


ScriptSourceForRule Property

[image]

SQL Data Compare API 12.0.40
Field..::.ScriptSourceForRule Property
Field Class See Also

The location of the creation script for the rule binding of this field if the database source is set to scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSourceForRule As ScriptSource
C#
public ScriptSource ScriptSourceForRule { get; set; }
Visual C++
public:
virtual property ScriptSource^ ScriptSourceForRule {
    ScriptSource^ get () sealed;
    void set (ScriptSource^ value) sealed;
}

Implements

IField..::.ScriptSourceForRule

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


Sparse Property

[image]

SQL Data Compare API 12.0.40
Field..::.Sparse Property
Field Class See Also

Whether this column is a sparse column

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Sparse As Boolean
C#
public bool Sparse { get; set; }
Visual C++
public:
virtual property bool Sparse {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IField..::.Sparse

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


SqlType Property

[image]

SQL Data Compare API 12.0.40
Field..::.SqlType Property
Field Class See Also

The field type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SqlType As SqlType
C#
public SqlType SqlType { get; set; }
Visual C++
public:
virtual property SqlType SqlType {
    SqlType get () sealed;
    void set (SqlType value) sealed;
}

Implements

IField..::.SqlType

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


Table Property

[image]

SQL Data Compare API 12.0.40
Field..::.Table Property
Field Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Table As Table
C#
public Table Table { get; set; }
Visual C++
public:
virtual property Table^ Table {
    Table^ get () sealed;
    void set (Table^ value) sealed;
}

Implements

IField..::.Table

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


TableOrView Property

[image]

SQL Data Compare API 12.0.40
Field..::.TableOrView Property
Field Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TableOrView As ViewTableSuperClass
C#
public ViewTableSuperClass TableOrView { get; set; }
Visual C++
public:
virtual property ViewTableSuperClass^ TableOrView {
    ViewTableSuperClass^ get () sealed;
    void set (ViewTableSuperClass^ value) sealed;
}

Implements

IField..::.TableOrView

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


TypeName Property

[image]

SQL Data Compare API 12.0.40
Field..::.TypeName Property
Field Class See Also

The name of the field type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeName As String
C#
public string TypeName { get; set; }
Visual C++
public:
virtual property String^ TypeName {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IField..::.TypeName

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


TypeSchemaName Property

[image]

SQL Data Compare API 12.0.40
Field..::.TypeSchemaName Property
Field Class See Also

The name of the schema for the field's data type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeSchemaName As String
C#
public string TypeSchemaName { get; set; }
Visual C++
public:
virtual property String^ TypeSchemaName {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IField..::.TypeSchemaName

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


View Property

[image]

SQL Data Compare API 12.0.40
Field..::.View Property
Field Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property View As View
C#
public View View { get; set; }
Visual C++
public:
virtual property View^ View {
    View^ get () sealed;
    void set (View^ value) sealed;
}

Implements

IField..::.View

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


XmlDocument Property

[image]

SQL Data Compare API 12.0.40
Field..::.XmlDocument Property
Field Class See Also

The referenced XML document.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlDocument As Boolean
C#
public bool XmlDocument { get; set; }
Visual C++
public:
virtual property bool XmlDocument {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IField..::.XmlDocument

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


XmlSchemaCollection Property

[image]

SQL Data Compare API 12.0.40
Field..::.XmlSchemaCollection Property
Field Class See Also

The referenced XML schema collection.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlSchemaCollection As XmlSchemaCollection
C#
public XmlSchemaCollection XmlSchemaCollection { get; set; }
Visual C++
public:
virtual property XmlSchemaCollection^ XmlSchemaCollection {
    XmlSchemaCollection^ get () sealed;
    void set (XmlSchemaCollection^ value) sealed;
}

Implements

IField..::.XmlSchemaCollection

See Also

Field Class
RedGate.SQLCompare.Engine Namespace


FieldBinding Class

[image]

SQL Data Compare API 12.0.40
FieldBinding Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FieldBinding _
    Implements ICanExistenceCheck
C#
public sealed class FieldBinding : ICanExistenceCheck
Visual C++
public ref class FieldBinding sealed : ICanExistenceCheck

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.FieldBinding

See Also

FieldBinding Members
RedGate.SQLCompare.Engine Namespace


FieldBinding Members

[image] [image]

SQL Data Compare API 12.0.40
FieldBinding Members
FieldBinding Class Methods Properties See Also

The FieldBinding type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundObjectName |
Field |
FullyQualifiedBoundObjectName |
Table |
Text |

See Also

FieldBinding Class
RedGate.SQLCompare.Engine Namespace


FieldBinding Properties

[image] [image]

SQL Data Compare API 12.0.40
FieldBinding Properties
FieldBinding Class See Also

The FieldBinding type exposes the following properties.

Properties

Name | Description
BoundObjectName |
Field |
FullyQualifiedBoundObjectName |
Table |
Text |

See Also

FieldBinding Class
RedGate.SQLCompare.Engine Namespace


BoundObjectName Property

[image]

SQL Data Compare API 12.0.40
FieldBinding..::.BoundObjectName Property
FieldBinding Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BoundObjectName As String
C#
public string BoundObjectName { get; }
Visual C++
public:
property String^ BoundObjectName {
    String^ get ();
}

See Also

FieldBinding Class
RedGate.SQLCompare.Engine Namespace


Field Property

[image]

SQL Data Compare API 12.0.40
FieldBinding..::.Field Property
FieldBinding Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Field As IField
C#
public IField Field { get; }
Visual C++
public:
property IField^ Field {
    IField^ get ();
}

See Also

FieldBinding Class
RedGate.SQLCompare.Engine Namespace


FullyQualifiedBoundObjectName Property

[image]

SQL Data Compare API 12.0.40
FieldBinding..::.FullyQualifiedBoundObjectName Property
FieldBinding Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullyQualifiedBoundObjectName As String
C#
public string FullyQualifiedBoundObjectName { get; }
Visual C++
public:
property String^ FullyQualifiedBoundObjectName {
    String^ get ();
}

See Also

FieldBinding Class
RedGate.SQLCompare.Engine Namespace


Table Property

[image]

SQL Data Compare API 12.0.40
FieldBinding..::.Table Property
FieldBinding Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Table As Table
C#
public Table Table { get; }
Visual C++
public:
property Table^ Table {
    Table^ get ();
}

See Also

FieldBinding Class
RedGate.SQLCompare.Engine Namespace


Text Property

[image]

SQL Data Compare API 12.0.40
FieldBinding..::.Text Property
FieldBinding Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
C#
public string Text { get; }
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

FieldBinding Class
RedGate.SQLCompare.Engine Namespace


FieldBindings Class

[image]

SQL Data Compare API 12.0.40
FieldBindings Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FieldBindings _
    Inherits KeyedCollection(Of FieldBinding)
C#
public sealed class FieldBindings : KeyedCollection<FieldBinding>
Visual C++
public ref class FieldBindings sealed : public KeyedCollection<FieldBinding^>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( FieldBinding >)>)
RedGate.SQLCompare.Engine..::.FieldBindings

See Also

FieldBindings Members
RedGate.SQLCompare.Engine Namespace


FieldBindings Members

[image] [image]

SQL Data Compare API 12.0.40
FieldBindings Members
FieldBindings Class Methods Fields Properties Explicit Interface Implementations See Also

The FieldBindings type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

FieldBindings Class
RedGate.SQLCompare.Engine Namespace


FieldMappingBestMatchMessage Class

[image]

SQL Data Compare API 12.0.40
FieldMappingBestMatchMessage Class
Members See Also

A message.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FieldMappingBestMatchMessage _
    Inherits MessageBase
C#
public sealed class FieldMappingBestMatchMessage : MessageBase
Visual C++
public ref class FieldMappingBestMatchMessage sealed : public MessageBase

Remarks

See Work for more information.

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.MessageBase
RedGate.SQLCompare.Engine..::.FieldMappingBestMatchMessage

See Also

FieldMappingBestMatchMessage Members
RedGate.SQLCompare.Engine Namespace


FieldMappingBestMatchMessage Members

[image] [image]

SQL Data Compare API 12.0.40
FieldMappingBestMatchMessage Members
FieldMappingBestMatchMessage Class Constructors Methods Fields Properties See Also

The FieldMappingBestMatchMessage type exposes the following members.

Constructors

Name | Description
FieldMappingBestMatchMessage | For internal use only.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from MessageBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_IDatabaseObject | (Inherited from MessageBase.)
m_MessageTypeID | (Inherited from MessageBase.)
m_Severity | (Inherited from MessageBase.)
m_Text | (Inherited from MessageBase.)

Properties

Name | Description
BestMatchedFieldMappings |
DatabaseObject | The database object to which this message belongs. (Inherited from MessageBase.)
HelpURL | (Inherited from MessageBase.)
MessageTypeID | The identifier of the message type. (Inherited from MessageBase.)
Text | (Overrides MessageBase ..::. Text.)
WarningSeverity | The severity of the message or warning. (Inherited from MessageBase.)

See Also

FieldMappingBestMatchMessage Class
RedGate.SQLCompare.Engine Namespace


FieldMappingBestMatchMessage Constructor

[image]

SQL Data Compare API 12.0.40
FieldMappingBestMatchMessage Constructor
FieldMappingBestMatchMessage Class See Also

For internal use only.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    dbobject As IDatabaseObject, _
    bestMatchedFieldMappings As List(Of SqlCompareFieldMapping) _
)
C#
public FieldMappingBestMatchMessage(
    IDatabaseObject dbobject,
    List<SqlCompareFieldMapping> bestMatchedFieldMappings
)
Visual C++
public:
FieldMappingBestMatchMessage(
    IDatabaseObject^ dbobject,
    List<SqlCompareFieldMapping^>^ bestMatchedFieldMappings
)

Parameters

dbobject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The object to which the warning belongs to.
bestMatchedFieldMappings
Type: List<(Of <( SqlCompareFieldMapping >)>)
The list of auto field mappings to warn about.

See Also

FieldMappingBestMatchMessage Class
RedGate.SQLCompare.Engine Namespace


FieldMappingBestMatchMessage Properties

[image] [image]

SQL Data Compare API 12.0.40
FieldMappingBestMatchMessage Properties
FieldMappingBestMatchMessage Class See Also

The FieldMappingBestMatchMessage type exposes the following properties.

Properties

Name | Description
BestMatchedFieldMappings |
DatabaseObject | The database object to which this message belongs. (Inherited from MessageBase.)
HelpURL | (Inherited from MessageBase.)
MessageTypeID | The identifier of the message type. (Inherited from MessageBase.)
Text | (Overrides MessageBase ..::. Text.)
WarningSeverity | The severity of the message or warning. (Inherited from MessageBase.)

See Also

FieldMappingBestMatchMessage Class
RedGate.SQLCompare.Engine Namespace


BestMatchedFieldMappings Property

[image]

SQL Data Compare API 12.0.40
FieldMappingBestMatchMessage..::.BestMatchedFieldMappings Property
FieldMappingBestMatchMessage Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BestMatchedFieldMappings As List(Of SqlCompareFieldMapping)
C#
public List<SqlCompareFieldMapping> BestMatchedFieldMappings { get; set; }
Visual C++
public:
property List<SqlCompareFieldMapping^>^ BestMatchedFieldMappings {
    List<SqlCompareFieldMapping^>^ get ();
    void set (List<SqlCompareFieldMapping^>^ value);
}

See Also

FieldMappingBestMatchMessage Class
RedGate.SQLCompare.Engine Namespace


Text Property

[image]

SQL Data Compare API 12.0.40
FieldMappingBestMatchMessage..::.Text Property
FieldMappingBestMatchMessage Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Text As String
C#
public override string Text { get; }
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
}

Implements

IDeploymentMessageText()()()

See Also

FieldMappingBestMatchMessage Class
RedGate.SQLCompare.Engine Namespace


Fields Class

[image]

SQL Data Compare API 12.0.40
Fields Class
Members See Also

A collection of fields.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Fields _
    Inherits DatabaseObjectCollection(Of IField)
C#
public sealed class Fields : DatabaseObjectCollection<IField>
Visual C++
public ref class Fields sealed : public DatabaseObjectCollection<IField^>

Remarks

A table contains a collection of fields. An index also contains a collection of fields.

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( IField >)>)
RedGate.SQLCompare.Engine..::.DatabaseObjectCollection <(Of <( IField >)>)
RedGate.SQLCompare.Engine..::.Fields

See Also

Fields Members
RedGate.SQLCompare.Engine Namespace


Fields Members

[image] [image]

SQL Data Compare API 12.0.40
Fields Members
Fields Class Methods Fields Properties Explicit Interface Implementations See Also

The Fields type exposes the following members.

Methods

Name | Description
Add | (Overrides DatabaseObjectCollection <(Of <( IField >)>)..::. Add(T).)
AsReadOnly | (Inherited from DatabaseObjectCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from DatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | Get a nicely-formatted object name to display to the user if the Add(T) method throws an argument exception (Inherited from DatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

Fields Class
RedGate.SQLCompare.Engine Namespace


Fields Methods

[image] [image]

SQL Data Compare API 12.0.40
Fields Methods
Fields Class See Also

The Fields type exposes the following methods.

Methods

Name | Description
Add | (Overrides DatabaseObjectCollection <(Of <( IField >)>)..::. Add(T).)
AsReadOnly | (Inherited from DatabaseObjectCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from DatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | Get a nicely-formatted object name to display to the user if the Add(T) method throws an argument exception (Inherited from DatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

Fields Class
RedGate.SQLCompare.Engine Namespace


Add Method

[image]

SQL Data Compare API 12.0.40
Fields..::.Add Method
Fields Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Add ( _
    value As IField _
)
C#
public override void Add(
    IField value
)
Visual C++
public:
virtual void Add(
    IField^ value
) override

Parameters

value
Type: RedGate.SQLCompare.Engine..::.IField

Implements

IKeyedCollectionAdd(UTP)

See Also

Fields Class
RedGate.SQLCompare.Engine Namespace


FileGroups Class

[image]

SQL Data Compare API 12.0.40
FileGroups Class
Members See Also

A collection of filegroups.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FileGroups _
    Inherits InnerList(Of String)
C#
public sealed class FileGroups : InnerList<string>
Visual C++
public ref class FileGroups sealed : public InnerList<String^>

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( T >)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <(String>)>)
RedGate.SQLCompare.Engine..::.FileGroups

See Also

FileGroups Members
RedGate.SQLCompare.Engine Namespace


FileGroups Members

[image] [image]

SQL Data Compare API 12.0.40
FileGroups Members
FileGroups Class Methods Properties Explicit Interface Implementations See Also

The FileGroups type exposes the following members.

Methods

Name | Description
Add | (Overrides InnerList <(Of <(String>)>)..::.Add(UTP).)
Contains | (Inherited from InnerList<(Of <(T>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
Insert | (Overrides InnerList <(Of <(String>)>)..::.Insert(Int32, UTP).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | (Overrides InnerList <(Of <(String>)>)..::. Item[([(Int32])]).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

FileGroups Class
RedGate.SQLCompare.Engine Namespace


FileGroups Methods

[image] [image]

SQL Data Compare API 12.0.40
FileGroups Methods
FileGroups Class See Also

The FileGroups type exposes the following methods.

Methods

Name | Description
Add | (Overrides InnerList <(Of <(String>)>)..::.Add(UTP).)
Contains | (Inherited from InnerList<(Of <(T>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
Insert | (Overrides InnerList <(Of <(String>)>)..::.Insert(Int32, UTP).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

FileGroups Class
RedGate.SQLCompare.Engine Namespace


Add Method

[image]

SQL Data Compare API 12.0.40
FileGroups..::.Add Method
FileGroups Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Add ( _
    item As String _
)
C#
public override void Add(
    string item
)
Visual C++
public:
virtual void Add(
    String^ item
) override

Parameters

item
Type: String

See Also

FileGroups Class
RedGate.SQLCompare.Engine Namespace


Insert Method

[image]

SQL Data Compare API 12.0.40
FileGroups..::.Insert Method
FileGroups Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Insert ( _
    index As Integer, _
    item As String _
)
C#
public override void Insert(
    int index,
    string item
)
Visual C++
public:
virtual void Insert(
    int index,
    String^ item
) override

Parameters

index
Type: Int32
item
Type: String

Implements

IListInsert(Int32, UTP)

See Also

FileGroups Class
RedGate.SQLCompare.Engine Namespace


FileGroups Properties

[image] [image]

SQL Data Compare API 12.0.40
FileGroups Properties
FileGroups Class See Also

The FileGroups type exposes the following properties.

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | (Overrides InnerList <(Of <(String>)>)..::. Item[([(Int32])]).)

See Also

FileGroups Class
RedGate.SQLCompare.Engine Namespace


Item Property

[image]

SQL Data Compare API 12.0.40
FileGroups..::.Item Property
FileGroups Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Default Property Item ( _
    index As Integer _
) As String
C#
public override string this[
    int index
] { get; set; }
Visual C++
public:
virtual property String^ default[int index] {
    String^ get (int index) override;
    void set (int index, String^ value) override;
}

Parameters

index
Type: Int32

Implements

IListItem(Int32)

See Also

FileGroups Class
RedGate.SQLCompare.Engine Namespace


FileTable Class

[image]

SQL Data Compare API 12.0.40
FileTable Class
Members See Also

Filetables are a new feature in 2012 that provide a filestream view of a folder/file hierarchy.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class FileTable _
    Inherits Table
C#
public class FileTable : Table
Visual C++
public ref class FileTable : public Table

Remarks

They're basically just regular tables, except that all of the default schema is set in stone, while the user can add extra constraints, triggers and so on. We need to be able to compare the added stuff while making sure that the default stuff is not changed. So we just pretend that the system-defined objects don't exist. This is done by overriding the collections for these objects to filter out system-defined objects - note that this means that any operations that manipulate the object lists such as adding or sorting items must use eg the AllIndexes property instead. This only really affects DatabaseFactory/ReadFromFolder* This might be improved by, instead of hiding the fields everywhere and whitelisting places we need them, having the fields exist as normal, and the deployment code filter them out where they aren't needed. This has the advantage of making the FileTable code happen in places such as FileTable.GetSQL and methods specifically related to FileTables rather than arbitrarily scattered across the codebase. Filetables can also only be created using AS FILETABLE rather than constructing the default schema explicitely, so we need to take that into account if we try and rebuild one I'm not sure if we need to worry about making sure the database is set up for filestream/filegroup stuff if we're deploying to a database that doesn't have those

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.SchemaObjectWithAuthorization
RedGate.SQLCompare.Engine..::.ViewTableSuperClass
RedGate.SQLCompare.Engine..::.Table
RedGate.SQLCompare.Engine..::.FileTable

See Also

FileTable Members
RedGate.SQLCompare.Engine Namespace


FileTable Members

[image] [image]

SQL Data Compare API 12.0.40
FileTable Members
FileTable Class Methods Fields Properties Explicit Interface Implementations See Also

The FileTable type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLockEscalationSql | (Inherited from Table.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Inherited from Table.)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Fields

Name | Description
m_Fields | Fields. (Inherited from ViewTableSuperClass.)
m_Indexes | Indexes. (Inherited from ViewTableSuperClass.)
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)
UnknownDirName | This is a hack to make backup support partially work - the dirname/collation don't seem to be accessible with the current backup reader but we can at least compare the other stuff
UnknownFilenameCollation |

Properties

Name | Description
AllCheckConstraints |
AllFields |
AllForeignKeys |
AllIndexes |
AlterAuthorizationClassType | (Inherited from SchemaObjectWithAuthorization.)
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
CatalogUsedForFullTextIndex | The full-text catalog used for the full-text index defined on the table or view (Inherited from ViewTableSuperClass.)
ChangeTracking | Whether change tracking is enabled for this table. This is a SQL Server 2008 feature. (Inherited from Table.)
ChangeTrackingScriptSource | The script source for any ALTER TABLE CHANGE_TRACKING statement. (Inherited from Table.)
CheckConstraints | (Overrides Table ..::. CheckConstraints.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
DataCompressionPartitions | The partitions on which the table compression is set. This is a SQL Server 2008 feature. (Inherited from Table.)
DataCompressionPartitionsInternal | The partitions on which the table compression is set. This is a SQL Server 2008 feature. The internal version gives you direct access to the list that is stored. If there is no important information in the list it is not stored! (Inherited from Table.)
Durability | (Inherited from Table.)
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
Fields | (Overrides ViewTableSuperClass ..::. Fields.)
FileGroup | The filegroup on which the table is defined. (Inherited from Table.)
FilestreamFileGroup | The filegroup on which the filestreams of the table are to be stored. (Inherited from Table.)
ForeignKeys | (Overrides Table ..::. ForeignKeys.)
FullTextCatalogNameFromSerialization | (Inherited from ViewTableSuperClass.)
FullTextChangeTracking | The change tracking setting for the full text index. (Inherited from ViewTableSuperClass.)
FullTextSearchPropertyList | The search property list attached the full-text index (if both exist) (Inherited from ViewTableSuperClass.)
FullTextSPLNameFromSerialization | Name (Inherited from ViewTableSuperClass.)
FullTextStoplist | The user-defined stoplist for the full text index on the table or view. (Inherited from ViewTableSuperClass.)
FullTextStoplistNameFromSerialization | (Inherited from ViewTableSuperClass.)
FullTextStoplistType | The stoplist type used for the full text index on the table or view. (Inherited from ViewTableSuperClass.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
HasFullTextIndex | True if the table or view has a full-text index defined on it (Inherited from ViewTableSuperClass.)
Indexes | (Overrides ViewTableSuperClass ..::. Indexes.)
IsColumnstoreIndexed | Returns true iff the table has a columnstore index defined on it. (Inherited from ViewTableSuperClass.)
IsMemoryOptimized | (Inherited from Table.)
IsPartitioned | Indicates whether the table is partitioned. This is a SQL Server 2005 feature. (Inherited from Table.)
KeyIndexForFullTextIndex | The key index for the full-text index on the table or view. (Inherited from ViewTableSuperClass.)
LastModified | The time of the last change to this table's schema. (Inherited from Table.)
LockEscalation | (Inherited from Table.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Table (Inherited from Table.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
PartitionedField | Indicates the field over which the table is partitioned. This is a SQL Server 2005 feature. (Inherited from Table.)
PartitionScheme | The partition scheme for this table. This is a SQL Server 2005 feature. (Inherited from Table.)
Permissions | (Inherited from SchemaObjectWithAuthorization.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
RemoteDataArchiveState | (Inherited from Table.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSourceForFullTextTable | The location of the creation script for the fulltext table statement for this table or view if the database source is set to scripts folder. (Inherited from ViewTableSuperClass.)
ScriptSources | (Inherited from Table.)
ShouldWriteFileGroupOrPartitionScheme | (Inherited from Table.)
TextFileGroup | The filegroup on which the text in the table is defined. (Inherited from Table.)
Triggers | The triggers defined on the table or view. (Inherited from ViewTableSuperClass.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith | (Inherited from Table.)

See Also

FileTable Class
RedGate.SQLCompare.Engine Namespace


FileTable Fields

[image] [image]

SQL Data Compare API 12.0.40
FileTable Fields
FileTable Class See Also

The FileTable type exposes the following fields.

Fields

Name | Description
m_Fields | Fields. (Inherited from ViewTableSuperClass.)
m_Indexes | Indexes. (Inherited from ViewTableSuperClass.)
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)
UnknownDirName | This is a hack to make backup support partially work - the dirname/collation don't seem to be accessible with the current backup reader but we can at least compare the other stuff
UnknownFilenameCollation |

See Also

FileTable Class
RedGate.SQLCompare.Engine Namespace


UnknownDirName Field

[image]

SQL Data Compare API 12.0.40
FileTable..::.UnknownDirName Field
FileTable Class See Also

This is a hack to make backup support partially work - the dirname/collation don't seem to be accessible with the current backup reader but we can at least compare the other stuff

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Const UnknownDirName As String
C#
public const string UnknownDirName
Visual C++
public:
literal String^ UnknownDirName

See Also

FileTable Class
RedGate.SQLCompare.Engine Namespace


UnknownFilenameCollation Field

[image]

SQL Data Compare API 12.0.40
FileTable..::.UnknownFilenameCollation Field
FileTable Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Const UnknownFilenameCollation As String
C#
public const string UnknownFilenameCollation
Visual C++
public:
literal String^ UnknownFilenameCollation

See Also

FileTable Class
RedGate.SQLCompare.Engine Namespace


FileTable Methods

[image] [image]

SQL Data Compare API 12.0.40
FileTable Methods
FileTable Class See Also

The FileTable type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLockEscalationSql | (Inherited from Table.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Inherited from Table.)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith | (Inherited from Table.)

See Also

FileTable Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
FileTable..::.Equals Method
FileTable Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | (Overrides Table ..::. Equals(IDatabaseObject, Options).)

See Also

FileTable Class
FileTable Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
FileTable..::.Equals Method (IDatabaseObject, Options)
FileTable Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

FileTable Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


FileTable Properties

[image] [image]

SQL Data Compare API 12.0.40
FileTable Properties
FileTable Class See Also

The FileTable type exposes the following properties.

Properties

Name | Description
AllCheckConstraints |
AllFields |
AllForeignKeys |
AllIndexes |
AlterAuthorizationClassType | (Inherited from SchemaObjectWithAuthorization.)
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
CatalogUsedForFullTextIndex | The full-text catalog used for the full-text index defined on the table or view (Inherited from ViewTableSuperClass.)
ChangeTracking | Whether change tracking is enabled for this table. This is a SQL Server 2008 feature. (Inherited from Table.)
ChangeTrackingScriptSource | The script source for any ALTER TABLE CHANGE_TRACKING statement. (Inherited from Table.)
CheckConstraints | (Overrides Table ..::. CheckConstraints.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
DataCompressionPartitions | The partitions on which the table compression is set. This is a SQL Server 2008 feature. (Inherited from Table.)
DataCompressionPartitionsInternal | The partitions on which the table compression is set. This is a SQL Server 2008 feature. The internal version gives you direct access to the list that is stored. If there is no important information in the list it is not stored! (Inherited from Table.)
Durability | (Inherited from Table.)
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
Fields | (Overrides ViewTableSuperClass ..::. Fields.)
FileGroup | The filegroup on which the table is defined. (Inherited from Table.)
FilestreamFileGroup | The filegroup on which the filestreams of the table are to be stored. (Inherited from Table.)
ForeignKeys | (Overrides Table ..::. ForeignKeys.)
FullTextCatalogNameFromSerialization | (Inherited from ViewTableSuperClass.)
FullTextChangeTracking | The change tracking setting for the full text index. (Inherited from ViewTableSuperClass.)
FullTextSearchPropertyList | The search property list attached the full-text index (if both exist) (Inherited from ViewTableSuperClass.)
FullTextSPLNameFromSerialization | Name (Inherited from ViewTableSuperClass.)
FullTextStoplist | The user-defined stoplist for the full text index on the table or view. (Inherited from ViewTableSuperClass.)
FullTextStoplistNameFromSerialization | (Inherited from ViewTableSuperClass.)
FullTextStoplistType | The stoplist type used for the full text index on the table or view. (Inherited from ViewTableSuperClass.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
HasFullTextIndex | True if the table or view has a full-text index defined on it (Inherited from ViewTableSuperClass.)
Indexes | (Overrides ViewTableSuperClass ..::. Indexes.)
IsColumnstoreIndexed | Returns true iff the table has a columnstore index defined on it. (Inherited from ViewTableSuperClass.)
IsMemoryOptimized | (Inherited from Table.)
IsPartitioned | Indicates whether the table is partitioned. This is a SQL Server 2005 feature. (Inherited from Table.)
KeyIndexForFullTextIndex | The key index for the full-text index on the table or view. (Inherited from ViewTableSuperClass.)
LastModified | The time of the last change to this table's schema. (Inherited from Table.)
LockEscalation | (Inherited from Table.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Table (Inherited from Table.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
PartitionedField | Indicates the field over which the table is partitioned. This is a SQL Server 2005 feature. (Inherited from Table.)
PartitionScheme | The partition scheme for this table. This is a SQL Server 2005 feature. (Inherited from Table.)
Permissions | (Inherited from SchemaObjectWithAuthorization.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
RemoteDataArchiveState | (Inherited from Table.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSourceForFullTextTable | The location of the creation script for the fulltext table statement for this table or view if the database source is set to scripts folder. (Inherited from ViewTableSuperClass.)
ScriptSources | (Inherited from Table.)
ShouldWriteFileGroupOrPartitionScheme | (Inherited from Table.)
TextFileGroup | The filegroup on which the text in the table is defined. (Inherited from Table.)
Triggers | The triggers defined on the table or view. (Inherited from ViewTableSuperClass.)

See Also

FileTable Class
RedGate.SQLCompare.Engine Namespace


AllCheckConstraints Property

[image]

SQL Data Compare API 12.0.40
FileTable..::.AllCheckConstraints Property
FileTable Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AllCheckConstraints As CheckConstraints
C#
public CheckConstraints AllCheckConstraints { get; }
Visual C++
public:
property CheckConstraints^ AllCheckConstraints {
    CheckConstraints^ get ();
}

See Also

FileTable Class
RedGate.SQLCompare.Engine Namespace


AllFields Property

[image]

SQL Data Compare API 12.0.40
FileTable..::.AllFields Property
FileTable Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AllFields As Fields
C#
public Fields AllFields { get; }
Visual C++
public:
property Fields^ AllFields {
    Fields^ get ();
}

See Also

FileTable Class
RedGate.SQLCompare.Engine Namespace


AllForeignKeys Property

[image]

SQL Data Compare API 12.0.40
FileTable..::.AllForeignKeys Property
FileTable Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AllForeignKeys As ForeignKeys
C#
public ForeignKeys AllForeignKeys { get; }
Visual C++
public:
property ForeignKeys^ AllForeignKeys {
    ForeignKeys^ get ();
}

See Also

FileTable Class
RedGate.SQLCompare.Engine Namespace


AllIndexes Property

[image]

SQL Data Compare API 12.0.40
FileTable..::.AllIndexes Property
FileTable Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AllIndexes As Indexes
C#
public Indexes AllIndexes { get; }
Visual C++
public:
property Indexes^ AllIndexes {
    Indexes^ get ();
}

See Also

FileTable Class
RedGate.SQLCompare.Engine Namespace


CheckConstraints Property

[image]

SQL Data Compare API 12.0.40
FileTable..::.CheckConstraints Property
FileTable Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CheckConstraints As CheckConstraints
C#
public override CheckConstraints CheckConstraints { get; }
Visual C++
public:
virtual property CheckConstraints^ CheckConstraints {
    CheckConstraints^ get () override;
}

See Also

FileTable Class
RedGate.SQLCompare.Engine Namespace


Fields Property

[image]

SQL Data Compare API 12.0.40
FileTable..::.Fields Property
FileTable Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property Fields As Fields
C#
public override Fields Fields { get; protected internal set; }
Visual C++
public:
virtual property Fields^ Fields {
    Fields^ get () override;
    void set (Fields^ value) override;
}

See Also

FileTable Class
RedGate.SQLCompare.Engine Namespace


ForeignKeys Property

[image]

SQL Data Compare API 12.0.40
FileTable..::.ForeignKeys Property
FileTable Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ForeignKeys As ForeignKeys
C#
public override ForeignKeys ForeignKeys { get; }
Visual C++
public:
virtual property ForeignKeys^ ForeignKeys {
    ForeignKeys^ get () override;
}

See Also

FileTable Class
RedGate.SQLCompare.Engine Namespace


Indexes Property

[image]

SQL Data Compare API 12.0.40
FileTable..::.Indexes Property
FileTable Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Indexes As Indexes
C#
public override Indexes Indexes { get; }
Visual C++
public:
virtual property Indexes^ Indexes {
    Indexes^ get () override;
}

See Also

FileTable Class
RedGate.SQLCompare.Engine Namespace


FlatFieldList Class

[image]

SQL Data Compare API 12.0.40
FlatFieldList Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FlatFieldList _
    Inherits InnerList(Of IField)
C#
public sealed class FlatFieldList : InnerList<IField>
Visual C++
public ref class FlatFieldList sealed : public InnerList<IField^>

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( T >)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( IField >)>)
RedGate.SQLCompare.Engine..::.FlatFieldList

See Also

FlatFieldList Members
RedGate.SQLCompare.Engine Namespace


FlatFieldList Members

[image] [image]

SQL Data Compare API 12.0.40
FlatFieldList Members
FlatFieldList Class Constructors Methods Properties Explicit Interface Implementations See Also

The FlatFieldList type exposes the following members.

Constructors

Name | Description
FlatFieldList |

Methods

Name | Description
Contains | (Inherited from InnerList<(Of <(T>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | (Inherited from InnerList<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

FlatFieldList Class
RedGate.SQLCompare.Engine Namespace


FlatFieldList Constructor

[image]

SQL Data Compare API 12.0.40
FlatFieldList Constructor
FlatFieldList Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FlatFieldList()
Visual C++
public:
FlatFieldList()

See Also

FlatFieldList Class
RedGate.SQLCompare.Engine Namespace


ForeignKey Class

[image]

SQL Data Compare API 12.0.40
ForeignKey Class
Members See Also

A foreign key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ForeignKey _
    Implements IDatabaseObject, ITSqlObject, ICanExistenceCheck, IHasScriptSource,  _
    IPatchUpAfterDeserialization
C#
public sealed class ForeignKey : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck, IHasScriptSource, IPatchUpAfterDeserialization
Visual C++
public ref class ForeignKey sealed : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck, IHasScriptSource, IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ForeignKey

See Also

ForeignKey Members
RedGate.SQLCompare.Engine Namespace


ForeignKey Members

[image] [image]

SQL Data Compare API 12.0.40
ForeignKey Members
ForeignKey Class Methods Properties See Also

The ForeignKey type exposes the following members.

Methods

Name | Description
CompareWith |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Database | Obsolete. Unused
DeleteCascade | Obsolete. True if the foreign key is marked as on delete cascade.
DeleteReferentialAction | The referential action in case of a delete.
Disabled | True if the foreign key is disabled (it is set to NOCHECK).
Fields | The fields in the foreign key.
FullyQualifiedName |
Name | The name of the foreign key.
NoCheck | True if the foreign key is not trusted (it was created using WITH NOCHECK).
NotForReplication | True if the foreign key is marked as not for replication.
ObjectType | Obsolete. Unused
Owner |
QualifiedName | Obsolete. Unused
ReferencedFieldNames | The names of the fields referenced by the foreign key.
ReferencedFields | The fields referenced by the foreign key, or an empty collection if they could not be bound (in the case of a scripts folder register or a deserialization)
ReferencedTable | The table referenced by the foreign key.
ReferencedTableFullyQualifiedName | The fully-qualified name of the table referenced by the foreign key.
ScriptSource | The location of the creation script for object if the database source is set to scripts folder.
ScriptSourceNocheck | The location of any ALTER TABLE ... NOCHECK CONSTRAINT commands on the foreign key.
SystemNamed |
UpdateCascade | Obsolete. True if the foreign key is marked as on update cascade.
UpdateReferentialAction | The referential action in case of an update.

See Also

ForeignKey Class
RedGate.SQLCompare.Engine Namespace


ForeignKey Methods

[image] [image]

SQL Data Compare API 12.0.40
ForeignKey Methods
ForeignKey Class See Also

The ForeignKey type exposes the following methods.

Methods

Name | Description
CompareWith |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ForeignKey Class
RedGate.SQLCompare.Engine Namespace


CompareWith Method

[image]

SQL Data Compare API 12.0.40
ForeignKey..::.CompareWith Method
ForeignKey Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareWith ( _
    other As ForeignKey, _
    options As Options _
) As IEnumerable(Of EqualityDifference)
C#
public IEnumerable<EqualityDifference> CompareWith(
    ForeignKey other,
    Options options
)
Visual C++
public:
IEnumerable<EqualityDifference^>^ CompareWith(
    ForeignKey^ other,
    Options options
)

Parameters

other
Type: RedGate.SQLCompare.Engine..::.ForeignKey
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

ForeignKey Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
ForeignKey..::.Equals Method
ForeignKey Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(ForeignKey, Options) | Compares the foreign key with a specified foreign key.
Equals(IDatabaseObject, Options) |

See Also

ForeignKey Class
ForeignKey Members
RedGate.SQLCompare.Engine Namespace


Equals Method (ForeignKey, Options)

[image]

SQL Data Compare API 12.0.40
ForeignKey..::.Equals Method (ForeignKey, Options)
ForeignKey Class See Also

Compares the foreign key with a specified foreign key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    value As ForeignKey, _
    options As Options _
) As Boolean
C#
public bool Equals(
    ForeignKey value,
    Options options
)
Visual C++
public:
bool Equals(
    ForeignKey^ value,
    Options options
)

Parameters

value
Type: RedGate.SQLCompare.Engine..::.ForeignKey
The foreign key to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
The comparison options.

Return Value

True if the foreign keys are identical; otherwise, false.

See Also

ForeignKey Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
ForeignKey..::.Equals Method (IDatabaseObject, Options)
ForeignKey Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) sealed

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

ForeignKey Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
ForeignKey..::.PatchUpAfterDeserialization Method
ForeignKey Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

ForeignKey Class
RedGate.SQLCompare.Engine Namespace


ForeignKey Properties

[image] [image]

SQL Data Compare API 12.0.40
ForeignKey Properties
ForeignKey Class See Also

The ForeignKey type exposes the following properties.

Properties

Name | Description
Database | Obsolete. Unused
DeleteCascade | Obsolete. True if the foreign key is marked as on delete cascade.
DeleteReferentialAction | The referential action in case of a delete.
Disabled | True if the foreign key is disabled (it is set to NOCHECK).
Fields | The fields in the foreign key.
FullyQualifiedName |
Name | The name of the foreign key.
NoCheck | True if the foreign key is not trusted (it was created using WITH NOCHECK).
NotForReplication | True if the foreign key is marked as not for replication.
ObjectType | Obsolete. Unused
Owner |
QualifiedName | Obsolete. Unused
ReferencedFieldNames | The names of the fields referenced by the foreign key.
ReferencedFields | The fields referenced by the foreign key, or an empty collection if they could not be bound (in the case of a scripts folder register or a deserialization)
ReferencedTable | The table referenced by the foreign key.
ReferencedTableFullyQualifiedName | The fully-qualified name of the table referenced by the foreign key.
ScriptSource | The location of the creation script for object if the database source is set to scripts folder.
ScriptSourceNocheck | The location of any ALTER TABLE ... NOCHECK CONSTRAINT commands on the foreign key.
SystemNamed |
UpdateCascade | Obsolete. True if the foreign key is marked as on update cascade.
UpdateReferentialAction | The referential action in case of an update.

See Also

ForeignKey Class
RedGate.SQLCompare.Engine Namespace


Database Property

[image]

SQL Data Compare API 12.0.40
ForeignKey..::.Database Property
ForeignKey Class See Also

Unused

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Unused", True)> _
Public ReadOnly Property Database As Database
C#
[ObsoleteAttribute("Unused", true)]
public Database Database { get; }
Visual C++
[ObsoleteAttribute(L"Unused", true)]
public:
virtual property Database^ Database {
    Database^ get () sealed;
}

Implements

IDatabaseObject..::.Database

See Also

ForeignKey Class
RedGate.SQLCompare.Engine Namespace


DeleteCascade Property

[image]

SQL Data Compare API 12.0.40
ForeignKey..::.DeleteCascade Property
ForeignKey Class See Also

True if the foreign key is marked as on delete cascade.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Use DeleteReferentialAction.", False)> _
Public ReadOnly Property DeleteCascade As Boolean
C#
[ObsoleteAttribute("Use DeleteReferentialAction.", false)]
public bool DeleteCascade { get; }
Visual C++
[ObsoleteAttribute(L"Use DeleteReferentialAction.", false)]
public:
property bool DeleteCascade {
    bool get ();
}

See Also

ForeignKey Class
RedGate.SQLCompare.Engine Namespace


DeleteReferentialAction Property

[image]

SQL Data Compare API 12.0.40
ForeignKey..::.DeleteReferentialAction Property
ForeignKey Class See Also

The referential action in case of a delete.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DeleteReferentialAction As ReferentialAction
C#
public ReferentialAction DeleteReferentialAction { get; internal set; }
Visual C++
public:
property ReferentialAction DeleteReferentialAction {
    ReferentialAction get ();
    void set (ReferentialAction value);
}

See Also

ForeignKey Class
RedGate.SQLCompare.Engine Namespace


Disabled Property

[image]

SQL Data Compare API 12.0.40
ForeignKey..::.Disabled Property
ForeignKey Class See Also

True if the foreign key is disabled (it is set to NOCHECK).

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Disabled As Boolean
C#
public bool Disabled { get; internal set; }
Visual C++
public:
property bool Disabled {
    bool get ();
    void set (bool value);
}

See Also

ForeignKey Class
RedGate.SQLCompare.Engine Namespace


Fields Property

[image]

SQL Data Compare API 12.0.40
ForeignKey..::.Fields Property
ForeignKey Class See Also

The fields in the foreign key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Fields As Fields
C#
public Fields Fields { get; private set; }
Visual C++
public:
property Fields^ Fields {
    Fields^ get ();
    void set (Fields^ value);
}

See Also

ForeignKey Class
RedGate.SQLCompare.Engine Namespace


FullyQualifiedName Property

[image]

SQL Data Compare API 12.0.40
ForeignKey..::.FullyQualifiedName Property
ForeignKey Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullyQualifiedName As String
C#
public string FullyQualifiedName { get; }
Visual C++
public:
virtual property String^ FullyQualifiedName {
    String^ get () sealed;
}

Implements

ITSqlObjectFullyQualifiedName()()()

See Also

ForeignKey Class
RedGate.SQLCompare.Engine Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
ForeignKey..::.Name Property
ForeignKey Class See Also

The name of the foreign key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; internal set; }
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ITSqlObjectName()()()

See Also

ForeignKey Class
RedGate.SQLCompare.Engine Namespace


NoCheck Property

[image]

SQL Data Compare API 12.0.40
ForeignKey..::.NoCheck Property
ForeignKey Class See Also

True if the foreign key is not trusted (it was created using WITH NOCHECK).

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NoCheck As Boolean
C#
public bool NoCheck { get; internal set; }
Visual C++
public:
property bool NoCheck {
    bool get ();
    void set (bool value);
}

See Also

ForeignKey Class
RedGate.SQLCompare.Engine Namespace


NotForReplication Property

[image]

SQL Data Compare API 12.0.40
ForeignKey..::.NotForReplication Property
ForeignKey Class See Also

True if the foreign key is marked as not for replication.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NotForReplication As Boolean
C#
public bool NotForReplication { get; internal set; }
Visual C++
public:
property bool NotForReplication {
    bool get ();
    void set (bool value);
}

See Also

ForeignKey Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
ForeignKey..::.ObjectType Property
ForeignKey Class See Also

Unused

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Unused", True)> _
Public ReadOnly Property ObjectType As ObjectType
C#
[ObsoleteAttribute("Unused", true)]
public ObjectType ObjectType { get; }
Visual C++
[ObsoleteAttribute(L"Unused", true)]
public:
virtual property ObjectType ObjectType {
    ObjectType get () sealed;
}

Implements

ITSqlObjectObjectType()()()

See Also

ForeignKey Class
RedGate.SQLCompare.Engine Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
ForeignKey..::.Owner Property
ForeignKey Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Owner As String
C#
public string Owner { get; }
Visual C++
public:
virtual property String^ Owner {
    String^ get () sealed;
}

Implements

ITSqlObjectOwner()()()

See Also

ForeignKey Class
RedGate.SQLCompare.Engine Namespace


QualifiedName Property

[image]

SQL Data Compare API 12.0.40
ForeignKey..::.QualifiedName Property
ForeignKey Class See Also

Unused

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Unused", True)> _
Public ReadOnly Property QualifiedName As String
C#
[ObsoleteAttribute("Unused", true)]
public string QualifiedName { get; }
Visual C++
[ObsoleteAttribute(L"Unused", true)]
public:
virtual property String^ QualifiedName {
    String^ get () sealed;
}

Implements

ITSqlObjectQualifiedName()()()

See Also

ForeignKey Class
RedGate.SQLCompare.Engine Namespace


ReferencedFieldNames Property

[image]

SQL Data Compare API 12.0.40
ForeignKey..::.ReferencedFieldNames Property
ForeignKey Class See Also

The names of the fields referenced by the foreign key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ReferencedFieldNames As SerializableCollectionString
C#
public SerializableCollectionString ReferencedFieldNames { get; private set; }
Visual C++
public:
property SerializableCollectionString^ ReferencedFieldNames {
    SerializableCollectionString^ get ();
    void set (SerializableCollectionString^ value);
}

See Also

ForeignKey Class
RedGate.SQLCompare.Engine Namespace
ForeignKey..::.ReferencedFields


ReferencedFields Property

[image]

SQL Data Compare API 12.0.40
ForeignKey..::.ReferencedFields Property
ForeignKey Class See Also

The fields referenced by the foreign key, or an empty collection if they could not be bound (in the case of a scripts folder register or a deserialization)

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReferencedFields As Fields
C#
public Fields ReferencedFields { get; }
Visual C++
public:
property Fields^ ReferencedFields {
    Fields^ get ();
}

See Also

ForeignKey Class
RedGate.SQLCompare.Engine Namespace
ForeignKey..::.ReferencedFieldNames


ReferencedTable Property

[image]

SQL Data Compare API 12.0.40
ForeignKey..::.ReferencedTable Property
ForeignKey Class See Also

The table referenced by the foreign key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReferencedTable As Table
C#
public Table ReferencedTable { get; }
Visual C++
public:
property Table^ ReferencedTable {
    Table^ get ();
}

Return Value

null if we've been deserialized or read from a script folder, and couldn't find a definition of our ReferencedTable

See Also

ForeignKey Class
RedGate.SQLCompare.Engine Namespace
ForeignKey..::.ReferencedTableFullyQualifiedName


ReferencedTableFullyQualifiedName Property

[image]

SQL Data Compare API 12.0.40
ForeignKey..::.ReferencedTableFullyQualifiedName Property
ForeignKey Class See Also

The fully-qualified name of the table referenced by the foreign key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReferencedTableFullyQualifiedName As String
C#
public string ReferencedTableFullyQualifiedName { get; }
Visual C++
public:
property String^ ReferencedTableFullyQualifiedName {
    String^ get ();
}

Remarks

May be in a non-canonical case if we've been deserialized or read from a scripts folder and couldn't find a definition of our ReferencedTable

See Also

ForeignKey Class
RedGate.SQLCompare.Engine Namespace
ForeignKey..::.ReferencedTable


ScriptSource Property

[image]

SQL Data Compare API 12.0.40
ForeignKey..::.ScriptSource Property
ForeignKey Class See Also

The location of the creation script for object if the database source is set to scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSource As ScriptSource
C#
public ScriptSource ScriptSource { get; internal set; }
Visual C++
public:
virtual property ScriptSource^ ScriptSource {
    ScriptSource^ get () sealed;
    void set (ScriptSource^ value) sealed;
}

Implements

IHasScriptSource..::.ScriptSource

See Also

ForeignKey Class
RedGate.SQLCompare.Engine Namespace


ScriptSourceNocheck Property

[image]

SQL Data Compare API 12.0.40
ForeignKey..::.ScriptSourceNocheck Property
ForeignKey Class See Also

The location of any ALTER TABLE ... NOCHECK CONSTRAINT commands on the foreign key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSourceNocheck As ScriptSource
C#
public ScriptSource ScriptSourceNocheck { get; internal set; }
Visual C++
public:
property ScriptSource^ ScriptSourceNocheck {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

ForeignKey Class
RedGate.SQLCompare.Engine Namespace


SystemNamed Property

[image]

SQL Data Compare API 12.0.40
ForeignKey..::.SystemNamed Property
ForeignKey Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SystemNamed As Boolean
C#
public bool SystemNamed { get; set; }
Visual C++
public:
virtual property bool SystemNamed {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

ForeignKey Class
RedGate.SQLCompare.Engine Namespace


UpdateCascade Property

[image]

SQL Data Compare API 12.0.40
ForeignKey..::.UpdateCascade Property
ForeignKey Class See Also

True if the foreign key is marked as on update cascade.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Use UpdateReferentialAction.", False)> _
Public ReadOnly Property UpdateCascade As Boolean
C#
[ObsoleteAttribute("Use UpdateReferentialAction.", false)]
public bool UpdateCascade { get; }
Visual C++
[ObsoleteAttribute(L"Use UpdateReferentialAction.", false)]
public:
property bool UpdateCascade {
    bool get ();
}

See Also

ForeignKey Class
RedGate.SQLCompare.Engine Namespace


UpdateReferentialAction Property

[image]

SQL Data Compare API 12.0.40
ForeignKey..::.UpdateReferentialAction Property
ForeignKey Class See Also

The referential action in case of an update.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UpdateReferentialAction As ReferentialAction
C#
public ReferentialAction UpdateReferentialAction { get; internal set; }
Visual C++
public:
property ReferentialAction UpdateReferentialAction {
    ReferentialAction get ();
    void set (ReferentialAction value);
}

See Also

ForeignKey Class
RedGate.SQLCompare.Engine Namespace


ForeignKeyChangesCalculator Class

[image]

SQL Data Compare API 12.0.40
ForeignKeyChangesCalculator Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ForeignKeyChangesCalculator
C#
public class ForeignKeyChangesCalculator
Visual C++
public ref class ForeignKeyChangesCalculator

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ForeignKeyChangesCalculator

See Also

ForeignKeyChangesCalculator Members
RedGate.SQLCompare.Engine Namespace


ForeignKeyChangesCalculator Members

[image] [image]

SQL Data Compare API 12.0.40
ForeignKeyChangesCalculator Members
ForeignKeyChangesCalculator Class Constructors Methods See Also

The ForeignKeyChangesCalculator type exposes the following members.

Constructors

Name | Description
ForeignKeyChangesCalculator |

Methods

Name | Description
AddForeignKeys |
CalculateWorkTableForeignKeys |
DropForeignKeys |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ForeignKeyChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


ForeignKeyChangesCalculator Constructor

[image]

SQL Data Compare API 12.0.40
ForeignKeyChangesCalculator Constructor
ForeignKeyChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    dependenciesCollector As DependenciesCollector, _
    differences As Differences, _
    foreignKeysChanges As ForeignKeysChanges, _
    extendedProperties As ExtendedPropertiesChanges _
)
C#
public ForeignKeyChangesCalculator(
    DependenciesCollector dependenciesCollector,
    Differences differences,
    ForeignKeysChanges foreignKeysChanges,
    ExtendedPropertiesChanges extendedProperties
)
Visual C++
public:
ForeignKeyChangesCalculator(
    DependenciesCollector^ dependenciesCollector,
    Differences^ differences,
    ForeignKeysChanges^ foreignKeysChanges,
    ExtendedPropertiesChanges^ extendedProperties
)

Parameters

dependenciesCollector
Type: RedGate.SQLCompare.Engine..::.DependenciesCollector
differences
Type: RedGate.SQLCompare.Engine..::.Differences
foreignKeysChanges
Type: RedGate.SQLCompare.Engine..::.ForeignKeysChanges
extendedProperties
Type: RedGate.SQLCompare.Engine..::.ExtendedPropertiesChanges

See Also

ForeignKeyChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


ForeignKeyChangesCalculator Methods

[image] [image]

SQL Data Compare API 12.0.40
ForeignKeyChangesCalculator Methods
ForeignKeyChangesCalculator Class See Also

The ForeignKeyChangesCalculator type exposes the following methods.

Methods

Name | Description
AddForeignKeys |
CalculateWorkTableForeignKeys |
DropForeignKeys |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ForeignKeyChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


AddForeignKeys Method

[image]

SQL Data Compare API 12.0.40
ForeignKeyChangesCalculator..::.AddForeignKeys Method
ForeignKeyChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddForeignKeys ( _
    foreignKeys As ForeignKeys _
)
C#
public void AddForeignKeys(
    ForeignKeys foreignKeys
)
Visual C++
public:
void AddForeignKeys(
    ForeignKeys^ foreignKeys
)

Parameters

foreignKeys
Type: RedGate.SQLCompare.Engine..::.ForeignKeys

See Also

ForeignKeyChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


CalculateWorkTableForeignKeys Method

[image]

SQL Data Compare API 12.0.40
ForeignKeyChangesCalculator..::.CalculateWorkTableForeignKeys Method
ForeignKeyChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculateWorkTableForeignKeys ( _
    sourceTable As Table, _
    targetTable As Table, _
    targetDatabase As IDatabase, _
    options As Options, _
    needToForceTableBodyAlter As Boolean _
)
C#
public void CalculateWorkTableForeignKeys(
    Table sourceTable,
    Table targetTable,
    IDatabase targetDatabase,
    Options options,
    bool needToForceTableBodyAlter
)
Visual C++
public:
void CalculateWorkTableForeignKeys(
    Table^ sourceTable,
    Table^ targetTable,
    IDatabase^ targetDatabase,
    Options options,
    bool needToForceTableBodyAlter
)

Parameters

sourceTable
Type: RedGate.SQLCompare.Engine..::.Table
targetTable
Type: RedGate.SQLCompare.Engine..::.Table
targetDatabase
Type: RedGate.SQLCompare.Engine..::.IDatabase
options
Type: RedGate.SQLCompare.Engine..::.Options
needToForceTableBodyAlter
Type: Boolean
Used when the target is a scripts folder. This forces many extra creates for the implicit fks.

See Also

ForeignKeyChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


DropForeignKeys Method

[image]

SQL Data Compare API 12.0.40
ForeignKeyChangesCalculator..::.DropForeignKeys Method
ForeignKeyChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub DropForeignKeys ( _
    keys As ForeignKeys, _
    tableDifference As Difference _
)
C#
public void DropForeignKeys(
    ForeignKeys keys,
    Difference tableDifference
)
Visual C++
public:
void DropForeignKeys(
    ForeignKeys^ keys,
    Difference^ tableDifference
)

Parameters

keys
Type: RedGate.SQLCompare.Engine..::.ForeignKeys
tableDifference
Type: RedGate.SQLCompare.Engine..::.Difference

See Also

ForeignKeyChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


ForeignKeys Class

[image]

SQL Data Compare API 12.0.40
ForeignKeys Class
Members See Also

A collection of foreign keys.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ForeignKeys _
    Inherits SerializableDatabaseObjectCollection(Of ForeignKey)
C#
public sealed class ForeignKeys : SerializableDatabaseObjectCollection<ForeignKey>
Visual C++
public ref class ForeignKeys sealed : public SerializableDatabaseObjectCollection<ForeignKey^>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( ForeignKey >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( ForeignKey >)>)
RedGate.SQLCompare.Engine..::.ForeignKeys

See Also

ForeignKeys Members
RedGate.SQLCompare.Engine Namespace


ForeignKeys Members

[image] [image]

SQL Data Compare API 12.0.40
ForeignKeys Members
ForeignKeys Class Methods Fields Properties Explicit Interface Implementations See Also

The ForeignKeys type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

ForeignKeys Class
RedGate.SQLCompare.Engine Namespace


ForeignKeys Properties

[image] [image]

SQL Data Compare API 12.0.40
ForeignKeys Properties
ForeignKeys Class See Also

The ForeignKeys type exposes the following properties.

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

See Also

ForeignKeys Class
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
ForeignKeys..::.Item Property
ForeignKeys Class See Also

Overload List

Name | Description
Item[([(String])]) | Returns a foreign key given its name (Overrides KeyedCollection <(Of <( T >)>)..::. Item[([(String])]).)
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

ForeignKeys Class
ForeignKeys Members
RedGate.SQLCompare.Engine Namespace


Item Property ()

[image]

SQL Data Compare API 12.0.40
ForeignKeys..::.Item Property ()
ForeignKeys Class See Also

Returns a foreign key given its name

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Default Property Item ( _
    name As String _
) As ForeignKey
C#
public override ForeignKey this[
    string name
] { get; }
Visual C++
public:
virtual property ForeignKey^ default[String^ name] {
    ForeignKey^ get (String^ name) override;
}

Parameters

name
Type: String
The string-based index of the element to get or set.

Implements

IKeyedCollectionItem(String)

See Also

ForeignKeys Class
Item Overload
RedGate.SQLCompare.Engine Namespace


ForeignKeysChanges Class

[image]

SQL Data Compare API 12.0.40
ForeignKeysChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ForeignKeysChanges
C#
public sealed class ForeignKeysChanges
Visual C++
public ref class ForeignKeysChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ForeignKeysChanges

See Also

ForeignKeysChanges Members
RedGate.SQLCompare.Engine Namespace


ForeignKeysChanges Members

[image] [image]

SQL Data Compare API 12.0.40
ForeignKeysChanges Members
ForeignKeysChanges Class Constructors Methods Properties See Also

The ForeignKeysChanges type exposes the following members.

Constructors

Name | Description
ForeignKeysChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ForeignKeysToCreate |
ForeignKeysToDrop |

See Also

ForeignKeysChanges Class
RedGate.SQLCompare.Engine Namespace


ForeignKeysChanges Constructor

[image]

SQL Data Compare API 12.0.40
ForeignKeysChanges Constructor
ForeignKeysChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public ForeignKeysChanges(
    bool caseSensitive
)
Visual C++
public:
ForeignKeysChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

ForeignKeysChanges Class
RedGate.SQLCompare.Engine Namespace


ForeignKeysChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
ForeignKeysChanges Properties
ForeignKeysChanges Class See Also

The ForeignKeysChanges type exposes the following properties.

Properties

Name | Description
ForeignKeysToCreate |
ForeignKeysToDrop |

See Also

ForeignKeysChanges Class
RedGate.SQLCompare.Engine Namespace


ForeignKeysToCreate Property

[image]

SQL Data Compare API 12.0.40
ForeignKeysChanges..::.ForeignKeysToCreate Property
ForeignKeysChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ForeignKeysToCreate As ForeignKeys
C#
public ForeignKeys ForeignKeysToCreate { get; private set; }
Visual C++
public:
property ForeignKeys^ ForeignKeysToCreate {
    ForeignKeys^ get ();
    void set (ForeignKeys^ value);
}

See Also

ForeignKeysChanges Class
RedGate.SQLCompare.Engine Namespace


ForeignKeysToDrop Property

[image]

SQL Data Compare API 12.0.40
ForeignKeysChanges..::.ForeignKeysToDrop Property
ForeignKeysChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ForeignKeysToDrop As ForeignKeys
C#
public ForeignKeys ForeignKeysToDrop { get; private set; }
Visual C++
public:
property ForeignKeys^ ForeignKeysToDrop {
    ForeignKeys^ get ();
    void set (ForeignKeys^ value);
}

See Also

ForeignKeysChanges Class
RedGate.SQLCompare.Engine Namespace


FullTextCatalog Class

[image]

SQL Data Compare API 12.0.40
FullTextCatalog Class
Members See Also

A full text catalog.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FullTextCatalog _
    Inherits DatabaseObjectWithAuthorization _
    Implements IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck,  _
    IPatchUpAfterDeserialization, IHasAuthorization, ISqlComparable
C#
public sealed class FullTextCatalog : DatabaseObjectWithAuthorization, IHasPermissions,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, IPatchUpAfterDeserialization, IHasAuthorization,
    ISqlComparable
Visual C++
public ref class FullTextCatalog sealed : public DatabaseObjectWithAuthorization,
    IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck, IPatchUpAfterDeserialization,
    IHasAuthorization, ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.FullTextCatalog

See Also

FullTextCatalog Members
RedGate.SQLCompare.Engine Namespace


FullTextCatalog Members

[image] [image]

SQL Data Compare API 12.0.40
FullTextCatalog Members
FullTextCatalog Class Methods Fields Properties Explicit Interface Implementations See Also

The FullTextCatalog type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Inherited from ScriptableDatabaseObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AlterAuthorizationClassType | (Overrides DatabaseObjectWithAuthorization ..::. AlterAuthorizationClassType.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
FileGroup | The filegroup of the catalog. This is set only for SQL Server 2005 databases.
FullyQualifiedName | The fully-qualified name of the catalog. DANGER WILL ROBINSON!! This is not escaped. (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
IsAccentSensitive | Indicates whether the catalog is accent sensitive. This is used only for SQL Server 2005 databases.
IsDefault | Indicates whether the catalog is the default full text catalog. This is used only for SQL Server 2005 databases.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.FullTextCatalog (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Path | The path of the catalog. This is used only for SQL Server 2005 databases.
Permissions |
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)
ViewsAndTables | The views and tables that belong to the catalog.

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

FullTextCatalog Class
RedGate.SQLCompare.Engine Namespace


FullTextCatalog Methods

[image] [image]

SQL Data Compare API 12.0.40
FullTextCatalog Methods
FullTextCatalog Class See Also

The FullTextCatalog type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Inherited from ScriptableDatabaseObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

FullTextCatalog Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
FullTextCatalog..::.ISqlComparable..::.CompareWith Method
FullTextCatalog Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    other As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable other,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ other,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

other
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

FullTextCatalog Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
FullTextCatalog..::.Equals Method
FullTextCatalog Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the full text catalog with a specified full text catalog. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

FullTextCatalog Class
FullTextCatalog Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
FullTextCatalog..::.Equals Method (IDatabaseObject, Options)
FullTextCatalog Class See Also

Compares the full text catalog with a specified full text catalog.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) override

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The catalog to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the full text catalogs are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

FullTextCatalog Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
FullTextCatalog..::.PatchUpAfterDeserialization Method
FullTextCatalog Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

FullTextCatalog Class
RedGate.SQLCompare.Engine Namespace


FullTextCatalog Properties

[image] [image]

SQL Data Compare API 12.0.40
FullTextCatalog Properties
FullTextCatalog Class See Also

The FullTextCatalog type exposes the following properties.

Properties

Name | Description
AlterAuthorizationClassType | (Overrides DatabaseObjectWithAuthorization ..::. AlterAuthorizationClassType.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
FileGroup | The filegroup of the catalog. This is set only for SQL Server 2005 databases.
FullyQualifiedName | The fully-qualified name of the catalog. DANGER WILL ROBINSON!! This is not escaped. (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
IsAccentSensitive | Indicates whether the catalog is accent sensitive. This is used only for SQL Server 2005 databases.
IsDefault | Indicates whether the catalog is the default full text catalog. This is used only for SQL Server 2005 databases.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.FullTextCatalog (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Path | The path of the catalog. This is used only for SQL Server 2005 databases.
Permissions |
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)
ViewsAndTables | The views and tables that belong to the catalog.

See Also

FullTextCatalog Class
RedGate.SQLCompare.Engine Namespace


AlterAuthorizationClassType Property

[image]

SQL Data Compare API 12.0.40
FullTextCatalog..::.AlterAuthorizationClassType Property
FullTextCatalog Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property AlterAuthorizationClassType As String
C#
public override string AlterAuthorizationClassType { get; }
Visual C++
public:
virtual property String^ AlterAuthorizationClassType {
    String^ get () override;
}

Implements

IHasAuthorization..::.AlterAuthorizationClassType
IHasAuthorization..::.AlterAuthorizationClassType

See Also

FullTextCatalog Class
RedGate.SQLCompare.Engine Namespace


FileGroup Property

[image]

SQL Data Compare API 12.0.40
FullTextCatalog..::.FileGroup Property
FullTextCatalog Class See Also

The filegroup of the catalog. This is set only for SQL Server 2005 databases.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FileGroup As String
C#
public string FileGroup { get; internal set; }
Visual C++
public:
property String^ FileGroup {
    String^ get ();
    void set (String^ value);
}

See Also

FullTextCatalog Class
RedGate.SQLCompare.Engine Namespace


FullyQualifiedName Property

[image]

SQL Data Compare API 12.0.40
FullTextCatalog..::.FullyQualifiedName Property
FullTextCatalog Class See Also

The fully-qualified name of the catalog. DANGER WILL ROBINSON!! This is not escaped.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FullyQualifiedName As String
C#
public override string FullyQualifiedName { get; }
Visual C++
public:
virtual property String^ FullyQualifiedName {
    String^ get () override;
}

Implements

ITSqlObjectFullyQualifiedName()()()
ITSqlObjectFullyQualifiedName()()()

See Also

FullTextCatalog Class
RedGate.SQLCompare.Engine Namespace


IsAccentSensitive Property

[image]

SQL Data Compare API 12.0.40
FullTextCatalog..::.IsAccentSensitive Property
FullTextCatalog Class See Also

Indicates whether the catalog is accent sensitive. This is used only for SQL Server 2005 databases.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsAccentSensitive As Boolean
C#
public bool IsAccentSensitive { get; internal set; }
Visual C++
public:
property bool IsAccentSensitive {
    bool get ();
    void set (bool value);
}

See Also

FullTextCatalog Class
RedGate.SQLCompare.Engine Namespace


IsDefault Property

[image]

SQL Data Compare API 12.0.40
FullTextCatalog..::.IsDefault Property
FullTextCatalog Class See Also

Indicates whether the catalog is the default full text catalog. This is used only for SQL Server 2005 databases.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsDefault As Boolean
C#
public bool IsDefault { get; internal set; }
Visual C++
public:
property bool IsDefault {
    bool get ();
    void set (bool value);
}

See Also

FullTextCatalog Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
FullTextCatalog..::.ObjectType Property
FullTextCatalog Class See Also

Returns ObjectType.FullTextCatalog

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()
ITSqlObjectObjectType()()()

See Also

FullTextCatalog Class
RedGate.SQLCompare.Engine Namespace


Path Property

[image]

SQL Data Compare API 12.0.40
FullTextCatalog..::.Path Property
FullTextCatalog Class See Also

The path of the catalog. This is used only for SQL Server 2005 databases.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Path As String
C#
public string Path { get; internal set; }
Visual C++
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

See Also

FullTextCatalog Class
RedGate.SQLCompare.Engine Namespace


Permissions Property

[image]

SQL Data Compare API 12.0.40
FullTextCatalog..::.Permissions Property
FullTextCatalog Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Permissions As Permissions
C#
public Permissions Permissions { get; private set; }
Visual C++
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
    void set (Permissions^ value) sealed;
}

Implements

IHasPermissions..::.Permissions

See Also

FullTextCatalog Class
RedGate.SQLCompare.Engine Namespace


ViewsAndTables Property

[image]

SQL Data Compare API 12.0.40
FullTextCatalog..::.ViewsAndTables Property
FullTextCatalog Class See Also

The views and tables that belong to the catalog.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ViewsAndTables As ViewsAndTables
C#
public ViewsAndTables ViewsAndTables { get; private set; }
Visual C++
public:
property ViewsAndTables^ ViewsAndTables {
    ViewsAndTables^ get ();
    void set (ViewsAndTables^ value);
}

See Also

FullTextCatalog Class
RedGate.SQLCompare.Engine Namespace


FullTextCatalogs Class

[image]

SQL Data Compare API 12.0.40
FullTextCatalogs Class
Members See Also

A collection of full text catalogs.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FullTextCatalogs _
    Inherits SerializableDatabaseObjectCollection(Of FullTextCatalog) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class FullTextCatalogs : SerializableDatabaseObjectCollection<FullTextCatalog>, IPatchUpAfterDeserialization
Visual C++
public ref class FullTextCatalogs sealed : public SerializableDatabaseObjectCollection<FullTextCatalog^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( FullTextCatalog >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( FullTextCatalog >)>)
RedGate.SQLCompare.Engine..::.FullTextCatalogs

See Also

FullTextCatalogs Members
RedGate.SQLCompare.Engine Namespace


FullTextCatalogs Members

[image] [image]

SQL Data Compare API 12.0.40
FullTextCatalogs Members
FullTextCatalogs Class Methods Fields Properties Explicit Interface Implementations See Also

The FullTextCatalogs type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

FullTextCatalogs Class
RedGate.SQLCompare.Engine Namespace


FullTextCatalogs Methods

[image] [image]

SQL Data Compare API 12.0.40
FullTextCatalogs Methods
FullTextCatalogs Class See Also

The FullTextCatalogs type exposes the following methods.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

FullTextCatalogs Class
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
FullTextCatalogs..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
FullTextCatalogs Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

FullTextCatalogs Class
RedGate.SQLCompare.Engine Namespace


FulltextChanges Class

[image]

SQL Data Compare API 12.0.40
FulltextChanges Class
Members See Also

TODO: is there a sensible subdivision of this class? Alternatively, we might want to put fulltext changes queues alongside their normal versions (eg fulltext views/tables to drop goes alongside views (or tables?) and fulltext columns to drop goes alongside fields to drop

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FulltextChanges
C#
public sealed class FulltextChanges
Visual C++
public ref class FulltextChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.FulltextChanges

See Also

FulltextChanges Members
RedGate.SQLCompare.Engine Namespace


FulltextChanges Members

[image] [image]

SQL Data Compare API 12.0.40
FulltextChanges Members
FulltextChanges Class Constructors Methods Properties See Also

The FulltextChanges type exposes the following members.

Constructors

Name | Description
FulltextChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CatalogsToAlter |
CatalogsToCreate |
CatalogsToDrop |
CatalogTargets |
FullTextColumnsToCreate |
FullTextColumnsToDrop |
FullTextViewsAndTablesToAdd |
FullTextViewsAndTablesToAlter |
FullTextViewsAndTablesToCreate |
FullTextViewsAndTablesToCreateOrAdd |
FullTextViewsAndTablesToDrop |

See Also

FulltextChanges Class
RedGate.SQLCompare.Engine Namespace


FulltextChanges Constructor

[image]

SQL Data Compare API 12.0.40
FulltextChanges Constructor
FulltextChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public FulltextChanges(
    bool caseSensitive
)
Visual C++
public:
FulltextChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

FulltextChanges Class
RedGate.SQLCompare.Engine Namespace


FulltextChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
FulltextChanges Properties
FulltextChanges Class See Also

The FulltextChanges type exposes the following properties.

Properties

Name | Description
CatalogsToAlter |
CatalogsToCreate |
CatalogsToDrop |
CatalogTargets |
FullTextColumnsToCreate |
FullTextColumnsToDrop |
FullTextViewsAndTablesToAdd |
FullTextViewsAndTablesToAlter |
FullTextViewsAndTablesToCreate |
FullTextViewsAndTablesToCreateOrAdd |
FullTextViewsAndTablesToDrop |

See Also

FulltextChanges Class
RedGate.SQLCompare.Engine Namespace


CatalogsToAlter Property

[image]

SQL Data Compare API 12.0.40
FulltextChanges..::.CatalogsToAlter Property
FulltextChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CatalogsToAlter As FullTextCatalogs
C#
public FullTextCatalogs CatalogsToAlter { get; private set; }
Visual C++
public:
property FullTextCatalogs^ CatalogsToAlter {
    FullTextCatalogs^ get ();
    void set (FullTextCatalogs^ value);
}

See Also

FulltextChanges Class
RedGate.SQLCompare.Engine Namespace


CatalogsToCreate Property

[image]

SQL Data Compare API 12.0.40
FulltextChanges..::.CatalogsToCreate Property
FulltextChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CatalogsToCreate As FullTextCatalogs
C#
public FullTextCatalogs CatalogsToCreate { get; private set; }
Visual C++
public:
property FullTextCatalogs^ CatalogsToCreate {
    FullTextCatalogs^ get ();
    void set (FullTextCatalogs^ value);
}

See Also

FulltextChanges Class
RedGate.SQLCompare.Engine Namespace


CatalogsToDrop Property

[image]

SQL Data Compare API 12.0.40
FulltextChanges..::.CatalogsToDrop Property
FulltextChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CatalogsToDrop As FullTextCatalogs
C#
public FullTextCatalogs CatalogsToDrop { get; private set; }
Visual C++
public:
property FullTextCatalogs^ CatalogsToDrop {
    FullTextCatalogs^ get ();
    void set (FullTextCatalogs^ value);
}

See Also

FulltextChanges Class
RedGate.SQLCompare.Engine Namespace


CatalogTargets Property

[image]

SQL Data Compare API 12.0.40
FulltextChanges..::.CatalogTargets Property
FulltextChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CatalogTargets As Dictionary(Of FullTextCatalog, FullTextCatalog)
C#
public Dictionary<FullTextCatalog, FullTextCatalog> CatalogTargets { get; private set; }
Visual C++
public:
property Dictionary<FullTextCatalog^, FullTextCatalog^>^ CatalogTargets {
    Dictionary<FullTextCatalog^, FullTextCatalog^>^ get ();
    void set (Dictionary<FullTextCatalog^, FullTextCatalog^>^ value);
}

See Also

FulltextChanges Class
RedGate.SQLCompare.Engine Namespace


FullTextColumnsToCreate Property

[image]

SQL Data Compare API 12.0.40
FulltextChanges..::.FullTextColumnsToCreate Property
FulltextChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextColumnsToCreate As FlatFieldList
C#
public FlatFieldList FullTextColumnsToCreate { get; private set; }
Visual C++
public:
property FlatFieldList^ FullTextColumnsToCreate {
    FlatFieldList^ get ();
    void set (FlatFieldList^ value);
}

See Also

FulltextChanges Class
RedGate.SQLCompare.Engine Namespace


FullTextColumnsToDrop Property

[image]

SQL Data Compare API 12.0.40
FulltextChanges..::.FullTextColumnsToDrop Property
FulltextChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextColumnsToDrop As FlatFieldList
C#
public FlatFieldList FullTextColumnsToDrop { get; private set; }
Visual C++
public:
property FlatFieldList^ FullTextColumnsToDrop {
    FlatFieldList^ get ();
    void set (FlatFieldList^ value);
}

See Also

FulltextChanges Class
RedGate.SQLCompare.Engine Namespace


FullTextViewsAndTablesToAdd Property

[image]

SQL Data Compare API 12.0.40
FulltextChanges..::.FullTextViewsAndTablesToAdd Property
FulltextChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextViewsAndTablesToAdd As ViewsAndTables
C#
public ViewsAndTables FullTextViewsAndTablesToAdd { get; private set; }
Visual C++
public:
property ViewsAndTables^ FullTextViewsAndTablesToAdd {
    ViewsAndTables^ get ();
    void set (ViewsAndTables^ value);
}

See Also

FulltextChanges Class
RedGate.SQLCompare.Engine Namespace


FullTextViewsAndTablesToAlter Property

[image]

SQL Data Compare API 12.0.40
FulltextChanges..::.FullTextViewsAndTablesToAlter Property
FulltextChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextViewsAndTablesToAlter As ViewsAndTables
C#
public ViewsAndTables FullTextViewsAndTablesToAlter { get; private set; }
Visual C++
public:
property ViewsAndTables^ FullTextViewsAndTablesToAlter {
    ViewsAndTables^ get ();
    void set (ViewsAndTables^ value);
}

See Also

FulltextChanges Class
RedGate.SQLCompare.Engine Namespace


FullTextViewsAndTablesToCreate Property

[image]

SQL Data Compare API 12.0.40
FulltextChanges..::.FullTextViewsAndTablesToCreate Property
FulltextChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextViewsAndTablesToCreate As ViewsAndTables
C#
public ViewsAndTables FullTextViewsAndTablesToCreate { get; private set; }
Visual C++
public:
property ViewsAndTables^ FullTextViewsAndTablesToCreate {
    ViewsAndTables^ get ();
    void set (ViewsAndTables^ value);
}

See Also

FulltextChanges Class
RedGate.SQLCompare.Engine Namespace


FullTextViewsAndTablesToCreateOrAdd Property

[image]

SQL Data Compare API 12.0.40
FulltextChanges..::.FullTextViewsAndTablesToCreateOrAdd Property
FulltextChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullTextViewsAndTablesToCreateOrAdd As IEnumerable(Of ViewTableSuperClass)
C#
public IEnumerable<ViewTableSuperClass> FullTextViewsAndTablesToCreateOrAdd { get; }
Visual C++
public:
property IEnumerable<ViewTableSuperClass^>^ FullTextViewsAndTablesToCreateOrAdd {
    IEnumerable<ViewTableSuperClass^>^ get ();
}

See Also

FulltextChanges Class
RedGate.SQLCompare.Engine Namespace


FullTextViewsAndTablesToDrop Property

[image]

SQL Data Compare API 12.0.40
FulltextChanges..::.FullTextViewsAndTablesToDrop Property
FulltextChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextViewsAndTablesToDrop As ViewsAndTables
C#
public ViewsAndTables FullTextViewsAndTablesToDrop { get; private set; }
Visual C++
public:
property ViewsAndTables^ FullTextViewsAndTablesToDrop {
    ViewsAndTables^ get ();
    void set (ViewsAndTables^ value);
}

See Also

FulltextChanges Class
RedGate.SQLCompare.Engine Namespace


FullTextChangesCalculator Class

[image]

SQL Data Compare API 12.0.40
FullTextChangesCalculator Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class FullTextChangesCalculator
C#
public class FullTextChangesCalculator
Visual C++
public ref class FullTextChangesCalculator

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.FullTextChangesCalculator

See Also

FullTextChangesCalculator Members
RedGate.SQLCompare.Engine Namespace


FullTextChangesCalculator Members

[image] [image]

SQL Data Compare API 12.0.40
FullTextChangesCalculator Members
FullTextChangesCalculator Class Constructors Methods See Also

The FullTextChangesCalculator type exposes the following members.

Constructors

Name | Description
FullTextChangesCalculator |

Methods

Name | Description
AddCreateForFullText |
AddDropForFullText |
AddFullTextColumnToCreate |
AddFullTextColumnToDrop |
AddFullTextRemoveAlters |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FullTextChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


FullTextChangesCalculator Constructor

[image]

SQL Data Compare API 12.0.40
FullTextChangesCalculator Constructor
FullTextChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fulltextChanges As FulltextChanges _
)
C#
public FullTextChangesCalculator(
    FulltextChanges fulltextChanges
)
Visual C++
public:
FullTextChangesCalculator(
    FulltextChanges^ fulltextChanges
)

Parameters

fulltextChanges
Type: RedGate.SQLCompare.Engine..::.FulltextChanges

See Also

FullTextChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


FullTextChangesCalculator Methods

[image] [image]

SQL Data Compare API 12.0.40
FullTextChangesCalculator Methods
FullTextChangesCalculator Class See Also

The FullTextChangesCalculator type exposes the following methods.

Methods

Name | Description
AddCreateForFullText |
AddDropForFullText |
AddFullTextColumnToCreate |
AddFullTextColumnToDrop |
AddFullTextRemoveAlters |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FullTextChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


AddCreateForFullText Method

[image]

SQL Data Compare API 12.0.40
FullTextChangesCalculator..::.AddCreateForFullText Method
FullTextChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddCreateForFullText ( _
    table As Table _
)
C#
public void AddCreateForFullText(
    Table table
)
Visual C++
public:
void AddCreateForFullText(
    Table^ table
)

Parameters

table
Type: RedGate.SQLCompare.Engine..::.Table

See Also

FullTextChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


AddDropForFullText Method

[image]

SQL Data Compare API 12.0.40
FullTextChangesCalculator..::.AddDropForFullText Method
FullTextChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddDropForFullText ( _
    targetTable As Table _
)
C#
public void AddDropForFullText(
    Table targetTable
)
Visual C++
public:
void AddDropForFullText(
    Table^ targetTable
)

Parameters

targetTable
Type: RedGate.SQLCompare.Engine..::.Table

See Also

FullTextChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


AddFullTextColumnToCreate Method

[image]

SQL Data Compare API 12.0.40
FullTextChangesCalculator..::.AddFullTextColumnToCreate Method
FullTextChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddFullTextColumnToCreate ( _
    field As IField _
)
C#
public void AddFullTextColumnToCreate(
    IField field
)
Visual C++
public:
void AddFullTextColumnToCreate(
    IField^ field
)

Parameters

field
Type: RedGate.SQLCompare.Engine..::.IField

See Also

FullTextChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


AddFullTextColumnToDrop Method

[image]

SQL Data Compare API 12.0.40
FullTextChangesCalculator..::.AddFullTextColumnToDrop Method
FullTextChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddFullTextColumnToDrop ( _
    field As IField _
)
C#
public void AddFullTextColumnToDrop(
    IField field
)
Visual C++
public:
void AddFullTextColumnToDrop(
    IField^ field
)

Parameters

field
Type: RedGate.SQLCompare.Engine..::.IField

See Also

FullTextChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


AddFullTextRemoveAlters Method

[image]

SQL Data Compare API 12.0.40
FullTextChangesCalculator..::.AddFullTextRemoveAlters Method
FullTextChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddFullTextRemoveAlters ( _
    table As Table, _
    options As Options, _
    f1 As IField, _
    targetField As IField _
)
C#
public void AddFullTextRemoveAlters(
    Table table,
    Options options,
    IField f1,
    IField targetField
)
Visual C++
public:
void AddFullTextRemoveAlters(
    Table^ table,
    Options options,
    IField^ f1,
    IField^ targetField
)

Parameters

table
Type: RedGate.SQLCompare.Engine..::.Table
options
Type: RedGate.SQLCompare.Engine..::.Options
f1
Type: RedGate.SQLCompare.Engine..::.IField
targetField
Type: RedGate.SQLCompare.Engine..::.IField

See Also

FullTextChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


FullTextChangeTracking Enumeration

[image]

SQL Data Compare API 12.0.40
FullTextChangeTracking Enumeration
See Also

The type of change tracking applied to the full text index on a view or table.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration FullTextChangeTracking
C#
public enum FullTextChangeTracking
Visual C++
public enum class FullTextChangeTracking

Members

Member name | Description
Off | Change tracking is disabled.
Manual | The change tracking log is propagated manually
Auto | The full text index is updated automatically.

See Also

RedGate.SQLCompare.Engine Namespace


FullTextStoplist Class

[image]

SQL Data Compare API 12.0.40
FullTextStoplist Class
Members See Also

A full text stoplist.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FullTextStoplist _
    Inherits DatabaseObjectWithAuthorization _
    Implements ISqlComparable
C#
public sealed class FullTextStoplist : DatabaseObjectWithAuthorization, ISqlComparable
Visual C++
public ref class FullTextStoplist sealed : public DatabaseObjectWithAuthorization,
    ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.FullTextStoplist

See Also

FullTextStoplist Members
RedGate.SQLCompare.Engine Namespace


FullTextStoplist Members

[image] [image]

SQL Data Compare API 12.0.40
FullTextStoplist Members
FullTextStoplist Class Methods Fields Properties Explicit Interface Implementations See Also

The FullTextStoplist type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AlterAuthorizationClassType | (Overrides DatabaseObjectWithAuthorization ..::. AlterAuthorizationClassType.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
FullyQualifiedName | The fully-qualified name of the stoplist. DANGER WILL ROBINSON!! This is not escaped. (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | The type of the object. (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)
Stopwords | Returns the words in this stoplist.

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

FullTextStoplist Class
RedGate.SQLCompare.Engine Namespace


FullTextStoplist Methods

[image] [image]

SQL Data Compare API 12.0.40
FullTextStoplist Methods
FullTextStoplist Class See Also

The FullTextStoplist type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

FullTextStoplist Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
FullTextStoplist..::.ISqlComparable..::.CompareWith Method
FullTextStoplist Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    other As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable other,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ other,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

other
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

FullTextStoplist Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
FullTextStoplist..::.Equals Method
FullTextStoplist Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares two database objects. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

FullTextStoplist Class
FullTextStoplist Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
FullTextStoplist..::.Equals Method (IDatabaseObject, Options)
FullTextStoplist Class See Also

Compares two database objects.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) override

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The object to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
The comparison options.

Return Value

True if the database objects are identical; otherwise false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

FullTextStoplist Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
FullTextStoplist..::.ScriptObject Method
FullTextStoplist Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options, e.g. quoted identifier on or off.
options
Type: RedGate.SQLCompare.Engine..::.Options
Options that may influence the scripting.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

FullTextStoplist Class
RedGate.SQLCompare.Engine Namespace


FullTextStoplist Properties

[image] [image]

SQL Data Compare API 12.0.40
FullTextStoplist Properties
FullTextStoplist Class See Also

The FullTextStoplist type exposes the following properties.

Properties

Name | Description
AlterAuthorizationClassType | (Overrides DatabaseObjectWithAuthorization ..::. AlterAuthorizationClassType.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
FullyQualifiedName | The fully-qualified name of the stoplist. DANGER WILL ROBINSON!! This is not escaped. (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | The type of the object. (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)
Stopwords | Returns the words in this stoplist.

See Also

FullTextStoplist Class
RedGate.SQLCompare.Engine Namespace


AlterAuthorizationClassType Property

[image]

SQL Data Compare API 12.0.40
FullTextStoplist..::.AlterAuthorizationClassType Property
FullTextStoplist Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property AlterAuthorizationClassType As String
C#
public override string AlterAuthorizationClassType { get; }
Visual C++
public:
virtual property String^ AlterAuthorizationClassType {
    String^ get () override;
}

Implements

IHasAuthorization..::.AlterAuthorizationClassType

See Also

FullTextStoplist Class
RedGate.SQLCompare.Engine Namespace


FullyQualifiedName Property

[image]

SQL Data Compare API 12.0.40
FullTextStoplist..::.FullyQualifiedName Property
FullTextStoplist Class See Also

The fully-qualified name of the stoplist. DANGER WILL ROBINSON!! This is not escaped.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FullyQualifiedName As String
C#
public override string FullyQualifiedName { get; }
Visual C++
public:
virtual property String^ FullyQualifiedName {
    String^ get () override;
}

Implements

ITSqlObjectFullyQualifiedName()()()

See Also

FullTextStoplist Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
FullTextStoplist..::.ObjectType Property
FullTextStoplist Class See Also

The type of the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()

See Also

FullTextStoplist Class
RedGate.SQLCompare.Engine Namespace


Stopwords Property

[image]

SQL Data Compare API 12.0.40
FullTextStoplist..::.Stopwords Property
FullTextStoplist Class See Also

Returns the words in this stoplist.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Stopwords As FullTextStopwords
C#
public FullTextStopwords Stopwords { get; private set; }
Visual C++
public:
property FullTextStopwords^ Stopwords {
    FullTextStopwords^ get ();
    void set (FullTextStopwords^ value);
}

See Also

FullTextStoplist Class
RedGate.SQLCompare.Engine Namespace


FullTextStoplistChangesCalculator Class

[image]

SQL Data Compare API 12.0.40
FullTextStoplistChangesCalculator Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class FullTextStoplistChangesCalculator
C#
public class FullTextStoplistChangesCalculator
Visual C++
public ref class FullTextStoplistChangesCalculator

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.FullTextStoplistChangesCalculator

See Also

FullTextStoplistChangesCalculator Members
RedGate.SQLCompare.Engine Namespace


FullTextStoplistChangesCalculator Members

[image] [image]

SQL Data Compare API 12.0.40
FullTextStoplistChangesCalculator Members
FullTextStoplistChangesCalculator Class Constructors Methods See Also

The FullTextStoplistChangesCalculator type exposes the following members.

Constructors

Name | Description
FullTextStoplistChangesCalculator |

Methods

Name | Description
CalculateWork |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FullTextStoplistChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


FullTextStoplistChangesCalculator Constructor

[image]

SQL Data Compare API 12.0.40
FullTextStoplistChangesCalculator Constructor
FullTextStoplistChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    stoplistsChanges As StoplistsChanges _
)
C#
public FullTextStoplistChangesCalculator(
    StoplistsChanges stoplistsChanges
)
Visual C++
public:
FullTextStoplistChangesCalculator(
    StoplistsChanges^ stoplistsChanges
)

Parameters

stoplistsChanges
Type: RedGate.SQLCompare.Engine..::.StoplistsChanges

See Also

FullTextStoplistChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


FullTextStoplistChangesCalculator Methods

[image] [image]

SQL Data Compare API 12.0.40
FullTextStoplistChangesCalculator Methods
FullTextStoplistChangesCalculator Class See Also

The FullTextStoplistChangesCalculator type exposes the following methods.

Methods

Name | Description
CalculateWork |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FullTextStoplistChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


CalculateWork Method

[image]

SQL Data Compare API 12.0.40
FullTextStoplistChangesCalculator..::.CalculateWork Method
FullTextStoplistChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculateWork ( _
    stoplist As FullTextStoplist, _
    targetStoplist As FullTextStoplist _
)
C#
public void CalculateWork(
    FullTextStoplist stoplist,
    FullTextStoplist targetStoplist
)
Visual C++
public:
void CalculateWork(
    FullTextStoplist^ stoplist,
    FullTextStoplist^ targetStoplist
)

Parameters

stoplist
Type: RedGate.SQLCompare.Engine..::.FullTextStoplist
targetStoplist
Type: RedGate.SQLCompare.Engine..::.FullTextStoplist

See Also

FullTextStoplistChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


FullTextStoplists Class

[image]

SQL Data Compare API 12.0.40
FullTextStoplists Class
Members See Also

A collection of full text stoplists.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FullTextStoplists _
    Inherits SerializableDatabaseObjectCollection(Of FullTextStoplist) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class FullTextStoplists : SerializableDatabaseObjectCollection<FullTextStoplist>, IPatchUpAfterDeserialization
Visual C++
public ref class FullTextStoplists sealed : public SerializableDatabaseObjectCollection<FullTextStoplist^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( FullTextStoplist >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( FullTextStoplist >)>)
RedGate.SQLCompare.Engine..::.FullTextStoplists

See Also

FullTextStoplists Members
RedGate.SQLCompare.Engine Namespace


FullTextStoplists Members

[image] [image]

SQL Data Compare API 12.0.40
FullTextStoplists Members
FullTextStoplists Class Methods Fields Properties Explicit Interface Implementations See Also

The FullTextStoplists type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

FullTextStoplists Class
RedGate.SQLCompare.Engine Namespace


FullTextStoplists Methods

[image] [image]

SQL Data Compare API 12.0.40
FullTextStoplists Methods
FullTextStoplists Class See Also

The FullTextStoplists type exposes the following methods.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

FullTextStoplists Class
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
FullTextStoplists..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
FullTextStoplists Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

FullTextStoplists Class
RedGate.SQLCompare.Engine Namespace


FullTextStoplistType Enumeration

[image]

SQL Data Compare API 12.0.40
FullTextStoplistType Enumeration
See Also

The stoplist used by the full text index on a view or table.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration FullTextStoplistType
C#
public enum FullTextStoplistType
Visual C++
public enum class FullTextStoplistType

Members

Member name | Description
None | No stoplist is used for the fulltext index.
System | The system stoplist is used.
UserDefined | A user-defined stoplist is used.

See Also

RedGate.SQLCompare.Engine Namespace


FullTextStopwords Class

[image]

SQL Data Compare API 12.0.40
FullTextStopwords Class
Members See Also

A collection of stopwords associated with a full text stoplist.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FullTextStopwords _
    Implements IEnumerable(Of KeyValuePair(Of Integer, ICollection(Of String))),  _
    IEnumerable
C#
public sealed class FullTextStopwords : IEnumerable<KeyValuePair<int, ICollection<string>>>,
    IEnumerable
Visual C++
public ref class FullTextStopwords sealed : IEnumerable<KeyValuePair<int, ICollection<String^>^>>,
    IEnumerable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.FullTextStopwords

See Also

FullTextStopwords Members
RedGate.SQLCompare.Engine Namespace


FullTextStopwords Members

[image] [image]

SQL Data Compare API 12.0.40
FullTextStopwords Members
FullTextStopwords Class Methods Properties Explicit Interface Implementations See Also

The FullTextStopwords type exposes the following members.

Methods

Name | Description
Empty |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator of the languages in this stoplist and the stopwords associated with each language.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Item | A collection of stopwords associated with the specified LCID.
Languages | The LCIDs of the languages in this collection.
TotalStopwords | The total number of stopwords in this collection.

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator |

See Also

FullTextStopwords Class
RedGate.SQLCompare.Engine Namespace


FullTextStopwords Methods

[image] [image]

SQL Data Compare API 12.0.40
FullTextStopwords Methods
FullTextStopwords Class See Also

The FullTextStopwords type exposes the following methods.

Methods

Name | Description
Empty |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator of the languages in this stoplist and the stopwords associated with each language.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator |

See Also

FullTextStopwords Class
RedGate.SQLCompare.Engine Namespace


Empty Method

[image]

SQL Data Compare API 12.0.40
FullTextStopwords..::.Empty Method
FullTextStopwords Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Empty As FullTextStopwords
C#
public static FullTextStopwords Empty()
Visual C++
public:
static FullTextStopwords^ Empty()

See Also

FullTextStopwords Class
RedGate.SQLCompare.Engine Namespace


GetEnumerator Method

[image]

SQL Data Compare API 12.0.40
FullTextStopwords..::.GetEnumerator Method
FullTextStopwords Class See Also

Returns an enumerator of the languages in this stoplist and the stopwords associated with each language.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of Integer, ICollection(Of String)))
C#
public IEnumerator<KeyValuePair<int, ICollection<string>>> GetEnumerator()
Visual C++
public:
virtual IEnumerator<KeyValuePair<int, ICollection<String^>^>>^ GetEnumerator() sealed

Return Value

Implements

IEnumerableGetEnumerator()()()

See Also

FullTextStopwords Class
RedGate.SQLCompare.Engine Namespace


. Method

[image]

SQL Data Compare API 12.0.40
FullTextStopwords..::...::. Method
FullTextStopwords Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
C#
IEnumerator IEnumerable.GetEnumerator()
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerableGetEnumerator()()()

See Also

FullTextStopwords Class
RedGate.SQLCompare.Engine Namespace


FullTextStopwords Properties

[image] [image]

SQL Data Compare API 12.0.40
FullTextStopwords Properties
FullTextStopwords Class See Also

The FullTextStopwords type exposes the following properties.

Properties

Name | Description
Item | A collection of stopwords associated with the specified LCID.
Languages | The LCIDs of the languages in this collection.
TotalStopwords | The total number of stopwords in this collection.

See Also

FullTextStopwords Class
RedGate.SQLCompare.Engine Namespace


Item Property

[image]

SQL Data Compare API 12.0.40
FullTextStopwords..::.Item Property
FullTextStopwords Class See Also

A collection of stopwords associated with the specified LCID.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    language As Integer _
) As ICollection(Of String)
C#
public ICollection<string> this[
    int language
] { get; }
Visual C++
public:
property ICollection<String^>^ default[int language] {
    ICollection<String^>^ get (int language);
}

Parameters

language
Type: Int32
The LCID of the stopwords to return.

Return Value

A collection of stopwords for the specified LCID.

See Also

FullTextStopwords Class
RedGate.SQLCompare.Engine Namespace


Languages Property

[image]

SQL Data Compare API 12.0.40
FullTextStopwords..::.Languages Property
FullTextStopwords Class See Also

The LCIDs of the languages in this collection.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Languages As ICollection(Of Integer)
C#
public ICollection<int> Languages { get; }
Visual C++
public:
property ICollection<int>^ Languages {
    ICollection<int>^ get ();
}

See Also

FullTextStopwords Class
RedGate.SQLCompare.Engine Namespace


TotalStopwords Property

[image]

SQL Data Compare API 12.0.40
FullTextStopwords..::.TotalStopwords Property
FullTextStopwords Class See Also

The total number of stopwords in this collection.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TotalStopwords As Integer
C#
public int TotalStopwords { get; }
Visual C++
public:
property int TotalStopwords {
    int get ();
}

See Also

FullTextStopwords Class
RedGate.SQLCompare.Engine Namespace


Function Class

[image]

SQL Data Compare API 12.0.40
Function Class
Members See Also

A user-defined function.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Function _
    Inherits SchemaObjectWithAuthorization _
    Implements IDatabaseObject, ITSqlObject, ICanExistenceCheck, IExecuteAs,  _
    IIsSystemObject, IEncryptedTextObject, ITextObject, ISessionSetObject, IPatchUpAfterDeserialization,  _
    ISqlComparable, IHasLastModifiedDate
C#
public sealed class Function : SchemaObjectWithAuthorization, IDatabaseObject,
    ITSqlObject, ICanExistenceCheck, IExecuteAs, IIsSystemObject, IEncryptedTextObject,
    ITextObject, ISessionSetObject, IPatchUpAfterDeserialization, ISqlComparable, IHasLastModifiedDate
Visual C++
public ref class Function sealed : public SchemaObjectWithAuthorization,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, IExecuteAs, IIsSystemObject,
    IEncryptedTextObject, ITextObject, ISessionSetObject, IPatchUpAfterDeserialization, ISqlComparable,
    IHasLastModifiedDate

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.SchemaObjectWithAuthorization
RedGate.SQLCompare.Engine..::.Function

See Also

Function Members
RedGate.SQLCompare.Engine Namespace


Function Members

[image] [image]

SQL Data Compare API 12.0.40
Function Members
Function Class Methods Fields Properties Explicit Interface Implementations See Also

The Function type exposes the following members.

Methods

Name | Description
CompareWith |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSql |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
SetSessionOptions |
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AlterAuthorizationClassType | (Inherited from SchemaObjectWithAuthorization.)
AnsiNullsOn | True if the function was created with ansi nulls on.
Assembly | The CLR assembly for the function, if this is a CLR function.
AssemblyClass | The CLR assembly class name for the function, if this is a CLR function.
AssemblyMethod | The CLR assembly method name for the function, if this is a CLR function.
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
CLRObject | True if the function is a CLR function.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
Encrypted | True if the function definition was encrypted.
ExecuteAs | The user whose security context is to be used for the execution of the function. This is a SQL Server 2005 feature.
ExecuteAsType | The EXECUTE AS clause used for the object.
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
FunctionType | Returns the function type.
LastModified |
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
NullOnNullInput | The function returns NULL on NULL input.
ObjectType | Returns ObjectType.Function (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Parameters | The function parameters.
Permissions | (Inherited from SchemaObjectWithAuthorization.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
QuotedIdentifierOn | True if the function was created with quoted identifiers on.
ReturnFields | The function's return fields.
ReturnParameter | The function's return parameter.
SchemaBound | True if the function is schema bound.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSources | (Inherited from SchemaObject.)
Text | The text of the function.

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |
IEncryptedTextObject..::.TextID |

See Also

Function Class
RedGate.SQLCompare.Engine Namespace


Function Methods

[image] [image]

SQL Data Compare API 12.0.40
Function Methods
Function Class See Also

The Function type exposes the following methods.

Methods

Name | Description
CompareWith |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSql |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
SetSessionOptions |
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

Function Class
RedGate.SQLCompare.Engine Namespace


CompareWith Method

[image]

SQL Data Compare API 12.0.40
Function..::.CompareWith Method
Function Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareWith ( _
    target As Function, _
    options As Options _
) As IEnumerable(Of EqualityDifference)
C#
public IEnumerable<EqualityDifference> CompareWith(
    Function target,
    Options options
)
Visual C++
public:
IEnumerable<EqualityDifference^>^ CompareWith(
    Function^ target,
    Options options
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.Function
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

Function Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
Function..::.ISqlComparable..::.CompareWith Method
Function Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    other As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable other,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ other,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

other
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

Function Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
Function..::.Equals Method
Function Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the function with a specified function. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

Function Class
Function Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
Function..::.Equals Method (IDatabaseObject, Options)
Function Class See Also

Compares the function with a specified function.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) override

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The function to compare with.
options
Type: RedGate.SQLCompare.Engine..::.Options
The comparison options.

Return Value

True if the functions are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

Function Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


GetSql Method

[image]

SQL Data Compare API 12.0.40
Function..::.GetSql Method
Function Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSql ( _
    options As Options, _
    targetIsEncrypted As Boolean, _
    useAlter As Boolean, _
    targetFeatures As IFeatureChecker _
) As String
C#
public string GetSql(
    Options options,
    bool targetIsEncrypted,
    bool useAlter,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual String^ GetSql(
    Options options,
    bool targetIsEncrypted,
    bool useAlter,
    IFeatureChecker^ targetFeatures
) sealed

Parameters

options
Type: RedGate.SQLCompare.Engine..::.Options
targetIsEncrypted
Type: Boolean
useAlter
Type: Boolean
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Implements

IEncryptedTextObject..::.GetSql(Options, Boolean, Boolean, IFeatureChecker)

See Also

Function Class
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
Function..::.PatchUpAfterDeserialization Method
Function Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

Function Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
Function..::.ScriptObject Method
Function Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

Function Class
RedGate.SQLCompare.Engine Namespace


SetSessionOptions Method

[image]

SQL Data Compare API 12.0.40
Function..::.SetSessionOptions Method
Function Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetSessionOptions ( _
    ansiNulls As Boolean, _
    quotedIdentifier As Boolean _
)
C#
public void SetSessionOptions(
    bool ansiNulls,
    bool quotedIdentifier
)
Visual C++
public:
virtual void SetSessionOptions(
    bool ansiNulls,
    bool quotedIdentifier
) sealed

Parameters

ansiNulls
Type: Boolean
quotedIdentifier
Type: Boolean

Implements

ISessionSetObject..::.SetSessionOptions(Boolean, Boolean)

See Also

Function Class
RedGate.SQLCompare.Engine Namespace


Function Properties

[image] [image]

SQL Data Compare API 12.0.40
Function Properties
Function Class See Also

The Function type exposes the following properties.

Properties

Name | Description
AlterAuthorizationClassType | (Inherited from SchemaObjectWithAuthorization.)
AnsiNullsOn | True if the function was created with ansi nulls on.
Assembly | The CLR assembly for the function, if this is a CLR function.
AssemblyClass | The CLR assembly class name for the function, if this is a CLR function.
AssemblyMethod | The CLR assembly method name for the function, if this is a CLR function.
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
CLRObject | True if the function is a CLR function.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
Encrypted | True if the function definition was encrypted.
ExecuteAs | The user whose security context is to be used for the execution of the function. This is a SQL Server 2005 feature.
ExecuteAsType | The EXECUTE AS clause used for the object.
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
FunctionType | Returns the function type.
LastModified |
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
NullOnNullInput | The function returns NULL on NULL input.
ObjectType | Returns ObjectType.Function (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Parameters | The function parameters.
Permissions | (Inherited from SchemaObjectWithAuthorization.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
QuotedIdentifierOn | True if the function was created with quoted identifiers on.
ReturnFields | The function's return fields.
ReturnParameter | The function's return parameter.
SchemaBound | True if the function is schema bound.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSources | (Inherited from SchemaObject.)
Text | The text of the function.

Explicit Interface Implementations

Name | Description
IEncryptedTextObject..::.TextID |

See Also

Function Class
RedGate.SQLCompare.Engine Namespace


AnsiNullsOn Property

[image]

SQL Data Compare API 12.0.40
Function..::.AnsiNullsOn Property
Function Class See Also

True if the function was created with ansi nulls on.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AnsiNullsOn As Boolean
C#
public bool AnsiNullsOn { get; internal set; }
Visual C++
public:
virtual property bool AnsiNullsOn {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

ISessionSetObject..::.AnsiNullsOn

See Also

Function Class
RedGate.SQLCompare.Engine Namespace


Assembly Property

[image]

SQL Data Compare API 12.0.40
Function..::.Assembly Property
Function Class See Also

The CLR assembly for the function, if this is a CLR function.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Assembly As ClrAssembly
C#
public ClrAssembly Assembly { get; internal set; }
Visual C++
public:
virtual property ClrAssembly^ Assembly {
    ClrAssembly^ get () sealed;
    void set (ClrAssembly^ value) sealed;
}

See Also

Function Class
RedGate.SQLCompare.Engine Namespace


AssemblyClass Property

[image]

SQL Data Compare API 12.0.40
Function..::.AssemblyClass Property
Function Class See Also

The CLR assembly class name for the function, if this is a CLR function.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyClass As String
C#
public string AssemblyClass { get; internal set; }
Visual C++
public:
property String^ AssemblyClass {
    String^ get ();
    void set (String^ value);
}

See Also

Function Class
RedGate.SQLCompare.Engine Namespace


AssemblyMethod Property

[image]

SQL Data Compare API 12.0.40
Function..::.AssemblyMethod Property
Function Class See Also

The CLR assembly method name for the function, if this is a CLR function.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyMethod As String
C#
public string AssemblyMethod { get; internal set; }
Visual C++
public:
property String^ AssemblyMethod {
    String^ get ();
    void set (String^ value);
}

See Also

Function Class
RedGate.SQLCompare.Engine Namespace


CLRObject Property

[image]

SQL Data Compare API 12.0.40
Function..::.CLRObject Property
Function Class See Also

True if the function is a CLR function.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CLRObject As Boolean
C#
public bool CLRObject { get; internal set; }
Visual C++
public:
virtual property bool CLRObject {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

Function Class
RedGate.SQLCompare.Engine Namespace


Encrypted Property

[image]

SQL Data Compare API 12.0.40
Function..::.Encrypted Property
Function Class See Also

True if the function definition was encrypted.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Encrypted As Boolean
C#
public bool Encrypted { get; internal set; }
Visual C++
public:
virtual property bool Encrypted {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IEncryptedTextObject..::.Encrypted

See Also

Function Class
RedGate.SQLCompare.Engine Namespace


ExecuteAs Property

[image]

SQL Data Compare API 12.0.40
Function..::.ExecuteAs Property
Function Class See Also

The user whose security context is to be used for the execution of the function. This is a SQL Server 2005 feature.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecuteAs As User
C#
public User ExecuteAs { get; internal set; }
Visual C++
public:
virtual property User^ ExecuteAs {
    User^ get () sealed;
    void set (User^ value) sealed;
}

Implements

IExecuteAs..::.ExecuteAs

See Also

Function Class
RedGate.SQLCompare.Engine Namespace


ExecuteAsType Property

[image]

SQL Data Compare API 12.0.40
Function..::.ExecuteAsType Property
Function Class See Also

The EXECUTE AS clause used for the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecuteAsType As ExecuteAs
C#
public ExecuteAs ExecuteAsType { get; internal set; }
Visual C++
public:
virtual property ExecuteAs ExecuteAsType {
    ExecuteAs get () sealed;
    void set (ExecuteAs value) sealed;
}

Implements

IExecuteAs..::.ExecuteAsType

See Also

Function Class
RedGate.SQLCompare.Engine Namespace


FunctionType Property

[image]

SQL Data Compare API 12.0.40
Function..::.FunctionType Property
Function Class See Also

Returns the function type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FunctionType As FunctionType
C#
public FunctionType FunctionType { get; internal set; }
Visual C++
public:
property FunctionType FunctionType {
    FunctionType get ();
    void set (FunctionType value);
}

See Also

Function Class
RedGate.SQLCompare.Engine Namespace


LastModified Property

[image]

SQL Data Compare API 12.0.40
Function..::.LastModified Property
Function Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LastModified As DateTime
C#
public DateTime LastModified { get; internal set; }
Visual C++
public:
virtual property DateTime LastModified {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}

Implements

IHasLastModifiedDate..::.LastModified

See Also

Function Class
RedGate.SQLCompare.Engine Namespace


NullOnNullInput Property

[image]

SQL Data Compare API 12.0.40
Function..::.NullOnNullInput Property
Function Class See Also

The function returns NULL on NULL input.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NullOnNullInput As Boolean
C#
public bool NullOnNullInput { get; internal set; }
Visual C++
public:
property bool NullOnNullInput {
    bool get ();
    void set (bool value);
}

See Also

Function Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
Function..::.ObjectType Property
Function Class See Also

Returns ObjectType.Function

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()
ITSqlObjectObjectType()()()

See Also

Function Class
RedGate.SQLCompare.Engine Namespace


Parameters Property

[image]

SQL Data Compare API 12.0.40
Function..::.Parameters Property
Function Class See Also

The function parameters.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As Parameters
C#
public Parameters Parameters { get; }
Visual C++
public:
property Parameters^ Parameters {
    Parameters^ get ();
}

See Also

Function Class
RedGate.SQLCompare.Engine Namespace


QuotedIdentifierOn Property

[image]

SQL Data Compare API 12.0.40
Function..::.QuotedIdentifierOn Property
Function Class See Also

True if the function was created with quoted identifiers on.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property QuotedIdentifierOn As Boolean
C#
public bool QuotedIdentifierOn { get; internal set; }
Visual C++
public:
virtual property bool QuotedIdentifierOn {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

ISessionSetObject..::.QuotedIdentifierOn

See Also

Function Class
RedGate.SQLCompare.Engine Namespace


ReturnFields Property

[image]

SQL Data Compare API 12.0.40
Function..::.ReturnFields Property
Function Class See Also

The function's return fields.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ReturnFields As Fields
C#
public Fields ReturnFields { get; internal set; }
Visual C++
public:
property Fields^ ReturnFields {
    Fields^ get ();
    void set (Fields^ value);
}

See Also

Function Class
RedGate.SQLCompare.Engine Namespace


ReturnParameter Property

[image]

SQL Data Compare API 12.0.40
Function..::.ReturnParameter Property
Function Class See Also

The function's return parameter.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ReturnParameter As Parameter
C#
public Parameter ReturnParameter { get; internal set; }
Visual C++
public:
property Parameter^ ReturnParameter {
    Parameter^ get ();
    void set (Parameter^ value);
}

See Also

Function Class
RedGate.SQLCompare.Engine Namespace


SchemaBound Property

[image]

SQL Data Compare API 12.0.40
Function..::.SchemaBound Property
Function Class See Also

True if the function is schema bound.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SchemaBound As Boolean
C#
public bool SchemaBound { get; internal set; }
Visual C++
public:
property bool SchemaBound {
    bool get ();
    void set (bool value);
}

See Also

Function Class
RedGate.SQLCompare.Engine Namespace


Text Property

[image]

SQL Data Compare API 12.0.40
Function..::.Text Property
Function Class See Also

The text of the function.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
C#
public string Text { get; }
Visual C++
public:
virtual property String^ Text {
    String^ get () sealed;
}

Implements

ITextObject..::.Text

See Also

Function Class
RedGate.SQLCompare.Engine Namespace


IEncryptedTextObject.TextID Property

[image]

SQL Data Compare API 12.0.40
Function..::.IEncryptedTextObject..::.TextID Property
Function Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private ReadOnly Property TextID As Integer
    Implements IEncryptedTextObject.TextID
C#
int IEncryptedTextObject.TextID { get; }
Visual C++
private:
virtual property int TextID {
    int get () sealed = IEncryptedTextObject::TextID::get;
}

Implements

IEncryptedTextObject..::.TextID

See Also

Function Class
RedGate.SQLCompare.Engine Namespace


Functions Class

[image]

SQL Data Compare API 12.0.40
Functions Class
Members See Also

A collection of functions.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Functions _
    Inherits SerializableDatabaseObjectCollection(Of Function) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class Functions : SerializableDatabaseObjectCollection<Function>, IPatchUpAfterDeserialization
Visual C++
public ref class Functions sealed : public SerializableDatabaseObjectCollection<Function^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Function >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( Function >)>)
RedGate.SQLCompare.Engine..::.Functions

See Also

Functions Members
RedGate.SQLCompare.Engine Namespace


Functions Members

[image] [image]

SQL Data Compare API 12.0.40
Functions Members
Functions Class Methods Fields Properties Explicit Interface Implementations See Also

The Functions type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

Functions Class
RedGate.SQLCompare.Engine Namespace


Functions Methods

[image] [image]

SQL Data Compare API 12.0.40
Functions Methods
Functions Class See Also

The Functions type exposes the following methods.

Methods

Name | Description
Add | Overloaded.
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

Functions Class
RedGate.SQLCompare.Engine Namespace


Add Method

[image] [image]

SQL Data Compare API 12.0.40
Functions..::.Add Method
Functions Class See Also

Overload List

Name | Description
Add(T) | (Inherited from KeyedCollection<(Of <(T>)>).)
Add(Function) | (Overrides SerializableDatabaseObjectCollection <(Of <( Function >)>)..::. Add(T).)

See Also

Functions Class
Functions Members
RedGate.SQLCompare.Engine Namespace


Add Method (Function)

[image]

SQL Data Compare API 12.0.40
Functions..::.Add Method (Function)
Functions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Add ( _
    value As Function _
)
C#
public override void Add(
    Function value
)
Visual C++
public:
virtual void Add(
    Function^ value
) override

Parameters

value
Type: RedGate.SQLCompare.Engine..::.Function

See Also

Functions Class
Add Overload
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
Functions..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
Functions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

Functions Class
RedGate.SQLCompare.Engine Namespace


FunctionsChanges Class

[image]

SQL Data Compare API 12.0.40
FunctionsChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FunctionsChanges
C#
public sealed class FunctionsChanges
Visual C++
public ref class FunctionsChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.FunctionsChanges

See Also

FunctionsChanges Members
RedGate.SQLCompare.Engine Namespace


FunctionsChanges Members

[image] [image]

SQL Data Compare API 12.0.40
FunctionsChanges Members
FunctionsChanges Class Constructors Methods Properties See Also

The FunctionsChanges type exposes the following members.

Constructors

Name | Description
FunctionsChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FunctionsToAlter |
FunctionsToCreate |
FunctionsToDrop |
FunctionsToRebuild |
FunctionTargets |

See Also

FunctionsChanges Class
RedGate.SQLCompare.Engine Namespace


FunctionsChanges Constructor

[image]

SQL Data Compare API 12.0.40
FunctionsChanges Constructor
FunctionsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public FunctionsChanges(
    bool caseSensitive
)
Visual C++
public:
FunctionsChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

FunctionsChanges Class
RedGate.SQLCompare.Engine Namespace


FunctionsChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
FunctionsChanges Properties
FunctionsChanges Class See Also

The FunctionsChanges type exposes the following properties.

Properties

Name | Description
FunctionsToAlter |
FunctionsToCreate |
FunctionsToDrop |
FunctionsToRebuild |
FunctionTargets |

See Also

FunctionsChanges Class
RedGate.SQLCompare.Engine Namespace


FunctionsToAlter Property

[image]

SQL Data Compare API 12.0.40
FunctionsChanges..::.FunctionsToAlter Property
FunctionsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FunctionsToAlter As Functions
C#
public Functions FunctionsToAlter { get; private set; }
Visual C++
public:
property Functions^ FunctionsToAlter {
    Functions^ get ();
    void set (Functions^ value);
}

See Also

FunctionsChanges Class
RedGate.SQLCompare.Engine Namespace


FunctionsToCreate Property

[image]

SQL Data Compare API 12.0.40
FunctionsChanges..::.FunctionsToCreate Property
FunctionsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FunctionsToCreate As Functions
C#
public Functions FunctionsToCreate { get; private set; }
Visual C++
public:
property Functions^ FunctionsToCreate {
    Functions^ get ();
    void set (Functions^ value);
}

See Also

FunctionsChanges Class
RedGate.SQLCompare.Engine Namespace


FunctionsToDrop Property

[image]

SQL Data Compare API 12.0.40
FunctionsChanges..::.FunctionsToDrop Property
FunctionsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FunctionsToDrop As Functions
C#
public Functions FunctionsToDrop { get; private set; }
Visual C++
public:
property Functions^ FunctionsToDrop {
    Functions^ get ();
    void set (Functions^ value);
}

See Also

FunctionsChanges Class
RedGate.SQLCompare.Engine Namespace


FunctionsToRebuild Property

[image]

SQL Data Compare API 12.0.40
FunctionsChanges..::.FunctionsToRebuild Property
FunctionsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FunctionsToRebuild As Functions
C#
public Functions FunctionsToRebuild { get; private set; }
Visual C++
public:
property Functions^ FunctionsToRebuild {
    Functions^ get ();
    void set (Functions^ value);
}

See Also

FunctionsChanges Class
RedGate.SQLCompare.Engine Namespace


FunctionTargets Property

[image]

SQL Data Compare API 12.0.40
FunctionsChanges..::.FunctionTargets Property
FunctionsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FunctionTargets As Dictionary(Of Function, Function)
C#
public Dictionary<Function, Function> FunctionTargets { get; private set; }
Visual C++
public:
property Dictionary<Function^, Function^>^ FunctionTargets {
    Dictionary<Function^, Function^>^ get ();
    void set (Dictionary<Function^, Function^>^ value);
}

See Also

FunctionsChanges Class
RedGate.SQLCompare.Engine Namespace


FunctionType Enumeration

[image]

SQL Data Compare API 12.0.40
FunctionType Enumeration
See Also

The type of function.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration FunctionType
C#
public enum FunctionType
Visual C++
public enum class FunctionType

Members

Member name | Description
Unknown | Unknown
Inline | An inline function.
Scalar | A scalar function.
Table | A table function.
Aggregate | An aggregate.

See Also

RedGate.SQLCompare.Engine Namespace


GridDensity Enumeration

[image]

SQL Data Compare API 12.0.40
GridDensity Enumeration
See Also

The grid density for the levels of the spatial index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration GridDensity
C#
public enum GridDensity
Visual C++
public enum class GridDensity

Members

Member name | Description
LOW | LOW (16)
MEDIUM | MEDIUM (64)
HIGH | HIGH (256)

See Also

RedGate.SQLCompare.Engine Namespace


IBinaryObject Interface

[image]

SQL Data Compare API 12.0.40
IBinaryObject Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IBinaryObject _
    Implements IDatabaseObject, ITSqlObject, ICanExistenceCheck
C#
public interface IBinaryObject : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck
Visual C++
public interface class IBinaryObject : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck

See Also

IBinaryObject Members
RedGate.SQLCompare.Engine Namespace


IBinaryObject Members

[image] [image]

SQL Data Compare API 12.0.40
IBinaryObject Members
IBinaryObject Interface Methods Properties See Also

The IBinaryObject type exposes the following members.

Methods

Name | Description
Equals | Compares two database objects. (Inherited from IDatabaseObject.)
TryGetMetadata |
TryScriptObjectAsBinary |

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from IDatabaseObject.)
FullyQualifiedName | (Inherited from ITSqlObject.)
Name | (Inherited from ITSqlObject.)
ObjectType | (Inherited from ITSqlObject.)
Owner | (Inherited from ITSqlObject.)
QualifiedName | (Inherited from ITSqlObject.)

See Also

IBinaryObject Interface
RedGate.SQLCompare.Engine Namespace


IBinaryObject Methods

[image] [image]

SQL Data Compare API 12.0.40
IBinaryObject Methods
IBinaryObject Interface See Also

The IBinaryObject type exposes the following methods.

Methods

Name | Description
Equals | Compares two database objects. (Inherited from IDatabaseObject.)
TryGetMetadata |
TryScriptObjectAsBinary |

See Also

IBinaryObject Interface
RedGate.SQLCompare.Engine Namespace


TryGetMetadata Method

[image]

SQL Data Compare API 12.0.40
IBinaryObject..::.TryGetMetadata Method
IBinaryObject Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function TryGetMetadata ( _
    <OutAttribute> ByRef metadata As IAssemblyMetadata _
) As Boolean
C#
bool TryGetMetadata(
    out IAssemblyMetadata metadata
)
Visual C++
bool TryGetMetadata(
    [OutAttribute] IAssemblyMetadata^% metadata
)

Parameters

metadata
Type: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.IAssemblyMetadata %

See Also

IBinaryObject Interface
RedGate.SQLCompare.Engine Namespace


TryScriptObjectAsBinary Method

[image]

SQL Data Compare API 12.0.40
IBinaryObject..::.TryScriptObjectAsBinary Method
IBinaryObject Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function TryScriptObjectAsBinary ( _
    fileInfo As FileInfo, _
    options As Options _
) As Boolean
C#
bool TryScriptObjectAsBinary(
    FileInfo fileInfo,
    Options options
)
Visual C++
bool TryScriptObjectAsBinary(
    FileInfo^ fileInfo,
    Options options
)

Parameters

fileInfo
Type: FileInfo
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

IBinaryObject Interface
RedGate.SQLCompare.Engine Namespace


ICancellationStatus Interface

[image]

SQL Data Compare API 12.0.40
ICancellationStatus Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface ICancellationStatus
C#
public interface ICancellationStatus
Visual C++
public interface class ICancellationStatus

See Also

ICancellationStatus Members
RedGate.SQLCompare.Engine Namespace


ICancellationStatus Members

[image] [image]

SQL Data Compare API 12.0.40
ICancellationStatus Members
ICancellationStatus Interface Properties See Also

The ICancellationStatus type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the database registration has been canceled.

See Also

ICancellationStatus Interface
RedGate.SQLCompare.Engine Namespace


ICancellationStatus Properties

[image] [image]

SQL Data Compare API 12.0.40
ICancellationStatus Properties
ICancellationStatus Interface See Also

The ICancellationStatus type exposes the following properties.

Properties

Name | Description
Cancel | Indicates whether the database registration has been canceled.

See Also

ICancellationStatus Interface
RedGate.SQLCompare.Engine Namespace


Cancel Property

[image]

SQL Data Compare API 12.0.40
ICancellationStatus..::.Cancel Property
ICancellationStatus Interface See Also

Indicates whether the database registration has been canceled.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Cancel As Boolean
C#
bool Cancel { get; }
Visual C++
property bool Cancel {
    bool get ();
}

See Also

ICancellationStatus Interface
RedGate.SQLCompare.Engine Namespace


ICanExistenceCheck Interface

[image]

SQL Data Compare API 12.0.40
ICanExistenceCheck Interface
See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface ICanExistenceCheck
C#
public interface ICanExistenceCheck
Visual C++
public interface class ICanExistenceCheck

See Also

RedGate.SQLCompare.Engine Namespace


ICompareDifference Interface

[image]

SQL Data Compare API 12.0.40
ICompareDifference Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface ICompareDifference _
    Implements IDatabaseObjectDifference(Of IDatabaseObject), IDifference
C#
public interface ICompareDifference : IDatabaseObjectDifference<IDatabaseObject>,
    IDifference
Visual C++
public interface class ICompareDifference : IDatabaseObjectDifference<IDatabaseObject^>,
    IDifference

See Also

ICompareDifference Members
RedGate.SQLCompare.Engine Namespace


ICompareDifference Members

[image] [image]

SQL Data Compare API 12.0.40
ICompareDifference Members
ICompareDifference Interface Methods Properties See Also

The ICompareDifference type exposes the following members.

Methods

Name | Description
Equals | (Inherited from IDifference.)
GetHashCode | (Inherited from IDifference.)
ToString | (Inherited from IDifference.)

Properties

Name | Description
DatabaseObjectType | (Inherited from IDifference.)
Name | (Inherited from IDifference.)
ObjectIn1 | (Inherited from IDatabaseObjectDifference<(Of <( IDatabaseObject >)>).)
ObjectIn2 | (Inherited from IDatabaseObjectDifference<(Of <( IDatabaseObject >)>).)
Renamed | (Inherited from IDifference.)
Selected | (Inherited from IDifference.)
SelectedImplicity | (Inherited from IDifference.)
Type | (Inherited from IDifference.)

See Also

ICompareDifference Interface
RedGate.SQLCompare.Engine Namespace


IDatabase Interface

[image]

SQL Data Compare API 12.0.40
IDatabase Interface
Members See Also

A SQL Server database object model. The object model may represent a scripts folder, snapshot, or a live database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDatabase _
    Implements ICancellable, ICloneable, IVersionedDatabase, ICancellationStatus,  _
    IDatabaseObjects, IDisposable
C#
public interface IDatabase : ICancellable,
    ICloneable, IVersionedDatabase, ICancellationStatus, IDatabaseObjects, IDisposable
Visual C++
public interface class IDatabase : ICancellable,
    ICloneable, IVersionedDatabase, ICancellationStatus, IDatabaseObjects, IDisposable

Remarks

Use Register(ConnectionProperties, Options, IDmvModelFactory) to register the Databasefrom a live server or LoadFromDisk(String, Boolean, Nullable<(Of <(Options>)>)) to load a Database from a snapshot.

Registering a Database is a long-running operation. Status feedback is provided via the Status event handler. To cancel the operation, call CancelOperation.

You must call Dispose()()() when you have finished using a Database object.

See Also

IDatabase Members
RedGate.SQLCompare.Engine Namespace


IDatabase Members

[image] [image]

SQL Data Compare API 12.0.40
IDatabase Members
IDatabase Interface Methods Properties See Also

The IDatabase type exposes the following members.

Methods

Name | Description
CancelOperation | Cancels the current running operation. This will throw an instance of OperationCancelledException at the currently executing location on the executing thread (Inherited from ICancellable.)
Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
CompareWith | Overloaded.
CreateEmptyTarget | For internal use only
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
GetAllObjects |
GetDatabaseObject | (Inherited from IDatabaseObjects.)
GetDependencyStacks | For internal use only.
GetObjectCollectionByType | Returns a readonly collection of database objects, of the specified type.
LoadFromDisk | Loads the database from disk.
LoadFromStream | Loads the database from a stream. This is an alternative to the LoadFromDisk method.
Register | Overloaded.
RegisterForDataCompare | Overloaded.
RegisterForDependencyViewer | Internal use only.
RegisterForRefactoring | Internal use only.
RegisterGetObjectOwners | Internal use only.
SaveToDisk | Saves the database to disk.
SaveToFolder | Overloaded.
SaveToStream | Writes the database snapshot to the specified stream. This is an alternative to the SaveToDisk method

Properties

Name | Description
Assemblies | The CLR assemblies in the database. Note that CLR assemblies were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
AsymmetricKeys | The asymmetric keys in the database. Note that asymmetric keys were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Cancel | Indicates whether the database registration has been canceled. (Inherited from ICancellationStatus.)
CaseSensitive | Indicates whether the database has been set up as case sensitive.
Certificates | The certificates in the database. Note that certificates were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
ClrAssemblyDependencies | The dependencies of the CLR assemblies in the database.
ClrAssemblyDependenciesBuilder | The dependencies of the CLR assemblies in the database.
Collation | The collation of the database.
ConnectionProperties | The connection properties for the database.
Contracts | The contracts in the database. Note that contracts were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
DatabaseSource |
DbInfo | Script File Information *INTERNAL USE ONLY*
DdlTriggers | The DDL triggers in the database. (Inherited from IDatabaseObjects.)
Defaults | The defaults in the database. (Inherited from IDatabaseObjects.)
Dependencies | The dependencies in the database.
DependenciesBuilder | The dependencies in the database.
EventNotifications | The database-level event notifications in the database. Note that event notifications were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
ExtendedProperties | Database-level extended properties. (Inherited from IDatabaseObjects.)
FullTextCatalogs | The full-text catalogs in the database. (Inherited from IDatabaseObjects.)
FullTextEnabled | True if the database has full text enabled.
FullTextStoplists | The full-text stoplists in the database. (Inherited from IDatabaseObjects.)
Functions | The user-defined functions in the database. (Inherited from IDatabaseObjects.)
IsAzure | Is this database an Azure database?
MajorVersion | The major version of the SQL Server for the database. This reflects the compatibility mode of the database. (Inherited from IVersionedDatabase.)
MessageTypes | The message types in the database. Note that message types were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
ParserMessages | A list of parser messages generated during population from a script folder. This will be null if the database source is not a set of scripts.
PartitionFunctions | The partition functions in the database. Note that partition functions were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
PartitionSchemes | The partition schemes in the database. Note that partitions schemes were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Queues | The queues in the database. Note that queues were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Roles | The roles in the database. (Inherited from IDatabaseObjects.)
Routes | The routes in the database. Note that routes were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Rules | The rules in the database. (Inherited from IDatabaseObjects.)
Schemas | The schemas in the database. Note that schemas were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
ScriptFolder |
SearchPropertyLists | (Inherited from IDatabaseObjects.)
SecurityPolicies | The security policies in the database. (Inherited from IDatabaseObjects.)
Sequences | The sequence objects in the database. Note that these were introduced in SQL Server 2012 (Inherited from IDatabaseObjects.)
ServerMajorVersion | The major server version of the SQL Server for the database. This does not change if the database is running in compatibility mode. (Inherited from IVersionedDatabase.)
ServiceBindings | The service bindings in the database. Note that service bindings were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Services | The services in the database. Note that services were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
SOCCompareLocationProvider |
SourceControlInfo |
SqlServerVersionInfo | Information about the version of SQL Server this database exists on, including version number, compatibility level, internal version and whether or not it's an Azure database. (Inherited from IVersionedDatabase.)
Status | Gets and sets a delegate that can be used to notify of message or percentage changes (Inherited from ICancellable.)
StoredProcedures | The stored procedures in the database. (Inherited from IDatabaseObjects.)
SupportedFeatures | (Inherited from IVersionedDatabase.)
SymmetricKeys | The symmetric keys in the database. Note that symmetric keys were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Synonyms | The synonyms in the database. Note that synonyms were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Tables | The tables in the database. (Inherited from IDatabaseObjects.)
UserDefinedTypes | The user-defined types in the database. (Inherited from IDatabaseObjects.)
Users | The users in the database. (Inherited from IDatabaseObjects.)
Views | The views in the database. (Inherited from IDatabaseObjects.)
XmlSchemaCollections | The XML schema collections in the database. Note that XML schema collections were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


IDatabase Methods

[image] [image]

SQL Data Compare API 12.0.40
IDatabase Methods
IDatabase Interface See Also

The IDatabase type exposes the following methods.

Methods

Name | Description
CancelOperation | Cancels the current running operation. This will throw an instance of OperationCancelledException at the currently executing location on the executing thread (Inherited from ICancellable.)
Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
CompareWith | Overloaded.
CreateEmptyTarget | For internal use only
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
GetAllObjects |
GetDatabaseObject | (Inherited from IDatabaseObjects.)
GetDependencyStacks | For internal use only.
GetObjectCollectionByType | Returns a readonly collection of database objects, of the specified type.
LoadFromDisk | Loads the database from disk.
LoadFromStream | Loads the database from a stream. This is an alternative to the LoadFromDisk method.
Register | Overloaded.
RegisterForDataCompare | Overloaded.
RegisterForDependencyViewer | Internal use only.
RegisterForRefactoring | Internal use only.
RegisterGetObjectOwners | Internal use only.
SaveToDisk | Saves the database to disk.
SaveToFolder | Overloaded.
SaveToStream | Writes the database snapshot to the specified stream. This is an alternative to the SaveToDisk method

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


CompareWith Method

[image] [image]

SQL Data Compare API 12.0.40
IDatabase..::.CompareWith Method
IDatabase Interface See Also

Overload List

Name | Description
CompareWith(Database, Options) | Compares the database with another database.
CompareWith(Database, Options, SqlCompareOwnerMappings) | Compares the database with another database.
CompareWith(Database, Options, SqlCompareOwnerMappings, SqlCompareTableMappings) | Compares the database with another database.

See Also

IDatabase Interface
IDatabase Members
RedGate.SQLCompare.Engine Namespace


CompareWith Method (Database, Options)

[image]

SQL Data Compare API 12.0.40
IDatabase..::.CompareWith Method (Database, Options)
IDatabase Interface Example See Also

Compares the database with another database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function CompareWith ( _
    targetDatabase As Database, _
    options As Options _
) As Differences
C#
Differences CompareWith(
    Database targetDatabase,
    Options options
)
Visual C++
Differences^ CompareWith(
    Database^ targetDatabase,
    Options options
)

Parameters

targetDatabase
Type: RedGate.SQLCompare.Engine..::.Database
The database to compare with.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

A Differences collection containing the differences between the two databases.

Remarks

When two databases have been compared they can be synchronized using the Work class. Note that all objects that differ are selected for synchronization by default.

Progress feedback is provided via the Status event.

Examples

This example shows how you compare two databases and print out a summary of the differences.
C# Copy Code
            Database db1=new Database();
            Database db2=new Database();

            db1.Register(new ConnectionProperties(".", "WidgetStaging"), Options.Default);
            db2.Register(new ConnectionProperties(".", "WidgetProduction"), Options.Default);

            Differences differences=db1.CompareWith(db2, Options.Default);

            foreach (Difference difference in differences)
            {
                Console.WriteLine("{0} {1} {2}", difference.Type.ToString(), difference.DatabaseObjectType.ToString(), difference.Name);
            }

            //dispose of the objects
            db1.Dispose();
            db2.Dispose();
Visual Basic Copy Code
            Dim db1 As New Database()
            Dim db2 As New Database()

            db1.Register(New ConnectionProperties(".", "WidgetStaging"), Options.Default)
            db2.Register(New ConnectionProperties(".", "WidgetProduction"), Options.Default)

            Dim differences As Differences = db1.CompareWith(db2, Options.Default)

            Dim difference As Difference

            For Each difference In differences
                Console.WriteLine("{0} {1} {2}", difference.Type.ToString(), difference.DatabaseObjectType.ToString(), difference.Name)
            Next

            'dispose of the objects
            db1.Dispose()
            db2.Dispose()

See Also

IDatabase Interface
CompareWith Overload
RedGate.SQLCompare.Engine Namespace


CompareWith Method (Database, Options, SqlCompareOwnerMappings)

[image]

SQL Data Compare API 12.0.40
IDatabase..::.CompareWith Method (Database, Options, SqlCompareOwnerMappings)
IDatabase Interface See Also

Compares the database with another database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function CompareWith ( _
    targetDatabase As Database, _
    options As Options, _
    ownerMappings As SqlCompareOwnerMappings _
) As Differences
C#
Differences CompareWith(
    Database targetDatabase,
    Options options,
    SqlCompareOwnerMappings ownerMappings
)
Visual C++
Differences^ CompareWith(
    Database^ targetDatabase,
    Options options,
    SqlCompareOwnerMappings^ ownerMappings
)

Parameters

targetDatabase
Type: RedGate.SQLCompare.Engine..::.Database
The database to compare with.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.
ownerMappings
Type: RedGate.SQLCompare.Engine..::.SqlCompareOwnerMappings
Owner mappings.

Return Value

A Differences collection containing the differences between the two databases.

Remarks

When two databases have been compared they can be synchronized using the Work class. Note that all objects that differ are selected for synchronization by default.

Progress feedback is provided via the Status event.

See Also

IDatabase Interface
CompareWith Overload
RedGate.SQLCompare.Engine Namespace


CompareWith Method (Database, Options, SqlCompareOwnerMappings, SqlCompareTableMappings)

[image]

SQL Data Compare API 12.0.40
IDatabase..::.CompareWith Method (Database, Options, SqlCompareOwnerMappings, SqlCompareTableMappings)
IDatabase Interface See Also

Compares the database with another database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function CompareWith ( _
    targetDatabase As Database, _
    options As Options, _
    ownerMappings As SqlCompareOwnerMappings, _
    tableMappings As SqlCompareTableMappings _
) As Differences
C#
Differences CompareWith(
    Database targetDatabase,
    Options options,
    SqlCompareOwnerMappings ownerMappings,
    SqlCompareTableMappings tableMappings
)
Visual C++
Differences^ CompareWith(
    Database^ targetDatabase,
    Options options,
    SqlCompareOwnerMappings^ ownerMappings,
    SqlCompareTableMappings^ tableMappings
)

Parameters

targetDatabase
Type: RedGate.SQLCompare.Engine..::.Database
The database to compare with.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.
ownerMappings
Type: RedGate.SQLCompare.Engine..::.SqlCompareOwnerMappings
Owner mappings.
tableMappings
Type: RedGate.SQLCompare.Engine..::.SqlCompareTableMappings
Table mappings.

Return Value

A Differences collection containing the differences between the two databases.

Remarks

When two databases have been compared they can be synchronized using the Work class. Note that all objects that differ are selected for synchronization by default.

Progress feedback is provided via the Status event.

See Also

IDatabase Interface
CompareWith Overload
RedGate.SQLCompare.Engine Namespace


CreateEmptyTarget Method

[image]

SQL Data Compare API 12.0.40
IDatabase..::.CreateEmptyTarget Method
IDatabase Interface See Also

For internal use only

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function CreateEmptyTarget ( _
    caseSensitive As Boolean _
) As Database
C#
Database CreateEmptyTarget(
    bool caseSensitive
)
Visual C++
Database^ CreateEmptyTarget(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

Return Value

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


GetAllObjects Method

[image]

SQL Data Compare API 12.0.40
IDatabase..::.GetAllObjects Method
IDatabase Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetAllObjects As IEnumerable(Of IDatabaseObject)
C#
IEnumerable<IDatabaseObject> GetAllObjects()
Visual C++
IEnumerable<IDatabaseObject^>^ GetAllObjects()

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


GetDependencyStacks Method

[image]

SQL Data Compare API 12.0.40
IDatabase..::.GetDependencyStacks Method
IDatabase Interface See Also

For internal use only.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetDependencyStacks As Dictionary(Of Integer, Stack(Of String()))
C#
Dictionary<int, Stack<string[]>> GetDependencyStacks()
Visual C++
Dictionary<int, Stack<array<String^>^>^>^ GetDependencyStacks()

Return Value

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


GetObjectCollectionByType Method

[image]

SQL Data Compare API 12.0.40
IDatabase..::.GetObjectCollectionByType Method
IDatabase Interface See Also

Returns a readonly collection of database objects, of the specified type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetObjectCollectionByType ( _
    type As ObjectType _
) As ICollection(Of IDatabaseObject)
C#
ICollection<IDatabaseObject> GetObjectCollectionByType(
    ObjectType type
)
Visual C++
ICollection<IDatabaseObject^>^ GetObjectCollectionByType(
    ObjectType type
)

Parameters

type
Type: ObjectType

Return Value

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


LoadFromDisk Method

[image]

SQL Data Compare API 12.0.40
IDatabase..::.LoadFromDisk Method
IDatabase Interface Example See Also

Loads the database from disk.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub LoadFromDisk ( _
    fileName As String, _
    caseSensitiveComparison As Boolean, _
    options As Nullable(Of Options) _
)
C#
void LoadFromDisk(
    string fileName,
    bool caseSensitiveComparison,
    Nullable<Options> options
)
Visual C++
void LoadFromDisk(
    String^ fileName,
    bool caseSensitiveComparison,
    Nullable<Options> options
)

Parameters

fileName
Type: String
The name of the database snapshot file to load.
caseSensitiveComparison
Type: Boolean
Whether the comparison is case sensitive (from the project options). This is checked against the case sensitivity of the snapshot to ensure that they match.
options
Type: Nullable<(Of <( Options >)>)

Remarks

Progress events are fired via the Status event.

Examples

See SaveToDisk(String) for a code sample.

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


LoadFromStream Method

[image]

SQL Data Compare API 12.0.40
IDatabase..::.LoadFromStream Method
IDatabase Interface See Also

Loads the database from a stream. This is an alternative to the LoadFromDisk method.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub LoadFromStream ( _
    f As Stream, _
    caseSensitiveComparison As Boolean, _
    options As Nullable(Of Options) _
)
C#
void LoadFromStream(
    Stream f,
    bool caseSensitiveComparison,
    Nullable<Options> options
)
Visual C++
void LoadFromStream(
    Stream^ f,
    bool caseSensitiveComparison,
    Nullable<Options> options
)

Parameters

f
Type: Stream
The open stream from which to read the database.
caseSensitiveComparison
Type: Boolean
Whether the comparison is case sensitive (from the project options). This is checked against the case sensitivity of the snapshot to ensure that they match.
options
Type: Nullable<(Of <( Options >)>)

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


Register Method

[image] [image]

SQL Data Compare API 12.0.40
IDatabase..::.Register Method
IDatabase Interface See Also

Overload List

Name | Description
Register(String, ScriptDatabaseInformation, Options) | Registers the database from creation scripts that are stored in the folder specified by the path parameter.
Register(ConnectionProperties, Options, IDmvModelFactory) | Registers a database.
Register(String, ScriptDatabaseInformation, Options, IEnumerable<(Of <(String>)>)) | Registers the database from creation scripts that are stored in the folder specified by the path parameter.
Register(String, ScriptDatabaseInformation, Options, IEnumerable<(Of <(String>)>), IReadFromFolderCache, IDatabaseFromFolderPopulator) |

See Also

IDatabase Interface
IDatabase Members
RedGate.SQLCompare.Engine Namespace


Register Method (, ScriptDatabaseInformation, Options)

[image]

SQL Data Compare API 12.0.40
IDatabase..::.Register Method (, ScriptDatabaseInformation, Options)
IDatabase Interface See Also

Registers the database from creation scripts that are stored in the folder specified by the path parameter.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub Register ( _
    path As String, _
    dbinfo As ScriptDatabaseInformation, _
    options As Options _
)
C#
void Register(
    string path,
    ScriptDatabaseInformation dbinfo,
    Options options
)
Visual C++
void Register(
    String^ path,
    ScriptDatabaseInformation^ dbinfo,
    Options options
)

Parameters

path
Type: String
The path to the folder that contains the creations scripts.
dbinfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
This is an optional parameter. If the specified folder contains the SQL Compare generated xml file with the necessary database information, it does not need to be specified. However, if the folder does not contain this information, or this information needs to be overriden, then this parameter must be set.
options
Type: RedGate.SQLCompare.Engine..::.Options
Options.

See Also

IDatabase Interface
Register Overload
RedGate.SQLCompare.Engine Namespace


Register Method (ConnectionProperties, Options, IDmvModelFactory)

[image]

SQL Data Compare API 12.0.40
IDatabase..::.Register Method (ConnectionProperties, Options, IDmvModelFactory)
IDatabase Interface Example See Also

Registers a database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub Register ( _
    connectionProperties As ConnectionProperties, _
    options As Options, _
    factory As IDmvModelFactory _
)
C#
void Register(
    ConnectionProperties connectionProperties,
    Options options,
    IDmvModelFactory factory
)
Visual C++
void Register(
    ConnectionProperties^ connectionProperties,
    Options options,
    IDmvModelFactory^ factory
)

Parameters

connectionProperties
Type: RedGate.SQLCompare.Engine..::.ConnectionProperties
The connection properties associated with the database.
options
Type: RedGate.SQLCompare.Engine..::.Options
Options.
factory
Type: RedGate.SQLCompare.Engine..::.IDmvModelFactory
Factory for creating DMV model objects

Remarks

Connects to a database and retrieves all schema information. The database object can then be saved to disk or used in a comparison. Progress feedback is provided via the Status event.

Examples

This example shows how you register a database from a live server, with feedback.
C# Copy Code
            using System;
            using RedGate.Shared.Utils;
            using RedGate.SQLCompare.Engine;

            namespace ConsoleApplication2
            {
                public class Class1
                {

                    public static void Main()
                    {
                        Class1 c1=new Class1();
                        c.Run();
                    }

                    private void StatusCallback(object sender, StatusEventArgs e)
                    {
                        //fired by the SqlProvider to indicate events

                        if (e.Message!=null)
                        {
                            Console.WriteLine(e.Message);
                        }

                        if (e.Percentage!=-1)
                        {
                            Console.WriteLine("{0}%", e.Percentage);
                        }

                    }

                    private void Run()
                    {
                        Database db=new Database();
                        db.Status+=new StatusEventHandler(StatusCallback);
                        db.Register(new ConnectionProperties(".", "WidgetStaging"),Options.Default);
                        db.Dispose();
                    }
                }
            }
Visual Basic Copy Code
            Option Explicit On

            Imports RedGate.Shared.Utils
            Imports RedGate.SQLCompare.Engine

            Module Module3

                Sub Main()

                    Dim c As Class1 = New Class1()

                    c.Run()
                    Console.WriteLine("Press [Enter]")
                    Console.ReadLine()

                End Sub

                Public Class Class1

                    Sub StatusCallback(ByVal sender As Object, ByVal e As StatusEventArgs)

                        If Not (e.Message Is Nothing) Then
                            Console.WriteLine(e.Message)
                        End If

                        If e.Percentage <> -1 Then
                            Console.WriteLine("{0}%", e.Percentage)
                        End If

                    End Sub

                    Sub Run()

                        Dim db As New Database()
                        db.Status = New StatusEventHandler(AddressOf Me.StatusCallback)
                        db.Register(New ConnectionProperties(".", "WidgetStaging"), Options.Default)
                        db.Dispose()
                    End Sub

                End Class
            End Module

See Also

IDatabase Interface
Register Overload
RedGate.SQLCompare.Engine Namespace


Register Method (, ScriptDatabaseInformation, Options, ())

[image]

SQL Data Compare API 12.0.40
IDatabase..::.Register Method (, ScriptDatabaseInformation, Options, <(Of <(>)>))
IDatabase Interface See Also

Registers the database from creation scripts that are stored in the folder specified by the path parameter.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub Register ( _
    path As String, _
    dbinfo As ScriptDatabaseInformation, _
    options As Options, _
    filesToUse As IEnumerable(Of String) _
)
C#
void Register(
    string path,
    ScriptDatabaseInformation dbinfo,
    Options options,
    IEnumerable<string> filesToUse
)
Visual C++
void Register(
    String^ path,
    ScriptDatabaseInformation^ dbinfo,
    Options options,
    IEnumerable<String^>^ filesToUse
)

Parameters

path
Type: String
The path to the folder that contains the creations scripts.
dbinfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
This is an optional parameter. If the specified folder contains the SQL Compare generated xml file with the necessary database information, it does not need to be specified. However, if the folder does not contain this information, or this information needs to be overriden, then this parameter must be set.
options
Type: RedGate.SQLCompare.Engine..::.Options
Options.
filesToUse
Type: IEnumerable<(Of <(String>)>)
A list of files to use for the register if this is set to null then any .sql file found under the path and it's subfolders will be used

See Also

IDatabase Interface
Register Overload
RedGate.SQLCompare.Engine Namespace


Register Method (, ScriptDatabaseInformation, Options, (), IReadFromFolderCache, IDatabaseFromFolderPopulator)

[image]

SQL Data Compare API 12.0.40
IDatabase..::.Register Method (, ScriptDatabaseInformation, Options, <(Of <(>)>), IReadFromFolderCache, IDatabaseFromFolderPopulator)
IDatabase Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Register ( _
    path As String, _
    dbinfo As ScriptDatabaseInformation, _
    options As Options, _
    filesToUse As IEnumerable(Of String), _
    cache As IReadFromFolderCache, _
    databasePopulator As IDatabaseFromFolderPopulator _
) As CacheResult
C#
CacheResult Register(
    string path,
    ScriptDatabaseInformation dbinfo,
    Options options,
    IEnumerable<string> filesToUse,
    IReadFromFolderCache cache,
    IDatabaseFromFolderPopulator databasePopulator
)
Visual C++
CacheResult^ Register(
    String^ path,
    ScriptDatabaseInformation^ dbinfo,
    Options options,
    IEnumerable<String^>^ filesToUse,
    IReadFromFolderCache^ cache,
    IDatabaseFromFolderPopulator^ databasePopulator
)

Parameters

path
Type: String
dbinfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
options
Type: RedGate.SQLCompare.Engine..::.Options
filesToUse
Type: IEnumerable<(Of <(String>)>)
cache
Type: RedGate.SQLCompare.Engine.ReadFromFolder.Cache..::.IReadFromFolderCache
databasePopulator
Type: RedGate.SQLCompare.Engine.Model.DatabaseObjects.DatabaseFromFolderPopulator..::.IDatabaseFromFolderPopulator

Exceptions

Exception | Condition
ArgumentNullException |
RedGate.SQLCompare.Engine..::.SqlCompareException |

See Also

IDatabase Interface
Register Overload
RedGate.SQLCompare.Engine Namespace


RegisterForDataCompare Method

[image] [image]

SQL Data Compare API 12.0.40
IDatabase..::.RegisterForDataCompare Method
IDatabase Interface See Also

Overload List

Name | Description
RegisterForDataCompare(ConnectionProperties) | Registers a database for SQL Data Compare.
RegisterForDataCompare(ConnectionProperties, Options) | Registers a database for SQL Data Compare.
RegisterForDataCompare(String, ScriptDatabaseInformation, Options) |

See Also

IDatabase Interface
IDatabase Members
RedGate.SQLCompare.Engine Namespace


RegisterForDataCompare Method (ConnectionProperties)

[image]

SQL Data Compare API 12.0.40
IDatabase..::.RegisterForDataCompare Method (ConnectionProperties)
IDatabase Interface See Also

Registers a database for SQL Data Compare.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub RegisterForDataCompare ( _
    connectionProperties As ConnectionProperties _
)
C#
void RegisterForDataCompare(
    ConnectionProperties connectionProperties
)
Visual C++
void RegisterForDataCompare(
    ConnectionProperties^ connectionProperties
)

Parameters

connectionProperties
Type: RedGate.SQLCompare.Engine..::.ConnectionProperties
The connection properties to use for the database connection.

See Also

IDatabase Interface
RegisterForDataCompare Overload
RedGate.SQLCompare.Engine Namespace


RegisterForDataCompare Method (ConnectionProperties, Options)

[image]

SQL Data Compare API 12.0.40
IDatabase..::.RegisterForDataCompare Method (ConnectionProperties, Options)
IDatabase Interface See Also

Registers a database for SQL Data Compare.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub RegisterForDataCompare ( _
    connectionProperties As ConnectionProperties, _
    options As Options _
)
C#
void RegisterForDataCompare(
    ConnectionProperties connectionProperties,
    Options options
)
Visual C++
void RegisterForDataCompare(
    ConnectionProperties^ connectionProperties,
    Options options
)

Parameters

connectionProperties
Type: RedGate.SQLCompare.Engine..::.ConnectionProperties
The connection properties to use for the database connection.
options
Type: RedGate.SQLCompare.Engine..::.Options
Options.

See Also

IDatabase Interface
RegisterForDataCompare Overload
RedGate.SQLCompare.Engine Namespace


RegisterForDataCompare Method (, ScriptDatabaseInformation, Options)

[image]

SQL Data Compare API 12.0.40
IDatabase..::.RegisterForDataCompare Method (, ScriptDatabaseInformation, Options)
IDatabase Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub RegisterForDataCompare ( _
    path As String, _
    dbinfo As ScriptDatabaseInformation, _
    options As Options _
)
C#
void RegisterForDataCompare(
    string path,
    ScriptDatabaseInformation dbinfo,
    Options options
)
Visual C++
void RegisterForDataCompare(
    String^ path,
    ScriptDatabaseInformation^ dbinfo,
    Options options
)

Parameters

path
Type: String
dbinfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

IDatabase Interface
RegisterForDataCompare Overload
RedGate.SQLCompare.Engine Namespace


RegisterForDependencyViewer Method

[image]

SQL Data Compare API 12.0.40
IDatabase..::.RegisterForDependencyViewer Method
IDatabase Interface See Also

Internal use only.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub RegisterForDependencyViewer ( _
    connectionProperties As ConnectionProperties, _
    options As Options _
)
C#
void RegisterForDependencyViewer(
    ConnectionProperties connectionProperties,
    Options options
)
Visual C++
void RegisterForDependencyViewer(
    ConnectionProperties^ connectionProperties,
    Options options
)

Parameters

connectionProperties
Type: RedGate.SQLCompare.Engine..::.ConnectionProperties
Internal use only.
options
Type: RedGate.SQLCompare.Engine..::.Options
Internal use only.

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


RegisterForRefactoring Method

[image]

SQL Data Compare API 12.0.40
IDatabase..::.RegisterForRefactoring Method
IDatabase Interface See Also

Internal use only.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub RegisterForRefactoring ( _
    connectionProperties As ConnectionProperties, _
    options As Options _
)
C#
void RegisterForRefactoring(
    ConnectionProperties connectionProperties,
    Options options
)
Visual C++
void RegisterForRefactoring(
    ConnectionProperties^ connectionProperties,
    Options options
)

Parameters

connectionProperties
Type: RedGate.SQLCompare.Engine..::.ConnectionProperties
Internal use only.
options
Type: RedGate.SQLCompare.Engine..::.Options
Internal use only.

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


RegisterGetObjectOwners Method

[image]

SQL Data Compare API 12.0.40
IDatabase..::.RegisterGetObjectOwners Method
IDatabase Interface See Also

Internal use only.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub RegisterGetObjectOwners ( _
    connectionProperties As ConnectionProperties, _
    options As Options _
)
C#
void RegisterGetObjectOwners(
    ConnectionProperties connectionProperties,
    Options options
)
Visual C++
void RegisterGetObjectOwners(
    ConnectionProperties^ connectionProperties,
    Options options
)

Parameters

connectionProperties
Type: RedGate.SQLCompare.Engine..::.ConnectionProperties
Internal use only.
options
Type: RedGate.SQLCompare.Engine..::.Options
Internal use only.

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


SaveToDisk Method

[image]

SQL Data Compare API 12.0.40
IDatabase..::.SaveToDisk Method
IDatabase Interface Example See Also

Saves the database to disk.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub SaveToDisk ( _
    fileName As String _
)
C#
void SaveToDisk(
    string fileName
)
Visual C++
void SaveToDisk(
    String^ fileName
)

Parameters

fileName
Type: String
The name of the snapshot file to be created.

Examples

The example shows how you save and load a snapshot.
C# Copy Code
            //register a database using integrated security
            Database db1=new Database();
            db.Register(new ConnectionProperties(".", "WidgetStaging"), Options.Default);

            //save the database to disk
            db.SaveToDisk(@"c:\WidgetStaging.snp");

            Database db2=new Database();
            db2.LoadFromDisk(@"c:\WidgetStaging.snp");

            //dispose of the objects
            db.Dispose();
            db2.Dispose();
Visual Basic Copy Code
            'register a database using integrated security
            Dim db1 As New Database()
            db.Register(New ConnectionProperties(".", "WidgetStaging"), Options.Default)

            'save the database to disk
            db.SaveToDisk("c:\WidgetStaging.snp")

            Dim db2 As New Database()
            db2.LoadFromDisk("c:\WidgetStaging.snp")

            'dispose of the objects
            db.Dispose()
            db2.Dispose()

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


SaveToFolder Method

[image] [image]

SQL Data Compare API 12.0.40
IDatabase..::.SaveToFolder Method
IDatabase Interface See Also

Overload List

Name | Description
SaveToFolder(String) | Obsolete. Saves the database as a set of creation scripts to the specified folder.
SaveToFolder(String, ScriptDatabaseInformation) | Saves the database as a set of creation scripts to the specified folder.
SaveToFolder(String, Options, ScriptDatabaseInformation, IFileNameGenerator) | Saves the database as a set of creation scripts to the specified folder.

See Also

IDatabase Interface
IDatabase Members
RedGate.SQLCompare.Engine Namespace


SaveToFolder Method ()

[image]

SQL Data Compare API 12.0.40
IDatabase..::.SaveToFolder Method ()
IDatabase Interface See Also

Saves the database as a set of creation scripts to the specified folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Please use the SaveToFolder(string folderName, ScriptDatabaseInformation dbInfo) method!",  _
    True)> _
Sub SaveToFolder ( _
    folderName As String _
)
C#
[ObsoleteAttribute("Please use the SaveToFolder(string folderName, ScriptDatabaseInformation dbInfo) method!",
    true)]
void SaveToFolder(
    string folderName
)
Visual C++
[ObsoleteAttribute(L"Please use the SaveToFolder(string folderName, ScriptDatabaseInformation dbInfo) method!",
    true)]
void SaveToFolder(
    String^ folderName
)

Parameters

folderName
Type: String

See Also

IDatabase Interface
SaveToFolder Overload
RedGate.SQLCompare.Engine Namespace


SaveToFolder Method (, ScriptDatabaseInformation)

[image]

SQL Data Compare API 12.0.40
IDatabase..::.SaveToFolder Method (, ScriptDatabaseInformation)
IDatabase Interface See Also

Saves the database as a set of creation scripts to the specified folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub SaveToFolder ( _
    folderName As String, _
    dbInfo As ScriptDatabaseInformation _
)
C#
void SaveToFolder(
    string folderName,
    ScriptDatabaseInformation dbInfo
)
Visual C++
void SaveToFolder(
    String^ folderName,
    ScriptDatabaseInformation^ dbInfo
)

Parameters

folderName
Type: String
dbInfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
Options to control how the script files are written to the folder - will be changed by the call

See Also

IDatabase Interface
SaveToFolder Overload
RedGate.SQLCompare.Engine Namespace


SaveToFolder Method (, Options, ScriptDatabaseInformation, IFileNameGenerator)

[image]

SQL Data Compare API 12.0.40
IDatabase..::.SaveToFolder Method (, Options, ScriptDatabaseInformation, IFileNameGenerator)
IDatabase Interface See Also

Saves the database as a set of creation scripts to the specified folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub SaveToFolder ( _
    folderName As String, _
    options As Options, _
    dbInfo As ScriptDatabaseInformation, _
    generator As IFileNameGenerator _
)
C#
void SaveToFolder(
    string folderName,
    Options options,
    ScriptDatabaseInformation dbInfo,
    IFileNameGenerator generator
)
Visual C++
void SaveToFolder(
    String^ folderName,
    Options options,
    ScriptDatabaseInformation^ dbInfo,
    IFileNameGenerator^ generator
)

Parameters

folderName
Type: String
options
Type: RedGate.SQLCompare.Engine..::.Options
Options to control how the database objects are scripted out
dbInfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
Options to control how the script files are written to the folder - will be changed by the call
generator
Type: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser..::.IFileNameGenerator
Generator will be autodetected if none is specified.

See Also

IDatabase Interface
SaveToFolder Overload
RedGate.SQLCompare.Engine Namespace


SaveToStream Method

[image]

SQL Data Compare API 12.0.40
IDatabase..::.SaveToStream Method
IDatabase Interface See Also

Writes the database snapshot to the specified stream. This is an alternative to the SaveToDisk method

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub SaveToStream ( _
    stream As Stream _
)
C#
void SaveToStream(
    Stream stream
)
Visual C++
void SaveToStream(
    Stream^ stream
)

Parameters

stream
Type: Stream
The stream to write to.

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


IDatabase Properties

[image] [image]

SQL Data Compare API 12.0.40
IDatabase Properties
IDatabase Interface See Also

The IDatabase type exposes the following properties.

Properties

Name | Description
Assemblies | The CLR assemblies in the database. Note that CLR assemblies were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
AsymmetricKeys | The asymmetric keys in the database. Note that asymmetric keys were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Cancel | Indicates whether the database registration has been canceled. (Inherited from ICancellationStatus.)
CaseSensitive | Indicates whether the database has been set up as case sensitive.
Certificates | The certificates in the database. Note that certificates were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
ClrAssemblyDependencies | The dependencies of the CLR assemblies in the database.
ClrAssemblyDependenciesBuilder | The dependencies of the CLR assemblies in the database.
Collation | The collation of the database.
ConnectionProperties | The connection properties for the database.
Contracts | The contracts in the database. Note that contracts were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
DatabaseSource |
DbInfo | Script File Information *INTERNAL USE ONLY*
DdlTriggers | The DDL triggers in the database. (Inherited from IDatabaseObjects.)
Defaults | The defaults in the database. (Inherited from IDatabaseObjects.)
Dependencies | The dependencies in the database.
DependenciesBuilder | The dependencies in the database.
EventNotifications | The database-level event notifications in the database. Note that event notifications were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
ExtendedProperties | Database-level extended properties. (Inherited from IDatabaseObjects.)
FullTextCatalogs | The full-text catalogs in the database. (Inherited from IDatabaseObjects.)
FullTextEnabled | True if the database has full text enabled.
FullTextStoplists | The full-text stoplists in the database. (Inherited from IDatabaseObjects.)
Functions | The user-defined functions in the database. (Inherited from IDatabaseObjects.)
IsAzure | Is this database an Azure database?
MajorVersion | The major version of the SQL Server for the database. This reflects the compatibility mode of the database. (Inherited from IVersionedDatabase.)
MessageTypes | The message types in the database. Note that message types were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
ParserMessages | A list of parser messages generated during population from a script folder. This will be null if the database source is not a set of scripts.
PartitionFunctions | The partition functions in the database. Note that partition functions were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
PartitionSchemes | The partition schemes in the database. Note that partitions schemes were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Queues | The queues in the database. Note that queues were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Roles | The roles in the database. (Inherited from IDatabaseObjects.)
Routes | The routes in the database. Note that routes were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Rules | The rules in the database. (Inherited from IDatabaseObjects.)
Schemas | The schemas in the database. Note that schemas were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
ScriptFolder |
SearchPropertyLists | (Inherited from IDatabaseObjects.)
SecurityPolicies | The security policies in the database. (Inherited from IDatabaseObjects.)
Sequences | The sequence objects in the database. Note that these were introduced in SQL Server 2012 (Inherited from IDatabaseObjects.)
ServerMajorVersion | The major server version of the SQL Server for the database. This does not change if the database is running in compatibility mode. (Inherited from IVersionedDatabase.)
ServiceBindings | The service bindings in the database. Note that service bindings were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Services | The services in the database. Note that services were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
SOCCompareLocationProvider |
SourceControlInfo |
SqlServerVersionInfo | Information about the version of SQL Server this database exists on, including version number, compatibility level, internal version and whether or not it's an Azure database. (Inherited from IVersionedDatabase.)
Status | Gets and sets a delegate that can be used to notify of message or percentage changes (Inherited from ICancellable.)
StoredProcedures | The stored procedures in the database. (Inherited from IDatabaseObjects.)
SupportedFeatures | (Inherited from IVersionedDatabase.)
SymmetricKeys | The symmetric keys in the database. Note that symmetric keys were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Synonyms | The synonyms in the database. Note that synonyms were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Tables | The tables in the database. (Inherited from IDatabaseObjects.)
UserDefinedTypes | The user-defined types in the database. (Inherited from IDatabaseObjects.)
Users | The users in the database. (Inherited from IDatabaseObjects.)
Views | The views in the database. (Inherited from IDatabaseObjects.)
XmlSchemaCollections | The XML schema collections in the database. Note that XML schema collections were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


CaseSensitive Property

[image]

SQL Data Compare API 12.0.40
IDatabase..::.CaseSensitive Property
IDatabase Interface See Also

Indicates whether the database has been set up as case sensitive.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CaseSensitive As Boolean
C#
bool CaseSensitive { get; }
Visual C++
property bool CaseSensitive {
    bool get ();
}

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


ClrAssemblyDependencies Property

[image]

SQL Data Compare API 12.0.40
IDatabase..::.ClrAssemblyDependencies Property
IDatabase Interface See Also

The dependencies of the CLR assemblies in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ClrAssemblyDependencies As Dependencies
C#
Dependencies ClrAssemblyDependencies { get; }
Visual C++
property Dependencies^ ClrAssemblyDependencies {
    Dependencies^ get ();
}

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


ClrAssemblyDependenciesBuilder Property

[image]

SQL Data Compare API 12.0.40
IDatabase..::.ClrAssemblyDependenciesBuilder Property
IDatabase Interface See Also

The dependencies of the CLR assemblies in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ClrAssemblyDependenciesBuilder As DependenciesBuilder
C#
DependenciesBuilder ClrAssemblyDependenciesBuilder { get; }
Visual C++
property DependenciesBuilder^ ClrAssemblyDependenciesBuilder {
    DependenciesBuilder^ get ();
}

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


Collation Property

[image]

SQL Data Compare API 12.0.40
IDatabase..::.Collation Property
IDatabase Interface See Also

The collation of the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Collation As String
C#
string Collation { get; }
Visual C++
property String^ Collation {
    String^ get ();
}

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


ConnectionProperties Property

[image]

SQL Data Compare API 12.0.40
IDatabase..::.ConnectionProperties Property
IDatabase Interface See Also

The connection properties for the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property ConnectionProperties As ConnectionProperties
C#
ConnectionProperties ConnectionProperties { get; set; }
Visual C++
property ConnectionProperties^ ConnectionProperties {
    ConnectionProperties^ get ();
    void set (ConnectionProperties^ value);
}

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


DatabaseSource Property

[image]

SQL Data Compare API 12.0.40
IDatabase..::.DatabaseSource Property
IDatabase Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property DatabaseSource As DatabaseSource
C#
DatabaseSource DatabaseSource { get; set; }
Visual C++
property DatabaseSource DatabaseSource {
    DatabaseSource get ();
    void set (DatabaseSource value);
}

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


DbInfo Property

[image]

SQL Data Compare API 12.0.40
IDatabase..::.DbInfo Property
IDatabase Interface See Also

Script File Information *INTERNAL USE ONLY*

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property DbInfo As ScriptDatabaseInformation
C#
ScriptDatabaseInformation DbInfo { get; set; }
Visual C++
property ScriptDatabaseInformation^ DbInfo {
    ScriptDatabaseInformation^ get ();
    void set (ScriptDatabaseInformation^ value);
}

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


Dependencies Property

[image]

SQL Data Compare API 12.0.40
IDatabase..::.Dependencies Property
IDatabase Interface See Also

The dependencies in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Dependencies As Dependencies
C#
Dependencies Dependencies { get; }
Visual C++
property Dependencies^ Dependencies {
    Dependencies^ get ();
}

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


DependenciesBuilder Property

[image]

SQL Data Compare API 12.0.40
IDatabase..::.DependenciesBuilder Property
IDatabase Interface See Also

The dependencies in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DependenciesBuilder As DependenciesBuilder
C#
DependenciesBuilder DependenciesBuilder { get; }
Visual C++
property DependenciesBuilder^ DependenciesBuilder {
    DependenciesBuilder^ get ();
}

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


FullTextEnabled Property

[image]

SQL Data Compare API 12.0.40
IDatabase..::.FullTextEnabled Property
IDatabase Interface See Also

True if the database has full text enabled.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property FullTextEnabled As Boolean
C#
bool FullTextEnabled { get; }
Visual C++
property bool FullTextEnabled {
    bool get ();
}

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


IsAzure Property

[image]

SQL Data Compare API 12.0.40
IDatabase..::.IsAzure Property
IDatabase Interface See Also

Is this database an Azure database?

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsAzure As Boolean
C#
bool IsAzure { get; }
Visual C++
property bool IsAzure {
    bool get ();
}

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


ParserMessages Property

[image]

SQL Data Compare API 12.0.40
IDatabase..::.ParserMessages Property
IDatabase Interface See Also

A list of parser messages generated during population from a script folder. This will be null if the database source is not a set of scripts.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ParserMessages As ReadOnlyListWrapper(Of ParserMessage)
C#
ReadOnlyListWrapper<ParserMessage> ParserMessages { get; }
Visual C++
property ReadOnlyListWrapper<ParserMessage^>^ ParserMessages {
    ReadOnlyListWrapper<ParserMessage^>^ get ();
}

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


ScriptFolder Property

[image]

SQL Data Compare API 12.0.40
IDatabase..::.ScriptFolder Property
IDatabase Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property ScriptFolder As String
C#
string ScriptFolder { get; set; }
Visual C++
property String^ ScriptFolder {
    String^ get ();
    void set (String^ value);
}

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


SOCCompareLocationProvider Property

[image]

SQL Data Compare API 12.0.40
IDatabase..::.SOCCompareLocationProvider Property
IDatabase Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property SOCCompareLocationProvider As ISOCCompareLocationProvider
C#
ISOCCompareLocationProvider SOCCompareLocationProvider { get; set; }
Visual C++
property ISOCCompareLocationProvider^ SOCCompareLocationProvider {
    ISOCCompareLocationProvider^ get ();
    void set (ISOCCompareLocationProvider^ value);
}

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


SourceControlInfo Property

[image]

SQL Data Compare API 12.0.40
IDatabase..::.SourceControlInfo Property
IDatabase Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property SourceControlInfo As SourceControlInfo
C#
SourceControlInfo SourceControlInfo { get; set; }
Visual C++
property SourceControlInfo^ SourceControlInfo {
    SourceControlInfo^ get ();
    void set (SourceControlInfo^ value);
}

See Also

IDatabase Interface
RedGate.SQLCompare.Engine Namespace


IDatabaseObject Interface

[image]

SQL Data Compare API 12.0.40
IDatabaseObject Interface
Members See Also

An interface implemented by database objects.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDatabaseObject _
    Implements ITSqlObject, ICanExistenceCheck
C#
public interface IDatabaseObject : ITSqlObject,
    ICanExistenceCheck
Visual C++
public interface class IDatabaseObject : ITSqlObject,
    ICanExistenceCheck

See Also

IDatabaseObject Members
RedGate.SQLCompare.Engine Namespace


IDatabaseObject Members

[image] [image]

SQL Data Compare API 12.0.40
IDatabaseObject Members
IDatabaseObject Interface Methods Properties See Also

The IDatabaseObject type exposes the following members.

Methods

Name | Description
Equals | Compares two database objects.

Properties

Name | Description
Database | The database to which the object belongs.
FullyQualifiedName | (Inherited from ITSqlObject.)
Name | (Inherited from ITSqlObject.)
ObjectType | (Inherited from ITSqlObject.)
Owner | (Inherited from ITSqlObject.)
QualifiedName | (Inherited from ITSqlObject.)

See Also

IDatabaseObject Interface
RedGate.SQLCompare.Engine Namespace


IDatabaseObject Methods

[image] [image]

SQL Data Compare API 12.0.40
IDatabaseObject Methods
IDatabaseObject Interface See Also

The IDatabaseObject type exposes the following methods.

Methods

Name | Description
Equals | Compares two database objects.

See Also

IDatabaseObject Interface
RedGate.SQLCompare.Engine Namespace


Equals Method

[image]

SQL Data Compare API 12.0.40
IDatabaseObject..::.Equals Method
IDatabaseObject Interface See Also

Compares two database objects.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
bool Equals(
    IDatabaseObject^ target,
    Options options
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The object to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
The comparison options.

Return Value

True if the database objects are identical; otherwise false.

See Also

IDatabaseObject Interface
RedGate.SQLCompare.Engine Namespace


IDatabaseObject Properties

[image] [image]

SQL Data Compare API 12.0.40
IDatabaseObject Properties
IDatabaseObject Interface See Also

The IDatabaseObject type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs.
FullyQualifiedName | (Inherited from ITSqlObject.)
Name | (Inherited from ITSqlObject.)
ObjectType | (Inherited from ITSqlObject.)
Owner | (Inherited from ITSqlObject.)
QualifiedName | (Inherited from ITSqlObject.)

See Also

IDatabaseObject Interface
RedGate.SQLCompare.Engine Namespace


Database Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObject..::.Database Property
IDatabaseObject Interface See Also

The database to which the object belongs.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Database As Database
C#
Database Database { get; }
Visual C++
property Database^ Database {
    Database^ get ();
}

See Also

IDatabaseObject Interface
RedGate.SQLCompare.Engine Namespace


IDatabaseObjectExtensionMethods Class

[image]

SQL Data Compare API 12.0.40
IDatabaseObjectExtensionMethods Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class IDatabaseObjectExtensionMethods
C#
public static class IDatabaseObjectExtensionMethods
Visual C++
public ref class IDatabaseObjectExtensionMethods abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.IDatabaseObjectExtensionMethods

See Also

IDatabaseObjectExtensionMethods Members
RedGate.SQLCompare.Engine Namespace


IDatabaseObjectExtensionMethods Members

[image] [image]

SQL Data Compare API 12.0.40
IDatabaseObjectExtensionMethods Members
IDatabaseObjectExtensionMethods Class Methods See Also

Methods

Name | Description
ScriptObject | Overloaded.

See Also

IDatabaseObjectExtensionMethods Class
RedGate.SQLCompare.Engine Namespace


IDatabaseObjectExtensionMethods Methods

[image] [image]

SQL Data Compare API 12.0.40
IDatabaseObjectExtensionMethods Methods
IDatabaseObjectExtensionMethods Class See Also

Methods

Name | Description
ScriptObject | Overloaded.

See Also

IDatabaseObjectExtensionMethods Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image] [image]

SQL Data Compare API 12.0.40
IDatabaseObjectExtensionMethods..::.ScriptObject Method
IDatabaseObjectExtensionMethods Class See Also

Overload List

Name | Description
ScriptObject(ITSqlObject, Options) |
ScriptObject(ScriptableDatabaseObject, SqlSetOptions, Options) |

See Also

IDatabaseObjectExtensionMethods Class
IDatabaseObjectExtensionMethods Members
RedGate.SQLCompare.Engine Namespace


ScriptObject Method (, Options)

[image]

SQL Data Compare API 12.0.40
IDatabaseObjectExtensionMethods..::.ScriptObject Method (, Options)
IDatabaseObjectExtensionMethods Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ScriptObject ( _
    objectToScript As ITSqlObject, _
    options As Options _
) As Regions
C#
public static Regions ScriptObject(
    ITSqlObject objectToScript,
    Options options
)
Visual C++
public:
static Regions^ ScriptObject(
    ITSqlObject^ objectToScript,
    Options options
)

Parameters

objectToScript
Type: ITSqlObject
options
Type: RedGate.SQLCompare.Engine..::.Options

Return Value

See Also

IDatabaseObjectExtensionMethods Class
ScriptObject Overload
RedGate.SQLCompare.Engine Namespace


ScriptObject Method (ScriptableDatabaseObject, SqlSetOptions, Options)

[image]

SQL Data Compare API 12.0.40
IDatabaseObjectExtensionMethods..::.ScriptObject Method (ScriptableDatabaseObject, SqlSetOptions, Options)
IDatabaseObjectExtensionMethods Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ScriptObject ( _
    objectToScript As ScriptableDatabaseObject, _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public static Regions ScriptObject(
    ScriptableDatabaseObject objectToScript,
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
static Regions^ ScriptObject(
    ScriptableDatabaseObject^ objectToScript,
    SqlSetOptions^ sqlSetOptions,
    Options options
)

Parameters

objectToScript
Type: RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
options
Type: RedGate.SQLCompare.Engine..::.Options

Return Value

The regions for a ScriptableDatabaseObject suitable for showing in the diff viewer

See Also

IDatabaseObjectExtensionMethods Class
ScriptObject Overload
RedGate.SQLCompare.Engine Namespace


IDifferences Interface

[image]

SQL Data Compare API 12.0.40
IDifferences Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDifferences _
    Implements IEnumerable(Of Difference), IEnumerable
C#
public interface IDifferences : IEnumerable<Difference>,
    IEnumerable
Visual C++
public interface class IDifferences : IEnumerable<Difference^>,
    IEnumerable

See Also

IDifferences Members
RedGate.SQLCompare.Engine Namespace


IDifferences Members

[image] [image]

SQL Data Compare API 12.0.40
IDifferences Members
IDifferences Interface Methods Properties See Also

The IDifferences type exposes the following members.

Methods

Name | Description
GetEnumerator | Overloaded.
GetRenamedObject | For internal use only.

Properties

Name | Description
AreAllEqual |
Database1 | The first database to be compared.
Database2 | The second database to be compared.

See Also

IDifferences Interface
RedGate.SQLCompare.Engine Namespace


IDifferences Methods

[image] [image]

SQL Data Compare API 12.0.40
IDifferences Methods
IDifferences Interface See Also

The IDifferences type exposes the following methods.

Methods

Name | Description
GetEnumerator | Overloaded.
GetRenamedObject | For internal use only.

See Also

IDifferences Interface
RedGate.SQLCompare.Engine Namespace


GetEnumerator Method

[image] [image]

SQL Data Compare API 12.0.40
IDifferences..::.GetEnumerator Method
IDifferences Interface See Also

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( Difference >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IDifferences Interface
IDifferences Members
RedGate.SQLCompare.Engine Namespace


GetRenamedObject Method

[image]

SQL Data Compare API 12.0.40
IDifferences..::.GetRenamedObject Method
IDifferences Interface See Also

For internal use only.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetRenamedObject As IDatabaseObject
C#
IDatabaseObject GetRenamedObject()
Visual C++
IDatabaseObject^ GetRenamedObject()

Return Value

See Also

IDifferences Interface
RedGate.SQLCompare.Engine Namespace


IDifferences Properties

[image] [image]

SQL Data Compare API 12.0.40
IDifferences Properties
IDifferences Interface See Also

The IDifferences type exposes the following properties.

Properties

Name | Description
AreAllEqual |
Database1 | The first database to be compared.
Database2 | The second database to be compared.

See Also

IDifferences Interface
RedGate.SQLCompare.Engine Namespace


AreAllEqual Property

[image]

SQL Data Compare API 12.0.40
IDifferences..::.AreAllEqual Property
IDifferences Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property AreAllEqual As Boolean
C#
bool AreAllEqual { get; }
Visual C++
property bool AreAllEqual {
    bool get ();
}

See Also

IDifferences Interface
RedGate.SQLCompare.Engine Namespace


Database1 Property

[image]

SQL Data Compare API 12.0.40
IDifferences..::.Database1 Property
IDifferences Interface See Also

The first database to be compared.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Database1 As Database
C#
Database Database1 { get; }
Visual C++
property Database^ Database1 {
    Database^ get ();
}

See Also

IDifferences Interface
RedGate.SQLCompare.Engine Namespace


Database2 Property

[image]

SQL Data Compare API 12.0.40
IDifferences..::.Database2 Property
IDifferences Interface See Also

The second database to be compared.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Database2 As Database
C#
Database Database2 { get; }
Visual C++
property Database^ Database2 {
    Database^ get ();
}

See Also

IDifferences Interface
RedGate.SQLCompare.Engine Namespace


IDmvModel Interface

[image]

SQL Data Compare API 12.0.40
IDmvModel Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDmvModel _
    Implements IDisposable, IEncryptedTextReader
C#
public interface IDmvModel : IDisposable,
    IEncryptedTextReader
Visual C++
public interface class IDmvModel : IDisposable,
    IEncryptedTextReader

See Also

IDmvModel Members
RedGate.SQLCompare.Engine Namespace


IDmvModel Members

[image] [image]

SQL Data Compare API 12.0.40
IDmvModel Members
IDmvModel Interface Methods Properties See Also

The IDmvModel type exposes the following members.

Methods

Name | Description
Assemblies |
AssemblyDependencies |
AssemblyFiles |
AsymmetricKey |
CaseCheck |
Catalog |
Certificate |
Comment |
CommentForDataCompare |
Constraint |
Contract |
ContractMessage |
Count |
DdlTrigger |
Default |
Dependency |
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
EventNotification |
ExecuteSqlKey |
ExtendedProperty |
Field |
FileTableSystemDefinedObjects |
Function |
GetEncryptedText | Get the decrypted text for an object. Do not call if you are not viewing decrypted objects as it has significant performance impacts. (6-7 seconds on ICUST_1) (Inherited from IEncryptedTextReader.)
ID |
Index |
Member |
MessageType |
Parameter |
PartitionFunction |
PartitionParameter |
PartitionRangeValue |
PartitionScheme |
Permission |
Procedure |
Queue |
RemoteServiceBinding |
Role |
Route |
Rule |
Schema |
SearchPropertyList |
SecurityPolicy |
Sequence |
Service |
ServiceContract |
Setting |
SqlFeatureUsage |
Statistic |
Stoplist |
Stopword |
SymmetricKey |
Synonym |
Table |
TableUdt |
Trigger |
Udt |
UdtDependency |
User |
View |
ViewColumn |
ViewColumnWithDetails |
XmlCollection |
XmlCollectionDependencies |

Properties

Name | Description
CanDecrypt | (Inherited from IEncryptedTextReader.)
CanReadExpressionDependencies |
DatabaseSource |
EncryptionGuid |
SelectiveXmlIndexNamespaces |
SelectiveXmlIndexPaths |
VersionInformation |

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


IDmvModel Methods

[image] [image]

SQL Data Compare API 12.0.40
IDmvModel Methods
IDmvModel Interface See Also

The IDmvModel type exposes the following methods.

Methods

Name | Description
Assemblies |
AssemblyDependencies |
AssemblyFiles |
AsymmetricKey |
CaseCheck |
Catalog |
Certificate |
Comment |
CommentForDataCompare |
Constraint |
Contract |
ContractMessage |
Count |
DdlTrigger |
Default |
Dependency |
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
EventNotification |
ExecuteSqlKey |
ExtendedProperty |
Field |
FileTableSystemDefinedObjects |
Function |
GetEncryptedText | Get the decrypted text for an object. Do not call if you are not viewing decrypted objects as it has significant performance impacts. (6-7 seconds on ICUST_1) (Inherited from IEncryptedTextReader.)
ID |
Index |
Member |
MessageType |
Parameter |
PartitionFunction |
PartitionParameter |
PartitionRangeValue |
PartitionScheme |
Permission |
Procedure |
Queue |
RemoteServiceBinding |
Role |
Route |
Rule |
Schema |
SearchPropertyList |
SecurityPolicy |
Sequence |
Service |
ServiceContract |
Setting |
SqlFeatureUsage |
Statistic |
Stoplist |
Stopword |
SymmetricKey |
Synonym |
Table |
TableUdt |
Trigger |
Udt |
UdtDependency |
User |
View |
ViewColumn |
ViewColumnWithDetails |
XmlCollection |
XmlCollectionDependencies |

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Assemblies Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Assemblies Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Assemblies As IEnumerable(Of AssemblyQueryResult)
C#
IEnumerable<AssemblyQueryResult> Assemblies()
Visual C++
IEnumerable<AssemblyQueryResult^>^ Assemblies()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


AssemblyDependencies Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.AssemblyDependencies Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function AssemblyDependencies As IEnumerable(Of AssemblyDependencyQueryResult)
C#
IEnumerable<AssemblyDependencyQueryResult> AssemblyDependencies()
Visual C++
IEnumerable<AssemblyDependencyQueryResult^>^ AssemblyDependencies()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


AssemblyFiles Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.AssemblyFiles Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function AssemblyFiles As IEnumerable(Of AssemblyFileQueryResult)
C#
IEnumerable<AssemblyFileQueryResult> AssemblyFiles()
Visual C++
IEnumerable<AssemblyFileQueryResult^>^ AssemblyFiles()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


AsymmetricKey Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.AsymmetricKey Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function AsymmetricKey As IEnumerable(Of AsymmetricKeyQueryResult)
C#
IEnumerable<AsymmetricKeyQueryResult> AsymmetricKey()
Visual C++
IEnumerable<AsymmetricKeyQueryResult^>^ AsymmetricKey()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


CaseCheck Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.CaseCheck Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function CaseCheck As String
C#
string CaseCheck()
Visual C++
String^ CaseCheck()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Catalog Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Catalog Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Catalog As IEnumerable(Of FullTextCatalogQueryResult)
C#
IEnumerable<FullTextCatalogQueryResult> Catalog()
Visual C++
IEnumerable<FullTextCatalogQueryResult^>^ Catalog()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Certificate Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Certificate Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Certificate As IEnumerable(Of CertificateQueryResult)
C#
IEnumerable<CertificateQueryResult> Certificate()
Visual C++
IEnumerable<CertificateQueryResult^>^ Certificate()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Comment Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Comment Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Comment ( _
    decryptObjects As Boolean _
) As IEnumerable(Of CommentQueryResult)
C#
IEnumerable<CommentQueryResult> Comment(
    bool decryptObjects
)
Visual C++
IEnumerable<CommentQueryResult^>^ Comment(
    bool decryptObjects
)

Parameters

decryptObjects
Type: Boolean

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


CommentForDataCompare Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.CommentForDataCompare Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function CommentForDataCompare ( _
    decryptObjects As Boolean _
) As IEnumerable(Of CommentQueryResult)
C#
IEnumerable<CommentQueryResult> CommentForDataCompare(
    bool decryptObjects
)
Visual C++
IEnumerable<CommentQueryResult^>^ CommentForDataCompare(
    bool decryptObjects
)

Parameters

decryptObjects
Type: Boolean

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Constraint Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Constraint Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Constraint As IEnumerable(Of ConstraintQueryResult)
C#
IEnumerable<ConstraintQueryResult> Constraint()
Visual C++
IEnumerable<ConstraintQueryResult^>^ Constraint()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Contract Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Contract Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Contract As IEnumerable(Of ContractQueryResult)
C#
IEnumerable<ContractQueryResult> Contract()
Visual C++
IEnumerable<ContractQueryResult^>^ Contract()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


ContractMessage Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.ContractMessage Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function ContractMessage As IEnumerable(Of ContractMessageQueryResult)
C#
IEnumerable<ContractMessageQueryResult> ContractMessage()
Visual C++
IEnumerable<ContractMessageQueryResult^>^ ContractMessage()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Count Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Count Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Count As Long
C#
long Count()
Visual C++
long long Count()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


DdlTrigger Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.DdlTrigger Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function DdlTrigger As IEnumerable(Of DdlTriggerQueryResult)
C#
IEnumerable<DdlTriggerQueryResult> DdlTrigger()
Visual C++
IEnumerable<DdlTriggerQueryResult^>^ DdlTrigger()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Default Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Default Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Default As IEnumerable(Of DefaultQueryResult)
C#
IEnumerable<DefaultQueryResult> Default()
Visual C++
IEnumerable<DefaultQueryResult^>^ Default()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Dependency Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Dependency Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Dependency As IEnumerable(Of ExpressionDependencyQueryResult)
C#
IEnumerable<ExpressionDependencyQueryResult> Dependency()
Visual C++
IEnumerable<ExpressionDependencyQueryResult^>^ Dependency()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


EventNotification Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.EventNotification Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function EventNotification As IEnumerable(Of EventNotificationQueryResult)
C#
IEnumerable<EventNotificationQueryResult> EventNotification()
Visual C++
IEnumerable<EventNotificationQueryResult^>^ EventNotification()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


ExecuteSqlKey Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.ExecuteSqlKey Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function ExecuteSqlKey As IEnumerable(Of ForeignKeyQueryResult)
C#
IEnumerable<ForeignKeyQueryResult> ExecuteSqlKey()
Visual C++
IEnumerable<ForeignKeyQueryResult^>^ ExecuteSqlKey()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


ExtendedProperty Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.ExtendedProperty Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function ExtendedProperty ( _
    serverMajorVersion As SQLVersion _
) As IEnumerable(Of ExtendedPropertyQueryResult)
C#
IEnumerable<ExtendedPropertyQueryResult> ExtendedProperty(
    SQLVersion serverMajorVersion
)
Visual C++
IEnumerable<ExtendedPropertyQueryResult^>^ ExtendedProperty(
    SQLVersion serverMajorVersion
)

Parameters

serverMajorVersion
Type: SQLVersion

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Field Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Field Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Field As IEnumerable(Of FieldQueryResult)
C#
IEnumerable<FieldQueryResult> Field()
Visual C++
IEnumerable<FieldQueryResult^>^ Field()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


FileTableSystemDefinedObjects Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.FileTableSystemDefinedObjects Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function FileTableSystemDefinedObjects As IEnumerable(Of FileTableSystemDefinedObjectQueryResult)
C#
IEnumerable<FileTableSystemDefinedObjectQueryResult> FileTableSystemDefinedObjects()
Visual C++
IEnumerable<FileTableSystemDefinedObjectQueryResult^>^ FileTableSystemDefinedObjects()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Function Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Function Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Function As IEnumerable(Of FunctionQueryResult)
C#
IEnumerable<FunctionQueryResult> Function()
Visual C++
IEnumerable<FunctionQueryResult^>^ Function()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


ID Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.ID Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function ID As IEnumerable(Of ObjectNameQueryResult)
C#
IEnumerable<ObjectNameQueryResult> ID()
Visual C++
IEnumerable<ObjectNameQueryResult^>^ ID()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Index Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Index Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Index As IEnumerable(Of IndexQueryResult)
C#
IEnumerable<IndexQueryResult> Index()
Visual C++
IEnumerable<IndexQueryResult^>^ Index()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Member Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Member Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Member As IEnumerable(Of RoleQueryResult)
C#
IEnumerable<RoleQueryResult> Member()
Visual C++
IEnumerable<RoleQueryResult^>^ Member()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


MessageType Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.MessageType Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function MessageType As IEnumerable(Of MessageTypeQueryResult)
C#
IEnumerable<MessageTypeQueryResult> MessageType()
Visual C++
IEnumerable<MessageTypeQueryResult^>^ MessageType()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Parameter Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Parameter Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Parameter As IEnumerable(Of ParameterQueryResult)
C#
IEnumerable<ParameterQueryResult> Parameter()
Visual C++
IEnumerable<ParameterQueryResult^>^ Parameter()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


PartitionFunction Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.PartitionFunction Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function PartitionFunction As IEnumerable(Of PartitionFunctionQueryResult)
C#
IEnumerable<PartitionFunctionQueryResult> PartitionFunction()
Visual C++
IEnumerable<PartitionFunctionQueryResult^>^ PartitionFunction()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


PartitionParameter Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.PartitionParameter Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function PartitionParameter As IEnumerable(Of PartitionParameterQueryResult)
C#
IEnumerable<PartitionParameterQueryResult> PartitionParameter()
Visual C++
IEnumerable<PartitionParameterQueryResult^>^ PartitionParameter()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


PartitionRangeValue Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.PartitionRangeValue Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function PartitionRangeValue As IEnumerable(Of PartitionRangeValueSqlResult)
C#
IEnumerable<PartitionRangeValueSqlResult> PartitionRangeValue()
Visual C++
IEnumerable<PartitionRangeValueSqlResult^>^ PartitionRangeValue()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


PartitionScheme Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.PartitionScheme Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function PartitionScheme As IEnumerable(Of SqlPartitionSchemeResult)
C#
IEnumerable<SqlPartitionSchemeResult> PartitionScheme()
Visual C++
IEnumerable<SqlPartitionSchemeResult^>^ PartitionScheme()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Permission Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Permission Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Permission As IEnumerable(Of SqlPermissionResult)
C#
IEnumerable<SqlPermissionResult> Permission()
Visual C++
IEnumerable<SqlPermissionResult^>^ Permission()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Procedure Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Procedure Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Procedure As IEnumerable(Of SqlProcedureResult)
C#
IEnumerable<SqlProcedureResult> Procedure()
Visual C++
IEnumerable<SqlProcedureResult^>^ Procedure()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Queue Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Queue Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Queue As IEnumerable(Of SqlQueueResult)
C#
IEnumerable<SqlQueueResult> Queue()
Visual C++
IEnumerable<SqlQueueResult^>^ Queue()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


RemoteServiceBinding Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.RemoteServiceBinding Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function RemoteServiceBinding As IEnumerable(Of SqlRemoteServiceBindingResult)
C#
IEnumerable<SqlRemoteServiceBindingResult> RemoteServiceBinding()
Visual C++
IEnumerable<SqlRemoteServiceBindingResult^>^ RemoteServiceBinding()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Role Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Role Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Role As IEnumerable(Of SqlRoleResult)
C#
IEnumerable<SqlRoleResult> Role()
Visual C++
IEnumerable<SqlRoleResult^>^ Role()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Route Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Route Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Route As IEnumerable(Of SqlRouteResult)
C#
IEnumerable<SqlRouteResult> Route()
Visual C++
IEnumerable<SqlRouteResult^>^ Route()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Rule Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Rule Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Rule As IEnumerable(Of SqlRuleResult)
C#
IEnumerable<SqlRuleResult> Rule()
Visual C++
IEnumerable<SqlRuleResult^>^ Rule()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Schema Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Schema Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Schema As IEnumerable(Of SqlSchemasResult)
C#
IEnumerable<SqlSchemasResult> Schema()
Visual C++
IEnumerable<SqlSchemasResult^>^ Schema()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


SearchPropertyList Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.SearchPropertyList Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function SearchPropertyList As IEnumerable(Of SqlSearchPropertyListResult)
C#
IEnumerable<SqlSearchPropertyListResult> SearchPropertyList()
Visual C++
IEnumerable<SqlSearchPropertyListResult^>^ SearchPropertyList()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


SecurityPolicy Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.SecurityPolicy Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function SecurityPolicy As IEnumerable(Of SecurityPolicyQueryResult)
C#
IEnumerable<SecurityPolicyQueryResult> SecurityPolicy()
Visual C++
IEnumerable<SecurityPolicyQueryResult^>^ SecurityPolicy()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Sequence Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Sequence Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Sequence As IEnumerable(Of SqlSequencesResult)
C#
IEnumerable<SqlSequencesResult> Sequence()
Visual C++
IEnumerable<SqlSequencesResult^>^ Sequence()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Service Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Service Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Service As IEnumerable(Of SqlServiceResult)
C#
IEnumerable<SqlServiceResult> Service()
Visual C++
IEnumerable<SqlServiceResult^>^ Service()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


ServiceContract Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.ServiceContract Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function ServiceContract As IEnumerable(Of SqlServiceContractResult)
C#
IEnumerable<SqlServiceContractResult> ServiceContract()
Visual C++
IEnumerable<SqlServiceContractResult^>^ ServiceContract()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Setting Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Setting Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Setting As SqlSettingResult
C#
SqlSettingResult Setting()
Visual C++
SqlSettingResult^ Setting()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


SqlFeatureUsage Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.SqlFeatureUsage Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function SqlFeatureUsage As SqlFeatureUsageResult
C#
SqlFeatureUsageResult SqlFeatureUsage()
Visual C++
SqlFeatureUsageResult^ SqlFeatureUsage()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Statistic Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Statistic Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Statistic As IEnumerable(Of SqlStatisticsResult)
C#
IEnumerable<SqlStatisticsResult> Statistic()
Visual C++
IEnumerable<SqlStatisticsResult^>^ Statistic()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Stoplist Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Stoplist Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Stoplist As IEnumerable(Of SqlStoplistResult)
C#
IEnumerable<SqlStoplistResult> Stoplist()
Visual C++
IEnumerable<SqlStoplistResult^>^ Stoplist()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Stopword Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Stopword Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Stopword As IEnumerable(Of SqlStopwordResult)
C#
IEnumerable<SqlStopwordResult> Stopword()
Visual C++
IEnumerable<SqlStopwordResult^>^ Stopword()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


SymmetricKey Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.SymmetricKey Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function SymmetricKey As IEnumerable(Of SqlSymmetricKeyResult)
C#
IEnumerable<SqlSymmetricKeyResult> SymmetricKey()
Visual C++
IEnumerable<SqlSymmetricKeyResult^>^ SymmetricKey()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Synonym Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Synonym Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Synonym As IEnumerable(Of SqlSynonymResult)
C#
IEnumerable<SqlSynonymResult> Synonym()
Visual C++
IEnumerable<SqlSynonymResult^>^ Synonym()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Table Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Table Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Table As IEnumerable(Of SqlTableResult)
C#
IEnumerable<SqlTableResult> Table()
Visual C++
IEnumerable<SqlTableResult^>^ Table()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


TableUdt Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.TableUdt Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function TableUdt As IEnumerable(Of SqlTableUdtResult)
C#
IEnumerable<SqlTableUdtResult> TableUdt()
Visual C++
IEnumerable<SqlTableUdtResult^>^ TableUdt()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Trigger Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Trigger Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Trigger As IEnumerable(Of SqlTriggerResult)
C#
IEnumerable<SqlTriggerResult> Trigger()
Visual C++
IEnumerable<SqlTriggerResult^>^ Trigger()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


Udt Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.Udt Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Udt As IEnumerable(Of SqlUdtResult)
C#
IEnumerable<SqlUdtResult> Udt()
Visual C++
IEnumerable<SqlUdtResult^>^ Udt()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


UdtDependency Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.UdtDependency Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function UdtDependency As IEnumerable(Of UdtDependencyResult)
C#
IEnumerable<UdtDependencyResult> UdtDependency()
Visual C++
IEnumerable<UdtDependencyResult^>^ UdtDependency()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


User Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.User Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function User As IEnumerable(Of SqlUserResult)
C#
IEnumerable<SqlUserResult> User()
Visual C++
IEnumerable<SqlUserResult^>^ User()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


View Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.View Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function View As IEnumerable(Of SqlViewResult)
C#
IEnumerable<SqlViewResult> View()
Visual C++
IEnumerable<SqlViewResult^>^ View()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


ViewColumn Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.ViewColumn Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function ViewColumn As IEnumerable(Of SqlViewColumnWithDetailsResult)
C#
IEnumerable<SqlViewColumnWithDetailsResult> ViewColumn()
Visual C++
IEnumerable<SqlViewColumnWithDetailsResult^>^ ViewColumn()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


ViewColumnWithDetails Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.ViewColumnWithDetails Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function ViewColumnWithDetails As IEnumerable(Of SqlViewColumnWithDetailsResult)
C#
IEnumerable<SqlViewColumnWithDetailsResult> ViewColumnWithDetails()
Visual C++
IEnumerable<SqlViewColumnWithDetailsResult^>^ ViewColumnWithDetails()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


XmlCollection Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.XmlCollection Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function XmlCollection As IEnumerable(Of XmlCollectionResult)
C#
IEnumerable<XmlCollectionResult> XmlCollection()
Visual C++
IEnumerable<XmlCollectionResult^>^ XmlCollection()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


XmlCollectionDependencies Method

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.XmlCollectionDependencies Method
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function XmlCollectionDependencies As IEnumerable(Of XmlCollectionDependencyResult)
C#
IEnumerable<XmlCollectionDependencyResult> XmlCollectionDependencies()
Visual C++
IEnumerable<XmlCollectionDependencyResult^>^ XmlCollectionDependencies()

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


IDmvModel Properties

[image] [image]

SQL Data Compare API 12.0.40
IDmvModel Properties
IDmvModel Interface See Also

The IDmvModel type exposes the following properties.

Properties

Name | Description
CanDecrypt | (Inherited from IEncryptedTextReader.)
CanReadExpressionDependencies |
DatabaseSource |
EncryptionGuid |
SelectiveXmlIndexNamespaces |
SelectiveXmlIndexPaths |
VersionInformation |

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


CanReadExpressionDependencies Property

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.CanReadExpressionDependencies Property
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CanReadExpressionDependencies As Boolean
C#
bool CanReadExpressionDependencies { get; }
Visual C++
property bool CanReadExpressionDependencies {
    bool get ();
}

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


DatabaseSource Property

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.DatabaseSource Property
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DatabaseSource As DatabaseSource
C#
DatabaseSource DatabaseSource { get; }
Visual C++
property DatabaseSource DatabaseSource {
    DatabaseSource get ();
}

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


EncryptionGuid Property

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.EncryptionGuid Property
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property EncryptionGuid As Guid
C#
Guid EncryptionGuid { get; }
Visual C++
property Guid EncryptionGuid {
    Guid get ();
}

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


SelectiveXmlIndexNamespaces Property

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.SelectiveXmlIndexNamespaces Property
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SelectiveXmlIndexNamespaces As IEnumerable(Of SelectiveXmlIndexNamespacesQueryResult)
C#
IEnumerable<SelectiveXmlIndexNamespacesQueryResult> SelectiveXmlIndexNamespaces { get; }
Visual C++
property IEnumerable<SelectiveXmlIndexNamespacesQueryResult^>^ SelectiveXmlIndexNamespaces {
    IEnumerable<SelectiveXmlIndexNamespacesQueryResult^>^ get ();
}

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


SelectiveXmlIndexPaths Property

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.SelectiveXmlIndexPaths Property
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SelectiveXmlIndexPaths As IEnumerable(Of SelectiveXmlIndexPathsQueryResult)
C#
IEnumerable<SelectiveXmlIndexPathsQueryResult> SelectiveXmlIndexPaths { get; }
Visual C++
property IEnumerable<SelectiveXmlIndexPathsQueryResult^>^ SelectiveXmlIndexPaths {
    IEnumerable<SelectiveXmlIndexPathsQueryResult^>^ get ();
}

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


VersionInformation Property

[image]

SQL Data Compare API 12.0.40
IDmvModel..::.VersionInformation Property
IDmvModel Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property VersionInformation As SqlVersion
C#
SqlVersion VersionInformation { get; }
Visual C++
property SqlVersion^ VersionInformation {
    SqlVersion^ get ();
}

See Also

IDmvModel Interface
RedGate.SQLCompare.Engine Namespace


IDmvModelFactory Interface

[image]

SQL Data Compare API 12.0.40
IDmvModelFactory Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDmvModelFactory
C#
public interface IDmvModelFactory
Visual C++
public interface class IDmvModelFactory

See Also

IDmvModelFactory Members
RedGate.SQLCompare.Engine Namespace


IDmvModelFactory Members

[image] [image]

SQL Data Compare API 12.0.40
IDmvModelFactory Members
IDmvModelFactory Interface Methods See Also

The IDmvModelFactory type exposes the following members.

Methods

Name | Description
FromConnectionProperties |

See Also

IDmvModelFactory Interface
RedGate.SQLCompare.Engine Namespace


IDmvModelFactory Methods

[image] [image]

SQL Data Compare API 12.0.40
IDmvModelFactory Methods
IDmvModelFactory Interface See Also

The IDmvModelFactory type exposes the following methods.

Methods

Name | Description
FromConnectionProperties |

See Also

IDmvModelFactory Interface
RedGate.SQLCompare.Engine Namespace


FromConnectionProperties Method

[image]

SQL Data Compare API 12.0.40
IDmvModelFactory..::.FromConnectionProperties Method
IDmvModelFactory Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function FromConnectionProperties ( _
    connProp As ConnectionProperties, _
    options As Options, _
    cancellationStatus As ICancellationStatus, _
    temporaryFileManager As ITemporaryFileManager _
) As IDmvModel
C#
IDmvModel FromConnectionProperties(
    ConnectionProperties connProp,
    Options options,
    ICancellationStatus cancellationStatus,
    ITemporaryFileManager temporaryFileManager
)
Visual C++
IDmvModel^ FromConnectionProperties(
    ConnectionProperties^ connProp,
    Options options,
    ICancellationStatus^ cancellationStatus,
    ITemporaryFileManager^ temporaryFileManager
)

Parameters

connProp
Type: RedGate.SQLCompare.Engine..::.ConnectionProperties
options
Type: RedGate.SQLCompare.Engine..::.Options
cancellationStatus
Type: RedGate.SQLCompare.Engine..::.ICancellationStatus
temporaryFileManager
Type: ITemporaryFileManager

See Also

IDmvModelFactory Interface
RedGate.SQLCompare.Engine Namespace


IEncryptedTextObject Interface

[image]

SQL Data Compare API 12.0.40
IEncryptedTextObject Interface
Members See Also

A text object that can be encrypted and have other options applied to the textual definition.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IEncryptedTextObject _
    Implements ITextObject, IDatabaseObject, ITSqlObject, ICanExistenceCheck,  _
    ISessionSetObject
C#
public interface IEncryptedTextObject : ITextObject,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, ISessionSetObject
Visual C++
public interface class IEncryptedTextObject : ITextObject,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, ISessionSetObject

See Also

IEncryptedTextObject Members
RedGate.SQLCompare.Engine Namespace


IEncryptedTextObject Members

[image] [image]

SQL Data Compare API 12.0.40
IEncryptedTextObject Members
IEncryptedTextObject Interface Methods Properties See Also

The IEncryptedTextObject type exposes the following members.

Methods

Name | Description
Equals | Compares two database objects. (Inherited from IDatabaseObject.)
GetSql | Returns appropriate sql for creating or altering the object with or without a WITH ENCRYPTION clause
SetSessionOptions | Override the session set options stored in the object. (Inherited from ISessionSetObject.)

Properties

Name | Description
AnsiNullsOn | Returns a value indicating if ANSI nulls are on in the object definition. (Inherited from ISessionSetObject.)
Database | The database to which the object belongs. (Inherited from IDatabaseObject.)
Encrypted | Returns a value indicating if the object text was encrypted.
FullyQualifiedName | (Inherited from ITSqlObject.)
Name | (Inherited from ITSqlObject.)
ObjectType | (Inherited from ITSqlObject.)
Owner | (Inherited from ITSqlObject.)
QualifiedName | (Inherited from ITSqlObject.)
QuotedIdentifierOn | Returns a value indicating if quoted identifier is on in the object definition. (Inherited from ISessionSetObject.)
Text | Returns the object text. (Inherited from ITextObject.)
TextID | Returns the ID of the syscomments entry of this object's text.

See Also

IEncryptedTextObject Interface
RedGate.SQLCompare.Engine Namespace


IEncryptedTextObject Methods

[image] [image]

SQL Data Compare API 12.0.40
IEncryptedTextObject Methods
IEncryptedTextObject Interface See Also

The IEncryptedTextObject type exposes the following methods.

Methods

Name | Description
Equals | Compares two database objects. (Inherited from IDatabaseObject.)
GetSql | Returns appropriate sql for creating or altering the object with or without a WITH ENCRYPTION clause
SetSessionOptions | Override the session set options stored in the object. (Inherited from ISessionSetObject.)

See Also

IEncryptedTextObject Interface
RedGate.SQLCompare.Engine Namespace


GetSql Method

[image]

SQL Data Compare API 12.0.40
IEncryptedTextObject..::.GetSql Method
IEncryptedTextObject Interface See Also

Returns appropriate sql for creating or altering the object with or without a WITH ENCRYPTION clause

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetSql ( _
    options As Options, _
    targetIsEncrypted As Boolean, _
    useAlter As Boolean, _
    targetFeatures As IFeatureChecker _
) As String
C#
string GetSql(
    Options options,
    bool targetIsEncrypted,
    bool useAlter,
    IFeatureChecker targetFeatures
)
Visual C++
String^ GetSql(
    Options options,
    bool targetIsEncrypted,
    bool useAlter,
    IFeatureChecker^ targetFeatures
)

Parameters

options
Type: RedGate.SQLCompare.Engine..::.Options
targetIsEncrypted
Type: Boolean
useAlter
Type: Boolean
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

See Also

IEncryptedTextObject Interface
RedGate.SQLCompare.Engine Namespace


IEncryptedTextObject Properties

[image] [image]

SQL Data Compare API 12.0.40
IEncryptedTextObject Properties
IEncryptedTextObject Interface See Also

The IEncryptedTextObject type exposes the following properties.

Properties

Name | Description
AnsiNullsOn | Returns a value indicating if ANSI nulls are on in the object definition. (Inherited from ISessionSetObject.)
Database | The database to which the object belongs. (Inherited from IDatabaseObject.)
Encrypted | Returns a value indicating if the object text was encrypted.
FullyQualifiedName | (Inherited from ITSqlObject.)
Name | (Inherited from ITSqlObject.)
ObjectType | (Inherited from ITSqlObject.)
Owner | (Inherited from ITSqlObject.)
QualifiedName | (Inherited from ITSqlObject.)
QuotedIdentifierOn | Returns a value indicating if quoted identifier is on in the object definition. (Inherited from ISessionSetObject.)
Text | Returns the object text. (Inherited from ITextObject.)
TextID | Returns the ID of the syscomments entry of this object's text.

See Also

IEncryptedTextObject Interface
RedGate.SQLCompare.Engine Namespace


Encrypted Property

[image]

SQL Data Compare API 12.0.40
IEncryptedTextObject..::.Encrypted Property
IEncryptedTextObject Interface See Also

Returns a value indicating if the object text was encrypted.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Encrypted As Boolean
C#
bool Encrypted { get; }
Visual C++
property bool Encrypted {
    bool get ();
}

See Also

IEncryptedTextObject Interface
RedGate.SQLCompare.Engine Namespace


TextID Property

[image]

SQL Data Compare API 12.0.40
IEncryptedTextObject..::.TextID Property
IEncryptedTextObject Interface See Also

Returns the ID of the syscomments entry of this object's text.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TextID As Integer
C#
int TextID { get; }
Visual C++
property int TextID {
    int get ();
}

See Also

IEncryptedTextObject Interface
RedGate.SQLCompare.Engine Namespace


IEncryptedTextReader Interface

[image]

SQL Data Compare API 12.0.40
IEncryptedTextReader Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IEncryptedTextReader
C#
public interface IEncryptedTextReader
Visual C++
public interface class IEncryptedTextReader

See Also

IEncryptedTextReader Members
RedGate.SQLCompare.Engine Namespace


IEncryptedTextReader Members

[image] [image]

SQL Data Compare API 12.0.40
IEncryptedTextReader Members
IEncryptedTextReader Interface Methods Properties See Also

The IEncryptedTextReader type exposes the following members.

Methods

Name | Description
GetEncryptedText | Get the decrypted text for an object. Do not call if you are not viewing decrypted objects as it has significant performance impacts. (6-7 seconds on ICUST_1)

Properties

Name | Description
CanDecrypt |

See Also

IEncryptedTextReader Interface
RedGate.SQLCompare.Engine Namespace


IEncryptedTextReader Methods

[image] [image]

SQL Data Compare API 12.0.40
IEncryptedTextReader Methods
IEncryptedTextReader Interface See Also

The IEncryptedTextReader type exposes the following methods.

Methods

Name | Description
GetEncryptedText | Get the decrypted text for an object. Do not call if you are not viewing decrypted objects as it has significant performance impacts. (6-7 seconds on ICUST_1)

See Also

IEncryptedTextReader Interface
RedGate.SQLCompare.Engine Namespace


GetEncryptedText Method

[image]

SQL Data Compare API 12.0.40
IEncryptedTextReader..::.GetEncryptedText Method
IEncryptedTextReader Interface See Also

Get the decrypted text for an object. Do not call if you are not viewing decrypted objects as it has significant performance impacts. (6-7 seconds on ICUST_1)

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetEncryptedText ( _
    resultSet As IResultSet, _
    objectID As Integer _
) As Byte()
C#
byte[] GetEncryptedText(
    IResultSet resultSet,
    int objectID
)
Visual C++
array<unsigned char>^ GetEncryptedText(
    IResultSet^ resultSet,
    int objectID
)

Parameters

resultSet
Type: RedGate.SQLCompare.Engine..::.IResultSet
objectID
Type: Int32

Return Value

See Also

IEncryptedTextReader Interface
RedGate.SQLCompare.Engine Namespace


IEncryptedTextReader Properties

[image] [image]

SQL Data Compare API 12.0.40
IEncryptedTextReader Properties
IEncryptedTextReader Interface See Also

The IEncryptedTextReader type exposes the following properties.

Properties

Name | Description
CanDecrypt |

See Also

IEncryptedTextReader Interface
RedGate.SQLCompare.Engine Namespace


CanDecrypt Property

[image]

SQL Data Compare API 12.0.40
IEncryptedTextReader..::.CanDecrypt Property
IEncryptedTextReader Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CanDecrypt As Boolean
C#
bool CanDecrypt { get; }
Visual C++
property bool CanDecrypt {
    bool get ();
}

See Also

IEncryptedTextReader Interface
RedGate.SQLCompare.Engine Namespace


IExecuteAs Interface

[image]

SQL Data Compare API 12.0.40
IExecuteAs Interface
Members See Also

Used by database objects that can be executed as a specific user. This is used only for SQL Server 2005 and 2008.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IExecuteAs _
    Implements IDatabaseObject, ITSqlObject, ICanExistenceCheck
C#
public interface IExecuteAs : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck
Visual C++
public interface class IExecuteAs : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck

See Also

IExecuteAs Members
RedGate.SQLCompare.Engine Namespace


IExecuteAs Members

[image] [image]

SQL Data Compare API 12.0.40
IExecuteAs Members
IExecuteAs Interface Methods Properties See Also

The IExecuteAs type exposes the following members.

Methods

Name | Description
Equals | Compares two database objects. (Inherited from IDatabaseObject.)

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from IDatabaseObject.)
ExecuteAs | The user whose security context is to be used.
ExecuteAsType | The EXECUTE AS clause used for the object.
FullyQualifiedName | (Inherited from ITSqlObject.)
Name | (Inherited from ITSqlObject.)
ObjectType | (Inherited from ITSqlObject.)
Owner | (Inherited from ITSqlObject.)
QualifiedName | (Inherited from ITSqlObject.)

See Also

IExecuteAs Interface
RedGate.SQLCompare.Engine Namespace


IExecuteAs Properties

[image] [image]

SQL Data Compare API 12.0.40
IExecuteAs Properties
IExecuteAs Interface See Also

The IExecuteAs type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from IDatabaseObject.)
ExecuteAs | The user whose security context is to be used.
ExecuteAsType | The EXECUTE AS clause used for the object.
FullyQualifiedName | (Inherited from ITSqlObject.)
Name | (Inherited from ITSqlObject.)
ObjectType | (Inherited from ITSqlObject.)
Owner | (Inherited from ITSqlObject.)
QualifiedName | (Inherited from ITSqlObject.)

See Also

IExecuteAs Interface
RedGate.SQLCompare.Engine Namespace


ExecuteAs Property

[image]

SQL Data Compare API 12.0.40
IExecuteAs..::.ExecuteAs Property
IExecuteAs Interface See Also

The user whose security context is to be used.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ExecuteAs As User
C#
User ExecuteAs { get; }
Visual C++
property User^ ExecuteAs {
    User^ get ();
}

See Also

IExecuteAs Interface
RedGate.SQLCompare.Engine Namespace


ExecuteAsType Property

[image]

SQL Data Compare API 12.0.40
IExecuteAs..::.ExecuteAsType Property
IExecuteAs Interface See Also

The EXECUTE AS clause used for the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ExecuteAsType As ExecuteAs
C#
ExecuteAs ExecuteAsType { get; }
Visual C++
property ExecuteAs ExecuteAsType {
    ExecuteAs get ();
}

See Also

IExecuteAs Interface
RedGate.SQLCompare.Engine Namespace


IField Interface

[image]

SQL Data Compare API 12.0.40
IField Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IField _
    Implements IDatabaseObject, ITSqlObject, ICanExistenceCheck
C#
public interface IField : IDatabaseObject, ITSqlObject,
    ICanExistenceCheck
Visual C++
public interface class IField : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck

See Also

IField Members
RedGate.SQLCompare.Engine Namespace


IField Members

[image] [image]

SQL Data Compare API 12.0.40
IField Members
IField Interface Methods Properties See Also

The IField type exposes the following members.

Methods

Name | Description
Clone |
CompareWith | Compares the field with a specified field.
Equals | Overloaded.
GetDataTypeSql | Get the SQL string for the field type definition
GetSQL | Builds the SQL definition for this field for use when creating or altering a table
ToString |

Properties

Name | Description
AllowNulls | True if the field can contain NULL values.
Collation | The collation order of character fields.
ColumnID | For internal use only.
ColumnSet | True if this field is a column set.
Computed | True if the field is computed.
ComputedText | The computed text of the field.
Database | The database to which the object belongs. (Inherited from IDatabaseObject.)
DataMaskingFunction | The function used to mask the data.
Default | The default that is bound to the field.
DefaultText | The text of the field's default value.
DefinedSize | The length of the field.
DependentFields | Dependent fields for computed columns.
DRIDefault | The Declarative Referential Integrity (DRI) default.
DRIDefaultID |
DRIDefaultIsSystemNamed |
Filestream | Specifies if this is a filestream column.
FullTextLanguage | The language of any full-text index to which the field belongs.
FullTextTypeColumn | The column that holds document type information. This is a SQL Server 2005 feature.
FullyQualifiedName | (Inherited from ITSqlObject.)
FullyQualifiedTypeName | The name of the fully-qualified field type. For SQL Server 2005, this property contains the schema name.
Function |
Identity | True if the field is an identity field.
IdentityCurrent | The current identity value.
IdentityIncrement | The identity increment.
IdentitySeed | The identity seed.
IsFullTextFromInlineCreate | True if this fulltext field was set from an inline CREATE FULLTEXT INDEX statement
IsIncludedInFullTextIndex | True if the field is included in the full-text index on the table
Name | (Inherited from ITSqlObject.)
NotForReplication | True if the field is marked as not for replication.
NullabilityExplicitlySet |
ObjectType | (Inherited from ITSqlObject.)
Ordinal |
Owner | (Inherited from ITSqlObject.)
Persisted | The column is in a calculated column that is persisted.
Precision | The precision of a decimal or numeric data type.
QualifiedName | (Inherited from ITSqlObject.)
RowGUIDCol | True if the field is a ROWGUIDCOL.
Rule | The rule bound to the field.
Scale | The scale of the field.
ScriptSourceForDefault | The location of the creation script for the default binding of this field if the database source is set to scripts folder.
ScriptSourceForFullTextColumn | The location of the creation script for the fulltext column information for this field if the database source is set to scripts folder.
ScriptSourceForRule | The location of the creation script for the rule binding of this field if the database source is set to scripts folder.
Sparse | Whether this column is a sparse column
SqlType | The field type.
Table |
TableOrView |
TypeName | The name of the field type.
TypeSchemaName | The name of the schema for the field's data type.
View |
XmlDocument | The referenced XML document.
XmlSchemaCollection | The referenced XML schema collection.

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


IField Methods

[image] [image]

SQL Data Compare API 12.0.40
IField Methods
IField Interface See Also

The IField type exposes the following methods.

Methods

Name | Description
Clone |
CompareWith | Compares the field with a specified field.
Equals | Overloaded.
GetDataTypeSql | Get the SQL string for the field type definition
GetSQL | Builds the SQL definition for this field for use when creating or altering a table
ToString |

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
IField..::.Clone Method
IField Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Clone As Field
C#
Field Clone()
Visual C++
Field^ Clone()

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


CompareWith Method

[image]

SQL Data Compare API 12.0.40
IField..::.CompareWith Method
IField Interface See Also

Compares the field with a specified field.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function CompareWith ( _
    targetField As IField, _
    options As Options, _
    ignoreDriDefault As Boolean _
) As IEnumerable(Of EqualityDifference)
C#
IEnumerable<EqualityDifference> CompareWith(
    IField targetField,
    Options options,
    bool ignoreDriDefault
)
Visual C++
IEnumerable<EqualityDifference^>^ CompareWith(
    IField^ targetField,
    Options options,
    bool ignoreDriDefault
)

Parameters

targetField
Type: RedGate.SQLCompare.Engine..::.IField
The field to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.
ignoreDriDefault
Type: Boolean
Whether to ignore default constraints for the field

Return Value

True if the fields are identical; otherwise, false.

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
IField..::.Equals Method
IField Interface See Also

Overload List

Name | Description
Equals(IDatabaseObject, Options) | Compares two database objects. (Inherited from IDatabaseObject.)
Equals(IField, Options, Boolean) |

See Also

IField Interface
IField Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IField, Options, )

[image]

SQL Data Compare API 12.0.40
IField..::.Equals Method (IField, Options, )
IField Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Equals ( _
    targetField As IField, _
    options As Options, _
    ignoreDriDefault As Boolean _
) As Boolean
C#
bool Equals(
    IField targetField,
    Options options,
    bool ignoreDriDefault
)
Visual C++
bool Equals(
    IField^ targetField,
    Options options,
    bool ignoreDriDefault
)

Parameters

targetField
Type: RedGate.SQLCompare.Engine..::.IField
options
Type: RedGate.SQLCompare.Engine..::.Options
ignoreDriDefault
Type: Boolean

See Also

IField Interface
Equals Overload
RedGate.SQLCompare.Engine Namespace


GetDataTypeSql Method

[image]

SQL Data Compare API 12.0.40
IField..::.GetDataTypeSql Method
IField Interface See Also

Get the SQL string for the field type definition

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetDataTypeSql ( _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As String
C#
string GetDataTypeSql(
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
String^ GetDataTypeSql(
    Options options,
    IFeatureChecker^ targetFeatures
)

Parameters

options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker
SQL Server features supported by the comparison target.

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


GetSQL Method

[image]

SQL Data Compare API 12.0.40
IField..::.GetSQL Method
IField Interface See Also

Builds the SQL definition for this field for use when creating or altering a table

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetSQL ( _
    options As Options, _
    includeFullDefinition As Boolean, _
    targetFeatures As IFeatureChecker, _
    targetAllowsNulls As Nullable(Of Boolean) _
) As String
C#
string GetSQL(
    Options options,
    bool includeFullDefinition,
    IFeatureChecker targetFeatures,
    Nullable<bool> targetAllowsNulls
)
Visual C++
String^ GetSQL(
    Options options,
    bool includeFullDefinition,
    IFeatureChecker^ targetFeatures,
    Nullable<bool> targetAllowsNulls
)

Parameters

options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.
includeFullDefinition
Type: Boolean
true to include parts of the field definition that are only valid when creating a column (e.g. IDENTITY, ROWGUIDCOL, DEFAULT).
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker
SQL Server features supported by the comparison target.
targetAllowsNulls
Type: Nullable<(Of <(Boolean>)>)
Whether or not the target field allows NULL values. Used to preserve target nullability when altering something other than a column's nullability with the IgnoreNullability option on.

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
IField..::.ToString Method
IField Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function ToString As String
C#
string ToString()
Visual C++
String^ ToString()

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


IField Properties

[image] [image]

SQL Data Compare API 12.0.40
IField Properties
IField Interface See Also

The IField type exposes the following properties.

Properties

Name | Description
AllowNulls | True if the field can contain NULL values.
Collation | The collation order of character fields.
ColumnID | For internal use only.
ColumnSet | True if this field is a column set.
Computed | True if the field is computed.
ComputedText | The computed text of the field.
Database | The database to which the object belongs. (Inherited from IDatabaseObject.)
DataMaskingFunction | The function used to mask the data.
Default | The default that is bound to the field.
DefaultText | The text of the field's default value.
DefinedSize | The length of the field.
DependentFields | Dependent fields for computed columns.
DRIDefault | The Declarative Referential Integrity (DRI) default.
DRIDefaultID |
DRIDefaultIsSystemNamed |
Filestream | Specifies if this is a filestream column.
FullTextLanguage | The language of any full-text index to which the field belongs.
FullTextTypeColumn | The column that holds document type information. This is a SQL Server 2005 feature.
FullyQualifiedName | (Inherited from ITSqlObject.)
FullyQualifiedTypeName | The name of the fully-qualified field type. For SQL Server 2005, this property contains the schema name.
Function |
Identity | True if the field is an identity field.
IdentityCurrent | The current identity value.
IdentityIncrement | The identity increment.
IdentitySeed | The identity seed.
IsFullTextFromInlineCreate | True if this fulltext field was set from an inline CREATE FULLTEXT INDEX statement
IsIncludedInFullTextIndex | True if the field is included in the full-text index on the table
Name | (Inherited from ITSqlObject.)
NotForReplication | True if the field is marked as not for replication.
NullabilityExplicitlySet |
ObjectType | (Inherited from ITSqlObject.)
Ordinal |
Owner | (Inherited from ITSqlObject.)
Persisted | The column is in a calculated column that is persisted.
Precision | The precision of a decimal or numeric data type.
QualifiedName | (Inherited from ITSqlObject.)
RowGUIDCol | True if the field is a ROWGUIDCOL.
Rule | The rule bound to the field.
Scale | The scale of the field.
ScriptSourceForDefault | The location of the creation script for the default binding of this field if the database source is set to scripts folder.
ScriptSourceForFullTextColumn | The location of the creation script for the fulltext column information for this field if the database source is set to scripts folder.
ScriptSourceForRule | The location of the creation script for the rule binding of this field if the database source is set to scripts folder.
Sparse | Whether this column is a sparse column
SqlType | The field type.
Table |
TableOrView |
TypeName | The name of the field type.
TypeSchemaName | The name of the schema for the field's data type.
View |
XmlDocument | The referenced XML document.
XmlSchemaCollection | The referenced XML schema collection.

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


AllowNulls Property

[image]

SQL Data Compare API 12.0.40
IField..::.AllowNulls Property
IField Interface See Also

True if the field can contain NULL values.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property AllowNulls As Boolean
C#
bool AllowNulls { get; set; }
Visual C++
property bool AllowNulls {
    bool get ();
    void set (bool value);
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


Collation Property

[image]

SQL Data Compare API 12.0.40
IField..::.Collation Property
IField Interface See Also

The collation order of character fields.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property Collation As String
C#
string Collation { get; set; }
Visual C++
property String^ Collation {
    String^ get ();
    void set (String^ value);
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


ColumnID Property

[image]

SQL Data Compare API 12.0.40
IField..::.ColumnID Property
IField Interface See Also

For internal use only.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ColumnID As Integer
C#
int ColumnID { get; }
Visual C++
property int ColumnID {
    int get ();
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


ColumnSet Property

[image]

SQL Data Compare API 12.0.40
IField..::.ColumnSet Property
IField Interface See Also

True if this field is a column set.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ColumnSet As Boolean
C#
bool ColumnSet { get; }
Visual C++
property bool ColumnSet {
    bool get ();
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


Computed Property

[image]

SQL Data Compare API 12.0.40
IField..::.Computed Property
IField Interface See Also

True if the field is computed.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Computed As Boolean
C#
bool Computed { get; }
Visual C++
property bool Computed {
    bool get ();
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


ComputedText Property

[image]

SQL Data Compare API 12.0.40
IField..::.ComputedText Property
IField Interface See Also

The computed text of the field.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property ComputedText As String
C#
string ComputedText { get; set; }
Visual C++
property String^ ComputedText {
    String^ get ();
    void set (String^ value);
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


DataMaskingFunction Property

[image]

SQL Data Compare API 12.0.40
IField..::.DataMaskingFunction Property
IField Interface See Also

The function used to mask the data.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property DataMaskingFunction As String
C#
string DataMaskingFunction { get; set; }
Visual C++
property String^ DataMaskingFunction {
    String^ get ();
    void set (String^ value);
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


Default Property

[image]

SQL Data Compare API 12.0.40
IField..::.Default Property
IField Interface See Also

The default that is bound to the field.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property Default As Default
C#
Default Default { get; set; }
Visual C++
property Default^ Default {
    Default^ get ();
    void set (Default^ value);
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


DefaultText Property

[image]

SQL Data Compare API 12.0.40
IField..::.DefaultText Property
IField Interface See Also

The text of the field's default value.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property DefaultText As String
C#
string DefaultText { get; set; }
Visual C++
property String^ DefaultText {
    String^ get ();
    void set (String^ value);
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


DefinedSize Property

[image]

SQL Data Compare API 12.0.40
IField..::.DefinedSize Property
IField Interface See Also

The length of the field.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property DefinedSize As Integer
C#
int DefinedSize { get; set; }
Visual C++
property int DefinedSize {
    int get ();
    void set (int value);
}

Remarks

Valid only for character and binary data.

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


DependentFields Property

[image]

SQL Data Compare API 12.0.40
IField..::.DependentFields Property
IField Interface See Also

Dependent fields for computed columns.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property DependentFields As String()
C#
string[] DependentFields { get; set; }
Visual C++
property array<String^>^ DependentFields {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


DRIDefault Property

[image]

SQL Data Compare API 12.0.40
IField..::.DRIDefault Property
IField Interface See Also

The Declarative Referential Integrity (DRI) default.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property DRIDefault As String
C#
string DRIDefault { get; set; }
Visual C++
property String^ DRIDefault {
    String^ get ();
    void set (String^ value);
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


DRIDefaultID Property

[image]

SQL Data Compare API 12.0.40
IField..::.DRIDefaultID Property
IField Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property DRIDefaultID As Integer
C#
int DRIDefaultID { get; set; }
Visual C++
property int DRIDefaultID {
    int get ();
    void set (int value);
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


DRIDefaultIsSystemNamed Property

[image]

SQL Data Compare API 12.0.40
IField..::.DRIDefaultIsSystemNamed Property
IField Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property DRIDefaultIsSystemNamed As Boolean
C#
bool DRIDefaultIsSystemNamed { get; set; }
Visual C++
property bool DRIDefaultIsSystemNamed {
    bool get ();
    void set (bool value);
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


Filestream Property

[image]

SQL Data Compare API 12.0.40
IField..::.Filestream Property
IField Interface See Also

Specifies if this is a filestream column.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Filestream As Boolean
C#
bool Filestream { get; }
Visual C++
property bool Filestream {
    bool get ();
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


FullTextLanguage Property

[image]

SQL Data Compare API 12.0.40
IField..::.FullTextLanguage Property
IField Interface See Also

The language of any full-text index to which the field belongs.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property FullTextLanguage As Integer
C#
int FullTextLanguage { get; set; }
Visual C++
property int FullTextLanguage {
    int get ();
    void set (int value);
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


FullTextTypeColumn Property

[image]

SQL Data Compare API 12.0.40
IField..::.FullTextTypeColumn Property
IField Interface See Also

The column that holds document type information. This is a SQL Server 2005 feature.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property FullTextTypeColumn As String
C#
string FullTextTypeColumn { get; set; }
Visual C++
property String^ FullTextTypeColumn {
    String^ get ();
    void set (String^ value);
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


FullyQualifiedTypeName Property

[image]

SQL Data Compare API 12.0.40
IField..::.FullyQualifiedTypeName Property
IField Interface See Also

The name of the fully-qualified field type. For SQL Server 2005, this property contains the schema name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property FullyQualifiedTypeName As String
C#
string FullyQualifiedTypeName { get; }
Visual C++
property String^ FullyQualifiedTypeName {
    String^ get ();
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


Function Property

[image]

SQL Data Compare API 12.0.40
IField..::.Function Property
IField Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property Function As Function
C#
Function Function { get; set; }
Visual C++
property Function^ Function {
    Function^ get ();
    void set (Function^ value);
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


Identity Property

[image]

SQL Data Compare API 12.0.40
IField..::.Identity Property
IField Interface See Also

True if the field is an identity field.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Identity As Boolean
C#
bool Identity { get; }
Visual C++
property bool Identity {
    bool get ();
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


IdentityCurrent Property

[image]

SQL Data Compare API 12.0.40
IField..::.IdentityCurrent Property
IField Interface See Also

The current identity value.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IdentityCurrent As SqlDecimal
C#
SqlDecimal IdentityCurrent { get; }
Visual C++
property SqlDecimal IdentityCurrent {
    SqlDecimal get ();
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


IdentityIncrement Property

[image]

SQL Data Compare API 12.0.40
IField..::.IdentityIncrement Property
IField Interface See Also

The identity increment.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IdentityIncrement As Long
C#
long IdentityIncrement { get; }
Visual C++
property long long IdentityIncrement {
    long long get ();
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


IdentitySeed Property

[image]

SQL Data Compare API 12.0.40
IField..::.IdentitySeed Property
IField Interface See Also

The identity seed.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IdentitySeed As SqlDecimal
C#
SqlDecimal IdentitySeed { get; }
Visual C++
property SqlDecimal IdentitySeed {
    SqlDecimal get ();
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


IsFullTextFromInlineCreate Property

[image]

SQL Data Compare API 12.0.40
IField..::.IsFullTextFromInlineCreate Property
IField Interface See Also

True if this fulltext field was set from an inline CREATE FULLTEXT INDEX statement

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property IsFullTextFromInlineCreate As Boolean
C#
bool IsFullTextFromInlineCreate { get; set; }
Visual C++
property bool IsFullTextFromInlineCreate {
    bool get ();
    void set (bool value);
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


IsIncludedInFullTextIndex Property

[image]

SQL Data Compare API 12.0.40
IField..::.IsIncludedInFullTextIndex Property
IField Interface See Also

True if the field is included in the full-text index on the table

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property IsIncludedInFullTextIndex As Boolean
C#
bool IsIncludedInFullTextIndex { get; set; }
Visual C++
property bool IsIncludedInFullTextIndex {
    bool get ();
    void set (bool value);
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


NotForReplication Property

[image]

SQL Data Compare API 12.0.40
IField..::.NotForReplication Property
IField Interface See Also

True if the field is marked as not for replication.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property NotForReplication As Boolean
C#
bool NotForReplication { get; }
Visual C++
property bool NotForReplication {
    bool get ();
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


NullabilityExplicitlySet Property

[image]

SQL Data Compare API 12.0.40
IField..::.NullabilityExplicitlySet Property
IField Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property NullabilityExplicitlySet As Boolean
C#
bool NullabilityExplicitlySet { get; set; }
Visual C++
property bool NullabilityExplicitlySet {
    bool get ();
    void set (bool value);
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


Ordinal Property

[image]

SQL Data Compare API 12.0.40
IField..::.Ordinal Property
IField Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property Ordinal As Integer
C#
int Ordinal { get; set; }
Visual C++
property int Ordinal {
    int get ();
    void set (int value);
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


Persisted Property

[image]

SQL Data Compare API 12.0.40
IField..::.Persisted Property
IField Interface See Also

The column is in a calculated column that is persisted.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Persisted As Boolean
C#
bool Persisted { get; }
Visual C++
property bool Persisted {
    bool get ();
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


Precision Property

[image]

SQL Data Compare API 12.0.40
IField..::.Precision Property
IField Interface See Also

The precision of a decimal or numeric data type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Precision As Integer
C#
int Precision { get; }
Visual C++
property int Precision {
    int get ();
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


RowGUIDCol Property

[image]

SQL Data Compare API 12.0.40
IField..::.RowGUIDCol Property
IField Interface See Also

True if the field is a ROWGUIDCOL.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property RowGUIDCol As Boolean
C#
bool RowGUIDCol { get; }
Visual C++
property bool RowGUIDCol {
    bool get ();
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


Rule Property

[image]

SQL Data Compare API 12.0.40
IField..::.Rule Property
IField Interface See Also

The rule bound to the field.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property Rule As Rule
C#
Rule Rule { get; set; }
Visual C++
property Rule^ Rule {
    Rule^ get ();
    void set (Rule^ value);
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


Scale Property

[image]

SQL Data Compare API 12.0.40
IField..::.Scale Property
IField Interface See Also

The scale of the field.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Scale As Integer
C#
int Scale { get; }
Visual C++
property int Scale {
    int get ();
}

Remarks

Valid for numeric and decimal data types.

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


ScriptSourceForDefault Property

[image]

SQL Data Compare API 12.0.40
IField..::.ScriptSourceForDefault Property
IField Interface See Also

The location of the creation script for the default binding of this field if the database source is set to scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property ScriptSourceForDefault As ScriptSource
C#
ScriptSource ScriptSourceForDefault { get; set; }
Visual C++
property ScriptSource^ ScriptSourceForDefault {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


ScriptSourceForFullTextColumn Property

[image]

SQL Data Compare API 12.0.40
IField..::.ScriptSourceForFullTextColumn Property
IField Interface See Also

The location of the creation script for the fulltext column information for this field if the database source is set to scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property ScriptSourceForFullTextColumn As ScriptSource
C#
ScriptSource ScriptSourceForFullTextColumn { get; set; }
Visual C++
property ScriptSource^ ScriptSourceForFullTextColumn {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


ScriptSourceForRule Property

[image]

SQL Data Compare API 12.0.40
IField..::.ScriptSourceForRule Property
IField Interface See Also

The location of the creation script for the rule binding of this field if the database source is set to scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property ScriptSourceForRule As ScriptSource
C#
ScriptSource ScriptSourceForRule { get; set; }
Visual C++
property ScriptSource^ ScriptSourceForRule {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


Sparse Property

[image]

SQL Data Compare API 12.0.40
IField..::.Sparse Property
IField Interface See Also

Whether this column is a sparse column

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Sparse As Boolean
C#
bool Sparse { get; }
Visual C++
property bool Sparse {
    bool get ();
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


SqlType Property

[image]

SQL Data Compare API 12.0.40
IField..::.SqlType Property
IField Interface See Also

The field type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property SqlType As SqlType
C#
SqlType SqlType { get; set; }
Visual C++
property SqlType SqlType {
    SqlType get ();
    void set (SqlType value);
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


Table Property

[image]

SQL Data Compare API 12.0.40
IField..::.Table Property
IField Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property Table As Table
C#
Table Table { get; set; }
Visual C++
property Table^ Table {
    Table^ get ();
    void set (Table^ value);
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


TableOrView Property

[image]

SQL Data Compare API 12.0.40
IField..::.TableOrView Property
IField Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property TableOrView As ViewTableSuperClass
C#
ViewTableSuperClass TableOrView { get; set; }
Visual C++
property ViewTableSuperClass^ TableOrView {
    ViewTableSuperClass^ get ();
    void set (ViewTableSuperClass^ value);
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


TypeName Property

[image]

SQL Data Compare API 12.0.40
IField..::.TypeName Property
IField Interface See Also

The name of the field type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property TypeName As String
C#
string TypeName { get; set; }
Visual C++
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


TypeSchemaName Property

[image]

SQL Data Compare API 12.0.40
IField..::.TypeSchemaName Property
IField Interface See Also

The name of the schema for the field's data type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property TypeSchemaName As String
C#
string TypeSchemaName { get; set; }
Visual C++
property String^ TypeSchemaName {
    String^ get ();
    void set (String^ value);
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


View Property

[image]

SQL Data Compare API 12.0.40
IField..::.View Property
IField Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property View As View
C#
View View { get; set; }
Visual C++
property View^ View {
    View^ get ();
    void set (View^ value);
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


XmlDocument Property

[image]

SQL Data Compare API 12.0.40
IField..::.XmlDocument Property
IField Interface See Also

The referenced XML document.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property XmlDocument As Boolean
C#
bool XmlDocument { get; }
Visual C++
property bool XmlDocument {
    bool get ();
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


XmlSchemaCollection Property

[image]

SQL Data Compare API 12.0.40
IField..::.XmlSchemaCollection Property
IField Interface See Also

The referenced XML schema collection.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property XmlSchemaCollection As XmlSchemaCollection
C#
XmlSchemaCollection XmlSchemaCollection { get; set; }
Visual C++
property XmlSchemaCollection^ XmlSchemaCollection {
    XmlSchemaCollection^ get ();
    void set (XmlSchemaCollection^ value);
}

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


IHasAuthorization Interface

[image]

SQL Data Compare API 12.0.40
IHasAuthorization Interface
Members See Also

Marks objects that have an owner instead of a schema. Note that some objects can have both an owner and a schema; in this instance, SchemaObjectWithAuthorization is used instead.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IHasAuthorization _
    Implements IDatabaseObject, ITSqlObject, ICanExistenceCheck
C#
public interface IHasAuthorization : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck
Visual C++
public interface class IHasAuthorization : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck

See Also

IHasAuthorization Members
RedGate.SQLCompare.Engine Namespace


IHasAuthorization Members

[image] [image]

SQL Data Compare API 12.0.40
IHasAuthorization Members
IHasAuthorization Interface Methods Properties See Also

The IHasAuthorization type exposes the following members.

Methods

Name | Description
Equals | Compares two database objects. (Inherited from IDatabaseObject.)

Properties

Name | Description
AlterAuthorizationClassType | The securable class of the entity for which the owner is being changed.
Database | The database to which the object belongs. (Inherited from IDatabaseObject.)
FullyQualifiedName | (Inherited from ITSqlObject.)
Name | (Inherited from ITSqlObject.)
ObjectType | (Inherited from ITSqlObject.)
Owner | (Inherited from ITSqlObject.)
QualifiedName | (Inherited from ITSqlObject.)

See Also

IHasAuthorization Interface
RedGate.SQLCompare.Engine Namespace


IHasAuthorization Properties

[image] [image]

SQL Data Compare API 12.0.40
IHasAuthorization Properties
IHasAuthorization Interface See Also

The IHasAuthorization type exposes the following properties.

Properties

Name | Description
AlterAuthorizationClassType | The securable class of the entity for which the owner is being changed.
Database | The database to which the object belongs. (Inherited from IDatabaseObject.)
FullyQualifiedName | (Inherited from ITSqlObject.)
Name | (Inherited from ITSqlObject.)
ObjectType | (Inherited from ITSqlObject.)
Owner | (Inherited from ITSqlObject.)
QualifiedName | (Inherited from ITSqlObject.)

See Also

IHasAuthorization Interface
RedGate.SQLCompare.Engine Namespace


AlterAuthorizationClassType Property

[image]

SQL Data Compare API 12.0.40
IHasAuthorization..::.AlterAuthorizationClassType Property
IHasAuthorization Interface See Also

The securable class of the entity for which the owner is being changed.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property AlterAuthorizationClassType As String
C#
string AlterAuthorizationClassType { get; }
Visual C++
property String^ AlterAuthorizationClassType {
    String^ get ();
}

See Also

IHasAuthorization Interface
RedGate.SQLCompare.Engine Namespace


IHasPermissions Interface

[image]

SQL Data Compare API 12.0.40
IHasPermissions Interface
Members See Also

The database object may have permissions associated with it.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IHasPermissions _
    Implements IDatabaseObject, ITSqlObject, ICanExistenceCheck
C#
public interface IHasPermissions : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck
Visual C++
public interface class IHasPermissions : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck

See Also

IHasPermissions Members
RedGate.SQLCompare.Engine Namespace


IHasPermissions Members

[image] [image]

SQL Data Compare API 12.0.40
IHasPermissions Members
IHasPermissions Interface Methods Properties See Also

The IHasPermissions type exposes the following members.

Methods

Name | Description
Equals | Compares two database objects. (Inherited from IDatabaseObject.)

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from IDatabaseObject.)
FullyQualifiedName | (Inherited from ITSqlObject.)
Name | (Inherited from ITSqlObject.)
ObjectType | (Inherited from ITSqlObject.)
Owner | (Inherited from ITSqlObject.)
Permissions | The permissions of the object.
QualifiedName | (Inherited from ITSqlObject.)

See Also

IHasPermissions Interface
RedGate.SQLCompare.Engine Namespace


IHasPermissions Properties

[image] [image]

SQL Data Compare API 12.0.40
IHasPermissions Properties
IHasPermissions Interface See Also

The IHasPermissions type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from IDatabaseObject.)
FullyQualifiedName | (Inherited from ITSqlObject.)
Name | (Inherited from ITSqlObject.)
ObjectType | (Inherited from ITSqlObject.)
Owner | (Inherited from ITSqlObject.)
Permissions | The permissions of the object.
QualifiedName | (Inherited from ITSqlObject.)

See Also

IHasPermissions Interface
RedGate.SQLCompare.Engine Namespace


Permissions Property

[image]

SQL Data Compare API 12.0.40
IHasPermissions..::.Permissions Property
IHasPermissions Interface See Also

The permissions of the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Permissions As Permissions
C#
Permissions Permissions { get; }
Visual C++
property Permissions^ Permissions {
    Permissions^ get ();
}

See Also

IHasPermissions Interface
RedGate.SQLCompare.Engine Namespace


IIsSystemObject Interface

[image]

SQL Data Compare API 12.0.40
IIsSystemObject Interface
Members See Also

Indicates that an object instance is a system object when implemented by a class.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IIsSystemObject _
    Implements IDatabaseObject, ITSqlObject, ICanExistenceCheck
C#
public interface IIsSystemObject : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck
Visual C++
public interface class IIsSystemObject : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck

See Also

IIsSystemObject Members
RedGate.SQLCompare.Engine Namespace


IIsSystemObject Members

[image] [image]

SQL Data Compare API 12.0.40
IIsSystemObject Members
IIsSystemObject Interface Methods Properties See Also

The IIsSystemObject type exposes the following members.

Methods

Name | Description
Equals | Compares two database objects. (Inherited from IDatabaseObject.)

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from IDatabaseObject.)
FullyQualifiedName | (Inherited from ITSqlObject.)
IsSystemObject | Indicates that the object is a system object.
Name | (Inherited from ITSqlObject.)
ObjectType | (Inherited from ITSqlObject.)
Owner | (Inherited from ITSqlObject.)
QualifiedName | (Inherited from ITSqlObject.)

See Also

IIsSystemObject Interface
RedGate.SQLCompare.Engine Namespace


IIsSystemObject Properties

[image] [image]

SQL Data Compare API 12.0.40
IIsSystemObject Properties
IIsSystemObject Interface See Also

The IIsSystemObject type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from IDatabaseObject.)
FullyQualifiedName | (Inherited from ITSqlObject.)
IsSystemObject | Indicates that the object is a system object.
Name | (Inherited from ITSqlObject.)
ObjectType | (Inherited from ITSqlObject.)
Owner | (Inherited from ITSqlObject.)
QualifiedName | (Inherited from ITSqlObject.)

See Also

IIsSystemObject Interface
RedGate.SQLCompare.Engine Namespace


IsSystemObject Property

[image]

SQL Data Compare API 12.0.40
IIsSystemObject..::.IsSystemObject Property
IIsSystemObject Interface See Also

Indicates that the object is a system object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsSystemObject As Boolean
C#
bool IsSystemObject { get; }
Visual C++
property bool IsSystemObject {
    bool get ();
}

See Also

IIsSystemObject Interface
RedGate.SQLCompare.Engine Namespace


IMemoizeDependencies Interface

[image]

SQL Data Compare API 12.0.40
IMemoizeDependencies Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IMemoizeDependencies
C#
public interface IMemoizeDependencies
Visual C++
public interface class IMemoizeDependencies

See Also

IMemoizeDependencies Members
RedGate.SQLCompare.Engine Namespace


IMemoizeDependencies Members

[image] [image]

SQL Data Compare API 12.0.40
IMemoizeDependencies Members
IMemoizeDependencies Interface Methods See Also

The IMemoizeDependencies type exposes the following members.

Methods

Name | Description
Clear |
Memoize |
TryGetMemoized |

See Also

IMemoizeDependencies Interface
RedGate.SQLCompare.Engine Namespace


IMemoizeDependencies Methods

[image] [image]

SQL Data Compare API 12.0.40
IMemoizeDependencies Methods
IMemoizeDependencies Interface See Also

The IMemoizeDependencies type exposes the following methods.

Methods

Name | Description
Clear |
Memoize |
TryGetMemoized |

See Also

IMemoizeDependencies Interface
RedGate.SQLCompare.Engine Namespace


Clear Method

[image]

SQL Data Compare API 12.0.40
IMemoizeDependencies..::.Clear Method
IMemoizeDependencies Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub Clear
C#
void Clear()
Visual C++
void Clear()

See Also

IMemoizeDependencies Interface
RedGate.SQLCompare.Engine Namespace


Memoize Method

[image]

SQL Data Compare API 12.0.40
IMemoizeDependencies..::.Memoize Method
IMemoizeDependencies Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub Memoize ( _
    sql As String, _
    quotedIdentifiers As Boolean, _
    throwExceptions As Boolean, _
    result As Stack(Of String()) _
)
C#
void Memoize(
    string sql,
    bool quotedIdentifiers,
    bool throwExceptions,
    Stack<string[]> result
)
Visual C++
void Memoize(
    String^ sql,
    bool quotedIdentifiers,
    bool throwExceptions,
    Stack<array<String^>^>^ result
)

Parameters

sql
Type: String
Must not be null
quotedIdentifiers
Type: Boolean
throwExceptions
Type: Boolean
result
Type: Stack<(Of <(array<String>[]()[]>)>)
You must not modify the string[]s in the stack or the stack itself at any point

See Also

IMemoizeDependencies Interface
RedGate.SQLCompare.Engine Namespace


TryGetMemoized Method

[image]

SQL Data Compare API 12.0.40
IMemoizeDependencies..::.TryGetMemoized Method
IMemoizeDependencies Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function TryGetMemoized ( _
    sql As String, _
    quotedIdentifiers As Boolean, _
    throwExceptions As Boolean, _
    <OutAttribute> ByRef memoizedValue As Stack(Of String()) _
) As Boolean
C#
bool TryGetMemoized(
    string sql,
    bool quotedIdentifiers,
    bool throwExceptions,
    out Stack<string[]> memoizedValue
)
Visual C++
bool TryGetMemoized(
    String^ sql,
    bool quotedIdentifiers,
    bool throwExceptions,
    [OutAttribute] Stack<array<String^>^>^% memoizedValue
)

Parameters

sql
Type: String
Must not be null
quotedIdentifiers
Type: Boolean
throwExceptions
Type: Boolean
memoizedValue
Type: Stack<(Of <(array<String>[]()[]>)>)%

See Also

IMemoizeDependencies Interface
RedGate.SQLCompare.Engine Namespace


IMetadata Interface

[image]

SQL Data Compare API 12.0.40
IMetadata Interface
Members See Also

An interface for storing arbitrary extra data on an object

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IMetadata
C#
public interface IMetadata
Visual C++
public interface class IMetadata

Remarks

See Docs/GLOSSARY for more details

See Also

IMetadata Members
RedGate.SQLCompare.Engine Namespace


IMetadata Members

[image] [image]

SQL Data Compare API 12.0.40
IMetadata Members
IMetadata Interface Methods See Also

The IMetadata type exposes the following members.

Methods

Name | Description
AddMetadata<(Of <(T>)>) | Store a piece of metadata, keyed by its type
GetMetadata<(Of <(T>)>) | Returns T or default(T)

See Also

IMetadata Interface
RedGate.SQLCompare.Engine Namespace


IMetadata Methods

[image] [image]

SQL Data Compare API 12.0.40
IMetadata Methods
IMetadata Interface See Also

The IMetadata type exposes the following methods.

Methods

Name | Description
AddMetadata<(Of <(T>)>) | Store a piece of metadata, keyed by its type
GetMetadata<(Of <(T>)>) | Returns T or default(T)

See Also

IMetadata Interface
RedGate.SQLCompare.Engine Namespace


AddMetadata(T) Generic Method

[image]

SQL Data Compare API 12.0.40
IMetadata..::.AddMetadata<(Of <(T>)>) Generic Method
IMetadata Interface See Also

Store a piece of metadata, keyed by its type

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub AddMetadata(Of T) ( _
    value As T _
)
C#
void AddMetadata<T>(
    T value
)
Visual C++
generic<typename T>
void AddMetadata(
    T value
)

Parameters

value
Type: T

Type Parameters

T

See Also

IMetadata Interface
RedGate.SQLCompare.Engine Namespace


GetMetadata(T) Generic Method

[image]

SQL Data Compare API 12.0.40
IMetadata..::.GetMetadata<(Of <(T>)>) Generic Method
IMetadata Interface See Also

Returns T or default(T)

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetMetadata(Of T) As T
C#
T GetMetadata<T>()
Visual C++
generic<typename T>
T GetMetadata()

Type Parameters

T

See Also

IMetadata Interface
RedGate.SQLCompare.Engine Namespace


Index Class

[image]

SQL Data Compare API 12.0.40
Index Class
Members See Also

An index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class Index _
    Implements IDatabaseObject, ITSqlObject, ICanExistenceCheck, IHasScriptSource,  _
    ISqlComparable
C#
public abstract class Index : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck, IHasScriptSource, ISqlComparable
Visual C++
public ref class Index abstract : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck, IHasScriptSource, ISqlComparable

Remarks

This includes primary keys, unique constraints, xml and spatial indexes, and statistics.

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.Index
RedGate.SQLCompare.Engine..::.SpatialIndex
RedGate.SQLCompare.Engine..::.Statistics
RedGate.SQLCompare.Engine..::.RelationalIndex
RedGate.SQLCompare.Engine.Model.XmlIndexes..::.XmlIndex

See Also

Index Members
RedGate.SQLCompare.Engine Namespace


Index Members

[image] [image]

SQL Data Compare API 12.0.40
Index Members
Index Class Methods Properties Explicit Interface Implementations See Also

The Index type exposes the following members.

Methods

Name | Description
AppendWithClause |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FieldsCompareWith |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetQualifiedName |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowPageLocks | True if the index allows page locks.
AllowRowLocks | True if the index allows row locks.
Clustered | Obsolete.
Database | The database to which the index belongs.
Fields | The fields in the index.
FileGroup | Obsolete.
FileGroupOrPartitionScheme | The filegroup or the partition scheme on which the index is defined.
FilestreamFileGroup | Obsolete.
FillFactor | The fill factor.
Filter | Obsolete.
FullScan | True if the index is defined with FullScan
FullyQualifiedName | Obsolete. The fully-qualified name of the index. DANGER WILL ROBINSON!! This is not escaped.
IgnoreDuplicateKeys | True if set to ignore duplicate keys.
Incremental | True if incremental (introduced in SQL Server 2014)
IsColumnstore | Stupid columnstore indexes mark all of their fields as included but use the normal syntax to list them. (http://msdn.microsoft.com/en-us/library/ms175105.aspx)
IsDisabled | Indicates whether the index is disabled.
IsKeyIndexForFullTextIndex | Obsolete.
IsPartitioned | Indicates whether the index is built on a partition scheme. If it is, the name of the partition scheme is returned by the FileGroupOrPartitionScheme property.
Name | The name of the index. DANGER WILL ROBINSON!! This is not escaped. Do you mean Index..::.QualifiedName?
NoRecompute | True if the index is defined with NORECOMPUTE.
ObjectType | Returns ObjectType.Index
Online | True iff the index is to be created online.
Owner | The owner of the index's table.
Pad | The index padding.
PartitionedField | Obsolete.
PrimaryKey | Obsolete.
QualifiedName | The qualified name of the object. Do you mean Index..::.Name?
Relational | True if this is a relational index.
ScriptSource | The location of the creation script for this object if the database source is set to scripts folder.
SortInTempDb | True iff the index is to be created using tempdb.
Spatial | True if the index is a spatial index.
SpatialIndexInformation | Obsolete.
Statistics | True if the index is a statistic.
SysobjectID | The sysobject identier of the object.
SystemNamed |
Unique | Obsolete.
UniqueConstraint | Obsolete.
WriteFileGroupOrPartitionScheme | Whether (disregarding any options) the filegroup should be written out
Xml | True if the index is an XML index.

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |
IDatabaseObject..::.Equals |

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


Index Methods

[image] [image]

SQL Data Compare API 12.0.40
Index Methods
Index Class See Also

The Index type exposes the following methods.

Methods

Name | Description
AppendWithClause |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FieldsCompareWith |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetQualifiedName |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |
IDatabaseObject..::.Equals |

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


AppendWithClause Method

[image]

SQL Data Compare API 12.0.40
Index..::.AppendWithClause Method
Index Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub AppendWithClause ( _
    sb As StringBuilder, _
    optionItems As IList(Of String) _
)
C#
protected static void AppendWithClause(
    StringBuilder sb,
    IList<string> optionItems
)
Visual C++
protected:
static void AppendWithClause(
    StringBuilder^ sb,
    IList<String^>^ optionItems
)

Parameters

sb
Type: StringBuilder
optionItems
Type: IList<(Of <(String>)>)

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
Index..::.ISqlComparable..::.CompareWith Method
Index Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    obj As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable obj,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ obj,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

obj
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


IDatabaseObject.Equals Method

[image]

SQL Data Compare API 12.0.40
Index..::.IDatabaseObject..::.Equals Method
Index Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function Equals ( _
    obj As IDatabaseObject, _
    options As Options _
) As Boolean Implements IDatabaseObject.Equals
C#
bool IDatabaseObject.Equals(
    IDatabaseObject obj,
    Options options
)
Visual C++
private:
virtual bool Equals(
    IDatabaseObject^ obj,
    Options options
) sealed = IDatabaseObject::Equals

Parameters

obj
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


FieldsCompareWith Method

[image]

SQL Data Compare API 12.0.40
Index..::.FieldsCompareWith Method
Index Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function FieldsCompareWith ( _
    value As Index, _
    options As Options _
) As IEnumerable(Of EqualityDifference)
C#
protected virtual IEnumerable<EqualityDifference> FieldsCompareWith(
    Index value,
    Options options
)
Visual C++
protected:
virtual IEnumerable<EqualityDifference^>^ FieldsCompareWith(
    Index^ value,
    Options options
)

Parameters

value
Type: RedGate.SQLCompare.Engine..::.Index
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


GetQualifiedName Method

[image]

SQL Data Compare API 12.0.40
Index..::.GetQualifiedName Method
Index Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetQualifiedName ( _
    name As String _
) As String
C#
protected static string GetQualifiedName(
    string name
)
Visual C++
protected:
static String^ GetQualifiedName(
    String^ name
)

Parameters

name
Type: String

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


Index Properties

[image] [image]

SQL Data Compare API 12.0.40
Index Properties
Index Class See Also

The Index type exposes the following properties.

Properties

Name | Description
AllowPageLocks | True if the index allows page locks.
AllowRowLocks | True if the index allows row locks.
Clustered | Obsolete.
Database | The database to which the index belongs.
Fields | The fields in the index.
FileGroup | Obsolete.
FileGroupOrPartitionScheme | The filegroup or the partition scheme on which the index is defined.
FilestreamFileGroup | Obsolete.
FillFactor | The fill factor.
Filter | Obsolete.
FullScan | True if the index is defined with FullScan
FullyQualifiedName | Obsolete. The fully-qualified name of the index. DANGER WILL ROBINSON!! This is not escaped.
IgnoreDuplicateKeys | True if set to ignore duplicate keys.
Incremental | True if incremental (introduced in SQL Server 2014)
IsColumnstore | Stupid columnstore indexes mark all of their fields as included but use the normal syntax to list them. (http://msdn.microsoft.com/en-us/library/ms175105.aspx)
IsDisabled | Indicates whether the index is disabled.
IsKeyIndexForFullTextIndex | Obsolete.
IsPartitioned | Indicates whether the index is built on a partition scheme. If it is, the name of the partition scheme is returned by the FileGroupOrPartitionScheme property.
Name | The name of the index. DANGER WILL ROBINSON!! This is not escaped. Do you mean Index..::.QualifiedName?
NoRecompute | True if the index is defined with NORECOMPUTE.
ObjectType | Returns ObjectType.Index
Online | True iff the index is to be created online.
Owner | The owner of the index's table.
Pad | The index padding.
PartitionedField | Obsolete.
PrimaryKey | Obsolete.
QualifiedName | The qualified name of the object. Do you mean Index..::.Name?
Relational | True if this is a relational index.
ScriptSource | The location of the creation script for this object if the database source is set to scripts folder.
SortInTempDb | True iff the index is to be created using tempdb.
Spatial | True if the index is a spatial index.
SpatialIndexInformation | Obsolete.
Statistics | True if the index is a statistic.
SysobjectID | The sysobject identier of the object.
SystemNamed |
Unique | Obsolete.
UniqueConstraint | Obsolete.
WriteFileGroupOrPartitionScheme | Whether (disregarding any options) the filegroup should be written out
Xml | True if the index is an XML index.

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


AllowPageLocks Property

[image]

SQL Data Compare API 12.0.40
Index..::.AllowPageLocks Property
Index Class See Also

True if the index allows page locks.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowPageLocks As Boolean
C#
public bool AllowPageLocks { get; internal set; }
Visual C++
public:
property bool AllowPageLocks {
    bool get ();
    void set (bool value);
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


AllowRowLocks Property

[image]

SQL Data Compare API 12.0.40
Index..::.AllowRowLocks Property
Index Class See Also

True if the index allows row locks.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowRowLocks As Boolean
C#
public bool AllowRowLocks { get; internal set; }
Visual C++
public:
property bool AllowRowLocks {
    bool get ();
    void set (bool value);
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


Clustered Property

[image]

SQL Data Compare API 12.0.40
Index..::.Clustered Property
Index Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("This is now a property of the RelationalIndex class")> _
Public ReadOnly Property Clustered As Boolean
C#
[ObsoleteAttribute("This is now a property of the RelationalIndex class")]
public bool Clustered { get; }
Visual C++
[ObsoleteAttribute(L"This is now a property of the RelationalIndex class")]
public:
property bool Clustered {
    bool get ();
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


Database Property

[image]

SQL Data Compare API 12.0.40
Index..::.Database Property
Index Class See Also

The database to which the index belongs.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Database As Database
C#
public Database Database { get; }
Visual C++
public:
virtual property Database^ Database {
    Database^ get () sealed;
}

Implements

IDatabaseObject..::.Database

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


Fields Property

[image]

SQL Data Compare API 12.0.40
Index..::.Fields Property
Index Class See Also

The fields in the index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Fields As IndexFields
C#
public IndexFields Fields { get; private set; }
Visual C++
public:
property IndexFields^ Fields {
    IndexFields^ get ();
    void set (IndexFields^ value);
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


FileGroup Property

[image]

SQL Data Compare API 12.0.40
Index..::.FileGroup Property
Index Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("This has been renamed to FileGroupOrPartitionScheme")> _
Public ReadOnly Property FileGroup As String
C#
[ObsoleteAttribute("This has been renamed to FileGroupOrPartitionScheme")]
public string FileGroup { get; }
Visual C++
[ObsoleteAttribute(L"This has been renamed to FileGroupOrPartitionScheme")]
public:
property String^ FileGroup {
    String^ get ();
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


FileGroupOrPartitionScheme Property

[image]

SQL Data Compare API 12.0.40
Index..::.FileGroupOrPartitionScheme Property
Index Class See Also

The filegroup or the partition scheme on which the index is defined.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FileGroupOrPartitionScheme As String
C#
public string FileGroupOrPartitionScheme { get; internal set; }
Visual C++
public:
property String^ FileGroupOrPartitionScheme {
    String^ get ();
    void set (String^ value);
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


FilestreamFileGroup Property

[image]

SQL Data Compare API 12.0.40
Index..::.FilestreamFileGroup Property
Index Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("This is now a property of the RelationalIndex class")> _
Public ReadOnly Property FilestreamFileGroup As String
C#
[ObsoleteAttribute("This is now a property of the RelationalIndex class")]
public string FilestreamFileGroup { get; }
Visual C++
[ObsoleteAttribute(L"This is now a property of the RelationalIndex class")]
public:
property String^ FilestreamFileGroup {
    String^ get ();
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


FillFactor Property

[image]

SQL Data Compare API 12.0.40
Index..::.FillFactor Property
Index Class See Also

The fill factor.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FillFactor As Byte
C#
public byte FillFactor { get; internal set; }
Visual C++
public:
property unsigned char FillFactor {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


Filter Property

[image]

SQL Data Compare API 12.0.40
Index..::.Filter Property
Index Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("This is now a property of the RelationalIndex and Statistics classes")> _
Public ReadOnly Property Filter As String
C#
[ObsoleteAttribute("This is now a property of the RelationalIndex and Statistics classes")]
public string Filter { get; }
Visual C++
[ObsoleteAttribute(L"This is now a property of the RelationalIndex and Statistics classes")]
public:
property String^ Filter {
    String^ get ();
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


FullScan Property

[image]

SQL Data Compare API 12.0.40
Index..::.FullScan Property
Index Class See Also

True if the index is defined with FullScan

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullScan As Boolean
C#
public bool FullScan { get; internal set; }
Visual C++
public:
property bool FullScan {
    bool get ();
    void set (bool value);
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


FullyQualifiedName Property

[image]

SQL Data Compare API 12.0.40
Index..::.FullyQualifiedName Property
Index Class See Also

The fully-qualified name of the index. DANGER WILL ROBINSON!! This is not escaped.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Do not use this - to preserve previous behaviour, use Name, to get the actual FullyQualifiedName use Utils.BuildFullyQualifiedName(Owner, Name)")> _
Public ReadOnly Property FullyQualifiedName As String
C#
[ObsoleteAttribute("Do not use this - to preserve previous behaviour, use Name, to get the actual FullyQualifiedName use Utils.BuildFullyQualifiedName(Owner, Name)")]
public string FullyQualifiedName { get; }
Visual C++
[ObsoleteAttribute(L"Do not use this - to preserve previous behaviour, use Name, to get the actual FullyQualifiedName use Utils.BuildFullyQualifiedName(Owner, Name)")]
public:
virtual property String^ FullyQualifiedName {
    String^ get () sealed;
}

Implements

ITSqlObjectFullyQualifiedName()()()

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


IgnoreDuplicateKeys Property

[image]

SQL Data Compare API 12.0.40
Index..::.IgnoreDuplicateKeys Property
Index Class See Also

True if set to ignore duplicate keys.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IgnoreDuplicateKeys As Boolean
C#
public bool IgnoreDuplicateKeys { get; internal set; }
Visual C++
public:
property bool IgnoreDuplicateKeys {
    bool get ();
    void set (bool value);
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


Incremental Property

[image]

SQL Data Compare API 12.0.40
Index..::.Incremental Property
Index Class See Also

True if incremental (introduced in SQL Server 2014)

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Incremental As Boolean
C#
public bool Incremental { get; internal set; }
Visual C++
public:
property bool Incremental {
    bool get ();
    void set (bool value);
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


IsColumnstore Property

[image]

SQL Data Compare API 12.0.40
Index..::.IsColumnstore Property
Index Class See Also

Stupid columnstore indexes mark all of their fields as included but use the normal syntax to list them. (http://msdn.microsoft.com/en-us/library/ms175105.aspx)

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsColumnstore As Boolean
C#
public bool IsColumnstore { get; }
Visual C++
public:
property bool IsColumnstore {
    bool get ();
}

Remarks

Blargh, bad hack

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


IsDisabled Property

[image]

SQL Data Compare API 12.0.40
Index..::.IsDisabled Property
Index Class See Also

Indicates whether the index is disabled.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsDisabled As Boolean
C#
public bool IsDisabled { get; internal set; }
Visual C++
public:
property bool IsDisabled {
    bool get ();
    void set (bool value);
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


IsKeyIndexForFullTextIndex Property

[image]

SQL Data Compare API 12.0.40
Index..::.IsKeyIndexForFullTextIndex Property
Index Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("This is now a property of the RelationalIndex class")> _
Public ReadOnly Property IsKeyIndexForFullTextIndex As Boolean
C#
[ObsoleteAttribute("This is now a property of the RelationalIndex class")]
public bool IsKeyIndexForFullTextIndex { get; }
Visual C++
[ObsoleteAttribute(L"This is now a property of the RelationalIndex class")]
public:
property bool IsKeyIndexForFullTextIndex {
    bool get ();
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


IsPartitioned Property

[image]

SQL Data Compare API 12.0.40
Index..::.IsPartitioned Property
Index Class See Also

Indicates whether the index is built on a partition scheme. If it is, the name of the partition scheme is returned by the FileGroupOrPartitionScheme property.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsPartitioned As Boolean
C#
public bool IsPartitioned { get; internal set; }
Visual C++
public:
virtual property bool IsPartitioned {
    bool get () sealed;
    void set (bool value) sealed;
}

Remarks

This can be true for xml and spatial indexes, as they inherit their partitioning from the parent table if it isn't otherwise specified.

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
Index..::.Name Property
Index Class See Also

The name of the index. DANGER WILL ROBINSON!! This is not escaped. Do you mean Index..::.QualifiedName?

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; internal set; }
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ITSqlObjectName()()()

Remarks

Note that changing this WILL mess up the parent collection of Indexes! One should use/implement the rename index in that collection, OR do the rename outside the collection. The primary use for this method is in the refactoring tool.

See Also

Index Class
RedGate.SQLCompare.Engine Namespace
Index..::.QualifiedName


NoRecompute Property

[image]

SQL Data Compare API 12.0.40
Index..::.NoRecompute Property
Index Class See Also

True if the index is defined with NORECOMPUTE.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NoRecompute As Boolean
C#
public bool NoRecompute { get; internal set; }
Visual C++
public:
property bool NoRecompute {
    bool get ();
    void set (bool value);
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
Index..::.ObjectType Property
Index Class See Also

Returns ObjectType.Index

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ObjectType As ObjectType
C#
public ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () sealed;
}

Implements

ITSqlObjectObjectType()()()

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


Online Property

[image]

SQL Data Compare API 12.0.40
Index..::.Online Property
Index Class See Also

True iff the index is to be created online.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Online As Boolean
C#
public bool Online { get; internal set; }
Visual C++
public:
property bool Online {
    bool get ();
    void set (bool value);
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
Index..::.Owner Property
Index Class See Also

The owner of the index's table.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Owner As String
C#
public string Owner { get; }
Visual C++
public:
virtual property String^ Owner {
    String^ get () sealed;
}

Implements

ITSqlObjectOwner()()()

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


Pad Property

[image]

SQL Data Compare API 12.0.40
Index..::.Pad Property
Index Class See Also

The index padding.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Pad As Boolean
C#
public bool Pad { get; internal set; }
Visual C++
public:
property bool Pad {
    bool get ();
    void set (bool value);
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


PartitionedField Property

[image]

SQL Data Compare API 12.0.40
Index..::.PartitionedField Property
Index Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("This is now a property of the RelationalIndex class")> _
Public ReadOnly Property PartitionedField As IField
C#
[ObsoleteAttribute("This is now a property of the RelationalIndex class")]
public IField PartitionedField { get; }
Visual C++
[ObsoleteAttribute(L"This is now a property of the RelationalIndex class")]
public:
property IField^ PartitionedField {
    IField^ get ();
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


PrimaryKey Property

[image]

SQL Data Compare API 12.0.40
Index..::.PrimaryKey Property
Index Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("This is now a property of the RelationalIndex class")> _
Public ReadOnly Property PrimaryKey As Boolean
C#
[ObsoleteAttribute("This is now a property of the RelationalIndex class")]
public bool PrimaryKey { get; }
Visual C++
[ObsoleteAttribute(L"This is now a property of the RelationalIndex class")]
public:
property bool PrimaryKey {
    bool get ();
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


QualifiedName Property

[image]

SQL Data Compare API 12.0.40
Index..::.QualifiedName Property
Index Class See Also

The qualified name of the object. Do you mean Index..::.Name?

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property QualifiedName As String
C#
public string QualifiedName { get; }
Visual C++
public:
virtual property String^ QualifiedName {
    String^ get () sealed;
}

Implements

ITSqlObjectQualifiedName()()()

See Also

Index Class
RedGate.SQLCompare.Engine Namespace
Index..::.Name


Relational Property

[image]

SQL Data Compare API 12.0.40
Index..::.Relational Property
Index Class See Also

True if this is a relational index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Relational As Boolean
C#
public bool Relational { get; }
Visual C++
public:
property bool Relational {
    bool get ();
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


ScriptSource Property

[image]

SQL Data Compare API 12.0.40
Index..::.ScriptSource Property
Index Class See Also

The location of the creation script for this object if the database source is set to scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSource As ScriptSource
C#
public ScriptSource ScriptSource { get; internal set; }
Visual C++
public:
virtual property ScriptSource^ ScriptSource {
    ScriptSource^ get () sealed;
    void set (ScriptSource^ value) sealed;
}

Implements

IHasScriptSource..::.ScriptSource

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


SortInTempDb Property

[image]

SQL Data Compare API 12.0.40
Index..::.SortInTempDb Property
Index Class See Also

True iff the index is to be created using tempdb.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SortInTempDb As Boolean
C#
public bool SortInTempDb { get; set; }
Visual C++
public:
property bool SortInTempDb {
    bool get ();
    void set (bool value);
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


Spatial Property

[image]

SQL Data Compare API 12.0.40
Index..::.Spatial Property
Index Class See Also

True if the index is a spatial index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Spatial As Boolean
C#
public bool Spatial { get; }
Visual C++
public:
property bool Spatial {
    bool get ();
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


SpatialIndexInformation Property

[image]

SQL Data Compare API 12.0.40
Index..::.SpatialIndexInformation Property
Index Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("This is now part of the SpatialIndex class", True)> _
Public ReadOnly Property SpatialIndexInformation As SpatialIndexInformation
C#
[ObsoleteAttribute("This is now part of the SpatialIndex class", true)]
public SpatialIndexInformation SpatialIndexInformation { get; }
Visual C++
[ObsoleteAttribute(L"This is now part of the SpatialIndex class", true)]
public:
property SpatialIndexInformation^ SpatialIndexInformation {
    SpatialIndexInformation^ get ();
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


Statistics Property

[image]

SQL Data Compare API 12.0.40
Index..::.Statistics Property
Index Class See Also

True if the index is a statistic.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Statistics As Boolean
C#
public bool Statistics { get; }
Visual C++
public:
property bool Statistics {
    bool get ();
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


SysobjectID Property

[image]

SQL Data Compare API 12.0.40
Index..::.SysobjectID Property
Index Class See Also

The sysobject identier of the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SysobjectID As Integer
C#
public int SysobjectID { get; internal set; }
Visual C++
public:
virtual property int SysobjectID {
    int get () sealed;
    void set (int value) sealed;
}

Remarks

Currently this is only used for relational indexes to calculate whether they're part of a filetable's default schema

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


SystemNamed Property

[image]

SQL Data Compare API 12.0.40
Index..::.SystemNamed Property
Index Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SystemNamed As Boolean
C#
public bool SystemNamed { get; set; }
Visual C++
public:
virtual property bool SystemNamed {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


Unique Property

[image]

SQL Data Compare API 12.0.40
Index..::.Unique Property
Index Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("This is now a property of the RelationalIndex class")> _
Public ReadOnly Property Unique As Boolean
C#
[ObsoleteAttribute("This is now a property of the RelationalIndex class")]
public bool Unique { get; }
Visual C++
[ObsoleteAttribute(L"This is now a property of the RelationalIndex class")]
public:
property bool Unique {
    bool get ();
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


UniqueConstraint Property

[image]

SQL Data Compare API 12.0.40
Index..::.UniqueConstraint Property
Index Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("This is now a property of the RelationalIndex class")> _
Public ReadOnly Property UniqueConstraint As Boolean
C#
[ObsoleteAttribute("This is now a property of the RelationalIndex class")]
public bool UniqueConstraint { get; }
Visual C++
[ObsoleteAttribute(L"This is now a property of the RelationalIndex class")]
public:
property bool UniqueConstraint {
    bool get ();
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


WriteFileGroupOrPartitionScheme Property

[image]

SQL Data Compare API 12.0.40
Index..::.WriteFileGroupOrPartitionScheme Property
Index Class See Also

Whether (disregarding any options) the filegroup should be written out

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property WriteFileGroupOrPartitionScheme As Boolean
C#
protected bool WriteFileGroupOrPartitionScheme { get; }
Visual C++
protected:
property bool WriteFileGroupOrPartitionScheme {
    bool get ();
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


Xml Property

[image]

SQL Data Compare API 12.0.40
Index..::.Xml Property
Index Class See Also

True if the index is an XML index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Xml As Boolean
C#
public bool Xml { get; }
Visual C++
public:
property bool Xml {
    bool get ();
}

See Also

Index Class
RedGate.SQLCompare.Engine Namespace


Indexes Class

[image]

SQL Data Compare API 12.0.40
Indexes Class
Members See Also

A collection of indexes.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Indexes _
    Inherits SerializableDatabaseObjectCollection(Of Index)
C#
public sealed class Indexes : SerializableDatabaseObjectCollection<Index>
Visual C++
public ref class Indexes sealed : public SerializableDatabaseObjectCollection<Index^>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Index >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( Index >)>)
RedGate.SQLCompare.Engine..::.Indexes

See Also

Indexes Members
RedGate.SQLCompare.Engine Namespace


Indexes Members

[image] [image]

SQL Data Compare API 12.0.40
Indexes Members
Indexes Class Methods Fields Properties Explicit Interface Implementations See Also

The Indexes type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
ColumnstoreIndexes | An IEnumerable of all the columnstore indexes in this collection.
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.
Relational | An IEnumerable of all the relational indexes in this collection.
Spatial | An IEnumerable of all the spatial indexes in this collection.
Statistics | An IEnumerable of all the statistics in this collection.
Xml | An IEnumerable of all the xml indexes in this collection.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

Indexes Class
RedGate.SQLCompare.Engine Namespace


Indexes Methods

[image] [image]

SQL Data Compare API 12.0.40
Indexes Methods
Indexes Class See Also

The Indexes type exposes the following methods.

Methods

Name | Description
Add | Overloaded.
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

Indexes Class
RedGate.SQLCompare.Engine Namespace


Add Method

[image] [image]

SQL Data Compare API 12.0.40
Indexes..::.Add Method
Indexes Class See Also

Overload List

Name | Description
Add(T) | (Inherited from KeyedCollection<(Of <(T>)>).)
Add(Index) | (Overrides SerializableDatabaseObjectCollection <(Of <( Index >)>)..::. Add(T).)

See Also

Indexes Class
Indexes Members
RedGate.SQLCompare.Engine Namespace


Add Method (Index)

[image]

SQL Data Compare API 12.0.40
Indexes..::.Add Method (Index)
Indexes Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Add ( _
    value As Index _
)
C#
public override void Add(
    Index value
)
Visual C++
public:
virtual void Add(
    Index^ value
) override

Parameters

value
Type: RedGate.SQLCompare.Engine..::.Index

See Also

Indexes Class
Add Overload
RedGate.SQLCompare.Engine Namespace


Indexes Properties

[image] [image]

SQL Data Compare API 12.0.40
Indexes Properties
Indexes Class See Also

The Indexes type exposes the following properties.

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
ColumnstoreIndexes | An IEnumerable of all the columnstore indexes in this collection.
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.
Relational | An IEnumerable of all the relational indexes in this collection.
Spatial | An IEnumerable of all the spatial indexes in this collection.
Statistics | An IEnumerable of all the statistics in this collection.
Xml | An IEnumerable of all the xml indexes in this collection.

See Also

Indexes Class
RedGate.SQLCompare.Engine Namespace


ColumnstoreIndexes Property

[image]

SQL Data Compare API 12.0.40
Indexes..::.ColumnstoreIndexes Property
Indexes Class See Also

An IEnumerable of all the columnstore indexes in this collection.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnstoreIndexes As IEnumerable(Of RelationalIndex)
C#
public IEnumerable<RelationalIndex> ColumnstoreIndexes { get; }
Visual C++
public:
property IEnumerable<RelationalIndex^>^ ColumnstoreIndexes {
    IEnumerable<RelationalIndex^>^ get ();
}

See Also

Indexes Class
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
Indexes..::.Item Property
Indexes Class See Also

Overload List

Name | Description
Item[([(String])]) | Returns an index given a name. (Overrides KeyedCollection <(Of <( T >)>)..::. Item[([(String])]).)
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Indexes Class
Indexes Members
RedGate.SQLCompare.Engine Namespace


Item Property ()

[image]

SQL Data Compare API 12.0.40
Indexes..::.Item Property ()
Indexes Class See Also

Returns an index given a name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Default Property Item ( _
    name As String _
) As Index
C#
public override Index this[
    string name
] { get; }
Visual C++
public:
virtual property Index^ default[String^ name] {
    Index^ get (String^ name) override;
}

Parameters

name
Type: String
The string-based index of the element to get or set.

Implements

IKeyedCollectionItem(String)

See Also

Indexes Class
Item Overload
RedGate.SQLCompare.Engine Namespace


Relational Property

[image]

SQL Data Compare API 12.0.40
Indexes..::.Relational Property
Indexes Class See Also

An IEnumerable of all the relational indexes in this collection.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Relational As IEnumerable(Of RelationalIndex)
C#
public IEnumerable<RelationalIndex> Relational { get; }
Visual C++
public:
property IEnumerable<RelationalIndex^>^ Relational {
    IEnumerable<RelationalIndex^>^ get ();
}

See Also

Indexes Class
RedGate.SQLCompare.Engine Namespace


Spatial Property

[image]

SQL Data Compare API 12.0.40
Indexes..::.Spatial Property
Indexes Class See Also

An IEnumerable of all the spatial indexes in this collection.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Spatial As IEnumerable(Of SpatialIndex)
C#
public IEnumerable<SpatialIndex> Spatial { get; }
Visual C++
public:
property IEnumerable<SpatialIndex^>^ Spatial {
    IEnumerable<SpatialIndex^>^ get ();
}

See Also

Indexes Class
RedGate.SQLCompare.Engine Namespace


Statistics Property

[image]

SQL Data Compare API 12.0.40
Indexes..::.Statistics Property
Indexes Class See Also

An IEnumerable of all the statistics in this collection.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Statistics As IEnumerable(Of Statistics)
C#
public IEnumerable<Statistics> Statistics { get; }
Visual C++
public:
property IEnumerable<Statistics^>^ Statistics {
    IEnumerable<Statistics^>^ get ();
}

See Also

Indexes Class
RedGate.SQLCompare.Engine Namespace


Xml Property

[image]

SQL Data Compare API 12.0.40
Indexes..::.Xml Property
Indexes Class See Also

An IEnumerable of all the xml indexes in this collection.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Xml As IEnumerable(Of XmlIndex)
C#
public IEnumerable<XmlIndex> Xml { get; }
Visual C++
public:
property IEnumerable<XmlIndex^>^ Xml {
    IEnumerable<XmlIndex^>^ get ();
}

See Also

Indexes Class
RedGate.SQLCompare.Engine Namespace


IndexesChangeCalculator Class

[image]

SQL Data Compare API 12.0.40
IndexesChangeCalculator Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class IndexesChangeCalculator
C#
public class IndexesChangeCalculator
Visual C++
public ref class IndexesChangeCalculator

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.IndexesChangeCalculator

See Also

IndexesChangeCalculator Members
RedGate.SQLCompare.Engine Namespace


IndexesChangeCalculator Members

[image] [image]

SQL Data Compare API 12.0.40
IndexesChangeCalculator Members
IndexesChangeCalculator Class Constructors Methods See Also

The IndexesChangeCalculator type exposes the following members.

Constructors

Name | Description
IndexesChangeCalculator |

Methods

Name | Description
AnyIndexesBeingDroppedForPrimaryKeys |
CalculateWorkTableIndexes |
DropIndexes |
DropIndexesIfNeeded |
DropStatistics |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GenerateIndexDowngradeWarnings |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SkipDroppingClusteredIndexWhenDeployingToAzure |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryAddOrWarnAboutIndex |

See Also

IndexesChangeCalculator Class
RedGate.SQLCompare.Engine Namespace


IndexesChangeCalculator Constructor

[image]

SQL Data Compare API 12.0.40
IndexesChangeCalculator Constructor
IndexesChangeCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    indexWarningsCalculator As IndexWarningsCalculator, _
    udTsToRemoveFromFields As FieldBindings, _
    udTsToRebindToFields As FieldBindings, _
    checkConstraintChangesCalculator As CheckConstraintChangesCalculator, _
    indexesChanges As IndexesChanges, _
    partitionSchemeChanges As PartitionSchemesChanges, _
    filestreamIndexCalculator As FilestreamIndexCalculator _
)
C#
public IndexesChangeCalculator(
    IndexWarningsCalculator indexWarningsCalculator,
    FieldBindings udTsToRemoveFromFields,
    FieldBindings udTsToRebindToFields,
    CheckConstraintChangesCalculator checkConstraintChangesCalculator,
    IndexesChanges indexesChanges,
    PartitionSchemesChanges partitionSchemeChanges,
    FilestreamIndexCalculator filestreamIndexCalculator
)
Visual C++
public:
IndexesChangeCalculator(
    IndexWarningsCalculator^ indexWarningsCalculator,
    FieldBindings^ udTsToRemoveFromFields,
    FieldBindings^ udTsToRebindToFields,
    CheckConstraintChangesCalculator^ checkConstraintChangesCalculator,
    IndexesChanges^ indexesChanges,
    PartitionSchemesChanges^ partitionSchemeChanges,
    FilestreamIndexCalculator^ filestreamIndexCalculator
)

Parameters

indexWarningsCalculator
Type: RedGate.SQLCompare.Engine..::.IndexWarningsCalculator
udTsToRemoveFromFields
Type: RedGate.SQLCompare.Engine..::.FieldBindings
udTsToRebindToFields
Type: RedGate.SQLCompare.Engine..::.FieldBindings
checkConstraintChangesCalculator
Type: RedGate.SQLCompare.Engine..::.CheckConstraintChangesCalculator
indexesChanges
Type: RedGate.SQLCompare.Engine..::.IndexesChanges
partitionSchemeChanges
Type: RedGate.SQLCompare.Engine..::.PartitionSchemesChanges
filestreamIndexCalculator
Type: RedGate.SQLCompare.Engine.Deployment.ChangeCalculation..::.FilestreamIndexCalculator

See Also

IndexesChangeCalculator Class
RedGate.SQLCompare.Engine Namespace


IndexesChangeCalculator Methods

[image] [image]

SQL Data Compare API 12.0.40
IndexesChangeCalculator Methods
IndexesChangeCalculator Class See Also

The IndexesChangeCalculator type exposes the following methods.

Methods

Name | Description
AnyIndexesBeingDroppedForPrimaryKeys |
CalculateWorkTableIndexes |
DropIndexes |
DropIndexesIfNeeded |
DropStatistics |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GenerateIndexDowngradeWarnings |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SkipDroppingClusteredIndexWhenDeployingToAzure |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryAddOrWarnAboutIndex |

See Also

IndexesChangeCalculator Class
RedGate.SQLCompare.Engine Namespace


AnyIndexesBeingDroppedForPrimaryKeys Method

[image]

SQL Data Compare API 12.0.40
IndexesChangeCalculator..::.AnyIndexesBeingDroppedForPrimaryKeys Method
IndexesChangeCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function AnyIndexesBeingDroppedForPrimaryKeys ( _
    targetTable As Table _
) As Boolean
C#
public bool AnyIndexesBeingDroppedForPrimaryKeys(
    Table targetTable
)
Visual C++
public:
bool AnyIndexesBeingDroppedForPrimaryKeys(
    Table^ targetTable
)

Parameters

targetTable
Type: RedGate.SQLCompare.Engine..::.Table

See Also

IndexesChangeCalculator Class
RedGate.SQLCompare.Engine Namespace


CalculateWorkTableIndexes Method

[image]

SQL Data Compare API 12.0.40
IndexesChangeCalculator..::.CalculateWorkTableIndexes Method
IndexesChangeCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculateWorkTableIndexes ( _
    sourceTable As Table, _
    targetTable As Table, _
    targetDatabase As IDatabase, _
    fieldsToModify As Fields, _
    options As Options _
)
C#
public void CalculateWorkTableIndexes(
    Table sourceTable,
    Table targetTable,
    IDatabase targetDatabase,
    Fields fieldsToModify,
    Options options
)
Visual C++
public:
void CalculateWorkTableIndexes(
    Table^ sourceTable,
    Table^ targetTable,
    IDatabase^ targetDatabase,
    Fields^ fieldsToModify,
    Options options
)

Parameters

sourceTable
Type: RedGate.SQLCompare.Engine..::.Table
targetTable
Type: RedGate.SQLCompare.Engine..::.Table
targetDatabase
Type: RedGate.SQLCompare.Engine..::.IDatabase
fieldsToModify
Type: RedGate.SQLCompare.Engine..::.Fields
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

IndexesChangeCalculator Class
RedGate.SQLCompare.Engine Namespace


DropIndexes Method

[image]

SQL Data Compare API 12.0.40
IndexesChangeCalculator..::.DropIndexes Method
IndexesChangeCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub DropIndexes ( _
    targetTable As Table _
)
C#
public void DropIndexes(
    Table targetTable
)
Visual C++
public:
void DropIndexes(
    Table^ targetTable
)

Parameters

targetTable
Type: RedGate.SQLCompare.Engine..::.Table

See Also

IndexesChangeCalculator Class
RedGate.SQLCompare.Engine Namespace


DropIndexesIfNeeded Method

[image]

SQL Data Compare API 12.0.40
IndexesChangeCalculator..::.DropIndexesIfNeeded Method
IndexesChangeCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub DropIndexesIfNeeded ( _
    indexes As Indexes, _
    table As Table, _
    tableInSource As Table, _
    options As Options _
)
C#
public void DropIndexesIfNeeded(
    Indexes indexes,
    Table table,
    Table tableInSource,
    Options options
)
Visual C++
public:
void DropIndexesIfNeeded(
    Indexes^ indexes,
    Table^ table,
    Table^ tableInSource,
    Options options
)

Parameters

indexes
Type: RedGate.SQLCompare.Engine..::.Indexes
table
Type: RedGate.SQLCompare.Engine..::.Table
tableInSource
Type: RedGate.SQLCompare.Engine..::.Table
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

IndexesChangeCalculator Class
RedGate.SQLCompare.Engine Namespace


DropStatistics Method

[image]

SQL Data Compare API 12.0.40
IndexesChangeCalculator..::.DropStatistics Method
IndexesChangeCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub DropStatistics ( _
    table As Table _
)
C#
public void DropStatistics(
    Table table
)
Visual C++
public:
void DropStatistics(
    Table^ table
)

Parameters

table
Type: RedGate.SQLCompare.Engine..::.Table

See Also

IndexesChangeCalculator Class
RedGate.SQLCompare.Engine Namespace


GenerateIndexDowngradeWarnings Method

[image]

SQL Data Compare API 12.0.40
IndexesChangeCalculator..::.GenerateIndexDowngradeWarnings Method
IndexesChangeCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub GenerateIndexDowngradeWarnings ( _
    targetDatabase As Database, _
    options As Options, _
    indexes As Indexes, _
    sourceTable As Table, _
    targetTable As Table _
)
C#
public void GenerateIndexDowngradeWarnings(
    Database targetDatabase,
    Options options,
    Indexes indexes,
    Table sourceTable,
    Table targetTable
)
Visual C++
public:
void GenerateIndexDowngradeWarnings(
    Database^ targetDatabase,
    Options options,
    Indexes^ indexes,
    Table^ sourceTable,
    Table^ targetTable
)

Parameters

targetDatabase
Type: RedGate.SQLCompare.Engine..::.Database
options
Type: RedGate.SQLCompare.Engine..::.Options
indexes
Type: RedGate.SQLCompare.Engine..::.Indexes
sourceTable
Type: RedGate.SQLCompare.Engine..::.Table
targetTable
Type: RedGate.SQLCompare.Engine..::.Table

See Also

IndexesChangeCalculator Class
RedGate.SQLCompare.Engine Namespace


SkipDroppingClusteredIndexWhenDeployingToAzure Method

[image]

SQL Data Compare API 12.0.40
IndexesChangeCalculator..::.SkipDroppingClusteredIndexWhenDeployingToAzure Method
IndexesChangeCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SkipDroppingClusteredIndexWhenDeployingToAzure ( _
    idx As Index, _
    targetTable As Table _
) As Boolean
C#
public static bool SkipDroppingClusteredIndexWhenDeployingToAzure(
    Index idx,
    Table targetTable
)
Visual C++
public:
static bool SkipDroppingClusteredIndexWhenDeployingToAzure(
    Index^ idx,
    Table^ targetTable
)

Parameters

idx
Type: RedGate.SQLCompare.Engine..::.Index
targetTable
Type: RedGate.SQLCompare.Engine..::.Table

See Also

IndexesChangeCalculator Class
RedGate.SQLCompare.Engine Namespace


TryAddOrWarnAboutIndex Method

[image]

SQL Data Compare API 12.0.40
IndexesChangeCalculator..::.TryAddOrWarnAboutIndex Method
IndexesChangeCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub TryAddOrWarnAboutIndex ( _
    idx As Index, _
    targetDatabase As IDatabase, _
    options As Options _
)
C#
public void TryAddOrWarnAboutIndex(
    Index idx,
    IDatabase targetDatabase,
    Options options
)
Visual C++
public:
void TryAddOrWarnAboutIndex(
    Index^ idx,
    IDatabase^ targetDatabase,
    Options options
)

Parameters

idx
Type: RedGate.SQLCompare.Engine..::.Index
targetDatabase
Type: RedGate.SQLCompare.Engine..::.IDatabase
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

IndexesChangeCalculator Class
RedGate.SQLCompare.Engine Namespace


IndexesChanges Class

[image]

SQL Data Compare API 12.0.40
IndexesChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class IndexesChanges
C#
public sealed class IndexesChanges
Visual C++
public ref class IndexesChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.IndexesChanges

See Also

IndexesChanges Members
RedGate.SQLCompare.Engine Namespace


IndexesChanges Members

[image] [image]

SQL Data Compare API 12.0.40
IndexesChanges Members
IndexesChanges Class Constructors Methods Properties See Also

The IndexesChanges type exposes the following members.

Constructors

Name | Description
IndexesChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IndexesToCreate |
IndexesToDrop |

See Also

IndexesChanges Class
RedGate.SQLCompare.Engine Namespace


IndexesChanges Constructor

[image]

SQL Data Compare API 12.0.40
IndexesChanges Constructor
IndexesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public IndexesChanges(
    bool caseSensitive
)
Visual C++
public:
IndexesChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

IndexesChanges Class
RedGate.SQLCompare.Engine Namespace


IndexesChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
IndexesChanges Properties
IndexesChanges Class See Also

The IndexesChanges type exposes the following properties.

Properties

Name | Description
IndexesToCreate |
IndexesToDrop |

See Also

IndexesChanges Class
RedGate.SQLCompare.Engine Namespace


IndexesToCreate Property

[image]

SQL Data Compare API 12.0.40
IndexesChanges..::.IndexesToCreate Property
IndexesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IndexesToCreate As Indexes
C#
public Indexes IndexesToCreate { get; private set; }
Visual C++
public:
property Indexes^ IndexesToCreate {
    Indexes^ get ();
    void set (Indexes^ value);
}

See Also

IndexesChanges Class
RedGate.SQLCompare.Engine Namespace


IndexesToDrop Property

[image]

SQL Data Compare API 12.0.40
IndexesChanges..::.IndexesToDrop Property
IndexesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IndexesToDrop As Indexes
C#
public Indexes IndexesToDrop { get; private set; }
Visual C++
public:
property Indexes^ IndexesToDrop {
    Indexes^ get ();
    void set (Indexes^ value);
}

See Also

IndexesChanges Class
RedGate.SQLCompare.Engine Namespace


IndexFields Class

[image]

SQL Data Compare API 12.0.40
IndexFields Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class IndexFields _
    Inherits KeyedCollection(Of IndexField)
C#
public class IndexFields : KeyedCollection<IndexField>
Visual C++
public ref class IndexFields : public KeyedCollection<IndexField^>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( IndexField >)>)
RedGate.SQLCompare.Engine..::.IndexFields

See Also

IndexFields Members
RedGate.SQLCompare.Engine Namespace


IndexFields Members

[image] [image]

SQL Data Compare API 12.0.40
IndexFields Members
IndexFields Class Constructors Methods Fields Properties Explicit Interface Implementations See Also

The IndexFields type exposes the following members.

Constructors

Name | Description
IndexFields | Overloaded.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsField |
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | (Overrides KeyedCollection <(Of <( IndexField >)>)..::.GetKey(UTP).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WithName |

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

IndexFields Class
RedGate.SQLCompare.Engine Namespace


IndexFields Constructor

[image] [image]

SQL Data Compare API 12.0.40
IndexFields Constructor
IndexFields Class See Also

Overload List

Name | Description
IndexFields(Boolean) |
IndexFields(Boolean, Int32) |

See Also

IndexFields Class
IndexFields Members
RedGate.SQLCompare.Engine Namespace


IndexFields Constructor ()

[image]

SQL Data Compare API 12.0.40
IndexFields Constructor ()
IndexFields Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public IndexFields(
    bool caseSensitive
)
Visual C++
public:
IndexFields(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

IndexFields Class
IndexFields Overload
RedGate.SQLCompare.Engine Namespace


IndexFields Constructor (, )

[image]

SQL Data Compare API 12.0.40
IndexFields Constructor (, )
IndexFields Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean, _
    count As Integer _
)
C#
public IndexFields(
    bool caseSensitive,
    int count
)
Visual C++
public:
IndexFields(
    bool caseSensitive,
    int count
)

Parameters

caseSensitive
Type: Boolean
count
Type: Int32

See Also

IndexFields Class
IndexFields Overload
RedGate.SQLCompare.Engine Namespace


IndexFields Methods

[image] [image]

SQL Data Compare API 12.0.40
IndexFields Methods
IndexFields Class See Also

The IndexFields type exposes the following methods.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsField |
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | (Overrides KeyedCollection <(Of <( IndexField >)>)..::.GetKey(UTP).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WithName |

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

IndexFields Class
RedGate.SQLCompare.Engine Namespace


ContainsField Method

[image]

SQL Data Compare API 12.0.40
IndexFields..::.ContainsField Method
IndexFields Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function ContainsField ( _
    name As String _
) As Boolean
C#
public bool ContainsField(
    string name
)
Visual C++
public:
bool ContainsField(
    String^ name
)

Parameters

name
Type: String

See Also

IndexFields Class
RedGate.SQLCompare.Engine Namespace


GetKey Method

[image]

SQL Data Compare API 12.0.40
IndexFields..::.GetKey Method
IndexFields Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Friend Overrides Function GetKey ( _
    value As IndexField _
) As String
C#
protected internal override string GetKey(
    IndexField value
)
Visual C++
protected public:
virtual String^ GetKey(
    IndexField^ value
) override

Parameters

value
Type: RedGate.SQLCompare.Engine.Model..::.IndexField

See Also

IndexFields Class
RedGate.SQLCompare.Engine Namespace


WithName Method

[image]

SQL Data Compare API 12.0.40
IndexFields..::.WithName Method
IndexFields Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function WithName ( _
    name As String _
) As IndexField
C#
public IndexField WithName(
    string name
)
Visual C++
public:
IndexField^ WithName(
    String^ name
)

Parameters

name
Type: String

See Also

IndexFields Class
RedGate.SQLCompare.Engine Namespace


IndexWarningsCalculator Class

[image]

SQL Data Compare API 12.0.40
IndexWarningsCalculator Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class IndexWarningsCalculator
C#
public class IndexWarningsCalculator
Visual C++
public ref class IndexWarningsCalculator

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.IndexWarningsCalculator

See Also

IndexWarningsCalculator Members
RedGate.SQLCompare.Engine Namespace


IndexWarningsCalculator Members

[image] [image]

SQL Data Compare API 12.0.40
IndexWarningsCalculator Members
IndexWarningsCalculator Class Constructors Methods See Also

The IndexWarningsCalculator type exposes the following members.

Constructors

Name | Description
IndexWarningsCalculator |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IndexWarningsCalculator Class
RedGate.SQLCompare.Engine Namespace


IndexWarningsCalculator Constructor

[image]

SQL Data Compare API 12.0.40
IndexWarningsCalculator Constructor
IndexWarningsCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    warnings As Messages, _
    indexesChanges As IndexesChanges _
)
C#
public IndexWarningsCalculator(
    Messages warnings,
    IndexesChanges indexesChanges
)
Visual C++
public:
IndexWarningsCalculator(
    Messages^ warnings,
    IndexesChanges^ indexesChanges
)

Parameters

warnings
Type: RedGate.SQLCompare.Engine..::.Messages
indexesChanges
Type: RedGate.SQLCompare.Engine..::.IndexesChanges

See Also

IndexWarningsCalculator Class
RedGate.SQLCompare.Engine Namespace


InMemoryDependencyMemoizer Class

[image]

SQL Data Compare API 12.0.40
InMemoryDependencyMemoizer Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class InMemoryDependencyMemoizer _
    Implements IMemoizeDependencies
C#
public class InMemoryDependencyMemoizer : IMemoizeDependencies
Visual C++
public ref class InMemoryDependencyMemoizer : IMemoizeDependencies

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.InMemoryDependencyMemoizer

See Also

InMemoryDependencyMemoizer Members
RedGate.SQLCompare.Engine Namespace


InMemoryDependencyMemoizer Members

[image] [image]

SQL Data Compare API 12.0.40
InMemoryDependencyMemoizer Members
InMemoryDependencyMemoizer Class Constructors Methods See Also

The InMemoryDependencyMemoizer type exposes the following members.

Constructors

Name | Description
InMemoryDependencyMemoizer |

Methods

Name | Description
Clear |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Memoize |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryGetMemoized |

See Also

InMemoryDependencyMemoizer Class
RedGate.SQLCompare.Engine Namespace


InMemoryDependencyMemoizer Constructor

[image]

SQL Data Compare API 12.0.40
InMemoryDependencyMemoizer Constructor
InMemoryDependencyMemoizer Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public InMemoryDependencyMemoizer()
Visual C++
public:
InMemoryDependencyMemoizer()

See Also

InMemoryDependencyMemoizer Class
RedGate.SQLCompare.Engine Namespace


InMemoryDependencyMemoizer Methods

[image] [image]

SQL Data Compare API 12.0.40
InMemoryDependencyMemoizer Methods
InMemoryDependencyMemoizer Class See Also

The InMemoryDependencyMemoizer type exposes the following methods.

Methods

Name | Description
Clear |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Memoize |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryGetMemoized |

See Also

InMemoryDependencyMemoizer Class
RedGate.SQLCompare.Engine Namespace


Clear Method

[image]

SQL Data Compare API 12.0.40
InMemoryDependencyMemoizer..::.Clear Method
InMemoryDependencyMemoizer Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear
C#
public void Clear()
Visual C++
public:
virtual void Clear() sealed

Implements

IMemoizeDependencies..::.Clear()()()

See Also

InMemoryDependencyMemoizer Class
RedGate.SQLCompare.Engine Namespace


Memoize Method

[image]

SQL Data Compare API 12.0.40
InMemoryDependencyMemoizer..::.Memoize Method
InMemoryDependencyMemoizer Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Memoize ( _
    sql As String, _
    quotedIdentifiers As Boolean, _
    throwExceptions As Boolean, _
    result As Stack(Of String()) _
)
C#
public void Memoize(
    string sql,
    bool quotedIdentifiers,
    bool throwExceptions,
    Stack<string[]> result
)
Visual C++
public:
virtual void Memoize(
    String^ sql,
    bool quotedIdentifiers,
    bool throwExceptions,
    Stack<array<String^>^>^ result
) sealed

Parameters

sql
Type: String
quotedIdentifiers
Type: Boolean
throwExceptions
Type: Boolean
result
Type: Stack<(Of <(array<String>[]()[]>)>)

Implements

IMemoizeDependencies..::.Memoize(String, Boolean, Boolean, Stack<(Of <(array<String>[]()[]>)>))

See Also

InMemoryDependencyMemoizer Class
RedGate.SQLCompare.Engine Namespace


TryGetMemoized Method

[image]

SQL Data Compare API 12.0.40
InMemoryDependencyMemoizer..::.TryGetMemoized Method
InMemoryDependencyMemoizer Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function TryGetMemoized ( _
    sql As String, _
    quotedIdentifiers As Boolean, _
    throwExceptions As Boolean, _
    <OutAttribute> ByRef memoizedValue As Stack(Of String()) _
) As Boolean
C#
public bool TryGetMemoized(
    string sql,
    bool quotedIdentifiers,
    bool throwExceptions,
    out Stack<string[]> memoizedValue
)
Visual C++
public:
virtual bool TryGetMemoized(
    String^ sql,
    bool quotedIdentifiers,
    bool throwExceptions,
    [OutAttribute] Stack<array<String^>^>^% memoizedValue
) sealed

Parameters

sql
Type: String
quotedIdentifiers
Type: Boolean
throwExceptions
Type: Boolean
memoizedValue
Type: Stack<(Of <(array<String>[]()[]>)>)%

Implements

IMemoizeDependencies..::.TryGetMemoized(String, Boolean, Boolean, Stack<(Of <(array<String>[]()[]>)>)%)

See Also

InMemoryDependencyMemoizer Class
RedGate.SQLCompare.Engine Namespace


INonReadOnlyCollection Interface

[image]

SQL Data Compare API 12.0.40
INonReadOnlyCollection Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface INonReadOnlyCollection
C#
public interface INonReadOnlyCollection
Visual C++
public interface class INonReadOnlyCollection

See Also

INonReadOnlyCollection Members
RedGate.SQLCompare.Engine Namespace


INonReadOnlyCollection Members

[image] [image]

SQL Data Compare API 12.0.40
INonReadOnlyCollection Members
INonReadOnlyCollection Interface Methods See Also

The INonReadOnlyCollection type exposes the following members.

Methods

Name | Description
AsReadOnly |
Freeze |

See Also

INonReadOnlyCollection Interface
RedGate.SQLCompare.Engine Namespace


INonReadOnlyCollection Methods

[image] [image]

SQL Data Compare API 12.0.40
INonReadOnlyCollection Methods
INonReadOnlyCollection Interface See Also

The INonReadOnlyCollection type exposes the following methods.

Methods

Name | Description
AsReadOnly |
Freeze |

See Also

INonReadOnlyCollection Interface
RedGate.SQLCompare.Engine Namespace


AsReadOnly Method

[image]

SQL Data Compare API 12.0.40
INonReadOnlyCollection..::.AsReadOnly Method
INonReadOnlyCollection Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function AsReadOnly As IReadOnlyKeyedDatabaseObjectCollectionWrapper
C#
IReadOnlyKeyedDatabaseObjectCollectionWrapper AsReadOnly()
Visual C++
IReadOnlyKeyedDatabaseObjectCollectionWrapper^ AsReadOnly()

See Also

INonReadOnlyCollection Interface
RedGate.SQLCompare.Engine Namespace


Freeze Method

[image]

SQL Data Compare API 12.0.40
INonReadOnlyCollection..::.Freeze Method
INonReadOnlyCollection Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub Freeze
C#
void Freeze()
Visual C++
void Freeze()

See Also

INonReadOnlyCollection Interface
RedGate.SQLCompare.Engine Namespace


IOwner Interface

[image]

SQL Data Compare API 12.0.40
IOwner Interface
Members See Also

An interface representing an object that can 'own' other objects.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IOwner _
    Implements IDatabaseObject, ITSqlObject, ICanExistenceCheck
C#
public interface IOwner : IDatabaseObject, ITSqlObject,
    ICanExistenceCheck
Visual C++
public interface class IOwner : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck

Remarks

Currently used for Role, Schema, User

See Also

IOwner Members
RedGate.SQLCompare.Engine Namespace


IOwner Members

[image] [image]

SQL Data Compare API 12.0.40
IOwner Members
IOwner Interface Methods Properties See Also

The IOwner type exposes the following members.

Methods

Name | Description
Equals | Compares two database objects. (Inherited from IDatabaseObject.)

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from IDatabaseObject.)
FullyQualifiedName | (Inherited from ITSqlObject.)
Name | (Inherited from ITSqlObject.)
ObjectType | (Inherited from ITSqlObject.)
Owner | (Inherited from ITSqlObject.)
QualifiedName | (Inherited from ITSqlObject.)

See Also

IOwner Interface
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization Interface

[image]

SQL Data Compare API 12.0.40
IPatchUpAfterDeserialization Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IPatchUpAfterDeserialization
C#
public interface IPatchUpAfterDeserialization
Visual C++
public interface class IPatchUpAfterDeserialization

See Also

IPatchUpAfterDeserialization Members
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization Members

[image] [image]

SQL Data Compare API 12.0.40
IPatchUpAfterDeserialization Members
IPatchUpAfterDeserialization Interface Methods See Also

The IPatchUpAfterDeserialization type exposes the following members.

Methods

Name | Description
PatchUpAfterDeserialization | This method must be idempotent - it may be called any number of times and at any time. Ideally the first call should patch up the object collection, and all subsequent calls should do nothing.

See Also

IPatchUpAfterDeserialization Interface
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization Methods

[image] [image]

SQL Data Compare API 12.0.40
IPatchUpAfterDeserialization Methods
IPatchUpAfterDeserialization Interface See Also

The IPatchUpAfterDeserialization type exposes the following methods.

Methods

Name | Description
PatchUpAfterDeserialization | This method must be idempotent - it may be called any number of times and at any time. Ideally the first call should patch up the object collection, and all subsequent calls should do nothing.

See Also

IPatchUpAfterDeserialization Interface
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
IPatchUpAfterDeserialization Interface See Also

This method must be idempotent - it may be called any number of times and at any time. Ideally the first call should patch up the object collection, and all subsequent calls should do nothing.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
void PatchUpAfterDeserialization(
    Database database
)
Visual C++
void PatchUpAfterDeserialization(
    Database^ database
)

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

See Also

IPatchUpAfterDeserialization Interface
RedGate.SQLCompare.Engine Namespace


IReadOnlyKeyedDatabaseObjectCollectionWrapper Interface

[image]

SQL Data Compare API 12.0.40
IReadOnlyKeyedDatabaseObjectCollectionWrapper Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IReadOnlyKeyedDatabaseObjectCollectionWrapper _
    Implements ICollection(Of IDatabaseObject), IEnumerable(Of IDatabaseObject),  _
    IEnumerable
C#
public interface IReadOnlyKeyedDatabaseObjectCollectionWrapper : ICollection<IDatabaseObject>,
    IEnumerable<IDatabaseObject>, IEnumerable
Visual C++
public interface class IReadOnlyKeyedDatabaseObjectCollectionWrapper : ICollection<IDatabaseObject^>,
    IEnumerable<IDatabaseObject^>, IEnumerable

See Also

IReadOnlyKeyedDatabaseObjectCollectionWrapper Members
RedGate.SQLCompare.Engine Namespace


IReadOnlyKeyedDatabaseObjectCollectionWrapper Members

[image] [image]

SQL Data Compare API 12.0.40
IReadOnlyKeyedDatabaseObjectCollectionWrapper Members
IReadOnlyKeyedDatabaseObjectCollectionWrapper Interface Methods Properties See Also

The IReadOnlyKeyedDatabaseObjectCollectionWrapper type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection. (Inherited from ICollection<(Of <( IDatabaseObject >)>).)
Clear | Removes all items from the ICollection. (Inherited from ICollection<(Of <( IDatabaseObject >)>).)
Contains | Determines whether the ICollection contains a specific value. (Inherited from ICollection<(Of <( IDatabaseObject >)>).)
CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( IDatabaseObject >)>).)
GetEnumerator | Overloaded.
Remove | Removes the first occurrence of a specific object from the ICollection. (Inherited from ICollection<(Of <( IDatabaseObject >)>).)

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection. (Inherited from ICollection<(Of <( IDatabaseObject >)>).)
IsReadOnly | Gets a value indicating whether the ICollection is read-only. (Inherited from ICollection<(Of <( IDatabaseObject >)>).)
Item | Returns elements by key.

See Also

IReadOnlyKeyedDatabaseObjectCollectionWrapper Interface
RedGate.SQLCompare.Engine Namespace


IReadOnlyKeyedDatabaseObjectCollectionWrapper Properties

[image] [image]

SQL Data Compare API 12.0.40
IReadOnlyKeyedDatabaseObjectCollectionWrapper Properties
IReadOnlyKeyedDatabaseObjectCollectionWrapper Interface See Also

The IReadOnlyKeyedDatabaseObjectCollectionWrapper type exposes the following properties.

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection. (Inherited from ICollection<(Of <( IDatabaseObject >)>).)
IsReadOnly | Gets a value indicating whether the ICollection is read-only. (Inherited from ICollection<(Of <( IDatabaseObject >)>).)
Item | Returns elements by key.

See Also

IReadOnlyKeyedDatabaseObjectCollectionWrapper Interface
RedGate.SQLCompare.Engine Namespace


Item Property

[image]

SQL Data Compare API 12.0.40
IReadOnlyKeyedDatabaseObjectCollectionWrapper..::.Item Property
IReadOnlyKeyedDatabaseObjectCollectionWrapper Interface See Also

Returns elements by key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    key As String _
) As IDatabaseObject
C#
IDatabaseObject this[
    string key
] { get; }
Visual C++
property IDatabaseObject^ default[String^ key] {
    IDatabaseObject^ get (String^ key);
}

Parameters

key
Type: String

See Also

IReadOnlyKeyedDatabaseObjectCollectionWrapper Interface
RedGate.SQLCompare.Engine Namespace


IResultSet Interface

[image]

SQL Data Compare API 12.0.40
IResultSet Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IResultSet
C#
public interface IResultSet
Visual C++
public interface class IResultSet

See Also

IResultSet Members
RedGate.SQLCompare.Engine Namespace


IResultSet Members

[image] [image]

SQL Data Compare API 12.0.40
IResultSet Members
IResultSet Interface Methods Properties See Also

The IResultSet type exposes the following members.

Methods

Name | Description
HasColumn |

Properties

Name | Description
Item |

See Also

IResultSet Interface
RedGate.SQLCompare.Engine Namespace


IResultSet Methods

[image] [image]

SQL Data Compare API 12.0.40
IResultSet Methods
IResultSet Interface See Also

The IResultSet type exposes the following methods.

Methods

Name | Description
HasColumn |

See Also

IResultSet Interface
RedGate.SQLCompare.Engine Namespace


HasColumn Method

[image]

SQL Data Compare API 12.0.40
IResultSet..::.HasColumn Method
IResultSet Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function HasColumn ( _
    name As String _
) As Boolean
C#
bool HasColumn(
    string name
)
Visual C++
bool HasColumn(
    String^ name
)

Parameters

name
Type: String

See Also

IResultSet Interface
RedGate.SQLCompare.Engine Namespace


IResultSet Properties

[image] [image]

SQL Data Compare API 12.0.40
IResultSet Properties
IResultSet Interface See Also

The IResultSet type exposes the following properties.

Properties

Name | Description
Item |

See Also

IResultSet Interface
RedGate.SQLCompare.Engine Namespace


Item Property

[image]

SQL Data Compare API 12.0.40
IResultSet..::.Item Property
IResultSet Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    name As String _
) As Object
C#
Object this[
    string name
] { get; }
Visual C++
property Object^ default[String^ name] {
    Object^ get (String^ name);
}

Parameters

name
Type: String

See Also

IResultSet Interface
RedGate.SQLCompare.Engine Namespace


ISessionSetObject Interface

[image]

SQL Data Compare API 12.0.40
ISessionSetObject Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISessionSetObject _
    Implements IDatabaseObject, ITSqlObject, ICanExistenceCheck
C#
public interface ISessionSetObject : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck
Visual C++
public interface class ISessionSetObject : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck

See Also

ISessionSetObject Members
RedGate.SQLCompare.Engine Namespace


ISessionSetObject Members

[image] [image]

SQL Data Compare API 12.0.40
ISessionSetObject Members
ISessionSetObject Interface Methods Properties See Also

The ISessionSetObject type exposes the following members.

Methods

Name | Description
Equals | Compares two database objects. (Inherited from IDatabaseObject.)
SetSessionOptions | Override the session set options stored in the object.

Properties

Name | Description
AnsiNullsOn | Returns a value indicating if ANSI nulls are on in the object definition.
Database | The database to which the object belongs. (Inherited from IDatabaseObject.)
FullyQualifiedName | (Inherited from ITSqlObject.)
Name | (Inherited from ITSqlObject.)
ObjectType | (Inherited from ITSqlObject.)
Owner | (Inherited from ITSqlObject.)
QualifiedName | (Inherited from ITSqlObject.)
QuotedIdentifierOn | Returns a value indicating if quoted identifier is on in the object definition.

See Also

ISessionSetObject Interface
RedGate.SQLCompare.Engine Namespace


ISessionSetObject Methods

[image] [image]

SQL Data Compare API 12.0.40
ISessionSetObject Methods
ISessionSetObject Interface See Also

The ISessionSetObject type exposes the following methods.

Methods

Name | Description
Equals | Compares two database objects. (Inherited from IDatabaseObject.)
SetSessionOptions | Override the session set options stored in the object.

See Also

ISessionSetObject Interface
RedGate.SQLCompare.Engine Namespace


SetSessionOptions Method

[image]

SQL Data Compare API 12.0.40
ISessionSetObject..::.SetSessionOptions Method
ISessionSetObject Interface See Also

Override the session set options stored in the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub SetSessionOptions ( _
    ansiNulls As Boolean, _
    quotedIdentifier As Boolean _
)
C#
void SetSessionOptions(
    bool ansiNulls,
    bool quotedIdentifier
)
Visual C++
void SetSessionOptions(
    bool ansiNulls,
    bool quotedIdentifier
)

Parameters

ansiNulls
Type: Boolean
quotedIdentifier
Type: Boolean

See Also

ISessionSetObject Interface
RedGate.SQLCompare.Engine Namespace


ISessionSetObject Properties

[image] [image]

SQL Data Compare API 12.0.40
ISessionSetObject Properties
ISessionSetObject Interface See Also

The ISessionSetObject type exposes the following properties.

Properties

Name | Description
AnsiNullsOn | Returns a value indicating if ANSI nulls are on in the object definition.
Database | The database to which the object belongs. (Inherited from IDatabaseObject.)
FullyQualifiedName | (Inherited from ITSqlObject.)
Name | (Inherited from ITSqlObject.)
ObjectType | (Inherited from ITSqlObject.)
Owner | (Inherited from ITSqlObject.)
QualifiedName | (Inherited from ITSqlObject.)
QuotedIdentifierOn | Returns a value indicating if quoted identifier is on in the object definition.

See Also

ISessionSetObject Interface
RedGate.SQLCompare.Engine Namespace


AnsiNullsOn Property

[image]

SQL Data Compare API 12.0.40
ISessionSetObject..::.AnsiNullsOn Property
ISessionSetObject Interface See Also

Returns a value indicating if ANSI nulls are on in the object definition.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property AnsiNullsOn As Boolean
C#
bool AnsiNullsOn { get; }
Visual C++
property bool AnsiNullsOn {
    bool get ();
}

See Also

ISessionSetObject Interface
RedGate.SQLCompare.Engine Namespace


QuotedIdentifierOn Property

[image]

SQL Data Compare API 12.0.40
ISessionSetObject..::.QuotedIdentifierOn Property
ISessionSetObject Interface See Also

Returns a value indicating if quoted identifier is on in the object definition.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property QuotedIdentifierOn As Boolean
C#
bool QuotedIdentifierOn { get; }
Visual C++
property bool QuotedIdentifierOn {
    bool get ();
}

See Also

ISessionSetObject Interface
RedGate.SQLCompare.Engine Namespace


IShouldWriteStorageSettings Interface

[image]

SQL Data Compare API 12.0.40
IShouldWriteStorageSettings Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IShouldWriteStorageSettings
C#
public interface IShouldWriteStorageSettings
Visual C++
public interface class IShouldWriteStorageSettings

See Also

IShouldWriteStorageSettings Members
RedGate.SQLCompare.Engine Namespace


IShouldWriteStorageSettings Members

[image] [image]

SQL Data Compare API 12.0.40
IShouldWriteStorageSettings Members
IShouldWriteStorageSettings Interface Properties See Also

The IShouldWriteStorageSettings type exposes the following members.

Properties

Name | Description
ShouldWriteFileGroupOrPartitionScheme | Whether (disregarding any options) the filegroup should be written out

See Also

IShouldWriteStorageSettings Interface
RedGate.SQLCompare.Engine Namespace


IShouldWriteStorageSettings Properties

[image] [image]

SQL Data Compare API 12.0.40
IShouldWriteStorageSettings Properties
IShouldWriteStorageSettings Interface See Also

The IShouldWriteStorageSettings type exposes the following properties.

Properties

Name | Description
ShouldWriteFileGroupOrPartitionScheme | Whether (disregarding any options) the filegroup should be written out

See Also

IShouldWriteStorageSettings Interface
RedGate.SQLCompare.Engine Namespace


ShouldWriteFileGroupOrPartitionScheme Property

[image]

SQL Data Compare API 12.0.40
IShouldWriteStorageSettings..::.ShouldWriteFileGroupOrPartitionScheme Property
IShouldWriteStorageSettings Interface See Also

Whether (disregarding any options) the filegroup should be written out

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ShouldWriteFileGroupOrPartitionScheme As Boolean
C#
bool ShouldWriteFileGroupOrPartitionScheme { get; }
Visual C++
property bool ShouldWriteFileGroupOrPartitionScheme {
    bool get ();
}

See Also

IShouldWriteStorageSettings Interface
RedGate.SQLCompare.Engine Namespace


ISometimesInlinable Interface

[image]

SQL Data Compare API 12.0.40
ISometimesInlinable Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISometimesInlinable _
    Implements IHasScriptSource
C#
public interface ISometimesInlinable : IHasScriptSource
Visual C++
public interface class ISometimesInlinable : IHasScriptSource

See Also

ISometimesInlinable Members
RedGate.SQLCompare.Engine Namespace


ISometimesInlinable Members

[image] [image]

SQL Data Compare API 12.0.40
ISometimesInlinable Members
ISometimesInlinable Interface Methods Properties See Also

The ISometimesInlinable type exposes the following members.

Methods

Name | Description
IsInlined |

Properties

Name | Description
ScriptSource | (Inherited from IHasScriptSource.)

See Also

ISometimesInlinable Interface
RedGate.SQLCompare.Engine Namespace


ISometimesInlinable Methods

[image] [image]

SQL Data Compare API 12.0.40
ISometimesInlinable Methods
ISometimesInlinable Interface See Also

The ISometimesInlinable type exposes the following methods.

Methods

Name | Description
IsInlined |

See Also

ISometimesInlinable Interface
RedGate.SQLCompare.Engine Namespace


IsInlined Method

[image]

SQL Data Compare API 12.0.40
ISometimesInlinable..::.IsInlined Method
ISometimesInlinable Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function IsInlined ( _
    inlineIndexesWherePossible As Boolean _
) As Boolean
C#
bool IsInlined(
    bool inlineIndexesWherePossible
)
Visual C++
bool IsInlined(
    bool inlineIndexesWherePossible
)

Parameters

inlineIndexesWherePossible
Type: Boolean

See Also

ISometimesInlinable Interface
RedGate.SQLCompare.Engine Namespace


ITextObject Interface

[image]

SQL Data Compare API 12.0.40
ITextObject Interface
Members See Also

A database object that has its definition stored in the database as text.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITextObject _
    Implements IDatabaseObject, ITSqlObject, ICanExistenceCheck
C#
public interface ITextObject : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck
Visual C++
public interface class ITextObject : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck

See Also

ITextObject Members
RedGate.SQLCompare.Engine Namespace


ITextObject Members

[image] [image]

SQL Data Compare API 12.0.40
ITextObject Members
ITextObject Interface Methods Properties See Also

The ITextObject type exposes the following members.

Methods

Name | Description
Equals | Compares two database objects. (Inherited from IDatabaseObject.)

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from IDatabaseObject.)
FullyQualifiedName | (Inherited from ITSqlObject.)
Name | (Inherited from ITSqlObject.)
ObjectType | (Inherited from ITSqlObject.)
Owner | (Inherited from ITSqlObject.)
QualifiedName | (Inherited from ITSqlObject.)
Text | Returns the object text.

See Also

ITextObject Interface
RedGate.SQLCompare.Engine Namespace


ITextObject Properties

[image] [image]

SQL Data Compare API 12.0.40
ITextObject Properties
ITextObject Interface See Also

The ITextObject type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from IDatabaseObject.)
FullyQualifiedName | (Inherited from ITSqlObject.)
Name | (Inherited from ITSqlObject.)
ObjectType | (Inherited from ITSqlObject.)
Owner | (Inherited from ITSqlObject.)
QualifiedName | (Inherited from ITSqlObject.)
Text | Returns the object text.

See Also

ITextObject Interface
RedGate.SQLCompare.Engine Namespace


Text Property

[image]

SQL Data Compare API 12.0.40
ITextObject..::.Text Property
ITextObject Interface See Also

Returns the object text.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Text As String
C#
string Text { get; }
Visual C++
property String^ Text {
    String^ get ();
}

See Also

ITextObject Interface
RedGate.SQLCompare.Engine Namespace


IVersionedDatabase Interface

[image]

SQL Data Compare API 12.0.40
IVersionedDatabase Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IVersionedDatabase
C#
public interface IVersionedDatabase
Visual C++
public interface class IVersionedDatabase

See Also

IVersionedDatabase Members
RedGate.SQLCompare.Engine Namespace


IVersionedDatabase Members

[image] [image]

SQL Data Compare API 12.0.40
IVersionedDatabase Members
IVersionedDatabase Interface Properties See Also

The IVersionedDatabase type exposes the following members.

Properties

Name | Description
MajorVersion | The major version of the SQL Server for the database. This reflects the compatibility mode of the database.
ServerMajorVersion | The major server version of the SQL Server for the database. This does not change if the database is running in compatibility mode.
SqlServerVersionInfo | Information about the version of SQL Server this database exists on, including version number, compatibility level, internal version and whether or not it's an Azure database.
SupportedFeatures |

See Also

IVersionedDatabase Interface
RedGate.SQLCompare.Engine Namespace


IVersionedDatabase Properties

[image] [image]

SQL Data Compare API 12.0.40
IVersionedDatabase Properties
IVersionedDatabase Interface See Also

The IVersionedDatabase type exposes the following properties.

Properties

Name | Description
MajorVersion | The major version of the SQL Server for the database. This reflects the compatibility mode of the database.
ServerMajorVersion | The major server version of the SQL Server for the database. This does not change if the database is running in compatibility mode.
SqlServerVersionInfo | Information about the version of SQL Server this database exists on, including version number, compatibility level, internal version and whether or not it's an Azure database.
SupportedFeatures |

See Also

IVersionedDatabase Interface
RedGate.SQLCompare.Engine Namespace


MajorVersion Property

[image]

SQL Data Compare API 12.0.40
IVersionedDatabase..::.MajorVersion Property
IVersionedDatabase Interface See Also

The major version of the SQL Server for the database. This reflects the compatibility mode of the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property MajorVersion As SQLVersion
C#
SQLVersion MajorVersion { get; }
Visual C++
property SQLVersion MajorVersion {
    SQLVersion get ();
}

See Also

IVersionedDatabase Interface
RedGate.SQLCompare.Engine Namespace


ServerMajorVersion Property

[image]

SQL Data Compare API 12.0.40
IVersionedDatabase..::.ServerMajorVersion Property
IVersionedDatabase Interface See Also

The major server version of the SQL Server for the database. This does not change if the database is running in compatibility mode.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ServerMajorVersion As SQLVersion
C#
SQLVersion ServerMajorVersion { get; }
Visual C++
property SQLVersion ServerMajorVersion {
    SQLVersion get ();
}

See Also

IVersionedDatabase Interface
RedGate.SQLCompare.Engine Namespace


SqlServerVersionInfo Property

[image]

SQL Data Compare API 12.0.40
IVersionedDatabase..::.SqlServerVersionInfo Property
IVersionedDatabase Interface See Also

Information about the version of SQL Server this database exists on, including version number, compatibility level, internal version and whether or not it's an Azure database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SqlServerVersionInfo As SqlVersion
C#
SqlVersion SqlServerVersionInfo { get; }
Visual C++
property SqlVersion^ SqlServerVersionInfo {
    SqlVersion^ get ();
}

See Also

IVersionedDatabase Interface
RedGate.SQLCompare.Engine Namespace


SupportedFeatures Property

[image]

SQL Data Compare API 12.0.40
IVersionedDatabase..::.SupportedFeatures Property
IVersionedDatabase Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportedFeatures As IFeatureChecker
C#
IFeatureChecker SupportedFeatures { get; }
Visual C++
property IFeatureChecker^ SupportedFeatures {
    IFeatureChecker^ get ();
}

See Also

IVersionedDatabase Interface
RedGate.SQLCompare.Engine Namespace


IWork Interface

[image]

SQL Data Compare API 12.0.40
IWork Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IWork _
    Implements ICancellable
C#
public interface IWork : ICancellable
Visual C++
public interface class IWork : ICancellable

See Also

IWork Members
RedGate.SQLCompare.Engine Namespace


IWork Members

[image] [image]

SQL Data Compare API 12.0.40
IWork Members
IWork Interface Methods Properties See Also

The IWork type exposes the following members.

Methods

Name | Description
BuildFromDifferences | Overloaded.
CancelOperation | Cancels the current running operation. This will throw an instance of OperationCancelledException at the currently executing location on the executing thread (Inherited from ICancellable.)
GenerateFolderSynchronizationActions | This is the second stage of the main work, in which the scripts folder rewrite is generated for the synchronization. This can only be used internally.
GenerateSql | This is the second stage of the main work, in which the SQL is generated for the synchronization. This can only be used internally.
ProcessDifferences | This is the first stage of the main work, in which the necessary work is determined. This can only be used internally!
ScriptObject | Returns the script necessary to create a SQL object.
SetImplicitlySelectedDifferences | For internal use only.

Properties

Name | Description
BackupOptions |
CanRollBackOnFailure | True if the transaction can be completely rolled back on failure.
Dependencies | The dependencies selected for the current Work. Populated during ProcessDifferences(Differences, Difference, Options, Boolean). Dictionary is of <dependent object, objects depending on it>.
DependenciesHaveBeenCalculated | Indicates that the Dependencies property has been fully populated.
ExecutionBlock | A block of SQL batches containing SQL script for synchronization.
Messages | Informational messages about the work to be done.
ScriptSynchronizationActions | The script synchronization actions that will be performed during the synchronization.
StaticDataInsertPosition | For internal use only.
Status | Gets and sets a delegate that can be used to notify of message or percentage changes (Inherited from ICancellable.)
TransactionIsolationLevel |
Warnings | Warnings about the work to be done.

See Also

IWork Interface
RedGate.SQLCompare.Engine Namespace


IWork Methods

[image] [image]

SQL Data Compare API 12.0.40
IWork Methods
IWork Interface See Also

The IWork type exposes the following methods.

Methods

Name | Description
BuildFromDifferences | Overloaded.
CancelOperation | Cancels the current running operation. This will throw an instance of OperationCancelledException at the currently executing location on the executing thread (Inherited from ICancellable.)
GenerateFolderSynchronizationActions | This is the second stage of the main work, in which the scripts folder rewrite is generated for the synchronization. This can only be used internally.
GenerateSql | This is the second stage of the main work, in which the SQL is generated for the synchronization. This can only be used internally.
ProcessDifferences | This is the first stage of the main work, in which the necessary work is determined. This can only be used internally!
ScriptObject | Returns the script necessary to create a SQL object.
SetImplicitlySelectedDifferences | For internal use only.

See Also

IWork Interface
RedGate.SQLCompare.Engine Namespace


BuildFromDifferences Method

[image] [image]

SQL Data Compare API 12.0.40
IWork..::.BuildFromDifferences Method
IWork Interface See Also

Overload List

Name | Description
BuildFromDifferences(Differences, Options, Boolean) | Build the work object from a set of differences. Use this method when synchronizing to a live database.
BuildFromDifferences(Differences, Difference, Options, Boolean) | Builds the work object from an individual difference. It sets the ExecutionBlock property to include the script for synchronization. Use this method when synchronizing to a live database.
BuildFromDifferences(Differences, Options, Boolean, ScriptDatabaseInformation) | Build the work object from a set of differences. It sets the ScriptSynchronizationActions property to include the synchronization actions for modifying a scripts folder. Use this method when synchronizing to a scripts folder.
BuildFromDifferences(Differences, Difference, Options, Boolean, ScriptDatabaseInformation, IFileNameGenerator) | Builds the work object from an individual difference. It sets the ScriptSynchronizationActions property to include the synchronization actions for modifying a scripts folder. Use this method when synchronizing to a scripts folder.

See Also

IWork Interface
IWork Members
RedGate.SQLCompare.Engine Namespace


BuildFromDifferences Method (Differences, Options, )

[image]

SQL Data Compare API 12.0.40
IWork..::.BuildFromDifferences Method (Differences, Options, )
IWork Interface See Also

Build the work object from a set of differences. Use this method when synchronizing to a live database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub BuildFromDifferences ( _
    differences As Differences, _
    options As Options, _
    runOnTwo As Boolean _
)
C#
void BuildFromDifferences(
    Differences differences,
    Options options,
    bool runOnTwo
)
Visual C++
void BuildFromDifferences(
    Differences^ differences,
    Options options,
    bool runOnTwo
)

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
The differences to use.
options
Type: RedGate.SQLCompare.Engine..::.Options
The synchronization options.
runOnTwo
Type: Boolean
True if the SQL script is to be run on the second database.

See Also

IWork Interface
BuildFromDifferences Overload
RedGate.SQLCompare.Engine Namespace


BuildFromDifferences Method (Differences, Difference, Options, )

[image]

SQL Data Compare API 12.0.40
IWork..::.BuildFromDifferences Method (Differences, Difference, Options, )
IWork Interface See Also

Builds the work object from an individual difference. It sets the ExecutionBlock property to include the script for synchronization. Use this method when synchronizing to a live database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub BuildFromDifferences ( _
    differences As Differences, _
    onlyDifferenceToInclude As Difference, _
    options As Options, _
    runOnTwo As Boolean _
)
C#
void BuildFromDifferences(
    Differences differences,
    Difference onlyDifferenceToInclude,
    Options options,
    bool runOnTwo
)
Visual C++
void BuildFromDifferences(
    Differences^ differences,
    Difference^ onlyDifferenceToInclude,
    Options options,
    bool runOnTwo
)

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
The differences to use.
onlyDifferenceToInclude
Type: RedGate.SQLCompare.Engine..::.Difference
The single difference to include.
options
Type: RedGate.SQLCompare.Engine..::.Options
The synchronization options.
runOnTwo
Type: Boolean
True if the SQL script is to be run on the second database.

See Also

IWork Interface
BuildFromDifferences Overload
RedGate.SQLCompare.Engine Namespace


BuildFromDifferences Method (Differences, Options, , ScriptDatabaseInformation)

[image]

SQL Data Compare API 12.0.40
IWork..::.BuildFromDifferences Method (Differences, Options, , ScriptDatabaseInformation)
IWork Interface See Also

Build the work object from a set of differences. It sets the ScriptSynchronizationActions property to include the synchronization actions for modifying a scripts folder. Use this method when synchronizing to a scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub BuildFromDifferences ( _
    differences As Differences, _
    options As Options, _
    runOnTwo As Boolean, _
    dbInfo As ScriptDatabaseInformation _
)
C#
void BuildFromDifferences(
    Differences differences,
    Options options,
    bool runOnTwo,
    ScriptDatabaseInformation dbInfo
)
Visual C++
void BuildFromDifferences(
    Differences^ differences,
    Options options,
    bool runOnTwo,
    ScriptDatabaseInformation^ dbInfo
)

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
The differences to use.
options
Type: RedGate.SQLCompare.Engine..::.Options
The synchronization options.
runOnTwo
Type: Boolean
True if the SQL script is to be run on the second database.
dbInfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
Options that sepcify how files are to be created when synchronizing to a scripts folder.

See Also

IWork Interface
BuildFromDifferences Overload
RedGate.SQLCompare.Engine Namespace


BuildFromDifferences Method (Differences, Difference, Options, , ScriptDatabaseInformation, IFileNameGenerator)

[image]

SQL Data Compare API 12.0.40
IWork..::.BuildFromDifferences Method (Differences, Difference, Options, , ScriptDatabaseInformation, IFileNameGenerator)
IWork Interface See Also

Builds the work object from an individual difference. It sets the ScriptSynchronizationActions property to include the synchronization actions for modifying a scripts folder. Use this method when synchronizing to a scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub BuildFromDifferences ( _
    differences As Differences, _
    onlyDifferenceToInclude As Difference, _
    options As Options, _
    runOnTwo As Boolean, _
    dbInfo As ScriptDatabaseInformation, _
    generator As IFileNameGenerator _
)
C#
void BuildFromDifferences(
    Differences differences,
    Difference onlyDifferenceToInclude,
    Options options,
    bool runOnTwo,
    ScriptDatabaseInformation dbInfo,
    IFileNameGenerator generator
)
Visual C++
void BuildFromDifferences(
    Differences^ differences,
    Difference^ onlyDifferenceToInclude,
    Options options,
    bool runOnTwo,
    ScriptDatabaseInformation^ dbInfo,
    IFileNameGenerator^ generator
)

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
The differences to use.
onlyDifferenceToInclude
Type: RedGate.SQLCompare.Engine..::.Difference
The single difference to include.
options
Type: RedGate.SQLCompare.Engine..::.Options
The synchronization options.
runOnTwo
Type: Boolean
True if the SQL script is to be run on the second database.
dbInfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
Options that sepcify how files are to be created when synchronizing to a scripts folder.
generator
Type: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser..::.IFileNameGenerator
The object responsible for generating the names of the newly created objects

See Also

IWork Interface
BuildFromDifferences Overload
RedGate.SQLCompare.Engine Namespace


GenerateFolderSynchronizationActions Method

[image]

SQL Data Compare API 12.0.40
IWork..::.GenerateFolderSynchronizationActions Method
IWork Interface See Also

This is the second stage of the main work, in which the scripts folder rewrite is generated for the synchronization. This can only be used internally.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub GenerateFolderSynchronizationActions ( _
    differences As Differences, _
    onlyDifferenceToInclude As Difference, _
    options As Options, _
    runOnTwo As Boolean, _
    dbInfo As ScriptDatabaseInformation, _
    generator As IFileNameGenerator _
)
C#
void GenerateFolderSynchronizationActions(
    Differences differences,
    Difference onlyDifferenceToInclude,
    Options options,
    bool runOnTwo,
    ScriptDatabaseInformation dbInfo,
    IFileNameGenerator generator
)
Visual C++
void GenerateFolderSynchronizationActions(
    Differences^ differences,
    Difference^ onlyDifferenceToInclude,
    Options options,
    bool runOnTwo,
    ScriptDatabaseInformation^ dbInfo,
    IFileNameGenerator^ generator
)

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
The differences to use.
onlyDifferenceToInclude
Type: RedGate.SQLCompare.Engine..::.Difference
The single difference to include.
options
Type: RedGate.SQLCompare.Engine..::.Options
The synchronization options.
runOnTwo
Type: Boolean
True if the SQL script is to be run on the second database.
dbInfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
Options to control how the script files are saved.
generator
Type: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser..::.IFileNameGenerator
This object is repsonsible for generating the file name for any newly created objects

See Also

IWork Interface
RedGate.SQLCompare.Engine Namespace


GenerateSql Method

[image]

SQL Data Compare API 12.0.40
IWork..::.GenerateSql Method
IWork Interface See Also

This is the second stage of the main work, in which the SQL is generated for the synchronization. This can only be used internally.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub GenerateSql ( _
    differences As Differences, _
    onlyDifferenceToInclude As Difference, _
    options As Options, _
    runOnTwo As Boolean _
)
C#
void GenerateSql(
    Differences differences,
    Difference onlyDifferenceToInclude,
    Options options,
    bool runOnTwo
)
Visual C++
void GenerateSql(
    Differences^ differences,
    Difference^ onlyDifferenceToInclude,
    Options options,
    bool runOnTwo
)

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
The differences to use.
onlyDifferenceToInclude
Type: RedGate.SQLCompare.Engine..::.Difference
The single difference to include.
options
Type: RedGate.SQLCompare.Engine..::.Options
The synchronization options.
runOnTwo
Type: Boolean
True if the SQL script is to be run on the second database.

See Also

IWork Interface
RedGate.SQLCompare.Engine Namespace


ProcessDifferences Method

[image]

SQL Data Compare API 12.0.40
IWork..::.ProcessDifferences Method
IWork Interface See Also

This is the first stage of the main work, in which the necessary work is determined. This can only be used internally!

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub ProcessDifferences ( _
    differences As Differences, _
    onlyDifferenceToInclude As Difference, _
    options As Options, _
    runOnTwo As Boolean _
)
C#
void ProcessDifferences(
    Differences differences,
    Difference onlyDifferenceToInclude,
    Options options,
    bool runOnTwo
)
Visual C++
void ProcessDifferences(
    Differences^ differences,
    Difference^ onlyDifferenceToInclude,
    Options options,
    bool runOnTwo
)

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
The differences to use.
onlyDifferenceToInclude
Type: RedGate.SQLCompare.Engine..::.Difference
The single difference to include.
options
Type: RedGate.SQLCompare.Engine..::.Options
The synchronization options.
runOnTwo
Type: Boolean
True if the SQL script is to be run on the second database.

See Also

IWork Interface
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
IWork..::.ScriptObject Method
IWork Interface Example See Also

Returns the script necessary to create a SQL object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function ScriptObject ( _
    objectToScript As IDatabaseObject, _
    options As Options _
) As Regions
C#
Regions ScriptObject(
    IDatabaseObject objectToScript,
    Options options
)
Visual C++
Regions^ ScriptObject(
    IDatabaseObject^ objectToScript,
    Options options
)

Parameters

objectToScript
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
options
Type: RedGate.SQLCompare.Engine..::.Options

Return Value

A Regions collection containing batches of SQL script.

Remarks

This creates SQL code used to create an object such as a table, view, or stored procedure.

Examples

C# Copy Code
            Database db=new Database();

            db.Register(new ConnectionProperties(".", "WidgetStaging"), Options.Default);

            Work work=new Work();

            //get the script for an object
            Regions regions=work.ScriptObject(db.Tables[0], Options.Default);

            Console.WriteLine("SQL script:\n{0}", regions.ToString());

            db.Dispose();
Visual Basic Copy Code
            Dim db As New Database()

            db.Register(New ConnectionProperties(".", "WidgetStaging"), Options.Default)

            Dim work As New Work()

            'get the script for an object

            Dim regions As Regions = work.ScriptObject(db.Tables(0), Options.Default)

            Console.WriteLine("SQL script:")
            Console.WriteLine("{0}", regions.ToString())

            'dispose
            db.Dispose()

See Also

IWork Interface
RedGate.SQLCompare.Engine Namespace


SetImplicitlySelectedDifferences Method

[image]

SQL Data Compare API 12.0.40
IWork..::.SetImplicitlySelectedDifferences Method
IWork Interface See Also

For internal use only.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub SetImplicitlySelectedDifferences ( _
    differences As Differences _
)
C#
void SetImplicitlySelectedDifferences(
    Differences differences
)
Visual C++
void SetImplicitlySelectedDifferences(
    Differences^ differences
)

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
Internal use only.

See Also

IWork Interface
RedGate.SQLCompare.Engine Namespace


IWork Properties

[image] [image]

SQL Data Compare API 12.0.40
IWork Properties
IWork Interface See Also

The IWork type exposes the following properties.

Properties

Name | Description
BackupOptions |
CanRollBackOnFailure | True if the transaction can be completely rolled back on failure.
Dependencies | The dependencies selected for the current Work. Populated during ProcessDifferences(Differences, Difference, Options, Boolean). Dictionary is of <dependent object, objects depending on it>.
DependenciesHaveBeenCalculated | Indicates that the Dependencies property has been fully populated.
ExecutionBlock | A block of SQL batches containing SQL script for synchronization.
Messages | Informational messages about the work to be done.
ScriptSynchronizationActions | The script synchronization actions that will be performed during the synchronization.
StaticDataInsertPosition | For internal use only.
Status | Gets and sets a delegate that can be used to notify of message or percentage changes (Inherited from ICancellable.)
TransactionIsolationLevel |
Warnings | Warnings about the work to be done.

See Also

IWork Interface
RedGate.SQLCompare.Engine Namespace


BackupOptions Property

[image]

SQL Data Compare API 12.0.40
IWork..::.BackupOptions Property
IWork Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property BackupOptions As BackupOptions
C#
BackupOptions BackupOptions { get; set; }
Visual C++
property BackupOptions^ BackupOptions {
    BackupOptions^ get ();
    void set (BackupOptions^ value);
}

See Also

IWork Interface
RedGate.SQLCompare.Engine Namespace


CanRollBackOnFailure Property

[image]

SQL Data Compare API 12.0.40
IWork..::.CanRollBackOnFailure Property
IWork Interface See Also

True if the transaction can be completely rolled back on failure.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CanRollBackOnFailure As Boolean
C#
bool CanRollBackOnFailure { get; }
Visual C++
property bool CanRollBackOnFailure {
    bool get ();
}

Remarks

Some synchronization commands, such as full-text operations, cannot be included within transactions. If a script fails, these operations cannot be rolled back.

See Also

IWork Interface
RedGate.SQLCompare.Engine Namespace


Dependencies Property

[image]

SQL Data Compare API 12.0.40
IWork..::.Dependencies Property
IWork Interface See Also

The dependencies selected for the current Work. Populated during ProcessDifferences(Differences, Difference, Options, Boolean). Dictionary is of <dependent object, objects depending on it>.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Dependencies As IDictionary(Of Difference, Set(Of Difference))
C#
IDictionary<Difference, Set<Difference>> Dependencies { get; }
Visual C++
property IDictionary<Difference^, Set<Difference^>^>^ Dependencies {
    IDictionary<Difference^, Set<Difference^>^>^ get ();
}

See Also

IWork Interface
RedGate.SQLCompare.Engine Namespace


DependenciesHaveBeenCalculated Property

[image]

SQL Data Compare API 12.0.40
IWork..::.DependenciesHaveBeenCalculated Property
IWork Interface See Also

Indicates that the Dependencies property has been fully populated.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DependenciesHaveBeenCalculated As Boolean
C#
bool DependenciesHaveBeenCalculated { get; }
Visual C++
property bool DependenciesHaveBeenCalculated {
    bool get ();
}

See Also

IWork Interface
RedGate.SQLCompare.Engine Namespace


ExecutionBlock Property

[image]

SQL Data Compare API 12.0.40
IWork..::.ExecutionBlock Property
IWork Interface See Also

A block of SQL batches containing SQL script for synchronization.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ExecutionBlock As IExecutionBlock
C#
IExecutionBlock ExecutionBlock { get; }
Visual C++
property IExecutionBlock^ ExecutionBlock {
    IExecutionBlock^ get ();
}

See Also

IWork Interface
RedGate.SQLCompare.Engine Namespace


Messages Property

[image]

SQL Data Compare API 12.0.40
IWork..::.Messages Property
IWork Interface See Also

Informational messages about the work to be done.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Messages As IEnumerable(Of IDeploymentMessage)
C#
IEnumerable<IDeploymentMessage> Messages { get; }
Visual C++
property IEnumerable<IDeploymentMessage^>^ Messages {
    IEnumerable<IDeploymentMessage^>^ get ();
}

See Also

IWork Interface
RedGate.SQLCompare.Engine Namespace


ScriptSynchronizationActions Property

[image]

SQL Data Compare API 12.0.40
IWork..::.ScriptSynchronizationActions Property
IWork Interface See Also

The script synchronization actions that will be performed during the synchronization.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property ScriptSynchronizationActions As ScriptSynchronizationActions
C#
ScriptSynchronizationActions ScriptSynchronizationActions { get; set; }
Visual C++
property ScriptSynchronizationActions^ ScriptSynchronizationActions {
    ScriptSynchronizationActions^ get ();
    void set (ScriptSynchronizationActions^ value);
}

See Also

IWork Interface
RedGate.SQLCompare.Engine Namespace


StaticDataInsertPosition Property

[image]

SQL Data Compare API 12.0.40
IWork..::.StaticDataInsertPosition Property
IWork Interface See Also

For internal use only.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property StaticDataInsertPosition As Long
C#
long StaticDataInsertPosition { get; }
Visual C++
property long long StaticDataInsertPosition {
    long long get ();
}

See Also

IWork Interface
RedGate.SQLCompare.Engine Namespace


TransactionIsolationLevel Property

[image]

SQL Data Compare API 12.0.40
IWork..::.TransactionIsolationLevel Property
IWork Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property TransactionIsolationLevel As String
C#
string TransactionIsolationLevel { get; set; }
Visual C++
property String^ TransactionIsolationLevel {
    String^ get ();
    void set (String^ value);
}

See Also

IWork Interface
RedGate.SQLCompare.Engine Namespace


Warnings Property

[image]

SQL Data Compare API 12.0.40
IWork..::.Warnings Property
IWork Interface See Also

Warnings about the work to be done.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Warnings As IEnumerable(Of IDeploymentMessage)
C#
IEnumerable<IDeploymentMessage> Warnings { get; }
Visual C++
property IEnumerable<IDeploymentMessage^>^ Warnings {
    IEnumerable<IDeploymentMessage^>^ get ();
}

See Also

IWork Interface
RedGate.SQLCompare.Engine Namespace


IWorkStage Interface

[image]

SQL Data Compare API 12.0.40
IWorkStage Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IWorkStage _
    Implements ICancellable
C#
public interface IWorkStage : ICancellable
Visual C++
public interface class IWorkStage : ICancellable

See Also

IWorkStage Members
RedGate.SQLCompare.Engine Namespace


IWorkStage Members

[image] [image]

SQL Data Compare API 12.0.40
IWorkStage Members
IWorkStage Interface Methods Properties See Also

The IWorkStage type exposes the following members.

Methods

Name | Description
CancelOperation | Cancels the current running operation. This will throw an instance of OperationCancelledException at the currently executing location on the executing thread (Inherited from ICancellable.)
ScriptObject |

Properties

Name | Description
Status | Gets and sets a delegate that can be used to notify of message or percentage changes (Inherited from ICancellable.)
TransactionIsolationLevel |

See Also

IWorkStage Interface
RedGate.SQLCompare.Engine Namespace


IWorkStage Methods

[image] [image]

SQL Data Compare API 12.0.40
IWorkStage Methods
IWorkStage Interface See Also

The IWorkStage type exposes the following methods.

Methods

Name | Description
CancelOperation | Cancels the current running operation. This will throw an instance of OperationCancelledException at the currently executing location on the executing thread (Inherited from ICancellable.)
ScriptObject |

See Also

IWorkStage Interface
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
IWorkStage..::.ScriptObject Method
IWorkStage Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function ScriptObject ( _
    objectToScript As ITSqlObject, _
    options As Options _
) As Regions
C#
Regions ScriptObject(
    ITSqlObject objectToScript,
    Options options
)
Visual C++
Regions^ ScriptObject(
    ITSqlObject^ objectToScript,
    Options options
)

Parameters

objectToScript
Type: ITSqlObject
options
Type: RedGate.SQLCompare.Engine..::.Options

Return Value

The regions for a ScriptableDatabaseObject suitable for showing in the diff viewer

See Also

IWorkStage Interface
RedGate.SQLCompare.Engine Namespace


IWorkStage Properties

[image] [image]

SQL Data Compare API 12.0.40
IWorkStage Properties
IWorkStage Interface See Also

The IWorkStage type exposes the following properties.

Properties

Name | Description
Status | Gets and sets a delegate that can be used to notify of message or percentage changes (Inherited from ICancellable.)
TransactionIsolationLevel |

See Also

IWorkStage Interface
RedGate.SQLCompare.Engine Namespace


TransactionIsolationLevel Property

[image]

SQL Data Compare API 12.0.40
IWorkStage..::.TransactionIsolationLevel Property
IWorkStage Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property TransactionIsolationLevel As String
C#
string TransactionIsolationLevel { get; set; }
Visual C++
property String^ TransactionIsolationLevel {
    String^ get ();
    void set (String^ value);
}

See Also

IWorkStage Interface
RedGate.SQLCompare.Engine Namespace


KeyedCollection(T) Generic Class

[image]

SQL Data Compare API 12.0.40
KeyedCollection<(Of <(T>)>) Generic Class
Members See Also

A collection that can store items by key as well as by list index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class KeyedCollection(Of T) _
    Implements IEnumerable(Of T), IEnumerable, IKeyedCollection(Of T)
C#
public abstract class KeyedCollection<T> : IEnumerable<T>,
    IEnumerable, IKeyedCollection<T>
Visual C++
generic<typename T>
public ref class KeyedCollection abstract : IEnumerable<T>,
    IEnumerable, IKeyedCollection<T>

Type Parameters

T
The type stored in the KeyedCollection<(Of <(T>)>).

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection<(Of <(T>)>)
RedGate.SQLCompare.Engine..::.DatabaseObjectCollection<(Of <(T>)>)
RedGate.SQLCompare.Engine..::.IndexFields
RedGate.SQLCompare.Engine..::.TableFields
RedGate.SQLCompare.Engine..::.FieldBindings
RedGate.SQLCompare.Engine..::.Members
RedGate.SQLCompare.Engine..::.SchemaBindings
RedGate.SQLCompare.Engine..::.SerializableCollection<(Of <(T>)>)
RedGate.SQLCompare.Engine..::.UDTBindings
RedGate.SQLCompare.Engine..::.ViewsAndTables

See Also

KeyedCollection<(Of <(T>)>) Members
RedGate.SQLCompare.Engine Namespace


KeyedCollection(T) Members

[image] [image]

SQL Data Compare API 12.0.40
KeyedCollection<(Of <(T>)>) Members
KeyedCollection<(Of <(T>)>) Class Methods Fields Properties Explicit Interface Implementations See Also

The KeyedCollection<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Add |
Clear |
ContainsKey |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze |
GetEnumerator | Returns the list enumerator.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary.

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively.
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>).
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator |

See Also

KeyedCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


KeyedCollection(T) Fields

[image] [image]

SQL Data Compare API 12.0.40
KeyedCollection<(Of <(T>)>) Fields
KeyedCollection<(Of <(T>)>) Class See Also

The KeyedCollection<(Of <(T>)>) type exposes the following fields.

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary.

See Also

KeyedCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


m_KeyDictionary Field

[image]

SQL Data Compare API 12.0.40
KeyedCollection<(Of <(T>)>)..::.m_KeyDictionary Field
KeyedCollection<(Of <(T>)>) Class See Also

Internal keyed dictionary.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_KeyDictionary As Dictionary(Of String, T)
C#
protected Dictionary<string, T> m_KeyDictionary
Visual C++
protected:
Dictionary<String^, T>^ m_KeyDictionary

See Also

KeyedCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


KeyedCollection(T) Methods

[image] [image]

SQL Data Compare API 12.0.40
KeyedCollection<(Of <(T>)>) Methods
KeyedCollection<(Of <(T>)>) Class See Also

The KeyedCollection<(Of <(T>)>) type exposes the following methods.

Methods

Name | Description
Add |
Clear |
ContainsKey |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze |
GetEnumerator | Returns the list enumerator.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator |

See Also

KeyedCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


Add Method

[image]

SQL Data Compare API 12.0.40
KeyedCollection<(Of <(T>)>)..::.Add Method
KeyedCollection<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Add ( _
    value As T _
)
C#
public virtual void Add(
    T value
)
Visual C++
public:
virtual void Add(
    T value
)

Parameters

value
Type: T

Implements

IKeyedCollectionAdd(UTP)

See Also

KeyedCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


Clear Method

[image]

SQL Data Compare API 12.0.40
KeyedCollection<(Of <(T>)>)..::.Clear Method
KeyedCollection<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear
C#
public void Clear()
Visual C++
public:
virtual void Clear() sealed

Implements

IKeyedCollectionClear()()()

See Also

KeyedCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


ContainsKey Method

[image]

SQL Data Compare API 12.0.40
KeyedCollection<(Of <(T>)>)..::.ContainsKey Method
KeyedCollection<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function ContainsKey ( _
    key As String _
) As Boolean
C#
public bool ContainsKey(
    string key
)
Visual C++
public:
virtual bool ContainsKey(
    String^ key
) sealed

Parameters

key
Type: String

Implements

IKeyedCollectionContainsKey(String)

See Also

KeyedCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


Freeze Method

[image]

SQL Data Compare API 12.0.40
KeyedCollection<(Of <(T>)>)..::.Freeze Method
KeyedCollection<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Freeze
C#
public void Freeze()
Visual C++
public:
virtual void Freeze() sealed

See Also

KeyedCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


GetEnumerator Method

[image]

SQL Data Compare API 12.0.40
KeyedCollection<(Of <(T>)>)..::.GetEnumerator Method
KeyedCollection<(Of <(T>)>) Class See Also

Returns the list enumerator.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of T)
C#
public IEnumerator<T> GetEnumerator()
Visual C++
public:
virtual IEnumerator<T>^ GetEnumerator() sealed

Return Value

An enumerator.

Implements

IEnumerableGetEnumerator()()()

See Also

KeyedCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


. Method

[image]

SQL Data Compare API 12.0.40
KeyedCollection<(Of <(T>)>)..::...::. Method
KeyedCollection<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
C#
IEnumerator IEnumerable.GetEnumerator()
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerableGetEnumerator()()()

See Also

KeyedCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


KeyedCollection(T) Properties

[image] [image]

SQL Data Compare API 12.0.40
KeyedCollection<(Of <(T>)>) Properties
KeyedCollection<(Of <(T>)>) Class See Also

The KeyedCollection<(Of <(T>)>) type exposes the following properties.

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively.
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>).
Item | Overloaded.

See Also

KeyedCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


CaseSensitive Property

[image]

SQL Data Compare API 12.0.40
KeyedCollection<(Of <(T>)>)..::.CaseSensitive Property
KeyedCollection<(Of <(T>)>) Class See Also

True if the keys are stored case-sensitively.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Friend Property CaseSensitive As Boolean
C#
protected internal bool CaseSensitive { get; protected set; }
Visual C++
protected public:
property bool CaseSensitive {
    bool get ();
    void set (bool value);
}

See Also

KeyedCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


Count Property

[image]

SQL Data Compare API 12.0.40
KeyedCollection<(Of <(T>)>)..::.Count Property
KeyedCollection<(Of <(T>)>) Class See Also

Returns the number of elements stored in the KeyedCollection<(Of <(T>)>).

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count { get; }
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

IKeyedCollectionCount()()()

See Also

KeyedCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
KeyedCollection<(Of <(T>)>)..::.Item Property
KeyedCollection<(Of <(T>)>) Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index.
Item[([(String])]) | Returns elements by key.

See Also

KeyedCollection<(Of <(T>)>) Class
KeyedCollection<(Of <(T>)>) Members
RedGate.SQLCompare.Engine Namespace


Item Property ()

[image]

SQL Data Compare API 12.0.40
KeyedCollection<(Of <(T>)>)..::.Item Property ()
KeyedCollection<(Of <(T>)>) Class See Also

Returns elements by index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Default Property Item ( _
    index As Integer _
) As T
C#
public virtual T this[
    int index
] { get; }
Visual C++
public:
virtual property T default[int index] {
    T get (int index);
}

Parameters

index
Type: Int32

Return Value

Implements

IKeyedCollectionItem(Int32)

See Also

KeyedCollection<(Of <(T>)>) Class
Item Overload
RedGate.SQLCompare.Engine Namespace


Item Property ()

[image]

SQL Data Compare API 12.0.40
KeyedCollection<(Of <(T>)>)..::.Item Property ()
KeyedCollection<(Of <(T>)>) Class See Also

Returns elements by key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Default Property Item ( _
    key As String _
) As T
C#
public virtual T this[
    string key
] { get; }
Visual C++
public:
virtual property T default[String^ key] {
    T get (String^ key);
}

Parameters

key
Type: String

Return Value

The value, or default(T) if not found.

Implements

IKeyedCollectionItem(String)

See Also

KeyedCollection<(Of <(T>)>) Class
Item Overload
RedGate.SQLCompare.Engine Namespace


KeyReference Structure

[image]

SQL Data Compare API 12.0.40
KeyReference Structure
Members See Also

A reference to a Key

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Structure KeyReference
C#
public struct KeyReference
Visual C++
public value class KeyReference

See Also

KeyReference Members
RedGate.SQLCompare.Engine Namespace


KeyReference Members

[image] [image]

SQL Data Compare API 12.0.40
KeyReference Members
KeyReference Structure Constructors Methods Fields See Also

The KeyReference type exposes the following members.

Constructors

Name | Description
KeyReference | Creates a reference to a key

Methods

Name | Description
Equals | (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

Name | Description
IndexName | The name of the index
TableName | The table name

See Also

KeyReference Structure
RedGate.SQLCompare.Engine Namespace


KeyReference Constructor

[image]

SQL Data Compare API 12.0.40
KeyReference Constructor
KeyReference Structure See Also

Creates a reference to a key

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    tm As Mapping(Of ViewTableSuperClass), _
    im As Mapping(Of RelationalIndex) _
)
C#
public KeyReference(
    Mapping<ViewTableSuperClass> tm,
    Mapping<RelationalIndex> im
)
Visual C++
public:
KeyReference(
    Mapping<ViewTableSuperClass^>^ tm,
    Mapping<RelationalIndex^>^ im
)

Parameters

tm
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( ViewTableSuperClass >)>)
The table mapping
im
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( RelationalIndex >)>)
The index mapping

See Also

KeyReference Structure
RedGate.SQLCompare.Engine Namespace


KeyReference Fields

[image] [image]

SQL Data Compare API 12.0.40
KeyReference Fields
KeyReference Structure See Also

The KeyReference type exposes the following fields.

Fields

Name | Description
IndexName | The name of the index
TableName | The table name

See Also

KeyReference Structure
RedGate.SQLCompare.Engine Namespace


IndexName Field

[image]

SQL Data Compare API 12.0.40
KeyReference..::.IndexName Field
KeyReference Structure See Also

The name of the index

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public IndexName As String
C#
public string IndexName
Visual C++
public:
String^ IndexName

See Also

KeyReference Structure
RedGate.SQLCompare.Engine Namespace


TableName Field

[image]

SQL Data Compare API 12.0.40
KeyReference..::.TableName Field
KeyReference Structure See Also

The table name

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public TableName As String
C#
public string TableName
Visual C++
public:
String^ TableName

See Also

KeyReference Structure
RedGate.SQLCompare.Engine Namespace


KeyReference Methods

[image] [image]

SQL Data Compare API 12.0.40
KeyReference Methods
KeyReference Structure See Also

The KeyReference type exposes the following methods.

Methods

Name | Description
Equals | (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

KeyReference Structure
RedGate.SQLCompare.Engine Namespace


Equals Method

[image]

SQL Data Compare API 12.0.40
KeyReference..::.Equals Method
KeyReference Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object

See Also

KeyReference Structure
RedGate.SQLCompare.Engine Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
KeyReference..::.GetHashCode Method
KeyReference Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

See Also

KeyReference Structure
RedGate.SQLCompare.Engine Namespace


LazyWithOverride(T) Generic Class

[image]

SQL Data Compare API 12.0.40
LazyWithOverride<(Of <(T>)>) Generic Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class LazyWithOverride(Of T As Class)
C#
public class LazyWithOverride<T> where T : class
Visual C++
generic<typename T>
where T : ref class
public ref class LazyWithOverride

Type Parameters

T

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.LazyWithOverride<(Of <(T>)>)

See Also

LazyWithOverride<(Of <(T>)>) Members
RedGate.SQLCompare.Engine Namespace


LazyWithOverride(T) Members

[image] [image]

SQL Data Compare API 12.0.40
LazyWithOverride<(Of <(T>)>) Members
LazyWithOverride<(Of <(T>)>) Class Constructors Methods Properties See Also

The LazyWithOverride<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
LazyWithOverride<(Of <(T>)>) |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

LazyWithOverride<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


LazyWithOverride(T) Constructor

[image]

SQL Data Compare API 12.0.40
LazyWithOverride<(Of <(T>)>) Constructor
LazyWithOverride<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    defaultSetter As Func(Of T) _
)
C#
public LazyWithOverride(
    Func<T> defaultSetter
)
Visual C++
public:
LazyWithOverride(
    Func<T>^ defaultSetter
)

Parameters

defaultSetter
Type: Func<(Of <( T >)>)

See Also

LazyWithOverride<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


LazyWithOverride(T) Properties

[image] [image]

SQL Data Compare API 12.0.40
LazyWithOverride<(Of <(T>)>) Properties
LazyWithOverride<(Of <(T>)>) Class See Also

The LazyWithOverride<(Of <(T>)>) type exposes the following properties.

Properties

Name | Description
Value |

See Also

LazyWithOverride<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


Value Property

[image]

SQL Data Compare API 12.0.40
LazyWithOverride<(Of <(T>)>)..::.Value Property
LazyWithOverride<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As T
C#
public T Value { get; set; }
Visual C++
public:
property T Value {
    T get ();
    void set (T value);
}

See Also

LazyWithOverride<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


LiveDatabaseSource Class

[image]

SQL Data Compare API 12.0.40
LiveDatabaseSource Class
Members See Also

A standard SQL Server database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class LiveDatabaseSource _
    Inherits DataSource _
    Implements IVersionedDatasource
C#
[SerializableAttribute]
public sealed class LiveDatabaseSource : DataSource, IVersionedDatasource
Visual C++
[SerializableAttribute]
public ref class LiveDatabaseSource sealed : public DataSource,
    IVersionedDatasource

Inheritance Hierarchy

Object
RedGate.Shared.SQL..::.DataSource
RedGate.SQLCompare.Engine..::.LiveDatabaseSource

See Also

LiveDatabaseSource Members
RedGate.SQLCompare.Engine Namespace


LiveDatabaseSource Members

[image] [image]

SQL Data Compare API 12.0.40
LiveDatabaseSource Members
LiveDatabaseSource Class Constructors Methods Properties Explicit Interface Implementations See Also

The LiveDatabaseSource type exposes the following members.

Constructors

Name | Description
LiveDatabaseSource | Constructor.

Methods

Name | Description
Clone | Clones the data source. (Overrides DataSource ..::. Clone()()().)
Deserialize | Deserializes data. (Overrides DataSource ..::. Deserialize(Int32, ISerializeFormatter).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDifferentSource | Compares the data source with a specified data source. (Overrides DataSource ..::.IsDifferentSource(IDataSource).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the specified object. (Overrides DataSource ..::. Serialize(ISerializeFormatter).)
ToConnectionProperties | Returns the ConnectionProperties.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DatabaseName | Gets or sets the name of the database. (Overrides DataSource ..::. DatabaseName.)
IntegratedSecurity | Specifies whether Windows Integrated security or SQL authentication is used.
IsValid | (Overrides DataSource ..::. IsValid.)
IsWriteable | The data source can be written to. (Overrides DataSource ..::. IsWriteable.)
MigrationFolderLocationFromDeserialization |
MigrationsFolderLocation |
Password | Gets or sets the password for the SQL user.
SavePassword | Specifies whether the password should be written to disk when serializing the project.
ScriptFolderLocation |
ScriptFolderLocationFromDeserialization |
ServerName | Gets or sets the name of the SQL Server. (Overrides DataSource ..::. ServerName.)
SpecificVersion |
UserName | Gets or sets the SQL Server user name with which to connect to the SQL Server.
Version | Gets the current serialized version number of LiveDatabaseSource. (Overrides DataSource ..::. Version.)
VersionType |

Explicit Interface Implementations

Name | Description
ICloneableClone | (Inherited from DataSource.)

See Also

LiveDatabaseSource Class
RedGate.SQLCompare.Engine Namespace


LiveDatabaseSource Constructor

[image]

SQL Data Compare API 12.0.40
LiveDatabaseSource Constructor
LiveDatabaseSource Class See Also

Constructor.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LiveDatabaseSource()
Visual C++
public:
LiveDatabaseSource()

See Also

LiveDatabaseSource Class
RedGate.SQLCompare.Engine Namespace


LiveDatabaseSource Methods

[image] [image]

SQL Data Compare API 12.0.40
LiveDatabaseSource Methods
LiveDatabaseSource Class See Also

The LiveDatabaseSource type exposes the following methods.

Methods

Name | Description
Clone | Clones the data source. (Overrides DataSource ..::. Clone()()().)
Deserialize | Deserializes data. (Overrides DataSource ..::. Deserialize(Int32, ISerializeFormatter).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDifferentSource | Compares the data source with a specified data source. (Overrides DataSource ..::.IsDifferentSource(IDataSource).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the specified object. (Overrides DataSource ..::. Serialize(ISerializeFormatter).)
ToConnectionProperties | Returns the ConnectionProperties.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICloneableClone | (Inherited from DataSource.)

See Also

LiveDatabaseSource Class
RedGate.SQLCompare.Engine Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
LiveDatabaseSource..::.Clone Method
LiveDatabaseSource Class See Also

Clones the data source.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone As IDataSource
C#
public override IDataSource Clone()
Visual C++
public:
virtual IDataSource^ Clone() override

Implements

IVersionedDatasource..::.Clone()()()
IDataSource..::.Clone()()()

See Also

LiveDatabaseSource Class
RedGate.SQLCompare.Engine Namespace


Deserialize Method

[image]

SQL Data Compare API 12.0.40
LiveDatabaseSource..::.Deserialize Method
LiveDatabaseSource Class See Also

Deserializes data.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Deserialize ( _
    nVersionId As Integer, _
    obj As ISerializeFormatter _
) As Boolean
C#
public override bool Deserialize(
    int nVersionId,
    ISerializeFormatter obj
)
Visual C++
public:
virtual bool Deserialize(
    int nVersionId,
    ISerializeFormatter^ obj
) override

Parameters

nVersionId
Type: Int32
The serialization version.
obj
Type: ISerializeFormatter
The ISerializeFormatter for deserialization.

See Also

LiveDatabaseSource Class
RedGate.SQLCompare.Engine Namespace


IsDifferentSource Method

[image]

SQL Data Compare API 12.0.40
LiveDatabaseSource..::.IsDifferentSource Method
LiveDatabaseSource Class See Also

Compares the data source with a specified data source.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsDifferentSource ( _
    comparisonDataSource As IDataSource _
) As Boolean
C#
public override bool IsDifferentSource(
    IDataSource comparisonDataSource
)
Visual C++
public:
virtual bool IsDifferentSource(
    IDataSource^ comparisonDataSource
) override

Parameters

comparisonDataSource
Type: RedGate.Shared.SQL..::.IDataSource
The data source to compare.

Return Value

true if the data sources are different.

See Also

LiveDatabaseSource Class
RedGate.SQLCompare.Engine Namespace


Serialize Method

[image]

SQL Data Compare API 12.0.40
LiveDatabaseSource..::.Serialize Method
LiveDatabaseSource Class See Also

Serializes the specified object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    obj As ISerializeFormatter _
)
C#
public override void Serialize(
    ISerializeFormatter obj
)
Visual C++
public:
virtual void Serialize(
    ISerializeFormatter^ obj
) override

Parameters

obj
Type: ISerializeFormatter
The object to serialize.

See Also

LiveDatabaseSource Class
RedGate.SQLCompare.Engine Namespace


ToConnectionProperties Method

[image]

SQL Data Compare API 12.0.40
LiveDatabaseSource..::.ToConnectionProperties Method
LiveDatabaseSource Class See Also

Returns the ConnectionProperties.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Function ToConnectionProperties As ConnectionProperties
C#
public ConnectionProperties ToConnectionProperties()
Visual C++
public:
ConnectionProperties^ ToConnectionProperties()

See Also

LiveDatabaseSource Class
RedGate.SQLCompare.Engine Namespace


LiveDatabaseSource Properties

[image] [image]

SQL Data Compare API 12.0.40
LiveDatabaseSource Properties
LiveDatabaseSource Class See Also

The LiveDatabaseSource type exposes the following properties.

Properties

Name | Description
DatabaseName | Gets or sets the name of the database. (Overrides DataSource ..::. DatabaseName.)
IntegratedSecurity | Specifies whether Windows Integrated security or SQL authentication is used.
IsValid | (Overrides DataSource ..::. IsValid.)
IsWriteable | The data source can be written to. (Overrides DataSource ..::. IsWriteable.)
MigrationFolderLocationFromDeserialization |
MigrationsFolderLocation |
Password | Gets or sets the password for the SQL user.
SavePassword | Specifies whether the password should be written to disk when serializing the project.
ScriptFolderLocation |
ScriptFolderLocationFromDeserialization |
ServerName | Gets or sets the name of the SQL Server. (Overrides DataSource ..::. ServerName.)
SpecificVersion |
UserName | Gets or sets the SQL Server user name with which to connect to the SQL Server.
Version | Gets the current serialized version number of LiveDatabaseSource. (Overrides DataSource ..::. Version.)
VersionType |

See Also

LiveDatabaseSource Class
RedGate.SQLCompare.Engine Namespace


DatabaseName Property

[image]

SQL Data Compare API 12.0.40
LiveDatabaseSource..::.DatabaseName Property
LiveDatabaseSource Class See Also

Gets or sets the name of the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property DatabaseName As String
C#
public override string DatabaseName { get; set; }
Visual C++
public:
virtual property String^ DatabaseName {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IDataSource..::.DatabaseName

See Also

LiveDatabaseSource Class
RedGate.SQLCompare.Engine Namespace


IntegratedSecurity Property

[image]

SQL Data Compare API 12.0.40
LiveDatabaseSource..::.IntegratedSecurity Property
LiveDatabaseSource Class See Also

Specifies whether Windows Integrated security or SQL authentication is used.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property IntegratedSecurity As Boolean
C#
public bool IntegratedSecurity { get; set; }
Visual C++
public:
property bool IntegratedSecurity {
    bool get ();
    void set (bool value);
}

See Also

LiveDatabaseSource Class
RedGate.SQLCompare.Engine Namespace


IsValid Property

[image]

SQL Data Compare API 12.0.40
LiveDatabaseSource..::.IsValid Property
LiveDatabaseSource Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsValid As Boolean
C#
public override bool IsValid { get; }
Visual C++
public:
virtual property bool IsValid {
    bool get () override;
}

Implements

IDataSource..::.IsValid

See Also

LiveDatabaseSource Class
RedGate.SQLCompare.Engine Namespace


IsWriteable Property

[image]

SQL Data Compare API 12.0.40
LiveDatabaseSource..::.IsWriteable Property
LiveDatabaseSource Class See Also

The data source can be written to.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsWriteable As Boolean
C#
public override bool IsWriteable { get; }
Visual C++
public:
virtual property bool IsWriteable {
    bool get () override;
}

Implements

IDataSource..::.IsWriteable

See Also

LiveDatabaseSource Class
RedGate.SQLCompare.Engine Namespace


MigrationFolderLocationFromDeserialization Property

[image]

SQL Data Compare API 12.0.40
LiveDatabaseSource..::.MigrationFolderLocationFromDeserialization Property
LiveDatabaseSource Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property MigrationFolderLocationFromDeserialization As String
C#
public string MigrationFolderLocationFromDeserialization { get; set; }
Visual C++
public:
property String^ MigrationFolderLocationFromDeserialization {
    String^ get ();
    void set (String^ value);
}

See Also

LiveDatabaseSource Class
RedGate.SQLCompare.Engine Namespace


MigrationsFolderLocation Property

[image]

SQL Data Compare API 12.0.40
LiveDatabaseSource..::.MigrationsFolderLocation Property
LiveDatabaseSource Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property MigrationsFolderLocation As ISOCCompareLocation
C#
public ISOCCompareLocation MigrationsFolderLocation { get; set; }
Visual C++
public:
virtual property ISOCCompareLocation^ MigrationsFolderLocation {
    ISOCCompareLocation^ get () sealed;
    void set (ISOCCompareLocation^ value) sealed;
}

See Also

LiveDatabaseSource Class
RedGate.SQLCompare.Engine Namespace


Password Property

[image]

SQL Data Compare API 12.0.40
LiveDatabaseSource..::.Password Property
LiveDatabaseSource Class See Also

Gets or sets the password for the SQL user.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password { get; set; }
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

LiveDatabaseSource Class
RedGate.SQLCompare.Engine Namespace


SavePassword Property

[image]

SQL Data Compare API 12.0.40
LiveDatabaseSource..::.SavePassword Property
LiveDatabaseSource Class See Also

Specifies whether the password should be written to disk when serializing the project.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property SavePassword As Boolean
C#
public bool SavePassword { get; set; }
Visual C++
public:
property bool SavePassword {
    bool get ();
    void set (bool value);
}

See Also

LiveDatabaseSource Class
RedGate.SQLCompare.Engine Namespace


ScriptFolderLocation Property

[image]

SQL Data Compare API 12.0.40
LiveDatabaseSource..::.ScriptFolderLocation Property
LiveDatabaseSource Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptFolderLocation As ISOCCompareLocation
C#
public ISOCCompareLocation ScriptFolderLocation { get; set; }
Visual C++
public:
virtual property ISOCCompareLocation^ ScriptFolderLocation {
    ISOCCompareLocation^ get () sealed;
    void set (ISOCCompareLocation^ value) sealed;
}

See Also

LiveDatabaseSource Class
RedGate.SQLCompare.Engine Namespace


ScriptFolderLocationFromDeserialization Property

[image]

SQL Data Compare API 12.0.40
LiveDatabaseSource..::.ScriptFolderLocationFromDeserialization Property
LiveDatabaseSource Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptFolderLocationFromDeserialization As String
C#
public string ScriptFolderLocationFromDeserialization { get; set; }
Visual C++
public:
property String^ ScriptFolderLocationFromDeserialization {
    String^ get ();
    void set (String^ value);
}

See Also

LiveDatabaseSource Class
RedGate.SQLCompare.Engine Namespace


ServerName Property

[image]

SQL Data Compare API 12.0.40
LiveDatabaseSource..::.ServerName Property
LiveDatabaseSource Class See Also

Gets or sets the name of the SQL Server.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property ServerName As String
C#
public override string ServerName { get; set; }
Visual C++
public:
virtual property String^ ServerName {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IDataSource..::.ServerName

See Also

LiveDatabaseSource Class
RedGate.SQLCompare.Engine Namespace


SpecificVersion Property

[image]

SQL Data Compare API 12.0.40
LiveDatabaseSource..::.SpecificVersion Property
LiveDatabaseSource Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property SpecificVersion As String
C#
public string SpecificVersion { get; set; }
Visual C++
public:
virtual property String^ SpecificVersion {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IVersionedDatasource..::.SpecificVersion

See Also

LiveDatabaseSource Class
RedGate.SQLCompare.Engine Namespace


UserName Property

[image]

SQL Data Compare API 12.0.40
LiveDatabaseSource..::.UserName Property
LiveDatabaseSource Class See Also

Gets or sets the SQL Server user name with which to connect to the SQL Server.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property UserName As String
C#
public string UserName { get; set; }
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

LiveDatabaseSource Class
RedGate.SQLCompare.Engine Namespace


Version Property

[image]

SQL Data Compare API 12.0.40
LiveDatabaseSource..::.Version Property
LiveDatabaseSource Class See Also

Gets the current serialized version number of LiveDatabaseSource.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Version As Integer
C#
public override int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () override;
}

See Also

LiveDatabaseSource Class
RedGate.SQLCompare.Engine Namespace


VersionType Property

[image]

SQL Data Compare API 12.0.40
LiveDatabaseSource..::.VersionType Property
LiveDatabaseSource Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property VersionType As VersionType
C#
public VersionType VersionType { get; set; }
Visual C++
public:
virtual property VersionType VersionType {
    VersionType get () sealed;
    void set (VersionType value) sealed;
}

Implements

IVersionedDatasource..::.VersionType

See Also

LiveDatabaseSource Class
RedGate.SQLCompare.Engine Namespace


LockEscalationType Enumeration

[image]

SQL Data Compare API 12.0.40
LockEscalationType Enumeration
See Also

See MSDN docs on the LOCK_ESCALATION keyword: http://technet.microsoft.com/en-us/library/ms184286(v=sql.105).aspx Gotchas:- Text used to generate SQL The actual values are also the values stored by SQL Server

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration LockEscalationType
C#
public enum LockEscalationType
Visual C++
public enum class LockEscalationType

Members

Member name | Description
Table |
Disable |
Auto |

See Also

RedGate.SQLCompare.Engine Namespace


LockEscalationTypeExtensions Class

[image]

SQL Data Compare API 12.0.40
LockEscalationTypeExtensions Class
See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LockEscalationTypeExtensions
C#
public static class LockEscalationTypeExtensions
Visual C++
public ref class LockEscalationTypeExtensions abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.LockEscalationTypeExtensions

See Also

RedGate.SQLCompare.Engine Namespace


Mapping(T) Generic Class

[image]

SQL Data Compare API 12.0.40
Mapping<(Of <(T>)>) Generic Class
Members See Also

Abstract class used to contain a mapping between two database objects.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class Mapping(Of T As {Class, IDatabaseObject}) _
    Implements IComparable(Of Mapping(Of T)), ICloneable
C#
public class Mapping<T> : IComparable<Mapping<T>>,
    ICloneable where T : class, IDatabaseObject
Visual C++
generic<typename T>
where T : ref class, IDatabaseObject
public ref class Mapping : IComparable<Mapping<T>^>,
    ICloneable

Type Parameters

T
The type stored in the mappings.

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.Mapping<(Of <(T>)>)
RedGate.SQLCompare.Engine..::.SqlCompareFieldMapping
RedGate.SQLCompare.Engine..::.SqlCompareTableMapping
RedGate.SQLCompare.Engine..::.SqlCompareOwnerMapping
RedGate.SQLDataCompare.Engine..::.FieldMapping
RedGate.SQLDataCompare.Engine..::.IndexMapping
RedGate.SQLDataCompare.Engine..::.TableMapping
RedGate.SQLDataCompare.Engine..::.SchemaMapping

See Also

Mapping<(Of <(T>)>) Members
RedGate.SQLCompare.Engine Namespace


Mapping(T) Members

[image] [image]

SQL Data Compare API 12.0.40
Mapping<(Of <(T>)>) Members
Mapping<(Of <(T>)>) Class Methods Fields Properties Explicit Interface Implementations See Also

The Mapping<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Clone |
CompareTo | Sorts the Mappings.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

Fields

Name | Description
m_Messages |

Properties

Name | Description
Include | Specifies whether the mapping is to be included.
Messages | Messages that explain any issues concerning the mapping; null if no issues exist.
Obj1 | Returns the object from the first database
Obj2 | Returns the object from the second database

Explicit Interface Implementations

Name | Description
ICloneableClone | Creates a shallow copy.

See Also

Mapping<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


Mapping(T) Fields

[image] [image]

SQL Data Compare API 12.0.40
Mapping<(Of <(T>)>) Fields
Mapping<(Of <(T>)>) Class See Also

The Mapping<(Of <(T>)>) type exposes the following fields.

Fields

Name | Description
m_Messages |

See Also

Mapping<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


m_Messages Field

[image]

SQL Data Compare API 12.0.40
Mapping<(Of <(T>)>)..::.m_Messages Field
Mapping<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Messages As Messages
C#
protected Messages m_Messages
Visual C++
protected:
Messages^ m_Messages

See Also

Mapping<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


Mapping(T) Methods

[image] [image]

SQL Data Compare API 12.0.40
Mapping<(Of <(T>)>) Methods
Mapping<(Of <(T>)>) Class See Also

The Mapping<(Of <(T>)>) type exposes the following methods.

Methods

Name | Description
Clone |
CompareTo | Sorts the Mappings.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

Explicit Interface Implementations

Name | Description
ICloneableClone | Creates a shallow copy.

See Also

Mapping<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
Mapping<(Of <(T>)>)..::.Clone Method
Mapping<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone As Mapping(Of T)
C#
public virtual Mapping<T> Clone()
Visual C++
public:
virtual Mapping<T>^ Clone()

See Also

Mapping<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


. Method

[image]

SQL Data Compare API 12.0.40
Mapping<(Of <(T>)>)..::...::. Method
Mapping<(Of <(T>)>) Class See Also

Creates a shallow copy.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function Clone As Object Implements ICloneable.Clone
C#
Object ICloneable.Clone()
Visual C++
private:
virtual Object^ Clone() sealed = ICloneable::Clone

Return Value

A shallow copy.

Implements

ICloneableClone()()()

See Also

Mapping<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


CompareTo Method

[image]

SQL Data Compare API 12.0.40
Mapping<(Of <(T>)>)..::.CompareTo Method
Mapping<(Of <(T>)>) Class See Also

Sorts the Mappings.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function CompareTo ( _
    obj As Mapping(Of T) _
) As Integer
C#
public virtual int CompareTo(
    Mapping<T> obj
)
Visual C++
public:
virtual int CompareTo(
    Mapping<T>^ obj
)

Parameters

obj
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( T >)>)
The object to be compared.

Return Value

Less than zero when this instance is less than the specified object; zero when this instance is equal to the specified object; greater then zero when this instance is greater than the specified object.

Implements

IComparableCompareTo(UTP)

See Also

Mapping<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
Mapping<(Of <(T>)>)..::.ToString Method
Mapping<(Of <(T>)>) Class See Also

Returns a String that represents the current Object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

Mapping<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


Mapping(T) Properties

[image] [image]

SQL Data Compare API 12.0.40
Mapping<(Of <(T>)>) Properties
Mapping<(Of <(T>)>) Class See Also

The Mapping<(Of <(T>)>) type exposes the following properties.

Properties

Name | Description
Include | Specifies whether the mapping is to be included.
Messages | Messages that explain any issues concerning the mapping; null if no issues exist.
Obj1 | Returns the object from the first database
Obj2 | Returns the object from the second database

See Also

Mapping<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


Include Property

[image]

SQL Data Compare API 12.0.40
Mapping<(Of <(T>)>)..::.Include Property
Mapping<(Of <(T>)>) Class See Also

Specifies whether the mapping is to be included.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Include As Boolean
C#
public virtual bool Include { get; set; }
Visual C++
public:
virtual property bool Include {
    bool get ();
    void set (bool value);
}

See Also

Mapping<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


Messages Property

[image]

SQL Data Compare API 12.0.40
Mapping<(Of <(T>)>)..::.Messages Property
Mapping<(Of <(T>)>) Class See Also

Messages that explain any issues concerning the mapping; null if no issues exist.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Messages As Messages
C#
public Messages Messages { get; }
Visual C++
public:
property Messages^ Messages {
    Messages^ get ();
}

See Also

Mapping<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


Obj1 Property

[image]

SQL Data Compare API 12.0.40
Mapping<(Of <(T>)>)..::.Obj1 Property
Mapping<(Of <(T>)>) Class See Also

Returns the object from the first database

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Obj1 As T
C#
public T Obj1 { get; }
Visual C++
public:
property T Obj1 {
    T get ();
}

See Also

Mapping<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


Obj2 Property

[image]

SQL Data Compare API 12.0.40
Mapping<(Of <(T>)>)..::.Obj2 Property
Mapping<(Of <(T>)>) Class See Also

Returns the object from the second database

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Obj2 As T
C#
public T Obj2 { get; }
Visual C++
public:
property T Obj2 {
    T get ();
}

See Also

Mapping<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


MappingContext Class

[image]

SQL Data Compare API 12.0.40
MappingContext Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class MappingContext
C#
public class MappingContext
Visual C++
public ref class MappingContext

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.MappingContext

See Also

MappingContext Members
RedGate.SQLCompare.Engine Namespace


MappingContext Members

[image] [image]

SQL Data Compare API 12.0.40
MappingContext Members
MappingContext Class Constructors Methods Fields See Also

The MappingContext type exposes the following members.

Constructors

Name | Description
MappingContext |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
CaseSensitive |

See Also

MappingContext Class
RedGate.SQLCompare.Engine Namespace


MappingContext Constructor

[image]

SQL Data Compare API 12.0.40
MappingContext Constructor
MappingContext Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public MappingContext(
    bool caseSensitive
)
Visual C++
public:
MappingContext(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

MappingContext Class
RedGate.SQLCompare.Engine Namespace


MappingContext Fields

[image] [image]

SQL Data Compare API 12.0.40
MappingContext Fields
MappingContext Class See Also

The MappingContext type exposes the following fields.

Fields

Name | Description
CaseSensitive |

See Also

MappingContext Class
RedGate.SQLCompare.Engine Namespace


CaseSensitive Field

[image]

SQL Data Compare API 12.0.40
MappingContext..::.CaseSensitive Field
MappingContext Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly CaseSensitive As Boolean
C#
public readonly bool CaseSensitive
Visual C++
public:
initonly bool CaseSensitive

See Also

MappingContext Class
RedGate.SQLCompare.Engine Namespace


MappingException Class

[image]

SQL Data Compare API 12.0.40
MappingException Class
Members See Also

Exception thrown when an error is encountered whilst mapping.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class MappingException _
    Inherits ApplicationException
C#
[SerializableAttribute]
public class MappingException : ApplicationException
Visual C++
[SerializableAttribute]
public ref class MappingException : public ApplicationException

Inheritance Hierarchy

Object
Exception
ApplicationException
RedGate.SQLCompare.Engine..::.MappingException

See Also

MappingException Members
RedGate.SQLCompare.Engine Namespace


MappingException Members

[image] [image]

SQL Data Compare API 12.0.40
MappingException Members
MappingException Class Constructors Methods Properties See Also

The MappingException type exposes the following members.

Constructors

Name | Description
MappingException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MappingException Class
RedGate.SQLCompare.Engine Namespace


MappingException Constructor

[image] [image]

SQL Data Compare API 12.0.40
MappingException Constructor
MappingException Class See Also

Overload List

Name | Description
MappingException()()() | Creates a new exception.
MappingException(String) | Creates a new exception with the specified detail message.
MappingException(SerializationInfo, StreamingContext) | This constructor is called during deserialization to reconstitute the exception object transmitted over a stream. For more information, see XML and SOAP Serialization.
MappingException(String, Exception) | Creates a new exception with the specified detail message and cause.

See Also

MappingException Class
MappingException Members
RedGate.SQLCompare.Engine Namespace


MappingException Constructor

[image]

SQL Data Compare API 12.0.40
MappingException Constructor
MappingException Class See Also

Creates a new exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MappingException()
Visual C++
public:
MappingException()

See Also

MappingException Class
MappingException Overload
RedGate.SQLCompare.Engine Namespace


MappingException Constructor ()

[image]

SQL Data Compare API 12.0.40
MappingException Constructor ()
MappingException Class See Also

Creates a new exception with the specified detail message.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public MappingException(
    string message
)
Visual C++
public:
MappingException(
    String^ message
)

Parameters

message
Type: String
Detail message.

See Also

MappingException Class
MappingException Overload
RedGate.SQLCompare.Engine Namespace


MappingException Constructor (, )

[image]

SQL Data Compare API 12.0.40
MappingException Constructor (, )
MappingException Class See Also

This constructor is called during deserialization to reconstitute the exception object transmitted over a stream. For more information, see XML and SOAP Serialization.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected MappingException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
MappingException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: SerializationInfo
The object that holds the serialized object data.
context
Type: StreamingContext
The contextual information about the source or destination.

See Also

MappingException Class
MappingException Overload
RedGate.SQLCompare.Engine Namespace


MappingException Constructor (, )

[image]

SQL Data Compare API 12.0.40
MappingException Constructor (, )
MappingException Class See Also

Creates a new exception with the specified detail message and cause.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    cause As Exception _
)
C#
public MappingException(
    string message,
    Exception cause
)
Visual C++
public:
MappingException(
    String^ message,
    Exception^ cause
)

Parameters

message
Type: String
Detail message.
cause
Type: Exception
Cause of exception.

See Also

MappingException Class
MappingException Overload
RedGate.SQLCompare.Engine Namespace


MappingOptions Enumeration

[image]

SQL Data Compare API 12.0.40
MappingOptions Enumeration
See Also

Options used when generating the mapping between two databases.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration MappingOptions
C#
[FlagsAttribute]
public enum MappingOptions
Visual C++
[FlagsAttribute]
public enum class MappingOptions

Members

Member name Description
Default

The default options when generating the mappings. These are:

  • IgnoreCase
  • IgnoreSpaces
  • IncludeIdentities
  • IncludeTimestamps
None
None.
CaseSensitiveObjectDefinition
Ignores the case of the object names (tables, views, users, roles, schemas, indexes, and columns) when mapping. For example, [dbo].[Widget] is considered to be the same as [dbo].[widget] when you select this option.
IgnoreSpaces
Ignores the spaces in the object names (tables, views, users, roles, schemas, indexes, and columns) when mapping. For example, [dbo].[Widget Prices] is considered to be the same as [dbo].[WidgetPrices] when you select this option.
IgnoreUnderscores
Ignores the underscores in the object names (tables, views, users, roles, schemas, indexes, and columns) when mapping. For example, [dbo].[Widget_Prices] is considered to be the same as [dbo].[WidgetPrices] when you select this option.
MissingFrom2AsInclude
When the object does not exist in the second database, the Mapping status is set to success and include is set to true.
IncludeTimestamps
Includes timestamp columns from the tables or views in the schema information for the database. Timestamp columns cannot be synchronized.
IncludeIndexedViews
Includes views in the schema information for the database. Views can be synchronized only if the referenced rows are from a single table, and the referenced columns are simple (for example, they must not include identity columns or computed columns).
IncludeIdentities
Includes identity columns from the tables or views in the schema information for the database. You cannot synchronize views if they include an identity column.
MissingFrom1AsInclude
This option is only used by SQL Source Control to get the diffs correct for conflicts in the ODP. If you start using this option elsewhere, please modify this text.

See Also

RedGate.SQLCompare.Engine Namespace


Mappings(TMapping, TMap, TContext) Generic Class

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>) Generic Class
Members See Also

Abstract class for creating a set of mappings from a list of database objects.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class Mappings(Of TMapping As Mapping(Of TMap), TMap As {Class, IDatabaseObject}, TContext) _
    Inherits InnerList(Of TMapping) _
    Implements ICancellable
C#
public abstract class Mappings<TMapping, TMap, TContext> : InnerList<TMapping>, ICancellable where TMapping : Mapping<TMap> where TMap : class, IDatabaseObject
Visual C++
generic<typename TMapping, typename TMap, typename TContext>
where TMapping : Mapping<TMap>
where TMap : ref class, IDatabaseObject
public ref class Mappings abstract : public InnerList<TMapping>,
    ICancellable

Type Parameters

TMapping
TMap
TContext

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( T >)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <(TMapping>)>)
RedGate.SQLCompare.Engine..::.Mappings<(Of <(TMapping, TMap, TContext>)>)
RedGate.SQLCompare.Engine..::.SqlCompareOwnerMappings
RedGate.SQLCompare.Engine..::.SqlCompareFieldMappings
RedGate.SQLCompare.Engine..::.SqlCompareTableMappings
RedGate.SQLDataCompare.Engine..::.DataCompareMappings<(Of <(TMapping, TMap>)>)

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Members
RedGate.SQLCompare.Engine Namespace


Mappings(TMapping, TMap, TContext) Members

[image] [image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>) Members
Mappings<(Of <(TMapping, TMap, TContext>)>) Class Constructors Methods Fields Properties Explicit Interface Implementations See Also

The Mappings<(Of <(TMapping, TMap, TContext>)>) type exposes the following members.

Constructors

Name | Description
Mappings<(Of <(TMapping, TMap, TContext>)>) | Overloaded.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Overrides InnerList <(Of <( TMapping >)>)..::.Add(UTP).)
CancelOperation | Cancels the current operation.
Clear | Removes all objects from the Mappings instance. (Overrides InnerList <(Of <( TMapping >)>)..::.Clear()()().)
Contains | Determines whether the Mappings instance contains a specified object. (Overrides InnerList <(Of <( TMapping >)>)..::. Contains(T).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings<(Of <(U>)>) | Creates a mapping for each object in the collection where such a mapping is possible. All of the iteration is performed here and the matching can be affected by changing ShouldInclude(TMap, TMap, Object) in the sub class. The main action of joining to objects together is performed by Join(TMap, TMap) which can itself call CreateMappings on child database objects.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FromOne | Overloaded.
FromTwo | Returns the Mapping of the object in the second database.
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Overrides InnerList <(Of <( TMapping >)>)..::. IndexOf(T).)
Insert | Not Implemented. (Overrides InnerList <(Of <( TMapping >)>)..::.Insert(Int32, UTP).)
Join | Attempts to join two objects in one mapping.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnValidate | Performs additional custom proccesses when validating a value.
RealAdd | Adds a mapping to this Mappings instance. This will change the forwards and backwards maps as necessary. This will break any mapping that will conflict with the added mapping.
RealRemove | Removes the specified object from the mappings instance.
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Overrides InnerList <(Of <( TMapping >)>)..::.Remove(UTP).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Overrides InnerList <(Of <( TMapping >)>)..::.RemoveAt(Int32).)
ShouldInclude | Called to determine if an object should be included in the mapping at all, one of the obj arguments is null.
Sort | Sorts the Mappings according the criteria appropriate for the object.
Split | Splits a mapping and creates two mappings; one to null, and one from null.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Fields

Name | Description
m_Context |
m_PrepareString |

Properties

Name | Description
Context | Access to the mapping context. The type of the context is dependent on the mapped objects.
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.
Status | The event handler used to receive status update events.

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
RedGate.SQLCompare.Engine Namespace


Mappings(TMapping, TMap, TContext) Constructor

[image] [image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>) Constructor
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Overload List

Name | Description
Mappings<(Of <(TMapping, TMap, TContext>)>)()()() | Default constructor.
Mappings<(Of <(TMapping, TMap, TContext>)>)(Mappings<(Of <(TMapping, TMap, TContext>)>)) | Shallow copy constructor.
Mappings<(Of <(TMapping, TMap, TContext>)>)(PrepareStringDelegate<(Of <(TMap, TContext>)>)) | Contructor used when string preparation delegate is being changed.

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
Mappings<(Of <(TMapping, TMap, TContext>)>) Members
RedGate.SQLCompare.Engine Namespace


Mappings(TMapping, TMap, TContext) Constructor

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>) Constructor
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Default constructor.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected Mappings()
Visual C++
protected:
Mappings()

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
Mappings<(Of <(TMapping, TMap, TContext>)>) Overload
RedGate.SQLCompare.Engine Namespace


Mappings(TMapping, TMap, TContext) Constructor (Mappings(TMapping, TMap, TContext))

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>) Constructor (Mappings<(Of <(TMapping, TMap, TContext>)>))
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Shallow copy constructor.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    mappings As Mappings(Of TMapping, TMap, TContext) _
)
C#
protected Mappings(
    Mappings<TMapping, TMap, TContext> mappings
)
Visual C++
protected:
Mappings(
    Mappings<TMapping, TMap, TContext>^ mappings
)

Parameters

mappings
Type: RedGate.SQLCompare.Engine..::.Mappings <(Of <( TMapping, TMap, TContext >)>)
Mappings to copy.

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
Mappings<(Of <(TMapping, TMap, TContext>)>) Overload
RedGate.SQLCompare.Engine Namespace


Mappings(TMapping, TMap, TContext) Constructor (PrepareStringDelegate(TMap, TContext))

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>) Constructor (PrepareStringDelegate<(Of <(TMap, TContext>)>))
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Contructor used when string preparation delegate is being changed.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    prepareStringDelegate As PrepareStringDelegate(Of TMap, TContext) _
)
C#
protected Mappings(
    PrepareStringDelegate<TMap, TContext> prepareStringDelegate
)
Visual C++
protected:
Mappings(
    PrepareStringDelegate<TMap, TContext>^ prepareStringDelegate
)

Parameters

prepareStringDelegate
Type: RedGate.SQLCompare.Engine..::.PrepareStringDelegate <(Of <( TMap, TContext >)>)
Function to be used to prepare string.

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
Mappings<(Of <(TMapping, TMap, TContext>)>) Overload
RedGate.SQLCompare.Engine Namespace


Mappings(TMapping, TMap, TContext) Fields

[image] [image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>) Fields
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

The Mappings<(Of <(TMapping, TMap, TContext>)>) type exposes the following fields.

Fields

Name | Description
m_Context |
m_PrepareString |

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
RedGate.SQLCompare.Engine Namespace


m_Context Field

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>)..::.m_Context Field
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Context As TContext
C#
protected TContext m_Context
Visual C++
protected:
TContext m_Context

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
RedGate.SQLCompare.Engine Namespace


m_PrepareString Field

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>)..::.m_PrepareString Field
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_PrepareString As PrepareStringDelegate(Of TMap, TContext)
C#
protected PrepareStringDelegate<TMap, TContext> m_PrepareString
Visual C++
protected:
PrepareStringDelegate<TMap, TContext>^ m_PrepareString

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
RedGate.SQLCompare.Engine Namespace


Mappings(TMapping, TMap, TContext) Methods

[image] [image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>) Methods
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

The Mappings<(Of <(TMapping, TMap, TContext>)>) type exposes the following methods.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Overrides InnerList <(Of <( TMapping >)>)..::.Add(UTP).)
CancelOperation | Cancels the current operation.
Clear | Removes all objects from the Mappings instance. (Overrides InnerList <(Of <( TMapping >)>)..::.Clear()()().)
Contains | Determines whether the Mappings instance contains a specified object. (Overrides InnerList <(Of <( TMapping >)>)..::. Contains(T).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings<(Of <(U>)>) | Creates a mapping for each object in the collection where such a mapping is possible. All of the iteration is performed here and the matching can be affected by changing ShouldInclude(TMap, TMap, Object) in the sub class. The main action of joining to objects together is performed by Join(TMap, TMap) which can itself call CreateMappings on child database objects.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FromOne | Overloaded.
FromTwo | Returns the Mapping of the object in the second database.
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Overrides InnerList <(Of <( TMapping >)>)..::. IndexOf(T).)
Insert | Not Implemented. (Overrides InnerList <(Of <( TMapping >)>)..::.Insert(Int32, UTP).)
Join | Attempts to join two objects in one mapping.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnValidate | Performs additional custom proccesses when validating a value.
RealAdd | Adds a mapping to this Mappings instance. This will change the forwards and backwards maps as necessary. This will break any mapping that will conflict with the added mapping.
RealRemove | Removes the specified object from the mappings instance.
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Overrides InnerList <(Of <( TMapping >)>)..::.Remove(UTP).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Overrides InnerList <(Of <( TMapping >)>)..::.RemoveAt(Int32).)
ShouldInclude | Called to determine if an object should be included in the mapping at all, one of the obj arguments is null.
Sort | Sorts the Mappings according the criteria appropriate for the object.
Split | Splits a mapping and creates two mappings; one to null, and one from null.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
RedGate.SQLCompare.Engine Namespace


Add Method

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>)..::.Add Method
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Add ( _
    value As TMapping _
)
C#
public override void Add(
    TMapping value
)
Visual C++
public:
virtual void Add(
    TMapping value
) override

Parameters

value
Type: TMapping
The object to be added to the end of the Mappings instance.

Return Value

The Mappings index at which the object has been added.

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
RedGate.SQLCompare.Engine Namespace


CancelOperation Method

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>)..::.CancelOperation Method
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Cancels the current operation.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub CancelOperation
C#
public virtual void CancelOperation()
Visual C++
public:
virtual void CancelOperation()

Implements

ICancellable..::.CancelOperation()()()

Remarks

An OperationCancelledException will be thrown.

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
RedGate.SQLCompare.Engine Namespace


Clear Method

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>)..::.Clear Method
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Removes all objects from the Mappings instance.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Clear
C#
public override void Clear()
Visual C++
public:
virtual void Clear() override

Implements

ICollectionClear()()()

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
RedGate.SQLCompare.Engine Namespace


Contains Method

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>)..::.Contains Method
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Determines whether the Mappings instance contains a specified object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Contains ( _
    value As TMapping _
) As Boolean
C#
public override bool Contains(
    TMapping value
)
Visual C++
public:
virtual bool Contains(
    TMapping value
) override

Parameters

value
Type: TMapping
The Mapping<(Of <(T>)>) to locate in the Mappings instance.

Return Value

true if the Mappings instance contains the specified object; otherwise, false.

Implements

ICollectionContains(UTP)

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
RedGate.SQLCompare.Engine Namespace


CreateMappings(U) Generic Method

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>)..::.CreateMappings<(Of <(U>)>) Generic Method
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Creates a mapping for each object in the collection where such a mapping is possible. All of the iteration is performed here and the matching can be affected by changing ShouldInclude(TMap, TMap, Object) in the sub class. The main action of joining to objects together is performed by Join(TMap, TMap) which can itself call CreateMappings on child database objects.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub CreateMappings(Of U As ) ( _
    in1 As IKeyedCollection(Of U), _
    in2 As IKeyedCollection(Of U), _
    extra As Object, _
    useFullName As Boolean _
)
C#
protected void CreateMappings<U>(
    IKeyedCollection<U> in1,
    IKeyedCollection<U> in2,
    Object extra,
    bool useFullName
) where U :
Visual C++
protected:
generic<typename U>
where U :
void CreateMappings(
    IKeyedCollection<U>^ in1,
    IKeyedCollection<U>^ in2,
    Object^ extra,
    bool useFullName
)

Parameters

in1
Type: IKeyedCollection<(Of <(U>)>)
List of objects in the first database, or null.
in2
Type: IKeyedCollection<(Of <(U>)>)
List of objects in the second database, or null.
extra
Type: Object
This can be used by the Join(TMap, TMap) function for extra information on how to join the objects.
useFullName
Type: Boolean
Use the FullyQualifiedName for matching

Type Parameters

U

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
RedGate.SQLCompare.Engine Namespace


FromOne Method

[image] [image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>)..::.FromOne Method
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Overload List

Name | Description
FromOne(String) | Returns the Mapping of the object in the first database.
FromOne(TMap) | Returns the mapping of the object in the first database.

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
Mappings<(Of <(TMapping, TMap, TContext>)>) Members
RedGate.SQLCompare.Engine Namespace


FromOne Method ()

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>)..::.FromOne Method ()
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Returns the Mapping of the object in the first database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function FromOne ( _
    in1 As String _
) As TMapping
C#
public TMapping FromOne(
    string in1
)
Visual C++
public:
TMapping FromOne(
    String^ in1
)

Parameters

in1
Type: String
The FullyQualifiedName of the object in the first database.

Return Value

If no mapping exists, null; otherwise, the Mapping.

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
FromOne Overload
RedGate.SQLCompare.Engine Namespace


FromOne Method (TMap)

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>)..::.FromOne Method (TMap)
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Returns the mapping of the object in the first database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Function FromOne ( _
    in1 As TMap _
) As TMapping
C#
protected TMapping FromOne(
    TMap in1
)
Visual C++
protected:
TMapping FromOne(
    TMap in1
)

Parameters

in1
Type: TMap
object that the mapping is from, not null.

Return Value

null if no mapping exists, or the mapping.

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
FromOne Overload
RedGate.SQLCompare.Engine Namespace


FromTwo Method

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>)..::.FromTwo Method
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Returns the Mapping of the object in the second database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function FromTwo ( _
    in2 As String _
) As TMapping
C#
public TMapping FromTwo(
    string in2
)
Visual C++
public:
TMapping FromTwo(
    String^ in2
)

Parameters

in2
Type: String
The FullyQualifiedName of the object in the second database.

Return Value

If no mapping exists, null; otherwise, the Mapping.

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
RedGate.SQLCompare.Engine Namespace


GetKey Method

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>)..::.GetKey Method
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Return the key that should be used for the specified fully qualified name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetKey ( _
    fullyQualifiedName As String _
) As String
C#
protected virtual string GetKey(
    string fullyQualifiedName
)
Visual C++
protected:
virtual String^ GetKey(
    String^ fullyQualifiedName
)

Parameters

fullyQualifiedName
Type: String

Return Value

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
RedGate.SQLCompare.Engine Namespace


IndexOf Method

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>)..::.IndexOf Method
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IndexOf ( _
    value As TMapping _
) As Integer
C#
public override int IndexOf(
    TMapping value
)
Visual C++
public:
virtual int IndexOf(
    TMapping value
) override

Parameters

value
Type: TMapping
The object to locate in the Mappings instance.

Return Value

If found, the zero-based index of the first occurrence of the object within the Mappings instance; otherwise, -1.

Implements

IListIndexOf(UTP)

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
RedGate.SQLCompare.Engine Namespace


Insert Method

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>)..::.Insert Method
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Not Implemented.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Insert ( _
    index As Integer, _
    value As TMapping _
)
C#
public override void Insert(
    int index,
    TMapping value
)
Visual C++
public:
virtual void Insert(
    int index,
    TMapping value
) override

Parameters

index
Type: Int32
Ignored.
value
Type: TMapping
Ignored.

Implements

IListInsert(Int32, UTP)

Exceptions

Exception | Condition
NotImplementedException | Throws NotImplementedException always

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
RedGate.SQLCompare.Engine Namespace


Join Method

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>)..::.Join Method
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Attempts to join two objects in one mapping.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function Join ( _
    obj1 As TMap, _
    obj2 As TMap _
) As TMapping
C#
public abstract TMapping Join(
    TMap obj1,
    TMap obj2
)
Visual C++
public:
virtual TMapping Join(
    TMap obj1,
    TMap obj2
) abstract

Parameters

obj1
Type: TMap
The first object, or null.
obj2
Type: TMap
The second object, or null.

Return Value

The mapping created.

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
RedGate.SQLCompare.Engine Namespace


OnValidate Method

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>)..::.OnValidate Method
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Performs additional custom proccesses when validating a value.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnValidate ( _
    value As Mapping(Of TMap) _
)
C#
protected virtual void OnValidate(
    Mapping<TMap> value
)
Visual C++
protected:
virtual void OnValidate(
    Mapping<TMap>^ value
)

Parameters

value
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( TMap >)>)
The object to validate.

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
RedGate.SQLCompare.Engine Namespace


RealAdd Method

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>)..::.RealAdd Method
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Adds a mapping to this Mappings instance. This will change the forwards and backwards maps as necessary. This will break any mapping that will conflict with the added mapping.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Friend Function RealAdd ( _
    mapping As TMapping _
) As Integer
C#
protected internal int RealAdd(
    TMapping mapping
)
Visual C++
protected public:
int RealAdd(
    TMapping mapping
)

Parameters

mapping
Type: TMapping
mapping object to be added, not null.

Return Value

index of the mapping object in the Mappings.

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
RedGate.SQLCompare.Engine Namespace


RealRemove Method

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>)..::.RealRemove Method
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Removes the specified object from the mappings instance.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Friend Function RealRemove ( _
    mapping As TMapping _
) As Boolean
C#
protected internal bool RealRemove(
    TMapping mapping
)
Visual C++
protected public:
bool RealRemove(
    TMapping mapping
)

Parameters

mapping
Type: TMapping
Mapping object to be removed.

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
RedGate.SQLCompare.Engine Namespace


Remove Method

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>)..::.Remove Method
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Remove ( _
    value As TMapping _
) As Boolean
C#
public override bool Remove(
    TMapping value
)
Visual C++
public:
virtual bool Remove(
    TMapping value
) override

Parameters

value
Type: TMapping
The object to remove from the Mappings instance.

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
RedGate.SQLCompare.Engine Namespace


RemoveAt Method

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>)..::.RemoveAt Method
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Removes the mapping at the specified index of the Mappings instance.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub RemoveAt ( _
    index As Integer _
)
C#
public override sealed void RemoveAt(
    int index
)
Visual C++
public:
virtual void RemoveAt(
    int index
) override sealed

Parameters

index
Type: Int32
The index of the mapping to be removed.

Implements

IListRemoveAt(Int32)

Exceptions

Exception | Condition
ArgumentOutOfRangeException | Mapping is null at the specified index.

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
RedGate.SQLCompare.Engine Namespace


ShouldInclude Method

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>)..::.ShouldInclude Method
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Called to determine if an object should be included in the mapping at all, one of the obj arguments is null.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function ShouldInclude ( _
    obj1 As TMap, _
    obj2 As TMap, _
    extra As Object _
) As Boolean
C#
protected virtual bool ShouldInclude(
    TMap obj1,
    TMap obj2,
    Object extra
)
Visual C++
protected:
virtual bool ShouldInclude(
    TMap obj1,
    TMap obj2,
    Object^ extra
)

Parameters

obj1
Type: TMap
object or null if obj2 not null.
obj2
Type: TMap
object or null if obj1 not null.
extra
Type: Object
extra data passed into CreateMappings internally to determine relevance.

Return Value

true ( default )for inclusion, false otherwise.

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
RedGate.SQLCompare.Engine Namespace


Sort Method

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>)..::.Sort Method
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Sorts the Mappings according the criteria appropriate for the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Sort
C#
public void Sort()
Visual C++
public:
void Sort()

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
RedGate.SQLCompare.Engine Namespace


Split Method

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>)..::.Split Method
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Splits a mapping and creates two mappings; one to null, and one from null.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Split ( _
    old1 As TMapping _
)
C#
public virtual void Split(
    TMapping old1
)
Visual C++
public:
virtual void Split(
    TMapping old1
)

Parameters

old1
Type: TMapping
The mapping to be split, both obj1 and obj2 should be not null.

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
RedGate.SQLCompare.Engine Namespace


Mappings(TMapping, TMap, TContext) Properties

[image] [image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>) Properties
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

The Mappings<(Of <(TMapping, TMap, TContext>)>) type exposes the following properties.

Properties

Name | Description
Context | Access to the mapping context. The type of the context is dependent on the mapped objects.
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.
Status | The event handler used to receive status update events.

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
RedGate.SQLCompare.Engine Namespace


Context Property

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>)..::.Context Property
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Access to the mapping context. The type of the context is dependent on the mapped objects.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Property Context As TContext
C#
protected TContext Context { get; set; }
Visual C++
protected:
property TContext Context {
    TContext get ();
    void set (TContext value);
}

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>)..::.Item Property
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Gets the Mapping<(Of <(T>)>) at the specified index. (Overrides InnerList <(Of <( TMapping >)>)..::. Item[([(Int32])]).)
Item[([(String])]) | Gets the mapping of the specified object name, first attempting to match against objects in the first database, then matching against objects in the second database. Returns null if a mapping is not found.

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
Mappings<(Of <(TMapping, TMap, TContext>)>) Members
RedGate.SQLCompare.Engine Namespace


Item Property ()

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>)..::.Item Property ()
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Gets the Mapping<(Of <(T>)>) at the specified index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides WriteOnly Default Property Item ( _
    index As Integer _
) As TMapping
C#
public override TMapping this[
    int index
] { set; }
Visual C++
public:
virtual property TMapping default[int index] {
    void set (int index, TMapping value) override;
}

Parameters

index
Type: Int32
The zero-based index of the Mapping to get or set.

Implements

IListItem(Int32)

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
Item Overload
RedGate.SQLCompare.Engine Namespace


Item Property ()

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>)..::.Item Property ()
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

Gets the mapping of the specified object name, first attempting to match against objects in the first database, then matching against objects in the second database. Returns null if a mapping is not found.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    fullyQualifiedName As String _
) As TMapping
C#
public TMapping this[
    string fullyQualifiedName
] { get; }
Visual C++
public:
property TMapping default[String^ fullyQualifiedName] {
    TMapping get (String^ fullyQualifiedName);
}

Parameters

fullyQualifiedName
Type: String
The string-based index of the element to get.

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
Item Overload
RedGate.SQLCompare.Engine Namespace


Status Property

[image]

SQL Data Compare API 12.0.40
Mappings<(Of <(TMapping, TMap, TContext>)>)..::.Status Property
Mappings<(Of <(TMapping, TMap, TContext>)>) Class See Also

The event handler used to receive status update events.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

See Also

Mappings<(Of <(TMapping, TMap, TContext>)>) Class
RedGate.SQLCompare.Engine Namespace


Members Class

[image]

SQL Data Compare API 12.0.40
Members Class
Members See Also

A collection of role members. These can be users or roles.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Members _
    Inherits KeyedCollection(Of IOwner)
C#
public sealed class Members : KeyedCollection<IOwner>
Visual C++
public ref class Members sealed : public KeyedCollection<IOwner^>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( IOwner >)>)
RedGate.SQLCompare.Engine..::.Members

See Also

Members Members
RedGate.SQLCompare.Engine Namespace


Members Members

[image] [image]

SQL Data Compare API 12.0.40
Members Members
Members Class Methods Fields Properties Explicit Interface Implementations See Also

The Members type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

Members Class
RedGate.SQLCompare.Engine Namespace


Message Class

[image]

SQL Data Compare API 12.0.40
Message Class
Members See Also

A message.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Message _
    Inherits MessageBase
C#
public sealed class Message : MessageBase
Visual C++
public ref class Message sealed : public MessageBase

Remarks

See Work for more information.

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.MessageBase
RedGate.SQLCompare.Engine..::.Message

See Also

Message Members
RedGate.SQLCompare.Engine Namespace


Message Members

[image] [image]

SQL Data Compare API 12.0.40
Message Members
Message Class Methods Fields Properties See Also

The Message type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from MessageBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_IDatabaseObject | (Inherited from MessageBase.)
m_MessageTypeID | (Inherited from MessageBase.)
m_Severity | (Inherited from MessageBase.)
m_Text | (Inherited from MessageBase.)

Properties

Name | Description
DatabaseObject | The database object to which this message belongs. (Inherited from MessageBase.)
HelpURL | (Inherited from MessageBase.)
MessageTypeID | The identifier of the message type. (Inherited from MessageBase.)
Text | The text of the message. (Inherited from MessageBase.)
WarningSeverity | The severity of the message or warning. (Inherited from MessageBase.)

See Also

Message Class
RedGate.SQLCompare.Engine Namespace


MessageBase Class

[image]

SQL Data Compare API 12.0.40
MessageBase Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class MessageBase _
    Implements IDeploymentMessage
C#
public abstract class MessageBase : IDeploymentMessage
Visual C++
public ref class MessageBase abstract : IDeploymentMessage

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.MessageBase
RedGate.SQLCompare.Engine..::.FieldMappingBestMatchMessage
RedGate.SQLCompare.Engine..::.MigScriptPlugMessageDecorator
RedGate.SQLCompare.Engine..::.Message

See Also

MessageBase Members
RedGate.SQLCompare.Engine Namespace


MessageBase Members

[image] [image]

SQL Data Compare API 12.0.40
MessageBase Members
MessageBase Class Constructors Methods Fields Properties See Also

The MessageBase type exposes the following members.

Constructors

Name | Description
MessageBase |

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_IDatabaseObject |
m_MessageTypeID |
m_Severity |
m_Text |

Properties

Name | Description
DatabaseObject | The database object to which this message belongs.
HelpURL |
MessageTypeID | The identifier of the message type.
Text | The text of the message.
WarningSeverity | The severity of the message or warning.

See Also

MessageBase Class
RedGate.SQLCompare.Engine Namespace


MessageBase Constructor

[image]

SQL Data Compare API 12.0.40
MessageBase Constructor
MessageBase Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected MessageBase()
Visual C++
protected:
MessageBase()

See Also

MessageBase Class
RedGate.SQLCompare.Engine Namespace


MessageBase Fields

[image] [image]

SQL Data Compare API 12.0.40
MessageBase Fields
MessageBase Class See Also

The MessageBase type exposes the following fields.

Fields

Name | Description
m_IDatabaseObject |
m_MessageTypeID |
m_Severity |
m_Text |

See Also

MessageBase Class
RedGate.SQLCompare.Engine Namespace


m_IDatabaseObject Field

[image]

SQL Data Compare API 12.0.40
MessageBase..::.m_IDatabaseObject Field
MessageBase Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_IDatabaseObject As ITSqlObject
C#
protected ITSqlObject m_IDatabaseObject
Visual C++
protected:
ITSqlObject^ m_IDatabaseObject

See Also

MessageBase Class
RedGate.SQLCompare.Engine Namespace


m_MessageTypeID Field

[image]

SQL Data Compare API 12.0.40
MessageBase..::.m_MessageTypeID Field
MessageBase Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_MessageTypeID As String
C#
protected string m_MessageTypeID
Visual C++
protected:
String^ m_MessageTypeID

See Also

MessageBase Class
RedGate.SQLCompare.Engine Namespace


m_Severity Field

[image]

SQL Data Compare API 12.0.40
MessageBase..::.m_Severity Field
MessageBase Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Severity As WarningSeverity
C#
protected WarningSeverity m_Severity
Visual C++
protected:
WarningSeverity m_Severity

See Also

MessageBase Class
RedGate.SQLCompare.Engine Namespace


m_Text Field

[image]

SQL Data Compare API 12.0.40
MessageBase..::.m_Text Field
MessageBase Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Text As String
C#
protected string m_Text
Visual C++
protected:
String^ m_Text

See Also

MessageBase Class
RedGate.SQLCompare.Engine Namespace


MessageBase Methods

[image] [image]

SQL Data Compare API 12.0.40
MessageBase Methods
MessageBase Class See Also

The MessageBase type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MessageBase Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
MessageBase..::.Equals Method
MessageBase Class See Also

Overload List

Name | Description
Equals(Object) | (Overrides Object..::.Equals(Object).)
Equals(MessageBase) |

See Also

MessageBase Class
MessageBase Members
RedGate.SQLCompare.Engine Namespace


Equals Method ()

[image]

SQL Data Compare API 12.0.40
MessageBase..::.Equals Method ()
MessageBase Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object

See Also

MessageBase Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


Equals Method (MessageBase)

[image]

SQL Data Compare API 12.0.40
MessageBase..::.Equals Method (MessageBase)
MessageBase Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Function Equals ( _
    other As MessageBase _
) As Boolean
C#
protected bool Equals(
    MessageBase other
)
Visual C++
protected:
bool Equals(
    MessageBase^ other
)

Parameters

other
Type: RedGate.SQLCompare.Engine..::.MessageBase

See Also

MessageBase Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
MessageBase..::.GetHashCode Method
MessageBase Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

See Also

MessageBase Class
RedGate.SQLCompare.Engine Namespace


MessageBase Properties

[image] [image]

SQL Data Compare API 12.0.40
MessageBase Properties
MessageBase Class See Also

The MessageBase type exposes the following properties.

Properties

Name | Description
DatabaseObject | The database object to which this message belongs.
HelpURL |
MessageTypeID | The identifier of the message type.
Text | The text of the message.
WarningSeverity | The severity of the message or warning.

See Also

MessageBase Class
RedGate.SQLCompare.Engine Namespace


DatabaseObject Property

[image]

SQL Data Compare API 12.0.40
MessageBase..::.DatabaseObject Property
MessageBase Class See Also

The database object to which this message belongs.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property DatabaseObject As ITSqlObject
C#
public virtual ITSqlObject DatabaseObject { get; }
Visual C++
public:
virtual property ITSqlObject^ DatabaseObject {
    ITSqlObject^ get ();
}

Implements

IDeploymentMessageDatabaseObject()()()

See Also

MessageBase Class
RedGate.SQLCompare.Engine Namespace


HelpURL Property

[image]

SQL Data Compare API 12.0.40
MessageBase..::.HelpURL Property
MessageBase Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpURL As String
C#
public virtual string HelpURL { get; set; }
Visual C++
public:
virtual property String^ HelpURL {
    String^ get ();
    void set (String^ value);
}

Implements

IDeploymentMessageHelpURL()()()

See Also

MessageBase Class
RedGate.SQLCompare.Engine Namespace


MessageTypeID Property

[image]

SQL Data Compare API 12.0.40
MessageBase..::.MessageTypeID Property
MessageBase Class See Also

The identifier of the message type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property MessageTypeID As String
C#
public virtual string MessageTypeID { get; }
Visual C++
public:
virtual property String^ MessageTypeID {
    String^ get ();
}

Implements

IDeploymentMessageMessageTypeID()()()

See Also

MessageBase Class
RedGate.SQLCompare.Engine Namespace


Text Property

[image]

SQL Data Compare API 12.0.40
MessageBase..::.Text Property
MessageBase Class See Also

The text of the message.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Text As String
C#
public virtual string Text { get; }
Visual C++
public:
virtual property String^ Text {
    String^ get ();
}

Implements

IDeploymentMessageText()()()

See Also

MessageBase Class
RedGate.SQLCompare.Engine Namespace


WarningSeverity Property

[image]

SQL Data Compare API 12.0.40
MessageBase..::.WarningSeverity Property
MessageBase Class See Also

The severity of the message or warning.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property WarningSeverity As WarningSeverity
C#
public virtual WarningSeverity WarningSeverity { get; }
Visual C++
public:
virtual property WarningSeverity WarningSeverity {
    WarningSeverity get ();
}

Implements

IDeploymentMessageWarningSeverity()()()

See Also

MessageBase Class
RedGate.SQLCompare.Engine Namespace


Messages Class

[image]

SQL Data Compare API 12.0.40
Messages Class
Members See Also

A collection of messages.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Messages _
    Inherits InnerList(Of IDeploymentMessage)
C#
public sealed class Messages : InnerList<IDeploymentMessage>
Visual C++
public ref class Messages sealed : public InnerList<IDeploymentMessage^>

Remarks

See Work for more information.

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( T >)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <(IDeploymentMessage>)>)
RedGate.SQLCompare.Engine..::.Messages

See Also

Messages Members
RedGate.SQLCompare.Engine Namespace


Messages Members

[image] [image]

SQL Data Compare API 12.0.40
Messages Members
Messages Class Methods Properties Explicit Interface Implementations See Also

The Messages type exposes the following members.

Methods

Name | Description
AddHighPriorityWarning | Overloaded.
AddLowPriorityWarning | Overloaded.
AddMediumPriorityWarning | Overloaded.
AddMigrationScriptSuggestions |
Contains | (Inherited from InnerList<(Of <(T>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sort | Sorts the messages using the specified comparer.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | (Inherited from InnerList<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Messages Class
RedGate.SQLCompare.Engine Namespace


Messages Methods

[image] [image]

SQL Data Compare API 12.0.40
Messages Methods
Messages Class See Also

The Messages type exposes the following methods.

Methods

Name | Description
AddHighPriorityWarning | Overloaded.
AddLowPriorityWarning | Overloaded.
AddMediumPriorityWarning | Overloaded.
AddMigrationScriptSuggestions |
Contains | (Inherited from InnerList<(Of <(T>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sort | Sorts the messages using the specified comparer.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Messages Class
RedGate.SQLCompare.Engine Namespace


AddHighPriorityWarning Method

[image] [image]

SQL Data Compare API 12.0.40
Messages..::.AddHighPriorityWarning Method
Messages Class See Also

Overload List

Name | Description
AddHighPriorityWarning(String, String, array<Object>[]()[]) |
AddHighPriorityWarning(String, String, IDatabaseObject, array<Object>[]()[]) |

See Also

Messages Class
Messages Members
RedGate.SQLCompare.Engine Namespace


AddHighPriorityWarning Method (, , [])

[image]

SQL Data Compare API 12.0.40
Messages..::.AddHighPriorityWarning Method (, , array<>[]()[])
Messages Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddHighPriorityWarning ( _
    messageTypeId As String, _
    messageBody As String, _
    ParamArray referencedObjects As Object() _
)
C#
public void AddHighPriorityWarning(
    string messageTypeId,
    string messageBody,
    params Object[] referencedObjects
)
Visual C++
public:
void AddHighPriorityWarning(
    String^ messageTypeId,
    String^ messageBody,
    ... array<Object^>^ referencedObjects
)

Parameters

messageTypeId
Type: String
messageBody
Type: String
referencedObjects
Type: array<Object>[]()[]

See Also

Messages Class
AddHighPriorityWarning Overload
RedGate.SQLCompare.Engine Namespace


AddHighPriorityWarning Method (, , IDatabaseObject, [])

[image]

SQL Data Compare API 12.0.40
Messages..::.AddHighPriorityWarning Method (, , IDatabaseObject, array<>[]()[])
Messages Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddHighPriorityWarning ( _
    messageTypeId As String, _
    messageBody As String, _
    ownerObject As IDatabaseObject, _
    ParamArray referencedObjects As Object() _
)
C#
public void AddHighPriorityWarning(
    string messageTypeId,
    string messageBody,
    IDatabaseObject ownerObject,
    params Object[] referencedObjects
)
Visual C++
public:
void AddHighPriorityWarning(
    String^ messageTypeId,
    String^ messageBody,
    IDatabaseObject^ ownerObject,
    ... array<Object^>^ referencedObjects
)

Parameters

messageTypeId
Type: String
messageBody
Type: String
ownerObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
referencedObjects
Type: array<Object>[]()[]

See Also

Messages Class
AddHighPriorityWarning Overload
RedGate.SQLCompare.Engine Namespace


AddLowPriorityWarning Method

[image] [image]

SQL Data Compare API 12.0.40
Messages..::.AddLowPriorityWarning Method
Messages Class See Also

Overload List

Name | Description
AddLowPriorityWarning(String, String, array<Object>[]()[]) |
AddLowPriorityWarning(String, String, IDatabaseObject, array<Object>[]()[]) |

See Also

Messages Class
Messages Members
RedGate.SQLCompare.Engine Namespace


AddLowPriorityWarning Method (, , [])

[image]

SQL Data Compare API 12.0.40
Messages..::.AddLowPriorityWarning Method (, , array<>[]()[])
Messages Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddLowPriorityWarning ( _
    messageTypeId As String, _
    messageBody As String, _
    ParamArray referencedObjects As Object() _
)
C#
public void AddLowPriorityWarning(
    string messageTypeId,
    string messageBody,
    params Object[] referencedObjects
)
Visual C++
public:
void AddLowPriorityWarning(
    String^ messageTypeId,
    String^ messageBody,
    ... array<Object^>^ referencedObjects
)

Parameters

messageTypeId
Type: String
messageBody
Type: String
referencedObjects
Type: array<Object>[]()[]

See Also

Messages Class
AddLowPriorityWarning Overload
RedGate.SQLCompare.Engine Namespace


AddLowPriorityWarning Method (, , IDatabaseObject, [])

[image]

SQL Data Compare API 12.0.40
Messages..::.AddLowPriorityWarning Method (, , IDatabaseObject, array<>[]()[])
Messages Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddLowPriorityWarning ( _
    messageTypeId As String, _
    messageBody As String, _
    ownerObject As IDatabaseObject, _
    ParamArray referencedObjects As Object() _
)
C#
public void AddLowPriorityWarning(
    string messageTypeId,
    string messageBody,
    IDatabaseObject ownerObject,
    params Object[] referencedObjects
)
Visual C++
public:
void AddLowPriorityWarning(
    String^ messageTypeId,
    String^ messageBody,
    IDatabaseObject^ ownerObject,
    ... array<Object^>^ referencedObjects
)

Parameters

messageTypeId
Type: String
messageBody
Type: String
ownerObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
referencedObjects
Type: array<Object>[]()[]

See Also

Messages Class
AddLowPriorityWarning Overload
RedGate.SQLCompare.Engine Namespace


AddMediumPriorityWarning Method

[image] [image]

SQL Data Compare API 12.0.40
Messages..::.AddMediumPriorityWarning Method
Messages Class See Also

Overload List

Name | Description
AddMediumPriorityWarning(String, String, array<Object>[]()[]) |
AddMediumPriorityWarning(String, String, IDatabaseObject, array<Object>[]()[]) |

See Also

Messages Class
Messages Members
RedGate.SQLCompare.Engine Namespace


AddMediumPriorityWarning Method (, , [])

[image]

SQL Data Compare API 12.0.40
Messages..::.AddMediumPriorityWarning Method (, , array<>[]()[])
Messages Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddMediumPriorityWarning ( _
    messageTypeId As String, _
    messageBody As String, _
    ParamArray referencedObjects As Object() _
)
C#
public void AddMediumPriorityWarning(
    string messageTypeId,
    string messageBody,
    params Object[] referencedObjects
)
Visual C++
public:
void AddMediumPriorityWarning(
    String^ messageTypeId,
    String^ messageBody,
    ... array<Object^>^ referencedObjects
)

Parameters

messageTypeId
Type: String
messageBody
Type: String
referencedObjects
Type: array<Object>[]()[]

See Also

Messages Class
AddMediumPriorityWarning Overload
RedGate.SQLCompare.Engine Namespace


AddMediumPriorityWarning Method (, , IDatabaseObject, [])

[image]

SQL Data Compare API 12.0.40
Messages..::.AddMediumPriorityWarning Method (, , IDatabaseObject, array<>[]()[])
Messages Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddMediumPriorityWarning ( _
    messageTypeId As String, _
    messageBody As String, _
    ownerObject As IDatabaseObject, _
    ParamArray referencedObjects As Object() _
)
C#
public void AddMediumPriorityWarning(
    string messageTypeId,
    string messageBody,
    IDatabaseObject ownerObject,
    params Object[] referencedObjects
)
Visual C++
public:
void AddMediumPriorityWarning(
    String^ messageTypeId,
    String^ messageBody,
    IDatabaseObject^ ownerObject,
    ... array<Object^>^ referencedObjects
)

Parameters

messageTypeId
Type: String
messageBody
Type: String
ownerObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
referencedObjects
Type: array<Object>[]()[]

See Also

Messages Class
AddMediumPriorityWarning Overload
RedGate.SQLCompare.Engine Namespace


AddMigrationScriptSuggestions Method

[image]

SQL Data Compare API 12.0.40
Messages..::.AddMigrationScriptSuggestions Method
Messages Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddMigrationScriptSuggestions
C#
public void AddMigrationScriptSuggestions()
Visual C++
public:
void AddMigrationScriptSuggestions()

See Also

Messages Class
RedGate.SQLCompare.Engine Namespace


Sort Method

[image]

SQL Data Compare API 12.0.40
Messages..::.Sort Method
Messages Class See Also

Sorts the messages using the specified comparer.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Sort ( _
    comparer As IComparer(Of IDeploymentMessage) _
)
C#
public void Sort(
    IComparer<IDeploymentMessage> comparer
)
Visual C++
public:
void Sort(
    IComparer<IDeploymentMessage^>^ comparer
)

Parameters

comparer
Type: IComparer<(Of <(IDeploymentMessage>)>)
The IComparer to be used for the sorting.

See Also

Messages Class
RedGate.SQLCompare.Engine Namespace


MessageType Class

[image]

SQL Data Compare API 12.0.40
MessageType Class
Members See Also

A message type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MessageType _
    Inherits DatabaseObjectWithAuthorizationAndExtendedProperties _
    Implements IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck,  _
    IIsSystemObject, IPatchUpAfterDeserialization, ISqlComparable
C#
public sealed class MessageType : DatabaseObjectWithAuthorizationAndExtendedProperties, IHasPermissions,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, IIsSystemObject, IPatchUpAfterDeserialization,
    ISqlComparable
Visual C++
public ref class MessageType sealed : public DatabaseObjectWithAuthorizationAndExtendedProperties,
    IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck, IIsSystemObject,
    IPatchUpAfterDeserialization, ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorizationAndExtendedProperties
RedGate.SQLCompare.Engine..::.MessageType

See Also

MessageType Members
RedGate.SQLCompare.Engine Namespace


MessageType Members

[image] [image]

SQL Data Compare API 12.0.40
MessageType Members
MessageType Class Methods Fields Properties Explicit Interface Implementations See Also

The MessageType type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AlterAuthorizationClassType | (Overrides DatabaseObjectWithAuthorization ..::. AlterAuthorizationClassType.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
IsSystemObject | Indicates whether the object in question is a system object.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.MessageType (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)
Validation | The validation requirement for the message type.
XmlCollection | The XML schema collection referenced by the message type.

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

MessageType Class
RedGate.SQLCompare.Engine Namespace


MessageType Methods

[image] [image]

SQL Data Compare API 12.0.40
MessageType Methods
MessageType Class See Also

The MessageType type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

MessageType Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
MessageType..::.ISqlComparable..::.CompareWith Method
MessageType Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    target As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable target,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ target,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

target
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

MessageType Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
MessageType..::.Equals Method
MessageType Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the message type with a specified message type. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

MessageType Class
MessageType Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
MessageType..::.Equals Method (IDatabaseObject, Options)
MessageType Class See Also

Compares the message type with a specified message type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The message type to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the message types are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

MessageType Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
MessageType..::.PatchUpAfterDeserialization Method
MessageType Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

MessageType Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
MessageType..::.ScriptObject Method
MessageType Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

MessageType Class
RedGate.SQLCompare.Engine Namespace


MessageType Properties

[image] [image]

SQL Data Compare API 12.0.40
MessageType Properties
MessageType Class See Also

The MessageType type exposes the following properties.

Properties

Name | Description
AlterAuthorizationClassType | (Overrides DatabaseObjectWithAuthorization ..::. AlterAuthorizationClassType.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
IsSystemObject | Indicates whether the object in question is a system object.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.MessageType (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)
Validation | The validation requirement for the message type.
XmlCollection | The XML schema collection referenced by the message type.

See Also

MessageType Class
RedGate.SQLCompare.Engine Namespace


AlterAuthorizationClassType Property

[image]

SQL Data Compare API 12.0.40
MessageType..::.AlterAuthorizationClassType Property
MessageType Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property AlterAuthorizationClassType As String
C#
public override string AlterAuthorizationClassType { get; }
Visual C++
public:
virtual property String^ AlterAuthorizationClassType {
    String^ get () override;
}

Implements

IHasAuthorization..::.AlterAuthorizationClassType

See Also

MessageType Class
RedGate.SQLCompare.Engine Namespace


IsSystemObject Property

[image]

SQL Data Compare API 12.0.40
MessageType..::.IsSystemObject Property
MessageType Class See Also

Indicates whether the object in question is a system object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSystemObject As Boolean
C#
public bool IsSystemObject { get; }
Visual C++
public:
virtual property bool IsSystemObject {
    bool get () sealed;
}

Implements

IIsSystemObject..::.IsSystemObject

See Also

MessageType Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
MessageType..::.ObjectType Property
MessageType Class See Also

Returns ObjectType.MessageType

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()
ITSqlObjectObjectType()()()

See Also

MessageType Class
RedGate.SQLCompare.Engine Namespace


Validation Property

[image]

SQL Data Compare API 12.0.40
MessageType..::.Validation Property
MessageType Class See Also

The validation requirement for the message type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Validation As MessageTypeValidation
C#
public MessageTypeValidation Validation { get; internal set; }
Visual C++
public:
property MessageTypeValidation Validation {
    MessageTypeValidation get ();
    void set (MessageTypeValidation value);
}

See Also

MessageType Class
RedGate.SQLCompare.Engine Namespace


XmlCollection Property

[image]

SQL Data Compare API 12.0.40
MessageType..::.XmlCollection Property
MessageType Class See Also

The XML schema collection referenced by the message type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlCollection As XmlSchemaCollection
C#
public XmlSchemaCollection XmlCollection { get; internal set; }
Visual C++
public:
property XmlSchemaCollection^ XmlCollection {
    XmlSchemaCollection^ get ();
    void set (XmlSchemaCollection^ value);
}

See Also

MessageType Class
RedGate.SQLCompare.Engine Namespace


MessageTypes Class

[image]

SQL Data Compare API 12.0.40
MessageTypes Class
Members See Also

A collection of message types.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MessageTypes _
    Inherits SerializableDatabaseObjectCollection(Of MessageType) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class MessageTypes : SerializableDatabaseObjectCollection<MessageType>, IPatchUpAfterDeserialization
Visual C++
public ref class MessageTypes sealed : public SerializableDatabaseObjectCollection<MessageType^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( MessageType >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( MessageType >)>)
RedGate.SQLCompare.Engine..::.MessageTypes

See Also

MessageTypes Members
RedGate.SQLCompare.Engine Namespace


MessageTypes Members

[image] [image]

SQL Data Compare API 12.0.40
MessageTypes Members
MessageTypes Class Methods Fields Properties Explicit Interface Implementations See Also

The MessageTypes type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

MessageTypes Class
RedGate.SQLCompare.Engine Namespace


MessageTypes Methods

[image] [image]

SQL Data Compare API 12.0.40
MessageTypes Methods
MessageTypes Class See Also

The MessageTypes type exposes the following methods.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

MessageTypes Class
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
MessageTypes..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
MessageTypes Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

MessageTypes Class
RedGate.SQLCompare.Engine Namespace


MessageTypesChanges Class

[image]

SQL Data Compare API 12.0.40
MessageTypesChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MessageTypesChanges
C#
public sealed class MessageTypesChanges
Visual C++
public ref class MessageTypesChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.MessageTypesChanges

See Also

MessageTypesChanges Members
RedGate.SQLCompare.Engine Namespace


MessageTypesChanges Members

[image] [image]

SQL Data Compare API 12.0.40
MessageTypesChanges Members
MessageTypesChanges Class Constructors Methods Properties See Also

The MessageTypesChanges type exposes the following members.

Constructors

Name | Description
MessageTypesChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MessageTypesToAlter |
MessageTypesToCreate |
MessageTypesToDrop |
MessageTypeTargets |

See Also

MessageTypesChanges Class
RedGate.SQLCompare.Engine Namespace


MessageTypesChanges Constructor

[image]

SQL Data Compare API 12.0.40
MessageTypesChanges Constructor
MessageTypesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public MessageTypesChanges(
    bool caseSensitive
)
Visual C++
public:
MessageTypesChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

MessageTypesChanges Class
RedGate.SQLCompare.Engine Namespace


MessageTypesChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
MessageTypesChanges Properties
MessageTypesChanges Class See Also

The MessageTypesChanges type exposes the following properties.

Properties

Name | Description
MessageTypesToAlter |
MessageTypesToCreate |
MessageTypesToDrop |
MessageTypeTargets |

See Also

MessageTypesChanges Class
RedGate.SQLCompare.Engine Namespace


MessageTypesToAlter Property

[image]

SQL Data Compare API 12.0.40
MessageTypesChanges..::.MessageTypesToAlter Property
MessageTypesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property MessageTypesToAlter As MessageTypes
C#
public MessageTypes MessageTypesToAlter { get; private set; }
Visual C++
public:
property MessageTypes^ MessageTypesToAlter {
    MessageTypes^ get ();
    void set (MessageTypes^ value);
}

See Also

MessageTypesChanges Class
RedGate.SQLCompare.Engine Namespace


MessageTypesToCreate Property

[image]

SQL Data Compare API 12.0.40
MessageTypesChanges..::.MessageTypesToCreate Property
MessageTypesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property MessageTypesToCreate As MessageTypes
C#
public MessageTypes MessageTypesToCreate { get; private set; }
Visual C++
public:
property MessageTypes^ MessageTypesToCreate {
    MessageTypes^ get ();
    void set (MessageTypes^ value);
}

See Also

MessageTypesChanges Class
RedGate.SQLCompare.Engine Namespace


MessageTypesToDrop Property

[image]

SQL Data Compare API 12.0.40
MessageTypesChanges..::.MessageTypesToDrop Property
MessageTypesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property MessageTypesToDrop As MessageTypes
C#
public MessageTypes MessageTypesToDrop { get; private set; }
Visual C++
public:
property MessageTypes^ MessageTypesToDrop {
    MessageTypes^ get ();
    void set (MessageTypes^ value);
}

See Also

MessageTypesChanges Class
RedGate.SQLCompare.Engine Namespace


MessageTypeTargets Property

[image]

SQL Data Compare API 12.0.40
MessageTypesChanges..::.MessageTypeTargets Property
MessageTypesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property MessageTypeTargets As Dictionary(Of MessageType, MessageType)
C#
public Dictionary<MessageType, MessageType> MessageTypeTargets { get; private set; }
Visual C++
public:
property Dictionary<MessageType^, MessageType^>^ MessageTypeTargets {
    Dictionary<MessageType^, MessageType^>^ get ();
    void set (Dictionary<MessageType^, MessageType^>^ value);
}

See Also

MessageTypesChanges Class
RedGate.SQLCompare.Engine Namespace


MessageTypeValidation Enumeration

[image]

SQL Data Compare API 12.0.40
MessageTypeValidation Enumeration
See Also

The validation type for a message type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration MessageTypeValidation
C#
public enum MessageTypeValidation
Visual C++
public enum class MessageTypeValidation

Members

Member name | Description
None | None.
Xml | XML.
Empty | Empty.

See Also

RedGate.SQLCompare.Engine Namespace


MessageUsage Class

[image]

SQL Data Compare API 12.0.40
MessageUsage Class
Members See Also

A message usage.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MessageUsage _
    Implements IPatchUpAfterDeserialization
C#
public sealed class MessageUsage : IPatchUpAfterDeserialization
Visual C++
public ref class MessageUsage sealed : IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.MessageUsage

See Also

MessageUsage Members
RedGate.SQLCompare.Engine Namespace


MessageUsage Members

[image] [image]

SQL Data Compare API 12.0.40
MessageUsage Members
MessageUsage Class Methods Properties See Also

The MessageUsage type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MessageType | The message type.
SentByInitiator | True if the message type in the usage is sent by the initiator.
SentByTarget | True if the message type in the usage is sent by the target.

See Also

MessageUsage Class
RedGate.SQLCompare.Engine Namespace


MessageUsage Methods

[image] [image]

SQL Data Compare API 12.0.40
MessageUsage Methods
MessageUsage Class See Also

The MessageUsage type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MessageUsage Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
MessageUsage..::.Equals Method
MessageUsage Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(MessageUsage, Options) | Compares the message usage with a specified message usage.

See Also

MessageUsage Class
MessageUsage Members
RedGate.SQLCompare.Engine Namespace


Equals Method (MessageUsage, Options)

[image]

SQL Data Compare API 12.0.40
MessageUsage..::.Equals Method (MessageUsage, Options)
MessageUsage Class See Also

Compares the message usage with a specified message usage.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    target As MessageUsage, _
    options As Options _
) As Boolean
C#
public bool Equals(
    MessageUsage target,
    Options options
)
Visual C++
public:
bool Equals(
    MessageUsage^ target,
    Options options
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.MessageUsage
The message usage to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the message usages are identical; otherwise, false.

See Also

MessageUsage Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
MessageUsage..::.PatchUpAfterDeserialization Method
MessageUsage Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

MessageUsage Class
RedGate.SQLCompare.Engine Namespace


MessageUsage Properties

[image] [image]

SQL Data Compare API 12.0.40
MessageUsage Properties
MessageUsage Class See Also

The MessageUsage type exposes the following properties.

Properties

Name | Description
MessageType | The message type.
SentByInitiator | True if the message type in the usage is sent by the initiator.
SentByTarget | True if the message type in the usage is sent by the target.

See Also

MessageUsage Class
RedGate.SQLCompare.Engine Namespace


MessageType Property

[image]

SQL Data Compare API 12.0.40
MessageUsage..::.MessageType Property
MessageUsage Class See Also

The message type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property MessageType As MessageType
C#
public MessageType MessageType { get; internal set; }
Visual C++
public:
property MessageType^ MessageType {
    MessageType^ get ();
    void set (MessageType^ value);
}

See Also

MessageUsage Class
RedGate.SQLCompare.Engine Namespace


SentByInitiator Property

[image]

SQL Data Compare API 12.0.40
MessageUsage..::.SentByInitiator Property
MessageUsage Class See Also

True if the message type in the usage is sent by the initiator.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SentByInitiator As Boolean
C#
public bool SentByInitiator { get; internal set; }
Visual C++
public:
property bool SentByInitiator {
    bool get ();
    void set (bool value);
}

See Also

MessageUsage Class
RedGate.SQLCompare.Engine Namespace


SentByTarget Property

[image]

SQL Data Compare API 12.0.40
MessageUsage..::.SentByTarget Property
MessageUsage Class See Also

True if the message type in the usage is sent by the target.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SentByTarget As Boolean
C#
public bool SentByTarget { get; internal set; }
Visual C++
public:
property bool SentByTarget {
    bool get ();
    void set (bool value);
}

See Also

MessageUsage Class
RedGate.SQLCompare.Engine Namespace


MessageUsages Class

[image]

SQL Data Compare API 12.0.40
MessageUsages Class
Members See Also

A collection of message usages.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MessageUsages _
    Inherits SerializableCollection(Of MessageUsage) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class MessageUsages : SerializableCollection<MessageUsage>, IPatchUpAfterDeserialization
Visual C++
public ref class MessageUsages sealed : public SerializableCollection<MessageUsage^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( MessageUsage >)>)
RedGate.SQLCompare.Engine..::.MessageUsages

See Also

MessageUsages Members
RedGate.SQLCompare.Engine Namespace


MessageUsages Members

[image] [image]

SQL Data Compare API 12.0.40
MessageUsages Members
MessageUsages Class Methods Fields Properties Explicit Interface Implementations See Also

The MessageUsages type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

MessageUsages Class
RedGate.SQLCompare.Engine Namespace


MessageUsages Methods

[image] [image]

SQL Data Compare API 12.0.40
MessageUsages Methods
MessageUsages Class See Also

The MessageUsages type exposes the following methods.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

MessageUsages Class
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
MessageUsages..::.PatchUpAfterDeserialization Method
MessageUsages Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

MessageUsages Class
RedGate.SQLCompare.Engine Namespace


MigScriptPlugMessageDecorator Class

[image]

SQL Data Compare API 12.0.40
MigScriptPlugMessageDecorator Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class MigScriptPlugMessageDecorator _
    Inherits MessageBase
C#
public class MigScriptPlugMessageDecorator : MessageBase
Visual C++
public ref class MigScriptPlugMessageDecorator : public MessageBase

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.MessageBase
RedGate.SQLCompare.Engine..::.MigScriptPlugMessageDecorator

See Also

MigScriptPlugMessageDecorator Members
RedGate.SQLCompare.Engine Namespace


MigScriptPlugMessageDecorator Members

[image] [image]

SQL Data Compare API 12.0.40
MigScriptPlugMessageDecorator Members
MigScriptPlugMessageDecorator Class Constructors Methods Fields Properties See Also

The MigScriptPlugMessageDecorator type exposes the following members.

Constructors

Name | Description
MigScriptPlugMessageDecorator |

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from MessageBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_IDatabaseObject | (Inherited from MessageBase.)
m_MessageTypeID | (Inherited from MessageBase.)
m_Severity | (Inherited from MessageBase.)
m_Text | (Inherited from MessageBase.)

Properties

Name | Description
DatabaseObject | (Overrides MessageBase ..::. DatabaseObject.)
HelpURL | (Overrides MessageBase ..::. HelpURL.)
MessageTypeID | (Overrides MessageBase ..::. MessageTypeID.)
Text | (Overrides MessageBase ..::. Text.)
WarningSeverity | (Overrides MessageBase ..::. WarningSeverity.)

See Also

MigScriptPlugMessageDecorator Class
RedGate.SQLCompare.Engine Namespace


MigScriptPlugMessageDecorator Constructor

[image]

SQL Data Compare API 12.0.40
MigScriptPlugMessageDecorator Constructor
MigScriptPlugMessageDecorator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As IDeploymentMessage _
)
C#
public MigScriptPlugMessageDecorator(
    IDeploymentMessage message
)
Visual C++
public:
MigScriptPlugMessageDecorator(
    IDeploymentMessage^ message
)

Parameters

message
Type: IDeploymentMessage

See Also

MigScriptPlugMessageDecorator Class
RedGate.SQLCompare.Engine Namespace


MigScriptPlugMessageDecorator Properties

[image] [image]

SQL Data Compare API 12.0.40
MigScriptPlugMessageDecorator Properties
MigScriptPlugMessageDecorator Class See Also

The MigScriptPlugMessageDecorator type exposes the following properties.

Properties

Name | Description
DatabaseObject | (Overrides MessageBase ..::. DatabaseObject.)
HelpURL | (Overrides MessageBase ..::. HelpURL.)
MessageTypeID | (Overrides MessageBase ..::. MessageTypeID.)
Text | (Overrides MessageBase ..::. Text.)
WarningSeverity | (Overrides MessageBase ..::. WarningSeverity.)

See Also

MigScriptPlugMessageDecorator Class
RedGate.SQLCompare.Engine Namespace


DatabaseObject Property

[image]

SQL Data Compare API 12.0.40
MigScriptPlugMessageDecorator..::.DatabaseObject Property
MigScriptPlugMessageDecorator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property DatabaseObject As ITSqlObject
C#
public override ITSqlObject DatabaseObject { get; }
Visual C++
public:
virtual property ITSqlObject^ DatabaseObject {
    ITSqlObject^ get () override;
}

Implements

IDeploymentMessageDatabaseObject()()()

See Also

MigScriptPlugMessageDecorator Class
RedGate.SQLCompare.Engine Namespace


HelpURL Property

[image]

SQL Data Compare API 12.0.40
MigScriptPlugMessageDecorator..::.HelpURL Property
MigScriptPlugMessageDecorator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property HelpURL As String
C#
public override string HelpURL { get; set; }
Visual C++
public:
virtual property String^ HelpURL {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IDeploymentMessageHelpURL()()()

See Also

MigScriptPlugMessageDecorator Class
RedGate.SQLCompare.Engine Namespace


MessageTypeID Property

[image]

SQL Data Compare API 12.0.40
MigScriptPlugMessageDecorator..::.MessageTypeID Property
MigScriptPlugMessageDecorator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property MessageTypeID As String
C#
public override string MessageTypeID { get; }
Visual C++
public:
virtual property String^ MessageTypeID {
    String^ get () override;
}

Implements

IDeploymentMessageMessageTypeID()()()

See Also

MigScriptPlugMessageDecorator Class
RedGate.SQLCompare.Engine Namespace


Text Property

[image]

SQL Data Compare API 12.0.40
MigScriptPlugMessageDecorator..::.Text Property
MigScriptPlugMessageDecorator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Text As String
C#
public override string Text { get; }
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
}

Implements

IDeploymentMessageText()()()

See Also

MigScriptPlugMessageDecorator Class
RedGate.SQLCompare.Engine Namespace


WarningSeverity Property

[image]

SQL Data Compare API 12.0.40
MigScriptPlugMessageDecorator..::.WarningSeverity Property
MigScriptPlugMessageDecorator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property WarningSeverity As WarningSeverity
C#
public override WarningSeverity WarningSeverity { get; }
Visual C++
public:
virtual property WarningSeverity WarningSeverity {
    WarningSeverity get () override;
}

Implements

IDeploymentMessageWarningSeverity()()()

See Also

MigScriptPlugMessageDecorator Class
RedGate.SQLCompare.Engine Namespace


NewDataTypesFormatting Class

[image]

SQL Data Compare API 12.0.40
NewDataTypesFormatting Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class NewDataTypesFormatting
C#
public static class NewDataTypesFormatting
Visual C++
public ref class NewDataTypesFormatting abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.NewDataTypesFormatting

See Also

NewDataTypesFormatting Members
RedGate.SQLCompare.Engine Namespace


NewDataTypesFormatting Members

[image] [image]

SQL Data Compare API 12.0.40
NewDataTypesFormatting Members
NewDataTypesFormatting Class Methods See Also

The NewDataTypesFormatting type exposes the following members.

Methods

Name | Description
GetBinaryDateString |
GetBinaryDateTime2String |
GetBinaryDateTimeOffsetString |
GetBinaryTimeString |

See Also

NewDataTypesFormatting Class
RedGate.SQLCompare.Engine Namespace


NewDataTypesFormatting Methods

[image] [image]

SQL Data Compare API 12.0.40
NewDataTypesFormatting Methods
NewDataTypesFormatting Class See Also

The NewDataTypesFormatting type exposes the following methods.

Methods

Name | Description
GetBinaryDateString |
GetBinaryDateTime2String |
GetBinaryDateTimeOffsetString |
GetBinaryTimeString |

See Also

NewDataTypesFormatting Class
RedGate.SQLCompare.Engine Namespace


GetBinaryDateString Method

[image]

SQL Data Compare API 12.0.40
NewDataTypesFormatting..::.GetBinaryDateString Method
NewDataTypesFormatting Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetBinaryDateString ( _
    data As Byte() _
) As String
C#
public static string GetBinaryDateString(
    byte[] data
)
Visual C++
public:
static String^ GetBinaryDateString(
    array<unsigned char>^ data
)

Parameters

data
Type: array<Byte>[]()[]

See Also

NewDataTypesFormatting Class
RedGate.SQLCompare.Engine Namespace


GetBinaryDateTime2String Method

[image]

SQL Data Compare API 12.0.40
NewDataTypesFormatting..::.GetBinaryDateTime2String Method
NewDataTypesFormatting Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetBinaryDateTime2String ( _
    data As Byte(), _
    prec As Byte, _
    len As Byte, _
    scale As Byte _
) As String
C#
public static string GetBinaryDateTime2String(
    byte[] data,
    byte prec,
    byte len,
    byte scale
)
Visual C++
public:
static String^ GetBinaryDateTime2String(
    array<unsigned char>^ data,
    unsigned char prec,
    unsigned char len,
    unsigned char scale
)

Parameters

data
Type: array<Byte>[]()[]
prec
Type: Byte
len
Type: Byte
scale
Type: Byte

See Also

NewDataTypesFormatting Class
RedGate.SQLCompare.Engine Namespace


GetBinaryDateTimeOffsetString Method

[image]

SQL Data Compare API 12.0.40
NewDataTypesFormatting..::.GetBinaryDateTimeOffsetString Method
NewDataTypesFormatting Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetBinaryDateTimeOffsetString ( _
    data As Byte(), _
    prec As Byte, _
    len As Byte, _
    scale As Byte _
) As String
C#
public static string GetBinaryDateTimeOffsetString(
    byte[] data,
    byte prec,
    byte len,
    byte scale
)
Visual C++
public:
static String^ GetBinaryDateTimeOffsetString(
    array<unsigned char>^ data,
    unsigned char prec,
    unsigned char len,
    unsigned char scale
)

Parameters

data
Type: array<Byte>[]()[]
prec
Type: Byte
len
Type: Byte
scale
Type: Byte

See Also

NewDataTypesFormatting Class
RedGate.SQLCompare.Engine Namespace


GetBinaryTimeString Method

[image]

SQL Data Compare API 12.0.40
NewDataTypesFormatting..::.GetBinaryTimeString Method
NewDataTypesFormatting Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetBinaryTimeString ( _
    data As Byte(), _
    prec As Byte, _
    len As Byte, _
    scale As Byte _
) As String
C#
public static string GetBinaryTimeString(
    byte[] data,
    byte prec,
    byte len,
    byte scale
)
Visual C++
public:
static String^ GetBinaryTimeString(
    array<unsigned char>^ data,
    unsigned char prec,
    unsigned char len,
    unsigned char scale
)

Parameters

data
Type: array<Byte>[]()[]
prec
Type: Byte
len
Type: Byte
scale
Type: Byte

See Also

NewDataTypesFormatting Class
RedGate.SQLCompare.Engine Namespace


ObjectCollections Class

[image]

SQL Data Compare API 12.0.40
ObjectCollections Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class ObjectCollections _
    Implements IDatabaseObjects, IDisposable, IFullDatabaseObjects
C#
public abstract class ObjectCollections : IDatabaseObjects,
    IDisposable, IFullDatabaseObjects
Visual C++
public ref class ObjectCollections abstract : IDatabaseObjects,
    IDisposable, IFullDatabaseObjects

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ObjectCollections
RedGate.SQLCompare.Engine..::.Database

See Also

ObjectCollections Members
RedGate.SQLCompare.Engine Namespace


ObjectCollections Members

[image] [image]

SQL Data Compare API 12.0.40
ObjectCollections Members
ObjectCollections Class Constructors Methods Fields Properties See Also

The ObjectCollections type exposes the following members.

Constructors

Name | Description
ObjectCollections |

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllObjects |
GetDatabaseObject | Overloaded.
GetDatabaseObjects<(Of <(T>)>) |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectCollectionByType | Returns a readonly collection of database objects, of the specified type.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_Assemblies |
m_AssemblyDependencies |
m_AssemblyDependenciesBuilder |
m_AsymmetricKeys |
m_Certificates |
m_Contracts |
m_DdlTriggers |
m_Defaults |
m_Dependencies |
m_DependenciesBuilder |
m_EventNotifications |
m_ExtendedProperties |
m_ForeignKeys |
m_FullTextCatalogs |
m_FullTextStoplists |
m_Functions |
m_License |
m_MessageTypes |
m_PartitionFunctions |
m_PartitionSchemes |
m_Queues |
m_Roles |
m_Routes |
m_Rules |
m_Schemas |
m_SearchPropertyLists |
m_SecondaryDatabases |
m_SecurityPolicies |
m_Sequences |
m_ServiceBindings |
m_Services |
m_StoredProcedures |
m_SymmetricKeys |
m_Synonyms |
m_Tables |
m_Triggers |
m_UserDefinedTypes |
m_Users |
m_Views |
m_XmlSchemaCollections |
s_ObjectCollectionTypes |
s_ObjectTypesWithNoCollection |

Properties

Name | Description
Assemblies | The CLR assemblies in the database. Note that CLR assemblies were introduced in SQL Server 2005.
AsymmetricKeys | The asymmetric keys in the database. Note that asymmetric keys were introduced in SQL Server 2005.
Certificates | The certificates in the database. Note that certificates were introduced in SQL Server 2005.
Contracts | The contracts in the database. Note that contracts were introduced in SQL Server 2005.
DdlTriggers | The DDL triggers in the database.
Defaults | The defaults in the database.
EventNotifications | The database-level event notifications in the database. Note that event notifications were introduced in SQL Server 2005.
ExtendedProperties | Database-level extended properties.
FullTextCatalogs | The full-text catalogs in the database.
FullTextStoplists | The full-text stoplists in the database.
Functions | The user-defined functions in the database.
m_AssemblyData |
m_Comments |
m_XMLSchemaData |
MessageTypes | The message types in the database. Note that message types were introduced in SQL Server 2005.
PartitionFunctions | The partition functions in the database. Note that partition functions were introduced in SQL Server 2005.
PartitionSchemes | The partition schemes in the database. Note that partitions schemes were introduced in SQL Server 2005.
Queues | The queues in the database. Note that queues were introduced in SQL Server 2005.
Roles | The roles in the database.
Routes | The routes in the database. Note that routes were introduced in SQL Server 2005.
Rules | The rules in the database.
Schemas | The schemas in the database. Note that schemas were introduced in SQL Server 2005.
SearchPropertyLists |
SecurityPolicies | The security policies in the database.
Sequences | The sequence objects in the database. Note that these were introduced in SQL Server 2012
ServiceBindings | The service bindings in the database. Note that service bindings were introduced in SQL Server 2005.
Services | The services in the database. Note that services were introduced in SQL Server 2005.
StoredProcedures | The stored procedures in the database.
SymmetricKeys | The symmetric keys in the database. Note that symmetric keys were introduced in SQL Server 2005.
Synonyms | The synonyms in the database. Note that synonyms were introduced in SQL Server 2005.
Tables | The tables in the database.
TotalObjectCount |
UserDefinedTypes | The user-defined types in the database.
Users | The users in the database.
Views | The views in the database.
XmlSchemaCollections | The XML schema collections in the database. Note that XML schema collections were introduced in SQL Server 2005.

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


ObjectCollections Constructor

[image]

SQL Data Compare API 12.0.40
ObjectCollections Constructor
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected ObjectCollections()
Visual C++
protected:
ObjectCollections()

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


ObjectCollections Fields

[image] [image]

SQL Data Compare API 12.0.40
ObjectCollections Fields
ObjectCollections Class See Also

The ObjectCollections type exposes the following fields.

Fields

Name | Description
m_Assemblies |
m_AssemblyDependencies |
m_AssemblyDependenciesBuilder |
m_AsymmetricKeys |
m_Certificates |
m_Contracts |
m_DdlTriggers |
m_Defaults |
m_Dependencies |
m_DependenciesBuilder |
m_EventNotifications |
m_ExtendedProperties |
m_ForeignKeys |
m_FullTextCatalogs |
m_FullTextStoplists |
m_Functions |
m_License |
m_MessageTypes |
m_PartitionFunctions |
m_PartitionSchemes |
m_Queues |
m_Roles |
m_Routes |
m_Rules |
m_Schemas |
m_SearchPropertyLists |
m_SecondaryDatabases |
m_SecurityPolicies |
m_Sequences |
m_ServiceBindings |
m_Services |
m_StoredProcedures |
m_SymmetricKeys |
m_Synonyms |
m_Tables |
m_Triggers |
m_UserDefinedTypes |
m_Users |
m_Views |
m_XmlSchemaCollections |
s_ObjectCollectionTypes |
s_ObjectTypesWithNoCollection |

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_Assemblies Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_Assemblies Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Assemblies As ClrAssemblies
C#
protected ClrAssemblies m_Assemblies
Visual C++
protected:
ClrAssemblies^ m_Assemblies

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_AssemblyDependencies Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_AssemblyDependencies Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_AssemblyDependencies As Dependencies
C#
protected Dependencies m_AssemblyDependencies
Visual C++
protected:
Dependencies^ m_AssemblyDependencies

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_AssemblyDependenciesBuilder Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_AssemblyDependenciesBuilder Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_AssemblyDependenciesBuilder As DependenciesBuilder
C#
protected DependenciesBuilder m_AssemblyDependenciesBuilder
Visual C++
protected:
DependenciesBuilder^ m_AssemblyDependenciesBuilder

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_AsymmetricKeys Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_AsymmetricKeys Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_AsymmetricKeys As AsymmetricKeys
C#
protected AsymmetricKeys m_AsymmetricKeys
Visual C++
protected:
AsymmetricKeys^ m_AsymmetricKeys

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_Certificates Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_Certificates Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Certificates As Certificates
C#
protected Certificates m_Certificates
Visual C++
protected:
Certificates^ m_Certificates

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_Contracts Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_Contracts Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Contracts As Contracts
C#
protected Contracts m_Contracts
Visual C++
protected:
Contracts^ m_Contracts

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_DdlTriggers Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_DdlTriggers Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_DdlTriggers As DdlTriggers
C#
protected DdlTriggers m_DdlTriggers
Visual C++
protected:
DdlTriggers^ m_DdlTriggers

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_Defaults Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_Defaults Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Defaults As Defaults
C#
protected Defaults m_Defaults
Visual C++
protected:
Defaults^ m_Defaults

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_Dependencies Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_Dependencies Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Dependencies As Dependencies
C#
protected Dependencies m_Dependencies
Visual C++
protected:
Dependencies^ m_Dependencies

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_DependenciesBuilder Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_DependenciesBuilder Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_DependenciesBuilder As DependenciesBuilder
C#
protected DependenciesBuilder m_DependenciesBuilder
Visual C++
protected:
DependenciesBuilder^ m_DependenciesBuilder

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_EventNotifications Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_EventNotifications Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_EventNotifications As EventNotifications
C#
protected EventNotifications m_EventNotifications
Visual C++
protected:
EventNotifications^ m_EventNotifications

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_ExtendedProperties Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_ExtendedProperties Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_ExtendedProperties As ExtendedProperties
C#
protected ExtendedProperties m_ExtendedProperties
Visual C++
protected:
ExtendedProperties^ m_ExtendedProperties

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_ForeignKeys Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_ForeignKeys Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_ForeignKeys As ForeignKeys
C#
protected ForeignKeys m_ForeignKeys
Visual C++
protected:
ForeignKeys^ m_ForeignKeys

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_FullTextCatalogs Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_FullTextCatalogs Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_FullTextCatalogs As FullTextCatalogs
C#
protected FullTextCatalogs m_FullTextCatalogs
Visual C++
protected:
FullTextCatalogs^ m_FullTextCatalogs

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_FullTextStoplists Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_FullTextStoplists Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_FullTextStoplists As FullTextStoplists
C#
protected FullTextStoplists m_FullTextStoplists
Visual C++
protected:
FullTextStoplists^ m_FullTextStoplists

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_Functions Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_Functions Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Functions As Functions
C#
protected Functions m_Functions
Visual C++
protected:
Functions^ m_Functions

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_License Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_License Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_License As License
C#
protected License m_License
Visual C++
protected:
License^ m_License

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_MessageTypes Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_MessageTypes Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_MessageTypes As MessageTypes
C#
protected MessageTypes m_MessageTypes
Visual C++
protected:
MessageTypes^ m_MessageTypes

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_PartitionFunctions Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_PartitionFunctions Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_PartitionFunctions As PartitionFunctions
C#
protected PartitionFunctions m_PartitionFunctions
Visual C++
protected:
PartitionFunctions^ m_PartitionFunctions

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_PartitionSchemes Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_PartitionSchemes Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_PartitionSchemes As PartitionSchemes
C#
protected PartitionSchemes m_PartitionSchemes
Visual C++
protected:
PartitionSchemes^ m_PartitionSchemes

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_Queues Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_Queues Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Queues As Queues
C#
protected Queues m_Queues
Visual C++
protected:
Queues^ m_Queues

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_Roles Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_Roles Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Roles As Roles
C#
protected Roles m_Roles
Visual C++
protected:
Roles^ m_Roles

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_Routes Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_Routes Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Routes As Routes
C#
protected Routes m_Routes
Visual C++
protected:
Routes^ m_Routes

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_Rules Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_Rules Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Rules As Rules
C#
protected Rules m_Rules
Visual C++
protected:
Rules^ m_Rules

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_Schemas Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_Schemas Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Schemas As Schemas
C#
protected Schemas m_Schemas
Visual C++
protected:
Schemas^ m_Schemas

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_SearchPropertyLists Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_SearchPropertyLists Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_SearchPropertyLists As SearchPropertyLists
C#
protected SearchPropertyLists m_SearchPropertyLists
Visual C++
protected:
SearchPropertyLists^ m_SearchPropertyLists

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_SecondaryDatabases Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_SecondaryDatabases Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_SecondaryDatabases As List(Of Database)
C#
protected List<Database> m_SecondaryDatabases
Visual C++
protected:
List<Database^>^ m_SecondaryDatabases

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_SecurityPolicies Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_SecurityPolicies Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_SecurityPolicies As DatabaseObjectCollection(Of SecurityPolicy)
C#
protected DatabaseObjectCollection<SecurityPolicy> m_SecurityPolicies
Visual C++
protected:
DatabaseObjectCollection<SecurityPolicy^>^ m_SecurityPolicies

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_Sequences Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_Sequences Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Sequences As Sequences
C#
protected Sequences m_Sequences
Visual C++
protected:
Sequences^ m_Sequences

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_ServiceBindings Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_ServiceBindings Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_ServiceBindings As ServiceBindings
C#
protected ServiceBindings m_ServiceBindings
Visual C++
protected:
ServiceBindings^ m_ServiceBindings

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_Services Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_Services Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Services As Services
C#
protected Services m_Services
Visual C++
protected:
Services^ m_Services

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_StoredProcedures Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_StoredProcedures Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_StoredProcedures As StoredProcedures
C#
protected StoredProcedures m_StoredProcedures
Visual C++
protected:
StoredProcedures^ m_StoredProcedures

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_SymmetricKeys Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_SymmetricKeys Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_SymmetricKeys As SymmetricKeys
C#
protected SymmetricKeys m_SymmetricKeys
Visual C++
protected:
SymmetricKeys^ m_SymmetricKeys

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_Synonyms Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_Synonyms Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Synonyms As Synonyms
C#
protected Synonyms m_Synonyms
Visual C++
protected:
Synonyms^ m_Synonyms

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_Tables Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_Tables Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Tables As Tables
C#
protected Tables m_Tables
Visual C++
protected:
Tables^ m_Tables

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_Triggers Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_Triggers Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Triggers As Triggers
C#
protected Triggers m_Triggers
Visual C++
protected:
Triggers^ m_Triggers

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_UserDefinedTypes Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_UserDefinedTypes Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_UserDefinedTypes As UserDefinedTypes
C#
protected UserDefinedTypes m_UserDefinedTypes
Visual C++
protected:
UserDefinedTypes^ m_UserDefinedTypes

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_Users Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_Users Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Users As Users
C#
protected Users m_Users
Visual C++
protected:
Users^ m_Users

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_Views Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_Views Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Views As Views
C#
protected Views m_Views
Visual C++
protected:
Views^ m_Views

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_XmlSchemaCollections Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_XmlSchemaCollections Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_XmlSchemaCollections As XmlSchemaCollections
C#
protected XmlSchemaCollections m_XmlSchemaCollections
Visual C++
protected:
XmlSchemaCollections^ m_XmlSchemaCollections

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


s_ObjectCollectionTypes Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.s_ObjectCollectionTypes Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Shared s_ObjectCollectionTypes As IEnumerable(Of ObjectType)
C#
protected static IEnumerable<ObjectType> s_ObjectCollectionTypes
Visual C++
protected:
static IEnumerable<ObjectType>^ s_ObjectCollectionTypes

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


s_ObjectTypesWithNoCollection Field

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.s_ObjectTypesWithNoCollection Field
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Shared ReadOnly s_ObjectTypesWithNoCollection As ObjectType()
C#
protected static readonly ObjectType[] s_ObjectTypesWithNoCollection
Visual C++
protected:
static initonly array<ObjectType>^ s_ObjectTypesWithNoCollection

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


ObjectCollections Methods

[image] [image]

SQL Data Compare API 12.0.40
ObjectCollections Methods
ObjectCollections Class See Also

The ObjectCollections type exposes the following methods.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllObjects |
GetDatabaseObject | Overloaded.
GetDatabaseObjects<(Of <(T>)>) |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectCollectionByType | Returns a readonly collection of database objects, of the specified type.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


Dispose Method

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.Dispose Method
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Dispose
C#
public abstract void Dispose()
Visual C++
public:
virtual void Dispose() abstract

Implements

IDisposableDispose()()()

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


GetAllObjects Method

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.GetAllObjects Method
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetAllObjects As IEnumerable(Of IDatabaseObject)
C#
public IEnumerable<IDatabaseObject> GetAllObjects()
Visual C++
public:
virtual IEnumerable<IDatabaseObject^>^ GetAllObjects() sealed

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


GetDatabaseObject Method

[image] [image]

SQL Data Compare API 12.0.40
ObjectCollections..::.GetDatabaseObject Method
ObjectCollections Class See Also

Overload List

Name | Description
GetDatabaseObject(String) | Get database object by two-part name
GetDatabaseObject(String, ObjectType) |

See Also

ObjectCollections Class
ObjectCollections Members
RedGate.SQLCompare.Engine Namespace


GetDatabaseObject Method ()

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.GetDatabaseObject Method ()
ObjectCollections Class See Also

Get database object by two-part name

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDatabaseObject ( _
    name As String _
) As IDatabaseObject
C#
public IDatabaseObject GetDatabaseObject(
    string name
)
Visual C++
public:
IDatabaseObject^ GetDatabaseObject(
    String^ name
)

Parameters

name
Type: String
The name of the object to find in the whole database

Return Value

The object if found, NULL on not found

See Also

ObjectCollections Class
GetDatabaseObject Overload
RedGate.SQLCompare.Engine Namespace


GetDatabaseObject Method (, )

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.GetDatabaseObject Method (, )
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDatabaseObject ( _
    name As String, _
    type As ObjectType _
) As IDatabaseObject
C#
public IDatabaseObject GetDatabaseObject(
    string name,
    ObjectType type
)
Visual C++
public:
virtual IDatabaseObject^ GetDatabaseObject(
    String^ name,
    ObjectType type
) sealed

Parameters

name
Type: String
type
Type: ObjectType

Implements

IDatabaseObjects..::.GetDatabaseObject(String, ObjectType)
IFullDatabaseObjects..::.GetDatabaseObject(String, ObjectType)

See Also

ObjectCollections Class
GetDatabaseObject Overload
RedGate.SQLCompare.Engine Namespace


GetDatabaseObjects(T) Generic Method

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.GetDatabaseObjects<(Of <(T>)>) Generic Method
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDatabaseObjects(Of T As IDatabaseObject) As IDatabaseObjects(Of T)
C#
public IDatabaseObjects<T> GetDatabaseObjects<T>() where T : IDatabaseObject
Visual C++
public:
generic<typename T>
where T : IDatabaseObject
virtual IDatabaseObjects<T>^ GetDatabaseObjects() sealed

Type Parameters

T

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


GetObjectCollectionByType Method

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.GetObjectCollectionByType Method
ObjectCollections Class See Also

Returns a readonly collection of database objects, of the specified type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetObjectCollectionByType ( _
    type As ObjectType _
) As INonReadOnlyCollection
C#
public INonReadOnlyCollection GetObjectCollectionByType(
    ObjectType type
)
Visual C++
public:
INonReadOnlyCollection^ GetObjectCollectionByType(
    ObjectType type
)

Parameters

type
Type: ObjectType

Return Value

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


ObjectCollections Properties

[image] [image]

SQL Data Compare API 12.0.40
ObjectCollections Properties
ObjectCollections Class See Also

The ObjectCollections type exposes the following properties.

Properties

Name | Description
Assemblies | The CLR assemblies in the database. Note that CLR assemblies were introduced in SQL Server 2005.
AsymmetricKeys | The asymmetric keys in the database. Note that asymmetric keys were introduced in SQL Server 2005.
Certificates | The certificates in the database. Note that certificates were introduced in SQL Server 2005.
Contracts | The contracts in the database. Note that contracts were introduced in SQL Server 2005.
DdlTriggers | The DDL triggers in the database.
Defaults | The defaults in the database.
EventNotifications | The database-level event notifications in the database. Note that event notifications were introduced in SQL Server 2005.
ExtendedProperties | Database-level extended properties.
FullTextCatalogs | The full-text catalogs in the database.
FullTextStoplists | The full-text stoplists in the database.
Functions | The user-defined functions in the database.
m_AssemblyData |
m_Comments |
m_XMLSchemaData |
MessageTypes | The message types in the database. Note that message types were introduced in SQL Server 2005.
PartitionFunctions | The partition functions in the database. Note that partition functions were introduced in SQL Server 2005.
PartitionSchemes | The partition schemes in the database. Note that partitions schemes were introduced in SQL Server 2005.
Queues | The queues in the database. Note that queues were introduced in SQL Server 2005.
Roles | The roles in the database.
Routes | The routes in the database. Note that routes were introduced in SQL Server 2005.
Rules | The rules in the database.
Schemas | The schemas in the database. Note that schemas were introduced in SQL Server 2005.
SearchPropertyLists |
SecurityPolicies | The security policies in the database.
Sequences | The sequence objects in the database. Note that these were introduced in SQL Server 2012
ServiceBindings | The service bindings in the database. Note that service bindings were introduced in SQL Server 2005.
Services | The services in the database. Note that services were introduced in SQL Server 2005.
StoredProcedures | The stored procedures in the database.
SymmetricKeys | The symmetric keys in the database. Note that symmetric keys were introduced in SQL Server 2005.
Synonyms | The synonyms in the database. Note that synonyms were introduced in SQL Server 2005.
Tables | The tables in the database.
TotalObjectCount |
UserDefinedTypes | The user-defined types in the database.
Users | The users in the database.
Views | The views in the database.
XmlSchemaCollections | The XML schema collections in the database. Note that XML schema collections were introduced in SQL Server 2005.

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


Assemblies Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.Assemblies Property
ObjectCollections Class See Also

The CLR assemblies in the database. Note that CLR assemblies were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Assemblies As ClrAssemblies
C#
public ClrAssemblies Assemblies { get; }
Visual C++
public:
virtual property ClrAssemblies^ Assemblies {
    ClrAssemblies^ get () sealed;
}

Implements

IDatabaseObjects..::.Assemblies
IFullDatabaseObjects..::.Assemblies

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


AsymmetricKeys Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.AsymmetricKeys Property
ObjectCollections Class See Also

The asymmetric keys in the database. Note that asymmetric keys were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AsymmetricKeys As AsymmetricKeys
C#
public AsymmetricKeys AsymmetricKeys { get; }
Visual C++
public:
virtual property AsymmetricKeys^ AsymmetricKeys {
    AsymmetricKeys^ get () sealed;
}

Implements

IDatabaseObjects..::.AsymmetricKeys
IFullDatabaseObjects..::.AsymmetricKeys

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


Certificates Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.Certificates Property
ObjectCollections Class See Also

The certificates in the database. Note that certificates were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Certificates As Certificates
C#
public Certificates Certificates { get; }
Visual C++
public:
virtual property Certificates^ Certificates {
    Certificates^ get () sealed;
}

Implements

IDatabaseObjects..::.Certificates
IFullDatabaseObjects..::.Certificates

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


Contracts Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.Contracts Property
ObjectCollections Class See Also

The contracts in the database. Note that contracts were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Contracts As Contracts
C#
public Contracts Contracts { get; }
Visual C++
public:
virtual property Contracts^ Contracts {
    Contracts^ get () sealed;
}

Implements

IDatabaseObjects..::.Contracts
IFullDatabaseObjects..::.Contracts

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


DdlTriggers Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.DdlTriggers Property
ObjectCollections Class See Also

The DDL triggers in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DdlTriggers As DdlTriggers
C#
public DdlTriggers DdlTriggers { get; }
Visual C++
public:
virtual property DdlTriggers^ DdlTriggers {
    DdlTriggers^ get () sealed;
}

Implements

IDatabaseObjects..::.DdlTriggers
IFullDatabaseObjects..::.DdlTriggers

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


Defaults Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.Defaults Property
ObjectCollections Class See Also

The defaults in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Defaults As Defaults
C#
public Defaults Defaults { get; }
Visual C++
public:
virtual property Defaults^ Defaults {
    Defaults^ get () sealed;
}

Implements

IDatabaseObjects..::.Defaults
IFullDatabaseObjects..::.Defaults

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


EventNotifications Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.EventNotifications Property
ObjectCollections Class See Also

The database-level event notifications in the database. Note that event notifications were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EventNotifications As EventNotifications
C#
public EventNotifications EventNotifications { get; }
Visual C++
public:
virtual property EventNotifications^ EventNotifications {
    EventNotifications^ get () sealed;
}

Implements

IDatabaseObjects..::.EventNotifications
IFullDatabaseObjects..::.EventNotifications

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


ExtendedProperties Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.ExtendedProperties Property
ObjectCollections Class See Also

Database-level extended properties.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedProperties As ExtendedProperties
C#
public ExtendedProperties ExtendedProperties { get; internal set; }
Visual C++
public:
virtual property ExtendedProperties^ ExtendedProperties {
    ExtendedProperties^ get () sealed;
    void set (ExtendedProperties^ value) sealed;
}

Implements

IDatabaseObjects..::.ExtendedProperties
IFullDatabaseObjects..::.ExtendedProperties

Remarks

The collection contains extended properties that have been defined at the database level. Individual database objects (such as tables and users) can also have extended properties defined on them.

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


FullTextCatalogs Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.FullTextCatalogs Property
ObjectCollections Class See Also

The full-text catalogs in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullTextCatalogs As FullTextCatalogs
C#
public FullTextCatalogs FullTextCatalogs { get; }
Visual C++
public:
virtual property FullTextCatalogs^ FullTextCatalogs {
    FullTextCatalogs^ get () sealed;
}

Implements

IDatabaseObjects..::.FullTextCatalogs
IFullDatabaseObjects..::.FullTextCatalogs

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


FullTextStoplists Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.FullTextStoplists Property
ObjectCollections Class See Also

The full-text stoplists in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullTextStoplists As FullTextStoplists
C#
public FullTextStoplists FullTextStoplists { get; }
Visual C++
public:
virtual property FullTextStoplists^ FullTextStoplists {
    FullTextStoplists^ get () sealed;
}

Implements

IDatabaseObjects..::.FullTextStoplists
IFullDatabaseObjects..::.FullTextStoplists

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


Functions Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.Functions Property
ObjectCollections Class See Also

The user-defined functions in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Functions As Functions
C#
public Functions Functions { get; }
Visual C++
public:
virtual property Functions^ Functions {
    Functions^ get () sealed;
}

Implements

IDatabaseObjects..::.Functions
IFullDatabaseObjects..::.Functions

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_AssemblyData Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_AssemblyData Property
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Property m_AssemblyData As SerializableBlobStore
C#
protected SerializableBlobStore m_AssemblyData { get; set; }
Visual C++
protected:
property SerializableBlobStore^ m_AssemblyData {
    SerializableBlobStore^ get ();
    void set (SerializableBlobStore^ value);
}

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_Comments Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_Comments Property
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Property m_Comments As SerializableBlobStore
C#
protected SerializableBlobStore m_Comments { get; set; }
Visual C++
protected:
property SerializableBlobStore^ m_Comments {
    SerializableBlobStore^ get ();
    void set (SerializableBlobStore^ value);
}

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


m_XMLSchemaData Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.m_XMLSchemaData Property
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Property m_XMLSchemaData As SerializableBlobStore
C#
protected SerializableBlobStore m_XMLSchemaData { get; set; }
Visual C++
protected:
property SerializableBlobStore^ m_XMLSchemaData {
    SerializableBlobStore^ get ();
    void set (SerializableBlobStore^ value);
}

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


MessageTypes Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.MessageTypes Property
ObjectCollections Class See Also

The message types in the database. Note that message types were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MessageTypes As MessageTypes
C#
public MessageTypes MessageTypes { get; }
Visual C++
public:
virtual property MessageTypes^ MessageTypes {
    MessageTypes^ get () sealed;
}

Implements

IDatabaseObjects..::.MessageTypes
IFullDatabaseObjects..::.MessageTypes

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


PartitionFunctions Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.PartitionFunctions Property
ObjectCollections Class See Also

The partition functions in the database. Note that partition functions were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PartitionFunctions As PartitionFunctions
C#
public PartitionFunctions PartitionFunctions { get; }
Visual C++
public:
virtual property PartitionFunctions^ PartitionFunctions {
    PartitionFunctions^ get () sealed;
}

Implements

IDatabaseObjects..::.PartitionFunctions
IFullDatabaseObjects..::.PartitionFunctions

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


PartitionSchemes Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.PartitionSchemes Property
ObjectCollections Class See Also

The partition schemes in the database. Note that partitions schemes were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PartitionSchemes As PartitionSchemes
C#
public PartitionSchemes PartitionSchemes { get; }
Visual C++
public:
virtual property PartitionSchemes^ PartitionSchemes {
    PartitionSchemes^ get () sealed;
}

Implements

IDatabaseObjects..::.PartitionSchemes
IFullDatabaseObjects..::.PartitionSchemes

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


Queues Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.Queues Property
ObjectCollections Class See Also

The queues in the database. Note that queues were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queues As Queues
C#
public Queues Queues { get; }
Visual C++
public:
virtual property Queues^ Queues {
    Queues^ get () sealed;
}

Implements

IDatabaseObjects..::.Queues
IFullDatabaseObjects..::.Queues

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


Roles Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.Roles Property
ObjectCollections Class See Also

The roles in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Roles As Roles
C#
public Roles Roles { get; }
Visual C++
public:
virtual property Roles^ Roles {
    Roles^ get () sealed;
}

Implements

IDatabaseObjects..::.Roles
IFullDatabaseObjects..::.Roles

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


Routes Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.Routes Property
ObjectCollections Class See Also

The routes in the database. Note that routes were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Routes As Routes
C#
public Routes Routes { get; }
Visual C++
public:
virtual property Routes^ Routes {
    Routes^ get () sealed;
}

Implements

IDatabaseObjects..::.Routes
IFullDatabaseObjects..::.Routes

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


Rules Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.Rules Property
ObjectCollections Class See Also

The rules in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Rules As Rules
C#
public Rules Rules { get; }
Visual C++
public:
virtual property Rules^ Rules {
    Rules^ get () sealed;
}

Implements

IDatabaseObjects..::.Rules
IFullDatabaseObjects..::.Rules

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


Schemas Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.Schemas Property
ObjectCollections Class See Also

The schemas in the database. Note that schemas were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Schemas As Schemas
C#
public Schemas Schemas { get; }
Visual C++
public:
virtual property Schemas^ Schemas {
    Schemas^ get () sealed;
}

Implements

IDatabaseObjects..::.Schemas
IFullDatabaseObjects..::.Schemas

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


SearchPropertyLists Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.SearchPropertyLists Property
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SearchPropertyLists As SearchPropertyLists
C#
public SearchPropertyLists SearchPropertyLists { get; }
Visual C++
public:
virtual property SearchPropertyLists^ SearchPropertyLists {
    SearchPropertyLists^ get () sealed;
}

Implements

IDatabaseObjects..::.SearchPropertyLists
IFullDatabaseObjects..::.SearchPropertyLists

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


SecurityPolicies Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.SecurityPolicies Property
ObjectCollections Class See Also

The security policies in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SecurityPolicies As DatabaseObjectCollection(Of SecurityPolicy)
C#
public DatabaseObjectCollection<SecurityPolicy> SecurityPolicies { get; }
Visual C++
public:
virtual property DatabaseObjectCollection<SecurityPolicy^>^ SecurityPolicies {
    DatabaseObjectCollection<SecurityPolicy^>^ get () sealed;
}

Implements

IDatabaseObjects..::.SecurityPolicies

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


Sequences Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.Sequences Property
ObjectCollections Class See Also

The sequence objects in the database. Note that these were introduced in SQL Server 2012

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sequences As Sequences
C#
public Sequences Sequences { get; }
Visual C++
public:
virtual property Sequences^ Sequences {
    Sequences^ get () sealed;
}

Implements

IDatabaseObjects..::.Sequences
IFullDatabaseObjects..::.Sequences

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


ServiceBindings Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.ServiceBindings Property
ObjectCollections Class See Also

The service bindings in the database. Note that service bindings were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ServiceBindings As ServiceBindings
C#
public ServiceBindings ServiceBindings { get; }
Visual C++
public:
virtual property ServiceBindings^ ServiceBindings {
    ServiceBindings^ get () sealed;
}

Implements

IDatabaseObjects..::.ServiceBindings
IFullDatabaseObjects..::.ServiceBindings

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


Services Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.Services Property
ObjectCollections Class See Also

The services in the database. Note that services were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Services As Services
C#
public Services Services { get; }
Visual C++
public:
virtual property Services^ Services {
    Services^ get () sealed;
}

Implements

IDatabaseObjects..::.Services
IFullDatabaseObjects..::.Services

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


StoredProcedures Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.StoredProcedures Property
ObjectCollections Class See Also

The stored procedures in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StoredProcedures As StoredProcedures
C#
public StoredProcedures StoredProcedures { get; }
Visual C++
public:
virtual property StoredProcedures^ StoredProcedures {
    StoredProcedures^ get () sealed;
}

Implements

IDatabaseObjects..::.StoredProcedures
IFullDatabaseObjects..::.StoredProcedures

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


SymmetricKeys Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.SymmetricKeys Property
ObjectCollections Class See Also

The symmetric keys in the database. Note that symmetric keys were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SymmetricKeys As SymmetricKeys
C#
public SymmetricKeys SymmetricKeys { get; }
Visual C++
public:
virtual property SymmetricKeys^ SymmetricKeys {
    SymmetricKeys^ get () sealed;
}

Implements

IDatabaseObjects..::.SymmetricKeys
IFullDatabaseObjects..::.SymmetricKeys

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


Synonyms Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.Synonyms Property
ObjectCollections Class See Also

The synonyms in the database. Note that synonyms were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Synonyms As Synonyms
C#
public Synonyms Synonyms { get; }
Visual C++
public:
virtual property Synonyms^ Synonyms {
    Synonyms^ get () sealed;
}

Implements

IDatabaseObjects..::.Synonyms
IFullDatabaseObjects..::.Synonyms

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


Tables Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.Tables Property
ObjectCollections Class See Also

The tables in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Tables As Tables
C#
public Tables Tables { get; }
Visual C++
public:
virtual property Tables^ Tables {
    Tables^ get () sealed;
}

Implements

IDatabaseObjects..::.Tables
IFullDatabaseObjects..::.Tables

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


TotalObjectCount Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.TotalObjectCount Property
ObjectCollections Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TotalObjectCount As Integer
C#
public int TotalObjectCount { get; }
Visual C++
public:
virtual property int TotalObjectCount {
    int get () sealed;
}

Implements

IFullDatabaseObjects..::.TotalObjectCount

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


UserDefinedTypes Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.UserDefinedTypes Property
ObjectCollections Class See Also

The user-defined types in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UserDefinedTypes As UserDefinedTypes
C#
public UserDefinedTypes UserDefinedTypes { get; }
Visual C++
public:
virtual property UserDefinedTypes^ UserDefinedTypes {
    UserDefinedTypes^ get () sealed;
}

Implements

IDatabaseObjects..::.UserDefinedTypes
IFullDatabaseObjects..::.UserDefinedTypes

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


Users Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.Users Property
ObjectCollections Class See Also

The users in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Users As Users
C#
public Users Users { get; }
Visual C++
public:
virtual property Users^ Users {
    Users^ get () sealed;
}

Implements

IDatabaseObjects..::.Users
IFullDatabaseObjects..::.Users

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


Views Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.Views Property
ObjectCollections Class See Also

The views in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Views As Views
C#
public Views Views { get; }
Visual C++
public:
virtual property Views^ Views {
    Views^ get () sealed;
}

Implements

IDatabaseObjects..::.Views
IFullDatabaseObjects..::.Views

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


XmlSchemaCollections Property

[image]

SQL Data Compare API 12.0.40
ObjectCollections..::.XmlSchemaCollections Property
ObjectCollections Class See Also

The XML schema collections in the database. Note that XML schema collections were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property XmlSchemaCollections As XmlSchemaCollections
C#
public XmlSchemaCollections XmlSchemaCollections { get; }
Visual C++
public:
virtual property XmlSchemaCollections^ XmlSchemaCollections {
    XmlSchemaCollections^ get () sealed;
}

Implements

IDatabaseObjects..::.XmlSchemaCollections
IFullDatabaseObjects..::.XmlSchemaCollections

See Also

ObjectCollections Class
RedGate.SQLCompare.Engine Namespace


ObjectNotInDatabaseException Class

[image]

SQL Data Compare API 12.0.40
ObjectNotInDatabaseException Class
Members See Also

An exception that is used when a database object that is not in the database is requested.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ObjectNotInDatabaseException _
    Inherits SqlCompareException
C#
public class ObjectNotInDatabaseException : SqlCompareException
Visual C++
public ref class ObjectNotInDatabaseException : public SqlCompareException

Inheritance Hierarchy

Object
Exception
RedGate.SQLCompare.Engine..::.SqlCompareException
RedGate.SQLCompare.Engine..::.ObjectNotInDatabaseException

See Also

ObjectNotInDatabaseException Members
RedGate.SQLCompare.Engine Namespace


ObjectNotInDatabaseException Members

[image] [image]

SQL Data Compare API 12.0.40
ObjectNotInDatabaseException Members
ObjectNotInDatabaseException Class Constructors Methods Properties See Also

The ObjectNotInDatabaseException type exposes the following members.

Constructors

Name | Description
ObjectNotInDatabaseException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ObjectNotInDatabaseException Class
RedGate.SQLCompare.Engine Namespace


ObjectNotInDatabaseException Constructor

[image] [image]

SQL Data Compare API 12.0.40
ObjectNotInDatabaseException Constructor
ObjectNotInDatabaseException Class See Also

Overload List

Name | Description
ObjectNotInDatabaseException()()() | Constructs an ObjectNotInDatabaseException exception.
ObjectNotInDatabaseException(String) | Constructs an ObjectNotInDatabaseException exception.
ObjectNotInDatabaseException(String, Exception) | Constructs an ObjectNotInDatabaseException exception.
ObjectNotInDatabaseException(ObjectType, String, ObjectType, String) |
ObjectNotInDatabaseException(String, String, String, String) |

See Also

ObjectNotInDatabaseException Class
ObjectNotInDatabaseException Members
RedGate.SQLCompare.Engine Namespace


ObjectNotInDatabaseException Constructor

[image]

SQL Data Compare API 12.0.40
ObjectNotInDatabaseException Constructor
ObjectNotInDatabaseException Class See Also

Constructs an ObjectNotInDatabaseException exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ObjectNotInDatabaseException()
Visual C++
public:
ObjectNotInDatabaseException()

See Also

ObjectNotInDatabaseException Class
ObjectNotInDatabaseException Overload
RedGate.SQLCompare.Engine Namespace


ObjectNotInDatabaseException Constructor ()

[image]

SQL Data Compare API 12.0.40
ObjectNotInDatabaseException Constructor ()
ObjectNotInDatabaseException Class See Also

Constructs an ObjectNotInDatabaseException exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public ObjectNotInDatabaseException(
    string message
)
Visual C++
public:
ObjectNotInDatabaseException(
    String^ message
)

Parameters

message
Type: String
The message for the exception.

See Also

ObjectNotInDatabaseException Class
ObjectNotInDatabaseException Overload
RedGate.SQLCompare.Engine Namespace


ObjectNotInDatabaseException Constructor (, )

[image]

SQL Data Compare API 12.0.40
ObjectNotInDatabaseException Constructor (, )
ObjectNotInDatabaseException Class See Also

Constructs an ObjectNotInDatabaseException exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
C#
public ObjectNotInDatabaseException(
    string message,
    Exception inner
)
Visual C++
public:
ObjectNotInDatabaseException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: String
The message for the exception.
inner
Type: Exception
The inner exception.

See Also

ObjectNotInDatabaseException Class
ObjectNotInDatabaseException Overload
RedGate.SQLCompare.Engine Namespace


ObjectNotInDatabaseException Constructor (, , , )

[image]

SQL Data Compare API 12.0.40
ObjectNotInDatabaseException Constructor (, , , )
ObjectNotInDatabaseException Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    referencedObjectType As ObjectType, _
    referencedObjectName As String, _
    referencingObjectType As ObjectType, _
    referencingObjectName As String _
)
C#
public ObjectNotInDatabaseException(
    ObjectType referencedObjectType,
    string referencedObjectName,
    ObjectType referencingObjectType,
    string referencingObjectName
)
Visual C++
public:
ObjectNotInDatabaseException(
    ObjectType referencedObjectType,
    String^ referencedObjectName,
    ObjectType referencingObjectType,
    String^ referencingObjectName
)

Parameters

referencedObjectType
Type: ObjectType
referencedObjectName
Type: String
referencingObjectType
Type: ObjectType
referencingObjectName
Type: String

See Also

ObjectNotInDatabaseException Class
ObjectNotInDatabaseException Overload
RedGate.SQLCompare.Engine Namespace


ObjectNotInDatabaseException Constructor (, , , )

[image]

SQL Data Compare API 12.0.40
ObjectNotInDatabaseException Constructor (, , , )
ObjectNotInDatabaseException Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    referencedObjectType As String, _
    referencedObjectName As String, _
    referencingObjectType As String, _
    referencingObjectName As String _
)
C#
public ObjectNotInDatabaseException(
    string referencedObjectType,
    string referencedObjectName,
    string referencingObjectType,
    string referencingObjectName
)
Visual C++
public:
ObjectNotInDatabaseException(
    String^ referencedObjectType,
    String^ referencedObjectName,
    String^ referencingObjectType,
    String^ referencingObjectName
)

Parameters

referencedObjectType
Type: String
referencedObjectName
Type: String
referencingObjectType
Type: String
referencingObjectName
Type: String

See Also

ObjectNotInDatabaseException Class
ObjectNotInDatabaseException Overload
RedGate.SQLCompare.Engine Namespace


ObjectNotInDifferences Class

[image]

SQL Data Compare API 12.0.40
ObjectNotInDifferences Class
Members See Also

Exception that is used when a database object that is not in the differences collection is requested.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ObjectNotInDifferences _
    Inherits SqlCompareException
C#
public class ObjectNotInDifferences : SqlCompareException
Visual C++
public ref class ObjectNotInDifferences : public SqlCompareException

Inheritance Hierarchy

Object
Exception
RedGate.SQLCompare.Engine..::.SqlCompareException
RedGate.SQLCompare.Engine..::.ObjectNotInDifferences

See Also

ObjectNotInDifferences Members
RedGate.SQLCompare.Engine Namespace


ObjectNotInDifferences Members

[image] [image]

SQL Data Compare API 12.0.40
ObjectNotInDifferences Members
ObjectNotInDifferences Class Constructors Methods Properties See Also

The ObjectNotInDifferences type exposes the following members.

Constructors

Name | Description
ObjectNotInDifferences | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ObjectNotInDifferences Class
RedGate.SQLCompare.Engine Namespace


ObjectNotInDifferences Constructor

[image] [image]

SQL Data Compare API 12.0.40
ObjectNotInDifferences Constructor
ObjectNotInDifferences Class See Also

Overload List

Name | Description
ObjectNotInDifferences()()() | Constructs an ObjectNotInDifferences exception.
ObjectNotInDifferences(String) | Constructs an ObjectNotInDifferences exception.
ObjectNotInDifferences(String, Exception) | Constructs an ObjectNotInDifferences exception.

See Also

ObjectNotInDifferences Class
ObjectNotInDifferences Members
RedGate.SQLCompare.Engine Namespace


ObjectNotInDifferences Constructor

[image]

SQL Data Compare API 12.0.40
ObjectNotInDifferences Constructor
ObjectNotInDifferences Class See Also

Constructs an ObjectNotInDifferences exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ObjectNotInDifferences()
Visual C++
public:
ObjectNotInDifferences()

See Also

ObjectNotInDifferences Class
ObjectNotInDifferences Overload
RedGate.SQLCompare.Engine Namespace


ObjectNotInDifferences Constructor ()

[image]

SQL Data Compare API 12.0.40
ObjectNotInDifferences Constructor ()
ObjectNotInDifferences Class See Also

Constructs an ObjectNotInDifferences exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public ObjectNotInDifferences(
    string message
)
Visual C++
public:
ObjectNotInDifferences(
    String^ message
)

Parameters

message
Type: String
The message for the exception.

See Also

ObjectNotInDifferences Class
ObjectNotInDifferences Overload
RedGate.SQLCompare.Engine Namespace


ObjectNotInDifferences Constructor (, )

[image]

SQL Data Compare API 12.0.40
ObjectNotInDifferences Constructor (, )
ObjectNotInDifferences Class See Also

Constructs an ObjectNotInDifferences exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
C#
public ObjectNotInDifferences(
    string message,
    Exception inner
)
Visual C++
public:
ObjectNotInDifferences(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: String
The message for the exception.
inner
Type: Exception
The inner exception.

See Also

ObjectNotInDifferences Class
ObjectNotInDifferences Overload
RedGate.SQLCompare.Engine Namespace


ObjectTypeHelper Class

[image]

SQL Data Compare API 12.0.40
ObjectTypeHelper Class
Members See Also

Various useful methods for ObjectType

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ObjectTypeHelper
C#
public static class ObjectTypeHelper
Visual C++
public ref class ObjectTypeHelper abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ObjectTypeHelper

See Also

ObjectTypeHelper Members
RedGate.SQLCompare.Engine Namespace


ObjectTypeHelper Members

[image] [image]

SQL Data Compare API 12.0.40
ObjectTypeHelper Members
ObjectTypeHelper Class Methods Properties See Also

The ObjectTypeHelper type exposes the following members.

Methods

Name | Description
GetLowercaseTextForObjectType |
GetRenameObjectType |
GetTextForObjectType |
IsSchemaObject |

Properties

Name | Description
ObjectTypes |

See Also

ObjectTypeHelper Class
RedGate.SQLCompare.Engine Namespace


ObjectTypeHelper Methods

[image] [image]

SQL Data Compare API 12.0.40
ObjectTypeHelper Methods
ObjectTypeHelper Class See Also

The ObjectTypeHelper type exposes the following methods.

Methods

Name | Description
GetLowercaseTextForObjectType |
GetRenameObjectType |
GetTextForObjectType |
IsSchemaObject |

See Also

ObjectTypeHelper Class
RedGate.SQLCompare.Engine Namespace


GetLowercaseTextForObjectType Method

[image]

SQL Data Compare API 12.0.40
ObjectTypeHelper..::.GetLowercaseTextForObjectType Method
ObjectTypeHelper Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetLowercaseTextForObjectType ( _
    objectType As ObjectType, _
    plural As Boolean _
) As String
C#
public static string GetLowercaseTextForObjectType(
    ObjectType objectType,
    bool plural
)
Visual C++
public:
static String^ GetLowercaseTextForObjectType(
    ObjectType objectType,
    bool plural
)

Parameters

objectType
Type: ObjectType
plural
Type: Boolean

See Also

ObjectTypeHelper Class
RedGate.SQLCompare.Engine Namespace


GetRenameObjectType Method

[image]

SQL Data Compare API 12.0.40
ObjectTypeHelper..::.GetRenameObjectType Method
ObjectTypeHelper Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRenameObjectType ( _
    objectType As ObjectType _
) As String
C#
public static string GetRenameObjectType(
    ObjectType objectType
)
Visual C++
public:
static String^ GetRenameObjectType(
    ObjectType objectType
)

Parameters

objectType
Type: ObjectType

See Also

ObjectTypeHelper Class
RedGate.SQLCompare.Engine Namespace


GetTextForObjectType Method

[image]

SQL Data Compare API 12.0.40
ObjectTypeHelper..::.GetTextForObjectType Method
ObjectTypeHelper Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetTextForObjectType ( _
    type As ObjectType, _
    plural As Boolean _
) As String
C#
public static string GetTextForObjectType(
    ObjectType type,
    bool plural
)
Visual C++
public:
static String^ GetTextForObjectType(
    ObjectType type,
    bool plural
)

Parameters

type
Type: ObjectType
plural
Type: Boolean

See Also

ObjectTypeHelper Class
RedGate.SQLCompare.Engine Namespace


IsSchemaObject Method

[image]

SQL Data Compare API 12.0.40
ObjectTypeHelper..::.IsSchemaObject Method
ObjectTypeHelper Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsSchemaObject ( _
    type As ObjectType _
) As Boolean
C#
public static bool IsSchemaObject(
    ObjectType type
)
Visual C++
public:
static bool IsSchemaObject(
    ObjectType type
)

Parameters

type
Type: ObjectType

See Also

ObjectTypeHelper Class
RedGate.SQLCompare.Engine Namespace


ObjectTypeHelper Properties

[image] [image]

SQL Data Compare API 12.0.40
ObjectTypeHelper Properties
ObjectTypeHelper Class See Also

The ObjectTypeHelper type exposes the following properties.

Properties

Name | Description
ObjectTypes |

See Also

ObjectTypeHelper Class
RedGate.SQLCompare.Engine Namespace


ObjectTypes Property

[image]

SQL Data Compare API 12.0.40
ObjectTypeHelper..::.ObjectTypes Property
ObjectTypeHelper Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ObjectTypes As ICollection(Of ObjectType)
C#
public static ICollection<ObjectType> ObjectTypes { get; }
Visual C++
public:
static property ICollection<ObjectType>^ ObjectTypes {
    ICollection<ObjectType>^ get ();
}

See Also

ObjectTypeHelper Class
RedGate.SQLCompare.Engine Namespace


Option Enumeration

[image]

SQL Data Compare API 12.0.40
Option Enumeration
See Also

This enum is used to store the names of options and assign each of them a unique value

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration Option
C#
public enum Option
Visual C++
public enum class Option

Members

Member name | Description
ForceColumnOrder |
IgnoreFillFactor |
IgnorePermissions |
IgnoreWhiteSpace |
IgnoreBindings |
IgnoreQuotedIdentifiersAndAnsiNullSettings |
CaseSensitiveObjectDefinition |
IgnoreExtendedProperties |
IgnoreFullTextIndexing |
NoSQLPlumbing |
IgnoreCollations |
IgnoreComments |
IgnoreIndexes |
IgnoreKeys |
IgnoreChecks |
IgnoreTriggers |
IncludeDependencies |
IgnoreInsteadOfTriggers |
IgnoreFileGroups |
IgnoreIdentitySeedAndIncrement |
IgnoreWithNocheck |
IgnoreConstraintNames |
IgnoreStatistics |
DoNotOutputCommentHeader |
AddWithEncryption |
IgnoreSynonymDependencies |
SeparateTriggers |
IgnoreOwners |
IgnoreQueueEventNotifications |
TargetIsPre2005 |
UseClrUdtToStringForClrMigration |
ConsiderNextFilegroupInPartitionSchemes |
IgnoreCertificatesAndCryptoKeys |
IgnoreTriggerOrder |
IgnoreUsers |
IgnoreUserProperties |
DisableAndReenableDdlTriggers |
IgnoreWithElementOrder |
IgnoreIndexLockProperties |
IgnoreReplicationTriggers |
IgnoreIdentityProperties |
IgnoreNotForReplication |
TargetIsPre2008 |
IgnoreDataCompression |
IgnoreDatabaseAndServerName |
AddDatabaseUseStatement |
IgnoreSchemaObjectAuthorization |
DecryptPost2kEncryptedObjects |
ForceSyncScriptGeneration |
IgnoreStatisticsNorecompute |
IgnoreSquareBrackets |
ThrowOnFileParseFailed |
EnableDeployNow |
TargetIsSqlAzure |
ObjectExistenceChecks |
DropAndCreateInsteadOfAlter |
IgnoreMigrationScripts |
IgnoreTSQLT |
IgnoreSystemNamedConstraintNames |
IgnoreInternallyUsedMicrosoftExtendedProperties |
TargetIsPre2012 |
InlineTableObjects |
WriteAssembliesAsDlls |
InlineFulltextFields |
ReadAsDataToolsPermissions |
WriteAsDataToolsPermissions |
InferTypeForSqlVariant |
UseSetStatementsInScriptDatabaseInfo |
ForbidDuplicateTableStorageSettings |
IgnoreWithEncryption |
CloneDatabaseLevelPropertiesForMigrations |
UseMigrationsV2 |
TargetIsPre2014 |
NoTransactions |
NoErrorHandling |
IgnoreNocheckAndWithNocheck |
AssumeAlreadyInTransaction |
UseCompatibilityLevel |
IgnoreNullability |
IgnoreDataSyncSchema |
NoAutoColumnMapping |
DisableSocForLiveDbs | Obsolete.

Remarks

The duplication between this enum and the equivalent fields on Options is annoying. Alternatives include: - removing this list and using reflection on Options fields to reproduce it (pros: makes handling Default/Ssdt easier, cons: is a terrible terrible hack) - removing the fields on Options and changing everything to use a mix of Option and Options (pros: is probably the morally right thing to do, cons: means changing a whole lot of code and making it more complicated) Ideally we could get some sort of composite pattern going between Option and Options, but when one is a struct and the other is an enum that doesn't seem likely.

See Also

RedGate.SQLCompare.Engine Namespace


OptionDescriptionAttribute Class

[image]

SQL Data Compare API 12.0.40
OptionDescriptionAttribute Class
Members See Also

Options used in comparison and synchronization.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Field)> _
Public NotInheritable Class OptionDescriptionAttribute _
    Inherits Attribute
C#
[AttributeUsageAttribute(AttributeTargets.Field)]
public sealed class OptionDescriptionAttribute : Attribute
Visual C++
[AttributeUsageAttribute(AttributeTargets::Field)]
public ref class OptionDescriptionAttribute sealed : public Attribute

Inheritance Hierarchy

Object
Attribute
RedGate.SQLCompare.Engine..::.OptionDescriptionAttribute

See Also

OptionDescriptionAttribute Members
RedGate.SQLCompare.Engine Namespace


OptionDescriptionAttribute Members

[image] [image]

SQL Data Compare API 12.0.40
OptionDescriptionAttribute Members
OptionDescriptionAttribute Class Constructors Methods Properties Explicit Interface Implementations See Also

The OptionDescriptionAttribute type exposes the following members.

Constructors

Name | Description
OptionDescriptionAttribute | Constructor.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FriendlyName | A friendly name.
HelpText | Some help text.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
System#Runtime#InteropServices#_Attribute#GetIDsOfNames | (Inherited from Attribute.)
System#Runtime#InteropServices#_Attribute#GetTypeInfo | (Inherited from Attribute.)
System#Runtime#InteropServices#_Attribute#GetTypeInfoCount | (Inherited from Attribute.)
System#Runtime#InteropServices#_Attribute#Invoke | (Inherited from Attribute.)

See Also

OptionDescriptionAttribute Class
RedGate.SQLCompare.Engine Namespace


OptionDescriptionAttribute Constructor

[image]

SQL Data Compare API 12.0.40
OptionDescriptionAttribute Constructor
OptionDescriptionAttribute Class See Also

Constructor.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    friendlyName As String, _
    helpText As String _
)
C#
public OptionDescriptionAttribute(
    string friendlyName,
    string helpText
)
Visual C++
public:
OptionDescriptionAttribute(
    String^ friendlyName,
    String^ helpText
)

Parameters

friendlyName
Type: String
The friendly name of the option description.
helpText
Type: String
Help text.

See Also

OptionDescriptionAttribute Class
RedGate.SQLCompare.Engine Namespace


OptionDescriptionAttribute Properties

[image] [image]

SQL Data Compare API 12.0.40
OptionDescriptionAttribute Properties
OptionDescriptionAttribute Class See Also

The OptionDescriptionAttribute type exposes the following properties.

Properties

Name | Description
FriendlyName | A friendly name.
HelpText | Some help text.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

OptionDescriptionAttribute Class
RedGate.SQLCompare.Engine Namespace


FriendlyName Property

[image]

SQL Data Compare API 12.0.40
OptionDescriptionAttribute..::.FriendlyName Property
OptionDescriptionAttribute Class See Also

A friendly name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FriendlyName As String
C#
public string FriendlyName { get; }
Visual C++
public:
property String^ FriendlyName {
    String^ get ();
}

See Also

OptionDescriptionAttribute Class
RedGate.SQLCompare.Engine Namespace


HelpText Property

[image]

SQL Data Compare API 12.0.40
OptionDescriptionAttribute..::.HelpText Property
OptionDescriptionAttribute Class See Also

Some help text.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HelpText As String
C#
public string HelpText { get; }
Visual C++
public:
property String^ HelpText {
    String^ get ();
}

See Also

OptionDescriptionAttribute Class
RedGate.SQLCompare.Engine Namespace


OptionDescriptionDCAttribute Class

[image]

SQL Data Compare API 12.0.40
OptionDescriptionDCAttribute Class
Members See Also

Options used when comparing and synchronizing databases.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Field)> _
Public NotInheritable Class OptionDescriptionDCAttribute _
    Inherits Attribute
C#
[AttributeUsageAttribute(AttributeTargets.Field)]
public sealed class OptionDescriptionDCAttribute : Attribute
Visual C++
[AttributeUsageAttribute(AttributeTargets::Field)]
public ref class OptionDescriptionDCAttribute sealed : public Attribute

Inheritance Hierarchy

Object
Attribute
RedGate.SQLCompare.Engine..::.OptionDescriptionDCAttribute

See Also

OptionDescriptionDCAttribute Members
RedGate.SQLCompare.Engine Namespace


OptionDescriptionDCAttribute Members

[image] [image]

SQL Data Compare API 12.0.40
OptionDescriptionDCAttribute Members
OptionDescriptionDCAttribute Class Constructors Methods Properties Explicit Interface Implementations See Also

The OptionDescriptionDCAttribute type exposes the following members.

Constructors

Name | Description
OptionDescriptionDCAttribute | Constructor.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FriendlyName | A friendly name.
HelpText | Some help text.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
System#Runtime#InteropServices#_Attribute#GetIDsOfNames | (Inherited from Attribute.)
System#Runtime#InteropServices#_Attribute#GetTypeInfo | (Inherited from Attribute.)
System#Runtime#InteropServices#_Attribute#GetTypeInfoCount | (Inherited from Attribute.)
System#Runtime#InteropServices#_Attribute#Invoke | (Inherited from Attribute.)

See Also

OptionDescriptionDCAttribute Class
RedGate.SQLCompare.Engine Namespace


OptionDescriptionDCAttribute Constructor

[image]

SQL Data Compare API 12.0.40
OptionDescriptionDCAttribute Constructor
OptionDescriptionDCAttribute Class See Also

Constructor.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    friendlyName As String, _
    helpText As String _
)
C#
public OptionDescriptionDCAttribute(
    string friendlyName,
    string helpText
)
Visual C++
public:
OptionDescriptionDCAttribute(
    String^ friendlyName,
    String^ helpText
)

Parameters

friendlyName
Type: String
helpText
Type: String

See Also

OptionDescriptionDCAttribute Class
RedGate.SQLCompare.Engine Namespace


OptionDescriptionDCAttribute Properties

[image] [image]

SQL Data Compare API 12.0.40
OptionDescriptionDCAttribute Properties
OptionDescriptionDCAttribute Class See Also

The OptionDescriptionDCAttribute type exposes the following properties.

Properties

Name | Description
FriendlyName | A friendly name.
HelpText | Some help text.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

OptionDescriptionDCAttribute Class
RedGate.SQLCompare.Engine Namespace


FriendlyName Property

[image]

SQL Data Compare API 12.0.40
OptionDescriptionDCAttribute..::.FriendlyName Property
OptionDescriptionDCAttribute Class See Also

A friendly name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FriendlyName As String
C#
public string FriendlyName { get; }
Visual C++
public:
property String^ FriendlyName {
    String^ get ();
}

See Also

OptionDescriptionDCAttribute Class
RedGate.SQLCompare.Engine Namespace


HelpText Property

[image]

SQL Data Compare API 12.0.40
OptionDescriptionDCAttribute..::.HelpText Property
OptionDescriptionDCAttribute Class See Also

Some help text.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HelpText As String
C#
public string HelpText { get; }
Visual C++
public:
property String^ HelpText {
    String^ get ();
}

See Also

OptionDescriptionDCAttribute Class
RedGate.SQLCompare.Engine Namespace


Options Structure

[image]

SQL Data Compare API 12.0.40
Options Structure
Members See Also

Options used when comparing and synchronizing databases.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Structure Options _
    Implements IEquatable(Of Options)
C#
public struct Options : IEquatable<Options>
Visual C++
public value class Options : IEquatable<Options>

Remarks

Calling methods on default(Options) will throw an exception. Do not use default(Options). Instead, use a nullable version of the Options type.

See Also

Options Members
RedGate.SQLCompare.Engine Namespace


Options Members

[image] [image]

SQL Data Compare API 12.0.40
Options Members
Options Structure Methods Fields See Also

The Options type exposes the following members.

Methods

Name | Description
AreAllEnabled | Overloaded.
AreAnyEnabled |
Equals | Overloaded.
Except |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromOldOptionsLong |
FromString |
GetHashCode | (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValidatedOptions |
IsOptionSet |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Plus |
SetOptions |
ToString | (Overrides ValueType..::.ToString()()().)
TryParseOptionName |
TrySetOption |

Operators

Name | Description
Equality |
Inequality |

Fields

Name | Description
AddDatabaseUseStatement
Adds a USE statement at the top of the sync sql
AddWithEncryption
Add WITH ENCRYPTION option to stored procedures etc.
All
For use in serialization etc.
AssumeAlreadyInTransaction
Assume that a transaction is already open.
CaseSensitiveObjectDefinition
Treat items as case sensitive.
CloneDatabaseLevelPropertiesForMigrations
ConsiderNextFilegroupInPartitionSchemes
If set, the next filegroups in partition schemes are compared with the filegroups that have a partition range associated with them.
DecryptPost2kEncryptedObjects
Decrypt 2005 and 2008 encrypted objects. Note that this can have a significant performance impact.
Default

The default options for a comparison. These are:

  • IgnoreFileGroups
  • IgnoreFillFactor
  • IgnoreUserProperties
  • IgnoreWhiteSpace
  • IgnoreWithElementOrder
  • IncludeDependencies
  • IgnoreDatabaseNames
  • DecryptPost2kEncryptedObjects

NB: this means the default is NOT case-sensitive

DisableAndReenableDdlTriggers
Disable and later re-enable DDL triggers. SQL Server 2005 only.
DisableSocForLiveDbs | Obsolete.
DoNotOutputCommentHeader
Do not output comment header.
DropAndCreateInsteadOfAlter
Uses a drop/create on functions, stored procs and views in place of an alter
EnableDeployNow
Enable the "Deploy Now" button in Compare
ForbidDuplicateTableStorageSettings
To match SSDT behaviour, forbids setting filegroup, filestream, partition scheme, and data compression options on both a table and a clustered index or non-inlined clustered constraint on that table, event though when options are specified on both, the options specified on the table are ignored by SQL Server.
ForceColumnOrder
Force table column order to be identical.
ForceSyncScriptGeneration
Generate a synchronization SQL script rather than folder sync actions when syncing to scripts.
IgnoreBindings
Ignore bindings.
IgnoreCertificatesAndCryptoKeys
Ignore public certificates, symmetric keys and asymmetric keys in SQL Server 2005 databases.
IgnoreChecks
Ignore check constraints.
IgnoreCollations
Ignore collation order.
IgnoreComments
Ignore comments.
IgnoreConstraintNames
Ignore constraint names.
IgnoreDatabaseAndServerName
Ignores database and server names in synonyms.
IgnoreDatabaseName Obsolete.
Ignores database and server names in synonyms.
IgnoreDataCompression
Ignores data compression.
IgnoreDataSyncSchema
Ignore all objects contained in a schema called DataSync. Data Sync is an Azure feature that temporarily populates a user's database with objects that the user may want to ignore during comparison.
IgnoreExtendedProperties
Ignore extended properties
IgnoreFileGroups
Ignore filegroups, partition schemes, and partition functions.
IgnoreFillFactor
Ignore fill factor.
IgnoreFullTextIndexing
Ignore full text indexing.
IgnoreIdentityProperties
Ignores identity properties.
IgnoreIdentitySeedAndIncrement
Ignore identity seed and increment values.
IgnoreIndexes
Ignore indexes.
IgnoreIndexLockProperties
Ignore the lock properties of indexes.
IgnoreInsteadOfTriggers
Ignore INSTEAD OF triggers.
IgnoreInternallyUsedMicrosoftExtendedProperties
Make scripting out of objects ignore the extended properties used internally by the SSMS designer
IgnoreKeys
Ignore foreign keys.
IgnoreMigrationScripts
IgnoreNocheckAndWithNocheck
Ignores the NOCHECK and WITH NOCHECK arguments on foreign keys and check constraints.
IgnoreNotForReplication
Ignores NOT FOR REPLICATION.
IgnoreNullability
Ignore nullability of columns.
IgnoreOwners
Ignore owners when checking for equality.
IgnorePermissions
Ignore permissions.
IgnoreQueueEventNotifications
Ignore event notifications on queues.
IgnoreQuotedIdentifiersAndAnsiNullSettings
Ignore SET QUOTED_IDENTIFIER and SET ANSI_NULLS statements.
IgnoreReplicationTriggers
Ignore replication triggers.
IgnoreSchemaObjectAuthorization
Ignores owner authorization on schema objects.
IgnoreSquareBrackets
Ignore square brackets in object names.
IgnoreStatistics
Ignore statistics.
IgnoreStatisticsNorecompute
Ignore the STATISTICS_NORECOMPUTE property on indexes.
IgnoreSynonymDependencies
Ignore dependencies through synonyms.
IgnoreSystemNamedConstraintNames
Ignore system named constraint names.
IgnoreTriggerOrder
Ignore trigger order.
IgnoreTriggers
Ignore DML triggers.
IgnoreTSQLT
Ignores the tSQLt schema and its contents, the tSQLtCLR assembly, the SQLCop schema and its contents, and any schemas and their contents with the tSQLt.TestClass extended property set.
IgnoreUserProperties
Ignore user properties.
IgnoreUsers
Ignore users' permissions and role memberships.
IgnoreWhiteSpace
Ignore white space.
IgnoreWithElementOrder
Ignore the order of with elements in non CLR stored procedures, functions, triggers, DDL triggers and views.
IgnoreWithEncryption
Ignore WITH ENCRYPTION statements on triggers, views, stored procedures and functions
IgnoreWithNocheck
Ignores the WITH NOCHECK argument on foreign keys and check constraints.
IncludeDependencies
Include dependencies.
InferTypeForSqlVariant
Allow SQL server to infer the type of a sql variant rather than trying to help it.
InlineFulltextFields
Script out FullText indexes as a single create instead of lots of ALTERs.
InlineTableObjects
Script out definitions as part of the table's body where possible for primary keys, foreign keys etc. Only some Indexes can be inlined.
NoAutoColumnMapping
Do not automatically map 'sufficiently similar' columns in mapped tables. If set, only identical columns will be mapped.
NoErrorHandling
Do not include error handling for synchronization scripts.
None
None.
NoSQLPlumbing
Do not include plumbing for transactional synchronization scripts.
NoTransactions
Do not include error handling for transactional synchronization scripts.
ObjectExistenceChecks
Adds if exists checks before objects are modified to make the generated scripts rerunnable
ReadAsDataToolsPermissions
WIP - Read in permissions from a script folder as though they were from a Data Tools project.
SeparateTriggers
Separate triggers from tables and views.
SsdtCompatibleOptions
Make script folder output output compatible with SSDT.
ThrowOnFileParseFailed
Throw an exception when parsing a scripts fails during Register. If this option is not set then the file (and all objects in it) will be ignored.
UseClrUdtToStringForClrMigration
If a CLR assembly must be changed, unbind the dependent types from tables using ToString, and then convert these table values back to CLR type.
UseCompatibilityLevel
Ignore database compatibility level
UseSetStatementsInScriptDatabaseInfo
Use RedGateDatabaseProperties.xml to store/recover set statements for objects.
WriteAsDataToolsPermissions
WIP - Script out Permissions so they're correct as far as a Data Tools project is concerned.
WriteAssembliesAsDlls
WIP - CLR Assembly objects will be written in their true DLL form rather than our legacy sql script containing a binary blob in hex.

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


Options Fields

[image] [image]

SQL Data Compare API 12.0.40
Options Fields
Options Structure See Also

The Options type exposes the following fields.

Fields

Name | Description
AddDatabaseUseStatement
Adds a USE statement at the top of the sync sql
AddWithEncryption
Add WITH ENCRYPTION option to stored procedures etc.
All
For use in serialization etc.
AssumeAlreadyInTransaction
Assume that a transaction is already open.
CaseSensitiveObjectDefinition
Treat items as case sensitive.
CloneDatabaseLevelPropertiesForMigrations
ConsiderNextFilegroupInPartitionSchemes
If set, the next filegroups in partition schemes are compared with the filegroups that have a partition range associated with them.
DecryptPost2kEncryptedObjects
Decrypt 2005 and 2008 encrypted objects. Note that this can have a significant performance impact.
Default

The default options for a comparison. These are:

  • IgnoreFileGroups
  • IgnoreFillFactor
  • IgnoreUserProperties
  • IgnoreWhiteSpace
  • IgnoreWithElementOrder
  • IncludeDependencies
  • IgnoreDatabaseNames
  • DecryptPost2kEncryptedObjects

NB: this means the default is NOT case-sensitive

DisableAndReenableDdlTriggers
Disable and later re-enable DDL triggers. SQL Server 2005 only.
DisableSocForLiveDbs | Obsolete.
DoNotOutputCommentHeader
Do not output comment header.
DropAndCreateInsteadOfAlter
Uses a drop/create on functions, stored procs and views in place of an alter
EnableDeployNow
Enable the "Deploy Now" button in Compare
ForbidDuplicateTableStorageSettings
To match SSDT behaviour, forbids setting filegroup, filestream, partition scheme, and data compression options on both a table and a clustered index or non-inlined clustered constraint on that table, event though when options are specified on both, the options specified on the table are ignored by SQL Server.
ForceColumnOrder
Force table column order to be identical.
ForceSyncScriptGeneration
Generate a synchronization SQL script rather than folder sync actions when syncing to scripts.
IgnoreBindings
Ignore bindings.
IgnoreCertificatesAndCryptoKeys
Ignore public certificates, symmetric keys and asymmetric keys in SQL Server 2005 databases.
IgnoreChecks
Ignore check constraints.
IgnoreCollations
Ignore collation order.
IgnoreComments
Ignore comments.
IgnoreConstraintNames
Ignore constraint names.
IgnoreDatabaseAndServerName
Ignores database and server names in synonyms.
IgnoreDatabaseName Obsolete.
Ignores database and server names in synonyms.
IgnoreDataCompression
Ignores data compression.
IgnoreDataSyncSchema
Ignore all objects contained in a schema called DataSync. Data Sync is an Azure feature that temporarily populates a user's database with objects that the user may want to ignore during comparison.
IgnoreExtendedProperties
Ignore extended properties
IgnoreFileGroups
Ignore filegroups, partition schemes, and partition functions.
IgnoreFillFactor
Ignore fill factor.
IgnoreFullTextIndexing
Ignore full text indexing.
IgnoreIdentityProperties
Ignores identity properties.
IgnoreIdentitySeedAndIncrement
Ignore identity seed and increment values.
IgnoreIndexes
Ignore indexes.
IgnoreIndexLockProperties
Ignore the lock properties of indexes.
IgnoreInsteadOfTriggers
Ignore INSTEAD OF triggers.
IgnoreInternallyUsedMicrosoftExtendedProperties
Make scripting out of objects ignore the extended properties used internally by the SSMS designer
IgnoreKeys
Ignore foreign keys.
IgnoreMigrationScripts
IgnoreNocheckAndWithNocheck
Ignores the NOCHECK and WITH NOCHECK arguments on foreign keys and check constraints.
IgnoreNotForReplication
Ignores NOT FOR REPLICATION.
IgnoreNullability
Ignore nullability of columns.
IgnoreOwners
Ignore owners when checking for equality.
IgnorePermissions
Ignore permissions.
IgnoreQueueEventNotifications
Ignore event notifications on queues.
IgnoreQuotedIdentifiersAndAnsiNullSettings
Ignore SET QUOTED_IDENTIFIER and SET ANSI_NULLS statements.
IgnoreReplicationTriggers
Ignore replication triggers.
IgnoreSchemaObjectAuthorization
Ignores owner authorization on schema objects.
IgnoreSquareBrackets
Ignore square brackets in object names.
IgnoreStatistics
Ignore statistics.
IgnoreStatisticsNorecompute
Ignore the STATISTICS_NORECOMPUTE property on indexes.
IgnoreSynonymDependencies
Ignore dependencies through synonyms.
IgnoreSystemNamedConstraintNames
Ignore system named constraint names.
IgnoreTriggerOrder
Ignore trigger order.
IgnoreTriggers
Ignore DML triggers.
IgnoreTSQLT
Ignores the tSQLt schema and its contents, the tSQLtCLR assembly, the SQLCop schema and its contents, and any schemas and their contents with the tSQLt.TestClass extended property set.
IgnoreUserProperties
Ignore user properties.
IgnoreUsers
Ignore users' permissions and role memberships.
IgnoreWhiteSpace
Ignore white space.
IgnoreWithElementOrder
Ignore the order of with elements in non CLR stored procedures, functions, triggers, DDL triggers and views.
IgnoreWithEncryption
Ignore WITH ENCRYPTION statements on triggers, views, stored procedures and functions
IgnoreWithNocheck
Ignores the WITH NOCHECK argument on foreign keys and check constraints.
IncludeDependencies
Include dependencies.
InferTypeForSqlVariant
Allow SQL server to infer the type of a sql variant rather than trying to help it.
InlineFulltextFields
Script out FullText indexes as a single create instead of lots of ALTERs.
InlineTableObjects
Script out definitions as part of the table's body where possible for primary keys, foreign keys etc. Only some Indexes can be inlined.
NoAutoColumnMapping
Do not automatically map 'sufficiently similar' columns in mapped tables. If set, only identical columns will be mapped.
NoErrorHandling
Do not include error handling for synchronization scripts.
None
None.
NoSQLPlumbing
Do not include plumbing for transactional synchronization scripts.
NoTransactions
Do not include error handling for transactional synchronization scripts.
ObjectExistenceChecks
Adds if exists checks before objects are modified to make the generated scripts rerunnable
ReadAsDataToolsPermissions
WIP - Read in permissions from a script folder as though they were from a Data Tools project.
SeparateTriggers
Separate triggers from tables and views.
SsdtCompatibleOptions
Make script folder output output compatible with SSDT.
ThrowOnFileParseFailed
Throw an exception when parsing a scripts fails during Register. If this option is not set then the file (and all objects in it) will be ignored.
UseClrUdtToStringForClrMigration
If a CLR assembly must be changed, unbind the dependent types from tables using ToString, and then convert these table values back to CLR type.
UseCompatibilityLevel
Ignore database compatibility level
UseSetStatementsInScriptDatabaseInfo
Use RedGateDatabaseProperties.xml to store/recover set statements for objects.
WriteAsDataToolsPermissions
WIP - Script out Permissions so they're correct as far as a Data Tools project is concerned.
WriteAssembliesAsDlls
WIP - CLR Assembly objects will be written in their true DLL form rather than our legacy sql script containing a binary blob in hex.

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


AddDatabaseUseStatement Field

[image]

SQL Data Compare API 12.0.40
Options..::.AddDatabaseUseStatement Field
Options Structure See Also

Adds a USE statement at the top of the sync sql

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Adds a database USE statement.", "Adds a database USE statement at the top of the synchronization SQL.")> _
Public Shared AddDatabaseUseStatement As Options
C#
[OptionDescriptionAttribute("Adds a database USE statement.", "Adds a database USE statement at the top of the synchronization SQL.")]
public static Options AddDatabaseUseStatement
Visual C++
[OptionDescriptionAttribute(L"Adds a database USE statement.", L"Adds a database USE statement at the top of the synchronization SQL.")]
public:
static Options AddDatabaseUseStatement

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


AddWithEncryption Field

[image]

SQL Data Compare API 12.0.40
Options..::.AddWithEncryption Field
Options Structure See Also

Add WITH ENCRYPTION option to stored procedures etc.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Add WITH ENCRYPTION option to stored procedures etc.",  _
    "Add WITH ENCRYPTION option to stored procedures etc.")> _
Public Shared AddWithEncryption As Options
C#
[OptionDescriptionAttribute("Add WITH ENCRYPTION option to stored procedures etc.",
    "Add WITH ENCRYPTION option to stored procedures etc.")]
public static Options AddWithEncryption
Visual C++
[OptionDescriptionAttribute(L"Add WITH ENCRYPTION option to stored procedures etc.",
    L"Add WITH ENCRYPTION option to stored procedures etc.")]
public:
static Options AddWithEncryption

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


All Field

[image]

SQL Data Compare API 12.0.40
Options..::.All Field
Options Structure See Also

For use in serialization etc.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared All As Options
C#
public static Options All
Visual C++
public:
static Options All

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


AssumeAlreadyInTransaction Field

[image]

SQL Data Compare API 12.0.40
Options..::.AssumeAlreadyInTransaction Field
Options Structure See Also

Assume that a transaction is already open.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Assume that a transaction is already open", "Prevents the output of any transaction-related SQL, but still does checking as if a transaction is in use.")> _
Public Shared AssumeAlreadyInTransaction As Options
C#
[OptionDescriptionAttribute("Assume that a transaction is already open", "Prevents the output of any transaction-related SQL, but still does checking as if a transaction is in use.")]
public static Options AssumeAlreadyInTransaction
Visual C++
[OptionDescriptionAttribute(L"Assume that a transaction is already open", L"Prevents the output of any transaction-related SQL, but still does checking as if a transaction is in use.")]
public:
static Options AssumeAlreadyInTransaction

Remarks

Prevents the output of any transaction-related SQL, but still does checking as if a transaction is in use. This is to allow the migrations code to do the relevant checks (e.g. for full text indexing), while handling the scope of the transaction itself.

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


CaseSensitiveObjectDefinition Field

[image]

SQL Data Compare API 12.0.40
Options..::.CaseSensitiveObjectDefinition Field
Options Structure See Also

Treat items as case sensitive.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Treat items as case sensitive", "")> _
Public Shared CaseSensitiveObjectDefinition As Options
C#
[OptionDescriptionAttribute("Treat items as case sensitive", "")]
public static Options CaseSensitiveObjectDefinition
Visual C++
[OptionDescriptionAttribute(L"Treat items as case sensitive", L"")]
public:
static Options CaseSensitiveObjectDefinition

Remarks

Treats object names such as ATable and atable as different, and carries out case sensitive comparisons on stored procedures etc.

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


CloneDatabaseLevelPropertiesForMigrations Field

[image]

SQL Data Compare API 12.0.40
Options..::.CloneDatabaseLevelPropertiesForMigrations Field
Options Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore Database Level Properties For Migrations",  _
    "When creating a temporary database for Migrations, don't copy the database level properties")> _
Public Shared CloneDatabaseLevelPropertiesForMigrations As Options
C#
[OptionDescriptionAttribute("Ignore Database Level Properties For Migrations",
    "When creating a temporary database for Migrations, don't copy the database level properties")]
public static Options CloneDatabaseLevelPropertiesForMigrations
Visual C++
[OptionDescriptionAttribute(L"Ignore Database Level Properties For Migrations",
    L"When creating a temporary database for Migrations, don't copy the database level properties")]
public:
static Options CloneDatabaseLevelPropertiesForMigrations

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


ConsiderNextFilegroupInPartitionSchemes Field

[image]

SQL Data Compare API 12.0.40
Options..::.ConsiderNextFilegroupInPartitionSchemes Field
Options Structure See Also

If set, the next filegroups in partition schemes are compared with the filegroups that have a partition range associated with them.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Consider next filegroups in partition schemes.",  _
    "Consider next filegroups in partition schemes.")> _
Public Shared ConsiderNextFilegroupInPartitionSchemes As Options
C#
[OptionDescriptionAttribute("Consider next filegroups in partition schemes.",
    "Consider next filegroups in partition schemes.")]
public static Options ConsiderNextFilegroupInPartitionSchemes
Visual C++
[OptionDescriptionAttribute(L"Consider next filegroups in partition schemes.",
    L"Consider next filegroups in partition schemes.")]
public:
static Options ConsiderNextFilegroupInPartitionSchemes

Remarks

Target database is post SQL Server 2005.

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


DecryptPost2kEncryptedObjects Field

[image]

SQL Data Compare API 12.0.40
Options..::.DecryptPost2kEncryptedObjects Field
Options Structure See Also

Decrypt 2005 and 2008 encrypted objects. Note that this can have a significant performance impact.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Decrypt 2005 and 2008 encrypted objects", "Decrypt 2005 and 2008 encrypted objects")> _
Public Shared DecryptPost2kEncryptedObjects As Options
C#
[OptionDescriptionAttribute("Decrypt 2005 and 2008 encrypted objects", "Decrypt 2005 and 2008 encrypted objects")]
public static Options DecryptPost2kEncryptedObjects
Visual C++
[OptionDescriptionAttribute(L"Decrypt 2005 and 2008 encrypted objects", L"Decrypt 2005 and 2008 encrypted objects")]
public:
static Options DecryptPost2kEncryptedObjects

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


Default Field

[image]

SQL Data Compare API 12.0.40
Options..::.Default Field
Options Structure See Also

The default options for a comparison. These are:

  • IgnoreFileGroups
  • IgnoreFillFactor
  • IgnoreUserProperties
  • IgnoreWhiteSpace
  • IgnoreWithElementOrder
  • IncludeDependencies
  • IgnoreDatabaseNames
  • DecryptPost2kEncryptedObjects

NB: this means the default is NOT case-sensitive

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Default", "The default options for a sensible comparison")> _
Public Shared Default As Options
C#
[OptionDescriptionAttribute("Default", "The default options for a sensible comparison")]
public static Options Default
Visual C++
[OptionDescriptionAttribute(L"Default", L"The default options for a sensible comparison")]
public:
static Options Default

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


DisableAndReenableDdlTriggers Field

[image]

SQL Data Compare API 12.0.40
Options..::.DisableAndReenableDdlTriggers Field
Options Structure See Also

Disable and later re-enable DDL triggers. SQL Server 2005 only.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Disable and later reenable DDL triggers.", "Disable and later reenable DDL triggers.")> _
Public Shared DisableAndReenableDdlTriggers As Options
C#
[OptionDescriptionAttribute("Disable and later reenable DDL triggers.", "Disable and later reenable DDL triggers.")]
public static Options DisableAndReenableDdlTriggers
Visual C++
[OptionDescriptionAttribute(L"Disable and later reenable DDL triggers.", L"Disable and later reenable DDL triggers.")]
public:
static Options DisableAndReenableDdlTriggers

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


DisableSocForLiveDbs Field

[image]

SQL Data Compare API 12.0.40
Options..::.DisableSocForLiveDbs Field
Options Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Please use IgnoreMigrationScripts")> _
<OptionDescriptionAttribute("Disable SoC integration for live databases", "SQL Compare will not try to use SQL Source Control when comparing live databases.")> _
Public Shared DisableSocForLiveDbs As Options
C#
[ObsoleteAttribute("Please use IgnoreMigrationScripts")]
[OptionDescriptionAttribute("Disable SoC integration for live databases", "SQL Compare will not try to use SQL Source Control when comparing live databases.")]
public static Options DisableSocForLiveDbs
Visual C++
[ObsoleteAttribute(L"Please use IgnoreMigrationScripts")]
[OptionDescriptionAttribute(L"Disable SoC integration for live databases", L"SQL Compare will not try to use SQL Source Control when comparing live databases.")]
public:
static Options DisableSocForLiveDbs

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


DoNotOutputCommentHeader Field

[image]

SQL Data Compare API 12.0.40
Options..::.DoNotOutputCommentHeader Field
Options Structure See Also

Do not output comment header.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Do not include comments in the output script", "Do not write the comment header in the output script")> _
Public Shared DoNotOutputCommentHeader As Options
C#
[OptionDescriptionAttribute("Do not include comments in the output script", "Do not write the comment header in the output script")]
public static Options DoNotOutputCommentHeader
Visual C++
[OptionDescriptionAttribute(L"Do not include comments in the output script",
    L"Do not write the comment header in the output script")]
public:
static Options DoNotOutputCommentHeader

Remarks

Do not include the comment in the header of the output script

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


DropAndCreateInsteadOfAlter Field

[image]

SQL Data Compare API 12.0.40
Options..::.DropAndCreateInsteadOfAlter Field
Options Structure See Also

Uses a drop/create on functions, stored procs and views in place of an alter

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared DropAndCreateInsteadOfAlter As Options
C#
public static Options DropAndCreateInsteadOfAlter
Visual C++
public:
static Options DropAndCreateInsteadOfAlter

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


EnableDeployNow Field

[image]

SQL Data Compare API 12.0.40
Options..::.EnableDeployNow Field
Options Structure See Also

Enable the "Deploy Now" button in Compare

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Enable deployment without comparison", "Enable deployment without comparison")> _
Public Shared EnableDeployNow As Options
C#
[OptionDescriptionAttribute("Enable deployment without comparison", "Enable deployment without comparison")]
public static Options EnableDeployNow
Visual C++
[OptionDescriptionAttribute(L"Enable deployment without comparison", L"Enable deployment without comparison")]
public:
static Options EnableDeployNow

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


ForbidDuplicateTableStorageSettings Field

[image]

SQL Data Compare API 12.0.40
Options..::.ForbidDuplicateTableStorageSettings Field
Options Structure See Also

To match SSDT behaviour, forbids setting filegroup, filestream, partition scheme, and data compression options on both a table and a clustered index or non-inlined clustered constraint on that table, event though when options are specified on both, the options specified on the table are ignored by SQL Server.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ForbidDuplicateTableStorageSettings As Options
C#
public static Options ForbidDuplicateTableStorageSettings
Visual C++
public:
static Options ForbidDuplicateTableStorageSettings

Remarks

See http://social.msdn.microsoft.com/Forums/en-US/ssdt/thread/c5c8802f-c6d1-4986-9768-c5f7340bda34/

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


ForceColumnOrder Field

[image]

SQL Data Compare API 12.0.40
Options..::.ForceColumnOrder Field
Options Structure See Also

Force table column order to be identical.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Force table column order to be identical", "")> _
Public Shared ForceColumnOrder As Options
C#
[OptionDescriptionAttribute("Force table column order to be identical", "")]
public static Options ForceColumnOrder
Visual C++
[OptionDescriptionAttribute(L"Force table column order to be identical", L"")]
public:
static Options ForceColumnOrder

Remarks

If additional columns are inserted into the middle of a table this option will force a rebuild of the table so the column order after synchronization is correct

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


ForceSyncScriptGeneration Field

[image]

SQL Data Compare API 12.0.40
Options..::.ForceSyncScriptGeneration Field
Options Structure See Also

Generate a synchronization SQL script rather than folder sync actions when syncing to scripts.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Force sync sql when syncing to scripts", "Force sync sql when syncing to scripts")> _
Public Shared ForceSyncScriptGeneration As Options
C#
[OptionDescriptionAttribute("Force sync sql when syncing to scripts", "Force sync sql when syncing to scripts")]
public static Options ForceSyncScriptGeneration
Visual C++
[OptionDescriptionAttribute(L"Force sync sql when syncing to scripts", L"Force sync sql when syncing to scripts")]
public:
static Options ForceSyncScriptGeneration

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreBindings Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreBindings Field
Options Structure See Also

Ignore bindings.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore bindings", "")> _
Public Shared IgnoreBindings As Options
C#
[OptionDescriptionAttribute("Ignore bindings", "")]
public static Options IgnoreBindings
Visual C++
[OptionDescriptionAttribute(L"Ignore bindings", L"")]
public:
static Options IgnoreBindings

Remarks

Ignores bindings on columns and user defined types (eg sp_bindrule and sp_bindefault clauses won't be scripted)

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreCertificatesAndCryptoKeys Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreCertificatesAndCryptoKeys Field
Options Structure See Also

Ignore public certificates, symmetric keys and asymmetric keys in SQL Server 2005 databases.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore certificates, symmetric and asymmetric keys.",  _
    "Ignore certificates, symmetric and asymmetric keys.")> _
Public Shared IgnoreCertificatesAndCryptoKeys As Options
C#
[OptionDescriptionAttribute("Ignore certificates, symmetric and asymmetric keys.",
    "Ignore certificates, symmetric and asymmetric keys.")]
public static Options IgnoreCertificatesAndCryptoKeys
Visual C++
[OptionDescriptionAttribute(L"Ignore certificates, symmetric and asymmetric keys.",
    L"Ignore certificates, symmetric and asymmetric keys.")]
public:
static Options IgnoreCertificatesAndCryptoKeys

Remarks

Target database is post SQL Server 2005.

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreChecks Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreChecks Field
Options Structure See Also

Ignore check constraints.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore check constraints", "Ignores check constraints when comparing and synchronizing databases")> _
Public Shared IgnoreChecks As Options
C#
[OptionDescriptionAttribute("Ignore check constraints", "Ignores check constraints when comparing and synchronizing databases")]
public static Options IgnoreChecks
Visual C++
[OptionDescriptionAttribute(L"Ignore check constraints", L"Ignores check constraints when comparing and synchronizing databases")]
public:
static Options IgnoreChecks

Remarks

Ignores check constraints when comparing and synchronizing databases

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreCollations Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreCollations Field
Options Structure See Also

Ignore collation order.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore collation order", "Ignores collation orders on character datatype columns when comparing and synchronizing databases")> _
Public Shared IgnoreCollations As Options
C#
[OptionDescriptionAttribute("Ignore collation order", "Ignores collation orders on character datatype columns when comparing and synchronizing databases")]
public static Options IgnoreCollations
Visual C++
[OptionDescriptionAttribute(L"Ignore collation order", L"Ignores collation orders on character datatype columns when comparing and synchronizing databases")]
public:
static Options IgnoreCollations

Remarks

Ignores collation orders on character datatype columns when comparing and synchronizing databases

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreComments Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreComments Field
Options Structure See Also

Ignore comments.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore comments", "")> _
Public Shared IgnoreComments As Options
C#
[OptionDescriptionAttribute("Ignore comments", "")]
public static Options IgnoreComments
Visual C++
[OptionDescriptionAttribute(L"Ignore comments", L"")]
public:
static Options IgnoreComments

Remarks

Ignores comments when comparing views, stored procedures etc. Note that comments will still appear in the synchronization scripts

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreConstraintNames Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreConstraintNames Field
Options Structure See Also

Ignore constraint names.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore constraint and index names", "Ignores the names of foreign keys, indexes, primary keys, default, unique and check constraints.")> _
Public Shared IgnoreConstraintNames As Options
C#
[OptionDescriptionAttribute("Ignore constraint and index names", "Ignores the names of foreign keys, indexes, primary keys, default, unique and check constraints.")]
public static Options IgnoreConstraintNames
Visual C++
[OptionDescriptionAttribute(L"Ignore constraint and index names", L"Ignores the names of foreign keys, indexes, primary keys, default, unique and check constraints.")]
public:
static Options IgnoreConstraintNames

Remarks

Ignores the names of foreign keys, indexes, primary keys, default, unique and check constraints when comparing.

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreDatabaseAndServerName Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreDatabaseAndServerName Field
Options Structure See Also

Ignores database and server names in synonyms.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignores database and server name in synonyms.",  _
    "Ignores the database and server name in synonyms.")> _
Public Shared IgnoreDatabaseAndServerName As Options
C#
[OptionDescriptionAttribute("Ignores database and server name in synonyms.",
    "Ignores the database and server name in synonyms.")]
public static Options IgnoreDatabaseAndServerName
Visual C++
[OptionDescriptionAttribute(L"Ignores database and server name in synonyms.",
    L"Ignores the database and server name in synonyms.")]
public:
static Options IgnoreDatabaseAndServerName

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreDatabaseName Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreDatabaseName Field
Options Structure See Also

Ignores database and server names in synonyms.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Please use IgnoreDatabaseAndServerName instead",  _
    True)> _
<OptionDescriptionAttribute("Ignores database name in synonyms.", "Ignores the database name in synonyms.")> _
Public Shared IgnoreDatabaseName As Options
C#
[ObsoleteAttribute("Please use IgnoreDatabaseAndServerName instead",
    true)]
[OptionDescriptionAttribute("Ignores database name in synonyms.", "Ignores the database name in synonyms.")]
public static Options IgnoreDatabaseName
Visual C++
[ObsoleteAttribute(L"Please use IgnoreDatabaseAndServerName instead",
    true)]
[OptionDescriptionAttribute(L"Ignores database name in synonyms.", L"Ignores the database name in synonyms.")]
public:
static Options IgnoreDatabaseName

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreDataCompression Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreDataCompression Field
Options Structure See Also

Ignores data compression.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignores data compression options.", "Ignores data compression properties of indexes and tables.")> _
Public Shared IgnoreDataCompression As Options
C#
[OptionDescriptionAttribute("Ignores data compression options.", "Ignores data compression properties of indexes and tables.")]
public static Options IgnoreDataCompression
Visual C++
[OptionDescriptionAttribute(L"Ignores data compression options.", L"Ignores data compression properties of indexes and tables.")]
public:
static Options IgnoreDataCompression

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreDataSyncSchema Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreDataSyncSchema Field
Options Structure See Also

Ignore all objects contained in a schema called DataSync. Data Sync is an Azure feature that temporarily populates a user's database with objects that the user may want to ignore during comparison.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared IgnoreDataSyncSchema As Options
C#
public static Options IgnoreDataSyncSchema
Visual C++
public:
static Options IgnoreDataSyncSchema

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreExtendedProperties Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreExtendedProperties Field
Options Structure See Also

Ignore extended properties

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore extended properties", "Ignores extended properties when comparing and synchronizing databases")> _
Public Shared IgnoreExtendedProperties As Options
C#
[OptionDescriptionAttribute("Ignore extended properties", "Ignores extended properties when comparing and synchronizing databases")]
public static Options IgnoreExtendedProperties
Visual C++
[OptionDescriptionAttribute(L"Ignore extended properties", L"Ignores extended properties when comparing and synchronizing databases")]
public:
static Options IgnoreExtendedProperties

Remarks

Ignores extended properties when comparing and synchronizing databases

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreFileGroups Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreFileGroups Field
Options Structure See Also

Ignore filegroups, partition schemes, and partition functions.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore filegroups, partition schemes and partition functions.",  _
    "Ignores FILEGROUP clauses, partition functions and partition schemes on tables, queues and keys when comparing and synchronizing databases")> _
Public Shared IgnoreFileGroups As Options
C#
[OptionDescriptionAttribute("Ignore filegroups, partition schemes and partition functions.",
    "Ignores FILEGROUP clauses, partition functions and partition schemes on tables, queues and keys when comparing and synchronizing databases")]
public static Options IgnoreFileGroups
Visual C++
[OptionDescriptionAttribute(L"Ignore filegroups, partition schemes and partition functions.",
    L"Ignores FILEGROUP clauses, partition functions and partition schemes on tables, queues and keys when comparing and synchronizing databases")]
public:
static Options IgnoreFileGroups

Remarks

Ignores FILEGROUP clauses when comparing and synchronizing databases

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreFillFactor Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreFillFactor Field
Options Structure See Also

Ignore fill factor.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore fill factor and index padding", "Ignores the fill factor in indexes and primary keys when comparing and synchronizing databases")> _
Public Shared IgnoreFillFactor As Options
C#
[OptionDescriptionAttribute("Ignore fill factor and index padding", "Ignores the fill factor in indexes and primary keys when comparing and synchronizing databases")]
public static Options IgnoreFillFactor
Visual C++
[OptionDescriptionAttribute(L"Ignore fill factor and index padding", L"Ignores the fill factor in indexes and primary keys when comparing and synchronizing databases")]
public:
static Options IgnoreFillFactor

Remarks

Ignores the fill factor in indexes when comparing and synchronizing databases

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreFullTextIndexing Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreFullTextIndexing Field
Options Structure See Also

Ignore full text indexing.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore full text indexing", "Ignores full text indexes, catalogs etc. when comparing and synchronizing databases")> _
Public Shared IgnoreFullTextIndexing As Options
C#
[OptionDescriptionAttribute("Ignore full text indexing", "Ignores full text indexes, catalogs etc. when comparing and synchronizing databases")]
public static Options IgnoreFullTextIndexing
Visual C++
[OptionDescriptionAttribute(L"Ignore full text indexing", L"Ignores full text indexes, catalogs etc. when comparing and synchronizing databases")]
public:
static Options IgnoreFullTextIndexing

Remarks

Ignores full text indexes, catalogs etc. when comparing and synchronizing databases

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreIdentityProperties Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreIdentityProperties Field
Options Structure See Also

Ignores identity properties.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignores identity properties.", "Ignores identity properties.")> _
Public Shared IgnoreIdentityProperties As Options
C#
[OptionDescriptionAttribute("Ignores identity properties.", "Ignores identity properties.")]
public static Options IgnoreIdentityProperties
Visual C++
[OptionDescriptionAttribute(L"Ignores identity properties.", L"Ignores identity properties.")]
public:
static Options IgnoreIdentityProperties

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreIdentitySeedAndIncrement Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreIdentitySeedAndIncrement Field
Options Structure See Also

Ignore identity seed and increment values.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore identity seed and increment values", "")> _
Public Shared IgnoreIdentitySeedAndIncrement As Options
C#
[OptionDescriptionAttribute("Ignore identity seed and increment values", "")]
public static Options IgnoreIdentitySeedAndIncrement
Visual C++
[OptionDescriptionAttribute(L"Ignore identity seed and increment values", L"")]
public:
static Options IgnoreIdentitySeedAndIncrement

Remarks

Ignores identity seed and increment values when comparing databases. Note that they will still appear in synchronization scripts

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreIndexes Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreIndexes Field
Options Structure See Also

Ignore indexes.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore indexes", "Ignores indexes, statistics, unique constraints and primary keys when comparing and synchronizing databases")> _
Public Shared IgnoreIndexes As Options
C#
[OptionDescriptionAttribute("Ignore indexes", "Ignores indexes, statistics, unique constraints and primary keys when comparing and synchronizing databases")]
public static Options IgnoreIndexes
Visual C++
[OptionDescriptionAttribute(L"Ignore indexes", L"Ignores indexes, statistics, unique constraints and primary keys when comparing and synchronizing databases")]
public:
static Options IgnoreIndexes

Remarks

Ignores indexes, statistics, unique constraints and primary keys when comparing and synchronizing databases

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreIndexLockProperties Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreIndexLockProperties Field
Options Structure See Also

Ignore the lock properties of indexes.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore the lock properties of indexes.", "Ignore the lock properties of indexes.")> _
Public Shared IgnoreIndexLockProperties As Options
C#
[OptionDescriptionAttribute("Ignore the lock properties of indexes.", "Ignore the lock properties of indexes.")]
public static Options IgnoreIndexLockProperties
Visual C++
[OptionDescriptionAttribute(L"Ignore the lock properties of indexes.", L"Ignore the lock properties of indexes.")]
public:
static Options IgnoreIndexLockProperties

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreInsteadOfTriggers Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreInsteadOfTriggers Field
Options Structure See Also

Ignore INSTEAD OF triggers.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore INSTEAD OF triggers", "Ignores INSTEAD OF triggers when comparing and synchronizing databases")> _
Public Shared IgnoreInsteadOfTriggers As Options
C#
[OptionDescriptionAttribute("Ignore INSTEAD OF triggers", "Ignores INSTEAD OF triggers when comparing and synchronizing databases")]
public static Options IgnoreInsteadOfTriggers
Visual C++
[OptionDescriptionAttribute(L"Ignore INSTEAD OF triggers", L"Ignores INSTEAD OF triggers when comparing and synchronizing databases")]
public:
static Options IgnoreInsteadOfTriggers

Remarks

Ignores INSTEAD OF triggers when comparing and synchronizing databases

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreInternallyUsedMicrosoftExtendedProperties Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreInternallyUsedMicrosoftExtendedProperties Field
Options Structure See Also

Make scripting out of objects ignore the extended properties used internally by the SSMS designer

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared IgnoreInternallyUsedMicrosoftExtendedProperties As Options
C#
public static Options IgnoreInternallyUsedMicrosoftExtendedProperties
Visual C++
public:
static Options IgnoreInternallyUsedMicrosoftExtendedProperties

Remarks

This option affects the scripting out of objects so that extended properties used internally by the SSMS designer (e.g. MS_DiagramPaneCount, MS_DiagramPane1, MS_DiagramPane2, MS_DiagramPane3, etc) are not included in the deployment script

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreKeys Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreKeys Field
Options Structure See Also

Ignore foreign keys.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore foreign keys", "Ignores foreign keys when comparing and synchronizing databases")> _
Public Shared IgnoreKeys As Options
C#
[OptionDescriptionAttribute("Ignore foreign keys", "Ignores foreign keys when comparing and synchronizing databases")]
public static Options IgnoreKeys
Visual C++
[OptionDescriptionAttribute(L"Ignore foreign keys", L"Ignores foreign keys when comparing and synchronizing databases")]
public:
static Options IgnoreKeys

Remarks

Ignores foreign keys when comparing and synchronizing databases

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreMigrationScripts Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreMigrationScripts Field
Options Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Disable Migrations", "SQL Compare will not try to use Migrations when comparing databases.")> _
Public Shared IgnoreMigrationScripts As Options
C#
[OptionDescriptionAttribute("Disable Migrations", "SQL Compare will not try to use Migrations when comparing databases.")]
public static Options IgnoreMigrationScripts
Visual C++
[OptionDescriptionAttribute(L"Disable Migrations", L"SQL Compare will not try to use Migrations when comparing databases.")]
public:
static Options IgnoreMigrationScripts

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreNocheckAndWithNocheck Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreNocheckAndWithNocheck Field
Options Structure See Also

Ignores the NOCHECK and WITH NOCHECK arguments on foreign keys and check constraints.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignores the NOCHECK and WITH NOCHECK arguments on foreign keys and check constraints",  _
    "When this option is selected, SQL Compare always applies constraints, even when NOCHECK and WITH NOCHECK are enabled. The 'Ignore WITH NOCHECK' option is automatically selected.")> _
Public Shared IgnoreNocheckAndWithNocheck As Options
C#
[OptionDescriptionAttribute("Ignores the NOCHECK and WITH NOCHECK arguments on foreign keys and check constraints",
    "When this option is selected, SQL Compare always applies constraints, even when NOCHECK and WITH NOCHECK are enabled. The 'Ignore WITH NOCHECK' option is automatically selected.")]
public static Options IgnoreNocheckAndWithNocheck
Visual C++
[OptionDescriptionAttribute(L"Ignores the NOCHECK and WITH NOCHECK arguments on foreign keys and check constraints",
    L"When this option is selected, SQL Compare always applies constraints, even when NOCHECK and WITH NOCHECK are enabled. The 'Ignore WITH NOCHECK' option is automatically selected.")]
public:
static Options IgnoreNocheckAndWithNocheck

Remarks

When this option is selected, SQL Compare always applies constraints, even when NOCHECK and WITH NOCHECK are enabled. The 'Ignore WITH NOCHECK' option is automatically selected.

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreNotForReplication Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreNotForReplication Field
Options Structure See Also

Ignores NOT FOR REPLICATION.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignores the NOT FOR REPLICATION option.", "Ignores the NOT FOR REPLICATION option.")> _
Public Shared IgnoreNotForReplication As Options
C#
[OptionDescriptionAttribute("Ignores the NOT FOR REPLICATION option.", "Ignores the NOT FOR REPLICATION option.")]
public static Options IgnoreNotForReplication
Visual C++
[OptionDescriptionAttribute(L"Ignores the NOT FOR REPLICATION option.", L"Ignores the NOT FOR REPLICATION option.")]
public:
static Options IgnoreNotForReplication

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreNullability Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreNullability Field
Options Structure See Also

Ignore nullability of columns.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore nullability of columns.", "")> _
Public Shared IgnoreNullability As Options
C#
[OptionDescriptionAttribute("Ignore nullability of columns.", "")]
public static Options IgnoreNullability
Visual C++
[OptionDescriptionAttribute(L"Ignore nullability of columns.", L"")]
public:
static Options IgnoreNullability

Remarks

Ignore whether or not a column can allow NULL values when comparing and deploying databases.

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreOwners Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreOwners Field
Options Structure See Also

Ignore owners when checking for equality.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore owners when checking for equality.", "Ignore owners when checking for equality.")> _
Public Shared IgnoreOwners As Options
C#
[OptionDescriptionAttribute("Ignore owners when checking for equality.", "Ignore owners when checking for equality.")]
public static Options IgnoreOwners
Visual C++
[OptionDescriptionAttribute(L"Ignore owners when checking for equality.", L"Ignore owners when checking for equality.")]
public:
static Options IgnoreOwners

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnorePermissions Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnorePermissions Field
Options Structure See Also

Ignore permissions.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore permissions", "Ignores permissions on objects when comparing and synchronizing objects")> _
Public Shared IgnorePermissions As Options
C#
[OptionDescriptionAttribute("Ignore permissions", "Ignores permissions on objects when comparing and synchronizing objects")]
public static Options IgnorePermissions
Visual C++
[OptionDescriptionAttribute(L"Ignore permissions", L"Ignores permissions on objects when comparing and synchronizing objects")]
public:
static Options IgnorePermissions

Remarks

Ignores permissions on objects when comparing and synchronizing objects

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreQueueEventNotifications Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreQueueEventNotifications Field
Options Structure See Also

Ignore event notifications on queues.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore event notifications on queues.", "Ignore event notifications on queues.")> _
Public Shared IgnoreQueueEventNotifications As Options
C#
[OptionDescriptionAttribute("Ignore event notifications on queues.", "Ignore event notifications on queues.")]
public static Options IgnoreQueueEventNotifications
Visual C++
[OptionDescriptionAttribute(L"Ignore event notifications on queues.", L"Ignore event notifications on queues.")]
public:
static Options IgnoreQueueEventNotifications

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreQuotedIdentifiersAndAnsiNullSettings Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreQuotedIdentifiersAndAnsiNullSettings Field
Options Structure See Also

Ignore SET QUOTED_IDENTIFIER and SET ANSI_NULLS statements.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore SET QUOTED_IDENTIFIER and SET ANSI_NULLS statements",  _
    "")> _
Public Shared IgnoreQuotedIdentifiersAndAnsiNullSettings As Options
C#
[OptionDescriptionAttribute("Ignore SET QUOTED_IDENTIFIER and SET ANSI_NULLS statements",
    "")]
public static Options IgnoreQuotedIdentifiersAndAnsiNullSettings
Visual C++
[OptionDescriptionAttribute(L"Ignore SET QUOTED_IDENTIFIER and SET ANSI_NULLS statements",
    L"")]
public:
static Options IgnoreQuotedIdentifiersAndAnsiNullSettings

Remarks

Ignores these common SET statements when comparing views, stored procedures etc. Note that these statements will still appear in synchronization script. Note that all other Session SET statements are always ignored. It is not necessary to set this option for SSDT compatibility, it is part of the option group.

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreReplicationTriggers Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreReplicationTriggers Field
Options Structure See Also

Ignore replication triggers.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore replication triggers.", "Ignore replication triggers.")> _
Public Shared IgnoreReplicationTriggers As Options
C#
[OptionDescriptionAttribute("Ignore replication triggers.", "Ignore replication triggers.")]
public static Options IgnoreReplicationTriggers
Visual C++
[OptionDescriptionAttribute(L"Ignore replication triggers.", L"Ignore replication triggers.")]
public:
static Options IgnoreReplicationTriggers

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreSchemaObjectAuthorization Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreSchemaObjectAuthorization Field
Options Structure See Also

Ignores owner authorization on schema objects.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignores owner authorization on schema objects.",  _
    "Ignores owner authorization on schema objects.")> _
Public Shared IgnoreSchemaObjectAuthorization As Options
C#
[OptionDescriptionAttribute("Ignores owner authorization on schema objects.",
    "Ignores owner authorization on schema objects.")]
public static Options IgnoreSchemaObjectAuthorization
Visual C++
[OptionDescriptionAttribute(L"Ignores owner authorization on schema objects.",
    L"Ignores owner authorization on schema objects.")]
public:
static Options IgnoreSchemaObjectAuthorization

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreSquareBrackets Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreSquareBrackets Field
Options Structure See Also

Ignore square brackets in object names.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore square brackets in object names", "Ignore square brackets in object names")> _
Public Shared IgnoreSquareBrackets As Options
C#
[OptionDescriptionAttribute("Ignore square brackets in object names", "Ignore square brackets in object names")]
public static Options IgnoreSquareBrackets
Visual C++
[OptionDescriptionAttribute(L"Ignore square brackets in object names", L"Ignore square brackets in object names")]
public:
static Options IgnoreSquareBrackets

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreStatistics Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreStatistics Field
Options Structure See Also

Ignore statistics.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore statistics", "Ignores statistics when comparing and synchronizing")> _
Public Shared IgnoreStatistics As Options
C#
[OptionDescriptionAttribute("Ignore statistics", "Ignores statistics when comparing and synchronizing")]
public static Options IgnoreStatistics
Visual C++
[OptionDescriptionAttribute(L"Ignore statistics", L"Ignores statistics when comparing and synchronizing")]
public:
static Options IgnoreStatistics

Remarks

Ignores statistics when comparing and synchronizing

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreStatisticsNorecompute Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreStatisticsNorecompute Field
Options Structure See Also

Ignore the STATISTICS_NORECOMPUTE property on indexes.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore the STATISTICS_NORECOMPUTE property on indexes",  _
    "Ignore the STATISTICS_NORECOMPUTE property on indexes")> _
Public Shared IgnoreStatisticsNorecompute As Options
C#
[OptionDescriptionAttribute("Ignore the STATISTICS_NORECOMPUTE property on indexes",
    "Ignore the STATISTICS_NORECOMPUTE property on indexes")]
public static Options IgnoreStatisticsNorecompute
Visual C++
[OptionDescriptionAttribute(L"Ignore the STATISTICS_NORECOMPUTE property on indexes",
    L"Ignore the STATISTICS_NORECOMPUTE property on indexes")]
public:
static Options IgnoreStatisticsNorecompute

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreSynonymDependencies Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreSynonymDependencies Field
Options Structure See Also

Ignore dependencies through synonyms.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore dependencies through synonyms.", "Ignore dependencies through synonyms.")> _
Public Shared IgnoreSynonymDependencies As Options
C#
[OptionDescriptionAttribute("Ignore dependencies through synonyms.", "Ignore dependencies through synonyms.")]
public static Options IgnoreSynonymDependencies
Visual C++
[OptionDescriptionAttribute(L"Ignore dependencies through synonyms.", L"Ignore dependencies through synonyms.")]
public:
static Options IgnoreSynonymDependencies

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreSystemNamedConstraintNames Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreSystemNamedConstraintNames Field
Options Structure See Also

Ignore system named constraint names.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore system named constraint and index names",  _
    "Ignores the names of system named indexes, foreign keys, primary keys, default, unique and check constraints.")> _
Public Shared IgnoreSystemNamedConstraintNames As Options
C#
[OptionDescriptionAttribute("Ignore system named constraint and index names",
    "Ignores the names of system named indexes, foreign keys, primary keys, default, unique and check constraints.")]
public static Options IgnoreSystemNamedConstraintNames
Visual C++
[OptionDescriptionAttribute(L"Ignore system named constraint and index names",
    L"Ignores the names of system named indexes, foreign keys, primary keys, default, unique and check constraints.")]
public:
static Options IgnoreSystemNamedConstraintNames

Remarks

Ignores the names of system named (including Compare generated) foreign keys, indexes, primary keys, default, unique and check constraints when comparing.

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreTriggerOrder Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreTriggerOrder Field
Options Structure See Also

Ignore trigger order.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore trigger order.", "Ignore trigger order.")> _
Public Shared IgnoreTriggerOrder As Options
C#
[OptionDescriptionAttribute("Ignore trigger order.", "Ignore trigger order.")]
public static Options IgnoreTriggerOrder
Visual C++
[OptionDescriptionAttribute(L"Ignore trigger order.", L"Ignore trigger order.")]
public:
static Options IgnoreTriggerOrder

Remarks

Target server is either SQL Server 2000 or later.

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreTriggers Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreTriggers Field
Options Structure See Also

Ignore DML triggers.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore DML triggers", "Ignores DML triggers when comparing and synchronizing databases")> _
Public Shared IgnoreTriggers As Options
C#
[OptionDescriptionAttribute("Ignore DML triggers", "Ignores DML triggers when comparing and synchronizing databases")]
public static Options IgnoreTriggers
Visual C++
[OptionDescriptionAttribute(L"Ignore DML triggers", L"Ignores DML triggers when comparing and synchronizing databases")]
public:
static Options IgnoreTriggers

Remarks

Ignores DML triggers when comparing and synchronizing databases

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreTSQLT Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreTSQLT Field
Options Structure See Also

Ignores the tSQLt schema and its contents, the tSQLtCLR assembly, the SQLCop schema and its contents, and any schemas and their contents with the tSQLt.TestClass extended property set.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore tSQLT framework and tests", "Ignores the tSQLt schema and its contents, the tSQLtCLR assembly, the SQLCop schema and its contents, and any schemas and their contents with the tSQLt.TestClass extended property set.")> _
Public Shared IgnoreTSQLT As Options
C#
[OptionDescriptionAttribute("Ignore tSQLT framework and tests", "Ignores the tSQLt schema and its contents, the tSQLtCLR assembly, the SQLCop schema and its contents, and any schemas and their contents with the tSQLt.TestClass extended property set.")]
public static Options IgnoreTSQLT
Visual C++
[OptionDescriptionAttribute(L"Ignore tSQLT framework and tests", L"Ignores the tSQLt schema and its contents, the tSQLtCLR assembly, the SQLCop schema and its contents, and any schemas and their contents with the tSQLt.TestClass extended property set.")]
public:
static Options IgnoreTSQLT

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreUserProperties Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreUserProperties Field
Options Structure See Also

Ignore user properties.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore users' properties in comparison.", "Ignore users' properties in comparison.")> _
Public Shared IgnoreUserProperties As Options
C#
[OptionDescriptionAttribute("Ignore users' properties in comparison.", "Ignore users' properties in comparison.")]
public static Options IgnoreUserProperties
Visual C++
[OptionDescriptionAttribute(L"Ignore users' properties in comparison.", L"Ignore users' properties in comparison.")]
public:
static Options IgnoreUserProperties

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreUsers Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreUsers Field
Options Structure See Also

Ignore users' permissions and role memberships.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore users' permissions and role memberships.",  _
    "Ignore users' permissions and role memberships.")> _
Public Shared IgnoreUsers As Options
C#
[OptionDescriptionAttribute("Ignore users' permissions and role memberships.",
    "Ignore users' permissions and role memberships.")]
public static Options IgnoreUsers
Visual C++
[OptionDescriptionAttribute(L"Ignore users' permissions and role memberships.",
    L"Ignore users' permissions and role memberships.")]
public:
static Options IgnoreUsers

Remarks

This should really be called something like IgnoreUserBasedPermissions. The idea is that if people are doing The Right Thing (tm) and assigning all permissions to roles rather than directly to users, then those roles are part of the schema. However, the individual users who are members of those roles (and any permissions that happen to be assigned to users) aren't part of the schema and so aren't worthy of attention.

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreWhiteSpace Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreWhiteSpace Field
Options Structure See Also

Ignore white space.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore white space", "Ignores white space (newlines, tabs, spaces etc.) when comparing objects")> _
Public Shared IgnoreWhiteSpace As Options
C#
[OptionDescriptionAttribute("Ignore white space", "Ignores white space (newlines, tabs, spaces etc.) when comparing objects")]
public static Options IgnoreWhiteSpace
Visual C++
[OptionDescriptionAttribute(L"Ignore white space", L"Ignores white space (newlines, tabs, spaces etc.) when comparing objects")]
public:
static Options IgnoreWhiteSpace

Remarks

Ignores white space (newlines, tabs, spaces etc.) when comparing objects

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreWithElementOrder Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreWithElementOrder Field
Options Structure See Also

Ignore the order of with elements in non CLR stored procedures, functions, triggers, DDL triggers and views.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore the order of with elements.", "Ignore the order of with elements.")> _
Public Shared IgnoreWithElementOrder As Options
C#
[OptionDescriptionAttribute("Ignore the order of with elements.", "Ignore the order of with elements.")]
public static Options IgnoreWithElementOrder
Visual C++
[OptionDescriptionAttribute(L"Ignore the order of with elements.", L"Ignore the order of with elements.")]
public:
static Options IgnoreWithElementOrder

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreWithEncryption Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreWithEncryption Field
Options Structure See Also

Ignore WITH ENCRYPTION statements on triggers, views, stored procedures and functions

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignore WITH ENCRYPTION statements.", "Ignore WITH ENCRYPTION statements on triggers, views, stored procedures and functions.")> _
Public Shared IgnoreWithEncryption As Options
C#
[OptionDescriptionAttribute("Ignore WITH ENCRYPTION statements.", "Ignore WITH ENCRYPTION statements on triggers, views, stored procedures and functions.")]
public static Options IgnoreWithEncryption
Visual C++
[OptionDescriptionAttribute(L"Ignore WITH ENCRYPTION statements.", L"Ignore WITH ENCRYPTION statements on triggers, views, stored procedures and functions.")]
public:
static Options IgnoreWithEncryption

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IgnoreWithNocheck Field

[image]

SQL Data Compare API 12.0.40
Options..::.IgnoreWithNocheck Field
Options Structure See Also

Ignores the WITH NOCHECK argument on foreign keys and check constraints.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Ignores the WITH NOCHECK argument on foreign keys and check constraints",  _
    "When this option is selected, disabled constraints aren't ignored, so this option is useful if you want to find out if a constraint is disabled.")> _
Public Shared IgnoreWithNocheck As Options
C#
[OptionDescriptionAttribute("Ignores the WITH NOCHECK argument on foreign keys and check constraints",
    "When this option is selected, disabled constraints aren't ignored, so this option is useful if you want to find out if a constraint is disabled.")]
public static Options IgnoreWithNocheck
Visual C++
[OptionDescriptionAttribute(L"Ignores the WITH NOCHECK argument on foreign keys and check constraints",
    L"When this option is selected, disabled constraints aren't ignored, so this option is useful if you want to find out if a constraint is disabled.")]
public:
static Options IgnoreWithNocheck

Remarks

When this option is selected, disabled constraints aren't ignored, so this option is useful if you want to find out if a constraint is disabled.

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IncludeDependencies Field

[image]

SQL Data Compare API 12.0.40
Options..::.IncludeDependencies Field
Options Structure See Also

Include dependencies.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Include dependencies", "")> _
Public Shared IncludeDependencies As Options
C#
[OptionDescriptionAttribute("Include dependencies", "")]
public static Options IncludeDependencies
Visual C++
[OptionDescriptionAttribute(L"Include dependencies", L"")]
public:
static Options IncludeDependencies

Remarks

Includes dependent objects when comparing and synchronizing databases. For example, if a view depends on a table then the table will be synchronized when synchronizing the view

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


InferTypeForSqlVariant Field

[image]

SQL Data Compare API 12.0.40
Options..::.InferTypeForSqlVariant Field
Options Structure See Also

Allow SQL server to infer the type of a sql variant rather than trying to help it.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared InferTypeForSqlVariant As Options
C#
public static Options InferTypeForSqlVariant
Visual C++
public:
static Options InferTypeForSqlVariant

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


InlineFulltextFields Field

[image]

SQL Data Compare API 12.0.40
Options..::.InlineFulltextFields Field
Options Structure See Also

Script out FullText indexes as a single create instead of lots of ALTERs.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared InlineFulltextFields As Options
C#
public static Options InlineFulltextFields
Visual C++
public:
static Options InlineFulltextFields

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


InlineTableObjects Field

[image]

SQL Data Compare API 12.0.40
Options..::.InlineTableObjects Field
Options Structure See Also

Script out definitions as part of the table's body where possible for primary keys, foreign keys etc. Only some Indexes can be inlined.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared InlineTableObjects As Options
C#
public static Options InlineTableObjects
Visual C++
public:
static Options InlineTableObjects

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


NoAutoColumnMapping Field

[image]

SQL Data Compare API 12.0.40
Options..::.NoAutoColumnMapping Field
Options Structure See Also

Do not automatically map 'sufficiently similar' columns in mapped tables. If set, only identical columns will be mapped.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared NoAutoColumnMapping As Options
C#
public static Options NoAutoColumnMapping
Visual C++
public:
static Options NoAutoColumnMapping

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


NoErrorHandling Field

[image]

SQL Data Compare API 12.0.40
Options..::.NoErrorHandling Field
Options Structure See Also

Do not include error handling for synchronization scripts.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Do not include error handling for transactional synchronization scripts",  _
    "Removes error handling from the synchronization scripts to produce more readable SQL")> _
Public Shared NoErrorHandling As Options
C#
[OptionDescriptionAttribute("Do not include error handling for transactional synchronization scripts",
    "Removes error handling from the synchronization scripts to produce more readable SQL")]
public static Options NoErrorHandling
Visual C++
[OptionDescriptionAttribute(L"Do not include error handling for transactional synchronization scripts",
    L"Removes error handling from the synchronization scripts to produce more readable SQL")]
public:
static Options NoErrorHandling

Remarks

Removes error handling from the synchronization scripts to produce more readable SQL

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


None Field

[image]

SQL Data Compare API 12.0.40
Options..::.None Field
Options Structure See Also

None.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared None As Options
C#
public static Options None
Visual C++
public:
static Options None

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


NoSQLPlumbing Field

[image]

SQL Data Compare API 12.0.40
Options..::.NoSQLPlumbing Field
Options Structure See Also

Do not include plumbing for transactional synchronization scripts.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Do not include transactions and error handling for transactional synchronization scripts",  _
    "Removes transactions and error handling from the synchronization scripts to produce more readable SQL")> _
Public Shared NoSQLPlumbing As Options
C#
[OptionDescriptionAttribute("Do not include transactions and error handling for transactional synchronization scripts",
    "Removes transactions and error handling from the synchronization scripts to produce more readable SQL")]
public static Options NoSQLPlumbing
Visual C++
[OptionDescriptionAttribute(L"Do not include transactions and error handling for transactional synchronization scripts",
    L"Removes transactions and error handling from the synchronization scripts to produce more readable SQL")]
public:
static Options NoSQLPlumbing

Remarks

Removes both transactions and error handling from the synchronization scripts to produce more readable SQL

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


NoTransactions Field

[image]

SQL Data Compare API 12.0.40
Options..::.NoTransactions Field
Options Structure See Also

Do not include error handling for transactional synchronization scripts.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Do not include transactions for transactional synchronization scripts",  _
    "Removes transactions from the synchronization scripts to produce more readable SQL")> _
Public Shared NoTransactions As Options
C#
[OptionDescriptionAttribute("Do not include transactions for transactional synchronization scripts",
    "Removes transactions from the synchronization scripts to produce more readable SQL")]
public static Options NoTransactions
Visual C++
[OptionDescriptionAttribute(L"Do not include transactions for transactional synchronization scripts",
    L"Removes transactions from the synchronization scripts to produce more readable SQL")]
public:
static Options NoTransactions

Remarks

Removes error handling from the synchronization scripts to produce more readable SQL

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


ObjectExistenceChecks Field

[image]

SQL Data Compare API 12.0.40
Options..::.ObjectExistenceChecks Field
Options Structure See Also

Adds if exists checks before objects are modified to make the generated scripts rerunnable

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ObjectExistenceChecks As Options
C#
public static Options ObjectExistenceChecks
Visual C++
public:
static Options ObjectExistenceChecks

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


ReadAsDataToolsPermissions Field

[image]

SQL Data Compare API 12.0.40
Options..::.ReadAsDataToolsPermissions Field
Options Structure See Also

WIP - Read in permissions from a script folder as though they were from a Data Tools project.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadAsDataToolsPermissions As Options
C#
public static Options ReadAsDataToolsPermissions
Visual C++
public:
static Options ReadAsDataToolsPermissions

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


SeparateTriggers Field

[image]

SQL Data Compare API 12.0.40
Options..::.SeparateTriggers Field
Options Structure See Also

Separate triggers from tables and views.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Separate triggers from tables and views.", "Separate triggers from tables and views.")> _
Public Shared SeparateTriggers As Options
C#
[OptionDescriptionAttribute("Separate triggers from tables and views.", "Separate triggers from tables and views.")]
public static Options SeparateTriggers
Visual C++
[OptionDescriptionAttribute(L"Separate triggers from tables and views.", L"Separate triggers from tables and views.")]
public:
static Options SeparateTriggers

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


SsdtCompatibleOptions Field

[image]

SQL Data Compare API 12.0.40
Options..::.SsdtCompatibleOptions Field
Options Structure See Also

Make script folder output output compatible with SSDT.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("When writing to a scripts folder, write scripts that can be read by SSDT.",  _
    "This option group contains all relevant options to  ignore ANSI_NULLS set statements, write out permissions differently, use a different XML info file, and write SQL more declaratively.")> _
Public Shared SsdtCompatibleOptions As Options
C#
[OptionDescriptionAttribute("When writing to a scripts folder, write scripts that can be read by SSDT.",
    "This option group contains all relevant options to  ignore ANSI_NULLS set statements, write out permissions differently, use a different XML info file, and write SQL more declaratively.")]
public static Options SsdtCompatibleOptions
Visual C++
[OptionDescriptionAttribute(L"When writing to a scripts folder, write scripts that can be read by SSDT.",
    L"This option group contains all relevant options to  ignore ANSI_NULLS set statements, write out permissions differently, use a different XML info file, and write SQL more declaratively.")]
public:
static Options SsdtCompatibleOptions

Remarks

IgnorePermissions is temporarily here until we've implemented support for SSDT style permissions IgnoreQuotedIdentifiersAndAnsiNullSettings is here because SET statements should not be part of an SSDT script and are stored separately. IgnoreWithNocheck is here because adding constraints with nocheck doesn't make sense as part of a DDL script - which has no data. IgnoreSystemNamedConstraintNames is here because sometimes SSDT style scripted objects don't have names, so when Compare generates a name internally it should continue to be ignored. InlineTableObjects is here because SSDT objects can't reference table objects created in ALTER statements (though the alter statements can be parsed). InlineFulltextFields is here for similar reasons to the above. InferTypeForSqlVariant is here because the trick Compare normally uses to tell SQL Server the actual type isn't supported in SSDT. UseSetStatementsInScriptDatabaseInfo is here because Set Statements can't be in scripts in SSDT. Eventually we'll probably just read this information from the sqlproj. WIP WriteAssembliesAsDlls - SSDT writes dlls by default WIP ForbidDuplicateIndexSettingsOnTable - some SSDT versions don't compile with duplicate table storage settings

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


ThrowOnFileParseFailed Field

[image]

SQL Data Compare API 12.0.40
Options..::.ThrowOnFileParseFailed Field
Options Structure See Also

Throw an exception when parsing a scripts fails during Register. If this option is not set then the file (and all objects in it) will be ignored.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Strict scripts folder registration", "Throw an exception when parsing a scripts fails during Register.")> _
Public Shared ThrowOnFileParseFailed As Options
C#
[OptionDescriptionAttribute("Strict scripts folder registration", "Throw an exception when parsing a scripts fails during Register.")]
public static Options ThrowOnFileParseFailed
Visual C++
[OptionDescriptionAttribute(L"Strict scripts folder registration", L"Throw an exception when parsing a scripts fails during Register.")]
public:
static Options ThrowOnFileParseFailed

Remarks

This value used to mean see cref="IgnoreDatabaseName"/>

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


UseClrUdtToStringForClrMigration Field

[image]

SQL Data Compare API 12.0.40
Options..::.UseClrUdtToStringForClrMigration Field
Options Structure See Also

If a CLR assembly must be changed, unbind the dependent types from tables using ToString, and then convert these table values back to CLR type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Do not use ALTER ASSEMBLY to change CLR types.",  _
    "This option is used only for SQL Server 2005 databases. If CLR types are to be synchronized, this option forces two rebuilds of the table with conversion to and from strings to update the CLR public types, instead of using ALTER ASSEMBLY. For a detailed explanation, see the online help. This option affects the synchronization only.")> _
Public Shared UseClrUdtToStringForClrMigration As Options
C#
[OptionDescriptionAttribute("Do not use ALTER ASSEMBLY to change CLR types.",
    "This option is used only for SQL Server 2005 databases. If CLR types are to be synchronized, this option forces two rebuilds of the table with conversion to and from strings to update the CLR public types, instead of using ALTER ASSEMBLY. For a detailed explanation, see the online help. This option affects the synchronization only.")]
public static Options UseClrUdtToStringForClrMigration
Visual C++
[OptionDescriptionAttribute(L"Do not use ALTER ASSEMBLY to change CLR types.",
    L"This option is used only for SQL Server 2005 databases. If CLR types are to be synchronized, this option forces two rebuilds of the table with conversion to and from strings to update the CLR public types, instead of using ALTER ASSEMBLY. For a detailed explanation, see the online help. This option affects the synchronization only.")]
public:
static Options UseClrUdtToStringForClrMigration

Remarks

Target database is post SQL Server 2005.

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


UseCompatibilityLevel Field

[image]

SQL Data Compare API 12.0.40
Options..::.UseCompatibilityLevel Field
Options Structure See Also

Ignore database compatibility level

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<OptionDescriptionAttribute("Use database compatibility level to determine supported features",  _
    "Makes SQL Compare use the compatibility level of your database to determine the features that are supported rather than the server version.")> _
Public Shared UseCompatibilityLevel As Options
C#
[OptionDescriptionAttribute("Use database compatibility level to determine supported features",
    "Makes SQL Compare use the compatibility level of your database to determine the features that are supported rather than the server version.")]
public static Options UseCompatibilityLevel
Visual C++
[OptionDescriptionAttribute(L"Use database compatibility level to determine supported features",
    L"Makes SQL Compare use the compatibility level of your database to determine the features that are supported rather than the server version.")]
public:
static Options UseCompatibilityLevel

Remarks

Makes SQL Compare use the server version for checking support of various features rather than the database compatibility level

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


UseSetStatementsInScriptDatabaseInfo Field

[image]

SQL Data Compare API 12.0.40
Options..::.UseSetStatementsInScriptDatabaseInfo Field
Options Structure See Also

Use RedGateDatabaseProperties.xml to store/recover set statements for objects.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared UseSetStatementsInScriptDatabaseInfo As Options
C#
public static Options UseSetStatementsInScriptDatabaseInfo
Visual C++
public:
static Options UseSetStatementsInScriptDatabaseInfo

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


WriteAsDataToolsPermissions Field

[image]

SQL Data Compare API 12.0.40
Options..::.WriteAsDataToolsPermissions Field
Options Structure See Also

WIP - Script out Permissions so they're correct as far as a Data Tools project is concerned.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared WriteAsDataToolsPermissions As Options
C#
public static Options WriteAsDataToolsPermissions
Visual C++
public:
static Options WriteAsDataToolsPermissions

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


WriteAssembliesAsDlls Field

[image]

SQL Data Compare API 12.0.40
Options..::.WriteAssembliesAsDlls Field
Options Structure See Also

WIP - CLR Assembly objects will be written in their true DLL form rather than our legacy sql script containing a binary blob in hex.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared WriteAssembliesAsDlls As Options
C#
public static Options WriteAssembliesAsDlls
Visual C++
public:
static Options WriteAssembliesAsDlls

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


Options Methods

[image] [image]

SQL Data Compare API 12.0.40
Options Methods
Options Structure See Also

The Options type exposes the following methods.

Methods

Name | Description
AreAllEnabled | Overloaded.
AreAnyEnabled |
Equals | Overloaded.
Except |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromOldOptionsLong |
FromString |
GetHashCode | (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValidatedOptions |
IsOptionSet |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Plus |
SetOptions |
ToString | (Overrides ValueType..::.ToString()()().)
TryParseOptionName |
TrySetOption |

Operators

Name | Description
Equality |
Inequality |

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


AreAllEnabled Method

[image] [image]

SQL Data Compare API 12.0.40
Options..::.AreAllEnabled Method
Options Structure See Also

Overload List

Name | Description
AreAllEnabled(Options) |
AreAllEnabled(array<Options>[]()[]) |

See Also

Options Structure
Options Members
RedGate.SQLCompare.Engine Namespace


AreAllEnabled Method (Options)

[image]

SQL Data Compare API 12.0.40
Options..::.AreAllEnabled Method (Options)
Options Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function AreAllEnabled ( _
    desired As Options _
) As Boolean
C#
public bool AreAllEnabled(
    Options desired
)
Visual C++
public:
bool AreAllEnabled(
    Options desired
)

Parameters

desired
Type: RedGate.SQLCompare.Engine..::.Options

See Also

Options Structure
AreAllEnabled Overload
RedGate.SQLCompare.Engine Namespace


AreAllEnabled Method (Options[])

[image]

SQL Data Compare API 12.0.40
Options..::.AreAllEnabled Method (array<Options>[]()[])
Options Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function AreAllEnabled ( _
    ParamArray desired As Options() _
) As Boolean
C#
public bool AreAllEnabled(
    params Options[] desired
)
Visual C++
public:
bool AreAllEnabled(
    ... array<Options>^ desired
)

Parameters

desired
Type: array< RedGate.SQLCompare.Engine..::.Options >[]()[]

See Also

Options Structure
AreAllEnabled Overload
RedGate.SQLCompare.Engine Namespace


AreAnyEnabled Method

[image]

SQL Data Compare API 12.0.40
Options..::.AreAnyEnabled Method
Options Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function AreAnyEnabled ( _
    desired As Options _
) As Boolean
C#
public bool AreAnyEnabled(
    Options desired
)
Visual C++
public:
bool AreAnyEnabled(
    Options desired
)

Parameters

desired
Type: RedGate.SQLCompare.Engine..::.Options

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


Equality Operator

[image]

SQL Data Compare API 12.0.40
Options..::.Equality Operator
Options Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator = ( _
    one As Options, _
    other As Options _
) As Boolean
C#
public static bool operator ==(
    Options one,
    Options other
)
Visual C++
public:
static bool operator ==(
    Options one,
    Options other
)

Parameters

one
Type: RedGate.SQLCompare.Engine..::.Options
other
Type: RedGate.SQLCompare.Engine..::.Options

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
Options..::.Equals Method
Options Structure See Also

Overload List

Name | Description
Equals(Object) | (Overrides ValueType..::.Equals(Object).)
Equals(Options) |

See Also

Options Structure
Options Members
RedGate.SQLCompare.Engine Namespace


Equals Method ()

[image]

SQL Data Compare API 12.0.40
Options..::.Equals Method ()
Options Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
C#
public override bool Equals(
    Object other
)
Visual C++
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: Object

See Also

Options Structure
Equals Overload
RedGate.SQLCompare.Engine Namespace


Equals Method (Options)

[image]

SQL Data Compare API 12.0.40
Options..::.Equals Method (Options)
Options Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    other As Options _
) As Boolean
C#
public bool Equals(
    Options other
)
Visual C++
public:
virtual bool Equals(
    Options other
) sealed

Parameters

other
Type: RedGate.SQLCompare.Engine..::.Options

Implements

IEquatableEquals(UTP)

See Also

Options Structure
Equals Overload
RedGate.SQLCompare.Engine Namespace


Except Method

[image]

SQL Data Compare API 12.0.40
Options..::.Except Method
Options Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Except ( _
    ParamArray optionsToExclude As Options() _
) As Options
C#
public Options Except(
    params Options[] optionsToExclude
)
Visual C++
public:
Options Except(
    ... array<Options>^ optionsToExclude
)

Parameters

optionsToExclude
Type: array< RedGate.SQLCompare.Engine..::.Options >[]()[]

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


FromOldOptionsLong Method

[image]

SQL Data Compare API 12.0.40
Options..::.FromOldOptionsLong Method
Options Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FromOldOptionsLong ( _
    input As Long _
) As Options
C#
public static Options FromOldOptionsLong(
    long input
)
Visual C++
public:
static Options FromOldOptionsLong(
    long long input
)

Parameters

input
Type: Int64

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


FromString Method

[image]

SQL Data Compare API 12.0.40
Options..::.FromString Method
Options Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FromString ( _
    input As String _
) As Options
C#
public static Options FromString(
    string input
)
Visual C++
public:
static Options FromString(
    String^ input
)

Parameters

input
Type: String

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
Options..::.GetHashCode Method
Options Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


GetValidatedOptions Method

[image]

SQL Data Compare API 12.0.40
Options..::.GetValidatedOptions Method
Options Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValidatedOptions As Options
C#
public Options GetValidatedOptions()
Visual C++
public:
Options GetValidatedOptions()

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


Inequality Operator

[image]

SQL Data Compare API 12.0.40
Options..::.Inequality Operator
Options Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <> ( _
    one As Options, _
    other As Options _
) As Boolean
C#
public static bool operator !=(
    Options one,
    Options other
)
Visual C++
public:
static bool operator !=(
    Options one,
    Options other
)

Parameters

one
Type: RedGate.SQLCompare.Engine..::.Options
other
Type: RedGate.SQLCompare.Engine..::.Options

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


IsOptionSet Method

[image]

SQL Data Compare API 12.0.40
Options..::.IsOptionSet Method
Options Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function IsOptionSet ( _
    optionName As String _
) As Boolean
C#
public bool IsOptionSet(
    string optionName
)
Visual C++
public:
bool IsOptionSet(
    String^ optionName
)

Parameters

optionName
Type: String

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


Plus Method

[image]

SQL Data Compare API 12.0.40
Options..::.Plus Method
Options Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Plus ( _
    ParamArray additionalOptions As Options() _
) As Options
C#
public Options Plus(
    params Options[] additionalOptions
)
Visual C++
public:
Options Plus(
    ... array<Options>^ additionalOptions
)

Parameters

additionalOptions
Type: array< RedGate.SQLCompare.Engine..::.Options >[]()[]

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


SetOptions Method

[image]

SQL Data Compare API 12.0.40
Options..::.SetOptions Method
Options Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function SetOptions ( _
    setOptions As Options, _
    areSet As Boolean _
) As Options
C#
public Options SetOptions(
    Options setOptions,
    bool areSet
)
Visual C++
public:
Options SetOptions(
    Options setOptions,
    bool areSet
)

Parameters

setOptions
Type: RedGate.SQLCompare.Engine..::.Options
areSet
Type: Boolean

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
Options..::.ToString Method
Options Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


TryParseOptionName Method

[image]

SQL Data Compare API 12.0.40
Options..::.TryParseOptionName Method
Options Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function TryParseOptionName ( _
    optionName As String, _
    <OutAttribute> ByRef namedOption As Options _
) As Boolean
C#
public static bool TryParseOptionName(
    string optionName,
    out Options namedOption
)
Visual C++
public:
static bool TryParseOptionName(
    String^ optionName,
    [OutAttribute] Options% namedOption
)

Parameters

optionName
Type: String
namedOption
Type: RedGate.SQLCompare.Engine..::.Options %

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


TrySetOption Method

[image]

SQL Data Compare API 12.0.40
Options..::.TrySetOption Method
Options Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function TrySetOption ( _
    optionName As String, _
    isSet As Boolean _
) As Options
C#
public Options TrySetOption(
    string optionName,
    bool isSet
)
Visual C++
public:
Options TrySetOption(
    String^ optionName,
    bool isSet
)

Parameters

optionName
Type: String
isSet
Type: Boolean

See Also

Options Structure
RedGate.SQLCompare.Engine Namespace


OptionsExtensions Class

[image]

SQL Data Compare API 12.0.40
OptionsExtensions Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class OptionsExtensions
C#
public static class OptionsExtensions
Visual C++
public ref class OptionsExtensions abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.OptionsExtensions

See Also

OptionsExtensions Members
RedGate.SQLCompare.Engine Namespace


OptionsExtensions Members

[image] [image]

SQL Data Compare API 12.0.40
OptionsExtensions Members
OptionsExtensions Class Methods See Also

The OptionsExtensions type exposes the following members.

Methods

Name | Description
IsDeployOption |
TryFromString |
WithOptionsFromFolder | Enables any options that are hinted at by information in the given folder, for example, SSDT compatibility is added if there's a sqlproj.

See Also

OptionsExtensions Class
RedGate.SQLCompare.Engine Namespace


OptionsExtensions Methods

[image] [image]

SQL Data Compare API 12.0.40
OptionsExtensions Methods
OptionsExtensions Class See Also

The OptionsExtensions type exposes the following methods.

Methods

Name | Description
IsDeployOption |
TryFromString |
WithOptionsFromFolder | Enables any options that are hinted at by information in the given folder, for example, SSDT compatibility is added if there's a sqlproj.

See Also

OptionsExtensions Class
RedGate.SQLCompare.Engine Namespace


IsDeployOption Method

[image]

SQL Data Compare API 12.0.40
OptionsExtensions..::.IsDeployOption Method
OptionsExtensions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsDeployOption ( _
    option As Options _
) As Boolean
C#
public static bool IsDeployOption(
    Options option
)
Visual C++
public:
static bool IsDeployOption(
    Options option
)

Parameters

option
Type: RedGate.SQLCompare.Engine..::.Options

See Also

OptionsExtensions Class
RedGate.SQLCompare.Engine Namespace


TryFromString Method

[image]

SQL Data Compare API 12.0.40
OptionsExtensions..::.TryFromString Method
OptionsExtensions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function TryFromString ( _
    input As String, _
    <OutAttribute> ByRef result As Options _
) As Boolean
C#
public static bool TryFromString(
    string input,
    out Options result
)
Visual C++
public:
static bool TryFromString(
    String^ input,
    [OutAttribute] Options% result
)

Parameters

input
Type: String
result
Type: RedGate.SQLCompare.Engine..::.Options %

See Also

OptionsExtensions Class
RedGate.SQLCompare.Engine Namespace


WithOptionsFromFolder Method

[image]

SQL Data Compare API 12.0.40
OptionsExtensions..::.WithOptionsFromFolder Method
OptionsExtensions Class See Also

Enables any options that are hinted at by information in the given folder, for example, SSDT compatibility is added if there's a sqlproj.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function WithOptionsFromFolder ( _
    options As Options, _
    path As String _
) As Options
C#
public static Options WithOptionsFromFolder(
    Options options,
    string path
)
Visual C++
public:
static Options WithOptionsFromFolder(
    Options options,
    String^ path
)

Parameters

options
Type: RedGate.SQLCompare.Engine..::.Options
path
Type: String

See Also

OptionsExtensions Class
RedGate.SQLCompare.Engine Namespace


Parameter Class

[image]

SQL Data Compare API 12.0.40
Parameter Class
Members See Also

A SQL Server parameter.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Parameter _
    Implements IPatchUpAfterDeserialization
C#
public sealed class Parameter : IPatchUpAfterDeserialization
Visual C++
public ref class Parameter sealed : IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.Parameter

See Also

Parameter Members
RedGate.SQLCompare.Engine Namespace


Parameter Members

[image] [image]

SQL Data Compare API 12.0.40
Parameter Members
Parameter Class Methods Properties See Also

The Parameter type exposes the following members.

Methods

Name | Description
CompareWith | Return a list of differences between this and , modified by
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Collation | The collation of the parameter.
DefaultValue | SQL representing the default value of the parameter.
DefinedSize | The length of the parameter.
FullyQualifiedTypeName | The name of the fully-qualified field type. For SQL Server 2005, this property contains the schema name.
HasDefaultValue | True if there is a default value.
IsOutput | Indicates whether the parameter is an output parameter.
Name | The name of the parameter
Precision | The precision of a decimal or numeric data type.
Scale | The scale of the parameter.
SqlType | The type of the parameter.
TypeName | The name of the type of the parameter.
TypeSchemaName | The name of the schema for the field's data type.
XmlDocument | True if the parameter is an XML document.
XmlSchemaCollection | The XML schema collection for strongly-typed XML parameters.

See Also

Parameter Class
RedGate.SQLCompare.Engine Namespace


Parameter Methods

[image] [image]

SQL Data Compare API 12.0.40
Parameter Methods
Parameter Class See Also

The Parameter type exposes the following methods.

Methods

Name | Description
CompareWith | Return a list of differences between this and , modified by
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Parameter Class
RedGate.SQLCompare.Engine Namespace


CompareWith Method

[image]

SQL Data Compare API 12.0.40
Parameter..::.CompareWith Method
Parameter Class See Also

Return a list of differences between this and , modified by

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareWith ( _
    target As Parameter, _
    options As Options _
) As IEnumerable(Of EqualityDifference)
C#
public IEnumerable<EqualityDifference> CompareWith(
    Parameter target,
    Options options
)
Visual C++
public:
IEnumerable<EqualityDifference^>^ CompareWith(
    Parameter^ target,
    Options options
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.Parameter
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

Parameter Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
Parameter..::.Equals Method
Parameter Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(Parameter, Options) | Compares the parameter with a specified parameter.

See Also

Parameter Class
Parameter Members
RedGate.SQLCompare.Engine Namespace


Equals Method (Parameter, Options)

[image]

SQL Data Compare API 12.0.40
Parameter..::.Equals Method (Parameter, Options)
Parameter Class See Also

Compares the parameter with a specified parameter.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    targetParameter As Parameter, _
    options As Options _
) As Boolean
C#
public bool Equals(
    Parameter targetParameter,
    Options options
)
Visual C++
public:
bool Equals(
    Parameter^ targetParameter,
    Options options
)

Parameters

targetParameter
Type: RedGate.SQLCompare.Engine..::.Parameter
The parameter to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the parameters are identical; otherwise, false.

See Also

Parameter Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
Parameter..::.PatchUpAfterDeserialization Method
Parameter Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

Parameter Class
RedGate.SQLCompare.Engine Namespace


Parameter Properties

[image] [image]

SQL Data Compare API 12.0.40
Parameter Properties
Parameter Class See Also

The Parameter type exposes the following properties.

Properties

Name | Description
Collation | The collation of the parameter.
DefaultValue | SQL representing the default value of the parameter.
DefinedSize | The length of the parameter.
FullyQualifiedTypeName | The name of the fully-qualified field type. For SQL Server 2005, this property contains the schema name.
HasDefaultValue | True if there is a default value.
IsOutput | Indicates whether the parameter is an output parameter.
Name | The name of the parameter
Precision | The precision of a decimal or numeric data type.
Scale | The scale of the parameter.
SqlType | The type of the parameter.
TypeName | The name of the type of the parameter.
TypeSchemaName | The name of the schema for the field's data type.
XmlDocument | True if the parameter is an XML document.
XmlSchemaCollection | The XML schema collection for strongly-typed XML parameters.

See Also

Parameter Class
RedGate.SQLCompare.Engine Namespace


Collation Property

[image]

SQL Data Compare API 12.0.40
Parameter..::.Collation Property
Parameter Class See Also

The collation of the parameter.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Collation As String
C#
public string Collation { get; internal set; }
Visual C++
public:
property String^ Collation {
    String^ get ();
    void set (String^ value);
}

See Also

Parameter Class
RedGate.SQLCompare.Engine Namespace


DefaultValue Property

[image]

SQL Data Compare API 12.0.40
Parameter..::.DefaultValue Property
Parameter Class See Also

SQL representing the default value of the parameter.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultValue As String
C#
public string DefaultValue { get; internal set; }
Visual C++
public:
property String^ DefaultValue {
    String^ get ();
    void set (String^ value);
}

See Also

Parameter Class
RedGate.SQLCompare.Engine Namespace


DefinedSize Property

[image]

SQL Data Compare API 12.0.40
Parameter..::.DefinedSize Property
Parameter Class See Also

The length of the parameter.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefinedSize As Integer
C#
public int DefinedSize { get; internal set; }
Visual C++
public:
property int DefinedSize {
    int get ();
    void set (int value);
}

Remarks

Valid only for character and binary data.

See Also

Parameter Class
RedGate.SQLCompare.Engine Namespace


FullyQualifiedTypeName Property

[image]

SQL Data Compare API 12.0.40
Parameter..::.FullyQualifiedTypeName Property
Parameter Class See Also

The name of the fully-qualified field type. For SQL Server 2005, this property contains the schema name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullyQualifiedTypeName As String
C#
public string FullyQualifiedTypeName { get; }
Visual C++
public:
property String^ FullyQualifiedTypeName {
    String^ get ();
}

See Also

Parameter Class
RedGate.SQLCompare.Engine Namespace


HasDefaultValue Property

[image]

SQL Data Compare API 12.0.40
Parameter..::.HasDefaultValue Property
Parameter Class See Also

True if there is a default value.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property HasDefaultValue As Boolean
C#
public bool HasDefaultValue { get; internal set; }
Visual C++
public:
property bool HasDefaultValue {
    bool get ();
    void set (bool value);
}

See Also

Parameter Class
RedGate.SQLCompare.Engine Namespace


IsOutput Property

[image]

SQL Data Compare API 12.0.40
Parameter..::.IsOutput Property
Parameter Class See Also

Indicates whether the parameter is an output parameter.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsOutput As Boolean
C#
public bool IsOutput { get; internal set; }
Visual C++
public:
property bool IsOutput {
    bool get ();
    void set (bool value);
}

See Also

Parameter Class
RedGate.SQLCompare.Engine Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
Parameter..::.Name Property
Parameter Class See Also

The name of the parameter

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; internal set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Parameter Class
RedGate.SQLCompare.Engine Namespace


Precision Property

[image]

SQL Data Compare API 12.0.40
Parameter..::.Precision Property
Parameter Class See Also

The precision of a decimal or numeric data type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Precision As Integer
C#
public int Precision { get; internal set; }
Visual C++
public:
property int Precision {
    int get ();
    void set (int value);
}

See Also

Parameter Class
RedGate.SQLCompare.Engine Namespace


Scale Property

[image]

SQL Data Compare API 12.0.40
Parameter..::.Scale Property
Parameter Class See Also

The scale of the parameter.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Scale As Integer
C#
public int Scale { get; internal set; }
Visual C++
public:
property int Scale {
    int get ();
    void set (int value);
}

Remarks

Valid for numeric and decimal data types.

See Also

Parameter Class
RedGate.SQLCompare.Engine Namespace


SqlType Property

[image]

SQL Data Compare API 12.0.40
Parameter..::.SqlType Property
Parameter Class See Also

The type of the parameter.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SqlType As SqlType
C#
public SqlType SqlType { get; internal set; }
Visual C++
public:
property SqlType SqlType {
    SqlType get ();
    void set (SqlType value);
}

See Also

Parameter Class
RedGate.SQLCompare.Engine Namespace


TypeName Property

[image]

SQL Data Compare API 12.0.40
Parameter..::.TypeName Property
Parameter Class See Also

The name of the type of the parameter.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeName As String
C#
public string TypeName { get; internal set; }
Visual C++
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}

See Also

Parameter Class
RedGate.SQLCompare.Engine Namespace


TypeSchemaName Property

[image]

SQL Data Compare API 12.0.40
Parameter..::.TypeSchemaName Property
Parameter Class See Also

The name of the schema for the field's data type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeSchemaName As String
C#
public string TypeSchemaName { get; internal set; }
Visual C++
public:
property String^ TypeSchemaName {
    String^ get ();
    void set (String^ value);
}

See Also

Parameter Class
RedGate.SQLCompare.Engine Namespace


XmlDocument Property

[image]

SQL Data Compare API 12.0.40
Parameter..::.XmlDocument Property
Parameter Class See Also

True if the parameter is an XML document.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlDocument As Boolean
C#
public bool XmlDocument { get; internal set; }
Visual C++
public:
property bool XmlDocument {
    bool get ();
    void set (bool value);
}

See Also

Parameter Class
RedGate.SQLCompare.Engine Namespace


XmlSchemaCollection Property

[image]

SQL Data Compare API 12.0.40
Parameter..::.XmlSchemaCollection Property
Parameter Class See Also

The XML schema collection for strongly-typed XML parameters.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlSchemaCollection As XmlSchemaCollection
C#
public XmlSchemaCollection XmlSchemaCollection { get; internal set; }
Visual C++
public:
property XmlSchemaCollection^ XmlSchemaCollection {
    XmlSchemaCollection^ get ();
    void set (XmlSchemaCollection^ value);
}

See Also

Parameter Class
RedGate.SQLCompare.Engine Namespace


Parameters Class

[image]

SQL Data Compare API 12.0.40
Parameters Class
Members See Also

A collection of parameters.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Parameters _
    Inherits SerializableCollection(Of Parameter)
C#
public sealed class Parameters : SerializableCollection<Parameter>
Visual C++
public ref class Parameters sealed : public SerializableCollection<Parameter^>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Parameter >)>)
RedGate.SQLCompare.Engine..::.Parameters

See Also

Parameters Members
RedGate.SQLCompare.Engine Namespace


Parameters Members

[image] [image]

SQL Data Compare API 12.0.40
Parameters Members
Parameters Class Methods Fields Properties Explicit Interface Implementations See Also

The Parameters type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
CompareWith | Return a list of differences between this and , modified by
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

Parameters Class
RedGate.SQLCompare.Engine Namespace


Parameters Methods

[image] [image]

SQL Data Compare API 12.0.40
Parameters Methods
Parameters Class See Also

The Parameters type exposes the following methods.

Methods

Name | Description
Add | Overloaded.
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
CompareWith | Return a list of differences between this and , modified by
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

Parameters Class
RedGate.SQLCompare.Engine Namespace


Add Method

[image] [image]

SQL Data Compare API 12.0.40
Parameters..::.Add Method
Parameters Class See Also

Overload List

Name | Description
Add(T) | (Inherited from KeyedCollection<(Of <(T>)>).)
Add(Parameter) |

See Also

Parameters Class
Parameters Members
RedGate.SQLCompare.Engine Namespace


Add Method (Parameter)

[image]

SQL Data Compare API 12.0.40
Parameters..::.Add Method (Parameter)
Parameters Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Add ( _
    value As Parameter _
)
C#
public virtual void Add(
    Parameter value
)
Visual C++
public:
virtual void Add(
    Parameter^ value
)

Parameters

value
Type: RedGate.SQLCompare.Engine..::.Parameter

See Also

Parameters Class
Add Overload
RedGate.SQLCompare.Engine Namespace


CompareWith Method

[image]

SQL Data Compare API 12.0.40
Parameters..::.CompareWith Method
Parameters Class See Also

Return a list of differences between this and , modified by

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareWith ( _
    target As Parameters, _
    options As Options _
) As IEnumerable(Of EqualityDifference)
C#
public IEnumerable<EqualityDifference> CompareWith(
    Parameters target,
    Options options
)
Visual C++
public:
IEnumerable<EqualityDifference^>^ CompareWith(
    Parameters^ target,
    Options options
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.Parameters
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

Parameters Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
Parameters..::.Equals Method
Parameters Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(Parameters, Options) | Compares the parameters collection with a specified parameters collection.

See Also

Parameters Class
Parameters Members
RedGate.SQLCompare.Engine Namespace


Equals Method (Parameters, Options)

[image]

SQL Data Compare API 12.0.40
Parameters..::.Equals Method (Parameters, Options)
Parameters Class See Also

Compares the parameters collection with a specified parameters collection.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    target As Parameters, _
    options As Options _
) As Boolean
C#
public bool Equals(
    Parameters target,
    Options options
)
Visual C++
public:
bool Equals(
    Parameters^ target,
    Options options
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.Parameters
The collection of parameters to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
The comparison options.

Return Value

True if the parameter collections are identical; otherwise, false.

See Also

Parameters Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
Parameters..::.PatchUpAfterDeserialization Method
Parameters Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
void PatchUpAfterDeserialization(
    Database^ database
)

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

See Also

Parameters Class
RedGate.SQLCompare.Engine Namespace


Parameters Properties

[image] [image]

SQL Data Compare API 12.0.40
Parameters Properties
Parameters Class See Also

The Parameters type exposes the following properties.

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

See Also

Parameters Class
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
Parameters..::.Item Property
Parameters Class See Also

Overload List

Name | Description
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(Int32])]) | Returns the parameter at the specified position. (Overrides KeyedCollection <(Of <( T >)>)..::. Item[([(Int32])]).)

See Also

Parameters Class
Parameters Members
RedGate.SQLCompare.Engine Namespace


Item Property ()

[image]

SQL Data Compare API 12.0.40
Parameters..::.Item Property ()
Parameters Class See Also

Returns the parameter at the specified position.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Default Property Item ( _
    index As Integer _
) As Parameter
C#
public override Parameter this[
    int index
] { get; }
Visual C++
public:
virtual property Parameter^ default[int index] {
    Parameter^ get (int index) override;
}

Parameters

index
Type: Int32
The zero-based index of the element to get or set.

Implements

IKeyedCollectionItem(Int32)

See Also

Parameters Class
Item Overload
RedGate.SQLCompare.Engine Namespace


PartitionFunction Class

[image]

SQL Data Compare API 12.0.40
PartitionFunction Class
Members See Also

A partition function.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PartitionFunction _
    Inherits ScriptableDatabaseObject _
    Implements IPatchUpAfterDeserialization, ISqlComparable
C#
public sealed class PartitionFunction : ScriptableDatabaseObject, IPatchUpAfterDeserialization,
    ISqlComparable
Visual C++
public ref class PartitionFunction sealed : public ScriptableDatabaseObject,
    IPatchUpAfterDeserialization, ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.PartitionFunction

See Also

PartitionFunction Members
RedGate.SQLCompare.Engine Namespace


PartitionFunction Members

[image] [image]

SQL Data Compare API 12.0.40
PartitionFunction Members
PartitionFunction Class Methods Fields Properties Explicit Interface Implementations See Also

The PartitionFunction type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties defined for the partition function.
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.PartitionFunction (Overrides ScriptableDatabaseObject ..::. ObjectType.)
OnRight | True if the boundary values belong to the interval on the right.
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Parameters | The parameters of the function.
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)
Values | The boundary values.

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

PartitionFunction Class
RedGate.SQLCompare.Engine Namespace


PartitionFunction Methods

[image] [image]

SQL Data Compare API 12.0.40
PartitionFunction Methods
PartitionFunction Class See Also

The PartitionFunction type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

PartitionFunction Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
PartitionFunction..::.ISqlComparable..::.CompareWith Method
PartitionFunction Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    other As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable other,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ other,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

other
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

PartitionFunction Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
PartitionFunction..::.Equals Method
PartitionFunction Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the partition function with a specified partition function. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

PartitionFunction Class
PartitionFunction Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
PartitionFunction..::.Equals Method (IDatabaseObject, Options)
PartitionFunction Class See Also

Compares the partition function with a specified partition function.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The partition function to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the partition functions are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

PartitionFunction Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
PartitionFunction..::.PatchUpAfterDeserialization Method
PartitionFunction Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

PartitionFunction Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
PartitionFunction..::.ScriptObject Method
PartitionFunction Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

PartitionFunction Class
RedGate.SQLCompare.Engine Namespace


PartitionFunction Properties

[image] [image]

SQL Data Compare API 12.0.40
PartitionFunction Properties
PartitionFunction Class See Also

The PartitionFunction type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties defined for the partition function.
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.PartitionFunction (Overrides ScriptableDatabaseObject ..::. ObjectType.)
OnRight | True if the boundary values belong to the interval on the right.
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Parameters | The parameters of the function.
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)
Values | The boundary values.

See Also

PartitionFunction Class
RedGate.SQLCompare.Engine Namespace


ExtendedProperties Property

[image]

SQL Data Compare API 12.0.40
PartitionFunction..::.ExtendedProperties Property
PartitionFunction Class See Also

The extended properties defined for the partition function.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedProperties
C#
public ExtendedProperties ExtendedProperties { get; }
Visual C++
public:
property ExtendedProperties^ ExtendedProperties {
    ExtendedProperties^ get ();
}

See Also

PartitionFunction Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
PartitionFunction..::.ObjectType Property
PartitionFunction Class See Also

Returns ObjectType.PartitionFunction

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()

See Also

PartitionFunction Class
RedGate.SQLCompare.Engine Namespace


OnRight Property

[image]

SQL Data Compare API 12.0.40
PartitionFunction..::.OnRight Property
PartitionFunction Class See Also

True if the boundary values belong to the interval on the right.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property OnRight As Boolean
C#
public bool OnRight { get; internal set; }
Visual C++
public:
property bool OnRight {
    bool get ();
    void set (bool value);
}

See Also

PartitionFunction Class
RedGate.SQLCompare.Engine Namespace


Parameters Property

[image]

SQL Data Compare API 12.0.40
PartitionFunction..::.Parameters Property
PartitionFunction Class See Also

The parameters of the function.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As Parameters
C#
public Parameters Parameters { get; }
Visual C++
public:
property Parameters^ Parameters {
    Parameters^ get ();
}

See Also

PartitionFunction Class
RedGate.SQLCompare.Engine Namespace


Values Property

[image]

SQL Data Compare API 12.0.40
PartitionFunction..::.Values Property
PartitionFunction Class See Also

The boundary values.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Values As Object()
C#
public Object[] Values { get; internal set; }
Visual C++
public:
property array<Object^>^ Values {
    array<Object^>^ get ();
    void set (array<Object^>^ value);
}

See Also

PartitionFunction Class
RedGate.SQLCompare.Engine Namespace


PartitionFunctions Class

[image]

SQL Data Compare API 12.0.40
PartitionFunctions Class
Members See Also

A collection of partition functions.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PartitionFunctions _
    Inherits SerializableDatabaseObjectCollection(Of PartitionFunction) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class PartitionFunctions : SerializableDatabaseObjectCollection<PartitionFunction>, IPatchUpAfterDeserialization
Visual C++
public ref class PartitionFunctions sealed : public SerializableDatabaseObjectCollection<PartitionFunction^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( PartitionFunction >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( PartitionFunction >)>)
RedGate.SQLCompare.Engine..::.PartitionFunctions

See Also

PartitionFunctions Members
RedGate.SQLCompare.Engine Namespace


PartitionFunctions Members

[image] [image]

SQL Data Compare API 12.0.40
PartitionFunctions Members
PartitionFunctions Class Methods Fields Properties Explicit Interface Implementations See Also

The PartitionFunctions type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

PartitionFunctions Class
RedGate.SQLCompare.Engine Namespace


PartitionFunctions Methods

[image] [image]

SQL Data Compare API 12.0.40
PartitionFunctions Methods
PartitionFunctions Class See Also

The PartitionFunctions type exposes the following methods.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

PartitionFunctions Class
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
PartitionFunctions..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
PartitionFunctions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

PartitionFunctions Class
RedGate.SQLCompare.Engine Namespace


PartitionFunctionsChanges Class

[image]

SQL Data Compare API 12.0.40
PartitionFunctionsChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PartitionFunctionsChanges
C#
public sealed class PartitionFunctionsChanges
Visual C++
public ref class PartitionFunctionsChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.PartitionFunctionsChanges

See Also

PartitionFunctionsChanges Members
RedGate.SQLCompare.Engine Namespace


PartitionFunctionsChanges Members

[image] [image]

SQL Data Compare API 12.0.40
PartitionFunctionsChanges Members
PartitionFunctionsChanges Class Constructors Methods Properties See Also

The PartitionFunctionsChanges type exposes the following members.

Constructors

Name | Description
PartitionFunctionsChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
PartFuncTargets |
PartitionFunctionsToAlter |
PartitionFunctionsToCreate |
PartitionFunctionsToDrop |

See Also

PartitionFunctionsChanges Class
RedGate.SQLCompare.Engine Namespace


PartitionFunctionsChanges Constructor

[image]

SQL Data Compare API 12.0.40
PartitionFunctionsChanges Constructor
PartitionFunctionsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public PartitionFunctionsChanges(
    bool caseSensitive
)
Visual C++
public:
PartitionFunctionsChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

PartitionFunctionsChanges Class
RedGate.SQLCompare.Engine Namespace


PartitionFunctionsChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
PartitionFunctionsChanges Properties
PartitionFunctionsChanges Class See Also

The PartitionFunctionsChanges type exposes the following properties.

Properties

Name | Description
PartFuncTargets |
PartitionFunctionsToAlter |
PartitionFunctionsToCreate |
PartitionFunctionsToDrop |

See Also

PartitionFunctionsChanges Class
RedGate.SQLCompare.Engine Namespace


PartFuncTargets Property

[image]

SQL Data Compare API 12.0.40
PartitionFunctionsChanges..::.PartFuncTargets Property
PartitionFunctionsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PartFuncTargets As Dictionary(Of PartitionFunction, PartitionFunction)
C#
public Dictionary<PartitionFunction, PartitionFunction> PartFuncTargets { get; private set; }
Visual C++
public:
property Dictionary<PartitionFunction^, PartitionFunction^>^ PartFuncTargets {
    Dictionary<PartitionFunction^, PartitionFunction^>^ get ();
    void set (Dictionary<PartitionFunction^, PartitionFunction^>^ value);
}

See Also

PartitionFunctionsChanges Class
RedGate.SQLCompare.Engine Namespace


PartitionFunctionsToAlter Property

[image]

SQL Data Compare API 12.0.40
PartitionFunctionsChanges..::.PartitionFunctionsToAlter Property
PartitionFunctionsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PartitionFunctionsToAlter As PartitionFunctions
C#
public PartitionFunctions PartitionFunctionsToAlter { get; private set; }
Visual C++
public:
property PartitionFunctions^ PartitionFunctionsToAlter {
    PartitionFunctions^ get ();
    void set (PartitionFunctions^ value);
}

See Also

PartitionFunctionsChanges Class
RedGate.SQLCompare.Engine Namespace


PartitionFunctionsToCreate Property

[image]

SQL Data Compare API 12.0.40
PartitionFunctionsChanges..::.PartitionFunctionsToCreate Property
PartitionFunctionsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PartitionFunctionsToCreate As PartitionFunctions
C#
public PartitionFunctions PartitionFunctionsToCreate { get; private set; }
Visual C++
public:
property PartitionFunctions^ PartitionFunctionsToCreate {
    PartitionFunctions^ get ();
    void set (PartitionFunctions^ value);
}

See Also

PartitionFunctionsChanges Class
RedGate.SQLCompare.Engine Namespace


PartitionFunctionsToDrop Property

[image]

SQL Data Compare API 12.0.40
PartitionFunctionsChanges..::.PartitionFunctionsToDrop Property
PartitionFunctionsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PartitionFunctionsToDrop As PartitionFunctions
C#
public PartitionFunctions PartitionFunctionsToDrop { get; private set; }
Visual C++
public:
property PartitionFunctions^ PartitionFunctionsToDrop {
    PartitionFunctions^ get ();
    void set (PartitionFunctions^ value);
}

See Also

PartitionFunctionsChanges Class
RedGate.SQLCompare.Engine Namespace


PartitionScheme Class

[image]

SQL Data Compare API 12.0.40
PartitionScheme Class
Members See Also

A partition scheme.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PartitionScheme _
    Inherits ScriptableDatabaseObject _
    Implements IPatchUpAfterDeserialization, ISqlComparable
C#
public sealed class PartitionScheme : ScriptableDatabaseObject, IPatchUpAfterDeserialization,
    ISqlComparable
Visual C++
public ref class PartitionScheme sealed : public ScriptableDatabaseObject,
    IPatchUpAfterDeserialization, ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.PartitionScheme

See Also

PartitionScheme Members
RedGate.SQLCompare.Engine Namespace


PartitionScheme Members

[image] [image]

SQL Data Compare API 12.0.40
PartitionScheme Members
PartitionScheme Class Methods Fields Properties Explicit Interface Implementations See Also

The PartitionScheme type exposes the following members.

Methods

Name | Description
CompareWith |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties defined for the partition scheme.
FileGroups | The filegroups that are used for partitioning.
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
Function | The partition function for the partition scheme.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Assembly (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

PartitionScheme Class
RedGate.SQLCompare.Engine Namespace


PartitionScheme Methods

[image] [image]

SQL Data Compare API 12.0.40
PartitionScheme Methods
PartitionScheme Class See Also

The PartitionScheme type exposes the following methods.

Methods

Name | Description
CompareWith |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

PartitionScheme Class
RedGate.SQLCompare.Engine Namespace


CompareWith Method

[image]

SQL Data Compare API 12.0.40
PartitionScheme..::.CompareWith Method
PartitionScheme Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareWith ( _
    target As PartitionScheme, _
    options As Options _
) As IEnumerable(Of EqualityDifference)
C#
public IEnumerable<EqualityDifference> CompareWith(
    PartitionScheme target,
    Options options
)
Visual C++
public:
IEnumerable<EqualityDifference^>^ CompareWith(
    PartitionScheme^ target,
    Options options
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.PartitionScheme
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

PartitionScheme Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
PartitionScheme..::.ISqlComparable..::.CompareWith Method
PartitionScheme Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    target As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable target,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ target,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

target
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

PartitionScheme Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
PartitionScheme..::.Equals Method
PartitionScheme Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the partition scheme with a specified partition scheme. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

PartitionScheme Class
PartitionScheme Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
PartitionScheme..::.Equals Method (IDatabaseObject, Options)
PartitionScheme Class See Also

Compares the partition scheme with a specified partition scheme.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The partition scheme to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the partition schemes are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

PartitionScheme Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
PartitionScheme..::.PatchUpAfterDeserialization Method
PartitionScheme Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

PartitionScheme Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
PartitionScheme..::.ScriptObject Method
PartitionScheme Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

PartitionScheme Class
RedGate.SQLCompare.Engine Namespace


PartitionScheme Properties

[image] [image]

SQL Data Compare API 12.0.40
PartitionScheme Properties
PartitionScheme Class See Also

The PartitionScheme type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties defined for the partition scheme.
FileGroups | The filegroups that are used for partitioning.
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
Function | The partition function for the partition scheme.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Assembly (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)

See Also

PartitionScheme Class
RedGate.SQLCompare.Engine Namespace


ExtendedProperties Property

[image]

SQL Data Compare API 12.0.40
PartitionScheme..::.ExtendedProperties Property
PartitionScheme Class See Also

The extended properties defined for the partition scheme.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedProperties
C#
public ExtendedProperties ExtendedProperties { get; }
Visual C++
public:
property ExtendedProperties^ ExtendedProperties {
    ExtendedProperties^ get ();
}

See Also

PartitionScheme Class
RedGate.SQLCompare.Engine Namespace


FileGroups Property

[image]

SQL Data Compare API 12.0.40
PartitionScheme..::.FileGroups Property
PartitionScheme Class See Also

The filegroups that are used for partitioning.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FileGroups As FileGroups
C#
public FileGroups FileGroups { get; }
Visual C++
public:
property FileGroups^ FileGroups {
    FileGroups^ get ();
}

See Also

PartitionScheme Class
RedGate.SQLCompare.Engine Namespace


Function Property

[image]

SQL Data Compare API 12.0.40
PartitionScheme..::.Function Property
PartitionScheme Class See Also

The partition function for the partition scheme.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Function As PartitionFunction
C#
public PartitionFunction Function { get; internal set; }
Visual C++
public:
property PartitionFunction^ Function {
    PartitionFunction^ get ();
    void set (PartitionFunction^ value);
}

See Also

PartitionScheme Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
PartitionScheme..::.ObjectType Property
PartitionScheme Class See Also

Returns ObjectType.Assembly

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()

See Also

PartitionScheme Class
RedGate.SQLCompare.Engine Namespace


PartitionSchemes Class

[image]

SQL Data Compare API 12.0.40
PartitionSchemes Class
Members See Also

A collection of partition schemes.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PartitionSchemes _
    Inherits SerializableDatabaseObjectCollection(Of PartitionScheme) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class PartitionSchemes : SerializableDatabaseObjectCollection<PartitionScheme>, IPatchUpAfterDeserialization
Visual C++
public ref class PartitionSchemes sealed : public SerializableDatabaseObjectCollection<PartitionScheme^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( PartitionScheme >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( PartitionScheme >)>)
RedGate.SQLCompare.Engine..::.PartitionSchemes

See Also

PartitionSchemes Members
RedGate.SQLCompare.Engine Namespace


PartitionSchemes Members

[image] [image]

SQL Data Compare API 12.0.40
PartitionSchemes Members
PartitionSchemes Class Methods Fields Properties Explicit Interface Implementations See Also

The PartitionSchemes type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

PartitionSchemes Class
RedGate.SQLCompare.Engine Namespace


PartitionSchemes Methods

[image] [image]

SQL Data Compare API 12.0.40
PartitionSchemes Methods
PartitionSchemes Class See Also

The PartitionSchemes type exposes the following methods.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

PartitionSchemes Class
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
PartitionSchemes..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
PartitionSchemes Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

PartitionSchemes Class
RedGate.SQLCompare.Engine Namespace


PartitionSchemesChanges Class

[image]

SQL Data Compare API 12.0.40
PartitionSchemesChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PartitionSchemesChanges
C#
public sealed class PartitionSchemesChanges
Visual C++
public ref class PartitionSchemesChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.PartitionSchemesChanges

See Also

PartitionSchemesChanges Members
RedGate.SQLCompare.Engine Namespace


PartitionSchemesChanges Members

[image] [image]

SQL Data Compare API 12.0.40
PartitionSchemesChanges Members
PartitionSchemesChanges Class Constructors Methods Properties See Also

The PartitionSchemesChanges type exposes the following members.

Constructors

Name | Description
PartitionSchemesChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
PartitionSchemesToAlter |
PartitionSchemesToCreate |
PartitionSchemesToDrop |
PartitionSchemesToRebuild |
PartSchemeTargets |

See Also

PartitionSchemesChanges Class
RedGate.SQLCompare.Engine Namespace


PartitionSchemesChanges Constructor

[image]

SQL Data Compare API 12.0.40
PartitionSchemesChanges Constructor
PartitionSchemesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public PartitionSchemesChanges(
    bool caseSensitive
)
Visual C++
public:
PartitionSchemesChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

PartitionSchemesChanges Class
RedGate.SQLCompare.Engine Namespace


PartitionSchemesChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
PartitionSchemesChanges Properties
PartitionSchemesChanges Class See Also

The PartitionSchemesChanges type exposes the following properties.

Properties

Name | Description
PartitionSchemesToAlter |
PartitionSchemesToCreate |
PartitionSchemesToDrop |
PartitionSchemesToRebuild |
PartSchemeTargets |

See Also

PartitionSchemesChanges Class
RedGate.SQLCompare.Engine Namespace


PartitionSchemesToAlter Property

[image]

SQL Data Compare API 12.0.40
PartitionSchemesChanges..::.PartitionSchemesToAlter Property
PartitionSchemesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PartitionSchemesToAlter As PartitionSchemes
C#
public PartitionSchemes PartitionSchemesToAlter { get; private set; }
Visual C++
public:
property PartitionSchemes^ PartitionSchemesToAlter {
    PartitionSchemes^ get ();
    void set (PartitionSchemes^ value);
}

See Also

PartitionSchemesChanges Class
RedGate.SQLCompare.Engine Namespace


PartitionSchemesToCreate Property

[image]

SQL Data Compare API 12.0.40
PartitionSchemesChanges..::.PartitionSchemesToCreate Property
PartitionSchemesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PartitionSchemesToCreate As PartitionSchemes
C#
public PartitionSchemes PartitionSchemesToCreate { get; private set; }
Visual C++
public:
property PartitionSchemes^ PartitionSchemesToCreate {
    PartitionSchemes^ get ();
    void set (PartitionSchemes^ value);
}

See Also

PartitionSchemesChanges Class
RedGate.SQLCompare.Engine Namespace


PartitionSchemesToDrop Property

[image]

SQL Data Compare API 12.0.40
PartitionSchemesChanges..::.PartitionSchemesToDrop Property
PartitionSchemesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PartitionSchemesToDrop As PartitionSchemes
C#
public PartitionSchemes PartitionSchemesToDrop { get; private set; }
Visual C++
public:
property PartitionSchemes^ PartitionSchemesToDrop {
    PartitionSchemes^ get ();
    void set (PartitionSchemes^ value);
}

See Also

PartitionSchemesChanges Class
RedGate.SQLCompare.Engine Namespace


PartitionSchemesToRebuild Property

[image]

SQL Data Compare API 12.0.40
PartitionSchemesChanges..::.PartitionSchemesToRebuild Property
PartitionSchemesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PartitionSchemesToRebuild As PartitionSchemes
C#
public PartitionSchemes PartitionSchemesToRebuild { get; private set; }
Visual C++
public:
property PartitionSchemes^ PartitionSchemesToRebuild {
    PartitionSchemes^ get ();
    void set (PartitionSchemes^ value);
}

See Also

PartitionSchemesChanges Class
RedGate.SQLCompare.Engine Namespace


PartSchemeTargets Property

[image]

SQL Data Compare API 12.0.40
PartitionSchemesChanges..::.PartSchemeTargets Property
PartitionSchemesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PartSchemeTargets As Dictionary(Of PartitionScheme, PartitionScheme)
C#
public Dictionary<PartitionScheme, PartitionScheme> PartSchemeTargets { get; private set; }
Visual C++
public:
property Dictionary<PartitionScheme^, PartitionScheme^>^ PartSchemeTargets {
    Dictionary<PartitionScheme^, PartitionScheme^>^ get ();
    void set (Dictionary<PartitionScheme^, PartitionScheme^>^ value);
}

See Also

PartitionSchemesChanges Class
RedGate.SQLCompare.Engine Namespace


Permission Class

[image]

SQL Data Compare API 12.0.40
Permission Class
Members See Also

A permission.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Permission
C#
public sealed class Permission
Visual C++
public ref class Permission sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.Permission

See Also

Permission Members
RedGate.SQLCompare.Engine Namespace


Permission Members

[image] [image]

SQL Data Compare API 12.0.40
Permission Members
Permission Class Methods Properties See Also

The Permission type exposes the following members.

Methods

Name | Description
Equals | Test equality on permission Currently it only tests for principal property without testing securable property, this might be improved in the future (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Hash code for overriding equality (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Fields | The fields to which the permission applies.
PermissionLevel | The permission level to which the permission applies (e.g. Select, Alter, etc)
Principal | The user or role to which the permission applies.
SecurableType | The class of permission (for example, object, XML schema collection).
StatementType | The type of permission statement (e.g Grant, Deny, etc)

See Also

Permission Class
RedGate.SQLCompare.Engine Namespace


Permission Methods

[image] [image]

SQL Data Compare API 12.0.40
Permission Methods
Permission Class See Also

The Permission type exposes the following methods.

Methods

Name | Description
Equals | Test equality on permission Currently it only tests for principal property without testing securable property, this might be improved in the future (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Hash code for overriding equality (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Permission Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image]

SQL Data Compare API 12.0.40
Permission..::.Equals Method
Permission Class See Also

Test equality on permission Currently it only tests for principal property without testing securable property, this might be improved in the future

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object

See Also

Permission Class
RedGate.SQLCompare.Engine Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
Permission..::.GetHashCode Method
Permission Class See Also

Hash code for overriding equality

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

See Also

Permission Class
RedGate.SQLCompare.Engine Namespace


Permission Properties

[image] [image]

SQL Data Compare API 12.0.40
Permission Properties
Permission Class See Also

The Permission type exposes the following properties.

Properties

Name | Description
Fields | The fields to which the permission applies.
PermissionLevel | The permission level to which the permission applies (e.g. Select, Alter, etc)
Principal | The user or role to which the permission applies.
SecurableType | The class of permission (for example, object, XML schema collection).
StatementType | The type of permission statement (e.g Grant, Deny, etc)

See Also

Permission Class
RedGate.SQLCompare.Engine Namespace


Fields Property

[image]

SQL Data Compare API 12.0.40
Permission..::.Fields Property
Permission Class See Also

The fields to which the permission applies.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Fields As Fields
C#
public Fields Fields { get; internal set; }
Visual C++
public:
property Fields^ Fields {
    Fields^ get ();
    void set (Fields^ value);
}

See Also

Permission Class
RedGate.SQLCompare.Engine Namespace


PermissionLevel Property

[image]

SQL Data Compare API 12.0.40
Permission..::.PermissionLevel Property
Permission Class See Also

The permission level to which the permission applies (e.g. Select, Alter, etc)

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PermissionLevel As PermissionLevel
C#
public PermissionLevel PermissionLevel { get; internal set; }
Visual C++
public:
property PermissionLevel PermissionLevel {
    PermissionLevel get ();
    void set (PermissionLevel value);
}

See Also

Permission Class
RedGate.SQLCompare.Engine Namespace


Principal Property

[image]

SQL Data Compare API 12.0.40
Permission..::.Principal Property
Permission Class See Also

The user or role to which the permission applies.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Principal As String
C#
public string Principal { get; internal set; }
Visual C++
public:
property String^ Principal {
    String^ get ();
    void set (String^ value);
}

See Also

Permission Class
RedGate.SQLCompare.Engine Namespace


SecurableType Property

[image]

SQL Data Compare API 12.0.40
Permission..::.SecurableType Property
Permission Class See Also

The class of permission (for example, object, XML schema collection).

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SecurableType As SecurableType
C#
public SecurableType SecurableType { get; internal set; }
Visual C++
public:
property SecurableType SecurableType {
    SecurableType get ();
    void set (SecurableType value);
}

See Also

Permission Class
RedGate.SQLCompare.Engine Namespace


StatementType Property

[image]

SQL Data Compare API 12.0.40
Permission..::.StatementType Property
Permission Class See Also

The type of permission statement (e.g Grant, Deny, etc)

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property StatementType As PermissionStatementType
C#
public PermissionStatementType StatementType { get; internal set; }
Visual C++
public:
property PermissionStatementType StatementType {
    PermissionStatementType get ();
    void set (PermissionStatementType value);
}

See Also

Permission Class
RedGate.SQLCompare.Engine Namespace


PermissionLevel Enumeration

[image]

SQL Data Compare API 12.0.40
PermissionLevel Enumeration
See Also

The action that a permission allows.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration PermissionLevel
C#
public enum PermissionLevel
Visual C++
public enum class PermissionLevel

Members

Member name | Description
None | Used for error handling.
Alter | Alter.
Control | Control.
ReceiveOrImpersonate | Receive in the case of objects; Impersonate in the case of users.
Send | Send.
TakeOwnership | Take ownership.
ViewDefinition | View definition.
References | References.
Select | Select.
Insert | Insert .
Delete | Delete.
Update | Update.
Execute | Execute.
ViewChangeTracking | View change tracking.
CreateSequenceObject | Create Sequence Object

See Also

RedGate.SQLCompare.Engine Namespace


Permissions Class

[image]

SQL Data Compare API 12.0.40
Permissions Class
Members See Also

A collection of permissions.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class Permissions _
    Inherits InnerList(Of Permission)
C#
public class Permissions : InnerList<Permission>
Visual C++
public ref class Permissions : public InnerList<Permission^>

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( T >)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( Permission >)>)
RedGate.SQLCompare.Engine..::.Permissions

See Also

Permissions Members
RedGate.SQLCompare.Engine Namespace


Permissions Members

[image] [image]

SQL Data Compare API 12.0.40
Permissions Members
Permissions Class Methods Properties Explicit Interface Implementations See Also

The Permissions type exposes the following members.

Methods

Name | Description
Contains | (Inherited from InnerList<(Of <(T>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
IsRole |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | (Inherited from InnerList<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Permissions Class
RedGate.SQLCompare.Engine Namespace


Permissions Methods

[image] [image]

SQL Data Compare API 12.0.40
Permissions Methods
Permissions Class See Also

The Permissions type exposes the following methods.

Methods

Name | Description
Contains | (Inherited from InnerList<(Of <(T>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
IsRole |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Permissions Class
RedGate.SQLCompare.Engine Namespace


IsRole Method

[image]

SQL Data Compare API 12.0.40
Permissions..::.IsRole Method
Permissions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsRole ( _
    database As Database, _
    userOrRoleName As String _
) As Boolean
C#
public static bool IsRole(
    Database database,
    string userOrRoleName
)
Visual C++
public:
static bool IsRole(
    Database^ database,
    String^ userOrRoleName
)

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database
userOrRoleName
Type: String

See Also

Permissions Class
RedGate.SQLCompare.Engine Namespace


PermissionsChanges Class

[image]

SQL Data Compare API 12.0.40
PermissionsChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PermissionsChanges
C#
public sealed class PermissionsChanges
Visual C++
public ref class PermissionsChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.PermissionsChanges

See Also

PermissionsChanges Members
RedGate.SQLCompare.Engine Namespace


PermissionsChanges Members

[image] [image]

SQL Data Compare API 12.0.40
PermissionsChanges Members
PermissionsChanges Class Constructors Methods Properties See Also

The PermissionsChanges type exposes the following members.

Constructors

Name | Description
PermissionsChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
PermissionsTargets |
PermissionsToAlter |
PermissionsToRestore |

See Also

PermissionsChanges Class
RedGate.SQLCompare.Engine Namespace


PermissionsChanges Constructor

[image]

SQL Data Compare API 12.0.40
PermissionsChanges Constructor
PermissionsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PermissionsChanges()
Visual C++
public:
PermissionsChanges()

See Also

PermissionsChanges Class
RedGate.SQLCompare.Engine Namespace


PermissionsChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
PermissionsChanges Properties
PermissionsChanges Class See Also

The PermissionsChanges type exposes the following properties.

Properties

Name | Description
PermissionsTargets |
PermissionsToAlter |
PermissionsToRestore |

See Also

PermissionsChanges Class
RedGate.SQLCompare.Engine Namespace


PermissionsTargets Property

[image]

SQL Data Compare API 12.0.40
PermissionsChanges..::.PermissionsTargets Property
PermissionsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PermissionsTargets As Dictionary(Of Permissions, Permissions)
C#
public Dictionary<Permissions, Permissions> PermissionsTargets { get; private set; }
Visual C++
public:
property Dictionary<Permissions^, Permissions^>^ PermissionsTargets {
    Dictionary<Permissions^, Permissions^>^ get ();
    void set (Dictionary<Permissions^, Permissions^>^ value);
}

See Also

PermissionsChanges Class
RedGate.SQLCompare.Engine Namespace


PermissionsToAlter Property

[image]

SQL Data Compare API 12.0.40
PermissionsChanges..::.PermissionsToAlter Property
PermissionsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PermissionsToAlter As PermissionsCollection
C#
public PermissionsCollection PermissionsToAlter { get; private set; }
Visual C++
public:
property PermissionsCollection^ PermissionsToAlter {
    PermissionsCollection^ get ();
    void set (PermissionsCollection^ value);
}

See Also

PermissionsChanges Class
RedGate.SQLCompare.Engine Namespace


PermissionsToRestore Property

[image]

SQL Data Compare API 12.0.40
PermissionsChanges..::.PermissionsToRestore Property
PermissionsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PermissionsToRestore As PermissionsCollection
C#
public PermissionsCollection PermissionsToRestore { get; private set; }
Visual C++
public:
property PermissionsCollection^ PermissionsToRestore {
    PermissionsCollection^ get ();
    void set (PermissionsCollection^ value);
}

See Also

PermissionsChanges Class
RedGate.SQLCompare.Engine Namespace


PermissionsCollection Class

[image]

SQL Data Compare API 12.0.40
PermissionsCollection Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PermissionsCollection _
    Inherits InnerList(Of Permissions)
C#
public sealed class PermissionsCollection : InnerList<Permissions>
Visual C++
public ref class PermissionsCollection sealed : public InnerList<Permissions^>

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( T >)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( Permissions >)>)
RedGate.SQLCompare.Engine..::.PermissionsCollection

See Also

PermissionsCollection Members
RedGate.SQLCompare.Engine Namespace


PermissionsCollection Members

[image] [image]

SQL Data Compare API 12.0.40
PermissionsCollection Members
PermissionsCollection Class Methods Properties Explicit Interface Implementations See Also

The PermissionsCollection type exposes the following members.

Methods

Name | Description
Add | (Overrides InnerList <(Of <( Permissions >)>)..::.Add(UTP).)
Contains | (Inherited from InnerList<(Of <(T>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | (Overrides InnerList <(Of <( Permissions >)>)..::.Remove(UTP).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | (Inherited from InnerList<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

PermissionsCollection Class
RedGate.SQLCompare.Engine Namespace


PermissionsCollection Methods

[image] [image]

SQL Data Compare API 12.0.40
PermissionsCollection Methods
PermissionsCollection Class See Also

The PermissionsCollection type exposes the following methods.

Methods

Name | Description
Add | (Overrides InnerList <(Of <( Permissions >)>)..::.Add(UTP).)
Contains | (Inherited from InnerList<(Of <(T>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | (Overrides InnerList <(Of <( Permissions >)>)..::.Remove(UTP).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

PermissionsCollection Class
RedGate.SQLCompare.Engine Namespace


Add Method

[image]

SQL Data Compare API 12.0.40
PermissionsCollection..::.Add Method
PermissionsCollection Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Add ( _
    value As Permissions _
)
C#
public override void Add(
    Permissions value
)
Visual C++
public:
virtual void Add(
    Permissions^ value
) override

Parameters

value
Type: RedGate.SQLCompare.Engine..::.Permissions

See Also

PermissionsCollection Class
RedGate.SQLCompare.Engine Namespace


Remove Method

[image]

SQL Data Compare API 12.0.40
PermissionsCollection..::.Remove Method
PermissionsCollection Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Remove ( _
    value As Permissions _
) As Boolean
C#
public override bool Remove(
    Permissions value
)
Visual C++
public:
virtual bool Remove(
    Permissions^ value
) override

Parameters

value
Type: RedGate.SQLCompare.Engine..::.Permissions

See Also

PermissionsCollection Class
RedGate.SQLCompare.Engine Namespace


PermissionSet Enumeration

[image]

SQL Data Compare API 12.0.40
PermissionSet Enumeration
See Also

The code access permissions for CLR assemblies.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration PermissionSet
C#
public enum PermissionSet
Visual C++
public enum class PermissionSet

Members

Member name | Description
SAFE | Safe.
EXTERNAL_ACCESS | External access.
UNSAFE | Unsafe.

See Also

RedGate.SQLCompare.Engine Namespace


PermissionStatementType Enumeration

[image]

SQL Data Compare API 12.0.40
PermissionStatementType Enumeration
See Also

The type of permission.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration PermissionStatementType
C#
public enum PermissionStatementType
Visual C++
public enum class PermissionStatementType

Members

Member name | Description
None | None.
GrantWithGrant | Grant with grant option.
Grant | Grant.
Deny | Deny.
Revoke | Revoke.
RevokeGrantOption | Revoke grant option

See Also

RedGate.SQLCompare.Engine Namespace


PlannedChangesExtensions Class

[image]

SQL Data Compare API 12.0.40
PlannedChangesExtensions Class
See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PlannedChangesExtensions
C#
public static class PlannedChangesExtensions
Visual C++
public ref class PlannedChangesExtensions abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.PlannedChangesExtensions

See Also

RedGate.SQLCompare.Engine Namespace


PrepareStringDelegate(TMap, TContext) Generic Delegate

[image]

SQL Data Compare API 12.0.40
PrepareStringDelegate<(Of <(TMap, TContext>)>) Generic Delegate
See Also

Creates the name used for comparing two objects when creating mappings.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Function PrepareStringDelegate(Of TMap As {Class, IDatabaseObject}, TContext) ( _
    obj As TMap, _
    useFullName As Boolean, _
    context As TContext _
) As String
C#
public delegate string PrepareStringDelegate<TMap, TContext>(
    TMap obj,
    bool useFullName,
    TContext context
) where TMap : class, IDatabaseObject
Visual C++
generic<typename TMap, typename TContext>
where TMap : ref class, IDatabaseObject
public delegate String^ PrepareStringDelegate(
    TMap obj,
    bool useFullName,
    TContext context
)

Parameters

obj
Type: TMap
The object for which the name is to be generated.
useFullName
Type: Boolean
If true, uses the fully-qualified name. If false, uses the name.
context
Type: TContext
The context object passed back from the Mappings class.

Type Parameters

TMap
The type stored in the mapping.
TContext
The type of the context object.

See Also

RedGate.SQLCompare.Engine Namespace


ProgressTracker Class

[image]

SQL Data Compare API 12.0.40
ProgressTracker Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ProgressTracker
C#
public sealed class ProgressTracker
Visual C++
public ref class ProgressTracker sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ProgressTracker

See Also

ProgressTracker Members
RedGate.SQLCompare.Engine Namespace


ProgressTracker Members

[image] [image]

SQL Data Compare API 12.0.40
ProgressTracker Members
ProgressTracker Class Constructors Methods Properties See Also

The ProgressTracker type exposes the following members.

Constructors

Name | Description
ProgressTracker | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Increment | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CurrentPercentage | Gets the current percentage of the CurrentValue over the specified range
CurrentValue | Gets and sets the current value within the specified range
HasPercentageChanged | Returns back if the percentage has changed since the last time HasPercentageChanged been called.
LowerLimit | Sets and gets the lower limit of the range. (The default value is 0)
Message | Access to the status message.
UpperLimit | Sets and gets the upper limit of the range. (The default value is 100)

See Also

ProgressTracker Class
RedGate.SQLCompare.Engine Namespace


ProgressTracker Constructor

[image] [image]

SQL Data Compare API 12.0.40
ProgressTracker Constructor
ProgressTracker Class See Also

Overload List

Name | Description
ProgressTracker()()() |
ProgressTracker(ICancellable, Int64) |

See Also

ProgressTracker Class
ProgressTracker Members
RedGate.SQLCompare.Engine Namespace


ProgressTracker Constructor

[image]

SQL Data Compare API 12.0.40
ProgressTracker Constructor
ProgressTracker Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ProgressTracker()
Visual C++
public:
ProgressTracker()

See Also

ProgressTracker Class
ProgressTracker Overload
RedGate.SQLCompare.Engine Namespace


ProgressTracker Constructor (ICancellable, )

[image]

SQL Data Compare API 12.0.40
ProgressTracker Constructor (ICancellable, )
ProgressTracker Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    subscriber As ICancellable, _
    upperLimit As Long _
)
C#
public ProgressTracker(
    ICancellable subscriber,
    long upperLimit
)
Visual C++
public:
ProgressTracker(
    ICancellable^ subscriber,
    long long upperLimit
)

Parameters

subscriber
Type: RedGate.Shared.Utils..::.ICancellable
upperLimit
Type: Int64

See Also

ProgressTracker Class
ProgressTracker Overload
RedGate.SQLCompare.Engine Namespace


ProgressTracker Methods

[image] [image]

SQL Data Compare API 12.0.40
ProgressTracker Methods
ProgressTracker Class See Also

The ProgressTracker type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Increment | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProgressTracker Class
RedGate.SQLCompare.Engine Namespace


Increment Method

[image] [image]

SQL Data Compare API 12.0.40
ProgressTracker..::.Increment Method
ProgressTracker Class See Also

Overload List

Name | Description
Increment()()() | Increments the CurrentValue by one
Increment(Int32) | Increments the CurrentValue by the value specified

See Also

ProgressTracker Class
ProgressTracker Members
RedGate.SQLCompare.Engine Namespace


Increment Method

[image]

SQL Data Compare API 12.0.40
ProgressTracker..::.Increment Method
ProgressTracker Class See Also

Increments the CurrentValue by one

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Increment As Boolean
C#
public bool Increment()
Visual C++
public:
bool Increment()

Return Value

If the CurrentPercentage has changed

See Also

ProgressTracker Class
Increment Overload
RedGate.SQLCompare.Engine Namespace


Increment Method ()

[image]

SQL Data Compare API 12.0.40
ProgressTracker..::.Increment Method ()
ProgressTracker Class See Also

Increments the CurrentValue by the value specified

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Increment ( _
    value As Integer _
) As Boolean
C#
public bool Increment(
    int value
)
Visual C++
public:
bool Increment(
    int value
)

Parameters

value
Type: Int32
The ammount to increment CurrentValue by.

Return Value

If the CurrentPercentage has changed

See Also

ProgressTracker Class
Increment Overload
RedGate.SQLCompare.Engine Namespace


ProgressTracker Properties

[image] [image]

SQL Data Compare API 12.0.40
ProgressTracker Properties
ProgressTracker Class See Also

The ProgressTracker type exposes the following properties.

Properties

Name | Description
CurrentPercentage | Gets the current percentage of the CurrentValue over the specified range
CurrentValue | Gets and sets the current value within the specified range
HasPercentageChanged | Returns back if the percentage has changed since the last time HasPercentageChanged been called.
LowerLimit | Sets and gets the lower limit of the range. (The default value is 0)
Message | Access to the status message.
UpperLimit | Sets and gets the upper limit of the range. (The default value is 100)

See Also

ProgressTracker Class
RedGate.SQLCompare.Engine Namespace


CurrentPercentage Property

[image]

SQL Data Compare API 12.0.40
ProgressTracker..::.CurrentPercentage Property
ProgressTracker Class See Also

Gets the current percentage of the CurrentValue over the specified range

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentPercentage As Integer
C#
public int CurrentPercentage { get; }
Visual C++
public:
property int CurrentPercentage {
    int get ();
}

See Also

ProgressTracker Class
RedGate.SQLCompare.Engine Namespace


CurrentValue Property

[image]

SQL Data Compare API 12.0.40
ProgressTracker..::.CurrentValue Property
ProgressTracker Class See Also

Gets and sets the current value within the specified range

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CurrentValue As Long
C#
public long CurrentValue { get; set; }
Visual C++
public:
property long long CurrentValue {
    long long get ();
    void set (long long value);
}

See Also

ProgressTracker Class
RedGate.SQLCompare.Engine Namespace


HasPercentageChanged Property

[image]

SQL Data Compare API 12.0.40
ProgressTracker..::.HasPercentageChanged Property
ProgressTracker Class See Also

Returns back if the percentage has changed since the last time HasPercentageChanged been called.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasPercentageChanged As Boolean
C#
public bool HasPercentageChanged { get; }
Visual C++
public:
property bool HasPercentageChanged {
    bool get ();
}

See Also

ProgressTracker Class
RedGate.SQLCompare.Engine Namespace


LowerLimit Property

[image]

SQL Data Compare API 12.0.40
ProgressTracker..::.LowerLimit Property
ProgressTracker Class See Also

Sets and gets the lower limit of the range. (The default value is 0)

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LowerLimit As Long
C#
public long LowerLimit { get; set; }
Visual C++
public:
property long long LowerLimit {
    long long get ();
    void set (long long value);
}

Exceptions

Exception | Condition
ArgumentException | If the upper and lower limits are set to the same value

See Also

ProgressTracker Class
RedGate.SQLCompare.Engine Namespace


Message Property

[image]

SQL Data Compare API 12.0.40
ProgressTracker..::.Message Property
ProgressTracker Class See Also

Access to the status message.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Message As String
C#
public string Message { get; set; }
Visual C++
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}

See Also

ProgressTracker Class
RedGate.SQLCompare.Engine Namespace


UpperLimit Property

[image]

SQL Data Compare API 12.0.40
ProgressTracker..::.UpperLimit Property
ProgressTracker Class See Also

Sets and gets the upper limit of the range. (The default value is 100)

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UpperLimit As Long
C#
public long UpperLimit { get; set; }
Visual C++
public:
property long long UpperLimit {
    long long get ();
    void set (long long value);
}

Exceptions

Exception | Condition
ArgumentException | If the upper and lower limits are set to the same value

See Also

ProgressTracker Class
RedGate.SQLCompare.Engine Namespace


Project Class

[image]

SQL Data Compare API 12.0.40
Project Class
Members Example See Also

A SQL Compare project.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Class Project
C#
public class Project
Visual C++
public ref class Project

Remarks

Use this class to load projects generated by SQL Compare, or to save projects for SQL Compare. Note that a project contains only connection information. It does not contain information about database schemas.

Examples

This example shows how to save and load a project.
C# Copy Code
            Project project1=new Project();

            //by default DataSource1/DataSource2 are created as a LiveDatabaseSources with
            //the server name set to "(local)".
            project1.DataSource1.DatabaseName = "WidgetProduction";
            project1.DataSource2.DatabaseName = "WidgetStaging";

            //this project can now be opened up in SQL Compare
            project1.SaveToDisk(@"c:\A sample project.scp");

            //load the project from disk
            Project project2=Project.LoadFromDisk(@"c:\A sample project.scp");

            Console.WriteLine(project2.FileName);
Visual Basic Copy Code
            Dim project1 As New Project()

            'by default DataSource1/DataSource2 are created as a LiveDatabaseSources with
            'the server name set to "(local)".
            project1.DataSource1.DatabaseName = "WidgetProduction"
            project1.DataSource2.DatabaseName = "WidgetStaging"

            'this project can now be opened up in SQL Compare
            project1.SaveToDisk("c:\A sample project.scp")

            'load the project from disk
            Dim project2 As Project = Project.LoadFromDisk("c:\A sample project.scp")

            Console.WriteLine(project2.FileName)

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.Project

See Also

Project Members
RedGate.SQLCompare.Engine Namespace


Project Members

[image] [image]

SQL Data Compare API 12.0.40
Project Members
Project Class Constructors Methods Fields Properties Events See Also

The Project type exposes the following members.

Constructors

Name | Description
Project | Overloaded.

Methods

Name | Description
AddAction |
ChangeSynchronizationDirection | Changes the direction in which changes are to be migrated.
ClearActions |
CreateCopyOfSelectTableActions |
CreateNew | Creates a new blank project.
Deserialize |
Equals | (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LoadFromDisk | Loads a project from disk.
MappingEquals |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SaveToDisk | Save the project to disk
Serialize | Support for serialization.
SetClean |
SetDirty |
SetProjectAsOld |
ToString | Converts an instance of Project to a string. (Overrides Object..::.ToString()()().)

Fields

Name | Description
m_DeserializationMode |

Properties

Name | Description
ChangesEffect |
ComparisonOptions | Options used when running a comparison or synchronization on the project.
DataSource1 | The connection properties for the first data source.
DataSource2 | The connection properties for the second data source.
DCGroupingStyle |
DCOptions | Options used when running a comparison or synchronization on the project.
Direction | The direction in which changes are migrated when a synchronization is run on the project.
Dirty | True if the project has been modified.
FileName | The file name of the project.
IsNewProject | Determines whether the project is a new project.
IsSsmsIntegrationPackGeneratedProject |
LastCompared | The time at which the project was last compared.
LastModified | The time at which the project was last compared.
Name | The file name of a project, or "New Project".
OriginalProject |
ProblemsLoadingProject | If part of a project can't be read, LoadFromDisk(String) will warn about the missing values here.
SCDeploymentOptions |
SCGroupingStyle |
SelectTableActions | Gets or sets the OwnerMappingUserActions.
ServerFactory |
SessionSettings | The session settings used in the project comparison.
Source1AsLiveDB | A convenience method for accessing the first data source as a live database, rather than casting explicitly in code.
Source2AsLiveDB | A convenience method for accessing the second data source as a live database, rather than casting explicitly in code.
UseMigrations |
UserNote | Gets or sets the user notes.
Version | The current project version. Used for serialization.

Events

Name | Description
ProjectDirtyStateChanged |

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


Project Constructor

[image] [image]

SQL Data Compare API 12.0.40
Project Constructor
Project Class See Also

Overload List

Name | Description
Project()()() | Constructor.
Project(Boolean) |

See Also

Project Class
Project Members
RedGate.SQLCompare.Engine Namespace


Project Constructor

[image]

SQL Data Compare API 12.0.40
Project Constructor
Project Class See Also

Constructor.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Project()
Visual C++
public:
Project()

See Also

Project Class
Project Overload
RedGate.SQLCompare.Engine Namespace


Project Constructor ()

[image]

SQL Data Compare API 12.0.40
Project Constructor ()
Project Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    createClone As Boolean _
)
C#
protected Project(
    bool createClone
)
Visual C++
protected:
Project(
    bool createClone
)

Parameters

createClone
Type: Boolean

See Also

Project Class
Project Overload
RedGate.SQLCompare.Engine Namespace


Project Fields

[image] [image]

SQL Data Compare API 12.0.40
Project Fields
Project Class See Also

The Project type exposes the following fields.

Fields

Name | Description
m_DeserializationMode |

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


m_DeserializationMode Field

[image]

SQL Data Compare API 12.0.40
Project..::.m_DeserializationMode Field
Project Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Protected m_DeserializationMode As Project..::.UberProjectDeserializationMode
C#
protected Project..::.UberProjectDeserializationMode m_DeserializationMode
Visual C++
protected:
Project..::.UberProjectDeserializationMode m_DeserializationMode

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


Project Methods

[image] [image]

SQL Data Compare API 12.0.40
Project Methods
Project Class See Also

The Project type exposes the following methods.

Methods

Name | Description
AddAction |
ChangeSynchronizationDirection | Changes the direction in which changes are to be migrated.
ClearActions |
CreateCopyOfSelectTableActions |
CreateNew | Creates a new blank project.
Deserialize |
Equals | (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LoadFromDisk | Loads a project from disk.
MappingEquals |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SaveToDisk | Save the project to disk
Serialize | Support for serialization.
SetClean |
SetDirty |
SetProjectAsOld |
ToString | Converts an instance of Project to a string. (Overrides Object..::.ToString()()().)

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


AddAction Method

[image]

SQL Data Compare API 12.0.40
Project..::.AddAction Method
Project Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddAction ( _
    e As SelectTableEvent _
)
C#
public void AddAction(
    SelectTableEvent e
)
Visual C++
public:
void AddAction(
    SelectTableEvent e
)

Parameters

e
Type: RedGate.SQLCompare.Engine..::.SelectTableEvent

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


ChangeSynchronizationDirection Method

[image]

SQL Data Compare API 12.0.40
Project..::.ChangeSynchronizationDirection Method
Project Class See Also

Changes the direction in which changes are to be migrated.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub ChangeSynchronizationDirection
C#
public void ChangeSynchronizationDirection()
Visual C++
public:
void ChangeSynchronizationDirection()

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


ClearActions Method

[image]

SQL Data Compare API 12.0.40
Project..::.ClearActions Method
Project Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub ClearActions
C#
public void ClearActions()
Visual C++
public:
void ClearActions()

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


CreateCopyOfSelectTableActions Method

[image]

SQL Data Compare API 12.0.40
Project..::.CreateCopyOfSelectTableActions Method
Project Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateCopyOfSelectTableActions ( _
    list As List(Of SelectTableEvent) _
) As List(Of SelectTableEvent)
C#
public static List<SelectTableEvent> CreateCopyOfSelectTableActions(
    List<SelectTableEvent> list
)
Visual C++
public:
static List<SelectTableEvent>^ CreateCopyOfSelectTableActions(
    List<SelectTableEvent>^ list
)

Parameters

list
Type: List<(Of <( SelectTableEvent >)>)

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


CreateNew Method

[image]

SQL Data Compare API 12.0.40
Project..::.CreateNew Method
Project Class See Also

Creates a new blank project.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateNew As Project
C#
public static Project CreateNew()
Visual C++
public:
static Project^ CreateNew()

Return Value

A new instance of class Project.

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


Deserialize Method

[image]

SQL Data Compare API 12.0.40
Project..::.Deserialize Method
Project Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Function Deserialize ( _
    versionId As Integer, _
    formatter As ISerializeFormatter _
) As Boolean
C#
public bool Deserialize(
    int versionId,
    ISerializeFormatter formatter
)
Visual C++
public:
virtual bool Deserialize(
    int versionId,
    ISerializeFormatter^ formatter
) sealed

Parameters

versionId
Type: Int32
formatter
Type: ISerializeFormatter

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image]

SQL Data Compare API 12.0.40
Project..::.Equals Method
Project Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
Project..::.GetHashCode Method
Project Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


LoadFromDisk Method

[image]

SQL Data Compare API 12.0.40
Project..::.LoadFromDisk Method
Project Class See Also

Loads a project from disk.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function LoadFromDisk ( _
    fileName As String _
) As Project
C#
public static Project LoadFromDisk(
    string fileName
)
Visual C++
public:
static Project^ LoadFromDisk(
    String^ fileName
)

Parameters

fileName
Type: String
The file name of the project.

Return Value

A Project object.

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


MappingEquals Method

[image]

SQL Data Compare API 12.0.40
Project..::.MappingEquals Method
Project Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Function MappingEquals ( _
    obj As Object _
) As Boolean
C#
public bool MappingEquals(
    Object obj
)
Visual C++
public:
bool MappingEquals(
    Object^ obj
)

Parameters

obj
Type: Object

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


SaveToDisk Method

[image]

SQL Data Compare API 12.0.40
Project..::.SaveToDisk Method
Project Class See Also

Save the project to disk

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveToDisk ( _
    fileName As String _
)
C#
public void SaveToDisk(
    string fileName
)
Visual C++
public:
void SaveToDisk(
    String^ fileName
)

Parameters

fileName
Type: String
The file name

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


Serialize Method

[image]

SQL Data Compare API 12.0.40
Project..::.Serialize Method
Project Class See Also

Support for serialization.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub Serialize ( _
    formatter As ISerializeFormatter _
)
C#
public void Serialize(
    ISerializeFormatter formatter
)
Visual C++
public:
virtual void Serialize(
    ISerializeFormatter^ formatter
) sealed

Parameters

formatter
Type: ISerializeFormatter
The formatter to write to.

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


SetClean Method

[image]

SQL Data Compare API 12.0.40
Project..::.SetClean Method
Project Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetClean
C#
public void SetClean()
Visual C++
public:
void SetClean()

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


SetDirty Method

[image]

SQL Data Compare API 12.0.40
Project..::.SetDirty Method
Project Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetDirty
C#
public void SetDirty()
Visual C++
public:
void SetDirty()

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


SetProjectAsOld Method

[image]

SQL Data Compare API 12.0.40
Project..::.SetProjectAsOld Method
Project Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetProjectAsOld
C#
public void SetProjectAsOld()
Visual C++
public:
void SetProjectAsOld()

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
Project..::.ToString Method
Project Class See Also

Converts an instance of Project to a string.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

Return Value

A string representation of the project details.

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


Project Properties

[image] [image]

SQL Data Compare API 12.0.40
Project Properties
Project Class See Also

The Project type exposes the following properties.

Properties

Name | Description
ChangesEffect |
ComparisonOptions | Options used when running a comparison or synchronization on the project.
DataSource1 | The connection properties for the first data source.
DataSource2 | The connection properties for the second data source.
DCGroupingStyle |
DCOptions | Options used when running a comparison or synchronization on the project.
Direction | The direction in which changes are migrated when a synchronization is run on the project.
Dirty | True if the project has been modified.
FileName | The file name of the project.
IsNewProject | Determines whether the project is a new project.
IsSsmsIntegrationPackGeneratedProject |
LastCompared | The time at which the project was last compared.
LastModified | The time at which the project was last compared.
Name | The file name of a project, or "New Project".
OriginalProject |
ProblemsLoadingProject | If part of a project can't be read, LoadFromDisk(String) will warn about the missing values here.
SCDeploymentOptions |
SCGroupingStyle |
SelectTableActions | Gets or sets the OwnerMappingUserActions.
ServerFactory |
SessionSettings | The session settings used in the project comparison.
Source1AsLiveDB | A convenience method for accessing the first data source as a live database, rather than casting explicitly in code.
Source2AsLiveDB | A convenience method for accessing the second data source as a live database, rather than casting explicitly in code.
UseMigrations |
UserNote | Gets or sets the user notes.
Version | The current project version. Used for serialization.

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


ChangesEffect Property

[image]

SQL Data Compare API 12.0.40
Project..::.ChangesEffect Property
Project Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ChangesEffect As Project..::.ProjectChangesEffect
C#
public Project..::.ProjectChangesEffect ChangesEffect { get; }
Visual C++
public:
property Project..::.ProjectChangesEffect ChangesEffect {
    Project..::.ProjectChangesEffect get ();
}

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


ComparisonOptions Property

[image]

SQL Data Compare API 12.0.40
Project..::.ComparisonOptions Property
Project Class See Also

Options used when running a comparison or synchronization on the project.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property ComparisonOptions As Options
C#
public Options ComparisonOptions { get; set; }
Visual C++
public:
property Options ComparisonOptions {
    Options get ();
    void set (Options value);
}

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


DataSource1 Property

[image]

SQL Data Compare API 12.0.40
Project..::.DataSource1 Property
Project Class See Also

The connection properties for the first data source.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property DataSource1 As IDataSource
C#
public IDataSource DataSource1 { get; set; }
Visual C++
public:
property IDataSource^ DataSource1 {
    IDataSource^ get ();
    void set (IDataSource^ value);
}

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


DataSource2 Property

[image]

SQL Data Compare API 12.0.40
Project..::.DataSource2 Property
Project Class See Also

The connection properties for the second data source.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property DataSource2 As IDataSource
C#
public IDataSource DataSource2 { get; set; }
Visual C++
public:
property IDataSource^ DataSource2 {
    IDataSource^ get ();
    void set (IDataSource^ value);
}

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


DCGroupingStyle Property

[image]

SQL Data Compare API 12.0.40
Project..::.DCGroupingStyle Property
Project Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property DCGroupingStyle As DataCompareGroupingStyle
C#
public DataCompareGroupingStyle DCGroupingStyle { get; set; }
Visual C++
public:
property DataCompareGroupingStyle DCGroupingStyle {
    DataCompareGroupingStyle get ();
    void set (DataCompareGroupingStyle value);
}

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


DCOptions Property

[image]

SQL Data Compare API 12.0.40
Project..::.DCOptions Property
Project Class See Also

Options used when running a comparison or synchronization on the project.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property DCOptions As EngineDataCompareOptions
C#
public EngineDataCompareOptions DCOptions { get; set; }
Visual C++
public:
property EngineDataCompareOptions^ DCOptions {
    EngineDataCompareOptions^ get ();
    void set (EngineDataCompareOptions^ value);
}

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


Direction Property

[image]

SQL Data Compare API 12.0.40
Project..::.Direction Property
Project Class See Also

The direction in which changes are migrated when a synchronization is run on the project.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property Direction As SynchronizationDirection
C#
public SynchronizationDirection Direction { get; set; }
Visual C++
public:
property SynchronizationDirection Direction {
    SynchronizationDirection get ();
    void set (SynchronizationDirection value);
}

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


Dirty Property

[image]

SQL Data Compare API 12.0.40
Project..::.Dirty Property
Project Class See Also

True if the project has been modified.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property Dirty As Boolean
C#
public bool Dirty { get; private set; }
Visual C++
public:
property bool Dirty {
    bool get ();
    void set (bool value);
}

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


FileName Property

[image]

SQL Data Compare API 12.0.40
Project..::.FileName Property
Project Class See Also

The file name of the project.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property FileName As String
C#
public string FileName { get; set; }
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


IsNewProject Property

[image]

SQL Data Compare API 12.0.40
Project..::.IsNewProject Property
Project Class See Also

Determines whether the project is a new project.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property IsNewProject As Boolean
C#
public bool IsNewProject { get; private set; }
Visual C++
public:
property bool IsNewProject {
    bool get ();
    void set (bool value);
}

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


IsSsmsIntegrationPackGeneratedProject Property

[image]

SQL Data Compare API 12.0.40
Project..::.IsSsmsIntegrationPackGeneratedProject Property
Project Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSsmsIntegrationPackGeneratedProject As Boolean
C#
public bool IsSsmsIntegrationPackGeneratedProject { get; private set; }
Visual C++
public:
property bool IsSsmsIntegrationPackGeneratedProject {
    bool get ();
    void set (bool value);
}

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


LastCompared Property

[image]

SQL Data Compare API 12.0.40
Project..::.LastCompared Property
Project Class See Also

The time at which the project was last compared.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property LastCompared As DateTime
C#
public DateTime LastCompared { get; set; }
Visual C++
public:
property DateTime LastCompared {
    DateTime get ();
    void set (DateTime value);
}

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


LastModified Property

[image]

SQL Data Compare API 12.0.40
Project..::.LastModified Property
Project Class See Also

The time at which the project was last compared.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property LastModified As DateTime
C#
public DateTime LastModified { get; set; }
Visual C++
public:
property DateTime LastModified {
    DateTime get ();
    void set (DateTime value);
}

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
Project..::.Name Property
Project Class See Also

The file name of a project, or "New Project".

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


OriginalProject Property

[image]

SQL Data Compare API 12.0.40
Project..::.OriginalProject Property
Project Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property OriginalProject As Project
C#
public Project OriginalProject { set; }
Visual C++
public:
property Project^ OriginalProject {
    void set (Project^ value);
}

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


ProblemsLoadingProject Property

[image]

SQL Data Compare API 12.0.40
Project..::.ProblemsLoadingProject Property
Project Class See Also

If part of a project can't be read, LoadFromDisk(String) will warn about the missing values here.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProblemsLoadingProject As IEnumerable(Of String)
C#
public IEnumerable<string> ProblemsLoadingProject { get; }
Visual C++
public:
property IEnumerable<String^>^ ProblemsLoadingProject {
    IEnumerable<String^>^ get ();
}

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


SCDeploymentOptions Property

[image]

SQL Data Compare API 12.0.40
Project..::.SCDeploymentOptions Property
Project Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property SCDeploymentOptions As SC_DeploymentOptions
C#
public SC_DeploymentOptions SCDeploymentOptions { get; set; }
Visual C++
public:
property SC_DeploymentOptions^ SCDeploymentOptions {
    SC_DeploymentOptions^ get ();
    void set (SC_DeploymentOptions^ value);
}

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


SCGroupingStyle Property

[image]

SQL Data Compare API 12.0.40
Project..::.SCGroupingStyle Property
Project Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property SCGroupingStyle As GroupingStyle
C#
public GroupingStyle SCGroupingStyle { get; set; }
Visual C++
public:
property GroupingStyle SCGroupingStyle {
    GroupingStyle get ();
    void set (GroupingStyle value);
}

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


SelectTableActions Property

[image]

SQL Data Compare API 12.0.40
Project..::.SelectTableActions Property
Project Class See Also

Gets or sets the OwnerMappingUserActions.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectTableActions As List(Of SelectTableEvent)
C#
public List<SelectTableEvent> SelectTableActions { get; set; }
Visual C++
public:
property List<SelectTableEvent>^ SelectTableActions {
    List<SelectTableEvent>^ get ();
    void set (List<SelectTableEvent>^ value);
}

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


ServerFactory Property

[image]

SQL Data Compare API 12.0.40
Project..::.ServerFactory Property
Project Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ServerFactory As IServerFactory
C#
public IServerFactory ServerFactory { get; }
Visual C++
public:
property IServerFactory^ ServerFactory {
    IServerFactory^ get ();
}

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


SessionSettings Property

[image]

SQL Data Compare API 12.0.40
Project..::.SessionSettings Property
Project Class See Also

The session settings used in the project comparison.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property SessionSettings As SessionSettings
C#
public SessionSettings SessionSettings { get; set; }
Visual C++
public:
property SessionSettings SessionSettings {
    SessionSettings get ();
    void set (SessionSettings value);
}

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


Source1AsLiveDB Property

[image]

SQL Data Compare API 12.0.40
Project..::.Source1AsLiveDB Property
Project Class See Also

A convenience method for accessing the first data source as a live database, rather than casting explicitly in code.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Source1AsLiveDB As LiveDatabaseSource
C#
public LiveDatabaseSource Source1AsLiveDB { get; }
Visual C++
public:
property LiveDatabaseSource^ Source1AsLiveDB {
    LiveDatabaseSource^ get ();
}

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


Source2AsLiveDB Property

[image]

SQL Data Compare API 12.0.40
Project..::.Source2AsLiveDB Property
Project Class See Also

A convenience method for accessing the second data source as a live database, rather than casting explicitly in code.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Source2AsLiveDB As LiveDatabaseSource
C#
public LiveDatabaseSource Source2AsLiveDB { get; }
Visual C++
public:
property LiveDatabaseSource^ Source2AsLiveDB {
    LiveDatabaseSource^ get ();
}

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


UseMigrations Property

[image]

SQL Data Compare API 12.0.40
Project..::.UseMigrations Property
Project Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property UseMigrations As Boolean
C#
public bool UseMigrations { get; set; }
Visual C++
public:
property bool UseMigrations {
    bool get ();
    void set (bool value);
}

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


UserNote Property

[image]

SQL Data Compare API 12.0.40
Project..::.UserNote Property
Project Class See Also

Gets or sets the user notes.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property UserNote As String
C#
public string UserNote { get; set; }
Visual C++
public:
property String^ UserNote {
    String^ get ();
    void set (String^ value);
}

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


Version Property

[image]

SQL Data Compare API 12.0.40
Project..::.Version Property
Project Class See Also

The current project version. Used for serialization.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As Integer
C#
public int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () sealed;
}

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


Project Events

[image] [image]

SQL Data Compare API 12.0.40
Project Events
Project Class See Also

The Project type exposes the following events.

Events

Name | Description
ProjectDirtyStateChanged |

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


ProjectDirtyStateChanged Event

[image]

SQL Data Compare API 12.0.40
Project..::.ProjectDirtyStateChanged Event
Project Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Event ProjectDirtyStateChanged As EventHandler(Of EventArgs)
C#
public event EventHandler<EventArgs> ProjectDirtyStateChanged
Visual C++
public:
 event EventHandler<EventArgs^>^ ProjectDirtyStateChanged {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

See Also

Project Class
RedGate.SQLCompare.Engine Namespace


Project.ProjectChangesEffect Enumeration

[image]

SQL Data Compare API 12.0.40
Project..::.ProjectChangesEffect Enumeration
Project Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration ProjectChangesEffect
C#
public enum ProjectChangesEffect
Visual C++
public enum class ProjectChangesEffect

Members

Member name | Description
None |
SyncOnly |
Recompare |

See Also

RedGate.SQLCompare.Engine Namespace


Project.UberProjectDeserializationMode Enumeration

[image]

SQL Data Compare API 12.0.40
Project..::.UberProjectDeserializationMode Enumeration
Project Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration UberProjectDeserializationMode
C#
public enum UberProjectDeserializationMode
Visual C++
public enum class UberProjectDeserializationMode

Members

Member name | Description
UberProject |
SQLCompare |
SQLDataCompare |

See Also

RedGate.SQLCompare.Engine Namespace


ProjectBackupOptions Class

[image]

SQL Data Compare API 12.0.40
ProjectBackupOptions Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ProjectBackupOptions
C#
public sealed class ProjectBackupOptions
Visual C++
public ref class ProjectBackupOptions sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ProjectBackupOptions

See Also

ProjectBackupOptions Members
RedGate.SQLCompare.Engine Namespace


ProjectBackupOptions Members

[image] [image]

SQL Data Compare API 12.0.40
ProjectBackupOptions Members
ProjectBackupOptions Class Constructors Methods Properties See Also

The ProjectBackupOptions type exposes the following members.

Constructors

Name | Description
ProjectBackupOptions |

Methods

Name | Description
Clone |
CloneToBackupOptions |
Deserialize |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize |
SetDefaultOptions |
ToString | (Overrides Object..::.ToString()()().)
UpdateFromDataSource |

Properties

Name | Description
BackupEnabled |
CachedSqbLicenseType | Gets the type of the SQL Backup license on the target server
CachedSqbVersion | Gets the installed version of SQL Backup on the target server. Returns zero if SQL Backup isn't installed.
CompressionLevel |
DatabaseName |
EncryptionLevel |
Filename |
Folder |
NameFileAutomatically |
OverwriteIfExists |
Password |
ProviderOfBackup |
ThreadCount |
TypeOfBackup |
Version |

See Also

ProjectBackupOptions Class
RedGate.SQLCompare.Engine Namespace


ProjectBackupOptions Constructor

[image]

SQL Data Compare API 12.0.40
ProjectBackupOptions Constructor
ProjectBackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ProjectBackupOptions()
Visual C++
public:
ProjectBackupOptions()

See Also

ProjectBackupOptions Class
RedGate.SQLCompare.Engine Namespace


ProjectBackupOptions Methods

[image] [image]

SQL Data Compare API 12.0.40
ProjectBackupOptions Methods
ProjectBackupOptions Class See Also

The ProjectBackupOptions type exposes the following methods.

Methods

Name | Description
Clone |
CloneToBackupOptions |
Deserialize |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize |
SetDefaultOptions |
ToString | (Overrides Object..::.ToString()()().)
UpdateFromDataSource |

See Also

ProjectBackupOptions Class
RedGate.SQLCompare.Engine Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
ProjectBackupOptions..::.Clone Method
ProjectBackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone As ProjectBackupOptions
C#
public ProjectBackupOptions Clone()
Visual C++
public:
ProjectBackupOptions^ Clone()

See Also

ProjectBackupOptions Class
RedGate.SQLCompare.Engine Namespace


CloneToBackupOptions Method

[image]

SQL Data Compare API 12.0.40
ProjectBackupOptions..::.CloneToBackupOptions Method
ProjectBackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Function CloneToBackupOptions As BackupOptions
C#
public BackupOptions CloneToBackupOptions()
Visual C++
public:
BackupOptions^ CloneToBackupOptions()

See Also

ProjectBackupOptions Class
RedGate.SQLCompare.Engine Namespace


Deserialize Method

[image]

SQL Data Compare API 12.0.40
ProjectBackupOptions..::.Deserialize Method
ProjectBackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Function Deserialize ( _
    versionId As Integer, _
    formatter As ISerializeFormatter _
) As Boolean
C#
public bool Deserialize(
    int versionId,
    ISerializeFormatter formatter
)
Visual C++
public:
virtual bool Deserialize(
    int versionId,
    ISerializeFormatter^ formatter
) sealed

Parameters

versionId
Type: Int32
formatter
Type: ISerializeFormatter

See Also

ProjectBackupOptions Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
ProjectBackupOptions..::.Equals Method
ProjectBackupOptions Class See Also

Overload List

Name | Description
Equals(Object) | (Overrides Object..::.Equals(Object).)
Equals(ProjectBackupOptions) |

See Also

ProjectBackupOptions Class
ProjectBackupOptions Members
RedGate.SQLCompare.Engine Namespace


Equals Method ()

[image]

SQL Data Compare API 12.0.40
ProjectBackupOptions..::.Equals Method ()
ProjectBackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object

See Also

ProjectBackupOptions Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


Equals Method (ProjectBackupOptions)

[image]

SQL Data Compare API 12.0.40
ProjectBackupOptions..::.Equals Method (ProjectBackupOptions)
ProjectBackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    other As ProjectBackupOptions _
) As Boolean
C#
public bool Equals(
    ProjectBackupOptions other
)
Visual C++
public:
bool Equals(
    ProjectBackupOptions^ other
)

Parameters

other
Type: RedGate.SQLCompare.Engine..::.ProjectBackupOptions

See Also

ProjectBackupOptions Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
ProjectBackupOptions..::.GetHashCode Method
ProjectBackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

See Also

ProjectBackupOptions Class
RedGate.SQLCompare.Engine Namespace


Serialize Method

[image]

SQL Data Compare API 12.0.40
ProjectBackupOptions..::.Serialize Method
ProjectBackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub Serialize ( _
    formatter As ISerializeFormatter _
)
C#
public void Serialize(
    ISerializeFormatter formatter
)
Visual C++
public:
virtual void Serialize(
    ISerializeFormatter^ formatter
) sealed

Parameters

formatter
Type: ISerializeFormatter

See Also

ProjectBackupOptions Class
RedGate.SQLCompare.Engine Namespace


SetDefaultOptions Method

[image]

SQL Data Compare API 12.0.40
ProjectBackupOptions..::.SetDefaultOptions Method
ProjectBackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetDefaultOptions
C#
public void SetDefaultOptions()
Visual C++
public:
void SetDefaultOptions()

See Also

ProjectBackupOptions Class
RedGate.SQLCompare.Engine Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
ProjectBackupOptions..::.ToString Method
ProjectBackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

See Also

ProjectBackupOptions Class
RedGate.SQLCompare.Engine Namespace


UpdateFromDataSource Method

[image]

SQL Data Compare API 12.0.40
ProjectBackupOptions..::.UpdateFromDataSource Method
ProjectBackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub UpdateFromDataSource ( _
    factory As IServerFactory, _
    dataSource As IDataSource _
)
C#
public void UpdateFromDataSource(
    IServerFactory factory,
    IDataSource dataSource
)
Visual C++
public:
void UpdateFromDataSource(
    IServerFactory^ factory,
    IDataSource^ dataSource
)

Parameters

factory
Type: RedGate.SQLCompare.Engine.Deployment..::.IServerFactory
dataSource
Type: RedGate.Shared.SQL..::.IDataSource

See Also

ProjectBackupOptions Class
RedGate.SQLCompare.Engine Namespace


ProjectBackupOptions Properties

[image] [image]

SQL Data Compare API 12.0.40
ProjectBackupOptions Properties
ProjectBackupOptions Class See Also

The ProjectBackupOptions type exposes the following properties.

Properties

Name | Description
BackupEnabled |
CachedSqbLicenseType | Gets the type of the SQL Backup license on the target server
CachedSqbVersion | Gets the installed version of SQL Backup on the target server. Returns zero if SQL Backup isn't installed.
CompressionLevel |
DatabaseName |
EncryptionLevel |
Filename |
Folder |
NameFileAutomatically |
OverwriteIfExists |
Password |
ProviderOfBackup |
ThreadCount |
TypeOfBackup |
Version |

See Also

ProjectBackupOptions Class
RedGate.SQLCompare.Engine Namespace


BackupEnabled Property

[image]

SQL Data Compare API 12.0.40
ProjectBackupOptions..::.BackupEnabled Property
ProjectBackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property BackupEnabled As Boolean
C#
public bool BackupEnabled { get; set; }
Visual C++
public:
property bool BackupEnabled {
    bool get ();
    void set (bool value);
}

See Also

ProjectBackupOptions Class
RedGate.SQLCompare.Engine Namespace


CachedSqbLicenseType Property

[image]

SQL Data Compare API 12.0.40
ProjectBackupOptions..::.CachedSqbLicenseType Property
ProjectBackupOptions Class See Also

Gets the type of the SQL Backup license on the target server

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property CachedSqbLicenseType As SqlBackupLicenseType
C#
public SqlBackupLicenseType CachedSqbLicenseType { get; internal set; }
Visual C++
public:
property SqlBackupLicenseType CachedSqbLicenseType {
    SqlBackupLicenseType get ();
    void set (SqlBackupLicenseType value);
}

See Also

ProjectBackupOptions Class
RedGate.SQLCompare.Engine Namespace


CachedSqbVersion Property

[image]

SQL Data Compare API 12.0.40
ProjectBackupOptions..::.CachedSqbVersion Property
ProjectBackupOptions Class See Also

Gets the installed version of SQL Backup on the target server. Returns zero if SQL Backup isn't installed.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property CachedSqbVersion As Integer
C#
public int CachedSqbVersion { get; set; }
Visual C++
public:
property int CachedSqbVersion {
    int get ();
    void set (int value);
}

See Also

ProjectBackupOptions Class
RedGate.SQLCompare.Engine Namespace


CompressionLevel Property

[image]

SQL Data Compare API 12.0.40
ProjectBackupOptions..::.CompressionLevel Property
ProjectBackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property CompressionLevel As Integer
C#
public int CompressionLevel { get; set; }
Visual C++
public:
property int CompressionLevel {
    int get ();
    void set (int value);
}

See Also

ProjectBackupOptions Class
RedGate.SQLCompare.Engine Namespace


DatabaseName Property

[image]

SQL Data Compare API 12.0.40
ProjectBackupOptions..::.DatabaseName Property
ProjectBackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property DatabaseName As String
C#
public string DatabaseName { get; set; }
Visual C++
public:
property String^ DatabaseName {
    String^ get ();
    void set (String^ value);
}

See Also

ProjectBackupOptions Class
RedGate.SQLCompare.Engine Namespace


EncryptionLevel Property

[image]

SQL Data Compare API 12.0.40
ProjectBackupOptions..::.EncryptionLevel Property
ProjectBackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property EncryptionLevel As SqbEncryptionLevel
C#
public SqbEncryptionLevel EncryptionLevel { get; set; }
Visual C++
public:
property SqbEncryptionLevel EncryptionLevel {
    SqbEncryptionLevel get ();
    void set (SqbEncryptionLevel value);
}

See Also

ProjectBackupOptions Class
RedGate.SQLCompare.Engine Namespace


Filename Property

[image]

SQL Data Compare API 12.0.40
ProjectBackupOptions..::.Filename Property
ProjectBackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property Filename As String
C#
public string Filename { get; set; }
Visual C++
public:
property String^ Filename {
    String^ get ();
    void set (String^ value);
}

See Also

ProjectBackupOptions Class
RedGate.SQLCompare.Engine Namespace


Folder Property

[image]

SQL Data Compare API 12.0.40
ProjectBackupOptions..::.Folder Property
ProjectBackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property Folder As String
C#
public string Folder { get; set; }
Visual C++
public:
property String^ Folder {
    String^ get ();
    void set (String^ value);
}

See Also

ProjectBackupOptions Class
RedGate.SQLCompare.Engine Namespace


NameFileAutomatically Property

[image]

SQL Data Compare API 12.0.40
ProjectBackupOptions..::.NameFileAutomatically Property
ProjectBackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property NameFileAutomatically As Boolean
C#
public bool NameFileAutomatically { get; set; }
Visual C++
public:
property bool NameFileAutomatically {
    bool get ();
    void set (bool value);
}

See Also

ProjectBackupOptions Class
RedGate.SQLCompare.Engine Namespace


OverwriteIfExists Property

[image]

SQL Data Compare API 12.0.40
ProjectBackupOptions..::.OverwriteIfExists Property
ProjectBackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property OverwriteIfExists As Boolean
C#
public bool OverwriteIfExists { get; set; }
Visual C++
public:
property bool OverwriteIfExists {
    bool get ();
    void set (bool value);
}

See Also

ProjectBackupOptions Class
RedGate.SQLCompare.Engine Namespace


Password Property

[image]

SQL Data Compare API 12.0.40
ProjectBackupOptions..::.Password Property
ProjectBackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password { get; set; }
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

ProjectBackupOptions Class
RedGate.SQLCompare.Engine Namespace


ProviderOfBackup Property

[image]

SQL Data Compare API 12.0.40
ProjectBackupOptions..::.ProviderOfBackup Property
ProjectBackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property ProviderOfBackup As BackupProvider
C#
public BackupProvider ProviderOfBackup { get; set; }
Visual C++
public:
property BackupProvider ProviderOfBackup {
    BackupProvider get ();
    void set (BackupProvider value);
}

See Also

ProjectBackupOptions Class
RedGate.SQLCompare.Engine Namespace


ThreadCount Property

[image]

SQL Data Compare API 12.0.40
ProjectBackupOptions..::.ThreadCount Property
ProjectBackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property ThreadCount As Integer
C#
public int ThreadCount { get; set; }
Visual C++
public:
property int ThreadCount {
    int get ();
    void set (int value);
}

See Also

ProjectBackupOptions Class
RedGate.SQLCompare.Engine Namespace


TypeOfBackup Property

[image]

SQL Data Compare API 12.0.40
ProjectBackupOptions..::.TypeOfBackup Property
ProjectBackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeOfBackup As TypeOfBackup
C#
public TypeOfBackup TypeOfBackup { get; set; }
Visual C++
public:
property TypeOfBackup TypeOfBackup {
    TypeOfBackup get ();
    void set (TypeOfBackup value);
}

See Also

ProjectBackupOptions Class
RedGate.SQLCompare.Engine Namespace


Version Property

[image]

SQL Data Compare API 12.0.40
ProjectBackupOptions..::.Version Property
ProjectBackupOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As Integer
C#
public int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () sealed;
}

See Also

ProjectBackupOptions Class
RedGate.SQLCompare.Engine Namespace


Queue Class

[image]

SQL Data Compare API 12.0.40
Queue Class
Members See Also

A queue.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Queue _
    Inherits SchemaObjectWithAuthorization _
    Implements IIsSystemObject, IDatabaseObject, ITSqlObject, ICanExistenceCheck,  _
    IExecuteAs, IPatchUpAfterDeserialization, ISqlComparable
C#
public sealed class Queue : SchemaObjectWithAuthorization, IIsSystemObject,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, IExecuteAs, IPatchUpAfterDeserialization,
    ISqlComparable
Visual C++
public ref class Queue sealed : public SchemaObjectWithAuthorization,
    IIsSystemObject, IDatabaseObject, ITSqlObject, ICanExistenceCheck, IExecuteAs,
    IPatchUpAfterDeserialization, ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.SchemaObjectWithAuthorization
RedGate.SQLCompare.Engine..::.Queue

See Also

Queue Members
RedGate.SQLCompare.Engine Namespace


Queue Members

[image] [image]

SQL Data Compare API 12.0.40
Queue Members
Queue Class Methods Fields Properties Explicit Interface Implementations See Also

The Queue type exposes the following members.

Methods

Name | Description
CompareWith |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
ActivationEnabled | True if the activation is enabled.
ActivationProcedure | The name of the activation stored procedure.
AlterAuthorizationClassType | (Inherited from SchemaObjectWithAuthorization.)
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
EnqueueEnabled | True if enqueue is enabled.
EventNotifications | The dependent event notifications.
ExecuteAs | The user whose security context is to be used for the execution of the queue. This is a SQL Server 2005 feature only.
ExecuteAsType | The EXECUTE AS clause used for the object.
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FileGroup | The filegroup for the queue.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
IsSystemObject | Indicates whether the object in question is a system object.
MaxReaders | The maximum number of readers.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Queue (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from SchemaObjectWithAuthorization.)
PoisonMessageHandling |
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ReceiveEnabled | True if the queue is receive enabled.
RetentionEnabled | True if retention is enabled.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSources | (Inherited from SchemaObject.)
Services | The dependent services.

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

Queue Class
RedGate.SQLCompare.Engine Namespace


Queue Methods

[image] [image]

SQL Data Compare API 12.0.40
Queue Methods
Queue Class See Also

The Queue type exposes the following methods.

Methods

Name | Description
CompareWith |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

Queue Class
RedGate.SQLCompare.Engine Namespace


CompareWith Method

[image]

SQL Data Compare API 12.0.40
Queue..::.CompareWith Method
Queue Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareWith ( _
    target As Queue, _
    options As Options _
) As IEnumerable(Of EqualityDifference)
C#
public IEnumerable<EqualityDifference> CompareWith(
    Queue target,
    Options options
)
Visual C++
public:
IEnumerable<EqualityDifference^>^ CompareWith(
    Queue^ target,
    Options options
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.Queue
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

Queue Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
Queue..::.ISqlComparable..::.CompareWith Method
Queue Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    obj As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable obj,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ obj,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

obj
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

Queue Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
Queue..::.Equals Method
Queue Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares two database objects. (Inherited from ScriptableDatabaseObject.)

See Also

Queue Class
Queue Members
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
Queue..::.PatchUpAfterDeserialization Method
Queue Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

Queue Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
Queue..::.ScriptObject Method
Queue Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

Queue Class
RedGate.SQLCompare.Engine Namespace


Queue Properties

[image] [image]

SQL Data Compare API 12.0.40
Queue Properties
Queue Class See Also

The Queue type exposes the following properties.

Properties

Name | Description
ActivationEnabled | True if the activation is enabled.
ActivationProcedure | The name of the activation stored procedure.
AlterAuthorizationClassType | (Inherited from SchemaObjectWithAuthorization.)
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
EnqueueEnabled | True if enqueue is enabled.
EventNotifications | The dependent event notifications.
ExecuteAs | The user whose security context is to be used for the execution of the queue. This is a SQL Server 2005 feature only.
ExecuteAsType | The EXECUTE AS clause used for the object.
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FileGroup | The filegroup for the queue.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
IsSystemObject | Indicates whether the object in question is a system object.
MaxReaders | The maximum number of readers.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Queue (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from SchemaObjectWithAuthorization.)
PoisonMessageHandling |
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ReceiveEnabled | True if the queue is receive enabled.
RetentionEnabled | True if retention is enabled.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSources | (Inherited from SchemaObject.)
Services | The dependent services.

See Also

Queue Class
RedGate.SQLCompare.Engine Namespace


ActivationEnabled Property

[image]

SQL Data Compare API 12.0.40
Queue..::.ActivationEnabled Property
Queue Class See Also

True if the activation is enabled.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ActivationEnabled As Boolean
C#
public bool ActivationEnabled { get; internal set; }
Visual C++
public:
property bool ActivationEnabled {
    bool get ();
    void set (bool value);
}

See Also

Queue Class
RedGate.SQLCompare.Engine Namespace


ActivationProcedure Property

[image]

SQL Data Compare API 12.0.40
Queue..::.ActivationProcedure Property
Queue Class See Also

The name of the activation stored procedure.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ActivationProcedure As String
C#
public string ActivationProcedure { get; internal set; }
Visual C++
public:
property String^ ActivationProcedure {
    String^ get ();
    void set (String^ value);
}

See Also

Queue Class
RedGate.SQLCompare.Engine Namespace


EnqueueEnabled Property

[image]

SQL Data Compare API 12.0.40
Queue..::.EnqueueEnabled Property
Queue Class See Also

True if enqueue is enabled.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property EnqueueEnabled As Boolean
C#
public bool EnqueueEnabled { get; internal set; }
Visual C++
public:
property bool EnqueueEnabled {
    bool get ();
    void set (bool value);
}

See Also

Queue Class
RedGate.SQLCompare.Engine Namespace


EventNotifications Property

[image]

SQL Data Compare API 12.0.40
Queue..::.EventNotifications Property
Queue Class See Also

The dependent event notifications.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EventNotifications As EventNotifications
C#
public EventNotifications EventNotifications { get; }
Visual C++
public:
property EventNotifications^ EventNotifications {
    EventNotifications^ get ();
}

See Also

Queue Class
RedGate.SQLCompare.Engine Namespace


ExecuteAs Property

[image]

SQL Data Compare API 12.0.40
Queue..::.ExecuteAs Property
Queue Class See Also

The user whose security context is to be used for the execution of the queue. This is a SQL Server 2005 feature only.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecuteAs As User
C#
public User ExecuteAs { get; internal set; }
Visual C++
public:
virtual property User^ ExecuteAs {
    User^ get () sealed;
    void set (User^ value) sealed;
}

Implements

IExecuteAs..::.ExecuteAs

See Also

Queue Class
RedGate.SQLCompare.Engine Namespace


ExecuteAsType Property

[image]

SQL Data Compare API 12.0.40
Queue..::.ExecuteAsType Property
Queue Class See Also

The EXECUTE AS clause used for the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecuteAsType As ExecuteAs
C#
public ExecuteAs ExecuteAsType { get; internal set; }
Visual C++
public:
virtual property ExecuteAs ExecuteAsType {
    ExecuteAs get () sealed;
    void set (ExecuteAs value) sealed;
}

Implements

IExecuteAs..::.ExecuteAsType

See Also

Queue Class
RedGate.SQLCompare.Engine Namespace


FileGroup Property

[image]

SQL Data Compare API 12.0.40
Queue..::.FileGroup Property
Queue Class See Also

The filegroup for the queue.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FileGroup As String
C#
public string FileGroup { get; internal set; }
Visual C++
public:
property String^ FileGroup {
    String^ get ();
    void set (String^ value);
}

See Also

Queue Class
RedGate.SQLCompare.Engine Namespace


IsSystemObject Property

[image]

SQL Data Compare API 12.0.40
Queue..::.IsSystemObject Property
Queue Class See Also

Indicates whether the object in question is a system object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSystemObject As Boolean
C#
public bool IsSystemObject { get; private set; }
Visual C++
public:
virtual property bool IsSystemObject {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IIsSystemObject..::.IsSystemObject

See Also

Queue Class
RedGate.SQLCompare.Engine Namespace


MaxReaders Property

[image]

SQL Data Compare API 12.0.40
Queue..::.MaxReaders Property
Queue Class See Also

The maximum number of readers.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxReaders As Short
C#
public short MaxReaders { get; internal set; }
Visual C++
public:
property short MaxReaders {
    short get ();
    void set (short value);
}

See Also

Queue Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
Queue..::.ObjectType Property
Queue Class See Also

Returns ObjectType.Queue

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()
ITSqlObjectObjectType()()()

See Also

Queue Class
RedGate.SQLCompare.Engine Namespace


PoisonMessageHandling Property

[image]

SQL Data Compare API 12.0.40
Queue..::.PoisonMessageHandling Property
Queue Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PoisonMessageHandling As Boolean
C#
public bool PoisonMessageHandling { get; set; }
Visual C++
public:
property bool PoisonMessageHandling {
    bool get ();
    void set (bool value);
}

See Also

Queue Class
RedGate.SQLCompare.Engine Namespace


ReceiveEnabled Property

[image]

SQL Data Compare API 12.0.40
Queue..::.ReceiveEnabled Property
Queue Class See Also

True if the queue is receive enabled.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ReceiveEnabled As Boolean
C#
public bool ReceiveEnabled { get; internal set; }
Visual C++
public:
property bool ReceiveEnabled {
    bool get ();
    void set (bool value);
}

See Also

Queue Class
RedGate.SQLCompare.Engine Namespace


RetentionEnabled Property

[image]

SQL Data Compare API 12.0.40
Queue..::.RetentionEnabled Property
Queue Class See Also

True if retention is enabled.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RetentionEnabled As Boolean
C#
public bool RetentionEnabled { get; internal set; }
Visual C++
public:
property bool RetentionEnabled {
    bool get ();
    void set (bool value);
}

See Also

Queue Class
RedGate.SQLCompare.Engine Namespace


Services Property

[image]

SQL Data Compare API 12.0.40
Queue..::.Services Property
Queue Class See Also

The dependent services.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Services As Services
C#
public Services Services { get; private set; }
Visual C++
public:
property Services^ Services {
    Services^ get ();
    void set (Services^ value);
}

See Also

Queue Class
RedGate.SQLCompare.Engine Namespace


Queues Class

[image]

SQL Data Compare API 12.0.40
Queues Class
Members See Also

A collection of queues.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Queues _
    Inherits SerializableDatabaseObjectCollection(Of Queue) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class Queues : SerializableDatabaseObjectCollection<Queue>, IPatchUpAfterDeserialization
Visual C++
public ref class Queues sealed : public SerializableDatabaseObjectCollection<Queue^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Queue >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( Queue >)>)
RedGate.SQLCompare.Engine..::.Queues

See Also

Queues Members
RedGate.SQLCompare.Engine Namespace


Queues Members

[image] [image]

SQL Data Compare API 12.0.40
Queues Members
Queues Class Methods Fields Properties Explicit Interface Implementations See Also

The Queues type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

Queues Class
RedGate.SQLCompare.Engine Namespace


Queues Methods

[image] [image]

SQL Data Compare API 12.0.40
Queues Methods
Queues Class See Also

The Queues type exposes the following methods.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

Queues Class
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
Queues..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
Queues Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

Queues Class
RedGate.SQLCompare.Engine Namespace


QueuesChanges Class

[image]

SQL Data Compare API 12.0.40
QueuesChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class QueuesChanges
C#
public sealed class QueuesChanges
Visual C++
public ref class QueuesChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.QueuesChanges

See Also

QueuesChanges Members
RedGate.SQLCompare.Engine Namespace


QueuesChanges Members

[image] [image]

SQL Data Compare API 12.0.40
QueuesChanges Members
QueuesChanges Class Constructors Methods Properties See Also

The QueuesChanges type exposes the following members.

Constructors

Name | Description
QueuesChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
QueuesToAlter |
QueuesToCreate |
QueuesToDrop |
QueueTargets |

See Also

QueuesChanges Class
RedGate.SQLCompare.Engine Namespace


QueuesChanges Constructor

[image]

SQL Data Compare API 12.0.40
QueuesChanges Constructor
QueuesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public QueuesChanges(
    bool caseSensitive
)
Visual C++
public:
QueuesChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

QueuesChanges Class
RedGate.SQLCompare.Engine Namespace


QueuesChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
QueuesChanges Properties
QueuesChanges Class See Also

The QueuesChanges type exposes the following properties.

Properties

Name | Description
QueuesToAlter |
QueuesToCreate |
QueuesToDrop |
QueueTargets |

See Also

QueuesChanges Class
RedGate.SQLCompare.Engine Namespace


QueuesToAlter Property

[image]

SQL Data Compare API 12.0.40
QueuesChanges..::.QueuesToAlter Property
QueuesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property QueuesToAlter As Queues
C#
public Queues QueuesToAlter { get; private set; }
Visual C++
public:
property Queues^ QueuesToAlter {
    Queues^ get ();
    void set (Queues^ value);
}

See Also

QueuesChanges Class
RedGate.SQLCompare.Engine Namespace


QueuesToCreate Property

[image]

SQL Data Compare API 12.0.40
QueuesChanges..::.QueuesToCreate Property
QueuesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property QueuesToCreate As Queues
C#
public Queues QueuesToCreate { get; private set; }
Visual C++
public:
property Queues^ QueuesToCreate {
    Queues^ get ();
    void set (Queues^ value);
}

See Also

QueuesChanges Class
RedGate.SQLCompare.Engine Namespace


QueuesToDrop Property

[image]

SQL Data Compare API 12.0.40
QueuesChanges..::.QueuesToDrop Property
QueuesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property QueuesToDrop As Queues
C#
public Queues QueuesToDrop { get; private set; }
Visual C++
public:
property Queues^ QueuesToDrop {
    Queues^ get ();
    void set (Queues^ value);
}

See Also

QueuesChanges Class
RedGate.SQLCompare.Engine Namespace


QueueTargets Property

[image]

SQL Data Compare API 12.0.40
QueuesChanges..::.QueueTargets Property
QueuesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property QueueTargets As Dictionary(Of Queue, Queue)
C#
public Dictionary<Queue, Queue> QueueTargets { get; private set; }
Visual C++
public:
property Dictionary<Queue^, Queue^>^ QueueTargets {
    Dictionary<Queue^, Queue^>^ get ();
    void set (Dictionary<Queue^, Queue^>^ value);
}

See Also

QueuesChanges Class
RedGate.SQLCompare.Engine Namespace


ReadOnlyDatabaseObjectCollectionWrapper(T) Generic Class

[image]

SQL Data Compare API 12.0.40
ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Generic Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ReadOnlyDatabaseObjectCollectionWrapper(Of T As IDatabaseObject) _
    Implements IReadOnlyKeyedDatabaseObjectCollectionWrapper, ICollection(Of IDatabaseObject),  _
    IEnumerable(Of IDatabaseObject), IEnumerable
C#
public class ReadOnlyDatabaseObjectCollectionWrapper<T> : IReadOnlyKeyedDatabaseObjectCollectionWrapper,
    ICollection<IDatabaseObject>, IEnumerable<IDatabaseObject>, IEnumerable where T : IDatabaseObject
Visual C++
generic<typename T>
where T : IDatabaseObject
public ref class ReadOnlyDatabaseObjectCollectionWrapper : IReadOnlyKeyedDatabaseObjectCollectionWrapper,
    ICollection<IDatabaseObject^>, IEnumerable<IDatabaseObject^>, IEnumerable

Type Parameters

T

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>)

See Also

ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Members
RedGate.SQLCompare.Engine Namespace


ReadOnlyDatabaseObjectCollectionWrapper(T) Members

[image] [image]

SQL Data Compare API 12.0.40
ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Members
ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Class Methods Properties Explicit Interface Implementations See Also

The ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Contains |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count |
IsReadOnly |
Item | Returns elements by key.

Explicit Interface Implementations

Name | Description
ICollection<(Of <(IDatabaseObject>)>)..::.Add |
ICollection<(Of <(IDatabaseObject>)>)..::.Clear |
ICollection<(Of <(IDatabaseObject>)>)..::.CopyTo |
IEnumerableGetEnumerator |
ICollection<(Of <(IDatabaseObject>)>)..::.Remove |

See Also

ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


ReadOnlyDatabaseObjectCollectionWrapper(T) Methods

[image] [image]

SQL Data Compare API 12.0.40
ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Methods
ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Class See Also

The ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) type exposes the following methods.

Methods

Name | Description
Contains |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICollection<(Of <(IDatabaseObject>)>)..::.Add |
ICollection<(Of <(IDatabaseObject>)>)..::.Clear |
ICollection<(Of <(IDatabaseObject>)>)..::.CopyTo |
IEnumerableGetEnumerator |
ICollection<(Of <(IDatabaseObject>)>)..::.Remove |

See Also

ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


(IDatabaseObject). Method

[image]

SQL Data Compare API 12.0.40
ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>)..::.<(Of <(IDatabaseObject>)>)..::. Method
ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub Add ( _
    item As IDatabaseObject _
) Implements ICollection(Of IDatabaseObject).Add
C#
void ICollection<IDatabaseObject>.Add(
    IDatabaseObject item
)
Visual C++
private:
virtual void Add(
    IDatabaseObject^ item
) sealed = ICollection<IDatabaseObject^>::Add

Parameters

item
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject

Implements

ICollectionAdd(UTP)

See Also

ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


(IDatabaseObject). Method

[image]

SQL Data Compare API 12.0.40
ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>)..::.<(Of <(IDatabaseObject>)>)..::. Method
ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub Clear Implements ICollection(Of IDatabaseObject).Clear
C#
void ICollection<IDatabaseObject>.Clear()
Visual C++
private:
virtual void Clear() sealed = ICollection<IDatabaseObject^>::Clear

Implements

ICollectionClear()()()

See Also

ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


Contains Method

[image]

SQL Data Compare API 12.0.40
ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>)..::.Contains Method
ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains ( _
    item As IDatabaseObject _
) As Boolean
C#
public bool Contains(
    IDatabaseObject item
)
Visual C++
public:
virtual bool Contains(
    IDatabaseObject^ item
) sealed

Parameters

item
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject

Implements

ICollectionContains(UTP)

See Also

ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


(IDatabaseObject). Method

[image]

SQL Data Compare API 12.0.40
ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>)..::.<(Of <(IDatabaseObject>)>)..::. Method
ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub CopyTo ( _
    array As IDatabaseObject(), _
    arrayIndex As Integer _
) Implements ICollection(Of IDatabaseObject).CopyTo
C#
void ICollection<IDatabaseObject>.CopyTo(
    IDatabaseObject[] array,
    int arrayIndex
)
Visual C++
private:
virtual void CopyTo(
    array<IDatabaseObject^>^ array,
    int arrayIndex
) sealed = ICollection<IDatabaseObject^>::CopyTo

Parameters

array
Type: array< RedGate.SQLCompare.Engine..::.IDatabaseObject >[]()[]
arrayIndex
Type: Int32

Implements

ICollectionCopyTo(array<UTP>[]()[], Int32)

See Also

ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


GetEnumerator Method

[image]

SQL Data Compare API 12.0.40
ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>)..::.GetEnumerator Method
ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of IDatabaseObject)
C#
public IEnumerator<IDatabaseObject> GetEnumerator()
Visual C++
public:
virtual IEnumerator<IDatabaseObject^>^ GetEnumerator() sealed

Implements

IEnumerableGetEnumerator()()()

See Also

ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


. Method

[image]

SQL Data Compare API 12.0.40
ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>)..::...::. Method
ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
C#
IEnumerator IEnumerable.GetEnumerator()
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerableGetEnumerator()()()

See Also

ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


(IDatabaseObject). Method

[image]

SQL Data Compare API 12.0.40
ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>)..::.<(Of <(IDatabaseObject>)>)..::. Method
ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function Remove ( _
    item As IDatabaseObject _
) As Boolean Implements ICollection(Of IDatabaseObject).Remove
C#
bool ICollection<IDatabaseObject>.Remove(
    IDatabaseObject item
)
Visual C++
private:
virtual bool Remove(
    IDatabaseObject^ item
) sealed = ICollection<IDatabaseObject^>::Remove

Parameters

item
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject

Implements

ICollectionRemove(UTP)

See Also

ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


ReadOnlyDatabaseObjectCollectionWrapper(T) Properties

[image] [image]

SQL Data Compare API 12.0.40
ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Properties
ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Class See Also

The ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) type exposes the following properties.

Properties

Name | Description
Count |
IsReadOnly |
Item | Returns elements by key.

See Also

ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


Count Property

[image]

SQL Data Compare API 12.0.40
ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>)..::.Count Property
ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count { get; }
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollectionCount()()()

See Also

ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


IsReadOnly Property

[image]

SQL Data Compare API 12.0.40
ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>)..::.IsReadOnly Property
ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
C#
public bool IsReadOnly { get; }
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Implements

ICollectionIsReadOnly()()()

See Also

ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


Item Property

[image]

SQL Data Compare API 12.0.40
ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>)..::.Item Property
ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Class See Also

Returns elements by key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    key As String _
) As IDatabaseObject
C#
public IDatabaseObject this[
    string key
] { get; }
Visual C++
public:
virtual property IDatabaseObject^ default[String^ key] {
    IDatabaseObject^ get (String^ key) sealed;
}

Parameters

key
Type: String

Implements

IReadOnlyKeyedDatabaseObjectCollectionWrapper..::.Item[([(String])])

See Also

ReadOnlyDatabaseObjectCollectionWrapper<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


ReferentialAction Enumeration

[image]

SQL Data Compare API 12.0.40
ReferentialAction Enumeration
See Also

Referential actions for foreign keys.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration ReferentialAction
C#
public enum ReferentialAction
Visual C++
public enum class ReferentialAction

Members

Member name | Description
NoAction | Cause update or delete to fail.
Cascade | Propagate changes to other tables.
SetNull | Set value to null.
SetDefault | Set value to default.

See Also

RedGate.SQLCompare.Engine Namespace


Region Class

[image]

SQL Data Compare API 12.0.40
Region Class
Members Example See Also

A region of text.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class Region
C#
public class Region
Visual C++
public ref class Region

Remarks

The script for a SQL object is returned as a collection of regions. For example, the SQL script for a table might contain regions for columns, constraints, indexes, foreign keys, and permissions.

Use ToString()()() to view the entire SQL script.

Examples

Viewing the SQL script to create a table.
C# Copy Code
            Database db=new Database();

            db.Register(new ConnectionProperties(".", "WidgetStaging"), Options.Default);

            Work work=new Work();

            //get the script for an object
            Regions regions=work.ScriptObject(db.Tables[0], Options.Default);

            Console.WriteLine("Entire SQL script:\n{0}", regions.ToString());

            Console.WriteLine("By region:\n");

            foreach (Region region in regions)
            {
                Console.WriteLine("***{0}", region.Name);
                Console.WriteLine(region.SQL);
            }

            db.Dispose();
Visual Basic Copy Code
            Dim db As New Database()

            db.Register(New ConnectionProperties(".", "WidgetStaging"), Options.Default)

            Dim work As New Work()

            'get the script for an object

            Dim regions As Regions = work.ScriptObject(db.Tables(0), Options.Default)

            Console.WriteLine("Entire SQL script:")
            Console.WriteLine("{0}", regions.ToString())

            Dim region As Region

            For Each region In regions
                Console.WriteLine("***{0}", region.Name)
                Console.WriteLine(region.SQL)
            Next

            'dispose
            db.Dispose()

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.Region

See Also

Region Members
RedGate.SQLCompare.Engine Namespace


Region Members

[image] [image]

SQL Data Compare API 12.0.40
Region Members
Region Class Constructors Methods Properties See Also

The Region type exposes the following members.

Constructors

Name | Description
Region | Construct a region containing a single sub-region.

Methods

Name | Description
AddGOStatement | Add a GO to the last region written.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | The SQL code that a region contains. (Overrides Object..::.ToString()()().)

Properties

Name | Description
Name | The name of the region.
SQL | The SQL code that a region contains.
SubRegions | The sub-regions contained within this region

See Also

Region Class
RedGate.SQLCompare.Engine Namespace


Region Constructor

[image]

SQL Data Compare API 12.0.40
Region Constructor
Region Class See Also

Construct a region containing a single sub-region.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    sql As String _
)
C#
public Region(
    string name,
    string sql
)
Visual C++
public:
Region(
    String^ name,
    String^ sql
)

Parameters

name
Type: String
sql
Type: String

See Also

Region Class
RedGate.SQLCompare.Engine Namespace


Region Methods

[image] [image]

SQL Data Compare API 12.0.40
Region Methods
Region Class See Also

The Region type exposes the following methods.

Methods

Name | Description
AddGOStatement | Add a GO to the last region written.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | The SQL code that a region contains. (Overrides Object..::.ToString()()().)

See Also

Region Class
RedGate.SQLCompare.Engine Namespace


AddGOStatement Method

[image]

SQL Data Compare API 12.0.40
Region..::.AddGOStatement Method
Region Class See Also

Add a GO to the last region written.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddGOStatement
C#
public void AddGOStatement()
Visual C++
public:
void AddGOStatement()

See Also

Region Class
RedGate.SQLCompare.Engine Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
Region..::.ToString Method
Region Class See Also

The SQL code that a region contains.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

Return Value

SQL code.

See Also

Region Class
RedGate.SQLCompare.Engine Namespace


Region Properties

[image] [image]

SQL Data Compare API 12.0.40
Region Properties
Region Class See Also

The Region type exposes the following properties.

Properties

Name | Description
Name | The name of the region.
SQL | The SQL code that a region contains.
SubRegions | The sub-regions contained within this region

See Also

Region Class
RedGate.SQLCompare.Engine Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
Region..::.Name Property
Region Class See Also

The name of the region.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

Region Class
RedGate.SQLCompare.Engine Namespace


SQL Property

[image]

SQL Data Compare API 12.0.40
Region..::.SQL Property
Region Class See Also

The SQL code that a region contains.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SQL As String
C#
public string SQL { get; }
Visual C++
public:
property String^ SQL {
    String^ get ();
}

See Also

Region Class
RedGate.SQLCompare.Engine Namespace


SubRegions Property

[image]

SQL Data Compare API 12.0.40
Region..::.SubRegions Property
Region Class See Also

The sub-regions contained within this region

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SubRegions As List(Of KeyValuePair(Of String, String))
C#
public List<KeyValuePair<string, string>> SubRegions { get; }
Visual C++
public:
property List<KeyValuePair<String^, String^>>^ SubRegions {
    List<KeyValuePair<String^, String^>>^ get ();
}

See Also

Region Class
RedGate.SQLCompare.Engine Namespace


Regions Class

[image]

SQL Data Compare API 12.0.40
Regions Class
Members See Also

A collection of regions.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class Regions _
    Inherits InnerList(Of Region)
C#
public class Regions : InnerList<Region>
Visual C++
public ref class Regions : public InnerList<Region^>

Remarks

Use the ToString() method to return the text that the regions represent.

See Region for more information and code samples.

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( T >)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( Region >)>)
RedGate.SQLCompare.Engine..::.Regions

See Also

Regions Members
RedGate.SQLCompare.Engine Namespace


Regions Members

[image] [image]

SQL Data Compare API 12.0.40
Regions Members
Regions Class Constructors Methods Properties Explicit Interface Implementations See Also

The Regions type exposes the following members.

Constructors

Name | Description
Regions |

Methods

Name | Description
Contains | (Inherited from InnerList<(Of <(T>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | The SQL script that a collection of regions contains. (Overrides Object..::.ToString()()().)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
WriteToStream | Writes the region to the specified stream.

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | (Inherited from InnerList<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Regions Class
RedGate.SQLCompare.Engine Namespace


Regions Constructor

[image]

SQL Data Compare API 12.0.40
Regions Constructor
Regions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Regions()
Visual C++
public:
Regions()

See Also

Regions Class
RedGate.SQLCompare.Engine Namespace


Regions Methods

[image] [image]

SQL Data Compare API 12.0.40
Regions Methods
Regions Class See Also

The Regions type exposes the following methods.

Methods

Name | Description
Contains | (Inherited from InnerList<(Of <(T>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | The SQL script that a collection of regions contains. (Overrides Object..::.ToString()()().)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
WriteToStream | Writes the region to the specified stream.

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Regions Class
RedGate.SQLCompare.Engine Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
Regions..::.ToString Method
Regions Class See Also

The SQL script that a collection of regions contains.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

Return Value

SQL script.

See Also

Regions Class
RedGate.SQLCompare.Engine Namespace


WriteToStream Method

[image]

SQL Data Compare API 12.0.40
Regions..::.WriteToStream Method
Regions Class See Also

Writes the region to the specified stream.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteToStream ( _
    sw As TextWriter _
)
C#
public void WriteToStream(
    TextWriter sw
)
Visual C++
public:
void WriteToStream(
    TextWriter^ sw
)

Parameters

sw
Type: TextWriter
The stream where the regions are to be written to.

See Also

Regions Class
RedGate.SQLCompare.Engine Namespace


RelationalIndex Class

[image]

SQL Data Compare API 12.0.40
RelationalIndex Class
Members See Also

A relational index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RelationalIndex _
    Inherits Index _
    Implements IShouldWriteStorageSettings, IDatabaseObject, ITSqlObject, ICanExistenceCheck
C#
public sealed class RelationalIndex : Index, IShouldWriteStorageSettings,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck
Visual C++
public ref class RelationalIndex sealed : public Index,
    IShouldWriteStorageSettings, IDatabaseObject, ITSqlObject, ICanExistenceCheck

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.Index
RedGate.SQLCompare.Engine..::.RelationalIndex

See Also

RelationalIndex Members
RedGate.SQLCompare.Engine Namespace


RelationalIndex Members

[image] [image]

SQL Data Compare API 12.0.40
RelationalIndex Members
RelationalIndex Class Constructors Methods Properties Explicit Interface Implementations See Also

The RelationalIndex type exposes the following members.

Constructors

Name | Description
RelationalIndex |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FieldsCompareWith | (Inherited from Index.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowPageLocks | True if the index allows page locks. (Inherited from Index.)
AllowRowLocks | True if the index allows row locks. (Inherited from Index.)
Clustered | True if the index is clustered.
Columnstore | True if the index is a columnstore index
Database | The database to which the index belongs. (Inherited from Index.)
DataCompressionPartitions | The partitions on which the table compression is set. This is a SQL Server 2008 feature.
DataCompressionPartitionsInternal | The partitions on which the table compression is set. This is a SQL Server 2008 feature. The internal version gives you direct access to the list that is stored. If there is no important information in the list it is not stored!
Fields | The fields in the index. (Inherited from Index.)
FileGroup | Obsolete. (Inherited from Index.)
FileGroupOrPartitionScheme | The filegroup or the partition scheme on which the index is defined. (Inherited from Index.)
FilestreamFileGroup | The filegroup or partition scheme containing filestream data.
FillFactor | The fill factor. (Inherited from Index.)
Filter | The filtering condition on the index. This property exists in SQL Server 2008 and later.
FullScan | True if the index is defined with FullScan (Inherited from Index.)
FullyQualifiedName | Obsolete. The fully-qualified name of the index. DANGER WILL ROBINSON!! This is not escaped. (Inherited from Index.)
HashBucketCount |
HashIndex |
IgnoreDuplicateKeys | True if set to ignore duplicate keys. (Inherited from Index.)
Incremental | True if incremental (introduced in SQL Server 2014) (Inherited from Index.)
IsColumnstore | Stupid columnstore indexes mark all of their fields as included but use the normal syntax to list them. (http://msdn.microsoft.com/en-us/library/ms175105.aspx) (Inherited from Index.)
IsDisabled | Indicates whether the index is disabled. (Inherited from Index.)
IsKeyIndexForFullTextIndex | True if the index is used in a full-text key.
IsPartitioned | Indicates whether the index is built on a partition scheme. If it is, the name of the partition scheme is returned by the FileGroupOrPartitionScheme property. (Inherited from Index.)
Name | The name of the index. DANGER WILL ROBINSON!! This is not escaped. Do you mean Index..::.QualifiedName? (Inherited from Index.)
NoRecompute | True if the index is defined with NORECOMPUTE. (Inherited from Index.)
ObjectType | Returns ObjectType.Index (Inherited from Index.)
Online | True iff the index is to be created online. (Inherited from Index.)
Owner | The owner of the index's table. (Inherited from Index.)
Pad | The index padding. (Inherited from Index.)
PartitionedField | Indicates the field over which the index is partitioned. This is a SQL Server 2005 feature.
PrimaryKey |
QualifiedName | The qualified name of the object. Do you mean Index..::.Name? (Inherited from Index.)
Relational | True if this is a relational index. (Inherited from Index.)
ScriptSource | The location of the creation script for this object if the database source is set to scripts folder. (Inherited from Index.)
ShouldWriteFileGroupOrPartitionScheme | Not for external use - will be obsolteted when more similar options can be encapsulated in a class together.
SortInTempDb | True iff the index is to be created using tempdb. (Inherited from Index.)
Spatial | True if the index is a spatial index. (Inherited from Index.)
SpatialIndexInformation | Obsolete. (Inherited from Index.)
Statistics | True if the index is a statistic. (Inherited from Index.)
SysobjectID | The sysobject identier of the object. (Inherited from Index.)
SystemNamed | (Inherited from Index.)
Unique | True if the index is unique.
UniqueConstraint | True if the index is a unique constraint.
WriteFileGroupOrPartitionScheme | Whether (disregarding any options) the filegroup should be written out (Inherited from Index.)
Xml | True if the index is an XML index. (Inherited from Index.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith | (Inherited from Index.)
IDatabaseObject..::.Equals | (Inherited from Index.)

See Also

RelationalIndex Class
RedGate.SQLCompare.Engine Namespace


RelationalIndex Constructor

[image]

SQL Data Compare API 12.0.40
RelationalIndex Constructor
RelationalIndex Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    index As RelationalIndex, _
    newParent As Table _
)
C#
public RelationalIndex(
    RelationalIndex index,
    Table newParent
)
Visual C++
public:
RelationalIndex(
    RelationalIndex^ index,
    Table^ newParent
)

Parameters

index
Type: RedGate.SQLCompare.Engine..::.RelationalIndex
newParent
Type: RedGate.SQLCompare.Engine..::.Table

See Also

RelationalIndex Class
RedGate.SQLCompare.Engine Namespace


RelationalIndex Properties

[image] [image]

SQL Data Compare API 12.0.40
RelationalIndex Properties
RelationalIndex Class See Also

The RelationalIndex type exposes the following properties.

Properties

Name | Description
AllowPageLocks | True if the index allows page locks. (Inherited from Index.)
AllowRowLocks | True if the index allows row locks. (Inherited from Index.)
Clustered | True if the index is clustered.
Columnstore | True if the index is a columnstore index
Database | The database to which the index belongs. (Inherited from Index.)
DataCompressionPartitions | The partitions on which the table compression is set. This is a SQL Server 2008 feature.
DataCompressionPartitionsInternal | The partitions on which the table compression is set. This is a SQL Server 2008 feature. The internal version gives you direct access to the list that is stored. If there is no important information in the list it is not stored!
Fields | The fields in the index. (Inherited from Index.)
FileGroup | Obsolete. (Inherited from Index.)
FileGroupOrPartitionScheme | The filegroup or the partition scheme on which the index is defined. (Inherited from Index.)
FilestreamFileGroup | The filegroup or partition scheme containing filestream data.
FillFactor | The fill factor. (Inherited from Index.)
Filter | The filtering condition on the index. This property exists in SQL Server 2008 and later.
FullScan | True if the index is defined with FullScan (Inherited from Index.)
FullyQualifiedName | Obsolete. The fully-qualified name of the index. DANGER WILL ROBINSON!! This is not escaped. (Inherited from Index.)
HashBucketCount |
HashIndex |
IgnoreDuplicateKeys | True if set to ignore duplicate keys. (Inherited from Index.)
Incremental | True if incremental (introduced in SQL Server 2014) (Inherited from Index.)
IsColumnstore | Stupid columnstore indexes mark all of their fields as included but use the normal syntax to list them. (http://msdn.microsoft.com/en-us/library/ms175105.aspx) (Inherited from Index.)
IsDisabled | Indicates whether the index is disabled. (Inherited from Index.)
IsKeyIndexForFullTextIndex | True if the index is used in a full-text key.
IsPartitioned | Indicates whether the index is built on a partition scheme. If it is, the name of the partition scheme is returned by the FileGroupOrPartitionScheme property. (Inherited from Index.)
Name | The name of the index. DANGER WILL ROBINSON!! This is not escaped. Do you mean Index..::.QualifiedName? (Inherited from Index.)
NoRecompute | True if the index is defined with NORECOMPUTE. (Inherited from Index.)
ObjectType | Returns ObjectType.Index (Inherited from Index.)
Online | True iff the index is to be created online. (Inherited from Index.)
Owner | The owner of the index's table. (Inherited from Index.)
Pad | The index padding. (Inherited from Index.)
PartitionedField | Indicates the field over which the index is partitioned. This is a SQL Server 2005 feature.
PrimaryKey |
QualifiedName | The qualified name of the object. Do you mean Index..::.Name? (Inherited from Index.)
Relational | True if this is a relational index. (Inherited from Index.)
ScriptSource | The location of the creation script for this object if the database source is set to scripts folder. (Inherited from Index.)
ShouldWriteFileGroupOrPartitionScheme | Not for external use - will be obsolteted when more similar options can be encapsulated in a class together.
SortInTempDb | True iff the index is to be created using tempdb. (Inherited from Index.)
Spatial | True if the index is a spatial index. (Inherited from Index.)
SpatialIndexInformation | Obsolete. (Inherited from Index.)
Statistics | True if the index is a statistic. (Inherited from Index.)
SysobjectID | The sysobject identier of the object. (Inherited from Index.)
SystemNamed | (Inherited from Index.)
Unique | True if the index is unique.
UniqueConstraint | True if the index is a unique constraint.
WriteFileGroupOrPartitionScheme | Whether (disregarding any options) the filegroup should be written out (Inherited from Index.)
Xml | True if the index is an XML index. (Inherited from Index.)

See Also

RelationalIndex Class
RedGate.SQLCompare.Engine Namespace


Clustered Property

[image]

SQL Data Compare API 12.0.40
RelationalIndex..::.Clustered Property
RelationalIndex Class See Also

True if the index is clustered.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Clustered As Boolean
C#
public bool Clustered { get; internal set; }
Visual C++
public:
property bool Clustered {
    bool get ();
    void set (bool value);
}

See Also

RelationalIndex Class
RedGate.SQLCompare.Engine Namespace


Columnstore Property

[image]

SQL Data Compare API 12.0.40
RelationalIndex..::.Columnstore Property
RelationalIndex Class See Also

True if the index is a columnstore index

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Columnstore As Boolean
C#
public bool Columnstore { get; internal set; }
Visual C++
public:
property bool Columnstore {
    bool get ();
    void set (bool value);
}

See Also

RelationalIndex Class
RedGate.SQLCompare.Engine Namespace


DataCompressionPartitions Property

[image]

SQL Data Compare API 12.0.40
RelationalIndex..::.DataCompressionPartitions Property
RelationalIndex Class See Also

The partitions on which the table compression is set. This is a SQL Server 2008 feature.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataCompressionPartitions As IDictionary(Of Integer, DataCompression)
C#
public IDictionary<int, DataCompression> DataCompressionPartitions { get; }
Visual C++
public:
virtual property IDictionary<int, DataCompression>^ DataCompressionPartitions {
    IDictionary<int, DataCompression>^ get () sealed;
}

See Also

RelationalIndex Class
RedGate.SQLCompare.Engine Namespace


DataCompressionPartitionsInternal Property

[image]

SQL Data Compare API 12.0.40
RelationalIndex..::.DataCompressionPartitionsInternal Property
RelationalIndex Class See Also

The partitions on which the table compression is set. This is a SQL Server 2008 feature. The internal version gives you direct access to the list that is stored. If there is no important information in the list it is not stored!

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DataCompressionPartitionsInternal As DataCompressionPartitions
C#
public DataCompressionPartitions DataCompressionPartitionsInternal { get; set; }
Visual C++
public:
virtual property DataCompressionPartitions^ DataCompressionPartitionsInternal {
    DataCompressionPartitions^ get () sealed;
    void set (DataCompressionPartitions^ value) sealed;
}

See Also

RelationalIndex Class
RedGate.SQLCompare.Engine Namespace


FilestreamFileGroup Property

[image]

SQL Data Compare API 12.0.40
RelationalIndex..::.FilestreamFileGroup Property
RelationalIndex Class See Also

The filegroup or partition scheme containing filestream data.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FilestreamFileGroup As String
C#
public string FilestreamFileGroup { get; internal set; }
Visual C++
public:
property String^ FilestreamFileGroup {
    String^ get ();
    void set (String^ value);
}

See Also

RelationalIndex Class
RedGate.SQLCompare.Engine Namespace


Filter Property

[image]

SQL Data Compare API 12.0.40
RelationalIndex..::.Filter Property
RelationalIndex Class See Also

The filtering condition on the index. This property exists in SQL Server 2008 and later.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Filter As String
C#
public string Filter { get; internal set; }
Visual C++
public:
property String^ Filter {
    String^ get ();
    void set (String^ value);
}

See Also

RelationalIndex Class
RedGate.SQLCompare.Engine Namespace


HashBucketCount Property

[image]

SQL Data Compare API 12.0.40
RelationalIndex..::.HashBucketCount Property
RelationalIndex Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property HashBucketCount As Integer
C#
public int HashBucketCount { get; internal set; }
Visual C++
public:
property int HashBucketCount {
    int get ();
    void set (int value);
}

See Also

RelationalIndex Class
RedGate.SQLCompare.Engine Namespace


HashIndex Property

[image]

SQL Data Compare API 12.0.40
RelationalIndex..::.HashIndex Property
RelationalIndex Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property HashIndex As Boolean
C#
public bool HashIndex { get; internal set; }
Visual C++
public:
property bool HashIndex {
    bool get ();
    void set (bool value);
}

See Also

RelationalIndex Class
RedGate.SQLCompare.Engine Namespace


IsKeyIndexForFullTextIndex Property

[image]

SQL Data Compare API 12.0.40
RelationalIndex..::.IsKeyIndexForFullTextIndex Property
RelationalIndex Class See Also

True if the index is used in a full-text key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsKeyIndexForFullTextIndex As Boolean
C#
public bool IsKeyIndexForFullTextIndex { get; internal set; }
Visual C++
public:
property bool IsKeyIndexForFullTextIndex {
    bool get ();
    void set (bool value);
}

See Also

RelationalIndex Class
RedGate.SQLCompare.Engine Namespace


PartitionedField Property

[image]

SQL Data Compare API 12.0.40
RelationalIndex..::.PartitionedField Property
RelationalIndex Class See Also

Indicates the field over which the index is partitioned. This is a SQL Server 2005 feature.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PartitionedField As IndexField
C#
public IndexField PartitionedField { get; internal set; }
Visual C++
public:
property IndexField^ PartitionedField {
    IndexField^ get ();
    void set (IndexField^ value);
}

See Also

RelationalIndex Class
RedGate.SQLCompare.Engine Namespace


PrimaryKey Property

[image]

SQL Data Compare API 12.0.40
RelationalIndex..::.PrimaryKey Property
RelationalIndex Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PrimaryKey As Boolean
C#
public bool PrimaryKey { get; internal set; }
Visual C++
public:
property bool PrimaryKey {
    bool get ();
    void set (bool value);
}

See Also

RelationalIndex Class
RedGate.SQLCompare.Engine Namespace


ShouldWriteFileGroupOrPartitionScheme Property

[image]

SQL Data Compare API 12.0.40
RelationalIndex..::.ShouldWriteFileGroupOrPartitionScheme Property
RelationalIndex Class See Also

Not for external use - will be obsolteted when more similar options can be encapsulated in a class together.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ShouldWriteFileGroupOrPartitionScheme As Boolean
C#
public bool ShouldWriteFileGroupOrPartitionScheme { get; }
Visual C++
public:
virtual property bool ShouldWriteFileGroupOrPartitionScheme {
    bool get () sealed;
}

Implements

IShouldWriteStorageSettings..::.ShouldWriteFileGroupOrPartitionScheme

See Also

RelationalIndex Class
RedGate.SQLCompare.Engine Namespace


Unique Property

[image]

SQL Data Compare API 12.0.40
RelationalIndex..::.Unique Property
RelationalIndex Class See Also

True if the index is unique.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Unique As Boolean
C#
public bool Unique { get; internal set; }
Visual C++
public:
property bool Unique {
    bool get ();
    void set (bool value);
}

See Also

RelationalIndex Class
RedGate.SQLCompare.Engine Namespace


UniqueConstraint Property

[image]

SQL Data Compare API 12.0.40
RelationalIndex..::.UniqueConstraint Property
RelationalIndex Class See Also

True if the index is a unique constraint.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UniqueConstraint As Boolean
C#
public bool UniqueConstraint { get; internal set; }
Visual C++
public:
property bool UniqueConstraint {
    bool get ();
    void set (bool value);
}

See Also

RelationalIndex Class
RedGate.SQLCompare.Engine Namespace


RemoteDataArchiveState Enumeration

[image]

SQL Data Compare API 12.0.40
RemoteDataArchiveState Enumeration
See Also

The Stretch Database state of a table

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration RemoteDataArchiveState
C#
public enum RemoteDataArchiveState
Visual C++
public enum class RemoteDataArchiveState

Members

Member name | Description
Disabled | REMOTE_DATA_ARCHIVE is disabled
Enabled | REMOTE_DATA_ARCHIVE is enabled with MIGRATION_STATE = PAUSED (so stretch data can be queried but is not being actively archived)
EnabledWithMigration | REMOTE_DATA_ARCHIVE is enabled with MIGRATION_STATE = OUTBOUND (so stretch data is being actively archived)

See Also

RedGate.SQLCompare.Engine Namespace


Role Class

[image]

SQL Data Compare API 12.0.40
Role Class
Members See Also

A role.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Role _
    Inherits DatabaseObjectWithAuthorizationAndExtendedProperties _
    Implements IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck,  _
    IOwner, IIsSystemObject, IPatchUpAfterDeserialization, ISqlComparable
C#
public sealed class Role : DatabaseObjectWithAuthorizationAndExtendedProperties, IHasPermissions,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, IOwner, IIsSystemObject,
    IPatchUpAfterDeserialization, ISqlComparable
Visual C++
public ref class Role sealed : public DatabaseObjectWithAuthorizationAndExtendedProperties,
    IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck, IOwner,
    IIsSystemObject, IPatchUpAfterDeserialization, ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorizationAndExtendedProperties
RedGate.SQLCompare.Engine..::.Role

See Also

Role Members
RedGate.SQLCompare.Engine Namespace


Role Members

[image] [image]

SQL Data Compare API 12.0.40
Role Members
Role Class Methods Fields Properties Explicit Interface Implementations See Also

The Role type exposes the following members.

Methods

Name | Description
CompareWith |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AlterAuthorizationClassType | (Overrides DatabaseObjectWithAuthorization ..::. AlterAuthorizationClassType.)
AppRole | True if the role is an application role.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
DatabaseLevelPermissions | Access to the role's database-level permissions.
DefaultSchema | The default schema for the application role. If the role is not an application role the value for the default schema is null.
ExtendedProperties | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
FullyQualifiedName | The fully-qualified name of the role. DANGER WILL ROBINSON!! This is not escaped. (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
IsSystemObject |
Members | The users in the role.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Role (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

Role Class
RedGate.SQLCompare.Engine Namespace


Role Methods

[image] [image]

SQL Data Compare API 12.0.40
Role Methods
Role Class See Also

The Role type exposes the following methods.

Methods

Name | Description
CompareWith |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

Role Class
RedGate.SQLCompare.Engine Namespace


CompareWith Method

[image]

SQL Data Compare API 12.0.40
Role..::.CompareWith Method
Role Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareWith ( _
    target As Role, _
    options As Options _
) As IEnumerable(Of EqualityDifference)
C#
public IEnumerable<EqualityDifference> CompareWith(
    Role target,
    Options options
)
Visual C++
public:
IEnumerable<EqualityDifference^>^ CompareWith(
    Role^ target,
    Options options
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.Role
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

Role Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
Role..::.ISqlComparable..::.CompareWith Method
Role Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    obj As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable obj,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ obj,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

obj
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

Role Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
Role..::.Equals Method
Role Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the role with a specified role. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

Role Class
Role Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
Role..::.Equals Method (IDatabaseObject, Options)
Role Class See Also

Compares the role with a specified role.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) override

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The role to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the roles are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

Role Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
Role..::.PatchUpAfterDeserialization Method
Role Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

Role Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
Role..::.ScriptObject Method
Role Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

Role Class
RedGate.SQLCompare.Engine Namespace


Role Properties

[image] [image]

SQL Data Compare API 12.0.40
Role Properties
Role Class See Also

The Role type exposes the following properties.

Properties

Name | Description
AlterAuthorizationClassType | (Overrides DatabaseObjectWithAuthorization ..::. AlterAuthorizationClassType.)
AppRole | True if the role is an application role.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
DatabaseLevelPermissions | Access to the role's database-level permissions.
DefaultSchema | The default schema for the application role. If the role is not an application role the value for the default schema is null.
ExtendedProperties | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
FullyQualifiedName | The fully-qualified name of the role. DANGER WILL ROBINSON!! This is not escaped. (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
IsSystemObject |
Members | The users in the role.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Role (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)

See Also

Role Class
RedGate.SQLCompare.Engine Namespace


AlterAuthorizationClassType Property

[image]

SQL Data Compare API 12.0.40
Role..::.AlterAuthorizationClassType Property
Role Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property AlterAuthorizationClassType As String
C#
public override string AlterAuthorizationClassType { get; }
Visual C++
public:
virtual property String^ AlterAuthorizationClassType {
    String^ get () override;
}

Implements

IHasAuthorization..::.AlterAuthorizationClassType

See Also

Role Class
RedGate.SQLCompare.Engine Namespace


AppRole Property

[image]

SQL Data Compare API 12.0.40
Role..::.AppRole Property
Role Class See Also

True if the role is an application role.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AppRole As Boolean
C#
public bool AppRole { get; internal set; }
Visual C++
public:
property bool AppRole {
    bool get ();
    void set (bool value);
}

See Also

Role Class
RedGate.SQLCompare.Engine Namespace


DatabaseLevelPermissions Property

[image]

SQL Data Compare API 12.0.40
Role..::.DatabaseLevelPermissions Property
Role Class See Also

Access to the role's database-level permissions.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DatabaseLevelPermissions As DatabaseLevelPermissions
C#
public DatabaseLevelPermissions DatabaseLevelPermissions { get; }
Visual C++
public:
property DatabaseLevelPermissions^ DatabaseLevelPermissions {
    DatabaseLevelPermissions^ get ();
}

See Also

Role Class
RedGate.SQLCompare.Engine Namespace


DefaultSchema Property

[image]

SQL Data Compare API 12.0.40
Role..::.DefaultSchema Property
Role Class See Also

The default schema for the application role. If the role is not an application role the value for the default schema is null.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DefaultSchema As String
C#
public string DefaultSchema { get; }
Visual C++
public:
property String^ DefaultSchema {
    String^ get ();
}

See Also

Role Class
RedGate.SQLCompare.Engine Namespace


FullyQualifiedName Property

[image]

SQL Data Compare API 12.0.40
Role..::.FullyQualifiedName Property
Role Class See Also

The fully-qualified name of the role. DANGER WILL ROBINSON!! This is not escaped.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FullyQualifiedName As String
C#
public override string FullyQualifiedName { get; }
Visual C++
public:
virtual property String^ FullyQualifiedName {
    String^ get () override;
}

Implements

ITSqlObjectFullyQualifiedName()()()
ITSqlObjectFullyQualifiedName()()()

See Also

Role Class
RedGate.SQLCompare.Engine Namespace


IsSystemObject Property

[image]

SQL Data Compare API 12.0.40
Role..::.IsSystemObject Property
Role Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSystemObject As Boolean
C#
public bool IsSystemObject { get; }
Visual C++
public:
virtual property bool IsSystemObject {
    bool get () sealed;
}

Implements

IIsSystemObject..::.IsSystemObject

See Also

Role Class
RedGate.SQLCompare.Engine Namespace


Members Property

[image]

SQL Data Compare API 12.0.40
Role..::.Members Property
Role Class See Also

The users in the role.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Members As Members
C#
public Members Members { get; private set; }
Visual C++
public:
property Members^ Members {
    Members^ get ();
    void set (Members^ value);
}

See Also

Role Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
Role..::.ObjectType Property
Role Class See Also

Returns ObjectType.Role

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()
ITSqlObjectObjectType()()()

See Also

Role Class
RedGate.SQLCompare.Engine Namespace


Roles Class

[image]

SQL Data Compare API 12.0.40
Roles Class
Members See Also

A collection of roles.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Roles _
    Inherits SerializableDatabaseObjectCollection(Of Role) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class Roles : SerializableDatabaseObjectCollection<Role>, IPatchUpAfterDeserialization
Visual C++
public ref class Roles sealed : public SerializableDatabaseObjectCollection<Role^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Role >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( Role >)>)
RedGate.SQLCompare.Engine..::.Roles

See Also

Roles Members
RedGate.SQLCompare.Engine Namespace


Roles Members

[image] [image]

SQL Data Compare API 12.0.40
Roles Members
Roles Class Methods Fields Properties Explicit Interface Implementations See Also

The Roles type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

Roles Class
RedGate.SQLCompare.Engine Namespace


Roles Methods

[image] [image]

SQL Data Compare API 12.0.40
Roles Methods
Roles Class See Also

The Roles type exposes the following methods.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

Roles Class
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
Roles..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
Roles Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

Roles Class
RedGate.SQLCompare.Engine Namespace


RolesChanges Class

[image]

SQL Data Compare API 12.0.40
RolesChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RolesChanges
C#
public sealed class RolesChanges
Visual C++
public ref class RolesChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.RolesChanges

See Also

RolesChanges Members
RedGate.SQLCompare.Engine Namespace


RolesChanges Members

[image] [image]

SQL Data Compare API 12.0.40
RolesChanges Members
RolesChanges Class Constructors Methods Properties See Also

The RolesChanges type exposes the following members.

Constructors

Name | Description
RolesChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
RolesToAlter |
RolesToCreate |
RolesToDrop |
RoleTargets |

See Also

RolesChanges Class
RedGate.SQLCompare.Engine Namespace


RolesChanges Constructor

[image]

SQL Data Compare API 12.0.40
RolesChanges Constructor
RolesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public RolesChanges(
    bool caseSensitive
)
Visual C++
public:
RolesChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

RolesChanges Class
RedGate.SQLCompare.Engine Namespace


RolesChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
RolesChanges Properties
RolesChanges Class See Also

The RolesChanges type exposes the following properties.

Properties

Name | Description
RolesToAlter |
RolesToCreate |
RolesToDrop |
RoleTargets |

See Also

RolesChanges Class
RedGate.SQLCompare.Engine Namespace


RolesToAlter Property

[image]

SQL Data Compare API 12.0.40
RolesChanges..::.RolesToAlter Property
RolesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RolesToAlter As Roles
C#
public Roles RolesToAlter { get; private set; }
Visual C++
public:
property Roles^ RolesToAlter {
    Roles^ get ();
    void set (Roles^ value);
}

See Also

RolesChanges Class
RedGate.SQLCompare.Engine Namespace


RolesToCreate Property

[image]

SQL Data Compare API 12.0.40
RolesChanges..::.RolesToCreate Property
RolesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RolesToCreate As Roles
C#
public Roles RolesToCreate { get; private set; }
Visual C++
public:
property Roles^ RolesToCreate {
    Roles^ get ();
    void set (Roles^ value);
}

See Also

RolesChanges Class
RedGate.SQLCompare.Engine Namespace


RolesToDrop Property

[image]

SQL Data Compare API 12.0.40
RolesChanges..::.RolesToDrop Property
RolesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RolesToDrop As Roles
C#
public Roles RolesToDrop { get; private set; }
Visual C++
public:
property Roles^ RolesToDrop {
    Roles^ get ();
    void set (Roles^ value);
}

See Also

RolesChanges Class
RedGate.SQLCompare.Engine Namespace


RoleTargets Property

[image]

SQL Data Compare API 12.0.40
RolesChanges..::.RoleTargets Property
RolesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RoleTargets As Dictionary(Of Role, Role)
C#
public Dictionary<Role, Role> RoleTargets { get; private set; }
Visual C++
public:
property Dictionary<Role^, Role^>^ RoleTargets {
    Dictionary<Role^, Role^>^ get ();
    void set (Dictionary<Role^, Role^>^ value);
}

See Also

RolesChanges Class
RedGate.SQLCompare.Engine Namespace


Route Class

[image]

SQL Data Compare API 12.0.40
Route Class
Members See Also

A route.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Route _
    Inherits DatabaseObjectWithAuthorizationAndExtendedProperties _
    Implements IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck,  _
    IIsSystemObject, IPatchUpAfterDeserialization, ISqlComparable
C#
public sealed class Route : DatabaseObjectWithAuthorizationAndExtendedProperties, IHasPermissions,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, IIsSystemObject, IPatchUpAfterDeserialization,
    ISqlComparable
Visual C++
public ref class Route sealed : public DatabaseObjectWithAuthorizationAndExtendedProperties,
    IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck, IIsSystemObject,
    IPatchUpAfterDeserialization, ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorizationAndExtendedProperties
RedGate.SQLCompare.Engine..::.Route

See Also

Route Members
RedGate.SQLCompare.Engine Namespace


Route Members

[image] [image]

SQL Data Compare API 12.0.40
Route Members
Route Class Methods Fields Properties Explicit Interface Implementations See Also

The Route type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LifetimesEquivalent |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
RequiresRebuildFrom |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
Address | The address of the route.
AlterAuthorizationClassType | (Overrides DatabaseObjectWithAuthorization ..::. AlterAuthorizationClassType.)
BrokerInstance | The broker instance.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
HasLifeTime | True if the route has a lifetime set.
IsSystemObject | Indicates whether the route is a system object.
Lifetime | The lifetime of the route.
MirrorAddress | The mirror address of the route.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Assembly (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
RemoteServiceName | The name of the remote service.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

Route Class
RedGate.SQLCompare.Engine Namespace


Route Methods

[image] [image]

SQL Data Compare API 12.0.40
Route Methods
Route Class See Also

The Route type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LifetimesEquivalent |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
RequiresRebuildFrom |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

Route Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
Route..::.ISqlComparable..::.CompareWith Method
Route Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    target As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable target,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ target,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

target
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

Route Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
Route..::.Equals Method
Route Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the route with a specified route. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

Route Class
Route Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
Route..::.Equals Method (IDatabaseObject, Options)
Route Class See Also

Compares the route with a specified route.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The route to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the routes are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

Route Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


LifetimesEquivalent Method

[image]

SQL Data Compare API 12.0.40
Route..::.LifetimesEquivalent Method
Route Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function LifetimesEquivalent ( _
    target As Route, _
    referenceTime As DateTime _
) As Boolean
C#
public bool LifetimesEquivalent(
    Route target,
    DateTime referenceTime
)
Visual C++
public:
bool LifetimesEquivalent(
    Route^ target,
    DateTime referenceTime
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.Route
referenceTime
Type: DateTime

See Also

Route Class
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
Route..::.PatchUpAfterDeserialization Method
Route Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

Route Class
RedGate.SQLCompare.Engine Namespace


RequiresRebuildFrom Method

[image]

SQL Data Compare API 12.0.40
Route..::.RequiresRebuildFrom Method
Route Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function RequiresRebuildFrom ( _
    fromRoute As Route _
) As Boolean
C#
public bool RequiresRebuildFrom(
    Route fromRoute
)
Visual C++
public:
bool RequiresRebuildFrom(
    Route^ fromRoute
)

Parameters

fromRoute
Type: RedGate.SQLCompare.Engine..::.Route

See Also

Route Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
Route..::.ScriptObject Method
Route Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

Route Class
RedGate.SQLCompare.Engine Namespace


Route Properties

[image] [image]

SQL Data Compare API 12.0.40
Route Properties
Route Class See Also

The Route type exposes the following properties.

Properties

Name | Description
Address | The address of the route.
AlterAuthorizationClassType | (Overrides DatabaseObjectWithAuthorization ..::. AlterAuthorizationClassType.)
BrokerInstance | The broker instance.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
HasLifeTime | True if the route has a lifetime set.
IsSystemObject | Indicates whether the route is a system object.
Lifetime | The lifetime of the route.
MirrorAddress | The mirror address of the route.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Assembly (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
RemoteServiceName | The name of the remote service.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)

See Also

Route Class
RedGate.SQLCompare.Engine Namespace


Address Property

[image]

SQL Data Compare API 12.0.40
Route..::.Address Property
Route Class See Also

The address of the route.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Address As String
C#
public string Address { get; internal set; }
Visual C++
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}

See Also

Route Class
RedGate.SQLCompare.Engine Namespace


AlterAuthorizationClassType Property

[image]

SQL Data Compare API 12.0.40
Route..::.AlterAuthorizationClassType Property
Route Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property AlterAuthorizationClassType As String
C#
public override string AlterAuthorizationClassType { get; }
Visual C++
public:
virtual property String^ AlterAuthorizationClassType {
    String^ get () override;
}

Implements

IHasAuthorization..::.AlterAuthorizationClassType

See Also

Route Class
RedGate.SQLCompare.Engine Namespace


BrokerInstance Property

[image]

SQL Data Compare API 12.0.40
Route..::.BrokerInstance Property
Route Class See Also

The broker instance.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BrokerInstance As String
C#
public string BrokerInstance { get; internal set; }
Visual C++
public:
property String^ BrokerInstance {
    String^ get ();
    void set (String^ value);
}

See Also

Route Class
RedGate.SQLCompare.Engine Namespace


HasLifeTime Property

[image]

SQL Data Compare API 12.0.40
Route..::.HasLifeTime Property
Route Class See Also

True if the route has a lifetime set.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property HasLifeTime As Boolean
C#
public bool HasLifeTime { get; internal set; }
Visual C++
public:
property bool HasLifeTime {
    bool get ();
    void set (bool value);
}

See Also

Route Class
RedGate.SQLCompare.Engine Namespace


IsSystemObject Property

[image]

SQL Data Compare API 12.0.40
Route..::.IsSystemObject Property
Route Class See Also

Indicates whether the route is a system object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSystemObject As Boolean
C#
public bool IsSystemObject { get; private set; }
Visual C++
public:
virtual property bool IsSystemObject {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IIsSystemObject..::.IsSystemObject

See Also

Route Class
RedGate.SQLCompare.Engine Namespace


Lifetime Property

[image]

SQL Data Compare API 12.0.40
Route..::.Lifetime Property
Route Class See Also

The lifetime of the route.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Lifetime As DateTime
C#
public DateTime Lifetime { get; internal set; }
Visual C++
public:
property DateTime Lifetime {
    DateTime get ();
    void set (DateTime value);
}

See Also

Route Class
RedGate.SQLCompare.Engine Namespace


MirrorAddress Property

[image]

SQL Data Compare API 12.0.40
Route..::.MirrorAddress Property
Route Class See Also

The mirror address of the route.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property MirrorAddress As String
C#
public string MirrorAddress { get; internal set; }
Visual C++
public:
property String^ MirrorAddress {
    String^ get ();
    void set (String^ value);
}

See Also

Route Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
Route..::.ObjectType Property
Route Class See Also

Returns ObjectType.Assembly

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()
ITSqlObjectObjectType()()()

See Also

Route Class
RedGate.SQLCompare.Engine Namespace


RemoteServiceName Property

[image]

SQL Data Compare API 12.0.40
Route..::.RemoteServiceName Property
Route Class See Also

The name of the remote service.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RemoteServiceName As String
C#
public string RemoteServiceName { get; internal set; }
Visual C++
public:
property String^ RemoteServiceName {
    String^ get ();
    void set (String^ value);
}

See Also

Route Class
RedGate.SQLCompare.Engine Namespace


Routes Class

[image]

SQL Data Compare API 12.0.40
Routes Class
Members See Also

A collection of routes.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Routes _
    Inherits SerializableDatabaseObjectCollection(Of Route) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class Routes : SerializableDatabaseObjectCollection<Route>, IPatchUpAfterDeserialization
Visual C++
public ref class Routes sealed : public SerializableDatabaseObjectCollection<Route^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Route >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( Route >)>)
RedGate.SQLCompare.Engine..::.Routes

See Also

Routes Members
RedGate.SQLCompare.Engine Namespace


Routes Members

[image] [image]

SQL Data Compare API 12.0.40
Routes Members
Routes Class Methods Fields Properties Explicit Interface Implementations See Also

The Routes type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

Routes Class
RedGate.SQLCompare.Engine Namespace


Routes Methods

[image] [image]

SQL Data Compare API 12.0.40
Routes Methods
Routes Class See Also

The Routes type exposes the following methods.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

Routes Class
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
Routes..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
Routes Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

Routes Class
RedGate.SQLCompare.Engine Namespace


RoutesChanges Class

[image]

SQL Data Compare API 12.0.40
RoutesChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RoutesChanges
C#
public sealed class RoutesChanges
Visual C++
public ref class RoutesChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.RoutesChanges

See Also

RoutesChanges Members
RedGate.SQLCompare.Engine Namespace


RoutesChanges Members

[image] [image]

SQL Data Compare API 12.0.40
RoutesChanges Members
RoutesChanges Class Constructors Methods Properties See Also

The RoutesChanges type exposes the following members.

Constructors

Name | Description
RoutesChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
RoutesToAlter |
RoutesToCreate |
RoutesToDrop |
RouteTargets |

See Also

RoutesChanges Class
RedGate.SQLCompare.Engine Namespace


RoutesChanges Constructor

[image]

SQL Data Compare API 12.0.40
RoutesChanges Constructor
RoutesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public RoutesChanges(
    bool caseSensitive
)
Visual C++
public:
RoutesChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

RoutesChanges Class
RedGate.SQLCompare.Engine Namespace


RoutesChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
RoutesChanges Properties
RoutesChanges Class See Also

The RoutesChanges type exposes the following properties.

Properties

Name | Description
RoutesToAlter |
RoutesToCreate |
RoutesToDrop |
RouteTargets |

See Also

RoutesChanges Class
RedGate.SQLCompare.Engine Namespace


RoutesToAlter Property

[image]

SQL Data Compare API 12.0.40
RoutesChanges..::.RoutesToAlter Property
RoutesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RoutesToAlter As Routes
C#
public Routes RoutesToAlter { get; private set; }
Visual C++
public:
property Routes^ RoutesToAlter {
    Routes^ get ();
    void set (Routes^ value);
}

See Also

RoutesChanges Class
RedGate.SQLCompare.Engine Namespace


RoutesToCreate Property

[image]

SQL Data Compare API 12.0.40
RoutesChanges..::.RoutesToCreate Property
RoutesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RoutesToCreate As Routes
C#
public Routes RoutesToCreate { get; private set; }
Visual C++
public:
property Routes^ RoutesToCreate {
    Routes^ get ();
    void set (Routes^ value);
}

See Also

RoutesChanges Class
RedGate.SQLCompare.Engine Namespace


RoutesToDrop Property

[image]

SQL Data Compare API 12.0.40
RoutesChanges..::.RoutesToDrop Property
RoutesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RoutesToDrop As Routes
C#
public Routes RoutesToDrop { get; private set; }
Visual C++
public:
property Routes^ RoutesToDrop {
    Routes^ get ();
    void set (Routes^ value);
}

See Also

RoutesChanges Class
RedGate.SQLCompare.Engine Namespace


RouteTargets Property

[image]

SQL Data Compare API 12.0.40
RoutesChanges..::.RouteTargets Property
RoutesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RouteTargets As Dictionary(Of Route, Route)
C#
public Dictionary<Route, Route> RouteTargets { get; private set; }
Visual C++
public:
property Dictionary<Route^, Route^>^ RouteTargets {
    Dictionary<Route^, Route^>^ get ();
    void set (Dictionary<Route^, Route^>^ value);
}

See Also

RoutesChanges Class
RedGate.SQLCompare.Engine Namespace


Rule Class

[image]

SQL Data Compare API 12.0.40
Rule Class
Members See Also

A rule.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Rule _
    Inherits SchemaObject _
    Implements IDatabaseObject, ITSqlObject, ICanExistenceCheck, ITextObject,  _
    IPatchUpAfterDeserialization, ISqlComparable
C#
public sealed class Rule : SchemaObject, IDatabaseObject,
    ITSqlObject, ICanExistenceCheck, ITextObject, IPatchUpAfterDeserialization, ISqlComparable
Visual C++
public ref class Rule sealed : public SchemaObject,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, ITextObject, IPatchUpAfterDeserialization,
    ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.Rule

See Also

Rule Members
RedGate.SQLCompare.Engine Namespace


Rule Members

[image] [image]

SQL Data Compare API 12.0.40
Rule Members
Rule Class Methods Fields Properties Explicit Interface Implementations See Also

The Rule type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | (Overrides SchemaObject ..::. ToString()()().)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Rule (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSources | (Inherited from SchemaObject.)
Text | The text of the rule.

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

Rule Class
RedGate.SQLCompare.Engine Namespace


Rule Methods

[image] [image]

SQL Data Compare API 12.0.40
Rule Methods
Rule Class See Also

The Rule type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | (Overrides SchemaObject ..::. ToString()()().)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

Rule Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
Rule..::.ISqlComparable..::.CompareWith Method
Rule Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    target As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable target,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ target,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

target
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

Rule Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
Rule..::.Equals Method
Rule Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the rule with a specified rule. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

Rule Class
Rule Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
Rule..::.Equals Method (IDatabaseObject, Options)
Rule Class See Also

Compares the rule with a specified rule.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) override

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The rule to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the rules are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

Rule Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
Rule..::.PatchUpAfterDeserialization Method
Rule Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

Rule Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
Rule..::.ScriptObject Method
Rule Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

Rule Class
RedGate.SQLCompare.Engine Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
Rule..::.ToString Method
Rule Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

See Also

Rule Class
RedGate.SQLCompare.Engine Namespace


Rule Properties

[image] [image]

SQL Data Compare API 12.0.40
Rule Properties
Rule Class See Also

The Rule type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Rule (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSources | (Inherited from SchemaObject.)
Text | The text of the rule.

See Also

Rule Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
Rule..::.ObjectType Property
Rule Class See Also

Returns ObjectType.Rule

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()
ITSqlObjectObjectType()()()

See Also

Rule Class
RedGate.SQLCompare.Engine Namespace


Text Property

[image]

SQL Data Compare API 12.0.40
Rule..::.Text Property
Rule Class See Also

The text of the rule.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text { get; internal set; }
Visual C++
public:
virtual property String^ Text {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ITextObject..::.Text

See Also

Rule Class
RedGate.SQLCompare.Engine Namespace


Rules Class

[image]

SQL Data Compare API 12.0.40
Rules Class
Members See Also

A collection of rules.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Rules _
    Inherits SerializableDatabaseObjectCollection(Of Rule) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class Rules : SerializableDatabaseObjectCollection<Rule>, IPatchUpAfterDeserialization
Visual C++
public ref class Rules sealed : public SerializableDatabaseObjectCollection<Rule^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Rule >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( Rule >)>)
RedGate.SQLCompare.Engine..::.Rules

See Also

Rules Members
RedGate.SQLCompare.Engine Namespace


Rules Members

[image] [image]

SQL Data Compare API 12.0.40
Rules Members
Rules Class Methods Fields Properties Explicit Interface Implementations See Also

The Rules type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

Rules Class
RedGate.SQLCompare.Engine Namespace


Rules Methods

[image] [image]

SQL Data Compare API 12.0.40
Rules Methods
Rules Class See Also

The Rules type exposes the following methods.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

Rules Class
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
Rules..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
Rules Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

Rules Class
RedGate.SQLCompare.Engine Namespace


RulesChanges Class

[image]

SQL Data Compare API 12.0.40
RulesChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RulesChanges
C#
public sealed class RulesChanges
Visual C++
public ref class RulesChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.RulesChanges

See Also

RulesChanges Members
RedGate.SQLCompare.Engine Namespace


RulesChanges Members

[image] [image]

SQL Data Compare API 12.0.40
RulesChanges Members
RulesChanges Class Constructors Methods Properties See Also

The RulesChanges type exposes the following members.

Constructors

Name | Description
RulesChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FieldRulesToBind |
FieldRulesToUnbind |
RulesToCreate |
RulesToDrop |
UDTRulesToBind |
UDTRulesToUnbind |

See Also

RulesChanges Class
RedGate.SQLCompare.Engine Namespace


RulesChanges Constructor

[image]

SQL Data Compare API 12.0.40
RulesChanges Constructor
RulesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public RulesChanges(
    bool caseSensitive
)
Visual C++
public:
RulesChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

RulesChanges Class
RedGate.SQLCompare.Engine Namespace


RulesChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
RulesChanges Properties
RulesChanges Class See Also

The RulesChanges type exposes the following properties.

Properties

Name | Description
FieldRulesToBind |
FieldRulesToUnbind |
RulesToCreate |
RulesToDrop |
UDTRulesToBind |
UDTRulesToUnbind |

See Also

RulesChanges Class
RedGate.SQLCompare.Engine Namespace


FieldRulesToBind Property

[image]

SQL Data Compare API 12.0.40
RulesChanges..::.FieldRulesToBind Property
RulesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FieldRulesToBind As FieldBindings
C#
public FieldBindings FieldRulesToBind { get; private set; }
Visual C++
public:
property FieldBindings^ FieldRulesToBind {
    FieldBindings^ get ();
    void set (FieldBindings^ value);
}

See Also

RulesChanges Class
RedGate.SQLCompare.Engine Namespace


FieldRulesToUnbind Property

[image]

SQL Data Compare API 12.0.40
RulesChanges..::.FieldRulesToUnbind Property
RulesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FieldRulesToUnbind As FieldBindings
C#
public FieldBindings FieldRulesToUnbind { get; private set; }
Visual C++
public:
property FieldBindings^ FieldRulesToUnbind {
    FieldBindings^ get ();
    void set (FieldBindings^ value);
}

See Also

RulesChanges Class
RedGate.SQLCompare.Engine Namespace


RulesToCreate Property

[image]

SQL Data Compare API 12.0.40
RulesChanges..::.RulesToCreate Property
RulesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RulesToCreate As Rules
C#
public Rules RulesToCreate { get; private set; }
Visual C++
public:
property Rules^ RulesToCreate {
    Rules^ get ();
    void set (Rules^ value);
}

See Also

RulesChanges Class
RedGate.SQLCompare.Engine Namespace


RulesToDrop Property

[image]

SQL Data Compare API 12.0.40
RulesChanges..::.RulesToDrop Property
RulesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RulesToDrop As Rules
C#
public Rules RulesToDrop { get; private set; }
Visual C++
public:
property Rules^ RulesToDrop {
    Rules^ get ();
    void set (Rules^ value);
}

See Also

RulesChanges Class
RedGate.SQLCompare.Engine Namespace


UDTRulesToBind Property

[image]

SQL Data Compare API 12.0.40
RulesChanges..::.UDTRulesToBind Property
RulesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UDTRulesToBind As UDTBindings
C#
public UDTBindings UDTRulesToBind { get; private set; }
Visual C++
public:
property UDTBindings^ UDTRulesToBind {
    UDTBindings^ get ();
    void set (UDTBindings^ value);
}

See Also

RulesChanges Class
RedGate.SQLCompare.Engine Namespace


UDTRulesToUnbind Property

[image]

SQL Data Compare API 12.0.40
RulesChanges..::.UDTRulesToUnbind Property
RulesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UDTRulesToUnbind As UDTBindings
C#
public UDTBindings UDTRulesToUnbind { get; private set; }
Visual C++
public:
property UDTBindings^ UDTRulesToUnbind {
    UDTBindings^ get ();
    void set (UDTBindings^ value);
}

See Also

RulesChanges Class
RedGate.SQLCompare.Engine Namespace


SC_DeploymentOptions Class

[image]

SQL Data Compare API 12.0.40
SC_DeploymentOptions Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SC_DeploymentOptions
C#
public sealed class SC_DeploymentOptions
Visual C++
public ref class SC_DeploymentOptions sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.SC_DeploymentOptions

See Also

SC_DeploymentOptions Members
RedGate.SQLCompare.Engine Namespace


SC_DeploymentOptions Members

[image] [image]

SQL Data Compare API 12.0.40
SC_DeploymentOptions Members
SC_DeploymentOptions Class Constructors Methods Properties See Also

The SC_DeploymentOptions type exposes the following members.

Constructors

Name | Description
SC_DeploymentOptions |

Methods

Name | Description
Clone |
Deserialize |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize |
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
BackupOptions |
Version |

See Also

SC_DeploymentOptions Class
RedGate.SQLCompare.Engine Namespace


SC_DeploymentOptions Constructor

[image]

SQL Data Compare API 12.0.40
SC_DeploymentOptions Constructor
SC_DeploymentOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SC_DeploymentOptions()
Visual C++
public:
SC_DeploymentOptions()

See Also

SC_DeploymentOptions Class
RedGate.SQLCompare.Engine Namespace


SC_DeploymentOptions Methods

[image] [image]

SQL Data Compare API 12.0.40
SC_DeploymentOptions Methods
SC_DeploymentOptions Class See Also

The SC_DeploymentOptions type exposes the following methods.

Methods

Name | Description
Clone |
Deserialize |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize |
ToString | (Overrides Object..::.ToString()()().)

See Also

SC_DeploymentOptions Class
RedGate.SQLCompare.Engine Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
SC_DeploymentOptions..::.Clone Method
SC_DeploymentOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone As SC_DeploymentOptions
C#
public SC_DeploymentOptions Clone()
Visual C++
public:
SC_DeploymentOptions^ Clone()

See Also

SC_DeploymentOptions Class
RedGate.SQLCompare.Engine Namespace


Deserialize Method

[image]

SQL Data Compare API 12.0.40
SC_DeploymentOptions..::.Deserialize Method
SC_DeploymentOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Function Deserialize ( _
    versionId As Integer, _
    formatter As ISerializeFormatter _
) As Boolean
C#
public bool Deserialize(
    int versionId,
    ISerializeFormatter formatter
)
Visual C++
public:
virtual bool Deserialize(
    int versionId,
    ISerializeFormatter^ formatter
) sealed

Parameters

versionId
Type: Int32
formatter
Type: ISerializeFormatter

See Also

SC_DeploymentOptions Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
SC_DeploymentOptions..::.Equals Method
SC_DeploymentOptions Class See Also

Overload List

Name | Description
Equals(Object) | (Overrides Object..::.Equals(Object).)
Equals(SC_DeploymentOptions) |

See Also

SC_DeploymentOptions Class
SC_DeploymentOptions Members
RedGate.SQLCompare.Engine Namespace


Equals Method ()

[image]

SQL Data Compare API 12.0.40
SC_DeploymentOptions..::.Equals Method ()
SC_DeploymentOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object

See Also

SC_DeploymentOptions Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


Equals Method (SC_DeploymentOptions)

[image]

SQL Data Compare API 12.0.40
SC_DeploymentOptions..::.Equals Method (SC_DeploymentOptions)
SC_DeploymentOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    other As SC_DeploymentOptions _
) As Boolean
C#
public bool Equals(
    SC_DeploymentOptions other
)
Visual C++
public:
bool Equals(
    SC_DeploymentOptions^ other
)

Parameters

other
Type: RedGate.SQLCompare.Engine..::.SC_DeploymentOptions

See Also

SC_DeploymentOptions Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
SC_DeploymentOptions..::.GetHashCode Method
SC_DeploymentOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

See Also

SC_DeploymentOptions Class
RedGate.SQLCompare.Engine Namespace


Serialize Method

[image]

SQL Data Compare API 12.0.40
SC_DeploymentOptions..::.Serialize Method
SC_DeploymentOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub Serialize ( _
    formatter As ISerializeFormatter _
)
C#
public void Serialize(
    ISerializeFormatter formatter
)
Visual C++
public:
virtual void Serialize(
    ISerializeFormatter^ formatter
) sealed

Parameters

formatter
Type: ISerializeFormatter

See Also

SC_DeploymentOptions Class
RedGate.SQLCompare.Engine Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
SC_DeploymentOptions..::.ToString Method
SC_DeploymentOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

See Also

SC_DeploymentOptions Class
RedGate.SQLCompare.Engine Namespace


SC_DeploymentOptions Properties

[image] [image]

SQL Data Compare API 12.0.40
SC_DeploymentOptions Properties
SC_DeploymentOptions Class See Also

The SC_DeploymentOptions type exposes the following properties.

Properties

Name | Description
BackupOptions |
Version |

See Also

SC_DeploymentOptions Class
RedGate.SQLCompare.Engine Namespace


BackupOptions Property

[image]

SQL Data Compare API 12.0.40
SC_DeploymentOptions..::.BackupOptions Property
SC_DeploymentOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property BackupOptions As ProjectBackupOptions
C#
public ProjectBackupOptions BackupOptions { get; set; }
Visual C++
public:
property ProjectBackupOptions^ BackupOptions {
    ProjectBackupOptions^ get ();
    void set (ProjectBackupOptions^ value);
}

See Also

SC_DeploymentOptions Class
RedGate.SQLCompare.Engine Namespace


Version Property

[image]

SQL Data Compare API 12.0.40
SC_DeploymentOptions..::.Version Property
SC_DeploymentOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As Integer
C#
public int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () sealed;
}

See Also

SC_DeploymentOptions Class
RedGate.SQLCompare.Engine Namespace


Schema Class

[image]

SQL Data Compare API 12.0.40
Schema Class
Members See Also

A schema.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Schema _
    Inherits DatabaseObjectWithAuthorizationAndExtendedProperties _
    Implements IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck,  _
    IIsSystemObject, IOwner, IPatchUpAfterDeserialization, ISqlComparable
C#
public sealed class Schema : DatabaseObjectWithAuthorizationAndExtendedProperties, IHasPermissions,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, IIsSystemObject, IOwner,
    IPatchUpAfterDeserialization, ISqlComparable
Visual C++
public ref class Schema sealed : public DatabaseObjectWithAuthorizationAndExtendedProperties,
    IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck, IIsSystemObject,
    IOwner, IPatchUpAfterDeserialization, ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorizationAndExtendedProperties
RedGate.SQLCompare.Engine..::.Schema

See Also

Schema Members
RedGate.SQLCompare.Engine Namespace


Schema Members

[image] [image]

SQL Data Compare API 12.0.40
Schema Members
Schema Class Methods Fields Properties Explicit Interface Implementations See Also

The Schema type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AlterAuthorizationClassType | (Overrides DatabaseObjectWithAuthorization ..::. AlterAuthorizationClassType.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
FullyQualifiedName | The name of the schema. DANGER WILL ROBINSON!! This is not escaped. (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
IsSystemObject | Indicates whether the schema is a system object.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.User (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

Schema Class
RedGate.SQLCompare.Engine Namespace


Schema Methods

[image] [image]

SQL Data Compare API 12.0.40
Schema Methods
Schema Class See Also

The Schema type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

Schema Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
Schema..::.ISqlComparable..::.CompareWith Method
Schema Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    target As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable target,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ target,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

target
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

Schema Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
Schema..::.Equals Method
Schema Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the schema with a specified schema. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

Schema Class
Schema Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
Schema..::.Equals Method (IDatabaseObject, Options)
Schema Class See Also

Compares the schema with a specified schema.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) override

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The schema to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the schemas are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

Schema Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
Schema..::.PatchUpAfterDeserialization Method
Schema Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

Schema Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
Schema..::.ScriptObject Method
Schema Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

Schema Class
RedGate.SQLCompare.Engine Namespace


Schema Properties

[image] [image]

SQL Data Compare API 12.0.40
Schema Properties
Schema Class See Also

The Schema type exposes the following properties.

Properties

Name | Description
AlterAuthorizationClassType | (Overrides DatabaseObjectWithAuthorization ..::. AlterAuthorizationClassType.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
FullyQualifiedName | The name of the schema. DANGER WILL ROBINSON!! This is not escaped. (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
IsSystemObject | Indicates whether the schema is a system object.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.User (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)

See Also

Schema Class
RedGate.SQLCompare.Engine Namespace


AlterAuthorizationClassType Property

[image]

SQL Data Compare API 12.0.40
Schema..::.AlterAuthorizationClassType Property
Schema Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property AlterAuthorizationClassType As String
C#
public override string AlterAuthorizationClassType { get; }
Visual C++
public:
virtual property String^ AlterAuthorizationClassType {
    String^ get () override;
}

Implements

IHasAuthorization..::.AlterAuthorizationClassType

See Also

Schema Class
RedGate.SQLCompare.Engine Namespace


FullyQualifiedName Property

[image]

SQL Data Compare API 12.0.40
Schema..::.FullyQualifiedName Property
Schema Class See Also

The name of the schema. DANGER WILL ROBINSON!! This is not escaped.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FullyQualifiedName As String
C#
public override string FullyQualifiedName { get; }
Visual C++
public:
virtual property String^ FullyQualifiedName {
    String^ get () override;
}

Implements

ITSqlObjectFullyQualifiedName()()()
ITSqlObjectFullyQualifiedName()()()

See Also

Schema Class
RedGate.SQLCompare.Engine Namespace


IsSystemObject Property

[image]

SQL Data Compare API 12.0.40
Schema..::.IsSystemObject Property
Schema Class See Also

Indicates whether the schema is a system object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSystemObject As Boolean
C#
public bool IsSystemObject { get; private set; }
Visual C++
public:
virtual property bool IsSystemObject {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IIsSystemObject..::.IsSystemObject

See Also

Schema Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
Schema..::.ObjectType Property
Schema Class See Also

Returns ObjectType.User

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()
ITSqlObjectObjectType()()()

See Also

Schema Class
RedGate.SQLCompare.Engine Namespace


SchemaBinding Class

[image]

SQL Data Compare API 12.0.40
SchemaBinding Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SchemaBinding
C#
public sealed class SchemaBinding
Visual C++
public ref class SchemaBinding sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.SchemaBinding

See Also

SchemaBinding Members
RedGate.SQLCompare.Engine Namespace


SchemaBinding Members

[image] [image]

SQL Data Compare API 12.0.40
SchemaBinding Members
SchemaBinding Class Constructors Methods Properties See Also

The SchemaBinding type exposes the following members.

Constructors

Name | Description
SchemaBinding |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundObject |

See Also

SchemaBinding Class
RedGate.SQLCompare.Engine Namespace


SchemaBinding Constructor

[image]

SQL Data Compare API 12.0.40
SchemaBinding Constructor
SchemaBinding Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    boundObject As IDatabaseObject _
)
C#
public SchemaBinding(
    IDatabaseObject boundObject
)
Visual C++
public:
SchemaBinding(
    IDatabaseObject^ boundObject
)

Parameters

boundObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject

See Also

SchemaBinding Class
RedGate.SQLCompare.Engine Namespace


SchemaBinding Properties

[image] [image]

SQL Data Compare API 12.0.40
SchemaBinding Properties
SchemaBinding Class See Also

The SchemaBinding type exposes the following properties.

Properties

Name | Description
BoundObject |

See Also

SchemaBinding Class
RedGate.SQLCompare.Engine Namespace


BoundObject Property

[image]

SQL Data Compare API 12.0.40
SchemaBinding..::.BoundObject Property
SchemaBinding Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BoundObject As IDatabaseObject
C#
public IDatabaseObject BoundObject { get; }
Visual C++
public:
property IDatabaseObject^ BoundObject {
    IDatabaseObject^ get ();
}

See Also

SchemaBinding Class
RedGate.SQLCompare.Engine Namespace


SchemaBindings Class

[image]

SQL Data Compare API 12.0.40
SchemaBindings Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SchemaBindings _
    Inherits KeyedCollection(Of SchemaBinding)
C#
public sealed class SchemaBindings : KeyedCollection<SchemaBinding>
Visual C++
public ref class SchemaBindings sealed : public KeyedCollection<SchemaBinding^>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( SchemaBinding >)>)
RedGate.SQLCompare.Engine..::.SchemaBindings

See Also

SchemaBindings Members
RedGate.SQLCompare.Engine Namespace


SchemaBindings Members

[image] [image]

SQL Data Compare API 12.0.40
SchemaBindings Members
SchemaBindings Class Methods Fields Properties Explicit Interface Implementations See Also

The SchemaBindings type exposes the following members.

Methods

Name | Description
Add | (Overrides KeyedCollection <(Of <( SchemaBinding >)>)..::. Add(T).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortByDependency |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

SchemaBindings Class
RedGate.SQLCompare.Engine Namespace


SchemaBindings Methods

[image] [image]

SQL Data Compare API 12.0.40
SchemaBindings Methods
SchemaBindings Class See Also

The SchemaBindings type exposes the following methods.

Methods

Name | Description
Add | (Overrides KeyedCollection <(Of <( SchemaBinding >)>)..::. Add(T).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortByDependency |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

SchemaBindings Class
RedGate.SQLCompare.Engine Namespace


Add Method

[image]

SQL Data Compare API 12.0.40
SchemaBindings..::.Add Method
SchemaBindings Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Add ( _
    value As SchemaBinding _
)
C#
public override void Add(
    SchemaBinding value
)
Visual C++
public:
virtual void Add(
    SchemaBinding^ value
) override

Parameters

value
Type: RedGate.SQLCompare.Engine..::.SchemaBinding

Implements

IKeyedCollectionAdd(UTP)

See Also

SchemaBindings Class
RedGate.SQLCompare.Engine Namespace


SortByDependency Method

[image]

SQL Data Compare API 12.0.40
SchemaBindings..::.SortByDependency Method
SchemaBindings Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SortByDependency ( _
    d As Dependencies, _
    reverse As Boolean _
)
C#
public void SortByDependency(
    Dependencies d,
    bool reverse
)
Visual C++
public:
void SortByDependency(
    Dependencies^ d,
    bool reverse
)

Parameters

d
Type: Dependencies
reverse
Type: Boolean

See Also

SchemaBindings Class
RedGate.SQLCompare.Engine Namespace


SchemaBindingsToUnbindCalculator Class

[image]

SQL Data Compare API 12.0.40
SchemaBindingsToUnbindCalculator Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SchemaBindingsToUnbindCalculator
C#
public class SchemaBindingsToUnbindCalculator
Visual C++
public ref class SchemaBindingsToUnbindCalculator

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.SchemaBindingsToUnbindCalculator

See Also

SchemaBindingsToUnbindCalculator Members
RedGate.SQLCompare.Engine Namespace


SchemaBindingsToUnbindCalculator Members

[image] [image]

SQL Data Compare API 12.0.40
SchemaBindingsToUnbindCalculator Members
SchemaBindingsToUnbindCalculator Class Constructors Methods See Also

The SchemaBindingsToUnbindCalculator type exposes the following members.

Constructors

Name | Description
SchemaBindingsToUnbindCalculator |

Methods

Name | Description
DropSchemaBindings | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SchemaBindingsToUnbindCalculator Class
RedGate.SQLCompare.Engine Namespace


SchemaBindingsToUnbindCalculator Constructor

[image]

SQL Data Compare API 12.0.40
SchemaBindingsToUnbindCalculator Constructor
SchemaBindingsToUnbindCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    schemaBindingsToUnbind As SchemaBindings, _
    differences As Differences _
)
C#
public SchemaBindingsToUnbindCalculator(
    SchemaBindings schemaBindingsToUnbind,
    Differences differences
)
Visual C++
public:
SchemaBindingsToUnbindCalculator(
    SchemaBindings^ schemaBindingsToUnbind,
    Differences^ differences
)

Parameters

schemaBindingsToUnbind
Type: RedGate.SQLCompare.Engine..::.SchemaBindings
differences
Type: RedGate.SQLCompare.Engine..::.Differences

See Also

SchemaBindingsToUnbindCalculator Class
RedGate.SQLCompare.Engine Namespace


SchemaBindingsToUnbindCalculator Methods

[image] [image]

SQL Data Compare API 12.0.40
SchemaBindingsToUnbindCalculator Methods
SchemaBindingsToUnbindCalculator Class See Also

The SchemaBindingsToUnbindCalculator type exposes the following methods.

Methods

Name | Description
DropSchemaBindings | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SchemaBindingsToUnbindCalculator Class
RedGate.SQLCompare.Engine Namespace


DropSchemaBindings Method

[image] [image]

SQL Data Compare API 12.0.40
SchemaBindingsToUnbindCalculator..::.DropSchemaBindings Method
SchemaBindingsToUnbindCalculator Class See Also

Overload List

Name | Description
DropSchemaBindings(Function, Options) | For a specific function it adds the dependent schema bound functions to the SchemaBindingsToUnbind queue
DropSchemaBindings(ViewTableSuperClass, Options) | for a specific table it adds the dependent schema bound functions and views to the SchemaBindingsToUnbind queue

See Also

SchemaBindingsToUnbindCalculator Class
SchemaBindingsToUnbindCalculator Members
RedGate.SQLCompare.Engine Namespace


DropSchemaBindings Method (Function, Options)

[image]

SQL Data Compare API 12.0.40
SchemaBindingsToUnbindCalculator..::.DropSchemaBindings Method (Function, Options)
SchemaBindingsToUnbindCalculator Class See Also

For a specific function it adds the dependent schema bound functions to the SchemaBindingsToUnbind queue

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub DropSchemaBindings ( _
    functionBase As Function, _
    options As Options _
)
C#
public void DropSchemaBindings(
    Function functionBase,
    Options options
)
Visual C++
public:
void DropSchemaBindings(
    Function^ functionBase,
    Options options
)

Parameters

functionBase
Type: RedGate.SQLCompare.Engine..::.Function
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

SchemaBindingsToUnbindCalculator Class
DropSchemaBindings Overload
RedGate.SQLCompare.Engine Namespace


DropSchemaBindings Method (ViewTableSuperClass, Options)

[image]

SQL Data Compare API 12.0.40
SchemaBindingsToUnbindCalculator..::.DropSchemaBindings Method (ViewTableSuperClass, Options)
SchemaBindingsToUnbindCalculator Class See Also

for a specific table it adds the dependent schema bound functions and views to the SchemaBindingsToUnbind queue

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub DropSchemaBindings ( _
    targetTableOrView As ViewTableSuperClass, _
    options As Options _
)
C#
public void DropSchemaBindings(
    ViewTableSuperClass targetTableOrView,
    Options options
)
Visual C++
public:
void DropSchemaBindings(
    ViewTableSuperClass^ targetTableOrView,
    Options options
)

Parameters

targetTableOrView
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

SchemaBindingsToUnbindCalculator Class
DropSchemaBindings Overload
RedGate.SQLCompare.Engine Namespace


SchemaObject Class

[image]

SQL Data Compare API 12.0.40
SchemaObject Class
Members See Also

A schema object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class SchemaObject _
    Inherits ScriptableDatabaseObject
C#
public abstract class SchemaObject : ScriptableDatabaseObject
Visual C++
public ref class SchemaObject abstract : public ScriptableDatabaseObject

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.Default
RedGate.SQLCompare.Engine..::.Rule
RedGate.SQLCompare.Engine..::.SchemaObjectWithAuthorization

See Also

SchemaObject Members
RedGate.SQLCompare.Engine Namespace


SchemaObject Members

[image] [image]

SQL Data Compare API 12.0.40
SchemaObject Members
SchemaObject Class Methods Fields Properties See Also

The SchemaObject type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Inherited from ScriptableDatabaseObject.)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Overrides Object..::.ToString()()().)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties on the schema object.
FullyQualifiedName | The fully-qualified name of the object. (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | The type of the object. (Inherited from ScriptableDatabaseObject.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSources | (Overrides ScriptableDatabaseObject ..::. ScriptSources.)

See Also

SchemaObject Class
RedGate.SQLCompare.Engine Namespace


SchemaObject Methods

[image] [image]

SQL Data Compare API 12.0.40
SchemaObject Methods
SchemaObject Class See Also

The SchemaObject type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Inherited from ScriptableDatabaseObject.)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Overrides Object..::.ToString()()().)

See Also

SchemaObject Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
SchemaObject..::.Equals Method
SchemaObject Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares two database objects. (Inherited from ScriptableDatabaseObject.)

See Also

SchemaObject Class
SchemaObject Members
RedGate.SQLCompare.Engine Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
SchemaObject..::.ToString Method
SchemaObject Class See Also

Returns the fully-qualified name of the object prefixed with the object type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

Return Value

The fully-qualified name of the object prefixed with the object type.

See Also

SchemaObject Class
RedGate.SQLCompare.Engine Namespace


SchemaObject Properties

[image] [image]

SQL Data Compare API 12.0.40
SchemaObject Properties
SchemaObject Class See Also

The SchemaObject type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties on the schema object.
FullyQualifiedName | The fully-qualified name of the object. (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | The type of the object. (Inherited from ScriptableDatabaseObject.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSources | (Overrides ScriptableDatabaseObject ..::. ScriptSources.)

See Also

SchemaObject Class
RedGate.SQLCompare.Engine Namespace


ExtendedProperties Property

[image]

SQL Data Compare API 12.0.40
SchemaObject..::.ExtendedProperties Property
SchemaObject Class See Also

The extended properties on the schema object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedProperties As ExtendedProperties
C#
public ExtendedProperties ExtendedProperties { get; protected internal set; }
Visual C++
public:
property ExtendedProperties^ ExtendedProperties {
    ExtendedProperties^ get ();
    void set (ExtendedProperties^ value);
}

See Also

SchemaObject Class
RedGate.SQLCompare.Engine Namespace


FullyQualifiedName Property

[image]

SQL Data Compare API 12.0.40
SchemaObject..::.FullyQualifiedName Property
SchemaObject Class See Also

The fully-qualified name of the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FullyQualifiedName As String
C#
public override string FullyQualifiedName { get; }
Visual C++
public:
virtual property String^ FullyQualifiedName {
    String^ get () override;
}

Implements

ITSqlObjectFullyQualifiedName()()()

See Also

SchemaObject Class
RedGate.SQLCompare.Engine Namespace


ScriptSources Property

[image]

SQL Data Compare API 12.0.40
SchemaObject..::.ScriptSources Property
SchemaObject Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ScriptSources As IEnumerable(Of ScriptSource)
C#
public override IEnumerable<ScriptSource> ScriptSources { get; }
Visual C++
public:
virtual property IEnumerable<ScriptSource^>^ ScriptSources {
    IEnumerable<ScriptSource^>^ get () override;
}

See Also

SchemaObject Class
RedGate.SQLCompare.Engine Namespace


SchemaObjectAuthorizationsChanges Class

[image]

SQL Data Compare API 12.0.40
SchemaObjectAuthorizationsChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SchemaObjectAuthorizationsChanges
C#
public sealed class SchemaObjectAuthorizationsChanges
Visual C++
public ref class SchemaObjectAuthorizationsChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.SchemaObjectAuthorizationsChanges

See Also

SchemaObjectAuthorizationsChanges Members
RedGate.SQLCompare.Engine Namespace


SchemaObjectAuthorizationsChanges Members

[image] [image]

SQL Data Compare API 12.0.40
SchemaObjectAuthorizationsChanges Members
SchemaObjectAuthorizationsChanges Class Constructors Methods Properties See Also

The SchemaObjectAuthorizationsChanges type exposes the following members.

Constructors

Name | Description
SchemaObjectAuthorizationsChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
SchemaAuthTargets |
SchemaObjectAuthorizationsToAlter |

See Also

SchemaObjectAuthorizationsChanges Class
RedGate.SQLCompare.Engine Namespace


SchemaObjectAuthorizationsChanges Constructor

[image]

SQL Data Compare API 12.0.40
SchemaObjectAuthorizationsChanges Constructor
SchemaObjectAuthorizationsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SchemaObjectAuthorizationsChanges()
Visual C++
public:
SchemaObjectAuthorizationsChanges()

See Also

SchemaObjectAuthorizationsChanges Class
RedGate.SQLCompare.Engine Namespace


SchemaObjectAuthorizationsChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
SchemaObjectAuthorizationsChanges Properties
SchemaObjectAuthorizationsChanges Class See Also

The SchemaObjectAuthorizationsChanges type exposes the following properties.

Properties

Name | Description
SchemaAuthTargets |
SchemaObjectAuthorizationsToAlter |

See Also

SchemaObjectAuthorizationsChanges Class
RedGate.SQLCompare.Engine Namespace


SchemaAuthTargets Property

[image]

SQL Data Compare API 12.0.40
SchemaObjectAuthorizationsChanges..::.SchemaAuthTargets Property
SchemaObjectAuthorizationsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SchemaAuthTargets As Dictionary(Of SchemaObjectWithAuthorization, SchemaObjectWithAuthorization)
C#
public Dictionary<SchemaObjectWithAuthorization, SchemaObjectWithAuthorization> SchemaAuthTargets { get; private set; }
Visual C++
public:
property Dictionary<SchemaObjectWithAuthorization^, SchemaObjectWithAuthorization^>^ SchemaAuthTargets {
    Dictionary<SchemaObjectWithAuthorization^, SchemaObjectWithAuthorization^>^ get ();
    void set (Dictionary<SchemaObjectWithAuthorization^, SchemaObjectWithAuthorization^>^ value);
}

See Also

SchemaObjectAuthorizationsChanges Class
RedGate.SQLCompare.Engine Namespace


SchemaObjectAuthorizationsToAlter Property

[image]

SQL Data Compare API 12.0.40
SchemaObjectAuthorizationsChanges..::.SchemaObjectAuthorizationsToAlter Property
SchemaObjectAuthorizationsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SchemaObjectAuthorizationsToAlter As Set(Of SchemaObjectWithAuthorization)
C#
public Set<SchemaObjectWithAuthorization> SchemaObjectAuthorizationsToAlter { get; private set; }
Visual C++
public:
property Set<SchemaObjectWithAuthorization^>^ SchemaObjectAuthorizationsToAlter {
    Set<SchemaObjectWithAuthorization^>^ get ();
    void set (Set<SchemaObjectWithAuthorization^>^ value);
}

See Also

SchemaObjectAuthorizationsChanges Class
RedGate.SQLCompare.Engine Namespace


SchemaObjectWithAuthorization Class

[image]

SQL Data Compare API 12.0.40
SchemaObjectWithAuthorization Class
Members See Also

Represents a schema object that can also have an ALTER AUTHORIZATION applied to it to change the user as well (so it can have both user & schema).

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class SchemaObjectWithAuthorization _
    Inherits SchemaObject _
    Implements IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck,  _
    IHasAuthorization
C#
public abstract class SchemaObjectWithAuthorization : SchemaObject, IHasPermissions,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, IHasAuthorization
Visual C++
public ref class SchemaObjectWithAuthorization abstract : public SchemaObject,
    IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck, IHasAuthorization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.SchemaObjectWithAuthorization
RedGate.SQLCompare.Engine..::.Sequence
RedGate.SQLCompare.Engine..::.Function
RedGate.SQLCompare.Engine..::.Queue
RedGate.SQLCompare.Engine..::.StoredProcedure
RedGate.SQLCompare.Engine..::.Synonym
RedGate.SQLCompare.Engine..::.UserDefinedType
RedGate.SQLCompare.Engine..::.ViewTableSuperClass
RedGate.SQLCompare.Engine..::.XmlSchemaCollection
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies..::.SecurityPolicy

See Also

SchemaObjectWithAuthorization Members
RedGate.SQLCompare.Engine Namespace


SchemaObjectWithAuthorization Members

[image] [image]

SQL Data Compare API 12.0.40
SchemaObjectWithAuthorization Members
SchemaObjectWithAuthorization Class Methods Fields Properties See Also

The SchemaObjectWithAuthorization type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Inherited from ScriptableDatabaseObject.)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AlterAuthorizationClassType |
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()).
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | The type of the object. (Inherited from ScriptableDatabaseObject.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions |
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder.
ScriptSources | (Inherited from SchemaObject.)

See Also

SchemaObjectWithAuthorization Class
RedGate.SQLCompare.Engine Namespace


SchemaObjectWithAuthorization Properties

[image] [image]

SQL Data Compare API 12.0.40
SchemaObjectWithAuthorization Properties
SchemaObjectWithAuthorization Class See Also

The SchemaObjectWithAuthorization type exposes the following properties.

Properties

Name | Description
AlterAuthorizationClassType |
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()).
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | The type of the object. (Inherited from ScriptableDatabaseObject.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions |
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder.
ScriptSources | (Inherited from SchemaObject.)

See Also

SchemaObjectWithAuthorization Class
RedGate.SQLCompare.Engine Namespace


AlterAuthorizationClassType Property

[image]

SQL Data Compare API 12.0.40
SchemaObjectWithAuthorization..::.AlterAuthorizationClassType Property
SchemaObjectWithAuthorization Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AlterAuthorizationClassType As String
C#
public string AlterAuthorizationClassType { get; }
Visual C++
public:
virtual property String^ AlterAuthorizationClassType {
    String^ get () sealed;
}

Implements

IHasAuthorization..::.AlterAuthorizationClassType

See Also

SchemaObjectWithAuthorization Class
RedGate.SQLCompare.Engine Namespace


Authorization Property

[image]

SQL Data Compare API 12.0.40
SchemaObjectWithAuthorization..::.Authorization Property
SchemaObjectWithAuthorization Class See Also

Returns the authorization owner of the object (as opposed to the schema; see Owner()()()).

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Authorization As String
C#
public string Authorization { get; internal set; }
Visual C++
public:
property String^ Authorization {
    String^ get ();
    void set (String^ value);
}

See Also

SchemaObjectWithAuthorization Class
RedGate.SQLCompare.Engine Namespace


Permissions Property

[image]

SQL Data Compare API 12.0.40
SchemaObjectWithAuthorization..::.Permissions Property
SchemaObjectWithAuthorization Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Permissions As Permissions
C#
public Permissions Permissions { get; protected internal set; }
Visual C++
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
    void set (Permissions^ value) sealed;
}

Implements

IHasPermissions..::.Permissions

See Also

SchemaObjectWithAuthorization Class
RedGate.SQLCompare.Engine Namespace


ScriptSourceAuthorization Property

[image]

SQL Data Compare API 12.0.40
SchemaObjectWithAuthorization..::.ScriptSourceAuthorization Property
SchemaObjectWithAuthorization Class See Also

The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSourceAuthorization As ScriptSource
C#
public ScriptSource ScriptSourceAuthorization { get; internal set; }
Visual C++
public:
property ScriptSource^ ScriptSourceAuthorization {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

SchemaObjectWithAuthorization Class
RedGate.SQLCompare.Engine Namespace


Schemas Class

[image]

SQL Data Compare API 12.0.40
Schemas Class
Members See Also

A collection of schemas.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Schemas _
    Inherits SerializableDatabaseObjectCollection(Of Schema) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class Schemas : SerializableDatabaseObjectCollection<Schema>, IPatchUpAfterDeserialization
Visual C++
public ref class Schemas sealed : public SerializableDatabaseObjectCollection<Schema^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Schema >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( Schema >)>)
RedGate.SQLCompare.Engine..::.Schemas

See Also

Schemas Members
RedGate.SQLCompare.Engine Namespace


Schemas Members

[image] [image]

SQL Data Compare API 12.0.40
Schemas Members
Schemas Class Methods Fields Properties Explicit Interface Implementations See Also

The Schemas type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

Schemas Class
RedGate.SQLCompare.Engine Namespace


Schemas Methods

[image] [image]

SQL Data Compare API 12.0.40
Schemas Methods
Schemas Class See Also

The Schemas type exposes the following methods.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

Schemas Class
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
Schemas..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
Schemas Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

Schemas Class
RedGate.SQLCompare.Engine Namespace


SchemasChanges Class

[image]

SQL Data Compare API 12.0.40
SchemasChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SchemasChanges
C#
public sealed class SchemasChanges
Visual C++
public ref class SchemasChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.SchemasChanges

See Also

SchemasChanges Members
RedGate.SQLCompare.Engine Namespace


SchemasChanges Members

[image] [image]

SQL Data Compare API 12.0.40
SchemasChanges Members
SchemasChanges Class Constructors Methods Properties See Also

The SchemasChanges type exposes the following members.

Constructors

Name | Description
SchemasChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
SchemasToAlter |
SchemasToCreate |
SchemasToDrop |
SchemaTargets |

See Also

SchemasChanges Class
RedGate.SQLCompare.Engine Namespace


SchemasChanges Constructor

[image]

SQL Data Compare API 12.0.40
SchemasChanges Constructor
SchemasChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public SchemasChanges(
    bool caseSensitive
)
Visual C++
public:
SchemasChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

SchemasChanges Class
RedGate.SQLCompare.Engine Namespace


SchemasChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
SchemasChanges Properties
SchemasChanges Class See Also

The SchemasChanges type exposes the following properties.

Properties

Name | Description
SchemasToAlter |
SchemasToCreate |
SchemasToDrop |
SchemaTargets |

See Also

SchemasChanges Class
RedGate.SQLCompare.Engine Namespace


SchemasToAlter Property

[image]

SQL Data Compare API 12.0.40
SchemasChanges..::.SchemasToAlter Property
SchemasChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SchemasToAlter As Schemas
C#
public Schemas SchemasToAlter { get; private set; }
Visual C++
public:
property Schemas^ SchemasToAlter {
    Schemas^ get ();
    void set (Schemas^ value);
}

See Also

SchemasChanges Class
RedGate.SQLCompare.Engine Namespace


SchemasToCreate Property

[image]

SQL Data Compare API 12.0.40
SchemasChanges..::.SchemasToCreate Property
SchemasChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SchemasToCreate As Schemas
C#
public Schemas SchemasToCreate { get; private set; }
Visual C++
public:
property Schemas^ SchemasToCreate {
    Schemas^ get ();
    void set (Schemas^ value);
}

See Also

SchemasChanges Class
RedGate.SQLCompare.Engine Namespace


SchemasToDrop Property

[image]

SQL Data Compare API 12.0.40
SchemasChanges..::.SchemasToDrop Property
SchemasChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SchemasToDrop As Schemas
C#
public Schemas SchemasToDrop { get; private set; }
Visual C++
public:
property Schemas^ SchemasToDrop {
    Schemas^ get ();
    void set (Schemas^ value);
}

See Also

SchemasChanges Class
RedGate.SQLCompare.Engine Namespace


SchemaTargets Property

[image]

SQL Data Compare API 12.0.40
SchemasChanges..::.SchemaTargets Property
SchemasChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SchemaTargets As Dictionary(Of Schema, Schema)
C#
public Dictionary<Schema, Schema> SchemaTargets { get; private set; }
Visual C++
public:
property Dictionary<Schema^, Schema^>^ SchemaTargets {
    Dictionary<Schema^, Schema^>^ get ();
    void set (Dictionary<Schema^, Schema^>^ value);
}

See Also

SchemasChanges Class
RedGate.SQLCompare.Engine Namespace


ScriptableDatabaseObject Class

[image]

SQL Data Compare API 12.0.40
ScriptableDatabaseObject Class
Members See Also

Represents a scriptable database object. Also has default implementations of some of the IDatabaseObject methods & properties

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class ScriptableDatabaseObject _
    Implements IDatabaseObject, ITSqlObject, ICanExistenceCheck, IHasScriptSource
C#
public abstract class ScriptableDatabaseObject : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck, IHasScriptSource
Visual C++
public ref class ScriptableDatabaseObject abstract : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck, IHasScriptSource

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.ClrFile
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.DdlTrigger
RedGate.SQLCompare.Engine..::.EventNotification
RedGate.SQLCompare.Engine..::.ExtendedProperty
RedGate.SQLCompare.Engine..::.PartitionFunction
RedGate.SQLCompare.Engine..::.PartitionScheme
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.User

See Also

ScriptableDatabaseObject Members
RedGate.SQLCompare.Engine Namespace


ScriptableDatabaseObject Members

[image] [image]

SQL Data Compare API 12.0.40
ScriptableDatabaseObject Members
ScriptableDatabaseObject Class Methods Fields Properties See Also

The ScriptableDatabaseObject type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
c_EscapedUnknownIdentifierPlaceholder | Sometimes we are unable to get information from the system tables due to privelege issues, we print this string as a placeholder.
c_UnescapedUnknownIdentifierPlaceholder | Sometimes we are unable to get information from the system tables due to privelege issues, we print this string as a placeholder.
m_ScriptSources |

Properties

Name | Description
Database | The database to which the object belongs.
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName?
ObjectType | The type of the object.
Owner | The owner or schema of the object.
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name?
ScriptSource | The script source for this object, if the database source is set to scripts folder.
ScriptSources |

See Also

ScriptableDatabaseObject Class
RedGate.SQLCompare.Engine Namespace


ScriptableDatabaseObject Fields

[image] [image]

SQL Data Compare API 12.0.40
ScriptableDatabaseObject Fields
ScriptableDatabaseObject Class See Also

The ScriptableDatabaseObject type exposes the following fields.

Fields

Name | Description
c_EscapedUnknownIdentifierPlaceholder | Sometimes we are unable to get information from the system tables due to privelege issues, we print this string as a placeholder.
c_UnescapedUnknownIdentifierPlaceholder | Sometimes we are unable to get information from the system tables due to privelege issues, we print this string as a placeholder.
m_ScriptSources |

See Also

ScriptableDatabaseObject Class
RedGate.SQLCompare.Engine Namespace


c_EscapedUnknownIdentifierPlaceholder Field

[image]

SQL Data Compare API 12.0.40
ScriptableDatabaseObject..::.c_EscapedUnknownIdentifierPlaceholder Field
ScriptableDatabaseObject Class See Also

Sometimes we are unable to get information from the system tables due to privelege issues, we print this string as a placeholder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Const c_EscapedUnknownIdentifierPlaceholder As String
C#
protected const string c_EscapedUnknownIdentifierPlaceholder
Visual C++
protected:
literal String^ c_EscapedUnknownIdentifierPlaceholder

See Also

ScriptableDatabaseObject Class
RedGate.SQLCompare.Engine Namespace


c_UnescapedUnknownIdentifierPlaceholder Field

[image]

SQL Data Compare API 12.0.40
ScriptableDatabaseObject..::.c_UnescapedUnknownIdentifierPlaceholder Field
ScriptableDatabaseObject Class See Also

Sometimes we are unable to get information from the system tables due to privelege issues, we print this string as a placeholder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Const c_UnescapedUnknownIdentifierPlaceholder As String
C#
protected const string c_UnescapedUnknownIdentifierPlaceholder
Visual C++
protected:
literal String^ c_UnescapedUnknownIdentifierPlaceholder

See Also

ScriptableDatabaseObject Class
RedGate.SQLCompare.Engine Namespace


m_ScriptSources Field

[image]

SQL Data Compare API 12.0.40
ScriptableDatabaseObject..::.m_ScriptSources Field
ScriptableDatabaseObject Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly m_ScriptSources As Dictionary(Of String, ScriptSource)
C#
protected readonly Dictionary<string, ScriptSource> m_ScriptSources
Visual C++
protected:
initonly Dictionary<String^, ScriptSource^>^ m_ScriptSources

See Also

ScriptableDatabaseObject Class
RedGate.SQLCompare.Engine Namespace


ScriptableDatabaseObject Methods

[image] [image]

SQL Data Compare API 12.0.40
ScriptableDatabaseObject Methods
ScriptableDatabaseObject Class See Also

The ScriptableDatabaseObject type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScriptableDatabaseObject Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
ScriptableDatabaseObject..::.Equals Method
ScriptableDatabaseObject Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares two database objects.

See Also

ScriptableDatabaseObject Class
ScriptableDatabaseObject Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
ScriptableDatabaseObject..::.Equals Method (IDatabaseObject, Options)
ScriptableDatabaseObject Class See Also

Compares two database objects.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public abstract bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) abstract

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The object to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
The comparison options.

Return Value

True if the database objects are identical; otherwise false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

ScriptableDatabaseObject Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
ScriptableDatabaseObject..::.ScriptObject Method
ScriptableDatabaseObject Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public abstract Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) abstract

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options, e.g. quoted identifier on or off.
options
Type: RedGate.SQLCompare.Engine..::.Options
Options that may influence the scripting.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

ScriptableDatabaseObject Class
RedGate.SQLCompare.Engine Namespace


ScriptableDatabaseObject Properties

[image] [image]

SQL Data Compare API 12.0.40
ScriptableDatabaseObject Properties
ScriptableDatabaseObject Class See Also

The ScriptableDatabaseObject type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs.
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName?
ObjectType | The type of the object.
Owner | The owner or schema of the object.
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name?
ScriptSource | The script source for this object, if the database source is set to scripts folder.
ScriptSources |

See Also

ScriptableDatabaseObject Class
RedGate.SQLCompare.Engine Namespace


Database Property

[image]

SQL Data Compare API 12.0.40
ScriptableDatabaseObject..::.Database Property
ScriptableDatabaseObject Class See Also

The database to which the object belongs.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Database As Database
C#
public Database Database { get; internal set; }
Visual C++
public:
virtual property Database^ Database {
    Database^ get () sealed;
    void set (Database^ value) sealed;
}

Implements

IDatabaseObject..::.Database

See Also

ScriptableDatabaseObject Class
RedGate.SQLCompare.Engine Namespace


FullyQualifiedName Property

[image]

SQL Data Compare API 12.0.40
ScriptableDatabaseObject..::.FullyQualifiedName Property
ScriptableDatabaseObject Class See Also

The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property FullyQualifiedName As String
C#
public virtual string FullyQualifiedName { get; }
Visual C++
public:
virtual property String^ FullyQualifiedName {
    String^ get ();
}

Implements

ITSqlObjectFullyQualifiedName()()()

See Also

ScriptableDatabaseObject Class
RedGate.SQLCompare.Engine Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
ScriptableDatabaseObject..::.Name Property
ScriptableDatabaseObject Class See Also

The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName?

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Name As String
C#
public virtual string Name { get; internal set; }
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}

Implements

ITSqlObjectName()()()

See Also

ScriptableDatabaseObject Class
RedGate.SQLCompare.Engine Namespace
ScriptableDatabaseObject..::.QualifiedName


ObjectType Property

[image]

SQL Data Compare API 12.0.40
ScriptableDatabaseObject..::.ObjectType Property
ScriptableDatabaseObject Class See Also

The type of the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property ObjectType As ObjectType
C#
public abstract ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () abstract;
}

Implements

ITSqlObjectObjectType()()()

See Also

ScriptableDatabaseObject Class
RedGate.SQLCompare.Engine Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
ScriptableDatabaseObject..::.Owner Property
ScriptableDatabaseObject Class See Also

The owner or schema of the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Owner As String
C#
public virtual string Owner { get; internal set; }
Visual C++
public:
virtual property String^ Owner {
    String^ get ();
    void set (String^ value);
}

Implements

ITSqlObjectOwner()()()

See Also

ScriptableDatabaseObject Class
RedGate.SQLCompare.Engine Namespace


QualifiedName Property

[image]

SQL Data Compare API 12.0.40
ScriptableDatabaseObject..::.QualifiedName Property
ScriptableDatabaseObject Class See Also

The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name?

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property QualifiedName As String
C#
public string QualifiedName { get; }
Visual C++
public:
virtual property String^ QualifiedName {
    String^ get () sealed;
}

Implements

ITSqlObjectQualifiedName()()()

See Also

ScriptableDatabaseObject Class
RedGate.SQLCompare.Engine Namespace
ScriptableDatabaseObject..::.Name


ScriptSource Property

[image]

SQL Data Compare API 12.0.40
ScriptableDatabaseObject..::.ScriptSource Property
ScriptableDatabaseObject Class See Also

The script source for this object, if the database source is set to scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSource As ScriptSource
C#
public ScriptSource ScriptSource { get; internal set; }
Visual C++
public:
virtual property ScriptSource^ ScriptSource {
    ScriptSource^ get () sealed;
    void set (ScriptSource^ value) sealed;
}

Implements

IHasScriptSource..::.ScriptSource

See Also

ScriptableDatabaseObject Class
RedGate.SQLCompare.Engine Namespace


ScriptSources Property

[image]

SQL Data Compare API 12.0.40
ScriptableDatabaseObject..::.ScriptSources Property
ScriptableDatabaseObject Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ScriptSources As IEnumerable(Of ScriptSource)
C#
public virtual IEnumerable<ScriptSource> ScriptSources { get; }
Visual C++
public:
virtual property IEnumerable<ScriptSource^>^ ScriptSources {
    IEnumerable<ScriptSource^>^ get ();
}

See Also

ScriptableDatabaseObject Class
RedGate.SQLCompare.Engine Namespace


ScriptGenerationResult Class

[image]

SQL Data Compare API 12.0.40
ScriptGenerationResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ScriptGenerationResult _
    Inherits DeploymentResult
C#
public class ScriptGenerationResult : DeploymentResult
Visual C++
public ref class ScriptGenerationResult : public DeploymentResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.DeploymentResult
RedGate.SQLCompare.Engine..::.ScriptGenerationResult

See Also

ScriptGenerationResult Members
RedGate.SQLCompare.Engine Namespace


ScriptGenerationResult Members

[image] [image]

SQL Data Compare API 12.0.40
ScriptGenerationResult Members
ScriptGenerationResult Class Methods Properties See Also

The ScriptGenerationResult type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Messages | (Inherited from DeploymentResult.)
ScriptSynchronizationActions |
Warnings | (Inherited from DeploymentResult.)

See Also

ScriptGenerationResult Class
RedGate.SQLCompare.Engine Namespace


ScriptGenerationResult Properties

[image] [image]

SQL Data Compare API 12.0.40
ScriptGenerationResult Properties
ScriptGenerationResult Class See Also

The ScriptGenerationResult type exposes the following properties.

Properties

Name | Description
Messages | (Inherited from DeploymentResult.)
ScriptSynchronizationActions |
Warnings | (Inherited from DeploymentResult.)

See Also

ScriptGenerationResult Class
RedGate.SQLCompare.Engine Namespace


ScriptSynchronizationActions Property

[image]

SQL Data Compare API 12.0.40
ScriptGenerationResult..::.ScriptSynchronizationActions Property
ScriptGenerationResult Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSynchronizationActions As ScriptSynchronizationActions
C#
public ScriptSynchronizationActions ScriptSynchronizationActions { get; set; }
Visual C++
public:
property ScriptSynchronizationActions^ ScriptSynchronizationActions {
    ScriptSynchronizationActions^ get ();
    void set (ScriptSynchronizationActions^ value);
}

See Also

ScriptGenerationResult Class
RedGate.SQLCompare.Engine Namespace


ScriptRegistrationInformation Class

[image]

SQL Data Compare API 12.0.40
ScriptRegistrationInformation Class
Members See Also

Holds the information needed in order to perform a registration of a scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ScriptRegistrationInformation
C#
public class ScriptRegistrationInformation
Visual C++
public ref class ScriptRegistrationInformation

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptRegistrationInformation

See Also

ScriptRegistrationInformation Members
RedGate.SQLCompare.Engine Namespace


ScriptRegistrationInformation Members

[image] [image]

SQL Data Compare API 12.0.40
ScriptRegistrationInformation Members
ScriptRegistrationInformation Class Constructors Methods Properties See Also

The ScriptRegistrationInformation type exposes the following members.

Constructors

Name | Description
ScriptRegistrationInformation | Create a new instance.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Database |
DBInfo |
FilesToUse |
Options |

See Also

ScriptRegistrationInformation Class
RedGate.SQLCompare.Engine Namespace


ScriptRegistrationInformation Constructor

[image]

SQL Data Compare API 12.0.40
ScriptRegistrationInformation Constructor
ScriptRegistrationInformation Class See Also

Create a new instance.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    database As IDatabase, _
    dbInfo As ScriptDatabaseInformation, _
    options As Options, _
    filesToUse As IEnumerable(Of String) _
)
C#
public ScriptRegistrationInformation(
    IDatabase database,
    ScriptDatabaseInformation dbInfo,
    Options options,
    IEnumerable<string> filesToUse
)
Visual C++
public:
ScriptRegistrationInformation(
    IDatabase^ database,
    ScriptDatabaseInformation^ dbInfo,
    Options options,
    IEnumerable<String^>^ filesToUse
)

Parameters

database
Type: RedGate.SQLCompare.Engine..::.IDatabase
The database to be populated.
dbInfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
The ScriptDatabaseInformation to be used during the register.
options
Type: RedGate.SQLCompare.Engine..::.Options
The options to use for the register.
filesToUse
Type: IEnumerable<(Of <(String>)>)
A sequence of files to populate from, or null to default to everything in the scripts folder.

See Also

ScriptRegistrationInformation Class
RedGate.SQLCompare.Engine Namespace


ScriptRegistrationInformation Properties

[image] [image]

SQL Data Compare API 12.0.40
ScriptRegistrationInformation Properties
ScriptRegistrationInformation Class See Also

The ScriptRegistrationInformation type exposes the following properties.

Properties

Name | Description
Database |
DBInfo |
FilesToUse |
Options |

See Also

ScriptRegistrationInformation Class
RedGate.SQLCompare.Engine Namespace


Database Property

[image]

SQL Data Compare API 12.0.40
ScriptRegistrationInformation..::.Database Property
ScriptRegistrationInformation Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Database As IDatabase
C#
public IDatabase Database { get; private set; }
Visual C++
public:
property IDatabase^ Database {
    IDatabase^ get ();
    void set (IDatabase^ value);
}

See Also

ScriptRegistrationInformation Class
RedGate.SQLCompare.Engine Namespace


DBInfo Property

[image]

SQL Data Compare API 12.0.40
ScriptRegistrationInformation..::.DBInfo Property
ScriptRegistrationInformation Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DBInfo As ScriptDatabaseInformation
C#
public ScriptDatabaseInformation DBInfo { get; private set; }
Visual C++
public:
property ScriptDatabaseInformation^ DBInfo {
    ScriptDatabaseInformation^ get ();
    void set (ScriptDatabaseInformation^ value);
}

See Also

ScriptRegistrationInformation Class
RedGate.SQLCompare.Engine Namespace


FilesToUse Property

[image]

SQL Data Compare API 12.0.40
ScriptRegistrationInformation..::.FilesToUse Property
ScriptRegistrationInformation Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FilesToUse As IList(Of String)
C#
public IList<string> FilesToUse { get; private set; }
Visual C++
public:
property IList<String^>^ FilesToUse {
    IList<String^>^ get ();
    void set (IList<String^>^ value);
}

See Also

ScriptRegistrationInformation Class
RedGate.SQLCompare.Engine Namespace


Options Property

[image]

SQL Data Compare API 12.0.40
ScriptRegistrationInformation..::.Options Property
ScriptRegistrationInformation Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Options As Options
C#
public Options Options { get; private set; }
Visual C++
public:
property Options Options {
    Options get ();
    void set (Options value);
}

See Also

ScriptRegistrationInformation Class
RedGate.SQLCompare.Engine Namespace


ScriptSource Class

[image]

SQL Data Compare API 12.0.40
ScriptSource Class
Members See Also

Information about the source of a database object. This information includes details of the creation script file, as well as the starting and ending character position for the creation statement.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ScriptSource
C#
public sealed class ScriptSource
Visual C++
public ref class ScriptSource sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptSource

See Also

ScriptSource Members
RedGate.SQLCompare.Engine Namespace


ScriptSource Members

[image] [image]

SQL Data Compare API 12.0.40
ScriptSource Members
ScriptSource Class Methods Properties See Also

The ScriptSource type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
FileInfo | Information about the file that contains the SQL statement.
LowerPosition | The first character position of the SQL statement.
PermissionsSources | A collection of script sources for the permission statements.
SetAnsiNulls | The script source of the relevant "SET ANSII NULLS" statement.
SetQuotedIdentifiers | The script source of the relevant "SET QUOTED IDENTIFIERS" statement.
UpperPosition | The last character position of the SQL statement.

See Also

ScriptSource Class
RedGate.SQLCompare.Engine Namespace


ScriptSource Methods

[image] [image]

SQL Data Compare API 12.0.40
ScriptSource Methods
ScriptSource Class See Also

The ScriptSource type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

See Also

ScriptSource Class
RedGate.SQLCompare.Engine Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
ScriptSource..::.ToString Method
ScriptSource Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

See Also

ScriptSource Class
RedGate.SQLCompare.Engine Namespace


ScriptSource Properties

[image] [image]

SQL Data Compare API 12.0.40
ScriptSource Properties
ScriptSource Class See Also

The ScriptSource type exposes the following properties.

Properties

Name | Description
FileInfo | Information about the file that contains the SQL statement.
LowerPosition | The first character position of the SQL statement.
PermissionsSources | A collection of script sources for the permission statements.
SetAnsiNulls | The script source of the relevant "SET ANSII NULLS" statement.
SetQuotedIdentifiers | The script source of the relevant "SET QUOTED IDENTIFIERS" statement.
UpperPosition | The last character position of the SQL statement.

See Also

ScriptSource Class
RedGate.SQLCompare.Engine Namespace


FileInfo Property

[image]

SQL Data Compare API 12.0.40
ScriptSource..::.FileInfo Property
ScriptSource Class See Also

Information about the file that contains the SQL statement.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FileInfo As FileInfo
C#
public FileInfo FileInfo { get; private set; }
Visual C++
public:
property FileInfo^ FileInfo {
    FileInfo^ get ();
    void set (FileInfo^ value);
}

See Also

ScriptSource Class
RedGate.SQLCompare.Engine Namespace


LowerPosition Property

[image]

SQL Data Compare API 12.0.40
ScriptSource..::.LowerPosition Property
ScriptSource Class See Also

The first character position of the SQL statement.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LowerPosition As Integer
C#
public int LowerPosition { get; private set; }
Visual C++
public:
property int LowerPosition {
    int get ();
    void set (int value);
}

See Also

ScriptSource Class
RedGate.SQLCompare.Engine Namespace


PermissionsSources Property

[image]

SQL Data Compare API 12.0.40
ScriptSource..::.PermissionsSources Property
ScriptSource Class See Also

A collection of script sources for the permission statements.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PermissionsSources As List(Of ScriptSource)
C#
public List<ScriptSource> PermissionsSources { get; }
Visual C++
public:
property List<ScriptSource^>^ PermissionsSources {
    List<ScriptSource^>^ get ();
}

See Also

ScriptSource Class
RedGate.SQLCompare.Engine Namespace


SetAnsiNulls Property

[image]

SQL Data Compare API 12.0.40
ScriptSource..::.SetAnsiNulls Property
ScriptSource Class See Also

The script source of the relevant "SET ANSII NULLS" statement.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SetAnsiNulls As ScriptSource
C#
public ScriptSource SetAnsiNulls { get; internal set; }
Visual C++
public:
property ScriptSource^ SetAnsiNulls {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

ScriptSource Class
RedGate.SQLCompare.Engine Namespace


SetQuotedIdentifiers Property

[image]

SQL Data Compare API 12.0.40
ScriptSource..::.SetQuotedIdentifiers Property
ScriptSource Class See Also

The script source of the relevant "SET QUOTED IDENTIFIERS" statement.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SetQuotedIdentifiers As ScriptSource
C#
public ScriptSource SetQuotedIdentifiers { get; internal set; }
Visual C++
public:
property ScriptSource^ SetQuotedIdentifiers {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

ScriptSource Class
RedGate.SQLCompare.Engine Namespace


UpperPosition Property

[image]

SQL Data Compare API 12.0.40
ScriptSource..::.UpperPosition Property
ScriptSource Class See Also

The last character position of the SQL statement.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UpperPosition As Integer
C#
public int UpperPosition { get; private set; }
Visual C++
public:
property int UpperPosition {
    int get ();
    void set (int value);
}

See Also

ScriptSource Class
RedGate.SQLCompare.Engine Namespace


SearchProperty Class

[image]

SQL Data Compare API 12.0.40
SearchProperty Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SearchProperty
C#
public class SearchProperty
Visual C++
public ref class SearchProperty

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.SearchProperty

See Also

SearchProperty Members
RedGate.SQLCompare.Engine Namespace


SearchProperty Members

[image] [image]

SQL Data Compare API 12.0.40
SearchProperty Members
SearchProperty Class Methods Properties See Also

The SearchProperty type exposes the following members.

Methods

Name | Description
Equals | (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | A description of the property
GuidOfSet | An identifier for the property set the property belongs to
IdInSet | Which property in the property set to use
InternalID | SQL Server's internal id for this instance of the property
Name | The name of the property

See Also

SearchProperty Class
RedGate.SQLCompare.Engine Namespace


SearchProperty Methods

[image] [image]

SQL Data Compare API 12.0.40
SearchProperty Methods
SearchProperty Class See Also

The SearchProperty type exposes the following methods.

Methods

Name | Description
Equals | (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SearchProperty Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image]

SQL Data Compare API 12.0.40
SearchProperty..::.Equals Method
SearchProperty Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object

See Also

SearchProperty Class
RedGate.SQLCompare.Engine Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
SearchProperty..::.GetHashCode Method
SearchProperty Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

See Also

SearchProperty Class
RedGate.SQLCompare.Engine Namespace


SearchProperty Properties

[image] [image]

SQL Data Compare API 12.0.40
SearchProperty Properties
SearchProperty Class See Also

The SearchProperty type exposes the following properties.

Properties

Name | Description
Description | A description of the property
GuidOfSet | An identifier for the property set the property belongs to
IdInSet | Which property in the property set to use
InternalID | SQL Server's internal id for this instance of the property
Name | The name of the property

See Also

SearchProperty Class
RedGate.SQLCompare.Engine Namespace


Description Property

[image]

SQL Data Compare API 12.0.40
SearchProperty..::.Description Property
SearchProperty Class See Also

A description of the property

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; private set; }
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

SearchProperty Class
RedGate.SQLCompare.Engine Namespace


GuidOfSet Property

[image]

SQL Data Compare API 12.0.40
SearchProperty..::.GuidOfSet Property
SearchProperty Class See Also

An identifier for the property set the property belongs to

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property GuidOfSet As Guid
C#
public Guid GuidOfSet { get; private set; }
Visual C++
public:
property Guid GuidOfSet {
    Guid get ();
    void set (Guid value);
}

See Also

SearchProperty Class
RedGate.SQLCompare.Engine Namespace


IdInSet Property

[image]

SQL Data Compare API 12.0.40
SearchProperty..::.IdInSet Property
SearchProperty Class See Also

Which property in the property set to use

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IdInSet As Integer
C#
public int IdInSet { get; private set; }
Visual C++
public:
property int IdInSet {
    int get ();
    void set (int value);
}

See Also

SearchProperty Class
RedGate.SQLCompare.Engine Namespace


InternalID Property

[image]

SQL Data Compare API 12.0.40
SearchProperty..::.InternalID Property
SearchProperty Class See Also

SQL Server's internal id for this instance of the property

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property InternalID As Integer
C#
public int InternalID { get; private set; }
Visual C++
public:
property int InternalID {
    int get ();
    void set (int value);
}

See Also

SearchProperty Class
RedGate.SQLCompare.Engine Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
SearchProperty..::.Name Property
SearchProperty Class See Also

The name of the property

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; private set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

SearchProperty Class
RedGate.SQLCompare.Engine Namespace


SearchPropertyList Class

[image]

SQL Data Compare API 12.0.40
SearchPropertyList Class
Members See Also

A list of search properties we can attach to a fulltext index which lets the index search those properties on a document as well as the document text

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SearchPropertyList _
    Inherits DatabaseObjectWithAuthorization _
    Implements IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck,  _
    IPatchUpAfterDeserialization, ISqlComparable
C#
public class SearchPropertyList : DatabaseObjectWithAuthorization, IHasPermissions,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, IPatchUpAfterDeserialization, ISqlComparable
Visual C++
public ref class SearchPropertyList : public DatabaseObjectWithAuthorization,
    IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck, IPatchUpAfterDeserialization,
    ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.SearchPropertyList

See Also

SearchPropertyList Members
RedGate.SQLCompare.Engine Namespace


SearchPropertyList Members

[image] [image]

SQL Data Compare API 12.0.40
SearchPropertyList Members
SearchPropertyList Class Constructors Methods Fields Properties Explicit Interface Implementations See Also

The SearchPropertyList type exposes the following members.

Constructors

Name | Description
SearchPropertyList | Overloaded.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AlterAuthorizationClassType | (Overrides DatabaseObjectWithAuthorization ..::. AlterAuthorizationClassType.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtraScriptSources | Since the property list can only be created with extra ALTER statements, we can have multiple script sources. ScriptSource always refers to the main CREATE statement and these refer to the ADD PROPERTY statements. When a scripts folder is modified, then all of these sources are blanked out and ScriptSource is replaced with the full SQL for the SPL to try and keep things tidy.
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | The type of the object. (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions |
PropertyList |
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

SearchPropertyList Class
RedGate.SQLCompare.Engine Namespace


SearchPropertyList Constructor

[image] [image]

SQL Data Compare API 12.0.40
SearchPropertyList Constructor
SearchPropertyList Class See Also

Overload List

Name | Description
SearchPropertyList(NullableBinaryReader) |
SearchPropertyList(String, String, Int32, Boolean, Database) |

See Also

SearchPropertyList Class
SearchPropertyList Members
RedGate.SQLCompare.Engine Namespace


SearchPropertyList Constructor ()

[image]

SQL Data Compare API 12.0.40
SearchPropertyList Constructor ()
SearchPropertyList Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    reader As NullableBinaryReader _
)
C#
public SearchPropertyList(
    NullableBinaryReader reader
)
Visual C++
public:
SearchPropertyList(
    NullableBinaryReader^ reader
)

Parameters

reader
Type: NullableBinaryReader

See Also

SearchPropertyList Class
SearchPropertyList Overload
RedGate.SQLCompare.Engine Namespace


SearchPropertyList Constructor (, , , , Database)

[image]

SQL Data Compare API 12.0.40
SearchPropertyList Constructor (, , , , Database)
SearchPropertyList Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    owner As String, _
    name As String, _
    id As Integer, _
    caseSensitive As Boolean, _
    database As Database _
)
C#
public SearchPropertyList(
    string owner,
    string name,
    int id,
    bool caseSensitive,
    Database database
)
Visual C++
public:
SearchPropertyList(
    String^ owner,
    String^ name,
    int id,
    bool caseSensitive,
    Database^ database
)

Parameters

owner
Type: String
name
Type: String
id
Type: Int32
caseSensitive
Type: Boolean
database
Type: RedGate.SQLCompare.Engine..::.Database

See Also

SearchPropertyList Class
SearchPropertyList Overload
RedGate.SQLCompare.Engine Namespace


SearchPropertyList Methods

[image] [image]

SQL Data Compare API 12.0.40
SearchPropertyList Methods
SearchPropertyList Class See Also

The SearchPropertyList type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

SearchPropertyList Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
SearchPropertyList..::.ISqlComparable..::.CompareWith Method
SearchPropertyList Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    other As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable other,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ other,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

other
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

SearchPropertyList Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
SearchPropertyList..::.Equals Method
SearchPropertyList Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares two database objects. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

SearchPropertyList Class
SearchPropertyList Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
SearchPropertyList..::.Equals Method (IDatabaseObject, Options)
SearchPropertyList Class See Also

Compares two database objects.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) override

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The object to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
The comparison options.

Return Value

True if the database objects are identical; otherwise false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

SearchPropertyList Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
SearchPropertyList..::.PatchUpAfterDeserialization Method
SearchPropertyList Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

SearchPropertyList Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
SearchPropertyList..::.ScriptObject Method
SearchPropertyList Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options, e.g. quoted identifier on or off.
options
Type: RedGate.SQLCompare.Engine..::.Options
Options that may influence the scripting.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

SearchPropertyList Class
RedGate.SQLCompare.Engine Namespace


SearchPropertyList Properties

[image] [image]

SQL Data Compare API 12.0.40
SearchPropertyList Properties
SearchPropertyList Class See Also

The SearchPropertyList type exposes the following properties.

Properties

Name | Description
AlterAuthorizationClassType | (Overrides DatabaseObjectWithAuthorization ..::. AlterAuthorizationClassType.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtraScriptSources | Since the property list can only be created with extra ALTER statements, we can have multiple script sources. ScriptSource always refers to the main CREATE statement and these refer to the ADD PROPERTY statements. When a scripts folder is modified, then all of these sources are blanked out and ScriptSource is replaced with the full SQL for the SPL to try and keep things tidy.
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | The type of the object. (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions |
PropertyList |
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)

See Also

SearchPropertyList Class
RedGate.SQLCompare.Engine Namespace


AlterAuthorizationClassType Property

[image]

SQL Data Compare API 12.0.40
SearchPropertyList..::.AlterAuthorizationClassType Property
SearchPropertyList Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property AlterAuthorizationClassType As String
C#
public override string AlterAuthorizationClassType { get; }
Visual C++
public:
virtual property String^ AlterAuthorizationClassType {
    String^ get () override;
}

Implements

IHasAuthorization..::.AlterAuthorizationClassType

See Also

SearchPropertyList Class
RedGate.SQLCompare.Engine Namespace


ExtraScriptSources Property

[image]

SQL Data Compare API 12.0.40
SearchPropertyList..::.ExtraScriptSources Property
SearchPropertyList Class See Also

Since the property list can only be created with extra ALTER statements, we can have multiple script sources. ScriptSource always refers to the main CREATE statement and these refer to the ADD PROPERTY statements. When a scripts folder is modified, then all of these sources are blanked out and ScriptSource is replaced with the full SQL for the SPL to try and keep things tidy.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtraScriptSources As List(Of ScriptSource)
C#
public List<ScriptSource> ExtraScriptSources { get; internal set; }
Visual C++
public:
property List<ScriptSource^>^ ExtraScriptSources {
    List<ScriptSource^>^ get ();
    void set (List<ScriptSource^>^ value);
}

See Also

SearchPropertyList Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
SearchPropertyList..::.ObjectType Property
SearchPropertyList Class See Also

The type of the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()
ITSqlObjectObjectType()()()

See Also

SearchPropertyList Class
RedGate.SQLCompare.Engine Namespace


Permissions Property

[image]

SQL Data Compare API 12.0.40
SearchPropertyList..::.Permissions Property
SearchPropertyList Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Permissions As Permissions
C#
public Permissions Permissions { get; protected set; }
Visual C++
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
    void set (Permissions^ value) sealed;
}

Implements

IHasPermissions..::.Permissions

See Also

SearchPropertyList Class
RedGate.SQLCompare.Engine Namespace


PropertyList Property

[image]

SQL Data Compare API 12.0.40
SearchPropertyList..::.PropertyList Property
SearchPropertyList Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PropertyList As List(Of SearchProperty)
C#
public List<SearchProperty> PropertyList { get; internal set; }
Visual C++
public:
property List<SearchProperty^>^ PropertyList {
    List<SearchProperty^>^ get ();
    void set (List<SearchProperty^>^ value);
}

See Also

SearchPropertyList Class
RedGate.SQLCompare.Engine Namespace


SearchPropertyLists Class

[image]

SQL Data Compare API 12.0.40
SearchPropertyLists Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SearchPropertyLists _
    Inherits SerializableDatabaseObjectCollection(Of SearchPropertyList) _
    Implements IPatchUpAfterDeserialization
C#
public class SearchPropertyLists : SerializableDatabaseObjectCollection<SearchPropertyList>, IPatchUpAfterDeserialization
Visual C++
public ref class SearchPropertyLists : public SerializableDatabaseObjectCollection<SearchPropertyList^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( SearchPropertyList >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( SearchPropertyList >)>)
RedGate.SQLCompare.Engine..::.SearchPropertyLists

See Also

SearchPropertyLists Members
RedGate.SQLCompare.Engine Namespace


SearchPropertyLists Members

[image] [image]

SQL Data Compare API 12.0.40
SearchPropertyLists Members
SearchPropertyLists Class Constructors Methods Fields Properties Explicit Interface Implementations See Also

The SearchPropertyLists type exposes the following members.

Constructors

Name | Description
SearchPropertyLists | Overloaded.

Methods

Name | Description
Add | Overloaded.
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
DeserializeItem | For internal use (Overrides SerializableCollection <(Of <( SearchPropertyList >)>)..::.DeserializeItem(NullableBinaryReader).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SerializeItem | For internal use (Overrides SerializableCollection <(Of <( SearchPropertyList >)>)..::.SerializeItem(UTP, NullableBinaryWriter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

SearchPropertyLists Class
RedGate.SQLCompare.Engine Namespace


SearchPropertyLists Constructor

[image] [image]

SQL Data Compare API 12.0.40
SearchPropertyLists Constructor
SearchPropertyLists Class See Also

Overload List

Name | Description
SearchPropertyLists(NullableBinaryReader) |
SearchPropertyLists(Boolean) |

See Also

SearchPropertyLists Class
SearchPropertyLists Members
RedGate.SQLCompare.Engine Namespace


SearchPropertyLists Constructor ()

[image]

SQL Data Compare API 12.0.40
SearchPropertyLists Constructor ()
SearchPropertyLists Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    reader As NullableBinaryReader _
)
C#
public SearchPropertyLists(
    NullableBinaryReader reader
)
Visual C++
public:
SearchPropertyLists(
    NullableBinaryReader^ reader
)

Parameters

reader
Type: NullableBinaryReader

See Also

SearchPropertyLists Class
SearchPropertyLists Overload
RedGate.SQLCompare.Engine Namespace


SearchPropertyLists Constructor ()

[image]

SQL Data Compare API 12.0.40
SearchPropertyLists Constructor ()
SearchPropertyLists Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public SearchPropertyLists(
    bool caseSensitive
)
Visual C++
public:
SearchPropertyLists(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

SearchPropertyLists Class
SearchPropertyLists Overload
RedGate.SQLCompare.Engine Namespace


SearchPropertyLists Methods

[image] [image]

SQL Data Compare API 12.0.40
SearchPropertyLists Methods
SearchPropertyLists Class See Also

The SearchPropertyLists type exposes the following methods.

Methods

Name | Description
Add | Overloaded.
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
DeserializeItem | For internal use (Overrides SerializableCollection <(Of <( SearchPropertyList >)>)..::.DeserializeItem(NullableBinaryReader).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SerializeItem | For internal use (Overrides SerializableCollection <(Of <( SearchPropertyList >)>)..::.SerializeItem(UTP, NullableBinaryWriter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

SearchPropertyLists Class
RedGate.SQLCompare.Engine Namespace


Add Method

[image] [image]

SQL Data Compare API 12.0.40
SearchPropertyLists..::.Add Method
SearchPropertyLists Class See Also

Overload List

Name | Description
Add(T) | (Inherited from KeyedCollection<(Of <(T>)>).)
Add(SearchPropertyList) | (Overrides SerializableDatabaseObjectCollection <(Of <( SearchPropertyList >)>)..::. Add(T).)

See Also

SearchPropertyLists Class
SearchPropertyLists Members
RedGate.SQLCompare.Engine Namespace


Add Method (SearchPropertyList)

[image]

SQL Data Compare API 12.0.40
SearchPropertyLists..::.Add Method (SearchPropertyList)
SearchPropertyLists Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Add ( _
    value As SearchPropertyList _
)
C#
public override void Add(
    SearchPropertyList value
)
Visual C++
public:
virtual void Add(
    SearchPropertyList^ value
) override

Parameters

value
Type: RedGate.SQLCompare.Engine..::.SearchPropertyList

See Also

SearchPropertyLists Class
Add Overload
RedGate.SQLCompare.Engine Namespace


DeserializeItem Method

[image]

SQL Data Compare API 12.0.40
SearchPropertyLists..::.DeserializeItem Method
SearchPropertyLists Class See Also

For internal use

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Friend Overrides Function DeserializeItem ( _
    reader As NullableBinaryReader _
) As SearchPropertyList
C#
protected internal override SearchPropertyList DeserializeItem(
    NullableBinaryReader reader
)
Visual C++
protected public:
virtual SearchPropertyList^ DeserializeItem(
    NullableBinaryReader^ reader
) override

Parameters

reader
Type: NullableBinaryReader

See Also

SearchPropertyLists Class
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
SearchPropertyLists..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
SearchPropertyLists Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

SearchPropertyLists Class
RedGate.SQLCompare.Engine Namespace


SerializeItem Method

[image]

SQL Data Compare API 12.0.40
SearchPropertyLists..::.SerializeItem Method
SearchPropertyLists Class See Also

For internal use

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Friend Overrides Sub SerializeItem ( _
    value As SearchPropertyList, _
    writer As NullableBinaryWriter _
)
C#
protected internal override void SerializeItem(
    SearchPropertyList value,
    NullableBinaryWriter writer
)
Visual C++
protected public:
virtual void SerializeItem(
    SearchPropertyList^ value,
    NullableBinaryWriter^ writer
) override

Parameters

value
Type: RedGate.SQLCompare.Engine..::.SearchPropertyList
writer
Type: NullableBinaryWriter

See Also

SearchPropertyLists Class
RedGate.SQLCompare.Engine Namespace


SearchPropertyListsChanges Class

[image]

SQL Data Compare API 12.0.40
SearchPropertyListsChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SearchPropertyListsChanges
C#
public sealed class SearchPropertyListsChanges
Visual C++
public ref class SearchPropertyListsChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.SearchPropertyListsChanges

See Also

SearchPropertyListsChanges Members
RedGate.SQLCompare.Engine Namespace


SearchPropertyListsChanges Members

[image] [image]

SQL Data Compare API 12.0.40
SearchPropertyListsChanges Members
SearchPropertyListsChanges Class Constructors Methods Properties See Also

The SearchPropertyListsChanges type exposes the following members.

Constructors

Name | Description
SearchPropertyListsChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
SearchPropertyListsToAlter |
SearchPropertyListsToCreate |
SearchPropertyListsToDrop |
SearchPropertyListTargets |

See Also

SearchPropertyListsChanges Class
RedGate.SQLCompare.Engine Namespace


SearchPropertyListsChanges Constructor

[image]

SQL Data Compare API 12.0.40
SearchPropertyListsChanges Constructor
SearchPropertyListsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public SearchPropertyListsChanges(
    bool caseSensitive
)
Visual C++
public:
SearchPropertyListsChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

SearchPropertyListsChanges Class
RedGate.SQLCompare.Engine Namespace


SearchPropertyListsChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
SearchPropertyListsChanges Properties
SearchPropertyListsChanges Class See Also

The SearchPropertyListsChanges type exposes the following properties.

Properties

Name | Description
SearchPropertyListsToAlter |
SearchPropertyListsToCreate |
SearchPropertyListsToDrop |
SearchPropertyListTargets |

See Also

SearchPropertyListsChanges Class
RedGate.SQLCompare.Engine Namespace


SearchPropertyListsToAlter Property

[image]

SQL Data Compare API 12.0.40
SearchPropertyListsChanges..::.SearchPropertyListsToAlter Property
SearchPropertyListsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SearchPropertyListsToAlter As SearchPropertyLists
C#
public SearchPropertyLists SearchPropertyListsToAlter { get; private set; }
Visual C++
public:
property SearchPropertyLists^ SearchPropertyListsToAlter {
    SearchPropertyLists^ get ();
    void set (SearchPropertyLists^ value);
}

See Also

SearchPropertyListsChanges Class
RedGate.SQLCompare.Engine Namespace


SearchPropertyListsToCreate Property

[image]

SQL Data Compare API 12.0.40
SearchPropertyListsChanges..::.SearchPropertyListsToCreate Property
SearchPropertyListsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SearchPropertyListsToCreate As SearchPropertyLists
C#
public SearchPropertyLists SearchPropertyListsToCreate { get; private set; }
Visual C++
public:
property SearchPropertyLists^ SearchPropertyListsToCreate {
    SearchPropertyLists^ get ();
    void set (SearchPropertyLists^ value);
}

See Also

SearchPropertyListsChanges Class
RedGate.SQLCompare.Engine Namespace


SearchPropertyListsToDrop Property

[image]

SQL Data Compare API 12.0.40
SearchPropertyListsChanges..::.SearchPropertyListsToDrop Property
SearchPropertyListsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SearchPropertyListsToDrop As SearchPropertyLists
C#
public SearchPropertyLists SearchPropertyListsToDrop { get; private set; }
Visual C++
public:
property SearchPropertyLists^ SearchPropertyListsToDrop {
    SearchPropertyLists^ get ();
    void set (SearchPropertyLists^ value);
}

See Also

SearchPropertyListsChanges Class
RedGate.SQLCompare.Engine Namespace


SearchPropertyListTargets Property

[image]

SQL Data Compare API 12.0.40
SearchPropertyListsChanges..::.SearchPropertyListTargets Property
SearchPropertyListsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SearchPropertyListTargets As Dictionary(Of SearchPropertyList, SearchPropertyList)
C#
public Dictionary<SearchPropertyList, SearchPropertyList> SearchPropertyListTargets { get; private set; }
Visual C++
public:
property Dictionary<SearchPropertyList^, SearchPropertyList^>^ SearchPropertyListTargets {
    Dictionary<SearchPropertyList^, SearchPropertyList^>^ get ();
    void set (Dictionary<SearchPropertyList^, SearchPropertyList^>^ value);
}

See Also

SearchPropertyListsChanges Class
RedGate.SQLCompare.Engine Namespace


SecurableType Enumeration

[image]

SQL Data Compare API 12.0.40
SecurableType Enumeration
See Also

The class on which the permission exists.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration SecurableType
C#
public enum SecurableType
Visual C++
public enum class SecurableType

Members

Member name | Description
Other | None, this is used for error handling.
Database | Database.
ObjectOrColumn | Object or column. Prior to SQL Server 2005, this is the only permission class used.
Schema | Schema.
DatabasePrincipal | Database principal.
Assembly | Assembly.
Type | Type.
XmlSchemaCollection | XML schema collection.
MessageType | Message type.
ServiceContract | Service contract.
Service | Service.
RemoteServiceBinding | Remote service binding.
Route | Route.
FullTextCatalog | Full text catalog.
SymmetricKey | Symmetric key.
AsymmetricKey | Asymmetric key.
Certificate | Certificate.
SearchPropertyList | Search Property List.

See Also

RedGate.SQLCompare.Engine Namespace


.ComparableByteArray Class

[image]

SQL Data Compare API 12.0.40
..::.ComparableByteArray Class
SelectedSyncObjects Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Class ComparableByteArray _
    Implements IComparable, ICloneable
C#
public class ComparableByteArray : IComparable,
    ICloneable
Visual C++
public ref class ComparableByteArray : IComparable,
    ICloneable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.SelectedSyncObjects..::.ComparableByteArray

See Also

SelectedSyncObjects..::.ComparableByteArray Members
RedGate.SQLCompare.Engine Namespace


.ComparableByteArray Members

[image] [image]

SQL Data Compare API 12.0.40
..::.ComparableByteArray Members
SelectedSyncObjects..::.ComparableByteArray Class Constructors Methods Properties See Also

The SelectedSyncObjects..::.ComparableByteArray type exposes the following members.

Constructors

Name | Description
SelectedSyncObjects..::.ComparableByteArray | Overloaded.

Methods

Name | Description
Clone |
CompareTo |
Equals | (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Bytes |
Version |

See Also

SelectedSyncObjects..::.ComparableByteArray Class
RedGate.SQLCompare.Engine Namespace


.ComparableByteArray Constructor

[image] [image]

SQL Data Compare API 12.0.40
..::.ComparableByteArray Constructor
SelectedSyncObjects..::.ComparableByteArray Class See Also

Overload List

Name | Description
SelectedSyncObjects..::.ComparableByteArray()()() |
SelectedSyncObjects..::.ComparableByteArray(array<Byte>[]()[]) |

See Also

SelectedSyncObjects..::.ComparableByteArray Class
SelectedSyncObjects..::.ComparableByteArray Members
RedGate.SQLCompare.Engine Namespace


.ComparableByteArray Constructor

[image]

SQL Data Compare API 12.0.40
..::.ComparableByteArray Constructor
SelectedSyncObjects..::.ComparableByteArray Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ComparableByteArray()
Visual C++
public:
ComparableByteArray()

See Also

SelectedSyncObjects..::.ComparableByteArray Class
SelectedSyncObjects..::.ComparableByteArray Overload
RedGate.SQLCompare.Engine Namespace


.ComparableByteArray Constructor ([])

[image]

SQL Data Compare API 12.0.40
..::.ComparableByteArray Constructor (array<>[]()[])
SelectedSyncObjects..::.ComparableByteArray Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    byteArray As Byte() _
)
C#
public ComparableByteArray(
    byte[] byteArray
)
Visual C++
public:
ComparableByteArray(
    array<unsigned char>^ byteArray
)

Parameters

byteArray
Type: array<Byte>[]()[]

See Also

SelectedSyncObjects..::.ComparableByteArray Class
SelectedSyncObjects..::.ComparableByteArray Overload
RedGate.SQLCompare.Engine Namespace


.ComparableByteArray Methods

[image] [image]

SQL Data Compare API 12.0.40
..::.ComparableByteArray Methods
SelectedSyncObjects..::.ComparableByteArray Class See Also

The SelectedSyncObjects..::.ComparableByteArray type exposes the following methods.

Methods

Name | Description
Clone |
CompareTo |
Equals | (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelectedSyncObjects..::.ComparableByteArray Class
RedGate.SQLCompare.Engine Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
..::.ComparableByteArray..::.Clone Method
SelectedSyncObjects..::.ComparableByteArray Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone As Object
C#
public Object Clone()
Visual C++
public:
virtual Object^ Clone() sealed

Implements

ICloneableClone()()()

See Also

SelectedSyncObjects..::.ComparableByteArray Class
RedGate.SQLCompare.Engine Namespace


CompareTo Method

[image]

SQL Data Compare API 12.0.40
..::.ComparableByteArray..::.CompareTo Method
SelectedSyncObjects..::.ComparableByteArray Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareTo ( _
    o As Object _
) As Integer
C#
public int CompareTo(
    Object o
)
Visual C++
public:
virtual int CompareTo(
    Object^ o
) sealed

Parameters

o
Type: Object

Implements

IComparableCompareTo(Object)

See Also

SelectedSyncObjects..::.ComparableByteArray Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image]

SQL Data Compare API 12.0.40
..::.ComparableByteArray..::.Equals Method
SelectedSyncObjects..::.ComparableByteArray Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object

See Also

SelectedSyncObjects..::.ComparableByteArray Class
RedGate.SQLCompare.Engine Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
..::.ComparableByteArray..::.GetHashCode Method
SelectedSyncObjects..::.ComparableByteArray Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

See Also

SelectedSyncObjects..::.ComparableByteArray Class
RedGate.SQLCompare.Engine Namespace


.ComparableByteArray Properties

[image] [image]

SQL Data Compare API 12.0.40
..::.ComparableByteArray Properties
SelectedSyncObjects..::.ComparableByteArray Class See Also

The SelectedSyncObjects..::.ComparableByteArray type exposes the following properties.

Properties

Name | Description
Bytes |
Version |

See Also

SelectedSyncObjects..::.ComparableByteArray Class
RedGate.SQLCompare.Engine Namespace


Bytes Property

[image]

SQL Data Compare API 12.0.40
..::.ComparableByteArray..::.Bytes Property
SelectedSyncObjects..::.ComparableByteArray Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property Bytes As Byte()
C#
public byte[] Bytes { get; set; }
Visual C++
public:
property array<unsigned char>^ Bytes {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

SelectedSyncObjects..::.ComparableByteArray Class
RedGate.SQLCompare.Engine Namespace


Version Property

[image]

SQL Data Compare API 12.0.40
..::.ComparableByteArray..::.Version Property
SelectedSyncObjects..::.ComparableByteArray Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As Integer
C#
public int Version { get; }
Visual C++
public:
property int Version {
    int get ();
}

See Also

SelectedSyncObjects..::.ComparableByteArray Class
RedGate.SQLCompare.Engine Namespace


.HitValue Class

[image]

SQL Data Compare API 12.0.40
..::.HitValue Class
SelectedSyncObjects Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Class HitValue
C#
public class HitValue
Visual C++
public ref class HitValue

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.SelectedSyncObjects..::.HitValue

See Also

SelectedSyncObjects..::.HitValue Members
RedGate.SQLCompare.Engine Namespace


.HitValue Members

[image] [image]

SQL Data Compare API 12.0.40
..::.HitValue Members
SelectedSyncObjects..::.HitValue Class Constructors Methods Properties See Also

The SelectedSyncObjects..::.HitValue type exposes the following members.

Constructors

Name | Description
SelectedSyncObjects..::.HitValue | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ResetHit |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Byte |
Hit |

See Also

SelectedSyncObjects..::.HitValue Class
RedGate.SQLCompare.Engine Namespace


.HitValue Constructor

[image] [image]

SQL Data Compare API 12.0.40
..::.HitValue Constructor
SelectedSyncObjects..::.HitValue Class See Also

Overload List

Name | Description
SelectedSyncObjects..::.HitValue(Byte) |
SelectedSyncObjects..::.HitValue(Byte, Boolean) |

See Also

SelectedSyncObjects..::.HitValue Class
SelectedSyncObjects..::.HitValue Members
RedGate.SQLCompare.Engine Namespace


.HitValue Constructor ()

[image]

SQL Data Compare API 12.0.40
..::.HitValue Constructor ()
SelectedSyncObjects..::.HitValue Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    b As Byte _
)
C#
public HitValue(
    byte b
)
Visual C++
public:
HitValue(
    unsigned char b
)

Parameters

b
Type: Byte

See Also

SelectedSyncObjects..::.HitValue Class
SelectedSyncObjects..::.HitValue Overload
RedGate.SQLCompare.Engine Namespace


.HitValue Constructor (, )

[image]

SQL Data Compare API 12.0.40
..::.HitValue Constructor (, )
SelectedSyncObjects..::.HitValue Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    b As Byte, _
    hit As Boolean _
)
C#
public HitValue(
    byte b,
    bool hit
)
Visual C++
public:
HitValue(
    unsigned char b,
    bool hit
)

Parameters

b
Type: Byte
hit
Type: Boolean

See Also

SelectedSyncObjects..::.HitValue Class
SelectedSyncObjects..::.HitValue Overload
RedGate.SQLCompare.Engine Namespace


.HitValue Methods

[image] [image]

SQL Data Compare API 12.0.40
..::.HitValue Methods
SelectedSyncObjects..::.HitValue Class See Also

The SelectedSyncObjects..::.HitValue type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ResetHit |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelectedSyncObjects..::.HitValue Class
RedGate.SQLCompare.Engine Namespace


ResetHit Method

[image]

SQL Data Compare API 12.0.40
..::.HitValue..::.ResetHit Method
SelectedSyncObjects..::.HitValue Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub ResetHit
C#
public void ResetHit()
Visual C++
public:
void ResetHit()

See Also

SelectedSyncObjects..::.HitValue Class
RedGate.SQLCompare.Engine Namespace


.HitValue Properties

[image] [image]

SQL Data Compare API 12.0.40
..::.HitValue Properties
SelectedSyncObjects..::.HitValue Class See Also

The SelectedSyncObjects..::.HitValue type exposes the following properties.

Properties

Name | Description
Byte |
Hit |

See Also

SelectedSyncObjects..::.HitValue Class
RedGate.SQLCompare.Engine Namespace


Byte Property

[image]

SQL Data Compare API 12.0.40
..::.HitValue..::.Byte Property
SelectedSyncObjects..::.HitValue Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property Byte As Byte
C#
public byte Byte { get; set; }
Visual C++
public:
property unsigned char Byte {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

SelectedSyncObjects..::.HitValue Class
RedGate.SQLCompare.Engine Namespace


Hit Property

[image]

SQL Data Compare API 12.0.40
..::.HitValue..::.Hit Property
SelectedSyncObjects..::.HitValue Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property Hit As Boolean
C#
public bool Hit { get; set; }
Visual C++
public:
property bool Hit {
    bool get ();
    void set (bool value);
}

See Also

SelectedSyncObjects..::.HitValue Class
RedGate.SQLCompare.Engine Namespace


SelectTableEvent Structure

[image]

SQL Data Compare API 12.0.40
SelectTableEvent Structure
Members See Also

Struct representing a user action

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Structure SelectTableEvent
C#
public struct SelectTableEvent
Visual C++
public value class SelectTableEvent

See Also

SelectTableEvent Members
RedGate.SQLCompare.Engine Namespace


SelectTableEvent Members

[image] [image]

SQL Data Compare API 12.0.40
SelectTableEvent Members
SelectTableEvent Structure Constructors Methods Fields Properties See Also

The SelectTableEvent type exposes the following members.

Constructors

Name | Description
SelectTableEvent | Creates a new select table event

Methods

Name | Description
Deserialize | Serialization support
Equals | (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serialization support
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

Name | Description
action | An enum denoting which action was performed
data | Some data about the action

Properties

Name | Description
Version | For serialization. The current version

See Also

SelectTableEvent Structure
RedGate.SQLCompare.Engine Namespace


SelectTableEvent Constructor

[image]

SQL Data Compare API 12.0.40
SelectTableEvent Constructor
SelectTableEvent Structure See Also

Creates a new select table event

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    action As SelectTableEventAction, _
    data As Object _
)
C#
public SelectTableEvent(
    SelectTableEventAction action,
    Object data
)
Visual C++
public:
SelectTableEvent(
    SelectTableEventAction action,
    Object^ data
)

Parameters

action
Type: RedGate.SQLCompare.Engine..::.SelectTableEventAction
The action performed
data
Type: Object
The assosciated data for that action

See Also

SelectTableEvent Structure
RedGate.SQLCompare.Engine Namespace


SelectTableEvent Fields

[image] [image]

SQL Data Compare API 12.0.40
SelectTableEvent Fields
SelectTableEvent Structure See Also

The SelectTableEvent type exposes the following fields.

Fields

Name | Description
action | An enum denoting which action was performed
data | Some data about the action

See Also

SelectTableEvent Structure
RedGate.SQLCompare.Engine Namespace


action Field

[image]

SQL Data Compare API 12.0.40
SelectTableEvent..::.action Field
SelectTableEvent Structure See Also

An enum denoting which action was performed

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public action As SelectTableEventAction
C#
public SelectTableEventAction action
Visual C++
public:
SelectTableEventAction action

See Also

SelectTableEvent Structure
RedGate.SQLCompare.Engine Namespace


data Field

[image]

SQL Data Compare API 12.0.40
SelectTableEvent..::.data Field
SelectTableEvent Structure See Also

Some data about the action

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public data As Object
C#
public Object data
Visual C++
public:
Object^ data

See Also

SelectTableEvent Structure
RedGate.SQLCompare.Engine Namespace


SelectTableEvent Methods

[image] [image]

SQL Data Compare API 12.0.40
SelectTableEvent Methods
SelectTableEvent Structure See Also

The SelectTableEvent type exposes the following methods.

Methods

Name | Description
Deserialize | Serialization support
Equals | (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serialization support
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

SelectTableEvent Structure
RedGate.SQLCompare.Engine Namespace


Deserialize Method

[image]

SQL Data Compare API 12.0.40
SelectTableEvent..::.Deserialize Method
SelectTableEvent Structure See Also

Serialization support

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Function Deserialize ( _
    nVersionId As Integer, _
    obj As ISerializeFormatter _
) As Boolean
C#
public bool Deserialize(
    int nVersionId,
    ISerializeFormatter obj
)
Visual C++
public:
virtual bool Deserialize(
    int nVersionId,
    ISerializeFormatter^ obj
) sealed

Parameters

nVersionId
Type: Int32
The version we are deserializng
obj
Type: ISerializeFormatter
The assosciated formatter

See Also

SelectTableEvent Structure
RedGate.SQLCompare.Engine Namespace


Equals Method

[image]

SQL Data Compare API 12.0.40
SelectTableEvent..::.Equals Method
SelectTableEvent Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object

See Also

SelectTableEvent Structure
RedGate.SQLCompare.Engine Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
SelectTableEvent..::.GetHashCode Method
SelectTableEvent Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

See Also

SelectTableEvent Structure
RedGate.SQLCompare.Engine Namespace


Serialize Method

[image]

SQL Data Compare API 12.0.40
SelectTableEvent..::.Serialize Method
SelectTableEvent Structure See Also

Serialization support

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub Serialize ( _
    obj As ISerializeFormatter _
)
C#
public void Serialize(
    ISerializeFormatter obj
)
Visual C++
public:
virtual void Serialize(
    ISerializeFormatter^ obj
) sealed

Parameters

obj
Type: ISerializeFormatter
THe formatter to write out to

See Also

SelectTableEvent Structure
RedGate.SQLCompare.Engine Namespace


SelectTableEvent Properties

[image] [image]

SQL Data Compare API 12.0.40
SelectTableEvent Properties
SelectTableEvent Structure See Also

The SelectTableEvent type exposes the following properties.

Properties

Name | Description
Version | For serialization. The current version

See Also

SelectTableEvent Structure
RedGate.SQLCompare.Engine Namespace


Version Property

[image]

SQL Data Compare API 12.0.40
SelectTableEvent..::.Version Property
SelectTableEvent Structure See Also

For serialization. The current version

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As Integer
C#
public int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () sealed;
}

See Also

SelectTableEvent Structure
RedGate.SQLCompare.Engine Namespace


SelectTableEventAction Enumeration

[image]

SQL Data Compare API 12.0.40
SelectTableEventAction Enumeration
See Also

An enum stating which action the user made

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration SelectTableEventAction
C#
public enum SelectTableEventAction
Visual C++
public enum class SelectTableEventAction

Members

Member name | Description
None | Not used
SelectAll | Enum value used to represent a select all event
SelectItem | Enum value used to represent a select item event
DeselectAll | Enum value used to represent a deselect all event
DeselectItem | Enum value used to represent a deselect item event
SelectColumn | Enum value used to represent a select column event
DeselectColumn | Enum value used to represent a deselect column event
UseKey | Enum value used to represent a comparison key selection event
UseCustomKey | Enum value used to represent the user choosing to use a custom key
SelectColumnAsKey | Enum value used to represent the user choosing a column for thier key
DeselectColumnAsKey | Enum value used to represent the user choosing not to use a column for their key
SetLeftWhereClause | Enum value used to represent the user setting a left where caluse
SetRightWhereClause | Enum value used to represent the user setting a right where caluse
MapTables | Enum value used to represent the user mapping two tables
UnmapTables | Enum value used to represent the user unmapping two tables
MapColumn | Enum value used to represent the user mapping two columns
UnmapColumns | Enum value used to represent the user unmapping two columns
MapOwners | Enum value used to represent the user mapping two owners
UnmapOwners | Enum value used to represent the user unmapping two owners

See Also

RedGate.SQLCompare.Engine Namespace


Sequence Class

[image]

SQL Data Compare API 12.0.40
Sequence Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class Sequence _
    Inherits SchemaObjectWithAuthorization _
    Implements IDatabaseObject, ITSqlObject, ICanExistenceCheck, IPatchUpAfterDeserialization,  _
    ISqlComparable
C#
public class Sequence : SchemaObjectWithAuthorization, IDatabaseObject,
    ITSqlObject, ICanExistenceCheck, IPatchUpAfterDeserialization, ISqlComparable
Visual C++
public ref class Sequence : public SchemaObjectWithAuthorization,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, IPatchUpAfterDeserialization, ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.SchemaObjectWithAuthorization
RedGate.SQLCompare.Engine..::.Sequence

See Also

Sequence Members
RedGate.SQLCompare.Engine Namespace


Sequence Members

[image] [image]

SQL Data Compare API 12.0.40
Sequence Members
Sequence Class Constructors Methods Fields Properties Explicit Interface Implementations See Also

The Sequence type exposes the following members.

Constructors

Name | Description
Sequence | Overloaded.

Methods

Name | Description
CompareWith |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AlterAuthorizationClassType | (Inherited from SchemaObjectWithAuthorization.)
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
CacheSize |
CurrentValue |
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Increment |
IsCached |
IsCycling |
IsExhausted |
MaxValue |
MinValue |
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | The type of the object. (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from SchemaObjectWithAuthorization.)
Precision |
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
Scale |
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSources | (Inherited from SchemaObject.)
Start |
SysobjectID |
TypeName |
TypeNameWithScaleAndPrecision |
TypeSchemaName |

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

Sequence Class
RedGate.SQLCompare.Engine Namespace


Sequence Constructor

[image] [image]

SQL Data Compare API 12.0.40
Sequence Constructor
Sequence Class See Also

Overload List

Name | Description
Sequence(NullableBinaryReader) |
Sequence(Boolean) |

See Also

Sequence Class
Sequence Members
RedGate.SQLCompare.Engine Namespace


Sequence Constructor ()

[image]

SQL Data Compare API 12.0.40
Sequence Constructor ()
Sequence Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    reader As NullableBinaryReader _
)
C#
public Sequence(
    NullableBinaryReader reader
)
Visual C++
public:
Sequence(
    NullableBinaryReader^ reader
)

Parameters

reader
Type: NullableBinaryReader

See Also

Sequence Class
Sequence Overload
RedGate.SQLCompare.Engine Namespace


Sequence Constructor ()

[image]

SQL Data Compare API 12.0.40
Sequence Constructor ()
Sequence Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public Sequence(
    bool caseSensitive
)
Visual C++
public:
Sequence(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

Sequence Class
Sequence Overload
RedGate.SQLCompare.Engine Namespace


Sequence Methods

[image] [image]

SQL Data Compare API 12.0.40
Sequence Methods
Sequence Class See Also

The Sequence type exposes the following methods.

Methods

Name | Description
CompareWith |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

Sequence Class
RedGate.SQLCompare.Engine Namespace


CompareWith Method

[image]

SQL Data Compare API 12.0.40
Sequence..::.CompareWith Method
Sequence Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareWith ( _
    other As Sequence, _
    options As Options _
) As IEnumerable(Of EqualityDifference)
C#
public IEnumerable<EqualityDifference> CompareWith(
    Sequence other,
    Options options
)
Visual C++
public:
IEnumerable<EqualityDifference^>^ CompareWith(
    Sequence^ other,
    Options options
)

Parameters

other
Type: RedGate.SQLCompare.Engine..::.Sequence
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

Sequence Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
Sequence..::.ISqlComparable..::.CompareWith Method
Sequence Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    obj As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable obj,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ obj,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

obj
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

Sequence Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
Sequence..::.Equals Method
Sequence Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares two database objects. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

Sequence Class
Sequence Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
Sequence..::.Equals Method (IDatabaseObject, Options)
Sequence Class See Also

Compares two database objects.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) override

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The object to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
The comparison options.

Return Value

True if the database objects are identical; otherwise false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

Sequence Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
Sequence..::.PatchUpAfterDeserialization Method
Sequence Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

Sequence Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
Sequence..::.ScriptObject Method
Sequence Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options, e.g. quoted identifier on or off.
options
Type: RedGate.SQLCompare.Engine..::.Options
Options that may influence the scripting.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

Sequence Class
RedGate.SQLCompare.Engine Namespace


Sequence Properties

[image] [image]

SQL Data Compare API 12.0.40
Sequence Properties
Sequence Class See Also

The Sequence type exposes the following properties.

Properties

Name | Description
AlterAuthorizationClassType | (Inherited from SchemaObjectWithAuthorization.)
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
CacheSize |
CurrentValue |
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Increment |
IsCached |
IsCycling |
IsExhausted |
MaxValue |
MinValue |
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | The type of the object. (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from SchemaObjectWithAuthorization.)
Precision |
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
Scale |
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSources | (Inherited from SchemaObject.)
Start |
SysobjectID |
TypeName |
TypeNameWithScaleAndPrecision |
TypeSchemaName |

See Also

Sequence Class
RedGate.SQLCompare.Engine Namespace


CacheSize Property

[image]

SQL Data Compare API 12.0.40
Sequence..::.CacheSize Property
Sequence Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CacheSize As Nullable(Of Integer)
C#
public Nullable<int> CacheSize { get; internal set; }
Visual C++
public:
property Nullable<int> CacheSize {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

Sequence Class
RedGate.SQLCompare.Engine Namespace


CurrentValue Property

[image]

SQL Data Compare API 12.0.40
Sequence..::.CurrentValue Property
Sequence Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CurrentValue As SqlDecimal
C#
public SqlDecimal CurrentValue { get; internal set; }
Visual C++
public:
property SqlDecimal CurrentValue {
    SqlDecimal get ();
    void set (SqlDecimal value);
}

See Also

Sequence Class
RedGate.SQLCompare.Engine Namespace


Increment Property

[image]

SQL Data Compare API 12.0.40
Sequence..::.Increment Property
Sequence Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Increment As SqlDecimal
C#
public SqlDecimal Increment { get; internal set; }
Visual C++
public:
property SqlDecimal Increment {
    SqlDecimal get ();
    void set (SqlDecimal value);
}

See Also

Sequence Class
RedGate.SQLCompare.Engine Namespace


IsCached Property

[image]

SQL Data Compare API 12.0.40
Sequence..::.IsCached Property
Sequence Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsCached As Boolean
C#
public bool IsCached { get; internal set; }
Visual C++
public:
property bool IsCached {
    bool get ();
    void set (bool value);
}

See Also

Sequence Class
RedGate.SQLCompare.Engine Namespace


IsCycling Property

[image]

SQL Data Compare API 12.0.40
Sequence..::.IsCycling Property
Sequence Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsCycling As Boolean
C#
public bool IsCycling { get; internal set; }
Visual C++
public:
property bool IsCycling {
    bool get ();
    void set (bool value);
}

See Also

Sequence Class
RedGate.SQLCompare.Engine Namespace


IsExhausted Property

[image]

SQL Data Compare API 12.0.40
Sequence..::.IsExhausted Property
Sequence Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsExhausted As Boolean
C#
public bool IsExhausted { get; internal set; }
Visual C++
public:
property bool IsExhausted {
    bool get ();
    void set (bool value);
}

See Also

Sequence Class
RedGate.SQLCompare.Engine Namespace


MaxValue Property

[image]

SQL Data Compare API 12.0.40
Sequence..::.MaxValue Property
Sequence Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxValue As SqlDecimal
C#
public SqlDecimal MaxValue { get; internal set; }
Visual C++
public:
property SqlDecimal MaxValue {
    SqlDecimal get ();
    void set (SqlDecimal value);
}

See Also

Sequence Class
RedGate.SQLCompare.Engine Namespace


MinValue Property

[image]

SQL Data Compare API 12.0.40
Sequence..::.MinValue Property
Sequence Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property MinValue As SqlDecimal
C#
public SqlDecimal MinValue { get; internal set; }
Visual C++
public:
property SqlDecimal MinValue {
    SqlDecimal get ();
    void set (SqlDecimal value);
}

See Also

Sequence Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
Sequence..::.ObjectType Property
Sequence Class See Also

The type of the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()
ITSqlObjectObjectType()()()

See Also

Sequence Class
RedGate.SQLCompare.Engine Namespace


Precision Property

[image]

SQL Data Compare API 12.0.40
Sequence..::.Precision Property
Sequence Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Precision As Byte
C#
public byte Precision { get; internal set; }
Visual C++
public:
property unsigned char Precision {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

Sequence Class
RedGate.SQLCompare.Engine Namespace


Scale Property

[image]

SQL Data Compare API 12.0.40
Sequence..::.Scale Property
Sequence Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Scale As Byte
C#
public byte Scale { get; internal set; }
Visual C++
public:
property unsigned char Scale {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

Sequence Class
RedGate.SQLCompare.Engine Namespace


Start Property

[image]

SQL Data Compare API 12.0.40
Sequence..::.Start Property
Sequence Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Start As SqlDecimal
C#
public SqlDecimal Start { get; internal set; }
Visual C++
public:
property SqlDecimal Start {
    SqlDecimal get ();
    void set (SqlDecimal value);
}

See Also

Sequence Class
RedGate.SQLCompare.Engine Namespace


SysobjectID Property

[image]

SQL Data Compare API 12.0.40
Sequence..::.SysobjectID Property
Sequence Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SysobjectID As Integer
C#
public int SysobjectID { get; internal set; }
Visual C++
public:
virtual property int SysobjectID {
    int get () sealed;
    void set (int value) sealed;
}

See Also

Sequence Class
RedGate.SQLCompare.Engine Namespace


TypeName Property

[image]

SQL Data Compare API 12.0.40
Sequence..::.TypeName Property
Sequence Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeName As String
C#
public string TypeName { get; internal set; }
Visual C++
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}

See Also

Sequence Class
RedGate.SQLCompare.Engine Namespace


TypeNameWithScaleAndPrecision Property

[image]

SQL Data Compare API 12.0.40
Sequence..::.TypeNameWithScaleAndPrecision Property
Sequence Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TypeNameWithScaleAndPrecision As String
C#
public string TypeNameWithScaleAndPrecision { get; }
Visual C++
public:
property String^ TypeNameWithScaleAndPrecision {
    String^ get ();
}

See Also

Sequence Class
RedGate.SQLCompare.Engine Namespace


TypeSchemaName Property

[image]

SQL Data Compare API 12.0.40
Sequence..::.TypeSchemaName Property
Sequence Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeSchemaName As String
C#
public string TypeSchemaName { get; internal set; }
Visual C++
public:
property String^ TypeSchemaName {
    String^ get ();
    void set (String^ value);
}

See Also

Sequence Class
RedGate.SQLCompare.Engine Namespace


Sequences Class

[image]

SQL Data Compare API 12.0.40
Sequences Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Sequences _
    Inherits SerializableDatabaseObjectCollection(Of Sequence) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class Sequences : SerializableDatabaseObjectCollection<Sequence>, IPatchUpAfterDeserialization
Visual C++
public ref class Sequences sealed : public SerializableDatabaseObjectCollection<Sequence^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Sequence >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( Sequence >)>)
RedGate.SQLCompare.Engine..::.Sequences

See Also

Sequences Members
RedGate.SQLCompare.Engine Namespace


Sequences Members

[image] [image]

SQL Data Compare API 12.0.40
Sequences Members
Sequences Class Methods Fields Properties Explicit Interface Implementations See Also

The Sequences type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

Sequences Class
RedGate.SQLCompare.Engine Namespace


Sequences Methods

[image] [image]

SQL Data Compare API 12.0.40
Sequences Methods
Sequences Class See Also

The Sequences type exposes the following methods.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

Sequences Class
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
Sequences..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
Sequences Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

Sequences Class
RedGate.SQLCompare.Engine Namespace


SequencesChanges Class

[image]

SQL Data Compare API 12.0.40
SequencesChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SequencesChanges
C#
public class SequencesChanges
Visual C++
public ref class SequencesChanges

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.SequencesChanges

See Also

SequencesChanges Members
RedGate.SQLCompare.Engine Namespace


SequencesChanges Members

[image] [image]

SQL Data Compare API 12.0.40
SequencesChanges Members
SequencesChanges Class Constructors Methods Properties See Also

The SequencesChanges type exposes the following members.

Constructors

Name | Description
SequencesChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
SequencesToAlter |
SequencesToCreate |
SequencesToDrop |
SequenceTargets |

See Also

SequencesChanges Class
RedGate.SQLCompare.Engine Namespace


SequencesChanges Constructor

[image]

SQL Data Compare API 12.0.40
SequencesChanges Constructor
SequencesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public SequencesChanges(
    bool caseSensitive
)
Visual C++
public:
SequencesChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

SequencesChanges Class
RedGate.SQLCompare.Engine Namespace


SequencesChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
SequencesChanges Properties
SequencesChanges Class See Also

The SequencesChanges type exposes the following properties.

Properties

Name | Description
SequencesToAlter |
SequencesToCreate |
SequencesToDrop |
SequenceTargets |

See Also

SequencesChanges Class
RedGate.SQLCompare.Engine Namespace


SequencesToAlter Property

[image]

SQL Data Compare API 12.0.40
SequencesChanges..::.SequencesToAlter Property
SequencesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SequencesToAlter As Sequences
C#
public Sequences SequencesToAlter { get; private set; }
Visual C++
public:
property Sequences^ SequencesToAlter {
    Sequences^ get ();
    void set (Sequences^ value);
}

See Also

SequencesChanges Class
RedGate.SQLCompare.Engine Namespace


SequencesToCreate Property

[image]

SQL Data Compare API 12.0.40
SequencesChanges..::.SequencesToCreate Property
SequencesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SequencesToCreate As Sequences
C#
public Sequences SequencesToCreate { get; private set; }
Visual C++
public:
property Sequences^ SequencesToCreate {
    Sequences^ get ();
    void set (Sequences^ value);
}

See Also

SequencesChanges Class
RedGate.SQLCompare.Engine Namespace


SequencesToDrop Property

[image]

SQL Data Compare API 12.0.40
SequencesChanges..::.SequencesToDrop Property
SequencesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SequencesToDrop As Sequences
C#
public Sequences SequencesToDrop { get; private set; }
Visual C++
public:
property Sequences^ SequencesToDrop {
    Sequences^ get ();
    void set (Sequences^ value);
}

See Also

SequencesChanges Class
RedGate.SQLCompare.Engine Namespace


SequenceTargets Property

[image]

SQL Data Compare API 12.0.40
SequencesChanges..::.SequenceTargets Property
SequencesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SequenceTargets As Dictionary(Of Sequence, Sequence)
C#
public Dictionary<Sequence, Sequence> SequenceTargets { get; private set; }
Visual C++
public:
property Dictionary<Sequence^, Sequence^>^ SequenceTargets {
    Dictionary<Sequence^, Sequence^>^ get ();
    void set (Dictionary<Sequence^, Sequence^>^ value);
}

See Also

SequencesChanges Class
RedGate.SQLCompare.Engine Namespace


SerializableBlobStore Class

[image]

SQL Data Compare API 12.0.40
SerializableBlobStore Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SerializableBlobStore _
    Inherits DisposableBase
C#
public class SerializableBlobStore : DisposableBase
Visual C++
public ref class SerializableBlobStore : public DisposableBase

Inheritance Hierarchy

Object
RedGate.Shared.Utils..::.DisposableBase
RedGate.SQLCompare.Engine..::.SerializableBlobStore

See Also

SerializableBlobStore Members
RedGate.SQLCompare.Engine Namespace


SerializableBlobStore Members

[image] [image]

SQL Data Compare API 12.0.40
SerializableBlobStore Members
SerializableBlobStore Class Constructors Methods Properties See Also

The SerializableBlobStore type exposes the following members.

Constructors

Name | Description
SerializableBlobStore | Overloaded.

Methods

Name | Description
ContainsID |
Decryptable |
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetBlob | Overloaded.
GetBlobBytes |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize |
StoreBlob | Overloaded.
StoreBlobBytes |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDisposed | Returns a value indicating if this instance has been disposed. (Inherited from DisposableBase.)

See Also

SerializableBlobStore Class
RedGate.SQLCompare.Engine Namespace


SerializableBlobStore Constructor

[image] [image]

SQL Data Compare API 12.0.40
SerializableBlobStore Constructor
SerializableBlobStore Class See Also

Overload List

Name | Description
SerializableBlobStore()()() |
SerializableBlobStore(NullableBinaryReader) |

See Also

SerializableBlobStore Class
SerializableBlobStore Members
RedGate.SQLCompare.Engine Namespace


SerializableBlobStore Constructor

[image]

SQL Data Compare API 12.0.40
SerializableBlobStore Constructor
SerializableBlobStore Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SerializableBlobStore()
Visual C++
public:
SerializableBlobStore()

See Also

SerializableBlobStore Class
SerializableBlobStore Overload
RedGate.SQLCompare.Engine Namespace


SerializableBlobStore Constructor ()

[image]

SQL Data Compare API 12.0.40
SerializableBlobStore Constructor ()
SerializableBlobStore Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    reader As NullableBinaryReader _
)
C#
public SerializableBlobStore(
    NullableBinaryReader reader
)
Visual C++
public:
SerializableBlobStore(
    NullableBinaryReader^ reader
)

Parameters

reader
Type: NullableBinaryReader

See Also

SerializableBlobStore Class
SerializableBlobStore Overload
RedGate.SQLCompare.Engine Namespace


SerializableBlobStore Methods

[image] [image]

SQL Data Compare API 12.0.40
SerializableBlobStore Methods
SerializableBlobStore Class See Also

The SerializableBlobStore type exposes the following methods.

Methods

Name | Description
ContainsID |
Decryptable |
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetBlob | Overloaded.
GetBlobBytes |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize |
StoreBlob | Overloaded.
StoreBlobBytes |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SerializableBlobStore Class
RedGate.SQLCompare.Engine Namespace


ContainsID Method

[image]

SQL Data Compare API 12.0.40
SerializableBlobStore..::.ContainsID Method
SerializableBlobStore Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function ContainsID ( _
    id As Integer _
) As Boolean
C#
public bool ContainsID(
    int id
)
Visual C++
public:
virtual bool ContainsID(
    int id
) sealed

Parameters

id
Type: Int32

See Also

SerializableBlobStore Class
RedGate.SQLCompare.Engine Namespace


Decryptable Method

[image]

SQL Data Compare API 12.0.40
SerializableBlobStore..::.Decryptable Method
SerializableBlobStore Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Decryptable ( _
    id As Integer _
) As Boolean
C#
public bool Decryptable(
    int id
)
Visual C++
public:
virtual bool Decryptable(
    int id
) sealed

Parameters

id
Type: Int32

See Also

SerializableBlobStore Class
RedGate.SQLCompare.Engine Namespace


Dispose Method

[image] [image]

SQL Data Compare API 12.0.40
SerializableBlobStore..::.Dispose Method
SerializableBlobStore Class See Also

Overload List

Name | Description
Dispose()()() | (Inherited from DisposableBase.)
Dispose(Boolean) | (Overrides DisposableBase ..::. Dispose(Boolean).)

See Also

SerializableBlobStore Class
SerializableBlobStore Members
RedGate.SQLCompare.Engine Namespace


Dispose Method ()

[image]

SQL Data Compare API 12.0.40
SerializableBlobStore..::.Dispose Method ()
SerializableBlobStore Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
C#
protected override void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: Boolean

See Also

SerializableBlobStore Class
Dispose Overload
RedGate.SQLCompare.Engine Namespace


GetBlob Method

[image] [image]

SQL Data Compare API 12.0.40
SerializableBlobStore..::.GetBlob Method
SerializableBlobStore Class See Also

Overload List

Name | Description
GetBlob(Int32) |
GetBlob(UInt64) |

See Also

SerializableBlobStore Class
SerializableBlobStore Members
RedGate.SQLCompare.Engine Namespace


GetBlob Method ()

[image]

SQL Data Compare API 12.0.40
SerializableBlobStore..::.GetBlob Method ()
SerializableBlobStore Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetBlob ( _
    id As Integer _
) As String
C#
public string GetBlob(
    int id
)
Visual C++
public:
virtual String^ GetBlob(
    int id
) sealed

Parameters

id
Type: Int32

See Also

SerializableBlobStore Class
GetBlob Overload
RedGate.SQLCompare.Engine Namespace


GetBlob Method ()

[image]

SQL Data Compare API 12.0.40
SerializableBlobStore..::.GetBlob Method ()
SerializableBlobStore Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetBlob ( _
    id As ULong _
) As String
C#
public string GetBlob(
    ulong id
)
Visual C++
public:
String^ GetBlob(
    unsigned long long id
)

Parameters

id
Type: UInt64

See Also

SerializableBlobStore Class
GetBlob Overload
RedGate.SQLCompare.Engine Namespace


GetBlobBytes Method

[image]

SQL Data Compare API 12.0.40
SerializableBlobStore..::.GetBlobBytes Method
SerializableBlobStore Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBlobBytes ( _
    id As ULong _
) As Byte()
C#
public virtual byte[] GetBlobBytes(
    ulong id
)
Visual C++
public:
virtual array<unsigned char>^ GetBlobBytes(
    unsigned long long id
)

Parameters

id
Type: UInt64

See Also

SerializableBlobStore Class
RedGate.SQLCompare.Engine Namespace


Serialize Method

[image]

SQL Data Compare API 12.0.40
SerializableBlobStore..::.Serialize Method
SerializableBlobStore Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Serialize ( _
    writer As NullableBinaryWriter _
)
C#
public virtual void Serialize(
    NullableBinaryWriter writer
)
Visual C++
public:
virtual void Serialize(
    NullableBinaryWriter^ writer
)

Parameters

writer
Type: NullableBinaryWriter

See Also

SerializableBlobStore Class
RedGate.SQLCompare.Engine Namespace


StoreBlob Method

[image] [image]

SQL Data Compare API 12.0.40
SerializableBlobStore..::.StoreBlob Method
SerializableBlobStore Class See Also

Overload List

Name | Description
StoreBlob(Int32, String) |
StoreBlob(Int32, String, Boolean) |
StoreBlob(UInt64, String, Boolean) |

See Also

SerializableBlobStore Class
SerializableBlobStore Members
RedGate.SQLCompare.Engine Namespace


StoreBlob Method (, )

[image]

SQL Data Compare API 12.0.40
SerializableBlobStore..::.StoreBlob Method (, )
SerializableBlobStore Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub StoreBlob ( _
    id As Integer, _
    text As String _
)
C#
public void StoreBlob(
    int id,
    string text
)
Visual C++
public:
virtual void StoreBlob(
    int id,
    String^ text
) sealed

Parameters

id
Type: Int32
text
Type: String

See Also

SerializableBlobStore Class
StoreBlob Overload
RedGate.SQLCompare.Engine Namespace


StoreBlob Method (, , )

[image]

SQL Data Compare API 12.0.40
SerializableBlobStore..::.StoreBlob Method (, , )
SerializableBlobStore Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub StoreBlob ( _
    id As Integer, _
    text As String, _
    decryptable As Boolean _
)
C#
public void StoreBlob(
    int id,
    string text,
    bool decryptable
)
Visual C++
public:
virtual void StoreBlob(
    int id,
    String^ text,
    bool decryptable
) sealed

Parameters

id
Type: Int32
text
Type: String
decryptable
Type: Boolean

See Also

SerializableBlobStore Class
StoreBlob Overload
RedGate.SQLCompare.Engine Namespace


StoreBlob Method (, , )

[image]

SQL Data Compare API 12.0.40
SerializableBlobStore..::.StoreBlob Method (, , )
SerializableBlobStore Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub StoreBlob ( _
    id As ULong, _
    text As String, _
    decryptable As Boolean _
)
C#
public void StoreBlob(
    ulong id,
    string text,
    bool decryptable
)
Visual C++
public:
void StoreBlob(
    unsigned long long id,
    String^ text,
    bool decryptable
)

Parameters

id
Type: UInt64
text
Type: String
decryptable
Type: Boolean

See Also

SerializableBlobStore Class
StoreBlob Overload
RedGate.SQLCompare.Engine Namespace


StoreBlobBytes Method

[image]

SQL Data Compare API 12.0.40
SerializableBlobStore..::.StoreBlobBytes Method
SerializableBlobStore Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub StoreBlobBytes ( _
    id As ULong, _
    bytes As Byte() _
)
C#
public void StoreBlobBytes(
    ulong id,
    byte[] bytes
)
Visual C++
public:
virtual void StoreBlobBytes(
    unsigned long long id,
    array<unsigned char>^ bytes
) sealed

Parameters

id
Type: UInt64
bytes
Type: array<Byte>[]()[]

See Also

SerializableBlobStore Class
RedGate.SQLCompare.Engine Namespace


SerializableCollection(T) Generic Class

[image]

SQL Data Compare API 12.0.40
SerializableCollection<(Of <(T>)>) Generic Class
Members See Also

A collection that can be serialized to disk.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class SerializableCollection(Of T) _
    Inherits KeyedCollection(Of T)
C#
public abstract class SerializableCollection<T> : KeyedCollection<T>
Visual C++
generic<typename T>
public ref class SerializableCollection abstract : public KeyedCollection<T>

Type Parameters

T

Remarks

For internal use by SQL Compare.

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection<(Of <(T>)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection<(Of <(T>)>)
RedGate.SQLCompare.Engine..::.EventTypes
RedGate.SQLCompare.Engine..::.MessageUsages
RedGate.SQLCompare.Engine..::.Parameters
RedGate.SQLCompare.Engine..::.SerializableCollectionString

See Also

SerializableCollection<(Of <(T>)>) Members
RedGate.SQLCompare.Engine Namespace


SerializableCollection(T) Members

[image] [image]

SQL Data Compare API 12.0.40
SerializableCollection<(Of <(T>)>) Members
SerializableCollection<(Of <(T>)>) Class Constructors Methods Fields Properties Explicit Interface Implementations See Also

The SerializableCollection<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
SerializableCollection<(Of <(T>)>) |

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

SerializableCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


SerializableCollection(T) Constructor

[image]

SQL Data Compare API 12.0.40
SerializableCollection<(Of <(T>)>) Constructor
SerializableCollection<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    reader As NullableBinaryReader _
)
C#
protected SerializableCollection(
    NullableBinaryReader reader
)
Visual C++
protected:
SerializableCollection(
    NullableBinaryReader^ reader
)

Parameters

reader
Type: NullableBinaryReader

See Also

SerializableCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


SerializableCollectionString Class

[image]

SQL Data Compare API 12.0.40
SerializableCollectionString Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SerializableCollectionString _
    Inherits SerializableCollection(Of String)
C#
public class SerializableCollectionString : SerializableCollection<string>
Visual C++
public ref class SerializableCollectionString : public SerializableCollection<String^>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <(String>)>)
RedGate.SQLCompare.Engine..::.SerializableCollectionString

See Also

SerializableCollectionString Members
RedGate.SQLCompare.Engine Namespace


SerializableCollectionString Members

[image] [image]

SQL Data Compare API 12.0.40
SerializableCollectionString Members
SerializableCollectionString Class Methods Fields Properties Explicit Interface Implementations See Also

The SerializableCollectionString type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
DeserializeItem | (Overrides SerializableCollection <(Of <(String>)>)..::.DeserializeItem(NullableBinaryReader).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReplaceEntry |
SerializeItem | (Overrides SerializableCollection <(Of <(String>)>)..::.SerializeItem(UTP, NullableBinaryWriter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

SerializableCollectionString Class
RedGate.SQLCompare.Engine Namespace


SerializableCollectionString Methods

[image] [image]

SQL Data Compare API 12.0.40
SerializableCollectionString Methods
SerializableCollectionString Class See Also

The SerializableCollectionString type exposes the following methods.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
DeserializeItem | (Overrides SerializableCollection <(Of <(String>)>)..::.DeserializeItem(NullableBinaryReader).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReplaceEntry |
SerializeItem | (Overrides SerializableCollection <(Of <(String>)>)..::.SerializeItem(UTP, NullableBinaryWriter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

SerializableCollectionString Class
RedGate.SQLCompare.Engine Namespace


DeserializeItem Method

[image]

SQL Data Compare API 12.0.40
SerializableCollectionString..::.DeserializeItem Method
SerializableCollectionString Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Friend Overrides Function DeserializeItem ( _
    reader As NullableBinaryReader _
) As String
C#
protected internal override string DeserializeItem(
    NullableBinaryReader reader
)
Visual C++
protected public:
virtual String^ DeserializeItem(
    NullableBinaryReader^ reader
) override

Parameters

reader
Type: NullableBinaryReader

See Also

SerializableCollectionString Class
RedGate.SQLCompare.Engine Namespace


GetKey Method

[image]

SQL Data Compare API 12.0.40
SerializableCollectionString..::.GetKey Method
SerializableCollectionString Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Friend Overridable Function GetKey ( _
    value As String _
) As String
C#
protected internal virtual string GetKey(
    string value
)
Visual C++
protected public:
virtual String^ GetKey(
    String^ value
)

Parameters

value
Type: String

See Also

SerializableCollectionString Class
RedGate.SQLCompare.Engine Namespace


ReplaceEntry Method

[image]

SQL Data Compare API 12.0.40
SerializableCollectionString..::.ReplaceEntry Method
SerializableCollectionString Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub ReplaceEntry ( _
    oldEntry As String, _
    newEntry As String _
)
C#
public void ReplaceEntry(
    string oldEntry,
    string newEntry
)
Visual C++
public:
void ReplaceEntry(
    String^ oldEntry,
    String^ newEntry
)

Parameters

oldEntry
Type: String
newEntry
Type: String

See Also

SerializableCollectionString Class
RedGate.SQLCompare.Engine Namespace


SerializeItem Method

[image]

SQL Data Compare API 12.0.40
SerializableCollectionString..::.SerializeItem Method
SerializableCollectionString Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Friend Overrides Sub SerializeItem ( _
    value As String, _
    writer As NullableBinaryWriter _
)
C#
protected internal override void SerializeItem(
    string value,
    NullableBinaryWriter writer
)
Visual C++
protected public:
virtual void SerializeItem(
    String^ value,
    NullableBinaryWriter^ writer
) override

Parameters

value
Type: String
writer
Type: NullableBinaryWriter

See Also

SerializableCollectionString Class
RedGate.SQLCompare.Engine Namespace


SerializableDatabaseObjectCollection(T) Generic Class

[image]

SQL Data Compare API 12.0.40
SerializableDatabaseObjectCollection<(Of <(T>)>) Generic Class
Members See Also

A collection of database objects that can be serialized to disk.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class SerializableDatabaseObjectCollection(Of T As IDatabaseObject) _
    Inherits SerializableCollection(Of T) _
    Implements IDatabaseObjects(Of T), IKeyedCollection(Of T),  _
    IEnumerable(Of T), IEnumerable, INonReadOnlyCollection
C#
public abstract class SerializableDatabaseObjectCollection<T> : SerializableCollection<T>, IDatabaseObjects<T>,
    IKeyedCollection<T>, IEnumerable<T>, IEnumerable, INonReadOnlyCollection where T : IDatabaseObject
Visual C++
generic<typename T>
where T : IDatabaseObject
public ref class SerializableDatabaseObjectCollection abstract : public SerializableCollection<T>,
    IDatabaseObjects<T>, IKeyedCollection<T>, IEnumerable<T>, IEnumerable, INonReadOnlyCollection

Type Parameters

T
The type stored in the collection.

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <(T>)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection<(Of <(T>)>)
RedGate.SQLCompare.Engine..::.SearchPropertyLists
RedGate.SQLCompare.Engine..::.Sequences
RedGate.SQLCompare.Engine..::.FullTextStoplists
RedGate.SQLCompare.Engine..::.AsymmetricKeys
RedGate.SQLCompare.Engine..::.Certificates
RedGate.SQLCompare.Engine..::.CheckConstraints
RedGate.SQLCompare.Engine..::.ClrAssemblies
RedGate.SQLCompare.Engine..::.Contracts
RedGate.SQLCompare.Engine..::.DdlTriggers
RedGate.SQLCompare.Engine..::.Defaults
RedGate.SQLCompare.Engine..::.EventNotifications
RedGate.SQLCompare.Engine..::.ExtendedProperties
RedGate.SQLCompare.Engine..::.ForeignKeys
RedGate.SQLCompare.Engine..::.FullTextCatalogs
RedGate.SQLCompare.Engine..::.Functions
RedGate.SQLCompare.Engine..::.Indexes
RedGate.SQLCompare.Engine..::.MessageTypes
RedGate.SQLCompare.Engine..::.PartitionFunctions
RedGate.SQLCompare.Engine..::.PartitionSchemes
RedGate.SQLCompare.Engine..::.Queues
RedGate.SQLCompare.Engine..::.Roles
RedGate.SQLCompare.Engine..::.Routes
RedGate.SQLCompare.Engine..::.Rules
RedGate.SQLCompare.Engine..::.Schemas
RedGate.SQLCompare.Engine..::.ServiceBindings
RedGate.SQLCompare.Engine..::.Services
RedGate.SQLCompare.Engine..::.StoredProcedures
RedGate.SQLCompare.Engine..::.SymmetricKeys
RedGate.SQLCompare.Engine..::.Synonyms
RedGate.SQLCompare.Engine..::.Triggers
RedGate.SQLCompare.Engine..::.UserDefinedTypes
RedGate.SQLCompare.Engine..::.Users
RedGate.SQLCompare.Engine..::.Views
RedGate.SQLCompare.Engine..::.XmlSchemaCollections

See Also

SerializableDatabaseObjectCollection<(Of <(T>)>) Members
RedGate.SQLCompare.Engine Namespace


SerializableDatabaseObjectCollection(T) Members

[image] [image]

SQL Data Compare API 12.0.40
SerializableDatabaseObjectCollection<(Of <(T>)>) Members
SerializableDatabaseObjectCollection<(Of <(T>)>) Class Methods Fields Properties Explicit Interface Implementations See Also

The SerializableDatabaseObjectCollection<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use.
GetObjectNameForException |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly |
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

SerializableDatabaseObjectCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


SerializableDatabaseObjectCollection(T) Methods

[image] [image]

SQL Data Compare API 12.0.40
SerializableDatabaseObjectCollection<(Of <(T>)>) Methods
SerializableDatabaseObjectCollection<(Of <(T>)>) Class See Also

The SerializableDatabaseObjectCollection<(Of <(T>)>) type exposes the following methods.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use.
GetObjectNameForException |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly |
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

SerializableDatabaseObjectCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


INonReadOnlyCollection.AsReadOnly Method

[image]

SQL Data Compare API 12.0.40
SerializableDatabaseObjectCollection<(Of <(T>)>)..::.INonReadOnlyCollection..::.AsReadOnly Method
SerializableDatabaseObjectCollection<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function AsReadOnly As IReadOnlyKeyedDatabaseObjectCollectionWrapper
    Implements INonReadOnlyCollection.AsReadOnly
C#
IReadOnlyKeyedDatabaseObjectCollectionWrapper INonReadOnlyCollection.AsReadOnly()
Visual C++
private:
virtual IReadOnlyKeyedDatabaseObjectCollectionWrapper^ AsReadOnly() sealed = INonReadOnlyCollection::AsReadOnly

Implements

INonReadOnlyCollection..::.AsReadOnly()()()

See Also

SerializableDatabaseObjectCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


GetKey Method

[image]

SQL Data Compare API 12.0.40
SerializableDatabaseObjectCollection<(Of <(T>)>)..::.GetKey Method
SerializableDatabaseObjectCollection<(Of <(T>)>) Class See Also

For internal use.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Friend Overridable Function GetKey ( _
    value As T _
) As String
C#
protected internal virtual string GetKey(
    T value
)
Visual C++
protected public:
virtual String^ GetKey(
    T value
)

Parameters

value
Type: T
For internal use

Return Value

For internal use

See Also

SerializableDatabaseObjectCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


GetObjectNameForException Method

[image]

SQL Data Compare API 12.0.40
SerializableDatabaseObjectCollection<(Of <(T>)>)..::.GetObjectNameForException Method
SerializableDatabaseObjectCollection<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetObjectNameForException ( _
    value As T _
) As String
C#
protected virtual string GetObjectNameForException(
    T value
)
Visual C++
protected:
virtual String^ GetObjectNameForException(
    T value
)

Parameters

value
Type: T

See Also

SerializableDatabaseObjectCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


SerializableDatabaseObjectCollection(T) Properties

[image] [image]

SQL Data Compare API 12.0.40
SerializableDatabaseObjectCollection<(Of <(T>)>) Properties
SerializableDatabaseObjectCollection<(Of <(T>)>) Class See Also

The SerializableDatabaseObjectCollection<(Of <(T>)>) type exposes the following properties.

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

See Also

SerializableDatabaseObjectCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
SerializableDatabaseObjectCollection<(Of <(T>)>)..::.Item Property
SerializableDatabaseObjectCollection<(Of <(T>)>) Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name.

See Also

SerializableDatabaseObjectCollection<(Of <(T>)>) Class
SerializableDatabaseObjectCollection<(Of <(T>)>) Members
RedGate.SQLCompare.Engine Namespace


Item Property (, )

[image]

SQL Data Compare API 12.0.40
SerializableDatabaseObjectCollection<(Of <(T>)>)..::.Item Property (, )
SerializableDatabaseObjectCollection<(Of <(T>)>) Class See Also

Returns a database object given its owner and name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Default Property Item ( _
    owner As String, _
    name As String _
) As T
C#
public virtual T this[
    string owner,
    string name
] { get; }
Visual C++
public:
virtual property T default[String^ owner, String^ name] {
    T get (String^ owner, String^ name);
}

Parameters

owner
Type: String
The owner component of the string-based index of the element to get or set.
name
Type: String
The name component of the string-based index of the element to get or set.

See Also

SerializableDatabaseObjectCollection<(Of <(T>)>) Class
Item Overload
RedGate.SQLCompare.Engine Namespace


Service Class

[image]

SQL Data Compare API 12.0.40
Service Class
Members See Also

A service.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Service _
    Inherits DatabaseObjectWithAuthorizationAndExtendedProperties _
    Implements IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck,  _
    IIsSystemObject, IPatchUpAfterDeserialization, ISqlComparable
C#
public sealed class Service : DatabaseObjectWithAuthorizationAndExtendedProperties, IHasPermissions,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, IIsSystemObject, IPatchUpAfterDeserialization,
    ISqlComparable
Visual C++
public ref class Service sealed : public DatabaseObjectWithAuthorizationAndExtendedProperties,
    IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck, IIsSystemObject,
    IPatchUpAfterDeserialization, ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorizationAndExtendedProperties
RedGate.SQLCompare.Engine..::.Service

See Also

Service Members
RedGate.SQLCompare.Engine Namespace


Service Members

[image] [image]

SQL Data Compare API 12.0.40
Service Members
Service Class Methods Fields Properties Explicit Interface Implementations See Also

The Service type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AlterAuthorizationClassType | (Overrides DatabaseObjectWithAuthorization ..::. AlterAuthorizationClassType.)
Contracts | The contracts that the service uses.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
EventNotifications | The event notifications that depend on the service.
ExtendedProperties | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
IsSystemObject | Indicates whether the object is a system object.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Service (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
Queue | The queue that the service is on.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

Service Class
RedGate.SQLCompare.Engine Namespace


Service Methods

[image] [image]

SQL Data Compare API 12.0.40
Service Methods
Service Class See Also

The Service type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

Service Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
Service..::.ISqlComparable..::.CompareWith Method
Service Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    target As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable target,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ target,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

target
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

Service Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
Service..::.Equals Method
Service Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the service with a specified service. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

Service Class
Service Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
Service..::.Equals Method (IDatabaseObject, Options)
Service Class See Also

Compares the service with a specified service.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The service to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the services are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

Service Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
Service..::.PatchUpAfterDeserialization Method
Service Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

Service Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
Service..::.ScriptObject Method
Service Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

Service Class
RedGate.SQLCompare.Engine Namespace


Service Properties

[image] [image]

SQL Data Compare API 12.0.40
Service Properties
Service Class See Also

The Service type exposes the following properties.

Properties

Name | Description
AlterAuthorizationClassType | (Overrides DatabaseObjectWithAuthorization ..::. AlterAuthorizationClassType.)
Contracts | The contracts that the service uses.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
EventNotifications | The event notifications that depend on the service.
ExtendedProperties | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
IsSystemObject | Indicates whether the object is a system object.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Service (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
Queue | The queue that the service is on.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)

See Also

Service Class
RedGate.SQLCompare.Engine Namespace


AlterAuthorizationClassType Property

[image]

SQL Data Compare API 12.0.40
Service..::.AlterAuthorizationClassType Property
Service Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property AlterAuthorizationClassType As String
C#
public override string AlterAuthorizationClassType { get; }
Visual C++
public:
virtual property String^ AlterAuthorizationClassType {
    String^ get () override;
}

Implements

IHasAuthorization..::.AlterAuthorizationClassType

See Also

Service Class
RedGate.SQLCompare.Engine Namespace


Contracts Property

[image]

SQL Data Compare API 12.0.40
Service..::.Contracts Property
Service Class See Also

The contracts that the service uses.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Contracts As Contracts
C#
public Contracts Contracts { get; }
Visual C++
public:
property Contracts^ Contracts {
    Contracts^ get ();
}

See Also

Service Class
RedGate.SQLCompare.Engine Namespace


EventNotifications Property

[image]

SQL Data Compare API 12.0.40
Service..::.EventNotifications Property
Service Class See Also

The event notifications that depend on the service.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EventNotifications As EventNotifications
C#
public EventNotifications EventNotifications { get; }
Visual C++
public:
property EventNotifications^ EventNotifications {
    EventNotifications^ get ();
}

See Also

Service Class
RedGate.SQLCompare.Engine Namespace


IsSystemObject Property

[image]

SQL Data Compare API 12.0.40
Service..::.IsSystemObject Property
Service Class See Also

Indicates whether the object is a system object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSystemObject As Boolean
C#
public bool IsSystemObject { get; private set; }
Visual C++
public:
virtual property bool IsSystemObject {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IIsSystemObject..::.IsSystemObject

See Also

Service Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
Service..::.ObjectType Property
Service Class See Also

Returns ObjectType.Service

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()
ITSqlObjectObjectType()()()

See Also

Service Class
RedGate.SQLCompare.Engine Namespace


Queue Property

[image]

SQL Data Compare API 12.0.40
Service..::.Queue Property
Service Class See Also

The queue that the service is on.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Queue As Queue
C#
public Queue Queue { get; internal set; }
Visual C++
public:
property Queue^ Queue {
    Queue^ get ();
    void set (Queue^ value);
}

See Also

Service Class
RedGate.SQLCompare.Engine Namespace


ServiceBinding Class

[image]

SQL Data Compare API 12.0.40
ServiceBinding Class
Members See Also

A service binding.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ServiceBinding _
    Inherits DatabaseObjectWithAuthorizationAndExtendedProperties _
    Implements IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck,  _
    IPatchUpAfterDeserialization, ISqlComparable
C#
public sealed class ServiceBinding : DatabaseObjectWithAuthorizationAndExtendedProperties, IHasPermissions,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, IPatchUpAfterDeserialization, ISqlComparable
Visual C++
public ref class ServiceBinding sealed : public DatabaseObjectWithAuthorizationAndExtendedProperties,
    IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck, IPatchUpAfterDeserialization,
    ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorizationAndExtendedProperties
RedGate.SQLCompare.Engine..::.ServiceBinding

See Also

ServiceBinding Members
RedGate.SQLCompare.Engine Namespace


ServiceBinding Members

[image] [image]

SQL Data Compare API 12.0.40
ServiceBinding Members
ServiceBinding Class Methods Fields Properties Explicit Interface Implementations See Also

The ServiceBinding type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AlterAuthorizationClassType | (Overrides DatabaseObjectWithAuthorization ..::. AlterAuthorizationClassType.)
Anonymous | True if anonymous authentication is to be used.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Service (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
RemoteService | The remote service.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)
UserName | The user name.

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

ServiceBinding Class
RedGate.SQLCompare.Engine Namespace


ServiceBinding Methods

[image] [image]

SQL Data Compare API 12.0.40
ServiceBinding Methods
ServiceBinding Class See Also

The ServiceBinding type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

ServiceBinding Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
ServiceBinding..::.ISqlComparable..::.CompareWith Method
ServiceBinding Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    target As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable target,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ target,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

target
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

ServiceBinding Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
ServiceBinding..::.Equals Method
ServiceBinding Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the service binding with a specified service binding. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

ServiceBinding Class
ServiceBinding Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
ServiceBinding..::.Equals Method (IDatabaseObject, Options)
ServiceBinding Class See Also

Compares the service binding with a specified service binding.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The service to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the service bindings are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

ServiceBinding Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
ServiceBinding..::.PatchUpAfterDeserialization Method
ServiceBinding Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

ServiceBinding Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
ServiceBinding..::.ScriptObject Method
ServiceBinding Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

ServiceBinding Class
RedGate.SQLCompare.Engine Namespace


ServiceBinding Properties

[image] [image]

SQL Data Compare API 12.0.40
ServiceBinding Properties
ServiceBinding Class See Also

The ServiceBinding type exposes the following properties.

Properties

Name | Description
AlterAuthorizationClassType | (Overrides DatabaseObjectWithAuthorization ..::. AlterAuthorizationClassType.)
Anonymous | True if anonymous authentication is to be used.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Service (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from DatabaseObjectWithAuthorizationAndExtendedProperties.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
RemoteService | The remote service.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)
UserName | The user name.

See Also

ServiceBinding Class
RedGate.SQLCompare.Engine Namespace


AlterAuthorizationClassType Property

[image]

SQL Data Compare API 12.0.40
ServiceBinding..::.AlterAuthorizationClassType Property
ServiceBinding Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property AlterAuthorizationClassType As String
C#
public override string AlterAuthorizationClassType { get; }
Visual C++
public:
virtual property String^ AlterAuthorizationClassType {
    String^ get () override;
}

Implements

IHasAuthorization..::.AlterAuthorizationClassType

See Also

ServiceBinding Class
RedGate.SQLCompare.Engine Namespace


Anonymous Property

[image]

SQL Data Compare API 12.0.40
ServiceBinding..::.Anonymous Property
ServiceBinding Class See Also

True if anonymous authentication is to be used.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Anonymous As Boolean
C#
public bool Anonymous { get; internal set; }
Visual C++
public:
property bool Anonymous {
    bool get ();
    void set (bool value);
}

See Also

ServiceBinding Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
ServiceBinding..::.ObjectType Property
ServiceBinding Class See Also

Returns ObjectType.Service

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()
ITSqlObjectObjectType()()()

See Also

ServiceBinding Class
RedGate.SQLCompare.Engine Namespace


RemoteService Property

[image]

SQL Data Compare API 12.0.40
ServiceBinding..::.RemoteService Property
ServiceBinding Class See Also

The remote service.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RemoteService As String
C#
public string RemoteService { get; internal set; }
Visual C++
public:
property String^ RemoteService {
    String^ get ();
    void set (String^ value);
}

See Also

ServiceBinding Class
RedGate.SQLCompare.Engine Namespace


UserName Property

[image]

SQL Data Compare API 12.0.40
ServiceBinding..::.UserName Property
ServiceBinding Class See Also

The user name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UserName As String
C#
public string UserName { get; internal set; }
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

ServiceBinding Class
RedGate.SQLCompare.Engine Namespace


ServiceBindings Class

[image]

SQL Data Compare API 12.0.40
ServiceBindings Class
Members See Also

A collection of service bindings.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ServiceBindings _
    Inherits SerializableDatabaseObjectCollection(Of ServiceBinding) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class ServiceBindings : SerializableDatabaseObjectCollection<ServiceBinding>, IPatchUpAfterDeserialization
Visual C++
public ref class ServiceBindings sealed : public SerializableDatabaseObjectCollection<ServiceBinding^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( ServiceBinding >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( ServiceBinding >)>)
RedGate.SQLCompare.Engine..::.ServiceBindings

See Also

ServiceBindings Members
RedGate.SQLCompare.Engine Namespace


ServiceBindings Members

[image] [image]

SQL Data Compare API 12.0.40
ServiceBindings Members
ServiceBindings Class Methods Fields Properties Explicit Interface Implementations See Also

The ServiceBindings type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

ServiceBindings Class
RedGate.SQLCompare.Engine Namespace


ServiceBindings Methods

[image] [image]

SQL Data Compare API 12.0.40
ServiceBindings Methods
ServiceBindings Class See Also

The ServiceBindings type exposes the following methods.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

ServiceBindings Class
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
ServiceBindings..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
ServiceBindings Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

ServiceBindings Class
RedGate.SQLCompare.Engine Namespace


ServiceBindingsChanges Class

[image]

SQL Data Compare API 12.0.40
ServiceBindingsChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ServiceBindingsChanges
C#
public sealed class ServiceBindingsChanges
Visual C++
public ref class ServiceBindingsChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ServiceBindingsChanges

See Also

ServiceBindingsChanges Members
RedGate.SQLCompare.Engine Namespace


ServiceBindingsChanges Members

[image] [image]

SQL Data Compare API 12.0.40
ServiceBindingsChanges Members
ServiceBindingsChanges Class Constructors Methods Properties See Also

The ServiceBindingsChanges type exposes the following members.

Constructors

Name | Description
ServiceBindingsChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ServiceBindingsToAlter |
ServiceBindingsToCreate |
ServiceBindingsToDrop |
ServiceBindingTargets |

See Also

ServiceBindingsChanges Class
RedGate.SQLCompare.Engine Namespace


ServiceBindingsChanges Constructor

[image]

SQL Data Compare API 12.0.40
ServiceBindingsChanges Constructor
ServiceBindingsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public ServiceBindingsChanges(
    bool caseSensitive
)
Visual C++
public:
ServiceBindingsChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

ServiceBindingsChanges Class
RedGate.SQLCompare.Engine Namespace


ServiceBindingsChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
ServiceBindingsChanges Properties
ServiceBindingsChanges Class See Also

The ServiceBindingsChanges type exposes the following properties.

Properties

Name | Description
ServiceBindingsToAlter |
ServiceBindingsToCreate |
ServiceBindingsToDrop |
ServiceBindingTargets |

See Also

ServiceBindingsChanges Class
RedGate.SQLCompare.Engine Namespace


ServiceBindingsToAlter Property

[image]

SQL Data Compare API 12.0.40
ServiceBindingsChanges..::.ServiceBindingsToAlter Property
ServiceBindingsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ServiceBindingsToAlter As ServiceBindings
C#
public ServiceBindings ServiceBindingsToAlter { get; private set; }
Visual C++
public:
property ServiceBindings^ ServiceBindingsToAlter {
    ServiceBindings^ get ();
    void set (ServiceBindings^ value);
}

See Also

ServiceBindingsChanges Class
RedGate.SQLCompare.Engine Namespace


ServiceBindingsToCreate Property

[image]

SQL Data Compare API 12.0.40
ServiceBindingsChanges..::.ServiceBindingsToCreate Property
ServiceBindingsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ServiceBindingsToCreate As ServiceBindings
C#
public ServiceBindings ServiceBindingsToCreate { get; private set; }
Visual C++
public:
property ServiceBindings^ ServiceBindingsToCreate {
    ServiceBindings^ get ();
    void set (ServiceBindings^ value);
}

See Also

ServiceBindingsChanges Class
RedGate.SQLCompare.Engine Namespace


ServiceBindingsToDrop Property

[image]

SQL Data Compare API 12.0.40
ServiceBindingsChanges..::.ServiceBindingsToDrop Property
ServiceBindingsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ServiceBindingsToDrop As ServiceBindings
C#
public ServiceBindings ServiceBindingsToDrop { get; private set; }
Visual C++
public:
property ServiceBindings^ ServiceBindingsToDrop {
    ServiceBindings^ get ();
    void set (ServiceBindings^ value);
}

See Also

ServiceBindingsChanges Class
RedGate.SQLCompare.Engine Namespace


ServiceBindingTargets Property

[image]

SQL Data Compare API 12.0.40
ServiceBindingsChanges..::.ServiceBindingTargets Property
ServiceBindingsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ServiceBindingTargets As Dictionary(Of ServiceBinding, ServiceBinding)
C#
public Dictionary<ServiceBinding, ServiceBinding> ServiceBindingTargets { get; private set; }
Visual C++
public:
property Dictionary<ServiceBinding^, ServiceBinding^>^ ServiceBindingTargets {
    Dictionary<ServiceBinding^, ServiceBinding^>^ get ();
    void set (Dictionary<ServiceBinding^, ServiceBinding^>^ value);
}

See Also

ServiceBindingsChanges Class
RedGate.SQLCompare.Engine Namespace


Services Class

[image]

SQL Data Compare API 12.0.40
Services Class
Members See Also

A collection of services.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Services _
    Inherits SerializableDatabaseObjectCollection(Of Service) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class Services : SerializableDatabaseObjectCollection<Service>, IPatchUpAfterDeserialization
Visual C++
public ref class Services sealed : public SerializableDatabaseObjectCollection<Service^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Service >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( Service >)>)
RedGate.SQLCompare.Engine..::.Services

See Also

Services Members
RedGate.SQLCompare.Engine Namespace


Services Members

[image] [image]

SQL Data Compare API 12.0.40
Services Members
Services Class Methods Fields Properties Explicit Interface Implementations See Also

The Services type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

Services Class
RedGate.SQLCompare.Engine Namespace


Services Methods

[image] [image]

SQL Data Compare API 12.0.40
Services Methods
Services Class See Also

The Services type exposes the following methods.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

Services Class
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
Services..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
Services Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

Services Class
RedGate.SQLCompare.Engine Namespace


ServicesChanges Class

[image]

SQL Data Compare API 12.0.40
ServicesChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ServicesChanges
C#
public sealed class ServicesChanges
Visual C++
public ref class ServicesChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ServicesChanges

See Also

ServicesChanges Members
RedGate.SQLCompare.Engine Namespace


ServicesChanges Members

[image] [image]

SQL Data Compare API 12.0.40
ServicesChanges Members
ServicesChanges Class Constructors Methods Properties See Also

The ServicesChanges type exposes the following members.

Constructors

Name | Description
ServicesChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ServicesToAlter |
ServicesToCreate |
ServicesToDrop |
ServiceTargets |

See Also

ServicesChanges Class
RedGate.SQLCompare.Engine Namespace


ServicesChanges Constructor

[image]

SQL Data Compare API 12.0.40
ServicesChanges Constructor
ServicesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public ServicesChanges(
    bool caseSensitive
)
Visual C++
public:
ServicesChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

ServicesChanges Class
RedGate.SQLCompare.Engine Namespace


ServicesChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
ServicesChanges Properties
ServicesChanges Class See Also

The ServicesChanges type exposes the following properties.

Properties

Name | Description
ServicesToAlter |
ServicesToCreate |
ServicesToDrop |
ServiceTargets |

See Also

ServicesChanges Class
RedGate.SQLCompare.Engine Namespace


ServicesToAlter Property

[image]

SQL Data Compare API 12.0.40
ServicesChanges..::.ServicesToAlter Property
ServicesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ServicesToAlter As Services
C#
public Services ServicesToAlter { get; private set; }
Visual C++
public:
property Services^ ServicesToAlter {
    Services^ get ();
    void set (Services^ value);
}

See Also

ServicesChanges Class
RedGate.SQLCompare.Engine Namespace


ServicesToCreate Property

[image]

SQL Data Compare API 12.0.40
ServicesChanges..::.ServicesToCreate Property
ServicesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ServicesToCreate As Services
C#
public Services ServicesToCreate { get; private set; }
Visual C++
public:
property Services^ ServicesToCreate {
    Services^ get ();
    void set (Services^ value);
}

See Also

ServicesChanges Class
RedGate.SQLCompare.Engine Namespace


ServicesToDrop Property

[image]

SQL Data Compare API 12.0.40
ServicesChanges..::.ServicesToDrop Property
ServicesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ServicesToDrop As Services
C#
public Services ServicesToDrop { get; private set; }
Visual C++
public:
property Services^ ServicesToDrop {
    Services^ get ();
    void set (Services^ value);
}

See Also

ServicesChanges Class
RedGate.SQLCompare.Engine Namespace


ServiceTargets Property

[image]

SQL Data Compare API 12.0.40
ServicesChanges..::.ServiceTargets Property
ServicesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ServiceTargets As Dictionary(Of Service, Service)
C#
public Dictionary<Service, Service> ServiceTargets { get; private set; }
Visual C++
public:
property Dictionary<Service^, Service^>^ ServiceTargets {
    Dictionary<Service^, Service^>^ get ();
    void set (Dictionary<Service^, Service^>^ value);
}

See Also

ServicesChanges Class
RedGate.SQLCompare.Engine Namespace


SessionSettings Enumeration

[image]

SQL Data Compare API 12.0.40
SessionSettings Enumeration
See Also

Settings for comparing objects.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration SessionSettings
C#
[FlagsAttribute]
public enum SessionSettings
Visual C++
[FlagsAttribute]
public enum class SessionSettings

Members

Member name | Description
IncludeIdenticalRecords | Include records that are the same in both databases.
IncludeDifferentRecords | Include records that exist in both databases and are different.
IncludeRecordsInOne | Include records that exist in the first database, but not the second.
IncludeRecordsInTwo | Include records that exist in the second database, but not the first.
UseDotNETSQLDataReader | Use DotNET SQLDataReader
UseLargeBlobSQLDataReader | Use LargeBlob DataReader
Default | The default setting.

See Also

RedGate.SQLCompare.Engine Namespace


SnapshotSource Class

[image]

SQL Data Compare API 12.0.40
SnapshotSource Class
Members See Also

A SQL Server database encapsulated within a snapshot.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class SnapshotSource _
    Inherits DataSource
C#
[SerializableAttribute]
public sealed class SnapshotSource : DataSource
Visual C++
[SerializableAttribute]
public ref class SnapshotSource sealed : public DataSource

Inheritance Hierarchy

Object
RedGate.Shared.SQL..::.DataSource
RedGate.SQLCompare.Engine..::.SnapshotSource

See Also

SnapshotSource Members
RedGate.SQLCompare.Engine Namespace


SnapshotSource Members

[image] [image]

SQL Data Compare API 12.0.40
SnapshotSource Members
SnapshotSource Class Constructors Methods Properties Explicit Interface Implementations See Also

The SnapshotSource type exposes the following members.

Constructors

Name | Description
SnapshotSource | Overloaded.

Methods

Name | Description
Clone | Clones the data source. (Overrides DataSource ..::. Clone()()().)
Deserialize | Deserializes data. (Overrides DataSource ..::. Deserialize(Int32, ISerializeFormatter).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDifferentSource | Compares the data source with a specified data source. (Overrides DataSource ..::.IsDifferentSource(IDataSource).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes data. (Overrides DataSource ..::. Serialize(ISerializeFormatter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CreationTime | Gets the creation time of the snapshot file (the time at which the file was last written to).
DatabaseName | Gets or sets the name of the database. (Overrides DataSource ..::. DatabaseName.)
FileName | Gets or sets the snapshot file name.
IsValid | True if this snapshot represents a valid data source that can be used in comparison. If false, then there is a problem with the snapshot file - for example, it could not be found or is in the wrong format. (Overrides DataSource ..::. IsValid.)
IsWriteable | The data source cannot be written to. (Overrides DataSource ..::. IsWriteable.)
ServerName | Gets or sets the name of the SQL Server. (Overrides DataSource ..::. ServerName.)
Version | Gets the current serialized version number of the snapshot. (Overrides DataSource ..::. Version.)

Explicit Interface Implementations

Name | Description
ICloneableClone | (Inherited from DataSource.)

See Also

SnapshotSource Class
RedGate.SQLCompare.Engine Namespace


SnapshotSource Constructor

[image] [image]

SQL Data Compare API 12.0.40
SnapshotSource Constructor
SnapshotSource Class See Also

Overload List

Name | Description
SnapshotSource()()() | Constructs a snapshot.
SnapshotSource(String) | Constructs the snapshot file name.

See Also

SnapshotSource Class
SnapshotSource Members
RedGate.SQLCompare.Engine Namespace


SnapshotSource Constructor

[image]

SQL Data Compare API 12.0.40
SnapshotSource Constructor
SnapshotSource Class See Also

Constructs a snapshot.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SnapshotSource()
Visual C++
public:
SnapshotSource()

See Also

SnapshotSource Class
SnapshotSource Overload
RedGate.SQLCompare.Engine Namespace


SnapshotSource Constructor ()

[image]

SQL Data Compare API 12.0.40
SnapshotSource Constructor ()
SnapshotSource Class See Also

Constructs the snapshot file name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    snapshotFileName As String _
)
C#
public SnapshotSource(
    string snapshotFileName
)
Visual C++
public:
SnapshotSource(
    String^ snapshotFileName
)

Parameters

snapshotFileName
Type: String
The file name of the snapshot.

See Also

SnapshotSource Class
SnapshotSource Overload
RedGate.SQLCompare.Engine Namespace


SnapshotSource Methods

[image] [image]

SQL Data Compare API 12.0.40
SnapshotSource Methods
SnapshotSource Class See Also

The SnapshotSource type exposes the following methods.

Methods

Name | Description
Clone | Clones the data source. (Overrides DataSource ..::. Clone()()().)
Deserialize | Deserializes data. (Overrides DataSource ..::. Deserialize(Int32, ISerializeFormatter).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDifferentSource | Compares the data source with a specified data source. (Overrides DataSource ..::.IsDifferentSource(IDataSource).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes data. (Overrides DataSource ..::. Serialize(ISerializeFormatter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICloneableClone | (Inherited from DataSource.)

See Also

SnapshotSource Class
RedGate.SQLCompare.Engine Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
SnapshotSource..::.Clone Method
SnapshotSource Class See Also

Clones the data source.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone As IDataSource
C#
public override IDataSource Clone()
Visual C++
public:
virtual IDataSource^ Clone() override

Implements

IDataSource..::.Clone()()()

See Also

SnapshotSource Class
RedGate.SQLCompare.Engine Namespace


Deserialize Method

[image]

SQL Data Compare API 12.0.40
SnapshotSource..::.Deserialize Method
SnapshotSource Class See Also

Deserializes data.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Deserialize ( _
    versionId As Integer, _
    formatter As ISerializeFormatter _
) As Boolean
C#
public override bool Deserialize(
    int versionId,
    ISerializeFormatter formatter
)
Visual C++
public:
virtual bool Deserialize(
    int versionId,
    ISerializeFormatter^ formatter
) override

Parameters

versionId
Type: Int32
The serialization version.
formatter
Type: ISerializeFormatter
The ISerializeFormatter for deserialization.

Return Value

true if the data can be deserialized.

See Also

SnapshotSource Class
RedGate.SQLCompare.Engine Namespace


IsDifferentSource Method

[image]

SQL Data Compare API 12.0.40
SnapshotSource..::.IsDifferentSource Method
SnapshotSource Class See Also

Compares the data source with a specified data source.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsDifferentSource ( _
    comparisonDataSource As IDataSource _
) As Boolean
C#
public override bool IsDifferentSource(
    IDataSource comparisonDataSource
)
Visual C++
public:
virtual bool IsDifferentSource(
    IDataSource^ comparisonDataSource
) override

Parameters

comparisonDataSource
Type: RedGate.Shared.SQL..::.IDataSource
The data source to compare.

Return Value

true if the data sources are different.

See Also

SnapshotSource Class
RedGate.SQLCompare.Engine Namespace


Serialize Method

[image]

SQL Data Compare API 12.0.40
SnapshotSource..::.Serialize Method
SnapshotSource Class See Also

Serializes data.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    formatter As ISerializeFormatter _
)
C#
public override void Serialize(
    ISerializeFormatter formatter
)
Visual C++
public:
virtual void Serialize(
    ISerializeFormatter^ formatter
) override

Parameters

formatter
Type: ISerializeFormatter
The ISerializeFormatter for serialization.

See Also

SnapshotSource Class
RedGate.SQLCompare.Engine Namespace


SnapshotSource Properties

[image] [image]

SQL Data Compare API 12.0.40
SnapshotSource Properties
SnapshotSource Class See Also

The SnapshotSource type exposes the following properties.

Properties

Name | Description
CreationTime | Gets the creation time of the snapshot file (the time at which the file was last written to).
DatabaseName | Gets or sets the name of the database. (Overrides DataSource ..::. DatabaseName.)
FileName | Gets or sets the snapshot file name.
IsValid | True if this snapshot represents a valid data source that can be used in comparison. If false, then there is a problem with the snapshot file - for example, it could not be found or is in the wrong format. (Overrides DataSource ..::. IsValid.)
IsWriteable | The data source cannot be written to. (Overrides DataSource ..::. IsWriteable.)
ServerName | Gets or sets the name of the SQL Server. (Overrides DataSource ..::. ServerName.)
Version | Gets the current serialized version number of the snapshot. (Overrides DataSource ..::. Version.)

See Also

SnapshotSource Class
RedGate.SQLCompare.Engine Namespace


CreationTime Property

[image]

SQL Data Compare API 12.0.40
SnapshotSource..::.CreationTime Property
SnapshotSource Class See Also

Gets the creation time of the snapshot file (the time at which the file was last written to).

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CreationTime As DateTime
C#
public DateTime CreationTime { get; }
Visual C++
public:
property DateTime CreationTime {
    DateTime get ();
}

See Also

SnapshotSource Class
RedGate.SQLCompare.Engine Namespace


DatabaseName Property

[image]

SQL Data Compare API 12.0.40
SnapshotSource..::.DatabaseName Property
SnapshotSource Class See Also

Gets or sets the name of the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property DatabaseName As String
C#
public override string DatabaseName { get; set; }
Visual C++
public:
virtual property String^ DatabaseName {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IDataSource..::.DatabaseName

See Also

SnapshotSource Class
RedGate.SQLCompare.Engine Namespace


FileName Property

[image]

SQL Data Compare API 12.0.40
SnapshotSource..::.FileName Property
SnapshotSource Class See Also

Gets or sets the snapshot file name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property FileName As String
C#
public string FileName { get; set; }
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

See Also

SnapshotSource Class
RedGate.SQLCompare.Engine Namespace


IsValid Property

[image]

SQL Data Compare API 12.0.40
SnapshotSource..::.IsValid Property
SnapshotSource Class See Also

True if this snapshot represents a valid data source that can be used in comparison. If false, then there is a problem with the snapshot file - for example, it could not be found or is in the wrong format.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsValid As Boolean
C#
public override bool IsValid { get; }
Visual C++
public:
virtual property bool IsValid {
    bool get () override;
}

Implements

IDataSource..::.IsValid

See Also

SnapshotSource Class
RedGate.SQLCompare.Engine Namespace


IsWriteable Property

[image]

SQL Data Compare API 12.0.40
SnapshotSource..::.IsWriteable Property
SnapshotSource Class See Also

The data source cannot be written to.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsWriteable As Boolean
C#
public override bool IsWriteable { get; }
Visual C++
public:
virtual property bool IsWriteable {
    bool get () override;
}

Implements

IDataSource..::.IsWriteable

See Also

SnapshotSource Class
RedGate.SQLCompare.Engine Namespace


ServerName Property

[image]

SQL Data Compare API 12.0.40
SnapshotSource..::.ServerName Property
SnapshotSource Class See Also

Gets or sets the name of the SQL Server.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property ServerName As String
C#
public override string ServerName { get; set; }
Visual C++
public:
virtual property String^ ServerName {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IDataSource..::.ServerName

See Also

SnapshotSource Class
RedGate.SQLCompare.Engine Namespace


Version Property

[image]

SQL Data Compare API 12.0.40
SnapshotSource..::.Version Property
SnapshotSource Class See Also

Gets the current serialized version number of the snapshot.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Version As Integer
C#
public override int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () override;
}

See Also

SnapshotSource Class
RedGate.SQLCompare.Engine Namespace


SourceControlDataSource Class

[image]

SQL Data Compare API 12.0.40
SourceControlDataSource Class
Members See Also

A link to a SQL Source Control database

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SourceControlDataSource _
    Inherits DataSource _
    Implements IVersionedDatasource
C#
public sealed class SourceControlDataSource : DataSource, IVersionedDatasource
Visual C++
public ref class SourceControlDataSource sealed : public DataSource,
    IVersionedDatasource

Inheritance Hierarchy

Object
RedGate.Shared.SQL..::.DataSource
RedGate.SQLCompare.Engine..::.SourceControlDataSource

See Also

SourceControlDataSource Members
RedGate.SQLCompare.Engine Namespace


SourceControlDataSource Members

[image] [image]

SQL Data Compare API 12.0.40
SourceControlDataSource Members
SourceControlDataSource Class Constructors Methods Properties Explicit Interface Implementations See Also

The SourceControlDataSource type exposes the following members.

Constructors

Name | Description
SourceControlDataSource |

Methods

Name | Description
Clone | (Overrides DataSource ..::. Clone()()().)
Deserialize | (Overrides DataSource ..::. Deserialize(Int32, ISerializeFormatter).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FixupAfterDeserialization | uses a SOCCompareLink to resolve the location xml fragments
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDifferentSource | (Overrides DataSource ..::.IsDifferentSource(IDataSource).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | (Overrides DataSource ..::. Serialize(ISerializeFormatter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DatabaseName | (Overrides DataSource ..::. DatabaseName.)
Description | The source control repository description, will try the following in order 1) Get description from scriptFolderLocation. 2) If no location, try to fall back on the deserialized description 3) If theres no serialized description (eg from old SIP generated projects) it'll fall back to the servername
IsValid | (Overrides DataSource ..::. IsValid.)
IsWriteable | (Overrides DataSource ..::. IsWriteable.)
MigrationsFolderLocation |
ScriptFolderLocation |
ServerName | (Overrides DataSource ..::. ServerName.)
SpecificVersion |
Version | (Overrides DataSource ..::. Version.)
VersionType |

Explicit Interface Implementations

Name | Description
ICloneableClone | (Inherited from DataSource.)

See Also

SourceControlDataSource Class
RedGate.SQLCompare.Engine Namespace


SourceControlDataSource Constructor

[image]

SQL Data Compare API 12.0.40
SourceControlDataSource Constructor
SourceControlDataSource Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SourceControlDataSource()
Visual C++
public:
SourceControlDataSource()

See Also

SourceControlDataSource Class
RedGate.SQLCompare.Engine Namespace


SourceControlDataSource Methods

[image] [image]

SQL Data Compare API 12.0.40
SourceControlDataSource Methods
SourceControlDataSource Class See Also

The SourceControlDataSource type exposes the following methods.

Methods

Name | Description
Clone | (Overrides DataSource ..::. Clone()()().)
Deserialize | (Overrides DataSource ..::. Deserialize(Int32, ISerializeFormatter).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FixupAfterDeserialization | uses a SOCCompareLink to resolve the location xml fragments
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDifferentSource | (Overrides DataSource ..::.IsDifferentSource(IDataSource).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | (Overrides DataSource ..::. Serialize(ISerializeFormatter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICloneableClone | (Inherited from DataSource.)

See Also

SourceControlDataSource Class
RedGate.SQLCompare.Engine Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
SourceControlDataSource..::.Clone Method
SourceControlDataSource Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone As IDataSource
C#
public override IDataSource Clone()
Visual C++
public:
virtual IDataSource^ Clone() override

Implements

IVersionedDatasource..::.Clone()()()
IDataSource..::.Clone()()()

See Also

SourceControlDataSource Class
RedGate.SQLCompare.Engine Namespace


Deserialize Method

[image]

SQL Data Compare API 12.0.40
SourceControlDataSource..::.Deserialize Method
SourceControlDataSource Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Deserialize ( _
    versionId As Integer, _
    formatter As ISerializeFormatter _
) As Boolean
C#
public override bool Deserialize(
    int versionId,
    ISerializeFormatter formatter
)
Visual C++
public:
virtual bool Deserialize(
    int versionId,
    ISerializeFormatter^ formatter
) override

Parameters

versionId
Type: Int32
formatter
Type: ISerializeFormatter

See Also

SourceControlDataSource Class
RedGate.SQLCompare.Engine Namespace


FixupAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
SourceControlDataSource..::.FixupAfterDeserialization Method
SourceControlDataSource Class See Also

uses a SOCCompareLink to resolve the location xml fragments

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub FixupAfterDeserialization ( _
    link As ISOCCompareLink _
)
C#
public void FixupAfterDeserialization(
    ISOCCompareLink link
)
Visual C++
public:
void FixupAfterDeserialization(
    ISOCCompareLink^ link
)

Parameters

link
Type: ISOCCompareLink
The link to use

See Also

SourceControlDataSource Class
RedGate.SQLCompare.Engine Namespace


IsDifferentSource Method

[image]

SQL Data Compare API 12.0.40
SourceControlDataSource..::.IsDifferentSource Method
SourceControlDataSource Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsDifferentSource ( _
    newDataSource As IDataSource _
) As Boolean
C#
public override bool IsDifferentSource(
    IDataSource newDataSource
)
Visual C++
public:
virtual bool IsDifferentSource(
    IDataSource^ newDataSource
) override

Parameters

newDataSource
Type: RedGate.Shared.SQL..::.IDataSource

See Also

SourceControlDataSource Class
RedGate.SQLCompare.Engine Namespace


Serialize Method

[image]

SQL Data Compare API 12.0.40
SourceControlDataSource..::.Serialize Method
SourceControlDataSource Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    formatter As ISerializeFormatter _
)
C#
public override void Serialize(
    ISerializeFormatter formatter
)
Visual C++
public:
virtual void Serialize(
    ISerializeFormatter^ formatter
) override

Parameters

formatter
Type: ISerializeFormatter

See Also

SourceControlDataSource Class
RedGate.SQLCompare.Engine Namespace


SourceControlDataSource Properties

[image] [image]

SQL Data Compare API 12.0.40
SourceControlDataSource Properties
SourceControlDataSource Class See Also

The SourceControlDataSource type exposes the following properties.

Properties

Name | Description
DatabaseName | (Overrides DataSource ..::. DatabaseName.)
Description | The source control repository description, will try the following in order 1) Get description from scriptFolderLocation. 2) If no location, try to fall back on the deserialized description 3) If theres no serialized description (eg from old SIP generated projects) it'll fall back to the servername
IsValid | (Overrides DataSource ..::. IsValid.)
IsWriteable | (Overrides DataSource ..::. IsWriteable.)
MigrationsFolderLocation |
ScriptFolderLocation |
ServerName | (Overrides DataSource ..::. ServerName.)
SpecificVersion |
Version | (Overrides DataSource ..::. Version.)
VersionType |

See Also

SourceControlDataSource Class
RedGate.SQLCompare.Engine Namespace


DatabaseName Property

[image]

SQL Data Compare API 12.0.40
SourceControlDataSource..::.DatabaseName Property
SourceControlDataSource Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property DatabaseName As String
C#
public override string DatabaseName { get; set; }
Visual C++
public:
virtual property String^ DatabaseName {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IDataSource..::.DatabaseName

See Also

SourceControlDataSource Class
RedGate.SQLCompare.Engine Namespace


Description Property

[image]

SQL Data Compare API 12.0.40
SourceControlDataSource..::.Description Property
SourceControlDataSource Class See Also

The source control repository description, will try the following in order 1) Get description from scriptFolderLocation. 2) If no location, try to fall back on the deserialized description 3) If theres no serialized description (eg from old SIP generated projects) it'll fall back to the servername

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Description As String
C#
public string Description { get; }
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

SourceControlDataSource Class
RedGate.SQLCompare.Engine Namespace


IsValid Property

[image]

SQL Data Compare API 12.0.40
SourceControlDataSource..::.IsValid Property
SourceControlDataSource Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsValid As Boolean
C#
public override bool IsValid { get; }
Visual C++
public:
virtual property bool IsValid {
    bool get () override;
}

Implements

IDataSource..::.IsValid

See Also

SourceControlDataSource Class
RedGate.SQLCompare.Engine Namespace


IsWriteable Property

[image]

SQL Data Compare API 12.0.40
SourceControlDataSource..::.IsWriteable Property
SourceControlDataSource Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsWriteable As Boolean
C#
public override bool IsWriteable { get; }
Visual C++
public:
virtual property bool IsWriteable {
    bool get () override;
}

Implements

IDataSource..::.IsWriteable

See Also

SourceControlDataSource Class
RedGate.SQLCompare.Engine Namespace


MigrationsFolderLocation Property

[image]

SQL Data Compare API 12.0.40
SourceControlDataSource..::.MigrationsFolderLocation Property
SourceControlDataSource Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property MigrationsFolderLocation As ISOCCompareLocation
C#
public ISOCCompareLocation MigrationsFolderLocation { get; set; }
Visual C++
public:
virtual property ISOCCompareLocation^ MigrationsFolderLocation {
    ISOCCompareLocation^ get () sealed;
    void set (ISOCCompareLocation^ value) sealed;
}

See Also

SourceControlDataSource Class
RedGate.SQLCompare.Engine Namespace


ScriptFolderLocation Property

[image]

SQL Data Compare API 12.0.40
SourceControlDataSource..::.ScriptFolderLocation Property
SourceControlDataSource Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptFolderLocation As ISOCCompareLocation
C#
public ISOCCompareLocation ScriptFolderLocation { get; set; }
Visual C++
public:
virtual property ISOCCompareLocation^ ScriptFolderLocation {
    ISOCCompareLocation^ get () sealed;
    void set (ISOCCompareLocation^ value) sealed;
}

See Also

SourceControlDataSource Class
RedGate.SQLCompare.Engine Namespace


ServerName Property

[image]

SQL Data Compare API 12.0.40
SourceControlDataSource..::.ServerName Property
SourceControlDataSource Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property ServerName As String
C#
public override string ServerName { get; set; }
Visual C++
public:
virtual property String^ ServerName {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IDataSource..::.ServerName

See Also

SourceControlDataSource Class
RedGate.SQLCompare.Engine Namespace


SpecificVersion Property

[image]

SQL Data Compare API 12.0.40
SourceControlDataSource..::.SpecificVersion Property
SourceControlDataSource Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property SpecificVersion As String
C#
public string SpecificVersion { get; set; }
Visual C++
public:
virtual property String^ SpecificVersion {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IVersionedDatasource..::.SpecificVersion

See Also

SourceControlDataSource Class
RedGate.SQLCompare.Engine Namespace


Version Property

[image]

SQL Data Compare API 12.0.40
SourceControlDataSource..::.Version Property
SourceControlDataSource Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Version As Integer
C#
public override int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () override;
}

See Also

SourceControlDataSource Class
RedGate.SQLCompare.Engine Namespace


VersionType Property

[image]

SQL Data Compare API 12.0.40
SourceControlDataSource..::.VersionType Property
SourceControlDataSource Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property VersionType As VersionType
C#
public VersionType VersionType { get; set; }
Visual C++
public:
virtual property VersionType VersionType {
    VersionType get () sealed;
    void set (VersionType value) sealed;
}

Implements

IVersionedDatasource..::.VersionType

See Also

SourceControlDataSource Class
RedGate.SQLCompare.Engine Namespace


SourceControlInfo Class

[image]

SQL Data Compare API 12.0.40
SourceControlInfo Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SourceControlInfo
C#
public class SourceControlInfo
Visual C++
public ref class SourceControlInfo

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.SourceControlInfo

See Also

SourceControlInfo Members
RedGate.SQLCompare.Engine Namespace


SourceControlInfo Members

[image] [image]

SQL Data Compare API 12.0.40
SourceControlInfo Members
SourceControlInfo Class Constructors Methods Properties See Also

The SourceControlInfo type exposes the following members.

Constructors

Name | Description
SourceControlInfo | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MigrationFolderLocation |
ScriptFolderLocation |
Version |
VersionInfo |

See Also

SourceControlInfo Class
RedGate.SQLCompare.Engine Namespace


SourceControlInfo Constructor

[image] [image]

SQL Data Compare API 12.0.40
SourceControlInfo Constructor
SourceControlInfo Class See Also

Overload List

Name | Description
SourceControlInfo()()() |
SourceControlInfo(Nullable<(Of <(Int64>)>), ISOCCompareLocation, ISOCCompareLocation) |
SourceControlInfo(String, ISOCCompareLocation, ISOCCompareLocation) |

See Also

SourceControlInfo Class
SourceControlInfo Members
RedGate.SQLCompare.Engine Namespace


SourceControlInfo Constructor

[image]

SQL Data Compare API 12.0.40
SourceControlInfo Constructor
SourceControlInfo Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SourceControlInfo()
Visual C++
public:
SourceControlInfo()

See Also

SourceControlInfo Class
SourceControlInfo Overload
RedGate.SQLCompare.Engine Namespace


SourceControlInfo Constructor ((), , )

[image]

SQL Data Compare API 12.0.40
SourceControlInfo Constructor (<(Of <(>)>), , )
SourceControlInfo Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    version As Nullable(Of Long), _
    scriptFolderLocation As ISOCCompareLocation, _
    migrationFolderLocation As ISOCCompareLocation _
)
C#
public SourceControlInfo(
    Nullable<long> version,
    ISOCCompareLocation scriptFolderLocation,
    ISOCCompareLocation migrationFolderLocation
)
Visual C++
public:
SourceControlInfo(
    Nullable<long long> version,
    ISOCCompareLocation^ scriptFolderLocation,
    ISOCCompareLocation^ migrationFolderLocation
)

Parameters

version
Type: Nullable<(Of <(Int64>)>)
scriptFolderLocation
Type: ISOCCompareLocation
migrationFolderLocation
Type: ISOCCompareLocation

See Also

SourceControlInfo Class
SourceControlInfo Overload
RedGate.SQLCompare.Engine Namespace


SourceControlInfo Constructor (, , )

[image]

SQL Data Compare API 12.0.40
SourceControlInfo Constructor (, , )
SourceControlInfo Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    versionString As String, _
    scriptFolderLocation As ISOCCompareLocation, _
    migrationFolderLocation As ISOCCompareLocation _
)
C#
public SourceControlInfo(
    string versionString,
    ISOCCompareLocation scriptFolderLocation,
    ISOCCompareLocation migrationFolderLocation
)
Visual C++
public:
SourceControlInfo(
    String^ versionString,
    ISOCCompareLocation^ scriptFolderLocation,
    ISOCCompareLocation^ migrationFolderLocation
)

Parameters

versionString
Type: String
scriptFolderLocation
Type: ISOCCompareLocation
migrationFolderLocation
Type: ISOCCompareLocation

See Also

SourceControlInfo Class
SourceControlInfo Overload
RedGate.SQLCompare.Engine Namespace


SourceControlInfo Properties

[image] [image]

SQL Data Compare API 12.0.40
SourceControlInfo Properties
SourceControlInfo Class See Also

The SourceControlInfo type exposes the following properties.

Properties

Name | Description
MigrationFolderLocation |
ScriptFolderLocation |
Version |
VersionInfo |

See Also

SourceControlInfo Class
RedGate.SQLCompare.Engine Namespace


MigrationFolderLocation Property

[image]

SQL Data Compare API 12.0.40
SourceControlInfo..::.MigrationFolderLocation Property
SourceControlInfo Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MigrationFolderLocation As ISOCCompareLocation
C#
public ISOCCompareLocation MigrationFolderLocation { get; }
Visual C++
public:
property ISOCCompareLocation^ MigrationFolderLocation {
    ISOCCompareLocation^ get ();
}

See Also

SourceControlInfo Class
RedGate.SQLCompare.Engine Namespace


ScriptFolderLocation Property

[image]

SQL Data Compare API 12.0.40
SourceControlInfo..::.ScriptFolderLocation Property
SourceControlInfo Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ScriptFolderLocation As ISOCCompareLocation
C#
public ISOCCompareLocation ScriptFolderLocation { get; }
Visual C++
public:
property ISOCCompareLocation^ ScriptFolderLocation {
    ISOCCompareLocation^ get ();
}

See Also

SourceControlInfo Class
RedGate.SQLCompare.Engine Namespace


Version Property

[image]

SQL Data Compare API 12.0.40
SourceControlInfo..::.Version Property
SourceControlInfo Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As Nullable(Of Long)
C#
public Nullable<long> Version { get; }
Visual C++
public:
property Nullable<long long> Version {
    Nullable<long long> get ();
}

See Also

SourceControlInfo Class
RedGate.SQLCompare.Engine Namespace


VersionInfo Property

[image]

SQL Data Compare API 12.0.40
SourceControlInfo..::.VersionInfo Property
SourceControlInfo Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VersionInfo As VersionInfo
C#
public VersionInfo VersionInfo { get; }
Visual C++
public:
property VersionInfo^ VersionInfo {
    VersionInfo^ get ();
}

See Also

SourceControlInfo Class
RedGate.SQLCompare.Engine Namespace


SpatialIndex Class

[image]

SQL Data Compare API 12.0.40
SpatialIndex Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SpatialIndex _
    Inherits Index
C#
public sealed class SpatialIndex : Index
Visual C++
public ref class SpatialIndex sealed : public Index

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.Index
RedGate.SQLCompare.Engine..::.SpatialIndex

See Also

SpatialIndex Members
RedGate.SQLCompare.Engine Namespace


SpatialIndex Members

[image] [image]

SQL Data Compare API 12.0.40
SpatialIndex Members
SpatialIndex Class Methods Properties Explicit Interface Implementations See Also

The SpatialIndex type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FieldsCompareWith | (Inherited from Index.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowPageLocks | True if the index allows page locks. (Inherited from Index.)
AllowRowLocks | True if the index allows row locks. (Inherited from Index.)
BoundingBoxXMax | The x-coordinate of the upper-right corner of the bounding box.
BoundingBoxXMin | The x-coordinate of the lower-left corner of the bounding box.
BoundingBoxYMax | The y-coordinate of the upper-right corner of the bounding box.
BoundingBoxYMin | The y-coordinate of the lower-left corner of the bounding box.
CellsPerObject | The number of tesselation cells per objects.
Clustered | Obsolete. (Inherited from Index.)
Database | The database to which the index belongs. (Inherited from Index.)
Fields | The fields in the index. (Inherited from Index.)
FileGroup | Obsolete. (Inherited from Index.)
FileGroupOrPartitionScheme | The filegroup or the partition scheme on which the index is defined. (Inherited from Index.)
FilestreamFileGroup | Obsolete. (Inherited from Index.)
FillFactor | The fill factor. (Inherited from Index.)
Filter | Obsolete. (Inherited from Index.)
FullScan | True if the index is defined with FullScan (Inherited from Index.)
FullyQualifiedName | Obsolete. The fully-qualified name of the index. DANGER WILL ROBINSON!! This is not escaped. (Inherited from Index.)
IgnoreDuplicateKeys | True if set to ignore duplicate keys. (Inherited from Index.)
Incremental | True if incremental (introduced in SQL Server 2014) (Inherited from Index.)
IsColumnstore | Stupid columnstore indexes mark all of their fields as included but use the normal syntax to list them. (http://msdn.microsoft.com/en-us/library/ms175105.aspx) (Inherited from Index.)
IsDisabled | Indicates whether the index is disabled. (Inherited from Index.)
IsKeyIndexForFullTextIndex | Obsolete. (Inherited from Index.)
IsPartitioned | Indicates whether the index is built on a partition scheme. If it is, the name of the partition scheme is returned by the FileGroupOrPartitionScheme property. (Inherited from Index.)
Level1Grid | The first tesselation level's grid density.
Level2Grid | The second tesselation level's grid density.
Level3Grid | The third tesselation level's grid density.
Level4Grid | The fourth tesselation level's grid density.
Name | The name of the index. DANGER WILL ROBINSON!! This is not escaped. Do you mean Index..::.QualifiedName? (Inherited from Index.)
NoRecompute | True if the index is defined with NORECOMPUTE. (Inherited from Index.)
ObjectType | Returns ObjectType.Index (Inherited from Index.)
Online | True iff the index is to be created online. (Inherited from Index.)
Owner | The owner of the index's table. (Inherited from Index.)
Pad | The index padding. (Inherited from Index.)
PartitionedField | Obsolete. (Inherited from Index.)
PrimaryKey | Obsolete. (Inherited from Index.)
QualifiedName | The qualified name of the object. Do you mean Index..::.Name? (Inherited from Index.)
Relational | True if this is a relational index. (Inherited from Index.)
ScriptSource | The location of the creation script for this object if the database source is set to scripts folder. (Inherited from Index.)
SortInTempDb | True iff the index is to be created using tempdb. (Inherited from Index.)
Spatial | True if the index is a spatial index. (Inherited from Index.)
SpatialIndexInformation | Obsolete. (Inherited from Index.)
SpatialIndexType | The type of the spatial index. In SQL Server 2008 it can be either geometry or geography.
Statistics | True if the index is a statistic. (Inherited from Index.)
SysobjectID | The sysobject identier of the object. (Inherited from Index.)
SystemNamed | (Inherited from Index.)
TesselationScheme | The tesselation scheme of the spatial index.
Unique | Obsolete. (Inherited from Index.)
UniqueConstraint | Obsolete. (Inherited from Index.)
WriteFileGroupOrPartitionScheme | Whether (disregarding any options) the filegroup should be written out (Inherited from Index.)
Xml | True if the index is an XML index. (Inherited from Index.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith | (Inherited from Index.)
IDatabaseObject..::.Equals | (Inherited from Index.)

See Also

SpatialIndex Class
RedGate.SQLCompare.Engine Namespace


SpatialIndex Properties

[image] [image]

SQL Data Compare API 12.0.40
SpatialIndex Properties
SpatialIndex Class See Also

The SpatialIndex type exposes the following properties.

Properties

Name | Description
AllowPageLocks | True if the index allows page locks. (Inherited from Index.)
AllowRowLocks | True if the index allows row locks. (Inherited from Index.)
BoundingBoxXMax | The x-coordinate of the upper-right corner of the bounding box.
BoundingBoxXMin | The x-coordinate of the lower-left corner of the bounding box.
BoundingBoxYMax | The y-coordinate of the upper-right corner of the bounding box.
BoundingBoxYMin | The y-coordinate of the lower-left corner of the bounding box.
CellsPerObject | The number of tesselation cells per objects.
Clustered | Obsolete. (Inherited from Index.)
Database | The database to which the index belongs. (Inherited from Index.)
Fields | The fields in the index. (Inherited from Index.)
FileGroup | Obsolete. (Inherited from Index.)
FileGroupOrPartitionScheme | The filegroup or the partition scheme on which the index is defined. (Inherited from Index.)
FilestreamFileGroup | Obsolete. (Inherited from Index.)
FillFactor | The fill factor. (Inherited from Index.)
Filter | Obsolete. (Inherited from Index.)
FullScan | True if the index is defined with FullScan (Inherited from Index.)
FullyQualifiedName | Obsolete. The fully-qualified name of the index. DANGER WILL ROBINSON!! This is not escaped. (Inherited from Index.)
IgnoreDuplicateKeys | True if set to ignore duplicate keys. (Inherited from Index.)
Incremental | True if incremental (introduced in SQL Server 2014) (Inherited from Index.)
IsColumnstore | Stupid columnstore indexes mark all of their fields as included but use the normal syntax to list them. (http://msdn.microsoft.com/en-us/library/ms175105.aspx) (Inherited from Index.)
IsDisabled | Indicates whether the index is disabled. (Inherited from Index.)
IsKeyIndexForFullTextIndex | Obsolete. (Inherited from Index.)
IsPartitioned | Indicates whether the index is built on a partition scheme. If it is, the name of the partition scheme is returned by the FileGroupOrPartitionScheme property. (Inherited from Index.)
Level1Grid | The first tesselation level's grid density.
Level2Grid | The second tesselation level's grid density.
Level3Grid | The third tesselation level's grid density.
Level4Grid | The fourth tesselation level's grid density.
Name | The name of the index. DANGER WILL ROBINSON!! This is not escaped. Do you mean Index..::.QualifiedName? (Inherited from Index.)
NoRecompute | True if the index is defined with NORECOMPUTE. (Inherited from Index.)
ObjectType | Returns ObjectType.Index (Inherited from Index.)
Online | True iff the index is to be created online. (Inherited from Index.)
Owner | The owner of the index's table. (Inherited from Index.)
Pad | The index padding. (Inherited from Index.)
PartitionedField | Obsolete. (Inherited from Index.)
PrimaryKey | Obsolete. (Inherited from Index.)
QualifiedName | The qualified name of the object. Do you mean Index..::.Name? (Inherited from Index.)
Relational | True if this is a relational index. (Inherited from Index.)
ScriptSource | The location of the creation script for this object if the database source is set to scripts folder. (Inherited from Index.)
SortInTempDb | True iff the index is to be created using tempdb. (Inherited from Index.)
Spatial | True if the index is a spatial index. (Inherited from Index.)
SpatialIndexInformation | Obsolete. (Inherited from Index.)
SpatialIndexType | The type of the spatial index. In SQL Server 2008 it can be either geometry or geography.
Statistics | True if the index is a statistic. (Inherited from Index.)
SysobjectID | The sysobject identier of the object. (Inherited from Index.)
SystemNamed | (Inherited from Index.)
TesselationScheme | The tesselation scheme of the spatial index.
Unique | Obsolete. (Inherited from Index.)
UniqueConstraint | Obsolete. (Inherited from Index.)
WriteFileGroupOrPartitionScheme | Whether (disregarding any options) the filegroup should be written out (Inherited from Index.)
Xml | True if the index is an XML index. (Inherited from Index.)

See Also

SpatialIndex Class
RedGate.SQLCompare.Engine Namespace


BoundingBoxXMax Property

[image]

SQL Data Compare API 12.0.40
SpatialIndex..::.BoundingBoxXMax Property
SpatialIndex Class See Also

The x-coordinate of the upper-right corner of the bounding box.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BoundingBoxXMax As Double
C#
public double BoundingBoxXMax { get; internal set; }
Visual C++
public:
property double BoundingBoxXMax {
    double get ();
    void set (double value);
}

See Also

SpatialIndex Class
RedGate.SQLCompare.Engine Namespace


BoundingBoxXMin Property

[image]

SQL Data Compare API 12.0.40
SpatialIndex..::.BoundingBoxXMin Property
SpatialIndex Class See Also

The x-coordinate of the lower-left corner of the bounding box.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BoundingBoxXMin As Double
C#
public double BoundingBoxXMin { get; internal set; }
Visual C++
public:
property double BoundingBoxXMin {
    double get ();
    void set (double value);
}

See Also

SpatialIndex Class
RedGate.SQLCompare.Engine Namespace


BoundingBoxYMax Property

[image]

SQL Data Compare API 12.0.40
SpatialIndex..::.BoundingBoxYMax Property
SpatialIndex Class See Also

The y-coordinate of the upper-right corner of the bounding box.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BoundingBoxYMax As Double
C#
public double BoundingBoxYMax { get; internal set; }
Visual C++
public:
property double BoundingBoxYMax {
    double get ();
    void set (double value);
}

See Also

SpatialIndex Class
RedGate.SQLCompare.Engine Namespace


BoundingBoxYMin Property

[image]

SQL Data Compare API 12.0.40
SpatialIndex..::.BoundingBoxYMin Property
SpatialIndex Class See Also

The y-coordinate of the lower-left corner of the bounding box.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BoundingBoxYMin As Double
C#
public double BoundingBoxYMin { get; internal set; }
Visual C++
public:
property double BoundingBoxYMin {
    double get ();
    void set (double value);
}

See Also

SpatialIndex Class
RedGate.SQLCompare.Engine Namespace


CellsPerObject Property

[image]

SQL Data Compare API 12.0.40
SpatialIndex..::.CellsPerObject Property
SpatialIndex Class See Also

The number of tesselation cells per objects.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CellsPerObject As Short
C#
public short CellsPerObject { get; internal set; }
Visual C++
public:
property short CellsPerObject {
    short get ();
    void set (short value);
}

See Also

SpatialIndex Class
RedGate.SQLCompare.Engine Namespace


Level1Grid Property

[image]

SQL Data Compare API 12.0.40
SpatialIndex..::.Level1Grid Property
SpatialIndex Class See Also

The first tesselation level's grid density.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Level1Grid As GridDensity
C#
public GridDensity Level1Grid { get; internal set; }
Visual C++
public:
property GridDensity Level1Grid {
    GridDensity get ();
    void set (GridDensity value);
}

See Also

SpatialIndex Class
RedGate.SQLCompare.Engine Namespace


Level2Grid Property

[image]

SQL Data Compare API 12.0.40
SpatialIndex..::.Level2Grid Property
SpatialIndex Class See Also

The second tesselation level's grid density.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Level2Grid As GridDensity
C#
public GridDensity Level2Grid { get; internal set; }
Visual C++
public:
property GridDensity Level2Grid {
    GridDensity get ();
    void set (GridDensity value);
}

See Also

SpatialIndex Class
RedGate.SQLCompare.Engine Namespace


Level3Grid Property

[image]

SQL Data Compare API 12.0.40
SpatialIndex..::.Level3Grid Property
SpatialIndex Class See Also

The third tesselation level's grid density.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Level3Grid As GridDensity
C#
public GridDensity Level3Grid { get; internal set; }
Visual C++
public:
property GridDensity Level3Grid {
    GridDensity get ();
    void set (GridDensity value);
}

See Also

SpatialIndex Class
RedGate.SQLCompare.Engine Namespace


Level4Grid Property

[image]

SQL Data Compare API 12.0.40
SpatialIndex..::.Level4Grid Property
SpatialIndex Class See Also

The fourth tesselation level's grid density.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Level4Grid As GridDensity
C#
public GridDensity Level4Grid { get; internal set; }
Visual C++
public:
property GridDensity Level4Grid {
    GridDensity get ();
    void set (GridDensity value);
}

See Also

SpatialIndex Class
RedGate.SQLCompare.Engine Namespace


SpatialIndexType Property

[image]

SQL Data Compare API 12.0.40
SpatialIndex..::.SpatialIndexType Property
SpatialIndex Class See Also

The type of the spatial index. In SQL Server 2008 it can be either geometry or geography.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SpatialIndexType As SpatialIndexType
C#
public SpatialIndexType SpatialIndexType { get; internal set; }
Visual C++
public:
property SpatialIndexType SpatialIndexType {
    SpatialIndexType get ();
    void set (SpatialIndexType value);
}

See Also

SpatialIndex Class
RedGate.SQLCompare.Engine Namespace


TesselationScheme Property

[image]

SQL Data Compare API 12.0.40
SpatialIndex..::.TesselationScheme Property
SpatialIndex Class See Also

The tesselation scheme of the spatial index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TesselationScheme As TesselationScheme
C#
public TesselationScheme TesselationScheme { get; internal set; }
Visual C++
public:
property TesselationScheme TesselationScheme {
    TesselationScheme get ();
    void set (TesselationScheme value);
}

See Also

SpatialIndex Class
RedGate.SQLCompare.Engine Namespace


.GridDensities Enumeration

[image]

SQL Data Compare API 12.0.40
..::.GridDensities Enumeration
SpatialIndexInformation See Also

The grid densities of spatial indexes

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Please use RedGate.SQLCompare.Engine.GridDensity (singular) instead",  _
    True)> _
Public Enumeration GridDensities
C#
[ObsoleteAttribute("Please use RedGate.SQLCompare.Engine.GridDensity (singular) instead",
    true)]
public enum GridDensities
Visual C++
[ObsoleteAttribute(L"Please use RedGate.SQLCompare.Engine.GridDensity (singular) instead",
    true)]
public enum class GridDensities

Members

Member name | Description
LOW | LOW (16)
MEDIUM | MEDIUM (64)
HIGH | HIGH (256)

See Also

RedGate.SQLCompare.Engine Namespace


.SpatialIndexTypes Enumeration

[image]

SQL Data Compare API 12.0.40
..::.SpatialIndexTypes Enumeration
SpatialIndexInformation See Also

The type of the spatial index. In SQL Server 2008 this can be either geometry or geography.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Please use RedGate.SQLCompare.Engine.SpatialIndexType (singular) instead",  _
    True)> _
Public Enumeration SpatialIndexTypes
C#
[ObsoleteAttribute("Please use RedGate.SQLCompare.Engine.SpatialIndexType (singular) instead",
    true)]
public enum SpatialIndexTypes
Visual C++
[ObsoleteAttribute(L"Please use RedGate.SQLCompare.Engine.SpatialIndexType (singular) instead",
    true)]
public enum class SpatialIndexTypes

Members

Member name | Description
Geometry | Geometry
Geography | Geography

See Also

RedGate.SQLCompare.Engine Namespace


.TesselationSchemes Enumeration

[image]

SQL Data Compare API 12.0.40
..::.TesselationSchemes Enumeration
SpatialIndexInformation See Also

Used to specify the tesselation scheme for the spatial index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Please use RedGate.SQLCompare.Engine.TesselationScheme (singular) instead",  _
    True)> _
Public Enumeration TesselationSchemes
C#
[ObsoleteAttribute("Please use RedGate.SQLCompare.Engine.TesselationScheme (singular) instead",
    true)]
public enum TesselationSchemes
Visual C++
[ObsoleteAttribute(L"Please use RedGate.SQLCompare.Engine.TesselationScheme (singular) instead",
    true)]
public enum class TesselationSchemes

Members

Member name | Description
GeometryGrid | GEOMETRY_GRID
GeographyGrid | GEOGRAPHY_GRID

See Also

RedGate.SQLCompare.Engine Namespace


SpatialIndexType Enumeration

[image]

SQL Data Compare API 12.0.40
SpatialIndexType Enumeration
See Also

The type of the spatial index. In SQL Server 2008 this can be either geometry or geography.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration SpatialIndexType
C#
public enum SpatialIndexType
Visual C++
public enum class SpatialIndexType

Members

Member name | Description
Geometry | Geometry
Geography | Geography

See Also

RedGate.SQLCompare.Engine Namespace


SqbEncryptionLevel Enumeration

[image]

SQL Data Compare API 12.0.40
SqbEncryptionLevel Enumeration
See Also

SQB encryption level enumeration

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration SqbEncryptionLevel
C#
public enum SqbEncryptionLevel
Visual C++
public enum class SqbEncryptionLevel

Members

Member name | Description
None |
AES128 |
AES256 |

See Also

RedGate.SQLCompare.Engine Namespace


SqlBackupLicenseType Enumeration

[image]

SQL Data Compare API 12.0.40
SqlBackupLicenseType Enumeration
See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration SqlBackupLicenseType
C#
public enum SqlBackupLicenseType
Visual C++
public enum class SqlBackupLicenseType

Members

Member name | Description
None |
Lite |
Standard |
Pro |

See Also

RedGate.SQLCompare.Engine Namespace


SqlCompareArgumentException Class

[image]

SQL Data Compare API 12.0.40
SqlCompareArgumentException Class
Members See Also

This exception is used as the general exception for SQL Compare.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class SqlCompareArgumentException _
    Inherits SqlCompareException
C#
[SerializableAttribute]
public class SqlCompareArgumentException : SqlCompareException
Visual C++
[SerializableAttribute]
public ref class SqlCompareArgumentException : public SqlCompareException

Inheritance Hierarchy

Object
Exception
RedGate.SQLCompare.Engine..::.SqlCompareException
RedGate.SQLCompare.Engine..::.SqlCompareArgumentException

See Also

SqlCompareArgumentException Members
RedGate.SQLCompare.Engine Namespace


SqlCompareArgumentException Members

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareArgumentException Members
SqlCompareArgumentException Class Constructors Methods Properties See Also

The SqlCompareArgumentException type exposes the following members.

Constructors

Name | Description
SqlCompareArgumentException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SqlCompareArgumentException Class
RedGate.SQLCompare.Engine Namespace


SqlCompareArgumentException Constructor

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareArgumentException Constructor
SqlCompareArgumentException Class See Also

Overload List

Name | Description
SqlCompareArgumentException()()() | Constructs a SqlCompareArgumentException exception.
SqlCompareArgumentException(String) | Constructs a SqlCompareArgumentException exception.
SqlCompareArgumentException(SerializationInfo, StreamingContext) | Constructs a SqlCompareArgumentException exception.
SqlCompareArgumentException(String, Exception) | Constructs a SqlCompareArgumentException exception.

See Also

SqlCompareArgumentException Class
SqlCompareArgumentException Members
RedGate.SQLCompare.Engine Namespace


SqlCompareArgumentException Constructor

[image]

SQL Data Compare API 12.0.40
SqlCompareArgumentException Constructor
SqlCompareArgumentException Class See Also

Constructs a SqlCompareArgumentException exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlCompareArgumentException()
Visual C++
public:
SqlCompareArgumentException()

See Also

SqlCompareArgumentException Class
SqlCompareArgumentException Overload
RedGate.SQLCompare.Engine Namespace


SqlCompareArgumentException Constructor ()

[image]

SQL Data Compare API 12.0.40
SqlCompareArgumentException Constructor ()
SqlCompareArgumentException Class See Also

Constructs a SqlCompareArgumentException exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public SqlCompareArgumentException(
    string message
)
Visual C++
public:
SqlCompareArgumentException(
    String^ message
)

Parameters

message
Type: String
The message for the exception.

See Also

SqlCompareArgumentException Class
SqlCompareArgumentException Overload
RedGate.SQLCompare.Engine Namespace


SqlCompareArgumentException Constructor (, )

[image]

SQL Data Compare API 12.0.40
SqlCompareArgumentException Constructor (, )
SqlCompareArgumentException Class See Also

Constructs a SqlCompareArgumentException exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected SqlCompareArgumentException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
SqlCompareArgumentException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: SerializationInfo
context
Type: StreamingContext

See Also

SqlCompareArgumentException Class
SqlCompareArgumentException Overload
RedGate.SQLCompare.Engine Namespace


SqlCompareArgumentException Constructor (, )

[image]

SQL Data Compare API 12.0.40
SqlCompareArgumentException Constructor (, )
SqlCompareArgumentException Class See Also

Constructs a SqlCompareArgumentException exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
C#
public SqlCompareArgumentException(
    string message,
    Exception inner
)
Visual C++
public:
SqlCompareArgumentException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: String
The message for the exception.
inner
Type: Exception
The inner exception.

See Also

SqlCompareArgumentException Class
SqlCompareArgumentException Overload
RedGate.SQLCompare.Engine Namespace


SqlCompareException Class

[image]

SQL Data Compare API 12.0.40
SqlCompareException Class
Members See Also

This exception is used as the general exception for SQL Compare.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class SqlCompareException _
    Inherits Exception
C#
[SerializableAttribute]
public class SqlCompareException : Exception
Visual C++
[SerializableAttribute]
public ref class SqlCompareException : public Exception

Inheritance Hierarchy

Object
Exception
RedGate.SQLCompare.Engine..::.SqlCompareException
RedGate.SQLCompare.Engine..::.DuplicateObjectNameException
RedGate.SQLCompare.Engine..::.SqlCompareArgumentException
RedGate.SQLCompare.Engine..::.UnsupportedDataWarehouseException
RedGate.SQLCompare.Engine..::.UnsupportedSqlServerVersionException
RedGate.SQLCompare.Engine..::.ObjectNotInDatabaseException
RedGate.SQLCompare.Engine..::.ObjectNotInDifferences
RedGate.SQLCompare.Engine.Filter..::.FilterException
RedGate.SQLCompare.Engine.Settings..::.UnknownOptionException
RedGate.SQLCompare.Engine.ReadFromFolder..::.ErrorsOccurredDuringScriptFileParsingException
RedGate.SQLCompare.Engine.Registration.QueryResult..::.InvalidDmvQueryResultException

See Also

SqlCompareException Members
RedGate.SQLCompare.Engine Namespace


SqlCompareException Members

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareException Members
SqlCompareException Class Constructors Methods Properties See Also

The SqlCompareException type exposes the following members.

Constructors

Name | Description
SqlCompareException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SqlCompareException Class
RedGate.SQLCompare.Engine Namespace


SqlCompareException Constructor

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareException Constructor
SqlCompareException Class See Also

Overload List

Name | Description
SqlCompareException()()() | Constructs a SqlCompareException exception.
SqlCompareException(String) | Constructs a SqlCompareException exception.
SqlCompareException(SerializationInfo, StreamingContext) | Constructs an SqlCompareException exception.
SqlCompareException(String, Exception) | Constructs a SqlCompareException exception.

See Also

SqlCompareException Class
SqlCompareException Members
RedGate.SQLCompare.Engine Namespace


SqlCompareException Constructor

[image]

SQL Data Compare API 12.0.40
SqlCompareException Constructor
SqlCompareException Class See Also

Constructs a SqlCompareException exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlCompareException()
Visual C++
public:
SqlCompareException()

See Also

SqlCompareException Class
SqlCompareException Overload
RedGate.SQLCompare.Engine Namespace


SqlCompareException Constructor ()

[image]

SQL Data Compare API 12.0.40
SqlCompareException Constructor ()
SqlCompareException Class See Also

Constructs a SqlCompareException exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public SqlCompareException(
    string message
)
Visual C++
public:
SqlCompareException(
    String^ message
)

Parameters

message
Type: String
The message for the exception.

See Also

SqlCompareException Class
SqlCompareException Overload
RedGate.SQLCompare.Engine Namespace


SqlCompareException Constructor (, )

[image]

SQL Data Compare API 12.0.40
SqlCompareException Constructor (, )
SqlCompareException Class See Also

Constructs an SqlCompareException exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected SqlCompareException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
SqlCompareException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: SerializationInfo
context
Type: StreamingContext

See Also

SqlCompareException Class
SqlCompareException Overload
RedGate.SQLCompare.Engine Namespace


SqlCompareException Constructor (, )

[image]

SQL Data Compare API 12.0.40
SqlCompareException Constructor (, )
SqlCompareException Class See Also

Constructs a SqlCompareException exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
C#
public SqlCompareException(
    string message,
    Exception inner
)
Visual C++
public:
SqlCompareException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: String
The message for the exception.
inner
Type: Exception
The inner exception.

See Also

SqlCompareException Class
SqlCompareException Overload
RedGate.SQLCompare.Engine Namespace


SqlCompareFieldMapping Class

[image]

SQL Data Compare API 12.0.40
SqlCompareFieldMapping Class
Members See Also

Contains a mapping from a field in one table to a field in another table.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlCompareFieldMapping _
    Inherits Mapping(Of IField)
C#
public class SqlCompareFieldMapping : Mapping<IField>
Visual C++
public ref class SqlCompareFieldMapping : public Mapping<IField^>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.Mapping <(Of <( IField >)>)
RedGate.SQLCompare.Engine..::.SqlCompareFieldMapping

See Also

SqlCompareFieldMapping Members
RedGate.SQLCompare.Engine Namespace


SqlCompareFieldMapping Members

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareFieldMapping Members
SqlCompareFieldMapping Class Constructors Methods Fields Properties Explicit Interface Implementations See Also

The SqlCompareFieldMapping type exposes the following members.

Constructors

Name | Description
SqlCompareFieldMapping | Constructor. Calls the base constructor.

Methods

Name | Description
Clone | Creates a shallow copy of the field mapping. (Overrides Mapping <(Of <( IField >)>)..::. Clone()()().)
CompareTo | Sorts the FieldMappings by fully-qualified name in the first database; if null in the first database, sorts by fully-qualified name in the second database. (Overrides Mapping <(Of <( IField >)>)..::. CompareTo(Mapping<(Of <(T>)>)).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Mapping<(Of <(T>)>).)

Fields

Name | Description
m_Messages | (Inherited from Mapping<(Of <(T>)>).)

Properties

Name | Description
Include | Specifies whether the mapping is to be included. (Inherited from Mapping<(Of <(T>)>).)
Messages | Messages that explain any issues concerning the mapping; null if no issues exist. (Inherited from Mapping<(Of <(T>)>).)
Obj1 | Returns the object from the first database (Inherited from Mapping<(Of <(T>)>).)
Obj2 | Returns the object from the second database (Inherited from Mapping<(Of <(T>)>).)
Status | The status of the field mapping.
ValidForMatching | Specifies whether the FieldMapping can be used in a matching mapping.

Explicit Interface Implementations

Name | Description
ICloneableClone | Creates a shallow copy. (Inherited from Mapping<(Of <(T>)>).)

See Also

SqlCompareFieldMapping Class
RedGate.SQLCompare.Engine Namespace


SqlCompareFieldMapping Constructor

[image]

SQL Data Compare API 12.0.40
SqlCompareFieldMapping Constructor
SqlCompareFieldMapping Class See Also

Constructor. Calls the base constructor.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    obj1 As IField, _
    obj2 As IField, _
    status As SqlCompareFieldMappingStatus _
)
C#
public SqlCompareFieldMapping(
    IField obj1,
    IField obj2,
    SqlCompareFieldMappingStatus status
)
Visual C++
public:
SqlCompareFieldMapping(
    IField^ obj1,
    IField^ obj2,
    SqlCompareFieldMappingStatus status
)

Parameters

obj1
Type: RedGate.SQLCompare.Engine..::.IField
The field in the first database.
obj2
Type: RedGate.SQLCompare.Engine..::.IField
The field in the second database.
status
Type: RedGate.SQLCompare.Engine..::.SqlCompareFieldMappingStatus
The status of the mapping.

See Also

SqlCompareFieldMapping Class
RedGate.SQLCompare.Engine Namespace


SqlCompareFieldMapping Methods

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareFieldMapping Methods
SqlCompareFieldMapping Class See Also

The SqlCompareFieldMapping type exposes the following methods.

Methods

Name | Description
Clone | Creates a shallow copy of the field mapping. (Overrides Mapping <(Of <( IField >)>)..::. Clone()()().)
CompareTo | Sorts the FieldMappings by fully-qualified name in the first database; if null in the first database, sorts by fully-qualified name in the second database. (Overrides Mapping <(Of <( IField >)>)..::. CompareTo(Mapping<(Of <(T>)>)).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Mapping<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
ICloneableClone | Creates a shallow copy. (Inherited from Mapping<(Of <(T>)>).)

See Also

SqlCompareFieldMapping Class
RedGate.SQLCompare.Engine Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
SqlCompareFieldMapping..::.Clone Method
SqlCompareFieldMapping Class See Also

Creates a shallow copy of the field mapping.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone As Mapping(Of IField)
C#
public override Mapping<IField> Clone()
Visual C++
public:
virtual Mapping<IField^>^ Clone() override

Return Value

A shallow copy of the field mapping.

See Also

SqlCompareFieldMapping Class
RedGate.SQLCompare.Engine Namespace


CompareTo Method

[image]

SQL Data Compare API 12.0.40
SqlCompareFieldMapping..::.CompareTo Method
SqlCompareFieldMapping Class See Also

Sorts the FieldMappings by fully-qualified name in the first database; if null in the first database, sorts by fully-qualified name in the second database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function CompareTo ( _
    obj As Mapping(Of IField) _
) As Integer
C#
public override int CompareTo(
    Mapping<IField> obj
)
Visual C++
public:
virtual int CompareTo(
    Mapping<IField^>^ obj
) override

Parameters

obj
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( IField >)>)
The object to be compared.

Return Value

Less than zero when this instance is less than the specified object; zero when this instance is equal to the specified object; greater then zero when this instance is greater than the specified object.

Implements

IComparableCompareTo(UTP)

See Also

SqlCompareFieldMapping Class
RedGate.SQLCompare.Engine Namespace


SqlCompareFieldMapping Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareFieldMapping Properties
SqlCompareFieldMapping Class See Also

The SqlCompareFieldMapping type exposes the following properties.

Properties

Name | Description
Include | Specifies whether the mapping is to be included. (Inherited from Mapping<(Of <(T>)>).)
Messages | Messages that explain any issues concerning the mapping; null if no issues exist. (Inherited from Mapping<(Of <(T>)>).)
Obj1 | Returns the object from the first database (Inherited from Mapping<(Of <(T>)>).)
Obj2 | Returns the object from the second database (Inherited from Mapping<(Of <(T>)>).)
Status | The status of the field mapping.
ValidForMatching | Specifies whether the FieldMapping can be used in a matching mapping.

See Also

SqlCompareFieldMapping Class
RedGate.SQLCompare.Engine Namespace


Status Property

[image]

SQL Data Compare API 12.0.40
SqlCompareFieldMapping..::.Status Property
SqlCompareFieldMapping Class See Also

The status of the field mapping.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Status As SqlCompareFieldMappingStatus
C#
public SqlCompareFieldMappingStatus Status { get; }
Visual C++
public:
property SqlCompareFieldMappingStatus Status {
    SqlCompareFieldMappingStatus get ();
}

See Also

SqlCompareFieldMapping Class
RedGate.SQLCompare.Engine Namespace


ValidForMatching Property

[image]

SQL Data Compare API 12.0.40
SqlCompareFieldMapping..::.ValidForMatching Property
SqlCompareFieldMapping Class See Also

Specifies whether the FieldMapping can be used in a matching mapping.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ValidForMatching As Boolean
C#
public bool ValidForMatching { get; internal set; }
Visual C++
public:
property bool ValidForMatching {
    bool get ();
    void set (bool value);
}

See Also

SqlCompareFieldMapping Class
RedGate.SQLCompare.Engine Namespace


SqlCompareFieldMappings Class

[image]

SQL Data Compare API 12.0.40
SqlCompareFieldMappings Class
Members See Also

Holds mappings for fields in a table or view.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlCompareFieldMappings _
    Inherits Mappings(Of SqlCompareFieldMapping, IField, MappingContext)
C#
public class SqlCompareFieldMappings : Mappings<SqlCompareFieldMapping, IField, MappingContext>
Visual C++
public ref class SqlCompareFieldMappings : public Mappings<SqlCompareFieldMapping^, IField^, MappingContext^>

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( T >)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( SqlCompareFieldMapping >)>)
RedGate.SQLCompare.Engine..::.Mappings <(Of <( SqlCompareFieldMapping, IField, MappingContext >)>)
RedGate.SQLCompare.Engine..::.SqlCompareFieldMappings

See Also

SqlCompareFieldMappings Members
RedGate.SQLCompare.Engine Namespace


SqlCompareFieldMappings Members

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareFieldMappings Members
SqlCompareFieldMappings Class Constructors Methods Fields Properties Explicit Interface Implementations See Also

The SqlCompareFieldMappings type exposes the following members.

Constructors

Name | Description
SqlCompareFieldMappings | Overloaded.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
CanBeMapped | Returns true if the two fields can be mapped together because the types can be compared by the SQL Data Compare engine.
CancelOperation | Cancels the current operation. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Clear | Removes all objects from the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Contains | Determines whether the Mappings instance contains a specified object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FromTwo | Returns the Mapping of the object in the second database. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Insert | Not Implemented. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Join | Joins two fields in the different databases, and returns the created mapping. The mapping may not have its status set as Success if the field types are incompatible. (Overrides Mappings <(Of <( SqlCompareFieldMapping, IField, MappingContext >)>)..::. Join(TMap, TMap).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnValidate | Performs additionl custom proccesses when validating a value. (Overrides Mappings <(Of <( SqlCompareFieldMapping, IField, MappingContext >)>)..::. OnValidate(Mapping<(Of <(TMap>)>)).)
RealAdd | Adds a mapping to this Mappings instance. This will change the forwards and backwards maps as necessary. This will break any mapping that will conflict with the added mapping. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RealRemove | Removes the specified object from the mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ShouldInclude | Called to determine if an object should be included in the mapping at all, one of the obj arguments is null. (Overrides Mappings <(Of <( SqlCompareFieldMapping, IField, MappingContext >)>)..::. ShouldInclude(TMap, TMap, Object).)
Sort | Sorts the Mappings according the criteria appropriate for the object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Split | (Overrides Mappings <(Of <( SqlCompareFieldMapping, IField, MappingContext >)>)..::. Split(TMapping).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Fields

Name | Description
m_Context | (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
m_PrepareString | (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

Properties

Name | Description
Context | Access to the mapping context. The type of the context is dependent on the mapped objects. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Count | (Inherited from InnerList<(Of <(T>)>).)
IsTrivialMapping |
Item | Overloaded.
Status | The event handler used to receive status update events. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

SqlCompareFieldMappings Class
RedGate.SQLCompare.Engine Namespace


SqlCompareFieldMappings Constructor

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareFieldMappings Constructor
SqlCompareFieldMappings Class See Also

Overload List

Name | Description
SqlCompareFieldMappings(SqlCompareTableMapping, Mappings<(Of <(SqlCompareFieldMapping, IField, MappingContext>)>)) | Shallow copy constructor.
SqlCompareFieldMappings(SqlCompareTableMapping, MappingContext, Boolean) | The default constructor.
SqlCompareFieldMappings(SqlCompareTableMapping, SqlCompareFieldMappings, Boolean) | Shallow copy constructor for matching mappings.

See Also

SqlCompareFieldMappings Class
SqlCompareFieldMappings Members
RedGate.SQLCompare.Engine Namespace


SqlCompareFieldMappings Constructor (SqlCompareTableMapping, Mappings(SqlCompareFieldMapping, IField, MappingContext))

[image]

SQL Data Compare API 12.0.40
SqlCompareFieldMappings Constructor (SqlCompareTableMapping, Mappings<(Of <(SqlCompareFieldMapping, IField, MappingContext>)>))
SqlCompareFieldMappings Class See Also

Shallow copy constructor.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    parent As SqlCompareTableMapping, _
    fieldMappings As Mappings(Of SqlCompareFieldMapping, IField, MappingContext) _
)
C#
public SqlCompareFieldMappings(
    SqlCompareTableMapping parent,
    Mappings<SqlCompareFieldMapping, IField, MappingContext> fieldMappings
)
Visual C++
public:
SqlCompareFieldMappings(
    SqlCompareTableMapping^ parent,
    Mappings<SqlCompareFieldMapping^, IField^, MappingContext^>^ fieldMappings
)

Parameters

parent
Type: RedGate.SQLCompare.Engine..::.SqlCompareTableMapping
Table to which this FieldMappings class belongs.
fieldMappings
Type: RedGate.SQLCompare.Engine..::.Mappings <(Of <( SqlCompareFieldMapping, IField, MappingContext >)>)
The field mappings to copy.

See Also

SqlCompareFieldMappings Class
SqlCompareFieldMappings Overload
RedGate.SQLCompare.Engine Namespace


SqlCompareFieldMappings Constructor (SqlCompareTableMapping, MappingContext, )

[image]

SQL Data Compare API 12.0.40
SqlCompareFieldMappings Constructor (SqlCompareTableMapping, MappingContext, )
SqlCompareFieldMappings Class See Also

The default constructor.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    parent As SqlCompareTableMapping, _
    context As MappingContext, _
    autoMapColumns As Boolean _
)
C#
public SqlCompareFieldMappings(
    SqlCompareTableMapping parent,
    MappingContext context,
    bool autoMapColumns
)
Visual C++
public:
SqlCompareFieldMappings(
    SqlCompareTableMapping^ parent,
    MappingContext^ context,
    bool autoMapColumns
)

Parameters

parent
Type: RedGate.SQLCompare.Engine..::.SqlCompareTableMapping
Table to which this FieldMappings class belongs.
context
Type: RedGate.SQLCompare.Engine..::.MappingContext
Case sensitivity
autoMapColumns
Type: Boolean
Whether or not similar columns should be mapped automatically

See Also

SqlCompareFieldMappings Class
SqlCompareFieldMappings Overload
RedGate.SQLCompare.Engine Namespace


SqlCompareFieldMappings Constructor (SqlCompareTableMapping, SqlCompareFieldMappings, )

[image]

SQL Data Compare API 12.0.40
SqlCompareFieldMappings Constructor (SqlCompareTableMapping, SqlCompareFieldMappings, )
SqlCompareFieldMappings Class See Also

Shallow copy constructor for matching mappings.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    parent As SqlCompareTableMapping, _
    fieldMappings As SqlCompareFieldMappings, _
    isMatching As Boolean _
)
C#
public SqlCompareFieldMappings(
    SqlCompareTableMapping parent,
    SqlCompareFieldMappings fieldMappings,
    bool isMatching
)
Visual C++
public:
SqlCompareFieldMappings(
    SqlCompareTableMapping^ parent,
    SqlCompareFieldMappings^ fieldMappings,
    bool isMatching
)

Parameters

parent
Type: RedGate.SQLCompare.Engine..::.SqlCompareTableMapping
Table to which this FieldMappings class belongs.
fieldMappings
Type: RedGate.SQLCompare.Engine..::.SqlCompareFieldMappings
SqlCompareFieldMappings to copy.
isMatching
Type: Boolean
true for matching mappings; false otherwise.

See Also

SqlCompareFieldMappings Class
SqlCompareFieldMappings Overload
RedGate.SQLCompare.Engine Namespace


SqlCompareFieldMappings Methods

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareFieldMappings Methods
SqlCompareFieldMappings Class See Also

The SqlCompareFieldMappings type exposes the following methods.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
CanBeMapped | Returns true if the two fields can be mapped together because the types can be compared by the SQL Data Compare engine.
CancelOperation | Cancels the current operation. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Clear | Removes all objects from the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Contains | Determines whether the Mappings instance contains a specified object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FromTwo | Returns the Mapping of the object in the second database. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Insert | Not Implemented. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Join | Joins two fields in the different databases, and returns the created mapping. The mapping may not have its status set as Success if the field types are incompatible. (Overrides Mappings <(Of <( SqlCompareFieldMapping, IField, MappingContext >)>)..::. Join(TMap, TMap).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnValidate | Performs additionl custom proccesses when validating a value. (Overrides Mappings <(Of <( SqlCompareFieldMapping, IField, MappingContext >)>)..::. OnValidate(Mapping<(Of <(TMap>)>)).)
RealAdd | Adds a mapping to this Mappings instance. This will change the forwards and backwards maps as necessary. This will break any mapping that will conflict with the added mapping. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RealRemove | Removes the specified object from the mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ShouldInclude | Called to determine if an object should be included in the mapping at all, one of the obj arguments is null. (Overrides Mappings <(Of <( SqlCompareFieldMapping, IField, MappingContext >)>)..::. ShouldInclude(TMap, TMap, Object).)
Sort | Sorts the Mappings according the criteria appropriate for the object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Split | (Overrides Mappings <(Of <( SqlCompareFieldMapping, IField, MappingContext >)>)..::. Split(TMapping).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

SqlCompareFieldMappings Class
RedGate.SQLCompare.Engine Namespace


CanBeMapped Method

[image]

SQL Data Compare API 12.0.40
SqlCompareFieldMappings..::.CanBeMapped Method
SqlCompareFieldMappings Class See Also

Returns true if the two fields can be mapped together because the types can be compared by the SQL Data Compare engine.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CanBeMapped ( _
    field1 As IField, _
    field2 As IField _
) As Boolean
C#
public static bool CanBeMapped(
    IField field1,
    IField field2
)
Visual C++
public:
static bool CanBeMapped(
    IField^ field1,
    IField^ field2
)

Parameters

field1
Type: RedGate.SQLCompare.Engine..::.IField
The field from the first database.
field2
Type: RedGate.SQLCompare.Engine..::.IField
The field from the second database.

Return Value

true if the types are comparable; otherwise false.

See Also

SqlCompareFieldMappings Class
RedGate.SQLCompare.Engine Namespace


CreateMappings Method

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareFieldMappings..::.CreateMappings Method
SqlCompareFieldMappings Class See Also

Overload List

Name | Description
CreateMappings(Fields, Fields) | Creates a mapping for each object in the collection for which such a mapping is possible.
CreateMappings<(Of <(U>)>)(IKeyedCollection<(Of <(U>)>), IKeyedCollection<(Of <(U>)>), Object, Boolean) | Creates a mapping for each object in the collection where such a mapping is possible. All of the iteration is performed here and the matching can be affected by changing ShouldInclude(TMap, TMap, Object) in the sub class. The main action of joining to objects together is performed by Join(TMap, TMap) which can itself call CreateMappings on child database objects. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

See Also

SqlCompareFieldMappings Class
SqlCompareFieldMappings Members
RedGate.SQLCompare.Engine Namespace


CreateMappings Method (Fields, Fields)

[image]

SQL Data Compare API 12.0.40
SqlCompareFieldMappings..::.CreateMappings Method (Fields, Fields)
SqlCompareFieldMappings Class See Also

Creates a mapping for each object in the collection for which such a mapping is possible.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateMappings ( _
    in1 As Fields, _
    in2 As Fields _
)
C#
public void CreateMappings(
    Fields in1,
    Fields in2
)
Visual C++
public:
void CreateMappings(
    Fields^ in1,
    Fields^ in2
)

Parameters

in1
Type: RedGate.SQLCompare.Engine..::.Fields
List of objects in the first database, or null.
in2
Type: RedGate.SQLCompare.Engine..::.Fields
List of objects in the second database, or null.

See Also

SqlCompareFieldMappings Class
CreateMappings Overload
RedGate.SQLCompare.Engine Namespace


Join Method

[image]

SQL Data Compare API 12.0.40
SqlCompareFieldMappings..::.Join Method
SqlCompareFieldMappings Class See Also

Joins two fields in the different databases, and returns the created mapping. The mapping may not have its status set as Success if the field types are incompatible.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Join ( _
    field1 As IField, _
    field2 As IField _
) As SqlCompareFieldMapping
C#
public override SqlCompareFieldMapping Join(
    IField field1,
    IField field2
)
Visual C++
public:
virtual SqlCompareFieldMapping^ Join(
    IField^ field1,
    IField^ field2
) override

Parameters

field1
Type: RedGate.SQLCompare.Engine..::.IField
The field in the first database.
field2
Type: RedGate.SQLCompare.Engine..::.IField
The field in the second database.

Return Value

The created mapping.

Exceptions

Exception | Condition
ArgumentException | FieldMappings. Join must be called with Field arguments.

See Also

SqlCompareFieldMappings Class
RedGate.SQLCompare.Engine Namespace


OnValidate Method

[image]

SQL Data Compare API 12.0.40
SqlCompareFieldMappings..::.OnValidate Method
SqlCompareFieldMappings Class See Also

Performs additionl custom proccesses when validating a value.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnValidate ( _
    value As Mapping(Of IField) _
)
C#
protected override void OnValidate(
    Mapping<IField> value
)
Visual C++
protected:
virtual void OnValidate(
    Mapping<IField^>^ value
) override

Parameters

value
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( IField >)>)
The object to validate.

Exceptions

Exception | Condition
ArgumentException | SqlCompareFieldMappings only supports SqlCompareFieldMapping objects.

See Also

SqlCompareFieldMappings Class
RedGate.SQLCompare.Engine Namespace


ShouldInclude Method

[image]

SQL Data Compare API 12.0.40
SqlCompareFieldMappings..::.ShouldInclude Method
SqlCompareFieldMappings Class See Also

Called to determine if an object should be included in the mapping at all, one of the obj arguments is null.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ShouldInclude ( _
    obj1 As IField, _
    obj2 As IField, _
    extra As Object _
) As Boolean
C#
protected override bool ShouldInclude(
    IField obj1,
    IField obj2,
    Object extra
)
Visual C++
protected:
virtual bool ShouldInclude(
    IField^ obj1,
    IField^ obj2,
    Object^ extra
) override

Parameters

obj1
Type: RedGate.SQLCompare.Engine..::.IField
object or null if obj2 not null.
obj2
Type: RedGate.SQLCompare.Engine..::.IField
object or null if obj1 not null.
extra
Type: Object
extra data passed into CreateMappings internally to determine relevance.

Return Value

true ( default )for inclusion, false otherwise.

See Also

SqlCompareFieldMappings Class
RedGate.SQLCompare.Engine Namespace


Split Method

[image]

SQL Data Compare API 12.0.40
SqlCompareFieldMappings..::.Split Method
SqlCompareFieldMappings Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Split ( _
    old1 As SqlCompareFieldMapping _
)
C#
public override void Split(
    SqlCompareFieldMapping old1
)
Visual C++
public:
virtual void Split(
    SqlCompareFieldMapping^ old1
) override

Parameters

old1
Type: RedGate.SQLCompare.Engine..::.SqlCompareFieldMapping

See Also

SqlCompareFieldMappings Class
RedGate.SQLCompare.Engine Namespace


SqlCompareFieldMappings Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareFieldMappings Properties
SqlCompareFieldMappings Class See Also

The SqlCompareFieldMappings type exposes the following properties.

Properties

Name | Description
Context | Access to the mapping context. The type of the context is dependent on the mapped objects. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Count | (Inherited from InnerList<(Of <(T>)>).)
IsTrivialMapping |
Item | Overloaded.
Status | The event handler used to receive status update events. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

See Also

SqlCompareFieldMappings Class
RedGate.SQLCompare.Engine Namespace


IsTrivialMapping Property

[image]

SQL Data Compare API 12.0.40
SqlCompareFieldMappings..::.IsTrivialMapping Property
SqlCompareFieldMappings Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsTrivialMapping As Boolean
C#
public bool IsTrivialMapping { get; set; }
Visual C++
public:
property bool IsTrivialMapping {
    bool get ();
    void set (bool value);
}

See Also

SqlCompareFieldMappings Class
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareFieldMappings..::.Item Property
SqlCompareFieldMappings Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Gets the Mapping<(Of <(T>)>) at the specified index. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Item[([(String])]) | Gets the mapping of the specified object name, first attempting to match against objects in the first database, then matching against objects in the second database. Returns null if a mapping is not found. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

See Also

SqlCompareFieldMappings Class
SqlCompareFieldMappings Members
RedGate.SQLCompare.Engine Namespace


SqlCompareFieldMappingStatus Enumeration

[image]

SQL Data Compare API 12.0.40
SqlCompareFieldMappingStatus Enumeration
See Also

The result of the SqlCompareFieldMapping.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration SqlCompareFieldMappingStatus
C#
public enum SqlCompareFieldMappingStatus
Visual C++
public enum class SqlCompareFieldMappingStatus

Members

Member name | Description
Success | Mapping success.
UnableToCompare | Mapping succeeded but SQL Data Compare is still unable to compare the databases. This is usually because of type comparison failure.

See Also

RedGate.SQLCompare.Engine Namespace


SqlCompareOwnerMapping Class

[image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMapping Class
Members See Also

Contains a mapping between the schema or owners in the different databases.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Please use Mapping<IOwner> instead", True)> _
Public Class SqlCompareOwnerMapping _
    Inherits Mapping(Of IOwner)
C#
[ObsoleteAttribute("Please use Mapping<IOwner> instead", true)]
public class SqlCompareOwnerMapping : Mapping<IOwner>
Visual C++
[ObsoleteAttribute(L"Please use Mapping<IOwner> instead", true)]
public ref class SqlCompareOwnerMapping : public Mapping<IOwner^>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.Mapping <(Of <( IOwner >)>)
RedGate.SQLCompare.Engine..::.SqlCompareOwnerMapping

See Also

SqlCompareOwnerMapping Members
RedGate.SQLCompare.Engine Namespace


SqlCompareOwnerMapping Members

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMapping Members
SqlCompareOwnerMapping Class Constructors Methods Fields Properties Explicit Interface Implementations See Also

The SqlCompareOwnerMapping type exposes the following members.

Constructors

Name | Description
SqlCompareOwnerMapping | Overloaded.

Methods

Name | Description
Clone | Creates a shallow copy. (Overrides Mapping <(Of <( IOwner >)>)..::. Clone()()().)
CompareTo | Sorts the Mappings. (Inherited from Mapping<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Mapping<(Of <(T>)>).)

Fields

Name | Description
m_Messages | (Inherited from Mapping<(Of <(T>)>).)

Properties

Name | Description
Include | Specifies whether the mapping is to be included. (Inherited from Mapping<(Of <(T>)>).)
Messages | Messages that explain any issues concerning the mapping; null if no issues exist. (Inherited from Mapping<(Of <(T>)>).)
Obj1 | Returns the object from the first database (Inherited from Mapping<(Of <(T>)>).)
Obj2 | Returns the object from the second database (Inherited from Mapping<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
ICloneableClone | Creates a shallow copy. (Inherited from Mapping<(Of <(T>)>).)

See Also

SqlCompareOwnerMapping Class
RedGate.SQLCompare.Engine Namespace


SqlCompareOwnerMapping Constructor

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMapping Constructor
SqlCompareOwnerMapping Class See Also

Overload List

Name | Description
SqlCompareOwnerMapping(Mapping<(Of <(IOwner>)>)) | Copy constructor.
SqlCompareOwnerMapping(IOwner, IOwner) | Contructor, calls the base constructor.

See Also

SqlCompareOwnerMapping Class
SqlCompareOwnerMapping Members
RedGate.SQLCompare.Engine Namespace


SqlCompareOwnerMapping Constructor (Mapping(IOwner))

[image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMapping Constructor (Mapping<(Of <(IOwner>)>))
SqlCompareOwnerMapping Class See Also

Copy constructor.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    copy As Mapping(Of IOwner) _
)
C#
protected SqlCompareOwnerMapping(
    Mapping<IOwner> copy
)
Visual C++
protected:
SqlCompareOwnerMapping(
    Mapping<IOwner^>^ copy
)

Parameters

copy
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( IOwner >)>)
SchemaMapping to copy.

See Also

SqlCompareOwnerMapping Class
SqlCompareOwnerMapping Overload
RedGate.SQLCompare.Engine Namespace


SqlCompareOwnerMapping Constructor (IOwner, IOwner)

[image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMapping Constructor (IOwner, IOwner)
SqlCompareOwnerMapping Class See Also

Contructor, calls the base constructor.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    obj1 As IOwner, _
    obj2 As IOwner _
)
C#
public SqlCompareOwnerMapping(
    IOwner obj1,
    IOwner obj2
)
Visual C++
public:
SqlCompareOwnerMapping(
    IOwner^ obj1,
    IOwner^ obj2
)

Parameters

obj1
Type: RedGate.SQLCompare.Engine..::.IOwner
The index in the first database.
obj2
Type: RedGate.SQLCompare.Engine..::.IOwner
The index in the second database.

See Also

SqlCompareOwnerMapping Class
SqlCompareOwnerMapping Overload
RedGate.SQLCompare.Engine Namespace


SqlCompareOwnerMapping Methods

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMapping Methods
SqlCompareOwnerMapping Class See Also

The SqlCompareOwnerMapping type exposes the following methods.

Methods

Name | Description
Clone | Creates a shallow copy. (Overrides Mapping <(Of <( IOwner >)>)..::. Clone()()().)
CompareTo | Sorts the Mappings. (Inherited from Mapping<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Mapping<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
ICloneableClone | Creates a shallow copy. (Inherited from Mapping<(Of <(T>)>).)

See Also

SqlCompareOwnerMapping Class
RedGate.SQLCompare.Engine Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMapping..::.Clone Method
SqlCompareOwnerMapping Class See Also

Creates a shallow copy.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone As Mapping(Of IOwner)
C#
public override Mapping<IOwner> Clone()
Visual C++
public:
virtual Mapping<IOwner^>^ Clone() override

Return Value

A shallow copy.

See Also

SqlCompareOwnerMapping Class
RedGate.SQLCompare.Engine Namespace


SqlCompareOwnerMappings Class

[image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMappings Class
Members See Also

Holds mappings for the schema or owners between the two databases. Uses the database objects to create the mappings for the views and the tables from the two databases.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlCompareOwnerMappings _
    Inherits Mappings(Of Mapping(Of IOwner), IOwner, MappingContext) _
    Implements IDisposable
C#
public class SqlCompareOwnerMappings : Mappings<Mapping<IOwner>, IOwner, MappingContext>, IDisposable
Visual C++
public ref class SqlCompareOwnerMappings : public Mappings<Mapping<IOwner^>^, IOwner^, MappingContext^>,
    IDisposable

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( T >)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( Mapping <(Of <( IOwner >)>)>)>)
RedGate.SQLCompare.Engine..::.Mappings <(Of <( Mapping <(Of <( IOwner >)>), IOwner, MappingContext >)>)
RedGate.SQLCompare.Engine..::.SqlCompareOwnerMappings

See Also

SqlCompareOwnerMappings Members
RedGate.SQLCompare.Engine Namespace


SqlCompareOwnerMappings Members

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMappings Members
SqlCompareOwnerMappings Class Constructors Methods Fields Properties Explicit Interface Implementations See Also

The SqlCompareOwnerMappings type exposes the following members.

Constructors

Name | Description
SqlCompareOwnerMappings | Overloaded.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
CancelOperation | Cancels the current operation. (Overrides Mappings <(Of <( Mapping <(Of <( IOwner >)>), IOwner, MappingContext >)>)..::. CancelOperation()()().)
Clear | Removes all objects from the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Contains | Determines whether the Mappings instance contains a specified object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings | Overloaded.
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | (Overrides Object..::.Finalize()()().)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FromTwo | Returns the Mapping of the object in the second database. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name. (Overrides Mappings <(Of <( Mapping <(Of <( IOwner >)>), IOwner, MappingContext >)>)..::. GetKey(String).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Insert | Not Implemented. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Join | Called to join two schemas or users tables together. For each schema or user, attempts to map the tables and views in the specified schema or belonging to the specified user. Any tables mapped in the schema or belonging to the user will be Split(TMapping). (Overrides Mappings <(Of <( Mapping <(Of <( IOwner >)>), IOwner, MappingContext >)>)..::. Join(TMap, TMap).)
MapDatabase | Maps the specified database according to the current mappings.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnValidate | Performs additional custom proccesses when validating a value. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RealAdd | Adds a mapping to this Mappings instance. This will change the forwards and backwards maps as necessary. This will break any mapping that will conflict with the added mapping. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RealRemove | Removes the specified object from the mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ShouldInclude | Called to determine if an object should be included in the mapping at all, one of the obj arguments is null. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Sort | Sorts the Mappings according the criteria appropriate for the object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Split | Splits apart a mapping and creates two mappings, one to null and one from null. (Overrides Mappings <(Of <( Mapping <(Of <( IOwner >)>), IOwner, MappingContext >)>)..::. Split(TMapping).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Fields

Name | Description
m_Context | (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
m_PrepareString | (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are case-sensitive.
Context | Access to the mapping context. The type of the context is dependent on the mapped objects. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.
SchemaObjectMappings | Returns the schema object mappings for the databases.
Status | The event handler used to receive status update events. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
TableMappings |

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

SqlCompareOwnerMappings Class
RedGate.SQLCompare.Engine Namespace


SqlCompareOwnerMappings Constructor

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMappings Constructor
SqlCompareOwnerMappings Class See Also

Overload List

Name | Description
SqlCompareOwnerMappings()()() | Default constructor, with case-sensitive mapping keys and auto column mapping
SqlCompareOwnerMappings(SqlCompareOwnerMappings) | Shallow copy constructor.
SqlCompareOwnerMappings(Boolean, Boolean) | Constructor specifying case-sensitivity and auto mapping of columns

See Also

SqlCompareOwnerMappings Class
SqlCompareOwnerMappings Members
RedGate.SQLCompare.Engine Namespace


SqlCompareOwnerMappings Constructor

[image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMappings Constructor
SqlCompareOwnerMappings Class See Also

Default constructor, with case-sensitive mapping keys and auto column mapping

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlCompareOwnerMappings()
Visual C++
public:
SqlCompareOwnerMappings()

See Also

SqlCompareOwnerMappings Class
SqlCompareOwnerMappings Overload
RedGate.SQLCompare.Engine Namespace


SqlCompareOwnerMappings Constructor (SqlCompareOwnerMappings)

[image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMappings Constructor (SqlCompareOwnerMappings)
SqlCompareOwnerMappings Class See Also

Shallow copy constructor.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    ownerMappings As SqlCompareOwnerMappings _
)
C#
public SqlCompareOwnerMappings(
    SqlCompareOwnerMappings ownerMappings
)
Visual C++
public:
SqlCompareOwnerMappings(
    SqlCompareOwnerMappings^ ownerMappings
)

Parameters

ownerMappings
Type: RedGate.SQLCompare.Engine..::.SqlCompareOwnerMappings
SqlCompareOwnerMappings to copy.

See Also

SqlCompareOwnerMappings Class
SqlCompareOwnerMappings Overload
RedGate.SQLCompare.Engine Namespace


SqlCompareOwnerMappings Constructor (, )

[image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMappings Constructor (, )
SqlCompareOwnerMappings Class See Also

Constructor specifying case-sensitivity and auto mapping of columns

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean, _
    autoMapColumns As Boolean _
)
C#
public SqlCompareOwnerMappings(
    bool caseSensitive,
    bool autoMapColumns
)
Visual C++
public:
SqlCompareOwnerMappings(
    bool caseSensitive,
    bool autoMapColumns
)

Parameters

caseSensitive
Type: Boolean
If true, the mappings will be done using case-sensitive keys. If false, the keys will be case-insensitive
autoMapColumns
Type: Boolean
Whether or not similar columns should be mapped automatically

See Also

SqlCompareOwnerMappings Class
SqlCompareOwnerMappings Overload
RedGate.SQLCompare.Engine Namespace


SqlCompareOwnerMappings Methods

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMappings Methods
SqlCompareOwnerMappings Class See Also

The SqlCompareOwnerMappings type exposes the following methods.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
CancelOperation | Cancels the current operation. (Overrides Mappings <(Of <( Mapping <(Of <( IOwner >)>), IOwner, MappingContext >)>)..::. CancelOperation()()().)
Clear | Removes all objects from the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Contains | Determines whether the Mappings instance contains a specified object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings | Overloaded.
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | (Overrides Object..::.Finalize()()().)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FromTwo | Returns the Mapping of the object in the second database. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name. (Overrides Mappings <(Of <( Mapping <(Of <( IOwner >)>), IOwner, MappingContext >)>)..::. GetKey(String).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Insert | Not Implemented. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Join | Called to join two schemas or users tables together. For each schema or user, attempts to map the tables and views in the specified schema or belonging to the specified user. Any tables mapped in the schema or belonging to the user will be Split(TMapping). (Overrides Mappings <(Of <( Mapping <(Of <( IOwner >)>), IOwner, MappingContext >)>)..::. Join(TMap, TMap).)
MapDatabase | Maps the specified database according to the current mappings.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnValidate | Performs additional custom proccesses when validating a value. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RealAdd | Adds a mapping to this Mappings instance. This will change the forwards and backwards maps as necessary. This will break any mapping that will conflict with the added mapping. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RealRemove | Removes the specified object from the mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ShouldInclude | Called to determine if an object should be included in the mapping at all, one of the obj arguments is null. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Sort | Sorts the Mappings according the criteria appropriate for the object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Split | Splits apart a mapping and creates two mappings, one to null and one from null. (Overrides Mappings <(Of <( Mapping <(Of <( IOwner >)>), IOwner, MappingContext >)>)..::. Split(TMapping).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

SqlCompareOwnerMappings Class
RedGate.SQLCompare.Engine Namespace


CancelOperation Method

[image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMappings..::.CancelOperation Method
SqlCompareOwnerMappings Class See Also

Cancels the current operation.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub CancelOperation
C#
public override void CancelOperation()
Visual C++
public:
virtual void CancelOperation() override

Implements

ICancellable..::.CancelOperation()()()

Remarks

An OperationCancelledException will be thrown.

See Also

SqlCompareOwnerMappings Class
RedGate.SQLCompare.Engine Namespace


CreateMappings Method

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMappings..::.CreateMappings Method
SqlCompareOwnerMappings Class See Also

Overload List

Name | Description
CreateMappings(Database, Database) | Creates a mapping for each owner or schema in the database where such a mapping is possible.
CreateMappings<(Of <(U>)>)(IKeyedCollection<(Of <(U>)>), IKeyedCollection<(Of <(U>)>), Object, Boolean) | Creates a mapping for each object in the collection where such a mapping is possible. All of the iteration is performed here and the matching can be affected by changing ShouldInclude(TMap, TMap, Object) in the sub class. The main action of joining to objects together is performed by Join(TMap, TMap) which can itself call CreateMappings on child database objects. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

See Also

SqlCompareOwnerMappings Class
SqlCompareOwnerMappings Members
RedGate.SQLCompare.Engine Namespace


CreateMappings Method (Database, Database)

[image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMappings..::.CreateMappings Method (Database, Database)
SqlCompareOwnerMappings Class See Also

Creates a mapping for each owner or schema in the database where such a mapping is possible.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateMappings ( _
    db1 As Database, _
    db2 As Database _
)
C#
public void CreateMappings(
    Database db1,
    Database db2
)
Visual C++
public:
void CreateMappings(
    Database^ db1,
    Database^ db2
)

Parameters

db1
Type: RedGate.SQLCompare.Engine..::.Database
The first database, or null.
db2
Type: RedGate.SQLCompare.Engine..::.Database
The second database, or null.

See Also

SqlCompareOwnerMappings Class
CreateMappings Overload
RedGate.SQLCompare.Engine Namespace


Dispose Method

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMappings..::.Dispose Method
SqlCompareOwnerMappings Class See Also

Overload List

Name | Description
Dispose()()() |
Dispose(Boolean) |

See Also

SqlCompareOwnerMappings Class
SqlCompareOwnerMappings Members
RedGate.SQLCompare.Engine Namespace


Dispose Method

[image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMappings..::.Dispose Method
SqlCompareOwnerMappings Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose
C#
public void Dispose()
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposableDispose()()()

See Also

SqlCompareOwnerMappings Class
Dispose Overload
RedGate.SQLCompare.Engine Namespace


Dispose Method ()

[image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMappings..::.Dispose Method ()
SqlCompareOwnerMappings Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
C#
protected virtual void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: Boolean

See Also

SqlCompareOwnerMappings Class
Dispose Overload
RedGate.SQLCompare.Engine Namespace


Finalize Method

[image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMappings..::.Finalize Method
SqlCompareOwnerMappings Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Finalize
C#
protected override void Finalize()
Visual C++
protected:
virtual void Finalize() override

Implements

ObjectFinalize()()()

See Also

SqlCompareOwnerMappings Class
RedGate.SQLCompare.Engine Namespace


GetKey Method

[image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMappings..::.GetKey Method
SqlCompareOwnerMappings Class See Also

Return the key that should be used for the specified fully qualified name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetKey ( _
    fullyQualifiedName As String _
) As String
C#
protected override string GetKey(
    string fullyQualifiedName
)
Visual C++
protected:
virtual String^ GetKey(
    String^ fullyQualifiedName
) override

Parameters

fullyQualifiedName
Type: String

Return Value

See Also

SqlCompareOwnerMappings Class
RedGate.SQLCompare.Engine Namespace


Join Method

[image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMappings..::.Join Method
SqlCompareOwnerMappings Class See Also

Called to join two schemas or users tables together. For each schema or user, attempts to map the tables and views in the specified schema or belonging to the specified user. Any tables mapped in the schema or belonging to the user will be Split(TMapping).

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Join ( _
    obj1 As IOwner, _
    obj2 As IOwner _
) As Mapping(Of IOwner)
C#
public override Mapping<IOwner> Join(
    IOwner obj1,
    IOwner obj2
)
Visual C++
public:
virtual Mapping<IOwner^>^ Join(
    IOwner^ obj1,
    IOwner^ obj2
) override

Parameters

obj1
Type: RedGate.SQLCompare.Engine..::.IOwner
The schema or user in the first database.
obj2
Type: RedGate.SQLCompare.Engine..::.IOwner
The schema or user in the second database.

Return Value

The created mapping.

Exceptions

Exception | Condition
ArgumentException | SchemaMappings.Join must be called with Schema or Users arguments.

See Also

SqlCompareOwnerMappings Class
RedGate.SQLCompare.Engine Namespace


MapDatabase Method

[image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMappings..::.MapDatabase Method
SqlCompareOwnerMappings Class See Also

Maps the specified database according to the current mappings.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub MapDatabase ( _
    first As Boolean _
)
C#
public void MapDatabase(
    bool first
)
Visual C++
public:
void MapDatabase(
    bool first
)

Parameters

first
Type: Boolean
If true, Database1()()() is mapped. If false, Database2()()() is mapped.

See Also

SqlCompareOwnerMappings Class
RedGate.SQLCompare.Engine Namespace


Split Method

[image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMappings..::.Split Method
SqlCompareOwnerMappings Class See Also

Splits apart a mapping and creates two mappings, one to null and one from null.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Split ( _
    old1 As Mapping(Of IOwner) _
)
C#
public override void Split(
    Mapping<IOwner> old1
)
Visual C++
public:
virtual void Split(
    Mapping<IOwner^>^ old1
) override

Parameters

old1
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( IOwner >)>)
The mapping to be split. Both obj1 and obj2 should be not null.

See Also

SqlCompareOwnerMappings Class
RedGate.SQLCompare.Engine Namespace


SqlCompareOwnerMappings Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMappings Properties
SqlCompareOwnerMappings Class See Also

The SqlCompareOwnerMappings type exposes the following properties.

Properties

Name | Description
CaseSensitive | True if the keys are case-sensitive.
Context | Access to the mapping context. The type of the context is dependent on the mapped objects. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.
SchemaObjectMappings | Returns the schema object mappings for the databases.
Status | The event handler used to receive status update events. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
TableMappings |

See Also

SqlCompareOwnerMappings Class
RedGate.SQLCompare.Engine Namespace


CaseSensitive Property

[image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMappings..::.CaseSensitive Property
SqlCompareOwnerMappings Class See Also

True if the keys are case-sensitive.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CaseSensitive As Boolean
C#
public bool CaseSensitive { get; }
Visual C++
public:
property bool CaseSensitive {
    bool get ();
}

See Also

SqlCompareOwnerMappings Class
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMappings..::.Item Property
SqlCompareOwnerMappings Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Gets the Mapping<(Of <(T>)>) at the specified index. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Item[([(String])]) | Gets the mapping of the specified object name, first attempting to match against objects in the first database, then matching against objects in the second database. Returns null if a mapping is not found. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

See Also

SqlCompareOwnerMappings Class
SqlCompareOwnerMappings Members
RedGate.SQLCompare.Engine Namespace


SchemaObjectMappings Property

[image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMappings..::.SchemaObjectMappings Property
SqlCompareOwnerMappings Class See Also

Returns the schema object mappings for the databases.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SchemaObjectMappings As SchemaObjectMappings
C#
public SchemaObjectMappings SchemaObjectMappings { get; }
Visual C++
public:
property SchemaObjectMappings^ SchemaObjectMappings {
    SchemaObjectMappings^ get ();
}

See Also

SqlCompareOwnerMappings Class
RedGate.SQLCompare.Engine Namespace


TableMappings Property

[image]

SQL Data Compare API 12.0.40
SqlCompareOwnerMappings..::.TableMappings Property
SqlCompareOwnerMappings Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TableMappings As SqlCompareTableMappings
C#
public SqlCompareTableMappings TableMappings { get; }
Visual C++
public:
property SqlCompareTableMappings^ TableMappings {
    SqlCompareTableMappings^ get ();
}

See Also

SqlCompareOwnerMappings Class
RedGate.SQLCompare.Engine Namespace


SqlCompareTableMapping Class

[image]

SQL Data Compare API 12.0.40
SqlCompareTableMapping Class
Members See Also

Contains a mapping from a view or table to another view or table. Also contains information on the criteria used for matching the two tables, which can be based on an index or an arbitrary set of mapped fields.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlCompareTableMapping _
    Inherits Mapping(Of ViewTableSuperClass)
C#
public class SqlCompareTableMapping : Mapping<ViewTableSuperClass>
Visual C++
public ref class SqlCompareTableMapping : public Mapping<ViewTableSuperClass^>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.Mapping <(Of <( ViewTableSuperClass >)>)
RedGate.SQLCompare.Engine..::.SqlCompareTableMapping

See Also

SqlCompareTableMapping Members
RedGate.SQLCompare.Engine Namespace


SqlCompareTableMapping Members

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareTableMapping Members
SqlCompareTableMapping Class Constructors Methods Fields Properties Explicit Interface Implementations See Also

The SqlCompareTableMapping type exposes the following members.

Constructors

Name | Description
SqlCompareTableMapping | Overloaded.

Methods

Name | Description
Clone | Creates a shallow copy. (Overrides Mapping <(Of <( ViewTableSuperClass >)>)..::. Clone()()().)
CompareTo | Sorts the Mappings. (Inherited from Mapping<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshMappingStatus | Checks the current contents of FieldMappings to determine whether the current TableMapping can be compared. If the TableMapping can be compared, the TableMapping Status is set to Success; otherwise the Status is set to UnableToCompare. If not all of the fields in the table are mapped successfully, if the Status is not already set to UnableToCompare, it is set to PartialSuccess.
ToString | Returns a String that represents the current Object. (Inherited from Mapping<(Of <(T>)>).)

Fields

Name | Description
m_Messages | (Inherited from Mapping<(Of <(T>)>).)

Properties

Name | Description
FieldMappings | Returns the field mappings for the tables.
Include | The include property for tables.
Messages | Messages that explain any issues concerning the mapping; null if no issues exist. (Inherited from Mapping<(Of <(T>)>).)
Obj1 | Returns the object from the first database (Inherited from Mapping<(Of <(T>)>).)
Obj2 | Returns the object from the second database (Inherited from Mapping<(Of <(T>)>).)
Status | The status of the Table Mapping.

Explicit Interface Implementations

Name | Description
ICloneableClone | Creates a shallow copy. (Inherited from Mapping<(Of <(T>)>).)

See Also

SqlCompareTableMapping Class
RedGate.SQLCompare.Engine Namespace


SqlCompareTableMapping Constructor

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareTableMapping Constructor
SqlCompareTableMapping Class See Also

Overload List

Name | Description
SqlCompareTableMapping(ViewTableSuperClass, ViewTableSuperClass, SqlCompareTableMappingStatus, MappingContext, Boolean) | Constructor. Calls the base constructor and initializes the index mappings.
SqlCompareTableMapping(ViewTableSuperClass, ViewTableSuperClass, SqlCompareTableMappingStatus, Boolean, Boolean) | Constructor. Calls the base constructor and initializes the index mappings.

See Also

SqlCompareTableMapping Class
SqlCompareTableMapping Members
RedGate.SQLCompare.Engine Namespace


SqlCompareTableMapping Constructor (ViewTableSuperClass, ViewTableSuperClass, SqlCompareTableMappingStatus, MappingContext, )

[image]

SQL Data Compare API 12.0.40
SqlCompareTableMapping Constructor (ViewTableSuperClass, ViewTableSuperClass, SqlCompareTableMappingStatus, MappingContext, )
SqlCompareTableMapping Class See Also

Constructor. Calls the base constructor and initializes the index mappings.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    obj1 As ViewTableSuperClass, _
    obj2 As ViewTableSuperClass, _
    status As SqlCompareTableMappingStatus, _
    context As MappingContext, _
    autoMapColumns As Boolean _
)
C#
public SqlCompareTableMapping(
    ViewTableSuperClass obj1,
    ViewTableSuperClass obj2,
    SqlCompareTableMappingStatus status,
    MappingContext context,
    bool autoMapColumns
)
Visual C++
public:
SqlCompareTableMapping(
    ViewTableSuperClass^ obj1,
    ViewTableSuperClass^ obj2,
    SqlCompareTableMappingStatus status,
    MappingContext^ context,
    bool autoMapColumns
)

Parameters

obj1
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
The view or table in the first database.
obj2
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
The view or table in the second database.
status
Type: RedGate.SQLCompare.Engine..::.SqlCompareTableMappingStatus
The status of the mapping.
context
Type: RedGate.SQLCompare.Engine..::.MappingContext
The mapping context
autoMapColumns
Type: Boolean
Whether or not similar columns should be mapped automatically

See Also

SqlCompareTableMapping Class
SqlCompareTableMapping Overload
RedGate.SQLCompare.Engine Namespace


SqlCompareTableMapping Constructor (ViewTableSuperClass, ViewTableSuperClass, SqlCompareTableMappingStatus, , )

[image]

SQL Data Compare API 12.0.40
SqlCompareTableMapping Constructor (ViewTableSuperClass, ViewTableSuperClass, SqlCompareTableMappingStatus, , )
SqlCompareTableMapping Class See Also

Constructor. Calls the base constructor and initializes the index mappings.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    obj1 As ViewTableSuperClass, _
    obj2 As ViewTableSuperClass, _
    status As SqlCompareTableMappingStatus, _
    caseSensitive As Boolean, _
    autoMapColumns As Boolean _
)
C#
public SqlCompareTableMapping(
    ViewTableSuperClass obj1,
    ViewTableSuperClass obj2,
    SqlCompareTableMappingStatus status,
    bool caseSensitive,
    bool autoMapColumns
)
Visual C++
public:
SqlCompareTableMapping(
    ViewTableSuperClass^ obj1,
    ViewTableSuperClass^ obj2,
    SqlCompareTableMappingStatus status,
    bool caseSensitive,
    bool autoMapColumns
)

Parameters

obj1
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
The view or table in the first database.
obj2
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
The view or table in the second database.
status
Type: RedGate.SQLCompare.Engine..::.SqlCompareTableMappingStatus
The status of the mapping.
caseSensitive
Type: Boolean
Case sensitivity
autoMapColumns
Type: Boolean
Whether or not similar columns should be mapped automatically

See Also

SqlCompareTableMapping Class
SqlCompareTableMapping Overload
RedGate.SQLCompare.Engine Namespace


SqlCompareTableMapping Methods

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareTableMapping Methods
SqlCompareTableMapping Class See Also

The SqlCompareTableMapping type exposes the following methods.

Methods

Name | Description
Clone | Creates a shallow copy. (Overrides Mapping <(Of <( ViewTableSuperClass >)>)..::. Clone()()().)
CompareTo | Sorts the Mappings. (Inherited from Mapping<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshMappingStatus | Checks the current contents of FieldMappings to determine whether the current TableMapping can be compared. If the TableMapping can be compared, the TableMapping Status is set to Success; otherwise the Status is set to UnableToCompare. If not all of the fields in the table are mapped successfully, if the Status is not already set to UnableToCompare, it is set to PartialSuccess.
ToString | Returns a String that represents the current Object. (Inherited from Mapping<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
ICloneableClone | Creates a shallow copy. (Inherited from Mapping<(Of <(T>)>).)

See Also

SqlCompareTableMapping Class
RedGate.SQLCompare.Engine Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
SqlCompareTableMapping..::.Clone Method
SqlCompareTableMapping Class See Also

Creates a shallow copy.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone As Mapping(Of ViewTableSuperClass)
C#
public override Mapping<ViewTableSuperClass> Clone()
Visual C++
public:
virtual Mapping<ViewTableSuperClass^>^ Clone() override

Return Value

A shallow copy.

See Also

SqlCompareTableMapping Class
RedGate.SQLCompare.Engine Namespace


RefreshMappingStatus Method

[image]

SQL Data Compare API 12.0.40
SqlCompareTableMapping..::.RefreshMappingStatus Method
SqlCompareTableMapping Class See Also

Checks the current contents of FieldMappings to determine whether the current TableMapping can be compared.

If the TableMapping can be compared, the TableMapping Status is set to Success; otherwise the Status is set to UnableToCompare. If not all of the fields in the table are mapped successfully, if the Status is not already set to UnableToCompare, it is set to PartialSuccess.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub RefreshMappingStatus
C#
public void RefreshMappingStatus()
Visual C++
public:
void RefreshMappingStatus()

See Also

SqlCompareTableMapping Class
RedGate.SQLCompare.Engine Namespace


SqlCompareTableMapping Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareTableMapping Properties
SqlCompareTableMapping Class See Also

The SqlCompareTableMapping type exposes the following properties.

Properties

Name | Description
FieldMappings | Returns the field mappings for the tables.
Include | The include property for tables.
Messages | Messages that explain any issues concerning the mapping; null if no issues exist. (Inherited from Mapping<(Of <(T>)>).)
Obj1 | Returns the object from the first database (Inherited from Mapping<(Of <(T>)>).)
Obj2 | Returns the object from the second database (Inherited from Mapping<(Of <(T>)>).)
Status | The status of the Table Mapping.

See Also

SqlCompareTableMapping Class
RedGate.SQLCompare.Engine Namespace


FieldMappings Property

[image]

SQL Data Compare API 12.0.40
SqlCompareTableMapping..::.FieldMappings Property
SqlCompareTableMapping Class See Also

Returns the field mappings for the tables.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FieldMappings As SqlCompareFieldMappings
C#
public SqlCompareFieldMappings FieldMappings { get; private set; }
Visual C++
public:
property SqlCompareFieldMappings^ FieldMappings {
    SqlCompareFieldMappings^ get ();
    void set (SqlCompareFieldMappings^ value);
}

See Also

SqlCompareTableMapping Class
RedGate.SQLCompare.Engine Namespace


Include Property

[image]

SQL Data Compare API 12.0.40
SqlCompareTableMapping..::.Include Property
SqlCompareTableMapping Class See Also

The include property for tables.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Include As Boolean
C#
public bool Include { get; set; }
Visual C++
public:
property bool Include {
    bool get ();
    void set (bool value);
}

See Also

SqlCompareTableMapping Class
RedGate.SQLCompare.Engine Namespace


Status Property

[image]

SQL Data Compare API 12.0.40
SqlCompareTableMapping..::.Status Property
SqlCompareTableMapping Class See Also

The status of the Table Mapping.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As SqlCompareTableMappingStatus
C#
public SqlCompareTableMappingStatus Status { get; internal set; }
Visual C++
public:
property SqlCompareTableMappingStatus Status {
    SqlCompareTableMappingStatus get ();
    void set (SqlCompareTableMappingStatus value);
}

See Also

SqlCompareTableMapping Class
RedGate.SQLCompare.Engine Namespace


SqlCompareTableMappingExtensions Class

[image]

SQL Data Compare API 12.0.40
SqlCompareTableMappingExtensions Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SqlCompareTableMappingExtensions
C#
public static class SqlCompareTableMappingExtensions
Visual C++
public ref class SqlCompareTableMappingExtensions abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.SqlCompareTableMappingExtensions

See Also

SqlCompareTableMappingExtensions Members
RedGate.SQLCompare.Engine Namespace


SqlCompareTableMappingExtensions Members

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareTableMappingExtensions Members
SqlCompareTableMappingExtensions Class Methods See Also

The SqlCompareTableMappingExtensions type exposes the following members.

Methods

Name | Description
GetFieldMappings |

See Also

SqlCompareTableMappingExtensions Class
RedGate.SQLCompare.Engine Namespace


SqlCompareTableMappingExtensions Methods

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareTableMappingExtensions Methods
SqlCompareTableMappingExtensions Class See Also

The SqlCompareTableMappingExtensions type exposes the following methods.

Methods

Name | Description
GetFieldMappings |

See Also

SqlCompareTableMappingExtensions Class
RedGate.SQLCompare.Engine Namespace


GetFieldMappings Method

[image]

SQL Data Compare API 12.0.40
SqlCompareTableMappingExtensions..::.GetFieldMappings Method
SqlCompareTableMappingExtensions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFieldMappings ( _
    mapping As Mapping(Of ViewTableSuperClass) _
) As SqlCompareFieldMappings
C#
public static SqlCompareFieldMappings GetFieldMappings(
    Mapping<ViewTableSuperClass> mapping
)
Visual C++
public:
static SqlCompareFieldMappings^ GetFieldMappings(
    Mapping<ViewTableSuperClass^>^ mapping
)

Parameters

mapping
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( ViewTableSuperClass >)>)

See Also

SqlCompareTableMappingExtensions Class
RedGate.SQLCompare.Engine Namespace


SqlCompareTableMappings Class

[image]

SQL Data Compare API 12.0.40
SqlCompareTableMappings Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlCompareTableMappings _
    Inherits Mappings(Of SqlCompareTableMapping, ViewTableSuperClass, MappingContext)
C#
public class SqlCompareTableMappings : Mappings<SqlCompareTableMapping, ViewTableSuperClass, MappingContext>
Visual C++
public ref class SqlCompareTableMappings : public Mappings<SqlCompareTableMapping^, ViewTableSuperClass^, MappingContext^>

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( T >)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( SqlCompareTableMapping >)>)
RedGate.SQLCompare.Engine..::.Mappings <(Of <( SqlCompareTableMapping, ViewTableSuperClass, MappingContext >)>)
RedGate.SQLCompare.Engine..::.SqlCompareTableMappings

See Also

SqlCompareTableMappings Members
RedGate.SQLCompare.Engine Namespace


SqlCompareTableMappings Members

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareTableMappings Members
SqlCompareTableMappings Class Constructors Methods Fields Properties Explicit Interface Implementations See Also

The SqlCompareTableMappings type exposes the following members.

Constructors

Name | Description
SqlCompareTableMappings | Overloaded.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
CancelOperation | Cancels the current operation. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Clear | Removes all objects from the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Contains | Determines whether the Mappings instance contains a specified object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FromTwo | Returns the Mapping of the object in the second database. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Insert | Not Implemented. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Join | Joins two views or tables, and attempts to map their fields and indexes. If there are no suitable indexes, the status is set to Unable to Compare. (Overrides Mappings <(Of <( SqlCompareTableMapping, ViewTableSuperClass, MappingContext >)>)..::. Join(TMap, TMap).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnValidate | Performs additional custom proccesses when validating a value. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RealAdd | Adds a mapping to this Mappings instance. This will change the forwards and backwards maps as necessary. This will break any mapping that will conflict with the added mapping. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RealRemove | Removes the specified object from the mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ShouldInclude | Called to determine if an object should be included in the mapping at all, one of the obj arguments is null. (Overrides Mappings <(Of <( SqlCompareTableMapping, ViewTableSuperClass, MappingContext >)>)..::. ShouldInclude(TMap, TMap, Object).)
Sort | Sorts the Mappings according the criteria appropriate for the object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Split | (Overrides Mappings <(Of <( SqlCompareTableMapping, ViewTableSuperClass, MappingContext >)>)..::. Split(TMapping).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Fields

Name | Description
m_Context | (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
m_PrepareString | (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

Properties

Name | Description
Context | Access to the mapping context. The type of the context is dependent on the mapped objects. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Count | (Inherited from InnerList<(Of <(T>)>).)
IsTrivialMapping |
Item | Overloaded.
Status | The event handler used to receive status update events. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

SqlCompareTableMappings Class
RedGate.SQLCompare.Engine Namespace


SqlCompareTableMappings Constructor

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareTableMappings Constructor
SqlCompareTableMappings Class See Also

Overload List

Name | Description
SqlCompareTableMappings(Mappings<(Of <(SqlCompareTableMapping, ViewTableSuperClass, MappingContext>)>)) | Shallow copy constructor.
SqlCompareTableMappings(Boolean, Boolean) | Default constructor.

See Also

SqlCompareTableMappings Class
SqlCompareTableMappings Members
RedGate.SQLCompare.Engine Namespace


SqlCompareTableMappings Constructor (Mappings(SqlCompareTableMapping, ViewTableSuperClass, MappingContext))

[image]

SQL Data Compare API 12.0.40
SqlCompareTableMappings Constructor (Mappings<(Of <(SqlCompareTableMapping, ViewTableSuperClass, MappingContext>)>))
SqlCompareTableMappings Class See Also

Shallow copy constructor.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    tableMappings As Mappings(Of SqlCompareTableMapping, ViewTableSuperClass, MappingContext) _
)
C#
public SqlCompareTableMappings(
    Mappings<SqlCompareTableMapping, ViewTableSuperClass, MappingContext> tableMappings
)
Visual C++
public:
SqlCompareTableMappings(
    Mappings<SqlCompareTableMapping^, ViewTableSuperClass^, MappingContext^>^ tableMappings
)

Parameters

tableMappings
Type: RedGate.SQLCompare.Engine..::.Mappings <(Of <( SqlCompareTableMapping, ViewTableSuperClass, MappingContext >)>)
The SqlCompareTableMappings to be copied.

See Also

SqlCompareTableMappings Class
SqlCompareTableMappings Overload
RedGate.SQLCompare.Engine Namespace


SqlCompareTableMappings Constructor (, )

[image]

SQL Data Compare API 12.0.40
SqlCompareTableMappings Constructor (, )
SqlCompareTableMappings Class See Also

Default constructor.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean, _
    autoMapColumns As Boolean _
)
C#
public SqlCompareTableMappings(
    bool caseSensitive,
    bool autoMapColumns
)
Visual C++
public:
SqlCompareTableMappings(
    bool caseSensitive,
    bool autoMapColumns
)

Parameters

caseSensitive
Type: Boolean
autoMapColumns
Type: Boolean

See Also

SqlCompareTableMappings Class
SqlCompareTableMappings Overload
RedGate.SQLCompare.Engine Namespace


SqlCompareTableMappings Methods

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareTableMappings Methods
SqlCompareTableMappings Class See Also

The SqlCompareTableMappings type exposes the following methods.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
CancelOperation | Cancels the current operation. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Clear | Removes all objects from the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Contains | Determines whether the Mappings instance contains a specified object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FromTwo | Returns the Mapping of the object in the second database. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Insert | Not Implemented. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Join | Joins two views or tables, and attempts to map their fields and indexes. If there are no suitable indexes, the status is set to Unable to Compare. (Overrides Mappings <(Of <( SqlCompareTableMapping, ViewTableSuperClass, MappingContext >)>)..::. Join(TMap, TMap).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnValidate | Performs additional custom proccesses when validating a value. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RealAdd | Adds a mapping to this Mappings instance. This will change the forwards and backwards maps as necessary. This will break any mapping that will conflict with the added mapping. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RealRemove | Removes the specified object from the mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ShouldInclude | Called to determine if an object should be included in the mapping at all, one of the obj arguments is null. (Overrides Mappings <(Of <( SqlCompareTableMapping, ViewTableSuperClass, MappingContext >)>)..::. ShouldInclude(TMap, TMap, Object).)
Sort | Sorts the Mappings according the criteria appropriate for the object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Split | (Overrides Mappings <(Of <( SqlCompareTableMapping, ViewTableSuperClass, MappingContext >)>)..::. Split(TMapping).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

SqlCompareTableMappings Class
RedGate.SQLCompare.Engine Namespace


CreateMappings Method

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareTableMappings..::.CreateMappings Method
SqlCompareTableMappings Class See Also

Overload List

Name | Description
CreateMappings(Tables, Tables) | Creates a mapping for each object in the collection for which such a mapping is possible.
CreateMappings(Views, Views) | Creates a mapping for each object in the collection for which such a mapping is possible.
CreateMappings<(Of <(U>)>)(IKeyedCollection<(Of <(U>)>), IKeyedCollection<(Of <(U>)>), Object, Boolean) | Creates a mapping for each object in the collection where such a mapping is possible. All of the iteration is performed here and the matching can be affected by changing ShouldInclude(TMap, TMap, Object) in the sub class. The main action of joining to objects together is performed by Join(TMap, TMap) which can itself call CreateMappings on child database objects. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

See Also

SqlCompareTableMappings Class
SqlCompareTableMappings Members
RedGate.SQLCompare.Engine Namespace


CreateMappings Method (Tables, Tables)

[image]

SQL Data Compare API 12.0.40
SqlCompareTableMappings..::.CreateMappings Method (Tables, Tables)
SqlCompareTableMappings Class See Also

Creates a mapping for each object in the collection for which such a mapping is possible.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateMappings ( _
    in1 As Tables, _
    in2 As Tables _
)
C#
public void CreateMappings(
    Tables in1,
    Tables in2
)
Visual C++
public:
void CreateMappings(
    Tables^ in1,
    Tables^ in2
)

Parameters

in1
Type: RedGate.SQLCompare.Engine..::.Tables
A list of objects in the first database, or null.
in2
Type: RedGate.SQLCompare.Engine..::.Tables
A list of objects in the second database, or null.

See Also

SqlCompareTableMappings Class
CreateMappings Overload
RedGate.SQLCompare.Engine Namespace


CreateMappings Method (Views, Views)

[image]

SQL Data Compare API 12.0.40
SqlCompareTableMappings..::.CreateMappings Method (Views, Views)
SqlCompareTableMappings Class See Also

Creates a mapping for each object in the collection for which such a mapping is possible.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateMappings ( _
    in1 As Views, _
    in2 As Views _
)
C#
public void CreateMappings(
    Views in1,
    Views in2
)
Visual C++
public:
void CreateMappings(
    Views^ in1,
    Views^ in2
)

Parameters

in1
Type: RedGate.SQLCompare.Engine..::.Views
List of objects in the first database, or null.
in2
Type: RedGate.SQLCompare.Engine..::.Views
List of objects in the second database, or null.

See Also

SqlCompareTableMappings Class
CreateMappings Overload
RedGate.SQLCompare.Engine Namespace


Join Method

[image]

SQL Data Compare API 12.0.40
SqlCompareTableMappings..::.Join Method
SqlCompareTableMappings Class See Also

Joins two views or tables, and attempts to map their fields and indexes. If there are no suitable indexes, the status is set to Unable to Compare.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Join ( _
    obj1 As ViewTableSuperClass, _
    obj2 As ViewTableSuperClass _
) As SqlCompareTableMapping
C#
public override SqlCompareTableMapping Join(
    ViewTableSuperClass obj1,
    ViewTableSuperClass obj2
)
Visual C++
public:
virtual SqlCompareTableMapping^ Join(
    ViewTableSuperClass^ obj1,
    ViewTableSuperClass^ obj2
) override

Parameters

obj1
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
The table or view in the first database.
obj2
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
The table or view in the second database.

Return Value

The created mapping.

Exceptions

Exception | Condition
ArgumentException | TableMappings. Join must be called with ViewTableSuperClass arguments.

See Also

SqlCompareTableMappings Class
RedGate.SQLCompare.Engine Namespace


ShouldInclude Method

[image]

SQL Data Compare API 12.0.40
SqlCompareTableMappings..::.ShouldInclude Method
SqlCompareTableMappings Class See Also

Called to determine if an object should be included in the mapping at all, one of the obj arguments is null.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ShouldInclude ( _
    obj1 As ViewTableSuperClass, _
    obj2 As ViewTableSuperClass, _
    extra As Object _
) As Boolean
C#
protected override bool ShouldInclude(
    ViewTableSuperClass obj1,
    ViewTableSuperClass obj2,
    Object extra
)
Visual C++
protected:
virtual bool ShouldInclude(
    ViewTableSuperClass^ obj1,
    ViewTableSuperClass^ obj2,
    Object^ extra
) override

Parameters

obj1
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
object or null if obj2 not null.
obj2
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
object or null if obj1 not null.
extra
Type: Object
extra data passed into CreateMappings internally to determine relevance.

Return Value

true ( default )for inclusion, false otherwise.

See Also

SqlCompareTableMappings Class
RedGate.SQLCompare.Engine Namespace


Split Method

[image]

SQL Data Compare API 12.0.40
SqlCompareTableMappings..::.Split Method
SqlCompareTableMappings Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Split ( _
    old1 As SqlCompareTableMapping _
)
C#
public override void Split(
    SqlCompareTableMapping old1
)
Visual C++
public:
virtual void Split(
    SqlCompareTableMapping^ old1
) override

Parameters

old1
Type: RedGate.SQLCompare.Engine..::.SqlCompareTableMapping

See Also

SqlCompareTableMappings Class
RedGate.SQLCompare.Engine Namespace


SqlCompareTableMappings Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareTableMappings Properties
SqlCompareTableMappings Class See Also

The SqlCompareTableMappings type exposes the following properties.

Properties

Name | Description
Context | Access to the mapping context. The type of the context is dependent on the mapped objects. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Count | (Inherited from InnerList<(Of <(T>)>).)
IsTrivialMapping |
Item | Overloaded.
Status | The event handler used to receive status update events. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

See Also

SqlCompareTableMappings Class
RedGate.SQLCompare.Engine Namespace


IsTrivialMapping Property

[image]

SQL Data Compare API 12.0.40
SqlCompareTableMappings..::.IsTrivialMapping Property
SqlCompareTableMappings Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsTrivialMapping As Boolean
C#
public bool IsTrivialMapping { get; internal set; }
Visual C++
public:
property bool IsTrivialMapping {
    bool get ();
    void set (bool value);
}

See Also

SqlCompareTableMappings Class
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareTableMappings..::.Item Property
SqlCompareTableMappings Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Gets the Mapping<(Of <(T>)>) at the specified index. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Item[([(String])]) | Gets the mapping of the specified object name, first attempting to match against objects in the first database, then matching against objects in the second database. Returns null if a mapping is not found. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

See Also

SqlCompareTableMappings Class
SqlCompareTableMappings Members
RedGate.SQLCompare.Engine Namespace


SqlCompareTableMappingStatus Enumeration

[image]

SQL Data Compare API 12.0.40
SqlCompareTableMappingStatus Enumeration
See Also

The result of the mapping.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration SqlCompareTableMappingStatus
C#
public enum SqlCompareTableMappingStatus
Visual C++
public enum class SqlCompareTableMappingStatus

Members

Member name | Description
Success | The mapping was successful.
UnableToCompare | The mapping succeeded, but SQL Data Compare is unable to compare. This is usually because of type comparison failure.
PartialSuccess | The mapping was a partial success; some columns remain unmapped.

See Also

RedGate.SQLCompare.Engine Namespace


SqlExceptionWithSql Class

[image]

SQL Data Compare API 12.0.40
SqlExceptionWithSql Class
Members See Also

Wrap a SqlException with the sql that failed

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class SqlExceptionWithSql _
    Inherits Exception
C#
[SerializableAttribute]
public class SqlExceptionWithSql : Exception
Visual C++
[SerializableAttribute]
public ref class SqlExceptionWithSql : public Exception

Inheritance Hierarchy

Object
Exception
RedGate.SQLCompare.Engine..::.SqlExceptionWithSql

See Also

SqlExceptionWithSql Members
RedGate.SQLCompare.Engine Namespace


SqlExceptionWithSql Members

[image] [image]

SQL Data Compare API 12.0.40
SqlExceptionWithSql Members
SqlExceptionWithSql Class Constructors Methods Properties See Also

The SqlExceptionWithSql type exposes the following members.

Constructors

Name | Description
SqlExceptionWithSql | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | (Overrides Exception..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
ErrorNumber |
FailedSql |
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SqlExceptionWithSql Class
RedGate.SQLCompare.Engine Namespace


SqlExceptionWithSql Constructor

[image] [image]

SQL Data Compare API 12.0.40
SqlExceptionWithSql Constructor
SqlExceptionWithSql Class See Also

Overload List

Name | Description
SqlExceptionWithSql(SerializationInfo, StreamingContext) |
SqlExceptionWithSql(String, SqlException) |

See Also

SqlExceptionWithSql Class
SqlExceptionWithSql Members
RedGate.SQLCompare.Engine Namespace


SqlExceptionWithSql Constructor (, )

[image]

SQL Data Compare API 12.0.40
SqlExceptionWithSql Constructor (, )
SqlExceptionWithSql Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected SqlExceptionWithSql(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
SqlExceptionWithSql(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: SerializationInfo
context
Type: StreamingContext

See Also

SqlExceptionWithSql Class
SqlExceptionWithSql Overload
RedGate.SQLCompare.Engine Namespace


SqlExceptionWithSql Constructor (, )

[image]

SQL Data Compare API 12.0.40
SqlExceptionWithSql Constructor (, )
SqlExceptionWithSql Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    failedSql As String, _
    inner As SqlException _
)
C#
public SqlExceptionWithSql(
    string failedSql,
    SqlException inner
)
Visual C++
public:
SqlExceptionWithSql(
    String^ failedSql,
    SqlException^ inner
)

Parameters

failedSql
Type: String
inner
Type: SqlException

See Also

SqlExceptionWithSql Class
SqlExceptionWithSql Overload
RedGate.SQLCompare.Engine Namespace


SqlExceptionWithSql Methods

[image] [image]

SQL Data Compare API 12.0.40
SqlExceptionWithSql Methods
SqlExceptionWithSql Class See Also

The SqlExceptionWithSql type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | (Overrides Exception..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

SqlExceptionWithSql Class
RedGate.SQLCompare.Engine Namespace


GetObjectData Method

[image]

SQL Data Compare API 12.0.40
SqlExceptionWithSql..::.GetObjectData Method
SqlExceptionWithSql Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: SerializationInfo
context
Type: StreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)

See Also

SqlExceptionWithSql Class
RedGate.SQLCompare.Engine Namespace


SqlExceptionWithSql Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlExceptionWithSql Properties
SqlExceptionWithSql Class See Also

The SqlExceptionWithSql type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
ErrorNumber |
FailedSql |
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SqlExceptionWithSql Class
RedGate.SQLCompare.Engine Namespace


ErrorNumber Property

[image]

SQL Data Compare API 12.0.40
SqlExceptionWithSql..::.ErrorNumber Property
SqlExceptionWithSql Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ErrorNumber As Integer
C#
public int ErrorNumber { get; }
Visual C++
public:
property int ErrorNumber {
    int get ();
}

See Also

SqlExceptionWithSql Class
RedGate.SQLCompare.Engine Namespace


FailedSql Property

[image]

SQL Data Compare API 12.0.40
SqlExceptionWithSql..::.FailedSql Property
SqlExceptionWithSql Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FailedSql As String
C#
public string FailedSql { get; }
Visual C++
public:
property String^ FailedSql {
    String^ get ();
}

See Also

SqlExceptionWithSql Class
RedGate.SQLCompare.Engine Namespace


SqlGenerationQueueBuilder Class

[image]

SQL Data Compare API 12.0.40
SqlGenerationQueueBuilder Class
Members See Also

Calculates the database object changes required based on the selected Differences

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlGenerationQueueBuilder _
    Implements IWorkStage, ICancellable
C#
public class SqlGenerationQueueBuilder : IWorkStage,
    ICancellable
Visual C++
public ref class SqlGenerationQueueBuilder : IWorkStage,
    ICancellable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.SqlGenerationQueueBuilder

See Also

SqlGenerationQueueBuilder Members
RedGate.SQLCompare.Engine Namespace


SqlGenerationQueueBuilder Members

[image] [image]

SQL Data Compare API 12.0.40
SqlGenerationQueueBuilder Members
SqlGenerationQueueBuilder Class Constructors Methods Properties See Also

The SqlGenerationQueueBuilder type exposes the following members.

Constructors

Name | Description
SqlGenerationQueueBuilder |

Methods

Name | Description
CancelOperation | Cancels the current operation.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ProcessDifferences | This is the first stage of the main work, in which the necessary work is determined. This can only be used internally!
ScriptObject |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BackupOptions |
DateTimeProvider | Provides timestamps for naming files created by backup statements in the script
ProductInfo | A string indicating the product generating the script, e.g. "SQL Compare version 1.2.3"
Status | The event handler for status events.
TransactionIsolationLevel |
WorkFields |

See Also

SqlGenerationQueueBuilder Class
RedGate.SQLCompare.Engine Namespace


SqlGenerationQueueBuilder Constructor

[image]

SQL Data Compare API 12.0.40
SqlGenerationQueueBuilder Constructor
SqlGenerationQueueBuilder Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlGenerationQueueBuilder()
Visual C++
public:
SqlGenerationQueueBuilder()

See Also

SqlGenerationQueueBuilder Class
RedGate.SQLCompare.Engine Namespace


SqlGenerationQueueBuilder Methods

[image] [image]

SQL Data Compare API 12.0.40
SqlGenerationQueueBuilder Methods
SqlGenerationQueueBuilder Class See Also

The SqlGenerationQueueBuilder type exposes the following methods.

Methods

Name | Description
CancelOperation | Cancels the current operation.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ProcessDifferences | This is the first stage of the main work, in which the necessary work is determined. This can only be used internally!
ScriptObject |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlGenerationQueueBuilder Class
RedGate.SQLCompare.Engine Namespace


CancelOperation Method

[image]

SQL Data Compare API 12.0.40
SqlGenerationQueueBuilder..::.CancelOperation Method
SqlGenerationQueueBuilder Class See Also

Cancels the current operation.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelOperation
C#
public void CancelOperation()
Visual C++
public:
virtual void CancelOperation() sealed

Implements

ICancellable..::.CancelOperation()()()

See Also

SqlGenerationQueueBuilder Class
RedGate.SQLCompare.Engine Namespace


ProcessDifferences Method

[image]

SQL Data Compare API 12.0.40
SqlGenerationQueueBuilder..::.ProcessDifferences Method
SqlGenerationQueueBuilder Class See Also

This is the first stage of the main work, in which the necessary work is determined. This can only be used internally!

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function ProcessDifferences ( _
    userDifferences As Differences, _
    onlyDifferenceToInclude As Difference, _
    options As Options, _
    runOnTwo As Boolean _
) As SqlGenerationQueues
C#
public SqlGenerationQueues ProcessDifferences(
    Differences userDifferences,
    Difference onlyDifferenceToInclude,
    Options options,
    bool runOnTwo
)
Visual C++
public:
SqlGenerationQueues^ ProcessDifferences(
    Differences^ userDifferences,
    Difference^ onlyDifferenceToInclude,
    Options options,
    bool runOnTwo
)

Parameters

userDifferences
Type: RedGate.SQLCompare.Engine..::.Differences
The differences to use.
onlyDifferenceToInclude
Type: RedGate.SQLCompare.Engine..::.Difference
The single difference to include.
options
Type: RedGate.SQLCompare.Engine..::.Options
The synchronization options.
runOnTwo
Type: Boolean
True if the SQL script is to be run on the second database.

See Also

SqlGenerationQueueBuilder Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
SqlGenerationQueueBuilder..::.ScriptObject Method
SqlGenerationQueueBuilder Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function ScriptObject ( _
    objectToScript As ITSqlObject, _
    options As Options _
) As Regions
C#
public Regions ScriptObject(
    ITSqlObject objectToScript,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    ITSqlObject^ objectToScript,
    Options options
) sealed

Parameters

objectToScript
Type: ITSqlObject
options
Type: RedGate.SQLCompare.Engine..::.Options

Return Value

The regions for a ScriptableDatabaseObject suitable for showing in the diff viewer

Implements

IWorkStage..::.ScriptObject(ITSqlObject, Options)

See Also

SqlGenerationQueueBuilder Class
RedGate.SQLCompare.Engine Namespace


SqlGenerationQueueBuilder Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlGenerationQueueBuilder Properties
SqlGenerationQueueBuilder Class See Also

The SqlGenerationQueueBuilder type exposes the following properties.

Properties

Name | Description
BackupOptions |
DateTimeProvider | Provides timestamps for naming files created by backup statements in the script
ProductInfo | A string indicating the product generating the script, e.g. "SQL Compare version 1.2.3"
Status | The event handler for status events.
TransactionIsolationLevel |
WorkFields |

See Also

SqlGenerationQueueBuilder Class
RedGate.SQLCompare.Engine Namespace


BackupOptions Property

[image]

SQL Data Compare API 12.0.40
SqlGenerationQueueBuilder..::.BackupOptions Property
SqlGenerationQueueBuilder Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BackupOptions As BackupOptions
C#
public BackupOptions BackupOptions { get; internal set; }
Visual C++
public:
property BackupOptions^ BackupOptions {
    BackupOptions^ get ();
    void set (BackupOptions^ value);
}

See Also

SqlGenerationQueueBuilder Class
RedGate.SQLCompare.Engine Namespace


DateTimeProvider Property

[image]

SQL Data Compare API 12.0.40
SqlGenerationQueueBuilder..::.DateTimeProvider Property
SqlGenerationQueueBuilder Class See Also

Provides timestamps for naming files created by backup statements in the script

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DateTimeProvider As IDateTimeProvider
C#
public IDateTimeProvider DateTimeProvider { get; set; }
Visual C++
public:
property IDateTimeProvider^ DateTimeProvider {
    IDateTimeProvider^ get ();
    void set (IDateTimeProvider^ value);
}

See Also

SqlGenerationQueueBuilder Class
RedGate.SQLCompare.Engine Namespace


ProductInfo Property

[image]

SQL Data Compare API 12.0.40
SqlGenerationQueueBuilder..::.ProductInfo Property
SqlGenerationQueueBuilder Class See Also

A string indicating the product generating the script, e.g. "SQL Compare version 1.2.3"

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ProductInfo As String
C#
public string ProductInfo { get; set; }
Visual C++
public:
property String^ ProductInfo {
    String^ get ();
    void set (String^ value);
}

See Also

SqlGenerationQueueBuilder Class
RedGate.SQLCompare.Engine Namespace


Status Property

[image]

SQL Data Compare API 12.0.40
SqlGenerationQueueBuilder..::.Status Property
SqlGenerationQueueBuilder Class See Also

The event handler for status events.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

See Also

SqlGenerationQueueBuilder Class
RedGate.SQLCompare.Engine Namespace


TransactionIsolationLevel Property

[image]

SQL Data Compare API 12.0.40
SqlGenerationQueueBuilder..::.TransactionIsolationLevel Property
SqlGenerationQueueBuilder Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TransactionIsolationLevel As String
C#
public string TransactionIsolationLevel { get; set; }
Visual C++
public:
virtual property String^ TransactionIsolationLevel {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IWorkStage..::.TransactionIsolationLevel

See Also

SqlGenerationQueueBuilder Class
RedGate.SQLCompare.Engine Namespace


WorkFields Property

[image]

SQL Data Compare API 12.0.40
SqlGenerationQueueBuilder..::.WorkFields Property
SqlGenerationQueueBuilder Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property WorkFields As WorkFields
C#
public WorkFields WorkFields { get; }
Visual C++
public:
property WorkFields^ WorkFields {
    WorkFields^ get ();
}

See Also

SqlGenerationQueueBuilder Class
RedGate.SQLCompare.Engine Namespace


SqlGenerationQueues Class

[image]

SQL Data Compare API 12.0.40
SqlGenerationQueues Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SqlGenerationQueues _
    Implements IWorkStage, ICancellable
C#
public sealed class SqlGenerationQueues : IWorkStage,
    ICancellable
Visual C++
public ref class SqlGenerationQueues sealed : IWorkStage,
    ICancellable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.SqlGenerationQueues

See Also

SqlGenerationQueues Members
RedGate.SQLCompare.Engine Namespace


SqlGenerationQueues Members

[image] [image]

SQL Data Compare API 12.0.40
SqlGenerationQueues Members
SqlGenerationQueues Class Methods Properties See Also

The SqlGenerationQueues type exposes the following members.

Methods

Name | Description
CancelOperation | Cancels the current operation.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GenerateFolderSynchronizationActions |
GenerateSql | This is the second stage of the main work, in which the SQL is generated for the synchronization. This can only be used internally.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject |
SetImplicitlySelectedDifferences | For internal use only.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BackupOptions |
Dependencies | The dependencies selected for the current Work. Populated during ProcessDifferences>. Dictionary is of < dependent object, objects depending on it>.
ProductInfo |
Status | The event handler for status events.
TransactionIsolationLevel |
Warnings | Warnings about the work to be done.

See Also

SqlGenerationQueues Class
RedGate.SQLCompare.Engine Namespace


SqlGenerationQueues Methods

[image] [image]

SQL Data Compare API 12.0.40
SqlGenerationQueues Methods
SqlGenerationQueues Class See Also

The SqlGenerationQueues type exposes the following methods.

Methods

Name | Description
CancelOperation | Cancels the current operation.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GenerateFolderSynchronizationActions |
GenerateSql | This is the second stage of the main work, in which the SQL is generated for the synchronization. This can only be used internally.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject |
SetImplicitlySelectedDifferences | For internal use only.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlGenerationQueues Class
RedGate.SQLCompare.Engine Namespace


CancelOperation Method

[image]

SQL Data Compare API 12.0.40
SqlGenerationQueues..::.CancelOperation Method
SqlGenerationQueues Class See Also

Cancels the current operation.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelOperation
C#
public void CancelOperation()
Visual C++
public:
virtual void CancelOperation() sealed

Implements

ICancellable..::.CancelOperation()()()

See Also

SqlGenerationQueues Class
RedGate.SQLCompare.Engine Namespace


GenerateFolderSynchronizationActions Method

[image]

SQL Data Compare API 12.0.40
SqlGenerationQueues..::.GenerateFolderSynchronizationActions Method
SqlGenerationQueues Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GenerateFolderSynchronizationActions ( _
    options As Options, _
    dbInfo As ScriptDatabaseInformation, _
    database As IDatabase, _
    targetDatabase As Database, _
    generator As IFileNameGenerator _
) As ScriptGenerationResult
C#
public ScriptGenerationResult GenerateFolderSynchronizationActions(
    Options options,
    ScriptDatabaseInformation dbInfo,
    IDatabase database,
    Database targetDatabase,
    IFileNameGenerator generator
)
Visual C++
public:
ScriptGenerationResult^ GenerateFolderSynchronizationActions(
    Options options,
    ScriptDatabaseInformation^ dbInfo,
    IDatabase^ database,
    Database^ targetDatabase,
    IFileNameGenerator^ generator
)

Parameters

options
Type: RedGate.SQLCompare.Engine..::.Options
dbInfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
database
Type: RedGate.SQLCompare.Engine..::.IDatabase
targetDatabase
Type: RedGate.SQLCompare.Engine..::.Database
generator
Type: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser..::.IFileNameGenerator

See Also

SqlGenerationQueues Class
RedGate.SQLCompare.Engine Namespace


GenerateSql Method

[image]

SQL Data Compare API 12.0.40
SqlGenerationQueues..::.GenerateSql Method
SqlGenerationQueues Class See Also

This is the second stage of the main work, in which the SQL is generated for the synchronization. This can only be used internally.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GenerateSql As SqlGenerationResult
C#
public SqlGenerationResult GenerateSql()
Visual C++
public:
SqlGenerationResult^ GenerateSql()

See Also

SqlGenerationQueues Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
SqlGenerationQueues..::.ScriptObject Method
SqlGenerationQueues Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function ScriptObject ( _
    objectToScript As ITSqlObject, _
    options As Options _
) As Regions
C#
public Regions ScriptObject(
    ITSqlObject objectToScript,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    ITSqlObject^ objectToScript,
    Options options
) sealed

Parameters

objectToScript
Type: ITSqlObject
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

IWorkStage..::.ScriptObject(ITSqlObject, Options)

See Also

SqlGenerationQueues Class
RedGate.SQLCompare.Engine Namespace


SetImplicitlySelectedDifferences Method

[image]

SQL Data Compare API 12.0.40
SqlGenerationQueues..::.SetImplicitlySelectedDifferences Method
SqlGenerationQueues Class See Also

For internal use only.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetImplicitlySelectedDifferences
C#
public void SetImplicitlySelectedDifferences()
Visual C++
public:
void SetImplicitlySelectedDifferences()

See Also

SqlGenerationQueues Class
RedGate.SQLCompare.Engine Namespace


SqlGenerationQueues Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlGenerationQueues Properties
SqlGenerationQueues Class See Also

The SqlGenerationQueues type exposes the following properties.

Properties

Name | Description
BackupOptions |
Dependencies | The dependencies selected for the current Work. Populated during ProcessDifferences>. Dictionary is of < dependent object, objects depending on it>.
ProductInfo |
Status | The event handler for status events.
TransactionIsolationLevel |
Warnings | Warnings about the work to be done.

See Also

SqlGenerationQueues Class
RedGate.SQLCompare.Engine Namespace


BackupOptions Property

[image]

SQL Data Compare API 12.0.40
SqlGenerationQueues..::.BackupOptions Property
SqlGenerationQueues Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BackupOptions As BackupOptions
C#
public BackupOptions BackupOptions { get; set; }
Visual C++
public:
property BackupOptions^ BackupOptions {
    BackupOptions^ get ();
    void set (BackupOptions^ value);
}

See Also

SqlGenerationQueues Class
RedGate.SQLCompare.Engine Namespace


Dependencies Property

[image]

SQL Data Compare API 12.0.40
SqlGenerationQueues..::.Dependencies Property
SqlGenerationQueues Class See Also

The dependencies selected for the current Work. Populated during ProcessDifferences>. Dictionary is of < dependent object, objects depending on it>.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dependencies As IDictionary(Of Difference, Set(Of Difference))
C#
public IDictionary<Difference, Set<Difference>> Dependencies { get; }
Visual C++
public:
property IDictionary<Difference^, Set<Difference^>^>^ Dependencies {
    IDictionary<Difference^, Set<Difference^>^>^ get ();
}

See Also

SqlGenerationQueues Class
RedGate.SQLCompare.Engine Namespace


ProductInfo Property

[image]

SQL Data Compare API 12.0.40
SqlGenerationQueues..::.ProductInfo Property
SqlGenerationQueues Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ProductInfo As String
C#
public string ProductInfo { get; set; }
Visual C++
public:
property String^ ProductInfo {
    String^ get ();
    void set (String^ value);
}

See Also

SqlGenerationQueues Class
RedGate.SQLCompare.Engine Namespace


Status Property

[image]

SQL Data Compare API 12.0.40
SqlGenerationQueues..::.Status Property
SqlGenerationQueues Class See Also

The event handler for status events.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

See Also

SqlGenerationQueues Class
RedGate.SQLCompare.Engine Namespace


TransactionIsolationLevel Property

[image]

SQL Data Compare API 12.0.40
SqlGenerationQueues..::.TransactionIsolationLevel Property
SqlGenerationQueues Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TransactionIsolationLevel As String
C#
public string TransactionIsolationLevel { get; set; }
Visual C++
public:
virtual property String^ TransactionIsolationLevel {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IWorkStage..::.TransactionIsolationLevel

See Also

SqlGenerationQueues Class
RedGate.SQLCompare.Engine Namespace


Warnings Property

[image]

SQL Data Compare API 12.0.40
SqlGenerationQueues..::.Warnings Property
SqlGenerationQueues Class See Also

Warnings about the work to be done.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Warnings As Messages
C#
public Messages Warnings { get; }
Visual C++
public:
property Messages^ Warnings {
    Messages^ get ();
}

See Also

SqlGenerationQueues Class
RedGate.SQLCompare.Engine Namespace


SqlGenerationResult Class

[image]

SQL Data Compare API 12.0.40
SqlGenerationResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlGenerationResult _
    Inherits DeploymentResult _
    Implements ISqlGenerationResult
C#
public class SqlGenerationResult : DeploymentResult, ISqlGenerationResult
Visual C++
public ref class SqlGenerationResult : public DeploymentResult,
    ISqlGenerationResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.DeploymentResult
RedGate.SQLCompare.Engine..::.SqlGenerationResult

See Also

SqlGenerationResult Members
RedGate.SQLCompare.Engine Namespace


SqlGenerationResult Members

[image] [image]

SQL Data Compare API 12.0.40
SqlGenerationResult Members
SqlGenerationResult Class Methods Properties See Also

The SqlGenerationResult type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
EndOfDeploymentBeforeErrorHandling |
EndOfTransactionalStatements |
ExecutionBlock |
Messages | (Inherited from DeploymentResult.)
StartOfTopNonTransactionalStatements |
StartOfTransactionalStatements |
StaticDataInsertPosition |
Warnings | (Inherited from DeploymentResult.)

See Also

SqlGenerationResult Class
RedGate.SQLCompare.Engine Namespace


SqlGenerationResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlGenerationResult Properties
SqlGenerationResult Class See Also

The SqlGenerationResult type exposes the following properties.

Properties

Name | Description
EndOfDeploymentBeforeErrorHandling |
EndOfTransactionalStatements |
ExecutionBlock |
Messages | (Inherited from DeploymentResult.)
StartOfTopNonTransactionalStatements |
StartOfTransactionalStatements |
StaticDataInsertPosition |
Warnings | (Inherited from DeploymentResult.)

See Also

SqlGenerationResult Class
RedGate.SQLCompare.Engine Namespace


EndOfDeploymentBeforeErrorHandling Property

[image]

SQL Data Compare API 12.0.40
SqlGenerationResult..::.EndOfDeploymentBeforeErrorHandling Property
SqlGenerationResult Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EndOfDeploymentBeforeErrorHandling As Long
C#
public long EndOfDeploymentBeforeErrorHandling { get; }
Visual C++
public:
property long long EndOfDeploymentBeforeErrorHandling {
    long long get ();
}

See Also

SqlGenerationResult Class
RedGate.SQLCompare.Engine Namespace


EndOfTransactionalStatements Property

[image]

SQL Data Compare API 12.0.40
SqlGenerationResult..::.EndOfTransactionalStatements Property
SqlGenerationResult Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EndOfTransactionalStatements As Long
C#
public long EndOfTransactionalStatements { get; }
Visual C++
public:
property long long EndOfTransactionalStatements {
    long long get ();
}

See Also

SqlGenerationResult Class
RedGate.SQLCompare.Engine Namespace


ExecutionBlock Property

[image]

SQL Data Compare API 12.0.40
SqlGenerationResult..::.ExecutionBlock Property
SqlGenerationResult Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExecutionBlock As IExecutionBlock
C#
public IExecutionBlock ExecutionBlock { get; }
Visual C++
public:
virtual property IExecutionBlock^ ExecutionBlock {
    IExecutionBlock^ get () sealed;
}

Implements

ISqlGenerationResultExecutionBlock()()()

See Also

SqlGenerationResult Class
RedGate.SQLCompare.Engine Namespace


StartOfTopNonTransactionalStatements Property

[image]

SQL Data Compare API 12.0.40
SqlGenerationResult..::.StartOfTopNonTransactionalStatements Property
SqlGenerationResult Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StartOfTopNonTransactionalStatements As Long
C#
public long StartOfTopNonTransactionalStatements { get; }
Visual C++
public:
property long long StartOfTopNonTransactionalStatements {
    long long get ();
}

See Also

SqlGenerationResult Class
RedGate.SQLCompare.Engine Namespace


StartOfTransactionalStatements Property

[image]

SQL Data Compare API 12.0.40
SqlGenerationResult..::.StartOfTransactionalStatements Property
SqlGenerationResult Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StartOfTransactionalStatements As Long
C#
public long StartOfTransactionalStatements { get; }
Visual C++
public:
property long long StartOfTransactionalStatements {
    long long get ();
}

See Also

SqlGenerationResult Class
RedGate.SQLCompare.Engine Namespace


StaticDataInsertPosition Property

[image]

SQL Data Compare API 12.0.40
SqlGenerationResult..::.StaticDataInsertPosition Property
SqlGenerationResult Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StaticDataInsertPosition As Long
C#
public long StaticDataInsertPosition { get; }
Visual C++
public:
property long long StaticDataInsertPosition {
    long long get ();
}

See Also

SqlGenerationResult Class
RedGate.SQLCompare.Engine Namespace


SqlOptions Enumeration

[image]

SQL Data Compare API 12.0.40
SqlOptions Enumeration
See Also

Options used when synchronizing databases.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration SqlOptions
C#
[FlagsAttribute]
public enum SqlOptions
Visual C++
[FlagsAttribute]
public enum class SqlOptions

Members

Member name Description
Default

The default options when synchronizing databases. These are:

  • DisableKeys
  • OutputCommentHeader
  • UseTransactions
  • OutputComments
None
None.
DisableTriggers
Disable, then re-enable, DML triggers on tables and views in the synchronization script.
DisableKeys
Disable, then re-enable, foreign keys in the synchronization script. Note that in some circumstances foreign keys are dropped and recreated rather than disabled and re-enabled.
DropConstraintsAndIndexes
Drop and recreate primary keys, indexes, and unique constraints in the synchronization script. If the primary key, index, or unique constraint is the comparison key, it cannot be dropped.
OutputCommentHeader
Include the comment header in the synchronization script. The comment header contains information about the databases that you are comparing, and the version of SQL Data Compare.
DontUseTransactions
Inserts BEGIN TRANSACTION at the beginning of the synchronization script and COMMIT TRANSACTION at the end of the synchronization script.
TransportCLRBinary
In the synchronization script, SQL Data Compare can use the binary representation or the string representation (.ToString()) of the CLR column. Setting this option forces SQL Data Compare to use the binary representation in the synchronization script. The binary representations of the CLR columns must be the same.
DDLTriggerDisable
Disable and then re-enable all DDL triggers in the synchronization script.
DontOutputComments
Include the comments in the output script. The comments make it easier to locate items in the output.
ReseedIdentity
Reseeds identity columns so that identity values in the database you are updating match values in the source database.
SkipFkChecks
Uses WITH NOCHECK to skip integrity checks. If you select this option: - deployments may run faster - foreign keys will be left in a 'not trusted' state.

See Also

RedGate.SQLCompare.Engine Namespace


SqlScriptAdjuster Class

[image]

SQL Data Compare API 12.0.40
SqlScriptAdjuster Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SqlScriptAdjuster
C#
public static class SqlScriptAdjuster
Visual C++
public ref class SqlScriptAdjuster abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.SqlScriptAdjuster

See Also

SqlScriptAdjuster Members
RedGate.SQLCompare.Engine Namespace


SqlScriptAdjuster Members

[image] [image]

SQL Data Compare API 12.0.40
SqlScriptAdjuster Members
SqlScriptAdjuster Class Methods See Also

The SqlScriptAdjuster type exposes the following members.

Methods

Name | Description
ChangeCreateToAlter |
GetTriggerFromBatch | Given some SQL, this method tries to parse a statement batch from it and then returns the first trigger statement it finds. If it doesn't find one, it returns null.
RemoveWithAppendFromTrigger | SQL Server 2012 removed support for the obsolete WITH APPEND clause in a CREATE TRIGGER statement. Here we remove the WITH APPEND portion of a CREATE TRIGGER statement, if it is present.

See Also

SqlScriptAdjuster Class
RedGate.SQLCompare.Engine Namespace


SqlScriptAdjuster Methods

[image] [image]

SQL Data Compare API 12.0.40
SqlScriptAdjuster Methods
SqlScriptAdjuster Class See Also

The SqlScriptAdjuster type exposes the following methods.

Methods

Name | Description
ChangeCreateToAlter |
GetTriggerFromBatch | Given some SQL, this method tries to parse a statement batch from it and then returns the first trigger statement it finds. If it doesn't find one, it returns null.
RemoveWithAppendFromTrigger | SQL Server 2012 removed support for the obsolete WITH APPEND clause in a CREATE TRIGGER statement. Here we remove the WITH APPEND portion of a CREATE TRIGGER statement, if it is present.

See Also

SqlScriptAdjuster Class
RedGate.SQLCompare.Engine Namespace


ChangeCreateToAlter Method

[image]

SQL Data Compare API 12.0.40
SqlScriptAdjuster..::.ChangeCreateToAlter Method
SqlScriptAdjuster Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ChangeCreateToAlter ( _
    sql As String _
) As String
C#
public static string ChangeCreateToAlter(
    string sql
)
Visual C++
public:
static String^ ChangeCreateToAlter(
    String^ sql
)

Parameters

sql
Type: String

See Also

SqlScriptAdjuster Class
RedGate.SQLCompare.Engine Namespace


GetTriggerFromBatch Method

[image]

SQL Data Compare API 12.0.40
SqlScriptAdjuster..::.GetTriggerFromBatch Method
SqlScriptAdjuster Class See Also

Given some SQL, this method tries to parse a statement batch from it and then returns the first trigger statement it finds. If it doesn't find one, it returns null.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetTriggerFromBatch ( _
    sql As String _
) As Trigger
C#
public static Trigger GetTriggerFromBatch(
    string sql
)
Visual C++
public:
static Trigger^ GetTriggerFromBatch(
    String^ sql
)

Parameters

sql
Type: String
A statement batch, possibly containing a trigger statement

Return Value

See Also

SqlScriptAdjuster Class
RedGate.SQLCompare.Engine Namespace


RemoveWithAppendFromTrigger Method

[image]

SQL Data Compare API 12.0.40
SqlScriptAdjuster..::.RemoveWithAppendFromTrigger Method
SqlScriptAdjuster Class See Also

SQL Server 2012 removed support for the obsolete WITH APPEND clause in a CREATE TRIGGER statement. Here we remove the WITH APPEND portion of a CREATE TRIGGER statement, if it is present.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function RemoveWithAppendFromTrigger ( _
    sql As String _
) As String
C#
public static string RemoveWithAppendFromTrigger(
    string sql
)
Visual C++
public:
static String^ RemoveWithAppendFromTrigger(
    String^ sql
)

Parameters

sql
Type: String
The CREATE TRIGGER statement, possibly containing a WITH APPEND clause.

Return Value

The create trigger statement with the WITH APPEND clause removed.

See Also

SqlScriptAdjuster Class
RedGate.SQLCompare.Engine Namespace


SqlSetOption Enumeration

[image]

SQL Data Compare API 12.0.40
SqlSetOption Enumeration
See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration SqlSetOption
C#
public enum SqlSetOption
Visual C++
public enum class SqlSetOption

Members

Member name | Description
NUMERIC_ROUNDABORT |
ANSI_PADDING |
ANSI_WARNINGS |
CONCAT_NULL_YIELDS_NULL |
ARITHABORT |
QUOTED_IDENTIFIER |
ANSI_NULLS |
XACT_ABORT |

See Also

RedGate.SQLCompare.Engine Namespace


SqlSetOptions Class

[image]

SQL Data Compare API 12.0.40
SqlSetOptions Class
Members See Also

SQL set options.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SqlSetOptions _
    Implements IEnumerable(Of KeyValuePair(Of SqlSetOption, Boolean)),  _
    IEnumerable
C#
public sealed class SqlSetOptions : IEnumerable<KeyValuePair<SqlSetOption, bool>>,
    IEnumerable
Visual C++
public ref class SqlSetOptions sealed : IEnumerable<KeyValuePair<SqlSetOption, bool>>,
    IEnumerable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.SqlSetOptions

See Also

SqlSetOptions Members
RedGate.SQLCompare.Engine Namespace


SqlSetOptions Members

[image] [image]

SQL Data Compare API 12.0.40
SqlSetOptions Members
SqlSetOptions Class Constructors Methods Properties Explicit Interface Implementations See Also

The SqlSetOptions type exposes the following members.

Constructors

Name | Description
SqlSetOptions | Constructs a SQLSetOptions class. This stores information about connection settings, such as ANSI warnings, ANSI NULLs, quoted identifiers, etc.

Methods

Name | Description
CreateDefault |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Item |

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator |

See Also

SqlSetOptions Class
RedGate.SQLCompare.Engine Namespace


SqlSetOptions Constructor

[image]

SQL Data Compare API 12.0.40
SqlSetOptions Constructor
SqlSetOptions Class See Also

Constructs a SQLSetOptions class. This stores information about connection settings, such as ANSI warnings, ANSI NULLs, quoted identifiers, etc.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlSetOptions()
Visual C++
public:
SqlSetOptions()

See Also

SqlSetOptions Class
RedGate.SQLCompare.Engine Namespace


SqlSetOptions Methods

[image] [image]

SQL Data Compare API 12.0.40
SqlSetOptions Methods
SqlSetOptions Class See Also

The SqlSetOptions type exposes the following methods.

Methods

Name | Description
CreateDefault |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator |

See Also

SqlSetOptions Class
RedGate.SQLCompare.Engine Namespace


CreateDefault Method

[image]

SQL Data Compare API 12.0.40
SqlSetOptions..::.CreateDefault Method
SqlSetOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateDefault As SqlSetOptions
C#
public static SqlSetOptions CreateDefault()
Visual C++
public:
static SqlSetOptions^ CreateDefault()

Remarks

Does not set a default for XACT_ABORT

See Also

SqlSetOptions Class
RedGate.SQLCompare.Engine Namespace


GetEnumerator Method

[image]

SQL Data Compare API 12.0.40
SqlSetOptions..::.GetEnumerator Method
SqlSetOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of SqlSetOption, Boolean))
C#
public IEnumerator<KeyValuePair<SqlSetOption, bool>> GetEnumerator()
Visual C++
public:
virtual IEnumerator<KeyValuePair<SqlSetOption, bool>>^ GetEnumerator() sealed

Implements

IEnumerableGetEnumerator()()()

See Also

SqlSetOptions Class
RedGate.SQLCompare.Engine Namespace


. Method

[image]

SQL Data Compare API 12.0.40
SqlSetOptions..::...::. Method
SqlSetOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
C#
IEnumerator IEnumerable.GetEnumerator()
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerableGetEnumerator()()()

See Also

SqlSetOptions Class
RedGate.SQLCompare.Engine Namespace


SqlSetOptions Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlSetOptions Properties
SqlSetOptions Class See Also

The SqlSetOptions type exposes the following properties.

Properties

Name | Description
Item |

See Also

SqlSetOptions Class
RedGate.SQLCompare.Engine Namespace


Item Property

[image]

SQL Data Compare API 12.0.40
SqlSetOptions..::.Item Property
SqlSetOptions Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Default Property Item ( _
    sqlSetOption As SqlSetOption _
) As Boolean
C#
public bool this[
    SqlSetOption sqlSetOption
] { set; }
Visual C++
public:
property bool default[SqlSetOption sqlSetOption] {
    void set (SqlSetOption sqlSetOption, bool value);
}

Parameters

sqlSetOption
Type: RedGate.SQLCompare.Engine..::.SqlSetOption

See Also

SqlSetOptions Class
RedGate.SQLCompare.Engine Namespace


SqlType Enumeration

[image]

SQL Data Compare API 12.0.40
SqlType Enumeration
See Also

A SQL Server data type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration SqlType
C#
public enum SqlType
Visual C++
public enum class SqlType

Members

Member name | Description
Other | Unknown or UDT
ClrType | CLR type
Table | Table type
Empty | Not used
Binary | binary
Varbinary | varbinary
Char | char
Varchar | varchar
NChar | nchar
NVarchar | nvarchar
DateTime | datetime
SmallDatetime | smalldatetime
Decimal | decimal
Numeric | numeric
Float | float
Real | real
Integer64 | integer64
Integer32 | integer32
Integer16 | integer16
Byte | byte
Money | money
SmallMoney | smallmoney
Boolean | boolean
Timestamp | timestamp
Guid | guid
Image | image
NText | ntext
Text | text
Variant | variant
Xml | XML
Date | date
Time | time
DateTimeOffset | datetimeoffset
DateTime2 | datetime2

Remarks

This extends SByte, as that is how ExtendedPropertyValue serializes/deserializes it. If we run out of space, the serialization/deserialization will need to be changed and the serialization version number bumped.

See Also

RedGate.SQLCompare.Engine Namespace


Statistics Class

[image]

SQL Data Compare API 12.0.40
Statistics Class
Members See Also

This implements ISystemNameable indirectly, but only in 2000 is it even possibly system nameable

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class Statistics _
    Inherits Index
C#
public class Statistics : Index
Visual C++
public ref class Statistics : public Index

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.Index
RedGate.SQLCompare.Engine..::.Statistics

See Also

Statistics Members
RedGate.SQLCompare.Engine Namespace


Statistics Members

[image] [image]

SQL Data Compare API 12.0.40
Statistics Members
Statistics Class Methods Properties Explicit Interface Implementations See Also

The Statistics type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FieldsCompareWith | (Overrides Index ..::. FieldsCompareWith(Index, Options).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowPageLocks | True if the index allows page locks. (Inherited from Index.)
AllowRowLocks | True if the index allows row locks. (Inherited from Index.)
Clustered | Obsolete. (Inherited from Index.)
Database | The database to which the index belongs. (Inherited from Index.)
Fields | The fields in the index. (Inherited from Index.)
FileGroup | Obsolete. (Inherited from Index.)
FileGroupOrPartitionScheme | The filegroup or the partition scheme on which the index is defined. (Inherited from Index.)
FilestreamFileGroup | Obsolete. (Inherited from Index.)
FillFactor | The fill factor. (Inherited from Index.)
Filter | The filtering condition on the index. This property exists in SQL Server 2008 and later.
FullScan | True if the index is defined with FullScan (Inherited from Index.)
FullyQualifiedName | Obsolete. The fully-qualified name of the index. DANGER WILL ROBINSON!! This is not escaped. (Inherited from Index.)
IgnoreDuplicateKeys | True if set to ignore duplicate keys. (Inherited from Index.)
Incremental | True if incremental (introduced in SQL Server 2014) (Inherited from Index.)
IsColumnstore | Stupid columnstore indexes mark all of their fields as included but use the normal syntax to list them. (http://msdn.microsoft.com/en-us/library/ms175105.aspx) (Inherited from Index.)
IsDisabled | Indicates whether the index is disabled. (Inherited from Index.)
IsKeyIndexForFullTextIndex | Obsolete. (Inherited from Index.)
IsPartitioned | Indicates whether the index is built on a partition scheme. If it is, the name of the partition scheme is returned by the FileGroupOrPartitionScheme property. (Inherited from Index.)
Name | The name of the index. DANGER WILL ROBINSON!! This is not escaped. Do you mean Index..::.QualifiedName? (Inherited from Index.)
NoRecompute | True if the index is defined with NORECOMPUTE. (Inherited from Index.)
ObjectType | Returns ObjectType.Index (Inherited from Index.)
Online | True iff the index is to be created online. (Inherited from Index.)
Owner | The owner of the index's table. (Inherited from Index.)
Pad | The index padding. (Inherited from Index.)
PartitionedField | Obsolete. (Inherited from Index.)
PrimaryKey | Obsolete. (Inherited from Index.)
QualifiedName | The qualified name of the object. Do you mean Index..::.Name? (Inherited from Index.)
Relational | True if this is a relational index. (Inherited from Index.)
ScriptSource | The location of the creation script for this object if the database source is set to scripts folder. (Inherited from Index.)
SortInTempDb | True iff the index is to be created using tempdb. (Inherited from Index.)
Spatial | True if the index is a spatial index. (Inherited from Index.)
SpatialIndexInformation | Obsolete. (Inherited from Index.)
Statistics | True if the index is a statistic. (Inherited from Index.)
SysobjectID | The sysobject identier of the object. (Inherited from Index.)
SystemNamed | (Inherited from Index.)
Unique | Obsolete. (Inherited from Index.)
UniqueConstraint | Obsolete. (Inherited from Index.)
WriteFileGroupOrPartitionScheme | Whether (disregarding any options) the filegroup should be written out (Inherited from Index.)
Xml | True if the index is an XML index. (Inherited from Index.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith | (Inherited from Index.)
IDatabaseObject..::.Equals | (Inherited from Index.)

See Also

Statistics Class
RedGate.SQLCompare.Engine Namespace


Statistics Methods

[image] [image]

SQL Data Compare API 12.0.40
Statistics Methods
Statistics Class See Also

The Statistics type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FieldsCompareWith | (Overrides Index ..::. FieldsCompareWith(Index, Options).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith | (Inherited from Index.)
IDatabaseObject..::.Equals | (Inherited from Index.)

See Also

Statistics Class
RedGate.SQLCompare.Engine Namespace


FieldsCompareWith Method

[image]

SQL Data Compare API 12.0.40
Statistics..::.FieldsCompareWith Method
Statistics Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function FieldsCompareWith ( _
    value As Index, _
    options As Options _
) As IEnumerable(Of EqualityDifference)
C#
protected override IEnumerable<EqualityDifference> FieldsCompareWith(
    Index value,
    Options options
)
Visual C++
protected:
virtual IEnumerable<EqualityDifference^>^ FieldsCompareWith(
    Index^ value,
    Options options
) override

Parameters

value
Type: RedGate.SQLCompare.Engine..::.Index
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

Statistics Class
RedGate.SQLCompare.Engine Namespace


Statistics Properties

[image] [image]

SQL Data Compare API 12.0.40
Statistics Properties
Statistics Class See Also

The Statistics type exposes the following properties.

Properties

Name | Description
AllowPageLocks | True if the index allows page locks. (Inherited from Index.)
AllowRowLocks | True if the index allows row locks. (Inherited from Index.)
Clustered | Obsolete. (Inherited from Index.)
Database | The database to which the index belongs. (Inherited from Index.)
Fields | The fields in the index. (Inherited from Index.)
FileGroup | Obsolete. (Inherited from Index.)
FileGroupOrPartitionScheme | The filegroup or the partition scheme on which the index is defined. (Inherited from Index.)
FilestreamFileGroup | Obsolete. (Inherited from Index.)
FillFactor | The fill factor. (Inherited from Index.)
Filter | The filtering condition on the index. This property exists in SQL Server 2008 and later.
FullScan | True if the index is defined with FullScan (Inherited from Index.)
FullyQualifiedName | Obsolete. The fully-qualified name of the index. DANGER WILL ROBINSON!! This is not escaped. (Inherited from Index.)
IgnoreDuplicateKeys | True if set to ignore duplicate keys. (Inherited from Index.)
Incremental | True if incremental (introduced in SQL Server 2014) (Inherited from Index.)
IsColumnstore | Stupid columnstore indexes mark all of their fields as included but use the normal syntax to list them. (http://msdn.microsoft.com/en-us/library/ms175105.aspx) (Inherited from Index.)
IsDisabled | Indicates whether the index is disabled. (Inherited from Index.)
IsKeyIndexForFullTextIndex | Obsolete. (Inherited from Index.)
IsPartitioned | Indicates whether the index is built on a partition scheme. If it is, the name of the partition scheme is returned by the FileGroupOrPartitionScheme property. (Inherited from Index.)
Name | The name of the index. DANGER WILL ROBINSON!! This is not escaped. Do you mean Index..::.QualifiedName? (Inherited from Index.)
NoRecompute | True if the index is defined with NORECOMPUTE. (Inherited from Index.)
ObjectType | Returns ObjectType.Index (Inherited from Index.)
Online | True iff the index is to be created online. (Inherited from Index.)
Owner | The owner of the index's table. (Inherited from Index.)
Pad | The index padding. (Inherited from Index.)
PartitionedField | Obsolete. (Inherited from Index.)
PrimaryKey | Obsolete. (Inherited from Index.)
QualifiedName | The qualified name of the object. Do you mean Index..::.Name? (Inherited from Index.)
Relational | True if this is a relational index. (Inherited from Index.)
ScriptSource | The location of the creation script for this object if the database source is set to scripts folder. (Inherited from Index.)
SortInTempDb | True iff the index is to be created using tempdb. (Inherited from Index.)
Spatial | True if the index is a spatial index. (Inherited from Index.)
SpatialIndexInformation | Obsolete. (Inherited from Index.)
Statistics | True if the index is a statistic. (Inherited from Index.)
SysobjectID | The sysobject identier of the object. (Inherited from Index.)
SystemNamed | (Inherited from Index.)
Unique | Obsolete. (Inherited from Index.)
UniqueConstraint | Obsolete. (Inherited from Index.)
WriteFileGroupOrPartitionScheme | Whether (disregarding any options) the filegroup should be written out (Inherited from Index.)
Xml | True if the index is an XML index. (Inherited from Index.)

See Also

Statistics Class
RedGate.SQLCompare.Engine Namespace


Filter Property

[image]

SQL Data Compare API 12.0.40
Statistics..::.Filter Property
Statistics Class See Also

The filtering condition on the index. This property exists in SQL Server 2008 and later.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Filter As String
C#
public string Filter { get; internal set; }
Visual C++
public:
property String^ Filter {
    String^ get ();
    void set (String^ value);
}

See Also

Statistics Class
RedGate.SQLCompare.Engine Namespace


StoplistsChanges Class

[image]

SQL Data Compare API 12.0.40
StoplistsChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StoplistsChanges
C#
public sealed class StoplistsChanges
Visual C++
public ref class StoplistsChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.StoplistsChanges

See Also

StoplistsChanges Members
RedGate.SQLCompare.Engine Namespace


StoplistsChanges Members

[image] [image]

SQL Data Compare API 12.0.40
StoplistsChanges Members
StoplistsChanges Class Constructors Methods Properties See Also

The StoplistsChanges type exposes the following members.

Constructors

Name | Description
StoplistsChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
StoplistsToAlter |
StoplistsToCreate |
StoplistsToDrop |
StoplistTargets |

See Also

StoplistsChanges Class
RedGate.SQLCompare.Engine Namespace


StoplistsChanges Constructor

[image]

SQL Data Compare API 12.0.40
StoplistsChanges Constructor
StoplistsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public StoplistsChanges(
    bool caseSensitive
)
Visual C++
public:
StoplistsChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

StoplistsChanges Class
RedGate.SQLCompare.Engine Namespace


StoplistsChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
StoplistsChanges Properties
StoplistsChanges Class See Also

The StoplistsChanges type exposes the following properties.

Properties

Name | Description
StoplistsToAlter |
StoplistsToCreate |
StoplistsToDrop |
StoplistTargets |

See Also

StoplistsChanges Class
RedGate.SQLCompare.Engine Namespace


StoplistsToAlter Property

[image]

SQL Data Compare API 12.0.40
StoplistsChanges..::.StoplistsToAlter Property
StoplistsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property StoplistsToAlter As FullTextStoplists
C#
public FullTextStoplists StoplistsToAlter { get; private set; }
Visual C++
public:
property FullTextStoplists^ StoplistsToAlter {
    FullTextStoplists^ get ();
    void set (FullTextStoplists^ value);
}

See Also

StoplistsChanges Class
RedGate.SQLCompare.Engine Namespace


StoplistsToCreate Property

[image]

SQL Data Compare API 12.0.40
StoplistsChanges..::.StoplistsToCreate Property
StoplistsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property StoplistsToCreate As FullTextStoplists
C#
public FullTextStoplists StoplistsToCreate { get; private set; }
Visual C++
public:
property FullTextStoplists^ StoplistsToCreate {
    FullTextStoplists^ get ();
    void set (FullTextStoplists^ value);
}

See Also

StoplistsChanges Class
RedGate.SQLCompare.Engine Namespace


StoplistsToDrop Property

[image]

SQL Data Compare API 12.0.40
StoplistsChanges..::.StoplistsToDrop Property
StoplistsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property StoplistsToDrop As FullTextStoplists
C#
public FullTextStoplists StoplistsToDrop { get; private set; }
Visual C++
public:
property FullTextStoplists^ StoplistsToDrop {
    FullTextStoplists^ get ();
    void set (FullTextStoplists^ value);
}

See Also

StoplistsChanges Class
RedGate.SQLCompare.Engine Namespace


StoplistTargets Property

[image]

SQL Data Compare API 12.0.40
StoplistsChanges..::.StoplistTargets Property
StoplistsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property StoplistTargets As Dictionary(Of FullTextStoplist, FullTextStoplist)
C#
public Dictionary<FullTextStoplist, FullTextStoplist> StoplistTargets { get; private set; }
Visual C++
public:
property Dictionary<FullTextStoplist^, FullTextStoplist^>^ StoplistTargets {
    Dictionary<FullTextStoplist^, FullTextStoplist^>^ get ();
    void set (Dictionary<FullTextStoplist^, FullTextStoplist^>^ value);
}

See Also

StoplistsChanges Class
RedGate.SQLCompare.Engine Namespace


StoredProcedure Class

[image]

SQL Data Compare API 12.0.40
StoredProcedure Class
Members See Also

A stored procedure.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StoredProcedure _
    Inherits SchemaObjectWithAuthorization _
    Implements IDatabaseObject, ITSqlObject, ICanExistenceCheck, IExecuteAs,  _
    IIsSystemObject, IEncryptedTextObject, ITextObject, ISessionSetObject, IPatchUpAfterDeserialization,  _
    ISqlComparable, IHasLastModifiedDate
C#
public sealed class StoredProcedure : SchemaObjectWithAuthorization, IDatabaseObject,
    ITSqlObject, ICanExistenceCheck, IExecuteAs, IIsSystemObject, IEncryptedTextObject,
    ITextObject, ISessionSetObject, IPatchUpAfterDeserialization, ISqlComparable, IHasLastModifiedDate
Visual C++
public ref class StoredProcedure sealed : public SchemaObjectWithAuthorization,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, IExecuteAs, IIsSystemObject,
    IEncryptedTextObject, ITextObject, ISessionSetObject, IPatchUpAfterDeserialization, ISqlComparable,
    IHasLastModifiedDate

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.SchemaObjectWithAuthorization
RedGate.SQLCompare.Engine..::.StoredProcedure

See Also

StoredProcedure Members
RedGate.SQLCompare.Engine Namespace


StoredProcedure Members

[image] [image]

SQL Data Compare API 12.0.40
StoredProcedure Members
StoredProcedure Class Methods Fields Properties Explicit Interface Implementations See Also

The StoredProcedure type exposes the following members.

Methods

Name | Description
CompareWith |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSql |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
SetSessionOptions |
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AlterAuthorizationClassType | (Inherited from SchemaObjectWithAuthorization.)
AnsiNullsOn | True if the stored procedure was created with ansi nulls on.
Assembly | The CLR assembly for the stored procedure, if it is a CLR stored procedure.
AssemblyClass | The CLR assembly class name for the stored procedure, if it is a CLR stored procedure.
AssemblyMethod | The CLR assembly method name for the stored procedure, if it is a CLR stored procedure.
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
CLRObject | True if the stored procedure is a CLR stored procedure.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
Encrypted | True if the stored procedure definition is encrypted.
ExecuteAs | The user whose security context is to be used for the execution of the stored procedure. This is a SQL Server 2005 and 2008 feature.
ExecuteAsType | The EXECUTE AS clause used for the object.
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
LastModified | The last time this stored procedure was modified.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
NativelyCompiled |
NumberedProcScriptSources | The script sources associated with additional numbered stored procedures.
ObjectType | Returns ObjectType.StoredProcedure (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Parameters | The parameters of the stored procedure.
Permissions | (Inherited from SchemaObjectWithAuthorization.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
QuotedIdentifierOn | True if the stored procedure was created with quoted identifiers on.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSources | (Overrides SchemaObject ..::. ScriptSources.)
Text | The text of the stored procedure.

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |
IEncryptedTextObject..::.TextID |

See Also

StoredProcedure Class
RedGate.SQLCompare.Engine Namespace


StoredProcedure Methods

[image] [image]

SQL Data Compare API 12.0.40
StoredProcedure Methods
StoredProcedure Class See Also

The StoredProcedure type exposes the following methods.

Methods

Name | Description
CompareWith |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSql |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
SetSessionOptions |
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

StoredProcedure Class
RedGate.SQLCompare.Engine Namespace


CompareWith Method

[image]

SQL Data Compare API 12.0.40
StoredProcedure..::.CompareWith Method
StoredProcedure Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareWith ( _
    target As StoredProcedure, _
    options As Options _
) As IEnumerable(Of EqualityDifference)
C#
public IEnumerable<EqualityDifference> CompareWith(
    StoredProcedure target,
    Options options
)
Visual C++
public:
IEnumerable<EqualityDifference^>^ CompareWith(
    StoredProcedure^ target,
    Options options
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.StoredProcedure
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

StoredProcedure Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
StoredProcedure..::.ISqlComparable..::.CompareWith Method
StoredProcedure Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    other As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable other,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ other,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

other
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

StoredProcedure Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
StoredProcedure..::.Equals Method
StoredProcedure Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the stored procedure with a specified stored procedure. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

StoredProcedure Class
StoredProcedure Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
StoredProcedure..::.Equals Method (IDatabaseObject, Options)
StoredProcedure Class See Also

Compares the stored procedure with a specified stored procedure.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) override

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The stored procedure to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the stored procedures are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

StoredProcedure Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


GetSql Method

[image]

SQL Data Compare API 12.0.40
StoredProcedure..::.GetSql Method
StoredProcedure Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSql ( _
    options As Options, _
    targetIsEncrypted As Boolean, _
    useAlter As Boolean, _
    targetFeatures As IFeatureChecker _
) As String
C#
public string GetSql(
    Options options,
    bool targetIsEncrypted,
    bool useAlter,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual String^ GetSql(
    Options options,
    bool targetIsEncrypted,
    bool useAlter,
    IFeatureChecker^ targetFeatures
) sealed

Parameters

options
Type: RedGate.SQLCompare.Engine..::.Options
targetIsEncrypted
Type: Boolean
useAlter
Type: Boolean
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Implements

IEncryptedTextObject..::.GetSql(Options, Boolean, Boolean, IFeatureChecker)

See Also

StoredProcedure Class
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
StoredProcedure..::.PatchUpAfterDeserialization Method
StoredProcedure Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

StoredProcedure Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
StoredProcedure..::.ScriptObject Method
StoredProcedure Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

StoredProcedure Class
RedGate.SQLCompare.Engine Namespace


SetSessionOptions Method

[image]

SQL Data Compare API 12.0.40
StoredProcedure..::.SetSessionOptions Method
StoredProcedure Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetSessionOptions ( _
    ansiNulls As Boolean, _
    quotedIdentifier As Boolean _
)
C#
public void SetSessionOptions(
    bool ansiNulls,
    bool quotedIdentifier
)
Visual C++
public:
virtual void SetSessionOptions(
    bool ansiNulls,
    bool quotedIdentifier
) sealed

Parameters

ansiNulls
Type: Boolean
quotedIdentifier
Type: Boolean

Implements

ISessionSetObject..::.SetSessionOptions(Boolean, Boolean)

See Also

StoredProcedure Class
RedGate.SQLCompare.Engine Namespace


StoredProcedure Properties

[image] [image]

SQL Data Compare API 12.0.40
StoredProcedure Properties
StoredProcedure Class See Also

The StoredProcedure type exposes the following properties.

Properties

Name | Description
AlterAuthorizationClassType | (Inherited from SchemaObjectWithAuthorization.)
AnsiNullsOn | True if the stored procedure was created with ansi nulls on.
Assembly | The CLR assembly for the stored procedure, if it is a CLR stored procedure.
AssemblyClass | The CLR assembly class name for the stored procedure, if it is a CLR stored procedure.
AssemblyMethod | The CLR assembly method name for the stored procedure, if it is a CLR stored procedure.
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
CLRObject | True if the stored procedure is a CLR stored procedure.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
Encrypted | True if the stored procedure definition is encrypted.
ExecuteAs | The user whose security context is to be used for the execution of the stored procedure. This is a SQL Server 2005 and 2008 feature.
ExecuteAsType | The EXECUTE AS clause used for the object.
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
LastModified | The last time this stored procedure was modified.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
NativelyCompiled |
NumberedProcScriptSources | The script sources associated with additional numbered stored procedures.
ObjectType | Returns ObjectType.StoredProcedure (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Parameters | The parameters of the stored procedure.
Permissions | (Inherited from SchemaObjectWithAuthorization.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
QuotedIdentifierOn | True if the stored procedure was created with quoted identifiers on.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSources | (Overrides SchemaObject ..::. ScriptSources.)
Text | The text of the stored procedure.

Explicit Interface Implementations

Name | Description
IEncryptedTextObject..::.TextID |

See Also

StoredProcedure Class
RedGate.SQLCompare.Engine Namespace


AnsiNullsOn Property

[image]

SQL Data Compare API 12.0.40
StoredProcedure..::.AnsiNullsOn Property
StoredProcedure Class See Also

True if the stored procedure was created with ansi nulls on.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AnsiNullsOn As Boolean
C#
public bool AnsiNullsOn { get; internal set; }
Visual C++
public:
virtual property bool AnsiNullsOn {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

ISessionSetObject..::.AnsiNullsOn

See Also

StoredProcedure Class
RedGate.SQLCompare.Engine Namespace


Assembly Property

[image]

SQL Data Compare API 12.0.40
StoredProcedure..::.Assembly Property
StoredProcedure Class See Also

The CLR assembly for the stored procedure, if it is a CLR stored procedure.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Assembly As ClrAssembly
C#
public ClrAssembly Assembly { get; internal set; }
Visual C++
public:
virtual property ClrAssembly^ Assembly {
    ClrAssembly^ get () sealed;
    void set (ClrAssembly^ value) sealed;
}

See Also

StoredProcedure Class
RedGate.SQLCompare.Engine Namespace


AssemblyClass Property

[image]

SQL Data Compare API 12.0.40
StoredProcedure..::.AssemblyClass Property
StoredProcedure Class See Also

The CLR assembly class name for the stored procedure, if it is a CLR stored procedure.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyClass As String
C#
public string AssemblyClass { get; internal set; }
Visual C++
public:
property String^ AssemblyClass {
    String^ get ();
    void set (String^ value);
}

See Also

StoredProcedure Class
RedGate.SQLCompare.Engine Namespace


AssemblyMethod Property

[image]

SQL Data Compare API 12.0.40
StoredProcedure..::.AssemblyMethod Property
StoredProcedure Class See Also

The CLR assembly method name for the stored procedure, if it is a CLR stored procedure.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyMethod As String
C#
public string AssemblyMethod { get; internal set; }
Visual C++
public:
property String^ AssemblyMethod {
    String^ get ();
    void set (String^ value);
}

See Also

StoredProcedure Class
RedGate.SQLCompare.Engine Namespace


CLRObject Property

[image]

SQL Data Compare API 12.0.40
StoredProcedure..::.CLRObject Property
StoredProcedure Class See Also

True if the stored procedure is a CLR stored procedure.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CLRObject As Boolean
C#
public bool CLRObject { get; internal set; }
Visual C++
public:
virtual property bool CLRObject {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

StoredProcedure Class
RedGate.SQLCompare.Engine Namespace


Encrypted Property

[image]

SQL Data Compare API 12.0.40
StoredProcedure..::.Encrypted Property
StoredProcedure Class See Also

True if the stored procedure definition is encrypted.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Encrypted As Boolean
C#
public bool Encrypted { get; internal set; }
Visual C++
public:
virtual property bool Encrypted {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IEncryptedTextObject..::.Encrypted

See Also

StoredProcedure Class
RedGate.SQLCompare.Engine Namespace


ExecuteAs Property

[image]

SQL Data Compare API 12.0.40
StoredProcedure..::.ExecuteAs Property
StoredProcedure Class See Also

The user whose security context is to be used for the execution of the stored procedure. This is a SQL Server 2005 and 2008 feature.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecuteAs As User
C#
public User ExecuteAs { get; internal set; }
Visual C++
public:
virtual property User^ ExecuteAs {
    User^ get () sealed;
    void set (User^ value) sealed;
}

Implements

IExecuteAs..::.ExecuteAs

See Also

StoredProcedure Class
RedGate.SQLCompare.Engine Namespace


ExecuteAsType Property

[image]

SQL Data Compare API 12.0.40
StoredProcedure..::.ExecuteAsType Property
StoredProcedure Class See Also

The EXECUTE AS clause used for the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecuteAsType As ExecuteAs
C#
public ExecuteAs ExecuteAsType { get; internal set; }
Visual C++
public:
virtual property ExecuteAs ExecuteAsType {
    ExecuteAs get () sealed;
    void set (ExecuteAs value) sealed;
}

Implements

IExecuteAs..::.ExecuteAsType

See Also

StoredProcedure Class
RedGate.SQLCompare.Engine Namespace


LastModified Property

[image]

SQL Data Compare API 12.0.40
StoredProcedure..::.LastModified Property
StoredProcedure Class See Also

The last time this stored procedure was modified.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LastModified As DateTime
C#
public DateTime LastModified { get; internal set; }
Visual C++
public:
virtual property DateTime LastModified {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}

Implements

IHasLastModifiedDate..::.LastModified

See Also

StoredProcedure Class
RedGate.SQLCompare.Engine Namespace


NativelyCompiled Property

[image]

SQL Data Compare API 12.0.40
StoredProcedure..::.NativelyCompiled Property
StoredProcedure Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NativelyCompiled As Boolean
C#
public bool NativelyCompiled { get; set; }
Visual C++
public:
property bool NativelyCompiled {
    bool get ();
    void set (bool value);
}

See Also

StoredProcedure Class
RedGate.SQLCompare.Engine Namespace


NumberedProcScriptSources Property

[image]

SQL Data Compare API 12.0.40
StoredProcedure..::.NumberedProcScriptSources Property
StoredProcedure Class See Also

The script sources associated with additional numbered stored procedures.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NumberedProcScriptSources As IList(Of ScriptSource)
C#
public IList<ScriptSource> NumberedProcScriptSources { get; internal set; }
Visual C++
public:
property IList<ScriptSource^>^ NumberedProcScriptSources {
    IList<ScriptSource^>^ get ();
    void set (IList<ScriptSource^>^ value);
}

See Also

StoredProcedure Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
StoredProcedure..::.ObjectType Property
StoredProcedure Class See Also

Returns ObjectType.StoredProcedure

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()
ITSqlObjectObjectType()()()

See Also

StoredProcedure Class
RedGate.SQLCompare.Engine Namespace


Parameters Property

[image]

SQL Data Compare API 12.0.40
StoredProcedure..::.Parameters Property
StoredProcedure Class See Also

The parameters of the stored procedure.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As Parameters
C#
public Parameters Parameters { get; }
Visual C++
public:
property Parameters^ Parameters {
    Parameters^ get ();
}

See Also

StoredProcedure Class
RedGate.SQLCompare.Engine Namespace


QuotedIdentifierOn Property

[image]

SQL Data Compare API 12.0.40
StoredProcedure..::.QuotedIdentifierOn Property
StoredProcedure Class See Also

True if the stored procedure was created with quoted identifiers on.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property QuotedIdentifierOn As Boolean
C#
public bool QuotedIdentifierOn { get; internal set; }
Visual C++
public:
virtual property bool QuotedIdentifierOn {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

ISessionSetObject..::.QuotedIdentifierOn

See Also

StoredProcedure Class
RedGate.SQLCompare.Engine Namespace


ScriptSources Property

[image]

SQL Data Compare API 12.0.40
StoredProcedure..::.ScriptSources Property
StoredProcedure Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ScriptSources As IEnumerable(Of ScriptSource)
C#
public override IEnumerable<ScriptSource> ScriptSources { get; }
Visual C++
public:
virtual property IEnumerable<ScriptSource^>^ ScriptSources {
    IEnumerable<ScriptSource^>^ get () override;
}

See Also

StoredProcedure Class
RedGate.SQLCompare.Engine Namespace


Text Property

[image]

SQL Data Compare API 12.0.40
StoredProcedure..::.Text Property
StoredProcedure Class See Also

The text of the stored procedure.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
C#
public string Text { get; }
Visual C++
public:
virtual property String^ Text {
    String^ get () sealed;
}

Implements

ITextObject..::.Text

See Also

StoredProcedure Class
RedGate.SQLCompare.Engine Namespace


IEncryptedTextObject.TextID Property

[image]

SQL Data Compare API 12.0.40
StoredProcedure..::.IEncryptedTextObject..::.TextID Property
StoredProcedure Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private ReadOnly Property TextID As Integer
    Implements IEncryptedTextObject.TextID
C#
int IEncryptedTextObject.TextID { get; }
Visual C++
private:
virtual property int TextID {
    int get () sealed = IEncryptedTextObject::TextID::get;
}

Implements

IEncryptedTextObject..::.TextID

See Also

StoredProcedure Class
RedGate.SQLCompare.Engine Namespace


StoredProcedures Class

[image]

SQL Data Compare API 12.0.40
StoredProcedures Class
Members See Also

A collection of stored procedures.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StoredProcedures _
    Inherits SerializableDatabaseObjectCollection(Of StoredProcedure) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class StoredProcedures : SerializableDatabaseObjectCollection<StoredProcedure>, IPatchUpAfterDeserialization
Visual C++
public ref class StoredProcedures sealed : public SerializableDatabaseObjectCollection<StoredProcedure^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( StoredProcedure >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( StoredProcedure >)>)
RedGate.SQLCompare.Engine..::.StoredProcedures

See Also

StoredProcedures Members
RedGate.SQLCompare.Engine Namespace


StoredProcedures Members

[image] [image]

SQL Data Compare API 12.0.40
StoredProcedures Members
StoredProcedures Class Methods Fields Properties Explicit Interface Implementations See Also

The StoredProcedures type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

StoredProcedures Class
RedGate.SQLCompare.Engine Namespace


StoredProcedures Methods

[image] [image]

SQL Data Compare API 12.0.40
StoredProcedures Methods
StoredProcedures Class See Also

The StoredProcedures type exposes the following methods.

Methods

Name | Description
Add | Overloaded.
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

StoredProcedures Class
RedGate.SQLCompare.Engine Namespace


Add Method

[image] [image]

SQL Data Compare API 12.0.40
StoredProcedures..::.Add Method
StoredProcedures Class See Also

Overload List

Name | Description
Add(T) | (Inherited from KeyedCollection<(Of <(T>)>).)
Add(StoredProcedure) | (Overrides SerializableDatabaseObjectCollection <(Of <( StoredProcedure >)>)..::. Add(T).)

See Also

StoredProcedures Class
StoredProcedures Members
RedGate.SQLCompare.Engine Namespace


Add Method (StoredProcedure)

[image]

SQL Data Compare API 12.0.40
StoredProcedures..::.Add Method (StoredProcedure)
StoredProcedures Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Add ( _
    value As StoredProcedure _
)
C#
public override void Add(
    StoredProcedure value
)
Visual C++
public:
virtual void Add(
    StoredProcedure^ value
) override

Parameters

value
Type: RedGate.SQLCompare.Engine..::.StoredProcedure

See Also

StoredProcedures Class
Add Overload
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
StoredProcedures..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
StoredProcedures Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

StoredProcedures Class
RedGate.SQLCompare.Engine Namespace


StoredProceduresChanges Class

[image]

SQL Data Compare API 12.0.40
StoredProceduresChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StoredProceduresChanges
C#
public sealed class StoredProceduresChanges
Visual C++
public ref class StoredProceduresChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.StoredProceduresChanges

See Also

StoredProceduresChanges Members
RedGate.SQLCompare.Engine Namespace


StoredProceduresChanges Members

[image] [image]

SQL Data Compare API 12.0.40
StoredProceduresChanges Members
StoredProceduresChanges Class Constructors Methods Properties See Also

The StoredProceduresChanges type exposes the following members.

Constructors

Name | Description
StoredProceduresChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectsToCreate |
GetObjectsToDrop |
GetObjectsToRebuild |
GetTargets |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ProceduresToAlter |
ProceduresToCreate |
ProceduresToDrop |
ProceduresToRebuild |
StoredProcTargets |

See Also

StoredProceduresChanges Class
RedGate.SQLCompare.Engine Namespace


StoredProceduresChanges Constructor

[image]

SQL Data Compare API 12.0.40
StoredProceduresChanges Constructor
StoredProceduresChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public StoredProceduresChanges(
    bool caseSensitive
)
Visual C++
public:
StoredProceduresChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

StoredProceduresChanges Class
RedGate.SQLCompare.Engine Namespace


StoredProceduresChanges Methods

[image] [image]

SQL Data Compare API 12.0.40
StoredProceduresChanges Methods
StoredProceduresChanges Class See Also

The StoredProceduresChanges type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectsToCreate |
GetObjectsToDrop |
GetObjectsToRebuild |
GetTargets |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StoredProceduresChanges Class
RedGate.SQLCompare.Engine Namespace


GetObjectsToCreate Method

[image]

SQL Data Compare API 12.0.40
StoredProceduresChanges..::.GetObjectsToCreate Method
StoredProceduresChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetObjectsToCreate As KeyedCollection(Of StoredProcedure)
C#
public KeyedCollection<StoredProcedure> GetObjectsToCreate()
Visual C++
public:
virtual KeyedCollection<StoredProcedure^>^ GetObjectsToCreate() sealed

See Also

StoredProceduresChanges Class
RedGate.SQLCompare.Engine Namespace


GetObjectsToDrop Method

[image]

SQL Data Compare API 12.0.40
StoredProceduresChanges..::.GetObjectsToDrop Method
StoredProceduresChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetObjectsToDrop As KeyedCollection(Of StoredProcedure)
C#
public KeyedCollection<StoredProcedure> GetObjectsToDrop()
Visual C++
public:
virtual KeyedCollection<StoredProcedure^>^ GetObjectsToDrop() sealed

See Also

StoredProceduresChanges Class
RedGate.SQLCompare.Engine Namespace


GetObjectsToRebuild Method

[image]

SQL Data Compare API 12.0.40
StoredProceduresChanges..::.GetObjectsToRebuild Method
StoredProceduresChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetObjectsToRebuild As KeyedCollection(Of StoredProcedure)
C#
public KeyedCollection<StoredProcedure> GetObjectsToRebuild()
Visual C++
public:
virtual KeyedCollection<StoredProcedure^>^ GetObjectsToRebuild() sealed

See Also

StoredProceduresChanges Class
RedGate.SQLCompare.Engine Namespace


GetTargets Method

[image]

SQL Data Compare API 12.0.40
StoredProceduresChanges..::.GetTargets Method
StoredProceduresChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetTargets As Dictionary(Of StoredProcedure, StoredProcedure)
C#
public Dictionary<StoredProcedure, StoredProcedure> GetTargets()
Visual C++
public:
virtual Dictionary<StoredProcedure^, StoredProcedure^>^ GetTargets() sealed

See Also

StoredProceduresChanges Class
RedGate.SQLCompare.Engine Namespace


StoredProceduresChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
StoredProceduresChanges Properties
StoredProceduresChanges Class See Also

The StoredProceduresChanges type exposes the following properties.

Properties

Name | Description
ProceduresToAlter |
ProceduresToCreate |
ProceduresToDrop |
ProceduresToRebuild |
StoredProcTargets |

See Also

StoredProceduresChanges Class
RedGate.SQLCompare.Engine Namespace


ProceduresToAlter Property

[image]

SQL Data Compare API 12.0.40
StoredProceduresChanges..::.ProceduresToAlter Property
StoredProceduresChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ProceduresToAlter As StoredProcedures
C#
public StoredProcedures ProceduresToAlter { get; private set; }
Visual C++
public:
property StoredProcedures^ ProceduresToAlter {
    StoredProcedures^ get ();
    void set (StoredProcedures^ value);
}

See Also

StoredProceduresChanges Class
RedGate.SQLCompare.Engine Namespace


ProceduresToCreate Property

[image]

SQL Data Compare API 12.0.40
StoredProceduresChanges..::.ProceduresToCreate Property
StoredProceduresChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ProceduresToCreate As StoredProcedures
C#
public StoredProcedures ProceduresToCreate { get; private set; }
Visual C++
public:
property StoredProcedures^ ProceduresToCreate {
    StoredProcedures^ get ();
    void set (StoredProcedures^ value);
}

See Also

StoredProceduresChanges Class
RedGate.SQLCompare.Engine Namespace


ProceduresToDrop Property

[image]

SQL Data Compare API 12.0.40
StoredProceduresChanges..::.ProceduresToDrop Property
StoredProceduresChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ProceduresToDrop As StoredProcedures
C#
public StoredProcedures ProceduresToDrop { get; private set; }
Visual C++
public:
property StoredProcedures^ ProceduresToDrop {
    StoredProcedures^ get ();
    void set (StoredProcedures^ value);
}

See Also

StoredProceduresChanges Class
RedGate.SQLCompare.Engine Namespace


ProceduresToRebuild Property

[image]

SQL Data Compare API 12.0.40
StoredProceduresChanges..::.ProceduresToRebuild Property
StoredProceduresChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ProceduresToRebuild As StoredProcedures
C#
public StoredProcedures ProceduresToRebuild { get; private set; }
Visual C++
public:
property StoredProcedures^ ProceduresToRebuild {
    StoredProcedures^ get ();
    void set (StoredProcedures^ value);
}

See Also

StoredProceduresChanges Class
RedGate.SQLCompare.Engine Namespace


StoredProcTargets Property

[image]

SQL Data Compare API 12.0.40
StoredProceduresChanges..::.StoredProcTargets Property
StoredProceduresChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property StoredProcTargets As Dictionary(Of StoredProcedure, StoredProcedure)
C#
public Dictionary<StoredProcedure, StoredProcedure> StoredProcTargets { get; private set; }
Visual C++
public:
property Dictionary<StoredProcedure^, StoredProcedure^>^ StoredProcTargets {
    Dictionary<StoredProcedure^, StoredProcedure^>^ get ();
    void set (Dictionary<StoredProcedure^, StoredProcedure^>^ value);
}

See Also

StoredProceduresChanges Class
RedGate.SQLCompare.Engine Namespace


SymmetricKey Class

[image]

SQL Data Compare API 12.0.40
SymmetricKey Class
Members See Also

A symmetric key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SymmetricKey _
    Inherits DatabaseObjectWithAuthorization _
    Implements IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck,  _
    IPatchUpAfterDeserialization, ISqlComparable
C#
public sealed class SymmetricKey : DatabaseObjectWithAuthorization, IHasPermissions,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, IPatchUpAfterDeserialization, ISqlComparable
Visual C++
public ref class SymmetricKey sealed : public DatabaseObjectWithAuthorization,
    IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck, IPatchUpAfterDeserialization,
    ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.SymmetricKey

See Also

SymmetricKey Members
RedGate.SQLCompare.Engine Namespace


SymmetricKey Members

[image] [image]

SQL Data Compare API 12.0.40
SymmetricKey Members
SymmetricKey Class Methods Fields Properties Explicit Interface Implementations See Also

The SymmetricKey type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AlterAuthorizationClassType | (Overrides DatabaseObjectWithAuthorization ..::. AlterAuthorizationClassType.)
CreateDate | The date of creation for the symmetric key.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
KeyAlgorithm | The symmetric key algorithm.
KeyGuid | The GUID for the symmetric key.
KeyLength | The length of the symmetric key.
ModifyDate | The date of the last modification for the symmetric key.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.SymmetricKey (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions |
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

SymmetricKey Class
RedGate.SQLCompare.Engine Namespace


SymmetricKey Methods

[image] [image]

SQL Data Compare API 12.0.40
SymmetricKey Methods
SymmetricKey Class See Also

The SymmetricKey type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

SymmetricKey Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
SymmetricKey..::.ISqlComparable..::.CompareWith Method
SymmetricKey Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    target As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable target,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ target,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

target
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

SymmetricKey Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
SymmetricKey..::.Equals Method
SymmetricKey Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the symmetric key with a specified symmetric key. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

SymmetricKey Class
SymmetricKey Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
SymmetricKey..::.Equals Method (IDatabaseObject, Options)
SymmetricKey Class See Also

Compares the symmetric key with a specified symmetric key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The symmetric key to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the symmetric keys are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

SymmetricKey Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
SymmetricKey..::.PatchUpAfterDeserialization Method
SymmetricKey Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

SymmetricKey Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
SymmetricKey..::.ScriptObject Method
SymmetricKey Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options, e.g. quoted identifier on or off.
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

SymmetricKey Class
RedGate.SQLCompare.Engine Namespace


SymmetricKey Properties

[image] [image]

SQL Data Compare API 12.0.40
SymmetricKey Properties
SymmetricKey Class See Also

The SymmetricKey type exposes the following properties.

Properties

Name | Description
AlterAuthorizationClassType | (Overrides DatabaseObjectWithAuthorization ..::. AlterAuthorizationClassType.)
CreateDate | The date of creation for the symmetric key.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
FullyQualifiedName | The fully-qualified name of the object. DANGER WILL ROBINSON!! Sometimes this will be escaped, and sometimes it won't be. (Inherited from ScriptableDatabaseObject.)
KeyAlgorithm | The symmetric key algorithm.
KeyGuid | The GUID for the symmetric key.
KeyLength | The length of the symmetric key.
ModifyDate | The date of the last modification for the symmetric key.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.SymmetricKey (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions |
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSources | (Inherited from ScriptableDatabaseObject.)

See Also

SymmetricKey Class
RedGate.SQLCompare.Engine Namespace


AlterAuthorizationClassType Property

[image]

SQL Data Compare API 12.0.40
SymmetricKey..::.AlterAuthorizationClassType Property
SymmetricKey Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property AlterAuthorizationClassType As String
C#
public override string AlterAuthorizationClassType { get; }
Visual C++
public:
virtual property String^ AlterAuthorizationClassType {
    String^ get () override;
}

Implements

IHasAuthorization..::.AlterAuthorizationClassType

See Also

SymmetricKey Class
RedGate.SQLCompare.Engine Namespace


CreateDate Property

[image]

SQL Data Compare API 12.0.40
SymmetricKey..::.CreateDate Property
SymmetricKey Class See Also

The date of creation for the symmetric key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CreateDate As DateTime
C#
public DateTime CreateDate { get; internal set; }
Visual C++
public:
property DateTime CreateDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

SymmetricKey Class
RedGate.SQLCompare.Engine Namespace


KeyAlgorithm Property

[image]

SQL Data Compare API 12.0.40
SymmetricKey..::.KeyAlgorithm Property
SymmetricKey Class See Also

The symmetric key algorithm.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property KeyAlgorithm As SymmetricKey..::.SymmetricKeyEncryptionAlgorithm
C#
public SymmetricKey..::.SymmetricKeyEncryptionAlgorithm KeyAlgorithm { get; internal set; }
Visual C++
public:
property SymmetricKey..::.SymmetricKeyEncryptionAlgorithm KeyAlgorithm {
    SymmetricKey..::.SymmetricKeyEncryptionAlgorithm get ();
    void set (SymmetricKey..::.SymmetricKeyEncryptionAlgorithm value);
}

See Also

SymmetricKey Class
RedGate.SQLCompare.Engine Namespace


KeyGuid Property

[image]

SQL Data Compare API 12.0.40
SymmetricKey..::.KeyGuid Property
SymmetricKey Class See Also

The GUID for the symmetric key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property KeyGuid As Guid
C#
public Guid KeyGuid { get; internal set; }
Visual C++
public:
property Guid KeyGuid {
    Guid get ();
    void set (Guid value);
}

See Also

SymmetricKey Class
RedGate.SQLCompare.Engine Namespace


KeyLength Property

[image]

SQL Data Compare API 12.0.40
SymmetricKey..::.KeyLength Property
SymmetricKey Class See Also

The length of the symmetric key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property KeyLength As Integer
C#
public int KeyLength { get; internal set; }
Visual C++
public:
property int KeyLength {
    int get ();
    void set (int value);
}

See Also

SymmetricKey Class
RedGate.SQLCompare.Engine Namespace


ModifyDate Property

[image]

SQL Data Compare API 12.0.40
SymmetricKey..::.ModifyDate Property
SymmetricKey Class See Also

The date of the last modification for the symmetric key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ModifyDate As DateTime
C#
public DateTime ModifyDate { get; internal set; }
Visual C++
public:
property DateTime ModifyDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

SymmetricKey Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
SymmetricKey..::.ObjectType Property
SymmetricKey Class See Also

Returns ObjectType.SymmetricKey

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()
ITSqlObjectObjectType()()()

See Also

SymmetricKey Class
RedGate.SQLCompare.Engine Namespace


Permissions Property

[image]

SQL Data Compare API 12.0.40
SymmetricKey..::.Permissions Property
SymmetricKey Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Permissions As Permissions
C#
public Permissions Permissions { get; private set; }
Visual C++
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
    void set (Permissions^ value) sealed;
}

Implements

IHasPermissions..::.Permissions

See Also

SymmetricKey Class
RedGate.SQLCompare.Engine Namespace


SymmetricKey.SymmetricKeyEncryptionAlgorithm Enumeration

[image]

SQL Data Compare API 12.0.40
SymmetricKey..::.SymmetricKeyEncryptionAlgorithm Enumeration
SymmetricKey Class See Also

The symmetric key encryption algorithm.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration SymmetricKeyEncryptionAlgorithm
C#
public enum SymmetricKeyEncryptionAlgorithm
Visual C++
public enum class SymmetricKeyEncryptionAlgorithm

Members

Member name | Description
Unknown | Unknown
R2 | R2 = RC2
R4 | R4 = RC4
D | D = DES
D3 | D3 = Triple DES
DX | DX = DESX
A1 | A1 = AES 128
A2 | A2 = AES 192
A3 | A3 = AES 256

See Also

RedGate.SQLCompare.Engine Namespace


SymmetricKeys Class

[image]

SQL Data Compare API 12.0.40
SymmetricKeys Class
Members See Also

A collection of symmetric keys.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SymmetricKeys _
    Inherits SerializableDatabaseObjectCollection(Of SymmetricKey) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class SymmetricKeys : SerializableDatabaseObjectCollection<SymmetricKey>, IPatchUpAfterDeserialization
Visual C++
public ref class SymmetricKeys sealed : public SerializableDatabaseObjectCollection<SymmetricKey^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( SymmetricKey >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( SymmetricKey >)>)
RedGate.SQLCompare.Engine..::.SymmetricKeys

See Also

SymmetricKeys Members
RedGate.SQLCompare.Engine Namespace


SymmetricKeys Members

[image] [image]

SQL Data Compare API 12.0.40
SymmetricKeys Members
SymmetricKeys Class Methods Fields Properties Explicit Interface Implementations See Also

The SymmetricKeys type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

SymmetricKeys Class
RedGate.SQLCompare.Engine Namespace


SymmetricKeys Methods

[image] [image]

SQL Data Compare API 12.0.40
SymmetricKeys Methods
SymmetricKeys Class See Also

The SymmetricKeys type exposes the following methods.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

SymmetricKeys Class
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
SymmetricKeys..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
SymmetricKeys Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

SymmetricKeys Class
RedGate.SQLCompare.Engine Namespace


SymmetricKeysChanges Class

[image]

SQL Data Compare API 12.0.40
SymmetricKeysChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SymmetricKeysChanges
C#
public sealed class SymmetricKeysChanges
Visual C++
public ref class SymmetricKeysChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.SymmetricKeysChanges

See Also

SymmetricKeysChanges Members
RedGate.SQLCompare.Engine Namespace


SymmetricKeysChanges Members

[image] [image]

SQL Data Compare API 12.0.40
SymmetricKeysChanges Members
SymmetricKeysChanges Class Constructors Methods Properties See Also

The SymmetricKeysChanges type exposes the following members.

Constructors

Name | Description
SymmetricKeysChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
SymmetricKeysToAlter |
SymmetricKeysToCreate |
SymmetricKeysToDrop |
SymmKeyTargets |

See Also

SymmetricKeysChanges Class
RedGate.SQLCompare.Engine Namespace


SymmetricKeysChanges Constructor

[image]

SQL Data Compare API 12.0.40
SymmetricKeysChanges Constructor
SymmetricKeysChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public SymmetricKeysChanges(
    bool caseSensitive
)
Visual C++
public:
SymmetricKeysChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

SymmetricKeysChanges Class
RedGate.SQLCompare.Engine Namespace


SymmetricKeysChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
SymmetricKeysChanges Properties
SymmetricKeysChanges Class See Also

The SymmetricKeysChanges type exposes the following properties.

Properties

Name | Description
SymmetricKeysToAlter |
SymmetricKeysToCreate |
SymmetricKeysToDrop |
SymmKeyTargets |

See Also

SymmetricKeysChanges Class
RedGate.SQLCompare.Engine Namespace


SymmetricKeysToAlter Property

[image]

SQL Data Compare API 12.0.40
SymmetricKeysChanges..::.SymmetricKeysToAlter Property
SymmetricKeysChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SymmetricKeysToAlter As SymmetricKeys
C#
public SymmetricKeys SymmetricKeysToAlter { get; private set; }
Visual C++
public:
property SymmetricKeys^ SymmetricKeysToAlter {
    SymmetricKeys^ get ();
    void set (SymmetricKeys^ value);
}

See Also

SymmetricKeysChanges Class
RedGate.SQLCompare.Engine Namespace


SymmetricKeysToCreate Property

[image]

SQL Data Compare API 12.0.40
SymmetricKeysChanges..::.SymmetricKeysToCreate Property
SymmetricKeysChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SymmetricKeysToCreate As SymmetricKeys
C#
public SymmetricKeys SymmetricKeysToCreate { get; private set; }
Visual C++
public:
property SymmetricKeys^ SymmetricKeysToCreate {
    SymmetricKeys^ get ();
    void set (SymmetricKeys^ value);
}

See Also

SymmetricKeysChanges Class
RedGate.SQLCompare.Engine Namespace


SymmetricKeysToDrop Property

[image]

SQL Data Compare API 12.0.40
SymmetricKeysChanges..::.SymmetricKeysToDrop Property
SymmetricKeysChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SymmetricKeysToDrop As SymmetricKeys
C#
public SymmetricKeys SymmetricKeysToDrop { get; private set; }
Visual C++
public:
property SymmetricKeys^ SymmetricKeysToDrop {
    SymmetricKeys^ get ();
    void set (SymmetricKeys^ value);
}

See Also

SymmetricKeysChanges Class
RedGate.SQLCompare.Engine Namespace


SymmKeyTargets Property

[image]

SQL Data Compare API 12.0.40
SymmetricKeysChanges..::.SymmKeyTargets Property
SymmetricKeysChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SymmKeyTargets As Dictionary(Of SymmetricKey, SymmetricKey)
C#
public Dictionary<SymmetricKey, SymmetricKey> SymmKeyTargets { get; private set; }
Visual C++
public:
property Dictionary<SymmetricKey^, SymmetricKey^>^ SymmKeyTargets {
    Dictionary<SymmetricKey^, SymmetricKey^>^ get ();
    void set (Dictionary<SymmetricKey^, SymmetricKey^>^ value);
}

See Also

SymmetricKeysChanges Class
RedGate.SQLCompare.Engine Namespace


SynchronizationDirection Enumeration

[image]

SQL Data Compare API 12.0.40
SynchronizationDirection Enumeration
See Also

The direction of migration for synchronization.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration SynchronizationDirection
C#
public enum SynchronizationDirection
Visual C++
public enum class SynchronizationDirection

Members

Member name | Description
From1To2 | SQL scripts will migrate any changes in DataSource1 to DataSource2.
From2To1 | SQL scripts will migrate any changes in DataSource2 to DataSource1.

See Also

RedGate.SQLCompare.Engine Namespace


Synonym Class

[image]

SQL Data Compare API 12.0.40
Synonym Class
Members See Also

A synonym.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Synonym _
    Inherits SchemaObjectWithAuthorization _
    Implements IDatabaseObject, ITSqlObject, ICanExistenceCheck, IPatchUpAfterDeserialization,  _
    ISqlComparable
C#
public sealed class Synonym : SchemaObjectWithAuthorization, IDatabaseObject,
    ITSqlObject, ICanExistenceCheck, IPatchUpAfterDeserialization, ISqlComparable
Visual C++
public ref class Synonym sealed : public SchemaObjectWithAuthorization,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, IPatchUpAfterDeserialization, ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.SchemaObjectWithAuthorization
RedGate.SQLCompare.Engine..::.Synonym

See Also

Synonym Members
RedGate.SQLCompare.Engine Namespace


Synonym Members

[image] [image]

SQL Data Compare API 12.0.40
Synonym Members
Synonym Class Methods Fields Properties Explicit Interface Implementations See Also

The Synonym type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetReferenceLocation |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ParseReferenceName |
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AlterAuthorizationClassType | (Inherited from SchemaObjectWithAuthorization.)
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Synonym (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from SchemaObjectWithAuthorization.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ReferencedName | The name that the synonym references.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSources | (Inherited from SchemaObject.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

Synonym Class
RedGate.SQLCompare.Engine Namespace


Synonym Methods

[image] [image]

SQL Data Compare API 12.0.40
Synonym Methods
Synonym Class See Also

The Synonym type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetReferenceLocation |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ParseReferenceName |
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

Synonym Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
Synonym..::.ISqlComparable..::.CompareWith Method
Synonym Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    target As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable target,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ target,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

target
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

Synonym Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
Synonym..::.Equals Method
Synonym Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares two database objects. (Inherited from ScriptableDatabaseObject.)

See Also

Synonym Class
Synonym Members
RedGate.SQLCompare.Engine Namespace


GetReferenceLocation Method

[image]

SQL Data Compare API 12.0.40
Synonym..::.GetReferenceLocation Method
Synonym Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetReferenceLocation As Synonym..::.ReferenceLocation
C#
public Synonym..::.ReferenceLocation GetReferenceLocation()
Visual C++
public:
Synonym..::.ReferenceLocation GetReferenceLocation()

Return Value

Our best guess as to whether the object being referenced by this synonym is on the same database or not

See Also

Synonym Class
RedGate.SQLCompare.Engine Namespace


ParseReferenceName Method

[image]

SQL Data Compare API 12.0.40
Synonym..::.ParseReferenceName Method
Synonym Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub ParseReferenceName ( _
    <OutAttribute> ByRef serverName As String, _
    <OutAttribute> ByRef databaseName As String, _
    <OutAttribute> ByRef ownerName As String, _
    <OutAttribute> ByRef objectName As String _
)
C#
public void ParseReferenceName(
    out string serverName,
    out string databaseName,
    out string ownerName,
    out string objectName
)
Visual C++
public:
void ParseReferenceName(
    [OutAttribute] String^% serverName,
    [OutAttribute] String^% databaseName,
    [OutAttribute] String^% ownerName,
    [OutAttribute] String^% objectName
)

Parameters

serverName
Type: String%
databaseName
Type: String%
ownerName
Type: String%
objectName
Type: String%

See Also

Synonym Class
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
Synonym..::.PatchUpAfterDeserialization Method
Synonym Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

Synonym Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
Synonym..::.ScriptObject Method
Synonym Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

Synonym Class
RedGate.SQLCompare.Engine Namespace


Synonym Properties

[image] [image]

SQL Data Compare API 12.0.40
Synonym Properties
Synonym Class See Also

The Synonym type exposes the following properties.

Properties

Name | Description
AlterAuthorizationClassType | (Inherited from SchemaObjectWithAuthorization.)
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Synonym (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from SchemaObjectWithAuthorization.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ReferencedName | The name that the synonym references.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSources | (Inherited from SchemaObject.)

See Also

Synonym Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
Synonym..::.ObjectType Property
Synonym Class See Also

Returns ObjectType.Synonym

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()
ITSqlObjectObjectType()()()

See Also

Synonym Class
RedGate.SQLCompare.Engine Namespace


ReferencedName Property

[image]

SQL Data Compare API 12.0.40
Synonym..::.ReferencedName Property
Synonym Class See Also

The name that the synonym references.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ReferencedName As String
C#
public string ReferencedName { get; internal set; }
Visual C++
public:
property String^ ReferencedName {
    String^ get ();
    void set (String^ value);
}

See Also

Synonym Class
RedGate.SQLCompare.Engine Namespace


Synonym.ReferenceLocation Enumeration

[image]

SQL Data Compare API 12.0.40
Synonym..::.ReferenceLocation Enumeration
Synonym Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration ReferenceLocation
C#
public enum ReferenceLocation
Visual C++
public enum class ReferenceLocation

Members

Member name | Description
Unknown |
Local |
CrossDatabase |
CrossServer |

See Also

RedGate.SQLCompare.Engine Namespace


Synonyms Class

[image]

SQL Data Compare API 12.0.40
Synonyms Class
Members See Also

A collection of synonyms.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Synonyms _
    Inherits SerializableDatabaseObjectCollection(Of Synonym) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class Synonyms : SerializableDatabaseObjectCollection<Synonym>, IPatchUpAfterDeserialization
Visual C++
public ref class Synonyms sealed : public SerializableDatabaseObjectCollection<Synonym^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Synonym >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( Synonym >)>)
RedGate.SQLCompare.Engine..::.Synonyms

See Also

Synonyms Members
RedGate.SQLCompare.Engine Namespace


Synonyms Members

[image] [image]

SQL Data Compare API 12.0.40
Synonyms Members
Synonyms Class Methods Fields Properties Explicit Interface Implementations See Also

The Synonyms type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

Synonyms Class
RedGate.SQLCompare.Engine Namespace


Synonyms Methods

[image] [image]

SQL Data Compare API 12.0.40
Synonyms Methods
Synonyms Class See Also

The Synonyms type exposes the following methods.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

Synonyms Class
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
Synonyms..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
Synonyms Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

Synonyms Class
RedGate.SQLCompare.Engine Namespace


SynonymsChanges Class

[image]

SQL Data Compare API 12.0.40
SynonymsChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SynonymsChanges
C#
public sealed class SynonymsChanges
Visual C++
public ref class SynonymsChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.SynonymsChanges

See Also

SynonymsChanges Members
RedGate.SQLCompare.Engine Namespace


SynonymsChanges Members

[image] [image]

SQL Data Compare API 12.0.40
SynonymsChanges Members
SynonymsChanges Class Constructors Methods Properties See Also

The SynonymsChanges type exposes the following members.

Constructors

Name | Description
SynonymsChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
SynonymsToCreate |
SynonymsToDrop |
SynonymTargets |

See Also

SynonymsChanges Class
RedGate.SQLCompare.Engine Namespace


SynonymsChanges Constructor

[image]

SQL Data Compare API 12.0.40
SynonymsChanges Constructor
SynonymsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public SynonymsChanges(
    bool caseSensitive
)
Visual C++
public:
SynonymsChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

SynonymsChanges Class
RedGate.SQLCompare.Engine Namespace


SynonymsChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
SynonymsChanges Properties
SynonymsChanges Class See Also

The SynonymsChanges type exposes the following properties.

Properties

Name | Description
SynonymsToCreate |
SynonymsToDrop |
SynonymTargets |

See Also

SynonymsChanges Class
RedGate.SQLCompare.Engine Namespace


SynonymsToCreate Property

[image]

SQL Data Compare API 12.0.40
SynonymsChanges..::.SynonymsToCreate Property
SynonymsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SynonymsToCreate As Synonyms
C#
public Synonyms SynonymsToCreate { get; private set; }
Visual C++
public:
property Synonyms^ SynonymsToCreate {
    Synonyms^ get ();
    void set (Synonyms^ value);
}

See Also

SynonymsChanges Class
RedGate.SQLCompare.Engine Namespace


SynonymsToDrop Property

[image]

SQL Data Compare API 12.0.40
SynonymsChanges..::.SynonymsToDrop Property
SynonymsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SynonymsToDrop As Synonyms
C#
public Synonyms SynonymsToDrop { get; private set; }
Visual C++
public:
property Synonyms^ SynonymsToDrop {
    Synonyms^ get ();
    void set (Synonyms^ value);
}

See Also

SynonymsChanges Class
RedGate.SQLCompare.Engine Namespace


SynonymTargets Property

[image]

SQL Data Compare API 12.0.40
SynonymsChanges..::.SynonymTargets Property
SynonymsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SynonymTargets As Dictionary(Of Synonym, Synonym)
C#
public Dictionary<Synonym, Synonym> SynonymTargets { get; private set; }
Visual C++
public:
property Dictionary<Synonym^, Synonym^>^ SynonymTargets {
    Dictionary<Synonym^, Synonym^>^ get ();
    void set (Dictionary<Synonym^, Synonym^>^ value);
}

See Also

SynonymsChanges Class
RedGate.SQLCompare.Engine Namespace


Table Class

[image]

SQL Data Compare API 12.0.40
Table Class
Members See Also

A table.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class Table _
    Inherits ViewTableSuperClass _
    Implements IShouldWriteStorageSettings, IDatabaseObject, ITSqlObject, ICanExistenceCheck,  _
    ISqlComparable, IHasLastModifiedDate
C#
public class Table : ViewTableSuperClass, IShouldWriteStorageSettings,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, ISqlComparable, IHasLastModifiedDate
Visual C++
public ref class Table : public ViewTableSuperClass,
    IShouldWriteStorageSettings, IDatabaseObject, ITSqlObject, ICanExistenceCheck, ISqlComparable,
    IHasLastModifiedDate

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.SchemaObjectWithAuthorization
RedGate.SQLCompare.Engine..::.ViewTableSuperClass
RedGate.SQLCompare.Engine..::.Table
RedGate.SQLCompare.Engine..::.FileTable

See Also

Table Members
RedGate.SQLCompare.Engine Namespace


Table Members

[image] [image]

SQL Data Compare API 12.0.40
Table Members
Table Class Methods Fields Properties Explicit Interface Implementations See Also

The Table type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLockEscalationSql |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Fields

Name | Description
m_Fields | Fields. (Inherited from ViewTableSuperClass.)
m_Indexes | Indexes. (Inherited from ViewTableSuperClass.)
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AlterAuthorizationClassType | (Inherited from SchemaObjectWithAuthorization.)
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
CatalogUsedForFullTextIndex | The full-text catalog used for the full-text index defined on the table or view (Inherited from ViewTableSuperClass.)
ChangeTracking | Whether change tracking is enabled for this table. This is a SQL Server 2008 feature.
ChangeTrackingScriptSource | The script source for any ALTER TABLE CHANGE_TRACKING statement.
CheckConstraints | The table's check constraints.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
DataCompressionPartitions | The partitions on which the table compression is set. This is a SQL Server 2008 feature.
DataCompressionPartitionsInternal | The partitions on which the table compression is set. This is a SQL Server 2008 feature. The internal version gives you direct access to the list that is stored. If there is no important information in the list it is not stored!
Durability |
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
Fields | The fields belonging to the table or view. (Inherited from ViewTableSuperClass.)
FileGroup | The filegroup on which the table is defined.
FilestreamFileGroup | The filegroup on which the filestreams of the table are to be stored.
ForeignKeys | The table's foreign keys.
FullTextCatalogNameFromSerialization | (Inherited from ViewTableSuperClass.)
FullTextChangeTracking | The change tracking setting for the full text index. (Inherited from ViewTableSuperClass.)
FullTextSearchPropertyList | The search property list attached the full-text index (if both exist) (Inherited from ViewTableSuperClass.)
FullTextSPLNameFromSerialization | Name (Inherited from ViewTableSuperClass.)
FullTextStoplist | The user-defined stoplist for the full text index on the table or view. (Inherited from ViewTableSuperClass.)
FullTextStoplistNameFromSerialization | (Inherited from ViewTableSuperClass.)
FullTextStoplistType | The stoplist type used for the full text index on the table or view. (Inherited from ViewTableSuperClass.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
HasFullTextIndex | True if the table or view has a full-text index defined on it (Inherited from ViewTableSuperClass.)
Indexes | The indexes defined on the table or view. (Inherited from ViewTableSuperClass.)
IsColumnstoreIndexed | Returns true iff the table has a columnstore index defined on it. (Inherited from ViewTableSuperClass.)
IsMemoryOptimized |
IsPartitioned | Indicates whether the table is partitioned. This is a SQL Server 2005 feature.
KeyIndexForFullTextIndex | The key index for the full-text index on the table or view. (Inherited from ViewTableSuperClass.)
LastModified | The time of the last change to this table's schema.
LockEscalation |
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Table (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
PartitionedField | Indicates the field over which the table is partitioned. This is a SQL Server 2005 feature.
PartitionScheme | The partition scheme for this table. This is a SQL Server 2005 feature.
Permissions | (Inherited from SchemaObjectWithAuthorization.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
RemoteDataArchiveState |
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSourceForFullTextTable | The location of the creation script for the fulltext table statement for this table or view if the database source is set to scripts folder. (Inherited from ViewTableSuperClass.)
ScriptSources | (Overrides ViewTableSuperClass ..::. ScriptSources.)
ShouldWriteFileGroupOrPartitionScheme |
TextFileGroup | The filegroup on which the text in the table is defined.
Triggers | The triggers defined on the table or view. (Inherited from ViewTableSuperClass.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

Table Class
RedGate.SQLCompare.Engine Namespace


Table Methods

[image] [image]

SQL Data Compare API 12.0.40
Table Methods
Table Class See Also

The Table type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLockEscalationSql |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

Table Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
Table..::.ISqlComparable..::.CompareWith Method
Table Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    obj As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable obj,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ obj,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

obj
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

Table Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
Table..::.Equals Method
Table Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the table with a specified table. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

Table Class
Table Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
Table..::.Equals Method (IDatabaseObject, Options)
Table Class See Also

Compares the table with a specified table.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The table to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the tables are identical; otherwise false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

Table Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


GetLockEscalationSql Method

[image]

SQL Data Compare API 12.0.40
Table..::.GetLockEscalationSql Method
Table Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLockEscalationSql ( _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As String
C#
public string GetLockEscalationSql(
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
String^ GetLockEscalationSql(
    Options options,
    IFeatureChecker^ targetFeatures
)

Parameters

options
Type: RedGate.SQLCompare.Engine..::.Options
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

See Also

Table Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
Table..::.ScriptObject Method
Table Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

Table Class
RedGate.SQLCompare.Engine Namespace


Table Properties

[image] [image]

SQL Data Compare API 12.0.40
Table Properties
Table Class See Also

The Table type exposes the following properties.

Properties

Name | Description
AlterAuthorizationClassType | (Inherited from SchemaObjectWithAuthorization.)
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
CatalogUsedForFullTextIndex | The full-text catalog used for the full-text index defined on the table or view (Inherited from ViewTableSuperClass.)
ChangeTracking | Whether change tracking is enabled for this table. This is a SQL Server 2008 feature.
ChangeTrackingScriptSource | The script source for any ALTER TABLE CHANGE_TRACKING statement.
CheckConstraints | The table's check constraints.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
DataCompressionPartitions | The partitions on which the table compression is set. This is a SQL Server 2008 feature.
DataCompressionPartitionsInternal | The partitions on which the table compression is set. This is a SQL Server 2008 feature. The internal version gives you direct access to the list that is stored. If there is no important information in the list it is not stored!
Durability |
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
Fields | The fields belonging to the table or view. (Inherited from ViewTableSuperClass.)
FileGroup | The filegroup on which the table is defined.
FilestreamFileGroup | The filegroup on which the filestreams of the table are to be stored.
ForeignKeys | The table's foreign keys.
FullTextCatalogNameFromSerialization | (Inherited from ViewTableSuperClass.)
FullTextChangeTracking | The change tracking setting for the full text index. (Inherited from ViewTableSuperClass.)
FullTextSearchPropertyList | The search property list attached the full-text index (if both exist) (Inherited from ViewTableSuperClass.)
FullTextSPLNameFromSerialization | Name (Inherited from ViewTableSuperClass.)
FullTextStoplist | The user-defined stoplist for the full text index on the table or view. (Inherited from ViewTableSuperClass.)
FullTextStoplistNameFromSerialization | (Inherited from ViewTableSuperClass.)
FullTextStoplistType | The stoplist type used for the full text index on the table or view. (Inherited from ViewTableSuperClass.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
HasFullTextIndex | True if the table or view has a full-text index defined on it (Inherited from ViewTableSuperClass.)
Indexes | The indexes defined on the table or view. (Inherited from ViewTableSuperClass.)
IsColumnstoreIndexed | Returns true iff the table has a columnstore index defined on it. (Inherited from ViewTableSuperClass.)
IsMemoryOptimized |
IsPartitioned | Indicates whether the table is partitioned. This is a SQL Server 2005 feature.
KeyIndexForFullTextIndex | The key index for the full-text index on the table or view. (Inherited from ViewTableSuperClass.)
LastModified | The time of the last change to this table's schema.
LockEscalation |
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Table (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
PartitionedField | Indicates the field over which the table is partitioned. This is a SQL Server 2005 feature.
PartitionScheme | The partition scheme for this table. This is a SQL Server 2005 feature.
Permissions | (Inherited from SchemaObjectWithAuthorization.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
RemoteDataArchiveState |
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSourceForFullTextTable | The location of the creation script for the fulltext table statement for this table or view if the database source is set to scripts folder. (Inherited from ViewTableSuperClass.)
ScriptSources | (Overrides ViewTableSuperClass ..::. ScriptSources.)
ShouldWriteFileGroupOrPartitionScheme |
TextFileGroup | The filegroup on which the text in the table is defined.
Triggers | The triggers defined on the table or view. (Inherited from ViewTableSuperClass.)

See Also

Table Class
RedGate.SQLCompare.Engine Namespace


ChangeTracking Property

[image]

SQL Data Compare API 12.0.40
Table..::.ChangeTracking Property
Table Class See Also

Whether change tracking is enabled for this table. This is a SQL Server 2008 feature.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ChangeTracking As Table..::.TableChangeTracking
C#
public Table..::.TableChangeTracking ChangeTracking { get; internal set; }
Visual C++
public:
property Table..::.TableChangeTracking ChangeTracking {
    Table..::.TableChangeTracking get ();
    void set (Table..::.TableChangeTracking value);
}

See Also

Table Class
RedGate.SQLCompare.Engine Namespace


ChangeTrackingScriptSource Property

[image]

SQL Data Compare API 12.0.40
Table..::.ChangeTrackingScriptSource Property
Table Class See Also

The script source for any ALTER TABLE CHANGE_TRACKING statement.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ChangeTrackingScriptSource As ScriptSource
C#
public ScriptSource ChangeTrackingScriptSource { get; internal set; }
Visual C++
public:
property ScriptSource^ ChangeTrackingScriptSource {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

Table Class
RedGate.SQLCompare.Engine Namespace


CheckConstraints Property

[image]

SQL Data Compare API 12.0.40
Table..::.CheckConstraints Property
Table Class See Also

The table's check constraints.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CheckConstraints As CheckConstraints
C#
public virtual CheckConstraints CheckConstraints { get; internal set; }
Visual C++
public:
virtual property CheckConstraints^ CheckConstraints {
    CheckConstraints^ get ();
    void set (CheckConstraints^ value);
}

See Also

Table Class
RedGate.SQLCompare.Engine Namespace


DataCompressionPartitions Property

[image]

SQL Data Compare API 12.0.40
Table..::.DataCompressionPartitions Property
Table Class See Also

The partitions on which the table compression is set. This is a SQL Server 2008 feature.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataCompressionPartitions As IDictionary(Of Integer, DataCompression)
C#
public IDictionary<int, DataCompression> DataCompressionPartitions { get; }
Visual C++
public:
virtual property IDictionary<int, DataCompression>^ DataCompressionPartitions {
    IDictionary<int, DataCompression>^ get () sealed;
}

See Also

Table Class
RedGate.SQLCompare.Engine Namespace


DataCompressionPartitionsInternal Property

[image]

SQL Data Compare API 12.0.40
Table..::.DataCompressionPartitionsInternal Property
Table Class See Also

The partitions on which the table compression is set. This is a SQL Server 2008 feature. The internal version gives you direct access to the list that is stored. If there is no important information in the list it is not stored!

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DataCompressionPartitionsInternal As DataCompressionPartitions
C#
public DataCompressionPartitions DataCompressionPartitionsInternal { get; set; }
Visual C++
public:
virtual property DataCompressionPartitions^ DataCompressionPartitionsInternal {
    DataCompressionPartitions^ get () sealed;
    void set (DataCompressionPartitions^ value) sealed;
}

See Also

Table Class
RedGate.SQLCompare.Engine Namespace


Durability Property

[image]

SQL Data Compare API 12.0.40
Table..::.Durability Property
Table Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Durability As DurabilityTypes
C#
public DurabilityTypes Durability { get; set; }
Visual C++
public:
property DurabilityTypes Durability {
    DurabilityTypes get ();
    void set (DurabilityTypes value);
}

See Also

Table Class
RedGate.SQLCompare.Engine Namespace


FileGroup Property

[image]

SQL Data Compare API 12.0.40
Table..::.FileGroup Property
Table Class See Also

The filegroup on which the table is defined.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FileGroup As String
C#
public string FileGroup { get; internal set; }
Visual C++
public:
property String^ FileGroup {
    String^ get ();
    void set (String^ value);
}

See Also

Table Class
RedGate.SQLCompare.Engine Namespace


FilestreamFileGroup Property

[image]

SQL Data Compare API 12.0.40
Table..::.FilestreamFileGroup Property
Table Class See Also

The filegroup on which the filestreams of the table are to be stored.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FilestreamFileGroup As String
C#
public string FilestreamFileGroup { get; internal set; }
Visual C++
public:
property String^ FilestreamFileGroup {
    String^ get ();
    void set (String^ value);
}

See Also

Table Class
RedGate.SQLCompare.Engine Namespace


ForeignKeys Property

[image]

SQL Data Compare API 12.0.40
Table..::.ForeignKeys Property
Table Class See Also

The table's foreign keys.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ForeignKeys As ForeignKeys
C#
public virtual ForeignKeys ForeignKeys { get; internal set; }
Visual C++
public:
virtual property ForeignKeys^ ForeignKeys {
    ForeignKeys^ get ();
    void set (ForeignKeys^ value);
}

See Also

Table Class
RedGate.SQLCompare.Engine Namespace


IsMemoryOptimized Property

[image]

SQL Data Compare API 12.0.40
Table..::.IsMemoryOptimized Property
Table Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsMemoryOptimized As Boolean
C#
public bool IsMemoryOptimized { get; set; }
Visual C++
public:
property bool IsMemoryOptimized {
    bool get ();
    void set (bool value);
}

See Also

Table Class
RedGate.SQLCompare.Engine Namespace


IsPartitioned Property

[image]

SQL Data Compare API 12.0.40
Table..::.IsPartitioned Property
Table Class See Also

Indicates whether the table is partitioned. This is a SQL Server 2005 feature.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsPartitioned As Boolean
C#
public bool IsPartitioned { get; internal set; }
Visual C++
public:
virtual property bool IsPartitioned {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

Table Class
RedGate.SQLCompare.Engine Namespace


LastModified Property

[image]

SQL Data Compare API 12.0.40
Table..::.LastModified Property
Table Class See Also

The time of the last change to this table's schema.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LastModified As DateTime
C#
public DateTime LastModified { get; set; }
Visual C++
public:
virtual property DateTime LastModified {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}

Implements

IHasLastModifiedDate..::.LastModified

See Also

Table Class
RedGate.SQLCompare.Engine Namespace


LockEscalation Property

[image]

SQL Data Compare API 12.0.40
Table..::.LockEscalation Property
Table Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LockEscalation As LockEscalationType
C#
public LockEscalationType LockEscalation { get; internal set; }
Visual C++
public:
property LockEscalationType LockEscalation {
    LockEscalationType get ();
    void set (LockEscalationType value);
}

See Also

Table Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
Table..::.ObjectType Property
Table Class See Also

Returns ObjectType.Table

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()
ITSqlObjectObjectType()()()

See Also

Table Class
RedGate.SQLCompare.Engine Namespace


PartitionedField Property

[image]

SQL Data Compare API 12.0.40
Table..::.PartitionedField Property
Table Class See Also

Indicates the field over which the table is partitioned. This is a SQL Server 2005 feature.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PartitionedField As IField
C#
public IField PartitionedField { get; internal set; }
Visual C++
public:
property IField^ PartitionedField {
    IField^ get ();
    void set (IField^ value);
}

See Also

Table Class
RedGate.SQLCompare.Engine Namespace


PartitionScheme Property

[image]

SQL Data Compare API 12.0.40
Table..::.PartitionScheme Property
Table Class See Also

The partition scheme for this table. This is a SQL Server 2005 feature.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PartitionScheme As PartitionScheme
C#
public PartitionScheme PartitionScheme { get; internal set; }
Visual C++
public:
property PartitionScheme^ PartitionScheme {
    PartitionScheme^ get ();
    void set (PartitionScheme^ value);
}

See Also

Table Class
RedGate.SQLCompare.Engine Namespace


RemoteDataArchiveState Property

[image]

SQL Data Compare API 12.0.40
Table..::.RemoteDataArchiveState Property
Table Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RemoteDataArchiveState As RemoteDataArchiveState
C#
public RemoteDataArchiveState RemoteDataArchiveState { get; internal set; }
Visual C++
public:
property RemoteDataArchiveState RemoteDataArchiveState {
    RemoteDataArchiveState get ();
    void set (RemoteDataArchiveState value);
}

See Also

Table Class
RedGate.SQLCompare.Engine Namespace


ScriptSources Property

[image]

SQL Data Compare API 12.0.40
Table..::.ScriptSources Property
Table Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ScriptSources As IEnumerable(Of ScriptSource)
C#
public override IEnumerable<ScriptSource> ScriptSources { get; }
Visual C++
public:
virtual property IEnumerable<ScriptSource^>^ ScriptSources {
    IEnumerable<ScriptSource^>^ get () override;
}

See Also

Table Class
RedGate.SQLCompare.Engine Namespace


ShouldWriteFileGroupOrPartitionScheme Property

[image]

SQL Data Compare API 12.0.40
Table..::.ShouldWriteFileGroupOrPartitionScheme Property
Table Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ShouldWriteFileGroupOrPartitionScheme As Boolean
C#
public bool ShouldWriteFileGroupOrPartitionScheme { get; }
Visual C++
public:
virtual property bool ShouldWriteFileGroupOrPartitionScheme {
    bool get () sealed;
}

Implements

IShouldWriteStorageSettings..::.ShouldWriteFileGroupOrPartitionScheme

See Also

Table Class
RedGate.SQLCompare.Engine Namespace


TextFileGroup Property

[image]

SQL Data Compare API 12.0.40
Table..::.TextFileGroup Property
Table Class See Also

The filegroup on which the text in the table is defined.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TextFileGroup As String
C#
public string TextFileGroup { get; internal set; }
Visual C++
public:
property String^ TextFileGroup {
    String^ get ();
    void set (String^ value);
}

See Also

Table Class
RedGate.SQLCompare.Engine Namespace


Table.TableChangeTracking Enumeration

[image]

SQL Data Compare API 12.0.40
Table..::.TableChangeTracking Enumeration
Table Class See Also

Table change tracking option set. This has been introduced in SQL Server 2008.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration TableChangeTracking
C#
public enum TableChangeTracking
Visual C++
public enum class TableChangeTracking

Members

Member name | Description
Disabled | Change tracking is disabled.
Enabled | Change tracking is enabled.
EnabledWithTrackColumnsUpdated | Change tracking is enabled with information on which columns were updated.

See Also

RedGate.SQLCompare.Engine Namespace


TableChange Class

[image]

SQL Data Compare API 12.0.40
TableChange Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TableChange
C#
public sealed class TableChange
Visual C++
public ref class TableChange sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.TableChange

See Also

TableChange Members
RedGate.SQLCompare.Engine Namespace


TableChange Members

[image] [image]

SQL Data Compare API 12.0.40
TableChange Members
TableChange Class Methods See Also

The TableChange type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

See Also

TableChange Class
RedGate.SQLCompare.Engine Namespace


TableChange Methods

[image] [image]

SQL Data Compare API 12.0.40
TableChange Methods
TableChange Class See Also

The TableChange type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

See Also

TableChange Class
RedGate.SQLCompare.Engine Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
TableChange..::.ToString Method
TableChange Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

See Also

TableChange Class
RedGate.SQLCompare.Engine Namespace


TableChangeTrackingChangesCalculator Class

[image]

SQL Data Compare API 12.0.40
TableChangeTrackingChangesCalculator Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class TableChangeTrackingChangesCalculator
C#
public class TableChangeTrackingChangesCalculator
Visual C++
public ref class TableChangeTrackingChangesCalculator

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.TableChangeTrackingChangesCalculator

See Also

TableChangeTrackingChangesCalculator Members
RedGate.SQLCompare.Engine Namespace


TableChangeTrackingChangesCalculator Members

[image] [image]

SQL Data Compare API 12.0.40
TableChangeTrackingChangesCalculator Members
TableChangeTrackingChangesCalculator Class Constructors Methods See Also

The TableChangeTrackingChangesCalculator type exposes the following members.

Constructors

Name | Description
TableChangeTrackingChangesCalculator |

Methods

Name | Description
CalculateWorkTableChangeTracking |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TableChangeTrackingChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


TableChangeTrackingChangesCalculator Constructor

[image]

SQL Data Compare API 12.0.40
TableChangeTrackingChangesCalculator Constructor
TableChangeTrackingChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    warnings As Messages, _
    changeTrackingsChanges As ChangeTrackingsChanges _
)
C#
public TableChangeTrackingChangesCalculator(
    Messages warnings,
    ChangeTrackingsChanges changeTrackingsChanges
)
Visual C++
public:
TableChangeTrackingChangesCalculator(
    Messages^ warnings,
    ChangeTrackingsChanges^ changeTrackingsChanges
)

Parameters

warnings
Type: RedGate.SQLCompare.Engine..::.Messages
changeTrackingsChanges
Type: RedGate.SQLCompare.Engine..::.ChangeTrackingsChanges

See Also

TableChangeTrackingChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


TableChangeTrackingChangesCalculator Methods

[image] [image]

SQL Data Compare API 12.0.40
TableChangeTrackingChangesCalculator Methods
TableChangeTrackingChangesCalculator Class See Also

The TableChangeTrackingChangesCalculator type exposes the following methods.

Methods

Name | Description
CalculateWorkTableChangeTracking |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TableChangeTrackingChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


CalculateWorkTableChangeTracking Method

[image]

SQL Data Compare API 12.0.40
TableChangeTrackingChangesCalculator..::.CalculateWorkTableChangeTracking Method
TableChangeTrackingChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculateWorkTableChangeTracking ( _
    table As Table, _
    targetTable As Table, _
    targetDatabase As IDatabase, _
    options As Options, _
    anyIndexesBeingDroppedForPrimaryKeys As Boolean _
)
C#
public void CalculateWorkTableChangeTracking(
    Table table,
    Table targetTable,
    IDatabase targetDatabase,
    Options options,
    bool anyIndexesBeingDroppedForPrimaryKeys
)
Visual C++
public:
void CalculateWorkTableChangeTracking(
    Table^ table,
    Table^ targetTable,
    IDatabase^ targetDatabase,
    Options options,
    bool anyIndexesBeingDroppedForPrimaryKeys
)

Parameters

table
Type: RedGate.SQLCompare.Engine..::.Table
targetTable
Type: RedGate.SQLCompare.Engine..::.Table
targetDatabase
Type: RedGate.SQLCompare.Engine..::.IDatabase
options
Type: RedGate.SQLCompare.Engine..::.Options
anyIndexesBeingDroppedForPrimaryKeys
Type: Boolean

See Also

TableChangeTrackingChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


TableFields Class

[image]

SQL Data Compare API 12.0.40
TableFields Class
Members See Also

A collection of Fields belonging to several different tables

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TableFields _
    Inherits KeyedCollection(Of IField)
C#
public sealed class TableFields : KeyedCollection<IField>
Visual C++
public ref class TableFields sealed : public KeyedCollection<IField^>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( IField >)>)
RedGate.SQLCompare.Engine..::.TableFields

See Also

TableFields Members
RedGate.SQLCompare.Engine Namespace


TableFields Members

[image] [image]

SQL Data Compare API 12.0.40
TableFields Members
TableFields Class Constructors Methods Fields Properties Explicit Interface Implementations See Also

The TableFields type exposes the following members.

Constructors

Name | Description
TableFields |

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

TableFields Class
RedGate.SQLCompare.Engine Namespace


TableFields Constructor

[image]

SQL Data Compare API 12.0.40
TableFields Constructor
TableFields Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public TableFields(
    bool caseSensitive
)
Visual C++
public:
TableFields(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

TableFields Class
RedGate.SQLCompare.Engine Namespace


TablePairReference Structure

[image]

SQL Data Compare API 12.0.40
TablePairReference Structure
Members See Also

A reference to a table pair

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Structure TablePairReference
C#
public struct TablePairReference
Visual C++
public value class TablePairReference

See Also

TablePairReference Members
RedGate.SQLCompare.Engine Namespace


TablePairReference Members

[image] [image]

SQL Data Compare API 12.0.40
TablePairReference Members
TablePairReference Structure Constructors Methods Fields See Also

The TablePairReference type exposes the following members.

Constructors

Name | Description
TablePairReference | Creates a new table pair reference

Methods

Name | Description
Equals | (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

Name | Description
Table1 | The qualified name of the first table
Table2 | The qualified name of the second table

See Also

TablePairReference Structure
RedGate.SQLCompare.Engine Namespace


TablePairReference Constructor

[image]

SQL Data Compare API 12.0.40
TablePairReference Constructor
TablePairReference Structure See Also

Creates a new table pair reference

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    one As String, _
    two As String _
)
C#
public TablePairReference(
    string one,
    string two
)
Visual C++
public:
TablePairReference(
    String^ one,
    String^ two
)

Parameters

one
Type: String
the name of the first table
two
Type: String
the name of the second table

See Also

TablePairReference Structure
RedGate.SQLCompare.Engine Namespace


TablePairReference Fields

[image] [image]

SQL Data Compare API 12.0.40
TablePairReference Fields
TablePairReference Structure See Also

The TablePairReference type exposes the following fields.

Fields

Name | Description
Table1 | The qualified name of the first table
Table2 | The qualified name of the second table

See Also

TablePairReference Structure
RedGate.SQLCompare.Engine Namespace


Table1 Field

[image]

SQL Data Compare API 12.0.40
TablePairReference..::.Table1 Field
TablePairReference Structure See Also

The qualified name of the first table

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Table1 As String
C#
public string Table1
Visual C++
public:
String^ Table1

See Also

TablePairReference Structure
RedGate.SQLCompare.Engine Namespace


Table2 Field

[image]

SQL Data Compare API 12.0.40
TablePairReference..::.Table2 Field
TablePairReference Structure See Also

The qualified name of the second table

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Table2 As String
C#
public string Table2
Visual C++
public:
String^ Table2

See Also

TablePairReference Structure
RedGate.SQLCompare.Engine Namespace


TablePairReference Methods

[image] [image]

SQL Data Compare API 12.0.40
TablePairReference Methods
TablePairReference Structure See Also

The TablePairReference type exposes the following methods.

Methods

Name | Description
Equals | (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

TablePairReference Structure
RedGate.SQLCompare.Engine Namespace


Equals Method

[image]

SQL Data Compare API 12.0.40
TablePairReference..::.Equals Method
TablePairReference Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object

See Also

TablePairReference Structure
RedGate.SQLCompare.Engine Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
TablePairReference..::.GetHashCode Method
TablePairReference Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

See Also

TablePairReference Structure
RedGate.SQLCompare.Engine Namespace


Tables Class

[image]

SQL Data Compare API 12.0.40
Tables Class
Members See Also

A collection of tables.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Tables _
    Inherits DatabaseObjectCollection(Of Table)
C#
public sealed class Tables : DatabaseObjectCollection<Table>
Visual C++
public ref class Tables sealed : public DatabaseObjectCollection<Table^>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( Table >)>)
RedGate.SQLCompare.Engine..::.DatabaseObjectCollection <(Of <( Table >)>)
RedGate.SQLCompare.Engine..::.Tables

See Also

Tables Members
RedGate.SQLCompare.Engine Namespace


Tables Members

[image] [image]

SQL Data Compare API 12.0.40
Tables Members
Tables Class Methods Fields Properties Explicit Interface Implementations See Also

The Tables type exposes the following members.

Methods

Name | Description
Add | (Overrides DatabaseObjectCollection <(Of <( Table >)>)..::. Add(T).)
AsReadOnly | (Inherited from DatabaseObjectCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from DatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | Get a nicely-formatted object name to display to the user if the Add(T) method throws an argument exception (Inherited from DatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

Tables Class
RedGate.SQLCompare.Engine Namespace


Tables Methods

[image] [image]

SQL Data Compare API 12.0.40
Tables Methods
Tables Class See Also

The Tables type exposes the following methods.

Methods

Name | Description
Add | (Overrides DatabaseObjectCollection <(Of <( Table >)>)..::. Add(T).)
AsReadOnly | (Inherited from DatabaseObjectCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from DatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | Get a nicely-formatted object name to display to the user if the Add(T) method throws an argument exception (Inherited from DatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

Tables Class
RedGate.SQLCompare.Engine Namespace


Add Method

[image]

SQL Data Compare API 12.0.40
Tables..::.Add Method
Tables Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Add ( _
    value As Table _
)
C#
public override void Add(
    Table value
)
Visual C++
public:
virtual void Add(
    Table^ value
) override

Parameters

value
Type: RedGate.SQLCompare.Engine..::.Table

Implements

IKeyedCollectionAdd(UTP)

See Also

Tables Class
RedGate.SQLCompare.Engine Namespace


TablesChanges Class

[image]

SQL Data Compare API 12.0.40
TablesChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TablesChanges
C#
public sealed class TablesChanges
Visual C++
public ref class TablesChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.TablesChanges

See Also

TablesChanges Members
RedGate.SQLCompare.Engine Namespace


TablesChanges Members

[image] [image]

SQL Data Compare API 12.0.40
TablesChanges Members
TablesChanges Class Constructors Methods Properties See Also

The TablesChanges type exposes the following members.

Constructors

Name | Description
TablesChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectsToCreate |
GetObjectsToDrop |
GetObjectsToRebuild |
GetTargets |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ModifiedFieldTargets |
TablesToCreate |
TablesToDoubleRebuild |
TablesToDrop |
TablesToModify |
TablesToRebuild |
TablesToRename |
TableTargets |

See Also

TablesChanges Class
RedGate.SQLCompare.Engine Namespace


TablesChanges Constructor

[image]

SQL Data Compare API 12.0.40
TablesChanges Constructor
TablesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public TablesChanges(
    bool caseSensitive
)
Visual C++
public:
TablesChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

TablesChanges Class
RedGate.SQLCompare.Engine Namespace


TablesChanges Methods

[image] [image]

SQL Data Compare API 12.0.40
TablesChanges Methods
TablesChanges Class See Also

The TablesChanges type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectsToCreate |
GetObjectsToDrop |
GetObjectsToRebuild |
GetTargets |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TablesChanges Class
RedGate.SQLCompare.Engine Namespace


GetObjectsToCreate Method

[image]

SQL Data Compare API 12.0.40
TablesChanges..::.GetObjectsToCreate Method
TablesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetObjectsToCreate As KeyedCollection(Of Table)
C#
public KeyedCollection<Table> GetObjectsToCreate()
Visual C++
public:
virtual KeyedCollection<Table^>^ GetObjectsToCreate() sealed

See Also

TablesChanges Class
RedGate.SQLCompare.Engine Namespace


GetObjectsToDrop Method

[image]

SQL Data Compare API 12.0.40
TablesChanges..::.GetObjectsToDrop Method
TablesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetObjectsToDrop As KeyedCollection(Of Table)
C#
public KeyedCollection<Table> GetObjectsToDrop()
Visual C++
public:
virtual KeyedCollection<Table^>^ GetObjectsToDrop() sealed

See Also

TablesChanges Class
RedGate.SQLCompare.Engine Namespace


GetObjectsToRebuild Method

[image]

SQL Data Compare API 12.0.40
TablesChanges..::.GetObjectsToRebuild Method
TablesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetObjectsToRebuild As KeyedCollection(Of Table)
C#
public KeyedCollection<Table> GetObjectsToRebuild()
Visual C++
public:
virtual KeyedCollection<Table^>^ GetObjectsToRebuild() sealed

See Also

TablesChanges Class
RedGate.SQLCompare.Engine Namespace


GetTargets Method

[image]

SQL Data Compare API 12.0.40
TablesChanges..::.GetTargets Method
TablesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetTargets As Dictionary(Of Table, Table)
C#
public Dictionary<Table, Table> GetTargets()
Visual C++
public:
virtual Dictionary<Table^, Table^>^ GetTargets() sealed

See Also

TablesChanges Class
RedGate.SQLCompare.Engine Namespace


TablesChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
TablesChanges Properties
TablesChanges Class See Also

The TablesChanges type exposes the following properties.

Properties

Name | Description
ModifiedFieldTargets |
TablesToCreate |
TablesToDoubleRebuild |
TablesToDrop |
TablesToModify |
TablesToRebuild |
TablesToRename |
TableTargets |

See Also

TablesChanges Class
RedGate.SQLCompare.Engine Namespace


ModifiedFieldTargets Property

[image]

SQL Data Compare API 12.0.40
TablesChanges..::.ModifiedFieldTargets Property
TablesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ModifiedFieldTargets As Dictionary(Of IField, IField)
C#
public Dictionary<IField, IField> ModifiedFieldTargets { get; private set; }
Visual C++
public:
property Dictionary<IField^, IField^>^ ModifiedFieldTargets {
    Dictionary<IField^, IField^>^ get ();
    void set (Dictionary<IField^, IField^>^ value);
}

See Also

TablesChanges Class
RedGate.SQLCompare.Engine Namespace


TablesToCreate Property

[image]

SQL Data Compare API 12.0.40
TablesChanges..::.TablesToCreate Property
TablesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TablesToCreate As Tables
C#
public Tables TablesToCreate { get; private set; }
Visual C++
public:
property Tables^ TablesToCreate {
    Tables^ get ();
    void set (Tables^ value);
}

See Also

TablesChanges Class
RedGate.SQLCompare.Engine Namespace


TablesToDoubleRebuild Property

[image]

SQL Data Compare API 12.0.40
TablesChanges..::.TablesToDoubleRebuild Property
TablesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TablesToDoubleRebuild As Tables
C#
public Tables TablesToDoubleRebuild { get; private set; }
Visual C++
public:
property Tables^ TablesToDoubleRebuild {
    Tables^ get ();
    void set (Tables^ value);
}

See Also

TablesChanges Class
RedGate.SQLCompare.Engine Namespace


TablesToDrop Property

[image]

SQL Data Compare API 12.0.40
TablesChanges..::.TablesToDrop Property
TablesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TablesToDrop As Tables
C#
public Tables TablesToDrop { get; private set; }
Visual C++
public:
property Tables^ TablesToDrop {
    Tables^ get ();
    void set (Tables^ value);
}

See Also

TablesChanges Class
RedGate.SQLCompare.Engine Namespace


TablesToModify Property

[image]

SQL Data Compare API 12.0.40
TablesChanges..::.TablesToModify Property
TablesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TablesToModify As List(Of TableChange)
C#
public List<TableChange> TablesToModify { get; private set; }
Visual C++
public:
property List<TableChange^>^ TablesToModify {
    List<TableChange^>^ get ();
    void set (List<TableChange^>^ value);
}

See Also

TablesChanges Class
RedGate.SQLCompare.Engine Namespace


TablesToRebuild Property

[image]

SQL Data Compare API 12.0.40
TablesChanges..::.TablesToRebuild Property
TablesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TablesToRebuild As Tables
C#
public Tables TablesToRebuild { get; private set; }
Visual C++
public:
property Tables^ TablesToRebuild {
    Tables^ get ();
    void set (Tables^ value);
}

See Also

TablesChanges Class
RedGate.SQLCompare.Engine Namespace


TablesToRename Property

[image]

SQL Data Compare API 12.0.40
TablesChanges..::.TablesToRename Property
TablesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TablesToRename As Tables
C#
public Tables TablesToRename { get; private set; }
Visual C++
public:
property Tables^ TablesToRename {
    Tables^ get ();
    void set (Tables^ value);
}

See Also

TablesChanges Class
RedGate.SQLCompare.Engine Namespace


TableTargets Property

[image]

SQL Data Compare API 12.0.40
TablesChanges..::.TableTargets Property
TablesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TableTargets As Dictionary(Of Table, Table)
C#
public Dictionary<Table, Table> TableTargets { get; private set; }
Visual C++
public:
property Dictionary<Table^, Table^>^ TableTargets {
    Dictionary<Table^, Table^>^ get ();
    void set (Dictionary<Table^, Table^>^ value);
}

See Also

TablesChanges Class
RedGate.SQLCompare.Engine Namespace


TesselationScheme Enumeration

[image]

SQL Data Compare API 12.0.40
TesselationScheme Enumeration
See Also

The tesselation scheme for the spatial index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration TesselationScheme
C#
public enum TesselationScheme
Visual C++
public enum class TesselationScheme

Members

Member name | Description
GeometryGrid | GEOMETRY_GRID
GeographyGrid | GEOGRAPHY_GRID
GeometryAutoGrid | GEOMETRY_AUTO_GRID
GeographyAutoGrid | GEOGRAPHY_AUTO_GRID

See Also

RedGate.SQLCompare.Engine Namespace


Trigger Class

[image]

SQL Data Compare API 12.0.40
Trigger Class
Members See Also

A trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Trigger _
    Implements IDatabaseObject, ITSqlObject, ICanExistenceCheck, IExecuteAs,  _
    IEncryptedTextObject, ITextObject, ISessionSetObject, IHasScriptSource, ISqlComparable
C#
public sealed class Trigger : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck, IExecuteAs, IEncryptedTextObject, ITextObject,
    ISessionSetObject, IHasScriptSource, ISqlComparable
Visual C++
public ref class Trigger sealed : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck, IExecuteAs, IEncryptedTextObject, ITextObject,
    ISessionSetObject, IHasScriptSource, ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.Trigger

See Also

Trigger Members
RedGate.SQLCompare.Engine Namespace


Trigger Members

[image] [image]

SQL Data Compare API 12.0.40
Trigger Members
Trigger Class Methods Properties Explicit Interface Implementations See Also

The Trigger type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSql |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetSessionOptions |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
After | True if the trigger is an after trigger.
AnsiNullsOn | True if the trigger was created with ansi nulls on.
Assembly | The CLR assembly for the DML trigger, if it is a CLR DML trigger.
AssemblyClass | The CLR assembly class name for the DML trigger, if it is a CLR DML trigger.
AssemblyMethod | The CLR assembly method name for the DML trigger, if it is a CLR DML trigger.
CLRObject | True if the trigger is a CLR trigger.
Database | The database to which the trigger belongs.
Delete | True if the trigger is a delete trigger.
EnableDisableStatementSource |
Encrypted | True if the trigger definition is encrypted.
ExecuteAs | The user whose security context is to be used for the execution of the trigger. This is a SQL Server 2005 and 2008 feature.
ExecuteAsType | The EXECUTE AS clause used for the object.
FirstDeleteTrigger | True if the trigger is the first delete trigger.
FirstInsertTrigger | True if the trigger is the first insert trigger.
FirstUpdateTrigger | True if the trigger is the first update trigger.
FullyQualifiedName | The fully-qualified name of the trigger.
ID | Obsolete. The identifier of the trigger.
Insert | True if the trigger is an insert trigger.
InsteadOf | True if the trigger is an instead of trigger.
IsDisabled | True if the trigger is disabled.
LastDeleteTrigger | True if the trigger is the last delete trigger.
LastInsertTrigger | True if the trigger is the last insert trigger.
LastUpdateTrigger | True if the trigger is the last update trigger.
Name | The name of the trigger. DANGER WILL ROBINSON!! This is not escaped. Do you mean Trigger..::.QualifiedName?
NotForReplication | True if this trigger is NOT FOR REPLICATION.
ObjectType | Returns ObjectType.Trigger
Owner | The owner or the schema of the trigger.
Parent | The parent of the trigger.
QualifiedName | The qualified name of the object. Do you mean Trigger..::.Name?
QuotedIdentifierOn | True if the trigger was created with quoted identifiers on.
ScriptSource |
ScriptSourceDeleteOrder |
ScriptSourceInsertOrder |
ScriptSources |
ScriptSourceUpdateOrder |
SysobjectID | The identifier of the trigger.
Text | The text of the trigger.
Update | True if the trigger is an update trigger.

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |
IDatabaseObject..::.Equals |
IEncryptedTextObject..::.TextID |

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


Trigger Methods

[image] [image]

SQL Data Compare API 12.0.40
Trigger Methods
Trigger Class See Also

The Trigger type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSql |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetSessionOptions |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |
IDatabaseObject..::.Equals |

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
Trigger..::.ISqlComparable..::.CompareWith Method
Trigger Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    obj As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable obj,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ obj,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

obj
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
Trigger..::.Equals Method
Trigger Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(Trigger, Options) | Compares the trigger with a specified trigger.

See Also

Trigger Class
Trigger Members
RedGate.SQLCompare.Engine Namespace


Equals Method (Trigger, Options)

[image]

SQL Data Compare API 12.0.40
Trigger..::.Equals Method (Trigger, Options)
Trigger Class See Also

Compares the trigger with a specified trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    targetTrigger As Trigger, _
    options As Options _
) As Boolean
C#
public bool Equals(
    Trigger targetTrigger,
    Options options
)
Visual C++
public:
bool Equals(
    Trigger^ targetTrigger,
    Options options
)

Parameters

targetTrigger
Type: RedGate.SQLCompare.Engine..::.Trigger
The trigger to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the triggers are identical; otherwise, false.

See Also

Trigger Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


IDatabaseObject.Equals Method

[image]

SQL Data Compare API 12.0.40
Trigger..::.IDatabaseObject..::.Equals Method
Trigger Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean Implements IDatabaseObject.Equals
C#
bool IDatabaseObject.Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
private:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) sealed = IDatabaseObject::Equals

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


GetSql Method

[image]

SQL Data Compare API 12.0.40
Trigger..::.GetSql Method
Trigger Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSql ( _
    options As Options, _
    targetIsEncrypted As Boolean, _
    useAlter As Boolean, _
    targetFeatures As IFeatureChecker _
) As String
C#
public string GetSql(
    Options options,
    bool targetIsEncrypted,
    bool useAlter,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual String^ GetSql(
    Options options,
    bool targetIsEncrypted,
    bool useAlter,
    IFeatureChecker^ targetFeatures
) sealed

Parameters

options
Type: RedGate.SQLCompare.Engine..::.Options
targetIsEncrypted
Type: Boolean
useAlter
Type: Boolean
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Implements

IEncryptedTextObject..::.GetSql(Options, Boolean, Boolean, IFeatureChecker)

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


SetSessionOptions Method

[image]

SQL Data Compare API 12.0.40
Trigger..::.SetSessionOptions Method
Trigger Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetSessionOptions ( _
    ansiNulls As Boolean, _
    quotedIdentifier As Boolean _
)
C#
public void SetSessionOptions(
    bool ansiNulls,
    bool quotedIdentifier
)
Visual C++
public:
virtual void SetSessionOptions(
    bool ansiNulls,
    bool quotedIdentifier
) sealed

Parameters

ansiNulls
Type: Boolean
quotedIdentifier
Type: Boolean

Implements

ISessionSetObject..::.SetSessionOptions(Boolean, Boolean)

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


Trigger Properties

[image] [image]

SQL Data Compare API 12.0.40
Trigger Properties
Trigger Class See Also

The Trigger type exposes the following properties.

Properties

Name | Description
After | True if the trigger is an after trigger.
AnsiNullsOn | True if the trigger was created with ansi nulls on.
Assembly | The CLR assembly for the DML trigger, if it is a CLR DML trigger.
AssemblyClass | The CLR assembly class name for the DML trigger, if it is a CLR DML trigger.
AssemblyMethod | The CLR assembly method name for the DML trigger, if it is a CLR DML trigger.
CLRObject | True if the trigger is a CLR trigger.
Database | The database to which the trigger belongs.
Delete | True if the trigger is a delete trigger.
EnableDisableStatementSource |
Encrypted | True if the trigger definition is encrypted.
ExecuteAs | The user whose security context is to be used for the execution of the trigger. This is a SQL Server 2005 and 2008 feature.
ExecuteAsType | The EXECUTE AS clause used for the object.
FirstDeleteTrigger | True if the trigger is the first delete trigger.
FirstInsertTrigger | True if the trigger is the first insert trigger.
FirstUpdateTrigger | True if the trigger is the first update trigger.
FullyQualifiedName | The fully-qualified name of the trigger.
ID | Obsolete. The identifier of the trigger.
Insert | True if the trigger is an insert trigger.
InsteadOf | True if the trigger is an instead of trigger.
IsDisabled | True if the trigger is disabled.
LastDeleteTrigger | True if the trigger is the last delete trigger.
LastInsertTrigger | True if the trigger is the last insert trigger.
LastUpdateTrigger | True if the trigger is the last update trigger.
Name | The name of the trigger. DANGER WILL ROBINSON!! This is not escaped. Do you mean Trigger..::.QualifiedName?
NotForReplication | True if this trigger is NOT FOR REPLICATION.
ObjectType | Returns ObjectType.Trigger
Owner | The owner or the schema of the trigger.
Parent | The parent of the trigger.
QualifiedName | The qualified name of the object. Do you mean Trigger..::.Name?
QuotedIdentifierOn | True if the trigger was created with quoted identifiers on.
ScriptSource |
ScriptSourceDeleteOrder |
ScriptSourceInsertOrder |
ScriptSources |
ScriptSourceUpdateOrder |
SysobjectID | The identifier of the trigger.
Text | The text of the trigger.
Update | True if the trigger is an update trigger.

Explicit Interface Implementations

Name | Description
IEncryptedTextObject..::.TextID |

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


After Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.After Property
Trigger Class See Also

True if the trigger is an after trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property After As Boolean
C#
public bool After { get; internal set; }
Visual C++
public:
property bool After {
    bool get ();
    void set (bool value);
}

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


AnsiNullsOn Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.AnsiNullsOn Property
Trigger Class See Also

True if the trigger was created with ansi nulls on.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AnsiNullsOn As Boolean
C#
public bool AnsiNullsOn { get; internal set; }
Visual C++
public:
virtual property bool AnsiNullsOn {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

ISessionSetObject..::.AnsiNullsOn

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


Assembly Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.Assembly Property
Trigger Class See Also

The CLR assembly for the DML trigger, if it is a CLR DML trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Assembly As ClrAssembly
C#
public ClrAssembly Assembly { get; internal set; }
Visual C++
public:
virtual property ClrAssembly^ Assembly {
    ClrAssembly^ get () sealed;
    void set (ClrAssembly^ value) sealed;
}

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


AssemblyClass Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.AssemblyClass Property
Trigger Class See Also

The CLR assembly class name for the DML trigger, if it is a CLR DML trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyClass As String
C#
public string AssemblyClass { get; internal set; }
Visual C++
public:
property String^ AssemblyClass {
    String^ get ();
    void set (String^ value);
}

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


AssemblyMethod Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.AssemblyMethod Property
Trigger Class See Also

The CLR assembly method name for the DML trigger, if it is a CLR DML trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyMethod As String
C#
public string AssemblyMethod { get; internal set; }
Visual C++
public:
property String^ AssemblyMethod {
    String^ get ();
    void set (String^ value);
}

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


CLRObject Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.CLRObject Property
Trigger Class See Also

True if the trigger is a CLR trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CLRObject As Boolean
C#
public bool CLRObject { get; internal set; }
Visual C++
public:
virtual property bool CLRObject {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


Database Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.Database Property
Trigger Class See Also

The database to which the trigger belongs.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Database As Database
C#
public Database Database { get; internal set; }
Visual C++
public:
virtual property Database^ Database {
    Database^ get () sealed;
    void set (Database^ value) sealed;
}

Implements

IDatabaseObject..::.Database

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


Delete Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.Delete Property
Trigger Class See Also

True if the trigger is a delete trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Delete As Boolean
C#
public bool Delete { get; internal set; }
Visual C++
public:
property bool Delete {
    bool get ();
    void set (bool value);
}

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


EnableDisableStatementSource Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.EnableDisableStatementSource Property
Trigger Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property EnableDisableStatementSource As ScriptSource
C#
public ScriptSource EnableDisableStatementSource { get; set; }
Visual C++
public:
property ScriptSource^ EnableDisableStatementSource {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


Encrypted Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.Encrypted Property
Trigger Class See Also

True if the trigger definition is encrypted.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Encrypted As Boolean
C#
public bool Encrypted { get; internal set; }
Visual C++
public:
virtual property bool Encrypted {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IEncryptedTextObject..::.Encrypted

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


ExecuteAs Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.ExecuteAs Property
Trigger Class See Also

The user whose security context is to be used for the execution of the trigger. This is a SQL Server 2005 and 2008 feature.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecuteAs As User
C#
public User ExecuteAs { get; internal set; }
Visual C++
public:
virtual property User^ ExecuteAs {
    User^ get () sealed;
    void set (User^ value) sealed;
}

Implements

IExecuteAs..::.ExecuteAs

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


ExecuteAsType Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.ExecuteAsType Property
Trigger Class See Also

The EXECUTE AS clause used for the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecuteAsType As ExecuteAs
C#
public ExecuteAs ExecuteAsType { get; internal set; }
Visual C++
public:
virtual property ExecuteAs ExecuteAsType {
    ExecuteAs get () sealed;
    void set (ExecuteAs value) sealed;
}

Implements

IExecuteAs..::.ExecuteAsType

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


FirstDeleteTrigger Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.FirstDeleteTrigger Property
Trigger Class See Also

True if the trigger is the first delete trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FirstDeleteTrigger As Boolean
C#
public bool FirstDeleteTrigger { get; internal set; }
Visual C++
public:
property bool FirstDeleteTrigger {
    bool get ();
    void set (bool value);
}

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


FirstInsertTrigger Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.FirstInsertTrigger Property
Trigger Class See Also

True if the trigger is the first insert trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FirstInsertTrigger As Boolean
C#
public bool FirstInsertTrigger { get; internal set; }
Visual C++
public:
property bool FirstInsertTrigger {
    bool get ();
    void set (bool value);
}

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


FirstUpdateTrigger Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.FirstUpdateTrigger Property
Trigger Class See Also

True if the trigger is the first update trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FirstUpdateTrigger As Boolean
C#
public bool FirstUpdateTrigger { get; internal set; }
Visual C++
public:
property bool FirstUpdateTrigger {
    bool get ();
    void set (bool value);
}

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


FullyQualifiedName Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.FullyQualifiedName Property
Trigger Class See Also

The fully-qualified name of the trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullyQualifiedName As String
C#
public string FullyQualifiedName { get; private set; }
Visual C++
public:
virtual property String^ FullyQualifiedName {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ITSqlObjectFullyQualifiedName()()()

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


ID Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.ID Property
Trigger Class See Also

The identifier of the trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Please use SysobjectID instead")> _
Public Property ID As Integer
C#
[ObsoleteAttribute("Please use SysobjectID instead")]
public int ID { get; private set; }
Visual C++
[ObsoleteAttribute(L"Please use SysobjectID instead")]
public:
property int ID {
    int get ();
    void set (int value);
}

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


Insert Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.Insert Property
Trigger Class See Also

True if the trigger is an insert trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Insert As Boolean
C#
public bool Insert { get; internal set; }
Visual C++
public:
property bool Insert {
    bool get ();
    void set (bool value);
}

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


InsteadOf Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.InsteadOf Property
Trigger Class See Also

True if the trigger is an instead of trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property InsteadOf As Boolean
C#
public bool InsteadOf { get; internal set; }
Visual C++
public:
property bool InsteadOf {
    bool get ();
    void set (bool value);
}

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


IsDisabled Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.IsDisabled Property
Trigger Class See Also

True if the trigger is disabled.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsDisabled As Boolean
C#
public bool IsDisabled { get; internal set; }
Visual C++
public:
property bool IsDisabled {
    bool get ();
    void set (bool value);
}

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


LastDeleteTrigger Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.LastDeleteTrigger Property
Trigger Class See Also

True if the trigger is the last delete trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LastDeleteTrigger As Boolean
C#
public bool LastDeleteTrigger { get; internal set; }
Visual C++
public:
property bool LastDeleteTrigger {
    bool get ();
    void set (bool value);
}

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


LastInsertTrigger Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.LastInsertTrigger Property
Trigger Class See Also

True if the trigger is the last insert trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LastInsertTrigger As Boolean
C#
public bool LastInsertTrigger { get; internal set; }
Visual C++
public:
property bool LastInsertTrigger {
    bool get ();
    void set (bool value);
}

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


LastUpdateTrigger Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.LastUpdateTrigger Property
Trigger Class See Also

True if the trigger is the last update trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LastUpdateTrigger As Boolean
C#
public bool LastUpdateTrigger { get; internal set; }
Visual C++
public:
property bool LastUpdateTrigger {
    bool get ();
    void set (bool value);
}

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.Name Property
Trigger Class See Also

The name of the trigger. DANGER WILL ROBINSON!! This is not escaped. Do you mean Trigger..::.QualifiedName?

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
}

Implements

ITSqlObjectName()()()

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace
Trigger..::.QualifiedName


NotForReplication Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.NotForReplication Property
Trigger Class See Also

True if this trigger is NOT FOR REPLICATION.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NotForReplication As Boolean
C#
public bool NotForReplication { get; internal set; }
Visual C++
public:
property bool NotForReplication {
    bool get ();
    void set (bool value);
}

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.ObjectType Property
Trigger Class See Also

Returns ObjectType.Trigger

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ObjectType As ObjectType
C#
public ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () sealed;
}

Implements

ITSqlObjectObjectType()()()

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.Owner Property
Trigger Class See Also

The owner or the schema of the trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Owner As String
C#
public string Owner { get; internal set; }
Visual C++
public:
virtual property String^ Owner {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ITSqlObjectOwner()()()

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


Parent Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.Parent Property
Trigger Class See Also

The parent of the trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Parent As IDatabaseObject
C#
public IDatabaseObject Parent { get; internal set; }
Visual C++
public:
property IDatabaseObject^ Parent {
    IDatabaseObject^ get ();
    void set (IDatabaseObject^ value);
}

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


QualifiedName Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.QualifiedName Property
Trigger Class See Also

The qualified name of the object. Do you mean Trigger..::.Name?

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property QualifiedName As String
C#
public string QualifiedName { get; }
Visual C++
public:
virtual property String^ QualifiedName {
    String^ get () sealed;
}

Implements

ITSqlObjectQualifiedName()()()

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace
Trigger..::.Name


QuotedIdentifierOn Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.QuotedIdentifierOn Property
Trigger Class See Also

True if the trigger was created with quoted identifiers on.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property QuotedIdentifierOn As Boolean
C#
public bool QuotedIdentifierOn { get; internal set; }
Visual C++
public:
virtual property bool QuotedIdentifierOn {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

ISessionSetObject..::.QuotedIdentifierOn

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


ScriptSource Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.ScriptSource Property
Trigger Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSource As ScriptSource
C#
public ScriptSource ScriptSource { get; set; }
Visual C++
public:
virtual property ScriptSource^ ScriptSource {
    ScriptSource^ get () sealed;
    void set (ScriptSource^ value) sealed;
}

Implements

IHasScriptSource..::.ScriptSource

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


ScriptSourceDeleteOrder Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.ScriptSourceDeleteOrder Property
Trigger Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSourceDeleteOrder As ScriptSource
C#
public ScriptSource ScriptSourceDeleteOrder { get; set; }
Visual C++
public:
property ScriptSource^ ScriptSourceDeleteOrder {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


ScriptSourceInsertOrder Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.ScriptSourceInsertOrder Property
Trigger Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSourceInsertOrder As ScriptSource
C#
public ScriptSource ScriptSourceInsertOrder { get; set; }
Visual C++
public:
property ScriptSource^ ScriptSourceInsertOrder {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


ScriptSources Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.ScriptSources Property
Trigger Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ScriptSources As IEnumerable(Of ScriptSource)
C#
public IEnumerable<ScriptSource> ScriptSources { get; }
Visual C++
public:
property IEnumerable<ScriptSource^>^ ScriptSources {
    IEnumerable<ScriptSource^>^ get ();
}

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


ScriptSourceUpdateOrder Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.ScriptSourceUpdateOrder Property
Trigger Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSourceUpdateOrder As ScriptSource
C#
public ScriptSource ScriptSourceUpdateOrder { get; set; }
Visual C++
public:
property ScriptSource^ ScriptSourceUpdateOrder {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


SysobjectID Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.SysobjectID Property
Trigger Class See Also

The identifier of the trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SysobjectID As Integer
C#
public int SysobjectID { get; internal set; }
Visual C++
public:
virtual property int SysobjectID {
    int get () sealed;
    void set (int value) sealed;
}

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


Text Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.Text Property
Trigger Class See Also

The text of the trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
C#
public string Text { get; }
Visual C++
public:
virtual property String^ Text {
    String^ get () sealed;
}

Implements

ITextObject..::.Text

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


IEncryptedTextObject.TextID Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.IEncryptedTextObject..::.TextID Property
Trigger Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private ReadOnly Property TextID As Integer
    Implements IEncryptedTextObject.TextID
C#
int IEncryptedTextObject.TextID { get; }
Visual C++
private:
virtual property int TextID {
    int get () sealed = IEncryptedTextObject::TextID::get;
}

Implements

IEncryptedTextObject..::.TextID

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


Update Property

[image]

SQL Data Compare API 12.0.40
Trigger..::.Update Property
Trigger Class See Also

True if the trigger is an update trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Update As Boolean
C#
public bool Update { get; internal set; }
Visual C++
public:
property bool Update {
    bool get ();
    void set (bool value);
}

See Also

Trigger Class
RedGate.SQLCompare.Engine Namespace


TriggerChangesCalculator Class

[image]

SQL Data Compare API 12.0.40
TriggerChangesCalculator Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class TriggerChangesCalculator
C#
public class TriggerChangesCalculator
Visual C++
public ref class TriggerChangesCalculator

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.TriggerChangesCalculator

See Also

TriggerChangesCalculator Members
RedGate.SQLCompare.Engine Namespace


TriggerChangesCalculator Members

[image] [image]

SQL Data Compare API 12.0.40
TriggerChangesCalculator Members
TriggerChangesCalculator Class Constructors Methods See Also

The TriggerChangesCalculator type exposes the following members.

Constructors

Name | Description
TriggerChangesCalculator |

Methods

Name | Description
AddTrigger |
CalculateWorkTableTriggers |
DropTriggers |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TriggerChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


TriggerChangesCalculator Constructor

[image]

SQL Data Compare API 12.0.40
TriggerChangesCalculator Constructor
TriggerChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    warnings As Messages, _
    clrDowngradeWarningsCalculator As CLRDowngradeWarningsCalculator, _
    dmlTriggersChanges As DmlTriggersChanges _
)
C#
public TriggerChangesCalculator(
    Messages warnings,
    CLRDowngradeWarningsCalculator clrDowngradeWarningsCalculator,
    DmlTriggersChanges dmlTriggersChanges
)
Visual C++
public:
TriggerChangesCalculator(
    Messages^ warnings,
    CLRDowngradeWarningsCalculator^ clrDowngradeWarningsCalculator,
    DmlTriggersChanges^ dmlTriggersChanges
)

Parameters

warnings
Type: RedGate.SQLCompare.Engine..::.Messages
clrDowngradeWarningsCalculator
Type: RedGate.SQLCompare.Engine..::.CLRDowngradeWarningsCalculator
dmlTriggersChanges
Type: RedGate.SQLCompare.Engine..::.DmlTriggersChanges

See Also

TriggerChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


TriggerChangesCalculator Methods

[image] [image]

SQL Data Compare API 12.0.40
TriggerChangesCalculator Methods
TriggerChangesCalculator Class See Also

The TriggerChangesCalculator type exposes the following methods.

Methods

Name | Description
AddTrigger |
CalculateWorkTableTriggers |
DropTriggers |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TriggerChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


AddTrigger Method

[image]

SQL Data Compare API 12.0.40
TriggerChangesCalculator..::.AddTrigger Method
TriggerChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddTrigger ( _
    owner As IDatabaseObject, _
    targetDatabase As IDatabase, _
    options As Options, _
    trigger As Trigger _
)
C#
public void AddTrigger(
    IDatabaseObject owner,
    IDatabase targetDatabase,
    Options options,
    Trigger trigger
)
Visual C++
public:
void AddTrigger(
    IDatabaseObject^ owner,
    IDatabase^ targetDatabase,
    Options options,
    Trigger^ trigger
)

Parameters

owner
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
targetDatabase
Type: RedGate.SQLCompare.Engine..::.IDatabase
options
Type: RedGate.SQLCompare.Engine..::.Options
trigger
Type: RedGate.SQLCompare.Engine..::.Trigger

See Also

TriggerChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


CalculateWorkTableTriggers Method

[image]

SQL Data Compare API 12.0.40
TriggerChangesCalculator..::.CalculateWorkTableTriggers Method
TriggerChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculateWorkTableTriggers ( _
    options As Options, _
    sourceOwner As IDatabaseObject, _
    sourceTriggers As Triggers, _
    targetTriggers As Triggers, _
    targetDatabase As Database _
)
C#
public void CalculateWorkTableTriggers(
    Options options,
    IDatabaseObject sourceOwner,
    Triggers sourceTriggers,
    Triggers targetTriggers,
    Database targetDatabase
)
Visual C++
public:
void CalculateWorkTableTriggers(
    Options options,
    IDatabaseObject^ sourceOwner,
    Triggers^ sourceTriggers,
    Triggers^ targetTriggers,
    Database^ targetDatabase
)

Parameters

options
Type: RedGate.SQLCompare.Engine..::.Options
sourceOwner
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
sourceTriggers
Type: RedGate.SQLCompare.Engine..::.Triggers
targetTriggers
Type: RedGate.SQLCompare.Engine..::.Triggers
targetDatabase
Type: RedGate.SQLCompare.Engine..::.Database

See Also

TriggerChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


DropTriggers Method

[image]

SQL Data Compare API 12.0.40
TriggerChangesCalculator..::.DropTriggers Method
TriggerChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub DropTriggers ( _
    triggers As Triggers _
)
C#
public void DropTriggers(
    Triggers triggers
)
Visual C++
public:
void DropTriggers(
    Triggers^ triggers
)

Parameters

triggers
Type: RedGate.SQLCompare.Engine..::.Triggers

See Also

TriggerChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


Triggers Class

[image]

SQL Data Compare API 12.0.40
Triggers Class
Members See Also

A collection of triggers.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Triggers _
    Inherits SerializableDatabaseObjectCollection(Of Trigger)
C#
public sealed class Triggers : SerializableDatabaseObjectCollection<Trigger>
Visual C++
public ref class Triggers sealed : public SerializableDatabaseObjectCollection<Trigger^>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Trigger >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( Trigger >)>)
RedGate.SQLCompare.Engine..::.Triggers

See Also

Triggers Members
RedGate.SQLCompare.Engine Namespace


Triggers Members

[image] [image]

SQL Data Compare API 12.0.40
Triggers Members
Triggers Class Methods Fields Properties Explicit Interface Implementations See Also

The Triggers type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

Triggers Class
RedGate.SQLCompare.Engine Namespace


Triggers Methods

[image] [image]

SQL Data Compare API 12.0.40
Triggers Methods
Triggers Class See Also

The Triggers type exposes the following methods.

Methods

Name | Description
Add | Overloaded.
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

Triggers Class
RedGate.SQLCompare.Engine Namespace


Add Method

[image] [image]

SQL Data Compare API 12.0.40
Triggers..::.Add Method
Triggers Class See Also

Overload List

Name | Description
Add(T) | (Inherited from KeyedCollection<(Of <(T>)>).)
Add(Trigger) | (Overrides SerializableDatabaseObjectCollection <(Of <( Trigger >)>)..::. Add(T).)

See Also

Triggers Class
Triggers Members
RedGate.SQLCompare.Engine Namespace


Add Method (Trigger)

[image]

SQL Data Compare API 12.0.40
Triggers..::.Add Method (Trigger)
Triggers Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Add ( _
    value As Trigger _
)
C#
public override void Add(
    Trigger value
)
Visual C++
public:
virtual void Add(
    Trigger^ value
) override

Parameters

value
Type: RedGate.SQLCompare.Engine..::.Trigger

See Also

Triggers Class
Add Overload
RedGate.SQLCompare.Engine Namespace


Triggers Properties

[image] [image]

SQL Data Compare API 12.0.40
Triggers Properties
Triggers Class See Also

The Triggers type exposes the following properties.

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

See Also

Triggers Class
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
Triggers..::.Item Property
Triggers Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns a trigger given its fully-qualified name. (Overrides KeyedCollection <(Of <( T >)>)..::. Item[([(String])]).)
Item[([(String, String])]) | Returns a trigger given its name and owner. (Overrides SerializableDatabaseObjectCollection <(Of <( Trigger >)>)..::. Item[([(String, String])]).)

See Also

Triggers Class
Triggers Members
RedGate.SQLCompare.Engine Namespace


Item Property ()

[image]

SQL Data Compare API 12.0.40
Triggers..::.Item Property ()
Triggers Class See Also

Returns a trigger given its fully-qualified name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Default Property Item ( _
    fullyQualifiedName As String _
) As Trigger
C#
public override Trigger this[
    string fullyQualifiedName
] { get; }
Visual C++
public:
virtual property Trigger^ default[String^ fullyQualifiedName] {
    Trigger^ get (String^ fullyQualifiedName) override;
}

Parameters

fullyQualifiedName
Type: String
The string-based index of the element to get or set.

Implements

IKeyedCollectionItem(String)

See Also

Triggers Class
Item Overload
RedGate.SQLCompare.Engine Namespace


Item Property (, )

[image]

SQL Data Compare API 12.0.40
Triggers..::.Item Property (, )
Triggers Class See Also

Returns a trigger given its name and owner.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Default Property Item ( _
    owner As String, _
    name As String _
) As Trigger
C#
public override Trigger this[
    string owner,
    string name
] { get; }
Visual C++
public:
virtual property Trigger^ default[String^ owner, String^ name] {
    Trigger^ get (String^ owner, String^ name) override;
}

Parameters

owner
Type: String
The owner component of the string-based index of the element to get or set.
name
Type: String
The name component of the string-based index of the element to get or set.

See Also

Triggers Class
Item Overload
RedGate.SQLCompare.Engine Namespace


TypeOfBackup Enumeration

[image]

SQL Data Compare API 12.0.40
TypeOfBackup Enumeration
See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration TypeOfBackup
C#
public enum TypeOfBackup
Visual C++
public enum class TypeOfBackup

Members

Member name | Description
Full |
Differential |

See Also

RedGate.SQLCompare.Engine Namespace


TypeRebuilderCollector Class

[image]

SQL Data Compare API 12.0.40
TypeRebuilderCollector Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class TypeRebuilderCollector
C#
public class TypeRebuilderCollector
Visual C++
public ref class TypeRebuilderCollector

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.TypeRebuilderCollector

See Also

TypeRebuilderCollector Members
RedGate.SQLCompare.Engine Namespace


TypeRebuilderCollector Members

[image] [image]

SQL Data Compare API 12.0.40
TypeRebuilderCollector Members
TypeRebuilderCollector Class Constructors Methods See Also

The TypeRebuilderCollector type exposes the following members.

Constructors

Name | Description
TypeRebuilderCollector |

Methods

Name | Description
AddTypeToRebuild |
Contains |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEmpty |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TypeRebuilderCollector Class
RedGate.SQLCompare.Engine Namespace


TypeRebuilderCollector Constructor

[image]

SQL Data Compare API 12.0.40
TypeRebuilderCollector Constructor
TypeRebuilderCollector Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    typesChanges As TypesChanges _
)
C#
public TypeRebuilderCollector(
    TypesChanges typesChanges
)
Visual C++
public:
TypeRebuilderCollector(
    TypesChanges^ typesChanges
)

Parameters

typesChanges
Type: RedGate.SQLCompare.Engine..::.TypesChanges

See Also

TypeRebuilderCollector Class
RedGate.SQLCompare.Engine Namespace


TypeRebuilderCollector Methods

[image] [image]

SQL Data Compare API 12.0.40
TypeRebuilderCollector Methods
TypeRebuilderCollector Class See Also

The TypeRebuilderCollector type exposes the following methods.

Methods

Name | Description
AddTypeToRebuild |
Contains |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEmpty |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TypeRebuilderCollector Class
RedGate.SQLCompare.Engine Namespace


AddTypeToRebuild Method

[image]

SQL Data Compare API 12.0.40
TypeRebuilderCollector..::.AddTypeToRebuild Method
TypeRebuilderCollector Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddTypeToRebuild ( _
    fullyQualifiedName As String _
)
C#
public void AddTypeToRebuild(
    string fullyQualifiedName
)
Visual C++
public:
void AddTypeToRebuild(
    String^ fullyQualifiedName
)

Parameters

fullyQualifiedName
Type: String

See Also

TypeRebuilderCollector Class
RedGate.SQLCompare.Engine Namespace


Contains Method

[image]

SQL Data Compare API 12.0.40
TypeRebuilderCollector..::.Contains Method
TypeRebuilderCollector Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains ( _
    fullyQualifiedTypeName As String _
) As Boolean
C#
public bool Contains(
    string fullyQualifiedTypeName
)
Visual C++
public:
bool Contains(
    String^ fullyQualifiedTypeName
)

Parameters

fullyQualifiedTypeName
Type: String

See Also

TypeRebuilderCollector Class
RedGate.SQLCompare.Engine Namespace


IsEmpty Method

[image]

SQL Data Compare API 12.0.40
TypeRebuilderCollector..::.IsEmpty Method
TypeRebuilderCollector Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function IsEmpty As Boolean
C#
public bool IsEmpty()
Visual C++
public:
bool IsEmpty()

See Also

TypeRebuilderCollector Class
RedGate.SQLCompare.Engine Namespace


TypesChanges Class

[image]

SQL Data Compare API 12.0.40
TypesChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TypesChanges
C#
public sealed class TypesChanges
Visual C++
public ref class TypesChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.TypesChanges

See Also

TypesChanges Members
RedGate.SQLCompare.Engine Namespace


TypesChanges Members

[image] [image]

SQL Data Compare API 12.0.40
TypesChanges Members
TypesChanges Class Constructors Methods Fields Properties See Also

The TypesChanges type exposes the following members.

Constructors

Name | Description
TypesChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectsToCreate |
GetObjectsToDrop |
GetObjectsToRebuild |
GetTargets |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
UnusedTypesToRebuild |
UnusedTypeTargets |

Properties

Name | Description
TypesToCreate |
TypesToDrop |
TypesToRebuild |

See Also

TypesChanges Class
RedGate.SQLCompare.Engine Namespace


TypesChanges Constructor

[image]

SQL Data Compare API 12.0.40
TypesChanges Constructor
TypesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public TypesChanges(
    bool caseSensitive
)
Visual C++
public:
TypesChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

TypesChanges Class
RedGate.SQLCompare.Engine Namespace


TypesChanges Fields

[image] [image]

SQL Data Compare API 12.0.40
TypesChanges Fields
TypesChanges Class See Also

The TypesChanges type exposes the following fields.

Fields

Name | Description
UnusedTypesToRebuild |
UnusedTypeTargets |

See Also

TypesChanges Class
RedGate.SQLCompare.Engine Namespace


UnusedTypesToRebuild Field

[image]

SQL Data Compare API 12.0.40
TypesChanges..::.UnusedTypesToRebuild Field
TypesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared UnusedTypesToRebuild As UserDefinedTypes
C#
public static UserDefinedTypes UnusedTypesToRebuild
Visual C++
public:
static UserDefinedTypes^ UnusedTypesToRebuild

See Also

TypesChanges Class
RedGate.SQLCompare.Engine Namespace


UnusedTypeTargets Field

[image]

SQL Data Compare API 12.0.40
TypesChanges..::.UnusedTypeTargets Field
TypesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared UnusedTypeTargets As Dictionary(Of UserDefinedType, UserDefinedType)
C#
public static Dictionary<UserDefinedType, UserDefinedType> UnusedTypeTargets
Visual C++
public:
static Dictionary<UserDefinedType^, UserDefinedType^>^ UnusedTypeTargets

See Also

TypesChanges Class
RedGate.SQLCompare.Engine Namespace


TypesChanges Methods

[image] [image]

SQL Data Compare API 12.0.40
TypesChanges Methods
TypesChanges Class See Also

The TypesChanges type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectsToCreate |
GetObjectsToDrop |
GetObjectsToRebuild |
GetTargets |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TypesChanges Class
RedGate.SQLCompare.Engine Namespace


GetObjectsToCreate Method

[image]

SQL Data Compare API 12.0.40
TypesChanges..::.GetObjectsToCreate Method
TypesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetObjectsToCreate As KeyedCollection(Of UserDefinedType)
C#
public KeyedCollection<UserDefinedType> GetObjectsToCreate()
Visual C++
public:
virtual KeyedCollection<UserDefinedType^>^ GetObjectsToCreate() sealed

See Also

TypesChanges Class
RedGate.SQLCompare.Engine Namespace


GetObjectsToDrop Method

[image]

SQL Data Compare API 12.0.40
TypesChanges..::.GetObjectsToDrop Method
TypesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetObjectsToDrop As KeyedCollection(Of UserDefinedType)
C#
public KeyedCollection<UserDefinedType> GetObjectsToDrop()
Visual C++
public:
virtual KeyedCollection<UserDefinedType^>^ GetObjectsToDrop() sealed

See Also

TypesChanges Class
RedGate.SQLCompare.Engine Namespace


GetObjectsToRebuild Method

[image]

SQL Data Compare API 12.0.40
TypesChanges..::.GetObjectsToRebuild Method
TypesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetObjectsToRebuild As KeyedCollection(Of UserDefinedType)
C#
public KeyedCollection<UserDefinedType> GetObjectsToRebuild()
Visual C++
public:
virtual KeyedCollection<UserDefinedType^>^ GetObjectsToRebuild() sealed

See Also

TypesChanges Class
RedGate.SQLCompare.Engine Namespace


GetTargets Method

[image]

SQL Data Compare API 12.0.40
TypesChanges..::.GetTargets Method
TypesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetTargets As Dictionary(Of UserDefinedType, UserDefinedType)
C#
public Dictionary<UserDefinedType, UserDefinedType> GetTargets()
Visual C++
public:
virtual Dictionary<UserDefinedType^, UserDefinedType^>^ GetTargets() sealed

See Also

TypesChanges Class
RedGate.SQLCompare.Engine Namespace


TypesChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
TypesChanges Properties
TypesChanges Class See Also

The TypesChanges type exposes the following properties.

Properties

Name | Description
TypesToCreate |
TypesToDrop |
TypesToRebuild |

See Also

TypesChanges Class
RedGate.SQLCompare.Engine Namespace


TypesToCreate Property

[image]

SQL Data Compare API 12.0.40
TypesChanges..::.TypesToCreate Property
TypesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TypesToCreate As UserDefinedTypes
C#
public UserDefinedTypes TypesToCreate { get; private set; }
Visual C++
public:
property UserDefinedTypes^ TypesToCreate {
    UserDefinedTypes^ get ();
    void set (UserDefinedTypes^ value);
}

See Also

TypesChanges Class
RedGate.SQLCompare.Engine Namespace


TypesToDrop Property

[image]

SQL Data Compare API 12.0.40
TypesChanges..::.TypesToDrop Property
TypesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TypesToDrop As UserDefinedTypes
C#
public UserDefinedTypes TypesToDrop { get; private set; }
Visual C++
public:
property UserDefinedTypes^ TypesToDrop {
    UserDefinedTypes^ get ();
    void set (UserDefinedTypes^ value);
}

See Also

TypesChanges Class
RedGate.SQLCompare.Engine Namespace


TypesToRebuild Property

[image]

SQL Data Compare API 12.0.40
TypesChanges..::.TypesToRebuild Property
TypesChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TypesToRebuild As Set(Of String)
C#
public Set<string> TypesToRebuild { get; private set; }
Visual C++
public:
property Set<String^>^ TypesToRebuild {
    Set<String^>^ get ();
    void set (Set<String^>^ value);
}

See Also

TypesChanges Class
RedGate.SQLCompare.Engine Namespace


UDTBinding Class

[image]

SQL Data Compare API 12.0.40
UDTBinding Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class UDTBinding _
    Implements ICanExistenceCheck
C#
public sealed class UDTBinding : ICanExistenceCheck
Visual C++
public ref class UDTBinding sealed : ICanExistenceCheck

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.UDTBinding

See Also

UDTBinding Members
RedGate.SQLCompare.Engine Namespace


UDTBinding Members

[image] [image]

SQL Data Compare API 12.0.40
UDTBinding Members
UDTBinding Class Methods Properties See Also

The UDTBinding type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundObjectName |
Type |

See Also

UDTBinding Class
RedGate.SQLCompare.Engine Namespace


UDTBinding Properties

[image] [image]

SQL Data Compare API 12.0.40
UDTBinding Properties
UDTBinding Class See Also

The UDTBinding type exposes the following properties.

Properties

Name | Description
BoundObjectName |
Type |

See Also

UDTBinding Class
RedGate.SQLCompare.Engine Namespace


BoundObjectName Property

[image]

SQL Data Compare API 12.0.40
UDTBinding..::.BoundObjectName Property
UDTBinding Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BoundObjectName As String
C#
public string BoundObjectName { get; }
Visual C++
public:
property String^ BoundObjectName {
    String^ get ();
}

See Also

UDTBinding Class
RedGate.SQLCompare.Engine Namespace


Type Property

[image]

SQL Data Compare API 12.0.40
UDTBinding..::.Type Property
UDTBinding Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As UserDefinedType
C#
public UserDefinedType Type { get; }
Visual C++
public:
property UserDefinedType^ Type {
    UserDefinedType^ get ();
}

See Also

UDTBinding Class
RedGate.SQLCompare.Engine Namespace


UDTBindings Class

[image]

SQL Data Compare API 12.0.40
UDTBindings Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class UDTBindings _
    Inherits KeyedCollection(Of UDTBinding)
C#
public sealed class UDTBindings : KeyedCollection<UDTBinding>
Visual C++
public ref class UDTBindings sealed : public KeyedCollection<UDTBinding^>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( UDTBinding >)>)
RedGate.SQLCompare.Engine..::.UDTBindings

See Also

UDTBindings Members
RedGate.SQLCompare.Engine Namespace


UDTBindings Members

[image] [image]

SQL Data Compare API 12.0.40
UDTBindings Members
UDTBindings Class Methods Fields Properties Explicit Interface Implementations See Also

The UDTBindings type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

UDTBindings Class
RedGate.SQLCompare.Engine Namespace


UnsupportedDataWarehouseException Class

[image]

SQL Data Compare API 12.0.40
UnsupportedDataWarehouseException Class
Members See Also

Exception for when trying to register an Azure Data Warehouse (and possibly PDW) database

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class UnsupportedDataWarehouseException _
    Inherits SqlCompareException
C#
public class UnsupportedDataWarehouseException : SqlCompareException
Visual C++
public ref class UnsupportedDataWarehouseException : public SqlCompareException

Inheritance Hierarchy

Object
Exception
RedGate.SQLCompare.Engine..::.SqlCompareException
RedGate.SQLCompare.Engine..::.UnsupportedDataWarehouseException

See Also

UnsupportedDataWarehouseException Members
RedGate.SQLCompare.Engine Namespace


UnsupportedDataWarehouseException Members

[image] [image]

SQL Data Compare API 12.0.40
UnsupportedDataWarehouseException Members
UnsupportedDataWarehouseException Class Constructors Methods Properties See Also

The UnsupportedDataWarehouseException type exposes the following members.

Constructors

Name | Description
UnsupportedDataWarehouseException |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

UnsupportedDataWarehouseException Class
RedGate.SQLCompare.Engine Namespace


UnsupportedDataWarehouseException Constructor

[image]

SQL Data Compare API 12.0.40
UnsupportedDataWarehouseException Constructor
UnsupportedDataWarehouseException Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public UnsupportedDataWarehouseException()
Visual C++
public:
UnsupportedDataWarehouseException()

See Also

UnsupportedDataWarehouseException Class
RedGate.SQLCompare.Engine Namespace


UnsupportedSqlServerVersionException Class

[image]

SQL Data Compare API 12.0.40
UnsupportedSqlServerVersionException Class
Members See Also

Exception for when trying to register a database for a SQL Server version that is too old (currently 2000 and earlier)

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class UnsupportedSqlServerVersionException _
    Inherits SqlCompareException
C#
public class UnsupportedSqlServerVersionException : SqlCompareException
Visual C++
public ref class UnsupportedSqlServerVersionException : public SqlCompareException

Inheritance Hierarchy

Object
Exception
RedGate.SQLCompare.Engine..::.SqlCompareException
RedGate.SQLCompare.Engine..::.UnsupportedSqlServerVersionException

See Also

UnsupportedSqlServerVersionException Members
RedGate.SQLCompare.Engine Namespace


UnsupportedSqlServerVersionException Members

[image] [image]

SQL Data Compare API 12.0.40
UnsupportedSqlServerVersionException Members
UnsupportedSqlServerVersionException Class Constructors Methods Properties See Also

The UnsupportedSqlServerVersionException type exposes the following members.

Constructors

Name | Description
UnsupportedSqlServerVersionException |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

UnsupportedSqlServerVersionException Class
RedGate.SQLCompare.Engine Namespace


UnsupportedSqlServerVersionException Constructor

[image]

SQL Data Compare API 12.0.40
UnsupportedSqlServerVersionException Constructor
UnsupportedSqlServerVersionException Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public UnsupportedSqlServerVersionException()
Visual C++
public:
UnsupportedSqlServerVersionException()

See Also

UnsupportedSqlServerVersionException Class
RedGate.SQLCompare.Engine Namespace


User Class

[image]

SQL Data Compare API 12.0.40
User Class
Members See Also

A user.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class User _
    Inherits ScriptableDatabaseObject _
    Implements IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck,  _
    IOwner, IPatchUpAfterDeserialization, ISqlComparable
C#
public sealed class User : ScriptableDatabaseObject, IHasPermissions,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, IOwner, IPatchUpAfterDeserialization,
    ISqlComparable
Visual C++
public ref class User sealed : public ScriptableDatabaseObject,
    IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck, IOwner,
    IPatchUpAfterDeserialization, ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.User

See Also

User Members
RedGate.SQLCompare.Engine Namespace


User Members

[image] [image]

SQL Data Compare API 12.0.40
User Members
User Class Methods Fields Properties Explicit Interface Implementations See Also

The User type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AsymmetricKey | The name of the asymmetric key if the user is an asymmetric key bound user.
Certificate | The name of the certificate key if the user is an certificate key bound user.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
DatabaseLevelPermissions | Access to the user's database-level permissions.
DefaultSchema | The default schema of SQL Server 2005 users.
ExtendedProperties | The extended properties defined for the user.
FullyQualifiedName | The fully-qualified name of the user. DANGER WILL ROBINSON!! This is not escaped. (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
IsSQLUser | Obsolete. True if the user is a SQL user.
IsWindowsUser | Obsolete. True if the user is a Windows user.
LoginName | The login name of the user.
LoginNameWithoutDomain | For a user based on a login for a Windows principal, returns the login name without the domain. For example, for user @"red-gate.com\fred" this property returns @"fred".
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.User (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner of the user. This is undefined. (Overrides ScriptableDatabaseObject ..::. Owner.)
Permissions | The permissions on this user.
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceCreateLogin | The location of the creation script for the create login statement for this object if the database source is set to scripts folder.
ScriptSources | (Inherited from ScriptableDatabaseObject.)
UserNameWithoutDomain | For a user based on a login for a Windows principal, returns the user name without the domain. For example, for user @"red-gate.com\fred" this property returns @"fred". Users attached to windows logins often have the same name as the login, although this doesn't have to be the case (eg SC-9134)
UserType | The user type. This can be a certificate or asymmetric key bound user. In addition, in SQL Sever 2000 and earlier this can be a Windows user or a SQL user in SQL Server 2000.

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

User Class
RedGate.SQLCompare.Engine Namespace


User Methods

[image] [image]

SQL Data Compare API 12.0.40
User Methods
User Class See Also

The User type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

User Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
User..::.ISqlComparable..::.CompareWith Method
User Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    target As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable target,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ target,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

target
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

User Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
User..::.Equals Method
User Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the user with a specified user. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

User Class
User Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
User..::.Equals Method (IDatabaseObject, Options)
User Class See Also

Compares the user with a specified user.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) override

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The user to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the users are identical; otherwise false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

User Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
User..::.PatchUpAfterDeserialization Method
User Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

User Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
User..::.ScriptObject Method
User Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

User Class
RedGate.SQLCompare.Engine Namespace


User Properties

[image] [image]

SQL Data Compare API 12.0.40
User Properties
User Class See Also

The User type exposes the following properties.

Properties

Name | Description
AsymmetricKey | The name of the asymmetric key if the user is an asymmetric key bound user.
Certificate | The name of the certificate key if the user is an certificate key bound user.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
DatabaseLevelPermissions | Access to the user's database-level permissions.
DefaultSchema | The default schema of SQL Server 2005 users.
ExtendedProperties | The extended properties defined for the user.
FullyQualifiedName | The fully-qualified name of the user. DANGER WILL ROBINSON!! This is not escaped. (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
IsSQLUser | Obsolete. True if the user is a SQL user.
IsWindowsUser | Obsolete. True if the user is a Windows user.
LoginName | The login name of the user.
LoginNameWithoutDomain | For a user based on a login for a Windows principal, returns the login name without the domain. For example, for user @"red-gate.com\fred" this property returns @"fred".
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.User (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner of the user. This is undefined. (Overrides ScriptableDatabaseObject ..::. Owner.)
Permissions | The permissions on this user.
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceCreateLogin | The location of the creation script for the create login statement for this object if the database source is set to scripts folder.
ScriptSources | (Inherited from ScriptableDatabaseObject.)
UserNameWithoutDomain | For a user based on a login for a Windows principal, returns the user name without the domain. For example, for user @"red-gate.com\fred" this property returns @"fred". Users attached to windows logins often have the same name as the login, although this doesn't have to be the case (eg SC-9134)
UserType | The user type. This can be a certificate or asymmetric key bound user. In addition, in SQL Sever 2000 and earlier this can be a Windows user or a SQL user in SQL Server 2000.

See Also

User Class
RedGate.SQLCompare.Engine Namespace


AsymmetricKey Property

[image]

SQL Data Compare API 12.0.40
User..::.AsymmetricKey Property
User Class See Also

The name of the asymmetric key if the user is an asymmetric key bound user.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AsymmetricKey As String
C#
public string AsymmetricKey { get; internal set; }
Visual C++
public:
property String^ AsymmetricKey {
    String^ get ();
    void set (String^ value);
}

See Also

User Class
RedGate.SQLCompare.Engine Namespace


Certificate Property

[image]

SQL Data Compare API 12.0.40
User..::.Certificate Property
User Class See Also

The name of the certificate key if the user is an certificate key bound user.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Certificate As String
C#
public string Certificate { get; internal set; }
Visual C++
public:
property String^ Certificate {
    String^ get ();
    void set (String^ value);
}

See Also

User Class
RedGate.SQLCompare.Engine Namespace


DatabaseLevelPermissions Property

[image]

SQL Data Compare API 12.0.40
User..::.DatabaseLevelPermissions Property
User Class See Also

Access to the user's database-level permissions.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DatabaseLevelPermissions As DatabaseLevelPermissions
C#
public DatabaseLevelPermissions DatabaseLevelPermissions { get; }
Visual C++
public:
property DatabaseLevelPermissions^ DatabaseLevelPermissions {
    DatabaseLevelPermissions^ get ();
}

See Also

User Class
RedGate.SQLCompare.Engine Namespace


DefaultSchema Property

[image]

SQL Data Compare API 12.0.40
User..::.DefaultSchema Property
User Class See Also

The default schema of SQL Server 2005 users.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultSchema As String
C#
public string DefaultSchema { get; internal set; }
Visual C++
public:
property String^ DefaultSchema {
    String^ get ();
    void set (String^ value);
}

See Also

User Class
RedGate.SQLCompare.Engine Namespace


ExtendedProperties Property

[image]

SQL Data Compare API 12.0.40
User..::.ExtendedProperties Property
User Class See Also

The extended properties defined for the user.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedProperties
C#
public ExtendedProperties ExtendedProperties { get; }
Visual C++
public:
property ExtendedProperties^ ExtendedProperties {
    ExtendedProperties^ get ();
}

See Also

User Class
RedGate.SQLCompare.Engine Namespace


FullyQualifiedName Property

[image]

SQL Data Compare API 12.0.40
User..::.FullyQualifiedName Property
User Class See Also

The fully-qualified name of the user. DANGER WILL ROBINSON!! This is not escaped.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FullyQualifiedName As String
C#
public override string FullyQualifiedName { get; }
Visual C++
public:
virtual property String^ FullyQualifiedName {
    String^ get () override;
}

Implements

ITSqlObjectFullyQualifiedName()()()
ITSqlObjectFullyQualifiedName()()()

See Also

User Class
RedGate.SQLCompare.Engine Namespace


IsSQLUser Property

[image]

SQL Data Compare API 12.0.40
User..::.IsSQLUser Property
User Class See Also

True if the user is a SQL user.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Use UserType.", False)> _
Public ReadOnly Property IsSQLUser As Boolean
C#
[ObsoleteAttribute("Use UserType.", false)]
public bool IsSQLUser { get; }
Visual C++
[ObsoleteAttribute(L"Use UserType.", false)]
public:
property bool IsSQLUser {
    bool get ();
}

See Also

User Class
RedGate.SQLCompare.Engine Namespace


IsWindowsUser Property

[image]

SQL Data Compare API 12.0.40
User..::.IsWindowsUser Property
User Class See Also

True if the user is a Windows user.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Use UserType.", False)> _
Public ReadOnly Property IsWindowsUser As Boolean
C#
[ObsoleteAttribute("Use UserType.", false)]
public bool IsWindowsUser { get; }
Visual C++
[ObsoleteAttribute(L"Use UserType.", false)]
public:
property bool IsWindowsUser {
    bool get ();
}

See Also

User Class
RedGate.SQLCompare.Engine Namespace


LoginName Property

[image]

SQL Data Compare API 12.0.40
User..::.LoginName Property
User Class See Also

The login name of the user.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LoginName As String
C#
public string LoginName { get; internal set; }
Visual C++
public:
property String^ LoginName {
    String^ get ();
    void set (String^ value);
}

See Also

User Class
RedGate.SQLCompare.Engine Namespace


LoginNameWithoutDomain Property

[image]

SQL Data Compare API 12.0.40
User..::.LoginNameWithoutDomain Property
User Class See Also

For a user based on a login for a Windows principal, returns the login name without the domain. For example, for user @"red-gate.com\fred" this property returns @"fred".

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LoginNameWithoutDomain As String
C#
public string LoginNameWithoutDomain { get; }
Visual C++
public:
property String^ LoginNameWithoutDomain {
    String^ get ();
}

See Also

User Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
User..::.ObjectType Property
User Class See Also

Returns ObjectType.User

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()
ITSqlObjectObjectType()()()

See Also

User Class
RedGate.SQLCompare.Engine Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
User..::.Owner Property
User Class See Also

The owner of the user. This is undefined.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Owner As String
C#
public override string Owner { get; }
Visual C++
public:
virtual property String^ Owner {
    String^ get () override;
}

Implements

ITSqlObjectOwner()()()
ITSqlObjectOwner()()()

See Also

User Class
RedGate.SQLCompare.Engine Namespace


Permissions Property

[image]

SQL Data Compare API 12.0.40
User..::.Permissions Property
User Class See Also

The permissions on this user.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Permissions As Permissions
C#
public Permissions Permissions { get; }
Visual C++
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
}

Implements

IHasPermissions..::.Permissions

See Also

User Class
RedGate.SQLCompare.Engine Namespace


ScriptSourceCreateLogin Property

[image]

SQL Data Compare API 12.0.40
User..::.ScriptSourceCreateLogin Property
User Class See Also

The location of the creation script for the create login statement for this object if the database source is set to scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSourceCreateLogin As ScriptSource
C#
public ScriptSource ScriptSourceCreateLogin { get; internal set; }
Visual C++
public:
property ScriptSource^ ScriptSourceCreateLogin {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

User Class
RedGate.SQLCompare.Engine Namespace


UserNameWithoutDomain Property

[image]

SQL Data Compare API 12.0.40
User..::.UserNameWithoutDomain Property
User Class See Also

For a user based on a login for a Windows principal, returns the user name without the domain. For example, for user @"red-gate.com\fred" this property returns @"fred". Users attached to windows logins often have the same name as the login, although this doesn't have to be the case (eg SC-9134)

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UserNameWithoutDomain As String
C#
public string UserNameWithoutDomain { get; }
Visual C++
public:
property String^ UserNameWithoutDomain {
    String^ get ();
}

See Also

User Class
RedGate.SQLCompare.Engine Namespace


UserType Property

[image]

SQL Data Compare API 12.0.40
User..::.UserType Property
User Class See Also

The user type. This can be a certificate or asymmetric key bound user. In addition, in SQL Sever 2000 and earlier this can be a Windows user or a SQL user in SQL Server 2000.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UserType As UserType
C#
public UserType UserType { get; internal set; }
Visual C++
public:
property UserType UserType {
    UserType get ();
    void set (UserType value);
}

See Also

User Class
RedGate.SQLCompare.Engine Namespace


UserActionUtilities Class

[image]

SQL Data Compare API 12.0.40
UserActionUtilities Class
Members See Also

Various utilities for use with user actions

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class UserActionUtilities
C#
public static class UserActionUtilities
Visual C++
public ref class UserActionUtilities abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.UserActionUtilities

See Also

UserActionUtilities Members
RedGate.SQLCompare.Engine Namespace


UserActionUtilities Members

[image] [image]

SQL Data Compare API 12.0.40
UserActionUtilities Members
UserActionUtilities Class Methods See Also

The UserActionUtilities type exposes the following members.

Methods

Name | Description
GetFieldMappingFQN | Returns a unique name for a field mapping.
GetKeyFQN | Returns a unique name for an index mapping.
GetTableMappingFQN | Returns a unique name for a mapping, this is NOT the same as the unique name used for TableDifferences

See Also

UserActionUtilities Class
RedGate.SQLCompare.Engine Namespace


UserActionUtilities Methods

[image] [image]

SQL Data Compare API 12.0.40
UserActionUtilities Methods
UserActionUtilities Class See Also

The UserActionUtilities type exposes the following methods.

Methods

Name | Description
GetFieldMappingFQN | Returns a unique name for a field mapping.
GetKeyFQN | Returns a unique name for an index mapping.
GetTableMappingFQN | Returns a unique name for a mapping, this is NOT the same as the unique name used for TableDifferences

See Also

UserActionUtilities Class
RedGate.SQLCompare.Engine Namespace


GetFieldMappingFQN Method

[image]

SQL Data Compare API 12.0.40
UserActionUtilities..::.GetFieldMappingFQN Method
UserActionUtilities Class See Also

Returns a unique name for a field mapping.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFieldMappingFQN ( _
    fm As Mapping(Of IField) _
) As String
C#
public static string GetFieldMappingFQN(
    Mapping<IField> fm
)
Visual C++
public:
static String^ GetFieldMappingFQN(
    Mapping<IField^>^ fm
)

Parameters

fm
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( IField >)>)
The field mapping

Return Value

A deterministically unique name

See Also

UserActionUtilities Class
RedGate.SQLCompare.Engine Namespace


GetKeyFQN Method

[image]

SQL Data Compare API 12.0.40
UserActionUtilities..::.GetKeyFQN Method
UserActionUtilities Class See Also

Returns a unique name for an index mapping.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetKeyFQN ( _
    im As Mapping(Of RelationalIndex) _
) As String
C#
public static string GetKeyFQN(
    Mapping<RelationalIndex> im
)
Visual C++
public:
static String^ GetKeyFQN(
    Mapping<RelationalIndex^>^ im
)

Parameters

im
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( RelationalIndex >)>)
The index mapping

Return Value

A deterministically unique name

See Also

UserActionUtilities Class
RedGate.SQLCompare.Engine Namespace


GetTableMappingFQN Method

[image]

SQL Data Compare API 12.0.40
UserActionUtilities..::.GetTableMappingFQN Method
UserActionUtilities Class See Also

Returns a unique name for a mapping, this is NOT the same as the unique name used for TableDifferences

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetTableMappingFQN ( _
    t As Mapping(Of ViewTableSuperClass) _
) As String
C#
public static string GetTableMappingFQN(
    Mapping<ViewTableSuperClass> t
)
Visual C++
public:
static String^ GetTableMappingFQN(
    Mapping<ViewTableSuperClass^>^ t
)

Parameters

t
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( ViewTableSuperClass >)>)
The table mapping

Return Value

a unique name

See Also

UserActionUtilities Class
RedGate.SQLCompare.Engine Namespace


UserActionWarning Structure

[image]

SQL Data Compare API 12.0.40
UserActionWarning Structure
Members See Also

Contains details of a user action that has failed due to schema changes since the project was created.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Structure UserActionWarning
C#
public struct UserActionWarning
Visual C++
public value class UserActionWarning

See Also

UserActionWarning Members
RedGate.SQLCompare.Engine Namespace


UserActionWarning Members

[image] [image]

SQL Data Compare API 12.0.40
UserActionWarning Members
UserActionWarning Structure Methods Properties See Also

The UserActionWarning type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
Message | Textual description of the reason for the failure of the user action.
UserAction | The user action that has failed.

See Also

UserActionWarning Structure
RedGate.SQLCompare.Engine Namespace


UserActionWarning Properties

[image] [image]

SQL Data Compare API 12.0.40
UserActionWarning Properties
UserActionWarning Structure See Also

The UserActionWarning type exposes the following properties.

Properties

Name | Description
Message | Textual description of the reason for the failure of the user action.
UserAction | The user action that has failed.

See Also

UserActionWarning Structure
RedGate.SQLCompare.Engine Namespace


Message Property

[image]

SQL Data Compare API 12.0.40
UserActionWarning..::.Message Property
UserActionWarning Structure See Also

Textual description of the reason for the failure of the user action.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Message As String
C#
public string Message { get; }
Visual C++
public:
property String^ Message {
    String^ get ();
}

See Also

UserActionWarning Structure
RedGate.SQLCompare.Engine Namespace


UserAction Property

[image]

SQL Data Compare API 12.0.40
UserActionWarning..::.UserAction Property
UserActionWarning Structure See Also

The user action that has failed.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UserAction As SelectTableEvent
C#
public SelectTableEvent UserAction { get; }
Visual C++
public:
property SelectTableEvent UserAction {
    SelectTableEvent get ();
}

See Also

UserActionWarning Structure
RedGate.SQLCompare.Engine Namespace


UserDefinedType Class

[image]

SQL Data Compare API 12.0.40
UserDefinedType Class
Members See Also

A user-defined type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class UserDefinedType _
    Inherits SchemaObjectWithAuthorization _
    Implements IDatabaseObject, ITSqlObject, ICanExistenceCheck, IPatchUpAfterDeserialization,  _
    ISqlComparable
C#
public sealed class UserDefinedType : SchemaObjectWithAuthorization, IDatabaseObject,
    ITSqlObject, ICanExistenceCheck, IPatchUpAfterDeserialization, ISqlComparable
Visual C++
public ref class UserDefinedType sealed : public SchemaObjectWithAuthorization,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, IPatchUpAfterDeserialization, ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.SchemaObjectWithAuthorization
RedGate.SQLCompare.Engine..::.UserDefinedType

See Also

UserDefinedType Members
RedGate.SQLCompare.Engine Namespace


UserDefinedType Members

[image] [image]

SQL Data Compare API 12.0.40
UserDefinedType Members
UserDefinedType Class Methods Fields Properties Explicit Interface Implementations See Also

The UserDefinedType type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AllowNulls | True if the user-defined type allows nulls.
AlterAuthorizationClassType | (Inherited from SchemaObjectWithAuthorization.)
Assembly | The CLR assembly for the user-defined type, if this is a CLR user-defined type.
AssemblyClass | The CLR assembly class name for the user-defined type, if this is a CLR user-defined type.
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
BaseTypeName | The name of the underlying type.
CLRObject | True if the user-defined type is a CLR user-defined type.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
Default | The default bound to the user-defined type.
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Length | The length of the user-defined type.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.UserDefinedType (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from SchemaObjectWithAuthorization.)
Precision | The precision of the user-defined type.
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
Rule | The rule bound to the user-defined type.
Scale | The scale of the user-defined type.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSourceForDefault | The location of the creation script for the default binding statement for this object if the database source is set to scripts folder.
ScriptSourceForRule | The location of the creation script for the default binding statement for this object if the database source is set to scripts folder.
ScriptSources | (Inherited from SchemaObject.)
SqlType | The underlying type.
TypeTable | This table contains information about the type if it is a table type. Table types have been introduced in SQL Server 2008.

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

UserDefinedType Class
RedGate.SQLCompare.Engine Namespace


UserDefinedType Methods

[image] [image]

SQL Data Compare API 12.0.40
UserDefinedType Methods
UserDefinedType Class See Also

The UserDefinedType type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

UserDefinedType Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
UserDefinedType..::.ISqlComparable..::.CompareWith Method
UserDefinedType Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    obj As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable obj,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ obj,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

obj
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

UserDefinedType Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
UserDefinedType..::.Equals Method
UserDefinedType Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the user-defined type with a specified user-defined type. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

UserDefinedType Class
UserDefinedType Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
UserDefinedType..::.Equals Method (IDatabaseObject, Options)
UserDefinedType Class See Also

Compares the user-defined type with a specified user-defined type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) override

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The user-defined type to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
The comparison options.

Return Value

True if the user-defined types are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

UserDefinedType Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
UserDefinedType..::.PatchUpAfterDeserialization Method
UserDefinedType Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

UserDefinedType Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
UserDefinedType..::.ScriptObject Method
UserDefinedType Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

UserDefinedType Class
RedGate.SQLCompare.Engine Namespace


UserDefinedType Properties

[image] [image]

SQL Data Compare API 12.0.40
UserDefinedType Properties
UserDefinedType Class See Also

The UserDefinedType type exposes the following properties.

Properties

Name | Description
AllowNulls | True if the user-defined type allows nulls.
AlterAuthorizationClassType | (Inherited from SchemaObjectWithAuthorization.)
Assembly | The CLR assembly for the user-defined type, if this is a CLR user-defined type.
AssemblyClass | The CLR assembly class name for the user-defined type, if this is a CLR user-defined type.
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
BaseTypeName | The name of the underlying type.
CLRObject | True if the user-defined type is a CLR user-defined type.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
Default | The default bound to the user-defined type.
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Length | The length of the user-defined type.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.UserDefinedType (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from SchemaObjectWithAuthorization.)
Precision | The precision of the user-defined type.
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
Rule | The rule bound to the user-defined type.
Scale | The scale of the user-defined type.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSourceForDefault | The location of the creation script for the default binding statement for this object if the database source is set to scripts folder.
ScriptSourceForRule | The location of the creation script for the default binding statement for this object if the database source is set to scripts folder.
ScriptSources | (Inherited from SchemaObject.)
SqlType | The underlying type.
TypeTable | This table contains information about the type if it is a table type. Table types have been introduced in SQL Server 2008.

See Also

UserDefinedType Class
RedGate.SQLCompare.Engine Namespace


AllowNulls Property

[image]

SQL Data Compare API 12.0.40
UserDefinedType..::.AllowNulls Property
UserDefinedType Class See Also

True if the user-defined type allows nulls.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowNulls As Boolean
C#
public bool AllowNulls { get; internal set; }
Visual C++
public:
property bool AllowNulls {
    bool get ();
    void set (bool value);
}

See Also

UserDefinedType Class
RedGate.SQLCompare.Engine Namespace


Assembly Property

[image]

SQL Data Compare API 12.0.40
UserDefinedType..::.Assembly Property
UserDefinedType Class See Also

The CLR assembly for the user-defined type, if this is a CLR user-defined type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Assembly As ClrAssembly
C#
public ClrAssembly Assembly { get; internal set; }
Visual C++
public:
virtual property ClrAssembly^ Assembly {
    ClrAssembly^ get () sealed;
    void set (ClrAssembly^ value) sealed;
}

See Also

UserDefinedType Class
RedGate.SQLCompare.Engine Namespace


AssemblyClass Property

[image]

SQL Data Compare API 12.0.40
UserDefinedType..::.AssemblyClass Property
UserDefinedType Class See Also

The CLR assembly class name for the user-defined type, if this is a CLR user-defined type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyClass As String
C#
public string AssemblyClass { get; internal set; }
Visual C++
public:
property String^ AssemblyClass {
    String^ get ();
    void set (String^ value);
}

See Also

UserDefinedType Class
RedGate.SQLCompare.Engine Namespace


BaseTypeName Property

[image]

SQL Data Compare API 12.0.40
UserDefinedType..::.BaseTypeName Property
UserDefinedType Class See Also

The name of the underlying type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BaseTypeName As String
C#
public string BaseTypeName { get; internal set; }
Visual C++
public:
property String^ BaseTypeName {
    String^ get ();
    void set (String^ value);
}

See Also

UserDefinedType Class
RedGate.SQLCompare.Engine Namespace


CLRObject Property

[image]

SQL Data Compare API 12.0.40
UserDefinedType..::.CLRObject Property
UserDefinedType Class See Also

True if the user-defined type is a CLR user-defined type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CLRObject As Boolean
C#
public bool CLRObject { get; internal set; }
Visual C++
public:
virtual property bool CLRObject {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

UserDefinedType Class
RedGate.SQLCompare.Engine Namespace


Default Property

[image]

SQL Data Compare API 12.0.40
UserDefinedType..::.Default Property
UserDefinedType Class See Also

The default bound to the user-defined type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Default As Default
C#
public Default Default { get; internal set; }
Visual C++
public:
property Default^ Default {
    Default^ get ();
    void set (Default^ value);
}

See Also

UserDefinedType Class
RedGate.SQLCompare.Engine Namespace


Length Property

[image]

SQL Data Compare API 12.0.40
UserDefinedType..::.Length Property
UserDefinedType Class See Also

The length of the user-defined type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Length As Integer
C#
public int Length { get; internal set; }
Visual C++
public:
property int Length {
    int get ();
    void set (int value);
}

See Also

UserDefinedType Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
UserDefinedType..::.ObjectType Property
UserDefinedType Class See Also

Returns ObjectType.UserDefinedType

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()
ITSqlObjectObjectType()()()

See Also

UserDefinedType Class
RedGate.SQLCompare.Engine Namespace


Precision Property

[image]

SQL Data Compare API 12.0.40
UserDefinedType..::.Precision Property
UserDefinedType Class See Also

The precision of the user-defined type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Precision As Integer
C#
public int Precision { get; internal set; }
Visual C++
public:
property int Precision {
    int get ();
    void set (int value);
}

See Also

UserDefinedType Class
RedGate.SQLCompare.Engine Namespace


Rule Property

[image]

SQL Data Compare API 12.0.40
UserDefinedType..::.Rule Property
UserDefinedType Class See Also

The rule bound to the user-defined type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Rule As Rule
C#
public Rule Rule { get; internal set; }
Visual C++
public:
property Rule^ Rule {
    Rule^ get ();
    void set (Rule^ value);
}

See Also

UserDefinedType Class
RedGate.SQLCompare.Engine Namespace


Scale Property

[image]

SQL Data Compare API 12.0.40
UserDefinedType..::.Scale Property
UserDefinedType Class See Also

The scale of the user-defined type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Scale As Integer
C#
public int Scale { get; internal set; }
Visual C++
public:
property int Scale {
    int get ();
    void set (int value);
}

See Also

UserDefinedType Class
RedGate.SQLCompare.Engine Namespace


ScriptSourceForDefault Property

[image]

SQL Data Compare API 12.0.40
UserDefinedType..::.ScriptSourceForDefault Property
UserDefinedType Class See Also

The location of the creation script for the default binding statement for this object if the database source is set to scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSourceForDefault As ScriptSource
C#
public ScriptSource ScriptSourceForDefault { get; internal set; }
Visual C++
public:
property ScriptSource^ ScriptSourceForDefault {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

UserDefinedType Class
RedGate.SQLCompare.Engine Namespace


ScriptSourceForRule Property

[image]

SQL Data Compare API 12.0.40
UserDefinedType..::.ScriptSourceForRule Property
UserDefinedType Class See Also

The location of the creation script for the default binding statement for this object if the database source is set to scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSourceForRule As ScriptSource
C#
public ScriptSource ScriptSourceForRule { get; internal set; }
Visual C++
public:
property ScriptSource^ ScriptSourceForRule {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

UserDefinedType Class
RedGate.SQLCompare.Engine Namespace


SqlType Property

[image]

SQL Data Compare API 12.0.40
UserDefinedType..::.SqlType Property
UserDefinedType Class See Also

The underlying type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SqlType As SqlType
C#
public SqlType SqlType { get; internal set; }
Visual C++
public:
property SqlType SqlType {
    SqlType get ();
    void set (SqlType value);
}

See Also

UserDefinedType Class
RedGate.SQLCompare.Engine Namespace


TypeTable Property

[image]

SQL Data Compare API 12.0.40
UserDefinedType..::.TypeTable Property
UserDefinedType Class See Also

This table contains information about the type if it is a table type. Table types have been introduced in SQL Server 2008.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeTable As Table
C#
public Table TypeTable { get; internal set; }
Visual C++
public:
property Table^ TypeTable {
    Table^ get ();
    void set (Table^ value);
}

See Also

UserDefinedType Class
RedGate.SQLCompare.Engine Namespace


UserDefinedTypes Class

[image]

SQL Data Compare API 12.0.40
UserDefinedTypes Class
Members See Also

A collection of user-defined types.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class UserDefinedTypes _
    Inherits SerializableDatabaseObjectCollection(Of UserDefinedType) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class UserDefinedTypes : SerializableDatabaseObjectCollection<UserDefinedType>, IPatchUpAfterDeserialization
Visual C++
public ref class UserDefinedTypes sealed : public SerializableDatabaseObjectCollection<UserDefinedType^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( UserDefinedType >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( UserDefinedType >)>)
RedGate.SQLCompare.Engine..::.UserDefinedTypes

See Also

UserDefinedTypes Members
RedGate.SQLCompare.Engine Namespace


UserDefinedTypes Members

[image] [image]

SQL Data Compare API 12.0.40
UserDefinedTypes Members
UserDefinedTypes Class Methods Fields Properties Explicit Interface Implementations See Also

The UserDefinedTypes type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortByDependency |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization | Must be run after assemblies and tables are patched up.

See Also

UserDefinedTypes Class
RedGate.SQLCompare.Engine Namespace


UserDefinedTypes Methods

[image] [image]

SQL Data Compare API 12.0.40
UserDefinedTypes Methods
UserDefinedTypes Class See Also

The UserDefinedTypes type exposes the following methods.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortByDependency |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization | Must be run after assemblies and tables are patched up.

See Also

UserDefinedTypes Class
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
UserDefinedTypes..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
UserDefinedTypes Class See Also

Must be run after assemblies and tables are patched up.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

UserDefinedTypes Class
RedGate.SQLCompare.Engine Namespace


SortByDependency Method

[image]

SQL Data Compare API 12.0.40
UserDefinedTypes..::.SortByDependency Method
UserDefinedTypes Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function SortByDependency ( _
    dependencies As Dependencies _
) As IEnumerable(Of UserDefinedType)
C#
public IEnumerable<UserDefinedType> SortByDependency(
    Dependencies dependencies
)
Visual C++
public:
IEnumerable<UserDefinedType^>^ SortByDependency(
    Dependencies^ dependencies
)

Parameters

dependencies
Type: Dependencies

See Also

UserDefinedTypes Class
RedGate.SQLCompare.Engine Namespace


Users Class

[image]

SQL Data Compare API 12.0.40
Users Class
Members See Also

A collection of users.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Users _
    Inherits SerializableDatabaseObjectCollection(Of User) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class Users : SerializableDatabaseObjectCollection<User>, IPatchUpAfterDeserialization
Visual C++
public ref class Users sealed : public SerializableDatabaseObjectCollection<User^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( User >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( User >)>)
RedGate.SQLCompare.Engine..::.Users

See Also

Users Members
RedGate.SQLCompare.Engine Namespace


Users Members

[image] [image]

SQL Data Compare API 12.0.40
Users Members
Users Class Methods Fields Properties Explicit Interface Implementations See Also

The Users type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

Users Class
RedGate.SQLCompare.Engine Namespace


Users Methods

[image] [image]

SQL Data Compare API 12.0.40
Users Methods
Users Class See Also

The Users type exposes the following methods.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

Users Class
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
Users..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
Users Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

Users Class
RedGate.SQLCompare.Engine Namespace


Users Properties

[image] [image]

SQL Data Compare API 12.0.40
Users Properties
Users Class See Also

The Users type exposes the following properties.

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

See Also

Users Class
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
Users..::.Item Property
Users Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Lookup a user first by its fully qualified name (which may include a domain component eg 'DOMAIN\user'), falling back to a lookup without the domain component. (Overrides KeyedCollection <(Of <( T >)>)..::. Item[([(String])]).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Users Class
Users Members
RedGate.SQLCompare.Engine Namespace


Item Property ()

[image]

SQL Data Compare API 12.0.40
Users..::.Item Property ()
Users Class See Also

Lookup a user first by its fully qualified name (which may include a domain component eg 'DOMAIN\user'), falling back to a lookup without the domain component.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Default Property Item ( _
    key As String _
) As User
C#
public override User this[
    string key
] { get; }
Visual C++
public:
virtual property User^ default[String^ key] {
    User^ get (String^ key) override;
}

Parameters

key
Type: String

Return Value

Implements

IKeyedCollectionItem(String)

See Also

Users Class
Item Overload
RedGate.SQLCompare.Engine Namespace


UsersChanges Class

[image]

SQL Data Compare API 12.0.40
UsersChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class UsersChanges
C#
public sealed class UsersChanges
Visual C++
public ref class UsersChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.UsersChanges

See Also

UsersChanges Members
RedGate.SQLCompare.Engine Namespace


UsersChanges Members

[image] [image]

SQL Data Compare API 12.0.40
UsersChanges Members
UsersChanges Class Constructors Methods Properties See Also

The UsersChanges type exposes the following members.

Constructors

Name | Description
UsersChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
UsersToAlter |
UsersToCreate |
UsersToDrop |
UserTargets |

See Also

UsersChanges Class
RedGate.SQLCompare.Engine Namespace


UsersChanges Constructor

[image]

SQL Data Compare API 12.0.40
UsersChanges Constructor
UsersChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public UsersChanges(
    bool caseSensitive
)
Visual C++
public:
UsersChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

UsersChanges Class
RedGate.SQLCompare.Engine Namespace


UsersChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
UsersChanges Properties
UsersChanges Class See Also

The UsersChanges type exposes the following properties.

Properties

Name | Description
UsersToAlter |
UsersToCreate |
UsersToDrop |
UserTargets |

See Also

UsersChanges Class
RedGate.SQLCompare.Engine Namespace


UsersToAlter Property

[image]

SQL Data Compare API 12.0.40
UsersChanges..::.UsersToAlter Property
UsersChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UsersToAlter As Users
C#
public Users UsersToAlter { get; private set; }
Visual C++
public:
property Users^ UsersToAlter {
    Users^ get ();
    void set (Users^ value);
}

See Also

UsersChanges Class
RedGate.SQLCompare.Engine Namespace


UsersToCreate Property

[image]

SQL Data Compare API 12.0.40
UsersChanges..::.UsersToCreate Property
UsersChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UsersToCreate As Users
C#
public Users UsersToCreate { get; private set; }
Visual C++
public:
property Users^ UsersToCreate {
    Users^ get ();
    void set (Users^ value);
}

See Also

UsersChanges Class
RedGate.SQLCompare.Engine Namespace


UsersToDrop Property

[image]

SQL Data Compare API 12.0.40
UsersChanges..::.UsersToDrop Property
UsersChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UsersToDrop As Users
C#
public Users UsersToDrop { get; private set; }
Visual C++
public:
property Users^ UsersToDrop {
    Users^ get ();
    void set (Users^ value);
}

See Also

UsersChanges Class
RedGate.SQLCompare.Engine Namespace


UserTargets Property

[image]

SQL Data Compare API 12.0.40
UsersChanges..::.UserTargets Property
UsersChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UserTargets As Dictionary(Of User, User)
C#
public Dictionary<User, User> UserTargets { get; private set; }
Visual C++
public:
property Dictionary<User^, User^>^ UserTargets {
    Dictionary<User^, User^>^ get ();
    void set (Dictionary<User^, User^>^ value);
}

See Also

UsersChanges Class
RedGate.SQLCompare.Engine Namespace


UserType Enumeration

[image]

SQL Data Compare API 12.0.40
UserType Enumeration
See Also

The type of user.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration UserType
C#
public enum UserType
Visual C++
public enum class UserType

Members

Member name | Description
SqlUser | SQL Server user.
WindowsUser | Windows user.
CertificateUser | Certificate bound user.
AsymmetricKeyUser | Asymmetric key bound user.

See Also

RedGate.SQLCompare.Engine Namespace


Utils Class

[image]

SQL Data Compare API 12.0.40
Utils Class
Members See Also

A class providing utility functions.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Utils
C#
public static class Utils
Visual C++
public ref class Utils abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.Utils

See Also

Utils Members
RedGate.SQLCompare.Engine Namespace


Utils Members

[image] [image]

SQL Data Compare API 12.0.40
Utils Members
Utils Class Methods See Also

The Utils type exposes the following members.

Methods

Name | Description
EncloseInSquareBrackets | Encloses the id in square brackets and escapes closing square brackets.
GetTimeToRun | Overloaded.
IdenticalFreeText | Check if two text are identical, used by extended property comparison to ignore whitespace
PrepareString | Overloaded.
StoreRegistrationTime | Helper method for saving a RegistrationTime metadata

See Also

Utils Class
RedGate.SQLCompare.Engine Namespace


Utils Methods

[image] [image]

SQL Data Compare API 12.0.40
Utils Methods
Utils Class See Also

The Utils type exposes the following methods.

Methods

Name | Description
EncloseInSquareBrackets | Encloses the id in square brackets and escapes closing square brackets.
GetTimeToRun | Overloaded.
IdenticalFreeText | Check if two text are identical, used by extended property comparison to ignore whitespace
PrepareString | Overloaded.
StoreRegistrationTime | Helper method for saving a RegistrationTime metadata

See Also

Utils Class
RedGate.SQLCompare.Engine Namespace


EncloseInSquareBrackets Method

[image]

SQL Data Compare API 12.0.40
Utils..::.EncloseInSquareBrackets Method
Utils Class See Also

Encloses the id in square brackets and escapes closing square brackets.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function EncloseInSquareBrackets ( _
    id As String _
) As String
C#
public static string EncloseInSquareBrackets(
    string id
)
Visual C++
public:
static String^ EncloseInSquareBrackets(
    String^ id
)

Parameters

id
Type: String

Return Value

See Also

Utils Class
RedGate.SQLCompare.Engine Namespace


GetTimeToRun Method

[image] [image]

SQL Data Compare API 12.0.40
Utils..::.GetTimeToRun Method
Utils Class See Also

Overload List

Name | Description
GetTimeToRun(Action) | Time how long action takes
GetTimeToRun<(Of <(T>)>)(Func<(Of <(T>)>)) | Time how long action takes

See Also

Utils Class
Utils Members
RedGate.SQLCompare.Engine Namespace


GetTimeToRun Method ()

[image]

SQL Data Compare API 12.0.40
Utils..::.GetTimeToRun Method ()
Utils Class See Also

Time how long action takes

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetTimeToRun ( _
    action As Action _
) As TimeSpan
C#
public static TimeSpan GetTimeToRun(
    Action action
)
Visual C++
public:
static TimeSpan GetTimeToRun(
    Action^ action
)

Parameters

action
Type: Action

See Also

Utils Class
GetTimeToRun Overload
RedGate.SQLCompare.Engine Namespace


GetTimeToRun(T) Generic Method ((T))

[image]

SQL Data Compare API 12.0.40
Utils..::.GetTimeToRun<(Of <(T>)>) Generic Method (<(Of <(T>)>))
Utils Class See Also

Time how long action takes

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetTimeToRun(Of T) ( _
    action As Func(Of T) _
) As Utils..::.ResultWithDuration(Of T)
C#
public static Utils..::.ResultWithDuration<T> GetTimeToRun<T>(
    Func<T> action
)
Visual C++
public:
generic<typename T>
static Utils..::.ResultWithDuration<T>^ GetTimeToRun(
    Func<T>^ action
)

Parameters

action
Type: Func<(Of <(T>)>)

Type Parameters

T

See Also

Utils Class
GetTimeToRun Overload
RedGate.SQLCompare.Engine Namespace


IdenticalFreeText Method

[image]

SQL Data Compare API 12.0.40
Utils..::.IdenticalFreeText Method
Utils Class See Also

Check if two text are identical, used by extended property comparison to ignore whitespace

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IdenticalFreeText ( _
    left As String, _
    right As String, _
    options As Options _
) As Boolean
C#
public static bool IdenticalFreeText(
    string left,
    string right,
    Options options
)
Visual C++
public:
static bool IdenticalFreeText(
    String^ left,
    String^ right,
    Options options
)

Parameters

left
Type: String
right
Type: String
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

Utils Class
RedGate.SQLCompare.Engine Namespace


PrepareString Method

[image] [image]

SQL Data Compare API 12.0.40
Utils..::.PrepareString Method
Utils Class See Also

Overload List

Name | Description
PrepareString(MappingOptions, String) | Returns a string that is reduced to it's basic components for quick comparison.
PrepareString(MappingOptions, IDatabaseObject, Boolean) | Returns a string that is reduced to it's basic components for quick comparison.

See Also

Utils Class
Utils Members
RedGate.SQLCompare.Engine Namespace


PrepareString Method (MappingOptions, )

[image]

SQL Data Compare API 12.0.40
Utils..::.PrepareString Method (MappingOptions, )
Utils Class See Also

Returns a string that is reduced to it's basic components for quick comparison.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function PrepareString ( _
    mappingOptions As MappingOptions, _
    name As String _
) As String
C#
public static string PrepareString(
    MappingOptions mappingOptions,
    string name
)
Visual C++
public:
static String^ PrepareString(
    MappingOptions mappingOptions,
    String^ name
)

Parameters

mappingOptions
Type: RedGate.SQLCompare.Engine..::.MappingOptions
Mapping options to use for string transformation.
name
Type: String
The name to be prepared.

Return Value

string lowered, removed spaces, removed underscores, removed prefix according to settings.

See Also

Utils Class
PrepareString Overload
RedGate.SQLCompare.Engine Namespace


PrepareString Method (MappingOptions, IDatabaseObject, )

[image]

SQL Data Compare API 12.0.40
Utils..::.PrepareString Method (MappingOptions, IDatabaseObject, )
Utils Class See Also

Returns a string that is reduced to it's basic components for quick comparison.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function PrepareString ( _
    mappingOptions As MappingOptions, _
    obj1 As IDatabaseObject, _
    fullName As Boolean _
) As String
C#
public static string PrepareString(
    MappingOptions mappingOptions,
    IDatabaseObject obj1,
    bool fullName
)
Visual C++
public:
static String^ PrepareString(
    MappingOptions mappingOptions,
    IDatabaseObject^ obj1,
    bool fullName
)

Parameters

mappingOptions
Type: RedGate.SQLCompare.Engine..::.MappingOptions
Mapping options to use for string transformation.
obj1
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
Object whose name is to be prepared.
fullName
Type: Boolean
Use the FullyQualifiedName or just Name

Return Value

string lowered, removed spaces, removed underscores, removed prefix according to settings.

See Also

Utils Class
PrepareString Overload
RedGate.SQLCompare.Engine Namespace


StoreRegistrationTime Method

[image]

SQL Data Compare API 12.0.40
Utils..::.StoreRegistrationTime Method
Utils Class See Also

Helper method for saving a RegistrationTime metadata

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub StoreRegistrationTime ( _
    metadata As IMetadata, _
    duration As TimeSpan _
)
C#
public static void StoreRegistrationTime(
    IMetadata metadata,
    TimeSpan duration
)
Visual C++
public:
static void StoreRegistrationTime(
    IMetadata^ metadata,
    TimeSpan duration
)

Parameters

metadata
Type: RedGate.SQLCompare.Engine..::.IMetadata
duration
Type: TimeSpan

See Also

Utils Class
RedGate.SQLCompare.Engine Namespace


Utils.ResultWithDuration(T) Generic Class

[image]

SQL Data Compare API 12.0.40
Utils..::.ResultWithDuration<(Of <(T>)>) Generic Class
Utils Class Members See Also

Helper class for returning both the result of an operation and the time the operation took

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ResultWithDuration(Of T)
C#
public class ResultWithDuration<T>
Visual C++
generic<typename T>
public ref class ResultWithDuration

Type Parameters

T

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.Utils..::.ResultWithDuration<(Of <(T>)>)

See Also

Utils..::.ResultWithDuration<(Of <(T>)>) Members
RedGate.SQLCompare.Engine Namespace


Utils.ResultWithDuration(T) Members

[image] [image]

SQL Data Compare API 12.0.40
Utils..::.ResultWithDuration<(Of <(T>)>) Members
Utils..::.ResultWithDuration<(Of <(T>)>) Class Constructors Methods Properties See Also

A class providing utility functions.

The Utils..::.ResultWithDuration<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
Utils..::.ResultWithDuration<(Of <(T>)>) |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Duration |
Result |

See Also

Utils..::.ResultWithDuration<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


Utils.ResultWithDuration(T) Constructor

[image]

SQL Data Compare API 12.0.40
Utils..::.ResultWithDuration<(Of <(T>)>) Constructor
Utils..::.ResultWithDuration<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    result As T, _
    duration As TimeSpan _
)
C#
public ResultWithDuration(
    T result,
    TimeSpan duration
)
Visual C++
public:
ResultWithDuration(
    T result,
    TimeSpan duration
)

Parameters

result
Type: T
duration
Type: TimeSpan

See Also

Utils..::.ResultWithDuration<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


Utils.ResultWithDuration(T) Properties

[image] [image]

SQL Data Compare API 12.0.40
Utils..::.ResultWithDuration<(Of <(T>)>) Properties
Utils..::.ResultWithDuration<(Of <(T>)>) Class See Also

The Utils..::.ResultWithDuration<(Of <(T>)>) type exposes the following properties.

Properties

Name | Description
Duration |
Result |

See Also

Utils..::.ResultWithDuration<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


Duration Property

[image]

SQL Data Compare API 12.0.40
Utils..::.ResultWithDuration<(Of <(T>)>)..::.Duration Property
Utils..::.ResultWithDuration<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Duration As TimeSpan
C#
public TimeSpan Duration { get; }
Visual C++
public:
property TimeSpan Duration {
    TimeSpan get ();
}

See Also

Utils..::.ResultWithDuration<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


Result Property

[image]

SQL Data Compare API 12.0.40
Utils..::.ResultWithDuration<(Of <(T>)>)..::.Result Property
Utils..::.ResultWithDuration<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As T
C#
public T Result { get; }
Visual C++
public:
property T Result {
    T get ();
}

See Also

Utils..::.ResultWithDuration<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


View Class

[image]

SQL Data Compare API 12.0.40
View Class
Members See Also

A view.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class View _
    Inherits ViewTableSuperClass _
    Implements IEncryptedTextObject, ITextObject, IDatabaseObject, ITSqlObject,  _
    ICanExistenceCheck, ISessionSetObject, IPatchUpAfterDeserialization, ISqlComparable, IHasLastModifiedDate
C#
public sealed class View : ViewTableSuperClass, IEncryptedTextObject,
    ITextObject, IDatabaseObject, ITSqlObject, ICanExistenceCheck, ISessionSetObject,
    IPatchUpAfterDeserialization, ISqlComparable, IHasLastModifiedDate
Visual C++
public ref class View sealed : public ViewTableSuperClass,
    IEncryptedTextObject, ITextObject, IDatabaseObject, ITSqlObject, ICanExistenceCheck,
    ISessionSetObject, IPatchUpAfterDeserialization, ISqlComparable, IHasLastModifiedDate

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.SchemaObjectWithAuthorization
RedGate.SQLCompare.Engine..::.ViewTableSuperClass
RedGate.SQLCompare.Engine..::.View

See Also

View Members
RedGate.SQLCompare.Engine Namespace


View Members

[image] [image]

SQL Data Compare API 12.0.40
View Members
View Class Methods Fields Properties Explicit Interface Implementations See Also

The View type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSql |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
SetSessionOptions |
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Fields

Name | Description
m_Fields | Fields. (Inherited from ViewTableSuperClass.)
m_Indexes | Indexes. (Inherited from ViewTableSuperClass.)
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AlterAuthorizationClassType | (Inherited from SchemaObjectWithAuthorization.)
AnsiNullsOn | True if the view was created with ansi nulls on.
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
CatalogUsedForFullTextIndex | The full-text catalog used for the full-text index defined on the table or view (Inherited from ViewTableSuperClass.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
Encrypted | Identifies whether the view is encrypted.
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
Fields | The fields belonging to the table or view. (Inherited from ViewTableSuperClass.)
FullTextCatalogNameFromSerialization | (Inherited from ViewTableSuperClass.)
FullTextChangeTracking | The change tracking setting for the full text index. (Inherited from ViewTableSuperClass.)
FullTextSearchPropertyList | The search property list attached the full-text index (if both exist) (Inherited from ViewTableSuperClass.)
FullTextSPLNameFromSerialization | Name (Inherited from ViewTableSuperClass.)
FullTextStoplist | The user-defined stoplist for the full text index on the table or view. (Inherited from ViewTableSuperClass.)
FullTextStoplistNameFromSerialization | (Inherited from ViewTableSuperClass.)
FullTextStoplistType | The stoplist type used for the full text index on the table or view. (Inherited from ViewTableSuperClass.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
HasFullTextIndex | True if the table or view has a full-text index defined on it (Inherited from ViewTableSuperClass.)
Indexes | The indexes defined on the table or view. (Inherited from ViewTableSuperClass.)
IsColumnstoreIndexed | Returns true iff the table has a columnstore index defined on it. (Inherited from ViewTableSuperClass.)
KeyIndexForFullTextIndex | The key index for the full-text index on the table or view. (Inherited from ViewTableSuperClass.)
LastModified |
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.View (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from SchemaObjectWithAuthorization.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
QuotedIdentifierOn | True if the view was created with quoted identifiers on.
SchemaBound | True if the view is schema bound.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSourceForFullTextTable | The location of the creation script for the fulltext table statement for this table or view if the database source is set to scripts folder. (Inherited from ViewTableSuperClass.)
ScriptSources | (Inherited from ViewTableSuperClass.)
Text | The text of the view.
Triggers | The triggers defined on the table or view. (Inherited from ViewTableSuperClass.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |
IEncryptedTextObject..::.TextID |

See Also

View Class
RedGate.SQLCompare.Engine Namespace


View Methods

[image] [image]

SQL Data Compare API 12.0.40
View Methods
View Class See Also

The View type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSql |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
SetSessionOptions |
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

View Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
View..::.ISqlComparable..::.CompareWith Method
View Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    other As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable other,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ other,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

other
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

View Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
View..::.Equals Method
View Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the view with a specified view. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

View Class
View Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
View..::.Equals Method (IDatabaseObject, Options)
View Class See Also

Compares the view with a specified view.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) override

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The view to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the views are identical; otherwise false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

View Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


GetSql Method

[image]

SQL Data Compare API 12.0.40
View..::.GetSql Method
View Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSql ( _
    options As Options, _
    targetIsEncrypted As Boolean, _
    useAlter As Boolean, _
    targetFeatures As IFeatureChecker _
) As String
C#
public string GetSql(
    Options options,
    bool targetIsEncrypted,
    bool useAlter,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual String^ GetSql(
    Options options,
    bool targetIsEncrypted,
    bool useAlter,
    IFeatureChecker^ targetFeatures
) sealed

Parameters

options
Type: RedGate.SQLCompare.Engine..::.Options
targetIsEncrypted
Type: Boolean
useAlter
Type: Boolean
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Implements

IEncryptedTextObject..::.GetSql(Options, Boolean, Boolean, IFeatureChecker)

See Also

View Class
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
View..::.PatchUpAfterDeserialization Method
View Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

View Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
View..::.ScriptObject Method
View Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

View Class
RedGate.SQLCompare.Engine Namespace


SetSessionOptions Method

[image]

SQL Data Compare API 12.0.40
View..::.SetSessionOptions Method
View Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetSessionOptions ( _
    ansiNulls As Boolean, _
    quotedIdentifier As Boolean _
)
C#
public void SetSessionOptions(
    bool ansiNulls,
    bool quotedIdentifier
)
Visual C++
public:
virtual void SetSessionOptions(
    bool ansiNulls,
    bool quotedIdentifier
) sealed

Parameters

ansiNulls
Type: Boolean
quotedIdentifier
Type: Boolean

Implements

ISessionSetObject..::.SetSessionOptions(Boolean, Boolean)

See Also

View Class
RedGate.SQLCompare.Engine Namespace


View Properties

[image] [image]

SQL Data Compare API 12.0.40
View Properties
View Class See Also

The View type exposes the following properties.

Properties

Name | Description
AlterAuthorizationClassType | (Inherited from SchemaObjectWithAuthorization.)
AnsiNullsOn | True if the view was created with ansi nulls on.
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
CatalogUsedForFullTextIndex | The full-text catalog used for the full-text index defined on the table or view (Inherited from ViewTableSuperClass.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
Encrypted | Identifies whether the view is encrypted.
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
Fields | The fields belonging to the table or view. (Inherited from ViewTableSuperClass.)
FullTextCatalogNameFromSerialization | (Inherited from ViewTableSuperClass.)
FullTextChangeTracking | The change tracking setting for the full text index. (Inherited from ViewTableSuperClass.)
FullTextSearchPropertyList | The search property list attached the full-text index (if both exist) (Inherited from ViewTableSuperClass.)
FullTextSPLNameFromSerialization | Name (Inherited from ViewTableSuperClass.)
FullTextStoplist | The user-defined stoplist for the full text index on the table or view. (Inherited from ViewTableSuperClass.)
FullTextStoplistNameFromSerialization | (Inherited from ViewTableSuperClass.)
FullTextStoplistType | The stoplist type used for the full text index on the table or view. (Inherited from ViewTableSuperClass.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
HasFullTextIndex | True if the table or view has a full-text index defined on it (Inherited from ViewTableSuperClass.)
Indexes | The indexes defined on the table or view. (Inherited from ViewTableSuperClass.)
IsColumnstoreIndexed | Returns true iff the table has a columnstore index defined on it. (Inherited from ViewTableSuperClass.)
KeyIndexForFullTextIndex | The key index for the full-text index on the table or view. (Inherited from ViewTableSuperClass.)
LastModified |
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.View (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from SchemaObjectWithAuthorization.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
QuotedIdentifierOn | True if the view was created with quoted identifiers on.
SchemaBound | True if the view is schema bound.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSourceForFullTextTable | The location of the creation script for the fulltext table statement for this table or view if the database source is set to scripts folder. (Inherited from ViewTableSuperClass.)
ScriptSources | (Inherited from ViewTableSuperClass.)
Text | The text of the view.
Triggers | The triggers defined on the table or view. (Inherited from ViewTableSuperClass.)

Explicit Interface Implementations

Name | Description
IEncryptedTextObject..::.TextID |

See Also

View Class
RedGate.SQLCompare.Engine Namespace


AnsiNullsOn Property

[image]

SQL Data Compare API 12.0.40
View..::.AnsiNullsOn Property
View Class See Also

True if the view was created with ansi nulls on.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AnsiNullsOn As Boolean
C#
public bool AnsiNullsOn { get; internal set; }
Visual C++
public:
virtual property bool AnsiNullsOn {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

ISessionSetObject..::.AnsiNullsOn

See Also

View Class
RedGate.SQLCompare.Engine Namespace


Encrypted Property

[image]

SQL Data Compare API 12.0.40
View..::.Encrypted Property
View Class See Also

Identifies whether the view is encrypted.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Encrypted As Boolean
C#
public bool Encrypted { get; internal set; }
Visual C++
public:
virtual property bool Encrypted {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IEncryptedTextObject..::.Encrypted

See Also

View Class
RedGate.SQLCompare.Engine Namespace


LastModified Property

[image]

SQL Data Compare API 12.0.40
View..::.LastModified Property
View Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LastModified As DateTime
C#
public DateTime LastModified { get; internal set; }
Visual C++
public:
virtual property DateTime LastModified {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}

Implements

IHasLastModifiedDate..::.LastModified

See Also

View Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
View..::.ObjectType Property
View Class See Also

Returns ObjectType.View

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()
ITSqlObjectObjectType()()()

See Also

View Class
RedGate.SQLCompare.Engine Namespace


QuotedIdentifierOn Property

[image]

SQL Data Compare API 12.0.40
View..::.QuotedIdentifierOn Property
View Class See Also

True if the view was created with quoted identifiers on.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property QuotedIdentifierOn As Boolean
C#
public bool QuotedIdentifierOn { get; internal set; }
Visual C++
public:
virtual property bool QuotedIdentifierOn {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

ISessionSetObject..::.QuotedIdentifierOn

See Also

View Class
RedGate.SQLCompare.Engine Namespace


SchemaBound Property

[image]

SQL Data Compare API 12.0.40
View..::.SchemaBound Property
View Class See Also

True if the view is schema bound.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SchemaBound As Boolean
C#
public bool SchemaBound { get; internal set; }
Visual C++
public:
property bool SchemaBound {
    bool get ();
    void set (bool value);
}

See Also

View Class
RedGate.SQLCompare.Engine Namespace


Text Property

[image]

SQL Data Compare API 12.0.40
View..::.Text Property
View Class See Also

The text of the view.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
C#
public string Text { get; }
Visual C++
public:
virtual property String^ Text {
    String^ get () sealed;
}

Implements

ITextObject..::.Text

See Also

View Class
RedGate.SQLCompare.Engine Namespace


IEncryptedTextObject.TextID Property

[image]

SQL Data Compare API 12.0.40
View..::.IEncryptedTextObject..::.TextID Property
View Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private ReadOnly Property TextID As Integer
    Implements IEncryptedTextObject.TextID
C#
int IEncryptedTextObject.TextID { get; }
Visual C++
private:
virtual property int TextID {
    int get () sealed = IEncryptedTextObject::TextID::get;
}

Implements

IEncryptedTextObject..::.TextID

See Also

View Class
RedGate.SQLCompare.Engine Namespace


Views Class

[image]

SQL Data Compare API 12.0.40
Views Class
Members See Also

A collection of views.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Views _
    Inherits SerializableDatabaseObjectCollection(Of View) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class Views : SerializableDatabaseObjectCollection<View>, IPatchUpAfterDeserialization
Visual C++
public ref class Views sealed : public SerializableDatabaseObjectCollection<View^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( View >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( View >)>)
RedGate.SQLCompare.Engine..::.Views

See Also

Views Members
RedGate.SQLCompare.Engine Namespace


Views Members

[image] [image]

SQL Data Compare API 12.0.40
Views Members
Views Class Methods Fields Properties Explicit Interface Implementations See Also

The Views type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

Views Class
RedGate.SQLCompare.Engine Namespace


Views Methods

[image] [image]

SQL Data Compare API 12.0.40
Views Methods
Views Class See Also

The Views type exposes the following methods.

Methods

Name | Description
Add | Overloaded.
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization |

See Also

Views Class
RedGate.SQLCompare.Engine Namespace


Add Method

[image] [image]

SQL Data Compare API 12.0.40
Views..::.Add Method
Views Class See Also

Overload List

Name | Description
Add(T) | (Inherited from KeyedCollection<(Of <(T>)>).)
Add(View) | (Overrides SerializableDatabaseObjectCollection <(Of <( View >)>)..::. Add(T).)

See Also

Views Class
Views Members
RedGate.SQLCompare.Engine Namespace


Add Method (View)

[image]

SQL Data Compare API 12.0.40
Views..::.Add Method (View)
Views Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Add ( _
    value As View _
)
C#
public override void Add(
    View value
)
Visual C++
public:
virtual void Add(
    View^ value
) override

Parameters

value
Type: RedGate.SQLCompare.Engine..::.View

See Also

Views Class
Add Overload
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
Views..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
Views Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

Views Class
RedGate.SQLCompare.Engine Namespace


ViewsAndTables Class

[image]

SQL Data Compare API 12.0.40
ViewsAndTables Class
Members See Also

A collection of Views and Tables.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ViewsAndTables _
    Inherits KeyedCollection(Of ViewTableSuperClass)
C#
public sealed class ViewsAndTables : KeyedCollection<ViewTableSuperClass>
Visual C++
public ref class ViewsAndTables sealed : public KeyedCollection<ViewTableSuperClass^>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( ViewTableSuperClass >)>)
RedGate.SQLCompare.Engine..::.ViewsAndTables

See Also

ViewsAndTables Members
RedGate.SQLCompare.Engine Namespace


ViewsAndTables Members

[image] [image]

SQL Data Compare API 12.0.40
ViewsAndTables Members
ViewsAndTables Class Methods Fields Properties Explicit Interface Implementations See Also

The ViewsAndTables type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

ViewsAndTables Class
RedGate.SQLCompare.Engine Namespace


ViewsChanges Class

[image]

SQL Data Compare API 12.0.40
ViewsChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ViewsChanges
C#
public sealed class ViewsChanges
Visual C++
public ref class ViewsChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ViewsChanges

See Also

ViewsChanges Members
RedGate.SQLCompare.Engine Namespace


ViewsChanges Members

[image] [image]

SQL Data Compare API 12.0.40
ViewsChanges Members
ViewsChanges Class Constructors Methods Properties See Also

The ViewsChanges type exposes the following members.

Constructors

Name | Description
ViewsChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ViewsToAlter |
ViewsToCreate |
ViewsToDrop |
ViewsToRefresh |
ViewTargets |

See Also

ViewsChanges Class
RedGate.SQLCompare.Engine Namespace


ViewsChanges Constructor

[image]

SQL Data Compare API 12.0.40
ViewsChanges Constructor
ViewsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public ViewsChanges(
    bool caseSensitive
)
Visual C++
public:
ViewsChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

ViewsChanges Class
RedGate.SQLCompare.Engine Namespace


ViewsChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
ViewsChanges Properties
ViewsChanges Class See Also

The ViewsChanges type exposes the following properties.

Properties

Name | Description
ViewsToAlter |
ViewsToCreate |
ViewsToDrop |
ViewsToRefresh |
ViewTargets |

See Also

ViewsChanges Class
RedGate.SQLCompare.Engine Namespace


ViewsToAlter Property

[image]

SQL Data Compare API 12.0.40
ViewsChanges..::.ViewsToAlter Property
ViewsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ViewsToAlter As Views
C#
public Views ViewsToAlter { get; private set; }
Visual C++
public:
property Views^ ViewsToAlter {
    Views^ get ();
    void set (Views^ value);
}

See Also

ViewsChanges Class
RedGate.SQLCompare.Engine Namespace


ViewsToCreate Property

[image]

SQL Data Compare API 12.0.40
ViewsChanges..::.ViewsToCreate Property
ViewsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ViewsToCreate As Views
C#
public Views ViewsToCreate { get; private set; }
Visual C++
public:
property Views^ ViewsToCreate {
    Views^ get ();
    void set (Views^ value);
}

See Also

ViewsChanges Class
RedGate.SQLCompare.Engine Namespace


ViewsToDrop Property

[image]

SQL Data Compare API 12.0.40
ViewsChanges..::.ViewsToDrop Property
ViewsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ViewsToDrop As Views
C#
public Views ViewsToDrop { get; private set; }
Visual C++
public:
property Views^ ViewsToDrop {
    Views^ get ();
    void set (Views^ value);
}

See Also

ViewsChanges Class
RedGate.SQLCompare.Engine Namespace


ViewsToRefresh Property

[image]

SQL Data Compare API 12.0.40
ViewsChanges..::.ViewsToRefresh Property
ViewsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ViewsToRefresh As Views
C#
public Views ViewsToRefresh { get; private set; }
Visual C++
public:
property Views^ ViewsToRefresh {
    Views^ get ();
    void set (Views^ value);
}

See Also

ViewsChanges Class
RedGate.SQLCompare.Engine Namespace


ViewTargets Property

[image]

SQL Data Compare API 12.0.40
ViewsChanges..::.ViewTargets Property
ViewsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ViewTargets As Dictionary(Of View, View)
C#
public Dictionary<View, View> ViewTargets { get; private set; }
Visual C++
public:
property Dictionary<View^, View^>^ ViewTargets {
    Dictionary<View^, View^>^ get ();
    void set (Dictionary<View^, View^>^ value);
}

See Also

ViewsChanges Class
RedGate.SQLCompare.Engine Namespace


ViewTableFulltextChangesCalculator Class

[image]

SQL Data Compare API 12.0.40
ViewTableFulltextChangesCalculator Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ViewTableFulltextChangesCalculator
C#
public class ViewTableFulltextChangesCalculator
Visual C++
public ref class ViewTableFulltextChangesCalculator

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ViewTableFulltextChangesCalculator

See Also

ViewTableFulltextChangesCalculator Members
RedGate.SQLCompare.Engine Namespace


ViewTableFulltextChangesCalculator Members

[image] [image]

SQL Data Compare API 12.0.40
ViewTableFulltextChangesCalculator Members
ViewTableFulltextChangesCalculator Class Constructors Methods See Also

The ViewTableFulltextChangesCalculator type exposes the following members.

Constructors

Name | Description
ViewTableFulltextChangesCalculator |

Methods

Name | Description
CalculateWorkFulltexts |
CalculateWorkFullTextVtscCreate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewTableFulltextChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


ViewTableFulltextChangesCalculator Constructor

[image]

SQL Data Compare API 12.0.40
ViewTableFulltextChangesCalculator Constructor
ViewTableFulltextChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fulltextChanges As FulltextChanges _
)
C#
public ViewTableFulltextChangesCalculator(
    FulltextChanges fulltextChanges
)
Visual C++
public:
ViewTableFulltextChangesCalculator(
    FulltextChanges^ fulltextChanges
)

Parameters

fulltextChanges
Type: RedGate.SQLCompare.Engine..::.FulltextChanges

See Also

ViewTableFulltextChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


ViewTableFulltextChangesCalculator Methods

[image] [image]

SQL Data Compare API 12.0.40
ViewTableFulltextChangesCalculator Methods
ViewTableFulltextChangesCalculator Class See Also

The ViewTableFulltextChangesCalculator type exposes the following methods.

Methods

Name | Description
CalculateWorkFulltexts |
CalculateWorkFullTextVtscCreate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewTableFulltextChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


CalculateWorkFulltexts Method

[image]

SQL Data Compare API 12.0.40
ViewTableFulltextChangesCalculator..::.CalculateWorkFulltexts Method
ViewTableFulltextChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculateWorkFulltexts ( _
    vtsc As ViewTableSuperClass, _
    targetVtsc As ViewTableSuperClass, _
    sourceDatabase As IDatabase, _
    targetDatabase As IDatabase, _
    fieldsToDrop As Fields, _
    fieldsToRename As Fields, _
    options As Options _
)
C#
public void CalculateWorkFulltexts(
    ViewTableSuperClass vtsc,
    ViewTableSuperClass targetVtsc,
    IDatabase sourceDatabase,
    IDatabase targetDatabase,
    Fields fieldsToDrop,
    Fields fieldsToRename,
    Options options
)
Visual C++
public:
void CalculateWorkFulltexts(
    ViewTableSuperClass^ vtsc,
    ViewTableSuperClass^ targetVtsc,
    IDatabase^ sourceDatabase,
    IDatabase^ targetDatabase,
    Fields^ fieldsToDrop,
    Fields^ fieldsToRename,
    Options options
)

Parameters

vtsc
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
targetVtsc
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
sourceDatabase
Type: RedGate.SQLCompare.Engine..::.IDatabase
targetDatabase
Type: RedGate.SQLCompare.Engine..::.IDatabase
fieldsToDrop
Type: RedGate.SQLCompare.Engine..::.Fields
fieldsToRename
Type: RedGate.SQLCompare.Engine..::.Fields
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

ViewTableFulltextChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


CalculateWorkFullTextVtscCreate Method

[image]

SQL Data Compare API 12.0.40
ViewTableFulltextChangesCalculator..::.CalculateWorkFullTextVtscCreate Method
ViewTableFulltextChangesCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculateWorkFullTextVtscCreate ( _
    vtsc As ViewTableSuperClass, _
    options As Options _
)
C#
public void CalculateWorkFullTextVtscCreate(
    ViewTableSuperClass vtsc,
    Options options
)
Visual C++
public:
void CalculateWorkFullTextVtscCreate(
    ViewTableSuperClass^ vtsc,
    Options options
)

Parameters

vtsc
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

ViewTableFulltextChangesCalculator Class
RedGate.SQLCompare.Engine Namespace


ViewTableSuperClass Class

[image]

SQL Data Compare API 12.0.40
ViewTableSuperClass Class
Members See Also

A view or table superclass.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class ViewTableSuperClass _
    Inherits SchemaObjectWithAuthorization _
    Implements IDatabaseObject, ITSqlObject, ICanExistenceCheck, IIsSystemObject
C#
public abstract class ViewTableSuperClass : SchemaObjectWithAuthorization, IDatabaseObject,
    ITSqlObject, ICanExistenceCheck, IIsSystemObject
Visual C++
public ref class ViewTableSuperClass abstract : public SchemaObjectWithAuthorization,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, IIsSystemObject

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.SchemaObjectWithAuthorization
RedGate.SQLCompare.Engine..::.ViewTableSuperClass
RedGate.SQLCompare.Engine..::.Table
RedGate.SQLCompare.Engine..::.View

See Also

ViewTableSuperClass Members
RedGate.SQLCompare.Engine Namespace


ViewTableSuperClass Members

[image] [image]

SQL Data Compare API 12.0.40
ViewTableSuperClass Members
ViewTableSuperClass Class Methods Fields Properties See Also

The ViewTableSuperClass type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Inherited from ScriptableDatabaseObject.)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Fields

Name | Description
m_Fields | Fields.
m_Indexes | Indexes.
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AlterAuthorizationClassType | (Inherited from SchemaObjectWithAuthorization.)
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
CatalogUsedForFullTextIndex | The full-text catalog used for the full-text index defined on the table or view
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
Fields | The fields belonging to the table or view.
FullTextCatalogNameFromSerialization |
FullTextChangeTracking | The change tracking setting for the full text index.
FullTextSearchPropertyList | The search property list attached the full-text index (if both exist)
FullTextSPLNameFromSerialization | Name
FullTextStoplist | The user-defined stoplist for the full text index on the table or view.
FullTextStoplistNameFromSerialization |
FullTextStoplistType | The stoplist type used for the full text index on the table or view.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
HasFullTextIndex | True if the table or view has a full-text index defined on it
Indexes | The indexes defined on the table or view.
IsColumnstoreIndexed | Returns true iff the table has a columnstore index defined on it.
KeyIndexForFullTextIndex | The key index for the full-text index on the table or view.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | The type of the object. (Inherited from ScriptableDatabaseObject.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from SchemaObjectWithAuthorization.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSourceForFullTextTable | The location of the creation script for the fulltext table statement for this table or view if the database source is set to scripts folder.
ScriptSources | (Overrides SchemaObject ..::. ScriptSources.)
Triggers | The triggers defined on the table or view.

See Also

ViewTableSuperClass Class
RedGate.SQLCompare.Engine Namespace


ViewTableSuperClass Fields

[image] [image]

SQL Data Compare API 12.0.40
ViewTableSuperClass Fields
ViewTableSuperClass Class See Also

The ViewTableSuperClass type exposes the following fields.

Fields

Name | Description
m_Fields | Fields.
m_Indexes | Indexes.
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

See Also

ViewTableSuperClass Class
RedGate.SQLCompare.Engine Namespace


m_Fields Field

[image]

SQL Data Compare API 12.0.40
ViewTableSuperClass..::.m_Fields Field
ViewTableSuperClass Class See Also

Fields.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Fields As Fields
C#
protected Fields m_Fields
Visual C++
protected:
Fields^ m_Fields

See Also

ViewTableSuperClass Class
RedGate.SQLCompare.Engine Namespace


m_Indexes Field

[image]

SQL Data Compare API 12.0.40
ViewTableSuperClass..::.m_Indexes Field
ViewTableSuperClass Class See Also

Indexes.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Indexes As Indexes
C#
protected Indexes m_Indexes
Visual C++
protected:
Indexes^ m_Indexes

See Also

ViewTableSuperClass Class
RedGate.SQLCompare.Engine Namespace


ViewTableSuperClass Properties

[image] [image]

SQL Data Compare API 12.0.40
ViewTableSuperClass Properties
ViewTableSuperClass Class See Also

The ViewTableSuperClass type exposes the following properties.

Properties

Name | Description
AlterAuthorizationClassType | (Inherited from SchemaObjectWithAuthorization.)
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
CatalogUsedForFullTextIndex | The full-text catalog used for the full-text index defined on the table or view
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
Fields | The fields belonging to the table or view.
FullTextCatalogNameFromSerialization |
FullTextChangeTracking | The change tracking setting for the full text index.
FullTextSearchPropertyList | The search property list attached the full-text index (if both exist)
FullTextSPLNameFromSerialization | Name
FullTextStoplist | The user-defined stoplist for the full text index on the table or view.
FullTextStoplistNameFromSerialization |
FullTextStoplistType | The stoplist type used for the full text index on the table or view.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
HasFullTextIndex | True if the table or view has a full-text index defined on it
Indexes | The indexes defined on the table or view.
IsColumnstoreIndexed | Returns true iff the table has a columnstore index defined on it.
KeyIndexForFullTextIndex | The key index for the full-text index on the table or view.
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | The type of the object. (Inherited from ScriptableDatabaseObject.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from SchemaObjectWithAuthorization.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSourceForFullTextTable | The location of the creation script for the fulltext table statement for this table or view if the database source is set to scripts folder.
ScriptSources | (Overrides SchemaObject ..::. ScriptSources.)
Triggers | The triggers defined on the table or view.

See Also

ViewTableSuperClass Class
RedGate.SQLCompare.Engine Namespace


CatalogUsedForFullTextIndex Property

[image]

SQL Data Compare API 12.0.40
ViewTableSuperClass..::.CatalogUsedForFullTextIndex Property
ViewTableSuperClass Class See Also

The full-text catalog used for the full-text index defined on the table or view

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CatalogUsedForFullTextIndex As FullTextCatalog
C#
public FullTextCatalog CatalogUsedForFullTextIndex { get; internal set; }
Visual C++
public:
property FullTextCatalog^ CatalogUsedForFullTextIndex {
    FullTextCatalog^ get ();
    void set (FullTextCatalog^ value);
}

See Also

ViewTableSuperClass Class
RedGate.SQLCompare.Engine Namespace


Fields Property

[image]

SQL Data Compare API 12.0.40
ViewTableSuperClass..::.Fields Property
ViewTableSuperClass Class See Also

The fields belonging to the table or view.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Fields As Fields
C#
public virtual Fields Fields { get; protected internal set; }
Visual C++
public:
virtual property Fields^ Fields {
    Fields^ get ();
    void set (Fields^ value);
}

See Also

ViewTableSuperClass Class
RedGate.SQLCompare.Engine Namespace


FullTextCatalogNameFromSerialization Property

[image]

SQL Data Compare API 12.0.40
ViewTableSuperClass..::.FullTextCatalogNameFromSerialization Property
ViewTableSuperClass Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Property FullTextCatalogNameFromSerialization As String
C#
protected string FullTextCatalogNameFromSerialization { get; set; }
Visual C++
protected:
property String^ FullTextCatalogNameFromSerialization {
    String^ get ();
    void set (String^ value);
}

See Also

ViewTableSuperClass Class
RedGate.SQLCompare.Engine Namespace


FullTextChangeTracking Property

[image]

SQL Data Compare API 12.0.40
ViewTableSuperClass..::.FullTextChangeTracking Property
ViewTableSuperClass Class See Also

The change tracking setting for the full text index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextChangeTracking As FullTextChangeTracking
C#
public FullTextChangeTracking FullTextChangeTracking { get; internal set; }
Visual C++
public:
property FullTextChangeTracking FullTextChangeTracking {
    FullTextChangeTracking get ();
    void set (FullTextChangeTracking value);
}

See Also

ViewTableSuperClass Class
RedGate.SQLCompare.Engine Namespace


FullTextSearchPropertyList Property

[image]

SQL Data Compare API 12.0.40
ViewTableSuperClass..::.FullTextSearchPropertyList Property
ViewTableSuperClass Class See Also

The search property list attached the full-text index (if both exist)

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextSearchPropertyList As SearchPropertyList
C#
public SearchPropertyList FullTextSearchPropertyList { get; internal set; }
Visual C++
public:
property SearchPropertyList^ FullTextSearchPropertyList {
    SearchPropertyList^ get ();
    void set (SearchPropertyList^ value);
}

See Also

ViewTableSuperClass Class
RedGate.SQLCompare.Engine Namespace


FullTextSPLNameFromSerialization Property

[image]

SQL Data Compare API 12.0.40
ViewTableSuperClass..::.FullTextSPLNameFromSerialization Property
ViewTableSuperClass Class See Also

Name

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Property FullTextSPLNameFromSerialization As String
C#
protected string FullTextSPLNameFromSerialization { get; set; }
Visual C++
protected:
property String^ FullTextSPLNameFromSerialization {
    String^ get ();
    void set (String^ value);
}

See Also

ViewTableSuperClass Class
RedGate.SQLCompare.Engine Namespace


FullTextStoplist Property

[image]

SQL Data Compare API 12.0.40
ViewTableSuperClass..::.FullTextStoplist Property
ViewTableSuperClass Class See Also

The user-defined stoplist for the full text index on the table or view.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextStoplist As FullTextStoplist
C#
public FullTextStoplist FullTextStoplist { get; internal set; }
Visual C++
public:
property FullTextStoplist^ FullTextStoplist {
    FullTextStoplist^ get ();
    void set (FullTextStoplist^ value);
}

See Also

ViewTableSuperClass Class
RedGate.SQLCompare.Engine Namespace


FullTextStoplistNameFromSerialization Property

[image]

SQL Data Compare API 12.0.40
ViewTableSuperClass..::.FullTextStoplistNameFromSerialization Property
ViewTableSuperClass Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Property FullTextStoplistNameFromSerialization As String
C#
protected string FullTextStoplistNameFromSerialization { get; set; }
Visual C++
protected:
property String^ FullTextStoplistNameFromSerialization {
    String^ get ();
    void set (String^ value);
}

See Also

ViewTableSuperClass Class
RedGate.SQLCompare.Engine Namespace


FullTextStoplistType Property

[image]

SQL Data Compare API 12.0.40
ViewTableSuperClass..::.FullTextStoplistType Property
ViewTableSuperClass Class See Also

The stoplist type used for the full text index on the table or view.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextStoplistType As FullTextStoplistType
C#
public FullTextStoplistType FullTextStoplistType { get; internal set; }
Visual C++
public:
property FullTextStoplistType FullTextStoplistType {
    FullTextStoplistType get ();
    void set (FullTextStoplistType value);
}

See Also

ViewTableSuperClass Class
RedGate.SQLCompare.Engine Namespace


HasFullTextIndex Property

[image]

SQL Data Compare API 12.0.40
ViewTableSuperClass..::.HasFullTextIndex Property
ViewTableSuperClass Class See Also

True if the table or view has a full-text index defined on it

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property HasFullTextIndex As Boolean
C#
public bool HasFullTextIndex { get; internal set; }
Visual C++
public:
property bool HasFullTextIndex {
    bool get ();
    void set (bool value);
}

See Also

ViewTableSuperClass Class
RedGate.SQLCompare.Engine Namespace


Indexes Property

[image]

SQL Data Compare API 12.0.40
ViewTableSuperClass..::.Indexes Property
ViewTableSuperClass Class See Also

The indexes defined on the table or view.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Indexes As Indexes
C#
public virtual Indexes Indexes { get; protected internal set; }
Visual C++
public:
virtual property Indexes^ Indexes {
    Indexes^ get ();
    void set (Indexes^ value);
}

See Also

ViewTableSuperClass Class
RedGate.SQLCompare.Engine Namespace


IsColumnstoreIndexed Property

[image]

SQL Data Compare API 12.0.40
ViewTableSuperClass..::.IsColumnstoreIndexed Property
ViewTableSuperClass Class See Also

Returns true iff the table has a columnstore index defined on it.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsColumnstoreIndexed As Boolean
C#
public bool IsColumnstoreIndexed { get; }
Visual C++
public:
property bool IsColumnstoreIndexed {
    bool get ();
}

See Also

ViewTableSuperClass Class
RedGate.SQLCompare.Engine Namespace


KeyIndexForFullTextIndex Property

[image]

SQL Data Compare API 12.0.40
ViewTableSuperClass..::.KeyIndexForFullTextIndex Property
ViewTableSuperClass Class See Also

The key index for the full-text index on the table or view.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property KeyIndexForFullTextIndex As RelationalIndex
C#
public RelationalIndex KeyIndexForFullTextIndex { get; }
Visual C++
public:
property RelationalIndex^ KeyIndexForFullTextIndex {
    RelationalIndex^ get ();
}

See Also

ViewTableSuperClass Class
RedGate.SQLCompare.Engine Namespace


ScriptSourceForFullTextTable Property

[image]

SQL Data Compare API 12.0.40
ViewTableSuperClass..::.ScriptSourceForFullTextTable Property
ViewTableSuperClass Class See Also

The location of the creation script for the fulltext table statement for this table or view if the database source is set to scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSourceForFullTextTable As ScriptSource
C#
public ScriptSource ScriptSourceForFullTextTable { get; internal set; }
Visual C++
public:
property ScriptSource^ ScriptSourceForFullTextTable {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

ViewTableSuperClass Class
RedGate.SQLCompare.Engine Namespace


ScriptSources Property

[image]

SQL Data Compare API 12.0.40
ViewTableSuperClass..::.ScriptSources Property
ViewTableSuperClass Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ScriptSources As IEnumerable(Of ScriptSource)
C#
public override IEnumerable<ScriptSource> ScriptSources { get; }
Visual C++
public:
virtual property IEnumerable<ScriptSource^>^ ScriptSources {
    IEnumerable<ScriptSource^>^ get () override;
}

See Also

ViewTableSuperClass Class
RedGate.SQLCompare.Engine Namespace


Triggers Property

[image]

SQL Data Compare API 12.0.40
ViewTableSuperClass..::.Triggers Property
ViewTableSuperClass Class See Also

The triggers defined on the table or view.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Triggers As Triggers
C#
public Triggers Triggers { get; protected internal set; }
Visual C++
public:
property Triggers^ Triggers {
    Triggers^ get ();
    void set (Triggers^ value);
}

See Also

ViewTableSuperClass Class
RedGate.SQLCompare.Engine Namespace


WarningURLs Class

[image]

SQL Data Compare API 12.0.40
WarningURLs Class
Members See Also

A strongly-typed resource class, for looking up localized strings, etc.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Resources.Tools.StronglyTypedResourceBuilder",  _
    "4.0.0.0")> _
Public Class WarningURLs
C#
[GeneratedCodeAttribute("System.Resources.Tools.StronglyTypedResourceBuilder",
    "4.0.0.0")]
public class WarningURLs
Visual C++
[GeneratedCodeAttribute(L"System.Resources.Tools.StronglyTypedResourceBuilder",
    L"4.0.0.0")]
public ref class WarningURLs

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.WarningURLs

See Also

WarningURLs Members
RedGate.SQLCompare.Engine Namespace


WarningURLs Members

[image] [image]

SQL Data Compare API 12.0.40
WarningURLs Members
WarningURLs Class Methods Properties See Also

The WarningURLs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
MigrationsURL | Looks up a localized string similar to http://www.red-gate.com/soc5/compare-migrations-warning.
ResourceManager | Returns the cached ResourceManager instance used by this class.

See Also

WarningURLs Class
RedGate.SQLCompare.Engine Namespace


WarningURLs Properties

[image] [image]

SQL Data Compare API 12.0.40
WarningURLs Properties
WarningURLs Class See Also

The WarningURLs type exposes the following properties.

Properties

Name | Description
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
MigrationsURL | Looks up a localized string similar to http://www.red-gate.com/soc5/compare-migrations-warning.
ResourceManager | Returns the cached ResourceManager instance used by this class.

See Also

WarningURLs Class
RedGate.SQLCompare.Engine Namespace


Culture Property

[image]

SQL Data Compare API 12.0.40
WarningURLs..::.Culture Property
WarningURLs Class See Also

Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Property Culture As CultureInfo
C#
public static CultureInfo Culture { get; set; }
Visual C++
public:
static property CultureInfo^ Culture {
    CultureInfo^ get ();
    void set (CultureInfo^ value);
}

See Also

WarningURLs Class
RedGate.SQLCompare.Engine Namespace


MigrationsURL Property

[image]

SQL Data Compare API 12.0.40
WarningURLs..::.MigrationsURL Property
WarningURLs Class See Also

Looks up a localized string similar to http://www.red-gate.com/soc5/compare-migrations-warning.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property MigrationsURL As String
C#
public static string MigrationsURL { get; }
Visual C++
public:
static property String^ MigrationsURL {
    String^ get ();
}

See Also

WarningURLs Class
RedGate.SQLCompare.Engine Namespace


ResourceManager Property

[image]

SQL Data Compare API 12.0.40
WarningURLs..::.ResourceManager Property
WarningURLs Class See Also

Returns the cached ResourceManager instance used by this class.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ResourceManager As ResourceManager
C#
public static ResourceManager ResourceManager { get; }
Visual C++
public:
static property ResourceManager^ ResourceManager {
    ResourceManager^ get ();
}

See Also

WarningURLs Class
RedGate.SQLCompare.Engine Namespace


WhereClauseReference Structure

[image]

SQL Data Compare API 12.0.40
WhereClauseReference Structure
Members See Also

A reference to a where clause

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Structure WhereClauseReference
C#
public struct WhereClauseReference
Visual C++
public value class WhereClauseReference

See Also

WhereClauseReference Members
RedGate.SQLCompare.Engine Namespace


WhereClauseReference Members

[image] [image]

SQL Data Compare API 12.0.40
WhereClauseReference Members
WhereClauseReference Structure Constructors Methods Fields See Also

The WhereClauseReference type exposes the following members.

Constructors

Name | Description
WhereClauseReference | Creates a new where clause reference

Methods

Name | Description
Equals | (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

Name | Description
TableName | The table name to which the where clause applies
WhereClause | The text of the where clause

See Also

WhereClauseReference Structure
RedGate.SQLCompare.Engine Namespace


WhereClauseReference Constructor

[image]

SQL Data Compare API 12.0.40
WhereClauseReference Constructor
WhereClauseReference Structure See Also

Creates a new where clause reference

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    tm As Mapping(Of ViewTableSuperClass), _
    clause As String _
)
C#
public WhereClauseReference(
    Mapping<ViewTableSuperClass> tm,
    string clause
)
Visual C++
public:
WhereClauseReference(
    Mapping<ViewTableSuperClass^>^ tm,
    String^ clause
)

Parameters

tm
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( ViewTableSuperClass >)>)
The table mapping
clause
Type: String
The string of the where clause

See Also

WhereClauseReference Structure
RedGate.SQLCompare.Engine Namespace


WhereClauseReference Fields

[image] [image]

SQL Data Compare API 12.0.40
WhereClauseReference Fields
WhereClauseReference Structure See Also

The WhereClauseReference type exposes the following fields.

Fields

Name | Description
TableName | The table name to which the where clause applies
WhereClause | The text of the where clause

See Also

WhereClauseReference Structure
RedGate.SQLCompare.Engine Namespace


TableName Field

[image]

SQL Data Compare API 12.0.40
WhereClauseReference..::.TableName Field
WhereClauseReference Structure See Also

The table name to which the where clause applies

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public TableName As String
C#
public string TableName
Visual C++
public:
String^ TableName

See Also

WhereClauseReference Structure
RedGate.SQLCompare.Engine Namespace


WhereClause Field

[image]

SQL Data Compare API 12.0.40
WhereClauseReference..::.WhereClause Field
WhereClauseReference Structure See Also

The text of the where clause

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public WhereClause As String
C#
public string WhereClause
Visual C++
public:
String^ WhereClause

See Also

WhereClauseReference Structure
RedGate.SQLCompare.Engine Namespace


WhereClauseReference Methods

[image] [image]

SQL Data Compare API 12.0.40
WhereClauseReference Methods
WhereClauseReference Structure See Also

The WhereClauseReference type exposes the following methods.

Methods

Name | Description
Equals | (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

WhereClauseReference Structure
RedGate.SQLCompare.Engine Namespace


Equals Method

[image]

SQL Data Compare API 12.0.40
WhereClauseReference..::.Equals Method
WhereClauseReference Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object

See Also

WhereClauseReference Structure
RedGate.SQLCompare.Engine Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
WhereClauseReference..::.GetHashCode Method
WhereClauseReference Structure See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

See Also

WhereClauseReference Structure
RedGate.SQLCompare.Engine Namespace


Work Class

[image]

SQL Data Compare API 12.0.40
Work Class
Members Example See Also

Used to calculate the work to be done to synchronize databases.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class Work _
    Implements IWork, ICancellable
C#
public class Work : IWork, ICancellable
Visual C++
public ref class Work : IWork, ICancellable

Remarks

The Work class is used to convert a set of Differences into an ExecutionBlock containing SQL script, which can be used to synchronize two databases. It also provides Warnings and Messages about the work to be done.

ScriptObject(IDatabaseObject, Options) can be used to generate scripts for individual database objects.

Note that you should not re-use a Work object; you should re-create a new object every time.

Examples

This example shows how to compare and synchronize two databases.
C# Copy Code
             Database db1=new Database();
             Database db2=new Database();

             db1.Register(new ConnectionProperties(".", "WidgetStaging"), Options.Default);
             db2.Register(new ConnectionProperties(".", "WidgetProduction"), Options.Default);

             Differences differences=db1.PopulateDifferences(db2, Options.Default);

             foreach (Difference difference in differences)
             {
                 //make sure the difference is selected so it is included in the synchronization
                 difference.Selected=true;
             }

             Work work=new Work();

             //calculate the work to do using sensible default options
             //the script is to be run on WidgetProduction so the runOnTwo parameter is true
             work.BuildFromDifferences(differences, Options.Default, true);

             //we can now access the messages and warnings

             Console.WriteLine("Messages:");

             foreach (Message message in work.Messages)
             {
                 Console.WriteLine(message.Text);
             }

             Console.WriteLine("Warnings:");

             foreach (Message message in work.Warnings)
             {
                 Console.WriteLine(message.Text);
             }

             //print out the SQL used to synchronize

             ExecutionBlock block=work.ExecutionBlock;

             Console.WriteLine("SQL to synchronize:");

             Console.WriteLine(block.GetString());

             //and run the SQL

             RedGate.Shared.Sql.ExecutionBlock.BlockExecutor executor=new RedGate.Shared.Sql.ExecutionBlock.BlockExecutor();
             executor.ExecuteBlock(block, ".", "WidgetProduction");

             //dispose of the objects
             block.Dispose();
             db1.Dispose();
             db2.Dispose();
Visual Basic Copy Code
             Dim db1 As Database = New Database()
             Dim db2 As Database = New Database()

             db1.Register(New ConnectionProperties(".", "WidgetStaging"), Options.Default)
             db2.Register(New ConnectionProperties(".", "WidgetProduction"), Options.Default)

             Dim differences As Differences = db1.PopulateDifferences(db2, Options.Default)

             Dim difference As Difference

             For Each difference In differences
                 'make sure the difference is selected so it is included in the synchronization
                 difference.Selected = True
             Next

             Dim work As Work = New Work()

             'calculate the work to do using sensible default options
             'the script is to be run on WidgetProduction so the runOnTwo parameter is true

             work.BuildFromDifferences(differences, Options.Default, True)

             'we can now access the messages and warnings

             Console.WriteLine("Messages:")

             Dim message As Message

             For Each message In work.Messages
                 Console.WriteLine(message.Text)
             Next

             Console.WriteLine("Warnings:")

             For Each message In work.Warnings
                 Console.WriteLine(message.Text)
             Next

             'print out the SQL used to synchronize

             Dim block As ExecutionBlock = work.ExecutionBlock

             Console.WriteLine("SQL to synchronize:")

             Console.WriteLine(block.GetString())

             'and run the SQL

             Dim executor As BlockExecutor = New BlockExecutor

             executor.ExecuteBlock(block, ".", "WidgetProduction")

             'dispose of the objects
             block.Dispose()
             db1.Dispose()
             db2.Dispose()

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.Work

See Also

Work Members
RedGate.SQLCompare.Engine Namespace


Work Members

[image] [image]

SQL Data Compare API 12.0.40
Work Members
Work Class Constructors Methods Properties See Also

The Work type exposes the following members.

Constructors

Name | Description
Work | Overloaded.

Methods

Name | Description
BuildFromDifferences | Overloaded.
CancelOperation |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Returns the script necessary to create a SQL object.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BackupOptions |
CanRollBackOnFailure |
Dependencies |
DependenciesHaveBeenCalculated |
ExecutionBlock |
Messages |
ProductInformation |
ScriptSynchronizationActions |
StaticDataInsertPosition |
Status |
TransactionIsolationLevel |
Warnings |

See Also

Work Class
RedGate.SQLCompare.Engine Namespace


Work Constructor

[image] [image]

SQL Data Compare API 12.0.40
Work Constructor
Work Class See Also

Overload List

Name | Description
Work()()() |
Work(IFileNameGenerator) | Constructor.

See Also

Work Class
Work Members
RedGate.SQLCompare.Engine Namespace


Work Constructor

[image]

SQL Data Compare API 12.0.40
Work Constructor
Work Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Work()
Visual C++
public:
Work()

See Also

Work Class
Work Overload
RedGate.SQLCompare.Engine Namespace


Work Constructor (IFileNameGenerator)

[image]

SQL Data Compare API 12.0.40
Work Constructor (IFileNameGenerator)
Work Class See Also

Constructor.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fileNameGenerator As IFileNameGenerator _
)
C#
public Work(
    IFileNameGenerator fileNameGenerator
)
Visual C++
public:
Work(
    IFileNameGenerator^ fileNameGenerator
)

Parameters

fileNameGenerator
Type: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser..::.IFileNameGenerator
The sql file name generator for new objects

See Also

Work Class
Work Overload
RedGate.SQLCompare.Engine Namespace


Work Methods

[image] [image]

SQL Data Compare API 12.0.40
Work Methods
Work Class See Also

The Work type exposes the following methods.

Methods

Name | Description
BuildFromDifferences | Overloaded.
CancelOperation |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Returns the script necessary to create a SQL object.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Work Class
RedGate.SQLCompare.Engine Namespace


BuildFromDifferences Method

[image] [image]

SQL Data Compare API 12.0.40
Work..::.BuildFromDifferences Method
Work Class See Also

Overload List

Name | Description
BuildFromDifferences(Differences, Options, Boolean) | Build the work object from a set of differences. Use this method when synchronizing to a live database.
BuildFromDifferences(Differences, Difference, Options, Boolean) | Builds the work object from an individual difference. It sets the ExecutionBlock property to include the script for synchronization. Use this method when synchronizing to a live database.
BuildFromDifferences(Differences, Options, Boolean, ScriptDatabaseInformation) | Build the work object from a set of differences. It sets the ScriptSynchronizationActions property to include the synchronization actions for modifying a scripts folder. Use this method when synchronizing to a scripts folder.
BuildFromDifferences(Differences, Options, Boolean, ScriptDatabaseInformation, IFileNameGenerator) | Build the work object from a set of differences. It sets the ScriptSynchronizationActions property to include the synchronization actions for modifying a scripts folder. Use this method when synchronizing to a scripts folder.
BuildFromDifferences(Differences, Difference, Options, Boolean, ScriptDatabaseInformation, IFileNameGenerator) | Builds the work object from an individual difference. It sets the ScriptSynchronizationActions property to include the synchronization actions for modifying a scripts folder. Use this method when synchronizing to a scripts folder.

See Also

Work Class
Work Members
RedGate.SQLCompare.Engine Namespace


BuildFromDifferences Method (Differences, Options, )

[image]

SQL Data Compare API 12.0.40
Work..::.BuildFromDifferences Method (Differences, Options, )
Work Class See Also

Build the work object from a set of differences. Use this method when synchronizing to a live database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub BuildFromDifferences ( _
    differences As Differences, _
    options As Options, _
    runOnTwo As Boolean _
)
C#
public void BuildFromDifferences(
    Differences differences,
    Options options,
    bool runOnTwo
)
Visual C++
public:
virtual void BuildFromDifferences(
    Differences^ differences,
    Options options,
    bool runOnTwo
) sealed

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
The differences to use.
options
Type: RedGate.SQLCompare.Engine..::.Options
The synchronization options.
runOnTwo
Type: Boolean
True if the SQL script is to be run on the second database.

Implements

IWork..::.BuildFromDifferences(Differences, Options, Boolean)

See Also

Work Class
BuildFromDifferences Overload
RedGate.SQLCompare.Engine Namespace


BuildFromDifferences Method (Differences, Difference, Options, )

[image]

SQL Data Compare API 12.0.40
Work..::.BuildFromDifferences Method (Differences, Difference, Options, )
Work Class See Also

Builds the work object from an individual difference. It sets the ExecutionBlock property to include the script for synchronization. Use this method when synchronizing to a live database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub BuildFromDifferences ( _
    differences As Differences, _
    onlyDifferenceToInclude As Difference, _
    options As Options, _
    runOnTwo As Boolean _
)
C#
public void BuildFromDifferences(
    Differences differences,
    Difference onlyDifferenceToInclude,
    Options options,
    bool runOnTwo
)
Visual C++
public:
virtual void BuildFromDifferences(
    Differences^ differences,
    Difference^ onlyDifferenceToInclude,
    Options options,
    bool runOnTwo
) sealed

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
The differences to use.
onlyDifferenceToInclude
Type: RedGate.SQLCompare.Engine..::.Difference
The single difference to include.
options
Type: RedGate.SQLCompare.Engine..::.Options
The synchronization options.
runOnTwo
Type: Boolean
True if the SQL script is to be run on the second database.

Implements

IWork..::.BuildFromDifferences(Differences, Difference, Options, Boolean)

See Also

Work Class
BuildFromDifferences Overload
RedGate.SQLCompare.Engine Namespace


BuildFromDifferences Method (Differences, Options, , ScriptDatabaseInformation)

[image]

SQL Data Compare API 12.0.40
Work..::.BuildFromDifferences Method (Differences, Options, , ScriptDatabaseInformation)
Work Class See Also

Build the work object from a set of differences. It sets the ScriptSynchronizationActions property to include the synchronization actions for modifying a scripts folder. Use this method when synchronizing to a scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub BuildFromDifferences ( _
    differences As Differences, _
    options As Options, _
    runOnTwo As Boolean, _
    dbInfo As ScriptDatabaseInformation _
)
C#
public void BuildFromDifferences(
    Differences differences,
    Options options,
    bool runOnTwo,
    ScriptDatabaseInformation dbInfo
)
Visual C++
public:
virtual void BuildFromDifferences(
    Differences^ differences,
    Options options,
    bool runOnTwo,
    ScriptDatabaseInformation^ dbInfo
) sealed

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
The differences to use.
options
Type: RedGate.SQLCompare.Engine..::.Options
The synchronization options.
runOnTwo
Type: Boolean
True if the SQL script is to be run on the second database.
dbInfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
Options that sepcify how files are to be created when synchronizing to a scripts folder.

Implements

IWork..::.BuildFromDifferences(Differences, Options, Boolean, ScriptDatabaseInformation)

See Also

Work Class
BuildFromDifferences Overload
RedGate.SQLCompare.Engine Namespace


BuildFromDifferences Method (Differences, Options, , ScriptDatabaseInformation, IFileNameGenerator)

[image]

SQL Data Compare API 12.0.40
Work..::.BuildFromDifferences Method (Differences, Options, , ScriptDatabaseInformation, IFileNameGenerator)
Work Class See Also

Build the work object from a set of differences. It sets the ScriptSynchronizationActions property to include the synchronization actions for modifying a scripts folder. Use this method when synchronizing to a scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub BuildFromDifferences ( _
    differences As Differences, _
    options As Options, _
    runOnTwo As Boolean, _
    dbInfo As ScriptDatabaseInformation, _
    generator As IFileNameGenerator _
)
C#
public void BuildFromDifferences(
    Differences differences,
    Options options,
    bool runOnTwo,
    ScriptDatabaseInformation dbInfo,
    IFileNameGenerator generator
)
Visual C++
public:
void BuildFromDifferences(
    Differences^ differences,
    Options options,
    bool runOnTwo,
    ScriptDatabaseInformation^ dbInfo,
    IFileNameGenerator^ generator
)

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
The differences to use.
options
Type: RedGate.SQLCompare.Engine..::.Options
The synchronization options.
runOnTwo
Type: Boolean
True if the SQL script is to be run on the second database.
dbInfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
Options that sepcify how files are to be created when synchronizing to a scripts folder.
generator
Type: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser..::.IFileNameGenerator
The object responsible for generating the names of the newly created objects

See Also

Work Class
BuildFromDifferences Overload
RedGate.SQLCompare.Engine Namespace


BuildFromDifferences Method (Differences, Difference, Options, , ScriptDatabaseInformation, IFileNameGenerator)

[image]

SQL Data Compare API 12.0.40
Work..::.BuildFromDifferences Method (Differences, Difference, Options, , ScriptDatabaseInformation, IFileNameGenerator)
Work Class See Also

Builds the work object from an individual difference. It sets the ScriptSynchronizationActions property to include the synchronization actions for modifying a scripts folder. Use this method when synchronizing to a scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub BuildFromDifferences ( _
    differences As Differences, _
    onlyDifferenceToInclude As Difference, _
    options As Options, _
    runOnTwo As Boolean, _
    dbInfo As ScriptDatabaseInformation, _
    generator As IFileNameGenerator _
)
C#
public void BuildFromDifferences(
    Differences differences,
    Difference onlyDifferenceToInclude,
    Options options,
    bool runOnTwo,
    ScriptDatabaseInformation dbInfo,
    IFileNameGenerator generator
)
Visual C++
public:
virtual void BuildFromDifferences(
    Differences^ differences,
    Difference^ onlyDifferenceToInclude,
    Options options,
    bool runOnTwo,
    ScriptDatabaseInformation^ dbInfo,
    IFileNameGenerator^ generator
) sealed

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
The differences to use.
onlyDifferenceToInclude
Type: RedGate.SQLCompare.Engine..::.Difference
The single difference to include.
options
Type: RedGate.SQLCompare.Engine..::.Options
The synchronization options.
runOnTwo
Type: Boolean
True if the SQL script is to be run on the second database.
dbInfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
Options that sepcify how files are to be created when synchronizing to a scripts folder.
generator
Type: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser..::.IFileNameGenerator
The object responsible for generating the names of the newly created objects

Implements

IWork..::.BuildFromDifferences(Differences, Difference, Options, Boolean, ScriptDatabaseInformation, IFileNameGenerator)

See Also

Work Class
BuildFromDifferences Overload
RedGate.SQLCompare.Engine Namespace


CancelOperation Method

[image]

SQL Data Compare API 12.0.40
Work..::.CancelOperation Method
Work Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelOperation
C#
public void CancelOperation()
Visual C++
public:
virtual void CancelOperation() sealed

Implements

ICancellable..::.CancelOperation()()()

See Also

Work Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
Work..::.ScriptObject Method
Work Class Example See Also

Returns the script necessary to create a SQL object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function ScriptObject ( _
    objectToScript As IDatabaseObject, _
    options As Options _
) As Regions
C#
public Regions ScriptObject(
    IDatabaseObject objectToScript,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    IDatabaseObject^ objectToScript,
    Options options
) sealed

Parameters

objectToScript
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
options
Type: RedGate.SQLCompare.Engine..::.Options

Return Value

A Regions collection containing batches of SQL script.

Implements

IWork..::.ScriptObject(IDatabaseObject, Options)

Remarks

This creates SQL code used to create an object such as a table, view, or stored procedure.

Examples

C# Copy Code
             Database db=new Database();

             db.Register(new ConnectionProperties(".", "WidgetStaging"), Options.Default);

             Work work=new Work();

             //get the script for an object
             Regions regions=work.ScriptObject(db.Tables[0], Options.Default);

             Console.WriteLine("SQL script:\n{0}", regions.ToString());

             db.Dispose();
Visual Basic Copy Code
             Dim db As New Database()

             db.Register(New ConnectionProperties(".", "WidgetStaging"), Options.Default)

             Dim work As New Work()

             'get the script for an object

             Dim regions As Regions = work.ScriptObject(db.Tables(0), Options.Default)

             Console.WriteLine("SQL script:")
             Console.WriteLine("{0}", regions.ToString())

             'dispose
             db.Dispose()

See Also

Work Class
RedGate.SQLCompare.Engine Namespace


Work Properties

[image] [image]

SQL Data Compare API 12.0.40
Work Properties
Work Class See Also

The Work type exposes the following properties.

Properties

Name | Description
BackupOptions |
CanRollBackOnFailure |
Dependencies |
DependenciesHaveBeenCalculated |
ExecutionBlock |
Messages |
ProductInformation |
ScriptSynchronizationActions |
StaticDataInsertPosition |
Status |
TransactionIsolationLevel |
Warnings |

See Also

Work Class
RedGate.SQLCompare.Engine Namespace


BackupOptions Property

[image]

SQL Data Compare API 12.0.40
Work..::.BackupOptions Property
Work Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BackupOptions As BackupOptions
C#
public BackupOptions BackupOptions { get; set; }
Visual C++
public:
virtual property BackupOptions^ BackupOptions {
    BackupOptions^ get () sealed;
    void set (BackupOptions^ value) sealed;
}

Implements

IWork..::.BackupOptions

See Also

Work Class
RedGate.SQLCompare.Engine Namespace


CanRollBackOnFailure Property

[image]

SQL Data Compare API 12.0.40
Work..::.CanRollBackOnFailure Property
Work Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanRollBackOnFailure As Boolean
C#
public bool CanRollBackOnFailure { get; }
Visual C++
public:
virtual property bool CanRollBackOnFailure {
    bool get () sealed;
}

Implements

IWork..::.CanRollBackOnFailure

See Also

Work Class
RedGate.SQLCompare.Engine Namespace


Dependencies Property

[image]

SQL Data Compare API 12.0.40
Work..::.Dependencies Property
Work Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dependencies As IDictionary(Of Difference, Set(Of Difference))
C#
public IDictionary<Difference, Set<Difference>> Dependencies { get; }
Visual C++
public:
virtual property IDictionary<Difference^, Set<Difference^>^>^ Dependencies {
    IDictionary<Difference^, Set<Difference^>^>^ get () sealed;
}

Implements

IWork..::.Dependencies

See Also

Work Class
RedGate.SQLCompare.Engine Namespace


DependenciesHaveBeenCalculated Property

[image]

SQL Data Compare API 12.0.40
Work..::.DependenciesHaveBeenCalculated Property
Work Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DependenciesHaveBeenCalculated As Boolean
C#
public bool DependenciesHaveBeenCalculated { get; }
Visual C++
public:
virtual property bool DependenciesHaveBeenCalculated {
    bool get () sealed;
}

Implements

IWork..::.DependenciesHaveBeenCalculated

See Also

Work Class
RedGate.SQLCompare.Engine Namespace


ExecutionBlock Property

[image]

SQL Data Compare API 12.0.40
Work..::.ExecutionBlock Property
Work Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExecutionBlock As IExecutionBlock
C#
public IExecutionBlock ExecutionBlock { get; }
Visual C++
public:
virtual property IExecutionBlock^ ExecutionBlock {
    IExecutionBlock^ get () sealed;
}

Implements

IWork..::.ExecutionBlock

See Also

Work Class
RedGate.SQLCompare.Engine Namespace


Messages Property

[image]

SQL Data Compare API 12.0.40
Work..::.Messages Property
Work Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Messages As IEnumerable(Of IDeploymentMessage)
C#
public IEnumerable<IDeploymentMessage> Messages { get; }
Visual C++
public:
virtual property IEnumerable<IDeploymentMessage^>^ Messages {
    IEnumerable<IDeploymentMessage^>^ get () sealed;
}

Implements

IWork..::.Messages

See Also

Work Class
RedGate.SQLCompare.Engine Namespace


ProductInformation Property

[image]

SQL Data Compare API 12.0.40
Work..::.ProductInformation Property
Work Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ProductInformation As String
C#
public string ProductInformation { get; set; }
Visual C++
public:
property String^ ProductInformation {
    String^ get ();
    void set (String^ value);
}

See Also

Work Class
RedGate.SQLCompare.Engine Namespace


ScriptSynchronizationActions Property

[image]

SQL Data Compare API 12.0.40
Work..::.ScriptSynchronizationActions Property
Work Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSynchronizationActions As ScriptSynchronizationActions
C#
public ScriptSynchronizationActions ScriptSynchronizationActions { get; set; }
Visual C++
public:
virtual property ScriptSynchronizationActions^ ScriptSynchronizationActions {
    ScriptSynchronizationActions^ get () sealed;
    void set (ScriptSynchronizationActions^ value) sealed;
}

Implements

IWork..::.ScriptSynchronizationActions

See Also

Work Class
RedGate.SQLCompare.Engine Namespace


StaticDataInsertPosition Property

[image]

SQL Data Compare API 12.0.40
Work..::.StaticDataInsertPosition Property
Work Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StaticDataInsertPosition As Long
C#
public long StaticDataInsertPosition { get; }
Visual C++
public:
virtual property long long StaticDataInsertPosition {
    long long get () sealed;
}

Implements

IWork..::.StaticDataInsertPosition

See Also

Work Class
RedGate.SQLCompare.Engine Namespace


Status Property

[image]

SQL Data Compare API 12.0.40
Work..::.Status Property
Work Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

See Also

Work Class
RedGate.SQLCompare.Engine Namespace


TransactionIsolationLevel Property

[image]

SQL Data Compare API 12.0.40
Work..::.TransactionIsolationLevel Property
Work Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TransactionIsolationLevel As String
C#
public string TransactionIsolationLevel { get; set; }
Visual C++
public:
virtual property String^ TransactionIsolationLevel {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IWork..::.TransactionIsolationLevel

See Also

Work Class
RedGate.SQLCompare.Engine Namespace


Warnings Property

[image]

SQL Data Compare API 12.0.40
Work..::.Warnings Property
Work Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Warnings As IEnumerable(Of IDeploymentMessage)
C#
public IEnumerable<IDeploymentMessage> Warnings { get; }
Visual C++
public:
virtual property IEnumerable<IDeploymentMessage^>^ Warnings {
    IEnumerable<IDeploymentMessage^>^ get () sealed;
}

Implements

IWork..::.Warnings

See Also

Work Class
RedGate.SQLCompare.Engine Namespace


WorkFields Class

[image]

SQL Data Compare API 12.0.40
WorkFields Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class WorkFields
C#
public class WorkFields
Visual C++
public ref class WorkFields

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.WorkFields

See Also

WorkFields Members
RedGate.SQLCompare.Engine Namespace


WorkFields Members

[image] [image]

SQL Data Compare API 12.0.40
WorkFields Members
WorkFields Class Methods See Also

The WorkFields type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorkFields Class
RedGate.SQLCompare.Engine Namespace


XmlSchemaCollection Class

[image]

SQL Data Compare API 12.0.40
XmlSchemaCollection Class
Members See Also

An XML schema collection.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class XmlSchemaCollection _
    Inherits SchemaObjectWithAuthorization _
    Implements IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck,  _
    ISqlComparable, IPatchUpAfterDeserialization
C#
public sealed class XmlSchemaCollection : SchemaObjectWithAuthorization, IHasPermissions,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck, ISqlComparable, IPatchUpAfterDeserialization
Visual C++
public ref class XmlSchemaCollection sealed : public SchemaObjectWithAuthorization,
    IHasPermissions, IDatabaseObject, ITSqlObject, ICanExistenceCheck, ISqlComparable,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.SchemaObjectWithAuthorization
RedGate.SQLCompare.Engine..::.XmlSchemaCollection

See Also

XmlSchemaCollection Members
RedGate.SQLCompare.Engine Namespace


XmlSchemaCollection Members

[image] [image]

SQL Data Compare API 12.0.40
XmlSchemaCollection Members
XmlSchemaCollection Class Methods Fields Properties Explicit Interface Implementations See Also

The XmlSchemaCollection type exposes the following members.

Methods

Name | Description
CompareWith |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AlterAuthorizationClassType | (Inherited from SchemaObjectWithAuthorization.)
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
Contents | The raw schema data.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
DependentFields | The dependent database columns.
DependentFunctions | The dependent functions.
DependentStoredProcedures | The dependent stored procedures.
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.XmlSchemaCollection (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from SchemaObjectWithAuthorization.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSources | (Inherited from SchemaObject.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

XmlSchemaCollection Class
RedGate.SQLCompare.Engine Namespace


XmlSchemaCollection Methods

[image] [image]

SQL Data Compare API 12.0.40
XmlSchemaCollection Methods
XmlSchemaCollection Class See Also

The XmlSchemaCollection type exposes the following methods.

Methods

Name | Description
CompareWith |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PatchUpAfterDeserialization |
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith |

See Also

XmlSchemaCollection Class
RedGate.SQLCompare.Engine Namespace


CompareWith Method

[image]

SQL Data Compare API 12.0.40
XmlSchemaCollection..::.CompareWith Method
XmlSchemaCollection Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareWith ( _
    target As XmlSchemaCollection, _
    options As Options _
) As IEnumerable(Of EqualityDifference)
C#
public IEnumerable<EqualityDifference> CompareWith(
    XmlSchemaCollection target,
    Options options
)
Visual C++
public:
IEnumerable<EqualityDifference^>^ CompareWith(
    XmlSchemaCollection^ target,
    Options options
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.XmlSchemaCollection
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

XmlSchemaCollection Class
RedGate.SQLCompare.Engine Namespace


ISqlComparable.CompareWith Method

[image]

SQL Data Compare API 12.0.40
XmlSchemaCollection..::.ISqlComparable..::.CompareWith Method
XmlSchemaCollection Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function CompareWith ( _
    other As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference) Implements ISqlComparable.CompareWith
C#
IEnumerable<EqualityDifference> ISqlComparable.CompareWith(
    ISqlComparable other,
    Options options
)
Visual C++
private:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ other,
    Options options
) sealed = ISqlComparable::CompareWith

Parameters

other
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

XmlSchemaCollection Class
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
XmlSchemaCollection..::.Equals Method
XmlSchemaCollection Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the schema collection with a specified schema collection. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

XmlSchemaCollection Class
XmlSchemaCollection Members
RedGate.SQLCompare.Engine Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
XmlSchemaCollection..::.Equals Method (IDatabaseObject, Options)
XmlSchemaCollection Class See Also

Compares the schema collection with a specified schema collection.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The schema collection to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the schema collections are identical; otherwise false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

XmlSchemaCollection Class
Equals Overload
RedGate.SQLCompare.Engine Namespace


PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
XmlSchemaCollection..::.PatchUpAfterDeserialization Method
XmlSchemaCollection Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PatchUpAfterDeserialization ( _
    database As Database _
)
C#
public void PatchUpAfterDeserialization(
    Database database
)
Visual C++
public:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

XmlSchemaCollection Class
RedGate.SQLCompare.Engine Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
XmlSchemaCollection..::.ScriptObject Method
XmlSchemaCollection Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

Return Value

Regions that contain the script.

See Also

XmlSchemaCollection Class
RedGate.SQLCompare.Engine Namespace


XmlSchemaCollection Properties

[image] [image]

SQL Data Compare API 12.0.40
XmlSchemaCollection Properties
XmlSchemaCollection Class See Also

The XmlSchemaCollection type exposes the following properties.

Properties

Name | Description
AlterAuthorizationClassType | (Inherited from SchemaObjectWithAuthorization.)
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
Contents | The raw schema data.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
DependentFields | The dependent database columns.
DependentFunctions | The dependent functions.
DependentStoredProcedures | The dependent stored procedures.
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.XmlSchemaCollection (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from SchemaObjectWithAuthorization.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSources | (Inherited from SchemaObject.)

See Also

XmlSchemaCollection Class
RedGate.SQLCompare.Engine Namespace


Contents Property

[image]

SQL Data Compare API 12.0.40
XmlSchemaCollection..::.Contents Property
XmlSchemaCollection Class See Also

The raw schema data.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Contents As String
C#
public string Contents { get; }
Visual C++
public:
property String^ Contents {
    String^ get ();
}

See Also

XmlSchemaCollection Class
RedGate.SQLCompare.Engine Namespace


DependentFields Property

[image]

SQL Data Compare API 12.0.40
XmlSchemaCollection..::.DependentFields Property
XmlSchemaCollection Class See Also

The dependent database columns.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DependentFields As List(Of IField)
C#
public List<IField> DependentFields { get; }
Visual C++
public:
property List<IField^>^ DependentFields {
    List<IField^>^ get ();
}

See Also

XmlSchemaCollection Class
RedGate.SQLCompare.Engine Namespace


DependentFunctions Property

[image]

SQL Data Compare API 12.0.40
XmlSchemaCollection..::.DependentFunctions Property
XmlSchemaCollection Class See Also

The dependent functions.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DependentFunctions As Functions
C#
public Functions DependentFunctions { get; }
Visual C++
public:
property Functions^ DependentFunctions {
    Functions^ get ();
}

See Also

XmlSchemaCollection Class
RedGate.SQLCompare.Engine Namespace


DependentStoredProcedures Property

[image]

SQL Data Compare API 12.0.40
XmlSchemaCollection..::.DependentStoredProcedures Property
XmlSchemaCollection Class See Also

The dependent stored procedures.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DependentStoredProcedures As StoredProcedures
C#
public StoredProcedures DependentStoredProcedures { get; }
Visual C++
public:
property StoredProcedures^ DependentStoredProcedures {
    StoredProcedures^ get ();
}

See Also

XmlSchemaCollection Class
RedGate.SQLCompare.Engine Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
XmlSchemaCollection..::.ObjectType Property
XmlSchemaCollection Class See Also

Returns ObjectType.XmlSchemaCollection

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()
ITSqlObjectObjectType()()()

See Also

XmlSchemaCollection Class
RedGate.SQLCompare.Engine Namespace


XmlSchemaCollections Class

[image]

SQL Data Compare API 12.0.40
XmlSchemaCollections Class
Members See Also

A collection of XML schema collections.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class XmlSchemaCollections _
    Inherits SerializableDatabaseObjectCollection(Of XmlSchemaCollection) _
    Implements IPatchUpAfterDeserialization
C#
public sealed class XmlSchemaCollections : SerializableDatabaseObjectCollection<XmlSchemaCollection>, IPatchUpAfterDeserialization
Visual C++
public ref class XmlSchemaCollections sealed : public SerializableDatabaseObjectCollection<XmlSchemaCollection^>,
    IPatchUpAfterDeserialization

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( XmlSchemaCollection >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( XmlSchemaCollection >)>)
RedGate.SQLCompare.Engine..::.XmlSchemaCollections

See Also

XmlSchemaCollections Members
RedGate.SQLCompare.Engine Namespace


XmlSchemaCollections Members

[image] [image]

SQL Data Compare API 12.0.40
XmlSchemaCollections Members
XmlSchemaCollections Class Methods Fields Properties Explicit Interface Implementations See Also

The XmlSchemaCollections type exposes the following members.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_KeyDictionary | Internal keyed dictionary. (Inherited from KeyedCollection<(Of <(T>)>).)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization | Must be run before table patch up!

See Also

XmlSchemaCollections Class
RedGate.SQLCompare.Engine Namespace


XmlSchemaCollections Methods

[image] [image]

SQL Data Compare API 12.0.40
XmlSchemaCollections Methods
XmlSchemaCollections Class See Also

The XmlSchemaCollections type exposes the following methods.

Methods

Name | Description
Add | (Inherited from KeyedCollection<(Of <(T>)>).)
Clear | (Inherited from KeyedCollection<(Of <(T>)>).)
ContainsKey | (Inherited from KeyedCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Freeze | (Inherited from KeyedCollection<(Of <(T>)>).)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetObjectNameForException | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
INonReadOnlyCollection..::.AsReadOnly | (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from KeyedCollection<(Of <(T>)>).)
IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization | Must be run before table patch up!

See Also

XmlSchemaCollections Class
RedGate.SQLCompare.Engine Namespace


IPatchUpAfterDeserialization.PatchUpAfterDeserialization Method

[image]

SQL Data Compare API 12.0.40
XmlSchemaCollections..::.IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization Method
XmlSchemaCollections Class See Also

Must be run before table patch up!

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub PatchUpAfterDeserialization ( _
    database As Database _
) Implements IPatchUpAfterDeserialization.PatchUpAfterDeserialization
C#
void IPatchUpAfterDeserialization.PatchUpAfterDeserialization(
    Database database
)
Visual C++
private:
virtual void PatchUpAfterDeserialization(
    Database^ database
) sealed = IPatchUpAfterDeserialization::PatchUpAfterDeserialization

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

Implements

IPatchUpAfterDeserialization..::.PatchUpAfterDeserialization(Database)

See Also

XmlSchemaCollections Class
RedGate.SQLCompare.Engine Namespace


XmlSchemaCollectionsChanges Class

[image]

SQL Data Compare API 12.0.40
XmlSchemaCollectionsChanges Class
Members See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class XmlSchemaCollectionsChanges
C#
public sealed class XmlSchemaCollectionsChanges
Visual C++
public ref class XmlSchemaCollectionsChanges sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.XmlSchemaCollectionsChanges

See Also

XmlSchemaCollectionsChanges Members
RedGate.SQLCompare.Engine Namespace


XmlSchemaCollectionsChanges Members

[image] [image]

SQL Data Compare API 12.0.40
XmlSchemaCollectionsChanges Members
XmlSchemaCollectionsChanges Class Constructors Methods Properties See Also

The XmlSchemaCollectionsChanges type exposes the following members.

Constructors

Name | Description
XmlSchemaCollectionsChanges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
XmlSchemaCollectionsToAlter |
XmlSchemaCollectionsToCreate |
XmlSchemaCollectionsToDrop |
XmlSchemaTargets |

See Also

XmlSchemaCollectionsChanges Class
RedGate.SQLCompare.Engine Namespace


XmlSchemaCollectionsChanges Constructor

[image]

SQL Data Compare API 12.0.40
XmlSchemaCollectionsChanges Constructor
XmlSchemaCollectionsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public XmlSchemaCollectionsChanges(
    bool caseSensitive
)
Visual C++
public:
XmlSchemaCollectionsChanges(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

XmlSchemaCollectionsChanges Class
RedGate.SQLCompare.Engine Namespace


XmlSchemaCollectionsChanges Properties

[image] [image]

SQL Data Compare API 12.0.40
XmlSchemaCollectionsChanges Properties
XmlSchemaCollectionsChanges Class See Also

The XmlSchemaCollectionsChanges type exposes the following properties.

Properties

Name | Description
XmlSchemaCollectionsToAlter |
XmlSchemaCollectionsToCreate |
XmlSchemaCollectionsToDrop |
XmlSchemaTargets |

See Also

XmlSchemaCollectionsChanges Class
RedGate.SQLCompare.Engine Namespace


XmlSchemaCollectionsToAlter Property

[image]

SQL Data Compare API 12.0.40
XmlSchemaCollectionsChanges..::.XmlSchemaCollectionsToAlter Property
XmlSchemaCollectionsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlSchemaCollectionsToAlter As XmlSchemaCollections
C#
public XmlSchemaCollections XmlSchemaCollectionsToAlter { get; private set; }
Visual C++
public:
property XmlSchemaCollections^ XmlSchemaCollectionsToAlter {
    XmlSchemaCollections^ get ();
    void set (XmlSchemaCollections^ value);
}

See Also

XmlSchemaCollectionsChanges Class
RedGate.SQLCompare.Engine Namespace


XmlSchemaCollectionsToCreate Property

[image]

SQL Data Compare API 12.0.40
XmlSchemaCollectionsChanges..::.XmlSchemaCollectionsToCreate Property
XmlSchemaCollectionsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlSchemaCollectionsToCreate As XmlSchemaCollections
C#
public XmlSchemaCollections XmlSchemaCollectionsToCreate { get; private set; }
Visual C++
public:
property XmlSchemaCollections^ XmlSchemaCollectionsToCreate {
    XmlSchemaCollections^ get ();
    void set (XmlSchemaCollections^ value);
}

See Also

XmlSchemaCollectionsChanges Class
RedGate.SQLCompare.Engine Namespace


XmlSchemaCollectionsToDrop Property

[image]

SQL Data Compare API 12.0.40
XmlSchemaCollectionsChanges..::.XmlSchemaCollectionsToDrop Property
XmlSchemaCollectionsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlSchemaCollectionsToDrop As XmlSchemaCollections
C#
public XmlSchemaCollections XmlSchemaCollectionsToDrop { get; private set; }
Visual C++
public:
property XmlSchemaCollections^ XmlSchemaCollectionsToDrop {
    XmlSchemaCollections^ get ();
    void set (XmlSchemaCollections^ value);
}

See Also

XmlSchemaCollectionsChanges Class
RedGate.SQLCompare.Engine Namespace


XmlSchemaTargets Property

[image]

SQL Data Compare API 12.0.40
XmlSchemaCollectionsChanges..::.XmlSchemaTargets Property
XmlSchemaCollectionsChanges Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlSchemaTargets As Dictionary(Of XmlSchemaCollection, XmlSchemaCollection)
C#
public Dictionary<XmlSchemaCollection, XmlSchemaCollection> XmlSchemaTargets { get; private set; }
Visual C++
public:
property Dictionary<XmlSchemaCollection^, XmlSchemaCollection^>^ XmlSchemaTargets {
    Dictionary<XmlSchemaCollection^, XmlSchemaCollection^>^ get ();
    void set (Dictionary<XmlSchemaCollection^, XmlSchemaCollection^>^ value);
}

See Also

XmlSchemaCollectionsChanges Class
RedGate.SQLCompare.Engine Namespace


RedGate.SQLCompare.Engine.ApiHelpers Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.ApiHelpers Namespace

Classes

Class | Description
DeploymentOptions |
DeploymentScriptStatementFactory | Used to create IDeploymentScriptStatements for use in a IDeploymentPlan
StagedDeploymentSqlGenerator |


DeploymentOptions Class

[image]

SQL Data Compare API 12.0.40
DeploymentOptions Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ApiHelpers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DeploymentOptions
C#
public sealed class DeploymentOptions
Visual C++
public ref class DeploymentOptions sealed

Remarks

Simple wrapper to help keep various customizable aspects of deployment together

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ApiHelpers..::.DeploymentOptions

See Also

DeploymentOptions Members
RedGate.SQLCompare.Engine.ApiHelpers Namespace


DeploymentOptions Members

[image] [image]

SQL Data Compare API 12.0.40
DeploymentOptions Members
DeploymentOptions Class Constructors Methods Properties See Also

The DeploymentOptions type exposes the following members.

Constructors

Name | Description
DeploymentOptions |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BackupOptions |
DateTimeProvider |
Options |
ProductInfo |
TransactionIsolationLevel |

See Also

DeploymentOptions Class
RedGate.SQLCompare.Engine.ApiHelpers Namespace


DeploymentOptions Constructor

[image]

SQL Data Compare API 12.0.40
DeploymentOptions Constructor
DeploymentOptions Class See Also

Namespace: RedGate.SQLCompare.Engine.ApiHelpers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    options As Options, _
    backupOptions As BackupOptions, _
    productInfo As String, _
    dateTimeProvider As IDateTimeProvider, _
    transactionIsolationLevel As String _
)
C#
public DeploymentOptions(
    Options options,
    BackupOptions backupOptions,
    string productInfo,
    IDateTimeProvider dateTimeProvider,
    string transactionIsolationLevel
)
Visual C++
public:
DeploymentOptions(
    Options options,
    BackupOptions^ backupOptions,
    String^ productInfo,
    IDateTimeProvider^ dateTimeProvider,
    String^ transactionIsolationLevel
)

Parameters

options
Type: RedGate.SQLCompare.Engine..::.Options
backupOptions
Type: RedGate.SQLCompare.Engine..::.BackupOptions
productInfo
Type: String
dateTimeProvider
Type: RedGate.SQLCompare.Engine.Deployment.SqlGenerators..::.IDateTimeProvider
transactionIsolationLevel
Type: String

See Also

DeploymentOptions Class
RedGate.SQLCompare.Engine.ApiHelpers Namespace


DeploymentOptions Properties

[image] [image]

SQL Data Compare API 12.0.40
DeploymentOptions Properties
DeploymentOptions Class See Also

The DeploymentOptions type exposes the following properties.

Properties

Name | Description
BackupOptions |
DateTimeProvider |
Options |
ProductInfo |
TransactionIsolationLevel |

See Also

DeploymentOptions Class
RedGate.SQLCompare.Engine.ApiHelpers Namespace


BackupOptions Property

[image]

SQL Data Compare API 12.0.40
DeploymentOptions..::.BackupOptions Property
DeploymentOptions Class See Also

Namespace: RedGate.SQLCompare.Engine.ApiHelpers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BackupOptions As BackupOptions
C#
public BackupOptions BackupOptions { get; private set; }
Visual C++
public:
property BackupOptions^ BackupOptions {
    BackupOptions^ get ();
    void set (BackupOptions^ value);
}

See Also

DeploymentOptions Class
RedGate.SQLCompare.Engine.ApiHelpers Namespace


DateTimeProvider Property

[image]

SQL Data Compare API 12.0.40
DeploymentOptions..::.DateTimeProvider Property
DeploymentOptions Class See Also

Namespace: RedGate.SQLCompare.Engine.ApiHelpers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DateTimeProvider As IDateTimeProvider
C#
public IDateTimeProvider DateTimeProvider { get; private set; }
Visual C++
public:
property IDateTimeProvider^ DateTimeProvider {
    IDateTimeProvider^ get ();
    void set (IDateTimeProvider^ value);
}

See Also

DeploymentOptions Class
RedGate.SQLCompare.Engine.ApiHelpers Namespace


Options Property

[image]

SQL Data Compare API 12.0.40
DeploymentOptions..::.Options Property
DeploymentOptions Class See Also

Namespace: RedGate.SQLCompare.Engine.ApiHelpers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Options As Options
C#
public Options Options { get; private set; }
Visual C++
public:
property Options Options {
    Options get ();
    void set (Options value);
}

See Also

DeploymentOptions Class
RedGate.SQLCompare.Engine.ApiHelpers Namespace


ProductInfo Property

[image]

SQL Data Compare API 12.0.40
DeploymentOptions..::.ProductInfo Property
DeploymentOptions Class See Also

Namespace: RedGate.SQLCompare.Engine.ApiHelpers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ProductInfo As String
C#
public string ProductInfo { get; set; }
Visual C++
public:
property String^ ProductInfo {
    String^ get ();
    void set (String^ value);
}

See Also

DeploymentOptions Class
RedGate.SQLCompare.Engine.ApiHelpers Namespace


TransactionIsolationLevel Property

[image]

SQL Data Compare API 12.0.40
DeploymentOptions..::.TransactionIsolationLevel Property
DeploymentOptions Class See Also

Namespace: RedGate.SQLCompare.Engine.ApiHelpers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TransactionIsolationLevel As String
C#
public string TransactionIsolationLevel { get; set; }
Visual C++
public:
property String^ TransactionIsolationLevel {
    String^ get ();
    void set (String^ value);
}

See Also

DeploymentOptions Class
RedGate.SQLCompare.Engine.ApiHelpers Namespace


DeploymentScriptStatementFactory Class

[image]

SQL Data Compare API 12.0.40
DeploymentScriptStatementFactory Class
Members See Also

Used to create IDeploymentScriptStatements for use in a IDeploymentPlan

Namespace: RedGate.SQLCompare.Engine.ApiHelpers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class DeploymentScriptStatementFactory _
    Implements ISqlStatementFactory
C#
public class DeploymentScriptStatementFactory : ISqlStatementFactory
Visual C++
public ref class DeploymentScriptStatementFactory : ISqlStatementFactory

Remarks

Intended for use with Deployment Blocks

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ApiHelpers..::.DeploymentScriptStatementFactory

See Also

DeploymentScriptStatementFactory Members
RedGate.SQLCompare.Engine.ApiHelpers Namespace


DeploymentScriptStatementFactory Members

[image] [image]

SQL Data Compare API 12.0.40
DeploymentScriptStatementFactory Members
DeploymentScriptStatementFactory Class Constructors Methods See Also

The DeploymentScriptStatementFactory type exposes the following members.

Constructors

Name | Description
DeploymentScriptStatementFactory |

Methods

Name | Description
CreateStatements | Creates statements for a user-specified script
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeploymentScriptStatementFactory Class
RedGate.SQLCompare.Engine.ApiHelpers Namespace


DeploymentScriptStatementFactory Constructor

[image]

SQL Data Compare API 12.0.40
DeploymentScriptStatementFactory Constructor
DeploymentScriptStatementFactory Class See Also

Namespace: RedGate.SQLCompare.Engine.ApiHelpers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DeploymentScriptStatementFactory()
Visual C++
public:
DeploymentScriptStatementFactory()

See Also

DeploymentScriptStatementFactory Class
RedGate.SQLCompare.Engine.ApiHelpers Namespace


DeploymentScriptStatementFactory Methods

[image] [image]

SQL Data Compare API 12.0.40
DeploymentScriptStatementFactory Methods
DeploymentScriptStatementFactory Class See Also

The DeploymentScriptStatementFactory type exposes the following methods.

Methods

Name | Description
CreateStatements | Creates statements for a user-specified script
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeploymentScriptStatementFactory Class
RedGate.SQLCompare.Engine.ApiHelpers Namespace


CreateStatements Method

[image]

SQL Data Compare API 12.0.40
DeploymentScriptStatementFactory..::.CreateStatements Method
DeploymentScriptStatementFactory Class See Also

Creates statements for a user-specified script

Namespace: RedGate.SQLCompare.Engine.ApiHelpers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateStatements ( _
    lazySql As Func(Of String) _
) As IEnumerable(Of IDeploymentScriptStatement)
C#
public IEnumerable<IDeploymentScriptStatement> CreateStatements(
    Func<string> lazySql
)
Visual C++
public:
virtual IEnumerable<IDeploymentScriptStatement^>^ CreateStatements(
    Func<String^>^ lazySql
) sealed

Parameters

lazySql
Type: Func<(Of <(String>)>)

Implements

ISqlStatementFactoryCreateStatements(Func<(Of <(String>)>))

See Also

DeploymentScriptStatementFactory Class
RedGate.SQLCompare.Engine.ApiHelpers Namespace


StagedDeploymentSqlGenerator Class

[image]

SQL Data Compare API 12.0.40
StagedDeploymentSqlGenerator Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ApiHelpers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class StagedDeploymentSqlGenerator _
    Inherits DisposableBase _
    Implements IStagedDeploymentSqlGenerator
C#
public class StagedDeploymentSqlGenerator : DisposableBase, IStagedDeploymentSqlGenerator
Visual C++
public ref class StagedDeploymentSqlGenerator : public DisposableBase,
    IStagedDeploymentSqlGenerator

Remarks

Intended for use with Deployment Blocks. For each deployment block, GenerateDeploymentPlan(DirectoryInfo, DirectoryInfo, IDifferenceFilterer) will be called. The results will be merged, and GenerateSql(IDeploymentPlan) will be used to create a final script.

Inheritance Hierarchy

Object
RedGate.Shared.Utils..::.DisposableBase
RedGate.SQLCompare.Engine.ApiHelpers..::.StagedDeploymentSqlGenerator

See Also

StagedDeploymentSqlGenerator Members
RedGate.SQLCompare.Engine.ApiHelpers Namespace


StagedDeploymentSqlGenerator Members

[image] [image]

SQL Data Compare API 12.0.40
StagedDeploymentSqlGenerator Members
StagedDeploymentSqlGenerator Class Constructors Methods Properties See Also

The StagedDeploymentSqlGenerator type exposes the following members.

Constructors

Name | Description
StagedDeploymentSqlGenerator |

Methods

Name | Description
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GenerateDeploymentPlan |
GenerateSql |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDisposed | Returns a value indicating if this instance has been disposed. (Inherited from DisposableBase.)

See Also

StagedDeploymentSqlGenerator Class
RedGate.SQLCompare.Engine.ApiHelpers Namespace


StagedDeploymentSqlGenerator Constructor

[image]

SQL Data Compare API 12.0.40
StagedDeploymentSqlGenerator Constructor
StagedDeploymentSqlGenerator Class See Also

Namespace: RedGate.SQLCompare.Engine.ApiHelpers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    deploymentOptions As DeploymentOptions, _
    targetDatabaseMetadata As IDatabase _
)
C#
public StagedDeploymentSqlGenerator(
    DeploymentOptions deploymentOptions,
    IDatabase targetDatabaseMetadata
)
Visual C++
public:
StagedDeploymentSqlGenerator(
    DeploymentOptions^ deploymentOptions,
    IDatabase^ targetDatabaseMetadata
)

Parameters

deploymentOptions
Type: RedGate.SQLCompare.Engine.ApiHelpers..::.DeploymentOptions
targetDatabaseMetadata
Type: RedGate.SQLCompare.Engine..::.IDatabase

See Also

StagedDeploymentSqlGenerator Class
RedGate.SQLCompare.Engine.ApiHelpers Namespace


StagedDeploymentSqlGenerator Methods

[image] [image]

SQL Data Compare API 12.0.40
StagedDeploymentSqlGenerator Methods
StagedDeploymentSqlGenerator Class See Also

The StagedDeploymentSqlGenerator type exposes the following methods.

Methods

Name | Description
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GenerateDeploymentPlan |
GenerateSql |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StagedDeploymentSqlGenerator Class
RedGate.SQLCompare.Engine.ApiHelpers Namespace


Dispose Method

[image] [image]

SQL Data Compare API 12.0.40
StagedDeploymentSqlGenerator..::.Dispose Method
StagedDeploymentSqlGenerator Class See Also

Overload List

Name | Description
Dispose()()() | (Inherited from DisposableBase.)
Dispose(Boolean) | (Overrides DisposableBase ..::. Dispose(Boolean).)

See Also

StagedDeploymentSqlGenerator Class
StagedDeploymentSqlGenerator Members
RedGate.SQLCompare.Engine.ApiHelpers Namespace


Dispose Method ()

[image]

SQL Data Compare API 12.0.40
StagedDeploymentSqlGenerator..::.Dispose Method ()
StagedDeploymentSqlGenerator Class See Also

Namespace: RedGate.SQLCompare.Engine.ApiHelpers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
C#
protected override void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: Boolean

See Also

StagedDeploymentSqlGenerator Class
Dispose Overload
RedGate.SQLCompare.Engine.ApiHelpers Namespace


GenerateDeploymentPlan Method

[image]

SQL Data Compare API 12.0.40
StagedDeploymentSqlGenerator..::.GenerateDeploymentPlan Method
StagedDeploymentSqlGenerator Class See Also

Namespace: RedGate.SQLCompare.Engine.ApiHelpers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GenerateDeploymentPlan ( _
    sourceScriptsFolder As DirectoryInfo, _
    targetScriptsFolder As DirectoryInfo, _
    differenceFilterer As IDifferenceFilterer _
) As IDeploymentPlan
C#
public IDeploymentPlan GenerateDeploymentPlan(
    DirectoryInfo sourceScriptsFolder,
    DirectoryInfo targetScriptsFolder,
    IDifferenceFilterer differenceFilterer
)
Visual C++
public:
virtual IDeploymentPlan^ GenerateDeploymentPlan(
    DirectoryInfo^ sourceScriptsFolder,
    DirectoryInfo^ targetScriptsFolder,
    IDifferenceFilterer^ differenceFilterer
) sealed

Parameters

sourceScriptsFolder
Type: DirectoryInfo
targetScriptsFolder
Type: DirectoryInfo
differenceFilterer
Type: IDifferenceFilterer

Implements

IStagedDeploymentSqlGeneratorGenerateDeploymentPlan(DirectoryInfo, DirectoryInfo, IDifferenceFilterer)

Remarks

The statements generated must not contain any metadata about targetScriptsFolder since the generated script is intended to run against the target database specified in the constructor.

See Also

StagedDeploymentSqlGenerator Class
RedGate.SQLCompare.Engine.ApiHelpers Namespace


GenerateSql Method

[image]

SQL Data Compare API 12.0.40
StagedDeploymentSqlGenerator..::.GenerateSql Method
StagedDeploymentSqlGenerator Class See Also

Namespace: RedGate.SQLCompare.Engine.ApiHelpers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GenerateSql ( _
    actionSqlSections As IDeploymentPlan _
) As ISqlGenerationResult
C#
public ISqlGenerationResult GenerateSql(
    IDeploymentPlan actionSqlSections
)
Visual C++
public:
virtual ISqlGenerationResult^ GenerateSql(
    IDeploymentPlan^ actionSqlSections
) sealed

Parameters

actionSqlSections
Type: IDeploymentPlan

Implements

IStagedDeploymentSqlGeneratorGenerateSql(IDeploymentPlan)

See Also

StagedDeploymentSqlGenerator Class
RedGate.SQLCompare.Engine.ApiHelpers Namespace


RedGate.SQLCompare.Engine.ClrMetaData Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.ClrMetaData Namespace

Classes

Class | Description
ClrAssemblyStrongName |


ClrAssemblyStrongName Class

[image]

SQL Data Compare API 12.0.40
ClrAssemblyStrongName Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ClrMetaData
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class ClrAssemblyStrongName
C#
[SerializableAttribute]
public sealed class ClrAssemblyStrongName
Visual C++
[SerializableAttribute]
public ref class ClrAssemblyStrongName sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ClrMetaData..::.ClrAssemblyStrongName

See Also

ClrAssemblyStrongName Members
RedGate.SQLCompare.Engine.ClrMetaData Namespace


ClrAssemblyStrongName Members

[image] [image]

SQL Data Compare API 12.0.40
ClrAssemblyStrongName Members
ClrAssemblyStrongName Class Constructors Methods Properties See Also

The ClrAssemblyStrongName type exposes the following members.

Constructors

Name | Description
ClrAssemblyStrongName |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromAssembly |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Name |
Version |

See Also

ClrAssemblyStrongName Class
RedGate.SQLCompare.Engine.ClrMetaData Namespace


ClrAssemblyStrongName Constructor

[image]

SQL Data Compare API 12.0.40
ClrAssemblyStrongName Constructor
ClrAssemblyStrongName Class See Also

Namespace: RedGate.SQLCompare.Engine.ClrMetaData
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    version As Version _
)
C#
public ClrAssemblyStrongName(
    string name,
    Version version
)
Visual C++
public:
ClrAssemblyStrongName(
    String^ name,
    Version^ version
)

Parameters

name
Type: String
version
Type: Version

See Also

ClrAssemblyStrongName Class
RedGate.SQLCompare.Engine.ClrMetaData Namespace


ClrAssemblyStrongName Methods

[image] [image]

SQL Data Compare API 12.0.40
ClrAssemblyStrongName Methods
ClrAssemblyStrongName Class See Also

The ClrAssemblyStrongName type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromAssembly |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ClrAssemblyStrongName Class
RedGate.SQLCompare.Engine.ClrMetaData Namespace


FromAssembly Method

[image]

SQL Data Compare API 12.0.40
ClrAssemblyStrongName..::.FromAssembly Method
ClrAssemblyStrongName Class See Also

Namespace: RedGate.SQLCompare.Engine.ClrMetaData
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FromAssembly ( _
    assembly As IAssembly _
) As ClrAssemblyStrongName
C#
public static ClrAssemblyStrongName FromAssembly(
    IAssembly assembly
)
Visual C++
public:
static ClrAssemblyStrongName^ FromAssembly(
    IAssembly^ assembly
)

Parameters

assembly
Type: IAssembly

See Also

ClrAssemblyStrongName Class
RedGate.SQLCompare.Engine.ClrMetaData Namespace


ClrAssemblyStrongName Properties

[image] [image]

SQL Data Compare API 12.0.40
ClrAssemblyStrongName Properties
ClrAssemblyStrongName Class See Also

The ClrAssemblyStrongName type exposes the following properties.

Properties

Name | Description
Name |
Version |

See Also

ClrAssemblyStrongName Class
RedGate.SQLCompare.Engine.ClrMetaData Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
ClrAssemblyStrongName..::.Name Property
ClrAssemblyStrongName Class See Also

Namespace: RedGate.SQLCompare.Engine.ClrMetaData
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

ClrAssemblyStrongName Class
RedGate.SQLCompare.Engine.ClrMetaData Namespace


Version Property

[image]

SQL Data Compare API 12.0.40
ClrAssemblyStrongName..::.Version Property
ClrAssemblyStrongName Class See Also

Namespace: RedGate.SQLCompare.Engine.ClrMetaData
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As Version
C#
public Version Version { get; }
Visual C++
public:
property Version^ Version {
    Version^ get ();
}

See Also

ClrAssemblyStrongName Class
RedGate.SQLCompare.Engine.ClrMetaData Namespace


RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace

Classes

Class | Description
ObjectNameUtils |

Interfaces

Interface | Description
IComparableDatabase |
IDatabaseObjects |
IFullDatabaseObjects |


IComparableDatabase Interface

[image]

SQL Data Compare API 12.0.40
IComparableDatabase Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IComparableDatabase _
    Implements IDatabaseObjects, IVersionedDatabase
C#
public interface IComparableDatabase : IDatabaseObjects,
    IVersionedDatabase
Visual C++
public interface class IComparableDatabase : IDatabaseObjects,
    IVersionedDatabase

See Also

IComparableDatabase Members
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


IComparableDatabase Members

[image] [image]

SQL Data Compare API 12.0.40
IComparableDatabase Members
IComparableDatabase Interface Methods Properties See Also

The IComparableDatabase type exposes the following members.

Methods

Name | Description
GetDatabaseObject | (Inherited from IDatabaseObjects.)
GetDatabaseObjects<(Of <(T>)>) |

Properties

Name | Description
Assemblies | The CLR assemblies in the database. Note that CLR assemblies were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
AsymmetricKeys | The asymmetric keys in the database. Note that asymmetric keys were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Certificates | The certificates in the database. Note that certificates were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Contracts | The contracts in the database. Note that contracts were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
DdlTriggers | The DDL triggers in the database. (Inherited from IDatabaseObjects.)
Defaults | The defaults in the database. (Inherited from IDatabaseObjects.)
EventNotifications | The database-level event notifications in the database. Note that event notifications were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
ExtendedProperties | Database-level extended properties. (Inherited from IDatabaseObjects.)
FullTextCatalogs | The full-text catalogs in the database. (Inherited from IDatabaseObjects.)
FullTextStoplists | The full-text stoplists in the database. (Inherited from IDatabaseObjects.)
Functions | The user-defined functions in the database. (Inherited from IDatabaseObjects.)
MajorVersion | The major version of the SQL Server for the database. This reflects the compatibility mode of the database. (Inherited from IVersionedDatabase.)
MessageTypes | The message types in the database. Note that message types were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
PartitionFunctions | The partition functions in the database. Note that partition functions were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
PartitionSchemes | The partition schemes in the database. Note that partitions schemes were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Queues | The queues in the database. Note that queues were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Roles | The roles in the database. (Inherited from IDatabaseObjects.)
Routes | The routes in the database. Note that routes were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Rules | The rules in the database. (Inherited from IDatabaseObjects.)
Schemas | The schemas in the database. Note that schemas were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
SearchPropertyLists | (Inherited from IDatabaseObjects.)
SecurityPolicies | The security policies in the database. (Inherited from IDatabaseObjects.)
Sequences | The sequence objects in the database. Note that these were introduced in SQL Server 2012 (Inherited from IDatabaseObjects.)
ServerMajorVersion | The major server version of the SQL Server for the database. This does not change if the database is running in compatibility mode. (Inherited from IVersionedDatabase.)
ServiceBindings | The service bindings in the database. Note that service bindings were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Services | The services in the database. Note that services were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
SqlServerVersionInfo | Information about the version of SQL Server this database exists on, including version number, compatibility level, internal version and whether or not it's an Azure database. (Inherited from IVersionedDatabase.)
StoredProcedures | The stored procedures in the database. (Inherited from IDatabaseObjects.)
SupportedFeatures | (Inherited from IVersionedDatabase.)
SymmetricKeys | The symmetric keys in the database. Note that symmetric keys were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Synonyms | The synonyms in the database. Note that synonyms were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Tables | The tables in the database. (Inherited from IDatabaseObjects.)
TotalObjectCount |
UserDefinedTypes | The user-defined types in the database. (Inherited from IDatabaseObjects.)
Users | The users in the database. (Inherited from IDatabaseObjects.)
Views | The views in the database. (Inherited from IDatabaseObjects.)
XmlSchemaCollections | The XML schema collections in the database. Note that XML schema collections were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)

See Also

IComparableDatabase Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


IComparableDatabase Methods

[image] [image]

SQL Data Compare API 12.0.40
IComparableDatabase Methods
IComparableDatabase Interface See Also

The IComparableDatabase type exposes the following methods.

Methods

Name | Description
GetDatabaseObject | (Inherited from IDatabaseObjects.)
GetDatabaseObjects<(Of <(T>)>) |

See Also

IComparableDatabase Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


GetDatabaseObjects(T) Generic Method

[image]

SQL Data Compare API 12.0.40
IComparableDatabase..::.GetDatabaseObjects<(Of <(T>)>) Generic Method
IComparableDatabase Interface See Also

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetDatabaseObjects(Of T As IDatabaseObject) As IDatabaseObjects(Of T)
C#
IDatabaseObjects<T> GetDatabaseObjects<T>() where T : IDatabaseObject
Visual C++
generic<typename T>
where T : IDatabaseObject
IDatabaseObjects<T>^ GetDatabaseObjects()

Type Parameters

T

See Also

IComparableDatabase Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


IComparableDatabase Properties

[image] [image]

SQL Data Compare API 12.0.40
IComparableDatabase Properties
IComparableDatabase Interface See Also

The IComparableDatabase type exposes the following properties.

Properties

Name | Description
Assemblies | The CLR assemblies in the database. Note that CLR assemblies were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
AsymmetricKeys | The asymmetric keys in the database. Note that asymmetric keys were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Certificates | The certificates in the database. Note that certificates were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Contracts | The contracts in the database. Note that contracts were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
DdlTriggers | The DDL triggers in the database. (Inherited from IDatabaseObjects.)
Defaults | The defaults in the database. (Inherited from IDatabaseObjects.)
EventNotifications | The database-level event notifications in the database. Note that event notifications were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
ExtendedProperties | Database-level extended properties. (Inherited from IDatabaseObjects.)
FullTextCatalogs | The full-text catalogs in the database. (Inherited from IDatabaseObjects.)
FullTextStoplists | The full-text stoplists in the database. (Inherited from IDatabaseObjects.)
Functions | The user-defined functions in the database. (Inherited from IDatabaseObjects.)
MajorVersion | The major version of the SQL Server for the database. This reflects the compatibility mode of the database. (Inherited from IVersionedDatabase.)
MessageTypes | The message types in the database. Note that message types were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
PartitionFunctions | The partition functions in the database. Note that partition functions were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
PartitionSchemes | The partition schemes in the database. Note that partitions schemes were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Queues | The queues in the database. Note that queues were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Roles | The roles in the database. (Inherited from IDatabaseObjects.)
Routes | The routes in the database. Note that routes were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Rules | The rules in the database. (Inherited from IDatabaseObjects.)
Schemas | The schemas in the database. Note that schemas were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
SearchPropertyLists | (Inherited from IDatabaseObjects.)
SecurityPolicies | The security policies in the database. (Inherited from IDatabaseObjects.)
Sequences | The sequence objects in the database. Note that these were introduced in SQL Server 2012 (Inherited from IDatabaseObjects.)
ServerMajorVersion | The major server version of the SQL Server for the database. This does not change if the database is running in compatibility mode. (Inherited from IVersionedDatabase.)
ServiceBindings | The service bindings in the database. Note that service bindings were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Services | The services in the database. Note that services were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
SqlServerVersionInfo | Information about the version of SQL Server this database exists on, including version number, compatibility level, internal version and whether or not it's an Azure database. (Inherited from IVersionedDatabase.)
StoredProcedures | The stored procedures in the database. (Inherited from IDatabaseObjects.)
SupportedFeatures | (Inherited from IVersionedDatabase.)
SymmetricKeys | The symmetric keys in the database. Note that symmetric keys were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Synonyms | The synonyms in the database. Note that synonyms were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Tables | The tables in the database. (Inherited from IDatabaseObjects.)
TotalObjectCount |
UserDefinedTypes | The user-defined types in the database. (Inherited from IDatabaseObjects.)
Users | The users in the database. (Inherited from IDatabaseObjects.)
Views | The views in the database. (Inherited from IDatabaseObjects.)
XmlSchemaCollections | The XML schema collections in the database. Note that XML schema collections were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)

See Also

IComparableDatabase Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


TotalObjectCount Property

[image]

SQL Data Compare API 12.0.40
IComparableDatabase..::.TotalObjectCount Property
IComparableDatabase Interface See Also

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TotalObjectCount As Integer
C#
int TotalObjectCount { get; }
Visual C++
property int TotalObjectCount {
    int get ();
}

See Also

IComparableDatabase Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


IDatabaseObjects Interface

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDatabaseObjects
C#
public interface IDatabaseObjects
Visual C++
public interface class IDatabaseObjects

See Also

IDatabaseObjects Members
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


IDatabaseObjects Members

[image] [image]

SQL Data Compare API 12.0.40
IDatabaseObjects Members
IDatabaseObjects Interface Methods Properties See Also

The IDatabaseObjects type exposes the following members.

Methods

Name | Description
GetDatabaseObject |

Properties

Name | Description
Assemblies | The CLR assemblies in the database. Note that CLR assemblies were introduced in SQL Server 2005.
AsymmetricKeys | The asymmetric keys in the database. Note that asymmetric keys were introduced in SQL Server 2005.
Certificates | The certificates in the database. Note that certificates were introduced in SQL Server 2005.
Contracts | The contracts in the database. Note that contracts were introduced in SQL Server 2005.
DdlTriggers | The DDL triggers in the database.
Defaults | The defaults in the database.
EventNotifications | The database-level event notifications in the database. Note that event notifications were introduced in SQL Server 2005.
ExtendedProperties | Database-level extended properties.
FullTextCatalogs | The full-text catalogs in the database.
FullTextStoplists | The full-text stoplists in the database.
Functions | The user-defined functions in the database.
MessageTypes | The message types in the database. Note that message types were introduced in SQL Server 2005.
PartitionFunctions | The partition functions in the database. Note that partition functions were introduced in SQL Server 2005.
PartitionSchemes | The partition schemes in the database. Note that partitions schemes were introduced in SQL Server 2005.
Queues | The queues in the database. Note that queues were introduced in SQL Server 2005.
Roles | The roles in the database.
Routes | The routes in the database. Note that routes were introduced in SQL Server 2005.
Rules | The rules in the database.
Schemas | The schemas in the database. Note that schemas were introduced in SQL Server 2005.
SearchPropertyLists |
SecurityPolicies | The security policies in the database.
Sequences | The sequence objects in the database. Note that these were introduced in SQL Server 2012
ServiceBindings | The service bindings in the database. Note that service bindings were introduced in SQL Server 2005.
Services | The services in the database. Note that services were introduced in SQL Server 2005.
StoredProcedures | The stored procedures in the database.
SymmetricKeys | The symmetric keys in the database. Note that symmetric keys were introduced in SQL Server 2005.
Synonyms | The synonyms in the database. Note that synonyms were introduced in SQL Server 2005.
Tables | The tables in the database.
UserDefinedTypes | The user-defined types in the database.
Users | The users in the database.
Views | The views in the database.
XmlSchemaCollections | The XML schema collections in the database. Note that XML schema collections were introduced in SQL Server 2005.

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


IDatabaseObjects Methods

[image] [image]

SQL Data Compare API 12.0.40
IDatabaseObjects Methods
IDatabaseObjects Interface See Also

The IDatabaseObjects type exposes the following methods.

Methods

Name | Description
GetDatabaseObject |

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


GetDatabaseObject Method

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.GetDatabaseObject Method
IDatabaseObjects Interface See Also

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetDatabaseObject ( _
    name As String, _
    type As ObjectType _
) As IDatabaseObject
C#
IDatabaseObject GetDatabaseObject(
    string name,
    ObjectType type
)
Visual C++
IDatabaseObject^ GetDatabaseObject(
    String^ name,
    ObjectType type
)

Parameters

name
Type: String
type
Type: ObjectType

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


IDatabaseObjects Properties

[image] [image]

SQL Data Compare API 12.0.40
IDatabaseObjects Properties
IDatabaseObjects Interface See Also

The IDatabaseObjects type exposes the following properties.

Properties

Name | Description
Assemblies | The CLR assemblies in the database. Note that CLR assemblies were introduced in SQL Server 2005.
AsymmetricKeys | The asymmetric keys in the database. Note that asymmetric keys were introduced in SQL Server 2005.
Certificates | The certificates in the database. Note that certificates were introduced in SQL Server 2005.
Contracts | The contracts in the database. Note that contracts were introduced in SQL Server 2005.
DdlTriggers | The DDL triggers in the database.
Defaults | The defaults in the database.
EventNotifications | The database-level event notifications in the database. Note that event notifications were introduced in SQL Server 2005.
ExtendedProperties | Database-level extended properties.
FullTextCatalogs | The full-text catalogs in the database.
FullTextStoplists | The full-text stoplists in the database.
Functions | The user-defined functions in the database.
MessageTypes | The message types in the database. Note that message types were introduced in SQL Server 2005.
PartitionFunctions | The partition functions in the database. Note that partition functions were introduced in SQL Server 2005.
PartitionSchemes | The partition schemes in the database. Note that partitions schemes were introduced in SQL Server 2005.
Queues | The queues in the database. Note that queues were introduced in SQL Server 2005.
Roles | The roles in the database.
Routes | The routes in the database. Note that routes were introduced in SQL Server 2005.
Rules | The rules in the database.
Schemas | The schemas in the database. Note that schemas were introduced in SQL Server 2005.
SearchPropertyLists |
SecurityPolicies | The security policies in the database.
Sequences | The sequence objects in the database. Note that these were introduced in SQL Server 2012
ServiceBindings | The service bindings in the database. Note that service bindings were introduced in SQL Server 2005.
Services | The services in the database. Note that services were introduced in SQL Server 2005.
StoredProcedures | The stored procedures in the database.
SymmetricKeys | The symmetric keys in the database. Note that symmetric keys were introduced in SQL Server 2005.
Synonyms | The synonyms in the database. Note that synonyms were introduced in SQL Server 2005.
Tables | The tables in the database.
UserDefinedTypes | The user-defined types in the database.
Users | The users in the database.
Views | The views in the database.
XmlSchemaCollections | The XML schema collections in the database. Note that XML schema collections were introduced in SQL Server 2005.

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Assemblies Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.Assemblies Property
IDatabaseObjects Interface See Also

The CLR assemblies in the database. Note that CLR assemblies were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Assemblies As ClrAssemblies
C#
ClrAssemblies Assemblies { get; }
Visual C++
property ClrAssemblies^ Assemblies {
    ClrAssemblies^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


AsymmetricKeys Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.AsymmetricKeys Property
IDatabaseObjects Interface See Also

The asymmetric keys in the database. Note that asymmetric keys were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property AsymmetricKeys As AsymmetricKeys
C#
AsymmetricKeys AsymmetricKeys { get; }
Visual C++
property AsymmetricKeys^ AsymmetricKeys {
    AsymmetricKeys^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Certificates Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.Certificates Property
IDatabaseObjects Interface See Also

The certificates in the database. Note that certificates were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Certificates As Certificates
C#
Certificates Certificates { get; }
Visual C++
property Certificates^ Certificates {
    Certificates^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Contracts Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.Contracts Property
IDatabaseObjects Interface See Also

The contracts in the database. Note that contracts were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Contracts As Contracts
C#
Contracts Contracts { get; }
Visual C++
property Contracts^ Contracts {
    Contracts^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


DdlTriggers Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.DdlTriggers Property
IDatabaseObjects Interface See Also

The DDL triggers in the database.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DdlTriggers As DdlTriggers
C#
DdlTriggers DdlTriggers { get; }
Visual C++
property DdlTriggers^ DdlTriggers {
    DdlTriggers^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Defaults Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.Defaults Property
IDatabaseObjects Interface See Also

The defaults in the database.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Defaults As Defaults
C#
Defaults Defaults { get; }
Visual C++
property Defaults^ Defaults {
    Defaults^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


EventNotifications Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.EventNotifications Property
IDatabaseObjects Interface See Also

The database-level event notifications in the database. Note that event notifications were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property EventNotifications As EventNotifications
C#
EventNotifications EventNotifications { get; }
Visual C++
property EventNotifications^ EventNotifications {
    EventNotifications^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


ExtendedProperties Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.ExtendedProperties Property
IDatabaseObjects Interface See Also

Database-level extended properties.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ExtendedProperties As ExtendedProperties
C#
ExtendedProperties ExtendedProperties { get; }
Visual C++
property ExtendedProperties^ ExtendedProperties {
    ExtendedProperties^ get ();
}

Remarks

The collection contains extended properties that have been defined at the database level. Individual database objects (such as tables and users) can also have extended properties defined on them.

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


FullTextCatalogs Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.FullTextCatalogs Property
IDatabaseObjects Interface See Also

The full-text catalogs in the database.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property FullTextCatalogs As FullTextCatalogs
C#
FullTextCatalogs FullTextCatalogs { get; }
Visual C++
property FullTextCatalogs^ FullTextCatalogs {
    FullTextCatalogs^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


FullTextStoplists Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.FullTextStoplists Property
IDatabaseObjects Interface See Also

The full-text stoplists in the database.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property FullTextStoplists As FullTextStoplists
C#
FullTextStoplists FullTextStoplists { get; }
Visual C++
property FullTextStoplists^ FullTextStoplists {
    FullTextStoplists^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Functions Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.Functions Property
IDatabaseObjects Interface See Also

The user-defined functions in the database.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Functions As Functions
C#
Functions Functions { get; }
Visual C++
property Functions^ Functions {
    Functions^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


MessageTypes Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.MessageTypes Property
IDatabaseObjects Interface See Also

The message types in the database. Note that message types were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property MessageTypes As MessageTypes
C#
MessageTypes MessageTypes { get; }
Visual C++
property MessageTypes^ MessageTypes {
    MessageTypes^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


PartitionFunctions Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.PartitionFunctions Property
IDatabaseObjects Interface See Also

The partition functions in the database. Note that partition functions were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property PartitionFunctions As PartitionFunctions
C#
PartitionFunctions PartitionFunctions { get; }
Visual C++
property PartitionFunctions^ PartitionFunctions {
    PartitionFunctions^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


PartitionSchemes Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.PartitionSchemes Property
IDatabaseObjects Interface See Also

The partition schemes in the database. Note that partitions schemes were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property PartitionSchemes As PartitionSchemes
C#
PartitionSchemes PartitionSchemes { get; }
Visual C++
property PartitionSchemes^ PartitionSchemes {
    PartitionSchemes^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Queues Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.Queues Property
IDatabaseObjects Interface See Also

The queues in the database. Note that queues were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Queues As Queues
C#
Queues Queues { get; }
Visual C++
property Queues^ Queues {
    Queues^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Roles Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.Roles Property
IDatabaseObjects Interface See Also

The roles in the database.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Roles As Roles
C#
Roles Roles { get; }
Visual C++
property Roles^ Roles {
    Roles^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Routes Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.Routes Property
IDatabaseObjects Interface See Also

The routes in the database. Note that routes were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Routes As Routes
C#
Routes Routes { get; }
Visual C++
property Routes^ Routes {
    Routes^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Rules Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.Rules Property
IDatabaseObjects Interface See Also

The rules in the database.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Rules As Rules
C#
Rules Rules { get; }
Visual C++
property Rules^ Rules {
    Rules^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Schemas Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.Schemas Property
IDatabaseObjects Interface See Also

The schemas in the database. Note that schemas were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Schemas As Schemas
C#
Schemas Schemas { get; }
Visual C++
property Schemas^ Schemas {
    Schemas^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


SearchPropertyLists Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.SearchPropertyLists Property
IDatabaseObjects Interface See Also

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SearchPropertyLists As SearchPropertyLists
C#
SearchPropertyLists SearchPropertyLists { get; }
Visual C++
property SearchPropertyLists^ SearchPropertyLists {
    SearchPropertyLists^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


SecurityPolicies Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.SecurityPolicies Property
IDatabaseObjects Interface See Also

The security policies in the database.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SecurityPolicies As DatabaseObjectCollection(Of SecurityPolicy)
C#
DatabaseObjectCollection<SecurityPolicy> SecurityPolicies { get; }
Visual C++
property DatabaseObjectCollection<SecurityPolicy^>^ SecurityPolicies {
    DatabaseObjectCollection<SecurityPolicy^>^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Sequences Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.Sequences Property
IDatabaseObjects Interface See Also

The sequence objects in the database. Note that these were introduced in SQL Server 2012

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Sequences As Sequences
C#
Sequences Sequences { get; }
Visual C++
property Sequences^ Sequences {
    Sequences^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


ServiceBindings Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.ServiceBindings Property
IDatabaseObjects Interface See Also

The service bindings in the database. Note that service bindings were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ServiceBindings As ServiceBindings
C#
ServiceBindings ServiceBindings { get; }
Visual C++
property ServiceBindings^ ServiceBindings {
    ServiceBindings^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Services Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.Services Property
IDatabaseObjects Interface See Also

The services in the database. Note that services were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Services As Services
C#
Services Services { get; }
Visual C++
property Services^ Services {
    Services^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


StoredProcedures Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.StoredProcedures Property
IDatabaseObjects Interface See Also

The stored procedures in the database.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property StoredProcedures As StoredProcedures
C#
StoredProcedures StoredProcedures { get; }
Visual C++
property StoredProcedures^ StoredProcedures {
    StoredProcedures^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


SymmetricKeys Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.SymmetricKeys Property
IDatabaseObjects Interface See Also

The symmetric keys in the database. Note that symmetric keys were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SymmetricKeys As SymmetricKeys
C#
SymmetricKeys SymmetricKeys { get; }
Visual C++
property SymmetricKeys^ SymmetricKeys {
    SymmetricKeys^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Synonyms Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.Synonyms Property
IDatabaseObjects Interface See Also

The synonyms in the database. Note that synonyms were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Synonyms As Synonyms
C#
Synonyms Synonyms { get; }
Visual C++
property Synonyms^ Synonyms {
    Synonyms^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Tables Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.Tables Property
IDatabaseObjects Interface See Also

The tables in the database.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Tables As Tables
C#
Tables Tables { get; }
Visual C++
property Tables^ Tables {
    Tables^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


UserDefinedTypes Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.UserDefinedTypes Property
IDatabaseObjects Interface See Also

The user-defined types in the database.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property UserDefinedTypes As UserDefinedTypes
C#
UserDefinedTypes UserDefinedTypes { get; }
Visual C++
property UserDefinedTypes^ UserDefinedTypes {
    UserDefinedTypes^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Users Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.Users Property
IDatabaseObjects Interface See Also

The users in the database.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Users As Users
C#
Users Users { get; }
Visual C++
property Users^ Users {
    Users^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Views Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.Views Property
IDatabaseObjects Interface See Also

The views in the database.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Views As Views
C#
Views Views { get; }
Visual C++
property Views^ Views {
    Views^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


XmlSchemaCollections Property

[image]

SQL Data Compare API 12.0.40
IDatabaseObjects..::.XmlSchemaCollections Property
IDatabaseObjects Interface See Also

The XML schema collections in the database. Note that XML schema collections were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property XmlSchemaCollections As XmlSchemaCollections
C#
XmlSchemaCollections XmlSchemaCollections { get; }
Visual C++
property XmlSchemaCollections^ XmlSchemaCollections {
    XmlSchemaCollections^ get ();
}

See Also

IDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


IFullDatabaseObjects Interface

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IFullDatabaseObjects
C#
public interface IFullDatabaseObjects
Visual C++
public interface class IFullDatabaseObjects

See Also

IFullDatabaseObjects Members
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


IFullDatabaseObjects Members

[image] [image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects Members
IFullDatabaseObjects Interface Methods Properties See Also

The IFullDatabaseObjects type exposes the following members.

Methods

Name | Description
GetDatabaseObject |

Properties

Name | Description
Assemblies | The CLR assemblies in the database. Note that CLR assemblies were introduced in SQL Server 2005.
AsymmetricKeys | The asymmetric keys in the database. Note that asymmetric keys were introduced in SQL Server 2005.
Certificates | The certificates in the database. Note that certificates were introduced in SQL Server 2005.
Contracts | The contracts in the database. Note that contracts were introduced in SQL Server 2005.
DdlTriggers | The DDL triggers in the database.
Defaults | The defaults in the database.
EventNotifications | The database-level event notifications in the database. Note that event notifications were introduced in SQL Server 2005.
ExtendedProperties | Database-level extended properties.
FullTextCatalogs | The full-text catalogs in the database.
FullTextStoplists | The full-text stoplists in the database.
Functions | The user-defined functions in the database.
MessageTypes | The message types in the database. Note that message types were introduced in SQL Server 2005.
PartitionFunctions | The partition functions in the database. Note that partition functions were introduced in SQL Server 2005.
PartitionSchemes | The partition schemes in the database. Note that partitions schemes were introduced in SQL Server 2005.
Queues | The queues in the database. Note that queues were introduced in SQL Server 2005.
Roles | The roles in the database.
Routes | The routes in the database. Note that routes were introduced in SQL Server 2005.
Rules | The rules in the database.
Schemas | The schemas in the database. Note that schemas were introduced in SQL Server 2005.
SearchPropertyLists |
Sequences | The sequence objects in the database. Note that these were introduced in SQL Server 2012
ServiceBindings | The service bindings in the database. Note that service bindings were introduced in SQL Server 2005.
Services | The services in the database. Note that services were introduced in SQL Server 2005.
StoredProcedures | The stored procedures in the database.
SymmetricKeys | The symmetric keys in the database. Note that symmetric keys were introduced in SQL Server 2005.
Synonyms | The synonyms in the database. Note that synonyms were introduced in SQL Server 2005.
Tables | The tables in the database.
TotalObjectCount |
UserDefinedTypes | The user-defined types in the database.
Users | The users in the database.
Views | The views in the database.
XmlSchemaCollections | The XML schema collections in the database. Note that XML schema collections were introduced in SQL Server 2005.

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


IFullDatabaseObjects Methods

[image] [image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects Methods
IFullDatabaseObjects Interface See Also

The IFullDatabaseObjects type exposes the following methods.

Methods

Name | Description
GetDatabaseObject |

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


GetDatabaseObject Method

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.GetDatabaseObject Method
IFullDatabaseObjects Interface See Also

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetDatabaseObject ( _
    name As String, _
    type As ObjectType _
) As IDatabaseObject
C#
IDatabaseObject GetDatabaseObject(
    string name,
    ObjectType type
)
Visual C++
IDatabaseObject^ GetDatabaseObject(
    String^ name,
    ObjectType type
)

Parameters

name
Type: String
type
Type: ObjectType

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


IFullDatabaseObjects Properties

[image] [image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects Properties
IFullDatabaseObjects Interface See Also

The IFullDatabaseObjects type exposes the following properties.

Properties

Name | Description
Assemblies | The CLR assemblies in the database. Note that CLR assemblies were introduced in SQL Server 2005.
AsymmetricKeys | The asymmetric keys in the database. Note that asymmetric keys were introduced in SQL Server 2005.
Certificates | The certificates in the database. Note that certificates were introduced in SQL Server 2005.
Contracts | The contracts in the database. Note that contracts were introduced in SQL Server 2005.
DdlTriggers | The DDL triggers in the database.
Defaults | The defaults in the database.
EventNotifications | The database-level event notifications in the database. Note that event notifications were introduced in SQL Server 2005.
ExtendedProperties | Database-level extended properties.
FullTextCatalogs | The full-text catalogs in the database.
FullTextStoplists | The full-text stoplists in the database.
Functions | The user-defined functions in the database.
MessageTypes | The message types in the database. Note that message types were introduced in SQL Server 2005.
PartitionFunctions | The partition functions in the database. Note that partition functions were introduced in SQL Server 2005.
PartitionSchemes | The partition schemes in the database. Note that partitions schemes were introduced in SQL Server 2005.
Queues | The queues in the database. Note that queues were introduced in SQL Server 2005.
Roles | The roles in the database.
Routes | The routes in the database. Note that routes were introduced in SQL Server 2005.
Rules | The rules in the database.
Schemas | The schemas in the database. Note that schemas were introduced in SQL Server 2005.
SearchPropertyLists |
Sequences | The sequence objects in the database. Note that these were introduced in SQL Server 2012
ServiceBindings | The service bindings in the database. Note that service bindings were introduced in SQL Server 2005.
Services | The services in the database. Note that services were introduced in SQL Server 2005.
StoredProcedures | The stored procedures in the database.
SymmetricKeys | The symmetric keys in the database. Note that symmetric keys were introduced in SQL Server 2005.
Synonyms | The synonyms in the database. Note that synonyms were introduced in SQL Server 2005.
Tables | The tables in the database.
TotalObjectCount |
UserDefinedTypes | The user-defined types in the database.
Users | The users in the database.
Views | The views in the database.
XmlSchemaCollections | The XML schema collections in the database. Note that XML schema collections were introduced in SQL Server 2005.

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Assemblies Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.Assemblies Property
IFullDatabaseObjects Interface See Also

The CLR assemblies in the database. Note that CLR assemblies were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Assemblies As ClrAssemblies
C#
ClrAssemblies Assemblies { get; }
Visual C++
property ClrAssemblies^ Assemblies {
    ClrAssemblies^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


AsymmetricKeys Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.AsymmetricKeys Property
IFullDatabaseObjects Interface See Also

The asymmetric keys in the database. Note that asymmetric keys were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property AsymmetricKeys As AsymmetricKeys
C#
AsymmetricKeys AsymmetricKeys { get; }
Visual C++
property AsymmetricKeys^ AsymmetricKeys {
    AsymmetricKeys^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Certificates Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.Certificates Property
IFullDatabaseObjects Interface See Also

The certificates in the database. Note that certificates were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Certificates As Certificates
C#
Certificates Certificates { get; }
Visual C++
property Certificates^ Certificates {
    Certificates^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Contracts Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.Contracts Property
IFullDatabaseObjects Interface See Also

The contracts in the database. Note that contracts were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Contracts As Contracts
C#
Contracts Contracts { get; }
Visual C++
property Contracts^ Contracts {
    Contracts^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


DdlTriggers Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.DdlTriggers Property
IFullDatabaseObjects Interface See Also

The DDL triggers in the database.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DdlTriggers As DdlTriggers
C#
DdlTriggers DdlTriggers { get; }
Visual C++
property DdlTriggers^ DdlTriggers {
    DdlTriggers^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Defaults Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.Defaults Property
IFullDatabaseObjects Interface See Also

The defaults in the database.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Defaults As Defaults
C#
Defaults Defaults { get; }
Visual C++
property Defaults^ Defaults {
    Defaults^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


EventNotifications Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.EventNotifications Property
IFullDatabaseObjects Interface See Also

The database-level event notifications in the database. Note that event notifications were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property EventNotifications As EventNotifications
C#
EventNotifications EventNotifications { get; }
Visual C++
property EventNotifications^ EventNotifications {
    EventNotifications^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


ExtendedProperties Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.ExtendedProperties Property
IFullDatabaseObjects Interface See Also

Database-level extended properties.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ExtendedProperties As ExtendedProperties
C#
ExtendedProperties ExtendedProperties { get; }
Visual C++
property ExtendedProperties^ ExtendedProperties {
    ExtendedProperties^ get ();
}

Remarks

The collection contains extended properties that have been defined at the database level. Individual database objects (such as tables and users) can also have extended properties defined on them.

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


FullTextCatalogs Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.FullTextCatalogs Property
IFullDatabaseObjects Interface See Also

The full-text catalogs in the database.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property FullTextCatalogs As FullTextCatalogs
C#
FullTextCatalogs FullTextCatalogs { get; }
Visual C++
property FullTextCatalogs^ FullTextCatalogs {
    FullTextCatalogs^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


FullTextStoplists Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.FullTextStoplists Property
IFullDatabaseObjects Interface See Also

The full-text stoplists in the database.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property FullTextStoplists As FullTextStoplists
C#
FullTextStoplists FullTextStoplists { get; }
Visual C++
property FullTextStoplists^ FullTextStoplists {
    FullTextStoplists^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Functions Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.Functions Property
IFullDatabaseObjects Interface See Also

The user-defined functions in the database.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Functions As Functions
C#
Functions Functions { get; }
Visual C++
property Functions^ Functions {
    Functions^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


MessageTypes Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.MessageTypes Property
IFullDatabaseObjects Interface See Also

The message types in the database. Note that message types were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property MessageTypes As MessageTypes
C#
MessageTypes MessageTypes { get; }
Visual C++
property MessageTypes^ MessageTypes {
    MessageTypes^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


PartitionFunctions Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.PartitionFunctions Property
IFullDatabaseObjects Interface See Also

The partition functions in the database. Note that partition functions were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property PartitionFunctions As PartitionFunctions
C#
PartitionFunctions PartitionFunctions { get; }
Visual C++
property PartitionFunctions^ PartitionFunctions {
    PartitionFunctions^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


PartitionSchemes Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.PartitionSchemes Property
IFullDatabaseObjects Interface See Also

The partition schemes in the database. Note that partitions schemes were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property PartitionSchemes As PartitionSchemes
C#
PartitionSchemes PartitionSchemes { get; }
Visual C++
property PartitionSchemes^ PartitionSchemes {
    PartitionSchemes^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Queues Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.Queues Property
IFullDatabaseObjects Interface See Also

The queues in the database. Note that queues were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Queues As Queues
C#
Queues Queues { get; }
Visual C++
property Queues^ Queues {
    Queues^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Roles Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.Roles Property
IFullDatabaseObjects Interface See Also

The roles in the database.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Roles As Roles
C#
Roles Roles { get; }
Visual C++
property Roles^ Roles {
    Roles^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Routes Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.Routes Property
IFullDatabaseObjects Interface See Also

The routes in the database. Note that routes were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Routes As Routes
C#
Routes Routes { get; }
Visual C++
property Routes^ Routes {
    Routes^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Rules Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.Rules Property
IFullDatabaseObjects Interface See Also

The rules in the database.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Rules As Rules
C#
Rules Rules { get; }
Visual C++
property Rules^ Rules {
    Rules^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Schemas Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.Schemas Property
IFullDatabaseObjects Interface See Also

The schemas in the database. Note that schemas were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Schemas As Schemas
C#
Schemas Schemas { get; }
Visual C++
property Schemas^ Schemas {
    Schemas^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


SearchPropertyLists Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.SearchPropertyLists Property
IFullDatabaseObjects Interface See Also

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SearchPropertyLists As SearchPropertyLists
C#
SearchPropertyLists SearchPropertyLists { get; }
Visual C++
property SearchPropertyLists^ SearchPropertyLists {
    SearchPropertyLists^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Sequences Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.Sequences Property
IFullDatabaseObjects Interface See Also

The sequence objects in the database. Note that these were introduced in SQL Server 2012

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Sequences As Sequences
C#
Sequences Sequences { get; }
Visual C++
property Sequences^ Sequences {
    Sequences^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


ServiceBindings Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.ServiceBindings Property
IFullDatabaseObjects Interface See Also

The service bindings in the database. Note that service bindings were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ServiceBindings As ServiceBindings
C#
ServiceBindings ServiceBindings { get; }
Visual C++
property ServiceBindings^ ServiceBindings {
    ServiceBindings^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Services Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.Services Property
IFullDatabaseObjects Interface See Also

The services in the database. Note that services were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Services As Services
C#
Services Services { get; }
Visual C++
property Services^ Services {
    Services^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


StoredProcedures Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.StoredProcedures Property
IFullDatabaseObjects Interface See Also

The stored procedures in the database.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property StoredProcedures As StoredProcedures
C#
StoredProcedures StoredProcedures { get; }
Visual C++
property StoredProcedures^ StoredProcedures {
    StoredProcedures^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


SymmetricKeys Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.SymmetricKeys Property
IFullDatabaseObjects Interface See Also

The symmetric keys in the database. Note that symmetric keys were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SymmetricKeys As SymmetricKeys
C#
SymmetricKeys SymmetricKeys { get; }
Visual C++
property SymmetricKeys^ SymmetricKeys {
    SymmetricKeys^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Synonyms Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.Synonyms Property
IFullDatabaseObjects Interface See Also

The synonyms in the database. Note that synonyms were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Synonyms As Synonyms
C#
Synonyms Synonyms { get; }
Visual C++
property Synonyms^ Synonyms {
    Synonyms^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Tables Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.Tables Property
IFullDatabaseObjects Interface See Also

The tables in the database.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Tables As Tables
C#
Tables Tables { get; }
Visual C++
property Tables^ Tables {
    Tables^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


TotalObjectCount Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.TotalObjectCount Property
IFullDatabaseObjects Interface See Also

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TotalObjectCount As Integer
C#
int TotalObjectCount { get; }
Visual C++
property int TotalObjectCount {
    int get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


UserDefinedTypes Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.UserDefinedTypes Property
IFullDatabaseObjects Interface See Also

The user-defined types in the database.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property UserDefinedTypes As UserDefinedTypes
C#
UserDefinedTypes UserDefinedTypes { get; }
Visual C++
property UserDefinedTypes^ UserDefinedTypes {
    UserDefinedTypes^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Users Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.Users Property
IFullDatabaseObjects Interface See Also

The users in the database.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Users As Users
C#
Users Users { get; }
Visual C++
property Users^ Users {
    Users^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


Views Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.Views Property
IFullDatabaseObjects Interface See Also

The views in the database.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Views As Views
C#
Views Views { get; }
Visual C++
property Views^ Views {
    Views^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


XmlSchemaCollections Property

[image]

SQL Data Compare API 12.0.40
IFullDatabaseObjects..::.XmlSchemaCollections Property
IFullDatabaseObjects Interface See Also

The XML schema collections in the database. Note that XML schema collections were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property XmlSchemaCollections As XmlSchemaCollections
C#
XmlSchemaCollections XmlSchemaCollections { get; }
Visual C++
property XmlSchemaCollections^ XmlSchemaCollections {
    XmlSchemaCollections^ get ();
}

See Also

IFullDatabaseObjects Interface
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


ObjectNameUtils Class

[image]

SQL Data Compare API 12.0.40
ObjectNameUtils Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ObjectNameUtils
C#
public static class ObjectNameUtils
Visual C++
public ref class ObjectNameUtils abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.DatabaseCollaborators..::.ObjectNameUtils

See Also

ObjectNameUtils Members
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


ObjectNameUtils Members

[image] [image]

SQL Data Compare API 12.0.40
ObjectNameUtils Members
ObjectNameUtils Class Methods See Also

The ObjectNameUtils type exposes the following members.

Methods

Name | Description
ParseObjectName | Breaks up a name into its constituent parts, such as object name, owner name, database name, and server name.

See Also

ObjectNameUtils Class
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


ObjectNameUtils Methods

[image] [image]

SQL Data Compare API 12.0.40
ObjectNameUtils Methods
ObjectNameUtils Class See Also

The ObjectNameUtils type exposes the following methods.

Methods

Name | Description
ParseObjectName | Breaks up a name into its constituent parts, such as object name, owner name, database name, and server name.

See Also

ObjectNameUtils Class
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


ParseObjectName Method

[image]

SQL Data Compare API 12.0.40
ObjectNameUtils..::.ParseObjectName Method
ObjectNameUtils Class See Also

Breaks up a name into its constituent parts, such as object name, owner name, database name, and server name.

Namespace: RedGate.SQLCompare.Engine.DatabaseCollaborators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ParseObjectName ( _
    fullyQualifiedName As String, _
    <OutAttribute> ByRef serverName As String, _
    <OutAttribute> ByRef databaseName As String, _
    <OutAttribute> ByRef ownerName As String, _
    <OutAttribute> ByRef objectName As String _
)
C#
public static void ParseObjectName(
    string fullyQualifiedName,
    out string serverName,
    out string databaseName,
    out string ownerName,
    out string objectName
)
Visual C++
public:
static void ParseObjectName(
    String^ fullyQualifiedName,
    [OutAttribute] String^% serverName,
    [OutAttribute] String^% databaseName,
    [OutAttribute] String^% ownerName,
    [OutAttribute] String^% objectName
)

Parameters

fullyQualifiedName
Type: String
serverName
Type: String%
databaseName
Type: String%
ownerName
Type: String%
objectName
Type: String%

See Also

ObjectNameUtils Class
RedGate.SQLCompare.Engine.DatabaseCollaborators Namespace


RedGate.SQLCompare.Engine.DatabaseObjectCollections Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.DatabaseObjectCollections Namespace

Classes

Class | Description
IndexesExtensions |


IndexesExtensions Class

[image]

SQL Data Compare API 12.0.40
IndexesExtensions Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.DatabaseObjectCollections
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class IndexesExtensions
C#
public static class IndexesExtensions
Visual C++
public ref class IndexesExtensions abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.DatabaseObjectCollections..::.IndexesExtensions

See Also

IndexesExtensions Members
RedGate.SQLCompare.Engine.DatabaseObjectCollections Namespace


IndexesExtensions Members

[image] [image]

SQL Data Compare API 12.0.40
IndexesExtensions Members
IndexesExtensions Class Methods See Also

The IndexesExtensions type exposes the following members.

Methods

Name | Description
ColumnstoreIndexes | An IEnumerable of all the columnstore indexes in this collection.
Relational | An IEnumerable of all the relational indexes in this collection.
Spatial | An IEnumerable of all the spatial indexes in this collection.
Statistics | An IEnumerable of all the statistics in this collection.
Xml | An IEnumerable of all the xml indexes in this collection.

See Also

IndexesExtensions Class
RedGate.SQLCompare.Engine.DatabaseObjectCollections Namespace


IndexesExtensions Methods

[image] [image]

SQL Data Compare API 12.0.40
IndexesExtensions Methods
IndexesExtensions Class See Also

The IndexesExtensions type exposes the following methods.

Methods

Name | Description
ColumnstoreIndexes | An IEnumerable of all the columnstore indexes in this collection.
Relational | An IEnumerable of all the relational indexes in this collection.
Spatial | An IEnumerable of all the spatial indexes in this collection.
Statistics | An IEnumerable of all the statistics in this collection.
Xml | An IEnumerable of all the xml indexes in this collection.

See Also

IndexesExtensions Class
RedGate.SQLCompare.Engine.DatabaseObjectCollections Namespace


ColumnstoreIndexes Method

[image]

SQL Data Compare API 12.0.40
IndexesExtensions..::.ColumnstoreIndexes Method
IndexesExtensions Class See Also

An IEnumerable of all the columnstore indexes in this collection.

Namespace: RedGate.SQLCompare.Engine.DatabaseObjectCollections
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ColumnstoreIndexes ( _
    indexes As IEnumerable(Of Index) _
) As IEnumerable(Of RelationalIndex)
C#
public static IEnumerable<RelationalIndex> ColumnstoreIndexes(
    IEnumerable<Index> indexes
)
Visual C++
public:
static IEnumerable<RelationalIndex^>^ ColumnstoreIndexes(
    IEnumerable<Index^>^ indexes
)

Parameters

indexes
Type: IEnumerable<(Of <( Index >)>)

See Also

IndexesExtensions Class
RedGate.SQLCompare.Engine.DatabaseObjectCollections Namespace


Relational Method

[image]

SQL Data Compare API 12.0.40
IndexesExtensions..::.Relational Method
IndexesExtensions Class See Also

An IEnumerable of all the relational indexes in this collection.

Namespace: RedGate.SQLCompare.Engine.DatabaseObjectCollections
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Relational ( _
    indexes As IEnumerable(Of Index) _
) As IEnumerable(Of RelationalIndex)
C#
public static IEnumerable<RelationalIndex> Relational(
    IEnumerable<Index> indexes
)
Visual C++
public:
static IEnumerable<RelationalIndex^>^ Relational(
    IEnumerable<Index^>^ indexes
)

Parameters

indexes
Type: IEnumerable<(Of <( Index >)>)

See Also

IndexesExtensions Class
RedGate.SQLCompare.Engine.DatabaseObjectCollections Namespace


Spatial Method

[image]

SQL Data Compare API 12.0.40
IndexesExtensions..::.Spatial Method
IndexesExtensions Class See Also

An IEnumerable of all the spatial indexes in this collection.

Namespace: RedGate.SQLCompare.Engine.DatabaseObjectCollections
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Spatial ( _
    indexes As IEnumerable(Of Index) _
) As IEnumerable(Of SpatialIndex)
C#
public static IEnumerable<SpatialIndex> Spatial(
    IEnumerable<Index> indexes
)
Visual C++
public:
static IEnumerable<SpatialIndex^>^ Spatial(
    IEnumerable<Index^>^ indexes
)

Parameters

indexes
Type: IEnumerable<(Of <( Index >)>)

See Also

IndexesExtensions Class
RedGate.SQLCompare.Engine.DatabaseObjectCollections Namespace


Statistics Method

[image]

SQL Data Compare API 12.0.40
IndexesExtensions..::.Statistics Method
IndexesExtensions Class See Also

An IEnumerable of all the statistics in this collection.

Namespace: RedGate.SQLCompare.Engine.DatabaseObjectCollections
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Statistics ( _
    indexes As IEnumerable(Of Index) _
) As IEnumerable(Of Statistics)
C#
public static IEnumerable<Statistics> Statistics(
    IEnumerable<Index> indexes
)
Visual C++
public:
static IEnumerable<Statistics^>^ Statistics(
    IEnumerable<Index^>^ indexes
)

Parameters

indexes
Type: IEnumerable<(Of <( Index >)>)

See Also

IndexesExtensions Class
RedGate.SQLCompare.Engine.DatabaseObjectCollections Namespace


Xml Method

[image]

SQL Data Compare API 12.0.40
IndexesExtensions..::.Xml Method
IndexesExtensions Class See Also

An IEnumerable of all the xml indexes in this collection.

Namespace: RedGate.SQLCompare.Engine.DatabaseObjectCollections
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Xml ( _
    indexes As IEnumerable(Of Index) _
) As IEnumerable(Of XmlIndex)
C#
public static IEnumerable<XmlIndex> Xml(
    IEnumerable<Index> indexes
)
Visual C++
public:
static IEnumerable<XmlIndex^>^ Xml(
    IEnumerable<Index^>^ indexes
)

Parameters

indexes
Type: IEnumerable<(Of <( Index >)>)

See Also

IndexesExtensions Class
RedGate.SQLCompare.Engine.DatabaseObjectCollections Namespace


RedGate.SQLCompare.Engine.DatabaseObjects Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.DatabaseObjects Namespace

Interfaces

Interface | Description
IHasScriptSource |


IHasScriptSource Interface

[image]

SQL Data Compare API 12.0.40
IHasScriptSource Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.DatabaseObjects
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IHasScriptSource
C#
public interface IHasScriptSource
Visual C++
public interface class IHasScriptSource

See Also

IHasScriptSource Members
RedGate.SQLCompare.Engine.DatabaseObjects Namespace


IHasScriptSource Members

[image] [image]

SQL Data Compare API 12.0.40
IHasScriptSource Members
IHasScriptSource Interface Properties See Also

The IHasScriptSource type exposes the following members.

Properties

Name | Description
ScriptSource |

See Also

IHasScriptSource Interface
RedGate.SQLCompare.Engine.DatabaseObjects Namespace


IHasScriptSource Properties

[image] [image]

SQL Data Compare API 12.0.40
IHasScriptSource Properties
IHasScriptSource Interface See Also

The IHasScriptSource type exposes the following properties.

Properties

Name | Description
ScriptSource |

See Also

IHasScriptSource Interface
RedGate.SQLCompare.Engine.DatabaseObjects Namespace


ScriptSource Property

[image]

SQL Data Compare API 12.0.40
IHasScriptSource..::.ScriptSource Property
IHasScriptSource Interface See Also

Namespace: RedGate.SQLCompare.Engine.DatabaseObjects
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ScriptSource As ScriptSource
C#
ScriptSource ScriptSource { get; }
Visual C++
property ScriptSource^ ScriptSource {
    ScriptSource^ get ();
}

See Also

IHasScriptSource Interface
RedGate.SQLCompare.Engine.DatabaseObjects Namespace


RedGate.SQLCompare.Engine.Deployment Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.Deployment Namespace

Interfaces

Interface | Description
IServerBackupCapabilities |
IServerDetails |
IServerFactory |


IServerBackupCapabilities Interface

[image]

SQL Data Compare API 12.0.40
IServerBackupCapabilities Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.Deployment
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IServerBackupCapabilities
C#
public interface IServerBackupCapabilities
Visual C++
public interface class IServerBackupCapabilities

See Also

IServerBackupCapabilities Members
RedGate.SQLCompare.Engine.Deployment Namespace


IServerBackupCapabilities Members

[image] [image]

SQL Data Compare API 12.0.40
IServerBackupCapabilities Members
IServerBackupCapabilities Interface Methods Properties See Also

The IServerBackupCapabilities type exposes the following members.

Methods

Name | Description
DefaultBackupFolder |

Properties

Name | Description
IsSqlBackupInstalled |
SqlBackupLicenseType |
SqlBackupVersion |

See Also

IServerBackupCapabilities Interface
RedGate.SQLCompare.Engine.Deployment Namespace


IServerBackupCapabilities Methods

[image] [image]

SQL Data Compare API 12.0.40
IServerBackupCapabilities Methods
IServerBackupCapabilities Interface See Also

The IServerBackupCapabilities type exposes the following methods.

Methods

Name | Description
DefaultBackupFolder |

See Also

IServerBackupCapabilities Interface
RedGate.SQLCompare.Engine.Deployment Namespace


DefaultBackupFolder Method

[image]

SQL Data Compare API 12.0.40
IServerBackupCapabilities..::.DefaultBackupFolder Method
IServerBackupCapabilities Interface See Also

Namespace: RedGate.SQLCompare.Engine.Deployment
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function DefaultBackupFolder ( _
    provider As BackupProvider _
) As String
C#
string DefaultBackupFolder(
    BackupProvider provider
)
Visual C++
String^ DefaultBackupFolder(
    BackupProvider provider
)

Parameters

provider
Type: RedGate.SQLCompare.Engine..::.BackupProvider

See Also

IServerBackupCapabilities Interface
RedGate.SQLCompare.Engine.Deployment Namespace


IServerBackupCapabilities Properties

[image] [image]

SQL Data Compare API 12.0.40
IServerBackupCapabilities Properties
IServerBackupCapabilities Interface See Also

The IServerBackupCapabilities type exposes the following properties.

Properties

Name | Description
IsSqlBackupInstalled |
SqlBackupLicenseType |
SqlBackupVersion |

See Also

IServerBackupCapabilities Interface
RedGate.SQLCompare.Engine.Deployment Namespace


IsSqlBackupInstalled Property

[image]

SQL Data Compare API 12.0.40
IServerBackupCapabilities..::.IsSqlBackupInstalled Property
IServerBackupCapabilities Interface See Also

Namespace: RedGate.SQLCompare.Engine.Deployment
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsSqlBackupInstalled As Boolean
C#
bool IsSqlBackupInstalled { get; }
Visual C++
property bool IsSqlBackupInstalled {
    bool get ();
}

See Also

IServerBackupCapabilities Interface
RedGate.SQLCompare.Engine.Deployment Namespace


SqlBackupLicenseType Property

[image]

SQL Data Compare API 12.0.40
IServerBackupCapabilities..::.SqlBackupLicenseType Property
IServerBackupCapabilities Interface See Also

Namespace: RedGate.SQLCompare.Engine.Deployment
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SqlBackupLicenseType As SqlBackupLicenseType
C#
SqlBackupLicenseType SqlBackupLicenseType { get; }
Visual C++
property SqlBackupLicenseType SqlBackupLicenseType {
    SqlBackupLicenseType get ();
}

See Also

IServerBackupCapabilities Interface
RedGate.SQLCompare.Engine.Deployment Namespace


SqlBackupVersion Property

[image]

SQL Data Compare API 12.0.40
IServerBackupCapabilities..::.SqlBackupVersion Property
IServerBackupCapabilities Interface See Also

Namespace: RedGate.SQLCompare.Engine.Deployment
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SqlBackupVersion As Integer
C#
int SqlBackupVersion { get; }
Visual C++
property int SqlBackupVersion {
    int get ();
}

See Also

IServerBackupCapabilities Interface
RedGate.SQLCompare.Engine.Deployment Namespace


IServerDetails Interface

[image]

SQL Data Compare API 12.0.40
IServerDetails Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.Deployment
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IServerDetails _
    Implements IDisposable
C#
public interface IServerDetails : IDisposable
Visual C++
public interface class IServerDetails : IDisposable

See Also

IServerDetails Members
RedGate.SQLCompare.Engine.Deployment Namespace


IServerDetails Members

[image] [image]

SQL Data Compare API 12.0.40
IServerDetails Members
IServerDetails Interface Methods See Also

The IServerDetails type exposes the following members.

Methods

Name | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)

See Also

IServerDetails Interface
RedGate.SQLCompare.Engine.Deployment Namespace


IServerFactory Interface

[image]

SQL Data Compare API 12.0.40
IServerFactory Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.Deployment
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IServerFactory
C#
public interface IServerFactory
Visual C++
public interface class IServerFactory

See Also

IServerFactory Members
RedGate.SQLCompare.Engine.Deployment Namespace


IServerFactory Members

[image] [image]

SQL Data Compare API 12.0.40
IServerFactory Members
IServerFactory Interface Methods See Also

The IServerFactory type exposes the following members.

Methods

Name | Description
CreateServerBackupCapabilities |

See Also

IServerFactory Interface
RedGate.SQLCompare.Engine.Deployment Namespace


IServerFactory Methods

[image] [image]

SQL Data Compare API 12.0.40
IServerFactory Methods
IServerFactory Interface See Also

The IServerFactory type exposes the following methods.

Methods

Name | Description
CreateServerBackupCapabilities |

See Also

IServerFactory Interface
RedGate.SQLCompare.Engine.Deployment Namespace


CreateServerBackupCapabilities Method

[image]

SQL Data Compare API 12.0.40
IServerFactory..::.CreateServerBackupCapabilities Method
IServerFactory Interface See Also

Namespace: RedGate.SQLCompare.Engine.Deployment
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function CreateServerBackupCapabilities ( _
    dataSource As IDataSource _
) As IServerBackupCapabilities
C#
IServerBackupCapabilities CreateServerBackupCapabilities(
    IDataSource dataSource
)
Visual C++
IServerBackupCapabilities^ CreateServerBackupCapabilities(
    IDataSource^ dataSource
)

Parameters

dataSource
Type: RedGate.Shared.SQL..::.IDataSource

See Also

IServerFactory Interface
RedGate.SQLCompare.Engine.Deployment Namespace


RedGate.SQLCompare.Engine.Deployment.ChangeCalculation Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.Deployment.ChangeCalculation Namespace

Classes

Class | Description
FilestreamIndexCalculator | This class memoises the best filestream index for a pair of tables, given certain options. This was created as a potential performance optimisation for tables containing large numbers of indexes, although it is likely that it is not required for most databases.


FilestreamIndexCalculator Class

[image]

SQL Data Compare API 12.0.40
FilestreamIndexCalculator Class
Members See Also

This class memoises the best filestream index for a pair of tables, given certain options. This was created as a potential performance optimisation for tables containing large numbers of indexes, although it is likely that it is not required for most databases.

Namespace: RedGate.SQLCompare.Engine.Deployment.ChangeCalculation
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class FilestreamIndexCalculator
C#
public class FilestreamIndexCalculator
Visual C++
public ref class FilestreamIndexCalculator

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Deployment.ChangeCalculation..::.FilestreamIndexCalculator

See Also

FilestreamIndexCalculator Members
RedGate.SQLCompare.Engine.Deployment.ChangeCalculation Namespace


FilestreamIndexCalculator Members

[image] [image]

SQL Data Compare API 12.0.40
FilestreamIndexCalculator Members
FilestreamIndexCalculator Class Constructors Methods See Also

The FilestreamIndexCalculator type exposes the following members.

Constructors

Name | Description
FilestreamIndexCalculator |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilestreamIndexCalculator Class
RedGate.SQLCompare.Engine.Deployment.ChangeCalculation Namespace


FilestreamIndexCalculator Constructor

[image]

SQL Data Compare API 12.0.40
FilestreamIndexCalculator Constructor
FilestreamIndexCalculator Class See Also

Namespace: RedGate.SQLCompare.Engine.Deployment.ChangeCalculation
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FilestreamIndexCalculator()
Visual C++
public:
FilestreamIndexCalculator()

See Also

FilestreamIndexCalculator Class
RedGate.SQLCompare.Engine.Deployment.ChangeCalculation Namespace


RedGate.SQLCompare.Engine.Deployment.SqlGenerators Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.Deployment.SqlGenerators Namespace

Classes

Class | Description
BackupCommandGenerator |
TemporaryObjectNameCreator |

Interfaces

Interface | Description
IDateTimeProvider |


BackupCommandGenerator Class

[image]

SQL Data Compare API 12.0.40
BackupCommandGenerator Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Deployment.SqlGenerators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class BackupCommandGenerator
C#
public class BackupCommandGenerator
Visual C++
public ref class BackupCommandGenerator

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Deployment.SqlGenerators..::.BackupCommandGenerator

See Also

BackupCommandGenerator Members
RedGate.SQLCompare.Engine.Deployment.SqlGenerators Namespace


BackupCommandGenerator Members

[image] [image]

SQL Data Compare API 12.0.40
BackupCommandGenerator Members
BackupCommandGenerator Class Constructors Methods See Also

The BackupCommandGenerator type exposes the following members.

Constructors

Name | Description
BackupCommandGenerator |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBackupSQL |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetPostSQL |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BackupCommandGenerator Class
RedGate.SQLCompare.Engine.Deployment.SqlGenerators Namespace


BackupCommandGenerator Constructor

[image]

SQL Data Compare API 12.0.40
BackupCommandGenerator Constructor
BackupCommandGenerator Class See Also

Namespace: RedGate.SQLCompare.Engine.Deployment.SqlGenerators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    backupOptions As BackupOptions, _
    canceler As Canceler, _
    progressTracker As ProgressTracker, _
    dateTimeProvider As IDateTimeProvider _
)
C#
public BackupCommandGenerator(
    BackupOptions backupOptions,
    Canceler canceler,
    ProgressTracker progressTracker,
    IDateTimeProvider dateTimeProvider
)
Visual C++
public:
BackupCommandGenerator(
    BackupOptions^ backupOptions,
    Canceler^ canceler,
    ProgressTracker^ progressTracker,
    IDateTimeProvider^ dateTimeProvider
)

Parameters

backupOptions
Type: RedGate.SQLCompare.Engine..::.BackupOptions
canceler
Type: RedGate.SQLCompare.Engine..::.Canceler
progressTracker
Type: RedGate.SQLCompare.Engine..::.ProgressTracker
dateTimeProvider
Type: RedGate.SQLCompare.Engine.Deployment.SqlGenerators..::.IDateTimeProvider

See Also

BackupCommandGenerator Class
RedGate.SQLCompare.Engine.Deployment.SqlGenerators Namespace


BackupCommandGenerator Methods

[image] [image]

SQL Data Compare API 12.0.40
BackupCommandGenerator Methods
BackupCommandGenerator Class See Also

The BackupCommandGenerator type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBackupSQL |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetPostSQL |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BackupCommandGenerator Class
RedGate.SQLCompare.Engine.Deployment.SqlGenerators Namespace


GetBackupSQL Method

[image]

SQL Data Compare API 12.0.40
BackupCommandGenerator..::.GetBackupSQL Method
BackupCommandGenerator Class See Also

Namespace: RedGate.SQLCompare.Engine.Deployment.SqlGenerators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetBackupSQL As String
C#
public string GetBackupSQL()
Visual C++
public:
String^ GetBackupSQL()

See Also

BackupCommandGenerator Class
RedGate.SQLCompare.Engine.Deployment.SqlGenerators Namespace


GetPostSQL Method

[image]

SQL Data Compare API 12.0.40
BackupCommandGenerator..::.GetPostSQL Method
BackupCommandGenerator Class See Also

Namespace: RedGate.SQLCompare.Engine.Deployment.SqlGenerators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPostSQL As String
C#
public string GetPostSQL()
Visual C++
public:
String^ GetPostSQL()

See Also

BackupCommandGenerator Class
RedGate.SQLCompare.Engine.Deployment.SqlGenerators Namespace


IDateTimeProvider Interface

[image]

SQL Data Compare API 12.0.40
IDateTimeProvider Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.Deployment.SqlGenerators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDateTimeProvider
C#
public interface IDateTimeProvider
Visual C++
public interface class IDateTimeProvider

See Also

IDateTimeProvider Members
RedGate.SQLCompare.Engine.Deployment.SqlGenerators Namespace


IDateTimeProvider Members

[image] [image]

SQL Data Compare API 12.0.40
IDateTimeProvider Members
IDateTimeProvider Interface Properties See Also

The IDateTimeProvider type exposes the following members.

Properties

Name | Description
DateTime |

See Also

IDateTimeProvider Interface
RedGate.SQLCompare.Engine.Deployment.SqlGenerators Namespace


IDateTimeProvider Properties

[image] [image]

SQL Data Compare API 12.0.40
IDateTimeProvider Properties
IDateTimeProvider Interface See Also

The IDateTimeProvider type exposes the following properties.

Properties

Name | Description
DateTime |

See Also

IDateTimeProvider Interface
RedGate.SQLCompare.Engine.Deployment.SqlGenerators Namespace


DateTime Property

[image]

SQL Data Compare API 12.0.40
IDateTimeProvider..::.DateTime Property
IDateTimeProvider Interface See Also

Namespace: RedGate.SQLCompare.Engine.Deployment.SqlGenerators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DateTime As DateTime
C#
DateTime DateTime { get; }
Visual C++
property DateTime DateTime {
    DateTime get ();
}

See Also

IDateTimeProvider Interface
RedGate.SQLCompare.Engine.Deployment.SqlGenerators Namespace


TemporaryObjectNameCreator Class

[image]

SQL Data Compare API 12.0.40
TemporaryObjectNameCreator Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Deployment.SqlGenerators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class TemporaryObjectNameCreator
C#
public class TemporaryObjectNameCreator
Visual C++
public ref class TemporaryObjectNameCreator

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Deployment.SqlGenerators..::.TemporaryObjectNameCreator

See Also

TemporaryObjectNameCreator Members
RedGate.SQLCompare.Engine.Deployment.SqlGenerators Namespace


TemporaryObjectNameCreator Members

[image] [image]

SQL Data Compare API 12.0.40
TemporaryObjectNameCreator Members
TemporaryObjectNameCreator Class Constructors Methods See Also

The TemporaryObjectNameCreator type exposes the following members.

Constructors

Name | Description
TemporaryObjectNameCreator |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemporaryNameWithHash |
GetTemporaryTableName |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemporaryObjectNameCreator Class
RedGate.SQLCompare.Engine.Deployment.SqlGenerators Namespace


TemporaryObjectNameCreator Constructor

[image]

SQL Data Compare API 12.0.40
TemporaryObjectNameCreator Constructor
TemporaryObjectNameCreator Class See Also

Namespace: RedGate.SQLCompare.Engine.Deployment.SqlGenerators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    tables As IEnumerable(Of Table), _
    warnings As Messages _
)
C#
public TemporaryObjectNameCreator(
    IEnumerable<Table> tables,
    Messages warnings
)
Visual C++
public:
TemporaryObjectNameCreator(
    IEnumerable<Table^>^ tables,
    Messages^ warnings
)

Parameters

tables
Type: IEnumerable<(Of <( Table >)>)
warnings
Type: RedGate.SQLCompare.Engine..::.Messages

See Also

TemporaryObjectNameCreator Class
RedGate.SQLCompare.Engine.Deployment.SqlGenerators Namespace


TemporaryObjectNameCreator Methods

[image] [image]

SQL Data Compare API 12.0.40
TemporaryObjectNameCreator Methods
TemporaryObjectNameCreator Class See Also

The TemporaryObjectNameCreator type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemporaryNameWithHash |
GetTemporaryTableName |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemporaryObjectNameCreator Class
RedGate.SQLCompare.Engine.Deployment.SqlGenerators Namespace


GetTemporaryNameWithHash Method

[image]

SQL Data Compare API 12.0.40
TemporaryObjectNameCreator..::.GetTemporaryNameWithHash Method
TemporaryObjectNameCreator Class See Also

Namespace: RedGate.SQLCompare.Engine.Deployment.SqlGenerators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetTemporaryNameWithHash ( _
    prefix As String, _
    name As String _
) As String
C#
public static string GetTemporaryNameWithHash(
    string prefix,
    string name
)
Visual C++
public:
static String^ GetTemporaryNameWithHash(
    String^ prefix,
    String^ name
)

Parameters

prefix
Type: String
name
Type: String

See Also

TemporaryObjectNameCreator Class
RedGate.SQLCompare.Engine.Deployment.SqlGenerators Namespace


GetTemporaryTableName Method

[image]

SQL Data Compare API 12.0.40
TemporaryObjectNameCreator..::.GetTemporaryTableName Method
TemporaryObjectNameCreator Class See Also

Namespace: RedGate.SQLCompare.Engine.Deployment.SqlGenerators
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetTemporaryTableName ( _
    name As String _
) As String
C#
public string GetTemporaryTableName(
    string name
)
Visual C++
public:
String^ GetTemporaryTableName(
    String^ name
)

Parameters

name
Type: String

See Also

TemporaryObjectNameCreator Class
RedGate.SQLCompare.Engine.Deployment.SqlGenerators Namespace


RedGate.SQLCompare.Engine.Deployment.SyncToScript Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.Deployment.SyncToScript Namespace

Classes

Class | Description
SqlCompareDatabaseScripter | Deploys a database to a folder taking into account current contents.


SqlCompareDatabaseScripter Class

[image]

SQL Data Compare API 12.0.40
SqlCompareDatabaseScripter Class
Members See Also

Deploys a database to a folder taking into account current contents.

Namespace: RedGate.SQLCompare.Engine.Deployment.SyncToScript
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlCompareDatabaseScripter _
    Implements IDatabaseScripter(Of Database)
C#
public class SqlCompareDatabaseScripter : IDatabaseScripter<Database>
Visual C++
public ref class SqlCompareDatabaseScripter : IDatabaseScripter<Database^>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Deployment.SyncToScript..::.SqlCompareDatabaseScripter

See Also

SqlCompareDatabaseScripter Members
RedGate.SQLCompare.Engine.Deployment.SyncToScript Namespace


SqlCompareDatabaseScripter Members

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareDatabaseScripter Members
SqlCompareDatabaseScripter Class Constructors Methods See Also

The SqlCompareDatabaseScripter type exposes the following members.

Constructors

Name | Description
SqlCompareDatabaseScripter |

Methods

Name | Description
DeployToFolder |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlCompareDatabaseScripter Class
RedGate.SQLCompare.Engine.Deployment.SyncToScript Namespace


SqlCompareDatabaseScripter Constructor

[image]

SQL Data Compare API 12.0.40
SqlCompareDatabaseScripter Constructor
SqlCompareDatabaseScripter Class See Also

Namespace: RedGate.SQLCompare.Engine.Deployment.SyncToScript
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    options As Options, _
    generator As IFileNameGenerator, _
    dbInfo As ScriptDatabaseInformation _
)
C#
public SqlCompareDatabaseScripter(
    Options options,
    IFileNameGenerator generator,
    ScriptDatabaseInformation dbInfo
)
Visual C++
public:
SqlCompareDatabaseScripter(
    Options options,
    IFileNameGenerator^ generator,
    ScriptDatabaseInformation^ dbInfo
)

Parameters

options
Type: RedGate.SQLCompare.Engine..::.Options
Used for registering the target scripts folder, comparing and deploying
generator
Type: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser..::.IFileNameGenerator
Used to chooses file names for created objects
dbInfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
Used for registering the target scripts folder and building differences

See Also

SqlCompareDatabaseScripter Class
RedGate.SQLCompare.Engine.Deployment.SyncToScript Namespace


SqlCompareDatabaseScripter Methods

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareDatabaseScripter Methods
SqlCompareDatabaseScripter Class See Also

The SqlCompareDatabaseScripter type exposes the following methods.

Methods

Name | Description
DeployToFolder |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlCompareDatabaseScripter Class
RedGate.SQLCompare.Engine.Deployment.SyncToScript Namespace


DeployToFolder Method

[image]

SQL Data Compare API 12.0.40
SqlCompareDatabaseScripter..::.DeployToFolder Method
SqlCompareDatabaseScripter Class See Also

Namespace: RedGate.SQLCompare.Engine.Deployment.SyncToScript
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeployToFolder ( _
    sourceDatabase As Database, _
    targetScriptsFolder As DirectoryInfo _
)
C#
public void DeployToFolder(
    Database sourceDatabase,
    DirectoryInfo targetScriptsFolder
)
Visual C++
public:
virtual void DeployToFolder(
    Database^ sourceDatabase,
    DirectoryInfo^ targetScriptsFolder
) sealed

Parameters

sourceDatabase
Type: RedGate.SQLCompare.Engine..::.Database
targetScriptsFolder
Type: DirectoryInfo

Implements

IDatabaseScripterDeployToFolder(UTP, DirectoryInfo)

See Also

SqlCompareDatabaseScripter Class
RedGate.SQLCompare.Engine.Deployment.SyncToScript Namespace


RedGate.SQLCompare.Engine.ExtensionMethods Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.ExtensionMethods Namespace

Classes

Class | Description
DifferenceExtensions |


DifferenceExtensions Class

[image]

SQL Data Compare API 12.0.40
DifferenceExtensions Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ExtensionMethods
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DifferenceExtensions
C#
public static class DifferenceExtensions
Visual C++
public ref class DifferenceExtensions abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ExtensionMethods..::.DifferenceExtensions

See Also

DifferenceExtensions Members
RedGate.SQLCompare.Engine.ExtensionMethods Namespace


DifferenceExtensions Members

[image] [image]

SQL Data Compare API 12.0.40
DifferenceExtensions Members
DifferenceExtensions Class Methods See Also

The DifferenceExtensions type exposes the following members.

Methods

Name | Description
IsDataSync | Overloaded.
IsTSQLT | Overloaded.
SelectAll
Set the selectedness state of all differences to
Copy Code
true

See Also

DifferenceExtensions Class
RedGate.SQLCompare.Engine.ExtensionMethods Namespace


DifferenceExtensions Methods

[image] [image]

SQL Data Compare API 12.0.40
DifferenceExtensions Methods
DifferenceExtensions Class See Also

The DifferenceExtensions type exposes the following methods.

Methods

Name | Description
IsDataSync | Overloaded.
IsTSQLT | Overloaded.
SelectAll
Set the selectedness state of all differences to
Copy Code
true

See Also

DifferenceExtensions Class
RedGate.SQLCompare.Engine.ExtensionMethods Namespace


IsDataSync Method

[image] [image]

SQL Data Compare API 12.0.40
DifferenceExtensions..::.IsDataSync Method
DifferenceExtensions Class See Also

Overload List

Name | Description
IsDataSync(Difference) | Returns true iff differencerefers to an object that is in the DataSync schema.
IsDataSync(IDatabaseObject) | Returns true iff databaseObject is in the DataSync schema.

See Also

DifferenceExtensions Class
DifferenceExtensions Members
RedGate.SQLCompare.Engine.ExtensionMethods Namespace


IsDataSync Method (Difference)

[image]

SQL Data Compare API 12.0.40
DifferenceExtensions..::.IsDataSync Method (Difference)
DifferenceExtensions Class See Also

Returns true iff differencerefers to an object that is in the DataSync schema.

Namespace: RedGate.SQLCompare.Engine.ExtensionMethods
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsDataSync ( _
    difference As Difference _
) As Boolean
C#
public static bool IsDataSync(
    Difference difference
)
Visual C++
public:
static bool IsDataSync(
    Difference^ difference
)

Parameters

difference
Type: RedGate.SQLCompare.Engine..::.Difference

Return Value

See Also

DifferenceExtensions Class
IsDataSync Overload
RedGate.SQLCompare.Engine.ExtensionMethods Namespace


IsDataSync Method (IDatabaseObject)

[image]

SQL Data Compare API 12.0.40
DifferenceExtensions..::.IsDataSync Method (IDatabaseObject)
DifferenceExtensions Class See Also

Returns true iff databaseObject is in the DataSync schema.

Namespace: RedGate.SQLCompare.Engine.ExtensionMethods
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsDataSync ( _
    databaseObject As IDatabaseObject _
) As Boolean
C#
public static bool IsDataSync(
    IDatabaseObject databaseObject
)
Visual C++
public:
static bool IsDataSync(
    IDatabaseObject^ databaseObject
)

Parameters

databaseObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject

Return Value

See Also

DifferenceExtensions Class
IsDataSync Overload
RedGate.SQLCompare.Engine.ExtensionMethods Namespace


IsTSQLT Method

[image] [image]

SQL Data Compare API 12.0.40
DifferenceExtensions..::.IsTSQLT Method
DifferenceExtensions Class See Also

Overload List

Name | Description
IsTSQLT(Difference) |
IsTSQLT(IDatabaseObject) |

See Also

DifferenceExtensions Class
DifferenceExtensions Members
RedGate.SQLCompare.Engine.ExtensionMethods Namespace


IsTSQLT Method (Difference)

[image]

SQL Data Compare API 12.0.40
DifferenceExtensions..::.IsTSQLT Method (Difference)
DifferenceExtensions Class See Also

Namespace: RedGate.SQLCompare.Engine.ExtensionMethods
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsTSQLT ( _
    difference As Difference _
) As Boolean
C#
public static bool IsTSQLT(
    Difference difference
)
Visual C++
public:
static bool IsTSQLT(
    Difference^ difference
)

Parameters

difference
Type: RedGate.SQLCompare.Engine..::.Difference

See Also

DifferenceExtensions Class
IsTSQLT Overload
RedGate.SQLCompare.Engine.ExtensionMethods Namespace


IsTSQLT Method (IDatabaseObject)

[image]

SQL Data Compare API 12.0.40
DifferenceExtensions..::.IsTSQLT Method (IDatabaseObject)
DifferenceExtensions Class See Also

Namespace: RedGate.SQLCompare.Engine.ExtensionMethods
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsTSQLT ( _
    databaseObject As IDatabaseObject _
) As Boolean
C#
public static bool IsTSQLT(
    IDatabaseObject databaseObject
)
Visual C++
public:
static bool IsTSQLT(
    IDatabaseObject^ databaseObject
)

Parameters

databaseObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject

See Also

DifferenceExtensions Class
IsTSQLT Overload
RedGate.SQLCompare.Engine.ExtensionMethods Namespace


SelectAll Method

[image]

SQL Data Compare API 12.0.40
DifferenceExtensions..::.SelectAll Method
DifferenceExtensions Class See Also

Set the selectedness state of all differences to
Copy Code
true

Namespace: RedGate.SQLCompare.Engine.ExtensionMethods
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub SelectAll ( _
    differences As Differences _
)
C#
public static void SelectAll(
    Differences differences
)
Visual C++
public:
static void SelectAll(
    Differences^ differences
)

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences

See Also

DifferenceExtensions Class
RedGate.SQLCompare.Engine.ExtensionMethods Namespace


RedGate.SQLCompare.Engine.Facts Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.Facts Namespace

Classes

Class | Description
DatabaseFurFacts | Methods for getting interesting FUR data out of the engine without having to depend on the model directly


DatabaseFurFacts Class

[image]

SQL Data Compare API 12.0.40
DatabaseFurFacts Class
Members See Also

Methods for getting interesting FUR data out of the engine without having to depend on the model directly

Namespace: RedGate.SQLCompare.Engine.Facts
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DatabaseFurFacts
C#
public static class DatabaseFurFacts
Visual C++
public ref class DatabaseFurFacts abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Facts..::.DatabaseFurFacts

See Also

DatabaseFurFacts Members
RedGate.SQLCompare.Engine.Facts Namespace


DatabaseFurFacts Members

[image] [image]

SQL Data Compare API 12.0.40
DatabaseFurFacts Members
DatabaseFurFacts Class Methods See Also

The DatabaseFurFacts type exposes the following members.

Methods

Name | Description
GetPropertiesForDatabase | Get a set of interesting facts about a database to be used in a PFUR event

See Also

DatabaseFurFacts Class
RedGate.SQLCompare.Engine.Facts Namespace


DatabaseFurFacts Methods

[image] [image]

SQL Data Compare API 12.0.40
DatabaseFurFacts Methods
DatabaseFurFacts Class See Also

The DatabaseFurFacts type exposes the following methods.

Methods

Name | Description
GetPropertiesForDatabase | Get a set of interesting facts about a database to be used in a PFUR event

See Also

DatabaseFurFacts Class
RedGate.SQLCompare.Engine.Facts Namespace


GetPropertiesForDatabase Method

[image]

SQL Data Compare API 12.0.40
DatabaseFurFacts..::.GetPropertiesForDatabase Method
DatabaseFurFacts Class See Also

Get a set of interesting facts about a database to be used in a PFUR event

Namespace: RedGate.SQLCompare.Engine.Facts
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetPropertiesForDatabase ( _
    database As Database _
) As Object
C#
public static Object GetPropertiesForDatabase(
    Database database
)
Visual C++
public:
static Object^ GetPropertiesForDatabase(
    Database^ database
)

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database

See Also

DatabaseFurFacts Class
RedGate.SQLCompare.Engine.Facts Namespace


RedGate.SQLCompare.Engine.Filter Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.Filter Namespace

Classes

Class | Description
AND<(Of <(T>)>) | A set of filter conditions ANDed together.
Condition | A filter condition on a difference's name or schema.
DifferenceFilter | Filters a collection of Differences based on various object properties.
DifferenceFilterFactory | Class for creating a DifferenceFilter from a global filter expression.
FilterableObjectId |
FilterConditionCollection<(Of <(T>)>) | A set of filter conditions.
FilterException |
NamedFilter |
NOT<(Of <(T>)>) | A NOT filter condition.
OR<(Of <(T>)>) | A set of filter conditions ORed together.
True<(Of <(T>)>) | A condition that always evaluates to true.

Structures

Structure | Description
DifferenceFilter..::.ObjectTypeFilter | A filter for a single object type. Can be set as include or exclude.

Interfaces

Interface | Description
IFilterCondition<(Of <(T>)>) | A filter condition with value equality.

Enumerations

Enumeration | Description
DifferenceFilter..::.ObjectTypeFilterStatus | The filtering status for a specific object type (see GetFilterStatus(ObjectType)).
FilterOn | The difference property being filtered on.
FilterType | The filter condition to apply to filter objects.


AND(T) Generic Class

[image]

SQL Data Compare API 12.0.40
AND<(Of <(T>)>) Generic Class
Members See Also

A set of filter conditions ANDed together.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class AND(Of T) _
    Inherits FilterConditionCollection(Of T)
C#
public class AND<T> : FilterConditionCollection<T>
Visual C++
generic<typename T>
public ref class AND : public FilterConditionCollection<T>

Type Parameters

T
The type of object being filtered.

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <(T>)>)
RedGate.Shared.Utils.Collections..::.DictionaryBasedSet <(Of <(T>)>)
RedGate.Shared.Utils.Collections..::.Set <(Of <( IFilterCondition <(Of <(T>)>)>)>)
RedGate.SQLCompare.Engine.Filter..::.FilterConditionCollection <(Of <(T>)>)
RedGate.SQLCompare.Engine.Filter..::.AND<(Of <(T>)>)

See Also

AND<(Of <(T>)>) Members
RedGate.SQLCompare.Engine.Filter Namespace


AND(T) Members

[image] [image]

SQL Data Compare API 12.0.40
AND<(Of <(T>)>) Members
AND<(Of <(T>)>) Class Constructors Methods Properties Explicit Interface Implementations See Also

The AND<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
AND<(Of <(T>)>) | Overloaded.

Methods

Name | Description
Add | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
AddIfNotExists | Adds item to the DictionaryBasedSet<(Of <(T>)>) if it does not already exist. (Inherited from DictionaryBasedSet<(Of <(T>)>).)
AddRange | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
AddRangeIfNotExists | Adds items to the DictionaryBasedSet<(Of <(T>)>) only if none of the items are already in the set. (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Clear | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Clone | (Overrides FilterConditionCollection <(Of <( T >)>)..::. Clone(Boolean).)
Contains | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Difference | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Equals | Overloaded.
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
GetHashCode | (Inherited from FilterConditionCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersection | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
IsDisjointWith | (Inherited from Set<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ObjectIncluded | (Overrides FilterConditionCollection <(Of <( T >)>)..::. ObjectIncluded(T, T).)
Remove | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
ToString | (Inherited from FilterConditionCollection<(Of <(T>)>).)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
Union | (Inherited from DictionaryBasedSet<(Of <(T>)>).)

Properties

Name | Description
Count | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
IsReadOnly | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Operator | (Overrides FilterConditionCollection <(Of <( T >)>)..::. Operator.)

Explicit Interface Implementations

Name | Description
ICollectionCopyTo | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
IEquatable<(Of <(IFilterCondition<(Of <(T>)>)>)>)..::.Equals | (Inherited from FilterConditionCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)
ICollectionIsSynchronized | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
ICollectionSyncRoot | (Inherited from DictionaryBasedSet<(Of <(T>)>).)

See Also

AND<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


AND(T) Constructor

[image] [image]

SQL Data Compare API 12.0.40
AND<(Of <(T>)>) Constructor
AND<(Of <(T>)>) Class See Also

Overload List

Name | Description
AND<(Of <(T>)>)()()() | Initializes a new AND.
AND<(Of <(T>)>)(Int32) | Initializes a new AND with the specified capacity.
AND<(Of <(T>)>)(IEnumerable<(Of <(IFilterCondition<(Of <(T>)>)>)>)) | Initializes a new AND with the contents of the specified IEnumerable.

See Also

AND<(Of <(T>)>) Class
AND<(Of <(T>)>) Members
RedGate.SQLCompare.Engine.Filter Namespace


AND(T) Constructor

[image]

SQL Data Compare API 12.0.40
AND<(Of <(T>)>) Constructor
AND<(Of <(T>)>) Class See Also

Initializes a new AND.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public AND()
Visual C++
public:
AND()

See Also

AND<(Of <(T>)>) Class
AND<(Of <(T>)>) Overload
RedGate.SQLCompare.Engine.Filter Namespace


AND(T) Constructor ()

[image]

SQL Data Compare API 12.0.40
AND<(Of <(T>)>) Constructor ()
AND<(Of <(T>)>) Class See Also

Initializes a new AND with the specified capacity.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    capacity As Integer _
)
C#
public AND(
    int capacity
)
Visual C++
public:
AND(
    int capacity
)

Parameters

capacity
Type: Int32

See Also

AND<(Of <(T>)>) Class
AND<(Of <(T>)>) Overload
RedGate.SQLCompare.Engine.Filter Namespace


AND(T) Constructor ((IFilterCondition(T)))

[image]

SQL Data Compare API 12.0.40
AND<(Of <(T>)>) Constructor (<(Of <(IFilterCondition<(Of <(T>)>)>)>))
AND<(Of <(T>)>) Class See Also

Initializes a new AND with the contents of the specified IEnumerable.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    e As IEnumerable(Of IFilterCondition(Of T)) _
)
C#
public AND(
    IEnumerable<IFilterCondition<T>> e
)
Visual C++
public:
AND(
    IEnumerable<IFilterCondition<T>^>^ e
)

Parameters

e
Type: IEnumerable<(Of <( IFilterCondition <(Of <( T >)>)>)>)

See Also

AND<(Of <(T>)>) Class
AND<(Of <(T>)>) Overload
RedGate.SQLCompare.Engine.Filter Namespace


AND(T) Methods

[image] [image]

SQL Data Compare API 12.0.40
AND<(Of <(T>)>) Methods
AND<(Of <(T>)>) Class See Also

The AND<(Of <(T>)>) type exposes the following methods.

Methods

Name | Description
Add | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
AddIfNotExists | Adds item to the DictionaryBasedSet<(Of <(T>)>) if it does not already exist. (Inherited from DictionaryBasedSet<(Of <(T>)>).)
AddRange | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
AddRangeIfNotExists | Adds items to the DictionaryBasedSet<(Of <(T>)>) only if none of the items are already in the set. (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Clear | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Clone | (Overrides FilterConditionCollection <(Of <( T >)>)..::. Clone(Boolean).)
Contains | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Difference | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Equals | Overloaded.
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
GetHashCode | (Inherited from FilterConditionCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersection | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
IsDisjointWith | (Inherited from Set<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ObjectIncluded | (Overrides FilterConditionCollection <(Of <( T >)>)..::. ObjectIncluded(T, T).)
Remove | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
ToString | (Inherited from FilterConditionCollection<(Of <(T>)>).)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
Union | (Inherited from DictionaryBasedSet<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
ICollectionCopyTo | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
IEquatable<(Of <(IFilterCondition<(Of <(T>)>)>)>)..::.Equals | (Inherited from FilterConditionCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

AND<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
AND<(Of <(T>)>)..::.Clone Method
AND<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone ( _
    caseSensitive As Boolean _
) As IFilterCondition(Of T)
C#
public override IFilterCondition<T> Clone(
    bool caseSensitive
)
Visual C++
public:
virtual IFilterCondition<T>^ Clone(
    bool caseSensitive
) override

Parameters

caseSensitive
Type: Boolean

Implements

IFilterCondition<(Of <(T>)>)..::.Clone(Boolean)

See Also

AND<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
AND<(Of <(T>)>)..::.Equals Method
AND<(Of <(T>)>) Class See Also

Overload List

Name | Description
Equals(Object) | (Inherited from FilterConditionCollection<(Of <(T>)>).)
Equals(FilterConditionCollection<(Of <(T>)>)) | (Inherited from FilterConditionCollection<(Of <(T>)>).)

See Also

AND<(Of <(T>)>) Class
AND<(Of <(T>)>) Members
RedGate.SQLCompare.Engine.Filter Namespace


ObjectIncluded Method

[image]

SQL Data Compare API 12.0.40
AND<(Of <(T>)>)..::.ObjectIncluded Method
AND<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ObjectIncluded ( _
    objectIn1 As T, _
    objectIn2 As T _
) As Nullable(Of Boolean)
C#
public override Nullable<bool> ObjectIncluded(
    T objectIn1,
    T objectIn2
)
Visual C++
public:
virtual Nullable<bool> ObjectIncluded(
    T objectIn1,
    T objectIn2
) override

Parameters

objectIn1
Type: T
objectIn2
Type: T

Implements

IFilterCondition<(Of <(T>)>)..::.ObjectIncluded(T, T)

See Also

AND<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


AND(T) Properties

[image] [image]

SQL Data Compare API 12.0.40
AND<(Of <(T>)>) Properties
AND<(Of <(T>)>) Class See Also

The AND<(Of <(T>)>) type exposes the following properties.

Properties

Name | Description
Count | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
IsReadOnly | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Operator | (Overrides FilterConditionCollection <(Of <( T >)>)..::. Operator.)

Explicit Interface Implementations

Name | Description
ICollectionIsSynchronized | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
ICollectionSyncRoot | (Inherited from DictionaryBasedSet<(Of <(T>)>).)

See Also

AND<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


Operator Property

[image]

SQL Data Compare API 12.0.40
AND<(Of <(T>)>)..::.Operator Property
AND<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Operator As String
C#
public override sealed string Operator { get; }
Visual C++
public:
virtual property String^ Operator {
    String^ get () override sealed;
}

See Also

AND<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


Condition Class

[image]

SQL Data Compare API 12.0.40
Condition Class
Members See Also

A filter condition on a difference's name or schema.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Condition _
    Implements IFilterCondition(Of FilterableObjectId), IEquatable(Of IFilterCondition(Of FilterableObjectId)),  _
    IEquatable(Of Condition)
C#
public sealed class Condition : IFilterCondition<FilterableObjectId>,
    IEquatable<IFilterCondition<FilterableObjectId>>, IEquatable<Condition>
Visual C++
public ref class Condition sealed : IFilterCondition<FilterableObjectId^>,
    IEquatable<IFilterCondition<FilterableObjectId^>^>, IEquatable<Condition^>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Filter..::.Condition

See Also

Condition Members
RedGate.SQLCompare.Engine.Filter Namespace


Condition Members

[image] [image]

SQL Data Compare API 12.0.40
Condition Members
Condition Class Constructors Methods Properties Explicit Interface Implementations See Also

The Condition type exposes the following members.

Constructors

Name | Description
Condition |

Methods

Name | Description
Clone |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ObjectIncluded |
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
BeginsWith |
DoesNotBeginWith |
DoesNotEndWith |
EndsWith |
FilterExpression | The filter expression.
FilterOn | The difference property being filtered on.
FilterType | The filter type.

Explicit Interface Implementations

Name | Description
IEquatable<(Of <(IFilterCondition<(Of <(FilterableObjectId>)>)>)>)..::.Equals |

See Also

Condition Class
RedGate.SQLCompare.Engine.Filter Namespace


Condition Constructor

[image]

SQL Data Compare API 12.0.40
Condition Constructor
Condition Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean, _
    filterOn As FilterOn, _
    filterType As FilterType, _
    expr As String _
)
C#
public Condition(
    bool caseSensitive,
    FilterOn filterOn,
    FilterType filterType,
    string expr
)
Visual C++
public:
Condition(
    bool caseSensitive,
    FilterOn filterOn,
    FilterType filterType,
    String^ expr
)

Parameters

caseSensitive
Type: Boolean
filterOn
Type: RedGate.SQLCompare.Engine.Filter..::.FilterOn
filterType
Type: RedGate.SQLCompare.Engine.Filter..::.FilterType
expr
Type: String

See Also

Condition Class
RedGate.SQLCompare.Engine.Filter Namespace


Condition Methods

[image] [image]

SQL Data Compare API 12.0.40
Condition Methods
Condition Class See Also

The Condition type exposes the following methods.

Methods

Name | Description
Clone |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ObjectIncluded |
ToString | (Overrides Object..::.ToString()()().)

Explicit Interface Implementations

Name | Description
IEquatable<(Of <(IFilterCondition<(Of <(FilterableObjectId>)>)>)>)..::.Equals |

See Also

Condition Class
RedGate.SQLCompare.Engine.Filter Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
Condition..::.Clone Method
Condition Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone ( _
    caseSensitive As Boolean _
) As IFilterCondition(Of FilterableObjectId)
C#
public IFilterCondition<FilterableObjectId> Clone(
    bool caseSensitive
)
Visual C++
public:
virtual IFilterCondition<FilterableObjectId^>^ Clone(
    bool caseSensitive
) sealed

Parameters

caseSensitive
Type: Boolean

Implements

IFilterCondition<(Of <(T>)>)..::.Clone(Boolean)

See Also

Condition Class
RedGate.SQLCompare.Engine.Filter Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
Condition..::.Equals Method
Condition Class See Also

Overload List

Name | Description
Equals(Object) | (Overrides Object..::.Equals(Object).)
Equals(Condition) | Indicates if the two conditions are equal.

See Also

Condition Class
Condition Members
RedGate.SQLCompare.Engine.Filter Namespace


Equals Method ()

[image]

SQL Data Compare API 12.0.40
Condition..::.Equals Method ()
Condition Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object

See Also

Condition Class
Equals Overload
RedGate.SQLCompare.Engine.Filter Namespace


Equals Method (Condition)

[image]

SQL Data Compare API 12.0.40
Condition..::.Equals Method (Condition)
Condition Class See Also

Indicates if the two conditions are equal.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    c As Condition _
) As Boolean
C#
public bool Equals(
    Condition c
)
Visual C++
public:
virtual bool Equals(
    Condition^ c
) sealed

Parameters

c
Type: RedGate.SQLCompare.Engine.Filter..::.Condition

Return Value

Implements

IEquatableEquals(UTP)

See Also

Condition Class
Equals Overload
RedGate.SQLCompare.Engine.Filter Namespace


(IFilterCondition(FilterableObjectId)). Method

[image]

SQL Data Compare API 12.0.40
Condition..::.<(Of <(IFilterCondition<(Of <(FilterableObjectId>)>)>)>)..::. Method
Condition Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function Equals ( _
    ifcc As IFilterCondition(Of FilterableObjectId) _
) As Boolean Implements IEquatable(Of IFilterCondition(Of FilterableObjectId)).Equals
C#
bool IEquatable<IFilterCondition<FilterableObjectId>>.Equals(
    IFilterCondition<FilterableObjectId> ifcc
)
Visual C++
private:
virtual bool Equals(
    IFilterCondition<FilterableObjectId^>^ ifcc
) sealed = IEquatable<IFilterCondition<FilterableObjectId^>^>::Equals

Parameters

ifcc
Type: RedGate.SQLCompare.Engine.Filter..::.IFilterCondition <(Of <( FilterableObjectId >)>)

Implements

IEquatableEquals(UTP)

See Also

Condition Class
RedGate.SQLCompare.Engine.Filter Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
Condition..::.GetHashCode Method
Condition Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

See Also

Condition Class
RedGate.SQLCompare.Engine.Filter Namespace


ObjectIncluded Method

[image]

SQL Data Compare API 12.0.40
Condition..::.ObjectIncluded Method
Condition Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function ObjectIncluded ( _
    objectIn1 As FilterableObjectId, _
    objectIn2 As FilterableObjectId _
) As Nullable(Of Boolean)
C#
public Nullable<bool> ObjectIncluded(
    FilterableObjectId objectIn1,
    FilterableObjectId objectIn2
)
Visual C++
public:
virtual Nullable<bool> ObjectIncluded(
    FilterableObjectId^ objectIn1,
    FilterableObjectId^ objectIn2
) sealed

Parameters

objectIn1
Type: RedGate.SQLCompare.Engine.Filter..::.FilterableObjectId
objectIn2
Type: RedGate.SQLCompare.Engine.Filter..::.FilterableObjectId

Implements

IFilterCondition<(Of <(T>)>)..::.ObjectIncluded(T, T)

See Also

Condition Class
RedGate.SQLCompare.Engine.Filter Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
Condition..::.ToString Method
Condition Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

See Also

Condition Class
RedGate.SQLCompare.Engine.Filter Namespace


Condition Properties

[image] [image]

SQL Data Compare API 12.0.40
Condition Properties
Condition Class See Also

The Condition type exposes the following properties.

Properties

Name | Description
BeginsWith |
DoesNotBeginWith |
DoesNotEndWith |
EndsWith |
FilterExpression | The filter expression.
FilterOn | The difference property being filtered on.
FilterType | The filter type.

See Also

Condition Class
RedGate.SQLCompare.Engine.Filter Namespace


BeginsWith Property

[image]

SQL Data Compare API 12.0.40
Condition..::.BeginsWith Property
Condition Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BeginsWith As Boolean
C#
public bool BeginsWith { get; }
Visual C++
public:
property bool BeginsWith {
    bool get ();
}

See Also

Condition Class
RedGate.SQLCompare.Engine.Filter Namespace


DoesNotBeginWith Property

[image]

SQL Data Compare API 12.0.40
Condition..::.DoesNotBeginWith Property
Condition Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DoesNotBeginWith As Boolean
C#
public bool DoesNotBeginWith { get; }
Visual C++
public:
property bool DoesNotBeginWith {
    bool get ();
}

See Also

Condition Class
RedGate.SQLCompare.Engine.Filter Namespace


DoesNotEndWith Property

[image]

SQL Data Compare API 12.0.40
Condition..::.DoesNotEndWith Property
Condition Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DoesNotEndWith As Boolean
C#
public bool DoesNotEndWith { get; }
Visual C++
public:
property bool DoesNotEndWith {
    bool get ();
}

See Also

Condition Class
RedGate.SQLCompare.Engine.Filter Namespace


EndsWith Property

[image]

SQL Data Compare API 12.0.40
Condition..::.EndsWith Property
Condition Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EndsWith As Boolean
C#
public bool EndsWith { get; }
Visual C++
public:
property bool EndsWith {
    bool get ();
}

See Also

Condition Class
RedGate.SQLCompare.Engine.Filter Namespace


FilterExpression Property

[image]

SQL Data Compare API 12.0.40
Condition..::.FilterExpression Property
Condition Class See Also

The filter expression.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FilterExpression As String
C#
public string FilterExpression { get; }
Visual C++
public:
property String^ FilterExpression {
    String^ get ();
}

See Also

Condition Class
RedGate.SQLCompare.Engine.Filter Namespace


FilterOn Property

[image]

SQL Data Compare API 12.0.40
Condition..::.FilterOn Property
Condition Class See Also

The difference property being filtered on.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FilterOn As FilterOn
C#
public FilterOn FilterOn { get; }
Visual C++
public:
property FilterOn FilterOn {
    FilterOn get ();
}

See Also

Condition Class
RedGate.SQLCompare.Engine.Filter Namespace


FilterType Property

[image]

SQL Data Compare API 12.0.40
Condition..::.FilterType Property
Condition Class See Also

The filter type.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FilterType As FilterType
C#
public FilterType FilterType { get; }
Visual C++
public:
property FilterType FilterType {
    FilterType get ();
}

See Also

Condition Class
RedGate.SQLCompare.Engine.Filter Namespace


DifferenceFilter Class

[image]

SQL Data Compare API 12.0.40
DifferenceFilter Class
Members See Also

Filters a collection of Differences based on various object properties.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DifferenceFilter _
    Implements IEquatable(Of DifferenceFilter), ICloneable
C#
public sealed class DifferenceFilter : IEquatable<DifferenceFilter>,
    ICloneable
Visual C++
public ref class DifferenceFilter sealed : IEquatable<DifferenceFilter^>,
    ICloneable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Filter..::.DifferenceFilter

See Also

DifferenceFilter Members
RedGate.SQLCompare.Engine.Filter Namespace


DifferenceFilter Members

[image] [image]

SQL Data Compare API 12.0.40
DifferenceFilter Members
DifferenceFilter Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The DifferenceFilter type exposes the following members.

Constructors

Name | Description
DifferenceFilter | Overloaded.

Methods

Name | Description
CanBeFiltered | True if the specified object type can be filtered.
Clone |
DifferenceIncluded | Overloaded.
Equals | Overloaded.
FilterDifferences | Returns an IEnumerable of all the differences that match the filter expression.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilter | Gets the filter for the specified object type.
GetFilterStatus | Returns a value indicating the current filter status of the specified object type.
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetObjectTypeExclude | Sets the specified object type to be unconditionally excluded.
SetObjectTypeFilter | Overloaded.
SetObjectTypeInclude | Sets the specified object type to be unconditionally included.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ObjectTypes | A collection of the object types that can be filtered.

Events

Name | Description
FilterChanged | Event that occurs when a difference filter is changed.

Explicit Interface Implementations

Name | Description
ICloneableClone |
Version |

See Also

DifferenceFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


DifferenceFilter Constructor

[image] [image]

SQL Data Compare API 12.0.40
DifferenceFilter Constructor
DifferenceFilter Class See Also

Overload List

Name | Description
DifferenceFilter()()() | Initializes a new instance of the DifferenceFilter class to include all objects and using case-insensitive matching.
DifferenceFilter(Boolean) | Initializes a new instance of the DifferenceFilter class using case-insensitive matching.
DifferenceFilter(DifferenceFilter) | Initializes a new instance of the DifferenceFilter class to use the same filter expression as the toCopy filter.
DifferenceFilter(Boolean, Boolean) | Initializes a new instance of the DifferenceFilter class.
DifferenceFilter(DifferenceFilter, Boolean) | Initializes a new instance of the DifferenceFilter class to use the same filter expression as the toCopy filter and the specified case-sensitivity.

See Also

DifferenceFilter Class
DifferenceFilter Members
RedGate.SQLCompare.Engine.Filter Namespace


DifferenceFilter Constructor

[image]

SQL Data Compare API 12.0.40
DifferenceFilter Constructor
DifferenceFilter Class See Also

Initializes a new instance of the DifferenceFilter class to include all objects and using case-insensitive matching.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DifferenceFilter()
Visual C++
public:
DifferenceFilter()

See Also

DifferenceFilter Class
DifferenceFilter Overload
RedGate.SQLCompare.Engine.Filter Namespace


DifferenceFilter Constructor ()

[image]

SQL Data Compare API 12.0.40
DifferenceFilter Constructor ()
DifferenceFilter Class See Also

Initializes a new instance of the DifferenceFilter class using case-insensitive matching.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    includeAllObjects As Boolean _
)
C#
public DifferenceFilter(
    bool includeAllObjects
)
Visual C++
public:
DifferenceFilter(
    bool includeAllObjects
)

Parameters

includeAllObjects
Type: Boolean
If true, all objects are included. If false, all objects are filtered out.

See Also

DifferenceFilter Class
DifferenceFilter Overload
RedGate.SQLCompare.Engine.Filter Namespace


DifferenceFilter Constructor (DifferenceFilter)

[image]

SQL Data Compare API 12.0.40
DifferenceFilter Constructor (DifferenceFilter)
DifferenceFilter Class See Also

Initializes a new instance of the DifferenceFilter class to use the same filter expression as the toCopy filter.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    toCopy As DifferenceFilter _
)
C#
public DifferenceFilter(
    DifferenceFilter toCopy
)
Visual C++
public:
DifferenceFilter(
    DifferenceFilter^ toCopy
)

Parameters

toCopy
Type: RedGate.SQLCompare.Engine.Filter..::.DifferenceFilter
The filter to copy.

See Also

DifferenceFilter Class
DifferenceFilter Overload
RedGate.SQLCompare.Engine.Filter Namespace


DifferenceFilter Constructor (, )

[image]

SQL Data Compare API 12.0.40
DifferenceFilter Constructor (, )
DifferenceFilter Class See Also

Initializes a new instance of the DifferenceFilter class.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean, _
    includeAllObjects As Boolean _
)
C#
public DifferenceFilter(
    bool caseSensitive,
    bool includeAllObjects
)
Visual C++
public:
DifferenceFilter(
    bool caseSensitive,
    bool includeAllObjects
)

Parameters

caseSensitive
Type: Boolean
True if matching should be done case-sensitively.
includeAllObjects
Type: Boolean
If true, all objects are included. If false, all objects are filtered out.

See Also

DifferenceFilter Class
DifferenceFilter Overload
RedGate.SQLCompare.Engine.Filter Namespace


DifferenceFilter Constructor (DifferenceFilter, )

[image]

SQL Data Compare API 12.0.40
DifferenceFilter Constructor (DifferenceFilter, )
DifferenceFilter Class See Also

Initializes a new instance of the DifferenceFilter class to use the same filter expression as the toCopy filter and the specified case-sensitivity.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    toCopy As DifferenceFilter, _
    caseSensitive As Boolean _
)
C#
public DifferenceFilter(
    DifferenceFilter toCopy,
    bool caseSensitive
)
Visual C++
public:
DifferenceFilter(
    DifferenceFilter^ toCopy,
    bool caseSensitive
)

Parameters

toCopy
Type: RedGate.SQLCompare.Engine.Filter..::.DifferenceFilter
caseSensitive
Type: Boolean

See Also

DifferenceFilter Class
DifferenceFilter Overload
RedGate.SQLCompare.Engine.Filter Namespace


DifferenceFilter Methods

[image] [image]

SQL Data Compare API 12.0.40
DifferenceFilter Methods
DifferenceFilter Class See Also

The DifferenceFilter type exposes the following methods.

Methods

Name | Description
CanBeFiltered | True if the specified object type can be filtered.
Clone |
DifferenceIncluded | Overloaded.
Equals | Overloaded.
FilterDifferences | Returns an IEnumerable of all the differences that match the filter expression.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilter | Gets the filter for the specified object type.
GetFilterStatus | Returns a value indicating the current filter status of the specified object type.
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetObjectTypeExclude | Sets the specified object type to be unconditionally excluded.
SetObjectTypeFilter | Overloaded.
SetObjectTypeInclude | Sets the specified object type to be unconditionally included.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICloneableClone |

See Also

DifferenceFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


CanBeFiltered Method

[image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.CanBeFiltered Method
DifferenceFilter Class See Also

True if the specified object type can be filtered.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CanBeFiltered ( _
    type As ObjectType _
) As Boolean
C#
public static bool CanBeFiltered(
    ObjectType type
)
Visual C++
public:
static bool CanBeFiltered(
    ObjectType type
)

Parameters

type
Type: ObjectType

Return Value

See Also

DifferenceFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.Clone Method
DifferenceFilter Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone As DifferenceFilter
C#
public DifferenceFilter Clone()
Visual C++
public:
DifferenceFilter^ Clone()

See Also

DifferenceFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


. Method

[image]

SQL Data Compare API 12.0.40
DifferenceFilter..::...::. Method
DifferenceFilter Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function Clone As Object Implements ICloneable.Clone
C#
Object ICloneable.Clone()
Visual C++
private:
virtual Object^ Clone() sealed = ICloneable::Clone

Implements

ICloneableClone()()()

See Also

DifferenceFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


DifferenceIncluded Method

[image] [image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.DifferenceIncluded Method
DifferenceFilter Class See Also

Overload List

Name | Description
DifferenceIncluded(Difference) | Returns true if the specified difference is included by the filter expression.
DifferenceIncluded(FilterableObjectId, FilterableObjectId) | Returns true if the specified difference is included by the filter expression.

See Also

DifferenceFilter Class
DifferenceFilter Members
RedGate.SQLCompare.Engine.Filter Namespace


DifferenceIncluded Method (Difference)

[image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.DifferenceIncluded Method (Difference)
DifferenceFilter Class See Also

Returns true if the specified difference is included by the filter expression.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function DifferenceIncluded ( _
    difference As Difference _
) As Boolean
C#
public bool DifferenceIncluded(
    Difference difference
)
Visual C++
public:
bool DifferenceIncluded(
    Difference^ difference
)

Parameters

difference
Type: RedGate.SQLCompare.Engine..::.Difference

Return Value

True if the difference is included, false if it is excluded.

See Also

DifferenceFilter Class
DifferenceIncluded Overload
RedGate.SQLCompare.Engine.Filter Namespace


DifferenceIncluded Method (FilterableObjectId, FilterableObjectId)

[image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.DifferenceIncluded Method (FilterableObjectId, FilterableObjectId)
DifferenceFilter Class See Also

Returns true if the specified difference is included by the filter expression.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function DifferenceIncluded ( _
    objectIn1 As FilterableObjectId, _
    objectIn2 As FilterableObjectId _
) As Boolean
C#
public bool DifferenceIncluded(
    FilterableObjectId objectIn1,
    FilterableObjectId objectIn2
)
Visual C++
public:
bool DifferenceIncluded(
    FilterableObjectId^ objectIn1,
    FilterableObjectId^ objectIn2
)

Parameters

objectIn1
Type: RedGate.SQLCompare.Engine.Filter..::.FilterableObjectId
objectIn2
Type: RedGate.SQLCompare.Engine.Filter..::.FilterableObjectId

Return Value

True if the difference is included, false if it is excluded.

See Also

DifferenceFilter Class
DifferenceIncluded Overload
RedGate.SQLCompare.Engine.Filter Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.Equals Method
DifferenceFilter Class See Also

Overload List

Name | Description
Equals(Object) | (Overrides Object..::.Equals(Object).)
Equals(DifferenceFilter) |

See Also

DifferenceFilter Class
DifferenceFilter Members
RedGate.SQLCompare.Engine.Filter Namespace


Equals Method ()

[image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.Equals Method ()
DifferenceFilter Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object

See Also

DifferenceFilter Class
Equals Overload
RedGate.SQLCompare.Engine.Filter Namespace


Equals Method (DifferenceFilter)

[image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.Equals Method (DifferenceFilter)
DifferenceFilter Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    other As DifferenceFilter _
) As Boolean
C#
public bool Equals(
    DifferenceFilter other
)
Visual C++
public:
virtual bool Equals(
    DifferenceFilter^ other
) sealed

Parameters

other
Type: RedGate.SQLCompare.Engine.Filter..::.DifferenceFilter

Implements

IEquatableEquals(UTP)

See Also

DifferenceFilter Class
Equals Overload
RedGate.SQLCompare.Engine.Filter Namespace


FilterDifferences Method

[image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.FilterDifferences Method
DifferenceFilter Class See Also

Returns an IEnumerable of all the differences that match the filter expression.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function FilterDifferences ( _
    differences As IEnumerable(Of Difference) _
) As IEnumerable(Of Difference)
C#
public IEnumerable<Difference> FilterDifferences(
    IEnumerable<Difference> differences
)
Visual C++
public:
IEnumerable<Difference^>^ FilterDifferences(
    IEnumerable<Difference^>^ differences
)

Parameters

differences
Type: IEnumerable<(Of <( Difference >)>)

Return Value

An IEnumerable containing the differences remaining after filtering.

See Also

DifferenceFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


GetFilter Method

[image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.GetFilter Method
DifferenceFilter Class See Also

Gets the filter for the specified object type.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetFilter ( _
    type As ObjectType _
) As DifferenceFilter..::.ObjectTypeFilter
C#
public DifferenceFilter..::.ObjectTypeFilter GetFilter(
    ObjectType type
)
Visual C++
public:
DifferenceFilter..::.ObjectTypeFilter GetFilter(
    ObjectType type
)

Parameters

type
Type: ObjectType

Return Value

See Also

DifferenceFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


GetFilterStatus Method

[image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.GetFilterStatus Method
DifferenceFilter Class See Also

Returns a value indicating the current filter status of the specified object type.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetFilterStatus ( _
    type As ObjectType _
) As DifferenceFilter..::.ObjectTypeFilterStatus
C#
public DifferenceFilter..::.ObjectTypeFilterStatus GetFilterStatus(
    ObjectType type
)
Visual C++
public:
DifferenceFilter..::.ObjectTypeFilterStatus GetFilterStatus(
    ObjectType type
)

Parameters

type
Type: ObjectType

Return Value

An instance of the DifferenceFilter..::.ObjectTypeFilterStatus enum indicating the current filter status.

Exceptions

Exception | Condition
ArgumentException | The specified type is not a valid type for filtering, or type is None()()().

See Also

DifferenceFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.GetHashCode Method
DifferenceFilter Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

See Also

DifferenceFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


SetObjectTypeExclude Method

[image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.SetObjectTypeExclude Method
DifferenceFilter Class See Also

Sets the specified object type to be unconditionally excluded.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetObjectTypeExclude ( _
    type As ObjectType _
)
C#
public void SetObjectTypeExclude(
    ObjectType type
)
Visual C++
public:
void SetObjectTypeExclude(
    ObjectType type
)

Parameters

type
Type: ObjectType

See Also

DifferenceFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


SetObjectTypeFilter Method

[image] [image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.SetObjectTypeFilter Method
DifferenceFilter Class See Also

Overload List

Name | Description
SetObjectTypeFilter(ObjectType, Boolean, IFilterCondition<(Of <(FilterableObjectId>)>)) | Sets the specified object type to be filtered.
SetObjectTypeFilter(ObjectType, Boolean, String) | Sets the specified object type to be filtered.

See Also

DifferenceFilter Class
DifferenceFilter Members
RedGate.SQLCompare.Engine.Filter Namespace


SetObjectTypeFilter Method (, , IFilterCondition(FilterableObjectId))

[image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.SetObjectTypeFilter Method (, , IFilterCondition<(Of <(FilterableObjectId>)>))
DifferenceFilter Class See Also

Sets the specified object type to be filtered.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetObjectTypeFilter ( _
    type As ObjectType, _
    include As Boolean, _
    filterCondition As IFilterCondition(Of FilterableObjectId) _
)
C#
public void SetObjectTypeFilter(
    ObjectType type,
    bool include,
    IFilterCondition<FilterableObjectId> filterCondition
)
Visual C++
public:
void SetObjectTypeFilter(
    ObjectType type,
    bool include,
    IFilterCondition<FilterableObjectId^>^ filterCondition
)

Parameters

type
Type: ObjectType
The object type.
include
Type: Boolean
True if this is an inclusion filter, false if it is an exclusion filter.
filterCondition
Type: RedGate.SQLCompare.Engine.Filter..::.IFilterCondition <(Of <( FilterableObjectId >)>)
The filter condition.

See Also

DifferenceFilter Class
SetObjectTypeFilter Overload
RedGate.SQLCompare.Engine.Filter Namespace


SetObjectTypeFilter Method (, , )

[image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.SetObjectTypeFilter Method (, , )
DifferenceFilter Class See Also

Sets the specified object type to be filtered.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetObjectTypeFilter ( _
    type As ObjectType, _
    include As Boolean, _
    filterExpression As String _
)
C#
public void SetObjectTypeFilter(
    ObjectType type,
    bool include,
    string filterExpression
)
Visual C++
public:
void SetObjectTypeFilter(
    ObjectType type,
    bool include,
    String^ filterExpression
)

Parameters

type
Type: ObjectType
The object type.
include
Type: Boolean
True if this is an inclusion filter, false if it is an exclusion filter.
filterExpression
Type: String
The filter expression.

See Also

DifferenceFilter Class
SetObjectTypeFilter Overload
RedGate.SQLCompare.Engine.Filter Namespace


SetObjectTypeInclude Method

[image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.SetObjectTypeInclude Method
DifferenceFilter Class See Also

Sets the specified object type to be unconditionally included.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetObjectTypeInclude ( _
    type As ObjectType _
)
C#
public void SetObjectTypeInclude(
    ObjectType type
)
Visual C++
public:
void SetObjectTypeInclude(
    ObjectType type
)

Parameters

type
Type: ObjectType

See Also

DifferenceFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


DifferenceFilter Properties

[image] [image]

SQL Data Compare API 12.0.40
DifferenceFilter Properties
DifferenceFilter Class See Also

The DifferenceFilter type exposes the following properties.

Properties

Name | Description
ObjectTypes | A collection of the object types that can be filtered.

Explicit Interface Implementations

Name | Description
Version |

See Also

DifferenceFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


ObjectTypes Property

[image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.ObjectTypes Property
DifferenceFilter Class See Also

A collection of the object types that can be filtered.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ObjectTypes As ICollection(Of ObjectType)
C#
public static ICollection<ObjectType> ObjectTypes { get; }
Visual C++
public:
static property ICollection<ObjectType>^ ObjectTypes {
    ICollection<ObjectType>^ get ();
}

See Also

DifferenceFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


Property

[image]

SQL Data Compare API 12.0.40
DifferenceFilter..::. Property
DifferenceFilter Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private ReadOnly Property Version As Integer
C#
private int Version { get; }
Visual C++
private:
virtual property int Version {
    int get () sealed;
}

See Also

DifferenceFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


DifferenceFilter Events

[image] [image]

SQL Data Compare API 12.0.40
DifferenceFilter Events
DifferenceFilter Class See Also

The DifferenceFilter type exposes the following events.

Events

Name | Description
FilterChanged | Event that occurs when a difference filter is changed.

See Also

DifferenceFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


FilterChanged Event

[image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.FilterChanged Event
DifferenceFilter Class See Also

Event that occurs when a difference filter is changed.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Event FilterChanged As EventHandler
C#
public event EventHandler FilterChanged
Visual C++
public:
 event EventHandler^ FilterChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

DifferenceFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


DifferenceFilter.ObjectTypeFilter Structure

[image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.ObjectTypeFilter Structure
DifferenceFilter Class Members See Also

A filter for a single object type. Can be set as include or exclude.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Structure ObjectTypeFilter _
    Implements IEquatable(Of DifferenceFilter..::.ObjectTypeFilter)
C#
public struct ObjectTypeFilter : IEquatable<DifferenceFilter..::.ObjectTypeFilter>
Visual C++
public value class ObjectTypeFilter : IEquatable<DifferenceFilter..::.ObjectTypeFilter>

See Also

DifferenceFilter..::.ObjectTypeFilter Members
RedGate.SQLCompare.Engine.Filter Namespace


DifferenceFilter.ObjectTypeFilter Members

[image] [image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.ObjectTypeFilter Members
DifferenceFilter..::.ObjectTypeFilter Structure Methods Properties See Also

Filters a collection of Differences based on various object properties.

The DifferenceFilter..::.ObjectTypeFilter type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Operators

Name | Description
Equality |
Inequality |

Properties

Name | Description
Filter | The filter condition.
Include | True if Filter specifies inclusion, false if it specifies exclusion.

See Also

DifferenceFilter..::.ObjectTypeFilter Structure
RedGate.SQLCompare.Engine.Filter Namespace


DifferenceFilter.ObjectTypeFilter Methods

[image] [image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.ObjectTypeFilter Methods
DifferenceFilter..::.ObjectTypeFilter Structure See Also

The DifferenceFilter..::.ObjectTypeFilter type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Operators

Name | Description
Equality |
Inequality |

See Also

DifferenceFilter..::.ObjectTypeFilter Structure
RedGate.SQLCompare.Engine.Filter Namespace


Equality Operator

[image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.ObjectTypeFilter..::.Equality Operator
DifferenceFilter..::.ObjectTypeFilter Structure See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator = ( _
    x As DifferenceFilter..::.ObjectTypeFilter, _
    y As DifferenceFilter..::.ObjectTypeFilter _
) As Boolean
C#
public static bool operator ==(
    DifferenceFilter..::.ObjectTypeFilter x,
    DifferenceFilter..::.ObjectTypeFilter y
)
Visual C++
public:
static bool operator ==(
    DifferenceFilter..::.ObjectTypeFilter x,
    DifferenceFilter..::.ObjectTypeFilter y
)

Parameters

x
Type: RedGate.SQLCompare.Engine.Filter..::.DifferenceFilter..::.ObjectTypeFilter
y
Type: RedGate.SQLCompare.Engine.Filter..::.DifferenceFilter..::.ObjectTypeFilter

See Also

DifferenceFilter..::.ObjectTypeFilter Structure
RedGate.SQLCompare.Engine.Filter Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.ObjectTypeFilter..::.Equals Method
DifferenceFilter..::.ObjectTypeFilter Structure See Also

Overload List

Name | Description
Equals(Object) | (Overrides ValueType..::.Equals(Object).)
Equals(DifferenceFilter..::.ObjectTypeFilter) |

See Also

DifferenceFilter..::.ObjectTypeFilter Structure
DifferenceFilter..::.ObjectTypeFilter Members
RedGate.SQLCompare.Engine.Filter Namespace


Equals Method ()

[image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.ObjectTypeFilter..::.Equals Method ()
DifferenceFilter..::.ObjectTypeFilter Structure See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object

See Also

DifferenceFilter..::.ObjectTypeFilter Structure
Equals Overload
RedGate.SQLCompare.Engine.Filter Namespace


Equals Method (DifferenceFilter.ObjectTypeFilter)

[image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.ObjectTypeFilter..::.Equals Method (DifferenceFilter..::.ObjectTypeFilter)
DifferenceFilter..::.ObjectTypeFilter Structure See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    filter As DifferenceFilter..::.ObjectTypeFilter _
) As Boolean
C#
public bool Equals(
    DifferenceFilter..::.ObjectTypeFilter filter
)
Visual C++
public:
virtual bool Equals(
    DifferenceFilter..::.ObjectTypeFilter filter
) sealed

Parameters

filter
Type: RedGate.SQLCompare.Engine.Filter..::.DifferenceFilter..::.ObjectTypeFilter

Implements

IEquatableEquals(UTP)

See Also

DifferenceFilter..::.ObjectTypeFilter Structure
Equals Overload
RedGate.SQLCompare.Engine.Filter Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.ObjectTypeFilter..::.GetHashCode Method
DifferenceFilter..::.ObjectTypeFilter Structure See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

See Also

DifferenceFilter..::.ObjectTypeFilter Structure
RedGate.SQLCompare.Engine.Filter Namespace


Inequality Operator

[image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.ObjectTypeFilter..::.Inequality Operator
DifferenceFilter..::.ObjectTypeFilter Structure See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <> ( _
    x As DifferenceFilter..::.ObjectTypeFilter, _
    y As DifferenceFilter..::.ObjectTypeFilter _
) As Boolean
C#
public static bool operator !=(
    DifferenceFilter..::.ObjectTypeFilter x,
    DifferenceFilter..::.ObjectTypeFilter y
)
Visual C++
public:
static bool operator !=(
    DifferenceFilter..::.ObjectTypeFilter x,
    DifferenceFilter..::.ObjectTypeFilter y
)

Parameters

x
Type: RedGate.SQLCompare.Engine.Filter..::.DifferenceFilter..::.ObjectTypeFilter
y
Type: RedGate.SQLCompare.Engine.Filter..::.DifferenceFilter..::.ObjectTypeFilter

See Also

DifferenceFilter..::.ObjectTypeFilter Structure
RedGate.SQLCompare.Engine.Filter Namespace


DifferenceFilter.ObjectTypeFilter Properties

[image] [image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.ObjectTypeFilter Properties
DifferenceFilter..::.ObjectTypeFilter Structure See Also

The DifferenceFilter..::.ObjectTypeFilter type exposes the following properties.

Properties

Name | Description
Filter | The filter condition.
Include | True if Filter specifies inclusion, false if it specifies exclusion.

See Also

DifferenceFilter..::.ObjectTypeFilter Structure
RedGate.SQLCompare.Engine.Filter Namespace


Filter Property

[image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.ObjectTypeFilter..::.Filter Property
DifferenceFilter..::.ObjectTypeFilter Structure See Also

The filter condition.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Filter As IFilterCondition(Of FilterableObjectId)
C#
public IFilterCondition<FilterableObjectId> Filter { get; }
Visual C++
public:
property IFilterCondition<FilterableObjectId^>^ Filter {
    IFilterCondition<FilterableObjectId^>^ get ();
}

See Also

DifferenceFilter..::.ObjectTypeFilter Structure
RedGate.SQLCompare.Engine.Filter Namespace


Include Property

[image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.ObjectTypeFilter..::.Include Property
DifferenceFilter..::.ObjectTypeFilter Structure See Also

True if Filter specifies inclusion, false if it specifies exclusion.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Include As Boolean
C#
public bool Include { get; }
Visual C++
public:
property bool Include {
    bool get ();
}

See Also

DifferenceFilter..::.ObjectTypeFilter Structure
RedGate.SQLCompare.Engine.Filter Namespace


DifferenceFilter.ObjectTypeFilterStatus Enumeration

[image]

SQL Data Compare API 12.0.40
DifferenceFilter..::.ObjectTypeFilterStatus Enumeration
DifferenceFilter Class See Also

The filtering status for a specific object type (see GetFilterStatus(ObjectType)).

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration ObjectTypeFilterStatus
C#
public enum ObjectTypeFilterStatus
Visual C++
public enum class ObjectTypeFilterStatus

Members

Member name | Description
Excluded |
Filtered |
Included |

See Also

RedGate.SQLCompare.Engine.Filter Namespace


DifferenceFilterFactory Class

[image]

SQL Data Compare API 12.0.40
DifferenceFilterFactory Class
Members See Also

Class for creating a DifferenceFilter from a global filter expression.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DifferenceFilterFactory
C#
public static class DifferenceFilterFactory
Visual C++
public ref class DifferenceFilterFactory abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Filter..::.DifferenceFilterFactory

See Also

DifferenceFilterFactory Members
RedGate.SQLCompare.Engine.Filter Namespace


DifferenceFilterFactory Members

[image] [image]

SQL Data Compare API 12.0.40
DifferenceFilterFactory Members
DifferenceFilterFactory Class Methods See Also

The DifferenceFilterFactory type exposes the following members.

Methods

Name | Description
CreateFilter | Creates a filter from the specified filter expression.

See Also

DifferenceFilterFactory Class
RedGate.SQLCompare.Engine.Filter Namespace


DifferenceFilterFactory Methods

[image] [image]

SQL Data Compare API 12.0.40
DifferenceFilterFactory Methods
DifferenceFilterFactory Class See Also

The DifferenceFilterFactory type exposes the following methods.

Methods

Name | Description
CreateFilter | Creates a filter from the specified filter expression.

See Also

DifferenceFilterFactory Class
RedGate.SQLCompare.Engine.Filter Namespace


CreateFilter Method

[image]

SQL Data Compare API 12.0.40
DifferenceFilterFactory..::.CreateFilter Method
DifferenceFilterFactory Class See Also

Creates a filter from the specified filter expression.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateFilter ( _
    caseSensitive As Boolean, _
    filter As String _
) As DifferenceFilter
C#
public static DifferenceFilter CreateFilter(
    bool caseSensitive,
    string filter
)
Visual C++
public:
static DifferenceFilter^ CreateFilter(
    bool caseSensitive,
    String^ filter
)

Parameters

caseSensitive
Type: Boolean
filter
Type: String

Return Value

See Also

DifferenceFilterFactory Class
RedGate.SQLCompare.Engine.Filter Namespace


FilterableObjectId Class

[image]

SQL Data Compare API 12.0.40
FilterableObjectId Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class FilterableObjectId _
    Implements IDatabaseObject, ITSqlObject, ICanExistenceCheck
C#
public class FilterableObjectId : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck
Visual C++
public ref class FilterableObjectId : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Filter..::.FilterableObjectId

See Also

FilterableObjectId Members
RedGate.SQLCompare.Engine.Filter Namespace


FilterableObjectId Members

[image] [image]

SQL Data Compare API 12.0.40
FilterableObjectId Members
FilterableObjectId Class Constructors Methods Properties Explicit Interface Implementations See Also

The FilterableObjectId type exposes the following members.

Constructors

Name | Description
FilterableObjectId |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterableObjectIds |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Name |
ObjectType |
Owner |

Explicit Interface Implementations

Name | Description
IDatabaseObject..::.Database |
IDatabaseObject..::.Equals |
ITSqlObjectFullyQualifiedName |
ITSqlObjectQualifiedName |

See Also

FilterableObjectId Class
RedGate.SQLCompare.Engine.Filter Namespace


FilterableObjectId Constructor

[image]

SQL Data Compare API 12.0.40
FilterableObjectId Constructor
FilterableObjectId Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    owner As String, _
    name As String, _
    objectType As ObjectType _
)
C#
public FilterableObjectId(
    string owner,
    string name,
    ObjectType objectType
)
Visual C++
public:
FilterableObjectId(
    String^ owner,
    String^ name,
    ObjectType objectType
)

Parameters

owner
Type: String
name
Type: String
objectType
Type: ObjectType

See Also

FilterableObjectId Class
RedGate.SQLCompare.Engine.Filter Namespace


FilterableObjectId Methods

[image] [image]

SQL Data Compare API 12.0.40
FilterableObjectId Methods
FilterableObjectId Class See Also

The FilterableObjectId type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterableObjectIds |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IDatabaseObject..::.Equals |

See Also

FilterableObjectId Class
RedGate.SQLCompare.Engine.Filter Namespace


IDatabaseObject.Equals Method

[image]

SQL Data Compare API 12.0.40
FilterableObjectId..::.IDatabaseObject..::.Equals Method
FilterableObjectId Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean Implements IDatabaseObject.Equals
C#
bool IDatabaseObject.Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
private:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) sealed = IDatabaseObject::Equals

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

FilterableObjectId Class
RedGate.SQLCompare.Engine.Filter Namespace


GetFilterableObjectIds Method

[image]

SQL Data Compare API 12.0.40
FilterableObjectId..::.GetFilterableObjectIds Method
FilterableObjectId Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFilterableObjectIds ( _
    difference As Difference _
) As Pair(Of FilterableObjectId, FilterableObjectId)
C#
public static Pair<FilterableObjectId, FilterableObjectId> GetFilterableObjectIds(
    Difference difference
)
Visual C++
public:
static Pair<FilterableObjectId^, FilterableObjectId^> GetFilterableObjectIds(
    Difference^ difference
)

Parameters

difference
Type: RedGate.SQLCompare.Engine..::.Difference

See Also

FilterableObjectId Class
RedGate.SQLCompare.Engine.Filter Namespace


FilterableObjectId Properties

[image] [image]

SQL Data Compare API 12.0.40
FilterableObjectId Properties
FilterableObjectId Class See Also

The FilterableObjectId type exposes the following properties.

Properties

Name | Description
Name |
ObjectType |
Owner |

Explicit Interface Implementations

Name | Description
IDatabaseObject..::.Database |
ITSqlObjectFullyQualifiedName |
ITSqlObjectQualifiedName |

See Also

FilterableObjectId Class
RedGate.SQLCompare.Engine.Filter Namespace


IDatabaseObject.Database Property

[image]

SQL Data Compare API 12.0.40
FilterableObjectId..::.IDatabaseObject..::.Database Property
FilterableObjectId Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private ReadOnly Property Database As Database
    Implements IDatabaseObject.Database
C#
Database IDatabaseObject.Database { get; }
Visual C++
private:
virtual property Database^ Database {
    Database^ get () sealed = IDatabaseObject::Database::get;
}

Implements

IDatabaseObject..::.Database

See Also

FilterableObjectId Class
RedGate.SQLCompare.Engine.Filter Namespace


. Property

[image]

SQL Data Compare API 12.0.40
FilterableObjectId..::...::. Property
FilterableObjectId Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private ReadOnly Property FullyQualifiedName As String
    Implements ITSqlObject.FullyQualifiedName
C#
string ITSqlObject.FullyQualifiedName { get; }
Visual C++
private:
virtual property String^ FullyQualifiedName {
    String^ get () sealed = ITSqlObject::FullyQualifiedName::get;
}

Implements

ITSqlObjectFullyQualifiedName()()()

See Also

FilterableObjectId Class
RedGate.SQLCompare.Engine.Filter Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
FilterableObjectId..::.Name Property
FilterableObjectId Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
}

Implements

ITSqlObjectName()()()

See Also

FilterableObjectId Class
RedGate.SQLCompare.Engine.Filter Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
FilterableObjectId..::.ObjectType Property
FilterableObjectId Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ObjectType As ObjectType
C#
public ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () sealed;
}

Implements

ITSqlObjectObjectType()()()

See Also

FilterableObjectId Class
RedGate.SQLCompare.Engine.Filter Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
FilterableObjectId..::.Owner Property
FilterableObjectId Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Owner As String
C#
public string Owner { get; }
Visual C++
public:
virtual property String^ Owner {
    String^ get () sealed;
}

Implements

ITSqlObjectOwner()()()

See Also

FilterableObjectId Class
RedGate.SQLCompare.Engine.Filter Namespace


. Property

[image]

SQL Data Compare API 12.0.40
FilterableObjectId..::...::. Property
FilterableObjectId Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private ReadOnly Property QualifiedName As String
    Implements ITSqlObject.QualifiedName
C#
string ITSqlObject.QualifiedName { get; }
Visual C++
private:
virtual property String^ QualifiedName {
    String^ get () sealed = ITSqlObject::QualifiedName::get;
}

Implements

ITSqlObjectQualifiedName()()()

See Also

FilterableObjectId Class
RedGate.SQLCompare.Engine.Filter Namespace


FilterConditionCollection(T) Generic Class

[image]

SQL Data Compare API 12.0.40
FilterConditionCollection<(Of <(T>)>) Generic Class
Members See Also

A set of filter conditions.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class FilterConditionCollection(Of T) _
    Inherits Set(Of IFilterCondition(Of T)) _
    Implements IFilterCondition(Of T), IEquatable(Of IFilterCondition(Of T)),  _
    IEquatable(Of FilterConditionCollection(Of T))
C#
public abstract class FilterConditionCollection<T> : Set<IFilterCondition<T>>, IFilterCondition<T>,
    IEquatable<IFilterCondition<T>>, IEquatable<FilterConditionCollection<T>>
Visual C++
generic<typename T>
public ref class FilterConditionCollection abstract : public Set<IFilterCondition<T>^>,
    IFilterCondition<T>, IEquatable<IFilterCondition<T>^>, IEquatable<FilterConditionCollection<T>^>

Type Parameters

T

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <(T>)>)
RedGate.Shared.Utils.Collections..::.DictionaryBasedSet <(Of <(T>)>)
RedGate.Shared.Utils.Collections..::.Set <(Of <( IFilterCondition <(Of <(T>)>)>)>)
RedGate.SQLCompare.Engine.Filter..::.FilterConditionCollection<(Of <(T>)>)
RedGate.SQLCompare.Engine.Filter..::.AND<(Of <(T>)>)
RedGate.SQLCompare.Engine.Filter..::.OR<(Of <(T>)>)

See Also

FilterConditionCollection<(Of <(T>)>) Members
RedGate.SQLCompare.Engine.Filter Namespace


FilterConditionCollection(T) Members

[image] [image]

SQL Data Compare API 12.0.40
FilterConditionCollection<(Of <(T>)>) Members
FilterConditionCollection<(Of <(T>)>) Class Constructors Methods Properties Explicit Interface Implementations See Also

The FilterConditionCollection<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
FilterConditionCollection<(Of <(T>)>) | Overloaded.

Methods

Name | Description
Add | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
AddIfNotExists | Adds item to the DictionaryBasedSet<(Of <(T>)>) if it does not already exist. (Inherited from DictionaryBasedSet<(Of <(T>)>).)
AddRange | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
AddRangeIfNotExists | Adds items to the DictionaryBasedSet<(Of <(T>)>) only if none of the items are already in the set. (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Clear | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Clone |
Contains | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Difference | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Equals | Overloaded.
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersection | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
IsDisjointWith | (Inherited from Set<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ObjectIncluded |
Remove | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
ToString | (Overrides Object..::.ToString()()().)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
Union | (Inherited from DictionaryBasedSet<(Of <(T>)>).)

Properties

Name | Description
Count | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
IsReadOnly | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Operator | The operator to join filter conditions in the string representation of the collection (eg 'AND' or 'OR')

Explicit Interface Implementations

Name | Description
ICollectionCopyTo | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
IEquatable<(Of <(IFilterCondition<(Of <(T>)>)>)>)..::.Equals |
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)
ICollectionIsSynchronized | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
ICollectionSyncRoot | (Inherited from DictionaryBasedSet<(Of <(T>)>).)

See Also

FilterConditionCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


FilterConditionCollection(T) Constructor

[image] [image]

SQL Data Compare API 12.0.40
FilterConditionCollection<(Of <(T>)>) Constructor
FilterConditionCollection<(Of <(T>)>) Class See Also

Overload List

Name | Description
FilterConditionCollection<(Of <(T>)>)()()() | Initializes a new FilterConditionCollection.
FilterConditionCollection<(Of <(T>)>)(Int32) | Initializes a new FilterConditionCollection with the specified capacity.
FilterConditionCollection<(Of <(T>)>)(IEnumerable<(Of <(IFilterCondition<(Of <(T>)>)>)>)) | Initializes a new FilterConditionCollection with the contents of the specified IEnumerable.

See Also

FilterConditionCollection<(Of <(T>)>) Class
FilterConditionCollection<(Of <(T>)>) Members
RedGate.SQLCompare.Engine.Filter Namespace


FilterConditionCollection(T) Constructor

[image]

SQL Data Compare API 12.0.40
FilterConditionCollection<(Of <(T>)>) Constructor
FilterConditionCollection<(Of <(T>)>) Class See Also

Initializes a new FilterConditionCollection.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected FilterConditionCollection()
Visual C++
protected:
FilterConditionCollection()

See Also

FilterConditionCollection<(Of <(T>)>) Class
FilterConditionCollection<(Of <(T>)>) Overload
RedGate.SQLCompare.Engine.Filter Namespace


FilterConditionCollection(T) Constructor ()

[image]

SQL Data Compare API 12.0.40
FilterConditionCollection<(Of <(T>)>) Constructor ()
FilterConditionCollection<(Of <(T>)>) Class See Also

Initializes a new FilterConditionCollection with the specified capacity.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    capacity As Integer _
)
C#
protected FilterConditionCollection(
    int capacity
)
Visual C++
protected:
FilterConditionCollection(
    int capacity
)

Parameters

capacity
Type: Int32

See Also

FilterConditionCollection<(Of <(T>)>) Class
FilterConditionCollection<(Of <(T>)>) Overload
RedGate.SQLCompare.Engine.Filter Namespace


FilterConditionCollection(T) Constructor ((IFilterCondition(T)))

[image]

SQL Data Compare API 12.0.40
FilterConditionCollection<(Of <(T>)>) Constructor (<(Of <(IFilterCondition<(Of <(T>)>)>)>))
FilterConditionCollection<(Of <(T>)>) Class See Also

Initializes a new FilterConditionCollection with the contents of the specified IEnumerable.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    enumerable As IEnumerable(Of IFilterCondition(Of T)) _
)
C#
protected FilterConditionCollection(
    IEnumerable<IFilterCondition<T>> enumerable
)
Visual C++
protected:
FilterConditionCollection(
    IEnumerable<IFilterCondition<T>^>^ enumerable
)

Parameters

enumerable
Type: IEnumerable<(Of <( IFilterCondition <(Of <( T >)>)>)>)

See Also

FilterConditionCollection<(Of <(T>)>) Class
FilterConditionCollection<(Of <(T>)>) Overload
RedGate.SQLCompare.Engine.Filter Namespace


FilterConditionCollection(T) Methods

[image] [image]

SQL Data Compare API 12.0.40
FilterConditionCollection<(Of <(T>)>) Methods
FilterConditionCollection<(Of <(T>)>) Class See Also

The FilterConditionCollection<(Of <(T>)>) type exposes the following methods.

Methods

Name | Description
Add | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
AddIfNotExists | Adds item to the DictionaryBasedSet<(Of <(T>)>) if it does not already exist. (Inherited from DictionaryBasedSet<(Of <(T>)>).)
AddRange | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
AddRangeIfNotExists | Adds items to the DictionaryBasedSet<(Of <(T>)>) only if none of the items are already in the set. (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Clear | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Clone |
Contains | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Difference | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Equals | Overloaded.
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersection | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
IsDisjointWith | (Inherited from Set<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ObjectIncluded |
Remove | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
ToString | (Overrides Object..::.ToString()()().)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
Union | (Inherited from DictionaryBasedSet<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
ICollectionCopyTo | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
IEquatable<(Of <(IFilterCondition<(Of <(T>)>)>)>)..::.Equals |
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

FilterConditionCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
FilterConditionCollection<(Of <(T>)>)..::.Clone Method
FilterConditionCollection<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function Clone ( _
    caseSensitive As Boolean _
) As IFilterCondition(Of T)
C#
public abstract IFilterCondition<T> Clone(
    bool caseSensitive
)
Visual C++
public:
virtual IFilterCondition<T>^ Clone(
    bool caseSensitive
) abstract

Parameters

caseSensitive
Type: Boolean

Implements

IFilterCondition<(Of <(T>)>)..::.Clone(Boolean)

See Also

FilterConditionCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
FilterConditionCollection<(Of <(T>)>)..::.Equals Method
FilterConditionCollection<(Of <(T>)>) Class See Also

Overload List

Name | Description
Equals(Object) | (Overrides Object..::.Equals(Object).)
Equals(FilterConditionCollection<(Of <(T>)>)) |

See Also

FilterConditionCollection<(Of <(T>)>) Class
FilterConditionCollection<(Of <(T>)>) Members
RedGate.SQLCompare.Engine.Filter Namespace


Equals Method ()

[image]

SQL Data Compare API 12.0.40
FilterConditionCollection<(Of <(T>)>)..::.Equals Method ()
FilterConditionCollection<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
C#
public override sealed bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: Object

See Also

FilterConditionCollection<(Of <(T>)>) Class
Equals Overload
RedGate.SQLCompare.Engine.Filter Namespace


Equals Method (FilterConditionCollection(T))

[image]

SQL Data Compare API 12.0.40
FilterConditionCollection<(Of <(T>)>)..::.Equals Method (FilterConditionCollection<(Of <(T>)>))
FilterConditionCollection<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Equals ( _
    other As FilterConditionCollection(Of T) _
) As Boolean
C#
public virtual bool Equals(
    FilterConditionCollection<T> other
)
Visual C++
public:
virtual bool Equals(
    FilterConditionCollection<T>^ other
)

Parameters

other
Type: RedGate.SQLCompare.Engine.Filter..::.FilterConditionCollection <(Of <( T >)>)

Implements

IEquatableEquals(UTP)

See Also

FilterConditionCollection<(Of <(T>)>) Class
Equals Overload
RedGate.SQLCompare.Engine.Filter Namespace


(IFilterCondition(T)). Method

[image]

SQL Data Compare API 12.0.40
FilterConditionCollection<(Of <(T>)>)..::.<(Of <(IFilterCondition<(Of <(T>)>)>)>)..::. Method
FilterConditionCollection<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function Equals ( _
    ifc As IFilterCondition(Of T) _
) As Boolean Implements IEquatable(Of IFilterCondition(Of T)).Equals
C#
bool IEquatable<IFilterCondition<T>>.Equals(
    IFilterCondition<T> ifc
)
Visual C++
private:
virtual bool Equals(
    IFilterCondition<T>^ ifc
) sealed = IEquatable<IFilterCondition<T>^>::Equals

Parameters

ifc
Type: RedGate.SQLCompare.Engine.Filter..::.IFilterCondition <(Of <( T >)>)

Implements

IEquatableEquals(UTP)

See Also

FilterConditionCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
FilterConditionCollection<(Of <(T>)>)..::.GetHashCode Method
FilterConditionCollection<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

See Also

FilterConditionCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


ObjectIncluded Method

[image]

SQL Data Compare API 12.0.40
FilterConditionCollection<(Of <(T>)>)..::.ObjectIncluded Method
FilterConditionCollection<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function ObjectIncluded ( _
    o As T, _
    o2 As T _
) As Nullable(Of Boolean)
C#
public abstract Nullable<bool> ObjectIncluded(
    T o,
    T o2
)
Visual C++
public:
virtual Nullable<bool> ObjectIncluded(
    T o,
    T o2
) abstract

Parameters

o
Type: T
o2
Type: T

Implements

IFilterCondition<(Of <(T>)>)..::.ObjectIncluded(T, T)

See Also

FilterConditionCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
FilterConditionCollection<(Of <(T>)>)..::.ToString Method
FilterConditionCollection<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

See Also

FilterConditionCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


FilterConditionCollection(T) Properties

[image] [image]

SQL Data Compare API 12.0.40
FilterConditionCollection<(Of <(T>)>) Properties
FilterConditionCollection<(Of <(T>)>) Class See Also

The FilterConditionCollection<(Of <(T>)>) type exposes the following properties.

Properties

Name | Description
Count | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
IsReadOnly | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Operator | The operator to join filter conditions in the string representation of the collection (eg 'AND' or 'OR')

Explicit Interface Implementations

Name | Description
ICollectionIsSynchronized | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
ICollectionSyncRoot | (Inherited from DictionaryBasedSet<(Of <(T>)>).)

See Also

FilterConditionCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


Operator Property

[image]

SQL Data Compare API 12.0.40
FilterConditionCollection<(Of <(T>)>)..::.Operator Property
FilterConditionCollection<(Of <(T>)>) Class See Also

The operator to join filter conditions in the string representation of the collection (eg 'AND' or 'OR')

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Operator As String
C#
public abstract string Operator { get; }
Visual C++
public:
virtual property String^ Operator {
    String^ get () abstract;
}

See Also

FilterConditionCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


FilterException Class

[image]

SQL Data Compare API 12.0.40
FilterException Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class FilterException _
    Inherits SqlCompareException
C#
[SerializableAttribute]
public class FilterException : SqlCompareException
Visual C++
[SerializableAttribute]
public ref class FilterException : public SqlCompareException

Inheritance Hierarchy

Object
Exception
RedGate.SQLCompare.Engine..::.SqlCompareException
RedGate.SQLCompare.Engine.Filter..::.FilterException

See Also

FilterException Members
RedGate.SQLCompare.Engine.Filter Namespace


FilterException Members

[image] [image]

SQL Data Compare API 12.0.40
FilterException Members
FilterException Class Constructors Methods Properties See Also

The FilterException type exposes the following members.

Constructors

Name | Description
FilterException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FilterException Class
RedGate.SQLCompare.Engine.Filter Namespace


FilterException Constructor

[image] [image]

SQL Data Compare API 12.0.40
FilterException Constructor
FilterException Class See Also

Overload List

Name | Description
FilterException()()() |
FilterException(String) |
FilterException(SerializationInfo, StreamingContext) |
FilterException(String, Exception) |

See Also

FilterException Class
FilterException Members
RedGate.SQLCompare.Engine.Filter Namespace


FilterException Constructor

[image]

SQL Data Compare API 12.0.40
FilterException Constructor
FilterException Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FilterException()
Visual C++
public:
FilterException()

See Also

FilterException Class
FilterException Overload
RedGate.SQLCompare.Engine.Filter Namespace


FilterException Constructor ()

[image]

SQL Data Compare API 12.0.40
FilterException Constructor ()
FilterException Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public FilterException(
    string message
)
Visual C++
public:
FilterException(
    String^ message
)

Parameters

message
Type: String

See Also

FilterException Class
FilterException Overload
RedGate.SQLCompare.Engine.Filter Namespace


FilterException Constructor (, )

[image]

SQL Data Compare API 12.0.40
FilterException Constructor (, )
FilterException Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected FilterException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
FilterException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: SerializationInfo
context
Type: StreamingContext

See Also

FilterException Class
FilterException Overload
RedGate.SQLCompare.Engine.Filter Namespace


FilterException Constructor (, )

[image]

SQL Data Compare API 12.0.40
FilterException Constructor (, )
FilterException Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
C#
public FilterException(
    string message,
    Exception innerException
)
Visual C++
public:
FilterException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: String
innerException
Type: Exception

See Also

FilterException Class
FilterException Overload
RedGate.SQLCompare.Engine.Filter Namespace


FilterOn Enumeration

[image]

SQL Data Compare API 12.0.40
FilterOn Enumeration
See Also

The difference property being filtered on.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration FilterOn
C#
public enum FilterOn
Visual C++
public enum class FilterOn

Members

Member name | Description
Name | The difference's name is being filtered.
Schema | The difference's schema is being filtered, if it has one.

See Also

RedGate.SQLCompare.Engine.Filter Namespace


FilterType Enumeration

[image]

SQL Data Compare API 12.0.40
FilterType Enumeration
See Also

The filter condition to apply to filter objects.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration FilterType
C#
public enum FilterType
Visual C++
public enum class FilterType

Members

Member name | Description
EQ | The object property should be equal to the condition value.
NEQ | The object property should be not equals to the condition value.
LIKE | The object property should match the LIKE regex specified in the condition value.
NLIKE | The object property should not match the LIKE regex specified in the condition value.

See Also

RedGate.SQLCompare.Engine.Filter Namespace


IFilterCondition(T) Generic Interface

[image]

SQL Data Compare API 12.0.40
IFilterCondition<(Of <(T>)>) Generic Interface
Members See Also

A filter condition with value equality.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IFilterCondition(Of T) _
    Implements IEquatable(Of IFilterCondition(Of T))
C#
public interface IFilterCondition<T> : IEquatable<IFilterCondition<T>>
Visual C++
generic<typename T>
public interface class IFilterCondition : IEquatable<IFilterCondition<T>^>

Type Parameters

T
The type of object being filtered.

See Also

IFilterCondition<(Of <(T>)>) Members
RedGate.SQLCompare.Engine.Filter Namespace


IFilterCondition(T) Members

[image] [image]

SQL Data Compare API 12.0.40
IFilterCondition<(Of <(T>)>) Members
IFilterCondition<(Of <(T>)>) Interface Methods See Also

The IFilterCondition<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Clone |
Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable<(Of <( IFilterCondition <(Of <( T >)>)>)>).)
ObjectIncluded | Returns true if the difference is included, false if it is filtered out, and null if this filter condition does not apply to this object.

See Also

IFilterCondition<(Of <(T>)>) Interface
RedGate.SQLCompare.Engine.Filter Namespace


IFilterCondition(T) Methods

[image] [image]

SQL Data Compare API 12.0.40
IFilterCondition<(Of <(T>)>) Methods
IFilterCondition<(Of <(T>)>) Interface See Also

The IFilterCondition<(Of <(T>)>) type exposes the following methods.

Methods

Name | Description
Clone |
Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable<(Of <( IFilterCondition <(Of <( T >)>)>)>).)
ObjectIncluded | Returns true if the difference is included, false if it is filtered out, and null if this filter condition does not apply to this object.

See Also

IFilterCondition<(Of <(T>)>) Interface
RedGate.SQLCompare.Engine.Filter Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
IFilterCondition<(Of <(T>)>)..::.Clone Method
IFilterCondition<(Of <(T>)>) Interface See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Clone ( _
    caseSensitive As Boolean _
) As IFilterCondition(Of T)
C#
IFilterCondition<T> Clone(
    bool caseSensitive
)
Visual C++
IFilterCondition<T>^ Clone(
    bool caseSensitive
)

Parameters

caseSensitive
Type: Boolean

See Also

IFilterCondition<(Of <(T>)>) Interface
RedGate.SQLCompare.Engine.Filter Namespace


ObjectIncluded Method

[image]

SQL Data Compare API 12.0.40
IFilterCondition<(Of <(T>)>)..::.ObjectIncluded Method
IFilterCondition<(Of <(T>)>) Interface See Also

Returns true if the difference is included, false if it is filtered out, and null if this filter condition does not apply to this object.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function ObjectIncluded ( _
    objectIn1 As T, _
    objectIn2 As T _
) As Nullable(Of Boolean)
C#
Nullable<bool> ObjectIncluded(
    T objectIn1,
    T objectIn2
)
Visual C++
Nullable<bool> ObjectIncluded(
    T objectIn1,
    T objectIn2
)

Parameters

objectIn1
Type: T
The object to filter on.
objectIn2
Type: T
TODO:

Return Value

True if this object is included, false if it is filtered out, and null if this condition does not apply to this object.

See Also

IFilterCondition<(Of <(T>)>) Interface
RedGate.SQLCompare.Engine.Filter Namespace


NamedFilter Class

[image]

SQL Data Compare API 12.0.40
NamedFilter Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class NamedFilter
C#
public sealed class NamedFilter
Visual C++
public ref class NamedFilter sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Filter..::.NamedFilter

See Also

NamedFilter Members
RedGate.SQLCompare.Engine.Filter Namespace


NamedFilter Members

[image] [image]

SQL Data Compare API 12.0.40
NamedFilter Members
NamedFilter Class Constructors Methods Properties Explicit Interface Implementations See Also

The NamedFilter type exposes the following members.

Constructors

Name | Description
NamedFilter | Overloaded.

Methods

Name | Description
Equals | (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LoadFromDisk |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReloadFromDisk |
SaveToDisk |
SaveToTextWriter |
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
DisplayName |
FileName |
Filter |
IsDirty |
Name |
UnsavedFilter |

Explicit Interface Implementations

Name | Description
Version |

See Also

NamedFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


NamedFilter Constructor

[image] [image]

SQL Data Compare API 12.0.40
NamedFilter Constructor
NamedFilter Class See Also

Overload List

Name | Description
NamedFilter()()() |
NamedFilter(NamedFilter) |
NamedFilter(String, DifferenceFilter) |

See Also

NamedFilter Class
NamedFilter Members
RedGate.SQLCompare.Engine.Filter Namespace


NamedFilter Constructor

[image]

SQL Data Compare API 12.0.40
NamedFilter Constructor
NamedFilter Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public NamedFilter()
Visual C++
public:
NamedFilter()

See Also

NamedFilter Class
NamedFilter Overload
RedGate.SQLCompare.Engine.Filter Namespace


NamedFilter Constructor (NamedFilter)

[image]

SQL Data Compare API 12.0.40
NamedFilter Constructor (NamedFilter)
NamedFilter Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    nf As NamedFilter _
)
C#
public NamedFilter(
    NamedFilter nf
)
Visual C++
public:
NamedFilter(
    NamedFilter^ nf
)

Parameters

nf
Type: RedGate.SQLCompare.Engine.Filter..::.NamedFilter

See Also

NamedFilter Class
NamedFilter Overload
RedGate.SQLCompare.Engine.Filter Namespace


NamedFilter Constructor (, DifferenceFilter)

[image]

SQL Data Compare API 12.0.40
NamedFilter Constructor (, DifferenceFilter)
NamedFilter Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    filter As DifferenceFilter _
)
C#
public NamedFilter(
    string name,
    DifferenceFilter filter
)
Visual C++
public:
NamedFilter(
    String^ name,
    DifferenceFilter^ filter
)

Parameters

name
Type: String
filter
Type: RedGate.SQLCompare.Engine.Filter..::.DifferenceFilter

See Also

NamedFilter Class
NamedFilter Overload
RedGate.SQLCompare.Engine.Filter Namespace


NamedFilter Methods

[image] [image]

SQL Data Compare API 12.0.40
NamedFilter Methods
NamedFilter Class See Also

The NamedFilter type exposes the following methods.

Methods

Name | Description
Equals | (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LoadFromDisk |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReloadFromDisk |
SaveToDisk |
SaveToTextWriter |
ToString | (Overrides Object..::.ToString()()().)

See Also

NamedFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


Equals Method

[image]

SQL Data Compare API 12.0.40
NamedFilter..::.Equals Method
NamedFilter Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object

See Also

NamedFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
NamedFilter..::.GetHashCode Method
NamedFilter Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

See Also

NamedFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


LoadFromDisk Method

[image]

SQL Data Compare API 12.0.40
NamedFilter..::.LoadFromDisk Method
NamedFilter Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function LoadFromDisk ( _
    fileName As String _
) As NamedFilter
C#
public static NamedFilter LoadFromDisk(
    string fileName
)
Visual C++
public:
static NamedFilter^ LoadFromDisk(
    String^ fileName
)

Parameters

fileName
Type: String

See Also

NamedFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


ReloadFromDisk Method

[image]

SQL Data Compare API 12.0.40
NamedFilter..::.ReloadFromDisk Method
NamedFilter Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub ReloadFromDisk
C#
public void ReloadFromDisk()
Visual C++
public:
void ReloadFromDisk()

See Also

NamedFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


SaveToDisk Method

[image]

SQL Data Compare API 12.0.40
NamedFilter..::.SaveToDisk Method
NamedFilter Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function SaveToDisk ( _
    fileName As String _
) As Boolean
C#
public bool SaveToDisk(
    string fileName
)
Visual C++
public:
bool SaveToDisk(
    String^ fileName
)

Parameters

fileName
Type: String

See Also

NamedFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


SaveToTextWriter Method

[image]

SQL Data Compare API 12.0.40
NamedFilter..::.SaveToTextWriter Method
NamedFilter Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveToTextWriter ( _
    textWriter As TextWriter _
)
C#
public void SaveToTextWriter(
    TextWriter textWriter
)
Visual C++
public:
void SaveToTextWriter(
    TextWriter^ textWriter
)

Parameters

textWriter
Type: TextWriter

See Also

NamedFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
NamedFilter..::.ToString Method
NamedFilter Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

See Also

NamedFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


NamedFilter Properties

[image] [image]

SQL Data Compare API 12.0.40
NamedFilter Properties
NamedFilter Class See Also

The NamedFilter type exposes the following properties.

Properties

Name | Description
DisplayName |
FileName |
Filter |
IsDirty |
Name |
UnsavedFilter |

Explicit Interface Implementations

Name | Description
Version |

See Also

NamedFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


DisplayName Property

[image]

SQL Data Compare API 12.0.40
NamedFilter..::.DisplayName Property
NamedFilter Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DisplayName As String
C#
public string DisplayName { get; }
Visual C++
public:
property String^ DisplayName {
    String^ get ();
}

See Also

NamedFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


FileName Property

[image]

SQL Data Compare API 12.0.40
NamedFilter..::.FileName Property
NamedFilter Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FileName As String
C#
public string FileName { get; set; }
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

See Also

NamedFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


Filter Property

[image]

SQL Data Compare API 12.0.40
NamedFilter..::.Filter Property
NamedFilter Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Filter As DifferenceFilter
C#
public DifferenceFilter Filter { get; set; }
Visual C++
public:
property DifferenceFilter^ Filter {
    DifferenceFilter^ get ();
    void set (DifferenceFilter^ value);
}

See Also

NamedFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


IsDirty Property

[image]

SQL Data Compare API 12.0.40
NamedFilter..::.IsDirty Property
NamedFilter Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsDirty As Boolean
C#
public bool IsDirty { get; set; }
Visual C++
public:
property bool IsDirty {
    bool get ();
    void set (bool value);
}

See Also

NamedFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
NamedFilter..::.Name Property
NamedFilter Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

NamedFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


UnsavedFilter Property

[image]

SQL Data Compare API 12.0.40
NamedFilter..::.UnsavedFilter Property
NamedFilter Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UnsavedFilter As Boolean
C#
public bool UnsavedFilter { get; }
Visual C++
public:
property bool UnsavedFilter {
    bool get ();
}

See Also

NamedFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


Property

[image]

SQL Data Compare API 12.0.40
NamedFilter..::. Property
NamedFilter Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private ReadOnly Property Version As Integer
C#
private int Version { get; }
Visual C++
private:
virtual property int Version {
    int get () sealed;
}

See Also

NamedFilter Class
RedGate.SQLCompare.Engine.Filter Namespace


NOT(T) Generic Class

[image]

SQL Data Compare API 12.0.40
NOT<(Of <(T>)>) Generic Class
Members See Also

A NOT filter condition.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class NOT(Of T) _
    Implements IFilterCondition(Of T), IEquatable(Of IFilterCondition(Of T))
C#
public class NOT<T> : IFilterCondition<T>, IEquatable<IFilterCondition<T>>
Visual C++
generic<typename T>
public ref class NOT : IFilterCondition<T>, IEquatable<IFilterCondition<T>^>

Type Parameters

T
The type of object being filtered.

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Filter..::.NOT<(Of <(T>)>)

See Also

NOT<(Of <(T>)>) Members
RedGate.SQLCompare.Engine.Filter Namespace


NOT(T) Members

[image] [image]

SQL Data Compare API 12.0.40
NOT<(Of <(T>)>) Members
NOT<(Of <(T>)>) Class Constructors Methods Properties See Also

The NOT<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
NOT<(Of <(T>)>) |

Methods

Name | Description
Clone |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ObjectIncluded |
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
NotCondition |

See Also

NOT<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


NOT(T) Constructor

[image]

SQL Data Compare API 12.0.40
NOT<(Of <(T>)>) Constructor
NOT<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    cond As IFilterCondition(Of T) _
)
C#
public NOT(
    IFilterCondition<T> cond
)
Visual C++
public:
NOT(
    IFilterCondition<T>^ cond
)

Parameters

cond
Type: RedGate.SQLCompare.Engine.Filter..::.IFilterCondition <(Of <( T >)>)

See Also

NOT<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


NOT(T) Methods

[image] [image]

SQL Data Compare API 12.0.40
NOT<(Of <(T>)>) Methods
NOT<(Of <(T>)>) Class See Also

The NOT<(Of <(T>)>) type exposes the following methods.

Methods

Name | Description
Clone |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ObjectIncluded |
ToString | (Overrides Object..::.ToString()()().)

See Also

NOT<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
NOT<(Of <(T>)>)..::.Clone Method
NOT<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone ( _
    caseSensitive As Boolean _
) As IFilterCondition(Of T)
C#
public IFilterCondition<T> Clone(
    bool caseSensitive
)
Visual C++
public:
virtual IFilterCondition<T>^ Clone(
    bool caseSensitive
) sealed

Parameters

caseSensitive
Type: Boolean

See Also

NOT<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
NOT<(Of <(T>)>)..::.Equals Method
NOT<(Of <(T>)>) Class See Also

Overload List

Name | Description
Equals(Object) | (Overrides Object..::.Equals(Object).)
Equals(IFilterCondition<(Of <(T>)>)) |

See Also

NOT<(Of <(T>)>) Class
NOT<(Of <(T>)>) Members
RedGate.SQLCompare.Engine.Filter Namespace


Equals Method ()

[image]

SQL Data Compare API 12.0.40
NOT<(Of <(T>)>)..::.Equals Method ()
NOT<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object

See Also

NOT<(Of <(T>)>) Class
Equals Overload
RedGate.SQLCompare.Engine.Filter Namespace


Equals Method (IFilterCondition(T))

[image]

SQL Data Compare API 12.0.40
NOT<(Of <(T>)>)..::.Equals Method (IFilterCondition<(Of <(T>)>))
NOT<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    other As IFilterCondition(Of T) _
) As Boolean
C#
public bool Equals(
    IFilterCondition<T> other
)
Visual C++
public:
virtual bool Equals(
    IFilterCondition<T>^ other
) sealed

Parameters

other
Type: RedGate.SQLCompare.Engine.Filter..::.IFilterCondition <(Of <( T >)>)

Implements

IEquatableEquals(UTP)

See Also

NOT<(Of <(T>)>) Class
Equals Overload
RedGate.SQLCompare.Engine.Filter Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
NOT<(Of <(T>)>)..::.GetHashCode Method
NOT<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

See Also

NOT<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


ObjectIncluded Method

[image]

SQL Data Compare API 12.0.40
NOT<(Of <(T>)>)..::.ObjectIncluded Method
NOT<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function ObjectIncluded ( _
    objectIn1 As T, _
    objectIn2 As T _
) As Nullable(Of Boolean)
C#
public Nullable<bool> ObjectIncluded(
    T objectIn1,
    T objectIn2
)
Visual C++
public:
virtual Nullable<bool> ObjectIncluded(
    T objectIn1,
    T objectIn2
) sealed

Parameters

objectIn1
Type: T
objectIn2
Type: T

Implements

IFilterCondition<(Of <(T>)>)..::.ObjectIncluded(T, T)

See Also

NOT<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
NOT<(Of <(T>)>)..::.ToString Method
NOT<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

See Also

NOT<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


NOT(T) Properties

[image] [image]

SQL Data Compare API 12.0.40
NOT<(Of <(T>)>) Properties
NOT<(Of <(T>)>) Class See Also

The NOT<(Of <(T>)>) type exposes the following properties.

Properties

Name | Description
NotCondition |

See Also

NOT<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


NotCondition Property

[image]

SQL Data Compare API 12.0.40
NOT<(Of <(T>)>)..::.NotCondition Property
NOT<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NotCondition As IFilterCondition(Of T)
C#
public IFilterCondition<T> NotCondition { get; }
Visual C++
public:
property IFilterCondition<T>^ NotCondition {
    IFilterCondition<T>^ get ();
}

See Also

NOT<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


OR(T) Generic Class

[image]

SQL Data Compare API 12.0.40
OR<(Of <(T>)>) Generic Class
Members See Also

A set of filter conditions ORed together.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class OR(Of T) _
    Inherits FilterConditionCollection(Of T)
C#
public class OR<T> : FilterConditionCollection<T>
Visual C++
generic<typename T>
public ref class OR : public FilterConditionCollection<T>

Type Parameters

T

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <(T>)>)
RedGate.Shared.Utils.Collections..::.DictionaryBasedSet <(Of <(T>)>)
RedGate.Shared.Utils.Collections..::.Set <(Of <( IFilterCondition <(Of <( T >)>)>)>)
RedGate.SQLCompare.Engine.Filter..::.FilterConditionCollection <(Of <( T >)>)
RedGate.SQLCompare.Engine.Filter..::.OR<(Of <(T>)>)

See Also

OR<(Of <(T>)>) Members
RedGate.SQLCompare.Engine.Filter Namespace


OR(T) Members

[image] [image]

SQL Data Compare API 12.0.40
OR<(Of <(T>)>) Members
OR<(Of <(T>)>) Class Constructors Methods Properties Explicit Interface Implementations See Also

The OR<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
OR<(Of <(T>)>) | Overloaded.

Methods

Name | Description
Add | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
AddIfNotExists | Adds item to the DictionaryBasedSet<(Of <(T>)>) if it does not already exist. (Inherited from DictionaryBasedSet<(Of <(T>)>).)
AddRange | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
AddRangeIfNotExists | Adds items to the DictionaryBasedSet<(Of <(T>)>) only if none of the items are already in the set. (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Clear | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Clone | (Overrides FilterConditionCollection <(Of <( T >)>)..::. Clone(Boolean).)
Contains | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Difference | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Equals | Overloaded.
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
GetHashCode | (Inherited from FilterConditionCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersection | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
IsDisjointWith | (Inherited from Set<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ObjectIncluded | (Inherited from FilterConditionCollection<(Of <(T>)>).)
Remove | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
ToString | (Inherited from FilterConditionCollection<(Of <(T>)>).)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
Union | (Inherited from DictionaryBasedSet<(Of <(T>)>).)

Properties

Name | Description
Count | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
IsReadOnly | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Operator | (Overrides FilterConditionCollection <(Of <( T >)>)..::. Operator.)

Explicit Interface Implementations

Name | Description
ICollectionCopyTo | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
IEquatable<(Of <(IFilterCondition<(Of <(T>)>)>)>)..::.Equals | (Inherited from FilterConditionCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)
ICollectionIsSynchronized | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
ICollectionSyncRoot | (Inherited from DictionaryBasedSet<(Of <(T>)>).)

See Also

OR<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


OR(T) Constructor

[image] [image]

SQL Data Compare API 12.0.40
OR<(Of <(T>)>) Constructor
OR<(Of <(T>)>) Class See Also

Overload List

Name | Description
OR<(Of <(T>)>)()()() | Initializes a new OR.
OR<(Of <(T>)>)(Int32) | Initializes a new OR with the specified capacity.
OR<(Of <(T>)>)(IEnumerable<(Of <(IFilterCondition<(Of <(T>)>)>)>)) | Initializes a new OR with the contents of the specified IEnumerable.

See Also

OR<(Of <(T>)>) Class
OR<(Of <(T>)>) Members
RedGate.SQLCompare.Engine.Filter Namespace


OR(T) Constructor

[image]

SQL Data Compare API 12.0.40
OR<(Of <(T>)>) Constructor
OR<(Of <(T>)>) Class See Also

Initializes a new OR.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public OR()
Visual C++
public:
OR()

See Also

OR<(Of <(T>)>) Class
OR<(Of <(T>)>) Overload
RedGate.SQLCompare.Engine.Filter Namespace


OR(T) Constructor ()

[image]

SQL Data Compare API 12.0.40
OR<(Of <(T>)>) Constructor ()
OR<(Of <(T>)>) Class See Also

Initializes a new OR with the specified capacity.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    capacity As Integer _
)
C#
public OR(
    int capacity
)
Visual C++
public:
OR(
    int capacity
)

Parameters

capacity
Type: Int32

See Also

OR<(Of <(T>)>) Class
OR<(Of <(T>)>) Overload
RedGate.SQLCompare.Engine.Filter Namespace


OR(T) Constructor ((IFilterCondition(T)))

[image]

SQL Data Compare API 12.0.40
OR<(Of <(T>)>) Constructor (<(Of <(IFilterCondition<(Of <(T>)>)>)>))
OR<(Of <(T>)>) Class See Also

Initializes a new OR with the contents of the specified IEnumerable.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    e As IEnumerable(Of IFilterCondition(Of T)) _
)
C#
public OR(
    IEnumerable<IFilterCondition<T>> e
)
Visual C++
public:
OR(
    IEnumerable<IFilterCondition<T>^>^ e
)

Parameters

e
Type: IEnumerable<(Of <( IFilterCondition <(Of <( T >)>)>)>)

See Also

OR<(Of <(T>)>) Class
OR<(Of <(T>)>) Overload
RedGate.SQLCompare.Engine.Filter Namespace


OR(T) Methods

[image] [image]

SQL Data Compare API 12.0.40
OR<(Of <(T>)>) Methods
OR<(Of <(T>)>) Class See Also

The OR<(Of <(T>)>) type exposes the following methods.

Methods

Name | Description
Add | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
AddIfNotExists | Adds item to the DictionaryBasedSet<(Of <(T>)>) if it does not already exist. (Inherited from DictionaryBasedSet<(Of <(T>)>).)
AddRange | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
AddRangeIfNotExists | Adds items to the DictionaryBasedSet<(Of <(T>)>) only if none of the items are already in the set. (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Clear | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Clone | (Overrides FilterConditionCollection <(Of <( T >)>)..::. Clone(Boolean).)
Contains | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Difference | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Equals | Overloaded.
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
GetHashCode | (Inherited from FilterConditionCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersection | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
IsDisjointWith | (Inherited from Set<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ObjectIncluded | (Inherited from FilterConditionCollection<(Of <(T>)>).)
Remove | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
ToString | (Inherited from FilterConditionCollection<(Of <(T>)>).)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
Union | (Inherited from DictionaryBasedSet<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
ICollectionCopyTo | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
IEquatable<(Of <(IFilterCondition<(Of <(T>)>)>)>)..::.Equals | (Inherited from FilterConditionCollection<(Of <(T>)>).)
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

OR<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
OR<(Of <(T>)>)..::.Clone Method
OR<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone ( _
    caseSensitive As Boolean _
) As IFilterCondition(Of T)
C#
public override IFilterCondition<T> Clone(
    bool caseSensitive
)
Visual C++
public:
virtual IFilterCondition<T>^ Clone(
    bool caseSensitive
) override

Parameters

caseSensitive
Type: Boolean

Implements

IFilterCondition<(Of <(T>)>)..::.Clone(Boolean)

See Also

OR<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
OR<(Of <(T>)>)..::.Equals Method
OR<(Of <(T>)>) Class See Also

Overload List

Name | Description
Equals(Object) | (Inherited from FilterConditionCollection<(Of <(T>)>).)
Equals(FilterConditionCollection<(Of <(T>)>)) | (Inherited from FilterConditionCollection<(Of <(T>)>).)

See Also

OR<(Of <(T>)>) Class
OR<(Of <(T>)>) Members
RedGate.SQLCompare.Engine.Filter Namespace


OR(T) Properties

[image] [image]

SQL Data Compare API 12.0.40
OR<(Of <(T>)>) Properties
OR<(Of <(T>)>) Class See Also

The OR<(Of <(T>)>) type exposes the following properties.

Properties

Name | Description
Count | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
IsReadOnly | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Operator | (Overrides FilterConditionCollection <(Of <( T >)>)..::. Operator.)

Explicit Interface Implementations

Name | Description
ICollectionIsSynchronized | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
ICollectionSyncRoot | (Inherited from DictionaryBasedSet<(Of <(T>)>).)

See Also

OR<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


Operator Property

[image]

SQL Data Compare API 12.0.40
OR<(Of <(T>)>)..::.Operator Property
OR<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Operator As String
C#
public override string Operator { get; }
Visual C++
public:
virtual property String^ Operator {
    String^ get () override;
}

See Also

OR<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


True(T) Generic Class

[image]

SQL Data Compare API 12.0.40
True<(Of <(T>)>) Generic Class
Members See Also

A condition that always evaluates to true.

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class True(Of T) _
    Implements IFilterCondition(Of T), IEquatable(Of IFilterCondition(Of T))
C#
public sealed class True<T> : IFilterCondition<T>,
    IEquatable<IFilterCondition<T>>
Visual C++
generic<typename T>
public ref class True sealed : IFilterCondition<T>,
    IEquatable<IFilterCondition<T>^>

Type Parameters

T

Remarks

This is used internally when parsing a filter expression, and as a placeholder for unconditional type conditions.

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Filter..::.True<(Of <(T>)>)

See Also

True<(Of <(T>)>) Members
RedGate.SQLCompare.Engine.Filter Namespace


True(T) Members

[image] [image]

SQL Data Compare API 12.0.40
True<(Of <(T>)>) Members
True<(Of <(T>)>) Class Methods Properties Explicit Interface Implementations See Also

The True<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
Value |

Explicit Interface Implementations

Name | Description
IFilterCondition<(Of <(T>)>)..::.Clone |
IEquatable<(Of <(IFilterCondition<(Of <(T>)>)>)>)..::.Equals |
IFilterCondition<(Of <(T>)>)..::.ObjectIncluded |

See Also

True<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


True(T) Methods

[image] [image]

SQL Data Compare API 12.0.40
True<(Of <(T>)>) Methods
True<(Of <(T>)>) Class See Also

The True<(Of <(T>)>) type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

Explicit Interface Implementations

Name | Description
IFilterCondition<(Of <(T>)>)..::.Clone |
IEquatable<(Of <(IFilterCondition<(Of <(T>)>)>)>)..::.Equals |
IFilterCondition<(Of <(T>)>)..::.ObjectIncluded |

See Also

True<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


IFilterCondition(T).Clone Method

[image]

SQL Data Compare API 12.0.40
True<(Of <(T>)>)..::.IFilterCondition<(Of <(T>)>)..::.Clone Method
True<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function Clone ( _
    caseSensitive As Boolean _
) As IFilterCondition(Of T) Implements IFilterCondition(Of T).Clone
C#
IFilterCondition<T> IFilterCondition<T>.Clone(
    bool caseSensitive
)
Visual C++
private:
virtual IFilterCondition<T>^ Clone(
    bool caseSensitive
) sealed = IFilterCondition<T>::Clone

Parameters

caseSensitive
Type: Boolean

Implements

IFilterCondition<(Of <(T>)>)..::.Clone(Boolean)

See Also

True<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


(IFilterCondition(T)). Method

[image]

SQL Data Compare API 12.0.40
True<(Of <(T>)>)..::.<(Of <(IFilterCondition<(Of <(T>)>)>)>)..::. Method
True<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function Equals ( _
    other As IFilterCondition(Of T) _
) As Boolean Implements IEquatable(Of IFilterCondition(Of T)).Equals
C#
bool IEquatable<IFilterCondition<T>>.Equals(
    IFilterCondition<T> other
)
Visual C++
private:
virtual bool Equals(
    IFilterCondition<T>^ other
) sealed = IEquatable<IFilterCondition<T>^>::Equals

Parameters

other
Type: RedGate.SQLCompare.Engine.Filter..::.IFilterCondition <(Of <( T >)>)

Implements

IEquatableEquals(UTP)

See Also

True<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


IFilterCondition(T).ObjectIncluded Method

[image]

SQL Data Compare API 12.0.40
True<(Of <(T>)>)..::.IFilterCondition<(Of <(T>)>)..::.ObjectIncluded Method
True<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function ObjectIncluded ( _
    objectIn1 As T, _
    objectin2 As T _
) As Nullable(Of Boolean) Implements IFilterCondition(Of T).ObjectIncluded
C#
Nullable<bool> IFilterCondition<T>.ObjectIncluded(
    T objectIn1,
    T objectin2
)
Visual C++
private:
virtual Nullable<bool> ObjectIncluded(
    T objectIn1,
    T objectin2
) sealed = IFilterCondition<T>::ObjectIncluded

Parameters

objectIn1
Type: T
objectin2
Type: T

Implements

IFilterCondition<(Of <(T>)>)..::.ObjectIncluded(T, T)

See Also

True<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
True<(Of <(T>)>)..::.ToString Method
True<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

See Also

True<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


True(T) Properties

[image] [image]

SQL Data Compare API 12.0.40
True<(Of <(T>)>) Properties
True<(Of <(T>)>) Class See Also

The True<(Of <(T>)>) type exposes the following properties.

Properties

Name | Description
Value |

See Also

True<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


Value Property

[image]

SQL Data Compare API 12.0.40
True<(Of <(T>)>)..::.Value Property
True<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Value As True(Of T)
C#
public static True<T> Value { get; }
Visual C++
public:
static property True<T>^ Value {
    True<T>^ get ();
}

See Also

True<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


RedGate.SQLCompare.Engine.MigrationBlocks Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.MigrationBlocks Namespace

Classes

Class | Description
ConjunctionDifferenceFilterer | Performs a boolean AND of two IDifferenceFilterers
ExcludeUnselectedDifferenceFilterer | Includes all differences which have not been unselected


ConjunctionDifferenceFilterer Class

[image]

SQL Data Compare API 12.0.40
ConjunctionDifferenceFilterer Class
Members See Also

Performs a boolean AND of two IDifferenceFilterers

Namespace: RedGate.SQLCompare.Engine.MigrationBlocks
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ConjunctionDifferenceFilterer _
    Implements IDifferenceFilterer
C#
public class ConjunctionDifferenceFilterer : IDifferenceFilterer
Visual C++
public ref class ConjunctionDifferenceFilterer : IDifferenceFilterer

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.MigrationBlocks..::.ConjunctionDifferenceFilterer

See Also

ConjunctionDifferenceFilterer Members
RedGate.SQLCompare.Engine.MigrationBlocks Namespace


ConjunctionDifferenceFilterer Members

[image] [image]

SQL Data Compare API 12.0.40
ConjunctionDifferenceFilterer Members
ConjunctionDifferenceFilterer Class Constructors Methods See Also

The ConjunctionDifferenceFilterer type exposes the following members.

Constructors

Name | Description
ConjunctionDifferenceFilterer |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ShouldIncludeInDeployment |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConjunctionDifferenceFilterer Class
RedGate.SQLCompare.Engine.MigrationBlocks Namespace


ConjunctionDifferenceFilterer Constructor

[image]

SQL Data Compare API 12.0.40
ConjunctionDifferenceFilterer Constructor
ConjunctionDifferenceFilterer Class See Also

Namespace: RedGate.SQLCompare.Engine.MigrationBlocks
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    first As IDifferenceFilterer, _
    second As IDifferenceFilterer _
)
C#
public ConjunctionDifferenceFilterer(
    IDifferenceFilterer first,
    IDifferenceFilterer second
)
Visual C++
public:
ConjunctionDifferenceFilterer(
    IDifferenceFilterer^ first,
    IDifferenceFilterer^ second
)

Parameters

first
Type: IDifferenceFilterer
second
Type: IDifferenceFilterer

See Also

ConjunctionDifferenceFilterer Class
RedGate.SQLCompare.Engine.MigrationBlocks Namespace


ConjunctionDifferenceFilterer Methods

[image] [image]

SQL Data Compare API 12.0.40
ConjunctionDifferenceFilterer Methods
ConjunctionDifferenceFilterer Class See Also

The ConjunctionDifferenceFilterer type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ShouldIncludeInDeployment |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConjunctionDifferenceFilterer Class
RedGate.SQLCompare.Engine.MigrationBlocks Namespace


ShouldIncludeInDeployment Method

[image]

SQL Data Compare API 12.0.40
ConjunctionDifferenceFilterer..::.ShouldIncludeInDeployment Method
ConjunctionDifferenceFilterer Class See Also

Namespace: RedGate.SQLCompare.Engine.MigrationBlocks
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function ShouldIncludeInDeployment ( _
    difference As IDatabaseObjectDifference(Of ITSqlObject) _
) As Boolean
C#
public bool ShouldIncludeInDeployment(
    IDatabaseObjectDifference<ITSqlObject> difference
)
Visual C++
public:
virtual bool ShouldIncludeInDeployment(
    IDatabaseObjectDifference<ITSqlObject^>^ difference
) sealed

Parameters

difference
Type: IDatabaseObjectDifference<(Of <(ITSqlObject>)>)

Implements

IDifferenceFiltererShouldIncludeInDeployment(IDatabaseObjectDifference<(Of <(ITSqlObject>)>))

See Also

ConjunctionDifferenceFilterer Class
RedGate.SQLCompare.Engine.MigrationBlocks Namespace


ExcludeUnselectedDifferenceFilterer Class

[image]

SQL Data Compare API 12.0.40
ExcludeUnselectedDifferenceFilterer Class
Members See Also

Includes all differences which have not been unselected

Namespace: RedGate.SQLCompare.Engine.MigrationBlocks
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ExcludeUnselectedDifferenceFilterer _
    Implements IDifferenceFilterer
C#
public class ExcludeUnselectedDifferenceFilterer : IDifferenceFilterer
Visual C++
public ref class ExcludeUnselectedDifferenceFilterer : IDifferenceFilterer

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.MigrationBlocks..::.ExcludeUnselectedDifferenceFilterer

See Also

ExcludeUnselectedDifferenceFilterer Members
RedGate.SQLCompare.Engine.MigrationBlocks Namespace


ExcludeUnselectedDifferenceFilterer Members

[image] [image]

SQL Data Compare API 12.0.40
ExcludeUnselectedDifferenceFilterer Members
ExcludeUnselectedDifferenceFilterer Class Constructors Methods See Also

The ExcludeUnselectedDifferenceFilterer type exposes the following members.

Constructors

Name | Description
ExcludeUnselectedDifferenceFilterer |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ShouldIncludeInDeployment |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExcludeUnselectedDifferenceFilterer Class
RedGate.SQLCompare.Engine.MigrationBlocks Namespace


ExcludeUnselectedDifferenceFilterer Constructor

[image]

SQL Data Compare API 12.0.40
ExcludeUnselectedDifferenceFilterer Constructor
ExcludeUnselectedDifferenceFilterer Class See Also

Namespace: RedGate.SQLCompare.Engine.MigrationBlocks
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    differences As IEnumerable(Of IDatabaseObjectDifference(Of ITSqlObject)) _
)
C#
public ExcludeUnselectedDifferenceFilterer(
    IEnumerable<IDatabaseObjectDifference<ITSqlObject>> differences
)
Visual C++
public:
ExcludeUnselectedDifferenceFilterer(
    IEnumerable<IDatabaseObjectDifference<ITSqlObject^>^>^ differences
)

Parameters

differences
Type: IEnumerable<(Of <(IDatabaseObjectDifference<(Of <(ITSqlObject>)>)>)>)

See Also

ExcludeUnselectedDifferenceFilterer Class
RedGate.SQLCompare.Engine.MigrationBlocks Namespace


ExcludeUnselectedDifferenceFilterer Methods

[image] [image]

SQL Data Compare API 12.0.40
ExcludeUnselectedDifferenceFilterer Methods
ExcludeUnselectedDifferenceFilterer Class See Also

The ExcludeUnselectedDifferenceFilterer type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ShouldIncludeInDeployment |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExcludeUnselectedDifferenceFilterer Class
RedGate.SQLCompare.Engine.MigrationBlocks Namespace


ShouldIncludeInDeployment Method

[image]

SQL Data Compare API 12.0.40
ExcludeUnselectedDifferenceFilterer..::.ShouldIncludeInDeployment Method
ExcludeUnselectedDifferenceFilterer Class See Also

Namespace: RedGate.SQLCompare.Engine.MigrationBlocks
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function ShouldIncludeInDeployment ( _
    difference As IDatabaseObjectDifference(Of ITSqlObject) _
) As Boolean
C#
public bool ShouldIncludeInDeployment(
    IDatabaseObjectDifference<ITSqlObject> difference
)
Visual C++
public:
virtual bool ShouldIncludeInDeployment(
    IDatabaseObjectDifference<ITSqlObject^>^ difference
) sealed

Parameters

difference
Type: IDatabaseObjectDifference<(Of <(ITSqlObject>)>)

Implements

IDifferenceFiltererShouldIncludeInDeployment(IDatabaseObjectDifference<(Of <(ITSqlObject>)>))

Remarks

It's not enough to say that an object is explicitly included, because there may not be a difference. For example, I might have created a proc, created a migration which depends on that proc and then dropped that proc. The proc still needs be deployed, but there wouldn't be a difference to include. ExcludeUnselectedDifferenceFiltererTests.ADifferenceNotInTheListShouldBeDeployed covers this. As such, we're saying deploy everything except the things the user has specifically excluded.

See Also

ExcludeUnselectedDifferenceFilterer Class
RedGate.SQLCompare.Engine.MigrationBlocks Namespace


RedGate.SQLCompare.Engine.Migrations Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.Migrations Namespace

Classes

Class | Description
FileScript |
MigrationsComparer | A comparer for migrations folders.
MigrationsComparisonResult | The result of comparing two migrations folders.
MigrationScript | A migration script that exists within a MigrationScriptFolder.
MigrationScript..::.ContentsAndMetadataEqualityComparer |
MigrationScript..::.MetadataEqualityComparer |
MigrationScriptComparisonResult | The result of comparing two migration scripts.
MigrationScriptProviderExtensions |
MigrationsFolder | An object that represents a migration scripts folder on disk.
MigrationsHelper |
MigrationsLoader | A loader for migrations folders.
ReadOnlyObjectIdentifierCollection |
SqlCompareSqlSourceControlMigrationScriptHandOff |
StringScript | Represents a SQL script created from a string
UnversionedMigrationsSynchronizer | UnversionedMigrationsSynchronizer can synchronize a MigrationsComparisonResult that contains a single unversioned migrations script. Any migration scripts that have version will be ignored. Note: This will also mutate the SourceFolder
UnversionedMigrationsSynchronizerResult |
VersionedDatabaseNameFormatter |
VersionedMigrationsSynchronizer | A synchronizer for migrations folders.
VersionedSynchronizationPlan | A versioned synchronization plan to be used as input to VersionedWork.
VersionedSynchronizationPlanItem | An item within a versioned synchronization plan.
VersionedSynchronizationPlanner |
VersionedWork |
VersionInfo |

Structures

Structure | Description
ObjectIdentifier |

Interfaces

Interface | Description
IExecutable |
IExecutable<(Of <(TResult>)>) |
IMigrationScriptProvider |
IMigrationsFolder |
IScript | An abstract representation of a script.
ISOCCompareLocationProvider |
IVersionedDatabaseProvider |
IVersionedDatasource |

Enumerations

Enumeration | Description
VersionType |


FileScript Class

[image]

SQL Data Compare API 12.0.40
FileScript Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class FileScript _
    Implements IScript
C#
public class FileScript : IScript
Visual C++
public ref class FileScript : IScript

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Migrations..::.FileScript

See Also

FileScript Members
RedGate.SQLCompare.Engine.Migrations Namespace


FileScript Members

[image] [image]

SQL Data Compare API 12.0.40
FileScript Members
FileScript Class Constructors Methods Properties See Also

The FileScript type exposes the following members.

Constructors

Name | Description
FileScript |

Methods

Name | Description
ContentEquals |
CopyFrom |
CopyTo |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetExecutionBlock |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ScriptPath |

See Also

FileScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


FileScript Constructor

[image]

SQL Data Compare API 12.0.40
FileScript Constructor
FileScript Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    scriptPath As String _
)
C#
public FileScript(
    string scriptPath
)
Visual C++
public:
FileScript(
    String^ scriptPath
)

Parameters

scriptPath
Type: String

See Also

FileScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


FileScript Methods

[image] [image]

SQL Data Compare API 12.0.40
FileScript Methods
FileScript Class See Also

The FileScript type exposes the following methods.

Methods

Name | Description
ContentEquals |
CopyFrom |
CopyTo |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetExecutionBlock |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


ContentEquals Method

[image]

SQL Data Compare API 12.0.40
FileScript..::.ContentEquals Method
FileScript Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function ContentEquals ( _
    other As IScript _
) As Boolean
C#
public bool ContentEquals(
    IScript other
)
Visual C++
public:
virtual bool ContentEquals(
    IScript^ other
) sealed

Parameters

other
Type: RedGate.SQLCompare.Engine.Migrations..::.IScript

Implements

IScript..::.ContentEquals(IScript)

See Also

FileScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


CopyFrom Method

[image]

SQL Data Compare API 12.0.40
FileScript..::.CopyFrom Method
FileScript Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyFrom ( _
    sourceScript As IScript _
)
C#
public void CopyFrom(
    IScript sourceScript
)
Visual C++
public:
virtual void CopyFrom(
    IScript^ sourceScript
) sealed

Parameters

sourceScript
Type: RedGate.SQLCompare.Engine.Migrations..::.IScript

Implements

IScript..::.CopyFrom(IScript)

See Also

FileScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


CopyTo Method

[image]

SQL Data Compare API 12.0.40
FileScript..::.CopyTo Method
FileScript Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyTo ( _
    targetPath As String _
)
C#
public void CopyTo(
    string targetPath
)
Visual C++
public:
virtual void CopyTo(
    String^ targetPath
) sealed

Parameters

targetPath
Type: String

Implements

IScript..::.CopyTo(String)

See Also

FileScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


GetExecutionBlock Method

[image]

SQL Data Compare API 12.0.40
FileScript..::.GetExecutionBlock Method
FileScript Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetExecutionBlock As IExecutionBlock
C#
public IExecutionBlock GetExecutionBlock()
Visual C++
public:
virtual IExecutionBlock^ GetExecutionBlock() sealed

Implements

IScript..::.GetExecutionBlock()()()

See Also

FileScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


FileScript Properties

[image] [image]

SQL Data Compare API 12.0.40
FileScript Properties
FileScript Class See Also

The FileScript type exposes the following properties.

Properties

Name | Description
ScriptPath |

See Also

FileScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


ScriptPath Property

[image]

SQL Data Compare API 12.0.40
FileScript..::.ScriptPath Property
FileScript Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ScriptPath As String
C#
public string ScriptPath { get; }
Visual C++
public:
property String^ ScriptPath {
    String^ get ();
}

See Also

FileScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


IExecutable Interface

[image]

SQL Data Compare API 12.0.40
IExecutable Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IExecutable _
    Implements ICancellable
C#
public interface IExecutable : ICancellable
Visual C++
public interface class IExecutable : ICancellable

See Also

IExecutable Members
RedGate.SQLCompare.Engine.Migrations Namespace


IExecutable Members

[image] [image]

SQL Data Compare API 12.0.40
IExecutable Members
IExecutable Interface Methods Properties See Also

The IExecutable type exposes the following members.

Methods

Name | Description
CancelOperation | Cancels the current running operation. This will throw an instance of OperationCancelledException at the currently executing location on the executing thread (Inherited from ICancellable.)
Execute |

Properties

Name | Description
Status | Gets and sets a delegate that can be used to notify of message or percentage changes (Inherited from ICancellable.)

See Also

IExecutable Interface
RedGate.SQLCompare.Engine.Migrations Namespace


IExecutable Methods

[image] [image]

SQL Data Compare API 12.0.40
IExecutable Methods
IExecutable Interface See Also

The IExecutable type exposes the following methods.

Methods

Name | Description
CancelOperation | Cancels the current running operation. This will throw an instance of OperationCancelledException at the currently executing location on the executing thread (Inherited from ICancellable.)
Execute |

See Also

IExecutable Interface
RedGate.SQLCompare.Engine.Migrations Namespace


Execute Method

[image]

SQL Data Compare API 12.0.40
IExecutable..::.Execute Method
IExecutable Interface See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub Execute
C#
void Execute()
Visual C++
void Execute()

See Also

IExecutable Interface
RedGate.SQLCompare.Engine.Migrations Namespace


IExecutable(TResult) Generic Interface

[image]

SQL Data Compare API 12.0.40
IExecutable<(Of <(TResult>)>) Generic Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IExecutable(Of TResult) _
    Implements ICancellable
C#
public interface IExecutable<TResult> : ICancellable
Visual C++
generic<typename TResult>
public interface class IExecutable : ICancellable

Type Parameters

TResult

See Also

IExecutable<(Of <(TResult>)>) Members
RedGate.SQLCompare.Engine.Migrations Namespace


IExecutable(TResult) Members

[image] [image]

SQL Data Compare API 12.0.40
IExecutable<(Of <(TResult>)>) Members
IExecutable<(Of <(TResult>)>) Interface Methods Properties See Also

The IExecutable<(Of <(TResult>)>) type exposes the following members.

Methods

Name | Description
CancelOperation | Cancels the current running operation. This will throw an instance of OperationCancelledException at the currently executing location on the executing thread (Inherited from ICancellable.)
Execute |

Properties

Name | Description
Status | Gets and sets a delegate that can be used to notify of message or percentage changes (Inherited from ICancellable.)

See Also

IExecutable<(Of <(TResult>)>) Interface
RedGate.SQLCompare.Engine.Migrations Namespace


IExecutable(TResult) Methods

[image] [image]

SQL Data Compare API 12.0.40
IExecutable<(Of <(TResult>)>) Methods
IExecutable<(Of <(TResult>)>) Interface See Also

The IExecutable<(Of <(TResult>)>) type exposes the following methods.

Methods

Name | Description
CancelOperation | Cancels the current running operation. This will throw an instance of OperationCancelledException at the currently executing location on the executing thread (Inherited from ICancellable.)
Execute |

See Also

IExecutable<(Of <(TResult>)>) Interface
RedGate.SQLCompare.Engine.Migrations Namespace


Execute Method

[image]

SQL Data Compare API 12.0.40
IExecutable<(Of <(TResult>)>)..::.Execute Method
IExecutable<(Of <(TResult>)>) Interface See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Execute As TResult
C#
TResult Execute()
Visual C++
TResult Execute()

See Also

IExecutable<(Of <(TResult>)>) Interface
RedGate.SQLCompare.Engine.Migrations Namespace


IMigrationScriptProvider Interface

[image]

SQL Data Compare API 12.0.40
IMigrationScriptProvider Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IMigrationScriptProvider _
    Implements ICancellable
C#
public interface IMigrationScriptProvider : ICancellable
Visual C++
public interface class IMigrationScriptProvider : ICancellable

See Also

IMigrationScriptProvider Members
RedGate.SQLCompare.Engine.Migrations Namespace


IMigrationScriptProvider Members

[image] [image]

SQL Data Compare API 12.0.40
IMigrationScriptProvider Members
IMigrationScriptProvider Interface Methods Properties See Also

The IMigrationScriptProvider type exposes the following members.

Methods

Name | Description
CancelOperation | Cancels the current running operation. This will throw an instance of OperationCancelledException at the currently executing location on the executing thread (Inherited from ICancellable.)
GetMigrationScripts | Return an enumerable collection of migration scripts where the migration script is entirely between fromVersion and toVersion, inclusive. Scripts should be in ascending or descending fromVersion order, depending on whether fromVersion < toVersion or toVersion < fromVersion respectively.

Properties

Name | Description
Status | Gets and sets a delegate that can be used to notify of message or percentage changes (Inherited from ICancellable.)

See Also

IMigrationScriptProvider Interface
RedGate.SQLCompare.Engine.Migrations Namespace


IMigrationScriptProvider Methods

[image] [image]

SQL Data Compare API 12.0.40
IMigrationScriptProvider Methods
IMigrationScriptProvider Interface See Also

The IMigrationScriptProvider type exposes the following methods.

Methods

Name | Description
CancelOperation | Cancels the current running operation. This will throw an instance of OperationCancelledException at the currently executing location on the executing thread (Inherited from ICancellable.)
GetMigrationScripts | Return an enumerable collection of migration scripts where the migration script is entirely between fromVersion and toVersion, inclusive. Scripts should be in ascending or descending fromVersion order, depending on whether fromVersion < toVersion or toVersion < fromVersion respectively.

See Also

IMigrationScriptProvider Interface
RedGate.SQLCompare.Engine.Migrations Namespace


GetMigrationScripts Method

[image]

SQL Data Compare API 12.0.40
IMigrationScriptProvider..::.GetMigrationScripts Method
IMigrationScriptProvider Interface See Also

Return an enumerable collection of migration scripts where the migration script is entirely between fromVersion and toVersion, inclusive. Scripts should be in ascending or descending fromVersion order, depending on whether fromVersion < toVersion or toVersion < fromVersion respectively.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetMigrationScripts ( _
    fromVersion As VersionInfo, _
    toVersion As VersionInfo _
) As IEnumerable(Of MigrationScript)
C#
IEnumerable<MigrationScript> GetMigrationScripts(
    VersionInfo fromVersion,
    VersionInfo toVersion
)
Visual C++
IEnumerable<MigrationScript^>^ GetMigrationScripts(
    VersionInfo^ fromVersion,
    VersionInfo^ toVersion
)

Parameters

fromVersion
Type: RedGate.SQLCompare.Engine.Migrations..::.VersionInfo
The version from which to get migration scripts.
toVersion
Type: RedGate.SQLCompare.Engine.Migrations..::.VersionInfo
The version to which to get migration scripts.

Return Value

An enumerable collection of migration scripts.

See Also

IMigrationScriptProvider Interface
RedGate.SQLCompare.Engine.Migrations Namespace


IMigrationsFolder Interface

[image]

SQL Data Compare API 12.0.40
IMigrationsFolder Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IMigrationsFolder _
    Implements IMigrationScriptProvider, ICancellable
C#
public interface IMigrationsFolder : IMigrationScriptProvider,
    ICancellable
Visual C++
public interface class IMigrationsFolder : IMigrationScriptProvider,
    ICancellable

See Also

IMigrationsFolder Members
RedGate.SQLCompare.Engine.Migrations Namespace


IMigrationsFolder Members

[image] [image]

SQL Data Compare API 12.0.40
IMigrationsFolder Members
IMigrationsFolder Interface Methods Properties See Also

The IMigrationsFolder type exposes the following members.

Methods

Name | Description
AddScript |
CancelOperation | Cancels the current running operation. This will throw an instance of OperationCancelledException at the currently executing location on the executing thread (Inherited from ICancellable.)
GetMigrationScript | Overloaded.
GetMigrationScripts | Return an enumerable collection of migration scripts where the migration script is entirely between fromVersion and toVersion, inclusive. Scripts should be in ascending or descending fromVersion order, depending on whether fromVersion < toVersion or toVersion < fromVersion respectively. (Inherited from IMigrationScriptProvider.)
GetScriptFilePaths |
GetSqlFilePath |
GetXmlFilePath |
RemoveScript |

Properties

Name | Description
FolderPath |
Scripts |
Status | Gets and sets a delegate that can be used to notify of message or percentage changes (Inherited from ICancellable.)

See Also

IMigrationsFolder Interface
RedGate.SQLCompare.Engine.Migrations Namespace


IMigrationsFolder Methods

[image] [image]

SQL Data Compare API 12.0.40
IMigrationsFolder Methods
IMigrationsFolder Interface See Also

The IMigrationsFolder type exposes the following methods.

Methods

Name | Description
AddScript |
CancelOperation | Cancels the current running operation. This will throw an instance of OperationCancelledException at the currently executing location on the executing thread (Inherited from ICancellable.)
GetMigrationScript | Overloaded.
GetMigrationScripts | Return an enumerable collection of migration scripts where the migration script is entirely between fromVersion and toVersion, inclusive. Scripts should be in ascending or descending fromVersion order, depending on whether fromVersion < toVersion or toVersion < fromVersion respectively. (Inherited from IMigrationScriptProvider.)
GetScriptFilePaths |
GetSqlFilePath |
GetXmlFilePath |
RemoveScript |

See Also

IMigrationsFolder Interface
RedGate.SQLCompare.Engine.Migrations Namespace


AddScript Method

[image]

SQL Data Compare API 12.0.40
IMigrationsFolder..::.AddScript Method
IMigrationsFolder Interface See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function AddScript ( _
    fromVersion As VersionInfo, _
    toVersion As VersionInfo, _
    objectIdentifiers As IEnumerable(Of ObjectIdentifier), _
    sqlScriptPath As String, _
    description As String _
) As MigrationScript
C#
MigrationScript AddScript(
    VersionInfo fromVersion,
    VersionInfo toVersion,
    IEnumerable<ObjectIdentifier> objectIdentifiers,
    string sqlScriptPath,
    string description
)
Visual C++
MigrationScript^ AddScript(
    VersionInfo^ fromVersion,
    VersionInfo^ toVersion,
    IEnumerable<ObjectIdentifier>^ objectIdentifiers,
    String^ sqlScriptPath,
    String^ description
)

Parameters

fromVersion
Type: RedGate.SQLCompare.Engine.Migrations..::.VersionInfo
toVersion
Type: RedGate.SQLCompare.Engine.Migrations..::.VersionInfo
objectIdentifiers
Type: IEnumerable<(Of <( ObjectIdentifier >)>)
sqlScriptPath
Type: String
description
Type: String

See Also

IMigrationsFolder Interface
RedGate.SQLCompare.Engine.Migrations Namespace


GetMigrationScript Method

[image] [image]

SQL Data Compare API 12.0.40
IMigrationsFolder..::.GetMigrationScript Method
IMigrationsFolder Interface See Also

Overload List

Name | Description
GetMigrationScript(String) |
GetMigrationScript(VersionInfo, VersionInfo) |

See Also

IMigrationsFolder Interface
IMigrationsFolder Members
RedGate.SQLCompare.Engine.Migrations Namespace


GetMigrationScript Method ()

[image]

SQL Data Compare API 12.0.40
IMigrationsFolder..::.GetMigrationScript Method ()
IMigrationsFolder Interface See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetMigrationScript ( _
    name As String _
) As MigrationScript
C#
MigrationScript GetMigrationScript(
    string name
)
Visual C++
MigrationScript^ GetMigrationScript(
    String^ name
)

Parameters

name
Type: String

See Also

IMigrationsFolder Interface
GetMigrationScript Overload
RedGate.SQLCompare.Engine.Migrations Namespace


GetMigrationScript Method (VersionInfo, VersionInfo)

[image]

SQL Data Compare API 12.0.40
IMigrationsFolder..::.GetMigrationScript Method (VersionInfo, VersionInfo)
IMigrationsFolder Interface See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetMigrationScript ( _
    fromVersion As VersionInfo, _
    toVersion As VersionInfo _
) As MigrationScript
C#
MigrationScript GetMigrationScript(
    VersionInfo fromVersion,
    VersionInfo toVersion
)
Visual C++
MigrationScript^ GetMigrationScript(
    VersionInfo^ fromVersion,
    VersionInfo^ toVersion
)

Parameters

fromVersion
Type: RedGate.SQLCompare.Engine.Migrations..::.VersionInfo
toVersion
Type: RedGate.SQLCompare.Engine.Migrations..::.VersionInfo

See Also

IMigrationsFolder Interface
GetMigrationScript Overload
RedGate.SQLCompare.Engine.Migrations Namespace


GetScriptFilePaths Method

[image]

SQL Data Compare API 12.0.40
IMigrationsFolder..::.GetScriptFilePaths Method
IMigrationsFolder Interface See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetScriptFilePaths ( _
    script As MigrationScript _
) As IEnumerable(Of String)
C#
IEnumerable<string> GetScriptFilePaths(
    MigrationScript script
)
Visual C++
IEnumerable<String^>^ GetScriptFilePaths(
    MigrationScript^ script
)

Parameters

script
Type: RedGate.SQLCompare.Engine.Migrations..::.MigrationScript

See Also

IMigrationsFolder Interface
RedGate.SQLCompare.Engine.Migrations Namespace


GetSqlFilePath Method

[image]

SQL Data Compare API 12.0.40
IMigrationsFolder..::.GetSqlFilePath Method
IMigrationsFolder Interface See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetSqlFilePath ( _
    scriptName As String _
) As String
C#
string GetSqlFilePath(
    string scriptName
)
Visual C++
String^ GetSqlFilePath(
    String^ scriptName
)

Parameters

scriptName
Type: String

See Also

IMigrationsFolder Interface
RedGate.SQLCompare.Engine.Migrations Namespace


GetXmlFilePath Method

[image]

SQL Data Compare API 12.0.40
IMigrationsFolder..::.GetXmlFilePath Method
IMigrationsFolder Interface See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetXmlFilePath ( _
    scriptName As String _
) As String
C#
string GetXmlFilePath(
    string scriptName
)
Visual C++
String^ GetXmlFilePath(
    String^ scriptName
)

Parameters

scriptName
Type: String

See Also

IMigrationsFolder Interface
RedGate.SQLCompare.Engine.Migrations Namespace


RemoveScript Method

[image]

SQL Data Compare API 12.0.40
IMigrationsFolder..::.RemoveScript Method
IMigrationsFolder Interface See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub RemoveScript ( _
    script As MigrationScript _
)
C#
void RemoveScript(
    MigrationScript script
)
Visual C++
void RemoveScript(
    MigrationScript^ script
)

Parameters

script
Type: RedGate.SQLCompare.Engine.Migrations..::.MigrationScript

See Also

IMigrationsFolder Interface
RedGate.SQLCompare.Engine.Migrations Namespace


IMigrationsFolder Properties

[image] [image]

SQL Data Compare API 12.0.40
IMigrationsFolder Properties
IMigrationsFolder Interface See Also

The IMigrationsFolder type exposes the following properties.

Properties

Name | Description
FolderPath |
Scripts |
Status | Gets and sets a delegate that can be used to notify of message or percentage changes (Inherited from ICancellable.)

See Also

IMigrationsFolder Interface
RedGate.SQLCompare.Engine.Migrations Namespace


FolderPath Property

[image]

SQL Data Compare API 12.0.40
IMigrationsFolder..::.FolderPath Property
IMigrationsFolder Interface See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property FolderPath As String
C#
string FolderPath { get; }
Visual C++
property String^ FolderPath {
    String^ get ();
}

See Also

IMigrationsFolder Interface
RedGate.SQLCompare.Engine.Migrations Namespace


Scripts Property

[image]

SQL Data Compare API 12.0.40
IMigrationsFolder..::.Scripts Property
IMigrationsFolder Interface See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Scripts As ReadOnlyCollection(Of MigrationScript)
C#
ReadOnlyCollection<MigrationScript> Scripts { get; }
Visual C++
property ReadOnlyCollection<MigrationScript^>^ Scripts {
    ReadOnlyCollection<MigrationScript^>^ get ();
}

See Also

IMigrationsFolder Interface
RedGate.SQLCompare.Engine.Migrations Namespace


IScript Interface

[image]

SQL Data Compare API 12.0.40
IScript Interface
Members See Also

An abstract representation of a script.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IScript
C#
public interface IScript
Visual C++
public interface class IScript

See Also

IScript Members
RedGate.SQLCompare.Engine.Migrations Namespace


IScript Members

[image] [image]

SQL Data Compare API 12.0.40
IScript Members
IScript Interface Methods See Also

The IScript type exposes the following members.

Methods

Name | Description
ContentEquals | Returns whether the content of one script file is equal to that of another.
CopyFrom | Copies another script over this one.
CopyTo | Copy this script to a file on disk.
GetExecutionBlock | Return an execution block for the script. This operation may be non-trivial.

See Also

IScript Interface
RedGate.SQLCompare.Engine.Migrations Namespace


IScript Methods

[image] [image]

SQL Data Compare API 12.0.40
IScript Methods
IScript Interface See Also

The IScript type exposes the following methods.

Methods

Name | Description
ContentEquals | Returns whether the content of one script file is equal to that of another.
CopyFrom | Copies another script over this one.
CopyTo | Copy this script to a file on disk.
GetExecutionBlock | Return an execution block for the script. This operation may be non-trivial.

See Also

IScript Interface
RedGate.SQLCompare.Engine.Migrations Namespace


ContentEquals Method

[image]

SQL Data Compare API 12.0.40
IScript..::.ContentEquals Method
IScript Interface See Also

Returns whether the content of one script file is equal to that of another.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function ContentEquals ( _
    other As IScript _
) As Boolean
C#
bool ContentEquals(
    IScript other
)
Visual C++
bool ContentEquals(
    IScript^ other
)

Parameters

other
Type: RedGate.SQLCompare.Engine.Migrations..::.IScript
The other script to compare against.

See Also

IScript Interface
RedGate.SQLCompare.Engine.Migrations Namespace


CopyFrom Method

[image]

SQL Data Compare API 12.0.40
IScript..::.CopyFrom Method
IScript Interface See Also

Copies another script over this one.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub CopyFrom ( _
    sourceScript As IScript _
)
C#
void CopyFrom(
    IScript sourceScript
)
Visual C++
void CopyFrom(
    IScript^ sourceScript
)

Parameters

sourceScript
Type: RedGate.SQLCompare.Engine.Migrations..::.IScript
The script to copy from.

See Also

IScript Interface
RedGate.SQLCompare.Engine.Migrations Namespace


CopyTo Method

[image]

SQL Data Compare API 12.0.40
IScript..::.CopyTo Method
IScript Interface See Also

Copy this script to a file on disk.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub CopyTo ( _
    targetPath As String _
)
C#
void CopyTo(
    string targetPath
)
Visual C++
void CopyTo(
    String^ targetPath
)

Parameters

targetPath
Type: String
The path of the file to copy to.

See Also

IScript Interface
RedGate.SQLCompare.Engine.Migrations Namespace


GetExecutionBlock Method

[image]

SQL Data Compare API 12.0.40
IScript..::.GetExecutionBlock Method
IScript Interface See Also

Return an execution block for the script. This operation may be non-trivial.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetExecutionBlock As IExecutionBlock
C#
IExecutionBlock GetExecutionBlock()
Visual C++
IExecutionBlock^ GetExecutionBlock()

See Also

IScript Interface
RedGate.SQLCompare.Engine.Migrations Namespace


ISOCCompareLocationProvider Interface

[image]

SQL Data Compare API 12.0.40
ISOCCompareLocationProvider Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISOCCompareLocationProvider
C#
public interface ISOCCompareLocationProvider
Visual C++
public interface class ISOCCompareLocationProvider

See Also

ISOCCompareLocationProvider Members
RedGate.SQLCompare.Engine.Migrations Namespace


ISOCCompareLocationProvider Members

[image] [image]

SQL Data Compare API 12.0.40
ISOCCompareLocationProvider Members
ISOCCompareLocationProvider Interface Methods See Also

The ISOCCompareLocationProvider type exposes the following members.

Methods

Name | Description
GetSOCCompareLocation |
TryGetSOCCompareLocation |

See Also

ISOCCompareLocationProvider Interface
RedGate.SQLCompare.Engine.Migrations Namespace


ISOCCompareLocationProvider Methods

[image] [image]

SQL Data Compare API 12.0.40
ISOCCompareLocationProvider Methods
ISOCCompareLocationProvider Interface See Also

The ISOCCompareLocationProvider type exposes the following methods.

Methods

Name | Description
GetSOCCompareLocation |
TryGetSOCCompareLocation |

See Also

ISOCCompareLocationProvider Interface
RedGate.SQLCompare.Engine.Migrations Namespace


GetSOCCompareLocation Method

[image]

SQL Data Compare API 12.0.40
ISOCCompareLocationProvider..::.GetSOCCompareLocation Method
ISOCCompareLocationProvider Interface See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetSOCCompareLocation ( _
    xml As String _
) As ISOCCompareLocation
C#
ISOCCompareLocation GetSOCCompareLocation(
    string xml
)
Visual C++
ISOCCompareLocation^ GetSOCCompareLocation(
    String^ xml
)

Parameters

xml
Type: String

See Also

ISOCCompareLocationProvider Interface
RedGate.SQLCompare.Engine.Migrations Namespace


TryGetSOCCompareLocation Method

[image]

SQL Data Compare API 12.0.40
ISOCCompareLocationProvider..::.TryGetSOCCompareLocation Method
ISOCCompareLocationProvider Interface See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function TryGetSOCCompareLocation ( _
    xml As String, _
    <OutAttribute> ByRef location As ISOCCompareLocation _
) As Boolean
C#
bool TryGetSOCCompareLocation(
    string xml,
    out ISOCCompareLocation location
)
Visual C++
bool TryGetSOCCompareLocation(
    String^ xml,
    [OutAttribute] ISOCCompareLocation^% location
)

Parameters

xml
Type: String
location
Type: ISOCCompareLocation%

See Also

ISOCCompareLocationProvider Interface
RedGate.SQLCompare.Engine.Migrations Namespace


IVersionedDatabaseProvider Interface

[image]

SQL Data Compare API 12.0.40
IVersionedDatabaseProvider Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IVersionedDatabaseProvider _
    Implements ICancellable
C#
public interface IVersionedDatabaseProvider : ICancellable
Visual C++
public interface class IVersionedDatabaseProvider : ICancellable

See Also

IVersionedDatabaseProvider Members
RedGate.SQLCompare.Engine.Migrations Namespace


IVersionedDatabaseProvider Members

[image] [image]

SQL Data Compare API 12.0.40
IVersionedDatabaseProvider Members
IVersionedDatabaseProvider Interface Methods Properties See Also

The IVersionedDatabaseProvider type exposes the following members.

Methods

Name | Description
CancelOperation | Cancels the current running operation. This will throw an instance of OperationCancelledException at the currently executing location on the executing thread (Inherited from ICancellable.)
GetDatabase | Return a database for the specified version. The Database.Version property should be set to the value passed in.

Properties

Name | Description
Status | Gets and sets a delegate that can be used to notify of message or percentage changes (Inherited from ICancellable.)

See Also

IVersionedDatabaseProvider Interface
RedGate.SQLCompare.Engine.Migrations Namespace


IVersionedDatabaseProvider Methods

[image] [image]

SQL Data Compare API 12.0.40
IVersionedDatabaseProvider Methods
IVersionedDatabaseProvider Interface See Also

The IVersionedDatabaseProvider type exposes the following methods.

Methods

Name | Description
CancelOperation | Cancels the current running operation. This will throw an instance of OperationCancelledException at the currently executing location on the executing thread (Inherited from ICancellable.)
GetDatabase | Return a database for the specified version. The Database.Version property should be set to the value passed in.

See Also

IVersionedDatabaseProvider Interface
RedGate.SQLCompare.Engine.Migrations Namespace


GetDatabase Method

[image]

SQL Data Compare API 12.0.40
IVersionedDatabaseProvider..::.GetDatabase Method
IVersionedDatabaseProvider Interface See Also

Return a database for the specified version. The Database.Version property should be set to the value passed in.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetDatabase ( _
    version As Long, _
    options As Options _
) As Database
C#
Database GetDatabase(
    long version,
    Options options
)
Visual C++
Database^ GetDatabase(
    long long version,
    Options options
)

Parameters

version
Type: Int64
The version to be provided.
options
Type: RedGate.SQLCompare.Engine..::.Options
The options to use when registering the database.

Return Value

A database for the specified version.

See Also

IVersionedDatabaseProvider Interface
RedGate.SQLCompare.Engine.Migrations Namespace


IVersionedDatasource Interface

[image]

SQL Data Compare API 12.0.40
IVersionedDatasource Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IVersionedDatasource
C#
public interface IVersionedDatasource
Visual C++
public interface class IVersionedDatasource

See Also

IVersionedDatasource Members
RedGate.SQLCompare.Engine.Migrations Namespace


IVersionedDatasource Members

[image] [image]

SQL Data Compare API 12.0.40
IVersionedDatasource Members
IVersionedDatasource Interface Methods Properties See Also

The IVersionedDatasource type exposes the following members.

Methods

Name | Description
Clone |

Properties

Name | Description
MigrationsFolderLocation |
ScriptFolderLocation |
SpecificVersion |
VersionType |

See Also

IVersionedDatasource Interface
RedGate.SQLCompare.Engine.Migrations Namespace


IVersionedDatasource Methods

[image] [image]

SQL Data Compare API 12.0.40
IVersionedDatasource Methods
IVersionedDatasource Interface See Also

The IVersionedDatasource type exposes the following methods.

Methods

Name | Description
Clone |

See Also

IVersionedDatasource Interface
RedGate.SQLCompare.Engine.Migrations Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
IVersionedDatasource..::.Clone Method
IVersionedDatasource Interface See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Clone As IDataSource
C#
IDataSource Clone()
Visual C++
IDataSource^ Clone()

See Also

IVersionedDatasource Interface
RedGate.SQLCompare.Engine.Migrations Namespace


IVersionedDatasource Properties

[image] [image]

SQL Data Compare API 12.0.40
IVersionedDatasource Properties
IVersionedDatasource Interface See Also

The IVersionedDatasource type exposes the following properties.

Properties

Name | Description
MigrationsFolderLocation |
ScriptFolderLocation |
SpecificVersion |
VersionType |

See Also

IVersionedDatasource Interface
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationsFolderLocation Property

[image]

SQL Data Compare API 12.0.40
IVersionedDatasource..::.MigrationsFolderLocation Property
IVersionedDatasource Interface See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property MigrationsFolderLocation As ISOCCompareLocation
C#
ISOCCompareLocation MigrationsFolderLocation { get; set; }
Visual C++
property ISOCCompareLocation^ MigrationsFolderLocation {
    ISOCCompareLocation^ get ();
    void set (ISOCCompareLocation^ value);
}

See Also

IVersionedDatasource Interface
RedGate.SQLCompare.Engine.Migrations Namespace


ScriptFolderLocation Property

[image]

SQL Data Compare API 12.0.40
IVersionedDatasource..::.ScriptFolderLocation Property
IVersionedDatasource Interface See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property ScriptFolderLocation As ISOCCompareLocation
C#
ISOCCompareLocation ScriptFolderLocation { get; set; }
Visual C++
property ISOCCompareLocation^ ScriptFolderLocation {
    ISOCCompareLocation^ get ();
    void set (ISOCCompareLocation^ value);
}

See Also

IVersionedDatasource Interface
RedGate.SQLCompare.Engine.Migrations Namespace


SpecificVersion Property

[image]

SQL Data Compare API 12.0.40
IVersionedDatasource..::.SpecificVersion Property
IVersionedDatasource Interface See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property SpecificVersion As String
C#
string SpecificVersion { get; set; }
Visual C++
property String^ SpecificVersion {
    String^ get ();
    void set (String^ value);
}

See Also

IVersionedDatasource Interface
RedGate.SQLCompare.Engine.Migrations Namespace


VersionType Property

[image]

SQL Data Compare API 12.0.40
IVersionedDatasource..::.VersionType Property
IVersionedDatasource Interface See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property VersionType As VersionType
C#
VersionType VersionType { get; set; }
Visual C++
property VersionType VersionType {
    VersionType get ();
    void set (VersionType value);
}

See Also

IVersionedDatasource Interface
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationsComparer Class

[image]

SQL Data Compare API 12.0.40
MigrationsComparer Class
Members See Also

A comparer for migrations folders.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class MigrationsComparer _
    Implements IExecutable(Of MigrationsComparisonResult), ICancellable
C#
public class MigrationsComparer : IExecutable<MigrationsComparisonResult>,
    ICancellable
Visual C++
public ref class MigrationsComparer : IExecutable<MigrationsComparisonResult^>,
    ICancellable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Migrations..::.MigrationsComparer

See Also

MigrationsComparer Members
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationsComparer Members

[image] [image]

SQL Data Compare API 12.0.40
MigrationsComparer Members
MigrationsComparer Class Constructors Methods Properties See Also

The MigrationsComparer type exposes the following members.

Constructors

Name | Description
MigrationsComparer | Creates a migrations folder comparer.

Methods

Name | Description
CancelOperation | Cancels the comparison operation.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Execute the comparison. Returns the comparison result, or null if cancelled. Can only be called once.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Status | The StatusEventHandler used to update progress information.

See Also

MigrationsComparer Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationsComparer Constructor

[image]

SQL Data Compare API 12.0.40
MigrationsComparer Constructor
MigrationsComparer Class See Also

Creates a migrations folder comparer.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    sourceFolder As IMigrationsFolder, _
    targetFolder As IMigrationsFolder _
)
C#
public MigrationsComparer(
    IMigrationsFolder sourceFolder,
    IMigrationsFolder targetFolder
)
Visual C++
public:
MigrationsComparer(
    IMigrationsFolder^ sourceFolder,
    IMigrationsFolder^ targetFolder
)

Parameters

sourceFolder
Type: RedGate.SQLCompare.Engine.Migrations..::.IMigrationsFolder
The source migrations folder in the comparison.
targetFolder
Type: RedGate.SQLCompare.Engine.Migrations..::.IMigrationsFolder
The target migrations folder in the comparison.

See Also

MigrationsComparer Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationsComparer Methods

[image] [image]

SQL Data Compare API 12.0.40
MigrationsComparer Methods
MigrationsComparer Class See Also

The MigrationsComparer type exposes the following methods.

Methods

Name | Description
CancelOperation | Cancels the comparison operation.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Execute the comparison. Returns the comparison result, or null if cancelled. Can only be called once.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MigrationsComparer Class
RedGate.SQLCompare.Engine.Migrations Namespace


CancelOperation Method

[image]

SQL Data Compare API 12.0.40
MigrationsComparer..::.CancelOperation Method
MigrationsComparer Class See Also

Cancels the comparison operation.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelOperation
C#
public void CancelOperation()
Visual C++
public:
virtual void CancelOperation() sealed

Implements

ICancellable..::.CancelOperation()()()

See Also

MigrationsComparer Class
RedGate.SQLCompare.Engine.Migrations Namespace


Execute Method

[image]

SQL Data Compare API 12.0.40
MigrationsComparer..::.Execute Method
MigrationsComparer Class See Also

Execute the comparison. Returns the comparison result, or null if cancelled. Can only be called once.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Execute As MigrationsComparisonResult
C#
public MigrationsComparisonResult Execute()
Visual C++
public:
virtual MigrationsComparisonResult^ Execute() sealed

Implements

IExecutable<(Of <(TResult>)>)..::.Execute()()()

See Also

MigrationsComparer Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationsComparer Properties

[image] [image]

SQL Data Compare API 12.0.40
MigrationsComparer Properties
MigrationsComparer Class See Also

The MigrationsComparer type exposes the following properties.

Properties

Name | Description
Status | The StatusEventHandler used to update progress information.

See Also

MigrationsComparer Class
RedGate.SQLCompare.Engine.Migrations Namespace


Status Property

[image]

SQL Data Compare API 12.0.40
MigrationsComparer..::.Status Property
MigrationsComparer Class See Also

The StatusEventHandler used to update progress information.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

See Also

MigrationsComparer Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationsComparisonResult Class

[image]

SQL Data Compare API 12.0.40
MigrationsComparisonResult Class
Members See Also

The result of comparing two migrations folders.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class MigrationsComparisonResult
C#
public class MigrationsComparisonResult
Visual C++
public ref class MigrationsComparisonResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Migrations..::.MigrationsComparisonResult

See Also

MigrationsComparisonResult Members
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationsComparisonResult Members

[image] [image]

SQL Data Compare API 12.0.40
MigrationsComparisonResult Members
MigrationsComparisonResult Class Methods Properties See Also

The MigrationsComparisonResult type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ScriptResults |
SourceFolder |
TargetFolder |

See Also

MigrationsComparisonResult Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationsComparisonResult Properties

[image] [image]

SQL Data Compare API 12.0.40
MigrationsComparisonResult Properties
MigrationsComparisonResult Class See Also

The MigrationsComparisonResult type exposes the following properties.

Properties

Name | Description
ScriptResults |
SourceFolder |
TargetFolder |

See Also

MigrationsComparisonResult Class
RedGate.SQLCompare.Engine.Migrations Namespace


ScriptResults Property

[image]

SQL Data Compare API 12.0.40
MigrationsComparisonResult..::.ScriptResults Property
MigrationsComparisonResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ScriptResults As ReadOnlyCollection(Of MigrationScriptComparisonResult)
C#
public ReadOnlyCollection<MigrationScriptComparisonResult> ScriptResults { get; }
Visual C++
public:
property ReadOnlyCollection<MigrationScriptComparisonResult^>^ ScriptResults {
    ReadOnlyCollection<MigrationScriptComparisonResult^>^ get ();
}

See Also

MigrationsComparisonResult Class
RedGate.SQLCompare.Engine.Migrations Namespace


SourceFolder Property

[image]

SQL Data Compare API 12.0.40
MigrationsComparisonResult..::.SourceFolder Property
MigrationsComparisonResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SourceFolder As IMigrationsFolder
C#
public IMigrationsFolder SourceFolder { get; }
Visual C++
public:
property IMigrationsFolder^ SourceFolder {
    IMigrationsFolder^ get ();
}

See Also

MigrationsComparisonResult Class
RedGate.SQLCompare.Engine.Migrations Namespace


TargetFolder Property

[image]

SQL Data Compare API 12.0.40
MigrationsComparisonResult..::.TargetFolder Property
MigrationsComparisonResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetFolder As IMigrationsFolder
C#
public IMigrationsFolder TargetFolder { get; }
Visual C++
public:
property IMigrationsFolder^ TargetFolder {
    IMigrationsFolder^ get ();
}

See Also

MigrationsComparisonResult Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationScript Class

[image]

SQL Data Compare API 12.0.40
MigrationScript Class
Members See Also

A migration script that exists within a MigrationScriptFolder.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class MigrationScript
C#
public class MigrationScript
Visual C++
public ref class MigrationScript

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Migrations..::.MigrationScript

See Also

MigrationScript Members
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationScript Members

[image] [image]

SQL Data Compare API 12.0.40
MigrationScript Members
MigrationScript Class Constructors Methods Properties Explicit Interface Implementations See Also

The MigrationScript type exposes the following members.

Constructors

Name | Description
MigrationScript | Overloaded.

Methods

Name | Description
AddTypes | Overloaded.
ContentEquals | Returns whether the content of one migration script is equal to that of another, including name, versions, object identifiers and sql script.
CopySqlTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetExecutionBlock | Returns the associated execution block. This operation may be non-trivial.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PostDeserializeFixup |
StartsAndEndsInOneOf | Test a migration script to check whether it either starts and ends in one of several script folder locations.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name Description
Description
FromVersion
The version from which the migration script is used.
Name
The name of the migration script.
ObjectIdentifiers
A readonly collection of object identifiers, representing all objects involved in the migration script.
SQLScript
ToVersion
The version to which the migration script is used.
VersionDefined
Returns

Field Value

false if it's an unversioned migration script, e.g. in SOC before it's committed for the first time.

Explicit Interface Implementations

Name | Description
Version |

See Also

MigrationScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationScript Constructor

[image] [image]

SQL Data Compare API 12.0.40
MigrationScript Constructor
MigrationScript Class See Also

Overload List

Name | Description
MigrationScript()()() |
MigrationScript(String) |

See Also

MigrationScript Class
MigrationScript Members
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationScript Constructor

[image]

SQL Data Compare API 12.0.40
MigrationScript Constructor
MigrationScript Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MigrationScript()
Visual C++
public:
MigrationScript()

See Also

MigrationScript Class
MigrationScript Overload
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationScript Constructor ()

[image]

SQL Data Compare API 12.0.40
MigrationScript Constructor ()
MigrationScript Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    description As String _
)
C#
public MigrationScript(
    string description
)
Visual C++
public:
MigrationScript(
    String^ description
)

Parameters

description
Type: String

See Also

MigrationScript Class
MigrationScript Overload
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationScript Methods

[image] [image]

SQL Data Compare API 12.0.40
MigrationScript Methods
MigrationScript Class See Also

The MigrationScript type exposes the following methods.

Methods

Name | Description
AddTypes | Overloaded.
ContentEquals | Returns whether the content of one migration script is equal to that of another, including name, versions, object identifiers and sql script.
CopySqlTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetExecutionBlock | Returns the associated execution block. This operation may be non-trivial.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PostDeserializeFixup |
StartsAndEndsInOneOf | Test a migration script to check whether it either starts and ends in one of several script folder locations.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MigrationScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


AddTypes Method

[image] [image]

SQL Data Compare API 12.0.40
MigrationScript..::.AddTypes Method
MigrationScript Class See Also

Overload List

Name | Description
AddTypes(ISerializeFormatter) |
AddTypes(XMLSerializeFormatter) |

See Also

MigrationScript Class
MigrationScript Members
RedGate.SQLCompare.Engine.Migrations Namespace


AddTypes Method ()

[image]

SQL Data Compare API 12.0.40
MigrationScript..::.AddTypes Method ()
MigrationScript Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AddTypes ( _
    formatter As ISerializeFormatter _
)
C#
public static void AddTypes(
    ISerializeFormatter formatter
)
Visual C++
public:
static void AddTypes(
    ISerializeFormatter^ formatter
)

Parameters

formatter
Type: ISerializeFormatter

See Also

MigrationScript Class
AddTypes Overload
RedGate.SQLCompare.Engine.Migrations Namespace


AddTypes Method ()

[image]

SQL Data Compare API 12.0.40
MigrationScript..::.AddTypes Method ()
MigrationScript Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AddTypes ( _
    formatter As XMLSerializeFormatter _
)
C#
public static void AddTypes(
    XMLSerializeFormatter formatter
)
Visual C++
public:
static void AddTypes(
    XMLSerializeFormatter^ formatter
)

Parameters

formatter
Type: XMLSerializeFormatter

See Also

MigrationScript Class
AddTypes Overload
RedGate.SQLCompare.Engine.Migrations Namespace


ContentEquals Method

[image]

SQL Data Compare API 12.0.40
MigrationScript..::.ContentEquals Method
MigrationScript Class See Also

Returns whether the content of one migration script is equal to that of another, including name, versions, object identifiers and sql script.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function ContentEquals ( _
    other As MigrationScript _
) As Boolean
C#
public bool ContentEquals(
    MigrationScript other
)
Visual C++
public:
bool ContentEquals(
    MigrationScript^ other
)

Parameters

other
Type: RedGate.SQLCompare.Engine.Migrations..::.MigrationScript
The other migration script to compare with.

See Also

MigrationScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


CopySqlTo Method

[image] [image]

SQL Data Compare API 12.0.40
MigrationScript..::.CopySqlTo Method
MigrationScript Class See Also

Overload List

Name | Description
CopySqlTo(String) | Copies the sql to a file.
CopySqlTo(MigrationScript) | Copies the sql to another migration script.

See Also

MigrationScript Class
MigrationScript Members
RedGate.SQLCompare.Engine.Migrations Namespace


CopySqlTo Method ()

[image]

SQL Data Compare API 12.0.40
MigrationScript..::.CopySqlTo Method ()
MigrationScript Class See Also

Copies the sql to a file.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopySqlTo ( _
    targetPath As String _
)
C#
public void CopySqlTo(
    string targetPath
)
Visual C++
public:
void CopySqlTo(
    String^ targetPath
)

Parameters

targetPath
Type: String
The path to copy to.

See Also

MigrationScript Class
CopySqlTo Overload
RedGate.SQLCompare.Engine.Migrations Namespace


CopySqlTo Method (MigrationScript)

[image]

SQL Data Compare API 12.0.40
MigrationScript..::.CopySqlTo Method (MigrationScript)
MigrationScript Class See Also

Copies the sql to another migration script.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopySqlTo ( _
    targetScript As MigrationScript _
)
C#
public void CopySqlTo(
    MigrationScript targetScript
)
Visual C++
public:
void CopySqlTo(
    MigrationScript^ targetScript
)

Parameters

targetScript
Type: RedGate.SQLCompare.Engine.Migrations..::.MigrationScript
The target migration script to copy to.

See Also

MigrationScript Class
CopySqlTo Overload
RedGate.SQLCompare.Engine.Migrations Namespace


GetExecutionBlock Method

[image]

SQL Data Compare API 12.0.40
MigrationScript..::.GetExecutionBlock Method
MigrationScript Class See Also

Returns the associated execution block. This operation may be non-trivial.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetExecutionBlock As IExecutionBlock
C#
public IExecutionBlock GetExecutionBlock()
Visual C++
public:
IExecutionBlock^ GetExecutionBlock()

See Also

MigrationScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


PostDeserializeFixup Method

[image]

SQL Data Compare API 12.0.40
MigrationScript..::.PostDeserializeFixup Method
MigrationScript Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PostDeserializeFixup ( _
    locationProvider As ISOCCompareLocationProvider _
)
C#
public void PostDeserializeFixup(
    ISOCCompareLocationProvider locationProvider
)
Visual C++
public:
void PostDeserializeFixup(
    ISOCCompareLocationProvider^ locationProvider
)

Parameters

locationProvider
Type: RedGate.SQLCompare.Engine.Migrations..::.ISOCCompareLocationProvider

See Also

MigrationScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


StartsAndEndsInOneOf Method

[image]

SQL Data Compare API 12.0.40
MigrationScript..::.StartsAndEndsInOneOf Method
MigrationScript Class See Also

Test a migration script to check whether it either starts and ends in one of several script folder locations.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function StartsAndEndsInOneOf ( _
    socCompareLocations As IEnumerable(Of ISOCCompareLocation) _
) As Boolean
C#
public bool StartsAndEndsInOneOf(
    IEnumerable<ISOCCompareLocation> socCompareLocations
)
Visual C++
public:
bool StartsAndEndsInOneOf(
    IEnumerable<ISOCCompareLocation^>^ socCompareLocations
)

Parameters

socCompareLocations
Type: IEnumerable<(Of <(ISOCCompareLocation>)>)
A collection of script folder locations

Return Value

true iff the migration script starts and ends in one of the script folder locations contained in socCompareLocations

See Also

MigrationScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationScript Properties

[image] [image]

SQL Data Compare API 12.0.40
MigrationScript Properties
MigrationScript Class See Also

The MigrationScript type exposes the following properties.

Properties

Name Description
Description
FromVersion
The version from which the migration script is used.
Name
The name of the migration script.
ObjectIdentifiers
A readonly collection of object identifiers, representing all objects involved in the migration script.
SQLScript
ToVersion
The version to which the migration script is used.
VersionDefined
Returns

Field Value

false if it's an unversioned migration script, e.g. in SOC before it's committed for the first time.

Explicit Interface Implementations

Name | Description
Version |

See Also

MigrationScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


Description Property

[image]

SQL Data Compare API 12.0.40
MigrationScript..::.Description Property
MigrationScript Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; private set; }
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

MigrationScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


FromVersion Property

[image]

SQL Data Compare API 12.0.40
MigrationScript..::.FromVersion Property
MigrationScript Class See Also

The version from which the migration script is used.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FromVersion As VersionInfo
C#
public VersionInfo FromVersion { get; private set; }
Visual C++
public:
property VersionInfo^ FromVersion {
    VersionInfo^ get ();
    void set (VersionInfo^ value);
}

See Also

MigrationScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
MigrationScript..::.Name Property
MigrationScript Class See Also

The name of the migration script.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; private set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

MigrationScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


ObjectIdentifiers Property

[image]

SQL Data Compare API 12.0.40
MigrationScript..::.ObjectIdentifiers Property
MigrationScript Class See Also

A readonly collection of object identifiers, representing all objects involved in the migration script.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ObjectIdentifiers As ReadOnlyCollection(Of ObjectIdentifier)
C#
public ReadOnlyCollection<ObjectIdentifier> ObjectIdentifiers { get; }
Visual C++
public:
property ReadOnlyCollection<ObjectIdentifier>^ ObjectIdentifiers {
    ReadOnlyCollection<ObjectIdentifier>^ get ();
}

See Also

MigrationScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


SQLScript Property

[image]

SQL Data Compare API 12.0.40
MigrationScript..::.SQLScript Property
MigrationScript Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SQLScript As IScript
C#
public IScript SQLScript { get; set; }
Visual C++
public:
property IScript^ SQLScript {
    IScript^ get ();
    void set (IScript^ value);
}

See Also

MigrationScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


ToVersion Property

[image]

SQL Data Compare API 12.0.40
MigrationScript..::.ToVersion Property
MigrationScript Class See Also

The version to which the migration script is used.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ToVersion As VersionInfo
C#
public VersionInfo ToVersion { get; private set; }
Visual C++
public:
property VersionInfo^ ToVersion {
    VersionInfo^ get ();
    void set (VersionInfo^ value);
}

See Also

MigrationScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


Property

[image]

SQL Data Compare API 12.0.40
MigrationScript..::. Property
MigrationScript Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private ReadOnly Property Version As Integer
C#
private int Version { get; }
Visual C++
private:
virtual property int Version {
    int get () sealed;
}

See Also

MigrationScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


VersionDefined Property

[image]

SQL Data Compare API 12.0.40
MigrationScript..::.VersionDefined Property
MigrationScript Class See Also

Returns

Field Value

false if it's an unversioned migration script, e.g. in SOC before it's committed for the first time.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VersionDefined As Boolean
C#
public bool VersionDefined { get; }
Visual C++
public:
property bool VersionDefined {
    bool get ();
}

See Also

MigrationScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationScript.ContentsAndMetadataEqualityComparer Class

[image]

SQL Data Compare API 12.0.40
MigrationScript..::.ContentsAndMetadataEqualityComparer Class
MigrationScript Class Members See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ContentsAndMetadataEqualityComparer _
    Implements IEqualityComparer(Of MigrationScript)
C#
public class ContentsAndMetadataEqualityComparer : IEqualityComparer<MigrationScript>
Visual C++
public ref class ContentsAndMetadataEqualityComparer : IEqualityComparer<MigrationScript^>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Migrations..::.MigrationScript..::.ContentsAndMetadataEqualityComparer

See Also

MigrationScript..::.ContentsAndMetadataEqualityComparer Members
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationScript.ContentsAndMetadataEqualityComparer Members

[image] [image]

SQL Data Compare API 12.0.40
MigrationScript..::.ContentsAndMetadataEqualityComparer Members
MigrationScript..::.ContentsAndMetadataEqualityComparer Class Constructors Methods See Also

A migration script that exists within a MigrationScriptFolder.

The MigrationScript..::.ContentsAndMetadataEqualityComparer type exposes the following members.

Constructors

Name | Description
MigrationScript..::.ContentsAndMetadataEqualityComparer |

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MigrationScript..::.ContentsAndMetadataEqualityComparer Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationScript.ContentsAndMetadataEqualityComparer Constructor

[image]

SQL Data Compare API 12.0.40
MigrationScript..::.ContentsAndMetadataEqualityComparer Constructor
MigrationScript..::.ContentsAndMetadataEqualityComparer Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ContentsAndMetadataEqualityComparer()
Visual C++
public:
ContentsAndMetadataEqualityComparer()

See Also

MigrationScript..::.ContentsAndMetadataEqualityComparer Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationScript.ContentsAndMetadataEqualityComparer Methods

[image] [image]

SQL Data Compare API 12.0.40
MigrationScript..::.ContentsAndMetadataEqualityComparer Methods
MigrationScript..::.ContentsAndMetadataEqualityComparer Class See Also

The MigrationScript..::.ContentsAndMetadataEqualityComparer type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MigrationScript..::.ContentsAndMetadataEqualityComparer Class
RedGate.SQLCompare.Engine.Migrations Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
MigrationScript..::.ContentsAndMetadataEqualityComparer..::.Equals Method
MigrationScript..::.ContentsAndMetadataEqualityComparer Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(MigrationScript, MigrationScript) |

See Also

MigrationScript..::.ContentsAndMetadataEqualityComparer Class
MigrationScript..::.ContentsAndMetadataEqualityComparer Members
RedGate.SQLCompare.Engine.Migrations Namespace


Equals Method (MigrationScript, MigrationScript)

[image]

SQL Data Compare API 12.0.40
MigrationScript..::.ContentsAndMetadataEqualityComparer..::.Equals Method (MigrationScript, MigrationScript)
MigrationScript..::.ContentsAndMetadataEqualityComparer Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    x As MigrationScript, _
    y As MigrationScript _
) As Boolean
C#
public bool Equals(
    MigrationScript x,
    MigrationScript y
)
Visual C++
public:
virtual bool Equals(
    MigrationScript^ x,
    MigrationScript^ y
) sealed

Parameters

x
Type: RedGate.SQLCompare.Engine.Migrations..::.MigrationScript
y
Type: RedGate.SQLCompare.Engine.Migrations..::.MigrationScript

Implements

IEqualityComparerEquals(UTP, UTP)

See Also

MigrationScript..::.ContentsAndMetadataEqualityComparer Class
Equals Overload
RedGate.SQLCompare.Engine.Migrations Namespace


GetHashCode Method

[image] [image]

SQL Data Compare API 12.0.40
MigrationScript..::.ContentsAndMetadataEqualityComparer..::.GetHashCode Method
MigrationScript..::.ContentsAndMetadataEqualityComparer Class See Also

Overload List

Name | Description
GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetHashCode(MigrationScript) |

See Also

MigrationScript..::.ContentsAndMetadataEqualityComparer Class
MigrationScript..::.ContentsAndMetadataEqualityComparer Members
RedGate.SQLCompare.Engine.Migrations Namespace


GetHashCode Method (MigrationScript)

[image]

SQL Data Compare API 12.0.40
MigrationScript..::.ContentsAndMetadataEqualityComparer..::.GetHashCode Method (MigrationScript)
MigrationScript..::.ContentsAndMetadataEqualityComparer Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetHashCode ( _
    obj As MigrationScript _
) As Integer
C#
public int GetHashCode(
    MigrationScript obj
)
Visual C++
public:
virtual int GetHashCode(
    MigrationScript^ obj
) sealed

Parameters

obj
Type: RedGate.SQLCompare.Engine.Migrations..::.MigrationScript

Implements

IEqualityComparerGetHashCode(UTP)

See Also

MigrationScript..::.ContentsAndMetadataEqualityComparer Class
GetHashCode Overload
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationScript.MetadataEqualityComparer Class

[image]

SQL Data Compare API 12.0.40
MigrationScript..::.MetadataEqualityComparer Class
MigrationScript Class Members See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class MetadataEqualityComparer _
    Implements IEqualityComparer(Of MigrationScript)
C#
public class MetadataEqualityComparer : IEqualityComparer<MigrationScript>
Visual C++
public ref class MetadataEqualityComparer : IEqualityComparer<MigrationScript^>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Migrations..::.MigrationScript..::.MetadataEqualityComparer

See Also

MigrationScript..::.MetadataEqualityComparer Members
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationScript.MetadataEqualityComparer Members

[image] [image]

SQL Data Compare API 12.0.40
MigrationScript..::.MetadataEqualityComparer Members
MigrationScript..::.MetadataEqualityComparer Class Constructors Methods See Also

A migration script that exists within a MigrationScriptFolder.

The MigrationScript..::.MetadataEqualityComparer type exposes the following members.

Constructors

Name | Description
MigrationScript..::.MetadataEqualityComparer |

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MigrationScript..::.MetadataEqualityComparer Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationScript.MetadataEqualityComparer Constructor

[image]

SQL Data Compare API 12.0.40
MigrationScript..::.MetadataEqualityComparer Constructor
MigrationScript..::.MetadataEqualityComparer Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MetadataEqualityComparer()
Visual C++
public:
MetadataEqualityComparer()

See Also

MigrationScript..::.MetadataEqualityComparer Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationScript.MetadataEqualityComparer Methods

[image] [image]

SQL Data Compare API 12.0.40
MigrationScript..::.MetadataEqualityComparer Methods
MigrationScript..::.MetadataEqualityComparer Class See Also

The MigrationScript..::.MetadataEqualityComparer type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MigrationScript..::.MetadataEqualityComparer Class
RedGate.SQLCompare.Engine.Migrations Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
MigrationScript..::.MetadataEqualityComparer..::.Equals Method
MigrationScript..::.MetadataEqualityComparer Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(MigrationScript, MigrationScript) |

See Also

MigrationScript..::.MetadataEqualityComparer Class
MigrationScript..::.MetadataEqualityComparer Members
RedGate.SQLCompare.Engine.Migrations Namespace


Equals Method (MigrationScript, MigrationScript)

[image]

SQL Data Compare API 12.0.40
MigrationScript..::.MetadataEqualityComparer..::.Equals Method (MigrationScript, MigrationScript)
MigrationScript..::.MetadataEqualityComparer Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    x As MigrationScript, _
    y As MigrationScript _
) As Boolean
C#
public bool Equals(
    MigrationScript x,
    MigrationScript y
)
Visual C++
public:
virtual bool Equals(
    MigrationScript^ x,
    MigrationScript^ y
) sealed

Parameters

x
Type: RedGate.SQLCompare.Engine.Migrations..::.MigrationScript
y
Type: RedGate.SQLCompare.Engine.Migrations..::.MigrationScript

Implements

IEqualityComparerEquals(UTP, UTP)

See Also

MigrationScript..::.MetadataEqualityComparer Class
Equals Overload
RedGate.SQLCompare.Engine.Migrations Namespace


GetHashCode Method

[image] [image]

SQL Data Compare API 12.0.40
MigrationScript..::.MetadataEqualityComparer..::.GetHashCode Method
MigrationScript..::.MetadataEqualityComparer Class See Also

Overload List

Name | Description
GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetHashCode(MigrationScript) |

See Also

MigrationScript..::.MetadataEqualityComparer Class
MigrationScript..::.MetadataEqualityComparer Members
RedGate.SQLCompare.Engine.Migrations Namespace


GetHashCode Method (MigrationScript)

[image]

SQL Data Compare API 12.0.40
MigrationScript..::.MetadataEqualityComparer..::.GetHashCode Method (MigrationScript)
MigrationScript..::.MetadataEqualityComparer Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetHashCode ( _
    obj As MigrationScript _
) As Integer
C#
public int GetHashCode(
    MigrationScript obj
)
Visual C++
public:
virtual int GetHashCode(
    MigrationScript^ obj
) sealed

Parameters

obj
Type: RedGate.SQLCompare.Engine.Migrations..::.MigrationScript

Implements

IEqualityComparerGetHashCode(UTP)

See Also

MigrationScript..::.MetadataEqualityComparer Class
GetHashCode Overload
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationScriptComparisonResult Class

[image]

SQL Data Compare API 12.0.40
MigrationScriptComparisonResult Class
Members See Also

The result of comparing two migration scripts.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class MigrationScriptComparisonResult
C#
public class MigrationScriptComparisonResult
Visual C++
public ref class MigrationScriptComparisonResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Migrations..::.MigrationScriptComparisonResult

See Also

MigrationScriptComparisonResult Members
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationScriptComparisonResult Members

[image] [image]

SQL Data Compare API 12.0.40
MigrationScriptComparisonResult Members
MigrationScriptComparisonResult Class Methods Properties See Also

The MigrationScriptComparisonResult type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ResultType |
SourceScript |
TargetScript |

See Also

MigrationScriptComparisonResult Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationScriptComparisonResult Properties

[image] [image]

SQL Data Compare API 12.0.40
MigrationScriptComparisonResult Properties
MigrationScriptComparisonResult Class See Also

The MigrationScriptComparisonResult type exposes the following properties.

Properties

Name | Description
ResultType |
SourceScript |
TargetScript |

See Also

MigrationScriptComparisonResult Class
RedGate.SQLCompare.Engine.Migrations Namespace


ResultType Property

[image]

SQL Data Compare API 12.0.40
MigrationScriptComparisonResult..::.ResultType Property
MigrationScriptComparisonResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ResultType As DifferenceType
C#
public DifferenceType ResultType { get; }
Visual C++
public:
property DifferenceType ResultType {
    DifferenceType get ();
}

See Also

MigrationScriptComparisonResult Class
RedGate.SQLCompare.Engine.Migrations Namespace


SourceScript Property

[image]

SQL Data Compare API 12.0.40
MigrationScriptComparisonResult..::.SourceScript Property
MigrationScriptComparisonResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SourceScript As MigrationScript
C#
public MigrationScript SourceScript { get; }
Visual C++
public:
property MigrationScript^ SourceScript {
    MigrationScript^ get ();
}

See Also

MigrationScriptComparisonResult Class
RedGate.SQLCompare.Engine.Migrations Namespace


TargetScript Property

[image]

SQL Data Compare API 12.0.40
MigrationScriptComparisonResult..::.TargetScript Property
MigrationScriptComparisonResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetScript As MigrationScript
C#
public MigrationScript TargetScript { get; }
Visual C++
public:
property MigrationScript^ TargetScript {
    MigrationScript^ get ();
}

See Also

MigrationScriptComparisonResult Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationScriptProviderExtensions Class

[image]

SQL Data Compare API 12.0.40
MigrationScriptProviderExtensions Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MigrationScriptProviderExtensions
C#
public static class MigrationScriptProviderExtensions
Visual C++
public ref class MigrationScriptProviderExtensions abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Migrations..::.MigrationScriptProviderExtensions

See Also

MigrationScriptProviderExtensions Members
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationScriptProviderExtensions Members

[image] [image]

SQL Data Compare API 12.0.40
MigrationScriptProviderExtensions Members
MigrationScriptProviderExtensions Class Methods See Also

The MigrationScriptProviderExtensions type exposes the following members.

Methods

Name | Description
TryGetMigrationScripts |

See Also

MigrationScriptProviderExtensions Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationScriptProviderExtensions Methods

[image] [image]

SQL Data Compare API 12.0.40
MigrationScriptProviderExtensions Methods
MigrationScriptProviderExtensions Class See Also

The MigrationScriptProviderExtensions type exposes the following methods.

Methods

Name | Description
TryGetMigrationScripts |

See Also

MigrationScriptProviderExtensions Class
RedGate.SQLCompare.Engine.Migrations Namespace


TryGetMigrationScripts Method

[image]

SQL Data Compare API 12.0.40
MigrationScriptProviderExtensions..::.TryGetMigrationScripts Method
MigrationScriptProviderExtensions Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function TryGetMigrationScripts ( _
    migrationScriptProvider As IMigrationScriptProvider, _
    fromVersion As VersionInfo, _
    toVersion As VersionInfo, _
    <OutAttribute> ByRef migrationScripts As List(Of MigrationScript) _
) As Boolean
C#
public static bool TryGetMigrationScripts(
    IMigrationScriptProvider migrationScriptProvider,
    VersionInfo fromVersion,
    VersionInfo toVersion,
    out List<MigrationScript> migrationScripts
)
Visual C++
public:
static bool TryGetMigrationScripts(
    IMigrationScriptProvider^ migrationScriptProvider,
    VersionInfo^ fromVersion,
    VersionInfo^ toVersion,
    [OutAttribute] List<MigrationScript^>^% migrationScripts
)

Parameters

migrationScriptProvider
Type: RedGate.SQLCompare.Engine.Migrations..::.IMigrationScriptProvider
fromVersion
Type: RedGate.SQLCompare.Engine.Migrations..::.VersionInfo
toVersion
Type: RedGate.SQLCompare.Engine.Migrations..::.VersionInfo
migrationScripts
Type: List<(Of <( MigrationScript >)>)%

See Also

MigrationScriptProviderExtensions Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationsFolder Class

[image]

SQL Data Compare API 12.0.40
MigrationsFolder Class
Members See Also

An object that represents a migration scripts folder on disk.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class MigrationsFolder _
    Implements IMigrationsFolder, IMigrationScriptProvider, ICancellable
C#
public class MigrationsFolder : IMigrationsFolder,
    IMigrationScriptProvider, ICancellable
Visual C++
public ref class MigrationsFolder : IMigrationsFolder,
    IMigrationScriptProvider, ICancellable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Migrations..::.MigrationsFolder

See Also

MigrationsFolder Members
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationsFolder Members

[image] [image]

SQL Data Compare API 12.0.40
MigrationsFolder Members
MigrationsFolder Class Methods Properties See Also

The MigrationsFolder type exposes the following members.

Methods

Name | Description
AddScript | Add a script to a migration scripts folder. The name of the script will be extrapolated from the provided sqlScriptPath. Names must be unique.
CancelOperation |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetMigrationScript | Overloaded.
GetMigrationScripts | Return an enumerable collection of migration scripts where the migration script is entirely between fromVersion and toVersion, inclusive. Scripts should be in ascending or descending fromVersion order, depending on whether fromVersion < toVersion or toVersion < fromVersion respectively. If the script folder location for fromVersion and toVersion is not equal, then an empty list is returned, as cross-branch migrations are currently not supported. Migration scripts with locations other than found in fromVersion and toVersion are not returned, as they are not relevant.
GetScriptFilePaths | Returns an array containing the paths of all files on disk, associated to a migration script.
GetSqlFilePath | Returns the path of the SQL file within the folder. The file doesn't need to exist.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlFilePath |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RemoveScript | Remove a migration script from the folder, including all associated files on disk.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FolderPath | The path of the migration scripts folder on disk.
Scripts | A collection of migration scripts.
Status |

See Also

MigrationsFolder Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationsFolder Methods

[image] [image]

SQL Data Compare API 12.0.40
MigrationsFolder Methods
MigrationsFolder Class See Also

The MigrationsFolder type exposes the following methods.

Methods

Name | Description
AddScript | Add a script to a migration scripts folder. The name of the script will be extrapolated from the provided sqlScriptPath. Names must be unique.
CancelOperation |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetMigrationScript | Overloaded.
GetMigrationScripts | Return an enumerable collection of migration scripts where the migration script is entirely between fromVersion and toVersion, inclusive. Scripts should be in ascending or descending fromVersion order, depending on whether fromVersion < toVersion or toVersion < fromVersion respectively. If the script folder location for fromVersion and toVersion is not equal, then an empty list is returned, as cross-branch migrations are currently not supported. Migration scripts with locations other than found in fromVersion and toVersion are not returned, as they are not relevant.
GetScriptFilePaths | Returns an array containing the paths of all files on disk, associated to a migration script.
GetSqlFilePath | Returns the path of the SQL file within the folder. The file doesn't need to exist.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlFilePath |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RemoveScript | Remove a migration script from the folder, including all associated files on disk.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MigrationsFolder Class
RedGate.SQLCompare.Engine.Migrations Namespace


AddScript Method

[image]

SQL Data Compare API 12.0.40
MigrationsFolder..::.AddScript Method
MigrationsFolder Class See Also

Add a script to a migration scripts folder. The name of the script will be extrapolated from the provided sqlScriptPath. Names must be unique.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function AddScript ( _
    fromVersion As VersionInfo, _
    toVersion As VersionInfo, _
    objectIdentifiers As IEnumerable(Of ObjectIdentifier), _
    sqlScriptPath As String, _
    description As String _
) As MigrationScript
C#
public MigrationScript AddScript(
    VersionInfo fromVersion,
    VersionInfo toVersion,
    IEnumerable<ObjectIdentifier> objectIdentifiers,
    string sqlScriptPath,
    string description
)
Visual C++
public:
virtual MigrationScript^ AddScript(
    VersionInfo^ fromVersion,
    VersionInfo^ toVersion,
    IEnumerable<ObjectIdentifier>^ objectIdentifiers,
    String^ sqlScriptPath,
    String^ description
) sealed

Parameters

fromVersion
Type: RedGate.SQLCompare.Engine.Migrations..::.VersionInfo
The version from which the migration script is used.
toVersion
Type: RedGate.SQLCompare.Engine.Migrations..::.VersionInfo
The version to which the migration script is used.
objectIdentifiers
Type: IEnumerable<(Of <( ObjectIdentifier >)>)
sqlScriptPath
Type: String
The path of the sql script file to use. This file must end in .sql and reside within the migrations folder.
description
Type: String

Implements

IMigrationsFolder..::.AddScript(VersionInfo, VersionInfo, IEnumerable<(Of <(ObjectIdentifier>)>), String, String)

See Also

MigrationsFolder Class
RedGate.SQLCompare.Engine.Migrations Namespace


CancelOperation Method

[image]

SQL Data Compare API 12.0.40
MigrationsFolder..::.CancelOperation Method
MigrationsFolder Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelOperation
C#
public void CancelOperation()
Visual C++
public:
virtual void CancelOperation() sealed

Implements

ICancellable..::.CancelOperation()()()

See Also

MigrationsFolder Class
RedGate.SQLCompare.Engine.Migrations Namespace


GetMigrationScript Method

[image] [image]

SQL Data Compare API 12.0.40
MigrationsFolder..::.GetMigrationScript Method
MigrationsFolder Class See Also

Overload List

Name | Description
GetMigrationScript(String) | Returns a migration script matching the specified name, or null if there is no match.
GetMigrationScript(VersionInfo, VersionInfo) | Returns a migration script matching exactly the fromVersion and toVersion, or null if there is no match.

See Also

MigrationsFolder Class
MigrationsFolder Members
RedGate.SQLCompare.Engine.Migrations Namespace


GetMigrationScript Method ()

[image]

SQL Data Compare API 12.0.40
MigrationsFolder..::.GetMigrationScript Method ()
MigrationsFolder Class See Also

Returns a migration script matching the specified name, or null if there is no match.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMigrationScript ( _
    name As String _
) As MigrationScript
C#
public MigrationScript GetMigrationScript(
    string name
)
Visual C++
public:
virtual MigrationScript^ GetMigrationScript(
    String^ name
) sealed

Parameters

name
Type: String
The name of the migration script to return.

Implements

IMigrationsFolder..::.GetMigrationScript(String)

See Also

MigrationsFolder Class
GetMigrationScript Overload
RedGate.SQLCompare.Engine.Migrations Namespace


GetMigrationScript Method (VersionInfo, VersionInfo)

[image]

SQL Data Compare API 12.0.40
MigrationsFolder..::.GetMigrationScript Method (VersionInfo, VersionInfo)
MigrationsFolder Class See Also

Returns a migration script matching exactly the fromVersion and toVersion, or null if there is no match.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMigrationScript ( _
    fromVersion As VersionInfo, _
    toVersion As VersionInfo _
) As MigrationScript
C#
public MigrationScript GetMigrationScript(
    VersionInfo fromVersion,
    VersionInfo toVersion
)
Visual C++
public:
virtual MigrationScript^ GetMigrationScript(
    VersionInfo^ fromVersion,
    VersionInfo^ toVersion
) sealed

Parameters

fromVersion
Type: RedGate.SQLCompare.Engine.Migrations..::.VersionInfo
The version to match against fromVersion.
toVersion
Type: RedGate.SQLCompare.Engine.Migrations..::.VersionInfo
The version to match against toVersion.

Implements

IMigrationsFolder..::.GetMigrationScript(VersionInfo, VersionInfo)

See Also

MigrationsFolder Class
GetMigrationScript Overload
RedGate.SQLCompare.Engine.Migrations Namespace


GetMigrationScripts Method

[image]

SQL Data Compare API 12.0.40
MigrationsFolder..::.GetMigrationScripts Method
MigrationsFolder Class See Also

Return an enumerable collection of migration scripts where the migration script is entirely between fromVersion and toVersion, inclusive. Scripts should be in ascending or descending fromVersion order, depending on whether fromVersion < toVersion or toVersion < fromVersion respectively. If the script folder location for fromVersion and toVersion is not equal, then an empty list is returned, as cross-branch migrations are currently not supported. Migration scripts with locations other than found in fromVersion and toVersion are not returned, as they are not relevant.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMigrationScripts ( _
    fromVersion As VersionInfo, _
    toVersion As VersionInfo _
) As IEnumerable(Of MigrationScript)
C#
public IEnumerable<MigrationScript> GetMigrationScripts(
    VersionInfo fromVersion,
    VersionInfo toVersion
)
Visual C++
public:
virtual IEnumerable<MigrationScript^>^ GetMigrationScripts(
    VersionInfo^ fromVersion,
    VersionInfo^ toVersion
) sealed

Parameters

fromVersion
Type: RedGate.SQLCompare.Engine.Migrations..::.VersionInfo
The version from which to get migration scripts.
toVersion
Type: RedGate.SQLCompare.Engine.Migrations..::.VersionInfo
The version to which to get migration scripts.

Implements

IMigrationScriptProvider..::.GetMigrationScripts(VersionInfo, VersionInfo)

See Also

MigrationsFolder Class
RedGate.SQLCompare.Engine.Migrations Namespace


GetScriptFilePaths Method

[image]

SQL Data Compare API 12.0.40
MigrationsFolder..::.GetScriptFilePaths Method
MigrationsFolder Class See Also

Returns an array containing the paths of all files on disk, associated to a migration script.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetScriptFilePaths ( _
    script As MigrationScript _
) As IEnumerable(Of String)
C#
public IEnumerable<string> GetScriptFilePaths(
    MigrationScript script
)
Visual C++
public:
virtual IEnumerable<String^>^ GetScriptFilePaths(
    MigrationScript^ script
) sealed

Parameters

script
Type: RedGate.SQLCompare.Engine.Migrations..::.MigrationScript
The migration script for which to return file paths.

Implements

IMigrationsFolder..::.GetScriptFilePaths(MigrationScript)

See Also

MigrationsFolder Class
RedGate.SQLCompare.Engine.Migrations Namespace


GetSqlFilePath Method

[image]

SQL Data Compare API 12.0.40
MigrationsFolder..::.GetSqlFilePath Method
MigrationsFolder Class See Also

Returns the path of the SQL file within the folder. The file doesn't need to exist.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlFilePath ( _
    scriptName As String _
) As String
C#
public string GetSqlFilePath(
    string scriptName
)
Visual C++
public:
virtual String^ GetSqlFilePath(
    String^ scriptName
) sealed

Parameters

scriptName
Type: String
The name of the migration script for which to return the sql file path.

Implements

IMigrationsFolder..::.GetSqlFilePath(String)

See Also

MigrationsFolder Class
RedGate.SQLCompare.Engine.Migrations Namespace


GetXmlFilePath Method

[image]

SQL Data Compare API 12.0.40
MigrationsFolder..::.GetXmlFilePath Method
MigrationsFolder Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetXmlFilePath ( _
    scriptName As String _
) As String
C#
public string GetXmlFilePath(
    string scriptName
)
Visual C++
public:
virtual String^ GetXmlFilePath(
    String^ scriptName
) sealed

Parameters

scriptName
Type: String

Implements

IMigrationsFolder..::.GetXmlFilePath(String)

See Also

MigrationsFolder Class
RedGate.SQLCompare.Engine.Migrations Namespace


RemoveScript Method

[image]

SQL Data Compare API 12.0.40
MigrationsFolder..::.RemoveScript Method
MigrationsFolder Class See Also

Remove a migration script from the folder, including all associated files on disk.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveScript ( _
    script As MigrationScript _
)
C#
public void RemoveScript(
    MigrationScript script
)
Visual C++
public:
virtual void RemoveScript(
    MigrationScript^ script
) sealed

Parameters

script
Type: RedGate.SQLCompare.Engine.Migrations..::.MigrationScript
The migration script to remove. The script must be a member of this folder.

Implements

IMigrationsFolder..::.RemoveScript(MigrationScript)

See Also

MigrationsFolder Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationsFolder Properties

[image] [image]

SQL Data Compare API 12.0.40
MigrationsFolder Properties
MigrationsFolder Class See Also

The MigrationsFolder type exposes the following properties.

Properties

Name | Description
FolderPath | The path of the migration scripts folder on disk.
Scripts | A collection of migration scripts.
Status |

See Also

MigrationsFolder Class
RedGate.SQLCompare.Engine.Migrations Namespace


FolderPath Property

[image]

SQL Data Compare API 12.0.40
MigrationsFolder..::.FolderPath Property
MigrationsFolder Class See Also

The path of the migration scripts folder on disk.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FolderPath As String
C#
public string FolderPath { get; }
Visual C++
public:
virtual property String^ FolderPath {
    String^ get () sealed;
}

Implements

IMigrationsFolder..::.FolderPath

See Also

MigrationsFolder Class
RedGate.SQLCompare.Engine.Migrations Namespace


Scripts Property

[image]

SQL Data Compare API 12.0.40
MigrationsFolder..::.Scripts Property
MigrationsFolder Class See Also

A collection of migration scripts.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Scripts As ReadOnlyCollection(Of MigrationScript)
C#
public ReadOnlyCollection<MigrationScript> Scripts { get; }
Visual C++
public:
virtual property ReadOnlyCollection<MigrationScript^>^ Scripts {
    ReadOnlyCollection<MigrationScript^>^ get () sealed;
}

Implements

IMigrationsFolder..::.Scripts

See Also

MigrationsFolder Class
RedGate.SQLCompare.Engine.Migrations Namespace


Status Property

[image]

SQL Data Compare API 12.0.40
MigrationsFolder..::.Status Property
MigrationsFolder Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

See Also

MigrationsFolder Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationsHelper Class

[image]

SQL Data Compare API 12.0.40
MigrationsHelper Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MigrationsHelper
C#
public static class MigrationsHelper
Visual C++
public ref class MigrationsHelper abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Migrations..::.MigrationsHelper

See Also

MigrationsHelper Members
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationsHelper Members

[image] [image]

SQL Data Compare API 12.0.40
MigrationsHelper Members
MigrationsHelper Class Methods Fields Properties See Also

The MigrationsHelper type exposes the following members.

Methods

Name | Description
GetExtendedPropertiesExecutionBlock |
IgnoreExtendedProperty |

Fields

Name | Description
DriftDetectionNotPerformed |
MigrationsActionTitle |
MigrationScriptsDetectedRequiresProLicense |
MigrationsLoadFailed |
MigrationsRequiresProLicense |
MigrationsSourceDrift |
SourceControlExtendedPropertyPrefix |

Properties

Name | Description
MigrationFolderLocationExtendedPropertyName |
ScriptFolderLocationExtendedPropertyName |
VersionExtendedPropertyName |

See Also

MigrationsHelper Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationsHelper Fields

[image] [image]

SQL Data Compare API 12.0.40
MigrationsHelper Fields
MigrationsHelper Class See Also

The MigrationsHelper type exposes the following fields.

Fields

Name | Description
DriftDetectionNotPerformed |
MigrationsActionTitle |
MigrationScriptsDetectedRequiresProLicense |
MigrationsLoadFailed |
MigrationsRequiresProLicense |
MigrationsSourceDrift |
SourceControlExtendedPropertyPrefix |

See Also

MigrationsHelper Class
RedGate.SQLCompare.Engine.Migrations Namespace


DriftDetectionNotPerformed Field

[image]

SQL Data Compare API 12.0.40
MigrationsHelper..::.DriftDetectionNotPerformed Field
MigrationsHelper Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Const DriftDetectionNotPerformed As String
C#
public const string DriftDetectionNotPerformed
Visual C++
public:
literal String^ DriftDetectionNotPerformed

See Also

MigrationsHelper Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationsActionTitle Field

[image]

SQL Data Compare API 12.0.40
MigrationsHelper..::.MigrationsActionTitle Field
MigrationsHelper Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Const MigrationsActionTitle As String
C#
public const string MigrationsActionTitle
Visual C++
public:
literal String^ MigrationsActionTitle

See Also

MigrationsHelper Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationScriptsDetectedRequiresProLicense Field

[image]

SQL Data Compare API 12.0.40
MigrationsHelper..::.MigrationScriptsDetectedRequiresProLicense Field
MigrationsHelper Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Const MigrationScriptsDetectedRequiresProLicense As String
C#
public const string MigrationScriptsDetectedRequiresProLicense
Visual C++
public:
literal String^ MigrationScriptsDetectedRequiresProLicense

See Also

MigrationsHelper Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationsLoadFailed Field

[image]

SQL Data Compare API 12.0.40
MigrationsHelper..::.MigrationsLoadFailed Field
MigrationsHelper Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Const MigrationsLoadFailed As String
C#
public const string MigrationsLoadFailed
Visual C++
public:
literal String^ MigrationsLoadFailed

See Also

MigrationsHelper Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationsRequiresProLicense Field

[image]

SQL Data Compare API 12.0.40
MigrationsHelper..::.MigrationsRequiresProLicense Field
MigrationsHelper Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Const MigrationsRequiresProLicense As String
C#
public const string MigrationsRequiresProLicense
Visual C++
public:
literal String^ MigrationsRequiresProLicense

See Also

MigrationsHelper Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationsSourceDrift Field

[image]

SQL Data Compare API 12.0.40
MigrationsHelper..::.MigrationsSourceDrift Field
MigrationsHelper Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Const MigrationsSourceDrift As String
C#
public const string MigrationsSourceDrift
Visual C++
public:
literal String^ MigrationsSourceDrift

See Also

MigrationsHelper Class
RedGate.SQLCompare.Engine.Migrations Namespace


SourceControlExtendedPropertyPrefix Field

[image]

SQL Data Compare API 12.0.40
MigrationsHelper..::.SourceControlExtendedPropertyPrefix Field
MigrationsHelper Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Const SourceControlExtendedPropertyPrefix As String
C#
public const string SourceControlExtendedPropertyPrefix
Visual C++
public:
literal String^ SourceControlExtendedPropertyPrefix

See Also

MigrationsHelper Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationsHelper Methods

[image] [image]

SQL Data Compare API 12.0.40
MigrationsHelper Methods
MigrationsHelper Class See Also

The MigrationsHelper type exposes the following methods.

Methods

Name | Description
GetExtendedPropertiesExecutionBlock |
IgnoreExtendedProperty |

See Also

MigrationsHelper Class
RedGate.SQLCompare.Engine.Migrations Namespace


GetExtendedPropertiesExecutionBlock Method

[image]

SQL Data Compare API 12.0.40
MigrationsHelper..::.GetExtendedPropertiesExecutionBlock Method
MigrationsHelper Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetExtendedPropertiesExecutionBlock ( _
    version As Long, _
    scriptFolderLocation As ISOCCompareLocation, _
    migrationFolderLocation As ISOCCompareLocation _
) As IExecutionBlock
C#
public static IExecutionBlock GetExtendedPropertiesExecutionBlock(
    long version,
    ISOCCompareLocation scriptFolderLocation,
    ISOCCompareLocation migrationFolderLocation
)
Visual C++
public:
static IExecutionBlock^ GetExtendedPropertiesExecutionBlock(
    long long version,
    ISOCCompareLocation^ scriptFolderLocation,
    ISOCCompareLocation^ migrationFolderLocation
)

Parameters

version
Type: Int64
scriptFolderLocation
Type: ISOCCompareLocation
migrationFolderLocation
Type: ISOCCompareLocation

See Also

MigrationsHelper Class
RedGate.SQLCompare.Engine.Migrations Namespace


IgnoreExtendedProperty Method

[image]

SQL Data Compare API 12.0.40
MigrationsHelper..::.IgnoreExtendedProperty Method
MigrationsHelper Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IgnoreExtendedProperty ( _
    propertyName As String _
) As Boolean
C#
public static bool IgnoreExtendedProperty(
    string propertyName
)
Visual C++
public:
static bool IgnoreExtendedProperty(
    String^ propertyName
)

Parameters

propertyName
Type: String

See Also

MigrationsHelper Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationsHelper Properties

[image] [image]

SQL Data Compare API 12.0.40
MigrationsHelper Properties
MigrationsHelper Class See Also

The MigrationsHelper type exposes the following properties.

Properties

Name | Description
MigrationFolderLocationExtendedPropertyName |
ScriptFolderLocationExtendedPropertyName |
VersionExtendedPropertyName |

See Also

MigrationsHelper Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationFolderLocationExtendedPropertyName Property

[image]

SQL Data Compare API 12.0.40
MigrationsHelper..::.MigrationFolderLocationExtendedPropertyName Property
MigrationsHelper Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property MigrationFolderLocationExtendedPropertyName As String
C#
public static string MigrationFolderLocationExtendedPropertyName { get; }
Visual C++
public:
static property String^ MigrationFolderLocationExtendedPropertyName {
    String^ get ();
}

See Also

MigrationsHelper Class
RedGate.SQLCompare.Engine.Migrations Namespace


ScriptFolderLocationExtendedPropertyName Property

[image]

SQL Data Compare API 12.0.40
MigrationsHelper..::.ScriptFolderLocationExtendedPropertyName Property
MigrationsHelper Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ScriptFolderLocationExtendedPropertyName As String
C#
public static string ScriptFolderLocationExtendedPropertyName { get; }
Visual C++
public:
static property String^ ScriptFolderLocationExtendedPropertyName {
    String^ get ();
}

See Also

MigrationsHelper Class
RedGate.SQLCompare.Engine.Migrations Namespace


VersionExtendedPropertyName Property

[image]

SQL Data Compare API 12.0.40
MigrationsHelper..::.VersionExtendedPropertyName Property
MigrationsHelper Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property VersionExtendedPropertyName As String
C#
public static string VersionExtendedPropertyName { get; }
Visual C++
public:
static property String^ VersionExtendedPropertyName {
    String^ get ();
}

See Also

MigrationsHelper Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationsLoader Class

[image]

SQL Data Compare API 12.0.40
MigrationsLoader Class
Members See Also

A loader for migrations folders.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class MigrationsLoader _
    Implements IExecutable(Of MigrationsFolder), ICancellable
C#
public class MigrationsLoader : IExecutable<MigrationsFolder>,
    ICancellable
Visual C++
public ref class MigrationsLoader : IExecutable<MigrationsFolder^>,
    ICancellable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Migrations..::.MigrationsLoader

See Also

MigrationsLoader Members
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationsLoader Members

[image] [image]

SQL Data Compare API 12.0.40
MigrationsLoader Members
MigrationsLoader Class Constructors Methods Properties See Also

The MigrationsLoader type exposes the following members.

Constructors

Name | Description
MigrationsLoader | Creates a migrations folder loader.

Methods

Name | Description
CancelOperation | Cancels the load operation.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Execute the load. Returns the loaded migration scripts folder. Can only be called once.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Status | The StatusEventHandler used to update progress information.

See Also

MigrationsLoader Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationsLoader Constructor

[image]

SQL Data Compare API 12.0.40
MigrationsLoader Constructor
MigrationsLoader Class See Also

Creates a migrations folder loader.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    folderPath As String, _
    locationProvider As ISOCCompareLocationProvider _
)
C#
public MigrationsLoader(
    string folderPath,
    ISOCCompareLocationProvider locationProvider
)
Visual C++
public:
MigrationsLoader(
    String^ folderPath,
    ISOCCompareLocationProvider^ locationProvider
)

Parameters

folderPath
Type: String
The path of the migration scripts folder on disk. This folder must exist.
locationProvider
Type: RedGate.SQLCompare.Engine.Migrations..::.ISOCCompareLocationProvider
The location provider used to get location objects.

See Also

MigrationsLoader Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationsLoader Methods

[image] [image]

SQL Data Compare API 12.0.40
MigrationsLoader Methods
MigrationsLoader Class See Also

The MigrationsLoader type exposes the following methods.

Methods

Name | Description
CancelOperation | Cancels the load operation.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Execute the load. Returns the loaded migration scripts folder. Can only be called once.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MigrationsLoader Class
RedGate.SQLCompare.Engine.Migrations Namespace


CancelOperation Method

[image]

SQL Data Compare API 12.0.40
MigrationsLoader..::.CancelOperation Method
MigrationsLoader Class See Also

Cancels the load operation.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelOperation
C#
public void CancelOperation()
Visual C++
public:
virtual void CancelOperation() sealed

Implements

ICancellable..::.CancelOperation()()()

See Also

MigrationsLoader Class
RedGate.SQLCompare.Engine.Migrations Namespace


Execute Method

[image]

SQL Data Compare API 12.0.40
MigrationsLoader..::.Execute Method
MigrationsLoader Class See Also

Execute the load. Returns the loaded migration scripts folder. Can only be called once.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Execute As MigrationsFolder
C#
public MigrationsFolder Execute()
Visual C++
public:
virtual MigrationsFolder^ Execute() sealed

Implements

IExecutable<(Of <(TResult>)>)..::.Execute()()()

See Also

MigrationsLoader Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationsLoader Properties

[image] [image]

SQL Data Compare API 12.0.40
MigrationsLoader Properties
MigrationsLoader Class See Also

The MigrationsLoader type exposes the following properties.

Properties

Name | Description
Status | The StatusEventHandler used to update progress information.

See Also

MigrationsLoader Class
RedGate.SQLCompare.Engine.Migrations Namespace


Status Property

[image]

SQL Data Compare API 12.0.40
MigrationsLoader..::.Status Property
MigrationsLoader Class See Also

The StatusEventHandler used to update progress information.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

See Also

MigrationsLoader Class
RedGate.SQLCompare.Engine.Migrations Namespace


ObjectIdentifier Structure

[image]

SQL Data Compare API 12.0.40
ObjectIdentifier Structure
Members See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Structure ObjectIdentifier
C#
public struct ObjectIdentifier
Visual C++
public value class ObjectIdentifier

See Also

ObjectIdentifier Members
RedGate.SQLCompare.Engine.Migrations Namespace


ObjectIdentifier Members

[image] [image]

SQL Data Compare API 12.0.40
ObjectIdentifier Members
ObjectIdentifier Structure Constructors Methods Properties Explicit Interface Implementations See Also

The ObjectIdentifier type exposes the following members.

Constructors

Name | Description
ObjectIdentifier | Overloaded.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
FullyQualifiedAndEscapedName |
Type |

Explicit Interface Implementations

Name | Description
Version |

See Also

ObjectIdentifier Structure
RedGate.SQLCompare.Engine.Migrations Namespace


ObjectIdentifier Constructor

[image] [image]

SQL Data Compare API 12.0.40
ObjectIdentifier Constructor
ObjectIdentifier Structure See Also

Overload List

Name | Description
ObjectIdentifier(String, ObjectType) |
ObjectIdentifier(String, String, ObjectType) |

See Also

ObjectIdentifier Structure
ObjectIdentifier Members
RedGate.SQLCompare.Engine.Migrations Namespace


ObjectIdentifier Constructor (, )

[image]

SQL Data Compare API 12.0.40
ObjectIdentifier Constructor (, )
ObjectIdentifier Structure See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fullyQualifiedAndEscapedName As String, _
    type As ObjectType _
)
C#
public ObjectIdentifier(
    string fullyQualifiedAndEscapedName,
    ObjectType type
)
Visual C++
public:
ObjectIdentifier(
    String^ fullyQualifiedAndEscapedName,
    ObjectType type
)

Parameters

fullyQualifiedAndEscapedName
Type: String
type
Type: ObjectType

See Also

ObjectIdentifier Structure
ObjectIdentifier Overload
RedGate.SQLCompare.Engine.Migrations Namespace


ObjectIdentifier Constructor (, , )

[image]

SQL Data Compare API 12.0.40
ObjectIdentifier Constructor (, , )
ObjectIdentifier Structure See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    owner As String, _
    name As String, _
    type As ObjectType _
)
C#
public ObjectIdentifier(
    string owner,
    string name,
    ObjectType type
)
Visual C++
public:
ObjectIdentifier(
    String^ owner,
    String^ name,
    ObjectType type
)

Parameters

owner
Type: String
name
Type: String
type
Type: ObjectType

See Also

ObjectIdentifier Structure
ObjectIdentifier Overload
RedGate.SQLCompare.Engine.Migrations Namespace


ObjectIdentifier Properties

[image] [image]

SQL Data Compare API 12.0.40
ObjectIdentifier Properties
ObjectIdentifier Structure See Also

The ObjectIdentifier type exposes the following properties.

Properties

Name | Description
FullyQualifiedAndEscapedName |
Type |

Explicit Interface Implementations

Name | Description
Version |

See Also

ObjectIdentifier Structure
RedGate.SQLCompare.Engine.Migrations Namespace


FullyQualifiedAndEscapedName Property

[image]

SQL Data Compare API 12.0.40
ObjectIdentifier..::.FullyQualifiedAndEscapedName Property
ObjectIdentifier Structure See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullyQualifiedAndEscapedName As String
C#
public string FullyQualifiedAndEscapedName { get; }
Visual C++
public:
property String^ FullyQualifiedAndEscapedName {
    String^ get ();
}

See Also

ObjectIdentifier Structure
RedGate.SQLCompare.Engine.Migrations Namespace


Type Property

[image]

SQL Data Compare API 12.0.40
ObjectIdentifier..::.Type Property
ObjectIdentifier Structure See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As ObjectType
C#
public ObjectType Type { get; }
Visual C++
public:
property ObjectType Type {
    ObjectType get ();
}

See Also

ObjectIdentifier Structure
RedGate.SQLCompare.Engine.Migrations Namespace


Property

[image]

SQL Data Compare API 12.0.40
ObjectIdentifier..::. Property
ObjectIdentifier Structure See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private ReadOnly Property Version As Integer
C#
private int Version { get; }
Visual C++
private:
virtual property int Version {
    int get () sealed;
}

See Also

ObjectIdentifier Structure
RedGate.SQLCompare.Engine.Migrations Namespace


ReadOnlyObjectIdentifierCollection Class

[image]

SQL Data Compare API 12.0.40
ReadOnlyObjectIdentifierCollection Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ReadOnlyObjectIdentifierCollection _
    Inherits ReadOnlyCollection(Of ObjectIdentifier)
C#
public class ReadOnlyObjectIdentifierCollection : ReadOnlyCollection<ObjectIdentifier>
Visual C++
public ref class ReadOnlyObjectIdentifierCollection : public ReadOnlyCollection<ObjectIdentifier>

Inheritance Hierarchy

Object
ReadOnlyCollection<(Of <( ObjectIdentifier >)>)
RedGate.SQLCompare.Engine.Migrations..::.ReadOnlyObjectIdentifierCollection

See Also

ReadOnlyObjectIdentifierCollection Members
RedGate.SQLCompare.Engine.Migrations Namespace


ReadOnlyObjectIdentifierCollection Members

[image] [image]

SQL Data Compare API 12.0.40
ReadOnlyObjectIdentifierCollection Members
ReadOnlyObjectIdentifierCollection Class Constructors Methods Properties Explicit Interface Implementations See Also

The ReadOnlyObjectIdentifierCollection type exposes the following members.

Constructors

Name | Description
ReadOnlyObjectIdentifierCollection |

Methods

Name | Description
Contains | Determines whether an element is in the ReadOnlyCollection. (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
ContentEquals |
CopyTo | Copies the entire ReadOnlyCollection to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection. (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection. (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection instance. (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
Item | Gets the element at the specified index. (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
Items | Returns the IList that the ReadOnlyCollection wraps. (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)

Explicit Interface Implementations

Name | Description
System#Collections#Generic#ICollection{`0}#Add | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#IList#Add | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#Generic#ICollection{`0}#Clear | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#IList#Clear | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#IList#Contains | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#ICollection#CopyTo | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#IEnumerable#GetEnumerator | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#IList#IndexOf | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#Generic#IList{`0}#Insert | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#IList#Insert | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#IList#IsFixedSize | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#Generic#ICollection{`0}#IsReadOnly | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#IList#IsReadOnly | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#ICollection#IsSynchronized | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#Generic#IList{`0}#Item | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#IList#Item | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#Generic#ICollection{`0}#Remove | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#IList#Remove | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#Generic#IList{`0}#RemoveAt | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#IList#RemoveAt | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#ICollection#SyncRoot | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)

See Also

ReadOnlyObjectIdentifierCollection Class
RedGate.SQLCompare.Engine.Migrations Namespace


ReadOnlyObjectIdentifierCollection Constructor

[image]

SQL Data Compare API 12.0.40
ReadOnlyObjectIdentifierCollection Constructor
ReadOnlyObjectIdentifierCollection Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    list As IList(Of ObjectIdentifier) _
)
C#
public ReadOnlyObjectIdentifierCollection(
    IList<ObjectIdentifier> list
)
Visual C++
public:
ReadOnlyObjectIdentifierCollection(
    IList<ObjectIdentifier>^ list
)

Parameters

list
Type: IList<(Of <( ObjectIdentifier >)>)

See Also

ReadOnlyObjectIdentifierCollection Class
RedGate.SQLCompare.Engine.Migrations Namespace


ReadOnlyObjectIdentifierCollection Methods

[image] [image]

SQL Data Compare API 12.0.40
ReadOnlyObjectIdentifierCollection Methods
ReadOnlyObjectIdentifierCollection Class See Also

The ReadOnlyObjectIdentifierCollection type exposes the following methods.

Methods

Name | Description
Contains | Determines whether an element is in the ReadOnlyCollection. (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
ContentEquals |
CopyTo | Copies the entire ReadOnlyCollection to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection. (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection. (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
System#Collections#Generic#ICollection{`0}#Add | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#IList#Add | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#Generic#ICollection{`0}#Clear | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#IList#Clear | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#IList#Contains | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#ICollection#CopyTo | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#IEnumerable#GetEnumerator | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#IList#IndexOf | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#Generic#IList{`0}#Insert | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#IList#Insert | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#Generic#ICollection{`0}#Remove | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#IList#Remove | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#Generic#IList{`0}#RemoveAt | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)
System#Collections#IList#RemoveAt | (Inherited from ReadOnlyCollection<(Of <( ObjectIdentifier >)>).)

See Also

ReadOnlyObjectIdentifierCollection Class
RedGate.SQLCompare.Engine.Migrations Namespace


ContentEquals Method

[image]

SQL Data Compare API 12.0.40
ReadOnlyObjectIdentifierCollection..::.ContentEquals Method
ReadOnlyObjectIdentifierCollection Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function ContentEquals ( _
    other As ReadOnlyObjectIdentifierCollection _
) As Boolean
C#
public bool ContentEquals(
    ReadOnlyObjectIdentifierCollection other
)
Visual C++
public:
bool ContentEquals(
    ReadOnlyObjectIdentifierCollection^ other
)

Parameters

other
Type: RedGate.SQLCompare.Engine.Migrations..::.ReadOnlyObjectIdentifierCollection

See Also

ReadOnlyObjectIdentifierCollection Class
RedGate.SQLCompare.Engine.Migrations Namespace


SqlCompareSqlSourceControlMigrationScriptHandOff Class

[image]

SQL Data Compare API 12.0.40
SqlCompareSqlSourceControlMigrationScriptHandOff Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlCompareSqlSourceControlMigrationScriptHandOff
C#
public class SqlCompareSqlSourceControlMigrationScriptHandOff
Visual C++
public ref class SqlCompareSqlSourceControlMigrationScriptHandOff

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Migrations..::.SqlCompareSqlSourceControlMigrationScriptHandOff

See Also

SqlCompareSqlSourceControlMigrationScriptHandOff Members
RedGate.SQLCompare.Engine.Migrations Namespace


SqlCompareSqlSourceControlMigrationScriptHandOff Members

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareSqlSourceControlMigrationScriptHandOff Members
SqlCompareSqlSourceControlMigrationScriptHandOff Class Constructors Methods Properties See Also

The SqlCompareSqlSourceControlMigrationScriptHandOff type exposes the following members.

Constructors

Name | Description
SqlCompareSqlSourceControlMigrationScriptHandOff | Overloaded.

Methods

Name | Description
Deserialize |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Read |
Serialize |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConnectionProperties |
FileName |
FromVersion |
ToVersion |
Version |

See Also

SqlCompareSqlSourceControlMigrationScriptHandOff Class
RedGate.SQLCompare.Engine.Migrations Namespace


SqlCompareSqlSourceControlMigrationScriptHandOff Constructor

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareSqlSourceControlMigrationScriptHandOff Constructor
SqlCompareSqlSourceControlMigrationScriptHandOff Class See Also

Overload List

Name | Description
SqlCompareSqlSourceControlMigrationScriptHandOff()()() | Solely for the use of IRedGateSerializable
SqlCompareSqlSourceControlMigrationScriptHandOff(ConnectionProperties, String, Int64, Int64, String) |

See Also

SqlCompareSqlSourceControlMigrationScriptHandOff Class
SqlCompareSqlSourceControlMigrationScriptHandOff Members
RedGate.SQLCompare.Engine.Migrations Namespace


SqlCompareSqlSourceControlMigrationScriptHandOff Constructor

[image]

SQL Data Compare API 12.0.40
SqlCompareSqlSourceControlMigrationScriptHandOff Constructor
SqlCompareSqlSourceControlMigrationScriptHandOff Class See Also

Solely for the use of IRedGateSerializable

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlCompareSqlSourceControlMigrationScriptHandOff()
Visual C++
public:
SqlCompareSqlSourceControlMigrationScriptHandOff()

See Also

SqlCompareSqlSourceControlMigrationScriptHandOff Class
SqlCompareSqlSourceControlMigrationScriptHandOff Overload
RedGate.SQLCompare.Engine.Migrations Namespace
IRedGateSerializable


SqlCompareSqlSourceControlMigrationScriptHandOff Constructor (ConnectionProperties, , , , )

[image]

SQL Data Compare API 12.0.40
SqlCompareSqlSourceControlMigrationScriptHandOff Constructor (ConnectionProperties, , , , )
SqlCompareSqlSourceControlMigrationScriptHandOff Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    connectionProperties As ConnectionProperties, _
    serverAndInstanceName As String, _
    fromVersion As Long, _
    toVersion As Long, _
    fileName As String _
)
C#
public SqlCompareSqlSourceControlMigrationScriptHandOff(
    ConnectionProperties connectionProperties,
    string serverAndInstanceName,
    long fromVersion,
    long toVersion,
    string fileName
)
Visual C++
public:
SqlCompareSqlSourceControlMigrationScriptHandOff(
    ConnectionProperties^ connectionProperties,
    String^ serverAndInstanceName,
    long long fromVersion,
    long long toVersion,
    String^ fileName
)

Parameters

connectionProperties
Type: RedGate.SQLCompare.Engine..::.ConnectionProperties
serverAndInstanceName
Type: String
fromVersion
Type: Int64
toVersion
Type: Int64
fileName
Type: String

See Also

SqlCompareSqlSourceControlMigrationScriptHandOff Class
SqlCompareSqlSourceControlMigrationScriptHandOff Overload
RedGate.SQLCompare.Engine.Migrations Namespace


SqlCompareSqlSourceControlMigrationScriptHandOff Methods

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareSqlSourceControlMigrationScriptHandOff Methods
SqlCompareSqlSourceControlMigrationScriptHandOff Class See Also

The SqlCompareSqlSourceControlMigrationScriptHandOff type exposes the following methods.

Methods

Name | Description
Deserialize |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Read |
Serialize |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlCompareSqlSourceControlMigrationScriptHandOff Class
RedGate.SQLCompare.Engine.Migrations Namespace


Deserialize Method

[image]

SQL Data Compare API 12.0.40
SqlCompareSqlSourceControlMigrationScriptHandOff..::.Deserialize Method
SqlCompareSqlSourceControlMigrationScriptHandOff Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Deserialize ( _
    versionId As Integer, _
    formatter As ISerializeFormatter _
) As Boolean
C#
public bool Deserialize(
    int versionId,
    ISerializeFormatter formatter
)
Visual C++
public:
virtual bool Deserialize(
    int versionId,
    ISerializeFormatter^ formatter
) sealed

Parameters

versionId
Type: Int32
formatter
Type: ISerializeFormatter

See Also

SqlCompareSqlSourceControlMigrationScriptHandOff Class
RedGate.SQLCompare.Engine.Migrations Namespace


Read Method

[image]

SQL Data Compare API 12.0.40
SqlCompareSqlSourceControlMigrationScriptHandOff..::.Read Method
SqlCompareSqlSourceControlMigrationScriptHandOff Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Read ( _
    fileName As String _
) As SqlCompareSqlSourceControlMigrationScriptHandOff
C#
public static SqlCompareSqlSourceControlMigrationScriptHandOff Read(
    string fileName
)
Visual C++
public:
static SqlCompareSqlSourceControlMigrationScriptHandOff^ Read(
    String^ fileName
)

Parameters

fileName
Type: String

See Also

SqlCompareSqlSourceControlMigrationScriptHandOff Class
RedGate.SQLCompare.Engine.Migrations Namespace


Serialize Method

[image]

SQL Data Compare API 12.0.40
SqlCompareSqlSourceControlMigrationScriptHandOff..::.Serialize Method
SqlCompareSqlSourceControlMigrationScriptHandOff Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Serialize ( _
    formatter As ISerializeFormatter _
)
C#
public void Serialize(
    ISerializeFormatter formatter
)
Visual C++
public:
virtual void Serialize(
    ISerializeFormatter^ formatter
) sealed

Parameters

formatter
Type: ISerializeFormatter

See Also

SqlCompareSqlSourceControlMigrationScriptHandOff Class
RedGate.SQLCompare.Engine.Migrations Namespace


SqlCompareSqlSourceControlMigrationScriptHandOff Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlCompareSqlSourceControlMigrationScriptHandOff Properties
SqlCompareSqlSourceControlMigrationScriptHandOff Class See Also

The SqlCompareSqlSourceControlMigrationScriptHandOff type exposes the following properties.

Properties

Name | Description
ConnectionProperties |
FileName |
FromVersion |
ToVersion |
Version |

See Also

SqlCompareSqlSourceControlMigrationScriptHandOff Class
RedGate.SQLCompare.Engine.Migrations Namespace


ConnectionProperties Property

[image]

SQL Data Compare API 12.0.40
SqlCompareSqlSourceControlMigrationScriptHandOff..::.ConnectionProperties Property
SqlCompareSqlSourceControlMigrationScriptHandOff Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ConnectionProperties As ConnectionProperties
C#
public ConnectionProperties ConnectionProperties { get; private set; }
Visual C++
public:
property ConnectionProperties^ ConnectionProperties {
    ConnectionProperties^ get ();
    void set (ConnectionProperties^ value);
}

See Also

SqlCompareSqlSourceControlMigrationScriptHandOff Class
RedGate.SQLCompare.Engine.Migrations Namespace


FileName Property

[image]

SQL Data Compare API 12.0.40
SqlCompareSqlSourceControlMigrationScriptHandOff..::.FileName Property
SqlCompareSqlSourceControlMigrationScriptHandOff Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FileName As String
C#
public string FileName { get; private set; }
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlCompareSqlSourceControlMigrationScriptHandOff Class
RedGate.SQLCompare.Engine.Migrations Namespace


FromVersion Property

[image]

SQL Data Compare API 12.0.40
SqlCompareSqlSourceControlMigrationScriptHandOff..::.FromVersion Property
SqlCompareSqlSourceControlMigrationScriptHandOff Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FromVersion As Long
C#
public long FromVersion { get; private set; }
Visual C++
public:
property long long FromVersion {
    long long get ();
    void set (long long value);
}

See Also

SqlCompareSqlSourceControlMigrationScriptHandOff Class
RedGate.SQLCompare.Engine.Migrations Namespace


ToVersion Property

[image]

SQL Data Compare API 12.0.40
SqlCompareSqlSourceControlMigrationScriptHandOff..::.ToVersion Property
SqlCompareSqlSourceControlMigrationScriptHandOff Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ToVersion As Long
C#
public long ToVersion { get; private set; }
Visual C++
public:
property long long ToVersion {
    long long get ();
    void set (long long value);
}

See Also

SqlCompareSqlSourceControlMigrationScriptHandOff Class
RedGate.SQLCompare.Engine.Migrations Namespace


Version Property

[image]

SQL Data Compare API 12.0.40
SqlCompareSqlSourceControlMigrationScriptHandOff..::.Version Property
SqlCompareSqlSourceControlMigrationScriptHandOff Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As Integer
C#
public int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () sealed;
}

See Also

SqlCompareSqlSourceControlMigrationScriptHandOff Class
RedGate.SQLCompare.Engine.Migrations Namespace


StringScript Class

[image]

SQL Data Compare API 12.0.40
StringScript Class
Members See Also

Represents a SQL script created from a string

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class StringScript _
    Implements IScript
C#
public class StringScript : IScript
Visual C++
public ref class StringScript : IScript

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Migrations..::.StringScript

See Also

StringScript Members
RedGate.SQLCompare.Engine.Migrations Namespace


StringScript Members

[image] [image]

SQL Data Compare API 12.0.40
StringScript Members
StringScript Class Constructors Methods Properties See Also

The StringScript type exposes the following members.

Constructors

Name | Description
StringScript |

Methods

Name | Description
ContentEquals |
CopyFrom |
CopyTo |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetExecutionBlock |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Script |

See Also

StringScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


StringScript Constructor

[image]

SQL Data Compare API 12.0.40
StringScript Constructor
StringScript Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    script As String _
)
C#
public StringScript(
    string script
)
Visual C++
public:
StringScript(
    String^ script
)

Parameters

script
Type: String

See Also

StringScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


StringScript Methods

[image] [image]

SQL Data Compare API 12.0.40
StringScript Methods
StringScript Class See Also

The StringScript type exposes the following methods.

Methods

Name | Description
ContentEquals |
CopyFrom |
CopyTo |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetExecutionBlock |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StringScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


ContentEquals Method

[image]

SQL Data Compare API 12.0.40
StringScript..::.ContentEquals Method
StringScript Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function ContentEquals ( _
    other As IScript _
) As Boolean
C#
public bool ContentEquals(
    IScript other
)
Visual C++
public:
virtual bool ContentEquals(
    IScript^ other
) sealed

Parameters

other
Type: RedGate.SQLCompare.Engine.Migrations..::.IScript

Implements

IScript..::.ContentEquals(IScript)

See Also

StringScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


CopyFrom Method

[image]

SQL Data Compare API 12.0.40
StringScript..::.CopyFrom Method
StringScript Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyFrom ( _
    sourceScript As IScript _
)
C#
public void CopyFrom(
    IScript sourceScript
)
Visual C++
public:
virtual void CopyFrom(
    IScript^ sourceScript
) sealed

Parameters

sourceScript
Type: RedGate.SQLCompare.Engine.Migrations..::.IScript

Implements

IScript..::.CopyFrom(IScript)

See Also

StringScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


CopyTo Method

[image]

SQL Data Compare API 12.0.40
StringScript..::.CopyTo Method
StringScript Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyTo ( _
    targetPath As String _
)
C#
public void CopyTo(
    string targetPath
)
Visual C++
public:
virtual void CopyTo(
    String^ targetPath
) sealed

Parameters

targetPath
Type: String

Implements

IScript..::.CopyTo(String)

See Also

StringScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


GetExecutionBlock Method

[image]

SQL Data Compare API 12.0.40
StringScript..::.GetExecutionBlock Method
StringScript Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetExecutionBlock As IExecutionBlock
C#
public IExecutionBlock GetExecutionBlock()
Visual C++
public:
virtual IExecutionBlock^ GetExecutionBlock() sealed

Implements

IScript..::.GetExecutionBlock()()()

See Also

StringScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


StringScript Properties

[image] [image]

SQL Data Compare API 12.0.40
StringScript Properties
StringScript Class See Also

The StringScript type exposes the following properties.

Properties

Name | Description
Script |

See Also

StringScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


Script Property

[image]

SQL Data Compare API 12.0.40
StringScript..::.Script Property
StringScript Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Script As String
C#
public string Script { get; private set; }
Visual C++
public:
property String^ Script {
    String^ get ();
    void set (String^ value);
}

See Also

StringScript Class
RedGate.SQLCompare.Engine.Migrations Namespace


UnversionedMigrationsSynchronizer Class

[image]

SQL Data Compare API 12.0.40
UnversionedMigrationsSynchronizer Class
Members See Also

UnversionedMigrationsSynchronizer can synchronize a MigrationsComparisonResult that contains a single unversioned migrations script. Any migration scripts that have version will be ignored. Note: This will also mutate the SourceFolder

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class UnversionedMigrationsSynchronizer _
    Implements IExecutable(Of UnversionedMigrationsSynchronizerResult), ICancellable
C#
public class UnversionedMigrationsSynchronizer : IExecutable<UnversionedMigrationsSynchronizerResult>,
    ICancellable
Visual C++
public ref class UnversionedMigrationsSynchronizer : IExecutable<UnversionedMigrationsSynchronizerResult^>,
    ICancellable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Migrations..::.UnversionedMigrationsSynchronizer

See Also

UnversionedMigrationsSynchronizer Members
RedGate.SQLCompare.Engine.Migrations Namespace


UnversionedMigrationsSynchronizer Members

[image] [image]

SQL Data Compare API 12.0.40
UnversionedMigrationsSynchronizer Members
UnversionedMigrationsSynchronizer Class Constructors Methods Properties See Also

The UnversionedMigrationsSynchronizer type exposes the following members.

Constructors

Name | Description
UnversionedMigrationsSynchronizer |

Methods

Name | Description
CancelOperation |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Status |

See Also

UnversionedMigrationsSynchronizer Class
RedGate.SQLCompare.Engine.Migrations Namespace


UnversionedMigrationsSynchronizer Constructor

[image]

SQL Data Compare API 12.0.40
UnversionedMigrationsSynchronizer Constructor
UnversionedMigrationsSynchronizer Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    migrationsComparisonResult As MigrationsComparisonResult, _
    scriptComparisonResultToSynchronize As MigrationScriptComparisonResult, _
    fromVersion As VersionInfo, _
    toVersion As VersionInfo, _
    destSqlFilename As String _
)
C#
public UnversionedMigrationsSynchronizer(
    MigrationsComparisonResult migrationsComparisonResult,
    MigrationScriptComparisonResult scriptComparisonResultToSynchronize,
    VersionInfo fromVersion,
    VersionInfo toVersion,
    string destSqlFilename
)
Visual C++
public:
UnversionedMigrationsSynchronizer(
    MigrationsComparisonResult^ migrationsComparisonResult,
    MigrationScriptComparisonResult^ scriptComparisonResultToSynchronize,
    VersionInfo^ fromVersion,
    VersionInfo^ toVersion,
    String^ destSqlFilename
)

Parameters

migrationsComparisonResult
Type: RedGate.SQLCompare.Engine.Migrations..::.MigrationsComparisonResult
scriptComparisonResultToSynchronize
Type: RedGate.SQLCompare.Engine.Migrations..::.MigrationScriptComparisonResult
fromVersion
Type: RedGate.SQLCompare.Engine.Migrations..::.VersionInfo
toVersion
Type: RedGate.SQLCompare.Engine.Migrations..::.VersionInfo
destSqlFilename
Type: String

See Also

UnversionedMigrationsSynchronizer Class
RedGate.SQLCompare.Engine.Migrations Namespace


UnversionedMigrationsSynchronizer Methods

[image] [image]

SQL Data Compare API 12.0.40
UnversionedMigrationsSynchronizer Methods
UnversionedMigrationsSynchronizer Class See Also

The UnversionedMigrationsSynchronizer type exposes the following methods.

Methods

Name | Description
CancelOperation |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UnversionedMigrationsSynchronizer Class
RedGate.SQLCompare.Engine.Migrations Namespace


CancelOperation Method

[image]

SQL Data Compare API 12.0.40
UnversionedMigrationsSynchronizer..::.CancelOperation Method
UnversionedMigrationsSynchronizer Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelOperation
C#
public void CancelOperation()
Visual C++
public:
virtual void CancelOperation() sealed

Implements

ICancellable..::.CancelOperation()()()

See Also

UnversionedMigrationsSynchronizer Class
RedGate.SQLCompare.Engine.Migrations Namespace


Execute Method

[image]

SQL Data Compare API 12.0.40
UnversionedMigrationsSynchronizer..::.Execute Method
UnversionedMigrationsSynchronizer Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Execute As UnversionedMigrationsSynchronizerResult
C#
public UnversionedMigrationsSynchronizerResult Execute()
Visual C++
public:
virtual UnversionedMigrationsSynchronizerResult^ Execute() sealed

Implements

IExecutable<(Of <(TResult>)>)..::.Execute()()()

See Also

UnversionedMigrationsSynchronizer Class
RedGate.SQLCompare.Engine.Migrations Namespace


UnversionedMigrationsSynchronizer Properties

[image] [image]

SQL Data Compare API 12.0.40
UnversionedMigrationsSynchronizer Properties
UnversionedMigrationsSynchronizer Class See Also

The UnversionedMigrationsSynchronizer type exposes the following properties.

Properties

Name | Description
Status |

See Also

UnversionedMigrationsSynchronizer Class
RedGate.SQLCompare.Engine.Migrations Namespace


Status Property

[image]

SQL Data Compare API 12.0.40
UnversionedMigrationsSynchronizer..::.Status Property
UnversionedMigrationsSynchronizer Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

See Also

UnversionedMigrationsSynchronizer Class
RedGate.SQLCompare.Engine.Migrations Namespace


UnversionedMigrationsSynchronizerResult Class

[image]

SQL Data Compare API 12.0.40
UnversionedMigrationsSynchronizerResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class UnversionedMigrationsSynchronizerResult
C#
public class UnversionedMigrationsSynchronizerResult
Visual C++
public ref class UnversionedMigrationsSynchronizerResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Migrations..::.UnversionedMigrationsSynchronizerResult

See Also

UnversionedMigrationsSynchronizerResult Members
RedGate.SQLCompare.Engine.Migrations Namespace


UnversionedMigrationsSynchronizerResult Members

[image] [image]

SQL Data Compare API 12.0.40
UnversionedMigrationsSynchronizerResult Members
UnversionedMigrationsSynchronizerResult Class Methods Properties See Also

The UnversionedMigrationsSynchronizerResult type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AddedFiles |
FromVersion |
SourceFolderNewFilePath |
SourceFolderOldFilePath |
ToVersion |

See Also

UnversionedMigrationsSynchronizerResult Class
RedGate.SQLCompare.Engine.Migrations Namespace


UnversionedMigrationsSynchronizerResult Properties

[image] [image]

SQL Data Compare API 12.0.40
UnversionedMigrationsSynchronizerResult Properties
UnversionedMigrationsSynchronizerResult Class See Also

The UnversionedMigrationsSynchronizerResult type exposes the following properties.

Properties

Name | Description
AddedFiles |
FromVersion |
SourceFolderNewFilePath |
SourceFolderOldFilePath |
ToVersion |

See Also

UnversionedMigrationsSynchronizerResult Class
RedGate.SQLCompare.Engine.Migrations Namespace


AddedFiles Property

[image]

SQL Data Compare API 12.0.40
UnversionedMigrationsSynchronizerResult..::.AddedFiles Property
UnversionedMigrationsSynchronizerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AddedFiles As IEnumerable(Of String)
C#
public IEnumerable<string> AddedFiles { get; }
Visual C++
public:
property IEnumerable<String^>^ AddedFiles {
    IEnumerable<String^>^ get ();
}

See Also

UnversionedMigrationsSynchronizerResult Class
RedGate.SQLCompare.Engine.Migrations Namespace


FromVersion Property

[image]

SQL Data Compare API 12.0.40
UnversionedMigrationsSynchronizerResult..::.FromVersion Property
UnversionedMigrationsSynchronizerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FromVersion As VersionInfo
C#
public VersionInfo FromVersion { get; }
Visual C++
public:
property VersionInfo^ FromVersion {
    VersionInfo^ get ();
}

See Also

UnversionedMigrationsSynchronizerResult Class
RedGate.SQLCompare.Engine.Migrations Namespace


SourceFolderNewFilePath Property

[image]

SQL Data Compare API 12.0.40
UnversionedMigrationsSynchronizerResult..::.SourceFolderNewFilePath Property
UnversionedMigrationsSynchronizerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SourceFolderNewFilePath As String
C#
public string SourceFolderNewFilePath { get; }
Visual C++
public:
property String^ SourceFolderNewFilePath {
    String^ get ();
}

See Also

UnversionedMigrationsSynchronizerResult Class
RedGate.SQLCompare.Engine.Migrations Namespace


SourceFolderOldFilePath Property

[image]

SQL Data Compare API 12.0.40
UnversionedMigrationsSynchronizerResult..::.SourceFolderOldFilePath Property
UnversionedMigrationsSynchronizerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SourceFolderOldFilePath As String
C#
public string SourceFolderOldFilePath { get; }
Visual C++
public:
property String^ SourceFolderOldFilePath {
    String^ get ();
}

See Also

UnversionedMigrationsSynchronizerResult Class
RedGate.SQLCompare.Engine.Migrations Namespace


ToVersion Property

[image]

SQL Data Compare API 12.0.40
UnversionedMigrationsSynchronizerResult..::.ToVersion Property
UnversionedMigrationsSynchronizerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ToVersion As VersionInfo
C#
public VersionInfo ToVersion { get; }
Visual C++
public:
property VersionInfo^ ToVersion {
    VersionInfo^ get ();
}

See Also

UnversionedMigrationsSynchronizerResult Class
RedGate.SQLCompare.Engine.Migrations Namespace


VersionedDatabaseNameFormatter Class

[image]

SQL Data Compare API 12.0.40
VersionedDatabaseNameFormatter Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class VersionedDatabaseNameFormatter
C#
public static class VersionedDatabaseNameFormatter
Visual C++
public ref class VersionedDatabaseNameFormatter abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Migrations..::.VersionedDatabaseNameFormatter

See Also

VersionedDatabaseNameFormatter Members
RedGate.SQLCompare.Engine.Migrations Namespace


VersionedDatabaseNameFormatter Members

[image] [image]

SQL Data Compare API 12.0.40
VersionedDatabaseNameFormatter Members
VersionedDatabaseNameFormatter Class Methods See Also

Methods

Name | Description
GetName | Overloaded.

See Also

VersionedDatabaseNameFormatter Class
RedGate.SQLCompare.Engine.Migrations Namespace


VersionedDatabaseNameFormatter Methods

[image] [image]

SQL Data Compare API 12.0.40
VersionedDatabaseNameFormatter Methods
VersionedDatabaseNameFormatter Class See Also

Methods

Name | Description
GetName | Overloaded.

See Also

VersionedDatabaseNameFormatter Class
RedGate.SQLCompare.Engine.Migrations Namespace


GetName Method

[image] [image]

SQL Data Compare API 12.0.40
VersionedDatabaseNameFormatter..::.GetName Method
VersionedDatabaseNameFormatter Class See Also

Overload List

Name | Description
GetName(IDatabase) |
GetName(IDataSource) |

See Also

VersionedDatabaseNameFormatter Class
VersionedDatabaseNameFormatter Members
RedGate.SQLCompare.Engine.Migrations Namespace


GetName Method (IDatabase)

[image]

SQL Data Compare API 12.0.40
VersionedDatabaseNameFormatter..::.GetName Method (IDatabase)
VersionedDatabaseNameFormatter Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetName ( _
    database As IDatabase _
) As String
C#
public static string GetName(
    IDatabase database
)
Visual C++
public:
static String^ GetName(
    IDatabase^ database
)

Parameters

database
Type: RedGate.SQLCompare.Engine..::.IDatabase

See Also

VersionedDatabaseNameFormatter Class
GetName Overload
RedGate.SQLCompare.Engine.Migrations Namespace


GetName Method (IDataSource)

[image]

SQL Data Compare API 12.0.40
VersionedDatabaseNameFormatter..::.GetName Method (IDataSource)
VersionedDatabaseNameFormatter Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetName ( _
    dataSource As IDataSource _
) As String
C#
public static string GetName(
    IDataSource dataSource
)
Visual C++
public:
static String^ GetName(
    IDataSource^ dataSource
)

Parameters

dataSource
Type: RedGate.Shared.SQL..::.IDataSource

See Also

VersionedDatabaseNameFormatter Class
GetName Overload
RedGate.SQLCompare.Engine.Migrations Namespace


VersionedMigrationsSynchronizer Class

[image]

SQL Data Compare API 12.0.40
VersionedMigrationsSynchronizer Class
Members See Also

A synchronizer for migrations folders.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class VersionedMigrationsSynchronizer _
    Implements IExecutable, ICancellable
C#
public class VersionedMigrationsSynchronizer : IExecutable,
    ICancellable
Visual C++
public ref class VersionedMigrationsSynchronizer : IExecutable,
    ICancellable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Migrations..::.VersionedMigrationsSynchronizer

See Also

VersionedMigrationsSynchronizer Members
RedGate.SQLCompare.Engine.Migrations Namespace


VersionedMigrationsSynchronizer Members

[image] [image]

SQL Data Compare API 12.0.40
VersionedMigrationsSynchronizer Members
VersionedMigrationsSynchronizer Class Constructors Methods Properties See Also

The VersionedMigrationsSynchronizer type exposes the following members.

Constructors

Name | Description
VersionedMigrationsSynchronizer | Creates a migrations folder synchronizer.

Methods

Name | Description
CancelOperation | Cancels the comparison operation.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Execute the synchronization. Can only be called once.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Status | The StatusEventHandler used to update progress information.

See Also

VersionedMigrationsSynchronizer Class
RedGate.SQLCompare.Engine.Migrations Namespace


VersionedMigrationsSynchronizer Constructor

[image]

SQL Data Compare API 12.0.40
VersionedMigrationsSynchronizer Constructor
VersionedMigrationsSynchronizer Class See Also

Creates a migrations folder synchronizer.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    comparisonResult As MigrationsComparisonResult, _
    scriptComparisonResultsToSynchronize As IEnumerable(Of MigrationScriptComparisonResult) _
)
C#
public VersionedMigrationsSynchronizer(
    MigrationsComparisonResult comparisonResult,
    IEnumerable<MigrationScriptComparisonResult> scriptComparisonResultsToSynchronize
)
Visual C++
public:
VersionedMigrationsSynchronizer(
    MigrationsComparisonResult^ comparisonResult,
    IEnumerable<MigrationScriptComparisonResult^>^ scriptComparisonResultsToSynchronize
)

Parameters

comparisonResult
Type: RedGate.SQLCompare.Engine.Migrations..::.MigrationsComparisonResult
The migrations folder comparison result.
scriptComparisonResultsToSynchronize
Type: IEnumerable<(Of <( MigrationScriptComparisonResult >)>)
An enumerable collection of migration script comparison results to synchronize.

See Also

VersionedMigrationsSynchronizer Class
RedGate.SQLCompare.Engine.Migrations Namespace


VersionedMigrationsSynchronizer Methods

[image] [image]

SQL Data Compare API 12.0.40
VersionedMigrationsSynchronizer Methods
VersionedMigrationsSynchronizer Class See Also

The VersionedMigrationsSynchronizer type exposes the following methods.

Methods

Name | Description
CancelOperation | Cancels the comparison operation.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Execute the synchronization. Can only be called once.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VersionedMigrationsSynchronizer Class
RedGate.SQLCompare.Engine.Migrations Namespace


CancelOperation Method

[image]

SQL Data Compare API 12.0.40
VersionedMigrationsSynchronizer..::.CancelOperation Method
VersionedMigrationsSynchronizer Class See Also

Cancels the comparison operation.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelOperation
C#
public void CancelOperation()
Visual C++
public:
virtual void CancelOperation() sealed

Implements

ICancellable..::.CancelOperation()()()

See Also

VersionedMigrationsSynchronizer Class
RedGate.SQLCompare.Engine.Migrations Namespace


Execute Method

[image]

SQL Data Compare API 12.0.40
VersionedMigrationsSynchronizer..::.Execute Method
VersionedMigrationsSynchronizer Class See Also

Execute the synchronization. Can only be called once.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Execute
C#
public void Execute()
Visual C++
public:
virtual void Execute() sealed

Implements

IExecutable..::.Execute()()()

See Also

VersionedMigrationsSynchronizer Class
RedGate.SQLCompare.Engine.Migrations Namespace


VersionedMigrationsSynchronizer Properties

[image] [image]

SQL Data Compare API 12.0.40
VersionedMigrationsSynchronizer Properties
VersionedMigrationsSynchronizer Class See Also

The VersionedMigrationsSynchronizer type exposes the following properties.

Properties

Name | Description
Status | The StatusEventHandler used to update progress information.

See Also

VersionedMigrationsSynchronizer Class
RedGate.SQLCompare.Engine.Migrations Namespace


Status Property

[image]

SQL Data Compare API 12.0.40
VersionedMigrationsSynchronizer..::.Status Property
VersionedMigrationsSynchronizer Class See Also

The StatusEventHandler used to update progress information.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

See Also

VersionedMigrationsSynchronizer Class
RedGate.SQLCompare.Engine.Migrations Namespace


VersionedSynchronizationPlan Class

[image]

SQL Data Compare API 12.0.40
VersionedSynchronizationPlan Class
Members See Also

A versioned synchronization plan to be used as input to VersionedWork.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class VersionedSynchronizationPlan
C#
public class VersionedSynchronizationPlan
Visual C++
public ref class VersionedSynchronizationPlan

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Migrations..::.VersionedSynchronizationPlan

See Also

VersionedSynchronizationPlan Members
RedGate.SQLCompare.Engine.Migrations Namespace


VersionedSynchronizationPlan Members

[image] [image]

SQL Data Compare API 12.0.40
VersionedSynchronizationPlan Members
VersionedSynchronizationPlan Class Methods Properties See Also

The VersionedSynchronizationPlan type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FromVersion | The version from which the plan should be used.
MigrationScripts | Returns a list of all migration scripts used within the plan.
PlanItems | A read-only collection of plan items.
ToVersion | The version to which the plan should be used.

See Also

VersionedSynchronizationPlan Class
RedGate.SQLCompare.Engine.Migrations Namespace


VersionedSynchronizationPlan Properties

[image] [image]

SQL Data Compare API 12.0.40
VersionedSynchronizationPlan Properties
VersionedSynchronizationPlan Class See Also

The VersionedSynchronizationPlan type exposes the following properties.

Properties

Name | Description
FromVersion | The version from which the plan should be used.
MigrationScripts | Returns a list of all migration scripts used within the plan.
PlanItems | A read-only collection of plan items.
ToVersion | The version to which the plan should be used.

See Also

VersionedSynchronizationPlan Class
RedGate.SQLCompare.Engine.Migrations Namespace


FromVersion Property

[image]

SQL Data Compare API 12.0.40
VersionedSynchronizationPlan..::.FromVersion Property
VersionedSynchronizationPlan Class See Also

The version from which the plan should be used.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FromVersion As VersionInfo
C#
public VersionInfo FromVersion { get; private set; }
Visual C++
public:
property VersionInfo^ FromVersion {
    VersionInfo^ get ();
    void set (VersionInfo^ value);
}

See Also

VersionedSynchronizationPlan Class
RedGate.SQLCompare.Engine.Migrations Namespace


MigrationScripts Property

[image]

SQL Data Compare API 12.0.40
VersionedSynchronizationPlan..::.MigrationScripts Property
VersionedSynchronizationPlan Class See Also

Returns a list of all migration scripts used within the plan.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MigrationScripts As List(Of MigrationScript)
C#
public List<MigrationScript> MigrationScripts { get; }
Visual C++
public:
property List<MigrationScript^>^ MigrationScripts {
    List<MigrationScript^>^ get ();
}

See Also

VersionedSynchronizationPlan Class
RedGate.SQLCompare.Engine.Migrations Namespace


PlanItems Property

[image]

SQL Data Compare API 12.0.40
VersionedSynchronizationPlan..::.PlanItems Property
VersionedSynchronizationPlan Class See Also

A read-only collection of plan items.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PlanItems As ReadOnlyCollection(Of VersionedSynchronizationPlanItem)
C#
public ReadOnlyCollection<VersionedSynchronizationPlanItem> PlanItems { get; private set; }
Visual C++
public:
property ReadOnlyCollection<VersionedSynchronizationPlanItem^>^ PlanItems {
    ReadOnlyCollection<VersionedSynchronizationPlanItem^>^ get ();
    void set (ReadOnlyCollection<VersionedSynchronizationPlanItem^>^ value);
}

See Also

VersionedSynchronizationPlan Class
RedGate.SQLCompare.Engine.Migrations Namespace


ToVersion Property

[image]

SQL Data Compare API 12.0.40
VersionedSynchronizationPlan..::.ToVersion Property
VersionedSynchronizationPlan Class See Also

The version to which the plan should be used.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ToVersion As VersionInfo
C#
public VersionInfo ToVersion { get; private set; }
Visual C++
public:
property VersionInfo^ ToVersion {
    VersionInfo^ get ();
    void set (VersionInfo^ value);
}

See Also

VersionedSynchronizationPlan Class
RedGate.SQLCompare.Engine.Migrations Namespace


VersionedSynchronizationPlanItem Class

[image]

SQL Data Compare API 12.0.40
VersionedSynchronizationPlanItem Class
Members See Also

An item within a versioned synchronization plan.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class VersionedSynchronizationPlanItem
C#
public class VersionedSynchronizationPlanItem
Visual C++
public ref class VersionedSynchronizationPlanItem

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Migrations..::.VersionedSynchronizationPlanItem

See Also

VersionedSynchronizationPlanItem Members
RedGate.SQLCompare.Engine.Migrations Namespace


VersionedSynchronizationPlanItem Members

[image] [image]

SQL Data Compare API 12.0.40
VersionedSynchronizationPlanItem Members
VersionedSynchronizationPlanItem Class Constructors Methods Properties See Also

The VersionedSynchronizationPlanItem type exposes the following members.

Constructors

Name | Description
VersionedSynchronizationPlanItem | Returns a new VersionedSynchronizationPlanItem instance.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FromVersion | The version from which this plan item corresponds. A null value represents the target database.
Script | The migration script to use as part of this plan item. This can be null, if a regular compare and script is to be performed.
ToVersion | The version to which this plan item corresponds.

See Also

VersionedSynchronizationPlanItem Class
RedGate.SQLCompare.Engine.Migrations Namespace


VersionedSynchronizationPlanItem Constructor

[image]

SQL Data Compare API 12.0.40
VersionedSynchronizationPlanItem Constructor
VersionedSynchronizationPlanItem Class See Also

Returns a new VersionedSynchronizationPlanItem instance.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fromVersion As VersionInfo, _
    toVersion As VersionInfo, _
    script As MigrationScript _
)
C#
public VersionedSynchronizationPlanItem(
    VersionInfo fromVersion,
    VersionInfo toVersion,
    MigrationScript script
)
Visual C++
public:
VersionedSynchronizationPlanItem(
    VersionInfo^ fromVersion,
    VersionInfo^ toVersion,
    MigrationScript^ script
)

Parameters

fromVersion
Type: RedGate.SQLCompare.Engine.Migrations..::.VersionInfo
The from version of this plan item. This can be null, to represent using the target database.
toVersion
Type: RedGate.SQLCompare.Engine.Migrations..::.VersionInfo
>The to version of this plan item. This can be null, to represent using the source database.
script
Type: RedGate.SQLCompare.Engine.Migrations..::.MigrationScript
The migration script to use as part of this plan item. This can be null, if a regular compare and script is to be performed.

See Also

VersionedSynchronizationPlanItem Class
RedGate.SQLCompare.Engine.Migrations Namespace


VersionedSynchronizationPlanItem Properties

[image] [image]

SQL Data Compare API 12.0.40
VersionedSynchronizationPlanItem Properties
VersionedSynchronizationPlanItem Class See Also

The VersionedSynchronizationPlanItem type exposes the following properties.

Properties

Name | Description
FromVersion | The version from which this plan item corresponds. A null value represents the target database.
Script | The migration script to use as part of this plan item. This can be null, if a regular compare and script is to be performed.
ToVersion | The version to which this plan item corresponds.

See Also

VersionedSynchronizationPlanItem Class
RedGate.SQLCompare.Engine.Migrations Namespace


FromVersion Property

[image]

SQL Data Compare API 12.0.40
VersionedSynchronizationPlanItem..::.FromVersion Property
VersionedSynchronizationPlanItem Class See Also

The version from which this plan item corresponds. A null value represents the target database.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FromVersion As VersionInfo
C#
public VersionInfo FromVersion { get; }
Visual C++
public:
property VersionInfo^ FromVersion {
    VersionInfo^ get ();
}

See Also

VersionedSynchronizationPlanItem Class
RedGate.SQLCompare.Engine.Migrations Namespace


Script Property

[image]

SQL Data Compare API 12.0.40
VersionedSynchronizationPlanItem..::.Script Property
VersionedSynchronizationPlanItem Class See Also

The migration script to use as part of this plan item. This can be null, if a regular compare and script is to be performed.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Script As MigrationScript
C#
public MigrationScript Script { get; }
Visual C++
public:
property MigrationScript^ Script {
    MigrationScript^ get ();
}

See Also

VersionedSynchronizationPlanItem Class
RedGate.SQLCompare.Engine.Migrations Namespace


ToVersion Property

[image]

SQL Data Compare API 12.0.40
VersionedSynchronizationPlanItem..::.ToVersion Property
VersionedSynchronizationPlanItem Class See Also

The version to which this plan item corresponds.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ToVersion As VersionInfo
C#
public VersionInfo ToVersion { get; }
Visual C++
public:
property VersionInfo^ ToVersion {
    VersionInfo^ get ();
}

See Also

VersionedSynchronizationPlanItem Class
RedGate.SQLCompare.Engine.Migrations Namespace


VersionedSynchronizationPlanner Class

[image]

SQL Data Compare API 12.0.40
VersionedSynchronizationPlanner Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class VersionedSynchronizationPlanner
C#
public static class VersionedSynchronizationPlanner
Visual C++
public ref class VersionedSynchronizationPlanner abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Migrations..::.VersionedSynchronizationPlanner

See Also

VersionedSynchronizationPlanner Members
RedGate.SQLCompare.Engine.Migrations Namespace


VersionedSynchronizationPlanner Members

[image] [image]

SQL Data Compare API 12.0.40
VersionedSynchronizationPlanner Members
VersionedSynchronizationPlanner Class Methods See Also

The VersionedSynchronizationPlanner type exposes the following members.

Methods

Name | Description
GetPlan | Returns the optimal versioned synchronization plan, for the specified set of migration scripts and versions.

See Also

VersionedSynchronizationPlanner Class
RedGate.SQLCompare.Engine.Migrations Namespace


VersionedSynchronizationPlanner Methods

[image] [image]

SQL Data Compare API 12.0.40
VersionedSynchronizationPlanner Methods
VersionedSynchronizationPlanner Class See Also

The VersionedSynchronizationPlanner type exposes the following methods.

Methods

Name | Description
GetPlan | Returns the optimal versioned synchronization plan, for the specified set of migration scripts and versions.

See Also

VersionedSynchronizationPlanner Class
RedGate.SQLCompare.Engine.Migrations Namespace


GetPlan Method

[image]

SQL Data Compare API 12.0.40
VersionedSynchronizationPlanner..::.GetPlan Method
VersionedSynchronizationPlanner Class See Also

Returns the optimal versioned synchronization plan, for the specified set of migration scripts and versions.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetPlan ( _
    fromVersion As VersionInfo, _
    toVersion As VersionInfo, _
    migScripts As IEnumerable(Of MigrationScript), _
    toLiveDb As Boolean _
) As VersionedSynchronizationPlan
C#
public static VersionedSynchronizationPlan GetPlan(
    VersionInfo fromVersion,
    VersionInfo toVersion,
    IEnumerable<MigrationScript> migScripts,
    bool toLiveDb
)
Visual C++
public:
static VersionedSynchronizationPlan^ GetPlan(
    VersionInfo^ fromVersion,
    VersionInfo^ toVersion,
    IEnumerable<MigrationScript^>^ migScripts,
    bool toLiveDb
)

Parameters

fromVersion
Type: RedGate.SQLCompare.Engine.Migrations..::.VersionInfo
The version from which to generate a synchronization plan. Can be null.
toVersion
Type: RedGate.SQLCompare.Engine.Migrations..::.VersionInfo
The version to which to generate a synchronization plan.
migScripts
Type: IEnumerable<(Of <( MigrationScript >)>)
An enumerable collection of migration scripts between from and to versions. If fromVersion is null, then provide all migration scripts from revision 0.
toLiveDb
Type: Boolean

See Also

VersionedSynchronizationPlanner Class
RedGate.SQLCompare.Engine.Migrations Namespace


VersionedWork Class

[image]

SQL Data Compare API 12.0.40
VersionedWork Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class VersionedWork _
    Implements IWork, ICancellable
C#
public class VersionedWork : IWork,
    ICancellable
Visual C++
public ref class VersionedWork : IWork,
    ICancellable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Migrations..::.VersionedWork

See Also

VersionedWork Members
RedGate.SQLCompare.Engine.Migrations Namespace


VersionedWork Members

[image] [image]

SQL Data Compare API 12.0.40
VersionedWork Members
VersionedWork Class Constructors Methods Properties Explicit Interface Implementations See Also

The VersionedWork type exposes the following members.

Constructors

Name | Description
VersionedWork | Overloaded.

Methods

Name | Description
BuildFromDifferences |
CancelOperation |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasDatabaseDrifted |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ProcessDifferences |
SetImplicitlySelectedDifferences |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BackupOptions |
CanRollBackOnFailure |
Dependencies |
DependenciesHaveBeenCalculated |
ExecutionBlock |
Messages |
Plan |
StaticDataInsertPosition | For internal use only.
Status |
TransactionIsolationLevel |
Warnings |

Explicit Interface Implementations

Name | Description
IWork..::.BuildFromDifferences |
IWork..::.BuildFromDifferences |
IWork..::.BuildFromDifferences |
IWork..::.GenerateFolderSynchronizationActions |
IWork..::.GenerateSql |
IWork..::.ScriptObject |
IWork..::.ScriptSynchronizationActions |

See Also

VersionedWork Class
RedGate.SQLCompare.Engine.Migrations Namespace


VersionedWork Constructor

[image] [image]

SQL Data Compare API 12.0.40
VersionedWork Constructor
VersionedWork Class See Also

Overload List

Name | Description
VersionedWork(IVersionedDatabaseProvider, VersionedSynchronizationPlan) |
VersionedWork(IVersionedDatabaseProvider, VersionedSynchronizationPlan, IEnumerable<(Of <(ObjectIdentifier>)>)) |

See Also

VersionedWork Class
VersionedWork Members
RedGate.SQLCompare.Engine.Migrations Namespace


VersionedWork Constructor (IVersionedDatabaseProvider, VersionedSynchronizationPlan)

[image]

SQL Data Compare API 12.0.40
VersionedWork Constructor (IVersionedDatabaseProvider, VersionedSynchronizationPlan)
VersionedWork Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    versionedDatabaseProvider As IVersionedDatabaseProvider, _
    versionedSynchronizationPlan As VersionedSynchronizationPlan _
)
C#
public VersionedWork(
    IVersionedDatabaseProvider versionedDatabaseProvider,
    VersionedSynchronizationPlan versionedSynchronizationPlan
)
Visual C++
public:
VersionedWork(
    IVersionedDatabaseProvider^ versionedDatabaseProvider,
    VersionedSynchronizationPlan^ versionedSynchronizationPlan
)

Parameters

versionedDatabaseProvider
Type: RedGate.SQLCompare.Engine.Migrations..::.IVersionedDatabaseProvider
versionedSynchronizationPlan
Type: RedGate.SQLCompare.Engine.Migrations..::.VersionedSynchronizationPlan

See Also

VersionedWork Class
VersionedWork Overload
RedGate.SQLCompare.Engine.Migrations Namespace


VersionedWork Constructor (IVersionedDatabaseProvider, VersionedSynchronizationPlan, (ObjectIdentifier))

[image]

SQL Data Compare API 12.0.40
VersionedWork Constructor (IVersionedDatabaseProvider, VersionedSynchronizationPlan, <(Of <(ObjectIdentifier>)>))
VersionedWork Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    versionedDatabaseProvider As IVersionedDatabaseProvider, _
    versionedSynchronizationPlan As VersionedSynchronizationPlan, _
    objectsToExclude As IEnumerable(Of ObjectIdentifier) _
)
C#
public VersionedWork(
    IVersionedDatabaseProvider versionedDatabaseProvider,
    VersionedSynchronizationPlan versionedSynchronizationPlan,
    IEnumerable<ObjectIdentifier> objectsToExclude
)
Visual C++
public:
VersionedWork(
    IVersionedDatabaseProvider^ versionedDatabaseProvider,
    VersionedSynchronizationPlan^ versionedSynchronizationPlan,
    IEnumerable<ObjectIdentifier>^ objectsToExclude
)

Parameters

versionedDatabaseProvider
Type: RedGate.SQLCompare.Engine.Migrations..::.IVersionedDatabaseProvider
versionedSynchronizationPlan
Type: RedGate.SQLCompare.Engine.Migrations..::.VersionedSynchronizationPlan
objectsToExclude
Type: IEnumerable<(Of <( ObjectIdentifier >)>)

See Also

VersionedWork Class
VersionedWork Overload
RedGate.SQLCompare.Engine.Migrations Namespace


VersionedWork Methods

[image] [image]

SQL Data Compare API 12.0.40
VersionedWork Methods
VersionedWork Class See Also

The VersionedWork type exposes the following methods.

Methods

Name | Description
BuildFromDifferences |
CancelOperation |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasDatabaseDrifted |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ProcessDifferences |
SetImplicitlySelectedDifferences |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IWork..::.BuildFromDifferences |
IWork..::.BuildFromDifferences |
IWork..::.BuildFromDifferences |
IWork..::.GenerateFolderSynchronizationActions |
IWork..::.GenerateSql |
IWork..::.ScriptObject |

See Also

VersionedWork Class
RedGate.SQLCompare.Engine.Migrations Namespace


BuildFromDifferences Method

[image]

SQL Data Compare API 12.0.40
VersionedWork..::.BuildFromDifferences Method
VersionedWork Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub BuildFromDifferences ( _
    differences As Differences, _
    options As Options, _
    runOnTwo As Boolean _
)
C#
public void BuildFromDifferences(
    Differences differences,
    Options options,
    bool runOnTwo
)
Visual C++
public:
virtual void BuildFromDifferences(
    Differences^ differences,
    Options options,
    bool runOnTwo
) sealed

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
options
Type: RedGate.SQLCompare.Engine..::.Options
runOnTwo
Type: Boolean

Implements

IWork..::.BuildFromDifferences(Differences, Options, Boolean)

See Also

VersionedWork Class
RedGate.SQLCompare.Engine.Migrations Namespace


IWork.BuildFromDifferences Method

[image]

SQL Data Compare API 12.0.40
VersionedWork..::.IWork..::.BuildFromDifferences Method
VersionedWork Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub BuildFromDifferences ( _
    differences As Differences, _
    onlyDifferenceToInclude As Difference, _
    options As Options, _
    runOnTwo As Boolean _
) Implements IWork.BuildFromDifferences
C#
void IWork.BuildFromDifferences(
    Differences differences,
    Difference onlyDifferenceToInclude,
    Options options,
    bool runOnTwo
)
Visual C++
private:
virtual void BuildFromDifferences(
    Differences^ differences,
    Difference^ onlyDifferenceToInclude,
    Options options,
    bool runOnTwo
) sealed = IWork::BuildFromDifferences

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
onlyDifferenceToInclude
Type: RedGate.SQLCompare.Engine..::.Difference
options
Type: RedGate.SQLCompare.Engine..::.Options
runOnTwo
Type: Boolean

Implements

IWork..::.BuildFromDifferences(Differences, Difference, Options, Boolean)

See Also

VersionedWork Class
RedGate.SQLCompare.Engine.Migrations Namespace


IWork.BuildFromDifferences Method

[image]

SQL Data Compare API 12.0.40
VersionedWork..::.IWork..::.BuildFromDifferences Method
VersionedWork Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub BuildFromDifferences ( _
    differences As Differences, _
    onlyDifferenceToInclude As Difference, _
    options As Options, _
    runOnTwo As Boolean, _
    dbInfo As ScriptDatabaseInformation, _
    generator As IFileNameGenerator _
) Implements IWork.BuildFromDifferences
C#
void IWork.BuildFromDifferences(
    Differences differences,
    Difference onlyDifferenceToInclude,
    Options options,
    bool runOnTwo,
    ScriptDatabaseInformation dbInfo,
    IFileNameGenerator generator
)
Visual C++
private:
virtual void BuildFromDifferences(
    Differences^ differences,
    Difference^ onlyDifferenceToInclude,
    Options options,
    bool runOnTwo,
    ScriptDatabaseInformation^ dbInfo,
    IFileNameGenerator^ generator
) sealed = IWork::BuildFromDifferences

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
onlyDifferenceToInclude
Type: RedGate.SQLCompare.Engine..::.Difference
options
Type: RedGate.SQLCompare.Engine..::.Options
runOnTwo
Type: Boolean
dbInfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
generator
Type: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser..::.IFileNameGenerator

Implements

IWork..::.BuildFromDifferences(Differences, Difference, Options, Boolean, ScriptDatabaseInformation, IFileNameGenerator)

See Also

VersionedWork Class
RedGate.SQLCompare.Engine.Migrations Namespace


IWork.BuildFromDifferences Method

[image]

SQL Data Compare API 12.0.40
VersionedWork..::.IWork..::.BuildFromDifferences Method
VersionedWork Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub BuildFromDifferences ( _
    differences As Differences, _
    options As Options, _
    runOnTwo As Boolean, _
    dbInfo As ScriptDatabaseInformation _
) Implements IWork.BuildFromDifferences
C#
void IWork.BuildFromDifferences(
    Differences differences,
    Options options,
    bool runOnTwo,
    ScriptDatabaseInformation dbInfo
)
Visual C++
private:
virtual void BuildFromDifferences(
    Differences^ differences,
    Options options,
    bool runOnTwo,
    ScriptDatabaseInformation^ dbInfo
) sealed = IWork::BuildFromDifferences

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
options
Type: RedGate.SQLCompare.Engine..::.Options
runOnTwo
Type: Boolean
dbInfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation

Implements

IWork..::.BuildFromDifferences(Differences, Options, Boolean, ScriptDatabaseInformation)

See Also

VersionedWork Class
RedGate.SQLCompare.Engine.Migrations Namespace


CancelOperation Method

[image]

SQL Data Compare API 12.0.40
VersionedWork..::.CancelOperation Method
VersionedWork Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelOperation
C#
public void CancelOperation()
Visual C++
public:
virtual void CancelOperation() sealed

Implements

ICancellable..::.CancelOperation()()()

See Also

VersionedWork Class
RedGate.SQLCompare.Engine.Migrations Namespace


IWork.GenerateFolderSynchronizationActions Method

[image]

SQL Data Compare API 12.0.40
VersionedWork..::.IWork..::.GenerateFolderSynchronizationActions Method
VersionedWork Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub GenerateFolderSynchronizationActions ( _
    differences As Differences, _
    onlyDifferenceToInclude As Difference, _
    options As Options, _
    runOnTwo As Boolean, _
    dbInfo As ScriptDatabaseInformation, _
    generator As IFileNameGenerator _
) Implements IWork.GenerateFolderSynchronizationActions
C#
void IWork.GenerateFolderSynchronizationActions(
    Differences differences,
    Difference onlyDifferenceToInclude,
    Options options,
    bool runOnTwo,
    ScriptDatabaseInformation dbInfo,
    IFileNameGenerator generator
)
Visual C++
private:
virtual void GenerateFolderSynchronizationActions(
    Differences^ differences,
    Difference^ onlyDifferenceToInclude,
    Options options,
    bool runOnTwo,
    ScriptDatabaseInformation^ dbInfo,
    IFileNameGenerator^ generator
) sealed = IWork::GenerateFolderSynchronizationActions

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
onlyDifferenceToInclude
Type: RedGate.SQLCompare.Engine..::.Difference
options
Type: RedGate.SQLCompare.Engine..::.Options
runOnTwo
Type: Boolean
dbInfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
generator
Type: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser..::.IFileNameGenerator

Implements

IWork..::.GenerateFolderSynchronizationActions(Differences, Difference, Options, Boolean, ScriptDatabaseInformation, IFileNameGenerator)

See Also

VersionedWork Class
RedGate.SQLCompare.Engine.Migrations Namespace


IWork.GenerateSql Method

[image]

SQL Data Compare API 12.0.40
VersionedWork..::.IWork..::.GenerateSql Method
VersionedWork Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Sub GenerateSql ( _
    differences As Differences, _
    onlyDifferenceToInclude As Difference, _
    options As Options, _
    runOnTwo As Boolean _
) Implements IWork.GenerateSql
C#
void IWork.GenerateSql(
    Differences differences,
    Difference onlyDifferenceToInclude,
    Options options,
    bool runOnTwo
)
Visual C++
private:
virtual void GenerateSql(
    Differences^ differences,
    Difference^ onlyDifferenceToInclude,
    Options options,
    bool runOnTwo
) sealed = IWork::GenerateSql

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
onlyDifferenceToInclude
Type: RedGate.SQLCompare.Engine..::.Difference
options
Type: RedGate.SQLCompare.Engine..::.Options
runOnTwo
Type: Boolean

Implements

IWork..::.GenerateSql(Differences, Difference, Options, Boolean)

See Also

VersionedWork Class
RedGate.SQLCompare.Engine.Migrations Namespace


HasDatabaseDrifted Method

[image]

SQL Data Compare API 12.0.40
VersionedWork..::.HasDatabaseDrifted Method
VersionedWork Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function HasDatabaseDrifted ( _
    database As IDatabase, _
    options As Options _
) As Boolean
C#
public bool HasDatabaseDrifted(
    IDatabase database,
    Options options
)
Visual C++
public:
bool HasDatabaseDrifted(
    IDatabase^ database,
    Options options
)

Parameters

database
Type: RedGate.SQLCompare.Engine..::.IDatabase
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

VersionedWork Class
RedGate.SQLCompare.Engine.Migrations Namespace


ProcessDifferences Method

[image]

SQL Data Compare API 12.0.40
VersionedWork..::.ProcessDifferences Method
VersionedWork Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub ProcessDifferences ( _
    differences As Differences, _
    onlyDifferenceToInclude As Difference, _
    options As Options, _
    runOnTwo As Boolean _
)
C#
public void ProcessDifferences(
    Differences differences,
    Difference onlyDifferenceToInclude,
    Options options,
    bool runOnTwo
)
Visual C++
public:
virtual void ProcessDifferences(
    Differences^ differences,
    Difference^ onlyDifferenceToInclude,
    Options options,
    bool runOnTwo
) sealed

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
onlyDifferenceToInclude
Type: RedGate.SQLCompare.Engine..::.Difference
options
Type: RedGate.SQLCompare.Engine..::.Options
runOnTwo
Type: Boolean

Implements

IWork..::.ProcessDifferences(Differences, Difference, Options, Boolean)

See Also

VersionedWork Class
RedGate.SQLCompare.Engine.Migrations Namespace


IWork.ScriptObject Method

[image]

SQL Data Compare API 12.0.40
VersionedWork..::.IWork..::.ScriptObject Method
VersionedWork Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function ScriptObject ( _
    objectToScript As IDatabaseObject, _
    options As Options _
) As Regions Implements IWork.ScriptObject
C#
Regions IWork.ScriptObject(
    IDatabaseObject objectToScript,
    Options options
)
Visual C++
private:
virtual Regions^ ScriptObject(
    IDatabaseObject^ objectToScript,
    Options options
) sealed = IWork::ScriptObject

Parameters

objectToScript
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

IWork..::.ScriptObject(IDatabaseObject, Options)

See Also

VersionedWork Class
RedGate.SQLCompare.Engine.Migrations Namespace


SetImplicitlySelectedDifferences Method

[image]

SQL Data Compare API 12.0.40
VersionedWork..::.SetImplicitlySelectedDifferences Method
VersionedWork Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetImplicitlySelectedDifferences ( _
    differences As Differences _
)
C#
public void SetImplicitlySelectedDifferences(
    Differences differences
)
Visual C++
public:
virtual void SetImplicitlySelectedDifferences(
    Differences^ differences
) sealed

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences

Implements

IWork..::.SetImplicitlySelectedDifferences(Differences)

See Also

VersionedWork Class
RedGate.SQLCompare.Engine.Migrations Namespace


VersionedWork Properties

[image] [image]

SQL Data Compare API 12.0.40
VersionedWork Properties
VersionedWork Class See Also

The VersionedWork type exposes the following properties.

Properties

Name | Description
BackupOptions |
CanRollBackOnFailure |
Dependencies |
DependenciesHaveBeenCalculated |
ExecutionBlock |
Messages |
Plan |
StaticDataInsertPosition | For internal use only.
Status |
TransactionIsolationLevel |
Warnings |

Explicit Interface Implementations

Name | Description
IWork..::.ScriptSynchronizationActions |

See Also

VersionedWork Class
RedGate.SQLCompare.Engine.Migrations Namespace


BackupOptions Property

[image]

SQL Data Compare API 12.0.40
VersionedWork..::.BackupOptions Property
VersionedWork Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BackupOptions As BackupOptions
C#
public BackupOptions BackupOptions { get; set; }
Visual C++
public:
virtual property BackupOptions^ BackupOptions {
    BackupOptions^ get () sealed;
    void set (BackupOptions^ value) sealed;
}

Implements

IWork..::.BackupOptions

See Also

VersionedWork Class
RedGate.SQLCompare.Engine.Migrations Namespace


CanRollBackOnFailure Property

[image]

SQL Data Compare API 12.0.40
VersionedWork..::.CanRollBackOnFailure Property
VersionedWork Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanRollBackOnFailure As Boolean
C#
public bool CanRollBackOnFailure { get; }
Visual C++
public:
virtual property bool CanRollBackOnFailure {
    bool get () sealed;
}

Implements

IWork..::.CanRollBackOnFailure

See Also

VersionedWork Class
RedGate.SQLCompare.Engine.Migrations Namespace


Dependencies Property

[image]

SQL Data Compare API 12.0.40
VersionedWork..::.Dependencies Property
VersionedWork Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dependencies As IDictionary(Of Difference, Set(Of Difference))
C#
public IDictionary<Difference, Set<Difference>> Dependencies { get; }
Visual C++
public:
virtual property IDictionary<Difference^, Set<Difference^>^>^ Dependencies {
    IDictionary<Difference^, Set<Difference^>^>^ get () sealed;
}

Implements

IWork..::.Dependencies

See Also

VersionedWork Class
RedGate.SQLCompare.Engine.Migrations Namespace


DependenciesHaveBeenCalculated Property

[image]

SQL Data Compare API 12.0.40
VersionedWork..::.DependenciesHaveBeenCalculated Property
VersionedWork Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DependenciesHaveBeenCalculated As Boolean
C#
public bool DependenciesHaveBeenCalculated { get; private set; }
Visual C++
public:
virtual property bool DependenciesHaveBeenCalculated {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IWork..::.DependenciesHaveBeenCalculated

See Also

VersionedWork Class
RedGate.SQLCompare.Engine.Migrations Namespace


ExecutionBlock Property

[image]

SQL Data Compare API 12.0.40
VersionedWork..::.ExecutionBlock Property
VersionedWork Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExecutionBlock As IExecutionBlock
C#
public IExecutionBlock ExecutionBlock { get; }
Visual C++
public:
virtual property IExecutionBlock^ ExecutionBlock {
    IExecutionBlock^ get () sealed;
}

Implements

IWork..::.ExecutionBlock

See Also

VersionedWork Class
RedGate.SQLCompare.Engine.Migrations Namespace


Messages Property

[image]

SQL Data Compare API 12.0.40
VersionedWork..::.Messages Property
VersionedWork Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Messages As IEnumerable(Of IDeploymentMessage)
C#
public IEnumerable<IDeploymentMessage> Messages { get; }
Visual C++
public:
virtual property IEnumerable<IDeploymentMessage^>^ Messages {
    IEnumerable<IDeploymentMessage^>^ get () sealed;
}

Implements

IWork..::.Messages

See Also

VersionedWork Class
RedGate.SQLCompare.Engine.Migrations Namespace


Plan Property

[image]

SQL Data Compare API 12.0.40
VersionedWork..::.Plan Property
VersionedWork Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Plan As VersionedSynchronizationPlan
C#
public VersionedSynchronizationPlan Plan { get; }
Visual C++
public:
property VersionedSynchronizationPlan^ Plan {
    VersionedSynchronizationPlan^ get ();
}

See Also

VersionedWork Class
RedGate.SQLCompare.Engine.Migrations Namespace


IWork.ScriptSynchronizationActions Property

[image]

SQL Data Compare API 12.0.40
VersionedWork..::.IWork..::.ScriptSynchronizationActions Property
VersionedWork Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Property ScriptSynchronizationActions As ScriptSynchronizationActions
    Implements IWork.ScriptSynchronizationActions
C#
ScriptSynchronizationActions IWork.ScriptSynchronizationActions { get; set; }
Visual C++
private:
virtual property ScriptSynchronizationActions^ ScriptSynchronizationActions {
    ScriptSynchronizationActions^ get () sealed = IWork::ScriptSynchronizationActions::get;
    void set (ScriptSynchronizationActions^ value) sealed = IWork::ScriptSynchronizationActions::set;
}

Implements

IWork..::.ScriptSynchronizationActions

See Also

VersionedWork Class
RedGate.SQLCompare.Engine.Migrations Namespace


StaticDataInsertPosition Property

[image]

SQL Data Compare API 12.0.40
VersionedWork..::.StaticDataInsertPosition Property
VersionedWork Class See Also

For internal use only.

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StaticDataInsertPosition As Long
C#
public long StaticDataInsertPosition { get; }
Visual C++
public:
virtual property long long StaticDataInsertPosition {
    long long get () sealed;
}

Implements

IWork..::.StaticDataInsertPosition

See Also

VersionedWork Class
RedGate.SQLCompare.Engine.Migrations Namespace


Status Property

[image]

SQL Data Compare API 12.0.40
VersionedWork..::.Status Property
VersionedWork Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

See Also

VersionedWork Class
RedGate.SQLCompare.Engine.Migrations Namespace


TransactionIsolationLevel Property

[image]

SQL Data Compare API 12.0.40
VersionedWork..::.TransactionIsolationLevel Property
VersionedWork Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TransactionIsolationLevel As String
C#
public string TransactionIsolationLevel { get; set; }
Visual C++
public:
virtual property String^ TransactionIsolationLevel {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IWork..::.TransactionIsolationLevel

See Also

VersionedWork Class
RedGate.SQLCompare.Engine.Migrations Namespace


Warnings Property

[image]

SQL Data Compare API 12.0.40
VersionedWork..::.Warnings Property
VersionedWork Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Warnings As IEnumerable(Of IDeploymentMessage)
C#
public IEnumerable<IDeploymentMessage> Warnings { get; }
Visual C++
public:
virtual property IEnumerable<IDeploymentMessage^>^ Warnings {
    IEnumerable<IDeploymentMessage^>^ get () sealed;
}

Implements

IWork..::.Warnings

See Also

VersionedWork Class
RedGate.SQLCompare.Engine.Migrations Namespace


VersionInfo Class

[image]

SQL Data Compare API 12.0.40
VersionInfo Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class VersionInfo _
    Implements IEquatable(Of VersionInfo)
C#
public sealed class VersionInfo : IEquatable<VersionInfo>
Visual C++
public ref class VersionInfo sealed : IEquatable<VersionInfo^>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Migrations..::.VersionInfo

See Also

VersionInfo Members
RedGate.SQLCompare.Engine.Migrations Namespace


VersionInfo Members

[image] [image]

SQL Data Compare API 12.0.40
VersionInfo Members
VersionInfo Class Constructors Methods Properties See Also

The VersionInfo type exposes the following members.

Constructors

Name | Description
VersionInfo |

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Get |
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality |
Inequality |

Properties

Name | Description
ScriptFolderLocation |
Version |

See Also

VersionInfo Class
RedGate.SQLCompare.Engine.Migrations Namespace


VersionInfo Constructor

[image]

SQL Data Compare API 12.0.40
VersionInfo Constructor
VersionInfo Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    version As Long, _
    scriptFolderLocation As ISOCCompareLocation _
)
C#
public VersionInfo(
    long version,
    ISOCCompareLocation scriptFolderLocation
)
Visual C++
public:
VersionInfo(
    long long version,
    ISOCCompareLocation^ scriptFolderLocation
)

Parameters

version
Type: Int64
scriptFolderLocation
Type: ISOCCompareLocation

See Also

VersionInfo Class
RedGate.SQLCompare.Engine.Migrations Namespace


VersionInfo Methods

[image] [image]

SQL Data Compare API 12.0.40
VersionInfo Methods
VersionInfo Class See Also

The VersionInfo type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Get |
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality |
Inequality |

See Also

VersionInfo Class
RedGate.SQLCompare.Engine.Migrations Namespace


Equality Operator

[image]

SQL Data Compare API 12.0.40
VersionInfo..::.Equality Operator
VersionInfo Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator = ( _
    a As VersionInfo, _
    b As VersionInfo _
) As Boolean
C#
public static bool operator ==(
    VersionInfo a,
    VersionInfo b
)
Visual C++
public:
static bool operator ==(
    VersionInfo^ a,
    VersionInfo^ b
)

Parameters

a
Type: RedGate.SQLCompare.Engine.Migrations..::.VersionInfo
b
Type: RedGate.SQLCompare.Engine.Migrations..::.VersionInfo

See Also

VersionInfo Class
RedGate.SQLCompare.Engine.Migrations Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
VersionInfo..::.Equals Method
VersionInfo Class See Also

Overload List

Name | Description
Equals(Object) | (Overrides Object..::.Equals(Object).)
Equals(VersionInfo) |

See Also

VersionInfo Class
VersionInfo Members
RedGate.SQLCompare.Engine.Migrations Namespace


Equals Method ()

[image]

SQL Data Compare API 12.0.40
VersionInfo..::.Equals Method ()
VersionInfo Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object

See Also

VersionInfo Class
Equals Overload
RedGate.SQLCompare.Engine.Migrations Namespace


Equals Method (VersionInfo)

[image]

SQL Data Compare API 12.0.40
VersionInfo..::.Equals Method (VersionInfo)
VersionInfo Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    other As VersionInfo _
) As Boolean
C#
public bool Equals(
    VersionInfo other
)
Visual C++
public:
virtual bool Equals(
    VersionInfo^ other
) sealed

Parameters

other
Type: RedGate.SQLCompare.Engine.Migrations..::.VersionInfo

Implements

IEquatableEquals(UTP)

See Also

VersionInfo Class
Equals Overload
RedGate.SQLCompare.Engine.Migrations Namespace


Get Method

[image]

SQL Data Compare API 12.0.40
VersionInfo..::.Get Method
VersionInfo Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Get ( _
    version As Nullable(Of Long), _
    scriptFolderLocation As ISOCCompareLocation _
) As VersionInfo
C#
public static VersionInfo Get(
    Nullable<long> version,
    ISOCCompareLocation scriptFolderLocation
)
Visual C++
public:
static VersionInfo^ Get(
    Nullable<long long> version,
    ISOCCompareLocation^ scriptFolderLocation
)

Parameters

version
Type: Nullable<(Of <(Int64>)>)
scriptFolderLocation
Type: ISOCCompareLocation

See Also

VersionInfo Class
RedGate.SQLCompare.Engine.Migrations Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
VersionInfo..::.GetHashCode Method
VersionInfo Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

See Also

VersionInfo Class
RedGate.SQLCompare.Engine.Migrations Namespace


Inequality Operator

[image]

SQL Data Compare API 12.0.40
VersionInfo..::.Inequality Operator
VersionInfo Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <> ( _
    a As VersionInfo, _
    b As VersionInfo _
) As Boolean
C#
public static bool operator !=(
    VersionInfo a,
    VersionInfo b
)
Visual C++
public:
static bool operator !=(
    VersionInfo^ a,
    VersionInfo^ b
)

Parameters

a
Type: RedGate.SQLCompare.Engine.Migrations..::.VersionInfo
b
Type: RedGate.SQLCompare.Engine.Migrations..::.VersionInfo

See Also

VersionInfo Class
RedGate.SQLCompare.Engine.Migrations Namespace


VersionInfo Properties

[image] [image]

SQL Data Compare API 12.0.40
VersionInfo Properties
VersionInfo Class See Also

The VersionInfo type exposes the following properties.

Properties

Name | Description
ScriptFolderLocation |
Version |

See Also

VersionInfo Class
RedGate.SQLCompare.Engine.Migrations Namespace


ScriptFolderLocation Property

[image]

SQL Data Compare API 12.0.40
VersionInfo..::.ScriptFolderLocation Property
VersionInfo Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ScriptFolderLocation As ISOCCompareLocation
C#
public ISOCCompareLocation ScriptFolderLocation { get; }
Visual C++
public:
property ISOCCompareLocation^ ScriptFolderLocation {
    ISOCCompareLocation^ get ();
}

See Also

VersionInfo Class
RedGate.SQLCompare.Engine.Migrations Namespace


Version Property

[image]

SQL Data Compare API 12.0.40
VersionInfo..::.Version Property
VersionInfo Class See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As Long
C#
public long Version { get; }
Visual C++
public:
property long long Version {
    long long get ();
}

See Also

VersionInfo Class
RedGate.SQLCompare.Engine.Migrations Namespace


VersionType Enumeration

[image]

SQL Data Compare API 12.0.40
VersionType Enumeration
See Also

Namespace: RedGate.SQLCompare.Engine.Migrations
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration VersionType
C#
public enum VersionType
Visual C++
public enum class VersionType

Members

Member name | Description
Unversioned |
Latest |
Specific |

See Also

RedGate.SQLCompare.Engine.Migrations Namespace


RedGate.SQLCompare.Engine.Model Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.Model Namespace

Classes

Class | Description
DataCompressionPartitions |
EmptyDatabaseSource |
IndexField |

Interfaces

Interface | Description
ISqlComparable |


DataCompressionPartitions Class

[image]

SQL Data Compare API 12.0.40
DataCompressionPartitions Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataCompressionPartitions _
    Implements IDictionary(Of Integer, DataCompression), ICollection(Of KeyValuePair(Of Integer, DataCompression)),  _
    IEnumerable(Of KeyValuePair(Of Integer, DataCompression)), IEnumerable
C#
public sealed class DataCompressionPartitions : IDictionary<int, DataCompression>,
    ICollection<KeyValuePair<int, DataCompression>>, IEnumerable<KeyValuePair<int, DataCompression>>,
    IEnumerable
Visual C++
public ref class DataCompressionPartitions sealed : IDictionary<int, DataCompression>,
    ICollection<KeyValuePair<int, DataCompression>>, IEnumerable<KeyValuePair<int, DataCompression>>,
    IEnumerable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Model..::.DataCompressionPartitions

See Also

DataCompressionPartitions Members
RedGate.SQLCompare.Engine.Model Namespace


DataCompressionPartitions Members

[image] [image]

SQL Data Compare API 12.0.40
DataCompressionPartitions Members
DataCompressionPartitions Class Constructors Methods Fields Properties Explicit Interface Implementations See Also

The DataCompressionPartitions type exposes the following members.

Constructors

Name | Description
DataCompressionPartitions |

Methods

Name | Description
Add | Overloaded.
AddOrUpdatePartition |
Clear |
Clone |
Contains |
ContainsIndex |
ContainsKey |
CopyTo |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCompressionByIndex |
GetCompressionByPartition |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasDataCompression |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryGetValue |

Fields

Name | Description
DefaultDataCompression |
DefaultDataCompressionColumnStore |

Properties

Name | Description
Count |
IsReadOnly |
Item |
Keys |

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator |
IDictionary<(Of <(Int32, DataCompression>)>)..::.Values |

See Also

DataCompressionPartitions Class
RedGate.SQLCompare.Engine.Model Namespace


DataCompressionPartitions Constructor

[image]

SQL Data Compare API 12.0.40
DataCompressionPartitions Constructor
DataCompressionPartitions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    parent As IDatabaseObject _
)
C#
public DataCompressionPartitions(
    IDatabaseObject parent
)
Visual C++
public:
DataCompressionPartitions(
    IDatabaseObject^ parent
)

Parameters

parent
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject

See Also

DataCompressionPartitions Class
RedGate.SQLCompare.Engine.Model Namespace


DataCompressionPartitions Fields

[image] [image]

SQL Data Compare API 12.0.40
DataCompressionPartitions Fields
DataCompressionPartitions Class See Also

The DataCompressionPartitions type exposes the following fields.

Fields

Name | Description
DefaultDataCompression |
DefaultDataCompressionColumnStore |

See Also

DataCompressionPartitions Class
RedGate.SQLCompare.Engine.Model Namespace


DefaultDataCompression Field

[image]

SQL Data Compare API 12.0.40
DataCompressionPartitions..::.DefaultDataCompression Field
DataCompressionPartitions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DefaultDataCompression As IDictionary(Of Integer, DataCompression)
C#
public static readonly IDictionary<int, DataCompression> DefaultDataCompression
Visual C++
public:
static initonly IDictionary<int, DataCompression>^ DefaultDataCompression

See Also

DataCompressionPartitions Class
RedGate.SQLCompare.Engine.Model Namespace


DefaultDataCompressionColumnStore Field

[image]

SQL Data Compare API 12.0.40
DataCompressionPartitions..::.DefaultDataCompressionColumnStore Field
DataCompressionPartitions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DefaultDataCompressionColumnStore As IDictionary(Of Integer, DataCompression)
C#
public static readonly IDictionary<int, DataCompression> DefaultDataCompressionColumnStore
Visual C++
public:
static initonly IDictionary<int, DataCompression>^ DefaultDataCompressionColumnStore

See Also

DataCompressionPartitions Class
RedGate.SQLCompare.Engine.Model Namespace


DataCompressionPartitions Methods

[image] [image]

SQL Data Compare API 12.0.40
DataCompressionPartitions Methods
DataCompressionPartitions Class See Also

The DataCompressionPartitions type exposes the following methods.

Methods

Name | Description
Add | Overloaded.
AddOrUpdatePartition |
Clear |
Clone |
Contains |
ContainsIndex |
ContainsKey |
CopyTo |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCompressionByIndex |
GetCompressionByPartition |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasDataCompression |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryGetValue |

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator |

See Also

DataCompressionPartitions Class
RedGate.SQLCompare.Engine.Model Namespace


Add Method

[image] [image]

SQL Data Compare API 12.0.40
DataCompressionPartitions..::.Add Method
DataCompressionPartitions Class See Also

Overload List

Name | Description
Add(KeyValuePair<(Of <(Int32, DataCompression>)>)) |
Add(Int32, DataCompression) |

See Also

DataCompressionPartitions Class
DataCompressionPartitions Members
RedGate.SQLCompare.Engine.Model Namespace


Add Method ((, DataCompression))

[image]

SQL Data Compare API 12.0.40
DataCompressionPartitions..::.Add Method (<(Of <(, DataCompression>)>))
DataCompressionPartitions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add ( _
    item As KeyValuePair(Of Integer, DataCompression) _
)
C#
public void Add(
    KeyValuePair<int, DataCompression> item
)
Visual C++
public:
virtual void Add(
    KeyValuePair<int, DataCompression> item
) sealed

Parameters

item
Type: KeyValuePair<(Of <(Int32, DataCompression >)>)

Implements

ICollectionAdd(UTP)

See Also

DataCompressionPartitions Class
Add Overload
RedGate.SQLCompare.Engine.Model Namespace


Add Method (, DataCompression)

[image]

SQL Data Compare API 12.0.40
DataCompressionPartitions..::.Add Method (, DataCompression)
DataCompressionPartitions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add ( _
    key As Integer, _
    comp As DataCompression _
)
C#
public void Add(
    int key,
    DataCompression comp
)
Visual C++
public:
virtual void Add(
    int key,
    DataCompression comp
) sealed

Parameters

key
Type: Int32
comp
Type: RedGate.SQLCompare.Engine..::.DataCompression

Implements

IDictionaryAdd(UTP, UTP)

See Also

DataCompressionPartitions Class
Add Overload
RedGate.SQLCompare.Engine.Model Namespace


AddOrUpdatePartition Method

[image]

SQL Data Compare API 12.0.40
DataCompressionPartitions..::.AddOrUpdatePartition Method
DataCompressionPartitions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddOrUpdatePartition ( _
    partitionId As Integer, _
    compression As DataCompression _
)
C#
public void AddOrUpdatePartition(
    int partitionId,
    DataCompression compression
)
Visual C++
public:
void AddOrUpdatePartition(
    int partitionId,
    DataCompression compression
)

Parameters

partitionId
Type: Int32
compression
Type: RedGate.SQLCompare.Engine..::.DataCompression

See Also

DataCompressionPartitions Class
RedGate.SQLCompare.Engine.Model Namespace


Clear Method

[image]

SQL Data Compare API 12.0.40
DataCompressionPartitions..::.Clear Method
DataCompressionPartitions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear
C#
public void Clear()
Visual C++
public:
virtual void Clear() sealed

Implements

ICollectionClear()()()

See Also

DataCompressionPartitions Class
RedGate.SQLCompare.Engine.Model Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
DataCompressionPartitions..::.Clone Method
DataCompressionPartitions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone ( _
    parent As IDatabaseObject _
) As DataCompressionPartitions
C#
public DataCompressionPartitions Clone(
    IDatabaseObject parent
)
Visual C++
public:
DataCompressionPartitions^ Clone(
    IDatabaseObject^ parent
)

Parameters

parent
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject

See Also

DataCompressionPartitions Class
RedGate.SQLCompare.Engine.Model Namespace


Contains Method

[image]

SQL Data Compare API 12.0.40
DataCompressionPartitions..::.Contains Method
DataCompressionPartitions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains ( _
    item As KeyValuePair(Of Integer, DataCompression) _
) As Boolean
C#
public bool Contains(
    KeyValuePair<int, DataCompression> item
)
Visual C++
public:
virtual bool Contains(
    KeyValuePair<int, DataCompression> item
) sealed

Parameters

item
Type: KeyValuePair<(Of <(Int32, DataCompression >)>)

Implements

ICollectionContains(UTP)

See Also

DataCompressionPartitions Class
RedGate.SQLCompare.Engine.Model Namespace


ContainsIndex Method

[image]

SQL Data Compare API 12.0.40
DataCompressionPartitions..::.ContainsIndex Method
DataCompressionPartitions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function ContainsIndex ( _
    key As Integer _
) As Boolean
C#
public bool ContainsIndex(
    int key
)
Visual C++
public:
bool ContainsIndex(
    int key
)

Parameters

key
Type: Int32

See Also

DataCompressionPartitions Class
RedGate.SQLCompare.Engine.Model Namespace


ContainsKey Method

[image]

SQL Data Compare API 12.0.40
DataCompressionPartitions..::.ContainsKey Method
DataCompressionPartitions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function ContainsKey ( _
    key As Integer _
) As Boolean
C#
public bool ContainsKey(
    int key
)
Visual C++
public:
virtual bool ContainsKey(
    int key
) sealed

Parameters

key
Type: Int32

Implements

IDictionaryContainsKey(UTP)

See Also

DataCompressionPartitions Class
RedGate.SQLCompare.Engine.Model Namespace


CopyTo Method

[image]

SQL Data Compare API 12.0.40
DataCompressionPartitions..::.CopyTo Method
DataCompressionPartitions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As KeyValuePair(Of Integer, DataCompression)(), _
    arrayIndex As Integer _
)
C#
public void CopyTo(
    KeyValuePair<int, DataCompression>[] array,
    int arrayIndex
)
Visual C++
public:
virtual void CopyTo(
    array<KeyValuePair<int, DataCompression>>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: array<KeyValuePair<(Of <(Int32, DataCompression >)>)>[]()[]
arrayIndex
Type: Int32

Implements

ICollectionCopyTo(array<UTP>[]()[], Int32)

See Also

DataCompressionPartitions Class
RedGate.SQLCompare.Engine.Model Namespace


GetCompressionByIndex Method

[image]

SQL Data Compare API 12.0.40
DataCompressionPartitions..::.GetCompressionByIndex Method
DataCompressionPartitions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetCompressionByIndex ( _
    key As Integer _
) As DataCompression
C#
public DataCompression GetCompressionByIndex(
    int key
)
Visual C++
public:
DataCompression GetCompressionByIndex(
    int key
)

Parameters

key
Type: Int32

See Also

DataCompressionPartitions Class
RedGate.SQLCompare.Engine.Model Namespace


GetCompressionByPartition Method

[image]

SQL Data Compare API 12.0.40
DataCompressionPartitions..::.GetCompressionByPartition Method
DataCompressionPartitions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetCompressionByPartition ( _
    partition As Integer _
) As DataCompression
C#
public DataCompression GetCompressionByPartition(
    int partition
)
Visual C++
public:
DataCompression GetCompressionByPartition(
    int partition
)

Parameters

partition
Type: Int32

See Also

DataCompressionPartitions Class
RedGate.SQLCompare.Engine.Model Namespace


GetEnumerator Method

[image]

SQL Data Compare API 12.0.40
DataCompressionPartitions..::.GetEnumerator Method
DataCompressionPartitions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of Integer, DataCompression))
C#
public IEnumerator<KeyValuePair<int, DataCompression>> GetEnumerator()
Visual C++
public:
virtual IEnumerator<KeyValuePair<int, DataCompression>>^ GetEnumerator() sealed

Implements

IEnumerableGetEnumerator()()()

See Also

DataCompressionPartitions Class
RedGate.SQLCompare.Engine.Model Namespace


. Method

[image]

SQL Data Compare API 12.0.40
DataCompressionPartitions..::...::. Method
DataCompressionPartitions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
C#
IEnumerator IEnumerable.GetEnumerator()
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerableGetEnumerator()()()

See Also

DataCompressionPartitions Class
RedGate.SQLCompare.Engine.Model Namespace


HasDataCompression Method

[image]

SQL Data Compare API 12.0.40
DataCompressionPartitions..::.HasDataCompression Method
DataCompressionPartitions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function HasDataCompression As Boolean
C#
public bool HasDataCompression()
Visual C++
public:
bool HasDataCompression()

See Also

DataCompressionPartitions Class
RedGate.SQLCompare.Engine.Model Namespace


Remove Method

[image] [image]

SQL Data Compare API 12.0.40
DataCompressionPartitions..::.Remove Method
DataCompressionPartitions Class See Also

Overload List

Name | Description
Remove(KeyValuePair<(Of <(Int32, DataCompression>)>)) |
Remove(Int32) |

See Also

DataCompressionPartitions Class
DataCompressionPartitions Members
RedGate.SQLCompare.Engine.Model Namespace


Remove Method ((, DataCompression))

[image]

SQL Data Compare API 12.0.40
DataCompressionPartitions..::.Remove Method (<(Of <(, DataCompression>)>))
DataCompressionPartitions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Remove ( _
    item As KeyValuePair(Of Integer, DataCompression) _
) As Boolean
C#
public bool Remove(
    KeyValuePair<int, DataCompression> item
)
Visual C++
public:
virtual bool Remove(
    KeyValuePair<int, DataCompression> item
) sealed

Parameters

item
Type: KeyValuePair<(Of <(Int32, DataCompression >)>)

Implements

ICollectionRemove(UTP)

See Also

DataCompressionPartitions Class
Remove Overload
RedGate.SQLCompare.Engine.Model Namespace


Remove Method ()

[image]

SQL Data Compare API 12.0.40
DataCompressionPartitions..::.Remove Method ()
DataCompressionPartitions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Remove ( _
    key As Integer _
) As Boolean
C#
public bool Remove(
    int key
)
Visual C++
public:
virtual bool Remove(
    int key
) sealed

Parameters

key
Type: Int32

Implements

IDictionaryRemove(UTP)

See Also

DataCompressionPartitions Class
Remove Overload
RedGate.SQLCompare.Engine.Model Namespace


TryGetValue Method

[image]

SQL Data Compare API 12.0.40
DataCompressionPartitions..::.TryGetValue Method
DataCompressionPartitions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function TryGetValue ( _
    key As Integer, _
    <OutAttribute> ByRef value As DataCompression _
) As Boolean
C#
public bool TryGetValue(
    int key,
    out DataCompression value
)
Visual C++
public:
virtual bool TryGetValue(
    int key,
    [OutAttribute] DataCompression% value
) sealed

Parameters

key
Type: Int32
value
Type: RedGate.SQLCompare.Engine..::.DataCompression %

Implements

IDictionaryTryGetValue(UTP, UTP%)

See Also

DataCompressionPartitions Class
RedGate.SQLCompare.Engine.Model Namespace


DataCompressionPartitions Properties

[image] [image]

SQL Data Compare API 12.0.40
DataCompressionPartitions Properties
DataCompressionPartitions Class See Also

The DataCompressionPartitions type exposes the following properties.

Properties

Name | Description
Count |
IsReadOnly |
Item |
Keys |

Explicit Interface Implementations

Name | Description
IDictionary<(Of <(Int32, DataCompression>)>)..::.Values |

See Also

DataCompressionPartitions Class
RedGate.SQLCompare.Engine.Model Namespace


Count Property

[image]

SQL Data Compare API 12.0.40
DataCompressionPartitions..::.Count Property
DataCompressionPartitions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count { get; }
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollectionCount()()()

See Also

DataCompressionPartitions Class
RedGate.SQLCompare.Engine.Model Namespace


IsReadOnly Property

[image]

SQL Data Compare API 12.0.40
DataCompressionPartitions..::.IsReadOnly Property
DataCompressionPartitions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsReadOnly As Boolean
C#
public bool IsReadOnly { get; private set; }
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

ICollectionIsReadOnly()()()

See Also

DataCompressionPartitions Class
RedGate.SQLCompare.Engine.Model Namespace


Item Property

[image]

SQL Data Compare API 12.0.40
DataCompressionPartitions..::.Item Property
DataCompressionPartitions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item ( _
    partition As Integer _
) As DataCompression
C#
public DataCompression this[
    int partition
] { get; set; }
Visual C++
public:
virtual property DataCompression default[int partition] {
    DataCompression get (int partition) sealed;
    void set (int partition, DataCompression value) sealed;
}

Parameters

partition
Type: Int32

Implements

IDictionaryItem(UTP)

See Also

DataCompressionPartitions Class
RedGate.SQLCompare.Engine.Model Namespace


Keys Property

[image]

SQL Data Compare API 12.0.40
DataCompressionPartitions..::.Keys Property
DataCompressionPartitions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Keys As ICollection(Of Integer)
C#
public ICollection<int> Keys { get; }
Visual C++
public:
virtual property ICollection<int>^ Keys {
    ICollection<int>^ get () sealed;
}

Implements

IDictionaryKeys()()()

See Also

DataCompressionPartitions Class
RedGate.SQLCompare.Engine.Model Namespace


(, DataCompression). Property

[image]

SQL Data Compare API 12.0.40
DataCompressionPartitions..::.<(Of <(, DataCompression>)>)..::. Property
DataCompressionPartitions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private ReadOnly Property Values As ICollection(Of DataCompression)
    Implements IDictionary(Of Integer, DataCompression).Values
C#
ICollection<DataCompression> IDictionary<int, DataCompression>.Values { get; }
Visual C++
private:
virtual property ICollection<DataCompression>^ Values {
    ICollection<DataCompression>^ get () sealed = IDictionary<int, DataCompression>::Values::get;
}

Implements

IDictionaryValues()()()

See Also

DataCompressionPartitions Class
RedGate.SQLCompare.Engine.Model Namespace


EmptyDatabaseSource Class

[image]

SQL Data Compare API 12.0.40
EmptyDatabaseSource Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Class EmptyDatabaseSource _
    Inherits DataSource
C#
public class EmptyDatabaseSource : DataSource
Visual C++
public ref class EmptyDatabaseSource : public DataSource

Inheritance Hierarchy

Object
RedGate.Shared.SQL..::.DataSource
RedGate.SQLCompare.Engine.Model..::.EmptyDatabaseSource

See Also

EmptyDatabaseSource Members
RedGate.SQLCompare.Engine.Model Namespace


EmptyDatabaseSource Members

[image] [image]

SQL Data Compare API 12.0.40
EmptyDatabaseSource Members
EmptyDatabaseSource Class Constructors Methods Properties Explicit Interface Implementations See Also

The EmptyDatabaseSource type exposes the following members.

Constructors

Name | Description
EmptyDatabaseSource |

Methods

Name | Description
Clone | (Overrides DataSource ..::. Clone()()().)
Deserialize | (Overrides DataSource ..::. Deserialize(Int32, ISerializeFormatter).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDifferentSource | (Overrides DataSource ..::.IsDifferentSource(IDataSource).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | (Overrides DataSource ..::. Serialize(ISerializeFormatter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DatabaseName | (Overrides DataSource ..::. DatabaseName.)
IsValid | (Overrides DataSource ..::. IsValid.)
IsWriteable | (Overrides DataSource ..::. IsWriteable.)
ServerName | (Overrides DataSource ..::. ServerName.)
Version | (Overrides DataSource ..::. Version.)

Explicit Interface Implementations

Name | Description
ICloneableClone | (Inherited from DataSource.)

See Also

EmptyDatabaseSource Class
RedGate.SQLCompare.Engine.Model Namespace


EmptyDatabaseSource Constructor

[image]

SQL Data Compare API 12.0.40
EmptyDatabaseSource Constructor
EmptyDatabaseSource Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public EmptyDatabaseSource()
Visual C++
public:
EmptyDatabaseSource()

See Also

EmptyDatabaseSource Class
RedGate.SQLCompare.Engine.Model Namespace


EmptyDatabaseSource Methods

[image] [image]

SQL Data Compare API 12.0.40
EmptyDatabaseSource Methods
EmptyDatabaseSource Class See Also

The EmptyDatabaseSource type exposes the following methods.

Methods

Name | Description
Clone | (Overrides DataSource ..::. Clone()()().)
Deserialize | (Overrides DataSource ..::. Deserialize(Int32, ISerializeFormatter).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDifferentSource | (Overrides DataSource ..::.IsDifferentSource(IDataSource).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | (Overrides DataSource ..::. Serialize(ISerializeFormatter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICloneableClone | (Inherited from DataSource.)

See Also

EmptyDatabaseSource Class
RedGate.SQLCompare.Engine.Model Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
EmptyDatabaseSource..::.Clone Method
EmptyDatabaseSource Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone As IDataSource
C#
public override IDataSource Clone()
Visual C++
public:
virtual IDataSource^ Clone() override

Implements

IDataSource..::.Clone()()()

See Also

EmptyDatabaseSource Class
RedGate.SQLCompare.Engine.Model Namespace


Deserialize Method

[image]

SQL Data Compare API 12.0.40
EmptyDatabaseSource..::.Deserialize Method
EmptyDatabaseSource Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Deserialize ( _
    versionId As Integer, _
    formatter As ISerializeFormatter _
) As Boolean
C#
public override bool Deserialize(
    int versionId,
    ISerializeFormatter formatter
)
Visual C++
public:
virtual bool Deserialize(
    int versionId,
    ISerializeFormatter^ formatter
) override

Parameters

versionId
Type: Int32
formatter
Type: ISerializeFormatter

See Also

EmptyDatabaseSource Class
RedGate.SQLCompare.Engine.Model Namespace


IsDifferentSource Method

[image]

SQL Data Compare API 12.0.40
EmptyDatabaseSource..::.IsDifferentSource Method
EmptyDatabaseSource Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsDifferentSource ( _
    newDataSource As IDataSource _
) As Boolean
C#
public override bool IsDifferentSource(
    IDataSource newDataSource
)
Visual C++
public:
virtual bool IsDifferentSource(
    IDataSource^ newDataSource
) override

Parameters

newDataSource
Type: RedGate.Shared.SQL..::.IDataSource

See Also

EmptyDatabaseSource Class
RedGate.SQLCompare.Engine.Model Namespace


Serialize Method

[image]

SQL Data Compare API 12.0.40
EmptyDatabaseSource..::.Serialize Method
EmptyDatabaseSource Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    formatter As ISerializeFormatter _
)
C#
public override void Serialize(
    ISerializeFormatter formatter
)
Visual C++
public:
virtual void Serialize(
    ISerializeFormatter^ formatter
) override

Parameters

formatter
Type: ISerializeFormatter

See Also

EmptyDatabaseSource Class
RedGate.SQLCompare.Engine.Model Namespace


EmptyDatabaseSource Properties

[image] [image]

SQL Data Compare API 12.0.40
EmptyDatabaseSource Properties
EmptyDatabaseSource Class See Also

The EmptyDatabaseSource type exposes the following properties.

Properties

Name | Description
DatabaseName | (Overrides DataSource ..::. DatabaseName.)
IsValid | (Overrides DataSource ..::. IsValid.)
IsWriteable | (Overrides DataSource ..::. IsWriteable.)
ServerName | (Overrides DataSource ..::. ServerName.)
Version | (Overrides DataSource ..::. Version.)

See Also

EmptyDatabaseSource Class
RedGate.SQLCompare.Engine.Model Namespace


DatabaseName Property

[image]

SQL Data Compare API 12.0.40
EmptyDatabaseSource..::.DatabaseName Property
EmptyDatabaseSource Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property DatabaseName As String
C#
public override string DatabaseName { get; set; }
Visual C++
public:
virtual property String^ DatabaseName {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IDataSource..::.DatabaseName

See Also

EmptyDatabaseSource Class
RedGate.SQLCompare.Engine.Model Namespace


IsValid Property

[image]

SQL Data Compare API 12.0.40
EmptyDatabaseSource..::.IsValid Property
EmptyDatabaseSource Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsValid As Boolean
C#
public override bool IsValid { get; }
Visual C++
public:
virtual property bool IsValid {
    bool get () override;
}

Implements

IDataSource..::.IsValid

See Also

EmptyDatabaseSource Class
RedGate.SQLCompare.Engine.Model Namespace


IsWriteable Property

[image]

SQL Data Compare API 12.0.40
EmptyDatabaseSource..::.IsWriteable Property
EmptyDatabaseSource Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsWriteable As Boolean
C#
public override bool IsWriteable { get; }
Visual C++
public:
virtual property bool IsWriteable {
    bool get () override;
}

Implements

IDataSource..::.IsWriteable

See Also

EmptyDatabaseSource Class
RedGate.SQLCompare.Engine.Model Namespace


ServerName Property

[image]

SQL Data Compare API 12.0.40
EmptyDatabaseSource..::.ServerName Property
EmptyDatabaseSource Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property ServerName As String
C#
public override string ServerName { get; set; }
Visual C++
public:
virtual property String^ ServerName {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IDataSource..::.ServerName

See Also

EmptyDatabaseSource Class
RedGate.SQLCompare.Engine.Model Namespace


Version Property

[image]

SQL Data Compare API 12.0.40
EmptyDatabaseSource..::.Version Property
EmptyDatabaseSource Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Version As Integer
C#
public override int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () override;
}

See Also

EmptyDatabaseSource Class
RedGate.SQLCompare.Engine.Model Namespace


IndexField Class

[image]

SQL Data Compare API 12.0.40
IndexField Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class IndexField _
    Implements IDatabaseObject, ITSqlObject, ICanExistenceCheck
C#
public class IndexField : IDatabaseObject, ITSqlObject,
    ICanExistenceCheck
Visual C++
public ref class IndexField : IDatabaseObject,
    ITSqlObject, ICanExistenceCheck

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Model..::.IndexField

See Also

IndexField Members
RedGate.SQLCompare.Engine.Model Namespace


IndexField Members

[image] [image]

SQL Data Compare API 12.0.40
IndexField Members
IndexField Class Constructors Methods Properties See Also

The IndexField type exposes the following members.

Constructors

Name | Description
IndexField |

Methods

Name | Description
Clone |
CompareWith |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Database |
Descending |
Field |
FullyQualifiedName |
Included |
Name |
ObjectType |
Owner |
QualifiedName |

See Also

IndexField Class
RedGate.SQLCompare.Engine.Model Namespace


IndexField Constructor

[image]

SQL Data Compare API 12.0.40
IndexField Constructor
IndexField Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    underlyingField As IField _
)
C#
public IndexField(
    IField underlyingField
)
Visual C++
public:
IndexField(
    IField^ underlyingField
)

Parameters

underlyingField
Type: RedGate.SQLCompare.Engine..::.IField

See Also

IndexField Class
RedGate.SQLCompare.Engine.Model Namespace


IndexField Methods

[image] [image]

SQL Data Compare API 12.0.40
IndexField Methods
IndexField Class See Also

The IndexField type exposes the following methods.

Methods

Name | Description
Clone |
CompareWith |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IndexField Class
RedGate.SQLCompare.Engine.Model Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
IndexField..::.Clone Method
IndexField Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone As IndexField
C#
public IndexField Clone()
Visual C++
public:
IndexField^ Clone()

See Also

IndexField Class
RedGate.SQLCompare.Engine.Model Namespace


CompareWith Method

[image]

SQL Data Compare API 12.0.40
IndexField..::.CompareWith Method
IndexField Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareWith ( _
    other As IndexField, _
    options As Options _
) As IEnumerable(Of EqualityDifference)
C#
public IEnumerable<EqualityDifference> CompareWith(
    IndexField other,
    Options options
)
Visual C++
public:
IEnumerable<EqualityDifference^>^ CompareWith(
    IndexField^ other,
    Options options
)

Parameters

other
Type: RedGate.SQLCompare.Engine.Model..::.IndexField
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

IndexField Class
RedGate.SQLCompare.Engine.Model Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
IndexField..::.Equals Method
IndexField Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) |
Equals(IndexField, Options) |

See Also

IndexField Class
IndexField Members
RedGate.SQLCompare.Engine.Model Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
IndexField..::.Equals Method (IDatabaseObject, Options)
IndexField Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) sealed

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

IndexField Class
Equals Overload
RedGate.SQLCompare.Engine.Model Namespace


Equals Method (IndexField, Options)

[image]

SQL Data Compare API 12.0.40
IndexField..::.Equals Method (IndexField, Options)
IndexField Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    target As IndexField, _
    options As Options _
) As Boolean
C#
public bool Equals(
    IndexField target,
    Options options
)
Visual C++
public:
bool Equals(
    IndexField^ target,
    Options options
)

Parameters

target
Type: RedGate.SQLCompare.Engine.Model..::.IndexField
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

IndexField Class
Equals Overload
RedGate.SQLCompare.Engine.Model Namespace


IndexField Properties

[image] [image]

SQL Data Compare API 12.0.40
IndexField Properties
IndexField Class See Also

The IndexField type exposes the following properties.

Properties

Name | Description
Database |
Descending |
Field |
FullyQualifiedName |
Included |
Name |
ObjectType |
Owner |
QualifiedName |

See Also

IndexField Class
RedGate.SQLCompare.Engine.Model Namespace


Database Property

[image]

SQL Data Compare API 12.0.40
IndexField..::.Database Property
IndexField Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Database As Database
C#
public Database Database { get; }
Visual C++
public:
virtual property Database^ Database {
    Database^ get () sealed;
}

Implements

IDatabaseObject..::.Database

See Also

IndexField Class
RedGate.SQLCompare.Engine.Model Namespace


Descending Property

[image]

SQL Data Compare API 12.0.40
IndexField..::.Descending Property
IndexField Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Descending As Boolean
C#
public bool Descending { get; internal set; }
Visual C++
public:
property bool Descending {
    bool get ();
    void set (bool value);
}

See Also

IndexField Class
RedGate.SQLCompare.Engine.Model Namespace


Field Property

[image]

SQL Data Compare API 12.0.40
IndexField..::.Field Property
IndexField Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Field As IField
C#
public IField Field { get; }
Visual C++
public:
property IField^ Field {
    IField^ get ();
}

See Also

IndexField Class
RedGate.SQLCompare.Engine.Model Namespace


FullyQualifiedName Property

[image]

SQL Data Compare API 12.0.40
IndexField..::.FullyQualifiedName Property
IndexField Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullyQualifiedName As String
C#
public string FullyQualifiedName { get; }
Visual C++
public:
virtual property String^ FullyQualifiedName {
    String^ get () sealed;
}

Implements

ITSqlObjectFullyQualifiedName()()()

See Also

IndexField Class
RedGate.SQLCompare.Engine.Model Namespace


Included Property

[image]

SQL Data Compare API 12.0.40
IndexField..::.Included Property
IndexField Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Included As Boolean
C#
public bool Included { get; internal set; }
Visual C++
public:
property bool Included {
    bool get ();
    void set (bool value);
}

See Also

IndexField Class
RedGate.SQLCompare.Engine.Model Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
IndexField..::.Name Property
IndexField Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
}

Implements

ITSqlObjectName()()()

See Also

IndexField Class
RedGate.SQLCompare.Engine.Model Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
IndexField..::.ObjectType Property
IndexField Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ObjectType As ObjectType
C#
public ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () sealed;
}

Implements

ITSqlObjectObjectType()()()

See Also

IndexField Class
RedGate.SQLCompare.Engine.Model Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
IndexField..::.Owner Property
IndexField Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Owner As String
C#
public string Owner { get; }
Visual C++
public:
virtual property String^ Owner {
    String^ get () sealed;
}

Implements

ITSqlObjectOwner()()()

See Also

IndexField Class
RedGate.SQLCompare.Engine.Model Namespace


QualifiedName Property

[image]

SQL Data Compare API 12.0.40
IndexField..::.QualifiedName Property
IndexField Class See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property QualifiedName As String
C#
public string QualifiedName { get; }
Visual C++
public:
virtual property String^ QualifiedName {
    String^ get () sealed;
}

Implements

ITSqlObjectQualifiedName()()()

See Also

IndexField Class
RedGate.SQLCompare.Engine.Model Namespace


ISqlComparable Interface

[image]

SQL Data Compare API 12.0.40
ISqlComparable Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISqlComparable
C#
public interface ISqlComparable
Visual C++
public interface class ISqlComparable

See Also

ISqlComparable Members
RedGate.SQLCompare.Engine.Model Namespace


ISqlComparable Members

[image] [image]

SQL Data Compare API 12.0.40
ISqlComparable Members
ISqlComparable Interface Methods See Also

The ISqlComparable type exposes the following members.

Methods

Name | Description
CompareWith |

See Also

ISqlComparable Interface
RedGate.SQLCompare.Engine.Model Namespace


ISqlComparable Methods

[image] [image]

SQL Data Compare API 12.0.40
ISqlComparable Methods
ISqlComparable Interface See Also

The ISqlComparable type exposes the following methods.

Methods

Name | Description
CompareWith |

See Also

ISqlComparable Interface
RedGate.SQLCompare.Engine.Model Namespace


CompareWith Method

[image]

SQL Data Compare API 12.0.40
ISqlComparable..::.CompareWith Method
ISqlComparable Interface See Also

Namespace: RedGate.SQLCompare.Engine.Model
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function CompareWith ( _
    obj As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference)
C#
IEnumerable<EqualityDifference> CompareWith(
    ISqlComparable obj,
    Options options
)
Visual C++
IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ obj,
    Options options
)

Parameters

obj
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

See Also

ISqlComparable Interface
RedGate.SQLCompare.Engine.Model Namespace


RedGate.SQLCompare.Engine.Model.DatabaseObjects.DatabaseFromFolderPopulator Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.Model.DatabaseObjects.DatabaseFromFolderPopulator Namespace

Classes

Class | Description
DatabaseFromFolderPopulator | Populates a database object from a folder of sql scripts.

Interfaces

Interface | Description
IDatabaseFromFolderPopulator | Interface for an object that populates a Database from a scripts folder


DatabaseFromFolderPopulator Class

[image]

SQL Data Compare API 12.0.40
DatabaseFromFolderPopulator Class
Members See Also

Populates a database object from a folder of sql scripts.

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.DatabaseFromFolderPopulator
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class DatabaseFromFolderPopulator _
    Implements IDatabaseFromFolderPopulator
C#
public class DatabaseFromFolderPopulator : IDatabaseFromFolderPopulator
Visual C++
public ref class DatabaseFromFolderPopulator : IDatabaseFromFolderPopulator

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Model.DatabaseObjects.DatabaseFromFolderPopulator..::.DatabaseFromFolderPopulator

See Also

DatabaseFromFolderPopulator Members
RedGate.SQLCompare.Engine.Model.DatabaseObjects.DatabaseFromFolderPopulator Namespace


DatabaseFromFolderPopulator Members

[image] [image]

SQL Data Compare API 12.0.40
DatabaseFromFolderPopulator Members
DatabaseFromFolderPopulator Class Constructors Methods See Also

The DatabaseFromFolderPopulator type exposes the following members.

Constructors

Name | Description
DatabaseFromFolderPopulator |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Populate |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseFromFolderPopulator Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.DatabaseFromFolderPopulator Namespace


DatabaseFromFolderPopulator Constructor

[image]

SQL Data Compare API 12.0.40
DatabaseFromFolderPopulator Constructor
DatabaseFromFolderPopulator Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.DatabaseFromFolderPopulator
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    scriptRegistrationInfo As ScriptRegistrationInformation, _
    cache As IReadFromFolderCache _
)
C#
public DatabaseFromFolderPopulator(
    ScriptRegistrationInformation scriptRegistrationInfo,
    IReadFromFolderCache cache
)
Visual C++
public:
DatabaseFromFolderPopulator(
    ScriptRegistrationInformation^ scriptRegistrationInfo,
    IReadFromFolderCache^ cache
)

Parameters

scriptRegistrationInfo
Type: RedGate.SQLCompare.Engine..::.ScriptRegistrationInformation
cache
Type: RedGate.SQLCompare.Engine.ReadFromFolder.Cache..::.IReadFromFolderCache

See Also

DatabaseFromFolderPopulator Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.DatabaseFromFolderPopulator Namespace


DatabaseFromFolderPopulator Methods

[image] [image]

SQL Data Compare API 12.0.40
DatabaseFromFolderPopulator Methods
DatabaseFromFolderPopulator Class See Also

The DatabaseFromFolderPopulator type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Populate |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseFromFolderPopulator Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.DatabaseFromFolderPopulator Namespace


Populate Method

[image]

SQL Data Compare API 12.0.40
DatabaseFromFolderPopulator..::.Populate Method
DatabaseFromFolderPopulator Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.DatabaseFromFolderPopulator
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Populate ( _
    path As String, _
    cancellationToken As CancellationToken _
) As CacheResult
C#
public CacheResult Populate(
    string path,
    CancellationToken cancellationToken
)
Visual C++
public:
virtual CacheResult^ Populate(
    String^ path,
    CancellationToken cancellationToken
) sealed

Parameters

path
Type: String
cancellationToken
Type: CancellationToken

Implements

IDatabaseFromFolderPopulator..::.Populate(String, CancellationToken)

Exceptions

Exception | Condition
ArgumentNullException |
RedGate.SQLCompare.Engine..::.SqlCompareException |

See Also

DatabaseFromFolderPopulator Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.DatabaseFromFolderPopulator Namespace


IDatabaseFromFolderPopulator Interface

[image]

SQL Data Compare API 12.0.40
IDatabaseFromFolderPopulator Interface
Members See Also

Interface for an object that populates a Database from a scripts folder

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.DatabaseFromFolderPopulator
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDatabaseFromFolderPopulator
C#
public interface IDatabaseFromFolderPopulator
Visual C++
public interface class IDatabaseFromFolderPopulator

See Also

IDatabaseFromFolderPopulator Members
RedGate.SQLCompare.Engine.Model.DatabaseObjects.DatabaseFromFolderPopulator Namespace


IDatabaseFromFolderPopulator Members

[image] [image]

SQL Data Compare API 12.0.40
IDatabaseFromFolderPopulator Members
IDatabaseFromFolderPopulator Interface Methods See Also

The IDatabaseFromFolderPopulator type exposes the following members.

Methods

Name | Description
Populate |

See Also

IDatabaseFromFolderPopulator Interface
RedGate.SQLCompare.Engine.Model.DatabaseObjects.DatabaseFromFolderPopulator Namespace


IDatabaseFromFolderPopulator Methods

[image] [image]

SQL Data Compare API 12.0.40
IDatabaseFromFolderPopulator Methods
IDatabaseFromFolderPopulator Interface See Also

The IDatabaseFromFolderPopulator type exposes the following methods.

Methods

Name | Description
Populate |

See Also

IDatabaseFromFolderPopulator Interface
RedGate.SQLCompare.Engine.Model.DatabaseObjects.DatabaseFromFolderPopulator Namespace


Populate Method

[image]

SQL Data Compare API 12.0.40
IDatabaseFromFolderPopulator..::.Populate Method
IDatabaseFromFolderPopulator Interface See Also

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.DatabaseFromFolderPopulator
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Populate ( _
    path As String, _
    cancellationToken As CancellationToken _
) As CacheResult
C#
CacheResult Populate(
    string path,
    CancellationToken cancellationToken
)
Visual C++
CacheResult^ Populate(
    String^ path,
    CancellationToken cancellationToken
)

Parameters

path
Type: String
cancellationToken
Type: CancellationToken

Exceptions

Exception | Condition
ArgumentNullException |
RedGate.SQLCompare.Engine..::.SqlCompareException |

See Also

IDatabaseFromFolderPopulator Interface
RedGate.SQLCompare.Engine.Model.DatabaseObjects.DatabaseFromFolderPopulator Namespace


RedGate.SQLCompare.Engine.Model.DatabaseObjects.Meta Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Meta Namespace

Classes

Class | Description
SqlFeatureUsage | Metadata for IMetadata: Counts of object types that we don't already have FUR for (eg we count number of tables, but not specific types of tables)


SqlFeatureUsage Class

[image]

SQL Data Compare API 12.0.40
SqlFeatureUsage Class
Members See Also

Metadata for IMetadata: Counts of object types that we don't already have FUR for (eg we count number of tables, but not specific types of tables)

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Meta
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlFeatureUsage
C#
public class SqlFeatureUsage
Visual C++
public ref class SqlFeatureUsage

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Meta..::.SqlFeatureUsage

See Also

SqlFeatureUsage Members
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Meta Namespace


SqlFeatureUsage Members

[image] [image]

SQL Data Compare API 12.0.40
SqlFeatureUsage Members
SqlFeatureUsage Class Constructors Methods Properties See Also

The SqlFeatureUsage type exposes the following members.

Constructors

Name | Description
SqlFeatureUsage |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColumnEncryptionKeys |
ColumnMasterKeys |
InMemoryTables |
PredicatedStretchTables |
StretchTables |
TemporalTables |

See Also

SqlFeatureUsage Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Meta Namespace


SqlFeatureUsage Constructor

[image]

SQL Data Compare API 12.0.40
SqlFeatureUsage Constructor
SqlFeatureUsage Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Meta
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    stretchTables As Integer, _
    predicatedStretchTables As Integer, _
    inMemoryTables As Integer, _
    temporalTables As Integer, _
    columnMasterKeys As Integer, _
    columnEncryptionKeys As Integer _
)
C#
public SqlFeatureUsage(
    int stretchTables,
    int predicatedStretchTables,
    int inMemoryTables,
    int temporalTables,
    int columnMasterKeys,
    int columnEncryptionKeys
)
Visual C++
public:
SqlFeatureUsage(
    int stretchTables,
    int predicatedStretchTables,
    int inMemoryTables,
    int temporalTables,
    int columnMasterKeys,
    int columnEncryptionKeys
)

Parameters

stretchTables
Type: Int32
predicatedStretchTables
Type: Int32
inMemoryTables
Type: Int32
temporalTables
Type: Int32
columnMasterKeys
Type: Int32
columnEncryptionKeys
Type: Int32

See Also

SqlFeatureUsage Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Meta Namespace


SqlFeatureUsage Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlFeatureUsage Properties
SqlFeatureUsage Class See Also

The SqlFeatureUsage type exposes the following properties.

Properties

Name | Description
ColumnEncryptionKeys |
ColumnMasterKeys |
InMemoryTables |
PredicatedStretchTables |
StretchTables |
TemporalTables |

See Also

SqlFeatureUsage Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Meta Namespace


ColumnEncryptionKeys Property

[image]

SQL Data Compare API 12.0.40
SqlFeatureUsage..::.ColumnEncryptionKeys Property
SqlFeatureUsage Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Meta
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnEncryptionKeys As Integer
C#
public int ColumnEncryptionKeys { get; }
Visual C++
public:
property int ColumnEncryptionKeys {
    int get ();
}

See Also

SqlFeatureUsage Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Meta Namespace


ColumnMasterKeys Property

[image]

SQL Data Compare API 12.0.40
SqlFeatureUsage..::.ColumnMasterKeys Property
SqlFeatureUsage Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Meta
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnMasterKeys As Integer
C#
public int ColumnMasterKeys { get; }
Visual C++
public:
property int ColumnMasterKeys {
    int get ();
}

See Also

SqlFeatureUsage Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Meta Namespace


InMemoryTables Property

[image]

SQL Data Compare API 12.0.40
SqlFeatureUsage..::.InMemoryTables Property
SqlFeatureUsage Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Meta
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InMemoryTables As Integer
C#
public int InMemoryTables { get; }
Visual C++
public:
property int InMemoryTables {
    int get ();
}

See Also

SqlFeatureUsage Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Meta Namespace


PredicatedStretchTables Property

[image]

SQL Data Compare API 12.0.40
SqlFeatureUsage..::.PredicatedStretchTables Property
SqlFeatureUsage Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Meta
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PredicatedStretchTables As Integer
C#
public int PredicatedStretchTables { get; }
Visual C++
public:
property int PredicatedStretchTables {
    int get ();
}

See Also

SqlFeatureUsage Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Meta Namespace


StretchTables Property

[image]

SQL Data Compare API 12.0.40
SqlFeatureUsage..::.StretchTables Property
SqlFeatureUsage Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Meta
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StretchTables As Integer
C#
public int StretchTables { get; }
Visual C++
public:
property int StretchTables {
    int get ();
}

See Also

SqlFeatureUsage Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Meta Namespace


TemporalTables Property

[image]

SQL Data Compare API 12.0.40
SqlFeatureUsage..::.TemporalTables Property
SqlFeatureUsage Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Meta
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TemporalTables As Integer
C#
public int TemporalTables { get; }
Visual C++
public:
property int TemporalTables {
    int get ();
}

See Also

SqlFeatureUsage Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Meta Namespace


RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace

Classes

Class | Description
SecurityPolicy | A Security Policy defines a number of security predicates that restrict access to rows in a table. This is part of the new Row-Level Security feature introduced in SQL Server 2016 CTP2. See https://msdn.microsoft.com/en-us/library/dn765131.aspx for more information.
SecurityPredicate | A sub-object on a security policy that restricts read or write operations on rows in a table. This restriction is defined within a table-valued function and applied to the table that the security predicate is declared on. If it is a filter predicate, this restriction affects SELECT, DELETE and UPDATE operations. Access to unfiltered rows is not affected. If it is a block predicate, the restriction can be applied to INSERT, UPDATE or DELETE operations. The write operation to be blocked by a block predicate is stated in its definition. This is part of the new Row-Level Security feature introduced in SQL Server 2016 CTP2. See https://msdn.microsoft.com/en-us/library/dn765131.aspx for more information.

Enumerations

Enumeration | Description
BlockDmlOperation | Type of DML operation prohibited by a block predicate within a security policy object
PredicateType | Type of security predicate within a security policy object


BlockDmlOperation Enumeration

[image]

SQL Data Compare API 12.0.40
BlockDmlOperation Enumeration
See Also

Type of DML operation prohibited by a block predicate within a security policy object

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration BlockDmlOperation
C#
public enum BlockDmlOperation
Visual C++
public enum class BlockDmlOperation

Members

Member name | Description
None |
AfterInsert |
AfterUpdate |
BeforeUpdate |
BeforeDelete |

See Also

RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace


PredicateType Enumeration

[image]

SQL Data Compare API 12.0.40
PredicateType Enumeration
See Also

Type of security predicate within a security policy object

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration PredicateType
C#
public enum PredicateType
Visual C++
public enum class PredicateType

Members

Member name | Description
Filter |
Block |

See Also

RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace


SecurityPolicy Class

[image]

SQL Data Compare API 12.0.40
SecurityPolicy Class
Members See Also

A Security Policy defines a number of security predicates that restrict access to rows in a table. This is part of the new Row-Level Security feature introduced in SQL Server 2016 CTP2. See https://msdn.microsoft.com/en-us/library/dn765131.aspx for more information.

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SecurityPolicy _
    Inherits SchemaObjectWithAuthorization _
    Implements ISqlComparable, IDatabaseObject, ITSqlObject, ICanExistenceCheck
C#
public class SecurityPolicy : SchemaObjectWithAuthorization, ISqlComparable,
    IDatabaseObject, ITSqlObject, ICanExistenceCheck
Visual C++
public ref class SecurityPolicy : public SchemaObjectWithAuthorization,
    ISqlComparable, IDatabaseObject, ITSqlObject, ICanExistenceCheck

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.SchemaObjectWithAuthorization
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies..::.SecurityPolicy

See Also

SecurityPolicy Members
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace


SecurityPolicy Members

[image] [image]

SQL Data Compare API 12.0.40
SecurityPolicy Members
SecurityPolicy Class Constructors Methods Fields Properties See Also

The SecurityPolicy type exposes the following members.

Constructors

Name | Description
SecurityPolicy |

Methods

Name | Description
CompareWith |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Fields

Name | Description
m_ScriptSources | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AlterAuthorizationClassType | (Inherited from SchemaObjectWithAuthorization.)
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
NotForReplication |
ObjectType | (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from SchemaObjectWithAuthorization.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSources | (Inherited from SchemaObject.)
SecurityPredicates |
State |
SysobjectID |

See Also

SecurityPolicy Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace


SecurityPolicy Constructor

[image]

SQL Data Compare API 12.0.40
SecurityPolicy Constructor
SecurityPolicy Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    database As Database, _
    owner As String, _
    name As String, _
    authorization As String, _
    state As Boolean, _
    notForReplication As Boolean, _
    securityPredicates As List(Of SecurityPredicate), _
    extendedProperties As ExtendedProperties, _
    permissions As Permissions, _
    sysobjectID As Integer _
)
C#
public SecurityPolicy(
    Database database,
    string owner,
    string name,
    string authorization,
    bool state,
    bool notForReplication,
    List<SecurityPredicate> securityPredicates,
    ExtendedProperties extendedProperties,
    Permissions permissions,
    int sysobjectID
)
Visual C++
public:
SecurityPolicy(
    Database^ database,
    String^ owner,
    String^ name,
    String^ authorization,
    bool state,
    bool notForReplication,
    List<SecurityPredicate^>^ securityPredicates,
    ExtendedProperties^ extendedProperties,
    Permissions^ permissions,
    int sysobjectID
)

Parameters

database
Type: RedGate.SQLCompare.Engine..::.Database
owner
Type: String
name
Type: String
authorization
Type: String
state
Type: Boolean
notForReplication
Type: Boolean
securityPredicates
Type: List<(Of <( SecurityPredicate >)>)
extendedProperties
Type: RedGate.SQLCompare.Engine..::.ExtendedProperties
permissions
Type: RedGate.SQLCompare.Engine..::.Permissions
sysobjectID
Type: Int32

See Also

SecurityPolicy Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace


SecurityPolicy Methods

[image] [image]

SQL Data Compare API 12.0.40
SecurityPolicy Methods
SecurityPolicy Class See Also

The SecurityPolicy type exposes the following methods.

Methods

Name | Description
CompareWith |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options, IFeatureChecker).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

See Also

SecurityPolicy Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace


CompareWith Method

[image]

SQL Data Compare API 12.0.40
SecurityPolicy..::.CompareWith Method
SecurityPolicy Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareWith ( _
    obj As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference)
C#
public IEnumerable<EqualityDifference> CompareWith(
    ISqlComparable obj,
    Options options
)
Visual C++
public:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ obj,
    Options options
) sealed

Parameters

obj
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

SecurityPolicy Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
SecurityPolicy..::.Equals Method
SecurityPolicy Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

SecurityPolicy Class
SecurityPolicy Members
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 12.0.40
SecurityPolicy..::.Equals Method (IDatabaseObject, Options)
SecurityPolicy Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

SecurityPolicy Class
Equals Overload
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace


ScriptObject Method

[image]

SQL Data Compare API 12.0.40
SecurityPolicy..::.ScriptObject Method
SecurityPolicy Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options, _
    targetFeatures As IFeatureChecker _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options,
    IFeatureChecker targetFeatures
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options,
    IFeatureChecker^ targetFeatures
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
options
Type: RedGate.SQLCompare.Engine..::.Options
targetFeatures
Type: RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.IFeatureChecker

See Also

SecurityPolicy Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace


SecurityPolicy Properties

[image] [image]

SQL Data Compare API 12.0.40
SecurityPolicy Properties
SecurityPolicy Class See Also

The SecurityPolicy type exposes the following properties.

Properties

Name | Description
AlterAuthorizationClassType | (Inherited from SchemaObjectWithAuthorization.)
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Name | The name of the object. DANGER WILL ROBINSON!! This is not escaped. Do you mean ScriptableDatabaseObject..::.QualifiedName? (Inherited from ScriptableDatabaseObject.)
NotForReplication |
ObjectType | (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | (Inherited from SchemaObjectWithAuthorization.)
QualifiedName | The qualified name of the object. Do you mean ScriptableDatabaseObject..::.Name? (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSources | (Inherited from SchemaObject.)
SecurityPredicates |
State |
SysobjectID |

See Also

SecurityPolicy Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace


NotForReplication Property

[image]

SQL Data Compare API 12.0.40
SecurityPolicy..::.NotForReplication Property
SecurityPolicy Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NotForReplication As Boolean
C#
public bool NotForReplication { get; private set; }
Visual C++
public:
property bool NotForReplication {
    bool get ();
    void set (bool value);
}

See Also

SecurityPolicy Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
SecurityPolicy..::.ObjectType Property
SecurityPolicy Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

ITSqlObjectObjectType()()()
ITSqlObjectObjectType()()()

See Also

SecurityPolicy Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace


SecurityPredicates Property

[image]

SQL Data Compare API 12.0.40
SecurityPolicy..::.SecurityPredicates Property
SecurityPolicy Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SecurityPredicates As List(Of SecurityPredicate)
C#
public List<SecurityPredicate> SecurityPredicates { get; private set; }
Visual C++
public:
property List<SecurityPredicate^>^ SecurityPredicates {
    List<SecurityPredicate^>^ get ();
    void set (List<SecurityPredicate^>^ value);
}

See Also

SecurityPolicy Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace


State Property

[image]

SQL Data Compare API 12.0.40
SecurityPolicy..::.State Property
SecurityPolicy Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property State As Boolean
C#
public bool State { get; private set; }
Visual C++
public:
property bool State {
    bool get ();
    void set (bool value);
}

See Also

SecurityPolicy Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace


SysobjectID Property

[image]

SQL Data Compare API 12.0.40
SecurityPolicy..::.SysobjectID Property
SecurityPolicy Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SysobjectID As Integer
C#
public int SysobjectID { get; }
Visual C++
public:
virtual property int SysobjectID {
    int get () sealed;
}

See Also

SecurityPolicy Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace


SecurityPredicate Class

[image]

SQL Data Compare API 12.0.40
SecurityPredicate Class
Members See Also

A sub-object on a security policy that restricts read or write operations on rows in a table. This restriction is defined within a table-valued function and applied to the table that the security predicate is declared on. If it is a filter predicate, this restriction affects SELECT, DELETE and UPDATE operations. Access to unfiltered rows is not affected. If it is a block predicate, the restriction can be applied to INSERT, UPDATE or DELETE operations. The write operation to be blocked by a block predicate is stated in its definition. This is part of the new Row-Level Security feature introduced in SQL Server 2016 CTP2. See https://msdn.microsoft.com/en-us/library/dn765131.aspx for more information.

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SecurityPredicate _
    Implements ISqlComparable
C#
public class SecurityPredicate : ISqlComparable
Visual C++
public ref class SecurityPredicate : ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies..::.SecurityPredicate

See Also

SecurityPredicate Members
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace


SecurityPredicate Members

[image] [image]

SQL Data Compare API 12.0.40
SecurityPredicate Members
SecurityPredicate Class Constructors Methods Properties See Also

The SecurityPredicate type exposes the following members.

Constructors

Name | Description
SecurityPredicate | Create a security predicate, the part of a security policy that restricts read or write access to data in a table or view.

Methods

Name | Description
CompareWith |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Arguments |
BlockDmlOperation |
FunctionName |
PredicateType |
TableName |

See Also

SecurityPredicate Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace


SecurityPredicate Constructor

[image]

SQL Data Compare API 12.0.40
SecurityPredicate Constructor
SecurityPredicate Class See Also

Create a security predicate, the part of a security policy that restricts read or write access to data in a table or view.

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    functionName As String, _
    arguments As String, _
    tableName As String, _
    predicateType As PredicateType, _
    blockDmlOperation As BlockDmlOperation _
)
C#
public SecurityPredicate(
    string functionName,
    string arguments,
    string tableName,
    PredicateType predicateType,
    BlockDmlOperation blockDmlOperation
)
Visual C++
public:
SecurityPredicate(
    String^ functionName,
    String^ arguments,
    String^ tableName,
    PredicateType predicateType,
    BlockDmlOperation blockDmlOperation
)

Parameters

functionName
Type: String
arguments
Type: String
tableName
Type: String
predicateType
Type: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies..::.PredicateType
blockDmlOperation
Type: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies..::.BlockDmlOperation

See Also

SecurityPredicate Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace


SecurityPredicate Methods

[image] [image]

SQL Data Compare API 12.0.40
SecurityPredicate Methods
SecurityPredicate Class See Also

The SecurityPredicate type exposes the following methods.

Methods

Name | Description
CompareWith |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SecurityPredicate Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace


CompareWith Method

[image]

SQL Data Compare API 12.0.40
SecurityPredicate..::.CompareWith Method
SecurityPredicate Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareWith ( _
    obj As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference)
C#
public IEnumerable<EqualityDifference> CompareWith(
    ISqlComparable obj,
    Options options
)
Visual C++
public:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ obj,
    Options options
) sealed

Parameters

obj
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

SecurityPredicate Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace


SecurityPredicate Properties

[image] [image]

SQL Data Compare API 12.0.40
SecurityPredicate Properties
SecurityPredicate Class See Also

The SecurityPredicate type exposes the following properties.

Properties

Name | Description
Arguments |
BlockDmlOperation |
FunctionName |
PredicateType |
TableName |

See Also

SecurityPredicate Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace


Arguments Property

[image]

SQL Data Compare API 12.0.40
SecurityPredicate..::.Arguments Property
SecurityPredicate Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Arguments As String
C#
public string Arguments { get; private set; }
Visual C++
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}

See Also

SecurityPredicate Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace


BlockDmlOperation Property

[image]

SQL Data Compare API 12.0.40
SecurityPredicate..::.BlockDmlOperation Property
SecurityPredicate Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BlockDmlOperation As BlockDmlOperation
C#
public BlockDmlOperation BlockDmlOperation { get; private set; }
Visual C++
public:
property BlockDmlOperation BlockDmlOperation {
    BlockDmlOperation get ();
    void set (BlockDmlOperation value);
}

See Also

SecurityPredicate Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace


FunctionName Property

[image]

SQL Data Compare API 12.0.40
SecurityPredicate..::.FunctionName Property
SecurityPredicate Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FunctionName As String
C#
public string FunctionName { get; private set; }
Visual C++
public:
property String^ FunctionName {
    String^ get ();
    void set (String^ value);
}

See Also

SecurityPredicate Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace


PredicateType Property

[image]

SQL Data Compare API 12.0.40
SecurityPredicate..::.PredicateType Property
SecurityPredicate Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PredicateType As PredicateType
C#
public PredicateType PredicateType { get; private set; }
Visual C++
public:
property PredicateType PredicateType {
    PredicateType get ();
    void set (PredicateType value);
}

See Also

SecurityPredicate Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace


TableName Property

[image]

SQL Data Compare API 12.0.40
SecurityPredicate..::.TableName Property
SecurityPredicate Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TableName As String
C#
public string TableName { get; private set; }
Visual C++
public:
property String^ TableName {
    String^ get ();
    void set (String^ value);
}

See Also

SecurityPredicate Class
RedGate.SQLCompare.Engine.Model.DatabaseObjects.Security.SecurityPolicies Namespace


RedGate.SQLCompare.Engine.Model.Interfaces Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.Model.Interfaces Namespace

Interfaces

Interface | Description
IHasLastModifiedDate | Represents objects that support having a last modification date.


IHasLastModifiedDate Interface

[image]

SQL Data Compare API 12.0.40
IHasLastModifiedDate Interface
Members See Also

Represents objects that support having a last modification date.

Namespace: RedGate.SQLCompare.Engine.Model.Interfaces
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IHasLastModifiedDate
C#
public interface IHasLastModifiedDate
Visual C++
public interface class IHasLastModifiedDate

See Also

IHasLastModifiedDate Members
RedGate.SQLCompare.Engine.Model.Interfaces Namespace


IHasLastModifiedDate Members

[image] [image]

SQL Data Compare API 12.0.40
IHasLastModifiedDate Members
IHasLastModifiedDate Interface Properties See Also

The IHasLastModifiedDate type exposes the following members.

Properties

Name | Description
LastModified |

See Also

IHasLastModifiedDate Interface
RedGate.SQLCompare.Engine.Model.Interfaces Namespace


IHasLastModifiedDate Properties

[image] [image]

SQL Data Compare API 12.0.40
IHasLastModifiedDate Properties
IHasLastModifiedDate Interface See Also

The IHasLastModifiedDate type exposes the following properties.

Properties

Name | Description
LastModified |

See Also

IHasLastModifiedDate Interface
RedGate.SQLCompare.Engine.Model.Interfaces Namespace


LastModified Property

[image]

SQL Data Compare API 12.0.40
IHasLastModifiedDate..::.LastModified Property
IHasLastModifiedDate Interface See Also

Namespace: RedGate.SQLCompare.Engine.Model.Interfaces
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property LastModified As DateTime
C#
DateTime LastModified { get; }
Visual C++
property DateTime LastModified {
    DateTime get ();
}

See Also

IHasLastModifiedDate Interface
RedGate.SQLCompare.Engine.Model.Interfaces Namespace


RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace

Classes

Class | Description
SqlVersion |
WellKnownSqlVersions |

Interfaces

Interface | Description
IFeatureChecker |


IFeatureChecker Interface

[image]

SQL Data Compare API 12.0.40
IFeatureChecker Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IFeatureChecker
C#
public interface IFeatureChecker
Visual C++
public interface class IFeatureChecker

See Also

IFeatureChecker Members
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


IFeatureChecker Members

[image] [image]

SQL Data Compare API 12.0.40
IFeatureChecker Members
IFeatureChecker Interface Properties See Also

The IFeatureChecker type exposes the following members.

Properties

Name | Description
RequiresClusteredIndexOnAllTables | Tables on Azure are all required to have clustered indexes (or be empty) due to a limitation in the underlying database engine: https://msdn.microsoft.com/library/ee336245.aspx#cir Azure v12 lifts this restriction
RequiresCreateUserStatementToBeOnlyStatementInBatch | This is a peculiar requirement of the Azure TSQL engine.
RequiresExtraParamForSetTriggerOrder | Requires an extra param when calling sp_settriggerorder TODO: is this really necessary? We always just append ", null" when using this and msdn says the extra param is optional See https://msdn.microsoft.com/library/ms186762.aspx "Supported" on Azure
RequiresWithAppendToBeRemovedFromTriggers | WITH APPEND is a deprecated (finally removed in 2012) trigger option that appends a new trigger to the event rather than replacing any existing triggers. This is now the default behaviour (as of 2000!). Compare still cares because we have code that removes the WITH APPEND clause from trigger text to help with deploying old triggers See also https://msdn.microsoft.com/library/aa258254(v=sql.80).aspx and https://msdn.microsoft.com/library/ms144262.aspx Not supported in Azure
SupportsAlterRoleSyntax | Supports ALTER ROLE syntax Supports using CREATE ROLE / CREATE APPLICATION ROLE instead of sp_addrole / sp_addapprole Introduced in 2005: https://msdn.microsoft.com/library/ms189775.aspx Supported on Azure
SupportsAlterUserSyntax | Supports ALTER USER syntax Introduced in 2005: https://msdn.microsoft.com/library/ms176060.aspx Supported on Azure
SupportsApplicationRoles | Application roles are similar to normal database roles, but don't get assigned to users. Supported on Azure v12
SupportsArbitraryIndexesOnUserDefinedTableTypes | Prior to 2014, user-defined table types could only have "schema" indexes on them (unique and primary constraints). In 2014, you can now specify additional "performance" indexes as well (all other types of indexes) Probably not supported on Azure
SupportsCatalogIsAccentSensitive | The ACCENT_SENSITIVITY option on fulltext catalogs Introduced in 2005: https://msdn.microsoft.com/library/ms189520.aspx Probably supported in Azure v12
SupportsCatalogIsDefault | The AS DEFAULT option on fulltext catalogs Introduced in 2005: https://msdn.microsoft.com/library/ms189520.aspx Probably supported in Azure v12
SupportsCatalogsOnFilegroups | In 2000, fulltext catalogs were stored separately to the database In 2005, fulltext catalogs were assigned to a particular filegroup which would determine storage After 2005, fulltext catalogs became virtual and fulltext filegroups are set per-index See https://technet.microsoft.com/library/aa214429(v=sql.80).aspx and http://dba.stackexchange.com/q/3244 for more details Not supported on Azure
SupportsChangeTracking | Change tracking lets you query which rows have changed recently for tables that it is enabled on Introduced in 2008: https://msdn.microsoft.com/library/bb933875.aspx Note that this is NOT "change data capture": a related feature which we don't currently support Supported in Azure v12
SupportsCheckIdent | DBCC CHECKIDENT is used to check or change the value of IDENTITY columns Not supported in Azure
SupportsClrFeatures | Allows loading of .NET assemblies into SQL Server to run custom code Introduced in 2005: https://msdn.microsoft.com/library/ms254963.aspx CLR features are supported on Azure v12
SupportsClusteredColumnstoreIndexes | Supports columnstore indexes as the clustered index Introduced in 2014: https://msdn.microsoft.com/library/dn589807.aspx Supported on Azure v12
SupportsColumnSetSparse | Supports SPARSE and COLUMN_SET columns on tables. Introduced in 2008: https://msdn.microsoft.com/library/cc280604.aspx and https://msdn.microsoft.com/library/cc280521.aspx Supported on Azure
SupportsColumnstoreIndexes | An index where data is stored column-by-column instead of row-by-row. Makes some operations more efficient - eg adding up every value in a particular column Introduced in 2012: https://msdn.microsoft.com/library/gg492088.aspx Supported on Azure v12
SupportsCreateLogin | Supports the CREATE LOGIN syntax for creating logins. On Azure you need to create logins using the web portal instead. Azure v12 adds a CREATE LOGIN statement.
SupportsCreateTypeSyntax | Supports CREATE TYPE syntax instead of using sp_addtype Introduced in 2005: https://msdn.microsoft.com/library/ms175007.aspx Supported on Azure
SupportsCryptography | Supports certificates and (a)symmetric keys for encrypting data. Introduced in 2005: https://msdn.microsoft.com/library/bb510663.aspx Not supported on Azure
SupportsDataCompression | Supports row and page compression for tables and indexes Introduced in 2008: https://msdn.microsoft.com/library/cc280449.aspx Not supported on Azure
SupportsDdlTriggers | DDL (Data Definition Language) triggers fire on schema changes (CREATE, ALTER, etc) Introduced in 2005: https://msdn.microsoft.com/library/ms175941.aspx Supported on Azure
SupportsDefaults | Defaults are a long-deprecated feature. Default objects are created, and then separately 'bound' to table columns, acting like a default constraint on that column. Supported on Azure v12. For some reason.
SupportsDisablingRowAndPageLocks | Supports the ALLOW_ROW_LOCKS and ALLOW_PAGE_LOCKS options on indexes. These let the user tweak the locking behaviour of an index for performance reasons Introduced in 2005: https://msdn.microsoft.com/library/ms188783.aspx Not supported on Azure
SupportsDropRoleSyntax | Supports using the DROP ROLE syntax instead of calling sp_dropapprole Introduced in 2005 Supported on Azure
SupportsDropTypeSyntax | Supports using the DROP TYPE syntax instead of calling sp_droptype Introduced in 2005 Supported on Azure
SupportsDynamicDataMasking | Supports dynamic data masking, a feature introduced in 2016, that masks sensitive data to non-privileged users. See https://msdn.microsoft.com/en-gb/library/mt130841.aspx for more details.
SupportsEncryptedObjects | The WITH ENCRYPTION option on text objects (sprocs, functions, views, etc) obfuscates the text of the object so that it can't easily be read. This "encryption" is reversible with sa permissions on the database Introduced in 2005: https://msdn.microsoft.com/library/ms187926.aspx Not supported on Azure
SupportsExtendedProperties | Extended properties allow you to attach arbitrary key/value pairs to most database objects. Supported in everything except Azure: https://msdn.microsoft.com/library/ms190243.aspx
SupportsFilegroups | Databases can be stored on multiple files in the filesystem. This means (for example) that the database can be spread across multiple hard drives for increased performance, or some tables can be stored on an SSD vs a spinning disk. Filegroups are an abstraction over physical files - objects are assigned to filegroups, and then filegroups can be assigned files depending on what hardware is currently hosting the database. Since Azure hides away all the physical filesystem stuff, it doesn't support filegroups.
SupportsFilestreamColumns | Supports storing varbinary(max) data on the filesystem instead of inside tables Introduced in 2008: https://msdn.microsoft.com/library/bb933993.aspx Not supported on Azure
SupportsFiletables | File tables let you read filesystem files out of a folder on disk as FILESTREAM data Introduced in 2012: https://msdn.microsoft.com/library/ff929144.aspx Not supported in Azure
SupportsFilteredIndexes | Filtered indexes are like normal indexes that act against a subset of the rows Introduced in 2008: https://msdn.microsoft.com/library/cc280372.aspx Supported on Azure
SupportsFkSetDefault | Supports the SET DEFAULT option for ON DELETE / ON UPDATE properties of a foreign key. These control the behaviour of dependent tables when a foreign key value is modified. Introduced in 2005: https://msdn.microsoft.com/library/ms188066.aspx Supported on Azure
SupportsFkSetNull | Supports the SET NULL option for ON DELETE / ON UPDATE properties of a foreign key. These control the behaviour of dependent tables when a foreign key value is modified. Introduced in 2005: https://msdn.microsoft.com/library/ms188066.aspx Supported on Azure
SupportsFulltext | Fulltext lets you search over natural language text in a sensible way. Introduced in 2005: https://msdn.microsoft.com/library/ms142571.aspx Supported on Azure
SupportsFulltextCatalogTsqlSyntax |
SupportsFulltextChangeTracking | Lets the user customise how changes in the data are propagated into the fulltext index. Introduced in 2005: https://msdn.microsoft.com/library/ms187317.aspx Probably supported on Azure v12
SupportsFulltextIndexesOnViews | Supports putting fulltext indexes on views - introduced in 2005 (Probably) supported on Azure v12
SupportsFulltextStoplists | Fulltext stoplists are lists of "stopwords" - words to ignore when doing a search, such as "the" Introduced in 2008: https://msdn.microsoft.com/en-US/library/ms142551(v=sql.100).aspx (2005 had noise words instead) Supported on Azure v12
SupportsFulltextTsqlSyntax | Supports using ALTER FULLTEXT INDEX instead of sp_fulltext_column Introduced in 2005 Probably supported on Azure v12
SupportsGeographyTesselation | Supports some more options on spatial indexes. Spatial indexes are used to efficiently store and lookup information like points on a plane or points on a sphere (so an example query might be "find the nearest pub to my location" on Google Maps or similar) New options (manual tessellation) were introduced in 2012: https://msdn.microsoft.com/library/bb934196.aspx Supported on Azure
SupportsIncludedColumnsOnIndexes | Included columns let you store extra data in the index that is not used as part of the lookup Introduced in 2005: https://msdn.microsoft.com/library/ms190806.aspx Supported on Azure
SupportsIncrementalStatistics | When SQL Server uses an index, it stores "statistics" about the table that improve the generated query plans for future queries. "Incremental statistics" is a new feature in 2014 that lets statistics be updated over time rather than having to read the entire table in one go. See more: https://msdn.microsoft.com/library/ms190397.aspx Not supported in Azure
SupportsIndexFillFactor | A performance-tuning property on indexes. When creating a filter, specifies how much free space is left for new entries Introduced in 2005: https://msdn.microsoft.com/library/ms177459.aspx Not supported on Azure
SupportsLockEscalation | Lets users customise the lock escalation policy for a table (whether row locks get escalated to table locks in some circumstances) Introduced in 2008: https://msdn.microsoft.com/library/ms184286.aspx Supported on Azure
SupportsMemoryOptimizedFeatures | "In-Memory OLTP" (online transaction processing) is a set of features that allow large speedups when tables are hosted in RAM Introduced in 2014: https://msdn.microsoft.com/library/dn133186.aspx Not supported on Azure
SupportsMultipartNamesInSynonyms | Supports synonyms that reference another database or server. Not supported on Azure
SupportsNonSqlUsers | "Sql users" are users that log in directly to SQL Server using a username and password, as opposed to Windows Auth users that log in using some external mechanism. Azure doesn't support Windows Auth (aka "integrated security")- users need to be created using the Azure portal: https://msdn.microsoft.com/library/azure/ff394108.aspx#authentication
SupportsNotForReplication | Supports altering the NOT FOR REPLICATION option on a field. 2000 has NOT FOR REPLICATION, but only allows it to be set in a CREATE TABLE statement. 2005 and later can use ALTER TABLE. Not supported on Azure
SupportsNotForReplicationInAlterTable | Supports altering the NOT FOR REPLICATION option on a field. 2000 has NOT FOR REPLICATION, but only allows it to be set in a CREATE TABLE statement. 2005 and later can use ALTER TABLE. Not supported on Azure
SupportsPartitioning | Partitioning lets you store different parts of tables and indexes in different filegroups. Introduced in 2005: https://msdn.microsoft.com/library/ms190787.aspx Not supported on Azure. Supported on Azure v12, even though you can't use filegroups apart from Primary
SupportsPersistedColumns | Persisted columns are computed columns where the computed value is actually stored on disk. Normally, computed columns are recalculated when needed. Introduced in 2005: https://msdn.microsoft.com/library/ms191250.aspx Supported on Azure
SupportsPoisonMessageHandling | The POISON_MESSAGE_HANDLING option on CREATE/ALTER QUEUE. This allows Service Broker applications to define their own poison message handling when disabled Introduced in 2008 **R2**: https://msdn.microsoft.com/library/ms189529.aspx Not supported on Azure
SupportsRevokeConnect | Supports REVOKE CONNECT FROM permissions syntax Introduced in 2005: https://msdn.microsoft.com/library/ms177573.aspx Supported on Azure
SupportsRowGuidCol | ROWGUIDCOL is a convenient designator for a GUID-based unique ID column - particularly useful for ensuring identity across multiple machines. Supported in everything except Azure: https://msdn.microsoft.com/library/ms191131.aspx
SupportsRowLevelSecurity | Supports row-level security, a feature introduced in 2016, that can restrict access to a subset of the rows in a table. See https://msdn.microsoft.com/en-us/library/dn765131.aspx for more details. Supported on Azure V12.
SupportsRules | Rules are a long-deprecated feature. Rule objects are created, and then separately 'bound' to table columns, acting like a check constraint on that column. Supported on Azure v12. For some reason.
SupportsSearchPropertyLists | Adds searching of document metadata (ie properties) to fulltext indexes Introduced in 2012: https://msdn.microsoft.com/library/ee677637.aspx Not supported on Azure
SupportsSelectiveXmlIndexes | Selective XML indexes apply to a defined subset of the xml document, instead of all the elements. This means potentially much better index speeds for the bits you actually care about. Introduced in 2012 SP1: https://msdn.microsoft.com/library/jj670108.aspx Supported on Azure v12
SupportsSequences | Sequences are objects which hand out a stream of unique values Introduced in 2012: https://msdn.microsoft.com/library/ff878058.aspx Supported on Azure v12
SupportsServiceBroker | Service Broker is a whole bunch of features built around having message queues inside of SQL Server. Introduced in 2005: https://technet.microsoft.com/en-us/library/ms345108(v=sql.90).aspx Not supported on Azure
SupportsStretchDatabase | Supports stretch database, a feature introduced in 2016 that archives old data in a table to an Azure instance. Not supported on Azure, for obvious reasons.
SupportsSynonyms | Synonyms are aliases for other SQL Server objects (possibly on another server) Introduced in 2005: https://msdn.microsoft.com/library/ms187552.aspx Supported on Azure
SupportsSystemDateAndTableTypes | Whether the database has date/time/datetime2/datetimeoffset types defined. This means that when we see types with those names, we assume they are system-defined rather than user-defined types Supported on Azure
SupportsUseDatabaseStatement | USE [database] lets you switch which database a connection is pointing at Not supported on Azure
SupportsUserDefinedTableTypes | A user-defined table type is a user-defined type for the definition of a table structure. Introduced in 2008: https://msdn.microsoft.com/en-us/library/bb522526.aspx Supported on Azure
SupportsUserDefinedTypes | Supports user-defined types (CREATE TYPE syntax). Present in 2005 and later Supported on Azure
SupportsUsersWithoutLogin | Supports CREATE USER foo WITHOUT LOGIN Introduced in 2005: https://msdn.microsoft.com/library/ms173463.aspx Not supported in Azure
SupportsVarcharMaxColumns | Supports VARCHAR(MAX) columns Introduced in 2005: https://msdn.microsoft.com/library/ms176089.aspx Supported on Azure
SupportsXmlData | Allows storing xml data as a native type, with schema checking and useful indexing Introduced in 2005: https://msdn.microsoft.com/library/bb522446.aspx XML features are supported on Azure v12

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


IFeatureChecker Properties

[image] [image]

SQL Data Compare API 12.0.40
IFeatureChecker Properties
IFeatureChecker Interface See Also

The IFeatureChecker type exposes the following properties.

Properties

Name | Description
RequiresClusteredIndexOnAllTables | Tables on Azure are all required to have clustered indexes (or be empty) due to a limitation in the underlying database engine: https://msdn.microsoft.com/library/ee336245.aspx#cir Azure v12 lifts this restriction
RequiresCreateUserStatementToBeOnlyStatementInBatch | This is a peculiar requirement of the Azure TSQL engine.
RequiresExtraParamForSetTriggerOrder | Requires an extra param when calling sp_settriggerorder TODO: is this really necessary? We always just append ", null" when using this and msdn says the extra param is optional See https://msdn.microsoft.com/library/ms186762.aspx "Supported" on Azure
RequiresWithAppendToBeRemovedFromTriggers | WITH APPEND is a deprecated (finally removed in 2012) trigger option that appends a new trigger to the event rather than replacing any existing triggers. This is now the default behaviour (as of 2000!). Compare still cares because we have code that removes the WITH APPEND clause from trigger text to help with deploying old triggers See also https://msdn.microsoft.com/library/aa258254(v=sql.80).aspx and https://msdn.microsoft.com/library/ms144262.aspx Not supported in Azure
SupportsAlterRoleSyntax | Supports ALTER ROLE syntax Supports using CREATE ROLE / CREATE APPLICATION ROLE instead of sp_addrole / sp_addapprole Introduced in 2005: https://msdn.microsoft.com/library/ms189775.aspx Supported on Azure
SupportsAlterUserSyntax | Supports ALTER USER syntax Introduced in 2005: https://msdn.microsoft.com/library/ms176060.aspx Supported on Azure
SupportsApplicationRoles | Application roles are similar to normal database roles, but don't get assigned to users. Supported on Azure v12
SupportsArbitraryIndexesOnUserDefinedTableTypes | Prior to 2014, user-defined table types could only have "schema" indexes on them (unique and primary constraints). In 2014, you can now specify additional "performance" indexes as well (all other types of indexes) Probably not supported on Azure
SupportsCatalogIsAccentSensitive | The ACCENT_SENSITIVITY option on fulltext catalogs Introduced in 2005: https://msdn.microsoft.com/library/ms189520.aspx Probably supported in Azure v12
SupportsCatalogIsDefault | The AS DEFAULT option on fulltext catalogs Introduced in 2005: https://msdn.microsoft.com/library/ms189520.aspx Probably supported in Azure v12
SupportsCatalogsOnFilegroups | In 2000, fulltext catalogs were stored separately to the database In 2005, fulltext catalogs were assigned to a particular filegroup which would determine storage After 2005, fulltext catalogs became virtual and fulltext filegroups are set per-index See https://technet.microsoft.com/library/aa214429(v=sql.80).aspx and http://dba.stackexchange.com/q/3244 for more details Not supported on Azure
SupportsChangeTracking | Change tracking lets you query which rows have changed recently for tables that it is enabled on Introduced in 2008: https://msdn.microsoft.com/library/bb933875.aspx Note that this is NOT "change data capture": a related feature which we don't currently support Supported in Azure v12
SupportsCheckIdent | DBCC CHECKIDENT is used to check or change the value of IDENTITY columns Not supported in Azure
SupportsClrFeatures | Allows loading of .NET assemblies into SQL Server to run custom code Introduced in 2005: https://msdn.microsoft.com/library/ms254963.aspx CLR features are supported on Azure v12
SupportsClusteredColumnstoreIndexes | Supports columnstore indexes as the clustered index Introduced in 2014: https://msdn.microsoft.com/library/dn589807.aspx Supported on Azure v12
SupportsColumnSetSparse | Supports SPARSE and COLUMN_SET columns on tables. Introduced in 2008: https://msdn.microsoft.com/library/cc280604.aspx and https://msdn.microsoft.com/library/cc280521.aspx Supported on Azure
SupportsColumnstoreIndexes | An index where data is stored column-by-column instead of row-by-row. Makes some operations more efficient - eg adding up every value in a particular column Introduced in 2012: https://msdn.microsoft.com/library/gg492088.aspx Supported on Azure v12
SupportsCreateLogin | Supports the CREATE LOGIN syntax for creating logins. On Azure you need to create logins using the web portal instead. Azure v12 adds a CREATE LOGIN statement.
SupportsCreateTypeSyntax | Supports CREATE TYPE syntax instead of using sp_addtype Introduced in 2005: https://msdn.microsoft.com/library/ms175007.aspx Supported on Azure
SupportsCryptography | Supports certificates and (a)symmetric keys for encrypting data. Introduced in 2005: https://msdn.microsoft.com/library/bb510663.aspx Not supported on Azure
SupportsDataCompression | Supports row and page compression for tables and indexes Introduced in 2008: https://msdn.microsoft.com/library/cc280449.aspx Not supported on Azure
SupportsDdlTriggers | DDL (Data Definition Language) triggers fire on schema changes (CREATE, ALTER, etc) Introduced in 2005: https://msdn.microsoft.com/library/ms175941.aspx Supported on Azure
SupportsDefaults | Defaults are a long-deprecated feature. Default objects are created, and then separately 'bound' to table columns, acting like a default constraint on that column. Supported on Azure v12. For some reason.
SupportsDisablingRowAndPageLocks | Supports the ALLOW_ROW_LOCKS and ALLOW_PAGE_LOCKS options on indexes. These let the user tweak the locking behaviour of an index for performance reasons Introduced in 2005: https://msdn.microsoft.com/library/ms188783.aspx Not supported on Azure
SupportsDropRoleSyntax | Supports using the DROP ROLE syntax instead of calling sp_dropapprole Introduced in 2005 Supported on Azure
SupportsDropTypeSyntax | Supports using the DROP TYPE syntax instead of calling sp_droptype Introduced in 2005 Supported on Azure
SupportsDynamicDataMasking | Supports dynamic data masking, a feature introduced in 2016, that masks sensitive data to non-privileged users. See https://msdn.microsoft.com/en-gb/library/mt130841.aspx for more details.
SupportsEncryptedObjects | The WITH ENCRYPTION option on text objects (sprocs, functions, views, etc) obfuscates the text of the object so that it can't easily be read. This "encryption" is reversible with sa permissions on the database Introduced in 2005: https://msdn.microsoft.com/library/ms187926.aspx Not supported on Azure
SupportsExtendedProperties | Extended properties allow you to attach arbitrary key/value pairs to most database objects. Supported in everything except Azure: https://msdn.microsoft.com/library/ms190243.aspx
SupportsFilegroups | Databases can be stored on multiple files in the filesystem. This means (for example) that the database can be spread across multiple hard drives for increased performance, or some tables can be stored on an SSD vs a spinning disk. Filegroups are an abstraction over physical files - objects are assigned to filegroups, and then filegroups can be assigned files depending on what hardware is currently hosting the database. Since Azure hides away all the physical filesystem stuff, it doesn't support filegroups.
SupportsFilestreamColumns | Supports storing varbinary(max) data on the filesystem instead of inside tables Introduced in 2008: https://msdn.microsoft.com/library/bb933993.aspx Not supported on Azure
SupportsFiletables | File tables let you read filesystem files out of a folder on disk as FILESTREAM data Introduced in 2012: https://msdn.microsoft.com/library/ff929144.aspx Not supported in Azure
SupportsFilteredIndexes | Filtered indexes are like normal indexes that act against a subset of the rows Introduced in 2008: https://msdn.microsoft.com/library/cc280372.aspx Supported on Azure
SupportsFkSetDefault | Supports the SET DEFAULT option for ON DELETE / ON UPDATE properties of a foreign key. These control the behaviour of dependent tables when a foreign key value is modified. Introduced in 2005: https://msdn.microsoft.com/library/ms188066.aspx Supported on Azure
SupportsFkSetNull | Supports the SET NULL option for ON DELETE / ON UPDATE properties of a foreign key. These control the behaviour of dependent tables when a foreign key value is modified. Introduced in 2005: https://msdn.microsoft.com/library/ms188066.aspx Supported on Azure
SupportsFulltext | Fulltext lets you search over natural language text in a sensible way. Introduced in 2005: https://msdn.microsoft.com/library/ms142571.aspx Supported on Azure
SupportsFulltextCatalogTsqlSyntax |
SupportsFulltextChangeTracking | Lets the user customise how changes in the data are propagated into the fulltext index. Introduced in 2005: https://msdn.microsoft.com/library/ms187317.aspx Probably supported on Azure v12
SupportsFulltextIndexesOnViews | Supports putting fulltext indexes on views - introduced in 2005 (Probably) supported on Azure v12
SupportsFulltextStoplists | Fulltext stoplists are lists of "stopwords" - words to ignore when doing a search, such as "the" Introduced in 2008: https://msdn.microsoft.com/en-US/library/ms142551(v=sql.100).aspx (2005 had noise words instead) Supported on Azure v12
SupportsFulltextTsqlSyntax | Supports using ALTER FULLTEXT INDEX instead of sp_fulltext_column Introduced in 2005 Probably supported on Azure v12
SupportsGeographyTesselation | Supports some more options on spatial indexes. Spatial indexes are used to efficiently store and lookup information like points on a plane or points on a sphere (so an example query might be "find the nearest pub to my location" on Google Maps or similar) New options (manual tessellation) were introduced in 2012: https://msdn.microsoft.com/library/bb934196.aspx Supported on Azure
SupportsIncludedColumnsOnIndexes | Included columns let you store extra data in the index that is not used as part of the lookup Introduced in 2005: https://msdn.microsoft.com/library/ms190806.aspx Supported on Azure
SupportsIncrementalStatistics | When SQL Server uses an index, it stores "statistics" about the table that improve the generated query plans for future queries. "Incremental statistics" is a new feature in 2014 that lets statistics be updated over time rather than having to read the entire table in one go. See more: https://msdn.microsoft.com/library/ms190397.aspx Not supported in Azure
SupportsIndexFillFactor | A performance-tuning property on indexes. When creating a filter, specifies how much free space is left for new entries Introduced in 2005: https://msdn.microsoft.com/library/ms177459.aspx Not supported on Azure
SupportsLockEscalation | Lets users customise the lock escalation policy for a table (whether row locks get escalated to table locks in some circumstances) Introduced in 2008: https://msdn.microsoft.com/library/ms184286.aspx Supported on Azure
SupportsMemoryOptimizedFeatures | "In-Memory OLTP" (online transaction processing) is a set of features that allow large speedups when tables are hosted in RAM Introduced in 2014: https://msdn.microsoft.com/library/dn133186.aspx Not supported on Azure
SupportsMultipartNamesInSynonyms | Supports synonyms that reference another database or server. Not supported on Azure
SupportsNonSqlUsers | "Sql users" are users that log in directly to SQL Server using a username and password, as opposed to Windows Auth users that log in using some external mechanism. Azure doesn't support Windows Auth (aka "integrated security")- users need to be created using the Azure portal: https://msdn.microsoft.com/library/azure/ff394108.aspx#authentication
SupportsNotForReplication | Supports altering the NOT FOR REPLICATION option on a field. 2000 has NOT FOR REPLICATION, but only allows it to be set in a CREATE TABLE statement. 2005 and later can use ALTER TABLE. Not supported on Azure
SupportsNotForReplicationInAlterTable | Supports altering the NOT FOR REPLICATION option on a field. 2000 has NOT FOR REPLICATION, but only allows it to be set in a CREATE TABLE statement. 2005 and later can use ALTER TABLE. Not supported on Azure
SupportsPartitioning | Partitioning lets you store different parts of tables and indexes in different filegroups. Introduced in 2005: https://msdn.microsoft.com/library/ms190787.aspx Not supported on Azure. Supported on Azure v12, even though you can't use filegroups apart from Primary
SupportsPersistedColumns | Persisted columns are computed columns where the computed value is actually stored on disk. Normally, computed columns are recalculated when needed. Introduced in 2005: https://msdn.microsoft.com/library/ms191250.aspx Supported on Azure
SupportsPoisonMessageHandling | The POISON_MESSAGE_HANDLING option on CREATE/ALTER QUEUE. This allows Service Broker applications to define their own poison message handling when disabled Introduced in 2008 **R2**: https://msdn.microsoft.com/library/ms189529.aspx Not supported on Azure
SupportsRevokeConnect | Supports REVOKE CONNECT FROM permissions syntax Introduced in 2005: https://msdn.microsoft.com/library/ms177573.aspx Supported on Azure
SupportsRowGuidCol | ROWGUIDCOL is a convenient designator for a GUID-based unique ID column - particularly useful for ensuring identity across multiple machines. Supported in everything except Azure: https://msdn.microsoft.com/library/ms191131.aspx
SupportsRowLevelSecurity | Supports row-level security, a feature introduced in 2016, that can restrict access to a subset of the rows in a table. See https://msdn.microsoft.com/en-us/library/dn765131.aspx for more details. Supported on Azure V12.
SupportsRules | Rules are a long-deprecated feature. Rule objects are created, and then separately 'bound' to table columns, acting like a check constraint on that column. Supported on Azure v12. For some reason.
SupportsSearchPropertyLists | Adds searching of document metadata (ie properties) to fulltext indexes Introduced in 2012: https://msdn.microsoft.com/library/ee677637.aspx Not supported on Azure
SupportsSelectiveXmlIndexes | Selective XML indexes apply to a defined subset of the xml document, instead of all the elements. This means potentially much better index speeds for the bits you actually care about. Introduced in 2012 SP1: https://msdn.microsoft.com/library/jj670108.aspx Supported on Azure v12
SupportsSequences | Sequences are objects which hand out a stream of unique values Introduced in 2012: https://msdn.microsoft.com/library/ff878058.aspx Supported on Azure v12
SupportsServiceBroker | Service Broker is a whole bunch of features built around having message queues inside of SQL Server. Introduced in 2005: https://technet.microsoft.com/en-us/library/ms345108(v=sql.90).aspx Not supported on Azure
SupportsStretchDatabase | Supports stretch database, a feature introduced in 2016 that archives old data in a table to an Azure instance. Not supported on Azure, for obvious reasons.
SupportsSynonyms | Synonyms are aliases for other SQL Server objects (possibly on another server) Introduced in 2005: https://msdn.microsoft.com/library/ms187552.aspx Supported on Azure
SupportsSystemDateAndTableTypes | Whether the database has date/time/datetime2/datetimeoffset types defined. This means that when we see types with those names, we assume they are system-defined rather than user-defined types Supported on Azure
SupportsUseDatabaseStatement | USE [database] lets you switch which database a connection is pointing at Not supported on Azure
SupportsUserDefinedTableTypes | A user-defined table type is a user-defined type for the definition of a table structure. Introduced in 2008: https://msdn.microsoft.com/en-us/library/bb522526.aspx Supported on Azure
SupportsUserDefinedTypes | Supports user-defined types (CREATE TYPE syntax). Present in 2005 and later Supported on Azure
SupportsUsersWithoutLogin | Supports CREATE USER foo WITHOUT LOGIN Introduced in 2005: https://msdn.microsoft.com/library/ms173463.aspx Not supported in Azure
SupportsVarcharMaxColumns | Supports VARCHAR(MAX) columns Introduced in 2005: https://msdn.microsoft.com/library/ms176089.aspx Supported on Azure
SupportsXmlData | Allows storing xml data as a native type, with schema checking and useful indexing Introduced in 2005: https://msdn.microsoft.com/library/bb522446.aspx XML features are supported on Azure v12

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


RequiresClusteredIndexOnAllTables Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.RequiresClusteredIndexOnAllTables Property
IFeatureChecker Interface See Also

Tables on Azure are all required to have clustered indexes (or be empty) due to a limitation in the underlying database engine: https://msdn.microsoft.com/library/ee336245.aspx#cir Azure v12 lifts this restriction

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property RequiresClusteredIndexOnAllTables As Boolean
C#
bool RequiresClusteredIndexOnAllTables { get; }
Visual C++
property bool RequiresClusteredIndexOnAllTables {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


RequiresCreateUserStatementToBeOnlyStatementInBatch Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.RequiresCreateUserStatementToBeOnlyStatementInBatch Property
IFeatureChecker Interface See Also

This is a peculiar requirement of the Azure TSQL engine.

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property RequiresCreateUserStatementToBeOnlyStatementInBatch As Boolean
C#
bool RequiresCreateUserStatementToBeOnlyStatementInBatch { get; }
Visual C++
property bool RequiresCreateUserStatementToBeOnlyStatementInBatch {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


RequiresExtraParamForSetTriggerOrder Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.RequiresExtraParamForSetTriggerOrder Property
IFeatureChecker Interface See Also

Requires an extra param when calling sp_settriggerorder TODO: is this really necessary? We always just append ", null" when using this and msdn says the extra param is optional See https://msdn.microsoft.com/library/ms186762.aspx "Supported" on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property RequiresExtraParamForSetTriggerOrder As Boolean
C#
bool RequiresExtraParamForSetTriggerOrder { get; }
Visual C++
property bool RequiresExtraParamForSetTriggerOrder {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


RequiresWithAppendToBeRemovedFromTriggers Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.RequiresWithAppendToBeRemovedFromTriggers Property
IFeatureChecker Interface See Also

WITH APPEND is a deprecated (finally removed in 2012) trigger option that appends a new trigger to the event rather than replacing any existing triggers. This is now the default behaviour (as of 2000!). Compare still cares because we have code that removes the WITH APPEND clause from trigger text to help with deploying old triggers See also https://msdn.microsoft.com/library/aa258254(v=sql.80).aspx and https://msdn.microsoft.com/library/ms144262.aspx Not supported in Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property RequiresWithAppendToBeRemovedFromTriggers As Boolean
C#
bool RequiresWithAppendToBeRemovedFromTriggers { get; }
Visual C++
property bool RequiresWithAppendToBeRemovedFromTriggers {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsAlterRoleSyntax Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsAlterRoleSyntax Property
IFeatureChecker Interface See Also

Supports ALTER ROLE syntax Supports using CREATE ROLE / CREATE APPLICATION ROLE instead of sp_addrole / sp_addapprole Introduced in 2005: https://msdn.microsoft.com/library/ms189775.aspx Supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsAlterRoleSyntax As Boolean
C#
bool SupportsAlterRoleSyntax { get; }
Visual C++
property bool SupportsAlterRoleSyntax {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsAlterUserSyntax Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsAlterUserSyntax Property
IFeatureChecker Interface See Also

Supports ALTER USER syntax Introduced in 2005: https://msdn.microsoft.com/library/ms176060.aspx Supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsAlterUserSyntax As Boolean
C#
bool SupportsAlterUserSyntax { get; }
Visual C++
property bool SupportsAlterUserSyntax {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsApplicationRoles Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsApplicationRoles Property
IFeatureChecker Interface See Also

Application roles are similar to normal database roles, but don't get assigned to users. Supported on Azure v12

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsApplicationRoles As Boolean
C#
bool SupportsApplicationRoles { get; }
Visual C++
property bool SupportsApplicationRoles {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsArbitraryIndexesOnUserDefinedTableTypes Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsArbitraryIndexesOnUserDefinedTableTypes Property
IFeatureChecker Interface See Also

Prior to 2014, user-defined table types could only have "schema" indexes on them (unique and primary constraints). In 2014, you can now specify additional "performance" indexes as well (all other types of indexes) Probably not supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsArbitraryIndexesOnUserDefinedTableTypes As Boolean
C#
bool SupportsArbitraryIndexesOnUserDefinedTableTypes { get; }
Visual C++
property bool SupportsArbitraryIndexesOnUserDefinedTableTypes {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsCatalogIsAccentSensitive Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsCatalogIsAccentSensitive Property
IFeatureChecker Interface See Also

The ACCENT_SENSITIVITY option on fulltext catalogs Introduced in 2005: https://msdn.microsoft.com/library/ms189520.aspx Probably supported in Azure v12

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsCatalogIsAccentSensitive As Boolean
C#
bool SupportsCatalogIsAccentSensitive { get; }
Visual C++
property bool SupportsCatalogIsAccentSensitive {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsCatalogIsDefault Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsCatalogIsDefault Property
IFeatureChecker Interface See Also

The AS DEFAULT option on fulltext catalogs Introduced in 2005: https://msdn.microsoft.com/library/ms189520.aspx Probably supported in Azure v12

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsCatalogIsDefault As Boolean
C#
bool SupportsCatalogIsDefault { get; }
Visual C++
property bool SupportsCatalogIsDefault {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsCatalogsOnFilegroups Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsCatalogsOnFilegroups Property
IFeatureChecker Interface See Also

In 2000, fulltext catalogs were stored separately to the database In 2005, fulltext catalogs were assigned to a particular filegroup which would determine storage After 2005, fulltext catalogs became virtual and fulltext filegroups are set per-index See https://technet.microsoft.com/library/aa214429(v=sql.80).aspx and http://dba.stackexchange.com/q/3244 for more details Not supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsCatalogsOnFilegroups As Boolean
C#
bool SupportsCatalogsOnFilegroups { get; }
Visual C++
property bool SupportsCatalogsOnFilegroups {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsChangeTracking Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsChangeTracking Property
IFeatureChecker Interface See Also

Change tracking lets you query which rows have changed recently for tables that it is enabled on Introduced in 2008: https://msdn.microsoft.com/library/bb933875.aspx Note that this is NOT "change data capture": a related feature which we don't currently support Supported in Azure v12

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsChangeTracking As Boolean
C#
bool SupportsChangeTracking { get; }
Visual C++
property bool SupportsChangeTracking {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsCheckIdent Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsCheckIdent Property
IFeatureChecker Interface See Also

DBCC CHECKIDENT is used to check or change the value of IDENTITY columns Not supported in Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsCheckIdent As Boolean
C#
bool SupportsCheckIdent { get; }
Visual C++
property bool SupportsCheckIdent {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsClrFeatures Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsClrFeatures Property
IFeatureChecker Interface See Also

Allows loading of .NET assemblies into SQL Server to run custom code Introduced in 2005: https://msdn.microsoft.com/library/ms254963.aspx CLR features are supported on Azure v12

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsClrFeatures As Boolean
C#
bool SupportsClrFeatures { get; }
Visual C++
property bool SupportsClrFeatures {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsClusteredColumnstoreIndexes Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsClusteredColumnstoreIndexes Property
IFeatureChecker Interface See Also

Supports columnstore indexes as the clustered index Introduced in 2014: https://msdn.microsoft.com/library/dn589807.aspx Supported on Azure v12

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsClusteredColumnstoreIndexes As Boolean
C#
bool SupportsClusteredColumnstoreIndexes { get; }
Visual C++
property bool SupportsClusteredColumnstoreIndexes {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsColumnSetSparse Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsColumnSetSparse Property
IFeatureChecker Interface See Also

Supports SPARSE and COLUMN_SET columns on tables. Introduced in 2008: https://msdn.microsoft.com/library/cc280604.aspx and https://msdn.microsoft.com/library/cc280521.aspx Supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsColumnSetSparse As Boolean
C#
bool SupportsColumnSetSparse { get; }
Visual C++
property bool SupportsColumnSetSparse {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsColumnstoreIndexes Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsColumnstoreIndexes Property
IFeatureChecker Interface See Also

An index where data is stored column-by-column instead of row-by-row. Makes some operations more efficient - eg adding up every value in a particular column Introduced in 2012: https://msdn.microsoft.com/library/gg492088.aspx Supported on Azure v12

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsColumnstoreIndexes As Boolean
C#
bool SupportsColumnstoreIndexes { get; }
Visual C++
property bool SupportsColumnstoreIndexes {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsCreateLogin Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsCreateLogin Property
IFeatureChecker Interface See Also

Supports the CREATE LOGIN syntax for creating logins. On Azure you need to create logins using the web portal instead. Azure v12 adds a CREATE LOGIN statement.

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsCreateLogin As Boolean
C#
bool SupportsCreateLogin { get; }
Visual C++
property bool SupportsCreateLogin {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsCreateTypeSyntax Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsCreateTypeSyntax Property
IFeatureChecker Interface See Also

Supports CREATE TYPE syntax instead of using sp_addtype Introduced in 2005: https://msdn.microsoft.com/library/ms175007.aspx Supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsCreateTypeSyntax As Boolean
C#
bool SupportsCreateTypeSyntax { get; }
Visual C++
property bool SupportsCreateTypeSyntax {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsCryptography Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsCryptography Property
IFeatureChecker Interface See Also

Supports certificates and (a)symmetric keys for encrypting data. Introduced in 2005: https://msdn.microsoft.com/library/bb510663.aspx Not supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsCryptography As Boolean
C#
bool SupportsCryptography { get; }
Visual C++
property bool SupportsCryptography {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsDataCompression Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsDataCompression Property
IFeatureChecker Interface See Also

Supports row and page compression for tables and indexes Introduced in 2008: https://msdn.microsoft.com/library/cc280449.aspx Not supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsDataCompression As Boolean
C#
bool SupportsDataCompression { get; }
Visual C++
property bool SupportsDataCompression {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsDdlTriggers Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsDdlTriggers Property
IFeatureChecker Interface See Also

DDL (Data Definition Language) triggers fire on schema changes (CREATE, ALTER, etc) Introduced in 2005: https://msdn.microsoft.com/library/ms175941.aspx Supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsDdlTriggers As Boolean
C#
bool SupportsDdlTriggers { get; }
Visual C++
property bool SupportsDdlTriggers {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsDefaults Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsDefaults Property
IFeatureChecker Interface See Also

Defaults are a long-deprecated feature. Default objects are created, and then separately 'bound' to table columns, acting like a default constraint on that column. Supported on Azure v12. For some reason.

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsDefaults As Boolean
C#
bool SupportsDefaults { get; }
Visual C++
property bool SupportsDefaults {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsDisablingRowAndPageLocks Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsDisablingRowAndPageLocks Property
IFeatureChecker Interface See Also

Supports the ALLOW_ROW_LOCKS and ALLOW_PAGE_LOCKS options on indexes. These let the user tweak the locking behaviour of an index for performance reasons Introduced in 2005: https://msdn.microsoft.com/library/ms188783.aspx Not supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsDisablingRowAndPageLocks As Boolean
C#
bool SupportsDisablingRowAndPageLocks { get; }
Visual C++
property bool SupportsDisablingRowAndPageLocks {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsDropRoleSyntax Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsDropRoleSyntax Property
IFeatureChecker Interface See Also

Supports using the DROP ROLE syntax instead of calling sp_dropapprole Introduced in 2005 Supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsDropRoleSyntax As Boolean
C#
bool SupportsDropRoleSyntax { get; }
Visual C++
property bool SupportsDropRoleSyntax {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsDropTypeSyntax Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsDropTypeSyntax Property
IFeatureChecker Interface See Also

Supports using the DROP TYPE syntax instead of calling sp_droptype Introduced in 2005 Supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsDropTypeSyntax As Boolean
C#
bool SupportsDropTypeSyntax { get; }
Visual C++
property bool SupportsDropTypeSyntax {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsDynamicDataMasking Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsDynamicDataMasking Property
IFeatureChecker Interface See Also

Supports dynamic data masking, a feature introduced in 2016, that masks sensitive data to non-privileged users. See https://msdn.microsoft.com/en-gb/library/mt130841.aspx for more details.

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsDynamicDataMasking As Boolean
C#
bool SupportsDynamicDataMasking { get; }
Visual C++
property bool SupportsDynamicDataMasking {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsEncryptedObjects Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsEncryptedObjects Property
IFeatureChecker Interface See Also

The WITH ENCRYPTION option on text objects (sprocs, functions, views, etc) obfuscates the text of the object so that it can't easily be read. This "encryption" is reversible with sa permissions on the database Introduced in 2005: https://msdn.microsoft.com/library/ms187926.aspx Not supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsEncryptedObjects As Boolean
C#
bool SupportsEncryptedObjects { get; }
Visual C++
property bool SupportsEncryptedObjects {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsExtendedProperties Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsExtendedProperties Property
IFeatureChecker Interface See Also

Extended properties allow you to attach arbitrary key/value pairs to most database objects. Supported in everything except Azure: https://msdn.microsoft.com/library/ms190243.aspx

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsExtendedProperties As Boolean
C#
bool SupportsExtendedProperties { get; }
Visual C++
property bool SupportsExtendedProperties {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsFilegroups Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsFilegroups Property
IFeatureChecker Interface See Also

Databases can be stored on multiple files in the filesystem. This means (for example) that the database can be spread across multiple hard drives for increased performance, or some tables can be stored on an SSD vs a spinning disk. Filegroups are an abstraction over physical files - objects are assigned to filegroups, and then filegroups can be assigned files depending on what hardware is currently hosting the database. Since Azure hides away all the physical filesystem stuff, it doesn't support filegroups.

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsFilegroups As Boolean
C#
bool SupportsFilegroups { get; }
Visual C++
property bool SupportsFilegroups {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsFilestreamColumns Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsFilestreamColumns Property
IFeatureChecker Interface See Also

Supports storing varbinary(max) data on the filesystem instead of inside tables Introduced in 2008: https://msdn.microsoft.com/library/bb933993.aspx Not supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsFilestreamColumns As Boolean
C#
bool SupportsFilestreamColumns { get; }
Visual C++
property bool SupportsFilestreamColumns {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsFiletables Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsFiletables Property
IFeatureChecker Interface See Also

File tables let you read filesystem files out of a folder on disk as FILESTREAM data Introduced in 2012: https://msdn.microsoft.com/library/ff929144.aspx Not supported in Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsFiletables As Boolean
C#
bool SupportsFiletables { get; }
Visual C++
property bool SupportsFiletables {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsFilteredIndexes Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsFilteredIndexes Property
IFeatureChecker Interface See Also

Filtered indexes are like normal indexes that act against a subset of the rows Introduced in 2008: https://msdn.microsoft.com/library/cc280372.aspx Supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsFilteredIndexes As Boolean
C#
bool SupportsFilteredIndexes { get; }
Visual C++
property bool SupportsFilteredIndexes {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsFkSetDefault Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsFkSetDefault Property
IFeatureChecker Interface See Also

Supports the SET DEFAULT option for ON DELETE / ON UPDATE properties of a foreign key. These control the behaviour of dependent tables when a foreign key value is modified. Introduced in 2005: https://msdn.microsoft.com/library/ms188066.aspx Supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsFkSetDefault As Boolean
C#
bool SupportsFkSetDefault { get; }
Visual C++
property bool SupportsFkSetDefault {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsFkSetNull Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsFkSetNull Property
IFeatureChecker Interface See Also

Supports the SET NULL option for ON DELETE / ON UPDATE properties of a foreign key. These control the behaviour of dependent tables when a foreign key value is modified. Introduced in 2005: https://msdn.microsoft.com/library/ms188066.aspx Supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsFkSetNull As Boolean
C#
bool SupportsFkSetNull { get; }
Visual C++
property bool SupportsFkSetNull {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsFulltext Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsFulltext Property
IFeatureChecker Interface See Also

Fulltext lets you search over natural language text in a sensible way. Introduced in 2005: https://msdn.microsoft.com/library/ms142571.aspx Supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsFulltext As Boolean
C#
bool SupportsFulltext { get; }
Visual C++
property bool SupportsFulltext {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsFulltextCatalogTsqlSyntax Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsFulltextCatalogTsqlSyntax Property
IFeatureChecker Interface See Also

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsFulltextCatalogTsqlSyntax As Boolean
C#
bool SupportsFulltextCatalogTsqlSyntax { get; }
Visual C++
property bool SupportsFulltextCatalogTsqlSyntax {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsFulltextChangeTracking Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsFulltextChangeTracking Property
IFeatureChecker Interface See Also

Lets the user customise how changes in the data are propagated into the fulltext index. Introduced in 2005: https://msdn.microsoft.com/library/ms187317.aspx Probably supported on Azure v12

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsFulltextChangeTracking As Boolean
C#
bool SupportsFulltextChangeTracking { get; }
Visual C++
property bool SupportsFulltextChangeTracking {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsFulltextIndexesOnViews Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsFulltextIndexesOnViews Property
IFeatureChecker Interface See Also

Supports putting fulltext indexes on views - introduced in 2005 (Probably) supported on Azure v12

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsFulltextIndexesOnViews As Boolean
C#
bool SupportsFulltextIndexesOnViews { get; }
Visual C++
property bool SupportsFulltextIndexesOnViews {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsFulltextStoplists Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsFulltextStoplists Property
IFeatureChecker Interface See Also

Fulltext stoplists are lists of "stopwords" - words to ignore when doing a search, such as "the" Introduced in 2008: https://msdn.microsoft.com/en-US/library/ms142551(v=sql.100).aspx (2005 had noise words instead) Supported on Azure v12

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsFulltextStoplists As Boolean
C#
bool SupportsFulltextStoplists { get; }
Visual C++
property bool SupportsFulltextStoplists {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsFulltextTsqlSyntax Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsFulltextTsqlSyntax Property
IFeatureChecker Interface See Also

Supports using ALTER FULLTEXT INDEX instead of sp_fulltext_column Introduced in 2005 Probably supported on Azure v12

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsFulltextTsqlSyntax As Boolean
C#
bool SupportsFulltextTsqlSyntax { get; }
Visual C++
property bool SupportsFulltextTsqlSyntax {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsGeographyTesselation Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsGeographyTesselation Property
IFeatureChecker Interface See Also

Supports some more options on spatial indexes. Spatial indexes are used to efficiently store and lookup information like points on a plane or points on a sphere (so an example query might be "find the nearest pub to my location" on Google Maps or similar) New options (manual tessellation) were introduced in 2012: https://msdn.microsoft.com/library/bb934196.aspx Supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsGeographyTesselation As Boolean
C#
bool SupportsGeographyTesselation { get; }
Visual C++
property bool SupportsGeographyTesselation {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsIncludedColumnsOnIndexes Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsIncludedColumnsOnIndexes Property
IFeatureChecker Interface See Also

Included columns let you store extra data in the index that is not used as part of the lookup Introduced in 2005: https://msdn.microsoft.com/library/ms190806.aspx Supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsIncludedColumnsOnIndexes As Boolean
C#
bool SupportsIncludedColumnsOnIndexes { get; }
Visual C++
property bool SupportsIncludedColumnsOnIndexes {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsIncrementalStatistics Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsIncrementalStatistics Property
IFeatureChecker Interface See Also

When SQL Server uses an index, it stores "statistics" about the table that improve the generated query plans for future queries. "Incremental statistics" is a new feature in 2014 that lets statistics be updated over time rather than having to read the entire table in one go. See more: https://msdn.microsoft.com/library/ms190397.aspx Not supported in Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsIncrementalStatistics As Boolean
C#
bool SupportsIncrementalStatistics { get; }
Visual C++
property bool SupportsIncrementalStatistics {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsIndexFillFactor Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsIndexFillFactor Property
IFeatureChecker Interface See Also

A performance-tuning property on indexes. When creating a filter, specifies how much free space is left for new entries Introduced in 2005: https://msdn.microsoft.com/library/ms177459.aspx Not supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsIndexFillFactor As Boolean
C#
bool SupportsIndexFillFactor { get; }
Visual C++
property bool SupportsIndexFillFactor {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsLockEscalation Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsLockEscalation Property
IFeatureChecker Interface See Also

Lets users customise the lock escalation policy for a table (whether row locks get escalated to table locks in some circumstances) Introduced in 2008: https://msdn.microsoft.com/library/ms184286.aspx Supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsLockEscalation As Boolean
C#
bool SupportsLockEscalation { get; }
Visual C++
property bool SupportsLockEscalation {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsMemoryOptimizedFeatures Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsMemoryOptimizedFeatures Property
IFeatureChecker Interface See Also

"In-Memory OLTP" (online transaction processing) is a set of features that allow large speedups when tables are hosted in RAM Introduced in 2014: https://msdn.microsoft.com/library/dn133186.aspx Not supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsMemoryOptimizedFeatures As Boolean
C#
bool SupportsMemoryOptimizedFeatures { get; }
Visual C++
property bool SupportsMemoryOptimizedFeatures {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsMultipartNamesInSynonyms Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsMultipartNamesInSynonyms Property
IFeatureChecker Interface See Also

Supports synonyms that reference another database or server. Not supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsMultipartNamesInSynonyms As Boolean
C#
bool SupportsMultipartNamesInSynonyms { get; }
Visual C++
property bool SupportsMultipartNamesInSynonyms {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace
synonyms


SupportsNonSqlUsers Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsNonSqlUsers Property
IFeatureChecker Interface See Also

"Sql users" are users that log in directly to SQL Server using a username and password, as opposed to Windows Auth users that log in using some external mechanism. Azure doesn't support Windows Auth (aka "integrated security")- users need to be created using the Azure portal: https://msdn.microsoft.com/library/azure/ff394108.aspx#authentication

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsNonSqlUsers As Boolean
C#
bool SupportsNonSqlUsers { get; }
Visual C++
property bool SupportsNonSqlUsers {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsNotForReplication Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsNotForReplication Property
IFeatureChecker Interface See Also

Supports altering the NOT FOR REPLICATION option on a field. 2000 has NOT FOR REPLICATION, but only allows it to be set in a CREATE TABLE statement. 2005 and later can use ALTER TABLE. Not supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsNotForReplication As Boolean
C#
bool SupportsNotForReplication { get; }
Visual C++
property bool SupportsNotForReplication {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsNotForReplicationInAlterTable Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsNotForReplicationInAlterTable Property
IFeatureChecker Interface See Also

Supports altering the NOT FOR REPLICATION option on a field. 2000 has NOT FOR REPLICATION, but only allows it to be set in a CREATE TABLE statement. 2005 and later can use ALTER TABLE. Not supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsNotForReplicationInAlterTable As Boolean
C#
bool SupportsNotForReplicationInAlterTable { get; }
Visual C++
property bool SupportsNotForReplicationInAlterTable {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsPartitioning Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsPartitioning Property
IFeatureChecker Interface See Also

Partitioning lets you store different parts of tables and indexes in different filegroups. Introduced in 2005: https://msdn.microsoft.com/library/ms190787.aspx Not supported on Azure. Supported on Azure v12, even though you can't use filegroups apart from Primary

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsPartitioning As Boolean
C#
bool SupportsPartitioning { get; }
Visual C++
property bool SupportsPartitioning {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsPersistedColumns Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsPersistedColumns Property
IFeatureChecker Interface See Also

Persisted columns are computed columns where the computed value is actually stored on disk. Normally, computed columns are recalculated when needed. Introduced in 2005: https://msdn.microsoft.com/library/ms191250.aspx Supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsPersistedColumns As Boolean
C#
bool SupportsPersistedColumns { get; }
Visual C++
property bool SupportsPersistedColumns {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsPoisonMessageHandling Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsPoisonMessageHandling Property
IFeatureChecker Interface See Also

The POISON_MESSAGE_HANDLING option on CREATE/ALTER QUEUE. This allows Service Broker applications to define their own poison message handling when disabled Introduced in 2008 **R2**: https://msdn.microsoft.com/library/ms189529.aspx Not supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsPoisonMessageHandling As Boolean
C#
bool SupportsPoisonMessageHandling { get; }
Visual C++
property bool SupportsPoisonMessageHandling {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsRevokeConnect Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsRevokeConnect Property
IFeatureChecker Interface See Also

Supports REVOKE CONNECT FROM permissions syntax Introduced in 2005: https://msdn.microsoft.com/library/ms177573.aspx Supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsRevokeConnect As Boolean
C#
bool SupportsRevokeConnect { get; }
Visual C++
property bool SupportsRevokeConnect {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsRowGuidCol Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsRowGuidCol Property
IFeatureChecker Interface See Also

ROWGUIDCOL is a convenient designator for a GUID-based unique ID column - particularly useful for ensuring identity across multiple machines. Supported in everything except Azure: https://msdn.microsoft.com/library/ms191131.aspx

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsRowGuidCol As Boolean
C#
bool SupportsRowGuidCol { get; }
Visual C++
property bool SupportsRowGuidCol {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsRowLevelSecurity Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsRowLevelSecurity Property
IFeatureChecker Interface See Also

Supports row-level security, a feature introduced in 2016, that can restrict access to a subset of the rows in a table. See https://msdn.microsoft.com/en-us/library/dn765131.aspx for more details. Supported on Azure V12.

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsRowLevelSecurity As Boolean
C#
bool SupportsRowLevelSecurity { get; }
Visual C++
property bool SupportsRowLevelSecurity {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsRules Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsRules Property
IFeatureChecker Interface See Also

Rules are a long-deprecated feature. Rule objects are created, and then separately 'bound' to table columns, acting like a check constraint on that column. Supported on Azure v12. For some reason.

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsRules As Boolean
C#
bool SupportsRules { get; }
Visual C++
property bool SupportsRules {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsSearchPropertyLists Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsSearchPropertyLists Property
IFeatureChecker Interface See Also

Adds searching of document metadata (ie properties) to fulltext indexes Introduced in 2012: https://msdn.microsoft.com/library/ee677637.aspx Not supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsSearchPropertyLists As Boolean
C#
bool SupportsSearchPropertyLists { get; }
Visual C++
property bool SupportsSearchPropertyLists {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsSelectiveXmlIndexes Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsSelectiveXmlIndexes Property
IFeatureChecker Interface See Also

Selective XML indexes apply to a defined subset of the xml document, instead of all the elements. This means potentially much better index speeds for the bits you actually care about. Introduced in 2012 SP1: https://msdn.microsoft.com/library/jj670108.aspx Supported on Azure v12

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsSelectiveXmlIndexes As Boolean
C#
bool SupportsSelectiveXmlIndexes { get; }
Visual C++
property bool SupportsSelectiveXmlIndexes {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsSequences Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsSequences Property
IFeatureChecker Interface See Also

Sequences are objects which hand out a stream of unique values Introduced in 2012: https://msdn.microsoft.com/library/ff878058.aspx Supported on Azure v12

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsSequences As Boolean
C#
bool SupportsSequences { get; }
Visual C++
property bool SupportsSequences {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsServiceBroker Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsServiceBroker Property
IFeatureChecker Interface See Also

Service Broker is a whole bunch of features built around having message queues inside of SQL Server. Introduced in 2005: https://technet.microsoft.com/en-us/library/ms345108(v=sql.90).aspx Not supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsServiceBroker As Boolean
C#
bool SupportsServiceBroker { get; }
Visual C++
property bool SupportsServiceBroker {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsStretchDatabase Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsStretchDatabase Property
IFeatureChecker Interface See Also

Supports stretch database, a feature introduced in 2016 that archives old data in a table to an Azure instance. Not supported on Azure, for obvious reasons.

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsStretchDatabase As Boolean
C#
bool SupportsStretchDatabase { get; }
Visual C++
property bool SupportsStretchDatabase {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsSynonyms Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsSynonyms Property
IFeatureChecker Interface See Also

Synonyms are aliases for other SQL Server objects (possibly on another server) Introduced in 2005: https://msdn.microsoft.com/library/ms187552.aspx Supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsSynonyms As Boolean
C#
bool SupportsSynonyms { get; }
Visual C++
property bool SupportsSynonyms {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsSystemDateAndTableTypes Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsSystemDateAndTableTypes Property
IFeatureChecker Interface See Also

Whether the database has date/time/datetime2/datetimeoffset types defined. This means that when we see types with those names, we assume they are system-defined rather than user-defined types Supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsSystemDateAndTableTypes As Boolean
C#
bool SupportsSystemDateAndTableTypes { get; }
Visual C++
property bool SupportsSystemDateAndTableTypes {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsUseDatabaseStatement Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsUseDatabaseStatement Property
IFeatureChecker Interface See Also

USE [database] lets you switch which database a connection is pointing at Not supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsUseDatabaseStatement As Boolean
C#
bool SupportsUseDatabaseStatement { get; }
Visual C++
property bool SupportsUseDatabaseStatement {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsUserDefinedTableTypes Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsUserDefinedTableTypes Property
IFeatureChecker Interface See Also

A user-defined table type is a user-defined type for the definition of a table structure. Introduced in 2008: https://msdn.microsoft.com/en-us/library/bb522526.aspx Supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsUserDefinedTableTypes As Boolean
C#
bool SupportsUserDefinedTableTypes { get; }
Visual C++
property bool SupportsUserDefinedTableTypes {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsUserDefinedTypes Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsUserDefinedTypes Property
IFeatureChecker Interface See Also

Supports user-defined types (CREATE TYPE syntax). Present in 2005 and later Supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsUserDefinedTypes As Boolean
C#
bool SupportsUserDefinedTypes { get; }
Visual C++
property bool SupportsUserDefinedTypes {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsUsersWithoutLogin Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsUsersWithoutLogin Property
IFeatureChecker Interface See Also

Supports CREATE USER foo WITHOUT LOGIN Introduced in 2005: https://msdn.microsoft.com/library/ms173463.aspx Not supported in Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsUsersWithoutLogin As Boolean
C#
bool SupportsUsersWithoutLogin { get; }
Visual C++
property bool SupportsUsersWithoutLogin {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsVarcharMaxColumns Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsVarcharMaxColumns Property
IFeatureChecker Interface See Also

Supports VARCHAR(MAX) columns Introduced in 2005: https://msdn.microsoft.com/library/ms176089.aspx Supported on Azure

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsVarcharMaxColumns As Boolean
C#
bool SupportsVarcharMaxColumns { get; }
Visual C++
property bool SupportsVarcharMaxColumns {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SupportsXmlData Property

[image]

SQL Data Compare API 12.0.40
IFeatureChecker..::.SupportsXmlData Property
IFeatureChecker Interface See Also

Allows storing xml data as a native type, with schema checking and useful indexing Introduced in 2005: https://msdn.microsoft.com/library/bb522446.aspx XML features are supported on Azure v12

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsXmlData As Boolean
C#
bool SupportsXmlData { get; }
Visual C++
property bool SupportsXmlData {
    bool get ();
}

See Also

IFeatureChecker Interface
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SqlVersion Class

[image]

SQL Data Compare API 12.0.40
SqlVersion Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlVersion
C#
public class SqlVersion
Visual C++
public ref class SqlVersion

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.SqlVersion

See Also

SqlVersion Members
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SqlVersion Members

[image] [image]

SQL Data Compare API 12.0.40
SqlVersion Members
SqlVersion Class Constructors Methods Fields See Also

The SqlVersion type exposes the following members.

Constructors

Name | Description
SqlVersion |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetShuSqlVersion | This method returns a Shared Utils SQLVersion for e.g. comparing with other such SQLVersions
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Build |
CompatibilityLevel |
IsAzure |
IsDataWarehouse | note: this is currently exclusive with IsAzure, although this being true probably indicates Azure Data Warehouse instead of the on-prem PDW version

See Also

SqlVersion Class
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SqlVersion Constructor

[image]

SQL Data Compare API 12.0.40
SqlVersion Constructor
SqlVersion Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    isAzure As Boolean, _
    build As Version, _
    compatibilityLevel As Integer, _
    isDataWarehouse As Boolean _
)
C#
public SqlVersion(
    bool isAzure,
    Version build,
    int compatibilityLevel,
    bool isDataWarehouse
)
Visual C++
public:
SqlVersion(
    bool isAzure,
    Version^ build,
    int compatibilityLevel,
    bool isDataWarehouse
)

Parameters

isAzure
Type: Boolean
build
Type: Version
compatibilityLevel
Type: Int32
isDataWarehouse
Type: Boolean

See Also

SqlVersion Class
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SqlVersion Fields

[image] [image]

SQL Data Compare API 12.0.40
SqlVersion Fields
SqlVersion Class See Also

The SqlVersion type exposes the following fields.

Fields

Name | Description
Build |
CompatibilityLevel |
IsAzure |
IsDataWarehouse | note: this is currently exclusive with IsAzure, although this being true probably indicates Azure Data Warehouse instead of the on-prem PDW version

See Also

SqlVersion Class
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


Build Field

[image]

SQL Data Compare API 12.0.40
SqlVersion..::.Build Field
SqlVersion Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Build As Version
C#
public readonly Version Build
Visual C++
public:
initonly Version^ Build

See Also

SqlVersion Class
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


CompatibilityLevel Field

[image]

SQL Data Compare API 12.0.40
SqlVersion..::.CompatibilityLevel Field
SqlVersion Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly CompatibilityLevel As Integer
C#
public readonly int CompatibilityLevel
Visual C++
public:
initonly int CompatibilityLevel

See Also

SqlVersion Class
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


IsAzure Field

[image]

SQL Data Compare API 12.0.40
SqlVersion..::.IsAzure Field
SqlVersion Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly IsAzure As Boolean
C#
public readonly bool IsAzure
Visual C++
public:
initonly bool IsAzure

See Also

SqlVersion Class
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


IsDataWarehouse Field

[image]

SQL Data Compare API 12.0.40
SqlVersion..::.IsDataWarehouse Field
SqlVersion Class See Also

note: this is currently exclusive with IsAzure, although this being true probably indicates Azure Data Warehouse instead of the on-prem PDW version

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly IsDataWarehouse As Boolean
C#
public readonly bool IsDataWarehouse
Visual C++
public:
initonly bool IsDataWarehouse

See Also

SqlVersion Class
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SqlVersion Methods

[image] [image]

SQL Data Compare API 12.0.40
SqlVersion Methods
SqlVersion Class See Also

The SqlVersion type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetShuSqlVersion | This method returns a Shared Utils SQLVersion for e.g. comparing with other such SQLVersions
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlVersion Class
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


GetShuSqlVersion Method

[image]

SQL Data Compare API 12.0.40
SqlVersion..::.GetShuSqlVersion Method
SqlVersion Class See Also

This method returns a Shared Utils SQLVersion for e.g. comparing with other such SQLVersions

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetShuSqlVersion As SQLVersion
C#
public SQLVersion GetShuSqlVersion()
Visual C++
public:
SQLVersion GetShuSqlVersion()

Remarks

This always uses the server version and does not take the database's compatibility level into account

See Also

SqlVersion Class
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


WellKnownSqlVersions Class

[image]

SQL Data Compare API 12.0.40
WellKnownSqlVersions Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class WellKnownSqlVersions
C#
public static class WellKnownSqlVersions
Visual C++
public ref class WellKnownSqlVersions abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Model.SqlServerVersioning..::.WellKnownSqlVersions

See Also

WellKnownSqlVersions Members
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


WellKnownSqlVersions Members

[image] [image]

SQL Data Compare API 12.0.40
WellKnownSqlVersions Members
WellKnownSqlVersions Class Methods Fields See Also

The WellKnownSqlVersions type exposes the following members.

Methods

Name | Description
CreateFromAzurenessAndShuVersion |
CreateFromBackup |

Fields

Name | Description
Azure |
AzureV12 |
Earliest | The oldest SQL Server version supported by Compare
Latest | The newest SQL Server version supported by Compare
SqlServer2005 |
SqlServer2008 |
SqlServer2008R2 |
SqlServer2012 |
SqlServer2012Sp1 |
SqlServer2014 |
SqlServer2016 |
Unknown | This replicates what version information you would have got if no information had been provided

See Also

WellKnownSqlVersions Class
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


WellKnownSqlVersions Fields

[image] [image]

SQL Data Compare API 12.0.40
WellKnownSqlVersions Fields
WellKnownSqlVersions Class See Also

The WellKnownSqlVersions type exposes the following fields.

Fields

Name | Description
Azure |
AzureV12 |
Earliest | The oldest SQL Server version supported by Compare
Latest | The newest SQL Server version supported by Compare
SqlServer2005 |
SqlServer2008 |
SqlServer2008R2 |
SqlServer2012 |
SqlServer2012Sp1 |
SqlServer2014 |
SqlServer2016 |
Unknown | This replicates what version information you would have got if no information had been provided

See Also

WellKnownSqlVersions Class
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


Azure Field

[image]

SQL Data Compare API 12.0.40
WellKnownSqlVersions..::.Azure Field
WellKnownSqlVersions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Azure As SqlVersion
C#
public static readonly SqlVersion Azure
Visual C++
public:
static initonly SqlVersion^ Azure

See Also

WellKnownSqlVersions Class
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


AzureV12 Field

[image]

SQL Data Compare API 12.0.40
WellKnownSqlVersions..::.AzureV12 Field
WellKnownSqlVersions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly AzureV12 As SqlVersion
C#
public static readonly SqlVersion AzureV12
Visual C++
public:
static initonly SqlVersion^ AzureV12

See Also

WellKnownSqlVersions Class
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


Earliest Field

[image]

SQL Data Compare API 12.0.40
WellKnownSqlVersions..::.Earliest Field
WellKnownSqlVersions Class See Also

The oldest SQL Server version supported by Compare

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Earliest As SqlVersion
C#
public static readonly SqlVersion Earliest
Visual C++
public:
static initonly SqlVersion^ Earliest

See Also

WellKnownSqlVersions Class
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


Latest Field

[image]

SQL Data Compare API 12.0.40
WellKnownSqlVersions..::.Latest Field
WellKnownSqlVersions Class See Also

The newest SQL Server version supported by Compare

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Latest As SqlVersion
C#
public static readonly SqlVersion Latest
Visual C++
public:
static initonly SqlVersion^ Latest

See Also

WellKnownSqlVersions Class
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SqlServer2005 Field

[image]

SQL Data Compare API 12.0.40
WellKnownSqlVersions..::.SqlServer2005 Field
WellKnownSqlVersions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SqlServer2005 As SqlVersion
C#
public static readonly SqlVersion SqlServer2005
Visual C++
public:
static initonly SqlVersion^ SqlServer2005

See Also

WellKnownSqlVersions Class
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SqlServer2008 Field

[image]

SQL Data Compare API 12.0.40
WellKnownSqlVersions..::.SqlServer2008 Field
WellKnownSqlVersions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SqlServer2008 As SqlVersion
C#
public static readonly SqlVersion SqlServer2008
Visual C++
public:
static initonly SqlVersion^ SqlServer2008

See Also

WellKnownSqlVersions Class
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SqlServer2008R2 Field

[image]

SQL Data Compare API 12.0.40
WellKnownSqlVersions..::.SqlServer2008R2 Field
WellKnownSqlVersions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SqlServer2008R2 As SqlVersion
C#
public static readonly SqlVersion SqlServer2008R2
Visual C++
public:
static initonly SqlVersion^ SqlServer2008R2

See Also

WellKnownSqlVersions Class
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SqlServer2012 Field

[image]

SQL Data Compare API 12.0.40
WellKnownSqlVersions..::.SqlServer2012 Field
WellKnownSqlVersions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SqlServer2012 As SqlVersion
C#
public static readonly SqlVersion SqlServer2012
Visual C++
public:
static initonly SqlVersion^ SqlServer2012

See Also

WellKnownSqlVersions Class
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SqlServer2012Sp1 Field

[image]

SQL Data Compare API 12.0.40
WellKnownSqlVersions..::.SqlServer2012Sp1 Field
WellKnownSqlVersions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SqlServer2012Sp1 As SqlVersion
C#
public static readonly SqlVersion SqlServer2012Sp1
Visual C++
public:
static initonly SqlVersion^ SqlServer2012Sp1

See Also

WellKnownSqlVersions Class
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SqlServer2014 Field

[image]

SQL Data Compare API 12.0.40
WellKnownSqlVersions..::.SqlServer2014 Field
WellKnownSqlVersions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SqlServer2014 As SqlVersion
C#
public static readonly SqlVersion SqlServer2014
Visual C++
public:
static initonly SqlVersion^ SqlServer2014

See Also

WellKnownSqlVersions Class
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


SqlServer2016 Field

[image]

SQL Data Compare API 12.0.40
WellKnownSqlVersions..::.SqlServer2016 Field
WellKnownSqlVersions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SqlServer2016 As SqlVersion
C#
public static readonly SqlVersion SqlServer2016
Visual C++
public:
static initonly SqlVersion^ SqlServer2016

See Also

WellKnownSqlVersions Class
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


Unknown Field

[image]

SQL Data Compare API 12.0.40
WellKnownSqlVersions..::.Unknown Field
WellKnownSqlVersions Class See Also

This replicates what version information you would have got if no information had been provided

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Unknown As SqlVersion
C#
public static readonly SqlVersion Unknown
Visual C++
public:
static initonly SqlVersion^ Unknown

See Also

WellKnownSqlVersions Class
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


WellKnownSqlVersions Methods

[image] [image]

SQL Data Compare API 12.0.40
WellKnownSqlVersions Methods
WellKnownSqlVersions Class See Also

The WellKnownSqlVersions type exposes the following methods.

Methods

Name | Description
CreateFromAzurenessAndShuVersion |
CreateFromBackup |

See Also

WellKnownSqlVersions Class
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


CreateFromAzurenessAndShuVersion Method

[image]

SQL Data Compare API 12.0.40
WellKnownSqlVersions..::.CreateFromAzurenessAndShuVersion Method
WellKnownSqlVersions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateFromAzurenessAndShuVersion ( _
    isAzure As Boolean, _
    shuSqlVersion As SQLVersion _
) As SqlVersion
C#
public static SqlVersion CreateFromAzurenessAndShuVersion(
    bool isAzure,
    SQLVersion shuSqlVersion
)
Visual C++
public:
static SqlVersion^ CreateFromAzurenessAndShuVersion(
    bool isAzure,
    SQLVersion shuSqlVersion
)

Parameters

isAzure
Type: Boolean
shuSqlVersion
Type: SQLVersion

See Also

WellKnownSqlVersions Class
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


CreateFromBackup Method

[image]

SQL Data Compare API 12.0.40
WellKnownSqlVersions..::.CreateFromBackup Method
WellKnownSqlVersions Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.SqlServerVersioning
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateFromBackup ( _
    backupConnection As IBackupConnection _
) As SqlVersion
C#
public static SqlVersion CreateFromBackup(
    IBackupConnection backupConnection
)
Visual C++
public:
static SqlVersion^ CreateFromBackup(
    IBackupConnection^ backupConnection
)

Parameters

backupConnection
Type: RedGate.Shared.SQL.BackupReaderInterfaces..::.IBackupConnection

See Also

WellKnownSqlVersions Class
RedGate.SQLCompare.Engine.Model.SqlServerVersioning Namespace


RedGate.SQLCompare.Engine.Model.XmlIndexes Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.Model.XmlIndexes Namespace

Classes

Class | Description
XmlIndex |

Enumerations

Enumeration | Description
SecondaryType | The secondary type of the XML index
XmlIndexType |


SecondaryType Enumeration

[image]

SQL Data Compare API 12.0.40
SecondaryType Enumeration
See Also

The secondary type of the XML index

Namespace: RedGate.SQLCompare.Engine.Model.XmlIndexes
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration SecondaryType
C#
public enum SecondaryType
Visual C++
public enum class SecondaryType

Members

Member name | Description
None | None.
Value | Value.
Path | Path.
Property | Property.

See Also

RedGate.SQLCompare.Engine.Model.XmlIndexes Namespace


XmlIndex Class

[image]

SQL Data Compare API 12.0.40
XmlIndex Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Model.XmlIndexes
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class XmlIndex _
    Inherits Index
C#
public sealed class XmlIndex : Index
Visual C++
public ref class XmlIndex sealed : public Index

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.Index
RedGate.SQLCompare.Engine.Model.XmlIndexes..::.XmlIndex

See Also

XmlIndex Members
RedGate.SQLCompare.Engine.Model.XmlIndexes Namespace


XmlIndex Members

[image] [image]

SQL Data Compare API 12.0.40
XmlIndex Members
XmlIndex Class Methods Properties Explicit Interface Implementations See Also

The XmlIndex type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FieldsCompareWith | (Inherited from Index.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetPrimarySelectivePath |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowPageLocks | True if the index allows page locks. (Inherited from Index.)
AllowRowLocks | True if the index allows row locks. (Inherited from Index.)
Clustered | Obsolete. (Inherited from Index.)
Database | The database to which the index belongs. (Inherited from Index.)
Fields | The fields in the index. (Inherited from Index.)
FileGroup | Obsolete. (Inherited from Index.)
FileGroupOrPartitionScheme | The filegroup or the partition scheme on which the index is defined. (Inherited from Index.)
FilestreamFileGroup | Obsolete. (Inherited from Index.)
FillFactor | The fill factor. (Inherited from Index.)
Filter | Obsolete. (Inherited from Index.)
FullScan | True if the index is defined with FullScan (Inherited from Index.)
FullyQualifiedName | Obsolete. The fully-qualified name of the index. DANGER WILL ROBINSON!! This is not escaped. (Inherited from Index.)
IgnoreDuplicateKeys | True if set to ignore duplicate keys. (Inherited from Index.)
Incremental | True if incremental (introduced in SQL Server 2014) (Inherited from Index.)
IsColumnstore | Stupid columnstore indexes mark all of their fields as included but use the normal syntax to list them. (http://msdn.microsoft.com/en-us/library/ms175105.aspx) (Inherited from Index.)
IsDisabled | Indicates whether the index is disabled. (Inherited from Index.)
IsKeyIndexForFullTextIndex | Obsolete. (Inherited from Index.)
IsPartitioned | Indicates whether the index is built on a partition scheme. If it is, the name of the partition scheme is returned by the FileGroupOrPartitionScheme property. (Inherited from Index.)
Name | The name of the index. DANGER WILL ROBINSON!! This is not escaped. Do you mean Index..::.QualifiedName? (Inherited from Index.)
NoRecompute | True if the index is defined with NORECOMPUTE. (Inherited from Index.)
ObjectType | Returns ObjectType.Index (Inherited from Index.)
Online | True iff the index is to be created online. (Inherited from Index.)
Owner | The owner of the index's table. (Inherited from Index.)
Pad | The index padding. (Inherited from Index.)
PartitionedField | Obsolete. (Inherited from Index.)
PrimaryKey | Obsolete. (Inherited from Index.)
QualifiedName | The qualified name of the object. Do you mean Index..::.Name? (Inherited from Index.)
Relational | True if this is a relational index. (Inherited from Index.)
ScriptSource | The location of the creation script for this object if the database source is set to scripts folder. (Inherited from Index.)
SecondaryType |
SelectiveXmlIndexNamespaces |
SelectiveXmlIndexPaths |
SortInTempDb | True iff the index is to be created using tempdb. (Inherited from Index.)
Spatial | True if the index is a spatial index. (Inherited from Index.)
SpatialIndexInformation | Obsolete. (Inherited from Index.)
Statistics | True if the index is a statistic. (Inherited from Index.)
SysobjectID | The sysobject identier of the object. (Inherited from Index.)
SystemNamed | (Inherited from Index.)
Unique | Obsolete. (Inherited from Index.)
UniqueConstraint | Obsolete. (Inherited from Index.)
WriteFileGroupOrPartitionScheme | Whether (disregarding any options) the filegroup should be written out (Inherited from Index.)
Xml | True if the index is an XML index. (Inherited from Index.)
XmlIndexType |
XmlPrimaryIndex | The primary XML index, if this index is a secondary XML index.
XmlPrimarySelectivePath | The xml path used if this is a secondary selective XML index

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith | (Inherited from Index.)
IDatabaseObject..::.Equals | (Inherited from Index.)

See Also

XmlIndex Class
RedGate.SQLCompare.Engine.Model.XmlIndexes Namespace


XmlIndex Methods

[image] [image]

SQL Data Compare API 12.0.40
XmlIndex Methods
XmlIndex Class See Also

The XmlIndex type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FieldsCompareWith | (Inherited from Index.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetPrimarySelectivePath |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ISqlComparable..::.CompareWith | (Inherited from Index.)
IDatabaseObject..::.Equals | (Inherited from Index.)

See Also

XmlIndex Class
RedGate.SQLCompare.Engine.Model.XmlIndexes Namespace


SetPrimarySelectivePath Method

[image]

SQL Data Compare API 12.0.40
XmlIndex..::.SetPrimarySelectivePath Method
XmlIndex Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.XmlIndexes
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetPrimarySelectivePath ( _
    pathName As String _
)
C#
public void SetPrimarySelectivePath(
    string pathName
)
Visual C++
public:
void SetPrimarySelectivePath(
    String^ pathName
)

Parameters

pathName
Type: String

See Also

XmlIndex Class
RedGate.SQLCompare.Engine.Model.XmlIndexes Namespace


XmlIndex Properties

[image] [image]

SQL Data Compare API 12.0.40
XmlIndex Properties
XmlIndex Class See Also

The XmlIndex type exposes the following properties.

Properties

Name | Description
AllowPageLocks | True if the index allows page locks. (Inherited from Index.)
AllowRowLocks | True if the index allows row locks. (Inherited from Index.)
Clustered | Obsolete. (Inherited from Index.)
Database | The database to which the index belongs. (Inherited from Index.)
Fields | The fields in the index. (Inherited from Index.)
FileGroup | Obsolete. (Inherited from Index.)
FileGroupOrPartitionScheme | The filegroup or the partition scheme on which the index is defined. (Inherited from Index.)
FilestreamFileGroup | Obsolete. (Inherited from Index.)
FillFactor | The fill factor. (Inherited from Index.)
Filter | Obsolete. (Inherited from Index.)
FullScan | True if the index is defined with FullScan (Inherited from Index.)
FullyQualifiedName | Obsolete. The fully-qualified name of the index. DANGER WILL ROBINSON!! This is not escaped. (Inherited from Index.)
IgnoreDuplicateKeys | True if set to ignore duplicate keys. (Inherited from Index.)
Incremental | True if incremental (introduced in SQL Server 2014) (Inherited from Index.)
IsColumnstore | Stupid columnstore indexes mark all of their fields as included but use the normal syntax to list them. (http://msdn.microsoft.com/en-us/library/ms175105.aspx) (Inherited from Index.)
IsDisabled | Indicates whether the index is disabled. (Inherited from Index.)
IsKeyIndexForFullTextIndex | Obsolete. (Inherited from Index.)
IsPartitioned | Indicates whether the index is built on a partition scheme. If it is, the name of the partition scheme is returned by the FileGroupOrPartitionScheme property. (Inherited from Index.)
Name | The name of the index. DANGER WILL ROBINSON!! This is not escaped. Do you mean Index..::.QualifiedName? (Inherited from Index.)
NoRecompute | True if the index is defined with NORECOMPUTE. (Inherited from Index.)
ObjectType | Returns ObjectType.Index (Inherited from Index.)
Online | True iff the index is to be created online. (Inherited from Index.)
Owner | The owner of the index's table. (Inherited from Index.)
Pad | The index padding. (Inherited from Index.)
PartitionedField | Obsolete. (Inherited from Index.)
PrimaryKey | Obsolete. (Inherited from Index.)
QualifiedName | The qualified name of the object. Do you mean Index..::.Name? (Inherited from Index.)
Relational | True if this is a relational index. (Inherited from Index.)
ScriptSource | The location of the creation script for this object if the database source is set to scripts folder. (Inherited from Index.)
SecondaryType |
SelectiveXmlIndexNamespaces |
SelectiveXmlIndexPaths |
SortInTempDb | True iff the index is to be created using tempdb. (Inherited from Index.)
Spatial | True if the index is a spatial index. (Inherited from Index.)
SpatialIndexInformation | Obsolete. (Inherited from Index.)
Statistics | True if the index is a statistic. (Inherited from Index.)
SysobjectID | The sysobject identier of the object. (Inherited from Index.)
SystemNamed | (Inherited from Index.)
Unique | Obsolete. (Inherited from Index.)
UniqueConstraint | Obsolete. (Inherited from Index.)
WriteFileGroupOrPartitionScheme | Whether (disregarding any options) the filegroup should be written out (Inherited from Index.)
Xml | True if the index is an XML index. (Inherited from Index.)
XmlIndexType |
XmlPrimaryIndex | The primary XML index, if this index is a secondary XML index.
XmlPrimarySelectivePath | The xml path used if this is a secondary selective XML index

See Also

XmlIndex Class
RedGate.SQLCompare.Engine.Model.XmlIndexes Namespace


SecondaryType Property

[image]

SQL Data Compare API 12.0.40
XmlIndex..::.SecondaryType Property
XmlIndex Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.XmlIndexes
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SecondaryType As SecondaryType
C#
public SecondaryType SecondaryType { get; internal set; }
Visual C++
public:
property SecondaryType SecondaryType {
    SecondaryType get ();
    void set (SecondaryType value);
}

See Also

XmlIndex Class
RedGate.SQLCompare.Engine.Model.XmlIndexes Namespace


SelectiveXmlIndexNamespaces Property

[image]

SQL Data Compare API 12.0.40
XmlIndex..::.SelectiveXmlIndexNamespaces Property
XmlIndex Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.XmlIndexes
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SelectiveXmlIndexNamespaces As IEnumerable(Of SelectiveXmlIndexNamespace)
C#
public IEnumerable<SelectiveXmlIndexNamespace> SelectiveXmlIndexNamespaces { get; }
Visual C++
public:
property IEnumerable<SelectiveXmlIndexNamespace^>^ SelectiveXmlIndexNamespaces {
    IEnumerable<SelectiveXmlIndexNamespace^>^ get ();
}

See Also

XmlIndex Class
RedGate.SQLCompare.Engine.Model.XmlIndexes Namespace


SelectiveXmlIndexPaths Property

[image]

SQL Data Compare API 12.0.40
XmlIndex..::.SelectiveXmlIndexPaths Property
XmlIndex Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.XmlIndexes
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SelectiveXmlIndexPaths As IEnumerable(Of ISelectiveXmlIndexPath)
C#
public IEnumerable<ISelectiveXmlIndexPath> SelectiveXmlIndexPaths { get; }
Visual C++
public:
property IEnumerable<ISelectiveXmlIndexPath^>^ SelectiveXmlIndexPaths {
    IEnumerable<ISelectiveXmlIndexPath^>^ get ();
}

See Also

XmlIndex Class
RedGate.SQLCompare.Engine.Model.XmlIndexes Namespace


XmlIndexType Property

[image]

SQL Data Compare API 12.0.40
XmlIndex..::.XmlIndexType Property
XmlIndex Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.XmlIndexes
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlIndexType As XmlIndexType
C#
public XmlIndexType XmlIndexType { get; private set; }
Visual C++
public:
property XmlIndexType XmlIndexType {
    XmlIndexType get ();
    void set (XmlIndexType value);
}

See Also

XmlIndex Class
RedGate.SQLCompare.Engine.Model.XmlIndexes Namespace


XmlPrimaryIndex Property

[image]

SQL Data Compare API 12.0.40
XmlIndex..::.XmlPrimaryIndex Property
XmlIndex Class See Also

The primary XML index, if this index is a secondary XML index.

Namespace: RedGate.SQLCompare.Engine.Model.XmlIndexes
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlPrimaryIndex As XmlIndex
C#
public XmlIndex XmlPrimaryIndex { get; internal set; }
Visual C++
public:
property XmlIndex^ XmlPrimaryIndex {
    XmlIndex^ get ();
    void set (XmlIndex^ value);
}

See Also

XmlIndex Class
RedGate.SQLCompare.Engine.Model.XmlIndexes Namespace


XmlPrimarySelectivePath Property

[image]

SQL Data Compare API 12.0.40
XmlIndex..::.XmlPrimarySelectivePath Property
XmlIndex Class See Also

The xml path used if this is a secondary selective XML index

Namespace: RedGate.SQLCompare.Engine.Model.XmlIndexes
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlPrimarySelectivePath As ISelectiveXmlIndexPath
C#
public ISelectiveXmlIndexPath XmlPrimarySelectivePath { get; internal set; }
Visual C++
public:
property ISelectiveXmlIndexPath^ XmlPrimarySelectivePath {
    ISelectiveXmlIndexPath^ get ();
    void set (ISelectiveXmlIndexPath^ value);
}

See Also

XmlIndex Class
RedGate.SQLCompare.Engine.Model.XmlIndexes Namespace


XmlIndexType Enumeration

[image]

SQL Data Compare API 12.0.40
XmlIndexType Enumeration
See Also

Namespace: RedGate.SQLCompare.Engine.Model.XmlIndexes
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration XmlIndexType
C#
public enum XmlIndexType
Visual C++
public enum class XmlIndexType

Members

Member name | Description
Primary |
Secondary |
Selective |
SecondarySelective |

See Also

RedGate.SQLCompare.Engine.Model.XmlIndexes Namespace


RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective Namespace

Classes

Class | Description
SelectiveXmlIndexNamespace |

Interfaces

Interface | Description
ISelectiveXmlIndexPath |


ISelectiveXmlIndexPath Interface

[image]

SQL Data Compare API 12.0.40
ISelectiveXmlIndexPath Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISelectiveXmlIndexPath _
    Implements ISqlComparable
C#
public interface ISelectiveXmlIndexPath : ISqlComparable
Visual C++
public interface class ISelectiveXmlIndexPath : ISqlComparable

See Also

ISelectiveXmlIndexPath Members
RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective Namespace


ISelectiveXmlIndexPath Members

[image] [image]

SQL Data Compare API 12.0.40
ISelectiveXmlIndexPath Members
ISelectiveXmlIndexPath Interface Methods Properties See Also

The ISelectiveXmlIndexPath type exposes the following members.

Methods

Name | Description
CompareWith | (Inherited from ISqlComparable.)
GetSql |
Serialize |

Properties

Name | Description
PathId |
PathName |

See Also

ISelectiveXmlIndexPath Interface
RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective Namespace


ISelectiveXmlIndexPath Methods

[image] [image]

SQL Data Compare API 12.0.40
ISelectiveXmlIndexPath Methods
ISelectiveXmlIndexPath Interface See Also

The ISelectiveXmlIndexPath type exposes the following methods.

Methods

Name | Description
CompareWith | (Inherited from ISqlComparable.)
GetSql |
Serialize |

See Also

ISelectiveXmlIndexPath Interface
RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective Namespace


GetSql Method

[image]

SQL Data Compare API 12.0.40
ISelectiveXmlIndexPath..::.GetSql Method
ISelectiveXmlIndexPath Interface See Also

Namespace: RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetSql As String
C#
string GetSql()
Visual C++
String^ GetSql()

See Also

ISelectiveXmlIndexPath Interface
RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective Namespace


Serialize Method

[image]

SQL Data Compare API 12.0.40
ISelectiveXmlIndexPath..::.Serialize Method
ISelectiveXmlIndexPath Interface See Also

Namespace: RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub Serialize ( _
    writer As NullableBinaryWriter _
)
C#
void Serialize(
    NullableBinaryWriter writer
)
Visual C++
void Serialize(
    NullableBinaryWriter^ writer
)

Parameters

writer
Type: NullableBinaryWriter

See Also

ISelectiveXmlIndexPath Interface
RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective Namespace


ISelectiveXmlIndexPath Properties

[image] [image]

SQL Data Compare API 12.0.40
ISelectiveXmlIndexPath Properties
ISelectiveXmlIndexPath Interface See Also

The ISelectiveXmlIndexPath type exposes the following properties.

Properties

Name | Description
PathId |
PathName |

See Also

ISelectiveXmlIndexPath Interface
RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective Namespace


PathId Property

[image]

SQL Data Compare API 12.0.40
ISelectiveXmlIndexPath..::.PathId Property
ISelectiveXmlIndexPath Interface See Also

Namespace: RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property PathId As Integer
C#
int PathId { get; }
Visual C++
property int PathId {
    int get ();
}

See Also

ISelectiveXmlIndexPath Interface
RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective Namespace


PathName Property

[image]

SQL Data Compare API 12.0.40
ISelectiveXmlIndexPath..::.PathName Property
ISelectiveXmlIndexPath Interface See Also

Namespace: RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property PathName As String
C#
string PathName { get; }
Visual C++
property String^ PathName {
    String^ get ();
}

See Also

ISelectiveXmlIndexPath Interface
RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective Namespace


SelectiveXmlIndexNamespace Class

[image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexNamespace Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SelectiveXmlIndexNamespace _
    Implements ISqlComparable
C#
public class SelectiveXmlIndexNamespace : ISqlComparable
Visual C++
public ref class SelectiveXmlIndexNamespace : ISqlComparable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective..::.SelectiveXmlIndexNamespace

See Also

SelectiveXmlIndexNamespace Members
RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective Namespace


SelectiveXmlIndexNamespace Members

[image] [image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexNamespace Members
SelectiveXmlIndexNamespace Class Constructors Methods Properties See Also

The SelectiveXmlIndexNamespace type exposes the following members.

Constructors

Name | Description
SelectiveXmlIndexNamespace | Overloaded.

Methods

Name | Description
CompareWith |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Prefix |
Uri |

See Also

SelectiveXmlIndexNamespace Class
RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective Namespace


SelectiveXmlIndexNamespace Constructor

[image] [image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexNamespace Constructor
SelectiveXmlIndexNamespace Class See Also

Overload List

Name | Description
SelectiveXmlIndexNamespace(NullableBinaryReader) |
SelectiveXmlIndexNamespace(String, String) |

See Also

SelectiveXmlIndexNamespace Class
SelectiveXmlIndexNamespace Members
RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective Namespace


SelectiveXmlIndexNamespace Constructor ()

[image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexNamespace Constructor ()
SelectiveXmlIndexNamespace Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    reader As NullableBinaryReader _
)
C#
public SelectiveXmlIndexNamespace(
    NullableBinaryReader reader
)
Visual C++
public:
SelectiveXmlIndexNamespace(
    NullableBinaryReader^ reader
)

Parameters

reader
Type: NullableBinaryReader

See Also

SelectiveXmlIndexNamespace Class
SelectiveXmlIndexNamespace Overload
RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective Namespace


SelectiveXmlIndexNamespace Constructor (, )

[image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexNamespace Constructor (, )
SelectiveXmlIndexNamespace Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    uri As String, _
    prefix As String _
)
C#
public SelectiveXmlIndexNamespace(
    string uri,
    string prefix
)
Visual C++
public:
SelectiveXmlIndexNamespace(
    String^ uri,
    String^ prefix
)

Parameters

uri
Type: String
prefix
Type: String

See Also

SelectiveXmlIndexNamespace Class
SelectiveXmlIndexNamespace Overload
RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective Namespace


SelectiveXmlIndexNamespace Methods

[image] [image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexNamespace Methods
SelectiveXmlIndexNamespace Class See Also

The SelectiveXmlIndexNamespace type exposes the following methods.

Methods

Name | Description
CompareWith |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelectiveXmlIndexNamespace Class
RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective Namespace


CompareWith Method

[image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexNamespace..::.CompareWith Method
SelectiveXmlIndexNamespace Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareWith ( _
    obj As ISqlComparable, _
    options As Options _
) As IEnumerable(Of EqualityDifference)
C#
public IEnumerable<EqualityDifference> CompareWith(
    ISqlComparable obj,
    Options options
)
Visual C++
public:
virtual IEnumerable<EqualityDifference^>^ CompareWith(
    ISqlComparable^ obj,
    Options options
) sealed

Parameters

obj
Type: RedGate.SQLCompare.Engine.Model..::.ISqlComparable
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

ISqlComparable..::.CompareWith(ISqlComparable, Options)

See Also

SelectiveXmlIndexNamespace Class
RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective Namespace


Serialize Method

[image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexNamespace..::.Serialize Method
SelectiveXmlIndexNamespace Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Serialize ( _
    writer As NullableBinaryWriter _
)
C#
public void Serialize(
    NullableBinaryWriter writer
)
Visual C++
public:
void Serialize(
    NullableBinaryWriter^ writer
)

Parameters

writer
Type: NullableBinaryWriter

See Also

SelectiveXmlIndexNamespace Class
RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective Namespace


SelectiveXmlIndexNamespace Properties

[image] [image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexNamespace Properties
SelectiveXmlIndexNamespace Class See Also

The SelectiveXmlIndexNamespace type exposes the following properties.

Properties

Name | Description
Prefix |
Uri |

See Also

SelectiveXmlIndexNamespace Class
RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective Namespace


Prefix Property

[image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexNamespace..::.Prefix Property
SelectiveXmlIndexNamespace Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Prefix As String
C#
public string Prefix { get; }
Visual C++
public:
property String^ Prefix {
    String^ get ();
}

See Also

SelectiveXmlIndexNamespace Class
RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective Namespace


Uri Property

[image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexNamespace..::.Uri Property
SelectiveXmlIndexNamespace Class See Also

Namespace: RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Uri As String
C#
public string Uri { get; }
Visual C++
public:
property String^ Uri {
    String^ get ();
}

See Also

SelectiveXmlIndexNamespace Class
RedGate.SQLCompare.Engine.Model.XmlIndexes.Selective Namespace


RedGate.SQLCompare.Engine.ObjectHasher Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.ObjectHasher Namespace

Classes

Class | Description
MD5 | Summary description for MD5.
MD5CryptoServiceProvider |


MD5 Class

[image]

SQL Data Compare API 12.0.40
MD5 Class
Members See Also

Summary description for MD5.

Namespace: RedGate.SQLCompare.Engine.ObjectHasher
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Class MD5 _
    Implements IDisposable
C#
public class MD5 : IDisposable
Visual C++
public ref class MD5 : IDisposable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ObjectHasher..::.MD5
RedGate.SQLCompare.Engine.ObjectHasher..::.MD5CryptoServiceProvider

See Also

MD5 Members
RedGate.SQLCompare.Engine.ObjectHasher Namespace


MD5 Members

[image] [image]

SQL Data Compare API 12.0.40
MD5 Members
MD5 Class Methods Fields Properties See Also

The MD5 type exposes the following members.

Methods

Name | Description
Clear |
ComputeHash | Overloaded.
Create | Overloaded.
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HashCore | MD5 block update operation. Continues an MD5 message-digest operation, processing another message block, and updating the context.
HashFinal | MD5 finalization. Ends an MD5 message-digest operation, writing the the message digest and zeroizing the context.
Initialize | MD5 initialization. Begins an MD5 operation, writing a new context.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformBlock |
TransformFinalBlock |

Fields

Name | Description
HashSizeValue |
HashValue |
State |

Properties

Name | Description
CanReuseTransform |
CanTransformMultipleBlocks |
Hash |
HashSize |
InputBlockSize |
OutputBlockSize |

See Also

MD5 Class
RedGate.SQLCompare.Engine.ObjectHasher Namespace


MD5 Fields

[image] [image]

SQL Data Compare API 12.0.40
MD5 Fields
MD5 Class See Also

The MD5 type exposes the following fields.

Fields

Name | Description
HashSizeValue |
HashValue |
State |

See Also

MD5 Class
RedGate.SQLCompare.Engine.ObjectHasher Namespace


HashSizeValue Field

[image]

SQL Data Compare API 12.0.40
MD5..::.HashSizeValue Field
MD5 Class See Also

Namespace: RedGate.SQLCompare.Engine.ObjectHasher
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Protected HashSizeValue As Integer
C#
protected int HashSizeValue
Visual C++
protected:
int HashSizeValue

See Also

MD5 Class
RedGate.SQLCompare.Engine.ObjectHasher Namespace


HashValue Field

[image]

SQL Data Compare API 12.0.40
MD5..::.HashValue Field
MD5 Class See Also

Namespace: RedGate.SQLCompare.Engine.ObjectHasher
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Protected HashValue As Byte()
C#
protected byte[] HashValue
Visual C++
protected:
array<unsigned char>^ HashValue

See Also

MD5 Class
RedGate.SQLCompare.Engine.ObjectHasher Namespace


State Field

[image]

SQL Data Compare API 12.0.40
MD5..::.State Field
MD5 Class See Also

Namespace: RedGate.SQLCompare.Engine.ObjectHasher
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Protected State As Integer
C#
protected int State
Visual C++
protected:
int State

See Also

MD5 Class
RedGate.SQLCompare.Engine.ObjectHasher Namespace


MD5 Methods

[image] [image]

SQL Data Compare API 12.0.40
MD5 Methods
MD5 Class See Also

The MD5 type exposes the following methods.

Methods

Name | Description
Clear |
ComputeHash | Overloaded.
Create | Overloaded.
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HashCore | MD5 block update operation. Continues an MD5 message-digest operation, processing another message block, and updating the context.
HashFinal | MD5 finalization. Ends an MD5 message-digest operation, writing the the message digest and zeroizing the context.
Initialize | MD5 initialization. Begins an MD5 operation, writing a new context.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformBlock |
TransformFinalBlock |

See Also

MD5 Class
RedGate.SQLCompare.Engine.ObjectHasher Namespace


Clear Method

[image]

SQL Data Compare API 12.0.40
MD5..::.Clear Method
MD5 Class See Also

Namespace: RedGate.SQLCompare.Engine.ObjectHasher
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear
C#
public void Clear()
Visual C++
public:
void Clear()

See Also

MD5 Class
RedGate.SQLCompare.Engine.ObjectHasher Namespace


ComputeHash Method

[image] [image]

SQL Data Compare API 12.0.40
MD5..::.ComputeHash Method
MD5 Class See Also

Overload List

Name | Description
ComputeHash(array<Byte>[]()[]) |
ComputeHash(Stream) |
ComputeHash(array<Byte>[]()[], Int32, Int32) |

See Also

MD5 Class
MD5 Members
RedGate.SQLCompare.Engine.ObjectHasher Namespace


ComputeHash Method ([])

[image]

SQL Data Compare API 12.0.40
MD5..::.ComputeHash Method (array<>[]()[])
MD5 Class See Also

Namespace: RedGate.SQLCompare.Engine.ObjectHasher
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Function ComputeHash ( _
    buffer As Byte() _
) As Byte()
C#
public byte[] ComputeHash(
    byte[] buffer
)
Visual C++
public:
array<unsigned char>^ ComputeHash(
    array<unsigned char>^ buffer
)

Parameters

buffer
Type: array<Byte>[]()[]

See Also

MD5 Class
ComputeHash Overload
RedGate.SQLCompare.Engine.ObjectHasher Namespace


ComputeHash Method ()

[image]

SQL Data Compare API 12.0.40
MD5..::.ComputeHash Method ()
MD5 Class See Also

Namespace: RedGate.SQLCompare.Engine.ObjectHasher
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Function ComputeHash ( _
    inputStream As Stream _
) As Byte()
C#
public byte[] ComputeHash(
    Stream inputStream
)
Visual C++
public:
array<unsigned char>^ ComputeHash(
    Stream^ inputStream
)

Parameters

inputStream
Type: Stream

See Also

MD5 Class
ComputeHash Overload
RedGate.SQLCompare.Engine.ObjectHasher Namespace


ComputeHash Method ([], , )

[image]

SQL Data Compare API 12.0.40
MD5..::.ComputeHash Method (array<>[]()[], , )
MD5 Class See Also

Namespace: RedGate.SQLCompare.Engine.ObjectHasher
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Function ComputeHash ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
) As Byte()
C#
public byte[] ComputeHash(
    byte[] buffer,
    int offset,
    int count
)
Visual C++
public:
array<unsigned char>^ ComputeHash(
    array<unsigned char>^ buffer,
    int offset,
    int count
)

Parameters

buffer
Type: array<Byte>[]()[]
offset
Type: Int32
count
Type: Int32

See Also

MD5 Class
ComputeHash Overload
RedGate.SQLCompare.Engine.ObjectHasher Namespace


Create Method

[image] [image]

SQL Data Compare API 12.0.40
MD5..::.Create Method
MD5 Class See Also

Overload List

Name | Description
Create()()() |
Create(String) |

See Also

MD5 Class
MD5 Members
RedGate.SQLCompare.Engine.ObjectHasher Namespace


Create Method

[image]

SQL Data Compare API 12.0.40
MD5..::.Create Method
MD5 Class See Also

Namespace: RedGate.SQLCompare.Engine.ObjectHasher
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Create As MD5
C#
public static MD5 Create()
Visual C++
public:
static MD5^ Create()

See Also

MD5 Class
Create Overload
RedGate.SQLCompare.Engine.ObjectHasher Namespace


Create Method ()

[image]

SQL Data Compare API 12.0.40
MD5..::.Create Method ()
MD5 Class See Also

Namespace: RedGate.SQLCompare.Engine.ObjectHasher
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Create ( _
    hashName As String _
) As MD5
C#
public static MD5 Create(
    string hashName
)
Visual C++
public:
static MD5^ Create(
    String^ hashName
)

Parameters

hashName
Type: String

See Also

MD5 Class
Create Overload
RedGate.SQLCompare.Engine.ObjectHasher Namespace


Dispose Method

[image] [image]

SQL Data Compare API 12.0.40
MD5..::.Dispose Method
MD5 Class See Also

Overload List

Name | Description
Dispose()()() |
Dispose(Boolean) |

See Also

MD5 Class
MD5 Members
RedGate.SQLCompare.Engine.ObjectHasher Namespace


Dispose Method

[image]

SQL Data Compare API 12.0.40
MD5..::.Dispose Method
MD5 Class See Also

Namespace: RedGate.SQLCompare.Engine.ObjectHasher
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose
C#
public void Dispose()
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposableDispose()()()

See Also

MD5 Class
Dispose Overload
RedGate.SQLCompare.Engine.ObjectHasher Namespace


Dispose Method ()

[image]

SQL Data Compare API 12.0.40
MD5..::.Dispose Method ()
MD5 Class See Also

Namespace: RedGate.SQLCompare.Engine.ObjectHasher
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
C#
protected virtual void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: Boolean

See Also

MD5 Class
Dispose Overload
RedGate.SQLCompare.Engine.ObjectHasher Namespace


HashCore Method

[image]

SQL Data Compare API 12.0.40
MD5..::.HashCore Method
MD5 Class See Also

MD5 block update operation. Continues an MD5 message-digest operation, processing another message block, and updating the context.

Namespace: RedGate.SQLCompare.Engine.ObjectHasher
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub HashCore ( _
    input As Byte(), _
    offset As Integer, _
    count As Integer _
)
C#
protected virtual void HashCore(
    byte[] input,
    int offset,
    int count
)
Visual C++
protected:
virtual void HashCore(
    array<unsigned char>^ input,
    int offset,
    int count
)

Parameters

input
Type: array<Byte>[]()[]
offset
Type: Int32
count
Type: Int32

Remarks

The RFC Named it MD5Update

See Also

MD5 Class
RedGate.SQLCompare.Engine.ObjectHasher Namespace


HashFinal Method

[image]

SQL Data Compare API 12.0.40
MD5..::.HashFinal Method
MD5 Class See Also

MD5 finalization. Ends an MD5 message-digest operation, writing the the message digest and zeroizing the context.

Namespace: RedGate.SQLCompare.Engine.ObjectHasher
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function HashFinal As Byte()
C#
protected virtual byte[] HashFinal()
Visual C++
protected:
virtual array<unsigned char>^ HashFinal()

Return Value

message digest

Remarks

The RFC named it MD5Final

See Also

MD5 Class
RedGate.SQLCompare.Engine.ObjectHasher Namespace


Initialize Method

[image]

SQL Data Compare API 12.0.40
MD5..::.Initialize Method
MD5 Class See Also

MD5 initialization. Begins an MD5 operation, writing a new context.

Namespace: RedGate.SQLCompare.Engine.ObjectHasher
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Initialize
C#
public virtual void Initialize()
Visual C++
public:
virtual void Initialize()

Remarks

The RFC named it "MD5Init"

See Also

MD5 Class
RedGate.SQLCompare.Engine.ObjectHasher Namespace


TransformBlock Method

[image]

SQL Data Compare API 12.0.40
MD5..::.TransformBlock Method
MD5 Class See Also

Namespace: RedGate.SQLCompare.Engine.ObjectHasher
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Function TransformBlock ( _
    inputBuffer As Byte(), _
    inputOffset As Integer, _
    inputCount As Integer, _
    outputBuffer As Byte(), _
    outputOffset As Integer _
) As Integer
C#
public int TransformBlock(
    byte[] inputBuffer,
    int inputOffset,
    int inputCount,
    byte[] outputBuffer,
    int outputOffset
)
Visual C++
public:
int TransformBlock(
    array<unsigned char>^ inputBuffer,
    int inputOffset,
    int inputCount,
    array<unsigned char>^ outputBuffer,
    int outputOffset
)

Parameters

inputBuffer
Type: array<Byte>[]()[]
inputOffset
Type: Int32
inputCount
Type: Int32
outputBuffer
Type: array<Byte>[]()[]
outputOffset
Type: Int32

See Also

MD5 Class
RedGate.SQLCompare.Engine.ObjectHasher Namespace


TransformFinalBlock Method

[image]

SQL Data Compare API 12.0.40
MD5..::.TransformFinalBlock Method
MD5 Class See Also

Namespace: RedGate.SQLCompare.Engine.ObjectHasher
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Function TransformFinalBlock ( _
    inputBuffer As Byte(), _
    inputOffset As Integer, _
    inputCount As Integer _
) As Byte()
C#
public byte[] TransformFinalBlock(
    byte[] inputBuffer,
    int inputOffset,
    int inputCount
)
Visual C++
public:
array<unsigned char>^ TransformFinalBlock(
    array<unsigned char>^ inputBuffer,
    int inputOffset,
    int inputCount
)

Parameters

inputBuffer
Type: array<Byte>[]()[]
inputOffset
Type: Int32
inputCount
Type: Int32

See Also

MD5 Class
RedGate.SQLCompare.Engine.ObjectHasher Namespace


MD5 Properties

[image] [image]

SQL Data Compare API 12.0.40
MD5 Properties
MD5 Class See Also

The MD5 type exposes the following properties.

Properties

Name | Description
CanReuseTransform |
CanTransformMultipleBlocks |
Hash |
HashSize |
InputBlockSize |
OutputBlockSize |

See Also

MD5 Class
RedGate.SQLCompare.Engine.ObjectHasher Namespace


CanReuseTransform Property

[image]

SQL Data Compare API 12.0.40
MD5..::.CanReuseTransform Property
MD5 Class See Also

Namespace: RedGate.SQLCompare.Engine.ObjectHasher
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property CanReuseTransform As Boolean
C#
public virtual bool CanReuseTransform { get; }
Visual C++
public:
virtual property bool CanReuseTransform {
    bool get ();
}

See Also

MD5 Class
RedGate.SQLCompare.Engine.ObjectHasher Namespace


CanTransformMultipleBlocks Property

[image]

SQL Data Compare API 12.0.40
MD5..::.CanTransformMultipleBlocks Property
MD5 Class See Also

Namespace: RedGate.SQLCompare.Engine.ObjectHasher
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property CanTransformMultipleBlocks As Boolean
C#
public virtual bool CanTransformMultipleBlocks { get; }
Visual C++
public:
virtual property bool CanTransformMultipleBlocks {
    bool get ();
}

See Also

MD5 Class
RedGate.SQLCompare.Engine.ObjectHasher Namespace


Hash Property

[image]

SQL Data Compare API 12.0.40
MD5..::.Hash Property
MD5 Class See Also

Namespace: RedGate.SQLCompare.Engine.ObjectHasher
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Hash As Byte()
C#
public virtual byte[] Hash { get; }
Visual C++
public:
virtual property array<unsigned char>^ Hash {
    array<unsigned char>^ get ();
}

See Also

MD5 Class
RedGate.SQLCompare.Engine.ObjectHasher Namespace


HashSize Property

[image]

SQL Data Compare API 12.0.40
MD5..::.HashSize Property
MD5 Class See Also

Namespace: RedGate.SQLCompare.Engine.ObjectHasher
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property HashSize As Integer
C#
public virtual int HashSize { get; }
Visual C++
public:
virtual property int HashSize {
    int get ();
}

See Also

MD5 Class
RedGate.SQLCompare.Engine.ObjectHasher Namespace


InputBlockSize Property

[image]

SQL Data Compare API 12.0.40
MD5..::.InputBlockSize Property
MD5 Class See Also

Namespace: RedGate.SQLCompare.Engine.ObjectHasher
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property InputBlockSize As Integer
C#
public virtual int InputBlockSize { get; }
Visual C++
public:
virtual property int InputBlockSize {
    int get ();
}

See Also

MD5 Class
RedGate.SQLCompare.Engine.ObjectHasher Namespace


OutputBlockSize Property

[image]

SQL Data Compare API 12.0.40
MD5..::.OutputBlockSize Property
MD5 Class See Also

Namespace: RedGate.SQLCompare.Engine.ObjectHasher
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property OutputBlockSize As Integer
C#
public virtual int OutputBlockSize { get; }
Visual C++
public:
virtual property int OutputBlockSize {
    int get ();
}

See Also

MD5 Class
RedGate.SQLCompare.Engine.ObjectHasher Namespace


MD5CryptoServiceProvider Class

[image]

SQL Data Compare API 12.0.40
MD5CryptoServiceProvider Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ObjectHasher
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Class MD5CryptoServiceProvider _
    Inherits MD5
C#
public class MD5CryptoServiceProvider : MD5
Visual C++
public ref class MD5CryptoServiceProvider : public MD5

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ObjectHasher..::.MD5
RedGate.SQLCompare.Engine.ObjectHasher..::.MD5CryptoServiceProvider

See Also

MD5CryptoServiceProvider Members
RedGate.SQLCompare.Engine.ObjectHasher Namespace


MD5CryptoServiceProvider Members

[image] [image]

SQL Data Compare API 12.0.40
MD5CryptoServiceProvider Members
MD5CryptoServiceProvider Class Constructors Methods Fields Properties See Also

The MD5CryptoServiceProvider type exposes the following members.

Constructors

Name | Description
MD5CryptoServiceProvider |

Methods

Name | Description
Clear | (Inherited from MD5.)
ComputeHash | Overloaded.
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HashCore | MD5 block update operation. Continues an MD5 message-digest operation, processing another message block, and updating the context. (Inherited from MD5.)
HashFinal | MD5 finalization. Ends an MD5 message-digest operation, writing the the message digest and zeroizing the context. (Inherited from MD5.)
Initialize | MD5 initialization. Begins an MD5 operation, writing a new context. (Inherited from MD5.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformBlock | (Inherited from MD5.)
TransformFinalBlock | (Inherited from MD5.)

Fields

Name | Description
HashSizeValue | (Inherited from MD5.)
HashValue | (Inherited from MD5.)
State | (Inherited from MD5.)

Properties

Name | Description
CanReuseTransform | (Inherited from MD5.)
CanTransformMultipleBlocks | (Inherited from MD5.)
Hash | (Inherited from MD5.)
HashSize | (Inherited from MD5.)
InputBlockSize | (Inherited from MD5.)
OutputBlockSize | (Inherited from MD5.)

See Also

MD5CryptoServiceProvider Class
RedGate.SQLCompare.Engine.ObjectHasher Namespace


MD5CryptoServiceProvider Constructor

[image]

SQL Data Compare API 12.0.40
MD5CryptoServiceProvider Constructor
MD5CryptoServiceProvider Class See Also

Namespace: RedGate.SQLCompare.Engine.ObjectHasher
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MD5CryptoServiceProvider()
Visual C++
public:
MD5CryptoServiceProvider()

See Also

MD5CryptoServiceProvider Class
RedGate.SQLCompare.Engine.ObjectHasher Namespace


RedGate.SQLCompare.Engine.ReadFromBackup Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.ReadFromBackup Namespace

Classes

Class | Description
BackupDatabaseSource | Representation of a data source that takes its data from a backup of a database.
BackupSetDatabase |
SQLBackupReaderLoadException | SQLBackupReaderLoadException

Interfaces

Interface | Description
IBackupSetDatabase |


BackupDatabaseSource Class

[image]

SQL Data Compare API 12.0.40
BackupDatabaseSource Class
Members See Also

Representation of a data source that takes its data from a backup of a database.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class BackupDatabaseSource _
    Inherits DataSource
C#
[SerializableAttribute]
public sealed class BackupDatabaseSource : DataSource
Visual C++
[SerializableAttribute]
public ref class BackupDatabaseSource sealed : public DataSource

Inheritance Hierarchy

Object
RedGate.Shared.SQL..::.DataSource
RedGate.SQLCompare.Engine.ReadFromBackup..::.BackupDatabaseSource

See Also

BackupDatabaseSource Members
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


BackupDatabaseSource Members

[image] [image]

SQL Data Compare API 12.0.40
BackupDatabaseSource Members
BackupDatabaseSource Class Constructors Methods Properties Explicit Interface Implementations See Also

The BackupDatabaseSource type exposes the following members.

Constructors

Name | Description
BackupDatabaseSource | Overloaded.

Methods

Name | Description
Clone | Overridden. Clones the data source. (Overrides DataSource ..::. Clone()()().)
Deserialize | Deserializes this data source. Note that the database information settings are serialized along with the data source. (Overrides DataSource ..::. Deserialize(Int32, ISerializeFormatter).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDifferentSource | Overridden. Compares the data source with a specified data source. (Overrides DataSource ..::.IsDifferentSource(IDataSource).)
IsPasswordRequired | Returns true if the backup files need a password to be read, false otherwise.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes this data source. Note that the database information settings are serialized along with the data source. (Overrides DataSource ..::. Serialize(ISerializeFormatter).)
ToConnectionProperties |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BackupSet | Gets or sets the BackupSet to be used in the backup file. If this is null the latest backup set will be used.
DatabaseName | Overridden. Gets the database name of the backup set. (Overrides DataSource ..::. DatabaseName.)
Files | The files that should be used as the source for the backup for this data source.
IgnoreWrongPasswords | Tells the backup reader to ignore files with incorrect passwords
IsCaseSensitive | Whether the underlying database is case sensitive or not!
IsValid | True if this snapshot represents a valid data source that can be used in comparison. If false, then there is a problem with the snapshot file - for example, it could not be found or is in the wrong format. (Overrides DataSource ..::. IsValid.)
IsWriteable | Overridden. The data source cannot be written to. This property always returns false. (Overrides DataSource ..::. IsWriteable.)
LastDatabaseName | Gets or sets the name of the database for the last backup set.
LastServerName | Gets or sets the name of the SQL Server for the last backup set.
Passwords | The SQL Backup passwords (one for each file) that are used to access the data source.
ServerName | Overridden. Gets the name of the SQL Server of the backup set. (Overrides DataSource ..::. ServerName.)
Version | Overridden. Gets the current serialized version number of BackupDatabaseSource. (Overrides DataSource ..::. Version.)

Explicit Interface Implementations

Name | Description
ICloneableClone | (Inherited from DataSource.)

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


BackupDatabaseSource Constructor

[image] [image]

SQL Data Compare API 12.0.40
BackupDatabaseSource Constructor
BackupDatabaseSource Class See Also

Overload List

Name | Description
BackupDatabaseSource()()() | Constructs this object with an empty files list.
BackupDatabaseSource(IEnumerable<(Of <(String>)>), IEnumerable<(Of <(String>)>), IBackupSet) | Constructs this object using the specified files.

See Also

BackupDatabaseSource Class
BackupDatabaseSource Members
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


BackupDatabaseSource Constructor

[image]

SQL Data Compare API 12.0.40
BackupDatabaseSource Constructor
BackupDatabaseSource Class See Also

Constructs this object with an empty files list.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BackupDatabaseSource()
Visual C++
public:
BackupDatabaseSource()

See Also

BackupDatabaseSource Class
BackupDatabaseSource Overload
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


BackupDatabaseSource Constructor ((), (), IBackupSet)

[image]

SQL Data Compare API 12.0.40
BackupDatabaseSource Constructor (<(Of <(>)>), <(Of <(>)>), IBackupSet)
BackupDatabaseSource Class See Also

Constructs this object using the specified files.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    files As IEnumerable(Of String), _
    passwords As IEnumerable(Of String), _
    backupSet As IBackupSet _
)
C#
public BackupDatabaseSource(
    IEnumerable<string> files,
    IEnumerable<string> passwords,
    IBackupSet backupSet
)
Visual C++
public:
BackupDatabaseSource(
    IEnumerable<String^>^ files,
    IEnumerable<String^>^ passwords,
    IBackupSet^ backupSet
)

Parameters

files
Type: IEnumerable<(Of <(String>)>)
The files from which to construct this data source
passwords
Type: IEnumerable<(Of <(String>)>)
The SQL Backup passwords (one for each file) that are used to access the data source
backupSet
Type: RedGate.Shared.SQL.BackupReaderInterfaces..::.IBackupSet
The backup set with which to construct this data source

See Also

BackupDatabaseSource Class
BackupDatabaseSource Overload
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


BackupDatabaseSource Methods

[image] [image]

SQL Data Compare API 12.0.40
BackupDatabaseSource Methods
BackupDatabaseSource Class See Also

The BackupDatabaseSource type exposes the following methods.

Methods

Name | Description
Clone | Overridden. Clones the data source. (Overrides DataSource ..::. Clone()()().)
Deserialize | Deserializes this data source. Note that the database information settings are serialized along with the data source. (Overrides DataSource ..::. Deserialize(Int32, ISerializeFormatter).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDifferentSource | Overridden. Compares the data source with a specified data source. (Overrides DataSource ..::.IsDifferentSource(IDataSource).)
IsPasswordRequired | Returns true if the backup files need a password to be read, false otherwise.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes this data source. Note that the database information settings are serialized along with the data source. (Overrides DataSource ..::. Serialize(ISerializeFormatter).)
ToConnectionProperties |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICloneableClone | (Inherited from DataSource.)

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
BackupDatabaseSource..::.Clone Method
BackupDatabaseSource Class See Also

Overridden. Clones the data source.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone As IDataSource
C#
public override IDataSource Clone()
Visual C++
public:
virtual IDataSource^ Clone() override

Return Value

Implements

IDataSource..::.Clone()()()

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


Deserialize Method

[image]

SQL Data Compare API 12.0.40
BackupDatabaseSource..::.Deserialize Method
BackupDatabaseSource Class See Also

Deserializes this data source. Note that the database information settings are serialized along with the data source.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Deserialize ( _
    versionId As Integer, _
    formatter As ISerializeFormatter _
) As Boolean
C#
public override bool Deserialize(
    int versionId,
    ISerializeFormatter formatter
)
Visual C++
public:
virtual bool Deserialize(
    int versionId,
    ISerializeFormatter^ formatter
) override

Parameters

versionId
Type: Int32
formatter
Type: ISerializeFormatter

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


IsDifferentSource Method

[image]

SQL Data Compare API 12.0.40
BackupDatabaseSource..::.IsDifferentSource Method
BackupDatabaseSource Class See Also

Overridden. Compares the data source with a specified data source.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsDifferentSource ( _
    newDataSource As IDataSource _
) As Boolean
C#
public override bool IsDifferentSource(
    IDataSource newDataSource
)
Visual C++
public:
virtual bool IsDifferentSource(
    IDataSource^ newDataSource
) override

Parameters

newDataSource
Type: RedGate.Shared.SQL..::.IDataSource
The data source to compare.

Return Value

true if the data sources are different.

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


IsPasswordRequired Method

[image]

SQL Data Compare API 12.0.40
BackupDatabaseSource..::.IsPasswordRequired Method
BackupDatabaseSource Class See Also

Returns true if the backup files need a password to be read, false otherwise.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsPasswordRequired ( _
    filePaths As IList(Of String) _
) As Boolean
C#
public static bool IsPasswordRequired(
    IList<string> filePaths
)
Visual C++
public:
static bool IsPasswordRequired(
    IList<String^>^ filePaths
)

Parameters

filePaths
Type: IList<(Of <(String>)>)
A list of the files to open

Return Value

true if the backup files need a password to be read, false otherwise

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


Serialize Method

[image]

SQL Data Compare API 12.0.40
BackupDatabaseSource..::.Serialize Method
BackupDatabaseSource Class See Also

Serializes this data source. Note that the database information settings are serialized along with the data source.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    formatter As ISerializeFormatter _
)
C#
public override void Serialize(
    ISerializeFormatter formatter
)
Visual C++
public:
virtual void Serialize(
    ISerializeFormatter^ formatter
) override

Parameters

formatter
Type: ISerializeFormatter

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


ToConnectionProperties Method

[image]

SQL Data Compare API 12.0.40
BackupDatabaseSource..::.ToConnectionProperties Method
BackupDatabaseSource Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Function ToConnectionProperties As ConnectionProperties
C#
public ConnectionProperties ToConnectionProperties()
Visual C++
public:
ConnectionProperties^ ToConnectionProperties()

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


BackupDatabaseSource Properties

[image] [image]

SQL Data Compare API 12.0.40
BackupDatabaseSource Properties
BackupDatabaseSource Class See Also

The BackupDatabaseSource type exposes the following properties.

Properties

Name | Description
BackupSet | Gets or sets the BackupSet to be used in the backup file. If this is null the latest backup set will be used.
DatabaseName | Overridden. Gets the database name of the backup set. (Overrides DataSource ..::. DatabaseName.)
Files | The files that should be used as the source for the backup for this data source.
IgnoreWrongPasswords | Tells the backup reader to ignore files with incorrect passwords
IsCaseSensitive | Whether the underlying database is case sensitive or not!
IsValid | True if this snapshot represents a valid data source that can be used in comparison. If false, then there is a problem with the snapshot file - for example, it could not be found or is in the wrong format. (Overrides DataSource ..::. IsValid.)
IsWriteable | Overridden. The data source cannot be written to. This property always returns false. (Overrides DataSource ..::. IsWriteable.)
LastDatabaseName | Gets or sets the name of the database for the last backup set.
LastServerName | Gets or sets the name of the SQL Server for the last backup set.
Passwords | The SQL Backup passwords (one for each file) that are used to access the data source.
ServerName | Overridden. Gets the name of the SQL Server of the backup set. (Overrides DataSource ..::. ServerName.)
Version | Overridden. Gets the current serialized version number of BackupDatabaseSource. (Overrides DataSource ..::. Version.)

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


BackupSet Property

[image]

SQL Data Compare API 12.0.40
BackupDatabaseSource..::.BackupSet Property
BackupDatabaseSource Class See Also

Gets or sets the BackupSet to be used in the backup file. If this is null the latest backup set will be used.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property BackupSet As IBackupSet
C#
public IBackupSet BackupSet { get; set; }
Visual C++
public:
property IBackupSet^ BackupSet {
    IBackupSet^ get ();
    void set (IBackupSet^ value);
}

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


DatabaseName Property

[image]

SQL Data Compare API 12.0.40
BackupDatabaseSource..::.DatabaseName Property
BackupDatabaseSource Class See Also

Overridden. Gets the database name of the backup set.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property DatabaseName As String
C#
public override string DatabaseName { get; set; }
Visual C++
public:
virtual property String^ DatabaseName {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IDataSource..::.DatabaseName

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


Files Property

[image]

SQL Data Compare API 12.0.40
BackupDatabaseSource..::.Files Property
BackupDatabaseSource Class See Also

The files that should be used as the source for the backup for this data source.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property Files As List(Of String)
C#
public List<string> Files { get; set; }
Visual C++
public:
property List<String^>^ Files {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


IgnoreWrongPasswords Property

[image]

SQL Data Compare API 12.0.40
BackupDatabaseSource..::.IgnoreWrongPasswords Property
BackupDatabaseSource Class See Also

Tells the backup reader to ignore files with incorrect passwords

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property IgnoreWrongPasswords As Boolean
C#
public bool IgnoreWrongPasswords { get; set; }
Visual C++
public:
property bool IgnoreWrongPasswords {
    bool get ();
    void set (bool value);
}

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


IsCaseSensitive Property

[image]

SQL Data Compare API 12.0.40
BackupDatabaseSource..::.IsCaseSensitive Property
BackupDatabaseSource Class See Also

Whether the underlying database is case sensitive or not!

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsCaseSensitive As Boolean
C#
public bool IsCaseSensitive { get; }
Visual C++
public:
property bool IsCaseSensitive {
    bool get ();
}

Return Value

true if case-sensitive, false otherwise

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


IsValid Property

[image]

SQL Data Compare API 12.0.40
BackupDatabaseSource..::.IsValid Property
BackupDatabaseSource Class See Also

True if this snapshot represents a valid data source that can be used in comparison. If false, then there is a problem with the snapshot file - for example, it could not be found or is in the wrong format.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsValid As Boolean
C#
public override bool IsValid { get; }
Visual C++
public:
virtual property bool IsValid {
    bool get () override;
}

Implements

IDataSource..::.IsValid

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


IsWriteable Property

[image]

SQL Data Compare API 12.0.40
BackupDatabaseSource..::.IsWriteable Property
BackupDatabaseSource Class See Also

Overridden. The data source cannot be written to. This property always returns false.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsWriteable As Boolean
C#
public override bool IsWriteable { get; }
Visual C++
public:
virtual property bool IsWriteable {
    bool get () override;
}

Implements

IDataSource..::.IsWriteable

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


LastDatabaseName Property

[image]

SQL Data Compare API 12.0.40
BackupDatabaseSource..::.LastDatabaseName Property
BackupDatabaseSource Class See Also

Gets or sets the name of the database for the last backup set.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property LastDatabaseName As String
C#
public string LastDatabaseName { get; set; }
Visual C++
public:
property String^ LastDatabaseName {
    String^ get ();
    void set (String^ value);
}

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


LastServerName Property

[image]

SQL Data Compare API 12.0.40
BackupDatabaseSource..::.LastServerName Property
BackupDatabaseSource Class See Also

Gets or sets the name of the SQL Server for the last backup set.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property LastServerName As String
C#
public string LastServerName { get; set; }
Visual C++
public:
property String^ LastServerName {
    String^ get ();
    void set (String^ value);
}

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


Passwords Property

[image]

SQL Data Compare API 12.0.40
BackupDatabaseSource..::.Passwords Property
BackupDatabaseSource Class See Also

The SQL Backup passwords (one for each file) that are used to access the data source.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property Passwords As List(Of String)
C#
public List<string> Passwords { get; set; }
Visual C++
public:
property List<String^>^ Passwords {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


ServerName Property

[image]

SQL Data Compare API 12.0.40
BackupDatabaseSource..::.ServerName Property
BackupDatabaseSource Class See Also

Overridden. Gets the name of the SQL Server of the backup set.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property ServerName As String
C#
public override string ServerName { get; set; }
Visual C++
public:
virtual property String^ ServerName {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IDataSource..::.ServerName

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


Version Property

[image]

SQL Data Compare API 12.0.40
BackupDatabaseSource..::.Version Property
BackupDatabaseSource Class See Also

Overridden. Gets the current serialized version number of BackupDatabaseSource.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Version As Integer
C#
public override int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () override;
}

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


BackupSetDatabase Class

[image]

SQL Data Compare API 12.0.40
BackupSetDatabase Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class BackupSetDatabase _
    Inherits Database
C#
public class BackupSetDatabase : Database
Visual C++
public ref class BackupSetDatabase : public Database

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.ObjectCollections
RedGate.SQLCompare.Engine..::.Database
RedGate.SQLCompare.Engine.ReadFromBackup..::.BackupSetDatabase

See Also

BackupSetDatabase Members
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


BackupSetDatabase Members

[image] [image]

SQL Data Compare API 12.0.40
BackupSetDatabase Members
BackupSetDatabase Class Constructors Methods Fields Properties Explicit Interface Implementations See Also

The BackupSetDatabase type exposes the following members.

Constructors

Name | Description
BackupSetDatabase |

Methods

Name | Description
CancelOperation | Cancels the current operation. (Overrides Database ..::.CancelOperation()()().)
Clone | (Overrides Database ..::.Clone()()().)
Close | Closes the connection to the backup database.
CompareWith | Overloaded.
CreateEmptyTarget | For internal use only (Inherited from Database.)
Dispose | Disposes of the object. (Overrides Database ..::. Dispose()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllObjects | (Inherited from ObjectCollections.)
GetBackupSets | Retreives a list of backup sets from the given backup files. This operation is ICancellable.
GetDatabaseObject | Overloaded.
GetDatabaseObjects<(Of <(T>)>) | (Inherited from ObjectCollections.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectCollectionByType | Returns a readonly collection of database objects, of the specified type. (Inherited from ObjectCollections.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsCaseSensitive |
IsPasswordRequired | Overloaded.
LoadFromDisk | Loads the Database from disk. (Inherited from Database.)
LoadFromStream | Loads the Database from a stream. This is an alternative to the LoadFromDisk method. (Inherited from Database.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PopulateFromMetadataFiles | (Inherited from Database.)
Register | Overloaded.
RegisterForDataCompare | Overloaded.
RegisterForDataCompareInner | (Overrides Database ..::. RegisterForDataCompareInner(IDatabaseFactory).)
SaveToDisk | Saves the Database to disk. (Inherited from Database.)
SaveToFolder | Overloaded.
SaveToStream | Writes the Database snapshot to the specified stream. This is an alternative to the SaveToDisk method (Inherited from Database.)
SetSqlServerVersionInfo | Sets the SqlVersion of the database and updates the associated list of supported features taking into account whether the server version or compatibility level should be used for the feature list. (Inherited from Database.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_Assemblies | (Inherited from ObjectCollections.)
m_AssemblyDependencies | (Inherited from ObjectCollections.)
m_AssemblyDependenciesBuilder | (Inherited from ObjectCollections.)
m_AsymmetricKeys | (Inherited from ObjectCollections.)
m_Certificates | (Inherited from ObjectCollections.)
m_Contracts | (Inherited from ObjectCollections.)
m_DBFactory | (Inherited from Database.)
m_DdlTriggers | (Inherited from ObjectCollections.)
m_Defaults | (Inherited from ObjectCollections.)
m_Dependencies | (Inherited from ObjectCollections.)
m_DependenciesBuilder | (Inherited from ObjectCollections.)
m_EventNotifications | (Inherited from ObjectCollections.)
m_ExtendedProperties | (Inherited from ObjectCollections.)
m_ForeignKeys | (Inherited from ObjectCollections.)
m_FullTextCatalogs | (Inherited from ObjectCollections.)
m_FullTextStoplists | (Inherited from ObjectCollections.)
m_Functions | (Inherited from ObjectCollections.)
m_License | (Inherited from ObjectCollections.)
m_MessageTypes | (Inherited from ObjectCollections.)
m_PartitionFunctions | (Inherited from ObjectCollections.)
m_PartitionSchemes | (Inherited from ObjectCollections.)
m_Queues | (Inherited from ObjectCollections.)
m_Roles | (Inherited from ObjectCollections.)
m_Routes | (Inherited from ObjectCollections.)
m_Rules | (Inherited from ObjectCollections.)
m_Schemas | (Inherited from ObjectCollections.)
m_SearchPropertyLists | (Inherited from ObjectCollections.)
m_SecondaryDatabases | (Inherited from ObjectCollections.)
m_SecurityPolicies | (Inherited from ObjectCollections.)
m_Sequences | (Inherited from ObjectCollections.)
m_ServiceBindings | (Inherited from ObjectCollections.)
m_Services | (Inherited from ObjectCollections.)
m_StoredProcedures | (Inherited from ObjectCollections.)
m_SymmetricKeys | (Inherited from ObjectCollections.)
m_Synonyms | (Inherited from ObjectCollections.)
m_Tables | (Inherited from ObjectCollections.)
m_Triggers | (Inherited from ObjectCollections.)
m_UserDefinedTypes | (Inherited from ObjectCollections.)
m_Users | (Inherited from ObjectCollections.)
m_Views | (Inherited from ObjectCollections.)
m_XmlSchemaCollections | (Inherited from ObjectCollections.)

Properties

Name | Description
Assemblies | The CLR assemblies in the database. Note that CLR assemblies were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
AsymmetricKeys | The asymmetric keys in the database. Note that asymmetric keys were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
BackupConnection | After registering a database this will contain the active connection to the backup database.
Cancel | Indicates whether the Database registration has been canceled. (Inherited from Database.)
CaseSensitive | Indicates whether the Database has been set up as case sensitive. (Inherited from Database.)
Certificates | The certificates in the database. Note that certificates were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
ClrAssemblyDependenciesBuilder | The dependencies of the CLR assemblies in the database. (Inherited from Database.)
Collation | The collation of the database. (Inherited from Database.)
ConnectionProperties | The connection properties for the database. (Inherited from Database.)
Contracts | The contracts in the database. Note that contracts were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
DatabaseSource | (Inherited from Database.)
DbInfo | Script File Information *INTERNAL USE ONLY* (Inherited from Database.)
DdlTriggers | The DDL triggers in the database. (Inherited from ObjectCollections.)
Defaults | The defaults in the database. (Inherited from ObjectCollections.)
DependenciesBuilder | The dependencies in the database. (Inherited from Database.)
EventNotifications | The database-level event notifications in the database. Note that event notifications were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
ExtendedProperties | Database-level extended properties. (Inherited from ObjectCollections.)
FullTextCatalogs | The full-text catalogs in the database. (Inherited from ObjectCollections.)
FullTextEnabled | True if the Database has full text enabled. (Inherited from Database.)
FullTextStoplists | The full-text stoplists in the database. (Inherited from ObjectCollections.)
Functions | The user-defined functions in the database. (Inherited from ObjectCollections.)
IgnoreWrongPasswords | Tells the backup reader to ignore files with incorrect passwords
IsAzure | Is this database an Azure database? (Inherited from Database.)
m_AssemblyData | (Inherited from ObjectCollections.)
m_Comments | (Inherited from ObjectCollections.)
m_XMLSchemaData | (Inherited from ObjectCollections.)
MajorVersion | The major version of the SQL Server for the database. This reflects the compatibility mode of the database. (Inherited from Database.)
MessageTypes | The message types in the database. Note that message types were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
ParserMessages | A list of parser messages generated during population from a script folder. This will be null if the Database source is not a set of scripts. (Inherited from Database.)
PartitionFunctions | The partition functions in the database. Note that partition functions were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
PartitionSchemes | The partition schemes in the database. Note that partitions schemes were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
Queues | The queues in the database. Note that queues were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
RemoteDataArchiveEnabled | True if the database has REMOTE_DATA_ARCHIVE (aka 'Stretch Database') enabled. (Inherited from Database.)
Roles | The roles in the database. (Inherited from ObjectCollections.)
Routes | The routes in the database. Note that routes were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
Rules | The rules in the database. (Inherited from ObjectCollections.)
Schemas | The schemas in the database. Note that schemas were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
ScriptFolder | (Inherited from Database.)
SearchPropertyLists | (Inherited from ObjectCollections.)
SecurityPolicies | The security policies in the database. (Inherited from ObjectCollections.)
Sequences | The sequence objects in the database. Note that these were introduced in SQL Server 2012 (Inherited from ObjectCollections.)
ServerMajorVersion | The major server version of the SQL Server for the database. This may be different from the MajorVersion property if the Database is running in a compatibility mode. (Inherited from Database.)
ServiceBindings | The service bindings in the database. Note that service bindings were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
Services | The services in the database. Note that services were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
SOCCompareLocationProvider | (Inherited from Database.)
SourceControlInfo | (Inherited from Database.)
SqlServerVersionInfo | Information about the version of SQL Server this database exists on, including version number, compatibility level, internal version and whether or not it's an Azure database. (Inherited from Database.)
Status | Used to provide status events. (Inherited from Database.)
StoredProcedures | The stored procedures in the database. (Inherited from ObjectCollections.)
SupportedFeatures | (Inherited from Database.)
SymmetricKeys | The symmetric keys in the database. Note that symmetric keys were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
Synonyms | The synonyms in the database. Note that synonyms were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
Tables | The tables in the database. (Inherited from ObjectCollections.)
TotalObjectCount | (Inherited from ObjectCollections.)
UserDefinedTypes | The user-defined types in the database. (Inherited from ObjectCollections.)
Users | The users in the database. (Inherited from ObjectCollections.)
Views | The views in the database. (Inherited from ObjectCollections.)
XmlSchemaCollections | The XML schema collections in the database. Note that XML schema collections were introduced in SQL Server 2005. (Inherited from ObjectCollections.)

Explicit Interface Implementations

Name | Description
ICloneableClone | (Inherited from Database.)
IDatabase..::.GetObjectCollectionByType | (Inherited from Database.)

See Also

BackupSetDatabase Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


BackupSetDatabase Constructor

[image]

SQL Data Compare API 12.0.40
BackupSetDatabase Constructor
BackupSetDatabase Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BackupSetDatabase()
Visual C++
public:
BackupSetDatabase()

See Also

BackupSetDatabase Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


BackupSetDatabase Methods

[image] [image]

SQL Data Compare API 12.0.40
BackupSetDatabase Methods
BackupSetDatabase Class See Also

The BackupSetDatabase type exposes the following methods.

Methods

Name | Description
CancelOperation | Cancels the current operation. (Overrides Database ..::.CancelOperation()()().)
Clone | (Overrides Database ..::.Clone()()().)
Close | Closes the connection to the backup database.
CompareWith | Overloaded.
CreateEmptyTarget | For internal use only (Inherited from Database.)
Dispose | Disposes of the object. (Overrides Database ..::. Dispose()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllObjects | (Inherited from ObjectCollections.)
GetBackupSets | Retreives a list of backup sets from the given backup files. This operation is ICancellable.
GetDatabaseObject | Overloaded.
GetDatabaseObjects<(Of <(T>)>) | (Inherited from ObjectCollections.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectCollectionByType | Returns a readonly collection of database objects, of the specified type. (Inherited from ObjectCollections.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsCaseSensitive |
IsPasswordRequired | Overloaded.
LoadFromDisk | Loads the Database from disk. (Inherited from Database.)
LoadFromStream | Loads the Database from a stream. This is an alternative to the LoadFromDisk method. (Inherited from Database.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PopulateFromMetadataFiles | (Inherited from Database.)
Register | Overloaded.
RegisterForDataCompare | Overloaded.
RegisterForDataCompareInner | (Overrides Database ..::. RegisterForDataCompareInner(IDatabaseFactory).)
SaveToDisk | Saves the Database to disk. (Inherited from Database.)
SaveToFolder | Overloaded.
SaveToStream | Writes the Database snapshot to the specified stream. This is an alternative to the SaveToDisk method (Inherited from Database.)
SetSqlServerVersionInfo | Sets the SqlVersion of the database and updates the associated list of supported features taking into account whether the server version or compatibility level should be used for the feature list. (Inherited from Database.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICloneableClone | (Inherited from Database.)
IDatabase..::.GetObjectCollectionByType | (Inherited from Database.)

See Also

BackupSetDatabase Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


CancelOperation Method

[image]

SQL Data Compare API 12.0.40
BackupSetDatabase..::.CancelOperation Method
BackupSetDatabase Class See Also

Cancels the current operation.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub CancelOperation
C#
public override void CancelOperation()
Visual C++
public:
virtual void CancelOperation() override

Implements

ICancellable..::.CancelOperation()()()

See Also

BackupSetDatabase Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
BackupSetDatabase..::.Clone Method
BackupSetDatabase Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone As Database
C#
public override Database Clone()
Visual C++
public:
virtual Database^ Clone() override

See Also

BackupSetDatabase Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


Close Method

[image]

SQL Data Compare API 12.0.40
BackupSetDatabase..::.Close Method
BackupSetDatabase Class See Also

Closes the connection to the backup database.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Close
C#
public void Close()
Visual C++
public:
void Close()

See Also

BackupSetDatabase Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


CompareWith Method

[image] [image]

SQL Data Compare API 12.0.40
BackupSetDatabase..::.CompareWith Method
BackupSetDatabase Class See Also

Overload List

Name | Description
CompareWith(Database, Options) | Compares the Database with another database. (Inherited from Database.)
CompareWith(Database, Options, SqlCompareOwnerMappings) | Compares the Database with another database. (Inherited from Database.)
CompareWith(Database, Options, SqlCompareOwnerMappings, SqlCompareTableMappings) | Compares the Database with another database. (Inherited from Database.)

See Also

BackupSetDatabase Class
BackupSetDatabase Members
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


Dispose Method

[image]

SQL Data Compare API 12.0.40
BackupSetDatabase..::.Dispose Method
BackupSetDatabase Class See Also

Disposes of the object.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Dispose
C#
public override void Dispose()
Visual C++
public:
virtual void Dispose() override

Implements

IDisposableDispose()()()
IDisposableDispose()()()

Remarks

It is important to dispose of the object to delete any temporary files it uses.

See Also

BackupSetDatabase Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


GetBackupSets Method

[image]

SQL Data Compare API 12.0.40
BackupSetDatabase..::.GetBackupSets Method
BackupSetDatabase Class See Also

Retreives a list of backup sets from the given backup files. This operation is ICancellable.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetBackupSets ( _
    filePaths As IList(Of String), _
    passwords As IList(Of String) _
) As IList(Of IBackupSet)
C#
public IList<IBackupSet> GetBackupSets(
    IList<string> filePaths,
    IList<string> passwords
)
Visual C++
public:
IList<IBackupSet^>^ GetBackupSets(
    IList<String^>^ filePaths,
    IList<String^>^ passwords
)

Parameters

filePaths
Type: IList<(Of <(String>)>)
A list of the files to open.
passwords
Type: IList<(Of <(String>)>)
A list of passwords for the files if this is an encrypted SQL Backup, String.Empty if password not needed for that file.

Return Value

A list of the available backup sets in the given files.

See Also

BackupSetDatabase Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


GetDatabaseObject Method

[image] [image]

SQL Data Compare API 12.0.40
BackupSetDatabase..::.GetDatabaseObject Method
BackupSetDatabase Class See Also

Overload List

Name | Description
GetDatabaseObject(String) | Get database object by two-part name (Inherited from ObjectCollections.)
GetDatabaseObject(String, ObjectType) | (Inherited from ObjectCollections.)

See Also

BackupSetDatabase Class
BackupSetDatabase Members
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


IsCaseSensitive Method

[image]

SQL Data Compare API 12.0.40
BackupSetDatabase..::.IsCaseSensitive Method
BackupSetDatabase Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsCaseSensitive ( _
    connProps As ConnectionProperties _
) As Boolean
C#
public static bool IsCaseSensitive(
    ConnectionProperties connProps
)
Visual C++
public:
static bool IsCaseSensitive(
    ConnectionProperties^ connProps
)

Parameters

connProps
Type: RedGate.SQLCompare.Engine..::.ConnectionProperties

See Also

BackupSetDatabase Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


IsPasswordRequired Method

[image] [image]

SQL Data Compare API 12.0.40
BackupSetDatabase..::.IsPasswordRequired Method
BackupSetDatabase Class See Also

Overload List

Name | Description
IsPasswordRequired(IList<(Of <(String>)>)) | Returns true if the backup files need a password to be read, false otherwise.
IsPasswordRequired(ConnectionProperties) |

See Also

BackupSetDatabase Class
BackupSetDatabase Members
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


IsPasswordRequired Method (())

[image]

SQL Data Compare API 12.0.40
BackupSetDatabase..::.IsPasswordRequired Method (<(Of <(>)>))
BackupSetDatabase Class See Also

Returns true if the backup files need a password to be read, false otherwise.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsPasswordRequired ( _
    filePaths As IList(Of String) _
) As Boolean
C#
public static bool IsPasswordRequired(
    IList<string> filePaths
)
Visual C++
public:
static bool IsPasswordRequired(
    IList<String^>^ filePaths
)

Parameters

filePaths
Type: IList<(Of <(String>)>)
A list of the files to open.

Return Value

true if the backup files need a password to be read, false otherwise.

See Also

BackupSetDatabase Class
IsPasswordRequired Overload
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


IsPasswordRequired Method (ConnectionProperties)

[image]

SQL Data Compare API 12.0.40
BackupSetDatabase..::.IsPasswordRequired Method (ConnectionProperties)
BackupSetDatabase Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsPasswordRequired ( _
    connProps As ConnectionProperties _
) As Boolean
C#
public static bool IsPasswordRequired(
    ConnectionProperties connProps
)
Visual C++
public:
static bool IsPasswordRequired(
    ConnectionProperties^ connProps
)

Parameters

connProps
Type: RedGate.SQLCompare.Engine..::.ConnectionProperties

See Also

BackupSetDatabase Class
IsPasswordRequired Overload
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


Register Method

[image] [image]

SQL Data Compare API 12.0.40
BackupSetDatabase..::.Register Method
BackupSetDatabase Class See Also

Overload List

Name | Description
Register(String, ScriptDatabaseInformation, Options) | Registers the Database from creation scripts that are stored in the folder specified by the path parameter. (Inherited from Database.)
Register(ConnectionProperties, Options, IDmvModelFactory) | Registers a database. (Inherited from Database.)
Register(String, ScriptDatabaseInformation, Options, IEnumerable<(Of <(String>)>)) | Registers the Database from creation scripts that are stored in the folder specified by the path parameter. (Inherited from Database.)
Register(String, ScriptDatabaseInformation, Options, IEnumerable<(Of <(String>)>), IReadFromFolderCache, IDatabaseFromFolderPopulator) | (Inherited from Database.)

See Also

BackupSetDatabase Class
BackupSetDatabase Members
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


RegisterForDataCompare Method

[image] [image]

SQL Data Compare API 12.0.40
BackupSetDatabase..::.RegisterForDataCompare Method
BackupSetDatabase Class See Also

Overload List

Name | Description
RegisterForDataCompare(ConnectionProperties) | Registers a Database for SQL Data Compare. (Inherited from Database.)
RegisterForDataCompare(ConnectionProperties, Options) | Registers a Database for SQL Data Compare. (Inherited from Database.)
RegisterForDataCompare(String, ScriptDatabaseInformation, Options) | (Inherited from Database.)

See Also

BackupSetDatabase Class
BackupSetDatabase Members
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


RegisterForDataCompareInner Method

[image]

SQL Data Compare API 12.0.40
BackupSetDatabase..::.RegisterForDataCompareInner Method
BackupSetDatabase Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RegisterForDataCompareInner ( _
    idbFactory As IDatabaseFactory _
)
C#
protected override void RegisterForDataCompareInner(
    IDatabaseFactory idbFactory
)
Visual C++
protected:
virtual void RegisterForDataCompareInner(
    IDatabaseFactory^ idbFactory
) override

Parameters

idbFactory
Type: RedGate.SQLCompare.Engine.Registration.ModelFactory..::.IDatabaseFactory

See Also

BackupSetDatabase Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


SaveToFolder Method

[image] [image]

SQL Data Compare API 12.0.40
BackupSetDatabase..::.SaveToFolder Method
BackupSetDatabase Class See Also

Overload List

Name | Description
SaveToFolder(String) | Obsolete. Saves the Database as a set of creation scripts to the specified folder. (Inherited from Database.)
SaveToFolder(String, ScriptDatabaseInformation) | Saves the Database as a set of creation scripts to the specified folder. (Inherited from Database.)
SaveToFolder(String, Options, ScriptDatabaseInformation, IFileNameGenerator) | Saves the Database as a set of creation scripts to the specified folder. (Inherited from Database.)

See Also

BackupSetDatabase Class
BackupSetDatabase Members
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


BackupSetDatabase Properties

[image] [image]

SQL Data Compare API 12.0.40
BackupSetDatabase Properties
BackupSetDatabase Class See Also

The BackupSetDatabase type exposes the following properties.

Properties

Name | Description
Assemblies | The CLR assemblies in the database. Note that CLR assemblies were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
AsymmetricKeys | The asymmetric keys in the database. Note that asymmetric keys were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
BackupConnection | After registering a database this will contain the active connection to the backup database.
Cancel | Indicates whether the Database registration has been canceled. (Inherited from Database.)
CaseSensitive | Indicates whether the Database has been set up as case sensitive. (Inherited from Database.)
Certificates | The certificates in the database. Note that certificates were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
ClrAssemblyDependenciesBuilder | The dependencies of the CLR assemblies in the database. (Inherited from Database.)
Collation | The collation of the database. (Inherited from Database.)
ConnectionProperties | The connection properties for the database. (Inherited from Database.)
Contracts | The contracts in the database. Note that contracts were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
DatabaseSource | (Inherited from Database.)
DbInfo | Script File Information *INTERNAL USE ONLY* (Inherited from Database.)
DdlTriggers | The DDL triggers in the database. (Inherited from ObjectCollections.)
Defaults | The defaults in the database. (Inherited from ObjectCollections.)
DependenciesBuilder | The dependencies in the database. (Inherited from Database.)
EventNotifications | The database-level event notifications in the database. Note that event notifications were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
ExtendedProperties | Database-level extended properties. (Inherited from ObjectCollections.)
FullTextCatalogs | The full-text catalogs in the database. (Inherited from ObjectCollections.)
FullTextEnabled | True if the Database has full text enabled. (Inherited from Database.)
FullTextStoplists | The full-text stoplists in the database. (Inherited from ObjectCollections.)
Functions | The user-defined functions in the database. (Inherited from ObjectCollections.)
IgnoreWrongPasswords | Tells the backup reader to ignore files with incorrect passwords
IsAzure | Is this database an Azure database? (Inherited from Database.)
m_AssemblyData | (Inherited from ObjectCollections.)
m_Comments | (Inherited from ObjectCollections.)
m_XMLSchemaData | (Inherited from ObjectCollections.)
MajorVersion | The major version of the SQL Server for the database. This reflects the compatibility mode of the database. (Inherited from Database.)
MessageTypes | The message types in the database. Note that message types were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
ParserMessages | A list of parser messages generated during population from a script folder. This will be null if the Database source is not a set of scripts. (Inherited from Database.)
PartitionFunctions | The partition functions in the database. Note that partition functions were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
PartitionSchemes | The partition schemes in the database. Note that partitions schemes were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
Queues | The queues in the database. Note that queues were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
RemoteDataArchiveEnabled | True if the database has REMOTE_DATA_ARCHIVE (aka 'Stretch Database') enabled. (Inherited from Database.)
Roles | The roles in the database. (Inherited from ObjectCollections.)
Routes | The routes in the database. Note that routes were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
Rules | The rules in the database. (Inherited from ObjectCollections.)
Schemas | The schemas in the database. Note that schemas were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
ScriptFolder | (Inherited from Database.)
SearchPropertyLists | (Inherited from ObjectCollections.)
SecurityPolicies | The security policies in the database. (Inherited from ObjectCollections.)
Sequences | The sequence objects in the database. Note that these were introduced in SQL Server 2012 (Inherited from ObjectCollections.)
ServerMajorVersion | The major server version of the SQL Server for the database. This may be different from the MajorVersion property if the Database is running in a compatibility mode. (Inherited from Database.)
ServiceBindings | The service bindings in the database. Note that service bindings were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
Services | The services in the database. Note that services were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
SOCCompareLocationProvider | (Inherited from Database.)
SourceControlInfo | (Inherited from Database.)
SqlServerVersionInfo | Information about the version of SQL Server this database exists on, including version number, compatibility level, internal version and whether or not it's an Azure database. (Inherited from Database.)
Status | Used to provide status events. (Inherited from Database.)
StoredProcedures | The stored procedures in the database. (Inherited from ObjectCollections.)
SupportedFeatures | (Inherited from Database.)
SymmetricKeys | The symmetric keys in the database. Note that symmetric keys were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
Synonyms | The synonyms in the database. Note that synonyms were introduced in SQL Server 2005. (Inherited from ObjectCollections.)
Tables | The tables in the database. (Inherited from ObjectCollections.)
TotalObjectCount | (Inherited from ObjectCollections.)
UserDefinedTypes | The user-defined types in the database. (Inherited from ObjectCollections.)
Users | The users in the database. (Inherited from ObjectCollections.)
Views | The views in the database. (Inherited from ObjectCollections.)
XmlSchemaCollections | The XML schema collections in the database. Note that XML schema collections were introduced in SQL Server 2005. (Inherited from ObjectCollections.)

See Also

BackupSetDatabase Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


BackupConnection Property

[image]

SQL Data Compare API 12.0.40
BackupSetDatabase..::.BackupConnection Property
BackupSetDatabase Class See Also

After registering a database this will contain the active connection to the backup database.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BackupConnection As IBackupConnection
C#
public IBackupConnection BackupConnection { get; }
Visual C++
public:
property IBackupConnection^ BackupConnection {
    IBackupConnection^ get ();
}

See Also

BackupSetDatabase Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


IgnoreWrongPasswords Property

[image]

SQL Data Compare API 12.0.40
BackupSetDatabase..::.IgnoreWrongPasswords Property
BackupSetDatabase Class See Also

Tells the backup reader to ignore files with incorrect passwords

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IgnoreWrongPasswords As Boolean
C#
public bool IgnoreWrongPasswords { get; set; }
Visual C++
public:
property bool IgnoreWrongPasswords {
    bool get ();
    void set (bool value);
}

See Also

BackupSetDatabase Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


IBackupSetDatabase Interface

[image]

SQL Data Compare API 12.0.40
IBackupSetDatabase Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IBackupSetDatabase _
    Implements IDatabase, ICancellable, ICloneable, IVersionedDatabase,  _
    ICancellationStatus, IDatabaseObjects, IDisposable
C#
public interface IBackupSetDatabase : IDatabase,
    ICancellable, ICloneable, IVersionedDatabase, ICancellationStatus, IDatabaseObjects,
    IDisposable
Visual C++
public interface class IBackupSetDatabase : IDatabase,
    ICancellable, ICloneable, IVersionedDatabase, ICancellationStatus, IDatabaseObjects,
    IDisposable

See Also

IBackupSetDatabase Members
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


IBackupSetDatabase Members

[image] [image]

SQL Data Compare API 12.0.40
IBackupSetDatabase Members
IBackupSetDatabase Interface Methods Properties See Also

The IBackupSetDatabase type exposes the following members.

Methods

Name | Description
CancelOperation | Cancels the current running operation. This will throw an instance of OperationCancelledException at the currently executing location on the executing thread (Inherited from ICancellable.)
Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Close | Closes the connection to the backup database.
CompareWith | Overloaded.
CreateEmptyTarget | For internal use only (Inherited from IDatabase.)
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
GetAllObjects | (Inherited from IDatabase.)
GetBackupSets | Overloaded.
GetDatabaseObject | (Inherited from IDatabaseObjects.)
GetDependencyStacks | For internal use only. (Inherited from IDatabase.)
GetObjectCollectionByType | Returns a readonly collection of database objects, of the specified type. (Inherited from IDatabase.)
LoadFromDisk | Loads the database from disk. (Inherited from IDatabase.)
LoadFromStream | Loads the database from a stream. This is an alternative to the LoadFromDisk method. (Inherited from IDatabase.)
Register | Overloaded.
RegisterForDataCompare | Overloaded.
RegisterForDependencyViewer | Internal use only. (Inherited from IDatabase.)
RegisterForRefactoring | Internal use only. (Inherited from IDatabase.)
RegisterGetObjectOwners | Internal use only. (Inherited from IDatabase.)
SaveToDisk | Saves the database to disk. (Inherited from IDatabase.)
SaveToFolder | Overloaded.
SaveToStream | Writes the database snapshot to the specified stream. This is an alternative to the SaveToDisk method (Inherited from IDatabase.)

Properties

Name | Description
Assemblies | The CLR assemblies in the database. Note that CLR assemblies were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
AsymmetricKeys | The asymmetric keys in the database. Note that asymmetric keys were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
BackupConnection | After registering a database this will contain the active connection to the backup database.
Cancel | Indicates whether the database registration has been canceled. (Inherited from ICancellationStatus.)
CaseSensitive | Indicates whether the database has been set up as case sensitive. (Inherited from IDatabase.)
Certificates | The certificates in the database. Note that certificates were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
ClrAssemblyDependencies | The dependencies of the CLR assemblies in the database. (Inherited from IDatabase.)
ClrAssemblyDependenciesBuilder | The dependencies of the CLR assemblies in the database. (Inherited from IDatabase.)
Collation | The collation of the database. (Inherited from IDatabase.)
ConnectionProperties | The connection properties for the database. (Inherited from IDatabase.)
Contracts | The contracts in the database. Note that contracts were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
DatabaseSource | (Inherited from IDatabase.)
DbInfo | Script File Information *INTERNAL USE ONLY* (Inherited from IDatabase.)
DdlTriggers | The DDL triggers in the database. (Inherited from IDatabaseObjects.)
Defaults | The defaults in the database. (Inherited from IDatabaseObjects.)
Dependencies | The dependencies in the database. (Inherited from IDatabase.)
DependenciesBuilder | The dependencies in the database. (Inherited from IDatabase.)
EventNotifications | The database-level event notifications in the database. Note that event notifications were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
ExtendedProperties | Database-level extended properties. (Inherited from IDatabaseObjects.)
FullTextCatalogs | The full-text catalogs in the database. (Inherited from IDatabaseObjects.)
FullTextEnabled | True if the database has full text enabled. (Inherited from IDatabase.)
FullTextStoplists | The full-text stoplists in the database. (Inherited from IDatabaseObjects.)
Functions | The user-defined functions in the database. (Inherited from IDatabaseObjects.)
IgnoreWrongPasswords | Tells the backup reader to ignore files with incorrect passwords
IsAzure | Is this database an Azure database? (Inherited from IDatabase.)
MajorVersion | The major version of the SQL Server for the database. This reflects the compatibility mode of the database. (Inherited from IVersionedDatabase.)
MessageTypes | The message types in the database. Note that message types were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
ParserMessages | A list of parser messages generated during population from a script folder. This will be null if the database source is not a set of scripts. (Inherited from IDatabase.)
PartitionFunctions | The partition functions in the database. Note that partition functions were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
PartitionSchemes | The partition schemes in the database. Note that partitions schemes were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Queues | The queues in the database. Note that queues were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Roles | The roles in the database. (Inherited from IDatabaseObjects.)
Routes | The routes in the database. Note that routes were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Rules | The rules in the database. (Inherited from IDatabaseObjects.)
Schemas | The schemas in the database. Note that schemas were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
ScriptFolder | (Inherited from IDatabase.)
SearchPropertyLists | (Inherited from IDatabaseObjects.)
SecurityPolicies | The security policies in the database. (Inherited from IDatabaseObjects.)
Sequences | The sequence objects in the database. Note that these were introduced in SQL Server 2012 (Inherited from IDatabaseObjects.)
ServerMajorVersion | The major server version of the SQL Server for the database. This does not change if the database is running in compatibility mode. (Inherited from IVersionedDatabase.)
ServiceBindings | The service bindings in the database. Note that service bindings were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Services | The services in the database. Note that services were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
SOCCompareLocationProvider | (Inherited from IDatabase.)
SourceControlInfo | (Inherited from IDatabase.)
SqlServerVersionInfo | Information about the version of SQL Server this database exists on, including version number, compatibility level, internal version and whether or not it's an Azure database. (Inherited from IVersionedDatabase.)
Status | Gets and sets a delegate that can be used to notify of message or percentage changes (Inherited from ICancellable.)
StoredProcedures | The stored procedures in the database. (Inherited from IDatabaseObjects.)
SupportedFeatures | (Inherited from IVersionedDatabase.)
SymmetricKeys | The symmetric keys in the database. Note that symmetric keys were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Synonyms | The synonyms in the database. Note that synonyms were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Tables | The tables in the database. (Inherited from IDatabaseObjects.)
UserDefinedTypes | The user-defined types in the database. (Inherited from IDatabaseObjects.)
Users | The users in the database. (Inherited from IDatabaseObjects.)
Views | The views in the database. (Inherited from IDatabaseObjects.)
XmlSchemaCollections | The XML schema collections in the database. Note that XML schema collections were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)

See Also

IBackupSetDatabase Interface
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


IBackupSetDatabase Methods

[image] [image]

SQL Data Compare API 12.0.40
IBackupSetDatabase Methods
IBackupSetDatabase Interface See Also

The IBackupSetDatabase type exposes the following methods.

Methods

Name | Description
CancelOperation | Cancels the current running operation. This will throw an instance of OperationCancelledException at the currently executing location on the executing thread (Inherited from ICancellable.)
Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Close | Closes the connection to the backup database.
CompareWith | Overloaded.
CreateEmptyTarget | For internal use only (Inherited from IDatabase.)
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
GetAllObjects | (Inherited from IDatabase.)
GetBackupSets | Overloaded.
GetDatabaseObject | (Inherited from IDatabaseObjects.)
GetDependencyStacks | For internal use only. (Inherited from IDatabase.)
GetObjectCollectionByType | Returns a readonly collection of database objects, of the specified type. (Inherited from IDatabase.)
LoadFromDisk | Loads the database from disk. (Inherited from IDatabase.)
LoadFromStream | Loads the database from a stream. This is an alternative to the LoadFromDisk method. (Inherited from IDatabase.)
Register | Overloaded.
RegisterForDataCompare | Overloaded.
RegisterForDependencyViewer | Internal use only. (Inherited from IDatabase.)
RegisterForRefactoring | Internal use only. (Inherited from IDatabase.)
RegisterGetObjectOwners | Internal use only. (Inherited from IDatabase.)
SaveToDisk | Saves the database to disk. (Inherited from IDatabase.)
SaveToFolder | Overloaded.
SaveToStream | Writes the database snapshot to the specified stream. This is an alternative to the SaveToDisk method (Inherited from IDatabase.)

See Also

IBackupSetDatabase Interface
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


Close Method

[image]

SQL Data Compare API 12.0.40
IBackupSetDatabase..::.Close Method
IBackupSetDatabase Interface See Also

Closes the connection to the backup database.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub Close
C#
void Close()
Visual C++
void Close()

See Also

IBackupSetDatabase Interface
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


CompareWith Method

[image] [image]

SQL Data Compare API 12.0.40
IBackupSetDatabase..::.CompareWith Method
IBackupSetDatabase Interface See Also

Overload List

Name | Description
CompareWith(Database, Options) | Compares the database with another database. (Inherited from IDatabase.)
CompareWith(Database, Options, SqlCompareOwnerMappings) | Compares the database with another database. (Inherited from IDatabase.)
CompareWith(Database, Options, SqlCompareOwnerMappings, SqlCompareTableMappings) | Compares the database with another database. (Inherited from IDatabase.)

See Also

IBackupSetDatabase Interface
IBackupSetDatabase Members
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


GetBackupSets Method

[image] [image]

SQL Data Compare API 12.0.40
IBackupSetDatabase..::.GetBackupSets Method
IBackupSetDatabase Interface See Also

Overload List

Name | Description
GetBackupSets(IList<(Of <(String>)>)) | Retreives a list of backup sets from the given backup files. This operation is ICancellable.
GetBackupSets(IList<(Of <(String>)>), IList<(Of <(String>)>)) | Retreives a list of backup sets from the given backup files. This operation is ICancellable.

See Also

IBackupSetDatabase Interface
IBackupSetDatabase Members
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


GetBackupSets Method (())

[image]

SQL Data Compare API 12.0.40
IBackupSetDatabase..::.GetBackupSets Method (<(Of <(>)>))
IBackupSetDatabase Interface See Also

Retreives a list of backup sets from the given backup files. This operation is ICancellable.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetBackupSets ( _
    filePaths As IList(Of String) _
) As IList(Of IBackupSet)
C#
IList<IBackupSet> GetBackupSets(
    IList<string> filePaths
)
Visual C++
IList<IBackupSet^>^ GetBackupSets(
    IList<String^>^ filePaths
)

Parameters

filePaths
Type: IList<(Of <(String>)>)
A list of the files to open.

Return Value

A list of the available backup sets in the given files.

See Also

IBackupSetDatabase Interface
GetBackupSets Overload
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


GetBackupSets Method ((), ())

[image]

SQL Data Compare API 12.0.40
IBackupSetDatabase..::.GetBackupSets Method (<(Of <(>)>), <(Of <(>)>))
IBackupSetDatabase Interface See Also

Retreives a list of backup sets from the given backup files. This operation is ICancellable.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetBackupSets ( _
    filePaths As IList(Of String), _
    passwords As IList(Of String) _
) As IList(Of IBackupSet)
C#
IList<IBackupSet> GetBackupSets(
    IList<string> filePaths,
    IList<string> passwords
)
Visual C++
IList<IBackupSet^>^ GetBackupSets(
    IList<String^>^ filePaths,
    IList<String^>^ passwords
)

Parameters

filePaths
Type: IList<(Of <(String>)>)
A list of the files to open.
passwords
Type: IList<(Of <(String>)>)
A list of passwords for the files if this is an encrypted SQL Backup, String.Empty if password not needed for that file.

Return Value

A list of the available backup sets in the given files.

See Also

IBackupSetDatabase Interface
GetBackupSets Overload
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


Register Method

[image] [image]

SQL Data Compare API 12.0.40
IBackupSetDatabase..::.Register Method
IBackupSetDatabase Interface See Also

Overload List

Name | Description
Register(String, ScriptDatabaseInformation, Options) | Registers the database from creation scripts that are stored in the folder specified by the path parameter. (Inherited from IDatabase.)
Register(ConnectionProperties, Options, IDmvModelFactory) | Registers a database. (Inherited from IDatabase.)
Register(String, ScriptDatabaseInformation, Options, IEnumerable<(Of <(String>)>)) | Registers the database from creation scripts that are stored in the folder specified by the path parameter. (Inherited from IDatabase.)
Register(String, ScriptDatabaseInformation, Options, IEnumerable<(Of <(String>)>), IReadFromFolderCache, IDatabaseFromFolderPopulator) | (Inherited from IDatabase.)

See Also

IBackupSetDatabase Interface
IBackupSetDatabase Members
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


RegisterForDataCompare Method

[image] [image]

SQL Data Compare API 12.0.40
IBackupSetDatabase..::.RegisterForDataCompare Method
IBackupSetDatabase Interface See Also

Overload List

Name | Description
RegisterForDataCompare(ConnectionProperties) | Registers a database for SQL Data Compare. (Inherited from IDatabase.)
RegisterForDataCompare(ConnectionProperties, Options) | Registers a database for SQL Data Compare. (Inherited from IDatabase.)
RegisterForDataCompare(String, ScriptDatabaseInformation, Options) | (Inherited from IDatabase.)

See Also

IBackupSetDatabase Interface
IBackupSetDatabase Members
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


SaveToFolder Method

[image] [image]

SQL Data Compare API 12.0.40
IBackupSetDatabase..::.SaveToFolder Method
IBackupSetDatabase Interface See Also

Overload List

Name | Description
SaveToFolder(String) | Obsolete. Saves the database as a set of creation scripts to the specified folder. (Inherited from IDatabase.)
SaveToFolder(String, ScriptDatabaseInformation) | Saves the database as a set of creation scripts to the specified folder. (Inherited from IDatabase.)
SaveToFolder(String, Options, ScriptDatabaseInformation, IFileNameGenerator) | Saves the database as a set of creation scripts to the specified folder. (Inherited from IDatabase.)

See Also

IBackupSetDatabase Interface
IBackupSetDatabase Members
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


IBackupSetDatabase Properties

[image] [image]

SQL Data Compare API 12.0.40
IBackupSetDatabase Properties
IBackupSetDatabase Interface See Also

The IBackupSetDatabase type exposes the following properties.

Properties

Name | Description
Assemblies | The CLR assemblies in the database. Note that CLR assemblies were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
AsymmetricKeys | The asymmetric keys in the database. Note that asymmetric keys were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
BackupConnection | After registering a database this will contain the active connection to the backup database.
Cancel | Indicates whether the database registration has been canceled. (Inherited from ICancellationStatus.)
CaseSensitive | Indicates whether the database has been set up as case sensitive. (Inherited from IDatabase.)
Certificates | The certificates in the database. Note that certificates were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
ClrAssemblyDependencies | The dependencies of the CLR assemblies in the database. (Inherited from IDatabase.)
ClrAssemblyDependenciesBuilder | The dependencies of the CLR assemblies in the database. (Inherited from IDatabase.)
Collation | The collation of the database. (Inherited from IDatabase.)
ConnectionProperties | The connection properties for the database. (Inherited from IDatabase.)
Contracts | The contracts in the database. Note that contracts were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
DatabaseSource | (Inherited from IDatabase.)
DbInfo | Script File Information *INTERNAL USE ONLY* (Inherited from IDatabase.)
DdlTriggers | The DDL triggers in the database. (Inherited from IDatabaseObjects.)
Defaults | The defaults in the database. (Inherited from IDatabaseObjects.)
Dependencies | The dependencies in the database. (Inherited from IDatabase.)
DependenciesBuilder | The dependencies in the database. (Inherited from IDatabase.)
EventNotifications | The database-level event notifications in the database. Note that event notifications were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
ExtendedProperties | Database-level extended properties. (Inherited from IDatabaseObjects.)
FullTextCatalogs | The full-text catalogs in the database. (Inherited from IDatabaseObjects.)
FullTextEnabled | True if the database has full text enabled. (Inherited from IDatabase.)
FullTextStoplists | The full-text stoplists in the database. (Inherited from IDatabaseObjects.)
Functions | The user-defined functions in the database. (Inherited from IDatabaseObjects.)
IgnoreWrongPasswords | Tells the backup reader to ignore files with incorrect passwords
IsAzure | Is this database an Azure database? (Inherited from IDatabase.)
MajorVersion | The major version of the SQL Server for the database. This reflects the compatibility mode of the database. (Inherited from IVersionedDatabase.)
MessageTypes | The message types in the database. Note that message types were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
ParserMessages | A list of parser messages generated during population from a script folder. This will be null if the database source is not a set of scripts. (Inherited from IDatabase.)
PartitionFunctions | The partition functions in the database. Note that partition functions were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
PartitionSchemes | The partition schemes in the database. Note that partitions schemes were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Queues | The queues in the database. Note that queues were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Roles | The roles in the database. (Inherited from IDatabaseObjects.)
Routes | The routes in the database. Note that routes were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Rules | The rules in the database. (Inherited from IDatabaseObjects.)
Schemas | The schemas in the database. Note that schemas were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
ScriptFolder | (Inherited from IDatabase.)
SearchPropertyLists | (Inherited from IDatabaseObjects.)
SecurityPolicies | The security policies in the database. (Inherited from IDatabaseObjects.)
Sequences | The sequence objects in the database. Note that these were introduced in SQL Server 2012 (Inherited from IDatabaseObjects.)
ServerMajorVersion | The major server version of the SQL Server for the database. This does not change if the database is running in compatibility mode. (Inherited from IVersionedDatabase.)
ServiceBindings | The service bindings in the database. Note that service bindings were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Services | The services in the database. Note that services were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
SOCCompareLocationProvider | (Inherited from IDatabase.)
SourceControlInfo | (Inherited from IDatabase.)
SqlServerVersionInfo | Information about the version of SQL Server this database exists on, including version number, compatibility level, internal version and whether or not it's an Azure database. (Inherited from IVersionedDatabase.)
Status | Gets and sets a delegate that can be used to notify of message or percentage changes (Inherited from ICancellable.)
StoredProcedures | The stored procedures in the database. (Inherited from IDatabaseObjects.)
SupportedFeatures | (Inherited from IVersionedDatabase.)
SymmetricKeys | The symmetric keys in the database. Note that symmetric keys were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Synonyms | The synonyms in the database. Note that synonyms were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)
Tables | The tables in the database. (Inherited from IDatabaseObjects.)
UserDefinedTypes | The user-defined types in the database. (Inherited from IDatabaseObjects.)
Users | The users in the database. (Inherited from IDatabaseObjects.)
Views | The views in the database. (Inherited from IDatabaseObjects.)
XmlSchemaCollections | The XML schema collections in the database. Note that XML schema collections were introduced in SQL Server 2005. (Inherited from IDatabaseObjects.)

See Also

IBackupSetDatabase Interface
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


BackupConnection Property

[image]

SQL Data Compare API 12.0.40
IBackupSetDatabase..::.BackupConnection Property
IBackupSetDatabase Interface See Also

After registering a database this will contain the active connection to the backup database.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property BackupConnection As IBackupConnection
C#
IBackupConnection BackupConnection { get; }
Visual C++
property IBackupConnection^ BackupConnection {
    IBackupConnection^ get ();
}

See Also

IBackupSetDatabase Interface
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


IgnoreWrongPasswords Property

[image]

SQL Data Compare API 12.0.40
IBackupSetDatabase..::.IgnoreWrongPasswords Property
IBackupSetDatabase Interface See Also

Tells the backup reader to ignore files with incorrect passwords

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property IgnoreWrongPasswords As Boolean
C#
bool IgnoreWrongPasswords { get; set; }
Visual C++
property bool IgnoreWrongPasswords {
    bool get ();
    void set (bool value);
}

See Also

IBackupSetDatabase Interface
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


SQLBackupReaderLoadException Class

[image]

SQL Data Compare API 12.0.40
SQLBackupReaderLoadException Class
Members See Also

SQLBackupReaderLoadException

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SQLBackupReaderLoadException _
    Inherits Exception
C#
public class SQLBackupReaderLoadException : Exception
Visual C++
public ref class SQLBackupReaderLoadException : public Exception

Inheritance Hierarchy

Object
Exception
RedGate.SQLCompare.Engine.ReadFromBackup..::.SQLBackupReaderLoadException

See Also

SQLBackupReaderLoadException Members
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


SQLBackupReaderLoadException Members

[image] [image]

SQL Data Compare API 12.0.40
SQLBackupReaderLoadException Members
SQLBackupReaderLoadException Class Constructors Methods Properties See Also

The SQLBackupReaderLoadException type exposes the following members.

Constructors

Name | Description
SQLBackupReaderLoadException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SQLBackupReaderLoadException Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


SQLBackupReaderLoadException Constructor

[image] [image]

SQL Data Compare API 12.0.40
SQLBackupReaderLoadException Constructor
SQLBackupReaderLoadException Class See Also

Overload List

Name | Description
SQLBackupReaderLoadException()()() | SQLBackupReaderLoadException
SQLBackupReaderLoadException(String, Exception) | SQLBackupReaderLoadException

See Also

SQLBackupReaderLoadException Class
SQLBackupReaderLoadException Members
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


SQLBackupReaderLoadException Constructor

[image]

SQL Data Compare API 12.0.40
SQLBackupReaderLoadException Constructor
SQLBackupReaderLoadException Class See Also

SQLBackupReaderLoadException

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SQLBackupReaderLoadException()
Visual C++
public:
SQLBackupReaderLoadException()

See Also

SQLBackupReaderLoadException Class
SQLBackupReaderLoadException Overload
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


SQLBackupReaderLoadException Constructor (, )

[image]

SQL Data Compare API 12.0.40
SQLBackupReaderLoadException Constructor (, )
SQLBackupReaderLoadException Class See Also

SQLBackupReaderLoadException

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    exception As Exception _
)
C#
public SQLBackupReaderLoadException(
    string message,
    Exception exception
)
Visual C++
public:
SQLBackupReaderLoadException(
    String^ message,
    Exception^ exception
)

Parameters

message
Type: String
exception
Type: Exception

See Also

SQLBackupReaderLoadException Class
SQLBackupReaderLoadException Overload
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


RedGate.SQLCompare.Engine.ReadFromFolder Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.ReadFromFolder Namespace

Classes

Class | Description
CacheResult |
DatabaseObjectExtensions |
DatabaseObjectProperty |
DataPreservingXmlStringBuilder | Takes an existing document and adds merges in data written to it.
ErrorsOccurredDuringScriptFileParsingException |
FolderDataSource | Representation of a data source that will take its data from a series of scripts in a folder.
LazyFileContents | Provides an abstraction over a file's contents so that it is not unnecessarily loaded. This is useful in: IO bound tasks (such as registering a scripts folder) since it reduces disk reads. Memory bound tasks (such as registering a scripts folder in a 32-bit process) since it reduces unnecessarily allocations. CPU bound tasks (such as registering a scripts folder with an SSD) since reduced memory pressure means fewer garbage collections.
NullUpdater |
ObjectInformationFromDatabase |
ObjectInformationFromDictionary |
ParserError | Contains an error found in the scripts
ParseResult |
ParserMessage | Represents an informative message generated during parsing.
ScriptDatabaseInformation | Options and settings that control how the creation SQL files are loaded and processed.
ScriptDatabaseInformation..::.WriteToFileOptions | Options that control how script files are written to a scripts folder.
ScriptEncoder |
ScriptSynchronizationAction | A synchronization action that is used when a file needs to be created or altered during synchronizing to a scripts folder.
ScriptSynchronizationActionBlatObject | A synchronization action that creates a new file for a database object. The database object may or may not be in the destination script folder already. Please use ScriptSynchronizationActionCreateObject if at all possible, because using this class causes SC-4654.
ScriptSynchronizationActionCreateObject | A synchronization action that creates a new file for a database object. The database object must not be in the destination script folder already.
ScriptSynchronizationActionRewrite | A synchronization action that modifies a creation SQL file.
ScriptSynchronizationActions | The synchronization actions that need to be executed during synchronizing to a scripts folder.
ScriptSynchronizationActionWrite | A synchronization action that creates a new file for a database object.
StringWriterWithEncoding | The normal StringWriter ignores encoding and therefore screws up when used with XmlTextWriter. This is to fix that issue.
SynchronizationActionBinaryRewrite |
SynchronizationActionRewriteBase |
TSQLParser |
UpdateDataToolsProjectAction |
UpdateDBInfoAction | Modifies database settings during synchronizing to a scripts folder.

Interfaces

Interface Description
IObjectLookup
Interface for looking up object names by their ID and vice versa We have two implementations of this interface: ObjectInformationFromDatabase and ObjectInformationFromDictionary. These two implementations provide slightly different tradeoffs, which work well for script and live registration respectively. ObjectInformationFromDatabase uses the database as the one true source of information. This works better for script folders since objects in the database probably have well-qualified names and are in a consistent state ObjectInformationFromDictionary stores information in a dictionary. This works well for live/backup registration since one of the first things we do is run a DMV query to fetch a big list of object names and IDs. This ends up meaning that live registration is built on the assumption that we can always know the ID of any object name, while script registration processes one file at a time, and so has more post-processing steps to fix up the model after all files have been read.
ITSQLParser
IUpdateProject

Enumerations

Enumeration | Description
FolderInformationErrors | A set of flags indicating warnings and errors that can occur while setting up a read from folder data source
ParserMessageType | The different types of messages the parser can produce.
ScriptEncodingType |


CacheResult Class

[image]

SQL Data Compare API 12.0.40
CacheResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class CacheResult
C#
public class CacheResult
Visual C++
public ref class CacheResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.CacheResult

See Also

CacheResult Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


CacheResult Members

[image] [image]

SQL Data Compare API 12.0.40
CacheResult Members
CacheResult Class Constructors Methods Properties See Also

The CacheResult type exposes the following members.

Constructors

Name | Description
CacheResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromSnapshot | Creates a cache result identifying that the scripts folder was incrementally registered
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
HasParsedObject |
ParsedAnew |
PercentageOfObjectsReadFromCache |
ReadFromCache |
ReadFromSnapshot |

See Also

CacheResult Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


CacheResult Constructor

[image]

SQL Data Compare API 12.0.40
CacheResult Constructor
CacheResult Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CacheResult()
Visual C++
public:
CacheResult()

See Also

CacheResult Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


CacheResult Methods

[image] [image]

SQL Data Compare API 12.0.40
CacheResult Methods
CacheResult Class See Also

The CacheResult type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromSnapshot | Creates a cache result identifying that the scripts folder was incrementally registered
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CacheResult Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FromSnapshot Method

[image]

SQL Data Compare API 12.0.40
CacheResult..::.FromSnapshot Method
CacheResult Class See Also

Creates a cache result identifying that the scripts folder was incrementally registered

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FromSnapshot As CacheResult
C#
public static CacheResult FromSnapshot()
Visual C++
public:
static CacheResult^ FromSnapshot()

See Also

CacheResult Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


CacheResult Properties

[image] [image]

SQL Data Compare API 12.0.40
CacheResult Properties
CacheResult Class See Also

The CacheResult type exposes the following properties.

Properties

Name | Description
HasParsedObject |
ParsedAnew |
PercentageOfObjectsReadFromCache |
ReadFromCache |
ReadFromSnapshot |

See Also

CacheResult Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


HasParsedObject Property

[image]

SQL Data Compare API 12.0.40
CacheResult..::.HasParsedObject Property
CacheResult Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasParsedObject As Boolean
C#
public bool HasParsedObject { get; }
Visual C++
public:
property bool HasParsedObject {
    bool get ();
}

See Also

CacheResult Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ParsedAnew Property

[image]

SQL Data Compare API 12.0.40
CacheResult..::.ParsedAnew Property
CacheResult Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParsedAnew As Integer
C#
public int ParsedAnew { get; }
Visual C++
public:
property int ParsedAnew {
    int get ();
}

See Also

CacheResult Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


PercentageOfObjectsReadFromCache Property

[image]

SQL Data Compare API 12.0.40
CacheResult..::.PercentageOfObjectsReadFromCache Property
CacheResult Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PercentageOfObjectsReadFromCache As Integer
C#
public int PercentageOfObjectsReadFromCache { get; }
Visual C++
public:
property int PercentageOfObjectsReadFromCache {
    int get ();
}

See Also

CacheResult Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ReadFromCache Property

[image]

SQL Data Compare API 12.0.40
CacheResult..::.ReadFromCache Property
CacheResult Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReadFromCache As Integer
C#
public int ReadFromCache { get; }
Visual C++
public:
property int ReadFromCache {
    int get ();
}

See Also

CacheResult Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ReadFromSnapshot Property

[image]

SQL Data Compare API 12.0.40
CacheResult..::.ReadFromSnapshot Property
CacheResult Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReadFromSnapshot As Boolean
C#
public bool ReadFromSnapshot { get; }
Visual C++
public:
property bool ReadFromSnapshot {
    bool get ();
}

See Also

CacheResult Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DatabaseObjectExtensions Class

[image]

SQL Data Compare API 12.0.40
DatabaseObjectExtensions Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DatabaseObjectExtensions
C#
public static class DatabaseObjectExtensions
Visual C++
public ref class DatabaseObjectExtensions abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.DatabaseObjectExtensions

See Also

DatabaseObjectExtensions Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DatabaseObjectExtensions Members

[image] [image]

SQL Data Compare API 12.0.40
DatabaseObjectExtensions Members
DatabaseObjectExtensions Class Methods See Also

The DatabaseObjectExtensions type exposes the following members.

Methods

Name | Description
HasOwner |

See Also

DatabaseObjectExtensions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DatabaseObjectExtensions Methods

[image] [image]

SQL Data Compare API 12.0.40
DatabaseObjectExtensions Methods
DatabaseObjectExtensions Class See Also

The DatabaseObjectExtensions type exposes the following methods.

Methods

Name | Description
HasOwner |

See Also

DatabaseObjectExtensions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


HasOwner Method

[image]

SQL Data Compare API 12.0.40
DatabaseObjectExtensions..::.HasOwner Method
DatabaseObjectExtensions Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function HasOwner ( _
    obj As IDatabaseObject _
) As Boolean
C#
public static bool HasOwner(
    IDatabaseObject obj
)
Visual C++
public:
static bool HasOwner(
    IDatabaseObject^ obj
)

Parameters

obj
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject

See Also

DatabaseObjectExtensions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DatabaseObjectProperty Class

[image]

SQL Data Compare API 12.0.40
DatabaseObjectProperty Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class DatabaseObjectProperty
C#
public class DatabaseObjectProperty
Visual C++
public ref class DatabaseObjectProperty

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.DatabaseObjectProperty

See Also

DatabaseObjectProperty Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DatabaseObjectProperty Members

[image] [image]

SQL Data Compare API 12.0.40
DatabaseObjectProperty Members
DatabaseObjectProperty Class Constructors Methods Properties See Also

The DatabaseObjectProperty type exposes the following members.

Constructors

Name | Description
DatabaseObjectProperty |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromXml |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetNullableBoolValue |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteXml |

Properties

Name | Description
AnsiNulls |
Name |
QuotedIdentifier |

See Also

DatabaseObjectProperty Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DatabaseObjectProperty Constructor

[image]

SQL Data Compare API 12.0.40
DatabaseObjectProperty Constructor
DatabaseObjectProperty Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    ansiNulls As Nullable(Of Boolean), _
    quotedIdentifier As Nullable(Of Boolean) _
)
C#
public DatabaseObjectProperty(
    string name,
    Nullable<bool> ansiNulls,
    Nullable<bool> quotedIdentifier
)
Visual C++
public:
DatabaseObjectProperty(
    String^ name,
    Nullable<bool> ansiNulls,
    Nullable<bool> quotedIdentifier
)

Parameters

name
Type: String
ansiNulls
Type: Nullable<(Of <(Boolean>)>)
quotedIdentifier
Type: Nullable<(Of <(Boolean>)>)

See Also

DatabaseObjectProperty Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DatabaseObjectProperty Methods

[image] [image]

SQL Data Compare API 12.0.40
DatabaseObjectProperty Methods
DatabaseObjectProperty Class See Also

The DatabaseObjectProperty type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromXml |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetNullableBoolValue |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteXml |

See Also

DatabaseObjectProperty Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FromXml Method

[image]

SQL Data Compare API 12.0.40
DatabaseObjectProperty..::.FromXml Method
DatabaseObjectProperty Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FromXml ( _
    objectsRoot As XmlNode _
) As IDictionary(Of String, DatabaseObjectProperty)
C#
public static IDictionary<string, DatabaseObjectProperty> FromXml(
    XmlNode objectsRoot
)
Visual C++
public:
static IDictionary<String^, DatabaseObjectProperty^>^ FromXml(
    XmlNode^ objectsRoot
)

Parameters

objectsRoot
Type: XmlNode

Remarks

Handles nulls, never returns null.

See Also

DatabaseObjectProperty Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


GetNullableBoolValue Method

[image]

SQL Data Compare API 12.0.40
DatabaseObjectProperty..::.GetNullableBoolValue Method
DatabaseObjectProperty Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetNullableBoolValue ( _
    node As XmlNode, _
    attributeName As String _
) As Nullable(Of Boolean)
C#
public static Nullable<bool> GetNullableBoolValue(
    XmlNode node,
    string attributeName
)
Visual C++
public:
static Nullable<bool> GetNullableBoolValue(
    XmlNode^ node,
    String^ attributeName
)

Parameters

node
Type: XmlNode
attributeName
Type: String

See Also

DatabaseObjectProperty Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


WriteXml Method

[image]

SQL Data Compare API 12.0.40
DatabaseObjectProperty..::.WriteXml Method
DatabaseObjectProperty Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteXml ( _
    xmlStringBuilder As DataPreservingXmlStringBuilder _
)
C#
public void WriteXml(
    DataPreservingXmlStringBuilder xmlStringBuilder
)
Visual C++
public:
void WriteXml(
    DataPreservingXmlStringBuilder^ xmlStringBuilder
)

Parameters

xmlStringBuilder
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.DataPreservingXmlStringBuilder

See Also

DatabaseObjectProperty Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DatabaseObjectProperty Properties

[image] [image]

SQL Data Compare API 12.0.40
DatabaseObjectProperty Properties
DatabaseObjectProperty Class See Also

The DatabaseObjectProperty type exposes the following properties.

Properties

Name | Description
AnsiNulls |
Name |
QuotedIdentifier |

See Also

DatabaseObjectProperty Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


AnsiNulls Property

[image]

SQL Data Compare API 12.0.40
DatabaseObjectProperty..::.AnsiNulls Property
DatabaseObjectProperty Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AnsiNulls As Nullable(Of Boolean)
C#
public Nullable<bool> AnsiNulls { get; private set; }
Visual C++
public:
property Nullable<bool> AnsiNulls {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

See Also

DatabaseObjectProperty Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
DatabaseObjectProperty..::.Name Property
DatabaseObjectProperty Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; private set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

DatabaseObjectProperty Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


QuotedIdentifier Property

[image]

SQL Data Compare API 12.0.40
DatabaseObjectProperty..::.QuotedIdentifier Property
DatabaseObjectProperty Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property QuotedIdentifier As Nullable(Of Boolean)
C#
public Nullable<bool> QuotedIdentifier { get; private set; }
Visual C++
public:
property Nullable<bool> QuotedIdentifier {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

See Also

DatabaseObjectProperty Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DataPreservingXmlStringBuilder Class

[image]

SQL Data Compare API 12.0.40
DataPreservingXmlStringBuilder Class
Members See Also

Takes an existing document and adds merges in data written to it.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class DataPreservingXmlStringBuilder
C#
public class DataPreservingXmlStringBuilder
Visual C++
public ref class DataPreservingXmlStringBuilder

Remarks

Works similarly to a normal XmlWriter, except in the case of writing lists (i.e. any two same typed nodes in the same scope). See WriteListStartElement for more details.

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.DataPreservingXmlStringBuilder

See Also

DataPreservingXmlStringBuilder Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DataPreservingXmlStringBuilder Members

[image] [image]

SQL Data Compare API 12.0.40
DataPreservingXmlStringBuilder Members
DataPreservingXmlStringBuilder Class Constructors Methods See Also

The DataPreservingXmlStringBuilder type exposes the following members.

Constructors

Name | Description
DataPreservingXmlStringBuilder |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlString |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SaveTo | Save the Xml string built.
ToString | Returns unformatted Xml string built. (Overrides Object..::.ToString()()().)
WriteAttributeString | Overloaded.
WriteEndElement |
WriteListEndElement |
WriteListStartElement | Removes any existing nodes of the given name. All elements within the list will be set not to replace each other even if they have the same element name.
WriteStartElement | Ensure a start element called nodeName exists as a child of the current node. Replaces a node of existing name if it is not within a list (see WriteListStartElement).
WriteStartElementInner | Ensure a start element called nodeName exists as a child of the current node. Replaces a node of existing name if it is not within a list (see WriteListStartElement)
WriteValue |

See Also

DataPreservingXmlStringBuilder Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DataPreservingXmlStringBuilder Constructor

[image]

SQL Data Compare API 12.0.40
DataPreservingXmlStringBuilder Constructor
DataPreservingXmlStringBuilder Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    persistedXml As XmlDocument _
)
C#
public DataPreservingXmlStringBuilder(
    XmlDocument persistedXml
)
Visual C++
public:
DataPreservingXmlStringBuilder(
    XmlDocument^ persistedXml
)

Parameters

persistedXml
Type: XmlDocument
Will be mutated to match the new document.

See Also

DataPreservingXmlStringBuilder Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DataPreservingXmlStringBuilder Methods

[image] [image]

SQL Data Compare API 12.0.40
DataPreservingXmlStringBuilder Methods
DataPreservingXmlStringBuilder Class See Also

The DataPreservingXmlStringBuilder type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlString |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SaveTo | Save the Xml string built.
ToString | Returns unformatted Xml string built. (Overrides Object..::.ToString()()().)
WriteAttributeString | Overloaded.
WriteEndElement |
WriteListEndElement |
WriteListStartElement | Removes any existing nodes of the given name. All elements within the list will be set not to replace each other even if they have the same element name.
WriteStartElement | Ensure a start element called nodeName exists as a child of the current node. Replaces a node of existing name if it is not within a list (see WriteListStartElement).
WriteStartElementInner | Ensure a start element called nodeName exists as a child of the current node. Replaces a node of existing name if it is not within a list (see WriteListStartElement)
WriteValue |

See Also

DataPreservingXmlStringBuilder Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


GetXmlString Method

[image]

SQL Data Compare API 12.0.40
DataPreservingXmlStringBuilder..::.GetXmlString Method
DataPreservingXmlStringBuilder Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetXmlString As String
C#
public string GetXmlString()
Visual C++
public:
String^ GetXmlString()

See Also

DataPreservingXmlStringBuilder Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


SaveTo Method

[image]

SQL Data Compare API 12.0.40
DataPreservingXmlStringBuilder..::.SaveTo Method
DataPreservingXmlStringBuilder Class See Also

Save the Xml string built.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveTo ( _
    writer As XmlWriter _
)
C#
public void SaveTo(
    XmlWriter writer
)
Visual C++
public:
void SaveTo(
    XmlWriter^ writer
)

Parameters

writer
Type: XmlWriter

Return Value

See Also

DataPreservingXmlStringBuilder Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
DataPreservingXmlStringBuilder..::.ToString Method
DataPreservingXmlStringBuilder Class See Also

Returns unformatted Xml string built.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

Return Value

See Also

DataPreservingXmlStringBuilder Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


WriteAttributeString Method

[image] [image]

SQL Data Compare API 12.0.40
DataPreservingXmlStringBuilder..::.WriteAttributeString Method
DataPreservingXmlStringBuilder Class See Also

Overload List

Name | Description
WriteAttributeString(String, String) |
WriteAttributeString(String, String, Func<(Of <(String, String, String>)>)) |

See Also

DataPreservingXmlStringBuilder Class
DataPreservingXmlStringBuilder Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


WriteAttributeString Method (, )

[image]

SQL Data Compare API 12.0.40
DataPreservingXmlStringBuilder..::.WriteAttributeString Method (, )
DataPreservingXmlStringBuilder Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteAttributeString ( _
    attributeName As String, _
    attributeValue As String _
)
C#
public void WriteAttributeString(
    string attributeName,
    string attributeValue
)
Visual C++
public:
void WriteAttributeString(
    String^ attributeName,
    String^ attributeValue
)

Parameters

attributeName
Type: String
attributeValue
Type: String

See Also

DataPreservingXmlStringBuilder Class
WriteAttributeString Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


WriteAttributeString Method (, , (, , ))

[image]

SQL Data Compare API 12.0.40
DataPreservingXmlStringBuilder..::.WriteAttributeString Method (, , <(Of <(, , >)>))
DataPreservingXmlStringBuilder Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteAttributeString ( _
    attributeName As String, _
    attributeValue As String, _
    valueToUse As Func(Of String, String, String) _
)
C#
public void WriteAttributeString(
    string attributeName,
    string attributeValue,
    Func<string, string, string> valueToUse
)
Visual C++
public:
void WriteAttributeString(
    String^ attributeName,
    String^ attributeValue,
    Func<String^, String^, String^>^ valueToUse
)

Parameters

attributeName
Type: String
attributeValue
Type: String
valueToUse
Type: Func<(Of <(String, String, String>)>)

See Also

DataPreservingXmlStringBuilder Class
WriteAttributeString Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


WriteEndElement Method

[image]

SQL Data Compare API 12.0.40
DataPreservingXmlStringBuilder..::.WriteEndElement Method
DataPreservingXmlStringBuilder Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteEndElement
C#
public void WriteEndElement()
Visual C++
public:
void WriteEndElement()

See Also

DataPreservingXmlStringBuilder Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


WriteListEndElement Method

[image]

SQL Data Compare API 12.0.40
DataPreservingXmlStringBuilder..::.WriteListEndElement Method
DataPreservingXmlStringBuilder Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteListEndElement
C#
public void WriteListEndElement()
Visual C++
public:
void WriteListEndElement()

See Also

DataPreservingXmlStringBuilder Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


WriteListStartElement Method

[image]

SQL Data Compare API 12.0.40
DataPreservingXmlStringBuilder..::.WriteListStartElement Method
DataPreservingXmlStringBuilder Class See Also

Removes any existing nodes of the given name. All elements within the list will be set not to replace each other even if they have the same element name.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteListStartElement ( _
    nodeName As String _
)
C#
public void WriteListStartElement(
    string nodeName
)
Visual C++
public:
void WriteListStartElement(
    String^ nodeName
)

Parameters

nodeName
Type: String
Name of the started element

Remarks

Lists cannot be nested in this implementation.

See Also

DataPreservingXmlStringBuilder Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


WriteStartElement Method

[image]

SQL Data Compare API 12.0.40
DataPreservingXmlStringBuilder..::.WriteStartElement Method
DataPreservingXmlStringBuilder Class See Also

Ensure a start element called nodeName exists as a child of the current node. Replaces a node of existing name if it is not within a list (see WriteListStartElement).

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteStartElement ( _
    nodeName As String _
)
C#
public void WriteStartElement(
    string nodeName
)
Visual C++
public:
void WriteStartElement(
    String^ nodeName
)

Parameters

nodeName
Type: String

See Also

DataPreservingXmlStringBuilder Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


WriteStartElementInner Method

[image]

SQL Data Compare API 12.0.40
DataPreservingXmlStringBuilder..::.WriteStartElementInner Method
DataPreservingXmlStringBuilder Class See Also

Ensure a start element called nodeName exists as a child of the current node. Replaces a node of existing name if it is not within a list (see WriteListStartElement)

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub WriteStartElementInner ( _
    nodeName As String, _
    replaceExistingData As Boolean, _
    removeExistingData As Boolean _
)
C#
protected void WriteStartElementInner(
    string nodeName,
    bool replaceExistingData,
    bool removeExistingData
)
Visual C++
protected:
void WriteStartElementInner(
    String^ nodeName,
    bool replaceExistingData,
    bool removeExistingData
)

Parameters

nodeName
Type: String
The name of the element.
replaceExistingData
Type: Boolean
If true, the first existing child called nodeName will become the current element. If there is no such element, a new one will be created.
removeExistingData
Type: Boolean
If true, any existing child elements called nodeName will be removed.

See Also

DataPreservingXmlStringBuilder Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


WriteValue Method

[image]

SQL Data Compare API 12.0.40
DataPreservingXmlStringBuilder..::.WriteValue Method
DataPreservingXmlStringBuilder Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteValue ( _
    stringValue As Object _
)
C#
public void WriteValue(
    Object stringValue
)
Visual C++
public:
void WriteValue(
    Object^ stringValue
)

Parameters

stringValue
Type: Object

See Also

DataPreservingXmlStringBuilder Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ErrorsOccurredDuringScriptFileParsingException Class

[image]

SQL Data Compare API 12.0.40
ErrorsOccurredDuringScriptFileParsingException Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ErrorsOccurredDuringScriptFileParsingException _
    Inherits SqlCompareException
C#
public class ErrorsOccurredDuringScriptFileParsingException : SqlCompareException
Visual C++
public ref class ErrorsOccurredDuringScriptFileParsingException : public SqlCompareException

Inheritance Hierarchy

Object
Exception
RedGate.SQLCompare.Engine..::.SqlCompareException
RedGate.SQLCompare.Engine.ReadFromFolder..::.ErrorsOccurredDuringScriptFileParsingException

See Also

ErrorsOccurredDuringScriptFileParsingException Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ErrorsOccurredDuringScriptFileParsingException Members

[image] [image]

SQL Data Compare API 12.0.40
ErrorsOccurredDuringScriptFileParsingException Members
ErrorsOccurredDuringScriptFileParsingException Class Constructors Methods Properties See Also

The ErrorsOccurredDuringScriptFileParsingException type exposes the following members.

Constructors

Name | Description
ErrorsOccurredDuringScriptFileParsingException |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
ErrorColumn |
ErrorLine |
ErrorText |
FileName |
HaveDetailedErrorInfo |
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ErrorsOccurredDuringScriptFileParsingException Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ErrorsOccurredDuringScriptFileParsingException Constructor

[image]

SQL Data Compare API 12.0.40
ErrorsOccurredDuringScriptFileParsingException Constructor
ErrorsOccurredDuringScriptFileParsingException Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected ErrorsOccurredDuringScriptFileParsingException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
ErrorsOccurredDuringScriptFileParsingException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: SerializationInfo
context
Type: StreamingContext

See Also

ErrorsOccurredDuringScriptFileParsingException Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ErrorsOccurredDuringScriptFileParsingException Properties

[image] [image]

SQL Data Compare API 12.0.40
ErrorsOccurredDuringScriptFileParsingException Properties
ErrorsOccurredDuringScriptFileParsingException Class See Also

The ErrorsOccurredDuringScriptFileParsingException type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
ErrorColumn |
ErrorLine |
ErrorText |
FileName |
HaveDetailedErrorInfo |
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ErrorsOccurredDuringScriptFileParsingException Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ErrorColumn Property

[image]

SQL Data Compare API 12.0.40
ErrorsOccurredDuringScriptFileParsingException..::.ErrorColumn Property
ErrorsOccurredDuringScriptFileParsingException Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ErrorColumn As Integer
C#
public int ErrorColumn { get; }
Visual C++
public:
property int ErrorColumn {
    int get ();
}

See Also

ErrorsOccurredDuringScriptFileParsingException Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ErrorLine Property

[image]

SQL Data Compare API 12.0.40
ErrorsOccurredDuringScriptFileParsingException..::.ErrorLine Property
ErrorsOccurredDuringScriptFileParsingException Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ErrorLine As Integer
C#
public int ErrorLine { get; }
Visual C++
public:
property int ErrorLine {
    int get ();
}

See Also

ErrorsOccurredDuringScriptFileParsingException Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ErrorText Property

[image]

SQL Data Compare API 12.0.40
ErrorsOccurredDuringScriptFileParsingException..::.ErrorText Property
ErrorsOccurredDuringScriptFileParsingException Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ErrorText As String
C#
public string ErrorText { get; }
Visual C++
public:
property String^ ErrorText {
    String^ get ();
}

See Also

ErrorsOccurredDuringScriptFileParsingException Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FileName Property

[image]

SQL Data Compare API 12.0.40
ErrorsOccurredDuringScriptFileParsingException..::.FileName Property
ErrorsOccurredDuringScriptFileParsingException Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FileName As String
C#
public string FileName { get; }
Visual C++
public:
property String^ FileName {
    String^ get ();
}

See Also

ErrorsOccurredDuringScriptFileParsingException Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


HaveDetailedErrorInfo Property

[image]

SQL Data Compare API 12.0.40
ErrorsOccurredDuringScriptFileParsingException..::.HaveDetailedErrorInfo Property
ErrorsOccurredDuringScriptFileParsingException Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HaveDetailedErrorInfo As Boolean
C#
public bool HaveDetailedErrorInfo { get; }
Visual C++
public:
property bool HaveDetailedErrorInfo {
    bool get ();
}

See Also

ErrorsOccurredDuringScriptFileParsingException Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FolderDataSource Class

[image]

SQL Data Compare API 12.0.40
FolderDataSource Class
Members See Also

Representation of a data source that will take its data from a series of scripts in a folder.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class FolderDataSource _
    Inherits DataSource _
    Implements IVersionedDatasource
C#
[SerializableAttribute]
public sealed class FolderDataSource : DataSource, IVersionedDatasource
Visual C++
[SerializableAttribute]
public ref class FolderDataSource sealed : public DataSource,
    IVersionedDatasource

Inheritance Hierarchy

Object
RedGate.Shared.SQL..::.DataSource
RedGate.SQLCompare.Engine.ReadFromFolder..::.FolderDataSource

See Also

FolderDataSource Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FolderDataSource Members

[image] [image]

SQL Data Compare API 12.0.40
FolderDataSource Members
FolderDataSource Class Constructors Methods Properties Explicit Interface Implementations See Also

The FolderDataSource type exposes the following members.

Constructors

Name | Description
FolderDataSource | Overloaded.

Methods

Name | Description
Clone | Clones the data source. (Overrides DataSource ..::. Clone()()().)
Deserialize | Deserializes this data source. Note that the database information settings are serialized with the data source. (Overrides DataSource ..::. Deserialize(Int32, ISerializeFormatter).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FixUpFolderLocations |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDifferentSource | Compares the data source with a specified data source. (Overrides DataSource ..::.IsDifferentSource(IDataSource).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshFromPath | Refreshes the database information for this folder, and sets the Errors property.
Serialize | Serializes this data source. Note that the database information settings are serialized with the data source. (Overrides DataSource ..::. Serialize(ISerializeFormatter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DatabaseInformation | Extra information that would normally be stored in the database that needs to be retrieved from an alternative source. The preferred method is the SqlCompareDatabaseInfo.xml script stored in the folder.
DatabaseName | Gets or sets the name of the SQL Server database. (Overrides DataSource ..::. DatabaseName.)
Errors | Returns the errors that occurred last time the database metadata for this data source was loaded.
IsValid | (Overrides DataSource ..::. IsValid.)
IsWriteable | The data source can be written to. (Overrides DataSource ..::. IsWriteable.)
MigrationsFolderLocation |
MigrationsFolderLocationXml |
Path | The path for the folder to be used as the source for the scripts making up this data source.
ScriptFolderLocation |
ScriptFolderLocationXml |
ServerName | Gets or sets the name of the SQL Server. (Overrides DataSource ..::. ServerName.)
SpecificVersion |
Version | Gets the current serialized version number of the snapshot. (Overrides DataSource ..::. Version.)
VersionType |

Explicit Interface Implementations

Name | Description
ICloneableClone | (Inherited from DataSource.)

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FolderDataSource Constructor

[image] [image]

SQL Data Compare API 12.0.40
FolderDataSource Constructor
FolderDataSource Class See Also

Overload List

Name | Description
FolderDataSource()()() | Constructs this object with an empty path for the folder.
FolderDataSource(String) | Constructs this object using the specified folder. If a SqlCompareDatabaseInfo.xml file exists in the specified directory, then this will be parsed to fill in the values in the Information object.
FolderDataSource(ScriptDatabaseInformation) | Constructs this object with an empty path for the folder and specific settings for the folder information.
FolderDataSource(String, ScriptDatabaseInformation) | Constructs a data source that will read from a specific folder, and optionally override the server information.

See Also

FolderDataSource Class
FolderDataSource Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FolderDataSource Constructor

[image]

SQL Data Compare API 12.0.40
FolderDataSource Constructor
FolderDataSource Class See Also

Constructs this object with an empty path for the folder.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FolderDataSource()
Visual C++
public:
FolderDataSource()

See Also

FolderDataSource Class
FolderDataSource Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FolderDataSource Constructor ()

[image]

SQL Data Compare API 12.0.40
FolderDataSource Constructor ()
FolderDataSource Class See Also

Constructs this object using the specified folder. If a SqlCompareDatabaseInfo.xml file exists in the specified directory, then this will be parsed to fill in the values in the Information object.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    folder As String _
)
C#
public FolderDataSource(
    string folder
)
Visual C++
public:
FolderDataSource(
    String^ folder
)

Parameters

folder
Type: String
The folder to construct this datasource from

See Also

FolderDataSource Class
FolderDataSource Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FolderDataSource Constructor (ScriptDatabaseInformation)

[image]

SQL Data Compare API 12.0.40
FolderDataSource Constructor (ScriptDatabaseInformation)
FolderDataSource Class See Also

Constructs this object with an empty path for the folder and specific settings for the folder information.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    information As ScriptDatabaseInformation _
)
C#
public FolderDataSource(
    ScriptDatabaseInformation information
)
Visual C++
public:
FolderDataSource(
    ScriptDatabaseInformation^ information
)

Parameters

information
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
The database information. This should not be null.

See Also

FolderDataSource Class
FolderDataSource Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FolderDataSource Constructor (, ScriptDatabaseInformation)

[image]

SQL Data Compare API 12.0.40
FolderDataSource Constructor (, ScriptDatabaseInformation)
FolderDataSource Class See Also

Constructs a data source that will read from a specific folder, and optionally override the server information.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    folder As String, _
    information As ScriptDatabaseInformation _
)
C#
public FolderDataSource(
    string folder,
    ScriptDatabaseInformation information
)
Visual C++
public:
FolderDataSource(
    String^ folder,
    ScriptDatabaseInformation^ information
)

Parameters

folder
Type: String
The folder to read scripts from
information
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
The database information. If null, then the script directory will be checked for a settings XML file.

See Also

FolderDataSource Class
FolderDataSource Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FolderDataSource Methods

[image] [image]

SQL Data Compare API 12.0.40
FolderDataSource Methods
FolderDataSource Class See Also

The FolderDataSource type exposes the following methods.

Methods

Name | Description
Clone | Clones the data source. (Overrides DataSource ..::. Clone()()().)
Deserialize | Deserializes this data source. Note that the database information settings are serialized with the data source. (Overrides DataSource ..::. Deserialize(Int32, ISerializeFormatter).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FixUpFolderLocations |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDifferentSource | Compares the data source with a specified data source. (Overrides DataSource ..::.IsDifferentSource(IDataSource).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshFromPath | Refreshes the database information for this folder, and sets the Errors property.
Serialize | Serializes this data source. Note that the database information settings are serialized with the data source. (Overrides DataSource ..::. Serialize(ISerializeFormatter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICloneableClone | (Inherited from DataSource.)

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
FolderDataSource..::.Clone Method
FolderDataSource Class See Also

Clones the data source.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone As IDataSource
C#
public override IDataSource Clone()
Visual C++
public:
virtual IDataSource^ Clone() override

Implements

IVersionedDatasource..::.Clone()()()
IDataSource..::.Clone()()()

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Deserialize Method

[image]

SQL Data Compare API 12.0.40
FolderDataSource..::.Deserialize Method
FolderDataSource Class See Also

Deserializes this data source. Note that the database information settings are serialized with the data source.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Deserialize ( _
    versionId As Integer, _
    formatter As ISerializeFormatter _
) As Boolean
C#
public override bool Deserialize(
    int versionId,
    ISerializeFormatter formatter
)
Visual C++
public:
virtual bool Deserialize(
    int versionId,
    ISerializeFormatter^ formatter
) override

Parameters

versionId
Type: Int32
formatter
Type: ISerializeFormatter

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FixUpFolderLocations Method

[image]

SQL Data Compare API 12.0.40
FolderDataSource..::.FixUpFolderLocations Method
FolderDataSource Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub FixUpFolderLocations ( _
    locationProvider As ISOCCompareLocationProvider _
)
C#
public void FixUpFolderLocations(
    ISOCCompareLocationProvider locationProvider
)
Visual C++
public:
void FixUpFolderLocations(
    ISOCCompareLocationProvider^ locationProvider
)

Parameters

locationProvider
Type: RedGate.SQLCompare.Engine.Migrations..::.ISOCCompareLocationProvider

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


IsDifferentSource Method

[image]

SQL Data Compare API 12.0.40
FolderDataSource..::.IsDifferentSource Method
FolderDataSource Class See Also

Compares the data source with a specified data source.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsDifferentSource ( _
    newDataSource As IDataSource _
) As Boolean
C#
public override bool IsDifferentSource(
    IDataSource newDataSource
)
Visual C++
public:
virtual bool IsDifferentSource(
    IDataSource^ newDataSource
) override

Parameters

newDataSource
Type: RedGate.Shared.SQL..::.IDataSource
The data source to compare.

Return Value

true if the data sources are different.

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


RefreshFromPath Method

[image]

SQL Data Compare API 12.0.40
FolderDataSource..::.RefreshFromPath Method
FolderDataSource Class See Also

Refreshes the database information for this folder, and sets the Errors property.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub RefreshFromPath
C#
public void RefreshFromPath()
Visual C++
public:
void RefreshFromPath()

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Serialize Method

[image]

SQL Data Compare API 12.0.40
FolderDataSource..::.Serialize Method
FolderDataSource Class See Also

Serializes this data source. Note that the database information settings are serialized with the data source.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    formatter As ISerializeFormatter _
)
C#
public override void Serialize(
    ISerializeFormatter formatter
)
Visual C++
public:
virtual void Serialize(
    ISerializeFormatter^ formatter
) override

Parameters

formatter
Type: ISerializeFormatter

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FolderDataSource Properties

[image] [image]

SQL Data Compare API 12.0.40
FolderDataSource Properties
FolderDataSource Class See Also

The FolderDataSource type exposes the following properties.

Properties

Name | Description
DatabaseInformation | Extra information that would normally be stored in the database that needs to be retrieved from an alternative source. The preferred method is the SqlCompareDatabaseInfo.xml script stored in the folder.
DatabaseName | Gets or sets the name of the SQL Server database. (Overrides DataSource ..::. DatabaseName.)
Errors | Returns the errors that occurred last time the database metadata for this data source was loaded.
IsValid | (Overrides DataSource ..::. IsValid.)
IsWriteable | The data source can be written to. (Overrides DataSource ..::. IsWriteable.)
MigrationsFolderLocation |
MigrationsFolderLocationXml |
Path | The path for the folder to be used as the source for the scripts making up this data source.
ScriptFolderLocation |
ScriptFolderLocationXml |
ServerName | Gets or sets the name of the SQL Server. (Overrides DataSource ..::. ServerName.)
SpecificVersion |
Version | Gets the current serialized version number of the snapshot. (Overrides DataSource ..::. Version.)
VersionType |

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DatabaseInformation Property

[image]

SQL Data Compare API 12.0.40
FolderDataSource..::.DatabaseInformation Property
FolderDataSource Class See Also

Extra information that would normally be stored in the database that needs to be retrieved from an alternative source. The preferred method is the SqlCompareDatabaseInfo.xml script stored in the folder.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property DatabaseInformation As ScriptDatabaseInformation
C#
public ScriptDatabaseInformation DatabaseInformation { get; set; }
Visual C++
public:
property ScriptDatabaseInformation^ DatabaseInformation {
    ScriptDatabaseInformation^ get ();
    void set (ScriptDatabaseInformation^ value);
}

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DatabaseName Property

[image]

SQL Data Compare API 12.0.40
FolderDataSource..::.DatabaseName Property
FolderDataSource Class See Also

Gets or sets the name of the SQL Server database.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property DatabaseName As String
C#
public override string DatabaseName { get; set; }
Visual C++
public:
virtual property String^ DatabaseName {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IDataSource..::.DatabaseName

Remarks

Scripts folders are not associated with any SQL Server, so this value is not meaningful. By default it is derived from the path name.

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Errors Property

[image]

SQL Data Compare API 12.0.40
FolderDataSource..::.Errors Property
FolderDataSource Class See Also

Returns the errors that occurred last time the database metadata for this data source was loaded.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property Errors As FolderInformationErrors
C#
public FolderInformationErrors Errors { get; set; }
Visual C++
public:
property FolderInformationErrors Errors {
    FolderInformationErrors get ();
    void set (FolderInformationErrors value);
}

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


IsValid Property

[image]

SQL Data Compare API 12.0.40
FolderDataSource..::.IsValid Property
FolderDataSource Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsValid As Boolean
C#
public override bool IsValid { get; }
Visual C++
public:
virtual property bool IsValid {
    bool get () override;
}

Implements

IDataSource..::.IsValid

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


IsWriteable Property

[image]

SQL Data Compare API 12.0.40
FolderDataSource..::.IsWriteable Property
FolderDataSource Class See Also

The data source can be written to.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsWriteable As Boolean
C#
public override bool IsWriteable { get; }
Visual C++
public:
virtual property bool IsWriteable {
    bool get () override;
}

Implements

IDataSource..::.IsWriteable

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


MigrationsFolderLocation Property

[image]

SQL Data Compare API 12.0.40
FolderDataSource..::.MigrationsFolderLocation Property
FolderDataSource Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property MigrationsFolderLocation As ISOCCompareLocation
C#
public ISOCCompareLocation MigrationsFolderLocation { get; set; }
Visual C++
public:
virtual property ISOCCompareLocation^ MigrationsFolderLocation {
    ISOCCompareLocation^ get () sealed;
    void set (ISOCCompareLocation^ value) sealed;
}

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


MigrationsFolderLocationXml Property

[image]

SQL Data Compare API 12.0.40
FolderDataSource..::.MigrationsFolderLocationXml Property
FolderDataSource Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property MigrationsFolderLocationXml As String
C#
public string MigrationsFolderLocationXml { get; set; }
Visual C++
public:
property String^ MigrationsFolderLocationXml {
    String^ get ();
    void set (String^ value);
}

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Path Property

[image]

SQL Data Compare API 12.0.40
FolderDataSource..::.Path Property
FolderDataSource Class See Also

The path for the folder to be used as the source for the scripts making up this data source.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property Path As String
C#
public string Path { get; set; }
Visual C++
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

Remarks

Call RefreshFromPath after setting this value in order to cause this object to update itself with information from the specified path. Refreshing can be a lengthy process if the path refers to a network location.

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptFolderLocation Property

[image]

SQL Data Compare API 12.0.40
FolderDataSource..::.ScriptFolderLocation Property
FolderDataSource Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptFolderLocation As ISOCCompareLocation
C#
public ISOCCompareLocation ScriptFolderLocation { get; set; }
Visual C++
public:
virtual property ISOCCompareLocation^ ScriptFolderLocation {
    ISOCCompareLocation^ get () sealed;
    void set (ISOCCompareLocation^ value) sealed;
}

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptFolderLocationXml Property

[image]

SQL Data Compare API 12.0.40
FolderDataSource..::.ScriptFolderLocationXml Property
FolderDataSource Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptFolderLocationXml As String
C#
public string ScriptFolderLocationXml { get; set; }
Visual C++
public:
property String^ ScriptFolderLocationXml {
    String^ get ();
    void set (String^ value);
}

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ServerName Property

[image]

SQL Data Compare API 12.0.40
FolderDataSource..::.ServerName Property
FolderDataSource Class See Also

Gets or sets the name of the SQL Server.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property ServerName As String
C#
public override string ServerName { get; set; }
Visual C++
public:
virtual property String^ ServerName {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IDataSource..::.ServerName

Remarks

Scripts folders are not associated with any SQL Server, so this value is not meaningful. By default it is 'Scripts', but it can be changed.

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


SpecificVersion Property

[image]

SQL Data Compare API 12.0.40
FolderDataSource..::.SpecificVersion Property
FolderDataSource Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property SpecificVersion As String
C#
public string SpecificVersion { get; set; }
Visual C++
public:
virtual property String^ SpecificVersion {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IVersionedDatasource..::.SpecificVersion

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Version Property

[image]

SQL Data Compare API 12.0.40
FolderDataSource..::.Version Property
FolderDataSource Class See Also

Gets the current serialized version number of the snapshot.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Version As Integer
C#
public override int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () override;
}

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


VersionType Property

[image]

SQL Data Compare API 12.0.40
FolderDataSource..::.VersionType Property
FolderDataSource Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Property VersionType As VersionType
C#
public VersionType VersionType { get; set; }
Visual C++
public:
virtual property VersionType VersionType {
    VersionType get () sealed;
    void set (VersionType value) sealed;
}

Implements

IVersionedDatasource..::.VersionType

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FolderInformationErrors Enumeration

[image]

SQL Data Compare API 12.0.40
FolderInformationErrors Enumeration
See Also

A set of flags indicating warnings and errors that can occur while setting up a read from folder data source

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration FolderInformationErrors
C#
[FlagsAttribute]
public enum FolderInformationErrors
Visual C++
[FlagsAttribute]
public enum class FolderInformationErrors

Members

Member name | Description
OK | Indicates that there are no errors or warnings
Error | Mask of all the possible errors that can occur
PathNotFound | Indicates that the path to the folder could not be found, so the database information file could not be loaded
Unauthorized | Indicates that an unauthorized access exception occurred while trying to load the information file
NotSupported | Indicates that a NotSupportedException occurred while trying to load the information file
IOException | Indicates that an IOException occurred while trying to load the information file
NeedsRefresh | Indicates that RefreshFromPath() needs to be called on this object to make it valid
Warnings | Mask of all the possible warnings that can occur
UnsupportedSqlServerVersion | Indicates that the database information file sets an unsupported SQL server version (so we picked SQL Server 2000 arbitrarily)
DatabaseInformationBadFormat | Indicates that the database information file has a bad format (not XML or malformed XML), so we're using the defaults
DatabaseInformationNotFound | Minor warning: no database information file was found, so we're using the defaults
DatabaseInformationPartialFile | Minor warning: the file was found and loaded, but some settings were missing so the defaults were chosen instead.

Remarks

Note that these flags include both errors and warnings. In order to check only for errors, perform a logical AND with the Error mask.

See Also

RedGate.SQLCompare.Engine.ReadFromFolder Namespace


IObjectLookup Interface

[image]

SQL Data Compare API 12.0.40
IObjectLookup Interface
Members See Also

Interface for looking up object names by their ID and vice versa We have two implementations of this interface: ObjectInformationFromDatabase and ObjectInformationFromDictionary. These two implementations provide slightly different tradeoffs, which work well for script and live registration respectively. ObjectInformationFromDatabase uses the database as the one true source of information. This works better for script folders since objects in the database probably have well-qualified names and are in a consistent state ObjectInformationFromDictionary stores information in a dictionary. This works well for live/backup registration since one of the first things we do is run a DMV query to fetch a big list of object names and IDs. This ends up meaning that live registration is built on the assumption that we can always know the ID of any object name, while script registration processes one file at a time, and so has more post-processing steps to fix up the model after all files have been read.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IObjectLookup
C#
public interface IObjectLookup
Visual C++
public interface class IObjectLookup

See Also

IObjectLookup Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


IObjectLookup Members

[image] [image]

SQL Data Compare API 12.0.40
IObjectLookup Members
IObjectLookup Interface Methods See Also

The IObjectLookup type exposes the following members.

Methods

Name | Description
ContainsName |
GetObjectName |
GetSystemObjectId |
TryGetObjectName |

See Also

IObjectLookup Interface
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


IObjectLookup Methods

[image] [image]

SQL Data Compare API 12.0.40
IObjectLookup Methods
IObjectLookup Interface See Also

The IObjectLookup type exposes the following methods.

Methods

Name | Description
ContainsName |
GetObjectName |
GetSystemObjectId |
TryGetObjectName |

See Also

IObjectLookup Interface
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ContainsName Method

[image]

SQL Data Compare API 12.0.40
IObjectLookup..::.ContainsName Method
IObjectLookup Interface See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function ContainsName ( _
    refName As String _
) As Boolean
C#
bool ContainsName(
    string refName
)
Visual C++
bool ContainsName(
    String^ refName
)

Parameters

refName
Type: String

See Also

IObjectLookup Interface
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


GetObjectName Method

[image]

SQL Data Compare API 12.0.40
IObjectLookup..::.GetObjectName Method
IObjectLookup Interface See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetObjectName ( _
    id As Integer _
) As String
C#
string GetObjectName(
    int id
)
Visual C++
String^ GetObjectName(
    int id
)

Parameters

id
Type: Int32

See Also

IObjectLookup Interface
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


GetSystemObjectId Method

[image]

SQL Data Compare API 12.0.40
IObjectLookup..::.GetSystemObjectId Method
IObjectLookup Interface See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetSystemObjectId ( _
    refName As String _
) As Integer
C#
int GetSystemObjectId(
    string refName
)
Visual C++
int GetSystemObjectId(
    String^ refName
)

Parameters

refName
Type: String

See Also

IObjectLookup Interface
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


TryGetObjectName Method

[image]

SQL Data Compare API 12.0.40
IObjectLookup..::.TryGetObjectName Method
IObjectLookup Interface See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function TryGetObjectName ( _
    id As Integer, _
    <OutAttribute> ByRef name As String _
) As Boolean
C#
bool TryGetObjectName(
    int id,
    out string name
)
Visual C++
bool TryGetObjectName(
    int id,
    [OutAttribute] String^% name
)

Parameters

id
Type: Int32
name
Type: String%

See Also

IObjectLookup Interface
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ITSQLParser Interface

[image]

SQL Data Compare API 12.0.40
ITSQLParser Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITSQLParser
C#
public interface ITSQLParser
Visual C++
public interface class ITSQLParser

See Also

ITSQLParser Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ITSQLParser Members

[image] [image]

SQL Data Compare API 12.0.40
ITSQLParser Members
ITSQLParser Interface Methods See Also

The ITSQLParser type exposes the following members.

Methods

Name | Description
Parse |

See Also

ITSQLParser Interface
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ITSQLParser Methods

[image] [image]

SQL Data Compare API 12.0.40
ITSQLParser Methods
ITSQLParser Interface See Also

The ITSQLParser type exposes the following methods.

Methods

Name | Description
Parse |

See Also

ITSQLParser Interface
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Parse Method

[image]

SQL Data Compare API 12.0.40
ITSQLParser..::.Parse Method
ITSQLParser Interface See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Parse As ParseResult
C#
ParseResult Parse()
Visual C++
ParseResult^ Parse()

See Also

ITSQLParser Interface
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


IUpdateProject Interface

[image]

SQL Data Compare API 12.0.40
IUpdateProject Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IUpdateProject
C#
public interface IUpdateProject
Visual C++
public interface class IUpdateProject

See Also

IUpdateProject Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


IUpdateProject Members

[image] [image]

SQL Data Compare API 12.0.40
IUpdateProject Members
IUpdateProject Interface Methods See Also

The IUpdateProject type exposes the following members.

Methods

Name | Description
Check |
Execute |

See Also

IUpdateProject Interface
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


IUpdateProject Methods

[image] [image]

SQL Data Compare API 12.0.40
IUpdateProject Methods
IUpdateProject Interface See Also

The IUpdateProject type exposes the following methods.

Methods

Name | Description
Check |
Execute |

See Also

IUpdateProject Interface
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Check Method

[image]

SQL Data Compare API 12.0.40
IUpdateProject..::.Check Method
IUpdateProject Interface See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub Check
C#
void Check()
Visual C++
void Check()

See Also

IUpdateProject Interface
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Execute Method

[image]

SQL Data Compare API 12.0.40
IUpdateProject..::.Execute Method
IUpdateProject Interface See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub Execute
C#
void Execute()
Visual C++
void Execute()

See Also

IUpdateProject Interface
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


LazyFileContents Class

[image]

SQL Data Compare API 12.0.40
LazyFileContents Class
Members See Also

Provides an abstraction over a file's contents so that it is not unnecessarily loaded. This is useful in: IO bound tasks (such as registering a scripts folder) since it reduces disk reads. Memory bound tasks (such as registering a scripts folder in a 32-bit process) since it reduces unnecessarily allocations. CPU bound tasks (such as registering a scripts folder with an SSD) since reduced memory pressure means fewer garbage collections.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class LazyFileContents
C#
public class LazyFileContents
Visual C++
public ref class LazyFileContents

Remarks

By forcing access to the string through these methods it should be more obvious in a profiler whether it's worth optimizing this further.

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.LazyFileContents

See Also

LazyFileContents Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


LazyFileContents Members

[image] [image]

SQL Data Compare API 12.0.40
LazyFileContents Members
LazyFileContents Class Constructors Methods Properties See Also

The LazyFileContents type exposes the following members.

Constructors

Name | Description
LazyFileContents | Overloaded.

Methods

Name | Description
CreateTextReader |
EagerlyLoaded |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLineContaining |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Substring |
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
Item |
Length |

See Also

LazyFileContents Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


LazyFileContents Constructor

[image] [image]

SQL Data Compare API 12.0.40
LazyFileContents Constructor
LazyFileContents Class See Also

Overload List

Name | Description
LazyFileContents(String) |
LazyFileContents(FileInfo, Encoding) |

See Also

LazyFileContents Class
LazyFileContents Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


LazyFileContents Constructor ()

[image]

SQL Data Compare API 12.0.40
LazyFileContents Constructor ()
LazyFileContents Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    contents As String _
)
C#
public LazyFileContents(
    string contents
)
Visual C++
public:
LazyFileContents(
    String^ contents
)

Parameters

contents
Type: String

See Also

LazyFileContents Class
LazyFileContents Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


LazyFileContents Constructor (, )

[image]

SQL Data Compare API 12.0.40
LazyFileContents Constructor (, )
LazyFileContents Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    file As FileInfo, _
    encoding As Encoding _
)
C#
public LazyFileContents(
    FileInfo file,
    Encoding encoding
)
Visual C++
public:
LazyFileContents(
    FileInfo^ file,
    Encoding^ encoding
)

Parameters

file
Type: FileInfo
encoding
Type: Encoding

See Also

LazyFileContents Class
LazyFileContents Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


LazyFileContents Methods

[image] [image]

SQL Data Compare API 12.0.40
LazyFileContents Methods
LazyFileContents Class See Also

The LazyFileContents type exposes the following methods.

Methods

Name | Description
CreateTextReader |
EagerlyLoaded |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLineContaining |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Substring |
ToString | (Overrides Object..::.ToString()()().)

See Also

LazyFileContents Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


CreateTextReader Method

[image]

SQL Data Compare API 12.0.40
LazyFileContents..::.CreateTextReader Method
LazyFileContents Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateTextReader As TextReader
C#
public TextReader CreateTextReader()
Visual C++
public:
TextReader^ CreateTextReader()

See Also

LazyFileContents Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


EagerlyLoaded Method

[image]

SQL Data Compare API 12.0.40
LazyFileContents..::.EagerlyLoaded Method
LazyFileContents Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function EagerlyLoaded As LazyFileContents
C#
public LazyFileContents EagerlyLoaded()
Visual C++
public:
LazyFileContents^ EagerlyLoaded()

See Also

LazyFileContents Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


GetLineContaining Method

[image]

SQL Data Compare API 12.0.40
LazyFileContents..::.GetLineContaining Method
LazyFileContents Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLineContaining ( _
    line As Integer, _
    offset As Integer _
) As String
C#
public string GetLineContaining(
    int line,
    int offset
)
Visual C++
public:
String^ GetLineContaining(
    int line,
    int offset
)

Parameters

line
Type: Int32
offset
Type: Int32

See Also

LazyFileContents Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Substring Method

[image]

SQL Data Compare API 12.0.40
LazyFileContents..::.Substring Method
LazyFileContents Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Substring ( _
    start As Integer, _
    length As Integer _
) As String
C#
public string Substring(
    int start,
    int length
)
Visual C++
public:
String^ Substring(
    int start,
    int length
)

Parameters

start
Type: Int32
length
Type: Int32

See Also

LazyFileContents Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
LazyFileContents..::.ToString Method
LazyFileContents Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

See Also

LazyFileContents Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


LazyFileContents Properties

[image] [image]

SQL Data Compare API 12.0.40
LazyFileContents Properties
LazyFileContents Class See Also

The LazyFileContents type exposes the following properties.

Properties

Name | Description
Item |
Length |

See Also

LazyFileContents Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Item Property

[image]

SQL Data Compare API 12.0.40
LazyFileContents..::.Item Property
LazyFileContents Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    characterIndex As Integer _
) As Char
C#
public char this[
    int characterIndex
] { get; }
Visual C++
public:
property wchar_t default[int characterIndex] {
    wchar_t get (int characterIndex);
}

Parameters

characterIndex
Type: Int32

See Also

LazyFileContents Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Length Property

[image]

SQL Data Compare API 12.0.40
LazyFileContents..::.Length Property
LazyFileContents Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Length As Integer
C#
public int Length { get; }
Visual C++
public:
property int Length {
    int get ();
}

See Also

LazyFileContents Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


NullUpdater Class

[image]

SQL Data Compare API 12.0.40
NullUpdater Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class NullUpdater _
    Implements IUpdateProject
C#
public class NullUpdater : IUpdateProject
Visual C++
public ref class NullUpdater : IUpdateProject

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.NullUpdater

See Also

NullUpdater Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


NullUpdater Members

[image] [image]

SQL Data Compare API 12.0.40
NullUpdater Members
NullUpdater Class Methods Fields See Also

The NullUpdater type exposes the following members.

Methods

Name | Description
Check |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Instance |

See Also

NullUpdater Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


NullUpdater Fields

[image] [image]

SQL Data Compare API 12.0.40
NullUpdater Fields
NullUpdater Class See Also

The NullUpdater type exposes the following fields.

Fields

Name | Description
Instance |

See Also

NullUpdater Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Instance Field

[image]

SQL Data Compare API 12.0.40
NullUpdater..::.Instance Field
NullUpdater Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Instance As NullUpdater
C#
public static readonly NullUpdater Instance
Visual C++
public:
static initonly NullUpdater^ Instance

See Also

NullUpdater Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


NullUpdater Methods

[image] [image]

SQL Data Compare API 12.0.40
NullUpdater Methods
NullUpdater Class See Also

The NullUpdater type exposes the following methods.

Methods

Name | Description
Check |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NullUpdater Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Check Method

[image]

SQL Data Compare API 12.0.40
NullUpdater..::.Check Method
NullUpdater Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Check
C#
public void Check()
Visual C++
public:
virtual void Check() sealed

Implements

IUpdateProject..::.Check()()()

See Also

NullUpdater Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Execute Method

[image]

SQL Data Compare API 12.0.40
NullUpdater..::.Execute Method
NullUpdater Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Execute
C#
public void Execute()
Visual C++
public:
virtual void Execute() sealed

Implements

IUpdateProject..::.Execute()()()

See Also

NullUpdater Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ObjectInformationFromDatabase Class

[image]

SQL Data Compare API 12.0.40
ObjectInformationFromDatabase Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ObjectInformationFromDatabase _
    Implements IObjectLookup
C#
public class ObjectInformationFromDatabase : IObjectLookup
Visual C++
public ref class ObjectInformationFromDatabase : IObjectLookup

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.ObjectInformationFromDatabase

See Also

ObjectInformationFromDatabase Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ObjectInformationFromDatabase Members

[image] [image]

SQL Data Compare API 12.0.40
ObjectInformationFromDatabase Members
ObjectInformationFromDatabase Class Constructors Methods See Also

The ObjectInformationFromDatabase type exposes the following members.

Constructors

Name | Description
ObjectInformationFromDatabase |

Methods

Name | Description
ContainsName |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectName |
GetSystemObjectId |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryGetObjectName |

See Also

ObjectInformationFromDatabase Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ObjectInformationFromDatabase Constructor

[image]

SQL Data Compare API 12.0.40
ObjectInformationFromDatabase Constructor
ObjectInformationFromDatabase Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    collections As IEnumerable(Of INonReadOnlyCollection), _
    isCaseSensitive As Boolean _
)
C#
public ObjectInformationFromDatabase(
    IEnumerable<INonReadOnlyCollection> collections,
    bool isCaseSensitive
)
Visual C++
public:
ObjectInformationFromDatabase(
    IEnumerable<INonReadOnlyCollection^>^ collections,
    bool isCaseSensitive
)

Parameters

collections
Type: IEnumerable<(Of <( INonReadOnlyCollection >)>)
isCaseSensitive
Type: Boolean

See Also

ObjectInformationFromDatabase Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ObjectInformationFromDatabase Methods

[image] [image]

SQL Data Compare API 12.0.40
ObjectInformationFromDatabase Methods
ObjectInformationFromDatabase Class See Also

The ObjectInformationFromDatabase type exposes the following methods.

Methods

Name | Description
ContainsName |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectName |
GetSystemObjectId |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryGetObjectName |

See Also

ObjectInformationFromDatabase Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ContainsName Method

[image]

SQL Data Compare API 12.0.40
ObjectInformationFromDatabase..::.ContainsName Method
ObjectInformationFromDatabase Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function ContainsName ( _
    refName As String _
) As Boolean
C#
public bool ContainsName(
    string refName
)
Visual C++
public:
virtual bool ContainsName(
    String^ refName
) sealed

Parameters

refName
Type: String

Implements

IObjectLookup..::.ContainsName(String)

See Also

ObjectInformationFromDatabase Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


GetObjectName Method

[image]

SQL Data Compare API 12.0.40
ObjectInformationFromDatabase..::.GetObjectName Method
ObjectInformationFromDatabase Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetObjectName ( _
    id As Integer _
) As String
C#
public string GetObjectName(
    int id
)
Visual C++
public:
virtual String^ GetObjectName(
    int id
) sealed

Parameters

id
Type: Int32

Implements

IObjectLookup..::.GetObjectName(Int32)

See Also

ObjectInformationFromDatabase Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


GetSystemObjectId Method

[image]

SQL Data Compare API 12.0.40
ObjectInformationFromDatabase..::.GetSystemObjectId Method
ObjectInformationFromDatabase Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSystemObjectId ( _
    refName As String _
) As Integer
C#
public int GetSystemObjectId(
    string refName
)
Visual C++
public:
virtual int GetSystemObjectId(
    String^ refName
) sealed

Parameters

refName
Type: String

Implements

IObjectLookup..::.GetSystemObjectId(String)

See Also

ObjectInformationFromDatabase Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


TryGetObjectName Method

[image]

SQL Data Compare API 12.0.40
ObjectInformationFromDatabase..::.TryGetObjectName Method
ObjectInformationFromDatabase Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function TryGetObjectName ( _
    id As Integer, _
    <OutAttribute> ByRef name As String _
) As Boolean
C#
public bool TryGetObjectName(
    int id,
    out string name
)
Visual C++
public:
virtual bool TryGetObjectName(
    int id,
    [OutAttribute] String^% name
) sealed

Parameters

id
Type: Int32
name
Type: String%

Implements

IObjectLookup..::.TryGetObjectName(Int32, String%)

See Also

ObjectInformationFromDatabase Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ObjectInformationFromDictionary Class

[image]

SQL Data Compare API 12.0.40
ObjectInformationFromDictionary Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ObjectInformationFromDictionary _
    Implements IObjectLookup
C#
public class ObjectInformationFromDictionary : IObjectLookup
Visual C++
public ref class ObjectInformationFromDictionary : IObjectLookup

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.ObjectInformationFromDictionary

See Also

ObjectInformationFromDictionary Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ObjectInformationFromDictionary Members

[image] [image]

SQL Data Compare API 12.0.40
ObjectInformationFromDictionary Members
ObjectInformationFromDictionary Class Constructors Methods See Also

The ObjectInformationFromDictionary type exposes the following members.

Constructors

Name | Description
ObjectInformationFromDictionary |

Methods

Name | Description
AddMapping |
ContainsName |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectName |
GetSystemObjectId |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryGetObjectName |

See Also

ObjectInformationFromDictionary Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ObjectInformationFromDictionary Constructor

[image]

SQL Data Compare API 12.0.40
ObjectInformationFromDictionary Constructor
ObjectInformationFromDictionary Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    isCaseSensitive As Boolean _
)
C#
public ObjectInformationFromDictionary(
    bool isCaseSensitive
)
Visual C++
public:
ObjectInformationFromDictionary(
    bool isCaseSensitive
)

Parameters

isCaseSensitive
Type: Boolean

See Also

ObjectInformationFromDictionary Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ObjectInformationFromDictionary Methods

[image] [image]

SQL Data Compare API 12.0.40
ObjectInformationFromDictionary Methods
ObjectInformationFromDictionary Class See Also

The ObjectInformationFromDictionary type exposes the following methods.

Methods

Name | Description
AddMapping |
ContainsName |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectName |
GetSystemObjectId |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryGetObjectName |

See Also

ObjectInformationFromDictionary Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


AddMapping Method

[image]

SQL Data Compare API 12.0.40
ObjectInformationFromDictionary..::.AddMapping Method
ObjectInformationFromDictionary Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddMapping ( _
    fullyQualifiedName As String, _
    sysobjectID As Integer _
)
C#
public void AddMapping(
    string fullyQualifiedName,
    int sysobjectID
)
Visual C++
public:
void AddMapping(
    String^ fullyQualifiedName,
    int sysobjectID
)

Parameters

fullyQualifiedName
Type: String
sysobjectID
Type: Int32

See Also

ObjectInformationFromDictionary Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ContainsName Method

[image]

SQL Data Compare API 12.0.40
ObjectInformationFromDictionary..::.ContainsName Method
ObjectInformationFromDictionary Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function ContainsName ( _
    refName As String _
) As Boolean
C#
public bool ContainsName(
    string refName
)
Visual C++
public:
virtual bool ContainsName(
    String^ refName
) sealed

Parameters

refName
Type: String

Implements

IObjectLookup..::.ContainsName(String)

See Also

ObjectInformationFromDictionary Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


GetObjectName Method

[image]

SQL Data Compare API 12.0.40
ObjectInformationFromDictionary..::.GetObjectName Method
ObjectInformationFromDictionary Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetObjectName ( _
    id As Integer _
) As String
C#
public string GetObjectName(
    int id
)
Visual C++
public:
virtual String^ GetObjectName(
    int id
) sealed

Parameters

id
Type: Int32

Implements

IObjectLookup..::.GetObjectName(Int32)

See Also

ObjectInformationFromDictionary Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


GetSystemObjectId Method

[image]

SQL Data Compare API 12.0.40
ObjectInformationFromDictionary..::.GetSystemObjectId Method
ObjectInformationFromDictionary Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSystemObjectId ( _
    refName As String _
) As Integer
C#
public int GetSystemObjectId(
    string refName
)
Visual C++
public:
virtual int GetSystemObjectId(
    String^ refName
) sealed

Parameters

refName
Type: String

Implements

IObjectLookup..::.GetSystemObjectId(String)

See Also

ObjectInformationFromDictionary Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


TryGetObjectName Method

[image]

SQL Data Compare API 12.0.40
ObjectInformationFromDictionary..::.TryGetObjectName Method
ObjectInformationFromDictionary Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function TryGetObjectName ( _
    id As Integer, _
    <OutAttribute> ByRef name As String _
) As Boolean
C#
public bool TryGetObjectName(
    int id,
    out string name
)
Visual C++
public:
virtual bool TryGetObjectName(
    int id,
    [OutAttribute] String^% name
) sealed

Parameters

id
Type: Int32
name
Type: String%

Implements

IObjectLookup..::.TryGetObjectName(Int32, String%)

See Also

ObjectInformationFromDictionary Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ParserError Class

[image]

SQL Data Compare API 12.0.40
ParserError Class
Members See Also

Contains an error found in the scripts

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ParserError
C#
public class ParserError
Visual C++
public ref class ParserError

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.ParserError

See Also

ParserError Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ParserError Members

[image] [image]

SQL Data Compare API 12.0.40
ParserError Members
ParserError Class Constructors Methods Properties See Also

The ParserError type exposes the following members.

Constructors

Name | Description
ParserError |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Column | The column on which the error was found
File | The file in which the error occured
Line | The line on which the error was found
Offset | The offset into the file on which the error was found
Text | The offset into the file on which the error was found

See Also

ParserError Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ParserError Constructor

[image]

SQL Data Compare API 12.0.40
ParserError Constructor
ParserError Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ParserError()
Visual C++
public:
ParserError()

See Also

ParserError Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ParserError Properties

[image] [image]

SQL Data Compare API 12.0.40
ParserError Properties
ParserError Class See Also

The ParserError type exposes the following properties.

Properties

Name | Description
Column | The column on which the error was found
File | The file in which the error occured
Line | The line on which the error was found
Offset | The offset into the file on which the error was found
Text | The offset into the file on which the error was found

See Also

ParserError Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Column Property

[image]

SQL Data Compare API 12.0.40
ParserError..::.Column Property
ParserError Class See Also

The column on which the error was found

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Column As Integer
C#
public int Column { get; set; }
Visual C++
public:
property int Column {
    int get ();
    void set (int value);
}

See Also

ParserError Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


File Property

[image]

SQL Data Compare API 12.0.40
ParserError..::.File Property
ParserError Class See Also

The file in which the error occured

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property File As FileInfo
C#
public FileInfo File { get; set; }
Visual C++
public:
property FileInfo^ File {
    FileInfo^ get ();
    void set (FileInfo^ value);
}

See Also

ParserError Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Line Property

[image]

SQL Data Compare API 12.0.40
ParserError..::.Line Property
ParserError Class See Also

The line on which the error was found

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Line As Integer
C#
public int Line { get; set; }
Visual C++
public:
property int Line {
    int get ();
    void set (int value);
}

See Also

ParserError Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Offset Property

[image]

SQL Data Compare API 12.0.40
ParserError..::.Offset Property
ParserError Class See Also

The offset into the file on which the error was found

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Offset As Integer
C#
public int Offset { get; set; }
Visual C++
public:
property int Offset {
    int get ();
    void set (int value);
}

See Also

ParserError Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Text Property

[image]

SQL Data Compare API 12.0.40
ParserError..::.Text Property
ParserError Class See Also

The offset into the file on which the error was found

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text { get; set; }
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

ParserError Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ParseResult Class

[image]

SQL Data Compare API 12.0.40
ParseResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ParseResult
C#
public class ParseResult
Visual C++
public ref class ParseResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.ParseResult

See Also

ParseResult Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ParseResult Members

[image] [image]

SQL Data Compare API 12.0.40
ParseResult Members
ParseResult Class Constructors Methods Properties See Also

The ParseResult type exposes the following members.

Constructors

Name | Description
ParseResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FileContents |
FileInfo |
ParserErrors |
ReadFromCache |
Results |

See Also

ParseResult Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ParseResult Constructor

[image]

SQL Data Compare API 12.0.40
ParseResult Constructor
ParseResult Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ParseResult()
Visual C++
public:
ParseResult()

See Also

ParseResult Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ParseResult Properties

[image] [image]

SQL Data Compare API 12.0.40
ParseResult Properties
ParseResult Class See Also

The ParseResult type exposes the following properties.

Properties

Name | Description
FileContents |
FileInfo |
ParserErrors |
ReadFromCache |
Results |

See Also

ParseResult Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FileContents Property

[image]

SQL Data Compare API 12.0.40
ParseResult..::.FileContents Property
ParseResult Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FileContents As LazyFileContents
C#
public LazyFileContents FileContents { get; set; }
Visual C++
public:
property LazyFileContents^ FileContents {
    LazyFileContents^ get ();
    void set (LazyFileContents^ value);
}

See Also

ParseResult Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FileInfo Property

[image]

SQL Data Compare API 12.0.40
ParseResult..::.FileInfo Property
ParseResult Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FileInfo As FileInfo
C#
public FileInfo FileInfo { get; set; }
Visual C++
public:
property FileInfo^ FileInfo {
    FileInfo^ get ();
    void set (FileInfo^ value);
}

See Also

ParseResult Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ParserErrors Property

[image]

SQL Data Compare API 12.0.40
ParseResult..::.ParserErrors Property
ParseResult Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ParserErrors As IList(Of ParserError)
C#
public IList<ParserError> ParserErrors { get; set; }
Visual C++
public:
property IList<ParserError^>^ ParserErrors {
    IList<ParserError^>^ get ();
    void set (IList<ParserError^>^ value);
}

See Also

ParseResult Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ReadFromCache Property

[image]

SQL Data Compare API 12.0.40
ParseResult..::.ReadFromCache Property
ParseResult Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ReadFromCache As Boolean
C#
public bool ReadFromCache { get; set; }
Visual C++
public:
property bool ReadFromCache {
    bool get ();
    void set (bool value);
}

See Also

ParseResult Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Results Property

[image]

SQL Data Compare API 12.0.40
ParseResult..::.Results Property
ParseResult Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Results As ICollection(Of Element)
C#
public ICollection<Element> Results { get; set; }
Visual C++
public:
property ICollection<Element^>^ Results {
    ICollection<Element^>^ get ();
    void set (ICollection<Element^>^ value);
}

See Also

ParseResult Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ParserMessage Class

[image]

SQL Data Compare API 12.0.40
ParserMessage Class
Members See Also

Represents an informative message generated during parsing.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ParserMessage
C#
public sealed class ParserMessage
Visual C++
public ref class ParserMessage sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.ParserMessage

See Also

ParserMessage Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ParserMessage Members

[image] [image]

SQL Data Compare API 12.0.40
ParserMessage Members
ParserMessage Class Methods Properties See Also

The ParserMessage type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasErrorString | Returns true if the specified ParserMessageType has a non-null ErrorString in it's messages.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ErrorString | The specific text that caused the parser message. Whether a particular message type has an associated string can be determined using HasErrorString(ParserMessageType).
File | The file being parsed at the time.
LineNumber | The line number containing the text that caused the message.
LineText | The line of text in which the error occurred.
Type | The type of parser message.

See Also

ParserMessage Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ParserMessage Methods

[image] [image]

SQL Data Compare API 12.0.40
ParserMessage Methods
ParserMessage Class See Also

The ParserMessage type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasErrorString | Returns true if the specified ParserMessageType has a non-null ErrorString in it's messages.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParserMessage Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


HasErrorString Method

[image]

SQL Data Compare API 12.0.40
ParserMessage..::.HasErrorString Method
ParserMessage Class See Also

Returns true if the specified ParserMessageType has a non-null ErrorString in it's messages.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function HasErrorString ( _
    type As ParserMessageType _
) As Boolean
C#
public static bool HasErrorString(
    ParserMessageType type
)
Visual C++
public:
static bool HasErrorString(
    ParserMessageType type
)

Parameters

type
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ParserMessageType

Return Value

See Also

ParserMessage Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ParserMessage Properties

[image] [image]

SQL Data Compare API 12.0.40
ParserMessage Properties
ParserMessage Class See Also

The ParserMessage type exposes the following properties.

Properties

Name | Description
ErrorString | The specific text that caused the parser message. Whether a particular message type has an associated string can be determined using HasErrorString(ParserMessageType).
File | The file being parsed at the time.
LineNumber | The line number containing the text that caused the message.
LineText | The line of text in which the error occurred.
Type | The type of parser message.

See Also

ParserMessage Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ErrorString Property

[image]

SQL Data Compare API 12.0.40
ParserMessage..::.ErrorString Property
ParserMessage Class See Also

The specific text that caused the parser message. Whether a particular message type has an associated string can be determined using HasErrorString(ParserMessageType).

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ErrorString As String
C#
public string ErrorString { get; }
Visual C++
public:
property String^ ErrorString {
    String^ get ();
}

See Also

ParserMessage Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


File Property

[image]

SQL Data Compare API 12.0.40
ParserMessage..::.File Property
ParserMessage Class See Also

The file being parsed at the time.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property File As FileInfo
C#
public FileInfo File { get; }
Visual C++
public:
property FileInfo^ File {
    FileInfo^ get ();
}

See Also

ParserMessage Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


LineNumber Property

[image]

SQL Data Compare API 12.0.40
ParserMessage..::.LineNumber Property
ParserMessage Class See Also

The line number containing the text that caused the message.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LineNumber As Integer
C#
public int LineNumber { get; }
Visual C++
public:
property int LineNumber {
    int get ();
}

See Also

ParserMessage Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


LineText Property

[image]

SQL Data Compare API 12.0.40
ParserMessage..::.LineText Property
ParserMessage Class See Also

The line of text in which the error occurred.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LineText As String
C#
public string LineText { get; }
Visual C++
public:
property String^ LineText {
    String^ get ();
}

See Also

ParserMessage Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Type Property

[image]

SQL Data Compare API 12.0.40
ParserMessage..::.Type Property
ParserMessage Class See Also

The type of parser message.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As ParserMessageType
C#
public ParserMessageType Type { get; }
Visual C++
public:
property ParserMessageType Type {
    ParserMessageType get ();
}

See Also

ParserMessage Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ParserMessageType Enumeration

[image]

SQL Data Compare API 12.0.40
ParserMessageType Enumeration
See Also

The different types of messages the parser can produce.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration ParserMessageType
C#
public enum ParserMessageType
Visual C++
public enum class ParserMessageType

Members

Member name | Description
InvalidSyntax | Invalid syntax was found; one or more statements were ignored.
IgnoredStatement | A non-schema statement was ignored.
IfClauseTakenAsTrue | An IF clause was assumed to evaluate as true.
ReferenceNotFound | An object referenced by a subsidiary object was not found.

See Also

RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptDatabaseInformation Class

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation Class
Members See Also

Options and settings that control how the creation SQL files are loaded and processed.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class ScriptDatabaseInformation _
    Implements IEquatable(Of ScriptDatabaseInformation)
C#
[SerializableAttribute]
public sealed class ScriptDatabaseInformation : IEquatable<ScriptDatabaseInformation>
Visual C++
[SerializableAttribute]
public ref class ScriptDatabaseInformation sealed : IEquatable<ScriptDatabaseInformation^>

Remarks

When adding a new property to this class you must also add it to the ScriptDatabaseInformationTests.

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation

See Also

ScriptDatabaseInformation Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptDatabaseInformation Members

[image] [image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation Members
ScriptDatabaseInformation Class Constructors Methods Properties See Also

The ScriptDatabaseInformation type exposes the following members.

Constructors

Name | Description
ScriptDatabaseInformation | Constructs a new ScriptDatabaseInformation object. By default it initializes itself with values that represent a SQL Server 2005 database with Latin1_General_CS_AS collation.

Methods

Name | Description
AddDataFileWritten |
ClearDataFiles |
Clone |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetScriptEncodingType | Get the current ScriptEncodingType as a string
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXml | Overloaded.
HasMatchingDatabaseObjectProperties | Determines whether two ScriptDatabaseInformation instances have equal DatabaseObjectProperties
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadFromXml |
SetScriptEncodingType | Set the ScriptEncodingType
TableHasDataFile |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AnsiNulls |
CaseSensitive | Indicates whether the database is case sensitive.
CustomScriptFolder | Folder name where custom scripts can be stored that will be ignored when reading from a directory
DatabaseObjectProperties |
DataFilesWritten |
DBWriteToFileOptions |
DefaultCollation | The default collation for this database.
DefaultFilegroup | Sets or gets the filegroup that should be used if nothing or "DEFAULT" is specified in a creation SQL statement.
DefaultOwner | Sets or gets the default owner for the database objects. In SQL Server 2005 this will set the default schema; in SQL Server 2000 it will set the default user owner.
DefaultUser | Sets or gets the default user that should be used for AUTHORIZATION clauses.
DefinesSetStatements | Set this if this ScriptDatabaseInformation is the definitive source for SET statements for the associated scripts.
HasChanged |
IsAzure | Is this database an Azure database?
MaxDataFileSize |
QuotedIdentifier |
ScriptEncodingType |
ServerVersionNumber |
ShouldOverrideSessionSets | Whether to build the object model based on these set statements
SQLServerDBVersion | Gets or sets the database major version. 8 is for SQL Server 2000. 9 is for SQL Server 2005. 10 is for SQL Server 2008.
TextEncoder |

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptDatabaseInformation Constructor

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation Constructor
ScriptDatabaseInformation Class See Also

Constructs a new ScriptDatabaseInformation object. By default it initializes itself with values that represent a SQL Server 2005 database with Latin1_General_CS_AS collation.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ScriptDatabaseInformation()
Visual C++
public:
ScriptDatabaseInformation()

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptDatabaseInformation Methods

[image] [image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation Methods
ScriptDatabaseInformation Class See Also

The ScriptDatabaseInformation type exposes the following methods.

Methods

Name | Description
AddDataFileWritten |
ClearDataFiles |
Clone |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetScriptEncodingType | Get the current ScriptEncodingType as a string
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXml | Overloaded.
HasMatchingDatabaseObjectProperties | Determines whether two ScriptDatabaseInformation instances have equal DatabaseObjectProperties
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadFromXml |
SetScriptEncodingType | Set the ScriptEncodingType
TableHasDataFile |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


AddDataFileWritten Method

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.AddDataFileWritten Method
ScriptDatabaseInformation Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddDataFileWritten ( _
    fileName As String _
)
C#
public void AddDataFileWritten(
    string fileName
)
Visual C++
public:
void AddDataFileWritten(
    String^ fileName
)

Parameters

fileName
Type: String

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ClearDataFiles Method

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.ClearDataFiles Method
ScriptDatabaseInformation Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub ClearDataFiles
C#
public void ClearDataFiles()
Visual C++
public:
void ClearDataFiles()

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.Clone Method
ScriptDatabaseInformation Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone As ScriptDatabaseInformation
C#
public ScriptDatabaseInformation Clone()
Visual C++
public:
ScriptDatabaseInformation^ Clone()

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.Equals Method
ScriptDatabaseInformation Class See Also

Overload List

Name | Description
Equals(Object) | (Overrides Object..::.Equals(Object).)
Equals(ScriptDatabaseInformation) | Determines whether the two ScriptDatabaseInformation instances are equal.

See Also

ScriptDatabaseInformation Class
ScriptDatabaseInformation Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Equals Method ()

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.Equals Method ()
ScriptDatabaseInformation Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object

See Also

ScriptDatabaseInformation Class
Equals Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Equals Method (ScriptDatabaseInformation)

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.Equals Method (ScriptDatabaseInformation)
ScriptDatabaseInformation Class See Also

Determines whether the two ScriptDatabaseInformation instances are equal.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    other As ScriptDatabaseInformation _
) As Boolean
C#
public bool Equals(
    ScriptDatabaseInformation other
)
Visual C++
public:
virtual bool Equals(
    ScriptDatabaseInformation^ other
) sealed

Parameters

other
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
The ScriptDatabaseInformation to compare with.

Return Value

True if the two instances are equal.

Implements

IEquatableEquals(UTP)

See Also

ScriptDatabaseInformation Class
Equals Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.GetHashCode Method
ScriptDatabaseInformation Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


GetScriptEncodingType Method

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.GetScriptEncodingType Method
ScriptDatabaseInformation Class See Also

Get the current ScriptEncodingType as a string

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetScriptEncodingType As String
C#
public string GetScriptEncodingType()
Visual C++
public:
String^ GetScriptEncodingType()

Return Value

The string representation of the current encoding type

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


GetXml Method

[image] [image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.GetXml Method
ScriptDatabaseInformation Class See Also

Overload List

Name | Description
GetXml()()() | Gets a string containing XML that represents this object.
GetXml(XmlWriter) | Obsolete.

See Also

ScriptDatabaseInformation Class
ScriptDatabaseInformation Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


GetXml Method

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.GetXml Method
ScriptDatabaseInformation Class See Also

Gets a string containing XML that represents this object.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetXml As String
C#
public string GetXml()
Visual C++
public:
String^ GetXml()

Remarks

This method is not thread safe.

See Also

ScriptDatabaseInformation Class
GetXml Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


GetXml Method ()

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.GetXml Method ()
ScriptDatabaseInformation Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Replaced by public string GetXml()")> _
Public Sub GetXml ( _
    xmlWriter As XmlWriter _
)
C#
[ObsoleteAttribute("Replaced by public string GetXml()")]
public void GetXml(
    XmlWriter xmlWriter
)
Visual C++
[ObsoleteAttribute(L"Replaced by public string GetXml()")]
public:
void GetXml(
    XmlWriter^ xmlWriter
)

Parameters

xmlWriter
Type: XmlWriter

See Also

ScriptDatabaseInformation Class
GetXml Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


HasMatchingDatabaseObjectProperties Method

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.HasMatchingDatabaseObjectProperties Method
ScriptDatabaseInformation Class See Also

Determines whether two ScriptDatabaseInformation instances have equal DatabaseObjectProperties

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function HasMatchingDatabaseObjectProperties ( _
    other As ScriptDatabaseInformation _
) As Boolean
C#
public bool HasMatchingDatabaseObjectProperties(
    ScriptDatabaseInformation other
)
Visual C++
public:
bool HasMatchingDatabaseObjectProperties(
    ScriptDatabaseInformation^ other
)

Parameters

other
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
The ScriptDatabaseInformation to compare with.

Return Value

True if the two instances have equal DatabaseObjectProperties.

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ReadFromXml Method

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.ReadFromXml Method
ScriptDatabaseInformation Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ReadFromXml ( _
    doc As XmlDocument, _
    ByRef errors As FolderInformationErrors _
) As ScriptDatabaseInformation
C#
public static ScriptDatabaseInformation ReadFromXml(
    XmlDocument doc,
    ref FolderInformationErrors errors
)
Visual C++
public:
static ScriptDatabaseInformation^ ReadFromXml(
    XmlDocument^ doc,
    FolderInformationErrors% errors
)

Parameters

doc
Type: XmlDocument
errors
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.FolderInformationErrors %

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


SetScriptEncodingType Method

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.SetScriptEncodingType Method
ScriptDatabaseInformation Class See Also

Set the ScriptEncodingType

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetScriptEncodingType ( _
    sct As String _
)
C#
public void SetScriptEncodingType(
    string sct
)
Visual C++
public:
void SetScriptEncodingType(
    String^ sct
)

Parameters

sct
Type: String
A string representing the ScriptEncdingType

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


TableHasDataFile Method

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.TableHasDataFile Method
ScriptDatabaseInformation Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function TableHasDataFile ( _
    table As Table _
) As Boolean
C#
public bool TableHasDataFile(
    Table table
)
Visual C++
public:
bool TableHasDataFile(
    Table^ table
)

Parameters

table
Type: RedGate.SQLCompare.Engine..::.Table

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptDatabaseInformation Properties

[image] [image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation Properties
ScriptDatabaseInformation Class See Also

The ScriptDatabaseInformation type exposes the following properties.

Properties

Name | Description
AnsiNulls |
CaseSensitive | Indicates whether the database is case sensitive.
CustomScriptFolder | Folder name where custom scripts can be stored that will be ignored when reading from a directory
DatabaseObjectProperties |
DataFilesWritten |
DBWriteToFileOptions |
DefaultCollation | The default collation for this database.
DefaultFilegroup | Sets or gets the filegroup that should be used if nothing or "DEFAULT" is specified in a creation SQL statement.
DefaultOwner | Sets or gets the default owner for the database objects. In SQL Server 2005 this will set the default schema; in SQL Server 2000 it will set the default user owner.
DefaultUser | Sets or gets the default user that should be used for AUTHORIZATION clauses.
DefinesSetStatements | Set this if this ScriptDatabaseInformation is the definitive source for SET statements for the associated scripts.
HasChanged |
IsAzure | Is this database an Azure database?
MaxDataFileSize |
QuotedIdentifier |
ScriptEncodingType |
ServerVersionNumber |
ShouldOverrideSessionSets | Whether to build the object model based on these set statements
SQLServerDBVersion | Gets or sets the database major version. 8 is for SQL Server 2000. 9 is for SQL Server 2005. 10 is for SQL Server 2008.
TextEncoder |

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


AnsiNulls Property

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.AnsiNulls Property
ScriptDatabaseInformation Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AnsiNulls As Boolean
C#
public bool AnsiNulls { get; set; }
Visual C++
public:
property bool AnsiNulls {
    bool get ();
    void set (bool value);
}

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


CaseSensitive Property

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.CaseSensitive Property
ScriptDatabaseInformation Class See Also

Indicates whether the database is case sensitive.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CaseSensitive As Boolean
C#
public bool CaseSensitive { get; private set; }
Visual C++
public:
property bool CaseSensitive {
    bool get ();
    void set (bool value);
}

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


CustomScriptFolder Property

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.CustomScriptFolder Property
ScriptDatabaseInformation Class See Also

Folder name where custom scripts can be stored that will be ignored when reading from a directory

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CustomScriptFolder As String
C#
public string CustomScriptFolder { get; }
Visual C++
public:
property String^ CustomScriptFolder {
    String^ get ();
}

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DatabaseObjectProperties Property

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.DatabaseObjectProperties Property
ScriptDatabaseInformation Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DatabaseObjectProperties As IDictionary(Of String, DatabaseObjectProperty)
C#
public IDictionary<string, DatabaseObjectProperty> DatabaseObjectProperties { get; private set; }
Visual C++
public:
property IDictionary<String^, DatabaseObjectProperty^>^ DatabaseObjectProperties {
    IDictionary<String^, DatabaseObjectProperty^>^ get ();
    void set (IDictionary<String^, DatabaseObjectProperty^>^ value);
}

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DataFilesWritten Property

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.DataFilesWritten Property
ScriptDatabaseInformation Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataFilesWritten As IEnumerable(Of String)
C#
public IEnumerable<string> DataFilesWritten { get; }
Visual C++
public:
property IEnumerable<String^>^ DataFilesWritten {
    IEnumerable<String^>^ get ();
}

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DBWriteToFileOptions Property

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.DBWriteToFileOptions Property
ScriptDatabaseInformation Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DBWriteToFileOptions As ScriptDatabaseInformation..::.WriteToFileOptions
C#
public ScriptDatabaseInformation..::.WriteToFileOptions DBWriteToFileOptions { get; }
Visual C++
public:
property ScriptDatabaseInformation..::.WriteToFileOptions^ DBWriteToFileOptions {
    ScriptDatabaseInformation..::.WriteToFileOptions^ get ();
}

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DefaultCollation Property

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.DefaultCollation Property
ScriptDatabaseInformation Class See Also

The default collation for this database.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultCollation As String
C#
public string DefaultCollation { get; set; }
Visual C++
public:
property String^ DefaultCollation {
    String^ get ();
    void set (String^ value);
}

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DefaultFilegroup Property

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.DefaultFilegroup Property
ScriptDatabaseInformation Class See Also

Sets or gets the filegroup that should be used if nothing or "DEFAULT" is specified in a creation SQL statement.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultFilegroup As String
C#
public string DefaultFilegroup { get; set; }
Visual C++
public:
property String^ DefaultFilegroup {
    String^ get ();
    void set (String^ value);
}

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DefaultOwner Property

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.DefaultOwner Property
ScriptDatabaseInformation Class See Also

Sets or gets the default owner for the database objects. In SQL Server 2005 this will set the default schema; in SQL Server 2000 it will set the default user owner.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultOwner As String
C#
public string DefaultOwner { get; set; }
Visual C++
public:
property String^ DefaultOwner {
    String^ get ();
    void set (String^ value);
}

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DefaultUser Property

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.DefaultUser Property
ScriptDatabaseInformation Class See Also

Sets or gets the default user that should be used for AUTHORIZATION clauses.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultUser As String
C#
public string DefaultUser { get; set; }
Visual C++
public:
property String^ DefaultUser {
    String^ get ();
    void set (String^ value);
}

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DefinesSetStatements Property

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.DefinesSetStatements Property
ScriptDatabaseInformation Class See Also

Set this if this ScriptDatabaseInformation is the definitive source for SET statements for the associated scripts.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefinesSetStatements As Boolean
C#
public bool DefinesSetStatements { get; set; }
Visual C++
public:
property bool DefinesSetStatements {
    bool get ();
    void set (bool value);
}

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


HasChanged Property

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.HasChanged Property
ScriptDatabaseInformation Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property HasChanged As Boolean
C#
public bool HasChanged { get; set; }
Visual C++
public:
property bool HasChanged {
    bool get ();
    void set (bool value);
}

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


IsAzure Property

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.IsAzure Property
ScriptDatabaseInformation Class See Also

Is this database an Azure database?

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsAzure As Boolean
C#
public bool IsAzure { get; set; }
Visual C++
public:
property bool IsAzure {
    bool get ();
    void set (bool value);
}

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


MaxDataFileSize Property

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.MaxDataFileSize Property
ScriptDatabaseInformation Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxDataFileSize As Integer
C#
public int MaxDataFileSize { get; set; }
Visual C++
public:
property int MaxDataFileSize {
    int get ();
    void set (int value);
}

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


QuotedIdentifier Property

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.QuotedIdentifier Property
ScriptDatabaseInformation Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property QuotedIdentifier As Boolean
C#
public bool QuotedIdentifier { get; set; }
Visual C++
public:
property bool QuotedIdentifier {
    bool get ();
    void set (bool value);
}

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptEncodingType Property

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.ScriptEncodingType Property
ScriptDatabaseInformation Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptEncodingType As ScriptEncodingType
C#
public ScriptEncodingType ScriptEncodingType { get; set; }
Visual C++
public:
property ScriptEncodingType ScriptEncodingType {
    ScriptEncodingType get ();
    void set (ScriptEncodingType value);
}

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ServerVersionNumber Property

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.ServerVersionNumber Property
ScriptDatabaseInformation Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ServerVersionNumber As Version
C#
public Version ServerVersionNumber { get; set; }
Visual C++
public:
property Version^ ServerVersionNumber {
    Version^ get ();
    void set (Version^ value);
}

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ShouldOverrideSessionSets Property

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.ShouldOverrideSessionSets Property
ScriptDatabaseInformation Class See Also

Whether to build the object model based on these set statements

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ShouldOverrideSessionSets As Boolean
C#
public bool ShouldOverrideSessionSets { get; }
Visual C++
public:
property bool ShouldOverrideSessionSets {
    bool get ();
}

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


SQLServerDBVersion Property

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.SQLServerDBVersion Property
ScriptDatabaseInformation Class See Also

Gets or sets the database major version. 8 is for SQL Server 2000. 9 is for SQL Server 2005. 10 is for SQL Server 2008.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SQLServerDBVersion As SQLVersion
C#
public SQLVersion SQLServerDBVersion { get; set; }
Visual C++
public:
property SQLVersion SQLServerDBVersion {
    SQLVersion get ();
    void set (SQLVersion value);
}

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


TextEncoder Property

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.TextEncoder Property
ScriptDatabaseInformation Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TextEncoder As Encoding
C#
public Encoding TextEncoder { get; }
Visual C++
public:
property Encoding^ TextEncoder {
    Encoding^ get ();
}

See Also

ScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptDatabaseInformation.WriteToFileOptions Class

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.WriteToFileOptions Class
ScriptDatabaseInformation Class Members See Also

Options that control how script files are written to a scripts folder.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class WriteToFileOptions
C#
[SerializableAttribute]
public class WriteToFileOptions
Visual C++
[SerializableAttribute]
public ref class WriteToFileOptions

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation..::.WriteToFileOptions

See Also

ScriptDatabaseInformation..::.WriteToFileOptions Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptDatabaseInformation.WriteToFileOptions Members

[image] [image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.WriteToFileOptions Members
ScriptDatabaseInformation..::.WriteToFileOptions Class Constructors Methods Properties See Also

Options and settings that control how the creation SQL files are loaded and processed.

The ScriptDatabaseInformation..::.WriteToFileOptions type exposes the following members.

Constructors

Name | Description
ScriptDatabaseInformation..::.WriteToFileOptions | Constructs a new instance of the WriteToFileOptions class.

Methods

Name | Description
Equals | (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromXml | Overloaded.
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NewWriteToFileOptions |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteXml | Overloaded.

Properties

Name | Description
ObjectPrefixes | The object prefixes for all the ObjectType enumeration elements. These prefixes may contain one or more subfolder names and an object name prefix.
WriteDataFilesInOneDirectory | Obsolete. Sets/Gets the write data files in one directory option

See Also

ScriptDatabaseInformation..::.WriteToFileOptions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptDatabaseInformation.WriteToFileOptions Constructor

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.WriteToFileOptions Constructor
ScriptDatabaseInformation..::.WriteToFileOptions Class See Also

Constructs a new instance of the WriteToFileOptions class.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected WriteToFileOptions()
Visual C++
protected:
WriteToFileOptions()

See Also

ScriptDatabaseInformation..::.WriteToFileOptions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptDatabaseInformation.WriteToFileOptions Methods

[image] [image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.WriteToFileOptions Methods
ScriptDatabaseInformation..::.WriteToFileOptions Class See Also

The ScriptDatabaseInformation..::.WriteToFileOptions type exposes the following methods.

Methods

Name | Description
Equals | (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromXml | Overloaded.
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NewWriteToFileOptions |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteXml | Overloaded.

See Also

ScriptDatabaseInformation..::.WriteToFileOptions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Equals Method

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.WriteToFileOptions..::.Equals Method
ScriptDatabaseInformation..::.WriteToFileOptions Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object

See Also

ScriptDatabaseInformation..::.WriteToFileOptions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FromXml Method

[image] [image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.WriteToFileOptions..::.FromXml Method
ScriptDatabaseInformation..::.WriteToFileOptions Class See Also

Overload List

Name | Description
FromXml(Stream) | Constructs a new WriteToFileOptions object given a stream. Returns null if the options cannot be constructed from the XML.
FromXml(TextReader) | Constructs a new WriteToFileOptions object given a textreader containing XML generated by GetXml(). Returns null if the options cannot be constructed from the XML.
FromXml(String) | Constructs a new WriteToFileOptions object given an XML string generated by GetXml() method. Returns null if the options cannot be constructed from the XML.
FromXml(XmlDocument) |
FromXml(XmlNode) |
FromXml(XmlReader) | Constructs a new WriteToFileOptions object given an XML reader. Returns null if the options cannot be constructed from the XML.

See Also

ScriptDatabaseInformation..::.WriteToFileOptions Class
ScriptDatabaseInformation..::.WriteToFileOptions Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FromXml Method ()

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.WriteToFileOptions..::.FromXml Method ()
ScriptDatabaseInformation..::.WriteToFileOptions Class See Also

Constructs a new WriteToFileOptions object given a stream. Returns null if the options cannot be constructed from the XML.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FromXml ( _
    xmlStream As Stream _
) As ScriptDatabaseInformation..::.WriteToFileOptions
C#
public static ScriptDatabaseInformation..::.WriteToFileOptions FromXml(
    Stream xmlStream
)
Visual C++
public:
static ScriptDatabaseInformation..::.WriteToFileOptions^ FromXml(
    Stream^ xmlStream
)

Parameters

xmlStream
Type: Stream

See Also

ScriptDatabaseInformation..::.WriteToFileOptions Class
FromXml Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FromXml Method ()

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.WriteToFileOptions..::.FromXml Method ()
ScriptDatabaseInformation..::.WriteToFileOptions Class See Also

Constructs a new WriteToFileOptions object given a textreader containing XML generated by GetXml(). Returns null if the options cannot be constructed from the XML.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FromXml ( _
    xmlText As TextReader _
) As ScriptDatabaseInformation..::.WriteToFileOptions
C#
public static ScriptDatabaseInformation..::.WriteToFileOptions FromXml(
    TextReader xmlText
)
Visual C++
public:
static ScriptDatabaseInformation..::.WriteToFileOptions^ FromXml(
    TextReader^ xmlText
)

Parameters

xmlText
Type: TextReader

See Also

ScriptDatabaseInformation..::.WriteToFileOptions Class
FromXml Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FromXml Method ()

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.WriteToFileOptions..::.FromXml Method ()
ScriptDatabaseInformation..::.WriteToFileOptions Class See Also

Constructs a new WriteToFileOptions object given an XML string generated by GetXml() method. Returns null if the options cannot be constructed from the XML.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FromXml ( _
    xml As String _
) As ScriptDatabaseInformation..::.WriteToFileOptions
C#
public static ScriptDatabaseInformation..::.WriteToFileOptions FromXml(
    string xml
)
Visual C++
public:
static ScriptDatabaseInformation..::.WriteToFileOptions^ FromXml(
    String^ xml
)

Parameters

xml
Type: String

See Also

ScriptDatabaseInformation..::.WriteToFileOptions Class
FromXml Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FromXml Method ()

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.WriteToFileOptions..::.FromXml Method ()
ScriptDatabaseInformation..::.WriteToFileOptions Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FromXml ( _
    doc As XmlDocument _
) As ScriptDatabaseInformation..::.WriteToFileOptions
C#
public static ScriptDatabaseInformation..::.WriteToFileOptions FromXml(
    XmlDocument doc
)
Visual C++
public:
static ScriptDatabaseInformation..::.WriteToFileOptions^ FromXml(
    XmlDocument^ doc
)

Parameters

doc
Type: XmlDocument

See Also

ScriptDatabaseInformation..::.WriteToFileOptions Class
FromXml Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FromXml Method ()

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.WriteToFileOptions..::.FromXml Method ()
ScriptDatabaseInformation..::.WriteToFileOptions Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FromXml ( _
    doc As XmlNode _
) As ScriptDatabaseInformation..::.WriteToFileOptions
C#
public static ScriptDatabaseInformation..::.WriteToFileOptions FromXml(
    XmlNode doc
)
Visual C++
public:
static ScriptDatabaseInformation..::.WriteToFileOptions^ FromXml(
    XmlNode^ doc
)

Parameters

doc
Type: XmlNode

See Also

ScriptDatabaseInformation..::.WriteToFileOptions Class
FromXml Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FromXml Method ()

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.WriteToFileOptions..::.FromXml Method ()
ScriptDatabaseInformation..::.WriteToFileOptions Class See Also

Constructs a new WriteToFileOptions object given an XML reader. Returns null if the options cannot be constructed from the XML.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FromXml ( _
    reader As XmlReader _
) As ScriptDatabaseInformation..::.WriteToFileOptions
C#
public static ScriptDatabaseInformation..::.WriteToFileOptions FromXml(
    XmlReader reader
)
Visual C++
public:
static ScriptDatabaseInformation..::.WriteToFileOptions^ FromXml(
    XmlReader^ reader
)

Parameters

reader
Type: XmlReader

See Also

ScriptDatabaseInformation..::.WriteToFileOptions Class
FromXml Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.WriteToFileOptions..::.GetHashCode Method
ScriptDatabaseInformation..::.WriteToFileOptions Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

See Also

ScriptDatabaseInformation..::.WriteToFileOptions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


NewWriteToFileOptions Method

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.WriteToFileOptions..::.NewWriteToFileOptions Method
ScriptDatabaseInformation..::.WriteToFileOptions Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function NewWriteToFileOptions As ScriptDatabaseInformation..::.WriteToFileOptions
C#
public static ScriptDatabaseInformation..::.WriteToFileOptions NewWriteToFileOptions()
Visual C++
public:
static ScriptDatabaseInformation..::.WriteToFileOptions^ NewWriteToFileOptions()

See Also

ScriptDatabaseInformation..::.WriteToFileOptions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


WriteXml Method

[image] [image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.WriteToFileOptions..::.WriteXml Method
ScriptDatabaseInformation..::.WriteToFileOptions Class See Also

Overload List

Name | Description
WriteXml(Stream) | Writes an XML version of these options to a stream.
WriteXml(DataPreservingXmlStringBuilder) | Writes an XML version of these options to an XmlWriter.

See Also

ScriptDatabaseInformation..::.WriteToFileOptions Class
ScriptDatabaseInformation..::.WriteToFileOptions Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


WriteXml Method ()

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.WriteToFileOptions..::.WriteXml Method ()
ScriptDatabaseInformation..::.WriteToFileOptions Class See Also

Writes an XML version of these options to a stream.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteXml ( _
    stream As Stream _
)
C#
public void WriteXml(
    Stream stream
)
Visual C++
public:
void WriteXml(
    Stream^ stream
)

Parameters

stream
Type: Stream

See Also

ScriptDatabaseInformation..::.WriteToFileOptions Class
WriteXml Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


WriteXml Method (DataPreservingXmlStringBuilder)

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.WriteToFileOptions..::.WriteXml Method (DataPreservingXmlStringBuilder)
ScriptDatabaseInformation..::.WriteToFileOptions Class See Also

Writes an XML version of these options to an XmlWriter.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteXml ( _
    optionXmlStringBuilder As DataPreservingXmlStringBuilder _
)
C#
public void WriteXml(
    DataPreservingXmlStringBuilder optionXmlStringBuilder
)
Visual C++
public:
void WriteXml(
    DataPreservingXmlStringBuilder^ optionXmlStringBuilder
)

Parameters

optionXmlStringBuilder
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.DataPreservingXmlStringBuilder

See Also

ScriptDatabaseInformation..::.WriteToFileOptions Class
WriteXml Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptDatabaseInformation.WriteToFileOptions Properties

[image] [image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.WriteToFileOptions Properties
ScriptDatabaseInformation..::.WriteToFileOptions Class See Also

The ScriptDatabaseInformation..::.WriteToFileOptions type exposes the following properties.

Properties

Name | Description
ObjectPrefixes | The object prefixes for all the ObjectType enumeration elements. These prefixes may contain one or more subfolder names and an object name prefix.
WriteDataFilesInOneDirectory | Obsolete. Sets/Gets the write data files in one directory option

See Also

ScriptDatabaseInformation..::.WriteToFileOptions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ObjectPrefixes Property

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.WriteToFileOptions..::.ObjectPrefixes Property
ScriptDatabaseInformation..::.WriteToFileOptions Class See Also

The object prefixes for all the ObjectType enumeration elements. These prefixes may contain one or more subfolder names and an object name prefix.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectPrefixes As String()
C#
public string[] ObjectPrefixes { get; internal set; }
Visual C++
public:
property array<String^>^ ObjectPrefixes {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

See Also

ScriptDatabaseInformation..::.WriteToFileOptions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


WriteDataFilesInOneDirectory Property

[image]

SQL Data Compare API 12.0.40
ScriptDatabaseInformation..::.WriteToFileOptions..::.WriteDataFilesInOneDirectory Property
ScriptDatabaseInformation..::.WriteToFileOptions Class See Also

Sets/Gets the write data files in one directory option

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Only the value of true is supported for this property.",  _
    True)> _
Public Property WriteDataFilesInOneDirectory As Boolean
C#
[ObsoleteAttribute("Only the value of true is supported for this property.",
    true)]
public bool WriteDataFilesInOneDirectory { get; set; }
Visual C++
[ObsoleteAttribute(L"Only the value of true is supported for this property.",
    true)]
public:
property bool WriteDataFilesInOneDirectory {
    bool get ();
    void set (bool value);
}

See Also

ScriptDatabaseInformation..::.WriteToFileOptions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptEncoder Class

[image]

SQL Data Compare API 12.0.40
ScriptEncoder Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ScriptEncoder
C#
public static class ScriptEncoder
Visual C++
public ref class ScriptEncoder abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptEncoder

See Also

ScriptEncoder Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptEncoder Members

[image] [image]

SQL Data Compare API 12.0.40
ScriptEncoder Members
ScriptEncoder Class Methods See Also

The ScriptEncoder type exposes the following members.

Methods

Name | Description
GetEncoding |

See Also

ScriptEncoder Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptEncoder Methods

[image] [image]

SQL Data Compare API 12.0.40
ScriptEncoder Methods
ScriptEncoder Class See Also

The ScriptEncoder type exposes the following methods.

Methods

Name | Description
GetEncoding |

See Also

ScriptEncoder Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


GetEncoding Method

[image]

SQL Data Compare API 12.0.40
ScriptEncoder..::.GetEncoding Method
ScriptEncoder Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetEncoding ( _
    set As ScriptEncodingType _
) As Encoding
C#
public static Encoding GetEncoding(
    ScriptEncodingType set
)
Visual C++
public:
static Encoding^ GetEncoding(
    ScriptEncodingType set
)

Parameters

set
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptEncodingType

See Also

ScriptEncoder Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptEncodingType Enumeration

[image]

SQL Data Compare API 12.0.40
ScriptEncodingType Enumeration
See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration ScriptEncodingType
C#
public enum ScriptEncodingType
Visual C++
public enum class ScriptEncodingType

Members

Member name | Description
ASCII |
Windows1252 |
UTF8 |
UTF8_BOM |
UTF16 |

See Also

RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationAction Class

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationAction Class
Members See Also

A synchronization action that is used when a file needs to be created or altered during synchronizing to a scripts folder.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class ScriptSynchronizationAction
C#
public abstract class ScriptSynchronizationAction
Visual C++
public ref class ScriptSynchronizationAction abstract

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationAction
RedGate.SQLCompare.Engine.ReadFromFolder..::.SynchronizationActionRewriteBase
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationActionWrite
RedGate.SQLDataCompare.Engine.FolderReader..::.DataCompareScriptSyncAction

See Also

ScriptSynchronizationAction Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationAction Members

[image] [image]

SQL Data Compare API 12.0.40
ScriptSynchronizationAction Members
ScriptSynchronizationAction Class Constructors Methods Properties See Also

The ScriptSynchronizationAction type exposes the following members.

Constructors

Name | Description
ScriptSynchronizationAction | Constructs a ScriptSynchronizationAction.

Methods

Name | Description
Check | Checks preconditions for the execution.
CheckFileAndDirectoryPermissions |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Executes the synchronization action and updates ScriptDatabaseInformation with relevant metadata
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DatabaseObjectType | The object type this action applies to.
FileName | The file name for this synchronization action.
ShortFileName | The name of the file and its prefix folder for this particular synchronization action.

See Also

ScriptSynchronizationAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationAction Constructor

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationAction Constructor
ScriptSynchronizationAction Class See Also

Constructs a ScriptSynchronizationAction.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    dbInfo As ScriptDatabaseInformation, _
    options As Options, _
    scriptFolder As String, _
    fileName As String _
)
C#
protected ScriptSynchronizationAction(
    ScriptDatabaseInformation dbInfo,
    Options options,
    string scriptFolder,
    string fileName
)
Visual C++
protected:
ScriptSynchronizationAction(
    ScriptDatabaseInformation^ dbInfo,
    Options options,
    String^ scriptFolder,
    String^ fileName
)

Parameters

dbInfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
The options that control how to write to the scripts folder.
options
Type: RedGate.SQLCompare.Engine..::.Options
Database options.
scriptFolder
Type: String
The scripts folder for the target scripts.
fileName
Type: String
The name of the file for this particular synchronization action.

See Also

ScriptSynchronizationAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationAction Methods

[image] [image]

SQL Data Compare API 12.0.40
ScriptSynchronizationAction Methods
ScriptSynchronizationAction Class See Also

The ScriptSynchronizationAction type exposes the following methods.

Methods

Name | Description
Check | Checks preconditions for the execution.
CheckFileAndDirectoryPermissions |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Executes the synchronization action and updates ScriptDatabaseInformation with relevant metadata
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScriptSynchronizationAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Check Method

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationAction..::.Check Method
ScriptSynchronizationAction Class See Also

Checks preconditions for the execution.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Check
C#
public abstract void Check()
Visual C++
public:
virtual void Check() abstract

See Also

ScriptSynchronizationAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


CheckFileAndDirectoryPermissions Method

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationAction..::.CheckFileAndDirectoryPermissions Method
ScriptSynchronizationAction Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub CheckFileAndDirectoryPermissions
C#
protected void CheckFileAndDirectoryPermissions()
Visual C++
protected:
void CheckFileAndDirectoryPermissions()

See Also

ScriptSynchronizationAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Execute Method

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationAction..::.Execute Method
ScriptSynchronizationAction Class See Also

Executes the synchronization action and updates ScriptDatabaseInformation with relevant metadata

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Execute
C#
public abstract void Execute()
Visual C++
public:
virtual void Execute() abstract

See Also

ScriptSynchronizationAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationAction Properties

[image] [image]

SQL Data Compare API 12.0.40
ScriptSynchronizationAction Properties
ScriptSynchronizationAction Class See Also

The ScriptSynchronizationAction type exposes the following properties.

Properties

Name | Description
DatabaseObjectType | The object type this action applies to.
FileName | The file name for this synchronization action.
ShortFileName | The name of the file and its prefix folder for this particular synchronization action.

See Also

ScriptSynchronizationAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DatabaseObjectType Property

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationAction..::.DatabaseObjectType Property
ScriptSynchronizationAction Class See Also

The object type this action applies to.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property DatabaseObjectType As ObjectType
C#
public abstract ObjectType DatabaseObjectType { get; }
Visual C++
public:
virtual property ObjectType DatabaseObjectType {
    ObjectType get () abstract;
}

See Also

ScriptSynchronizationAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FileName Property

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationAction..::.FileName Property
ScriptSynchronizationAction Class See Also

The file name for this synchronization action.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FileName As String
C#
public string FileName { get; protected internal set; }
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

See Also

ScriptSynchronizationAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ShortFileName Property

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationAction..::.ShortFileName Property
ScriptSynchronizationAction Class See Also

The name of the file and its prefix folder for this particular synchronization action.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ShortFileName As String
C#
public string ShortFileName { get; }
Visual C++
public:
property String^ ShortFileName {
    String^ get ();
}

See Also

ScriptSynchronizationAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActionBlatObject Class

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActionBlatObject Class
Members See Also

A synchronization action that creates a new file for a database object. The database object may or may not be in the destination script folder already. Please use ScriptSynchronizationActionCreateObject if at all possible, because using this class causes SC-4654.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ScriptSynchronizationActionBlatObject _
    Inherits ScriptSynchronizationActionWrite
C#
public sealed class ScriptSynchronizationActionBlatObject : ScriptSynchronizationActionWrite
Visual C++
public ref class ScriptSynchronizationActionBlatObject sealed : public ScriptSynchronizationActionWrite

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationAction
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationActionWrite
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationActionBlatObject

See Also

ScriptSynchronizationActionBlatObject Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActionBlatObject Members

[image] [image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActionBlatObject Members
ScriptSynchronizationActionBlatObject Class Methods Properties See Also

The ScriptSynchronizationActionBlatObject type exposes the following members.

Methods

Name | Description
Check | Checks preconditions for the execution. (Inherited from ScriptSynchronizationActionWrite.)
CheckFileAndDirectoryPermissions | (Inherited from ScriptSynchronizationAction.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Executes the synchronization action. (Overrides ScriptSynchronizationAction ..::. Execute()()().)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DatabaseObject | The database object that is to be created by this synchronization action. (Inherited from ScriptSynchronizationActionWrite.)
DatabaseObjectType | (Overrides ScriptSynchronizationAction ..::. DatabaseObjectType.)
FileName | The file name for this synchronization action. (Inherited from ScriptSynchronizationAction.)
ShortFileName | The name of the file and its prefix folder for this particular synchronization action. (Inherited from ScriptSynchronizationAction.)

See Also

ScriptSynchronizationActionBlatObject Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActionBlatObject Methods

[image] [image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActionBlatObject Methods
ScriptSynchronizationActionBlatObject Class See Also

The ScriptSynchronizationActionBlatObject type exposes the following methods.

Methods

Name | Description
Check | Checks preconditions for the execution. (Inherited from ScriptSynchronizationActionWrite.)
CheckFileAndDirectoryPermissions | (Inherited from ScriptSynchronizationAction.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Executes the synchronization action. (Overrides ScriptSynchronizationAction ..::. Execute()()().)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScriptSynchronizationActionBlatObject Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Execute Method

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActionBlatObject..::.Execute Method
ScriptSynchronizationActionBlatObject Class See Also

Executes the synchronization action.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Execute
C#
public override void Execute()
Visual C++
public:
virtual void Execute() override

See Also

ScriptSynchronizationActionBlatObject Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActionBlatObject Properties

[image] [image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActionBlatObject Properties
ScriptSynchronizationActionBlatObject Class See Also

The ScriptSynchronizationActionBlatObject type exposes the following properties.

Properties

Name | Description
DatabaseObject | The database object that is to be created by this synchronization action. (Inherited from ScriptSynchronizationActionWrite.)
DatabaseObjectType | (Overrides ScriptSynchronizationAction ..::. DatabaseObjectType.)
FileName | The file name for this synchronization action. (Inherited from ScriptSynchronizationAction.)
ShortFileName | The name of the file and its prefix folder for this particular synchronization action. (Inherited from ScriptSynchronizationAction.)

See Also

ScriptSynchronizationActionBlatObject Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DatabaseObjectType Property

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActionBlatObject..::.DatabaseObjectType Property
ScriptSynchronizationActionBlatObject Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property DatabaseObjectType As ObjectType
C#
public override ObjectType DatabaseObjectType { get; }
Visual C++
public:
virtual property ObjectType DatabaseObjectType {
    ObjectType get () override;
}

See Also

ScriptSynchronizationActionBlatObject Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActionCreateObject Class

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActionCreateObject Class
Members See Also

A synchronization action that creates a new file for a database object. The database object must not be in the destination script folder already.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ScriptSynchronizationActionCreateObject _
    Inherits ScriptSynchronizationActionWrite
C#
public sealed class ScriptSynchronizationActionCreateObject : ScriptSynchronizationActionWrite
Visual C++
public ref class ScriptSynchronizationActionCreateObject sealed : public ScriptSynchronizationActionWrite

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationAction
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationActionWrite
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationActionCreateObject

See Also

ScriptSynchronizationActionCreateObject Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActionCreateObject Members

[image] [image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActionCreateObject Members
ScriptSynchronizationActionCreateObject Class Methods Properties See Also

The ScriptSynchronizationActionCreateObject type exposes the following members.

Methods

Name | Description
Check | Checks preconditions for the execution. (Inherited from ScriptSynchronizationActionWrite.)
CheckFileAndDirectoryPermissions | (Inherited from ScriptSynchronizationAction.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Executes the synchronization action. Which involves writing out to the object file(s), and adding any required metadata to ScriptDatabaseInformation. (Overrides ScriptSynchronizationAction ..::. Execute()()().)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DatabaseObject | The database object that is to be created by this synchronization action. (Inherited from ScriptSynchronizationActionWrite.)
DatabaseObjectType | (Overrides ScriptSynchronizationAction ..::. DatabaseObjectType.)
FileName | The file name for this synchronization action. (Inherited from ScriptSynchronizationAction.)
ShortFileName | The name of the file and its prefix folder for this particular synchronization action. (Inherited from ScriptSynchronizationAction.)

See Also

ScriptSynchronizationActionCreateObject Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActionCreateObject Methods

[image] [image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActionCreateObject Methods
ScriptSynchronizationActionCreateObject Class See Also

The ScriptSynchronizationActionCreateObject type exposes the following methods.

Methods

Name | Description
Check | Checks preconditions for the execution. (Inherited from ScriptSynchronizationActionWrite.)
CheckFileAndDirectoryPermissions | (Inherited from ScriptSynchronizationAction.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Executes the synchronization action. Which involves writing out to the object file(s), and adding any required metadata to ScriptDatabaseInformation. (Overrides ScriptSynchronizationAction ..::. Execute()()().)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScriptSynchronizationActionCreateObject Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Execute Method

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActionCreateObject..::.Execute Method
ScriptSynchronizationActionCreateObject Class See Also

Executes the synchronization action. Which involves writing out to the object file(s), and adding any required metadata to ScriptDatabaseInformation.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Execute
C#
public override void Execute()
Visual C++
public:
virtual void Execute() override

See Also

ScriptSynchronizationActionCreateObject Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActionCreateObject Properties

[image] [image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActionCreateObject Properties
ScriptSynchronizationActionCreateObject Class See Also

The ScriptSynchronizationActionCreateObject type exposes the following properties.

Properties

Name | Description
DatabaseObject | The database object that is to be created by this synchronization action. (Inherited from ScriptSynchronizationActionWrite.)
DatabaseObjectType | (Overrides ScriptSynchronizationAction ..::. DatabaseObjectType.)
FileName | The file name for this synchronization action. (Inherited from ScriptSynchronizationAction.)
ShortFileName | The name of the file and its prefix folder for this particular synchronization action. (Inherited from ScriptSynchronizationAction.)

See Also

ScriptSynchronizationActionCreateObject Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DatabaseObjectType Property

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActionCreateObject..::.DatabaseObjectType Property
ScriptSynchronizationActionCreateObject Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property DatabaseObjectType As ObjectType
C#
public override ObjectType DatabaseObjectType { get; }
Visual C++
public:
virtual property ObjectType DatabaseObjectType {
    ObjectType get () override;
}

See Also

ScriptSynchronizationActionCreateObject Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActionRewrite Class

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActionRewrite Class
Members See Also

A synchronization action that modifies a creation SQL file.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ScriptSynchronizationActionRewrite _
    Inherits SynchronizationActionRewriteBase
C#
public sealed class ScriptSynchronizationActionRewrite : SynchronizationActionRewriteBase
Visual C++
public ref class ScriptSynchronizationActionRewrite sealed : public SynchronizationActionRewriteBase

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationAction
RedGate.SQLCompare.Engine.ReadFromFolder..::.SynchronizationActionRewriteBase
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationActionRewrite

See Also

ScriptSynchronizationActionRewrite Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActionRewrite Members

[image] [image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActionRewrite Members
ScriptSynchronizationActionRewrite Class Methods Properties See Also

The ScriptSynchronizationActionRewrite type exposes the following members.

Methods

Name | Description
Check | Checks if the script synchronization action can be carried out. (Inherited from SynchronizationActionRewriteBase.)
CheckFileAndDirectoryPermissions | (Inherited from ScriptSynchronizationAction.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Executes the synchronization action. (Overrides ScriptSynchronizationAction ..::. Execute()()().)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DatabaseObjectType | (Overrides ScriptSynchronizationAction ..::. DatabaseObjectType.)
FileName | The file name for this synchronization action. (Inherited from ScriptSynchronizationAction.)
ShortFileName | The name of the file and its prefix folder for this particular synchronization action. (Inherited from ScriptSynchronizationAction.)

See Also

ScriptSynchronizationActionRewrite Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActionRewrite Methods

[image] [image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActionRewrite Methods
ScriptSynchronizationActionRewrite Class See Also

The ScriptSynchronizationActionRewrite type exposes the following methods.

Methods

Name | Description
Check | Checks if the script synchronization action can be carried out. (Inherited from SynchronizationActionRewriteBase.)
CheckFileAndDirectoryPermissions | (Inherited from ScriptSynchronizationAction.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Executes the synchronization action. (Overrides ScriptSynchronizationAction ..::. Execute()()().)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScriptSynchronizationActionRewrite Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Execute Method

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActionRewrite..::.Execute Method
ScriptSynchronizationActionRewrite Class See Also

Executes the synchronization action.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Execute
C#
public override void Execute()
Visual C++
public:
virtual void Execute() override

See Also

ScriptSynchronizationActionRewrite Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActionRewrite Properties

[image] [image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActionRewrite Properties
ScriptSynchronizationActionRewrite Class See Also

The ScriptSynchronizationActionRewrite type exposes the following properties.

Properties

Name | Description
DatabaseObjectType | (Overrides ScriptSynchronizationAction ..::. DatabaseObjectType.)
FileName | The file name for this synchronization action. (Inherited from ScriptSynchronizationAction.)
ShortFileName | The name of the file and its prefix folder for this particular synchronization action. (Inherited from ScriptSynchronizationAction.)

See Also

ScriptSynchronizationActionRewrite Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DatabaseObjectType Property

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActionRewrite..::.DatabaseObjectType Property
ScriptSynchronizationActionRewrite Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property DatabaseObjectType As ObjectType
C#
public override ObjectType DatabaseObjectType { get; }
Visual C++
public:
virtual property ObjectType DatabaseObjectType {
    ObjectType get () override;
}

See Also

ScriptSynchronizationActionRewrite Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActions Class

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActions Class
Members See Also

The synchronization actions that need to be executed during synchronizing to a scripts folder.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ScriptSynchronizationActions _
    Implements ICancellable
C#
public class ScriptSynchronizationActions : ICancellable
Visual C++
public ref class ScriptSynchronizationActions : ICancellable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationActions

See Also

ScriptSynchronizationActions Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActions Members

[image] [image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActions Members
ScriptSynchronizationActions Class Constructors Methods Properties See Also

The ScriptSynchronizationActions type exposes the following members.

Constructors

Name | Description
ScriptSynchronizationActions | Constructs the ScriptSynchronizationActions.

Methods

Name | Description
AddUpdateDataToolsAction |
AddUpdateDBInfo |
CancelOperation | Cancels the current operation.
Check | Checks if the script synchronization actions can be carried out.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Performs the script synchronization actions; it will modify the SQL script files in the target scripts folder.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnStatus | Fire the status events.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Status | Used to provide status events.
SynchronizationActions | Access to the synchronization actions.

See Also

ScriptSynchronizationActions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActions Constructor

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActions Constructor
ScriptSynchronizationActions Class See Also

Constructs the ScriptSynchronizationActions.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ScriptSynchronizationActions()
Visual C++
public:
ScriptSynchronizationActions()

See Also

ScriptSynchronizationActions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActions Methods

[image] [image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActions Methods
ScriptSynchronizationActions Class See Also

The ScriptSynchronizationActions type exposes the following methods.

Methods

Name | Description
AddUpdateDataToolsAction |
AddUpdateDBInfo |
CancelOperation | Cancels the current operation.
Check | Checks if the script synchronization actions can be carried out.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Performs the script synchronization actions; it will modify the SQL script files in the target scripts folder.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnStatus | Fire the status events.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScriptSynchronizationActions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


AddUpdateDataToolsAction Method

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActions..::.AddUpdateDataToolsAction Method
ScriptSynchronizationActions Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddUpdateDataToolsAction ( _
    updateAction As UpdateDataToolsProjectAction _
)
C#
public void AddUpdateDataToolsAction(
    UpdateDataToolsProjectAction updateAction
)
Visual C++
public:
void AddUpdateDataToolsAction(
    UpdateDataToolsProjectAction^ updateAction
)

Parameters

updateAction
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.UpdateDataToolsProjectAction

See Also

ScriptSynchronizationActions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


AddUpdateDBInfo Method

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActions..::.AddUpdateDBInfo Method
ScriptSynchronizationActions Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddUpdateDBInfo ( _
    updateDBInfoAction As UpdateDBInfoAction _
)
C#
public void AddUpdateDBInfo(
    UpdateDBInfoAction updateDBInfoAction
)
Visual C++
public:
void AddUpdateDBInfo(
    UpdateDBInfoAction^ updateDBInfoAction
)

Parameters

updateDBInfoAction
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.UpdateDBInfoAction

See Also

ScriptSynchronizationActions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


CancelOperation Method

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActions..::.CancelOperation Method
ScriptSynchronizationActions Class See Also

Cancels the current operation.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelOperation
C#
public void CancelOperation()
Visual C++
public:
virtual void CancelOperation() sealed

Implements

ICancellable..::.CancelOperation()()()

See Also

ScriptSynchronizationActions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Check Method

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActions..::.Check Method
ScriptSynchronizationActions Class See Also

Checks if the script synchronization actions can be carried out.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Check
C#
public void Check()
Visual C++
public:
void Check()

See Also

ScriptSynchronizationActions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Execute Method

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActions..::.Execute Method
ScriptSynchronizationActions Class See Also

Performs the script synchronization actions; it will modify the SQL script files in the target scripts folder.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Execute
C#
public void Execute()
Visual C++
public:
void Execute()

See Also

ScriptSynchronizationActions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


OnStatus Method

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActions..::.OnStatus Method
ScriptSynchronizationActions Class See Also

Fire the status events.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub OnStatus ( _
    e As StatusEventArgs _
)
C#
protected void OnStatus(
    StatusEventArgs e
)
Visual C++
protected:
void OnStatus(
    StatusEventArgs^ e
)

Parameters

e
Type: RedGate.Shared.Utils..::.StatusEventArgs
Arguments.

See Also

ScriptSynchronizationActions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActions Properties

[image] [image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActions Properties
ScriptSynchronizationActions Class See Also

The ScriptSynchronizationActions type exposes the following properties.

Properties

Name | Description
Status | Used to provide status events.
SynchronizationActions | Access to the synchronization actions.

See Also

ScriptSynchronizationActions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Status Property

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActions..::.Status Property
ScriptSynchronizationActions Class See Also

Used to provide status events.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

See Also

ScriptSynchronizationActions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


SynchronizationActions Property

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActions..::.SynchronizationActions Property
ScriptSynchronizationActions Class See Also

Access to the synchronization actions.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SynchronizationActions As Dictionary(Of String, ScriptSynchronizationAction)
C#
public Dictionary<string, ScriptSynchronizationAction> SynchronizationActions { get; }
Visual C++
public:
property Dictionary<String^, ScriptSynchronizationAction^>^ SynchronizationActions {
    Dictionary<String^, ScriptSynchronizationAction^>^ get ();
}

See Also

ScriptSynchronizationActions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActionWrite Class

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActionWrite Class
Members See Also

A synchronization action that creates a new file for a database object.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class ScriptSynchronizationActionWrite _
    Inherits ScriptSynchronizationAction
C#
public abstract class ScriptSynchronizationActionWrite : ScriptSynchronizationAction
Visual C++
public ref class ScriptSynchronizationActionWrite abstract : public ScriptSynchronizationAction

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationAction
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationActionWrite
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationActionBlatObject
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationActionCreateObject

See Also

ScriptSynchronizationActionWrite Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActionWrite Members

[image] [image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActionWrite Members
ScriptSynchronizationActionWrite Class Constructors Methods Properties See Also

The ScriptSynchronizationActionWrite type exposes the following members.

Constructors

Name | Description
ScriptSynchronizationActionWrite | Constructs a ScriptSynchronizationActionWrite.

Methods

Name | Description
Check | Checks preconditions for the execution. (Overrides ScriptSynchronizationAction ..::. Check()()().)
CheckFileAndDirectoryPermissions | (Inherited from ScriptSynchronizationAction.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Executes the synchronization action and updates ScriptDatabaseInformation with relevant metadata (Inherited from ScriptSynchronizationAction.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DatabaseObject | The database object that is to be created by this synchronization action.
DatabaseObjectType | The object type this action applies to. (Inherited from ScriptSynchronizationAction.)
FileName | The file name for this synchronization action. (Inherited from ScriptSynchronizationAction.)
ShortFileName | The name of the file and its prefix folder for this particular synchronization action. (Inherited from ScriptSynchronizationAction.)

See Also

ScriptSynchronizationActionWrite Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActionWrite Constructor

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActionWrite Constructor
ScriptSynchronizationActionWrite Class See Also

Constructs a ScriptSynchronizationActionWrite.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    dbInfo As ScriptDatabaseInformation, _
    options As Options, _
    scriptFolder As String, _
    fileName As String, _
    dbObject As ScriptableDatabaseObject _
)
C#
protected ScriptSynchronizationActionWrite(
    ScriptDatabaseInformation dbInfo,
    Options options,
    string scriptFolder,
    string fileName,
    ScriptableDatabaseObject dbObject
)
Visual C++
protected:
ScriptSynchronizationActionWrite(
    ScriptDatabaseInformation^ dbInfo,
    Options options,
    String^ scriptFolder,
    String^ fileName,
    ScriptableDatabaseObject^ dbObject
)

Parameters

dbInfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
Information about how to write the object. Will be updated with any required metadata on constructor.
options
Type: RedGate.SQLCompare.Engine..::.Options
Options.
scriptFolder
Type: String
The root scripts folder.
fileName
Type: String
The filename for the new database object. This may include a relative sub folder prefix.
dbObject
Type: RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
The database object that is to be created by this action.

See Also

ScriptSynchronizationActionWrite Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActionWrite Methods

[image] [image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActionWrite Methods
ScriptSynchronizationActionWrite Class See Also

The ScriptSynchronizationActionWrite type exposes the following methods.

Methods

Name | Description
Check | Checks preconditions for the execution. (Overrides ScriptSynchronizationAction ..::. Check()()().)
CheckFileAndDirectoryPermissions | (Inherited from ScriptSynchronizationAction.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Executes the synchronization action and updates ScriptDatabaseInformation with relevant metadata (Inherited from ScriptSynchronizationAction.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScriptSynchronizationActionWrite Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Check Method

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActionWrite..::.Check Method
ScriptSynchronizationActionWrite Class See Also

Checks preconditions for the execution.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Check
C#
public override void Check()
Visual C++
public:
virtual void Check() override

See Also

ScriptSynchronizationActionWrite Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActionWrite Properties

[image] [image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActionWrite Properties
ScriptSynchronizationActionWrite Class See Also

The ScriptSynchronizationActionWrite type exposes the following properties.

Properties

Name | Description
DatabaseObject | The database object that is to be created by this synchronization action.
DatabaseObjectType | The object type this action applies to. (Inherited from ScriptSynchronizationAction.)
FileName | The file name for this synchronization action. (Inherited from ScriptSynchronizationAction.)
ShortFileName | The name of the file and its prefix folder for this particular synchronization action. (Inherited from ScriptSynchronizationAction.)

See Also

ScriptSynchronizationActionWrite Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DatabaseObject Property

[image]

SQL Data Compare API 12.0.40
ScriptSynchronizationActionWrite..::.DatabaseObject Property
ScriptSynchronizationActionWrite Class See Also

The database object that is to be created by this synchronization action.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DatabaseObject As ScriptableDatabaseObject
C#
public ScriptableDatabaseObject DatabaseObject { get; }
Visual C++
public:
property ScriptableDatabaseObject^ DatabaseObject {
    ScriptableDatabaseObject^ get ();
}

See Also

ScriptSynchronizationActionWrite Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


StringWriterWithEncoding Class

[image]

SQL Data Compare API 12.0.40
StringWriterWithEncoding Class
Members See Also

The normal StringWriter ignores encoding and therefore screws up when used with XmlTextWriter. This is to fix that issue.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class StringWriterWithEncoding _
    Inherits StringWriter
C#
public class StringWriterWithEncoding : StringWriter
Visual C++
public ref class StringWriterWithEncoding : public StringWriter

Inheritance Hierarchy

Object
MarshalByRefObject
TextWriter
StringWriter
RedGate.SQLCompare.Engine.ReadFromFolder..::.StringWriterWithEncoding

See Also

StringWriterWithEncoding Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


StringWriterWithEncoding Members

[image] [image]

SQL Data Compare API 12.0.40
StringWriterWithEncoding Members
StringWriterWithEncoding Class Constructors Methods Fields Properties See Also

The StringWriterWithEncoding type exposes the following members.

Constructors

Name | Description
StringWriterWithEncoding |

Methods

Name | Description
Close | Closes the current StringWriter and the underlying stream. (Inherited from StringWriter.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Flush | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device. (Inherited from TextWriter.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetStringBuilder | Returns the underlying StringBuilder. (Inherited from StringWriter.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
ToString | Returns a string containing the characters written to the current StringWriter so far. (Inherited from StringWriter.)
Write | Overloaded.
WriteLine | Overloaded.

Fields

Name | Description
CoreNewLine | Stores the new line characters used for this TextWriter. (Inherited from TextWriter.)
m_Encoding |

Properties

Name | Description
Encoding | (Overrides StringWriter..::.Encoding()()().)
FormatProvider | Gets an object that controls formatting. (Inherited from TextWriter.)
NewLine | Gets or sets the line terminator string used by the current TextWriter. (Inherited from TextWriter.)

See Also

StringWriterWithEncoding Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


StringWriterWithEncoding Constructor

[image]

SQL Data Compare API 12.0.40
StringWriterWithEncoding Constructor
StringWriterWithEncoding Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    builder As StringBuilder, _
    encoding As Encoding _
)
C#
public StringWriterWithEncoding(
    StringBuilder builder,
    Encoding encoding
)
Visual C++
public:
StringWriterWithEncoding(
    StringBuilder^ builder,
    Encoding^ encoding
)

Parameters

builder
Type: StringBuilder
encoding
Type: Encoding

See Also

StringWriterWithEncoding Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


StringWriterWithEncoding Fields

[image] [image]

SQL Data Compare API 12.0.40
StringWriterWithEncoding Fields
StringWriterWithEncoding Class See Also

The StringWriterWithEncoding type exposes the following fields.

Fields

Name | Description
CoreNewLine | Stores the new line characters used for this TextWriter. (Inherited from TextWriter.)
m_Encoding |

See Also

StringWriterWithEncoding Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


m_Encoding Field

[image]

SQL Data Compare API 12.0.40
StringWriterWithEncoding..::.m_Encoding Field
StringWriterWithEncoding Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly m_Encoding As Encoding
C#
protected readonly Encoding m_Encoding
Visual C++
protected:
initonly Encoding^ m_Encoding

See Also

StringWriterWithEncoding Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


StringWriterWithEncoding Properties

[image] [image]

SQL Data Compare API 12.0.40
StringWriterWithEncoding Properties
StringWriterWithEncoding Class See Also

The StringWriterWithEncoding type exposes the following properties.

Properties

Name | Description
Encoding | (Overrides StringWriter..::.Encoding()()().)
FormatProvider | Gets an object that controls formatting. (Inherited from TextWriter.)
NewLine | Gets or sets the line terminator string used by the current TextWriter. (Inherited from TextWriter.)

See Also

StringWriterWithEncoding Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Encoding Property

[image]

SQL Data Compare API 12.0.40
StringWriterWithEncoding..::.Encoding Property
StringWriterWithEncoding Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Encoding As Encoding
C#
public override Encoding Encoding { get; }
Visual C++
public:
virtual property Encoding^ Encoding {
    Encoding^ get () override;
}

See Also

StringWriterWithEncoding Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


SynchronizationActionBinaryRewrite Class

[image]

SQL Data Compare API 12.0.40
SynchronizationActionBinaryRewrite Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SynchronizationActionBinaryRewrite _
    Inherits SynchronizationActionRewriteBase
C#
public sealed class SynchronizationActionBinaryRewrite : SynchronizationActionRewriteBase
Visual C++
public ref class SynchronizationActionBinaryRewrite sealed : public SynchronizationActionRewriteBase

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationAction
RedGate.SQLCompare.Engine.ReadFromFolder..::.SynchronizationActionRewriteBase
RedGate.SQLCompare.Engine.ReadFromFolder..::.SynchronizationActionBinaryRewrite

See Also

SynchronizationActionBinaryRewrite Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


SynchronizationActionBinaryRewrite Members

[image] [image]

SQL Data Compare API 12.0.40
SynchronizationActionBinaryRewrite Members
SynchronizationActionBinaryRewrite Class Constructors Methods Properties See Also

The SynchronizationActionBinaryRewrite type exposes the following members.

Constructors

Name | Description
SynchronizationActionBinaryRewrite |

Methods

Name | Description
Check | (Overrides SynchronizationActionRewriteBase ..::. Check()()().)
CheckFileAndDirectoryPermissions | (Inherited from ScriptSynchronizationAction.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Overrides ScriptSynchronizationAction ..::. Execute()()().)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Binary |
DatabaseObjectType | (Overrides ScriptSynchronizationAction ..::. DatabaseObjectType.)
FileName | The file name for this synchronization action. (Inherited from ScriptSynchronizationAction.)
Remove |
ShortFileName | The name of the file and its prefix folder for this particular synchronization action. (Inherited from ScriptSynchronizationAction.)

See Also

SynchronizationActionBinaryRewrite Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


SynchronizationActionBinaryRewrite Constructor

[image]

SQL Data Compare API 12.0.40
SynchronizationActionBinaryRewrite Constructor
SynchronizationActionBinaryRewrite Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    dbInfo As ScriptDatabaseInformation, _
    options As Options, _
    scriptFolder As String, _
    fileName As String, _
    remove As Boolean, _
    assembly As IBinaryObject _
)
C#
public SynchronizationActionBinaryRewrite(
    ScriptDatabaseInformation dbInfo,
    Options options,
    string scriptFolder,
    string fileName,
    bool remove,
    IBinaryObject assembly
)
Visual C++
public:
SynchronizationActionBinaryRewrite(
    ScriptDatabaseInformation^ dbInfo,
    Options options,
    String^ scriptFolder,
    String^ fileName,
    bool remove,
    IBinaryObject^ assembly
)

Parameters

dbInfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
options
Type: RedGate.SQLCompare.Engine..::.Options
scriptFolder
Type: String
fileName
Type: String
remove
Type: Boolean
assembly
Type: RedGate.SQLCompare.Engine..::.IBinaryObject

See Also

SynchronizationActionBinaryRewrite Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


SynchronizationActionBinaryRewrite Methods

[image] [image]

SQL Data Compare API 12.0.40
SynchronizationActionBinaryRewrite Methods
SynchronizationActionBinaryRewrite Class See Also

The SynchronizationActionBinaryRewrite type exposes the following methods.

Methods

Name | Description
Check | (Overrides SynchronizationActionRewriteBase ..::. Check()()().)
CheckFileAndDirectoryPermissions | (Inherited from ScriptSynchronizationAction.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Overrides ScriptSynchronizationAction ..::. Execute()()().)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SynchronizationActionBinaryRewrite Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Check Method

[image]

SQL Data Compare API 12.0.40
SynchronizationActionBinaryRewrite..::.Check Method
SynchronizationActionBinaryRewrite Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Check
C#
public override void Check()
Visual C++
public:
virtual void Check() override

See Also

SynchronizationActionBinaryRewrite Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Execute Method

[image]

SQL Data Compare API 12.0.40
SynchronizationActionBinaryRewrite..::.Execute Method
SynchronizationActionBinaryRewrite Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Execute
C#
public override void Execute()
Visual C++
public:
virtual void Execute() override

See Also

SynchronizationActionBinaryRewrite Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


SynchronizationActionBinaryRewrite Properties

[image] [image]

SQL Data Compare API 12.0.40
SynchronizationActionBinaryRewrite Properties
SynchronizationActionBinaryRewrite Class See Also

The SynchronizationActionBinaryRewrite type exposes the following properties.

Properties

Name | Description
Binary |
DatabaseObjectType | (Overrides ScriptSynchronizationAction ..::. DatabaseObjectType.)
FileName | The file name for this synchronization action. (Inherited from ScriptSynchronizationAction.)
Remove |
ShortFileName | The name of the file and its prefix folder for this particular synchronization action. (Inherited from ScriptSynchronizationAction.)

See Also

SynchronizationActionBinaryRewrite Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Binary Property

[image]

SQL Data Compare API 12.0.40
SynchronizationActionBinaryRewrite..::.Binary Property
SynchronizationActionBinaryRewrite Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Binary As IBinaryObject
C#
public IBinaryObject Binary { get; private set; }
Visual C++
public:
property IBinaryObject^ Binary {
    IBinaryObject^ get ();
    void set (IBinaryObject^ value);
}

See Also

SynchronizationActionBinaryRewrite Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DatabaseObjectType Property

[image]

SQL Data Compare API 12.0.40
SynchronizationActionBinaryRewrite..::.DatabaseObjectType Property
SynchronizationActionBinaryRewrite Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property DatabaseObjectType As ObjectType
C#
public override ObjectType DatabaseObjectType { get; }
Visual C++
public:
virtual property ObjectType DatabaseObjectType {
    ObjectType get () override;
}

See Also

SynchronizationActionBinaryRewrite Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Remove Property

[image]

SQL Data Compare API 12.0.40
SynchronizationActionBinaryRewrite..::.Remove Property
SynchronizationActionBinaryRewrite Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Remove As Boolean
C#
public bool Remove { get; private set; }
Visual C++
public:
property bool Remove {
    bool get ();
    void set (bool value);
}

See Also

SynchronizationActionBinaryRewrite Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


SynchronizationActionRewriteBase Class

[image]

SQL Data Compare API 12.0.40
SynchronizationActionRewriteBase Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class SynchronizationActionRewriteBase _
    Inherits ScriptSynchronizationAction
C#
public abstract class SynchronizationActionRewriteBase : ScriptSynchronizationAction
Visual C++
public ref class SynchronizationActionRewriteBase abstract : public ScriptSynchronizationAction

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationAction
RedGate.SQLCompare.Engine.ReadFromFolder..::.SynchronizationActionRewriteBase
RedGate.SQLCompare.Engine.ReadFromFolder..::.SynchronizationActionBinaryRewrite
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationActionRewrite

See Also

SynchronizationActionRewriteBase Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


SynchronizationActionRewriteBase Members

[image] [image]

SQL Data Compare API 12.0.40
SynchronizationActionRewriteBase Members
SynchronizationActionRewriteBase Class Constructors Methods Properties See Also

The SynchronizationActionRewriteBase type exposes the following members.

Constructors

Name | Description
SynchronizationActionRewriteBase |

Methods

Name | Description
Check | Checks if the script synchronization action can be carried out. (Overrides ScriptSynchronizationAction ..::. Check()()().)
CheckFileAndDirectoryPermissions | (Inherited from ScriptSynchronizationAction.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Executes the synchronization action and updates ScriptDatabaseInformation with relevant metadata (Inherited from ScriptSynchronizationAction.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DatabaseObjectType | The object type this action applies to. (Inherited from ScriptSynchronizationAction.)
FileName | The file name for this synchronization action. (Inherited from ScriptSynchronizationAction.)
ShortFileName | The name of the file and its prefix folder for this particular synchronization action. (Inherited from ScriptSynchronizationAction.)

See Also

SynchronizationActionRewriteBase Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


SynchronizationActionRewriteBase Constructor

[image]

SQL Data Compare API 12.0.40
SynchronizationActionRewriteBase Constructor
SynchronizationActionRewriteBase Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    dbInfo As ScriptDatabaseInformation, _
    options As Options, _
    scriptFolder As String, _
    fileName As String _
)
C#
protected SynchronizationActionRewriteBase(
    ScriptDatabaseInformation dbInfo,
    Options options,
    string scriptFolder,
    string fileName
)
Visual C++
protected:
SynchronizationActionRewriteBase(
    ScriptDatabaseInformation^ dbInfo,
    Options options,
    String^ scriptFolder,
    String^ fileName
)

Parameters

dbInfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
options
Type: RedGate.SQLCompare.Engine..::.Options
scriptFolder
Type: String
fileName
Type: String

See Also

SynchronizationActionRewriteBase Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


SynchronizationActionRewriteBase Methods

[image] [image]

SQL Data Compare API 12.0.40
SynchronizationActionRewriteBase Methods
SynchronizationActionRewriteBase Class See Also

The SynchronizationActionRewriteBase type exposes the following methods.

Methods

Name | Description
Check | Checks if the script synchronization action can be carried out. (Overrides ScriptSynchronizationAction ..::. Check()()().)
CheckFileAndDirectoryPermissions | (Inherited from ScriptSynchronizationAction.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Executes the synchronization action and updates ScriptDatabaseInformation with relevant metadata (Inherited from ScriptSynchronizationAction.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SynchronizationActionRewriteBase Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Check Method

[image]

SQL Data Compare API 12.0.40
SynchronizationActionRewriteBase..::.Check Method
SynchronizationActionRewriteBase Class See Also

Checks if the script synchronization action can be carried out.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Check
C#
public override void Check()
Visual C++
public:
virtual void Check() override

See Also

SynchronizationActionRewriteBase Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


TSQLParser Class

[image]

SQL Data Compare API 12.0.40
TSQLParser Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class TSQLParser _
    Implements ITSQLParser
C#
public class TSQLParser : ITSQLParser
Visual C++
public ref class TSQLParser : ITSQLParser

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.TSQLParser

See Also

TSQLParser Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


TSQLParser Members

[image] [image]

SQL Data Compare API 12.0.40
TSQLParser Members
TSQLParser Class Constructors Methods Properties See Also

The TSQLParser type exposes the following members.

Constructors

Name | Description
TSQLParser | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
SqlFileName |

See Also

TSQLParser Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


TSQLParser Constructor

[image] [image]

SQL Data Compare API 12.0.40
TSQLParser Constructor
TSQLParser Class See Also

Overload List

Name | Description
TSQLParser(FileInfo, LazyFileContents, LexerOptions) |
TSQLParser(String, Encoding, LexerOptions) | Obsolete.

See Also

TSQLParser Class
TSQLParser Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


TSQLParser Constructor (, LazyFileContents, )

[image]

SQL Data Compare API 12.0.40
TSQLParser Constructor (, LazyFileContents, )
TSQLParser Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    file As FileInfo, _
    fileContents As LazyFileContents, _
    lexerOptions As LexerOptions _
)
C#
public TSQLParser(
    FileInfo file,
    LazyFileContents fileContents,
    LexerOptions lexerOptions
)
Visual C++
public:
TSQLParser(
    FileInfo^ file,
    LazyFileContents^ fileContents,
    LexerOptions lexerOptions
)

Parameters

file
Type: FileInfo
fileContents
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.LazyFileContents
lexerOptions
Type: LexerOptions

See Also

TSQLParser Class
TSQLParser Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


TSQLParser Constructor (, , )

[image]

SQL Data Compare API 12.0.40
TSQLParser Constructor (, , )
TSQLParser Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Passing a FileInfo object rather than the filename is preferred.")> _
Public Sub New ( _
    sqlFilename As String, _
    encoding As Encoding, _
    lexerOptions As LexerOptions _
)
C#
[ObsoleteAttribute("Passing a FileInfo object rather than the filename is preferred.")]
public TSQLParser(
    string sqlFilename,
    Encoding encoding,
    LexerOptions lexerOptions
)
Visual C++
[ObsoleteAttribute(L"Passing a FileInfo object rather than the filename is preferred.")]
public:
TSQLParser(
    String^ sqlFilename,
    Encoding^ encoding,
    LexerOptions lexerOptions
)

Parameters

sqlFilename
Type: String
encoding
Type: Encoding
lexerOptions
Type: LexerOptions

See Also

TSQLParser Class
TSQLParser Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


TSQLParser Methods

[image] [image]

SQL Data Compare API 12.0.40
TSQLParser Methods
TSQLParser Class See Also

The TSQLParser type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TSQLParser Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Parse Method

[image]

SQL Data Compare API 12.0.40
TSQLParser..::.Parse Method
TSQLParser Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Parse As ParseResult
C#
public ParseResult Parse()
Visual C++
public:
virtual ParseResult^ Parse() sealed

Implements

ITSQLParser..::.Parse()()()

See Also

TSQLParser Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


TSQLParser Properties

[image] [image]

SQL Data Compare API 12.0.40
TSQLParser Properties
TSQLParser Class See Also

The TSQLParser type exposes the following properties.

Properties

Name | Description
SqlFileName |

See Also

TSQLParser Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


SqlFileName Property

[image]

SQL Data Compare API 12.0.40
TSQLParser..::.SqlFileName Property
TSQLParser Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property SqlFileName As String
C#
protected string SqlFileName { get; }
Visual C++
protected:
property String^ SqlFileName {
    String^ get ();
}

See Also

TSQLParser Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


UpdateDataToolsProjectAction Class

[image]

SQL Data Compare API 12.0.40
UpdateDataToolsProjectAction Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class UpdateDataToolsProjectAction _
    Implements IUpdateProject
C#
public sealed class UpdateDataToolsProjectAction : IUpdateProject
Visual C++
public ref class UpdateDataToolsProjectAction sealed : IUpdateProject

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.UpdateDataToolsProjectAction

See Also

UpdateDataToolsProjectAction Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


UpdateDataToolsProjectAction Members

[image] [image]

SQL Data Compare API 12.0.40
UpdateDataToolsProjectAction Members
UpdateDataToolsProjectAction Class Constructors Methods See Also

The UpdateDataToolsProjectAction type exposes the following members.

Constructors

Name | Description
UpdateDataToolsProjectAction |

Methods

Name | Description
Check |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdateDataToolsProjectAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


UpdateDataToolsProjectAction Constructor

[image]

SQL Data Compare API 12.0.40
UpdateDataToolsProjectAction Constructor
UpdateDataToolsProjectAction Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    potentialCreateActions As IEnumerable(Of ScriptSynchronizationActionWrite), _
    potentialRemoveFileActions As IEnumerable(Of SynchronizationActionRewriteBase), _
    scriptFolder As String, _
    tryLoadFromFolderOverrideForTests As Func(Of DirectoryInfo, IDataToolsProject) _
)
C#
public UpdateDataToolsProjectAction(
    IEnumerable<ScriptSynchronizationActionWrite> potentialCreateActions,
    IEnumerable<SynchronizationActionRewriteBase> potentialRemoveFileActions,
    string scriptFolder,
    Func<DirectoryInfo, IDataToolsProject> tryLoadFromFolderOverrideForTests
)
Visual C++
public:
UpdateDataToolsProjectAction(
    IEnumerable<ScriptSynchronizationActionWrite^>^ potentialCreateActions,
    IEnumerable<SynchronizationActionRewriteBase^>^ potentialRemoveFileActions,
    String^ scriptFolder,
    Func<DirectoryInfo^, IDataToolsProject^>^ tryLoadFromFolderOverrideForTests
)

Parameters

potentialCreateActions
Type: IEnumerable<(Of <( ScriptSynchronizationActionWrite >)>)
potentialRemoveFileActions
Type: IEnumerable<(Of <( SynchronizationActionRewriteBase >)>)
scriptFolder
Type: String
tryLoadFromFolderOverrideForTests
Type: Func<(Of <(DirectoryInfo, IDataToolsProject >)>)
By default uses FileBasedSsdtProject to load the sqlproj. Only for use by tests.

See Also

UpdateDataToolsProjectAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


UpdateDataToolsProjectAction Methods

[image] [image]

SQL Data Compare API 12.0.40
UpdateDataToolsProjectAction Methods
UpdateDataToolsProjectAction Class See Also

The UpdateDataToolsProjectAction type exposes the following methods.

Methods

Name | Description
Check |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdateDataToolsProjectAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Check Method

[image]

SQL Data Compare API 12.0.40
UpdateDataToolsProjectAction..::.Check Method
UpdateDataToolsProjectAction Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Check
C#
public void Check()
Visual C++
public:
virtual void Check() sealed

Implements

IUpdateProject..::.Check()()()

See Also

UpdateDataToolsProjectAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Execute Method

[image]

SQL Data Compare API 12.0.40
UpdateDataToolsProjectAction..::.Execute Method
UpdateDataToolsProjectAction Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Execute
C#
public void Execute()
Visual C++
public:
virtual void Execute() sealed

Implements

IUpdateProject..::.Execute()()()

See Also

UpdateDataToolsProjectAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


UpdateDBInfoAction Class

[image]

SQL Data Compare API 12.0.40
UpdateDBInfoAction Class
Members See Also

Modifies database settings during synchronizing to a scripts folder.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class UpdateDBInfoAction _
    Implements IUpdateProject
C#
public sealed class UpdateDBInfoAction : IUpdateProject
Visual C++
public ref class UpdateDBInfoAction sealed : IUpdateProject

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.UpdateDBInfoAction

See Also

UpdateDBInfoAction Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


UpdateDBInfoAction Members

[image] [image]

SQL Data Compare API 12.0.40
UpdateDBInfoAction Members
UpdateDBInfoAction Class Methods See Also

The UpdateDBInfoAction type exposes the following members.

Methods

Name | Description
Check | Verifies that we'll be able to update the DB info file
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Creates the database info file
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdateDBInfoAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


UpdateDBInfoAction Methods

[image] [image]

SQL Data Compare API 12.0.40
UpdateDBInfoAction Methods
UpdateDBInfoAction Class See Also

The UpdateDBInfoAction type exposes the following methods.

Methods

Name | Description
Check | Verifies that we'll be able to update the DB info file
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Creates the database info file
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdateDBInfoAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Check Method

[image]

SQL Data Compare API 12.0.40
UpdateDBInfoAction..::.Check Method
UpdateDBInfoAction Class See Also

Verifies that we'll be able to update the DB info file

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Check
C#
public void Check()
Visual C++
public:
virtual void Check() sealed

Implements

IUpdateProject..::.Check()()()

See Also

UpdateDBInfoAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Execute Method

[image]

SQL Data Compare API 12.0.40
UpdateDBInfoAction..::.Execute Method
UpdateDBInfoAction Class See Also

Creates the database info file

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Execute
C#
public void Execute()
Visual C++
public:
virtual void Execute() sealed

Implements

IUpdateProject..::.Execute()()()

See Also

UpdateDBInfoAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace

Classes

Class | Description
CacheMetadata |
ParseDetails |
PersistentReadFromFolderCache |

Interfaces

Interface | Description
IReadFromFolderCache |


CacheMetadata Class

[image]

SQL Data Compare API 12.0.40
CacheMetadata Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.Cache
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class CacheMetadata
C#
public class CacheMetadata
Visual C++
public ref class CacheMetadata

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder.Cache..::.CacheMetadata

See Also

CacheMetadata Members
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


CacheMetadata Members

[image] [image]

SQL Data Compare API 12.0.40
CacheMetadata Members
CacheMetadata Class Constructors Methods Properties See Also

The CacheMetadata type exposes the following members.

Constructors

Name | Description
CacheMetadata |

Methods

Name | Description
Deserialize |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OrderedByDescendingReadTime |
Serialize |
Store |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Version |

See Also

CacheMetadata Class
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


CacheMetadata Constructor

[image]

SQL Data Compare API 12.0.40
CacheMetadata Constructor
CacheMetadata Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.Cache
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CacheMetadata()
Visual C++
public:
CacheMetadata()

See Also

CacheMetadata Class
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


CacheMetadata Methods

[image] [image]

SQL Data Compare API 12.0.40
CacheMetadata Methods
CacheMetadata Class See Also

The CacheMetadata type exposes the following methods.

Methods

Name | Description
Deserialize |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OrderedByDescendingReadTime |
Serialize |
Store |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CacheMetadata Class
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


Deserialize Method

[image]

SQL Data Compare API 12.0.40
CacheMetadata..::.Deserialize Method
CacheMetadata Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.Cache
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Deserialize ( _
    versionId As Integer, _
    formatter As ISerializeFormatter _
) As Boolean
C#
public bool Deserialize(
    int versionId,
    ISerializeFormatter formatter
)
Visual C++
public:
virtual bool Deserialize(
    int versionId,
    ISerializeFormatter^ formatter
) sealed

Parameters

versionId
Type: Int32
formatter
Type: ISerializeFormatter

See Also

CacheMetadata Class
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


OrderedByDescendingReadTime Method

[image]

SQL Data Compare API 12.0.40
CacheMetadata..::.OrderedByDescendingReadTime Method
CacheMetadata Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.Cache
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function OrderedByDescendingReadTime As IEnumerable(Of KeyValuePair(Of String, ParseDetails))
C#
public IEnumerable<KeyValuePair<string, ParseDetails>> OrderedByDescendingReadTime()
Visual C++
public:
IEnumerable<KeyValuePair<String^, ParseDetails^>>^ OrderedByDescendingReadTime()

See Also

CacheMetadata Class
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


Serialize Method

[image]

SQL Data Compare API 12.0.40
CacheMetadata..::.Serialize Method
CacheMetadata Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.Cache
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Serialize ( _
    formatter As ISerializeFormatter _
)
C#
public void Serialize(
    ISerializeFormatter formatter
)
Visual C++
public:
virtual void Serialize(
    ISerializeFormatter^ formatter
) sealed

Parameters

formatter
Type: ISerializeFormatter

See Also

CacheMetadata Class
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


Store Method

[image]

SQL Data Compare API 12.0.40
CacheMetadata..::.Store Method
CacheMetadata Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.Cache
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Store ( _
    fileInfo As FileInfo, _
    parseDetails As ParseDetails _
)
C#
public void Store(
    FileInfo fileInfo,
    ParseDetails parseDetails
)
Visual C++
public:
void Store(
    FileInfo^ fileInfo,
    ParseDetails^ parseDetails
)

Parameters

fileInfo
Type: FileInfo
parseDetails
Type: RedGate.SQLCompare.Engine.ReadFromFolder.Cache..::.ParseDetails

See Also

CacheMetadata Class
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


CacheMetadata Properties

[image] [image]

SQL Data Compare API 12.0.40
CacheMetadata Properties
CacheMetadata Class See Also

The CacheMetadata type exposes the following properties.

Properties

Name | Description
Version |

See Also

CacheMetadata Class
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


Version Property

[image]

SQL Data Compare API 12.0.40
CacheMetadata..::.Version Property
CacheMetadata Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.Cache
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As Integer
C#
public int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () sealed;
}

See Also

CacheMetadata Class
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


IReadFromFolderCache Interface

[image]

SQL Data Compare API 12.0.40
IReadFromFolderCache Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.Cache
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IReadFromFolderCache _
    Implements IDisposable
C#
public interface IReadFromFolderCache : IDisposable
Visual C++
public interface class IReadFromFolderCache : IDisposable

See Also

IReadFromFolderCache Members
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


IReadFromFolderCache Members

[image] [image]

SQL Data Compare API 12.0.40
IReadFromFolderCache Members
IReadFromFolderCache Interface Methods Properties See Also

The IReadFromFolderCache type exposes the following members.

Methods

Name | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
ParseFile |
PersistMetadata |

Properties

Name | Description
CacheFolderLocation |

See Also

IReadFromFolderCache Interface
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


IReadFromFolderCache Methods

[image] [image]

SQL Data Compare API 12.0.40
IReadFromFolderCache Methods
IReadFromFolderCache Interface See Also

The IReadFromFolderCache type exposes the following methods.

Methods

Name | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
ParseFile |
PersistMetadata |

See Also

IReadFromFolderCache Interface
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


ParseFile Method

[image]

SQL Data Compare API 12.0.40
IReadFromFolderCache..::.ParseFile Method
IReadFromFolderCache Interface See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.Cache
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function ParseFile ( _
    fileInfo As FileInfo, _
    lazyFileContents As LazyFileContents, _
    lexerOptions As LexerOptions _
) As ParseResult
C#
ParseResult ParseFile(
    FileInfo fileInfo,
    LazyFileContents lazyFileContents,
    LexerOptions lexerOptions
)
Visual C++
ParseResult^ ParseFile(
    FileInfo^ fileInfo,
    LazyFileContents^ lazyFileContents,
    LexerOptions lexerOptions
)

Parameters

fileInfo
Type: FileInfo
lazyFileContents
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.LazyFileContents
lexerOptions
Type: LexerOptions

See Also

IReadFromFolderCache Interface
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


PersistMetadata Method

[image]

SQL Data Compare API 12.0.40
IReadFromFolderCache..::.PersistMetadata Method
IReadFromFolderCache Interface See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.Cache
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub PersistMetadata
C#
void PersistMetadata()
Visual C++
void PersistMetadata()

See Also

IReadFromFolderCache Interface
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


IReadFromFolderCache Properties

[image] [image]

SQL Data Compare API 12.0.40
IReadFromFolderCache Properties
IReadFromFolderCache Interface See Also

The IReadFromFolderCache type exposes the following properties.

Properties

Name | Description
CacheFolderLocation |

See Also

IReadFromFolderCache Interface
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


CacheFolderLocation Property

[image]

SQL Data Compare API 12.0.40
IReadFromFolderCache..::.CacheFolderLocation Property
IReadFromFolderCache Interface See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.Cache
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CacheFolderLocation As String
C#
string CacheFolderLocation { get; }
Visual C++
property String^ CacheFolderLocation {
    String^ get ();
}

See Also

IReadFromFolderCache Interface
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


ParseDetails Class

[image]

SQL Data Compare API 12.0.40
ParseDetails Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.Cache
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ParseDetails _
    Implements IEquatable(Of ParseDetails)
C#
public class ParseDetails : IEquatable<ParseDetails>
Visual C++
public ref class ParseDetails : IEquatable<ParseDetails^>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder.Cache..::.ParseDetails

See Also

ParseDetails Members
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


ParseDetails Members

[image] [image]

SQL Data Compare API 12.0.40
ParseDetails Members
ParseDetails Class Constructors Methods Properties See Also

The ParseDetails type exposes the following members.

Constructors

Name | Description
ParseDetails |

Methods

Name | Description
Deserialize |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality |
Inequality |

Properties

Name | Description
Version |

See Also

ParseDetails Class
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


ParseDetails Constructor

[image]

SQL Data Compare API 12.0.40
ParseDetails Constructor
ParseDetails Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.Cache
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ParseDetails()
Visual C++
public:
ParseDetails()

See Also

ParseDetails Class
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


ParseDetails Methods

[image] [image]

SQL Data Compare API 12.0.40
ParseDetails Methods
ParseDetails Class See Also

The ParseDetails type exposes the following methods.

Methods

Name | Description
Deserialize |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality |
Inequality |

See Also

ParseDetails Class
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


Deserialize Method

[image]

SQL Data Compare API 12.0.40
ParseDetails..::.Deserialize Method
ParseDetails Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.Cache
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Deserialize ( _
    versionId As Integer, _
    formatter As ISerializeFormatter _
) As Boolean
C#
public bool Deserialize(
    int versionId,
    ISerializeFormatter formatter
)
Visual C++
public:
virtual bool Deserialize(
    int versionId,
    ISerializeFormatter^ formatter
) sealed

Parameters

versionId
Type: Int32
formatter
Type: ISerializeFormatter

See Also

ParseDetails Class
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


Equality Operator

[image]

SQL Data Compare API 12.0.40
ParseDetails..::.Equality Operator
ParseDetails Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.Cache
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator = ( _
    left As ParseDetails, _
    right As ParseDetails _
) As Boolean
C#
public static bool operator ==(
    ParseDetails left,
    ParseDetails right
)
Visual C++
public:
static bool operator ==(
    ParseDetails^ left,
    ParseDetails^ right
)

Parameters

left
Type: RedGate.SQLCompare.Engine.ReadFromFolder.Cache..::.ParseDetails
right
Type: RedGate.SQLCompare.Engine.ReadFromFolder.Cache..::.ParseDetails

See Also

ParseDetails Class
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
ParseDetails..::.Equals Method
ParseDetails Class See Also

Overload List

Name | Description
Equals(Object) | (Overrides Object..::.Equals(Object).)
Equals(ParseDetails) |

See Also

ParseDetails Class
ParseDetails Members
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


Equals Method ()

[image]

SQL Data Compare API 12.0.40
ParseDetails..::.Equals Method ()
ParseDetails Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.Cache
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object

See Also

ParseDetails Class
Equals Overload
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


Equals Method (ParseDetails)

[image]

SQL Data Compare API 12.0.40
ParseDetails..::.Equals Method (ParseDetails)
ParseDetails Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.Cache
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    other As ParseDetails _
) As Boolean
C#
public bool Equals(
    ParseDetails other
)
Visual C++
public:
virtual bool Equals(
    ParseDetails^ other
) sealed

Parameters

other
Type: RedGate.SQLCompare.Engine.ReadFromFolder.Cache..::.ParseDetails

Implements

IEquatableEquals(UTP)

See Also

ParseDetails Class
Equals Overload
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
ParseDetails..::.GetHashCode Method
ParseDetails Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.Cache
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

See Also

ParseDetails Class
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


Inequality Operator

[image]

SQL Data Compare API 12.0.40
ParseDetails..::.Inequality Operator
ParseDetails Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.Cache
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <> ( _
    left As ParseDetails, _
    right As ParseDetails _
) As Boolean
C#
public static bool operator !=(
    ParseDetails left,
    ParseDetails right
)
Visual C++
public:
static bool operator !=(
    ParseDetails^ left,
    ParseDetails^ right
)

Parameters

left
Type: RedGate.SQLCompare.Engine.ReadFromFolder.Cache..::.ParseDetails
right
Type: RedGate.SQLCompare.Engine.ReadFromFolder.Cache..::.ParseDetails

See Also

ParseDetails Class
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


Serialize Method

[image]

SQL Data Compare API 12.0.40
ParseDetails..::.Serialize Method
ParseDetails Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.Cache
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Serialize ( _
    formatter As ISerializeFormatter _
)
C#
public void Serialize(
    ISerializeFormatter formatter
)
Visual C++
public:
virtual void Serialize(
    ISerializeFormatter^ formatter
) sealed

Parameters

formatter
Type: ISerializeFormatter

See Also

ParseDetails Class
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


ParseDetails Properties

[image] [image]

SQL Data Compare API 12.0.40
ParseDetails Properties
ParseDetails Class See Also

The ParseDetails type exposes the following properties.

Properties

Name | Description
Version |

See Also

ParseDetails Class
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


Version Property

[image]

SQL Data Compare API 12.0.40
ParseDetails..::.Version Property
ParseDetails Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.Cache
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As Integer
C#
public int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () sealed;
}

See Also

ParseDetails Class
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


PersistentReadFromFolderCache Class

[image]

SQL Data Compare API 12.0.40
PersistentReadFromFolderCache Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.Cache
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class PersistentReadFromFolderCache _
    Implements IReadFromFolderCache, IDisposable
C#
public class PersistentReadFromFolderCache : IReadFromFolderCache,
    IDisposable
Visual C++
public ref class PersistentReadFromFolderCache : IReadFromFolderCache,
    IDisposable

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder.Cache..::.PersistentReadFromFolderCache

See Also

PersistentReadFromFolderCache Members
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


PersistentReadFromFolderCache Members

[image] [image]

SQL Data Compare API 12.0.40
PersistentReadFromFolderCache Members
PersistentReadFromFolderCache Class Constructors Methods Properties See Also

The PersistentReadFromFolderCache type exposes the following members.

Constructors

Name | Description
PersistentReadFromFolderCache |

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ParseFile |
PersistMetadata |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CacheFolderLocation |

See Also

PersistentReadFromFolderCache Class
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


PersistentReadFromFolderCache Constructor

[image]

SQL Data Compare API 12.0.40
PersistentReadFromFolderCache Constructor
PersistentReadFromFolderCache Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.Cache
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    astCacheFile As String, _
    cachedParsesFile As String, _
    maxFileSizeInMB As Integer _
)
C#
public PersistentReadFromFolderCache(
    string astCacheFile,
    string cachedParsesFile,
    int maxFileSizeInMB
)
Visual C++
public:
PersistentReadFromFolderCache(
    String^ astCacheFile,
    String^ cachedParsesFile,
    int maxFileSizeInMB
)

Parameters

astCacheFile
Type: String
cachedParsesFile
Type: String
maxFileSizeInMB
Type: Int32

See Also

PersistentReadFromFolderCache Class
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


PersistentReadFromFolderCache Methods

[image] [image]

SQL Data Compare API 12.0.40
PersistentReadFromFolderCache Methods
PersistentReadFromFolderCache Class See Also

The PersistentReadFromFolderCache type exposes the following methods.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ParseFile |
PersistMetadata |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PersistentReadFromFolderCache Class
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


Dispose Method

[image]

SQL Data Compare API 12.0.40
PersistentReadFromFolderCache..::.Dispose Method
PersistentReadFromFolderCache Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.Cache
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose
C#
public void Dispose()
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposableDispose()()()

See Also

PersistentReadFromFolderCache Class
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


ParseFile Method

[image]

SQL Data Compare API 12.0.40
PersistentReadFromFolderCache..::.ParseFile Method
PersistentReadFromFolderCache Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.Cache
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function ParseFile ( _
    fileInfo As FileInfo, _
    lazyFileContents As LazyFileContents, _
    lexerOptions As LexerOptions _
) As ParseResult
C#
public ParseResult ParseFile(
    FileInfo fileInfo,
    LazyFileContents lazyFileContents,
    LexerOptions lexerOptions
)
Visual C++
public:
virtual ParseResult^ ParseFile(
    FileInfo^ fileInfo,
    LazyFileContents^ lazyFileContents,
    LexerOptions lexerOptions
) sealed

Parameters

fileInfo
Type: FileInfo
lazyFileContents
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.LazyFileContents
lexerOptions
Type: LexerOptions

Implements

IReadFromFolderCache..::.ParseFile(FileInfo, LazyFileContents, LexerOptions)

See Also

PersistentReadFromFolderCache Class
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


PersistMetadata Method

[image]

SQL Data Compare API 12.0.40
PersistentReadFromFolderCache..::.PersistMetadata Method
PersistentReadFromFolderCache Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.Cache
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PersistMetadata
C#
public void PersistMetadata()
Visual C++
public:
virtual void PersistMetadata() sealed

Implements

IReadFromFolderCache..::.PersistMetadata()()()

See Also

PersistentReadFromFolderCache Class
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


PersistentReadFromFolderCache Properties

[image] [image]

SQL Data Compare API 12.0.40
PersistentReadFromFolderCache Properties
PersistentReadFromFolderCache Class See Also

The PersistentReadFromFolderCache type exposes the following properties.

Properties

Name | Description
CacheFolderLocation |

See Also

PersistentReadFromFolderCache Class
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


CacheFolderLocation Property

[image]

SQL Data Compare API 12.0.40
PersistentReadFromFolderCache..::.CacheFolderLocation Property
PersistentReadFromFolderCache Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.Cache
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CacheFolderLocation As String
C#
public string CacheFolderLocation { get; }
Visual C++
public:
virtual property String^ CacheFolderLocation {
    String^ get () sealed;
}

Implements

IReadFromFolderCache..::.CacheFolderLocation

See Also

PersistentReadFromFolderCache Class
RedGate.SQLCompare.Engine.ReadFromFolder.Cache Namespace


RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace

Classes

Class | Description
DatabaseProjectFile | Represents a SQL Server Data Tools project file
DataBaseProjectItem |
DataToolsProject |
FileBasedProject |

Interfaces

Interface | Description
IAssemblyMetadata |
IDatabaseProject |
IDatabaseProjectFile |
IDatabaseProjectFolder |
IDatabaseProjectItem |
IDataToolsProject |


DatabaseProjectFile Class

[image]

SQL Data Compare API 12.0.40
DatabaseProjectFile Class
Members See Also

Represents a SQL Server Data Tools project file

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class DatabaseProjectFile _
    Inherits DataBaseProjectItem _
    Implements IDatabaseProjectFile, IDatabaseProjectItem
C#
public class DatabaseProjectFile : DataBaseProjectItem, IDatabaseProjectFile,
    IDatabaseProjectItem
Visual C++
public ref class DatabaseProjectFile : public DataBaseProjectItem,
    IDatabaseProjectFile, IDatabaseProjectItem

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.DataBaseProjectItem
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.DatabaseProjectFile

See Also

DatabaseProjectFile Members
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


DatabaseProjectFile Members

[image] [image]

SQL Data Compare API 12.0.40
DatabaseProjectFile Members
DatabaseProjectFile Class Constructors Methods Properties See Also

The DatabaseProjectFile type exposes the following members.

Constructors

Name | Description
DatabaseProjectFile | Overloaded.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from DataBaseProjectItem.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AbsolutePath | (Inherited from DataBaseProjectItem.)
FileSize |
RelativePath | (Inherited from DataBaseProjectItem.)
RootPath | (Inherited from DataBaseProjectItem.)

See Also

DatabaseProjectFile Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


DatabaseProjectFile Constructor

[image] [image]

SQL Data Compare API 12.0.40
DatabaseProjectFile Constructor
DatabaseProjectFile Class See Also

Overload List

Name | Description
DatabaseProjectFile(String, FileInfo) |
DatabaseProjectFile(String, String) |

See Also

DatabaseProjectFile Class
DatabaseProjectFile Members
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


DatabaseProjectFile Constructor (, )

[image]

SQL Data Compare API 12.0.40
DatabaseProjectFile Constructor (, )
DatabaseProjectFile Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    rootFolder As String, _
    fileWithAbsolutePath As FileInfo _
)
C#
public DatabaseProjectFile(
    string rootFolder,
    FileInfo fileWithAbsolutePath
)
Visual C++
public:
DatabaseProjectFile(
    String^ rootFolder,
    FileInfo^ fileWithAbsolutePath
)

Parameters

rootFolder
Type: String
fileWithAbsolutePath
Type: FileInfo

See Also

DatabaseProjectFile Class
DatabaseProjectFile Overload
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


DatabaseProjectFile Constructor (, )

[image]

SQL Data Compare API 12.0.40
DatabaseProjectFile Constructor (, )
DatabaseProjectFile Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    rootFolder As String, _
    relativePath As String _
)
C#
public DatabaseProjectFile(
    string rootFolder,
    string relativePath
)
Visual C++
public:
DatabaseProjectFile(
    String^ rootFolder,
    String^ relativePath
)

Parameters

rootFolder
Type: String
relativePath
Type: String

See Also

DatabaseProjectFile Class
DatabaseProjectFile Overload
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


DatabaseProjectFile Properties

[image] [image]

SQL Data Compare API 12.0.40
DatabaseProjectFile Properties
DatabaseProjectFile Class See Also

The DatabaseProjectFile type exposes the following properties.

Properties

Name | Description
AbsolutePath | (Inherited from DataBaseProjectItem.)
FileSize |
RelativePath | (Inherited from DataBaseProjectItem.)
RootPath | (Inherited from DataBaseProjectItem.)

See Also

DatabaseProjectFile Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


FileSize Property

[image]

SQL Data Compare API 12.0.40
DatabaseProjectFile..::.FileSize Property
DatabaseProjectFile Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FileSize As Long
C#
public long FileSize { get; }
Visual C++
public:
property long long FileSize {
    long long get ();
}

See Also

DatabaseProjectFile Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


DataBaseProjectItem Class

[image]

SQL Data Compare API 12.0.40
DataBaseProjectItem Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class DataBaseProjectItem _
    Implements IDatabaseProjectItem
C#
public abstract class DataBaseProjectItem : IDatabaseProjectItem
Visual C++
public ref class DataBaseProjectItem abstract : IDatabaseProjectItem

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.DataBaseProjectItem
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.DatabaseProjectFile

See Also

DataBaseProjectItem Members
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


DataBaseProjectItem Members

[image] [image]

SQL Data Compare API 12.0.40
DataBaseProjectItem Members
DataBaseProjectItem Class Constructors Methods Properties See Also

The DataBaseProjectItem type exposes the following members.

Constructors

Name | Description
DataBaseProjectItem | Overloaded.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality |
Inequality |

Properties

Name | Description
AbsolutePath |
RelativePath |
RootPath |

See Also

DataBaseProjectItem Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


DataBaseProjectItem Constructor

[image] [image]

SQL Data Compare API 12.0.40
DataBaseProjectItem Constructor
DataBaseProjectItem Class See Also

Overload List

Name | Description
DataBaseProjectItem(String, FileSystemInfo, ItemType) |
DataBaseProjectItem(String, String, ItemType) |

See Also

DataBaseProjectItem Class
DataBaseProjectItem Members
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


DataBaseProjectItem Constructor (, , .)

[image]

SQL Data Compare API 12.0.40
DataBaseProjectItem Constructor (, , ..::.)
DataBaseProjectItem Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    rootFolder As String, _
    absolutePath As FileSystemInfo, _
    itemType As ItemType _
)
C#
protected DataBaseProjectItem(
    string rootFolder,
    FileSystemInfo absolutePath,
    ItemType itemType
)
Visual C++
protected:
DataBaseProjectItem(
    String^ rootFolder,
    FileSystemInfo^ absolutePath,
    ItemType itemType
)

Parameters

rootFolder
Type: String
absolutePath
Type: FileSystemInfo
itemType
Type: ItemType

See Also

DataBaseProjectItem Class
DataBaseProjectItem Overload
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


DataBaseProjectItem Constructor (, , .)

[image]

SQL Data Compare API 12.0.40
DataBaseProjectItem Constructor (, , ..::.)
DataBaseProjectItem Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    rootFolder As String, _
    relativePath As String, _
    itemType As ItemType _
)
C#
protected DataBaseProjectItem(
    string rootFolder,
    string relativePath,
    ItemType itemType
)
Visual C++
protected:
DataBaseProjectItem(
    String^ rootFolder,
    String^ relativePath,
    ItemType itemType
)

Parameters

rootFolder
Type: String
relativePath
Type: String
itemType
Type: ItemType

See Also

DataBaseProjectItem Class
DataBaseProjectItem Overload
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


DataBaseProjectItem Methods

[image] [image]

SQL Data Compare API 12.0.40
DataBaseProjectItem Methods
DataBaseProjectItem Class See Also

The DataBaseProjectItem type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality |
Inequality |

See Also

DataBaseProjectItem Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


Equality Operator

[image]

SQL Data Compare API 12.0.40
DataBaseProjectItem..::.Equality Operator
DataBaseProjectItem Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator = ( _
    left As DataBaseProjectItem, _
    right As DataBaseProjectItem _
) As Boolean
C#
public static bool operator ==(
    DataBaseProjectItem left,
    DataBaseProjectItem right
)
Visual C++
public:
static bool operator ==(
    DataBaseProjectItem^ left,
    DataBaseProjectItem^ right
)

Parameters

left
Type: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.DataBaseProjectItem
right
Type: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.DataBaseProjectItem

See Also

DataBaseProjectItem Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
DataBaseProjectItem..::.Equals Method
DataBaseProjectItem Class See Also

Overload List

Name | Description
Equals(Object) | (Overrides Object..::.Equals(Object).)
Equals(DataBaseProjectItem) |

See Also

DataBaseProjectItem Class
DataBaseProjectItem Members
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


Equals Method ()

[image]

SQL Data Compare API 12.0.40
DataBaseProjectItem..::.Equals Method ()
DataBaseProjectItem Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object

See Also

DataBaseProjectItem Class
Equals Overload
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


Equals Method (DataBaseProjectItem)

[image]

SQL Data Compare API 12.0.40
DataBaseProjectItem..::.Equals Method (DataBaseProjectItem)
DataBaseProjectItem Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Function Equals ( _
    other As DataBaseProjectItem _
) As Boolean
C#
protected bool Equals(
    DataBaseProjectItem other
)
Visual C++
protected:
bool Equals(
    DataBaseProjectItem^ other
)

Parameters

other
Type: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.DataBaseProjectItem

Remarks

["c:\folder", "file.sql"] != ["c:\", "folder\file.sql"]

See Also

DataBaseProjectItem Class
Equals Overload
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
DataBaseProjectItem..::.GetHashCode Method
DataBaseProjectItem Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

See Also

DataBaseProjectItem Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


Inequality Operator

[image]

SQL Data Compare API 12.0.40
DataBaseProjectItem..::.Inequality Operator
DataBaseProjectItem Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <> ( _
    left As DataBaseProjectItem, _
    right As DataBaseProjectItem _
) As Boolean
C#
public static bool operator !=(
    DataBaseProjectItem left,
    DataBaseProjectItem right
)
Visual C++
public:
static bool operator !=(
    DataBaseProjectItem^ left,
    DataBaseProjectItem^ right
)

Parameters

left
Type: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.DataBaseProjectItem
right
Type: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.DataBaseProjectItem

See Also

DataBaseProjectItem Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


DataBaseProjectItem Properties

[image] [image]

SQL Data Compare API 12.0.40
DataBaseProjectItem Properties
DataBaseProjectItem Class See Also

The DataBaseProjectItem type exposes the following properties.

Properties

Name | Description
AbsolutePath |
RelativePath |
RootPath |

See Also

DataBaseProjectItem Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


AbsolutePath Property

[image]

SQL Data Compare API 12.0.40
DataBaseProjectItem..::.AbsolutePath Property
DataBaseProjectItem Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AbsolutePath As String
C#
public string AbsolutePath { get; private set; }
Visual C++
public:
virtual property String^ AbsolutePath {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IDatabaseProjectItem..::.AbsolutePath

See Also

DataBaseProjectItem Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


RelativePath Property

[image]

SQL Data Compare API 12.0.40
DataBaseProjectItem..::.RelativePath Property
DataBaseProjectItem Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RelativePath As String
C#
public string RelativePath { get; private set; }
Visual C++
public:
virtual property String^ RelativePath {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IDatabaseProjectItem..::.RelativePath

See Also

DataBaseProjectItem Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


RootPath Property

[image]

SQL Data Compare API 12.0.40
DataBaseProjectItem..::.RootPath Property
DataBaseProjectItem Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RootPath As String
C#
public string RootPath { get; private set; }
Visual C++
public:
virtual property String^ RootPath {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IDatabaseProjectItem..::.RootPath

See Also

DataBaseProjectItem Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


DataToolsProject Class

[image]

SQL Data Compare API 12.0.40
DataToolsProject Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class DataToolsProject _
    Inherits FileBasedProject _
    Implements IDataToolsProject, IDatabaseProject, IDisposable
C#
public class DataToolsProject : FileBasedProject, IDataToolsProject,
    IDatabaseProject, IDisposable
Visual C++
public ref class DataToolsProject : public FileBasedProject,
    IDataToolsProject, IDatabaseProject, IDisposable

Inheritance Hierarchy

Object
RedGate.Shared.Utils..::.DisposableBase
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.FileBasedProject
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.DataToolsProject

See Also

DataToolsProject Members
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


DataToolsProject Members

[image] [image]

SQL Data Compare API 12.0.40
DataToolsProject Members
DataToolsProject Class Methods Properties See Also

The DataToolsProject type exposes the following members.

Methods

Name | Description
AddAssembly |
AddFile | (Inherited from FileBasedProject.)
AddFolder | (Inherited from FileBasedProject.)
AddItem | (Inherited from FileBasedProject.)
AddParentDirectoriesUpToRootPath | (Inherited from FileBasedProject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetItemGroupForType | (Inherited from FileBasedProject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueValueForBuildPropertyItem | (Inherited from FileBasedProject.)
ItemGroupsContainingType | (Inherited from FileBasedProject.)
ItemsOfType | (Inherited from FileBasedProject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RemoveAssembly |
RemoveFile | (Inherited from FileBasedProject.)
RemoveItem | (Inherited from FileBasedProject.)
Save | (Inherited from FileBasedProject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryGetAssemblyMetadata |
TryGetFoldersFromSqlProj | Reads the sqlproj in the given folder
TryGetSqlFilesFromSqlProj | Reads the sqlproj in the given folder
TryLoadFromFile |
TryLoadFromFolder |
TryLoadFromFolderOrAbove |

Properties

Name | Description
ClrFiles |
DefaultFileStructure |
FileName |
IsDisposed | Returns a value indicating if this instance has been disposed. (Inherited from DisposableBase.)
ProjectFiles | (Inherited from FileBasedProject.)
ProjectFolders | (Inherited from FileBasedProject.)

See Also

DataToolsProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


DataToolsProject Methods

[image] [image]

SQL Data Compare API 12.0.40
DataToolsProject Methods
DataToolsProject Class See Also

The DataToolsProject type exposes the following methods.

Methods

Name | Description
AddAssembly |
AddFile | (Inherited from FileBasedProject.)
AddFolder | (Inherited from FileBasedProject.)
AddItem | (Inherited from FileBasedProject.)
AddParentDirectoriesUpToRootPath | (Inherited from FileBasedProject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetItemGroupForType | (Inherited from FileBasedProject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueValueForBuildPropertyItem | (Inherited from FileBasedProject.)
ItemGroupsContainingType | (Inherited from FileBasedProject.)
ItemsOfType | (Inherited from FileBasedProject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RemoveAssembly |
RemoveFile | (Inherited from FileBasedProject.)
RemoveItem | (Inherited from FileBasedProject.)
Save | (Inherited from FileBasedProject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryGetAssemblyMetadata |
TryGetFoldersFromSqlProj | Reads the sqlproj in the given folder
TryGetSqlFilesFromSqlProj | Reads the sqlproj in the given folder
TryLoadFromFile |
TryLoadFromFolder |
TryLoadFromFolderOrAbove |

See Also

DataToolsProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


AddAssembly Method

[image]

SQL Data Compare API 12.0.40
DataToolsProject..::.AddAssembly Method
DataToolsProject Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddAssembly ( _
    file As IDatabaseProjectFile, _
    metadata As IAssemblyMetadata _
)
C#
public void AddAssembly(
    IDatabaseProjectFile file,
    IAssemblyMetadata metadata
)
Visual C++
public:
virtual void AddAssembly(
    IDatabaseProjectFile^ file,
    IAssemblyMetadata^ metadata
) sealed

Parameters

file
Type: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.IDatabaseProjectFile
metadata
Type: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.IAssemblyMetadata

Implements

IDataToolsProject..::.AddAssembly(IDatabaseProjectFile, IAssemblyMetadata)

See Also

DataToolsProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


Dispose Method

[image] [image]

SQL Data Compare API 12.0.40
DataToolsProject..::.Dispose Method
DataToolsProject Class See Also

Overload List

Name | Description
Dispose()()() | (Inherited from DisposableBase.)
Dispose(Boolean) | (Inherited from FileBasedProject.)

See Also

DataToolsProject Class
DataToolsProject Members
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


RemoveAssembly Method

[image]

SQL Data Compare API 12.0.40
DataToolsProject..::.RemoveAssembly Method
DataToolsProject Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveAssembly ( _
    databaseProjectFile As IDatabaseProjectFile _
)
C#
public void RemoveAssembly(
    IDatabaseProjectFile databaseProjectFile
)
Visual C++
public:
virtual void RemoveAssembly(
    IDatabaseProjectFile^ databaseProjectFile
) sealed

Parameters

databaseProjectFile
Type: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.IDatabaseProjectFile

Implements

IDataToolsProject..::.RemoveAssembly(IDatabaseProjectFile)

See Also

DataToolsProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


TryGetAssemblyMetadata Method

[image]

SQL Data Compare API 12.0.40
DataToolsProject..::.TryGetAssemblyMetadata Method
DataToolsProject Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function TryGetAssemblyMetadata ( _
    databaseProjectFile As IDatabaseProjectFile, _
    <OutAttribute> ByRef metadata As IAssemblyMetadata _
) As Boolean
C#
public bool TryGetAssemblyMetadata(
    IDatabaseProjectFile databaseProjectFile,
    out IAssemblyMetadata metadata
)
Visual C++
public:
bool TryGetAssemblyMetadata(
    IDatabaseProjectFile^ databaseProjectFile,
    [OutAttribute] IAssemblyMetadata^% metadata
)

Parameters

databaseProjectFile
Type: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.IDatabaseProjectFile
metadata
Type: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.IAssemblyMetadata %

See Also

DataToolsProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


TryGetFoldersFromSqlProj Method

[image]

SQL Data Compare API 12.0.40
DataToolsProject..::.TryGetFoldersFromSqlProj Method
DataToolsProject Class See Also

Reads the sqlproj in the given folder

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function TryGetFoldersFromSqlProj ( _
    projectFolderPath As String, _
    <OutAttribute> ByRef folders As IEnumerable(Of IDatabaseProjectFolder) _
) As Boolean
C#
public static bool TryGetFoldersFromSqlProj(
    string projectFolderPath,
    out IEnumerable<IDatabaseProjectFolder> folders
)
Visual C++
public:
static bool TryGetFoldersFromSqlProj(
    String^ projectFolderPath,
    [OutAttribute] IEnumerable<IDatabaseProjectFolder^>^% folders
)

Parameters

projectFolderPath
Type: String
folders
Type: IEnumerable<(Of <( IDatabaseProjectFolder >)>)%

Return Value

A list of folders marked as Folder Include

See Also

DataToolsProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


TryGetSqlFilesFromSqlProj Method

[image]

SQL Data Compare API 12.0.40
DataToolsProject..::.TryGetSqlFilesFromSqlProj Method
DataToolsProject Class See Also

Reads the sqlproj in the given folder

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function TryGetSqlFilesFromSqlProj ( _
    projectFolderPath As String, _
    <OutAttribute> ByRef files As IEnumerable(Of IDatabaseProjectFile) _
) As Boolean
C#
public static bool TryGetSqlFilesFromSqlProj(
    string projectFolderPath,
    out IEnumerable<IDatabaseProjectFile> files
)
Visual C++
public:
static bool TryGetSqlFilesFromSqlProj(
    String^ projectFolderPath,
    [OutAttribute] IEnumerable<IDatabaseProjectFile^>^% files
)

Parameters

projectFolderPath
Type: String
files
Type: IEnumerable<(Of <( IDatabaseProjectFile >)>)%

Return Value

A list of sql files marked as build

See Also

DataToolsProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


TryLoadFromFile Method

[image]

SQL Data Compare API 12.0.40
DataToolsProject..::.TryLoadFromFile Method
DataToolsProject Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function TryLoadFromFile ( _
    sqlprojFullPath As FileInfo, _
    <OutAttribute> ByRef project As DataToolsProject _
) As Boolean
C#
public static bool TryLoadFromFile(
    FileInfo sqlprojFullPath,
    out DataToolsProject project
)
Visual C++
public:
static bool TryLoadFromFile(
    FileInfo^ sqlprojFullPath,
    [OutAttribute] DataToolsProject^% project
)

Parameters

sqlprojFullPath
Type: FileInfo
project
Type: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.DataToolsProject %

See Also

DataToolsProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


TryLoadFromFolder Method

[image]

SQL Data Compare API 12.0.40
DataToolsProject..::.TryLoadFromFolder Method
DataToolsProject Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function TryLoadFromFolder ( _
    directory As DirectoryInfo, _
    <OutAttribute> ByRef project As DataToolsProject _
) As Boolean
C#
public static bool TryLoadFromFolder(
    DirectoryInfo directory,
    out DataToolsProject project
)
Visual C++
public:
static bool TryLoadFromFolder(
    DirectoryInfo^ directory,
    [OutAttribute] DataToolsProject^% project
)

Parameters

directory
Type: DirectoryInfo
project
Type: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.DataToolsProject %

See Also

DataToolsProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


TryLoadFromFolderOrAbove Method

[image]

SQL Data Compare API 12.0.40
DataToolsProject..::.TryLoadFromFolderOrAbove Method
DataToolsProject Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function TryLoadFromFolderOrAbove ( _
    directory As DirectoryInfo, _
    <OutAttribute> ByRef project As DataToolsProject _
) As Boolean
C#
public static bool TryLoadFromFolderOrAbove(
    DirectoryInfo directory,
    out DataToolsProject project
)
Visual C++
public:
static bool TryLoadFromFolderOrAbove(
    DirectoryInfo^ directory,
    [OutAttribute] DataToolsProject^% project
)

Parameters

directory
Type: DirectoryInfo
project
Type: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.DataToolsProject %

See Also

DataToolsProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


DataToolsProject Properties

[image] [image]

SQL Data Compare API 12.0.40
DataToolsProject Properties
DataToolsProject Class See Also

The DataToolsProject type exposes the following properties.

Properties

Name | Description
ClrFiles |
DefaultFileStructure |
FileName |
IsDisposed | Returns a value indicating if this instance has been disposed. (Inherited from DisposableBase.)
ProjectFiles | (Inherited from FileBasedProject.)
ProjectFolders | (Inherited from FileBasedProject.)

See Also

DataToolsProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


ClrFiles Property

[image]

SQL Data Compare API 12.0.40
DataToolsProject..::.ClrFiles Property
DataToolsProject Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClrFiles As IEnumerable(Of IDatabaseProjectFile)
C#
public IEnumerable<IDatabaseProjectFile> ClrFiles { get; }
Visual C++
public:
virtual property IEnumerable<IDatabaseProjectFile^>^ ClrFiles {
    IEnumerable<IDatabaseProjectFile^>^ get () sealed;
}

Implements

IDataToolsProject..::.ClrFiles

See Also

DataToolsProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


DefaultFileStructure Property

[image]

SQL Data Compare API 12.0.40
DataToolsProject..::.DefaultFileStructure Property
DataToolsProject Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DefaultFileStructure As DefaultFileStructure
C#
public DefaultFileStructure DefaultFileStructure { get; }
Visual C++
public:
virtual property DefaultFileStructure DefaultFileStructure {
    DefaultFileStructure get () sealed;
}

Implements

IDataToolsProject..::.DefaultFileStructure

See Also

DataToolsProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


FileName Property

[image]

SQL Data Compare API 12.0.40
DataToolsProject..::.FileName Property
DataToolsProject Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FileName As String
C#
public string FileName { get; }
Visual C++
public:
virtual property String^ FileName {
    String^ get () sealed;
}

Implements

IDataToolsProject..::.FileName

See Also

DataToolsProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


FileBasedProject Class

[image]

SQL Data Compare API 12.0.40
FileBasedProject Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class FileBasedProject _
    Inherits DisposableBase _
    Implements IDatabaseProject, IDisposable
C#
public abstract class FileBasedProject : DisposableBase, IDatabaseProject,
    IDisposable
Visual C++
public ref class FileBasedProject abstract : public DisposableBase,
    IDatabaseProject, IDisposable

Inheritance Hierarchy

Object
RedGate.Shared.Utils..::.DisposableBase
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.FileBasedProject
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.DataToolsProject

See Also

FileBasedProject Members
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


FileBasedProject Members

[image] [image]

SQL Data Compare API 12.0.40
FileBasedProject Members
FileBasedProject Class Constructors Methods Properties See Also

The FileBasedProject type exposes the following members.

Constructors

Name | Description
FileBasedProject |

Methods

Name | Description
AddFile |
AddFolder |
AddItem |
AddParentDirectoriesUpToRootPath |
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetItemGroupForType |
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueValueForBuildPropertyItem |
ItemGroupsContainingType |
ItemsOfType |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RemoveFile |
RemoveItem |
Save |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDisposed | Returns a value indicating if this instance has been disposed. (Inherited from DisposableBase.)
ProjectFiles |
ProjectFolders |

See Also

FileBasedProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


FileBasedProject Constructor

[image]

SQL Data Compare API 12.0.40
FileBasedProject Constructor
FileBasedProject Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    originalFilePath As String, _
    projectFileGroupName As String _
)
C#
protected FileBasedProject(
    string originalFilePath,
    string projectFileGroupName
)
Visual C++
protected:
FileBasedProject(
    String^ originalFilePath,
    String^ projectFileGroupName
)

Parameters

originalFilePath
Type: String
projectFileGroupName
Type: String

See Also

FileBasedProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


FileBasedProject Methods

[image] [image]

SQL Data Compare API 12.0.40
FileBasedProject Methods
FileBasedProject Class See Also

The FileBasedProject type exposes the following methods.

Methods

Name | Description
AddFile |
AddFolder |
AddItem |
AddParentDirectoriesUpToRootPath |
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetItemGroupForType |
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueValueForBuildPropertyItem |
ItemGroupsContainingType |
ItemsOfType |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RemoveFile |
RemoveItem |
Save |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileBasedProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


AddFile Method

[image]

SQL Data Compare API 12.0.40
FileBasedProject..::.AddFile Method
FileBasedProject Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddFile ( _
    file As IDatabaseProjectFile _
)
C#
public void AddFile(
    IDatabaseProjectFile file
)
Visual C++
public:
virtual void AddFile(
    IDatabaseProjectFile^ file
) sealed

Parameters

file
Type: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.IDatabaseProjectFile

Implements

IDatabaseProject..::.AddFile(IDatabaseProjectFile)

See Also

FileBasedProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


AddFolder Method

[image]

SQL Data Compare API 12.0.40
FileBasedProject..::.AddFolder Method
FileBasedProject Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddFolder ( _
    folder As IDatabaseProjectFolder _
)
C#
public void AddFolder(
    IDatabaseProjectFolder folder
)
Visual C++
public:
virtual void AddFolder(
    IDatabaseProjectFolder^ folder
) sealed

Parameters

folder
Type: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.IDatabaseProjectFolder

Implements

IDatabaseProject..::.AddFolder(IDatabaseProjectFolder)

See Also

FileBasedProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


AddItem Method

[image]

SQL Data Compare API 12.0.40
FileBasedProject..::.AddItem Method
FileBasedProject Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Function AddItem ( _
    itemName As String, _
    overrideFileGroup As String _
) As BuildItem
C#
protected BuildItem AddItem(
    string itemName,
    string overrideFileGroup
)
Visual C++
protected:
BuildItem^ AddItem(
    String^ itemName,
    String^ overrideFileGroup
)

Parameters

itemName
Type: String
overrideFileGroup
Type: String

See Also

FileBasedProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


AddParentDirectoriesUpToRootPath Method

[image]

SQL Data Compare API 12.0.40
FileBasedProject..::.AddParentDirectoriesUpToRootPath Method
FileBasedProject Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub AddParentDirectoriesUpToRootPath ( _
    file As IDatabaseProjectFile _
)
C#
protected void AddParentDirectoriesUpToRootPath(
    IDatabaseProjectFile file
)
Visual C++
protected:
void AddParentDirectoriesUpToRootPath(
    IDatabaseProjectFile^ file
)

Parameters

file
Type: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.IDatabaseProjectFile

See Also

FileBasedProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


Dispose Method

[image] [image]

SQL Data Compare API 12.0.40
FileBasedProject..::.Dispose Method
FileBasedProject Class See Also

Overload List

Name | Description
Dispose()()() | (Inherited from DisposableBase.)
Dispose(Boolean) | (Overrides DisposableBase ..::. Dispose(Boolean).)

See Also

FileBasedProject Class
FileBasedProject Members
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


Dispose Method ()

[image]

SQL Data Compare API 12.0.40
FileBasedProject..::.Dispose Method ()
FileBasedProject Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
C#
protected override void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: Boolean

See Also

FileBasedProject Class
Dispose Overload
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


GetItemGroupForType Method

[image]

SQL Data Compare API 12.0.40
FileBasedProject..::.GetItemGroupForType Method
FileBasedProject Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetItemGroupForType ( _
    groupType As String _
) As BuildItemGroup
C#
protected BuildItemGroup GetItemGroupForType(
    string groupType
)
Visual C++
protected:
BuildItemGroup^ GetItemGroupForType(
    String^ groupType
)

Parameters

groupType
Type: String

Return Value

The first item group containing an object of groupType, or a new item group if no such group exists.

See Also

FileBasedProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


GetUniqueValueForBuildPropertyItem Method

[image]

SQL Data Compare API 12.0.40
FileBasedProject..::.GetUniqueValueForBuildPropertyItem Method
FileBasedProject Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetUniqueValueForBuildPropertyItem ( _
    buildPropertyName As String _
) As String
C#
protected string GetUniqueValueForBuildPropertyItem(
    string buildPropertyName
)
Visual C++
protected:
String^ GetUniqueValueForBuildPropertyItem(
    String^ buildPropertyName
)

Parameters

buildPropertyName
Type: String

See Also

FileBasedProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


ItemGroupsContainingType Method

[image]

SQL Data Compare API 12.0.40
FileBasedProject..::.ItemGroupsContainingType Method
FileBasedProject Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Function ItemGroupsContainingType ( _
    groupType As String _
) As IEnumerable(Of BuildItemGroup)
C#
protected IEnumerable<BuildItemGroup> ItemGroupsContainingType(
    string groupType
)
Visual C++
protected:
IEnumerable<BuildItemGroup^>^ ItemGroupsContainingType(
    String^ groupType
)

Parameters

groupType
Type: String

See Also

FileBasedProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


ItemsOfType Method

[image]

SQL Data Compare API 12.0.40
FileBasedProject..::.ItemsOfType Method
FileBasedProject Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Function ItemsOfType ( _
    groupType As String _
) As IEnumerable(Of BuildItem)
C#
protected IEnumerable<BuildItem> ItemsOfType(
    string groupType
)
Visual C++
protected:
IEnumerable<BuildItem^>^ ItemsOfType(
    String^ groupType
)

Parameters

groupType
Type: String

See Also

FileBasedProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


RemoveFile Method

[image]

SQL Data Compare API 12.0.40
FileBasedProject..::.RemoveFile Method
FileBasedProject Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveFile ( _
    databaseProjectFile As IDatabaseProjectFile _
)
C#
public void RemoveFile(
    IDatabaseProjectFile databaseProjectFile
)
Visual C++
public:
virtual void RemoveFile(
    IDatabaseProjectFile^ databaseProjectFile
) sealed

Parameters

databaseProjectFile
Type: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.IDatabaseProjectFile

Implements

IDatabaseProject..::.RemoveFile(IDatabaseProjectFile)

See Also

FileBasedProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


RemoveItem Method

[image]

SQL Data Compare API 12.0.40
FileBasedProject..::.RemoveItem Method
FileBasedProject Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RemoveItem ( _
    itemName As String, _
    overrideFileGroup As String _
)
C#
protected void RemoveItem(
    string itemName,
    string overrideFileGroup
)
Visual C++
protected:
void RemoveItem(
    String^ itemName,
    String^ overrideFileGroup
)

Parameters

itemName
Type: String
overrideFileGroup
Type: String

See Also

FileBasedProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


Save Method

[image]

SQL Data Compare API 12.0.40
FileBasedProject..::.Save Method
FileBasedProject Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Save
C#
public void Save()
Visual C++
public:
virtual void Save() sealed

Implements

IDatabaseProject..::.Save()()()

See Also

FileBasedProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


FileBasedProject Properties

[image] [image]

SQL Data Compare API 12.0.40
FileBasedProject Properties
FileBasedProject Class See Also

The FileBasedProject type exposes the following properties.

Properties

Name | Description
IsDisposed | Returns a value indicating if this instance has been disposed. (Inherited from DisposableBase.)
ProjectFiles |
ProjectFolders |

See Also

FileBasedProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


ProjectFiles Property

[image]

SQL Data Compare API 12.0.40
FileBasedProject..::.ProjectFiles Property
FileBasedProject Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProjectFiles As IEnumerable(Of IDatabaseProjectFile)
C#
public IEnumerable<IDatabaseProjectFile> ProjectFiles { get; }
Visual C++
public:
virtual property IEnumerable<IDatabaseProjectFile^>^ ProjectFiles {
    IEnumerable<IDatabaseProjectFile^>^ get () sealed;
}

Implements

IDatabaseProject..::.ProjectFiles

See Also

FileBasedProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


ProjectFolders Property

[image]

SQL Data Compare API 12.0.40
FileBasedProject..::.ProjectFolders Property
FileBasedProject Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProjectFolders As IEnumerable(Of IDatabaseProjectFolder)
C#
public IEnumerable<IDatabaseProjectFolder> ProjectFolders { get; }
Visual C++
public:
virtual property IEnumerable<IDatabaseProjectFolder^>^ ProjectFolders {
    IEnumerable<IDatabaseProjectFolder^>^ get () sealed;
}

Implements

IDatabaseProject..::.ProjectFolders

See Also

FileBasedProject Class
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


IAssemblyMetadata Interface

[image]

SQL Data Compare API 12.0.40
IAssemblyMetadata Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IAssemblyMetadata
C#
public interface IAssemblyMetadata
Visual C++
public interface class IAssemblyMetadata

See Also

IAssemblyMetadata Members
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


IAssemblyMetadata Members

[image] [image]

SQL Data Compare API 12.0.40
IAssemblyMetadata Members
IAssemblyMetadata Interface Properties See Also

The IAssemblyMetadata type exposes the following members.

Properties

Name | Description
CLRName | The CLR name of the assembly.
Owner | The owner of the assembly.
PermissionSet | The code access permission for the CLR assembly.

See Also

IAssemblyMetadata Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


IAssemblyMetadata Properties

[image] [image]

SQL Data Compare API 12.0.40
IAssemblyMetadata Properties
IAssemblyMetadata Interface See Also

The IAssemblyMetadata type exposes the following properties.

Properties

Name | Description
CLRName | The CLR name of the assembly.
Owner | The owner of the assembly.
PermissionSet | The code access permission for the CLR assembly.

See Also

IAssemblyMetadata Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


CLRName Property

[image]

SQL Data Compare API 12.0.40
IAssemblyMetadata..::.CLRName Property
IAssemblyMetadata Interface See Also

The CLR name of the assembly.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CLRName As String
C#
string CLRName { get; }
Visual C++
property String^ CLRName {
    String^ get ();
}

See Also

IAssemblyMetadata Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
IAssemblyMetadata..::.Owner Property
IAssemblyMetadata Interface See Also

The owner of the assembly.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Owner As String
C#
string Owner { get; }
Visual C++
property String^ Owner {
    String^ get ();
}

See Also

IAssemblyMetadata Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


PermissionSet Property

[image]

SQL Data Compare API 12.0.40
IAssemblyMetadata..::.PermissionSet Property
IAssemblyMetadata Interface See Also

The code access permission for the CLR assembly.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property PermissionSet As PermissionSet
C#
PermissionSet PermissionSet { get; }
Visual C++
property PermissionSet PermissionSet {
    PermissionSet get ();
}

See Also

IAssemblyMetadata Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


IDatabaseProject Interface

[image]

SQL Data Compare API 12.0.40
IDatabaseProject Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDatabaseProject _
    Implements IDisposable
C#
public interface IDatabaseProject : IDisposable
Visual C++
public interface class IDatabaseProject : IDisposable

See Also

IDatabaseProject Members
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


IDatabaseProject Members

[image] [image]

SQL Data Compare API 12.0.40
IDatabaseProject Members
IDatabaseProject Interface Methods Properties See Also

The IDatabaseProject type exposes the following members.

Methods

Name | Description
AddFile |
AddFolder |
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
RemoveFile |
Save |

Properties

Name | Description
ProjectFiles |
ProjectFolders |

See Also

IDatabaseProject Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


IDatabaseProject Methods

[image] [image]

SQL Data Compare API 12.0.40
IDatabaseProject Methods
IDatabaseProject Interface See Also

The IDatabaseProject type exposes the following methods.

Methods

Name | Description
AddFile |
AddFolder |
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
RemoveFile |
Save |

See Also

IDatabaseProject Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


AddFile Method

[image]

SQL Data Compare API 12.0.40
IDatabaseProject..::.AddFile Method
IDatabaseProject Interface See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub AddFile ( _
    file As IDatabaseProjectFile _
)
C#
void AddFile(
    IDatabaseProjectFile file
)
Visual C++
void AddFile(
    IDatabaseProjectFile^ file
)

Parameters

file
Type: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.IDatabaseProjectFile

See Also

IDatabaseProject Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


AddFolder Method

[image]

SQL Data Compare API 12.0.40
IDatabaseProject..::.AddFolder Method
IDatabaseProject Interface See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub AddFolder ( _
    folder As IDatabaseProjectFolder _
)
C#
void AddFolder(
    IDatabaseProjectFolder folder
)
Visual C++
void AddFolder(
    IDatabaseProjectFolder^ folder
)

Parameters

folder
Type: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.IDatabaseProjectFolder

See Also

IDatabaseProject Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


RemoveFile Method

[image]

SQL Data Compare API 12.0.40
IDatabaseProject..::.RemoveFile Method
IDatabaseProject Interface See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub RemoveFile ( _
    databaseProjectFile As IDatabaseProjectFile _
)
C#
void RemoveFile(
    IDatabaseProjectFile databaseProjectFile
)
Visual C++
void RemoveFile(
    IDatabaseProjectFile^ databaseProjectFile
)

Parameters

databaseProjectFile
Type: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.IDatabaseProjectFile

See Also

IDatabaseProject Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


Save Method

[image]

SQL Data Compare API 12.0.40
IDatabaseProject..::.Save Method
IDatabaseProject Interface See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub Save
C#
void Save()
Visual C++
void Save()

See Also

IDatabaseProject Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


IDatabaseProject Properties

[image] [image]

SQL Data Compare API 12.0.40
IDatabaseProject Properties
IDatabaseProject Interface See Also

The IDatabaseProject type exposes the following properties.

Properties

Name | Description
ProjectFiles |
ProjectFolders |

See Also

IDatabaseProject Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


ProjectFiles Property

[image]

SQL Data Compare API 12.0.40
IDatabaseProject..::.ProjectFiles Property
IDatabaseProject Interface See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ProjectFiles As IEnumerable(Of IDatabaseProjectFile)
C#
IEnumerable<IDatabaseProjectFile> ProjectFiles { get; }
Visual C++
property IEnumerable<IDatabaseProjectFile^>^ ProjectFiles {
    IEnumerable<IDatabaseProjectFile^>^ get ();
}

See Also

IDatabaseProject Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


ProjectFolders Property

[image]

SQL Data Compare API 12.0.40
IDatabaseProject..::.ProjectFolders Property
IDatabaseProject Interface See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ProjectFolders As IEnumerable(Of IDatabaseProjectFolder)
C#
IEnumerable<IDatabaseProjectFolder> ProjectFolders { get; }
Visual C++
property IEnumerable<IDatabaseProjectFolder^>^ ProjectFolders {
    IEnumerable<IDatabaseProjectFolder^>^ get ();
}

See Also

IDatabaseProject Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


IDatabaseProjectFile Interface

[image]

SQL Data Compare API 12.0.40
IDatabaseProjectFile Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDatabaseProjectFile _
    Implements IDatabaseProjectItem
C#
public interface IDatabaseProjectFile : IDatabaseProjectItem
Visual C++
public interface class IDatabaseProjectFile : IDatabaseProjectItem

See Also

IDatabaseProjectFile Members
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


IDatabaseProjectFile Members

[image] [image]

SQL Data Compare API 12.0.40
IDatabaseProjectFile Members
IDatabaseProjectFile Interface Properties See Also

The IDatabaseProjectFile type exposes the following members.

Properties

Name | Description
AbsolutePath | (Inherited from IDatabaseProjectItem.)
RelativePath | (Inherited from IDatabaseProjectItem.)
RootPath | (Inherited from IDatabaseProjectItem.)

See Also

IDatabaseProjectFile Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


IDatabaseProjectFolder Interface

[image]

SQL Data Compare API 12.0.40
IDatabaseProjectFolder Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDatabaseProjectFolder _
    Implements IDatabaseProjectItem
C#
public interface IDatabaseProjectFolder : IDatabaseProjectItem
Visual C++
public interface class IDatabaseProjectFolder : IDatabaseProjectItem

See Also

IDatabaseProjectFolder Members
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


IDatabaseProjectFolder Members

[image] [image]

SQL Data Compare API 12.0.40
IDatabaseProjectFolder Members
IDatabaseProjectFolder Interface Properties See Also

The IDatabaseProjectFolder type exposes the following members.

Properties

Name | Description
AbsolutePath | (Inherited from IDatabaseProjectItem.)
RelativePath | (Inherited from IDatabaseProjectItem.)
RootPath | (Inherited from IDatabaseProjectItem.)

See Also

IDatabaseProjectFolder Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


IDatabaseProjectItem Interface

[image]

SQL Data Compare API 12.0.40
IDatabaseProjectItem Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDatabaseProjectItem
C#
public interface IDatabaseProjectItem
Visual C++
public interface class IDatabaseProjectItem

See Also

IDatabaseProjectItem Members
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


IDatabaseProjectItem Members

[image] [image]

SQL Data Compare API 12.0.40
IDatabaseProjectItem Members
IDatabaseProjectItem Interface Properties See Also

The IDatabaseProjectItem type exposes the following members.

Properties

Name | Description
AbsolutePath |
RelativePath |
RootPath |

See Also

IDatabaseProjectItem Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


IDatabaseProjectItem Properties

[image] [image]

SQL Data Compare API 12.0.40
IDatabaseProjectItem Properties
IDatabaseProjectItem Interface See Also

The IDatabaseProjectItem type exposes the following properties.

Properties

Name | Description
AbsolutePath |
RelativePath |
RootPath |

See Also

IDatabaseProjectItem Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


AbsolutePath Property

[image]

SQL Data Compare API 12.0.40
IDatabaseProjectItem..::.AbsolutePath Property
IDatabaseProjectItem Interface See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property AbsolutePath As String
C#
string AbsolutePath { get; }
Visual C++
property String^ AbsolutePath {
    String^ get ();
}

See Also

IDatabaseProjectItem Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


RelativePath Property

[image]

SQL Data Compare API 12.0.40
IDatabaseProjectItem..::.RelativePath Property
IDatabaseProjectItem Interface See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property RelativePath As String
C#
string RelativePath { get; }
Visual C++
property String^ RelativePath {
    String^ get ();
}

See Also

IDatabaseProjectItem Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


RootPath Property

[image]

SQL Data Compare API 12.0.40
IDatabaseProjectItem..::.RootPath Property
IDatabaseProjectItem Interface See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property RootPath As String
C#
string RootPath { get; }
Visual C++
property String^ RootPath {
    String^ get ();
}

See Also

IDatabaseProjectItem Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


IDataToolsProject Interface

[image]

SQL Data Compare API 12.0.40
IDataToolsProject Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDataToolsProject _
    Implements IDatabaseProject, IDisposable
C#
public interface IDataToolsProject : IDatabaseProject,
    IDisposable
Visual C++
public interface class IDataToolsProject : IDatabaseProject,
    IDisposable

See Also

IDataToolsProject Members
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


IDataToolsProject Members

[image] [image]

SQL Data Compare API 12.0.40
IDataToolsProject Members
IDataToolsProject Interface Methods Properties See Also

The IDataToolsProject type exposes the following members.

Methods

Name | Description
AddAssembly |
AddFile | (Inherited from IDatabaseProject.)
AddFolder | (Inherited from IDatabaseProject.)
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
RemoveAssembly |
RemoveFile | (Inherited from IDatabaseProject.)
Save | (Inherited from IDatabaseProject.)

Properties

Name | Description
ClrFiles |
DefaultFileStructure |
FileName |
ProjectFiles | (Inherited from IDatabaseProject.)
ProjectFolders | (Inherited from IDatabaseProject.)

See Also

IDataToolsProject Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


IDataToolsProject Methods

[image] [image]

SQL Data Compare API 12.0.40
IDataToolsProject Methods
IDataToolsProject Interface See Also

The IDataToolsProject type exposes the following methods.

Methods

Name | Description
AddAssembly |
AddFile | (Inherited from IDatabaseProject.)
AddFolder | (Inherited from IDatabaseProject.)
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
RemoveAssembly |
RemoveFile | (Inherited from IDatabaseProject.)
Save | (Inherited from IDatabaseProject.)

See Also

IDataToolsProject Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


AddAssembly Method

[image]

SQL Data Compare API 12.0.40
IDataToolsProject..::.AddAssembly Method
IDataToolsProject Interface See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub AddAssembly ( _
    file As IDatabaseProjectFile, _
    metadata As IAssemblyMetadata _
)
C#
void AddAssembly(
    IDatabaseProjectFile file,
    IAssemblyMetadata metadata
)
Visual C++
void AddAssembly(
    IDatabaseProjectFile^ file,
    IAssemblyMetadata^ metadata
)

Parameters

file
Type: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.IDatabaseProjectFile
metadata
Type: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.IAssemblyMetadata

See Also

IDataToolsProject Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


RemoveAssembly Method

[image]

SQL Data Compare API 12.0.40
IDataToolsProject..::.RemoveAssembly Method
IDataToolsProject Interface See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub RemoveAssembly ( _
    databaseProjectFile As IDatabaseProjectFile _
)
C#
void RemoveAssembly(
    IDatabaseProjectFile databaseProjectFile
)
Visual C++
void RemoveAssembly(
    IDatabaseProjectFile^ databaseProjectFile
)

Parameters

databaseProjectFile
Type: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.IDatabaseProjectFile

See Also

IDataToolsProject Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


IDataToolsProject Properties

[image] [image]

SQL Data Compare API 12.0.40
IDataToolsProject Properties
IDataToolsProject Interface See Also

The IDataToolsProject type exposes the following properties.

Properties

Name | Description
ClrFiles |
DefaultFileStructure |
FileName |
ProjectFiles | (Inherited from IDatabaseProject.)
ProjectFolders | (Inherited from IDatabaseProject.)

See Also

IDataToolsProject Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


ClrFiles Property

[image]

SQL Data Compare API 12.0.40
IDataToolsProject..::.ClrFiles Property
IDataToolsProject Interface See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ClrFiles As IEnumerable(Of IDatabaseProjectFile)
C#
IEnumerable<IDatabaseProjectFile> ClrFiles { get; }
Visual C++
property IEnumerable<IDatabaseProjectFile^>^ ClrFiles {
    IEnumerable<IDatabaseProjectFile^>^ get ();
}

See Also

IDataToolsProject Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


DefaultFileStructure Property

[image]

SQL Data Compare API 12.0.40
IDataToolsProject..::.DefaultFileStructure Property
IDataToolsProject Interface See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DefaultFileStructure As DefaultFileStructure
C#
DefaultFileStructure DefaultFileStructure { get; }
Visual C++
property DefaultFileStructure DefaultFileStructure {
    DefaultFileStructure get ();
}

See Also

IDataToolsProject Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


FileName Property

[image]

SQL Data Compare API 12.0.40
IDataToolsProject..::.FileName Property
IDataToolsProject Interface See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property FileName As String
C#
string FileName { get; }
Visual C++
property String^ FileName {
    String^ get ();
}

See Also

IDataToolsProject Interface
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace

Classes

Class | Description
ByObjectPathChooser |
BySchemaPathChooser |
BySchemaThenObjectPathChooser |
DefaultFileStructureParser |
FileNameGeneratorBase |
FileNameGeneratorFactory |
FolderChooser |
PathChooserBase |

Interfaces

Interface | Description
IFileNameGenerator | Used to generate file names for new objects (to handle file name collisions)
IIdealPathChooser |
ISqlFileCollection |

Enumerations

Enumeration | Description
DefaultFileStructure |


ByObjectPathChooser Class

[image]

SQL Data Compare API 12.0.40
ByObjectPathChooser Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ByObjectPathChooser _
    Inherits PathChooserBase
C#
public class ByObjectPathChooser : PathChooserBase
Visual C++
public ref class ByObjectPathChooser : public PathChooserBase

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser..::.PathChooserBase
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser..::.ByObjectPathChooser

See Also

ByObjectPathChooser Members
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


ByObjectPathChooser Members

[image] [image]

SQL Data Compare API 12.0.40
ByObjectPathChooser Members
ByObjectPathChooser Class Constructors Methods See Also

The ByObjectPathChooser type exposes the following members.

Constructors

Name | Description
ByObjectPathChooser |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetIdealFilenameInner | (Overrides PathChooserBase ..::. GetIdealFilenameInner(IDatabaseObject, String).)
GetIdealPath | (Inherited from PathChooserBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ByObjectPathChooser Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


ByObjectPathChooser Constructor

[image]

SQL Data Compare API 12.0.40
ByObjectPathChooser Constructor
ByObjectPathChooser Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ByObjectPathChooser()
Visual C++
public:
ByObjectPathChooser()

See Also

ByObjectPathChooser Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


ByObjectPathChooser Methods

[image] [image]

SQL Data Compare API 12.0.40
ByObjectPathChooser Methods
ByObjectPathChooser Class See Also

The ByObjectPathChooser type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetIdealFilenameInner | (Overrides PathChooserBase ..::. GetIdealFilenameInner(IDatabaseObject, String).)
GetIdealPath | (Inherited from PathChooserBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ByObjectPathChooser Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


GetIdealFilenameInner Method

[image]

SQL Data Compare API 12.0.40
ByObjectPathChooser..::.GetIdealFilenameInner Method
ByObjectPathChooser Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetIdealFilenameInner ( _
    dbObject As IDatabaseObject, _
    dotExtension As String _
) As String
C#
protected override string GetIdealFilenameInner(
    IDatabaseObject dbObject,
    string dotExtension
)
Visual C++
protected:
virtual String^ GetIdealFilenameInner(
    IDatabaseObject^ dbObject,
    String^ dotExtension
) override

Parameters

dbObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
dotExtension
Type: String

See Also

ByObjectPathChooser Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


BySchemaPathChooser Class

[image]

SQL Data Compare API 12.0.40
BySchemaPathChooser Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class BySchemaPathChooser _
    Inherits PathChooserBase
C#
public class BySchemaPathChooser : PathChooserBase
Visual C++
public ref class BySchemaPathChooser : public PathChooserBase

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser..::.PathChooserBase
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser..::.BySchemaPathChooser

See Also

BySchemaPathChooser Members
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


BySchemaPathChooser Members

[image] [image]

SQL Data Compare API 12.0.40
BySchemaPathChooser Members
BySchemaPathChooser Class Constructors Methods See Also

The BySchemaPathChooser type exposes the following members.

Constructors

Name | Description
BySchemaPathChooser |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetIdealFilenameInner | (Overrides PathChooserBase ..::. GetIdealFilenameInner(IDatabaseObject, String).)
GetIdealPath | (Inherited from PathChooserBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BySchemaPathChooser Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


BySchemaPathChooser Constructor

[image]

SQL Data Compare API 12.0.40
BySchemaPathChooser Constructor
BySchemaPathChooser Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BySchemaPathChooser()
Visual C++
public:
BySchemaPathChooser()

See Also

BySchemaPathChooser Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


BySchemaPathChooser Methods

[image] [image]

SQL Data Compare API 12.0.40
BySchemaPathChooser Methods
BySchemaPathChooser Class See Also

The BySchemaPathChooser type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetIdealFilenameInner | (Overrides PathChooserBase ..::. GetIdealFilenameInner(IDatabaseObject, String).)
GetIdealPath | (Inherited from PathChooserBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BySchemaPathChooser Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


GetIdealFilenameInner Method

[image]

SQL Data Compare API 12.0.40
BySchemaPathChooser..::.GetIdealFilenameInner Method
BySchemaPathChooser Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetIdealFilenameInner ( _
    dbObject As IDatabaseObject, _
    dotExtension As String _
) As String
C#
protected override string GetIdealFilenameInner(
    IDatabaseObject dbObject,
    string dotExtension
)
Visual C++
protected:
virtual String^ GetIdealFilenameInner(
    IDatabaseObject^ dbObject,
    String^ dotExtension
) override

Parameters

dbObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
dotExtension
Type: String

See Also

BySchemaPathChooser Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


BySchemaThenObjectPathChooser Class

[image]

SQL Data Compare API 12.0.40
BySchemaThenObjectPathChooser Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class BySchemaThenObjectPathChooser _
    Inherits PathChooserBase
C#
public class BySchemaThenObjectPathChooser : PathChooserBase
Visual C++
public ref class BySchemaThenObjectPathChooser : public PathChooserBase

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser..::.PathChooserBase
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser..::.BySchemaThenObjectPathChooser

See Also

BySchemaThenObjectPathChooser Members
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


BySchemaThenObjectPathChooser Members

[image] [image]

SQL Data Compare API 12.0.40
BySchemaThenObjectPathChooser Members
BySchemaThenObjectPathChooser Class Constructors Methods See Also

The BySchemaThenObjectPathChooser type exposes the following members.

Constructors

Name | Description
BySchemaThenObjectPathChooser |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetIdealFilenameInner | (Overrides PathChooserBase ..::. GetIdealFilenameInner(IDatabaseObject, String).)
GetIdealPath | (Inherited from PathChooserBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BySchemaThenObjectPathChooser Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


BySchemaThenObjectPathChooser Constructor

[image]

SQL Data Compare API 12.0.40
BySchemaThenObjectPathChooser Constructor
BySchemaThenObjectPathChooser Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BySchemaThenObjectPathChooser()
Visual C++
public:
BySchemaThenObjectPathChooser()

See Also

BySchemaThenObjectPathChooser Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


BySchemaThenObjectPathChooser Methods

[image] [image]

SQL Data Compare API 12.0.40
BySchemaThenObjectPathChooser Methods
BySchemaThenObjectPathChooser Class See Also

The BySchemaThenObjectPathChooser type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetIdealFilenameInner | (Overrides PathChooserBase ..::. GetIdealFilenameInner(IDatabaseObject, String).)
GetIdealPath | (Inherited from PathChooserBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BySchemaThenObjectPathChooser Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


GetIdealFilenameInner Method

[image]

SQL Data Compare API 12.0.40
BySchemaThenObjectPathChooser..::.GetIdealFilenameInner Method
BySchemaThenObjectPathChooser Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetIdealFilenameInner ( _
    dbObject As IDatabaseObject, _
    dotExtension As String _
) As String
C#
protected override string GetIdealFilenameInner(
    IDatabaseObject dbObject,
    string dotExtension
)
Visual C++
protected:
virtual String^ GetIdealFilenameInner(
    IDatabaseObject^ dbObject,
    String^ dotExtension
) override

Parameters

dbObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
dotExtension
Type: String

See Also

BySchemaThenObjectPathChooser Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


DefaultFileStructure Enumeration

[image]

SQL Data Compare API 12.0.40
DefaultFileStructure Enumeration
See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration DefaultFileStructure
C#
public enum DefaultFileStructure
Visual C++
public enum class DefaultFileStructure

Members

Member name | Description
Legacy |
None |
BySchema |
ByObjectType |
BySchemaThenObjectType |

See Also

RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


DefaultFileStructureParser Class

[image]

SQL Data Compare API 12.0.40
DefaultFileStructureParser Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DefaultFileStructureParser
C#
public static class DefaultFileStructureParser
Visual C++
public ref class DefaultFileStructureParser abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser..::.DefaultFileStructureParser

See Also

DefaultFileStructureParser Members
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


DefaultFileStructureParser Members

[image] [image]

SQL Data Compare API 12.0.40
DefaultFileStructureParser Members
DefaultFileStructureParser Class Methods See Also

The DefaultFileStructureParser type exposes the following members.

Methods

Name | Description
Parse |

See Also

DefaultFileStructureParser Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


DefaultFileStructureParser Methods

[image] [image]

SQL Data Compare API 12.0.40
DefaultFileStructureParser Methods
DefaultFileStructureParser Class See Also

The DefaultFileStructureParser type exposes the following methods.

Methods

Name | Description
Parse |

See Also

DefaultFileStructureParser Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


Parse Method

[image]

SQL Data Compare API 12.0.40
DefaultFileStructureParser..::.Parse Method
DefaultFileStructureParser Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Parse ( _
    valueForElement As String _
) As DefaultFileStructure
C#
public static DefaultFileStructure Parse(
    string valueForElement
)
Visual C++
public:
static DefaultFileStructure Parse(
    String^ valueForElement
)

Parameters

valueForElement
Type: String

See Also

DefaultFileStructureParser Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


FileNameGeneratorBase Class

[image]

SQL Data Compare API 12.0.40
FileNameGeneratorBase Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class FileNameGeneratorBase _
    Implements IFileNameGenerator
C#
public abstract class FileNameGeneratorBase : IFileNameGenerator
Visual C++
public ref class FileNameGeneratorBase abstract : IFileNameGenerator

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser..::.FileNameGeneratorBase

See Also

FileNameGeneratorBase Members
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


FileNameGeneratorBase Members

[image] [image]

SQL Data Compare API 12.0.40
FileNameGeneratorBase Members
FileNameGeneratorBase Class Constructors Methods See Also

The FileNameGeneratorBase type exposes the following members.

Constructors

Name | Description
FileNameGeneratorBase |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFileNameForObjectToScript | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectName |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RemoveNastyBitsOfFileName | Returns a legal and unproblematic version of a file name
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileNameGeneratorBase Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


FileNameGeneratorBase Constructor

[image]

SQL Data Compare API 12.0.40
FileNameGeneratorBase Constructor
FileNameGeneratorBase Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected FileNameGeneratorBase()
Visual C++
protected:
FileNameGeneratorBase()

See Also

FileNameGeneratorBase Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


FileNameGeneratorBase Methods

[image] [image]

SQL Data Compare API 12.0.40
FileNameGeneratorBase Methods
FileNameGeneratorBase Class See Also

The FileNameGeneratorBase type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFileNameForObjectToScript | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectName |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RemoveNastyBitsOfFileName | Returns a legal and unproblematic version of a file name
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileNameGeneratorBase Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


GetFileNameForObjectToScript Method

[image] [image]

SQL Data Compare API 12.0.40
FileNameGeneratorBase..::.GetFileNameForObjectToScript Method
FileNameGeneratorBase Class See Also

Overload List

Name | Description
GetFileNameForObjectToScript(String, IDatabaseObject, String, IDictionary<(Of <(String, ScriptSynchronizationAction>)>), String) |
GetFileNameForObjectToScript(String, String, String, Predicate<(Of <(String>)>), String) |

See Also

FileNameGeneratorBase Class
FileNameGeneratorBase Members
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


GetFileNameForObjectToScript Method (, IDatabaseObject, , (, ScriptSynchronizationAction), )

[image]

SQL Data Compare API 12.0.40
FileNameGeneratorBase..::.GetFileNameForObjectToScript Method (, IDatabaseObject, , <(Of <(, ScriptSynchronizationAction>)>), )
FileNameGeneratorBase Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetFileNameForObjectToScript ( _
    folderPath As String, _
    obj As IDatabaseObject, _
    objectPrefix As String, _
    actionsCollection As IDictionary(Of String, ScriptSynchronizationAction), _
    dotExtension As String _
) As FileInfo
C#
public FileInfo GetFileNameForObjectToScript(
    string folderPath,
    IDatabaseObject obj,
    string objectPrefix,
    IDictionary<string, ScriptSynchronizationAction> actionsCollection,
    string dotExtension
)
Visual C++
public:
virtual FileInfo^ GetFileNameForObjectToScript(
    String^ folderPath,
    IDatabaseObject^ obj,
    String^ objectPrefix,
    IDictionary<String^, ScriptSynchronizationAction^>^ actionsCollection,
    String^ dotExtension
) sealed

Parameters

folderPath
Type: String
obj
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
objectPrefix
Type: String
actionsCollection
Type: IDictionary<(Of <(String, ScriptSynchronizationAction >)>)
dotExtension
Type: String

Implements

IFileNameGenerator..::.GetFileNameForObjectToScript(String, IDatabaseObject, String, IDictionary<(Of <(String, ScriptSynchronizationAction>)>), String)

See Also

FileNameGeneratorBase Class
GetFileNameForObjectToScript Overload
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


GetFileNameForObjectToScript Method (, , , (), )

[image]

SQL Data Compare API 12.0.40
FileNameGeneratorBase..::.GetFileNameForObjectToScript Method (, , , <(Of <(>)>), )
FileNameGeneratorBase Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetFileNameForObjectToScript ( _
    folderPath As String, _
    objectPrefix As String, _
    objectName As String, _
    inUseByDifferentObject As Predicate(Of String), _
    dotExtension As String _
) As FileInfo
C#
protected abstract FileInfo GetFileNameForObjectToScript(
    string folderPath,
    string objectPrefix,
    string objectName,
    Predicate<string> inUseByDifferentObject,
    string dotExtension
)
Visual C++
protected:
virtual FileInfo^ GetFileNameForObjectToScript(
    String^ folderPath,
    String^ objectPrefix,
    String^ objectName,
    Predicate<String^>^ inUseByDifferentObject,
    String^ dotExtension
) abstract

Parameters

folderPath
Type: String
objectPrefix
Type: String
objectName
Type: String
inUseByDifferentObject
Type: Predicate<(Of <(String>)>)
dotExtension
Type: String

See Also

FileNameGeneratorBase Class
GetFileNameForObjectToScript Overload
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


GetObjectName Method

[image]

SQL Data Compare API 12.0.40
FileNameGeneratorBase..::.GetObjectName Method
FileNameGeneratorBase Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetObjectName ( _
    obj As IDatabaseObject _
) As String
C#
protected static string GetObjectName(
    IDatabaseObject obj
)
Visual C++
protected:
static String^ GetObjectName(
    IDatabaseObject^ obj
)

Parameters

obj
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject

See Also

FileNameGeneratorBase Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


RemoveNastyBitsOfFileName Method

[image]

SQL Data Compare API 12.0.40
FileNameGeneratorBase..::.RemoveNastyBitsOfFileName Method
FileNameGeneratorBase Class See Also

Returns a legal and unproblematic version of a file name

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function RemoveNastyBitsOfFileName ( _
    name As String _
) As String
C#
protected static string RemoveNastyBitsOfFileName(
    string name
)
Visual C++
protected:
static String^ RemoveNastyBitsOfFileName(
    String^ name
)

Parameters

name
Type: String
Nasty file name

Return Value

nice file name

See Also

FileNameGeneratorBase Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


FileNameGeneratorFactory Class

[image]

SQL Data Compare API 12.0.40
FileNameGeneratorFactory Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FileNameGeneratorFactory
C#
public static class FileNameGeneratorFactory
Visual C++
public ref class FileNameGeneratorFactory abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser..::.FileNameGeneratorFactory

See Also

FileNameGeneratorFactory Members
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


FileNameGeneratorFactory Members

[image] [image]

SQL Data Compare API 12.0.40
FileNameGeneratorFactory Members
FileNameGeneratorFactory Class Methods See Also

The FileNameGeneratorFactory type exposes the following members.

Methods

Name | Description
CreateFromDatabase |

See Also

FileNameGeneratorFactory Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


FileNameGeneratorFactory Methods

[image] [image]

SQL Data Compare API 12.0.40
FileNameGeneratorFactory Methods
FileNameGeneratorFactory Class See Also

The FileNameGeneratorFactory type exposes the following methods.

Methods

Name | Description
CreateFromDatabase |

See Also

FileNameGeneratorFactory Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


CreateFromDatabase Method

[image]

SQL Data Compare API 12.0.40
FileNameGeneratorFactory..::.CreateFromDatabase Method
FileNameGeneratorFactory Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateFromDatabase ( _
    targetScriptsFolderDatabase As IDatabase _
) As IFileNameGenerator
C#
public static IFileNameGenerator CreateFromDatabase(
    IDatabase targetScriptsFolderDatabase
)
Visual C++
public:
static IFileNameGenerator^ CreateFromDatabase(
    IDatabase^ targetScriptsFolderDatabase
)

Parameters

targetScriptsFolderDatabase
Type: RedGate.SQLCompare.Engine..::.IDatabase

See Also

FileNameGeneratorFactory Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


FolderChooser Class

[image]

SQL Data Compare API 12.0.40
FolderChooser Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FolderChooser
C#
public static class FolderChooser
Visual C++
public ref class FolderChooser abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser..::.FolderChooser

See Also

FolderChooser Members
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


FolderChooser Members

[image] [image]

SQL Data Compare API 12.0.40
FolderChooser Members
FolderChooser Class Methods See Also

The FolderChooser type exposes the following members.

Methods

Name | Description
GetDefaultFolder |

See Also

FolderChooser Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


FolderChooser Methods

[image] [image]

SQL Data Compare API 12.0.40
FolderChooser Methods
FolderChooser Class See Also

The FolderChooser type exposes the following methods.

Methods

Name | Description
GetDefaultFolder |

See Also

FolderChooser Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


GetDefaultFolder Method

[image]

SQL Data Compare API 12.0.40
FolderChooser..::.GetDefaultFolder Method
FolderChooser Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDefaultFolder ( _
    objectType As ObjectType _
) As String
C#
public static string GetDefaultFolder(
    ObjectType objectType
)
Visual C++
public:
static String^ GetDefaultFolder(
    ObjectType objectType
)

Parameters

objectType
Type: ObjectType

See Also

FolderChooser Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


IFileNameGenerator Interface

[image]

SQL Data Compare API 12.0.40
IFileNameGenerator Interface
Members See Also

Used to generate file names for new objects (to handle file name collisions)

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IFileNameGenerator
C#
public interface IFileNameGenerator
Visual C++
public interface class IFileNameGenerator

See Also

IFileNameGenerator Members
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


IFileNameGenerator Members

[image] [image]

SQL Data Compare API 12.0.40
IFileNameGenerator Members
IFileNameGenerator Interface Methods See Also

The IFileNameGenerator type exposes the following members.

Methods

Name | Description
GetFileNameForObjectToScript |

See Also

IFileNameGenerator Interface
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


IFileNameGenerator Methods

[image] [image]

SQL Data Compare API 12.0.40
IFileNameGenerator Methods
IFileNameGenerator Interface See Also

The IFileNameGenerator type exposes the following methods.

Methods

Name | Description
GetFileNameForObjectToScript |

See Also

IFileNameGenerator Interface
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


GetFileNameForObjectToScript Method

[image]

SQL Data Compare API 12.0.40
IFileNameGenerator..::.GetFileNameForObjectToScript Method
IFileNameGenerator Interface See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetFileNameForObjectToScript ( _
    folderPath As String, _
    obj As IDatabaseObject, _
    objectPrefix As String, _
    actionsCollection As IDictionary(Of String, ScriptSynchronizationAction), _
    dotExtension As String _
) As FileInfo
C#
FileInfo GetFileNameForObjectToScript(
    string folderPath,
    IDatabaseObject obj,
    string objectPrefix,
    IDictionary<string, ScriptSynchronizationAction> actionsCollection,
    string dotExtension
)
Visual C++
FileInfo^ GetFileNameForObjectToScript(
    String^ folderPath,
    IDatabaseObject^ obj,
    String^ objectPrefix,
    IDictionary<String^, ScriptSynchronizationAction^>^ actionsCollection,
    String^ dotExtension
)

Parameters

folderPath
Type: String
obj
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
objectPrefix
Type: String
actionsCollection
Type: IDictionary<(Of <(String, ScriptSynchronizationAction >)>)
dotExtension
Type: String
File extension with leading dot

See Also

IFileNameGenerator Interface
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


IIdealPathChooser Interface

[image]

SQL Data Compare API 12.0.40
IIdealPathChooser Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IIdealPathChooser
C#
public interface IIdealPathChooser
Visual C++
public interface class IIdealPathChooser

See Also

IIdealPathChooser Members
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


IIdealPathChooser Members

[image] [image]

SQL Data Compare API 12.0.40
IIdealPathChooser Members
IIdealPathChooser Interface Methods See Also

The IIdealPathChooser type exposes the following members.

Methods

Name | Description
GetIdealPath |

See Also

IIdealPathChooser Interface
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


IIdealPathChooser Methods

[image] [image]

SQL Data Compare API 12.0.40
IIdealPathChooser Methods
IIdealPathChooser Interface See Also

The IIdealPathChooser type exposes the following methods.

Methods

Name | Description
GetIdealPath |

See Also

IIdealPathChooser Interface
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


GetIdealPath Method

[image]

SQL Data Compare API 12.0.40
IIdealPathChooser..::.GetIdealPath Method
IIdealPathChooser Interface See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetIdealPath ( _
    dbObject As IDatabaseObject, _
    dotExtension As String _
) As String
C#
string GetIdealPath(
    IDatabaseObject dbObject,
    string dotExtension
)
Visual C++
String^ GetIdealPath(
    IDatabaseObject^ dbObject,
    String^ dotExtension
)

Parameters

dbObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The object whose name is required
dotExtension
Type: String
The file extension to use with a preceding dot

Return Value

See Also

IIdealPathChooser Interface
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


ISqlFileCollection Interface

[image]

SQL Data Compare API 12.0.40
ISqlFileCollection Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISqlFileCollection
C#
public interface ISqlFileCollection
Visual C++
public interface class ISqlFileCollection

See Also

ISqlFileCollection Members
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


ISqlFileCollection Members

[image] [image]

SQL Data Compare API 12.0.40
ISqlFileCollection Members
ISqlFileCollection Interface Properties See Also

The ISqlFileCollection type exposes the following members.

Properties

Name | Description
ProjectFolderPath |
SqlFiles |

See Also

ISqlFileCollection Interface
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


ISqlFileCollection Properties

[image] [image]

SQL Data Compare API 12.0.40
ISqlFileCollection Properties
ISqlFileCollection Interface See Also

The ISqlFileCollection type exposes the following properties.

Properties

Name | Description
ProjectFolderPath |
SqlFiles |

See Also

ISqlFileCollection Interface
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


ProjectFolderPath Property

[image]

SQL Data Compare API 12.0.40
ISqlFileCollection..::.ProjectFolderPath Property
ISqlFileCollection Interface See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ProjectFolderPath As String
C#
string ProjectFolderPath { get; }
Visual C++
property String^ ProjectFolderPath {
    String^ get ();
}

See Also

ISqlFileCollection Interface
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


SqlFiles Property

[image]

SQL Data Compare API 12.0.40
ISqlFileCollection..::.SqlFiles Property
ISqlFileCollection Interface See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SqlFiles As IEnumerable(Of FileInfo)
C#
IEnumerable<FileInfo> SqlFiles { get; }
Visual C++
property IEnumerable<FileInfo^>^ SqlFiles {
    IEnumerable<FileInfo^>^ get ();
}

See Also

ISqlFileCollection Interface
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


PathChooserBase Class

[image]

SQL Data Compare API 12.0.40
PathChooserBase Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class PathChooserBase _
    Implements IIdealPathChooser
C#
public abstract class PathChooserBase : IIdealPathChooser
Visual C++
public ref class PathChooserBase abstract : IIdealPathChooser

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser..::.PathChooserBase
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser..::.ByObjectPathChooser
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser..::.BySchemaPathChooser
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser..::.BySchemaThenObjectPathChooser

See Also

PathChooserBase Members
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


PathChooserBase Members

[image] [image]

SQL Data Compare API 12.0.40
PathChooserBase Members
PathChooserBase Class Constructors Methods See Also

The PathChooserBase type exposes the following members.

Constructors

Name | Description
PathChooserBase |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetIdealFilenameInner |
GetIdealPath |
GetSanitizedFilename |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PathChooserBase Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


PathChooserBase Constructor

[image]

SQL Data Compare API 12.0.40
PathChooserBase Constructor
PathChooserBase Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected PathChooserBase()
Visual C++
protected:
PathChooserBase()

See Also

PathChooserBase Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


PathChooserBase Methods

[image] [image]

SQL Data Compare API 12.0.40
PathChooserBase Methods
PathChooserBase Class See Also

The PathChooserBase type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetIdealFilenameInner |
GetIdealPath |
GetSanitizedFilename |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PathChooserBase Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


GetIdealFilenameInner Method

[image]

SQL Data Compare API 12.0.40
PathChooserBase..::.GetIdealFilenameInner Method
PathChooserBase Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetIdealFilenameInner ( _
    dbObject As IDatabaseObject, _
    dotExtension As String _
) As String
C#
protected abstract string GetIdealFilenameInner(
    IDatabaseObject dbObject,
    string dotExtension
)
Visual C++
protected:
virtual String^ GetIdealFilenameInner(
    IDatabaseObject^ dbObject,
    String^ dotExtension
) abstract

Parameters

dbObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
dotExtension
Type: String

See Also

PathChooserBase Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


GetIdealPath Method

[image]

SQL Data Compare API 12.0.40
PathChooserBase..::.GetIdealPath Method
PathChooserBase Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetIdealPath ( _
    dbObject As IDatabaseObject, _
    dotExtension As String _
) As String
C#
public string GetIdealPath(
    IDatabaseObject dbObject,
    string dotExtension
)
Visual C++
public:
virtual String^ GetIdealPath(
    IDatabaseObject^ dbObject,
    String^ dotExtension
) sealed

Parameters

dbObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
dotExtension
Type: String

Implements

IIdealPathChooser..::.GetIdealPath(IDatabaseObject, String)

See Also

PathChooserBase Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


GetSanitizedFilename Method

[image]

SQL Data Compare API 12.0.40
PathChooserBase..::.GetSanitizedFilename Method
PathChooserBase Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetSanitizedFilename ( _
    dbObject As IDatabaseObject, _
    dotExtension As String _
) As String
C#
protected static string GetSanitizedFilename(
    IDatabaseObject dbObject,
    string dotExtension
)
Visual C++
protected:
static String^ GetSanitizedFilename(
    IDatabaseObject^ dbObject,
    String^ dotExtension
)

Parameters

dbObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
dotExtension
Type: String

See Also

PathChooserBase Class
RedGate.SQLCompare.Engine.ReadFromFolder.PathChooser Namespace


RedGate.SQLCompare.Engine.Registration.ModelFactory Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.Registration.ModelFactory Namespace

Interfaces

Interface | Description
IDatabaseFactory |


IDatabaseFactory Interface

[image]

SQL Data Compare API 12.0.40
IDatabaseFactory Interface
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ModelFactory
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDatabaseFactory
C#
public interface IDatabaseFactory
Visual C++
public interface class IDatabaseFactory

See Also

IDatabaseFactory Members
RedGate.SQLCompare.Engine.Registration.ModelFactory Namespace


IDatabaseFactory Members

[image] [image]

SQL Data Compare API 12.0.40
IDatabaseFactory Members
IDatabaseFactory Interface Methods Properties See Also

The IDatabaseFactory type exposes the following members.

Methods

Name | Description
LightWeightPopulate | This method populates part of the database based on the information in a live database. Mainly used for sql data compare. Note that dependencies are set, but their transitive closure is not calculated.
Populate | This method populates the entire database based on the information in a live database.
PopulateCaseInformationExternal | Mutate the database to set the case sensitivity properties
PopulateObjectOwners | This method populates only the objectOwners. This is for the refactoring tool!

Properties

Name | Description
DatabaseSource |

See Also

IDatabaseFactory Interface
RedGate.SQLCompare.Engine.Registration.ModelFactory Namespace


IDatabaseFactory Methods

[image] [image]

SQL Data Compare API 12.0.40
IDatabaseFactory Methods
IDatabaseFactory Interface See Also

The IDatabaseFactory type exposes the following methods.

Methods

Name | Description
LightWeightPopulate | This method populates part of the database based on the information in a live database. Mainly used for sql data compare. Note that dependencies are set, but their transitive closure is not calculated.
Populate | This method populates the entire database based on the information in a live database.
PopulateCaseInformationExternal | Mutate the database to set the case sensitivity properties
PopulateObjectOwners | This method populates only the objectOwners. This is for the refactoring tool!

See Also

IDatabaseFactory Interface
RedGate.SQLCompare.Engine.Registration.ModelFactory Namespace


LightWeightPopulate Method

[image]

SQL Data Compare API 12.0.40
IDatabaseFactory..::.LightWeightPopulate Method
IDatabaseFactory Interface See Also

This method populates part of the database based on the information in a live database. Mainly used for sql data compare. Note that dependencies are set, but their transitive closure is not calculated.

Namespace: RedGate.SQLCompare.Engine.Registration.ModelFactory
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub LightWeightPopulate ( _
    popOptions As DBPopulationOptions _
)
C#
void LightWeightPopulate(
    DBPopulationOptions popOptions
)
Visual C++
void LightWeightPopulate(
    DBPopulationOptions popOptions
)

Parameters

popOptions
Type: RedGate.SQLCompare.Engine..::.DBPopulationOptions

See Also

IDatabaseFactory Interface
RedGate.SQLCompare.Engine.Registration.ModelFactory Namespace


Populate Method

[image]

SQL Data Compare API 12.0.40
IDatabaseFactory..::.Populate Method
IDatabaseFactory Interface See Also

This method populates the entire database based on the information in a live database.

Namespace: RedGate.SQLCompare.Engine.Registration.ModelFactory
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub Populate ( _
    popOptions As DBPopulationOptions _
)
C#
void Populate(
    DBPopulationOptions popOptions
)
Visual C++
void Populate(
    DBPopulationOptions popOptions
)

Parameters

popOptions
Type: RedGate.SQLCompare.Engine..::.DBPopulationOptions
Population Options

See Also

IDatabaseFactory Interface
RedGate.SQLCompare.Engine.Registration.ModelFactory Namespace


PopulateCaseInformationExternal Method

[image]

SQL Data Compare API 12.0.40
IDatabaseFactory..::.PopulateCaseInformationExternal Method
IDatabaseFactory Interface See Also

Mutate the database to set the case sensitivity properties

Namespace: RedGate.SQLCompare.Engine.Registration.ModelFactory
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub PopulateCaseInformationExternal ( _
    connectionProperties As String _
)
C#
void PopulateCaseInformationExternal(
    string connectionProperties
)
Visual C++
void PopulateCaseInformationExternal(
    String^ connectionProperties
)

Parameters

connectionProperties
Type: String

See Also

IDatabaseFactory Interface
RedGate.SQLCompare.Engine.Registration.ModelFactory Namespace


PopulateObjectOwners Method

[image]

SQL Data Compare API 12.0.40
IDatabaseFactory..::.PopulateObjectOwners Method
IDatabaseFactory Interface See Also

This method populates only the objectOwners. This is for the refactoring tool!

Namespace: RedGate.SQLCompare.Engine.Registration.ModelFactory
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub PopulateObjectOwners
C#
void PopulateObjectOwners()
Visual C++
void PopulateObjectOwners()

See Also

IDatabaseFactory Interface
RedGate.SQLCompare.Engine.Registration.ModelFactory Namespace


IDatabaseFactory Properties

[image] [image]

SQL Data Compare API 12.0.40
IDatabaseFactory Properties
IDatabaseFactory Interface See Also

The IDatabaseFactory type exposes the following properties.

Properties

Name | Description
DatabaseSource |

See Also

IDatabaseFactory Interface
RedGate.SQLCompare.Engine.Registration.ModelFactory Namespace


DatabaseSource Property

[image]

SQL Data Compare API 12.0.40
IDatabaseFactory..::.DatabaseSource Property
IDatabaseFactory Interface See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ModelFactory
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DatabaseSource As DatabaseSource
C#
DatabaseSource DatabaseSource { get; }
Visual C++
property DatabaseSource DatabaseSource {
    DatabaseSource get ();
}

See Also

IDatabaseFactory Interface
RedGate.SQLCompare.Engine.Registration.ModelFactory Namespace


RedGate.SQLCompare.Engine.Registration.QueryResult Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace

Classes

Class | Description
AssemblyDependencyQueryResult |
AssemblyFileQueryResult |
AssemblyQueryResult |
AsymmetricKeyQueryResult |
CertificateQueryResult |
CommentQueryResult |
ConstraintQueryResult |
ContractMessageQueryResult |
ContractQueryResult |
DdlTriggerQueryResult |
DefaultQueryResult |
EventNotificationQueryResult |
ExpressionDependencyQueryResult |
ExtendedPropertyQueryResult |
FieldQueryResult |
FileTableSystemDefinedObjectQueryResult |
ForeignKeyQueryResult |
FullTextCatalogQueryResult |
FunctionQueryResult |
IndexQueryResult |
InvalidDmvQueryResultException | Exception raised when an error occurs while reading from the DMV queries
MessageTypeQueryResult |
ObjectNameQueryResult |
ParameterQueryResult |
PartitionFunctionQueryResult |
PartitionParameterQueryResult |
PartitionRangeValueSqlResult |
RoleQueryResult |
SecurityPolicyQueryResult |
SqlFeatureUsageResult | DMV result for FUR counts
SqlPartitionSchemeResult |
SqlPermissionResult |
SqlProcedureResult |
SqlQueueResult |
SqlRemoteServiceBindingResult |
SqlRoleResult |
SqlRouteResult |
SqlRuleResult |
SqlSchemasResult |
SqlSearchPropertyListResult |
SqlSequencesResult |
SqlServiceContractResult |
SqlServiceResult |
SqlSettingResult |
SqlStatisticsResult |
SqlStoplistResult |
SqlStopwordResult |
SqlSymmetricKeyResult |
SqlSynonymResult |
SqlTableResult |
SqlTableUdtResult |
SqlTriggerResult |
SqlUdtResult |
SqlUserResult |
SqlViewColumnWithDetailsResult |
SqlViewResult |
UdtDependencyResult |
XmlCollectionDependencyResult |
XmlCollectionResult |

Interfaces

Interface | Description
ICacheableQueryResult | Any DMV query result to be used in IDmvCache needs to implement this interface.


AssemblyDependencyQueryResult Class

[image]

SQL Data Compare API 12.0.40
AssemblyDependencyQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class AssemblyDependencyQueryResult
C#
public class AssemblyDependencyQueryResult
Visual C++
public ref class AssemblyDependencyQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.AssemblyDependencyQueryResult

See Also

AssemblyDependencyQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AssemblyDependencyQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
AssemblyDependencyQueryResult Members
AssemblyDependencyQueryResult Class Constructors Methods Properties See Also

The AssemblyDependencyQueryResult type exposes the following members.

Constructors

Name | Description
AssemblyDependencyQueryResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ReferencedAssembly |
ReferencingAssembly |

See Also

AssemblyDependencyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AssemblyDependencyQueryResult Constructor

[image]

SQL Data Compare API 12.0.40
AssemblyDependencyQueryResult Constructor
AssemblyDependencyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public AssemblyDependencyQueryResult()
Visual C++
public:
AssemblyDependencyQueryResult()

See Also

AssemblyDependencyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AssemblyDependencyQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
AssemblyDependencyQueryResult Properties
AssemblyDependencyQueryResult Class See Also

The AssemblyDependencyQueryResult type exposes the following properties.

Properties

Name | Description
ReferencedAssembly |
ReferencingAssembly |

See Also

AssemblyDependencyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ReferencedAssembly Property

[image]

SQL Data Compare API 12.0.40
AssemblyDependencyQueryResult..::.ReferencedAssembly Property
AssemblyDependencyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ReferencedAssembly As Integer
C#
public int ReferencedAssembly { get; set; }
Visual C++
public:
property int ReferencedAssembly {
    int get ();
    void set (int value);
}

See Also

AssemblyDependencyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ReferencingAssembly Property

[image]

SQL Data Compare API 12.0.40
AssemblyDependencyQueryResult..::.ReferencingAssembly Property
AssemblyDependencyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ReferencingAssembly As Integer
C#
public int ReferencingAssembly { get; set; }
Visual C++
public:
property int ReferencingAssembly {
    int get ();
    void set (int value);
}

See Also

AssemblyDependencyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AssemblyFileQueryResult Class

[image]

SQL Data Compare API 12.0.40
AssemblyFileQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class AssemblyFileQueryResult
C#
public class AssemblyFileQueryResult
Visual C++
public ref class AssemblyFileQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.AssemblyFileQueryResult

See Also

AssemblyFileQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AssemblyFileQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
AssemblyFileQueryResult Members
AssemblyFileQueryResult Class Constructors Methods Properties See Also

The AssemblyFileQueryResult type exposes the following members.

Constructors

Name | Description
AssemblyFileQueryResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AsmBytes |
AssemblyID |
FileID |
Name |

See Also

AssemblyFileQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AssemblyFileQueryResult Constructor

[image]

SQL Data Compare API 12.0.40
AssemblyFileQueryResult Constructor
AssemblyFileQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public AssemblyFileQueryResult()
Visual C++
public:
AssemblyFileQueryResult()

See Also

AssemblyFileQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AssemblyFileQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
AssemblyFileQueryResult Properties
AssemblyFileQueryResult Class See Also

The AssemblyFileQueryResult type exposes the following properties.

Properties

Name | Description
AsmBytes |
AssemblyID |
FileID |
Name |

See Also

AssemblyFileQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AsmBytes Property

[image]

SQL Data Compare API 12.0.40
AssemblyFileQueryResult..::.AsmBytes Property
AssemblyFileQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AsmBytes As Byte()
C#
public byte[] AsmBytes { get; set; }
Visual C++
public:
property array<unsigned char>^ AsmBytes {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

AssemblyFileQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AssemblyID Property

[image]

SQL Data Compare API 12.0.40
AssemblyFileQueryResult..::.AssemblyID Property
AssemblyFileQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyID As Integer
C#
public int AssemblyID { get; set; }
Visual C++
public:
property int AssemblyID {
    int get ();
    void set (int value);
}

See Also

AssemblyFileQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FileID Property

[image]

SQL Data Compare API 12.0.40
AssemblyFileQueryResult..::.FileID Property
AssemblyFileQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FileID As Integer
C#
public int FileID { get; set; }
Visual C++
public:
property int FileID {
    int get ();
    void set (int value);
}

See Also

AssemblyFileQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
AssemblyFileQueryResult..::.Name Property
AssemblyFileQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

AssemblyFileQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AssemblyQueryResult Class

[image]

SQL Data Compare API 12.0.40
AssemblyQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class AssemblyQueryResult
C#
public class AssemblyQueryResult
Visual C++
public ref class AssemblyQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.AssemblyQueryResult

See Also

AssemblyQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AssemblyQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
AssemblyQueryResult Members
AssemblyQueryResult Class Constructors Methods Properties See Also

The AssemblyQueryResult type exposes the following members.

Constructors

Name | Description
AssemblyQueryResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AssemblyId |
ClrName |
IsVisible |
Name |
Owner |
PermissionSet |

See Also

AssemblyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AssemblyQueryResult Constructor

[image]

SQL Data Compare API 12.0.40
AssemblyQueryResult Constructor
AssemblyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public AssemblyQueryResult()
Visual C++
public:
AssemblyQueryResult()

See Also

AssemblyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AssemblyQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
AssemblyQueryResult Properties
AssemblyQueryResult Class See Also

The AssemblyQueryResult type exposes the following properties.

Properties

Name | Description
AssemblyId |
ClrName |
IsVisible |
Name |
Owner |
PermissionSet |

See Also

AssemblyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AssemblyId Property

[image]

SQL Data Compare API 12.0.40
AssemblyQueryResult..::.AssemblyId Property
AssemblyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyId As Integer
C#
public int AssemblyId { get; set; }
Visual C++
public:
property int AssemblyId {
    int get ();
    void set (int value);
}

See Also

AssemblyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ClrName Property

[image]

SQL Data Compare API 12.0.40
AssemblyQueryResult..::.ClrName Property
AssemblyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ClrName As String
C#
public string ClrName { get; set; }
Visual C++
public:
property String^ ClrName {
    String^ get ();
    void set (String^ value);
}

See Also

AssemblyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsVisible Property

[image]

SQL Data Compare API 12.0.40
AssemblyQueryResult..::.IsVisible Property
AssemblyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsVisible As Boolean
C#
public bool IsVisible { get; set; }
Visual C++
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}

See Also

AssemblyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
AssemblyQueryResult..::.Name Property
AssemblyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

AssemblyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
AssemblyQueryResult..::.Owner Property
AssemblyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Owner As String
C#
public string Owner { get; set; }
Visual C++
public:
property String^ Owner {
    String^ get ();
    void set (String^ value);
}

See Also

AssemblyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PermissionSet Property

[image]

SQL Data Compare API 12.0.40
AssemblyQueryResult..::.PermissionSet Property
AssemblyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PermissionSet As Byte
C#
public byte PermissionSet { get; set; }
Visual C++
public:
property unsigned char PermissionSet {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

AssemblyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AsymmetricKeyQueryResult Class

[image]

SQL Data Compare API 12.0.40
AsymmetricKeyQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class AsymmetricKeyQueryResult
C#
public class AsymmetricKeyQueryResult
Visual C++
public ref class AsymmetricKeyQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.AsymmetricKeyQueryResult

See Also

AsymmetricKeyQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AsymmetricKeyQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
AsymmetricKeyQueryResult Members
AsymmetricKeyQueryResult Class Constructors Methods Properties See Also

The AsymmetricKeyQueryResult type exposes the following members.

Constructors

Name | Description
AsymmetricKeyQueryResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ID |
KeyAlgorithm |
KeyLength |
Name |
Owner |
PrivateKeyEncryption |
ThumbPrint |

See Also

AsymmetricKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AsymmetricKeyQueryResult Constructor

[image]

SQL Data Compare API 12.0.40
AsymmetricKeyQueryResult Constructor
AsymmetricKeyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public AsymmetricKeyQueryResult()
Visual C++
public:
AsymmetricKeyQueryResult()

See Also

AsymmetricKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AsymmetricKeyQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
AsymmetricKeyQueryResult Properties
AsymmetricKeyQueryResult Class See Also

The AsymmetricKeyQueryResult type exposes the following properties.

Properties

Name | Description
ID |
KeyAlgorithm |
KeyLength |
Name |
Owner |
PrivateKeyEncryption |
ThumbPrint |

See Also

AsymmetricKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ID Property

[image]

SQL Data Compare API 12.0.40
AsymmetricKeyQueryResult..::.ID Property
AsymmetricKeyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ID As Integer
C#
public int ID { get; set; }
Visual C++
public:
property int ID {
    int get ();
    void set (int value);
}

See Also

AsymmetricKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


KeyAlgorithm Property

[image]

SQL Data Compare API 12.0.40
AsymmetricKeyQueryResult..::.KeyAlgorithm Property
AsymmetricKeyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property KeyAlgorithm As String
C#
public string KeyAlgorithm { get; set; }
Visual C++
public:
property String^ KeyAlgorithm {
    String^ get ();
    void set (String^ value);
}

See Also

AsymmetricKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


KeyLength Property

[image]

SQL Data Compare API 12.0.40
AsymmetricKeyQueryResult..::.KeyLength Property
AsymmetricKeyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property KeyLength As Integer
C#
public int KeyLength { get; set; }
Visual C++
public:
property int KeyLength {
    int get ();
    void set (int value);
}

See Also

AsymmetricKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
AsymmetricKeyQueryResult..::.Name Property
AsymmetricKeyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

AsymmetricKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
AsymmetricKeyQueryResult..::.Owner Property
AsymmetricKeyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Owner As String
C#
public string Owner { get; set; }
Visual C++
public:
property String^ Owner {
    String^ get ();
    void set (String^ value);
}

See Also

AsymmetricKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PrivateKeyEncryption Property

[image]

SQL Data Compare API 12.0.40
AsymmetricKeyQueryResult..::.PrivateKeyEncryption Property
AsymmetricKeyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PrivateKeyEncryption As String
C#
public string PrivateKeyEncryption { get; set; }
Visual C++
public:
property String^ PrivateKeyEncryption {
    String^ get ();
    void set (String^ value);
}

See Also

AsymmetricKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ThumbPrint Property

[image]

SQL Data Compare API 12.0.40
AsymmetricKeyQueryResult..::.ThumbPrint Property
AsymmetricKeyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ThumbPrint As Byte()
C#
public byte[] ThumbPrint { get; set; }
Visual C++
public:
property array<unsigned char>^ ThumbPrint {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

AsymmetricKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


CertificateQueryResult Class

[image]

SQL Data Compare API 12.0.40
CertificateQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class CertificateQueryResult
C#
public class CertificateQueryResult
Visual C++
public ref class CertificateQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.CertificateQueryResult

See Also

CertificateQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


CertificateQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
CertificateQueryResult Members
CertificateQueryResult Class Constructors Methods Properties See Also

The CertificateQueryResult type exposes the following members.

Constructors

Name | Description
CertificateQueryResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ActiveForDialog |
ExpiryDate |
ID |
IssuerName |
KeyEncryptionType |
Name |
Owner |
SerialNumber |
StartDate |
Subject |
ThumbPrint |

See Also

CertificateQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


CertificateQueryResult Constructor

[image]

SQL Data Compare API 12.0.40
CertificateQueryResult Constructor
CertificateQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CertificateQueryResult()
Visual C++
public:
CertificateQueryResult()

See Also

CertificateQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


CertificateQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
CertificateQueryResult Properties
CertificateQueryResult Class See Also

The CertificateQueryResult type exposes the following properties.

Properties

Name | Description
ActiveForDialog |
ExpiryDate |
ID |
IssuerName |
KeyEncryptionType |
Name |
Owner |
SerialNumber |
StartDate |
Subject |
ThumbPrint |

See Also

CertificateQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ActiveForDialog Property

[image]

SQL Data Compare API 12.0.40
CertificateQueryResult..::.ActiveForDialog Property
CertificateQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ActiveForDialog As Boolean
C#
public bool ActiveForDialog { get; set; }
Visual C++
public:
property bool ActiveForDialog {
    bool get ();
    void set (bool value);
}

See Also

CertificateQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ExpiryDate Property

[image]

SQL Data Compare API 12.0.40
CertificateQueryResult..::.ExpiryDate Property
CertificateQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExpiryDate As DateTime
C#
public DateTime ExpiryDate { get; set; }
Visual C++
public:
property DateTime ExpiryDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

CertificateQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ID Property

[image]

SQL Data Compare API 12.0.40
CertificateQueryResult..::.ID Property
CertificateQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ID As Integer
C#
public int ID { get; set; }
Visual C++
public:
property int ID {
    int get ();
    void set (int value);
}

See Also

CertificateQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IssuerName Property

[image]

SQL Data Compare API 12.0.40
CertificateQueryResult..::.IssuerName Property
CertificateQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IssuerName As String
C#
public string IssuerName { get; set; }
Visual C++
public:
property String^ IssuerName {
    String^ get ();
    void set (String^ value);
}

See Also

CertificateQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


KeyEncryptionType Property

[image]

SQL Data Compare API 12.0.40
CertificateQueryResult..::.KeyEncryptionType Property
CertificateQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property KeyEncryptionType As String
C#
public string KeyEncryptionType { get; set; }
Visual C++
public:
property String^ KeyEncryptionType {
    String^ get ();
    void set (String^ value);
}

See Also

CertificateQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
CertificateQueryResult..::.Name Property
CertificateQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CertificateQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
CertificateQueryResult..::.Owner Property
CertificateQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Owner As String
C#
public string Owner { get; set; }
Visual C++
public:
property String^ Owner {
    String^ get ();
    void set (String^ value);
}

See Also

CertificateQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SerialNumber Property

[image]

SQL Data Compare API 12.0.40
CertificateQueryResult..::.SerialNumber Property
CertificateQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SerialNumber As String
C#
public string SerialNumber { get; set; }
Visual C++
public:
property String^ SerialNumber {
    String^ get ();
    void set (String^ value);
}

See Also

CertificateQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


StartDate Property

[image]

SQL Data Compare API 12.0.40
CertificateQueryResult..::.StartDate Property
CertificateQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property StartDate As DateTime
C#
public DateTime StartDate { get; set; }
Visual C++
public:
property DateTime StartDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

CertificateQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Subject Property

[image]

SQL Data Compare API 12.0.40
CertificateQueryResult..::.Subject Property
CertificateQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Subject As String
C#
public string Subject { get; set; }
Visual C++
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}

See Also

CertificateQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ThumbPrint Property

[image]

SQL Data Compare API 12.0.40
CertificateQueryResult..::.ThumbPrint Property
CertificateQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ThumbPrint As Byte()
C#
public byte[] ThumbPrint { get; set; }
Visual C++
public:
property array<unsigned char>^ ThumbPrint {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

CertificateQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


CommentQueryResult Class

[image]

SQL Data Compare API 12.0.40
CommentQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class CommentQueryResult _
    Implements ICacheableQueryResult
C#
public class CommentQueryResult : ICacheableQueryResult
Visual C++
public ref class CommentQueryResult : ICacheableQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.CommentQueryResult

See Also

CommentQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


CommentQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
CommentQueryResult Members
CommentQueryResult Class Constructors Methods Properties Explicit Interface Implementations See Also

The CommentQueryResult type exposes the following members.

Constructors

Name | Description
CommentQueryResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CText |
Encrypted |
EncryptedText |
ID |
IsDefault |
IsQuoted |
Number |
Text |

Explicit Interface Implementations

Name | Description
ICacheableQueryResult..::.CacheKey |

See Also

CommentQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


CommentQueryResult Constructor

[image]

SQL Data Compare API 12.0.40
CommentQueryResult Constructor
CommentQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CommentQueryResult()
Visual C++
public:
CommentQueryResult()

See Also

CommentQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


CommentQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
CommentQueryResult Properties
CommentQueryResult Class See Also

The CommentQueryResult type exposes the following properties.

Properties

Name | Description
CText |
Encrypted |
EncryptedText |
ID |
IsDefault |
IsQuoted |
Number |
Text |

Explicit Interface Implementations

Name | Description
ICacheableQueryResult..::.CacheKey |

See Also

CommentQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ICacheableQueryResult.CacheKey Property

[image]

SQL Data Compare API 12.0.40
CommentQueryResult..::.ICacheableQueryResult..::.CacheKey Property
CommentQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private ReadOnly Property CacheKey As Integer
    Implements ICacheableQueryResult.CacheKey
C#
int ICacheableQueryResult.CacheKey { get; }
Visual C++
private:
virtual property int CacheKey {
    int get () sealed = ICacheableQueryResult::CacheKey::get;
}

Implements

ICacheableQueryResult..::.CacheKey

See Also

CommentQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


CText Property

[image]

SQL Data Compare API 12.0.40
CommentQueryResult..::.CText Property
CommentQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CText As Byte()
C#
public byte[] CText { get; set; }
Visual C++
public:
property array<unsigned char>^ CText {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

CommentQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Encrypted Property

[image]

SQL Data Compare API 12.0.40
CommentQueryResult..::.Encrypted Property
CommentQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Encrypted As Boolean
C#
public bool Encrypted { get; set; }
Visual C++
public:
property bool Encrypted {
    bool get ();
    void set (bool value);
}

See Also

CommentQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


EncryptedText Property

[image]

SQL Data Compare API 12.0.40
CommentQueryResult..::.EncryptedText Property
CommentQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property EncryptedText As Byte()
C#
public byte[] EncryptedText { get; set; }
Visual C++
public:
property array<unsigned char>^ EncryptedText {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

CommentQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ID Property

[image]

SQL Data Compare API 12.0.40
CommentQueryResult..::.ID Property
CommentQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ID As Integer
C#
public int ID { get; set; }
Visual C++
public:
property int ID {
    int get ();
    void set (int value);
}

See Also

CommentQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsDefault Property

[image]

SQL Data Compare API 12.0.40
CommentQueryResult..::.IsDefault Property
CommentQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsDefault As Boolean
C#
public bool IsDefault { get; set; }
Visual C++
public:
property bool IsDefault {
    bool get ();
    void set (bool value);
}

See Also

CommentQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsQuoted Property

[image]

SQL Data Compare API 12.0.40
CommentQueryResult..::.IsQuoted Property
CommentQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsQuoted As Boolean
C#
public bool IsQuoted { get; set; }
Visual C++
public:
property bool IsQuoted {
    bool get ();
    void set (bool value);
}

See Also

CommentQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Number Property

[image]

SQL Data Compare API 12.0.40
CommentQueryResult..::.Number Property
CommentQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Number As UShort
C#
public ushort Number { get; set; }
Visual C++
public:
property unsigned short Number {
    unsigned short get ();
    void set (unsigned short value);
}

See Also

CommentQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Text Property

[image]

SQL Data Compare API 12.0.40
CommentQueryResult..::.Text Property
CommentQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text { get; set; }
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

CommentQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ConstraintQueryResult Class

[image]

SQL Data Compare API 12.0.40
ConstraintQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ConstraintQueryResult
C#
public class ConstraintQueryResult
Visual C++
public ref class ConstraintQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.ConstraintQueryResult

See Also

ConstraintQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ConstraintQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
ConstraintQueryResult Members
ConstraintQueryResult Class Constructors Methods Properties See Also

The ConstraintQueryResult type exposes the following members.

Constructors

Name | Description
ConstraintQueryResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColId |
ColumnName |
ConstraintName |
Disabled |
IsSystemNamed |
NoCheck |
NotForReplication |
SysobjectID |
TableName |
TableOwner |
Text |

See Also

ConstraintQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ConstraintQueryResult Constructor

[image]

SQL Data Compare API 12.0.40
ConstraintQueryResult Constructor
ConstraintQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ConstraintQueryResult()
Visual C++
public:
ConstraintQueryResult()

See Also

ConstraintQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ConstraintQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
ConstraintQueryResult Properties
ConstraintQueryResult Class See Also

The ConstraintQueryResult type exposes the following properties.

Properties

Name | Description
ColId |
ColumnName |
ConstraintName |
Disabled |
IsSystemNamed |
NoCheck |
NotForReplication |
SysobjectID |
TableName |
TableOwner |
Text |

See Also

ConstraintQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ColId Property

[image]

SQL Data Compare API 12.0.40
ConstraintQueryResult..::.ColId Property
ConstraintQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ColId As Integer
C#
public int ColId { get; set; }
Visual C++
public:
property int ColId {
    int get ();
    void set (int value);
}

See Also

ConstraintQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ColumnName Property

[image]

SQL Data Compare API 12.0.40
ConstraintQueryResult..::.ColumnName Property
ConstraintQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ColumnName As String
C#
public string ColumnName { get; set; }
Visual C++
public:
property String^ ColumnName {
    String^ get ();
    void set (String^ value);
}

See Also

ConstraintQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ConstraintName Property

[image]

SQL Data Compare API 12.0.40
ConstraintQueryResult..::.ConstraintName Property
ConstraintQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ConstraintName As String
C#
public string ConstraintName { get; set; }
Visual C++
public:
property String^ ConstraintName {
    String^ get ();
    void set (String^ value);
}

See Also

ConstraintQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Disabled Property

[image]

SQL Data Compare API 12.0.40
ConstraintQueryResult..::.Disabled Property
ConstraintQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Disabled As Boolean
C#
public bool Disabled { get; set; }
Visual C++
public:
property bool Disabled {
    bool get ();
    void set (bool value);
}

See Also

ConstraintQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsSystemNamed Property

[image]

SQL Data Compare API 12.0.40
ConstraintQueryResult..::.IsSystemNamed Property
ConstraintQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSystemNamed As Boolean
C#
public bool IsSystemNamed { get; set; }
Visual C++
public:
property bool IsSystemNamed {
    bool get ();
    void set (bool value);
}

See Also

ConstraintQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


NoCheck Property

[image]

SQL Data Compare API 12.0.40
ConstraintQueryResult..::.NoCheck Property
ConstraintQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NoCheck As Boolean
C#
public bool NoCheck { get; set; }
Visual C++
public:
property bool NoCheck {
    bool get ();
    void set (bool value);
}

See Also

ConstraintQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


NotForReplication Property

[image]

SQL Data Compare API 12.0.40
ConstraintQueryResult..::.NotForReplication Property
ConstraintQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NotForReplication As Boolean
C#
public bool NotForReplication { get; set; }
Visual C++
public:
property bool NotForReplication {
    bool get ();
    void set (bool value);
}

See Also

ConstraintQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SysobjectID Property

[image]

SQL Data Compare API 12.0.40
ConstraintQueryResult..::.SysobjectID Property
ConstraintQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SysobjectID As Integer
C#
public int SysobjectID { get; set; }
Visual C++
public:
property int SysobjectID {
    int get ();
    void set (int value);
}

See Also

ConstraintQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TableName Property

[image]

SQL Data Compare API 12.0.40
ConstraintQueryResult..::.TableName Property
ConstraintQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TableName As String
C#
public string TableName { get; set; }
Visual C++
public:
property String^ TableName {
    String^ get ();
    void set (String^ value);
}

See Also

ConstraintQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TableOwner Property

[image]

SQL Data Compare API 12.0.40
ConstraintQueryResult..::.TableOwner Property
ConstraintQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TableOwner As String
C#
public string TableOwner { get; set; }
Visual C++
public:
property String^ TableOwner {
    String^ get ();
    void set (String^ value);
}

See Also

ConstraintQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Text Property

[image]

SQL Data Compare API 12.0.40
ConstraintQueryResult..::.Text Property
ConstraintQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text { get; set; }
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

ConstraintQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ContractMessageQueryResult Class

[image]

SQL Data Compare API 12.0.40
ContractMessageQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ContractMessageQueryResult
C#
public class ContractMessageQueryResult
Visual C++
public ref class ContractMessageQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.ContractMessageQueryResult

See Also

ContractMessageQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ContractMessageQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
ContractMessageQueryResult Members
ContractMessageQueryResult Class Constructors Methods Properties See Also

The ContractMessageQueryResult type exposes the following members.

Constructors

Name | Description
ContractMessageQueryResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ContractName |
MessageName |
SentByInitiator |
SentByTarget |

See Also

ContractMessageQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ContractMessageQueryResult Constructor

[image]

SQL Data Compare API 12.0.40
ContractMessageQueryResult Constructor
ContractMessageQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ContractMessageQueryResult()
Visual C++
public:
ContractMessageQueryResult()

See Also

ContractMessageQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ContractMessageQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
ContractMessageQueryResult Properties
ContractMessageQueryResult Class See Also

The ContractMessageQueryResult type exposes the following properties.

Properties

Name | Description
ContractName |
MessageName |
SentByInitiator |
SentByTarget |

See Also

ContractMessageQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ContractName Property

[image]

SQL Data Compare API 12.0.40
ContractMessageQueryResult..::.ContractName Property
ContractMessageQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ContractName As String
C#
public string ContractName { get; set; }
Visual C++
public:
property String^ ContractName {
    String^ get ();
    void set (String^ value);
}

See Also

ContractMessageQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


MessageName Property

[image]

SQL Data Compare API 12.0.40
ContractMessageQueryResult..::.MessageName Property
ContractMessageQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property MessageName As String
C#
public string MessageName { get; set; }
Visual C++
public:
property String^ MessageName {
    String^ get ();
    void set (String^ value);
}

See Also

ContractMessageQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SentByInitiator Property

[image]

SQL Data Compare API 12.0.40
ContractMessageQueryResult..::.SentByInitiator Property
ContractMessageQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SentByInitiator As Boolean
C#
public bool SentByInitiator { get; set; }
Visual C++
public:
property bool SentByInitiator {
    bool get ();
    void set (bool value);
}

See Also

ContractMessageQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SentByTarget Property

[image]

SQL Data Compare API 12.0.40
ContractMessageQueryResult..::.SentByTarget Property
ContractMessageQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SentByTarget As Boolean
C#
public bool SentByTarget { get; set; }
Visual C++
public:
property bool SentByTarget {
    bool get ();
    void set (bool value);
}

See Also

ContractMessageQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ContractQueryResult Class

[image]

SQL Data Compare API 12.0.40
ContractQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ContractQueryResult
C#
public class ContractQueryResult
Visual C++
public ref class ContractQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.ContractQueryResult

See Also

ContractQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ContractQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
ContractQueryResult Members
ContractQueryResult Class Constructors Methods Properties See Also

The ContractQueryResult type exposes the following members.

Constructors

Name | Description
ContractQueryResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ID |
Name |
Owner |

See Also

ContractQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ContractQueryResult Constructor

[image]

SQL Data Compare API 12.0.40
ContractQueryResult Constructor
ContractQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ContractQueryResult()
Visual C++
public:
ContractQueryResult()

See Also

ContractQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ContractQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
ContractQueryResult Properties
ContractQueryResult Class See Also

The ContractQueryResult type exposes the following properties.

Properties

Name | Description
ID |
Name |
Owner |

See Also

ContractQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ID Property

[image]

SQL Data Compare API 12.0.40
ContractQueryResult..::.ID Property
ContractQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ID As Integer
C#
public int ID { get; set; }
Visual C++
public:
property int ID {
    int get ();
    void set (int value);
}

See Also

ContractQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
ContractQueryResult..::.Name Property
ContractQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ContractQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
ContractQueryResult..::.Owner Property
ContractQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Owner As String
C#
public string Owner { get; set; }
Visual C++
public:
property String^ Owner {
    String^ get ();
    void set (String^ value);
}

See Also

ContractQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DdlTriggerQueryResult Class

[image]

SQL Data Compare API 12.0.40
DdlTriggerQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class DdlTriggerQueryResult
C#
public class DdlTriggerQueryResult
Visual C++
public ref class DdlTriggerQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.DdlTriggerQueryResult

See Also

DdlTriggerQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DdlTriggerQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
DdlTriggerQueryResult Members
DdlTriggerQueryResult Class Constructors Methods Properties See Also

The DdlTriggerQueryResult type exposes the following members.

Constructors

Name | Description
DdlTriggerQueryResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AnsiNulls |
Assembly |
AssemblyClass |
AssemblyMethod |
DdlTriggerName |
DdlTriggerType |
Encrypted |
EventType |
ExecuteAs |
InsteadOf |
IsDisabled |
QuotedIdentifier |
TriggerID |

See Also

DdlTriggerQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DdlTriggerQueryResult Constructor

[image]

SQL Data Compare API 12.0.40
DdlTriggerQueryResult Constructor
DdlTriggerQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DdlTriggerQueryResult()
Visual C++
public:
DdlTriggerQueryResult()

See Also

DdlTriggerQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DdlTriggerQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
DdlTriggerQueryResult Properties
DdlTriggerQueryResult Class See Also

The DdlTriggerQueryResult type exposes the following properties.

Properties

Name | Description
AnsiNulls |
Assembly |
AssemblyClass |
AssemblyMethod |
DdlTriggerName |
DdlTriggerType |
Encrypted |
EventType |
ExecuteAs |
InsteadOf |
IsDisabled |
QuotedIdentifier |
TriggerID |

See Also

DdlTriggerQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AnsiNulls Property

[image]

SQL Data Compare API 12.0.40
DdlTriggerQueryResult..::.AnsiNulls Property
DdlTriggerQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AnsiNulls As Boolean
C#
public bool AnsiNulls { get; set; }
Visual C++
public:
property bool AnsiNulls {
    bool get ();
    void set (bool value);
}

See Also

DdlTriggerQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Assembly Property

[image]

SQL Data Compare API 12.0.40
DdlTriggerQueryResult..::.Assembly Property
DdlTriggerQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Assembly As String
C#
public string Assembly { get; set; }
Visual C++
public:
property String^ Assembly {
    String^ get ();
    void set (String^ value);
}

See Also

DdlTriggerQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AssemblyClass Property

[image]

SQL Data Compare API 12.0.40
DdlTriggerQueryResult..::.AssemblyClass Property
DdlTriggerQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyClass As String
C#
public string AssemblyClass { get; set; }
Visual C++
public:
property String^ AssemblyClass {
    String^ get ();
    void set (String^ value);
}

See Also

DdlTriggerQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AssemblyMethod Property

[image]

SQL Data Compare API 12.0.40
DdlTriggerQueryResult..::.AssemblyMethod Property
DdlTriggerQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyMethod As String
C#
public string AssemblyMethod { get; set; }
Visual C++
public:
property String^ AssemblyMethod {
    String^ get ();
    void set (String^ value);
}

See Also

DdlTriggerQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DdlTriggerName Property

[image]

SQL Data Compare API 12.0.40
DdlTriggerQueryResult..::.DdlTriggerName Property
DdlTriggerQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DdlTriggerName As String
C#
public string DdlTriggerName { get; set; }
Visual C++
public:
property String^ DdlTriggerName {
    String^ get ();
    void set (String^ value);
}

See Also

DdlTriggerQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DdlTriggerType Property

[image]

SQL Data Compare API 12.0.40
DdlTriggerQueryResult..::.DdlTriggerType Property
DdlTriggerQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DdlTriggerType As String
C#
public string DdlTriggerType { get; set; }
Visual C++
public:
property String^ DdlTriggerType {
    String^ get ();
    void set (String^ value);
}

See Also

DdlTriggerQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Encrypted Property

[image]

SQL Data Compare API 12.0.40
DdlTriggerQueryResult..::.Encrypted Property
DdlTriggerQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Encrypted As Boolean
C#
public bool Encrypted { get; set; }
Visual C++
public:
property bool Encrypted {
    bool get ();
    void set (bool value);
}

See Also

DdlTriggerQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


EventType Property

[image]

SQL Data Compare API 12.0.40
DdlTriggerQueryResult..::.EventType Property
DdlTriggerQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property EventType As String
C#
public string EventType { get; set; }
Visual C++
public:
property String^ EventType {
    String^ get ();
    void set (String^ value);
}

See Also

DdlTriggerQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ExecuteAs Property

[image]

SQL Data Compare API 12.0.40
DdlTriggerQueryResult..::.ExecuteAs Property
DdlTriggerQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecuteAs As String
C#
public string ExecuteAs { get; set; }
Visual C++
public:
property String^ ExecuteAs {
    String^ get ();
    void set (String^ value);
}

See Also

DdlTriggerQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


InsteadOf Property

[image]

SQL Data Compare API 12.0.40
DdlTriggerQueryResult..::.InsteadOf Property
DdlTriggerQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property InsteadOf As Boolean
C#
public bool InsteadOf { get; set; }
Visual C++
public:
property bool InsteadOf {
    bool get ();
    void set (bool value);
}

See Also

DdlTriggerQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsDisabled Property

[image]

SQL Data Compare API 12.0.40
DdlTriggerQueryResult..::.IsDisabled Property
DdlTriggerQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsDisabled As Boolean
C#
public bool IsDisabled { get; set; }
Visual C++
public:
property bool IsDisabled {
    bool get ();
    void set (bool value);
}

See Also

DdlTriggerQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


QuotedIdentifier Property

[image]

SQL Data Compare API 12.0.40
DdlTriggerQueryResult..::.QuotedIdentifier Property
DdlTriggerQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property QuotedIdentifier As Boolean
C#
public bool QuotedIdentifier { get; set; }
Visual C++
public:
property bool QuotedIdentifier {
    bool get ();
    void set (bool value);
}

See Also

DdlTriggerQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TriggerID Property

[image]

SQL Data Compare API 12.0.40
DdlTriggerQueryResult..::.TriggerID Property
DdlTriggerQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TriggerID As Integer
C#
public int TriggerID { get; set; }
Visual C++
public:
property int TriggerID {
    int get ();
    void set (int value);
}

See Also

DdlTriggerQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DefaultQueryResult Class

[image]

SQL Data Compare API 12.0.40
DefaultQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class DefaultQueryResult
C#
public class DefaultQueryResult
Visual C++
public ref class DefaultQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.DefaultQueryResult

See Also

DefaultQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DefaultQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
DefaultQueryResult Members
DefaultQueryResult Class Constructors Methods Properties See Also

The DefaultQueryResult type exposes the following members.

Constructors

Name | Description
DefaultQueryResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DefaultId |
DefaultName |
DefaultOwner |
Text |

See Also

DefaultQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DefaultQueryResult Constructor

[image]

SQL Data Compare API 12.0.40
DefaultQueryResult Constructor
DefaultQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DefaultQueryResult()
Visual C++
public:
DefaultQueryResult()

See Also

DefaultQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DefaultQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
DefaultQueryResult Properties
DefaultQueryResult Class See Also

The DefaultQueryResult type exposes the following properties.

Properties

Name | Description
DefaultId |
DefaultName |
DefaultOwner |
Text |

See Also

DefaultQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DefaultId Property

[image]

SQL Data Compare API 12.0.40
DefaultQueryResult..::.DefaultId Property
DefaultQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultId As Integer
C#
public int DefaultId { get; set; }
Visual C++
public:
property int DefaultId {
    int get ();
    void set (int value);
}

See Also

DefaultQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DefaultName Property

[image]

SQL Data Compare API 12.0.40
DefaultQueryResult..::.DefaultName Property
DefaultQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultName As String
C#
public string DefaultName { get; set; }
Visual C++
public:
property String^ DefaultName {
    String^ get ();
    void set (String^ value);
}

See Also

DefaultQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DefaultOwner Property

[image]

SQL Data Compare API 12.0.40
DefaultQueryResult..::.DefaultOwner Property
DefaultQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultOwner As String
C#
public string DefaultOwner { get; set; }
Visual C++
public:
property String^ DefaultOwner {
    String^ get ();
    void set (String^ value);
}

See Also

DefaultQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Text Property

[image]

SQL Data Compare API 12.0.40
DefaultQueryResult..::.Text Property
DefaultQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text { get; set; }
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

DefaultQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


EventNotificationQueryResult Class

[image]

SQL Data Compare API 12.0.40
EventNotificationQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class EventNotificationQueryResult
C#
public class EventNotificationQueryResult
Visual C++
public ref class EventNotificationQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.EventNotificationQueryResult

See Also

EventNotificationQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


EventNotificationQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
EventNotificationQueryResult Members
EventNotificationQueryResult Class Constructors Methods Properties See Also

The EventNotificationQueryResult type exposes the following members.

Constructors

Name | Description
EventNotificationQueryResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BrokerInstance |
EventName |
EventType |
FanIn |
ObjectName |
ObjectSchema |
ParentClass |
ServiceName |

See Also

EventNotificationQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


EventNotificationQueryResult Constructor

[image]

SQL Data Compare API 12.0.40
EventNotificationQueryResult Constructor
EventNotificationQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public EventNotificationQueryResult()
Visual C++
public:
EventNotificationQueryResult()

See Also

EventNotificationQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


EventNotificationQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
EventNotificationQueryResult Properties
EventNotificationQueryResult Class See Also

The EventNotificationQueryResult type exposes the following properties.

Properties

Name | Description
BrokerInstance |
EventName |
EventType |
FanIn |
ObjectName |
ObjectSchema |
ParentClass |
ServiceName |

See Also

EventNotificationQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


BrokerInstance Property

[image]

SQL Data Compare API 12.0.40
EventNotificationQueryResult..::.BrokerInstance Property
EventNotificationQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BrokerInstance As String
C#
public string BrokerInstance { get; set; }
Visual C++
public:
property String^ BrokerInstance {
    String^ get ();
    void set (String^ value);
}

See Also

EventNotificationQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


EventName Property

[image]

SQL Data Compare API 12.0.40
EventNotificationQueryResult..::.EventName Property
EventNotificationQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property EventName As String
C#
public string EventName { get; set; }
Visual C++
public:
property String^ EventName {
    String^ get ();
    void set (String^ value);
}

See Also

EventNotificationQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


EventType Property

[image]

SQL Data Compare API 12.0.40
EventNotificationQueryResult..::.EventType Property
EventNotificationQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property EventType As Integer
C#
public int EventType { get; set; }
Visual C++
public:
property int EventType {
    int get ();
    void set (int value);
}

See Also

EventNotificationQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FanIn Property

[image]

SQL Data Compare API 12.0.40
EventNotificationQueryResult..::.FanIn Property
EventNotificationQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FanIn As Boolean
C#
public bool FanIn { get; set; }
Visual C++
public:
property bool FanIn {
    bool get ();
    void set (bool value);
}

See Also

EventNotificationQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ObjectName Property

[image]

SQL Data Compare API 12.0.40
EventNotificationQueryResult..::.ObjectName Property
EventNotificationQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectName As String
C#
public string ObjectName { get; set; }
Visual C++
public:
property String^ ObjectName {
    String^ get ();
    void set (String^ value);
}

See Also

EventNotificationQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ObjectSchema Property

[image]

SQL Data Compare API 12.0.40
EventNotificationQueryResult..::.ObjectSchema Property
EventNotificationQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectSchema As String
C#
public string ObjectSchema { get; set; }
Visual C++
public:
property String^ ObjectSchema {
    String^ get ();
    void set (String^ value);
}

See Also

EventNotificationQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ParentClass Property

[image]

SQL Data Compare API 12.0.40
EventNotificationQueryResult..::.ParentClass Property
EventNotificationQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ParentClass As Byte
C#
public byte ParentClass { get; set; }
Visual C++
public:
property unsigned char ParentClass {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

EventNotificationQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ServiceName Property

[image]

SQL Data Compare API 12.0.40
EventNotificationQueryResult..::.ServiceName Property
EventNotificationQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ServiceName As String
C#
public string ServiceName { get; set; }
Visual C++
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}

See Also

EventNotificationQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ExpressionDependencyQueryResult Class

[image]

SQL Data Compare API 12.0.40
ExpressionDependencyQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ExpressionDependencyQueryResult
C#
public class ExpressionDependencyQueryResult
Visual C++
public ref class ExpressionDependencyQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.ExpressionDependencyQueryResult

See Also

ExpressionDependencyQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ExpressionDependencyQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
ExpressionDependencyQueryResult Members
ExpressionDependencyQueryResult Class Constructors Methods Properties See Also

The ExpressionDependencyQueryResult type exposes the following members.

Constructors

Name | Description
ExpressionDependencyQueryResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsSchemaBound |
ReferencedClass |
ReferencedDatabaseName |
ReferencedEntityName |
ReferencedId |
ReferencedSchemaName |
ReferencedServerName |
ReferencingId |

See Also

ExpressionDependencyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ExpressionDependencyQueryResult Constructor

[image]

SQL Data Compare API 12.0.40
ExpressionDependencyQueryResult Constructor
ExpressionDependencyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ExpressionDependencyQueryResult()
Visual C++
public:
ExpressionDependencyQueryResult()

See Also

ExpressionDependencyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ExpressionDependencyQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
ExpressionDependencyQueryResult Properties
ExpressionDependencyQueryResult Class See Also

The ExpressionDependencyQueryResult type exposes the following properties.

Properties

Name | Description
IsSchemaBound |
ReferencedClass |
ReferencedDatabaseName |
ReferencedEntityName |
ReferencedId |
ReferencedSchemaName |
ReferencedServerName |
ReferencingId |

See Also

ExpressionDependencyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsSchemaBound Property

[image]

SQL Data Compare API 12.0.40
ExpressionDependencyQueryResult..::.IsSchemaBound Property
ExpressionDependencyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSchemaBound As Boolean
C#
public bool IsSchemaBound { get; set; }
Visual C++
public:
property bool IsSchemaBound {
    bool get ();
    void set (bool value);
}

See Also

ExpressionDependencyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ReferencedClass Property

[image]

SQL Data Compare API 12.0.40
ExpressionDependencyQueryResult..::.ReferencedClass Property
ExpressionDependencyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ReferencedClass As Integer
C#
public int ReferencedClass { get; set; }
Visual C++
public:
property int ReferencedClass {
    int get ();
    void set (int value);
}

See Also

ExpressionDependencyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ReferencedDatabaseName Property

[image]

SQL Data Compare API 12.0.40
ExpressionDependencyQueryResult..::.ReferencedDatabaseName Property
ExpressionDependencyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ReferencedDatabaseName As String
C#
public string ReferencedDatabaseName { get; set; }
Visual C++
public:
property String^ ReferencedDatabaseName {
    String^ get ();
    void set (String^ value);
}

See Also

ExpressionDependencyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ReferencedEntityName Property

[image]

SQL Data Compare API 12.0.40
ExpressionDependencyQueryResult..::.ReferencedEntityName Property
ExpressionDependencyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ReferencedEntityName As String
C#
public string ReferencedEntityName { get; set; }
Visual C++
public:
property String^ ReferencedEntityName {
    String^ get ();
    void set (String^ value);
}

See Also

ExpressionDependencyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ReferencedId Property

[image]

SQL Data Compare API 12.0.40
ExpressionDependencyQueryResult..::.ReferencedId Property
ExpressionDependencyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ReferencedId As Integer
C#
public int ReferencedId { get; set; }
Visual C++
public:
property int ReferencedId {
    int get ();
    void set (int value);
}

See Also

ExpressionDependencyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ReferencedSchemaName Property

[image]

SQL Data Compare API 12.0.40
ExpressionDependencyQueryResult..::.ReferencedSchemaName Property
ExpressionDependencyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ReferencedSchemaName As String
C#
public string ReferencedSchemaName { get; set; }
Visual C++
public:
property String^ ReferencedSchemaName {
    String^ get ();
    void set (String^ value);
}

See Also

ExpressionDependencyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ReferencedServerName Property

[image]

SQL Data Compare API 12.0.40
ExpressionDependencyQueryResult..::.ReferencedServerName Property
ExpressionDependencyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ReferencedServerName As String
C#
public string ReferencedServerName { get; set; }
Visual C++
public:
property String^ ReferencedServerName {
    String^ get ();
    void set (String^ value);
}

See Also

ExpressionDependencyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ReferencingId Property

[image]

SQL Data Compare API 12.0.40
ExpressionDependencyQueryResult..::.ReferencingId Property
ExpressionDependencyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ReferencingId As Integer
C#
public int ReferencingId { get; set; }
Visual C++
public:
property int ReferencingId {
    int get ();
    void set (int value);
}

See Also

ExpressionDependencyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ExtendedPropertyQueryResult Class

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ExtendedPropertyQueryResult
C#
public class ExtendedPropertyQueryResult
Visual C++
public ref class ExtendedPropertyQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.ExtendedPropertyQueryResult

See Also

ExtendedPropertyQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ExtendedPropertyQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult Members
ExtendedPropertyQueryResult Class Constructors Methods Properties See Also

The ExtendedPropertyQueryResult type exposes the following members.

Constructors

Name | Description
ExtendedPropertyQueryResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DdlTriggerName |
EventNotificationName |
FieldName |
IndexName |
ObjectName |
ObjectOwner |
ObjectType |
ParentName |
ParentOwner |
ParentType |
PropertyName |
PropertyType |
PropertyValue |
PropertyValueAsSqlDecimal |
PropertyValueBaseType |
PropertyValueBinary |
PropertyValueMaxLength |
PropertyValuePrecision |
PropertyValueScale |
PropertyValueTime |
PropertyValueVarBinary |
QueueName |
QueueSchema |
SmallId |
SqlServer2005ObjectName |
SqlServer2005ObjectOwner |
UdtName |
UdtOwner |
UserName |

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ExtendedPropertyQueryResult Constructor

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult Constructor
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ExtendedPropertyQueryResult()
Visual C++
public:
ExtendedPropertyQueryResult()

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ExtendedPropertyQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult Properties
ExtendedPropertyQueryResult Class See Also

The ExtendedPropertyQueryResult type exposes the following properties.

Properties

Name | Description
DdlTriggerName |
EventNotificationName |
FieldName |
IndexName |
ObjectName |
ObjectOwner |
ObjectType |
ParentName |
ParentOwner |
ParentType |
PropertyName |
PropertyType |
PropertyValue |
PropertyValueAsSqlDecimal |
PropertyValueBaseType |
PropertyValueBinary |
PropertyValueMaxLength |
PropertyValuePrecision |
PropertyValueScale |
PropertyValueTime |
PropertyValueVarBinary |
QueueName |
QueueSchema |
SmallId |
SqlServer2005ObjectName |
SqlServer2005ObjectOwner |
UdtName |
UdtOwner |
UserName |

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DdlTriggerName Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.DdlTriggerName Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DdlTriggerName As String
C#
public string DdlTriggerName { get; set; }
Visual C++
public:
property String^ DdlTriggerName {
    String^ get ();
    void set (String^ value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


EventNotificationName Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.EventNotificationName Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property EventNotificationName As String
C#
public string EventNotificationName { get; set; }
Visual C++
public:
property String^ EventNotificationName {
    String^ get ();
    void set (String^ value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FieldName Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.FieldName Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FieldName As String
C#
public string FieldName { get; set; }
Visual C++
public:
property String^ FieldName {
    String^ get ();
    void set (String^ value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IndexName Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.IndexName Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IndexName As String
C#
public string IndexName { get; set; }
Visual C++
public:
property String^ IndexName {
    String^ get ();
    void set (String^ value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ObjectName Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.ObjectName Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectName As String
C#
public string ObjectName { get; set; }
Visual C++
public:
property String^ ObjectName {
    String^ get ();
    void set (String^ value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ObjectOwner Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.ObjectOwner Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectOwner As String
C#
public string ObjectOwner { get; set; }
Visual C++
public:
property String^ ObjectOwner {
    String^ get ();
    void set (String^ value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.ObjectType Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectType As String
C#
public string ObjectType { get; set; }
Visual C++
public:
property String^ ObjectType {
    String^ get ();
    void set (String^ value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ParentName Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.ParentName Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ParentName As String
C#
public string ParentName { get; set; }
Visual C++
public:
property String^ ParentName {
    String^ get ();
    void set (String^ value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ParentOwner Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.ParentOwner Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ParentOwner As String
C#
public string ParentOwner { get; set; }
Visual C++
public:
property String^ ParentOwner {
    String^ get ();
    void set (String^ value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ParentType Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.ParentType Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ParentType As String
C#
public string ParentType { get; set; }
Visual C++
public:
property String^ ParentType {
    String^ get ();
    void set (String^ value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PropertyName Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.PropertyName Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PropertyName As String
C#
public string PropertyName { get; set; }
Visual C++
public:
property String^ PropertyName {
    String^ get ();
    void set (String^ value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PropertyType Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.PropertyType Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PropertyType As Integer
C#
public int PropertyType { get; set; }
Visual C++
public:
property int PropertyType {
    int get ();
    void set (int value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PropertyValue Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.PropertyValue Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PropertyValue As Object
C#
public Object PropertyValue { get; set; }
Visual C++
public:
property Object^ PropertyValue {
    Object^ get ();
    void set (Object^ value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PropertyValueAsSqlDecimal Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.PropertyValueAsSqlDecimal Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PropertyValueAsSqlDecimal As SqlDecimal
C#
public SqlDecimal PropertyValueAsSqlDecimal { get; set; }
Visual C++
public:
property SqlDecimal PropertyValueAsSqlDecimal {
    SqlDecimal get ();
    void set (SqlDecimal value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PropertyValueBaseType Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.PropertyValueBaseType Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PropertyValueBaseType As String
C#
public string PropertyValueBaseType { get; set; }
Visual C++
public:
property String^ PropertyValueBaseType {
    String^ get ();
    void set (String^ value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PropertyValueBinary Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.PropertyValueBinary Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PropertyValueBinary As Byte()
C#
public byte[] PropertyValueBinary { get; set; }
Visual C++
public:
property array<unsigned char>^ PropertyValueBinary {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PropertyValueMaxLength Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.PropertyValueMaxLength Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PropertyValueMaxLength As Integer
C#
public int PropertyValueMaxLength { get; set; }
Visual C++
public:
property int PropertyValueMaxLength {
    int get ();
    void set (int value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PropertyValuePrecision Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.PropertyValuePrecision Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PropertyValuePrecision As Integer
C#
public int PropertyValuePrecision { get; set; }
Visual C++
public:
property int PropertyValuePrecision {
    int get ();
    void set (int value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PropertyValueScale Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.PropertyValueScale Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PropertyValueScale As Integer
C#
public int PropertyValueScale { get; set; }
Visual C++
public:
property int PropertyValueScale {
    int get ();
    void set (int value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PropertyValueTime Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.PropertyValueTime Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PropertyValueTime As Byte()
C#
public byte[] PropertyValueTime { get; set; }
Visual C++
public:
property array<unsigned char>^ PropertyValueTime {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PropertyValueVarBinary Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.PropertyValueVarBinary Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PropertyValueVarBinary As Byte()
C#
public byte[] PropertyValueVarBinary { get; set; }
Visual C++
public:
property array<unsigned char>^ PropertyValueVarBinary {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


QueueName Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.QueueName Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property QueueName As String
C#
public string QueueName { get; set; }
Visual C++
public:
property String^ QueueName {
    String^ get ();
    void set (String^ value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


QueueSchema Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.QueueSchema Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property QueueSchema As String
C#
public string QueueSchema { get; set; }
Visual C++
public:
property String^ QueueSchema {
    String^ get ();
    void set (String^ value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SmallId Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.SmallId Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SmallId As Integer
C#
public int SmallId { get; set; }
Visual C++
public:
property int SmallId {
    int get ();
    void set (int value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlServer2005ObjectName Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.SqlServer2005ObjectName Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SqlServer2005ObjectName As String
C#
public string SqlServer2005ObjectName { get; set; }
Visual C++
public:
property String^ SqlServer2005ObjectName {
    String^ get ();
    void set (String^ value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlServer2005ObjectOwner Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.SqlServer2005ObjectOwner Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SqlServer2005ObjectOwner As String
C#
public string SqlServer2005ObjectOwner { get; set; }
Visual C++
public:
property String^ SqlServer2005ObjectOwner {
    String^ get ();
    void set (String^ value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


UdtName Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.UdtName Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UdtName As String
C#
public string UdtName { get; set; }
Visual C++
public:
property String^ UdtName {
    String^ get ();
    void set (String^ value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


UdtOwner Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.UdtOwner Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UdtOwner As String
C#
public string UdtOwner { get; set; }
Visual C++
public:
property String^ UdtOwner {
    String^ get ();
    void set (String^ value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


UserName Property

[image]

SQL Data Compare API 12.0.40
ExtendedPropertyQueryResult..::.UserName Property
ExtendedPropertyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UserName As String
C#
public string UserName { get; set; }
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

ExtendedPropertyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FieldQueryResult Class

[image]

SQL Data Compare API 12.0.40
FieldQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class FieldQueryResult _
    Implements ICacheableQueryResult
C#
public class FieldQueryResult : ICacheableQueryResult
Visual C++
public ref class FieldQueryResult : ICacheableQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.FieldQueryResult

See Also

FieldQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FieldQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
FieldQueryResult Members
FieldQueryResult Class Constructors Methods Properties See Also

The FieldQueryResult type exposes the following members.

Constructors

Name | Description
FieldQueryResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowNulls |
BaseTypeName |
CacheKey |
Collation |
ColumnID |
ColumnName |
ColumnSet |
ComputedText |
DataMaskingFunction |
Defaultid |
DefaultName |
DefaultSchemaName |
DefaultTextID |
DRIDefaultName |
Filestream |
FullTextIndexed |
FullTextLanguage |
FullTextTypeColumn |
Identity |
IdentityCurrent |
IdentityIncrement |
IdentitySeed |
IsBoundDefault |
IsComputed |
IsPersisted |
IsRowGuidCol |
IsSystemNamed |
Length |
NotForReplication |
Precision |
RuleName |
RuleSchemaName |
Scale |
SchemaName |
Sparse |
TableName |
TableOwner |
Type |
TypeName |
TypeOwner |
TypeSchemaName |
XMLCollection |
XMLCollectionSchemaName |
XMLDocument |

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FieldQueryResult Constructor

[image]

SQL Data Compare API 12.0.40
FieldQueryResult Constructor
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FieldQueryResult()
Visual C++
public:
FieldQueryResult()

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FieldQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
FieldQueryResult Properties
FieldQueryResult Class See Also

The FieldQueryResult type exposes the following properties.

Properties

Name | Description
AllowNulls |
BaseTypeName |
CacheKey |
Collation |
ColumnID |
ColumnName |
ColumnSet |
ComputedText |
DataMaskingFunction |
Defaultid |
DefaultName |
DefaultSchemaName |
DefaultTextID |
DRIDefaultName |
Filestream |
FullTextIndexed |
FullTextLanguage |
FullTextTypeColumn |
Identity |
IdentityCurrent |
IdentityIncrement |
IdentitySeed |
IsBoundDefault |
IsComputed |
IsPersisted |
IsRowGuidCol |
IsSystemNamed |
Length |
NotForReplication |
Precision |
RuleName |
RuleSchemaName |
Scale |
SchemaName |
Sparse |
TableName |
TableOwner |
Type |
TypeName |
TypeOwner |
TypeSchemaName |
XMLCollection |
XMLCollectionSchemaName |
XMLDocument |

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AllowNulls Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.AllowNulls Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowNulls As Boolean
C#
public bool AllowNulls { get; set; }
Visual C++
public:
property bool AllowNulls {
    bool get ();
    void set (bool value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


BaseTypeName Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.BaseTypeName Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BaseTypeName As String
C#
public string BaseTypeName { get; set; }
Visual C++
public:
property String^ BaseTypeName {
    String^ get ();
    void set (String^ value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


CacheKey Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.CacheKey Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CacheKey As Integer
C#
public int CacheKey { get; set; }
Visual C++
public:
virtual property int CacheKey {
    int get () sealed;
    void set (int value) sealed;
}

Implements

ICacheableQueryResult..::.CacheKey

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Collation Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.Collation Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Collation As String
C#
public string Collation { get; set; }
Visual C++
public:
property String^ Collation {
    String^ get ();
    void set (String^ value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ColumnID Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.ColumnID Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ColumnID As Integer
C#
public int ColumnID { get; set; }
Visual C++
public:
property int ColumnID {
    int get ();
    void set (int value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ColumnName Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.ColumnName Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ColumnName As String
C#
public string ColumnName { get; set; }
Visual C++
public:
property String^ ColumnName {
    String^ get ();
    void set (String^ value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ColumnSet Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.ColumnSet Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ColumnSet As Boolean
C#
public bool ColumnSet { get; set; }
Visual C++
public:
property bool ColumnSet {
    bool get ();
    void set (bool value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ComputedText Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.ComputedText Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ComputedText As String
C#
public string ComputedText { get; set; }
Visual C++
public:
property String^ ComputedText {
    String^ get ();
    void set (String^ value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DataMaskingFunction Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.DataMaskingFunction Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DataMaskingFunction As String
C#
public string DataMaskingFunction { get; set; }
Visual C++
public:
property String^ DataMaskingFunction {
    String^ get ();
    void set (String^ value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Defaultid Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.Defaultid Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Defaultid As Integer
C#
public int Defaultid { get; set; }
Visual C++
public:
property int Defaultid {
    int get ();
    void set (int value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DefaultName Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.DefaultName Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultName As String
C#
public string DefaultName { get; set; }
Visual C++
public:
property String^ DefaultName {
    String^ get ();
    void set (String^ value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DefaultSchemaName Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.DefaultSchemaName Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultSchemaName As String
C#
public string DefaultSchemaName { get; set; }
Visual C++
public:
property String^ DefaultSchemaName {
    String^ get ();
    void set (String^ value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DefaultTextID Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.DefaultTextID Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultTextID As Integer
C#
public int DefaultTextID { get; set; }
Visual C++
public:
property int DefaultTextID {
    int get ();
    void set (int value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DRIDefaultName Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.DRIDefaultName Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DRIDefaultName As String
C#
public string DRIDefaultName { get; set; }
Visual C++
public:
property String^ DRIDefaultName {
    String^ get ();
    void set (String^ value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Filestream Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.Filestream Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Filestream As Boolean
C#
public bool Filestream { get; set; }
Visual C++
public:
property bool Filestream {
    bool get ();
    void set (bool value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FullTextIndexed Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.FullTextIndexed Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextIndexed As Boolean
C#
public bool FullTextIndexed { get; set; }
Visual C++
public:
property bool FullTextIndexed {
    bool get ();
    void set (bool value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FullTextLanguage Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.FullTextLanguage Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextLanguage As Nullable(Of Integer)
C#
public Nullable<int> FullTextLanguage { get; set; }
Visual C++
public:
property Nullable<int> FullTextLanguage {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FullTextTypeColumn Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.FullTextTypeColumn Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextTypeColumn As String
C#
public string FullTextTypeColumn { get; set; }
Visual C++
public:
property String^ FullTextTypeColumn {
    String^ get ();
    void set (String^ value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Identity Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.Identity Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Identity As Boolean
C#
public bool Identity { get; set; }
Visual C++
public:
property bool Identity {
    bool get ();
    void set (bool value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IdentityCurrent Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.IdentityCurrent Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IdentityCurrent As SqlDecimal
C#
public SqlDecimal IdentityCurrent { get; set; }
Visual C++
public:
property SqlDecimal IdentityCurrent {
    SqlDecimal get ();
    void set (SqlDecimal value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IdentityIncrement Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.IdentityIncrement Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IdentityIncrement As Nullable(Of Long)
C#
public Nullable<long> IdentityIncrement { get; set; }
Visual C++
public:
property Nullable<long long> IdentityIncrement {
    Nullable<long long> get ();
    void set (Nullable<long long> value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IdentitySeed Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.IdentitySeed Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IdentitySeed As SqlDecimal
C#
public SqlDecimal IdentitySeed { get; set; }
Visual C++
public:
property SqlDecimal IdentitySeed {
    SqlDecimal get ();
    void set (SqlDecimal value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsBoundDefault Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.IsBoundDefault Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsBoundDefault As Boolean
C#
public bool IsBoundDefault { get; set; }
Visual C++
public:
property bool IsBoundDefault {
    bool get ();
    void set (bool value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsComputed Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.IsComputed Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsComputed As Boolean
C#
public bool IsComputed { get; set; }
Visual C++
public:
property bool IsComputed {
    bool get ();
    void set (bool value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsPersisted Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.IsPersisted Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsPersisted As Boolean
C#
public bool IsPersisted { get; set; }
Visual C++
public:
property bool IsPersisted {
    bool get ();
    void set (bool value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsRowGuidCol Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.IsRowGuidCol Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsRowGuidCol As Boolean
C#
public bool IsRowGuidCol { get; set; }
Visual C++
public:
property bool IsRowGuidCol {
    bool get ();
    void set (bool value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsSystemNamed Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.IsSystemNamed Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSystemNamed As Boolean
C#
public bool IsSystemNamed { get; set; }
Visual C++
public:
property bool IsSystemNamed {
    bool get ();
    void set (bool value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Length Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.Length Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Length As Integer
C#
public int Length { get; set; }
Visual C++
public:
property int Length {
    int get ();
    void set (int value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


NotForReplication Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.NotForReplication Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NotForReplication As Boolean
C#
public bool NotForReplication { get; set; }
Visual C++
public:
property bool NotForReplication {
    bool get ();
    void set (bool value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Precision Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.Precision Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Precision As Integer
C#
public int Precision { get; set; }
Visual C++
public:
property int Precision {
    int get ();
    void set (int value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


RuleName Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.RuleName Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RuleName As String
C#
public string RuleName { get; set; }
Visual C++
public:
property String^ RuleName {
    String^ get ();
    void set (String^ value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


RuleSchemaName Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.RuleSchemaName Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RuleSchemaName As String
C#
public string RuleSchemaName { get; set; }
Visual C++
public:
property String^ RuleSchemaName {
    String^ get ();
    void set (String^ value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Scale Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.Scale Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Scale As Integer
C#
public int Scale { get; set; }
Visual C++
public:
property int Scale {
    int get ();
    void set (int value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SchemaName Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.SchemaName Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SchemaName As String
C#
public string SchemaName { get; set; }
Visual C++
public:
property String^ SchemaName {
    String^ get ();
    void set (String^ value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Sparse Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.Sparse Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Sparse As Boolean
C#
public bool Sparse { get; set; }
Visual C++
public:
property bool Sparse {
    bool get ();
    void set (bool value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TableName Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.TableName Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TableName As String
C#
public string TableName { get; set; }
Visual C++
public:
property String^ TableName {
    String^ get ();
    void set (String^ value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TableOwner Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.TableOwner Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TableOwner As String
C#
public string TableOwner { get; set; }
Visual C++
public:
property String^ TableOwner {
    String^ get ();
    void set (String^ value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Type Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.Type Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As String
C#
public string Type { get; set; }
Visual C++
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TypeName Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.TypeName Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeName As String
C#
public string TypeName { get; set; }
Visual C++
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TypeOwner Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.TypeOwner Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeOwner As String
C#
public string TypeOwner { get; set; }
Visual C++
public:
property String^ TypeOwner {
    String^ get ();
    void set (String^ value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TypeSchemaName Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.TypeSchemaName Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeSchemaName As String
C#
public string TypeSchemaName { get; set; }
Visual C++
public:
property String^ TypeSchemaName {
    String^ get ();
    void set (String^ value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


XMLCollection Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.XMLCollection Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XMLCollection As String
C#
public string XMLCollection { get; set; }
Visual C++
public:
property String^ XMLCollection {
    String^ get ();
    void set (String^ value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


XMLCollectionSchemaName Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.XMLCollectionSchemaName Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XMLCollectionSchemaName As String
C#
public string XMLCollectionSchemaName { get; set; }
Visual C++
public:
property String^ XMLCollectionSchemaName {
    String^ get ();
    void set (String^ value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


XMLDocument Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResult..::.XMLDocument Property
FieldQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XMLDocument As Boolean
C#
public bool XMLDocument { get; set; }
Visual C++
public:
property bool XMLDocument {
    bool get ();
    void set (bool value);
}

See Also

FieldQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FileTableSystemDefinedObjectQueryResult Class

[image]

SQL Data Compare API 12.0.40
FileTableSystemDefinedObjectQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class FileTableSystemDefinedObjectQueryResult
C#
public class FileTableSystemDefinedObjectQueryResult
Visual C++
public ref class FileTableSystemDefinedObjectQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.FileTableSystemDefinedObjectQueryResult

See Also

FileTableSystemDefinedObjectQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FileTableSystemDefinedObjectQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
FileTableSystemDefinedObjectQueryResult Members
FileTableSystemDefinedObjectQueryResult Class Constructors Methods Properties See Also

The FileTableSystemDefinedObjectQueryResult type exposes the following members.

Constructors

Name | Description
FileTableSystemDefinedObjectQueryResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FiletableObjectID |
ObjectID |

See Also

FileTableSystemDefinedObjectQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FileTableSystemDefinedObjectQueryResult Constructor

[image]

SQL Data Compare API 12.0.40
FileTableSystemDefinedObjectQueryResult Constructor
FileTableSystemDefinedObjectQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FileTableSystemDefinedObjectQueryResult()
Visual C++
public:
FileTableSystemDefinedObjectQueryResult()

See Also

FileTableSystemDefinedObjectQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FileTableSystemDefinedObjectQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
FileTableSystemDefinedObjectQueryResult Properties
FileTableSystemDefinedObjectQueryResult Class See Also

The FileTableSystemDefinedObjectQueryResult type exposes the following properties.

Properties

Name | Description
FiletableObjectID |
ObjectID |

See Also

FileTableSystemDefinedObjectQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FiletableObjectID Property

[image]

SQL Data Compare API 12.0.40
FileTableSystemDefinedObjectQueryResult..::.FiletableObjectID Property
FileTableSystemDefinedObjectQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FiletableObjectID As Integer
C#
public int FiletableObjectID { get; set; }
Visual C++
public:
property int FiletableObjectID {
    int get ();
    void set (int value);
}

See Also

FileTableSystemDefinedObjectQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ObjectID Property

[image]

SQL Data Compare API 12.0.40
FileTableSystemDefinedObjectQueryResult..::.ObjectID Property
FileTableSystemDefinedObjectQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectID As Integer
C#
public int ObjectID { get; set; }
Visual C++
public:
property int ObjectID {
    int get ();
    void set (int value);
}

See Also

FileTableSystemDefinedObjectQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ForeignKeyQueryResult Class

[image]

SQL Data Compare API 12.0.40
ForeignKeyQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ForeignKeyQueryResult
C#
public class ForeignKeyQueryResult
Visual C++
public ref class ForeignKeyQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.ForeignKeyQueryResult

See Also

ForeignKeyQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ForeignKeyQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
ForeignKeyQueryResult Members
ForeignKeyQueryResult Class Constructors Methods Properties See Also

The ForeignKeyQueryResult type exposes the following members.

Constructors

Name | Description
ForeignKeyQueryResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConstraintName |
DeleteReferentialAction |
Disabled |
FieldName |
IsDeleteCascade |
IsNotForReplication |
IsSystemNamed |
IsUpdateCascade |
ObjectID |
ReferencedFieldName |
ReferencedTableName |
ReferencedTableOwner |
TableName |
TableOwner |
UpdateReferentialAction |
WithNoCheck |

See Also

ForeignKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ForeignKeyQueryResult Constructor

[image]

SQL Data Compare API 12.0.40
ForeignKeyQueryResult Constructor
ForeignKeyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ForeignKeyQueryResult()
Visual C++
public:
ForeignKeyQueryResult()

See Also

ForeignKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ForeignKeyQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
ForeignKeyQueryResult Properties
ForeignKeyQueryResult Class See Also

The ForeignKeyQueryResult type exposes the following properties.

Properties

Name | Description
ConstraintName |
DeleteReferentialAction |
Disabled |
FieldName |
IsDeleteCascade |
IsNotForReplication |
IsSystemNamed |
IsUpdateCascade |
ObjectID |
ReferencedFieldName |
ReferencedTableName |
ReferencedTableOwner |
TableName |
TableOwner |
UpdateReferentialAction |
WithNoCheck |

See Also

ForeignKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ConstraintName Property

[image]

SQL Data Compare API 12.0.40
ForeignKeyQueryResult..::.ConstraintName Property
ForeignKeyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ConstraintName As String
C#
public string ConstraintName { get; set; }
Visual C++
public:
property String^ ConstraintName {
    String^ get ();
    void set (String^ value);
}

See Also

ForeignKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DeleteReferentialAction Property

[image]

SQL Data Compare API 12.0.40
ForeignKeyQueryResult..::.DeleteReferentialAction Property
ForeignKeyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DeleteReferentialAction As Byte
C#
public byte DeleteReferentialAction { get; set; }
Visual C++
public:
property unsigned char DeleteReferentialAction {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

ForeignKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Disabled Property

[image]

SQL Data Compare API 12.0.40
ForeignKeyQueryResult..::.Disabled Property
ForeignKeyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Disabled As Boolean
C#
public bool Disabled { get; set; }
Visual C++
public:
property bool Disabled {
    bool get ();
    void set (bool value);
}

See Also

ForeignKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FieldName Property

[image]

SQL Data Compare API 12.0.40
ForeignKeyQueryResult..::.FieldName Property
ForeignKeyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FieldName As String
C#
public string FieldName { get; set; }
Visual C++
public:
property String^ FieldName {
    String^ get ();
    void set (String^ value);
}

See Also

ForeignKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsDeleteCascade Property

[image]

SQL Data Compare API 12.0.40
ForeignKeyQueryResult..::.IsDeleteCascade Property
ForeignKeyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsDeleteCascade As Boolean
C#
public bool IsDeleteCascade { get; set; }
Visual C++
public:
property bool IsDeleteCascade {
    bool get ();
    void set (bool value);
}

See Also

ForeignKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsNotForReplication Property

[image]

SQL Data Compare API 12.0.40
ForeignKeyQueryResult..::.IsNotForReplication Property
ForeignKeyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsNotForReplication As Boolean
C#
public bool IsNotForReplication { get; set; }
Visual C++
public:
property bool IsNotForReplication {
    bool get ();
    void set (bool value);
}

See Also

ForeignKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsSystemNamed Property

[image]

SQL Data Compare API 12.0.40
ForeignKeyQueryResult..::.IsSystemNamed Property
ForeignKeyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSystemNamed As Boolean
C#
public bool IsSystemNamed { get; set; }
Visual C++
public:
property bool IsSystemNamed {
    bool get ();
    void set (bool value);
}

See Also

ForeignKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsUpdateCascade Property

[image]

SQL Data Compare API 12.0.40
ForeignKeyQueryResult..::.IsUpdateCascade Property
ForeignKeyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsUpdateCascade As Boolean
C#
public bool IsUpdateCascade { get; set; }
Visual C++
public:
property bool IsUpdateCascade {
    bool get ();
    void set (bool value);
}

See Also

ForeignKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ObjectID Property

[image]

SQL Data Compare API 12.0.40
ForeignKeyQueryResult..::.ObjectID Property
ForeignKeyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectID As Integer
C#
public int ObjectID { get; set; }
Visual C++
public:
property int ObjectID {
    int get ();
    void set (int value);
}

See Also

ForeignKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ReferencedFieldName Property

[image]

SQL Data Compare API 12.0.40
ForeignKeyQueryResult..::.ReferencedFieldName Property
ForeignKeyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ReferencedFieldName As String
C#
public string ReferencedFieldName { get; set; }
Visual C++
public:
property String^ ReferencedFieldName {
    String^ get ();
    void set (String^ value);
}

See Also

ForeignKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ReferencedTableName Property

[image]

SQL Data Compare API 12.0.40
ForeignKeyQueryResult..::.ReferencedTableName Property
ForeignKeyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ReferencedTableName As String
C#
public string ReferencedTableName { get; set; }
Visual C++
public:
property String^ ReferencedTableName {
    String^ get ();
    void set (String^ value);
}

See Also

ForeignKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ReferencedTableOwner Property

[image]

SQL Data Compare API 12.0.40
ForeignKeyQueryResult..::.ReferencedTableOwner Property
ForeignKeyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ReferencedTableOwner As String
C#
public string ReferencedTableOwner { get; set; }
Visual C++
public:
property String^ ReferencedTableOwner {
    String^ get ();
    void set (String^ value);
}

See Also

ForeignKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TableName Property

[image]

SQL Data Compare API 12.0.40
ForeignKeyQueryResult..::.TableName Property
ForeignKeyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TableName As String
C#
public string TableName { get; set; }
Visual C++
public:
property String^ TableName {
    String^ get ();
    void set (String^ value);
}

See Also

ForeignKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TableOwner Property

[image]

SQL Data Compare API 12.0.40
ForeignKeyQueryResult..::.TableOwner Property
ForeignKeyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TableOwner As String
C#
public string TableOwner { get; set; }
Visual C++
public:
property String^ TableOwner {
    String^ get ();
    void set (String^ value);
}

See Also

ForeignKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


UpdateReferentialAction Property

[image]

SQL Data Compare API 12.0.40
ForeignKeyQueryResult..::.UpdateReferentialAction Property
ForeignKeyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UpdateReferentialAction As Byte
C#
public byte UpdateReferentialAction { get; set; }
Visual C++
public:
property unsigned char UpdateReferentialAction {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

ForeignKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


WithNoCheck Property

[image]

SQL Data Compare API 12.0.40
ForeignKeyQueryResult..::.WithNoCheck Property
ForeignKeyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property WithNoCheck As Boolean
C#
public bool WithNoCheck { get; set; }
Visual C++
public:
property bool WithNoCheck {
    bool get ();
    void set (bool value);
}

See Also

ForeignKeyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FullTextCatalogQueryResult Class

[image]

SQL Data Compare API 12.0.40
FullTextCatalogQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class FullTextCatalogQueryResult
C#
public class FullTextCatalogQueryResult
Visual C++
public ref class FullTextCatalogQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.FullTextCatalogQueryResult

See Also

FullTextCatalogQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FullTextCatalogQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
FullTextCatalogQueryResult Members
FullTextCatalogQueryResult Class Constructors Methods Properties See Also

The FullTextCatalogQueryResult type exposes the following members.

Constructors

Name | Description
FullTextCatalogQueryResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DataSpace |
IsAccentSensitive |
IsDefault |
Name |
Owner |
Path |

See Also

FullTextCatalogQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FullTextCatalogQueryResult Constructor

[image]

SQL Data Compare API 12.0.40
FullTextCatalogQueryResult Constructor
FullTextCatalogQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FullTextCatalogQueryResult()
Visual C++
public:
FullTextCatalogQueryResult()

See Also

FullTextCatalogQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FullTextCatalogQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
FullTextCatalogQueryResult Properties
FullTextCatalogQueryResult Class See Also

The FullTextCatalogQueryResult type exposes the following properties.

Properties

Name | Description
DataSpace |
IsAccentSensitive |
IsDefault |
Name |
Owner |
Path |

See Also

FullTextCatalogQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DataSpace Property

[image]

SQL Data Compare API 12.0.40
FullTextCatalogQueryResult..::.DataSpace Property
FullTextCatalogQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DataSpace As String
C#
public string DataSpace { get; set; }
Visual C++
public:
property String^ DataSpace {
    String^ get ();
    void set (String^ value);
}

See Also

FullTextCatalogQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsAccentSensitive Property

[image]

SQL Data Compare API 12.0.40
FullTextCatalogQueryResult..::.IsAccentSensitive Property
FullTextCatalogQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsAccentSensitive As Boolean
C#
public bool IsAccentSensitive { get; set; }
Visual C++
public:
property bool IsAccentSensitive {
    bool get ();
    void set (bool value);
}

See Also

FullTextCatalogQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsDefault Property

[image]

SQL Data Compare API 12.0.40
FullTextCatalogQueryResult..::.IsDefault Property
FullTextCatalogQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsDefault As Boolean
C#
public bool IsDefault { get; set; }
Visual C++
public:
property bool IsDefault {
    bool get ();
    void set (bool value);
}

See Also

FullTextCatalogQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
FullTextCatalogQueryResult..::.Name Property
FullTextCatalogQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

FullTextCatalogQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
FullTextCatalogQueryResult..::.Owner Property
FullTextCatalogQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Owner As String
C#
public string Owner { get; set; }
Visual C++
public:
property String^ Owner {
    String^ get ();
    void set (String^ value);
}

See Also

FullTextCatalogQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Path Property

[image]

SQL Data Compare API 12.0.40
FullTextCatalogQueryResult..::.Path Property
FullTextCatalogQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Path As String
C#
public string Path { get; set; }
Visual C++
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

See Also

FullTextCatalogQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FunctionQueryResult Class

[image]

SQL Data Compare API 12.0.40
FunctionQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class FunctionQueryResult
C#
public class FunctionQueryResult
Visual C++
public ref class FunctionQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.FunctionQueryResult

See Also

FunctionQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FunctionQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
FunctionQueryResult Members
FunctionQueryResult Class Constructors Methods Properties See Also

The FunctionQueryResult type exposes the following members.

Constructors

Name | Description
FunctionQueryResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AnsiNulls |
Assembly |
AssemblyClass |
AssemblyMethod |
Encrypted |
ExecuteAs |
ExecuteAsOwner |
FunctionName |
FunctionOwner |
FunctionType |
ID |
InlineFunction |
LastModified |
NullOnNullInput |
QuotedIdentifier |
ScalarFunction |
SchemaBound |
SchemaName |
SystemObject |
TableFunction |

See Also

FunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FunctionQueryResult Constructor

[image]

SQL Data Compare API 12.0.40
FunctionQueryResult Constructor
FunctionQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FunctionQueryResult()
Visual C++
public:
FunctionQueryResult()

See Also

FunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FunctionQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
FunctionQueryResult Properties
FunctionQueryResult Class See Also

The FunctionQueryResult type exposes the following properties.

Properties

Name | Description
AnsiNulls |
Assembly |
AssemblyClass |
AssemblyMethod |
Encrypted |
ExecuteAs |
ExecuteAsOwner |
FunctionName |
FunctionOwner |
FunctionType |
ID |
InlineFunction |
LastModified |
NullOnNullInput |
QuotedIdentifier |
ScalarFunction |
SchemaBound |
SchemaName |
SystemObject |
TableFunction |

See Also

FunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AnsiNulls Property

[image]

SQL Data Compare API 12.0.40
FunctionQueryResult..::.AnsiNulls Property
FunctionQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AnsiNulls As Boolean
C#
public bool AnsiNulls { get; set; }
Visual C++
public:
property bool AnsiNulls {
    bool get ();
    void set (bool value);
}

See Also

FunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Assembly Property

[image]

SQL Data Compare API 12.0.40
FunctionQueryResult..::.Assembly Property
FunctionQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Assembly As String
C#
public string Assembly { get; set; }
Visual C++
public:
property String^ Assembly {
    String^ get ();
    void set (String^ value);
}

See Also

FunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AssemblyClass Property

[image]

SQL Data Compare API 12.0.40
FunctionQueryResult..::.AssemblyClass Property
FunctionQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyClass As String
C#
public string AssemblyClass { get; set; }
Visual C++
public:
property String^ AssemblyClass {
    String^ get ();
    void set (String^ value);
}

See Also

FunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AssemblyMethod Property

[image]

SQL Data Compare API 12.0.40
FunctionQueryResult..::.AssemblyMethod Property
FunctionQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyMethod As String
C#
public string AssemblyMethod { get; set; }
Visual C++
public:
property String^ AssemblyMethod {
    String^ get ();
    void set (String^ value);
}

See Also

FunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Encrypted Property

[image]

SQL Data Compare API 12.0.40
FunctionQueryResult..::.Encrypted Property
FunctionQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Encrypted As Boolean
C#
public bool Encrypted { get; set; }
Visual C++
public:
property bool Encrypted {
    bool get ();
    void set (bool value);
}

See Also

FunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ExecuteAs Property

[image]

SQL Data Compare API 12.0.40
FunctionQueryResult..::.ExecuteAs Property
FunctionQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecuteAs As String
C#
public string ExecuteAs { get; set; }
Visual C++
public:
property String^ ExecuteAs {
    String^ get ();
    void set (String^ value);
}

See Also

FunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ExecuteAsOwner Property

[image]

SQL Data Compare API 12.0.40
FunctionQueryResult..::.ExecuteAsOwner Property
FunctionQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecuteAsOwner As Boolean
C#
public bool ExecuteAsOwner { get; set; }
Visual C++
public:
property bool ExecuteAsOwner {
    bool get ();
    void set (bool value);
}

See Also

FunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FunctionName Property

[image]

SQL Data Compare API 12.0.40
FunctionQueryResult..::.FunctionName Property
FunctionQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FunctionName As String
C#
public string FunctionName { get; set; }
Visual C++
public:
property String^ FunctionName {
    String^ get ();
    void set (String^ value);
}

See Also

FunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FunctionOwner Property

[image]

SQL Data Compare API 12.0.40
FunctionQueryResult..::.FunctionOwner Property
FunctionQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FunctionOwner As String
C#
public string FunctionOwner { get; set; }
Visual C++
public:
property String^ FunctionOwner {
    String^ get ();
    void set (String^ value);
}

See Also

FunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FunctionType Property

[image]

SQL Data Compare API 12.0.40
FunctionQueryResult..::.FunctionType Property
FunctionQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FunctionType As String
C#
public string FunctionType { get; set; }
Visual C++
public:
property String^ FunctionType {
    String^ get ();
    void set (String^ value);
}

See Also

FunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ID Property

[image]

SQL Data Compare API 12.0.40
FunctionQueryResult..::.ID Property
FunctionQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ID As Integer
C#
public int ID { get; set; }
Visual C++
public:
property int ID {
    int get ();
    void set (int value);
}

See Also

FunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


InlineFunction Property

[image]

SQL Data Compare API 12.0.40
FunctionQueryResult..::.InlineFunction Property
FunctionQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property InlineFunction As Boolean
C#
public bool InlineFunction { get; set; }
Visual C++
public:
property bool InlineFunction {
    bool get ();
    void set (bool value);
}

See Also

FunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


LastModified Property

[image]

SQL Data Compare API 12.0.40
FunctionQueryResult..::.LastModified Property
FunctionQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LastModified As DateTime
C#
public DateTime LastModified { get; set; }
Visual C++
public:
property DateTime LastModified {
    DateTime get ();
    void set (DateTime value);
}

See Also

FunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


NullOnNullInput Property

[image]

SQL Data Compare API 12.0.40
FunctionQueryResult..::.NullOnNullInput Property
FunctionQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NullOnNullInput As Boolean
C#
public bool NullOnNullInput { get; set; }
Visual C++
public:
property bool NullOnNullInput {
    bool get ();
    void set (bool value);
}

See Also

FunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


QuotedIdentifier Property

[image]

SQL Data Compare API 12.0.40
FunctionQueryResult..::.QuotedIdentifier Property
FunctionQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property QuotedIdentifier As Boolean
C#
public bool QuotedIdentifier { get; set; }
Visual C++
public:
property bool QuotedIdentifier {
    bool get ();
    void set (bool value);
}

See Also

FunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ScalarFunction Property

[image]

SQL Data Compare API 12.0.40
FunctionQueryResult..::.ScalarFunction Property
FunctionQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScalarFunction As Boolean
C#
public bool ScalarFunction { get; set; }
Visual C++
public:
property bool ScalarFunction {
    bool get ();
    void set (bool value);
}

See Also

FunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SchemaBound Property

[image]

SQL Data Compare API 12.0.40
FunctionQueryResult..::.SchemaBound Property
FunctionQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SchemaBound As Boolean
C#
public bool SchemaBound { get; set; }
Visual C++
public:
property bool SchemaBound {
    bool get ();
    void set (bool value);
}

See Also

FunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SchemaName Property

[image]

SQL Data Compare API 12.0.40
FunctionQueryResult..::.SchemaName Property
FunctionQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SchemaName As String
C#
public string SchemaName { get; set; }
Visual C++
public:
property String^ SchemaName {
    String^ get ();
    void set (String^ value);
}

See Also

FunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SystemObject Property

[image]

SQL Data Compare API 12.0.40
FunctionQueryResult..::.SystemObject Property
FunctionQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SystemObject As Boolean
C#
public bool SystemObject { get; set; }
Visual C++
public:
property bool SystemObject {
    bool get ();
    void set (bool value);
}

See Also

FunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TableFunction Property

[image]

SQL Data Compare API 12.0.40
FunctionQueryResult..::.TableFunction Property
FunctionQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TableFunction As Boolean
C#
public bool TableFunction { get; set; }
Visual C++
public:
property bool TableFunction {
    bool get ();
    void set (bool value);
}

See Also

FunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ICacheableQueryResult Interface

[image]

SQL Data Compare API 12.0.40
ICacheableQueryResult Interface
Members See Also

Any DMV query result to be used in IDmvCache needs to implement this interface.

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface ICacheableQueryResult
C#
public interface ICacheableQueryResult
Visual C++
public interface class ICacheableQueryResult

Remarks

The CacheKey should be a unique identifier of an object which has a modification date. For example, indexes don't have a modification date, but the parent table/view does, so a suitable CacheKey is the object ID of the parent table/view.

See Also

ICacheableQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ICacheableQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
ICacheableQueryResult Members
ICacheableQueryResult Interface Properties See Also

The ICacheableQueryResult type exposes the following members.

Properties

Name | Description
CacheKey |

See Also

ICacheableQueryResult Interface
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ICacheableQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
ICacheableQueryResult Properties
ICacheableQueryResult Interface See Also

The ICacheableQueryResult type exposes the following properties.

Properties

Name | Description
CacheKey |

See Also

ICacheableQueryResult Interface
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


CacheKey Property

[image]

SQL Data Compare API 12.0.40
ICacheableQueryResult..::.CacheKey Property
ICacheableQueryResult Interface See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CacheKey As Integer
C#
int CacheKey { get; }
Visual C++
property int CacheKey {
    int get ();
}

See Also

ICacheableQueryResult Interface
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IndexQueryResult Class

[image]

SQL Data Compare API 12.0.40
IndexQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class IndexQueryResult _
    Implements ICacheableQueryResult
C#
public class IndexQueryResult : ICacheableQueryResult
Visual C++
public ref class IndexQueryResult : ICacheableQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.IndexQueryResult

See Also

IndexQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IndexQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
IndexQueryResult Members
IndexQueryResult Class Constructors Methods Properties Explicit Interface Implementations See Also

The IndexQueryResult type exposes the following members.

Constructors

Name | Description
IndexQueryResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowPageLocks |
AllowRowLocks |
BoundingBoxXmax |
BoundingBoxXmin |
BoundingBoxYmax |
BoundingBoxYmin |
BucketCount |
CellsPerObject |
Clustered |
ColumnName |
Columnstore |
DataCompression |
DataCompressionPartitionNumber |
Dataspacetype |
Descending |
FileGroup |
FillFactor |
FilterDefinition |
FullTextKey |
Hash |
IgnoreDupKey |
Included |
Incremental |
Indexid |
IndexName |
IsDisabled |
IsPadIndex |
IsSystemNamed |
IsTable |
IsView |
KeyOrdinal |
Level1Grid |
Level2Grid |
Level3Grid |
Level4Grid |
NoRecompute |
ObjectID |
ParentName |
ParentObjectId |
ParentOwner |
PartitionOrdinal |
Primary |
PrimaryIndexPathName |
PropertyListID |
SchemaName |
SecondaryXMLType |
SpatialIndexType |
Statistics |
TessellationScheme |
Unique |
UniqueConstraint |
UsingIndexName |
Xml |
XmlIndexType |

Explicit Interface Implementations

Name | Description
ICacheableQueryResult..::.CacheKey |

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IndexQueryResult Constructor

[image]

SQL Data Compare API 12.0.40
IndexQueryResult Constructor
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public IndexQueryResult()
Visual C++
public:
IndexQueryResult()

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IndexQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
IndexQueryResult Properties
IndexQueryResult Class See Also

The IndexQueryResult type exposes the following properties.

Properties

Name | Description
AllowPageLocks |
AllowRowLocks |
BoundingBoxXmax |
BoundingBoxXmin |
BoundingBoxYmax |
BoundingBoxYmin |
BucketCount |
CellsPerObject |
Clustered |
ColumnName |
Columnstore |
DataCompression |
DataCompressionPartitionNumber |
Dataspacetype |
Descending |
FileGroup |
FillFactor |
FilterDefinition |
FullTextKey |
Hash |
IgnoreDupKey |
Included |
Incremental |
Indexid |
IndexName |
IsDisabled |
IsPadIndex |
IsSystemNamed |
IsTable |
IsView |
KeyOrdinal |
Level1Grid |
Level2Grid |
Level3Grid |
Level4Grid |
NoRecompute |
ObjectID |
ParentName |
ParentObjectId |
ParentOwner |
PartitionOrdinal |
Primary |
PrimaryIndexPathName |
PropertyListID |
SchemaName |
SecondaryXMLType |
SpatialIndexType |
Statistics |
TessellationScheme |
Unique |
UniqueConstraint |
UsingIndexName |
Xml |
XmlIndexType |

Explicit Interface Implementations

Name | Description
ICacheableQueryResult..::.CacheKey |

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AllowPageLocks Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.AllowPageLocks Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowPageLocks As Boolean
C#
public bool AllowPageLocks { get; set; }
Visual C++
public:
property bool AllowPageLocks {
    bool get ();
    void set (bool value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AllowRowLocks Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.AllowRowLocks Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowRowLocks As Boolean
C#
public bool AllowRowLocks { get; set; }
Visual C++
public:
property bool AllowRowLocks {
    bool get ();
    void set (bool value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


BoundingBoxXmax Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.BoundingBoxXmax Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BoundingBoxXmax As Double
C#
public double BoundingBoxXmax { get; set; }
Visual C++
public:
property double BoundingBoxXmax {
    double get ();
    void set (double value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


BoundingBoxXmin Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.BoundingBoxXmin Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BoundingBoxXmin As Double
C#
public double BoundingBoxXmin { get; set; }
Visual C++
public:
property double BoundingBoxXmin {
    double get ();
    void set (double value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


BoundingBoxYmax Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.BoundingBoxYmax Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BoundingBoxYmax As Double
C#
public double BoundingBoxYmax { get; set; }
Visual C++
public:
property double BoundingBoxYmax {
    double get ();
    void set (double value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


BoundingBoxYmin Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.BoundingBoxYmin Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BoundingBoxYmin As Double
C#
public double BoundingBoxYmin { get; set; }
Visual C++
public:
property double BoundingBoxYmin {
    double get ();
    void set (double value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


BucketCount Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.BucketCount Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BucketCount As Integer
C#
public int BucketCount { get; set; }
Visual C++
public:
property int BucketCount {
    int get ();
    void set (int value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ICacheableQueryResult.CacheKey Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.ICacheableQueryResult..::.CacheKey Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private ReadOnly Property CacheKey As Integer
    Implements ICacheableQueryResult.CacheKey
C#
int ICacheableQueryResult.CacheKey { get; }
Visual C++
private:
virtual property int CacheKey {
    int get () sealed = ICacheableQueryResult::CacheKey::get;
}

Implements

ICacheableQueryResult..::.CacheKey

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


CellsPerObject Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.CellsPerObject Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CellsPerObject As Short
C#
public short CellsPerObject { get; set; }
Visual C++
public:
property short CellsPerObject {
    short get ();
    void set (short value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Clustered Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.Clustered Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Clustered As Boolean
C#
public bool Clustered { get; set; }
Visual C++
public:
property bool Clustered {
    bool get ();
    void set (bool value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ColumnName Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.ColumnName Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ColumnName As String
C#
public string ColumnName { get; set; }
Visual C++
public:
property String^ ColumnName {
    String^ get ();
    void set (String^ value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Columnstore Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.Columnstore Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Columnstore As Boolean
C#
public bool Columnstore { get; set; }
Visual C++
public:
property bool Columnstore {
    bool get ();
    void set (bool value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DataCompression Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.DataCompression Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DataCompression As Byte
C#
public byte DataCompression { get; set; }
Visual C++
public:
property unsigned char DataCompression {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DataCompressionPartitionNumber Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.DataCompressionPartitionNumber Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DataCompressionPartitionNumber As Integer
C#
public int DataCompressionPartitionNumber { get; set; }
Visual C++
public:
property int DataCompressionPartitionNumber {
    int get ();
    void set (int value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Dataspacetype Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.Dataspacetype Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Dataspacetype As String
C#
public string Dataspacetype { get; set; }
Visual C++
public:
property String^ Dataspacetype {
    String^ get ();
    void set (String^ value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Descending Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.Descending Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Descending As Boolean
C#
public bool Descending { get; set; }
Visual C++
public:
property bool Descending {
    bool get ();
    void set (bool value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FileGroup Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.FileGroup Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FileGroup As String
C#
public string FileGroup { get; set; }
Visual C++
public:
property String^ FileGroup {
    String^ get ();
    void set (String^ value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FillFactor Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.FillFactor Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FillFactor As Byte
C#
public byte FillFactor { get; set; }
Visual C++
public:
property unsigned char FillFactor {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FilterDefinition Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.FilterDefinition Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FilterDefinition As String
C#
public string FilterDefinition { get; set; }
Visual C++
public:
property String^ FilterDefinition {
    String^ get ();
    void set (String^ value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FullTextKey Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.FullTextKey Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextKey As Boolean
C#
public bool FullTextKey { get; set; }
Visual C++
public:
property bool FullTextKey {
    bool get ();
    void set (bool value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Hash Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.Hash Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Hash As Boolean
C#
public bool Hash { get; set; }
Visual C++
public:
property bool Hash {
    bool get ();
    void set (bool value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IgnoreDupKey Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.IgnoreDupKey Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IgnoreDupKey As Boolean
C#
public bool IgnoreDupKey { get; set; }
Visual C++
public:
property bool IgnoreDupKey {
    bool get ();
    void set (bool value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Included Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.Included Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Included As Boolean
C#
public bool Included { get; set; }
Visual C++
public:
property bool Included {
    bool get ();
    void set (bool value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Incremental Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.Incremental Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Incremental As Boolean
C#
public bool Incremental { get; set; }
Visual C++
public:
property bool Incremental {
    bool get ();
    void set (bool value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Indexid Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.Indexid Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Indexid As Integer
C#
public int Indexid { get; set; }
Visual C++
public:
property int Indexid {
    int get ();
    void set (int value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IndexName Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.IndexName Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IndexName As String
C#
public string IndexName { get; set; }
Visual C++
public:
property String^ IndexName {
    String^ get ();
    void set (String^ value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsDisabled Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.IsDisabled Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsDisabled As Boolean
C#
public bool IsDisabled { get; set; }
Visual C++
public:
property bool IsDisabled {
    bool get ();
    void set (bool value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsPadIndex Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.IsPadIndex Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsPadIndex As Boolean
C#
public bool IsPadIndex { get; set; }
Visual C++
public:
property bool IsPadIndex {
    bool get ();
    void set (bool value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsSystemNamed Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.IsSystemNamed Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSystemNamed As Boolean
C#
public bool IsSystemNamed { get; set; }
Visual C++
public:
property bool IsSystemNamed {
    bool get ();
    void set (bool value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsTable Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.IsTable Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsTable As Boolean
C#
public bool IsTable { get; set; }
Visual C++
public:
property bool IsTable {
    bool get ();
    void set (bool value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsView Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.IsView Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsView As Boolean
C#
public bool IsView { get; set; }
Visual C++
public:
property bool IsView {
    bool get ();
    void set (bool value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


KeyOrdinal Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.KeyOrdinal Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property KeyOrdinal As Byte
C#
public byte KeyOrdinal { get; set; }
Visual C++
public:
property unsigned char KeyOrdinal {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Level1Grid Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.Level1Grid Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Level1Grid As Short
C#
public short Level1Grid { get; set; }
Visual C++
public:
property short Level1Grid {
    short get ();
    void set (short value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Level2Grid Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.Level2Grid Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Level2Grid As Short
C#
public short Level2Grid { get; set; }
Visual C++
public:
property short Level2Grid {
    short get ();
    void set (short value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Level3Grid Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.Level3Grid Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Level3Grid As Short
C#
public short Level3Grid { get; set; }
Visual C++
public:
property short Level3Grid {
    short get ();
    void set (short value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Level4Grid Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.Level4Grid Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Level4Grid As Short
C#
public short Level4Grid { get; set; }
Visual C++
public:
property short Level4Grid {
    short get ();
    void set (short value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


NoRecompute Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.NoRecompute Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NoRecompute As Boolean
C#
public bool NoRecompute { get; set; }
Visual C++
public:
property bool NoRecompute {
    bool get ();
    void set (bool value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ObjectID Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.ObjectID Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectID As Integer
C#
public int ObjectID { get; set; }
Visual C++
public:
property int ObjectID {
    int get ();
    void set (int value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ParentName Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.ParentName Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ParentName As String
C#
public string ParentName { get; set; }
Visual C++
public:
property String^ ParentName {
    String^ get ();
    void set (String^ value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ParentObjectId Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.ParentObjectId Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ParentObjectId As Integer
C#
public int ParentObjectId { get; set; }
Visual C++
public:
property int ParentObjectId {
    int get ();
    void set (int value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ParentOwner Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.ParentOwner Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ParentOwner As String
C#
public string ParentOwner { get; set; }
Visual C++
public:
property String^ ParentOwner {
    String^ get ();
    void set (String^ value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PartitionOrdinal Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.PartitionOrdinal Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PartitionOrdinal As Byte
C#
public byte PartitionOrdinal { get; set; }
Visual C++
public:
property unsigned char PartitionOrdinal {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Primary Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.Primary Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Primary As Boolean
C#
public bool Primary { get; set; }
Visual C++
public:
property bool Primary {
    bool get ();
    void set (bool value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PrimaryIndexPathName Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.PrimaryIndexPathName Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PrimaryIndexPathName As String
C#
public string PrimaryIndexPathName { get; set; }
Visual C++
public:
property String^ PrimaryIndexPathName {
    String^ get ();
    void set (String^ value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PropertyListID Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.PropertyListID Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PropertyListID As Integer
C#
public int PropertyListID { get; set; }
Visual C++
public:
property int PropertyListID {
    int get ();
    void set (int value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SchemaName Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.SchemaName Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SchemaName As String
C#
public string SchemaName { get; set; }
Visual C++
public:
property String^ SchemaName {
    String^ get ();
    void set (String^ value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SecondaryXMLType Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.SecondaryXMLType Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SecondaryXMLType As String
C#
public string SecondaryXMLType { get; set; }
Visual C++
public:
property String^ SecondaryXMLType {
    String^ get ();
    void set (String^ value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SpatialIndexType Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.SpatialIndexType Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SpatialIndexType As Nullable(Of Integer)
C#
public Nullable<int> SpatialIndexType { get; set; }
Visual C++
public:
property Nullable<int> SpatialIndexType {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Statistics Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.Statistics Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Statistics As Boolean
C#
public bool Statistics { get; set; }
Visual C++
public:
property bool Statistics {
    bool get ();
    void set (bool value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TessellationScheme Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.TessellationScheme Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TessellationScheme As String
C#
public string TessellationScheme { get; set; }
Visual C++
public:
property String^ TessellationScheme {
    String^ get ();
    void set (String^ value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Unique Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.Unique Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Unique As Boolean
C#
public bool Unique { get; set; }
Visual C++
public:
property bool Unique {
    bool get ();
    void set (bool value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


UniqueConstraint Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.UniqueConstraint Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UniqueConstraint As Boolean
C#
public bool UniqueConstraint { get; set; }
Visual C++
public:
property bool UniqueConstraint {
    bool get ();
    void set (bool value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


UsingIndexName Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.UsingIndexName Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UsingIndexName As String
C#
public string UsingIndexName { get; set; }
Visual C++
public:
property String^ UsingIndexName {
    String^ get ();
    void set (String^ value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Xml Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.Xml Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Xml As Boolean
C#
public bool Xml { get; set; }
Visual C++
public:
property bool Xml {
    bool get ();
    void set (bool value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


XmlIndexType Property

[image]

SQL Data Compare API 12.0.40
IndexQueryResult..::.XmlIndexType Property
IndexQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlIndexType As Byte
C#
public byte XmlIndexType { get; set; }
Visual C++
public:
property unsigned char XmlIndexType {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

IndexQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


InvalidDmvQueryResultException Class

[image]

SQL Data Compare API 12.0.40
InvalidDmvQueryResultException Class
Members See Also

Exception raised when an error occurs while reading from the DMV queries

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class InvalidDmvQueryResultException _
    Inherits SqlCompareException
C#
public class InvalidDmvQueryResultException : SqlCompareException
Visual C++
public ref class InvalidDmvQueryResultException : public SqlCompareException

Inheritance Hierarchy

Object
Exception
RedGate.SQLCompare.Engine..::.SqlCompareException
RedGate.SQLCompare.Engine.Registration.QueryResult..::.InvalidDmvQueryResultException

See Also

InvalidDmvQueryResultException Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


InvalidDmvQueryResultException Members

[image] [image]

SQL Data Compare API 12.0.40
InvalidDmvQueryResultException Members
InvalidDmvQueryResultException Class Constructors Methods Properties See Also

The InvalidDmvQueryResultException type exposes the following members.

Constructors

Name | Description
InvalidDmvQueryResultException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidDmvQueryResultException Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


InvalidDmvQueryResultException Constructor

[image] [image]

SQL Data Compare API 12.0.40
InvalidDmvQueryResultException Constructor
InvalidDmvQueryResultException Class See Also

Overload List

Name | Description
InvalidDmvQueryResultException()()() | Default constructor for InvalidDmvQueryResultException
InvalidDmvQueryResultException(String) | Constructs an InvalidDmvQueryResultException with a specific message
InvalidDmvQueryResultException(SerializationInfo, StreamingContext) | Constructs an InvalidDmvQueryResultException during deserialization.
InvalidDmvQueryResultException(String, Exception) | Constructs an InvalidDmvQueryResultException with a specific message and an underlying cause.

See Also

InvalidDmvQueryResultException Class
InvalidDmvQueryResultException Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


InvalidDmvQueryResultException Constructor

[image]

SQL Data Compare API 12.0.40
InvalidDmvQueryResultException Constructor
InvalidDmvQueryResultException Class See Also

Default constructor for InvalidDmvQueryResultException

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public InvalidDmvQueryResultException()
Visual C++
public:
InvalidDmvQueryResultException()

See Also

InvalidDmvQueryResultException Class
InvalidDmvQueryResultException Overload
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


InvalidDmvQueryResultException Constructor ()

[image]

SQL Data Compare API 12.0.40
InvalidDmvQueryResultException Constructor ()
InvalidDmvQueryResultException Class See Also

Constructs an InvalidDmvQueryResultException with a specific message

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public InvalidDmvQueryResultException(
    string message
)
Visual C++
public:
InvalidDmvQueryResultException(
    String^ message
)

Parameters

message
Type: String
The cause of the error

See Also

InvalidDmvQueryResultException Class
InvalidDmvQueryResultException Overload
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


InvalidDmvQueryResultException Constructor (, )

[image]

SQL Data Compare API 12.0.40
InvalidDmvQueryResultException Constructor (, )
InvalidDmvQueryResultException Class See Also

Constructs an InvalidDmvQueryResultException during deserialization.

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected InvalidDmvQueryResultException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
InvalidDmvQueryResultException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: SerializationInfo
context
Type: StreamingContext

See Also

InvalidDmvQueryResultException Class
InvalidDmvQueryResultException Overload
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


InvalidDmvQueryResultException Constructor (, )

[image]

SQL Data Compare API 12.0.40
InvalidDmvQueryResultException Constructor (, )
InvalidDmvQueryResultException Class See Also

Constructs an InvalidDmvQueryResultException with a specific message and an underlying cause.

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
C#
public InvalidDmvQueryResultException(
    string message,
    Exception inner
)
Visual C++
public:
InvalidDmvQueryResultException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: String
The error message to display to the user
inner
Type: Exception
The underlying exception

See Also

InvalidDmvQueryResultException Class
InvalidDmvQueryResultException Overload
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


MessageTypeQueryResult Class

[image]

SQL Data Compare API 12.0.40
MessageTypeQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class MessageTypeQueryResult
C#
public class MessageTypeQueryResult
Visual C++
public ref class MessageTypeQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.MessageTypeQueryResult

See Also

MessageTypeQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


MessageTypeQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
MessageTypeQueryResult Members
MessageTypeQueryResult Class Constructors Methods Properties See Also

The MessageTypeQueryResult type exposes the following members.

Constructors

Name | Description
MessageTypeQueryResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Collectionname |
Collectionschema |
ID |
Name |
Owner |
Validation |

See Also

MessageTypeQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


MessageTypeQueryResult Constructor

[image]

SQL Data Compare API 12.0.40
MessageTypeQueryResult Constructor
MessageTypeQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MessageTypeQueryResult()
Visual C++
public:
MessageTypeQueryResult()

See Also

MessageTypeQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


MessageTypeQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
MessageTypeQueryResult Properties
MessageTypeQueryResult Class See Also

The MessageTypeQueryResult type exposes the following properties.

Properties

Name | Description
Collectionname |
Collectionschema |
ID |
Name |
Owner |
Validation |

See Also

MessageTypeQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Collectionname Property

[image]

SQL Data Compare API 12.0.40
MessageTypeQueryResult..::.Collectionname Property
MessageTypeQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Collectionname As String
C#
public string Collectionname { get; set; }
Visual C++
public:
property String^ Collectionname {
    String^ get ();
    void set (String^ value);
}

See Also

MessageTypeQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Collectionschema Property

[image]

SQL Data Compare API 12.0.40
MessageTypeQueryResult..::.Collectionschema Property
MessageTypeQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Collectionschema As String
C#
public string Collectionschema { get; set; }
Visual C++
public:
property String^ Collectionschema {
    String^ get ();
    void set (String^ value);
}

See Also

MessageTypeQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ID Property

[image]

SQL Data Compare API 12.0.40
MessageTypeQueryResult..::.ID Property
MessageTypeQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ID As Integer
C#
public int ID { get; set; }
Visual C++
public:
property int ID {
    int get ();
    void set (int value);
}

See Also

MessageTypeQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
MessageTypeQueryResult..::.Name Property
MessageTypeQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

MessageTypeQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
MessageTypeQueryResult..::.Owner Property
MessageTypeQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Owner As String
C#
public string Owner { get; set; }
Visual C++
public:
property String^ Owner {
    String^ get ();
    void set (String^ value);
}

See Also

MessageTypeQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Validation Property

[image]

SQL Data Compare API 12.0.40
MessageTypeQueryResult..::.Validation Property
MessageTypeQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Validation As String
C#
public string Validation { get; set; }
Visual C++
public:
property String^ Validation {
    String^ get ();
    void set (String^ value);
}

See Also

MessageTypeQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ObjectNameQueryResult Class

[image]

SQL Data Compare API 12.0.40
ObjectNameQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ObjectNameQueryResult
C#
public class ObjectNameQueryResult
Visual C++
public ref class ObjectNameQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.ObjectNameQueryResult

See Also

ObjectNameQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ObjectNameQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
ObjectNameQueryResult Members
ObjectNameQueryResult Class Constructors Methods Properties See Also

The ObjectNameQueryResult type exposes the following members.

Constructors

Name | Description
ObjectNameQueryResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ID |
Name |
Ownername |

See Also

ObjectNameQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ObjectNameQueryResult Constructor

[image]

SQL Data Compare API 12.0.40
ObjectNameQueryResult Constructor
ObjectNameQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ObjectNameQueryResult()
Visual C++
public:
ObjectNameQueryResult()

See Also

ObjectNameQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ObjectNameQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
ObjectNameQueryResult Properties
ObjectNameQueryResult Class See Also

The ObjectNameQueryResult type exposes the following properties.

Properties

Name | Description
ID |
Name |
Ownername |

See Also

ObjectNameQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ID Property

[image]

SQL Data Compare API 12.0.40
ObjectNameQueryResult..::.ID Property
ObjectNameQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ID As Integer
C#
public int ID { get; set; }
Visual C++
public:
property int ID {
    int get ();
    void set (int value);
}

See Also

ObjectNameQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
ObjectNameQueryResult..::.Name Property
ObjectNameQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ObjectNameQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Ownername Property

[image]

SQL Data Compare API 12.0.40
ObjectNameQueryResult..::.Ownername Property
ObjectNameQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Ownername As String
C#
public string Ownername { get; set; }
Visual C++
public:
property String^ Ownername {
    String^ get ();
    void set (String^ value);
}

See Also

ObjectNameQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ParameterQueryResult Class

[image]

SQL Data Compare API 12.0.40
ParameterQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ParameterQueryResult
C#
public class ParameterQueryResult
Visual C++
public ref class ParameterQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.ParameterQueryResult

See Also

ParameterQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ParameterQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
ParameterQueryResult Members
ParameterQueryResult Class Constructors Methods Properties See Also

The ParameterQueryResult type exposes the following members.

Constructors

Name | Description
ParameterQueryResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BaseTypeName |
DefaultValueAsByteArray |
DefaultValueAsString |
HasDefaultValue |
IsOutput |
Length |
ObjectName |
ObjectType |
ParameterID |
ParameterName |
Precision |
Scale |
SchemaName |
TypeName |
TypeSchemaName |
XMLCollection |
XMLCollectionSchemaName |
XMLDocument |

See Also

ParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ParameterQueryResult Constructor

[image]

SQL Data Compare API 12.0.40
ParameterQueryResult Constructor
ParameterQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ParameterQueryResult()
Visual C++
public:
ParameterQueryResult()

See Also

ParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ParameterQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
ParameterQueryResult Properties
ParameterQueryResult Class See Also

The ParameterQueryResult type exposes the following properties.

Properties

Name | Description
BaseTypeName |
DefaultValueAsByteArray |
DefaultValueAsString |
HasDefaultValue |
IsOutput |
Length |
ObjectName |
ObjectType |
ParameterID |
ParameterName |
Precision |
Scale |
SchemaName |
TypeName |
TypeSchemaName |
XMLCollection |
XMLCollectionSchemaName |
XMLDocument |

See Also

ParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


BaseTypeName Property

[image]

SQL Data Compare API 12.0.40
ParameterQueryResult..::.BaseTypeName Property
ParameterQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BaseTypeName As String
C#
public string BaseTypeName { get; set; }
Visual C++
public:
property String^ BaseTypeName {
    String^ get ();
    void set (String^ value);
}

See Also

ParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DefaultValueAsByteArray Property

[image]

SQL Data Compare API 12.0.40
ParameterQueryResult..::.DefaultValueAsByteArray Property
ParameterQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultValueAsByteArray As Byte()
C#
public byte[] DefaultValueAsByteArray { get; set; }
Visual C++
public:
property array<unsigned char>^ DefaultValueAsByteArray {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

ParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DefaultValueAsString Property

[image]

SQL Data Compare API 12.0.40
ParameterQueryResult..::.DefaultValueAsString Property
ParameterQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultValueAsString As String
C#
public string DefaultValueAsString { get; set; }
Visual C++
public:
property String^ DefaultValueAsString {
    String^ get ();
    void set (String^ value);
}

See Also

ParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


HasDefaultValue Property

[image]

SQL Data Compare API 12.0.40
ParameterQueryResult..::.HasDefaultValue Property
ParameterQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property HasDefaultValue As Boolean
C#
public bool HasDefaultValue { get; set; }
Visual C++
public:
property bool HasDefaultValue {
    bool get ();
    void set (bool value);
}

See Also

ParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsOutput Property

[image]

SQL Data Compare API 12.0.40
ParameterQueryResult..::.IsOutput Property
ParameterQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsOutput As Boolean
C#
public bool IsOutput { get; set; }
Visual C++
public:
property bool IsOutput {
    bool get ();
    void set (bool value);
}

See Also

ParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Length Property

[image]

SQL Data Compare API 12.0.40
ParameterQueryResult..::.Length Property
ParameterQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Length As Integer
C#
public int Length { get; set; }
Visual C++
public:
property int Length {
    int get ();
    void set (int value);
}

See Also

ParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ObjectName Property

[image]

SQL Data Compare API 12.0.40
ParameterQueryResult..::.ObjectName Property
ParameterQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectName As String
C#
public string ObjectName { get; set; }
Visual C++
public:
property String^ ObjectName {
    String^ get ();
    void set (String^ value);
}

See Also

ParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
ParameterQueryResult..::.ObjectType Property
ParameterQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectType As String
C#
public string ObjectType { get; set; }
Visual C++
public:
property String^ ObjectType {
    String^ get ();
    void set (String^ value);
}

See Also

ParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ParameterID Property

[image]

SQL Data Compare API 12.0.40
ParameterQueryResult..::.ParameterID Property
ParameterQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterID As Integer
C#
public int ParameterID { get; set; }
Visual C++
public:
property int ParameterID {
    int get ();
    void set (int value);
}

See Also

ParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ParameterName Property

[image]

SQL Data Compare API 12.0.40
ParameterQueryResult..::.ParameterName Property
ParameterQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterName As String
C#
public string ParameterName { get; set; }
Visual C++
public:
property String^ ParameterName {
    String^ get ();
    void set (String^ value);
}

See Also

ParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Precision Property

[image]

SQL Data Compare API 12.0.40
ParameterQueryResult..::.Precision Property
ParameterQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Precision As Integer
C#
public int Precision { get; set; }
Visual C++
public:
property int Precision {
    int get ();
    void set (int value);
}

See Also

ParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Scale Property

[image]

SQL Data Compare API 12.0.40
ParameterQueryResult..::.Scale Property
ParameterQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Scale As Integer
C#
public int Scale { get; set; }
Visual C++
public:
property int Scale {
    int get ();
    void set (int value);
}

See Also

ParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SchemaName Property

[image]

SQL Data Compare API 12.0.40
ParameterQueryResult..::.SchemaName Property
ParameterQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SchemaName As String
C#
public string SchemaName { get; set; }
Visual C++
public:
property String^ SchemaName {
    String^ get ();
    void set (String^ value);
}

See Also

ParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TypeName Property

[image]

SQL Data Compare API 12.0.40
ParameterQueryResult..::.TypeName Property
ParameterQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeName As String
C#
public string TypeName { get; set; }
Visual C++
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}

See Also

ParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TypeSchemaName Property

[image]

SQL Data Compare API 12.0.40
ParameterQueryResult..::.TypeSchemaName Property
ParameterQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeSchemaName As String
C#
public string TypeSchemaName { get; set; }
Visual C++
public:
property String^ TypeSchemaName {
    String^ get ();
    void set (String^ value);
}

See Also

ParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


XMLCollection Property

[image]

SQL Data Compare API 12.0.40
ParameterQueryResult..::.XMLCollection Property
ParameterQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XMLCollection As String
C#
public string XMLCollection { get; set; }
Visual C++
public:
property String^ XMLCollection {
    String^ get ();
    void set (String^ value);
}

See Also

ParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


XMLCollectionSchemaName Property

[image]

SQL Data Compare API 12.0.40
ParameterQueryResult..::.XMLCollectionSchemaName Property
ParameterQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XMLCollectionSchemaName As String
C#
public string XMLCollectionSchemaName { get; set; }
Visual C++
public:
property String^ XMLCollectionSchemaName {
    String^ get ();
    void set (String^ value);
}

See Also

ParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


XMLDocument Property

[image]

SQL Data Compare API 12.0.40
ParameterQueryResult..::.XMLDocument Property
ParameterQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XMLDocument As Boolean
C#
public bool XMLDocument { get; set; }
Visual C++
public:
property bool XMLDocument {
    bool get ();
    void set (bool value);
}

See Also

ParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PartitionFunctionQueryResult Class

[image]

SQL Data Compare API 12.0.40
PartitionFunctionQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class PartitionFunctionQueryResult
C#
public class PartitionFunctionQueryResult
Visual C++
public ref class PartitionFunctionQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.PartitionFunctionQueryResult

See Also

PartitionFunctionQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PartitionFunctionQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
PartitionFunctionQueryResult Members
PartitionFunctionQueryResult Class Constructors Methods Properties See Also

The PartitionFunctionQueryResult type exposes the following members.

Constructors

Name | Description
PartitionFunctionQueryResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ID |
Length |
Name |
OnRight |

See Also

PartitionFunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PartitionFunctionQueryResult Constructor

[image]

SQL Data Compare API 12.0.40
PartitionFunctionQueryResult Constructor
PartitionFunctionQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PartitionFunctionQueryResult()
Visual C++
public:
PartitionFunctionQueryResult()

See Also

PartitionFunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PartitionFunctionQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
PartitionFunctionQueryResult Properties
PartitionFunctionQueryResult Class See Also

The PartitionFunctionQueryResult type exposes the following properties.

Properties

Name | Description
ID |
Length |
Name |
OnRight |

See Also

PartitionFunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ID Property

[image]

SQL Data Compare API 12.0.40
PartitionFunctionQueryResult..::.ID Property
PartitionFunctionQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ID As Integer
C#
public int ID { get; set; }
Visual C++
public:
property int ID {
    int get ();
    void set (int value);
}

See Also

PartitionFunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Length Property

[image]

SQL Data Compare API 12.0.40
PartitionFunctionQueryResult..::.Length Property
PartitionFunctionQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Length As Integer
C#
public int Length { get; set; }
Visual C++
public:
property int Length {
    int get ();
    void set (int value);
}

See Also

PartitionFunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
PartitionFunctionQueryResult..::.Name Property
PartitionFunctionQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

PartitionFunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


OnRight Property

[image]

SQL Data Compare API 12.0.40
PartitionFunctionQueryResult..::.OnRight Property
PartitionFunctionQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property OnRight As Boolean
C#
public bool OnRight { get; set; }
Visual C++
public:
property bool OnRight {
    bool get ();
    void set (bool value);
}

See Also

PartitionFunctionQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PartitionParameterQueryResult Class

[image]

SQL Data Compare API 12.0.40
PartitionParameterQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class PartitionParameterQueryResult
C#
public class PartitionParameterQueryResult
Visual C++
public ref class PartitionParameterQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.PartitionParameterQueryResult

See Also

PartitionParameterQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PartitionParameterQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
PartitionParameterQueryResult Members
PartitionParameterQueryResult Class Constructors Methods Properties See Also

The PartitionParameterQueryResult type exposes the following members.

Constructors

Name | Description
PartitionParameterQueryResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CollationName |
Functionname |
Length |
ParameterID |
Precision |
Scale |
Typename |

See Also

PartitionParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PartitionParameterQueryResult Constructor

[image]

SQL Data Compare API 12.0.40
PartitionParameterQueryResult Constructor
PartitionParameterQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PartitionParameterQueryResult()
Visual C++
public:
PartitionParameterQueryResult()

See Also

PartitionParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PartitionParameterQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
PartitionParameterQueryResult Properties
PartitionParameterQueryResult Class See Also

The PartitionParameterQueryResult type exposes the following properties.

Properties

Name | Description
CollationName |
Functionname |
Length |
ParameterID |
Precision |
Scale |
Typename |

See Also

PartitionParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


CollationName Property

[image]

SQL Data Compare API 12.0.40
PartitionParameterQueryResult..::.CollationName Property
PartitionParameterQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CollationName As String
C#
public string CollationName { get; set; }
Visual C++
public:
property String^ CollationName {
    String^ get ();
    void set (String^ value);
}

See Also

PartitionParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Functionname Property

[image]

SQL Data Compare API 12.0.40
PartitionParameterQueryResult..::.Functionname Property
PartitionParameterQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Functionname As String
C#
public string Functionname { get; set; }
Visual C++
public:
property String^ Functionname {
    String^ get ();
    void set (String^ value);
}

See Also

PartitionParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Length Property

[image]

SQL Data Compare API 12.0.40
PartitionParameterQueryResult..::.Length Property
PartitionParameterQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Length As Integer
C#
public int Length { get; set; }
Visual C++
public:
property int Length {
    int get ();
    void set (int value);
}

See Also

PartitionParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ParameterID Property

[image]

SQL Data Compare API 12.0.40
PartitionParameterQueryResult..::.ParameterID Property
PartitionParameterQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterID As Integer
C#
public int ParameterID { get; set; }
Visual C++
public:
property int ParameterID {
    int get ();
    void set (int value);
}

See Also

PartitionParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Precision Property

[image]

SQL Data Compare API 12.0.40
PartitionParameterQueryResult..::.Precision Property
PartitionParameterQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Precision As Byte
C#
public byte Precision { get; set; }
Visual C++
public:
property unsigned char Precision {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

PartitionParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Scale Property

[image]

SQL Data Compare API 12.0.40
PartitionParameterQueryResult..::.Scale Property
PartitionParameterQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Scale As Byte
C#
public byte Scale { get; set; }
Visual C++
public:
property unsigned char Scale {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

PartitionParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Typename Property

[image]

SQL Data Compare API 12.0.40
PartitionParameterQueryResult..::.Typename Property
PartitionParameterQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Typename As String
C#
public string Typename { get; set; }
Visual C++
public:
property String^ Typename {
    String^ get ();
    void set (String^ value);
}

See Also

PartitionParameterQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PartitionRangeValueSqlResult Class

[image]

SQL Data Compare API 12.0.40
PartitionRangeValueSqlResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class PartitionRangeValueSqlResult
C#
public class PartitionRangeValueSqlResult
Visual C++
public ref class PartitionRangeValueSqlResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.PartitionRangeValueSqlResult

See Also

PartitionRangeValueSqlResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PartitionRangeValueSqlResult Members

[image] [image]

SQL Data Compare API 12.0.40
PartitionRangeValueSqlResult Members
PartitionRangeValueSqlResult Class Constructors Methods Properties See Also

The PartitionRangeValueSqlResult type exposes the following members.

Constructors

Name | Description
PartitionRangeValueSqlResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundaryID |
Field0 |
Field1 |
FieldAsSqlDecimal |
Functionname |
Value |

See Also

PartitionRangeValueSqlResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PartitionRangeValueSqlResult Constructor

[image]

SQL Data Compare API 12.0.40
PartitionRangeValueSqlResult Constructor
PartitionRangeValueSqlResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PartitionRangeValueSqlResult()
Visual C++
public:
PartitionRangeValueSqlResult()

See Also

PartitionRangeValueSqlResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PartitionRangeValueSqlResult Properties

[image] [image]

SQL Data Compare API 12.0.40
PartitionRangeValueSqlResult Properties
PartitionRangeValueSqlResult Class See Also

The PartitionRangeValueSqlResult type exposes the following properties.

Properties

Name | Description
BoundaryID |
Field0 |
Field1 |
FieldAsSqlDecimal |
Functionname |
Value |

See Also

PartitionRangeValueSqlResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


BoundaryID Property

[image]

SQL Data Compare API 12.0.40
PartitionRangeValueSqlResult..::.BoundaryID Property
PartitionRangeValueSqlResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BoundaryID As Integer
C#
public int BoundaryID { get; set; }
Visual C++
public:
property int BoundaryID {
    int get ();
    void set (int value);
}

See Also

PartitionRangeValueSqlResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Field0 Property

[image]

SQL Data Compare API 12.0.40
PartitionRangeValueSqlResult..::.Field0 Property
PartitionRangeValueSqlResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Field0 As Byte()
C#
public byte[] Field0 { get; set; }
Visual C++
public:
property array<unsigned char>^ Field0 {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

PartitionRangeValueSqlResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Field1 Property

[image]

SQL Data Compare API 12.0.40
PartitionRangeValueSqlResult..::.Field1 Property
PartitionRangeValueSqlResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Field1 As Byte()
C#
public byte[] Field1 { get; set; }
Visual C++
public:
property array<unsigned char>^ Field1 {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

PartitionRangeValueSqlResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FieldAsSqlDecimal Property

[image]

SQL Data Compare API 12.0.40
PartitionRangeValueSqlResult..::.FieldAsSqlDecimal Property
PartitionRangeValueSqlResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FieldAsSqlDecimal As SqlDecimal
C#
public SqlDecimal FieldAsSqlDecimal { get; set; }
Visual C++
public:
property SqlDecimal FieldAsSqlDecimal {
    SqlDecimal get ();
    void set (SqlDecimal value);
}

See Also

PartitionRangeValueSqlResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Functionname Property

[image]

SQL Data Compare API 12.0.40
PartitionRangeValueSqlResult..::.Functionname Property
PartitionRangeValueSqlResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Functionname As String
C#
public string Functionname { get; set; }
Visual C++
public:
property String^ Functionname {
    String^ get ();
    void set (String^ value);
}

See Also

PartitionRangeValueSqlResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Value Property

[image]

SQL Data Compare API 12.0.40
PartitionRangeValueSqlResult..::.Value Property
PartitionRangeValueSqlResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Object
C#
public Object Value { get; set; }
Visual C++
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

See Also

PartitionRangeValueSqlResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


RoleQueryResult Class

[image]

SQL Data Compare API 12.0.40
RoleQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class RoleQueryResult
C#
public class RoleQueryResult
Visual C++
public ref class RoleQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.RoleQueryResult

See Also

RoleQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


RoleQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
RoleQueryResult Members
RoleQueryResult Class Constructors Methods Properties See Also

The RoleQueryResult type exposes the following members.

Constructors

Name | Description
RoleQueryResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
GroupName |
UserName |

See Also

RoleQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


RoleQueryResult Constructor

[image]

SQL Data Compare API 12.0.40
RoleQueryResult Constructor
RoleQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RoleQueryResult()
Visual C++
public:
RoleQueryResult()

See Also

RoleQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


RoleQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
RoleQueryResult Properties
RoleQueryResult Class See Also

The RoleQueryResult type exposes the following properties.

Properties

Name | Description
GroupName |
UserName |

See Also

RoleQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


GroupName Property

[image]

SQL Data Compare API 12.0.40
RoleQueryResult..::.GroupName Property
RoleQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property GroupName As String
C#
public string GroupName { get; set; }
Visual C++
public:
property String^ GroupName {
    String^ get ();
    void set (String^ value);
}

See Also

RoleQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


UserName Property

[image]

SQL Data Compare API 12.0.40
RoleQueryResult..::.UserName Property
RoleQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UserName As String
C#
public string UserName { get; set; }
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

RoleQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SecurityPolicyQueryResult Class

[image]

SQL Data Compare API 12.0.40
SecurityPolicyQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SecurityPolicyQueryResult
C#
public class SecurityPolicyQueryResult
Visual C++
public ref class SecurityPolicyQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.SecurityPolicyQueryResult

See Also

SecurityPolicyQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SecurityPolicyQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
SecurityPolicyQueryResult Members
SecurityPolicyQueryResult Class Constructors Methods Properties See Also

The SecurityPolicyQueryResult type exposes the following members.

Constructors

Name | Description
SecurityPolicyQueryResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Id |
Name |
NotForReplication |
Owner |
Schema |
SecurityPredicateBlockDmlOperation |
SecurityPredicateFunctionDefinition |
SecurityPredicateSchema |
SecurityPredicateTable |
SecurityPredicateType |
State |

See Also

SecurityPolicyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SecurityPolicyQueryResult Constructor

[image]

SQL Data Compare API 12.0.40
SecurityPolicyQueryResult Constructor
SecurityPolicyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SecurityPolicyQueryResult()
Visual C++
public:
SecurityPolicyQueryResult()

See Also

SecurityPolicyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SecurityPolicyQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SecurityPolicyQueryResult Properties
SecurityPolicyQueryResult Class See Also

The SecurityPolicyQueryResult type exposes the following properties.

Properties

Name | Description
Id |
Name |
NotForReplication |
Owner |
Schema |
SecurityPredicateBlockDmlOperation |
SecurityPredicateFunctionDefinition |
SecurityPredicateSchema |
SecurityPredicateTable |
SecurityPredicateType |
State |

See Also

SecurityPolicyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Id Property

[image]

SQL Data Compare API 12.0.40
SecurityPolicyQueryResult..::.Id Property
SecurityPolicyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Id As Integer
C#
public int Id { get; set; }
Visual C++
public:
property int Id {
    int get ();
    void set (int value);
}

See Also

SecurityPolicyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
SecurityPolicyQueryResult..::.Name Property
SecurityPolicyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

SecurityPolicyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


NotForReplication Property

[image]

SQL Data Compare API 12.0.40
SecurityPolicyQueryResult..::.NotForReplication Property
SecurityPolicyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NotForReplication As Boolean
C#
public bool NotForReplication { get; set; }
Visual C++
public:
property bool NotForReplication {
    bool get ();
    void set (bool value);
}

See Also

SecurityPolicyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
SecurityPolicyQueryResult..::.Owner Property
SecurityPolicyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Owner As String
C#
public string Owner { get; set; }
Visual C++
public:
property String^ Owner {
    String^ get ();
    void set (String^ value);
}

See Also

SecurityPolicyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Schema Property

[image]

SQL Data Compare API 12.0.40
SecurityPolicyQueryResult..::.Schema Property
SecurityPolicyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Schema As String
C#
public string Schema { get; set; }
Visual C++
public:
property String^ Schema {
    String^ get ();
    void set (String^ value);
}

See Also

SecurityPolicyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SecurityPredicateBlockDmlOperation Property

[image]

SQL Data Compare API 12.0.40
SecurityPolicyQueryResult..::.SecurityPredicateBlockDmlOperation Property
SecurityPolicyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SecurityPredicateBlockDmlOperation As Integer
C#
public int SecurityPredicateBlockDmlOperation { get; set; }
Visual C++
public:
property int SecurityPredicateBlockDmlOperation {
    int get ();
    void set (int value);
}

See Also

SecurityPolicyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SecurityPredicateFunctionDefinition Property

[image]

SQL Data Compare API 12.0.40
SecurityPolicyQueryResult..::.SecurityPredicateFunctionDefinition Property
SecurityPolicyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SecurityPredicateFunctionDefinition As String
C#
public string SecurityPredicateFunctionDefinition { get; set; }
Visual C++
public:
property String^ SecurityPredicateFunctionDefinition {
    String^ get ();
    void set (String^ value);
}

See Also

SecurityPolicyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SecurityPredicateSchema Property

[image]

SQL Data Compare API 12.0.40
SecurityPolicyQueryResult..::.SecurityPredicateSchema Property
SecurityPolicyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SecurityPredicateSchema As String
C#
public string SecurityPredicateSchema { get; set; }
Visual C++
public:
property String^ SecurityPredicateSchema {
    String^ get ();
    void set (String^ value);
}

See Also

SecurityPolicyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SecurityPredicateTable Property

[image]

SQL Data Compare API 12.0.40
SecurityPolicyQueryResult..::.SecurityPredicateTable Property
SecurityPolicyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SecurityPredicateTable As String
C#
public string SecurityPredicateTable { get; set; }
Visual C++
public:
property String^ SecurityPredicateTable {
    String^ get ();
    void set (String^ value);
}

See Also

SecurityPolicyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SecurityPredicateType Property

[image]

SQL Data Compare API 12.0.40
SecurityPolicyQueryResult..::.SecurityPredicateType Property
SecurityPolicyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SecurityPredicateType As Integer
C#
public int SecurityPredicateType { get; set; }
Visual C++
public:
property int SecurityPredicateType {
    int get ();
    void set (int value);
}

See Also

SecurityPolicyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


State Property

[image]

SQL Data Compare API 12.0.40
SecurityPolicyQueryResult..::.State Property
SecurityPolicyQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property State As Boolean
C#
public bool State { get; set; }
Visual C++
public:
property bool State {
    bool get ();
    void set (bool value);
}

See Also

SecurityPolicyQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlFeatureUsageResult Class

[image]

SQL Data Compare API 12.0.40
SqlFeatureUsageResult Class
Members See Also

DMV result for FUR counts

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlFeatureUsageResult
C#
public class SqlFeatureUsageResult
Visual C++
public ref class SqlFeatureUsageResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlFeatureUsageResult

See Also

SqlFeatureUsageResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlFeatureUsageResult Members

[image] [image]

SQL Data Compare API 12.0.40
SqlFeatureUsageResult Members
SqlFeatureUsageResult Class Constructors Methods Properties See Also

The SqlFeatureUsageResult type exposes the following members.

Constructors

Name | Description
SqlFeatureUsageResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColumnEncryptionKeyCount |
ColumnMasterKeyCount |
InMemoryTableCount |
PredicatedStretchTableCount |
StretchTableCount |
TemporalTableCount |

See Also

SqlFeatureUsageResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlFeatureUsageResult Constructor

[image]

SQL Data Compare API 12.0.40
SqlFeatureUsageResult Constructor
SqlFeatureUsageResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlFeatureUsageResult()
Visual C++
public:
SqlFeatureUsageResult()

See Also

SqlFeatureUsageResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlFeatureUsageResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlFeatureUsageResult Properties
SqlFeatureUsageResult Class See Also

The SqlFeatureUsageResult type exposes the following properties.

Properties

Name | Description
ColumnEncryptionKeyCount |
ColumnMasterKeyCount |
InMemoryTableCount |
PredicatedStretchTableCount |
StretchTableCount |
TemporalTableCount |

See Also

SqlFeatureUsageResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ColumnEncryptionKeyCount Property

[image]

SQL Data Compare API 12.0.40
SqlFeatureUsageResult..::.ColumnEncryptionKeyCount Property
SqlFeatureUsageResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ColumnEncryptionKeyCount As Integer
C#
public int ColumnEncryptionKeyCount { get; private set; }
Visual C++
public:
property int ColumnEncryptionKeyCount {
    int get ();
    void set (int value);
}

See Also

SqlFeatureUsageResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ColumnMasterKeyCount Property

[image]

SQL Data Compare API 12.0.40
SqlFeatureUsageResult..::.ColumnMasterKeyCount Property
SqlFeatureUsageResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ColumnMasterKeyCount As Integer
C#
public int ColumnMasterKeyCount { get; private set; }
Visual C++
public:
property int ColumnMasterKeyCount {
    int get ();
    void set (int value);
}

See Also

SqlFeatureUsageResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


InMemoryTableCount Property

[image]

SQL Data Compare API 12.0.40
SqlFeatureUsageResult..::.InMemoryTableCount Property
SqlFeatureUsageResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property InMemoryTableCount As Integer
C#
public int InMemoryTableCount { get; private set; }
Visual C++
public:
property int InMemoryTableCount {
    int get ();
    void set (int value);
}

See Also

SqlFeatureUsageResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PredicatedStretchTableCount Property

[image]

SQL Data Compare API 12.0.40
SqlFeatureUsageResult..::.PredicatedStretchTableCount Property
SqlFeatureUsageResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PredicatedStretchTableCount As Integer
C#
public int PredicatedStretchTableCount { get; private set; }
Visual C++
public:
property int PredicatedStretchTableCount {
    int get ();
    void set (int value);
}

See Also

SqlFeatureUsageResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


StretchTableCount Property

[image]

SQL Data Compare API 12.0.40
SqlFeatureUsageResult..::.StretchTableCount Property
SqlFeatureUsageResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property StretchTableCount As Integer
C#
public int StretchTableCount { get; private set; }
Visual C++
public:
property int StretchTableCount {
    int get ();
    void set (int value);
}

See Also

SqlFeatureUsageResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TemporalTableCount Property

[image]

SQL Data Compare API 12.0.40
SqlFeatureUsageResult..::.TemporalTableCount Property
SqlFeatureUsageResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TemporalTableCount As Integer
C#
public int TemporalTableCount { get; private set; }
Visual C++
public:
property int TemporalTableCount {
    int get ();
    void set (int value);
}

See Also

SqlFeatureUsageResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlPartitionSchemeResult Class

[image]

SQL Data Compare API 12.0.40
SqlPartitionSchemeResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlPartitionSchemeResult
C#
public class SqlPartitionSchemeResult
Visual C++
public ref class SqlPartitionSchemeResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlPartitionSchemeResult

See Also

SqlPartitionSchemeResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlPartitionSchemeResult Members

[image] [image]

SQL Data Compare API 12.0.40
SqlPartitionSchemeResult Members
SqlPartitionSchemeResult Class Constructors Methods Properties See Also

The SqlPartitionSchemeResult type exposes the following members.

Constructors

Name | Description
SqlPartitionSchemeResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DataSpace |
FunctionName |
ID |
Name |

See Also

SqlPartitionSchemeResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlPartitionSchemeResult Constructor

[image]

SQL Data Compare API 12.0.40
SqlPartitionSchemeResult Constructor
SqlPartitionSchemeResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlPartitionSchemeResult()
Visual C++
public:
SqlPartitionSchemeResult()

See Also

SqlPartitionSchemeResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlPartitionSchemeResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlPartitionSchemeResult Properties
SqlPartitionSchemeResult Class See Also

The SqlPartitionSchemeResult type exposes the following properties.

Properties

Name | Description
DataSpace |
FunctionName |
ID |
Name |

See Also

SqlPartitionSchemeResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DataSpace Property

[image]

SQL Data Compare API 12.0.40
SqlPartitionSchemeResult..::.DataSpace Property
SqlPartitionSchemeResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DataSpace As String
C#
public string DataSpace { get; set; }
Visual C++
public:
property String^ DataSpace {
    String^ get ();
    void set (String^ value);
}

See Also

SqlPartitionSchemeResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FunctionName Property

[image]

SQL Data Compare API 12.0.40
SqlPartitionSchemeResult..::.FunctionName Property
SqlPartitionSchemeResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FunctionName As String
C#
public string FunctionName { get; set; }
Visual C++
public:
property String^ FunctionName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlPartitionSchemeResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ID Property

[image]

SQL Data Compare API 12.0.40
SqlPartitionSchemeResult..::.ID Property
SqlPartitionSchemeResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ID As Integer
C#
public int ID { get; set; }
Visual C++
public:
property int ID {
    int get ();
    void set (int value);
}

See Also

SqlPartitionSchemeResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
SqlPartitionSchemeResult..::.Name Property
SqlPartitionSchemeResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

SqlPartitionSchemeResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlPermissionResult Class

[image]

SQL Data Compare API 12.0.40
SqlPermissionResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlPermissionResult
C#
public class SqlPermissionResult
Visual C++
public ref class SqlPermissionResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlPermissionResult

See Also

SqlPermissionResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlPermissionResult Members

[image] [image]

SQL Data Compare API 12.0.40
SqlPermissionResult Members
SqlPermissionResult Class Constructors Methods Properties See Also

The SqlPermissionResult type exposes the following members.

Constructors

Name | Description
SqlPermissionResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Action |
Class |
ColumnPermissionID |
Columns |
ColumnsAsByteArray |
IsFunction |
IsProcedure |
IsTable |
IsView |
ObjectName |
ObjectOwner |
ObjectType |
ProtectType |
State |
Type |
UID |
UserName |

See Also

SqlPermissionResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlPermissionResult Constructor

[image]

SQL Data Compare API 12.0.40
SqlPermissionResult Constructor
SqlPermissionResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlPermissionResult()
Visual C++
public:
SqlPermissionResult()

See Also

SqlPermissionResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlPermissionResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlPermissionResult Properties
SqlPermissionResult Class See Also

The SqlPermissionResult type exposes the following properties.

Properties

Name | Description
Action |
Class |
ColumnPermissionID |
Columns |
ColumnsAsByteArray |
IsFunction |
IsProcedure |
IsTable |
IsView |
ObjectName |
ObjectOwner |
ObjectType |
ProtectType |
State |
Type |
UID |
UserName |

See Also

SqlPermissionResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Action Property

[image]

SQL Data Compare API 12.0.40
SqlPermissionResult..::.Action Property
SqlPermissionResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Action As Byte
C#
public byte Action { get; set; }
Visual C++
public:
property unsigned char Action {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

SqlPermissionResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Class Property

[image]

SQL Data Compare API 12.0.40
SqlPermissionResult..::.Class Property
SqlPermissionResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Class As Integer
C#
public int Class { get; set; }
Visual C++
public:
property int Class {
    int get ();
    void set (int value);
}

See Also

SqlPermissionResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ColumnPermissionID Property

[image]

SQL Data Compare API 12.0.40
SqlPermissionResult..::.ColumnPermissionID Property
SqlPermissionResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ColumnPermissionID As Integer
C#
public int ColumnPermissionID { get; set; }
Visual C++
public:
property int ColumnPermissionID {
    int get ();
    void set (int value);
}

See Also

SqlPermissionResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Columns Property

[image]

SQL Data Compare API 12.0.40
SqlPermissionResult..::.Columns Property
SqlPermissionResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Columns As Nullable(Of Integer)
C#
public Nullable<int> Columns { get; set; }
Visual C++
public:
property Nullable<int> Columns {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

SqlPermissionResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ColumnsAsByteArray Property

[image]

SQL Data Compare API 12.0.40
SqlPermissionResult..::.ColumnsAsByteArray Property
SqlPermissionResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ColumnsAsByteArray As Byte()
C#
public byte[] ColumnsAsByteArray { get; set; }
Visual C++
public:
property array<unsigned char>^ ColumnsAsByteArray {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

SqlPermissionResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsFunction Property

[image]

SQL Data Compare API 12.0.40
SqlPermissionResult..::.IsFunction Property
SqlPermissionResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsFunction As Boolean
C#
public bool IsFunction { get; set; }
Visual C++
public:
property bool IsFunction {
    bool get ();
    void set (bool value);
}

See Also

SqlPermissionResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsProcedure Property

[image]

SQL Data Compare API 12.0.40
SqlPermissionResult..::.IsProcedure Property
SqlPermissionResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsProcedure As Boolean
C#
public bool IsProcedure { get; set; }
Visual C++
public:
property bool IsProcedure {
    bool get ();
    void set (bool value);
}

See Also

SqlPermissionResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsTable Property

[image]

SQL Data Compare API 12.0.40
SqlPermissionResult..::.IsTable Property
SqlPermissionResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsTable As Boolean
C#
public bool IsTable { get; set; }
Visual C++
public:
property bool IsTable {
    bool get ();
    void set (bool value);
}

See Also

SqlPermissionResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsView Property

[image]

SQL Data Compare API 12.0.40
SqlPermissionResult..::.IsView Property
SqlPermissionResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsView As Boolean
C#
public bool IsView { get; set; }
Visual C++
public:
property bool IsView {
    bool get ();
    void set (bool value);
}

See Also

SqlPermissionResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ObjectName Property

[image]

SQL Data Compare API 12.0.40
SqlPermissionResult..::.ObjectName Property
SqlPermissionResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectName As String
C#
public string ObjectName { get; set; }
Visual C++
public:
property String^ ObjectName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlPermissionResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ObjectOwner Property

[image]

SQL Data Compare API 12.0.40
SqlPermissionResult..::.ObjectOwner Property
SqlPermissionResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectOwner As String
C#
public string ObjectOwner { get; set; }
Visual C++
public:
property String^ ObjectOwner {
    String^ get ();
    void set (String^ value);
}

See Also

SqlPermissionResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
SqlPermissionResult..::.ObjectType Property
SqlPermissionResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectType As String
C#
public string ObjectType { get; set; }
Visual C++
public:
property String^ ObjectType {
    String^ get ();
    void set (String^ value);
}

See Also

SqlPermissionResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ProtectType Property

[image]

SQL Data Compare API 12.0.40
SqlPermissionResult..::.ProtectType Property
SqlPermissionResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ProtectType As Byte
C#
public byte ProtectType { get; set; }
Visual C++
public:
property unsigned char ProtectType {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

SqlPermissionResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


State Property

[image]

SQL Data Compare API 12.0.40
SqlPermissionResult..::.State Property
SqlPermissionResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property State As String
C#
public string State { get; set; }
Visual C++
public:
property String^ State {
    String^ get ();
    void set (String^ value);
}

See Also

SqlPermissionResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Type Property

[image]

SQL Data Compare API 12.0.40
SqlPermissionResult..::.Type Property
SqlPermissionResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As String
C#
public string Type { get; set; }
Visual C++
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}

See Also

SqlPermissionResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


UID Property

[image]

SQL Data Compare API 12.0.40
SqlPermissionResult..::.UID Property
SqlPermissionResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UID As Integer
C#
public int UID { get; set; }
Visual C++
public:
property int UID {
    int get ();
    void set (int value);
}

See Also

SqlPermissionResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


UserName Property

[image]

SQL Data Compare API 12.0.40
SqlPermissionResult..::.UserName Property
SqlPermissionResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UserName As String
C#
public string UserName { get; set; }
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlPermissionResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlProcedureResult Class

[image]

SQL Data Compare API 12.0.40
SqlProcedureResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlProcedureResult _
    Implements ICacheableQueryResult
C#
public class SqlProcedureResult : ICacheableQueryResult
Visual C++
public ref class SqlProcedureResult : ICacheableQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlProcedureResult

See Also

SqlProcedureResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlProcedureResult Members

[image] [image]

SQL Data Compare API 12.0.40
SqlProcedureResult Members
SqlProcedureResult Class Constructors Methods Properties See Also

The SqlProcedureResult type exposes the following members.

Constructors

Name | Description
SqlProcedureResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Assembly |
AssemblyClass |
AssemblyMethod |
CacheKey |
Encrypted |
ExecuteAs |
ExecuteAsOwner |
ID |
IsAnsiNulls |
IsNativelyCompiled |
IsQuotedIdentifier |
IsSystemObject |
LastModified |
ProcedureName |
ProcedureOwner |
ProcedureType |
SchemaName |
TextID |

See Also

SqlProcedureResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlProcedureResult Constructor

[image]

SQL Data Compare API 12.0.40
SqlProcedureResult Constructor
SqlProcedureResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlProcedureResult()
Visual C++
public:
SqlProcedureResult()

See Also

SqlProcedureResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlProcedureResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlProcedureResult Properties
SqlProcedureResult Class See Also

The SqlProcedureResult type exposes the following properties.

Properties

Name | Description
Assembly |
AssemblyClass |
AssemblyMethod |
CacheKey |
Encrypted |
ExecuteAs |
ExecuteAsOwner |
ID |
IsAnsiNulls |
IsNativelyCompiled |
IsQuotedIdentifier |
IsSystemObject |
LastModified |
ProcedureName |
ProcedureOwner |
ProcedureType |
SchemaName |
TextID |

See Also

SqlProcedureResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Assembly Property

[image]

SQL Data Compare API 12.0.40
SqlProcedureResult..::.Assembly Property
SqlProcedureResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Assembly As String
C#
public string Assembly { get; set; }
Visual C++
public:
property String^ Assembly {
    String^ get ();
    void set (String^ value);
}

See Also

SqlProcedureResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AssemblyClass Property

[image]

SQL Data Compare API 12.0.40
SqlProcedureResult..::.AssemblyClass Property
SqlProcedureResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyClass As String
C#
public string AssemblyClass { get; set; }
Visual C++
public:
property String^ AssemblyClass {
    String^ get ();
    void set (String^ value);
}

See Also

SqlProcedureResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AssemblyMethod Property

[image]

SQL Data Compare API 12.0.40
SqlProcedureResult..::.AssemblyMethod Property
SqlProcedureResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyMethod As String
C#
public string AssemblyMethod { get; set; }
Visual C++
public:
property String^ AssemblyMethod {
    String^ get ();
    void set (String^ value);
}

See Also

SqlProcedureResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


CacheKey Property

[image]

SQL Data Compare API 12.0.40
SqlProcedureResult..::.CacheKey Property
SqlProcedureResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CacheKey As Integer
C#
public int CacheKey { get; }
Visual C++
public:
virtual property int CacheKey {
    int get () sealed;
}

Implements

ICacheableQueryResult..::.CacheKey

See Also

SqlProcedureResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Encrypted Property

[image]

SQL Data Compare API 12.0.40
SqlProcedureResult..::.Encrypted Property
SqlProcedureResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Encrypted As Boolean
C#
public bool Encrypted { get; set; }
Visual C++
public:
property bool Encrypted {
    bool get ();
    void set (bool value);
}

See Also

SqlProcedureResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ExecuteAs Property

[image]

SQL Data Compare API 12.0.40
SqlProcedureResult..::.ExecuteAs Property
SqlProcedureResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecuteAs As String
C#
public string ExecuteAs { get; set; }
Visual C++
public:
property String^ ExecuteAs {
    String^ get ();
    void set (String^ value);
}

See Also

SqlProcedureResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ExecuteAsOwner Property

[image]

SQL Data Compare API 12.0.40
SqlProcedureResult..::.ExecuteAsOwner Property
SqlProcedureResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecuteAsOwner As Boolean
C#
public bool ExecuteAsOwner { get; set; }
Visual C++
public:
property bool ExecuteAsOwner {
    bool get ();
    void set (bool value);
}

See Also

SqlProcedureResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ID Property

[image]

SQL Data Compare API 12.0.40
SqlProcedureResult..::.ID Property
SqlProcedureResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ID As Integer
C#
public int ID { get; set; }
Visual C++
public:
property int ID {
    int get ();
    void set (int value);
}

See Also

SqlProcedureResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsAnsiNulls Property

[image]

SQL Data Compare API 12.0.40
SqlProcedureResult..::.IsAnsiNulls Property
SqlProcedureResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsAnsiNulls As Boolean
C#
public bool IsAnsiNulls { get; set; }
Visual C++
public:
property bool IsAnsiNulls {
    bool get ();
    void set (bool value);
}

See Also

SqlProcedureResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsNativelyCompiled Property

[image]

SQL Data Compare API 12.0.40
SqlProcedureResult..::.IsNativelyCompiled Property
SqlProcedureResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsNativelyCompiled As Boolean
C#
public bool IsNativelyCompiled { get; set; }
Visual C++
public:
property bool IsNativelyCompiled {
    bool get ();
    void set (bool value);
}

See Also

SqlProcedureResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsQuotedIdentifier Property

[image]

SQL Data Compare API 12.0.40
SqlProcedureResult..::.IsQuotedIdentifier Property
SqlProcedureResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsQuotedIdentifier As Boolean
C#
public bool IsQuotedIdentifier { get; set; }
Visual C++
public:
property bool IsQuotedIdentifier {
    bool get ();
    void set (bool value);
}

See Also

SqlProcedureResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsSystemObject Property

[image]

SQL Data Compare API 12.0.40
SqlProcedureResult..::.IsSystemObject Property
SqlProcedureResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSystemObject As Boolean
C#
public bool IsSystemObject { get; set; }
Visual C++
public:
property bool IsSystemObject {
    bool get ();
    void set (bool value);
}

See Also

SqlProcedureResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


LastModified Property

[image]

SQL Data Compare API 12.0.40
SqlProcedureResult..::.LastModified Property
SqlProcedureResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LastModified As DateTime
C#
public DateTime LastModified { get; set; }
Visual C++
public:
property DateTime LastModified {
    DateTime get ();
    void set (DateTime value);
}

See Also

SqlProcedureResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ProcedureName Property

[image]

SQL Data Compare API 12.0.40
SqlProcedureResult..::.ProcedureName Property
SqlProcedureResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ProcedureName As String
C#
public string ProcedureName { get; set; }
Visual C++
public:
property String^ ProcedureName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlProcedureResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ProcedureOwner Property

[image]

SQL Data Compare API 12.0.40
SqlProcedureResult..::.ProcedureOwner Property
SqlProcedureResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ProcedureOwner As String
C#
public string ProcedureOwner { get; set; }
Visual C++
public:
property String^ ProcedureOwner {
    String^ get ();
    void set (String^ value);
}

See Also

SqlProcedureResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ProcedureType Property

[image]

SQL Data Compare API 12.0.40
SqlProcedureResult..::.ProcedureType Property
SqlProcedureResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ProcedureType As String
C#
public string ProcedureType { get; set; }
Visual C++
public:
property String^ ProcedureType {
    String^ get ();
    void set (String^ value);
}

See Also

SqlProcedureResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SchemaName Property

[image]

SQL Data Compare API 12.0.40
SqlProcedureResult..::.SchemaName Property
SqlProcedureResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SchemaName As String
C#
public string SchemaName { get; set; }
Visual C++
public:
property String^ SchemaName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlProcedureResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TextID Property

[image]

SQL Data Compare API 12.0.40
SqlProcedureResult..::.TextID Property
SqlProcedureResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TextID As Integer
C#
public int TextID { get; set; }
Visual C++
public:
property int TextID {
    int get ();
    void set (int value);
}

See Also

SqlProcedureResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlQueueResult Class

[image]

SQL Data Compare API 12.0.40
SqlQueueResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlQueueResult
C#
public class SqlQueueResult
Visual C++
public ref class SqlQueueResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlQueueResult

See Also

SqlQueueResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlQueueResult Members

[image] [image]

SQL Data Compare API 12.0.40
SqlQueueResult Members
SqlQueueResult Class Constructors Methods Properties See Also

The SqlQueueResult type exposes the following members.

Constructors

Name | Description
SqlQueueResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ActivationProcedure |
ExecuteAs |
ExecuteAsOwner |
FileGroup |
ID |
IsActivationEnabled |
IsEnqueueEnabled |
IsPoisonMessageHandlingEnabled |
IsReceiveEnabled |
IsRetentionEnabled |
MaxReaders |
Name |
Owner |
SchemaName |

See Also

SqlQueueResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlQueueResult Constructor

[image]

SQL Data Compare API 12.0.40
SqlQueueResult Constructor
SqlQueueResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlQueueResult()
Visual C++
public:
SqlQueueResult()

See Also

SqlQueueResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlQueueResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlQueueResult Properties
SqlQueueResult Class See Also

The SqlQueueResult type exposes the following properties.

Properties

Name | Description
ActivationProcedure |
ExecuteAs |
ExecuteAsOwner |
FileGroup |
ID |
IsActivationEnabled |
IsEnqueueEnabled |
IsPoisonMessageHandlingEnabled |
IsReceiveEnabled |
IsRetentionEnabled |
MaxReaders |
Name |
Owner |
SchemaName |

See Also

SqlQueueResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ActivationProcedure Property

[image]

SQL Data Compare API 12.0.40
SqlQueueResult..::.ActivationProcedure Property
SqlQueueResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ActivationProcedure As String
C#
public string ActivationProcedure { get; set; }
Visual C++
public:
property String^ ActivationProcedure {
    String^ get ();
    void set (String^ value);
}

See Also

SqlQueueResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ExecuteAs Property

[image]

SQL Data Compare API 12.0.40
SqlQueueResult..::.ExecuteAs Property
SqlQueueResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecuteAs As String
C#
public string ExecuteAs { get; set; }
Visual C++
public:
property String^ ExecuteAs {
    String^ get ();
    void set (String^ value);
}

See Also

SqlQueueResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ExecuteAsOwner Property

[image]

SQL Data Compare API 12.0.40
SqlQueueResult..::.ExecuteAsOwner Property
SqlQueueResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecuteAsOwner As Boolean
C#
public bool ExecuteAsOwner { get; set; }
Visual C++
public:
property bool ExecuteAsOwner {
    bool get ();
    void set (bool value);
}

See Also

SqlQueueResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FileGroup Property

[image]

SQL Data Compare API 12.0.40
SqlQueueResult..::.FileGroup Property
SqlQueueResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FileGroup As String
C#
public string FileGroup { get; set; }
Visual C++
public:
property String^ FileGroup {
    String^ get ();
    void set (String^ value);
}

See Also

SqlQueueResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ID Property

[image]

SQL Data Compare API 12.0.40
SqlQueueResult..::.ID Property
SqlQueueResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ID As Integer
C#
public int ID { get; set; }
Visual C++
public:
property int ID {
    int get ();
    void set (int value);
}

See Also

SqlQueueResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsActivationEnabled Property

[image]

SQL Data Compare API 12.0.40
SqlQueueResult..::.IsActivationEnabled Property
SqlQueueResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActivationEnabled As Boolean
C#
public bool IsActivationEnabled { get; set; }
Visual C++
public:
property bool IsActivationEnabled {
    bool get ();
    void set (bool value);
}

See Also

SqlQueueResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsEnqueueEnabled Property

[image]

SQL Data Compare API 12.0.40
SqlQueueResult..::.IsEnqueueEnabled Property
SqlQueueResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsEnqueueEnabled As Boolean
C#
public bool IsEnqueueEnabled { get; set; }
Visual C++
public:
property bool IsEnqueueEnabled {
    bool get ();
    void set (bool value);
}

See Also

SqlQueueResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsPoisonMessageHandlingEnabled Property

[image]

SQL Data Compare API 12.0.40
SqlQueueResult..::.IsPoisonMessageHandlingEnabled Property
SqlQueueResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsPoisonMessageHandlingEnabled As Boolean
C#
public bool IsPoisonMessageHandlingEnabled { get; set; }
Visual C++
public:
property bool IsPoisonMessageHandlingEnabled {
    bool get ();
    void set (bool value);
}

See Also

SqlQueueResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsReceiveEnabled Property

[image]

SQL Data Compare API 12.0.40
SqlQueueResult..::.IsReceiveEnabled Property
SqlQueueResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsReceiveEnabled As Boolean
C#
public bool IsReceiveEnabled { get; set; }
Visual C++
public:
property bool IsReceiveEnabled {
    bool get ();
    void set (bool value);
}

See Also

SqlQueueResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsRetentionEnabled Property

[image]

SQL Data Compare API 12.0.40
SqlQueueResult..::.IsRetentionEnabled Property
SqlQueueResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsRetentionEnabled As Boolean
C#
public bool IsRetentionEnabled { get; set; }
Visual C++
public:
property bool IsRetentionEnabled {
    bool get ();
    void set (bool value);
}

See Also

SqlQueueResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


MaxReaders Property

[image]

SQL Data Compare API 12.0.40
SqlQueueResult..::.MaxReaders Property
SqlQueueResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxReaders As Short
C#
public short MaxReaders { get; set; }
Visual C++
public:
property short MaxReaders {
    short get ();
    void set (short value);
}

See Also

SqlQueueResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
SqlQueueResult..::.Name Property
SqlQueueResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

SqlQueueResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
SqlQueueResult..::.Owner Property
SqlQueueResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Owner As String
C#
public string Owner { get; set; }
Visual C++
public:
property String^ Owner {
    String^ get ();
    void set (String^ value);
}

See Also

SqlQueueResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SchemaName Property

[image]

SQL Data Compare API 12.0.40
SqlQueueResult..::.SchemaName Property
SqlQueueResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SchemaName As String
C#
public string SchemaName { get; set; }
Visual C++
public:
property String^ SchemaName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlQueueResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlRemoteServiceBindingResult Class

[image]

SQL Data Compare API 12.0.40
SqlRemoteServiceBindingResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlRemoteServiceBindingResult
C#
public class SqlRemoteServiceBindingResult
Visual C++
public ref class SqlRemoteServiceBindingResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlRemoteServiceBindingResult

See Also

SqlRemoteServiceBindingResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlRemoteServiceBindingResult Members

[image] [image]

SQL Data Compare API 12.0.40
SqlRemoteServiceBindingResult Members
SqlRemoteServiceBindingResult Class Constructors Methods Properties See Also

The SqlRemoteServiceBindingResult type exposes the following members.

Constructors

Name | Description
SqlRemoteServiceBindingResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsAnonymous |
Name |
Owner |
RemoteServiceName |
RemoteUser |

See Also

SqlRemoteServiceBindingResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlRemoteServiceBindingResult Constructor

[image]

SQL Data Compare API 12.0.40
SqlRemoteServiceBindingResult Constructor
SqlRemoteServiceBindingResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlRemoteServiceBindingResult()
Visual C++
public:
SqlRemoteServiceBindingResult()

See Also

SqlRemoteServiceBindingResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlRemoteServiceBindingResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlRemoteServiceBindingResult Properties
SqlRemoteServiceBindingResult Class See Also

The SqlRemoteServiceBindingResult type exposes the following properties.

Properties

Name | Description
IsAnonymous |
Name |
Owner |
RemoteServiceName |
RemoteUser |

See Also

SqlRemoteServiceBindingResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsAnonymous Property

[image]

SQL Data Compare API 12.0.40
SqlRemoteServiceBindingResult..::.IsAnonymous Property
SqlRemoteServiceBindingResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsAnonymous As Boolean
C#
public bool IsAnonymous { get; set; }
Visual C++
public:
property bool IsAnonymous {
    bool get ();
    void set (bool value);
}

See Also

SqlRemoteServiceBindingResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
SqlRemoteServiceBindingResult..::.Name Property
SqlRemoteServiceBindingResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

SqlRemoteServiceBindingResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
SqlRemoteServiceBindingResult..::.Owner Property
SqlRemoteServiceBindingResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Owner As String
C#
public string Owner { get; set; }
Visual C++
public:
property String^ Owner {
    String^ get ();
    void set (String^ value);
}

See Also

SqlRemoteServiceBindingResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


RemoteServiceName Property

[image]

SQL Data Compare API 12.0.40
SqlRemoteServiceBindingResult..::.RemoteServiceName Property
SqlRemoteServiceBindingResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RemoteServiceName As String
C#
public string RemoteServiceName { get; set; }
Visual C++
public:
property String^ RemoteServiceName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlRemoteServiceBindingResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


RemoteUser Property

[image]

SQL Data Compare API 12.0.40
SqlRemoteServiceBindingResult..::.RemoteUser Property
SqlRemoteServiceBindingResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RemoteUser As String
C#
public string RemoteUser { get; set; }
Visual C++
public:
property String^ RemoteUser {
    String^ get ();
    void set (String^ value);
}

See Also

SqlRemoteServiceBindingResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlRoleResult Class

[image]

SQL Data Compare API 12.0.40
SqlRoleResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlRoleResult
C#
public class SqlRoleResult
Visual C++
public ref class SqlRoleResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlRoleResult

See Also

SqlRoleResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlRoleResult Members

[image] [image]

SQL Data Compare API 12.0.40
SqlRoleResult Members
SqlRoleResult Class Constructors Methods Properties See Also

The SqlRoleResult type exposes the following members.

Constructors

Name | Description
SqlRoleResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DefaultSchemaName |
IsAppRole |
Name |
Owner |

See Also

SqlRoleResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlRoleResult Constructor

[image]

SQL Data Compare API 12.0.40
SqlRoleResult Constructor
SqlRoleResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlRoleResult()
Visual C++
public:
SqlRoleResult()

See Also

SqlRoleResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlRoleResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlRoleResult Properties
SqlRoleResult Class See Also

The SqlRoleResult type exposes the following properties.

Properties

Name | Description
DefaultSchemaName |
IsAppRole |
Name |
Owner |

See Also

SqlRoleResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DefaultSchemaName Property

[image]

SQL Data Compare API 12.0.40
SqlRoleResult..::.DefaultSchemaName Property
SqlRoleResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultSchemaName As String
C#
public string DefaultSchemaName { get; set; }
Visual C++
public:
property String^ DefaultSchemaName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlRoleResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsAppRole Property

[image]

SQL Data Compare API 12.0.40
SqlRoleResult..::.IsAppRole Property
SqlRoleResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsAppRole As Boolean
C#
public bool IsAppRole { get; set; }
Visual C++
public:
property bool IsAppRole {
    bool get ();
    void set (bool value);
}

See Also

SqlRoleResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
SqlRoleResult..::.Name Property
SqlRoleResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

SqlRoleResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
SqlRoleResult..::.Owner Property
SqlRoleResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Owner As String
C#
public string Owner { get; set; }
Visual C++
public:
property String^ Owner {
    String^ get ();
    void set (String^ value);
}

See Also

SqlRoleResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlRouteResult Class

[image]

SQL Data Compare API 12.0.40
SqlRouteResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlRouteResult
C#
public class SqlRouteResult
Visual C++
public ref class SqlRouteResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlRouteResult

See Also

SqlRouteResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlRouteResult Members

[image] [image]

SQL Data Compare API 12.0.40
SqlRouteResult Members
SqlRouteResult Class Constructors Methods Properties See Also

The SqlRouteResult type exposes the following members.

Constructors

Name | Description
SqlRouteResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Address |
BrokerInstance |
ID |
Lifetime |
MirrorAddress |
Name |
Owner |
RemoteServiceName |

See Also

SqlRouteResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlRouteResult Constructor

[image]

SQL Data Compare API 12.0.40
SqlRouteResult Constructor
SqlRouteResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlRouteResult()
Visual C++
public:
SqlRouteResult()

See Also

SqlRouteResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlRouteResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlRouteResult Properties
SqlRouteResult Class See Also

The SqlRouteResult type exposes the following properties.

Properties

Name | Description
Address |
BrokerInstance |
ID |
Lifetime |
MirrorAddress |
Name |
Owner |
RemoteServiceName |

See Also

SqlRouteResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Address Property

[image]

SQL Data Compare API 12.0.40
SqlRouteResult..::.Address Property
SqlRouteResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Address As String
C#
public string Address { get; set; }
Visual C++
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}

See Also

SqlRouteResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


BrokerInstance Property

[image]

SQL Data Compare API 12.0.40
SqlRouteResult..::.BrokerInstance Property
SqlRouteResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BrokerInstance As String
C#
public string BrokerInstance { get; set; }
Visual C++
public:
property String^ BrokerInstance {
    String^ get ();
    void set (String^ value);
}

See Also

SqlRouteResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ID Property

[image]

SQL Data Compare API 12.0.40
SqlRouteResult..::.ID Property
SqlRouteResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ID As Integer
C#
public int ID { get; set; }
Visual C++
public:
property int ID {
    int get ();
    void set (int value);
}

See Also

SqlRouteResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Lifetime Property

[image]

SQL Data Compare API 12.0.40
SqlRouteResult..::.Lifetime Property
SqlRouteResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Lifetime As Nullable(Of DateTime)
C#
public Nullable<DateTime> Lifetime { get; set; }
Visual C++
public:
property Nullable<DateTime> Lifetime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

See Also

SqlRouteResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


MirrorAddress Property

[image]

SQL Data Compare API 12.0.40
SqlRouteResult..::.MirrorAddress Property
SqlRouteResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property MirrorAddress As String
C#
public string MirrorAddress { get; set; }
Visual C++
public:
property String^ MirrorAddress {
    String^ get ();
    void set (String^ value);
}

See Also

SqlRouteResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
SqlRouteResult..::.Name Property
SqlRouteResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

SqlRouteResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
SqlRouteResult..::.Owner Property
SqlRouteResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Owner As String
C#
public string Owner { get; set; }
Visual C++
public:
property String^ Owner {
    String^ get ();
    void set (String^ value);
}

See Also

SqlRouteResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


RemoteServiceName Property

[image]

SQL Data Compare API 12.0.40
SqlRouteResult..::.RemoteServiceName Property
SqlRouteResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RemoteServiceName As String
C#
public string RemoteServiceName { get; set; }
Visual C++
public:
property String^ RemoteServiceName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlRouteResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlRuleResult Class

[image]

SQL Data Compare API 12.0.40
SqlRuleResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlRuleResult
C#
public class SqlRuleResult
Visual C++
public ref class SqlRuleResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlRuleResult

See Also

SqlRuleResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlRuleResult Members

[image] [image]

SQL Data Compare API 12.0.40
SqlRuleResult Members
SqlRuleResult Class Constructors Methods Properties See Also

The SqlRuleResult type exposes the following members.

Constructors

Name | Description
SqlRuleResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ID |
RuleName |
RuleOwner |
Text |

See Also

SqlRuleResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlRuleResult Constructor

[image]

SQL Data Compare API 12.0.40
SqlRuleResult Constructor
SqlRuleResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlRuleResult()
Visual C++
public:
SqlRuleResult()

See Also

SqlRuleResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlRuleResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlRuleResult Properties
SqlRuleResult Class See Also

The SqlRuleResult type exposes the following properties.

Properties

Name | Description
ID |
RuleName |
RuleOwner |
Text |

See Also

SqlRuleResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ID Property

[image]

SQL Data Compare API 12.0.40
SqlRuleResult..::.ID Property
SqlRuleResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ID As Integer
C#
public int ID { get; set; }
Visual C++
public:
property int ID {
    int get ();
    void set (int value);
}

See Also

SqlRuleResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


RuleName Property

[image]

SQL Data Compare API 12.0.40
SqlRuleResult..::.RuleName Property
SqlRuleResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RuleName As String
C#
public string RuleName { get; set; }
Visual C++
public:
property String^ RuleName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlRuleResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


RuleOwner Property

[image]

SQL Data Compare API 12.0.40
SqlRuleResult..::.RuleOwner Property
SqlRuleResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RuleOwner As String
C#
public string RuleOwner { get; set; }
Visual C++
public:
property String^ RuleOwner {
    String^ get ();
    void set (String^ value);
}

See Also

SqlRuleResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Text Property

[image]

SQL Data Compare API 12.0.40
SqlRuleResult..::.Text Property
SqlRuleResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text { get; set; }
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

SqlRuleResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlSchemasResult Class

[image]

SQL Data Compare API 12.0.40
SqlSchemasResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlSchemasResult
C#
public class SqlSchemasResult
Visual C++
public ref class SqlSchemasResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlSchemasResult

See Also

SqlSchemasResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlSchemasResult Members

[image] [image]

SQL Data Compare API 12.0.40
SqlSchemasResult Members
SqlSchemasResult Class Constructors Methods Properties See Also

The SqlSchemasResult type exposes the following members.

Constructors

Name | Description
SqlSchemasResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Name |
Owner |

See Also

SqlSchemasResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlSchemasResult Constructor

[image]

SQL Data Compare API 12.0.40
SqlSchemasResult Constructor
SqlSchemasResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlSchemasResult()
Visual C++
public:
SqlSchemasResult()

See Also

SqlSchemasResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlSchemasResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlSchemasResult Properties
SqlSchemasResult Class See Also

The SqlSchemasResult type exposes the following properties.

Properties

Name | Description
Name |
Owner |

See Also

SqlSchemasResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
SqlSchemasResult..::.Name Property
SqlSchemasResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

SqlSchemasResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
SqlSchemasResult..::.Owner Property
SqlSchemasResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Owner As String
C#
public string Owner { get; set; }
Visual C++
public:
property String^ Owner {
    String^ get ();
    void set (String^ value);
}

See Also

SqlSchemasResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlSearchPropertyListResult Class

[image]

SQL Data Compare API 12.0.40
SqlSearchPropertyListResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlSearchPropertyListResult
C#
public class SqlSearchPropertyListResult
Visual C++
public ref class SqlSearchPropertyListResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlSearchPropertyListResult

See Also

SqlSearchPropertyListResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlSearchPropertyListResult Members

[image] [image]

SQL Data Compare API 12.0.40
SqlSearchPropertyListResult Members
SqlSearchPropertyListResult Class Constructors Methods Properties See Also

The SqlSearchPropertyListResult type exposes the following members.

Constructors

Name | Description
SqlSearchPropertyListResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
PropertyDescription |
PropertyIDInSet |
PropertyInternalID |
PropertyListID |
PropertyListName |
PropertyListOwner |
PropertyName |
PropertySetGuid |

See Also

SqlSearchPropertyListResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlSearchPropertyListResult Constructor

[image]

SQL Data Compare API 12.0.40
SqlSearchPropertyListResult Constructor
SqlSearchPropertyListResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlSearchPropertyListResult()
Visual C++
public:
SqlSearchPropertyListResult()

See Also

SqlSearchPropertyListResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlSearchPropertyListResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlSearchPropertyListResult Properties
SqlSearchPropertyListResult Class See Also

The SqlSearchPropertyListResult type exposes the following properties.

Properties

Name | Description
PropertyDescription |
PropertyIDInSet |
PropertyInternalID |
PropertyListID |
PropertyListName |
PropertyListOwner |
PropertyName |
PropertySetGuid |

See Also

SqlSearchPropertyListResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PropertyDescription Property

[image]

SQL Data Compare API 12.0.40
SqlSearchPropertyListResult..::.PropertyDescription Property
SqlSearchPropertyListResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PropertyDescription As String
C#
public string PropertyDescription { get; set; }
Visual C++
public:
property String^ PropertyDescription {
    String^ get ();
    void set (String^ value);
}

See Also

SqlSearchPropertyListResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PropertyIDInSet Property

[image]

SQL Data Compare API 12.0.40
SqlSearchPropertyListResult..::.PropertyIDInSet Property
SqlSearchPropertyListResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PropertyIDInSet As Nullable(Of Integer)
C#
public Nullable<int> PropertyIDInSet { get; set; }
Visual C++
public:
property Nullable<int> PropertyIDInSet {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

SqlSearchPropertyListResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PropertyInternalID Property

[image]

SQL Data Compare API 12.0.40
SqlSearchPropertyListResult..::.PropertyInternalID Property
SqlSearchPropertyListResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PropertyInternalID As Nullable(Of Integer)
C#
public Nullable<int> PropertyInternalID { get; set; }
Visual C++
public:
property Nullable<int> PropertyInternalID {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

SqlSearchPropertyListResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PropertyListID Property

[image]

SQL Data Compare API 12.0.40
SqlSearchPropertyListResult..::.PropertyListID Property
SqlSearchPropertyListResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PropertyListID As Integer
C#
public int PropertyListID { get; set; }
Visual C++
public:
property int PropertyListID {
    int get ();
    void set (int value);
}

See Also

SqlSearchPropertyListResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PropertyListName Property

[image]

SQL Data Compare API 12.0.40
SqlSearchPropertyListResult..::.PropertyListName Property
SqlSearchPropertyListResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PropertyListName As String
C#
public string PropertyListName { get; set; }
Visual C++
public:
property String^ PropertyListName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlSearchPropertyListResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PropertyListOwner Property

[image]

SQL Data Compare API 12.0.40
SqlSearchPropertyListResult..::.PropertyListOwner Property
SqlSearchPropertyListResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PropertyListOwner As String
C#
public string PropertyListOwner { get; set; }
Visual C++
public:
property String^ PropertyListOwner {
    String^ get ();
    void set (String^ value);
}

See Also

SqlSearchPropertyListResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PropertyName Property

[image]

SQL Data Compare API 12.0.40
SqlSearchPropertyListResult..::.PropertyName Property
SqlSearchPropertyListResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PropertyName As String
C#
public string PropertyName { get; set; }
Visual C++
public:
property String^ PropertyName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlSearchPropertyListResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


PropertySetGuid Property

[image]

SQL Data Compare API 12.0.40
SqlSearchPropertyListResult..::.PropertySetGuid Property
SqlSearchPropertyListResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PropertySetGuid As Nullable(Of Guid)
C#
public Nullable<Guid> PropertySetGuid { get; set; }
Visual C++
public:
property Nullable<Guid> PropertySetGuid {
    Nullable<Guid> get ();
    void set (Nullable<Guid> value);
}

See Also

SqlSearchPropertyListResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlSequencesResult Class

[image]

SQL Data Compare API 12.0.40
SqlSequencesResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlSequencesResult
C#
public class SqlSequencesResult
Visual C++
public ref class SqlSequencesResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlSequencesResult

See Also

SqlSequencesResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlSequencesResult Members

[image] [image]

SQL Data Compare API 12.0.40
SqlSequencesResult Members
SqlSequencesResult Class Constructors Methods Properties See Also

The SqlSequencesResult type exposes the following members.

Constructors

Name | Description
SqlSequencesResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Authorization |
CacheSize |
CurrentValue |
Increment |
IsCached |
IsCycling |
IsExhausted |
MaxValue |
MinValue |
Name |
Owner |
Precision |
Scale |
Start |
SysobjectID |
TypeName |
TypeSchemaName |

See Also

SqlSequencesResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlSequencesResult Constructor

[image]

SQL Data Compare API 12.0.40
SqlSequencesResult Constructor
SqlSequencesResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlSequencesResult()
Visual C++
public:
SqlSequencesResult()

See Also

SqlSequencesResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlSequencesResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlSequencesResult Properties
SqlSequencesResult Class See Also

The SqlSequencesResult type exposes the following properties.

Properties

Name | Description
Authorization |
CacheSize |
CurrentValue |
Increment |
IsCached |
IsCycling |
IsExhausted |
MaxValue |
MinValue |
Name |
Owner |
Precision |
Scale |
Start |
SysobjectID |
TypeName |
TypeSchemaName |

See Also

SqlSequencesResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Authorization Property

[image]

SQL Data Compare API 12.0.40
SqlSequencesResult..::.Authorization Property
SqlSequencesResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Authorization As String
C#
public string Authorization { get; set; }
Visual C++
public:
property String^ Authorization {
    String^ get ();
    void set (String^ value);
}

See Also

SqlSequencesResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


CacheSize Property

[image]

SQL Data Compare API 12.0.40
SqlSequencesResult..::.CacheSize Property
SqlSequencesResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CacheSize As Nullable(Of Integer)
C#
public Nullable<int> CacheSize { get; set; }
Visual C++
public:
property Nullable<int> CacheSize {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

SqlSequencesResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


CurrentValue Property

[image]

SQL Data Compare API 12.0.40
SqlSequencesResult..::.CurrentValue Property
SqlSequencesResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CurrentValue As SqlDecimal
C#
public SqlDecimal CurrentValue { get; set; }
Visual C++
public:
property SqlDecimal CurrentValue {
    SqlDecimal get ();
    void set (SqlDecimal value);
}

See Also

SqlSequencesResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Increment Property

[image]

SQL Data Compare API 12.0.40
SqlSequencesResult..::.Increment Property
SqlSequencesResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Increment As SqlDecimal
C#
public SqlDecimal Increment { get; set; }
Visual C++
public:
property SqlDecimal Increment {
    SqlDecimal get ();
    void set (SqlDecimal value);
}

See Also

SqlSequencesResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsCached Property

[image]

SQL Data Compare API 12.0.40
SqlSequencesResult..::.IsCached Property
SqlSequencesResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsCached As Boolean
C#
public bool IsCached { get; set; }
Visual C++
public:
property bool IsCached {
    bool get ();
    void set (bool value);
}

See Also

SqlSequencesResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsCycling Property

[image]

SQL Data Compare API 12.0.40
SqlSequencesResult..::.IsCycling Property
SqlSequencesResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsCycling As Boolean
C#
public bool IsCycling { get; set; }
Visual C++
public:
property bool IsCycling {
    bool get ();
    void set (bool value);
}

See Also

SqlSequencesResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsExhausted Property

[image]

SQL Data Compare API 12.0.40
SqlSequencesResult..::.IsExhausted Property
SqlSequencesResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsExhausted As Boolean
C#
public bool IsExhausted { get; set; }
Visual C++
public:
property bool IsExhausted {
    bool get ();
    void set (bool value);
}

See Also

SqlSequencesResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


MaxValue Property

[image]

SQL Data Compare API 12.0.40
SqlSequencesResult..::.MaxValue Property
SqlSequencesResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxValue As SqlDecimal
C#
public SqlDecimal MaxValue { get; set; }
Visual C++
public:
property SqlDecimal MaxValue {
    SqlDecimal get ();
    void set (SqlDecimal value);
}

See Also

SqlSequencesResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


MinValue Property

[image]

SQL Data Compare API 12.0.40
SqlSequencesResult..::.MinValue Property
SqlSequencesResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property MinValue As SqlDecimal
C#
public SqlDecimal MinValue { get; set; }
Visual C++
public:
property SqlDecimal MinValue {
    SqlDecimal get ();
    void set (SqlDecimal value);
}

See Also

SqlSequencesResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
SqlSequencesResult..::.Name Property
SqlSequencesResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

SqlSequencesResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
SqlSequencesResult..::.Owner Property
SqlSequencesResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Owner As String
C#
public string Owner { get; set; }
Visual C++
public:
property String^ Owner {
    String^ get ();
    void set (String^ value);
}

See Also

SqlSequencesResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Precision Property

[image]

SQL Data Compare API 12.0.40
SqlSequencesResult..::.Precision Property
SqlSequencesResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Precision As Byte
C#
public byte Precision { get; set; }
Visual C++
public:
property unsigned char Precision {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

SqlSequencesResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Scale Property

[image]

SQL Data Compare API 12.0.40
SqlSequencesResult..::.Scale Property
SqlSequencesResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Scale As Byte
C#
public byte Scale { get; set; }
Visual C++
public:
property unsigned char Scale {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

SqlSequencesResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Start Property

[image]

SQL Data Compare API 12.0.40
SqlSequencesResult..::.Start Property
SqlSequencesResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Start As SqlDecimal
C#
public SqlDecimal Start { get; set; }
Visual C++
public:
property SqlDecimal Start {
    SqlDecimal get ();
    void set (SqlDecimal value);
}

See Also

SqlSequencesResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SysobjectID Property

[image]

SQL Data Compare API 12.0.40
SqlSequencesResult..::.SysobjectID Property
SqlSequencesResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SysobjectID As Integer
C#
public int SysobjectID { get; set; }
Visual C++
public:
property int SysobjectID {
    int get ();
    void set (int value);
}

See Also

SqlSequencesResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TypeName Property

[image]

SQL Data Compare API 12.0.40
SqlSequencesResult..::.TypeName Property
SqlSequencesResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeName As String
C#
public string TypeName { get; set; }
Visual C++
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlSequencesResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TypeSchemaName Property

[image]

SQL Data Compare API 12.0.40
SqlSequencesResult..::.TypeSchemaName Property
SqlSequencesResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeSchemaName As String
C#
public string TypeSchemaName { get; set; }
Visual C++
public:
property String^ TypeSchemaName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlSequencesResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlServiceContractResult Class

[image]

SQL Data Compare API 12.0.40
SqlServiceContractResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlServiceContractResult
C#
public class SqlServiceContractResult
Visual C++
public ref class SqlServiceContractResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlServiceContractResult

See Also

SqlServiceContractResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlServiceContractResult Members

[image] [image]

SQL Data Compare API 12.0.40
SqlServiceContractResult Members
SqlServiceContractResult Class Constructors Methods Properties See Also

The SqlServiceContractResult type exposes the following members.

Constructors

Name | Description
SqlServiceContractResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Contract |
Service |

See Also

SqlServiceContractResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlServiceContractResult Constructor

[image]

SQL Data Compare API 12.0.40
SqlServiceContractResult Constructor
SqlServiceContractResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlServiceContractResult()
Visual C++
public:
SqlServiceContractResult()

See Also

SqlServiceContractResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlServiceContractResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlServiceContractResult Properties
SqlServiceContractResult Class See Also

The SqlServiceContractResult type exposes the following properties.

Properties

Name | Description
Contract |
Service |

See Also

SqlServiceContractResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Contract Property

[image]

SQL Data Compare API 12.0.40
SqlServiceContractResult..::.Contract Property
SqlServiceContractResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Contract As String
C#
public string Contract { get; set; }
Visual C++
public:
property String^ Contract {
    String^ get ();
    void set (String^ value);
}

See Also

SqlServiceContractResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Service Property

[image]

SQL Data Compare API 12.0.40
SqlServiceContractResult..::.Service Property
SqlServiceContractResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Service As String
C#
public string Service { get; set; }
Visual C++
public:
property String^ Service {
    String^ get ();
    void set (String^ value);
}

See Also

SqlServiceContractResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlServiceResult Class

[image]

SQL Data Compare API 12.0.40
SqlServiceResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlServiceResult
C#
public class SqlServiceResult
Visual C++
public ref class SqlServiceResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlServiceResult

See Also

SqlServiceResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlServiceResult Members

[image] [image]

SQL Data Compare API 12.0.40
SqlServiceResult Members
SqlServiceResult Class Constructors Methods Properties See Also

The SqlServiceResult type exposes the following members.

Constructors

Name | Description
SqlServiceResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ID |
Name |
Owner |
QueueName |
QueueSchema |

See Also

SqlServiceResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlServiceResult Constructor

[image]

SQL Data Compare API 12.0.40
SqlServiceResult Constructor
SqlServiceResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlServiceResult()
Visual C++
public:
SqlServiceResult()

See Also

SqlServiceResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlServiceResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlServiceResult Properties
SqlServiceResult Class See Also

The SqlServiceResult type exposes the following properties.

Properties

Name | Description
ID |
Name |
Owner |
QueueName |
QueueSchema |

See Also

SqlServiceResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ID Property

[image]

SQL Data Compare API 12.0.40
SqlServiceResult..::.ID Property
SqlServiceResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ID As Integer
C#
public int ID { get; set; }
Visual C++
public:
property int ID {
    int get ();
    void set (int value);
}

See Also

SqlServiceResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
SqlServiceResult..::.Name Property
SqlServiceResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

SqlServiceResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
SqlServiceResult..::.Owner Property
SqlServiceResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Owner As String
C#
public string Owner { get; set; }
Visual C++
public:
property String^ Owner {
    String^ get ();
    void set (String^ value);
}

See Also

SqlServiceResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


QueueName Property

[image]

SQL Data Compare API 12.0.40
SqlServiceResult..::.QueueName Property
SqlServiceResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property QueueName As String
C#
public string QueueName { get; set; }
Visual C++
public:
property String^ QueueName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlServiceResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


QueueSchema Property

[image]

SQL Data Compare API 12.0.40
SqlServiceResult..::.QueueSchema Property
SqlServiceResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property QueueSchema As String
C#
public string QueueSchema { get; set; }
Visual C++
public:
property String^ QueueSchema {
    String^ get ();
    void set (String^ value);
}

See Also

SqlServiceResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlSettingResult Class

[image]

SQL Data Compare API 12.0.40
SqlSettingResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlSettingResult
C#
public class SqlSettingResult
Visual C++
public ref class SqlSettingResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlSettingResult

See Also

SqlSettingResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlSettingResult Members

[image] [image]

SQL Data Compare API 12.0.40
SqlSettingResult Members
SqlSettingResult Class Constructors Methods Properties See Also

The SqlSettingResult type exposes the following members.

Constructors

Name | Description
SqlSettingResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FullTextEnabled |
RemoteDataArchiveEnabled |

See Also

SqlSettingResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlSettingResult Constructor

[image]

SQL Data Compare API 12.0.40
SqlSettingResult Constructor
SqlSettingResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlSettingResult()
Visual C++
public:
SqlSettingResult()

See Also

SqlSettingResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlSettingResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlSettingResult Properties
SqlSettingResult Class See Also

The SqlSettingResult type exposes the following properties.

Properties

Name | Description
FullTextEnabled |
RemoteDataArchiveEnabled |

See Also

SqlSettingResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FullTextEnabled Property

[image]

SQL Data Compare API 12.0.40
SqlSettingResult..::.FullTextEnabled Property
SqlSettingResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextEnabled As Boolean
C#
public bool FullTextEnabled { get; set; }
Visual C++
public:
property bool FullTextEnabled {
    bool get ();
    void set (bool value);
}

See Also

SqlSettingResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


RemoteDataArchiveEnabled Property

[image]

SQL Data Compare API 12.0.40
SqlSettingResult..::.RemoteDataArchiveEnabled Property
SqlSettingResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RemoteDataArchiveEnabled As Boolean
C#
public bool RemoteDataArchiveEnabled { get; set; }
Visual C++
public:
property bool RemoteDataArchiveEnabled {
    bool get ();
    void set (bool value);
}

See Also

SqlSettingResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlStatisticsResult Class

[image]

SQL Data Compare API 12.0.40
SqlStatisticsResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlStatisticsResult
C#
public class SqlStatisticsResult
Visual C++
public ref class SqlStatisticsResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlStatisticsResult

See Also

SqlStatisticsResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlStatisticsResult Members

[image] [image]

SQL Data Compare API 12.0.40
SqlStatisticsResult Members
SqlStatisticsResult Class Constructors Methods Properties See Also

The SqlStatisticsResult type exposes the following members.

Constructors

Name | Description
SqlStatisticsResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColumnName |
FilterDefinition |
Incremental |
IndexID |
IndexName |
IsTable |
NoRecompute |
ParentName |
SchemaName |

See Also

SqlStatisticsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlStatisticsResult Constructor

[image]

SQL Data Compare API 12.0.40
SqlStatisticsResult Constructor
SqlStatisticsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlStatisticsResult()
Visual C++
public:
SqlStatisticsResult()

See Also

SqlStatisticsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlStatisticsResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlStatisticsResult Properties
SqlStatisticsResult Class See Also

The SqlStatisticsResult type exposes the following properties.

Properties

Name | Description
ColumnName |
FilterDefinition |
Incremental |
IndexID |
IndexName |
IsTable |
NoRecompute |
ParentName |
SchemaName |

See Also

SqlStatisticsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ColumnName Property

[image]

SQL Data Compare API 12.0.40
SqlStatisticsResult..::.ColumnName Property
SqlStatisticsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ColumnName As String
C#
public string ColumnName { get; set; }
Visual C++
public:
property String^ ColumnName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlStatisticsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FilterDefinition Property

[image]

SQL Data Compare API 12.0.40
SqlStatisticsResult..::.FilterDefinition Property
SqlStatisticsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FilterDefinition As String
C#
public string FilterDefinition { get; set; }
Visual C++
public:
property String^ FilterDefinition {
    String^ get ();
    void set (String^ value);
}

See Also

SqlStatisticsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Incremental Property

[image]

SQL Data Compare API 12.0.40
SqlStatisticsResult..::.Incremental Property
SqlStatisticsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Incremental As Boolean
C#
public bool Incremental { get; set; }
Visual C++
public:
property bool Incremental {
    bool get ();
    void set (bool value);
}

See Also

SqlStatisticsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IndexID Property

[image]

SQL Data Compare API 12.0.40
SqlStatisticsResult..::.IndexID Property
SqlStatisticsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IndexID As Integer
C#
public int IndexID { get; set; }
Visual C++
public:
property int IndexID {
    int get ();
    void set (int value);
}

See Also

SqlStatisticsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IndexName Property

[image]

SQL Data Compare API 12.0.40
SqlStatisticsResult..::.IndexName Property
SqlStatisticsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IndexName As String
C#
public string IndexName { get; set; }
Visual C++
public:
property String^ IndexName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlStatisticsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsTable Property

[image]

SQL Data Compare API 12.0.40
SqlStatisticsResult..::.IsTable Property
SqlStatisticsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsTable As Boolean
C#
public bool IsTable { get; set; }
Visual C++
public:
property bool IsTable {
    bool get ();
    void set (bool value);
}

See Also

SqlStatisticsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


NoRecompute Property

[image]

SQL Data Compare API 12.0.40
SqlStatisticsResult..::.NoRecompute Property
SqlStatisticsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NoRecompute As Boolean
C#
public bool NoRecompute { get; set; }
Visual C++
public:
property bool NoRecompute {
    bool get ();
    void set (bool value);
}

See Also

SqlStatisticsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ParentName Property

[image]

SQL Data Compare API 12.0.40
SqlStatisticsResult..::.ParentName Property
SqlStatisticsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ParentName As String
C#
public string ParentName { get; set; }
Visual C++
public:
property String^ ParentName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlStatisticsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SchemaName Property

[image]

SQL Data Compare API 12.0.40
SqlStatisticsResult..::.SchemaName Property
SqlStatisticsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SchemaName As String
C#
public string SchemaName { get; set; }
Visual C++
public:
property String^ SchemaName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlStatisticsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlStoplistResult Class

[image]

SQL Data Compare API 12.0.40
SqlStoplistResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlStoplistResult
C#
public class SqlStoplistResult
Visual C++
public ref class SqlStoplistResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlStoplistResult

See Also

SqlStoplistResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlStoplistResult Members

[image] [image]

SQL Data Compare API 12.0.40
SqlStoplistResult Members
SqlStoplistResult Class Constructors Methods Properties See Also

The SqlStoplistResult type exposes the following members.

Constructors

Name | Description
SqlStoplistResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Name |
Owner |

See Also

SqlStoplistResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlStoplistResult Constructor

[image]

SQL Data Compare API 12.0.40
SqlStoplistResult Constructor
SqlStoplistResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlStoplistResult()
Visual C++
public:
SqlStoplistResult()

See Also

SqlStoplistResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlStoplistResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlStoplistResult Properties
SqlStoplistResult Class See Also

The SqlStoplistResult type exposes the following properties.

Properties

Name | Description
Name |
Owner |

See Also

SqlStoplistResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
SqlStoplistResult..::.Name Property
SqlStoplistResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

SqlStoplistResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
SqlStoplistResult..::.Owner Property
SqlStoplistResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Owner As String
C#
public string Owner { get; set; }
Visual C++
public:
property String^ Owner {
    String^ get ();
    void set (String^ value);
}

See Also

SqlStoplistResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlStopwordResult Class

[image]

SQL Data Compare API 12.0.40
SqlStopwordResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlStopwordResult
C#
public class SqlStopwordResult
Visual C++
public ref class SqlStopwordResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlStopwordResult

See Also

SqlStopwordResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlStopwordResult Members

[image] [image]

SQL Data Compare API 12.0.40
SqlStopwordResult Members
SqlStopwordResult Class Constructors Methods Properties See Also

The SqlStopwordResult type exposes the following members.

Constructors

Name | Description
SqlStopwordResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
LanguageID |
StoplistName |
StopWord |

See Also

SqlStopwordResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlStopwordResult Constructor

[image]

SQL Data Compare API 12.0.40
SqlStopwordResult Constructor
SqlStopwordResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlStopwordResult()
Visual C++
public:
SqlStopwordResult()

See Also

SqlStopwordResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlStopwordResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlStopwordResult Properties
SqlStopwordResult Class See Also

The SqlStopwordResult type exposes the following properties.

Properties

Name | Description
LanguageID |
StoplistName |
StopWord |

See Also

SqlStopwordResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


LanguageID Property

[image]

SQL Data Compare API 12.0.40
SqlStopwordResult..::.LanguageID Property
SqlStopwordResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LanguageID As Nullable(Of Integer)
C#
public Nullable<int> LanguageID { get; set; }
Visual C++
public:
property Nullable<int> LanguageID {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

SqlStopwordResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


StoplistName Property

[image]

SQL Data Compare API 12.0.40
SqlStopwordResult..::.StoplistName Property
SqlStopwordResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property StoplistName As String
C#
public string StoplistName { get; set; }
Visual C++
public:
property String^ StoplistName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlStopwordResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


StopWord Property

[image]

SQL Data Compare API 12.0.40
SqlStopwordResult..::.StopWord Property
SqlStopwordResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property StopWord As String
C#
public string StopWord { get; set; }
Visual C++
public:
property String^ StopWord {
    String^ get ();
    void set (String^ value);
}

See Also

SqlStopwordResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlSymmetricKeyResult Class

[image]

SQL Data Compare API 12.0.40
SqlSymmetricKeyResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlSymmetricKeyResult
C#
public class SqlSymmetricKeyResult
Visual C++
public ref class SqlSymmetricKeyResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlSymmetricKeyResult

See Also

SqlSymmetricKeyResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlSymmetricKeyResult Members

[image] [image]

SQL Data Compare API 12.0.40
SqlSymmetricKeyResult Members
SqlSymmetricKeyResult Class Constructors Methods Properties See Also

The SqlSymmetricKeyResult type exposes the following members.

Constructors

Name | Description
SqlSymmetricKeyResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CreateDate |
ID |
KeyAlgorithm |
KeyGuid |
KeyLength |
ModifyDate |
Name |
Owner |

See Also

SqlSymmetricKeyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlSymmetricKeyResult Constructor

[image]

SQL Data Compare API 12.0.40
SqlSymmetricKeyResult Constructor
SqlSymmetricKeyResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlSymmetricKeyResult()
Visual C++
public:
SqlSymmetricKeyResult()

See Also

SqlSymmetricKeyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlSymmetricKeyResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlSymmetricKeyResult Properties
SqlSymmetricKeyResult Class See Also

The SqlSymmetricKeyResult type exposes the following properties.

Properties

Name | Description
CreateDate |
ID |
KeyAlgorithm |
KeyGuid |
KeyLength |
ModifyDate |
Name |
Owner |

See Also

SqlSymmetricKeyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


CreateDate Property

[image]

SQL Data Compare API 12.0.40
SqlSymmetricKeyResult..::.CreateDate Property
SqlSymmetricKeyResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CreateDate As DateTime
C#
public DateTime CreateDate { get; set; }
Visual C++
public:
property DateTime CreateDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

SqlSymmetricKeyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ID Property

[image]

SQL Data Compare API 12.0.40
SqlSymmetricKeyResult..::.ID Property
SqlSymmetricKeyResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ID As Integer
C#
public int ID { get; set; }
Visual C++
public:
property int ID {
    int get ();
    void set (int value);
}

See Also

SqlSymmetricKeyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


KeyAlgorithm Property

[image]

SQL Data Compare API 12.0.40
SqlSymmetricKeyResult..::.KeyAlgorithm Property
SqlSymmetricKeyResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property KeyAlgorithm As String
C#
public string KeyAlgorithm { get; set; }
Visual C++
public:
property String^ KeyAlgorithm {
    String^ get ();
    void set (String^ value);
}

See Also

SqlSymmetricKeyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


KeyGuid Property

[image]

SQL Data Compare API 12.0.40
SqlSymmetricKeyResult..::.KeyGuid Property
SqlSymmetricKeyResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property KeyGuid As Guid
C#
public Guid KeyGuid { get; set; }
Visual C++
public:
property Guid KeyGuid {
    Guid get ();
    void set (Guid value);
}

See Also

SqlSymmetricKeyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


KeyLength Property

[image]

SQL Data Compare API 12.0.40
SqlSymmetricKeyResult..::.KeyLength Property
SqlSymmetricKeyResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property KeyLength As Integer
C#
public int KeyLength { get; set; }
Visual C++
public:
property int KeyLength {
    int get ();
    void set (int value);
}

See Also

SqlSymmetricKeyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ModifyDate Property

[image]

SQL Data Compare API 12.0.40
SqlSymmetricKeyResult..::.ModifyDate Property
SqlSymmetricKeyResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ModifyDate As DateTime
C#
public DateTime ModifyDate { get; set; }
Visual C++
public:
property DateTime ModifyDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

SqlSymmetricKeyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
SqlSymmetricKeyResult..::.Name Property
SqlSymmetricKeyResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

SqlSymmetricKeyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
SqlSymmetricKeyResult..::.Owner Property
SqlSymmetricKeyResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Owner As String
C#
public string Owner { get; set; }
Visual C++
public:
property String^ Owner {
    String^ get ();
    void set (String^ value);
}

See Also

SqlSymmetricKeyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlSynonymResult Class

[image]

SQL Data Compare API 12.0.40
SqlSynonymResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlSynonymResult
C#
public class SqlSynonymResult
Visual C++
public ref class SqlSynonymResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlSynonymResult

See Also

SqlSynonymResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlSynonymResult Members

[image] [image]

SQL Data Compare API 12.0.40
SqlSynonymResult Members
SqlSynonymResult Class Constructors Methods Properties See Also

The SqlSynonymResult type exposes the following members.

Constructors

Name | Description
SqlSynonymResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Authorization |
BaseObjectName |
ID |
Name |
Owner |
ReferenceID |

See Also

SqlSynonymResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlSynonymResult Constructor

[image]

SQL Data Compare API 12.0.40
SqlSynonymResult Constructor
SqlSynonymResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlSynonymResult()
Visual C++
public:
SqlSynonymResult()

See Also

SqlSynonymResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlSynonymResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlSynonymResult Properties
SqlSynonymResult Class See Also

The SqlSynonymResult type exposes the following properties.

Properties

Name | Description
Authorization |
BaseObjectName |
ID |
Name |
Owner |
ReferenceID |

See Also

SqlSynonymResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Authorization Property

[image]

SQL Data Compare API 12.0.40
SqlSynonymResult..::.Authorization Property
SqlSynonymResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Authorization As String
C#
public string Authorization { get; set; }
Visual C++
public:
property String^ Authorization {
    String^ get ();
    void set (String^ value);
}

See Also

SqlSynonymResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


BaseObjectName Property

[image]

SQL Data Compare API 12.0.40
SqlSynonymResult..::.BaseObjectName Property
SqlSynonymResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BaseObjectName As String
C#
public string BaseObjectName { get; set; }
Visual C++
public:
property String^ BaseObjectName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlSynonymResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ID Property

[image]

SQL Data Compare API 12.0.40
SqlSynonymResult..::.ID Property
SqlSynonymResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ID As Integer
C#
public int ID { get; set; }
Visual C++
public:
property int ID {
    int get ();
    void set (int value);
}

See Also

SqlSynonymResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
SqlSynonymResult..::.Name Property
SqlSynonymResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

SqlSynonymResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
SqlSynonymResult..::.Owner Property
SqlSynonymResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Owner As String
C#
public string Owner { get; set; }
Visual C++
public:
property String^ Owner {
    String^ get ();
    void set (String^ value);
}

See Also

SqlSynonymResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ReferenceID Property

[image]

SQL Data Compare API 12.0.40
SqlSynonymResult..::.ReferenceID Property
SqlSynonymResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ReferenceID As Nullable(Of Integer)
C#
public Nullable<int> ReferenceID { get; set; }
Visual C++
public:
property Nullable<int> ReferenceID {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

SqlSynonymResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlTableResult Class

[image]

SQL Data Compare API 12.0.40
SqlTableResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlTableResult
C#
public class SqlTableResult
Visual C++
public ref class SqlTableResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlTableResult

See Also

SqlTableResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlTableResult Members

[image] [image]

SQL Data Compare API 12.0.40
SqlTableResult Members
SqlTableResult Class Constructors Methods Properties See Also

The SqlTableResult type exposes the following members.

Constructors

Name | Description
SqlTableResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DataCompression |
DataCompressionPartitionNumber |
DataSpaceType |
DirectoryName |
Durability |
FileGroup |
FilenameCollationName |
FilestreamFileGroup |
FullTextCatalogName |
FullTextChangeTracking |
FullTextIndexed |
FullTextStoplistID |
FullTextStoplistName |
ID |
IsFileTable |
IsMemoryOptimized |
IsRemoteDataArchiveEnabled |
IsRemoteDataArchivePaused |
IsSystemObject |
LastModified |
LockEscalation |
Name |
Owner |
SchemaName |
TableChangeTrackingEnabled |
TableChangeTrackingTracksColumns |
TextFileGroup |

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlTableResult Constructor

[image]

SQL Data Compare API 12.0.40
SqlTableResult Constructor
SqlTableResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlTableResult()
Visual C++
public:
SqlTableResult()

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlTableResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlTableResult Properties
SqlTableResult Class See Also

The SqlTableResult type exposes the following properties.

Properties

Name | Description
DataCompression |
DataCompressionPartitionNumber |
DataSpaceType |
DirectoryName |
Durability |
FileGroup |
FilenameCollationName |
FilestreamFileGroup |
FullTextCatalogName |
FullTextChangeTracking |
FullTextIndexed |
FullTextStoplistID |
FullTextStoplistName |
ID |
IsFileTable |
IsMemoryOptimized |
IsRemoteDataArchiveEnabled |
IsRemoteDataArchivePaused |
IsSystemObject |
LastModified |
LockEscalation |
Name |
Owner |
SchemaName |
TableChangeTrackingEnabled |
TableChangeTrackingTracksColumns |
TextFileGroup |

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DataCompression Property

[image]

SQL Data Compare API 12.0.40
SqlTableResult..::.DataCompression Property
SqlTableResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DataCompression As Nullable(Of Byte)
C#
public Nullable<byte> DataCompression { get; set; }
Visual C++
public:
property Nullable<unsigned char> DataCompression {
    Nullable<unsigned char> get ();
    void set (Nullable<unsigned char> value);
}

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DataCompressionPartitionNumber Property

[image]

SQL Data Compare API 12.0.40
SqlTableResult..::.DataCompressionPartitionNumber Property
SqlTableResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DataCompressionPartitionNumber As Integer
C#
public int DataCompressionPartitionNumber { get; set; }
Visual C++
public:
property int DataCompressionPartitionNumber {
    int get ();
    void set (int value);
}

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DataSpaceType Property

[image]

SQL Data Compare API 12.0.40
SqlTableResult..::.DataSpaceType Property
SqlTableResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DataSpaceType As String
C#
public string DataSpaceType { get; set; }
Visual C++
public:
property String^ DataSpaceType {
    String^ get ();
    void set (String^ value);
}

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DirectoryName Property

[image]

SQL Data Compare API 12.0.40
SqlTableResult..::.DirectoryName Property
SqlTableResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DirectoryName As String
C#
public string DirectoryName { get; set; }
Visual C++
public:
property String^ DirectoryName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Durability Property

[image]

SQL Data Compare API 12.0.40
SqlTableResult..::.Durability Property
SqlTableResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Durability As Byte
C#
public byte Durability { get; set; }
Visual C++
public:
property unsigned char Durability {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FileGroup Property

[image]

SQL Data Compare API 12.0.40
SqlTableResult..::.FileGroup Property
SqlTableResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FileGroup As String
C#
public string FileGroup { get; set; }
Visual C++
public:
property String^ FileGroup {
    String^ get ();
    void set (String^ value);
}

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FilenameCollationName Property

[image]

SQL Data Compare API 12.0.40
SqlTableResult..::.FilenameCollationName Property
SqlTableResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FilenameCollationName As String
C#
public string FilenameCollationName { get; set; }
Visual C++
public:
property String^ FilenameCollationName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FilestreamFileGroup Property

[image]

SQL Data Compare API 12.0.40
SqlTableResult..::.FilestreamFileGroup Property
SqlTableResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FilestreamFileGroup As String
C#
public string FilestreamFileGroup { get; set; }
Visual C++
public:
property String^ FilestreamFileGroup {
    String^ get ();
    void set (String^ value);
}

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FullTextCatalogName Property

[image]

SQL Data Compare API 12.0.40
SqlTableResult..::.FullTextCatalogName Property
SqlTableResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextCatalogName As String
C#
public string FullTextCatalogName { get; set; }
Visual C++
public:
property String^ FullTextCatalogName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FullTextChangeTracking Property

[image]

SQL Data Compare API 12.0.40
SqlTableResult..::.FullTextChangeTracking Property
SqlTableResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextChangeTracking As String
C#
public string FullTextChangeTracking { get; set; }
Visual C++
public:
property String^ FullTextChangeTracking {
    String^ get ();
    void set (String^ value);
}

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FullTextIndexed Property

[image]

SQL Data Compare API 12.0.40
SqlTableResult..::.FullTextIndexed Property
SqlTableResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextIndexed As Boolean
C#
public bool FullTextIndexed { get; set; }
Visual C++
public:
property bool FullTextIndexed {
    bool get ();
    void set (bool value);
}

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FullTextStoplistID Property

[image]

SQL Data Compare API 12.0.40
SqlTableResult..::.FullTextStoplistID Property
SqlTableResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextStoplistID As Nullable(Of Integer)
C#
public Nullable<int> FullTextStoplistID { get; set; }
Visual C++
public:
property Nullable<int> FullTextStoplistID {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FullTextStoplistName Property

[image]

SQL Data Compare API 12.0.40
SqlTableResult..::.FullTextStoplistName Property
SqlTableResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextStoplistName As String
C#
public string FullTextStoplistName { get; set; }
Visual C++
public:
property String^ FullTextStoplistName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ID Property

[image]

SQL Data Compare API 12.0.40
SqlTableResult..::.ID Property
SqlTableResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ID As Integer
C#
public int ID { get; set; }
Visual C++
public:
property int ID {
    int get ();
    void set (int value);
}

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsFileTable Property

[image]

SQL Data Compare API 12.0.40
SqlTableResult..::.IsFileTable Property
SqlTableResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsFileTable As Boolean
C#
public bool IsFileTable { get; set; }
Visual C++
public:
property bool IsFileTable {
    bool get ();
    void set (bool value);
}

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsMemoryOptimized Property

[image]

SQL Data Compare API 12.0.40
SqlTableResult..::.IsMemoryOptimized Property
SqlTableResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsMemoryOptimized As Boolean
C#
public bool IsMemoryOptimized { get; set; }
Visual C++
public:
property bool IsMemoryOptimized {
    bool get ();
    void set (bool value);
}

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsRemoteDataArchiveEnabled Property

[image]

SQL Data Compare API 12.0.40
SqlTableResult..::.IsRemoteDataArchiveEnabled Property
SqlTableResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsRemoteDataArchiveEnabled As Boolean
C#
public bool IsRemoteDataArchiveEnabled { get; set; }
Visual C++
public:
property bool IsRemoteDataArchiveEnabled {
    bool get ();
    void set (bool value);
}

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsRemoteDataArchivePaused Property

[image]

SQL Data Compare API 12.0.40
SqlTableResult..::.IsRemoteDataArchivePaused Property
SqlTableResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsRemoteDataArchivePaused As Boolean
C#
public bool IsRemoteDataArchivePaused { get; set; }
Visual C++
public:
property bool IsRemoteDataArchivePaused {
    bool get ();
    void set (bool value);
}

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsSystemObject Property

[image]

SQL Data Compare API 12.0.40
SqlTableResult..::.IsSystemObject Property
SqlTableResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSystemObject As Boolean
C#
public bool IsSystemObject { get; set; }
Visual C++
public:
property bool IsSystemObject {
    bool get ();
    void set (bool value);
}

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


LastModified Property

[image]

SQL Data Compare API 12.0.40
SqlTableResult..::.LastModified Property
SqlTableResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LastModified As DateTime
C#
public DateTime LastModified { get; set; }
Visual C++
public:
property DateTime LastModified {
    DateTime get ();
    void set (DateTime value);
}

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


LockEscalation Property

[image]

SQL Data Compare API 12.0.40
SqlTableResult..::.LockEscalation Property
SqlTableResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LockEscalation As Nullable(Of Byte)
C#
public Nullable<byte> LockEscalation { get; set; }
Visual C++
public:
property Nullable<unsigned char> LockEscalation {
    Nullable<unsigned char> get ();
    void set (Nullable<unsigned char> value);
}

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
SqlTableResult..::.Name Property
SqlTableResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
SqlTableResult..::.Owner Property
SqlTableResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Owner As String
C#
public string Owner { get; set; }
Visual C++
public:
property String^ Owner {
    String^ get ();
    void set (String^ value);
}

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SchemaName Property

[image]

SQL Data Compare API 12.0.40
SqlTableResult..::.SchemaName Property
SqlTableResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SchemaName As String
C#
public string SchemaName { get; set; }
Visual C++
public:
property String^ SchemaName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TableChangeTrackingEnabled Property

[image]

SQL Data Compare API 12.0.40
SqlTableResult..::.TableChangeTrackingEnabled Property
SqlTableResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TableChangeTrackingEnabled As Boolean
C#
public bool TableChangeTrackingEnabled { get; set; }
Visual C++
public:
property bool TableChangeTrackingEnabled {
    bool get ();
    void set (bool value);
}

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TableChangeTrackingTracksColumns Property

[image]

SQL Data Compare API 12.0.40
SqlTableResult..::.TableChangeTrackingTracksColumns Property
SqlTableResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TableChangeTrackingTracksColumns As Boolean
C#
public bool TableChangeTrackingTracksColumns { get; set; }
Visual C++
public:
property bool TableChangeTrackingTracksColumns {
    bool get ();
    void set (bool value);
}

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TextFileGroup Property

[image]

SQL Data Compare API 12.0.40
SqlTableResult..::.TextFileGroup Property
SqlTableResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TextFileGroup As String
C#
public string TextFileGroup { get; set; }
Visual C++
public:
property String^ TextFileGroup {
    String^ get ();
    void set (String^ value);
}

See Also

SqlTableResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlTableUdtResult Class

[image]

SQL Data Compare API 12.0.40
SqlTableUdtResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlTableUdtResult
C#
public class SqlTableUdtResult
Visual C++
public ref class SqlTableUdtResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlTableUdtResult

See Also

SqlTableUdtResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlTableUdtResult Members

[image] [image]

SQL Data Compare API 12.0.40
SqlTableUdtResult Members
SqlTableUdtResult Class Constructors Methods Properties See Also

The SqlTableUdtResult type exposes the following members.

Constructors

Name | Description
SqlTableUdtResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsMemoryOptimized |
TableID |
TableName |
UDTName |
UDTSchema |

See Also

SqlTableUdtResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlTableUdtResult Constructor

[image]

SQL Data Compare API 12.0.40
SqlTableUdtResult Constructor
SqlTableUdtResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlTableUdtResult()
Visual C++
public:
SqlTableUdtResult()

See Also

SqlTableUdtResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlTableUdtResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlTableUdtResult Properties
SqlTableUdtResult Class See Also

The SqlTableUdtResult type exposes the following properties.

Properties

Name | Description
IsMemoryOptimized |
TableID |
TableName |
UDTName |
UDTSchema |

See Also

SqlTableUdtResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsMemoryOptimized Property

[image]

SQL Data Compare API 12.0.40
SqlTableUdtResult..::.IsMemoryOptimized Property
SqlTableUdtResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsMemoryOptimized As Boolean
C#
public bool IsMemoryOptimized { get; set; }
Visual C++
public:
property bool IsMemoryOptimized {
    bool get ();
    void set (bool value);
}

See Also

SqlTableUdtResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TableID Property

[image]

SQL Data Compare API 12.0.40
SqlTableUdtResult..::.TableID Property
SqlTableUdtResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TableID As Integer
C#
public int TableID { get; set; }
Visual C++
public:
property int TableID {
    int get ();
    void set (int value);
}

See Also

SqlTableUdtResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TableName Property

[image]

SQL Data Compare API 12.0.40
SqlTableUdtResult..::.TableName Property
SqlTableUdtResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TableName As String
C#
public string TableName { get; set; }
Visual C++
public:
property String^ TableName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlTableUdtResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


UDTName Property

[image]

SQL Data Compare API 12.0.40
SqlTableUdtResult..::.UDTName Property
SqlTableUdtResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UDTName As String
C#
public string UDTName { get; set; }
Visual C++
public:
property String^ UDTName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlTableUdtResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


UDTSchema Property

[image]

SQL Data Compare API 12.0.40
SqlTableUdtResult..::.UDTSchema Property
SqlTableUdtResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UDTSchema As String
C#
public string UDTSchema { get; set; }
Visual C++
public:
property String^ UDTSchema {
    String^ get ();
    void set (String^ value);
}

See Also

SqlTableUdtResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlTriggerResult Class

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlTriggerResult
C#
public class SqlTriggerResult
Visual C++
public ref class SqlTriggerResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlTriggerResult

See Also

SqlTriggerResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlTriggerResult Members

[image] [image]

SQL Data Compare API 12.0.40
SqlTriggerResult Members
SqlTriggerResult Class Constructors Methods Properties See Also

The SqlTriggerResult type exposes the following members.

Constructors

Name | Description
SqlTriggerResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AnsiNullsOn |
Assembly |
AssemblyClass |
AssemblyMethod |
Encrypted |
EventType |
ExecuteAs |
ExecuteAsOwner |
FireFirst |
FireLast |
FirstDeleteTrigger |
FirstInsertTrigger |
FirstUpdateTrigger |
ID |
IsAfterTrigger |
IsDeleteTrigger |
IsDisabled |
IsInsertTrigger |
IsInsteadOfTrigger |
IsNotForReplication |
IsTable |
IsUpdateTrigger |
IsView |
LastDeleteTrigger |
LastInsertTrigger |
LastUpdateTrigger |
ParentID |
ParentName |
ParentOwner |
ParentSchema |
QuotedIdentifierOn |
SchemaName |
TriggerName |
TriggerOwner |
TriggerType |

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlTriggerResult Constructor

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult Constructor
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlTriggerResult()
Visual C++
public:
SqlTriggerResult()

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlTriggerResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlTriggerResult Properties
SqlTriggerResult Class See Also

The SqlTriggerResult type exposes the following properties.

Properties

Name | Description
AnsiNullsOn |
Assembly |
AssemblyClass |
AssemblyMethod |
Encrypted |
EventType |
ExecuteAs |
ExecuteAsOwner |
FireFirst |
FireLast |
FirstDeleteTrigger |
FirstInsertTrigger |
FirstUpdateTrigger |
ID |
IsAfterTrigger |
IsDeleteTrigger |
IsDisabled |
IsInsertTrigger |
IsInsteadOfTrigger |
IsNotForReplication |
IsTable |
IsUpdateTrigger |
IsView |
LastDeleteTrigger |
LastInsertTrigger |
LastUpdateTrigger |
ParentID |
ParentName |
ParentOwner |
ParentSchema |
QuotedIdentifierOn |
SchemaName |
TriggerName |
TriggerOwner |
TriggerType |

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AnsiNullsOn Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.AnsiNullsOn Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AnsiNullsOn As Boolean
C#
public bool AnsiNullsOn { get; set; }
Visual C++
public:
property bool AnsiNullsOn {
    bool get ();
    void set (bool value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Assembly Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.Assembly Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Assembly As String
C#
public string Assembly { get; set; }
Visual C++
public:
property String^ Assembly {
    String^ get ();
    void set (String^ value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AssemblyClass Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.AssemblyClass Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyClass As String
C#
public string AssemblyClass { get; set; }
Visual C++
public:
property String^ AssemblyClass {
    String^ get ();
    void set (String^ value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AssemblyMethod Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.AssemblyMethod Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyMethod As String
C#
public string AssemblyMethod { get; set; }
Visual C++
public:
property String^ AssemblyMethod {
    String^ get ();
    void set (String^ value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Encrypted Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.Encrypted Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Encrypted As Boolean
C#
public bool Encrypted { get; set; }
Visual C++
public:
property bool Encrypted {
    bool get ();
    void set (bool value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


EventType Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.EventType Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property EventType As Integer
C#
public int EventType { get; set; }
Visual C++
public:
property int EventType {
    int get ();
    void set (int value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ExecuteAs Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.ExecuteAs Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecuteAs As String
C#
public string ExecuteAs { get; set; }
Visual C++
public:
property String^ ExecuteAs {
    String^ get ();
    void set (String^ value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ExecuteAsOwner Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.ExecuteAsOwner Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecuteAsOwner As Boolean
C#
public bool ExecuteAsOwner { get; set; }
Visual C++
public:
property bool ExecuteAsOwner {
    bool get ();
    void set (bool value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FireFirst Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.FireFirst Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FireFirst As Boolean
C#
public bool FireFirst { get; set; }
Visual C++
public:
property bool FireFirst {
    bool get ();
    void set (bool value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FireLast Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.FireLast Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FireLast As Boolean
C#
public bool FireLast { get; set; }
Visual C++
public:
property bool FireLast {
    bool get ();
    void set (bool value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FirstDeleteTrigger Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.FirstDeleteTrigger Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FirstDeleteTrigger As Boolean
C#
public bool FirstDeleteTrigger { get; set; }
Visual C++
public:
property bool FirstDeleteTrigger {
    bool get ();
    void set (bool value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FirstInsertTrigger Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.FirstInsertTrigger Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FirstInsertTrigger As Boolean
C#
public bool FirstInsertTrigger { get; set; }
Visual C++
public:
property bool FirstInsertTrigger {
    bool get ();
    void set (bool value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FirstUpdateTrigger Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.FirstUpdateTrigger Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FirstUpdateTrigger As Boolean
C#
public bool FirstUpdateTrigger { get; set; }
Visual C++
public:
property bool FirstUpdateTrigger {
    bool get ();
    void set (bool value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ID Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.ID Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ID As Integer
C#
public int ID { get; set; }
Visual C++
public:
property int ID {
    int get ();
    void set (int value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsAfterTrigger Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.IsAfterTrigger Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsAfterTrigger As Boolean
C#
public bool IsAfterTrigger { get; set; }
Visual C++
public:
property bool IsAfterTrigger {
    bool get ();
    void set (bool value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsDeleteTrigger Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.IsDeleteTrigger Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsDeleteTrigger As Boolean
C#
public bool IsDeleteTrigger { get; set; }
Visual C++
public:
property bool IsDeleteTrigger {
    bool get ();
    void set (bool value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsDisabled Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.IsDisabled Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsDisabled As Boolean
C#
public bool IsDisabled { get; set; }
Visual C++
public:
property bool IsDisabled {
    bool get ();
    void set (bool value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsInsertTrigger Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.IsInsertTrigger Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsInsertTrigger As Boolean
C#
public bool IsInsertTrigger { get; set; }
Visual C++
public:
property bool IsInsertTrigger {
    bool get ();
    void set (bool value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsInsteadOfTrigger Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.IsInsteadOfTrigger Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsInsteadOfTrigger As Boolean
C#
public bool IsInsteadOfTrigger { get; set; }
Visual C++
public:
property bool IsInsteadOfTrigger {
    bool get ();
    void set (bool value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsNotForReplication Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.IsNotForReplication Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsNotForReplication As Boolean
C#
public bool IsNotForReplication { get; set; }
Visual C++
public:
property bool IsNotForReplication {
    bool get ();
    void set (bool value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsTable Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.IsTable Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsTable As Boolean
C#
public bool IsTable { get; set; }
Visual C++
public:
property bool IsTable {
    bool get ();
    void set (bool value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsUpdateTrigger Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.IsUpdateTrigger Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsUpdateTrigger As Boolean
C#
public bool IsUpdateTrigger { get; set; }
Visual C++
public:
property bool IsUpdateTrigger {
    bool get ();
    void set (bool value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsView Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.IsView Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsView As Boolean
C#
public bool IsView { get; set; }
Visual C++
public:
property bool IsView {
    bool get ();
    void set (bool value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


LastDeleteTrigger Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.LastDeleteTrigger Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LastDeleteTrigger As Boolean
C#
public bool LastDeleteTrigger { get; set; }
Visual C++
public:
property bool LastDeleteTrigger {
    bool get ();
    void set (bool value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


LastInsertTrigger Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.LastInsertTrigger Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LastInsertTrigger As Boolean
C#
public bool LastInsertTrigger { get; set; }
Visual C++
public:
property bool LastInsertTrigger {
    bool get ();
    void set (bool value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


LastUpdateTrigger Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.LastUpdateTrigger Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LastUpdateTrigger As Boolean
C#
public bool LastUpdateTrigger { get; set; }
Visual C++
public:
property bool LastUpdateTrigger {
    bool get ();
    void set (bool value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ParentID Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.ParentID Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ParentID As Integer
C#
public int ParentID { get; set; }
Visual C++
public:
property int ParentID {
    int get ();
    void set (int value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ParentName Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.ParentName Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ParentName As String
C#
public string ParentName { get; set; }
Visual C++
public:
property String^ ParentName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ParentOwner Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.ParentOwner Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ParentOwner As String
C#
public string ParentOwner { get; set; }
Visual C++
public:
property String^ ParentOwner {
    String^ get ();
    void set (String^ value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ParentSchema Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.ParentSchema Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ParentSchema As String
C#
public string ParentSchema { get; set; }
Visual C++
public:
property String^ ParentSchema {
    String^ get ();
    void set (String^ value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


QuotedIdentifierOn Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.QuotedIdentifierOn Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property QuotedIdentifierOn As Boolean
C#
public bool QuotedIdentifierOn { get; set; }
Visual C++
public:
property bool QuotedIdentifierOn {
    bool get ();
    void set (bool value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SchemaName Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.SchemaName Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SchemaName As String
C#
public string SchemaName { get; set; }
Visual C++
public:
property String^ SchemaName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TriggerName Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.TriggerName Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TriggerName As String
C#
public string TriggerName { get; set; }
Visual C++
public:
property String^ TriggerName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TriggerOwner Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.TriggerOwner Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TriggerOwner As String
C#
public string TriggerOwner { get; set; }
Visual C++
public:
property String^ TriggerOwner {
    String^ get ();
    void set (String^ value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TriggerType Property

[image]

SQL Data Compare API 12.0.40
SqlTriggerResult..::.TriggerType Property
SqlTriggerResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TriggerType As String
C#
public string TriggerType { get; set; }
Visual C++
public:
property String^ TriggerType {
    String^ get ();
    void set (String^ value);
}

See Also

SqlTriggerResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlUdtResult Class

[image]

SQL Data Compare API 12.0.40
SqlUdtResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlUdtResult
C#
public class SqlUdtResult
Visual C++
public ref class SqlUdtResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlUdtResult

See Also

SqlUdtResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlUdtResult Members

[image] [image]

SQL Data Compare API 12.0.40
SqlUdtResult Members
SqlUdtResult Class Constructors Methods Properties See Also

The SqlUdtResult type exposes the following members.

Constructors

Name | Description
SqlUdtResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowNulls |
Assembly |
AssemblyClass |
BaseType |
DefaultName |
DefaultOwner |
IsAssemblyType |
IsTableType |
Length |
Precision |
RuleName |
RuleOwner |
Scale |
UDTName |
UDTOwner |
UDTSchema |

See Also

SqlUdtResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlUdtResult Constructor

[image]

SQL Data Compare API 12.0.40
SqlUdtResult Constructor
SqlUdtResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlUdtResult()
Visual C++
public:
SqlUdtResult()

See Also

SqlUdtResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlUdtResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlUdtResult Properties
SqlUdtResult Class See Also

The SqlUdtResult type exposes the following properties.

Properties

Name | Description
AllowNulls |
Assembly |
AssemblyClass |
BaseType |
DefaultName |
DefaultOwner |
IsAssemblyType |
IsTableType |
Length |
Precision |
RuleName |
RuleOwner |
Scale |
UDTName |
UDTOwner |
UDTSchema |

See Also

SqlUdtResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AllowNulls Property

[image]

SQL Data Compare API 12.0.40
SqlUdtResult..::.AllowNulls Property
SqlUdtResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowNulls As Boolean
C#
public bool AllowNulls { get; set; }
Visual C++
public:
property bool AllowNulls {
    bool get ();
    void set (bool value);
}

See Also

SqlUdtResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Assembly Property

[image]

SQL Data Compare API 12.0.40
SqlUdtResult..::.Assembly Property
SqlUdtResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Assembly As String
C#
public string Assembly { get; set; }
Visual C++
public:
property String^ Assembly {
    String^ get ();
    void set (String^ value);
}

See Also

SqlUdtResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AssemblyClass Property

[image]

SQL Data Compare API 12.0.40
SqlUdtResult..::.AssemblyClass Property
SqlUdtResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyClass As String
C#
public string AssemblyClass { get; set; }
Visual C++
public:
property String^ AssemblyClass {
    String^ get ();
    void set (String^ value);
}

See Also

SqlUdtResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


BaseType Property

[image]

SQL Data Compare API 12.0.40
SqlUdtResult..::.BaseType Property
SqlUdtResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BaseType As String
C#
public string BaseType { get; set; }
Visual C++
public:
property String^ BaseType {
    String^ get ();
    void set (String^ value);
}

See Also

SqlUdtResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DefaultName Property

[image]

SQL Data Compare API 12.0.40
SqlUdtResult..::.DefaultName Property
SqlUdtResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultName As String
C#
public string DefaultName { get; set; }
Visual C++
public:
property String^ DefaultName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlUdtResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DefaultOwner Property

[image]

SQL Data Compare API 12.0.40
SqlUdtResult..::.DefaultOwner Property
SqlUdtResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultOwner As String
C#
public string DefaultOwner { get; set; }
Visual C++
public:
property String^ DefaultOwner {
    String^ get ();
    void set (String^ value);
}

See Also

SqlUdtResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsAssemblyType Property

[image]

SQL Data Compare API 12.0.40
SqlUdtResult..::.IsAssemblyType Property
SqlUdtResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsAssemblyType As Boolean
C#
public bool IsAssemblyType { get; set; }
Visual C++
public:
property bool IsAssemblyType {
    bool get ();
    void set (bool value);
}

See Also

SqlUdtResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsTableType Property

[image]

SQL Data Compare API 12.0.40
SqlUdtResult..::.IsTableType Property
SqlUdtResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsTableType As Boolean
C#
public bool IsTableType { get; set; }
Visual C++
public:
property bool IsTableType {
    bool get ();
    void set (bool value);
}

See Also

SqlUdtResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Length Property

[image]

SQL Data Compare API 12.0.40
SqlUdtResult..::.Length Property
SqlUdtResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Length As Integer
C#
public int Length { get; set; }
Visual C++
public:
property int Length {
    int get ();
    void set (int value);
}

See Also

SqlUdtResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Precision Property

[image]

SQL Data Compare API 12.0.40
SqlUdtResult..::.Precision Property
SqlUdtResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Precision As Integer
C#
public int Precision { get; set; }
Visual C++
public:
property int Precision {
    int get ();
    void set (int value);
}

See Also

SqlUdtResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


RuleName Property

[image]

SQL Data Compare API 12.0.40
SqlUdtResult..::.RuleName Property
SqlUdtResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RuleName As String
C#
public string RuleName { get; set; }
Visual C++
public:
property String^ RuleName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlUdtResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


RuleOwner Property

[image]

SQL Data Compare API 12.0.40
SqlUdtResult..::.RuleOwner Property
SqlUdtResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RuleOwner As String
C#
public string RuleOwner { get; set; }
Visual C++
public:
property String^ RuleOwner {
    String^ get ();
    void set (String^ value);
}

See Also

SqlUdtResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Scale Property

[image]

SQL Data Compare API 12.0.40
SqlUdtResult..::.Scale Property
SqlUdtResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Scale As Integer
C#
public int Scale { get; set; }
Visual C++
public:
property int Scale {
    int get ();
    void set (int value);
}

See Also

SqlUdtResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


UDTName Property

[image]

SQL Data Compare API 12.0.40
SqlUdtResult..::.UDTName Property
SqlUdtResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UDTName As String
C#
public string UDTName { get; set; }
Visual C++
public:
property String^ UDTName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlUdtResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


UDTOwner Property

[image]

SQL Data Compare API 12.0.40
SqlUdtResult..::.UDTOwner Property
SqlUdtResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UDTOwner As String
C#
public string UDTOwner { get; set; }
Visual C++
public:
property String^ UDTOwner {
    String^ get ();
    void set (String^ value);
}

See Also

SqlUdtResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


UDTSchema Property

[image]

SQL Data Compare API 12.0.40
SqlUdtResult..::.UDTSchema Property
SqlUdtResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UDTSchema As String
C#
public string UDTSchema { get; set; }
Visual C++
public:
property String^ UDTSchema {
    String^ get ();
    void set (String^ value);
}

See Also

SqlUdtResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlUserResult Class

[image]

SQL Data Compare API 12.0.40
SqlUserResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlUserResult
C#
public class SqlUserResult
Visual C++
public ref class SqlUserResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlUserResult

See Also

SqlUserResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlUserResult Members

[image] [image]

SQL Data Compare API 12.0.40
SqlUserResult Members
SqlUserResult Class Constructors Methods Properties See Also

The SqlUserResult type exposes the following members.

Constructors

Name | Description
SqlUserResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AsymmetricKeyName |
CertificateName |
DefaultSchema |
IsNTName |
IsSqlUser |
LoginName |
Name |
Type |

See Also

SqlUserResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlUserResult Constructor

[image]

SQL Data Compare API 12.0.40
SqlUserResult Constructor
SqlUserResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlUserResult()
Visual C++
public:
SqlUserResult()

See Also

SqlUserResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlUserResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlUserResult Properties
SqlUserResult Class See Also

The SqlUserResult type exposes the following properties.

Properties

Name | Description
AsymmetricKeyName |
CertificateName |
DefaultSchema |
IsNTName |
IsSqlUser |
LoginName |
Name |
Type |

See Also

SqlUserResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AsymmetricKeyName Property

[image]

SQL Data Compare API 12.0.40
SqlUserResult..::.AsymmetricKeyName Property
SqlUserResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AsymmetricKeyName As String
C#
public string AsymmetricKeyName { get; set; }
Visual C++
public:
property String^ AsymmetricKeyName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlUserResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


CertificateName Property

[image]

SQL Data Compare API 12.0.40
SqlUserResult..::.CertificateName Property
SqlUserResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CertificateName As String
C#
public string CertificateName { get; set; }
Visual C++
public:
property String^ CertificateName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlUserResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


DefaultSchema Property

[image]

SQL Data Compare API 12.0.40
SqlUserResult..::.DefaultSchema Property
SqlUserResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultSchema As String
C#
public string DefaultSchema { get; set; }
Visual C++
public:
property String^ DefaultSchema {
    String^ get ();
    void set (String^ value);
}

See Also

SqlUserResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsNTName Property

[image]

SQL Data Compare API 12.0.40
SqlUserResult..::.IsNTName Property
SqlUserResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsNTName As Boolean
C#
public bool IsNTName { get; set; }
Visual C++
public:
property bool IsNTName {
    bool get ();
    void set (bool value);
}

See Also

SqlUserResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsSqlUser Property

[image]

SQL Data Compare API 12.0.40
SqlUserResult..::.IsSqlUser Property
SqlUserResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSqlUser As Boolean
C#
public bool IsSqlUser { get; set; }
Visual C++
public:
property bool IsSqlUser {
    bool get ();
    void set (bool value);
}

See Also

SqlUserResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


LoginName Property

[image]

SQL Data Compare API 12.0.40
SqlUserResult..::.LoginName Property
SqlUserResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LoginName As String
C#
public string LoginName { get; set; }
Visual C++
public:
property String^ LoginName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlUserResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
SqlUserResult..::.Name Property
SqlUserResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

SqlUserResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Type Property

[image]

SQL Data Compare API 12.0.40
SqlUserResult..::.Type Property
SqlUserResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As String
C#
public string Type { get; set; }
Visual C++
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}

See Also

SqlUserResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlViewColumnWithDetailsResult Class

[image]

SQL Data Compare API 12.0.40
SqlViewColumnWithDetailsResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlViewColumnWithDetailsResult _
    Implements ICacheableQueryResult
C#
public class SqlViewColumnWithDetailsResult : ICacheableQueryResult
Visual C++
public ref class SqlViewColumnWithDetailsResult : ICacheableQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlViewColumnWithDetailsResult

See Also

SqlViewColumnWithDetailsResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlViewColumnWithDetailsResult Members

[image] [image]

SQL Data Compare API 12.0.40
SqlViewColumnWithDetailsResult Members
SqlViewColumnWithDetailsResult Class Constructors Methods Properties See Also

The SqlViewColumnWithDetailsResult type exposes the following members.

Constructors

Name | Description
SqlViewColumnWithDetailsResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowNulls |
BaseTypeName |
CacheKey |
Collation |
ColumnID |
ColumnName |
FullTextIndexed |
FullTextLanguage |
FullTextTypeColumn |
Identity |
IsComputed |
IsRowGuidCol |
Length |
NotForReplication |
ParentObjectId |
Precision |
Scale |
TypeName |
TypeOwner |
TypeSchemaName |
ViewName |
ViewOwner |

See Also

SqlViewColumnWithDetailsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlViewColumnWithDetailsResult Constructor

[image]

SQL Data Compare API 12.0.40
SqlViewColumnWithDetailsResult Constructor
SqlViewColumnWithDetailsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlViewColumnWithDetailsResult()
Visual C++
public:
SqlViewColumnWithDetailsResult()

See Also

SqlViewColumnWithDetailsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlViewColumnWithDetailsResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlViewColumnWithDetailsResult Properties
SqlViewColumnWithDetailsResult Class See Also

The SqlViewColumnWithDetailsResult type exposes the following properties.

Properties

Name | Description
AllowNulls |
BaseTypeName |
CacheKey |
Collation |
ColumnID |
ColumnName |
FullTextIndexed |
FullTextLanguage |
FullTextTypeColumn |
Identity |
IsComputed |
IsRowGuidCol |
Length |
NotForReplication |
ParentObjectId |
Precision |
Scale |
TypeName |
TypeOwner |
TypeSchemaName |
ViewName |
ViewOwner |

See Also

SqlViewColumnWithDetailsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AllowNulls Property

[image]

SQL Data Compare API 12.0.40
SqlViewColumnWithDetailsResult..::.AllowNulls Property
SqlViewColumnWithDetailsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowNulls As Boolean
C#
public bool AllowNulls { get; set; }
Visual C++
public:
property bool AllowNulls {
    bool get ();
    void set (bool value);
}

See Also

SqlViewColumnWithDetailsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


BaseTypeName Property

[image]

SQL Data Compare API 12.0.40
SqlViewColumnWithDetailsResult..::.BaseTypeName Property
SqlViewColumnWithDetailsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BaseTypeName As String
C#
public string BaseTypeName { get; set; }
Visual C++
public:
property String^ BaseTypeName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlViewColumnWithDetailsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


CacheKey Property

[image]

SQL Data Compare API 12.0.40
SqlViewColumnWithDetailsResult..::.CacheKey Property
SqlViewColumnWithDetailsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CacheKey As Integer
C#
public int CacheKey { get; }
Visual C++
public:
virtual property int CacheKey {
    int get () sealed;
}

Implements

ICacheableQueryResult..::.CacheKey

See Also

SqlViewColumnWithDetailsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Collation Property

[image]

SQL Data Compare API 12.0.40
SqlViewColumnWithDetailsResult..::.Collation Property
SqlViewColumnWithDetailsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Collation As String
C#
public string Collation { get; set; }
Visual C++
public:
property String^ Collation {
    String^ get ();
    void set (String^ value);
}

See Also

SqlViewColumnWithDetailsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ColumnID Property

[image]

SQL Data Compare API 12.0.40
SqlViewColumnWithDetailsResult..::.ColumnID Property
SqlViewColumnWithDetailsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ColumnID As Integer
C#
public int ColumnID { get; set; }
Visual C++
public:
property int ColumnID {
    int get ();
    void set (int value);
}

See Also

SqlViewColumnWithDetailsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ColumnName Property

[image]

SQL Data Compare API 12.0.40
SqlViewColumnWithDetailsResult..::.ColumnName Property
SqlViewColumnWithDetailsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ColumnName As String
C#
public string ColumnName { get; set; }
Visual C++
public:
property String^ ColumnName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlViewColumnWithDetailsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FullTextIndexed Property

[image]

SQL Data Compare API 12.0.40
SqlViewColumnWithDetailsResult..::.FullTextIndexed Property
SqlViewColumnWithDetailsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextIndexed As Boolean
C#
public bool FullTextIndexed { get; set; }
Visual C++
public:
property bool FullTextIndexed {
    bool get ();
    void set (bool value);
}

See Also

SqlViewColumnWithDetailsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FullTextLanguage Property

[image]

SQL Data Compare API 12.0.40
SqlViewColumnWithDetailsResult..::.FullTextLanguage Property
SqlViewColumnWithDetailsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextLanguage As Integer
C#
public int FullTextLanguage { get; set; }
Visual C++
public:
property int FullTextLanguage {
    int get ();
    void set (int value);
}

See Also

SqlViewColumnWithDetailsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FullTextTypeColumn Property

[image]

SQL Data Compare API 12.0.40
SqlViewColumnWithDetailsResult..::.FullTextTypeColumn Property
SqlViewColumnWithDetailsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextTypeColumn As String
C#
public string FullTextTypeColumn { get; set; }
Visual C++
public:
property String^ FullTextTypeColumn {
    String^ get ();
    void set (String^ value);
}

See Also

SqlViewColumnWithDetailsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Identity Property

[image]

SQL Data Compare API 12.0.40
SqlViewColumnWithDetailsResult..::.Identity Property
SqlViewColumnWithDetailsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Identity As Boolean
C#
public bool Identity { get; set; }
Visual C++
public:
property bool Identity {
    bool get ();
    void set (bool value);
}

See Also

SqlViewColumnWithDetailsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsComputed Property

[image]

SQL Data Compare API 12.0.40
SqlViewColumnWithDetailsResult..::.IsComputed Property
SqlViewColumnWithDetailsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsComputed As Boolean
C#
public bool IsComputed { get; set; }
Visual C++
public:
property bool IsComputed {
    bool get ();
    void set (bool value);
}

See Also

SqlViewColumnWithDetailsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsRowGuidCol Property

[image]

SQL Data Compare API 12.0.40
SqlViewColumnWithDetailsResult..::.IsRowGuidCol Property
SqlViewColumnWithDetailsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsRowGuidCol As Boolean
C#
public bool IsRowGuidCol { get; set; }
Visual C++
public:
property bool IsRowGuidCol {
    bool get ();
    void set (bool value);
}

See Also

SqlViewColumnWithDetailsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Length Property

[image]

SQL Data Compare API 12.0.40
SqlViewColumnWithDetailsResult..::.Length Property
SqlViewColumnWithDetailsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Length As Integer
C#
public int Length { get; set; }
Visual C++
public:
property int Length {
    int get ();
    void set (int value);
}

See Also

SqlViewColumnWithDetailsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


NotForReplication Property

[image]

SQL Data Compare API 12.0.40
SqlViewColumnWithDetailsResult..::.NotForReplication Property
SqlViewColumnWithDetailsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NotForReplication As Boolean
C#
public bool NotForReplication { get; set; }
Visual C++
public:
property bool NotForReplication {
    bool get ();
    void set (bool value);
}

See Also

SqlViewColumnWithDetailsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ParentObjectId Property

[image]

SQL Data Compare API 12.0.40
SqlViewColumnWithDetailsResult..::.ParentObjectId Property
SqlViewColumnWithDetailsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ParentObjectId As Integer
C#
public int ParentObjectId { get; set; }
Visual C++
public:
property int ParentObjectId {
    int get ();
    void set (int value);
}

See Also

SqlViewColumnWithDetailsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Precision Property

[image]

SQL Data Compare API 12.0.40
SqlViewColumnWithDetailsResult..::.Precision Property
SqlViewColumnWithDetailsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Precision As Integer
C#
public int Precision { get; set; }
Visual C++
public:
property int Precision {
    int get ();
    void set (int value);
}

See Also

SqlViewColumnWithDetailsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Scale Property

[image]

SQL Data Compare API 12.0.40
SqlViewColumnWithDetailsResult..::.Scale Property
SqlViewColumnWithDetailsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Scale As Integer
C#
public int Scale { get; set; }
Visual C++
public:
property int Scale {
    int get ();
    void set (int value);
}

See Also

SqlViewColumnWithDetailsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TypeName Property

[image]

SQL Data Compare API 12.0.40
SqlViewColumnWithDetailsResult..::.TypeName Property
SqlViewColumnWithDetailsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeName As String
C#
public string TypeName { get; set; }
Visual C++
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlViewColumnWithDetailsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TypeOwner Property

[image]

SQL Data Compare API 12.0.40
SqlViewColumnWithDetailsResult..::.TypeOwner Property
SqlViewColumnWithDetailsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeOwner As String
C#
public string TypeOwner { get; set; }
Visual C++
public:
property String^ TypeOwner {
    String^ get ();
    void set (String^ value);
}

See Also

SqlViewColumnWithDetailsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


TypeSchemaName Property

[image]

SQL Data Compare API 12.0.40
SqlViewColumnWithDetailsResult..::.TypeSchemaName Property
SqlViewColumnWithDetailsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeSchemaName As String
C#
public string TypeSchemaName { get; set; }
Visual C++
public:
property String^ TypeSchemaName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlViewColumnWithDetailsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ViewName Property

[image]

SQL Data Compare API 12.0.40
SqlViewColumnWithDetailsResult..::.ViewName Property
SqlViewColumnWithDetailsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ViewName As String
C#
public string ViewName { get; set; }
Visual C++
public:
property String^ ViewName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlViewColumnWithDetailsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ViewOwner Property

[image]

SQL Data Compare API 12.0.40
SqlViewColumnWithDetailsResult..::.ViewOwner Property
SqlViewColumnWithDetailsResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ViewOwner As String
C#
public string ViewOwner { get; set; }
Visual C++
public:
property String^ ViewOwner {
    String^ get ();
    void set (String^ value);
}

See Also

SqlViewColumnWithDetailsResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlViewResult Class

[image]

SQL Data Compare API 12.0.40
SqlViewResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlViewResult
C#
public class SqlViewResult
Visual C++
public ref class SqlViewResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlViewResult

See Also

SqlViewResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlViewResult Members

[image] [image]

SQL Data Compare API 12.0.40
SqlViewResult Members
SqlViewResult Class Constructors Methods Properties See Also

The SqlViewResult type exposes the following members.

Constructors

Name | Description
SqlViewResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AnsiNulls |
Encrypted |
FullTextCatalogName |
FullTextChangeTracking |
FullTextIndexed |
FullTextStopListID |
FullTextStopListName |
ID |
IsSystemObject |
LastModified |
QuotedIdentifier |
SchemaBound |
ViewName |
ViewOwner |
ViewSchema |

See Also

SqlViewResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlViewResult Constructor

[image]

SQL Data Compare API 12.0.40
SqlViewResult Constructor
SqlViewResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlViewResult()
Visual C++
public:
SqlViewResult()

See Also

SqlViewResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SqlViewResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlViewResult Properties
SqlViewResult Class See Also

The SqlViewResult type exposes the following properties.

Properties

Name | Description
AnsiNulls |
Encrypted |
FullTextCatalogName |
FullTextChangeTracking |
FullTextIndexed |
FullTextStopListID |
FullTextStopListName |
ID |
IsSystemObject |
LastModified |
QuotedIdentifier |
SchemaBound |
ViewName |
ViewOwner |
ViewSchema |

See Also

SqlViewResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


AnsiNulls Property

[image]

SQL Data Compare API 12.0.40
SqlViewResult..::.AnsiNulls Property
SqlViewResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AnsiNulls As Boolean
C#
public bool AnsiNulls { get; set; }
Visual C++
public:
property bool AnsiNulls {
    bool get ();
    void set (bool value);
}

See Also

SqlViewResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Encrypted Property

[image]

SQL Data Compare API 12.0.40
SqlViewResult..::.Encrypted Property
SqlViewResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Encrypted As Boolean
C#
public bool Encrypted { get; set; }
Visual C++
public:
property bool Encrypted {
    bool get ();
    void set (bool value);
}

See Also

SqlViewResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FullTextCatalogName Property

[image]

SQL Data Compare API 12.0.40
SqlViewResult..::.FullTextCatalogName Property
SqlViewResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextCatalogName As String
C#
public string FullTextCatalogName { get; set; }
Visual C++
public:
property String^ FullTextCatalogName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlViewResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FullTextChangeTracking Property

[image]

SQL Data Compare API 12.0.40
SqlViewResult..::.FullTextChangeTracking Property
SqlViewResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextChangeTracking As String
C#
public string FullTextChangeTracking { get; set; }
Visual C++
public:
property String^ FullTextChangeTracking {
    String^ get ();
    void set (String^ value);
}

See Also

SqlViewResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FullTextIndexed Property

[image]

SQL Data Compare API 12.0.40
SqlViewResult..::.FullTextIndexed Property
SqlViewResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextIndexed As Boolean
C#
public bool FullTextIndexed { get; set; }
Visual C++
public:
property bool FullTextIndexed {
    bool get ();
    void set (bool value);
}

See Also

SqlViewResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FullTextStopListID Property

[image]

SQL Data Compare API 12.0.40
SqlViewResult..::.FullTextStopListID Property
SqlViewResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextStopListID As Nullable(Of Integer)
C#
public Nullable<int> FullTextStopListID { get; set; }
Visual C++
public:
property Nullable<int> FullTextStopListID {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

SqlViewResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


FullTextStopListName Property

[image]

SQL Data Compare API 12.0.40
SqlViewResult..::.FullTextStopListName Property
SqlViewResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextStopListName As String
C#
public string FullTextStopListName { get; set; }
Visual C++
public:
property String^ FullTextStopListName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlViewResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ID Property

[image]

SQL Data Compare API 12.0.40
SqlViewResult..::.ID Property
SqlViewResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ID As Integer
C#
public int ID { get; set; }
Visual C++
public:
property int ID {
    int get ();
    void set (int value);
}

See Also

SqlViewResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsSystemObject Property

[image]

SQL Data Compare API 12.0.40
SqlViewResult..::.IsSystemObject Property
SqlViewResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSystemObject As Boolean
C#
public bool IsSystemObject { get; set; }
Visual C++
public:
property bool IsSystemObject {
    bool get ();
    void set (bool value);
}

See Also

SqlViewResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


LastModified Property

[image]

SQL Data Compare API 12.0.40
SqlViewResult..::.LastModified Property
SqlViewResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LastModified As DateTime
C#
public DateTime LastModified { get; set; }
Visual C++
public:
property DateTime LastModified {
    DateTime get ();
    void set (DateTime value);
}

See Also

SqlViewResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


QuotedIdentifier Property

[image]

SQL Data Compare API 12.0.40
SqlViewResult..::.QuotedIdentifier Property
SqlViewResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property QuotedIdentifier As Boolean
C#
public bool QuotedIdentifier { get; set; }
Visual C++
public:
property bool QuotedIdentifier {
    bool get ();
    void set (bool value);
}

See Also

SqlViewResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SchemaBound Property

[image]

SQL Data Compare API 12.0.40
SqlViewResult..::.SchemaBound Property
SqlViewResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SchemaBound As Boolean
C#
public bool SchemaBound { get; set; }
Visual C++
public:
property bool SchemaBound {
    bool get ();
    void set (bool value);
}

See Also

SqlViewResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ViewName Property

[image]

SQL Data Compare API 12.0.40
SqlViewResult..::.ViewName Property
SqlViewResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ViewName As String
C#
public string ViewName { get; set; }
Visual C++
public:
property String^ ViewName {
    String^ get ();
    void set (String^ value);
}

See Also

SqlViewResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ViewOwner Property

[image]

SQL Data Compare API 12.0.40
SqlViewResult..::.ViewOwner Property
SqlViewResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ViewOwner As String
C#
public string ViewOwner { get; set; }
Visual C++
public:
property String^ ViewOwner {
    String^ get ();
    void set (String^ value);
}

See Also

SqlViewResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ViewSchema Property

[image]

SQL Data Compare API 12.0.40
SqlViewResult..::.ViewSchema Property
SqlViewResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ViewSchema As String
C#
public string ViewSchema { get; set; }
Visual C++
public:
property String^ ViewSchema {
    String^ get ();
    void set (String^ value);
}

See Also

SqlViewResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


UdtDependencyResult Class

[image]

SQL Data Compare API 12.0.40
UdtDependencyResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class UdtDependencyResult
C#
public class UdtDependencyResult
Visual C++
public ref class UdtDependencyResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.UdtDependencyResult

See Also

UdtDependencyResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


UdtDependencyResult Members

[image] [image]

SQL Data Compare API 12.0.40
UdtDependencyResult Members
UdtDependencyResult Class Constructors Methods Properties See Also

The UdtDependencyResult type exposes the following members.

Constructors

Name | Description
UdtDependencyResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsFunction |
IsProcedure |
IsTable |
ObjectName |
ObjectOwner |
UDTName |
UDTOwner |

See Also

UdtDependencyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


UdtDependencyResult Constructor

[image]

SQL Data Compare API 12.0.40
UdtDependencyResult Constructor
UdtDependencyResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public UdtDependencyResult()
Visual C++
public:
UdtDependencyResult()

See Also

UdtDependencyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


UdtDependencyResult Properties

[image] [image]

SQL Data Compare API 12.0.40
UdtDependencyResult Properties
UdtDependencyResult Class See Also

The UdtDependencyResult type exposes the following properties.

Properties

Name | Description
IsFunction |
IsProcedure |
IsTable |
ObjectName |
ObjectOwner |
UDTName |
UDTOwner |

See Also

UdtDependencyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsFunction Property

[image]

SQL Data Compare API 12.0.40
UdtDependencyResult..::.IsFunction Property
UdtDependencyResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsFunction As Boolean
C#
public bool IsFunction { get; set; }
Visual C++
public:
property bool IsFunction {
    bool get ();
    void set (bool value);
}

See Also

UdtDependencyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsProcedure Property

[image]

SQL Data Compare API 12.0.40
UdtDependencyResult..::.IsProcedure Property
UdtDependencyResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsProcedure As Boolean
C#
public bool IsProcedure { get; set; }
Visual C++
public:
property bool IsProcedure {
    bool get ();
    void set (bool value);
}

See Also

UdtDependencyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


IsTable Property

[image]

SQL Data Compare API 12.0.40
UdtDependencyResult..::.IsTable Property
UdtDependencyResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsTable As Boolean
C#
public bool IsTable { get; set; }
Visual C++
public:
property bool IsTable {
    bool get ();
    void set (bool value);
}

See Also

UdtDependencyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ObjectName Property

[image]

SQL Data Compare API 12.0.40
UdtDependencyResult..::.ObjectName Property
UdtDependencyResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectName As String
C#
public string ObjectName { get; set; }
Visual C++
public:
property String^ ObjectName {
    String^ get ();
    void set (String^ value);
}

See Also

UdtDependencyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ObjectOwner Property

[image]

SQL Data Compare API 12.0.40
UdtDependencyResult..::.ObjectOwner Property
UdtDependencyResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectOwner As String
C#
public string ObjectOwner { get; set; }
Visual C++
public:
property String^ ObjectOwner {
    String^ get ();
    void set (String^ value);
}

See Also

UdtDependencyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


UDTName Property

[image]

SQL Data Compare API 12.0.40
UdtDependencyResult..::.UDTName Property
UdtDependencyResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UDTName As String
C#
public string UDTName { get; set; }
Visual C++
public:
property String^ UDTName {
    String^ get ();
    void set (String^ value);
}

See Also

UdtDependencyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


UDTOwner Property

[image]

SQL Data Compare API 12.0.40
UdtDependencyResult..::.UDTOwner Property
UdtDependencyResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UDTOwner As String
C#
public string UDTOwner { get; set; }
Visual C++
public:
property String^ UDTOwner {
    String^ get ();
    void set (String^ value);
}

See Also

UdtDependencyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


XmlCollectionDependencyResult Class

[image]

SQL Data Compare API 12.0.40
XmlCollectionDependencyResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlCollectionDependencyResult
C#
public class XmlCollectionDependencyResult
Visual C++
public ref class XmlCollectionDependencyResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.XmlCollectionDependencyResult

See Also

XmlCollectionDependencyResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


XmlCollectionDependencyResult Members

[image] [image]

SQL Data Compare API 12.0.40
XmlCollectionDependencyResult Members
XmlCollectionDependencyResult Class Constructors Methods Properties See Also

The XmlCollectionDependencyResult type exposes the following members.

Constructors

Name | Description
XmlCollectionDependencyResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ObjectID |
ObjectName |
ObjectSchema |
ObjectType |
XmlCollectionID |
XmlCollectionName |
XmlCollectionSchema |

See Also

XmlCollectionDependencyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


XmlCollectionDependencyResult Constructor

[image]

SQL Data Compare API 12.0.40
XmlCollectionDependencyResult Constructor
XmlCollectionDependencyResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public XmlCollectionDependencyResult()
Visual C++
public:
XmlCollectionDependencyResult()

See Also

XmlCollectionDependencyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


XmlCollectionDependencyResult Properties

[image] [image]

SQL Data Compare API 12.0.40
XmlCollectionDependencyResult Properties
XmlCollectionDependencyResult Class See Also

The XmlCollectionDependencyResult type exposes the following properties.

Properties

Name | Description
ObjectID |
ObjectName |
ObjectSchema |
ObjectType |
XmlCollectionID |
XmlCollectionName |
XmlCollectionSchema |

See Also

XmlCollectionDependencyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ObjectID Property

[image]

SQL Data Compare API 12.0.40
XmlCollectionDependencyResult..::.ObjectID Property
XmlCollectionDependencyResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectID As Integer
C#
public int ObjectID { get; set; }
Visual C++
public:
property int ObjectID {
    int get ();
    void set (int value);
}

See Also

XmlCollectionDependencyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ObjectName Property

[image]

SQL Data Compare API 12.0.40
XmlCollectionDependencyResult..::.ObjectName Property
XmlCollectionDependencyResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectName As String
C#
public string ObjectName { get; set; }
Visual C++
public:
property String^ ObjectName {
    String^ get ();
    void set (String^ value);
}

See Also

XmlCollectionDependencyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ObjectSchema Property

[image]

SQL Data Compare API 12.0.40
XmlCollectionDependencyResult..::.ObjectSchema Property
XmlCollectionDependencyResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectSchema As String
C#
public string ObjectSchema { get; set; }
Visual C++
public:
property String^ ObjectSchema {
    String^ get ();
    void set (String^ value);
}

See Also

XmlCollectionDependencyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ObjectType Property

[image]

SQL Data Compare API 12.0.40
XmlCollectionDependencyResult..::.ObjectType Property
XmlCollectionDependencyResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectType As String
C#
public string ObjectType { get; set; }
Visual C++
public:
property String^ ObjectType {
    String^ get ();
    void set (String^ value);
}

See Also

XmlCollectionDependencyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


XmlCollectionID Property

[image]

SQL Data Compare API 12.0.40
XmlCollectionDependencyResult..::.XmlCollectionID Property
XmlCollectionDependencyResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlCollectionID As Integer
C#
public int XmlCollectionID { get; set; }
Visual C++
public:
property int XmlCollectionID {
    int get ();
    void set (int value);
}

See Also

XmlCollectionDependencyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


XmlCollectionName Property

[image]

SQL Data Compare API 12.0.40
XmlCollectionDependencyResult..::.XmlCollectionName Property
XmlCollectionDependencyResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlCollectionName As String
C#
public string XmlCollectionName { get; set; }
Visual C++
public:
property String^ XmlCollectionName {
    String^ get ();
    void set (String^ value);
}

See Also

XmlCollectionDependencyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


XmlCollectionSchema Property

[image]

SQL Data Compare API 12.0.40
XmlCollectionDependencyResult..::.XmlCollectionSchema Property
XmlCollectionDependencyResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlCollectionSchema As String
C#
public string XmlCollectionSchema { get; set; }
Visual C++
public:
property String^ XmlCollectionSchema {
    String^ get ();
    void set (String^ value);
}

See Also

XmlCollectionDependencyResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


XmlCollectionResult Class

[image]

SQL Data Compare API 12.0.40
XmlCollectionResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlCollectionResult
C#
public class XmlCollectionResult
Visual C++
public ref class XmlCollectionResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult..::.XmlCollectionResult

See Also

XmlCollectionResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


XmlCollectionResult Members

[image] [image]

SQL Data Compare API 12.0.40
XmlCollectionResult Members
XmlCollectionResult Class Constructors Methods Properties See Also

The XmlCollectionResult type exposes the following members.

Constructors

Name | Description
XmlCollectionResult |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Document |
Name |
ObjectId |
Owner |
SchemaName |

See Also

XmlCollectionResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


XmlCollectionResult Constructor

[image]

SQL Data Compare API 12.0.40
XmlCollectionResult Constructor
XmlCollectionResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public XmlCollectionResult()
Visual C++
public:
XmlCollectionResult()

See Also

XmlCollectionResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


XmlCollectionResult Properties

[image] [image]

SQL Data Compare API 12.0.40
XmlCollectionResult Properties
XmlCollectionResult Class See Also

The XmlCollectionResult type exposes the following properties.

Properties

Name | Description
Document |
Name |
ObjectId |
Owner |
SchemaName |

See Also

XmlCollectionResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Document Property

[image]

SQL Data Compare API 12.0.40
XmlCollectionResult..::.Document Property
XmlCollectionResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Document As String
C#
public string Document { get; set; }
Visual C++
public:
property String^ Document {
    String^ get ();
    void set (String^ value);
}

See Also

XmlCollectionResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
XmlCollectionResult..::.Name Property
XmlCollectionResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

XmlCollectionResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


ObjectId Property

[image]

SQL Data Compare API 12.0.40
XmlCollectionResult..::.ObjectId Property
XmlCollectionResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectId As Integer
C#
public int ObjectId { get; set; }
Visual C++
public:
property int ObjectId {
    int get ();
    void set (int value);
}

See Also

XmlCollectionResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


Owner Property

[image]

SQL Data Compare API 12.0.40
XmlCollectionResult..::.Owner Property
XmlCollectionResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Owner As String
C#
public string Owner { get; set; }
Visual C++
public:
property String^ Owner {
    String^ get ();
    void set (String^ value);
}

See Also

XmlCollectionResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


SchemaName Property

[image]

SQL Data Compare API 12.0.40
XmlCollectionResult..::.SchemaName Property
XmlCollectionResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SchemaName As String
C#
public string SchemaName { get; set; }
Visual C++
public:
property String^ SchemaName {
    String^ get ();
    void set (String^ value);
}

See Also

XmlCollectionResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult Namespace


RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective Namespace

Classes

Class | Description
SelectiveXmlIndexNamespacesQueryResult |
SelectiveXmlIndexPathsQueryResult |


SelectiveXmlIndexNamespacesQueryResult Class

[image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexNamespacesQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SelectiveXmlIndexNamespacesQueryResult
C#
public class SelectiveXmlIndexNamespacesQueryResult
Visual C++
public ref class SelectiveXmlIndexNamespacesQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective..::.SelectiveXmlIndexNamespacesQueryResult

See Also

SelectiveXmlIndexNamespacesQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective Namespace


SelectiveXmlIndexNamespacesQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexNamespacesQueryResult Members
SelectiveXmlIndexNamespacesQueryResult Class Methods Properties See Also

The SelectiveXmlIndexNamespacesQueryResult type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IndexName |
Prefix |
Uri |

See Also

SelectiveXmlIndexNamespacesQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective Namespace


SelectiveXmlIndexNamespacesQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexNamespacesQueryResult Properties
SelectiveXmlIndexNamespacesQueryResult Class See Also

The SelectiveXmlIndexNamespacesQueryResult type exposes the following properties.

Properties

Name | Description
IndexName |
Prefix |
Uri |

See Also

SelectiveXmlIndexNamespacesQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective Namespace


IndexName Property

[image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexNamespacesQueryResult..::.IndexName Property
SelectiveXmlIndexNamespacesQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IndexName As String
C#
public string IndexName { get; private set; }
Visual C++
public:
property String^ IndexName {
    String^ get ();
    void set (String^ value);
}

See Also

SelectiveXmlIndexNamespacesQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective Namespace


Prefix Property

[image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexNamespacesQueryResult..::.Prefix Property
SelectiveXmlIndexNamespacesQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Prefix As String
C#
public string Prefix { get; private set; }
Visual C++
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}

See Also

SelectiveXmlIndexNamespacesQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective Namespace


Uri Property

[image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexNamespacesQueryResult..::.Uri Property
SelectiveXmlIndexNamespacesQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Uri As String
C#
public string Uri { get; private set; }
Visual C++
public:
property String^ Uri {
    String^ get ();
    void set (String^ value);
}

See Also

SelectiveXmlIndexNamespacesQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective Namespace


SelectiveXmlIndexPathsQueryResult Class

[image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexPathsQueryResult Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SelectiveXmlIndexPathsQueryResult
C#
public class SelectiveXmlIndexPathsQueryResult
Visual C++
public ref class SelectiveXmlIndexPathsQueryResult

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective..::.SelectiveXmlIndexPathsQueryResult

See Also

SelectiveXmlIndexPathsQueryResult Members
RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective Namespace


SelectiveXmlIndexPathsQueryResult Members

[image] [image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexPathsQueryResult Members
SelectiveXmlIndexPathsQueryResult Class Methods Properties See Also

The SelectiveXmlIndexPathsQueryResult type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DefinedLength |
IndexName |
IsNodeHint |
IsSingleton |
Path |
PathId |
PathName |
PathType |
Precision |
Scale |
SqlType |
XqueryMaxLength |
XqueryTypeDescription |

See Also

SelectiveXmlIndexPathsQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective Namespace


SelectiveXmlIndexPathsQueryResult Properties

[image] [image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexPathsQueryResult Properties
SelectiveXmlIndexPathsQueryResult Class See Also

The SelectiveXmlIndexPathsQueryResult type exposes the following properties.

Properties

Name | Description
DefinedLength |
IndexName |
IsNodeHint |
IsSingleton |
Path |
PathId |
PathName |
PathType |
Precision |
Scale |
SqlType |
XqueryMaxLength |
XqueryTypeDescription |

See Also

SelectiveXmlIndexPathsQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective Namespace


DefinedLength Property

[image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexPathsQueryResult..::.DefinedLength Property
SelectiveXmlIndexPathsQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefinedLength As Integer
C#
public int DefinedLength { get; private set; }
Visual C++
public:
property int DefinedLength {
    int get ();
    void set (int value);
}

See Also

SelectiveXmlIndexPathsQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective Namespace


IndexName Property

[image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexPathsQueryResult..::.IndexName Property
SelectiveXmlIndexPathsQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IndexName As String
C#
public string IndexName { get; private set; }
Visual C++
public:
property String^ IndexName {
    String^ get ();
    void set (String^ value);
}

See Also

SelectiveXmlIndexPathsQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective Namespace


IsNodeHint Property

[image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexPathsQueryResult..::.IsNodeHint Property
SelectiveXmlIndexPathsQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsNodeHint As Boolean
C#
public bool IsNodeHint { get; private set; }
Visual C++
public:
property bool IsNodeHint {
    bool get ();
    void set (bool value);
}

See Also

SelectiveXmlIndexPathsQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective Namespace


IsSingleton Property

[image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexPathsQueryResult..::.IsSingleton Property
SelectiveXmlIndexPathsQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSingleton As Boolean
C#
public bool IsSingleton { get; private set; }
Visual C++
public:
property bool IsSingleton {
    bool get ();
    void set (bool value);
}

See Also

SelectiveXmlIndexPathsQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective Namespace


Path Property

[image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexPathsQueryResult..::.Path Property
SelectiveXmlIndexPathsQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Path As String
C#
public string Path { get; private set; }
Visual C++
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

See Also

SelectiveXmlIndexPathsQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective Namespace


PathId Property

[image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexPathsQueryResult..::.PathId Property
SelectiveXmlIndexPathsQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PathId As Integer
C#
public int PathId { get; private set; }
Visual C++
public:
property int PathId {
    int get ();
    void set (int value);
}

See Also

SelectiveXmlIndexPathsQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective Namespace


PathName Property

[image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexPathsQueryResult..::.PathName Property
SelectiveXmlIndexPathsQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PathName As String
C#
public string PathName { get; private set; }
Visual C++
public:
property String^ PathName {
    String^ get ();
    void set (String^ value);
}

See Also

SelectiveXmlIndexPathsQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective Namespace


PathType Property

[image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexPathsQueryResult..::.PathType Property
SelectiveXmlIndexPathsQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PathType As Byte
C#
public byte PathType { get; private set; }
Visual C++
public:
property unsigned char PathType {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

SelectiveXmlIndexPathsQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective Namespace


Precision Property

[image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexPathsQueryResult..::.Precision Property
SelectiveXmlIndexPathsQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Precision As Integer
C#
public int Precision { get; private set; }
Visual C++
public:
property int Precision {
    int get ();
    void set (int value);
}

See Also

SelectiveXmlIndexPathsQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective Namespace


Scale Property

[image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexPathsQueryResult..::.Scale Property
SelectiveXmlIndexPathsQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Scale As Integer
C#
public int Scale { get; private set; }
Visual C++
public:
property int Scale {
    int get ();
    void set (int value);
}

See Also

SelectiveXmlIndexPathsQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective Namespace


SqlType Property

[image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexPathsQueryResult..::.SqlType Property
SelectiveXmlIndexPathsQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SqlType As String
C#
public string SqlType { get; private set; }
Visual C++
public:
property String^ SqlType {
    String^ get ();
    void set (String^ value);
}

See Also

SelectiveXmlIndexPathsQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective Namespace


XqueryMaxLength Property

[image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexPathsQueryResult..::.XqueryMaxLength Property
SelectiveXmlIndexPathsQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XqueryMaxLength As Integer
C#
public int XqueryMaxLength { get; private set; }
Visual C++
public:
property int XqueryMaxLength {
    int get ();
    void set (int value);
}

See Also

SelectiveXmlIndexPathsQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective Namespace


XqueryTypeDescription Property

[image]

SQL Data Compare API 12.0.40
SelectiveXmlIndexPathsQueryResult..::.XqueryTypeDescription Property
SelectiveXmlIndexPathsQueryResult Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XqueryTypeDescription As String
C#
public string XqueryTypeDescription { get; private set; }
Visual C++
public:
property String^ XqueryTypeDescription {
    String^ get ();
    void set (String^ value);
}

See Also

SelectiveXmlIndexPathsQueryResult Class
RedGate.SQLCompare.Engine.Registration.QueryResult.XmlIndexes.Selective Namespace


RedGate.SQLCompare.Engine.Registration.ReadFromBackup Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.Registration.ReadFromBackup Namespace

Classes

Class | Description
BackupUtils |


BackupUtils Class

[image]

SQL Data Compare API 12.0.40
BackupUtils Class
See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class BackupUtils
C#
public static class BackupUtils
Visual C++
public ref class BackupUtils abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.ReadFromBackup..::.BackupUtils

See Also

RedGate.SQLCompare.Engine.Registration.ReadFromBackup Namespace


RedGate.SQLCompare.Engine.Registration.ReadFromFolder Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.Registration.ReadFromFolder Namespace

Classes

Class | Description
FileInfoExtensions | Extension methods for FileInfo
FolderUtils |


FileInfoExtensions Class

[image]

SQL Data Compare API 12.0.40
FileInfoExtensions Class
Members See Also

Extension methods for FileInfo

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FileInfoExtensions
C#
public static class FileInfoExtensions
Visual C++
public ref class FileInfoExtensions abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.ReadFromFolder..::.FileInfoExtensions

See Also

FileInfoExtensions Members
RedGate.SQLCompare.Engine.Registration.ReadFromFolder Namespace


FileInfoExtensions Members

[image] [image]

SQL Data Compare API 12.0.40
FileInfoExtensions Members
FileInfoExtensions Class Methods See Also

The FileInfoExtensions type exposes the following members.

Methods

Name | Description
ReadAllText | Opens a text file, reads all lines of the file, and then closes the file.
WriteAllText | Creates a new file, writes the specified string to the file, and then closes the file. If the target file already exists, it is overwritten.

See Also

FileInfoExtensions Class
RedGate.SQLCompare.Engine.Registration.ReadFromFolder Namespace


FileInfoExtensions Methods

[image] [image]

SQL Data Compare API 12.0.40
FileInfoExtensions Methods
FileInfoExtensions Class See Also

The FileInfoExtensions type exposes the following methods.

Methods

Name | Description
ReadAllText | Opens a text file, reads all lines of the file, and then closes the file.
WriteAllText | Creates a new file, writes the specified string to the file, and then closes the file. If the target file already exists, it is overwritten.

See Also

FileInfoExtensions Class
RedGate.SQLCompare.Engine.Registration.ReadFromFolder Namespace


ReadAllText Method

[image]

SQL Data Compare API 12.0.40
FileInfoExtensions..::.ReadAllText Method
FileInfoExtensions Class See Also

Opens a text file, reads all lines of the file, and then closes the file.

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ReadAllText ( _
    file As FileInfo _
) As String
C#
public static string ReadAllText(
    FileInfo file
)
Visual C++
public:
static String^ ReadAllText(
    FileInfo^ file
)

Parameters

file
Type: FileInfo

See Also

FileInfoExtensions Class
RedGate.SQLCompare.Engine.Registration.ReadFromFolder Namespace


WriteAllText Method

[image]

SQL Data Compare API 12.0.40
FileInfoExtensions..::.WriteAllText Method
FileInfoExtensions Class See Also

Creates a new file, writes the specified string to the file, and then closes the file. If the target file already exists, it is overwritten.

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteAllText ( _
    file As FileInfo, _
    contents As String _
)
C#
public static void WriteAllText(
    FileInfo file,
    string contents
)
Visual C++
public:
static void WriteAllText(
    FileInfo^ file,
    String^ contents
)

Parameters

file
Type: FileInfo
contents
Type: String

See Also

FileInfoExtensions Class
RedGate.SQLCompare.Engine.Registration.ReadFromFolder Namespace


FolderUtils Class

[image]

SQL Data Compare API 12.0.40
FolderUtils Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FolderUtils
C#
public static class FolderUtils
Visual C++
public ref class FolderUtils abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.ReadFromFolder..::.FolderUtils

See Also

FolderUtils Members
RedGate.SQLCompare.Engine.Registration.ReadFromFolder Namespace


FolderUtils Members

[image] [image]

SQL Data Compare API 12.0.40
FolderUtils Members
FolderUtils Class Methods See Also

The FolderUtils type exposes the following members.

Methods

Name | Description
GetDatabaseInfoFileAtributes | Throws an exception if the file to be written doesn't exist
GetDatabaseInfoFileNameToWrite |
GetDatabaseInformationFileNameToRead |
TryGetInformationFromXmlFile | Given a TextReader for an XML file, returns a database information object.
TryLoadDatabaseProject | Load a ScriptDatabaseInformation object
TryLoadScriptDatabaseInfomation | Load a ScriptDatabaseInformation object
WillWriteNewDBInfoFileReplacingOld | For internal use only
WriteDatabaseInformationFile | Write a ScriptDatabaseInformation object to the folder specified. Will throw an IO exception if it can't save the file

See Also

FolderUtils Class
RedGate.SQLCompare.Engine.Registration.ReadFromFolder Namespace


FolderUtils Methods

[image] [image]

SQL Data Compare API 12.0.40
FolderUtils Methods
FolderUtils Class See Also

The FolderUtils type exposes the following methods.

Methods

Name | Description
GetDatabaseInfoFileAtributes | Throws an exception if the file to be written doesn't exist
GetDatabaseInfoFileNameToWrite |
GetDatabaseInformationFileNameToRead |
TryGetInformationFromXmlFile | Given a TextReader for an XML file, returns a database information object.
TryLoadDatabaseProject | Load a ScriptDatabaseInformation object
TryLoadScriptDatabaseInfomation | Load a ScriptDatabaseInformation object
WillWriteNewDBInfoFileReplacingOld | For internal use only
WriteDatabaseInformationFile | Write a ScriptDatabaseInformation object to the folder specified. Will throw an IO exception if it can't save the file

See Also

FolderUtils Class
RedGate.SQLCompare.Engine.Registration.ReadFromFolder Namespace


GetDatabaseInfoFileAtributes Method

[image]

SQL Data Compare API 12.0.40
FolderUtils..::.GetDatabaseInfoFileAtributes Method
FolderUtils Class See Also

Throws an exception if the file to be written doesn't exist

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDatabaseInfoFileAtributes ( _
    folderPath As String _
) As FileAttributes
C#
public static FileAttributes GetDatabaseInfoFileAtributes(
    string folderPath
)
Visual C++
public:
static FileAttributes GetDatabaseInfoFileAtributes(
    String^ folderPath
)

Parameters

folderPath
Type: String

Return Value

Attributes of the ScriptDatabaseInformation

See Also

FolderUtils Class
RedGate.SQLCompare.Engine.Registration.ReadFromFolder Namespace


GetDatabaseInfoFileNameToWrite Method

[image]

SQL Data Compare API 12.0.40
FolderUtils..::.GetDatabaseInfoFileNameToWrite Method
FolderUtils Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDatabaseInfoFileNameToWrite ( _
    folderPath As String _
) As String
C#
public static string GetDatabaseInfoFileNameToWrite(
    string folderPath
)
Visual C++
public:
static String^ GetDatabaseInfoFileNameToWrite(
    String^ folderPath
)

Parameters

folderPath
Type: String

Return Value

The path that the xml file should be written out with

See Also

FolderUtils Class
RedGate.SQLCompare.Engine.Registration.ReadFromFolder Namespace


GetDatabaseInformationFileNameToRead Method

[image]

SQL Data Compare API 12.0.40
FolderUtils..::.GetDatabaseInformationFileNameToRead Method
FolderUtils Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDatabaseInformationFileNameToRead ( _
    folderPath As String _
) As String
C#
public static string GetDatabaseInformationFileNameToRead(
    string folderPath
)
Visual C++
public:
static String^ GetDatabaseInformationFileNameToRead(
    String^ folderPath
)

Parameters

folderPath
Type: String

Return Value

Returns the ScriptDatabaseInformation filename in the folderPath, or null if none exist.

See Also

FolderUtils Class
RedGate.SQLCompare.Engine.Registration.ReadFromFolder Namespace


TryGetInformationFromXmlFile Method

[image]

SQL Data Compare API 12.0.40
FolderUtils..::.TryGetInformationFromXmlFile Method
FolderUtils Class See Also

Given a TextReader for an XML file, returns a database information object.

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function TryGetInformationFromXmlFile ( _
    file As TextReader, _
    <OutAttribute> ByRef info As ScriptDatabaseInformation, _
    <OutAttribute> ByRef errors As FolderInformationErrors _
) As Boolean
C#
public static bool TryGetInformationFromXmlFile(
    TextReader file,
    out ScriptDatabaseInformation info,
    out FolderInformationErrors errors
)
Visual C++
public:
static bool TryGetInformationFromXmlFile(
    TextReader^ file,
    [OutAttribute] ScriptDatabaseInformation^% info,
    [OutAttribute] FolderInformationErrors% errors
)

Parameters

file
Type: TextReader
A TextReader for an XML file representing database metadata.
info
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation %
errors
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.FolderInformationErrors %
Changed on output to indicate any errors or warnings that might have occurred while the file was loaded.

Return Value

True if errors does not contain an error (only warning or OK)

See Also

FolderUtils Class
RedGate.SQLCompare.Engine.Registration.ReadFromFolder Namespace


TryLoadDatabaseProject Method

[image]

SQL Data Compare API 12.0.40
FolderUtils..::.TryLoadDatabaseProject Method
FolderUtils Class See Also

Load a ScriptDatabaseInformation object

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function TryLoadDatabaseProject ( _
    folderPath As String, _
    <OutAttribute> ByRef databaseInformation As IDatabaseProject _
) As Boolean
C#
public static bool TryLoadDatabaseProject(
    string folderPath,
    out IDatabaseProject databaseInformation
)
Visual C++
public:
static bool TryLoadDatabaseProject(
    String^ folderPath,
    [OutAttribute] IDatabaseProject^% databaseInformation
)

Parameters

folderPath
Type: String
Path to load from
databaseInformation
Type: RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject..::.IDatabaseProject %
If return value is true, this holds the IDatabaseProject

Return Value

True iff the a database information file exists.

See Also

FolderUtils Class
RedGate.SQLCompare.Engine.Registration.ReadFromFolder Namespace


TryLoadScriptDatabaseInfomation Method

[image]

SQL Data Compare API 12.0.40
FolderUtils..::.TryLoadScriptDatabaseInfomation Method
FolderUtils Class See Also

Load a ScriptDatabaseInformation object

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function TryLoadScriptDatabaseInfomation ( _
    folderPath As String, _
    <OutAttribute> ByRef databaseInformation As ScriptDatabaseInformation, _
    <OutAttribute> ByRef errors As FolderInformationErrors _
) As Boolean
C#
public static bool TryLoadScriptDatabaseInfomation(
    string folderPath,
    out ScriptDatabaseInformation databaseInformation,
    out FolderInformationErrors errors
)
Visual C++
public:
static bool TryLoadScriptDatabaseInfomation(
    String^ folderPath,
    [OutAttribute] ScriptDatabaseInformation^% databaseInformation,
    [OutAttribute] FolderInformationErrors% errors
)

Parameters

folderPath
Type: String
Path to load from
databaseInformation
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation %
If return value is true, this holds the ScriptDatabaseInformation
errors
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.FolderInformationErrors %
Loading errors

Return Value

True iff the a database information file exists.

See Also

FolderUtils Class
RedGate.SQLCompare.Engine.Registration.ReadFromFolder Namespace


WillWriteNewDBInfoFileReplacingOld Method

[image]

SQL Data Compare API 12.0.40
FolderUtils..::.WillWriteNewDBInfoFileReplacingOld Method
FolderUtils Class See Also

For internal use only

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function WillWriteNewDBInfoFileReplacingOld ( _
    path As String _
) As Boolean
C#
public static bool WillWriteNewDBInfoFileReplacingOld(
    string path
)
Visual C++
public:
static bool WillWriteNewDBInfoFileReplacingOld(
    String^ path
)

Parameters

path
Type: String

See Also

FolderUtils Class
RedGate.SQLCompare.Engine.Registration.ReadFromFolder Namespace


WriteDatabaseInformationFile Method

[image]

SQL Data Compare API 12.0.40
FolderUtils..::.WriteDatabaseInformationFile Method
FolderUtils Class See Also

Write a ScriptDatabaseInformation object to the folder specified. Will throw an IO exception if it can't save the file

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteDatabaseInformationFile ( _
    sdi As ScriptDatabaseInformation, _
    folderPath As String _
)
C#
public static void WriteDatabaseInformationFile(
    ScriptDatabaseInformation sdi,
    string folderPath
)
Visual C++
public:
static void WriteDatabaseInformationFile(
    ScriptDatabaseInformation^ sdi,
    String^ folderPath
)

Parameters

sdi
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
ScriptDatabaseInformation to save
folderPath
Type: String
Location to save to

See Also

FolderUtils Class
RedGate.SQLCompare.Engine.Registration.ReadFromFolder Namespace


RedGate.SQLCompare.Engine.Registration.ReadFromSnapshot Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.Registration.ReadFromSnapshot Namespace

Classes

Class | Description
DatabaseFromSnapshot |
SecurityPolicyCollectionExtensions | Handles writing collection of security policies to a snapshot file
UnsupportedSnapshotException | An exception thrown when a snapshot is unsupported.


DatabaseFromSnapshot Class

[image]

SQL Data Compare API 12.0.40
DatabaseFromSnapshot Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSnapshot
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class DatabaseFromSnapshot
C#
public class DatabaseFromSnapshot
Visual C++
public ref class DatabaseFromSnapshot

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.ReadFromSnapshot..::.DatabaseFromSnapshot

See Also

DatabaseFromSnapshot Members
RedGate.SQLCompare.Engine.Registration.ReadFromSnapshot Namespace


DatabaseFromSnapshot Members

[image] [image]

SQL Data Compare API 12.0.40
DatabaseFromSnapshot Members
DatabaseFromSnapshot Class Constructors Methods See Also

The DatabaseFromSnapshot type exposes the following members.

Constructors

Name | Description
DatabaseFromSnapshot |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConnectionPropertiesFromFile | Reads connection properties from a file.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseFromSnapshot Class
RedGate.SQLCompare.Engine.Registration.ReadFromSnapshot Namespace


DatabaseFromSnapshot Constructor

[image]

SQL Data Compare API 12.0.40
DatabaseFromSnapshot Constructor
DatabaseFromSnapshot Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSnapshot
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DatabaseFromSnapshot()
Visual C++
public:
DatabaseFromSnapshot()

See Also

DatabaseFromSnapshot Class
RedGate.SQLCompare.Engine.Registration.ReadFromSnapshot Namespace


DatabaseFromSnapshot Methods

[image] [image]

SQL Data Compare API 12.0.40
DatabaseFromSnapshot Methods
DatabaseFromSnapshot Class See Also

The DatabaseFromSnapshot type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConnectionPropertiesFromFile | Reads connection properties from a file.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseFromSnapshot Class
RedGate.SQLCompare.Engine.Registration.ReadFromSnapshot Namespace


GetConnectionPropertiesFromFile Method

[image]

SQL Data Compare API 12.0.40
DatabaseFromSnapshot..::.GetConnectionPropertiesFromFile Method
DatabaseFromSnapshot Class See Also

Reads connection properties from a file.

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSnapshot
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetConnectionPropertiesFromFile ( _
    fileName As String _
) As ConnectionProperties
C#
public static ConnectionProperties GetConnectionPropertiesFromFile(
    string fileName
)
Visual C++
public:
static ConnectionProperties^ GetConnectionPropertiesFromFile(
    String^ fileName
)

Parameters

fileName
Type: String
The name of a .scdb file.

Return Value

Connection properties.

Remarks

Provides a way to retrieve SQL Server name, Database name, and other connection information from a .snp file without loading the file.

See Also

DatabaseFromSnapshot Class
RedGate.SQLCompare.Engine.Registration.ReadFromSnapshot Namespace


SecurityPolicyCollectionExtensions Class

[image]

SQL Data Compare API 12.0.40
SecurityPolicyCollectionExtensions Class
Members See Also

Handles writing collection of security policies to a snapshot file

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSnapshot
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SecurityPolicyCollectionExtensions
C#
public static class SecurityPolicyCollectionExtensions
Visual C++
public ref class SecurityPolicyCollectionExtensions abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.ReadFromSnapshot..::.SecurityPolicyCollectionExtensions

See Also

SecurityPolicyCollectionExtensions Members
RedGate.SQLCompare.Engine.Registration.ReadFromSnapshot Namespace


SecurityPolicyCollectionExtensions Members

[image] [image]

SQL Data Compare API 12.0.40
SecurityPolicyCollectionExtensions Members
SecurityPolicyCollectionExtensions Class Methods See Also

The SecurityPolicyCollectionExtensions type exposes the following members.

Methods

Name | Description
Serialize | Write details for securityPolicies into writer.

See Also

SecurityPolicyCollectionExtensions Class
RedGate.SQLCompare.Engine.Registration.ReadFromSnapshot Namespace


SecurityPolicyCollectionExtensions Methods

[image] [image]

SQL Data Compare API 12.0.40
SecurityPolicyCollectionExtensions Methods
SecurityPolicyCollectionExtensions Class See Also

The SecurityPolicyCollectionExtensions type exposes the following methods.

Methods

Name | Description
Serialize | Write details for securityPolicies into writer.

See Also

SecurityPolicyCollectionExtensions Class
RedGate.SQLCompare.Engine.Registration.ReadFromSnapshot Namespace


Serialize Method

[image]

SQL Data Compare API 12.0.40
SecurityPolicyCollectionExtensions..::.Serialize Method
SecurityPolicyCollectionExtensions Class See Also

Write details for securityPolicies into writer.

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSnapshot
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Serialize ( _
    securityPolicies As DatabaseObjectCollection(Of SecurityPolicy), _
    writer As NullableBinaryWriter _
)
C#
public static void Serialize(
    DatabaseObjectCollection<SecurityPolicy> securityPolicies,
    NullableBinaryWriter writer
)
Visual C++
public:
static void Serialize(
    DatabaseObjectCollection<SecurityPolicy^>^ securityPolicies,
    NullableBinaryWriter^ writer
)

Parameters

securityPolicies
Type: RedGate.SQLCompare.Engine..::.DatabaseObjectCollection <(Of <( SecurityPolicy >)>)
writer
Type: NullableBinaryWriter

See Also

SecurityPolicyCollectionExtensions Class
RedGate.SQLCompare.Engine.Registration.ReadFromSnapshot Namespace


UnsupportedSnapshotException Class

[image]

SQL Data Compare API 12.0.40
UnsupportedSnapshotException Class
Members See Also

An exception thrown when a snapshot is unsupported.

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSnapshot
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class UnsupportedSnapshotException _
    Inherits Exception
C#
public class UnsupportedSnapshotException : Exception
Visual C++
public ref class UnsupportedSnapshotException : public Exception

Inheritance Hierarchy

Object
Exception
RedGate.SQLCompare.Engine.Registration.ReadFromSnapshot..::.UnsupportedSnapshotException

See Also

UnsupportedSnapshotException Members
RedGate.SQLCompare.Engine.Registration.ReadFromSnapshot Namespace


UnsupportedSnapshotException Members

[image] [image]

SQL Data Compare API 12.0.40
UnsupportedSnapshotException Members
UnsupportedSnapshotException Class Constructors Methods Properties See Also

The UnsupportedSnapshotException type exposes the following members.

Constructors

Name | Description
UnsupportedSnapshotException |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

UnsupportedSnapshotException Class
RedGate.SQLCompare.Engine.Registration.ReadFromSnapshot Namespace


UnsupportedSnapshotException Constructor

[image]

SQL Data Compare API 12.0.40
UnsupportedSnapshotException Constructor
UnsupportedSnapshotException Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSnapshot
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public UnsupportedSnapshotException(
    string message
)
Visual C++
public:
UnsupportedSnapshotException(
    String^ message
)

Parameters

message
Type: String

See Also

UnsupportedSnapshotException Class
RedGate.SQLCompare.Engine.Registration.ReadFromSnapshot Namespace


RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental Namespace

Classes

Class | Description
DmvResultMergeException | Thrown when the new DMV query results can't be merged with the cached results.
IncrementalDmvModelFactory | Keeps track of the DmvCaches for each database, and creates IncrementalDmvModel which use those caches.
LastCacheInvalidationDateQuery | Queries the database to get the latest date from: the last restore, the create date


DmvResultMergeException Class

[image]

SQL Data Compare API 12.0.40
DmvResultMergeException Class
Members See Also

Thrown when the new DMV query results can't be merged with the cached results.

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class DmvResultMergeException _
    Inherits Exception
C#
public class DmvResultMergeException : Exception
Visual C++
public ref class DmvResultMergeException : public Exception

Inheritance Hierarchy

Object
Exception
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental..::.DmvResultMergeException

See Also

DmvResultMergeException Members
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental Namespace


DmvResultMergeException Members

[image] [image]

SQL Data Compare API 12.0.40
DmvResultMergeException Members
DmvResultMergeException Class Constructors Methods Properties See Also

The DmvResultMergeException type exposes the following members.

Constructors

Name | Description
DmvResultMergeException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DmvResultMergeException Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental Namespace


DmvResultMergeException Constructor

[image] [image]

SQL Data Compare API 12.0.40
DmvResultMergeException Constructor
DmvResultMergeException Class See Also

Overload List

Name | Description
DmvResultMergeException()()() |
DmvResultMergeException(String) |
DmvResultMergeException(SerializationInfo, StreamingContext) |
DmvResultMergeException(String, Exception) |

See Also

DmvResultMergeException Class
DmvResultMergeException Members
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental Namespace


DmvResultMergeException Constructor

[image]

SQL Data Compare API 12.0.40
DmvResultMergeException Constructor
DmvResultMergeException Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DmvResultMergeException()
Visual C++
public:
DmvResultMergeException()

See Also

DmvResultMergeException Class
DmvResultMergeException Overload
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental Namespace


DmvResultMergeException Constructor ()

[image]

SQL Data Compare API 12.0.40
DmvResultMergeException Constructor ()
DmvResultMergeException Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public DmvResultMergeException(
    string message
)
Visual C++
public:
DmvResultMergeException(
    String^ message
)

Parameters

message
Type: String

See Also

DmvResultMergeException Class
DmvResultMergeException Overload
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental Namespace


DmvResultMergeException Constructor (, )

[image]

SQL Data Compare API 12.0.40
DmvResultMergeException Constructor (, )
DmvResultMergeException Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
public DmvResultMergeException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
public:
DmvResultMergeException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: SerializationInfo
context
Type: StreamingContext

See Also

DmvResultMergeException Class
DmvResultMergeException Overload
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental Namespace


DmvResultMergeException Constructor (, )

[image]

SQL Data Compare API 12.0.40
DmvResultMergeException Constructor (, )
DmvResultMergeException Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
C#
public DmvResultMergeException(
    string message,
    Exception innerException
)
Visual C++
public:
DmvResultMergeException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: String
innerException
Type: Exception

See Also

DmvResultMergeException Class
DmvResultMergeException Overload
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental Namespace


IncrementalDmvModelFactory Class

[image]

SQL Data Compare API 12.0.40
IncrementalDmvModelFactory Class
Members See Also

Keeps track of the DmvCaches for each database, and creates IncrementalDmvModel which use those caches.

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class IncrementalDmvModelFactory _
    Implements IDmvModelFactory
C#
public class IncrementalDmvModelFactory : IDmvModelFactory
Visual C++
public ref class IncrementalDmvModelFactory : IDmvModelFactory

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental..::.IncrementalDmvModelFactory

See Also

IncrementalDmvModelFactory Members
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental Namespace


IncrementalDmvModelFactory Members

[image] [image]

SQL Data Compare API 12.0.40
IncrementalDmvModelFactory Members
IncrementalDmvModelFactory Class Constructors Methods See Also

The IncrementalDmvModelFactory type exposes the following members.

Constructors

Name | Description
IncrementalDmvModelFactory |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromConnectionProperties |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IncrementalDmvModelFactory Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental Namespace


IncrementalDmvModelFactory Constructor

[image]

SQL Data Compare API 12.0.40
IncrementalDmvModelFactory Constructor
IncrementalDmvModelFactory Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    cacheFolder As String _
)
C#
public IncrementalDmvModelFactory(
    string cacheFolder
)
Visual C++
public:
IncrementalDmvModelFactory(
    String^ cacheFolder
)

Parameters

cacheFolder
Type: String

See Also

IncrementalDmvModelFactory Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental Namespace


IncrementalDmvModelFactory Methods

[image] [image]

SQL Data Compare API 12.0.40
IncrementalDmvModelFactory Methods
IncrementalDmvModelFactory Class See Also

The IncrementalDmvModelFactory type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromConnectionProperties |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IncrementalDmvModelFactory Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental Namespace


FromConnectionProperties Method

[image]

SQL Data Compare API 12.0.40
IncrementalDmvModelFactory..::.FromConnectionProperties Method
IncrementalDmvModelFactory Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function FromConnectionProperties ( _
    connProp As ConnectionProperties, _
    options As Options, _
    cancellationStatus As ICancellationStatus, _
    temporaryFileManager As ITemporaryFileManager _
) As IDmvModel
C#
public IDmvModel FromConnectionProperties(
    ConnectionProperties connProp,
    Options options,
    ICancellationStatus cancellationStatus,
    ITemporaryFileManager temporaryFileManager
)
Visual C++
public:
virtual IDmvModel^ FromConnectionProperties(
    ConnectionProperties^ connProp,
    Options options,
    ICancellationStatus^ cancellationStatus,
    ITemporaryFileManager^ temporaryFileManager
) sealed

Parameters

connProp
Type: RedGate.SQLCompare.Engine..::.ConnectionProperties
options
Type: RedGate.SQLCompare.Engine..::.Options
cancellationStatus
Type: RedGate.SQLCompare.Engine..::.ICancellationStatus
temporaryFileManager
Type: ITemporaryFileManager

Implements

IDmvModelFactory..::.FromConnectionProperties(ConnectionProperties, Options, ICancellationStatus, ITemporaryFileManager)

See Also

IncrementalDmvModelFactory Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental Namespace


LastCacheInvalidationDateQuery Class

[image]

SQL Data Compare API 12.0.40
LastCacheInvalidationDateQuery Class
Members See Also

Queries the database to get the latest date from: the last restore, the create date

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class LastCacheInvalidationDateQuery
C#
public class LastCacheInvalidationDateQuery
Visual C++
public ref class LastCacheInvalidationDateQuery

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental..::.LastCacheInvalidationDateQuery

See Also

LastCacheInvalidationDateQuery Members
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental Namespace


LastCacheInvalidationDateQuery Members

[image] [image]

SQL Data Compare API 12.0.40
LastCacheInvalidationDateQuery Members
LastCacheInvalidationDateQuery Class Constructors Methods See Also

The LastCacheInvalidationDateQuery type exposes the following members.

Constructors

Name | Description
LastCacheInvalidationDateQuery |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLastCacheInvalidationDateFor |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LastCacheInvalidationDateQuery Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental Namespace


LastCacheInvalidationDateQuery Constructor

[image]

SQL Data Compare API 12.0.40
LastCacheInvalidationDateQuery Constructor
LastCacheInvalidationDateQuery Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LastCacheInvalidationDateQuery()
Visual C++
public:
LastCacheInvalidationDateQuery()

See Also

LastCacheInvalidationDateQuery Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental Namespace


LastCacheInvalidationDateQuery Methods

[image] [image]

SQL Data Compare API 12.0.40
LastCacheInvalidationDateQuery Methods
LastCacheInvalidationDateQuery Class See Also

The LastCacheInvalidationDateQuery type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLastCacheInvalidationDateFor |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LastCacheInvalidationDateQuery Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental Namespace


GetLastCacheInvalidationDateFor Method

[image]

SQL Data Compare API 12.0.40
LastCacheInvalidationDateQuery..::.GetLastCacheInvalidationDateFor Method
LastCacheInvalidationDateQuery Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLastCacheInvalidationDateFor ( _
    connection As SqlConnection _
) As DateTime
C#
public DateTime GetLastCacheInvalidationDateFor(
    SqlConnection connection
)
Visual C++
public:
virtual DateTime GetLastCacheInvalidationDateFor(
    SqlConnection^ connection
) sealed

Parameters

connection
Type: SqlConnection

See Also

LastCacheInvalidationDateQuery Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental Namespace


RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace

Classes

Class | Description
CommentQueryResultSerializer | Serializer/deserializer for CommentQueryResult.
FieldQueryResultSerializer | Serializer/deserializer for CommentQueryResult.
SqlProcedureResultSerializer | Serializer/deserializer for CommentQueryResult.
ViewColumnWithDetailsQueryResultSerializer | Serializer/deserializer for SqlViewColumnWithDetailsResult.


CommentQueryResultSerializer Class

[image]

SQL Data Compare API 12.0.40
CommentQueryResultSerializer Class
Members See Also

Serializer/deserializer for CommentQueryResult.

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class CommentQueryResultSerializer
C#
public class CommentQueryResultSerializer
Visual C++
public ref class CommentQueryResultSerializer

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers..::.CommentQueryResultSerializer

See Also

CommentQueryResultSerializer Members
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


CommentQueryResultSerializer Members

[image] [image]

SQL Data Compare API 12.0.40
CommentQueryResultSerializer Members
CommentQueryResultSerializer Class Constructors Methods Properties See Also

The CommentQueryResultSerializer type exposes the following members.

Constructors

Name | Description
CommentQueryResultSerializer |

Methods

Name | Description
Deserialize |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Version |

See Also

CommentQueryResultSerializer Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


CommentQueryResultSerializer Constructor

[image]

SQL Data Compare API 12.0.40
CommentQueryResultSerializer Constructor
CommentQueryResultSerializer Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CommentQueryResultSerializer()
Visual C++
public:
CommentQueryResultSerializer()

See Also

CommentQueryResultSerializer Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


CommentQueryResultSerializer Methods

[image] [image]

SQL Data Compare API 12.0.40
CommentQueryResultSerializer Methods
CommentQueryResultSerializer Class See Also

The CommentQueryResultSerializer type exposes the following methods.

Methods

Name | Description
Deserialize |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CommentQueryResultSerializer Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


Deserialize Method

[image]

SQL Data Compare API 12.0.40
CommentQueryResultSerializer..::.Deserialize Method
CommentQueryResultSerializer Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Deserialize ( _
    reader As NullableBinaryReader _
) As CommentQueryResult
C#
public CommentQueryResult Deserialize(
    NullableBinaryReader reader
)
Visual C++
public:
virtual CommentQueryResult^ Deserialize(
    NullableBinaryReader^ reader
) sealed

Parameters

reader
Type: NullableBinaryReader

See Also

CommentQueryResultSerializer Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


Serialize Method

[image]

SQL Data Compare API 12.0.40
CommentQueryResultSerializer..::.Serialize Method
CommentQueryResultSerializer Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Serialize ( _
    writer As NullableBinaryWriter, _
    queryResult As CommentQueryResult _
)
C#
public void Serialize(
    NullableBinaryWriter writer,
    CommentQueryResult queryResult
)
Visual C++
public:
virtual void Serialize(
    NullableBinaryWriter^ writer,
    CommentQueryResult^ queryResult
) sealed

Parameters

writer
Type: NullableBinaryWriter
queryResult
Type: RedGate.SQLCompare.Engine.Registration.QueryResult..::.CommentQueryResult

See Also

CommentQueryResultSerializer Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


CommentQueryResultSerializer Properties

[image] [image]

SQL Data Compare API 12.0.40
CommentQueryResultSerializer Properties
CommentQueryResultSerializer Class See Also

The CommentQueryResultSerializer type exposes the following properties.

Properties

Name | Description
Version |

See Also

CommentQueryResultSerializer Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


Version Property

[image]

SQL Data Compare API 12.0.40
CommentQueryResultSerializer..::.Version Property
CommentQueryResultSerializer Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As Integer
C#
public int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () sealed;
}

See Also

CommentQueryResultSerializer Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


FieldQueryResultSerializer Class

[image]

SQL Data Compare API 12.0.40
FieldQueryResultSerializer Class
Members See Also

Serializer/deserializer for CommentQueryResult.

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class FieldQueryResultSerializer
C#
public class FieldQueryResultSerializer
Visual C++
public ref class FieldQueryResultSerializer

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers..::.FieldQueryResultSerializer

See Also

FieldQueryResultSerializer Members
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


FieldQueryResultSerializer Members

[image] [image]

SQL Data Compare API 12.0.40
FieldQueryResultSerializer Members
FieldQueryResultSerializer Class Constructors Methods Properties See Also

The FieldQueryResultSerializer type exposes the following members.

Constructors

Name | Description
FieldQueryResultSerializer |

Methods

Name | Description
Deserialize |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Version |

See Also

FieldQueryResultSerializer Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


FieldQueryResultSerializer Constructor

[image]

SQL Data Compare API 12.0.40
FieldQueryResultSerializer Constructor
FieldQueryResultSerializer Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FieldQueryResultSerializer()
Visual C++
public:
FieldQueryResultSerializer()

See Also

FieldQueryResultSerializer Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


FieldQueryResultSerializer Methods

[image] [image]

SQL Data Compare API 12.0.40
FieldQueryResultSerializer Methods
FieldQueryResultSerializer Class See Also

The FieldQueryResultSerializer type exposes the following methods.

Methods

Name | Description
Deserialize |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldQueryResultSerializer Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


Deserialize Method

[image]

SQL Data Compare API 12.0.40
FieldQueryResultSerializer..::.Deserialize Method
FieldQueryResultSerializer Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Deserialize ( _
    reader As NullableBinaryReader _
) As FieldQueryResult
C#
public FieldQueryResult Deserialize(
    NullableBinaryReader reader
)
Visual C++
public:
virtual FieldQueryResult^ Deserialize(
    NullableBinaryReader^ reader
) sealed

Parameters

reader
Type: NullableBinaryReader

See Also

FieldQueryResultSerializer Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


Serialize Method

[image]

SQL Data Compare API 12.0.40
FieldQueryResultSerializer..::.Serialize Method
FieldQueryResultSerializer Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Serialize ( _
    writer As NullableBinaryWriter, _
    queryResult As FieldQueryResult _
)
C#
public void Serialize(
    NullableBinaryWriter writer,
    FieldQueryResult queryResult
)
Visual C++
public:
virtual void Serialize(
    NullableBinaryWriter^ writer,
    FieldQueryResult^ queryResult
) sealed

Parameters

writer
Type: NullableBinaryWriter
queryResult
Type: RedGate.SQLCompare.Engine.Registration.QueryResult..::.FieldQueryResult

See Also

FieldQueryResultSerializer Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


FieldQueryResultSerializer Properties

[image] [image]

SQL Data Compare API 12.0.40
FieldQueryResultSerializer Properties
FieldQueryResultSerializer Class See Also

The FieldQueryResultSerializer type exposes the following properties.

Properties

Name | Description
Version |

See Also

FieldQueryResultSerializer Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


Version Property

[image]

SQL Data Compare API 12.0.40
FieldQueryResultSerializer..::.Version Property
FieldQueryResultSerializer Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As Integer
C#
public int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () sealed;
}

See Also

FieldQueryResultSerializer Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


SqlProcedureResultSerializer Class

[image]

SQL Data Compare API 12.0.40
SqlProcedureResultSerializer Class
Members See Also

Serializer/deserializer for CommentQueryResult.

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlProcedureResultSerializer
C#
public class SqlProcedureResultSerializer
Visual C++
public ref class SqlProcedureResultSerializer

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers..::.SqlProcedureResultSerializer

See Also

SqlProcedureResultSerializer Members
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


SqlProcedureResultSerializer Members

[image] [image]

SQL Data Compare API 12.0.40
SqlProcedureResultSerializer Members
SqlProcedureResultSerializer Class Constructors Methods Properties See Also

The SqlProcedureResultSerializer type exposes the following members.

Constructors

Name | Description
SqlProcedureResultSerializer |

Methods

Name | Description
Deserialize |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Version |

See Also

SqlProcedureResultSerializer Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


SqlProcedureResultSerializer Constructor

[image]

SQL Data Compare API 12.0.40
SqlProcedureResultSerializer Constructor
SqlProcedureResultSerializer Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlProcedureResultSerializer()
Visual C++
public:
SqlProcedureResultSerializer()

See Also

SqlProcedureResultSerializer Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


SqlProcedureResultSerializer Methods

[image] [image]

SQL Data Compare API 12.0.40
SqlProcedureResultSerializer Methods
SqlProcedureResultSerializer Class See Also

The SqlProcedureResultSerializer type exposes the following methods.

Methods

Name | Description
Deserialize |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlProcedureResultSerializer Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


Deserialize Method

[image]

SQL Data Compare API 12.0.40
SqlProcedureResultSerializer..::.Deserialize Method
SqlProcedureResultSerializer Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Deserialize ( _
    reader As NullableBinaryReader _
) As SqlProcedureResult
C#
public SqlProcedureResult Deserialize(
    NullableBinaryReader reader
)
Visual C++
public:
virtual SqlProcedureResult^ Deserialize(
    NullableBinaryReader^ reader
) sealed

Parameters

reader
Type: NullableBinaryReader

See Also

SqlProcedureResultSerializer Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


Serialize Method

[image]

SQL Data Compare API 12.0.40
SqlProcedureResultSerializer..::.Serialize Method
SqlProcedureResultSerializer Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Serialize ( _
    writer As NullableBinaryWriter, _
    queryResult As SqlProcedureResult _
)
C#
public void Serialize(
    NullableBinaryWriter writer,
    SqlProcedureResult queryResult
)
Visual C++
public:
virtual void Serialize(
    NullableBinaryWriter^ writer,
    SqlProcedureResult^ queryResult
) sealed

Parameters

writer
Type: NullableBinaryWriter
queryResult
Type: RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlProcedureResult

See Also

SqlProcedureResultSerializer Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


SqlProcedureResultSerializer Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlProcedureResultSerializer Properties
SqlProcedureResultSerializer Class See Also

The SqlProcedureResultSerializer type exposes the following properties.

Properties

Name | Description
Version |

See Also

SqlProcedureResultSerializer Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


Version Property

[image]

SQL Data Compare API 12.0.40
SqlProcedureResultSerializer..::.Version Property
SqlProcedureResultSerializer Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As Integer
C#
public int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () sealed;
}

See Also

SqlProcedureResultSerializer Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


ViewColumnWithDetailsQueryResultSerializer Class

[image]

SQL Data Compare API 12.0.40
ViewColumnWithDetailsQueryResultSerializer Class
Members See Also

Serializer/deserializer for SqlViewColumnWithDetailsResult.

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ViewColumnWithDetailsQueryResultSerializer
C#
public class ViewColumnWithDetailsQueryResultSerializer
Visual C++
public ref class ViewColumnWithDetailsQueryResultSerializer

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers..::.ViewColumnWithDetailsQueryResultSerializer

See Also

ViewColumnWithDetailsQueryResultSerializer Members
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


ViewColumnWithDetailsQueryResultSerializer Members

[image] [image]

SQL Data Compare API 12.0.40
ViewColumnWithDetailsQueryResultSerializer Members
ViewColumnWithDetailsQueryResultSerializer Class Constructors Methods Properties See Also

The ViewColumnWithDetailsQueryResultSerializer type exposes the following members.

Constructors

Name | Description
ViewColumnWithDetailsQueryResultSerializer |

Methods

Name | Description
Deserialize |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Version |

See Also

ViewColumnWithDetailsQueryResultSerializer Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


ViewColumnWithDetailsQueryResultSerializer Constructor

[image]

SQL Data Compare API 12.0.40
ViewColumnWithDetailsQueryResultSerializer Constructor
ViewColumnWithDetailsQueryResultSerializer Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ViewColumnWithDetailsQueryResultSerializer()
Visual C++
public:
ViewColumnWithDetailsQueryResultSerializer()

See Also

ViewColumnWithDetailsQueryResultSerializer Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


ViewColumnWithDetailsQueryResultSerializer Methods

[image] [image]

SQL Data Compare API 12.0.40
ViewColumnWithDetailsQueryResultSerializer Methods
ViewColumnWithDetailsQueryResultSerializer Class See Also

The ViewColumnWithDetailsQueryResultSerializer type exposes the following methods.

Methods

Name | Description
Deserialize |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewColumnWithDetailsQueryResultSerializer Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


Deserialize Method

[image]

SQL Data Compare API 12.0.40
ViewColumnWithDetailsQueryResultSerializer..::.Deserialize Method
ViewColumnWithDetailsQueryResultSerializer Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Deserialize ( _
    reader As NullableBinaryReader _
) As SqlViewColumnWithDetailsResult
C#
public SqlViewColumnWithDetailsResult Deserialize(
    NullableBinaryReader reader
)
Visual C++
public:
virtual SqlViewColumnWithDetailsResult^ Deserialize(
    NullableBinaryReader^ reader
) sealed

Parameters

reader
Type: NullableBinaryReader

See Also

ViewColumnWithDetailsQueryResultSerializer Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


Serialize Method

[image]

SQL Data Compare API 12.0.40
ViewColumnWithDetailsQueryResultSerializer..::.Serialize Method
ViewColumnWithDetailsQueryResultSerializer Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Serialize ( _
    writer As NullableBinaryWriter, _
    queryResult As SqlViewColumnWithDetailsResult _
)
C#
public void Serialize(
    NullableBinaryWriter writer,
    SqlViewColumnWithDetailsResult queryResult
)
Visual C++
public:
virtual void Serialize(
    NullableBinaryWriter^ writer,
    SqlViewColumnWithDetailsResult^ queryResult
) sealed

Parameters

writer
Type: NullableBinaryWriter
queryResult
Type: RedGate.SQLCompare.Engine.Registration.QueryResult..::.SqlViewColumnWithDetailsResult

See Also

ViewColumnWithDetailsQueryResultSerializer Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


ViewColumnWithDetailsQueryResultSerializer Properties

[image] [image]

SQL Data Compare API 12.0.40
ViewColumnWithDetailsQueryResultSerializer Properties
ViewColumnWithDetailsQueryResultSerializer Class See Also

The ViewColumnWithDetailsQueryResultSerializer type exposes the following properties.

Properties

Name | Description
Version |

See Also

ViewColumnWithDetailsQueryResultSerializer Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


Version Property

[image]

SQL Data Compare API 12.0.40
ViewColumnWithDetailsQueryResultSerializer..::.Version Property
ViewColumnWithDetailsQueryResultSerializer Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As Integer
C#
public int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () sealed;
}

See Also

ViewColumnWithDetailsQueryResultSerializer Class
RedGate.SQLCompare.Engine.Registration.ReadFromSql.Incremental.QueryResultSerializers Namespace


RedGate.SQLCompare.Engine.Registration.ServerFactory Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.Registration.ServerFactory Namespace

Classes

Class | Description
ServerFactory |


ServerFactory Class

[image]

SQL Data Compare API 12.0.40
ServerFactory Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ServerFactory
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Class ServerFactory _
    Implements IServerFactory
C#
public class ServerFactory : IServerFactory
Visual C++
public ref class ServerFactory : IServerFactory

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Registration.ServerFactory..::.ServerFactory

See Also

ServerFactory Members
RedGate.SQLCompare.Engine.Registration.ServerFactory Namespace


ServerFactory Members

[image] [image]

SQL Data Compare API 12.0.40
ServerFactory Members
ServerFactory Class Constructors Methods See Also

The ServerFactory type exposes the following members.

Constructors

Name | Description
ServerFactory |

Methods

Name | Description
CreateServerBackupCapabilities |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ServerFactory Class
RedGate.SQLCompare.Engine.Registration.ServerFactory Namespace


ServerFactory Constructor

[image]

SQL Data Compare API 12.0.40
ServerFactory Constructor
ServerFactory Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ServerFactory
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ServerFactory()
Visual C++
public:
ServerFactory()

See Also

ServerFactory Class
RedGate.SQLCompare.Engine.Registration.ServerFactory Namespace


ServerFactory Methods

[image] [image]

SQL Data Compare API 12.0.40
ServerFactory Methods
ServerFactory Class See Also

The ServerFactory type exposes the following methods.

Methods

Name | Description
CreateServerBackupCapabilities |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ServerFactory Class
RedGate.SQLCompare.Engine.Registration.ServerFactory Namespace


CreateServerBackupCapabilities Method

[image]

SQL Data Compare API 12.0.40
ServerFactory..::.CreateServerBackupCapabilities Method
ServerFactory Class See Also

Namespace: RedGate.SQLCompare.Engine.Registration.ServerFactory
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateServerBackupCapabilities ( _
    dataSource As IDataSource _
) As IServerBackupCapabilities
C#
public IServerBackupCapabilities CreateServerBackupCapabilities(
    IDataSource dataSource
)
Visual C++
public:
virtual IServerBackupCapabilities^ CreateServerBackupCapabilities(
    IDataSource^ dataSource
) sealed

Parameters

dataSource
Type: RedGate.Shared.SQL..::.IDataSource

Implements

IServerFactory..::.CreateServerBackupCapabilities(IDataSource)

See Also

ServerFactory Class
RedGate.SQLCompare.Engine.Registration.ServerFactory Namespace


RedGate.SQLCompare.Engine.Settings Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.Settings Namespace

Classes

Class | Description
UnknownOptionException |


UnknownOptionException Class

[image]

SQL Data Compare API 12.0.40
UnknownOptionException Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Settings
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class UnknownOptionException _
    Inherits SqlCompareException
C#
[SerializableAttribute]
public class UnknownOptionException : SqlCompareException
Visual C++
[SerializableAttribute]
public ref class UnknownOptionException : public SqlCompareException

Inheritance Hierarchy

Object
Exception
RedGate.SQLCompare.Engine..::.SqlCompareException
RedGate.SQLCompare.Engine.Settings..::.UnknownOptionException

See Also

UnknownOptionException Members
RedGate.SQLCompare.Engine.Settings Namespace


UnknownOptionException Members

[image] [image]

SQL Data Compare API 12.0.40
UnknownOptionException Members
UnknownOptionException Class Constructors Methods Properties See Also

The UnknownOptionException type exposes the following members.

Constructors

Name | Description
UnknownOptionException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

UnknownOptionException Class
RedGate.SQLCompare.Engine.Settings Namespace


UnknownOptionException Constructor

[image] [image]

SQL Data Compare API 12.0.40
UnknownOptionException Constructor
UnknownOptionException Class See Also

Overload List

Name | Description
UnknownOptionException(Exception) |
UnknownOptionException(SerializationInfo, StreamingContext) |

See Also

UnknownOptionException Class
UnknownOptionException Members
RedGate.SQLCompare.Engine.Settings Namespace


UnknownOptionException Constructor ()

[image]

SQL Data Compare API 12.0.40
UnknownOptionException Constructor ()
UnknownOptionException Class See Also

Namespace: RedGate.SQLCompare.Engine.Settings
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    inner As Exception _
)
C#
public UnknownOptionException(
    Exception inner
)
Visual C++
public:
UnknownOptionException(
    Exception^ inner
)

Parameters

inner
Type: Exception

See Also

UnknownOptionException Class
UnknownOptionException Overload
RedGate.SQLCompare.Engine.Settings Namespace


UnknownOptionException Constructor (, )

[image]

SQL Data Compare API 12.0.40
UnknownOptionException Constructor (, )
UnknownOptionException Class See Also

Namespace: RedGate.SQLCompare.Engine.Settings
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected UnknownOptionException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
UnknownOptionException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: SerializationInfo
context
Type: StreamingContext

See Also

UnknownOptionException Class
UnknownOptionException Overload
RedGate.SQLCompare.Engine.Settings Namespace


RedGate.SQLCompare.Engine.UIProject.UIProject Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.UIProject.UIProject Namespace

Classes

Class | Description
Logging |


Logging Class

[image]

SQL Data Compare API 12.0.40
Logging Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.UIProject.UIProject
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Logging
C#
public static class Logging
Visual C++
public ref class Logging abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.UIProject.UIProject..::.Logging

See Also

Logging Members
RedGate.SQLCompare.Engine.UIProject.UIProject Namespace


Logging Members

[image] [image]

SQL Data Compare API 12.0.40
Logging Members
Logging Class Properties See Also

The Logging type exposes the following members.

Properties

Name | Description
Project |

See Also

Logging Class
RedGate.SQLCompare.Engine.UIProject.UIProject Namespace


Logging Properties

[image] [image]

SQL Data Compare API 12.0.40
Logging Properties
Logging Class See Also

The Logging type exposes the following properties.

Properties

Name | Description
Project |

See Also

Logging Class
RedGate.SQLCompare.Engine.UIProject.UIProject Namespace


Project Property

[image]

SQL Data Compare API 12.0.40
Logging..::.Project Property
Logging Class See Also

Namespace: RedGate.SQLCompare.Engine.UIProject.UIProject
Assembly: RedGate.SQLCompare.Engine.UIProject (in RedGate.SQLCompare.Engine.UIProject.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Project As ComponentLogger
C#
public static ComponentLogger Project { get; }
Visual C++
public:
static property ComponentLogger^ Project {
    ComponentLogger^ get ();
}

See Also

Logging Class
RedGate.SQLCompare.Engine.UIProject.UIProject Namespace


RedGate.SQLCompare.Engine.Utilities Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLCompare.Engine.Utilities Namespace

Classes

Class | Description
StringUtils |


StringUtils Class

[image]

SQL Data Compare API 12.0.40
StringUtils Class
Members See Also

Namespace: RedGate.SQLCompare.Engine.Utilities
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StringUtils
C#
public static class StringUtils
Visual C++
public ref class StringUtils abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.Utilities..::.StringUtils

See Also

StringUtils Members
RedGate.SQLCompare.Engine.Utilities Namespace


StringUtils Members

[image] [image]

SQL Data Compare API 12.0.40
StringUtils Members
StringUtils Class Methods See Also

The StringUtils type exposes the following members.

Methods

Name | Description
GetLineContaining |

See Also

StringUtils Class
RedGate.SQLCompare.Engine.Utilities Namespace


StringUtils Methods

[image] [image]

SQL Data Compare API 12.0.40
StringUtils Methods
StringUtils Class See Also

The StringUtils type exposes the following methods.

Methods

Name | Description
GetLineContaining |

See Also

StringUtils Class
RedGate.SQLCompare.Engine.Utilities Namespace


GetLineContaining Method

[image]

SQL Data Compare API 12.0.40
StringUtils..::.GetLineContaining Method
StringUtils Class See Also

Namespace: RedGate.SQLCompare.Engine.Utilities
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetLineContaining ( _
    input As String, _
    lineNumber As Integer, _
    offset As Integer _
) As String
C#
public static string GetLineContaining(
    string input,
    int lineNumber,
    int offset
)
Visual C++
public:
static String^ GetLineContaining(
    String^ input,
    int lineNumber,
    int offset
)

Parameters

input
Type: String
lineNumber
Type: Int32
offset
Type: Int32

See Also

StringUtils Class
RedGate.SQLCompare.Engine.Utilities Namespace


RedGate.SQLDataCompare.Engine Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLDataCompare.Engine Namespace

Classes

Class | Description
Blob | Wrapper class for a byte array.
CLR | Wrapper class for a CLR data type.
ComparisonSession | Class used to compare two databases.
ComparisonSessionException | Exception thrown by ComparisonSession when it encounters an error comparing the databases.
ComparisonSessionSQLException | Exception thrown by ComparisonSession when it encounters an error comparing the databases.
DataCompareMappings<(Of <(TMapping, TMap>)>) | Base class of object mappings used in Data Compare.
DataCompareUserActions | Methods used to handle loading the user-actions section of a Data Compare project.
DataCompareVariant | Wrapper class for the SQL Variant data type.
DifferencesSummary | Holds information about the differences in the ResultsStore.
EnumerableExtensions | Extensions on IEnumerable, which should no longer be required when we move to .Net 4. Provides the Zip method that .Net 4 includes. TODO: remove when using .NET 4
FieldMapping | Contains a mapping from a field in one table to a field in another table.
FieldMappings | Holds mappings for fields in a table or view.
FieldPair | Field definition used in the ResultsStore class.
FieldPairs | A collection of FieldPair objects.
IndexMapping | Contains a mapping between the indexes in the different databases.
IndexMappings | Holds mappings of indexes. The indexes must be PrimaryKey, Unique, or UniqueConstraint to be included. The names of the indexes are not used for the mapping.
SchemaMapping | Obsolete. Contains a mapping between the schema, user, or role in two databases.
SchemaMappings | Holds mappings for schemas, users, or roles. Uses the database objects to create the mappings for the views and the tables from the two databases.
SpatialCLRType | Wrapper class for a Spatial CLR data type (SQL2008).
SqlDataCompareException | Superclass of all exceptions thrown by the SQL Data Compare engine.
SqlProvider | The provider for access to SQL Server databases.
SqlProviderException | Exception thrown by SqlProvider when it encounters an error whilst generating SQL code.
SqlVariantNull | Class representing a null in a SqlVariant
TableDifference | The results of a table being compared in two databases.
TableDifferences | A collection of TableDifference objects.
TableMapping | Contains a mapping from a view or table to another view or table. Also contains information on the criteria used for matching the two tables, which can be based on an index or an arbitrary set of mapped fields.
TableMappings | Holds mappings for tables or views in a schema.
WhereClause | An encapsulation class for the WHERE clause used on the tables in the databases.

Structures

Structure | Description
SynchronizationRecord | A record to be included in a synchronization. This is used by the script generation routines to confirm the inclusion of a record. Passed a parameter to the SelectionDelegate.
UserActionWarning | Contains details of a user action that has failed due to schema changes since the project was created.

Delegates

Delegate | Description
SelectionDelegate | The delegate called to indicate whether a record should be included in the synchronization SQL script.

Enumerations

Enumeration | Description
FieldMappingStatus | The result of the FieldMapping.
FieldPair..::.FieldPreference | Replacement for the bool parameter in SqlType(Boolean) to make client code slightly more readable.
ReaderType | Enum for possible sources of SQL being read by the ComparisonSession. Used by ComparisonSessionSQLException
SqlSynchronization | Controls which parts of the SQL script are produced when the synchronization script is created.
TableMappingStatus | The result of the mapping.


Blob Class

[image]

SQL Data Compare API 12.0.40
Blob Class
Members Example See Also

Wrapper class for a byte array.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class Blob _
    Inherits DisposableBase _
    Implements IComparable
C#
public class Blob : DisposableBase, IComparable
Visual C++
public ref class Blob : public DisposableBase,
    IComparable

Remarks

The Blob object is used internally by SQL Data Compare to represent a byte array. Use the ByteArray property to access the underlying data.

Examples

C# Copy Code
            using System;
            using RedGate.SQLCompare.Engine;
            using RedGate.SQLDataCompare.Engine;
            using RedGate.SQLDataCompare.Engine.ResultsStore;

            namespace SQLDataCompareCodeSnippets
            {
                public class BlobExample
                {
                    public void RunExample()
                    {
                        Database db1=new Database();
                        Database db2=new Database();

                        // Register the databases
                        db1.RegisterForDataCompare(new ConnectionProperties(".", "WidgetDev"));
                        db2.RegisterForDataCompare(new ConnectionProperties(".", "WidgetLive"));

                        using (ComparisonSession session = new ComparisonSession())
                        {
                            // Create the schema mappings used to compare the database
                            SchemaMappings mappings = new SchemaMappings();
                            mappings.CreateMappings(db1, db2);

                            session.CompareDatabases(db1, db2, mappings);

                            // Get the reader for the different rows in the results
                            Reader different=session.TableDifferences["[dbo].[WidgetDescriptions]"].ResultsStore.GetReader(Row.RowType.Different);

                            // get the first row in the ResultsStore Reader for the different rows.

                            Row currentRow=different.GetRow(0);

                            //field1 and field2 contain the position of the two BLOBs in the ResultsStore
                            int field1 = different.Fields["Picture"].OrdinalInResults1;
                            int field2 = different.Fields["Picture"].OrdinalInResults2;

                            Blob blob1=(Blob)currentRow.Values[field1];
                            Blob blob2=(Blob)currentRow.Values[field2];

                            // Output the first 20 bytes
                            for (int i=0; i<20; i++)
                            {
                                Console.Write("{0:X} ", blob1.ByteArray[i]);
                            }
                            Console.WriteLine();

                            // Output the first 20 bytes
                            for (int i=0; i<20; i++)
                            {
                                Console.Write("{0:X} ", blob2.ByteArray[i]);
                            }
                            Console.WriteLine();
                        }
                        db1.Dispose();
                        db2.Dispose();
                    }
                }
            }
Visual Basic Copy Code
            Option Explicit On

            Imports RedGate.SQLCompare.Engine
            Imports RedGate.SQLDataCompare.Engine
            Imports RedGate.SQLDataCompare.Engine.ResultsStore

            Class BlobExample
                Sub RunExample()
                    Dim session As New ComparisonSession

                    'register the databases for comparison
                    Dim db1 As New Database
                    Dim db2 As New Database

                    db1.RegisterForDataCompare(New ConnectionProperties(".", "WidgetDev"))
                    db2.RegisterForDataCompare(New ConnectionProperties(".", "WidgetLive"))

                    'create the schema mappings used to compare the database
                    Dim mappings As New SchemaMappings
                    mappings.CreateMappings(db1, db2)

                    'compare the databases
                    session.CompareDatabases(db1, db2, mappings)

                    Dim different As Reader = session.TableDifferences("[dbo].[WidgetDescriptions]").ResultsStore.GetReader(Row.RowType.Different)

                    'work out the two positions in the fields
                    Dim field1 As Integer = different.Fields("Picture").OrdinalInResults1
                    Dim field2 As Integer = different.Fields("Picture").OrdinalInResults2

                    'get the first row in the ResultsStore
                    Dim currentRow As Row = different.GetRow(0)

                    'field1 and field2 contain the position of the two BLOBs in the ResultsStore
                    Dim blob1 As Blob = currentRow.Values(field1)
                    Dim blob2 As Blob = currentRow.Values(field2)

                    Dim i As Integer

                    For i = 0 To 20
                        Console.Write("{0:X} ", blob1.ByteArray(i))
                    Next
                    Console.WriteLine()

                    For i = 0 To 20
                        Console.Write("{0:X} ", blob2.ByteArray(i))
                    Next
                    Console.WriteLine()

                    'dispose of the objects to delete temporary files
                    session.Dispose()
                    db1.Dispose()
                    db2.Dispose()
                End Sub
            End Class

Inheritance Hierarchy

Object
RedGate.Shared.Utils..::.DisposableBase
RedGate.SQLDataCompare.Engine..::.Blob
RedGate.SQLDataCompare.Engine..::.CLR

See Also

Blob Members
RedGate.SQLDataCompare.Engine Namespace


Blob Members

[image] [image]

SQL Data Compare API 12.0.40
Blob Members
Blob Class Constructors Methods Properties See Also

The Blob type exposes the following members.

Constructors

Name | Description
Blob | Constructs the Blob object with a specified byte array.

Methods

Name | Description
CompareTo | Compares the Blob with another Blob.
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ByteArray | The underlying byte array.
IsDisposed | Returns a value indicating if this instance has been disposed. (Inherited from DisposableBase.)
Length | The number of bytes in the underlying byte array.

See Also

Blob Class
RedGate.SQLDataCompare.Engine Namespace


Blob Constructor

[image]

SQL Data Compare API 12.0.40
Blob Constructor
Blob Class See Also

Constructs the Blob object with a specified byte array.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    bytes As Byte() _
)
C#
public Blob(
    byte[] bytes
)
Visual C++
public:
Blob(
    array<unsigned char>^ bytes
)

Parameters

bytes
Type: array<Byte>[]()[]
The byte array.

See Also

Blob Class
RedGate.SQLDataCompare.Engine Namespace


Blob Methods

[image] [image]

SQL Data Compare API 12.0.40
Blob Methods
Blob Class See Also

The Blob type exposes the following methods.

Methods

Name | Description
CompareTo | Compares the Blob with another Blob.
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Blob Class
RedGate.SQLDataCompare.Engine Namespace


CompareTo Method

[image]

SQL Data Compare API 12.0.40
Blob..::.CompareTo Method
Blob Class See Also

Compares the Blob with another Blob.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareTo ( _
    obj As Object _
) As Integer
C#
public int CompareTo(
    Object obj
)
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: Object
The Blob to compare.

Return Value

Returns -1, 0, or 1.

Implements

IComparableCompareTo(Object)

See Also

Blob Class
RedGate.SQLDataCompare.Engine Namespace


Dispose Method

[image] [image]

SQL Data Compare API 12.0.40
Blob..::.Dispose Method
Blob Class See Also

Overload List

Name | Description
Dispose()()() | (Inherited from DisposableBase.)
Dispose(Boolean) | Sets the underlying byte array to null (Overrides DisposableBase ..::. Dispose(Boolean).)

See Also

Blob Class
Blob Members
RedGate.SQLDataCompare.Engine Namespace


Dispose Method ()

[image]

SQL Data Compare API 12.0.40
Blob..::.Dispose Method ()
Blob Class See Also

Sets the underlying byte array to null

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
C#
protected override void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: Boolean

See Also

Blob Class
Dispose Overload
RedGate.SQLDataCompare.Engine Namespace


Blob Properties

[image] [image]

SQL Data Compare API 12.0.40
Blob Properties
Blob Class See Also

The Blob type exposes the following properties.

Properties

Name | Description
ByteArray | The underlying byte array.
IsDisposed | Returns a value indicating if this instance has been disposed. (Inherited from DisposableBase.)
Length | The number of bytes in the underlying byte array.

See Also

Blob Class
RedGate.SQLDataCompare.Engine Namespace


ByteArray Property

[image]

SQL Data Compare API 12.0.40
Blob..::.ByteArray Property
Blob Class See Also

The underlying byte array.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ByteArray As Byte()
C#
public byte[] ByteArray { get; }
Visual C++
public:
property array<unsigned char>^ ByteArray {
    array<unsigned char>^ get ();
}

See Also

Blob Class
RedGate.SQLDataCompare.Engine Namespace


Length Property

[image]

SQL Data Compare API 12.0.40
Blob..::.Length Property
Blob Class See Also

The number of bytes in the underlying byte array.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Length As Integer
C#
public int Length { get; }
Visual C++
public:
property int Length {
    int get ();
}

See Also

Blob Class
RedGate.SQLDataCompare.Engine Namespace


CLR Class

[image]

SQL Data Compare API 12.0.40
CLR Class
Members See Also

Wrapper class for a CLR data type.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class CLR _
    Inherits Blob
C#
public class CLR : Blob
Visual C++
public ref class CLR : public Blob

Remarks

The CLR object is used internally by SQL Data Compare to represent a CLR data type. Use the ByteArray and Text properties to access the underlying data.

Inheritance Hierarchy

Object
RedGate.Shared.Utils..::.DisposableBase
RedGate.SQLDataCompare.Engine..::.Blob
RedGate.SQLDataCompare.Engine..::.CLR
RedGate.SQLDataCompare.Engine..::.SpatialCLRType

See Also

CLR Members
RedGate.SQLDataCompare.Engine Namespace


CLR Members

[image] [image]

SQL Data Compare API 12.0.40
CLR Members
CLR Class Constructors Methods Properties See Also

The CLR type exposes the following members.

Constructors

Name | Description
CLR | Overloaded.

Methods

Name | Description
CompareTo | Compares the Blob with another Blob. (Inherited from Blob.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string representation of the object. (Overrides Object..::.ToString()()().)

Operators

Name | Description
Explicit | Explicit conversion from CLR to string.

Properties

Name | Description
ByteArray | The underlying byte array. (Inherited from Blob.)
HasText | Returns true if the CLR type has been populated with text, false otherwise (e.g. CLR was populated from a database backup).
IsDisposed | Returns a value indicating if this instance has been disposed. (Inherited from DisposableBase.)
Length | The number of bytes in the underlying byte array. (Inherited from Blob.)
Text | The textual representation of the CLR object.

See Also

CLR Class
RedGate.SQLDataCompare.Engine Namespace


CLR Constructor

[image] [image]

SQL Data Compare API 12.0.40
CLR Constructor
CLR Class See Also

Overload List

Name | Description
CLR(array<Byte>[]()[]) | Constructs the CLR object with a given byte array and textual representation.
CLR(array<Byte>[]()[], String) | Constructs the CLR object with a given byte array and textual representation.

See Also

CLR Class
CLR Members
RedGate.SQLDataCompare.Engine Namespace


CLR Constructor ([])

[image]

SQL Data Compare API 12.0.40
CLR Constructor (array<>[]()[])
CLR Class See Also

Constructs the CLR object with a given byte array and textual representation.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    bytes As Byte() _
)
C#
public CLR(
    byte[] bytes
)
Visual C++
public:
CLR(
    array<unsigned char>^ bytes
)

Parameters

bytes
Type: array<Byte>[]()[]
The byte array.

See Also

CLR Class
CLR Overload
RedGate.SQLDataCompare.Engine Namespace


CLR Constructor ([], )

[image]

SQL Data Compare API 12.0.40
CLR Constructor (array<>[]()[], )
CLR Class See Also

Constructs the CLR object with a given byte array and textual representation.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    bytes As Byte(), _
    textual As String _
)
C#
public CLR(
    byte[] bytes,
    string textual
)
Visual C++
public:
CLR(
    array<unsigned char>^ bytes,
    String^ textual
)

Parameters

bytes
Type: array<Byte>[]()[]
The byte array.
textual
Type: String
The textual representation of the CLR object.

See Also

CLR Class
CLR Overload
RedGate.SQLDataCompare.Engine Namespace


CLR Methods

[image] [image]

SQL Data Compare API 12.0.40
CLR Methods
CLR Class See Also

The CLR type exposes the following methods.

Methods

Name | Description
CompareTo | Compares the Blob with another Blob. (Inherited from Blob.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string representation of the object. (Overrides Object..::.ToString()()().)

Operators

Name | Description
Explicit | Explicit conversion from CLR to string.

See Also

CLR Class
RedGate.SQLDataCompare.Engine Namespace


Dispose Method

[image] [image]

SQL Data Compare API 12.0.40
CLR..::.Dispose Method
CLR Class See Also

Overload List

Name | Description
Dispose()()() | (Inherited from DisposableBase.)
Dispose(Boolean) | Sets the underlying byte array to null (Inherited from Blob.)

See Also

CLR Class
CLR Members
RedGate.SQLDataCompare.Engine Namespace


Explicit Operator

[image]

SQL Data Compare API 12.0.40
CLR..::.Explicit Operator
CLR Class See Also

Explicit conversion from CLR to string.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    clr As CLR _
) As String
C#
public static explicit operator string (
    CLR clr
)
Visual C++
static explicit operator String^ (
    CLR^ clr
)

Parameters

clr
Type: RedGate.SQLDataCompare.Engine..::.CLR
The CLR to cast.

Return Value

The textual representation of the CLR.

See Also

CLR Class
RedGate.SQLDataCompare.Engine Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
CLR..::.ToString Method
CLR Class See Also

Returns a string representation of the object.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

Return Value

The textual representation of the CLR object.

See Also

CLR Class
RedGate.SQLDataCompare.Engine Namespace


CLR Properties

[image] [image]

SQL Data Compare API 12.0.40
CLR Properties
CLR Class See Also

The CLR type exposes the following properties.

Properties

Name | Description
ByteArray | The underlying byte array. (Inherited from Blob.)
HasText | Returns true if the CLR type has been populated with text, false otherwise (e.g. CLR was populated from a database backup).
IsDisposed | Returns a value indicating if this instance has been disposed. (Inherited from DisposableBase.)
Length | The number of bytes in the underlying byte array. (Inherited from Blob.)
Text | The textual representation of the CLR object.

See Also

CLR Class
RedGate.SQLDataCompare.Engine Namespace


HasText Property

[image]

SQL Data Compare API 12.0.40
CLR..::.HasText Property
CLR Class See Also

Returns true if the CLR type has been populated with text, false otherwise (e.g. CLR was populated from a database backup).

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasText As Boolean
C#
public bool HasText { get; }
Visual C++
public:
property bool HasText {
    bool get ();
}

See Also

CLR Class
RedGate.SQLDataCompare.Engine Namespace


Text Property

[image]

SQL Data Compare API 12.0.40
CLR..::.Text Property
CLR Class See Also

The textual representation of the CLR object.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
C#
public string Text { get; }
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

CLR Class
RedGate.SQLDataCompare.Engine Namespace


ComparisonSession Class

[image]

SQL Data Compare API 12.0.40
ComparisonSession Class
Members Example See Also

Class used to compare two databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ComparisonSession _
    Inherits DisposableBase _
    Implements ICancellable, ICloneable
C#
public class ComparisonSession : DisposableBase, ICancellable,
    ICloneable
Visual C++
public ref class ComparisonSession : public DisposableBase,
    ICancellable, ICloneable

Remarks

The ComparisonSession class carries out the majority of the work to compare the data in two databases.

You need to instantiate a ComparisonSession class and then call CompareDatabases(IDatabase, IDatabase, TableMappings, SessionSettings, Boolean) . You can then access the results from the TableDifferences property.

Use the Status event handler to receive feedback about the comparison.

The operation can be canceled by calling CancelOperation()()().

Note that you must not re-use a ComparisonSession to carry out multiple comparisons; create a new ComparisonSession each time

SQL Data Compare makes extensive use of temporary files. It is essential that you call Dispose(Boolean) to ensure that these are cleaned up.

Examples

These examples show complete code samples for printing the different records in two databases. It shows how to get feedback during a long operation, and how to cancel part-way through.
C# Copy Code
            using System;
            using RedGate.SQLCompare.Engine;
            using RedGate.SQLDataCompare.Engine;
            using RedGate.SQLDataCompare.Engine.ResultsStore;

            namespace SQLDataCompareCodeSnippets
            {
                public class ComparisonSessionExample
                {
                    public void RunExample()
                    {
                        Database db1=new Database();
                        Database db2=new Database();
                        ComparisonSession session=new ComparisonSession();
                        SchemaMappings mappings = new SchemaMappings();

                        try
                        {
                            db1.RegisterForDataCompare(new ConnectionProperties(".", "WidgetDev"));
                            db2.RegisterForDataCompare(new ConnectionProperties(".", "WidgetLive"));

                            // Create the mappings between the two databases
                            mappings.CreateMappings(db1, db2);
                            session.CompareDatabases(db1, db2, mappings);

                            foreach (TableMapping mapping in mappings.TableMappings)
                            {
                                TableDifference difference=session.TableDifferences[mapping.Obj1.FullyQualifiedName];

                                // Any tables that couldn't be compared we don't output the results
                                if (difference == null)
                                    continue;

                                //loop through all the rows
                                foreach(Row row in difference.ResultsStore)
                                {
                                    //go through the non same records
                                    if (row.Type != Row.RowType.Same)
                                    {
                                        Console.WriteLine("{0} Row {1} type {2}", mapping.Obj1.FullyQualifiedName, row.Index, row.Type.ToString());
                                        int i=0;
                                        foreach (FieldPair field in difference.ResultsStore.Fields)
                                        {
                                            int field1=field.OrdinalInResults1;
                                            int field2=field.OrdinalInResults2;

                                            if (field1 != field2)
                                            {
                                                // Get the values
                                                object value1=row.Values[field1];
                                                object value2=row.Values[field2];
                                                if (value1 == null)
                                                    value1="NULL";
                                                if (value2 == null)
                                                    value2="NULL";
                                                Console.WriteLine("{0}\t{1}\t{2}\t{3}",field.Field(false).Name, value1.ToString(),row.FieldDifferent(i)?"<>":"==",  value2.ToString());
                                            }
                                            else
                                            {
                                                // This is part of the unique index we are comparing on
                                                object value=row.Values[field1];
                                                Console.WriteLine("*{0}\t{1}",field.Field(false).Name, value.ToString());
                                            }
                                            i++;
                                        }// End of foreach field pair
                                    }
                                }// End of foreach row
                            }// End of foreach mappings
                        }
                        finally
                        {
                            session.Dispose();
                            db1.Dispose();
                            db2.Dispose();
                        }
                    }
                }
            }
Visual Basic Copy Code
            Option Explicit On

            Imports RedGate.SQLCompare.Engine
            Imports RedGate.SQLDataCompare.Engine
            Imports RedGate.SQLDataCompare.Engine.ResultsStore

            Public Class ComparisonSessionExample
                Sub RunExample()
                    Dim session As New ComparisonSession

                    'register the databases for comparison
                    Dim db1 As New Database
                    Dim db2 As New Database

                    db1.RegisterForDataCompare(New ConnectionProperties(".", "WidgetDev"))
                    db2.RegisterForDataCompare(New ConnectionProperties(".", "WidgetLive"))

                    Dim mappings As New SchemaMappings
                    mappings.CreateMappings(db1, db2)

                    'compare the databases
                    session.CompareDatabases(db1, db2, mappings)

                    Dim mapping As TableMapping

                    For Each mapping In mappings.TableMappings
                        Dim table As ViewTableSuperClass = mapping.Obj1
                        Dim difference As TableDifference = session.TableDifferences(table.FullyQualifiedName)

                        ' Any tables that couldn't be compared we don't output the results
                        If difference Is Nothing Then
                            Continue For
                        End If

                        Dim row As row
                        For Each row In difference.ResultsStore  'loop through all the rows

                            If (row.Type <> row.RowType.Same) Then 'go through the non same records
                                Dim field As FieldPair
                                Dim i As Int32 = 0
                                Console.WriteLine("{0} Row {1} type {2}", table.FullyQualifiedName, row.Index, row.Type.ToString())
                                For Each field In difference.ResultsStore.Fields
                                    'work out where about in the results the field data is stored
                                    'if we were comparing identical records, or records present in one
                                    'database but not the other then we would not need to
                                    'use the OrdinalInResults1 and OrdinalInResults2 properties
                                    'but just OrdinalInResults
                                    Dim field1 As Int32 = field.OrdinalInResults1
                                    Dim field2 As Int32 = field.OrdinalInResults2

                                    If (field1 <> field2) Then
                                        'get the values
                                        Dim value1 As Object = row.Values(field1)
                                        Dim value2 As Object = row.Values(field2)
                                        If (value1 Is Nothing) Then
                                            value1 = "NULL"
                                        End If
                                        If (value2 Is Nothing) Then
                                            value2 = "NULL"
                                        End If
                                        If row.FieldDifferent(i) Then
                                            Console.WriteLine("{0}:{1} <> {2}", field.Field(False).Name, value1.ToString(), value2.ToString())
                                        Else
                                            Console.WriteLine("{0}:{1} == {2}", field.Field(False).Name, value1.ToString(), value2.ToString())
                                        End If
                                    Else
                                        'this is part of the unique index we are comparing on
                                        Dim value As Object = row.Values(field1)
                                        Console.WriteLine("*{0}:{1}", field.Field(False).Name, value.ToString())
                                    End If
                                    i += 1
                                Next
                            End If
                        Next
                    Next
                    'dispose of the objects
                    session.Dispose()
                    db1.Dispose()
                    db2.Dispose()
                End Sub
            End Class
C# Copy Code
            using System;
            using RedGate.Shared.Utils;
            using RedGate.Shared.SQL;
            using RedGate.SQLCompare.Engine;
            using RedGate.SQLDataCompare.Engine;

            namespace SQLDataCompareCodeSnippets
            {
                public class ComparisonSessionWithProgressExample
                {
                    private ComparisonSession m_Session=null;

                    private void StatusCallback(object sender, StatusEventArgs e)
                    {
                        //fired by the SqlProvider to indicate events

                        if (e.Message!=null)
                        {
                            Console.WriteLine(e.Message);
                        }

                        if (e.Percentage!=-1)
                        {
                            Console.WriteLine("{0}%", e.Percentage);
                        }

                        //cancel at random

                        Random r=new Random();
                        if (r.Next(100)<10)
                        {
                            m_Session.CancelOperation();
                        }
                    }

                    public void RunExample()
                    {
                        Database db1=new Database();
                        Database db2=new Database();
                        TableMappings mappings = new TableMappings();

                        db1.RegisterForDataCompare(new ConnectionProperties(".", "WidgetDev"));
                        db2.RegisterForDataCompare(new ConnectionProperties(".", "WidgetLive"));

                        mappings.Options =  new EngineDataCompareOptions(MappingOptions.Default,ComparisonOptions.Default,SqlOptions.Default);

                        mappings.CreateMappings(db1.Tables, db2.Tables);
                        mappings.CreateMappings(db1.Views, db2.Views);

                        using (m_Session = new ComparisonSession())
                        {
                            m_Session.Options = mappings.Options;
                            m_Session.Status+=new StatusEventHandler(StatusCallback);
                            try
                            {
                                m_Session.CompareDatabases( db1, db2, mappings, SessionSettings.Default);
                            }
                            catch (OperationCancelledException)
                            {
                                Console.WriteLine("Operation canceled!");
                            }
                            Console.WriteLine("Done!");
                        }
                        db1.Dispose();
                        db2.Dispose();
                    }
                }
            }
Visual Basic Copy Code
            Option Explicit On

            Imports RedGate.Shared.Utils
            Imports RedGate.Shared.SQL
            Imports RedGate.SQLCompare.Engine
            Imports RedGate.SQLDataCompare.Engine

            Public Class ComparisonSessionWithProgressExample

                Private m_Session As ComparisonSession

                Sub StatusCallback(ByVal sender As Object, ByVal e As StatusEventArgs)

                    If Not (e.Message Is Nothing) Then
                        Console.WriteLine(e.Message)
                    End If

                    If e.Percentage <> -1 Then
                        Console.WriteLine("{0}%", e.Percentage)
                    End If

                    'Cancel the operation at random

                    Dim r As Random = New Random

                    If r.Next(100) < 10 Then
                        m_Session.CancelOperation()
                    End If
                End Sub

                Sub RunExample()
                    Dim db1 As New Database
                    Dim db2 As New Database

                    db1.RegisterForDataCompare(New ConnectionProperties(".", "WidgetDev"))
                    db2.RegisterForDataCompare(New ConnectionProperties(".", "WidgetLive"))

                    'create an intersection of the tables
                    Dim mappings As New TableMappings
                    mappings.Options = New EngineDataCompareOptions(MappingOptions.Default, ComparisonOptions.Default, SqlOptions.Default)

                    mappings.CreateMappings(db1.Tables, db2.Tables)
                    mappings.CreateMappings(db1.Views, db2.Views)

                    m_Session = New ComparisonSession
                    m_Session.Options = mappings.Options
                    m_Session.Status = New StatusEventHandler(AddressOf StatusCallback)

                    Try
                        m_Session.CompareDatabases(db1, db2, mappings, SessionSettings.Default)
                    Catch e As OperationCancelledException
                        Console.WriteLine("Operation canceled!")
                    End Try

                    'dispose of the objects to delete temporary files
                    m_Session.Dispose()
                    db1.Dispose()
                    db2.Dispose()
                End Sub
            End Class
C# Copy Code
            using System;
            using System.Collections.Generic;
            using RedGate.Shared.Utils;
            using RedGate.BackupReader;
            using RedGate.SQLCompare.Engine;
            using RedGate.SQLCompare.ReadFromBackup;
            using RedGate.SQLDataCompare.Engine;
            using RedGate.SQLDataCompare.Engine.ResultsStore;

            namespace SQLDataCompareCodeSnippets
            {
                public class BackupComparisonExample
                {
                    public void RunExample()
                    {
                        BackupSetDatabase backupDB = new BackupSetDatabase();
                        Database liveDB = new Database();
                        ComparisonSession session = new ComparisonSession();
                        SchemaMappings mappings = new SchemaMappings();

                        try
                        {
                            // First register the backup file
                            Console.WriteLine("Registering backup");
                            backupDB.Status += new StatusEventHandler(StatusCallBack);
                            IList>string> files = new string[] { "c:\\widgetdev.bak" };
                            IList>string> passwords = null;
                            IList>BackupSet> backupSets = backupDB.GetBackupSets(files, passwords);

                            // use the latest backup set available
                            BackupSet backupSetToUse = backupSets[backupSets.Count - 1];

                            BackupDatabaseSource backupDBSource = new BackupDatabaseSource(files, passwords, backupSetToUse);
                            backupDB.RegisterForDataCompare(backupDBSource.ToConnectionProperties());

                            // Secondly register the live database
                            Console.WriteLine("Registering live database");
                            liveDB.Status += new StatusEventHandler(StatusCallBack);
                            liveDB.RegisterForDataCompare(new ConnectionProperties(".", "WidgetLive"), Options.Default);

                            // Create the mappings between the two databases
                            mappings.CreateMappings(backupDB, liveDB);
                            session.CompareDatabases(backupDB, liveDB, mappings);

                            foreach (TableMapping mapping in mappings.TableMappings)
                            {
                                TableDifference difference = session.TableDifferences[mapping.Obj1.FullyQualifiedName];

                                // Any tables that couldn't be compared we don't output the results
                                if (difference == null)
                                    continue;

                                //loop through all the rows
                                foreach (Row row in difference.ResultsStore)
                                {
                                    //go through the non same records
                                    if (row.Type != Row.RowType.Same)
                                    {
                                        Console.WriteLine("{0} Row {1} type {2}", mapping.Obj1.FullyQualifiedName, row.Index, row.Type.ToString());
                                        int i = 0;
                                        foreach (FieldPair field in difference.ResultsStore.Fields)
                                        {
                                            int field1 = field.OrdinalInResults1;
                                            int field2 = field.OrdinalInResults2;

                                            if (field1 != field2)
                                            {
                                                // Get the values
                                                object value1 = row.Values[field1];
                                                object value2 = row.Values[field2];
                                                if (value1 == null)
                                                    value1 = "NULL";
                                                if (value2 == null)
                                                    value2 = "NULL";
                                                Console.WriteLine("{0}\t{1}\t{2}\t{3}", field.Field(false).Name, value1.ToString(), row.FieldDifferent(i) ? "<>" : "==", value2.ToString());
                                            }
                                            else
                                            {
                                                // This is part of the unique index we are comparing on
                                                object value = row.Values[field1];
                                                Console.WriteLine("*{0}\t{1}", field.Field(false).Name, value.ToString());
                                            }
                                            i++;
                                        }// End of foreach field pair
                                    }
                                }// End of foreach row
                            }// End of foreach mappings
                        }
                        finally
                        {
                            session.Dispose();
                            backupDB.Dispose();
                            liveDB.Dispose();
                        }
                    }

                    private static void StatusCallBack(object sender, StatusEventArgs e)
                    {
                        if (e.Message != null)
                        {
                            Console.WriteLine(e.Message);
                        }

                        if (e.Percentage != -1)
                        {
                            Console.WriteLine("{0}%", e.Percentage);
                        }
                    }
                }
            }
Visual Basic Copy Code
            Option Explicit On

            Imports System.Collections.Generic
            Imports RedGate.BackupReader
            Imports RedGate.SQLCompare.Engine.ReadFromBackup
            Imports RedGate.SQLCompare.Engine
            Imports RedGate.SQLDataCompare.Engine
            Imports RedGate.SQLDataCompare.Engine.ResultsStore
            Imports RedGate.Shared.Utils

            Public Class BackupComparisonExample
                Sub RunExample()
                    Dim session As New ComparisonSession

                    'register the databases for comparison
                    Dim backupDB As New BackupSetDatabase
                    Dim liveDB As New Database

                    Try
                        ' First register the backup file
                        Console.WriteLine("Registering backup")
                        backupDB.Status = New StatusEventHandler(AddressOf StatusCallback)

                        Dim files() As String = {"c:\\widgetdev.bak"}
                        Dim passwords As IList(Of String) = New List(Of String)
                        Dim backupSets As IList(Of BackupSet) = backupDB.GetBackupSets(files, passwords)

                        ' use the latest backupset
                        Dim backupSetToUse As BackupSet = backupSets.Item(backupSets.Count - 1)
                        Dim backupDBSource As New BackupDatabaseSource(files, passwords, backupSetToUse)
                        backupDB.RegisterForDataCompare(backupDBSource.ToConnectionProperties())

                        backupDB.RegisterForDataCompare(New String() {"c:\\widgetdev.bak"}, Nothing)

                        ' Secondly register the live database
                        Console.WriteLine("Registering live database")
                        liveDB.Status = New StatusEventHandler(AddressOf StatusCallback)
                        liveDB.RegisterForDataCompare(New ConnectionProperties(".", "WidgetLive"), Options.Default)

                        Dim mappings As New SchemaMappings
                        mappings.CreateMappings(backupDB, liveDB)

                        'compare the databases
                        session.CompareDatabases(backupDB, liveDB, mappings)

                        Dim mapping As TableMapping

                        For Each mapping In mappings.TableMappings
                            Dim table As ViewTableSuperClass = mapping.Obj1
                            Dim difference As TableDifference = session.TableDifferences(table.FullyQualifiedName)

                            ' Any tables that couldn't be compared we don't output the results
                            If difference Is Nothing Then
                                Continue For
                            End If

                            Dim row As Row
                            For Each row In difference.ResultsStore  'loop through all the rows

                                If (row.Type <> row.RowType.Same) Then 'go through the non same records
                                    Dim field As FieldPair
                                    Dim i As Int32 = 0
                                    Console.WriteLine("{0} Row {1} type {2}", table.FullyQualifiedName, row.Index, row.Type.ToString())
                                    For Each field In difference.ResultsStore.Fields
                                        'work out where about in the results the field data is stored
                                        'if we were comparing identical records, or records present in one
                                        'database but not the other then we would not need to
                                        'use the OrdinalInResults1 and OrdinalInResults2 properties
                                        'but just OrdinalInResults
                                        Dim field1 As Int32 = field.OrdinalInResults1
                                        Dim field2 As Int32 = field.OrdinalInResults2

                                        If (field1 <> field2) Then
                                            'get the values
                                            Dim value1 As Object = row.Values(field1)
                                            Dim value2 As Object = row.Values(field2)
                                            If (value1 Is Nothing) Then
                                                value1 = "NULL"
                                            End If
                                            If (value2 Is Nothing) Then
                                                value2 = "NULL"
                                            End If
                                            If row.FieldDifferent(i) Then
                                                Console.WriteLine("{0}:{1} <> {2}", field.Field(False).Name, value1.ToString(), value2.ToString())
                                            Else
                                                Console.WriteLine("{0}:{1} == {2}", field.Field(False).Name, value1.ToString(), value2.ToString())
                                            End If
                                        Else
                                            'this is part of the unique index we are comparing on
                                            Dim value As Object = row.Values(field1)
                                            Console.WriteLine("*{0}:{1}", field.Field(False).Name, value.ToString())
                                        End If
                                        i += 1
                                    Next
                                End If
                            Next
                        Next
                    Finally
                        'dispose of the objects
                        session.Dispose()
                        backupDB.Dispose()
                        liveDB.Dispose()
                    End Try
                End Sub

                Sub StatusCallback(ByVal sender As Object, ByVal e As StatusEventArgs)

                    If Not (e.Message Is Nothing) Then
                        Console.WriteLine(e.Message)
                    End If

                    If e.Percentage <> -1 Then
                        Console.WriteLine("{0}%", e.Percentage)
                    End If
                End Sub
            End Class

Inheritance Hierarchy

Object
RedGate.Shared.Utils..::.DisposableBase
RedGate.SQLDataCompare.Engine..::.ComparisonSession

See Also

ComparisonSession Members
RedGate.SQLDataCompare.Engine Namespace


ComparisonSession Members

[image] [image]

SQL Data Compare API 12.0.40
ComparisonSession Members
ComparisonSession Class Constructors Methods Properties Explicit Interface Implementations See Also

The ComparisonSession type exposes the following members.

Constructors

Name | Description
ComparisonSession | Constructor.

Methods

Name | Description
CancelOperation | Cancels the current operation. Any table differences that were generated before the operation was canceled will be invalid.
Clone | Clone method
CompareDatabases | Overloaded.
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetFileInfos | TODO: better XML doc
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnStatus | Fires the status event handler.
RefreshSelectedItems | Refreshes the TableDifferences collection with any changes that have been made to the underlying data.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Database1 | Returns the first database that is being compared.
Database2 | Returns the second database that is being compared.
IsDisposed | Returns a value indicating if this instance has been disposed. (Inherited from DisposableBase.)
Options | The options used when the databases are compared.
Status | The event handler used to receive status update events.
TableDifferences | The differences resulting from the database comparison.

Explicit Interface Implementations

Name | Description
ICloneableClone |

See Also

ComparisonSession Class
RedGate.SQLDataCompare.Engine Namespace


ComparisonSession Constructor

[image]

SQL Data Compare API 12.0.40
ComparisonSession Constructor
ComparisonSession Class See Also

Constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ComparisonSession()
Visual C++
public:
ComparisonSession()

See Also

ComparisonSession Class
RedGate.SQLDataCompare.Engine Namespace


ComparisonSession Methods

[image] [image]

SQL Data Compare API 12.0.40
ComparisonSession Methods
ComparisonSession Class See Also

The ComparisonSession type exposes the following methods.

Methods

Name | Description
CancelOperation | Cancels the current operation. Any table differences that were generated before the operation was canceled will be invalid.
Clone | Clone method
CompareDatabases | Overloaded.
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetFileInfos | TODO: better XML doc
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnStatus | Fires the status event handler.
RefreshSelectedItems | Refreshes the TableDifferences collection with any changes that have been made to the underlying data.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICloneableClone |

See Also

ComparisonSession Class
RedGate.SQLDataCompare.Engine Namespace


CancelOperation Method

[image]

SQL Data Compare API 12.0.40
ComparisonSession..::.CancelOperation Method
ComparisonSession Class Example See Also

Cancels the current operation. Any table differences that were generated before the operation was canceled will be invalid.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelOperation
C#
public void CancelOperation()
Visual C++
public:
virtual void CancelOperation() sealed

Implements

ICancellable..::.CancelOperation()()()

Remarks

An OperationCancelledException is thrown.

Examples

See CompareDatabases(IDatabase, IDatabase, TableMappings, SessionSettings, Boolean) for an example of how to receive status events and cancel operations.

See Also

ComparisonSession Class
RedGate.SQLDataCompare.Engine Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
ComparisonSession..::.Clone Method
ComparisonSession Class See Also

Clone method

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone As ComparisonSession
C#
public ComparisonSession Clone()
Visual C++
public:
ComparisonSession^ Clone()

Return Value

See Also

ComparisonSession Class
RedGate.SQLDataCompare.Engine Namespace


. Method

[image]

SQL Data Compare API 12.0.40
ComparisonSession..::...::. Method
ComparisonSession Class See Also

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function Clone As Object Implements ICloneable.Clone
C#
Object ICloneable.Clone()
Visual C++
private:
virtual Object^ Clone() sealed = ICloneable::Clone

Implements

ICloneableClone()()()

See Also

ComparisonSession Class
RedGate.SQLDataCompare.Engine Namespace


CompareDatabases Method

[image] [image]

SQL Data Compare API 12.0.40
ComparisonSession..::.CompareDatabases Method
ComparisonSession Class See Also

Overload List

Name | Description
CompareDatabases(Database, Database, SchemaMappings) | Compares two databases using default session settings.
CompareDatabases(IDatabase, IDatabase, TableMappings) | Compares the tables in two databases using default session settings.
CompareDatabases(IDatabase, IDatabase, SchemaMappings, SessionSettings) | Compares two databases with customized session settings.
CompareDatabases(IDatabase, IDatabase, TableMappings, SessionSettings) | Compares the tables in two databases using customized session settings.
CompareDatabases(IDatabase, IDatabase, TableMappings, SessionSettings, Boolean) | Compares the tables in two databases using customized session settings.

See Also

ComparisonSession Class
ComparisonSession Members
RedGate.SQLDataCompare.Engine Namespace


CompareDatabases Method (Database, Database, SchemaMappings)

[image]

SQL Data Compare API 12.0.40
ComparisonSession..::.CompareDatabases Method (Database, Database, SchemaMappings)
ComparisonSession Class See Also

Compares two databases using default session settings.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CompareDatabases ( _
    db1 As Database, _
    db2 As Database, _
    mappings As SchemaMappings _
)
C#
public void CompareDatabases(
    Database db1,
    Database db2,
    SchemaMappings mappings
)
Visual C++
public:
void CompareDatabases(
    Database^ db1,
    Database^ db2,
    SchemaMappings^ mappings
)

Parameters

db1
Type: RedGate.SQLCompare.Engine..::.Database
The first database to compare.
db2
Type: RedGate.SQLCompare.Engine..::.Database
The second database to compare, or null.
mappings
Type: RedGate.SQLDataCompare.Engine..::.SchemaMappings
Mappings from the first database to the second database.

See Also

ComparisonSession Class
CompareDatabases Overload
RedGate.SQLDataCompare.Engine Namespace


CompareDatabases Method (IDatabase, IDatabase, TableMappings)

[image]

SQL Data Compare API 12.0.40
ComparisonSession..::.CompareDatabases Method (IDatabase, IDatabase, TableMappings)
ComparisonSession Class See Also

Compares the tables in two databases using default session settings.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CompareDatabases ( _
    db1 As IDatabase, _
    db2 As IDatabase, _
    mappings As TableMappings _
)
C#
public void CompareDatabases(
    IDatabase db1,
    IDatabase db2,
    TableMappings mappings
)
Visual C++
public:
void CompareDatabases(
    IDatabase^ db1,
    IDatabase^ db2,
    TableMappings^ mappings
)

Parameters

db1
Type: RedGate.SQLCompare.Engine..::.IDatabase
The first database to compare.
db2
Type: RedGate.SQLCompare.Engine..::.IDatabase
The second database to compare, or null.
mappings
Type: RedGate.SQLDataCompare.Engine..::.TableMappings
Mappings from the first database to the second database.

See Also

ComparisonSession Class
CompareDatabases Overload
RedGate.SQLDataCompare.Engine Namespace


CompareDatabases Method (IDatabase, IDatabase, SchemaMappings, SessionSettings)

[image]

SQL Data Compare API 12.0.40
ComparisonSession..::.CompareDatabases Method (IDatabase, IDatabase, SchemaMappings, SessionSettings)
ComparisonSession Class See Also

Compares two databases with customized session settings.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CompareDatabases ( _
    db1 As IDatabase, _
    db2 As IDatabase, _
    mappings As SchemaMappings, _
    sessionSettings As SessionSettings _
)
C#
public void CompareDatabases(
    IDatabase db1,
    IDatabase db2,
    SchemaMappings mappings,
    SessionSettings sessionSettings
)
Visual C++
public:
void CompareDatabases(
    IDatabase^ db1,
    IDatabase^ db2,
    SchemaMappings^ mappings,
    SessionSettings sessionSettings
)

Parameters

db1
Type: RedGate.SQLCompare.Engine..::.IDatabase
The first database to compare.
db2
Type: RedGate.SQLCompare.Engine..::.IDatabase
The second database to compare, or null.
mappings
Type: RedGate.SQLDataCompare.Engine..::.SchemaMappings
Mappings from the first database to the second database.
sessionSettings
Type: RedGate.SQLCompare.Engine..::.SessionSettings
The records to include, by comparison status (identical, different, additional, missing).

See Also

ComparisonSession Class
CompareDatabases Overload
RedGate.SQLDataCompare.Engine Namespace


CompareDatabases Method (IDatabase, IDatabase, TableMappings, SessionSettings)

[image]

SQL Data Compare API 12.0.40
ComparisonSession..::.CompareDatabases Method (IDatabase, IDatabase, TableMappings, SessionSettings)
ComparisonSession Class See Also

Compares the tables in two databases using customized session settings.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CompareDatabases ( _
    db1 As IDatabase, _
    db2 As IDatabase, _
    mappings As TableMappings, _
    sessionSettings As SessionSettings _
)
C#
public void CompareDatabases(
    IDatabase db1,
    IDatabase db2,
    TableMappings mappings,
    SessionSettings sessionSettings
)
Visual C++
public:
void CompareDatabases(
    IDatabase^ db1,
    IDatabase^ db2,
    TableMappings^ mappings,
    SessionSettings sessionSettings
)

Parameters

db1
Type: RedGate.SQLCompare.Engine..::.IDatabase
The first database to compare.
db2
Type: RedGate.SQLCompare.Engine..::.IDatabase
The second database to compare, or null.
mappings
Type: RedGate.SQLDataCompare.Engine..::.TableMappings
Mappings from the first database to the second database.
sessionSettings
Type: RedGate.SQLCompare.Engine..::.SessionSettings
The records to include, by comparison status (identical, different, additional, missing).

See Also

ComparisonSession Class
CompareDatabases Overload
RedGate.SQLDataCompare.Engine Namespace


CompareDatabases Method (IDatabase, IDatabase, TableMappings, SessionSettings, )

[image]

SQL Data Compare API 12.0.40
ComparisonSession..::.CompareDatabases Method (IDatabase, IDatabase, TableMappings, SessionSettings, )
ComparisonSession Class See Also

Compares the tables in two databases using customized session settings.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CompareDatabases ( _
    db1 As IDatabase, _
    db2 As IDatabase, _
    mappings As TableMappings, _
    sessionSettings As SessionSettings, _
    doNotBeDefeated As Boolean _
)
C#
public void CompareDatabases(
    IDatabase db1,
    IDatabase db2,
    TableMappings mappings,
    SessionSettings sessionSettings,
    bool doNotBeDefeated
)
Visual C++
public:
void CompareDatabases(
    IDatabase^ db1,
    IDatabase^ db2,
    TableMappings^ mappings,
    SessionSettings sessionSettings,
    bool doNotBeDefeated
)

Parameters

db1
Type: RedGate.SQLCompare.Engine..::.IDatabase
The first database to compare.
db2
Type: RedGate.SQLCompare.Engine..::.IDatabase
The second database to compare, or null.
mappings
Type: RedGate.SQLDataCompare.Engine..::.TableMappings
Mappings from the first database to the second database.
sessionSettings
Type: RedGate.SQLCompare.Engine..::.SessionSettings
The records to include, by comparison status (identical, different, additional, missing).
doNotBeDefeated
Type: Boolean
Whether to do a TrivialTableCompare on tables for which no mapping exists

See Also

ComparisonSession Class
CompareDatabases Overload
RedGate.SQLDataCompare.Engine Namespace


Dispose Method

[image] [image]

SQL Data Compare API 12.0.40
ComparisonSession..::.Dispose Method
ComparisonSession Class See Also

Overload List

Name | Description
Dispose()()() | (Inherited from DisposableBase.)
Dispose(Boolean) | Disposes of all the TableDifferences in this session. (Overrides DisposableBase ..::. Dispose(Boolean).)

See Also

ComparisonSession Class
ComparisonSession Members
RedGate.SQLDataCompare.Engine Namespace


Dispose Method ()

[image]

SQL Data Compare API 12.0.40
ComparisonSession..::.Dispose Method ()
ComparisonSession Class See Also

Disposes of all the TableDifferences in this session.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
C#
protected override void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: Boolean

See Also

ComparisonSession Class
Dispose Overload
RedGate.SQLDataCompare.Engine Namespace


GetFileInfos Method

[image]

SQL Data Compare API 12.0.40
ComparisonSession..::.GetFileInfos Method
ComparisonSession Class See Also

TODO: better XML doc

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetFileInfos ( _
    tableMapping As TableMapping, _
    onTwo As Boolean _
) As IList(Of FileInfo)
C#
public IList<FileInfo> GetFileInfos(
    TableMapping tableMapping,
    bool onTwo
)
Visual C++
public:
IList<FileInfo^>^ GetFileInfos(
    TableMapping^ tableMapping,
    bool onTwo
)

Parameters

tableMapping
Type: RedGate.SQLDataCompare.Engine..::.TableMapping
onTwo
Type: Boolean

See Also

ComparisonSession Class
RedGate.SQLDataCompare.Engine Namespace


OnStatus Method

[image]

SQL Data Compare API 12.0.40
ComparisonSession..::.OnStatus Method
ComparisonSession Class See Also

Fires the status event handler.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub OnStatus ( _
    e As StatusEventArgs _
)
C#
protected void OnStatus(
    StatusEventArgs e
)
Visual C++
protected:
void OnStatus(
    StatusEventArgs^ e
)

Parameters

e
Type: RedGate.Shared.Utils..::.StatusEventArgs

See Also

ComparisonSession Class
RedGate.SQLDataCompare.Engine Namespace


RefreshSelectedItems Method

[image]

SQL Data Compare API 12.0.40
ComparisonSession..::.RefreshSelectedItems Method
ComparisonSession Class See Also

Refreshes the TableDifferences collection with any changes that have been made to the underlying data.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub RefreshSelectedItems
C#
public void RefreshSelectedItems()
Visual C++
public:
void RefreshSelectedItems()

See Also

ComparisonSession Class
RedGate.SQLDataCompare.Engine Namespace


ComparisonSession Properties

[image] [image]

SQL Data Compare API 12.0.40
ComparisonSession Properties
ComparisonSession Class See Also

The ComparisonSession type exposes the following properties.

Properties

Name | Description
Database1 | Returns the first database that is being compared.
Database2 | Returns the second database that is being compared.
IsDisposed | Returns a value indicating if this instance has been disposed. (Inherited from DisposableBase.)
Options | The options used when the databases are compared.
Status | The event handler used to receive status update events.
TableDifferences | The differences resulting from the database comparison.

See Also

ComparisonSession Class
RedGate.SQLDataCompare.Engine Namespace


Database1 Property

[image]

SQL Data Compare API 12.0.40
ComparisonSession..::.Database1 Property
ComparisonSession Class See Also

Returns the first database that is being compared.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Database1 As IDatabase
C#
public IDatabase Database1 { get; }
Visual C++
public:
property IDatabase^ Database1 {
    IDatabase^ get ();
}

See Also

ComparisonSession Class
RedGate.SQLDataCompare.Engine Namespace


Database2 Property

[image]

SQL Data Compare API 12.0.40
ComparisonSession..::.Database2 Property
ComparisonSession Class See Also

Returns the second database that is being compared.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Database2 As IDatabase
C#
public IDatabase Database2 { get; }
Visual C++
public:
property IDatabase^ Database2 {
    IDatabase^ get ();
}

See Also

ComparisonSession Class
RedGate.SQLDataCompare.Engine Namespace


Options Property

[image]

SQL Data Compare API 12.0.40
ComparisonSession..::.Options Property
ComparisonSession Class See Also

The options used when the databases are compared.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Options As EngineDataCompareOptions
C#
public EngineDataCompareOptions Options { get; set; }
Visual C++
public:
property EngineDataCompareOptions^ Options {
    EngineDataCompareOptions^ get ();
    void set (EngineDataCompareOptions^ value);
}

See Also

ComparisonSession Class
RedGate.SQLDataCompare.Engine Namespace


Status Property

[image]

SQL Data Compare API 12.0.40
ComparisonSession..::.Status Property
ComparisonSession Class Example See Also

The event handler used to receive status update events.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

Examples

See CompareDatabases(IDatabase, IDatabase, TableMappings, SessionSettings, Boolean) for an example of how to receive status events and cancel operations.

See Also

ComparisonSession Class
RedGate.SQLDataCompare.Engine Namespace


TableDifferences Property

[image]

SQL Data Compare API 12.0.40
ComparisonSession..::.TableDifferences Property
ComparisonSession Class Example See Also

The differences resulting from the database comparison.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TableDifferences As TableDifferences
C#
public TableDifferences TableDifferences { get; }
Visual C++
public:
property TableDifferences^ TableDifferences {
    TableDifferences^ get ();
}

Examples

See ComparisonSession for an example of how to use this.

See Also

ComparisonSession Class
RedGate.SQLDataCompare.Engine Namespace


ComparisonSessionException Class

[image]

SQL Data Compare API 12.0.40
ComparisonSessionException Class
Members See Also

Exception thrown by ComparisonSession when it encounters an error comparing the databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ComparisonSessionException _
    Inherits SqlDataCompareException
C#
[SerializableAttribute]
public class ComparisonSessionException : SqlDataCompareException
Visual C++
[SerializableAttribute]
public ref class ComparisonSessionException : public SqlDataCompareException

Inheritance Hierarchy

Object
Exception
RedGate.SQLDataCompare.Engine..::.SqlDataCompareException
RedGate.SQLDataCompare.Engine..::.ComparisonSessionException
RedGate.SQLDataCompare.Engine..::.ComparisonSessionSQLException

See Also

ComparisonSessionException Members
RedGate.SQLDataCompare.Engine Namespace


ComparisonSessionException Members

[image] [image]

SQL Data Compare API 12.0.40
ComparisonSessionException Members
ComparisonSessionException Class Constructors Methods Properties See Also

The ComparisonSessionException type exposes the following members.

Constructors

Name | Description
ComparisonSessionException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ComparisonSessionException Class
RedGate.SQLDataCompare.Engine Namespace


ComparisonSessionException Constructor

[image] [image]

SQL Data Compare API 12.0.40
ComparisonSessionException Constructor
ComparisonSessionException Class See Also

Overload List

Name | Description
ComparisonSessionException()()() | Creates a new exception.
ComparisonSessionException(String) | Creates a new exception with the specified detail message.
ComparisonSessionException(SerializationInfo, StreamingContext) | This constructor is called during deserialization to reconstitute the exception object transmitted over a stream. For more information, see XML and SOAP Serialization.
ComparisonSessionException(String, Exception) | Creates a new exception with the specified detail message and cause.

See Also

ComparisonSessionException Class
ComparisonSessionException Members
RedGate.SQLDataCompare.Engine Namespace


ComparisonSessionException Constructor

[image]

SQL Data Compare API 12.0.40
ComparisonSessionException Constructor
ComparisonSessionException Class See Also

Creates a new exception.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ComparisonSessionException()
Visual C++
public:
ComparisonSessionException()

See Also

ComparisonSessionException Class
ComparisonSessionException Overload
RedGate.SQLDataCompare.Engine Namespace


ComparisonSessionException Constructor ()

[image]

SQL Data Compare API 12.0.40
ComparisonSessionException Constructor ()
ComparisonSessionException Class See Also

Creates a new exception with the specified detail message.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public ComparisonSessionException(
    string message
)
Visual C++
public:
ComparisonSessionException(
    String^ message
)

Parameters

message
Type: String
Detail message.

See Also

ComparisonSessionException Class
ComparisonSessionException Overload
RedGate.SQLDataCompare.Engine Namespace


ComparisonSessionException Constructor (, )

[image]

SQL Data Compare API 12.0.40
ComparisonSessionException Constructor (, )
ComparisonSessionException Class See Also

This constructor is called during deserialization to reconstitute the exception object transmitted over a stream. For more information, see XML and SOAP Serialization.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected ComparisonSessionException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
ComparisonSessionException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: SerializationInfo
The object that holds the serialized object data.
context
Type: StreamingContext
The contextual information about the source or destination.

See Also

ComparisonSessionException Class
ComparisonSessionException Overload
RedGate.SQLDataCompare.Engine Namespace


ComparisonSessionException Constructor (, )

[image]

SQL Data Compare API 12.0.40
ComparisonSessionException Constructor (, )
ComparisonSessionException Class See Also

Creates a new exception with the specified detail message and cause.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    cause As Exception _
)
C#
public ComparisonSessionException(
    string message,
    Exception cause
)
Visual C++
public:
ComparisonSessionException(
    String^ message,
    Exception^ cause
)

Parameters

message
Type: String
Detail message.
cause
Type: Exception
Cause of exception.

See Also

ComparisonSessionException Class
ComparisonSessionException Overload
RedGate.SQLDataCompare.Engine Namespace


ComparisonSessionSQLException Class

[image]

SQL Data Compare API 12.0.40
ComparisonSessionSQLException Class
Members See Also

Exception thrown by ComparisonSession when it encounters an error comparing the databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ComparisonSessionSQLException _
    Inherits ComparisonSessionException
C#
[SerializableAttribute]
public class ComparisonSessionSQLException : ComparisonSessionException
Visual C++
[SerializableAttribute]
public ref class ComparisonSessionSQLException : public ComparisonSessionException

Inheritance Hierarchy

Object
Exception
RedGate.SQLDataCompare.Engine..::.SqlDataCompareException
RedGate.SQLDataCompare.Engine..::.ComparisonSessionException
RedGate.SQLDataCompare.Engine..::.ComparisonSessionSQLException

See Also

ComparisonSessionSQLException Members
RedGate.SQLDataCompare.Engine Namespace


ComparisonSessionSQLException Members

[image] [image]

SQL Data Compare API 12.0.40
ComparisonSessionSQLException Members
ComparisonSessionSQLException Class Constructors Methods Properties See Also

The ComparisonSessionSQLException type exposes the following members.

Constructors

Name | Description
ComparisonSessionSQLException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
DataSource1 | Whether the error Occurred on DataSource1
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
ReaderType | Get the Reader Type
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ComparisonSessionSQLException Class
RedGate.SQLDataCompare.Engine Namespace


ComparisonSessionSQLException Constructor

[image] [image]

SQL Data Compare API 12.0.40
ComparisonSessionSQLException Constructor
ComparisonSessionSQLException Class See Also

Overload List

Name | Description
ComparisonSessionSQLException()()() | Creates a new exception.
ComparisonSessionSQLException(String) | Creates a new exception with the specified detail message.
ComparisonSessionSQLException(SerializationInfo, StreamingContext) | This constructor is called during deserialization to reconstitute the exception object transmitted over a stream. For more information, see XML and SOAP Serialization.
ComparisonSessionSQLException(Boolean, ReaderType, String, Exception) | Creates a new exception with the specified detail message and cause.

See Also

ComparisonSessionSQLException Class
ComparisonSessionSQLException Members
RedGate.SQLDataCompare.Engine Namespace


ComparisonSessionSQLException Constructor

[image]

SQL Data Compare API 12.0.40
ComparisonSessionSQLException Constructor
ComparisonSessionSQLException Class See Also

Creates a new exception.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ComparisonSessionSQLException()
Visual C++
public:
ComparisonSessionSQLException()

See Also

ComparisonSessionSQLException Class
ComparisonSessionSQLException Overload
RedGate.SQLDataCompare.Engine Namespace


ComparisonSessionSQLException Constructor ()

[image]

SQL Data Compare API 12.0.40
ComparisonSessionSQLException Constructor ()
ComparisonSessionSQLException Class See Also

Creates a new exception with the specified detail message.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public ComparisonSessionSQLException(
    string message
)
Visual C++
public:
ComparisonSessionSQLException(
    String^ message
)

Parameters

message
Type: String
Detail message.

See Also

ComparisonSessionSQLException Class
ComparisonSessionSQLException Overload
RedGate.SQLDataCompare.Engine Namespace


ComparisonSessionSQLException Constructor (, )

[image]

SQL Data Compare API 12.0.40
ComparisonSessionSQLException Constructor (, )
ComparisonSessionSQLException Class See Also

This constructor is called during deserialization to reconstitute the exception object transmitted over a stream. For more information, see XML and SOAP Serialization.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected ComparisonSessionSQLException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
ComparisonSessionSQLException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: SerializationInfo
The object that holds the serialized object data.
context
Type: StreamingContext
The contextual information about the source or destination.

See Also

ComparisonSessionSQLException Class
ComparisonSessionSQLException Overload
RedGate.SQLDataCompare.Engine Namespace


ComparisonSessionSQLException Constructor (, ReaderType, , )

[image]

SQL Data Compare API 12.0.40
ComparisonSessionSQLException Constructor (, ReaderType, , )
ComparisonSessionSQLException Class See Also

Creates a new exception with the specified detail message and cause.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    dataSource1 As Boolean, _
    rt As ReaderType, _
    message As String, _
    cause As Exception _
)
C#
public ComparisonSessionSQLException(
    bool dataSource1,
    ReaderType rt,
    string message,
    Exception cause
)
Visual C++
public:
ComparisonSessionSQLException(
    bool dataSource1,
    ReaderType rt,
    String^ message,
    Exception^ cause
)

Parameters

dataSource1
Type: Boolean
Which datasource caused the error
rt
Type: RedGate.SQLDataCompare.Engine..::.ReaderType
Reader Type
message
Type: String
Detail message.
cause
Type: Exception
Cause of exception.

See Also

ComparisonSessionSQLException Class
ComparisonSessionSQLException Overload
RedGate.SQLDataCompare.Engine Namespace


ComparisonSessionSQLException Properties

[image] [image]

SQL Data Compare API 12.0.40
ComparisonSessionSQLException Properties
ComparisonSessionSQLException Class See Also

The ComparisonSessionSQLException type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
DataSource1 | Whether the error Occurred on DataSource1
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
ReaderType | Get the Reader Type
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ComparisonSessionSQLException Class
RedGate.SQLDataCompare.Engine Namespace


DataSource1 Property

[image]

SQL Data Compare API 12.0.40
ComparisonSessionSQLException..::.DataSource1 Property
ComparisonSessionSQLException Class See Also

Whether the error Occurred on DataSource1

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataSource1 As Boolean
C#
public bool DataSource1 { get; }
Visual C++
public:
property bool DataSource1 {
    bool get ();
}

See Also

ComparisonSessionSQLException Class
RedGate.SQLDataCompare.Engine Namespace


ReaderType Property

[image]

SQL Data Compare API 12.0.40
ComparisonSessionSQLException..::.ReaderType Property
ComparisonSessionSQLException Class See Also

Get the Reader Type

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReaderType As ReaderType
C#
public ReaderType ReaderType { get; }
Visual C++
public:
property ReaderType ReaderType {
    ReaderType get ();
}

See Also

ComparisonSessionSQLException Class
RedGate.SQLDataCompare.Engine Namespace


DataCompareMappings(TMapping, TMap) Generic Class

[image]

SQL Data Compare API 12.0.40
DataCompareMappings<(Of <(TMapping, TMap>)>) Generic Class
Members See Also

Base class of object mappings used in Data Compare.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class DataCompareMappings(Of TMapping As Mapping(Of TMap), TMap As {Class, IDatabaseObject}) _
    Inherits Mappings(Of TMapping, TMap, EngineDataCompareOptions)
C#
public abstract class DataCompareMappings<TMapping, TMap> : Mappings<TMapping, TMap, EngineDataCompareOptions> where TMapping : Mapping<TMap> where TMap : class, IDatabaseObject
Visual C++
generic<typename TMapping, typename TMap>
where TMapping : Mapping<TMap>
where TMap : ref class, IDatabaseObject
public ref class DataCompareMappings abstract : public Mappings<TMapping, TMap, EngineDataCompareOptions^>

Type Parameters

TMapping
The type of mapping object
TMap
The type stored in the mappings.

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( T >)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <(TMapping>)>)
RedGate.SQLCompare.Engine..::.Mappings <(Of <(TMapping, TMap, EngineDataCompareOptions >)>)
RedGate.SQLDataCompare.Engine..::.DataCompareMappings<(Of <(TMapping, TMap>)>)
RedGate.SQLDataCompare.Engine..::.FieldMappings
RedGate.SQLDataCompare.Engine..::.IndexMappings
RedGate.SQLDataCompare.Engine..::.SchemaMappings
RedGate.SQLDataCompare.Engine..::.TableMappings

See Also

DataCompareMappings<(Of <(TMapping, TMap>)>) Members
RedGate.SQLDataCompare.Engine Namespace


DataCompareMappings(TMapping, TMap) Members

[image] [image]

SQL Data Compare API 12.0.40
DataCompareMappings<(Of <(TMapping, TMap>)>) Members
DataCompareMappings<(Of <(TMapping, TMap>)>) Class Constructors Methods Fields Properties Explicit Interface Implementations See Also

The DataCompareMappings<(Of <(TMapping, TMap>)>) type exposes the following members.

Constructors

Name | Description
DataCompareMappings<(Of <(TMapping, TMap>)>) | Overloaded.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
CancelOperation | Cancels the current operation. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Clear | Removes all objects from the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Contains | Determines whether the Mappings instance contains a specified object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings<(Of <(U>)>) | Creates a mapping for each object in the collection where such a mapping is possible. All of the iteration is performed here and the matching can be affected by changing ShouldInclude(TMap, TMap, Object) in the sub class. The main action of joining to objects together is performed by Join(TMap, TMap) which can itself call CreateMappings on child database objects. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FromTwo | Returns the Mapping of the object in the second database. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Insert | Not Implemented. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Join | Attempts to join two objects in one mapping. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnValidate | Performs additional custom proccesses when validating a value. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RealAdd | Adds a mapping to this Mappings instance. This will change the forwards and backwards maps as necessary. This will break any mapping that will conflict with the added mapping. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RealRemove | Removes the specified object from the mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ShouldInclude | Called to determine if an object should be included in the mapping at all, one of the obj arguments is null. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Sort | Sorts the Mappings according the criteria appropriate for the object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Split | Splits a mapping and creates two mappings; one to null, and one from null. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Fields

Name | Description
m_Context | (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
m_PrepareString | (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

Properties

Name | Description
Context | Access to the mapping context. The type of the context is dependent on the mapped objects. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.
Options | The MappingOptions object currently used for mappings.
Status | The event handler used to receive status update events. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

DataCompareMappings<(Of <(TMapping, TMap>)>) Class
RedGate.SQLDataCompare.Engine Namespace


DataCompareMappings(TMapping, TMap) Constructor

[image] [image]

SQL Data Compare API 12.0.40
DataCompareMappings<(Of <(TMapping, TMap>)>) Constructor
DataCompareMappings<(Of <(TMapping, TMap>)>) Class See Also

Overload List

Name | Description
DataCompareMappings<(Of <(TMapping, TMap>)>)()()() | Default constructor.
DataCompareMappings<(Of <(TMapping, TMap>)>)(Mappings<(Of <(TMapping, TMap, EngineDataCompareOptions>)>)) | Shallow copy constructor.
DataCompareMappings<(Of <(TMapping, TMap>)>)(PrepareStringDelegate<(Of <(TMap, EngineDataCompareOptions>)>)) | Contructor used when string preparation delegate is being changed.

See Also

DataCompareMappings<(Of <(TMapping, TMap>)>) Class
DataCompareMappings<(Of <(TMapping, TMap>)>) Members
RedGate.SQLDataCompare.Engine Namespace


DataCompareMappings(TMapping, TMap) Constructor

[image]

SQL Data Compare API 12.0.40
DataCompareMappings<(Of <(TMapping, TMap>)>) Constructor
DataCompareMappings<(Of <(TMapping, TMap>)>) Class See Also

Default constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected DataCompareMappings()
Visual C++
protected:
DataCompareMappings()

See Also

DataCompareMappings<(Of <(TMapping, TMap>)>) Class
DataCompareMappings<(Of <(TMapping, TMap>)>) Overload
RedGate.SQLDataCompare.Engine Namespace


DataCompareMappings(TMapping, TMap) Constructor (Mappings(TMapping, TMap, EngineDataCompareOptions))

[image]

SQL Data Compare API 12.0.40
DataCompareMappings<(Of <(TMapping, TMap>)>) Constructor (Mappings<(Of <(TMapping, TMap, EngineDataCompareOptions>)>))
DataCompareMappings<(Of <(TMapping, TMap>)>) Class See Also

Shallow copy constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    mappings As Mappings(Of TMapping, TMap, EngineDataCompareOptions) _
)
C#
protected DataCompareMappings(
    Mappings<TMapping, TMap, EngineDataCompareOptions> mappings
)
Visual C++
protected:
DataCompareMappings(
    Mappings<TMapping, TMap, EngineDataCompareOptions^>^ mappings
)

Parameters

mappings
Type: RedGate.SQLCompare.Engine..::.Mappings <(Of <( TMapping, TMap, EngineDataCompareOptions >)>)
Mappings to copy.

See Also

DataCompareMappings<(Of <(TMapping, TMap>)>) Class
DataCompareMappings<(Of <(TMapping, TMap>)>) Overload
RedGate.SQLDataCompare.Engine Namespace


DataCompareMappings(TMapping, TMap) Constructor (PrepareStringDelegate(TMap, EngineDataCompareOptions))

[image]

SQL Data Compare API 12.0.40
DataCompareMappings<(Of <(TMapping, TMap>)>) Constructor (PrepareStringDelegate<(Of <(TMap, EngineDataCompareOptions>)>))
DataCompareMappings<(Of <(TMapping, TMap>)>) Class See Also

Contructor used when string preparation delegate is being changed.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    prepareStringDelegate As PrepareStringDelegate(Of TMap, EngineDataCompareOptions) _
)
C#
protected DataCompareMappings(
    PrepareStringDelegate<TMap, EngineDataCompareOptions> prepareStringDelegate
)
Visual C++
protected:
DataCompareMappings(
    PrepareStringDelegate<TMap, EngineDataCompareOptions^>^ prepareStringDelegate
)

Parameters

prepareStringDelegate
Type: RedGate.SQLCompare.Engine..::.PrepareStringDelegate <(Of <( TMap, EngineDataCompareOptions >)>)
Function to be used to prepare string.

See Also

DataCompareMappings<(Of <(TMapping, TMap>)>) Class
DataCompareMappings<(Of <(TMapping, TMap>)>) Overload
RedGate.SQLDataCompare.Engine Namespace


DataCompareMappings(TMapping, TMap) Properties

[image] [image]

SQL Data Compare API 12.0.40
DataCompareMappings<(Of <(TMapping, TMap>)>) Properties
DataCompareMappings<(Of <(TMapping, TMap>)>) Class See Also

The DataCompareMappings<(Of <(TMapping, TMap>)>) type exposes the following properties.

Properties

Name | Description
Context | Access to the mapping context. The type of the context is dependent on the mapped objects. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.
Options | The MappingOptions object currently used for mappings.
Status | The event handler used to receive status update events. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

See Also

DataCompareMappings<(Of <(TMapping, TMap>)>) Class
RedGate.SQLDataCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
DataCompareMappings<(Of <(TMapping, TMap>)>)..::.Item Property
DataCompareMappings<(Of <(TMapping, TMap>)>) Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Gets the Mapping<(Of <(T>)>) at the specified index. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Item[([(String])]) | Gets the mapping of the specified object name, first attempting to match against objects in the first database, then matching against objects in the second database. Returns null if a mapping is not found. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

See Also

DataCompareMappings<(Of <(TMapping, TMap>)>) Class
DataCompareMappings<(Of <(TMapping, TMap>)>) Members
RedGate.SQLDataCompare.Engine Namespace


Options Property

[image]

SQL Data Compare API 12.0.40
DataCompareMappings<(Of <(TMapping, TMap>)>)..::.Options Property
DataCompareMappings<(Of <(TMapping, TMap>)>) Class See Also

The MappingOptions object currently used for mappings.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Options As EngineDataCompareOptions
C#
public EngineDataCompareOptions Options { get; set; }
Visual C++
public:
property EngineDataCompareOptions^ Options {
    EngineDataCompareOptions^ get ();
    void set (EngineDataCompareOptions^ value);
}

See Also

DataCompareMappings<(Of <(TMapping, TMap>)>) Class
RedGate.SQLDataCompare.Engine Namespace


DataCompareUserActions Class

[image]

SQL Data Compare API 12.0.40
DataCompareUserActions Class
Members See Also

Methods used to handle loading the user-actions section of a Data Compare project.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataCompareUserActions
C#
public static class DataCompareUserActions
Visual C++
public ref class DataCompareUserActions abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLDataCompare.Engine..::.DataCompareUserActions

See Also

DataCompareUserActions Members
RedGate.SQLDataCompare.Engine Namespace


DataCompareUserActions Members

[image] [image]

SQL Data Compare API 12.0.40
DataCompareUserActions Members
DataCompareUserActions Class Methods See Also

The DataCompareUserActions type exposes the following members.

Methods

Name | Description
ReplayUserActions | Replays the selections, custom mappings, and WHERE clause settings that the user has made before saving the project. Modifies the passed SchemaMappings to reflect the user changes.

See Also

DataCompareUserActions Class
RedGate.SQLDataCompare.Engine Namespace


DataCompareUserActions Methods

[image] [image]

SQL Data Compare API 12.0.40
DataCompareUserActions Methods
DataCompareUserActions Class See Also

The DataCompareUserActions type exposes the following methods.

Methods

Name | Description
ReplayUserActions | Replays the selections, custom mappings, and WHERE clause settings that the user has made before saving the project. Modifies the passed SchemaMappings to reflect the user changes.

See Also

DataCompareUserActions Class
RedGate.SQLDataCompare.Engine Namespace


ReplayUserActions Method

[image]

SQL Data Compare API 12.0.40
DataCompareUserActions..::.ReplayUserActions Method
DataCompareUserActions Class See Also

Replays the selections, custom mappings, and WHERE clause settings that the user has made before saving the project. Modifies the passed SchemaMappings to reflect the user changes.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ReplayUserActions ( _
    selectTableActions As IList(Of SelectTableEvent), _
    ds1 As IDataSource, _
    ds2 As IDataSource, _
    ByRef schemaMappings As SchemaMappings _
) As List(Of UserActionWarning)
C#
public static List<UserActionWarning> ReplayUserActions(
    IList<SelectTableEvent> selectTableActions,
    IDataSource ds1,
    IDataSource ds2,
    ref SchemaMappings schemaMappings
)
Visual C++
public:
static List<UserActionWarning>^ ReplayUserActions(
    IList<SelectTableEvent>^ selectTableActions,
    IDataSource^ ds1,
    IDataSource^ ds2,
    SchemaMappings^% schemaMappings
)

Parameters

selectTableActions
Type: IList<(Of <( SelectTableEvent >)>)
ds1
Type: RedGate.Shared.SQL..::.IDataSource
ds2
Type: RedGate.Shared.SQL..::.IDataSource
schemaMappings
Type: RedGate.SQLDataCompare.Engine..::.SchemaMappings %

Return Value

A list of the selections, custom mappings, and WHERE clause settings that could not be replayed due to changes in the database schema.

See Also

DataCompareUserActions Class
RedGate.SQLDataCompare.Engine Namespace


DataCompareVariant Class

[image]

SQL Data Compare API 12.0.40
DataCompareVariant Class
Members See Also

Wrapper class for the SQL Variant data type.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class DataCompareVariant _
    Implements IComparable
C#
public class DataCompareVariant : IComparable
Visual C++
public ref class DataCompareVariant : IComparable

Inheritance Hierarchy

Object
RedGate.SQLDataCompare.Engine..::.DataCompareVariant

See Also

DataCompareVariant Members
RedGate.SQLDataCompare.Engine Namespace


DataCompareVariant Members

[image] [image]

SQL Data Compare API 12.0.40
DataCompareVariant Members
DataCompareVariant Class Methods Properties See Also

The DataCompareVariant type exposes the following members.

Methods

Name | Description
CompareTo | Compare the DataCompareVariant object with another object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Shows the string value of the DataCompareVariant object. (Overrides Object..::.ToString()()().)

Properties

Name | Description
BaseType | The base type of the underlying SQL Variant.
Collation | The collation of the SQL Variant.
MaxLength | The maximum data type length of the SQL Variant.
Precision | The precision of the SQL Variant.
Scale | The scale of the SQL Variant.
Value | The value of the SQL Variant.

See Also

DataCompareVariant Class
RedGate.SQLDataCompare.Engine Namespace


DataCompareVariant Methods

[image] [image]

SQL Data Compare API 12.0.40
DataCompareVariant Methods
DataCompareVariant Class See Also

The DataCompareVariant type exposes the following methods.

Methods

Name | Description
CompareTo | Compare the DataCompareVariant object with another object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Shows the string value of the DataCompareVariant object. (Overrides Object..::.ToString()()().)

See Also

DataCompareVariant Class
RedGate.SQLDataCompare.Engine Namespace


CompareTo Method

[image]

SQL Data Compare API 12.0.40
DataCompareVariant..::.CompareTo Method
DataCompareVariant Class See Also

Compare the DataCompareVariant object with another object.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareTo ( _
    obj As Object _
) As Integer
C#
public int CompareTo(
    Object obj
)
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: Object
The object to compare.

Return Value

Returns -1, 0, or 1.

Implements

IComparableCompareTo(Object)

See Also

DataCompareVariant Class
RedGate.SQLDataCompare.Engine Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
DataCompareVariant..::.ToString Method
DataCompareVariant Class See Also

Shows the string value of the DataCompareVariant object.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

Return Value

The string value of the the DataCompareVariant object.

See Also

DataCompareVariant Class
RedGate.SQLDataCompare.Engine Namespace


DataCompareVariant Properties

[image] [image]

SQL Data Compare API 12.0.40
DataCompareVariant Properties
DataCompareVariant Class See Also

The DataCompareVariant type exposes the following properties.

Properties

Name | Description
BaseType | The base type of the underlying SQL Variant.
Collation | The collation of the SQL Variant.
MaxLength | The maximum data type length of the SQL Variant.
Precision | The precision of the SQL Variant.
Scale | The scale of the SQL Variant.
Value | The value of the SQL Variant.

See Also

DataCompareVariant Class
RedGate.SQLDataCompare.Engine Namespace


BaseType Property

[image]

SQL Data Compare API 12.0.40
DataCompareVariant..::.BaseType Property
DataCompareVariant Class See Also

The base type of the underlying SQL Variant.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BaseType As String
C#
public string BaseType { get; }
Visual C++
public:
property String^ BaseType {
    String^ get ();
}

See Also

DataCompareVariant Class
RedGate.SQLDataCompare.Engine Namespace


Collation Property

[image]

SQL Data Compare API 12.0.40
DataCompareVariant..::.Collation Property
DataCompareVariant Class See Also

The collation of the SQL Variant.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Collation As String
C#
public string Collation { get; }
Visual C++
public:
property String^ Collation {
    String^ get ();
}

See Also

DataCompareVariant Class
RedGate.SQLDataCompare.Engine Namespace


MaxLength Property

[image]

SQL Data Compare API 12.0.40
DataCompareVariant..::.MaxLength Property
DataCompareVariant Class See Also

The maximum data type length of the SQL Variant.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MaxLength As Integer
C#
public int MaxLength { get; }
Visual C++
public:
property int MaxLength {
    int get ();
}

Remarks

MaxLength is in bytes so for example the MaxLength of nvarchar(50) is 100.

See Also

DataCompareVariant Class
RedGate.SQLDataCompare.Engine Namespace


Precision Property

[image]

SQL Data Compare API 12.0.40
DataCompareVariant..::.Precision Property
DataCompareVariant Class See Also

The precision of the SQL Variant.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Precision As Integer
C#
public int Precision { get; }
Visual C++
public:
property int Precision {
    int get ();
}

See Also

DataCompareVariant Class
RedGate.SQLDataCompare.Engine Namespace


Scale Property

[image]

SQL Data Compare API 12.0.40
DataCompareVariant..::.Scale Property
DataCompareVariant Class See Also

The scale of the SQL Variant.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Scale As Integer
C#
public int Scale { get; }
Visual C++
public:
property int Scale {
    int get ();
}

See Also

DataCompareVariant Class
RedGate.SQLDataCompare.Engine Namespace


Value Property

[image]

SQL Data Compare API 12.0.40
DataCompareVariant..::.Value Property
DataCompareVariant Class See Also

The value of the SQL Variant.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Object
C#
public Object Value { get; }
Visual C++
public:
property Object^ Value {
    Object^ get ();
}

See Also

DataCompareVariant Class
RedGate.SQLDataCompare.Engine Namespace


DifferencesSummary Class

[image]

SQL Data Compare API 12.0.40
DifferencesSummary Class
Members See Also

Holds information about the differences in the ResultsStore.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DifferencesSummary
C#
public sealed class DifferencesSummary
Visual C++
public ref class DifferencesSummary sealed

Inheritance Hierarchy

Object
RedGate.SQLDataCompare.Engine..::.DifferencesSummary

See Also

DifferencesSummary Members
RedGate.SQLDataCompare.Engine Namespace


DifferencesSummary Members

[image] [image]

SQL Data Compare API 12.0.40
DifferencesSummary Members
DifferencesSummary Class Methods Properties See Also

The DifferencesSummary type exposes the following members.

Methods

Name | Description
DifferenceCount | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RepeatedKeys | If true, the matching keys for the table were not unique, and therefore synchronization may not be possible.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Different | Obsolete. The number of rows that exist in both databases but are different.
HasBackingStore1 | Whether the first database has a backing store for the difference that this summary represents
HasBackingStore2 | Whether the second database has a backing store for the difference that this summary represents
In1 | Obsolete. The number of rows only in the second database.
In2 | Obsolete. The number of rows only in the first database.
Same | Obsolete. The number of rows that are the same in both databases.

See Also

DifferencesSummary Class
RedGate.SQLDataCompare.Engine Namespace


DifferencesSummary Methods

[image] [image]

SQL Data Compare API 12.0.40
DifferencesSummary Methods
DifferencesSummary Class See Also

The DifferencesSummary type exposes the following methods.

Methods

Name | Description
DifferenceCount | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RepeatedKeys | If true, the matching keys for the table were not unique, and therefore synchronization may not be possible.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DifferencesSummary Class
RedGate.SQLDataCompare.Engine Namespace


DifferenceCount Method

[image] [image]

SQL Data Compare API 12.0.40
DifferencesSummary..::.DifferenceCount Method
DifferencesSummary Class See Also

Overload List

Name | Description
DifferenceCount()()() | Returns the number of rows that are different.
DifferenceCount(FieldPair) | Returns the number of rows of the specified fieldPair that are different.
DifferenceCount(Row..::.RowType) | Returns the number of rows of the specified rowType that are different.
DifferenceCount(Row..::.RowType, FieldPair) | Returns the number of different fields of the specified RowType and FieldPair.

See Also

DifferencesSummary Class
DifferencesSummary Members
RedGate.SQLDataCompare.Engine Namespace


DifferenceCount Method

[image]

SQL Data Compare API 12.0.40
DifferencesSummary..::.DifferenceCount Method
DifferencesSummary Class See Also

Returns the number of rows that are different.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function DifferenceCount As Integer
C#
public int DifferenceCount()
Visual C++
public:
int DifferenceCount()

Return Value

The number of rows that are different.

See Also

DifferencesSummary Class
DifferenceCount Overload
RedGate.SQLDataCompare.Engine Namespace


DifferenceCount Method (FieldPair)

[image]

SQL Data Compare API 12.0.40
DifferencesSummary..::.DifferenceCount Method (FieldPair)
DifferencesSummary Class See Also

Returns the number of rows of the specified fieldPair that are different.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function DifferenceCount ( _
    fieldPair As FieldPair _
) As Integer
C#
public int DifferenceCount(
    FieldPair fieldPair
)
Visual C++
public:
int DifferenceCount(
    FieldPair^ fieldPair
)

Parameters

fieldPair
Type: RedGate.SQLDataCompare.Engine..::.FieldPair
The field for the count.

Return Value

The number of rows for the specified fieldPair that are different.

See Also

DifferencesSummary Class
DifferenceCount Overload
RedGate.SQLDataCompare.Engine Namespace


DifferenceCount Method (Row.RowType)

[image]

SQL Data Compare API 12.0.40
DifferencesSummary..::.DifferenceCount Method (Row..::.RowType)
DifferencesSummary Class See Also

Returns the number of rows of the specified rowType that are different.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function DifferenceCount ( _
    rowType As Row..::.RowType _
) As Integer
C#
public int DifferenceCount(
    Row..::.RowType rowType
)
Visual C++
public:
int DifferenceCount(
    Row..::.RowType rowType
)

Parameters

rowType
Type: RedGate.SQLDataCompare.Engine.ResultsStore..::.Row..::.RowType
The type of rows to be for the returned count.

Return Value

The number of rows of the specified rowType that are different.

See Also

DifferencesSummary Class
DifferenceCount Overload
RedGate.SQLDataCompare.Engine Namespace


DifferenceCount Method (Row.RowType, FieldPair)

[image]

SQL Data Compare API 12.0.40
DifferencesSummary..::.DifferenceCount Method (Row..::.RowType, FieldPair)
DifferencesSummary Class See Also

Returns the number of different fields of the specified RowType and FieldPair.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function DifferenceCount ( _
    rowType As Row..::.RowType, _
    fieldPair As FieldPair _
) As Integer
C#
public int DifferenceCount(
    Row..::.RowType rowType,
    FieldPair fieldPair
)
Visual C++
public:
int DifferenceCount(
    Row..::.RowType rowType,
    FieldPair^ fieldPair
)

Parameters

rowType
Type: RedGate.SQLDataCompare.Engine.ResultsStore..::.Row..::.RowType
The type of rows for the returned count.
fieldPair
Type: RedGate.SQLDataCompare.Engine..::.FieldPair
The FieldPair for which you want the count.

Return Value

The number of fields of the specified RowType and FieldPair that are different.

See Also

DifferencesSummary Class
DifferenceCount Overload
RedGate.SQLDataCompare.Engine Namespace


RepeatedKeys Method

[image]

SQL Data Compare API 12.0.40
DifferencesSummary..::.RepeatedKeys Method
DifferencesSummary Class See Also

If true, the matching keys for the table were not unique, and therefore synchronization may not be possible.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function RepeatedKeys ( _
    runOnTwo As Boolean _
) As Boolean
C#
public bool RepeatedKeys(
    bool runOnTwo
)
Visual C++
public:
bool RepeatedKeys(
    bool runOnTwo
)

Parameters

runOnTwo
Type: Boolean
True to run on the second database.

See Also

DifferencesSummary Class
RedGate.SQLDataCompare.Engine Namespace


DifferencesSummary Properties

[image] [image]

SQL Data Compare API 12.0.40
DifferencesSummary Properties
DifferencesSummary Class See Also

The DifferencesSummary type exposes the following properties.

Properties

Name | Description
Different | Obsolete. The number of rows that exist in both databases but are different.
HasBackingStore1 | Whether the first database has a backing store for the difference that this summary represents
HasBackingStore2 | Whether the second database has a backing store for the difference that this summary represents
In1 | Obsolete. The number of rows only in the second database.
In2 | Obsolete. The number of rows only in the first database.
Same | Obsolete. The number of rows that are the same in both databases.

See Also

DifferencesSummary Class
RedGate.SQLDataCompare.Engine Namespace


Different Property

[image]

SQL Data Compare API 12.0.40
DifferencesSummary..::.Different Property
DifferencesSummary Class See Also

The number of rows that exist in both databases but are different.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Please use DifferenceCount(Row.RowType.Different)")> _
Public ReadOnly Property Different As Integer
C#
[ObsoleteAttribute("Please use DifferenceCount(Row.RowType.Different)")]
public int Different { get; }
Visual C++
[ObsoleteAttribute(L"Please use DifferenceCount(Row.RowType.Different)")]
public:
property int Different {
    int get ();
}

See Also

DifferencesSummary Class
RedGate.SQLDataCompare.Engine Namespace


HasBackingStore1 Property

[image]

SQL Data Compare API 12.0.40
DifferencesSummary..::.HasBackingStore1 Property
DifferencesSummary Class See Also

Whether the first database has a backing store for the difference that this summary represents

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasBackingStore1 As Boolean
C#
public bool HasBackingStore1 { get; }
Visual C++
public:
property bool HasBackingStore1 {
    bool get ();
}

See Also

DifferencesSummary Class
RedGate.SQLDataCompare.Engine Namespace


HasBackingStore2 Property

[image]

SQL Data Compare API 12.0.40
DifferencesSummary..::.HasBackingStore2 Property
DifferencesSummary Class See Also

Whether the second database has a backing store for the difference that this summary represents

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasBackingStore2 As Boolean
C#
public bool HasBackingStore2 { get; }
Visual C++
public:
property bool HasBackingStore2 {
    bool get ();
}

See Also

DifferencesSummary Class
RedGate.SQLDataCompare.Engine Namespace


In1 Property

[image]

SQL Data Compare API 12.0.40
DifferencesSummary..::.In1 Property
DifferencesSummary Class See Also

The number of rows only in the second database.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Please use DifferenceCount(Row.RowType.In1)")> _
Public ReadOnly Property In1 As Integer
C#
[ObsoleteAttribute("Please use DifferenceCount(Row.RowType.In1)")]
public int In1 { get; }
Visual C++
[ObsoleteAttribute(L"Please use DifferenceCount(Row.RowType.In1)")]
public:
property int In1 {
    int get ();
}

See Also

DifferencesSummary Class
RedGate.SQLDataCompare.Engine Namespace


In2 Property

[image]

SQL Data Compare API 12.0.40
DifferencesSummary..::.In2 Property
DifferencesSummary Class See Also

The number of rows only in the first database.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Please use DifferenceCount(Row.RowType.In2)")> _
Public ReadOnly Property In2 As Integer
C#
[ObsoleteAttribute("Please use DifferenceCount(Row.RowType.In2)")]
public int In2 { get; }
Visual C++
[ObsoleteAttribute(L"Please use DifferenceCount(Row.RowType.In2)")]
public:
property int In2 {
    int get ();
}

See Also

DifferencesSummary Class
RedGate.SQLDataCompare.Engine Namespace


Same Property

[image]

SQL Data Compare API 12.0.40
DifferencesSummary..::.Same Property
DifferencesSummary Class See Also

The number of rows that are the same in both databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Please use DifferenceCount(Row.RowType.Same)")> _
Public ReadOnly Property Same As Integer
C#
[ObsoleteAttribute("Please use DifferenceCount(Row.RowType.Same)")]
public int Same { get; }
Visual C++
[ObsoleteAttribute(L"Please use DifferenceCount(Row.RowType.Same)")]
public:
property int Same {
    int get ();
}

See Also

DifferencesSummary Class
RedGate.SQLDataCompare.Engine Namespace


EnumerableExtensions Class

[image]

SQL Data Compare API 12.0.40
EnumerableExtensions Class
Members See Also

Extensions on IEnumerable, which should no longer be required when we move to .Net 4. Provides the Zip method that .Net 4 includes. TODO: remove when using .NET 4

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class EnumerableExtensions
C#
public static class EnumerableExtensions
Visual C++
public ref class EnumerableExtensions abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLDataCompare.Engine..::.EnumerableExtensions

See Also

EnumerableExtensions Members
RedGate.SQLDataCompare.Engine Namespace


EnumerableExtensions Members

[image] [image]

SQL Data Compare API 12.0.40
EnumerableExtensions Members
EnumerableExtensions Class Methods See Also

The EnumerableExtensions type exposes the following members.

Methods

Name | Description
Zip<(Of <(TFirst, TSecond, TResult>)>) | Equivalent of the .Net 4 Zip method. taken from http://blogs.msdn.com/b/ericlippert/archive/2009/05/07/zip-me-up.aspx

See Also

EnumerableExtensions Class
RedGate.SQLDataCompare.Engine Namespace


EnumerableExtensions Methods

[image] [image]

SQL Data Compare API 12.0.40
EnumerableExtensions Methods
EnumerableExtensions Class See Also

The EnumerableExtensions type exposes the following methods.

Methods

Name | Description
Zip<(Of <(TFirst, TSecond, TResult>)>) | Equivalent of the .Net 4 Zip method. taken from http://blogs.msdn.com/b/ericlippert/archive/2009/05/07/zip-me-up.aspx

See Also

EnumerableExtensions Class
RedGate.SQLDataCompare.Engine Namespace


Zip(TFirst, TSecond, TResult) Generic Method

[image]

SQL Data Compare API 12.0.40
EnumerableExtensions..::.Zip<(Of <(TFirst, TSecond, TResult>)>) Generic Method
EnumerableExtensions Class See Also

Equivalent of the .Net 4 Zip method. taken from http://blogs.msdn.com/b/ericlippert/archive/2009/05/07/zip-me-up.aspx

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Zip(Of TFirst, TSecond, TResult) ( _
    first As IEnumerable(Of TFirst), _
    second As IEnumerable(Of TSecond), _
    resultSelector As Func(Of TFirst, TSecond, TResult) _
) As IEnumerable(Of TResult)
C#
public static IEnumerable<TResult> Zip<TFirst, TSecond, TResult>(
    IEnumerable<TFirst> first,
    IEnumerable<TSecond> second,
    Func<TFirst, TSecond, TResult> resultSelector
)
Visual C++
public:
generic<typename TFirst, typename TSecond, typename TResult>
static IEnumerable<TResult>^ Zip(
    IEnumerable<TFirst>^ first,
    IEnumerable<TSecond>^ second,
    Func<TFirst, TSecond, TResult>^ resultSelector
)

Parameters

first
Type: IEnumerable<(Of <(TFirst>)>)
second
Type: IEnumerable<(Of <(TSecond>)>)
resultSelector
Type: Func<(Of <(TFirst, TSecond, TResult>)>)

Type Parameters

TFirst
TSecond
TResult

See Also

EnumerableExtensions Class
RedGate.SQLDataCompare.Engine Namespace


FieldMapping Class

[image]

SQL Data Compare API 12.0.40
FieldMapping Class
Members See Also

Contains a mapping from a field in one table to a field in another table.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class FieldMapping _
    Inherits Mapping(Of IndexField)
C#
public class FieldMapping : Mapping<IndexField>
Visual C++
public ref class FieldMapping : public Mapping<IndexField^>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.Mapping <(Of <( IndexField >)>)
RedGate.SQLDataCompare.Engine..::.FieldMapping

See Also

FieldMapping Members
RedGate.SQLDataCompare.Engine Namespace


FieldMapping Members

[image] [image]

SQL Data Compare API 12.0.40
FieldMapping Members
FieldMapping Class Constructors Methods Fields Properties Explicit Interface Implementations See Also

The FieldMapping type exposes the following members.

Constructors

Name | Description
FieldMapping | Constructor. Calls the base constructor.

Methods

Name | Description
Clone | Creates a shallow copy of the field mapping. (Overrides Mapping <(Of <( IndexField >)>)..::. Clone()()().)
CompareTo | Sorts the FieldMappings by fully-qualified name in the first database; if null in the first database, sorts by fully-qualified name in the second database. (Overrides Mapping <(Of <( IndexField >)>)..::. CompareTo(Mapping<(Of <(T>)>)).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Mapping<(Of <(T>)>).)

Fields

Name | Description
m_Messages | (Inherited from Mapping<(Of <(T>)>).)

Properties

Name | Description
Include | Specifies whether the mapping is to be included. (Inherited from Mapping<(Of <(T>)>).)
Messages | Messages that explain any issues concerning the mapping; null if no issues exist. (Inherited from Mapping<(Of <(T>)>).)
Obj1 | Returns the object from the first database (Inherited from Mapping<(Of <(T>)>).)
Obj2 | Returns the object from the second database (Inherited from Mapping<(Of <(T>)>).)
Status | The status of the field mapping.
ValidForMatching | Specifies whether the FieldMapping can be used in a matching mapping.

Explicit Interface Implementations

Name | Description
ICloneableClone | Creates a shallow copy. (Inherited from Mapping<(Of <(T>)>).)

See Also

FieldMapping Class
RedGate.SQLDataCompare.Engine Namespace


FieldMapping Constructor

[image]

SQL Data Compare API 12.0.40
FieldMapping Constructor
FieldMapping Class See Also

Constructor. Calls the base constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    obj1 As IndexField, _
    obj2 As IndexField, _
    status As FieldMappingStatus _
)
C#
public FieldMapping(
    IndexField obj1,
    IndexField obj2,
    FieldMappingStatus status
)
Visual C++
public:
FieldMapping(
    IndexField^ obj1,
    IndexField^ obj2,
    FieldMappingStatus status
)

Parameters

obj1
Type: RedGate.SQLCompare.Engine.Model..::.IndexField
The field in the first database.
obj2
Type: RedGate.SQLCompare.Engine.Model..::.IndexField
The field in the second database.
status
Type: RedGate.SQLDataCompare.Engine..::.FieldMappingStatus
The status of the mapping.

See Also

FieldMapping Class
RedGate.SQLDataCompare.Engine Namespace


FieldMapping Methods

[image] [image]

SQL Data Compare API 12.0.40
FieldMapping Methods
FieldMapping Class See Also

The FieldMapping type exposes the following methods.

Methods

Name | Description
Clone | Creates a shallow copy of the field mapping. (Overrides Mapping <(Of <( IndexField >)>)..::. Clone()()().)
CompareTo | Sorts the FieldMappings by fully-qualified name in the first database; if null in the first database, sorts by fully-qualified name in the second database. (Overrides Mapping <(Of <( IndexField >)>)..::. CompareTo(Mapping<(Of <(T>)>)).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Mapping<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
ICloneableClone | Creates a shallow copy. (Inherited from Mapping<(Of <(T>)>).)

See Also

FieldMapping Class
RedGate.SQLDataCompare.Engine Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
FieldMapping..::.Clone Method
FieldMapping Class See Also

Creates a shallow copy of the field mapping.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone As Mapping(Of IndexField)
C#
public override Mapping<IndexField> Clone()
Visual C++
public:
virtual Mapping<IndexField^>^ Clone() override

Return Value

A shallow copy of the field mapping.

See Also

FieldMapping Class
RedGate.SQLDataCompare.Engine Namespace


CompareTo Method

[image]

SQL Data Compare API 12.0.40
FieldMapping..::.CompareTo Method
FieldMapping Class See Also

Sorts the FieldMappings by fully-qualified name in the first database; if null in the first database, sorts by fully-qualified name in the second database.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function CompareTo ( _
    obj As Mapping(Of IndexField) _
) As Integer
C#
public override int CompareTo(
    Mapping<IndexField> obj
)
Visual C++
public:
virtual int CompareTo(
    Mapping<IndexField^>^ obj
) override

Parameters

obj
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( IndexField >)>)
The object to be compared.

Return Value

Less than zero when this instance is less than the specified object; zero when this instance is equal to the specified object; greater then zero when this instance is greater than the specified object.

Implements

IComparableCompareTo(UTP)

See Also

FieldMapping Class
RedGate.SQLDataCompare.Engine Namespace


FieldMapping Properties

[image] [image]

SQL Data Compare API 12.0.40
FieldMapping Properties
FieldMapping Class See Also

The FieldMapping type exposes the following properties.

Properties

Name | Description
Include | Specifies whether the mapping is to be included. (Inherited from Mapping<(Of <(T>)>).)
Messages | Messages that explain any issues concerning the mapping; null if no issues exist. (Inherited from Mapping<(Of <(T>)>).)
Obj1 | Returns the object from the first database (Inherited from Mapping<(Of <(T>)>).)
Obj2 | Returns the object from the second database (Inherited from Mapping<(Of <(T>)>).)
Status | The status of the field mapping.
ValidForMatching | Specifies whether the FieldMapping can be used in a matching mapping.

See Also

FieldMapping Class
RedGate.SQLDataCompare.Engine Namespace


Status Property

[image]

SQL Data Compare API 12.0.40
FieldMapping..::.Status Property
FieldMapping Class See Also

The status of the field mapping.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Status As FieldMappingStatus
C#
public FieldMappingStatus Status { get; }
Visual C++
public:
property FieldMappingStatus Status {
    FieldMappingStatus get ();
}

See Also

FieldMapping Class
RedGate.SQLDataCompare.Engine Namespace


ValidForMatching Property

[image]

SQL Data Compare API 12.0.40
FieldMapping..::.ValidForMatching Property
FieldMapping Class See Also

Specifies whether the FieldMapping can be used in a matching mapping.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ValidForMatching As Boolean
C#
public bool ValidForMatching { get; }
Visual C++
public:
property bool ValidForMatching {
    bool get ();
}

See Also

FieldMapping Class
RedGate.SQLDataCompare.Engine Namespace


FieldMappings Class

[image]

SQL Data Compare API 12.0.40
FieldMappings Class
Members See Also

Holds mappings for fields in a table or view.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class FieldMappings _
    Inherits DataCompareMappings(Of FieldMapping, IndexField)
C#
public class FieldMappings : DataCompareMappings<FieldMapping, IndexField>
Visual C++
public ref class FieldMappings : public DataCompareMappings<FieldMapping^, IndexField^>

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( T >)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( FieldMapping >)>)
RedGate.SQLCompare.Engine..::.Mappings <(Of <( FieldMapping, IndexField, EngineDataCompareOptions >)>)
RedGate.SQLDataCompare.Engine..::.DataCompareMappings <(Of <( FieldMapping, IndexField >)>)
RedGate.SQLDataCompare.Engine..::.FieldMappings

See Also

FieldMappings Members
RedGate.SQLDataCompare.Engine Namespace


FieldMappings Members

[image] [image]

SQL Data Compare API 12.0.40
FieldMappings Members
FieldMappings Class Constructors Methods Fields Properties Explicit Interface Implementations See Also

The FieldMappings type exposes the following members.

Constructors

Name | Description
FieldMappings | Overloaded.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
CanBeMapped | Returns true if the two fields can be mapped together because the types can be compared by the SQL Data Compare engine.
CancelOperation | Cancels the current operation. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Clear | Removes all objects from the FieldMappings instance. (Overrides Mappings <(Of <( FieldMapping, IndexField, EngineDataCompareOptions >)>)..::. Clear()()().)
Contains | Determines whether the Mappings instance contains a specified object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FromTwo | Returns the Mapping of the object in the second database. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Insert | Not Implemented. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Join | Joins two fields in the different databases, and returns the created mapping. The mapping may not have its status set as Success if the field types are incompatible. (Overrides Mappings <(Of <( FieldMapping, IndexField, EngineDataCompareOptions >)>)..::. Join(TMap, TMap).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnValidate | Performs additionl custom proccesses when validating a value. (Overrides Mappings <(Of <( FieldMapping, IndexField, EngineDataCompareOptions >)>)..::. OnValidate(Mapping<(Of <(TMap>)>)).)
RealAdd | Adds a mapping to this Mappings instance. This will change the forwards and backwards maps as necessary. This will break any mapping that will conflict with the added mapping. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RealRemove | Removes the specified object from the mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ShouldInclude | Called to determine if an object should be included in the mapping at all, one of the obj arguments is null. (Overrides Mappings <(Of <( FieldMapping, IndexField, EngineDataCompareOptions >)>)..::. ShouldInclude(TMap, TMap, Object).)
Sort | Sorts the Mappings according the criteria appropriate for the object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Split | Splits a mapping and creates two mappings; one to null, and one from null. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Fields

Name | Description
m_Context | (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
m_PrepareString | (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

Properties

Name | Description
Context | Access to the mapping context. The type of the context is dependent on the mapped objects. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.
Options | The MappingOptions object currently used for mappings. (Inherited from DataCompareMappings<(Of <(TMapping, TMap>)>).)
Status | The event handler used to receive status update events. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

FieldMappings Class
RedGate.SQLDataCompare.Engine Namespace


FieldMappings Constructor

[image] [image]

SQL Data Compare API 12.0.40
FieldMappings Constructor
FieldMappings Class See Also

Overload List

Name | Description
FieldMappings(TableMapping) | The default constructor.
FieldMappings(TableMapping, Mappings<(Of <(FieldMapping, IndexField, EngineDataCompareOptions>)>)) | Shallow copy constructor.
FieldMappings(TableMapping, FieldMappings, Boolean) | Shallow copy constructor for matching mappings.

See Also

FieldMappings Class
FieldMappings Members
RedGate.SQLDataCompare.Engine Namespace


FieldMappings Constructor (TableMapping)

[image]

SQL Data Compare API 12.0.40
FieldMappings Constructor (TableMapping)
FieldMappings Class See Also

The default constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    parent As TableMapping _
)
C#
public FieldMappings(
    TableMapping parent
)
Visual C++
public:
FieldMappings(
    TableMapping^ parent
)

Parameters

parent
Type: RedGate.SQLDataCompare.Engine..::.TableMapping
Table to which this FieldMappings class belongs.

See Also

FieldMappings Class
FieldMappings Overload
RedGate.SQLDataCompare.Engine Namespace


FieldMappings Constructor (TableMapping, Mappings(FieldMapping, IndexField, EngineDataCompareOptions))

[image]

SQL Data Compare API 12.0.40
FieldMappings Constructor (TableMapping, Mappings<(Of <(FieldMapping, IndexField, EngineDataCompareOptions>)>))
FieldMappings Class See Also

Shallow copy constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    parent As TableMapping, _
    fieldMappings As Mappings(Of FieldMapping, IndexField, EngineDataCompareOptions) _
)
C#
public FieldMappings(
    TableMapping parent,
    Mappings<FieldMapping, IndexField, EngineDataCompareOptions> fieldMappings
)
Visual C++
public:
FieldMappings(
    TableMapping^ parent,
    Mappings<FieldMapping^, IndexField^, EngineDataCompareOptions^>^ fieldMappings
)

Parameters

parent
Type: RedGate.SQLDataCompare.Engine..::.TableMapping
Table to which this FieldMappings class belongs.
fieldMappings
Type: RedGate.SQLCompare.Engine..::.Mappings <(Of <( FieldMapping, IndexField, EngineDataCompareOptions >)>)
The field mappings to copy.

See Also

FieldMappings Class
FieldMappings Overload
RedGate.SQLDataCompare.Engine Namespace


FieldMappings Constructor (TableMapping, FieldMappings, )

[image]

SQL Data Compare API 12.0.40
FieldMappings Constructor (TableMapping, FieldMappings, )
FieldMappings Class See Also

Shallow copy constructor for matching mappings.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    parent As TableMapping, _
    fieldMappings As FieldMappings, _
    isMatching As Boolean _
)
C#
public FieldMappings(
    TableMapping parent,
    FieldMappings fieldMappings,
    bool isMatching
)
Visual C++
public:
FieldMappings(
    TableMapping^ parent,
    FieldMappings^ fieldMappings,
    bool isMatching
)

Parameters

parent
Type: RedGate.SQLDataCompare.Engine..::.TableMapping
Table to which this FieldMappings class belongs.
fieldMappings
Type: RedGate.SQLDataCompare.Engine..::.FieldMappings
FieldMappings to copy.
isMatching
Type: Boolean
true for matching mappings; false otherwise.

See Also

FieldMappings Class
FieldMappings Overload
RedGate.SQLDataCompare.Engine Namespace


FieldMappings Methods

[image] [image]

SQL Data Compare API 12.0.40
FieldMappings Methods
FieldMappings Class See Also

The FieldMappings type exposes the following methods.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
CanBeMapped | Returns true if the two fields can be mapped together because the types can be compared by the SQL Data Compare engine.
CancelOperation | Cancels the current operation. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Clear | Removes all objects from the FieldMappings instance. (Overrides Mappings <(Of <( FieldMapping, IndexField, EngineDataCompareOptions >)>)..::. Clear()()().)
Contains | Determines whether the Mappings instance contains a specified object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FromTwo | Returns the Mapping of the object in the second database. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Insert | Not Implemented. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Join | Joins two fields in the different databases, and returns the created mapping. The mapping may not have its status set as Success if the field types are incompatible. (Overrides Mappings <(Of <( FieldMapping, IndexField, EngineDataCompareOptions >)>)..::. Join(TMap, TMap).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnValidate | Performs additionl custom proccesses when validating a value. (Overrides Mappings <(Of <( FieldMapping, IndexField, EngineDataCompareOptions >)>)..::. OnValidate(Mapping<(Of <(TMap>)>)).)
RealAdd | Adds a mapping to this Mappings instance. This will change the forwards and backwards maps as necessary. This will break any mapping that will conflict with the added mapping. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RealRemove | Removes the specified object from the mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ShouldInclude | Called to determine if an object should be included in the mapping at all, one of the obj arguments is null. (Overrides Mappings <(Of <( FieldMapping, IndexField, EngineDataCompareOptions >)>)..::. ShouldInclude(TMap, TMap, Object).)
Sort | Sorts the Mappings according the criteria appropriate for the object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Split | Splits a mapping and creates two mappings; one to null, and one from null. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

FieldMappings Class
RedGate.SQLDataCompare.Engine Namespace


CanBeMapped Method

[image]

SQL Data Compare API 12.0.40
FieldMappings..::.CanBeMapped Method
FieldMappings Class See Also

Returns true if the two fields can be mapped together because the types can be compared by the SQL Data Compare engine.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CanBeMapped ( _
    field1 As IField, _
    field2 As IField _
) As Boolean
C#
public static bool CanBeMapped(
    IField field1,
    IField field2
)
Visual C++
public:
static bool CanBeMapped(
    IField^ field1,
    IField^ field2
)

Parameters

field1
Type: RedGate.SQLCompare.Engine..::.IField
The field from the first database.
field2
Type: RedGate.SQLCompare.Engine..::.IField
The field from the second database.

Return Value

true if the types are comparable; otherwise false.

See Also

FieldMappings Class
RedGate.SQLDataCompare.Engine Namespace


Clear Method

[image]

SQL Data Compare API 12.0.40
FieldMappings..::.Clear Method
FieldMappings Class See Also

Removes all objects from the FieldMappings instance.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Clear
C#
public override void Clear()
Visual C++
public:
virtual void Clear() override

Implements

ICollectionClear()()()

Remarks

If this FieldMapping is the matching mapping, it will also set the IndexMapping on the parent table class to null.

See Also

FieldMappings Class
RedGate.SQLDataCompare.Engine Namespace


CreateMappings Method

[image] [image]

SQL Data Compare API 12.0.40
FieldMappings..::.CreateMappings Method
FieldMappings Class See Also

Overload List

Name | Description
CreateMappings(Fields, Fields) | Version of CreateMappings(IndexFields, IndexFields) that creates IndexFields from Fields.
CreateMappings(IndexFields, IndexFields) | Creates a mapping for each object in the collection for which such a mapping is possible.
CreateMappings<(Of <(U>)>)(IKeyedCollection<(Of <(U>)>), IKeyedCollection<(Of <(U>)>), Object, Boolean) | Creates a mapping for each object in the collection where such a mapping is possible. All of the iteration is performed here and the matching can be affected by changing ShouldInclude(TMap, TMap, Object) in the sub class. The main action of joining to objects together is performed by Join(TMap, TMap) which can itself call CreateMappings on child database objects. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

See Also

FieldMappings Class
FieldMappings Members
RedGate.SQLDataCompare.Engine Namespace


CreateMappings Method (Fields, Fields)

[image]

SQL Data Compare API 12.0.40
FieldMappings..::.CreateMappings Method (Fields, Fields)
FieldMappings Class See Also

Version of CreateMappings(IndexFields, IndexFields) that creates IndexFields from Fields.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateMappings ( _
    in1 As Fields, _
    in2 As Fields _
)
C#
public void CreateMappings(
    Fields in1,
    Fields in2
)
Visual C++
public:
void CreateMappings(
    Fields^ in1,
    Fields^ in2
)

Parameters

in1
Type: RedGate.SQLCompare.Engine..::.Fields
in2
Type: RedGate.SQLCompare.Engine..::.Fields

Remarks

[MU, 17/03/2015] I'm not really sure why this method exists, and the comment in the body of this method doesn't give me any confidence that the original author knew why either.

See Also

FieldMappings Class
CreateMappings Overload
RedGate.SQLDataCompare.Engine Namespace


CreateMappings Method (IndexFields, IndexFields)

[image]

SQL Data Compare API 12.0.40
FieldMappings..::.CreateMappings Method (IndexFields, IndexFields)
FieldMappings Class See Also

Creates a mapping for each object in the collection for which such a mapping is possible.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateMappings ( _
    in1 As IndexFields, _
    in2 As IndexFields _
)
C#
public void CreateMappings(
    IndexFields in1,
    IndexFields in2
)
Visual C++
public:
void CreateMappings(
    IndexFields^ in1,
    IndexFields^ in2
)

Parameters

in1
Type: RedGate.SQLCompare.Engine..::.IndexFields
List of objects in the first database, or null.
in2
Type: RedGate.SQLCompare.Engine..::.IndexFields
List of objects in the second database, or null.

See Also

FieldMappings Class
CreateMappings Overload
RedGate.SQLDataCompare.Engine Namespace


Join Method

[image]

SQL Data Compare API 12.0.40
FieldMappings..::.Join Method
FieldMappings Class See Also

Joins two fields in the different databases, and returns the created mapping. The mapping may not have its status set as Success if the field types are incompatible.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Join ( _
    field1 As IndexField, _
    field2 As IndexField _
) As FieldMapping
C#
public override FieldMapping Join(
    IndexField field1,
    IndexField field2
)
Visual C++
public:
virtual FieldMapping^ Join(
    IndexField^ field1,
    IndexField^ field2
) override

Parameters

field1
Type: RedGate.SQLCompare.Engine.Model..::.IndexField
The field in the first database.
field2
Type: RedGate.SQLCompare.Engine.Model..::.IndexField
The field in the second database.

Return Value

The created mapping.

Exceptions

Exception | Condition
ArgumentException | FieldMappings. Join must be called with Field arguments.

See Also

FieldMappings Class
RedGate.SQLDataCompare.Engine Namespace


OnValidate Method

[image]

SQL Data Compare API 12.0.40
FieldMappings..::.OnValidate Method
FieldMappings Class See Also

Performs additionl custom proccesses when validating a value.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnValidate ( _
    value As Mapping(Of IndexField) _
)
C#
protected override void OnValidate(
    Mapping<IndexField> value
)
Visual C++
protected:
virtual void OnValidate(
    Mapping<IndexField^>^ value
) override

Parameters

value
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( IndexField >)>)
The object to validate.

Exceptions

Exception | Condition
ArgumentException | FieldMappings only supports FieldMapping objects.
ArgumentException | FieldMapping not valid for MatchingMappings

See Also

FieldMappings Class
RedGate.SQLDataCompare.Engine Namespace


ShouldInclude Method

[image]

SQL Data Compare API 12.0.40
FieldMappings..::.ShouldInclude Method
FieldMappings Class See Also

Called to determine if an object should be included in the mapping at all, one of the obj arguments is null.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ShouldInclude ( _
    obj1 As IndexField, _
    obj2 As IndexField, _
    extra As Object _
) As Boolean
C#
protected override bool ShouldInclude(
    IndexField obj1,
    IndexField obj2,
    Object extra
)
Visual C++
protected:
virtual bool ShouldInclude(
    IndexField^ obj1,
    IndexField^ obj2,
    Object^ extra
) override

Parameters

obj1
Type: RedGate.SQLCompare.Engine.Model..::.IndexField
object or null if obj2 not null.
obj2
Type: RedGate.SQLCompare.Engine.Model..::.IndexField
object or null if obj1 not null.
extra
Type: Object
extra data passed into CreateMappings internally to determine relevance.

Return Value

true ( default )for inclusion, false otherwise.

See Also

FieldMappings Class
RedGate.SQLDataCompare.Engine Namespace


FieldMappingStatus Enumeration

[image]

SQL Data Compare API 12.0.40
FieldMappingStatus Enumeration
See Also

The result of the FieldMapping.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration FieldMappingStatus
C#
public enum FieldMappingStatus
Visual C++
public enum class FieldMappingStatus

Members

Member name | Description
Success | Mapping success.
UnableToCompare | Mapping succeeded but SQL Data Compare is still unable to compare the databases. This is usually because of type comparison failure.

See Also

RedGate.SQLDataCompare.Engine Namespace


FieldPair Class

[image]

SQL Data Compare API 12.0.40
FieldPair Class
Members See Also

Field definition used in the ResultsStore class.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class FieldPair _
    Implements ISerializable
C#
[SerializableAttribute]
public sealed class FieldPair : ISerializable
Visual C++
[SerializableAttribute]
public ref class FieldPair sealed : ISerializable

Inheritance Hierarchy

Object
RedGate.SQLDataCompare.Engine..::.FieldPair

See Also

FieldPair Members
RedGate.SQLDataCompare.Engine Namespace


FieldPair Members

[image] [image]

SQL Data Compare API 12.0.40
FieldPair Members
FieldPair Class Methods Properties See Also

The FieldPair type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
EscapedFieldName | A convenience function that escapes the field name from the databases.
Field | A convenience function for easy access to the first or second field in a FieldPair. Returns the requested field, or the field in the other database if the requested field is null.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | Gets serialization information with all of the data required to recreate an instance of this FieldPair.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsUnicode | Returns true if the Field is Unicode (NChar, NText, NVarChar, XML, CLR).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SqlType | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Type | A convenience function for easy access to the first or second FieldType in a FieldPair. Returns the requested FieldType, or the FieldType for the other database if the requested FieldType is null.

Properties

Name | Description
Field1 | The field from the first database.
Field2 | The field from the second database.
Matching | True if the FieldPair is used to match the databases.
OrdinalInResults1 | The ordinal in the ResultsStore for the field in the first database.
OrdinalInResults2 | The ordinal in the ResultsStore for the field in the second database.
SqlType1 | The SqlType of the field in the first database, or the underlying SqlType of the User Defined Type of the field.
SqlType2 | The SqlType of the field in the second database, or the SqlType of the User Defined Type of the field.
Type1 | The ResultsStore type of the field in the first database.
Type2 | The ResultsStore type of the field in the second database.

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


FieldPair Methods

[image] [image]

SQL Data Compare API 12.0.40
FieldPair Methods
FieldPair Class See Also

The FieldPair type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
EscapedFieldName | A convenience function that escapes the field name from the databases.
Field | A convenience function for easy access to the first or second field in a FieldPair. Returns the requested field, or the field in the other database if the requested field is null.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | Gets serialization information with all of the data required to recreate an instance of this FieldPair.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsUnicode | Returns true if the Field is Unicode (NChar, NText, NVarChar, XML, CLR).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SqlType | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Type | A convenience function for easy access to the first or second FieldType in a FieldPair. Returns the requested FieldType, or the FieldType for the other database if the requested FieldType is null.

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


EscapedFieldName Method

[image]

SQL Data Compare API 12.0.40
FieldPair..::.EscapedFieldName Method
FieldPair Class See Also

A convenience function that escapes the field name from the databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function EscapedFieldName ( _
    onTwo As Boolean _
) As String
C#
public string EscapedFieldName(
    bool onTwo
)
Visual C++
public:
String^ EscapedFieldName(
    bool onTwo
)

Parameters

onTwo
Type: Boolean
true for the second database; false for the first database.

Return Value

The escaped field name for the requested database; if null, the escaped field name for the other database.

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


Field Method

[image]

SQL Data Compare API 12.0.40
FieldPair..::.Field Method
FieldPair Class See Also

A convenience function for easy access to the first or second field in a FieldPair. Returns the requested field, or the field in the other database if the requested field is null.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Field ( _
    onTwo As Boolean _
) As IndexField
C#
public IndexField Field(
    bool onTwo
)
Visual C++
public:
IndexField^ Field(
    bool onTwo
)

Parameters

onTwo
Type: Boolean
true for the second database; false for the first database.

Return Value

The field for the requested database; if this is null, the field for the other database.

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


GetObjectData Method

[image]

SQL Data Compare API 12.0.40
FieldPair..::.GetObjectData Method
FieldPair Class See Also

Gets serialization information with all of the data required to recreate an instance of this FieldPair.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: SerializationInfo
The object to be populated with serialization information.
context
Type: StreamingContext
The destination context of the serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


IsUnicode Method

[image]

SQL Data Compare API 12.0.40
FieldPair..::.IsUnicode Method
FieldPair Class See Also

Returns true if the Field is Unicode (NChar, NText, NVarChar, XML, CLR).

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function IsUnicode ( _
    onTwo As Boolean _
) As Boolean
C#
public bool IsUnicode(
    bool onTwo
)
Visual C++
public:
bool IsUnicode(
    bool onTwo
)

Parameters

onTwo
Type: Boolean
true for the second database; false for the first database.

Return Value

true if the Field is Unicode; otherwise, false.

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


SqlType Method

[image] [image]

SQL Data Compare API 12.0.40
FieldPair..::.SqlType Method
FieldPair Class See Also

Overload List

Name | Description
SqlType(Boolean) | A convenience function for easy access to the first or second SqlType in a FieldPair. Returns the requested SqlType, or the other SqlType if the requested field is null. Also de-references user-defined types.
SqlType(FieldPair..::.FieldPreference) | A convenience function for easy access to the first or second SqlType in a FieldPair. Returns the requested SqlType, or the other SqlType if the requested field is null. Also de-references user-defined types.

See Also

FieldPair Class
FieldPair Members
RedGate.SQLDataCompare.Engine Namespace


SqlType Method ()

[image]

SQL Data Compare API 12.0.40
FieldPair..::.SqlType Method ()
FieldPair Class See Also

A convenience function for easy access to the first or second SqlType in a FieldPair. Returns the requested SqlType, or the other SqlType if the requested field is null. Also de-references user-defined types.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function SqlType ( _
    onTwo As Boolean _
) As SqlType
C#
public SqlType SqlType(
    bool onTwo
)
Visual C++
public:
SqlType SqlType(
    bool onTwo
)

Parameters

onTwo
Type: Boolean
true for the second database; false for the first database.

Return Value

The SqlType for the field in the requested database; if null, the SqlType for the field in the other database.

See Also

FieldPair Class
SqlType Overload
RedGate.SQLDataCompare.Engine Namespace


SqlType Method (FieldPair.FieldPreference)

[image]

SQL Data Compare API 12.0.40
FieldPair..::.SqlType Method (FieldPair..::.FieldPreference)
FieldPair Class See Also

A convenience function for easy access to the first or second SqlType in a FieldPair. Returns the requested SqlType, or the other SqlType if the requested field is null. Also de-references user-defined types.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function SqlType ( _
    pref As FieldPair..::.FieldPreference _
) As SqlType
C#
public SqlType SqlType(
    FieldPair..::.FieldPreference pref
)
Visual C++
public:
SqlType SqlType(
    FieldPair..::.FieldPreference pref
)

Parameters

pref
Type: RedGate.SQLDataCompare.Engine..::.FieldPair..::.FieldPreference
Whether to use the first or second field type

Return Value

The SqlType for the field in the requested database; if null, the SqlType for the field in the other database.

See Also

FieldPair Class
SqlType Overload
RedGate.SQLDataCompare.Engine Namespace


Type Method

[image]

SQL Data Compare API 12.0.40
FieldPair..::.Type Method
FieldPair Class See Also

A convenience function for easy access to the first or second FieldType in a FieldPair. Returns the requested FieldType, or the FieldType for the other database if the requested FieldType is null.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Type ( _
    onTwo As Boolean _
) As FieldType
C#
public FieldType Type(
    bool onTwo
)
Visual C++
public:
FieldType Type(
    bool onTwo
)

Parameters

onTwo
Type: Boolean
true for the second database; false for the first database.

Return Value

The FieldType for the field in the requested database; if null, the FieldType for the field in the other database.

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


FieldPair Properties

[image] [image]

SQL Data Compare API 12.0.40
FieldPair Properties
FieldPair Class See Also

The FieldPair type exposes the following properties.

Properties

Name | Description
Field1 | The field from the first database.
Field2 | The field from the second database.
Matching | True if the FieldPair is used to match the databases.
OrdinalInResults1 | The ordinal in the ResultsStore for the field in the first database.
OrdinalInResults2 | The ordinal in the ResultsStore for the field in the second database.
SqlType1 | The SqlType of the field in the first database, or the underlying SqlType of the User Defined Type of the field.
SqlType2 | The SqlType of the field in the second database, or the SqlType of the User Defined Type of the field.
Type1 | The ResultsStore type of the field in the first database.
Type2 | The ResultsStore type of the field in the second database.

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


Field1 Property

[image]

SQL Data Compare API 12.0.40
FieldPair..::.Field1 Property
FieldPair Class See Also

The field from the first database.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Field1 As IndexField
C#
public IndexField Field1 { get; }
Visual C++
public:
property IndexField^ Field1 {
    IndexField^ get ();
}

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


Field2 Property

[image]

SQL Data Compare API 12.0.40
FieldPair..::.Field2 Property
FieldPair Class See Also

The field from the second database.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Field2 As IndexField
C#
public IndexField Field2 { get; }
Visual C++
public:
property IndexField^ Field2 {
    IndexField^ get ();
}

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


Matching Property

[image]

SQL Data Compare API 12.0.40
FieldPair..::.Matching Property
FieldPair Class See Also

True if the FieldPair is used to match the databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Matching As Boolean
C#
public bool Matching { get; }
Visual C++
public:
property bool Matching {
    bool get ();
}

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


OrdinalInResults1 Property

[image]

SQL Data Compare API 12.0.40
FieldPair..::.OrdinalInResults1 Property
FieldPair Class See Also

The ordinal in the ResultsStore for the field in the first database.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OrdinalInResults1 As Integer
C#
public int OrdinalInResults1 { get; }
Visual C++
public:
property int OrdinalInResults1 {
    int get ();
}

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


OrdinalInResults2 Property

[image]

SQL Data Compare API 12.0.40
FieldPair..::.OrdinalInResults2 Property
FieldPair Class See Also

The ordinal in the ResultsStore for the field in the second database.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OrdinalInResults2 As Integer
C#
public int OrdinalInResults2 { get; }
Visual C++
public:
property int OrdinalInResults2 {
    int get ();
}

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


SqlType1 Property

[image]

SQL Data Compare API 12.0.40
FieldPair..::.SqlType1 Property
FieldPair Class See Also

The SqlType of the field in the first database, or the underlying SqlType of the User Defined Type of the field.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SqlType1 As SqlType
C#
public SqlType SqlType1 { get; }
Visual C++
public:
property SqlType SqlType1 {
    SqlType get ();
}

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


SqlType2 Property

[image]

SQL Data Compare API 12.0.40
FieldPair..::.SqlType2 Property
FieldPair Class See Also

The SqlType of the field in the second database, or the SqlType of the User Defined Type of the field.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SqlType2 As SqlType
C#
public SqlType SqlType2 { get; }
Visual C++
public:
property SqlType SqlType2 {
    SqlType get ();
}

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


Type1 Property

[image]

SQL Data Compare API 12.0.40
FieldPair..::.Type1 Property
FieldPair Class See Also

The ResultsStore type of the field in the first database.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type1 As FieldType
C#
public FieldType Type1 { get; }
Visual C++
public:
property FieldType Type1 {
    FieldType get ();
}

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


Type2 Property

[image]

SQL Data Compare API 12.0.40
FieldPair..::.Type2 Property
FieldPair Class See Also

The ResultsStore type of the field in the second database.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type2 As FieldType
C#
public FieldType Type2 { get; }
Visual C++
public:
property FieldType Type2 {
    FieldType get ();
}

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


FieldPair.FieldPreference Enumeration

[image]

SQL Data Compare API 12.0.40
FieldPair..::.FieldPreference Enumeration
FieldPair Class See Also

Replacement for the bool parameter in SqlType(Boolean) to make client code slightly more readable.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration FieldPreference
C#
public enum FieldPreference
Visual C++
public enum class FieldPreference

Members

Member name | Description
First | Use the first field in the pair
Second | Use the second field in the pair

See Also

RedGate.SQLDataCompare.Engine Namespace


FieldPairs Class

[image]

SQL Data Compare API 12.0.40
FieldPairs Class
Members See Also

A collection of FieldPair objects.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class FieldPairs _
    Inherits InnerList(Of FieldPair) _
    Implements ISerializable
C#
[SerializableAttribute]
public sealed class FieldPairs : InnerList<FieldPair>, ISerializable
Visual C++
[SerializableAttribute]
public ref class FieldPairs sealed : public InnerList<FieldPair^>,
    ISerializable

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( T >)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( FieldPair >)>)
RedGate.SQLDataCompare.Engine..::.FieldPairs

See Also

FieldPairs Members
RedGate.SQLDataCompare.Engine Namespace


FieldPairs Members

[image] [image]

SQL Data Compare API 12.0.40
FieldPairs Members
FieldPairs Class Methods Properties Explicit Interface Implementations See Also

The FieldPairs type exposes the following members.

Methods

Name | Description
Add | Adds a FieldPair to the collection (Overrides InnerList <(Of <( FieldPair >)>)..::.Add(UTP).)
Contains | (Inherited from InnerList<(Of <(T>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | Gets serialization information with all of the data needed to recreate an instance of the FieldPairs collection.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.
OrdinalCount | Returns the number of unique field ordinals in the small fields collection.

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

FieldPairs Class
RedGate.SQLDataCompare.Engine Namespace


FieldPairs Methods

[image] [image]

SQL Data Compare API 12.0.40
FieldPairs Methods
FieldPairs Class See Also

The FieldPairs type exposes the following methods.

Methods

Name | Description
Add | Adds a FieldPair to the collection (Overrides InnerList <(Of <( FieldPair >)>)..::.Add(UTP).)
Contains | (Inherited from InnerList<(Of <(T>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | Gets serialization information with all of the data needed to recreate an instance of the FieldPairs collection.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

FieldPairs Class
RedGate.SQLDataCompare.Engine Namespace


Add Method

[image]

SQL Data Compare API 12.0.40
FieldPairs..::.Add Method
FieldPairs Class See Also

Adds a FieldPair to the collection

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Add ( _
    value As FieldPair _
)
C#
public override void Add(
    FieldPair value
)
Visual C++
public:
virtual void Add(
    FieldPair^ value
) override

Parameters

value
Type: RedGate.SQLDataCompare.Engine..::.FieldPair

See Also

FieldPairs Class
RedGate.SQLDataCompare.Engine Namespace


GetObjectData Method

[image]

SQL Data Compare API 12.0.40
FieldPairs..::.GetObjectData Method
FieldPairs Class See Also

Gets serialization information with all of the data needed to recreate an instance of the FieldPairs collection.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: SerializationInfo
The object to be populated with serialization information.
context
Type: StreamingContext
The destination context of the serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)

See Also

FieldPairs Class
RedGate.SQLDataCompare.Engine Namespace


FieldPairs Properties

[image] [image]

SQL Data Compare API 12.0.40
FieldPairs Properties
FieldPairs Class See Also

The FieldPairs type exposes the following properties.

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.
OrdinalCount | Returns the number of unique field ordinals in the small fields collection.

See Also

FieldPairs Class
RedGate.SQLDataCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
FieldPairs..::.Item Property
FieldPairs Class See Also

Overload List

Name | Description
Item[([(Int32])]) | (Inherited from InnerList<(Of <(T>)>).)
Item[([(String])]) | Gets the FieldPair at the specified index.

See Also

FieldPairs Class
FieldPairs Members
RedGate.SQLDataCompare.Engine Namespace


Item Property ()

[image]

SQL Data Compare API 12.0.40
FieldPairs..::.Item Property ()
FieldPairs Class See Also

Gets the FieldPair at the specified index.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As FieldPair
C#
public FieldPair this[
    string name
] { get; }
Visual C++
public:
property FieldPair^ default[String^ name] {
    FieldPair^ get (String^ name);
}

Parameters

name
Type: String
The string-based index of the FieldPair to get.

See Also

FieldPairs Class
Item Overload
RedGate.SQLDataCompare.Engine Namespace


OrdinalCount Property

[image]

SQL Data Compare API 12.0.40
FieldPairs..::.OrdinalCount Property
FieldPairs Class See Also

Returns the number of unique field ordinals in the small fields collection.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OrdinalCount As Integer
C#
public int OrdinalCount { get; }
Visual C++
public:
property int OrdinalCount {
    int get ();
}

Return Value

number of ordinals.

See Also

FieldPairs Class
RedGate.SQLDataCompare.Engine Namespace


IndexMapping Class

[image]

SQL Data Compare API 12.0.40
IndexMapping Class
Members See Also

Contains a mapping between the indexes in the different databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class IndexMapping _
    Inherits Mapping(Of RelationalIndex)
C#
public class IndexMapping : Mapping<RelationalIndex>
Visual C++
public ref class IndexMapping : public Mapping<RelationalIndex^>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.Mapping <(Of <( RelationalIndex >)>)
RedGate.SQLDataCompare.Engine..::.IndexMapping

See Also

IndexMapping Members
RedGate.SQLDataCompare.Engine Namespace


IndexMapping Members

[image] [image]

SQL Data Compare API 12.0.40
IndexMapping Members
IndexMapping Class Constructors Methods Fields Properties Explicit Interface Implementations See Also

The IndexMapping type exposes the following members.

Constructors

Name | Description
IndexMapping | Overloaded.

Methods

Name | Description
Clone | Creates a shallow copy. (Overrides Mapping <(Of <( RelationalIndex >)>)..::. Clone()()().)
CompareTo | Sorts the Mappings. (Inherited from Mapping<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the index name from the first database, or if null, from the second database. (Overrides Mapping <(Of <( RelationalIndex >)>)..::. ToString()()().)

Fields

Name | Description
m_Messages | (Inherited from Mapping<(Of <(T>)>).)

Properties

Name | Description
Include | Specifies whether the mapping is to be included. (Inherited from Mapping<(Of <(T>)>).)
Messages | Messages that explain any issues concerning the mapping; null if no issues exist. (Inherited from Mapping<(Of <(T>)>).)
Obj1 | Returns the object from the first database (Inherited from Mapping<(Of <(T>)>).)
Obj2 | Returns the object from the second database (Inherited from Mapping<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
ICloneableClone | Creates a shallow copy. (Inherited from Mapping<(Of <(T>)>).)

See Also

IndexMapping Class
RedGate.SQLDataCompare.Engine Namespace


IndexMapping Constructor

[image] [image]

SQL Data Compare API 12.0.40
IndexMapping Constructor
IndexMapping Class See Also

Overload List

Name | Description
IndexMapping(Mapping<(Of <(RelationalIndex>)>)) | Copy constructor.
IndexMapping(RelationalIndex, RelationalIndex) | Contructor. Calls the base constructor.

See Also

IndexMapping Class
IndexMapping Members
RedGate.SQLDataCompare.Engine Namespace


IndexMapping Constructor (Mapping(RelationalIndex))

[image]

SQL Data Compare API 12.0.40
IndexMapping Constructor (Mapping<(Of <(RelationalIndex>)>))
IndexMapping Class See Also

Copy constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    copy As Mapping(Of RelationalIndex) _
)
C#
protected IndexMapping(
    Mapping<RelationalIndex> copy
)
Visual C++
protected:
IndexMapping(
    Mapping<RelationalIndex^>^ copy
)

Parameters

copy
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( RelationalIndex >)>)
IndexMapping to copy.

See Also

IndexMapping Class
IndexMapping Overload
RedGate.SQLDataCompare.Engine Namespace


IndexMapping Constructor (RelationalIndex, RelationalIndex)

[image]

SQL Data Compare API 12.0.40
IndexMapping Constructor (RelationalIndex, RelationalIndex)
IndexMapping Class See Also

Contructor. Calls the base constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    obj1 As RelationalIndex, _
    obj2 As RelationalIndex _
)
C#
public IndexMapping(
    RelationalIndex obj1,
    RelationalIndex obj2
)
Visual C++
public:
IndexMapping(
    RelationalIndex^ obj1,
    RelationalIndex^ obj2
)

Parameters

obj1
Type: RedGate.SQLCompare.Engine..::.RelationalIndex
The index in the first database.
obj2
Type: RedGate.SQLCompare.Engine..::.RelationalIndex
The index in the second database.

See Also

IndexMapping Class
IndexMapping Overload
RedGate.SQLDataCompare.Engine Namespace


IndexMapping Methods

[image] [image]

SQL Data Compare API 12.0.40
IndexMapping Methods
IndexMapping Class See Also

The IndexMapping type exposes the following methods.

Methods

Name | Description
Clone | Creates a shallow copy. (Overrides Mapping <(Of <( RelationalIndex >)>)..::. Clone()()().)
CompareTo | Sorts the Mappings. (Inherited from Mapping<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the index name from the first database, or if null, from the second database. (Overrides Mapping <(Of <( RelationalIndex >)>)..::. ToString()()().)

Explicit Interface Implementations

Name | Description
ICloneableClone | Creates a shallow copy. (Inherited from Mapping<(Of <(T>)>).)

See Also

IndexMapping Class
RedGate.SQLDataCompare.Engine Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
IndexMapping..::.Clone Method
IndexMapping Class See Also

Creates a shallow copy.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone As Mapping(Of RelationalIndex)
C#
public override Mapping<RelationalIndex> Clone()
Visual C++
public:
virtual Mapping<RelationalIndex^>^ Clone() override

Return Value

A shallow copy.

See Also

IndexMapping Class
RedGate.SQLDataCompare.Engine Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
IndexMapping..::.ToString Method
IndexMapping Class See Also

Returns the index name from the first database, or if null, from the second database.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

Return Value

The name of the index.

See Also

IndexMapping Class
RedGate.SQLDataCompare.Engine Namespace


IndexMappings Class

[image]

SQL Data Compare API 12.0.40
IndexMappings Class
Members See Also

Holds mappings of indexes. The indexes must be PrimaryKey, Unique, or UniqueConstraint to be included. The names of the indexes are not used for the mapping.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class IndexMappings _
    Inherits DataCompareMappings(Of IndexMapping, RelationalIndex)
C#
public class IndexMappings : DataCompareMappings<IndexMapping, RelationalIndex>
Visual C++
public ref class IndexMappings : public DataCompareMappings<IndexMapping^, RelationalIndex^>

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( T >)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( IndexMapping >)>)
RedGate.SQLCompare.Engine..::.Mappings <(Of <( IndexMapping, RelationalIndex, EngineDataCompareOptions >)>)
RedGate.SQLDataCompare.Engine..::.DataCompareMappings <(Of <( IndexMapping, RelationalIndex >)>)
RedGate.SQLDataCompare.Engine..::.IndexMappings

See Also

IndexMappings Members
RedGate.SQLDataCompare.Engine Namespace


IndexMappings Members

[image] [image]

SQL Data Compare API 12.0.40
IndexMappings Members
IndexMappings Class Constructors Methods Fields Properties Explicit Interface Implementations See Also

The IndexMappings type exposes the following members.

Constructors

Name | Description
IndexMappings | Overloaded.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
CancelOperation | Cancels the current operation. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Clear | Removes all objects from the IndexMappings instance. (Overrides Mappings <(Of <( IndexMapping, RelationalIndex, EngineDataCompareOptions >)>)..::. Clear()()().)
Contains | Determines whether the Mappings instance contains a specified object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FromTwo | Returns the Mapping of the object in the second database. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Insert | Not Implemented. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Join | Joins two indexes in different databases. Returns the created mapping. The mapping created may not have its status set as Success. If the indexes are both primary keys, the parent table will have UseIndexForMapping called for this index. (Overrides Mappings <(Of <( IndexMapping, RelationalIndex, EngineDataCompareOptions >)>)..::. Join(TMap, TMap).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnValidate | Performs additional custom proccesses when validating a value. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RealAdd | Adds a mapping to this Mappings instance. This will change the forwards and backwards maps as necessary. This will break any mapping that will conflict with the added mapping. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RealRemove | Removes the specified object from the mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ShouldInclude | Called to determine if an object should be included in the mapping at all, one of the obj arguments is null. (Overrides Mappings <(Of <( IndexMapping, RelationalIndex, EngineDataCompareOptions >)>)..::. ShouldInclude(TMap, TMap, Object).)
Sort | Sorts the Mappings according the criteria appropriate for the object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Split | Splits a mapping and creates two mappings; one to null, and one from null. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Fields

Name | Description
m_Context | (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
m_PrepareString | (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

Properties

Name | Description
Context | Access to the mapping context. The type of the context is dependent on the mapped objects. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.
Options | The MappingOptions object currently used for mappings. (Inherited from DataCompareMappings<(Of <(TMapping, TMap>)>).)
PrimaryKey | Contains a reference to the mapping that is identified as a usable primary key shared on both tables; null if no usable primary key is found.
Status | The event handler used to receive status update events. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

IndexMappings Class
RedGate.SQLDataCompare.Engine Namespace


IndexMappings Constructor

[image] [image]

SQL Data Compare API 12.0.40
IndexMappings Constructor
IndexMappings Class See Also

Overload List

Name | Description
IndexMappings(IndexMappings) | Shallow copy constructor.
IndexMappings(TableMapping) | Creates an IndexMapping.

See Also

IndexMappings Class
IndexMappings Members
RedGate.SQLDataCompare.Engine Namespace


IndexMappings Constructor (IndexMappings)

[image]

SQL Data Compare API 12.0.40
IndexMappings Constructor (IndexMappings)
IndexMappings Class See Also

Shallow copy constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    indexMappings As IndexMappings _
)
C#
public IndexMappings(
    IndexMappings indexMappings
)
Visual C++
public:
IndexMappings(
    IndexMappings^ indexMappings
)

Parameters

indexMappings
Type: RedGate.SQLDataCompare.Engine..::.IndexMappings
The IndexMappings to copy.

See Also

IndexMappings Class
IndexMappings Overload
RedGate.SQLDataCompare.Engine Namespace


IndexMappings Constructor (TableMapping)

[image]

SQL Data Compare API 12.0.40
IndexMappings Constructor (TableMapping)
IndexMappings Class See Also

Creates an IndexMapping.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    parentTable As TableMapping _
)
C#
public IndexMappings(
    TableMapping parentTable
)
Visual C++
public:
IndexMappings(
    TableMapping^ parentTable
)

Parameters

parentTable
Type: RedGate.SQLDataCompare.Engine..::.TableMapping
The parent table mapping.

See Also

IndexMappings Class
IndexMappings Overload
RedGate.SQLDataCompare.Engine Namespace


IndexMappings Methods

[image] [image]

SQL Data Compare API 12.0.40
IndexMappings Methods
IndexMappings Class See Also

The IndexMappings type exposes the following methods.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
CancelOperation | Cancels the current operation. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Clear | Removes all objects from the IndexMappings instance. (Overrides Mappings <(Of <( IndexMapping, RelationalIndex, EngineDataCompareOptions >)>)..::. Clear()()().)
Contains | Determines whether the Mappings instance contains a specified object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FromTwo | Returns the Mapping of the object in the second database. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Insert | Not Implemented. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Join | Joins two indexes in different databases. Returns the created mapping. The mapping created may not have its status set as Success. If the indexes are both primary keys, the parent table will have UseIndexForMapping called for this index. (Overrides Mappings <(Of <( IndexMapping, RelationalIndex, EngineDataCompareOptions >)>)..::. Join(TMap, TMap).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnValidate | Performs additional custom proccesses when validating a value. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RealAdd | Adds a mapping to this Mappings instance. This will change the forwards and backwards maps as necessary. This will break any mapping that will conflict with the added mapping. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RealRemove | Removes the specified object from the mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ShouldInclude | Called to determine if an object should be included in the mapping at all, one of the obj arguments is null. (Overrides Mappings <(Of <( IndexMapping, RelationalIndex, EngineDataCompareOptions >)>)..::. ShouldInclude(TMap, TMap, Object).)
Sort | Sorts the Mappings according the criteria appropriate for the object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Split | Splits a mapping and creates two mappings; one to null, and one from null. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

IndexMappings Class
RedGate.SQLDataCompare.Engine Namespace


Clear Method

[image]

SQL Data Compare API 12.0.40
IndexMappings..::.Clear Method
IndexMappings Class See Also

Removes all objects from the IndexMappings instance.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Clear
C#
public override void Clear()
Visual C++
public:
virtual void Clear() override

Implements

ICollectionClear()()()

Remarks

If there is an index mapping, also sets the IndexMapping on the parent table class to null, and clears the MatchingMappings.

See Also

IndexMappings Class
RedGate.SQLDataCompare.Engine Namespace


CreateMappings Method

[image] [image]

SQL Data Compare API 12.0.40
IndexMappings..::.CreateMappings Method
IndexMappings Class See Also

Overload List

Name | Description
CreateMappings(Indexes, Indexes) | Creates a mapping for each object in the collection for which such a mapping is possible.
CreateMappings<(Of <(U>)>)(IKeyedCollection<(Of <(U>)>), IKeyedCollection<(Of <(U>)>), Object, Boolean) | Creates a mapping for each object in the collection where such a mapping is possible. All of the iteration is performed here and the matching can be affected by changing ShouldInclude(TMap, TMap, Object) in the sub class. The main action of joining to objects together is performed by Join(TMap, TMap) which can itself call CreateMappings on child database objects. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

See Also

IndexMappings Class
IndexMappings Members
RedGate.SQLDataCompare.Engine Namespace


CreateMappings Method (Indexes, Indexes)

[image]

SQL Data Compare API 12.0.40
IndexMappings..::.CreateMappings Method (Indexes, Indexes)
IndexMappings Class See Also

Creates a mapping for each object in the collection for which such a mapping is possible.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateMappings ( _
    in1 As Indexes, _
    in2 As Indexes _
)
C#
public void CreateMappings(
    Indexes in1,
    Indexes in2
)
Visual C++
public:
void CreateMappings(
    Indexes^ in1,
    Indexes^ in2
)

Parameters

in1
Type: RedGate.SQLCompare.Engine..::.Indexes
A list of the objects in the first database, or null.
in2
Type: RedGate.SQLCompare.Engine..::.Indexes
A list of the objects in the second database, or null.

See Also

IndexMappings Class
CreateMappings Overload
RedGate.SQLDataCompare.Engine Namespace


Join Method

[image]

SQL Data Compare API 12.0.40
IndexMappings..::.Join Method
IndexMappings Class See Also

Joins two indexes in different databases. Returns the created mapping. The mapping created may not have its status set as Success. If the indexes are both primary keys, the parent table will have UseIndexForMapping called for this index.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Join ( _
    index1 As RelationalIndex, _
    index2 As RelationalIndex _
) As IndexMapping
C#
public override IndexMapping Join(
    RelationalIndex index1,
    RelationalIndex index2
)
Visual C++
public:
virtual IndexMapping^ Join(
    RelationalIndex^ index1,
    RelationalIndex^ index2
) override

Parameters

index1
Type: RedGate.SQLCompare.Engine..::.RelationalIndex
The index from the first database.
index2
Type: RedGate.SQLCompare.Engine..::.RelationalIndex
The index from the second database.

Return Value

The created mapping.

Exceptions

Exception | Condition
ArgumentException | IndexMappings.Join must called with Field arguments.

See Also

IndexMappings Class
RedGate.SQLDataCompare.Engine Namespace


ShouldInclude Method

[image]

SQL Data Compare API 12.0.40
IndexMappings..::.ShouldInclude Method
IndexMappings Class See Also

Called to determine if an object should be included in the mapping at all, one of the obj arguments is null.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ShouldInclude ( _
    obj1 As RelationalIndex, _
    obj2 As RelationalIndex, _
    extra As Object _
) As Boolean
C#
protected override bool ShouldInclude(
    RelationalIndex obj1,
    RelationalIndex obj2,
    Object extra
)
Visual C++
protected:
virtual bool ShouldInclude(
    RelationalIndex^ obj1,
    RelationalIndex^ obj2,
    Object^ extra
) override

Parameters

obj1
Type: RedGate.SQLCompare.Engine..::.RelationalIndex
object or null if obj2 not null.
obj2
Type: RedGate.SQLCompare.Engine..::.RelationalIndex
object or null if obj1 not null.
extra
Type: Object
extra data passed into CreateMappings internally to determine relevance.

Return Value

true ( default )for inclusion, false otherwise.

See Also

IndexMappings Class
RedGate.SQLDataCompare.Engine Namespace


IndexMappings Properties

[image] [image]

SQL Data Compare API 12.0.40
IndexMappings Properties
IndexMappings Class See Also

The IndexMappings type exposes the following properties.

Properties

Name | Description
Context | Access to the mapping context. The type of the context is dependent on the mapped objects. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.
Options | The MappingOptions object currently used for mappings. (Inherited from DataCompareMappings<(Of <(TMapping, TMap>)>).)
PrimaryKey | Contains a reference to the mapping that is identified as a usable primary key shared on both tables; null if no usable primary key is found.
Status | The event handler used to receive status update events. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

See Also

IndexMappings Class
RedGate.SQLDataCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
IndexMappings..::.Item Property
IndexMappings Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Gets the Mapping<(Of <(T>)>) at the specified index. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Item[([(String])]) | Gets the mapping of the specified object name, first attempting to match against objects in the first database, then matching against objects in the second database. Returns null if a mapping is not found. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

See Also

IndexMappings Class
IndexMappings Members
RedGate.SQLDataCompare.Engine Namespace


PrimaryKey Property

[image]

SQL Data Compare API 12.0.40
IndexMappings..::.PrimaryKey Property
IndexMappings Class See Also

Contains a reference to the mapping that is identified as a usable primary key shared on both tables; null if no usable primary key is found.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrimaryKey As IndexMapping
C#
public IndexMapping PrimaryKey { get; }
Visual C++
public:
property IndexMapping^ PrimaryKey {
    IndexMapping^ get ();
}

See Also

IndexMappings Class
RedGate.SQLDataCompare.Engine Namespace


ReaderType Enumeration

[image]

SQL Data Compare API 12.0.40
ReaderType Enumeration
See Also

Enum for possible sources of SQL being read by the ComparisonSession. Used by ComparisonSessionSQLException

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration ReaderType
C#
public enum ReaderType
Visual C++
public enum class ReaderType

Members

Member name | Description
Unknown | Unknown source
Live | A real database
Backup | A backup of a database
Script | A scripts folder

See Also

RedGate.SQLDataCompare.Engine Namespace


SchemaMapping Class

[image]

SQL Data Compare API 12.0.40
SchemaMapping Class
Members See Also

Contains a mapping between the schema, user, or role in two databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Please use Mapping<IOwner> instead", True)> _
Public Class SchemaMapping _
    Inherits Mapping(Of IOwner)
C#
[ObsoleteAttribute("Please use Mapping<IOwner> instead", true)]
public class SchemaMapping : Mapping<IOwner>
Visual C++
[ObsoleteAttribute(L"Please use Mapping<IOwner> instead", true)]
public ref class SchemaMapping : public Mapping<IOwner^>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.Mapping <(Of <( IOwner >)>)
RedGate.SQLDataCompare.Engine..::.SchemaMapping

See Also

SchemaMapping Members
RedGate.SQLDataCompare.Engine Namespace


SchemaMapping Members

[image] [image]

SQL Data Compare API 12.0.40
SchemaMapping Members
SchemaMapping Class Constructors Methods Fields Properties Explicit Interface Implementations See Also

The SchemaMapping type exposes the following members.

Constructors

Name | Description
SchemaMapping | Overloaded.

Methods

Name | Description
Clone | Creates a (shallow) clone of this object (Overrides Mapping <(Of <( IOwner >)>)..::. Clone()()().)
CompareTo | Sorts the Mappings. (Inherited from Mapping<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Mapping<(Of <(T>)>).)

Fields

Name | Description
m_Messages | (Inherited from Mapping<(Of <(T>)>).)

Properties

Name | Description
Include | Specifies whether the mapping is to be included. (Inherited from Mapping<(Of <(T>)>).)
Messages | Messages that explain any issues concerning the mapping; null if no issues exist. (Inherited from Mapping<(Of <(T>)>).)
Obj1 | Returns the object from the first database (Inherited from Mapping<(Of <(T>)>).)
Obj2 | Returns the object from the second database (Inherited from Mapping<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
ICloneableClone | Creates a shallow copy. (Inherited from Mapping<(Of <(T>)>).)

See Also

SchemaMapping Class
RedGate.SQLDataCompare.Engine Namespace


SchemaMapping Constructor

[image] [image]

SQL Data Compare API 12.0.40
SchemaMapping Constructor
SchemaMapping Class See Also

Overload List

Name | Description
SchemaMapping(Mapping<(Of <(IOwner>)>)) | Copy constructor.
SchemaMapping(IOwner, IOwner) | Contructor. Calls the base constructor.

See Also

SchemaMapping Class
SchemaMapping Members
RedGate.SQLDataCompare.Engine Namespace


SchemaMapping Constructor (Mapping(IOwner))

[image]

SQL Data Compare API 12.0.40
SchemaMapping Constructor (Mapping<(Of <(IOwner>)>))
SchemaMapping Class See Also

Copy constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    copy As Mapping(Of IOwner) _
)
C#
public SchemaMapping(
    Mapping<IOwner> copy
)
Visual C++
public:
SchemaMapping(
    Mapping<IOwner^>^ copy
)

Parameters

copy
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( IOwner >)>)
SchemaMapping to copy.

See Also

SchemaMapping Class
SchemaMapping Overload
RedGate.SQLDataCompare.Engine Namespace


SchemaMapping Constructor (IOwner, IOwner)

[image]

SQL Data Compare API 12.0.40
SchemaMapping Constructor (IOwner, IOwner)
SchemaMapping Class See Also

Contructor. Calls the base constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    obj1 As IOwner, _
    obj2 As IOwner _
)
C#
public SchemaMapping(
    IOwner obj1,
    IOwner obj2
)
Visual C++
public:
SchemaMapping(
    IOwner^ obj1,
    IOwner^ obj2
)

Parameters

obj1
Type: RedGate.SQLCompare.Engine..::.IOwner
The index in the first database.
obj2
Type: RedGate.SQLCompare.Engine..::.IOwner
The index in the second database.

See Also

SchemaMapping Class
SchemaMapping Overload
RedGate.SQLDataCompare.Engine Namespace


SchemaMapping Methods

[image] [image]

SQL Data Compare API 12.0.40
SchemaMapping Methods
SchemaMapping Class See Also

The SchemaMapping type exposes the following methods.

Methods

Name | Description
Clone | Creates a (shallow) clone of this object (Overrides Mapping <(Of <( IOwner >)>)..::. Clone()()().)
CompareTo | Sorts the Mappings. (Inherited from Mapping<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Mapping<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
ICloneableClone | Creates a shallow copy. (Inherited from Mapping<(Of <(T>)>).)

See Also

SchemaMapping Class
RedGate.SQLDataCompare.Engine Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
SchemaMapping..::.Clone Method
SchemaMapping Class See Also

Creates a (shallow) clone of this object

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone As Mapping(Of IOwner)
C#
public override Mapping<IOwner> Clone()
Visual C++
public:
virtual Mapping<IOwner^>^ Clone() override

See Also

SchemaMapping Class
RedGate.SQLDataCompare.Engine Namespace


SchemaMappings Class

[image]

SQL Data Compare API 12.0.40
SchemaMappings Class
Members See Also

Holds mappings for schemas, users, or roles. Uses the database objects to create the mappings for the views and the tables from the two databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SchemaMappings _
    Inherits DataCompareMappings(Of Mapping(Of IOwner), IOwner)
C#
public class SchemaMappings : DataCompareMappings<Mapping<IOwner>, IOwner>
Visual C++
public ref class SchemaMappings : public DataCompareMappings<Mapping<IOwner^>^, IOwner^>

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( T >)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( Mapping <(Of <( IOwner >)>)>)>)
RedGate.SQLCompare.Engine..::.Mappings <(Of <( Mapping <(Of <( IOwner >)>), IOwner, EngineDataCompareOptions >)>)
RedGate.SQLDataCompare.Engine..::.DataCompareMappings <(Of <( Mapping <(Of <( IOwner >)>), IOwner >)>)
RedGate.SQLDataCompare.Engine..::.SchemaMappings

See Also

SchemaMappings Members
RedGate.SQLDataCompare.Engine Namespace


SchemaMappings Members

[image] [image]

SQL Data Compare API 12.0.40
SchemaMappings Members
SchemaMappings Class Constructors Methods Fields Properties Explicit Interface Implementations See Also

The SchemaMappings type exposes the following members.

Constructors

Name | Description
SchemaMappings | Overloaded.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
CancelOperation | Cancels the current operation. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Clear | Removes all objects from the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Contains | Determines whether the Mappings instance contains a specified object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FromTwo | Returns the Mapping of the object in the second database. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Insert | Not Implemented. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Join | Joins two schemas, two users, or a schema and a user, and attempts to map their tables and views. (Overrides Mappings <(Of <( Mapping <(Of <( IOwner >)>), IOwner, EngineDataCompareOptions >)>)..::. Join(TMap, TMap).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnValidate | Performs additional custom proccesses when validating a value. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RealAdd | Adds a mapping to this Mappings instance. This will change the forwards and backwards maps as necessary. This will break any mapping that will conflict with the added mapping. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RealRemove | Removes the specified object from the mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ShouldInclude | Called to determine if an object should be included in the mapping at all, one of the obj arguments is null. (Overrides Mappings <(Of <( Mapping <(Of <( IOwner >)>), IOwner, EngineDataCompareOptions >)>)..::. ShouldInclude(TMap, TMap, Object).)
Sort | Sorts the Mappings according the criteria appropriate for the object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Split | Splits a mapping and creates two mappings; one to null, and one from null. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Fields

Name | Description
m_Context | (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
m_PrepareString | (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

Properties

Name | Description
Context | Access to the mapping context. The type of the context is dependent on the mapped objects. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.
Options | The MappingOptions object currently used for mappings. (Inherited from DataCompareMappings<(Of <(TMapping, TMap>)>).)
Status | The event handler used to receive status update events. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
TableMappings | Returns the table mappings for the databases.

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

SchemaMappings Class
RedGate.SQLDataCompare.Engine Namespace


SchemaMappings Constructor

[image] [image]

SQL Data Compare API 12.0.40
SchemaMappings Constructor
SchemaMappings Class See Also

Overload List

Name | Description
SchemaMappings()()() | The default constructor.
SchemaMappings(SchemaMappings) | Shallow copy constructor.
SchemaMappings(SchemaMappings, IDatabase, IDatabase) | Copy constructor changing the database objects

See Also

SchemaMappings Class
SchemaMappings Members
RedGate.SQLDataCompare.Engine Namespace


SchemaMappings Constructor

[image]

SQL Data Compare API 12.0.40
SchemaMappings Constructor
SchemaMappings Class See Also

The default constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SchemaMappings()
Visual C++
public:
SchemaMappings()

See Also

SchemaMappings Class
SchemaMappings Overload
RedGate.SQLDataCompare.Engine Namespace


SchemaMappings Constructor (SchemaMappings)

[image]

SQL Data Compare API 12.0.40
SchemaMappings Constructor (SchemaMappings)
SchemaMappings Class See Also

Shallow copy constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    schemaMappings As SchemaMappings _
)
C#
public SchemaMappings(
    SchemaMappings schemaMappings
)
Visual C++
public:
SchemaMappings(
    SchemaMappings^ schemaMappings
)

Parameters

schemaMappings
Type: RedGate.SQLDataCompare.Engine..::.SchemaMappings
The SchemaMappings to copy.

See Also

SchemaMappings Class
SchemaMappings Overload
RedGate.SQLDataCompare.Engine Namespace


SchemaMappings Constructor (SchemaMappings, IDatabase, IDatabase)

[image]

SQL Data Compare API 12.0.40
SchemaMappings Constructor (SchemaMappings, IDatabase, IDatabase)
SchemaMappings Class See Also

Copy constructor changing the database objects

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    schemaMappings As SchemaMappings, _
    db1 As IDatabase, _
    db2 As IDatabase _
)
C#
public SchemaMappings(
    SchemaMappings schemaMappings,
    IDatabase db1,
    IDatabase db2
)
Visual C++
public:
SchemaMappings(
    SchemaMappings^ schemaMappings,
    IDatabase^ db1,
    IDatabase^ db2
)

Parameters

schemaMappings
Type: RedGate.SQLDataCompare.Engine..::.SchemaMappings
db1
Type: RedGate.SQLCompare.Engine..::.IDatabase
db2
Type: RedGate.SQLCompare.Engine..::.IDatabase

See Also

SchemaMappings Class
SchemaMappings Overload
RedGate.SQLDataCompare.Engine Namespace


SchemaMappings Methods

[image] [image]

SQL Data Compare API 12.0.40
SchemaMappings Methods
SchemaMappings Class See Also

The SchemaMappings type exposes the following methods.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
CancelOperation | Cancels the current operation. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Clear | Removes all objects from the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Contains | Determines whether the Mappings instance contains a specified object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FromTwo | Returns the Mapping of the object in the second database. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Insert | Not Implemented. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Join | Joins two schemas, two users, or a schema and a user, and attempts to map their tables and views. (Overrides Mappings <(Of <( Mapping <(Of <( IOwner >)>), IOwner, EngineDataCompareOptions >)>)..::. Join(TMap, TMap).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnValidate | Performs additional custom proccesses when validating a value. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RealAdd | Adds a mapping to this Mappings instance. This will change the forwards and backwards maps as necessary. This will break any mapping that will conflict with the added mapping. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RealRemove | Removes the specified object from the mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ShouldInclude | Called to determine if an object should be included in the mapping at all, one of the obj arguments is null. (Overrides Mappings <(Of <( Mapping <(Of <( IOwner >)>), IOwner, EngineDataCompareOptions >)>)..::. ShouldInclude(TMap, TMap, Object).)
Sort | Sorts the Mappings according the criteria appropriate for the object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Split | Splits a mapping and creates two mappings; one to null, and one from null. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

SchemaMappings Class
RedGate.SQLDataCompare.Engine Namespace


CreateMappings Method

[image] [image]

SQL Data Compare API 12.0.40
SchemaMappings..::.CreateMappings Method
SchemaMappings Class See Also

Overload List

Name | Description
CreateMappings(IDatabase, IDatabase) | Creates a mapping for each schema, user, or role in the database where such a mapping is possible.
CreateMappings<(Of <(U>)>)(IKeyedCollection<(Of <(U>)>), IKeyedCollection<(Of <(U>)>), Object, Boolean) | Creates a mapping for each object in the collection where such a mapping is possible. All of the iteration is performed here and the matching can be affected by changing ShouldInclude(TMap, TMap, Object) in the sub class. The main action of joining to objects together is performed by Join(TMap, TMap) which can itself call CreateMappings on child database objects. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

See Also

SchemaMappings Class
SchemaMappings Members
RedGate.SQLDataCompare.Engine Namespace


CreateMappings Method (IDatabase, IDatabase)

[image]

SQL Data Compare API 12.0.40
SchemaMappings..::.CreateMappings Method (IDatabase, IDatabase)
SchemaMappings Class See Also

Creates a mapping for each schema, user, or role in the database where such a mapping is possible.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateMappings ( _
    db1 As IDatabase, _
    db2 As IDatabase _
)
C#
public void CreateMappings(
    IDatabase db1,
    IDatabase db2
)
Visual C++
public:
void CreateMappings(
    IDatabase^ db1,
    IDatabase^ db2
)

Parameters

db1
Type: RedGate.SQLCompare.Engine..::.IDatabase
The first database, or null.
db2
Type: RedGate.SQLCompare.Engine..::.IDatabase
The second database, or null.

See Also

SchemaMappings Class
CreateMappings Overload
RedGate.SQLDataCompare.Engine Namespace


Join Method

[image]

SQL Data Compare API 12.0.40
SchemaMappings..::.Join Method
SchemaMappings Class See Also

Joins two schemas, two users, or a schema and a user, and attempts to map their tables and views.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Join ( _
    obj1 As IOwner, _
    obj2 As IOwner _
) As Mapping(Of IOwner)
C#
public override Mapping<IOwner> Join(
    IOwner obj1,
    IOwner obj2
)
Visual C++
public:
virtual Mapping<IOwner^>^ Join(
    IOwner^ obj1,
    IOwner^ obj2
) override

Parameters

obj1
Type: RedGate.SQLCompare.Engine..::.IOwner
The schema or user in the first database.
obj2
Type: RedGate.SQLCompare.Engine..::.IOwner
The schema or user in the second database.

Return Value

the created mapping.

Exceptions

Exception | Condition
ArgumentException | SchemaMappings. Join must be called with Schema or Users arguments.

See Also

SchemaMappings Class
RedGate.SQLDataCompare.Engine Namespace


ShouldInclude Method

[image]

SQL Data Compare API 12.0.40
SchemaMappings..::.ShouldInclude Method
SchemaMappings Class See Also

Called to determine if an object should be included in the mapping at all, one of the obj arguments is null.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ShouldInclude ( _
    obj1 As IOwner, _
    obj2 As IOwner, _
    extra As Object _
) As Boolean
C#
protected override bool ShouldInclude(
    IOwner obj1,
    IOwner obj2,
    Object extra
)
Visual C++
protected:
virtual bool ShouldInclude(
    IOwner^ obj1,
    IOwner^ obj2,
    Object^ extra
) override

Parameters

obj1
Type: RedGate.SQLCompare.Engine..::.IOwner
object or null if obj2 not null.
obj2
Type: RedGate.SQLCompare.Engine..::.IOwner
object or null if obj1 not null.
extra
Type: Object
extra data passed into CreateMappings internally to determine relevance.

Return Value

true ( default )for inclusion, false otherwise.

See Also

SchemaMappings Class
RedGate.SQLDataCompare.Engine Namespace


SchemaMappings Properties

[image] [image]

SQL Data Compare API 12.0.40
SchemaMappings Properties
SchemaMappings Class See Also

The SchemaMappings type exposes the following properties.

Properties

Name | Description
Context | Access to the mapping context. The type of the context is dependent on the mapped objects. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.
Options | The MappingOptions object currently used for mappings. (Inherited from DataCompareMappings<(Of <(TMapping, TMap>)>).)
Status | The event handler used to receive status update events. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
TableMappings | Returns the table mappings for the databases.

See Also

SchemaMappings Class
RedGate.SQLDataCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
SchemaMappings..::.Item Property
SchemaMappings Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Gets the Mapping<(Of <(T>)>) at the specified index. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Item[([(String])]) | Gets the mapping of the specified object name, first attempting to match against objects in the first database, then matching against objects in the second database. Returns null if a mapping is not found. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

See Also

SchemaMappings Class
SchemaMappings Members
RedGate.SQLDataCompare.Engine Namespace


TableMappings Property

[image]

SQL Data Compare API 12.0.40
SchemaMappings..::.TableMappings Property
SchemaMappings Class See Also

Returns the table mappings for the databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TableMappings As TableMappings
C#
public TableMappings TableMappings { get; }
Visual C++
public:
property TableMappings^ TableMappings {
    TableMappings^ get ();
}

See Also

SchemaMappings Class
RedGate.SQLDataCompare.Engine Namespace


SelectionDelegate Delegate

[image]

SQL Data Compare API 12.0.40
SelectionDelegate Delegate
See Also

The delegate called to indicate whether a record should be included in the synchronization SQL script.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Function SelectionDelegate ( _
    synchronizationRecord As SynchronizationRecord _
) As Boolean
C#
public delegate bool SelectionDelegate(
    SynchronizationRecord synchronizationRecord
)
Visual C++
public delegate bool SelectionDelegate(
    SynchronizationRecord synchronizationRecord
)

Parameters

synchronizationRecord
Type: RedGate.SQLDataCompare.Engine..::.SynchronizationRecord
The record to include.

Field Value

true if the record is to be included; false otherwise.

See Also

RedGate.SQLDataCompare.Engine Namespace


SpatialCLRType Class

[image]

SQL Data Compare API 12.0.40
SpatialCLRType Class
Members See Also

Wrapper class for a Spatial CLR data type (SQL2008).

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SpatialCLRType _
    Inherits CLR
C#
public class SpatialCLRType : CLR
Visual C++
public ref class SpatialCLRType : public CLR

Remarks

The CLR object is used internally by SQL Data Compare to represent a Spatial data type. Use the ByteArray and Text properties to access the underlying data.

Inheritance Hierarchy

Object
RedGate.Shared.Utils..::.DisposableBase
RedGate.SQLDataCompare.Engine..::.Blob
RedGate.SQLDataCompare.Engine..::.CLR
RedGate.SQLDataCompare.Engine..::.SpatialCLRType

See Also

SpatialCLRType Members
RedGate.SQLDataCompare.Engine Namespace


SpatialCLRType Members

[image] [image]

SQL Data Compare API 12.0.40
SpatialCLRType Members
SpatialCLRType Class Constructors Methods Properties See Also

The SpatialCLRType type exposes the following members.

Constructors

Name | Description
SpatialCLRType | Overloaded.

Methods

Name | Description
CompareTo | Compares the Blob with another Blob. (Inherited from Blob.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string representation of the object. (Overrides CLR ..::. ToString()()().)

Properties

Name | Description
ByteArray | The underlying byte array. (Inherited from Blob.)
HasText | Returns true if the CLR type has been populated with text, false otherwise (e.g. CLR was populated from a database backup). (Inherited from CLR.)
IsDisposed | Returns a value indicating if this instance has been disposed. (Inherited from DisposableBase.)
IsGeography | Gets whether the type represents a geography (not geometry type)
Length | The number of bytes in the underlying byte array. (Inherited from Blob.)
SRID | Get the unique ID associated with the type
Text | The textual representation of the CLR object. (Inherited from CLR.)

See Also

SpatialCLRType Class
RedGate.SQLDataCompare.Engine Namespace


SpatialCLRType Constructor

[image] [image]

SQL Data Compare API 12.0.40
SpatialCLRType Constructor
SpatialCLRType Class See Also

Overload List

Name | Description
SpatialCLRType(Boolean, array<Byte>[]()[]) | Constructs the CLR object with a given byte array and textual representation.
SpatialCLRType(Boolean, array<Byte>[]()[], String) | Constructs the CLR object with a given byte array and textual representation.
SpatialCLRType(Boolean, Int32, array<Byte>[]()[], String) | Constructs the CLR object with a given byte array and textual representation.

See Also

SpatialCLRType Class
SpatialCLRType Members
RedGate.SQLDataCompare.Engine Namespace


SpatialCLRType Constructor (, [])

[image]

SQL Data Compare API 12.0.40
SpatialCLRType Constructor (, array<>[]()[])
SpatialCLRType Class See Also

Constructs the CLR object with a given byte array and textual representation.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    geography As Boolean, _
    bytes As Byte() _
)
C#
public SpatialCLRType(
    bool geography,
    byte[] bytes
)
Visual C++
public:
SpatialCLRType(
    bool geography,
    array<unsigned char>^ bytes
)

Parameters

geography
Type: Boolean
Whether this CLR object represents a geography type.
bytes
Type: array<Byte>[]()[]
The byte array.

See Also

SpatialCLRType Class
SpatialCLRType Overload
RedGate.SQLDataCompare.Engine Namespace


SpatialCLRType Constructor (, [], )

[image]

SQL Data Compare API 12.0.40
SpatialCLRType Constructor (, array<>[]()[], )
SpatialCLRType Class See Also

Constructs the CLR object with a given byte array and textual representation.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    geography As Boolean, _
    bytes As Byte(), _
    textual As String _
)
C#
public SpatialCLRType(
    bool geography,
    byte[] bytes,
    string textual
)
Visual C++
public:
SpatialCLRType(
    bool geography,
    array<unsigned char>^ bytes,
    String^ textual
)

Parameters

geography
Type: Boolean
Whether this CLR object represents a geography type.
bytes
Type: array<Byte>[]()[]
The byte array.
textual
Type: String
The textual representation of the CLR object.

See Also

SpatialCLRType Class
SpatialCLRType Overload
RedGate.SQLDataCompare.Engine Namespace


SpatialCLRType Constructor (, , [], )

[image]

SQL Data Compare API 12.0.40
SpatialCLRType Constructor (, , array<>[]()[], )
SpatialCLRType Class See Also

Constructs the CLR object with a given byte array and textual representation.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    geography As Boolean, _
    uniqueId As Integer, _
    bytes As Byte(), _
    textual As String _
)
C#
public SpatialCLRType(
    bool geography,
    int uniqueId,
    byte[] bytes,
    string textual
)
Visual C++
public:
SpatialCLRType(
    bool geography,
    int uniqueId,
    array<unsigned char>^ bytes,
    String^ textual
)

Parameters

geography
Type: Boolean
Whether this CLR object represents a geography type.
uniqueId
Type: Int32
Unique identifier of the spatial data type
bytes
Type: array<Byte>[]()[]
The byte array.
textual
Type: String
The textual representation of the CLR object.

See Also

SpatialCLRType Class
SpatialCLRType Overload
RedGate.SQLDataCompare.Engine Namespace


SpatialCLRType Methods

[image] [image]

SQL Data Compare API 12.0.40
SpatialCLRType Methods
SpatialCLRType Class See Also

The SpatialCLRType type exposes the following methods.

Methods

Name | Description
CompareTo | Compares the Blob with another Blob. (Inherited from Blob.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string representation of the object. (Overrides CLR ..::. ToString()()().)

See Also

SpatialCLRType Class
RedGate.SQLDataCompare.Engine Namespace


Dispose Method

[image] [image]

SQL Data Compare API 12.0.40
SpatialCLRType..::.Dispose Method
SpatialCLRType Class See Also

Overload List

Name | Description
Dispose()()() | (Inherited from DisposableBase.)
Dispose(Boolean) | Sets the underlying byte array to null (Inherited from Blob.)

See Also

SpatialCLRType Class
SpatialCLRType Members
RedGate.SQLDataCompare.Engine Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
SpatialCLRType..::.ToString Method
SpatialCLRType Class See Also

Returns a string representation of the object.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

Return Value

The textual representation of the CLR object.

See Also

SpatialCLRType Class
RedGate.SQLDataCompare.Engine Namespace


SpatialCLRType Properties

[image] [image]

SQL Data Compare API 12.0.40
SpatialCLRType Properties
SpatialCLRType Class See Also

The SpatialCLRType type exposes the following properties.

Properties

Name | Description
ByteArray | The underlying byte array. (Inherited from Blob.)
HasText | Returns true if the CLR type has been populated with text, false otherwise (e.g. CLR was populated from a database backup). (Inherited from CLR.)
IsDisposed | Returns a value indicating if this instance has been disposed. (Inherited from DisposableBase.)
IsGeography | Gets whether the type represents a geography (not geometry type)
Length | The number of bytes in the underlying byte array. (Inherited from Blob.)
SRID | Get the unique ID associated with the type
Text | The textual representation of the CLR object. (Inherited from CLR.)

See Also

SpatialCLRType Class
RedGate.SQLDataCompare.Engine Namespace


IsGeography Property

[image]

SQL Data Compare API 12.0.40
SpatialCLRType..::.IsGeography Property
SpatialCLRType Class See Also

Gets whether the type represents a geography (not geometry type)

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsGeography As Boolean
C#
public bool IsGeography { get; }
Visual C++
public:
property bool IsGeography {
    bool get ();
}

See Also

SpatialCLRType Class
RedGate.SQLDataCompare.Engine Namespace


SRID Property

[image]

SQL Data Compare API 12.0.40
SpatialCLRType..::.SRID Property
SpatialCLRType Class See Also

Get the unique ID associated with the type

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SRID As Integer
C#
public int SRID { get; }
Visual C++
public:
property int SRID {
    int get ();
}

See Also

SpatialCLRType Class
RedGate.SQLDataCompare.Engine Namespace


SqlDataCompareException Class

[image]

SQL Data Compare API 12.0.40
SqlDataCompareException Class
Members See Also

Superclass of all exceptions thrown by the SQL Data Compare engine.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public MustInherit Class SqlDataCompareException _
    Inherits Exception
C#
[SerializableAttribute]
public abstract class SqlDataCompareException : Exception
Visual C++
[SerializableAttribute]
public ref class SqlDataCompareException abstract : public Exception

Inheritance Hierarchy

Object
Exception
RedGate.SQLDataCompare.Engine..::.SqlDataCompareException
RedGate.SQLDataCompare.Engine..::.ComparisonSessionException
RedGate.SQLDataCompare.Engine..::.SqlProviderException
RedGate.SQLDataCompare.Engine.ResultsStore..::.ResultsStoreException
RedGate.SQLDataCompare.Engine.FolderReader..::.FolderScriptParserException

See Also

SqlDataCompareException Members
RedGate.SQLDataCompare.Engine Namespace


SqlDataCompareException Members

[image] [image]

SQL Data Compare API 12.0.40
SqlDataCompareException Members
SqlDataCompareException Class Constructors Methods Properties See Also

The SqlDataCompareException type exposes the following members.

Constructors

Name | Description
SqlDataCompareException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SqlDataCompareException Class
RedGate.SQLDataCompare.Engine Namespace


SqlDataCompareException Constructor

[image] [image]

SQL Data Compare API 12.0.40
SqlDataCompareException Constructor
SqlDataCompareException Class See Also

Overload List

Name | Description
SqlDataCompareException()()() | Creates a new exception.
SqlDataCompareException(String) | Creates a new exception with the specified detail message.
SqlDataCompareException(SerializationInfo, StreamingContext) | This constructor is called during deserialization to reconstitute the exception object transmitted over a stream. For more information, see XML and SOAP Serialization.
SqlDataCompareException(String, Exception) | Creates a new exception with the specified detail message that was caused by the supplied exception.

See Also

SqlDataCompareException Class
SqlDataCompareException Members
RedGate.SQLDataCompare.Engine Namespace


SqlDataCompareException Constructor

[image]

SQL Data Compare API 12.0.40
SqlDataCompareException Constructor
SqlDataCompareException Class See Also

Creates a new exception.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected SqlDataCompareException()
Visual C++
protected:
SqlDataCompareException()

See Also

SqlDataCompareException Class
SqlDataCompareException Overload
RedGate.SQLDataCompare.Engine Namespace


SqlDataCompareException Constructor ()

[image]

SQL Data Compare API 12.0.40
SqlDataCompareException Constructor ()
SqlDataCompareException Class See Also

Creates a new exception with the specified detail message.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    message As String _
)
C#
protected SqlDataCompareException(
    string message
)
Visual C++
protected:
SqlDataCompareException(
    String^ message
)

Parameters

message
Type: String
Detail message.

See Also

SqlDataCompareException Class
SqlDataCompareException Overload
RedGate.SQLDataCompare.Engine Namespace


SqlDataCompareException Constructor (, )

[image]

SQL Data Compare API 12.0.40
SqlDataCompareException Constructor (, )
SqlDataCompareException Class See Also

This constructor is called during deserialization to reconstitute the exception object transmitted over a stream. For more information, see XML and SOAP Serialization.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected SqlDataCompareException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
SqlDataCompareException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: SerializationInfo
The object that holds the serialized object data.
context
Type: StreamingContext
The contextual information about the source or destination.

See Also

SqlDataCompareException Class
SqlDataCompareException Overload
RedGate.SQLDataCompare.Engine Namespace


SqlDataCompareException Constructor (, )

[image]

SQL Data Compare API 12.0.40
SqlDataCompareException Constructor (, )
SqlDataCompareException Class See Also

Creates a new exception with the specified detail message that was caused by the supplied exception.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    message As String, _
    cause As Exception _
)
C#
protected SqlDataCompareException(
    string message,
    Exception cause
)
Visual C++
protected:
SqlDataCompareException(
    String^ message,
    Exception^ cause
)

Parameters

message
Type: String
Detail message.
cause
Type: Exception
Cause of exception.

See Also

SqlDataCompareException Class
SqlDataCompareException Overload
RedGate.SQLDataCompare.Engine Namespace


SqlProvider Class

[image]

SQL Data Compare API 12.0.40
SqlProvider Class
Members Example See Also

The provider for access to SQL Server databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlProvider _
    Implements ICancellable
C#
public class SqlProvider : ICancellable
Visual C++
public ref class SqlProvider : ICancellable

Remarks

Use %GetMigrationSQL(ComparisonSession, System.Boolean)% to get an ExecutionBlock containing the SQL script to migrate data between two databases. It also provides helper methods used internally by SQL Data Compare.

Examples

See ComparisonSessionfor code samples on comparing data See GetMigrationSQL(ComparisonSession, Boolean)for code samples on synchronizing data.

Inheritance Hierarchy

Object
RedGate.SQLDataCompare.Engine..::.SqlProvider

See Also

SqlProvider Members
RedGate.SQLDataCompare.Engine Namespace


SqlProvider Members

[image] [image]

SQL Data Compare API 12.0.40
SqlProvider Members
SqlProvider Class Constructors Methods Properties See Also

The SqlProvider type exposes the following members.

Constructors

Name | Description
SqlProvider | Overloaded.

Methods

Name | Description
CancelOperation | Cancels the current operation.
ClearPostSQL | Clears all the current pre sql contents.
ClearPreSQL | Clears all the current pre sql contents.
DisposeOfSyncInfo | Dispose of the resources associated with the writer
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetMigrationSQL | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnStatus | Fires the Status event.
Synchronize | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Actions | Dictionary of changes to be applied to files in a scripts folder. The key is the filename to modify, and the value is the modification to perform.
BackupOptions | Options about adding a backup step to the deployment script
Block | The last execution block returned by GetMigrationSQL(ComparisonSession, Boolean).
MaxByteSizeOfTransactions | Max size of Execution Block transactions
Messages | Informal messages about the contents of the created SQL script.
Options | The options to use when synchronizing the databases.
Status | The event handler for status events.
Warnings | Warnings about the created SQL script.

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


SqlProvider Constructor

[image] [image]

SQL Data Compare API 12.0.40
SqlProvider Constructor
SqlProvider Class See Also

Overload List

Name | Description
SqlProvider()()() | Initializes a new SQLProvider class
SqlProvider(EngineDataCompareOptions) | Initializes a new SQLProvider class

See Also

SqlProvider Class
SqlProvider Members
RedGate.SQLDataCompare.Engine Namespace


SqlProvider Constructor

[image]

SQL Data Compare API 12.0.40
SqlProvider Constructor
SqlProvider Class See Also

Initializes a new SQLProvider class

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlProvider()
Visual C++
public:
SqlProvider()

See Also

SqlProvider Class
SqlProvider Overload
RedGate.SQLDataCompare.Engine Namespace


SqlProvider Constructor (EngineDataCompareOptions)

[image]

SQL Data Compare API 12.0.40
SqlProvider Constructor (EngineDataCompareOptions)
SqlProvider Class See Also

Initializes a new SQLProvider class

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    options As EngineDataCompareOptions _
)
C#
public SqlProvider(
    EngineDataCompareOptions options
)
Visual C++
public:
SqlProvider(
    EngineDataCompareOptions^ options
)

Parameters

options
Type: RedGate.SQLCompare.Engine..::.EngineDataCompareOptions

See Also

SqlProvider Class
SqlProvider Overload
RedGate.SQLDataCompare.Engine Namespace


SqlProvider Methods

[image] [image]

SQL Data Compare API 12.0.40
SqlProvider Methods
SqlProvider Class See Also

The SqlProvider type exposes the following methods.

Methods

Name | Description
CancelOperation | Cancels the current operation.
ClearPostSQL | Clears all the current pre sql contents.
ClearPreSQL | Clears all the current pre sql contents.
DisposeOfSyncInfo | Dispose of the resources associated with the writer
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetMigrationSQL | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnStatus | Fires the Status event.
Synchronize | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


CancelOperation Method

[image]

SQL Data Compare API 12.0.40
SqlProvider..::.CancelOperation Method
SqlProvider Class See Also

Cancels the current operation.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelOperation
C#
public void CancelOperation()
Visual C++
public:
virtual void CancelOperation() sealed

Implements

ICancellable..::.CancelOperation()()()

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


ClearPostSQL Method

[image]

SQL Data Compare API 12.0.40
SqlProvider..::.ClearPostSQL Method
SqlProvider Class See Also

Clears all the current pre sql contents.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub ClearPostSQL
C#
public void ClearPostSQL()
Visual C++
public:
void ClearPostSQL()

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


ClearPreSQL Method

[image]

SQL Data Compare API 12.0.40
SqlProvider..::.ClearPreSQL Method
SqlProvider Class See Also

Clears all the current pre sql contents.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub ClearPreSQL
C#
public void ClearPreSQL()
Visual C++
public:
void ClearPreSQL()

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


DisposeOfSyncInfo Method

[image]

SQL Data Compare API 12.0.40
SqlProvider..::.DisposeOfSyncInfo Method
SqlProvider Class See Also

Dispose of the resources associated with the writer

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub DisposeOfSyncInfo
C#
public void DisposeOfSyncInfo()
Visual C++
public:
void DisposeOfSyncInfo()

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


GetMigrationSQL Method

[image] [image]

SQL Data Compare API 12.0.40
SqlProvider..::.GetMigrationSQL Method
SqlProvider Class See Also

Overload List

Name | Description
GetMigrationSQL(ComparisonSession, Boolean) | Gets information about the SQL script for synchronizing multiple tables.
GetMigrationSQL(ComparisonSession, SelectionDelegate, Boolean) | Gets information about the SQL script for synchronizing multiple tables.
GetMigrationSQL(ComparisonSession, TableDifference, Boolean) | Gets information about the SQL script for synchronizing a single table.
GetMigrationSQL(ComparisonSession, TableDifference, SelectionDelegate, Boolean) | Gets information about the SQL script for synchronizing a single table.

See Also

SqlProvider Class
SqlProvider Members
RedGate.SQLDataCompare.Engine Namespace


GetMigrationSQL Method (ComparisonSession, )

[image]

SQL Data Compare API 12.0.40
SqlProvider..::.GetMigrationSQL Method (ComparisonSession, )
SqlProvider Class Example See Also

Gets information about the SQL script for synchronizing multiple tables.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMigrationSQL ( _
    session As ComparisonSession, _
    runOnTwo As Boolean _
) As IExecutionBlock
C#
public IExecutionBlock GetMigrationSQL(
    ComparisonSession session,
    bool runOnTwo
)
Visual C++
public:
IExecutionBlock^ GetMigrationSQL(
    ComparisonSession^ session,
    bool runOnTwo
)

Parameters

session
Type: RedGate.SQLDataCompare.Engine..::.ComparisonSession
The ComparisonSession used to compare the databases.
runOnTwo
Type: Boolean
true if the SQL script is to be run on the second database.

Return Value

An ExecutionBlock containing the SQL code to run.

Remarks

The Selected property must be set on all the TableDifferences to be included in the SQL script.

Remarks

The Messages and Warnings properties will be available

Examples

This example shows how to get and run the SQL script to synchronize two databases.
C# Copy Code
            using System;
            using RedGate.SQL.Shared;
            using RedGate.SQLCompare.Engine;
            using RedGate.SQLDataCompare.Engine;

            namespace SQLDataCompareCodeSnippets
            {
                public class SqlProviderExample
                {
                    public void RunExample()
                    {
                        Database db1=new Database();
                        Database db2=new Database();

                        db1.RegisterForDataCompare(new ConnectionProperties(".", "WidgetDev"));
                        db2.RegisterForDataCompare(new ConnectionProperties(".", "WidgetLive"));

                        // Create the mappings between the two databases
                        TableMappings mappings = new TableMappings();
                        mappings.CreateMappings(db1.Tables, db2.Tables);

                        using (ComparisonSession session=new ComparisonSession())
                        {
                            session.CompareDatabases(db1, db2, mappings);

                            // now get the ExecutionBlock containing the SQL
                            // we want to run this on WidgetLive so we pass on true as the second parameter
                            SqlProvider provider=new SqlProvider();
                            IExecutionBlock block;
                            try
                            {
                                block = provider.GetMigrationSQL(session, true);

                                Console.WriteLine("The synchronization SQL contains {0} lines in {1} batches", block.LineCount, block.BatchCount);

                                // if the ExecutionBlock was very large this could cause memory problems
                                Console.WriteLine("The SQL to be run is:");
                                Console.WriteLine(block.GetString());

                                // we can access the SQL in a memory efficient manner by accessing the underlying stream
                                // FileStream stream=block.GetFileStream();

                                // run the SQL ( commented out by default )
                                // BlockExecutor executor = new BlockExecutor();
                                // executor.ExecuteBlock(block, ".", "WidgetLive");
                            }
                            finally
                            {
                                block = provider.Block;
                                if (block != null)
                                {
                                    block.Dispose();    // dispose of the objects to delete temporary files
                                }
                            }
                        }
                        db1.Dispose();
                        db2.Dispose();
                    }
                }
            }
Visual Basic Copy Code
            Option Explicit On

            Imports RedGate.SQL.Shared
            Imports RedGate.SQLCompare.Engine
            Imports RedGate.SQLDataCompare.Engine

            Class SqlProviderExample
                Sub RunExample()
                    'register the databases for comparison
                    Dim db1 As New Database
                    Dim db2 As New Database

                    db1.RegisterForDataCompare(New ConnectionProperties(".", "WidgetDev"))
                    db2.RegisterForDataCompare(New ConnectionProperties(".", "WidgetLive"))

                    'create an intersection of the tables
                    Dim mappings As New TableMappings
                    mappings.CreateMappings(db1.Tables, db2.Tables)

                    'compare the databases
                    Dim session As New ComparisonSession
                    session.CompareDatabases(db1, db2, mappings)

                    'now get the ExecutionBlock containing the SQL
                    'we want to run this on WidgetLive so we pass on true as the second parameter
                    Dim provider As New SqlProvider
                    Dim block As IExecutionBlock
                    Try
                        block = provider.GetMigrationSQL(session, True)

                        Console.WriteLine("The synchronization SQL contains {0} lines in {1} batches", block.LineCount, block.BatchCount)

                        'if the ExecutionBlock was very large this could cause memory problems
                        Console.WriteLine("The SQL to be run is:")
                        Console.WriteLine(block.GetString())

                        'we can access the SQL in a memory efficient manner by accessing the underlying stream
                        'Dim stream As FileStream=block.GetFileStream()

                        'run the SQL ( commented out by default )

                        'Dim executor As RedGate.SQL.Shared.BlockExecutor = New BlockExecutor
                        'executor.ExecuteBlock(block, ".", "WidgetLive")
                    Finally
                        block = provider.Block
                        If (Typeof block Is ExecutionBlock) Then
                            block.Dispose()            'dispose of the objects to delete temporary files
                        End If
                    End Try

                    'dispose of the objects to delete temporary files
                    session.Dispose()
                    db1.Dispose()
                    db2.Dispose()
                End Sub
            End Class

Exceptions

Exception | Condition
RedGate.SQLDataCompare.Engine..::.SqlProviderException | If attempting to migrate data from a table with no primary key, unique index, or unique constraint defined on it, which means that rows cannot be uniquely identified.

See Also

SqlProvider Class
GetMigrationSQL Overload
RedGate.SQLDataCompare.Engine Namespace


GetMigrationSQL Method (ComparisonSession, SelectionDelegate, )

[image]

SQL Data Compare API 12.0.40
SqlProvider..::.GetMigrationSQL Method (ComparisonSession, SelectionDelegate, )
SqlProvider Class See Also

Gets information about the SQL script for synchronizing multiple tables.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMigrationSQL ( _
    session As ComparisonSession, _
    select As SelectionDelegate, _
    runOnTwo As Boolean _
) As IExecutionBlock
C#
public IExecutionBlock GetMigrationSQL(
    ComparisonSession session,
    SelectionDelegate select,
    bool runOnTwo
)
Visual C++
public:
IExecutionBlock^ GetMigrationSQL(
    ComparisonSession^ session,
    SelectionDelegate^ select,
    bool runOnTwo
)

Parameters

session
Type: RedGate.SQLDataCompare.Engine..::.ComparisonSession
The ComparisonSession used to compare the databases.
select
Type: RedGate.SQLDataCompare.Engine..::.SelectionDelegate
The selection delegate used to include specific records in the synchronization.
runOnTwo
Type: Boolean
true if the SQL script is to be run on the second database.

Return Value

An ExecutionBlock containing the SQL code to run.

Remarks

See GetMigrationSQL(ComparisonSession, Boolean) for more information.

Exceptions

Exception | Condition
RedGate.SQLDataCompare.Engine..::.SqlProviderException | If attempting to migrate data from a table with no primary key, unique index, or unique constraint defined on it, which means that rows cannot be uniquely identified.

See Also

SqlProvider Class
GetMigrationSQL Overload
RedGate.SQLDataCompare.Engine Namespace


GetMigrationSQL Method (ComparisonSession, TableDifference, )

[image]

SQL Data Compare API 12.0.40
SqlProvider..::.GetMigrationSQL Method (ComparisonSession, TableDifference, )
SqlProvider Class See Also

Gets information about the SQL script for synchronizing a single table.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMigrationSQL ( _
    session As ComparisonSession, _
    tableDifference As TableDifference, _
    runOnTwo As Boolean _
) As IExecutionBlock
C#
public IExecutionBlock GetMigrationSQL(
    ComparisonSession session,
    TableDifference tableDifference,
    bool runOnTwo
)
Visual C++
public:
IExecutionBlock^ GetMigrationSQL(
    ComparisonSession^ session,
    TableDifference^ tableDifference,
    bool runOnTwo
)

Parameters

session
Type: RedGate.SQLDataCompare.Engine..::.ComparisonSession
The ComparisonSession used to compare the databases.
tableDifference
Type: RedGate.SQLDataCompare.Engine..::.TableDifference
The table for which the the SQL script is to be retrieved.
runOnTwo
Type: Boolean
true if the SQL script is to be run on the second database.

Return Value

An ExecutionBlock containing the SQL code to run.

Remarks

See GetMigrationSQL(ComparisonSession, Boolean) for more information.

See Also

SqlProvider Class
GetMigrationSQL Overload
RedGate.SQLDataCompare.Engine Namespace


GetMigrationSQL Method (ComparisonSession, TableDifference, SelectionDelegate, )

[image]

SQL Data Compare API 12.0.40
SqlProvider..::.GetMigrationSQL Method (ComparisonSession, TableDifference, SelectionDelegate, )
SqlProvider Class See Also

Gets information about the SQL script for synchronizing a single table.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMigrationSQL ( _
    session As ComparisonSession, _
    tableDifference As TableDifference, _
    select As SelectionDelegate, _
    runOnTwo As Boolean _
) As IExecutionBlock
C#
public IExecutionBlock GetMigrationSQL(
    ComparisonSession session,
    TableDifference tableDifference,
    SelectionDelegate select,
    bool runOnTwo
)
Visual C++
public:
IExecutionBlock^ GetMigrationSQL(
    ComparisonSession^ session,
    TableDifference^ tableDifference,
    SelectionDelegate^ select,
    bool runOnTwo
)

Parameters

session
Type: RedGate.SQLDataCompare.Engine..::.ComparisonSession
The ComparisonSession used to compare the databases.
tableDifference
Type: RedGate.SQLDataCompare.Engine..::.TableDifference
The table for which the the SQL script is to be retrieved.
select
Type: RedGate.SQLDataCompare.Engine..::.SelectionDelegate
The selection delegate used to include specific records in the synchronization.
runOnTwo
Type: Boolean
true if the SQL script is to be run on the second database.

Return Value

An ExecutionBlock containing the SQL code to run.

Remarks

See GetMigrationSQL(ComparisonSession, Boolean) for more information.

See Also

SqlProvider Class
GetMigrationSQL Overload
RedGate.SQLDataCompare.Engine Namespace


OnStatus Method

[image]

SQL Data Compare API 12.0.40
SqlProvider..::.OnStatus Method
SqlProvider Class See Also

Fires the Status event.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub OnStatus ( _
    e As StatusEventArgs _
)
C#
protected void OnStatus(
    StatusEventArgs e
)
Visual C++
protected:
void OnStatus(
    StatusEventArgs^ e
)

Parameters

e
Type: RedGate.Shared.Utils..::.StatusEventArgs

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


Synchronize Method

[image] [image]

SQL Data Compare API 12.0.40
SqlProvider..::.Synchronize Method
SqlProvider Class See Also

Overload List

Name | Description
Synchronize()()() | Synchronize the Execution Block or script folder
Synchronize(BlockExecutor) | Apply the SQL to the target database, using the provided BlockExecutor.

See Also

SqlProvider Class
SqlProvider Members
RedGate.SQLDataCompare.Engine Namespace


Synchronize Method

[image]

SQL Data Compare API 12.0.40
SqlProvider..::.Synchronize Method
SqlProvider Class See Also

Synchronize the Execution Block or script folder

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Synchronize
C#
public void Synchronize()
Visual C++
public:
void Synchronize()

See Also

SqlProvider Class
Synchronize Overload
RedGate.SQLDataCompare.Engine Namespace


Synchronize Method (BlockExecutor)

[image]

SQL Data Compare API 12.0.40
SqlProvider..::.Synchronize Method (BlockExecutor)
SqlProvider Class See Also

Apply the SQL to the target database, using the provided BlockExecutor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Synchronize ( _
    blockExecutor As BlockExecutor _
)
C#
public void Synchronize(
    BlockExecutor blockExecutor
)
Visual C++
public:
void Synchronize(
    BlockExecutor^ blockExecutor
)

Parameters

blockExecutor
Type: RedGate.Shared.SQL.ExecutionBlock..::.BlockExecutor
The executor to use when running the SQL

See Also

SqlProvider Class
Synchronize Overload
RedGate.SQLDataCompare.Engine Namespace


SqlProvider Properties

[image] [image]

SQL Data Compare API 12.0.40
SqlProvider Properties
SqlProvider Class See Also

The SqlProvider type exposes the following properties.

Properties

Name | Description
Actions | Dictionary of changes to be applied to files in a scripts folder. The key is the filename to modify, and the value is the modification to perform.
BackupOptions | Options about adding a backup step to the deployment script
Block | The last execution block returned by GetMigrationSQL(ComparisonSession, Boolean).
MaxByteSizeOfTransactions | Max size of Execution Block transactions
Messages | Informal messages about the contents of the created SQL script.
Options | The options to use when synchronizing the databases.
Status | The event handler for status events.
Warnings | Warnings about the created SQL script.

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


Actions Property

[image]

SQL Data Compare API 12.0.40
SqlProvider..::.Actions Property
SqlProvider Class See Also

Dictionary of changes to be applied to files in a scripts folder. The key is the filename to modify, and the value is the modification to perform.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Actions As SortedDictionary(Of String, ScriptSynchronizationAction)
C#
public SortedDictionary<string, ScriptSynchronizationAction> Actions { get; }
Visual C++
public:
property SortedDictionary<String^, ScriptSynchronizationAction^>^ Actions {
    SortedDictionary<String^, ScriptSynchronizationAction^>^ get ();
}

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


BackupOptions Property

[image]

SQL Data Compare API 12.0.40
SqlProvider..::.BackupOptions Property
SqlProvider Class See Also

Options about adding a backup step to the deployment script

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BackupOptions As BackupOptions
C#
public BackupOptions BackupOptions { get; set; }
Visual C++
public:
property BackupOptions^ BackupOptions {
    BackupOptions^ get ();
    void set (BackupOptions^ value);
}

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


Block Property

[image]

SQL Data Compare API 12.0.40
SqlProvider..::.Block Property
SqlProvider Class See Also

The last execution block returned by GetMigrationSQL(ComparisonSession, Boolean).

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Block As IExecutionBlock
C#
public IExecutionBlock Block { get; }
Visual C++
public:
property IExecutionBlock^ Block {
    IExecutionBlock^ get ();
}

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


MaxByteSizeOfTransactions Property

[image]

SQL Data Compare API 12.0.40
SqlProvider..::.MaxByteSizeOfTransactions Property
SqlProvider Class See Also

Max size of Execution Block transactions

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxByteSizeOfTransactions As Long
C#
public long MaxByteSizeOfTransactions { get; set; }
Visual C++
public:
property long long MaxByteSizeOfTransactions {
    long long get ();
    void set (long long value);
}

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


Messages Property

[image]

SQL Data Compare API 12.0.40
SqlProvider..::.Messages Property
SqlProvider Class See Also

Informal messages about the contents of the created SQL script.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Messages As Messages
C#
public Messages Messages { get; }
Visual C++
public:
property Messages^ Messages {
    Messages^ get ();
}

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


Options Property

[image]

SQL Data Compare API 12.0.40
SqlProvider..::.Options Property
SqlProvider Class See Also

The options to use when synchronizing the databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Options As EngineDataCompareOptions
C#
public EngineDataCompareOptions Options { get; set; }
Visual C++
public:
property EngineDataCompareOptions^ Options {
    EngineDataCompareOptions^ get ();
    void set (EngineDataCompareOptions^ value);
}

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


Status Property

[image]

SQL Data Compare API 12.0.40
SqlProvider..::.Status Property
SqlProvider Class See Also

The event handler for status events.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


Warnings Property

[image]

SQL Data Compare API 12.0.40
SqlProvider..::.Warnings Property
SqlProvider Class See Also

Warnings about the created SQL script.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Warnings As Messages
C#
public Messages Warnings { get; }
Visual C++
public:
property Messages^ Warnings {
    Messages^ get ();
}

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


SqlProviderException Class

[image]

SQL Data Compare API 12.0.40
SqlProviderException Class
Members See Also

Exception thrown by SqlProvider when it encounters an error whilst generating SQL code.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class SqlProviderException _
    Inherits SqlDataCompareException
C#
[SerializableAttribute]
public class SqlProviderException : SqlDataCompareException
Visual C++
[SerializableAttribute]
public ref class SqlProviderException : public SqlDataCompareException

Inheritance Hierarchy

Object
Exception
RedGate.SQLDataCompare.Engine..::.SqlDataCompareException
RedGate.SQLDataCompare.Engine..::.SqlProviderException

See Also

SqlProviderException Members
RedGate.SQLDataCompare.Engine Namespace


SqlProviderException Members

[image] [image]

SQL Data Compare API 12.0.40
SqlProviderException Members
SqlProviderException Class Constructors Methods Properties See Also

The SqlProviderException type exposes the following members.

Constructors

Name | Description
SqlProviderException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SqlProviderException Class
RedGate.SQLDataCompare.Engine Namespace


SqlProviderException Constructor

[image] [image]

SQL Data Compare API 12.0.40
SqlProviderException Constructor
SqlProviderException Class See Also

Overload List

Name | Description
SqlProviderException()()() | Creates a new exception.
SqlProviderException(String) | Creates a new exception with the specified detail message.
SqlProviderException(SerializationInfo, StreamingContext) | This constructor is called during deserialization to reconstitute the exception object transmitted over a stream. For more information, see XML and SOAP Serialization.
SqlProviderException(String, Exception) | Creates a new exception with the specified detail message and cause.

See Also

SqlProviderException Class
SqlProviderException Members
RedGate.SQLDataCompare.Engine Namespace


SqlProviderException Constructor

[image]

SQL Data Compare API 12.0.40
SqlProviderException Constructor
SqlProviderException Class See Also

Creates a new exception.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlProviderException()
Visual C++
public:
SqlProviderException()

See Also

SqlProviderException Class
SqlProviderException Overload
RedGate.SQLDataCompare.Engine Namespace


SqlProviderException Constructor ()

[image]

SQL Data Compare API 12.0.40
SqlProviderException Constructor ()
SqlProviderException Class See Also

Creates a new exception with the specified detail message.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public SqlProviderException(
    string message
)
Visual C++
public:
SqlProviderException(
    String^ message
)

Parameters

message
Type: String
Detail message.

See Also

SqlProviderException Class
SqlProviderException Overload
RedGate.SQLDataCompare.Engine Namespace


SqlProviderException Constructor (, )

[image]

SQL Data Compare API 12.0.40
SqlProviderException Constructor (, )
SqlProviderException Class See Also

This constructor is called during deserialization to reconstitute the exception object transmitted over a stream. For more information, see XML and SOAP Serialization.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected SqlProviderException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
SqlProviderException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: SerializationInfo
The object that holds the serialized object data.
context
Type: StreamingContext
The contextual information about the source or destination.

See Also

SqlProviderException Class
SqlProviderException Overload
RedGate.SQLDataCompare.Engine Namespace


SqlProviderException Constructor (, )

[image]

SQL Data Compare API 12.0.40
SqlProviderException Constructor (, )
SqlProviderException Class See Also

Creates a new exception with the specified detail message and cause.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    cause As Exception _
)
C#
public SqlProviderException(
    string message,
    Exception cause
)
Visual C++
public:
SqlProviderException(
    String^ message,
    Exception^ cause
)

Parameters

message
Type: String
Detail message.
cause
Type: Exception
Cause of exception.

See Also

SqlProviderException Class
SqlProviderException Overload
RedGate.SQLDataCompare.Engine Namespace


SqlSynchronization Enumeration

[image]

SQL Data Compare API 12.0.40
SqlSynchronization Enumeration
See Also

Controls which parts of the SQL script are produced when the synchronization script is created.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration SqlSynchronization
C#
[FlagsAttribute]
public enum SqlSynchronization
Visual C++
[FlagsAttribute]
public enum class SqlSynchronization

Members

Member name | Description
None | No update SQL will be produced.
UpdateSql | Include the update SQL.
DeleteSql | Include the delete SQL.
AddSql | Include the insertion SQL.
AllSql | Include all SQL ( default ).

See Also

RedGate.SQLDataCompare.Engine Namespace


SqlVariantNull Class

[image]

SQL Data Compare API 12.0.40
SqlVariantNull Class
Members See Also

Class representing a null in a SqlVariant

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlVariantNull _
    Implements IComparable
C#
public class SqlVariantNull : IComparable
Visual C++
public ref class SqlVariantNull : IComparable

Inheritance Hierarchy

Object
RedGate.SQLDataCompare.Engine..::.SqlVariantNull

See Also

SqlVariantNull Members
RedGate.SQLDataCompare.Engine Namespace


SqlVariantNull Members

[image] [image]

SQL Data Compare API 12.0.40
SqlVariantNull Members
SqlVariantNull Class Constructors Methods See Also

The SqlVariantNull type exposes the following members.

Constructors

Name | Description
SqlVariantNull |

Methods

Name | Description
CompareTo | Compares equal to any other SqlVariantNull, greater than anything else
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns "Null" (Overrides Object..::.ToString()()().)

See Also

SqlVariantNull Class
RedGate.SQLDataCompare.Engine Namespace


SqlVariantNull Constructor

[image]

SQL Data Compare API 12.0.40
SqlVariantNull Constructor
SqlVariantNull Class See Also

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlVariantNull()
Visual C++
public:
SqlVariantNull()

See Also

SqlVariantNull Class
RedGate.SQLDataCompare.Engine Namespace


SqlVariantNull Methods

[image] [image]

SQL Data Compare API 12.0.40
SqlVariantNull Methods
SqlVariantNull Class See Also

The SqlVariantNull type exposes the following methods.

Methods

Name | Description
CompareTo | Compares equal to any other SqlVariantNull, greater than anything else
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns "Null" (Overrides Object..::.ToString()()().)

See Also

SqlVariantNull Class
RedGate.SQLDataCompare.Engine Namespace


CompareTo Method

[image]

SQL Data Compare API 12.0.40
SqlVariantNull..::.CompareTo Method
SqlVariantNull Class See Also

Compares equal to any other SqlVariantNull, greater than anything else

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareTo ( _
    o As Object _
) As Integer
C#
public int CompareTo(
    Object o
)
Visual C++
public:
virtual int CompareTo(
    Object^ o
) sealed

Parameters

o
Type: Object
The object to compare against

Return Value

0 if o is a SqlVariantNull, 1 otherwise

Implements

IComparableCompareTo(Object)

See Also

SqlVariantNull Class
RedGate.SQLDataCompare.Engine Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
SqlVariantNull..::.ToString Method
SqlVariantNull Class See Also

Returns "Null"

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

See Also

SqlVariantNull Class
RedGate.SQLDataCompare.Engine Namespace


SynchronizationRecord Structure

[image]

SQL Data Compare API 12.0.40
SynchronizationRecord Structure
Members See Also

A record to be included in a synchronization. This is used by the script generation routines to confirm the inclusion of a record. Passed a parameter to the SelectionDelegate.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Structure SynchronizationRecord
C#
public struct SynchronizationRecord
Visual C++
public value class SynchronizationRecord

See Also

SynchronizationRecord Members
RedGate.SQLDataCompare.Engine Namespace


SynchronizationRecord Members

[image] [image]

SQL Data Compare API 12.0.40
SynchronizationRecord Members
SynchronizationRecord Structure Methods Properties See Also

The SynchronizationRecord type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
Bookmark | The bookmark in the Store.
ResultsStoreType | The Row..::.RowType of the record.
TableName | The name of the table to which the record belongs.

See Also

SynchronizationRecord Structure
RedGate.SQLDataCompare.Engine Namespace


SynchronizationRecord Properties

[image] [image]

SQL Data Compare API 12.0.40
SynchronizationRecord Properties
SynchronizationRecord Structure See Also

The SynchronizationRecord type exposes the following properties.

Properties

Name | Description
Bookmark | The bookmark in the Store.
ResultsStoreType | The Row..::.RowType of the record.
TableName | The name of the table to which the record belongs.

See Also

SynchronizationRecord Structure
RedGate.SQLDataCompare.Engine Namespace


Bookmark Property

[image]

SQL Data Compare API 12.0.40
SynchronizationRecord..::.Bookmark Property
SynchronizationRecord Structure See Also

The bookmark in the Store.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bookmark As Integer
C#
public int Bookmark { get; }
Visual C++
public:
property int Bookmark {
    int get ();
}

See Also

SynchronizationRecord Structure
RedGate.SQLDataCompare.Engine Namespace


ResultsStoreType Property

[image]

SQL Data Compare API 12.0.40
SynchronizationRecord..::.ResultsStoreType Property
SynchronizationRecord Structure See Also

The Row..::.RowType of the record.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ResultsStoreType As Row..::.RowType
C#
public Row..::.RowType ResultsStoreType { get; }
Visual C++
public:
property Row..::.RowType ResultsStoreType {
    Row..::.RowType get ();
}

See Also

SynchronizationRecord Structure
RedGate.SQLDataCompare.Engine Namespace


TableName Property

[image]

SQL Data Compare API 12.0.40
SynchronizationRecord..::.TableName Property
SynchronizationRecord Structure See Also

The name of the table to which the record belongs.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TableName As String
C#
public string TableName { get; }
Visual C++
public:
property String^ TableName {
    String^ get ();
}

See Also

SynchronizationRecord Structure
RedGate.SQLDataCompare.Engine Namespace


TableDifference Class

[image]

SQL Data Compare API 12.0.40
TableDifference Class
Members Example See Also

The results of a table being compared in two databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TableDifference _
    Implements IDisposable
C#
public sealed class TableDifference : IDisposable
Visual C++
public ref class TableDifference sealed : IDisposable

Remarks

When CompareDatabases(IDatabase, IDatabase, TableMappings, SessionSettings, Boolean) is called, its TableDifferences collection contains a set of TableDifference objects, each one corresponding to a table that has been compared. Each TableDifference object contains properties giving a summary of the number of different records in the two tables, and a series of ResultsStore objects containing the details of differing and identical rows.

Examples

See ComparisonSession for an in-depth example.

Inheritance Hierarchy

Object
RedGate.SQLDataCompare.Engine..::.TableDifference

See Also

TableDifference Members
RedGate.SQLDataCompare.Engine Namespace


TableDifference Members

[image] [image]

SQL Data Compare API 12.0.40
TableDifference Members
TableDifference Class Methods Properties See Also

The TableDifference type exposes the following members.

Methods

Name | Description
Dispose | Disposes of the object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSql | Gets the SQL for rowType. TODO: better XML doc
GetSqlLines | Gets the SQL for rowType. TODO: better XML doc
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
TargetTable | Returns the target table on the specified database, or returns the source table if the target table does not exist.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DifferencesSummary | The differences summary object for the table difference.
Name | The fully-qualified name of the table being compared.
RefreshSelected | Set if the table is to be included when refreshing the TableDifferences. Defaults to true.
ResultsStore | The records that are in the two databases. This can be affected by ApplyFilter(Boolean) and ApplySort()()().
SqlSynchronization | Affects which parts of the SQL code are produced when the synchronization SQL script is generated.
TableMapping | The setting to be used when the table differences are refreshed.

See Also

TableDifference Class
RedGate.SQLDataCompare.Engine Namespace


TableDifference Methods

[image] [image]

SQL Data Compare API 12.0.40
TableDifference Methods
TableDifference Class See Also

The TableDifference type exposes the following methods.

Methods

Name | Description
Dispose | Disposes of the object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSql | Gets the SQL for rowType. TODO: better XML doc
GetSqlLines | Gets the SQL for rowType. TODO: better XML doc
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
TargetTable | Returns the target table on the specified database, or returns the source table if the target table does not exist.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TableDifference Class
RedGate.SQLDataCompare.Engine Namespace


Dispose Method

[image]

SQL Data Compare API 12.0.40
TableDifference..::.Dispose Method
TableDifference Class See Also

Disposes of the object.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose
C#
public void Dispose()
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposableDispose()()()

Remarks

Disposes of all the ResultsStore objects representing records in the two databases. These objects make extensive use of temporary files, therefore it is very important to call the Dispose method.

See Also

TableDifference Class
RedGate.SQLDataCompare.Engine Namespace


GetSql Method

[image]

SQL Data Compare API 12.0.40
TableDifference..::.GetSql Method
TableDifference Class See Also

Gets the SQL for rowType. TODO: better XML doc

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSql ( _
    rowType As Row..::.RowType, _
    onTwo As Boolean _
) As String
C#
public string GetSql(
    Row..::.RowType rowType,
    bool onTwo
)
Visual C++
public:
String^ GetSql(
    Row..::.RowType rowType,
    bool onTwo
)

Parameters

rowType
Type: RedGate.SQLDataCompare.Engine.ResultsStore..::.Row..::.RowType
onTwo
Type: Boolean

See Also

TableDifference Class
RedGate.SQLDataCompare.Engine Namespace


GetSqlLines Method

[image]

SQL Data Compare API 12.0.40
TableDifference..::.GetSqlLines Method
TableDifference Class See Also

Gets the SQL for rowType. TODO: better XML doc

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlLines ( _
    rowType As Row..::.RowType, _
    onTwo As Boolean _
) As IList(Of String)
C#
public IList<string> GetSqlLines(
    Row..::.RowType rowType,
    bool onTwo
)
Visual C++
public:
IList<String^>^ GetSqlLines(
    Row..::.RowType rowType,
    bool onTwo
)

Parameters

rowType
Type: RedGate.SQLDataCompare.Engine.ResultsStore..::.Row..::.RowType
onTwo
Type: Boolean

See Also

TableDifference Class
RedGate.SQLDataCompare.Engine Namespace


TargetTable Method

[image]

SQL Data Compare API 12.0.40
TableDifference..::.TargetTable Method
TableDifference Class See Also

Returns the target table on the specified database, or returns the source table if the target table does not exist.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function TargetTable ( _
    onTwo As Boolean _
) As ViewTableSuperClass
C#
public ViewTableSuperClass TargetTable(
    bool onTwo
)
Visual C++
public:
ViewTableSuperClass^ TargetTable(
    bool onTwo
)

Parameters

onTwo
Type: Boolean
true for second database.

Return Value

The target table.

See Also

TableDifference Class
RedGate.SQLDataCompare.Engine Namespace


TableDifference Properties

[image] [image]

SQL Data Compare API 12.0.40
TableDifference Properties
TableDifference Class See Also

The TableDifference type exposes the following properties.

Properties

Name | Description
DifferencesSummary | The differences summary object for the table difference.
Name | The fully-qualified name of the table being compared.
RefreshSelected | Set if the table is to be included when refreshing the TableDifferences. Defaults to true.
ResultsStore | The records that are in the two databases. This can be affected by ApplyFilter(Boolean) and ApplySort()()().
SqlSynchronization | Affects which parts of the SQL code are produced when the synchronization SQL script is generated.
TableMapping | The setting to be used when the table differences are refreshed.

See Also

TableDifference Class
RedGate.SQLDataCompare.Engine Namespace


DifferencesSummary Property

[image]

SQL Data Compare API 12.0.40
TableDifference..::.DifferencesSummary Property
TableDifference Class See Also

The differences summary object for the table difference.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DifferencesSummary As DifferencesSummary
C#
public DifferencesSummary DifferencesSummary { get; }
Visual C++
public:
property DifferencesSummary^ DifferencesSummary {
    DifferencesSummary^ get ();
}

See Also

TableDifference Class
RedGate.SQLDataCompare.Engine Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
TableDifference..::.Name Property
TableDifference Class See Also

The fully-qualified name of the table being compared.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
Visual C++
public:
property String^ Name {
    String^ get ();
}

Remarks

This is the name of the table in the first database; if null, this is the name of the table in the second database.

See Also

TableDifference Class
RedGate.SQLDataCompare.Engine Namespace


RefreshSelected Property

[image]

SQL Data Compare API 12.0.40
TableDifference..::.RefreshSelected Property
TableDifference Class See Also

Set if the table is to be included when refreshing the TableDifferences. Defaults to true.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RefreshSelected As Boolean
C#
public bool RefreshSelected { get; set; }
Visual C++
public:
property bool RefreshSelected {
    bool get ();
    void set (bool value);
}

See Also

TableDifference Class
RedGate.SQLDataCompare.Engine Namespace


ResultsStore Property

[image]

SQL Data Compare API 12.0.40
TableDifference..::.ResultsStore Property
TableDifference Class See Also

The records that are in the two databases. This can be affected by ApplyFilter(Boolean) and ApplySort()()().

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ResultsStore As Store
C#
public Store ResultsStore { get; }
Visual C++
public:
property Store^ ResultsStore {
    Store^ get ();
}

See Also

TableDifference Class
RedGate.SQLDataCompare.Engine Namespace


SqlSynchronization Property

[image]

SQL Data Compare API 12.0.40
TableDifference..::.SqlSynchronization Property
TableDifference Class See Also

Affects which parts of the SQL code are produced when the synchronization SQL script is generated.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SqlSynchronization As SqlSynchronization
C#
public SqlSynchronization SqlSynchronization { get; set; }
Visual C++
public:
property SqlSynchronization SqlSynchronization {
    SqlSynchronization get ();
    void set (SqlSynchronization value);
}

See Also

TableDifference Class
RedGate.SQLDataCompare.Engine Namespace


TableMapping Property

[image]

SQL Data Compare API 12.0.40
TableDifference..::.TableMapping Property
TableDifference Class See Also

The setting to be used when the table differences are refreshed.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TableMapping As TableMapping
C#
public TableMapping TableMapping { get; }
Visual C++
public:
property TableMapping^ TableMapping {
    TableMapping^ get ();
}

See Also

TableDifference Class
RedGate.SQLDataCompare.Engine Namespace


TableDifferences Class

[image]

SQL Data Compare API 12.0.40
TableDifferences Class
Members See Also

A collection of TableDifference objects.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TableDifferences _
    Inherits InnerList(Of TableDifference)
C#
public sealed class TableDifferences : InnerList<TableDifference>
Visual C++
public ref class TableDifferences sealed : public InnerList<TableDifference^>

Remarks

Contains the results of a comparison.

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( T >)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( TableDifference >)>)
RedGate.SQLDataCompare.Engine..::.TableDifferences

See Also

TableDifferences Members
RedGate.SQLDataCompare.Engine Namespace


TableDifferences Members

[image] [image]

SQL Data Compare API 12.0.40
TableDifferences Members
TableDifferences Class Methods Properties Explicit Interface Implementations See Also

The TableDifferences type exposes the following members.

Methods

Name | Description
Add | Adds a TableDifference to the collection (Overrides InnerList <(Of <( TableDifference >)>)..::.Add(UTP).)
Contains | (Inherited from InnerList<(Of <(T>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

TableDifferences Class
RedGate.SQLDataCompare.Engine Namespace


TableDifferences Methods

[image] [image]

SQL Data Compare API 12.0.40
TableDifferences Methods
TableDifferences Class See Also

The TableDifferences type exposes the following methods.

Methods

Name | Description
Add | Adds a TableDifference to the collection (Overrides InnerList <(Of <( TableDifference >)>)..::.Add(UTP).)
Contains | (Inherited from InnerList<(Of <(T>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

TableDifferences Class
RedGate.SQLDataCompare.Engine Namespace


Add Method

[image]

SQL Data Compare API 12.0.40
TableDifferences..::.Add Method
TableDifferences Class See Also

Adds a TableDifference to the collection

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Add ( _
    item As TableDifference _
)
C#
public override void Add(
    TableDifference item
)
Visual C++
public:
virtual void Add(
    TableDifference^ item
) override

Parameters

item
Type: RedGate.SQLDataCompare.Engine..::.TableDifference

See Also

TableDifferences Class
RedGate.SQLDataCompare.Engine Namespace


TableDifferences Properties

[image] [image]

SQL Data Compare API 12.0.40
TableDifferences Properties
TableDifferences Class See Also

The TableDifferences type exposes the following properties.

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.

See Also

TableDifferences Class
RedGate.SQLDataCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
TableDifferences..::.Item Property
TableDifferences Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Gets the TableDifference at the specified index. (Overrides InnerList <(Of <( TableDifference >)>)..::. Item[([(Int32])]).)
Item[([(String])]) | Returns a given TableDifference. The index is the name of the table in the first database or if null, the name of the table in the second database.

See Also

TableDifferences Class
TableDifferences Members
RedGate.SQLDataCompare.Engine Namespace


Item Property ()

[image]

SQL Data Compare API 12.0.40
TableDifferences..::.Item Property ()
TableDifferences Class See Also

Gets the TableDifference at the specified index.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides WriteOnly Default Property Item ( _
    index As Integer _
) As TableDifference
C#
public override TableDifference this[
    int index
] { set; }
Visual C++
public:
virtual property TableDifference^ default[int index] {
    void set (int index, TableDifference^ value) override;
}

Parameters

index
Type: Int32
The zero-based index of the TableDifference to get or set.

Implements

IListItem(Int32)

See Also

TableDifferences Class
Item Overload
RedGate.SQLDataCompare.Engine Namespace


Item Property ()

[image]

SQL Data Compare API 12.0.40
TableDifferences..::.Item Property ()
TableDifferences Class See Also

Returns a given TableDifference. The index is the name of the table in the first database or if null, the name of the table in the second database.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As TableDifference
C#
public TableDifference this[
    string name
] { get; }
Visual C++
public:
property TableDifference^ default[String^ name] {
    TableDifference^ get (String^ name);
}

Parameters

name
Type: String
The string-based index of the TableDifference to get.

See Also

TableDifferences Class
Item Overload
RedGate.SQLDataCompare.Engine Namespace


TableMapping Class

[image]

SQL Data Compare API 12.0.40
TableMapping Class
Members See Also

Contains a mapping from a view or table to another view or table. Also contains information on the criteria used for matching the two tables, which can be based on an index or an arbitrary set of mapped fields.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class TableMapping _
    Inherits Mapping(Of ViewTableSuperClass)
C#
public class TableMapping : Mapping<ViewTableSuperClass>
Visual C++
public ref class TableMapping : public Mapping<ViewTableSuperClass^>

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine..::.Mapping <(Of <( ViewTableSuperClass >)>)
RedGate.SQLDataCompare.Engine..::.TableMapping

See Also

TableMapping Members
RedGate.SQLDataCompare.Engine Namespace


TableMapping Members

[image] [image]

SQL Data Compare API 12.0.40
TableMapping Members
TableMapping Class Constructors Methods Fields Properties Explicit Interface Implementations See Also

The TableMapping type exposes the following members.

Constructors

Name | Description
TableMapping | Constructor. Calls the base constructor and initializes the index mappings.

Methods

Name | Description
Clone | Creates a shallow copy. (Overrides Mapping <(Of <( ViewTableSuperClass >)>)..::. Clone()()().)
CompareTo | Sorts the Mappings. (Inherited from Mapping<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDefaultComparisonKey | Returns the comparison key that SDC would use by default for this table. We prefer primary keys when possible, and look for suitable keys in the list of remaining indexes if a primary key is not present
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsMatching | Determines whether the specified field is being used for matching the databases.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshMappingStatus | Checks the current contents of IndexMapping and MatchingMappings to determine whether the current TableMapping can be compared. If the TableMapping can be compared, the TableMapping Status is set to Success; otherwise the Status is set to UnableToCompare. If not all of the fields in the table are mapped successfully, if the Status is not already set to UnableToCompare, it is set to PartialSuccess.
ToString | Returns a String that represents the current Object. (Inherited from Mapping<(Of <(T>)>).)
UseIndexForMapping | Changes the matching mappings to be the fields from the matched indexes. The property IndexMapping is set to the specified mapping; or null if a problem was encountered.

Fields

Name | Description
m_Messages | (Inherited from Mapping<(Of <(T>)>).)

Properties

Name | Description
FieldMappings | Returns the field mappings for the tables.
Include | The include property for tables.
IndexMapping | If an IndexMapping is being used for matching, this is the IndexMapping. Its FieldMapping is also in MatchingMappings.
IndexMappings | The IndexMappings for the indexes that can be used to compare tables or views. The indexes must be PrimaryKey, Unique, or UniqueConstraint.
MatchingMappings | The FieldMappings that are used to compare the databases. These may have been set from an IndexMapping.
Messages | Messages that explain any issues concerning the mapping; null if no issues exist.
Obj1 | Returns the object from the first database (Inherited from Mapping<(Of <(T>)>).)
Obj2 | Returns the object from the second database (Inherited from Mapping<(Of <(T>)>).)
Status | The status of the Table Mapping.
UserWantsToInclude | The user would like this table to be included, but there might not be a valid mapping
Where | Where clause object used on the databases.

Explicit Interface Implementations

Name | Description
ICloneableClone | Creates a shallow copy. (Inherited from Mapping<(Of <(T>)>).)

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace


TableMapping Constructor

[image]

SQL Data Compare API 12.0.40
TableMapping Constructor
TableMapping Class See Also

Constructor. Calls the base constructor and initializes the index mappings.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    obj1 As ViewTableSuperClass, _
    obj2 As ViewTableSuperClass, _
    status As TableMappingStatus _
)
C#
public TableMapping(
    ViewTableSuperClass obj1,
    ViewTableSuperClass obj2,
    TableMappingStatus status
)
Visual C++
public:
TableMapping(
    ViewTableSuperClass^ obj1,
    ViewTableSuperClass^ obj2,
    TableMappingStatus status
)

Parameters

obj1
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
The view or table in the first database.
obj2
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
The view or table in the second database.
status
Type: RedGate.SQLDataCompare.Engine..::.TableMappingStatus
The status of the mapping.

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace


TableMapping Methods

[image] [image]

SQL Data Compare API 12.0.40
TableMapping Methods
TableMapping Class See Also

The TableMapping type exposes the following methods.

Methods

Name | Description
Clone | Creates a shallow copy. (Overrides Mapping <(Of <( ViewTableSuperClass >)>)..::. Clone()()().)
CompareTo | Sorts the Mappings. (Inherited from Mapping<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDefaultComparisonKey | Returns the comparison key that SDC would use by default for this table. We prefer primary keys when possible, and look for suitable keys in the list of remaining indexes if a primary key is not present
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsMatching | Determines whether the specified field is being used for matching the databases.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshMappingStatus | Checks the current contents of IndexMapping and MatchingMappings to determine whether the current TableMapping can be compared. If the TableMapping can be compared, the TableMapping Status is set to Success; otherwise the Status is set to UnableToCompare. If not all of the fields in the table are mapped successfully, if the Status is not already set to UnableToCompare, it is set to PartialSuccess.
ToString | Returns a String that represents the current Object. (Inherited from Mapping<(Of <(T>)>).)
UseIndexForMapping | Changes the matching mappings to be the fields from the matched indexes. The property IndexMapping is set to the specified mapping; or null if a problem was encountered.

Explicit Interface Implementations

Name | Description
ICloneableClone | Creates a shallow copy. (Inherited from Mapping<(Of <(T>)>).)

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace


Clone Method

[image]

SQL Data Compare API 12.0.40
TableMapping..::.Clone Method
TableMapping Class See Also

Creates a shallow copy.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone As Mapping(Of ViewTableSuperClass)
C#
public override Mapping<ViewTableSuperClass> Clone()
Visual C++
public:
virtual Mapping<ViewTableSuperClass^>^ Clone() override

Return Value

A shallow copy.

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace


GetDefaultComparisonKey Method

[image]

SQL Data Compare API 12.0.40
TableMapping..::.GetDefaultComparisonKey Method
TableMapping Class See Also

Returns the comparison key that SDC would use by default for this table. We prefer primary keys when possible, and look for suitable keys in the list of remaining indexes if a primary key is not present

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDefaultComparisonKey ( _
    currentMatch As IndexMapping _
) As IndexMapping
C#
public IndexMapping GetDefaultComparisonKey(
    IndexMapping currentMatch
)
Visual C++
public:
IndexMapping^ GetDefaultComparisonKey(
    IndexMapping^ currentMatch
)

Parameters

currentMatch
Type: RedGate.SQLDataCompare.Engine..::.IndexMapping

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace


IsMatching Method

[image]

SQL Data Compare API 12.0.40
TableMapping..::.IsMatching Method
TableMapping Class See Also

Determines whether the specified field is being used for matching the databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function IsMatching ( _
    fieldName As String, _
    inTwo As Boolean _
) As Boolean
C#
public bool IsMatching(
    string fieldName,
    bool inTwo
)
Visual C++
public:
bool IsMatching(
    String^ fieldName,
    bool inTwo
)

Parameters

fieldName
Type: String
The name of the field.
inTwo
Type: Boolean
true if the check is to be performed on the second database.

Return Value

true if the field is being used for matching.

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace


RefreshMappingStatus Method

[image]

SQL Data Compare API 12.0.40
TableMapping..::.RefreshMappingStatus Method
TableMapping Class See Also

Checks the current contents of IndexMapping and MatchingMappings to determine whether the current TableMapping can be compared.

If the TableMapping can be compared, the TableMapping Status is set to Success; otherwise the Status is set to UnableToCompare. If not all of the fields in the table are mapped successfully, if the Status is not already set to UnableToCompare, it is set to PartialSuccess.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub RefreshMappingStatus
C#
public void RefreshMappingStatus()
Visual C++
public:
void RefreshMappingStatus()

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace


UseIndexForMapping Method

[image]

SQL Data Compare API 12.0.40
TableMapping..::.UseIndexForMapping Method
TableMapping Class See Also

Changes the matching mappings to be the fields from the matched indexes. The property IndexMapping is set to the specified mapping; or null if a problem was encountered.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function UseIndexForMapping ( _
    mapping As IndexMapping _
) As Boolean
C#
public bool UseIndexForMapping(
    IndexMapping mapping
)
Visual C++
public:
bool UseIndexForMapping(
    IndexMapping^ mapping
)

Parameters

mapping
Type: RedGate.SQLDataCompare.Engine..::.IndexMapping
The IndexMapping to be used.

Return Value

true if the mapping was successfully used; otherwise false.

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace


TableMapping Properties

[image] [image]

SQL Data Compare API 12.0.40
TableMapping Properties
TableMapping Class See Also

The TableMapping type exposes the following properties.

Properties

Name | Description
FieldMappings | Returns the field mappings for the tables.
Include | The include property for tables.
IndexMapping | If an IndexMapping is being used for matching, this is the IndexMapping. Its FieldMapping is also in MatchingMappings.
IndexMappings | The IndexMappings for the indexes that can be used to compare tables or views. The indexes must be PrimaryKey, Unique, or UniqueConstraint.
MatchingMappings | The FieldMappings that are used to compare the databases. These may have been set from an IndexMapping.
Messages | Messages that explain any issues concerning the mapping; null if no issues exist.
Obj1 | Returns the object from the first database (Inherited from Mapping<(Of <(T>)>).)
Obj2 | Returns the object from the second database (Inherited from Mapping<(Of <(T>)>).)
Status | The status of the Table Mapping.
UserWantsToInclude | The user would like this table to be included, but there might not be a valid mapping
Where | Where clause object used on the databases.

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace


FieldMappings Property

[image]

SQL Data Compare API 12.0.40
TableMapping..::.FieldMappings Property
TableMapping Class See Also

Returns the field mappings for the tables.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FieldMappings As FieldMappings
C#
public FieldMappings FieldMappings { get; }
Visual C++
public:
property FieldMappings^ FieldMappings {
    FieldMappings^ get ();
}

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace


Include Property

[image]

SQL Data Compare API 12.0.40
TableMapping..::.Include Property
TableMapping Class See Also

The include property for tables.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Include As Boolean
C#
public bool Include { get; set; }
Visual C++
public:
property bool Include {
    bool get ();
    void set (bool value);
}

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace


IndexMapping Property

[image]

SQL Data Compare API 12.0.40
TableMapping..::.IndexMapping Property
TableMapping Class See Also

If an IndexMapping is being used for matching, this is the IndexMapping. Its FieldMapping is also in MatchingMappings.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IndexMapping As IndexMapping
C#
public IndexMapping IndexMapping { get; internal set; }
Visual C++
public:
property IndexMapping^ IndexMapping {
    IndexMapping^ get ();
    void set (IndexMapping^ value);
}

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace
UseIndexForMapping Method


IndexMappings Property

[image]

SQL Data Compare API 12.0.40
TableMapping..::.IndexMappings Property
TableMapping Class See Also

The IndexMappings for the indexes that can be used to compare tables or views. The indexes must be PrimaryKey, Unique, or UniqueConstraint.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IndexMappings As IndexMappings
C#
public IndexMappings IndexMappings { get; }
Visual C++
public:
property IndexMappings^ IndexMappings {
    IndexMappings^ get ();
}

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace
UseIndexForMapping Method


MatchingMappings Property

[image]

SQL Data Compare API 12.0.40
TableMapping..::.MatchingMappings Property
TableMapping Class See Also

The FieldMappings that are used to compare the databases. These may have been set from an IndexMapping.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MatchingMappings As FieldMappings
C#
public FieldMappings MatchingMappings { get; }
Visual C++
public:
property FieldMappings^ MatchingMappings {
    FieldMappings^ get ();
}

Remarks

Changing the mapping of fields that are used for matching may have unforseen consequences.

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace
RefreshMappingStatus Method
UseIndexForMapping Method


Messages Property

[image]

SQL Data Compare API 12.0.40
TableMapping..::.Messages Property
TableMapping Class See Also

Messages that explain any issues concerning the mapping; null if no issues exist.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Messages As Messages
C#
public Messages Messages { get; }
Visual C++
public:
property Messages^ Messages {
    Messages^ get ();
}

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace


Status Property

[image]

SQL Data Compare API 12.0.40
TableMapping..::.Status Property
TableMapping Class See Also

The status of the Table Mapping.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As TableMappingStatus
C#
public TableMappingStatus Status { get; internal set; }
Visual C++
public:
property TableMappingStatus Status {
    TableMappingStatus get ();
    void set (TableMappingStatus value);
}

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace


UserWantsToInclude Property

[image]

SQL Data Compare API 12.0.40
TableMapping..::.UserWantsToInclude Property
TableMapping Class See Also

The user would like this table to be included, but there might not be a valid mapping

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UserWantsToInclude As Boolean
C#
public bool UserWantsToInclude { get; }
Visual C++
public:
property bool UserWantsToInclude {
    bool get ();
}

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace


Where Property

[image]

SQL Data Compare API 12.0.40
TableMapping..::.Where Property
TableMapping Class See Also

Where clause object used on the databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Where As WhereClause
C#
public WhereClause Where { get; set; }
Visual C++
public:
property WhereClause^ Where {
    WhereClause^ get ();
    void set (WhereClause^ value);
}

Remarks

Initialized to empty strings.

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace


TableMappings Class

[image]

SQL Data Compare API 12.0.40
TableMappings Class
Members Example See Also

Holds mappings for tables or views in a schema.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class TableMappings _
    Inherits DataCompareMappings(Of TableMapping, ViewTableSuperClass)
C#
public class TableMappings : DataCompareMappings<TableMapping, ViewTableSuperClass>
Visual C++
public ref class TableMappings : public DataCompareMappings<TableMapping^, ViewTableSuperClass^>

Examples

C# Copy Code
            using System;
            using RedGate.SQLCompare.Engine;
            using RedGate.SQLDataCompare.Engine;
            using RedGate.SQLDataCompare.Engine.ResultsStore;

            namespace RedGate.SQLDataCompare.ExampleTests
            {
                public class TableMappingExample
                {
                    public void RunExample()
                    {
                        Database db1=new Database();
                        Database db2=new Database();
                        ComparisonSession session=new ComparisonSession();
                        TableMappings mappings = new TableMappings();

                        try
                        {
                            db1.RegisterForDataCompare(new ConnectionProperties(".", "WidgetDev"));
                            db2.RegisterForDataCompare(new ConnectionProperties(".", "WidgetLive"));

                            // Create the mappings between a certain table
                            TableMapping tableMapping = (TableMapping)mappings.Join(db1.Tables["[dbo].[WidgetPrices]"], db2.Tables["[dbo].[WidgetPrices]"]);

                            // Set the custom comparison key for the table
                            tableMapping.MatchingMappings.Clear();
                            tableMapping.MatchingMappings.Add(tableMapping.FieldMappings["WidgetID"]);
                            tableMapping.RefreshMappingStatus();

                            // Set the where clause for the comparison
                            tableMapping.Where = new WhereClause("Active = 'Y'");

                            // Peform the comparison
                            session.CompareDatabases(db1, db2, mappings);

                            TableDifference difference=session.TableDifferences["[dbo].[WidgetPrices]"];

                            // Loop through all the rows
                            foreach(Row row in difference.ResultsStore)
                            {
                                Console.WriteLine("Row {0} type {1}", row.Index, row.Type.ToString());
                                int i=0;
                                foreach (FieldPair field in difference.ResultsStore.Fields)
                                {
                                    int field1=field.OrdinalInResults1;
                                    int field2=field.OrdinalInResults2;

                                    if (field1 != field2)
                                    {
                                        //get the values
                                        object value1=row.Values[field1];
                                        object value2=row.Values[field2];
                                        if (value1 == null)
                                            value1="NULL";
                                        if (value2 == null)
                                            value2="NULL";
                                        Console.WriteLine("{0}\t{1}\t{2}\t{3}",field.Field(false).Name, value1.ToString(),row.FieldDifferent(i)?"<>":"==",  value2.ToString());
                                    }
                                    else
                                    {
                                        //this is part of the custom index we are comparing on
                                        object value=row.Values[field1];
                                        Console.WriteLine("*{0}\t{1}",field.Field(false).Name, value.ToString());
                                    }
                                    i++;
                                }
                            }
                        }
                        finally
                        {
                            session.Dispose();
                            db1.Dispose();
                            db2.Dispose();
                        }
                    }
                }
            }
Visual Basic Copy Code
            Option Explicit On

            Imports RedGate.SQLCompare.Engine
            Imports RedGate.SQLDataCompare.Engine
            Imports RedGate.SQLDataCompare.Engine.ResultsStore

            Public Class TableMappingExample
                Sub RunExample()
                    Dim session As New ComparisonSession

                    'register the databases for comparison
                    Dim db1 As New Database
                    Dim db2 As New Database

                    db1.RegisterForDataCompare(New ConnectionProperties(".", "WidgetDev"))
                    db2.RegisterForDataCompare(New ConnectionProperties(".", "WidgetLive"))

                    Dim mappings As New TableMappings

                    Dim tableMapping As tableMapping = mappings.Join(db1.Tables("[dbo].[WidgetPrices]"), db2.Tables("[dbo].[WidgetPrices]"))

                    ' Set the custom comparison key for the table
                    tableMapping.MatchingMappings.Clear()
                    tableMapping.MatchingMappings.Add(tableMapping.FieldMappings("WidgetID"))
                    tableMapping.RefreshMappingStatus()

                    ' Set the where clause for the comparison
                    tableMapping.Where = New WhereClause("Active = 'Y'")

                    'compare the databases
                    session.CompareDatabases(db1, db2, mappings)

                    Dim mapping As TableMapping

                    Dim difference As TableDifference = session.TableDifferences("[dbo].[WidgetPrices]")
                    Dim row As row
                    For Each row In difference.ResultsStore  'loop through all the rows
                        Dim field As FieldPair
                        Dim i As Int32 = 0
                        Console.WriteLine("Row {0} type {1}", row.Index, row.Type.ToString())
                        For Each field In difference.ResultsStore.Fields
                            'work out where about in the results the field data is stored
                            'if we were comparing identical records, or records present in one
                            'database but not the other then we would not need to
                            'use the OrdinalInResults1 and OrdinalInResults2 properties
                            'but just OrdinalInResults
                            Dim field1 As Int32 = field.OrdinalInResults1
                            Dim field2 As Int32 = field.OrdinalInResults2

                            If (field1 <> field2) Then
                                'get the values
                                Dim value1 As Object = row.Values(field1)
                                Dim value2 As Object = row.Values(field2)
                                If (value1 Is Nothing) Then
                                    value1 = "NULL"
                                End If
                                If (value2 Is Nothing) Then
                                    value2 = "NULL"
                                End If
                                If row.FieldDifferent(i) Then
                                    Console.WriteLine("{0}:{1} <> {2}", field.Field(False).Name, value1.ToString(), value2.ToString())
                                Else
                                    Console.WriteLine("{0}:{1} == {2}", field.Field(False).Name, value1.ToString(), value2.ToString())
                                End If
                            Else
                                'this is part of the unique index we are comparing on
                                Dim value As Object = row.Values(field1)
                                Console.WriteLine("*{0}:{1}", field.Field(False).Name, value.ToString())
                            End If
                            i += 1
                        Next
                    Next
                    'dispose of the objects
                    session.Dispose()
                    db1.Dispose()
                    db2.Dispose()
                End Sub
            End Class

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( T >)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( TableMapping >)>)
RedGate.SQLCompare.Engine..::.Mappings <(Of <( TableMapping, ViewTableSuperClass, EngineDataCompareOptions >)>)
RedGate.SQLDataCompare.Engine..::.DataCompareMappings <(Of <( TableMapping, ViewTableSuperClass >)>)
RedGate.SQLDataCompare.Engine..::.TableMappings

See Also

TableMappings Members
RedGate.SQLDataCompare.Engine Namespace


TableMappings Members

[image] [image]

SQL Data Compare API 12.0.40
TableMappings Members
TableMappings Class Constructors Methods Fields Properties Explicit Interface Implementations See Also

The TableMappings type exposes the following members.

Constructors

Name | Description
TableMappings | Overloaded.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
CancelOperation | Cancels the current operation. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Clear | Removes all objects from the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Contains | Determines whether the Mappings instance contains a specified object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FromTwo | Returns the Mapping of the object in the second database. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Insert | Not Implemented. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Join | Joins two views or tables, and attempts to map their fields and indexes. If there are no suitable indexes, the status is set to Unable to Compare. (Overrides Mappings <(Of <( TableMapping, ViewTableSuperClass, EngineDataCompareOptions >)>)..::. Join(TMap, TMap).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnValidate | Performs additional custom proccesses when validating a value. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
PrepareScriptIndexes | Prepare the script databases for being mapped - this should be called before CreateMappings
RealAdd | Adds a mapping to this Mappings instance. This will change the forwards and backwards maps as necessary. This will break any mapping that will conflict with the added mapping. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RealRemove | Removes the specified object from the mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ShouldInclude | Called to determine if an object should be included in the mapping at all, one of the obj arguments is null. (Overrides Mappings <(Of <( TableMapping, ViewTableSuperClass, EngineDataCompareOptions >)>)..::. ShouldInclude(TMap, TMap, Object).)
Sort | Sorts the Mappings according the criteria appropriate for the object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Split | Splits a mapping and creates two mappings; one to null, and one from null. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Fields

Name | Description
m_Context | (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
m_PrepareString | (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

Properties

Name | Description
Context | Access to the mapping context. The type of the context is dependent on the mapped objects. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.
Options | The MappingOptions object currently used for mappings. (Inherited from DataCompareMappings<(Of <(TMapping, TMap>)>).)
Status | The event handler used to receive status update events. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

TableMappings Class
RedGate.SQLDataCompare.Engine Namespace


TableMappings Constructor

[image] [image]

SQL Data Compare API 12.0.40
TableMappings Constructor
TableMappings Class See Also

Overload List

Name | Description
TableMappings()()() | Default constructor.
TableMappings(Mappings<(Of <(TableMapping, ViewTableSuperClass, EngineDataCompareOptions>)>)) | Shallow copy constructor.

See Also

TableMappings Class
TableMappings Members
RedGate.SQLDataCompare.Engine Namespace


TableMappings Constructor

[image]

SQL Data Compare API 12.0.40
TableMappings Constructor
TableMappings Class See Also

Default constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TableMappings()
Visual C++
public:
TableMappings()

See Also

TableMappings Class
TableMappings Overload
RedGate.SQLDataCompare.Engine Namespace


TableMappings Constructor (Mappings(TableMapping, ViewTableSuperClass, EngineDataCompareOptions))

[image]

SQL Data Compare API 12.0.40
TableMappings Constructor (Mappings<(Of <(TableMapping, ViewTableSuperClass, EngineDataCompareOptions>)>))
TableMappings Class See Also

Shallow copy constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    tableMappings As Mappings(Of TableMapping, ViewTableSuperClass, EngineDataCompareOptions) _
)
C#
public TableMappings(
    Mappings<TableMapping, ViewTableSuperClass, EngineDataCompareOptions> tableMappings
)
Visual C++
public:
TableMappings(
    Mappings<TableMapping^, ViewTableSuperClass^, EngineDataCompareOptions^>^ tableMappings
)

Parameters

tableMappings
Type: RedGate.SQLCompare.Engine..::.Mappings <(Of <( TableMapping, ViewTableSuperClass, EngineDataCompareOptions >)>)
The TableMappings to be copied.

See Also

TableMappings Class
TableMappings Overload
RedGate.SQLDataCompare.Engine Namespace


TableMappings Methods

[image] [image]

SQL Data Compare API 12.0.40
TableMappings Methods
TableMappings Class See Also

The TableMappings type exposes the following methods.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
CancelOperation | Cancels the current operation. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Clear | Removes all objects from the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Contains | Determines whether the Mappings instance contains a specified object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FromTwo | Returns the Mapping of the object in the second database. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Insert | Not Implemented. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Join | Joins two views or tables, and attempts to map their fields and indexes. If there are no suitable indexes, the status is set to Unable to Compare. (Overrides Mappings <(Of <( TableMapping, ViewTableSuperClass, EngineDataCompareOptions >)>)..::. Join(TMap, TMap).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnValidate | Performs additional custom proccesses when validating a value. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
PrepareScriptIndexes | Prepare the script databases for being mapped - this should be called before CreateMappings
RealAdd | Adds a mapping to this Mappings instance. This will change the forwards and backwards maps as necessary. This will break any mapping that will conflict with the added mapping. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RealRemove | Removes the specified object from the mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ShouldInclude | Called to determine if an object should be included in the mapping at all, one of the obj arguments is null. (Overrides Mappings <(Of <( TableMapping, ViewTableSuperClass, EngineDataCompareOptions >)>)..::. ShouldInclude(TMap, TMap, Object).)
Sort | Sorts the Mappings according the criteria appropriate for the object. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Split | Splits a mapping and creates two mappings; one to null, and one from null. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

TableMappings Class
RedGate.SQLDataCompare.Engine Namespace


CreateMappings Method

[image] [image]

SQL Data Compare API 12.0.40
TableMappings..::.CreateMappings Method
TableMappings Class See Also

Overload List

Name | Description
CreateMappings(IDatabaseObjects<(Of <(Table>)>), IDatabaseObjects<(Of <(Table>)>)) | Creates a mapping for each object in the collection for which such a mapping is possible.
CreateMappings(Views, Views) | Creates a mapping for each object in the collection for which such a mapping is possible.
CreateMappings<(Of <(U>)>)(IKeyedCollection<(Of <(U>)>), IKeyedCollection<(Of <(U>)>), Object, Boolean) | Creates a mapping for each object in the collection where such a mapping is possible. All of the iteration is performed here and the matching can be affected by changing ShouldInclude(TMap, TMap, Object) in the sub class. The main action of joining to objects together is performed by Join(TMap, TMap) which can itself call CreateMappings on child database objects. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

See Also

TableMappings Class
TableMappings Members
RedGate.SQLDataCompare.Engine Namespace


CreateMappings Method ((Table), (Table))

[image]

SQL Data Compare API 12.0.40
TableMappings..::.CreateMappings Method (<(Of <(Table>)>), <(Of <(Table>)>))
TableMappings Class See Also

Creates a mapping for each object in the collection for which such a mapping is possible.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateMappings ( _
    in1 As IDatabaseObjects(Of Table), _
    in2 As IDatabaseObjects(Of Table) _
)
C#
public void CreateMappings(
    IDatabaseObjects<Table> in1,
    IDatabaseObjects<Table> in2
)
Visual C++
public:
void CreateMappings(
    IDatabaseObjects<Table^>^ in1,
    IDatabaseObjects<Table^>^ in2
)

Parameters

in1
Type: IDatabaseObjects<(Of <( Table >)>)
A list of objects in the first database, or null.
in2
Type: IDatabaseObjects<(Of <( Table >)>)
A list of objects in the second database, or null.

See Also

TableMappings Class
CreateMappings Overload
RedGate.SQLDataCompare.Engine Namespace


CreateMappings Method (Views, Views)

[image]

SQL Data Compare API 12.0.40
TableMappings..::.CreateMappings Method (Views, Views)
TableMappings Class See Also

Creates a mapping for each object in the collection for which such a mapping is possible.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateMappings ( _
    in1 As Views, _
    in2 As Views _
)
C#
public void CreateMappings(
    Views in1,
    Views in2
)
Visual C++
public:
void CreateMappings(
    Views^ in1,
    Views^ in2
)

Parameters

in1
Type: RedGate.SQLCompare.Engine..::.Views
List of objects in the first database, or null.
in2
Type: RedGate.SQLCompare.Engine..::.Views
List of objects in the second database, or null.

See Also

TableMappings Class
CreateMappings Overload
RedGate.SQLDataCompare.Engine Namespace


Join Method

[image]

SQL Data Compare API 12.0.40
TableMappings..::.Join Method
TableMappings Class See Also

Joins two views or tables, and attempts to map their fields and indexes. If there are no suitable indexes, the status is set to Unable to Compare.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Join ( _
    obj1 As ViewTableSuperClass, _
    obj2 As ViewTableSuperClass _
) As TableMapping
C#
public override TableMapping Join(
    ViewTableSuperClass obj1,
    ViewTableSuperClass obj2
)
Visual C++
public:
virtual TableMapping^ Join(
    ViewTableSuperClass^ obj1,
    ViewTableSuperClass^ obj2
) override

Parameters

obj1
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
The table or view in the first database.
obj2
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
The table or view in the second database.

Return Value

The created mapping.

Exceptions

Exception | Condition
ArgumentException | TableMappings. Join must be called with ViewTableSuperClass arguments.

See Also

TableMappings Class
RedGate.SQLDataCompare.Engine Namespace


PrepareScriptIndexes Method

[image]

SQL Data Compare API 12.0.40
TableMappings..::.PrepareScriptIndexes Method
TableMappings Class See Also

Prepare the script databases for being mapped - this should be called before CreateMappings

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub PrepareScriptIndexes ( _
    db1 As IDatabase, _
    db2 As IDatabase _
)
C#
public void PrepareScriptIndexes(
    IDatabase db1,
    IDatabase db2
)
Visual C++
public:
void PrepareScriptIndexes(
    IDatabase^ db1,
    IDatabase^ db2
)

Parameters

db1
Type: RedGate.SQLCompare.Engine..::.IDatabase
Database1
db2
Type: RedGate.SQLCompare.Engine..::.IDatabase
Database2

See Also

TableMappings Class
RedGate.SQLDataCompare.Engine Namespace


ShouldInclude Method

[image]

SQL Data Compare API 12.0.40
TableMappings..::.ShouldInclude Method
TableMappings Class See Also

Called to determine if an object should be included in the mapping at all, one of the obj arguments is null.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ShouldInclude ( _
    obj1 As ViewTableSuperClass, _
    obj2 As ViewTableSuperClass, _
    extra As Object _
) As Boolean
C#
protected override bool ShouldInclude(
    ViewTableSuperClass obj1,
    ViewTableSuperClass obj2,
    Object extra
)
Visual C++
protected:
virtual bool ShouldInclude(
    ViewTableSuperClass^ obj1,
    ViewTableSuperClass^ obj2,
    Object^ extra
) override

Parameters

obj1
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
object or null if obj2 not null.
obj2
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
object or null if obj1 not null.
extra
Type: Object
extra data passed into CreateMappings internally to determine relevance.

Return Value

true ( default )for inclusion, false otherwise.

See Also

TableMappings Class
RedGate.SQLDataCompare.Engine Namespace


TableMappingStatus Enumeration

[image]

SQL Data Compare API 12.0.40
TableMappingStatus Enumeration
See Also

The result of the mapping.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration TableMappingStatus
C#
public enum TableMappingStatus
Visual C++
public enum class TableMappingStatus

Members

Member name | Description
Success | The mapping was successful.
UnableToCompare | The mapping succeeded, but SQL Data Compare is unable to compare. This is usually because of type comparison failure.
PartialSuccess | The mapping was a partial success; some columns remain unmapped.

See Also

RedGate.SQLDataCompare.Engine Namespace


UserActionWarning Structure

[image]

SQL Data Compare API 12.0.40
UserActionWarning Structure
Members See Also

Contains details of a user action that has failed due to schema changes since the project was created.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Structure UserActionWarning
C#
public struct UserActionWarning
Visual C++
public value class UserActionWarning

See Also

UserActionWarning Members
RedGate.SQLDataCompare.Engine Namespace


UserActionWarning Members

[image] [image]

SQL Data Compare API 12.0.40
UserActionWarning Members
UserActionWarning Structure Methods Properties See Also

The UserActionWarning type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
Message | Textual description of the reason for the failure of the user action.
UserAction | The user action that has failed.

See Also

UserActionWarning Structure
RedGate.SQLDataCompare.Engine Namespace


UserActionWarning Properties

[image] [image]

SQL Data Compare API 12.0.40
UserActionWarning Properties
UserActionWarning Structure See Also

The UserActionWarning type exposes the following properties.

Properties

Name | Description
Message | Textual description of the reason for the failure of the user action.
UserAction | The user action that has failed.

See Also

UserActionWarning Structure
RedGate.SQLDataCompare.Engine Namespace


Message Property

[image]

SQL Data Compare API 12.0.40
UserActionWarning..::.Message Property
UserActionWarning Structure See Also

Textual description of the reason for the failure of the user action.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Message As String
C#
public string Message { get; }
Visual C++
public:
property String^ Message {
    String^ get ();
}

See Also

UserActionWarning Structure
RedGate.SQLDataCompare.Engine Namespace


UserAction Property

[image]

SQL Data Compare API 12.0.40
UserActionWarning..::.UserAction Property
UserActionWarning Structure See Also

The user action that has failed.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UserAction As SelectTableEvent
C#
public SelectTableEvent UserAction { get; }
Visual C++
public:
property SelectTableEvent UserAction {
    SelectTableEvent get ();
}

See Also

UserActionWarning Structure
RedGate.SQLDataCompare.Engine Namespace


WhereClause Class

[image]

SQL Data Compare API 12.0.40
WhereClause Class
Members See Also

An encapsulation class for the WHERE clause used on the tables in the databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class WhereClause
C#
public class WhereClause
Visual C++
public ref class WhereClause

Inheritance Hierarchy

Object
RedGate.SQLDataCompare.Engine..::.WhereClause

See Also

WhereClause Members
RedGate.SQLDataCompare.Engine Namespace


WhereClause Members

[image] [image]

SQL Data Compare API 12.0.40
WhereClause Members
WhereClause Class Constructors Methods Properties See Also

The WhereClause type exposes the following members.

Constructors

Name | Description
WhereClause | Overloaded.

Methods

Name | Description
Clause | A convenience function for easy access to the first or second WHERE clause. Returns the appropriate WHERE clause.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Clause1 | The WHERE clause used on the table in the first database.
Clause2 | The WHERE clause used on the table in the second database.

See Also

WhereClause Class
RedGate.SQLDataCompare.Engine Namespace


WhereClause Constructor

[image] [image]

SQL Data Compare API 12.0.40
WhereClause Constructor
WhereClause Class See Also

Overload List

Name | Description
WhereClause()()() | Default constructor. The WHERE clauses are set to empty strings for both databases.
WhereClause(String) | Constructor.
WhereClause(WhereClause) | Copy constructor.
WhereClause(String, String) | Constructor.

See Also

WhereClause Class
WhereClause Members
RedGate.SQLDataCompare.Engine Namespace


WhereClause Constructor

[image]

SQL Data Compare API 12.0.40
WhereClause Constructor
WhereClause Class See Also

Default constructor. The WHERE clauses are set to empty strings for both databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public WhereClause()
Visual C++
public:
WhereClause()

See Also

WhereClause Class
WhereClause Overload
RedGate.SQLDataCompare.Engine Namespace


WhereClause Constructor ()

[image]

SQL Data Compare API 12.0.40
WhereClause Constructor ()
WhereClause Class See Also

Constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    clause As String _
)
C#
public WhereClause(
    string clause
)
Visual C++
public:
WhereClause(
    String^ clause
)

Parameters

clause
Type: String
The WHERE clause to be used on the tables in both databases.

See Also

WhereClause Class
WhereClause Overload
RedGate.SQLDataCompare.Engine Namespace


WhereClause Constructor (WhereClause)

[image]

SQL Data Compare API 12.0.40
WhereClause Constructor (WhereClause)
WhereClause Class See Also

Copy constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    source As WhereClause _
)
C#
public WhereClause(
    WhereClause source
)
Visual C++
public:
WhereClause(
    WhereClause^ source
)

Parameters

source
Type: RedGate.SQLDataCompare.Engine..::.WhereClause
The source WHERE clause to be copied to the new class.

See Also

WhereClause Class
WhereClause Overload
RedGate.SQLDataCompare.Engine Namespace


WhereClause Constructor (, )

[image]

SQL Data Compare API 12.0.40
WhereClause Constructor (, )
WhereClause Class See Also

Constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    clause1 As String, _
    clause2 As String _
)
C#
public WhereClause(
    string clause1,
    string clause2
)
Visual C++
public:
WhereClause(
    String^ clause1,
    String^ clause2
)

Parameters

clause1
Type: String
The WHERE clause to be used on the table in the first database.
clause2
Type: String
The WHERE clause to be used on the table in the second database.

See Also

WhereClause Class
WhereClause Overload
RedGate.SQLDataCompare.Engine Namespace


WhereClause Methods

[image] [image]

SQL Data Compare API 12.0.40
WhereClause Methods
WhereClause Class See Also

The WhereClause type exposes the following methods.

Methods

Name | Description
Clause | A convenience function for easy access to the first or second WHERE clause. Returns the appropriate WHERE clause.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WhereClause Class
RedGate.SQLDataCompare.Engine Namespace


Clause Method

[image]

SQL Data Compare API 12.0.40
WhereClause..::.Clause Method
WhereClause Class See Also

A convenience function for easy access to the first or second WHERE clause. Returns the appropriate WHERE clause.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Clause ( _
    onTwo As Boolean _
) As String
C#
public string Clause(
    bool onTwo
)
Visual C++
public:
String^ Clause(
    bool onTwo
)

Parameters

onTwo
Type: Boolean
true to return the WHERE clause for the second database; false to return the WHERE clause for first database.

Return Value

The WHERE clause for the requested database.

See Also

WhereClause Class
RedGate.SQLDataCompare.Engine Namespace


WhereClause Properties

[image] [image]

SQL Data Compare API 12.0.40
WhereClause Properties
WhereClause Class See Also

The WhereClause type exposes the following properties.

Properties

Name | Description
Clause1 | The WHERE clause used on the table in the first database.
Clause2 | The WHERE clause used on the table in the second database.

See Also

WhereClause Class
RedGate.SQLDataCompare.Engine Namespace


Clause1 Property

[image]

SQL Data Compare API 12.0.40
WhereClause..::.Clause1 Property
WhereClause Class See Also

The WHERE clause used on the table in the first database.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Clause1 As String
C#
public string Clause1 { get; set; }
Visual C++
public:
property String^ Clause1 {
    String^ get ();
    void set (String^ value);
}

See Also

WhereClause Class
RedGate.SQLDataCompare.Engine Namespace


Clause2 Property

[image]

SQL Data Compare API 12.0.40
WhereClause..::.Clause2 Property
WhereClause Class See Also

The WHERE clause used on the table in the second database.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Clause2 As String
C#
public string Clause2 { get; set; }
Visual C++
public:
property String^ Clause2 {
    String^ get ();
    void set (String^ value);
}

See Also

WhereClause Class
RedGate.SQLDataCompare.Engine Namespace


RedGate.SQLDataCompare.Engine.FolderReader Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLDataCompare.Engine.FolderReader Namespace

Classes

Class | Description
DataCompareScriptSyncAction | A ScriptSynchronizationAction for data related changes to a scripts folder.
FolderScriptParserException | Exception thrown by ComparisonSession when it encounters an error comparing the databases.
FolderStructure | Encapsulates path information for the data parts of a scripts folder.
SqlDataCompareComputedColumnMarker | Marker for computed columns. TODO: (MU, 17/03/2015) Figure out why someone decided it was a good idea for this IComparable object to compare equal to everything in the world.


DataCompareScriptSyncAction Class

[image]

SQL Data Compare API 12.0.40
DataCompareScriptSyncAction Class
Members See Also

A ScriptSynchronizationAction for data related changes to a scripts folder.

Namespace: RedGate.SQLDataCompare.Engine.FolderReader
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataCompareScriptSyncAction _
    Inherits ScriptSynchronizationAction
C#
public sealed class DataCompareScriptSyncAction : ScriptSynchronizationAction
Visual C++
public ref class DataCompareScriptSyncAction sealed : public ScriptSynchronizationAction

Inheritance Hierarchy

Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationAction
RedGate.SQLDataCompare.Engine.FolderReader..::.DataCompareScriptSyncAction

See Also

DataCompareScriptSyncAction Members
RedGate.SQLDataCompare.Engine.FolderReader Namespace


DataCompareScriptSyncAction Members

[image] [image]

SQL Data Compare API 12.0.40
DataCompareScriptSyncAction Members
DataCompareScriptSyncAction Class Methods Properties See Also

The DataCompareScriptSyncAction type exposes the following members.

Methods

Name | Description
Check | Checks if the script synchronization action can be carried out. (Overrides ScriptSynchronizationAction ..::. Check()()().)
CheckFileAndDirectoryPermissions | (Inherited from ScriptSynchronizationAction.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Executes the synchronization action. (Overrides ScriptSynchronizationAction ..::. Execute()()().)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DatabaseObjectType | Returns None()()() (Overrides ScriptSynchronizationAction ..::. DatabaseObjectType.)
FileName | The file name for this synchronization action. (Inherited from ScriptSynchronizationAction.)
ShortFileName | The name of the file and its prefix folder for this particular synchronization action. (Inherited from ScriptSynchronizationAction.)

See Also

DataCompareScriptSyncAction Class
RedGate.SQLDataCompare.Engine.FolderReader Namespace


DataCompareScriptSyncAction Methods

[image] [image]

SQL Data Compare API 12.0.40
DataCompareScriptSyncAction Methods
DataCompareScriptSyncAction Class See Also

The DataCompareScriptSyncAction type exposes the following methods.

Methods

Name | Description
Check | Checks if the script synchronization action can be carried out. (Overrides ScriptSynchronizationAction ..::. Check()()().)
CheckFileAndDirectoryPermissions | (Inherited from ScriptSynchronizationAction.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Executes the synchronization action. (Overrides ScriptSynchronizationAction ..::. Execute()()().)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataCompareScriptSyncAction Class
RedGate.SQLDataCompare.Engine.FolderReader Namespace


Check Method

[image]

SQL Data Compare API 12.0.40
DataCompareScriptSyncAction..::.Check Method
DataCompareScriptSyncAction Class See Also

Checks if the script synchronization action can be carried out.

Namespace: RedGate.SQLDataCompare.Engine.FolderReader
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Check
C#
public override void Check()
Visual C++
public:
virtual void Check() override

See Also

DataCompareScriptSyncAction Class
RedGate.SQLDataCompare.Engine.FolderReader Namespace


Execute Method

[image]

SQL Data Compare API 12.0.40
DataCompareScriptSyncAction..::.Execute Method
DataCompareScriptSyncAction Class See Also

Executes the synchronization action.

Namespace: RedGate.SQLDataCompare.Engine.FolderReader
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Execute
C#
public override void Execute()
Visual C++
public:
virtual void Execute() override

See Also

DataCompareScriptSyncAction Class
RedGate.SQLDataCompare.Engine.FolderReader Namespace


DataCompareScriptSyncAction Properties

[image] [image]

SQL Data Compare API 12.0.40
DataCompareScriptSyncAction Properties
DataCompareScriptSyncAction Class See Also

The DataCompareScriptSyncAction type exposes the following properties.

Properties

Name | Description
DatabaseObjectType | Returns None()()() (Overrides ScriptSynchronizationAction ..::. DatabaseObjectType.)
FileName | The file name for this synchronization action. (Inherited from ScriptSynchronizationAction.)
ShortFileName | The name of the file and its prefix folder for this particular synchronization action. (Inherited from ScriptSynchronizationAction.)

See Also

DataCompareScriptSyncAction Class
RedGate.SQLDataCompare.Engine.FolderReader Namespace


DatabaseObjectType Property

[image]

SQL Data Compare API 12.0.40
DataCompareScriptSyncAction..::.DatabaseObjectType Property
DataCompareScriptSyncAction Class See Also

Returns None()()()

Namespace: RedGate.SQLDataCompare.Engine.FolderReader
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property DatabaseObjectType As ObjectType
C#
public override ObjectType DatabaseObjectType { get; }
Visual C++
public:
virtual property ObjectType DatabaseObjectType {
    ObjectType get () override;
}

See Also

DataCompareScriptSyncAction Class
RedGate.SQLDataCompare.Engine.FolderReader Namespace


FolderScriptParserException Class

[image]

SQL Data Compare API 12.0.40
FolderScriptParserException Class
Members See Also

Exception thrown by ComparisonSession when it encounters an error comparing the databases.

Namespace: RedGate.SQLDataCompare.Engine.FolderReader
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class FolderScriptParserException _
    Inherits SqlDataCompareException
C#
[SerializableAttribute]
public class FolderScriptParserException : SqlDataCompareException
Visual C++
[SerializableAttribute]
public ref class FolderScriptParserException : public SqlDataCompareException

Inheritance Hierarchy

Object
Exception
RedGate.SQLDataCompare.Engine..::.SqlDataCompareException
RedGate.SQLDataCompare.Engine.FolderReader..::.FolderScriptParserException

See Also

FolderScriptParserException Members
RedGate.SQLDataCompare.Engine.FolderReader Namespace


FolderScriptParserException Members

[image] [image]

SQL Data Compare API 12.0.40
FolderScriptParserException Members
FolderScriptParserException Class Constructors Methods Properties See Also

The FolderScriptParserException type exposes the following members.

Constructors

Name | Description
FolderScriptParserException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FolderScriptParserException Class
RedGate.SQLDataCompare.Engine.FolderReader Namespace


FolderScriptParserException Constructor

[image] [image]

SQL Data Compare API 12.0.40
FolderScriptParserException Constructor
FolderScriptParserException Class See Also

Overload List

Name | Description
FolderScriptParserException()()() | Creates a new exception.
FolderScriptParserException(String) | Creates a new exception with the specified detail message.
FolderScriptParserException(SerializationInfo, StreamingContext) | This constructor is called during deserialization to reconstitute the exception object transmitted over a stream. For more information, see XML and SOAP Serialization.
FolderScriptParserException(String, Exception) | Creates a new exception with the specified detail message and cause.

See Also

FolderScriptParserException Class
FolderScriptParserException Members
RedGate.SQLDataCompare.Engine.FolderReader Namespace


FolderScriptParserException Constructor

[image]

SQL Data Compare API 12.0.40
FolderScriptParserException Constructor
FolderScriptParserException Class See Also

Creates a new exception.

Namespace: RedGate.SQLDataCompare.Engine.FolderReader
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FolderScriptParserException()
Visual C++
public:
FolderScriptParserException()

See Also

FolderScriptParserException Class
FolderScriptParserException Overload
RedGate.SQLDataCompare.Engine.FolderReader Namespace


FolderScriptParserException Constructor ()

[image]

SQL Data Compare API 12.0.40
FolderScriptParserException Constructor ()
FolderScriptParserException Class See Also

Creates a new exception with the specified detail message.

Namespace: RedGate.SQLDataCompare.Engine.FolderReader
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public FolderScriptParserException(
    string message
)
Visual C++
public:
FolderScriptParserException(
    String^ message
)

Parameters

message
Type: String
Detail message.

See Also

FolderScriptParserException Class
FolderScriptParserException Overload
RedGate.SQLDataCompare.Engine.FolderReader Namespace


FolderScriptParserException Constructor (, )

[image]

SQL Data Compare API 12.0.40
FolderScriptParserException Constructor (, )
FolderScriptParserException Class See Also

This constructor is called during deserialization to reconstitute the exception object transmitted over a stream. For more information, see XML and SOAP Serialization.

Namespace: RedGate.SQLDataCompare.Engine.FolderReader
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected FolderScriptParserException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
FolderScriptParserException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: SerializationInfo
The object that holds the serialized object data.
context
Type: StreamingContext
The contextual information about the source or destination.

See Also

FolderScriptParserException Class
FolderScriptParserException Overload
RedGate.SQLDataCompare.Engine.FolderReader Namespace


FolderScriptParserException Constructor (, )

[image]

SQL Data Compare API 12.0.40
FolderScriptParserException Constructor (, )
FolderScriptParserException Class See Also

Creates a new exception with the specified detail message and cause.

Namespace: RedGate.SQLDataCompare.Engine.FolderReader
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    cause As Exception _
)
C#
public FolderScriptParserException(
    string message,
    Exception cause
)
Visual C++
public:
FolderScriptParserException(
    String^ message,
    Exception^ cause
)

Parameters

message
Type: String
Detail message.
cause
Type: Exception
Cause of exception.

See Also

FolderScriptParserException Class
FolderScriptParserException Overload
RedGate.SQLDataCompare.Engine.FolderReader Namespace


FolderStructure Class

[image]

SQL Data Compare API 12.0.40
FolderStructure Class
Members See Also

Encapsulates path information for the data parts of a scripts folder.

Namespace: RedGate.SQLDataCompare.Engine.FolderReader
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FolderStructure
C#
public sealed class FolderStructure
Visual C++
public ref class FolderStructure sealed

Inheritance Hierarchy

Object
RedGate.SQLDataCompare.Engine.FolderReader..::.FolderStructure

See Also

FolderStructure Members
RedGate.SQLDataCompare.Engine.FolderReader Namespace


FolderStructure Members

[image] [image]

SQL Data Compare API 12.0.40
FolderStructure Members
FolderStructure Class Methods See Also

The FolderStructure type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ObviousDataFileExists | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FolderStructure Class
RedGate.SQLDataCompare.Engine.FolderReader Namespace


FolderStructure Methods

[image] [image]

SQL Data Compare API 12.0.40
FolderStructure Methods
FolderStructure Class See Also

The FolderStructure type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ObviousDataFileExists | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FolderStructure Class
RedGate.SQLDataCompare.Engine.FolderReader Namespace


ObviousDataFileExists Method

[image] [image]

SQL Data Compare API 12.0.40
FolderStructure..::.ObviousDataFileExists Method
FolderStructure Class See Also

Overload List

Name | Description
ObviousDataFileExists(String, String, HashSet<(Of <(String>)>)) | Determines if a .SQL file exists in the data directory for this table without parsing any .SQL files. Note: This can return unexpected results if FolderStructure had to choose a non-default name for the .SQL file for the table that was being scripted out.
ObviousDataFileExists(Table, ScriptDatabaseInformation, String) | Determines if a .SQL file exists in the data directory for this table without parsing any .SQL files. Note: This can return unexpected results if FolderStructure had to choose a non-default name for the .SQL file for the table that was being scripted out.

See Also

FolderStructure Class
FolderStructure Members
RedGate.SQLDataCompare.Engine.FolderReader Namespace


ObviousDataFileExists Method (, , ())

[image]

SQL Data Compare API 12.0.40
FolderStructure..::.ObviousDataFileExists Method (, , <(Of <(>)>))
FolderStructure Class See Also

Determines if a .SQL file exists in the data directory for this table without parsing any .SQL files. Note: This can return unexpected results if FolderStructure had to choose a non-default name for the .SQL file for the table that was being scripted out.

Namespace: RedGate.SQLDataCompare.Engine.FolderReader
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ObviousDataFileExists ( _
    owner As String, _
    tableName As String, _
    files As HashSet(Of String) _
) As Boolean
C#
public static bool ObviousDataFileExists(
    string owner,
    string tableName,
    HashSet<string> files
)
Visual C++
public:
static bool ObviousDataFileExists(
    String^ owner,
    String^ tableName,
    HashSet<String^>^ files
)

Parameters

owner
Type: String
The owner of the tabel to check
tableName
Type: String
The name of the table to check
files
Type: HashSet<(Of <(String>)>)
The files to check against

Return Value

True to indicate the presence of a .SQL file that is likely the data file for the Table. False to indicate no likely candidate found

See Also

FolderStructure Class
ObviousDataFileExists Overload
RedGate.SQLDataCompare.Engine.FolderReader Namespace


ObviousDataFileExists Method (Table, ScriptDatabaseInformation, )

[image]

SQL Data Compare API 12.0.40
FolderStructure..::.ObviousDataFileExists Method (Table, ScriptDatabaseInformation, )
FolderStructure Class See Also

Determines if a .SQL file exists in the data directory for this table without parsing any .SQL files. Note: This can return unexpected results if FolderStructure had to choose a non-default name for the .SQL file for the table that was being scripted out.

Namespace: RedGate.SQLDataCompare.Engine.FolderReader
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ObviousDataFileExists ( _
    table As Table, _
    information As ScriptDatabaseInformation, _
    folderPath As String _
) As Boolean
C#
public static bool ObviousDataFileExists(
    Table table,
    ScriptDatabaseInformation information,
    string folderPath
)
Visual C++
public:
static bool ObviousDataFileExists(
    Table^ table,
    ScriptDatabaseInformation^ information,
    String^ folderPath
)

Parameters

table
Type: RedGate.SQLCompare.Engine..::.Table
The Table to check if the data file exists for
information
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptDatabaseInformation
A RedGateDatabaseInfo for the scripts folder
folderPath
Type: String
The full path of the scripts folder

Return Value

True to indicate the presence of a .SQL file that is likely the data file for the Table. False to indicate no likely candidate found

See Also

FolderStructure Class
ObviousDataFileExists Overload
RedGate.SQLDataCompare.Engine.FolderReader Namespace


SqlDataCompareComputedColumnMarker Class

[image]

SQL Data Compare API 12.0.40
SqlDataCompareComputedColumnMarker Class
Members See Also

Marker for computed columns. TODO: (MU, 17/03/2015) Figure out why someone decided it was a good idea for this IComparable object to compare equal to everything in the world.

Namespace: RedGate.SQLDataCompare.Engine.FolderReader
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SqlDataCompareComputedColumnMarker _
    Implements IComparable
C#
public sealed class SqlDataCompareComputedColumnMarker : IComparable
Visual C++
public ref class SqlDataCompareComputedColumnMarker sealed : IComparable

Inheritance Hierarchy

Object
RedGate.SQLDataCompare.Engine.FolderReader..::.SqlDataCompareComputedColumnMarker

See Also

SqlDataCompareComputedColumnMarker Members
RedGate.SQLDataCompare.Engine.FolderReader Namespace


SqlDataCompareComputedColumnMarker Members

[image] [image]

SQL Data Compare API 12.0.40
SqlDataCompareComputedColumnMarker Members
SqlDataCompareComputedColumnMarker Class Constructors Methods See Also

The SqlDataCompareComputedColumnMarker type exposes the following members.

Constructors

Name | Description
SqlDataCompareComputedColumnMarker |

Methods

Name | Description
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

SqlDataCompareComputedColumnMarker Class
RedGate.SQLDataCompare.Engine.FolderReader Namespace


SqlDataCompareComputedColumnMarker Constructor

[image]

SQL Data Compare API 12.0.40
SqlDataCompareComputedColumnMarker Constructor
SqlDataCompareComputedColumnMarker Class See Also

Namespace: RedGate.SQLDataCompare.Engine.FolderReader
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlDataCompareComputedColumnMarker()
Visual C++
public:
SqlDataCompareComputedColumnMarker()

See Also

SqlDataCompareComputedColumnMarker Class
RedGate.SQLDataCompare.Engine.FolderReader Namespace


SqlDataCompareComputedColumnMarker Methods

[image] [image]

SQL Data Compare API 12.0.40
SqlDataCompareComputedColumnMarker Methods
SqlDataCompareComputedColumnMarker Class See Also

The SqlDataCompareComputedColumnMarker type exposes the following methods.

Methods

Name | Description
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

SqlDataCompareComputedColumnMarker Class
RedGate.SQLDataCompare.Engine.FolderReader Namespace


CompareTo Method

[image]

SQL Data Compare API 12.0.40
SqlDataCompareComputedColumnMarker..::.CompareTo Method
SqlDataCompareComputedColumnMarker Class See Also

Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

Namespace: RedGate.SQLDataCompare.Engine.FolderReader
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareTo ( _
    obj As Object _
) As Integer
C#
public int CompareTo(
    Object obj
)
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: Object
An object to compare with this instance.

Return Value

A 32-bit signed integer that indicates the relative order of the objects being compared. The return value has these meanings: Value Meaning Less than zero This instance is less than obj. Zero This instance is equal to obj. Greater than zero This instance is greater than obj.

Implements

IComparableCompareTo(Object)

Exceptions

Exception | Condition
ArgumentException | obj is not the same type as this instance.

See Also

SqlDataCompareComputedColumnMarker Class
RedGate.SQLDataCompare.Engine.FolderReader Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
SqlDataCompareComputedColumnMarker..::.ToString Method
SqlDataCompareComputedColumnMarker Class See Also

Returns a String that represents the current Object.

Namespace: RedGate.SQLDataCompare.Engine.FolderReader
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

SqlDataCompareComputedColumnMarker Class
RedGate.SQLDataCompare.Engine.FolderReader Namespace


RedGate.SQLDataCompare.Engine.FolderReader.InsertReader Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLDataCompare.Engine.FolderReader.InsertReader Namespace

Classes

Class | Description
UseFastParser | Static flag to control whether the Data Compare engine should use ScriptFastDataReader or SQLDataCompareScriptsDataReader when parsing script files.


UseFastParser Class

[image]

SQL Data Compare API 12.0.40
UseFastParser Class
Members See Also

Static flag to control whether the Data Compare engine should use ScriptFastDataReader or SQLDataCompareScriptsDataReader when parsing script files.

Namespace: RedGate.SQLDataCompare.Engine.FolderReader.InsertReader
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class UseFastParser
C#
public static class UseFastParser
Visual C++
public ref class UseFastParser abstract sealed

Inheritance Hierarchy

Object
RedGate.SQLDataCompare.Engine.FolderReader.InsertReader..::.UseFastParser

See Also

UseFastParser Members
RedGate.SQLDataCompare.Engine.FolderReader.InsertReader Namespace


UseFastParser Members

[image] [image]

SQL Data Compare API 12.0.40
UseFastParser Members
UseFastParser Class Fields See Also

The UseFastParser type exposes the following members.

Fields

Name Description
ShallI
Set this value to control which data reader is used:
  • falseUse SQLDataCompareScriptsDataReader
  • trueUse ScriptFastDataReader

See Also

UseFastParser Class
RedGate.SQLDataCompare.Engine.FolderReader.InsertReader Namespace


UseFastParser Fields

[image] [image]

SQL Data Compare API 12.0.40
UseFastParser Fields
UseFastParser Class See Also

The UseFastParser type exposes the following fields.

Fields

Name Description
ShallI
Set this value to control which data reader is used:
  • falseUse SQLDataCompareScriptsDataReader
  • trueUse ScriptFastDataReader

See Also

UseFastParser Class
RedGate.SQLDataCompare.Engine.FolderReader.InsertReader Namespace


ShallI Field

[image]

SQL Data Compare API 12.0.40
UseFastParser..::.ShallI Field
UseFastParser Class See Also

Set this value to control which data reader is used:
  • falseUse SQLDataCompareScriptsDataReader
  • trueUse ScriptFastDataReader

Namespace: RedGate.SQLDataCompare.Engine.FolderReader.InsertReader
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ShallI As Boolean
C#
public static bool ShallI
Visual C++
public:
static bool ShallI

See Also

UseFastParser Class
RedGate.SQLDataCompare.Engine.FolderReader.InsertReader Namespace


RedGate.SQLDataCompare.Engine.ResultsStore Namespace

[image]

SQL Data Compare API 12.0.40
RedGate.SQLDataCompare.Engine.ResultsStore Namespace

Classes

Class | Description
ColumnConstraint | A class to filter the ResultsStore on field data.
ColumnRange | A range for a ColumnConstraint. A ColumnConstraint can contain a number of ranges.
ColumnSort | A class to sort the ResultsStore by field data.
ColumnSorts | A collection of ColumnSorts to be applied to a ResultsStore.
Filter | Used to create a filtered ResultsStore using the ApplyFilter method.
Missing | Signifies a Missing result, for which there is no value in the ResultsStore. There is a singleton class of this type, so all reference comparisons are valid.
Reader | Reads data from a results store. Can be created using GetReader()()().
ResultsStoreException | Exception thrown by classes in the RedGate.SQLDataCompare.Engine.ResultsStore namespace when it encounters an error.
Row | A row containing data in a ResultsStore object.
Sort | Used to specify a sort order for the ResultsStore when using ApplySort()()().
Store | A data set containing a collection of rows.

Interfaces

Interface | Description
IReader | Reader interface for reading from a RedGate.SQLDataCompare.Engine.ResultsStore

Enumerations

Enumeration | Description
FieldType | The types of field that a ResultsStore can contain.
Row..::.RowType | The type of the row. The values All and TotalDifferent can be used for DifferenceCount(Row..::.RowType).


ColumnConstraint Class

[image]

SQL Data Compare API 12.0.40
ColumnConstraint Class
Members See Also

A class to filter the ResultsStore on field data.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ColumnConstraint
C#
public class ColumnConstraint
Visual C++
public ref class ColumnConstraint

Inheritance Hierarchy

Object
RedGate.SQLDataCompare.Engine.ResultsStore..::.ColumnConstraint

See Also

ColumnConstraint Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnConstraint Members

[image] [image]

SQL Data Compare API 12.0.40
ColumnConstraint Members
ColumnConstraint Class Constructors Methods Properties See Also

The ColumnConstraint type exposes the following members.

Constructors

Name | Description
ColumnConstraint | Constructs a new ColumnConstraint object.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConstraintRanges | A set of ColumnRanges. The field must conform to at least one of the ColumnRanges.
FieldPair | The FieldPair to be filtered.
InOne | The constraint is to be used on the field in the first database.

See Also

ColumnConstraint Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnConstraint Constructor

[image]

SQL Data Compare API 12.0.40
ColumnConstraint Constructor
ColumnConstraint Class See Also

Constructs a new ColumnConstraint object.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fieldPair As FieldPair, _
    inOne As Boolean _
)
C#
public ColumnConstraint(
    FieldPair fieldPair,
    bool inOne
)
Visual C++
public:
ColumnConstraint(
    FieldPair^ fieldPair,
    bool inOne
)

Parameters

fieldPair
Type: RedGate.SQLDataCompare.Engine..::.FieldPair
The FieldPair being filtered.
inOne
Type: Boolean
true if the field is being filtered on the data in the first database.

See Also

ColumnConstraint Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnConstraint Properties

[image] [image]

SQL Data Compare API 12.0.40
ColumnConstraint Properties
ColumnConstraint Class See Also

The ColumnConstraint type exposes the following properties.

Properties

Name | Description
ConstraintRanges | A set of ColumnRanges. The field must conform to at least one of the ColumnRanges.
FieldPair | The FieldPair to be filtered.
InOne | The constraint is to be used on the field in the first database.

See Also

ColumnConstraint Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ConstraintRanges Property

[image]

SQL Data Compare API 12.0.40
ColumnConstraint..::.ConstraintRanges Property
ColumnConstraint Class See Also

A set of ColumnRanges. The field must conform to at least one of the ColumnRanges.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConstraintRanges As IList(Of ColumnRange)
C#
public IList<ColumnRange> ConstraintRanges { get; }
Visual C++
public:
property IList<ColumnRange^>^ ConstraintRanges {
    IList<ColumnRange^>^ get ();
}

See Also

ColumnConstraint Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


FieldPair Property

[image]

SQL Data Compare API 12.0.40
ColumnConstraint..::.FieldPair Property
ColumnConstraint Class See Also

The FieldPair to be filtered.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FieldPair As FieldPair
C#
public FieldPair FieldPair { get; set; }
Visual C++
public:
property FieldPair^ FieldPair {
    FieldPair^ get ();
    void set (FieldPair^ value);
}

See Also

ColumnConstraint Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


InOne Property

[image]

SQL Data Compare API 12.0.40
ColumnConstraint..::.InOne Property
ColumnConstraint Class See Also

The constraint is to be used on the field in the first database.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property InOne As Boolean
C#
public bool InOne { get; set; }
Visual C++
public:
property bool InOne {
    bool get ();
    void set (bool value);
}

See Also

ColumnConstraint Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnRange Class

[image]

SQL Data Compare API 12.0.40
ColumnRange Class
Members See Also

A range for a ColumnConstraint. A ColumnConstraint can contain a number of ranges.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ColumnRange
C#
public class ColumnRange
Visual C++
public ref class ColumnRange

Inheritance Hierarchy

Object
RedGate.SQLDataCompare.Engine.ResultsStore..::.ColumnRange

See Also

ColumnRange Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnRange Members

[image] [image]

SQL Data Compare API 12.0.40
ColumnRange Members
ColumnRange Class Constructors Methods Properties See Also

The ColumnRange type exposes the following members.

Constructors

Name | Description
ColumnRange | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsMissing | If set, the field value must be Missing. IsNull takes priority over this property.
IsNull | If set, the field must be null. This property takes priority over IsMissing.
MaxValue | The maximum (inclusive) value for a field.
MinValue | The minimum (inclusive) value for a field.

See Also

ColumnRange Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnRange Constructor

[image] [image]

SQL Data Compare API 12.0.40
ColumnRange Constructor
ColumnRange Class See Also

Overload List

Name | Description
ColumnRange(Boolean) | Constructs a range constraint in which the field must be null if true, or not null if false .
ColumnRange(IComparable) | Constructs a range constraint for a field filter in which the field must be greater than or equal to the specified value.
ColumnRange(IComparable, IComparable) | Constructs a range constraint for a field filter in which the field must be greater than or equal to the minimum value, and less than or equal to the maximum value.

See Also

ColumnRange Class
ColumnRange Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnRange Constructor ()

[image]

SQL Data Compare API 12.0.40
ColumnRange Constructor ()
ColumnRange Class See Also

Constructs a range constraint in which the field must be null if true, or not null if false .

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    isNull As Boolean _
)
C#
public ColumnRange(
    bool isNull
)
Visual C++
public:
ColumnRange(
    bool isNull
)

Parameters

isNull
Type: Boolean
true if the field must be null.

See Also

ColumnRange Class
ColumnRange Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnRange Constructor ()

[image]

SQL Data Compare API 12.0.40
ColumnRange Constructor ()
ColumnRange Class See Also

Constructs a range constraint for a field filter in which the field must be greater than or equal to the specified value.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    minValue As IComparable _
)
C#
public ColumnRange(
    IComparable minValue
)
Visual C++
public:
ColumnRange(
    IComparable^ minValue
)

Parameters

minValue
Type: IComparable
The minimum value (inclusive).

See Also

ColumnRange Class
ColumnRange Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnRange Constructor (, )

[image]

SQL Data Compare API 12.0.40
ColumnRange Constructor (, )
ColumnRange Class See Also

Constructs a range constraint for a field filter in which the field must be greater than or equal to the minimum value, and less than or equal to the maximum value.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    minValue As IComparable, _
    maxValue As IComparable _
)
C#
public ColumnRange(
    IComparable minValue,
    IComparable maxValue
)
Visual C++
public:
ColumnRange(
    IComparable^ minValue,
    IComparable^ maxValue
)

Parameters

minValue
Type: IComparable
The minimum value (inclusive).
maxValue
Type: IComparable
The maximum value (inclusive).

See Also

ColumnRange Class
ColumnRange Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnRange Properties

[image] [image]

SQL Data Compare API 12.0.40
ColumnRange Properties
ColumnRange Class See Also

The ColumnRange type exposes the following properties.

Properties

Name | Description
IsMissing | If set, the field value must be Missing. IsNull takes priority over this property.
IsNull | If set, the field must be null. This property takes priority over IsMissing.
MaxValue | The maximum (inclusive) value for a field.
MinValue | The minimum (inclusive) value for a field.

See Also

ColumnRange Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


IsMissing Property

[image]

SQL Data Compare API 12.0.40
ColumnRange..::.IsMissing Property
ColumnRange Class See Also

If set, the field value must be Missing. IsNull takes priority over this property.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsMissing As Boolean
C#
public bool IsMissing { get; set; }
Visual C++
public:
property bool IsMissing {
    bool get ();
    void set (bool value);
}

See Also

ColumnRange Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


IsNull Property

[image]

SQL Data Compare API 12.0.40
ColumnRange..::.IsNull Property
ColumnRange Class See Also

If set, the field must be null. This property takes priority over IsMissing.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsNull As Boolean
C#
public bool IsNull { get; set; }
Visual C++
public:
property bool IsNull {
    bool get ();
    void set (bool value);
}

See Also

ColumnRange Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


MaxValue Property

[image]

SQL Data Compare API 12.0.40
ColumnRange..::.MaxValue Property
ColumnRange Class See Also

The maximum (inclusive) value for a field.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxValue As IComparable
C#
public IComparable MaxValue { get; set; }
Visual C++
public:
property IComparable^ MaxValue {
    IComparable^ get ();
    void set (IComparable^ value);
}

See Also

ColumnRange Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


MinValue Property

[image]

SQL Data Compare API 12.0.40
ColumnRange..::.MinValue Property
ColumnRange Class See Also

The minimum (inclusive) value for a field.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property MinValue As IComparable
C#
public IComparable MinValue { get; set; }
Visual C++
public:
property IComparable^ MinValue {
    IComparable^ get ();
    void set (IComparable^ value);
}

See Also

ColumnRange Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnSort Class

[image]

SQL Data Compare API 12.0.40
ColumnSort Class
Members See Also

A class to sort the ResultsStore by field data.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ColumnSort
C#
public sealed class ColumnSort
Visual C++
public ref class ColumnSort sealed

Inheritance Hierarchy

Object
RedGate.SQLDataCompare.Engine.ResultsStore..::.ColumnSort

See Also

ColumnSort Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnSort Members

[image] [image]

SQL Data Compare API 12.0.40
ColumnSort Members
ColumnSort Class Constructors Methods Properties See Also

The ColumnSort type exposes the following members.

Constructors

Name | Description
ColumnSort | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Ascending | Specifies whether the field is sorted ascending or descending.
FieldPair | The name of the field being sorted.
InOne | Sort by the field in the first database.
SortByType | Sorts by the type.

See Also

ColumnSort Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnSort Constructor

[image] [image]

SQL Data Compare API 12.0.40
ColumnSort Constructor
ColumnSort Class See Also

Overload List

Name | Description
ColumnSort()()() | Constructs a new ColumnSort object for sorting by type. SortByType is set to true.
ColumnSort(FieldPair, Boolean) | Constructs a new ColumnSort object.

See Also

ColumnSort Class
ColumnSort Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnSort Constructor

[image]

SQL Data Compare API 12.0.40
ColumnSort Constructor
ColumnSort Class See Also

Constructs a new ColumnSort object for sorting by type. SortByType is set to true.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ColumnSort()
Visual C++
public:
ColumnSort()

See Also

ColumnSort Class
ColumnSort Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnSort Constructor (FieldPair, )

[image]

SQL Data Compare API 12.0.40
ColumnSort Constructor (FieldPair, )
ColumnSort Class See Also

Constructs a new ColumnSort object.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fieldPair As FieldPair, _
    inOne As Boolean _
)
C#
public ColumnSort(
    FieldPair fieldPair,
    bool inOne
)
Visual C++
public:
ColumnSort(
    FieldPair^ fieldPair,
    bool inOne
)

Parameters

fieldPair
Type: RedGate.SQLDataCompare.Engine..::.FieldPair
The FieldPair being sorted.
inOne
Type: Boolean
The field is being sorted using the data in the first database.

See Also

ColumnSort Class
ColumnSort Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnSort Properties

[image] [image]

SQL Data Compare API 12.0.40
ColumnSort Properties
ColumnSort Class See Also

The ColumnSort type exposes the following properties.

Properties

Name | Description
Ascending | Specifies whether the field is sorted ascending or descending.
FieldPair | The name of the field being sorted.
InOne | Sort by the field in the first database.
SortByType | Sorts by the type.

See Also

ColumnSort Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Ascending Property

[image]

SQL Data Compare API 12.0.40
ColumnSort..::.Ascending Property
ColumnSort Class See Also

Specifies whether the field is sorted ascending or descending.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Ascending As Boolean
C#
public bool Ascending { get; set; }
Visual C++
public:
property bool Ascending {
    bool get ();
    void set (bool value);
}

See Also

ColumnSort Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


FieldPair Property

[image]

SQL Data Compare API 12.0.40
ColumnSort..::.FieldPair Property
ColumnSort Class See Also

The name of the field being sorted.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FieldPair As FieldPair
C#
public FieldPair FieldPair { get; set; }
Visual C++
public:
property FieldPair^ FieldPair {
    FieldPair^ get ();
    void set (FieldPair^ value);
}

See Also

ColumnSort Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


InOne Property

[image]

SQL Data Compare API 12.0.40
ColumnSort..::.InOne Property
ColumnSort Class See Also

Sort by the field in the first database.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property InOne As Boolean
C#
public bool InOne { get; set; }
Visual C++
public:
property bool InOne {
    bool get ();
    void set (bool value);
}

See Also

ColumnSort Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


SortByType Property

[image]

SQL Data Compare API 12.0.40
ColumnSort..::.SortByType Property
ColumnSort Class See Also

Sorts by the type.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SortByType As Boolean
C#
public bool SortByType { get; set; }
Visual C++
public:
property bool SortByType {
    bool get ();
    void set (bool value);
}

See Also

ColumnSort Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnSorts Class

[image]

SQL Data Compare API 12.0.40
ColumnSorts Class
Members See Also

A collection of ColumnSorts to be applied to a ResultsStore.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ColumnSorts _
    Inherits InnerList(Of ColumnSort)
C#
public sealed class ColumnSorts : InnerList<ColumnSort>
Visual C++
public ref class ColumnSorts sealed : public InnerList<ColumnSort^>

Inheritance Hierarchy

Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( T >)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( ColumnSort >)>)
RedGate.SQLDataCompare.Engine.ResultsStore..::.ColumnSorts

See Also

ColumnSorts Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnSorts Members

[image] [image]

SQL Data Compare API 12.0.40
ColumnSorts Members
ColumnSorts Class Methods Properties Explicit Interface Implementations See Also

The ColumnSorts type exposes the following members.

Methods

Name | Description
Add | Adds ColumnSort to the ColumnSorts collection. ColumnSorts are added in order. (Overrides InnerList <(Of <( ColumnSort >)>)..::.Add(UTP).)
Clear | Removes all ColumnSorts from the collection. (Overrides InnerList <(Of <( ColumnSort >)>)..::.Clear()()().)
Contains | (Inherited from InnerList<(Of <(T>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RemoveAt | Removes the ColumnSort at the specified index. (Overrides InnerList <(Of <( ColumnSort >)>)..::.RemoveAt(Int32).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Returns the ColumnSort at the specified index. (Overrides InnerList <(Of <( ColumnSort >)>)..::. Item[([(Int32])]).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

ColumnSorts Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnSorts Methods

[image] [image]

SQL Data Compare API 12.0.40
ColumnSorts Methods
ColumnSorts Class See Also

The ColumnSorts type exposes the following methods.

Methods

Name | Description
Add | Adds ColumnSort to the ColumnSorts collection. ColumnSorts are added in order. (Overrides InnerList <(Of <( ColumnSort >)>)..::.Add(UTP).)
Clear | Removes all ColumnSorts from the collection. (Overrides InnerList <(Of <( ColumnSort >)>)..::.Clear()()().)
Contains | (Inherited from InnerList<(Of <(T>)>).)
ConvertAll<(Of <(TOutput>)>) | Returns an IEnumerable with the result of running converter on each element of this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines if there is an element in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
ExistsCount | Determines the number of elements in this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAll | Returns an IEnumerable of all the objects returned by this IEnumerable that satisfy predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
FindFirst | Returns the first object in this IEnumerable that satisfies predicate. (Inherited from EnumerableBase<(Of <(T>)>).)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RemoveAt | Removes the ColumnSort at the specified index. (Overrides InnerList <(Of <( ColumnSort >)>)..::.RemoveAt(Int32).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrueForAll | Determines if predicate is true for all objects returned by this IEnumerable. (Inherited from EnumerableBase<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

ColumnSorts Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Add Method

[image]

SQL Data Compare API 12.0.40
ColumnSorts..::.Add Method
ColumnSorts Class See Also

Adds ColumnSort to the ColumnSorts collection. ColumnSorts are added in order.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Add ( _
    value As ColumnSort _
)
C#
public override void Add(
    ColumnSort value
)
Visual C++
public:
virtual void Add(
    ColumnSort^ value
) override

Parameters

value
Type: RedGate.SQLDataCompare.Engine.ResultsStore..::.ColumnSort
The ColumnSort to be added.

Return Value

The index of the new ColumnSort.

See Also

ColumnSorts Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Clear Method

[image]

SQL Data Compare API 12.0.40
ColumnSorts..::.Clear Method
ColumnSorts Class See Also

Removes all ColumnSorts from the collection.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Clear
C#
public override void Clear()
Visual C++
public:
virtual void Clear() override

Implements

ICollectionClear()()()

See Also

ColumnSorts Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


RemoveAt Method

[image]

SQL Data Compare API 12.0.40
ColumnSorts..::.RemoveAt Method
ColumnSorts Class See Also

Removes the ColumnSort at the specified index.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub RemoveAt ( _
    index As Integer _
)
C#
public override void RemoveAt(
    int index
)
Visual C++
public:
virtual void RemoveAt(
    int index
) override

Parameters

index
Type: Int32
The index of the ColumnSort to be removed.

Implements

IListRemoveAt(Int32)

See Also

ColumnSorts Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnSorts Properties

[image] [image]

SQL Data Compare API 12.0.40
ColumnSorts Properties
ColumnSorts Class See Also

The ColumnSorts type exposes the following properties.

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Returns the ColumnSort at the specified index. (Overrides InnerList <(Of <( ColumnSort >)>)..::. Item[([(Int32])]).)

See Also

ColumnSorts Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Item Property

[image]

SQL Data Compare API 12.0.40
ColumnSorts..::.Item Property
ColumnSorts Class See Also

Returns the ColumnSort at the specified index.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides WriteOnly Default Property Item ( _
    index As Integer _
) As ColumnSort
C#
public override ColumnSort this[
    int index
] { set; }
Visual C++
public:
virtual property ColumnSort^ default[int index] {
    void set (int index, ColumnSort^ value) override;
}

Parameters

index
Type: Int32
The zero-based index of the ColumnSort to get or set.

Implements

IListItem(Int32)

See Also

ColumnSorts Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


FieldType Enumeration

[image]

SQL Data Compare API 12.0.40
FieldType Enumeration
See Also

The types of field that a ResultsStore can contain.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration FieldType
C#
public enum FieldType
Visual C++
public enum class FieldType

Members

Member name | Description
Empty | Not used.
Integer8 | 8-bit signed integer.
Integer16 | 16-bit signed integer.
Integer32 | 32-bit signed integer.
Integer64 | 64-bit signed integer.
Byte | 8-bit unsigned integer.
UInteger16 | 16-bit unsigned integer.
UInteger32 | 32-bit unsigned integer.
UInteger64 | 64-bit unsigned integer.
Single | Single-precision, 32-bit number.
Boolean | Boolean, True/False value.
String | String or XML.
Double | Double-precision, 64-bit number.
DateTime | Date and time.
Binary | Binary data.
Decimal | High-precision, decimal number suitable for financial information.
Object | An object.
Clr | A CLR type.
SortByte | An byte for sorting by type (cannot be compared).
Guid | A GUID/unique identifier.
Date | Date only
Time | Time only
DateTime2 | Datetime2
DateTimeOffset | DateTimeOffset
TimeSpan | TimeSpan
SqlVariantNull | SqlVariantNull
ComputedColumnMarker | ComputedColumnMarker

See Also

RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Filter Class

[image]

SQL Data Compare API 12.0.40
Filter Class
Members See Also

Used to create a filtered ResultsStore using the ApplyFilter method.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class Filter
C#
public class Filter
Visual C++
public ref class Filter

Inheritance Hierarchy

Object
RedGate.SQLDataCompare.Engine.ResultsStore..::.Filter

See Also

Filter Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Filter Members

[image] [image]

SQL Data Compare API 12.0.40
Filter Members
Filter Class Methods Properties See Also

The Filter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColumnConstraints | The ColumnConstraints for the filter.

See Also

Filter Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Filter Properties

[image] [image]

SQL Data Compare API 12.0.40
Filter Properties
Filter Class See Also

The Filter type exposes the following properties.

Properties

Name | Description
ColumnConstraints | The ColumnConstraints for the filter.

See Also

Filter Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnConstraints Property

[image]

SQL Data Compare API 12.0.40
Filter..::.ColumnConstraints Property
Filter Class See Also

The ColumnConstraints for the filter.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnConstraints As IList(Of ColumnConstraint)
C#
public IList<ColumnConstraint> ColumnConstraints { get; }
Visual C++
public:
property IList<ColumnConstraint^>^ ColumnConstraints {
    IList<ColumnConstraint^>^ get ();
}

See Also

Filter Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


IReader Interface

[image]

SQL Data Compare API 12.0.40
IReader Interface
Members See Also

Reader interface for reading from a RedGate.SQLDataCompare.Engine.ResultsStore

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IReader _
    Implements IDisposable
C#
public interface IReader : IDisposable
Visual C++
public interface class IReader : IDisposable

See Also

IReader Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


IReader Members

[image] [image]

SQL Data Compare API 12.0.40
IReader Members
IReader Interface Methods Properties See Also

The IReader type exposes the following members.

Methods

Name | Description
ApplyFilter | Applies the ResultsStore Filter class to the Reader. Any access to this Reader after the filter has been applied will access only the filtered data.
ApplySort | Sorts the ResultsStore according to SortOrder.
CancelOperation | Cancels the running operation. This may be a ApplyFilter(Boolean) or a ApplySort()()().
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
GetEnumerator | Returns a ResultsStore IEnumerator.
GetRow | Gets a row at the specified index.
GetRowType | Gets the type of a row at the specified index. Does not retrieve all the row fields if not needed.
GetSummaryRow | Gets a summary row at the specified index. If the current row has already been retrieved in full, the complete row is returned.
ReverseSort | Reverses the current order of the ResultsStore. This is a fast operation; it is much quicker than applying the sort in the reverse order.

Properties

Name | Description
Fields | Returns the fields for the current reader.
Filter | The filter used to generate a filtered ResultsStore.
Position | Gets and sets the absolute position of the current row.
RowCount | Returns the row count for the current reader.
SortOrder | The sort order to be used on the current ResultsStore.
Status | The status handler for the ApplySort()()() or ApplyFilter(Boolean) operations.
Where | Contains the WHERE clause that was used to create the ResultsStore.

See Also

IReader Interface
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


IReader Methods

[image] [image]

SQL Data Compare API 12.0.40
IReader Methods
IReader Interface See Also

The IReader type exposes the following methods.

Methods

Name | Description
ApplyFilter | Applies the ResultsStore Filter class to the Reader. Any access to this Reader after the filter has been applied will access only the filtered data.
ApplySort | Sorts the ResultsStore according to SortOrder.
CancelOperation | Cancels the running operation. This may be a ApplyFilter(Boolean) or a ApplySort()()().
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
GetEnumerator | Returns a ResultsStore IEnumerator.
GetRow | Gets a row at the specified index.
GetRowType | Gets the type of a row at the specified index. Does not retrieve all the row fields if not needed.
GetSummaryRow | Gets a summary row at the specified index. If the current row has already been retrieved in full, the complete row is returned.
ReverseSort | Reverses the current order of the ResultsStore. This is a fast operation; it is much quicker than applying the sort in the reverse order.

See Also

IReader Interface
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ApplyFilter Method

[image]

SQL Data Compare API 12.0.40
IReader..::.ApplyFilter Method
IReader Interface See Also

Applies the ResultsStore Filter class to the Reader. Any access to this Reader after the filter has been applied will access only the filtered data.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub ApplyFilter ( _
    useOriginalResultsStore As Boolean _
)
C#
void ApplyFilter(
    bool useOriginalResultsStore
)
Visual C++
void ApplyFilter(
    bool useOriginalResultsStore
)

Parameters

useOriginalResultsStore
Type: Boolean
When true, the filter will be applied to the original ResultsStore; when false, the filter will be applied to the current state of the ResultsStore.

See Also

IReader Interface
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ApplySort Method

[image]

SQL Data Compare API 12.0.40
IReader..::.ApplySort Method
IReader Interface See Also

Sorts the ResultsStore according to SortOrder.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub ApplySort
C#
void ApplySort()
Visual C++
void ApplySort()

Exceptions

Exception | Condition
RedGate.SQLDataCompare.Engine.ResultsStore..::.ResultsStoreException | Unable to sort when using a compressed results store.

See Also

IReader Interface
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


CancelOperation Method

[image]

SQL Data Compare API 12.0.40
IReader..::.CancelOperation Method
IReader Interface See Also

Cancels the running operation. This may be a ApplyFilter(Boolean) or a ApplySort()()().

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub CancelOperation
C#
void CancelOperation()
Visual C++
void CancelOperation()

See Also

IReader Interface
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


GetEnumerator Method

[image]

SQL Data Compare API 12.0.40
IReader..::.GetEnumerator Method
IReader Interface See Also

Returns a ResultsStore IEnumerator.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetEnumerator As IEnumerator(Of Row)
C#
IEnumerator<Row> GetEnumerator()
Visual C++
IEnumerator<Row^>^ GetEnumerator()

Return Value

Enumerator for the ResultsStore.

See Also

IReader Interface
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


GetRow Method

[image]

SQL Data Compare API 12.0.40
IReader..::.GetRow Method
IReader Interface See Also

Gets a row at the specified index.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetRow ( _
    index As Integer _
) As Row
C#
Row GetRow(
    int index
)
Visual C++
Row^ GetRow(
    int index
)

Parameters

index
Type: Int32
The index of the row to retrieve.

Return Value

The row at the requested index.

Remarks

The current row depends on how the ResultsStore is currently sorted

See Also

IReader Interface
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


GetRowType Method

[image]

SQL Data Compare API 12.0.40
IReader..::.GetRowType Method
IReader Interface See Also

Gets the type of a row at the specified index. Does not retrieve all the row fields if not needed.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetRowType ( _
    index As Integer _
) As Row..::.RowType
C#
Row..::.RowType GetRowType(
    int index
)
Visual C++
Row..::.RowType GetRowType(
    int index
)

Parameters

index
Type: Int32

Return Value

See Also

IReader Interface
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


GetSummaryRow Method

[image]

SQL Data Compare API 12.0.40
IReader..::.GetSummaryRow Method
IReader Interface See Also

Gets a summary row at the specified index. If the current row has already been retrieved in full, the complete row is returned.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function GetSummaryRow ( _
    index As Integer _
) As Row
C#
Row GetSummaryRow(
    int index
)
Visual C++
Row^ GetSummaryRow(
    int index
)

Parameters

index
Type: Int32
The index of the row to retrieve.

Return Value

The row at the requested index.

Remarks

The current row depends on how the ResultsStore is currently sorted.

See Also

IReader Interface
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ReverseSort Method

[image]

SQL Data Compare API 12.0.40
IReader..::.ReverseSort Method
IReader Interface See Also

Reverses the current order of the ResultsStore. This is a fast operation; it is much quicker than applying the sort in the reverse order.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Sub ReverseSort
C#
void ReverseSort()
Visual C++
void ReverseSort()

See Also

IReader Interface
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


IReader Properties

[image] [image]

SQL Data Compare API 12.0.40
IReader Properties
IReader Interface See Also

The IReader type exposes the following properties.

Properties

Name | Description
Fields | Returns the fields for the current reader.
Filter | The filter used to generate a filtered ResultsStore.
Position | Gets and sets the absolute position of the current row.
RowCount | Returns the row count for the current reader.
SortOrder | The sort order to be used on the current ResultsStore.
Status | The status handler for the ApplySort()()() or ApplyFilter(Boolean) operations.
Where | Contains the WHERE clause that was used to create the ResultsStore.

See Also

IReader Interface
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Fields Property

[image]

SQL Data Compare API 12.0.40
IReader..::.Fields Property
IReader Interface See Also

Returns the fields for the current reader.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Fields As FieldPairs
C#
FieldPairs Fields { get; }
Visual C++
property FieldPairs^ Fields {
    FieldPairs^ get ();
}

See Also

IReader Interface
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Filter Property

[image]

SQL Data Compare API 12.0.40
IReader..::.Filter Property
IReader Interface See Also

The filter used to generate a filtered ResultsStore.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Filter As Filter
C#
Filter Filter { get; }
Visual C++
property Filter^ Filter {
    Filter^ get ();
}

See Also

IReader Interface
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Position Property

[image]

SQL Data Compare API 12.0.40
IReader..::.Position Property
IReader Interface See Also

Gets and sets the absolute position of the current row.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property Position As Integer
C#
int Position { get; set; }
Visual C++
property int Position {
    int get ();
    void set (int value);
}

Remarks

This depends on the current sorting of the ResultsStore.

Exceptions

Exception | Condition
RedGate.SQLDataCompare.Engine.ResultsStore..::.ResultsStoreException | Invalid row index.

See Also

IReader Interface
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


RowCount Property

[image]

SQL Data Compare API 12.0.40
IReader..::.RowCount Property
IReader Interface See Also

Returns the row count for the current reader.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property RowCount As Integer
C#
int RowCount { get; }
Visual C++
property int RowCount {
    int get ();
}

See Also

IReader Interface
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


SortOrder Property

[image]

SQL Data Compare API 12.0.40
IReader..::.SortOrder Property
IReader Interface See Also

The sort order to be used on the current ResultsStore.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SortOrder As Sort
C#
Sort SortOrder { get; }
Visual C++
property Sort^ SortOrder {
    Sort^ get ();
}

See Also

IReader Interface
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Status Property

[image]

SQL Data Compare API 12.0.40
IReader..::.Status Property
IReader Interface See Also

The status handler for the ApplySort()()() or ApplyFilter(Boolean) operations.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property Status As StatusEventHandler
C#
StatusEventHandler Status { get; set; }
Visual C++
property StatusEventHandler^ Status {
    StatusEventHandler^ get ();
    void set (StatusEventHandler^ value);
}

See Also

IReader Interface
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Where Property

[image]

SQL Data Compare API 12.0.40
IReader..::.Where Property
IReader Interface See Also

Contains the WHERE clause that was used to create the ResultsStore.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Where As WhereClause
C#
WhereClause Where { get; }
Visual C++
property WhereClause^ Where {
    WhereClause^ get ();
}

See Also

IReader Interface
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Missing Class

[image]

SQL Data Compare API 12.0.40
Missing Class
Members See Also

Signifies a Missing result, for which there is no value in the ResultsStore. There is a singleton class of this type, so all reference comparisons are valid.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class Missing _
    Implements IComparable
C#
public class Missing : IComparable
Visual C++
public ref class Missing : IComparable

Inheritance Hierarchy

Object
RedGate.SQLDataCompare.Engine.ResultsStore..::.Missing

See Also

Missing Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Missing Members

[image] [image]

SQL Data Compare API 12.0.40
Missing Members
Missing Class Methods See Also

The Missing type exposes the following members.

Methods

Name | Description
CompareTo | Compares Missing objects, for which there is no value in the ResultsStore.
Equals | Indicates whether the Missing instance is identical to a specified object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. Returns the hash code for the instance. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns "Missing". (Overrides Object..::.ToString()()().)

See Also

Missing Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Missing Methods

[image] [image]

SQL Data Compare API 12.0.40
Missing Methods
Missing Class See Also

The Missing type exposes the following methods.

Methods

Name | Description
CompareTo | Compares Missing objects, for which there is no value in the ResultsStore.
Equals | Indicates whether the Missing instance is identical to a specified object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. Returns the hash code for the instance. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns "Missing". (Overrides Object..::.ToString()()().)

See Also

Missing Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


CompareTo Method

[image]

SQL Data Compare API 12.0.40
Missing..::.CompareTo Method
Missing Class See Also

Compares Missing objects, for which there is no value in the ResultsStore.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareTo ( _
    obj As Object _
) As Integer
C#
public int CompareTo(
    Object obj
)
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: Object
The object to be compared.

Return Value

Zero if the object is a Missing object; otherwise -1.

Implements

IComparableCompareTo(Object)

See Also

Missing Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Equals Method

[image]

SQL Data Compare API 12.0.40
Missing..::.Equals Method
Missing Class See Also

Indicates whether the Missing instance is identical to a specified object.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: Object
The object to compare.

Return Value

true if the underlying Missing data is the same; otherwise, false.

See Also

Missing Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


GetHashCode Method

[image]

SQL Data Compare API 12.0.40
Missing..::.GetHashCode Method
Missing Class See Also

Overridden. Returns the hash code for the instance.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

Return Value

A 32-bit signed integer hash code.

Exceptions

Exception | Condition
NotSupportedException | Missing class is used as a singleton; unable to create a hash code.

See Also

Missing Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ToString Method

[image]

SQL Data Compare API 12.0.40
Missing..::.ToString Method
Missing Class See Also

Returns "Missing".

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

Return Value

Missing.

See Also

Missing Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Reader Class

[image]

SQL Data Compare API 12.0.40
Reader Class
Members See Also

Reads data from a results store. Can be created using GetReader()()().

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class Reader _
    Inherits DisposableBase _
    Implements IEnumerable(Of Row), IEnumerable,  _
    ICancellable, IReader, IDisposable
C#
public class Reader : DisposableBase, IEnumerable<Row>,
    IEnumerable, ICancellable, IReader, IDisposable
Visual C++
public ref class Reader : public DisposableBase,
    IEnumerable<Row^>, IEnumerable, ICancellable, IReader,
    IDisposable

Inheritance Hierarchy

Object
RedGate.Shared.Utils..::.DisposableBase
RedGate.SQLDataCompare.Engine.ResultsStore..::.Reader

See Also

Reader Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Reader Members

[image] [image]

SQL Data Compare API 12.0.40
Reader Members
Reader Class Methods Properties Explicit Interface Implementations See Also

The Reader type exposes the following members.

Methods

Name | Description
ApplyFilter | Applies the ResultsStore Filter class to the Reader. Any access to this Reader after the filter has been applied will access only the filtered data.
ApplySort | Sorts the ResultsStore according to SortOrder.
CancelOperation | Cancels the running operation. This may be a ApplyFilter(Boolean) or a ApplySort()()().
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetEnumerator | Returns a ResultsStore IEnumerator.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetRow | Gets a row at the specified index.
GetRowType | Gets the type of a row at the specified index. Does not retrieve all the row fields if not needed.
GetSummaryRow | Gets a summary row at the specified index. If the current row has already been retrieved in full, the complete row is returned.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReverseSort | Reverses the current order of the ResultsStore. This is a fast operation; it is much quicker than applying the sort in the reverse order.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Fields | Returns the fields for the current reader.
Filter | The filter used to generate a filtered ResultsStore.
IsDisposed | Returns a value indicating if this instance has been disposed. (Inherited from DisposableBase.)
Missing | Compare against this singleton to check for Missing values.
Position | Gets and sets the absolute position of the current row.
RowCount | Returns the row count for the current reader.
SortOrder | The sort order to be used on the current ResultsStore.
Status | The status handler for the ApplySort()()() or ApplyFilter(Boolean) operations.
Where | Contains the WHERE clause that was used to create the ResultsStore.

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator |

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Reader Methods

[image] [image]

SQL Data Compare API 12.0.40
Reader Methods
Reader Class See Also

The Reader type exposes the following methods.

Methods

Name | Description
ApplyFilter | Applies the ResultsStore Filter class to the Reader. Any access to this Reader after the filter has been applied will access only the filtered data.
ApplySort | Sorts the ResultsStore according to SortOrder.
CancelOperation | Cancels the running operation. This may be a ApplyFilter(Boolean) or a ApplySort()()().
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetEnumerator | Returns a ResultsStore IEnumerator.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetRow | Gets a row at the specified index.
GetRowType | Gets the type of a row at the specified index. Does not retrieve all the row fields if not needed.
GetSummaryRow | Gets a summary row at the specified index. If the current row has already been retrieved in full, the complete row is returned.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReverseSort | Reverses the current order of the ResultsStore. This is a fast operation; it is much quicker than applying the sort in the reverse order.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator |

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ApplyFilter Method

[image]

SQL Data Compare API 12.0.40
Reader..::.ApplyFilter Method
Reader Class See Also

Applies the ResultsStore Filter class to the Reader. Any access to this Reader after the filter has been applied will access only the filtered data.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub ApplyFilter ( _
    useOriginalResultsStore As Boolean _
)
C#
public void ApplyFilter(
    bool useOriginalResultsStore
)
Visual C++
public:
virtual void ApplyFilter(
    bool useOriginalResultsStore
) sealed

Parameters

useOriginalResultsStore
Type: Boolean
When true, the filter will be applied to the original ResultsStore; when false, the filter will be applied to the current state of the ResultsStore.

Implements

IReader..::.ApplyFilter(Boolean)

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ApplySort Method

[image]

SQL Data Compare API 12.0.40
Reader..::.ApplySort Method
Reader Class See Also

Sorts the ResultsStore according to SortOrder.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub ApplySort
C#
public void ApplySort()
Visual C++
public:
virtual void ApplySort() sealed

Implements

IReader..::.ApplySort()()()

Exceptions

Exception | Condition
RedGate.SQLDataCompare.Engine.ResultsStore..::.ResultsStoreException | Unable to sort when using a compressed results store.

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


CancelOperation Method

[image]

SQL Data Compare API 12.0.40
Reader..::.CancelOperation Method
Reader Class See Also

Cancels the running operation. This may be a ApplyFilter(Boolean) or a ApplySort()()().

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelOperation
C#
public void CancelOperation()
Visual C++
public:
virtual void CancelOperation() sealed

Implements

ICancellable..::.CancelOperation()()()
IReader..::.CancelOperation()()()

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Dispose Method

[image] [image]

SQL Data Compare API 12.0.40
Reader..::.Dispose Method
Reader Class See Also

Overload List

Name | Description
Dispose()()() | (Inherited from DisposableBase.)
Dispose(Boolean) | Closes the underlying stream and reader. (Overrides DisposableBase ..::. Dispose(Boolean).)

See Also

Reader Class
Reader Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Dispose Method ()

[image]

SQL Data Compare API 12.0.40
Reader..::.Dispose Method ()
Reader Class See Also

Closes the underlying stream and reader.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
C#
protected override void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: Boolean

See Also

Reader Class
Dispose Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


GetEnumerator Method

[image]

SQL Data Compare API 12.0.40
Reader..::.GetEnumerator Method
Reader Class See Also

Returns a ResultsStore IEnumerator.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of Row)
C#
public IEnumerator<Row> GetEnumerator()
Visual C++
public:
virtual IEnumerator<Row^>^ GetEnumerator() sealed

Return Value

Enumerator for the ResultsStore.

Implements

IEnumerableGetEnumerator()()()
IReader..::.GetEnumerator()()()

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


. Method

[image]

SQL Data Compare API 12.0.40
Reader..::...::. Method
Reader Class See Also

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
C#
IEnumerator IEnumerable.GetEnumerator()
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerableGetEnumerator()()()

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


GetRow Method

[image]

SQL Data Compare API 12.0.40
Reader..::.GetRow Method
Reader Class See Also

Gets a row at the specified index.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetRow ( _
    index As Integer _
) As Row
C#
public Row GetRow(
    int index
)
Visual C++
public:
virtual Row^ GetRow(
    int index
) sealed

Parameters

index
Type: Int32
The index of the row to retrieve.

Return Value

The row at the requested index.

Implements

IReader..::.GetRow(Int32)

Remarks

The current row depends on how the ResultsStore is currently sorted

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


GetRowType Method

[image]

SQL Data Compare API 12.0.40
Reader..::.GetRowType Method
Reader Class See Also

Gets the type of a row at the specified index. Does not retrieve all the row fields if not needed.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetRowType ( _
    index As Integer _
) As Row..::.RowType
C#
public Row..::.RowType GetRowType(
    int index
)
Visual C++
public:
virtual Row..::.RowType GetRowType(
    int index
) sealed

Parameters

index
Type: Int32

Return Value

Implements

IReader..::.GetRowType(Int32)

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


GetSummaryRow Method

[image]

SQL Data Compare API 12.0.40
Reader..::.GetSummaryRow Method
Reader Class See Also

Gets a summary row at the specified index. If the current row has already been retrieved in full, the complete row is returned.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSummaryRow ( _
    index As Integer _
) As Row
C#
public Row GetSummaryRow(
    int index
)
Visual C++
public:
virtual Row^ GetSummaryRow(
    int index
) sealed

Parameters

index
Type: Int32
The index of the row to retrieve.

Return Value

The row at the requested index.

Implements

IReader..::.GetSummaryRow(Int32)

Remarks

The current row depends on how the ResultsStore is currently sorted.

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ReverseSort Method

[image]

SQL Data Compare API 12.0.40
Reader..::.ReverseSort Method
Reader Class See Also

Reverses the current order of the ResultsStore. This is a fast operation; it is much quicker than applying the sort in the reverse order.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub ReverseSort
C#
public void ReverseSort()
Visual C++
public:
virtual void ReverseSort() sealed

Implements

IReader..::.ReverseSort()()()

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Reader Properties

[image] [image]

SQL Data Compare API 12.0.40
Reader Properties
Reader Class See Also

The Reader type exposes the following properties.

Properties

Name | Description
Fields | Returns the fields for the current reader.
Filter | The filter used to generate a filtered ResultsStore.
IsDisposed | Returns a value indicating if this instance has been disposed. (Inherited from DisposableBase.)
Missing | Compare against this singleton to check for Missing values.
Position | Gets and sets the absolute position of the current row.
RowCount | Returns the row count for the current reader.
SortOrder | The sort order to be used on the current ResultsStore.
Status | The status handler for the ApplySort()()() or ApplyFilter(Boolean) operations.
Where | Contains the WHERE clause that was used to create the ResultsStore.

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Fields Property

[image]

SQL Data Compare API 12.0.40
Reader..::.Fields Property
Reader Class See Also

Returns the fields for the current reader.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fields As FieldPairs
C#
public FieldPairs Fields { get; }
Visual C++
public:
virtual property FieldPairs^ Fields {
    FieldPairs^ get () sealed;
}

Implements

IReader..::.Fields

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Filter Property

[image]

SQL Data Compare API 12.0.40
Reader..::.Filter Property
Reader Class See Also

The filter used to generate a filtered ResultsStore.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Filter As Filter
C#
public Filter Filter { get; }
Visual C++
public:
virtual property Filter^ Filter {
    Filter^ get () sealed;
}

Implements

IReader..::.Filter

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Missing Property

[image]

SQL Data Compare API 12.0.40
Reader..::.Missing Property
Reader Class See Also

Compare against this singleton to check for Missing values.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Missing As Missing
C#
public static Missing Missing { get; }
Visual C++
public:
static property Missing^ Missing {
    Missing^ get ();
}

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Position Property

[image]

SQL Data Compare API 12.0.40
Reader..::.Position Property
Reader Class See Also

Gets and sets the absolute position of the current row.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Position As Integer
C#
public int Position { get; set; }
Visual C++
public:
virtual property int Position {
    int get () sealed;
    void set (int value) sealed;
}

Implements

IReader..::.Position

Remarks

This depends on the current sorting of the ResultsStore.

Exceptions

Exception | Condition
RedGate.SQLDataCompare.Engine.ResultsStore..::.ResultsStoreException | Invalid row index.

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


RowCount Property

[image]

SQL Data Compare API 12.0.40
Reader..::.RowCount Property
Reader Class See Also

Returns the row count for the current reader.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowCount As Integer
C#
public int RowCount { get; }
Visual C++
public:
virtual property int RowCount {
    int get () sealed;
}

Implements

IReader..::.RowCount

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


SortOrder Property

[image]

SQL Data Compare API 12.0.40
Reader..::.SortOrder Property
Reader Class See Also

The sort order to be used on the current ResultsStore.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SortOrder As Sort
C#
public Sort SortOrder { get; }
Visual C++
public:
virtual property Sort^ SortOrder {
    Sort^ get () sealed;
}

Implements

IReader..::.SortOrder

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Status Property

[image]

SQL Data Compare API 12.0.40
Reader..::.Status Property
Reader Class See Also

The status handler for the ApplySort()()() or ApplyFilter(Boolean) operations.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status
IReader..::.Status

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Where Property

[image]

SQL Data Compare API 12.0.40
Reader..::.Where Property
Reader Class See Also

Contains the WHERE clause that was used to create the ResultsStore.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Where As WhereClause
C#
public WhereClause Where { get; }
Visual C++
public:
virtual property WhereClause^ Where {
    WhereClause^ get () sealed;
}

Implements

IReader..::.Where

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ResultsStoreException Class

[image]

SQL Data Compare API 12.0.40
ResultsStoreException Class
Members See Also

Exception thrown by classes in the RedGate.SQLDataCompare.Engine.ResultsStore namespace when it encounters an error.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ResultsStoreException _
    Inherits SqlDataCompareException
C#
[SerializableAttribute]
public class ResultsStoreException : SqlDataCompareException
Visual C++
[SerializableAttribute]
public ref class ResultsStoreException : public SqlDataCompareException

Inheritance Hierarchy

Object
Exception
RedGate.SQLDataCompare.Engine..::.SqlDataCompareException
RedGate.SQLDataCompare.Engine.ResultsStore..::.ResultsStoreException

See Also

ResultsStoreException Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ResultsStoreException Members

[image] [image]

SQL Data Compare API 12.0.40
ResultsStoreException Members
ResultsStoreException Class Constructors Methods Properties See Also

The ResultsStoreException type exposes the following members.

Constructors

Name | Description
ResultsStoreException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ResultsStoreException Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ResultsStoreException Constructor

[image] [image]

SQL Data Compare API 12.0.40
ResultsStoreException Constructor
ResultsStoreException Class See Also

Overload List

Name | Description
ResultsStoreException()()() | Creates a new exception.
ResultsStoreException(String) | Creates a new exception with the specified detail message.
ResultsStoreException(SerializationInfo, StreamingContext) | This constructor is called during deserialization to reconstitute the exception object transmitted over a stream. For more information, see XML and SOAP Serialization.
ResultsStoreException(String, Exception) | Creates a new exception with the specified detail message and cause.

See Also

ResultsStoreException Class
ResultsStoreException Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ResultsStoreException Constructor

[image]

SQL Data Compare API 12.0.40
ResultsStoreException Constructor
ResultsStoreException Class See Also

Creates a new exception.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ResultsStoreException()
Visual C++
public:
ResultsStoreException()

See Also

ResultsStoreException Class
ResultsStoreException Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ResultsStoreException Constructor ()

[image]

SQL Data Compare API 12.0.40
ResultsStoreException Constructor ()
ResultsStoreException Class See Also

Creates a new exception with the specified detail message.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public ResultsStoreException(
    string message
)
Visual C++
public:
ResultsStoreException(
    String^ message
)

Parameters

message
Type: String
Detail message.

See Also

ResultsStoreException Class
ResultsStoreException Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ResultsStoreException Constructor (, )

[image]

SQL Data Compare API 12.0.40
ResultsStoreException Constructor (, )
ResultsStoreException Class See Also

This constructor is called during deserialization to reconstitute the exception object transmitted over a stream. For more information, see XML and SOAP Serialization.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected ResultsStoreException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
ResultsStoreException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: SerializationInfo
The object that holds the serialized object data.
context
Type: StreamingContext
The contextual information about the source or destination.

See Also

ResultsStoreException Class
ResultsStoreException Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ResultsStoreException Constructor (, )

[image]

SQL Data Compare API 12.0.40
ResultsStoreException Constructor (, )
ResultsStoreException Class See Also

Creates a new exception with the specified detail message and cause.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    cause As Exception _
)
C#
public ResultsStoreException(
    string message,
    Exception cause
)
Visual C++
public:
ResultsStoreException(
    String^ message,
    Exception^ cause
)

Parameters

message
Type: String
Detail message.
cause
Type: Exception
Cause of exception.

See Also

ResultsStoreException Class
ResultsStoreException Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Row Class

[image]

SQL Data Compare API 12.0.40
Row Class
Members See Also

A row containing data in a ResultsStore object.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Row
C#
public sealed class Row
Visual C++
public ref class Row sealed

Remarks

See RedGate.SQLDataCompare.Engine.ResultsStore for more information and code samples.

Inheritance Hierarchy

Object
RedGate.SQLDataCompare.Engine.ResultsStore..::.Row

See Also

Row Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Row Members

[image] [image]

SQL Data Compare API 12.0.40
Row Members
Row Class Methods Properties See Also

The Row type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FieldDifferent | Returns true if the FieldPair of the specified ordinal is different.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Bookmark | The bookmark of the row in the ResultsStore.
Index | The index of the row in the ResultsStore.
Type | The type of the results in the row from Row..::.RowType.
Values | The values of the fields in the row.

See Also

Row Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Row Methods

[image] [image]

SQL Data Compare API 12.0.40
Row Methods
Row Class See Also

The Row type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FieldDifferent | Returns true if the FieldPair of the specified ordinal is different.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Row Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


FieldDifferent Method

[image]

SQL Data Compare API 12.0.40
Row..::.FieldDifferent Method
Row Class See Also

Returns true if the FieldPair of the specified ordinal is different.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function FieldDifferent ( _
    fieldIndex As Integer _
) As Boolean
C#
public bool FieldDifferent(
    int fieldIndex
)
Visual C++
public:
bool FieldDifferent(
    int fieldIndex
)

Parameters

fieldIndex
Type: Int32
Ordinal of the FieldPair in the ResultsStore.

Return Value

true if values are different; otherwise false.

See Also

Row Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Row Properties

[image] [image]

SQL Data Compare API 12.0.40
Row Properties
Row Class See Also

The Row type exposes the following properties.

Properties

Name | Description
Bookmark | The bookmark of the row in the ResultsStore.
Index | The index of the row in the ResultsStore.
Type | The type of the results in the row from Row..::.RowType.
Values | The values of the fields in the row.

See Also

Row Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Bookmark Property

[image]

SQL Data Compare API 12.0.40
Row..::.Bookmark Property
Row Class See Also

The bookmark of the row in the ResultsStore.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bookmark As Integer
C#
public int Bookmark { get; }
Visual C++
public:
property int Bookmark {
    int get ();
}

Remarks

The Bookmark property is independent of how the ResultsStore is sorted. Note that using the bookmark property is slow.

See Also

Row Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Index Property

[image]

SQL Data Compare API 12.0.40
Row..::.Index Property
Row Class See Also

The index of the row in the ResultsStore.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
C#
public int Index { get; }
Visual C++
public:
property int Index {
    int get ();
}

Remarks

The Index property changes as the ResultsStore is sorted.

See Also

Row Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Type Property

[image]

SQL Data Compare API 12.0.40
Row..::.Type Property
Row Class See Also

The type of the results in the row from Row..::.RowType.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As Row..::.RowType
C#
public Row..::.RowType Type { get; }
Visual C++
public:
property Row..::.RowType Type {
    Row..::.RowType get ();
}

See Also

Row Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Values Property

[image]

SQL Data Compare API 12.0.40
Row..::.Values Property
Row Class See Also

The values of the fields in the row.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Values As Object()
C#
public Object[] Values { get; }
Visual C++
public:
property array<Object^>^ Values {
    array<Object^>^ get ();
}

See Also

Row Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Row.RowType Enumeration

[image]

SQL Data Compare API 12.0.40
Row..::.RowType Enumeration
Row Class See Also

The type of the row. The values All and TotalDifferent can be used for DifferenceCount(Row..::.RowType).

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration RowType
C#
public enum RowType
Visual C++
public enum class RowType

Members

Member name | Description
In1 | Data exists only in the first database.
Different | Data exists in both databases and is different.
In2 | Data exists only in the second database.
Same | All data is identical.
All | All rows. Used for indexing Readers. Not a true row type.
TotalDifferent | The rows that differ, (Different, In1, and In2). Not a true row type.
MaxValue | Maximum value of real RowType

See Also

RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Sort Class

[image]

SQL Data Compare API 12.0.40
Sort Class
Members See Also

Used to specify a sort order for the ResultsStore when using ApplySort()()().

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Sort
C#
public sealed class Sort
Visual C++
public ref class Sort sealed

Inheritance Hierarchy

Object
RedGate.SQLDataCompare.Engine.ResultsStore..::.Sort

See Also

Sort Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Sort Members

[image] [image]

SQL Data Compare API 12.0.40
Sort Members
Sort Class Methods Properties See Also

The Sort type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColumnSorts | A collection of ColumnSort objects.

See Also

Sort Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Sort Properties

[image] [image]

SQL Data Compare API 12.0.40
Sort Properties
Sort Class See Also

The Sort type exposes the following properties.

Properties

Name | Description
ColumnSorts | A collection of ColumnSort objects.

See Also

Sort Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnSorts Property

[image]

SQL Data Compare API 12.0.40
Sort..::.ColumnSorts Property
Sort Class See Also

A collection of ColumnSort objects.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnSorts As ColumnSorts
C#
public ColumnSorts ColumnSorts { get; }
Visual C++
public:
property ColumnSorts^ ColumnSorts {
    ColumnSorts^ get ();
}

See Also

Sort Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Store Class

[image]

SQL Data Compare API 12.0.40
Store Class
Members Example See Also

A data set containing a collection of rows.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class Store _
    Inherits DisposableBase _
    Implements IEnumerable(Of Row), IEnumerable
C#
public class Store : DisposableBase, IEnumerable<Row>,
    IEnumerable
Visual C++
public ref class Store : public DisposableBase,
    IEnumerable<Row^>, IEnumerable

Remarks

SQL Data Compare returns results from a comparison as a ResultsStore class. A ResultsStore contains a number of field definitions. The fields can be of a number of different data types.

See FieldPair for more information on how to cross reference the ResultsStore to the underlying database tables being compared.

To access the data in a ResultsStore, use the GetReader()()() method to retrieve a Reader that can be used for data sorting, filtering and retrieval. You can also use the GetEnumerator()()() to retreive a IEnumerator that can be used to access the ResultsStore quickly.

Examples

Printing out different records in a table.
C# Copy Code
            using System;
            using RedGate.SQLCompare.Engine;
            using RedGate.SQLDataCompare.Engine;
            using RedGate.SQLDataCompare.Engine.ResultsStore;

            namespace SQLDataCompareCodeSnippets
            {
                /// <summary>
                /// Summary description for StoreExample.
                /// </summary>
                public class StoreExample
                {
                    public void RunExample()
                    {
                        Database db1=new Database();
                        Database db2=new Database();

                        db1.RegisterForDataCompare(new ConnectionProperties(".", "WidgetDev"));
                        db2.RegisterForDataCompare(new ConnectionProperties(".", "WidgetLive"));

                        using(ComparisonSession session=new ComparisonSession())
                        {

                            // Create the mappings between the two databases
                            TableMappings mappings = new TableMappings();
                            mappings.CreateMappings(db1.Tables, db2.Tables);

                            session.CompareDatabases(db1, db2, mappings);

                            Reader resultsReader=session.TableDifferences["[dbo].[Widgets]"].ResultsStore.GetReader();

                            // work out the two positions in the fields
                            int description1=resultsReader.Fields["Description"].OrdinalInResults1;
                            int description2=resultsReader.Fields["Description"].OrdinalInResults2;

                            // work out the position of the RecordID column
                            // this is part of the unique index we are comparing on
                            int recordID=resultsReader.Fields["RecordID"].OrdinalInResults1;

                            // sort by description in the first database
                            resultsReader.SortOrder.ColumnSorts.Add(new ColumnSort(resultsReader.Fields["Description"], true));
                            resultsReader.ApplySort();

                            foreach(Row row in resultsReader)
                            {
                                Console.Write("{0}:{1},{2}", row.Values[recordID], row.Values[description1], row.Values[description2]);
                                Console.WriteLine();
                            }
                        }
                        db1.Dispose();
                        db2.Dispose();
                    }
                }
            }
Visual Basic Copy Code
            Option Explicit On

            Imports RedGate.SQLCompare.Engine
            Imports RedGate.SQLDataCompare.Engine
            Imports RedGate.SQLDataCompare.Engine.ResultsStore

            Public Class StoreExample
                Sub RunExample()
                    Dim session As New ComparisonSession

                    'register the databases for comparison
                    Dim db1 As New Database
                    Dim db2 As New Database

                    db1.RegisterForDataCompare(New ConnectionProperties(".", "WidgetDev"))
                    db2.RegisterForDataCompare(New ConnectionProperties(".", "WidgetLive"))

                    'create an intersection of the tables
                    Dim mappings As New TableMappings
                    mappings.CreateMappings(db1.Tables, db2.Tables)

                    'compare the databases
                    session.CompareDatabases(db1, db2, mappings)

                    Dim resultsReader As Reader = session.TableDifferences("[dbo].[Widgets]").ResultsStore.GetReader

                    'work out the two positions in the fields
                    Dim description1 As Integer = resultsReader.Fields("Description").OrdinalInResults1
                    Dim description2 As Integer = resultsReader.Fields("Description").OrdinalInResults2

                    'work out the position of the RecordID column
                    'this is part of the unique index we are comparing on

                    Dim recordID As Integer = resultsReader.Fields("RecordID").OrdinalInResults1

                    'sort by description in the first database
                    resultsReader.SortOrder.ColumnSorts.Add(New ColumnSort(resultsReader.Fields("Description"), True))
                    resultsReader.ApplySort()

                    Dim row As Row
                    For Each row In resultsReader
                        Console.Write("{0}:{1},{2}", row.Values(recordID), row.Values(description1), row.Values(description2))
                        Console.WriteLine()
                    Next

                    'dispose of the objects to delete temporary files
                    session.Dispose()
                    db1.Dispose()
                    db2.Dispose()
                End Sub
            End Class

Inheritance Hierarchy

Object
RedGate.Shared.Utils..::.DisposableBase
RedGate.SQLDataCompare.Engine.ResultsStore..::.Store

See Also

Store Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Store Members

[image] [image]

SQL Data Compare API 12.0.40
Store Members
Store Class Methods Properties Explicit Interface Implementations See Also

The Store type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetEnumerator | Returns a default enumerator for the ResultsStore.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetReader | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IdenticalValues | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Compressed | True if the results store is using compressed temporary files, false otherwise.
Fields | The fields in the ResultsStore object.
IsDisposed | Returns a value indicating if this instance has been disposed. (Inherited from DisposableBase.)
RowCount | The number of rows in the ResultsStore.
Where | Contains the WHERE clause that was used to create the ResultsStore.

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator |

See Also

Store Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Store Methods

[image] [image]

SQL Data Compare API 12.0.40
Store Methods
Store Class See Also

The Store type exposes the following methods.

Methods

Name | Description
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetEnumerator | Returns a default enumerator for the ResultsStore.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetReader | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IdenticalValues | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerableGetEnumerator |

See Also

Store Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Dispose Method

[image] [image]

SQL Data Compare API 12.0.40
Store..::.Dispose Method
Store Class See Also

Overload List

Name | Description
Dispose()()() | (Inherited from DisposableBase.)
Dispose(Boolean) | Cleans up temporary files and stored data, but only after decrementing m_RefCount and checking that it's reached zero. AddRef()()(), and note that Clone()()() shares Store instances and uses AddRef()()() to prevent them being prematurely disposed. TODO This really isn't how IDisposable is meant to be used. (Overrides DisposableBase ..::. Dispose(Boolean).)

See Also

Store Class
Store Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Dispose Method ()

[image]

SQL Data Compare API 12.0.40
Store..::.Dispose Method ()
Store Class See Also

Cleans up temporary files and stored data, but only after decrementing m_RefCount and checking that it's reached zero. AddRef()()(), and note that Clone()()() shares Store instances and uses AddRef()()() to prevent them being prematurely disposed. TODO This really isn't how IDisposable is meant to be used.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
C#
protected override void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: Boolean

See Also

Store Class
Dispose Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


GetEnumerator Method

[image]

SQL Data Compare API 12.0.40
Store..::.GetEnumerator Method
Store Class See Also

Returns a default enumerator for the ResultsStore.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of Row)
C#
public IEnumerator<Row> GetEnumerator()
Visual C++
public:
virtual IEnumerator<Row^>^ GetEnumerator() sealed

Return Value

IEnumerator that can be used to access the results store.

Implements

IEnumerableGetEnumerator()()()

See Also

Store Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


. Method

[image]

SQL Data Compare API 12.0.40
Store..::...::. Method
Store Class See Also

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
C#
IEnumerator IEnumerable.GetEnumerator()
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerableGetEnumerator()()()

See Also

Store Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


GetReader Method

[image] [image]

SQL Data Compare API 12.0.40
Store..::.GetReader Method
Store Class See Also

Overload List

Name | Description
GetReader()()() | Gets a reader so that the ResultsStore can be read in a multi-threaded environment. By default, this is the same as calling GetReader(Row..::.RowType) with an argument of RowType.All.
GetReader(Reader) |
GetReader(Row..::.RowType) | Gets a reader for the ResultsStore for a specified type of results.

See Also

Store Class
Store Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


GetReader Method

[image]

SQL Data Compare API 12.0.40
Store..::.GetReader Method
Store Class See Also

Gets a reader so that the ResultsStore can be read in a multi-threaded environment. By default, this is the same as calling GetReader(Row..::.RowType) with an argument of RowType.All.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetReader As Reader
C#
public Reader GetReader()
Visual C++
public:
Reader^ GetReader()

Remarks

When this Store is disposed it will dispose any undisposed readers it has returned.

See Also

Store Class
GetReader Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


GetReader Method (Reader)

[image]

SQL Data Compare API 12.0.40
Store..::.GetReader Method (Reader)
Store Class See Also

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetReader ( _
    readerToGetOffsetsFrom As Reader _
) As Reader
C#
public Reader GetReader(
    Reader readerToGetOffsetsFrom
)
Visual C++
public:
Reader^ GetReader(
    Reader^ readerToGetOffsetsFrom
)

Parameters

readerToGetOffsetsFrom
Type: RedGate.SQLDataCompare.Engine.ResultsStore..::.Reader

Return Value

A new copy of a Reader using the Offsets from readerToGetOffsetsFrom.

Remarks

When this Store is disposed it will dispose any undisposed readers it has returned.

See Also

Store Class
GetReader Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


GetReader Method (Row.RowType)

[image]

SQL Data Compare API 12.0.40
Store..::.GetReader Method (Row..::.RowType)
Store Class See Also

Gets a reader for the ResultsStore for a specified type of results.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetReader ( _
    rowType As Row..::.RowType _
) As Reader
C#
public Reader GetReader(
    Row..::.RowType rowType
)
Visual C++
public:
Reader^ GetReader(
    Row..::.RowType rowType
)

Parameters

rowType
Type: RedGate.SQLDataCompare.Engine.ResultsStore..::.Row..::.RowType
The type of row to be matched.

Remarks

When this Store is disposed it will dispose any undisposed readers it has returned.

See Also

Store Class
GetReader Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


IdenticalValues Method

[image] [image]

SQL Data Compare API 12.0.40
Store..::.IdenticalValues Method
Store Class See Also

Overload List

Name | Description
IdenticalValues(Object, Object) | Obsolete. Returns true if two values are identical. This method is now obsolete; use IdenticalValues(object value1, object value2, Field f).
IdenticalValues(Object, Object, FieldPair) | Returns true if two specified values are identical.
IdenticalValues(Object, Object, FieldPair, Boolean, Boolean, Boolean) | Returns true if two specified values are identical.

See Also

Store Class
Store Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


IdenticalValues Method (, )

[image]

SQL Data Compare API 12.0.40
Store..::.IdenticalValues Method (, )
Store Class See Also

Returns true if two values are identical. This method is now obsolete; use IdenticalValues(object value1, object value2, Field f).

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Comparing values without field information can produce unreliable information, please pass Field information.",  _
    False)> _
Public Shared Function IdenticalValues ( _
    value1 As Object, _
    value2 As Object _
) As Boolean
C#
[ObsoleteAttribute("Comparing values without field information can produce unreliable information, please pass Field information.",
    false)]
public static bool IdenticalValues(
    Object value1,
    Object value2
)
Visual C++
[ObsoleteAttribute(L"Comparing values without field information can produce unreliable information, please pass Field information.",
    false)]
public:
static bool IdenticalValues(
    Object^ value1,
    Object^ value2
)

Parameters

value1
Type: Object
The first value to compare.
value2
Type: Object
The second value to compare.

Return Value

true if the two values are identical.

Remarks

If the values are of different types, or if one value is null, returns false.

See Also

Store Class
IdenticalValues Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


IdenticalValues Method (, , FieldPair)

[image]

SQL Data Compare API 12.0.40
Store..::.IdenticalValues Method (, , FieldPair)
Store Class See Also

Returns true if two specified values are identical.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IdenticalValues ( _
    value1 As Object, _
    value2 As Object, _
    fieldPair As FieldPair _
) As Boolean
C#
public static bool IdenticalValues(
    Object value1,
    Object value2,
    FieldPair fieldPair
)
Visual C++
public:
static bool IdenticalValues(
    Object^ value1,
    Object^ value2,
    FieldPair^ fieldPair
)

Parameters

value1
Type: Object
The first value to compare.
value2
Type: Object
The second value to compare.
fieldPair
Type: RedGate.SQLDataCompare.Engine..::.FieldPair
The FieldPair information for use in the comparison (collation and type information).

Return Value

true if the values are identical.

Remarks

If the values are of different types, or if one value is null, returns false. If you are using GetSummaryRow(Int32) to retrieve the data, you must use the FieldDifferent(Int32) method to determine whether the values are the same in a Row .

See Also

Store Class
IdenticalValues Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


IdenticalValues Method (, , FieldPair, , , )

[image]

SQL Data Compare API 12.0.40
Store..::.IdenticalValues Method (, , FieldPair, , , )
Store Class See Also

Returns true if two specified values are identical.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IdenticalValues ( _
    value1 As Object, _
    value2 As Object, _
    fieldPair As FieldPair, _
    forceBinaryString As Boolean, _
    roundDoubles As Boolean, _
    treatEmptyStringAsNull As Boolean _
) As Boolean
C#
public static bool IdenticalValues(
    Object value1,
    Object value2,
    FieldPair fieldPair,
    bool forceBinaryString,
    bool roundDoubles,
    bool treatEmptyStringAsNull
)
Visual C++
public:
static bool IdenticalValues(
    Object^ value1,
    Object^ value2,
    FieldPair^ fieldPair,
    bool forceBinaryString,
    bool roundDoubles,
    bool treatEmptyStringAsNull
)

Parameters

value1
Type: Object
The first value to compare.
value2
Type: Object
The second value to compare.
fieldPair
Type: RedGate.SQLDataCompare.Engine..::.FieldPair
The FieldPair information for use in the comparison (collation and type information).
forceBinaryString
Type: Boolean
If set to true the collation of the field is ignored for the comparison causing a binary string comparison.
roundDoubles
Type: Boolean
If set to true very small differences in floating point values will be ignored.
treatEmptyStringAsNull
Type: Boolean
If set to true nvarchar and varchar field containing null, will be treated as string.Empty.

Return Value

true if the values are identical.

Remarks

If the values are of different types, or if one value is null, returns false. If you are using GetSummaryRow(Int32) to retrieve the data, you must use the FieldDifferent(Int32) method to determine whether the values are the same in a Row .

See Also

Store Class
IdenticalValues Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Store Properties

[image] [image]

SQL Data Compare API 12.0.40
Store Properties
Store Class See Also

The Store type exposes the following properties.

Properties

Name | Description
Compressed | True if the results store is using compressed temporary files, false otherwise.
Fields | The fields in the ResultsStore object.
IsDisposed | Returns a value indicating if this instance has been disposed. (Inherited from DisposableBase.)
RowCount | The number of rows in the ResultsStore.
Where | Contains the WHERE clause that was used to create the ResultsStore.

See Also

Store Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Compressed Property

[image]

SQL Data Compare API 12.0.40
Store..::.Compressed Property
Store Class See Also

True if the results store is using compressed temporary files, false otherwise.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Compressed As Boolean
C#
public bool Compressed { get; }
Visual C++
public:
property bool Compressed {
    bool get ();
}

See Also

Store Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Fields Property

[image]

SQL Data Compare API 12.0.40
Store..::.Fields Property
Store Class See Also

The fields in the ResultsStore object.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fields As FieldPairs
C#
public FieldPairs Fields { get; }
Visual C++
public:
property FieldPairs^ Fields {
    FieldPairs^ get ();
}

See Also

Store Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


RowCount Property

[image]

SQL Data Compare API 12.0.40
Store..::.RowCount Property
Store Class See Also

The number of rows in the ResultsStore.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowCount As Integer
C#
public int RowCount { get; }
Visual C++
public:
property int RowCount {
    int get ();
}

See Also

Store Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Where Property

[image]

SQL Data Compare API 12.0.40
Store..::.Where Property
Store Class See Also

Contains the WHERE clause that was used to create the ResultsStore.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Where As WhereClause
C#
public WhereClause Where { get; set; }
Visual C++
public:
property WhereClause^ Where {
    WhereClause^ get ();
    void set (WhereClause^ value);
}

See Also

Store Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Worked example

SQL Comparison SDK: SQL Data Compare API 11

Worked example

This worked example shows you how to create a command line program to compare and deploy the data in two databases, WidgetDev and WidgetLive.

You will see how to:

  1. Set up the databases.
  2. Set up the project.
  3. Create a database object.
  4. Compare the databases.
  5. Print the changes to be made.
  6. Get the deployment SQL.
  7. Run the SQL script.
  8. Dispose of the objects.

For detailed information about the API, see the Reference topics.

Set up the databases

  1. If they already exist, delete WidgetDev and WidgetLive from your SQL Server.
  2. Click here to open the SQL creation script for the databases, and then run the script in your SQL application.

Set up the project

  1. Create a new console application project ConsoleApplication1 using Visual Studio.
  2. Add references to RedGate.Shared.ComparisonInterfaces.dll, RedGate.SQLCompare.Engine.dll, RedGate.SQLDataCompare.Engine.dll, RedGate.Shared.Utils.dll and RedGate.Shared.SQL.dll

    By default you can find the assemblies in C:\Program Files (x86)\Red Gate\SQL Comparison SDK 11\Assemblies\SQL Compare.

  3. Create a file licenses.licx and add it to the project, then add the following lines to it:

    RedGate.SQLCompare.Engine.Database, RedGate.SQLCompare.Engine

    RedGate.SQLDataCompare.Engine.ComparisonSession, RedGate.SQLDataCompare.Engine

Create a database object

  1. Make sure the default module or class is importing or using the RedGate.SQLCompare.Engine, RedGate.SQLDataCompare.Engine, RedGate.Shared.ComparisonInterfaces, RedGate.Shared.Utils and RedGate.Shared.SQL assemblies.
  2. Alter the Main method to instantiate two Database classes and call RegisterForDataCompare on them, passing in the details of the SQL Servers and databases that you want to connect to.
[Visual Basic]
Imports RedGate.Shared.Utils
Imports RedGate.Shared.SQL
Imports RedGate.SQLCompare.Engine
Imports RedGate.SQLDataCompare.Engine

Imports RedGate.SQLDataCompare.Engine.ResultsStore

Module Module1

  Sub Main()
     Dim db1 As New Database
     Dim db2 As New Database

     db1.RegisterForDataCompare(New ConnectionProperties(".", "WidgetDev"))
     db2.RegisterForDataCompare(New ConnectionProperties(".", "WidgetLive"))
  End Sub

End Module

[C#]
using System;
using RedGate.Shared.Utils;
using RedGate.Shared.SQL
using RedGate.SQLCompare.Engine;
using RedGate.SQLDataCompare.Engine;
using RedGate.SQLDataCompare.Engine.ResultsStore;

namespace ConsoleApplication1
{
  class Class1
     {
        [STAThread]
         static void Main(string[] args)
         {
            Database db1=new Database();
            Database db2=new Database();

            db1.RegisterForDataCompare(new ConnectionProperties(".", "WidgetDev"));
            db2.RegisterForDataCompare(new ConnectionProperties(".", "WidgetLive"));
         }
     }
}

Compare the databases

SQL Data Compare works best on databases that have identical structures. Because real databases often do not have identical structures, you can use SQL Data Compare to determine which tables are common to both databases, and which fields and indexes are common to these tables. SQL Data Compare provides the CreateMappings method for this.

When you have done this, create a ComparisonSession object and call CompareDatabases.

[Visual Basic]

    Dim mappings As New SchemaMappings
    mappings.CreateMappings(db1, db2)

    Dim session As New ComparisonSession()
    session.CompareDatabases(db1, db2, mappings)

[C#]

    SchemaMappings mappings = new SchemaMappings();
    mappings.CreateMappings(db1, db2);

    ComparisonSession session=new ComparisonSession();
    session.CompareDatabases(db1, db2, mappings);

Print the changes to be made

You can use the TableDifferences property to view summary information about the data differences between the two databases. This collection contains a number of TableDifference objects, indexed by fully-qualified table name. Each of these objects has a property ResultsStore that is a pointer to a ResultsStore.Store object. This object contains a list of the records that are identical, different, or present in one database but not the other.

You must use the OrdinalInResults1 and OrdinalInResults2 properties of a FieldPair class to retrieve the data from the Values property of a ResultsStore.Row.

  • If the ResultsStore represents identical records, or records that exist in only one database, the OrdinalInResults1 and OrdinalInResults2 are the same and indicate the position of the data for the field in the ResultsStore.
  • If the ResultsStore represents different records and the field is part of the unique index being used for the comparison, OrdinalInResults1 and OrdinalInResults2 are the same and indicate the position of the data.
  • If the ResultsStore represents different records and the field is not part of the unique index, OrdinalInResults1 and OrdinalInResults2 indicate the position of the data in the first database and second database respectively.

For example, if you are comparing two tables with the following structures:

*RecordID, FirstName, LastName

where * indicates a unique index, the ResultsStore representing identical records, or records present in only one database, will have the following structure:

RecordID, FirstName, LastName

and the OrdinalInResults1 and OrdinalInResults2 properties will have the following values in the Fields collection:

RecordID : 0
FirstName : 1
LastName : 2

If, however, the ResultsStore represents different records, it will have the following structure:

RecordID, FirstName, FirstName, LastName, LastName

The FirstName and LastName fields appear twice because they contain data from the two databases. The OrdinalInResults1 and OrdinalInResults2 properties on the Fields collection will have the following values:

RecordID : 0,0
FirstName : 1,2
LastName : 3,4

[Visual Basic]
    Dim mapping As TableMapping

    For Each mapping In mappings.TableMappings
      Dim table As ViewTableSuperClass = mapping.Obj1
      Dim difference As TableDifference = session.TableDifferences(table.FullyQualifiedName)

      ' Any tables that couldn't be compared we don't output the results
      If difference Is Nothing Then
         Continue For
      End If

      Dim row As Row
      For Each row In difference.ResultsStore  'loop through all the rows
         If (row.Type <> row.RowType.Same) Then 'go through the non same records
            Dim field As FieldPair
            Dim i As Int32 = 0
            Console.WriteLine("{0} Row {1} type {2}", table.FullyQualifiedName, row.Index, row.Type.ToString())
            For Each field In difference.ResultsStore.Fields
               'work out where about in the results the field data is stored
               'if we were comparing identical records, or records present in one
               'database but not the other then we would not need to
               'use the OrdinalInResults1 and OrdinalInResults2 properties
               'but just OrdinalInResults
               Dim field1 As Int32 = field.OrdinalInResults1
               Dim field2 As Int32 = field.OrdinalInResults2

               If (field1 <> field2) Then
                  'get the values
                  Dim value1 As Object = row.Values(field1)
                  Dim value2 As Object = row.Values(field2)
                  If (value1 Is Nothing) Then
                      value1 = "NULL"
                  End If
                  If (value2 Is Nothing) Then
                      value2 = "NULL"
                  End If
                  If row.FieldDifferent(i) Then
                     Console.WriteLine("{0}:{1} <> {2}", field.Field(False).Name, value1.ToString(), value2.ToString())
                  Else
                     Console.WriteLine("{0}:{1} == {2}", field.Field(False).Name, value1.ToString(), value2.ToString())
                  End If
               Else
                  'this is part of the unique index we are comparing on
                  Dim value As Object = row.Values(field1)
                  Console.WriteLine("*{0}:{1}", field.Field(False).Name, value.ToString())
               End If
                  i += 1
            Next
         End If
      Next
    Next

[C#]
    foreach (TableMapping mapping in mappings.TableMappings)
    {
      TableDifference difference=session.TableDifferences[mapping.Obj1.FullyQualifiedName];
      //display the different records

      // Any tables that couldn't be compared we don't output the results
      if (difference == null)
         continue;

      //loop through all the rows
      foreach(Row row in difference.ResultsStore)
      {
         //go through the non same records
         if (row.Type != Row.RowType.Same)
         {
            Console.WriteLine("{0} Row {1} type {2}", mapping.Obj1.FullyQualifiedName, row.Index, row.Type.ToString());
            int i=0;
            foreach (FieldPair field in difference.ResultsStore.Fields)
            {
               int field1=field.OrdinalInResults1;
               int field2=field.OrdinalInResults2;

               if (field1 != field2)
               {
                  //get the values
                  object value1=row.Values[field1];
                  object value2=row.Values[field2];
                  if (value1 == null)
                      value1="NULL";
                  if (value2 == null)
                      value2="NULL";
                  Console.WriteLine("{0}\t{1}\t{2}\t{3}",field.Field(false).Name, value1.ToString(),row.FieldDifferent(i)?"<>":"==",  value2.ToString());
                }
                else
                {
                   //this is part of the unique index we are comparing on
                   object value=row.Values[field1];
                   Console.WriteLine("*{0}\t{1}",field.Field(false).Name, value.ToString());
                }
                i++;
             }
          }
       }
    }

Get the deployment SQL

  1. Ensure the Selected property is set to true only on the TableDifference objects that you want to deploy.

    In this worked example, we will deploy all changes.

  2. Call GetMigrationSQL to get an ExecutionBlock containing the deployment SQL.
[Visual Basic]
    Dim provider as New SQLProvider
    'we want to run the SQL on WidgetLive so pass in true as the second parameter
    Dim block As ExecutionBlock = provider.GetMigrationSQL(session, True)
    Console.WriteLine("Migration SQL:")
    Console.WriteLine(block.GetString())

[C#]
    SqlProvider provider = New SqlProvider();
    //we want to run the SQL on WidgetLive so pass in true as the second parameter
    ExecutionBlock block=provider.GetMigrationSQL(session, true);
    Console.WriteLine("Migration SQL:");
    Console.WriteLine(block.GetString());

Run the SQL script

Instantiate a BlockExecutor object and call the ExecuteBlock method to run the SQL script. Ensure you run it on the correct database.

[Visual Basic]
    Dim executor As BlockExecutor = New BlockExecutor
    executor.ExecuteBlock(block, ".", "WidgetLive")

[C#]
    BlockExecutor executor = new BlockExecutor();
    executor.ExecuteBlock(block, ".", "WidgetLive");

Dispose of the objects

SQL Data Compare makes extensive use of temporary files. To ensure that these files are deleted you must dispose of the objects you have used.

[Visual Basic]
    session.Dispose()
    block.Dispose()
    db1.Dispose()
    db2.Dispose()

[C#]
    session.Dispose();
    block.Dispose();
    db1.Dispose();
    db2.Dispose();

See also

Comparing and deploying data using the API | Distributing your applications | Frequently asked questions for the SQL Data Compare API


Breaking changes in SQL Comparison SDK 10.5

SQL Comparison SDK: SQL Data Compare 11

Breaking changes in SQL Comparison SDK 10.5

Version 10.5 of the SQL Comparison SDK includes changes that might break your existing projects that use the SQL Compare, SQL Data Compare, or SQL Packager APIs.

To fix your projects, you might need to do one or more of the following:

  1. Use the new Options class
  2. Add new references
  3. Update uses of DifferenceType
  4. Distribute new assemblies

Use the new Options class

In previous versions of the SQL Comparison SDK, comparison options were specified as a bit flags enum. For example:

[C#]

Options.Default | Options.DropAndCreateInsteadOfAlter

In version 10.5, options are specified using the methods in the Options class. For example:

[C#]

Options.Default.Plus(Options.DropAndCreateInsteadOfAlter)

or

[C#]

Options.Default.Except(Options.IgnoreFileGroups, Options.IgnoreComments)

Add new references

With version 10.5, projects must reference RedGate.Shared.ComparisonInterfaces.dll.

Projects using the SQL Data Compare API must now also reference RedGate.SQLCompare.Engine.dll.

Update uses of DifferenceType

In version 10.5, the DifferenceType enum has moved from RedGate.SQLCompare.Engine to RedGate.Shared.ComparisonInterfaces.

You need to update any files that use DifferenceType:

  1. Add using RedGate.Shared.ComparisonInterfaces to the list of using statements at the top of your files.
  2. Replace all uses of RedGate.SQLCompare.Engine.DifferenceType with RedGate.Shared.ComparisonInterfaces.DifferenceType.

Distribute new assemblies

When you distribute your application, you now need to include the following assemblies:

  • RedGate.Shared.ComparisonInterfaces.dll
  • System.Threading.dll
  • RedGate.Migrations.Core.dll
  • Newtonsoft.Json.dll (distributed under the MIT license)
  • System.Data.SqlLocalDb.dll (distributed under the Apache license)

For more information, see Distributing your applications.


Comparing and deploying data using the API

SQL Comparison SDK: SQL Data Compare API 11

Comparing and deploying data using the API

To automate the comparison and deployment of database data, you use the SQL Data Compare API. You must reference the following assemblies from your Visual Studio .NET project:

  • RedGate.Shared.ComparisonInterfaces.dll
  • RedGate.SQL.Shared.Utils
  • RedGate.Shared.SQL
  • RedGate.SQLCompare.Engine
  • RedGate.SQLDataCompare.Engine
  • RedGate.SQLCompare.BackupReader (when comparing to backups)

You will need to have a number of files in the same directory as the program:

  • RedGate.SQLCompare.Rewriter.dll
  • RedGate.SQLCompare.ASTParser.dll

For comparing to backups you will also need:

  • RedGate.BackupReader.dll
  • System.Data.SQLite.dll

For comparing to SQL Backup files you will also need:

  • RedGate.BackupReader.SqbReader.dll
  • RedGate.BackupReader.CryptoHelper.dll
  • rglz.dll
  • zlib1.dll

To compare and deploy the data:

  1. Create a SqlCompare.Database object and call RegisterForDataCompare with a SqlCompare.ConnectionProperties object.
  2. Set up a SchemaMappings or TableMappings collection containing information about which tables, views, fields, and keys are to be used in the comparison.

    The easiest way to do this is to call CreateMappings on the SchemaMappings or TableMappings object.

  3. Create a ComparisonSession object and call CompareDatabases.
  4. Use the TableDifferences property to view the differences in data between the two databases.
  5. Create a SqlProvider object and call the GetMigrationSQL method to retrieve an ExecutionBlock object containing the deployment SQL code.
  6. To run the deployment script, create a BlockExecutor object and call ExecuteBlock, passing in the ExecutionBlock object.

    You can receive feedback events about the progress of the comparison and deployment by using the ICancellable interface.

  7. Dispose of the objects when you have finished using them.

For a detailed example, see Worked example.

See also

Getting started with the SQL Data Compare API | Distributing your applications


Distributing your applications

SQL Comparison SDK: SQL Data Compare API 11

Distributing your applications

To distribute your applications:

  1. Make sure you have a valid SQL Comparison SDK serial number.

    If you don't have a valid, activated serial number, the applications you distribute will display a trial expiry dialog box and will stop working when your trial expires.

  2. Add a licenses.licx file to your C# or Visual Basic .NET project in Visual Studio.

    If a licenses.licx file doesn't exist in your Visual Studio .NET project, you must create one with the following entries in it:

    RedGate.SQLCompare.Engine.Database, RedGate.SQLCompare.Engine

    RedGate.SQLDataCompare.Engine.ComparisonSession, RedGate.SQLDataCompare.Engine

  3. Compile your application.

    If you have a valid serial number and a valid licenses.licx file, your executable file will run SQL Data Compare without displaying the trial expiry dialog box.

  4. Distribute your application.

    You must distribute the following files with your application:

    • RedGate.Shared.ComparisonInterfaces.dll
    • RedGate.Shared.Utils.dll
    • RedGate.Shared.SQL.dll
    • RedGate.SQLCompare.Engine.dll
    • RedGate.SQLCompare.Rewriter.dll
    • RedGate.SQLCompare.ASTParser.dll
    • RedGate.SQLDataCompare.Engine.dll
    • System.Threading.dll
    • RedGate.Migrations.Core.dll
    • Newtonsoft.Json.dll (distributed under the MIT license)
    • System.Data.SqlLocalDb.dll (distributed under the Apache license)

    For comparing to backups, you must also distribute the following files:

    • RedGate.BackupReader.dll
    • RedGate.SQLCompare.BackupReader.dll
    • System.Data.SQLite.dll

    For comparing to SQL Backup files, you must also distribute the following files:

    • RedGate.BackupReader.SqbReader.dll
    • RedGate.BackupReader.CryptoHelper.dll
    • rglz.dll
    • zlib1.dll

Note that you aren't permitted to distribute any other Red Gate files. In particular, you must not distribute any .lic files.

See also

Getting started with the SQL Data Compare API | Frequently asked questions for the SQL Data Compare API


FAQs for the SQL Data Compare API

SQL Comparison SDK: SQL Data Compare API 11

Frequently asked questions

How do I change the comparison key?

If there is no primary key, unique index, or unique constraint, you can set a custom comparison key by adding FieldMappings objects to the MatchingMappings for a particular TableMapping. Call RefreshMappingStatus to confirm that SQL Data Compare can compare the tables.

For example, create a mapping for the WidgetPrices table, and then set WidgetID as the custom comparison key:

TableMapping tableMapping = (TableMapping)mappings.Join(db1.Tables["[dbo].[WidgetPrices]"], db2.Tables["[dbo].[WidgetPrices]"]);

tableMapping.MatchingMappings.Clear();
tableMapping.MatchingMappings.Add(tableMapping.FieldMappings["WidgetID"]);
tableMapping.RefreshMappingStatus();

To set a comparison key using columns from a particular index, call UseIndexForMapping

How do I exclude tables from the comparison?

To exclude a particular table, set the Include property for the TableMapping to false.

For example, to exclude the table WidgetPrices:

tableMapping["[dbo].[WidgetPrices]"].Include=false;

To exclude tables that begin with a particular string or that belong to particular schema (owner), you can loop through the tables and set the Include property as follows:

foreach (TableMapping m in tableMappings)
{
    if (m.Obj1.FullyQualifiedName.StartsWith("[dbo]"))
        m.Include=false;
}
m.RefreshMappingStatus();

How do I filter the rows that are compared?

You can filter the data that will be compared setting the Where property on a TableMapping object.

For example, to compare only rows where RecordID is greater than or equal to 2 in the Widgets table:

foreach (TableMapping mapping in mappings)
{
    if (mapping.Obj1.FullyQualifiedName=="[dbo].[Widgets]")
    {
        mapping.Include=true;
        mapping.Where = new WhereClause("RecordID>=2");
    }
    else
    {
    mapping.Include = false;
    }
}

If required, you can set a different WHERE clause for the two tables that you are comparing, using the Clause1 and Clause2 properties.

For example:

WhereClause w=new WhereClause();
w.Clause1="RecordID<2";
w.Clause2="RecordID>2"
tableMapping.Where=w;

How do I set the comparison options?

You specify the options on the SchemaMappings.Options property from the MappingOptions, ComparisonOptions, and SqlOptions enumerations.

MappingOptions are used for table and column mappings. The default options are as follows:

  • IgnoreCase
  • IgnoreSpaces
  • IncludeIdentities
  • IncludeTimestamps

ComparisonOptions are used for comparing the databases. There are no default options.

SqlOptions are used when you synchronize the databases. The default options are as follows:

  • DisableKeys
  • OutputCommentHeader
  • UseTransactions
  • OutputComments
  • ReseedIdentity

For example, to ignore trailing spaces when comparing strings, set the TrimTrailingSpaces option in ComparisonOptions:

tableMapping.FieldMappings.Options.ComparisonOptions = ComparisonOptions.TrimTrailingSpaces | ComparisonOptions.Default;

To set more than one option, logically OR them together; in Visual Basic, use Or and in C#, use the pipe character (|).

How can I choose individual records to synchronize?

Create a new SelectionDelegate and point it at a function that will return true or false, indicating whether the record is to be synchronized. This function will accept a SynchronizationRecord object as the only argument. Pass the SelectionDelegate as the second argument to the GetMigrationSQL method of the SqlProvider object.

Do I have to distribute my license file with my application?

No. A properly compiled SQL Data Compare API application will not request a serial number when it is distributed.

How do I install my application on the client?

Copy your application and the assemblies it references to the same folder (or the Global Assembly Cache - not recommended). No registration or registry entries are required unless specifically requested by your application.

See also

Getting started with the SQL Data Compare API

Introduction to the API reference

© 2012-2014 Red Gate Software Ltd. All rights reserved.


ObjectIncluded Method

[image]

SQL Data Compare API 12.0.40
OR<(Of <(T>)>)..::.ObjectIncluded Method
OR<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine.Filter
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ObjectIncluded ( _
    objectIn1 As T, _
    objectIn2 As T _
) As Nullable(Of Boolean)
C#
public virtual Nullable<bool> ObjectIncluded(
    T objectIn1,
    T objectIn2
)
Visual C++
public:
virtual Nullable<bool> ObjectIncluded(
    T objectIn1,
    T objectIn2
)

Parameters

objectIn1
Type: T
objectIn2
Type: T

See Also

OR<(Of <(T>)>) Class
RedGate.SQLCompare.Engine.Filter Namespace


Add Method

[image]

SQL Data Compare API 12.0.40
SerializableDatabaseObjectCollection<(Of <(T>)>)..::.Add Method
SerializableDatabaseObjectCollection<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Add ( _
    value As T _
)
C#
public virtual void Add(
    T value
)
Visual C++
public:
virtual void Add(
    T value
)

Parameters

value
Type: T

See Also

SerializableDatabaseObjectCollection<(Of <(T>)>) Class
RedGate.SQLCompare.Engine Namespace


ExecuteReader Method

[image] [image]

SQL Data Compare API 12.0.40
BackupCommand..::.ExecuteReader Method
BackupCommand Class See Also

Overload List

Name | Description
ExecuteReader()()() | (Inherited from BackupReaderCommandBase.)
ExecuteReader(CommandBehavior) | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)

See Also

BackupCommand Class
BackupCommand Members
RedGate.BackupReader Namespace


ExecuteReader Method

[image] [image]

SQL Data Compare API 12.0.40
LiveCommand..::.ExecuteReader Method
LiveCommand Class See Also

Overload List

Name | Description
ExecuteReader()()() | (Inherited from BackupReaderCommandBase.)
ExecuteReader(CommandBehavior) | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)

See Also

LiveCommand Class
LiveCommand Members
RedGate.BackupReader Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
AsymmetricKeys..::.Item Property
AsymmetricKeys Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

AsymmetricKeys Class
AsymmetricKeys Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
Certificates..::.Item Property
Certificates Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Certificates Class
Certificates Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
Contracts..::.Item Property
Contracts Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Contracts Class
Contracts Members
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
DatabaseObjectWithAuthorization..::.Equals Method
DatabaseObjectWithAuthorization Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares two database objects. (Inherited from ScriptableDatabaseObject.)

See Also

DatabaseObjectWithAuthorization Class
DatabaseObjectWithAuthorization Members
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
DatabaseObjectWithAuthorizationAndExtendedProperties..::.Equals Method
DatabaseObjectWithAuthorizationAndExtendedProperties Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares two database objects. (Inherited from ScriptableDatabaseObject.)

See Also

DatabaseObjectWithAuthorizationAndExtendedProperties Class
DatabaseObjectWithAuthorizationAndExtendedProperties Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
DdlTriggers..::.Item Property
DdlTriggers Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

DdlTriggers Class
DdlTriggers Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
Defaults..::.Item Property
Defaults Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Defaults Class
Defaults Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
EventNotifications..::.Item Property
EventNotifications Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

EventNotifications Class
EventNotifications Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
EventTypes..::.Item Property
EventTypes Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

EventTypes Class
EventTypes Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
FieldBindings..::.Item Property
FieldBindings Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

FieldBindings Class
FieldBindings Members
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
FieldMappingBestMatchMessage..::.Equals Method
FieldMappingBestMatchMessage Class See Also

Overload List

Name | Description
Equals(Object) | (Inherited from MessageBase.)
Equals(MessageBase) | (Inherited from MessageBase.)

See Also

FieldMappingBestMatchMessage Class
FieldMappingBestMatchMessage Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
Fields..::.Item Property
Fields Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from DatabaseObjectCollection<(Of <(T>)>).)

See Also

Fields Class
Fields Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
FullTextCatalogs..::.Item Property
FullTextCatalogs Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

FullTextCatalogs Class
FullTextCatalogs Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
FullTextStoplists..::.Item Property
FullTextStoplists Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

FullTextStoplists Class
FullTextStoplists Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
Functions..::.Item Property
Functions Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Functions Class
Functions Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
IndexFields..::.Item Property
IndexFields Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

IndexFields Class
IndexFields Members
RedGate.SQLCompare.Engine Namespace


GetEnumerator Method

[image] [image]

SQL Data Compare API 12.0.40
IReadOnlyKeyedDatabaseObjectCollectionWrapper..::.GetEnumerator Method
IReadOnlyKeyedDatabaseObjectCollectionWrapper Interface See Also

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( IDatabaseObject >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IReadOnlyKeyedDatabaseObjectCollectionWrapper Interface
IReadOnlyKeyedDatabaseObjectCollectionWrapper Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
Members..::.Item Property
Members Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

Members Class
Members Members
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
Message..::.Equals Method
Message Class See Also

Overload List

Name | Description
Equals(Object) | (Inherited from MessageBase.)
Equals(MessageBase) | (Inherited from MessageBase.)

See Also

Message Class
Message Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
MessageTypes..::.Item Property
MessageTypes Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

MessageTypes Class
MessageTypes Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
MessageUsages..::.Item Property
MessageUsages Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

MessageUsages Class
MessageUsages Members
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
MigScriptPlugMessageDecorator..::.Equals Method
MigScriptPlugMessageDecorator Class See Also

Overload List

Name | Description
Equals(Object) | (Inherited from MessageBase.)
Equals(MessageBase) | (Inherited from MessageBase.)

See Also

MigScriptPlugMessageDecorator Class
MigScriptPlugMessageDecorator Members
RedGate.SQLCompare.Engine Namespace


ComputeHash Method

[image] [image]

SQL Data Compare API 12.0.40
MD5CryptoServiceProvider..::.ComputeHash Method
MD5CryptoServiceProvider Class See Also

Overload List

Name | Description
ComputeHash(array<Byte>[]()[]) | (Inherited from MD5.)
ComputeHash(Stream) | (Inherited from MD5.)
ComputeHash(array<Byte>[]()[], Int32, Int32) | (Inherited from MD5.)

See Also

MD5CryptoServiceProvider Class
MD5CryptoServiceProvider Members
RedGate.SQLCompare.Engine.ObjectHasher Namespace


Dispose Method

[image] [image]

SQL Data Compare API 12.0.40
MD5CryptoServiceProvider..::.Dispose Method
MD5CryptoServiceProvider Class See Also

Overload List

Name | Description
Dispose()()() | (Inherited from MD5.)
Dispose(Boolean) | (Inherited from MD5.)

See Also

MD5CryptoServiceProvider Class
MD5CryptoServiceProvider Members
RedGate.SQLCompare.Engine.ObjectHasher Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
PartitionFunctions..::.Item Property
PartitionFunctions Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

PartitionFunctions Class
PartitionFunctions Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
PartitionSchemes..::.Item Property
PartitionSchemes Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

PartitionSchemes Class
PartitionSchemes Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
Queues..::.Item Property
Queues Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Queues Class
Queues Members
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
DatabaseProjectFile..::.Equals Method
DatabaseProjectFile Class See Also

Overload List

Name | Description
Equals(Object) | (Inherited from DataBaseProjectItem.)
Equals(DataBaseProjectItem) | (Inherited from DataBaseProjectItem.)

See Also

DatabaseProjectFile Class
DatabaseProjectFile Members
RedGate.SQLCompare.Engine.ReadFromFolder.DatabaseProject Namespace


Dispose Method

[image] [image]

SQL Data Compare API 12.0.40
StringWriterWithEncoding..::.Dispose Method
StringWriterWithEncoding Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the TextWriter object. (Inherited from TextWriter.)
Dispose(Boolean) | Releases the unmanaged resources used by the StringWriter and optionally releases the managed resources. (Inherited from StringWriter.)

See Also

StringWriterWithEncoding Class
StringWriterWithEncoding Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


MemberwiseClone Method

[image] [image]

SQL Data Compare API 12.0.40
StringWriterWithEncoding..::.MemberwiseClone Method
StringWriterWithEncoding Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

StringWriterWithEncoding Class
StringWriterWithEncoding Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Write Method

[image] [image]

SQL Data Compare API 12.0.40
StringWriterWithEncoding..::.Write Method
StringWriterWithEncoding Class See Also

Overload List

Name | Description
Write(Char) | Writes a character to this instance of the StringWriter. (Inherited from StringWriter.)
Write(String) | Writes a string to this instance of the StringWriter. (Inherited from StringWriter.)
Write(array<Char>[]()[]) | Writes a character array to the text stream. (Inherited from TextWriter.)
Write(Boolean) | Writes the text representation of a Boolean value to the text stream. (Inherited from TextWriter.)
Write(Int32) | Writes the text representation of a 4-byte signed integer to the text stream. (Inherited from TextWriter.)
Write(UInt32) | Writes the text representation of a 4-byte unsigned integer to the text stream. (Inherited from TextWriter.)
Write(Int64) | Writes the text representation of an 8-byte signed integer to the text stream. (Inherited from TextWriter.)
Write(UInt64) | Writes the text representation of an 8-byte unsigned integer to the text stream. (Inherited from TextWriter.)
Write(Single) | Writes the text representation of a 4-byte floating-point value to the text stream. (Inherited from TextWriter.)
Write(Double) | Writes the text representation of an 8-byte floating-point value to the text stream. (Inherited from TextWriter.)
Write(Decimal) | Writes the text representation of a decimal value followed by a line terminator to the text stream. (Inherited from TextWriter.)
Write(Object) | Writes the text representation of an object to the text stream by calling ToString on that object. (Inherited from TextWriter.)
Write(String, Object) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Write(String, array<Object>[]()[]) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Write(array<Char>[]()[], Int32, Int32) | Writes the specified region of a character array to this instance of the StringWriter. (Inherited from StringWriter.)
Write(String, Object, Object) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Write(String, Object, Object, Object) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)

See Also

StringWriterWithEncoding Class
StringWriterWithEncoding Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


WriteLine Method

[image] [image]

SQL Data Compare API 12.0.40
StringWriterWithEncoding..::.WriteLine Method
StringWriterWithEncoding Class See Also

Overload List

Name | Description
WriteLine()()() | Writes a line terminator to the text stream. (Inherited from TextWriter.)
WriteLine(Char) | Writes a character followed by a line terminator to the text stream. (Inherited from TextWriter.)
WriteLine(array<Char>[]()[]) | Writes an array of characters followed by a line terminator to the text stream. (Inherited from TextWriter.)
WriteLine(Boolean) | Writes the text representation of a Boolean followed by a line terminator to the text stream. (Inherited from TextWriter.)
WriteLine(Int32) | Writes the text representation of a 4-byte signed integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
WriteLine(UInt32) | Writes the text representation of a 4-byte unsigned integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
WriteLine(Int64) | Writes the text representation of an 8-byte signed integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
WriteLine(UInt64) | Writes the text representation of an 8-byte unsigned integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
WriteLine(Single) | Writes the text representation of a 4-byte floating-point value followed by a line terminator to the text stream. (Inherited from TextWriter.)
WriteLine(Double) | Writes the text representation of a 8-byte floating-point value followed by a line terminator to the text stream. (Inherited from TextWriter.)
WriteLine(Decimal) | Writes the text representation of a decimal value followed by a line terminator to the text stream. (Inherited from TextWriter.)
WriteLine(String) | Writes a string followed by a line terminator to the text stream. (Inherited from TextWriter.)
WriteLine(Object) | Writes the text representation of an object by calling ToString on this object, followed by a line terminator to the text stream. (Inherited from TextWriter.)
WriteLine(String, Object) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
WriteLine(String, array<Object>[]()[]) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
WriteLine(array<Char>[]()[], Int32, Int32) | Writes a subarray of characters followed by a line terminator to the text stream. (Inherited from TextWriter.)
WriteLine(String, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
WriteLine(String, Object, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)

See Also

StringWriterWithEncoding Class
StringWriterWithEncoding Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
Roles..::.Item Property
Roles Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Roles Class
Roles Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
Routes..::.Item Property
Routes Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Routes Class
Routes Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
Rules..::.Item Property
Rules Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Rules Class
Rules Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
SchemaBindings..::.Item Property
SchemaBindings Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

SchemaBindings Class
SchemaBindings Members
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
SchemaObjectWithAuthorization..::.Equals Method
SchemaObjectWithAuthorization Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares two database objects. (Inherited from ScriptableDatabaseObject.)

See Also

SchemaObjectWithAuthorization Class
SchemaObjectWithAuthorization Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
Schemas..::.Item Property
Schemas Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Schemas Class
Schemas Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
SearchPropertyLists..::.Item Property
SearchPropertyLists Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

SearchPropertyLists Class
SearchPropertyLists Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
Sequences..::.Item Property
Sequences Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Sequences Class
Sequences Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
SerializableCollection<(Of <(T>)>)..::.Item Property
SerializableCollection<(Of <(T>)>) Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

SerializableCollection<(Of <(T>)>) Class
SerializableCollection<(Of <(T>)>) Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
SerializableCollectionString..::.Item Property
SerializableCollectionString Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

SerializableCollectionString Class
SerializableCollectionString Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
ServiceBindings..::.Item Property
ServiceBindings Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

ServiceBindings Class
ServiceBindings Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
Services..::.Item Property
Services Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Services Class
Services Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
StoredProcedures..::.Item Property
StoredProcedures Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

StoredProcedures Class
StoredProcedures Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
SymmetricKeys..::.Item Property
SymmetricKeys Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

SymmetricKeys Class
SymmetricKeys Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
Synonyms..::.Item Property
Synonyms Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Synonyms Class
Synonyms Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
TableFields..::.Item Property
TableFields Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

TableFields Class
TableFields Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
Tables..::.Item Property
Tables Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from DatabaseObjectCollection<(Of <(T>)>).)

See Also

Tables Class
Tables Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
UDTBindings..::.Item Property
UDTBindings Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

UDTBindings Class
UDTBindings Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
UserDefinedTypes..::.Item Property
UserDefinedTypes Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

UserDefinedTypes Class
UserDefinedTypes Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
Views..::.Item Property
Views Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Views Class
Views Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
ViewsAndTables..::.Item Property
ViewsAndTables Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

ViewsAndTables Class
ViewsAndTables Members
RedGate.SQLCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 12.0.40
ViewTableSuperClass..::.Equals Method
ViewTableSuperClass Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares two database objects. (Inherited from ScriptableDatabaseObject.)

See Also

ViewTableSuperClass Class
ViewTableSuperClass Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
XmlSchemaCollections..::.Item Property
XmlSchemaCollections Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

XmlSchemaCollections Class
XmlSchemaCollections Members
RedGate.SQLCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
FieldMappings..::.Item Property
FieldMappings Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Gets the Mapping<(Of <(T>)>) at the specified index. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Item[([(String])]) | Gets the mapping of the specified object name, first attempting to match against objects in the first database, then matching against objects in the second database. Returns null if a mapping is not found. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

See Also

FieldMappings Class
FieldMappings Members
RedGate.SQLDataCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 12.0.40
TableMappings..::.Item Property
TableMappings Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Gets the Mapping<(Of <(T>)>) at the specified index. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)
Item[([(String])]) | Gets the mapping of the specified object name, first attempting to match against objects in the first database, then matching against objects in the second database. Returns null if a mapping is not found. (Inherited from Mappings<(Of <(TMapping, TMap, TContext>)>).)

See Also

TableMappings Class
TableMappings Members
RedGate.SQLDataCompare.Engine Namespace


Name Property

[image]

SQL Data Compare API 12.0.40
IField..::.Name Property
IField Interface See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Property Name As String
C#
string Name { get; set; }
Visual C++
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Implements

ITSqlObjectName()()()

See Also

IField Interface
RedGate.SQLCompare.Engine Namespace


Reference

SQL Comparison SDK: SQL Data Compare API 11

Introduction to the API reference

The SQL Data Compare API comprises the following assemblies:

  • RedGate.Shared.Utils is a library used by SQL Data Compare.
  • RedGate.SQLCompare.Engine is used by the SQL Data Compare API to retrieve the database schema.
  • RedGate.SQLDataCompare.Engine is used to automate the comparison and deployment of data.
  • RedGate.SQLCompare.BackupReader is used by the SQL Data Compare API to retrieve the database schema of a database backup (SQL Server native or SQL Backup v3 or later).

This Reference provides details of the classes, enumerations, interfaces, and delegates provided by these assemblies.

See also

Comparing and deploying data using the API