The SQL LocalDB instance 'RedGateTemp' does not exist
Published 10 March 2016
The following error text appears when running a DLM Automation PowerShell cmdlet or add-on:
Error message
... The SQL LocalDB instance 'RedGateTemp' does not exist ...
Cause
Your RedGateTemp instance may be corrupt. This is a known issue with LocalDB.
Fix
Delete the corrupt RedGateTemp instance from LocalDB. DLM Automation will recreate this when needed.
If you're using an external tool, such as TeamCity, you'll need to log on to the same account the service uses before deleting the RedGateTemp instance.
You can now delete the RedgateTemp instance:
- At the command prompt, enter
SqlLocalDB.exe info RedGateTemp
If an error message is displayed containingLocalDB instance "RedGateTemp" is corrupted!
, delete the instance. Enter
SqlLocalDB.exe delete RedGateTemp
Enter
SqlLocalDB.exe info
to display a list of instances. Check that the RedGateTemp instance no longer exists.
You can now try running the process again. The instance should be created automatically without corruption errors.
If you're still experiencing issues with LocalDB, contact Redgate Support.