Could not start LocalDB
Published 10 March 2016
The following error text appears when running a DLM Automation PowerShell cmdlet or add-on:
Error message
... Could not start LocalDB: Error occurred during LocalDB instance startup ...
Cause
There are two possible causes of this error:
- You don't have LocalDB installed.
- Your RedGateTemp instance is corrupt (this is a known issue with LocalDB).
Fix
To install LocalDB, do one of the following:
- Reinstall DLM Automation, and make sure your machine has an internet connection. LocalDB will be installed automatically.
- Install LocalDB manually. Install Local DB 32 bit or Local DB 64 bit depending on your machine.
If the error still persists, fix the corrupt RedGateTemp instance.