Flyway

International language support

Problem:

Non UTF-8 are not correctly displayed in the Flyway tools on Windows. Either Showing a Unicode replacement character (� ) or a question mark.


Cause:

The default Code Pages of the underlying command interfaces that the operating system provides haven't been configured to support the given character set(s).

Additionally it's possible for the code page to be correctly set, but the font is not able to support the selected code page.


Solutions:

The fastest resolution is to enable internal language support, in Windows this requires a restart.

Within the Windows Region settings

You will then be prompted to restart your machine.


Alternatively you could manually configure the required code pages and fonts to persist in your terminals via registry settings.

Please do not undertake modifying your core system files without understanding the risks that can pose to your environment.  

It's recommend to first manually test the outcome in the terminal to identify a viable permutation before attempting to redefine the defaults in the registry settings.


Didn't find what you were looking for?